A propos de ce document

Ce document a été construit automatiquement à partir de la documentation HTML disponible sur java.sun.com. Il est périodiquement remis à jour, lorsque de nouvelles versions des documentations originales deviennent disponibles. Pour télécharger librement et gratuitement ces mises à jour, mais aussi d''autres documents Java au format HTMLHelp ou WinHelp, visitez le site de Franck Allimant :

http://www.allimant.org/javadoc (en Français)

http://www.allimant.org/javadoc/indexe.html (en Anglais)

Bonne utilisation !

Contact

Les remarques et les suggestions sont les bienvenues. Merci de les faire parvenir à Franck Allimant.

Notes

La documentation HTML originale est disponible sur java.sun.com. Merci de la consulter si vous avez des incertitudes à propos les informations présentées dans ce document.

La version HTMLHelp de cette documentation diffère par quelques points de la version HTML, à cause de certaines limitations de HTMLHelp.

1. Applets Java

Les applets Java 1 fonctionnent correctement dans HTMLHelp, pourvu que les classes Java ne soient pas embarquées dans le fichier d'aide (chm) lui-même. Elles sont stockées dans le répertoire applets, qui se trouve au même endroit que le fichier d'aide. Ce répertoire n'est pas nécessaire au fonctionnement de l'aide : s'il est absent, les applets ne seront pas affichées.

Le plugin Java n'est pas supporté par HTMLHelp. Les applets nécessitant une machine virtuelle Java 2 ne peuvent pas être exécutées.

2. Fichiers nécessitant un plugin

Le support des plugins n'est pas complet dans HTMLHelp. En fonction de la configuration de votre machine, certains problèmes peuvent survenir lors de la visualisation de ces fichiers, en particulier les documents PDF.

3. Occurrences multiples d'un mot-clef de l'index

Si un mot clef de l'index pointe vers plusieurs documents, une page listant toutes les occurrences trouvées est affichée. Cette page fournit le titre des documents dans lequel le mot clef apparaît, et s'il s'agit d'une méthode, les paramètres de cette méthode. Ce mode d'affichage très détaillé a été préféré à la boîte de dialogue "Rubriques Trouvées" proposées en standard par HTMLHelp, pour permettre une navigation plus efficace et plus rapide dans un grand nombre de documents.

Merci à...

a.do Consulting, pour offrir gratuitement un parser HTML écrit en Java aussi compact et efficace.

Doug Kramer, de Sun, qui a autorisé la distribution des documentations Java pour WinHelp et HTMLHelp.

Distribution

Ce logiciel est gratuit. Il ne peut être diffusé sur Internet ou dupliqué que dans des buts non commerciaux, pour usage privé exclusivement. Toute distribution par CD-ROM est soumise à une autorisation préalable [contact].

Toutes les restrictions de distribution imposées par Sun à la documentation originale sont applicables au présent document. Consultez cette page (en anglais) pour en prendre connaissance.

Copyright © 1997-2004, Franck Allimant


About this document

This document is built from the HTML documentations available at java.sun.com. It is regularly updated, when new versions of original documentations become available. To download updates and many other WinHelp and HTMLHelp Java documentations for free, visit Franck Allimant's web site :

http://www.allimant.org/javadoc/indexe.html (in English)

http://www.allimant.org/javadoc (in French)

Contact

Comments and suggestions are welcome. Feel free to send them to Franck Allimant.

Notes

The original HTML documentation is available at java.sun.com. Please refer to this original documentation if you're not confident with the present document.

Due to some HTMLHelp limitations, there are some differences between this help file and the original HTML version of the documentation.

1. Java Applets

In most cases, Java 1 applets are running inside the HTMLHelp viewer, provided they're not embedded in the help (chm) file. They are stored in the applets directory, located at the same level as the help file. This folder is not required for browsing help, but if it is missing, applets will not be displayed.

Java 2 applets require the Java Plugin, which is not supported by the HTMLHelp viewer. These applets will not be displayed.

2. Documents that require a plugin

Plugins are not fully supported by the HTMLHelp viewer. Depending on the configuration of your machine, some problems may occur when viewing these files, for example PDF documents.

3. Multiple occurrences of an index keyword

If an index keyword points to more than one document, a page that lists all found occurrences is displayed. This page shows the title of every document in which the keyword appears, and if this keyword is a method, the parameters of this method. This detailed display has been preferred to the standard HTMLHelp "Topics Found" dialog box, to provide a faster and more efficient browsing of a large number of documents.

Thanks to...

a.do Consulting, for HtmlStreamTokenizer™, a compact, efficient and free HTML parser written in Java.

Doug Kramer at Sun, who authorized the distribution of this document.

Distribution

This software is free. Permission to use, copy, and distribute this software for non-commercial purposes via the Internet without fee is hereby granted. Permission is not granted for any distribution in the form of CD-ROM [contact].

Sun's documentation redistribution policy is applicable to this document. Please see this page for details.

Copyright © 1997-2004, Franck Allimant


Java 2 Platform Ent. Ed. v1.4

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


 All Classes
AccessLocalException
ActionType
ActivationDataFlavor
ActivationSpec
Address
AddressException
AddressStringTerm
AddressTerm
AndTerm
ApplicationServerInternalException
ArrayType
Association
AttachmentPart
Attribute
AttributeChangeNotification
AttributeChangeNotificationFilter
AttributeList
AttributeNotFoundException
AttributeValueExp
AuditableEvent
AuthenticationFailedException
Authenticator
BadAttributeValueExpException
BadBinaryOpValueExpException
BadStringOperationException
BeanNotFoundException
BigDecimalHolder
BigIntegerHolder
BodyContent
BodyPart
BodyTag
BodyTagSupport
BodyTerm
BooleanHolder
BooleanWrapperHolder
BootstrapContext
BoundaryStatistic
BoundedRangeStatistic
BulkResponse
BusinessLifeCycleManager
BusinessQueryManager
ByteArrayHolder
ByteHolder
ByteWrapperHolder
BytesMessage
CalendarHolder
Call
CapabilityProfile
ClassLoaderRepository
Classification
ClassificationScheme
ClientConfiguration
ClientExecuteException
CommException
CommandInfo
CommandMap
CommandObject
CommandType
ComparisonTerm
CompositeData
CompositeDataSupport
CompositeType
Concept
ConfigurationException
Connection
Connection
Connection
ConnectionAdapter
ConnectionConsumer
ConnectionEvent
ConnectionEvent
ConnectionEventListener
ConnectionFactory
ConnectionFactory
ConnectionFactory
ConnectionListener
ConnectionManager
ConnectionMetaData
ConnectionMetaData
ConnectionRequestInfo
ConnectionSpec
ContentDisposition
ContentType
Cookie
CountStatistic
CounterMonitor
CounterMonitorMBean
CreateException
DConfigBean
DConfigBeanRoot
DConfigBeanVersionType
DConfigBeanVersionUnsupportedException
DDBean
DDBeanRoot
DOMLocator
DOMResult
DOMSource
DataContentHandler
DataContentHandlerFactory
DataHandler
DataSource
DateTerm
DeclarativeQueryManager
DefaultLoaderRepository
DefaultLoaderRepository
DeleteException
DeliveryMode
DeployableObject
DeploymentConfiguration
DeploymentFactory
DeploymentFactoryManager
DeploymentManager
DeploymentManagerCreationException
DeploymentStatus
Descriptor
DescriptorAccess
DescriptorSupport
DeserializationContext
Deserializer
DeserializerFactory
Destination
Detail
DetailEntry
DissociatableManagedConnection
DocumentBuilder
DocumentBuilderFactory
DoubleHolder
DoubleWrapperHolder
DuplicateKeyException
DynamicAttributes
DynamicMBean
EISSystemException
EJBContext
EJBException
EJBHome
EJBLocalHome
EJBLocalObject
EJBMetaData
EJBMethodPermission
EJBObject
EJBRoleRefPermission
EJBStats
ELException
ELParseException
EmailAddress
EnterpriseBean
EntityBean
EntityBeanStats
EntityContext
ErrorData
ErrorListener
ExceptionListener
ExecutionContext
Expression
ExpressionEvaluator
ExtensibleObject
ExternalIdentifier
ExternalLink
ExtrinsicObject
FactoryConfigurationError
FederatedConnection
FetchProfile
FetchProfile.Item
FileDataSource
FileTypeMap
Filter
FilterChain
FilterConfig
FindException
FindQualifier
FinderException
FlagTerm
Flags
Flags.Flag
FloatHolder
FloatWrapperHolder
Folder
FolderAdapter
FolderClosedException
FolderEvent
FolderListener
FolderNotFoundException
FromStringTerm
FromTerm
FunctionInfo
FunctionMapper
GaugeMonitor
GaugeMonitorMBean
GenericCredential
GenericHandler
GenericServlet
Handle
HandleDelegate
Handler
HandlerChain
HandlerInfo
HandlerRegistry
Header
HeaderTerm
HeaderTokenizer
HeaderTokenizer.Token
HeuristicCommitException
HeuristicMixedException
HeuristicRollbackException
Holder
HomeHandle
HttpJspPage
HttpServlet
HttpServletRequest
HttpServletRequestWrapper
HttpServletResponse
HttpServletResponseWrapper
HttpSession
HttpSessionActivationListener
HttpSessionAttributeListener
HttpSessionBindingEvent
HttpSessionBindingListener
HttpSessionContext
HttpSessionEvent
HttpSessionListener
HttpUtils
IllegalStateException
IllegalStateException
IllegalWriteException
IndexedRecord
InstanceAlreadyExistsException
InstanceNotFoundException
IntHolder
IntegerComparisonTerm
IntegerWrapperHolder
Interaction
InteractionSpec
InternationalString
InternetAddress
InternetHeaders
IntrospectionException
InvalidApplicationException
InvalidAttributeValueException
InvalidClientIDException
InvalidDestinationException
InvalidKeyException
InvalidModuleException
InvalidOpenTypeException
InvalidPropertyException
InvalidRelationIdException
InvalidRelationServiceException
InvalidRelationTypeException
InvalidRequestException
InvalidRoleInfoException
InvalidRoleValueException
InvalidSelectorException
InvalidTargetObjectTypeException
InvalidTransactionException
IterationTag
J2eeApplicationObject
JAXRException
JAXRPCException
JAXRResponse
JCAConnectionPoolStats
JCAConnectionStats
JCAStats
JDBCConnectionPoolStats
JDBCConnectionStats
JDBCStats
JMException
JMRuntimeException
JMSConnectionStats
JMSConsumerStats
JMSEndpointStats
JMSException
JMSProducerStats
JMSSecurityException
JMSSessionStats
JMSStats
JTAStats
JVMStats
JavaMailStats
JspContext
JspEngineInfo
JspException
JspFactory
JspFragment
JspPage
JspTag
JspTagException
JspWriter
Key
KeyAlreadyExistsException
LazyAssociatableConnectionManager
LazyEnlistableConnectionManager
LazyEnlistableManagedConnection
LifeCycleManager
ListenerNotFoundException
ListenerRegistration
LocalTransaction
LocalTransaction
LocalTransactionException
LocalizedString
LongHolder
LongWrapperHolder
MBeanAttributeInfo
MBeanConstructorInfo
MBeanException
MBeanFeatureInfo
MBeanInfo
MBeanNotificationInfo
MBeanOperationInfo
MBeanParameterInfo
MBeanPermission
MBeanRegistration
MBeanRegistrationException
MBeanServer
MBeanServerBuilder
MBeanServerConnection
MBeanServerDelegate
MBeanServerDelegateMBean
MBeanServerFactory
MBeanServerInvocationHandler
MBeanServerNotification
MBeanServerNotificationFilter
MBeanServerPermission
MBeanTrustPermission
MLet
MLetMBean
MailDateFormat
MailEvent
MailcapCommandMap
MalformedObjectNameException
ManagedConnection
ManagedConnectionFactory
ManagedConnectionMetaData
Management
ManagementHome
MapMessage
MappedRecord
Message
Message
Message.RecipientType
MessageAware
MessageChangedEvent
MessageChangedListener
MessageConsumer
MessageContext
MessageContext
MessageCountAdapter
MessageCountEvent
MessageCountListener
MessageDrivenBean
MessageDrivenBeanStats
MessageDrivenContext
MessageEOFException
MessageEndpoint
MessageEndpointFactory
MessageFactory
MessageFormatException
MessageIDTerm
MessageListener
MessageListener
MessageNotReadableException
MessageNotWriteableException
MessageNumberTerm
MessageProducer
MessageRemovedException
MessagingException
MethodNotSupportedException
MimeBodyPart
MimeHeader
MimeHeaders
MimeMessage
MimeMessage.RecipientType
MimeMultipart
MimePart
MimePartDataSource
MimeType
MimeTypeParameterList
MimeTypeParseException
MimeUtility
MimetypesFileTypeMap
ModelMBean
ModelMBeanAttributeInfo
ModelMBeanConstructorInfo
ModelMBeanInfo
ModelMBeanInfoSupport
ModelMBeanNotificationBroadcaster
ModelMBeanNotificationInfo
ModelMBeanOperationInfo
ModuleType
Monitor
MonitorMBean
MonitorNotification
MonitorSettingException
Multipart
MultipartDataSource
Name
NamespaceConstants
NewsAddress
NoSuchEntityException
NoSuchObjectLocalException
NoSuchProviderException
Node
NotCompliantMBeanException
NotSupportedException
NotSupportedException
NotTerm
Notification
NotificationBroadcaster
NotificationBroadcasterSupport
NotificationEmitter
NotificationFilter
NotificationFilterSupport
NotificationListener
ObjectHolder
ObjectInstance
ObjectMessage
ObjectName
ObjectNotFoundException
OpenDataException
OpenMBeanAttributeInfo
OpenMBeanAttributeInfoSupport
OpenMBeanConstructorInfo
OpenMBeanConstructorInfoSupport
OpenMBeanInfo
OpenMBeanInfoSupport
OpenMBeanOperationInfo
OpenMBeanOperationInfoSupport
OpenMBeanParameterInfo
OpenMBeanParameterInfoSupport
OpenType
OperationUnsupportedException
OperationsException
OrTerm
Organization
OutputKeys
PageContext
PageData
ParameterList
ParameterMode
ParseException
ParserConfigurationException
Part
PasswordAuthentication
PasswordCredential
PersistentMBean
PersonName
PolicyConfiguration
PolicyConfigurationFactory
PolicyContext
PolicyContextException
PolicyContextHandler
PostalAddress
PrivateClassLoader
PrivateMLet
ProgressEvent
ProgressListener
ProgressObject
Provider
Provider.Type
QName
QNameHolder
Query
Query
QueryEval
QueryExp
QueryManager
Queue
QueueBrowser
QueueConnection
QueueConnectionFactory
QueueReceiver
QueueRequestor
QueueSender
QueueSession
RangeStatistic
ReadOnlyFolderException
ReceivedDateTerm
RecipientStringTerm
RecipientTerm
Record
RecordFactory
Referenceable
ReflectionException
RegistryEntry
RegistryException
RegistryObject
RegistryPackage
RegistryService
Relation
RelationException
RelationNotFoundException
RelationNotification
RelationService
RelationServiceMBean
RelationServiceNotRegisteredException
RelationSupport
RelationSupportMBean
RelationType
RelationTypeNotFoundException
RelationTypeSupport
RemoveException
RequestDispatcher
RequiredModelMBean
ResourceAdapter
ResourceAdapterAssociation
ResourceAdapterInternalException
ResourceAdapterMetaData
ResourceAllocationException
ResourceAllocationException
ResourceException
ResourceWarning
Result
ResultSet
ResultSetInfo
Role
RoleInfo
RoleInfoNotFoundException
RoleList
RoleNotFoundException
RoleResult
RoleStatus
RoleUnresolved
RoleUnresolvedList
RollbackException
RuntimeErrorException
RuntimeMBeanException
RuntimeOperationsException
SAXParser
SAXParserFactory
SAXResult
SAXSource
SAXTransformerFactory
SOAPBody
SOAPBodyElement
SOAPConnection
SOAPConnectionFactory
SOAPConstants
SOAPElement
SOAPElementFactory
SOAPEnvelope
SOAPException
SOAPFactory
SOAPFault
SOAPFaultElement
SOAPFaultException
SOAPHeader
SOAPHeaderElement
SOAPMessage
SOAPMessageContext
SOAPPart
SaveException
SearchException
SearchTerm
SecurityException
SendFailedException
SentDateTerm
SerializationContext
Serializer
SerializerFactory
ServerSession
ServerSessionPool
Service
Service
Service
ServiceBinding
ServiceException
ServiceFactory
ServiceLifecycle
ServiceNotFoundException
Servlet
ServletConfig
ServletContext
ServletContextAttributeEvent
ServletContextAttributeListener
ServletContextEvent
ServletContextListener
ServletEndpointContext
ServletException
ServletInputStream
ServletOutputStream
ServletRequest
ServletRequestAttributeEvent
ServletRequestAttributeListener
ServletRequestEvent
ServletRequestListener
ServletRequestWrapper
ServletResponse
ServletResponseWrapper
ServletStats
Session
Session
SessionBean
SessionBeanStats
SessionContext
SessionSynchronization
SharedInputStream
SharingViolationException
ShortHolder
ShortWrapperHolder
SimpleTag
SimpleTagSupport
SimpleType
SingleThreadModel
SizeTerm
SkipPageException
Slot
Source
SourceLocator
SpecificationLink
StandardMBean
StateType
StatefulSessionBeanStats
StatelessSessionBeanStats
Statistic
Stats
Status
Store
StoreClosedException
StoreEvent
StoreListener
StreamMessage
StreamResult
StreamSource
Streamable
StringHolder
StringMonitor
StringMonitorMBean
StringTerm
StringValueExp
Stub
SubjectTerm
Synchronization
SystemException
TabularData
TabularDataSupport
TabularType
Tag
TagAdapter
TagAttributeInfo
TagData
TagExtraInfo
TagFileInfo
TagInfo
TagLibraryInfo
TagLibraryValidator
TagSupport
TagVariableInfo
Target
TargetException
TargetModuleID
TelephoneNumber
Templates
TemplatesHandler
TemporaryQueue
TemporaryTopic
Text
TextMessage
TimeStatistic
TimedObject
Timer
Timer
TimerAlarmClockNotification
TimerHandle
TimerMBean
TimerNotification
TimerService
Topic
TopicConnection
TopicConnectionFactory
TopicPublisher
TopicRequestor
TopicSession
TopicSubscriber
Transaction
TransactionInProgressException
TransactionManager
TransactionRequiredException
TransactionRequiredLocalException
TransactionRolledBackException
TransactionRolledbackException
TransactionRolledbackLocalException
Transformer
TransformerConfigurationException
TransformerException
TransformerFactory
TransformerFactoryConfigurationError
TransformerHandler
Transport
TransportAdapter
TransportEvent
TransportListener
TryCatchFinally
TypeMapping
TypeMappingRegistry
UIDFolder
UIDFolder.FetchProfileItem
URIResolver
URIValidator
URLDataSource
URLName
URLStats
UnavailableException
UnavailableException
UnexpectedObjectException
UnsupportedCapabilityException
UnsupportedDataTypeException
User
UserTransaction
ValidatingManagedConnectionFactory
ValidationMessage
ValueExp
VariableInfo
VariableResolver
Versionable
WebResourcePermission
WebRoleRefPermission
WebUserDataPermission
Work
WorkAdapter
WorkCompletedException
WorkEvent
WorkException
WorkListener
WorkManager
WorkRejectedException
XAConnection
XAConnectionFactory
XAException
XAQueueConnection
XAQueueConnectionFactory
XAQueueSession
XAResource
XASession
XATerminator
XATopicConnection
XATopicConnectionFactory
XATopicSession
XMLParseException
XMLType
Xid
XpathEvent
XpathListener


API Help

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Exceptions
  • Errors

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Constant Field Values

Contents
  • javax.jms.*
  • javax.mail.*
  • javax.management.*
  • javax.resource.*
  • javax.servlet.*
  • javax.transaction.*
  • javax.xml.*
javax.jms.*

javax.jms.DeliveryMode
public static final int | NON_PERSISTENT | 1
public static final int | PERSISTENT | 2

javax.jms.Message
public static final int | DEFAULT_DELIVERY_MODE | 2
public static final int | DEFAULT_PRIORITY | 4
public static final long | DEFAULT_TIME_TO_LIVE | 0l

javax.jms.Session
public static final int | AUTO_ACKNOWLEDGE | 1
public static final int | CLIENT_ACKNOWLEDGE | 2
public static final int | DUPS_OK_ACKNOWLEDGE | 3
public static final int | SESSION_TRANSACTED | 0

javax.mail.*

javax.mail.Folder
public static final int | HOLDS_FOLDERS | 2
public static final int | HOLDS_MESSAGES | 1
public static final int | READ_ONLY | 1
public static final int | READ_WRITE | 2

javax.mail.Part
public static final String | ATTACHMENT | "attachment"
public static final String | INLINE | "inline"

javax.mail.UIDFolder
public static final long LASTUID -1l

javax.mail.event.ConnectionEvent
public static final int | CLOSED | 3
public static final int | DISCONNECTED | 2
public static final int | OPENED | 1

javax.mail.event.FolderEvent
public static final int | CREATED | 1
public static final int | DELETED | 2
public static final int | RENAMED | 3

javax.mail.event.MessageChangedEvent
public static final int | ENVELOPE_CHANGED | 2
public static final int | FLAGS_CHANGED | 1

javax.mail.event.MessageCountEvent
public static final int | ADDED | 1
public static final int | REMOVED | 2

javax.mail.event.StoreEvent
public static final int | ALERT | 1
public static final int | NOTICE | 2

javax.mail.event.TransportEvent
public static final int | MESSAGE_DELIVERED | 1
public static final int | MESSAGE_NOT_DELIVERED | 2
public static final int | MESSAGE_PARTIALLY_DELIVERED | 3

javax.mail.internet.HeaderTokenizer
public static final String | MIME | "()@,;:\\\"\t []/?="
public static final String | RFC822 | "()@,;:\\\"\t .[]"

javax.mail.internet.HeaderTokenizer.Token
public static final int | ATOM | -1
public static final int | COMMENT | -3
public static final int | EOF | -4
public static final int | QUOTEDSTRING | -2

javax.mail.internet.MimeUtility
public static final int ALL -1

javax.mail.search.ComparisonTerm
public static final int | EQ | 3
public static final int | GE | 6
public static final int | GT | 5
public static final int | LE | 1
public static final int | LT | 2
public static final int | NE | 4

javax.management.*

javax.management.MBeanOperationInfo
public static final int | ACTION | 1
public static final int | ACTION_INFO | 2
public static final int | INFO | 0
public static final int | UNKNOWN | 3

javax.management.MBeanServerNotification
public static final String | REGISTRATION_NOTIFICATION | "JMX.mbean.registered"
public static final String | UNREGISTRATION_NOTIFICATION | "JMX.mbean.unregistered"

javax.management.Query
public static final int | DIV | 3
public static final int | EQ | 4
public static final int | GE | 2
public static final int | GT | 0
public static final int | LE | 3
public static final int | LT | 1
public static final int | MINUS | 1
public static final int | PLUS | 0
public static final int | TIMES | 2

javax.management.monitor.Monitor
protected static final int | capacityIncrement | 16
protected static final int | OBSERVED_ATTRIBUTE_ERROR_NOTIFIED | 2
protected static final int | OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED | 4
protected static final int | OBSERVED_OBJECT_ERROR_NOTIFIED | 1
protected static final int | RESET_FLAGS_ALREADY_NOTIFIED | 0
protected static final int | RUNTIME_ERROR_NOTIFIED | 8

javax.management.relation.RelationNotification
public static final String | RELATION_BASIC_CREATION | "jmx.relation.creation.basic"
public static final String | RELATION_BASIC_REMOVAL | "jmx.relation.removal.basic"
public static final String | RELATION_BASIC_UPDATE | "jmx.relation.update.basic"
public static final String | RELATION_MBEAN_CREATION | "jmx.relation.creation.mbean"
public static final String | RELATION_MBEAN_REMOVAL | "jmx.relation.removal.mbean"
public static final String | RELATION_MBEAN_UPDATE | "jmx.relation.update.mbean"

javax.management.relation.RoleStatus
public static final int | LESS_THAN_MIN_ROLE_DEGREE | 4
public static final int | MORE_THAN_MAX_ROLE_DEGREE | 5
public static final int | NO_ROLE_WITH_NAME | 1
public static final int | REF_MBEAN_NOT_REGISTERED | 7
public static final int | REF_MBEAN_OF_INCORRECT_CLASS | 6
public static final int | ROLE_NOT_READABLE | 2
public static final int | ROLE_NOT_WRITABLE | 3

javax.management.timer.Timer
public static final long | ONE_DAY | 86400000l
public static final long | ONE_HOUR | 3600000l
public static final long | ONE_MINUTE | 60000l
public static final long | ONE_SECOND | 1000l
public static final long | ONE_WEEK | 604800000l

javax.resource.*

javax.resource.cci.InteractionSpec
public static final int | SYNC_RECEIVE | 2
public static final int | SYNC_SEND | 0
public static final int | SYNC_SEND_RECEIVE | 1

javax.resource.spi.ConnectionEvent
public static final int | CONNECTION_CLOSED | 1
public static final int | CONNECTION_ERROR_OCCURRED | 5
public static final int | LOCAL_TRANSACTION_COMMITTED | 3
public static final int | LOCAL_TRANSACTION_ROLLEDBACK | 4
public static final int | LOCAL_TRANSACTION_STARTED | 2

javax.resource.spi.work.WorkEvent
public static final int | WORK_ACCEPTED | 1
public static final int | WORK_COMPLETED | 4
public static final int | WORK_REJECTED | 2
public static final int | WORK_STARTED | 3

javax.resource.spi.work.WorkException
public static final String | INTERNAL | "-1"
public static final String | START_TIMED_OUT | "1"
public static final String | TX_CONCURRENT_WORK_DISALLOWED | "2"
public static final String | TX_RECREATE_FAILED | "3"
public static final String | UNDEFINED | "0"

javax.resource.spi.work.WorkManager
public static final long | IMMEDIATE | 0l
public static final long | INDEFINITE | 9223372036854775807l
public static final long | UNKNOWN | -1l

javax.servlet.*

javax.servlet.http.HttpServletRequest
public static final String | BASIC_AUTH | "BASIC"
public static final String | CLIENT_CERT_AUTH | "CLIENT_CERT"
public static final String | DIGEST_AUTH | "DIGEST"
public static final String | FORM_AUTH | "FORM"

javax.servlet.http.HttpServletResponse
public static final int | SC_ACCEPTED | 202
public static final int | SC_BAD_GATEWAY | 502
public static final int | SC_BAD_REQUEST | 400
public static final int | SC_CONFLICT | 409
public static final int | SC_CONTINUE | 100
public static final int | SC_CREATED | 201
public static final int | SC_EXPECTATION_FAILED | 417
public static final int | SC_FORBIDDEN | 403
public static final int | SC_FOUND | 302
public static final int | SC_GATEWAY_TIMEOUT | 504
public static final int | SC_GONE | 410
public static final int | SC_HTTP_VERSION_NOT_SUPPORTED | 505
public static final int | SC_INTERNAL_SERVER_ERROR | 500
public static final int | SC_LENGTH_REQUIRED | 411
public static final int | SC_METHOD_NOT_ALLOWED | 405
public static final int | SC_MOVED_PERMANENTLY | 301
public static final int | SC_MOVED_TEMPORARILY | 302
public static final int | SC_MULTIPLE_CHOICES | 300
public static final int | SC_NO_CONTENT | 204
public static final int | SC_NON_AUTHORITATIVE_INFORMATION | 203
public static final int | SC_NOT_ACCEPTABLE | 406
public static final int | SC_NOT_FOUND | 404
public static final int | SC_NOT_IMPLEMENTED | 501
public static final int | SC_NOT_MODIFIED | 304
public static final int | SC_OK | 200
public static final int | SC_PARTIAL_CONTENT | 206
public static final int | SC_PAYMENT_REQUIRED | 402
public static final int | SC_PRECONDITION_FAILED | 412
public static final int | SC_PROXY_AUTHENTICATION_REQUIRED | 407
public static final int | SC_REQUEST_ENTITY_TOO_LARGE | 413
public static final int | SC_REQUEST_TIMEOUT | 408
public static final int | SC_REQUEST_URI_TOO_LONG | 414
public static final int | SC_REQUESTED_RANGE_NOT_SATISFIABLE | 416
public static final int | SC_RESET_CONTENT | 205
public static final int | SC_SEE_OTHER | 303
public static final int | SC_SERVICE_UNAVAILABLE | 503
public static final int | SC_SWITCHING_PROTOCOLS | 101
public static final int | SC_TEMPORARY_REDIRECT | 307
public static final int | SC_UNAUTHORIZED | 401
public static final int | SC_UNSUPPORTED_MEDIA_TYPE | 415
public static final int | SC_USE_PROXY | 305

javax.servlet.jsp.JspWriter
public static final int | DEFAULT_BUFFER | -1
public static final int | NO_BUFFER | 0
public static final int | UNBOUNDED_BUFFER | -2

javax.servlet.jsp.PageContext
public static final String | APPLICATION | "javax.servlet.jsp.jspApplication"
public static final int | APPLICATION_SCOPE | 4
public static final String | CONFIG | "javax.servlet.jsp.jspConfig"
public static final String | EXCEPTION | "javax.servlet.jsp.jspException"
public static final String | OUT | "javax.servlet.jsp.jspOut"
public static final String | PAGE | "javax.servlet.jsp.jspPage"
public static final int | PAGE_SCOPE | 1
public static final String | PAGECONTEXT | "javax.servlet.jsp.jspPageContext"
public static final String | REQUEST | "javax.servlet.jsp.jspRequest"
public static final int | REQUEST_SCOPE | 2
public static final String | RESPONSE | "javax.servlet.jsp.jspResponse"
public static final String | SESSION | "javax.servlet.jsp.jspSession"
public static final int | SESSION_SCOPE | 3

javax.servlet.jsp.tagext.BodyTag
public static final int | EVAL_BODY_BUFFERED | 2
public static final int | EVAL_BODY_TAG | 2

javax.servlet.jsp.tagext.IterationTag
public static final int EVAL_BODY_AGAIN 2

javax.servlet.jsp.tagext.Tag
public static final int | EVAL_BODY_INCLUDE | 1
public static final int | EVAL_PAGE | 6
public static final int | SKIP_BODY | 0
public static final int | SKIP_PAGE | 5

javax.servlet.jsp.tagext.TagAttributeInfo
public static final String ID "id"

javax.servlet.jsp.tagext.TagInfo
public static final String | BODY_CONTENT_EMPTY | "EMPTY"
public static final String | BODY_CONTENT_JSP | "JSP"
public static final String | BODY_CONTENT_SCRIPTLESS | "SCRIPTLESS"
public static final String | BODY_CONTENT_TAG_DEPENDENT | "TAGDEPENDENT"

javax.servlet.jsp.tagext.VariableInfo
public static final int | AT_BEGIN | 1
public static final int | AT_END | 2
public static final int | NESTED | 0

javax.transaction.*

javax.transaction.Status
public static final int | STATUS_ACTIVE | 0
public static final int | STATUS_COMMITTED | 3
public static final int | STATUS_COMMITTING | 8
public static final int | STATUS_MARKED_ROLLBACK | 1
public static final int | STATUS_NO_TRANSACTION | 6
public static final int | STATUS_PREPARED | 2
public static final int | STATUS_PREPARING | 7
public static final int | STATUS_ROLLEDBACK | 4
public static final int | STATUS_ROLLING_BACK | 9
public static final int | STATUS_UNKNOWN | 5

javax.transaction.xa.XAException
public static final int | XA_HEURCOM | 7
public static final int | XA_HEURHAZ | 8
public static final int | XA_HEURMIX | 5
public static final int | XA_HEURRB | 6
public static final int | XA_NOMIGRATE | 9
public static final int | XA_RBBASE | 100
public static final int | XA_RBCOMMFAIL | 101
public static final int | XA_RBDEADLOCK | 102
public static final int | XA_RBEND | 107
public static final int | XA_RBINTEGRITY | 103
public static final int | XA_RBOTHER | 104
public static final int | XA_RBPROTO | 105
public static final int | XA_RBROLLBACK | 100
public static final int | XA_RBTIMEOUT | 106
public static final int | XA_RBTRANSIENT | 107
public static final int | XA_RDONLY | 3
public static final int | XA_RETRY | 4
public static final int | XAER_ASYNC | -2
public static final int | XAER_DUPID | -8
public static final int | XAER_INVAL | -5
public static final int | XAER_NOTA | -4
public static final int | XAER_OUTSIDE | -9
public static final int | XAER_PROTO | -6
public static final int | XAER_RMERR | -3
public static final int | XAER_RMFAIL | -7

javax.transaction.xa.XAResource
public static final int | TMENDRSCAN | 8388608
public static final int | TMFAIL | 536870912
public static final int | TMJOIN | 2097152
public static final int | TMNOFLAGS | 0
public static final int | TMONEPHASE | 1073741824
public static final int | TMRESUME | 134217728
public static final int | TMSTARTRSCAN | 16777216
public static final int | TMSUCCESS | 67108864
public static final int | TMSUSPEND | 33554432
public static final int | XA_OK | 0
public static final int | XA_RDONLY | 3

javax.transaction.xa.Xid
public static final int | MAXBQUALSIZE | 64
public static final int | MAXGTRIDSIZE | 64

javax.xml.*

javax.xml.registry.FindQualifier
public static final String | AND_ALL_KEYS | "andAllKeys"
public static final String | CASE_SENSITIVE_MATCH | "caseSensitiveMatch"
public static final String | COMBINE_CLASSIFICATIONS | "combineClassifications"
public static final String | EXACT_NAME_MATCH | "exactNameMatch"
public static final String | OR_ALL_KEYS | "orAllKeys"
public static final String | OR_LIKE_KEYS | "orLikeKeys"
public static final String | SERVICE_SUBSET | "serviceSubset"
public static final String | SORT_BY_DATE_ASC | "sortByDateAsc"
public static final String | SORT_BY_DATE_DESC | "sortByDateDesc"
public static final String | SORT_BY_NAME_ASC | "sortByNameAsc"
public static final String | SORT_BY_NAME_DESC | "sortByNameDesc"
public static final String | SOUNDEX | "soundex"

javax.xml.registry.JAXRResponse
public static final int | STATUS_FAILURE | 2
public static final int | STATUS_SUCCESS | 0
public static final int | STATUS_UNAVAILABLE | 3
public static final int | STATUS_WARNING | 1

javax.xml.registry.LifeCycleManager
public static final String | ASSOCIATION | "Association"
public static final String | AUDITABLE_EVENT | "AuditableEvent"
public static final String | CLASSIFICATION | "Classification"
public static final String | CLASSIFICATION_SCHEME | "ClassificationScheme"
public static final String | CONCEPT | "Concept"
public static final String | EMAIL_ADDRESS | "EmailAddress"
public static final String | EXTERNAL_IDENTIFIER | "ExternalIdentifier"
public static final String | EXTERNAL_LINK | "ExternalLink"
public static final String | EXTRINSIC_OBJECT | "ExtrinsicObject"
public static final String | INTERNATIONAL_STRING | "InternationalString"
public static final String | KEY | "Key"
public static final String | LOCALIZED_STRING | "LocalizedString"
public static final String | ORGANIZATION | "Organization"
public static final String | PERSON_NAME | "PersonName"
public static final String | POSTAL_ADDRESS | "PostalAddress"
public static final String | REGISTRY_ENTRY | "RegistryEntry"
public static final String | REGISTRY_PACKAGE | "RegistryPackage"
public static final String | SERVICE | "Service"
public static final String | SERVICE_BINDING | "ServiceBinding"
public static final String | SLOT | "Slot"
public static final String | SPECIFICATION_LINK | "SpecificationLink"
public static final String | TELEPHONE_NUMBER | "TelephoneNumber"
public static final String | USER | "User"
public static final String | VERSIONABLE | "Versionable"

javax.xml.registry.Query
public static final int | QUERY_TYPE_EBXML_FILTER_QUERY | 2
public static final int | QUERY_TYPE_SQL | 0
public static final int | QUERY_TYPE_XQUERY | 1

javax.xml.registry.infomodel.AuditableEvent
public static final int | EVENT_TYPE_CREATED | 0
public static final int | EVENT_TYPE_DELETED | 1
public static final int | EVENT_TYPE_DEPRECATED | 2
public static final int | EVENT_TYPE_UNDEPRECATED | 5
public static final int | EVENT_TYPE_UPDATED | 3
public static final int | EVENT_TYPE_VERSIONED | 4

javax.xml.registry.infomodel.ClassificationScheme
public static final int | VALUE_TYPE_EMBEDDED_PATH | 1
public static final int | VALUE_TYPE_NON_UNIQUE | 2
public static final int | VALUE_TYPE_UNIQUE | 0

javax.xml.registry.infomodel.LocalizedString
public static final String DEFAULT_CHARSET_NAME "UTF-8"

javax.xml.registry.infomodel.RegistryEntry
public static final int | STABILITY_DYNAMIC | 0
public static final int | STABILITY_DYNAMIC_COMPATIBLE | 1
public static final int | STABILITY_STATIC | 2
public static final int | STATUS_APPROVED | 1
public static final int | STATUS_DEPRECATED | 2
public static final int | STATUS_SUBMITTED | 0
public static final int | STATUS_WITHDRAWN | 3

javax.xml.registry.infomodel.Slot
public static final String | ADDRESS_LINES_SLOT | "addressLines"
public static final String | AUTHORIZED_NAME_SLOT | "authorizedName"
public static final String | OPERATOR_SLOT | "operator"
public static final String | SORT_CODE_SLOT | "sortCode"

javax.xml.rpc.Call
public static final String | ENCODINGSTYLE_URI_PROPERTY | "javax.xml.rpc.encodingstyle.namespace.uri"
public static final String | OPERATION_STYLE_PROPERTY | "javax.xml.rpc.soap.operation.style"
public static final String | PASSWORD_PROPERTY | "javax.xml.rpc.security.auth.password"
public static final String | SESSION_MAINTAIN_PROPERTY | "javax.xml.rpc.session.maintain"
public static final String | SOAPACTION_URI_PROPERTY | "javax.xml.rpc.soap.http.soapaction.uri"
public static final String | SOAPACTION_USE_PROPERTY | "javax.xml.rpc.soap.http.soapaction.use"
public static final String | USERNAME_PROPERTY | "javax.xml.rpc.security.auth.username"

javax.xml.rpc.NamespaceConstants
public static final String | NSPREFIX_SCHEMA_XSD | "xsd"
public static final String | NSPREFIX_SCHEMA_XSI | "xsi"
public static final String | NSPREFIX_SOAP_ENCODING | "soapenc"
public static final String | NSPREFIX_SOAP_ENVELOPE | "soapenv"
public static final String | NSURI_SCHEMA_XSD | "http://www.w3.org/2001/XMLSchema"
public static final String | NSURI_SCHEMA_XSI | "http://www.w3.org/2001/XMLSchema-instance"
public static final String | NSURI_SOAP_ENCODING | "http://schemas.xmlsoap.org/soap/encoding/"
public static final String | NSURI_SOAP_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
public static final String | NSURI_SOAP_NEXT_ACTOR | "http://schemas.xmlsoap.org/soap/actor/next"

javax.xml.rpc.ServiceFactory
public static final String SERVICEFACTORY_PROPERTY "javax.xml.rpc.ServiceFactory"

javax.xml.rpc.Stub
public static final String | ENDPOINT_ADDRESS_PROPERTY | "javax.xml.rpc.service.endpoint.address"
public static final String | PASSWORD_PROPERTY | "javax.xml.rpc.security.auth.password"
public static final String | SESSION_MAINTAIN_PROPERTY | "javax.xml.rpc.session.maintain"
public static final String | USERNAME_PROPERTY | "javax.xml.rpc.security.auth.username"

javax.xml.soap.SOAPConstants
public static final String | URI_NS_SOAP_ENCODING | "http://schemas.xmlsoap.org/soap/encoding/"
public static final String | URI_NS_SOAP_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
public static final String | URI_SOAP_ACTOR_NEXT | "http://schemas.xmlsoap.org/soap/actor/next"

javax.xml.soap.SOAPMessage
public static final String | CHARACTER_SET_ENCODING | "javax.xml.soap.character-set-encoding"
public static final String | WRITE_XML_DECLARATION | "javax.xml.soap.write-xml-declaration"

javax.xml.transform.OutputKeys
public static final String | CDATA_SECTION_ELEMENTS | "cdata-section-elements"
public static final String | DOCTYPE_PUBLIC | "doctype-public"
public static final String | DOCTYPE_SYSTEM | "doctype-system"
public static final String | ENCODING | "encoding"
public static final String | INDENT | "indent"
public static final String | MEDIA_TYPE | "media-type"
public static final String | METHOD | "method"
public static final String | OMIT_XML_DECLARATION | "omit-xml-declaration"
public static final String | STANDALONE | "standalone"
public static final String | VERSION | "version"

javax.xml.transform.Result
public static final String | PI_DISABLE_OUTPUT_ESCAPING | "javax.xml.transform.disable-output-escaping"
public static final String | PI_ENABLE_OUTPUT_ESCAPING | "javax.xml.transform.enable-output-escaping"

javax.xml.transform.dom.DOMResult
public static final String FEATURE "http://javax.xml.transform.dom.DOMResult/feature"

javax.xml.transform.dom.DOMSource
public static final String FEATURE "http://javax.xml.transform.dom.DOMSource/feature"

javax.xml.transform.sax.SAXResult
public static final String FEATURE "http://javax.xml.transform.sax.SAXResult/feature"

javax.xml.transform.sax.SAXSource
public static final String FEATURE "http://javax.xml.transform.sax.SAXSource/feature"

javax.xml.transform.sax.SAXTransformerFactory
public static final String | FEATURE | "http://javax.xml.transform.sax.SAXTransformerFactory/feature"
public static final String | FEATURE_XMLFILTER | "http://javax.xml.transform.sax.SAXTransformerFactory/feature/xmlfilter"

javax.xml.transform.stream.StreamResult
public static final String FEATURE "http://javax.xml.transform.stream.StreamResult/feature"

javax.xml.transform.stream.StreamSource
public static final String FEATURE "http://javax.xml.transform.stream.StreamSource/feature"

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Deprecated List

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Deprecated API

Deprecated Classes
javax.management.DefaultLoaderRepository
Use MBeanServer.getClassLoaderRepository()} instead.
javax.management.loading.DefaultLoaderRepository
Use MBeanServer.getClassLoaderRepository()} instead.
javax.servlet.http.HttpUtils
As of Java(tm) Servlet API 2.3. These methods were only useful with the default encoding and have been moved to the request interfaces.
javax.xml.soap.SOAPElementFactory
- Use javax.xml.soap.SOAPFactory for creating SOAPElements.
javax.management.timer.TimerAlarmClockNotification
This class is of no use to user code. It is retained purely for compatibility reasons.

Deprecated Interfaces
javax.resource.spi.security.GenericCredential
The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.
javax.servlet.http.HttpSessionContext
As of Java(tm) Servlet API 2.1 for security reasons, with no replacement. This interface will be removed in a future version of this API.
javax.servlet.SingleThreadModel
As of Java Servlet API 2.4, with no direct replacement.

Deprecated Fields
javax.management.monitor.Monitor.alreadyNotified
equivalent to Monitor.alreadyNotifieds[0].
javax.management.monitor.Monitor.dbgTag
No replacement.
javax.servlet.jsp.tagext.BodyTag.EVAL_BODY_TAG
As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.

Deprecated Methods
javax.xml.soap.SOAPElementFactory.create(Name)
Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
javax.xml.soap.SOAPElementFactory.create(String)
Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
javax.xml.soap.SOAPElementFactory.create(String, String, String)
Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
javax.management.MBeanServer.deserialize(ObjectName, byte[])
Use getClassLoaderFor to obtain the appropriate class loader for deserialization.
javax.management.MBeanServer.deserialize(String, byte[])
Use MBeanServer.getClassLoaderRepository() to obtain the class loader repository and use it to deserialize.
javax.management.MBeanServer.deserialize(String, ObjectName, byte[])
Use getClassLoader to obtain the class loader for deserialization.
javax.servlet.http.HttpServletResponse.encodeRedirectUrl(String)
As of version 2.1, use encodeRedirectURL(String url) instead
javax.servlet.http.HttpServletResponse.encodeUrl(String)
As of version 2.1, use encodeURL(String url) instead
javax.ejb.EJBContext.getCallerIdentity()
Use Principal getCallerPrincipal() instead.
javax.management.monitor.StringMonitor.getDerivedGauge()
As of JMX 1.2, replaced by StringMonitor.getDerivedGauge(ObjectName)
javax.management.monitor.StringMonitorMBean.getDerivedGauge()
As of JMX 1.2, replaced by StringMonitorMBean.getDerivedGauge(ObjectName)
javax.management.monitor.GaugeMonitor.getDerivedGauge()
As of JMX 1.2, replaced by GaugeMonitor.getDerivedGauge(ObjectName)
javax.management.monitor.GaugeMonitorMBean.getDerivedGauge()
As of JMX 1.2, replaced by GaugeMonitorMBean.getDerivedGauge(ObjectName)
javax.management.monitor.CounterMonitor.getDerivedGauge()
As of JMX 1.2, replaced by CounterMonitor.getDerivedGauge(ObjectName)
javax.management.monitor.CounterMonitorMBean.getDerivedGauge()
As of JMX 1.2, replaced by CounterMonitorMBean.getDerivedGauge(ObjectName)
javax.management.monitor.StringMonitor.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by StringMonitor.getDerivedGaugeTimeStamp(ObjectName)
javax.management.monitor.StringMonitorMBean.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
javax.management.monitor.GaugeMonitor.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName)
javax.management.monitor.GaugeMonitorMBean.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
javax.management.monitor.CounterMonitor.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by CounterMonitor.getDerivedGaugeTimeStamp(ObjectName)
javax.management.monitor.CounterMonitorMBean.getDerivedGaugeTimeStamp()
As of JMX 1.2, replaced by CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
javax.ejb.EJBContext.getEnvironment()
Use the JNDI naming context java:comp/env to access enterprise bean's environment.
javax.servlet.http.HttpSessionContext.getIds()
As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.
javax.resource.ResourceException.getLinkedException()
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..
javax.resource.cci.ResourceWarning.getLinkedWarning()
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
javax.enterprise.deploy.model.DeployableObject.getModuleDTDVersion()
As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
javax.enterprise.deploy.model.DDBeanRoot.getModuleDTDVersion()
As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
javax.management.monitor.Monitor.getObservedObject()
As of JMX 1.2, replaced by Monitor.getObservedObjects()
javax.management.monitor.MonitorMBean.getObservedObject()
As of JMX 1.2, replaced by MonitorMBean.getObservedObjects()
javax.servlet.ServletRequest.getRealPath(String)
As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.
javax.servlet.UnavailableException.getServlet()
As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.
javax.servlet.ServletContext.getServlet(String)
As of Java Servlet API 2.1, with no direct replacement.

This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.

javax.servlet.ServletContext.getServletNames()
As of Java Servlet API 2.1, with no replacement.

This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

javax.servlet.ServletContext.getServlets()
As of Java Servlet API 2.0, with no replacement.

This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

javax.servlet.http.HttpSessionContext.getSession(String)
As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.
javax.servlet.http.HttpSession.getSessionContext()
As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.
javax.management.monitor.CounterMonitor.getThreshold()
As of JMX 1.2, replaced by CounterMonitor.getThreshold(ObjectName)
javax.management.monitor.CounterMonitorMBean.getThreshold()
As of JMX 1.2, replaced by CounterMonitorMBean.getThreshold(ObjectName)
javax.servlet.http.HttpSession.getValue(String)
As of Version 2.2, this method is replaced by HttpSession.getAttribute(java.lang.String).
javax.servlet.http.HttpSession.getValueNames()
As of Version 2.2, this method is replaced by HttpSession.getAttributeNames()
javax.ejb.EJBContext.isCallerInRole(Identity)
Use boolean isCallerInRole(String roleName) instead.
javax.servlet.http.HttpServletRequest.isRequestedSessionIdFromUrl()
As of Version 2.1 of the Java Servlet API, use HttpServletRequest.isRequestedSessionIdFromURL() instead.
javax.servlet.ServletContext.log(Exception, String)
As of Java Servlet API 2.1, use ServletContext.log(String message, Throwable throwable) instead.

This method was originally defined to write an exception's stack trace and an explanatory error message to the servlet log file.

javax.servlet.http.HttpSession.putValue(String, Object)
As of Version 2.2, this method is replaced by HttpSession.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.http.HttpSession.removeValue(String)
As of Version 2.2, this method is replaced by HttpSession.removeAttribute(java.lang.String)
javax.resource.ResourceException.setLinkedException(Exception)
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
javax.resource.cci.ResourceWarning.setLinkedWarning(ResourceWarning)
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
javax.management.ValueExp.setMBeanServer(MBeanServer)
This method is not needed because a ValueExp can access the MBean server in which it is being evaluated by using QueryEval.getMBeanServer().
javax.management.monitor.Monitor.setObservedObject(ObjectName)
As of JMX 1.2, replaced by Monitor.addObservedObject(javax.management.ObjectName)
javax.management.monitor.MonitorMBean.setObservedObject(ObjectName)
As of JMX 1.2, replaced by MonitorMBean.addObservedObject(javax.management.ObjectName)
javax.servlet.http.HttpServletResponse.setStatus(int, String)
As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String). Sets the status code and message for this response.
javax.management.monitor.CounterMonitor.setThreshold(Number)
As of JMX 1.2, replaced by CounterMonitor.setInitThreshold(java.lang.Number)
javax.management.monitor.CounterMonitorMBean.setThreshold(Number)
As of JMX 1.2, replaced by CounterMonitorMBean.setInitThreshold(java.lang.Number)

Deprecated Constructors
javax.management.AttributeValueExp()
An instance created with this constructor cannot be used in a query.
javax.servlet.UnavailableException(int, Servlet, String)
As of Java Servlet API 2.2, use UnavailableException.UnavailableException(String, int) instead.
javax.servlet.UnavailableException(Servlet, String)
As of Java Servlet API 2.2, use UnavailableException.UnavailableException(String) instead.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For All Packages

Package Hierarchies:
javax.activation, javax.ejb, javax.ejb.spi, javax.enterprise.deploy.model, javax.enterprise.deploy.shared, javax.enterprise.deploy.shared.factories, javax.enterprise.deploy.spi, javax.enterprise.deploy.spi.exceptions, javax.enterprise.deploy.spi.factories, javax.enterprise.deploy.spi.status, javax.jms, javax.mail, javax.mail.event, javax.mail.internet, javax.mail.search, javax.management, javax.management.j2ee, javax.management.j2ee.statistics, javax.management.loading, javax.management.modelmbean, javax.management.monitor, javax.management.openmbean, javax.management.relation, javax.management.timer, javax.resource, javax.resource.cci, javax.resource.spi, javax.resource.spi.endpoint, javax.resource.spi.security, javax.resource.spi.work, javax.security.jacc, javax.servlet, javax.servlet.http, javax.servlet.jsp, javax.servlet.jsp.el, javax.servlet.jsp.tagext, javax.transaction, javax.transaction.xa, javax.xml.namespace, javax.xml.parsers, javax.xml.registry, javax.xml.registry.infomodel, javax.xml.rpc, javax.xml.rpc.encoding, javax.xml.rpc.handler, javax.xml.rpc.handler.soap, javax.xml.rpc.holders, javax.xml.rpc.server, javax.xml.rpc.soap, javax.xml.soap, javax.xml.transform, javax.xml.transform.dom, javax.xml.transform.sax, javax.xml.transform.stream

Class Hierarchy

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class javax.management.AttributeList
          • class javax.management.relation.RoleList
          • class javax.management.relation.RoleUnresolvedList
    • class javax.enterprise.deploy.shared.ActionType
    • class javax.mail.Address (implements java.io.Serializable)
      • class javax.mail.internet.InternetAddress (implements java.lang.Cloneable)
      • class javax.mail.internet.NewsAddress
    • class javax.xml.soap.AttachmentPart
    • class javax.management.Attribute (implements java.io.Serializable)
    • class javax.management.AttributeChangeNotificationFilter (implements javax.management.NotificationFilter, java.io.Serializable)
    • class javax.management.AttributeValueExp (implements javax.management.ValueExp)
    • class javax.mail.Authenticator
    • class javax.xml.rpc.holders.BigDecimalHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.BigIntegerHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.mail.BodyPart (implements javax.mail.Part)
      • class javax.mail.internet.MimeBodyPart (implements javax.mail.internet.MimePart)
    • class javax.xml.rpc.holders.BooleanHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.BooleanWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.ByteArrayHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.ByteHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.ByteWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.CalendarHolder (implements javax.xml.rpc.holders.Holder)
    • class java.lang.ClassLoader
      • class java.security.SecureClassLoader
        • class java.net.URLClassLoader
          • class javax.management.loading.MLet (implements java.io.Externalizable, javax.management.MBeanRegistration, javax.management.loading.MLetMBean)
            • class javax.management.loading.PrivateMLet (implements javax.management.loading.PrivateClassLoader)
    • class javax.activation.CommandInfo
    • class javax.activation.CommandMap
      • class javax.activation.MailcapCommandMap
    • class javax.enterprise.deploy.shared.CommandType
    • class javax.management.openmbean.CompositeDataSupport (implements javax.management.openmbean.CompositeData, java.io.Serializable)
    • class javax.mail.event.ConnectionAdapter (implements javax.mail.event.ConnectionListener)
    • class javax.xml.registry.ConnectionFactory
    • class javax.mail.internet.ContentDisposition
    • class javax.mail.internet.ContentType
    • class javax.servlet.http.Cookie (implements java.lang.Cloneable)
    • class java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
      • class javax.activation.ActivationDataFlavor
    • class javax.activation.DataHandler (implements java.awt.datatransfer.Transferable)
    • class javax.enterprise.deploy.shared.DConfigBeanVersionType
    • class javax.management.DefaultLoaderRepository
    • class javax.management.loading.DefaultLoaderRepository
    • class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
    • class javax.management.modelmbean.DescriptorSupport (implements javax.management.Descriptor)
    • class javax.xml.parsers.DocumentBuilder
    • class javax.xml.parsers.DocumentBuilderFactory
    • class javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
    • class javax.xml.transform.dom.DOMSource (implements javax.xml.transform.Source)
    • class javax.xml.rpc.holders.DoubleHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.DoubleWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.servlet.jsp.ErrorData
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.resource.spi.ConnectionEvent
      • class javax.servlet.http.HttpSessionEvent
        • class javax.servlet.http.HttpSessionBindingEvent
      • class javax.mail.event.MailEvent
        • class javax.mail.event.ConnectionEvent
        • class javax.mail.event.FolderEvent
        • class javax.mail.event.MessageChangedEvent
        • class javax.mail.event.MessageCountEvent
        • class javax.mail.event.StoreEvent
        • class javax.mail.event.TransportEvent
      • class javax.management.Notification
        • class javax.management.AttributeChangeNotification
        • class javax.management.MBeanServerNotification
        • class javax.management.monitor.MonitorNotification
        • class javax.management.relation.RelationNotification
        • class javax.management.timer.TimerAlarmClockNotification
        • class javax.management.timer.TimerNotification
      • class javax.enterprise.deploy.spi.status.ProgressEvent
      • class javax.servlet.ServletContextEvent
        • class javax.servlet.ServletContextAttributeEvent
      • class javax.servlet.ServletRequestEvent
        • class javax.servlet.ServletRequestAttributeEvent
      • class javax.resource.spi.work.WorkEvent
    • class javax.resource.spi.work.ExecutionContext
    • class javax.servlet.jsp.el.Expression
    • class javax.servlet.jsp.el.ExpressionEvaluator
    • class javax.mail.FetchProfile
    • class javax.mail.FetchProfile.Item
      • class javax.mail.UIDFolder.FetchProfileItem
    • class javax.activation.FileDataSource (implements javax.activation.DataSource)
    • class javax.activation.FileTypeMap
      • class javax.activation.MimetypesFileTypeMap
    • class javax.mail.Flags (implements java.lang.Cloneable, java.io.Serializable)
    • class javax.mail.Flags.Flag
    • class javax.xml.rpc.holders.FloatHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.FloatWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.mail.Folder
    • class javax.mail.event.FolderAdapter (implements javax.mail.event.FolderListener)
    • class java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • class java.text.DateFormat
        • class java.text.SimpleDateFormat
          • class javax.mail.internet.MailDateFormat
    • class javax.servlet.jsp.tagext.FunctionInfo
    • class javax.xml.rpc.handler.GenericHandler (implements javax.xml.rpc.handler.Handler)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
    • class javax.xml.rpc.handler.HandlerInfo (implements java.io.Serializable)
    • class javax.mail.Header
    • class javax.mail.internet.HeaderTokenizer
    • class javax.mail.internet.HeaderTokenizer.Token
    • class javax.servlet.http.HttpUtils
    • class java.io.InputStream
      • class javax.servlet.ServletInputStream
    • class javax.xml.rpc.holders.IntegerWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.mail.internet.InternetHeaders
    • class javax.xml.rpc.holders.IntHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.servlet.jsp.JspContext
      • class javax.servlet.jsp.PageContext
    • class javax.servlet.jsp.JspEngineInfo
    • class javax.servlet.jsp.JspFactory
    • class javax.servlet.jsp.tagext.JspFragment
    • class javax.xml.rpc.holders.LongHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.LongWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.management.MBeanFeatureInfo (implements java.io.Serializable)
      • class javax.management.MBeanAttributeInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.modelmbean.ModelMBeanAttributeInfo (implements java.lang.Cloneable, javax.management.DescriptorAccess)
        • class javax.management.openmbean.OpenMBeanAttributeInfoSupport (implements javax.management.openmbean.OpenMBeanAttributeInfo, java.io.Serializable)
      • class javax.management.MBeanConstructorInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.modelmbean.ModelMBeanConstructorInfo (implements java.lang.Cloneable, javax.management.DescriptorAccess)
        • class javax.management.openmbean.OpenMBeanConstructorInfoSupport (implements javax.management.openmbean.OpenMBeanConstructorInfo, java.io.Serializable)
      • class javax.management.MBeanNotificationInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.modelmbean.ModelMBeanNotificationInfo (implements java.lang.Cloneable, javax.management.DescriptorAccess)
      • class javax.management.MBeanOperationInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.modelmbean.ModelMBeanOperationInfo (implements javax.management.DescriptorAccess)
        • class javax.management.openmbean.OpenMBeanOperationInfoSupport (implements javax.management.openmbean.OpenMBeanOperationInfo, java.io.Serializable)
      • class javax.management.MBeanParameterInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.openmbean.OpenMBeanParameterInfoSupport (implements javax.management.openmbean.OpenMBeanParameterInfo, java.io.Serializable)
    • class javax.management.MBeanInfo (implements java.lang.Cloneable, java.io.Serializable)
      • class javax.management.modelmbean.ModelMBeanInfoSupport (implements javax.management.modelmbean.ModelMBeanInfo, java.io.Serializable)
      • class javax.management.openmbean.OpenMBeanInfoSupport (implements javax.management.openmbean.OpenMBeanInfo, java.io.Serializable)
    • class javax.management.MBeanServerBuilder
    • class javax.management.MBeanServerDelegate (implements javax.management.MBeanServerDelegateMBean, javax.management.NotificationEmitter)
    • class javax.management.MBeanServerFactory
    • class javax.management.MBeanServerInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • class javax.mail.Message (implements javax.mail.Part)
      • class javax.mail.internet.MimeMessage (implements javax.mail.internet.MimePart)
    • class javax.mail.Message.RecipientType (implements java.io.Serializable)
      • class javax.mail.internet.MimeMessage.RecipientType
    • class javax.mail.MessageContext
    • class javax.mail.event.MessageCountAdapter (implements javax.mail.event.MessageCountListener)
    • class javax.xml.soap.MessageFactory
    • class javax.xml.soap.MimeHeader
    • class javax.xml.soap.MimeHeaders
    • class javax.mail.internet.MimePartDataSource (implements javax.activation.DataSource, javax.mail.MessageAware)
    • class javax.activation.MimeType (implements java.io.Externalizable)
    • class javax.activation.MimeTypeParameterList
    • class javax.mail.internet.MimeUtility
    • class javax.enterprise.deploy.shared.ModuleType
    • class javax.mail.Multipart
      • class javax.mail.internet.MimeMultipart
    • class javax.xml.rpc.NamespaceConstants
    • class javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • class javax.management.monitor.Monitor (implements javax.management.MBeanRegistration, javax.management.monitor.MonitorMBean)
        • class javax.management.monitor.CounterMonitor (implements javax.management.monitor.CounterMonitorMBean)
        • class javax.management.monitor.GaugeMonitor (implements javax.management.monitor.GaugeMonitorMBean)
        • class javax.management.monitor.StringMonitor (implements javax.management.monitor.StringMonitorMBean)
      • class javax.management.relation.RelationService (implements javax.management.MBeanRegistration, javax.management.NotificationListener, javax.management.relation.RelationServiceMBean)
      • class javax.management.timer.Timer (implements javax.management.MBeanRegistration, javax.management.timer.TimerMBean)
    • class javax.management.NotificationFilterSupport (implements javax.management.NotificationFilter, java.io.Serializable)
      • class javax.management.relation.MBeanServerNotificationFilter
    • class javax.xml.rpc.holders.ObjectHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.management.ObjectInstance (implements java.io.Serializable)
    • class javax.management.ObjectName (implements javax.management.QueryExp, java.io.Serializable)
    • class javax.management.openmbean.OpenType (implements java.io.Serializable)
      • class javax.management.openmbean.ArrayType (implements java.io.Serializable)
      • class javax.management.openmbean.CompositeType (implements java.io.Serializable)
      • class javax.management.openmbean.SimpleType (implements java.io.Serializable)
      • class javax.management.openmbean.TabularType (implements java.io.Serializable)
    • class javax.xml.transform.OutputKeys
    • class java.io.OutputStream
      • class javax.servlet.ServletOutputStream
    • class javax.servlet.jsp.tagext.PageData
    • class javax.mail.internet.ParameterList
    • class javax.xml.rpc.ParameterMode
    • class javax.mail.PasswordAuthentication
    • class javax.resource.spi.security.PasswordCredential (implements java.io.Serializable)
    • class java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • class java.security.BasicPermission (implements java.io.Serializable)
        • class javax.management.MBeanServerPermission
        • class javax.management.MBeanTrustPermission
      • class javax.security.jacc.EJBMethodPermission (implements java.io.Serializable)
      • class javax.security.jacc.EJBRoleRefPermission (implements java.io.Serializable)
      • class javax.management.MBeanPermission
      • class javax.security.jacc.WebResourcePermission (implements java.io.Serializable)
      • class javax.security.jacc.WebRoleRefPermission (implements java.io.Serializable)
      • class javax.security.jacc.WebUserDataPermission (implements java.io.Serializable)
    • class javax.security.jacc.PolicyConfigurationFactory
    • class javax.security.jacc.PolicyContext
    • class javax.mail.Provider
    • class javax.mail.Provider.Type
    • class javax.xml.namespace.QName (implements java.io.Serializable)
    • class javax.xml.rpc.holders.QNameHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.management.Query
    • class javax.management.QueryEval (implements java.io.Serializable)
    • class javax.jms.QueueRequestor
    • class javax.management.relation.RelationSupport (implements javax.management.MBeanRegistration, javax.management.relation.RelationSupportMBean)
    • class javax.management.relation.RelationTypeSupport (implements javax.management.relation.RelationType)
    • class javax.management.modelmbean.RequiredModelMBean (implements javax.management.MBeanRegistration, javax.management.modelmbean.ModelMBean, javax.management.NotificationEmitter)
    • class javax.management.relation.Role (implements java.io.Serializable)
    • class javax.management.relation.RoleInfo (implements java.io.Serializable)
    • class javax.management.relation.RoleResult (implements java.io.Serializable)
    • class javax.management.relation.RoleStatus
    • class javax.management.relation.RoleUnresolved (implements java.io.Serializable)
    • class javax.xml.parsers.SAXParser
    • class javax.xml.parsers.SAXParserFactory
    • class javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
    • class javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
    • class javax.mail.search.SearchTerm (implements java.io.Serializable)
      • class javax.mail.search.AddressTerm
        • class javax.mail.search.FromTerm
        • class javax.mail.search.RecipientTerm
      • class javax.mail.search.AndTerm
      • class javax.mail.search.ComparisonTerm
        • class javax.mail.search.DateTerm
          • class javax.mail.search.ReceivedDateTerm
          • class javax.mail.search.SentDateTerm
        • class javax.mail.search.IntegerComparisonTerm
          • class javax.mail.search.MessageNumberTerm
          • class javax.mail.search.SizeTerm
      • class javax.mail.search.FlagTerm
      • class javax.mail.search.NotTerm
      • class javax.mail.search.OrTerm
      • class javax.mail.search.StringTerm
        • class javax.mail.search.AddressStringTerm
          • class javax.mail.search.FromStringTerm
          • class javax.mail.search.RecipientStringTerm
        • class javax.mail.search.BodyTerm
        • class javax.mail.search.HeaderTerm
        • class javax.mail.search.MessageIDTerm
        • class javax.mail.search.SubjectTerm
    • class javax.mail.Service
      • class javax.mail.Store
      • class javax.mail.Transport
    • class javax.xml.rpc.ServiceFactory
    • class javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • class javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
    • class javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • class javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
    • class javax.mail.Session
    • class javax.xml.rpc.holders.ShortHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.ShortWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.servlet.jsp.tagext.SimpleTagSupport (implements javax.servlet.jsp.tagext.SimpleTag)
    • class javax.xml.soap.SOAPConnection
    • class javax.xml.soap.SOAPConnectionFactory
    • class javax.xml.soap.SOAPElementFactory
    • class javax.xml.soap.SOAPFactory
    • class javax.xml.soap.SOAPMessage
    • class javax.xml.soap.SOAPPart (implements org.w3c.dom.Document)
    • class javax.management.StandardMBean (implements javax.management.DynamicMBean)
    • class javax.enterprise.deploy.shared.StateType
    • class javax.xml.transform.stream.StreamResult (implements javax.xml.transform.Result)
    • class javax.xml.transform.stream.StreamSource (implements javax.xml.transform.Source)
    • class javax.xml.rpc.holders.StringHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.management.StringValueExp (implements javax.management.ValueExp)
    • class javax.management.openmbean.TabularDataSupport (implements java.lang.Cloneable, java.util.Map, java.io.Serializable, javax.management.openmbean.TabularData)
    • class javax.servlet.jsp.tagext.TagAdapter (implements javax.servlet.jsp.tagext.Tag)
    • class javax.servlet.jsp.tagext.TagAttributeInfo
    • class javax.servlet.jsp.tagext.TagData (implements java.lang.Cloneable)
    • class javax.servlet.jsp.tagext.TagExtraInfo
    • class javax.servlet.jsp.tagext.TagFileInfo
    • class javax.servlet.jsp.tagext.TagInfo
    • class javax.servlet.jsp.tagext.TagLibraryInfo
    • class javax.servlet.jsp.tagext.TagLibraryValidator
    • class javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • class javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
    • class javax.servlet.jsp.tagext.TagVariableInfo
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Error
        • class javax.xml.parsers.FactoryConfigurationError
        • class javax.xml.transform.TransformerFactoryConfigurationError
      • class java.lang.Exception
        • class javax.management.BadAttributeValueExpException
        • class javax.management.BadBinaryOpValueExpException
        • class javax.management.BadStringOperationException
        • class javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
        • class javax.enterprise.deploy.spi.exceptions.ClientExecuteException
        • class javax.enterprise.deploy.spi.exceptions.ConfigurationException
        • class javax.ejb.CreateException
          • class javax.ejb.DuplicateKeyException
        • class javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
        • class javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
        • class javax.servlet.jsp.el.ELException
          • class javax.servlet.jsp.el.ELParseException
        • class javax.ejb.FinderException
          • class javax.ejb.ObjectNotFoundException
        • class javax.transaction.HeuristicCommitException
        • class javax.transaction.HeuristicMixedException
        • class javax.transaction.HeuristicRollbackException
        • class javax.management.InvalidApplicationException
        • class javax.enterprise.deploy.spi.exceptions.InvalidModuleException
        • class javax.management.modelmbean.InvalidTargetObjectTypeException
        • class java.io.IOException
          • class java.rmi.RemoteException
            • class javax.transaction.InvalidTransactionException
            • class javax.transaction.TransactionRequiredException
            • class javax.transaction.TransactionRolledbackException
          • class javax.activation.UnsupportedDataTypeException
        • class javax.xml.registry.JAXRException (implements javax.xml.registry.JAXRResponse)
          • class javax.xml.registry.InvalidRequestException
          • class javax.xml.registry.RegistryException
            • class javax.xml.registry.DeleteException
            • class javax.xml.registry.FindException
            • class javax.xml.registry.SaveException
          • class javax.xml.registry.UnexpectedObjectException
          • class javax.xml.registry.UnsupportedCapabilityException
        • class javax.management.JMException
          • class javax.management.MBeanException
            • class javax.management.MBeanRegistrationException
          • class javax.management.openmbean.OpenDataException (implements java.io.Serializable)
          • class javax.management.OperationsException
            • class javax.management.AttributeNotFoundException
            • class javax.management.InstanceAlreadyExistsException
            • class javax.management.InstanceNotFoundException
            • class javax.management.IntrospectionException
            • class javax.management.InvalidAttributeValueException
            • class javax.management.ListenerNotFoundException
            • class javax.management.MalformedObjectNameException
            • class javax.management.NotCompliantMBeanException
            • class javax.management.ServiceNotFoundException
          • class javax.management.ReflectionException
          • class javax.management.relation.RelationException
            • class javax.management.relation.InvalidRelationIdException
            • class javax.management.relation.InvalidRelationServiceException
            • class javax.management.relation.InvalidRelationTypeException
            • class javax.management.relation.InvalidRoleInfoException
            • class javax.management.relation.InvalidRoleValueException
            • class javax.management.relation.RelationNotFoundException
            • class javax.management.relation.RelationServiceNotRegisteredException
            • class javax.management.relation.RelationTypeNotFoundException
            • class javax.management.relation.RoleInfoNotFoundException
            • class javax.management.relation.RoleNotFoundException
        • class javax.jms.JMSException
          • class javax.jms.IllegalStateException
          • class javax.jms.InvalidClientIDException
          • class javax.jms.InvalidDestinationException
          • class javax.jms.InvalidSelectorException
          • class javax.jms.JMSSecurityException
          • class javax.jms.MessageEOFException
          • class javax.jms.MessageFormatException
          • class javax.jms.MessageNotReadableException
          • class javax.jms.MessageNotWriteableException
          • class javax.jms.ResourceAllocationException
          • class javax.jms.TransactionInProgressException
          • class javax.jms.TransactionRolledBackException
        • class javax.servlet.jsp.JspException
          • class javax.servlet.jsp.JspTagException
          • class javax.servlet.jsp.SkipPageException
        • class javax.mail.MessagingException
          • class javax.mail.AuthenticationFailedException
          • class javax.mail.FolderClosedException
          • class javax.mail.FolderNotFoundException
          • class javax.mail.IllegalWriteException
          • class javax.mail.MessageRemovedException
          • class javax.mail.MethodNotSupportedException
          • class javax.mail.NoSuchProviderException
          • class javax.mail.internet.ParseException
            • class javax.mail.internet.AddressException
          • class javax.mail.ReadOnlyFolderException
          • class javax.mail.search.SearchException
          • class javax.mail.SendFailedException
          • class javax.mail.StoreClosedException
        • class javax.activation.MimeTypeParseException
        • class javax.transaction.NotSupportedException
        • class javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException
        • class javax.xml.parsers.ParserConfigurationException
        • class javax.security.jacc.PolicyContextException
        • class javax.ejb.RemoveException
        • class javax.resource.ResourceException
          • class javax.resource.spi.ApplicationServerInternalException
          • class javax.resource.spi.CommException
          • class javax.resource.spi.EISSystemException
          • class javax.resource.spi.IllegalStateException
          • class javax.resource.spi.InvalidPropertyException
          • class javax.resource.spi.LocalTransactionException
          • class javax.resource.NotSupportedException
          • class javax.resource.spi.ResourceAdapterInternalException
          • class javax.resource.spi.ResourceAllocationException
          • class javax.resource.cci.ResourceWarning
          • class javax.resource.spi.SecurityException
          • class javax.resource.spi.SharingViolationException
          • class javax.resource.spi.UnavailableException
          • class javax.resource.spi.work.WorkException
            • class javax.resource.spi.work.WorkCompletedException
            • class javax.resource.spi.work.WorkRejectedException
        • class javax.transaction.RollbackException
        • class java.lang.RuntimeException
          • class javax.ejb.EJBException
            • class javax.ejb.AccessLocalException
            • class javax.ejb.NoSuchEntityException
            • class javax.ejb.NoSuchObjectLocalException
            • class javax.ejb.TransactionRequiredLocalException
            • class javax.ejb.TransactionRolledbackLocalException
          • class java.lang.IllegalArgumentException
            • class javax.management.openmbean.InvalidKeyException (implements java.io.Serializable)
            • class javax.management.openmbean.InvalidOpenTypeException (implements java.io.Serializable)
            • class javax.management.openmbean.KeyAlreadyExistsException (implements java.io.Serializable)
          • class javax.xml.rpc.JAXRPCException
          • class javax.management.JMRuntimeException
            • class javax.management.monitor.MonitorSettingException
            • class javax.management.RuntimeErrorException
            • class javax.management.RuntimeMBeanException
            • class javax.management.RuntimeOperationsException
          • class javax.xml.rpc.soap.SOAPFaultException
        • class javax.xml.rpc.ServiceException
        • class javax.servlet.ServletException
          • class javax.servlet.UnavailableException
        • class javax.xml.soap.SOAPException
        • class javax.transaction.SystemException
        • class javax.enterprise.deploy.spi.exceptions.TargetException
        • class javax.xml.transform.TransformerException
          • class javax.xml.transform.TransformerConfigurationException
        • class javax.transaction.xa.XAException
        • class javax.management.modelmbean.XMLParseException
    • class javax.jms.TopicRequestor
    • class javax.xml.transform.Transformer
    • class javax.xml.transform.TransformerFactory
      • class javax.xml.transform.sax.SAXTransformerFactory
    • class javax.mail.event.TransportAdapter (implements javax.mail.event.TransportListener)
    • class javax.activation.URLDataSource (implements javax.activation.DataSource)
    • class javax.mail.URLName
    • class javax.servlet.jsp.tagext.ValidationMessage
    • class javax.servlet.jsp.tagext.VariableInfo
    • class javax.resource.spi.work.WorkAdapter (implements javax.resource.spi.work.WorkListener)
    • class java.io.Writer
      • class javax.servlet.jsp.JspWriter
        • class javax.servlet.jsp.tagext.BodyContent
    • class javax.xml.rpc.encoding.XMLType
    • class javax.enterprise.deploy.model.XpathEvent

Interface Hierarchy

  • interface javax.resource.spi.BootstrapContext
  • interface javax.xml.rpc.Call
  • interface javax.xml.registry.CapabilityProfile
  • interface javax.management.loading.ClassLoaderRepository
  • interface java.lang.Cloneable
    • interface javax.management.Descriptor (also extends java.io.Serializable)
    • interface javax.resource.cci.Record (also extends java.io.Serializable)
      • interface javax.resource.cci.IndexedRecord (also extends java.util.List, java.io.Serializable)
      • interface javax.resource.cci.MappedRecord (also extends java.util.Map, java.io.Serializable)
      • interface javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
  • interface java.util.Collection
    • interface java.util.List
      • interface javax.xml.rpc.handler.HandlerChain
      • interface javax.resource.cci.IndexedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
  • interface javax.activation.CommandObject
  • interface javax.management.openmbean.CompositeData
  • interface javax.resource.cci.Connection
  • interface javax.xml.registry.Connection
    • interface javax.xml.registry.FederatedConnection
  • interface javax.jms.Connection
    • interface javax.jms.QueueConnection
      • interface javax.jms.XAQueueConnection (also extends javax.jms.XAConnection)
    • interface javax.jms.TopicConnection
      • interface javax.jms.XATopicConnection (also extends javax.jms.XAConnection)
    • interface javax.jms.XAConnection
      • interface javax.jms.XAQueueConnection (also extends javax.jms.QueueConnection)
      • interface javax.jms.XATopicConnection (also extends javax.jms.TopicConnection)
  • interface javax.jms.ConnectionConsumer
  • interface javax.jms.ConnectionFactory
    • interface javax.jms.QueueConnectionFactory
      • interface javax.jms.XAQueueConnectionFactory (also extends javax.jms.XAConnectionFactory)
    • interface javax.jms.TopicConnectionFactory
      • interface javax.jms.XATopicConnectionFactory (also extends javax.jms.XAConnectionFactory)
  • interface javax.resource.cci.ConnectionMetaData
  • interface javax.jms.ConnectionMetaData
  • interface javax.resource.spi.ConnectionRequestInfo
  • interface javax.resource.cci.ConnectionSpec
  • interface org.xml.sax.ContentHandler
    • interface javax.xml.transform.sax.TemplatesHandler
    • interface javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.DTDHandler, org.xml.sax.ext.LexicalHandler)
  • interface javax.activation.DataContentHandler
  • interface javax.activation.DataContentHandlerFactory
  • interface javax.activation.DataSource
    • interface javax.mail.MultipartDataSource
  • interface javax.enterprise.deploy.spi.DConfigBean
    • interface javax.enterprise.deploy.spi.DConfigBeanRoot
  • interface javax.enterprise.deploy.model.DDBean
    • interface javax.enterprise.deploy.model.DDBeanRoot
  • interface javax.jms.DeliveryMode
  • interface javax.enterprise.deploy.model.DeployableObject
    • interface javax.enterprise.deploy.model.J2eeApplicationObject
  • interface javax.enterprise.deploy.spi.DeploymentConfiguration
  • interface javax.enterprise.deploy.spi.factories.DeploymentFactory
  • interface javax.enterprise.deploy.spi.DeploymentManager
  • interface javax.enterprise.deploy.spi.status.DeploymentStatus
  • interface javax.management.DescriptorAccess
  • interface javax.xml.rpc.encoding.DeserializationContext
  • interface javax.jms.Destination
    • interface javax.jms.Queue
      • interface javax.jms.TemporaryQueue
    • interface javax.jms.Topic
      • interface javax.jms.TemporaryTopic
  • interface javax.resource.spi.DissociatableManagedConnection
  • interface org.xml.sax.DTDHandler
    • interface javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.ext.LexicalHandler)
  • interface javax.servlet.jsp.tagext.DynamicAttributes
  • interface javax.management.DynamicMBean
    • interface javax.management.modelmbean.ModelMBean (also extends javax.management.modelmbean.ModelMBeanNotificationBroadcaster, javax.management.PersistentMBean)
  • interface javax.ejb.EJBContext
    • interface javax.ejb.EntityContext
    • interface javax.ejb.MessageDrivenContext
    • interface javax.ejb.SessionContext
  • interface javax.ejb.EJBLocalHome
  • interface javax.ejb.EJBLocalObject
  • interface javax.ejb.EJBMetaData
  • interface javax.xml.registry.infomodel.EmailAddress
  • interface javax.xml.transform.ErrorListener
  • interface java.util.EventListener
    • interface javax.resource.spi.ConnectionEventListener
    • interface javax.mail.event.ConnectionListener
    • interface javax.mail.event.FolderListener
    • interface javax.servlet.http.HttpSessionActivationListener
    • interface javax.servlet.http.HttpSessionAttributeListener
    • interface javax.servlet.http.HttpSessionBindingListener
    • interface javax.servlet.http.HttpSessionListener
    • interface javax.mail.event.MessageChangedListener
    • interface javax.mail.event.MessageCountListener
    • interface javax.management.NotificationListener
    • interface javax.enterprise.deploy.spi.status.ProgressListener
    • interface javax.servlet.ServletContextAttributeListener
    • interface javax.servlet.ServletContextListener
    • interface javax.servlet.ServletRequestAttributeListener
    • interface javax.servlet.ServletRequestListener
    • interface javax.mail.event.StoreListener
    • interface javax.mail.event.TransportListener
    • interface javax.resource.spi.work.WorkListener
  • interface javax.jms.ExceptionListener
  • interface javax.xml.registry.infomodel.ExtensibleObject
    • interface javax.xml.registry.infomodel.PostalAddress
    • interface javax.xml.registry.infomodel.RegistryObject
      • interface javax.xml.registry.infomodel.Association
      • interface javax.xml.registry.infomodel.AuditableEvent
      • interface javax.xml.registry.infomodel.Classification
      • interface javax.xml.registry.infomodel.Concept
      • interface javax.xml.registry.infomodel.ExternalIdentifier
      • interface javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.URIValidator)
      • interface javax.xml.registry.infomodel.Organization
      • interface javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.Versionable)
        • interface javax.xml.registry.infomodel.ClassificationScheme
        • interface javax.xml.registry.infomodel.ExtrinsicObject
        • interface javax.xml.registry.infomodel.RegistryPackage
        • interface javax.xml.registry.infomodel.Service
      • interface javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.URIValidator)
      • interface javax.xml.registry.infomodel.SpecificationLink
      • interface javax.xml.registry.infomodel.User
  • interface javax.servlet.Filter
  • interface javax.servlet.FilterChain
  • interface javax.servlet.FilterConfig
  • interface javax.xml.registry.FindQualifier
  • interface javax.servlet.jsp.el.FunctionMapper
  • interface javax.resource.spi.security.GenericCredential
  • interface javax.ejb.spi.HandleDelegate
  • interface javax.xml.rpc.handler.Handler
  • interface javax.xml.rpc.holders.Holder
  • interface javax.servlet.http.HttpSession
  • interface javax.servlet.http.HttpSessionContext
  • interface javax.resource.cci.Interaction
  • interface javax.xml.registry.infomodel.InternationalString
  • interface javax.management.j2ee.statistics.JavaMailStats
  • interface javax.xml.registry.JAXRResponse
    • interface javax.xml.registry.BulkResponse
  • interface javax.servlet.jsp.tagext.JspTag
    • interface javax.servlet.jsp.tagext.SimpleTag
    • interface javax.servlet.jsp.tagext.Tag
      • interface javax.servlet.jsp.tagext.IterationTag
        • interface javax.servlet.jsp.tagext.BodyTag
  • interface javax.xml.registry.infomodel.Key
  • interface javax.resource.spi.LazyAssociatableConnectionManager
  • interface javax.resource.spi.LazyEnlistableConnectionManager
  • interface javax.resource.spi.LazyEnlistableManagedConnection
  • interface org.xml.sax.ext.LexicalHandler
    • interface javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.DTDHandler)
  • interface javax.xml.registry.LifeCycleManager
    • interface javax.xml.registry.BusinessLifeCycleManager
  • interface javax.xml.registry.infomodel.LocalizedString
  • interface javax.resource.cci.LocalTransaction
  • interface javax.resource.spi.LocalTransaction
  • interface javax.resource.spi.ManagedConnection
  • interface javax.resource.spi.ManagedConnectionMetaData
  • interface java.util.Map
    • interface javax.resource.cci.MappedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
  • interface javax.management.MBeanRegistration
  • interface javax.management.MBeanServerConnection
    • interface javax.management.MBeanServer
  • interface javax.management.MBeanServerDelegateMBean
  • interface javax.jms.Message
    • interface javax.jms.BytesMessage
    • interface javax.jms.MapMessage
    • interface javax.jms.ObjectMessage
    • interface javax.jms.StreamMessage
    • interface javax.jms.TextMessage
  • interface javax.mail.MessageAware
  • interface javax.jms.MessageConsumer
    • interface javax.jms.QueueReceiver
    • interface javax.jms.TopicSubscriber
  • interface javax.xml.rpc.handler.MessageContext
    • interface javax.xml.rpc.handler.soap.SOAPMessageContext
  • interface javax.resource.spi.endpoint.MessageEndpoint
  • interface javax.resource.spi.endpoint.MessageEndpointFactory
  • interface javax.resource.cci.MessageListener
  • interface javax.jms.MessageListener
  • interface javax.jms.MessageProducer
    • interface javax.jms.QueueSender
    • interface javax.jms.TopicPublisher
  • interface javax.management.loading.MLetMBean
  • interface javax.management.modelmbean.ModelMBeanInfo
  • interface javax.management.monitor.MonitorMBean
    • interface javax.management.monitor.CounterMonitorMBean
    • interface javax.management.monitor.GaugeMonitorMBean
    • interface javax.management.monitor.StringMonitorMBean
  • interface javax.xml.soap.Name
  • interface org.w3c.dom.Node
    • interface org.w3c.dom.CharacterData
      • interface org.w3c.dom.Text
        • interface javax.xml.soap.Text (also extends javax.xml.soap.Node)
    • interface org.w3c.dom.Element
      • interface javax.xml.soap.SOAPElement (also extends javax.xml.soap.Node)
        • interface javax.xml.soap.DetailEntry
        • interface javax.xml.soap.SOAPBody
        • interface javax.xml.soap.SOAPBodyElement
          • interface javax.xml.soap.SOAPFault
        • interface javax.xml.soap.SOAPEnvelope
        • interface javax.xml.soap.SOAPFaultElement
          • interface javax.xml.soap.Detail
        • interface javax.xml.soap.SOAPHeader
        • interface javax.xml.soap.SOAPHeaderElement
    • interface javax.xml.soap.Node
      • interface javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element)
        • interface javax.xml.soap.DetailEntry
        • interface javax.xml.soap.SOAPBody
        • interface javax.xml.soap.SOAPBodyElement
          • interface javax.xml.soap.SOAPFault
        • interface javax.xml.soap.SOAPEnvelope
        • interface javax.xml.soap.SOAPFaultElement
          • interface javax.xml.soap.Detail
        • interface javax.xml.soap.SOAPHeader
        • interface javax.xml.soap.SOAPHeaderElement
      • interface javax.xml.soap.Text (also extends org.w3c.dom.Text)
  • interface javax.management.NotificationBroadcaster
    • interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster
      • interface javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.PersistentMBean)
    • interface javax.management.NotificationEmitter
  • interface javax.management.openmbean.OpenMBeanConstructorInfo
  • interface javax.management.openmbean.OpenMBeanInfo
  • interface javax.management.openmbean.OpenMBeanOperationInfo
  • interface javax.management.openmbean.OpenMBeanParameterInfo
    • interface javax.management.openmbean.OpenMBeanAttributeInfo
  • interface javax.mail.Part
    • interface javax.mail.internet.MimePart
  • interface javax.management.PersistentMBean
    • interface javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.modelmbean.ModelMBeanNotificationBroadcaster)
  • interface javax.xml.registry.infomodel.PersonName
  • interface javax.security.jacc.PolicyConfiguration
  • interface javax.security.jacc.PolicyContextHandler
  • interface javax.management.loading.PrivateClassLoader
  • interface javax.enterprise.deploy.spi.status.ProgressObject
  • interface javax.xml.registry.Query
  • interface javax.xml.registry.QueryManager
    • interface javax.xml.registry.BusinessQueryManager
    • interface javax.xml.registry.DeclarativeQueryManager
  • interface javax.jms.QueueBrowser
  • interface javax.resource.cci.RecordFactory
  • interface javax.naming.Referenceable
    • interface javax.resource.Referenceable
      • interface javax.resource.cci.ConnectionFactory (also extends java.io.Serializable)
  • interface javax.xml.registry.RegistryService
  • interface javax.management.relation.Relation
    • interface javax.management.relation.RelationSupportMBean
  • interface javax.management.relation.RelationServiceMBean
  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
      • interface javax.management.j2ee.ManagementHome
    • interface javax.ejb.EJBObject
      • interface javax.management.j2ee.Management
  • interface javax.servlet.RequestDispatcher
  • interface javax.resource.spi.ResourceAdapter
  • interface javax.resource.spi.ResourceAdapterAssociation
    • interface javax.resource.spi.ActivationSpec
  • interface javax.resource.cci.ResourceAdapterMetaData
  • interface javax.xml.transform.Result
  • interface java.sql.ResultSet
    • interface javax.resource.cci.ResultSet (also extends javax.resource.cci.Record)
  • interface javax.resource.cci.ResultSetInfo
  • interface java.lang.Runnable
    • interface javax.jms.Session
      • interface javax.jms.QueueSession
      • interface javax.jms.TopicSession
      • interface javax.jms.XASession
        • interface javax.jms.XAQueueSession
        • interface javax.jms.XATopicSession
    • interface javax.resource.spi.work.Work
  • interface java.io.Serializable
    • interface javax.enterprise.deploy.spi.status.ClientConfiguration
    • interface javax.resource.cci.ConnectionFactory (also extends javax.resource.Referenceable)
    • interface javax.resource.spi.ConnectionManager
    • interface javax.management.Descriptor (also extends java.lang.Cloneable)
    • interface javax.xml.rpc.encoding.Deserializer
    • interface javax.xml.rpc.encoding.DeserializerFactory
    • interface javax.ejb.EnterpriseBean
      • interface javax.ejb.EntityBean
      • interface javax.ejb.MessageDrivenBean
      • interface javax.ejb.SessionBean
    • interface javax.ejb.Handle
    • interface javax.xml.rpc.handler.HandlerRegistry
    • interface javax.ejb.HomeHandle
    • interface javax.resource.cci.IndexedRecord (also extends java.util.List, javax.resource.cci.Record)
    • interface javax.resource.cci.InteractionSpec
    • interface javax.management.j2ee.ListenerRegistration
    • interface javax.resource.spi.ManagedConnectionFactory
    • interface javax.resource.cci.MappedRecord (also extends java.util.Map, javax.resource.cci.Record)
    • interface javax.management.NotificationFilter
    • interface javax.management.QueryExp
    • interface javax.resource.cci.Record (also extends java.lang.Cloneable)
      • interface javax.resource.cci.IndexedRecord (also extends java.util.List, java.io.Serializable)
      • interface javax.resource.cci.MappedRecord (also extends java.util.Map, java.io.Serializable)
      • interface javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
    • interface javax.management.relation.RelationType
    • interface javax.xml.rpc.encoding.Serializer
    • interface javax.xml.rpc.encoding.SerializerFactory
    • interface javax.ejb.TimerHandle
    • interface javax.xml.rpc.encoding.TypeMappingRegistry
    • interface javax.management.ValueExp
  • interface javax.xml.rpc.encoding.SerializationContext
  • interface javax.jms.ServerSession
  • interface javax.jms.ServerSessionPool
  • interface javax.xml.rpc.Service
  • interface javax.xml.rpc.server.ServiceLifecycle
  • interface javax.servlet.Servlet
    • interface javax.servlet.jsp.JspPage
      • interface javax.servlet.jsp.HttpJspPage
  • interface javax.servlet.ServletConfig
  • interface javax.servlet.ServletContext
  • interface javax.xml.rpc.server.ServletEndpointContext
  • interface javax.servlet.ServletRequest
    • interface javax.servlet.http.HttpServletRequest
  • interface javax.servlet.ServletResponse
    • interface javax.servlet.http.HttpServletResponse
  • interface javax.ejb.SessionSynchronization
  • interface javax.mail.internet.SharedInputStream
  • interface javax.servlet.SingleThreadModel
  • interface javax.xml.registry.infomodel.Slot
  • interface javax.xml.soap.SOAPConstants
  • interface javax.xml.transform.Source
  • interface javax.xml.transform.SourceLocator
    • interface javax.xml.transform.dom.DOMLocator
  • interface javax.management.j2ee.statistics.Statistic
    • interface javax.management.j2ee.statistics.BoundaryStatistic
      • interface javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.RangeStatistic)
    • interface javax.management.j2ee.statistics.CountStatistic
    • interface javax.management.j2ee.statistics.RangeStatistic
      • interface javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.BoundaryStatistic)
    • interface javax.management.j2ee.statistics.TimeStatistic
  • interface javax.management.j2ee.statistics.Stats
    • interface javax.management.j2ee.statistics.EJBStats
      • interface javax.management.j2ee.statistics.EntityBeanStats
      • interface javax.management.j2ee.statistics.MessageDrivenBeanStats
      • interface javax.management.j2ee.statistics.SessionBeanStats
        • interface javax.management.j2ee.statistics.StatefulSessionBeanStats
        • interface javax.management.j2ee.statistics.StatelessSessionBeanStats
    • interface javax.management.j2ee.statistics.JCAConnectionStats
      • interface javax.management.j2ee.statistics.JCAConnectionPoolStats
    • interface javax.management.j2ee.statistics.JCAStats
    • interface javax.management.j2ee.statistics.JDBCConnectionStats
      • interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
    • interface javax.management.j2ee.statistics.JDBCStats
    • interface javax.management.j2ee.statistics.JMSConnectionStats
    • interface javax.management.j2ee.statistics.JMSEndpointStats
      • interface javax.management.j2ee.statistics.JMSConsumerStats
      • interface javax.management.j2ee.statistics.JMSProducerStats
    • interface javax.management.j2ee.statistics.JMSSessionStats
    • interface javax.management.j2ee.statistics.JMSStats
    • interface javax.management.j2ee.statistics.JTAStats
    • interface javax.management.j2ee.statistics.JVMStats
    • interface javax.management.j2ee.statistics.ServletStats
    • interface javax.management.j2ee.statistics.URLStats
  • interface javax.transaction.Status
  • interface javax.resource.cci.Streamable
  • interface javax.xml.rpc.Stub
  • interface javax.transaction.Synchronization
  • interface javax.management.openmbean.TabularData
  • interface javax.enterprise.deploy.spi.Target
  • interface javax.enterprise.deploy.spi.TargetModuleID
  • interface javax.xml.registry.infomodel.TelephoneNumber
  • interface javax.xml.transform.Templates
  • interface javax.ejb.TimedObject
  • interface javax.ejb.Timer
  • interface javax.management.timer.TimerMBean
  • interface javax.ejb.TimerService
  • interface javax.transaction.Transaction
  • interface javax.transaction.TransactionManager
  • interface javax.servlet.jsp.tagext.TryCatchFinally
  • interface javax.xml.rpc.encoding.TypeMapping
  • interface javax.mail.UIDFolder
  • interface javax.xml.transform.URIResolver
  • interface javax.xml.registry.infomodel.URIValidator
    • interface javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.RegistryObject)
    • interface javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.RegistryObject)
  • interface javax.transaction.UserTransaction
  • interface javax.resource.spi.ValidatingManagedConnectionFactory
  • interface javax.servlet.jsp.el.VariableResolver
  • interface javax.xml.registry.infomodel.Versionable
    • interface javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.RegistryObject)
      • interface javax.xml.registry.infomodel.ClassificationScheme
      • interface javax.xml.registry.infomodel.ExtrinsicObject
      • interface javax.xml.registry.infomodel.RegistryPackage
      • interface javax.xml.registry.infomodel.Service
  • interface javax.resource.spi.work.WorkManager
  • interface javax.jms.XAConnectionFactory
    • interface javax.jms.XAQueueConnectionFactory (also extends javax.jms.QueueConnectionFactory)
    • interface javax.jms.XATopicConnectionFactory (also extends javax.jms.TopicConnectionFactory)
  • interface javax.transaction.xa.XAResource
  • interface javax.resource.spi.XATerminator
  • interface javax.transaction.xa.Xid
  • interface javax.enterprise.deploy.model.XpathListener
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Index

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

A

ACTION - Static variable in class javax.management.MBeanOperationInfo
Indicates that the operation is a write-like, and would modify the MBean in some way, typically by writing some value or changing a configuration.
ACTION_INFO - Static variable in class javax.management.MBeanOperationInfo
Indicates that the operation is both read-like and write-like.
ADDED - Static variable in class javax.mail.event.MessageCountEvent
The messages were added to their folder
ADDRESS_LINES_SLOT - Static variable in interface javax.xml.registry.infomodel.Slot
Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.
ALERT - Static variable in class javax.mail.event.StoreEvent
Indicates that this message is an ALERT.
ALL - Static variable in class javax.mail.internet.MimeUtility
ALLOWED_CLASSNAMES - Static variable in class javax.management.openmbean.OpenType
List of the fully qualified names of the Java classes allowed for open data values.
AND_ALL_KEYS - Static variable in interface javax.xml.registry.FindQualifier
ANSWERED - Static variable in class javax.mail.Flags.Flag
This message has been answered.
APPLICATION - Static variable in class javax.servlet.jsp.PageContext
Name used to store ServletContext in PageContext name table.
APPLICATION_SCOPE - Static variable in class javax.servlet.jsp.PageContext
Application scope: named reference remains available in the ServletContext until it is reclaimed.
ASSOCIATION - Static variable in interface javax.xml.registry.LifeCycleManager
ATOM - Static variable in class javax.mail.internet.HeaderTokenizer.Token
Token type indicating an ATOM.
ATTACHMENT - Static variable in interface javax.mail.Part
This part should be presented as an attachment.
ATTRIBUTE_CHANGE - Static variable in class javax.management.AttributeChangeNotification
Notification type which indicates that the observed MBean attribute value has changed.
AT_BEGIN - Static variable in class javax.servlet.jsp.tagext.VariableInfo
Scope information that scripting variable is visible after start tag.
AT_END - Static variable in class javax.servlet.jsp.tagext.VariableInfo
Scope information that scripting variable is visible after end tag.
AUDITABLE_EVENT - Static variable in interface javax.xml.registry.LifeCycleManager
AUTHORIZED_NAME_SLOT - Static variable in interface javax.xml.registry.infomodel.Slot
Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.
AUTO_ACKNOWLEDGE - Static variable in interface javax.jms.Session
With this acknowledgment mode, the session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.
AccessLocalException - exception javax.ejb.AccessLocalException.
An AccessLocalException is thrown to indicate that the caller does not have permission to call the method.
AccessLocalException() - Constructor for class javax.ejb.AccessLocalException
Constructs an AccessLocalException with no detail message.
AccessLocalException(String) - Constructor for class javax.ejb.AccessLocalException
Constructs an AccessLocalException with the specified detail message.
AccessLocalException(String, Exception) - Constructor for class javax.ejb.AccessLocalException
Constructs an AccessLocalException with the specified detail message and a nested exception.
ActionType - class javax.enterprise.deploy.shared.ActionType.
Class ActionTypes defines enumeration values for the J2EE DeploymentStatus actions.
ActionType(int) - Constructor for class javax.enterprise.deploy.shared.ActionType
Construct a new enumeration value with the given integer value.
ActivationDataFlavor - class javax.activation.ActivationDataFlavor.
The ActivationDataFlavor class is a special subclass of java.awt.datatransfer.DataFlavor.
ActivationDataFlavor(Class, String, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents an arbitrary Java object.
ActivationDataFlavor(Class, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents a MimeType.
ActivationDataFlavor(String, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents a MimeType.
ActivationSpec - interface javax.resource.spi.ActivationSpec.
This interface serves as a marker.
Address - class javax.mail.Address.
This abstract class models the addresses in a message.
Address() - Constructor for class javax.mail.Address
AddressException - exception javax.mail.internet.AddressException.
The exception thrown when a wrongly formatted address is encountered.
AddressException() - Constructor for class javax.mail.internet.AddressException
Constructs an AddressException with no detail message.
AddressException(String) - Constructor for class javax.mail.internet.AddressException
Constructs an AddressException with the specified detail message.
AddressException(String, String) - Constructor for class javax.mail.internet.AddressException
Constructs an AddressException with the specified detail message and reference info.
AddressException(String, String, int) - Constructor for class javax.mail.internet.AddressException
Constructs an AddressException with the specified detail message and reference info.
AddressStringTerm - class javax.mail.search.AddressStringTerm.
This abstract class implements string comparisons for Message addresses.
AddressStringTerm(String) - Constructor for class javax.mail.search.AddressStringTerm
Constructor.
AddressTerm - class javax.mail.search.AddressTerm.
This class implements Message Address comparisons.
AddressTerm(Address) - Constructor for class javax.mail.search.AddressTerm
AndTerm - class javax.mail.search.AndTerm.
This class implements the logical AND operator on individual SearchTerms.
AndTerm(SearchTerm, SearchTerm) - Constructor for class javax.mail.search.AndTerm
Constructor that takes two terms.
AndTerm(SearchTerm[]) - Constructor for class javax.mail.search.AndTerm
Constructor that takes an array of SearchTerms.
ApplicationServerInternalException - exception javax.resource.spi.ApplicationServerInternalException.
An ApplicationServerInternalException is thrown by an application server to indicate error conditions specific to an application server.
ApplicationServerInternalException() - Constructor for class javax.resource.spi.ApplicationServerInternalException
Constructs a new instance with null as its detail message.
ApplicationServerInternalException(String) - Constructor for class javax.resource.spi.ApplicationServerInternalException
Constructs a new instance with the specified detail message.
ApplicationServerInternalException(Throwable) - Constructor for class javax.resource.spi.ApplicationServerInternalException
Constructs a new throwable with the specified cause.
ApplicationServerInternalException(String, Throwable) - Constructor for class javax.resource.spi.ApplicationServerInternalException
Constructs a new throwable with the specified detail message and cause.
ApplicationServerInternalException(String, String) - Constructor for class javax.resource.spi.ApplicationServerInternalException
Constructs a new throwable with the specified detail message and an error code.
ArrayType - class javax.management.openmbean.ArrayType.
The ArrayType class is the open type class whose instances describe all open data values which are n-dimensional arrays of open data values.
ArrayType(int, OpenType) - Constructor for class javax.management.openmbean.ArrayType
Constructs an ArrayType instance describing open data values which are arrays with dimension dimension of elements whose open type is elementType.
Association - interface javax.xml.registry.infomodel.Association.
A RegistryObject instance may be associated with zero or more RegistryObject instances.
AttachmentPart - class javax.xml.soap.AttachmentPart.
A single attachment to a SOAPMessage object.
AttachmentPart() - Constructor for class javax.xml.soap.AttachmentPart
Attribute - class javax.management.Attribute.
Represents an MBean attribute by associating its name with its value.
Attribute(String, Object) - Constructor for class javax.management.Attribute
Constructs an Attribute object which associates the given attribute name with the given value.
AttributeChangeNotification - class javax.management.AttributeChangeNotification.
Provides definitions of the attribute change notifications sent by MBeans.
AttributeChangeNotification(Object, long, long, String, String, String, Object, Object) - Constructor for class javax.management.AttributeChangeNotification
Constructs an attribute change notification object.
AttributeChangeNotificationFilter - class javax.management.AttributeChangeNotificationFilter.
This class implements of the NotificationFilter interface for the attribute change notification.
AttributeChangeNotificationFilter() - Constructor for class javax.management.AttributeChangeNotificationFilter
AttributeList - class javax.management.AttributeList.
Represents a list of values for attributes of an MBean.
AttributeList() - Constructor for class javax.management.AttributeList
Constructs an empty AttributeList.
AttributeList(int) - Constructor for class javax.management.AttributeList
Constructs an empty AttributeList with the initial capacity specified.
AttributeList(AttributeList) - Constructor for class javax.management.AttributeList
Constructs an AttributeList containing the elements of the AttributeList specified, in the order in which they are returned by the AttributeList's iterator.
AttributeNotFoundException - exception javax.management.AttributeNotFoundException.
The specified attribute does not exist or cannot be retrieved.
AttributeNotFoundException() - Constructor for class javax.management.AttributeNotFoundException
Default constructor.
AttributeNotFoundException(String) - Constructor for class javax.management.AttributeNotFoundException
Constructor that allows a specific error message to be specified.
AttributeValueExp - class javax.management.AttributeValueExp.
Represents attributes used as arguments to relational constraints.
AttributeValueExp() - Constructor for class javax.management.AttributeValueExp
Deprecated. An instance created with this constructor cannot be used in a query.
AttributeValueExp(String) - Constructor for class javax.management.AttributeValueExp
Creates a new AttributeValueExp representing the specified object attribute, named attr.
AuditableEvent - interface javax.xml.registry.infomodel.AuditableEvent.
AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject.
AuthenticationFailedException - exception javax.mail.AuthenticationFailedException.
This exception is thrown when the connect method on a Store or Transport object fails due to an authentication failure (e.g., bad user name or password).
AuthenticationFailedException() - Constructor for class javax.mail.AuthenticationFailedException
Constructor
AuthenticationFailedException(String) - Constructor for class javax.mail.AuthenticationFailedException
Constructor
Authenticator - class javax.mail.Authenticator.
The class Authenticator represents an object that knows how to obtain authentication for a network connection.
Authenticator() - Constructor for class javax.mail.Authenticator
acknowledge() - Method in interface javax.jms.Message
Acknowledges all consumed messages of the session of this consumed message.
add(FetchProfile.Item) - Method in class javax.mail.FetchProfile
Add the given special item as one of the attributes to be prefetched.
add(String) - Method in class javax.mail.FetchProfile
Add the specified header-field to the list of attributes to be prefetched.
add(Flags.Flag) - Method in class javax.mail.Flags
Add the specified system flag to this Flags object.
add(String) - Method in class javax.mail.Flags
Add the specified user flag to this Flags object.
add(Flags) - Method in class javax.mail.Flags
Add all the flags in the given Flags object to this Flags object.
add(Attribute) - Method in class javax.management.AttributeList
Adds the Attribute specified as the last element of the list.
add(int, Attribute) - Method in class javax.management.AttributeList
Inserts the attribute specified as an element at the position specified.
add(Role) - Method in class javax.management.relation.RoleList
Adds the Role specified as the last element of the list.
add(int, Role) - Method in class javax.management.relation.RoleList
Inserts the role specified as an element at the position specified.
add(RoleUnresolved) - Method in class javax.management.relation.RoleUnresolvedList
Adds the RoleUnresolved specified as the last element of the list.
add(int, RoleUnresolved) - Method in class javax.management.relation.RoleUnresolvedList
Inserts the unresolved role specified as an element at the position specified.
addAll(AttributeList) - Method in class javax.management.AttributeList
Appends all the elements in the AttributeList specified to the end of the list, in the order in which they are returned by the Iterator of the AttributeList specified.
addAll(int, AttributeList) - Method in class javax.management.AttributeList
Inserts all of the elements in the AttributeList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the AttributeList specified.
addAll(RoleList) - Method in class javax.management.relation.RoleList
Appends all the elements in the RoleList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleList specified.
addAll(int, RoleList) - Method in class javax.management.relation.RoleList
Inserts all of the elements in the RoleList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleList specified.
addAll(RoleUnresolvedList) - Method in class javax.management.relation.RoleUnresolvedList
Appends all the elements in the RoleUnresolvedList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
addAll(int, RoleUnresolvedList) - Method in class javax.management.relation.RoleUnresolvedList
Inserts all of the elements in the RoleUnresolvedList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
addAssociation(Association) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified Association to use this object as source.
addAssociations(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified Associations to use this object as source.
addAttachmentPart(AttachmentPart) - Method in class javax.xml.soap.SOAPMessage
Adds the given AttachmentPart object to this SOAPMessage object.
addAttribute(Name, String) - Method in interface javax.xml.soap.SOAPElement
Adds an attribute with the specified name and value to this SOAPElement object.
addAttributeChangeNotificationListener(NotificationListener, String, Object) - Method in interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster
Registers an object which implements the NotificationListener interface as a listener.
addAttributeChangeNotificationListener(NotificationListener, String, Object) - Method in class javax.management.modelmbean.RequiredModelMBean
addBody() - Method in interface javax.xml.soap.SOAPEnvelope
Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
addBodyElement(Name) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
addBodyPart(BodyPart) - Method in class javax.mail.Multipart
Adds a Part to the multipart.
addBodyPart(BodyPart, int) - Method in class javax.mail.Multipart
Adds a BodyPart at position index.
addChildConcept(Concept) - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Adds a child Concept.
addChildConcept(Concept) - Method in interface javax.xml.registry.infomodel.Concept
Adds a child Concept.
addChildConcepts(Collection) - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Adds a Collection of Concept children.
addChildConcepts(Collection) - Method in interface javax.xml.registry.infomodel.Concept
Adds a Collection of Concept children.
addChildElement(Name) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
addChildElement(String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
addChildElement(String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
addChildElement(String, String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
addChildElement(SOAPElement) - Method in interface javax.xml.soap.SOAPElement
Add a SOAPElement as a child of this SOAPElement instance.
addChildOrganization(Organization) - Method in interface javax.xml.registry.infomodel.Organization
Adds a child Organization.
addChildOrganizations(Collection) - Method in interface javax.xml.registry.infomodel.Organization
Adds a Collection of Organization children.
addClassification(Classification) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified Classification to this object.
addClassifications(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified Classifications to this object.
addConnectionEventListener(ConnectionEventListener) - Method in interface javax.resource.spi.ManagedConnection
Adds a connection event listener to the ManagedConnection instance.
addConnectionListener(ConnectionListener) - Method in class javax.mail.Folder
Add a listener for Connection events on this Folder.
addConnectionListener(ConnectionListener) - Method in class javax.mail.Service
Add a listener for Connection events on this service.
addCookie(Cookie) - Method in interface javax.servlet.http.HttpServletResponse
Adds the specified cookie to the response.
addCookie(Cookie) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call addCookie(Cookie cookie) on the wrapped response object.
addDateHeader(String, long) - Method in interface javax.servlet.http.HttpServletResponse
Adds a response header with the given name and date-value.
addDateHeader(String, long) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call addDateHeader(String name, long date) on the wrapped response object.
addDetail() - Method in interface javax.xml.soap.SOAPFault
Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
addDetailEntry(Name) - Method in interface javax.xml.soap.Detail
Creates a new DetailEntry object with the given name and adds it to this Detail object.
addDocument(Document) - Method in interface javax.xml.soap.SOAPBody
Adds the root node of the DOM Document to this SOAPBody object.
addExternalIdentifier(ExternalIdentifier) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified ExternalIdentifier as an external identifier to this object.
addExternalIdentifiers(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified ExternalIdentifiers as an external identifiers to this object.
addExternalLink(ExternalLink) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified ExternalLink to this object.
addExternalLinks(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified ExternalLinks to this object.
addFault() - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(Name, String, Locale) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(Name, String) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFolderListener(FolderListener) - Method in class javax.mail.Folder
Add a listener for Folder events on this Folder.
addFolderListener(FolderListener) - Method in class javax.mail.Store
Add a listener for Folder events on any Folder object obtained from this Store.
addFrom(Address[]) - Method in class javax.mail.Message
Add these addresses to the existing "From" attribute
addFrom(Address[]) - Method in class javax.mail.internet.MimeMessage
Add the specified addresses to the existing "From" field.
addHeader(String, String) - Method in interface javax.mail.Part
Add this value to the existing values for this header_name.
addHeader(String, String) - Method in class javax.mail.internet.InternetHeaders
Add a header with the specified name and value to the header list.
addHeader(String, String) - Method in class javax.mail.internet.MimeBodyPart
Add this value to the existing values for this header_name.
addHeader(String, String) - Method in class javax.mail.internet.MimeMessage
Add this value to the existing values for this header_name.
addHeader(String, String) - Method in interface javax.servlet.http.HttpServletResponse
Adds a response header with the given name and value.
addHeader(String, String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to return addHeader(String name, String value) on the wrapped response object.
addHeader(String, String) - Method in class javax.xml.soap.MimeHeaders
Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.
addHeader() - Method in interface javax.xml.soap.SOAPEnvelope
Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
addHeaderElement(Name) - Method in interface javax.xml.soap.SOAPHeader
Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
addHeaderLine(String) - Method in class javax.mail.internet.InternetHeaders
Add an RFC822 header line to the header store.
addHeaderLine(String) - Method in class javax.mail.internet.MimeBodyPart
Add a header line to this body part
addHeaderLine(String) - Method in class javax.mail.internet.MimeMessage
Add a raw RFC 822 header-line.
addHeaderLine(String) - Method in interface javax.mail.internet.MimePart
Add a raw RFC822 header-line.
addIntHeader(String, int) - Method in interface javax.servlet.http.HttpServletResponse
Adds a response header with the given name and integer value.
addIntHeader(String, int) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call addIntHeader(String name, int value) on the wrapped response object.
addLocalizedString(LocalizedString) - Method in interface javax.xml.registry.infomodel.InternationalString
Adds a LocalizedString to this object.
addLocalizedStrings(Collection) - Method in interface javax.xml.registry.infomodel.InternationalString
Adds many LocalizedStrings to this object.
addMailcap(String) - Method in class javax.activation.MailcapCommandMap
Add entries to the registry.
addMessageChangedListener(MessageChangedListener) - Method in class javax.mail.Folder
Add a listener for MessageChanged events on this Folder.
addMessageCountListener(MessageCountListener) - Method in class javax.mail.Folder
Add a listener for MessageCount events on this Folder.
addMimeHeader(String, String) - Method in class javax.xml.soap.AttachmentPart
Adds a MIME header with the specified name and value to this AttachmentPart object.
addMimeHeader(String, String) - Method in class javax.xml.soap.SOAPPart
Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object.
addMimeTypes(String) - Method in class javax.activation.MimetypesFileTypeMap
Prepend the MIME type values to the registry.
addNamespaceDeclaration(String, String) - Method in interface javax.xml.soap.SOAPElement
Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
addNotification(String, String, Object, Date, long, long, boolean) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.
addNotification(String, String, Object, Date, long, long) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.
addNotification(String, String, Object, Date, long) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurences.
addNotification(String, String, Object, Date) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurences.
addNotification(String, String, Object, Date, long, long, boolean) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.
addNotification(String, String, Object, Date, long, long) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.
addNotification(String, String, Object, Date, long) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurences.
addNotification(String, String, Object, Date) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurences.
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.MBeanServer
Adds a listener to a registered MBean.
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management.MBeanServer
Adds a listener to a registered MBean.
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.MBeanServerConnection
Adds a listener to a registered MBean.
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management.MBeanServerConnection
Adds a listener to a registered MBean.
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.MBeanServerDelegate
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management.NotificationBroadcaster
Adds a listener to this MBean.
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.NotificationBroadcasterSupport
Adds a listener.
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.j2ee.ListenerRegistration
Add a listener to a registered managed object.
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.modelmbean.RequiredModelMBean
Registers an object which implements the NotificationListener interface as a listener.
addObservedObject(ObjectName) - Method in class javax.management.monitor.Monitor
Adds the specified object in the set of observed MBeans, if this object is not already present.
addObservedObject(ObjectName) - Method in interface javax.management.monitor.MonitorMBean
Adds the specified object in the set of observed MBeans.
addParameter(String, QName, ParameterMode) - Method in interface javax.xml.rpc.Call
Adds a parameter type and mode for a specific operation.
addParameter(String, QName, Class, ParameterMode) - Method in interface javax.xml.rpc.Call
Adds a parameter type and mode for a specific operation.
addProgressListener(ProgressListener) - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Add a listener to receive Progress events on deployment actions.
addPropertyChangeListener(PropertyChangeListener) - Method in interface javax.enterprise.deploy.spi.DConfigBean
Register a property listener for this bean.
addRecipient(Message.RecipientType, Address) - Method in class javax.mail.Message
Add this recipient address to the existing ones of the given type.
addRecipients(Message.RecipientType, Address[]) - Method in class javax.mail.Message
Add these recipient addresses to the existing ones of the given type.
addRecipients(Message.RecipientType, Address[]) - Method in class javax.mail.internet.MimeMessage
Add the given addresses to the specified recipient type.
addRecipients(Message.RecipientType, String) - Method in class javax.mail.internet.MimeMessage
Add the given addresses to the specified recipient type.
addRegistryObject(RegistryObject) - Method in interface javax.xml.registry.infomodel.RegistryPackage
Adds a child RegistryObject as member.
addRegistryObjects(Collection) - Method in interface javax.xml.registry.infomodel.RegistryPackage
Adds a Collection of RegistryObject children as members.
addRelation(ObjectName) - Method in class javax.management.relation.RelationService
Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
addRelation(ObjectName) - Method in interface javax.management.relation.RelationServiceMBean
Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
addRelationType(RelationType) - Method in class javax.management.relation.RelationService
Adds given object as a relation type.
addRelationType(RelationType) - Method in interface javax.management.relation.RelationServiceMBean
Adds given object as a relation type.
addRoleInfo(RoleInfo) - Method in class javax.management.relation.RelationTypeSupport
Add a role info.
addService(Service) - Method in interface javax.xml.registry.infomodel.Organization
Adds a child Service.
addServiceBinding(ServiceBinding) - Method in interface javax.xml.registry.infomodel.Service
Adds a child ServiceBinding.
addServiceBindings(Collection) - Method in interface javax.xml.registry.infomodel.Service
Adds a Collection of ServiceBinding children.
addServices(Collection) - Method in interface javax.xml.registry.infomodel.Organization
Adds a Collection of Service children.
addSlot(Slot) - Method in interface javax.xml.registry.infomodel.ExtensibleObject
Adds a Slot to this object.
addSlots(Collection) - Method in interface javax.xml.registry.infomodel.ExtensibleObject
Adds more Slots to this object.
addSpecificationLink(SpecificationLink) - Method in interface javax.xml.registry.infomodel.ServiceBinding
Adds a child SpecificationLink.
addSpecificationLinks(Collection) - Method in interface javax.xml.registry.infomodel.ServiceBinding
Adds a Collection of SpecificationLink children.
addStoreListener(StoreListener) - Method in class javax.mail.Store
Add a listener for StoreEvents on this Store.
addTextNode(String) - Method in interface javax.xml.soap.SOAPElement
Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
addToExcludedPolicy(PermissionCollection) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add excluded policy statements to this PolicyConfiguration.
addToExcludedPolicy(Permission) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add a single excluded policy statement to this PolicyConfiguration.
addToRole(String, PermissionCollection) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add permissions to a named role in this PolicyConfiguration.
addToRole(String, Permission) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add a single permission to a named role in this PolicyConfiguration.
addToUncheckedPolicy(PermissionCollection) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add unchecked policy statements to this PolicyConfiguration.
addToUncheckedPolicy(Permission) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add a single unchecked policy statement to this PolicyConfiguration.
addTransportListener(TransportListener) - Method in class javax.mail.Transport
Add a listener for Transport events.
addURL(URL) - Method in class javax.management.loading.MLet
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(String) - Method in class javax.management.loading.MLet
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(URL) - Method in interface javax.management.loading.MLetMBean
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(String) - Method in interface javax.management.loading.MLetMBean
Appends the specified URL to the list of URLs to search for classes and resources.
addUser(User) - Method in interface javax.xml.registry.infomodel.Organization
Adds a User.
addUsers(Collection) - Method in interface javax.xml.registry.infomodel.Organization
Adds a Collection of Users.
addXpathListener(String, XpathListener) - Method in interface javax.enterprise.deploy.model.DDBean
Register a listener for a specific XPath.
addXpathListener(ModuleType, String, XpathListener) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Register a listener for changes in XPath that are related to this deployableObject.
address - Variable in class javax.mail.internet.InternetAddress
address - Variable in class javax.mail.search.AddressTerm
The address.
afterBegin() - Method in interface javax.ejb.SessionSynchronization
The afterBegin method notifies a session Bean instance that a new transaction has started, and that the subsequent business methods on the instance will be invoked in the context of the transaction.
afterCompletion(boolean) - Method in interface javax.ejb.SessionSynchronization
The afterCompletion method notifies a session Bean instance that a transaction commit protocol has completed, and tells the instance whether the transaction has been committed or rolled back.
afterCompletion(int) - Method in interface javax.transaction.Synchronization
This method is called by the transaction manager after the transaction is committed or rolled back.
afterDelivery() - Method in interface javax.resource.spi.endpoint.MessageEndpoint
This is called by a resource adapter after a message is delivered.
allocateConnection(ManagedConnectionFactory, ConnectionRequestInfo) - Method in interface javax.resource.spi.ConnectionManager
The method allocateConnection gets called by the resource adapter's connection factory instance.
alreadyNotified - Variable in class javax.management.monitor.Monitor
Deprecated. equivalent to Monitor.alreadyNotifieds[0].
alreadyNotifieds - Variable in class javax.management.monitor.Monitor
Selected monitor errors that have already been notified.
and(QueryExp, QueryExp) - Static method in class javax.management.Query
Returns a query expression that is the conjunction of two other query expressions.
anySubString(AttributeValueExp, StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a matching constraint on a string argument.
appendMessages(Message[]) - Method in class javax.mail.Folder
Append given Messages to this folder.
apply(ObjectName) - Method in class javax.management.AttributeValueExp
Applies the AttributeValueExp on an MBean.
apply(ObjectName) - Method in class javax.management.ObjectName
Test whether this ObjectName, which may be a pattern, matches another ObjectName.
apply(ObjectName) - Method in interface javax.management.QueryExp
Applies the QueryExp on an MBean.
apply(ObjectName) - Method in class javax.management.StringValueExp
Applies the ValueExp on a MBean.
apply(ObjectName) - Method in interface javax.management.ValueExp
Applies the ValueExp on a MBean.
associateConnection(Object, ManagedConnectionFactory, ConnectionRequestInfo) - Method in interface javax.resource.spi.LazyAssociatableConnectionManager
This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.
associateConnection(Object) - Method in interface javax.resource.spi.ManagedConnection
Used by the container to change the association of an application-level connection handle with a ManagedConneciton instance.
attr(String) - Static method in class javax.management.Query
Returns a new attribute expression.
attr(String, String) - Static method in class javax.management.Query
Returns a new qualified attribute expression.
attributeAdded(ServletContextAttributeEvent) - Method in interface javax.servlet.ServletContextAttributeListener
Notification that a new attribute was added to the servlet context.
attributeAdded(ServletRequestAttributeEvent) - Method in interface javax.servlet.ServletRequestAttributeListener
Notification that a new attribute was added to the servlet request.
attributeAdded(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionAttributeListener
Notification that an attribute has been added to a session.
attributeRemoved(ServletContextAttributeEvent) - Method in interface javax.servlet.ServletContextAttributeListener
Notification that an existing attribute has been removed from the servlet context.
attributeRemoved(ServletRequestAttributeEvent) - Method in interface javax.servlet.ServletRequestAttributeListener
Notification that an existing attribute has been removed from the servlet request.
attributeRemoved(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionAttributeListener
Notification that an attribute has been removed from a session.
attributeReplaced(ServletContextAttributeEvent) - Method in interface javax.servlet.ServletContextAttributeListener
Notification that an attribute on the servlet context has been replaced.
attributeReplaced(ServletRequestAttributeEvent) - Method in interface javax.servlet.ServletRequestAttributeListener
Notification that an attribute on the servlet request has been replaced.
attributeReplaced(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionAttributeListener
Notification that an attribute has been replaced in a session.
autoFlush - Variable in class javax.servlet.jsp.JspWriter
Whether the JspWriter is autoflushing.

B

BASIC_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest
String identifier for Basic authentication.
BCC - Static variable in class javax.mail.Message.RecipientType
The "Bcc" (blind carbon copy) recipients.
BEAN_ADDED - Static variable in class javax.enterprise.deploy.model.XpathEvent
Adding a DDBean
BEAN_CHANGED - Static variable in class javax.enterprise.deploy.model.XpathEvent
Changing a DDBean
BEAN_REMOVED - Static variable in class javax.enterprise.deploy.model.XpathEvent
Removing a DDBean
BIGDECIMAL - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.math.BigDecimal.
BIGINTEGER - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.math.BigInteger.
BODY_CONTENT_EMPTY - Static variable in class javax.servlet.jsp.tagext.TagInfo
Static constant for getBodyContent() when it is empty.
BODY_CONTENT_JSP - Static variable in class javax.servlet.jsp.tagext.TagInfo
Static constant for getBodyContent() when it is JSP.
BODY_CONTENT_SCRIPTLESS - Static variable in class javax.servlet.jsp.tagext.TagInfo
Static constant for getBodyContent() when it is scriptless.
BODY_CONTENT_TAG_DEPENDENT - Static variable in class javax.servlet.jsp.tagext.TagInfo
Static constant for getBodyContent() when it is Tag dependent.
BOOLEAN - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Boolean.
BYTE - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Byte.
BadAttributeValueExpException - exception javax.management.BadAttributeValueExpException.
Thrown when an invalid MBean attribute is passed to a query constructing method.
BadAttributeValueExpException(Object) - Constructor for class javax.management.BadAttributeValueExpException
Constructs an BadAttributeValueExpException with the specified Object.
BadBinaryOpValueExpException - exception javax.management.BadBinaryOpValueExpException.
Thrown when an invalid expression is passed to a method for constructing a query.
BadBinaryOpValueExpException(ValueExp) - Constructor for class javax.management.BadBinaryOpValueExpException
Constructs a BadBinaryOpValueExpException with the specified ValueExp.
BadStringOperationException - exception javax.management.BadStringOperationException.
Thrown when an invalid string operation is passed to a method for constructing a query.
BadStringOperationException(String) - Constructor for class javax.management.BadStringOperationException
Constructs a BadStringOperationException with the specified detail message.
BeanNotFoundException - exception javax.enterprise.deploy.spi.exceptions.BeanNotFoundException.
This exception is to report that the bean is not a child of the parent bean.
BeanNotFoundException(String) - Constructor for class javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
Creates an new BeanNotFoundException object.
BigDecimalHolder - class javax.xml.rpc.holders.BigDecimalHolder.
BigDecimalHolder() - Constructor for class javax.xml.rpc.holders.BigDecimalHolder
BigDecimalHolder(BigDecimal) - Constructor for class javax.xml.rpc.holders.BigDecimalHolder
BigIntegerHolder - class javax.xml.rpc.holders.BigIntegerHolder.
BigIntegerHolder() - Constructor for class javax.xml.rpc.holders.BigIntegerHolder
BigIntegerHolder(BigInteger) - Constructor for class javax.xml.rpc.holders.BigIntegerHolder
BodyContent - class javax.servlet.jsp.tagext.BodyContent.
An encapsulation of the evaluation of the body of an action so it is available to a tag handler.
BodyContent(JspWriter) - Constructor for class javax.servlet.jsp.tagext.BodyContent
Protected constructor.
BodyPart - class javax.mail.BodyPart.
This class models a Part that is contained within a Multipart.
BodyPart() - Constructor for class javax.mail.BodyPart
BodyTag - interface javax.servlet.jsp.tagext.BodyTag.
The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.
BodyTagSupport - class javax.servlet.jsp.tagext.BodyTagSupport.
A base class for defining tag handlers implementing BodyTag.
BodyTagSupport() - Constructor for class javax.servlet.jsp.tagext.BodyTagSupport
Default constructor, all subclasses are required to only define a public constructor with the same signature, and to call the superclass constructor.
BodyTerm - class javax.mail.search.BodyTerm.
This class implements searches on a Message Body.
BodyTerm(String) - Constructor for class javax.mail.search.BodyTerm
Constructor
BooleanHolder - class javax.xml.rpc.holders.BooleanHolder.
BooleanHolder() - Constructor for class javax.xml.rpc.holders.BooleanHolder
BooleanHolder(boolean) - Constructor for class javax.xml.rpc.holders.BooleanHolder
BooleanWrapperHolder - class javax.xml.rpc.holders.BooleanWrapperHolder.
BooleanWrapperHolder() - Constructor for class javax.xml.rpc.holders.BooleanWrapperHolder
BooleanWrapperHolder(Boolean) - Constructor for class javax.xml.rpc.holders.BooleanWrapperHolder
BootstrapContext - interface javax.resource.spi.BootstrapContext.
This provides a mechanism to pass a bootstrap context to a resource adapter instance when it is bootstrapped.
BoundaryStatistic - interface javax.management.j2ee.statistics.BoundaryStatistic.
Specifies standard measurements of the upper and lower limits of the value of an attribute.
BoundedRangeStatistic - interface javax.management.j2ee.statistics.BoundedRangeStatistic.
The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.
BulkResponse - interface javax.xml.registry.BulkResponse.
Contains the response of a method in the API that performs a bulk operation and returns a bulk response.
BusinessLifeCycleManager - interface javax.xml.registry.BusinessLifeCycleManager.
The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API.
BusinessQueryManager - interface javax.xml.registry.BusinessQueryManager.
The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface.
ByteArrayHolder - class javax.xml.rpc.holders.ByteArrayHolder.
ByteArrayHolder() - Constructor for class javax.xml.rpc.holders.ByteArrayHolder
ByteArrayHolder(byte[]) - Constructor for class javax.xml.rpc.holders.ByteArrayHolder
ByteHolder - class javax.xml.rpc.holders.ByteHolder.
ByteHolder() - Constructor for class javax.xml.rpc.holders.ByteHolder
ByteHolder(byte) - Constructor for class javax.xml.rpc.holders.ByteHolder
ByteWrapperHolder - class javax.xml.rpc.holders.ByteWrapperHolder.
ByteWrapperHolder() - Constructor for class javax.xml.rpc.holders.ByteWrapperHolder
ByteWrapperHolder(Byte) - Constructor for class javax.xml.rpc.holders.ByteWrapperHolder
BytesMessage - interface javax.jms.BytesMessage.
A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.
beforeCompletion() - Method in interface javax.ejb.SessionSynchronization
The beforeCompletion method notifies a session Bean instance that a transaction is about to be committed.
beforeCompletion() - Method in interface javax.transaction.Synchronization
The beforeCompletion method is called by the transaction manager prior to the start of the two-phase transaction commit process.
beforeDelivery(Method) - Method in interface javax.resource.spi.endpoint.MessageEndpoint
This is called by a resource adapter before a message is delivered.
begin() - Method in interface javax.resource.cci.LocalTransaction
Begins a local transaction on an EIS instance.
begin() - Method in interface javax.resource.spi.LocalTransaction
Begin a local transaction
begin() - Method in interface javax.transaction.TransactionManager
Create a new transaction and associate it with the current thread.
begin() - Method in interface javax.transaction.UserTransaction
Create a new transaction and associate it with the current thread.
between(ValueExp, ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a query expression that represents the constraint that one value is between two other values.
bodyContent - Variable in class javax.servlet.jsp.tagext.BodyTagSupport
The current BodyContent for this BodyTag.
bufferSize - Variable in class javax.servlet.jsp.JspWriter
The size of the buffer used by the JspWriter.

C

CANCEL - Static variable in class javax.enterprise.deploy.shared.ActionType
A cancel operation is being preformed on the DeploymentManager action command.
CAR - Static variable in class javax.enterprise.deploy.shared.ModuleType
The module is an Client Application archive.
CASE_SENSITIVE_MATCH - Static variable in interface javax.xml.registry.FindQualifier
CC - Static variable in class javax.mail.Message.RecipientType
The "Cc" (carbon copy) recipients.
CDATA_SECTION_ELEMENTS - Static variable in class javax.xml.transform.OutputKeys
cdata-section-elements = expanded names.
CHARACTER - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Character.
CHARACTER_SET_ENCODING - Static variable in class javax.xml.soap.SOAPMessage
Specifies the character type encoding for the SOAP Message.
CLASSIFICATION - Static variable in interface javax.xml.registry.LifeCycleManager
CLASSIFICATION_SCHEME - Static variable in interface javax.xml.registry.LifeCycleManager
CLIENT_ACKNOWLEDGE - Static variable in interface javax.jms.Session
With this acknowledgment mode, the client acknowledges a consumed message by calling the message's acknowledge method.
CLIENT_CERT_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest
String identifier for Client Certificate authentication.
CLOSED - Static variable in class javax.mail.event.ConnectionEvent
A connection was closed.
COMBINE_CLASSIFICATIONS - Static variable in interface javax.xml.registry.FindQualifier
Maps to UDDI combineCategoryBags.
COMMENT - Static variable in class javax.mail.internet.HeaderTokenizer.Token
Token type indicating a comment.
COMPLETED - Static variable in class javax.enterprise.deploy.shared.StateType
The action operation has completed normally.
CONCEPT - Static variable in interface javax.xml.registry.LifeCycleManager
CONFIG - Static variable in class javax.servlet.jsp.PageContext
Name used to store ServletConfig in PageContext name table.
CONNECTION_CLOSED - Static variable in class javax.resource.spi.ConnectionEvent
Event notification that an application component has closed the connection
CONNECTION_ERROR_OCCURRED - Static variable in class javax.resource.spi.ConnectionEvent
Event notification that an error occurred on the connection.
CONTENT_INFO - Static variable in class javax.mail.FetchProfile.Item
This item is for fetching information about the content of the message.
CREATED - Static variable in class javax.mail.event.FolderEvent
The folder was created.
CalendarHolder - class javax.xml.rpc.holders.CalendarHolder.
CalendarHolder() - Constructor for class javax.xml.rpc.holders.CalendarHolder
CalendarHolder(Calendar) - Constructor for class javax.xml.rpc.holders.CalendarHolder
Call - interface javax.xml.rpc.Call.
The javax.xml.rpc.Call interface provides support for the dynamic invocation of a service endpoint.
CapabilityProfile - interface javax.xml.registry.CapabilityProfile.
Provides information about the capabilities of a JAXR provider.
ClassLoaderRepository - interface javax.management.loading.ClassLoaderRepository.
Instances of this interface are used to keep the list of ClassLoaders registered in an MBean Server.
Classification - interface javax.xml.registry.infomodel.Classification.
The Classification interface is used to classify RegistryObject instances.
ClassificationScheme - interface javax.xml.registry.infomodel.ClassificationScheme.
A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
ClientConfiguration - interface javax.enterprise.deploy.spi.status.ClientConfiguration.
The ClientConfiguration object installs, configures and executes an Application Client.
ClientExecuteException - exception javax.enterprise.deploy.spi.exceptions.ClientExecuteException.
This exception reports errors in setting up an application client for execution.
ClientExecuteException() - Constructor for class javax.enterprise.deploy.spi.exceptions.ClientExecuteException
Creates new ClientExecuteException without detail message.
ClientExecuteException(String) - Constructor for class javax.enterprise.deploy.spi.exceptions.ClientExecuteException
Constructs an ClientExecuteException with the specified detail message.
CommException - exception javax.resource.spi.CommException.
This indicates errors related to failed or interrupted communication with an EIS instance.
CommException() - Constructor for class javax.resource.spi.CommException
Constructs a new instance with null as its detail message.
CommException(String) - Constructor for class javax.resource.spi.CommException
Constructs a new instance with the specified detail message.
CommException(Throwable) - Constructor for class javax.resource.spi.CommException
Constructs a new throwable with the specified cause.
CommException(String, Throwable) - Constructor for class javax.resource.spi.CommException
Constructs a new throwable with the specified detail message and cause.
CommException(String, String) - Constructor for class javax.resource.spi.CommException
Constructs a new throwable with the specified detail message and an error code.
CommandInfo - class javax.activation.CommandInfo.
The CommandInfo class is used by CommandMap implementations to describe the results of command requests.
CommandInfo(String, String) - Constructor for class javax.activation.CommandInfo
The Constructor for CommandInfo.
CommandMap - class javax.activation.CommandMap.
The CommandMap class provides an interface to a registry of command objects available in the system.
CommandMap() - Constructor for class javax.activation.CommandMap
CommandObject - interface javax.activation.CommandObject.
JavaBeans components that are Activation Framework aware implement this interface to find out which command verb they're being asked to perform, and to obtain the DataHandler representing the data they should operate on.
CommandType - class javax.enterprise.deploy.shared.CommandType.
Class CommandTypes defines enumeration values for the DeploymentStatus object.
CommandType(int) - Constructor for class javax.enterprise.deploy.shared.CommandType
Construct a new enumeration value with the given integer value.
ComparisonTerm - class javax.mail.search.ComparisonTerm.
This class models the comparison operator.
ComparisonTerm() - Constructor for class javax.mail.search.ComparisonTerm
CompositeData - interface javax.management.openmbean.CompositeData.
The CompositeData interface specifies the behaviour of a specific type of complex open data objects which represent composite data structures.
CompositeDataSupport - class javax.management.openmbean.CompositeDataSupport.
The CompositeDataSupport class is the open data class which implements the CompositeData interface.
CompositeDataSupport(CompositeType, String[], Object[]) - Constructor for class javax.management.openmbean.CompositeDataSupport
Constructs a CompositeDataSupport instance with the specified compositeType, whose item values are specified by itemValues[], in the same order as in itemNames[].
CompositeDataSupport(CompositeType, Map) - Constructor for class javax.management.openmbean.CompositeDataSupport
Constructs a CompositeDataSupport instance with the specified compositeType, whose item names and corresponding values are given by the mappings in the map items.
CompositeType - class javax.management.openmbean.CompositeType.
The CompositeType class is the open type class whose instances describe the types of CompositeData values.
CompositeType(String, String, String[], String[], OpenType[]) - Constructor for class javax.management.openmbean.CompositeType
Constructs a CompositeType instance, checking for the validity of the given parameters.
Concept - interface javax.xml.registry.infomodel.Concept.
The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.
ConfigurationException - exception javax.enterprise.deploy.spi.exceptions.ConfigurationException.
This exception reports errors in generating a configuration bean.
ConfigurationException() - Constructor for class javax.enterprise.deploy.spi.exceptions.ConfigurationException
Creates new ConfigurationException without detail message.
ConfigurationException(String) - Constructor for class javax.enterprise.deploy.spi.exceptions.ConfigurationException
Constructs an ConfigurationException with the specified detail message.
Connection - interface javax.jms.Connection.
A Connection object is a client's active connection to its JMS provider.
Connection - interface javax.resource.cci.Connection.
A Connection represents an application-level handle that is used by a client to access the underlying physical connection.
Connection - interface javax.xml.registry.Connection.
This class represents a connection between a JAXR client and a JAXR provider.
ConnectionAdapter - class javax.mail.event.ConnectionAdapter.
The adapter which receives connection events.
ConnectionAdapter() - Constructor for class javax.mail.event.ConnectionAdapter
ConnectionConsumer - interface javax.jms.ConnectionConsumer.
For application servers, Connection objects provide a special facility for creating a ConnectionConsumer (optional).
ConnectionEvent - class javax.mail.event.ConnectionEvent.
This class models Connection events.
ConnectionEvent(Object, int) - Constructor for class javax.mail.event.ConnectionEvent
Constructor
ConnectionEvent - class javax.resource.spi.ConnectionEvent.
The ConnectionEvent class provides information about the source of a connection related event.A ConnectionEvent instance contains the following information: Type of the connection event ManagedConnection instance that generated the connection event.
ConnectionEvent(ManagedConnection, int) - Constructor for class javax.resource.spi.ConnectionEvent
Construct a ConnectionEvent object.
ConnectionEvent(ManagedConnection, int, Exception) - Constructor for class javax.resource.spi.ConnectionEvent
Construct a ConnectionEvent object.
ConnectionEventListener - interface javax.resource.spi.ConnectionEventListener.
The ConnectionEventListener interface provides an event callback mechanism to enable an application server to receive notifications from a ManagedConnection instance.
ConnectionFactory - interface javax.jms.ConnectionFactory.
A ConnectionFactory object encapsulates a set of connection configuration parameters that has been defined by an administrator.
ConnectionFactory - interface javax.resource.cci.ConnectionFactory.
ConnectionFactory provides an interface for getting connection to an EIS instance.
ConnectionFactory - class javax.xml.registry.ConnectionFactory.
This is the abstract base class for factory classes for creating a JAXR connection.
ConnectionFactory() - Constructor for class javax.xml.registry.ConnectionFactory
ConnectionListener - interface javax.mail.event.ConnectionListener.
This is the Listener interface for Connection events.
ConnectionManager - interface javax.resource.spi.ConnectionManager.
ConnectionManager interface provides a hook for the resource adapter to pass a connection request to the application server.
ConnectionMetaData - interface javax.jms.ConnectionMetaData.
A ConnectionMetaData object provides information describing the Connection object.
ConnectionMetaData - interface javax.resource.cci.ConnectionMetaData.
The interface ConnectionMetaData provides information about an EIS instance connected through a Connection instance.
ConnectionRequestInfo - interface javax.resource.spi.ConnectionRequestInfo.
The ConnectionRequestInfo interface enables a resource adapter to pass its own request specific data structure across the connection request flow.
ConnectionSpec - interface javax.resource.cci.ConnectionSpec.
ConnectionSpec is used by an application component to pass connection request-specific properties to the ConnectionFactory.
ContentDisposition - class javax.mail.internet.ContentDisposition.
This class represents a MIME ContentDisposition value.
ContentDisposition() - Constructor for class javax.mail.internet.ContentDisposition
No-arg Constructor.
ContentDisposition(String, ParameterList) - Constructor for class javax.mail.internet.ContentDisposition
Constructor.
ContentDisposition(String) - Constructor for class javax.mail.internet.ContentDisposition
Constructor that takes a ContentDisposition string.
ContentType - class javax.mail.internet.ContentType.
This class represents a MIME ContentType value.
ContentType() - Constructor for class javax.mail.internet.ContentType
No-arg Constructor.
ContentType(String, String, ParameterList) - Constructor for class javax.mail.internet.ContentType
Constructor.
ContentType(String) - Constructor for class javax.mail.internet.ContentType
Constructor that takes a Content-Type string.
Cookie - class javax.servlet.http.Cookie.
Creates a cookie, a small amount of information sent by a servlet to a Web browser, saved by the browser, and later sent back to the server.
Cookie(String, String) - Constructor for class javax.servlet.http.Cookie
Constructs a cookie with a specified name and value.
CountStatistic - interface javax.management.j2ee.statistics.CountStatistic.
Specifies standard count measurements.
CounterMonitor - class javax.management.monitor.CounterMonitor.
Defines a monitor MBean designed to observe the values of a counter attribute.
CounterMonitor() - Constructor for class javax.management.monitor.CounterMonitor
Default constructor.
CounterMonitorMBean - interface javax.management.monitor.CounterMonitorMBean.
Exposes the remote management interface of the counter monitor MBean.
CreateException - exception javax.ejb.CreateException.
The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise Bean's home interface.
CreateException() - Constructor for class javax.ejb.CreateException
Constructs a CreateException with no detail message.
CreateException(String) - Constructor for class javax.ejb.CreateException
Constructs a CreateException with the specified detail message.
cacheMBeanInfo(MBeanInfo) - Method in class javax.management.StandardMBean
Customization hook: cache the MBeanInfo built for this object.
calculateIndex(CompositeData) - Method in interface javax.management.openmbean.TabularData
Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
calculateIndex(CompositeData) - Method in class javax.management.openmbean.TabularDataSupport
Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
call(SOAPMessage, Object) - Method in class javax.xml.soap.SOAPConnection
Sends the given message to the specified endpoint and blocks until it has returned the response.
canBeRequestTime() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Whether this attribute can hold a request-time value.
cancel() - Method in interface javax.ejb.Timer
Cause the timer and all its associated expiration notifications to be cancelled.
cancel() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
(optional) A cancel request on an in-process operation stops all further processing of the operation and returns the environment to it original state before the operation was executed.
capacityIncrement - Static variable in class javax.management.monitor.Monitor
The amount by which the capacity of the monitor arrays are automatically incremented when their size becomes greater than their capacity.
cause - Variable in class javax.xml.registry.JAXRException
check(String, URL, String, MLetContent) - Method in class javax.management.loading.MLet
This method is to be overridden when extending this service to support caching and versioning.
checkMaxDegree(int) - Method in class javax.management.relation.RoleInfo
Returns a boolean to specify if given value is less or equal than expected maximum degree (true if yes).
checkMinDegree(int) - Method in class javax.management.relation.RoleInfo
Returns a boolean to specify if given value is greater or equal than expected minimum degree (true if yes).
checkRoleReading(String, String) - Method in class javax.management.relation.RelationService
Checks if given Role can be read in a relation of the given type.
checkRoleReading(String, String) - Method in interface javax.management.relation.RelationServiceMBean
Checks if given Role can be read in a relation of the given type.
checkRoleWriting(Role, String, Boolean) - Method in class javax.management.relation.RelationService
Checks if given Role can be set in a relation of given type.
checkRoleWriting(Role, String, Boolean) - Method in interface javax.management.relation.RelationServiceMBean
Checks if given Role can be set in a relation of given type.
classattr() - Static method in class javax.management.Query
Returns a new class attribute expression which can be used in any Query call that expects a ValueExp.
cleanup() - Method in interface javax.resource.spi.ManagedConnection
Application server calls this method to force any cleanup on the ManagedConnection instance.
clear() - Method in interface javax.management.openmbean.TabularData
Removes all CompositeData values (ie rows) from this TabularData instance.
clear() - Method in class javax.management.openmbean.TabularDataSupport
Removes all rows from this TabularDataSupport instance.
clear() - Method in class javax.servlet.jsp.JspWriter
Clear the contents of the buffer.
clear() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry
Removes all registered TypeMappings and encodingStyleURIs from this TypeMappingRegistry.
clearBody() - Method in interface javax.jms.Message
Clears out the message body.
clearBody() - Method in class javax.servlet.jsp.tagext.BodyContent
Clear the body without throwing any exceptions.
clearBuffer() - Method in class javax.servlet.jsp.JspWriter
Clears the current contents of the buffer.
clearContent() - Method in class javax.xml.soap.AttachmentPart
Clears out the content of this AttachmentPart object.
clearParameters() - Method in class javax.xml.transform.Transformer
Clear all parameters set with setParameter.
clearProperties() - Method in interface javax.jms.Message
Clears a message's properties.
clearWarnings() - Method in interface javax.resource.cci.Interaction
Clears all the warning reported by this Interaction instance.
clone() - Method in class javax.mail.Flags
Returns a clone of this Flags object.
clone() - Method in class javax.mail.internet.InternetAddress
Return a copy of this InternetAddress object.
clone() - Method in interface javax.management.Descriptor
Returns a new Descriptor which is a duplicate of the Descriptor.
clone() - Method in class javax.management.MBeanAttributeInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanConstructorInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanNotificationInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanOperationInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanParameterInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.modelmbean.DescriptorSupport
Returns a new Descriptor which is a duplicate of the Descriptor.
clone() - Method in class javax.management.modelmbean.ModelMBeanAttributeInfo
Creates and returns a new ModelMBeanAttributeInfo which is a duplicate of this ModelMBeanAttributeInfo.
clone() - Method in class javax.management.modelmbean.ModelMBeanConstructorInfo
Creates and returns a new ModelMBeanConstructorInfo which is a duplicate of this ModelMBeanConstructorInfo.
clone() - Method in interface javax.management.modelmbean.ModelMBeanInfo
Creates and returns a copy of this object.
clone() - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
clone() - Method in class javax.management.modelmbean.ModelMBeanNotificationInfo
Creates and returns a new ModelMBeanNotificationInfo which is a duplicate of this ModelMBeanNotificationInfo.
clone() - Method in class javax.management.modelmbean.ModelMBeanOperationInfo
Creates and returns a new ModelMBeanOperationInfo which is a duplicate of this ModelMBeanOperationInfo.
clone() - Method in class javax.management.openmbean.TabularDataSupport
Returns a clone of this TabularDataSupport instance: the clone is obtained by calling super.clone(), and then cloning the underlying map.
clone() - Method in class javax.management.relation.Role
Clone the role object.
clone() - Method in class javax.management.relation.RoleUnresolved
Clone this object.
clone() - Method in interface javax.resource.cci.Record
Creates and returns a copy of this object.
clone() - Method in class javax.servlet.http.Cookie
Overrides the standard java.lang.Object.clone method to return a copy of this cookie.
close() - Method in interface javax.jms.Connection
Closes the connection.
close() - Method in interface javax.jms.ConnectionConsumer
Closes the connection consumer.
close() - Method in interface javax.jms.MessageConsumer
Closes the message consumer.
close() - Method in interface javax.jms.MessageProducer
Closes the message producer.
close() - Method in interface javax.jms.QueueBrowser
Closes the QueueBrowser.
close() - Method in class javax.jms.QueueRequestor
Closes the QueueRequestor and its session.
close() - Method in interface javax.jms.Session
Closes the session.
close() - Method in class javax.jms.TopicRequestor
Closes the TopicRequestor and its session.
close(boolean) - Method in class javax.mail.Folder
Close this Folder.
close() - Method in class javax.mail.Service
Close this service and terminate its connection.
close() - Method in interface javax.resource.cci.Connection
Initiates close of the connection handle at the application level.
close() - Method in interface javax.resource.cci.Interaction
Closes the current Interaction and release all the resources held for this instance by the resource adapter.
close() - Method in class javax.servlet.jsp.JspWriter
Close the stream, flushing it first.
close() - Method in interface javax.xml.registry.Connection
Closes a Connection when it is no longer needed.
close() - Method in class javax.xml.soap.SOAPConnection
Closes this SOAPConnection object.
closed(ConnectionEvent) - Method in class javax.mail.event.ConnectionAdapter
closed(ConnectionEvent) - Method in interface javax.mail.event.ConnectionListener
Invoked when a Store/Folder/Transport is closed.
commit() - Method in interface javax.jms.Session
Commits all messages done in this transaction and releases any locks currently held.
commit() - Method in interface javax.jms.XASession
Throws a TransactionInProgressException, since it should not be called for an XASession object.
commit() - Method in interface javax.resource.cci.LocalTransaction
Commits the current local transaction and release all locks held by the underlying EIS instance.
commit() - Method in interface javax.resource.spi.LocalTransaction
Commit a local transaction
commit(Xid, boolean) - Method in interface javax.resource.spi.XATerminator
Commits the global transaction specified by xid.
commit() - Method in interface javax.security.jacc.PolicyConfiguration
This method is used to set to "inService" the state of the policy context whose interface is this PolicyConfiguration Object.
commit() - Method in interface javax.transaction.Transaction
Complete the transaction represented by this Transaction object.
commit() - Method in interface javax.transaction.TransactionManager
Complete the transaction associated with the current thread.
commit() - Method in interface javax.transaction.UserTransaction
Complete the transaction associated with the current thread.
commit(Xid, boolean) - Method in interface javax.transaction.xa.XAResource
Commits the global transaction specified by xid.
comparison - Variable in class javax.mail.search.ComparisonTerm
The comparison.
confirmAssociation(Association) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Confirms this Association by the User associated with the caller.
connect() - Method in class javax.mail.Service
A generic connect method that takes no parameters.
connect(String, String, String) - Method in class javax.mail.Service
Connect to the specified address.
connect(String, int, String, String) - Method in class javax.mail.Service
Similar to connect(host, user, password) except a specific port can be specified.
connectionClosed(ConnectionEvent) - Method in interface javax.resource.spi.ConnectionEventListener
Notifies that an application component has closed the connection.
connectionErrorOccurred(ConnectionEvent) - Method in interface javax.resource.spi.ConnectionEventListener
Notifies a connection related error.
contains(FetchProfile.Item) - Method in class javax.mail.FetchProfile
Returns true if the fetch profile contains given special item.
contains(String) - Method in class javax.mail.FetchProfile
Returns true if the fetch profile contains given header name.
contains(Flags.Flag) - Method in class javax.mail.Flags
Check whether the specified system flag is present in this Flags object.
contains(String) - Method in class javax.mail.Flags
Check whether the specified user flag is present in this Flags object.
contains(Flags) - Method in class javax.mail.Flags
Check whether all the flags in the specified Flags object are present in this Flags object.
containsHeader(String) - Method in interface javax.servlet.http.HttpServletResponse
Returns a boolean indicating whether the named response header has already been set.
containsHeader(String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call containsHeader(String name) on the wrapped response object.
containsKey(String) - Method in interface javax.management.openmbean.CompositeData
Returns true if and only if this CompositeData instance contains an item whose name is key.
containsKey(String) - Method in class javax.management.openmbean.CompositeDataSupport
Returns true if and only if this CompositeData instance contains an item whose name is key.
containsKey(String) - Method in class javax.management.openmbean.CompositeType
Returns true if this CompositeType instance defines an item whose name is itemName.
containsKey(Object[]) - Method in interface javax.management.openmbean.TabularData
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
containsKey(Object) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
containsKey(Object[]) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
containsObservedObject(ObjectName) - Method in class javax.management.monitor.Monitor
Tests whether the specified object is in the set of observed MBeans.
containsObservedObject(ObjectName) - Method in interface javax.management.monitor.MonitorMBean
Tests whether the specified object is in the set of observed MBeans.
containsProperty(String) - Method in interface javax.xml.rpc.handler.MessageContext
Returns true if the MessageContext contains a property with the specified name.
containsValue(Object) - Method in interface javax.management.openmbean.CompositeData
Returns true if and only if this CompositeData instance contains an item whose value is value.
containsValue(Object) - Method in class javax.management.openmbean.CompositeDataSupport
Returns true if and only if this CompositeData instance contains an item whose value is value.
containsValue(CompositeData) - Method in interface javax.management.openmbean.TabularData
Returns true if and only if this TabularData instance contains the specified CompositeData value.
containsValue(CompositeData) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains the specified CompositeData value.
containsValue(Object) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains the specified value.
content - Variable in class javax.mail.internet.MimeBodyPart
Byte array that holds the bytes of the content of this Part.
content - Variable in class javax.mail.internet.MimeMessage
Byte array that holds the bytes of this Message's content.
contentStream - Variable in class javax.mail.internet.MimeBodyPart
If the data for this body part was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this body part.
contentStream - Variable in class javax.mail.internet.MimeMessage
If the data for this message was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this message.
contentType - Variable in class javax.mail.Multipart
This field specifies the content-type of this multipart object.
contextDestroyed(ServletContextEvent) - Method in interface javax.servlet.ServletContextListener
Notification that the servlet context is about to be shut down.
contextInitialized(ServletContextEvent) - Method in interface javax.servlet.ServletContextListener
Notification that the web application initialization process is starting.
copyMessages(Message[], Folder) - Method in class javax.mail.Folder
Copy the specified Messages from this Folder into another Folder.
countAttachments() - Method in class javax.xml.soap.SOAPMessage
Gets a count of the number of attachments in this message.
create(int) - Method in class javax.mail.Folder
Create this folder on the Store.
create() - Method in interface javax.management.j2ee.ManagementHome
Creates an MEJB session object which provides access to the J2EE Management Model
create(Name) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
create(String) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
create(String, String, String) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
createAssociation(RegistryObject, Concept) - Method in interface javax.xml.registry.LifeCycleManager
Creates an Association instance using the specified parameters.
createAttachmentPart() - Method in class javax.xml.soap.SOAPMessage
Creates a new empty AttachmentPart object.
createAttachmentPart(DataHandler) - Method in class javax.xml.soap.SOAPMessage
Creates an AttachmentPart object and populates it using the given DataHandler object.
createAttachmentPart(Object, String) - Method in class javax.xml.soap.SOAPMessage
Creates an AttachmentPart object and populates it with the specified data of the specified content type.
createBrowser(Queue) - Method in interface javax.jms.QueueSession
Creates a QueueBrowser object to peek at the messages on the specified queue.
createBrowser(Queue, String) - Method in interface javax.jms.QueueSession
Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
createBrowser(Queue) - Method in interface javax.jms.Session
Creates a QueueBrowser object to peek at the messages on the specified queue.
createBrowser(Queue, String) - Method in interface javax.jms.Session
Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
createBytesMessage() - Method in interface javax.jms.Session
Creates a BytesMessage object.
createCall(QName) - Method in interface javax.xml.rpc.Service
Creates a Call instance.
createCall(QName, QName) - Method in interface javax.xml.rpc.Service
Creates a Call instance.
createCall(QName, String) - Method in interface javax.xml.rpc.Service
Creates a Call instance.
createCall() - Method in interface javax.xml.rpc.Service
Creates a Call object not associated with specific operation or target service endpoint.
createClassification(ClassificationScheme, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.
createClassification(ClassificationScheme, InternationalString, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.
createClassification(Concept) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.
createClassificationScheme(String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a ClassificationScheme given the specified String parameters.
createClassificationScheme(InternationalString, InternationalString) - Method in interface javax.xml.registry.LifeCycleManager
Creates a ClassificationScheme given the specified InternationalString parameters.
createClassificationScheme(Concept) - Method in interface javax.xml.registry.LifeCycleManager
Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.
createConcept(RegistryObject, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Concept instance using the specified parameters, where the name is a String.
createConcept(RegistryObject, InternationalString, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Concept instance using the specified parameters, where the name is an InternationalString.
createConfiguration(DeployableObject) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Retrieve the object that provides server-specific deployment configuration information for the J2EE deployable component.
createConnection() - Method in interface javax.jms.ConnectionFactory
Creates a connection with the default user identity.
createConnection(String, String) - Method in interface javax.jms.ConnectionFactory
Creates a connection with the specified user identity.
createConnection() - Method in class javax.xml.registry.ConnectionFactory
Create a named connection.
createConnection() - Method in class javax.xml.soap.SOAPConnectionFactory
Create a new SOAPConnection.
createConnectionConsumer(Destination, String, ServerSessionPool, int) - Method in interface javax.jms.Connection
Creates a connection consumer for this connection (optional operation).
createConnectionConsumer(Queue, String, ServerSessionPool, int) - Method in interface javax.jms.QueueConnection
Creates a connection consumer for this connection (optional operation).
createConnectionConsumer(Topic, String, ServerSessionPool, int) - Method in interface javax.jms.TopicConnection
Creates a connection consumer for this connection (optional operation).
createConnectionFactory(ConnectionManager) - Method in interface javax.resource.spi.ManagedConnectionFactory
Creates a Connection Factory instance.
createConnectionFactory() - Method in interface javax.resource.spi.ManagedConnectionFactory
Creates a Connection Factory instance.
createConsumer(Destination) - Method in interface javax.jms.Session
Creates a MessageConsumer for the specified destination.
createConsumer(Destination, String) - Method in interface javax.jms.Session
Creates a MessageConsumer for the specified destination, using a message selector.
createConsumer(Destination, String, boolean) - Method in interface javax.jms.Session
Creates MessageConsumer for the specified destination, using a message selector.
createDataContentHandler(String) - Method in class javax.activation.CommandMap
Locate a DataContentHandler that corresponds to the MIME type.
createDataContentHandler(String) - Method in interface javax.activation.DataContentHandlerFactory
Creates a new DataContentHandler object for the MIME type.
createDataContentHandler(String) - Method in class javax.activation.MailcapCommandMap
Return the DataContentHandler for the specified MIME type.
createDetail() - Method in class javax.xml.soap.SOAPFactory
Creates a new Detail object which serves as a container for DetailEntry objects.
createDurableConnectionConsumer(Topic, String, String, ServerSessionPool, int) - Method in interface javax.jms.Connection
Create a durable connection consumer for this connection (optional operation).
createDurableConnectionConsumer(Topic, String, String, ServerSessionPool, int) - Method in interface javax.jms.TopicConnection
Create a durable connection consumer for this connection (optional operation).
createDurableSubscriber(Topic, String) - Method in interface javax.jms.Session
Creates a durable subscriber to the specified topic.
createDurableSubscriber(Topic, String, String, boolean) - Method in interface javax.jms.Session
Creates a durable subscriber to the specified topic, using a message selector and specifying whether messages published by its own connection should be delivered to it.
createDurableSubscriber(Topic, String) - Method in interface javax.jms.TopicSession
Creates a durable subscriber to the specified topic.
createDurableSubscriber(Topic, String, String, boolean) - Method in interface javax.jms.TopicSession
Creates a durable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
createElement(Name) - Method in class javax.xml.soap.SOAPFactory
Create a SOAPElement object initialized with the given Name object.
createElement(String) - Method in class javax.xml.soap.SOAPFactory
Create a SOAPElement object initialized with the given local name.
createElement(String, String, String) - Method in class javax.xml.soap.SOAPFactory
Create a new SOAPElement object with the given local name, prefix and uri.
createEmailAddress(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an EmailAddress instance using an address as the parameter.
createEmailAddress(String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an EmailAddress instance using both an address and a type as parameters.
createEndpoint(XAResource) - Method in interface javax.resource.spi.endpoint.MessageEndpointFactory
This is used to create a message endpoint.
createExternalIdentifier(ClassificationScheme, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.
createExternalIdentifier(ClassificationScheme, InternationalString, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.
createExternalLink(String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an ExternalLink instance using the specified parameters, where the description is a String.
createExternalLink(String, InternationalString) - Method in interface javax.xml.registry.LifeCycleManager
Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.
createExtrinsicObject(DataHandler) - Method in interface javax.xml.registry.LifeCycleManager
Creates an ExtrinsicObject instance using the specified parameters.
createFederatedConnection(Collection) - Method in class javax.xml.registry.ConnectionFactory
Create a FederatedConnection.
createIndexedRecord(String) - Method in interface javax.resource.cci.RecordFactory
Creates a IndexedRecord.
createInteraction() - Method in interface javax.resource.cci.Connection
Creates an Interaction associated with this Connection.
createInternationalString() - Method in interface javax.xml.registry.LifeCycleManager
Creates an empty InternationalString instance.
createInternationalString(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an InternationalString instance using a String parameter and the default Locale.
createInternationalString(Locale, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an InternationalString instance using the specified Locale and String parameters.
createInternetHeaders(InputStream) - Method in class javax.mail.internet.MimeMessage
Create and return an InternetHeaders object that loads the headers from the given InputStream.
createInternetHeaders(InputStream) - Method in class javax.mail.internet.MimeMultipart
Create and return an InternetHeaders object that loads the headers from the given InputStream.
createKey(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Key instance from an ID.
createLocalizedString(Locale, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a LocalizedString instance using the specified Locale and String parameters.
createLocalizedString(Locale, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a LocalizedString instance using the specified Locale, String, and character set parameters.
createMBean(String, ObjectName) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBeanServer() - Static method in class javax.management.MBeanServerFactory
Return a new object implementing the MBeanServer interface with a standard default domain name.
createMBeanServer(String) - Static method in class javax.management.MBeanServerFactory
Return a new object implementing the MBeanServer interface with the specified default domain name.
createManagedConnection(Subject, ConnectionRequestInfo) - Method in interface javax.resource.spi.ManagedConnectionFactory
Creates a new physical connection to the underlying EIS resource manager.
createMapMessage() - Method in interface javax.jms.Session
Creates a MapMessage object.
createMappedRecord(String) - Method in interface javax.resource.cci.RecordFactory
Creates a MappedRecord.
createMessage() - Method in interface javax.jms.Session
Creates a Message object.
createMessage() - Method in class javax.xml.soap.MessageFactory
Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
createMessage(MimeHeaders, InputStream) - Method in class javax.xml.soap.MessageFactory
Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
createMimeBodyPart(InternetHeaders, byte[]) - Method in class javax.mail.internet.MimeMultipart
Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
createMimeBodyPart(InputStream) - Method in class javax.mail.internet.MimeMultipart
Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
createName(String, String, String) - Method in interface javax.xml.soap.SOAPEnvelope
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
createName(String) - Method in interface javax.xml.soap.SOAPEnvelope
Creates a new Name object initialized with the given local name.
createName(String, String, String) - Method in class javax.xml.soap.SOAPFactory
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
createName(String) - Method in class javax.xml.soap.SOAPFactory
Creates a new Name object initialized with the given local name.
createObject(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates instances of information model interfaces (factory method).
createObjectMessage() - Method in interface javax.jms.Session
Creates an ObjectMessage object.
createObjectMessage(Serializable) - Method in interface javax.jms.Session
Creates an initialized ObjectMessage object.
createOrganization(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an Organization instance using the specified name, where the name is a String.
createOrganization(InternationalString) - Method in interface javax.xml.registry.LifeCycleManager
Creates an Organization instance using the specified name, where the name is an InternationalString.
createPersonName(String, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a PersonName instance using the specified first, middle, and last names.
createPersonName(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a PersonName instance using the specified full name.
createPostalAddress(String, String, String, String, String, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a PostalAddress instance using the specified parameters.
createProducer(Destination) - Method in interface javax.jms.Session
Creates a MessageProducer to send messages to the specified destination.
createPublisher(Topic) - Method in interface javax.jms.TopicSession
Creates a publisher for the specified topic.
createQuery(int, String) - Method in interface javax.xml.registry.DeclarativeQueryManager
Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.
createQueue(String) - Method in interface javax.jms.QueueSession
Creates a queue identity given a Queue name.
createQueue(String) - Method in interface javax.jms.Session
Creates a queue identity given a Queue name.
createQueueConnection() - Method in interface javax.jms.QueueConnectionFactory
Creates a queue connection with the default user identity.
createQueueConnection(String, String) - Method in interface javax.jms.QueueConnectionFactory
Creates a queue connection with the specified user identity.
createQueueSession(boolean, int) - Method in interface javax.jms.QueueConnection
Creates a QueueSession object.
createQueueSession(boolean, int) - Method in interface javax.jms.XAQueueConnection
Creates an XAQueueSession object.
createReceiver(Queue) - Method in interface javax.jms.QueueSession
Creates a QueueReceiver object to receive messages from the specified queue.
createReceiver(Queue, String) - Method in interface javax.jms.QueueSession
Creates a QueueReceiver object to receive messages from the specified queue using a message selector.
createRegistryPackage(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a RegistryPackage instance using the specified name, where the name is a String.
createRegistryPackage(InternationalString) - Method in interface javax.xml.registry.LifeCycleManager
Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.
createRelation(String, String, RoleList) - Method in class javax.management.relation.RelationService
Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
createRelation(String, String, RoleList) - Method in interface javax.management.relation.RelationServiceMBean
Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
createRelationType(String, RoleInfo[]) - Method in class javax.management.relation.RelationService
Creates a relation type (a RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
createRelationType(String, RoleInfo[]) - Method in interface javax.management.relation.RelationServiceMBean
Creates a relation type (RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
createSender(Queue) - Method in interface javax.jms.QueueSession
Creates a QueueSender object to send messages to the specified queue.
createService(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Service instance using the specified name, where the name is a String.
createService(InternationalString) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Service instance using the specified name, where the name is an InternationalString.
createService(URL, QName) - Method in class javax.xml.rpc.ServiceFactory
Create a Service instance.
createService(QName) - Method in class javax.xml.rpc.ServiceFactory
Create a Service instance.
createServiceBinding() - Method in interface javax.xml.registry.LifeCycleManager
Creates an empty ServiceBinding instance.
createSession(boolean, int) - Method in interface javax.jms.Connection
Creates a Session object.
createSession(boolean, int) - Method in interface javax.jms.XAConnection
Creates an Session object.
createSlot(String, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Slot instance using the specified parameters, where the value is a String.
createSlot(String, Collection, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.
createSpecificationLink() - Method in interface javax.xml.registry.LifeCycleManager
Creates an empty SpecificationLink instance.
createStreamMessage() - Method in interface javax.jms.Session
Creates a StreamMessage object.
createSubscriber(Topic) - Method in interface javax.jms.TopicSession
Creates a nondurable subscriber to the specified topic.
createSubscriber(Topic, String, boolean) - Method in interface javax.jms.TopicSession
Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
createTelephoneNumber() - Method in interface javax.xml.registry.LifeCycleManager
Creates an empty TelephoneNumber instance.
createTemporaryQueue() - Method in interface javax.jms.QueueSession
Creates a TemporaryQueue object.
createTemporaryQueue() - Method in interface javax.jms.Session
Creates a TemporaryQueue object.
createTemporaryTopic() - Method in interface javax.jms.Session
Creates a TemporaryTopic object.
createTemporaryTopic() - Method in interface javax.jms.TopicSession
Creates a TemporaryTopic object.
createTextMessage() - Method in interface javax.jms.Session
Creates a TextMessage object.
createTextMessage(String) - Method in interface javax.jms.Session
Creates an initialized TextMessage object.
createTimer(long, Serializable) - Method in interface javax.ejb.TimerService
Create a single-action timer that expires after a specified duration.
createTimer(long, long, Serializable) - Method in interface javax.ejb.TimerService
Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
createTimer(Date, Serializable) - Method in interface javax.ejb.TimerService
Create a single-action timer that expires at a given point in time.
createTimer(Date, long, Serializable) - Method in interface javax.ejb.TimerService
Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
createTimer() - Method in interface javax.resource.spi.BootstrapContext
Creates a new java.util.Timer instance.
createTopic(String) - Method in interface javax.jms.Session
Creates a topic identity given a Topic name.
createTopic(String) - Method in interface javax.jms.TopicSession
Creates a topic identity given a Topic name.
createTopicConnection() - Method in interface javax.jms.TopicConnectionFactory
Creates a topic connection with the default user identity.
createTopicConnection(String, String) - Method in interface javax.jms.TopicConnectionFactory
Creates a topic connection with the specified user identity.
createTopicSession(boolean, int) - Method in interface javax.jms.TopicConnection
Creates a TopicSession object.
createTopicSession(boolean, int) - Method in interface javax.jms.XATopicConnection
Creates an XATopicSession object.
createTypeMapping() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry
Creates a new empty TypeMapping object.
createUser() - Method in interface javax.xml.registry.LifeCycleManager
Creates an empty User instance.
createXAConnection() - Method in interface javax.jms.XAConnectionFactory
Creates an XAConnection with the default user identity.
createXAConnection(String, String) - Method in interface javax.jms.XAConnectionFactory
Creates an XA connection with the specified user identity.
createXAQueueConnection() - Method in interface javax.jms.XAQueueConnectionFactory
Creates an XA queue connection with the default user identity.
createXAQueueConnection(String, String) - Method in interface javax.jms.XAQueueConnectionFactory
Creates an XA queue connection with the specified user identity.
createXAQueueSession() - Method in interface javax.jms.XAQueueConnection
Creates an XAQueueSession object.
createXASession() - Method in interface javax.jms.XAConnection
Creates an XASession object.
createXATopicConnection() - Method in interface javax.jms.XATopicConnectionFactory
Creates an XA topic connection with the default user identity.
createXATopicConnection(String, String) - Method in interface javax.jms.XATopicConnectionFactory
Creates an XA topic connection with the specified user identity.
createXATopicSession() - Method in interface javax.jms.XATopicConnection
Creates an XATopicSession object.

D

DATE - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.util.Date.
DConfigBean - interface javax.enterprise.deploy.spi.DConfigBean.
The DConfigBean is a deployment configuration bean (DConfigBean) that is associated with one or more deployment descriptor beans, (DDBean).
DConfigBeanRoot - interface javax.enterprise.deploy.spi.DConfigBeanRoot.
A J2EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents.
DConfigBeanVersionType - class javax.enterprise.deploy.shared.DConfigBeanVersionType.
Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.
DConfigBeanVersionType(int) - Constructor for class javax.enterprise.deploy.shared.DConfigBeanVersionType
Construct a new enumeration value with the given integer value.
DConfigBeanVersionUnsupportedException - exception javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException.
This exception is to report that there is no support for the DConfigBean version requested.
DConfigBeanVersionUnsupportedException(String) - Constructor for class javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
Creates an new DConfigBeanVersionUnsupportedException object.
DDBean - interface javax.enterprise.deploy.model.DDBean.
An interface for beans that represent a fragment of a standard deployment descriptor.
DDBeanRoot - interface javax.enterprise.deploy.model.DDBeanRoot.
An interface that represents the root of a standard deployment descriptor.
DEFAULT_BUFFER - Static variable in class javax.servlet.jsp.JspWriter
Constant indicating that the Writer is buffered and is using the implementation default buffer size.
DEFAULT_CHARSET_NAME - Static variable in interface javax.xml.registry.infomodel.LocalizedString
The default name returned by getCharsetName if no other name has explicitly been set.
DEFAULT_DELIVERY_MODE - Static variable in interface javax.jms.Message
The message producer's default delivery mode is PERSISTENT.
DEFAULT_PRIORITY - Static variable in interface javax.jms.Message
The message producer's default priority is 4.
DEFAULT_TIME_TO_LIVE - Static variable in interface javax.jms.Message
The message producer's default time to live is unlimited; the message never expires.
DELETED - Static variable in class javax.mail.Flags.Flag
This message is marked deleted.
DELETED - Static variable in class javax.mail.event.FolderEvent
The folder was deleted.
DIGEST_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest
String identifier for Digest authentication.
DISCONNECTED - Static variable in class javax.mail.event.ConnectionEvent
A connection was disconnected (not currently used).
DISTRIBUTE - Static variable in class javax.enterprise.deploy.shared.CommandType
The DeploymentManger action operation being processed is distribute.
DIV - Static variable in class javax.management.Query
A code representing the Query.div(javax.management.ValueExp, javax.management.ValueExp) expression.
DOCTYPE_PUBLIC - Static variable in class javax.xml.transform.OutputKeys
doctype-public = string.
DOCTYPE_SYSTEM - Static variable in class javax.xml.transform.OutputKeys
doctype-system = string.
DOMLocator - interface javax.xml.transform.dom.DOMLocator.
Indicates the position of a node in a source DOM, intended primarily for error reporting.
DOMResult - class javax.xml.transform.dom.DOMResult.
Acts as a holder for a transformation result tree, in the form of a Document Object Model (DOM) tree.
DOMResult() - Constructor for class javax.xml.transform.dom.DOMResult
Zero-argument default constructor.
DOMResult(Node) - Constructor for class javax.xml.transform.dom.DOMResult
Use a DOM node to create a new output target.
DOMResult(Node, String) - Constructor for class javax.xml.transform.dom.DOMResult
Create a new output target with a DOM node.
DOMSource - class javax.xml.transform.dom.DOMSource.
Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.
DOMSource() - Constructor for class javax.xml.transform.dom.DOMSource
Zero-argument default constructor.
DOMSource(Node) - Constructor for class javax.xml.transform.dom.DOMSource
Create a new input source with a DOM node.
DOMSource(Node, String) - Constructor for class javax.xml.transform.dom.DOMSource
Create a new input source with a DOM node, and with the system ID also passed in as the base URI.
DOUBLE - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Double.
DRAFT - Static variable in class javax.mail.Flags.Flag
This message is a draft.
DUPS_OK_ACKNOWLEDGE - Static variable in interface javax.jms.Session
This acknowledgment mode instructs the session to lazily acknowledge the delivery of messages.
DataContentHandler - interface javax.activation.DataContentHandler.
The DataContentHandler interface is implemented by objects that can be used to extend the capabilities of the DataHandler's implementation of the Transferable interface.
DataContentHandlerFactory - interface javax.activation.DataContentHandlerFactory.
This interface defines a factory for DataContentHandlers.
DataHandler - class javax.activation.DataHandler.
The DataHandler class provides a consistent interface to data available in many different sources and formats.
DataHandler(DataSource) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance referencing the specified DataSource.
DataHandler(Object, String) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance representing an object of this MIME type.
DataHandler(URL) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance referencing a URL.
DataSource - interface javax.activation.DataSource.
The DataSource interface provides the JavaBeans Activation Framework with an abstraction of some arbitrary collection of data.
DateTerm - class javax.mail.search.DateTerm.
This class implements comparisons for Dates
DateTerm(int, Date) - Constructor for class javax.mail.search.DateTerm
Constructor.
DeclarativeQueryManager - interface javax.xml.registry.DeclarativeQueryManager.
This interface provides the ability to execute declarative queries (e.g.
DefaultLoaderRepository - class javax.management.DefaultLoaderRepository.
Deprecated. Use MBeanServer.getClassLoaderRepository()} instead.
DefaultLoaderRepository() - Constructor for class javax.management.DefaultLoaderRepository
Deprecated.
DefaultLoaderRepository - class javax.management.loading.DefaultLoaderRepository.
Deprecated. Use MBeanServer.getClassLoaderRepository()} instead.
DefaultLoaderRepository() - Constructor for class javax.management.loading.DefaultLoaderRepository
Deprecated.
DeleteException - exception javax.xml.registry.DeleteException.
A RegistryException that occurs during a delete action.
DeleteException() - Constructor for class javax.xml.registry.DeleteException
Constructs a JAXRException object with no reason or embedded Throwable.
DeleteException(String) - Constructor for class javax.xml.registry.DeleteException
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
DeleteException(String, Throwable) - Constructor for class javax.xml.registry.DeleteException
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
DeleteException(Throwable) - Constructor for class javax.xml.registry.DeleteException
Constructs a JAXRException object initialized with the given Throwable object.
DeliveryMode - interface javax.jms.DeliveryMode.
The delivery modes supported by the JMS API are PERSISTENT and NON_PERSISTENT.
DeployableObject - interface javax.enterprise.deploy.model.DeployableObject.
The DeployableObject interface is an abstract representation of a J2EE deployable module (JAR, WAR, RAR, EAR).
DeploymentConfiguration - interface javax.enterprise.deploy.spi.DeploymentConfiguration.
An interface that defines a container for all the server-specific configuration information for a single top-level J2EE module.
DeploymentFactory - interface javax.enterprise.deploy.spi.factories.DeploymentFactory.
The DeploymentFactory interface is a deployment driver for a J2EE plaform product.
DeploymentFactoryManager - class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager.
The DeploymentFactoryManager class is a central registry for J2EE DeploymentFactory objects.
DeploymentManager - interface javax.enterprise.deploy.spi.DeploymentManager.
The DeploymentManager object provides the core set of functions a J2EE platform must provide for J2EE application deployment.
DeploymentManagerCreationException - exception javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException.
This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.
DeploymentManagerCreationException(String) - Constructor for class javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
Creates an new DeploymentManagerCreationException object.
DeploymentStatus - interface javax.enterprise.deploy.spi.status.DeploymentStatus.
The DeploymentStatus interface provides information about the progress status of a deployment action.
Descriptor - interface javax.management.Descriptor.
This interface represents the behavioral metadata set for a JMX Element.
DescriptorAccess - interface javax.management.DescriptorAccess.
This interface is used to gain access to descriptors of the Descriptor class which are associated with a JMX component, i.e.
DescriptorSupport - class javax.management.modelmbean.DescriptorSupport.
This class represents the metadata set for a ModelMBean element.
DescriptorSupport() - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor default constructor.
DescriptorSupport(int) - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor constructor.
DescriptorSupport(DescriptorSupport) - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor constructor taking a Descriptor as parameter.
DescriptorSupport(String) - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor constructor taking an XML String.
DescriptorSupport(String[], Object[]) - Constructor for class javax.management.modelmbean.DescriptorSupport
Constructor taking field names and field values.
DescriptorSupport(String[]) - Constructor for class javax.management.modelmbean.DescriptorSupport
Constructor taking fields in the fieldName=fieldValue format.
DeserializationContext - interface javax.xml.rpc.encoding.DeserializationContext.
The javax.xml.rpc.encoding.DeserializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner.
Deserializer - interface javax.xml.rpc.encoding.Deserializer.
The javax.xml.rpc.encoding.Deserializer interface defines a base interface for deserializers.
DeserializerFactory - interface javax.xml.rpc.encoding.DeserializerFactory.
The javax.xml.rpc.encoding.DeserializerFactory is a factory of deserializers.
Destination - interface javax.jms.Destination.
A Destination object encapsulates a provider-specific address.
Detail - interface javax.xml.soap.Detail.
A container for DetailEntry objects.
DetailEntry - interface javax.xml.soap.DetailEntry.
The content for a Detail object, giving details for a SOAPFault object.
DissociatableManagedConnection - interface javax.resource.spi.DissociatableManagedConnection.
This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation.
DocumentBuilder - class javax.xml.parsers.DocumentBuilder.
Defines the API to obtain DOM Document instances from an XML document.
DocumentBuilder() - Constructor for class javax.xml.parsers.DocumentBuilder
DocumentBuilderFactory - class javax.xml.parsers.DocumentBuilderFactory.
Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
DocumentBuilderFactory() - Constructor for class javax.xml.parsers.DocumentBuilderFactory
DoubleHolder - class javax.xml.rpc.holders.DoubleHolder.
DoubleHolder() - Constructor for class javax.xml.rpc.holders.DoubleHolder
DoubleHolder(double) - Constructor for class javax.xml.rpc.holders.DoubleHolder
DoubleWrapperHolder - class javax.xml.rpc.holders.DoubleWrapperHolder.
DoubleWrapperHolder() - Constructor for class javax.xml.rpc.holders.DoubleWrapperHolder
DoubleWrapperHolder(Double) - Constructor for class javax.xml.rpc.holders.DoubleWrapperHolder
DuplicateKeyException - exception javax.ejb.DuplicateKeyException.
The DuplicateKeyException exception is thrown if an entity EJB object cannot be created because an object with the same key already exists.
DuplicateKeyException() - Constructor for class javax.ejb.DuplicateKeyException
Constructs a DuplicateKeyException with no detail message.
DuplicateKeyException(String) - Constructor for class javax.ejb.DuplicateKeyException
Constructs a DuplicateKeyException with the specified detail message.
DynamicAttributes - interface javax.servlet.jsp.tagext.DynamicAttributes.
For a tag to declare that it accepts dynamic attributes, it must implement this interface.
DynamicMBean - interface javax.management.DynamicMBean.
Defines the methods that should be implemented by a Dynamic MBean (MBean that exposes a dynamic management interface).
date - Variable in class javax.mail.search.DateTerm
The date.
dbgTag - Variable in class javax.management.monitor.Monitor
Deprecated. No replacement.
debug - Variable in class javax.mail.Service
Debug flag for this service.
decode(InputStream, String) - Static method in class javax.mail.internet.MimeUtility
Decode the given input stream.
decodeText(String) - Static method in class javax.mail.internet.MimeUtility
Decode "unstructured" headers, that is, headers that are defined as '*text' as per RFC 822.
decodeWord(String) - Static method in class javax.mail.internet.MimeUtility
The string is parsed using the rules in RFC 2047 for parsing an "encoded-word".
delete() - Method in interface javax.jms.TemporaryQueue
Deletes this temporary queue.
delete() - Method in interface javax.jms.TemporaryTopic
Deletes this temporary topic.
delete(boolean) - Method in class javax.mail.Folder
Delete this Folder.
delete() - Method in interface javax.security.jacc.PolicyConfiguration
Causes all policy statements to be deleted from this PolicyConfiguration and sets its internal state such that calling any method, other than delete, getContextID, or inService on the PolicyConfiguration will be rejected and cause an UnsupportedOperationException to be thrown.
deleteAssociations(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the Associations corresponding to the specified Keys.
deleteClassificationSchemes(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the ClassificationSchemes corresponding to the specified Keys.
deleteConcepts(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the Concepts corresponding to the specified Keys.
deleteObjects(Collection) - Method in interface javax.xml.registry.LifeCycleManager
Deletes one or more previously submitted objects from the registry using the object keys.
deleteObjects(Collection, String) - Method in interface javax.xml.registry.LifeCycleManager
Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.
deleteOrganizations(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the organizations corresponding to the specified Keys.
deleteServiceBindings(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the ServiceBindings corresponding to the specified Keys.
deleteServices(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the services corresponding to the specified Keys.
deletesAreDetected(int) - Method in interface javax.resource.cci.ResultSetInfo
delistResource(XAResource, int) - Method in interface javax.transaction.Transaction
Disassociate the resource specified from the transaction associated with the target Transaction object.
deprecateObjects(Collection) - Method in interface javax.xml.registry.LifeCycleManager
Deprecates one or more previously submitted objects.
description - Variable in class javax.management.MBeanFeatureInfo
The human-readable description of the feature.
deserialize(ObjectName, byte[]) - Method in interface javax.management.MBeanServer
Deprecated. Use getClassLoaderFor to obtain the appropriate class loader for deserialization.
deserialize(String, byte[]) - Method in interface javax.management.MBeanServer
Deprecated. Use MBeanServer.getClassLoaderRepository() to obtain the class loader repository and use it to deserialize.
deserialize(String, ObjectName, byte[]) - Method in interface javax.management.MBeanServer
Deprecated. Use getClassLoader to obtain the class loader for deserialization.
destroy() - Method in interface javax.resource.spi.ManagedConnection
Destroys the physical connection to the underlying resource manager.
destroy() - Method in interface javax.servlet.Filter
Called by the web container to indicate to a filter that it is being taken out of service.
destroy() - Method in class javax.servlet.GenericServlet
Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.
destroy() - Method in interface javax.servlet.Servlet
Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.
destroy() - Method in class javax.xml.rpc.handler.GenericHandler
The destroy method indicates the end of lifecycle for a Handler instance.
destroy() - Method in interface javax.xml.rpc.handler.Handler
The destroy method indicates the end of lifecycle for a Handler instance.
destroy() - Method in interface javax.xml.rpc.handler.HandlerChain
Indicates the end of lifecycle for a HandlerChain.
destroy() - Method in interface javax.xml.rpc.server.ServiceLifecycle
JAX-RPC runtime system ends the lifecycle of a service endpoint instance by invoking the destroy method.
detachNode() - Method in interface javax.xml.soap.Node
Removes this Node object from the tree.
dh - Variable in class javax.mail.internet.MimeBodyPart
The DataHandler object representing this Part's content.
dh - Variable in class javax.mail.internet.MimeMessage
The DataHandler object representing this Message's content.
disableAllAttributes() - Method in class javax.management.AttributeChangeNotificationFilter
Disables all the attribute names.
disableAllObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter
Disables any MBeanServerNotification (all ObjectNames are deselected).
disableAllTypes() - Method in class javax.management.NotificationFilterSupport
Disables all notification types.
disableAttribute(String) - Method in class javax.management.AttributeChangeNotificationFilter
Disables all the attribute change notifications the attribute name of which equals the specified attribute name to be sent to the listener.
disableObjectName(ObjectName) - Method in class javax.management.relation.MBeanServerNotificationFilter
Disables MBeanServerNotifications concerning given ObjectName.
disableType(String) - Method in class javax.management.NotificationFilterSupport
Removes the given prefix from the prefix list.
disconnected(ConnectionEvent) - Method in class javax.mail.event.ConnectionAdapter
disconnected(ConnectionEvent) - Method in interface javax.mail.event.ConnectionListener
Invoked when a Store is disconnected.
dispatch(Object) - Method in class javax.mail.event.ConnectionEvent
Invokes the appropriate ConnectionListener method
dispatch(Object) - Method in class javax.mail.event.FolderEvent
Invokes the appropriate FolderListener method
dispatch(Object) - Method in class javax.mail.event.MailEvent
This method invokes the appropriate method on a listener for this event.
dispatch(Object) - Method in class javax.mail.event.MessageChangedEvent
Invokes the appropriate MessageChangedListener method.
dispatch(Object) - Method in class javax.mail.event.MessageCountEvent
Invokes the appropriate MessageCountListener method.
dispatch(Object) - Method in class javax.mail.event.StoreEvent
Invokes the appropriate StoreListener method.
dispatch(Object) - Method in class javax.mail.event.TransportEvent
Invokes the appropriate TransportListener method.
dissociateConnections() - Method in interface javax.resource.spi.DissociatableManagedConnection
This method is called by an application server (that is capable of lazy connection association optimization) in order to dissociate a ManagedConnection instance from all of its connection handles.
distribute(Target[], File, File) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
distribute(Target[], InputStream, InputStream) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
div(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a binary expression representing the quotient of two numeric values.
doAfterBody() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
After the body evaluation: do not reevaluate and continue with the page.
doAfterBody() - Method in interface javax.servlet.jsp.tagext.IterationTag
Process body (re)evaluation.
doAfterBody() - Method in class javax.servlet.jsp.tagext.TagSupport
Default processing for a body.
doCatch(Throwable) - Method in interface javax.servlet.jsp.tagext.TryCatchFinally
Invoked if a Throwable occurs while evaluating the BODY inside a tag or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().
doDelete(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a DELETE request.
doEndTag() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
Default processing of the end tag returning EVAL_PAGE.
doEndTag() - Method in interface javax.servlet.jsp.tagext.Tag
Process the end tag for this instance.
doEndTag() - Method in class javax.servlet.jsp.tagext.TagAdapter
Must not be called.
doEndTag() - Method in class javax.servlet.jsp.tagext.TagSupport
Default processing of the end tag returning EVAL_PAGE.
doFilter(ServletRequest, ServletResponse, FilterChain) - Method in interface javax.servlet.Filter
The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain.
doFilter(ServletRequest, ServletResponse) - Method in interface javax.servlet.FilterChain
Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.
doFinally() - Method in interface javax.servlet.jsp.tagext.TryCatchFinally
Invoked in all cases after doEndTag() for any class implementing Tag, IterationTag or BodyTag.
doGet(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a GET request.
doHead(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Receives an HTTP HEAD request from the protected service method and handles the request.
doInitBody() - Method in interface javax.servlet.jsp.tagext.BodyTag
Prepare for evaluation of the body.
doInitBody() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
Prepare for evaluation of the body just before the first body evaluation: no action.
doOptions(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a OPTIONS request.
doPost(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a POST request.
doPut(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a PUT request.
doStartTag() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
Default processing of the start tag returning EVAL_BODY_BUFFERED.
doStartTag() - Method in interface javax.servlet.jsp.tagext.Tag
Process the start tag for this instance.
doStartTag() - Method in class javax.servlet.jsp.tagext.TagAdapter
Must not be called.
doStartTag() - Method in class javax.servlet.jsp.tagext.TagSupport
Default processing of the start tag, returning SKIP_BODY.
doTag() - Method in interface javax.servlet.jsp.tagext.SimpleTag
Called by the container to invoke this tag.
doTag() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport
Default processing of the tag does nothing.
doTrace(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a TRACE request.
doWork(Work) - Method in interface javax.resource.spi.work.WorkManager
Accepts a Work instance for processing.
doWork(Work, long, ExecutionContext, WorkListener) - Method in interface javax.resource.spi.work.WorkManager
Accepts a Work instance for processing.
ds - Variable in class javax.mail.internet.MimeMultipart
The DataSource supplying our InputStream.

E

EAR - Static variable in class javax.enterprise.deploy.shared.ModuleType
The module is an EAR archive.
EISSystemException - exception javax.resource.spi.EISSystemException.
An EISSystemException is used to indicate any EIS specific system-level error conditions.
EISSystemException() - Constructor for class javax.resource.spi.EISSystemException
Constructs a new instance with null as its detail message.
EISSystemException(String) - Constructor for class javax.resource.spi.EISSystemException
Constructs a new instance with the specified detail message.
EISSystemException(Throwable) - Constructor for class javax.resource.spi.EISSystemException
Constructs a new throwable with the specified cause.
EISSystemException(String, Throwable) - Constructor for class javax.resource.spi.EISSystemException
Constructs a new throwable with the specified detail message and cause.
EISSystemException(String, String) - Constructor for class javax.resource.spi.EISSystemException
Constructs a new throwable with the specified detail message and an error code.
EJB - Static variable in class javax.enterprise.deploy.shared.ModuleType
The module is an Enterprise Java Bean archive.
EJBContext - interface javax.ejb.EJBContext.
The EJBContext interface provides an instance with access to the container-provided runtime context of an enterprise Bean instance.
EJBException - exception javax.ejb.EJBException.
The EJBException exception is thrown by an enterprise Bean instance to its container to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g. the instance failed to open a database connection).
EJBException() - Constructor for class javax.ejb.EJBException
Constructs an EJBException with no detail message.
EJBException(String) - Constructor for class javax.ejb.EJBException
Constructs an EJBException with the specified detailed message.
EJBException(Exception) - Constructor for class javax.ejb.EJBException
Constructs an EJBException that embeds the originally thrown exception.
EJBException(String, Exception) - Constructor for class javax.ejb.EJBException
Constructs an EJBException that embeds the originally thrown exception with the specified detail message.
EJBHome - interface javax.ejb.EJBHome.
The EJBHome interface must be extended by all enterprise Beans' remote home interfaces.
EJBLocalHome - interface javax.ejb.EJBLocalHome.
The EJBLocalHome interface must be extended by all enterprise Beans' local home interfaces.
EJBLocalObject - interface javax.ejb.EJBLocalObject.
The EJBLocalObject interface must be extended by all enterprise Beans' local interfaces.
EJBMetaData - interface javax.ejb.EJBMetaData.
The EJBMetaData interface allows a client to obtain the enterprise Bean's meta-data information.
EJBMethodPermission - class javax.security.jacc.EJBMethodPermission.
Class for EJB method permissions.
EJBMethodPermission(String, String) - Constructor for class javax.security.jacc.EJBMethodPermission
Creates a new EJBMethodPermission with the specified name and actions.
EJBMethodPermission(String, String, String, String[]) - Constructor for class javax.security.jacc.EJBMethodPermission
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodName, methodInterface, and methodParams.
EJBMethodPermission(String, String, Method) - Constructor for class javax.security.jacc.EJBMethodPermission
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodInterface, and the Method object.
EJBObject - interface javax.ejb.EJBObject.
The EJBObject interface is extended by all enterprise Beans' remote interfaces.
EJBRoleRefPermission - class javax.security.jacc.EJBRoleRefPermission.
Class for EJB isCallerInRole (String reference) permissions.
EJBRoleRefPermission(String, String) - Constructor for class javax.security.jacc.EJBRoleRefPermission
Creates a new EJBRoleRefPermission with the specified name and actions.
EJBStats - interface javax.management.j2ee.statistics.EJBStats.
Specifies statistics provided by all EJB component types.
ELException - exception javax.servlet.jsp.el.ELException.
Represents any of the exception conditions that arise during the operation evaluation of the evaluator.
ELException() - Constructor for class javax.servlet.jsp.el.ELException
Creates an ELException with no detail message.
ELException(String) - Constructor for class javax.servlet.jsp.el.ELException
Creates an ELException with the provided detail message.
ELException(Throwable) - Constructor for class javax.servlet.jsp.el.ELException
Creates an ELException with the given root cause.
ELException(String, Throwable) - Constructor for class javax.servlet.jsp.el.ELException
Creates an ELException with the given detail message and root cause.
ELParseException - exception javax.servlet.jsp.el.ELParseException.
Represents a parsing error encountered while parsing an EL expression.
ELParseException() - Constructor for class javax.servlet.jsp.el.ELParseException
Creates an ELParseException with no detail message.
ELParseException(String) - Constructor for class javax.servlet.jsp.el.ELParseException
Creates an ELParseException with the provided detail message.
EMAIL_ADDRESS - Static variable in interface javax.xml.registry.LifeCycleManager
ENCODING - Static variable in class javax.xml.transform.OutputKeys
encoding = string.
ENCODINGSTYLE_URI_PROPERTY - Static variable in interface javax.xml.rpc.Call
Standard property for encoding Style: Encoding style specified as a namespace URI.
ENDPOINT_ADDRESS_PROPERTY - Static variable in interface javax.xml.rpc.Stub
Standard property: Target service endpoint address.
ENVELOPE - Static variable in class javax.mail.FetchProfile.Item
This is the Envelope item.
ENVELOPE_CHANGED - Static variable in class javax.mail.event.MessageChangedEvent
The message's envelope (headers, but not body) changed.
EOF - Static variable in class javax.mail.internet.HeaderTokenizer.Token
Token type indicating end of input.
EQ - Static variable in class javax.mail.search.ComparisonTerm
EQ - Static variable in class javax.management.Query
A code representing the Query.eq(javax.management.ValueExp, javax.management.ValueExp) query.
EVAL_BODY_AGAIN - Static variable in interface javax.servlet.jsp.tagext.IterationTag
Request the reevaluation of some body.
EVAL_BODY_BUFFERED - Static variable in interface javax.servlet.jsp.tagext.BodyTag
Request the creation of new buffer, a BodyContent on which to evaluate the body of this tag.
EVAL_BODY_INCLUDE - Static variable in interface javax.servlet.jsp.tagext.Tag
Evaluate body into existing out stream.
EVAL_BODY_TAG - Static variable in interface javax.servlet.jsp.tagext.BodyTag
Deprecated. As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.
EVAL_PAGE - Static variable in interface javax.servlet.jsp.tagext.Tag
Continue evaluating the page.
EVENT_TYPE_CREATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is created.
EVENT_TYPE_DELETED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is deleted.
EVENT_TYPE_DEPRECATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is deprecated.
EVENT_TYPE_UNDEPRECATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is undeprecated.
EVENT_TYPE_UPDATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is updated.
EVENT_TYPE_VERSIONED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is versioned.
EXACT_NAME_MATCH - Static variable in interface javax.xml.registry.FindQualifier
EXCEPTION - Static variable in class javax.servlet.jsp.PageContext
Name used to store uncaught exception in ServletRequest attribute list and PageContext name table.
EXECUTE - Static variable in class javax.enterprise.deploy.shared.ActionType
The DeploymentManager action command is executing.
EXTERNAL_IDENTIFIER - Static variable in interface javax.xml.registry.LifeCycleManager
EXTERNAL_LINK - Static variable in interface javax.xml.registry.LifeCycleManager
EXTRINSIC_OBJECT - Static variable in interface javax.xml.registry.LifeCycleManager
EmailAddress - interface javax.xml.registry.infomodel.EmailAddress.
Represents an email address.
EnterpriseBean - interface javax.ejb.EnterpriseBean.
The EnterpriseBean interface must be implemented by every enterprise Bean class.
EntityBean - interface javax.ejb.EntityBean.
The EntityBean interface is implemented by every entity enterprise Bean class.
EntityBeanStats - interface javax.management.j2ee.statistics.EntityBeanStats.
Specifies statistics provided by entity beans.
EntityContext - interface javax.ejb.EntityContext.
The EntityContext interface provides an instance with access to the container-provided runtime context of an entity enterprise Bean instance.
ErrorData - class javax.servlet.jsp.ErrorData.
Contains information about an error, for error pages.
ErrorData(Throwable, int, String, String) - Constructor for class javax.servlet.jsp.ErrorData
Creates a new ErrorData object.
ErrorListener - interface javax.xml.transform.ErrorListener.
To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer.
ExceptionListener - interface javax.jms.ExceptionListener.
If a JMS provider detects a serious problem with a Connection object, it informs the Connection object's ExceptionListener, if one has been registered.
ExecutionContext - class javax.resource.spi.work.ExecutionContext.
This class models an execution context (transaction, security, etc) with which the Work instance must be executed.
ExecutionContext() - Constructor for class javax.resource.spi.work.ExecutionContext
Expression - class javax.servlet.jsp.el.Expression.
The abstract class for a prepared expression.
Expression() - Constructor for class javax.servlet.jsp.el.Expression
ExpressionEvaluator - class javax.servlet.jsp.el.ExpressionEvaluator.
The abstract base class for an expression-language evaluator.
ExpressionEvaluator() - Constructor for class javax.servlet.jsp.el.ExpressionEvaluator
ExtensibleObject - interface javax.xml.registry.infomodel.ExtensibleObject.
An ExtensibleObject is one that allows itself to be extended by utilizing dynamically added Slots that add arbitrary attributes to the object on a per instance basis.
ExternalIdentifier - interface javax.xml.registry.infomodel.ExternalIdentifier.
ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization.
ExternalLink - interface javax.xml.registry.infomodel.ExternalLink.
ExternalLink instances model a named URI to content that may reside outside the registry.
ExtrinsicObject - interface javax.xml.registry.infomodel.ExtrinsicObject.
ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).
ejbActivate() - Method in interface javax.ejb.EntityBean
A container invokes this method when the instance is taken out of the pool of available instances to become associated with a specific EJB object.
ejbActivate() - Method in interface javax.ejb.SessionBean
The activate method is called when the instance is activated from its "passive" state.
ejbLoad() - Method in interface javax.ejb.EntityBean
A container invokes this method to instruct the instance to synchronize its state by loading it state from the underlying database.
ejbPassivate() - Method in interface javax.ejb.EntityBean
A container invokes this method on an instance before the instance becomes disassociated with a specific EJB object.
ejbPassivate() - Method in interface javax.ejb.SessionBean
The passivate method is called before the instance enters the "passive" state.
ejbRemove() - Method in interface javax.ejb.EntityBean
A container invokes this method before it removes the EJB object that is currently associated with the instance.
ejbRemove() - Method in interface javax.ejb.MessageDrivenBean
A container invokes this method before it ends the life of the message-driven object.
ejbRemove() - Method in interface javax.ejb.SessionBean
A container invokes this method before it ends the life of the session object.
ejbStore() - Method in interface javax.ejb.EntityBean
A container invokes this method to instruct the instance to synchronize its state by storing it to the underlying database.
ejbTimeout(Timer) - Method in interface javax.ejb.TimedObject
Invoked by the EJB container upon timer expiration.
elementCount - Variable in class javax.management.monitor.Monitor
The number of valid components in the vector of observed objects.
enableAllObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter
Enables all MBeanServerNotifications (all ObjectNames are selected).
enableAttribute(String) - Method in class javax.management.AttributeChangeNotificationFilter
Enables all the attribute change notifications the attribute name of which equals the specified name to be sent to the listener.
enableObjectName(ObjectName) - Method in class javax.management.relation.MBeanServerNotificationFilter
Enables MBeanServerNotifications concerning given ObjectName.
enableType(String) - Method in class javax.management.NotificationFilterSupport
Enables all the notifications the type of which starts with the specified prefix to be sent to the listener.
encode(OutputStream, String) - Static method in class javax.mail.internet.MimeUtility
Wrap an encoder around the given output stream.
encode(OutputStream, String, String) - Static method in class javax.mail.internet.MimeUtility
Wrap an encoder around the given output stream.
encodeRedirectURL(String) - Method in interface javax.servlet.http.HttpServletResponse
Encodes the specified URL for use in the sendRedirect method or, if encoding is not needed, returns the URL unchanged.
encodeRedirectURL(String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to return encodeRedirectURL(String url) on the wrapped response object.
encodeRedirectUrl(String) - Method in interface javax.servlet.http.HttpServletResponse
Deprecated. As of version 2.1, use encodeRedirectURL(String url) instead
encodeRedirectUrl(String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to return encodeRedirectUrl(String url) on the wrapped response object.
encodeText(String) - Static method in class javax.mail.internet.MimeUtility
Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.
encodeText(String, String, String) - Static method in class javax.mail.internet.MimeUtility
Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.
encodeURL(String) - Method in interface javax.servlet.http.HttpServletResponse
Encodes the specified URL by including the session ID in it, or, if encoding is not needed, returns the URL unchanged.
encodeURL(String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call encodeURL(String url) on the wrapped response object.
encodeUrl(String) - Method in interface javax.servlet.http.HttpServletResponse
Deprecated. As of version 2.1, use encodeURL(String url) instead
encodeUrl(String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call encodeUrl(String url) on the wrapped response object.
encodeWord(String) - Static method in class javax.mail.internet.MimeUtility
Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.
encodeWord(String, String, String) - Static method in class javax.mail.internet.MimeUtility
Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.
encodedPersonal - Variable in class javax.mail.internet.InternetAddress
The RFC 2047 encoded version of the personal name.
end(Xid, int) - Method in interface javax.transaction.xa.XAResource
Ends the work performed on behalf of a transaction branch.
endpointActivation(MessageEndpointFactory, ActivationSpec) - Method in interface javax.resource.spi.ResourceAdapter
This is called during the activation of a message endpoint.
endpointDeactivation(MessageEndpointFactory, ActivationSpec) - Method in interface javax.resource.spi.ResourceAdapter
This is called when a message endpoint is deactivated.
enlistResource(XAResource) - Method in interface javax.transaction.Transaction
Enlist the resource specified with the transaction associated with the target Transaction object.
entries() - Method in interface javax.enterprise.deploy.model.DeployableObject
Returns an enumeration of the module file entries.
entrySet() - Method in class javax.management.openmbean.TabularDataSupport
Returns a collection view of the index to row mappings contained in this TabularDataSupport instance.
eq(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a query expression that represents an equality constraint on two values.
equals(DataFlavor) - Method in class javax.activation.ActivationDataFlavor
Compares the DataFlavor passed in with this DataFlavor; calls the isMimeTypeEqual method.
equals(Object) - Method in class javax.mail.Address
The equality operator.
equals(Object) - Method in class javax.mail.Flags
Check whether the two Flags objects are equal.
equals(Object) - Method in class javax.mail.URLName
Compares two URLNames.
equals(Object) - Method in class javax.mail.internet.InternetAddress
The equality operator.
equals(Object) - Method in class javax.mail.internet.NewsAddress
The equality operator.
equals(Object) - Method in class javax.mail.search.AddressStringTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.AddressTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.AndTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.BodyTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.ComparisonTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.DateTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.FlagTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.FromStringTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.FromTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.HeaderTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.IntegerComparisonTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.MessageIDTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.MessageNumberTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.NotTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.OrTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.ReceivedDateTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.RecipientStringTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.RecipientTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.SentDateTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.SizeTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.StringTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.SubjectTerm
Equality comparison.
equals(Object) - Method in class javax.management.Attribute
Compares the current Attribute Object with another Attribute Object.
equals(Object) - Method in class javax.management.MBeanAttributeInfo
Compare this MBeanAttributeInfo to another.
equals(Object) - Method in class javax.management.MBeanConstructorInfo
Compare this MBeanConstructorInfo to another.
equals(Object) - Method in class javax.management.MBeanFeatureInfo
Compare this MBeanFeatureInfo to another.
equals(Object) - Method in class javax.management.MBeanInfo
Compare this MBeanInfo to another.
equals(Object) - Method in class javax.management.MBeanNotificationInfo
Compare this MBeanAttributeInfo to another.
equals(Object) - Method in class javax.management.MBeanOperationInfo
Compare this MBeanOperationInfo to another.
equals(Object) - Method in class javax.management.MBeanParameterInfo
Compare this MBeanParameterInfo to another.
equals(Object) - Method in class javax.management.MBeanPermission
Checks two MBeanPermission objects for equality.
equals(Object) - Method in class javax.management.MBeanServerPermission
Checks two MBeanServerPermission objects for equality.
equals(Object) - Method in class javax.management.ObjectInstance
Compares the current object instance with another object instance.
equals(Object) - Method in class javax.management.ObjectName
Compares the current object name with another object name.
equals(Object) - Method in class javax.management.openmbean.ArrayType
Compares the specified obj parameter with this ArrayType instance for equality.
equals(Object) - Method in interface javax.management.openmbean.CompositeData
Compares the specified obj parameter with this CompositeData instance for equality.
equals(Object) - Method in class javax.management.openmbean.CompositeDataSupport
Compares the specified obj parameter with this CompositeDataSupport instance for equality.
equals(Object) - Method in class javax.management.openmbean.CompositeType
Compares the specified obj parameter with this CompositeType instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Compares the specified obj parameter with this OpenMBeanAttributeInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Compares the specified obj parameter with this OpenMBeanAttributeInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo
Compares the specified obj parameter with this OpenMBeanConstructorInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanConstructorInfoSupport
Compares the specified obj parameter with this OpenMBeanConstructorInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanInfo
Compares the specified obj parameter with this OpenMBeanInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanInfoSupport
Compares the specified obj parameter with this OpenMBeanInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Compares the specified obj parameter with this OpenMBeanOperationInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanOperationInfoSupport
Compares the specified obj parameter with this OpenMBeanOperationInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Compares the specified obj parameter with this OpenMBeanParameterInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Compares the specified obj parameter with this OpenMBeanParameterInfoSupport instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenType
Compares the specified obj parameter with this open type instance for equality.
equals(Object) - Method in class javax.management.openmbean.SimpleType
Compares the specified obj parameter with this SimpleType instance for equality.
equals(Object) - Method in interface javax.management.openmbean.TabularData
Compares the specified obj parameter with this TabularData instance for equality.
equals(Object) - Method in class javax.management.openmbean.TabularDataSupport
Compares the specified obj parameter with this TabularDataSupport instance for equality.
equals(Object) - Method in class javax.management.openmbean.TabularType
Compares the specified obj parameter with this TabularType instance for equality.
equals(Object) - Method in interface javax.resource.cci.Record
Check if this instance is equal to another Record.
equals(Object) - Method in interface javax.resource.spi.ConnectionRequestInfo
Checks whether this instance is equal to another.
equals(Object) - Method in interface javax.resource.spi.ManagedConnectionFactory
Check if this ManagedConnectionFactory is equal to another ManagedConnectionFactory.
equals(Object) - Method in interface javax.resource.spi.security.GenericCredential
Deprecated. Tests if this GenericCredential instance refers to the same entity as the supplied object.
equals(Object) - Method in class javax.resource.spi.security.PasswordCredential
Compares this PasswordCredential with the specified object for equality.
equals(Object) - Method in class javax.security.jacc.EJBMethodPermission
Checks two EJBMethodPermission objects for equality.
equals(Object) - Method in class javax.security.jacc.EJBRoleRefPermission
Checks two EJBRoleRefPermission objects for equality.
equals(Object) - Method in class javax.security.jacc.WebResourcePermission
Checks two WebResourcePermission objects for equality.
equals(Object) - Method in class javax.security.jacc.WebRoleRefPermission
Checks two WebRoleRefPermission objects for equality.
equals(Object) - Method in class javax.security.jacc.WebUserDataPermission
Checks two WebUserDataPermission objects for equality.
equals(Object) - Method in class javax.xml.namespace.QName
Test this QName for equality with another Object.
error(TransformerException) - Method in interface javax.xml.transform.ErrorListener
Receive notification of a recoverable error.
errorCode - Variable in class javax.transaction.SystemException
The error code with which to create the SystemException.
errorCode - Variable in class javax.transaction.xa.XAException
The error code with which to create the SystemException.
evaluate(VariableResolver) - Method in class javax.servlet.jsp.el.Expression
Evaluates an expression that was previously prepared.
evaluate(String, Class, VariableResolver, FunctionMapper) - Method in class javax.servlet.jsp.el.ExpressionEvaluator
Evaluates an expression.
examineAllHeaderElements() - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
examineHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor.
examineMustUnderstandHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.
execute() - Method in interface javax.enterprise.deploy.spi.status.ClientConfiguration
This method performs an exec and starts the application client running in another process.
execute(InteractionSpec, Record, Record) - Method in interface javax.resource.cci.Interaction
Executes an interaction represented by the InteractionSpec.
execute(InteractionSpec, Record) - Method in interface javax.resource.cci.Interaction
Executes an interaction represented by the InteractionSpec.
executeQuery(Query) - Method in interface javax.xml.registry.DeclarativeQueryManager
Executes a query as specified by query parameter.
exists() - Method in class javax.mail.Folder
Tests if this folder physically exists on the Store.
expunge() - Method in class javax.mail.Folder
Expunge (permanently remove) messages marked DELETED.
expunged - Variable in class javax.mail.Message
True if this message has been expunged.
extractAllHeaderElements() - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
extractHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.

F

FAILED - Static variable in class javax.enterprise.deploy.shared.StateType
The action operation has failed.
FEATURE - Static variable in class javax.xml.transform.dom.DOMResult
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.dom.DOMSource
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE - Static variable in class javax.xml.transform.sax.SAXResult
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.sax.SAXSource
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE - Static variable in class javax.xml.transform.sax.SAXTransformerFactory
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the TransformerFactory returned from TransformerFactory.newInstance() may be safely cast to a SAXTransformerFactory.
FEATURE - Static variable in class javax.xml.transform.stream.StreamResult
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.stream.StreamSource
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE_XMLFILTER - Static variable in class javax.xml.transform.sax.SAXTransformerFactory
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the SAXTransformerFactory.newXMLFilter(Source src) and SAXTransformerFactory.newXMLFilter(Templates templates) methods are supported.
FLAGGED - Static variable in class javax.mail.Flags.Flag
This message is flagged.
FLAGS - Static variable in class javax.mail.FetchProfile.Item
This is the Flags item.
FLAGS_CHANGED - Static variable in class javax.mail.event.MessageChangedEvent
The message's flags changed.
FLOAT - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Float.
FORM_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest
String identifier for Form authentication.
FactoryConfigurationError - error javax.xml.parsers.FactoryConfigurationError.
Thrown when a problem with configuration with the Parser Factories exists.
FactoryConfigurationError() - Constructor for class javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with no detail mesage.
FactoryConfigurationError(String) - Constructor for class javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with the String specified as an error message.
FactoryConfigurationError(Exception) - Constructor for class javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with a given Exception base cause of the error.
FactoryConfigurationError(Exception, String) - Constructor for class javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with the given Exception base cause and detail message.
FederatedConnection - interface javax.xml.registry.FederatedConnection.
Represents a single logical connection to a federation or group of registry providers.
FetchProfile - class javax.mail.FetchProfile.
Clients use a FetchProfile to list the Message attributes that it wishes to prefetch from the server for a range of messages.
FetchProfile() - Constructor for class javax.mail.FetchProfile
Create an empty FetchProfile.
FetchProfile.Item - class javax.mail.FetchProfile.Item.
This inner class is the base class of all items that can be requested in a FetchProfile.
FetchProfile.Item(String) - Constructor for class javax.mail.FetchProfile.Item
Constructor for an item.
FileDataSource - class javax.activation.FileDataSource.
The FileDataSource class implements a simple DataSource object that encapsulates a file.
FileDataSource(File) - Constructor for class javax.activation.FileDataSource
Creates a FileDataSource from a File object.
FileDataSource(String) - Constructor for class javax.activation.FileDataSource
Creates a FileDataSource from the specified path name.
FileTypeMap - class javax.activation.FileTypeMap.
The FileTypeMap is an abstract class that provides a data typing interface for files.
FileTypeMap() - Constructor for class javax.activation.FileTypeMap
The default constructor.
Filter - interface javax.servlet.Filter.
A filter is an object that performs filtering tasks on either the request to a resource (a servlet or static content), or on the response from a resource, or both.
FilterChain - interface javax.servlet.FilterChain.
A FilterChain is an object provided by the servlet container to the developer giving a view into the invocation chain of a filtered request for a resource.
FilterConfig - interface javax.servlet.FilterConfig.
A filter configuration object used by a servlet container to pass information to a filter during initialization.
FindException - exception javax.xml.registry.FindException.
A RegistryException that occurs during a find action.
FindException() - Constructor for class javax.xml.registry.FindException
Constructs a JAXRException object with no reason or embedded Throwable.
FindException(String) - Constructor for class javax.xml.registry.FindException
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
FindException(String, Throwable) - Constructor for class javax.xml.registry.FindException
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
FindException(Throwable) - Constructor for class javax.xml.registry.FindException
Constructs a JAXRException object initialized with the given Throwable object.
FindQualifier - interface javax.xml.registry.FindQualifier.
FindQualifier provides various constants that identify options that effect find method behavior.
FinderException - exception javax.ejb.FinderException.
The FinderException exception must be included in the throws clause of every findMETHOD(...) method of an entity Bean's home interface.
FinderException() - Constructor for class javax.ejb.FinderException
Constructs an FinderException with no detail message.
FinderException(String) - Constructor for class javax.ejb.FinderException
Constructs an FinderException with the specified detail message.
FlagTerm - class javax.mail.search.FlagTerm.
This class implements comparisons for Message Flags.
FlagTerm(Flags, boolean) - Constructor for class javax.mail.search.FlagTerm
Constructor.
Flags - class javax.mail.Flags.
The Flags class represents the set of flags on a Message.
Flags() - Constructor for class javax.mail.Flags
Construct an empty Flags object.
Flags(Flags) - Constructor for class javax.mail.Flags
Construct a Flags object initialized with the given flags.
Flags(Flags.Flag) - Constructor for class javax.mail.Flags
Construct a Flags object initialized with the given system flag.
Flags(String) - Constructor for class javax.mail.Flags
Construct a Flags object initialized with the given user flag.
Flags.Flag - class javax.mail.Flags.Flag.
This inner class represents an individual system flag.
FloatHolder - class javax.xml.rpc.holders.FloatHolder.
FloatHolder() - Constructor for class javax.xml.rpc.holders.FloatHolder
FloatHolder(float) - Constructor for class javax.xml.rpc.holders.FloatHolder
FloatWrapperHolder - class javax.xml.rpc.holders.FloatWrapperHolder.
FloatWrapperHolder() - Constructor for class javax.xml.rpc.holders.FloatWrapperHolder
FloatWrapperHolder(Float) - Constructor for class javax.xml.rpc.holders.FloatWrapperHolder
Folder - class javax.mail.Folder.
Folder is an abstract class that represents a folder for mail messages.
Folder(Store) - Constructor for class javax.mail.Folder
Constructor that takes a Store object.
FolderAdapter - class javax.mail.event.FolderAdapter.
The adapter which receives Folder events.
FolderAdapter() - Constructor for class javax.mail.event.FolderAdapter
FolderClosedException - exception javax.mail.FolderClosedException.
This exception is thrown when a method is invoked on a Messaging object and the Folder that owns that object has died due to some reason.
FolderClosedException(Folder) - Constructor for class javax.mail.FolderClosedException
Constructor
FolderClosedException(Folder, String) - Constructor for class javax.mail.FolderClosedException
Constructor
FolderEvent - class javax.mail.event.FolderEvent.
This class models Folder existence events.
FolderEvent(Object, Folder, int) - Constructor for class javax.mail.event.FolderEvent
Constructor.
FolderEvent(Object, Folder, Folder, int) - Constructor for class javax.mail.event.FolderEvent
Constructor.
FolderListener - interface javax.mail.event.FolderListener.
This is the Listener interface for Folder events.
FolderNotFoundException - exception javax.mail.FolderNotFoundException.
This exception is thrown by Folder methods, when those methods are invoked on a non existent folder.
FolderNotFoundException() - Constructor for class javax.mail.FolderNotFoundException
Constructs a MessagingException with no detail message.
FolderNotFoundException(Folder) - Constructor for class javax.mail.FolderNotFoundException
Constructs a MessagingException with the specified folder.
FolderNotFoundException(Folder, String) - Constructor for class javax.mail.FolderNotFoundException
Constructs a MessagingException with the specified folder and the specified detail message.
FolderNotFoundException(String, Folder) - Constructor for class javax.mail.FolderNotFoundException
Constructs a MessagingException with the specified detail message and the specified folder.
FromStringTerm - class javax.mail.search.FromStringTerm.
This class implements string comparisons for the From Address header.
FromStringTerm(String) - Constructor for class javax.mail.search.FromStringTerm
Constructor.
FromTerm - class javax.mail.search.FromTerm.
This class implements comparisons for the From Address header.
FromTerm(Address) - Constructor for class javax.mail.search.FromTerm
Constructor
FunctionInfo - class javax.servlet.jsp.tagext.FunctionInfo.
Information for a function in a Tag Library.
FunctionInfo(String, String, String) - Constructor for class javax.servlet.jsp.tagext.FunctionInfo
Constructor for FunctionInfo.
FunctionMapper - interface javax.servlet.jsp.el.FunctionMapper.
The interface to a map between EL function names and methods.
fatalError(TransformerException) - Method in interface javax.xml.transform.ErrorListener
Receive notification of a non-recoverable error.
fetch(Message[], FetchProfile) - Method in class javax.mail.Folder
Prefetch the items specified in the FetchProfile for the given Messages.
finalSubString(AttributeValueExp, StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a matching constraint on a string argument.
finalize() - Method in class javax.mail.Folder
finalize() - Method in class javax.mail.Service
Stop the event dispatcher thread so the queue can be garbage collected.
findAncestorWithClass(JspTag, Class) - Static method in class javax.servlet.jsp.tagext.SimpleTagSupport
Find the instance of a given class type that is closest to a given instance.
findAncestorWithClass(Tag, Class) - Static method in class javax.servlet.jsp.tagext.TagSupport
Find the instance of a given class type that is closest to a given instance.
findAssociatedMBeans(ObjectName, String, String) - Method in class javax.management.relation.RelationService
Retrieves the MBeans associated to given one in a relation.
findAssociatedMBeans(ObjectName, String, String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves the MBeans associated to given one in a relation.
findAssociations(Collection, String, String, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all Association objects that match all of the criteria specified by the parameters of this call.
findAttribute(String) - Method in class javax.servlet.jsp.JspContext
Searches for the named attribute in page, request, session (if valid), and application scope(s) in order and returns the value associated or null.
findCallerAssociations(Collection, Boolean, Boolean, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call.
findClass(String) - Method in class javax.management.loading.MLet
This is the main method for class loaders that is being redefined.
findClassificationSchemeByName(Collection, String) - Method in interface javax.xml.registry.BusinessQueryManager
Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.
findClassificationSchemes(Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call.
findConceptByPath(String) - Method in interface javax.xml.registry.BusinessQueryManager
Finds a Concept based on the path specified.
findConcepts(Collection, Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all Concept objects that match all of the criteria specified by the parameters of this call.
findLibrary(String) - Method in class javax.management.loading.MLet
Returns the absolute path name of a native library.
findMBeanServer(String) - Static method in class javax.management.MBeanServerFactory
Return a list of registered MBeanServer objects.
findOrganizations(Collection, Collection, Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all Organization objects that match all of the criteria specified by the parameters of this call.
findReferencingRelations(ObjectName, String, String) - Method in class javax.management.relation.RelationService
Retrieves the relations where a given MBean is referenced.
findReferencingRelations(ObjectName, String, String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves the relations where a given MBean is referenced.
findRegistryPackages(Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call.
findRelationsOfType(String) - Method in class javax.management.relation.RelationService
Returns the relation ids for relations of the given type.
findRelationsOfType(String) - Method in interface javax.management.relation.RelationServiceMBean
Returns the relation ids for relations of the given type.
findServiceBindings(Key, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call.
findServices(Key, Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all Service objects that match all of the criteria specified by the parameters of this call.
fireXpathEvent(XpathEvent) - Method in interface javax.enterprise.deploy.model.XpathListener
flags - Variable in class javax.mail.internet.MimeMessage
The Flags for this message.
flags - Variable in class javax.mail.search.FlagTerm
Flags object containing the flags to test.
flush() - Method in class javax.servlet.jsp.JspWriter
Flush the stream.
flush() - Method in class javax.servlet.jsp.tagext.BodyContent
Redefined flush() so it is not legal.
flushBuffer() - Method in interface javax.servlet.ServletResponse
Forces any content in the buffer to be written to the client.
flushBuffer() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to call flushBuffer() on the wrapped response object.
folder - Variable in class javax.mail.Message
The containing folder, if this message is obtained from a folder
folder - Variable in class javax.mail.event.FolderEvent
The folder the event occurred on.
folderCreated(FolderEvent) - Method in class javax.mail.event.FolderAdapter
folderCreated(FolderEvent) - Method in interface javax.mail.event.FolderListener
Invoked when a Folder is created.
folderDeleted(FolderEvent) - Method in class javax.mail.event.FolderAdapter
folderDeleted(FolderEvent) - Method in interface javax.mail.event.FolderListener
Invoked when a folder is deleted.
folderRenamed(FolderEvent) - Method in class javax.mail.event.FolderAdapter
folderRenamed(FolderEvent) - Method in interface javax.mail.event.FolderListener
Invoked when a folder is renamed.
forget(Xid) - Method in interface javax.resource.spi.XATerminator
Tells the resource manager to forget about a heuristically completed transaction branch.
forget(Xid) - Method in interface javax.transaction.xa.XAResource
Tells the resource manager to forget about a heuristically completed transaction branch.
format(Date, StringBuffer, FieldPosition) - Method in class javax.mail.internet.MailDateFormat
Formats the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.
forward(ServletRequest, ServletResponse) - Method in interface javax.servlet.RequestDispatcher
Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server.
forward(String) - Method in class javax.servlet.jsp.PageContext
This method is used to re-direct, or "forward" the current ServletRequest and ServletResponse to another active component in the application.
fullURL - Variable in class javax.mail.URLName
The full version of the URL
functions - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo
An array describing the functions that are defined in this tag library.

G

GE - Static variable in class javax.mail.search.ComparisonTerm
GE - Static variable in class javax.management.Query
A code representing the Query.geq(javax.management.ValueExp, javax.management.ValueExp) query.
GT - Static variable in class javax.mail.search.ComparisonTerm
GT - Static variable in class javax.management.Query
A code representing the Query.gt(javax.management.ValueExp, javax.management.ValueExp) query.
GaugeMonitor - class javax.management.monitor.GaugeMonitor.
Defines a monitor MBean designed to observe the values of a gauge attribute.
GaugeMonitor() - Constructor for class javax.management.monitor.GaugeMonitor
Default constructor.
GaugeMonitorMBean - interface javax.management.monitor.GaugeMonitorMBean.
Exposes the remote management interface of the gauge monitor MBean.
GenericCredential - interface javax.resource.spi.security.GenericCredential.
Deprecated. The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.
GenericHandler - class javax.xml.rpc.handler.GenericHandler.
The javax.xml.rpc.handler.GenericHandler class implements the Handler interface.
GenericHandler() - Constructor for class javax.xml.rpc.handler.GenericHandler
Default constructor
GenericServlet - class javax.servlet.GenericServlet.
Defines a generic, protocol-independent servlet.
GenericServlet() - Constructor for class javax.servlet.GenericServlet
Does nothing.
geq(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a "greater than or equal to" constraint on two values.
get(String) - Method in class javax.activation.MimeTypeParameterList
Retrieve the value associated with the given name, or null if there is no current association.
get(String) - Method in class javax.mail.internet.ParameterList
Returns the value of the specified parameter.
get(String) - Method in interface javax.management.openmbean.CompositeData
Returns the value of the item whose name is key.
get(String) - Method in class javax.management.openmbean.CompositeDataSupport
Returns the value of the item whose name is key.
get(Object[]) - Method in interface javax.management.openmbean.TabularData
Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.
get(Object) - Method in class javax.management.openmbean.TabularDataSupport
This method simply calls get((Object[]) key).
get(Object[]) - Method in class javax.management.openmbean.TabularDataSupport
Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.
getAccessURI() - Method in interface javax.xml.registry.infomodel.ServiceBinding
Gets the URI that gives access to the service via this binding.
getAcknowledgeMode() - Method in interface javax.jms.Session
Returns the acknowledgement mode of the session.
getAction() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
Retrieve the deployment ActionType for this event.
getActionType(int) - Static method in class javax.enterprise.deploy.shared.ActionType
Return an object of the specified value.
getActions() - Method in class javax.management.MBeanPermission
Returns the "canonical string representation" of the actions.
getActions() - Method in class javax.security.jacc.EJBMethodPermission
Returns a String containing a canonical representation of the actions of this EJBMethodPermission.
getActions() - Method in class javax.security.jacc.EJBRoleRefPermission
Returns a canonical String representation of the actions of this EJBRoleRefPermission.
getActions() - Method in class javax.security.jacc.WebResourcePermission
Returns a canonical String representation of the actions of this WebResourcePermission.
getActions() - Method in class javax.security.jacc.WebRoleRefPermission
Returns a canonical String representation of the actions of this WebRoleRefPermission.
getActions() - Method in class javax.security.jacc.WebUserDataPermission
Returns a canonical String representation of the actions of this WebUserDataPermission.
getActiveCount() - Method in interface javax.management.j2ee.statistics.JTAStats
Number of active transactions.
getActor() - Method in interface javax.xml.soap.SOAPHeaderElement
Returns the uri of the actor associated with this SOAPHeaderElement object.
getAdaptee() - Method in class javax.servlet.jsp.tagext.TagAdapter
Gets the tag that is being adapted to the Tag interface.
getAdapterName() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Gets a tool displayable name of the resource adapter.
getAdapterShortDescription() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Gets a tool displayable short desription of the resource adapter.
getAdapterVendorName() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Gets the name of the vendor that has provided the resource adapter.
getAdapterVersion() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Gets the version of the resource adapter.
getAddress() - Method in class javax.mail.internet.InternetAddress
Get the email address.
getAddress() - Method in class javax.mail.search.AddressTerm
Return the address to match with.
getAddress() - Method in interface javax.xml.registry.infomodel.EmailAddress
Returns the email address for this object.
getAll(String[]) - Method in interface javax.management.openmbean.CompositeData
Returns an array of the values of the items whose names are specified by keys, in the same order as keys.
getAll(String[]) - Method in class javax.management.openmbean.CompositeDataSupport
Returns an array of the values of the items whose names are specified by keys, in the same order as keys.
getAllAttributes() - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over all of the attribute Name objects in this SOAPElement object.
getAllCommands(String) - Method in class javax.activation.CommandMap
Get all the available commands for this type.
getAllCommands() - Method in class javax.activation.DataHandler
Return all the commands for this type of data.
getAllCommands(String) - Method in class javax.activation.MailcapCommandMap
Get all the available commands in all mailcap files known to this instance of MailcapCommandMap for this MIME type.
getAllHeaderLines() - Method in class javax.mail.internet.InternetHeaders
Return all the header lines as an Enumeration of Strings.
getAllHeaderLines() - Method in class javax.mail.internet.MimeBodyPart
Get all header lines as an Enumeration of Strings.
getAllHeaderLines() - Method in class javax.mail.internet.MimeMessage
Get all header lines as an Enumeration of Strings.
getAllHeaderLines() - Method in interface javax.mail.internet.MimePart
Get all header lines as an Enumeration of Strings.
getAllHeaders() - Method in interface javax.mail.Part
Return all the headers from this part as an Enumeration of Header objects.
getAllHeaders() - Method in class javax.mail.internet.InternetHeaders
Return all the headers as an Enumeration of Header objects.
getAllHeaders() - Method in class javax.mail.internet.MimeBodyPart
Return all the headers from this Message as an Enumeration of Header objects.
getAllHeaders() - Method in class javax.mail.internet.MimeMessage
Return all the headers from this Message as an enumeration of Header objects.
getAllHeaders() - Method in class javax.xml.soap.MimeHeaders
Returns all the MimeHeaders in this MimeHeaders object.
getAllMimeHeaders() - Method in class javax.xml.soap.AttachmentPart
Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.
getAllMimeHeaders() - Method in class javax.xml.soap.SOAPPart
Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.
getAllNotificationIDs() - Method in class javax.management.timer.Timer
Gets all timer notification identifiers registered into the list of notifications.
getAllNotificationIDs() - Method in interface javax.management.timer.TimerMBean
Gets all timer notification identifiers registered into the list of notifications.
getAllRecipients() - Method in class javax.mail.Message
Get all the recipient addresses for the message.
getAllRecipients() - Method in class javax.mail.internet.MimeMessage
Get all the recipient addresses for the message.
getAllRelationIds() - Method in class javax.management.relation.RelationService
Returns all the relation ids for all the relations handled by the Relation Service.
getAllRelationIds() - Method in interface javax.management.relation.RelationServiceMBean
Returns all the relation ids for all the relations handled by the Relation Service.
getAllRelationTypeNames() - Method in class javax.management.relation.RelationService
Retrieves names of all known relation types.
getAllRelationTypeNames() - Method in interface javax.management.relation.RelationServiceMBean
Retrieves names of all known relation types.
getAllRoles() - Method in interface javax.management.relation.Relation
Returns all roles present in the relation.
getAllRoles(String) - Method in class javax.management.relation.RelationService
Returns all roles present in the relation.
getAllRoles(String) - Method in interface javax.management.relation.RelationServiceMBean
Returns all roles present in the relation.
getAllRoles() - Method in class javax.management.relation.RelationSupport
Returns all roles present in the relation.
getAreaCode() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
Gets the area code.
getAssociatedObjects() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the collection of RegistryObject instances associated with this object.
getAssociatedStylesheet(Source, String, String, String) - Method in class javax.xml.transform.TransformerFactory
Get the stylesheet specification(s) associated via the xml-stylesheet processing instruction (see http://www.w3.org/TR/xml-stylesheet/) with the document document specified in the source parameter, and that match the given criteria.
getAssociationType() - Method in interface javax.xml.registry.infomodel.Association
Gets the association type for this Association.
getAssociations() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets all Associations where this object is source.
getAttachments() - Method in class javax.xml.soap.SOAPMessage
Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.
getAttachments(MimeHeaders) - Method in class javax.xml.soap.SOAPMessage
Retrieves all the AttachmentPart objects that have header entries that match the specified headers.
getAttribute(ObjectName) - Method in class javax.management.AttributeValueExp
Return the value of the given attribute in the named MBean.
getAttribute(String) - Method in interface javax.management.DynamicMBean
Obtain the value of a specific attribute of the Dynamic MBean.
getAttribute(ObjectName, String) - Method in interface javax.management.MBeanServer
Gets the value of a specific attribute of a named MBean.
getAttribute(ObjectName, String) - Method in interface javax.management.MBeanServerConnection
Gets the value of a specific attribute of a named MBean.
getAttribute(String) - Method in class javax.management.StandardMBean
getAttribute(ObjectName, String) - Method in interface javax.management.j2ee.Management
Gets the value of a specific attribute of a named managed object.
getAttribute(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns a ModelMBeanAttributeInfo requested by name.
getAttribute(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
getAttribute(String) - Method in class javax.management.modelmbean.RequiredModelMBean
Returns the value of a specific attribute defined for this ModelMBean.
getAttribute(String) - Method in interface javax.servlet.ServletContext
Returns the servlet container attribute with the given name, or null if there is no attribute by that name.
getAttribute(String) - Method in interface javax.servlet.ServletRequest
Returns the value of the named attribute as an Object, or null if no attribute of the given name exists.
getAttribute(String) - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to call getAttribute(String name) on the wrapped request object.
getAttribute(String) - Method in interface javax.servlet.http.HttpSession
Returns the object bound with the specified name in this session, or null if no object is bound under the name.
getAttribute(String) - Method in class javax.servlet.jsp.JspContext
Returns the object associated with the name in the page scope or null if not found.
getAttribute(String, int) - Method in class javax.servlet.jsp.JspContext
Return the object associated with the name in the specified scope or null if not found.
getAttribute(String) - Method in class javax.servlet.jsp.tagext.TagData
The value of the attribute.
getAttribute(String) - Method in class javax.xml.parsers.DocumentBuilderFactory
Allows the user to retrieve specific attributes on the underlying implementation.
getAttribute(String) - Method in class javax.xml.transform.TransformerFactory
Allows the user to retrieve specific attributes on the underlying implementation.
getAttributeName() - Method in class javax.management.AttributeChangeNotification
Gets the name of the attribute which has changed.
getAttributeName() - Method in class javax.management.AttributeValueExp
Returns a string representation of the name of the attribute.
getAttributeNames() - Method in interface javax.enterprise.deploy.model.DDBean
Returns the list of attribute names associated with the XML element.
getAttributeNames() - Method in interface javax.servlet.ServletContext
Returns an Enumeration containing the attribute names available within this servlet context.
getAttributeNames() - Method in interface javax.servlet.ServletRequest
Returns an Enumeration containing the names of the attributes available to this request.
getAttributeNames() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getAttributeNames() on the wrapped request object.
getAttributeNames() - Method in interface javax.servlet.http.HttpSession
Returns an Enumeration of String objects containing the names of all the objects bound to this session.
getAttributeNamesInScope(int) - Method in class javax.servlet.jsp.JspContext
Enumerate all the attributes in a given scope.
getAttributeString(String) - Method in class javax.servlet.jsp.tagext.TagData
Get the value for a given attribute.
getAttributeType() - Method in class javax.management.AttributeChangeNotification
Gets the type of the attribute which has changed.
getAttributeValue(String) - Method in interface javax.enterprise.deploy.model.DDBean
Returns the string value of the named attribute.
getAttributeValue(Name) - Method in interface javax.xml.soap.SOAPElement
Returns the value of the attribute with the specified name.
getAttributes(String[]) - Method in interface javax.management.DynamicMBean
Get the values of several attributes of the Dynamic MBean.
getAttributes() - Method in class javax.management.MBeanInfo
Returns the list of attributes exposed for management.
getAttributes(ObjectName, String[]) - Method in interface javax.management.MBeanServer
Gets the values of several attributes of a named MBean.
getAttributes(ObjectName, String[]) - Method in interface javax.management.MBeanServerConnection
Enables the values of several attributes of a named MBean.
getAttributes(String[]) - Method in class javax.management.StandardMBean
getAttributes(ObjectName, String[]) - Method in interface javax.management.j2ee.Management
Enables the values of several attributes of a named managed object.
getAttributes() - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns the list of attributes exposed for management.
getAttributes(String[]) - Method in class javax.management.modelmbean.RequiredModelMBean
Returns the values of several attributes in the ModelMBean.
getAttributes() - Method in interface javax.management.openmbean.OpenMBeanInfo
Returns an array of OpenMBeanAttributeInfo instances describing each attribute in the open MBean described by this OpenMBeanInfo instance.
getAttributes() - Method in class javax.servlet.jsp.tagext.TagData
Enumerates the attributes.
getAttributes() - Method in class javax.servlet.jsp.tagext.TagInfo
Attribute information (in the TLD) on this tag.
getAttributesScope(String) - Method in class javax.servlet.jsp.JspContext
Get the scope where a given attribute is defined.
getAuditTrail() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the complete audit trail of all requests that effected a state change in this object as an ordered Collection of AuditableEvent objects.
getAuthType() - Method in interface javax.servlet.http.HttpServletRequest
Returns the name of the authentication scheme used to protect the servlet.
getAuthType() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getAuthType() on the wrapped request object.
getAvailableModules(ModuleType, Target[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Retrieve the list of all J2EE application modules running or not running on the identified targets.
getBaseType() - Method in class javax.activation.MimeType
Return a String representation of this object without the parameter list.
getBaseType() - Method in class javax.mail.internet.ContentType
Return the MIME type string, without the parameters.
getBean(CommandInfo) - Method in class javax.activation.DataHandler
A convenience method that takes a CommandInfo object and instantiates the corresponding command, usually a JavaBean component.
getBean() - Method in class javax.enterprise.deploy.model.XpathEvent
The bean being added/removed/changed.
getBody() - Method in interface javax.xml.soap.SOAPEnvelope
Returns the SOAPBody object associated with this SOAPEnvelope object.
getBodyContent() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
Get current bodyContent.
getBodyContent() - Method in class javax.servlet.jsp.tagext.TagInfo
The bodycontent information for this tag.
getBodyLength() - Method in interface javax.jms.BytesMessage
Gets the number of bytes of the message body when the message is in read-only mode.
getBodyPart(int) - Method in class javax.mail.Multipart
Get the specified Part.
getBodyPart(int) - Method in interface javax.mail.MultipartDataSource
Get the specified Part.
getBodyPart(int) - Method in class javax.mail.internet.MimeMultipart
Get the specified BodyPart.
getBodyPart(String) - Method in class javax.mail.internet.MimeMultipart
Get the MimeBodyPart referred to by the given ContentID (CID).
getBoolean(String) - Method in interface javax.jms.MapMessage
Returns the boolean value with the specified name.
getBooleanProperty(String) - Method in interface javax.jms.Message
Returns the value of the boolean property with the specified name.
getBranchQualifier() - Method in interface javax.transaction.xa.Xid
Obtain the transaction branch identifier part of XID as an array of bytes.
getBufferSize() - Method in interface javax.servlet.ServletResponse
Returns the actual buffer size used for the response.
getBufferSize() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getBufferSize() on the wrapped response object.
getBufferSize() - Method in class javax.servlet.jsp.JspWriter
This method returns the size of the buffer used by the JspWriter.
getBulkResponse(String) - Method in interface javax.xml.registry.RegistryService
Returns the BulkResponse associated with specified requestId.
getBusinessLifeCycleManager() - Method in interface javax.xml.registry.RegistryService
Returns the BusinessLifeCycleManager object implemented by the JAXR provider.
getBusinessQueryManager() - Method in interface javax.xml.registry.RegistryService
Returns the BusinessQueryManager object implemented by the JAXR provider.
getByte(String) - Method in interface javax.jms.MapMessage
Returns the byte value with the specified name.
getByteProperty(String) - Method in interface javax.jms.Message
Returns the value of the byte property with the specified name.
getBytes(String) - Method in interface javax.jms.MapMessage
Returns the byte array value with the specified name.
getCachedMBeanInfo() - Method in class javax.management.StandardMBean
Customization hook: Return the MBeanInfo cached for this object.
getCallerIdentity() - Method in interface javax.ejb.EJBContext
Deprecated. Use Principal getCallerPrincipal() instead.
getCallerPrincipal() - Method in interface javax.ejb.EJBContext
Obtain the java.security.Principal that identifies the caller.
getCalls(QName) - Method in interface javax.xml.rpc.Service
Gets an array of preconfigured Call objects for invoking operations on the specified port.
getCanonicalKeyPropertyListString() - Method in class javax.management.ObjectName
Returns a string representation of the list of key properties, in which the key properties are sorted in lexical order.
getCanonicalName() - Method in class javax.management.ObjectName
Returns the canonical form of the name; that is, a string representation where the properties are sorted in lexical order.
getCapabilityLevel() - Method in interface javax.xml.registry.CapabilityProfile
Gets the capability level supported by the JAXR provider.
getCapabilityProfile() - Method in interface javax.xml.registry.RegistryService
Returns the CapabilityProfile for the JAXR provider.
getCause() - Method in class javax.management.MBeanException
Return the actual Exception thrown.
getCause() - Method in class javax.management.ReflectionException
Returns the actual Exception thrown.
getCause() - Method in class javax.management.RuntimeErrorException
Returns the actual Error thrown.
getCause() - Method in class javax.management.RuntimeMBeanException
Returns the actual RuntimeException thrown.
getCause() - Method in class javax.management.RuntimeOperationsException
Returns the actual RuntimeException thrown.
getCause() - Method in class javax.xml.registry.JAXRException
Returns the Throwable embedded in this JAXRException if there is one.
getCause() - Method in class javax.xml.soap.SOAPException
Returns the Throwable object embedded in this SOAPException if there is one.
getCause() - Method in class javax.xml.transform.TransformerException
Returns the cause of this throwable or null if the cause is nonexistent or unknown.
getCausedByException() - Method in class javax.ejb.EJBException
Obtain the exception that caused the EJBException being thrown.
getChangeEvent() - Method in class javax.enterprise.deploy.model.XpathEvent
getChar(String) - Method in interface javax.jms.MapMessage
Returns the Unicode character value with the specified name.
getCharacterEncoding() - Method in interface javax.servlet.ServletRequest
Returns the name of the character encoding used in the body of this request.
getCharacterEncoding() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getCharacterEncoding() on the wrapped request object.
getCharacterEncoding() - Method in interface javax.servlet.ServletResponse
Returns the name of the character encoding (MIME charset) used for the body sent in this response.
getCharacterEncoding() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getCharacterEncoding() on the wrapped response object.
getCharsetName() - Method in interface javax.xml.registry.infomodel.LocalizedString
Gets the canonical name for the charset for this object.
getChildBean(String) - Method in interface javax.enterprise.deploy.model.DDBean
Return a list of DDBeans based upon the XPath.
getChildBean(String) - Method in interface javax.enterprise.deploy.model.DeployableObject
Return an array of standard beans representing the XML content returned based upon the XPath.
getChildBean(ModuleType, String) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.
getChildConceptCount() - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Gets number of children.
getChildConceptCount() - Method in interface javax.xml.registry.infomodel.Concept
Gets number of children.
getChildElements() - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over all the immediate child Nodes of this element.
getChildElements(Name) - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over all the immediate child Nodes of this element with the specified name.
getChildOrganizationCount() - Method in interface javax.xml.registry.infomodel.Organization
Gets number of children.
getChildOrganizations() - Method in interface javax.xml.registry.infomodel.Organization
Gets all immediate children Organizations.
getChildTargetModuleID() - Method in interface javax.enterprise.deploy.spi.TargetModuleID
Retrieve a list of identifiers of the children of this deployed module.
getChildrenConcepts() - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Gets all immediate children Concepts.
getChildrenConcepts() - Method in interface javax.xml.registry.infomodel.Concept
Gets all immediate children Concepts.
getCity() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the city.
getClassFromScope(String) - Method in interface javax.enterprise.deploy.model.DeployableObject
Retrieve the specified class from this deployable module.
getClassLoader(ObjectName) - Method in interface javax.management.MBeanServer
Return the named ClassLoader.
getClassLoaderFor(ObjectName) - Method in interface javax.management.MBeanServer
Return the ClassLoader that was used for loading the class of the named MBean.
getClassLoaderRepository() - Method in interface javax.management.MBeanServer
Return the ClassLoaderRepository for this MBeanServer.
getClassLoaderRepository(MBeanServer) - Static method in class javax.management.MBeanServerFactory
Return the ClassLoaderRepository used by the given MBeanServer.
getClassLoaderRepository() - Method in class javax.management.modelmbean.RequiredModelMBean
Return the Class Loader Repository used to perform class loading.
getClassName() - Method in class javax.mail.Provider
Returns name of the class that implements the protocol
getClassName() - Method in class javax.management.MBeanInfo
Returns the name of the Java class of the MBean described by this MBeanInfo.
getClassName() - Method in class javax.management.ObjectInstance
Returns the class part.
getClassName(MBeanInfo) - Method in class javax.management.StandardMBean
Customization hook: Get the className that will be used in the MBeanInfo returned by this MBean.
getClassName() - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns the name of the Java class of the MBean described by this MBeanInfo.
getClassName() - Method in interface javax.management.openmbean.OpenMBeanInfo
Returns the fully qualified Java class name of the open MBean instances this OpenMBeanInfo describes.
getClassName() - Method in class javax.management.openmbean.OpenType
Returns the fully qualified Java class name of the open data values this open type describes.
getClassName() - Method in class javax.servlet.jsp.tagext.TagVariableInfo
The body of the <variable-class> element.
getClassName() - Method in class javax.servlet.jsp.tagext.VariableInfo
Returns the type of this variable.
getClassificationScheme() - Method in interface javax.xml.registry.infomodel.Classification
Gets the ClassificationScheme that is used in classifying the object.
getClassificationScheme() - Method in interface javax.xml.registry.infomodel.Concept
Gets the ClassificationScheme that this Concept is a descendent of.
getClassifications() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the Classification instances that classify this object.
getClassifiedObject() - Method in interface javax.xml.registry.infomodel.Classification
Gets the Object that is being classified.
getClientConfiguration(TargetModuleID) - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Return the ClientConfiguration object associated with the TargetModuleID.
getClientID() - Method in interface javax.jms.Connection
Gets the client identifier for this connection.
getCloseCount() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats
The number of connections closed
getCloseCount() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
Number of connections closed.
getCollection() - Method in interface javax.xml.registry.BulkResponse
Get the Collection of objects returned as a response of a bulk operation.
getColumnNumber() - Method in interface javax.xml.transform.SourceLocator
Return the character position where the current document event ends.
getCommand(String, String) - Method in class javax.activation.CommandMap
Get the default command corresponding to the MIME type.
getCommand(String) - Method in class javax.activation.DataHandler
Get the command cmdName.
getCommand(String, String) - Method in class javax.activation.MailcapCommandMap
Get the command corresponding to cmdName for the MIME type.
getCommand() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
Retrieve the deployment CommandType of this event.
getCommandClass() - Method in class javax.activation.CommandInfo
Return the command's class name.
getCommandName() - Method in class javax.activation.CommandInfo
Return the command verb.
getCommandObject(DataHandler, ClassLoader) - Method in class javax.activation.CommandInfo
Return the instantiated JavaBean component.
getCommandType(int) - Static method in class javax.enterprise.deploy.shared.CommandType
Return an object of the specified value.
getComment() - Method in class javax.servlet.http.Cookie
Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.
getCommittedCount() - Method in interface javax.management.j2ee.statistics.JTAStats
Number of committed transactions.
getComparison() - Method in class javax.mail.search.DateTerm
Return the type of comparison.
getComparison() - Method in class javax.mail.search.IntegerComparisonTerm
Return the type of comparison.
getCompositeType() - Method in interface javax.management.openmbean.CompositeData
Returns the composite type of this composite data instance.
getCompositeType() - Method in class javax.management.openmbean.CompositeDataSupport
Returns the composite type of this composite data instance.
getConcept() - Method in interface javax.xml.registry.infomodel.Classification
Gets the Concept that is classifying the object.
getConnection() - Method in interface javax.resource.cci.ConnectionFactory
Gets a connection to an EIS instance.
getConnection(ConnectionSpec) - Method in interface javax.resource.cci.ConnectionFactory
Gets a connection to an EIS instance.
getConnection() - Method in interface javax.resource.cci.Interaction
Gets the Connection associated with the Interaction.
getConnection(Subject, ConnectionRequestInfo) - Method in interface javax.resource.spi.ManagedConnection
Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance.
getConnectionFactory() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats
Returns the associated JCAConnectionFactory OBJECT_NAME
getConnectionHandle() - Method in class javax.resource.spi.ConnectionEvent
Get the connection handle associated with the Managed Connection instance.
getConnectionPools() - Method in interface javax.management.j2ee.statistics.JCAStats
Returns an array of JCAConnectionPool Stats that provide statistics about the connection pools associated with the referencing JCA resource statistics
getConnectionPools() - Method in interface javax.management.j2ee.statistics.JDBCStats
getConnections() - Method in interface javax.management.j2ee.statistics.JCAStats
Returns an array of JCAConnectionStats that provide statistics about the non-pooled connections associated with the referencing JCA resource statistics
getConnections() - Method in interface javax.management.j2ee.statistics.JDBCStats
getConnections() - Method in interface javax.management.j2ee.statistics.JMSStats
Returns an array of JMSConnectionStats that provide statistics about the connections associated with the referencing JMS resource.
getConstructor(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
Returns the ModelMBeanConstructorInfo requested by name.
getConstructors() - Method in class javax.management.MBeanInfo
Returns the list of the public constructors of the MBean.
getConstructors(MBeanConstructorInfo[], Object) - Method in class javax.management.StandardMBean
Customization hook: Get the MBeanConstructorInfo[] that will be used in the MBeanInfo returned by this MBean.
getConstructors() - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns the list of the public constructors of the MBean.
getConstructors() - Method in interface javax.management.openmbean.OpenMBeanInfo
Returns an array of OpenMBeanConstructorInfo instances describing each constructor in the open MBean described by this OpenMBeanInfo instance.
getConsumers() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Returns an array of JMSConsumerStats that provide statistics about the message consumers associated with the referencing JMS session statistics.
getContent(DataSource) - Method in interface javax.activation.DataContentHandler
Return an object representing the data in its most preferred form.
getContent() - Method in class javax.activation.DataHandler
Return the data in its preferred Object form.
getContent() - Method in interface javax.mail.Part
Return the content as a Java object.
getContent() - Method in class javax.mail.internet.MimeBodyPart
Return the content as a java object.
getContent() - Method in class javax.mail.internet.MimeMessage
Return the content as a Java object.
getContent() - Method in class javax.xml.soap.AttachmentPart
Gets the content of this AttachmentPart object as a Java object.
getContent() - Method in class javax.xml.soap.SOAPPart
Returns the content of the SOAPEnvelope as a JAXP Source object.
getContentDescription() - Method in class javax.xml.soap.SOAPMessage
Retrieves a description of this SOAPMessage object's content.
getContentID() - Method in class javax.mail.internet.MimeBodyPart
Returns the value of the "Content-ID" header field.
getContentID() - Method in class javax.mail.internet.MimeMessage
Returns the value of the "Content-ID" header field.
getContentID() - Method in interface javax.mail.internet.MimePart
Get the Content-ID of this part.
getContentId() - Method in class javax.xml.soap.AttachmentPart
Gets the value of the MIME header whose name is "Content-Id".
getContentId() - Method in class javax.xml.soap.SOAPPart
Retrieves the value of the MIME header whose name is "Content-Id".
getContentLanguage() - Method in class javax.mail.internet.MimeBodyPart
Get the languages specified in the Content-Language header of this MimePart.
getContentLanguage() - Method in class javax.mail.internet.MimeMessage
Get the languages specified in the "Content-Language" header field of this message.
getContentLanguage() - Method in interface javax.mail.internet.MimePart
Get the language tags specified in the Content-Language header of this MimePart.
getContentLength() - Method in interface javax.servlet.ServletRequest
Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known.
getContentLength() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getContentLength() on the wrapped request object.
getContentLocation() - Method in class javax.xml.soap.AttachmentPart
Gets the value of the MIME header whose name is "Content-Location".
getContentLocation() - Method in class javax.xml.soap.SOAPPart
Retrieves the value of the MIME header whose name is "Content-Location".
getContentMD5() - Method in class javax.mail.internet.MimeBodyPart
Return the value of the "Content-MD5" header field.
getContentMD5() - Method in class javax.mail.internet.MimeMessage
Return the value of the "Content-MD5" header field.
getContentMD5() - Method in interface javax.mail.internet.MimePart
Get the Content-MD5 digest of this part.
getContentStream() - Method in class javax.mail.internet.MimeBodyPart
Produce the raw bytes of the content.
getContentStream() - Method in class javax.mail.internet.MimeMessage
Produce the raw bytes of the content.
getContentType() - Method in class javax.activation.DataHandler
Return the MIME type of this object as retrieved from the source object.
getContentType() - Method in interface javax.activation.DataSource
This method returns the MIME type of the data in the form of a string.
getContentType() - Method in class javax.activation.FileDataSource
This method returns the MIME type of the data in the form of a string.
getContentType(File) - Method in class javax.activation.FileTypeMap
Return the type of the file object.
getContentType(String) - Method in class javax.activation.FileTypeMap
Return the type of the file passed in.
getContentType(File) - Method in class javax.activation.MimetypesFileTypeMap
Return the MIME type of the file object.
getContentType(String) - Method in class javax.activation.MimetypesFileTypeMap
Return the MIME type based on the specified file name.
getContentType() - Method in class javax.activation.URLDataSource
Returns the value of the URL content-type header field.
getContentType() - Method in class javax.mail.Multipart
Return the content-type of this Multipart.
getContentType() - Method in interface javax.mail.Part
Returns the Content-Type of the content of this part.
getContentType() - Method in class javax.mail.internet.MimeBodyPart
Returns the value of the RFC 822 "Content-Type" header field.
getContentType() - Method in class javax.mail.internet.MimeMessage
Returns the value of the RFC 822 "Content-Type" header field.
getContentType() - Method in class javax.mail.internet.MimePartDataSource
Returns the content-type of this DataSource.
getContentType() - Method in interface javax.servlet.ServletRequest
Returns the MIME type of the body of the request, or null if the type is not known.
getContentType() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getContentType() on the wrapped request object.
getContentType() - Method in interface javax.servlet.ServletResponse
Returns the content type used for the MIME body sent in this response.
getContentType() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getContentType() on the wrapped response object.
getContentType() - Method in class javax.xml.soap.AttachmentPart
Gets the value of the MIME header whose name is "Content-Type".
getContext(String) - Static method in class javax.security.jacc.PolicyContext
This method may be used by a Policy provider to activate the PolicyContextHandler registered to the context object key and cause it to return the corresponding policy context object from the container.
getContext(String, Object) - Method in interface javax.security.jacc.PolicyContextHandler
This public method is used by the PolicyContext class to activate the handler and obtain from it the context object identified by the (case-sensitive) key.
getContext(String) - Method in interface javax.servlet.ServletContext
Returns a ServletContext object that corresponds to a specified URL on the server.
getContextID() - Method in interface javax.security.jacc.PolicyConfiguration
This method returns this object's policy context identifier.
getContextID() - Static method in class javax.security.jacc.PolicyContext
This static method returns the value of the policy context identifier associated with the thread on which the accessor is called.
getContextPath() - Method in interface javax.servlet.http.HttpServletRequest
Returns the portion of the request URI that indicates the context of the request.
getContextPath() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getContextPath() on the wrapped request object.
getCookies() - Method in interface javax.servlet.http.HttpServletRequest
Returns an array containing all of the Cookie objects the client sent with this request.
getCookies() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getCookies() on the wrapped request object.
getCount() - Method in class javax.mail.Multipart
Return the number of enclosed BodyPart objects.
getCount() - Method in interface javax.mail.MultipartDataSource
Return the number of enclosed BodyPart objects.
getCount() - Method in class javax.mail.internet.MimeMultipart
Return the number of enclosed BodyPart objects.
getCount() - Method in interface javax.management.j2ee.statistics.CountStatistic
The count since the last reset.
getCount() - Method in interface javax.management.j2ee.statistics.TimeStatistic
Number of times the operation was invoked since the beginning of this measurement.
getCountry() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the country.
getCountryCode() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
Gets the country code.
getCreateCount() - Method in interface javax.management.j2ee.statistics.EJBStats
Number of times create was called.
getCreateCount() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats
The number of connections created
getCreateCount() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
Number of connections created.
getCreationTime() - Method in interface javax.servlet.http.HttpSession
Returns the time when this session was created, measured in milliseconds since midnight January 1, 1970 GMT.
getCredentialData() - Method in interface javax.resource.spi.security.GenericCredential
Deprecated. Gets security data for a specific security mechanism represented by the GenericCredential.
getCredentials() - Method in interface javax.xml.registry.Connection
Gets the credentials associated with this client.
getCurrent() - Method in interface javax.management.j2ee.statistics.RangeStatistic
The current value of this attribute.
getCurrentLocale() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Returns the active locale this implementation of javax.enterprise.deploy.spi subpackages is running.
getDConfigBean(DDBean) - Method in interface javax.enterprise.deploy.spi.DConfigBean
Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.
getDConfigBean(DDBeanRoot) - Method in interface javax.enterprise.deploy.spi.DConfigBeanRoot
Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor.
getDConfigBeanRoot(DDBeanRoot) - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration
Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.
getDConfigBeanVersion() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Returns the J2EE platform version number for which the configuration beans are provided.
getDConfigBeanVersionType(int) - Static method in class javax.enterprise.deploy.shared.DConfigBeanVersionType
Return an object of the specified value.
getDDBean() - Method in interface javax.enterprise.deploy.spi.DConfigBean
Return the JavaBean containing the deployment descriptor XML text associated with this DConfigBean.
getDDBeanRoot() - Method in interface javax.enterprise.deploy.model.DeployableObject
Return the top level standard bean representing the root of the deployment descriptor.
getDDBeanRoot(String) - Method in interface javax.enterprise.deploy.model.DeployableObject
Returns a DDBeanRoot object for the XML instance document named.
getDDBeanRootVersion() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Returns the version number of an XML instance document.
getDOMImplementation() - Method in class javax.xml.parsers.DocumentBuilder
Obtain an instance of a DOMImplementation object.
getDataHandler() - Method in interface javax.mail.Part
Return a DataHandler for the content within this part.
getDataHandler() - Method in class javax.mail.internet.MimeBodyPart
Return a DataHandler for this body part's content.
getDataHandler() - Method in class javax.mail.internet.MimeMessage
Return a DataHandler for this Message's content.
getDataHandler() - Method in class javax.xml.soap.AttachmentPart
Gets the DataHandler object for this AttachmentPart object.
getDataSource() - Method in class javax.activation.DataHandler
Return the DataSource associated with this instance of DataHandler.
getDate() - Method in class javax.mail.search.DateTerm
Return the Date to compare with.
getDate(Integer) - Method in class javax.management.timer.Timer
Gets a copy of the date associated to a timer notification.
getDate(Integer) - Method in interface javax.management.timer.TimerMBean
Gets a copy of the date associated to a timer notification.
getDateHeader(String) - Method in interface javax.servlet.http.HttpServletRequest
Returns the value of the specified request header as a long value that represents a Date object.
getDateHeader(String) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getDateHeader(String name) on the wrapped request object.
getDebug() - Method in class javax.mail.Session
Get the debug setting for this Session.
getDebugOut() - Method in class javax.mail.Session
Returns the stream to be used for debugging output.
getDeclarativeQueryManager() - Method in interface javax.xml.registry.RegistryService
Returns the DeclarativeQueryManager object implemented by the JAXR provider.
getDeclare() - Method in class javax.servlet.jsp.tagext.TagVariableInfo
The body of the <declare> element.
getDeclare() - Method in class javax.servlet.jsp.tagext.VariableInfo
Returns whether this is a new variable.
getDefaultCommandMap() - Static method in class javax.activation.CommandMap
Get the default CommandMap.
getDefaultDomain() - Method in interface javax.management.MBeanServer
Returns the default domain used for naming the MBean.
getDefaultDomain() - Method in interface javax.management.MBeanServerConnection
Returns the default domain used for naming the MBean.
getDefaultDomain() - Method in interface javax.management.j2ee.Management
Returns the default domain name of this MEJB.
getDefaultFactory() - Static method in class javax.servlet.jsp.JspFactory
Returns the default factory for this implementation.
getDefaultFileTypeMap() - Static method in class javax.activation.FileTypeMap
Return the default FileTypeMap for the system.
getDefaultFolder() - Method in class javax.mail.Store
Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.
getDefaultInstance(Properties, Authenticator) - Static method in class javax.mail.Session
Get the default Session object.
getDefaultInstance(Properties) - Static method in class javax.mail.Session
Get the default Session object.
getDefaultJavaCharset() - Static method in class javax.mail.internet.MimeUtility
Get the default charset corresponding to the system's current default locale.
getDefaultLocale() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Returns the default locale supported by this implementation of javax.enterprise.deploy.spi subpackages.
getDefaultPostalScheme() - Method in interface javax.xml.registry.RegistryService
Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.
getDefaultTypeMapping() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry
Gets the registered default TypeMapping instance.
getDefaultUserName() - Method in class javax.mail.Authenticator
getDefaultValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns the default value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
getDefaultValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns the default value for this parameter, if it has one, or null otherwise.
getDefaultValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns the default value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
getDeletedMessageCount() - Method in class javax.mail.Folder
Get the number of deleted messages in this Folder.
getDeliveryMode() - Method in interface javax.jms.MessageProducer
Gets the producer's default delivery mode.
getDeployableObject() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Return the containing DeployableObject
getDeployableObject(String) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the DeployableObject of the specified URI designator.
getDeployableObject() - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration
Returns an object that provides access to the deployment descriptor data and classes of a J2EE module.
getDeployableObjects(ModuleType) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the all DeployableObjects of the specified type.
getDeployableObjects() - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the all DeployableObjects in this application.
getDeploymentFactories() - Method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
Retrieve the lists of currently registered DeploymentFactories.
getDeploymentManager(String, String, String) - Method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
Retrieves a DeploymentManager instance to use for deployment.
getDeploymentManager(String, String, String) - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Return a connected DeploymentManager instance.
getDeploymentStatus() - Method in class javax.enterprise.deploy.spi.status.ProgressEvent
Retrieve the status information.
getDeploymentStatus() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Retrieve the status of this activity.
getDerivedGauge(ObjectName) - Method in class javax.management.monitor.CounterMonitor
Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
getDerivedGauge() - Method in class javax.management.monitor.CounterMonitor
Deprecated. As of JMX 1.2, replaced by CounterMonitor.getDerivedGauge(ObjectName)
getDerivedGauge() - Method in interface javax.management.monitor.CounterMonitorMBean
Deprecated. As of JMX 1.2, replaced by CounterMonitorMBean.getDerivedGauge(ObjectName)
getDerivedGauge(ObjectName) - Method in interface javax.management.monitor.CounterMonitorMBean
Gets the derived gauge for the specified MBean.
getDerivedGauge(ObjectName) - Method in class javax.management.monitor.GaugeMonitor
Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
getDerivedGauge() - Method in class javax.management.monitor.GaugeMonitor
Deprecated. As of JMX 1.2, replaced by GaugeMonitor.getDerivedGauge(ObjectName)
getDerivedGauge() - Method in interface javax.management.monitor.GaugeMonitorMBean
Deprecated. As of JMX 1.2, replaced by GaugeMonitorMBean.getDerivedGauge(ObjectName)
getDerivedGauge(ObjectName) - Method in interface javax.management.monitor.GaugeMonitorMBean
Gets the derived gauge for the specified MBean.
getDerivedGauge() - Method in class javax.management.monitor.MonitorNotification
Gets the derived gauge of this monitor notification.
getDerivedGauge(ObjectName) - Method in class javax.management.monitor.StringMonitor
Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
getDerivedGauge() - Method in class javax.management.monitor.StringMonitor
Deprecated. As of JMX 1.2, replaced by StringMonitor.getDerivedGauge(ObjectName)
getDerivedGauge() - Method in interface javax.management.monitor.StringMonitorMBean
Deprecated. As of JMX 1.2, replaced by StringMonitorMBean.getDerivedGauge(ObjectName)
getDerivedGauge(ObjectName) - Method in interface javax.management.monitor.StringMonitorMBean
Gets the derived gauge for the specified MBean.
getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor.CounterMonitor
Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
getDerivedGaugeTimeStamp() - Method in class javax.management.monitor.CounterMonitor
Deprecated. As of JMX 1.2, replaced by CounterMonitor.getDerivedGaugeTimeStamp(ObjectName)
getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor.CounterMonitorMBean
Deprecated. As of JMX 1.2, replaced by CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor.CounterMonitorMBean
Gets the derived gauge timestamp for the specified MBean.
getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor.GaugeMonitor
Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
getDerivedGaugeTimeStamp() - Method in class javax.management.monitor.GaugeMonitor
Deprecated. As of JMX 1.2, replaced by GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName)
getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor.GaugeMonitorMBean
Deprecated. As of JMX 1.2, replaced by GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor.GaugeMonitorMBean
Gets the derived gauge timestamp for the specified MBean.
getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor.StringMonitor
Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
getDerivedGaugeTimeStamp() - Method in class javax.management.monitor.StringMonitor
Deprecated. As of JMX 1.2, replaced by StringMonitor.getDerivedGaugeTimeStamp(ObjectName)
getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor.StringMonitorMBean
Deprecated. As of JMX 1.2, replaced by StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)
getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor.StringMonitorMBean
Gets the derived gauge timestamp for the specified MBean.
getDescendantConcepts() - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Gets all descendant Concepts.
getDescendantConcepts() - Method in interface javax.xml.registry.infomodel.Concept
Gets all descendant Concepts.
getDescendantOrganizations() - Method in interface javax.xml.registry.infomodel.Organization
Gets all descendant Organizations.
getDescription() - Method in interface javax.enterprise.deploy.spi.Target
Retrieve other descriptive information about the target.
getDescription() - Method in interface javax.mail.Part
Return a description String for this part.
getDescription() - Method in class javax.mail.internet.MimeBodyPart
Returns the "Content-Description" header field of this body part.
getDescription() - Method in class javax.mail.internet.MimeMessage
Returns the "Content-Description" header field of this Message.
getDescription() - Method in class javax.management.MBeanFeatureInfo
Returns the human-readable description of the feature.
getDescription() - Method in class javax.management.MBeanInfo
Returns a human readable description of the MBean.
getDescription(MBeanInfo) - Method in class javax.management.StandardMBean
Customization hook: Get the description that will be used in the MBeanInfo returned by this MBean.
getDescription(MBeanFeatureInfo) - Method in class javax.management.StandardMBean
Customization hook: Get the description that will be used in the MBeanFeatureInfo returned by this MBean.
getDescription(MBeanAttributeInfo) - Method in class javax.management.StandardMBean
Customization hook: Get the description that will be used in the MBeanAttributeInfo returned by this MBean.
getDescription(MBeanConstructorInfo) - Method in class javax.management.StandardMBean
Customization hook: Get the description that will be used in the MBeanConstructorInfo returned by this MBean.
getDescription(MBeanConstructorInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean
Customization hook: Get the description that will be used for the sequence MBeanParameterInfo of the MBeanConstructorInfo returned by this MBean.
getDescription(MBeanOperationInfo) - Method in class javax.management.StandardMBean
Customization hook: Get the description that will be used in the MBeanOperationInfo returned by this MBean.
getDescription(MBeanOperationInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean
Customization hook: Get the description that will be used for the sequence MBeanParameterInfo of the MBeanOperationInfo returned by this MBean.
getDescription() - Method in interface javax.management.j2ee.statistics.Statistic
A human-readable description of the Statistic.
getDescription() - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns a human readable description of the MBean.
getDescription(String) - Method in class javax.management.openmbean.CompositeType
Returns the description of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.
getDescription() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo
Returns a human readable description of the constructor described by this OpenMBeanConstructorInfo instance.
getDescription() - Method in interface javax.management.openmbean.OpenMBeanInfo
Returns a human readable description of the type of open MBean instances this OpenMBeanInfo describes.
getDescription() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Returns a human readable description of the operation described by this OpenMBeanOperationInfo instance.
getDescription() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns a human readable description of the parameter described by this OpenMBeanParameterInfo instance.
getDescription() - Method in class javax.management.openmbean.OpenType
Returns the text description of this OpenType instance.
getDescription() - Method in class javax.management.relation.RoleInfo
Returns description text for the role.
getDescription() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the textual description for this object.
getDescriptor() - Method in interface javax.management.DescriptorAccess
Returns a copy of Descriptor.
getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanAttributeInfo
Gets a copy of the associated Descriptor for the ModelMBeanAttributeInfo.
getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanConstructorInfo
Returns a copy of the associated Descriptor.
getDescriptor(String, String) - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns a Descriptor requested by name and descriptorType.
getDescriptor(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
Returns a Descriptor requested by name.
getDescriptor(String, String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanNotificationInfo
Returns a copy of the associated Descriptor for the ModelMBeanNotificationInfo.
getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanOperationInfo
Returns a copy of the associated Descriptor of the ModelMBeanOperationInfo.
getDescriptors(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.
getDescriptors(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
getDeserializer(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping
Gets the DeserializerFactory registered for the specified pair of Java type and XML data type.
getDeserializerAs(String) - Method in interface javax.xml.rpc.encoding.DeserializerFactory
Returns a Deserializer for the specified XML processing mechanism type.
getDestination() - Method in interface javax.jms.MessageProducer
Gets the destination associated with this MessageProducer.
getDestination() - Method in interface javax.management.j2ee.statistics.JMSProducerStats
Returns a string that encapsulates the identity of the message destination
getDetail() - Method in class javax.xml.rpc.soap.SOAPFaultException
Gets the detail element.
getDetail() - Method in interface javax.xml.soap.SOAPFault
Returns the optional detail element for this SOAPFault object.
getDetailEntries() - Method in interface javax.xml.soap.Detail
Gets an Iterator over all of the DetailEntrys in this Detail object.
getDifferenceMode() - Method in class javax.management.monitor.CounterMonitor
Gets the difference mode flag value common to all observed MBeans.
getDifferenceMode() - Method in interface javax.management.monitor.CounterMonitorMBean
Gets the difference mode flag value.
getDifferenceMode() - Method in class javax.management.monitor.GaugeMonitor
Gets the difference mode flag value common to all observed MBeans.
getDifferenceMode() - Method in interface javax.management.monitor.GaugeMonitorMBean
Gets the difference mode flag value.
getDimension() - Method in class javax.management.openmbean.ArrayType
Returns the dimension of arrays described by this ArrayType instance.
getDisableMessageID() - Method in interface javax.jms.MessageProducer
Gets an indication of whether message IDs are disabled.
getDisableMessageTimestamp() - Method in interface javax.jms.MessageProducer
Gets an indication of whether message timestamps are disabled.
getDisabledObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter
Gets all the ObjectNames disabled.
getDisconnectedDeploymentManager(String) - Method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
Return a disconnected DeploymentManager instance.
getDisconnectedDeploymentManager(String) - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Return a disconnected DeploymentManager instance.
getDisplayName() - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Provide a string with the name of this vendor's DeploymentManager.
getDisplayName() - Method in class javax.servlet.jsp.tagext.TagInfo
Get the displayName.
getDisposition() - Method in interface javax.mail.Part
Return the disposition of this part.
getDisposition() - Method in class javax.mail.internet.ContentDisposition
Return the disposition value.
getDisposition() - Method in class javax.mail.internet.MimeBodyPart
Returns the value of the "Content-Disposition" header field.
getDisposition() - Method in class javax.mail.internet.MimeMessage
Returns the value of the "Content-Disposition" header field.
getDomain() - Method in class javax.management.ObjectName
Returns the domain part.
getDomain() - Method in class javax.servlet.http.Cookie
Returns the domain name set for this cookie.
getDomains() - Method in interface javax.management.MBeanServer
Returns the list of domains in which any MBean is currently registered.
getDomains() - Method in interface javax.management.MBeanServerConnection
Returns the list of domains in which any MBean is currently registered.
getDouble(String) - Method in interface javax.jms.MapMessage
Returns the double value with the specified name.
getDoubleProperty(String) - Method in interface javax.jms.Message
Returns the value of the double property with the specified name.
getDurableSubscriptionCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Number of durable subscriptions.
getEISProductName() - Method in interface javax.resource.cci.ConnectionMetaData
Returns product name of the underlying EIS instance connected through the Connection that produced this metadata.
getEISProductName() - Method in interface javax.resource.spi.ManagedConnectionMetaData
Returns Product name of the underlying EIS instance connected through the ManagedConnection.
getEISProductVersion() - Method in interface javax.resource.cci.ConnectionMetaData
Returns product version of the underlying EIS instance.
getEISProductVersion() - Method in interface javax.resource.spi.ManagedConnectionMetaData
Returns product version of the underlying EIS instance connected through the ManagedConnection.
getEJBHome() - Method in interface javax.ejb.EJBContext
Obtain the enterprise bean's remote home interface.
getEJBHome() - Method in interface javax.ejb.EJBMetaData
Obtain the remote home interface of the enterprise Bean.
getEJBHome() - Method in interface javax.ejb.EJBObject
Obtain the enterprise Bean's remote home interface.
getEJBHome() - Method in interface javax.ejb.HomeHandle
Obtain the home object represented by this handle.
getEJBLocalHome() - Method in interface javax.ejb.EJBContext
Obtain the enterprise bean's local home interface.
getEJBLocalHome() - Method in interface javax.ejb.EJBLocalObject
Obtain the enterprise Bean's local home interface.
getEJBLocalObject() - Method in interface javax.ejb.EntityContext
Obtain a reference to the EJB local object that is currently associated with the instance.
getEJBLocalObject() - Method in interface javax.ejb.SessionContext
Obtain a reference to the EJB local object that is associated with the instance.
getEJBMetaData() - Method in interface javax.ejb.EJBHome
Obtain the EJBMetaData interface for the enterprise Bean.
getEJBObject() - Method in interface javax.ejb.EntityContext
Obtain a reference to the EJB object that is currently associated with the instance.
getEJBObject() - Method in interface javax.ejb.Handle
Obtain the EJB object reference represented by this handle.
getEJBObject() - Method in interface javax.ejb.SessionContext
Obtain a reference to the EJB object that is currently associated with the instance.
getElementName() - Method in interface javax.xml.soap.SOAPElement
Returns the name of this SOAPElement object.
getElementOpenType() - Method in class javax.management.openmbean.ArrayType
Returns the open type of element values contained in the arrays described by this ArrayType instance.
getEmailAddresses() - Method in interface javax.xml.registry.infomodel.User
Gets the email addresses for this User.
getEnabledAttributes() - Method in class javax.management.AttributeChangeNotificationFilter
Gets all the enabled attribute names for this filter.
getEnabledObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter
Gets all the ObjectNames enabled.
getEnabledTypes() - Method in class javax.management.NotificationFilterSupport
Gets all the enabled notification types for this filter.
getEnclosingWriter() - Method in class javax.servlet.jsp.tagext.BodyContent
Get the enclosing JspWriter.
getEncoding() - Method in class javax.mail.internet.MimeBodyPart
Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
getEncoding() - Method in class javax.mail.internet.MimeMessage
Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
getEncoding() - Method in interface javax.mail.internet.MimePart
Get the transfer encoding of this part.
getEncoding(DataSource) - Static method in class javax.mail.internet.MimeUtility
Get the content-transfer-encoding that should be applied to the input stream of this datasource, to make it mailsafe.
getEncoding(DataHandler) - Static method in class javax.mail.internet.MimeUtility
Same as getEncoding(DataSource) except that instead of reading the data from an InputStream it uses the writeTo method to examine the data.
getEncodingStyle() - Method in interface javax.xml.soap.SOAPElement
Returns the encoding style for this SOAPElement object.
getEngineInfo() - Method in class javax.servlet.jsp.JspFactory
called to get implementation-specific information on the current JSP engine.
getEntry(String) - Method in interface javax.enterprise.deploy.model.DeployableObject
Returns the InputStream for the given entry name The file name must be relative to the root of the module.
getEnumValueTable() - Method in class javax.enterprise.deploy.shared.ActionType
Returns the enumeration value table for class ActionType
getEnumValueTable() - Method in class javax.enterprise.deploy.shared.CommandType
Returns the enumeration value table for class CommandType
getEnumValueTable() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType
Returns the enumeration value table for class DConfigBeanVersionType
getEnumValueTable() - Method in class javax.enterprise.deploy.shared.ModuleType
Returns the enumeration value table for class ModuleType
getEnumValueTable() - Method in class javax.enterprise.deploy.shared.StateType
Returns the enumeration value table for class StateType
getEnumeration() - Method in interface javax.jms.QueueBrowser
Gets an enumeration for browsing the current queue messages in the order they would be received.
getEnvelope() - Method in class javax.xml.soap.SOAPPart
Gets the SOAPEnvelope object associated with this SOAPPart object.
getEnvironment() - Method in interface javax.ejb.EJBContext
Deprecated. Use the JNDI naming context java:comp/env to access enterprise bean's environment.
getErrorCode() - Method in class javax.jms.JMSException
Gets the vendor-specific error code.
getErrorCode() - Method in class javax.resource.ResourceException
Get the error code.
getErrorData() - Method in class javax.servlet.jsp.PageContext
Provides convenient access to error information.
getErrorListener() - Method in class javax.xml.transform.Transformer
Get the error event handler in effect for the transformation.
getErrorListener() - Method in class javax.xml.transform.TransformerFactory
Get the error event handler for the TransformerFactory.
getErrorObjectKey() - Method in class javax.xml.registry.RegistryException
Gets the Key to the first object that encountered an error in the registry.
getEventType() - Method in interface javax.xml.registry.infomodel.AuditableEvent
Gets the type of this event.
getException() - Method in class javax.resource.spi.ConnectionEvent
Get the exception.
getException() - Method in class javax.resource.spi.work.WorkEvent
Return the WorkException.
getException() - Method in class javax.servlet.jsp.PageContext
The current value of the exception object (an Exception).
getException() - Method in class javax.xml.parsers.FactoryConfigurationError
Return the actual exception (if any) that caused this exception to be raised.
getException() - Method in class javax.xml.transform.TransformerException
This method retrieves an exception that this exception wraps.
getException() - Method in class javax.xml.transform.TransformerFactoryConfigurationError
Return the actual exception (if any) that caused this exception to be raised.
getExceptionListener() - Method in interface javax.jms.Connection
Gets the ExceptionListener object for this connection.
getExceptions() - Method in interface javax.xml.registry.BulkResponse
Get the Collection of RegistryException instances in case of partial commit.
getExp() - Method in class javax.management.BadBinaryOpValueExpException
Returns the ValueExp that originated the exception.
getExpiration() - Method in interface javax.xml.registry.infomodel.RegistryEntry
Gets expirationDate attribute of the RegistryEntry within the Registry.
getExpiredMessageCount() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats
Number of messages that expired before delivery.
getExpiredMessageCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Number of expired messages.
getExpressionEvaluator() - Method in class javax.servlet.jsp.JspContext
Provides programmatic access to the ExpressionEvaluator.
getExtension() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
Gets the internal extension.
getExternalIdentifiers() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the ExternalIdentifiers associated with this object that are external identifiers for this object.
getExternalLinks() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the ExternalLinks associated with this object.
getExternalURI() - Method in interface javax.xml.registry.infomodel.ExternalLink
Gets URI to the an external resource.
getFault() - Method in interface javax.xml.soap.SOAPBody
Returns the SOAPFault object in this SOAPBody object.
getFaultActor() - Method in class javax.xml.rpc.soap.SOAPFaultException
Gets the faultactor element.
getFaultActor() - Method in interface javax.xml.soap.SOAPFault
Gets the fault actor for this SOAPFault object.
getFaultCode() - Method in class javax.xml.rpc.soap.SOAPFaultException
Gets the faultcode element.
getFaultCode() - Method in interface javax.xml.soap.SOAPFault
Gets the fault code for this SOAPFault object.
getFaultCodeAsName() - Method in interface javax.xml.soap.SOAPFault
Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.
getFaultString() - Method in class javax.xml.rpc.soap.SOAPFaultException
Gets the faultstring element.
getFaultString() - Method in interface javax.xml.soap.SOAPFault
Gets the fault string for this SOAPFault object.
getFaultStringLocale() - Method in interface javax.xml.soap.SOAPFault
Gets the locale of the fault string for this SOAPFault object.
getFeature(String) - Method in class javax.xml.parsers.SAXParserFactory
Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
getFeature(String) - Method in class javax.xml.transform.TransformerFactory
Look up the value of a feature.
getFieldNames() - Method in interface javax.management.Descriptor
Returns all the fields names in the descriptor.
getFieldNames() - Method in class javax.management.modelmbean.DescriptorSupport
Returns all the fields names in the descriptor.
getFieldValue(String) - Method in interface javax.management.Descriptor
Returns the value for a specific fieldname.
getFieldValue(String) - Method in class javax.management.modelmbean.DescriptorSupport
Returns the value for a specific fieldname.
getFieldValues(String[]) - Method in interface javax.management.Descriptor
Returns all the field values in the descriptor as an array of Objects.
getFieldValues(String[]) - Method in class javax.management.modelmbean.DescriptorSupport
Returns all the field values in the descriptor as an array of Objects.
getFields() - Method in interface javax.management.Descriptor
Returns all of the fields contained in this descriptor as a string array.
getFields() - Method in class javax.management.modelmbean.DescriptorSupport
Returns all the fields in the descriptor.
getFile() - Method in class javax.activation.FileDataSource
Return the File object that corresponds to this FileDataSource.
getFile() - Method in class javax.mail.URLName
Returns the file name of this URLName.
getFileName() - Method in interface javax.mail.Part
Get the filename associated with this part, if possible.
getFileName() - Method in class javax.mail.internet.MimeBodyPart
Get the filename associated with this body part.
getFileName() - Method in class javax.mail.internet.MimeMessage
Get the filename associated with this Message.
getFilename() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Returns the filename relative to the root of the module of the XML instance document this DDBeanRoot represents.
getFilterName() - Method in interface javax.servlet.FilterConfig
Returns the filter-name of this filter as defined in the deployment descriptor.
getFirstName() - Method in interface javax.xml.registry.infomodel.PersonName
Gets the first name for this Person.
getFixedRate(Integer) - Method in class javax.management.timer.Timer
Gets a copy of the flag indicating whether a peridic notification is executed at fixed-delay or at fixed-rate.
getFixedRate(Integer) - Method in interface javax.management.timer.TimerMBean
Gets a copy of the flag indicating whether a peridic notification is executed at fixed-delay or at fixed-rate.
getFlags() - Method in class javax.mail.Message
Returns a Flags object containing the flags for this message.
getFlags() - Method in class javax.mail.internet.MimeMessage
Return a Flags object containing the flags for this message.
getFlags() - Method in class javax.mail.search.FlagTerm
Return the Flags to test.
getFloat(String) - Method in interface javax.jms.MapMessage
Returns the float value with the specified name.
getFloatProperty(String) - Method in interface javax.jms.Message
Returns the value of the float property with the specified name.
getFolder(String) - Method in class javax.mail.Folder
Return the Folder object corresponding to the given name.
getFolder() - Method in class javax.mail.FolderClosedException
Returns the dead Folder object
getFolder() - Method in class javax.mail.FolderNotFoundException
Returns the offending Folder object.
getFolder() - Method in class javax.mail.Message
Get the folder from which this message was obtained.
getFolder() - Method in class javax.mail.ReadOnlyFolderException
Returns the dead Folder object.
getFolder(URLName) - Method in class javax.mail.Session
Get a closed Folder object for the given URLName.
getFolder(String) - Method in class javax.mail.Store
Return the Folder object corresponding to the given name.
getFolder(URLName) - Method in class javax.mail.Store
Return a closed Folder object, corresponding to the given URLName.
getFolder() - Method in class javax.mail.event.FolderEvent
Return the affected folder.
getFormatId() - Method in interface javax.transaction.xa.Xid
Obtain the format identifier part of the XID.
getFreePoolSize() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats
The number of free connections in the pool
getFreePoolSize() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
Number of free connections in the pool.
getFrom() - Method in class javax.mail.Message
Returns the "From" attribute.
getFrom() - Method in class javax.mail.internet.MimeMessage
Returns the value of the RFC 822 "From" header fields.
getFullName() - Method in class javax.mail.Folder
Returns the full name of this Folder.
getFullName() - Method in interface javax.xml.registry.infomodel.PersonName
Gets the fully formatted name for this person.
getFunction(String) - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
Get the FunctionInfo for a given function name, looking through all the functions in this tag library.
getFunctionClass() - Method in class javax.servlet.jsp.tagext.FunctionInfo
The class of the function.
getFunctionSignature() - Method in class javax.servlet.jsp.tagext.FunctionInfo
The signature of the function.
getFunctions() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
An array describing the functions that are defined in this tag library.
getGlobalTransactionId() - Method in interface javax.transaction.xa.Xid
Obtain the global transaction identifier part of XID as an array of bytes.
getGranularityPeriod() - Method in class javax.management.monitor.Monitor
Gets the granularity period (in milliseconds).
getGranularityPeriod() - Method in interface javax.management.monitor.MonitorMBean
Gets the granularity period (in milliseconds).
getGroup(boolean) - Method in class javax.mail.internet.InternetAddress
Return the members of a group address.
getHandle() - Method in interface javax.ejb.EJBObject
Obtain a handle for the EJB object.
getHandle() - Method in interface javax.ejb.Timer
Get a serializable handle to the timer.
getHandler() - Method in class javax.xml.transform.sax.SAXResult
Get the ContentHandler that is the Result.
getHandlerChain(QName) - Method in interface javax.xml.rpc.handler.HandlerRegistry
Gets the handler chain for the specified service endpoint.
getHandlerClass() - Method in class javax.xml.rpc.handler.HandlerInfo
Gets the Handler class
getHandlerConfig() - Method in class javax.xml.rpc.handler.HandlerInfo
Gets the Handler configuration
getHandlerKeys() - Static method in class javax.security.jacc.PolicyContext
This method may be used to obtain the keys that identify the container specific context handlers registered by the container.
getHandlerRegistry() - Method in interface javax.xml.rpc.Service
Returns the configured HandlerRegistry instance for this Service instance.
getHeader(String) - Method in interface javax.mail.Part
Get all the headers for this header name.
getHeader(String) - Method in class javax.mail.internet.InternetHeaders
Return all the values for the specified header.
getHeader(String, String) - Method in class javax.mail.internet.InternetHeaders
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
getHeader(String) - Method in class javax.mail.internet.MimeBodyPart
Get all the headers for this header_name.
getHeader(String, String) - Method in class javax.mail.internet.MimeBodyPart
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
getHeader(String) - Method in class javax.mail.internet.MimeMessage
Get all the headers for this header_name.
getHeader(String, String) - Method in class javax.mail.internet.MimeMessage
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
getHeader(String, String) - Method in interface javax.mail.internet.MimePart
Get the values of all header fields available for this header, returned as a single String, with the values separated by the delimiter.
getHeader(String) - Method in interface javax.servlet.http.HttpServletRequest
Returns the value of the specified request header as a String.
getHeader(String) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getHeader(String name) on the wrapped request object.
getHeader(String) - Method in class javax.xml.soap.MimeHeaders
Returns all of the values for the specified header as an array of String objects.
getHeader() - Method in interface javax.xml.soap.SOAPEnvelope
Returns the SOAPHeader object for this SOAPEnvelope object.
getHeaderName() - Method in class javax.mail.search.HeaderTerm
Return the name of the header to compare with.
getHeaderNames() - Method in class javax.mail.FetchProfile
Get the names of the header-fields set in this profile.
getHeaderNames() - Method in interface javax.servlet.http.HttpServletRequest
Returns an enumeration of all the header names this request contains.
getHeaderNames() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getHeaderNames() on the wrapped request object.
getHeaders(String) - Method in interface javax.servlet.http.HttpServletRequest
Returns all the values of the specified request header as an Enumeration of String objects.
getHeaders(String) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getHeaders(String name) on the wrapped request object.
getHeaders() - Method in class javax.xml.rpc.handler.GenericHandler
Gets the header blocks processed by this Handler instance.
getHeaders() - Method in interface javax.xml.rpc.handler.Handler
Gets the header blocks that can be processed by this Handler instance.
getHeaders() - Method in class javax.xml.rpc.handler.HandlerInfo
Gets the header blocks processed by this Handler.
getHeapSize() - Method in interface javax.management.j2ee.statistics.JVMStats
Size of the JVM's heap.
getHighThreshold() - Method in class javax.management.monitor.GaugeMonitor
Gets the high threshold value common to all observed MBeans.
getHighThreshold() - Method in interface javax.management.monitor.GaugeMonitorMBean
Gets the high threshold value.
getHighWaterMark() - Method in interface javax.management.j2ee.statistics.RangeStatistic
The highest value this attribute has held since the beginning of the measurement.
getHomeHandle() - Method in interface javax.ejb.EJBHome
Obtain a handle for the remote home object.
getHomeInterfaceClass() - Method in interface javax.ejb.EJBMetaData
Obtain the Class object for the enterprise Bean's remote home interface.
getHost() - Method in class javax.mail.URLName
Returns the host of this URLName.
getHost() - Method in class javax.mail.internet.NewsAddress
Get the host.
getHttpSession() - Method in interface javax.xml.rpc.server.ServletEndpointContext
The getHttpSession method returns the current HTTP session (as a javax.servlet.http.HTTPSession).
getHumanPresentableName() - Method in class javax.activation.ActivationDataFlavor
Return the Human Presentable name.
getId() - Method in interface javax.enterprise.deploy.model.DDBean
Returns a tool-specific reference for attribute ID on an element in the deployment descriptor.
getId() - Method in class javax.resource.spi.ConnectionEvent
Get the type of event
getId() - Method in interface javax.servlet.http.HttpSession
Returns a string containing the unique identifier assigned to this session.
getId() - Method in class javax.servlet.jsp.tagext.TagData
The value of the tag's id attribute.
getId() - Method in class javax.servlet.jsp.tagext.TagSupport
The value of the id attribute of this tag; or null.
getId() - Method in class javax.servlet.jsp.tagext.ValidationMessage
Get the jsp:id.
getId() - Method in interface javax.xml.registry.infomodel.Key
Returns the unique Id of this key.
getIdAttribute(TagAttributeInfo[]) - Static method in class javax.servlet.jsp.tagext.TagAttributeInfo
Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".
getIdentificationScheme() - Method in interface javax.xml.registry.infomodel.ExternalIdentifier
Gets the ClassificationScheme that is used as the identification scheme for identifying this object.
getIds() - Method in interface javax.servlet.http.HttpSessionContext
Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.
getIgnoreCase() - Method in class javax.mail.search.StringTerm
Return true if we should ignore case when matching.
getImpact() - Method in class javax.management.MBeanOperationInfo
Returns the impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN.
getImpact(MBeanOperationInfo) - Method in class javax.management.StandardMBean
Customization hook: Get the impact flag of the operation that will be used in the MBeanOperationInfo returned by this MBean.
getImpact() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Returns an int constant qualifying the impact of the operation described by this OpenMBeanOperationInfo instance.
getImplementation() - Method in class javax.management.StandardMBean
Get the implementation of this MBean.
getImplementationClass() - Method in class javax.management.StandardMBean
Get the class of the implementation of this MBean.
getImplementationName() - Method in class javax.management.MBeanServerDelegate
Returns the JMX implementation name (the name of this product).
getImplementationName() - Method in interface javax.management.MBeanServerDelegateMBean
Returns the JMX implementation name (the name of this product).
getImplementationVendor() - Method in class javax.management.MBeanServerDelegate
Returns the JMX implementation vendor (the vendor of this product).
getImplementationVendor() - Method in interface javax.management.MBeanServerDelegateMBean
Returns the JMX implementation vendor (the vendor of this product).
getImplementationVersion() - Method in class javax.management.MBeanServerDelegate
Returns the JMX implementation version (the version of this product).
getImplementationVersion() - Method in interface javax.management.MBeanServerDelegateMBean
Returns the JMX implementation version (the version of this product).
getIndexNames() - Method in class javax.management.openmbean.TabularType
Returns, in the same order as was given to this instance's constructor, an unmodifiable List of the names of the items the values of which are used to uniquely index each row element of tabular data values described by this TabularType instance.
getInfo() - Method in interface javax.ejb.Timer
Get the information associated with the timer at the time of creation.
getInfoString() - Method in class javax.servlet.jsp.tagext.TagInfo
The information string for the tag.
getInfoString() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
Information (documentation) for this TLD.
getInitParameter(String) - Method in interface javax.servlet.FilterConfig
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
getInitParameter(String) - Method in class javax.servlet.GenericServlet
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
getInitParameter(String) - Method in interface javax.servlet.ServletConfig
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
getInitParameter(String) - Method in interface javax.servlet.ServletContext
Returns a String containing the value of the named context-wide initialization parameter, or null if the parameter does not exist.
getInitParameterNames() - Method in interface javax.servlet.FilterConfig
Returns the names of the filter's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the filter has no initialization parameters.
getInitParameterNames() - Method in class javax.servlet.GenericServlet
Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
getInitParameterNames() - Method in interface javax.servlet.ServletConfig
Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
getInitParameterNames() - Method in interface javax.servlet.ServletContext
Returns the names of the context's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the context has no initialization parameters.
getInitParameters() - Method in class javax.servlet.jsp.tagext.TagLibraryValidator
Get the init parameters data as an immutable Map.
getInitThreshold() - Method in class javax.management.monitor.CounterMonitor
Gets the initial threshold value common to all observed objects.
getInitThreshold() - Method in interface javax.management.monitor.CounterMonitorMBean
Gets the initial threshold value common to all observed objects.
getInputSource() - Method in class javax.xml.transform.sax.SAXSource
Get the SAX InputSource to be used for the Source.
getInputStream() - Method in class javax.activation.DataHandler
Get the InputStream for this object.
getInputStream() - Method in interface javax.activation.DataSource
This method returns an InputStream representing the data and throws the appropriate exception if it can not do so.
getInputStream() - Method in class javax.activation.FileDataSource
This method will return an InputStream representing the the data and will throw an IOException if it can not do so.
getInputStream() - Method in class javax.activation.URLDataSource
The getInputStream method from the URL.
getInputStream() - Method in interface javax.mail.Part
Return an input stream for this part's "content".
getInputStream() - Method in class javax.mail.internet.MimeBodyPart
Return a decoded input stream for this body part's "content".
getInputStream() - Method in class javax.mail.internet.MimeMessage
Return a decoded input stream for this Message's "content".
getInputStream() - Method in class javax.mail.internet.MimePartDataSource
Returns an input stream from this MimePart.
getInputStream() - Method in interface javax.servlet.ServletRequest
Retrieves the body of the request as binary data using a ServletInputStream.
getInputStream() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getInputStream() on the wrapped request object.
getInputStream() - Method in class javax.servlet.jsp.tagext.PageData
Returns an input stream on the XML view of a JSP page.
getInputStream() - Method in class javax.xml.transform.stream.StreamSource
Get the byte stream that was set with setByteStream.
getInstance() - Static method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
Retrieve the Singleton DeploymentFactoryManager
getInstance(Properties, Authenticator) - Static method in class javax.mail.Session
Get a new Session object.
getInstance(Properties) - Static method in class javax.mail.Session
Get a new Session object.
getInstance(String) - Static method in class javax.management.ObjectName
Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(name) can be used.
getInstance(String, String, String) - Static method in class javax.management.ObjectName
Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, key, value) can be used.
getInstance(String, Hashtable) - Static method in class javax.management.ObjectName
Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, table) can be used.
getInstance(ObjectName) - Static method in class javax.management.ObjectName
Return an instance of ObjectName that can be used anywhere the given object can be used.
getInt(String) - Method in interface javax.jms.MapMessage
Returns the int value with the specified name.
getIntHeader(String) - Method in interface javax.servlet.http.HttpServletRequest
Returns the value of the specified request header as an int.
getIntHeader(String) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getIntHeader(String name) on the wrapped request object.
getIntProperty(String) - Method in interface javax.jms.Message
Returns the value of the int property with the specified name.
getInteractionSpecsSupported() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Returns an array of fully-qualified names of InteractionSpec types supported by the CCI implementation for this resource adapter.
getInvalidAddresses() - Method in class javax.mail.SendFailedException
Return the addresses to which this message could not be sent.
getInvalidAddresses() - Method in class javax.mail.event.TransportEvent
Return the addresses to which this message could not be sent.
getInvalidConnections(Set) - Method in interface javax.resource.spi.ValidatingManagedConnectionFactory
This method returns a set of invalid ManagedConnection objects chosen from a specified set of ManagedConnection objects.
getInvalidPropertyDescriptors() - Method in class javax.resource.spi.InvalidPropertyException
Get the list of invalid properties.
getItems() - Method in class javax.mail.FetchProfile
Get the items set in this profile.
getJMSCorrelationID() - Method in interface javax.jms.Message
Gets the correlation ID for the message.
getJMSCorrelationIDAsBytes() - Method in interface javax.jms.Message
Gets the correlation ID as an array of bytes for the message.
getJMSDeliveryMode() - Method in interface javax.jms.Message
Gets the DeliveryMode value specified for this message.
getJMSDestination() - Method in interface javax.jms.Message
Gets the Destination object for this message.
getJMSExpiration() - Method in interface javax.jms.Message
Gets the message's expiration value.
getJMSMajorVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS major version number.
getJMSMessageID() - Method in interface javax.jms.Message
Gets the message ID.
getJMSMinorVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS minor version number.
getJMSPriority() - Method in interface javax.jms.Message
Gets the message priority level.
getJMSProviderName() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS provider name.
getJMSRedelivered() - Method in interface javax.jms.Message
Gets an indication of whether this message is being redelivered.
getJMSReplyTo() - Method in interface javax.jms.Message
Gets the Destination object to which a reply to this message should be sent.
getJMSTimestamp() - Method in interface javax.jms.Message
Gets the message timestamp.
getJMSType() - Method in interface javax.jms.Message
Gets the message type identifier supplied by the client when the message was sent.
getJMSVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS API version.
getJMSXPropertyNames() - Method in interface javax.jms.ConnectionMetaData
Gets an enumeration of the JMSX property names.
getJdbcDataSource() - Method in interface javax.management.j2ee.statistics.JDBCConnectionStats
Identifies the JDBC driver for the corresponding JDBCConnection.
getJspBody() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport
Returns the body passed in by the container via setJspBody.
getJspContext() - Method in class javax.servlet.jsp.tagext.JspFragment
Returns the JspContext that is bound to this JspFragment.
getJspContext() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport
Returns the page context passed in by the container via setJspContext.
getKey() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the key representing the universally unique ID (UUID) for this object.
getKeyProperty(String) - Method in class javax.management.ObjectName
Obtains the value associated with a key in a key property.
getKeyPropertyList() - Method in class javax.management.ObjectName
Returns the key properties as a Hashtable.
getKeyPropertyListString() - Method in class javax.management.ObjectName
Returns a string representation of the list of key properties specified at creation time.
getKeys() - Method in interface javax.security.jacc.PolicyContextHandler
This public method returns the keys identifying the context objects supported by the handler.
getLargeIcon() - Method in class javax.servlet.jsp.tagext.TagInfo
Get the path to the large icon.
getLastAccessedTime() - Method in interface javax.servlet.http.HttpSession
Returns the last time the client sent a request associated with this session, as the number of milliseconds since midnight January 1, 1970 GMT, and marked by the time the container received the request.
getLastModified(HttpServletRequest) - Method in class javax.servlet.http.HttpServlet
Returns the time the HttpServletRequest object was last modified, in milliseconds since midnight January 1, 1970 GMT.
getLastName() - Method in interface javax.xml.registry.infomodel.PersonName
Gets the last name (surname) for this Person.
getLastSampleTime() - Method in interface javax.management.j2ee.statistics.Statistic
The time of the last measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
getLegalValues() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns an unmodifiable Set of legal values for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
getLegalValues() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns the set of legal values for this parameter, if it has one, or null otherwise.
getLegalValues() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns an unmodifiable Set of legal values for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
getLexicalHandler() - Method in class javax.xml.transform.sax.SAXResult
Get a SAX2 LexicalHandler for the output.
getLibraryDirectory() - Method in class javax.management.loading.MLet
Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.
getLibraryDirectory() - Method in interface javax.management.loading.MLetMBean
Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.
getLifeCycleManager() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the LifeCycleManager that created this object.
getLineCount() - Method in interface javax.mail.Part
Return the number of lines in the content of this part.
getLineCount() - Method in class javax.mail.internet.MimeBodyPart
Return the number of lines for the content of this Part.
getLineCount() - Method in class javax.mail.internet.MimeMessage
Return the number of lines for the content of this message.
getLineNumber() - Method in interface javax.xml.transform.SourceLocator
Return the line number where the current document event ends.
getLinkedCause() - Method in class javax.xml.rpc.JAXRPCException
Gets the Linked cause
getLinkedCause() - Method in class javax.xml.rpc.ServiceException
Gets the Linked cause
getLinkedException() - Method in class javax.jms.JMSException
Gets the exception linked to this one.
getLinkedException() - Method in class javax.resource.ResourceException
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..
getLinkedObjects() - Method in interface javax.xml.registry.infomodel.ExternalLink
Gets the collection of RegistryObjects that are annotated by this ExternalLink.
getLinkedWarning() - Method in class javax.resource.cci.ResourceWarning
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
getListenerRegistry() - Method in interface javax.management.j2ee.Management
Returns the listener registry implementation for this MEJB.
getLocalAddr() - Method in interface javax.servlet.ServletRequest
Returns the Internet Protocol (IP) address of the interface on which the request was received.
getLocalAddr() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getLocalAddr() on the wrapped request object.
getLocalAddress(Session) - Static method in class javax.mail.internet.InternetAddress
Return an InternetAddress object representing the current user.
getLocalName() - Method in interface javax.servlet.ServletRequest
Returns the host name of the Internet Protocol (IP) interface on which the request was received.
getLocalName() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getLocalName() on the wrapped request object.
getLocalName() - Method in interface javax.xml.soap.Name
Gets the local name part of the XML name that this Name object represents.
getLocalPart() - Method in class javax.xml.namespace.QName
Get the local part of this QName.
getLocalPort() - Method in interface javax.servlet.ServletRequest
Returns the Internet Protocol (IP) port number of the interface on which the request was received.
getLocalPort() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getLocalPort() on the wrapped request object.
getLocalTransaction() - Method in interface javax.resource.cci.Connection
Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection.
getLocalTransaction() - Method in interface javax.resource.spi.ManagedConnection
Returns an javax.resource.spi.LocalTransaction instance.
getLocale() - Method in interface javax.servlet.ServletRequest
Returns the preferred Locale that the client will accept content in, based on the Accept-Language header.
getLocale() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getLocale() on the wrapped request object.
getLocale() - Method in interface javax.servlet.ServletResponse
Returns the locale specified for this response using the ServletResponse.setLocale(java.util.Locale) method.
getLocale() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getLocale() on the wrapped response object.
getLocale() - Method in interface javax.xml.registry.infomodel.LocalizedString
Get the Locale for this object.
getLocales() - Method in interface javax.servlet.ServletRequest
Returns an Enumeration of Locale objects indicating, in decreasing order starting with the preferred locale, the locales that are acceptable to the client based on the Accept-Language header.
getLocales() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getLocales() on the wrapped request object.
getLocalizedString(Locale, String) - Method in interface javax.xml.registry.infomodel.InternationalString
Gets the LocalizedString for the specified Locale and charsetName.
getLocalizedStrings() - Method in interface javax.xml.registry.infomodel.InternationalString
Returns the LocalizedStrings associated with this object.
getLocationAsString() - Method in class javax.xml.transform.TransformerException
Get the location information as a string.
getLocator() - Method in class javax.xml.transform.TransformerException
Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.
getLogWriter() - Method in interface javax.resource.spi.ManagedConnection
Gets the log writer for this ManagedConnection instance.
getLogWriter() - Method in interface javax.resource.spi.ManagedConnectionFactory
Get the log writer for this ManagedConnectionFactory instance.
getLong(String) - Method in interface javax.jms.MapMessage
Returns the long value with the specified name.
getLongProperty(String) - Method in interface javax.jms.Message
Returns the value of the long property with the specified name.
getLowThreshold() - Method in class javax.management.monitor.GaugeMonitor
Gets the low threshold value common to all observed MBeans.
getLowThreshold() - Method in interface javax.management.monitor.GaugeMonitorMBean
Gets the low threshold value.
getLowWaterMark() - Method in interface javax.management.j2ee.statistics.RangeStatistic
The lowest value this attribute has held since the beginning of the measurement.
getLowerBound() - Method in interface javax.management.j2ee.statistics.BoundaryStatistic
The lower limit of the value of this attribute.The upper limit of the value of this attribute.
getMBeanCount() - Method in interface javax.management.MBeanServer
Returns the number of MBeans registered in the MBean server.
getMBeanCount() - Method in interface javax.management.MBeanServerConnection
Returns the number of MBeans registered in the MBean server.
getMBeanCount() - Method in interface javax.management.j2ee.Management
Returns the number of managed objects registered in the MEJB.
getMBeanDescriptor() - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns the ModelMBean's descriptor which contains MBean wide policies.
getMBeanDescriptor() - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
getMBeanInfo() - Method in interface javax.management.DynamicMBean
Provides the exposed attributes and actions of the Dynamic MBean using an MBeanInfo object.
getMBeanInfo(ObjectName) - Method in interface javax.management.MBeanServer
This method discovers the attributes and operations that an MBean exposes for management.
getMBeanInfo(ObjectName) - Method in interface javax.management.MBeanServerConnection
This method discovers the attributes and operations that an MBean exposes for management.
getMBeanInfo() - Method in class javax.management.StandardMBean
Get the MBeanInfo for this MBean.
getMBeanInfo(ObjectName) - Method in interface javax.management.j2ee.Management
This method discovers the attributes and operations that a managed object exposes for management.
getMBeanInfo() - Method in class javax.management.modelmbean.RequiredModelMBean
Returns the attributes, operations, constructors and notifications that this RequiredModelMBean exposes for management.
getMBeanInterface() - Method in class javax.management.StandardMBean
Get the Management Interface of this MBean.
getMBeanName() - Method in class javax.management.MBeanServerNotification
Returns the object name of the MBean that caused the notification.
getMBeanServer() - Static method in class javax.management.QueryEval
Return the MBean server that was most recently given to the setMBeanServer method by this thread.
getMBeanServerId() - Method in class javax.management.MBeanServerDelegate
Returns the MBean server agent identity.
getMBeanServerId() - Method in interface javax.management.MBeanServerDelegateMBean
Returns the MBean server agent identity.
getMBeansFromURL(URL) - Method in class javax.management.loading.MLet
Loads a text file containing MLET tags that define the MBeans to be added to the agent.
getMBeansFromURL(String) - Method in class javax.management.loading.MLet
Loads a text file containing MLET tags that define the MBeans to be added to the agent.
getMBeansFromURL(String) - Method in interface javax.management.loading.MLetMBean
Loads a text file containing MLET tags that define the MBeans to be added to the agent.
getMBeansFromURL(URL) - Method in interface javax.management.loading.MLetMBean
Loads a text file containing MLET tags that define the MBeans to be added to the agent.
getMBeansToUnregister() - Method in class javax.management.relation.RelationNotification
Returns the list of ObjectNames of MBeans expected to be unregistered due to a relation removal (only for relation removal).
getMajorVersion() - Method in interface javax.servlet.ServletContext
Returns the major version of the Java Servlet API that this servlet container supports.
getMajorVersion() - Method in interface javax.xml.registry.infomodel.Versionable
Gets the major revision number for this version of the Versionable object.
getManagedConnectionFactory() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats
Returns the associated JCAManagedConnectionFactory OBJECT_NAME
getManagedConnectionFactory() - Method in class javax.resource.spi.security.PasswordCredential
Gets the target ManagedConnectionFactory for which the user name and password has been set by the application server.
getMapNames() - Method in interface javax.jms.MapMessage
Returns an Enumeration of all the names in the MapMessage object.
getMatchingHeaderLines(String[]) - Method in class javax.mail.internet.InternetHeaders
Return all matching header lines as an Enumeration of Strings.
getMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeBodyPart
Get matching header lines as an Enumeration of Strings.
getMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeMessage
Get matching header lines as an Enumeration of Strings.
getMatchingHeaderLines(String[]) - Method in interface javax.mail.internet.MimePart
Get matching header lines as an Enumeration of Strings.
getMatchingHeaders(String[]) - Method in interface javax.mail.Part
Return matching headers from this part as an Enumeration of Header objects.
getMatchingHeaders(String[]) - Method in class javax.mail.internet.InternetHeaders
Return all matching Header objects.
getMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeBodyPart
Return matching headers from this Message as an Enumeration of Header objects.
getMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeMessage
Return matching headers from this Message as an Enumeration of Header objects.
getMatchingHeaders(String[]) - Method in class javax.xml.soap.MimeHeaders
Returns all the MimeHeader objects whose name matches a name in the given array of names.
getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.AttachmentPart
Retrieves all MimeHeader objects that match a name in the given array.
getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.SOAPPart
Retrieves all MimeHeader objects that match a name in the given array.
getMaxAge() - Method in class javax.servlet.http.Cookie
Returns the maximum age of the cookie, specified in seconds, By default, -1 indicating the cookie will persist until browser shutdown.
getMaxConnections() - Method in interface javax.resource.spi.ManagedConnectionMetaData
Returns maximum limit on number of active concurrent connections that an EIS instance can support across client processes.
getMaxDegree() - Method in class javax.management.relation.RoleInfo
Returns maximum degree for corresponding role reference.
getMaxInactiveInterval() - Method in interface javax.servlet.http.HttpSession
Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses.
getMaxTime() - Method in interface javax.management.j2ee.statistics.TimeStatistic
The maximum amount of time taken to complete one invocation of this operation since the beginning of this measurement.
getMaxValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns the maximal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
getMaxValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns the maximal value for this parameter, if it has one, or null otherwise.
getMaxValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns the maximal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
getMechType() - Method in interface javax.resource.spi.security.GenericCredential
Deprecated. Returns the mechanism type for the GenericCredential instance.
getMechanismType() - Method in interface javax.xml.rpc.encoding.Deserializer
Gets the type of the XML processing mechanism and representation used by this Deserializer.
getMechanismType() - Method in interface javax.xml.rpc.encoding.Serializer
Gets the type of the XML processing mechanism and representation used by this Serializer.
getMessage() - Method in class javax.ejb.EJBException
Returns the detail message, including the message from the nested exception if there is one.
getMessage() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
Retrieve any additional information about the status of this event.
getMessage(int) - Method in class javax.mail.Folder
Get the Message object corresponding to the given message number.
getMessage() - Method in class javax.mail.MessageContext
Return the Message that contains the content.
getMessage() - Method in class javax.mail.MessagingException
Produce the message, include the message from the nested exception if there is one.
getMessage() - Method in class javax.mail.event.MessageChangedEvent
Return the changed Message.
getMessage() - Method in class javax.mail.event.StoreEvent
Get the message from the Store.
getMessage() - Method in class javax.mail.event.TransportEvent
Get the Message object associated with this Transport Event.
getMessage() - Method in class javax.management.Notification
Get the notification message.
getMessage() - Method in class javax.resource.ResourceException
Returns a detailed message string describing this exception.
getMessage() - Method in class javax.servlet.jsp.tagext.ValidationMessage
Get the localized validation message.
getMessage() - Method in class javax.xml.parsers.FactoryConfigurationError
Return the message (if any) for this error .
getMessage() - Method in class javax.xml.registry.JAXRException
Returns the detail message for this JAXRException object.
getMessage() - Method in interface javax.xml.rpc.handler.soap.SOAPMessageContext
Gets the SOAPMessage from this message context
getMessage() - Method in class javax.xml.soap.SOAPException
Returns the detail message for this SOAPException object.
getMessage() - Method in class javax.xml.transform.TransformerFactoryConfigurationError
Return the message (if any) for this error .
getMessageAndLocation() - Method in class javax.xml.transform.TransformerException
Get the error message with location information appended.
getMessageByUID(long) - Method in interface javax.mail.UIDFolder
Get the Message corresponding to the given UID.
getMessageChangeType() - Method in class javax.mail.event.MessageChangedEvent
Return the type of this event.
getMessageContext() - Method in interface javax.ejb.SessionContext
Obtain a reference to the JAX-RPC MessageContext.
getMessageContext() - Method in interface javax.mail.MessageAware
Return the message context.
getMessageContext() - Method in class javax.mail.internet.MimePartDataSource
Return the MessageContext for the current part.
getMessageContext() - Method in interface javax.xml.rpc.server.ServletEndpointContext
The method getMessageContext returns the MessageContext targeted for this endpoint instance.
getMessageCount() - Method in class javax.mail.Folder
Get total number of messages in this Folder.
getMessageCount() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats
Number of messages sent or received.
getMessageCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Number of messages exchanged.
getMessageCount() - Method in interface javax.management.j2ee.statistics.MessageDrivenBeanStats
Number of messages received.
getMessageID() - Method in class javax.mail.internet.MimeMessage
Returns the value of the "Message-ID" header field.
getMessageListener() - Method in interface javax.jms.MessageConsumer
Gets the message consumer's MessageListener.
getMessageListener() - Method in interface javax.jms.Session
Returns the session's distinguished message listener (optional).
getMessageNumber() - Method in class javax.mail.Message
Get the Message number for this Message.
getMessageSelector() - Method in interface javax.jms.MessageConsumer
Gets this message consumer's message selector expression.
getMessageSelector() - Method in interface javax.jms.QueueBrowser
Gets this queue browser's message selector expression.
getMessageType() - Method in class javax.mail.event.StoreEvent
Return the type of this event.
getMessageWaitTime() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats
Time spent by a message before being delivered.
getMessageWaitTime() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Time spent by a message before being delivered.
getMessages(int, int) - Method in class javax.mail.Folder
Get the Message objects for message numbers ranging from start through end, both start and end inclusive.
getMessages(int[]) - Method in class javax.mail.Folder
Get the Message objects for message numbers specified in the array.
getMessages() - Method in class javax.mail.Folder
Get all Message objects from this Folder.
getMessages() - Method in class javax.mail.event.MessageCountEvent
Return the array of messages added or removed.
getMessagesByUID(long, long) - Method in interface javax.mail.UIDFolder
Get the Messages specified by the given range.
getMessagesByUID(long[]) - Method in interface javax.mail.UIDFolder
Get the Messages specified by the given array of UIDs.
getMetaData() - Method in interface javax.jms.Connection
Gets the metadata for this connection.
getMetaData() - Method in interface javax.resource.cci.Connection
Gets the information on the underlying EIS instance represented through an active connection.
getMetaData() - Method in interface javax.resource.cci.ConnectionFactory
Gets metadata for the Resource Adapter.
getMetaData() - Method in interface javax.resource.spi.ManagedConnection
Gets the metadata information for this connection's underlying EIS resource manager instance.
getMethod() - Method in interface javax.servlet.http.HttpServletRequest
Returns the name of the HTTP method with which this request was made, for example, GET, POST, or PUT.
getMethod() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getMethod() on the wrapped request object.
getMethodReadyCount() - Method in interface javax.management.j2ee.statistics.SessionBeanStats
Number of beans in the method-ready state.
getMiddleName() - Method in interface javax.xml.registry.infomodel.PersonName
Gets the middle name for this Person.
getMimeHeader(String) - Method in class javax.xml.soap.AttachmentPart
Gets all the values of the header identified by the given String.
getMimeHeader(String) - Method in class javax.xml.soap.SOAPPart
Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.
getMimeHeaders() - Method in class javax.xml.soap.SOAPMessage
Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
getMimeType() - Method in class javax.activation.ActivationDataFlavor
Return the MIME type for this DataFlavor.
getMimeType(String) - Method in interface javax.servlet.ServletContext
Returns the MIME type of the specified file, or null if the MIME type is not known.
getMimeType() - Method in interface javax.xml.registry.infomodel.ExtrinsicObject
Gets the mime type associated with this object.
getMinDegree() - Method in class javax.management.relation.RoleInfo
Returns minimum degree for corresponding role reference.
getMinTime() - Method in interface javax.management.j2ee.statistics.TimeStatistic
The minimum amount of time taken to complete one invocation of this operation since the beginning of this measurement.
getMinValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns the minimal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
getMinValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns the minimal value for this parameter, if it has one, or null otherwise.
getMinValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns the minimal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
getMinorVersion() - Method in interface javax.servlet.ServletContext
Returns the minor version of the Servlet API that this servlet container supports.
getMinorVersion() - Method in interface javax.xml.registry.infomodel.Versionable
Gets the minor revision number for this version of the Versionable object.
getMode() - Method in class javax.mail.Folder
Return the open mode of this folder.
getModuleDTDVersion() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
getModuleDTDVersion() - Method in interface javax.enterprise.deploy.model.DeployableObject
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
getModuleExtension() - Method in class javax.enterprise.deploy.shared.ModuleType
Return the file extension string for this enumeration.
getModuleID() - Method in interface javax.enterprise.deploy.spi.TargetModuleID
Retrieve the id assigned to represent the deployed module.
getModuleType(int) - Static method in class javax.enterprise.deploy.shared.ModuleType
Return an object of the specified value.
getModuleUris(ModuleType) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the list of URIs of the designated module type.
getModuleUris() - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the list of URIs for all modules in the application.
getModulus() - Method in class javax.management.monitor.CounterMonitor
Gets the modulus value common to all observed MBeans.
getModulus() - Method in interface javax.management.monitor.CounterMonitorMBean
Gets the modulus value.
getMustUnderstand() - Method in interface javax.xml.soap.SOAPHeaderElement
Returns whether the mustUnderstand attribute for this SOAPHeaderElement object is turned on.
getName() - Method in class javax.activation.DataHandler
Return the name of the data object.
getName() - Method in interface javax.activation.DataSource
Return the name of this object where the name of the object is dependant on the nature of the underlying objects.
getName() - Method in class javax.activation.FileDataSource
Return the name of this object.
getName() - Method in class javax.activation.URLDataSource
Calls the getFile method on the URL used to instantiate the object.
getName() - Method in interface javax.enterprise.deploy.spi.Target
Retrieve the name of the target server.
getName() - Method in class javax.mail.Folder
Returns the name of this Folder.
getName() - Method in class javax.mail.Header
Returns the name of this header.
getName() - Method in class javax.mail.internet.MimePartDataSource
DataSource method to return a name.
getName() - Method in class javax.management.Attribute
Returns a String containing the name of the attribute.
getName() - Method in class javax.management.MBeanFeatureInfo
Returns the name of the feature.
getName() - Method in interface javax.management.j2ee.statistics.Statistic
The name of this Statistic.
getName() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo
Returns the name of the constructor described by this OpenMBeanConstructorInfo instance.
getName() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Returns the name of the operation described by this OpenMBeanOperationInfo instance.
getName() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns the name of the parameter described by this OpenMBeanParameterInfo instance.
getName() - Method in class javax.management.relation.RoleInfo
Returns the name of the role.
getName() - Method in interface javax.resource.spi.security.GenericCredential
Deprecated. Returns the name of the resource principal associated with a GenericCredential instance.
getName() - Method in class javax.servlet.ServletContextAttributeEvent
Return the name of the attribute that changed on the ServletContext.
getName() - Method in class javax.servlet.ServletRequestAttributeEvent
Return the name of the attribute that changed on the ServletRequest.
getName() - Method in class javax.servlet.http.Cookie
Returns the name of the cookie.
getName() - Method in class javax.servlet.http.HttpSessionBindingEvent
Returns the name with which the attribute is bound to or unbound from the session.
getName() - Method in class javax.servlet.jsp.tagext.FunctionInfo
The name of the function.
getName() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
The name of this attribute.
getName() - Method in class javax.servlet.jsp.tagext.TagFileInfo
The unique action name of this tag.
getName() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the user-friendly name of this object.
getName() - Method in interface javax.xml.registry.infomodel.Slot
Gets the name for this Slot.
getName() - Method in class javax.xml.soap.MimeHeader
Returns the name of this MimeHeader object.
getNameFromAttribute() - Method in class javax.servlet.jsp.tagext.TagVariableInfo
The body of the <name-from-attribute> element.
getNameGiven() - Method in class javax.servlet.jsp.tagext.TagVariableInfo
The body of the <name-given> element.
getNamedDispatcher(String) - Method in interface javax.servlet.ServletContext
Returns a RequestDispatcher object that acts as a wrapper for the named servlet.
getNames() - Method in class javax.activation.MimeTypeParameterList
Retrieve an enumeration of all the names in this list.
getNames() - Method in class javax.mail.internet.ParameterList
Return an enumeration of the names of all parameters in this list.
getNamespacePrefixes() - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over the namespace prefix Strings declared by this element.
getNamespaceURI() - Method in class javax.xml.namespace.QName
Get the Namespace URI of this QName.
getNamespaceURI(String) - Method in interface javax.xml.soap.SOAPElement
Returns the URI of the namespace that has the given prefix.
getNbNotifications() - Method in class javax.management.timer.Timer
Gets the number of timer notifications registered into the list of notifications.
getNbNotifications() - Method in interface javax.management.timer.TimerMBean
Gets the number of timer notifications registered into the list of notifications.
getNbOccurences(Integer) - Method in class javax.management.timer.Timer
Gets a copy of the remaining number of occurences associated to a timer notification.
getNbOccurences(Integer) - Method in interface javax.management.timer.TimerMBean
Gets a copy of the remaining number of occurences associated to a timer notification.
getNewFolder() - Method in class javax.mail.event.FolderEvent
If this event indicates that a folder is renamed, (i.e, the event type is RENAMED), then this method returns the Folder object representing the new name.
getNewMessageCount() - Method in class javax.mail.Folder
Get the number of new messages in this Folder.
getNewRoleValue() - Method in class javax.management.relation.RelationNotification
Returns new value of updated role (only for role update).
getNewValue() - Method in class javax.management.AttributeChangeNotification
Gets the new value of the attribute which has changed.
getNewsgroup() - Method in class javax.mail.internet.NewsAddress
Get the newsgroup.
getNextException() - Method in class javax.mail.MessagingException
Get the next exception chained to this one.
getNextTimeout() - Method in interface javax.ejb.Timer
Get the point in time at which the next timer expiration is scheduled to occur.
getNoLocal() - Method in interface javax.jms.TopicSubscriber
Gets the NoLocal attribute for this subscriber.
getNode() - Method in class javax.xml.transform.dom.DOMResult
Get the node that will contain the result DOM tree.
getNode() - Method in class javax.xml.transform.dom.DOMSource
Get the node that represents a Source DOM tree.
getNonMatchingHeaderLines(String[]) - Method in class javax.mail.internet.InternetHeaders
Return all non-matching header lines
getNonMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeBodyPart
Get non-matching header lines as an Enumeration of Strings.
getNonMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeMessage
Get non-matching header lines as an Enumeration of Strings.
getNonMatchingHeaderLines(String[]) - Method in interface javax.mail.internet.MimePart
Get non-matching header lines as an Enumeration of Strings.
getNonMatchingHeaders(String[]) - Method in interface javax.mail.Part
Return non-matching headers from this envelope as an Enumeration of Header objects.
getNonMatchingHeaders(String[]) - Method in class javax.mail.internet.InternetHeaders
Return all non-matching Header objects.
getNonMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeBodyPart
Return non-matching headers from this Message as an Enumeration of Header objects.
getNonMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeMessage
Return non-matching headers from this Message as an Enumeration of Header objects.
getNonMatchingHeaders(String[]) - Method in class javax.xml.soap.MimeHeaders
Returns all of the MimeHeader objects whose name does not match a name in the given array of names.
getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.AttachmentPart
Retrieves all MimeHeader objects whose name does not match a name in the given array.
getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.SOAPPart
Retrieves all MimeHeader objects whose name does not match a name in the given array.
getNonRunningModules(ModuleType, Target[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Retrieve the list of J2EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.
getNotifTypes() - Method in class javax.management.MBeanNotificationInfo
Returns the array of strings (in dot notation) containing the notification types that the MBean may emit.
getNotification(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns a ModelMBeanNotificationInfo requested by name.
getNotification(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
getNotificationID() - Method in class javax.management.timer.TimerNotification
Gets the identifier of this timer notification.
getNotificationIDs(String) - Method in class javax.management.timer.Timer
Gets all the identifiers of timer notifications corresponding to the specified type.
getNotificationIDs(String) - Method in interface javax.management.timer.TimerMBean
Gets all the identifiers of timer notifications corresponding to the specified type.
getNotificationInfo() - Method in class javax.management.MBeanServerDelegate
getNotificationInfo() - Method in interface javax.management.NotificationBroadcaster
Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.
getNotificationInfo() - Method in class javax.management.NotificationBroadcasterSupport
getNotificationInfo() - Method in class javax.management.modelmbean.RequiredModelMBean
Returns the array of Notifications always generated by the RequiredModelMBean.
getNotificationInfo() - Method in class javax.management.monitor.CounterMonitor
Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the counter monitor.
getNotificationInfo() - Method in class javax.management.monitor.GaugeMonitor
Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the gauge monitor.
getNotificationInfo() - Method in class javax.management.monitor.StringMonitor
Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the string monitor.
getNotificationInfo() - Method in class javax.management.relation.RelationService
Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent.
getNotificationMessage(Integer) - Method in class javax.management.timer.Timer
Gets the timer notification detailed message corresponding to the specified identifier.
getNotificationMessage(Integer) - Method in interface javax.management.timer.TimerMBean
Gets the timer notification detailed message corresponding to the specified identifier.
getNotificationType(Integer) - Method in class javax.management.timer.Timer
Gets the timer notification type corresponding to the specified identifier.
getNotificationType(Integer) - Method in interface javax.management.timer.TimerMBean
Gets the timer notification type corresponding to the specified identifier.
getNotificationUserData(Integer) - Method in class javax.management.timer.Timer
Gets the timer notification user data object corresponding to the specified identifier.
getNotificationUserData(Integer) - Method in interface javax.management.timer.TimerMBean
Gets the timer notification user data object corresponding to the specified identifier.
getNotifications() - Method in class javax.management.MBeanInfo
Returns the list of the notifications emitted by the MBean.
getNotifications() - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns the list of the notifications emitted by the MBean.
getNotifications() - Method in interface javax.management.openmbean.OpenMBeanInfo
Returns an array of MBeanNotificationInfo instances describing each notification emitted by the open MBean described by this OpenMBeanInfo instance.
getNotify() - Method in class javax.management.monitor.CounterMonitor
Gets the notification's on/off switch value common to all observed MBeans.
getNotify() - Method in interface javax.management.monitor.CounterMonitorMBean
Gets the notification's on/off switch value.
getNotifyDiffer() - Method in class javax.management.monitor.StringMonitor
Gets the differing notification's on/off switch value common to all observed MBeans.
getNotifyDiffer() - Method in interface javax.management.monitor.StringMonitorMBean
Gets the differing notification's on/off switch value.
getNotifyHigh() - Method in class javax.management.monitor.GaugeMonitor
Gets the high notification's on/off switch value common to all observed MBeans.
getNotifyHigh() - Method in interface javax.management.monitor.GaugeMonitorMBean
Gets the high notification's on/off switch value.
getNotifyLow() - Method in class javax.management.monitor.GaugeMonitor
Gets the low notification's on/off switch value common to all observed MBeans.
getNotifyLow() - Method in interface javax.management.monitor.GaugeMonitorMBean
Gets the low notification's on/off switch value.
getNotifyMatch() - Method in class javax.management.monitor.StringMonitor
Gets the matching notification's on/off switch value common to all observed MBeans.
getNotifyMatch() - Method in interface javax.management.monitor.StringMonitorMBean
Gets the matching notification's on/off switch value.
getNumber() - Method in class javax.mail.search.IntegerComparisonTerm
Return the number to compare with.
getNumber() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
Gets the telephone number suffix, not including the country or area code.
getObject(String) - Method in interface javax.jms.MapMessage
Returns the value of the object with the specified name.
getObject() - Method in interface javax.jms.ObjectMessage
Gets the serializable object containing this message's data.
getObjectInstance(ObjectName) - Method in interface javax.management.MBeanServer
Gets the ObjectInstance for a given MBean registered with the MBean server.
getObjectInstance(ObjectName) - Method in interface javax.management.MBeanServerConnection
Gets the ObjectInstance for a given MBean registered with the MBean server.
getObjectName() - Method in class javax.management.ObjectInstance
Returns the object name part.
getObjectName() - Method in class javax.management.relation.RelationNotification
Returns the ObjectName of the created/removed/updated relation.
getObjectProperty(String) - Method in interface javax.jms.Message
Returns the value of the Java object property with the specified name.
getObjectType() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the object type that best describes the RegistryObject.
getObservedAttribute() - Method in class javax.management.monitor.Monitor
Gets the attribute being observed.
getObservedAttribute() - Method in interface javax.management.monitor.MonitorMBean
Gets the attribute being observed.
getObservedAttribute() - Method in class javax.management.monitor.MonitorNotification
Gets the observed attribute of this monitor notification.
getObservedObject() - Method in class javax.management.monitor.Monitor
Deprecated. As of JMX 1.2, replaced by Monitor.getObservedObjects()
getObservedObject() - Method in interface javax.management.monitor.MonitorMBean
Deprecated. As of JMX 1.2, replaced by MonitorMBean.getObservedObjects()
getObservedObject() - Method in class javax.management.monitor.MonitorNotification
Gets the observed object of this monitor notification.
getObservedObjects() - Method in class javax.management.monitor.Monitor
Returns an array containing the objects being observed.
getObservedObjects() - Method in interface javax.management.monitor.MonitorMBean
Returns an array containing the objects being observed.
getOffset() - Method in class javax.enterprise.deploy.shared.ActionType
Returns the lowest integer value used by this enumeration value's enumeration class.
getOffset() - Method in class javax.enterprise.deploy.shared.CommandType
Returns the lowest integer value used by this enumeration value's enumeration class.
getOffset() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType
Returns the lowest integer value used by this enumeration value's enumeration class.
getOffset() - Method in class javax.enterprise.deploy.shared.ModuleType
Returns the lowest integer value used by this enumeration value's enumeration class.
getOffset() - Method in class javax.enterprise.deploy.shared.StateType
Returns the lowest integer value used by this enumeration value's enumeration class.
getOffset() - Method in class javax.management.monitor.CounterMonitor
Gets the offset value common to all observed MBeans.
getOffset() - Method in interface javax.management.monitor.CounterMonitorMBean
Gets the offset value.
getOldRoleValue() - Method in class javax.management.relation.RelationNotification
Returns old value of updated role (only for role update).
getOldValue() - Method in class javax.management.AttributeChangeNotification
Gets the old value of the attribute which has changed.
getOpenType() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns the open type for the values of the attribute described by this OpenMBeanAttributeInfoSupport instance.
getOpenType() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns the open type of the values of the parameter described by this OpenMBeanParameterInfo instance.
getOpenType() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns the open type for the values of the parameter described by this OpenMBeanParameterInfoSupport instance.
getOperation(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns a ModelMBeanOperationInfo requested by name.
getOperation(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
getOperationName() - Method in interface javax.xml.rpc.Call
Gets the name of the operation to be invoked using this Call instance.
getOperations() - Method in class javax.management.MBeanInfo
Returns the list of operations of the MBean.
getOperations() - Method in interface javax.management.modelmbean.ModelMBeanInfo
Returns the list of operations of the MBean.
getOperations() - Method in interface javax.management.openmbean.OpenMBeanInfo
Returns an array of OpenMBeanOperationInfo instances describing each operation in the open MBean described by this OpenMBeanInfo instance.
getOrganization() - Method in interface javax.xml.registry.infomodel.User
Gets the Organization that this User is affiliated with.
getOrigin() - Method in interface javax.management.j2ee.statistics.JMSConsumerStats
Returns a string that encapsulates the identity of a message origin
getOriginatingNode() - Method in interface javax.xml.transform.dom.DOMLocator
Return the node where the event occurred.
getOut() - Method in class javax.servlet.jsp.JspContext
The current value of the out object (a JspWriter).
getOutputParams() - Method in interface javax.xml.rpc.Call
Returns a Map of {name, value} for the output parameters of the last invoked operation.
getOutputProperties() - Method in interface javax.xml.transform.Templates
Get the static properties for xsl:output.
getOutputProperties() - Method in class javax.xml.transform.Transformer
Get a copy of the output properties for the transformation.
getOutputProperty(String) - Method in class javax.xml.transform.Transformer
Get an output property that is in effect for the transformation.
getOutputStream() - Method in class javax.activation.DataHandler
Get an OutputStream for this DataHandler to allow overwriting the underlying data.
getOutputStream() - Method in interface javax.activation.DataSource
This method returns an OutputStream where the data can be written and throws the appropriate exception if it can not do so.
getOutputStream() - Method in class javax.activation.FileDataSource
This method will return an OutputStream representing the the data and will throw an IOException if it can not do so.
getOutputStream() - Method in class javax.activation.URLDataSource
The getOutputStream method from the URL.
getOutputStream() - Method in class javax.mail.internet.MimePartDataSource
DataSource method to return an output stream.
getOutputStream() - Method in interface javax.servlet.ServletResponse
Returns a ServletOutputStream suitable for writing binary data in the response.
getOutputStream() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getOutputStream() on the wrapped response object.
getOutputStream() - Method in class javax.xml.transform.stream.StreamResult
Get the byte stream that was set with setOutputStream.
getOutputValues() - Method in interface javax.xml.rpc.Call
Returns a List values for the output parameters of the last invoked operation.
getPage() - Method in class javax.servlet.jsp.PageContext
The current value of the page object (In a Servlet environment, this is an instance of javax.servlet.Servlet).
getPageContext(Servlet, ServletRequest, ServletResponse, String, boolean, int, boolean) - Method in class javax.servlet.jsp.JspFactory
obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.
getParameter(String) - Method in class javax.activation.MimeType
Retrieve the value associated with the given name, or null if there is no current association.
getParameter(String) - Method in class javax.mail.internet.ContentDisposition
Return the specified parameter value.
getParameter(String) - Method in class javax.mail.internet.ContentType
Return the specified parameter value.
getParameter(String) - Method in interface javax.servlet.ServletRequest
Returns the value of a request parameter as a String, or null if the parameter does not exist.
getParameter(String) - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getParameter(String name) on the wrapped request object.
getParameter(String) - Method in class javax.xml.transform.Transformer
Get a parameter that was explicitly set with setParameter or setParameters.
getParameterList() - Method in class javax.mail.internet.ContentDisposition
Return a ParameterList object that holds all the available parameters.
getParameterList() - Method in class javax.mail.internet.ContentType
Return a ParameterList object that holds all the available parameters.
getParameterMap() - Method in interface javax.servlet.ServletRequest
Returns a java.util.Map of the parameters of this request.
getParameterMap() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getParameterMap() on the wrapped request object.
getParameterName(MBeanConstructorInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean
Customization hook: Get the name that will be used for the sequence MBeanParameterInfo of the MBeanConstructorInfo returned by this MBean.
getParameterName(MBeanOperationInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean
Customization hook: Get the name that will be used for the sequence MBeanParameterInfo of the MBeanOperationInfo returned by this MBean.
getParameterNames() - Method in interface javax.servlet.ServletRequest
Returns an Enumeration of String objects containing the names of the parameters contained in this request.
getParameterNames() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getParameterNames() on the wrapped request object.
getParameterTypeByName(String) - Method in interface javax.xml.rpc.Call
Gets the XML type of a parameter by name
getParameterValues(String) - Method in interface javax.servlet.ServletRequest
Returns an array of String objects containing all of the values the given request parameter has, or null if the parameter does not exist.
getParameterValues(String) - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getParameterValues(String name) on the wrapped request object.
getParameters() - Method in class javax.activation.MimeType
Retrieve this object's parameter list.
getParent() - Method in class javax.mail.BodyPart
Return the containing Multipart object, or null if not known.
getParent() - Method in class javax.mail.Folder
Returns the parent folder of this folder.
getParent() - Method in class javax.mail.Multipart
Return the Part that contains this Multipart object, or null if not known.
getParent() - Method in interface javax.servlet.jsp.tagext.SimpleTag
Returns the parent of this tag, for collaboration purposes.
getParent() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport
Returns the parent of this tag, for collaboration purposes.
getParent() - Method in interface javax.servlet.jsp.tagext.Tag
Get the parent (closest enclosing tag handler) for this tag handler.
getParent() - Method in class javax.servlet.jsp.tagext.TagAdapter
Returns the parent of this tag, which is always getAdaptee().getParent().
getParent() - Method in class javax.servlet.jsp.tagext.TagSupport
The Tag instance most closely enclosing this tag instance.
getParent() - Method in interface javax.xml.registry.infomodel.Concept
Gets the parent Concept or ClassificationScheme for this object.
getParentConcept() - Method in interface javax.xml.registry.infomodel.Concept
Gets the parent Concept or null if parent is a ClassificationScheme.
getParentElement() - Method in interface javax.xml.soap.Node
Returns the parent element of this Node object.
getParentOrganization() - Method in interface javax.xml.registry.infomodel.Organization
Gets the parent (container) organization.
getParentTargetModuleID() - Method in interface javax.enterprise.deploy.spi.TargetModuleID
Retrieve the identifier of the parent object of this deployed module.
getParser() - Method in class javax.xml.parsers.SAXParser
Returns the SAX parser that is encapsultated by the implementation of this class.
getPart() - Method in class javax.mail.MessageContext
Return the Part that contains the content.
getPassiveCount() - Method in interface javax.management.j2ee.statistics.StatefulSessionBeanStats
Number of beans that are in the passive state.
getPassword() - Method in class javax.mail.PasswordAuthentication
getPassword() - Method in class javax.mail.URLName
Returns the password of this URLName.
getPassword() - Method in class javax.resource.spi.security.PasswordCredential
Returns the user password.
getPasswordAuthentication() - Method in class javax.mail.Authenticator
Called when password authentication is needed.
getPasswordAuthentication(URLName) - Method in class javax.mail.Session
Return any saved PasswordAuthentication for this (store or transport) URLName.
getPath() - Method in class javax.servlet.http.Cookie
Returns the path on the server to which the browser returns this cookie.
getPath() - Method in class javax.servlet.jsp.tagext.TagFileInfo
Where to find the .tag file implementing this action.
getPath() - Method in interface javax.xml.registry.infomodel.Concept
Gets the canonical path representation for this Concept.
getPathInfo() - Method in interface javax.servlet.http.HttpServletRequest
Returns any extra path information associated with the URL the client sent when it made this request.
getPathInfo() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getPathInfo() on the wrapped request object.
getPathTranslated() - Method in interface javax.servlet.http.HttpServletRequest
Returns any extra path information after the servlet name but before the query string, and translates it to a real path.
getPathTranslated() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getPathTranslated() on the wrapped request object.
getPattern() - Method in class javax.mail.search.StringTerm
Return the string to match with.
getPendingMessageCount() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats
Number of pending messages.
getPendingMessageCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Number of pending messages.
getPeriod(Integer) - Method in class javax.management.timer.Timer
Gets a copy of the period (in milliseconds) associated to a timer notification.
getPeriod(Integer) - Method in interface javax.management.timer.TimerMBean
Gets a copy of the period (in milliseconds) associated to a timer notification.
getPermanentFlags() - Method in class javax.mail.Folder
Get the permanent flags supported by this Folder.
getPersonName() - Method in interface javax.xml.registry.infomodel.User
Returns the name of this User.
getPersonal() - Method in class javax.mail.internet.InternetAddress
Get the personal name.
getPersonalNamespaces() - Method in class javax.mail.Store
Return a set of folders representing the personal namespaces for the current user.
getPolicyConfiguration(String, boolean) - Method in class javax.security.jacc.PolicyConfigurationFactory
This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider.
getPolicyConfigurationFactory() - Static method in class javax.security.jacc.PolicyConfigurationFactory
This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class.
getPoolSize() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats
The size of the connection pool
getPoolSize() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
Size of the connection pool.
getPooledCount() - Method in interface javax.management.j2ee.statistics.EntityBeanStats
Number of beans in the pooled state.
getPort() - Method in class javax.mail.URLName
Returns the port number of this URLName.
getPort(QName, Class) - Method in interface javax.xml.rpc.Service
The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
getPort(Class) - Method in interface javax.xml.rpc.Service
The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
getPortTypeName() - Method in interface javax.xml.rpc.Call
Gets the qualified name of the port type.
getPorts() - Method in interface javax.xml.rpc.Service
Returns an Iterator for the list of QNames of service endpoints grouped by this service
getPos() - Method in class javax.mail.internet.AddressException
Get the position with the reference string where the error was detected (-1 if not relevant).
getPosition() - Method in interface javax.mail.internet.SharedInputStream
Return the current position in the InputStream, as an offset from the beginning of the InputStream.
getPostalAddress() - Method in interface javax.xml.registry.infomodel.Organization
Gets the Address for this Organization.
getPostalAddresses() - Method in interface javax.xml.registry.infomodel.User
Gets the postal address for this User.
getPostalCode() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the postal or zip code.
getPostalScheme() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns a user-defined postal scheme for codifying the attributes of PostalAddress.
getPreferredCommands(String) - Method in class javax.activation.CommandMap
Get the preferred command list from a MIME Type.
getPreferredCommands() - Method in class javax.activation.DataHandler
Return the preferred commands for this type of data.
getPreferredCommands(String) - Method in class javax.activation.MailcapCommandMap
Get the preferred command list for a MIME Type.
getPrefix() - Method in class javax.xml.namespace.QName
Get the prefix of this QName.
getPrefix() - Method in interface javax.xml.soap.Name
Returns the prefix that was specified when this Name object was initialized.
getPrefixString() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
The prefix assigned to this taglib from the taglib directive
getPreviousOut() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
Get surrounding out JspWriter.
getPrimaryContact() - Method in interface javax.xml.registry.infomodel.Organization
Gets the primary Contact for this Organization.
getPrimaryKey() - Method in interface javax.ejb.EJBLocalObject
Obtain the primary key of the EJB local object.
getPrimaryKey() - Method in interface javax.ejb.EJBObject
Obtain the primary key of the EJB object.
getPrimaryKey() - Method in interface javax.ejb.EntityContext
Obtain the primary key of the EJB object that is currently associated with this instance.
getPrimaryKeyClass() - Method in interface javax.ejb.EJBMetaData
Obtain the Class object for the enterprise Bean's primary key class.
getPrimaryType() - Method in class javax.activation.MimeType
Retrieve the primary type of this object.
getPrimaryType() - Method in class javax.mail.internet.ContentType
Return the primary type.
getPriority() - Method in interface javax.jms.MessageProducer
Gets the producer's default priority.
getProblemType() - Method in class javax.management.relation.RoleUnresolved
Retrieves problem type.
getProducers() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Returns an array of JMSProducerStats that provide statistics about the message producers associated with the referencing JMS session statistics.
getProductVersion() - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Provide a string identifying version of this vendor's DeploymentManager.
getProperties() - Method in class javax.mail.Session
Returns the Properties object associated with this Session
getProperties() - Method in class javax.xml.registry.ConnectionFactory
Gets the Properties used during createConnection and createFederatedConnection calls.
getProperty(String) - Method in class javax.mail.Session
Returns the value of the specified property.
getProperty(String) - Method in class javax.xml.parsers.SAXParser
Returns the particular property requested for in the underlying implementation of XMLReader.
getProperty(String) - Method in interface javax.xml.rpc.Call
Gets the value of a named property.
getProperty(String) - Method in interface javax.xml.rpc.handler.MessageContext
Gets the value of a specific property from the MessageContext
getProperty(String) - Method in class javax.xml.soap.SOAPMessage
Retrieves value of the specified property.
getPropertyNames() - Method in interface javax.jms.Message
Returns an Enumeration of all the property names.
getPropertyNames() - Method in interface javax.xml.rpc.Call
Gets the names of configurable properties supported by this Call object.
getPropertyNames() - Method in interface javax.xml.rpc.handler.MessageContext
Returns an Iterator view of the names of the properties in this MessageContext
getProtocol() - Method in class javax.mail.Provider
Returns the protocol supported by this Provider
getProtocol() - Method in class javax.mail.URLName
Returns the protocol of this URLName.
getProtocol() - Method in interface javax.servlet.ServletRequest
Returns the name and version of the protocol the request uses in the form protocol/majorVersion.minorVersion, for example, HTTP/1.1.
getProtocol() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getProtocol() on the wrapped request object.
getProvider(String) - Method in class javax.mail.Session
Returns the default Provider for the protocol specified.
getProviderMajorVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS provider major version number.
getProviderMinorVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS provider minor version number.
getProviderVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS provider version.
getProviders() - Method in class javax.mail.Session
This method returns an array of all the implementations installed via the javamail.
getProvidingOrganization() - Method in interface javax.xml.registry.infomodel.Service
Gets the Organization that provides this service.
getPublicId() - Method in interface javax.xml.transform.SourceLocator
Return the public identifier for the current document event.
getPublicId() - Method in class javax.xml.transform.stream.StreamSource
Get the public identifier that was set with setPublicId.
getPurgeFlag() - Method in class javax.management.relation.RelationService
Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.
getPurgeFlag() - Method in interface javax.management.relation.RelationServiceMBean
Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.
getQualifiedName() - Method in interface javax.xml.soap.Name
Gets the namespace-qualified name of the XML name that this Name object represents.
getQueryString() - Method in interface javax.servlet.http.HttpServletRequest
Returns the query string that is contained in the request URL after the path.
getQueryString() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getQueryString() on the wrapped request object.
getQueue() - Method in interface javax.jms.QueueBrowser
Gets the queue associated with this queue browser.
getQueue() - Method in interface javax.jms.QueueReceiver
Gets the Queue associated with this queue receiver.
getQueue() - Method in interface javax.jms.QueueSender
Gets the queue associated with this QueueSender.
getQueueName() - Method in interface javax.jms.Queue
Gets the name of this queue.
getQueueSession() - Method in interface javax.jms.XAQueueSession
Gets the queue session associated with this XAQueueSession.
getRawInputStream() - Method in class javax.mail.internet.MimeBodyPart
Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
getRawInputStream() - Method in class javax.mail.internet.MimeMessage
Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
getReader() - Method in interface javax.servlet.ServletRequest
Retrieves the body of the request as character data using a BufferedReader.
getReader() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getReader() on the wrapped request object.
getReader() - Method in class javax.servlet.jsp.tagext.BodyContent
Return the value of this BodyContent as a Reader.
getReader() - Method in class javax.xml.transform.stream.StreamSource
Get the character stream that was set with setReader.
getReadyCount() - Method in interface javax.management.j2ee.statistics.EntityBeanStats
Number of beans in the ready state.
getRealPath(String) - Method in interface javax.servlet.ServletContext
Returns a String containing the real path for a given virtual path.
getRealPath(String) - Method in interface javax.servlet.ServletRequest
Deprecated. As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.
getRealPath(String) - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getRealPath(String path) on the wrapped request object.
getReceivedDate() - Method in class javax.mail.Message
Get the date this message was received.
getReceivedDate() - Method in class javax.mail.internet.MimeMessage
Returns the Date on this message was received.
getRecipientType() - Method in class javax.mail.search.RecipientStringTerm
Return the type of recipient to match with.
getRecipientType() - Method in class javax.mail.search.RecipientTerm
Return the type of recipient to match with.
getRecipients(Message.RecipientType) - Method in class javax.mail.Message
Get all the recipient addresses of the given type.
getRecipients(Message.RecipientType) - Method in class javax.mail.internet.MimeMessage
Returns the recepients specified by the type.
getRecordFactory() - Method in interface javax.resource.cci.ConnectionFactory
Gets a RecordFactory instance.
getRecordName() - Method in interface javax.resource.cci.Record
Gets the name of the Record.
getRecordShortDescription() - Method in interface javax.resource.cci.Record
Gets a short description string for the Record.
getRef() - Method in class javax.mail.URLName
Returns the reference of this URLName.
getRef() - Method in class javax.mail.internet.AddressException
Get the string that was being parsed when the error was detected (null if not relevant).
getRefMBeanClassName() - Method in class javax.management.relation.RoleInfo
Returns name of type of MBean expected to be referenced in corresponding role.
getReferencedMBeans() - Method in interface javax.management.relation.Relation
Retrieves MBeans referenced in the various roles of the relation.
getReferencedMBeans(String) - Method in class javax.management.relation.RelationService
Retrieves MBeans referenced in the various roles of the relation.
getReferencedMBeans(String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves MBeans referenced in the various roles of the relation.
getReferencedMBeans() - Method in class javax.management.relation.RelationSupport
Retrieves MBeans referenced in the various roles of the relation.
getRegisteredEncodingStyleURIs() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry
Returns a list of registered encodingStyle URIs in this TypeMappingRegistry instance.
getRegistryObject(String, String) - Method in interface javax.xml.registry.QueryManager
Gets the RegistryObject specified by the Id and type of object.
getRegistryObject(String) - Method in interface javax.xml.registry.QueryManager
Gets the RegistryObject specified by the Id.
getRegistryObject() - Method in interface javax.xml.registry.infomodel.AuditableEvent
Gets the RegistryObject associated with this AuditableEvent.
getRegistryObject() - Method in interface javax.xml.registry.infomodel.ExternalIdentifier
Gets the parent RegistryObject for this ExternalIdentifier.
getRegistryObjects(Collection) - Method in interface javax.xml.registry.QueryManager
Gets the specified RegistryObjects.
getRegistryObjects(Collection, String) - Method in interface javax.xml.registry.QueryManager
Gets the specified RegistryObjects.
getRegistryObjects() - Method in interface javax.xml.registry.QueryManager
Gets the RegistryObjects owned by the caller.
getRegistryObjects(String) - Method in interface javax.xml.registry.QueryManager
Gets the RegistryObjects owned by the caller, that are of the specified type.
getRegistryObjects() - Method in interface javax.xml.registry.infomodel.RegistryPackage
Gets the collection of member RegistryObjects of this RegistryPackage.
getRegistryPackages() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the Package associated with this object.
getRegistryService() - Method in interface javax.xml.registry.Connection
Gets the RegistryService interface associated with the Connection.
getRegistryService() - Method in interface javax.xml.registry.LifeCycleManager
Returns the parent RegistryService that created this object.
getRegistryService() - Method in interface javax.xml.registry.QueryManager
Returns the parent RegistryService that created this object.
getRelationId() - Method in interface javax.management.relation.Relation
Returns relation identifier (used to uniquely identify the relation inside the Relation Service).
getRelationId() - Method in class javax.management.relation.RelationNotification
Returns the relation identifier of created/removed/updated relation.
getRelationId() - Method in class javax.management.relation.RelationSupport
Returns relation identifier (used to uniquely identify the relation inside the Relation Service).
getRelationServiceName() - Method in interface javax.management.relation.Relation
Returns ObjectName of the Relation Service handling the relation.
getRelationServiceName() - Method in class javax.management.relation.RelationSupport
Returns ObjectName of the Relation Service handling the relation.
getRelationTypeName() - Method in interface javax.management.relation.Relation
Returns name of associated relation type.
getRelationTypeName() - Method in class javax.management.relation.RelationNotification
Returns the relation type name of created/removed/updated relation.
getRelationTypeName(String) - Method in class javax.management.relation.RelationService
Returns name of associated relation type for given relation.
getRelationTypeName(String) - Method in interface javax.management.relation.RelationServiceMBean
Returns name of associated relation type for given relation.
getRelationTypeName() - Method in class javax.management.relation.RelationSupport
Returns name of associated relation type.
getRelationTypeName() - Method in interface javax.management.relation.RelationType
Returns the relation type name.
getRelationTypeName() - Method in class javax.management.relation.RelationTypeSupport
Returns the relation type name.
getReliableURN() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
The "reliable" URN indicated in the TLD (the uri element).
getRemainder() - Method in class javax.mail.internet.HeaderTokenizer
Return the rest of the Header.
getRemaining() - Method in class javax.servlet.jsp.JspWriter
This method returns the number of unused bytes in the buffer.
getRemoteAddr() - Method in interface javax.servlet.ServletRequest
Returns the Internet Protocol (IP) address of the client or last proxy that sent the request.
getRemoteAddr() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getRemoteAddr() on the wrapped request object.
getRemoteHost() - Method in interface javax.servlet.ServletRequest
Returns the fully qualified name of the client or the last proxy that sent the request.
getRemoteHost() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getRemoteHost() on the wrapped request object.
getRemoteInterfaceClass() - Method in interface javax.ejb.EJBMetaData
Obtain the Class object for the enterprise Bean's remote interface.
getRemotePort() - Method in interface javax.servlet.ServletRequest
Returns the Internet Protocol (IP) source port of the client or last proxy that sent the request.
getRemotePort() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getRemotePort() on the wrapped request object.
getRemoteUser() - Method in interface javax.servlet.http.HttpServletRequest
Returns the login of the user making this request, if the user has been authenticated, or null if the user has not been authenticated.
getRemoteUser() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getRemoteUser() on the wrapped request object.
getRemoveCount() - Method in interface javax.management.j2ee.statistics.EJBStats
Number of times remove was called.
getReplyTo() - Method in class javax.mail.Message
Get the addresses to which replies should be directed.
getReplyTo() - Method in class javax.mail.internet.MimeMessage
Return the value of the RFC 822 "Reply-To" header field.
getRepositoryItem() - Method in interface javax.xml.registry.infomodel.ExtrinsicObject
Gets the repository item for this object.
getRepresentationClass() - Method in class javax.activation.ActivationDataFlavor
Return the representation class.
getRequest() - Method in class javax.servlet.ServletRequestWrapper
Return the wrapped request object.
getRequest() - Method in class javax.servlet.jsp.PageContext
The current value of the request object (a ServletRequest).
getRequestDispatcher(String) - Method in interface javax.servlet.ServletContext
Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
getRequestDispatcher(String) - Method in interface javax.servlet.ServletRequest
Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
getRequestDispatcher(String) - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getRequestDispatcher(String path) on the wrapped request object.
getRequestId() - Method in class javax.xml.registry.JAXRException
getRequestId() - Method in interface javax.xml.registry.JAXRResponse
Returns the unique id for the request that generated this response.
getRequestURI() - Method in interface javax.servlet.http.HttpServletRequest
Returns the part of this request's URL from the protocol name up to the query string in the first line of the HTTP request.
getRequestURI() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getRequestURI() on the wrapped request object.
getRequestURI() - Method in class javax.servlet.jsp.ErrorData
Returns the request URI.
getRequestURL() - Method in interface javax.servlet.http.HttpServletRequest
Reconstructs the URL the client used to make the request.
getRequestURL() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getRequestURL() on the wrapped request object.
getRequestURL(HttpServletRequest) - Static method in class javax.servlet.http.HttpUtils
Deprecated. Reconstructs the URL the client used to make the request, using information in the HttpServletRequest object.
getRequestedSessionId() - Method in interface javax.servlet.http.HttpServletRequest
Returns the session ID specified by the client.
getRequestedSessionId() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getRequestedSessionId() on the wrapped request object.
getRequestingPort() - Method in class javax.mail.Authenticator
getRequestingPrompt() - Method in class javax.mail.Authenticator
getRequestingProtocol() - Method in class javax.mail.Authenticator
Give the protocol that's requesting the connection.
getRequestingSite() - Method in class javax.mail.Authenticator
getRequiredVersion() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
A string describing the required version of the JSP container.
getResource(String) - Method in interface javax.management.loading.MLetMBean
Finds the resource with the given name.
getResource(String) - Method in interface javax.servlet.ServletContext
Returns a URL to the resource that is mapped to a specified path.
getResourceAdapter() - Method in interface javax.resource.spi.ResourceAdapterAssociation
Get the associated ResourceAdapter object.
getResourceAsStream(String) - Method in interface javax.management.loading.MLetMBean
Returns an input stream for reading the specified resource.
getResourceAsStream(String) - Method in interface javax.servlet.ServletContext
Returns the resource located at the named path as an InputStream object.
getResourcePaths(String) - Method in interface javax.servlet.ServletContext
Returns a directory-like listing of all the paths to resources within the web application whose longest sub-path matches the supplied path argument.
getResources(String) - Method in interface javax.management.loading.MLetMBean
Finds all the resources with the given name.
getResponse() - Method in class javax.servlet.ServletResponseWrapper
Return the wrapped ServletResponse object.
getResponse() - Method in class javax.servlet.jsp.PageContext
The current value of the response object (a ServletResponse).
getResultSetInfo() - Method in interface javax.resource.cci.Connection
Gets the information on the ResultSet functionality supported by a connected EIS instance.
getResultTargetModuleIDs() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Retrieve the list of TargetModuleIDs successfully processed or created by the associated DeploymentManager operation.
getReturnOpenType() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.
getReturnOpenType() - Method in class javax.management.openmbean.OpenMBeanOperationInfoSupport
Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.
getReturnType() - Method in class javax.management.MBeanOperationInfo
Returns the type of the method's return value.
getReturnType() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Returns the fully qualified Java class name of the values returned by the operation described by this OpenMBeanOperationInfo instance.
getReturnType() - Method in interface javax.xml.rpc.Call
Gets the return type for a specific operation
getRole(String) - Method in interface javax.management.relation.Relation
Retrieves role value for given role name.
getRole(String, String) - Method in class javax.management.relation.RelationService
Retrieves role value for given role name in given relation.
getRole(String, String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves role value for given role name in given relation.
getRole(String) - Method in class javax.management.relation.RelationSupport
Retrieves role value for given role name.
getRoleCardinality(String) - Method in interface javax.management.relation.Relation
Returns the number of MBeans currently referenced in the given role.
getRoleCardinality(String, String) - Method in class javax.management.relation.RelationService
Retrieves the number of MBeans currently referenced in the given role.
getRoleCardinality(String, String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves the number of MBeans currently referenced in the given role.
getRoleCardinality(String) - Method in class javax.management.relation.RelationSupport
Returns the number of MBeans currently referenced in the given role.
getRoleInfo(String, String) - Method in class javax.management.relation.RelationService
Retrieves role info for given role name of a given relation type.
getRoleInfo(String, String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves role info for given role of a given relation type.
getRoleInfo(String) - Method in interface javax.management.relation.RelationType
Returns the role info (RoleInfo object) for the given role info name (null if not found).
getRoleInfo(String) - Method in class javax.management.relation.RelationTypeSupport
Returns the role info (RoleInfo object) for the given role info name (null if not found).
getRoleInfos(String) - Method in class javax.management.relation.RelationService
Retrieves list of role infos (RoleInfo objects) of a given relation type.
getRoleInfos(String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves list of role infos (RoleInfo objects) of a given relation type.
getRoleInfos() - Method in interface javax.management.relation.RelationType
Returns the list of role definitions (ArrayList of RoleInfo objects).
getRoleInfos() - Method in class javax.management.relation.RelationTypeSupport
Returns the list of role definitions (ArrayList of RoleInfo objects).
getRoleName() - Method in class javax.management.relation.RelationNotification
Returns name of updated role of updated relation (only for role update).
getRoleName() - Method in class javax.management.relation.Role
Retrieves role name.
getRoleName() - Method in class javax.management.relation.RoleUnresolved
Retrieves role name.
getRoleValue() - Method in class javax.management.relation.Role
Retrieves role value.
getRoleValue() - Method in class javax.management.relation.RoleUnresolved
Retrieves role value.
getRoles(String[]) - Method in interface javax.management.relation.Relation
Retrieves values of roles with given names.
getRoles(String, String[]) - Method in class javax.management.relation.RelationService
Retrieves values of roles with given names in given relation.
getRoles(String, String[]) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves values of roles with given names in given relation.
getRoles(String[]) - Method in class javax.management.relation.RelationSupport
Retrieves values of roles with given names.
getRoles() - Method in class javax.management.relation.RoleResult
Retrieves list of roles successfully accessed.
getRoles() - Method in interface javax.xml.rpc.handler.HandlerChain
Gets SOAP actor roles registered for this HandlerChain at this SOAP node.
getRoles() - Method in interface javax.xml.rpc.handler.soap.SOAPMessageContext
Gets the SOAP actor roles associated with an execution of the HandlerChain and its contained Handler instances.
getRolesUnresolved() - Method in class javax.management.relation.RoleResult
Retrieves list of roles unsuccessfully accessed.
getRollbackOnly() - Method in interface javax.ejb.EJBContext
Test if the transaction has been marked for rollback only.
getRolledbackCount() - Method in interface javax.management.j2ee.statistics.JTAStats
Number of rolled-back transactions.
getRoot() - Method in interface javax.enterprise.deploy.model.DDBean
Return the root element for this DDBean.
getRootCause() - Method in class javax.servlet.ServletException
Returns the exception that caused this servlet exception.
getRootCause() - Method in class javax.servlet.jsp.JspException
Returns the exception that caused this JSP exception.
getRootCause() - Method in class javax.servlet.jsp.el.ELException
Returns the root cause.
getRootOrganization() - Method in interface javax.xml.registry.infomodel.Organization
Gets the root organization.
getRowType() - Method in class javax.management.openmbean.TabularType
Returns the type of the row elements of tabular data values described by this TabularType instance.
getRunningModules(ModuleType, Target[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Retrieve the list of J2EE application modules distributed to the identified targets and that are currently running on the associated server or servers.
getSOAPBody() - Method in class javax.xml.soap.SOAPMessage
Gets the SOAP Body contained in this SOAPMessage object.
getSOAPHeader() - Method in class javax.xml.soap.SOAPMessage
Gets the SOAP Header contained in this SOAPMessage object.
getSOAPPart() - Method in class javax.xml.soap.SOAPMessage
Gets the SOAP part of this SOAPMessage object.
getScheme() - Method in interface javax.servlet.ServletRequest
Returns the name of the scheme used to make this request, for example, http, https, or ftp.
getScheme() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getScheme() on the wrapped request object.
getScope() - Method in class javax.servlet.jsp.tagext.TagVariableInfo
The body of the <scope> element.
getScope() - Method in class javax.servlet.jsp.tagext.VariableInfo
Returns the lexical scope of the variable.
getSecure() - Method in class javax.servlet.http.Cookie
Returns true if the browser is sending cookies only over a secure protocol, or false if the browser can send cookies using any protocol.
getSendPastNotifications() - Method in class javax.management.timer.Timer
Gets the flag indicating whether or not the timer sends past notifications.
getSendPastNotifications() - Method in interface javax.management.timer.TimerMBean
Gets the flag indicating whether or not the timer sends past notifications.
getSender() - Method in class javax.mail.internet.MimeMessage
Returns the value of the RFC 822 "Sender" header field.
getSentDate() - Method in class javax.mail.Message
Get the date this message was sent.
getSentDate() - Method in class javax.mail.internet.MimeMessage
Returns the value of the RFC 822 "Date" field.
getSentMailCount() - Method in interface javax.management.j2ee.statistics.JavaMailStats
The number of mail messages sent.
getSeparator() - Method in class javax.mail.Folder
Return the delimiter character that separates this Folder's pathname from the names of immediate subfolders.
getSequenceNumber() - Method in class javax.management.Notification
Get the notification sequence number.
getSerializer(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping
Gets the SerializerFactory registered for the specified pair of Java type and XML data type.
getSerializerAs(String) - Method in interface javax.xml.rpc.encoding.SerializerFactory
Returns a Serializer for the specified XML processing mechanism type.
getServerInfo() - Method in interface javax.servlet.ServletContext
Returns the name and version of the servlet container on which the servlet is running.
getServerName() - Method in interface javax.servlet.ServletRequest
Returns the host name of the server to which the request was sent.
getServerName() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getServerName() on the wrapped request object.
getServerPort() - Method in interface javax.servlet.ServletRequest
Returns the port number to which the request was sent.
getServerPort() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getServerPort() on the wrapped request object.
getServerSession() - Method in interface javax.jms.ServerSessionPool
Return a server session from the pool.
getServerSessionPool() - Method in interface javax.jms.ConnectionConsumer
Gets the server session pool associated with this connection consumer.
getService() - Method in interface javax.xml.registry.infomodel.ServiceBinding
Gets the parent service for which this is a binding.
getServiceBinding() - Method in interface javax.xml.registry.infomodel.SpecificationLink
Gets the parent ServiceBinding for this SpecificationLink.
getServiceBindings() - Method in interface javax.xml.registry.infomodel.Service
Gets all children ServiceBindings.
getServiceName() - Method in interface javax.xml.rpc.Service
Gets the name of this service.
getServiceTime() - Method in interface javax.management.j2ee.statistics.ServletStats
Execution times for the methods.
getServices() - Method in interface javax.xml.registry.infomodel.Organization
Gets all children Services.
getServlet(String) - Method in interface javax.servlet.ServletContext
Deprecated. As of Java Servlet API 2.1, with no direct replacement.

This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.

getServlet() - Method in class javax.servlet.UnavailableException
Deprecated. As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.
getServletConfig() - Method in class javax.servlet.GenericServlet
Returns this servlet's ServletConfig object.
getServletConfig() - Method in interface javax.servlet.Servlet
Returns a ServletConfig object, which contains initialization and startup parameters for this servlet.
getServletConfig() - Method in class javax.servlet.jsp.PageContext
The ServletConfig instance.
getServletContext() - Method in interface javax.servlet.FilterConfig
Returns a reference to the ServletContext in which the caller is executing.
getServletContext() - Method in class javax.servlet.GenericServlet
Returns a reference to the ServletContext in which this servlet is running.
getServletContext() - Method in interface javax.servlet.ServletConfig
Returns a reference to the ServletContext in which the caller is executing.
getServletContext() - Method in class javax.servlet.ServletContextEvent
Return the ServletContext that changed.
getServletContext() - Method in class javax.servlet.ServletRequestEvent
Return the ServletContext that changed.
getServletContext() - Method in interface javax.servlet.http.HttpSession
Returns the ServletContext to which this session belongs.
getServletContext() - Method in class javax.servlet.jsp.PageContext
The ServletContext instance.
getServletContext() - Method in interface javax.xml.rpc.server.ServletEndpointContext
The method getServletContext returns the ServletContext associated with the web application that contain this endpoint.
getServletContextName() - Method in interface javax.servlet.ServletContext
Returns the name of this web application correponding to this ServletContext as specified in the deployment descriptor for this web application by the display-name element.
getServletInfo() - Method in class javax.servlet.GenericServlet
Returns information about the servlet, such as author, version, and copyright.
getServletInfo() - Method in interface javax.servlet.Servlet
Returns information about the servlet, such as author, version, and copyright.
getServletName() - Method in class javax.servlet.GenericServlet
Returns the name of this servlet instance.
getServletName() - Method in interface javax.servlet.ServletConfig
Returns the name of this servlet instance.
getServletName() - Method in class javax.servlet.jsp.ErrorData
Returns the name of the servlet invoked.
getServletNames() - Method in interface javax.servlet.ServletContext
Deprecated. As of Java Servlet API 2.1, with no replacement.

This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

getServletPath() - Method in interface javax.servlet.http.HttpServletRequest
Returns the part of this request's URL that calls the servlet.
getServletPath() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getServletPath() on the wrapped request object.
getServletRequest() - Method in class javax.servlet.ServletRequestEvent
Return the ServletRequest that changed.
getServlets() - Method in interface javax.servlet.ServletContext
Deprecated. As of Java Servlet API 2.0, with no replacement.

This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

getSession() - Method in interface javax.jms.ServerSession
Return the ServerSession's Session.
getSession() - Method in interface javax.jms.XASession
Gets the session associated with this XASession.
getSession() - Method in class javax.mail.MessageContext
Return the Session we're operating in.
getSession(boolean) - Method in interface javax.servlet.http.HttpServletRequest
Returns the current HttpSession associated with this request or, if there is no current session and create is true, returns a new session.
getSession() - Method in interface javax.servlet.http.HttpServletRequest
Returns the current session associated with this request, or if the request does not have a session, creates one.
getSession(boolean) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getSession(boolean create) on the wrapped request object.
getSession() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getSession() on the wrapped request object.
getSession() - Method in class javax.servlet.http.HttpSessionBindingEvent
Return the session that changed.
getSession(String) - Method in interface javax.servlet.http.HttpSessionContext
Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.
getSession() - Method in class javax.servlet.http.HttpSessionEvent
Return the session that changed.
getSession() - Method in class javax.servlet.jsp.PageContext
The current value of the session object (an HttpSession).
getSessionContext() - Method in interface javax.servlet.http.HttpSession
Deprecated. As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.
getSessions() - Method in interface javax.management.j2ee.statistics.JMSConnectionStats
Returns an array of JMSSessionStats that provide statistics about the sessions associated with the referencing JMSConnectionStats.
getSharedNamespaces() - Method in class javax.mail.Store
Return a set of folders representing the shared namespaces.
getShort(String) - Method in interface javax.jms.MapMessage
Returns the short value with the specified name.
getShortName() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
The preferred short name (prefix) as indicated in the TLD.
getShortProperty(String) - Method in interface javax.jms.Message
Returns the value of the short property with the specified name.
getSignature() - Method in class javax.management.MBeanConstructorInfo
Returns the list of parameters for this constructor.
getSignature() - Method in class javax.management.MBeanOperationInfo
Returns the list of parameters for this operation.
getSignature() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo
Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the constructor described by this OpenMBeanConstructorInfo instance.
getSignature() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the operation described by this OpenMBeanOperationInfo instance.
getSize() - Method in interface javax.mail.Part
Return the size of the content of this part in bytes.
getSize() - Method in class javax.mail.internet.MimeBodyPart
Return the size of the content of this body part in bytes.
getSize() - Method in class javax.mail.internet.MimeMessage
Return the size of the content of this message in bytes.
getSize() - Method in class javax.xml.soap.AttachmentPart
Returns the number of bytes in this AttachmentPart object.
getSlot(String) - Method in interface javax.xml.registry.infomodel.ExtensibleObject
Gets the slot specified by slotName.
getSlotType() - Method in interface javax.xml.registry.infomodel.Slot
Gets the slotType for this Slot.
getSlots() - Method in interface javax.xml.registry.infomodel.ExtensibleObject
Returns the Slots associated with this object.
getSmallIcon() - Method in class javax.servlet.jsp.tagext.TagInfo
Get the path to the small icon.
getSourceObject() - Method in interface javax.xml.registry.infomodel.Association
Gets the Object that is the source of this Association.
getSpecVersion() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Returns a string representation of the version of the connector architecture specification that is supported by the resource adapter.
getSpecificationLinks() - Method in interface javax.xml.registry.infomodel.ServiceBinding
Gets all children SpecificationLinks.
getSpecificationName() - Method in class javax.management.MBeanServerDelegate
Returns the full name of the JMX specification implemented by this product.
getSpecificationName() - Method in interface javax.management.MBeanServerDelegateMBean
Returns the full name of the JMX specification implemented by this product.
getSpecificationObject() - Method in interface javax.xml.registry.infomodel.SpecificationLink
Gets the specification object for this object.
getSpecificationVendor() - Method in class javax.management.MBeanServerDelegate
Returns the vendor of the JMX specification implemented by this product.
getSpecificationVendor() - Method in interface javax.management.MBeanServerDelegateMBean
Returns the vendor of the JMX specification implemented by this product.
getSpecificationVersion() - Method in class javax.management.MBeanServerDelegate
Returns the version of the JMX specification implemented by this product.
getSpecificationVersion() - Method in interface javax.management.MBeanServerDelegateMBean
Returns the version of the JMX specification implemented by this product.
getSpecificationVersion() - Method in class javax.servlet.jsp.JspEngineInfo
Return the version number of the JSP specification that is supported by this JSP engine.
getStability() - Method in interface javax.xml.registry.infomodel.RegistryEntry
Gets the stability indicator for the RegistryEntry within the Registry.
getStartDuration() - Method in class javax.resource.spi.work.WorkEvent
Return the start interval duration.
getStartTime() - Method in interface javax.management.j2ee.statistics.Statistic
The time of the first measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
getState() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
Retrieve the StateType value.
getStateOrProvince() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the state or province.
getStateType(int) - Static method in class javax.enterprise.deploy.shared.StateType
Return an object of the specified value.
getStatistic(String) - Method in interface javax.management.j2ee.statistics.Stats
Get a Statistic by name.
getStatisticNames() - Method in interface javax.management.j2ee.statistics.Stats
Returns an array of Strings which are the names of the attributes from the specific Stats submodel that this object supports.
getStatistics() - Method in interface javax.management.j2ee.statistics.Stats
Returns an array containing all of the Statistic objects supported by this Stats object.
getStatus() - Method in interface javax.transaction.Transaction
Obtain the status of the transaction associated with the target Transaction object.
getStatus() - Method in interface javax.transaction.TransactionManager
Obtain the status of the transaction associated with the current thread.
getStatus() - Method in interface javax.transaction.UserTransaction
Obtain the status of the transaction associated with the current thread.
getStatus() - Method in class javax.xml.registry.JAXRException
getStatus() - Method in interface javax.xml.registry.JAXRResponse
Returns the status for this response.
getStatus() - Method in interface javax.xml.registry.infomodel.RegistryEntry
Gets the life cycle status of the RegistryEntry within the registry.
getStatusCode() - Method in class javax.servlet.jsp.ErrorData
Returns the status code of the error.
getStore() - Method in class javax.mail.Folder
Returns the Store that owns this Folder object.
getStore() - Method in class javax.mail.Session
Get a Store object that implements this user's desired Store protocol.
getStore(String) - Method in class javax.mail.Session
Get a Store object that implements the specified protocol.
getStore(URLName) - Method in class javax.mail.Session
Get a Store object for the given URLName.
getStore(Provider) - Method in class javax.mail.Session
Get an instance of the store specified by Provider.
getStore() - Method in class javax.mail.StoreClosedException
Returns the dead Store object
getStreet() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the street name.
getStreetNumber() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the street number.
getString(String) - Method in interface javax.jms.MapMessage
Returns the String value with the specified name.
getString() - Method in class javax.servlet.jsp.tagext.BodyContent
Return the value of the BodyContent as a String.
getStringProperty(String) - Method in interface javax.jms.Message
Returns the value of the String property with the specified name.
getStringTable() - Method in class javax.enterprise.deploy.shared.ActionType
Returns the string table for class ActionType
getStringTable() - Method in class javax.enterprise.deploy.shared.CommandType
Returns the string table for class CommandType
getStringTable() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType
Returns the string table for class DConfigBeanVersionType
getStringTable() - Method in class javax.enterprise.deploy.shared.ModuleType
Returns the string table for class ModuleType
getStringTable() - Method in class javax.enterprise.deploy.shared.StateType
Returns the string table for class StateType
getStringToCompare() - Method in class javax.management.monitor.StringMonitor
Gets the string to compare with the observed attribute common to all observed MBeans.
getStringToCompare() - Method in interface javax.management.monitor.StringMonitorMBean
Gets the string to compare with the observed attribute.
getSubType() - Method in class javax.activation.MimeType
Retrieve the sub type of this object.
getSubType() - Method in class javax.mail.internet.ContentType
Return the subType.
getSubject() - Method in class javax.mail.Message
Get the subject of this message.
getSubject() - Method in class javax.mail.internet.MimeMessage
Returns the value of the "Subject" header field.
getSubmittingOrganization() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the Organization that submitted this RegistryObject.
getSupportedEncodings() - Method in interface javax.xml.rpc.encoding.TypeMapping
Returns the encodingStyle URIs (as String[]) supported by this TypeMapping instance.
getSupportedLocales() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Returns an array of supported locales for this implementation.
getSupportedMechanismTypes() - Method in interface javax.xml.rpc.encoding.DeserializerFactory
Returns a list of all XML processing mechanism types supported by this DeserializerFactory.
getSupportedMechanismTypes() - Method in interface javax.xml.rpc.encoding.SerializerFactory
Returns a list of all XML processing mechanism types supported by this SerializerFactory.
getSystemFlags() - Method in class javax.mail.Flags
Return all the system flags in this Flags object.
getSystemId() - Method in interface javax.xml.transform.Result
Get the system identifier that was set with setSystemId.
getSystemId() - Method in interface javax.xml.transform.Source
Get the system identifier that was set with setSystemId.
getSystemId() - Method in interface javax.xml.transform.SourceLocator
Return the system identifier for the current document event.
getSystemId() - Method in class javax.xml.transform.dom.DOMResult
Get the system identifier that was set with setSystemId.
getSystemId() - Method in class javax.xml.transform.dom.DOMSource
Get the base ID (URL or system ID) from where URLs will be resolved.
getSystemId() - Method in class javax.xml.transform.sax.SAXResult
Get the system identifier that was set with setSystemId.
getSystemId() - Method in class javax.xml.transform.sax.SAXSource
Get the base ID (URI or system ID) from where URIs will be resolved.
getSystemId() - Method in interface javax.xml.transform.sax.TemplatesHandler
Get the base ID (URI or system ID) from where relative URLs will be resolved.
getSystemId() - Method in interface javax.xml.transform.sax.TransformerHandler
Get the base ID (URI or system ID) from where relative URLs will be resolved.
getSystemId() - Method in class javax.xml.transform.stream.StreamResult
Get the system identifier that was set with setSystemId.
getSystemId() - Method in class javax.xml.transform.stream.StreamSource
Get the system identifier that was set with setSystemId.
getTabularType() - Method in interface javax.management.openmbean.TabularData
Returns the tabular type describing this TabularData instance.
getTabularType() - Method in class javax.management.openmbean.TabularDataSupport
Returns the tabular type describing this TabularData instance.
getTag(String) - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
Get the TagInfo for a given tag name, looking through all the tags in this tag library.
getTagClassName() - Method in class javax.servlet.jsp.tagext.TagInfo
Name of the class that provides the handler for this tag.
getTagExtraInfo() - Method in class javax.servlet.jsp.tagext.TagInfo
The instance (if any) for extra tag information.
getTagFile(String) - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
Get the TagFileInfo for a given tag name, looking through all the tag files in this tag library.
getTagFiles() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
An array describing the tag files that are defined in this tag library.
getTagInfo() - Method in class javax.servlet.jsp.tagext.TagExtraInfo
Get the TagInfo for this class.
getTagInfo() - Method in class javax.servlet.jsp.tagext.TagFileInfo
Returns information about this tag, parsed from the directives in the tag file.
getTagLibrary() - Method in class javax.servlet.jsp.tagext.TagInfo
The instance of TabLibraryInfo we belong to.
getTagName() - Method in class javax.servlet.jsp.tagext.TagInfo
The name of the Tag.
getTagVariableInfos() - Method in class javax.servlet.jsp.tagext.TagInfo
Get TagVariableInfo objects associated with this TagInfo.
getTags() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
An array describing the tags that are defined in this tag library.
getTarget() - Method in interface javax.enterprise.deploy.spi.TargetModuleID
Retrieve the name of the target server.
getTargetBinding() - Method in interface javax.xml.registry.infomodel.ServiceBinding
Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.
getTargetEndpointAddress() - Method in interface javax.xml.rpc.Call
Gets the address of a target service endpoint.
getTargetError() - Method in class javax.management.RuntimeErrorException
Returns the actual Error thrown.
getTargetException() - Method in class javax.management.MBeanException
Return the actual Exception thrown.
getTargetException() - Method in class javax.management.ReflectionException
Returns the actual Exception thrown.
getTargetException() - Method in class javax.management.RuntimeMBeanException
Returns the actual RuntimeException thrown.
getTargetException() - Method in class javax.management.RuntimeOperationsException
Returns the actual RuntimeException thrown.
getTargetModuleID() - Method in class javax.enterprise.deploy.spi.status.ProgressEvent
Retrieve the TargetModuleID for this event
getTargetObject() - Method in interface javax.xml.registry.infomodel.Association
Gets the Object that is the target of this Association.
getTargets() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Retrieve the list of deployment targets supported by this DeploymentManager.
getTelephoneNumbers(String) - Method in interface javax.xml.registry.infomodel.Organization
Gets the telephone numbers for this User that match the specified telephone number type.
getTelephoneNumbers(String) - Method in interface javax.xml.registry.infomodel.User
Gets the telephone numbers for this User that match the specified telephone number type.
getTemplates() - Method in interface javax.xml.transform.sax.TemplatesHandler
When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.
getTerm() - Method in class javax.mail.search.NotTerm
Return the term to negate.
getTerms() - Method in class javax.mail.search.AndTerm
Return the search terms.
getTerms() - Method in class javax.mail.search.OrTerm
Return the search terms.
getTestSet() - Method in class javax.mail.search.FlagTerm
Return true if testing whether the flags are set.
getText() - Method in interface javax.enterprise.deploy.model.DDBean
Returns the XML text for by this bean.
getText(String) - Method in interface javax.enterprise.deploy.model.DDBean
Return a list of text values for a given XPath in the deployment descriptor.
getText(String) - Method in interface javax.enterprise.deploy.model.DeployableObject
Return the XML content associated with the XPath from a deployment descriptor.
getText(ModuleType, String) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the text value from the XPath; search only the deployment descriptors of the specified type.
getText() - Method in interface javax.jms.TextMessage
Gets the string containing this message's data.
getThreshold(ObjectName) - Method in class javax.management.monitor.CounterMonitor
Gets the current threshold value of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
getThreshold() - Method in class javax.management.monitor.CounterMonitor
Deprecated. As of JMX 1.2, replaced by CounterMonitor.getThreshold(ObjectName)
getThreshold() - Method in interface javax.management.monitor.CounterMonitorMBean
Deprecated. As of JMX 1.2, replaced by CounterMonitorMBean.getThreshold(ObjectName)
getThreshold(ObjectName) - Method in interface javax.management.monitor.CounterMonitorMBean
Gets the threshold value for the specified MBean.
getThrowable() - Method in class javax.servlet.jsp.ErrorData
Returns the Throwable that caused the error.
getTimeRemaining() - Method in interface javax.ejb.Timer
Get the number of milliseconds that will elapse before the next scheduled timer expiration.
getTimeStamp() - Method in class javax.management.Notification
Get the notification timestamp.
getTimeToLive() - Method in interface javax.jms.MessageProducer
Gets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.
getTimer() - Method in interface javax.ejb.TimerHandle
Obtain a reference to the timer represented by this handle.
getTimerService() - Method in interface javax.ejb.EJBContext
Get access to the EJB Timer Service.
getTimers() - Method in interface javax.ejb.TimerService
Get all the active timers associated with this bean.
getTimestamp() - Method in interface javax.xml.registry.infomodel.AuditableEvent
Gets the Timestamp for when this event occurred.
getTopic() - Method in interface javax.jms.TopicPublisher
Gets the topic associated with this TopicPublisher.
getTopic() - Method in interface javax.jms.TopicSubscriber
Gets the Topic associated with this subscriber.
getTopicName() - Method in interface javax.jms.Topic
Gets the name of this topic.
getTopicSession() - Method in interface javax.jms.XATopicSession
Gets the topic session associated with this XATopicSession.
getTotalTime() - Method in interface javax.management.j2ee.statistics.TimeStatistic
This is the sum total of time taken to complete every invocation of this operation since the beginning of this measurement.
getTransacted() - Method in interface javax.jms.Session
Indicates whether the session is in transacted mode.
getTransacted() - Method in interface javax.jms.XASession
Indicates whether the session is in transacted mode.
getTransaction() - Method in interface javax.transaction.TransactionManager
Get the transaction object that represents the transaction context of the calling thread.
getTransactionTimeout() - Method in class javax.resource.spi.work.ExecutionContext
Get the transaction timeout value for a imported transaction.
getTransactionTimeout() - Method in interface javax.transaction.xa.XAResource
Obtains the current transaction timeout value set for this XAResource instance.
getTransferData(DataFlavor, DataSource) - Method in interface javax.activation.DataContentHandler
Returns an object which represents the data to be transferred.
getTransferData(DataFlavor) - Method in class javax.activation.DataHandler
Returns an object that represents the data to be transferred.
getTransferDataFlavors() - Method in interface javax.activation.DataContentHandler
Returns an array of DataFlavor objects indicating the flavors the data can be provided in.
getTransferDataFlavors() - Method in class javax.activation.DataHandler
Return the DataFlavors in which this data is available.
getTransformer() - Method in interface javax.xml.transform.sax.TransformerHandler
Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.
getTransport() - Method in class javax.mail.Session
Get a Transport object that implements this user's desired Transport protcol.
getTransport(String) - Method in class javax.mail.Session
Get a Transport object that implements the specified protocol.
getTransport(URLName) - Method in class javax.mail.Session
Get a Transport object for the given URLName.
getTransport(Provider) - Method in class javax.mail.Session
Get an instance of the transport specified in the Provider.
getTransport(Address) - Method in class javax.mail.Session
Get a Transport object that can transport a Message to the specified address type.
getTrigger() - Method in class javax.management.monitor.MonitorNotification
Gets the threshold/string (depending on the monitor type) that triggered off this monitor notification.
getType() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Return the ModuleType of deployment descriptor.
getType() - Method in interface javax.enterprise.deploy.model.DeployableObject
Return the ModuleType of deployment descriptor (i.e., EAR, JAR, WAR, RAR) this deployable object represents.
getType() - Method in class javax.mail.Address
Return a type string that identifies this address type.
getType() - Method in class javax.mail.Folder
Returns the type of this Folder, that is, whether this folder can hold messages or subfolders or both.
getType() - Method in class javax.mail.Provider
Returns the type of this Provider
getType() - Method in class javax.mail.event.ConnectionEvent
Return the type of this event
getType() - Method in class javax.mail.event.FolderEvent
Return the type of this event.
getType() - Method in class javax.mail.event.MessageCountEvent
Return the type of this event.
getType() - Method in class javax.mail.event.TransportEvent
Return the type of this event.
getType() - Method in class javax.mail.internet.HeaderTokenizer.Token
Return the type of the token.
getType() - Method in class javax.mail.internet.InternetAddress
Return the type of this address.
getType() - Method in class javax.mail.internet.NewsAddress
Return the type of this address.
getType() - Method in class javax.management.MBeanAttributeInfo
Returns the class name of the attribute.
getType() - Method in class javax.management.MBeanParameterInfo
Returns the type or class name of the data.
getType() - Method in class javax.management.Notification
Get the notification type.
getType(String) - Method in class javax.management.openmbean.CompositeType
Returns the open type of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.
getType() - Method in class javax.resource.spi.work.WorkEvent
Return the type of this event.
getType() - Method in interface javax.xml.registry.Query
Gets the type of Query (for example, QUERY_TYPE_SQL).
getType() - Method in interface javax.xml.registry.infomodel.EmailAddress
Gets the type for this object.
getType() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the type of address (for example, "headquarters") as a String.
getType() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
The type of telephone number (for example, "fax").
getType() - Method in interface javax.xml.registry.infomodel.User
Gets the type for this User.
getTypeMapping(String) - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry
Returns the registered TypeMapping for the specified encodingStyle URI.
getTypeMappingRegistry() - Method in interface javax.xml.rpc.Service
Gets the TypeMappingRegistry for this Service object.
getTypeName() - Method in class javax.management.openmbean.OpenType
Returns the name of this OpenType instance.
getTypeName() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
The type (as a String) of this attribute.
getUID(Message) - Method in interface javax.mail.UIDFolder
Get the UID for the specified message.
getUIDValidity() - Method in interface javax.mail.UIDFolder
Returns the UIDValidity value associated with this folder.
getURI() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
The value of the uri attribute from the taglib directive for this library.
getURI() - Method in interface javax.xml.soap.Name
Returns the URI of the namespace for the XML name that this Name object represents.
getURIResolver() - Method in class javax.xml.transform.Transformer
Get an object that will be used to resolve URIs used in document(), etc.
getURIResolver() - Method in class javax.xml.transform.TransformerFactory
Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
getURL() - Method in class javax.activation.URLDataSource
Return the URL used to create this DataSource.
getURL() - Method in class javax.mail.URLName
Constructs a URL from the URLName.
getURLName() - Method in class javax.mail.Folder
Return a URLName representing this folder.
getURLName() - Method in class javax.mail.Service
Return a URLName representing this service.
getURLs() - Method in class javax.management.loading.MLet
Returns the search path of URLs for loading classes and resources.
getURLs() - Method in interface javax.management.loading.MLetMBean
Returns the search path of URLs for loading classes and resources.
getUnavailableSeconds() - Method in class javax.servlet.UnavailableException
Returns the number of seconds the servlet expects to be temporarily unavailable.
getUnit() - Method in interface javax.management.j2ee.statistics.Statistic
The unit of measurement for this Statistic.
getUnreadMessageCount() - Method in class javax.mail.Folder
Get the total number of unread messages in this Folder.
getUpTime() - Method in interface javax.management.j2ee.statistics.JVMStats
Amount of time the JVM has been running.
getUpperBound() - Method in interface javax.management.j2ee.statistics.BoundaryStatistic
The upper limit of the value of this attribute.
getUrl() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
Gets the URL that can dial this number electronically.
getUrl() - Method in interface javax.xml.registry.infomodel.User
Gets the URL to the web page for this User.
getUsageDescription() - Method in interface javax.xml.registry.infomodel.SpecificationLink
Gets the description of usage parameters.
getUsageParameters() - Method in interface javax.xml.registry.infomodel.SpecificationLink
Gets any usage parameters.
getUseTime() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats
Returns the time spent using a connection
getUseTime() - Method in interface javax.management.j2ee.statistics.JDBCConnectionStats
Time spent using a connection.
getUser() - Method in interface javax.xml.registry.infomodel.AuditableEvent
Gets the User associated with this object.
getUserData() - Method in class javax.management.Notification
Get the user data.
getUserFlags() - Method in class javax.mail.Flags
Return all the user flags in this Flags object.
getUserName() - Method in class javax.mail.PasswordAuthentication
getUserName() - Method in interface javax.resource.cci.ConnectionMetaData
Returns the user name for an active connection as known to the underlying EIS instance.
getUserName() - Method in interface javax.resource.spi.ManagedConnectionMetaData
Returns name of the user associated with the ManagedConnection instance.
getUserName() - Method in class javax.resource.spi.security.PasswordCredential
Returns the user name.
getUserNamespaces(String) - Method in class javax.mail.Store
Return a set of folders representing the namespaces for user.
getUserPrincipal() - Method in interface javax.servlet.http.HttpServletRequest
Returns a java.security.Principal object containing the name of the current authenticated user.
getUserPrincipal() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getUserPrincipal() on the wrapped request object.
getUserPrincipal() - Method in interface javax.xml.rpc.server.ServletEndpointContext
Returns a java.security.Principal instance that contains the name of the authenticated user for the current method invocation on the endpoint instance.
getUserTransaction() - Method in interface javax.ejb.EJBContext
Obtain the transaction demarcation interface.
getUserVersion() - Method in interface javax.xml.registry.infomodel.Versionable
Gets the user-specified revision number for this version of the Versionable object.
getUsername() - Method in class javax.mail.URLName
Returns the user name of this URLName.
getUsers() - Method in interface javax.xml.registry.infomodel.Organization
Gets the Collection of Users affiliated with this Organization.
getValidSentAddresses() - Method in class javax.mail.SendFailedException
Return the addresses to which this message was sent succesfully.
getValidSentAddresses() - Method in class javax.mail.event.TransportEvent
Return the addresses to which this message was sent succesfully.
getValidUnsentAddresses() - Method in class javax.mail.SendFailedException
Return the addresses that are valid but to which this message was not sent.
getValidUnsentAddresses() - Method in class javax.mail.event.TransportEvent
Return the addresses that are valid but to which this message was not sent.
getValidateURI() - Method in interface javax.xml.registry.infomodel.URIValidator
Gets whether to do URI validation for this object.
getValue() - Method in class javax.enterprise.deploy.shared.ActionType
Returns this enumeration value's integer value.
getValue() - Method in class javax.enterprise.deploy.shared.CommandType
Returns this enumeration value's integer value.
getValue() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType
Returns this enumeration value's integer value.
getValue() - Method in class javax.enterprise.deploy.shared.ModuleType
Returns this enumeration value's integer value.
getValue() - Method in class javax.enterprise.deploy.shared.StateType
Returns this enumeration value's integer value.
getValue() - Method in class javax.mail.Header
Returns the value of this header.
getValue() - Method in class javax.mail.internet.HeaderTokenizer.Token
Returns the value of the token just read.
getValue() - Method in class javax.management.Attribute
Returns an Object that is the value of this attribute.
getValue() - Method in class javax.management.StringValueExp
Returns the string represented by the StringValueExp instance.
getValue() - Method in class javax.servlet.ServletContextAttributeEvent
Returns the value of the attribute that has been added, removed, or replaced.
getValue() - Method in class javax.servlet.ServletRequestAttributeEvent
Returns the value of the attribute that has been added removed or replaced.
getValue() - Method in class javax.servlet.http.Cookie
Returns the value of the cookie.
getValue(String) - Method in interface javax.servlet.http.HttpSession
Deprecated. As of Version 2.2, this method is replaced by HttpSession.getAttribute(java.lang.String).
getValue() - Method in class javax.servlet.http.HttpSessionBindingEvent
Returns the value of the attribute that has been added, removed or replaced.
getValue(String) - Method in class javax.servlet.jsp.tagext.TagSupport
Get a the value associated with a key.
getValue() - Method in interface javax.xml.registry.infomodel.Classification
Gets the taxonomy value for this Classification.
getValue() - Method in interface javax.xml.registry.infomodel.Concept
Gets the value (usually a code in a taxonomy) associated with this Concept.
getValue() - Method in interface javax.xml.registry.infomodel.ExternalIdentifier
Gets the value of an ExternalIdentifier.
getValue() - Method in interface javax.xml.registry.infomodel.InternationalString
Gets the String value for the Locale returned by Locale.getDefault().
getValue(Locale) - Method in interface javax.xml.registry.infomodel.InternationalString
Gets the String value for the specified Locale.
getValue() - Method in interface javax.xml.registry.infomodel.LocalizedString
Get the String value for this object.
getValue() - Method in class javax.xml.soap.MimeHeader
Returns the value of this MimeHeader object.
getValue() - Method in interface javax.xml.soap.Node
Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise.
getValueNames() - Method in interface javax.servlet.http.HttpSession
Deprecated. As of Version 2.2, this method is replaced by HttpSession.getAttributeNames()
getValueType() - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Gets the value type for this object.
getValues() - Method in class javax.servlet.jsp.tagext.TagSupport
Enumerate the keys for the values kept by this tag handler.
getValues() - Method in interface javax.xml.registry.infomodel.Slot
Gets the values for this Slot.
getVarName() - Method in class javax.servlet.jsp.tagext.VariableInfo
Returns the name of the scripting variable.
getVariableInfo(TagData) - Method in class javax.servlet.jsp.tagext.TagExtraInfo
information on scripting variables defined by the tag associated with this TagExtraInfo instance.
getVariableInfo(TagData) - Method in class javax.servlet.jsp.tagext.TagInfo
Information on the scripting objects created by this tag at runtime.
getVariableResolver() - Method in class javax.servlet.jsp.JspContext
Returns an instance of a VariableResolver that provides access to the implicit objects specified in the JSP specification using this JspContext as the context object.
getVendor() - Method in class javax.mail.Provider
Returns name of vendor associated with this implementation or null
getVersion() - Method in class javax.mail.Provider
Returns version of this implementation or null if no version
getVersion() - Method in class javax.servlet.http.Cookie
Returns the version of the protocol this cookie complies with.
getVersion() - Method in interface javax.xml.registry.CapabilityProfile
Gets the JAXR specification version supported by the JAXR provider.
getVisibleNamespacePrefixes() - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over the namespace prefix Strings visible to this element.
getWSDLDocumentLocation() - Method in interface javax.xml.rpc.Service
Gets the location of the WSDL document for this Service.
getWaitTime() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats
Returns the time spent waiting for a connection to be available
getWaitTime() - Method in interface javax.management.j2ee.statistics.JDBCConnectionStats
Time spent waiting for a connection to be available.
getWaitingThreadCount() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats
The number of threads waiting for a connection
getWaitingThreadCount() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
Number of threads waiting for a connection.
getWarnings() - Method in interface javax.resource.cci.Interaction
Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.
getWebURL() - Method in interface javax.enterprise.deploy.spi.TargetModuleID
If this TargetModulID represents a web module retrieve the URL for it.
getWork() - Method in class javax.resource.spi.work.WorkEvent
Return the Work instance which is the cause of the event.
getWorkManager() - Method in interface javax.resource.spi.BootstrapContext
Provides a handle to a WorkManager instance.
getWriter() - Method in interface javax.servlet.ServletResponse
Returns a PrintWriter object that can send character text to the client.
getWriter() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getWriter() on the wrapped response object.
getWriter() - Method in class javax.xml.transform.stream.StreamResult
Get the character stream that was set with setWriter.
getXAResource() - Method in interface javax.jms.XASession
Returns an XA resource to the caller.
getXAResource() - Method in interface javax.resource.spi.ManagedConnection
Returns an javax.transaction.xa.XAresource instance.
getXAResources(ActivationSpec[]) - Method in interface javax.resource.spi.ResourceAdapter
This method is called by the application server during crash recovery.
getXATerminator() - Method in interface javax.resource.spi.BootstrapContext
Provides a handle to a XATerminator instance.
getXMLReader() - Method in class javax.xml.parsers.SAXParser
Returns the XMLReader that is encapsulated by the implementation of this class.
getXMLReader() - Method in class javax.xml.transform.sax.SAXSource
Get the XMLReader to be used for the Source.
getXid() - Method in class javax.resource.spi.work.ExecutionContext
getXpath() - Method in interface javax.enterprise.deploy.model.DDBean
Returns the original xpath string provided by the DConfigBean.
getXpath() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Return the XPath for this standard bean.
getXpaths() - Method in interface javax.enterprise.deploy.spi.DConfigBean
Return a list of XPaths designating the deployment descriptor information this DConfigBean requires.
gt(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a "greater than" constraint on two values.

H

HOLDS_FOLDERS - Static variable in class javax.mail.Folder
This folder can contain other folders
HOLDS_MESSAGES - Static variable in class javax.mail.Folder
This folder can contain messages
Handle - interface javax.ejb.Handle.
The Handle interface is implemented by all EJB object handles.
HandleDelegate - interface javax.ejb.spi.HandleDelegate.
The HandleDelegate interface is implemented by the EJB container.
Handler - interface javax.xml.rpc.handler.Handler.
The javax.xml.rpc.handler.Handler interface is required to be implemented by a SOAP message handler.
HandlerChain - interface javax.xml.rpc.handler.HandlerChain.
The javax.xml.rpc.handler.HandlerChain represents a list of handlers.
HandlerInfo - class javax.xml.rpc.handler.HandlerInfo.
The javax.xml.rpc.handler.HandlerInfo represents information about a handler in the HandlerChain.
HandlerInfo() - Constructor for class javax.xml.rpc.handler.HandlerInfo
Default constructor
HandlerInfo(Class, Map, QName[]) - Constructor for class javax.xml.rpc.handler.HandlerInfo
Constructor for HandlerInfo
HandlerRegistry - interface javax.xml.rpc.handler.HandlerRegistry.
The javax.xml.rpc.handler.HandlerRegistry provides support for the programmatic configuration of handlers in a HandlerRegistry.
Header - class javax.mail.Header.
The Header class stores a name/value pair to represent headers.
Header(String, String) - Constructor for class javax.mail.Header
Construct a Header object.
HeaderTerm - class javax.mail.search.HeaderTerm.
This class implements comparisons for Message headers.
HeaderTerm(String, String) - Constructor for class javax.mail.search.HeaderTerm
Constructor.
HeaderTokenizer - class javax.mail.internet.HeaderTokenizer.
This class tokenizes RFC822 and MIME headers into the basic symbols specified by RFC822 and MIME.
HeaderTokenizer(String, String, boolean) - Constructor for class javax.mail.internet.HeaderTokenizer
Constructor that takes a rfc822 style header.
HeaderTokenizer(String, String) - Constructor for class javax.mail.internet.HeaderTokenizer
Constructor.
HeaderTokenizer(String) - Constructor for class javax.mail.internet.HeaderTokenizer
Constructor.
HeaderTokenizer.Token - class javax.mail.internet.HeaderTokenizer.Token.
The Token class represents tokens returned by the HeaderTokenizer.
HeaderTokenizer.Token(int, String) - Constructor for class javax.mail.internet.HeaderTokenizer.Token
Constructor.
HeuristicCommitException - exception javax.transaction.HeuristicCommitException.
This exception is thrown by the rollback operation on a resource to report that a heuristic decision was made and that all relevant updates have been committed.
HeuristicCommitException() - Constructor for class javax.transaction.HeuristicCommitException
HeuristicCommitException(String) - Constructor for class javax.transaction.HeuristicCommitException
HeuristicMixedException - exception javax.transaction.HeuristicMixedException.
This exception is thrown to report that a heuristic decision was made and that some relevant updates have been committed and others have been rolled back.
HeuristicMixedException() - Constructor for class javax.transaction.HeuristicMixedException
HeuristicMixedException(String) - Constructor for class javax.transaction.HeuristicMixedException
HeuristicRollbackException - exception javax.transaction.HeuristicRollbackException.
This exception is thrown by the commit operation to report that a heuristic decision was made and that all relevant updates have been rolled back.
HeuristicRollbackException() - Constructor for class javax.transaction.HeuristicRollbackException
HeuristicRollbackException(String) - Constructor for class javax.transaction.HeuristicRollbackException
Holder - interface javax.xml.rpc.holders.Holder.
The java.xml.rpc.holders.Holder interface represents the base interface for both standard and generated Holder classes.
HomeHandle - interface javax.ejb.HomeHandle.
The HomeHandle interface is implemented by all home object handles.
HttpJspPage - interface javax.servlet.jsp.HttpJspPage.
The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.
HttpServlet - class javax.servlet.http.HttpServlet.
Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site.
HttpServlet() - Constructor for class javax.servlet.http.HttpServlet
Does nothing, because this is an abstract class.
HttpServletRequest - interface javax.servlet.http.HttpServletRequest.
Extends the ServletRequest interface to provide request information for HTTP servlets.
HttpServletRequestWrapper - class javax.servlet.http.HttpServletRequestWrapper.
Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
HttpServletRequestWrapper(HttpServletRequest) - Constructor for class javax.servlet.http.HttpServletRequestWrapper
Constructs a request object wrapping the given request.
HttpServletResponse - interface javax.servlet.http.HttpServletResponse.
Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response.
HttpServletResponseWrapper - class javax.servlet.http.HttpServletResponseWrapper.
Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
HttpServletResponseWrapper(HttpServletResponse) - Constructor for class javax.servlet.http.HttpServletResponseWrapper
Constructs a response adaptor wrapping the given response.
HttpSession - interface javax.servlet.http.HttpSession.
Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.
HttpSessionActivationListener - interface javax.servlet.http.HttpSessionActivationListener.
Objects that are bound to a session may listen to container events notifying them that sessions will be passivated and that session will be activated.
HttpSessionAttributeListener - interface javax.servlet.http.HttpSessionAttributeListener.
This listener interface can be implemented in order to get notifications of changes to the attribute lists of sessions within this web application.
HttpSessionBindingEvent - class javax.servlet.http.HttpSessionBindingEvent.
Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.
HttpSessionBindingEvent(HttpSession, String) - Constructor for class javax.servlet.http.HttpSessionBindingEvent
Constructs an event that notifies an object that it has been bound to or unbound from a session.
HttpSessionBindingEvent(HttpSession, String, Object) - Constructor for class javax.servlet.http.HttpSessionBindingEvent
Constructs an event that notifies an object that it has been bound to or unbound from a session.
HttpSessionBindingListener - interface javax.servlet.http.HttpSessionBindingListener.
Causes an object to be notified when it is bound to or unbound from a session.
HttpSessionContext - interface javax.servlet.http.HttpSessionContext.
Deprecated. As of Java(tm) Servlet API 2.1 for security reasons, with no replacement. This interface will be removed in a future version of this API.
HttpSessionEvent - class javax.servlet.http.HttpSessionEvent.
This is the class representing event notifications for changes to sessions within a web application.
HttpSessionEvent(HttpSession) - Constructor for class javax.servlet.http.HttpSessionEvent
Construct a session event from the given source.
HttpSessionListener - interface javax.servlet.http.HttpSessionListener.
Implementations of this interface are notified of changes to the list of active sessions in a web application.
HttpUtils - class javax.servlet.http.HttpUtils.
Deprecated. As of Java(tm) Servlet API 2.3. These methods were only useful with the default encoding and have been moved to the request interfaces.
HttpUtils() - Constructor for class javax.servlet.http.HttpUtils
Deprecated. Constructs an empty HttpUtils object.
handleFault(MessageContext) - Method in class javax.xml.rpc.handler.GenericHandler
The handleFault method processes the SOAP faults based on the SOAP message processing model.
handleFault(MessageContext) - Method in interface javax.xml.rpc.handler.Handler
The handleFault method processes the SOAP faults based on the SOAP message processing model.
handleFault(MessageContext) - Method in interface javax.xml.rpc.handler.HandlerChain
The handleFault method initiates the SOAP fault processing for this handler chain.
handleMBeanUnregistration(ObjectName, String) - Method in interface javax.management.relation.Relation
Callback used by the Relation Service when a MBean referenced in a role is unregistered.
handleMBeanUnregistration(ObjectName, String) - Method in class javax.management.relation.RelationSupport
Callback used by the Relation Service when a MBean referenced in a role is unregistered.
handleNotification(NotificationListener, Notification, Object) - Method in class javax.management.NotificationBroadcasterSupport
This method is called by sendNotification for each listener in order to send the notification to that listener.
handleNotification(Notification, Object) - Method in interface javax.management.NotificationListener
Invoked when a JMX notification occurs.
handleNotification(Notification, Object) - Method in class javax.management.relation.RelationService
Invoked when a JMX notification occurs.
handlePageException(Exception) - Method in class javax.servlet.jsp.PageContext
This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
handlePageException(Throwable) - Method in class javax.servlet.jsp.PageContext
This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
handleProgressEvent(ProgressEvent) - Method in interface javax.enterprise.deploy.spi.status.ProgressListener
Invoked when a deployment progress event occurs.
handleRequest(MessageContext) - Method in class javax.xml.rpc.handler.GenericHandler
The handleRequest method processes the request SOAP message.
handleRequest(MessageContext) - Method in interface javax.xml.rpc.handler.Handler
The handleRequest method processes the request message.
handleRequest(MessageContext) - Method in interface javax.xml.rpc.handler.HandlerChain
The handleRequest method initiates the request processing for this handler chain.
handleResponse(MessageContext) - Method in class javax.xml.rpc.handler.GenericHandler
The handleResponse method processes the response message.
handleResponse(MessageContext) - Method in interface javax.xml.rpc.handler.Handler
The handleResponse method processes the response SOAP message.
handleResponse(MessageContext) - Method in interface javax.xml.rpc.handler.HandlerChain
The handleResponse method initiates the response processing for this handler chain.
handlesURI(String) - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Tests whether this factory can create a DeploymentManager object based on the specificed URI.
hasDefaultValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null default value for the described attribute, false otherwise.
hasDefaultValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified default value, or false otherwise.
hasDefaultValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null default value for the described parameter, false otherwise.
hasDynamicAttributes() - Method in class javax.servlet.jsp.tagext.TagInfo
Get dynamicAttributes associated with this TagInfo.
hasFault() - Method in interface javax.xml.soap.SOAPBody
Indicates whether a SOAPFault object exists in this SOAPBody object.
hasLegalValues() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null set of legal values for the described attribute, false otherwise.
hasLegalValues() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified set of legal values, or false otherwise.
hasLegalValues() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null set of legal values for the described parameter, false otherwise.
hasMaxValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null maximal value for the described attribute, false otherwise.
hasMaxValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified maximal value, or false otherwise.
hasMaxValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null maximal value for the described parameter, false otherwise.
hasMinValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null minimal value for the described attribute, false otherwise.
hasMinValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified minimal value, or false otherwise.
hasMinValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null minimal value for the described parameter, false otherwise.
hasNewMessages() - Method in class javax.mail.Folder
Returns true if this Folder has new messages since the last time this indication was reset.
hasRelation(String) - Method in class javax.management.relation.RelationService
Checks if there is a relation identified in Relation Service with given relation id.
hasRelation(String) - Method in interface javax.management.relation.RelationServiceMBean
Checks if there is a relation identified in Relation Service with given relation id.
hashCode() - Method in class javax.mail.Flags
Compute a hash code for this Flags object.
hashCode() - Method in class javax.mail.URLName
Compute the hash code for this URLName.
hashCode() - Method in class javax.mail.internet.InternetAddress
Compute a hash code for the address.
hashCode() - Method in class javax.mail.internet.NewsAddress
Compute a hash code for the address.
hashCode() - Method in class javax.mail.search.AddressTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.AndTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.ComparisonTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.DateTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.FlagTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.HeaderTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.IntegerComparisonTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.NotTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.OrTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.RecipientStringTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.RecipientTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.StringTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.management.MBeanAttributeInfo
hashCode() - Method in class javax.management.MBeanConstructorInfo
hashCode() - Method in class javax.management.MBeanFeatureInfo
hashCode() - Method in class javax.management.MBeanInfo
hashCode() - Method in class javax.management.MBeanNotificationInfo
hashCode() - Method in class javax.management.MBeanOperationInfo
hashCode() - Method in class javax.management.MBeanParameterInfo
hashCode() - Method in class javax.management.MBeanPermission
Returns the hash code value for this object.
hashCode() - Method in class javax.management.MBeanServerPermission
hashCode() - Method in class javax.management.ObjectInstance
hashCode() - Method in class javax.management.ObjectName
Returns a hash code for this object name.
hashCode() - Method in class javax.management.openmbean.ArrayType
Returns the hash code value for this ArrayType instance.
hashCode() - Method in interface javax.management.openmbean.CompositeData
Returns the hash code value for this CompositeData instance.
hashCode() - Method in class javax.management.openmbean.CompositeDataSupport
Returns the hash code value for this CompositeDataSupport instance.
hashCode() - Method in class javax.management.openmbean.CompositeType
Returns the hash code value for this CompositeType instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns the hash code value for this OpenMBeanAttributeInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns the hash code value for this OpenMBeanAttributeInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo
Returns the hash code value for this OpenMBeanConstructorInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanConstructorInfoSupport
Returns the hash code value for this OpenMBeanConstructorInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanInfo
Returns the hash code value for this OpenMBeanInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanInfoSupport
Returns the hash code value for this OpenMBeanInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Returns the hash code value for this OpenMBeanOperationInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanOperationInfoSupport
Returns the hash code value for this OpenMBeanOperationInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns the hash code value for this OpenMBeanParameterInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns the hash code value for this OpenMBeanParameterInfoSupport instance.
hashCode() - Method in class javax.management.openmbean.OpenType
hashCode() - Method in class javax.management.openmbean.SimpleType
Returns the hash code value for this SimpleType instance.
hashCode() - Method in interface javax.management.openmbean.TabularData
Returns the hash code value for this TabularData instance.
hashCode() - Method in class javax.management.openmbean.TabularDataSupport
Returns the hash code value for this TabularDataSupport instance.
hashCode() - Method in class javax.management.openmbean.TabularType
Returns the hash code value for this TabularType instance.
hashCode() - Method in interface javax.resource.cci.Record
Returns the hash code for the Record instance.
hashCode() - Method in interface javax.resource.spi.ConnectionRequestInfo
Returns the hashCode of the ConnectionRequestInfo.
hashCode() - Method in interface javax.resource.spi.ManagedConnectionFactory
Returns the hash code for the ManagedConnectionFactory
hashCode() - Method in interface javax.resource.spi.security.GenericCredential
Deprecated. Returns the hash code for this GenericCredential
hashCode() - Method in class javax.resource.spi.security.PasswordCredential
Returns the hash code for this PasswordCredential
hashCode() - Method in class javax.security.jacc.EJBMethodPermission
Returns the hash code value for this EJBMethodPermission.
hashCode() - Method in class javax.security.jacc.EJBRoleRefPermission
Returns the hash code value for this EJBRoleRefPermission.
hashCode() - Method in class javax.security.jacc.WebResourcePermission
Returns the hash code value for this WebResourcePermission.
hashCode() - Method in class javax.security.jacc.WebRoleRefPermission
Returns the hash code value for this WebRoleRefPermission.
hashCode() - Method in class javax.security.jacc.WebUserDataPermission
Returns the hash code value for this WebUserDataPermission.
hashCode() - Method in class javax.xml.namespace.QName
Generate the hash code for this QName.
headerName - Variable in class javax.mail.search.HeaderTerm
The name of the header.
headers - Variable in class javax.mail.internet.MimeBodyPart
The InternetHeaders object that stores all the headers of this body part.
headers - Variable in class javax.mail.internet.MimeMessage
The InternetHeaders object that stores the header of this message.
host - Variable in class javax.mail.internet.NewsAddress

I

ID - Static variable in class javax.servlet.jsp.tagext.TagAttributeInfo
"id" is wired in to be ID.
IMMEDIATE - Static variable in interface javax.resource.spi.work.WorkManager
A constant to indicate timeout duration.
IN - Static variable in class javax.xml.rpc.ParameterMode
IN mode for parameter passing
INDEFINITE - Static variable in interface javax.resource.spi.work.WorkManager
A constant to indicate timeout duration.
INDENT - Static variable in class javax.xml.transform.OutputKeys
indent = "yes" | "no".
INFO - Static variable in class javax.management.MBeanOperationInfo
Indicates that the operation is read-like, it basically returns information.
INLINE - Static variable in interface javax.mail.Part
This part should be presented inline.
INOUT - Static variable in class javax.xml.rpc.ParameterMode
INOUT mode for parameter passing
INTEGER - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Integer.
INTERNAL - Static variable in class javax.resource.spi.work.WorkException
Indicates an internal error condition.
INTERNATIONAL_STRING - Static variable in interface javax.xml.registry.LifeCycleManager
IllegalStateException - exception javax.jms.IllegalStateException.
This exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation.
IllegalStateException(String, String) - Constructor for class javax.jms.IllegalStateException
Constructs an IllegalStateException with the specified reason and error code.
IllegalStateException(String) - Constructor for class javax.jms.IllegalStateException
Constructs an IllegalStateException with the specified reason.
IllegalStateException - exception javax.resource.spi.IllegalStateException.
An IllegalStateException is thrown from a method if the callee (resource adapter or application server for system contracts) is in an illegal or inappropriate state for the method invocation.
IllegalStateException() - Constructor for class javax.resource.spi.IllegalStateException
Constructs a new instance with null as its detail message.
IllegalStateException(String) - Constructor for class javax.resource.spi.IllegalStateException
Constructs a new instance with the specified detail message.
IllegalStateException(Throwable) - Constructor for class javax.resource.spi.IllegalStateException
Constructs a new throwable with the specified cause.
IllegalStateException(String, Throwable) - Constructor for class javax.resource.spi.IllegalStateException
Constructs a new throwable with the specified detail message and cause.
IllegalStateException(String, String) - Constructor for class javax.resource.spi.IllegalStateException
Constructs a new throwable with the specified detail message and an error code.
IllegalWriteException - exception javax.mail.IllegalWriteException.
The exception thrown when a write is attempted on a read-only attribute of any Messaging object.
IllegalWriteException() - Constructor for class javax.mail.IllegalWriteException
Constructs a IllegalWriteException with no detail message.
IllegalWriteException(String) - Constructor for class javax.mail.IllegalWriteException
Constructs a IllegalWriteException with the specified detail message.
IndexedRecord - interface javax.resource.cci.IndexedRecord.
IndexedRecord represents an ordered collection of record elements based on the java.util.List interface.
InstanceAlreadyExistsException - exception javax.management.InstanceAlreadyExistsException.
The MBean is already registered in the repository.
InstanceAlreadyExistsException() - Constructor for class javax.management.InstanceAlreadyExistsException
Default constructor.
InstanceAlreadyExistsException(String) - Constructor for class javax.management.InstanceAlreadyExistsException
Constructor that allows a specific error message to be specified.
InstanceNotFoundException - exception javax.management.InstanceNotFoundException.
The specified MBean does not exist in the repository.
InstanceNotFoundException() - Constructor for class javax.management.InstanceNotFoundException
Default constructor.
InstanceNotFoundException(String) - Constructor for class javax.management.InstanceNotFoundException
Constructor that allows a specific error message to be specified.
IntHolder - class javax.xml.rpc.holders.IntHolder.
IntHolder() - Constructor for class javax.xml.rpc.holders.IntHolder
IntHolder(int) - Constructor for class javax.xml.rpc.holders.IntHolder
IntegerComparisonTerm - class javax.mail.search.IntegerComparisonTerm.
This class implements comparisons for integers.
IntegerComparisonTerm(int, int) - Constructor for class javax.mail.search.IntegerComparisonTerm
IntegerWrapperHolder - class javax.xml.rpc.holders.IntegerWrapperHolder.
IntegerWrapperHolder() - Constructor for class javax.xml.rpc.holders.IntegerWrapperHolder
IntegerWrapperHolder(Integer) - Constructor for class javax.xml.rpc.holders.IntegerWrapperHolder
Interaction - interface javax.resource.cci.Interaction.
The javax.resource.cci.Interaction enables a component to execute EIS functions.
InteractionSpec - interface javax.resource.cci.InteractionSpec.
An InteractionSpec holds properties for driving an Interaction with an EIS instance.
InternationalString - interface javax.xml.registry.infomodel.InternationalString.
This interface represents a String that has been internationalized into several Locales.
InternetAddress - class javax.mail.internet.InternetAddress.
This class represents an Internet email address using the syntax of RFC822.
InternetAddress() - Constructor for class javax.mail.internet.InternetAddress
Default constructor.
InternetAddress(String) - Constructor for class javax.mail.internet.InternetAddress
Constructor.
InternetAddress(String, boolean) - Constructor for class javax.mail.internet.InternetAddress
Parse the given string and create an InternetAddress.
InternetAddress(String, String) - Constructor for class javax.mail.internet.InternetAddress
Construct an InternetAddress given the address and personal name.
InternetAddress(String, String, String) - Constructor for class javax.mail.internet.InternetAddress
Construct an InternetAddress given the address and personal name.
InternetHeaders - class javax.mail.internet.InternetHeaders.
InternetHeaders is a utility class that manages RFC822 style headers.
InternetHeaders() - Constructor for class javax.mail.internet.InternetHeaders
Create an empty InternetHeaders object.
InternetHeaders(InputStream) - Constructor for class javax.mail.internet.InternetHeaders
Read and parse the given RFC822 message stream till the blank line separating the header from the body.
IntrospectionException - exception javax.management.IntrospectionException.
An exception occurred during the introspection of an MBean.
IntrospectionException() - Constructor for class javax.management.IntrospectionException
Default constructor.
IntrospectionException(String) - Constructor for class javax.management.IntrospectionException
Constructor that allows a specific error message to be specified.
InvalidApplicationException - exception javax.management.InvalidApplicationException.
Thrown when an attempt is made to apply either of the following: A subquery expression to an MBean or a qualified attribute expression to an MBean of the wrong class.
InvalidApplicationException(Object) - Constructor for class javax.management.InvalidApplicationException
Constructs an InvalidApplicationException with the specified Object.
InvalidAttributeValueException - exception javax.management.InvalidAttributeValueException.
The value specified is not valid for the attribute.
InvalidAttributeValueException() - Constructor for class javax.management.InvalidAttributeValueException
Default constructor.
InvalidAttributeValueException(String) - Constructor for class javax.management.InvalidAttributeValueException
Constructor that allows a specific error message to be specified.
InvalidClientIDException - exception javax.jms.InvalidClientIDException.
This exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider.
InvalidClientIDException(String, String) - Constructor for class javax.jms.InvalidClientIDException
Constructs an InvalidClientIDException with the specified reason and error code.
InvalidClientIDException(String) - Constructor for class javax.jms.InvalidClientIDException
Constructs an InvalidClientIDException with the specified reason.
InvalidDestinationException - exception javax.jms.InvalidDestinationException.
This exception must be thrown when a destination either is not understood by a provider or is no longer valid.
InvalidDestinationException(String, String) - Constructor for class javax.jms.InvalidDestinationException
Constructs an InvalidDestinationException with the specified reason and error code.
InvalidDestinationException(String) - Constructor for class javax.jms.InvalidDestinationException
Constructs an InvalidDestinationException with the specified reason.
InvalidKeyException - exception javax.management.openmbean.InvalidKeyException.
This runtime exception is thrown to indicate that a method parameter which was expected to be an item name of a composite data or a row index of a tabular data is not valid.
InvalidKeyException() - Constructor for class javax.management.openmbean.InvalidKeyException
An InvalidKeyException with no detail message.
InvalidKeyException(String) - Constructor for class javax.management.openmbean.InvalidKeyException
An InvalidKeyException with a detail message.
InvalidModuleException - exception javax.enterprise.deploy.spi.exceptions.InvalidModuleException.
This exception is to report an invalid J2EE deployment module type.
InvalidModuleException(String) - Constructor for class javax.enterprise.deploy.spi.exceptions.InvalidModuleException
Creates an new InvalidModuleException object.
InvalidOpenTypeException - exception javax.management.openmbean.InvalidOpenTypeException.
This runtime exception is thrown to indicate that the open type of an open data value is not the one expected.
InvalidOpenTypeException() - Constructor for class javax.management.openmbean.InvalidOpenTypeException
An InvalidOpenTypeException with no detail message.
InvalidOpenTypeException(String) - Constructor for class javax.management.openmbean.InvalidOpenTypeException
An InvalidOpenTypeException with a detail message.
InvalidPropertyException - exception javax.resource.spi.InvalidPropertyException.
This exception is thrown to indicate invalid configuration property settings.
InvalidPropertyException() - Constructor for class javax.resource.spi.InvalidPropertyException
Create a InvalidPropertyException.
InvalidPropertyException(String) - Constructor for class javax.resource.spi.InvalidPropertyException
Create a InvalidPropertyException.
InvalidPropertyException(Throwable) - Constructor for class javax.resource.spi.InvalidPropertyException
Constructs a new throwable with the specified cause.
InvalidPropertyException(String, Throwable) - Constructor for class javax.resource.spi.InvalidPropertyException
Constructs a new throwable with the specified detail message and cause.
InvalidPropertyException(String, String) - Constructor for class javax.resource.spi.InvalidPropertyException
Constructs a new throwable with the specified detail message and an error code.
InvalidRelationIdException - exception javax.management.relation.InvalidRelationIdException.
This exception is raised when relation id provided for a relation is already used.
InvalidRelationIdException() - Constructor for class javax.management.relation.InvalidRelationIdException
Default constructor, no message put in exception.
InvalidRelationIdException(String) - Constructor for class javax.management.relation.InvalidRelationIdException
Constructor with given message put in exception.
InvalidRelationServiceException - exception javax.management.relation.InvalidRelationServiceException.
This exception is raised when an invalid Relation Service is provided.
InvalidRelationServiceException() - Constructor for class javax.management.relation.InvalidRelationServiceException
Default constructor, no message put in exception.
InvalidRelationServiceException(String) - Constructor for class javax.management.relation.InvalidRelationServiceException
Constructor with given message put in exception.
InvalidRelationTypeException - exception javax.management.relation.InvalidRelationTypeException.
Invalid relation type.
InvalidRelationTypeException() - Constructor for class javax.management.relation.InvalidRelationTypeException
Default constructor, no message put in exception.
InvalidRelationTypeException(String) - Constructor for class javax.management.relation.InvalidRelationTypeException
Constructor with given message put in exception.
InvalidRequestException - exception javax.xml.registry.InvalidRequestException.
This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.
InvalidRequestException() - Constructor for class javax.xml.registry.InvalidRequestException
Constructs a JAXRException object with no reason or embedded Throwable.
InvalidRequestException(String) - Constructor for class javax.xml.registry.InvalidRequestException
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
InvalidRequestException(String, Throwable) - Constructor for class javax.xml.registry.InvalidRequestException
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
InvalidRequestException(Throwable) - Constructor for class javax.xml.registry.InvalidRequestException
Constructs a JAXRException object initialized with the given Throwable object.
InvalidRoleInfoException - exception javax.management.relation.InvalidRoleInfoException.
This exception is raised when, in a role info, its minimum degree is greater than its maximum degree.
InvalidRoleInfoException() - Constructor for class javax.management.relation.InvalidRoleInfoException
Default constructor, no message put in exception.
InvalidRoleInfoException(String) - Constructor for class javax.management.relation.InvalidRoleInfoException
Constructor with given message put in exception.
InvalidRoleValueException - exception javax.management.relation.InvalidRoleValueException.
Role value is invalid.
InvalidRoleValueException() - Constructor for class javax.management.relation.InvalidRoleValueException
Default constructor, no message put in exception.
InvalidRoleValueException(String) - Constructor for class javax.management.relation.InvalidRoleValueException
Constructor with given message put in exception.
InvalidSelectorException - exception javax.jms.InvalidSelectorException.
This exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax.
InvalidSelectorException(String, String) - Constructor for class javax.jms.InvalidSelectorException
Constructs an InvalidSelectorException with the specified reason and error code.
InvalidSelectorException(String) - Constructor for class javax.jms.InvalidSelectorException
Constructs an InvalidSelectorException with the specified reason.
InvalidTargetObjectTypeException - exception javax.management.modelmbean.InvalidTargetObjectTypeException.
Exception thrown when an invalid target object type is specified.
InvalidTargetObjectTypeException() - Constructor for class javax.management.modelmbean.InvalidTargetObjectTypeException
Default constructor.
InvalidTargetObjectTypeException(String) - Constructor for class javax.management.modelmbean.InvalidTargetObjectTypeException
Constructor from a string.
InvalidTargetObjectTypeException(Exception, String) - Constructor for class javax.management.modelmbean.InvalidTargetObjectTypeException
Constructor taking an exception and a string.
InvalidTransactionException - exception javax.transaction.InvalidTransactionException.
This exception indicates that the request carried an invalid transaction context.
InvalidTransactionException() - Constructor for class javax.transaction.InvalidTransactionException
InvalidTransactionException(String) - Constructor for class javax.transaction.InvalidTransactionException
IterationTag - interface javax.servlet.jsp.tagext.IterationTag.
The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.
id - Variable in class javax.resource.spi.ConnectionEvent
Type of the event
id - Variable in class javax.servlet.jsp.tagext.TagSupport
The value of the id attribute of this tag; or null.
ignoreCase - Variable in class javax.mail.search.StringTerm
Ignore case when comparing?
implies(Permission) - Method in class javax.management.MBeanPermission
Checks if this MBeanPermission object "implies" the specified permission.
implies(Permission) - Method in class javax.management.MBeanServerPermission
Checks if this MBeanServerPermission object "implies" the specified permission.
implies(Permission) - Method in class javax.security.jacc.EJBMethodPermission
Determines if the argument Permission is "implied by" this EJBMethodPermission.
implies(Permission) - Method in class javax.security.jacc.EJBRoleRefPermission
Determines if the argument Permission is "implied by" this EJBRoleRefPermission.
implies(Permission) - Method in class javax.security.jacc.WebResourcePermission
Determines if the argument Permission is "implied by" this WebResourcePermission.
implies(Permission) - Method in class javax.security.jacc.WebRoleRefPermission
Determines if the argument Permission is "implied by" this WebRoleRefPermission.
implies(Permission) - Method in class javax.security.jacc.WebUserDataPermission
Determines if the argument Permission is "implied by" this WebUserDataPermission.
in(ValueExp, ValueExp[]) - Static method in class javax.management.Query
Returns an expression constraining a value to be one of an explicit list.
inService() - Method in interface javax.security.jacc.PolicyConfiguration
This method is used to determine if the policy context whose interface is this PolicyConfiguration Object is in the "inService" state.
inService(String) - Method in class javax.security.jacc.PolicyConfigurationFactory
This method determines if the identified policy context exists with state "inService" in the Policy provider associated with the factory.
include(ServletRequest, ServletResponse) - Method in interface javax.servlet.RequestDispatcher
Includes the content of a resource (servlet, JSP page, HTML file) in the response.
include(String) - Method in class javax.servlet.jsp.PageContext
Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
include(String, boolean) - Method in class javax.servlet.jsp.PageContext
Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
info - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo
Information (documentation) for this TLD.
init(FilterConfig) - Method in interface javax.servlet.Filter
Called by the web container to indicate to a filter that it is being placed into service.
init(ServletConfig) - Method in class javax.servlet.GenericServlet
Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
init() - Method in class javax.servlet.GenericServlet
A convenience method which can be overridden so that there's no need to call super.init(config).
init(ServletConfig) - Method in interface javax.servlet.Servlet
Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
init(HandlerInfo) - Method in class javax.xml.rpc.handler.GenericHandler
The init method to enable the Handler instance to initialize itself.
init(HandlerInfo) - Method in interface javax.xml.rpc.handler.Handler
The init method enables the Handler instance to initialize itself.
init(Map) - Method in interface javax.xml.rpc.handler.HandlerChain
Initializes the configuration for a HandlerChain.
init(Object) - Method in interface javax.xml.rpc.server.ServiceLifecycle
Used for initialization of a service endpoint.
initCause(Throwable) - Method in class javax.xml.registry.JAXRException
Initializes the cause of this throwable to the specified value.
initCause(Throwable) - Method in class javax.xml.soap.SOAPException
Initializes the cause field of this SOAPException object with the given Throwable object.
initCause(Throwable) - Method in class javax.xml.transform.TransformerException
Initializes the cause of this throwable to the specified value.
initialSubString(AttributeValueExp, StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a matching constraint on a string argument.
initialize(Servlet, ServletRequest, ServletResponse, String, boolean, int, boolean) - Method in class javax.servlet.jsp.PageContext
The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.
insertsAreDetected(int) - Method in interface javax.resource.cci.ResultSetInfo
Indicates whether or not a visible row insert can be detected by calling ResultSet.rowInserted.
instantiate(String) - Method in interface javax.management.MBeanServer
Instantiates an object using the list of all class loaders registered in the MBean server's Class Loader Repository.
instantiate(String, ObjectName) - Method in interface javax.management.MBeanServer
Instantiates an object using the class Loader specified by its ObjectName.
instantiate(String, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates an object using the list of all class loaders registered in the MBean server Class Loader Repository.
instantiate(String, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates an object.
invalid - Variable in class javax.mail.SendFailedException
invalid - Variable in class javax.mail.event.TransportEvent
invalidate() - Method in interface javax.servlet.http.HttpSession
Invalidates this session then unbinds any objects bound to it.
invoke(String, Object[], String[]) - Method in interface javax.management.DynamicMBean
Allows an action to be invoked on the Dynamic MBean.
invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management.MBeanServer
Invokes an operation on an MBean.
invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management.MBeanServerConnection
Invokes an operation on an MBean.
invoke(Object, Method, Object[]) - Method in class javax.management.MBeanServerInvocationHandler
invoke(String, Object[], String[]) - Method in class javax.management.StandardMBean
invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management.j2ee.Management
Invokes an operation on a managed object.
invoke(String, Object[], String[]) - Method in class javax.management.modelmbean.RequiredModelMBean
Invokes a method on or through a RequiredModelMBean and returns the result of the method execution.
invoke(Writer) - Method in class javax.servlet.jsp.tagext.JspFragment
Executes the fragment and directs all output to the given Writer, or the JspWriter returned by the getOut() method of the JspContext associated with the fragment if out is null.
invoke(Object[]) - Method in interface javax.xml.rpc.Call
Invokes a specific operation using a synchronous request-response interaction mode.
invoke(QName, Object[]) - Method in interface javax.xml.rpc.Call
Invokes a specific operation using a synchronous request-response interaction mode.
invokeOneWay(Object[]) - Method in interface javax.xml.rpc.Call
Invokes a remote method using the one-way interaction mode.
isActive() - Method in class javax.management.monitor.Monitor
Tests whether the monitor MBean is active.
isActive() - Method in interface javax.management.monitor.MonitorMBean
Tests if the monitor MBean is active.
isActive() - Method in class javax.management.relation.RelationService
Checks if the Relation Service is active.
isActive() - Method in interface javax.management.relation.RelationServiceMBean
Checks if the Relation Service is active.
isActive() - Method in class javax.management.timer.Timer
Tests whether the timer MBean is active.
isActive() - Method in interface javax.management.timer.TimerMBean
Tests whether the timer MBean is active.
isAddEvent() - Method in class javax.enterprise.deploy.model.XpathEvent
Is this an add event?
isArray() - Method in class javax.management.openmbean.OpenType
Returns true if the open data values this open type describes are arrays, false otherwise.
isAutoFlush() - Method in class javax.servlet.jsp.JspWriter
This method indicates whether the JspWriter is autoFlushing.
isAvailable() - Method in class javax.xml.registry.JAXRException
Returns true if a response is available, false otherwise.
isAvailable() - Method in interface javax.xml.registry.JAXRResponse
Returns true if a response is available, false otherwise.
isCallerInRole(Identity) - Method in interface javax.ejb.EJBContext
Deprecated. Use boolean isCallerInRole(String roleName) instead.
isCallerInRole(String) - Method in interface javax.ejb.EJBContext
Test if the caller has a given security role.
isCancelSupported() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Tests whether the vendor supports a cancel opertation for deployment activities.
isChangeEvent() - Method in class javax.enterprise.deploy.model.XpathEvent
Is this a change event?
isClosed() - Method in interface javax.xml.registry.Connection
Indicated whether this Connection has been closed or not.
isCoalescing() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node.
isComment() - Method in interface javax.xml.soap.Text
Retrieves whether this Text object represents a comment.
isCommitted() - Method in interface javax.servlet.ServletResponse
Returns a boolean indicating if the response has been committed.
isCommitted() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return isCommitted() on the wrapped response object.
isCompleted() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
A convience method to report if the operation is in the completed state.
isConfirmed() - Method in interface javax.xml.registry.infomodel.Association
Determines whether an Association has been confirmed completely.
isConfirmedBySourceOwner() - Method in interface javax.xml.registry.infomodel.Association
Determines whether an Association has been confirmed by the owner of the source object.
isConfirmedByTargetOwner() - Method in interface javax.xml.registry.infomodel.Association
Determines whether an Association has been confirmed by the owner of the target object.
isConnected() - Method in class javax.mail.Service
Is this service currently connected?
isDConfigBeanVersionSupported(DConfigBeanVersionType) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Returns 'true' if the configuration beans support the J2EE platform version specified.
isDataFlavorSupported(DataFlavor) - Method in class javax.activation.DataHandler
Returns whether the specified data flavor is supported for this object.
isDeliveryTransacted(Method) - Method in interface javax.resource.spi.endpoint.MessageEndpointFactory
This is used to find out whether message deliveries to a target method on a message listener interface that is implemented by a message endpoint will be transacted or not.
isDomainPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern on the domain part.
isEmpty() - Method in class javax.activation.MimeTypeParameterList
Determine whether or not this list is empty.
isEmpty() - Method in interface javax.management.openmbean.TabularData
Returns true if the number of CompositeData values (ie the number of rows) contained in this TabularData instance is zero.
isEmpty() - Method in class javax.management.openmbean.TabularDataSupport
Returns true if this TabularDataSupport instance contains no rows.
isEmpty() - Method in class javax.management.timer.Timer
Tests whether the list of timer notifications is empty.
isEmpty() - Method in interface javax.management.timer.TimerMBean
Tests whether the list of timer notifications is empty.
isExpandEntityReferences() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which expand entity reference nodes.
isExpunged() - Method in class javax.mail.Message
Checks whether this message is expunged.
isExternal() - Method in interface javax.xml.registry.infomodel.Classification
Returns true if this is an external classification.
isExternal() - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Determines whether this ClassificationScheme is an external ClassificationScheme or an internal ClassificationScheme.
isExtramural() - Method in interface javax.xml.registry.infomodel.Association
Determines whether an Association is extramural or not.
isFailed() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
A convience method to report if the operation is in the failed state.
isFragment() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Whether this attribute is of type JspFragment.
isGroup() - Method in class javax.mail.internet.InternetAddress
Indicates whether this address is an RFC 822 group address.
isIdentical(EJBLocalObject) - Method in interface javax.ejb.EJBLocalObject
Test if a given EJB local object is identical to the invoked EJB local object.
isIdentical(EJBObject) - Method in interface javax.ejb.EJBObject
Test if a given EJB object is identical to the invoked EJB object.
isIgnoringComments() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which ignores comments.
isIgnoringElementContentWhitespace() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which ignore ignorable whitespace in element content.
isInRelationService() - Method in class javax.management.relation.RelationSupport
Returns an internal flag specifying if the object is still handled by the Relation Service.
isInRelationService() - Method in interface javax.management.relation.RelationSupportMBean
Returns an internal flag specifying if the object is still handled by the Relation Service.
isInstanceOf(ObjectName, String) - Method in interface javax.management.MBeanServer
Returns true if the MBean specified is an instance of the specified class, false otherwise.
isInstanceOf(ObjectName, String) - Method in interface javax.management.MBeanServerConnection
Returns true if the MBean specified is an instance of the specified class, false otherwise.
isIs() - Method in class javax.management.MBeanAttributeInfo
Indicates if this attribute has an "is" getter.
isIs() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is accessed through a isXXX getter (applies only to boolean and Boolean values), false otherwise.
isLocaleSupported(Locale) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Reports if this implementation supports the designated locale.
isMimeType(String) - Method in interface javax.mail.Part
Is this Part of the specified MIME type?
isMimeType(String) - Method in class javax.mail.internet.MimeBodyPart
Is this Part of the specified MIME type?
isMimeType(String) - Method in class javax.mail.internet.MimeMessage
Is this Part of the specified MIME type?
isMimeTypeEqual(String) - Method in class javax.activation.ActivationDataFlavor
Is the string representation of the MIME type passed in equivalent to the MIME type of this DataFlavor.
isNamespaceAware() - Method in class javax.xml.parsers.DocumentBuilder
Indicates whether or not this parser is configured to understand namespaces.
isNamespaceAware() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which are namespace aware.
isNamespaceAware() - Method in class javax.xml.parsers.SAXParser
Indicates whether or not this parser is configured to understand namespaces.
isNamespaceAware() - Method in class javax.xml.parsers.SAXParserFactory
Indicates whether or not the factory is configured to produce parsers which are namespace aware.
isNew() - Method in interface javax.servlet.http.HttpSession
Returns true if the client does not yet know about the session or if the client chooses not to join the session.
isNotificationEnabled(Notification) - Method in class javax.management.AttributeChangeNotificationFilter
Invoked before sending the specified notification to the listener.
isNotificationEnabled(Notification) - Method in interface javax.management.NotificationFilter
Invoked before sending the specified notification to the listener.
isNotificationEnabled(Notification) - Method in class javax.management.NotificationFilterSupport
Invoked before sending the specified notification to the listener.
isNotificationEnabled(Notification) - Method in class javax.management.relation.MBeanServerNotificationFilter
Invoked before sending the specified notification to the listener.
isOpaque() - Method in interface javax.xml.registry.infomodel.ExtrinsicObject
Determines whether the ExtrinsicObject is opaque (not readable) by the registry operator.
isOpen() - Method in class javax.mail.Folder
Indicates whether this Folder is in the 'open' state.
isParameterAndReturnSpecRequired(QName) - Method in interface javax.xml.rpc.Call
Indicates whether addParameter and setReturnType methods are to be invoked to specify the parameter and return type specification for a specific operation.
isPartialResponse() - Method in interface javax.xml.registry.BulkResponse
Determines whether the response is a partial response due to large result set.
isPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern.
isPermanent() - Method in class javax.servlet.UnavailableException
Returns a boolean indicating whether the servlet is permanently unavailable.
isPropertyPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern on the key properties.
isReadable() - Method in class javax.management.MBeanAttributeInfo
Whether the value of the attribute can be read.
isReadable() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is readable, false otherwise.
isReadable() - Method in class javax.management.relation.RoleInfo
Returns read access mode for the role (true if it is readable).
isRedeploySupported() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
This method designates whether this platform vendor provides application redeployment functionality.
isRegistered(ObjectName) - Method in interface javax.management.MBeanServer
Checks whether an MBean, identified by its object name, is already registered with the MBean server.
isRegistered(ObjectName) - Method in interface javax.management.MBeanServerConnection
Checks whether an MBean, identified by its object name, is already registered with the MBean server.
isRegistered(ObjectName) - Method in interface javax.management.j2ee.Management
Checks whether a managed object, identified by its object name, is already registered with the MEJB.
isRegistered(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping
Checks whether or not type mapping between specified XML type and Java type is registered.
isRelation(ObjectName) - Method in class javax.management.relation.RelationService
Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
isRelation(ObjectName) - Method in interface javax.management.relation.RelationServiceMBean
Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
isRelationMBean(String) - Method in class javax.management.relation.RelationService
If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
isRelationMBean(String) - Method in interface javax.management.relation.RelationServiceMBean
If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
isRemoveEvent() - Method in class javax.enterprise.deploy.model.XpathEvent
Is this a remove event?
isRemoved() - Method in class javax.mail.event.MessageCountEvent
Indicates whether this event is the result of an explicit expunge by this client, or due to an expunge from external sources.
isRequestedSessionIdFromCookie() - Method in interface javax.servlet.http.HttpServletRequest
Checks whether the requested session ID came in as a cookie.
isRequestedSessionIdFromCookie() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return isRequestedSessionIdFromCookie() on the wrapped request object.
isRequestedSessionIdFromURL() - Method in interface javax.servlet.http.HttpServletRequest
Checks whether the requested session ID came in as part of the request URL.
isRequestedSessionIdFromURL() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return isRequestedSessionIdFromURL() on the wrapped request object.
isRequestedSessionIdFromUrl() - Method in interface javax.servlet.http.HttpServletRequest
Deprecated. As of Version 2.1 of the Java Servlet API, use HttpServletRequest.isRequestedSessionIdFromURL() instead.
isRequestedSessionIdFromUrl() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return isRequestedSessionIdFromUrl() on the wrapped request object.
isRequestedSessionIdValid() - Method in interface javax.servlet.http.HttpServletRequest
Checks whether the requested session ID is still valid.
isRequestedSessionIdValid() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return isRequestedSessionIdValid() on the wrapped request object.
isRequired() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Whether this attribute is required.
isRoleStatus(int) - Static method in class javax.management.relation.RoleStatus
Returns true if given value corresponds to a known role status, false otherwise.
isRunning() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
A convience method to report if the operation is in the running state.
isSameRM(XAResource) - Method in interface javax.transaction.xa.XAResource
This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
isSecure() - Method in interface javax.servlet.ServletRequest
Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.
isSecure() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return isSecure() on the wrapped request object.
isSession() - Method in interface javax.ejb.EJBMetaData
Test if the enterprise Bean's type is "session".
isSet(Flags.Flag) - Method in class javax.mail.Message
Check whether the flag specified in the flag argument is set in this message.
isSet(Flags.Flag) - Method in class javax.mail.internet.MimeMessage
Check whether the flag specified in the flag argument is set in this message.
isStatelessSession() - Method in interface javax.ejb.EJBMetaData
Test if the enterprise Bean's type is "stateless session".
isStopSupported() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Tests whether the vendor supports a stop opertation for deployment activities.
isSubscribed() - Method in class javax.mail.Folder
Returns true if this Folder is subscribed.
isSynchronous() - Method in interface javax.xml.registry.Connection
Indicates whether a client uses synchronous communication with JAXR provider or not.
isTransactional() - Method in interface javax.management.j2ee.statistics.JMSConnectionStats
Returns the transactional state of this JMS connection.
isUserInRole(String) - Method in interface javax.servlet.http.HttpServletRequest
Returns a boolean indicating whether the authenticated user is included in the specified logical "role".
isUserInRole(String) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return isUserInRole(String role) on the wrapped request object.
isUserInRole(String) - Method in interface javax.xml.rpc.server.ServletEndpointContext
Returns a boolean indicating whether the authenticated user for the current method invocation on the endpoint instance is included in the specified logical "role".
isValid() - Method in interface javax.management.Descriptor
Returns true if all of the fields have legal values given their names.
isValid() - Method in class javax.management.modelmbean.DescriptorSupport
Returns true if all of the fields have legal values given their names.
isValid(TagData) - Method in class javax.servlet.jsp.tagext.TagExtraInfo
Translation-time validation of the attributes.
isValid(TagData) - Method in class javax.servlet.jsp.tagext.TagInfo
Translation-time validation of the attributes.
isValidating() - Method in class javax.xml.parsers.DocumentBuilder
Indicates whether or not this parser is configured to validate XML documents.
isValidating() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
isValidating() - Method in class javax.xml.parsers.SAXParser
Indicates whether or not this parser is configured to validate XML documents.
isValidating() - Method in class javax.xml.parsers.SAXParserFactory
Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
isValue(Object) - Method in class javax.management.openmbean.ArrayType
Tests whether obj is a value for this ArrayType instance.
isValue(Object) - Method in class javax.management.openmbean.CompositeType
Tests whether obj is a value which could be described by this CompositeType instance.
isValue(Object) - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Tests whether obj is a valid value for the attribute described by this OpenMBeanAttributeInfoSupport instance.
isValue(Object) - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
isValue(Object) - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
isValue(Object) - Method in class javax.management.openmbean.OpenType
Tests whether obj is a value for this open type.
isValue(Object) - Method in class javax.management.openmbean.SimpleType
Tests whether obj is a value for this SimpleType instance.
isValue(Object) - Method in class javax.management.openmbean.TabularType
Tests whether obj is a value which could be described by this TabularType instance.
isWritable() - Method in class javax.management.MBeanAttributeInfo
Whether new values can be written to the attribute.
isWritable() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is writable, false otherwise.
isWritable() - Method in class javax.management.relation.RoleInfo
Returns write access mode for the role (true if it is writable).
itemExists(String) - Method in interface javax.jms.MapMessage
Indicates whether an item exists in this MapMessage object.

J

J2eeApplicationObject - interface javax.enterprise.deploy.model.J2eeApplicationObject.
J2eeApplicationObject is an interface that represents a J2EE application (EAR); it maintains a DeployableObject for each module in the archive.
JAXRException - exception javax.xml.registry.JAXRException.
Signals that a JAXR exception has occurred.
JAXRException() - Constructor for class javax.xml.registry.JAXRException
Constructs a JAXRException object with no reason or embedded Throwable.
JAXRException(String) - Constructor for class javax.xml.registry.JAXRException
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
JAXRException(String, Throwable) - Constructor for class javax.xml.registry.JAXRException
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
JAXRException(Throwable) - Constructor for class javax.xml.registry.JAXRException
Constructs a JAXRException object initialized with the given Throwable object.
JAXRPCException - exception javax.xml.rpc.JAXRPCException.
The javax.xml.rpc.JAXRPCException is thrown from the core JAX-RPC APIs to indicate an exception related to the JAX-RPC runtime mechanisms.
JAXRPCException() - Constructor for class javax.xml.rpc.JAXRPCException
Constructs a new exception with null as its detail message.
JAXRPCException(String) - Constructor for class javax.xml.rpc.JAXRPCException
Constructs a new exception with the specified detail message.
JAXRPCException(String, Throwable) - Constructor for class javax.xml.rpc.JAXRPCException
Constructs a new exception with the specified detail message and cause.
JAXRPCException(Throwable) - Constructor for class javax.xml.rpc.JAXRPCException
Constructs a new JAXRPCException with the specified cause and a detail message of (cause==null ?
JAXRResponse - interface javax.xml.registry.JAXRResponse.
A JAXR requests' response.
JCAConnectionPoolStats - interface javax.management.j2ee.statistics.JCAConnectionPoolStats.
Specifies the statistics provided by a JCA Connection Pool
JCAConnectionStats - interface javax.management.j2ee.statistics.JCAConnectionStats.
Specifies the statistics provided by a JCA connection
JCAStats - interface javax.management.j2ee.statistics.JCAStats.
Specifies statistics provided by a JCA resource
JDBCConnectionPoolStats - interface javax.management.j2ee.statistics.JDBCConnectionPoolStats.
Specifies the statistics provided by a JDBC connection pool.
JDBCConnectionStats - interface javax.management.j2ee.statistics.JDBCConnectionStats.
Specifies the statistics provided by all (pooled and non-pooled) JDBC connections.
JDBCStats - interface javax.management.j2ee.statistics.JDBCStats.
Statistics provided by a JDBC resource
JMException - exception javax.management.JMException.
Exceptions thrown by JMX implementations.
JMException() - Constructor for class javax.management.JMException
Default constructor.
JMException(String) - Constructor for class javax.management.JMException
Constructor that allows a specific error message to be specified.
JMRuntimeException - exception javax.management.JMRuntimeException.
Runtime exceptions emitted by JMX implementations.
JMRuntimeException() - Constructor for class javax.management.JMRuntimeException
Default constructor.
JMRuntimeException(String) - Constructor for class javax.management.JMRuntimeException
Constructor that allows a specific error message to be specified.
JMSConnectionStats - interface javax.management.j2ee.statistics.JMSConnectionStats.
Specifies the statistics provided by a JMS connection
JMSConsumerStats - interface javax.management.j2ee.statistics.JMSConsumerStats.
Specifies the statistics provided by a JMS message consumer
JMSEndpointStats - interface javax.management.j2ee.statistics.JMSEndpointStats.
Specifies the statistics provided by a JMS message producer or a JMS message consumer.
JMSException - exception javax.jms.JMSException.
This is the root class of all JMS API exceptions.
JMSException(String, String) - Constructor for class javax.jms.JMSException
Constructs a JMSException with the specified reason and error code.
JMSException(String) - Constructor for class javax.jms.JMSException
Constructs a JMSException with the specified reason and with the error code defaulting to null.
JMSProducerStats - interface javax.management.j2ee.statistics.JMSProducerStats.
Specifies the statistics provided by a JMS message producer
JMSSecurityException - exception javax.jms.JMSSecurityException.
This exception must be thrown when a provider rejects a user name/password submitted by a client.
JMSSecurityException(String, String) - Constructor for class javax.jms.JMSSecurityException
Constructs a JMSSecurityException with the specified reason and error code.
JMSSecurityException(String) - Constructor for class javax.jms.JMSSecurityException
Constructs a JMSSecurityException with the specified reason.
JMSSessionStats - interface javax.management.j2ee.statistics.JMSSessionStats.
Specifies the statistics provided by a JMS session.
JMSStats - interface javax.management.j2ee.statistics.JMSStats.
Specifies the statistics provided by a JMS Resource
JTAStats - interface javax.management.j2ee.statistics.JTAStats.
Specifies the statistics provided by a JTA resource.
JVMStats - interface javax.management.j2ee.statistics.JVMStats.
Specifies the statistics provided by a Java VM.
JavaMailStats - interface javax.management.j2ee.statistics.JavaMailStats.
Specifies the statistics provided by a JavaMail resource.
JspContext - class javax.servlet.jsp.JspContext.
JspContext serves as the base class for the PageContext class and abstracts all information that is not specific to servlets.
JspContext() - Constructor for class javax.servlet.jsp.JspContext
Sole constructor.
JspEngineInfo - class javax.servlet.jsp.JspEngineInfo.
The JspEngineInfo is an abstract class that provides information on the current JSP engine.
JspEngineInfo() - Constructor for class javax.servlet.jsp.JspEngineInfo
Sole constructor.
JspException - exception javax.servlet.jsp.JspException.
A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.
JspException() - Constructor for class javax.servlet.jsp.JspException
Construct a JspException.
JspException(String) - Constructor for class javax.servlet.jsp.JspException
Constructs a new JSP exception with the specified message.
JspException(String, Throwable) - Constructor for class javax.servlet.jsp.JspException
Constructs a new JSP exception when the JSP needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
JspException(Throwable) - Constructor for class javax.servlet.jsp.JspException
Constructs a new JSP exception when the JSP needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.
JspFactory - class javax.servlet.jsp.JspFactory.
The JspFactory is an abstract class that defines a number of factory methods available to a JSP page at runtime for the purposes of creating instances of various interfaces and classes used to support the JSP implementation.
JspFactory() - Constructor for class javax.servlet.jsp.JspFactory
Sole constructor.
JspFragment - class javax.servlet.jsp.tagext.JspFragment.
Encapsulates a portion of JSP code in an object that can be invoked as many times as needed.
JspFragment() - Constructor for class javax.servlet.jsp.tagext.JspFragment

JspPage - interface javax.servlet.jsp.JspPage.
The JspPage interface describes the generic interaction that a JSP Page Implementation class must satisfy; pages that use the HTTP protocol are described by the HttpJspPage interface.
JspTag - interface javax.servlet.jsp.tagext.JspTag.
Serves as a base class for Tag and SimpleTag.
JspTagException - exception javax.servlet.jsp.JspTagException.
Exception to be used by a Tag Handler to indicate some unrecoverable error.
JspTagException(String) - Constructor for class javax.servlet.jsp.JspTagException
Constructs a new JspTagException with the specified message.
JspTagException() - Constructor for class javax.servlet.jsp.JspTagException
Constructs a new JspTagException with no message.
JspTagException(String, Throwable) - Constructor for class javax.servlet.jsp.JspTagException
Constructs a new JspTagException when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
JspTagException(Throwable) - Constructor for class javax.servlet.jsp.JspTagException
Constructs a new JSP Tag exception when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.
JspWriter - class javax.servlet.jsp.JspWriter.
The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.
JspWriter(int, boolean) - Constructor for class javax.servlet.jsp.JspWriter
Protected constructor.
javaCharset(String) - Static method in class javax.mail.internet.MimeUtility
Convert a MIME charset name into a valid Java charset name.
javax.activation - package javax.activation
The JavaBeans(TM) Activation Framework is used by the JavaMail(TM) API to manage MIME data.
javax.ejb - package javax.ejb
The javax.ejb package contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
javax.ejb.spi - package javax.ejb.spi
The javax.ejb.spi package defines interfaces that are implemented by the EJB container.
javax.enterprise.deploy.model - package javax.enterprise.deploy.model
Provides Tool Vendor implementation classes.
javax.enterprise.deploy.shared - package javax.enterprise.deploy.shared
Provides shared objects for Tool Vendor and Product Vendor implementation classes.
javax.enterprise.deploy.shared.factories - package javax.enterprise.deploy.shared.factories
Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
javax.enterprise.deploy.spi - package javax.enterprise.deploy.spi
Provides J2EE Product Vendor implementation classes.
javax.enterprise.deploy.spi.exceptions - package javax.enterprise.deploy.spi.exceptions
Provides J2EE Product Vendor deployment exception implementation classes.
javax.enterprise.deploy.spi.factories - package javax.enterprise.deploy.spi.factories
Provides J2EE Product Vendor deployment factory implementation classes.
javax.enterprise.deploy.spi.status - package javax.enterprise.deploy.spi.status
Provides J2EE Product Vendor deployment status implementation classes.
javax.jms - package javax.jms
The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.
javax.mail - package javax.mail
Classes modeling a mail system.
javax.mail.event - package javax.mail.event
Listeners and events for the JavaMail API.
javax.mail.internet - package javax.mail.internet
Classes specific to Internet mail systems.
javax.mail.search - package javax.mail.search
Message search terms for the JavaMail API.
javax.management - package javax.management
Provides the core JMX classes.
javax.management.j2ee - package javax.management.j2ee
Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.
javax.management.j2ee.statistics - package javax.management.j2ee.statistics
Provides the standard interfaces for accessing performance data from J2EE managed objects Package Specification JSR 77, J2EE Management Related Documentation For overviews, tutorials, examples, guides, and tool documentation, please see: J2EE Tools


Serialized Form

Package javax.activation

Class javax.activation.ActivationDataFlavor extends DataFlavor implements Serializable

Serialization Methods

readExternal

public void readExternal(ObjectInput)
                  throws IOException,
                         ClassNotFoundException

writeExternal

public void writeExternal(ObjectOutput)
                   throws IOException

Class javax.activation.MimeType extends Object implements Serializable

Serialization Methods

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
The object implements the readExternal method to restore its contents by calling the methods of DataInput for primitive types and readObject for objects, strings and arrays. The readExternal method must read the values in the same sequence and with the same types as were written by writeExternal.

Throws:
ClassNotFoundException - If the class for an object being restored cannot be found.
IOException

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException
The object implements the writeExternal method to save its contents by calling the methods of DataOutput for its primitive values or calling the writeObject method of ObjectOutput for objects, strings and arrays.

Throws:
IOException - Includes any I/O exceptions that may occur

Class javax.activation.MimeTypeParseException extends Exception implements Serializable

Class javax.activation.UnsupportedDataTypeException extends IOException implements Serializable

Package javax.resource

Class javax.resource.NotSupportedException extends ResourceException implements Serializable

Class javax.resource.ResourceException extends Exception implements Serializable

Serialized Fields

errorCode

String errorCode
Vendor specific error code

linkedException

Exception linkedException
reference to another exception

Package javax.resource.cci

Class javax.resource.cci.ResourceWarning extends ResourceException implements Serializable

Package javax.resource.spi

Class javax.resource.spi.ApplicationServerInternalException extends ResourceException implements Serializable

Class javax.resource.spi.CommException extends ResourceException implements Serializable

Class javax.resource.spi.ConnectionEvent extends EventObject implements Serializable

Serialized Fields

exception

Exception exception
Exception associated with the ConnectionEvent instance.

id

int id
Type of the event

connectionHandle

Object connectionHandle

Class javax.resource.spi.EISSystemException extends ResourceException implements Serializable

Class javax.resource.spi.IllegalStateException extends ResourceException implements Serializable

Class javax.resource.spi.InvalidPropertyException extends ResourceException implements Serializable

Serialized Fields

invalidProperties

PropertyDescriptor[] invalidProperties

Class javax.resource.spi.LocalTransactionException extends ResourceException implements Serializable

Class javax.resource.spi.ResourceAdapterInternalException extends ResourceException implements Serializable

Class javax.resource.spi.ResourceAllocationException extends ResourceException implements Serializable

Class javax.resource.spi.SecurityException extends ResourceException implements Serializable

Class javax.resource.spi.SharingViolationException extends ResourceException implements Serializable

Class javax.resource.spi.UnavailableException extends ResourceException implements Serializable

Package javax.resource.spi.security

Class javax.resource.spi.security.PasswordCredential extends Object implements Serializable

Serialized Fields

userName

String userName

password

char[] password

mcf

ManagedConnectionFactory mcf

Package javax.resource.spi.work

Class javax.resource.spi.work.WorkCompletedException extends WorkException implements Serializable

Class javax.resource.spi.work.WorkEvent extends EventObject implements Serializable

Serialized Fields

type

int type
The event type.

work

Work work
The Work object on which the event occured.

exc

WorkException exc
The exception that occured during Work processing.

startDuration

long startDuration
The start delay duration (in milliseconds).

Class javax.resource.spi.work.WorkException extends ResourceException implements Serializable

Class javax.resource.spi.work.WorkRejectedException extends WorkException implements Serializable

Package javax.enterprise.deploy.spi.exceptions

Class javax.enterprise.deploy.spi.exceptions.BeanNotFoundException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.ClientExecuteException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.ConfigurationException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.InvalidModuleException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.TargetException extends Exception implements Serializable

Package javax.enterprise.deploy.spi.status

Class javax.enterprise.deploy.spi.status.ProgressEvent extends EventObject implements Serializable

Serialized Fields

statuscode

DeploymentStatus statuscode

targetModuleID

TargetModuleID targetModuleID

Package javax.ejb

Class javax.ejb.AccessLocalException extends EJBException implements Serializable

Class javax.ejb.CreateException extends Exception implements Serializable

Class javax.ejb.DuplicateKeyException extends CreateException implements Serializable

Class javax.ejb.EJBException extends RuntimeException implements Serializable

Serialized Fields

causeException

Exception causeException

Class javax.ejb.FinderException extends Exception implements Serializable

Class javax.ejb.NoSuchEntityException extends EJBException implements Serializable

Class javax.ejb.NoSuchObjectLocalException extends EJBException implements Serializable

Class javax.ejb.ObjectNotFoundException extends FinderException implements Serializable

Class javax.ejb.RemoveException extends Exception implements Serializable

Class javax.ejb.TransactionRequiredLocalException extends EJBException implements Serializable

Class javax.ejb.TransactionRolledbackLocalException extends EJBException implements Serializable

Package javax.security.jacc

Class javax.security.jacc.EJBMethodPermission extends Permission implements Serializable

serialVersionUID: 1l

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.

Serialization Overview
The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

Serialized Fields

actions

String actions
the canonicalized actions string (as returned by getActions).

Class javax.security.jacc.EJBRoleRefPermission extends Permission implements Serializable

serialVersionUID: 1l

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.

Serialization Overview
The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

Serialized Fields

actions

String actions
the canonicalized actions string (as returned by getActions).

Class javax.security.jacc.PolicyContextException extends Exception implements Serializable

Class javax.security.jacc.WebResourcePermission extends Permission implements Serializable

serialVersionUID: 1l

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.

Serialization Overview
The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

Serialized Fields

actions

String actions
the canonicalized actions string (as returned by getActions).

Class javax.security.jacc.WebRoleRefPermission extends Permission implements Serializable

serialVersionUID: 1l

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.

Serialization Overview
The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

Serialized Fields

actions

String actions
the canonicalized actions string (as returned by getActions).

Class javax.security.jacc.WebUserDataPermission extends Permission implements Serializable

serialVersionUID: 1l

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.

Serialization Overview
The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

Serialized Fields

actions

String actions
the canonicalized actions string (as returned by getActions).

Package javax.xml.registry

Class javax.xml.registry.DeleteException extends RegistryException implements Serializable

Class javax.xml.registry.FindException extends RegistryException implements Serializable

Class javax.xml.registry.InvalidRequestException extends JAXRException implements Serializable

Class javax.xml.registry.JAXRException extends Exception implements Serializable

Serialized Fields

cause

Throwable cause

Class javax.xml.registry.RegistryException extends JAXRException implements Serializable

Serialized Fields

errorObjectKey

Key errorObjectKey

Class javax.xml.registry.SaveException extends RegistryException implements Serializable

Class javax.xml.registry.UnexpectedObjectException extends JAXRException implements Serializable

Class javax.xml.registry.UnsupportedCapabilityException extends JAXRException implements Serializable

Package javax.xml.namespace

Class javax.xml.namespace.QName extends Object implements Serializable

Serialized Fields

namespaceURI

String namespaceURI

Namespace URI of this QName.

localPart

String localPart

local part of this QName.

prefix

String prefix

prefix of this QName.

Package javax.xml.rpc

Class javax.xml.rpc.JAXRPCException extends RuntimeException implements Serializable

Serialized Fields

cause

Throwable cause

Class javax.xml.rpc.ServiceException extends Exception implements Serializable

Serialized Fields

cause

Throwable cause

Package javax.xml.rpc.handler

Class javax.xml.rpc.handler.HandlerInfo extends Object implements Serializable

Serialized Fields

handlerClass

Class handlerClass

config

Map config

headers

Vector headers

Package javax.xml.rpc.soap

Class javax.xml.rpc.soap.SOAPFaultException extends RuntimeException implements Serializable

Serialized Fields

faultcode

QName faultcode

faultstring

String faultstring

faultactor

String faultactor

detail

Detail detail

Package javax.jms

Class javax.jms.IllegalStateException extends JMSException implements Serializable

Class javax.jms.InvalidClientIDException extends JMSException implements Serializable

Class javax.jms.InvalidDestinationException extends JMSException implements Serializable

Class javax.jms.InvalidSelectorException extends JMSException implements Serializable

Class javax.jms.JMSException extends Exception implements Serializable

Serialized Fields

errorCode

String errorCode
Vendor-specific error code.

linkedException

Exception linkedException
Exception reference.

Class javax.jms.JMSSecurityException extends JMSException implements Serializable

Class javax.jms.MessageEOFException extends JMSException implements Serializable

Class javax.jms.MessageFormatException extends JMSException implements Serializable

Class javax.jms.MessageNotReadableException extends JMSException implements Serializable

Class javax.jms.MessageNotWriteableException extends JMSException implements Serializable

Class javax.jms.ResourceAllocationException extends JMSException implements Serializable

Class javax.jms.TransactionInProgressException extends JMSException implements Serializable

Class javax.jms.TransactionRolledBackException extends JMSException implements Serializable

Package javax.mail

Class javax.mail.Address extends Object implements Serializable

Class javax.mail.AuthenticationFailedException extends MessagingException implements Serializable

Class javax.mail.Flags extends Object implements Serializable

Serialized Fields

system_flags

int system_flags

user_flags

Hashtable user_flags

Class javax.mail.FolderClosedException extends MessagingException implements Serializable

Class javax.mail.FolderNotFoundException extends MessagingException implements Serializable

Class javax.mail.IllegalWriteException extends MessagingException implements Serializable

Class javax.mail.Message.RecipientType extends Object implements Serializable

Serialization Methods

readResolve

protected Object readResolve()
                      throws ObjectStreamException
When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class. Subclasses must implement their own readResolve method that checks for their known instances before calling this super method.

Serialized Fields

type

String type
The type of recipient, usually the name of a corresponding Internet standard header.

Class javax.mail.MessageRemovedException extends MessagingException implements Serializable

Class javax.mail.MessagingException extends Exception implements Serializable

Serialized Fields

next

Exception next
The next exception in the chain.

Class javax.mail.MethodNotSupportedException extends MessagingException implements Serializable

Class javax.mail.NoSuchProviderException extends MessagingException implements Serializable

Class javax.mail.ReadOnlyFolderException extends MessagingException implements Serializable

Class javax.mail.SendFailedException extends MessagingException implements Serializable

Class javax.mail.StoreClosedException extends MessagingException implements Serializable

Package javax.mail.event

Class javax.mail.event.ConnectionEvent extends MailEvent implements Serializable

Serialized Fields

type

int type
The event type.

Class javax.mail.event.FolderEvent extends MailEvent implements Serializable

Serialized Fields

type

int type
The event type.

Class javax.mail.event.MailEvent extends EventObject implements Serializable

Class javax.mail.event.MessageChangedEvent extends MailEvent implements Serializable

Serialized Fields

type

int type
The event type.

Class javax.mail.event.MessageCountEvent extends MailEvent implements Serializable

Serialized Fields

type

int type
The event type.

removed

boolean removed
If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this. If false, this event is the result of an expunge by external sources.

Class javax.mail.event.StoreEvent extends MailEvent implements Serializable

Serialized Fields

type

int type
The event type.

message

String message
The message text to be presented to the user.

Class javax.mail.event.TransportEvent extends MailEvent implements Serializable

Serialized Fields

type

int type
The event type.

Package javax.mail.internet

Class javax.mail.internet.AddressException extends ParseException implements Serializable

Serialized Fields

ref

String ref
The string being parsed.

pos

int pos
The index in the string where the error occurred, or -1 if not known.

Class javax.mail.internet.InternetAddress extends Address implements Serializable

Serialized Fields

address

String address

personal

String personal
The personal name.

encodedPersonal

String encodedPersonal
The RFC 2047 encoded version of the personal name.

This field and the personal field track each other, so if a subclass sets one of these fields directly, it should set the other to null, so that it is suitably recomputed.

Class javax.mail.internet.MailDateFormat extends SimpleDateFormat implements Serializable

Class javax.mail.internet.MimeMessage.RecipientType extends Message.RecipientType implements Serializable

Serialization Methods

readResolve

protected Object readResolve()
                      throws ObjectStreamException
Description copied from class: Message.RecipientType
When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class. Subclasses must implement their own readResolve method that checks for their known instances before calling this super method.

Class javax.mail.internet.NewsAddress extends Address implements Serializable

Serialized Fields

newsgroup

String newsgroup

host

String host

Class javax.mail.internet.ParseException extends MessagingException implements Serializable

Package javax.mail.search

Class javax.mail.search.AddressStringTerm extends StringTerm implements Serializable

Class javax.mail.search.AddressTerm extends SearchTerm implements Serializable

Serialized Fields

address

Address address
The address.

Class javax.mail.search.AndTerm extends SearchTerm implements Serializable

Serialized Fields

terms

SearchTerm[] terms
The array of terms on which the AND operator should be applied.

Class javax.mail.search.BodyTerm extends StringTerm implements Serializable

Class javax.mail.search.ComparisonTerm extends SearchTerm implements Serializable

Serialized Fields

comparison

int comparison
The comparison.

Class javax.mail.search.DateTerm extends ComparisonTerm implements Serializable

Serialized Fields

date

Date date
The date.

Class javax.mail.search.FlagTerm extends SearchTerm implements Serializable

Serialized Fields

set

boolean set
Indicates whether to test for the presence or absence of the specified Flag. If true, then test whether all the specified flags are present, else test whether all the specified flags are absent.

flags

Flags flags
Flags object containing the flags to test.

Class javax.mail.search.FromStringTerm extends AddressStringTerm implements Serializable

Class javax.mail.search.FromTerm extends AddressTerm implements Serializable

Class javax.mail.search.HeaderTerm extends StringTerm implements Serializable

Serialized Fields

headerName

String headerName
The name of the header.

Class javax.mail.search.IntegerComparisonTerm extends ComparisonTerm implements Serializable

Serialized Fields

number

int number
The number.

Class javax.mail.search.MessageIDTerm extends StringTerm implements Serializable

Class javax.mail.search.MessageNumberTerm extends IntegerComparisonTerm implements Serializable

Class javax.mail.search.NotTerm extends SearchTerm implements Serializable

Serialized Fields

term

SearchTerm term
The search term to negate.

Class javax.mail.search.OrTerm extends SearchTerm implements Serializable

Serialized Fields

terms

SearchTerm[] terms
The array of terms on which the OR operator should be applied.

Class javax.mail.search.ReceivedDateTerm extends DateTerm implements Serializable

Class javax.mail.search.RecipientStringTerm extends AddressStringTerm implements Serializable

Serialized Fields

type

Message.RecipientType type
The recipient type.

Class javax.mail.search.RecipientTerm extends AddressTerm implements Serializable

Serialized Fields

type

Message.RecipientType type
The recipient type.

Class javax.mail.search.SearchException extends MessagingException implements Serializable

Class javax.mail.search.SearchTerm extends Object implements Serializable

Class javax.mail.search.SentDateTerm extends DateTerm implements Serializable

Class javax.mail.search.SizeTerm extends IntegerComparisonTerm implements Serializable

Class javax.mail.search.StringTerm extends SearchTerm implements Serializable

Serialized Fields

pattern

String pattern
The pattern.

ignoreCase

boolean ignoreCase
Ignore case when comparing?

Class javax.mail.search.SubjectTerm extends StringTerm implements Serializable

Package javax.xml.soap

Class javax.xml.soap.SOAPException extends Exception implements Serializable

Serialized Fields

cause

Throwable cause

Package javax.servlet.jsp

Class javax.servlet.jsp.JspException extends Exception implements Serializable

Serialized Fields

rootCause

Throwable rootCause

Class javax.servlet.jsp.JspTagException extends JspException implements Serializable

Class javax.servlet.jsp.SkipPageException extends JspException implements Serializable

Package javax.servlet.jsp.el

Class javax.servlet.jsp.el.ELException extends Exception implements Serializable

Serialized Fields

mRootCause

Throwable mRootCause

Class javax.servlet.jsp.el.ELParseException extends ELException implements Serializable

Package javax.servlet.jsp.tagext

Class javax.servlet.jsp.tagext.BodyTagSupport extends TagSupport implements Serializable

Serialized Fields

bodyContent

BodyContent bodyContent
The current BodyContent for this BodyTag.

Class javax.servlet.jsp.tagext.TagSupport extends Object implements Serializable

Serialized Fields

parent

Tag parent

values

Hashtable values

id

String id
The value of the id attribute of this tag; or null.

pageContext

PageContext pageContext
The PageContext.

Package javax.servlet

Class javax.servlet.GenericServlet extends Object implements Serializable

Class javax.servlet.ServletContextAttributeEvent extends ServletContextEvent implements Serializable

Serialized Fields

name

String name

value

Object value

Class javax.servlet.ServletContextEvent extends EventObject implements Serializable

Class javax.servlet.ServletException extends Exception implements Serializable

Serialized Fields

rootCause

Throwable rootCause

Class javax.servlet.ServletRequestAttributeEvent extends ServletRequestEvent implements Serializable

Serialized Fields

name

String name

value

Object value

Class javax.servlet.ServletRequestEvent extends EventObject implements Serializable

Serialized Fields

request

ServletRequest request

Class javax.servlet.UnavailableException extends ServletException implements Serializable

Serialized Fields

servlet

Servlet servlet

permanent

boolean permanent

seconds

int seconds

Package javax.servlet.http

Class javax.servlet.http.HttpServlet extends GenericServlet implements Serializable

Class javax.servlet.http.HttpSessionBindingEvent extends HttpSessionEvent implements Serializable

Serialized Fields

name

String name

value

Object value

Class javax.servlet.http.HttpSessionEvent extends EventObject implements Serializable

Package javax.transaction

Class javax.transaction.HeuristicCommitException extends Exception implements Serializable

Class javax.transaction.HeuristicMixedException extends Exception implements Serializable

Class javax.transaction.HeuristicRollbackException extends Exception implements Serializable

Class javax.transaction.InvalidTransactionException extends RemoteException implements Serializable

Class javax.transaction.NotSupportedException extends Exception implements Serializable

Class javax.transaction.RollbackException extends Exception implements Serializable

Class javax.transaction.SystemException extends Exception implements Serializable

Serialized Fields

errorCode

int errorCode
The error code with which to create the SystemException.

The error code for the exception

Class javax.transaction.TransactionRequiredException extends RemoteException implements Serializable

Class javax.transaction.TransactionRolledbackException extends RemoteException implements Serializable

Package javax.transaction.xa

Class javax.transaction.xa.XAException extends Exception implements Serializable

Serialized Fields

errorCode

int errorCode
The error code with which to create the SystemException.

The error code for the exception.

Package javax.management

Class javax.management.AndQueryExp extends QueryEval implements Serializable

serialVersionUID: -1081892073854801359l

Serialized Fields

exp1

QueryExp exp1
The first QueryExp of the conjuction

exp2

QueryExp exp2
The second QueryExp of the conjuction

Class javax.management.Attribute extends Object implements Serializable

serialVersionUID: 2484220110589082382l

Serialized Fields

name

String name
Attribute name.

value

Object value
Attribute value

Class javax.management.AttributeChangeNotification extends Notification implements Serializable

serialVersionUID: 535176054565814134l

Serialized Fields

attributeName

String attributeName
The MBean attribute name.

attributeType

String attributeType
The MBean attribute type.

oldValue

Object oldValue
The MBean attribute old value.

newValue

Object newValue
The MBean attribute new value.

Class javax.management.AttributeChangeNotificationFilter extends Object implements Serializable

serialVersionUID: -6347317584796410029l

Serialized Fields

enabledAttributes

Vector enabledAttributes
Vector that contains the enabled attribute names. The default value is an empty vector.

Class javax.management.AttributeList extends ArrayList implements Serializable

serialVersionUID: -4077085769279709076l

Class javax.management.AttributeNotFoundException extends OperationsException implements Serializable

serialVersionUID: 6511584241791106926l

Class javax.management.AttributeValueExp extends Object implements Serializable

serialVersionUID: -7768025046539163385l

Serialized Fields

attr

String attr
The name of the attribute

Class javax.management.BadAttributeValueExpException extends Exception implements Serializable

serialVersionUID: -3105272988410493376l

Serialized Fields

val

Object val
The attribute value that originated this exception

Class javax.management.BadBinaryOpValueExpException extends Exception implements Serializable

serialVersionUID: 5068475589449021227l

Serialized Fields

exp

ValueExp exp
the ValueExp that originated this exception

Class javax.management.BadStringOperationException extends Exception implements Serializable

serialVersionUID: 7802201238441662100l

Serialized Fields

op

String op
The description of the operation that originated this exception

Class javax.management.BetweenQueryExp extends QueryEval implements Serializable

serialVersionUID: -2933597532866307444l

Serialized Fields

exp1

ValueExp exp1
The checked value

exp2

ValueExp exp2
The lower bound value

exp3

ValueExp exp3
The upper bound value

Class javax.management.BinaryOpValueExp extends QueryEval implements Serializable

serialVersionUID: 1216286847881456786l

Serialized Fields

op

int op
The operator

exp1

ValueExp exp1
The first value

exp2

ValueExp exp2
The second value

Class javax.management.BinaryRelQueryExp extends QueryEval implements Serializable

serialVersionUID: -5690656271650491000l

Serialized Fields

relOp

int relOp
The operator

exp1

ValueExp exp1
The first value

exp2

ValueExp exp2
The second value

Class javax.management.BooleanValueExp extends QueryEval implements Serializable

serialVersionUID: 7754922052666594581l

Serialized Fields

val

boolean val
The boolean value

Class javax.management.ClassAttributeValueExp extends AttributeValueExp implements Serializable

Serialized Fields

attr

String attr
The name of the attribute

Class javax.management.InQueryExp extends QueryEval implements Serializable

serialVersionUID: -5801329450358952434l

Serialized Fields

val

ValueExp val
The ValueExp to be found

valueList

ValueExp[] valueList
The array of ValueExp to be searched

Class javax.management.InstanceAlreadyExistsException extends OperationsException implements Serializable

serialVersionUID: 8893743928912733931l

Class javax.management.InstanceNotFoundException extends OperationsException implements Serializable

serialVersionUID: -882579438394773049l

Class javax.management.IntrospectionException extends OperationsException implements Serializable

serialVersionUID: 1054516935875481725l

Class javax.management.InvalidApplicationException extends Exception implements Serializable

serialVersionUID: -3048022274675537269l

Serialized Fields

val

Object val
The object representing the class of the MBean

Class javax.management.InvalidAttributeValueException extends OperationsException implements Serializable

serialVersionUID: 2164571879317142449l

Class javax.management.JMException extends Exception implements Serializable

serialVersionUID: 350520924977331825l

Class javax.management.JMRuntimeException extends RuntimeException implements Serializable

serialVersionUID: 6573344628407841861l

Class javax.management.ListenerNotFoundException extends OperationsException implements Serializable

serialVersionUID: -7242605822448519061l

Class javax.management.MalformedObjectNameException extends OperationsException implements Serializable

serialVersionUID: -572689714442915824l

Class javax.management.MatchQueryExp extends QueryEval implements Serializable

serialVersionUID: -7156603696948215014l

Serialized Fields

exp

AttributeValueExp exp
The attribute value to be matched

pattern

String pattern
The pattern to be matched

Class javax.management.MBeanAttributeInfo extends MBeanFeatureInfo implements Serializable

Serialized Fields

attributeType

String attributeType
The actual attribute type.

isWrite

boolean isWrite
The attribute write right.

isRead

boolean isRead
The attribute read right.

is

boolean is
Indicates if this method is a "is"

Class javax.management.MBeanConstructorInfo extends MBeanFeatureInfo implements Serializable

serialVersionUID: 4433990064191844427l

Serialized Fields

signature

MBeanParameterInfo[] signature
The signature of the method, that is, the class names of the arguments.

Class javax.management.MBeanException extends JMException implements Serializable

serialVersionUID: 4066342430588744142l

Serialized Fields

exception

Exception exception
Encapsulated Exception

Class javax.management.MBeanFeatureInfo extends Object implements Serializable

serialVersionUID: 3952882688968447265l

Serialized Fields

name

String name
The name of the feature. It is recommended that subclasses call MBeanFeatureInfo.getName() rather than reading this field, and that they not change it.

The name of the feature.

description

String description
The human-readable description of the feature. It is recommended that subclasses call MBeanFeatureInfo.getDescription() rather than reading this field, and that they not change it.

The human-readable description of the feature.

Class javax.management.MBeanInfo extends Object implements Serializable

serialVersionUID: -6451021435135161911l

Serialized Fields

description

String description
The human readable description of the class.

className

String className
The MBean qualified name.

attributes

MBeanAttributeInfo[] attributes
The MBean attribute descriptors.

operations

MBeanOperationInfo[] operations
The MBean operation descriptors.

constructors

MBeanConstructorInfo[] constructors
The MBean constructor descriptors.

notifications

MBeanNotificationInfo[] notifications
The MBean notification descriptors.

Class javax.management.MBeanNotificationInfo extends MBeanFeatureInfo implements Serializable

serialVersionUID: -3888371564530107064l

Serialized Fields

types

String[] types
The different types of the notification.

Class javax.management.MBeanOperationInfo extends MBeanFeatureInfo implements Serializable

serialVersionUID: -6178860474881375330l

Serialized Fields

type

String type
The method's return value.

signature

MBeanParameterInfo[] signature
The signature of the method, that is, the class names of the arguments.

impact

int impact
The impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN

Class javax.management.MBeanParameterInfo extends MBeanFeatureInfo implements Serializable

serialVersionUID: 7432616882776782338l

Serialized Fields

type

String type
The type or class name of the data.

Class javax.management.MBeanPermission extends Permission implements Serializable

serialVersionUID: -2416928705275160661l

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserialize this object based on its name and actions.

Serialized Fields

actions

String actions
The actions string.

Class javax.management.MBeanRegistrationException extends MBeanException implements Serializable

serialVersionUID: 4482382455277067805l

Class javax.management.MBeanServerNotification extends Notification implements Serializable

serialVersionUID: 2876477500475969677l

Serialized Fields

objectName

ObjectName objectName
The object names of the MBeans concerned by this notification

Class javax.management.MBeanServerPermission extends BasicPermission implements Serializable

serialVersionUID: -5661980843569388590l

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException

Class javax.management.MBeanServerPermissionCollection extends PermissionCollection implements Serializable

serialVersionUID: -5661980843569388590l

Serialized Fields

collectionPermission

MBeanServerPermission collectionPermission
Null if no permissions in collection, otherwise a single permission that is the union of all permissions that have been added.

Class javax.management.MBeanTrustPermission extends BasicPermission implements Serializable

serialVersionUID: -2952178077029018140l

Class javax.management.NotCompliantMBeanException extends OperationsException implements Serializable

serialVersionUID: 5175579583207963577l

Class javax.management.Notification extends EventObject implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a Notification from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a Notification to an ObjectOutputStream.

Serialized Fields

message

String message
The notification message.

sequenceNumber

long sequenceNumber
The notification sequence number. A serial number which identify particular instance of notification in the context of the notification source.

source

Object source
The object on which the notification initially occurred.

timeStamp

long timeStamp
The notification timestamp. Indicating when the notification was generated

type

String type
The notification type. A string expressed in a dot notation similar to Java properties. An example of a notification type is network.alarm.router

userData

Object userData
The notification user data. Used for whatever other data the notification source wishes to communicate to its consumers

Class javax.management.NotificationFilterSupport extends Object implements Serializable

serialVersionUID: 6579080007561786969l

Serialized Fields

enabledTypes

List enabledTypes
Vector that contains the enabled notification types. The default value is an empty vector.

Class javax.management.NotQueryExp extends QueryEval implements Serializable

serialVersionUID: 5269643775896723397l

Serialized Fields

exp

QueryExp exp
The negated QueryExp

Class javax.management.NumericValueExp extends QueryEval implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a NumericValueExp from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a NumericValueExp to an ObjectOutputStream.

Serialized Fields

val

Number val
The {@link Number} representing the numeric value

Class javax.management.ObjectInstance extends Object implements Serializable

serialVersionUID: -4099952623687795850l

Serialized Fields

name

ObjectName name
Object name.

className

String className
Class name.

Class javax.management.ObjectName extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an ObjectName from an ObjectInputStream.

Serial Data:
  • In the current serial form (value of property jmx.serial.form differs from 1.0): the string "<domain>:<properties><wild>", where:
    • <domain> represents the domain part of the ObjectName
    • <properties> represents the list of properties, as returned by ObjectName.getKeyPropertyListString()
    • <wild> is empty if not isPropertyPattern, or is the character "*" if isPropertyPattern and <properties> is empty, or is ",*" if isPropertyPattern and <properties> is not empty.
    The intent is that this string could be supplied to the ObjectName.ObjectName(String) constructor to produce an equivalent ObjectName.
  • In the old serial form (value of property jmx.serial.form is 1.0): <domain> <propertyList> <propertyListString> <canonicalName> <pattern> <propertyPattern>, where:
    • <domain> represents the domain part of the ObjectName
    • <propertyList> is the Hashtable that contains all the pairs (key,value) for this ObjectName
    • <propertyListString> is the String representation of the list of properties in any order (not mandatorily a canonical representation)
    • <canonicalName> is the String containing this ObjectName's canonical name
    • <pattern> is a boolean which is true if this ObjectName contains a pattern
    • <propertyPattern> is a boolean which is true if this ObjectName contains a pattern in the list of properties
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes an ObjectName to an ObjectOutputStream.

Serial Data:
  • In the current serial form (value of property jmx.serial.form differs from 1.0): the string "<domain>:<properties><wild>", where:
    • <domain> represents the domain part of the ObjectName
    • <properties> represents the list of properties, as returned by ObjectName.getKeyPropertyListString()
    • <wild> is empty if not isPropertyPattern, or is the character "*" if this isPropertyPattern and <properties> is empty, or is ",*" if isPropertyPattern and <properties> is not empty.
    The intent is that this string could be supplied to the ObjectName.ObjectName(String) constructor to produce an equivalent ObjectName.
  • In the old serial form (value of property jmx.serial.form is 1.0): <domain> <propertyList> <propertyListString> <canonicalName> <pattern> <propertyPattern>, where:
    • <domain> represents the domain part of the ObjectName
    • <propertyList> is the Hashtable that contains all the pairs (key,value) for this ObjectName
    • <propertyListString> is the String representation of the list of properties in any order (not mandatorily a canonical representation)
    • <canonicalName> is the String containing this ObjectName's canonical name
    • <pattern> is a boolean which is true if this ObjectName contains a pattern
    • <propertyPattern> is a boolean which is true if this ObjectName contains a pattern in the list of properties
Throws:
IOException
Serialized Fields

Class javax.management.OperationsException extends JMException implements Serializable

serialVersionUID: -4967597595580536216l

Class javax.management.OrQueryExp extends QueryEval implements Serializable

serialVersionUID: 2962973084421716523l

Serialized Fields

exp1

QueryExp exp1
The left query expression

exp2

QueryExp exp2
The right query expression

Class javax.management.QualifiedAttributeValueExp extends AttributeValueExp implements Serializable

serialVersionUID: 8832517277410933254l

Serialized Fields

className

String className
The attribute class name

Class javax.management.QueryEval extends Object implements Serializable

serialVersionUID: 2675899265640874796l

Class javax.management.ReflectionException extends JMException implements Serializable

serialVersionUID: 9170809325636915553l

Serialized Fields

exception

Exception exception
The wrapped Exception

Class javax.management.RuntimeErrorException extends JMRuntimeException implements Serializable

serialVersionUID: 704338937753949796l

Serialized Fields

error

Error error
The encapsulated Error

Class javax.management.RuntimeMBeanException extends JMRuntimeException implements Serializable

serialVersionUID: 5274912751982730171l

Serialized Fields

runtimeException

RuntimeException runtimeException
The encapsulated RuntimeException

Class javax.management.RuntimeOperationsException extends JMRuntimeException implements Serializable

serialVersionUID: -8408923047489133588l

Serialized Fields

runtimeException

RuntimeException runtimeException
The encapsulated RuntimeException

Class javax.management.ServiceNotFoundException extends OperationsException implements Serializable

serialVersionUID: -3990675661956646827l

Class javax.management.StringValueExp extends Object implements Serializable

serialVersionUID: -3256390509806284044l

Serialized Fields

val

String val
The string literal

Package javax.management.loading

Class javax.management.loading.MLet extends URLClassLoader implements Serializable

serialVersionUID: 3636148327800330130l

Serialization Methods

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

Restore this MLet's contents from the given ObjectInput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the read data.

The format of the read data is not specified, but if an implementation supports MLet.readExternal(java.io.ObjectInput) it must also support MLet.writeExternal(java.io.ObjectOutput) in such a way that what is written by the latter can be read by the former.

Throws:
IOException - if a problem occurred while reading.
ClassNotFoundException - if the class for the object being restored cannot be found.
UnsupportedOperationException - if this implementation does not support this operation.

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

Save this MLet's contents to the given ObjectOutput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the written data.

The format of the written data is not specified, but if an implementation supports MLet.writeExternal(java.io.ObjectOutput) it must also support MLet.readExternal(java.io.ObjectInput) in such a way that what is written by the former can be read by the latter.

Throws:
IOException - If a problem occurred while writing.
UnsupportedOperationException - If this implementation does not support this operation.

Class javax.management.loading.PrivateMLet extends MLet implements Serializable

serialVersionUID: 2503458973393711979l

Serialization Methods

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

Restore this MLet's contents from the given ObjectInput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the read data.

The format of the read data is not specified, but if an implementation supports MLet.readExternal(java.io.ObjectInput) it must also support MLet.writeExternal(java.io.ObjectOutput) in such a way that what is written by the latter can be read by the former.

Throws:
IOException - if a problem occurred while reading.
ClassNotFoundException - if the class for the object being restored cannot be found.
UnsupportedOperationException - if this implementation does not support this operation.

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

Save this MLet's contents to the given ObjectOutput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the written data.

The format of the written data is not specified, but if an implementation supports MLet.writeExternal(java.io.ObjectOutput) it must also support MLet.readExternal(java.io.ObjectInput) in such a way that what is written by the former can be read by the latter.

Throws:
IOException - If a problem occurred while writing.
UnsupportedOperationException - If this implementation does not support this operation.

Package javax.management.monitor

Class javax.management.monitor.MonitorNotification extends Notification implements Serializable

serialVersionUID: -4608189663661929204l

Serialized Fields

observedObject

ObjectName observedObject
Monitor notification observed object.

observedAttribute

String observedAttribute
Monitor notification observed attribute.

derivedGauge

Object derivedGauge
Monitor notification derived gauge.

trigger

Object trigger
Monitor notification release mechanism. This value is used to keep the threshold/string (depending on the monitor type) that triggered off this notification.

Class javax.management.monitor.MonitorSettingException extends JMRuntimeException implements Serializable

serialVersionUID: -8807913418190202007l

Package javax.management.modelmbean

Class javax.management.modelmbean.DescriptorSupport extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a DescriptorSupport from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a DescriptorSupport to an ObjectOutputStream.

Serialized Fields

descriptor

HashMap descriptor
The collection of fields representing this descriptor

Class javax.management.modelmbean.InvalidTargetObjectTypeException extends Exception implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an InvalidTargetObjectTypeException from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes an InvalidTargetObjectTypeException to an ObjectOutputStream.

Serialized Fields

exception

Exception exception
Encapsulated {@link Exception}

Class javax.management.modelmbean.ModelMBeanAttributeInfo extends MBeanAttributeInfo implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a ModelMBeanAttributeInfo from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a ModelMBeanAttributeInfo to an ObjectOutputStream.

Serialized Fields

attrDescriptor

Descriptor attrDescriptor
The {@link Descriptor} containing the metadata corresponding to this attribute

Class javax.management.modelmbean.ModelMBeanConstructorInfo extends MBeanConstructorInfo implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a ModelMBeanConstructorInfo from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a ModelMBeanConstructorInfo to an ObjectOutputStream.

Serialized Fields

consDescriptor

Descriptor consDescriptor
The {@link Descriptor} containing the metadata for this instance

Class javax.management.modelmbean.ModelMBeanInfoSupport extends MBeanInfo implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a ModelMBeanInfoSupport from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a ModelMBeanInfoSupport to an ObjectOutputStream.

Serialized Fields

modelMBeanAttributes

ModelMBeanAttributeInfo[] modelMBeanAttributes
The array of {@link ModelMBeanAttributeInfo} objects which have descriptors

modelMBeanConstructors

MBeanConstructorInfo[] modelMBeanConstructors
The array of {@link ModelMBeanConstructorInfo} objects which have descriptors

modelMBeanDescriptor

Descriptor modelMBeanDescriptor
The descriptor containing MBean wide policy

modelMBeanNotifications

MBeanNotificationInfo[] modelMBeanNotifications
The array of {@link ModelMBeanNotificationInfo} objects which have descriptors

modelMBeanOperations

MBeanOperationInfo[] modelMBeanOperations
The array of {@link ModelMBeanOperationInfo} objects which have descriptors

Class javax.management.modelmbean.ModelMBeanNotificationInfo extends MBeanNotificationInfo implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a ModelMBeanNotificationInfo from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a ModelMBeanNotificationInfo to an ObjectOutputStream.

Serialized Fields

notificationDescriptor

Descriptor notificationDescriptor
The descriptor containing the appropriate metadata for this instance

Class javax.management.modelmbean.ModelMBeanOperationInfo extends MBeanOperationInfo implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a ModelMBeanOperationInfo from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a ModelMBeanOperationInfo to an ObjectOutputStream.

Serialized Fields

operationDescriptor

Descriptor operationDescriptor
The descriptor containing the appropriate metadata for this instance

Class javax.management.modelmbean.XMLParseException extends Exception implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an XMLParseException from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes an XMLParseException to an ObjectOutputStream.

Serialized Fields

Package javax.management.openmbean

Class javax.management.openmbean.ArrayType extends OpenType implements Serializable

serialVersionUID: 720504429830309770l

Serialized Fields

dimension

int dimension
The dimension of arrays described by this ArrayType instance

elementType

OpenType elementType
The open type of element values contained in the arrays described by this ArrayType instance

Class javax.management.openmbean.CompositeDataSupport extends Object implements Serializable

serialVersionUID: 8003518976613702244l

Serialized Fields

contents

SortedMap contents
Internal representation of the mapping of item names to their respective values. A SortedMap is used for faster retrieval of elements.

compositeType

CompositeType compositeType
The composite type of this composite data instance.

Class javax.management.openmbean.CompositeType extends OpenType implements Serializable

serialVersionUID: -5366242454346948798l

Serialized Fields

nameToDescription

TreeMap nameToDescription
Sorted mapping of the item names to their descriptions

nameToType

TreeMap nameToType
Sorted mapping of the item names to their open types

Class javax.management.openmbean.InvalidKeyException extends IllegalArgumentException implements Serializable

serialVersionUID: 4224269443946322062l

Class javax.management.openmbean.InvalidOpenTypeException extends IllegalArgumentException implements Serializable

serialVersionUID: -2837312755412327534l

Class javax.management.openmbean.KeyAlreadyExistsException extends IllegalArgumentException implements Serializable

serialVersionUID: 1845183636745282866l

Class javax.management.openmbean.OpenDataException extends JMException implements Serializable

serialVersionUID: 8346311255433349870l

Class javax.management.openmbean.OpenMBeanAttributeInfoSupport extends MBeanAttributeInfo implements Serializable

serialVersionUID: -4867215622149721849l

Serialized Fields

openType

OpenType openType
The open mbean attribute's open type

defaultValue

Object defaultValue
The open mbean attribute's default value

legalValues

Set legalValues
The open mbean attribute's legal values. This Set is unmodifiable

minValue

Comparable minValue
The open mbean attribute's min value

maxValue

Comparable maxValue
The open mbean attribute's max value

Class javax.management.openmbean.OpenMBeanConstructorInfoSupport extends MBeanConstructorInfo implements Serializable

serialVersionUID: -4400441579007477003l

Class javax.management.openmbean.OpenMBeanInfoSupport extends MBeanInfo implements Serializable

serialVersionUID: 4349395935420511492l

Class javax.management.openmbean.OpenMBeanOperationInfoSupport extends MBeanOperationInfo implements Serializable

serialVersionUID: 4996859732565369366l

Serialized Fields

returnOpenType

OpenType returnOpenType
The open type of the values returned by the operation described by this OpenMBeanOperationInfo instance

Class javax.management.openmbean.OpenMBeanParameterInfoSupport extends MBeanParameterInfo implements Serializable

serialVersionUID: -7235016873758443122l

Serialized Fields

openType

OpenType openType
The open mbean parameter's open type

defaultValue

Object defaultValue
The open mbean parameter's default value

legalValues

Set legalValues
The open mbean parameter's legal values. This Set is unmodifiable

minValue

Comparable minValue
The open mbean parameter's min value

maxValue

Comparable maxValue
The open mbean parameter's max value

Class javax.management.openmbean.OpenType extends Object implements Serializable

serialVersionUID: -9195195325186646468l

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an OpenType from an ObjectInputStream.

Serialized Fields

className

String className
The fully qualified Java class name of open data values this type describes.

description

String description
The type description (should not be null or empty).

typeName

String typeName
The name given to this type (should not be null or empty).

Class javax.management.openmbean.SimpleType extends OpenType implements Serializable

serialVersionUID: 2215577471957694503l

Serialization Methods

readResolve

public Object readResolve()
                   throws ObjectStreamException
Replace an object read from an ObjectInputStream with the unique instance for that value.

Throws:
ObjectStreamException - if the read object cannot be resolved.

Class javax.management.openmbean.TabularDataSupport extends Object implements Serializable

serialVersionUID: 5720150593236309827l

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a TabularDataSupport from an ObjectInputStream.

Serialized Fields

dataMap

Map dataMap
This tabular data instance's contents: a HashMap

tabularType

TabularType tabularType
This tabular data instance's tabular type

Class javax.management.openmbean.TabularType extends OpenType implements Serializable

serialVersionUID: 6554071860220659261l

Serialized Fields

rowType

CompositeType rowType
The composite type of rows

indexNames

List indexNames
The items used to index each row element, kept in the order the user gave This is an unmodifiable ArrayList

Package javax.management.relation

Class javax.management.relation.InvalidRelationIdException extends RelationException implements Serializable

serialVersionUID: -7115040321202754171l

Class javax.management.relation.InvalidRelationServiceException extends RelationException implements Serializable

serialVersionUID: 3400722103759507559l

Class javax.management.relation.InvalidRelationTypeException extends RelationException implements Serializable

serialVersionUID: 3007446608299169961l

Class javax.management.relation.InvalidRoleInfoException extends RelationException implements Serializable

serialVersionUID: 7517834705158932074l

Class javax.management.relation.InvalidRoleValueException extends RelationException implements Serializable

serialVersionUID: -2066091747301983721l

Class javax.management.relation.MBeanServerNotificationFilter extends NotificationFilterSupport implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes an MBeanServerNotificationFilter from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes an MBeanServerNotificationFilter to an ObjectOutputStream.

Serialized Fields

deselectedNames

List deselectedNames
List of {@link ObjectName}s with no interest
  • null means that all {@link ObjectName}s are implictly deselected (check for explicit selections))
  • Empty vector means that no {@link ObjectName} is explicitly deselected

selectedNames

List selectedNames
List of {@link ObjectName}s of interest
  • null means that all {@link ObjectName}s are implictly selected (check for explicit deselections)
  • Empty vector means that no {@link ObjectName} is explicitly selected

Class javax.management.relation.RelationException extends JMException implements Serializable

serialVersionUID: 5434016005679159613l

Class javax.management.relation.RelationNotFoundException extends RelationException implements Serializable

serialVersionUID: -3793951411158559116l

Class javax.management.relation.RelationNotification extends Notification implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a RelationNotification from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a RelationNotification to an ObjectOutputStream.

Serialized Fields

newRoleValue

List newRoleValue
New role value ({@link ArrayList} of {@link ObjectName}s) (only for role update)

oldRoleValue

List oldRoleValue
Old role value ({@link ArrayList} of {@link ObjectName}s) (only for role update)

relationId

String relationId
Relation identifier of created/removed/updated relation

relationObjName

ObjectName relationObjName
{@link ObjectName} of the relation MBean of created/removed/updated relation (only if the relation is represented by an MBean)

relationTypeName

String relationTypeName
Relation type name of created/removed/updated relation

roleName

String roleName
Name of updated role (only for role update)

unregisterMBeanList

List unregisterMBeanList
List of {@link ObjectName}s of referenced MBeans to be unregistered due to relation removal

Class javax.management.relation.RelationServiceNotRegisteredException extends RelationException implements Serializable

serialVersionUID: 8454744887157122910l

Class javax.management.relation.RelationTypeNotFoundException extends RelationException implements Serializable

serialVersionUID: 1274155316284300752l

Class javax.management.relation.RelationTypeSupport extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a RelationTypeSupport from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a RelationTypeSupport to an ObjectOutputStream.

Serialized Fields

isInRelationService

boolean isInRelationService
Flag specifying whether the relation type has been declared in the Relation Service (so can no longer be updated)

roleName2InfoMap

Map roleName2InfoMap
{@link Map} holding the mapping: <role name ({@link String})> -> <role info ({@link RoleInfo} object)>

typeName

String typeName
Relation type name

Class javax.management.relation.Role extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a Role from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a Role to an ObjectOutputStream.

Serialized Fields

name

String name
Role name

objectNameList

List objectNameList
{@link List} of {@link ObjectName}s of referenced MBeans

Class javax.management.relation.RoleInfo extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a RoleInfo from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a RoleInfo to an ObjectOutputStream.

Serialized Fields

description

String description
Role description

isReadable

boolean isReadable
Read access mode: true if role is readable

isWritable

boolean isWritable
Write access mode: true if role is writable

maxDegree

int maxDegree
Maximum degree (i.e. maximum number of referenced MBeans in corresponding role)

minDegree

int minDegree
Minimum degree (i.e. minimum number of referenced MBeans in corresponding role)

name

String name
Role name

referencedMBeanClassName

String referencedMBeanClassName
Name of class of MBean(s) expected to be referenced in corresponding role

Class javax.management.relation.RoleInfoNotFoundException extends RelationException implements Serializable

serialVersionUID: 4394092234999959939l

Class javax.management.relation.RoleList extends ArrayList implements Serializable

serialVersionUID: 5568344346499649313l

Class javax.management.relation.RoleNotFoundException extends RelationException implements Serializable

serialVersionUID: -2986406101364031481l

Class javax.management.relation.RoleResult extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a RoleResult from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a RoleResult to an ObjectOutputStream.

Serialized Fields

roleList

RoleList roleList
List of roles successfully accessed

unresolvedRoleList

RoleUnresolvedList unresolvedRoleList
List of roles unsuccessfully accessed

Class javax.management.relation.RoleUnresolved extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a RoleUnresolved from an ObjectInputStream.

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a RoleUnresolved to an ObjectOutputStream.

Serialized Fields

problemType

int problemType
Problem type

roleName

String roleName
Role name

roleValue

List roleValue
Role value ({@link List} of {@link ObjectName} objects)

Class javax.management.relation.RoleUnresolvedList extends ArrayList implements Serializable

serialVersionUID: 4054902803091433324l

Package javax.management.timer

Class javax.management.timer.TimerAlarmClockNotification extends Notification implements Serializable

serialVersionUID: -4841061275673620641l

Class javax.management.timer.TimerNotification extends Notification implements Serializable

serialVersionUID: 1798492029603825750l

Serialized Fields

notificationID

Integer notificationID
Timer notification identifier. This identifier is used to retreive a timer notification from the timer list of notifications.

Package javax.xml.parsers

Class javax.xml.parsers.FactoryConfigurationError extends Error implements Serializable

Serialized Fields

exception

Exception exception

Class javax.xml.parsers.ParserConfigurationException extends Exception implements Serializable

Package javax.xml.transform

Class javax.xml.transform.TransformerConfigurationException extends TransformerException implements Serializable

Class javax.xml.transform.TransformerException extends Exception implements Serializable

Serialized Fields

locator

SourceLocator locator
Field locator specifies where the error occured

containedException

Throwable containedException
Field containedException specifies a wrapped exception. May be null.

Class javax.xml.transform.TransformerFactoryConfigurationError extends Error implements Serializable

Serialized Fields

exception

Exception exception

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


activation

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.activation

The JavaBeans(TM) Activation Framework is used by the JavaMail(TM) API to manage MIME data.

See:
Description

Interface Summary
CommandObject | JavaBeans components that are Activation Framework aware implement this interface to find out which command verb they're being asked to perform, and to obtain the DataHandler representing the data they should operate on.
DataContentHandler | The DataContentHandler interface is implemented by objects that can be used to extend the capabilities of the DataHandler's implementation of the Transferable interface.
DataContentHandlerFactory | This interface defines a factory for DataContentHandlers.
DataSource | The DataSource interface provides the JavaBeans Activation Framework with an abstraction of some arbitrary collection of data.

Class Summary
ActivationDataFlavor | The ActivationDataFlavor class is a special subclass of java.awt.datatransfer.DataFlavor.
CommandInfo | The CommandInfo class is used by CommandMap implementations to describe the results of command requests.
CommandMap | The CommandMap class provides an interface to a registry of command objects available in the system.
DataHandler | The DataHandler class provides a consistent interface to data available in many different sources and formats.
FileDataSource | The FileDataSource class implements a simple DataSource object that encapsulates a file.
FileTypeMap | The FileTypeMap is an abstract class that provides a data typing interface for files.
MailcapCommandMap | MailcapCommandMap extends the CommandMap abstract class.
MimeType | A Multipurpose Internet Mail Extension (MIME) type, as defined in RFC 2045 and 2046.
MimeTypeParameterList | A parameter list of a MimeType as defined in RFC 2045 and 2046.
MimetypesFileTypeMap | This class extends FileTypeMap and provides data typing of files via their file extension.
URLDataSource | The URLDataSource class provides an object that wraps a URL object in a DataSource interface.

Exception Summary
MimeTypeParseException | A class to encapsulate MimeType parsing related exceptions.
UnsupportedDataTypeException | Signals that the requested operation does not support the requested data type.

Package javax.activation Description

The JavaBeans(TM) Activation Framework is used by the JavaMail(TM) API to manage MIME data.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.activation Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.activation

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.activation.CommandInfo
    • class javax.activation.CommandMap
      • class javax.activation.MailcapCommandMap
    • class java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
      • class javax.activation.ActivationDataFlavor
    • class javax.activation.DataHandler (implements java.awt.datatransfer.Transferable)
    • class javax.activation.FileDataSource (implements javax.activation.DataSource)
    • class javax.activation.FileTypeMap
      • class javax.activation.MimetypesFileTypeMap
    • class javax.activation.MimeType (implements java.io.Externalizable)
    • class javax.activation.MimeTypeParameterList
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.io.IOException
          • class javax.activation.UnsupportedDataTypeException
        • class javax.activation.MimeTypeParseException
    • class javax.activation.URLDataSource (implements javax.activation.DataSource)

Interface Hierarchy

  • interface javax.activation.CommandObject
  • interface javax.activation.DataContentHandler
  • interface javax.activation.DataContentHandlerFactory
  • interface javax.activation.DataSource
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ActivationDataFlavor

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class ActivationDataFlavor

java.lang.Object
    extended by java.awt.datatransfer.DataFlavor
        extended by javax.activation.ActivationDataFlavor
All Implemented Interfaces:
Cloneable, Externalizable, Serializable
public class ActivationDataFlavor
extends DataFlavor

The ActivationDataFlavor class is a special subclass of java.awt.datatransfer.DataFlavor. It allows the JAF to set all three values stored by the DataFlavor class via a new constructor. It also contains improved MIME parsing in the equals method. Except for the improved parsing, its semantics are identical to that of the JDK's DataFlavor class.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.awt.datatransfer.DataFlavor
imageFlavor, javaFileListFlavor, javaJVMLocalObjectMimeType, javaRemoteObjectMimeType, javaSerializedObjectMimeType, plainTextFlavor, stringFlavor
Constructor Summary
ActivationDataFlavor(Class representationClass, String humanPresentableName)
Construct a DataFlavor that represents a MimeType.
ActivationDataFlavor(Class representationClass, String mimeType, String humanPresentableName)
Construct a DataFlavor that represents an arbitrary Java object.
ActivationDataFlavor(String mimeType, String humanPresentableName)
Construct a DataFlavor that represents a MimeType.
Method Summary
boolean | equals(DataFlavor dataFlavor) Compares the DataFlavor passed in with this DataFlavor; calls the isMimeTypeEqual method.
String | getHumanPresentableName() Return the Human Presentable name.
String | getMimeType() Return the MIME type for this DataFlavor.
Class | getRepresentationClass() Return the representation class.
boolean | isMimeTypeEqual(String mimeType) Is the string representation of the MIME type passed in equivalent to the MIME type of this DataFlavor.
protected String | normalizeMimeType(String mimeType) Called for each MIME type string to give DataFlavor subtypes the opportunity to change how the normalization of MIME types is accomplished.
protected String | normalizeMimeTypeParameter(String parameterName, String parameterValue) Called on DataFlavor for every MIME Type parameter to allow DataFlavor subclasses to handle special parameters like the text/plain charset parameters, whose values are case insensitive.
void | setHumanPresentableName(String humanPresentableName) Set the human presentable name.
Methods inherited from class java.awt.datatransfer.DataFlavor
clone, equals, equals, getDefaultRepresentationClass, getDefaultRepresentationClassAsString, getParameter, getPrimaryType, getReaderForText, getSubType, getTextPlainUnicodeFlavor, hashCode, isFlavorJavaFileListType, isFlavorRemoteObjectType, isFlavorSerializedObjectType, isFlavorTextType, isMimeTypeEqual, isMimeTypeSerializedObject, isRepresentationClassByteBuffer, isRepresentationClassCharBuffer, isRepresentationClassInputStream, isRepresentationClassReader, isRepresentationClassRemote, isRepresentationClassSerializable, match, readExternal, selectBestTextFlavor, toString, tryToLoadClass, writeExternal
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ActivationDataFlavor

public ActivationDataFlavor(Class representationClass,
                            String mimeType,
                            String humanPresentableName)
Construct a DataFlavor that represents an arbitrary Java object. This constructor is an extension of the JDK's DataFlavor in that it allows the explicit setting of all three DataFlavor attributes.

The returned DataFlavor will have the following characteristics:

representationClass = representationClass
mimeType = mimeType
humanName = humanName

Parameters:
representationClass - the class used in this DataFlavor
mimeType - the MIME type of the data represented by this class
humanPresentableName - the human presentable name of the flavor

ActivationDataFlavor

public ActivationDataFlavor(Class representationClass,
                            String humanPresentableName)
Construct a DataFlavor that represents a MimeType.

The returned DataFlavor will have the following characteristics:

If the mimeType is "application/x-java-serialized-object;
class=", the result is the same as calling new
DataFlavor(Class.forName()) as above.

otherwise:

representationClass = InputStream

mimeType = mimeType

Parameters:
representationClass - the class used in this DataFlavor
humanPresentableName - the human presentable name of the flavor

ActivationDataFlavor

public ActivationDataFlavor(String mimeType,
                            String humanPresentableName)
Construct a DataFlavor that represents a MimeType.

The returned DataFlavor will have the following characteristics:

If the mimeType is "application/x-java-serialized-object; class=", the result is the same as calling new DataFlavor(Class.forName()) as above, otherwise:

representationClass = InputStream

mimeType = mimeType

Parameters:
mimeType - the MIME type of the data represented by this class
humanPresentableName - the human presentable name of the flavor
Method Detail

getMimeType

public String getMimeType()
Return the MIME type for this DataFlavor.

Returns:
the MIME type

getRepresentationClass

public Class getRepresentationClass()
Return the representation class.

Returns:
the representation class

getHumanPresentableName

public String getHumanPresentableName()
Return the Human Presentable name.

Returns:
the human presentable name

setHumanPresentableName

public void setHumanPresentableName(String humanPresentableName)
Set the human presentable name.

Parameters:
humanPresentableName - the name to set

equals

public boolean equals(DataFlavor dataFlavor)
Compares the DataFlavor passed in with this DataFlavor; calls the isMimeTypeEqual method.

Parameters:
dataFlavor - the DataFlavor to compare with
Returns:
true if the MIME type and representation class are the same

isMimeTypeEqual

public boolean isMimeTypeEqual(String mimeType)
Is the string representation of the MIME type passed in equivalent to the MIME type of this DataFlavor.

ActivationDataFlavor delegates the comparison of MIME types to the MimeType class included as part of the JavaBeans Activation Framework. This provides a more robust comparison than is normally available in the DataFlavor class.

Parameters:
mimeType - the MIME type
Returns:
true if the same MIME type

normalizeMimeTypeParameter

protected String normalizeMimeTypeParameter(String parameterName,
                                            String parameterValue)
Called on DataFlavor for every MIME Type parameter to allow DataFlavor subclasses to handle special parameters like the text/plain charset parameters, whose values are case insensitive. (MIME type parameter values are supposed to be case sensitive).

This method is called for each parameter name/value pair and should return the normalized representation of the parameterValue.

Parameters:
parameterName - the parameter name
parameterValue - the parameter value
Returns:
the normalized parameter value

normalizeMimeType

protected String normalizeMimeType(String mimeType)
Called for each MIME type string to give DataFlavor subtypes the opportunity to change how the normalization of MIME types is accomplished. One possible use would be to add default parameter/value pairs in cases where none are present in the MIME type string passed in.

Parameters:
mimeType - the MIME type
Returns:
the normalized MIME type
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CommandInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class CommandInfo

java.lang.Object
    extended by javax.activation.CommandInfo
public class CommandInfo
extends Object

The CommandInfo class is used by CommandMap implementations to describe the results of command requests. It provides the requestor with both the verb requested, as well as an instance of the bean. There is also a method that will return the name of the class that implements the command but it is not guaranteed to return a valid value. The reason for this is to allow CommandMap implmentations that subclass CommandInfo to provide special behavior. For example a CommandMap could dynamically generate JavaBeans. In this case, it might not be possible to create an object with all the correct state information solely from the class name.

Constructor Summary
CommandInfo(String verb, String className)
The Constructor for CommandInfo.
Method Summary
String | getCommandClass() Return the command's class name.
String | getCommandName() Return the command verb.
Object | getCommandObject(DataHandler dh, ClassLoader loader) Return the instantiated JavaBean component.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommandInfo

public CommandInfo(String verb,
                   String className)
The Constructor for CommandInfo.

Parameters:
verb - The command verb this CommandInfo decribes.
className - The command's fully qualified class name.
Method Detail

getCommandName

public String getCommandName()
Return the command verb.

Returns:
the command verb.

getCommandClass

public String getCommandClass()
Return the command's class name. This method MAY return null in cases where a CommandMap subclassed CommandInfo for its own purposes. In other words, it might not be possible to create the correct state in the command by merely knowing its class name. DO NOT DEPEND ON THIS METHOD RETURNING A VALID VALUE!

Returns:
The class name of the command, or null

getCommandObject

public Object getCommandObject(DataHandler dh,
                               ClassLoader loader)
                        throws IOException,
                               ClassNotFoundException
Return the instantiated JavaBean component.

Begin by instantiating the component with Beans.instantiate().

If the bean implements the javax.activation.CommandObject interface, call its setCommandContext method.

If the DataHandler parameter is null, then the bean is instantiated with no data. NOTE: this may be useful if for some reason the DataHandler that is passed in throws IOExceptions when this method attempts to access its InputStream. It will allow the caller to retrieve a reference to the bean if it can be instantiated.

If the bean does NOT implement the CommandObject interface, this method will check if it implements the java.io.Externalizable interface. If it does, the bean's readExternal method will be called if an InputStream can be acquired from the DataHandler.

Parameters:
dh - The DataHandler that describes the data to be passed to the command.
loader - The ClassLoader to be used to instantiate the bean.
Returns:
The bean
Throws:
IOException
ClassNotFoundException
See Also:
Beans.instantiate(java.lang.ClassLoader, java.lang.String), CommandObject
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CommandMap

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class CommandMap

java.lang.Object
    extended by javax.activation.CommandMap
Direct Known Subclasses:
MailcapCommandMap
public abstract class CommandMap
extends Object

The CommandMap class provides an interface to a registry of command objects available in the system. Developers are expected to either use the CommandMap implementation included with this package (MailcapCommandMap) or develop their own. Note that some of the methods in this class are abstract.

Constructor Summary
CommandMap()
Method Summary
abstract DataContentHandler | createDataContentHandler(String mimeType) Locate a DataContentHandler that corresponds to the MIME type.
abstract CommandInfo[] | getAllCommands(String mimeType) Get all the available commands for this type.
abstract CommandInfo | getCommand(String mimeType, String cmdName) Get the default command corresponding to the MIME type.
static CommandMap | getDefaultCommandMap() Get the default CommandMap.
abstract CommandInfo[] | getPreferredCommands(String mimeType) Get the preferred command list from a MIME Type.
static void | setDefaultCommandMap(CommandMap commandMap) Set the default CommandMap.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommandMap

public CommandMap()
Method Detail

getDefaultCommandMap

public static CommandMap getDefaultCommandMap()
Get the default CommandMap.

  • In cases where a CommandMap instance has been previously set to some value (via setDefaultCommandMap) return the CommandMap.
  • In cases where no CommandMap has been set, the CommandMap creates an instance of MailcapCommandMap and set that to the default, returning its value.

Returns:
the CommandMap

setDefaultCommandMap

public static void setDefaultCommandMap(CommandMap commandMap)
Set the default CommandMap. Reset the CommandMap to the default by calling this method with null.

Parameters:
commandMap - The new default CommandMap.
Throws:
SecurityException - if the caller doesn't have permission to change the default

getPreferredCommands

public abstract CommandInfo[] getPreferredCommands(String mimeType)
Get the preferred command list from a MIME Type. The actual semantics are determined by the implementation of the CommandMap.

Parameters:
mimeType - the MIME type
Returns:
the CommandInfo classes that represent the command Beans.

getAllCommands

public abstract CommandInfo[] getAllCommands(String mimeType)
Get all the available commands for this type. This method should return all the possible commands for this MIME type.

Parameters:
mimeType - the MIME type
Returns:
the CommandInfo objects representing all the commands.

getCommand

public abstract CommandInfo getCommand(String mimeType,
                                       String cmdName)
Get the default command corresponding to the MIME type.

Parameters:
mimeType - the MIME type
cmdName - the command name
Returns:
the CommandInfo corresponding to the command.

createDataContentHandler

public abstract DataContentHandler createDataContentHandler(String mimeType)
Locate a DataContentHandler that corresponds to the MIME type. The mechanism and semantics for determining this are determined by the implementation of the particular CommandMap.

Parameters:
mimeType - the MIME type
Returns:
the DataContentHandler for the MIME type
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CommandObject

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.activation
Interface CommandObject

public interface CommandObject

JavaBeans components that are Activation Framework aware implement this interface to find out which command verb they're being asked to perform, and to obtain the DataHandler representing the data they should operate on. JavaBeans that don't implement this interface may be used as well. Such commands may obtain the data using the Externalizable interface, or using an application-specific method.

Method Summary
 void setCommandContext(String verb, DataHandler dh)
Initialize the Command with the verb it is requested to handle and the DataHandler that describes the data it will operate on.

Method Detail

setCommandContext

public void setCommandContext(String verb,
                              DataHandler dh)
                       throws IOException
Initialize the Command with the verb it is requested to handle and the DataHandler that describes the data it will operate on. NOTE: it is acceptable for the caller to pass null as the value for DataHandler.

Parameters:
verb - The Command Verb this object refers to.
dh - The DataHandler.
Throws:
IOException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DataContentHandler

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Interface DataContentHandler

public interface DataContentHandler

The DataContentHandler interface is implemented by objects that can be used to extend the capabilities of the DataHandler's implementation of the Transferable interface. Through DataContentHandlers the framework can be extended to convert streams in to objects, and to write objects to streams.

Applications don't generally call the methods in DataContentHandlers directly. Instead, an application calls the equivalent methods in DataHandler. The DataHandler will attempt to find an appropriate DataContentHandler that corresponds to its MIME type using the current DataContentHandlerFactory. The DataHandler then calls through to the methods in the DataContentHandler.

Method Summary
Object | getContent(DataSource ds) Return an object representing the data in its most preferred form.
Object | getTransferData(DataFlavor df, DataSource ds) Returns an object which represents the data to be transferred.
DataFlavor[] | getTransferDataFlavors() Returns an array of DataFlavor objects indicating the flavors the data can be provided in.
void | writeTo(Object obj, String mimeType, OutputStream os) Convert the object to a byte stream of the specified MIME type and write it to the output stream.

Method Detail

getTransferDataFlavors

public DataFlavor[] getTransferDataFlavors()
Returns an array of DataFlavor objects indicating the flavors the data can be provided in. The array should be ordered according to preference for providing the data (from most richly descriptive to least descriptive).

Returns:
The DataFlavors.

getTransferData

public Object getTransferData(DataFlavor df,
                              DataSource ds)
                       throws UnsupportedFlavorException,
                              IOException
Returns an object which represents the data to be transferred. The class of the object returned is defined by the representation class of the flavor.

Parameters:
df - The DataFlavor representing the requested type.
ds - The DataSource representing the data to be converted.
Returns:
The constructed Object.
Throws:
UnsupportedFlavorException
IOException

getContent

public Object getContent(DataSource ds)
                  throws IOException
Return an object representing the data in its most preferred form. Generally this will be the form described by the first DataFlavor returned by the getTransferDataFlavors method.

Parameters:
ds - The DataSource representing the data to be converted.
Returns:
The constructed Object.
Throws:
IOException

writeTo

public void writeTo(Object obj,
                    String mimeType,
                    OutputStream os)
             throws IOException
Convert the object to a byte stream of the specified MIME type and write it to the output stream.

Parameters:
obj - The object to be converted.
mimeType - The requested MIME type of the resulting byte stream.
os - The output stream into which to write the converted byte stream.
Throws:
IOException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DataContentHandlerFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Interface DataContentHandlerFactory

public interface DataContentHandlerFactory

This interface defines a factory for DataContentHandlers. An implementation of this interface should map a MIME type into an instance of DataContentHandler. The design pattern for classes implementing this interface is the same as for the ContentHandler mechanism used in java.net.URL.

Method Summary
 DataContentHandler createDataContentHandler(String mimeType)
Creates a new DataContentHandler object for the MIME type.

Method Detail

createDataContentHandler

public DataContentHandler createDataContentHandler(String mimeType)
Creates a new DataContentHandler object for the MIME type.

Parameters:
mimeType - the MIME type to create the DataContentHandler for.
Returns:
The new DataContentHandler, or null if none are found.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DataHandler

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class DataHandler

java.lang.Object
    extended by javax.activation.DataHandler
All Implemented Interfaces:
Transferable
public class DataHandler
extends Object
implements Transferable

The DataHandler class provides a consistent interface to data available in many different sources and formats. It manages simple stream to string conversions and related operations using DataContentHandlers. It provides access to commands that can operate on the data. The commands are found using a CommandMap.

DataHandler and the Transferable Interface

DataHandler implements the Transferable interface so that data can be used in AWT data transfer operations, such as cut and paste and drag and drop. The implementation of the Transferable interface relies on the availability of an installed DataContentHandler object corresponding to the MIME type of the data represented in the specific instance of the DataHandler.

DataHandler and CommandMaps

The DataHandler keeps track of the current CommandMap that it uses to service requests for commands (getCommand, getAllCommands, getPreferredCommands). Each instance of a DataHandler may have a CommandMap associated with it using the setCommandMap method. If a CommandMap was not set, DataHandler calls the getDefaultCommandMap method in CommandMap and uses the value it returns. See CommandMap for more information.

DataHandler and URLs

The current DataHandler implementation creates a private instance of URLDataSource when it is constructed with a URL.

See Also:
CommandMap, DataContentHandler, DataSource, URLDataSource

Constructor Summary
DataHandler(DataSource ds)
Create a DataHandler instance referencing the specified DataSource.
DataHandler(Object obj, String mimeType)
Create a DataHandler instance representing an object of this MIME type.
DataHandler(URL url)
Create a DataHandler instance referencing a URL.
Method Summary
CommandInfo[] | getAllCommands() Return all the commands for this type of data.
Object | getBean(CommandInfo cmdinfo) A convenience method that takes a CommandInfo object and instantiates the corresponding command, usually a JavaBean component.
CommandInfo | getCommand(String cmdName) Get the command cmdName.
Object | getContent() Return the data in its preferred Object form.
String | getContentType() Return the MIME type of this object as retrieved from the source object.
DataSource | getDataSource() Return the DataSource associated with this instance of DataHandler.
InputStream | getInputStream() Get the InputStream for this object.
String | getName() Return the name of the data object.
OutputStream | getOutputStream() Get an OutputStream for this DataHandler to allow overwriting the underlying data.
CommandInfo[] | getPreferredCommands() Return the preferred commands for this type of data.
Object | getTransferData(DataFlavor flavor) Returns an object that represents the data to be transferred.
DataFlavor[] | getTransferDataFlavors() Return the DataFlavors in which this data is available.
boolean | isDataFlavorSupported(DataFlavor flavor) Returns whether the specified data flavor is supported for this object.
void | setCommandMap(CommandMap commandMap) Set the CommandMap for use by this DataHandler.
static void | setDataContentHandlerFactory(DataContentHandlerFactory newFactory) Sets the DataContentHandlerFactory.
void | writeTo(OutputStream os) Write the data to an OutputStream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataHandler

public DataHandler(DataSource ds)
Create a DataHandler instance referencing the specified DataSource. The data exists in a byte stream form. The DataSource will provide an InputStream to access the data.

Parameters:
ds - the DataSource

DataHandler

public DataHandler(Object obj,
                   String mimeType)
Create a DataHandler instance representing an object of this MIME type. This constructor is used when the application already has an in-memory representation of the data in the form of a Java Object.

Parameters:
obj - the Java Object
mimeType - the MIME type of the object

DataHandler

public DataHandler(URL url)
Create a DataHandler instance referencing a URL. The DataHandler internally creates a URLDataSource instance to represent the URL.

Parameters:
url - a URL object
Method Detail

getDataSource

public DataSource getDataSource()
Return the DataSource associated with this instance of DataHandler.

For DataHandlers that have been instantiated with a DataSource, this method returns the DataSource that was used to create the DataHandler object. In other cases the DataHandler constructs a DataSource from the data used to construct the DataHandler. DataSources created for DataHandlers not instantiated with a DataSource are cached for performance reasons.

Returns:
a valid DataSource object for this DataHandler

getName

public String getName()
Return the name of the data object. If this DataHandler was created with a DataSource, this method calls through to the DataSource.getName method, otherwise it returns null.

Returns:
the name of the object

getContentType

public String getContentType()
Return the MIME type of this object as retrieved from the source object. Note that this is the full type with parameters.

Returns:
the MIME type

getInputStream

public InputStream getInputStream()
                           throws IOException
Get the InputStream for this object.

For DataHandlers instantiated with a DataSource, the DataHandler calls the DataSource.getInputStream method and returns the result to the caller.

For DataHandlers instantiated with an Object, the DataHandler first attempts to find a DataContentHandler for the Object. If the DataHandler can not find a DataContentHandler for this MIME type, it throws an UnsupportedDataTypeException. If it is successful, it creates a pipe and a thread. The thread uses the DataContentHandler's writeTo method to write the stream data into one end of the pipe. The other end of the pipe is returned to the caller. Because a thread is created to copy the data, IOExceptions that may occur during the copy can not be propagated back to the caller. The result is an empty stream.

Returns:
the InputStream representing this data
Throws:
IOException - if an I/O error occurs
See Also:
DataContentHandler.writeTo(java.lang.Object, java.lang.String, java.io.OutputStream), UnsupportedDataTypeException

writeTo

public void writeTo(OutputStream os)
             throws IOException
Write the data to an OutputStream.

If the DataHandler was created with a DataSource, writeTo retrieves the InputStream and copies the bytes from the InputStream to the OutputStream passed in.

If the DataHandler was created with an object, writeTo retrieves the DataContentHandler for the object's type. If the DataContentHandler was found, it calls the writeTo method on the DataContentHandler.

Parameters:
os - the OutputStream to write to
Throws:
IOException - if an I/O error occurs

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
Get an OutputStream for this DataHandler to allow overwriting the underlying data. If the DataHandler was created with a DataSource, the DataSource's getOutputStream method is called. Otherwise, null is returned.

Returns:
the OutputStream
Throws:
IOException
See Also:
DataSource.getOutputStream(), URLDataSource

getTransferDataFlavors

public DataFlavor[] getTransferDataFlavors()
Return the DataFlavors in which this data is available.

Returns an array of DataFlavor objects indicating the flavors the data can be provided in. The array is usually ordered according to preference for providing the data, from most richly descriptive to least richly descriptive.

The DataHandler attempts to find a DataContentHandler that corresponds to the MIME type of the data. If one is located, the DataHandler calls the DataContentHandler's getTransferDataFlavors method.

If a DataContentHandler can not be located, and if the DataHandler was created with a DataSource (or URL), one DataFlavor is returned that represents this object's MIME type and the java.io.InputStream class. If the DataHandler was created with an object and a MIME type, getTransferDataFlavors returns one DataFlavor that represents this object's MIME type and the object's class.

Specified by:
getTransferDataFlavors in interface Transferable
Returns:
an array of data flavors in which this data can be transferred
See Also:
DataContentHandler.getTransferDataFlavors()

isDataFlavorSupported

public boolean isDataFlavorSupported(DataFlavor flavor)
Returns whether the specified data flavor is supported for this object.

This method iterates through the DataFlavors returned from getTransferDataFlavors, comparing each with the specified flavor.

Specified by:
isDataFlavorSupported in interface Transferable
Parameters:
flavor - the requested flavor for the data
Returns:
true if the data flavor is supported
See Also:
getTransferDataFlavors()

getTransferData

public Object getTransferData(DataFlavor flavor)
                       throws UnsupportedFlavorException,
                              IOException
Returns an object that represents the data to be transferred. The class of the object returned is defined by the representation class of the data flavor.

For DataHandler's created with DataSources or URLs:

The DataHandler attempts to locate a DataContentHandler for this MIME type. If one is found, the passed in DataFlavor and the type of the data are passed to its getTransferData method. If the DataHandler fails to locate a DataContentHandler and the flavor specifies this object's MIME type and the java.io.InputStream class, this object's InputStream is returned. Otherwise it throws an UnsupportedFlavorException.

For DataHandler's created with Objects:

The DataHandler attempts to locate a DataContentHandler for this MIME type. If one is found, the passed in DataFlavor and the type of the data are passed to its getTransferData method. If the DataHandler fails to locate a DataContentHandler and the flavor specifies this object's MIME type and its class, this DataHandler's referenced object is returned. Otherwise it throws an UnsupportedFlavorException.

Specified by:
getTransferData in interface Transferable
Parameters:
flavor - the requested flavor for the data
Returns:
the object
Throws:
UnsupportedFlavorException - if the data could not be converted to the requested flavor
IOException - if an I/O error occurs
See Also:
ActivationDataFlavor

setCommandMap

public void setCommandMap(CommandMap commandMap)
Set the CommandMap for use by this DataHandler. Setting it to null causes the CommandMap to revert to the CommandMap returned by the CommandMap.getDefaultCommandMap method. Changing the CommandMap, or setting it to null, clears out any data cached from the previous CommandMap.

Parameters:
commandMap - the CommandMap to use in this DataHandler
See Also:
CommandMap.setDefaultCommandMap(javax.activation.CommandMap)

getPreferredCommands

public CommandInfo[] getPreferredCommands()
Return the preferred commands for this type of data. This method calls the getPreferredCommands method in the CommandMap associated with this instance of DataHandler. This method returns an array that represents a subset of available commands. In cases where multiple commands for the MIME type represented by this DataHandler are present, the installed CommandMap chooses the appropriate commands.

Returns:
the CommandInfo objects representing the preferred commands
See Also:
CommandMap.getPreferredCommands(java.lang.String)

getAllCommands

public CommandInfo[] getAllCommands()
Return all the commands for this type of data. This method returns an array containing all commands for the type of data represented by this DataHandler. The MIME type for the underlying data represented by this DataHandler is used to call through to the getAllCommands method of the CommandMap associated with this DataHandler.

Returns:
the CommandInfo objects representing all the commands
See Also:
CommandMap.getAllCommands(java.lang.String)

getCommand

public CommandInfo getCommand(String cmdName)
Get the command cmdName. Use the search semantics as defined by the CommandMap installed in this DataHandler. The MIME type for the underlying data represented by this DataHandler is used to call through to the getCommand method of the CommandMap associated with this DataHandler.

Parameters:
cmdName - the command name
Returns:
the CommandInfo corresponding to the command
See Also:
CommandMap.getCommand(java.lang.String, java.lang.String)

getContent

public Object getContent()
                  throws IOException
Return the data in its preferred Object form.

If the DataHandler was instantiated with an object, return the object.

If the DataHandler was instantiated with a DataSource, this method uses a DataContentHandler to return the content object for the data represented by this DataHandler. If no DataContentHandler can be found for the the type of this data, the DataHandler returns an InputStream for the data.

Returns:
the content.
Throws:
IOException - if an IOException occurs during this operation.

getBean

public Object getBean(CommandInfo cmdinfo)
A convenience method that takes a CommandInfo object and instantiates the corresponding command, usually a JavaBean component.

This method calls the CommandInfo's getCommandObject method with the ClassLoader used to load the javax.activation.DataHandler class itself.

Parameters:
cmdinfo - the CommandInfo corresponding to a command
Returns:
the instantiated command object

setDataContentHandlerFactory

public static void setDataContentHandlerFactory(DataContentHandlerFactory newFactory)
Sets the DataContentHandlerFactory. The DataContentHandlerFactory is called first to find DataContentHandlers. The DataContentHandlerFactory can only be set once.

If the DataContentHandlerFactory has already been set, this method throws an Error.

Throws:
Error - if the factory has already been defined.
See Also:
DataContentHandlerFactory
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DataSource

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.activation
Interface DataSource

All Known Subinterfaces:
MultipartDataSource
All Known Implementing Classes:
FileDataSource, MimePartDataSource, URLDataSource
public interface DataSource

The DataSource interface provides the JavaBeans Activation Framework with an abstraction of some arbitrary collection of data. It provides a type for that data as well as access to it in the form of InputStreams and OutputStreams where appropriate.

Method Summary
String | getContentType() This method returns the MIME type of the data in the form of a string.
InputStream | getInputStream() This method returns an InputStream representing the data and throws the appropriate exception if it can not do so.
String | getName() Return the name of this object where the name of the object is dependant on the nature of the underlying objects.
OutputStream | getOutputStream() This method returns an OutputStream where the data can be written and throws the appropriate exception if it can not do so.

Method Detail

getInputStream

public InputStream getInputStream()
                           throws IOException
This method returns an InputStream representing the data and throws the appropriate exception if it can not do so. Note that a new InputStream object must be returned each time this method is called, and the stream must be positioned at the beginning of the data.

Returns:
an InputStream
Throws:
IOException

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
This method returns an OutputStream where the data can be written and throws the appropriate exception if it can not do so. Note that a new OutputStream object must be returned each time this method is called, and the stream must be positioned at the location the data is to be written.

Returns:
an OutputStream
Throws:
IOException

getContentType

public String getContentType()
This method returns the MIME type of the data in the form of a string. It should always return a valid type. It is suggested that getContentType return "application/octet-stream" if the DataSource implementation can not determine the data type.

Returns:
the MIME Type

getName

public String getName()
Return the name of this object where the name of the object is dependant on the nature of the underlying objects. DataSources encapsulating files may choose to return the filename of the object. (Typically this would be the last component of the filename, not an entire pathname.)

Returns:
the name of the object.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FileDataSource

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class FileDataSource

java.lang.Object
    extended by javax.activation.FileDataSource
All Implemented Interfaces:
DataSource
public class FileDataSource
extends Object
implements DataSource

The FileDataSource class implements a simple DataSource object that encapsulates a file. It provides data typing services via a FileTypeMap object.

FileDataSource Typing Semantics

The FileDataSource class delegates data typing of files to an object subclassed from the FileTypeMap class. The setFileTypeMap method can be used to explicitly set the FileTypeMap for an instance of FileDataSource. If no FileTypeMap is set, the FileDataSource will call the FileTypeMap's getDefaultFileTypeMap method to get the System's default FileTypeMap.

See Also:
DataSource, FileTypeMap, MimetypesFileTypeMap

Constructor Summary
FileDataSource(File file)
Creates a FileDataSource from a File object.
FileDataSource(String name)
Creates a FileDataSource from the specified path name.
Method Summary
String | getContentType() This method returns the MIME type of the data in the form of a string.
File | getFile() Return the File object that corresponds to this FileDataSource.
InputStream | getInputStream() This method will return an InputStream representing the the data and will throw an IOException if it can not do so.
String | getName() Return the name of this object.
OutputStream | getOutputStream() This method will return an OutputStream representing the the data and will throw an IOException if it can not do so.
void | setFileTypeMap(FileTypeMap map) Set the FileTypeMap to use with this FileDataSource
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FileDataSource

public FileDataSource(File file)
Creates a FileDataSource from a File object. Note: The file will not actually be opened until a method is called that requires the file to be opened.

Parameters:
file - the file

FileDataSource

public FileDataSource(String name)
Creates a FileDataSource from the specified path name. Note: The file will not actually be opened until a method is called that requires the file to be opened.

Parameters:
name - the system-dependent file name.
Method Detail

getInputStream

public InputStream getInputStream()
                           throws IOException
This method will return an InputStream representing the the data and will throw an IOException if it can not do so. This method will return a new instance of InputStream with each invocation.

Specified by:
getInputStream in interface DataSource
Returns:
an InputStream
Throws:
IOException

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
This method will return an OutputStream representing the the data and will throw an IOException if it can not do so. This method will return a new instance of OutputStream with each invocation.

Specified by:
getOutputStream in interface DataSource
Returns:
an OutputStream
Throws:
IOException

getContentType

public String getContentType()
This method returns the MIME type of the data in the form of a string. This method uses the currently installed FileTypeMap. If there is no FileTypeMap explictly set, the FileDataSource will call the getDefaultFileTypeMap method on FileTypeMap to acquire a default FileTypeMap. Note: By default, the FileTypeMap used will be a MimetypesFileTypeMap.

Specified by:
getContentType in interface DataSource
Returns:
the MIME Type
See Also:
FileTypeMap.getDefaultFileTypeMap()

getName

public String getName()
Return the name of this object. The FileDataSource will return the file name of the object.

Specified by:
getName in interface DataSource
Returns:
the name of the object.
See Also:
DataSource

getFile

public File getFile()
Return the File object that corresponds to this FileDataSource.

Returns:
the File object for the file represented by this object.

setFileTypeMap

public void setFileTypeMap(FileTypeMap map)
Set the FileTypeMap to use with this FileDataSource

Parameters:
map - The FileTypeMap for this object.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FileTypeMap

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class FileTypeMap

java.lang.Object
    extended by javax.activation.FileTypeMap
Direct Known Subclasses:
MimetypesFileTypeMap
public abstract class FileTypeMap
extends Object

The FileTypeMap is an abstract class that provides a data typing interface for files. Implementations of this class will implement the getContentType methods which will derive a content type from a file name or a File object. FileTypeMaps could use any scheme to determine the data type, from examining the file extension of a file (like the MimetypesFileTypeMap) to opening the file and trying to derive its type from the contents of the file. The FileDataSource class uses the default FileTypeMap (a MimetypesFileTypeMap unless changed) to determine the content type of files.

See Also:
FileTypeMap, FileDataSource, MimetypesFileTypeMap

Constructor Summary
FileTypeMap()
The default constructor.
Method Summary
abstract String | getContentType(File file) Return the type of the file object.
abstract String | getContentType(String filename) Return the type of the file passed in.
static FileTypeMap | getDefaultFileTypeMap() Return the default FileTypeMap for the system.
static void | setDefaultFileTypeMap(FileTypeMap map) Sets the default FileTypeMap for the system.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FileTypeMap

public FileTypeMap()
The default constructor.

Method Detail

getContentType

public abstract String getContentType(File file)
Return the type of the file object. This method should always return a valid MIME type.

Returns:
The content type.

getContentType

public abstract String getContentType(String filename)
Return the type of the file passed in. This method should always return a valid MIME type.

Parameters:
filename - the pathname of the file.
Returns:
The content type.

setDefaultFileTypeMap

public static void setDefaultFileTypeMap(FileTypeMap map)
Sets the default FileTypeMap for the system. This instance will be returned to callers of getDefaultFileTypeMap.

Parameters:
map - The FileTypeMap.
Throws:
SecurityException - if the caller doesn't have permission to change the default

getDefaultFileTypeMap

public static FileTypeMap getDefaultFileTypeMap()
Return the default FileTypeMap for the system. If setDefaultFileTypeMap was called, return that instance, otherwise return an instance of MimetypesFileTypeMap.

Returns:
The default FileTypeMap
See Also:
setDefaultFileTypeMap(javax.activation.FileTypeMap)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MailcapCommandMap

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class MailcapCommandMap

java.lang.Object
    extended by javax.activation.CommandMap
        extended by javax.activation.MailcapCommandMap
public class MailcapCommandMap
extends CommandMap

MailcapCommandMap extends the CommandMap abstract class. It implements a CommandMap whose configuration is based on mailcap files (RFC 1524). The MailcapCommandMap can be configured both programmatically and via configuration files.

Mailcap file search order:

The MailcapCommandMap looks in various places in the user's system for mailcap file entries. When requests are made to search for commands in the MailcapCommandMap, it searches mailcap files in the following order:

  1. Programatically added entries to the MailcapCommandMap instance.
  2. The file .mailcap in the user's home directory.
  3. The file <java.home>/lib/mailcap.
  4. The file or resources named META-INF/mailcap.
  5. The file or resource named META-INF/mailcap.default (usually found only in the activation.jar file).

Mailcap file format:

Mailcap files must conform to the mailcap file specification (RFC 1524, A User Agent Configuration Mechanism For Multimedia Mail Format Information). The file format consists of entries corresponding to particular MIME types. In general, the specification specifies applications for clients to use when they themselves cannot operate on the specified MIME type. The MailcapCommandMap extends this specification by using a parameter mechanism in mailcap files that allows JavaBeans(tm) components to be specified as corresponding to particular commands for a MIME type.

When a mailcap file is parsed, the MailcapCommandMap recognizes certain parameter signatures, specifically those parameter names that begin with x-java-. The MailcapCommandMap uses this signature to find command entries for inclusion into its registries. Parameter names with the form x-java-<name> are read by the MailcapCommandMap as identifying a command with the name name. When the name is content-handler the MailcapCommandMap recognizes the class signified by this parameter as a DataContentHandler. All other commands are handled generically regardless of command name. The command implementation is specified by a fully qualified class name of a JavaBean(tm) component. For example; a command for viewing some data can be specified as: x-java-view=com.foo.ViewBean.

MailcapCommandMap aware mailcap files have the following general form:

# Comments begin with a '#' and continue to the end of the line.
<mime type>; ; <parameter list>
# Where a parameter list consists of one or more parameters,
# where parameters look like: x-java-view=com.sun.TextViewer
# and a parameter list looks like:
text/plain; ; x-java-view=com.sun.TextViewer; x-java-edit=com.sun.TextEdit
# Note that mailcap entries that do not contain 'x-java' parameters
# and comply to RFC 1524 are simply ignored:
image/gif; /usr/dt/bin/sdtimage %s

Author:
Bart Calder, Bill Shannon

Constructor Summary
MailcapCommandMap()
The default Constructor.
MailcapCommandMap(InputStream is)
Constructor that allows the caller to specify an InputStream containing a mailcap file.
MailcapCommandMap(String fileName)
Constructor that allows the caller to specify the path of a mailcap file.
Method Summary
void | addMailcap(String mail_cap) Add entries to the registry.
DataContentHandler | createDataContentHandler(String mimeType) Return the DataContentHandler for the specified MIME type.
CommandInfo[] | getAllCommands(String mimeType) Get all the available commands in all mailcap files known to this instance of MailcapCommandMap for this MIME type.
CommandInfo | getCommand(String mimeType, String cmdName) Get the command corresponding to cmdName for the MIME type.
CommandInfo[] | getPreferredCommands(String mimeType) Get the preferred command list for a MIME Type.
Methods inherited from class javax.activation.CommandMap
getDefaultCommandMap, setDefaultCommandMap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MailcapCommandMap

public MailcapCommandMap()
The default Constructor.

MailcapCommandMap

public MailcapCommandMap(String fileName)
                  throws IOException
Constructor that allows the caller to specify the path of a mailcap file.

Parameters:
fileName - The name of the mailcap file to open

MailcapCommandMap

public MailcapCommandMap(InputStream is)
Constructor that allows the caller to specify an InputStream containing a mailcap file.

Parameters:
is - InputStream of the mailcap file to open
Method Detail

getPreferredCommands

public CommandInfo[] getPreferredCommands(String mimeType)
Get the preferred command list for a MIME Type. The MailcapCommandMap searches the mailcap files as described above under Mailcap file search order.

The result of the search is a proper subset of available commands in all mailcap files known to this instance of MailcapCommandMap. The first entry for a particular command is considered the preferred command.

Specified by:
getPreferredCommands in class CommandMap
Parameters:
mimeType - the MIME type
Returns:
the CommandInfo objects representing the preferred commands.

getAllCommands

public CommandInfo[] getAllCommands(String mimeType)
Get all the available commands in all mailcap files known to this instance of MailcapCommandMap for this MIME type.

Specified by:
getAllCommands in class CommandMap
Parameters:
mimeType - the MIME type
Returns:
the CommandInfo objects representing all the commands.

getCommand

public CommandInfo getCommand(String mimeType,
                              String cmdName)
Get the command corresponding to cmdName for the MIME type.

Specified by:
getCommand in class CommandMap
Parameters:
mimeType - the MIME type
cmdName - the command name
Returns:
the CommandInfo object corresponding to the command.

addMailcap

public void addMailcap(String mail_cap)
Add entries to the registry. Programmatically added entries are searched before other entries.

The string that is passed in should be in mailcap format.

Parameters:
mail_cap - a correctly formatted mailcap string

createDataContentHandler

public DataContentHandler createDataContentHandler(String mimeType)
Return the DataContentHandler for the specified MIME type.

Specified by:
createDataContentHandler in class CommandMap
Parameters:
mimeType - the MIME type
Returns:
the DataContentHandler
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimeType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class MimeType

java.lang.Object
    extended by javax.activation.MimeType
All Implemented Interfaces:
Externalizable, Serializable
public class MimeType
extends Object
implements Externalizable

A Multipurpose Internet Mail Extension (MIME) type, as defined in RFC 2045 and 2046.

See Also:
Serialized Form

Constructor Summary
MimeType()
Default constructor.
MimeType(String rawdata)
Constructor that builds a MimeType from a String.
MimeType(String primary, String sub)
Constructor that builds a MimeType with the given primary and sub type but has an empty parameter list.
Method Summary
String | getBaseType() Return a String representation of this object without the parameter list.
String | getParameter(String name) Retrieve the value associated with the given name, or null if there is no current association.
MimeTypeParameterList | getParameters() Retrieve this object's parameter list.
String | getPrimaryType() Retrieve the primary type of this object.
String | getSubType() Retrieve the sub type of this object.
boolean | match(MimeType type) Determine if the primary and sub type of this object is the same as what is in the given type.
boolean | match(String rawdata) Determine if the primary and sub type of this object is the same as the content type described in rawdata.
void | readExternal(ObjectInput in) The object implements the readExternal method to restore its contents by calling the methods of DataInput for primitive types and readObject for objects, strings and arrays.
void | removeParameter(String name) Remove any value associated with the given name.
void | setParameter(String name, String value) Set the value to be associated with the given name, replacing any previous association.
void | setPrimaryType(String primary) Set the primary type for this object to the given String.
void | setSubType(String sub) Set the sub type for this object to the given String.
String | toString() Return the String representation of this object.
void | writeExternal(ObjectOutput out) The object implements the writeExternal method to save its contents by calling the methods of DataOutput for its primitive values or calling the writeObject method of ObjectOutput for objects, strings and arrays.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MimeType

public MimeType()
Default constructor.

MimeType

public MimeType(String rawdata)
         throws MimeTypeParseException
Constructor that builds a MimeType from a String.

Parameters:
rawdata - the MIME type string

MimeType

public MimeType(String primary,
                String sub)
         throws MimeTypeParseException
Constructor that builds a MimeType with the given primary and sub type but has an empty parameter list.

Parameters:
primary - the primary MIME type
sub - the MIME sub-type
Method Detail

getPrimaryType

public String getPrimaryType()
Retrieve the primary type of this object.

Returns:
the primary MIME type

setPrimaryType

public void setPrimaryType(String primary)
                    throws MimeTypeParseException
Set the primary type for this object to the given String.

Parameters:
primary - the primary MIME type
Throws:
MimeTypeParseException

getSubType

public String getSubType()
Retrieve the sub type of this object.

Returns:
the MIME sub-type

setSubType

public void setSubType(String sub)
                throws MimeTypeParseException
Set the sub type for this object to the given String.

Parameters:
sub - the MIME sub-type
Throws:
MimeTypeParseException

getParameters

public MimeTypeParameterList getParameters()
Retrieve this object's parameter list.

Returns:
a MimeTypeParameterList object representing the parameters

getParameter

public String getParameter(String name)
Retrieve the value associated with the given name, or null if there is no current association.

Parameters:
name - the parameter name
Returns:
the paramter's value

setParameter

public void setParameter(String name,
                         String value)
Set the value to be associated with the given name, replacing any previous association.

Parameters:
name - the parameter name
value - the paramter's value

removeParameter

public void removeParameter(String name)
Remove any value associated with the given name.

Parameters:
name - the parameter name

toString

public String toString()
Return the String representation of this object.

getBaseType

public String getBaseType()
Return a String representation of this object without the parameter list.

Returns:
the MIME type and sub-type

match

public boolean match(MimeType type)
Determine if the primary and sub type of this object is the same as what is in the given type.

Parameters:
type - the MimeType object to compare with
Returns:
true if they match

match

public boolean match(String rawdata)
              throws MimeTypeParseException
Determine if the primary and sub type of this object is the same as the content type described in rawdata.

Parameters:
rawdata - the MIME type string to compare with
Returns:
true if they match
Throws:
MimeTypeParseException

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException
The object implements the writeExternal method to save its contents by calling the methods of DataOutput for its primitive values or calling the writeObject method of ObjectOutput for objects, strings and arrays.

Specified by:
writeExternal in interface Externalizable
Parameters:
out - the ObjectOutput object to write to
Throws:
IOException - Includes any I/O exceptions that may occur

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
The object implements the readExternal method to restore its contents by calling the methods of DataInput for primitive types and readObject for objects, strings and arrays. The readExternal method must read the values in the same sequence and with the same types as were written by writeExternal.

Specified by:
readExternal in interface Externalizable
Parameters:
in - the IbjectInput object to read from
Throws:
ClassNotFoundException - If the class for an object being restored cannot be found.
IOException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimeTypeParameterList

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class MimeTypeParameterList

java.lang.Object
    extended by javax.activation.MimeTypeParameterList
public class MimeTypeParameterList
extends Object

A parameter list of a MimeType as defined in RFC 2045 and 2046. The Primary type of the object must already be stripped off.

See Also:
MimeType

Constructor Summary
MimeTypeParameterList()
Default constructor.
MimeTypeParameterList(String parameterList)
Constructs a new MimeTypeParameterList with the passed in data.
Method Summary
String | get(String name) Retrieve the value associated with the given name, or null if there is no current association.
Enumeration | getNames() Retrieve an enumeration of all the names in this list.
boolean | isEmpty() Determine whether or not this list is empty.
protected void | parse(String parameterList) A routine for parsing the parameter list out of a String.
void | remove(String name) Remove any value associated with the given name.
void | set(String name, String value) Set the value to be associated with the given name, replacing any previous association.
int | size() Return the number of name-value pairs in this list.
String | toString() Return a string representation of this object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MimeTypeParameterList

public MimeTypeParameterList()
Default constructor.

MimeTypeParameterList

public MimeTypeParameterList(String parameterList)
                      throws MimeTypeParseException
Constructs a new MimeTypeParameterList with the passed in data.

Parameters:
parameterList - an RFC 2045, 2046 compliant parameter list.
Method Detail

parse

protected void parse(String parameterList)
              throws MimeTypeParseException
A routine for parsing the parameter list out of a String.

Parameters:
parameterList - an RFC 2045, 2046 compliant parameter list.
Throws:
MimeTypeParseException

size

public int size()
Return the number of name-value pairs in this list.

Returns:
the number of parameters

isEmpty

public boolean isEmpty()
Determine whether or not this list is empty.

Returns:
true if there are no parameters

get

public String get(String name)
Retrieve the value associated with the given name, or null if there is no current association.

Parameters:
name - the parameter name
Returns:
the parameter's value

set

public void set(String name,
                String value)
Set the value to be associated with the given name, replacing any previous association.

Parameters:
name - the parameter name
value - the parameter's value

remove

public void remove(String name)
Remove any value associated with the given name.

Parameters:
name - the parameter name

getNames

public Enumeration getNames()
Retrieve an enumeration of all the names in this list.

Returns:
an enumeration of all parameter names

toString

public String toString()
Return a string representation of this object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimeTypeParseException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class MimeTypeParseException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.activation.MimeTypeParseException
All Implemented Interfaces:
Serializable
public class MimeTypeParseException
extends Exception

A class to encapsulate MimeType parsing related exceptions.

See Also:
Serialized Form

Constructor Summary
MimeTypeParseException()
Constructs a MimeTypeParseException with no specified detail message.
MimeTypeParseException(String s)
Constructs a MimeTypeParseException with the specified detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MimeTypeParseException

public MimeTypeParseException()
Constructs a MimeTypeParseException with no specified detail message.

MimeTypeParseException

public MimeTypeParseException(String s)
Constructs a MimeTypeParseException with the specified detail message.

Parameters:
s - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimetypesFileTypeMap

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class MimetypesFileTypeMap

java.lang.Object
    extended by javax.activation.FileTypeMap
        extended by javax.activation.MimetypesFileTypeMap
public class MimetypesFileTypeMap
extends FileTypeMap

This class extends FileTypeMap and provides data typing of files via their file extension. It uses the .mime.types format.

MIME types file search order:

The MimetypesFileTypeMap looks in various places in the user's system for MIME types file entries. When requests are made to search for MIME types in the MimetypesFileTypeMap, it searches MIME types files in the following order:

  1. Programmatically added entries to the MimetypesFileTypeMap instance.
  2. The file .mime.types in the user's home directory.
  3. The file <java.home>/lib/mime.types.
  4. The file or resources named META-INF/mime.types.
  5. The file or resource named META-INF/mimetypes.default (usually found only in the activation.jar file).

MIME types file format:

# comments begin with a '#'
# the format is <mime type> <space separated file extensions>
# for example:
text/plain txt text TXT
# this would map file.txt, file.text, and file.TXT to
# the mime type "text/plain"

Author:
Bart Calder, Bill Shannon

Constructor Summary
MimetypesFileTypeMap()
The default constructor.
MimetypesFileTypeMap(InputStream is)
Construct a MimetypesFileTypeMap with programmatic entries added from the InputStream.
MimetypesFileTypeMap(String mimeTypeFileName)
Construct a MimetypesFileTypeMap with programmatic entries added from the named file.
Method Summary
void | addMimeTypes(String mime_types) Prepend the MIME type values to the registry.
String | getContentType(File f) Return the MIME type of the file object.
String | getContentType(String filename) Return the MIME type based on the specified file name.
Methods inherited from class javax.activation.FileTypeMap
getDefaultFileTypeMap, setDefaultFileTypeMap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MimetypesFileTypeMap

public MimetypesFileTypeMap()
The default constructor.

MimetypesFileTypeMap

public MimetypesFileTypeMap(String mimeTypeFileName)
                     throws IOException
Construct a MimetypesFileTypeMap with programmatic entries added from the named file.

Parameters:
mimeTypeFileName - the file name

MimetypesFileTypeMap

public MimetypesFileTypeMap(InputStream is)
Construct a MimetypesFileTypeMap with programmatic entries added from the InputStream.

Parameters:
is - the input stream to read from
Method Detail

addMimeTypes

public void addMimeTypes(String mime_types)
Prepend the MIME type values to the registry.

Parameters:
mime_types - A .mime.types formatted string of entries.

getContentType

public String getContentType(File f)
Return the MIME type of the file object. The implementation in this class calls getContentType(f.getName()).

Specified by:
getContentType in class FileTypeMap
Parameters:
f - the file
Returns:
the file's MIME type

getContentType

public String getContentType(String filename)
Return the MIME type based on the specified file name. The MIME type entries are searched as described above under MIME types file search order. If no entry is found, the type "application/octet-stream" is returned.

Specified by:
getContentType in class FileTypeMap
Parameters:
filename - the file name
Returns:
the file's MIME type
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


UnsupportedDataTypeException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class UnsupportedDataTypeException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.io.IOException
                extended by javax.activation.UnsupportedDataTypeException
All Implemented Interfaces:
Serializable
public class UnsupportedDataTypeException
extends IOException

Signals that the requested operation does not support the requested data type.

See Also:
DataHandler, Serialized Form

Constructor Summary
UnsupportedDataTypeException()
Constructs an UnsupportedDataTypeException with no detail message.
UnsupportedDataTypeException(String s)
Constructs an UnsupportedDataTypeException with the specified message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnsupportedDataTypeException

public UnsupportedDataTypeException()
Constructs an UnsupportedDataTypeException with no detail message.

UnsupportedDataTypeException

public UnsupportedDataTypeException(String s)
Constructs an UnsupportedDataTypeException with the specified message.

Parameters:
s - The detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


URLDataSource

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class URLDataSource

java.lang.Object
    extended by javax.activation.URLDataSource
All Implemented Interfaces:
DataSource
public class URLDataSource
extends Object
implements DataSource

The URLDataSource class provides an object that wraps a URL object in a DataSource interface. URLDataSource simplifies the handling of data described by URLs within the JavaBeans Activation Framework because this class can be used to create new DataHandlers. NOTE: The DataHandler object creates a URLDataSource internally, when it is constructed with a URL.

See Also:
DataSource, DataHandler

Constructor Summary
URLDataSource(URL url)
URLDataSource constructor.
Method Summary
String | getContentType() Returns the value of the URL content-type header field.
InputStream | getInputStream() The getInputStream method from the URL.
String | getName() Calls the getFile method on the URL used to instantiate the object.
OutputStream | getOutputStream() The getOutputStream method from the URL.
URL | getURL() Return the URL used to create this DataSource.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

URLDataSource

public URLDataSource(URL url)
URLDataSource constructor. The URLDataSource class will not open a connection to the URL until a method requiring it to do so is called.

Parameters:
url - The URL to be encapsulated in this object.
Method Detail

getContentType

public String getContentType()
Returns the value of the URL content-type header field. It calls the URL's URLConnection.getContentType method after retrieving a URLConnection object. Note: this method attempts to call the openConnection method on the URL. If this method fails, or if a content type is not returned from the URLConnection, getContentType returns "application/octet-stream" as the content type.

Specified by:
getContentType in interface DataSource
Returns:
the content type.

getName

public String getName()
Calls the getFile method on the URL used to instantiate the object.

Specified by:
getName in interface DataSource
Returns:
the result of calling the URL's getFile method.

getInputStream

public InputStream getInputStream()
                           throws IOException
The getInputStream method from the URL. Calls the openStream method on the URL.

Specified by:
getInputStream in interface DataSource
Returns:
the InputStream.
Throws:
IOException

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
The getOutputStream method from the URL. First an attempt is made to get the URLConnection object for the URL. If that succeeds, the getOutputStream method on the URLConnection is returned.

Specified by:
getOutputStream in interface DataSource
Returns:
the OutputStream.
Throws:
IOException

getURL

public URL getURL()
Return the URL used to create this DataSource.

Returns:
The URL.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ejb

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.ejb

The javax.ejb package contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

See:
Description

Interface Summary
EJBContext | The EJBContext interface provides an instance with access to the container-provided runtime context of an enterprise Bean instance.
EJBHome | The EJBHome interface must be extended by all enterprise Beans' remote home interfaces.
EJBLocalHome | The EJBLocalHome interface must be extended by all enterprise Beans' local home interfaces.
EJBLocalObject | The EJBLocalObject interface must be extended by all enterprise Beans' local interfaces.
EJBMetaData | The EJBMetaData interface allows a client to obtain the enterprise Bean's meta-data information.
EJBObject | The EJBObject interface is extended by all enterprise Beans' remote interfaces.
EnterpriseBean | The EnterpriseBean interface must be implemented by every enterprise Bean class.
EntityBean | The EntityBean interface is implemented by every entity enterprise Bean class.
EntityContext | The EntityContext interface provides an instance with access to the container-provided runtime context of an entity enterprise Bean instance.
Handle | The Handle interface is implemented by all EJB object handles.
HomeHandle | The HomeHandle interface is implemented by all home object handles.
MessageDrivenBean | The MessageDrivenBean interface is implemented by every message-driven enterprise Bean class.
MessageDrivenContext | The MessageDrivenContext interface provides access to the runtime message-driven context that the container provides for a message-driven enterprise Bean instance.
SessionBean | The SessionBean interface is implemented by every session enterprise Bean class.
SessionContext | The SessionContext interface provides access to the runtime session context that the container provides for a session enterprise Bean instance.
SessionSynchronization | The SessionSynchronization interface allows a session Bean instance to be notified by its container of transaction boundaries.
TimedObject | The TimedObject interface contains the callback method that is used to deliver timer expiration notifications.
Timer | The Timer interface contains information about a timer that was created through the EJB Timer Service.
TimerHandle | The TimerHandle interface is implemented by all EJB timer handles.
TimerService | The TimerService interface provides enterprise bean components with access to the container-provided Timer Service.

Exception Summary
AccessLocalException | An AccessLocalException is thrown to indicate that the caller does not have permission to call the method.
CreateException | The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise Bean's home interface.
DuplicateKeyException | The DuplicateKeyException exception is thrown if an entity EJB object cannot be created because an object with the same key already exists.
EJBException | The EJBException exception is thrown by an enterprise Bean instance to its container to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g. the instance failed to open a database connection).
FinderException | The FinderException exception must be included in the throws clause of every findMETHOD(...) method of an entity Bean's home interface.
NoSuchEntityException | The NoSuchEntityException exception is thrown by an Entity Bean instance to its container to report that the invoked business method or callback method could not be completed because of the underlying entity was removed from the database.
NoSuchObjectLocalException | A NoSuchObjectLocalException is thrown if an attempt is made to invoke a method on an object that no longer exists.
ObjectNotFoundException | The ObjectNotFoundException exception is thrown by a finder method to indicate that the specified EJB object does not exist.
RemoveException | The RemoveException exception is thrown at an attempt to remove an EJB object when the enterprise Bean or the container does not allow the EJB object to be removed.
TransactionRequiredLocalException | This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.
TransactionRolledbackLocalException | This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back.

Package javax.ejb Description

The javax.ejb package contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EnterpriseBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EnterpriseBean

All Superinterfaces:
Serializable
All Known Subinterfaces:
EntityBean, MessageDrivenBean, SessionBean
public interface EnterpriseBean
extends Serializable

The EnterpriseBean interface must be implemented by every enterprise Bean class. It is a common superinterface for the SessionBean, EntityBean and MessageDrivenBean interfaces.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.ejb Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.ejb

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.ejb.CreateException
          • class javax.ejb.DuplicateKeyException
        • class javax.ejb.FinderException
          • class javax.ejb.ObjectNotFoundException
        • class javax.ejb.RemoveException
        • class java.lang.RuntimeException
          • class javax.ejb.EJBException
            • class javax.ejb.AccessLocalException
            • class javax.ejb.NoSuchEntityException
            • class javax.ejb.NoSuchObjectLocalException
            • class javax.ejb.TransactionRequiredLocalException
            • class javax.ejb.TransactionRolledbackLocalException

Interface Hierarchy

  • interface javax.ejb.EJBContext
    • interface javax.ejb.EntityContext
    • interface javax.ejb.MessageDrivenContext
    • interface javax.ejb.SessionContext
  • interface javax.ejb.EJBLocalHome
  • interface javax.ejb.EJBLocalObject
  • interface javax.ejb.EJBMetaData
  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
    • interface javax.ejb.EJBObject
  • interface java.io.Serializable
    • interface javax.ejb.EnterpriseBean
      • interface javax.ejb.EntityBean
      • interface javax.ejb.MessageDrivenBean
      • interface javax.ejb.SessionBean
    • interface javax.ejb.Handle
    • interface javax.ejb.HomeHandle
    • interface javax.ejb.TimerHandle
  • interface javax.ejb.SessionSynchronization
  • interface javax.ejb.TimedObject
  • interface javax.ejb.Timer
  • interface javax.ejb.TimerService
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageDrivenContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface MessageDrivenContext

All Superinterfaces:
EJBContext
public interface MessageDrivenContext
extends EJBContext

The MessageDrivenContext interface provides access to the runtime message-driven context that the container provides for a message-driven enterprise Bean instance. The container passes the MessageDrivenContext interface to an instance after the instance has been created. The message-driven context remains associated with the instance for the lifetime of the instance.

Methods inherited from interface javax.ejb.EJBContext
getCallerIdentity, getCallerPrincipal, getEJBHome, getEJBLocalHome, getEnvironment, getRollbackOnly, getTimerService, getUserTransaction, isCallerInRole, isCallerInRole, setRollbackOnly

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AccessLocalException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class AccessLocalException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.ejb.EJBException
                    extended by javax.ejb.AccessLocalException
All Implemented Interfaces:
Serializable
public class AccessLocalException
extends EJBException

An AccessLocalException is thrown to indicate that the caller does not have permission to call the method. This exception is thrown to local clients.

See Also:
Serialized Form

Constructor Summary
AccessLocalException()
Constructs an AccessLocalException with no detail message.
AccessLocalException(String message)
Constructs an AccessLocalException with the specified detail message.
AccessLocalException(String message, Exception ex)
Constructs an AccessLocalException with the specified detail message and a nested exception.
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AccessLocalException

public AccessLocalException()
Constructs an AccessLocalException with no detail message.

AccessLocalException

public AccessLocalException(String message)
Constructs an AccessLocalException with the specified detail message.

AccessLocalException

public AccessLocalException(String message,
                            Exception ex)
Constructs an AccessLocalException with the specified detail message and a nested exception.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CreateException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class CreateException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.ejb.CreateException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
DuplicateKeyException
public class CreateException
extends Exception

The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise Bean's home interface.

This exception is used as a standard application-level exception to report a failure to create an EJB object.

See Also:
Serialized Form

Constructor Summary
CreateException()
Constructs a CreateException with no detail message.
CreateException(String message)
Constructs a CreateException with the specified detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CreateException

public CreateException()
Constructs a CreateException with no detail message.

CreateException

public CreateException(String message)
Constructs a CreateException with the specified detail message.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DuplicateKeyException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class DuplicateKeyException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.ejb.CreateException
                extended by javax.ejb.DuplicateKeyException
All Implemented Interfaces:
Serializable
public class DuplicateKeyException
extends CreateException

The DuplicateKeyException exception is thrown if an entity EJB object cannot be created because an object with the same key already exists. This exception is thrown by the create methods defined in an entity Bean's home interface.

See Also:
Serialized Form

Constructor Summary
DuplicateKeyException()
Constructs a DuplicateKeyException with no detail message.
DuplicateKeyException(String message)
Constructs a DuplicateKeyException with the specified detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DuplicateKeyException

public DuplicateKeyException()
Constructs a DuplicateKeyException with no detail message.

DuplicateKeyException

public DuplicateKeyException(String message)
Constructs a DuplicateKeyException with the specified detail message.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EJBContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBContext

All Known Subinterfaces:
EntityContext, MessageDrivenContext, SessionContext
public interface EJBContext

The EJBContext interface provides an instance with access to the container-provided runtime context of an enterprise Bean instance.

This interface is extended by the SessionContext, EntityContext, and MessageDrivenContext interfaces to provide additional methods specific to the enterprise interface Bean type.

Method Summary
 Identity getCallerIdentity()
Deprecated. Use Principal getCallerPrincipal() instead.
 Principal getCallerPrincipal()
Obtain the java.security.Principal that identifies the caller.
 EJBHome getEJBHome()
Obtain the enterprise bean's remote home interface.
 EJBLocalHome getEJBLocalHome()
Obtain the enterprise bean's local home interface.
 Properties getEnvironment()
Deprecated. Use the JNDI naming context java:comp/env to access enterprise bean's environment.
 boolean getRollbackOnly()
Test if the transaction has been marked for rollback only.
 TimerService getTimerService()
Get access to the EJB Timer Service.
 UserTransaction getUserTransaction()
Obtain the transaction demarcation interface.
 boolean isCallerInRole(Identity role)
Deprecated. Use boolean isCallerInRole(String roleName) instead.
 boolean isCallerInRole(String roleName)
Test if the caller has a given security role.
 void setRollbackOnly()
Mark the current transaction for rollback.

Method Detail

getEJBHome

public EJBHome getEJBHome()
Obtain the enterprise bean's remote home interface.

Returns:
The enterprise bean's remote home interface.
Throws:
IllegalStateException - if the enterprise bean does not have a remote home interface.

getEJBLocalHome

public EJBLocalHome getEJBLocalHome()
Obtain the enterprise bean's local home interface.

Returns:
The enterprise bean's local home interface.
Throws:
IllegalStateException - if the enterprise bean does not have a local home interface.

getEnvironment

public Properties getEnvironment()
Deprecated. Use the JNDI naming context java:comp/env to access enterprise bean's environment.

Obtain the enterprise bean's environment properties.

Note: If the enterprise bean has no environment properties this method returns an empty java.util.Properties object. This method never returns null.

Returns:
The environment properties for the enterprise bean.

getCallerIdentity

public Identity getCallerIdentity()
Deprecated. Use Principal getCallerPrincipal() instead.

Obtain the java.security.Identity of the caller. This method is deprecated in EJB 1.1. The Container is allowed to return alway null from this method. The enterprise bean should use the getCallerPrincipal method instead.

Returns:
The Identity object that identifies the caller.

getCallerPrincipal

public Principal getCallerPrincipal()
Obtain the java.security.Principal that identifies the caller.

Returns:
The Principal object that identifies the caller. This method never returns null.
Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to call this method.

isCallerInRole

public boolean isCallerInRole(Identity role)
Deprecated. Use boolean isCallerInRole(String roleName) instead.

Test if the caller has a given role.

This method is deprecated in EJB 1.1. The enterprise bean should use the isCallerInRole(String roleName) method instead.

Parameters:
role - The java.security.Identity of the role to be tested.
Returns:
True if the caller has the specified role.

isCallerInRole

public boolean isCallerInRole(String roleName)
Test if the caller has a given security role.

Parameters:
roleName - The name of the security role. The role must be one of the security roles that is defined in the deployment descriptor.
Returns:
True if the caller has the specified role.
Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to call this method.

getUserTransaction

public UserTransaction getUserTransaction()
                                   throws IllegalStateException
Obtain the transaction demarcation interface. Only enterprise beans with bean-managed transactions are allowed to to use the UserTransaction interface. As entity beans must always use container-managed transactions, only session beans or message-driven beans with bean-managed transactions are allowed to invoke this method.

Returns:
The UserTransaction interface that the enterprise bean instance can use for transaction demarcation.
Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to use the UserTransaction interface (i.e. the instance is of a bean with container-managed transactions).

setRollbackOnly

public void setRollbackOnly()
                     throws IllegalStateException
Mark the current transaction for rollback. The transaction will become permanently marked for rollback. A transaction marked for rollback can never commit. Only enterprise beans with container-managed transactions are allowed to use this method.

Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to use this method (i.e. the instance is of a bean with bean-managed transactions).

getRollbackOnly

public boolean getRollbackOnly()
                        throws IllegalStateException
Test if the transaction has been marked for rollback only. An enterprise bean instance can use this operation, for example, to test after an exception has been caught, whether it is fruitless to continue computation on behalf of the current transaction. Only enterprise beans with container-managed transactions are allowed to use this method.

Returns:
True if the current transaction is marked for rollback, false otherwise.
Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to use this method (i.e. the instance is of a bean with bean-managed transactions).

getTimerService

public TimerService getTimerService()
                             throws IllegalStateException
Get access to the EJB Timer Service.

Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to use this method (e.g. if the bean is a stateful session bean)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EJBException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class EJBException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.ejb.EJBException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AccessLocalException, NoSuchEntityException, NoSuchObjectLocalException, TransactionRequiredLocalException, TransactionRolledbackLocalException
public class EJBException
extends RuntimeException

The EJBException exception is thrown by an enterprise Bean instance to its container to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g. the instance failed to open a database connection).

See Also:
Serialized Form

Constructor Summary
EJBException()
Constructs an EJBException with no detail message.
EJBException(Exception ex)
Constructs an EJBException that embeds the originally thrown exception.
EJBException(String message)
Constructs an EJBException with the specified detailed message.
EJBException(String message, Exception ex)
Constructs an EJBException that embeds the originally thrown exception with the specified detail message.
Method Summary
Exception | getCausedByException() Obtain the exception that caused the EJBException being thrown.
String | getMessage() Returns the detail message, including the message from the nested exception if there is one.
void | printStackTrace() Prints the composite message to System.err.
void | printStackTrace(PrintStream ps) Prints the composite message and the embedded stack trace to the specified stream ps.
void | printStackTrace(PrintWriter pw) Prints the composite message and the embedded stack trace to the specified print writer pw.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EJBException

public EJBException()
Constructs an EJBException with no detail message.

EJBException

public EJBException(String message)
Constructs an EJBException with the specified detailed message.

EJBException

public EJBException(Exception ex)
Constructs an EJBException that embeds the originally thrown exception.

EJBException

public EJBException(String message,
                    Exception ex)
Constructs an EJBException that embeds the originally thrown exception with the specified detail message.

Method Detail

getCausedByException

public Exception getCausedByException()
Obtain the exception that caused the EJBException being thrown.

getMessage

public String getMessage()
Returns the detail message, including the message from the nested exception if there is one.

printStackTrace

public void printStackTrace(PrintStream ps)
Prints the composite message and the embedded stack trace to the specified stream ps.

Parameters:
ps - the print stream

printStackTrace

public void printStackTrace()
Prints the composite message to System.err.

printStackTrace

public void printStackTrace(PrintWriter pw)
Prints the composite message and the embedded stack trace to the specified print writer pw.

Parameters:
pw - the print writer
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EJBHome

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBHome

All Superinterfaces:
Remote
All Known Subinterfaces:
ManagementHome
public interface EJBHome
extends Remote

The EJBHome interface must be extended by all enterprise Beans' remote home interfaces. An enterprise Bean's remote home interface defines the methods that allow a remote client to create, find, and remove EJB objects, as well as home business methods that are not specific to a bean instance (Session Beans do not have finders and home methods).

The remote home interface is defined by the enterprise Bean provider and implemented by the enterprise Bean container.

Method Summary
EJBMetaData | getEJBMetaData() Obtain the EJBMetaData interface for the enterprise Bean.
HomeHandle | getHomeHandle() Obtain a handle for the remote home object.
void | remove(Handle handle) Remove an EJB object identified by its handle.
void | remove(Object primaryKey) Remove an EJB object identified by its primary key.

Method Detail

remove

public void remove(Handle handle)
            throws RemoteException,
                   RemoveException
Remove an EJB object identified by its handle.

Throws:
RemoveException - Thrown if the enterprise Bean or the container does not allow the client to remove the object.
RemoteException - Thrown when the method failed due to a system-level failure.

remove

public void remove(Object primaryKey)
            throws RemoteException,
                   RemoveException
Remove an EJB object identified by its primary key.

This method can be used only for an entity bean. An attempt to call this method on a session bean will result in a RemoveException.

Throws:
RemoveException - Thrown if the enterprise Bean or the container does not allow the client to remove the object.
RemoteException - Thrown when the method failed due to a system-level failure.

getEJBMetaData

public EJBMetaData getEJBMetaData()
                           throws RemoteException
Obtain the EJBMetaData interface for the enterprise Bean. The EJBMetaData interface allows the client to obtain information about the enterprise Bean.

The information obtainable via the EJBMetaData interface is intended to be used by tools.

Returns:
The enterprise Bean's EJBMetaData interface.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure.

getHomeHandle

public HomeHandle getHomeHandle()
                         throws RemoteException
Obtain a handle for the remote home object. The handle can be used at later time to re-obtain a reference to the remote home object, possibly in a different Java Virtual Machine.

Returns:
A handle for the remote home object.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EJBLocalHome

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBLocalHome

public interface EJBLocalHome

The EJBLocalHome interface must be extended by all enterprise Beans' local home interfaces. An enterprise Bean's local home interface defines the methods that allow local clients to create, find, and remove EJB objects, as well as home business methods that are not specific to a bean instance (session Beans do not have finders and home business methods).

The local home interface is defined by the enterprise Bean provider and implemented by the enterprise Bean container.

Method Summary
 void remove(Object primaryKey)
Remove an EJB object identified by its primary key.

Method Detail

remove

public void remove(Object primaryKey)
            throws RemoveException,
                   EJBException
Remove an EJB object identified by its primary key.

This method can only be used by local clients of an entity bean. An attempt to call this method on a session bean will result in a RemoveException.

Throws:
RemoveException - Thrown if the enterprise Bean or the container does not allow the client to remove the object.
EJBException - Thrown when the method failed due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EJBLocalObject

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBLocalObject

public interface EJBLocalObject

The EJBLocalObject interface must be extended by all enterprise Beans' local interfaces. An enterprise Bean's local interface provides the local client view of an EJB object. An enterprise Bean's local interface defines the business methods callable by local clients.

The enterprise Bean's local interface is defined by the enterprise Bean provider and implemented by the enterprise Bean container.

Method Summary
EJBLocalHome | getEJBLocalHome() Obtain the enterprise Bean's local home interface.
Object | getPrimaryKey() Obtain the primary key of the EJB local object.
boolean | isIdentical(EJBLocalObject obj) Test if a given EJB local object is identical to the invoked EJB local object.
void | remove() Remove the EJB local object.

Method Detail

getEJBLocalHome

public EJBLocalHome getEJBLocalHome()
                             throws EJBException
Obtain the enterprise Bean's local home interface. The local home interface defines the enterprise Bean's create, finder, remove, and home business methods that are available to local clients.

Returns:
A reference to the enterprise Bean's local home interface.
Throws:
EJBException - Thrown when the method failed due to a system-level failure.

getPrimaryKey

public Object getPrimaryKey()
                     throws EJBException
Obtain the primary key of the EJB local object.

This method can be called on an entity bean. An attempt to invoke this method on a session Bean will result in an EJBException.

Returns:
The EJB local object's primary key.
Throws:
EJBException - Thrown when the method failed due to a system-level failure or when invoked on a session bean.

remove

public void remove()
            throws RemoveException,
                   EJBException
Remove the EJB local object.

Throws:
RemoveException - The enterprise Bean or the container does not allow destruction of the object.
EJBException - Thrown when the method failed due to a system-level failure.

isIdentical

public boolean isIdentical(EJBLocalObject obj)
                    throws EJBException
Test if a given EJB local object is identical to the invoked EJB local object.

Parameters:
obj - An object to test for identity with the invoked object.
Returns:
True if the given EJB local object is identical to the invoked object, false otherwise.
Throws:
EJBException - Thrown when the method failed due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EJBMetaData

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBMetaData

public interface EJBMetaData

The EJBMetaData interface allows a client to obtain the enterprise Bean's meta-data information.

The meta-data is intended for development tools used for building applications that use deployed enterprise Beans, and for clients using a scripting language to access the enterprise Bean.

Note that the EJBMetaData is not a remote interface. The class that implements this interface (this class is typically generated by container tools) must be serializable, and must be a valid RMI/IDL value type.

Method Summary
EJBHome | getEJBHome() Obtain the remote home interface of the enterprise Bean.
Class | getHomeInterfaceClass() Obtain the Class object for the enterprise Bean's remote home interface.
Class | getPrimaryKeyClass() Obtain the Class object for the enterprise Bean's primary key class.
Class | getRemoteInterfaceClass() Obtain the Class object for the enterprise Bean's remote interface.
boolean | isSession() Test if the enterprise Bean's type is "session".
boolean | isStatelessSession() Test if the enterprise Bean's type is "stateless session".

Method Detail

getEJBHome

public EJBHome getEJBHome()
Obtain the remote home interface of the enterprise Bean.

Returns:
the remote home interface of the enterprise Bean.

getHomeInterfaceClass

public Class getHomeInterfaceClass()
Obtain the Class object for the enterprise Bean's remote home interface.

Returns:
the Class object for the enterprise Bean's remote home interface.

getRemoteInterfaceClass

public Class getRemoteInterfaceClass()
Obtain the Class object for the enterprise Bean's remote interface.

Returns:
the Class object for the enterprise Bean's remote interface.

getPrimaryKeyClass

public Class getPrimaryKeyClass()
Obtain the Class object for the enterprise Bean's primary key class.

Returns:
the Class object for the enterprise Bean's primary key class.

isSession

public boolean isSession()
Test if the enterprise Bean's type is "session".

Returns:
True if the type of the enterprise Bean is session bean.

isStatelessSession

public boolean isStatelessSession()
Test if the enterprise Bean's type is "stateless session".

Returns:
True if the type of the enterprise Bean is stateless session.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EJBObject

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBObject

All Superinterfaces:
Remote
All Known Subinterfaces:
Management
public interface EJBObject
extends Remote

The EJBObject interface is extended by all enterprise Beans' remote interfaces. An enterprise Bean's remote interface provides the remote client view of an EJB object. An enterprise Bean's remote interface defines the business methods callable by a remote client.

The remote interface must extend the javax.ejb.EJBObject interface, and define the enterprise Bean specific business methods.

The enterprise Bean's remote interface is defined by the enterprise Bean provider and implemented by the enterprise Bean container.

Method Summary
EJBHome | getEJBHome() Obtain the enterprise Bean's remote home interface.
Handle | getHandle() Obtain a handle for the EJB object.
Object | getPrimaryKey() Obtain the primary key of the EJB object.
boolean | isIdentical(EJBObject obj) Test if a given EJB object is identical to the invoked EJB object.
void | remove() Remove the EJB object.

Method Detail

getEJBHome

public EJBHome getEJBHome()
                   throws RemoteException
Obtain the enterprise Bean's remote home interface. The remote home interface defines the enterprise Bean's create, finder, remove, and home business methods.

Returns:
A reference to the enterprise Bean's home interface.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure.

getPrimaryKey

public Object getPrimaryKey()
                     throws RemoteException
Obtain the primary key of the EJB object.

This method can be called on an entity bean. An attempt to invoke this method on a session bean will result in RemoteException.

Returns:
The EJB object's primary key.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure or when invoked on a session bean.

remove

public void remove()
            throws RemoteException,
                   RemoveException
Remove the EJB object.

Throws:
RemoteException - Thrown when the method failed due to a system-level failure.
RemoveException - The enterprise Bean or the container does not allow destruction of the object.

getHandle

public Handle getHandle()
                 throws RemoteException
Obtain a handle for the EJB object. The handle can be used at later time to re-obtain a reference to the EJB object, possibly in a different Java Virtual Machine.

Returns:
A handle for the EJB object.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure.

isIdentical

public boolean isIdentical(EJBObject obj)
                    throws RemoteException
Test if a given EJB object is identical to the invoked EJB object.

Parameters:
obj - An object to test for identity with the invoked object.
Returns:
True if the given EJB object is identical to the invoked object, false otherwise.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EntityBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EntityBean

All Superinterfaces:
EnterpriseBean, Serializable
public interface EntityBean
extends EnterpriseBean

The EntityBean interface is implemented by every entity enterprise Bean class. The container uses the EntityBean methods to notify the enterprise Bean instances of the instance's life cycle events.

Method Summary
void | ejbActivate() A container invokes this method when the instance is taken out of the pool of available instances to become associated with a specific EJB object.
void | ejbLoad() A container invokes this method to instruct the instance to synchronize its state by loading it state from the underlying database.
void | ejbPassivate() A container invokes this method on an instance before the instance becomes disassociated with a specific EJB object.
void | ejbRemove() A container invokes this method before it removes the EJB object that is currently associated with the instance.
void | ejbStore() A container invokes this method to instruct the instance to synchronize its state by storing it to the underlying database.
void | setEntityContext(EntityContext ctx) Set the associated entity context.
void | unsetEntityContext() Unset the associated entity context.

Method Detail

setEntityContext

public void setEntityContext(EntityContext ctx)
                      throws EJBException,
                             RemoteException
Set the associated entity context. The container invokes this method on an instance after the instance has been created.

This method is called in an unspecified transaction context.

Parameters:
ctx - An EntityContext interface for the instance. The instance should store the reference to the context in an instance variable.
Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

unsetEntityContext

public void unsetEntityContext()
                        throws EJBException,
                               RemoteException
Unset the associated entity context. The container calls this method before removing the instance.

This is the last method that the container invokes on the instance. The Java garbage collector will eventually invoke the finalize() method on the instance.

This method is called in an unspecified transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbRemove

public void ejbRemove()
               throws RemoveException,
                      EJBException,
                      RemoteException
A container invokes this method before it removes the EJB object that is currently associated with the instance. This method is invoked when a client invokes a remove operation on the enterprise Bean's home interface or the EJB object's remote interface. This method transitions the instance from the ready state to the pool of available instances.

This method is called in the transaction context of the remove operation.

Throws:
RemoveException - The enterprise Bean does not allow destruction of the object.
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbActivate

public void ejbActivate()
                 throws EJBException,
                        RemoteException
A container invokes this method when the instance is taken out of the pool of available instances to become associated with a specific EJB object. This method transitions the instance to the ready state.

This method executes in an unspecified transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbPassivate

public void ejbPassivate()
                  throws EJBException,
                         RemoteException
A container invokes this method on an instance before the instance becomes disassociated with a specific EJB object. After this method completes, the container will place the instance into the pool of available instances.

This method executes in an unspecified transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbLoad

public void ejbLoad()
             throws EJBException,
                    RemoteException
A container invokes this method to instruct the instance to synchronize its state by loading it state from the underlying database.

This method always executes in the transaction context determined by the value of the transaction attribute in the deployment descriptor.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbStore

public void ejbStore()
              throws EJBException,
                     RemoteException
A container invokes this method to instruct the instance to synchronize its state by storing it to the underlying database.

This method always executes in the transaction context determined by the value of the transaction attribute in the deployment descriptor.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EntityContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EntityContext

All Superinterfaces:
EJBContext
public interface EntityContext
extends EJBContext

The EntityContext interface provides an instance with access to the container-provided runtime context of an entity enterprise Bean instance. The container passes the EntityContext interface to an entity enterprise Bean instance after the instance has been created.

The EntityContext interface remains associated with the instance for the lifetime of the instance. Note that the information that the instance obtains using the EntityContext interface (such as the result of the getPrimaryKey() method) may change, as the container assigns the instance to different EJB objects during the instance's life cycle.

Method Summary
EJBLocalObject | getEJBLocalObject() Obtain a reference to the EJB local object that is currently associated with the instance.
EJBObject | getEJBObject() Obtain a reference to the EJB object that is currently associated with the instance.
Object | getPrimaryKey() Obtain the primary key of the EJB object that is currently associated with this instance.
Methods inherited from interface javax.ejb.EJBContext
getCallerIdentity, getCallerPrincipal, getEJBHome, getEJBLocalHome, getEnvironment, getRollbackOnly, getTimerService, getUserTransaction, isCallerInRole, isCallerInRole, setRollbackOnly

Method Detail

getEJBLocalObject

public EJBLocalObject getEJBLocalObject()
                                 throws IllegalStateException
Obtain a reference to the EJB local object that is currently associated with the instance.

An instance of an entity enterprise Bean can call this method only when the instance is associated with an EJB local object identity, i.e. in the ejbActivate, ejbPassivate, ejbPostCreate, ejbRemove, ejbLoad, ejbStore, and business methods.

An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

Returns:
The EJB local object currently associated with the instance.
Throws:
IllegalStateException - if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a local interface.

getEJBObject

public EJBObject getEJBObject()
                       throws IllegalStateException
Obtain a reference to the EJB object that is currently associated with the instance.

An instance of an entity enterprise Bean can call this method only when the instance is associated with an EJB object identity, i.e. in the ejbActivate, ejbPassivate, ejbPostCreate, ejbRemove, ejbLoad, ejbStore, and business methods.

An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

Returns:
The EJB object currently associated with the instance.
Throws:
IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a remote interface.

getPrimaryKey

public Object getPrimaryKey()
                     throws IllegalStateException
Obtain the primary key of the EJB object that is currently associated with this instance.

An instance of an entity enterprise Bean can call this method only when the instance is associated with an EJB object identity, i.e. in the ejbActivate, ejbPassivate, ejbPostCreate, ejbRemove, ejbLoad, ejbStore, and business methods.

Note: The result of this method is that same as the result of getEJBObject().getPrimaryKey().

Returns:
The primary key currently associated with the instance.
Throws:
IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FinderException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class FinderException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.ejb.FinderException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ObjectNotFoundException
public class FinderException
extends Exception

The FinderException exception must be included in the throws clause of every findMETHOD(...) method of an entity Bean's home interface.

The exception is used as a standard application-level exception to report a failure to find the requested EJB object(s).

See Also:
Serialized Form

Constructor Summary
FinderException()
Constructs an FinderException with no detail message.
FinderException(String message)
Constructs an FinderException with the specified detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FinderException

public FinderException()
Constructs an FinderException with no detail message.

FinderException

public FinderException(String message)
Constructs an FinderException with the specified detail message.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Handle

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface Handle

All Superinterfaces:
Serializable
public interface Handle
extends Serializable

The Handle interface is implemented by all EJB object handles. A handle is an abstraction of a network reference to an EJB object. A handle is intended to be used as a "robust" persistent reference to an EJB object.

Method Summary
 EJBObject getEJBObject()
Obtain the EJB object reference represented by this handle.

Method Detail

getEJBObject

public EJBObject getEJBObject()
                       throws RemoteException
Obtain the EJB object reference represented by this handle.

Returns:
the EJB object reference represented by this handle.
Throws:
RemoteException - The EJB object could not be obtained because of a system-level failure.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HomeHandle

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface HomeHandle

All Superinterfaces:
Serializable
public interface HomeHandle
extends Serializable

The HomeHandle interface is implemented by all home object handles. A handle is an abstraction of a network reference to a home object. A handle is intended to be used as a "robust" persistent reference to a home object.

Method Summary
 EJBHome getEJBHome()
Obtain the home object represented by this handle.

Method Detail

getEJBHome

public EJBHome getEJBHome()
                   throws RemoteException
Obtain the home object represented by this handle.

Returns:
the home object represented by this handle.
Throws:
RemoteException - The home object could not be obtained because of a system-level failure.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageDrivenBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface MessageDrivenBean

All Superinterfaces:
EnterpriseBean, Serializable
public interface MessageDrivenBean
extends EnterpriseBean

The MessageDrivenBean interface is implemented by every message-driven enterprise Bean class. The container uses the MessageDrivenBean methods to notify the enterprise Bean instances of the instance's life cycle events.

Method Summary
void | ejbRemove() A container invokes this method before it ends the life of the message-driven object.
void | setMessageDrivenContext(MessageDrivenContext ctx) Set the associated message-driven context.

Method Detail

setMessageDrivenContext

public void setMessageDrivenContext(MessageDrivenContext ctx)
                             throws EJBException
Set the associated message-driven context. The container calls this method after the instance creation.

The enterprise Bean instance should store the reference to the context object in an instance variable.

This method is called with no transaction context.

Parameters:
ctx - A MessageDrivenContext interface for the instance.
Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.

ejbRemove

public void ejbRemove()
               throws EJBException
A container invokes this method before it ends the life of the message-driven object. This happens when a container decides to terminate the message-driven object.

This method is called with no transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NoSuchEntityException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class NoSuchEntityException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.ejb.EJBException
                    extended by javax.ejb.NoSuchEntityException
All Implemented Interfaces:
Serializable
public class NoSuchEntityException
extends EJBException

The NoSuchEntityException exception is thrown by an Entity Bean instance to its container to report that the invoked business method or callback method could not be completed because of the underlying entity was removed from the database.

This exception may be thrown by the bean class methods that implement the business methods defined in the bean's component interface; and by the ejbLoad and ejbStore methods.

See Also:
Serialized Form

Constructor Summary
NoSuchEntityException()
Constructs a NoSuchEntityException with no detail message.
NoSuchEntityException(Exception ex)
Constructs a NoSuchEntityException that embeds the originally thrown exception.
NoSuchEntityException(String message)
Constructs a NoSuchEntityException with the specified detailed message.
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoSuchEntityException

public NoSuchEntityException()
Constructs a NoSuchEntityException with no detail message.

NoSuchEntityException

public NoSuchEntityException(String message)
Constructs a NoSuchEntityException with the specified detailed message.

NoSuchEntityException

public NoSuchEntityException(Exception ex)
Constructs a NoSuchEntityException that embeds the originally thrown exception.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NoSuchObjectLocalException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class NoSuchObjectLocalException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.ejb.EJBException
                    extended by javax.ejb.NoSuchObjectLocalException
All Implemented Interfaces:
Serializable
public class NoSuchObjectLocalException
extends EJBException

A NoSuchObjectLocalException is thrown if an attempt is made to invoke a method on an object that no longer exists.

See Also:
Serialized Form

Constructor Summary
NoSuchObjectLocalException()
Constructs a NoSuchObjectLocalException with no detail message.
NoSuchObjectLocalException(String message)
Constructs a NoSuchObjectLocalException with the specified detail message.
NoSuchObjectLocalException(String message, Exception ex)
Constructs a NoSuchObjectLocalException with the specified detail message and a nested exception.
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoSuchObjectLocalException

public NoSuchObjectLocalException()
Constructs a NoSuchObjectLocalException with no detail message.

NoSuchObjectLocalException

public NoSuchObjectLocalException(String message)
Constructs a NoSuchObjectLocalException with the specified detail message.

NoSuchObjectLocalException

public NoSuchObjectLocalException(String message,
                                  Exception ex)
Constructs a NoSuchObjectLocalException with the specified detail message and a nested exception.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ObjectNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class ObjectNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.ejb.FinderException
                extended by javax.ejb.ObjectNotFoundException
All Implemented Interfaces:
Serializable
public class ObjectNotFoundException
extends FinderException

The ObjectNotFoundException exception is thrown by a finder method to indicate that the specified EJB object does not exist.

Only the finder methods that are declared to return a single EJB object use this exception. This exception should not be thrown by finder methods that return a collection of EJB objects (they should return an empty collection instead).

See Also:
Serialized Form

Constructor Summary
ObjectNotFoundException()
Constructs an ObjectNotFoundException with no detail message.
ObjectNotFoundException(String message)
Constructs an ObjectNotFoundException with the specified detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ObjectNotFoundException

public ObjectNotFoundException()
Constructs an ObjectNotFoundException with no detail message.

ObjectNotFoundException

public ObjectNotFoundException(String message)
Constructs an ObjectNotFoundException with the specified detail message.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RemoveException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class RemoveException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.ejb.RemoveException
All Implemented Interfaces:
Serializable
public class RemoveException
extends Exception

The RemoveException exception is thrown at an attempt to remove an EJB object when the enterprise Bean or the container does not allow the EJB object to be removed.

See Also:
Serialized Form

Constructor Summary
RemoveException()
Constructs an RemoveException with no detail message.
RemoveException(String message)
Constructs an RemoveException with the specified detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RemoveException

public RemoveException()
Constructs an RemoveException with no detail message.

RemoveException

public RemoveException(String message)
Constructs an RemoveException with the specified detail message.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SessionBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface SessionBean

All Superinterfaces:
EnterpriseBean, Serializable
public interface SessionBean
extends EnterpriseBean

The SessionBean interface is implemented by every session enterprise Bean class. The container uses the SessionBean methods to notify the enterprise Bean instances of the instance's life cycle events.

Method Summary
void | ejbActivate() The activate method is called when the instance is activated from its "passive" state.
void | ejbPassivate() The passivate method is called before the instance enters the "passive" state.
void | ejbRemove() A container invokes this method before it ends the life of the session object.
void | setSessionContext(SessionContext ctx) Set the associated session context.

Method Detail

setSessionContext

public void setSessionContext(SessionContext ctx)
                       throws EJBException,
                              RemoteException
Set the associated session context. The container calls this method after the instance creation.

The enterprise Bean instance should store the reference to the context object in an instance variable.

This method is called with no transaction context.

Parameters:
ctx - A SessionContext interface for the instance.
Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for applications written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbRemove

public void ejbRemove()
               throws EJBException,
                      RemoteException
A container invokes this method before it ends the life of the session object. This happens as a result of a client's invoking a remove operation, or when a container decides to terminate the session object after a timeout.

This method is called with no transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbActivate

public void ejbActivate()
                 throws EJBException,
                        RemoteException
The activate method is called when the instance is activated from its "passive" state. The instance should acquire any resource that it has released earlier in the ejbPassivate() method.

This method is called with no transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbPassivate

public void ejbPassivate()
                  throws EJBException,
                         RemoteException
The passivate method is called before the instance enters the "passive" state. The instance should release any resources that it can re-acquire later in the ejbActivate() method.

After the passivate method completes, the instance must be in a state that allows the container to use the Java Serialization protocol to externalize and store away the instance's state.

This method is called with no transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SessionContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface SessionContext

All Superinterfaces:
EJBContext
public interface SessionContext
extends EJBContext

The SessionContext interface provides access to the runtime session context that the container provides for a session enterprise Bean instance. The container passes the SessionContext interface to an instance after the instance has been created. The session context remains associated with the instance for the lifetime of the instance.

Method Summary
EJBLocalObject | getEJBLocalObject() Obtain a reference to the EJB local object that is associated with the instance.
EJBObject | getEJBObject() Obtain a reference to the EJB object that is currently associated with the instance.
MessageContext | getMessageContext() Obtain a reference to the JAX-RPC MessageContext.
Methods inherited from interface javax.ejb.EJBContext
getCallerIdentity, getCallerPrincipal, getEJBHome, getEJBLocalHome, getEnvironment, getRollbackOnly, getTimerService, getUserTransaction, isCallerInRole, isCallerInRole, setRollbackOnly

Method Detail

getEJBLocalObject

public EJBLocalObject getEJBLocalObject()
                                 throws IllegalStateException
Obtain a reference to the EJB local object that is associated with the instance.

An instance of a session enterprise Bean can call this method at anytime between the ejbCreate() and ejbRemove() methods, including from within the ejbCreate() and ejbRemove() methods.

An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

Returns:
The EJB local object currently associated with the instance.
Throws:
IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a local interface.

getEJBObject

public EJBObject getEJBObject()
                       throws IllegalStateException
Obtain a reference to the EJB object that is currently associated with the instance.

An instance of a session enterprise Bean can call this method at anytime between the ejbCreate() and ejbRemove() methods, including from within the ejbCreate() and ejbRemove() methods.

An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

Returns:
The EJB object currently associated with the instance.
Throws:
IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a remote interface.

getMessageContext

public MessageContext getMessageContext()
                                 throws IllegalStateException
Obtain a reference to the JAX-RPC MessageContext.

An instance of a stateless session bean can call this method from any business method invoked through its web service endpoint interface.

Returns:
The MessageContext for this web service invocation.
Throws:
IllegalStateException - Thrown if this method is invoked while the instance is in a state that does not allow access to this method.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SessionSynchronization

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface SessionSynchronization

public interface SessionSynchronization

The SessionSynchronization interface allows a session Bean instance to be notified by its container of transaction boundaries.

An session Bean class is not required to implement this interface. A session Bean class should implement this interface only if it wishes to synchronize its state with the transactions.

Method Summary
void | afterBegin() The afterBegin method notifies a session Bean instance that a new transaction has started, and that the subsequent business methods on the instance will be invoked in the context of the transaction.
void | afterCompletion(boolean committed) The afterCompletion method notifies a session Bean instance that a transaction commit protocol has completed, and tells the instance whether the transaction has been committed or rolled back.
void | beforeCompletion() The beforeCompletion method notifies a session Bean instance that a transaction is about to be committed.

Method Detail

afterBegin

public void afterBegin()
                throws EJBException,
                       RemoteException
The afterBegin method notifies a session Bean instance that a new transaction has started, and that the subsequent business methods on the instance will be invoked in the context of the transaction.

The instance can use this method, for example, to read data from a database and cache the data in the instance fields.

This method executes in the proper transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 and higher specifications should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB 2.0 and higher specifications must not throw the java.rmi.RemoteException.

beforeCompletion

public void beforeCompletion()
                      throws EJBException,
                             RemoteException
The beforeCompletion method notifies a session Bean instance that a transaction is about to be committed. The instance can use this method, for example, to write any cached data to a database.

This method executes in the proper transaction context.

Note: The instance may still cause the container to rollback the transaction by invoking the setRollbackOnly() method on the instance context, or by throwing an exception.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 and higher specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB 2.0 and higher specifications must not throw the java.rmi.RemoteException.

afterCompletion

public void afterCompletion(boolean committed)
                     throws EJBException,
                            RemoteException
The afterCompletion method notifies a session Bean instance that a transaction commit protocol has completed, and tells the instance whether the transaction has been committed or rolled back.

This method executes with no transaction context.

This method executes with no transaction context.

Parameters:
committed - True if the transaction has been committed, false if is has been rolled back.
Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 and higher specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB 2.0 and higher specifications must not throw the java.rmi.RemoteException.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


spi

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.ejb.spi

The javax.ejb.spi package defines interfaces that are implemented by the EJB container.

See:
Description

Interface Summary
HandleDelegate The HandleDelegate interface is implemented by the EJB container.

Package javax.ejb.spi Description

The javax.ejb.spi package defines interfaces that are implemented by the EJB container. These interfaces are not used by application components.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.ejb.spi Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.ejb.spi

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface javax.ejb.spi.HandleDelegate
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HandleDelegate

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.ejb.spi
Interface HandleDelegate

public interface HandleDelegate

The HandleDelegate interface is implemented by the EJB container. It is used by portable implementations of javax.ejb.Handle and javax.ejb.HomeHandle. It is not used by EJB components or by client components. It provides methods to serialize and deserialize EJBObject and EJBHome references to streams.

The HandleDelegate object is obtained by JNDI lookup at the reserved name "java:comp/HandleDelegate".

Method Summary
EJBHome | readEJBHome(ObjectInputStream istream) Deserialize the EJBHome reference corresponding to a HomeHandle.
EJBObject | readEJBObject(ObjectInputStream istream) Deserialize the EJBObject reference corresponding to a Handle.
void | writeEJBHome(EJBHome ejbHome, ObjectOutputStream ostream) Serialize the EJBHome reference corresponding to a HomeHandle.
void | writeEJBObject(EJBObject ejbObject, ObjectOutputStream ostream) Serialize the EJBObject reference corresponding to a Handle.

Method Detail

writeEJBObject

public void writeEJBObject(EJBObject ejbObject,
                           ObjectOutputStream ostream)
                    throws IOException
Serialize the EJBObject reference corresponding to a Handle.

This method is called from the writeObject method of portable Handle implementation classes. The ostream object is the same object that was passed in to the Handle class's writeObject.

Parameters:
ejbObject - The EJBObject reference to be serialized.
ostream - The output stream.
Throws:
IOException - The EJBObject could not be serialized because of a system-level failure.

readEJBObject

public EJBObject readEJBObject(ObjectInputStream istream)
                        throws IOException,
                               ClassNotFoundException
Deserialize the EJBObject reference corresponding to a Handle.

readEJBObject is called from the readObject method of portable Handle implementation classes. The istream object is the same object that was passed in to the Handle class's readObject. When readEJBObject is called, istream must point to the location in the stream at which the EJBObject reference can be read. The container must ensure that the EJBObject reference is capable of performing invocations immediately after deserialization.

Parameters:
istream - The input stream.
Returns:
The deserialized EJBObject reference.
Throws:
IOException - The EJBObject could not be deserialized because of a system-level failure.
ClassNotFoundException - The EJBObject could not be deserialized because some class could not be found.

writeEJBHome

public void writeEJBHome(EJBHome ejbHome,
                         ObjectOutputStream ostream)
                  throws IOException
Serialize the EJBHome reference corresponding to a HomeHandle.

This method is called from the writeObject method of portable HomeHandle implementation classes. The ostream object is the same object that was passed in to the Handle class's writeObject.

Parameters:
ejbHome - The EJBHome reference to be serialized.
ostream - The output stream.
Throws:
IOException - The EJBObject could not be serialized because of a system-level failure.

readEJBHome

public EJBHome readEJBHome(ObjectInputStream istream)
                    throws IOException,
                           ClassNotFoundException
Deserialize the EJBHome reference corresponding to a HomeHandle.

readEJBHome is called from the readObject method of portable HomeHandle implementation classes. The istream object is the same object that was passed in to the HomeHandle class's readObject. When readEJBHome is called, istream must point to the location in the stream at which the EJBHome reference can be read. The container must ensure that the EJBHome reference is capable of performing invocations immediately after deserialization.

Parameters:
istream - The input stream.
Returns:
The deserialized EJBHome reference.
Throws:
IOException - The EJBHome could not be deserialized because of a system-level failure.
ClassNotFoundException - The EJBHome could not be deserialized because some class could not be found.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TimedObject

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface TimedObject

public interface TimedObject

The TimedObject interface contains the callback method that is used to deliver timer expiration notifications. It is implemented by an entity bean or stateless session bean or message-driven bean class.

Method Summary
 void ejbTimeout(Timer timer)
Invoked by the EJB container upon timer expiration.

Method Detail

ejbTimeout

public void ejbTimeout(Timer timer)
Invoked by the EJB container upon timer expiration.

Parameters:
timer - timer whose expiration caused this notification.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Timer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface Timer

public interface Timer

The Timer interface contains information about a timer that was created through the EJB Timer Service.

Method Summary
void | cancel() Cause the timer and all its associated expiration notifications to be cancelled.
TimerHandle | getHandle() Get a serializable handle to the timer.
Serializable | getInfo() Get the information associated with the timer at the time of creation.
Date | getNextTimeout() Get the point in time at which the next timer expiration is scheduled to occur.
long | getTimeRemaining() Get the number of milliseconds that will elapse before the next scheduled timer expiration.

Method Detail

cancel

public void cancel()
            throws IllegalStateException,
                   NoSuchObjectLocalException,
                   EJBException
Cause the timer and all its associated expiration notifications to be cancelled.

Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.

getTimeRemaining

public long getTimeRemaining()
                      throws IllegalStateException,
                             NoSuchObjectLocalException,
                             EJBException
Get the number of milliseconds that will elapse before the next scheduled timer expiration.

Returns:
the number of milliseconds that will elapse before the next scheduled timer expiration.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.

getNextTimeout

public Date getNextTimeout()
                    throws IllegalStateException,
                           NoSuchObjectLocalException,
                           EJBException
Get the point in time at which the next timer expiration is scheduled to occur.

Returns:
the point in time at which the next timer expiration is scheduled to occur.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.

getInfo

public Serializable getInfo()
                     throws IllegalStateException,
                            NoSuchObjectLocalException,
                            EJBException
Get the information associated with the timer at the time of creation.

Returns:
The Serializable object that was passed in at timer creation, or null if the info argument passed in at timer creation was null.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.

getHandle

public TimerHandle getHandle()
                      throws IllegalStateException,
                             NoSuchObjectLocalException,
                             EJBException
Get a serializable handle to the timer. This handle can be used at a later time to re-obtain the timer reference.

Returns:
a serializable handle to the timer.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TimerHandle

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface TimerHandle

All Superinterfaces:
Serializable
public interface TimerHandle
extends Serializable

The TimerHandle interface is implemented by all EJB timer handles.

Method Summary
 Timer getTimer()
Obtain a reference to the timer represented by this handle.

Method Detail

getTimer

public Timer getTimer()
               throws IllegalStateException,
                      NoSuchObjectLocalException,
                      EJBException
Obtain a reference to the timer represented by this handle.

Returns:
a reference to the timer represented by this handle.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a handle whose associated timer has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TimerService

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface TimerService

public interface TimerService

The TimerService interface provides enterprise bean components with access to the container-provided Timer Service. The EJB Timer Service allows entity beans, stateless session beans, and message-driven beans to be registered for timer callback events at a specified time, after a specified elapsed time, or after a specified interval.

Method Summary
Timer | createTimer(Date initialExpiration, long intervalDuration, Serializable info) Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
Timer | createTimer(Date expiration, Serializable info) Create a single-action timer that expires at a given point in time.
Timer | createTimer(long initialDuration, long intervalDuration, Serializable info) Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
Timer | createTimer(long duration, Serializable info) Create a single-action timer that expires after a specified duration.
Collection | getTimers() Get all the active timers associated with this bean.

Method Detail

createTimer

public Timer createTimer(long duration,
                         Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
Create a single-action timer that expires after a specified duration.

Parameters:
duration - The number of milliseconds that must elapse before the timer expires.
info - Application information to be delivered along with the timer expiration notification. This can be null.
Returns:
The newly created Timer.
Throws:
IllegalArgumentException - If duration is negative
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
EJBException - If this method fails due to a system-level failure.

createTimer

public Timer createTimer(long initialDuration,
                         long intervalDuration,
                         Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.

Parameters:
initialDuration - The number of milliseconds that must elapse before the first timer expiration notification.
intervalDuration - The number of milliseconds that must elapse between timer expiration notifications. Expiration notifications are scheduled relative to the time of the first expiration. If expiration is delayed(e.g. due to the interleaving of other method calls on the bean) two or more expiration notifications may occur in close succession to "catch up".
info - Application information to be delivered along with the timer expiration. This can be null.
Returns:
The newly created Timer.
Throws:
IllegalArgumentException - If initialDuration is negative, or intervalDuration is negative.
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
EJBException - If this method could not complete due to a system-level failure.

createTimer

public Timer createTimer(Date expiration,
                         Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
Create a single-action timer that expires at a given point in time.

Parameters:
expiration - The point in time at which the timer must expire.
info - Application information to be delivered along with the timer expiration notification. This can be null.
Returns:
The newly created Timer.
Throws:
IllegalArgumentException - If expiration is null, or expiration.getTime() is negative.
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
EJBException - If this method could not complete due to a system-level failure.

createTimer

public Timer createTimer(Date initialExpiration,
                         long intervalDuration,
                         Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.

Parameters:
initialExpiration - The point in time at which the first timer expiration must occur.
intervalDuration - The number of milliseconds that must elapse between timer expiration notifications. Expiration notifications are scheduled relative to the time of the first expiration. If expiration is delayed(e.g. due to the interleaving of other method calls on the bean) two or more expiration notifications may occur in close succession to "catch up".
info - Application information to be delivered along with the timer expiration. This can be null.
Returns:
The newly created Timer.
Throws:
IllegalArgumentException - If initialExpiration is null, or initialExpiration.getTime() is negative, or intervalDuration is negative.
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
EJBException - If this method could not complete due to a system-level failure.

getTimers

public Collection getTimers()
                     throws IllegalStateException,
                            EJBException
Get all the active timers associated with this bean.

Returns:
A collection of javax.ejb.Timer objects.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
EJBException - If this method could not complete due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransactionRequiredLocalException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class TransactionRequiredLocalException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.ejb.EJBException
                    extended by javax.ejb.TransactionRequiredLocalException
All Implemented Interfaces:
Serializable
public class TransactionRequiredLocalException
extends EJBException

This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.

See Also:
Serialized Form

Constructor Summary
TransactionRequiredLocalException()
Constructs a TransactionRequiredLocalException with no detail message.
TransactionRequiredLocalException(String message)
Constructs an TransactionRequiredLocalException with the specified detailed message.
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRequiredLocalException

public TransactionRequiredLocalException()
Constructs a TransactionRequiredLocalException with no detail message.

TransactionRequiredLocalException

public TransactionRequiredLocalException(String message)
Constructs an TransactionRequiredLocalException with the specified detailed message.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransactionRolledbackLocalException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class TransactionRolledbackLocalException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.ejb.EJBException
                    extended by javax.ejb.TransactionRolledbackLocalException
All Implemented Interfaces:
Serializable
public class TransactionRolledbackLocalException
extends EJBException

This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back. Thus the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless

See Also:
Serialized Form

Constructor Summary
TransactionRolledbackLocalException()
Constructs a TransactionRolledbackLocalException with no detail message.
TransactionRolledbackLocalException(String message)
Constructs a TransactionRolledbackLocalException with the specified detailed message.
TransactionRolledbackLocalException(String message, Exception ex)
Constructs a TransactionRolledbackLocalException with the specified detail message and a nested exception.
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRolledbackLocalException

public TransactionRolledbackLocalException()
Constructs a TransactionRolledbackLocalException with no detail message.

TransactionRolledbackLocalException

public TransactionRolledbackLocalException(String message)
Constructs a TransactionRolledbackLocalException with the specified detailed message.

TransactionRolledbackLocalException

public TransactionRolledbackLocalException(String message,
                                           Exception ex)
Constructs a TransactionRolledbackLocalException with the specified detail message and a nested exception.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


model

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.model

Provides Tool Vendor implementation classes.

See:
Description

Interface Summary
DDBean | An interface for beans that represent a fragment of a standard deployment descriptor.
DDBeanRoot | An interface that represents the root of a standard deployment descriptor.
DeployableObject | The DeployableObject interface is an abstract representation of a J2EE deployable module (JAR, WAR, RAR, EAR).
J2eeApplicationObject | J2eeApplicationObject is an interface that represents a J2EE application (EAR); it maintains a DeployableObject for each module in the archive.
XpathListener | The listener interface for receiving XpathEvents

Class Summary
XpathEvent An Event class describing ConfigBeans being added/subtracted from a server configuration.

Package javax.enterprise.deploy.model Description

Provides Tool Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.model Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.model

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.enterprise.deploy.model.XpathEvent

Interface Hierarchy

  • interface javax.enterprise.deploy.model.DDBean
    • interface javax.enterprise.deploy.model.DDBeanRoot
  • interface javax.enterprise.deploy.model.DeployableObject
    • interface javax.enterprise.deploy.model.J2eeApplicationObject
  • interface javax.enterprise.deploy.model.XpathListener
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DDBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Interface DDBean

All Known Subinterfaces:
DDBeanRoot
public interface DDBean

An interface for beans that represent a fragment of a standard deployment descriptor. A link is provided to the J2EE application that includes this bean.

Method Summary
void | addXpathListener(String xpath, XpathListener xpl) Register a listener for a specific XPath.
String[] | getAttributeNames() Returns the list of attribute names associated with the XML element.
String | getAttributeValue(String attrName) Returns the string value of the named attribute.
DDBean[] | getChildBean(String xpath) Return a list of DDBeans based upon the XPath.
String | getId() Returns a tool-specific reference for attribute ID on an element in the deployment descriptor.
DDBeanRoot | getRoot() Return the root element for this DDBean.
String | getText() Returns the XML text for by this bean.
String[] | getText(String xpath) Return a list of text values for a given XPath in the deployment descriptor.
String | getXpath() Returns the original xpath string provided by the DConfigBean.
void | removeXpathListener(String xpath, XpathListener xpl) Unregister a listener for a specific XPath.

Method Detail

getXpath

public String getXpath()
Returns the original xpath string provided by the DConfigBean.

Returns:
The XPath of this Bean.

getText

public String getText()
Returns the XML text for by this bean.

Returns:
The XML text for this Bean.

getId

public String getId()
Returns a tool-specific reference for attribute ID on an element in the deployment descriptor. This attribute is defined for J2EE 1.2 and 1.3 components.

Returns:
The XML text for this Bean or 'null' if no attribute was specifed with the tag.

getRoot

public DDBeanRoot getRoot()
Return the root element for this DDBean.

Returns:
The DDBeanRoot at the root of this DDBean tree.

getChildBean

public DDBean[] getChildBean(String xpath)
Return a list of DDBeans based upon the XPath.

Parameters:
xpath - An XPath string referring to a location in the same deployment descriptor as this standard bean.
Returns:
a list of DDBeans or 'null' if no matching XML data is found.

getText

public String[] getText(String xpath)
Return a list of text values for a given XPath in the deployment descriptor.

Parameters:
xpath - An XPath.
Returns:
The list text values for this XPath or 'null' if no matching XML data is found.

addXpathListener

public void addXpathListener(String xpath,
                             XpathListener xpl)
Register a listener for a specific XPath.

Parameters:
xpath - The XPath this listener is to be registered for.
xpl - The listener object.

removeXpathListener

public void removeXpathListener(String xpath,
                                XpathListener xpl)
Unregister a listener for a specific XPath.

Parameters:
xpath - The XPath from which this listener is to be unregistered.
xpl - The listener object.

getAttributeNames

public String[] getAttributeNames()
Returns the list of attribute names associated with the XML element.

Returns:
a list of attribute names on this element. Null is returned if there are no attributes.

getAttributeValue

public String getAttributeValue(String attrName)
Returns the string value of the named attribute.

Returns:
a the value of the attribute. Null is returned if there is no such attribute.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DDBeanRoot

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Interface DDBeanRoot

All Superinterfaces:
DDBean
public interface DDBeanRoot
extends DDBean

An interface that represents the root of a standard deployment descriptor. A DDBeanRoot is a type of DDBean.

Author:
gfink

Method Summary
 String getDDBeanRootVersion()
Returns the version number of an XML instance document.
 DeployableObject getDeployableObject()
Return the containing DeployableObject
 String getFilename()
Returns the filename relative to the root of the module of the XML instance document this DDBeanRoot represents.
 String getModuleDTDVersion()
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
 ModuleType getType()
Return the ModuleType of deployment descriptor.
 String getXpath()
Return the XPath for this standard bean.
Methods inherited from interface javax.enterprise.deploy.model.DDBean
addXpathListener, getAttributeNames, getAttributeValue, getChildBean, getId, getRoot, getText, getText, removeXpathListener

Method Detail

getType

public ModuleType getType()
Return the ModuleType of deployment descriptor.

Returns:
The ModuleType of deployment descriptor

getDeployableObject

public DeployableObject getDeployableObject()
Return the containing DeployableObject

Returns:
The DeployableObject that contains this deployment descriptor

getModuleDTDVersion

public String getModuleDTDVersion()
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()

A convenience method to return the DTD version number. The DeployableObject has this information.

Returns:
a string containing the DTD version number This method is being deprecated. Two DD data formats are being used, DTD and XML Schema. DDBeanRoot.getDDBeanRootVersion should be used in its place.

getDDBeanRootVersion

public String getDDBeanRootVersion()
Returns the version number of an XML instance document. This method is replacing the methods DDBeanRoot.getModuleDTDVersion and DeployableObject.getModuleDTDVersion. This method returns the version number of any J2EE XML instance document.

Returns:
a string that is the version number of the XML instance document. Null is returned if no version number can be found.

getXpath

public String getXpath()
Return the XPath for this standard bean. The root XPath is "/".

Specified by:
getXpath in interface DDBean
Returns:
"/" this is the root standard bean.

getFilename

public String getFilename()
Returns the filename relative to the root of the module of the XML instance document this DDBeanRoot represents.

Returns:
String the filename relative to the root of the module
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeployableObject

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Interface DeployableObject

All Known Subinterfaces:
J2eeApplicationObject
public interface DeployableObject

The DeployableObject interface is an abstract representation of a J2EE deployable module (JAR, WAR, RAR, EAR). A DeployableObject provides access to the module's deployment descriptor and class files.

Version:
0.1
Author:
gfink

Method Summary
 Enumeration entries()
Returns an enumeration of the module file entries.
 DDBean[] getChildBean(String xpath)
Return an array of standard beans representing the XML content returned based upon the XPath.
 Class getClassFromScope(String className)
Retrieve the specified class from this deployable module.
 DDBeanRoot getDDBeanRoot()
Return the top level standard bean representing the root of the deployment descriptor.
 DDBeanRoot getDDBeanRoot(String filename)
Returns a DDBeanRoot object for the XML instance document named.
 InputStream getEntry(String name)
Returns the InputStream for the given entry name The file name must be relative to the root of the module.
 String getModuleDTDVersion()
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
 String[] getText(String xpath)
Return the XML content associated with the XPath from a deployment descriptor.
 ModuleType getType()
Return the ModuleType of deployment descriptor (i.e., EAR, JAR, WAR, RAR) this deployable object represents.

Method Detail

getType

public ModuleType getType()
Return the ModuleType of deployment descriptor (i.e., EAR, JAR, WAR, RAR) this deployable object represents. Values are found in DeploymentManager.

Returns:
The ModuleType of deployable object

getDDBeanRoot

public DDBeanRoot getDDBeanRoot()
Return the top level standard bean representing the root of the deployment descriptor.

Returns:
A standard bean representing the deployment descriptor.

getChildBean

public DDBean[] getChildBean(String xpath)
Return an array of standard beans representing the XML content returned based upon the XPath.

Parameters:
xpath - An XPath string identifying the data to be extracted from the deployment descriptor.
Returns:
a array of DDBeans or 'null' if no matching data found.

getText

public String[] getText(String xpath)
Return the XML content associated with the XPath from a deployment descriptor.

Parameters:
xpath - An xpath string referring to a location in the deployment descriptor
Returns:
a list XML content or 'null' if no matching data found.

getClassFromScope

public Class getClassFromScope(String className)
Retrieve the specified class from this deployable module.

One use: to get all finder methods from an EJB If the tool is attempting to package an module and retrieve a class from the package, the class request may fail. The class may not yet be available. The tool should respect the manifest cross-path entries.

Parameters:
className - Class to retrieve.
Returns:
Class representation of the class

getModuleDTDVersion

public String getModuleDTDVersion()
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()

Returns the DTD version number given in the XML DOCTYPE text provided in every standard J2EE module's deployment descriptor file.

Returns:
a string containing the DTD version number
 A module's deployment descriptor file always contains
 a document type identifier, DOCTYPE.  The DOCTYPE statement
 contains the module DTD version number in the label of the
 statement.

     The format of the DOCTYPE statement is:

    <!DOCTYPE root_element PUBLIC
    "-//organization//label//language" "location">

 root_element - is the name of the root document in the DTD.
 organization  - is the name of the organization responsible
                 for the creation and maintenance of the DTD
                 being referenced.
 label - is a unique descriptive name for the public text being
                 referenced.
 language - is the ISO 639 language id representing the natural
                 language encoding of th DTD.
 location - is the URL of the DTD.

 An example J2EE deployment descriptor DOCTYPE statement is:

   <!DOCTYPE application-client PUBLIC
   "-//Sun Microsystems, Inc.//DTD J2EE Application Client 1.3//EN"
   "http://java.sun.com/dtd/application-client_1_3.dtd">

 In this example the label is, "DTD J2EE Application Client 1.3",
 and the DTD version number is 1.3. A call to getModuleDTDVersion
 would return a string containing, "1.3".
This method is being deprecated. With the addition of multiple deployment descritors in components for J2EE 1.4 this method is being replaced by DDBeanRoot.getDDBeanRootVersion.

getDDBeanRoot

public DDBeanRoot getDDBeanRoot(String filename)
                         throws FileNotFoundException,
                                javax.enterprise.deploy.model.exceptions.DDBeanCreateException
Returns a DDBeanRoot object for the XML instance document named. This method should be used to return DDBeanRoot objects for non deployment descriptor XML instance documents such as WSDL files.

Returns:
a DDBeanRoot object for the XML data.
Throws:
java.io.FileNotFoundException, - if the named file can not be found
javax.enterprise.deploy.model.exceptions.DDBeanCreateException - if an error is encountered creating the DDBeanRoot object.
FileNotFoundException

entries

public Enumeration entries()
Returns an enumeration of the module file entries. All elements in the enumeration are of type String. Each String represents a file name relative to the root of the module.

Returns:
an enumeration of the archive file entries.

getEntry

public InputStream getEntry(String name)
Returns the InputStream for the given entry name The file name must be relative to the root of the module.

Parameters:
name - the file name relative to the root of the module.
Returns:
the InputStream for the given entry name or null if not found.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


J2eeApplicationObject

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Interface J2eeApplicationObject

All Superinterfaces:
DeployableObject
public interface J2eeApplicationObject
extends DeployableObject

J2eeApplicationObject is an interface that represents a J2EE application (EAR); it maintains a DeployableObject for each module in the archive.

Method Summary
void | addXpathListener(ModuleType type, String xpath, XpathListener xpl) Register a listener for changes in XPath that are related to this deployableObject.
DDBean[] | getChildBean(ModuleType type, String xpath) Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.
DeployableObject | getDeployableObject(String uri) Return the DeployableObject of the specified URI designator.
DeployableObject[] | getDeployableObjects() Return the all DeployableObjects in this application.
DeployableObject[] | getDeployableObjects(ModuleType type) Return the all DeployableObjects of the specified type.
String[] | getModuleUris() Return the list of URIs for all modules in the application.
String[] | getModuleUris(ModuleType type) Return the list of URIs of the designated module type.
String[] | getText(ModuleType type, String xpath) Return the text value from the XPath; search only the deployment descriptors of the specified type.
void | removeXpathListener(ModuleType type, String xpath, XpathListener xpl) Unregister the listener for an XPath.
Methods inherited from interface javax.enterprise.deploy.model.DeployableObject
entries, getChildBean, getClassFromScope, getDDBeanRoot, getDDBeanRoot, getEntry, getModuleDTDVersion, getText, getType

Method Detail

getDeployableObject

public DeployableObject getDeployableObject(String uri)
Return the DeployableObject of the specified URI designator.

Parameters:
uri - Describes where to get the module from.
Returns:
the DeployableObject describing the j2ee module at this uri or 'null' if there is not match.

getDeployableObjects

public DeployableObject[] getDeployableObjects(ModuleType type)
Return the all DeployableObjects of the specified type.

Parameters:
type - The type of module to return.
Returns:
the list of DeployableObjects describing the j2ee module at this uri or 'null' if there are no matches.

getDeployableObjects

public DeployableObject[] getDeployableObjects()
Return the all DeployableObjects in this application.

Returns:
the DeployableObject describing the j2ee module at this uri or 'null' if there are no matches.

getModuleUris

public String[] getModuleUris(ModuleType type)
Return the list of URIs of the designated module type.

Parameters:
type - The type of module to return.
Returns:
the Uris of the contained modules or 'null' if there are no matches.

getModuleUris

public String[] getModuleUris()
Return the list of URIs for all modules in the application.

Returns:
the Uris of the contained modules or 'null' if there are no matches.

getChildBean

public DDBean[] getChildBean(ModuleType type,
                             String xpath)
Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.

Parameters:
type - The type of deployment descriptor to query.
xpath - An XPath string referring to a location in the deployment descriptor
Returns:
The list of DDBeans or 'null' of there are no matches.

getText

public String[] getText(ModuleType type,
                        String xpath)
Return the text value from the XPath; search only the deployment descriptors of the specified type.

Parameters:
type - The type of deployment descriptor to query.
xpath - An xpath string referring to a location in the deployment descriptor
Returns:
The text values of this xpath or 'null' if there are no matches.

addXpathListener

public void addXpathListener(ModuleType type,
                             String xpath,
                             XpathListener xpl)
Register a listener for changes in XPath that are related to this deployableObject.

Parameters:
type - The type of deployment descriptor to query.
xpath - The xpath to listen for.
xpl - The listener.

removeXpathListener

public void removeXpathListener(ModuleType type,
                                String xpath,
                                XpathListener xpl)
Unregister the listener for an XPath.

Parameters:
type - The type of deployment descriptor to query.
xpath - he XPath to listen for
xpl - The listener
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XpathEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Class XpathEvent

java.lang.Object
    extended by javax.enterprise.deploy.model.XpathEvent
public final class XpathEvent
extends Object

An Event class describing ConfigBeans being added/subtracted from a server configuration.

Field Summary
static Object | BEAN_ADDED Adding a DDBean
static Object | BEAN_CHANGED Changing a DDBean
static Object | BEAN_REMOVED Removing a DDBean
Constructor Summary
XpathEvent(DDBean bean, Object typ)
A description of a change in the ConfigBean tree.
Method Summary
DDBean | getBean() The bean being added/removed/changed.
PropertyChangeEvent | getChangeEvent()
boolean | isAddEvent() Is this an add event?
boolean | isChangeEvent() Is this a change event?
boolean | isRemoveEvent() Is this a remove event?
void | setChangeEvent(PropertyChangeEvent pce)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BEAN_ADDED

public static final Object BEAN_ADDED
Adding a DDBean

BEAN_REMOVED

public static final Object BEAN_REMOVED
Removing a DDBean

BEAN_CHANGED

public static final Object BEAN_CHANGED
Changing a DDBean

Constructor Detail

XpathEvent

public XpathEvent(DDBean bean,
                  Object typ)
A description of a change in the ConfigBean tree.

Parameters:
bean - The ConfigBean being added/removed.
typ - Indicates an add/remove event.
Method Detail

getChangeEvent

public PropertyChangeEvent getChangeEvent()

setChangeEvent

public void setChangeEvent(PropertyChangeEvent pce)

getBean

public DDBean getBean()
The bean being added/removed/changed.

Returns:
The bean being added/removed/changed.

isAddEvent

public boolean isAddEvent()
Is this an add event?

Returns:
true if this is an add event.

isRemoveEvent

public boolean isRemoveEvent()
Is this a remove event?

Returns:
true if this is a remove event.

isChangeEvent

public boolean isChangeEvent()
Is this a change event?

Returns:
true if this is a change event.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XpathListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Interface XpathListener

public interface XpathListener

The listener interface for receiving XpathEvents

Author:
gfink

Method Summary
 void fireXpathEvent(XpathEvent xpe)

Method Detail

fireXpathEvent

public void fireXpathEvent(XpathEvent xpe)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


shared

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.shared

Provides shared objects for Tool Vendor and Product Vendor implementation classes.

See:
Description

Class Summary
ActionType | Class ActionTypes defines enumeration values for the J2EE DeploymentStatus actions.
CommandType | Class CommandTypes defines enumeration values for the DeploymentStatus object.
DConfigBeanVersionType | Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.
ModuleType | Class ModuleTypes defines enumeration values for the J2EE module types.
StateType | Class StateTypes defines enumeration values for the DeploymentStatus object.

Package javax.enterprise.deploy.shared Description

Provides shared objects for Tool Vendor and Product Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.shared Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.shared

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.enterprise.deploy.shared.ActionType
    • class javax.enterprise.deploy.shared.CommandType
    • class javax.enterprise.deploy.shared.DConfigBeanVersionType
    • class javax.enterprise.deploy.shared.ModuleType
    • class javax.enterprise.deploy.shared.StateType
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ActionType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared
Class ActionType

java.lang.Object
    extended by javax.enterprise.deploy.shared.ActionType
public class ActionType
extends Object

Class ActionTypes defines enumeration values for the J2EE DeploymentStatus actions.

Author:
rsearls

Field Summary
static ActionType | CANCEL A cancel operation is being preformed on the DeploymentManager action command.
static ActionType | EXECUTE The DeploymentManager action command is executing.
static ActionType | STOP A stop operation is being preformed on the DeploymentManager action command.
Constructor Summary
protected ActionType(int value)
Construct a new enumeration value with the given integer value.
Method Summary
static ActionType | getActionType(int value) Return an object of the specified value.
protected ActionType[] | getEnumValueTable() Returns the enumeration value table for class ActionType
protected int | getOffset() Returns the lowest integer value used by this enumeration value's enumeration class.
protected String[] | getStringTable() Returns the string table for class ActionType
int | getValue() Returns this enumeration value's integer value.
String | toString() Return the string name of this ActionType or the integer value if outside the bounds of the table
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

EXECUTE

public static final ActionType EXECUTE
The DeploymentManager action command is executing.

CANCEL

public static final ActionType CANCEL
A cancel operation is being preformed on the DeploymentManager action command.

STOP

public static final ActionType STOP
A stop operation is being preformed on the DeploymentManager action command.

Constructor Detail

ActionType

protected ActionType(int value)
Construct a new enumeration value with the given integer value.

Parameters:
value - Integer value.
Method Detail

getValue

public int getValue()
Returns this enumeration value's integer value.

Returns:
the value

getStringTable

protected String[] getStringTable()
Returns the string table for class ActionType

getEnumValueTable

protected ActionType[] getEnumValueTable()
Returns the enumeration value table for class ActionType

getActionType

public static ActionType getActionType(int value)
Return an object of the specified value.

Parameters:
value - a designator for the object.

toString

public String toString()
Return the string name of this ActionType or the integer value if outside the bounds of the table

getOffset

protected int getOffset()
Returns the lowest integer value used by this enumeration value's enumeration class.

The default implementation returns 0.

Returns:
the offset of the lowest enumeration value.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CommandType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared
Class CommandType

java.lang.Object
    extended by javax.enterprise.deploy.shared.CommandType
public class CommandType
extends Object

Class CommandTypes defines enumeration values for the DeploymentStatus object.

Author:
rsearls

Field Summary
static CommandType | DISTRIBUTE The DeploymentManger action operation being processed is distribute.
static CommandType | REDEPLOY The DeploymentManger action operation being processed is redeploy.
static CommandType | START The DeploymentManger action operation being processed is start.
static CommandType | STOP The DeploymentManger action operation being processed is stop.
static CommandType | UNDEPLOY The DeploymentManger action operation being processed is undeploy.
Constructor Summary
protected CommandType(int value)
Construct a new enumeration value with the given integer value.
Method Summary
static CommandType | getCommandType(int value) Return an object of the specified value.
protected CommandType[] | getEnumValueTable() Returns the enumeration value table for class CommandType
protected int | getOffset() Returns the lowest integer value used by this enumeration value's enumeration class.
protected String[] | getStringTable() Returns the string table for class CommandType
int | getValue() Returns this enumeration value's integer value.
String | toString() Return the string name of this CommandType or the integer value if outside the bounds of the table
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

DISTRIBUTE

public static final CommandType DISTRIBUTE
The DeploymentManger action operation being processed is distribute.

START

public static final CommandType START
The DeploymentManger action operation being processed is start.

STOP

public static final CommandType STOP
The DeploymentManger action operation being processed is stop.

UNDEPLOY

public static final CommandType UNDEPLOY
The DeploymentManger action operation being processed is undeploy.

REDEPLOY

public static final CommandType REDEPLOY
The DeploymentManger action operation being processed is redeploy.

Constructor Detail

CommandType

protected CommandType(int value)
Construct a new enumeration value with the given integer value.

Parameters:
value - Integer value.
Method Detail

getValue

public int getValue()
Returns this enumeration value's integer value.

Returns:
the value

getStringTable

protected String[] getStringTable()
Returns the string table for class CommandType

getEnumValueTable

protected CommandType[] getEnumValueTable()
Returns the enumeration value table for class CommandType

getCommandType

public static CommandType getCommandType(int value)
Return an object of the specified value.

Parameters:
value - a designator for the object.

toString

public String toString()
Return the string name of this CommandType or the integer value if outside the bounds of the table

getOffset

protected int getOffset()
Returns the lowest integer value used by this enumeration value's enumeration class.

The default implementation returns 0.

Returns:
the offset of the lowest enumeration value.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DConfigBeanVersionType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared
Class DConfigBeanVersionType

java.lang.Object
    extended by javax.enterprise.deploy.shared.DConfigBeanVersionType
public class DConfigBeanVersionType
extends Object

Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.

Author:
rsearls

Field Summary
static DConfigBeanVersionType | V1_3 J2EE Platform version 1.3
static DConfigBeanVersionType | V1_3_1 J2EE Platform version 1.3.1 THIS CONSTANT SHOULD NEVER BE USED.
static DConfigBeanVersionType | V1_4 J2EE Platform version 1.4
Constructor Summary
protected DConfigBeanVersionType(int value)
Construct a new enumeration value with the given integer value.
Method Summary
static DConfigBeanVersionType | getDConfigBeanVersionType(int value) Return an object of the specified value.
protected DConfigBeanVersionType[] | getEnumValueTable() Returns the enumeration value table for class DConfigBeanVersionType
protected int | getOffset() Returns the lowest integer value used by this enumeration value's enumeration class.
protected String[] | getStringTable() Returns the string table for class DConfigBeanVersionType
int | getValue() Returns this enumeration value's integer value.
String | toString() Return the string name of this DConfigBeanVersionType or the integer value if outside the bounds of the table
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

V1_3

public static final DConfigBeanVersionType V1_3
J2EE Platform version 1.3

V1_3_1

public static final DConfigBeanVersionType V1_3_1
J2EE Platform version 1.3.1 THIS CONSTANT SHOULD NEVER BE USED. Use V1_3 instead.

V1_4

public static final DConfigBeanVersionType V1_4
J2EE Platform version 1.4

Constructor Detail

DConfigBeanVersionType

protected DConfigBeanVersionType(int value)
Construct a new enumeration value with the given integer value.

Parameters:
value - Integer value.
Method Detail

getValue

public int getValue()
Returns this enumeration value's integer value.

Returns:
the value

getStringTable

protected String[] getStringTable()
Returns the string table for class DConfigBeanVersionType

getEnumValueTable

protected DConfigBeanVersionType[] getEnumValueTable()
Returns the enumeration value table for class DConfigBeanVersionType

getDConfigBeanVersionType

public static DConfigBeanVersionType getDConfigBeanVersionType(int value)
Return an object of the specified value.

Parameters:
value - a designator for the object.

toString

public String toString()
Return the string name of this DConfigBeanVersionType or the integer value if outside the bounds of the table

getOffset

protected int getOffset()
Returns the lowest integer value used by this enumeration value's enumeration class.

The default implementation returns 0.

Returns:
the offset of the lowest enumeration value.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


factories

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.shared.factories

Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.

See:
Description

Class Summary
DeploymentFactoryManager The DeploymentFactoryManager class is a central registry for J2EE DeploymentFactory objects.

Package javax.enterprise.deploy.shared.factories Description

Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.shared.factories Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.shared.factories

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeploymentFactoryManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared.factories
Class DeploymentFactoryManager

java.lang.Object
    extended by javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
public final class DeploymentFactoryManager
extends Object

The DeploymentFactoryManager class is a central registry for J2EE DeploymentFactory objects. The DeploymentFactoryManager retains references to DeploymentFactory objects loaded by a tool. A DeploymentFactory object provides a reference to a DeploymentManager. The DeploymentFactoryManager has been implemented as a singleton. A tool gets a reference to the DeploymentFactoryManager via the getInstance method. The DeploymentFactoryManager can return two types of DeploymentManagers, a connected DeploymentManager and a disconnected DeploymentManager. The connected DeploymentManager provides access to any product resources that may be required for configurations and deployment. The method to retrieve a connected DeploymentManager is getDeploymentManager. This method provides parameters for user name and password that the product may require for user authentication. A disconnected DeploymentManager does not provide access to a running J2EE product. The method to retrieve a disconnected DeploymentManager is getDisconnectedDeploymentManager. A disconnected DeploymentManager does not need user authentication information.

Method Summary
DeploymentFactory[] | getDeploymentFactories() Retrieve the lists of currently registered DeploymentFactories.
DeploymentManager | getDeploymentManager(String uri, String username, String password) Retrieves a DeploymentManager instance to use for deployment.
DeploymentManager | getDisconnectedDeploymentManager(String uri) Return a disconnected DeploymentManager instance.
static DeploymentFactoryManager | getInstance() Retrieve the Singleton DeploymentFactoryManager
void | registerDeploymentFactory(DeploymentFactory factory) Registers a DeploymentFactory so it will be able to handle requests.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getInstance

public static DeploymentFactoryManager getInstance()
Retrieve the Singleton DeploymentFactoryManager

Returns:
DeploymentFactoryManager instance

getDeploymentFactories

public DeploymentFactory[] getDeploymentFactories()
Retrieve the lists of currently registered DeploymentFactories.

Returns:
the list of DeploymentFactory objects or an empty array if there are none.

getDeploymentManager

public DeploymentManager getDeploymentManager(String uri,
                                              String username,
                                              String password)
                                       throws DeploymentManagerCreationException
Retrieves a DeploymentManager instance to use for deployment. The caller provides a URI and optional username and password, and all registered DeploymentFactories will be checked. The first one to understand the URI provided will attempt to initiate a server connection and return a ready DeploymentManager instance.

Parameters:
uri - The uri to check
username - An optional username (may be null if no authentication is required for this platform).
password - An optional password (may be null if no authentication is required for this platform).
Returns:
A ready DeploymentManager instance.
Throws:
DeploymentManagerCreationException - Occurs when the factory appropriate to the specified URI was unable to initialize a DeploymentManager instance (server down, unable to authenticate, etc.).

registerDeploymentFactory

public void registerDeploymentFactory(DeploymentFactory factory)
Registers a DeploymentFactory so it will be able to handle requests.

getDisconnectedDeploymentManager

public DeploymentManager getDisconnectedDeploymentManager(String uri)
                                                   throws DeploymentManagerCreationException
Return a disconnected DeploymentManager instance.

Parameters:
uri - identifier of the disconnected DeploymentManager to return.
Returns:
A DeploymentManager instance.
Throws:
DeploymentDriverException - occurs if the DeploymentManager could not be created.
DeploymentManagerCreationException
Overview  Package   Class  Tree  Deprecated  Index  Help
JavaTM 2 Platform
Ent. Ed. v1.4
 PREV CLASS   NEXT CLASS | FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ModuleType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared
Class ModuleType

java.lang.Object
    extended by javax.enterprise.deploy.shared.ModuleType
public class ModuleType
extends Object

Class ModuleTypes defines enumeration values for the J2EE module types.

Author:
Rebecca Searls

Field Summary
static ModuleType | CAR The module is an Client Application archive.
static ModuleType | EAR The module is an EAR archive.
static ModuleType | EJB The module is an Enterprise Java Bean archive.
static ModuleType | RAR The module is an Connector archive.
static ModuleType | WAR The module is an Web Application archive.
Constructor Summary
protected ModuleType(int value)
Construct a new enumeration value with the given integer value.
Method Summary
protected ModuleType[] | getEnumValueTable() Returns the enumeration value table for class ModuleType
String | getModuleExtension() Return the file extension string for this enumeration.
static ModuleType | getModuleType(int value) Return an object of the specified value.
protected int | getOffset() Returns the lowest integer value used by this enumeration value's enumeration class.
protected String[] | getStringTable() Returns the string table for class ModuleType
int | getValue() Returns this enumeration value's integer value.
String | toString() Return the string name of this ModuleType or the integer value if outside the bounds of the table
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

EAR

public static final ModuleType EAR
The module is an EAR archive.

EJB

public static final ModuleType EJB
The module is an Enterprise Java Bean archive.

CAR

public static final ModuleType CAR
The module is an Client Application archive.

RAR

public static final ModuleType RAR
The module is an Connector archive.

WAR

public static final ModuleType WAR
The module is an Web Application archive.

Constructor Detail

ModuleType

protected ModuleType(int value)
Construct a new enumeration value with the given integer value.

Parameters:
value - Integer value.
Method Detail

getValue

public int getValue()
Returns this enumeration value's integer value.

Returns:
the value

getStringTable

protected String[] getStringTable()
Returns the string table for class ModuleType

getEnumValueTable

protected ModuleType[] getEnumValueTable()
Returns the enumeration value table for class ModuleType

getModuleExtension

public String getModuleExtension()
Return the file extension string for this enumeration.

getModuleType

public static ModuleType getModuleType(int value)
Return an object of the specified value.

Parameters:
value - a designator for the object.

toString

public String toString()
Return the string name of this ModuleType or the integer value if outside the bounds of the table

getOffset

protected int getOffset()
Returns the lowest integer value used by this enumeration value's enumeration class.

The default implementation returns 0. If the enumeration class (a subclass of class EnumSyntax) uses integer values starting at other than 0, override this method in the subclass.

Returns:
the offset of the lowest enumeration value.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StateType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared
Class StateType

java.lang.Object
    extended by javax.enterprise.deploy.shared.StateType
public class StateType
extends Object

Class StateTypes defines enumeration values for the DeploymentStatus object.

Author:
rsearls

Field Summary
static StateType | COMPLETED The action operation has completed normally.
static StateType | FAILED The action operation has failed.
static StateType | RELEASED The DeploymentManager is running in discommected mode.
static StateType | RUNNING The action operation is running normally.
Constructor Summary
protected StateType(int value)
Construct a new enumeration value with the given integer value.
Method Summary
protected StateType[] | getEnumValueTable() Returns the enumeration value table for class StateType
protected int | getOffset() Returns the lowest integer value used by this enumeration value's enumeration class.
static StateType | getStateType(int value) Return an object of the specified value.
protected String[] | getStringTable() Returns the string table for class StateType
int | getValue() Returns this enumeration value's integer value.
String | toString() Return the string name of this StateType or the integer value if outside the bounds of the table
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RUNNING

public static final StateType RUNNING
The action operation is running normally.

COMPLETED

public static final StateType COMPLETED
The action operation has completed normally.

FAILED

public static final StateType FAILED
The action operation has failed.

RELEASED

public static final StateType RELEASED
The DeploymentManager is running in discommected mode.

Constructor Detail

StateType

protected StateType(int value)
Construct a new enumeration value with the given integer value.

Parameters:
value - Integer value.
Method Detail

getValue

public int getValue()
Returns this enumeration value's integer value.

Returns:
the value

getStringTable

protected String[] getStringTable()
Returns the string table for class StateType

getEnumValueTable

protected StateType[] getEnumValueTable()
Returns the enumeration value table for class StateType

getStateType

public static StateType getStateType(int value)
Return an object of the specified value.

Parameters:
value - a designator for the object.

toString

public String toString()
Return the string name of this StateType or the integer value if outside the bounds of the table

getOffset

protected int getOffset()
Returns the lowest integer value used by this enumeration value's enumeration class.

The default implementation returns 0.

Returns:
the offset of the lowest enumeration value.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


spi

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.spi

Provides J2EE Product Vendor implementation classes.

See:
Description

Interface Summary
DConfigBean | The DConfigBean is a deployment configuration bean (DConfigBean) that is associated with one or more deployment descriptor beans, (DDBean).
DConfigBeanRoot | A J2EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents.
DeploymentConfiguration | An interface that defines a container for all the server-specific configuration information for a single top-level J2EE module.
DeploymentManager | The DeploymentManager object provides the core set of functions a J2EE platform must provide for J2EE application deployment.
Target | A Target interface represents a single logical core server of one instance of a J2EE platform product.
TargetModuleID | A TargetModuleID interface represents a unique identifier for a deployed application module.

Package javax.enterprise.deploy.spi Description

Provides J2EE Product Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.spi Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.spi

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface javax.enterprise.deploy.spi.DConfigBean
    • interface javax.enterprise.deploy.spi.DConfigBeanRoot
  • interface javax.enterprise.deploy.spi.DeploymentConfiguration
  • interface javax.enterprise.deploy.spi.DeploymentManager
  • interface javax.enterprise.deploy.spi.Target
  • interface javax.enterprise.deploy.spi.TargetModuleID
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DConfigBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface DConfigBean

All Known Subinterfaces:
DConfigBeanRoot
public interface DConfigBean

The DConfigBean is a deployment configuration bean (DConfigBean) that is associated with one or more deployment descriptor beans, (DDBean). A DConfigBean represents a logical grouping of deployment configuration data to be presented to the Deployer. A DConfigBean provides zero or more XPaths that identifies the XML information it requires. A DConfigBean may contain other DConfigBeans and regular JavaBeans. The top most DConfigBean is a DConfigBeanRoot object which represents a single XML instance document.

A DConfigBean is created by calling DConfigBean.getDConfigBean(DDBean) method, where DConfigBean is the object that provided the XPath which the DDBean represents.

A DConfigBean is a JavaBean component that presents the dynamic deployment configuration information for a J2EE plugin to the deployer. It is a JavaBean. The JavaBean architecture was chosen because of its versatility in providing both simple and complex components. JavaBeans also enable the development of property sheets and property editors, as well as sophisticated customization wizards.

It is expected that a plugin vendor will provide a Property Editor for any complex datatype in a DConfigBean that a deployer needs to edit through a property sheet. The Property Editor should be implemented and made available to a tool according to the guidelines defined in the JavaBeans API Specification version 1.01.

Method Summary
void | addPropertyChangeListener(PropertyChangeListener pcl) Register a property listener for this bean.
DConfigBean | getDConfigBean(DDBean bean) Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.
DDBean | getDDBean() Return the JavaBean containing the deployment descriptor XML text associated with this DConfigBean.
String[] | getXpaths() Return a list of XPaths designating the deployment descriptor information this DConfigBean requires.
void | notifyDDChange(XpathEvent event) A notification that the DDBean provided in the event has changed and this bean or its child beans need to reevaluate themselves.
void | removeDConfigBean(DConfigBean bean) Remove a child DConfigBean from this bean.
void | removePropertyChangeListener(PropertyChangeListener pcl) Unregister a property listener for this bean.

Method Detail

getDDBean

public DDBean getDDBean()
Return the JavaBean containing the deployment descriptor XML text associated with this DConfigBean.

Returns:
The bean class containing the XML text for this DConfigBean.

getXpaths

public String[] getXpaths()
Return a list of XPaths designating the deployment descriptor information this DConfigBean requires. A given server vendor will need to specify some server-specific information. Each String returned by this method is an XPath describing a certain portion of the standard deployment descriptor for which there is corresponding server-specific configuration.

Returns:
a list of XPath Strings representing XML data to be retrieved or 'null' if there are none.

getDConfigBean

public DConfigBean getDConfigBean(DDBean bean)
                           throws ConfigurationException
Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.

Parameters:
bean - The DDBean containing the XML data to be evaluated.
Returns:
The DConfigBean to display the server-specific properties for the standard bean.
Throws:
ConfigurationException - reports errors in generating a configuration bean. This DDBean is considered undeployable to this server until this exception is resolved. A suitably descriptive message is required so the user can diagnose the error.

removeDConfigBean

public void removeDConfigBean(DConfigBean bean)
                       throws BeanNotFoundException
Remove a child DConfigBean from this bean.

Parameters:
bean - The child DConfigBean to be removed.
Throws:
BeanNotFoundException - the bean provided is not in the child list of this bean.

notifyDDChange

public void notifyDDChange(XpathEvent event)
A notification that the DDBean provided in the event has changed and this bean or its child beans need to reevaluate themselves.

Parameters:
event - an event containing a reference to the DDBean which has changed.

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener pcl)
Register a property listener for this bean.

Parameters:
pcl - PropertyChangeListener to add

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener pcl)
Unregister a property listener for this bean.

Parameters:
pcl - Listener to remove.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DConfigBeanRoot

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface DConfigBeanRoot

All Superinterfaces:
DConfigBean
public interface DConfigBeanRoot
extends DConfigBean

A J2EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents. A module must contain a component-specific deployment descriptor file (see the component specification for details). It may contain one or more secondary deployment descriptor files that define extra functionality on the component and zero or more non-deployment descriptor XML instance documents (see the Web Services specification).

The DConfigBeanRoot object is a deployment configuration bean (DConfigBean) that is associated with the root of the component's deployment descriptor. It must be created by calling the DeploymentConfiguration.getDConfigBean(DDBeanRoot) method, where DDBeanRoot represents the component's deployment descriptor.

A DConfigBean object is associated with a deployment descriptor that extends a component's functionality. It must be created by calling the DConfigBeanRoot.getDConfigBean(DDBeanRoot) method. This DConfigBean object is a child of the compontent's DConfigBeanRoot object. The DDBeanRoot argument represents the secondary deployment descriptor. Deployment descriptor files such as webservice.xml and webserviceclient.xml are examples of secondary deployment descriptor files.

The server plugin must request a DDBeanRoot object for any non-deployment descriptor XML instance document data it requires. The plugin must call method DeployableObject.getDDBeanRoot(String) where String is the full path name from the root of the module to the file to be represented. A WSDL file is an example of a non-deployment descriptor XML instance document.

Author:
gfink

Method Summary
 DConfigBean getDConfigBean(DDBeanRoot ddBeanRoot)
Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor.
Methods inherited from interface javax.enterprise.deploy.spi.DConfigBean
addPropertyChangeListener, getDConfigBean, getDDBean, getXpaths, notifyDDChange, removeDConfigBean, removePropertyChangeListener

Method Detail

getDConfigBean

public DConfigBean getDConfigBean(DDBeanRoot ddBeanRoot)
Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor. Web services provides a deployment descriptor in addition to the module's primary deployment descriptor. Only the DDBeanRoot for this catagory of secondary deployment descriptors are to be passed as arguments through this method. Web service has two deployment descriptor files, one that defines the web service and one that defines a client of a web service. See the Web Service specificiation for the details.

Parameters:
ddBeanRoot - represents the root element of a deployment descriptor file.
Returns:
a DConfigBean to be used for processing this deployment descriptor data. Null may be returned if no DConfigBean is required for this deployment descriptor.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeploymentConfiguration

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface DeploymentConfiguration

public interface DeploymentConfiguration

An interface that defines a container for all the server-specific configuration information for a single top-level J2EE module. The DeploymentConfiguration object could represent a single stand alone module or an EAR file that contains several sub-modules.

Version:
0.1
Author:
gfink

Method Summary
DConfigBeanRoot | getDConfigBeanRoot(DDBeanRoot bean) Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.
DeployableObject | getDeployableObject() Returns an object that provides access to the deployment descriptor data and classes of a J2EE module.
void | removeDConfigBean(DConfigBeanRoot bean) Remove the root DConfigBean and all its children.
void | restore(InputStream inputArchive) Restore from disk to a full set of configuration beans previously stored.
DConfigBeanRoot | restoreDConfigBean(InputStream inputArchive, DDBeanRoot bean) Restore from disk to instantated objects all the DConfigBeans associated with a specific deployment descriptor.
void | save(OutputStream outputArchive) Save to disk the current set configuration beans created for this deployable module.
void | saveDConfigBean(OutputStream outputArchive, DConfigBeanRoot bean) Save to disk all the configuration beans associated with a particular deployment descriptor file.

Method Detail

getDeployableObject

public DeployableObject getDeployableObject()
Returns an object that provides access to the deployment descriptor data and classes of a J2EE module.

Returns:
DeployableObject

getDConfigBeanRoot

public DConfigBeanRoot getDConfigBeanRoot(DDBeanRoot bean)
                                   throws ConfigurationException
Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.

Parameters:
bean - The top level bean that represents the associated deployment descriptor.
Returns:
the DConfigBeanRoot for editing the server-specific properties required by the module.
Throws:
ConfigurationException - reports errors in generating a configuration bean

removeDConfigBean

public void removeDConfigBean(DConfigBeanRoot bean)
                       throws BeanNotFoundException
Remove the root DConfigBean and all its children.

Parameters:
bean - the top leve DConfigBean to remove.
Throws:
BeanNotFoundException - the bean provides is not in this beans child list.

restoreDConfigBean

public DConfigBeanRoot restoreDConfigBean(InputStream inputArchive,
                                          DDBeanRoot bean)
                                   throws ConfigurationException
Restore from disk to instantated objects all the DConfigBeans associated with a specific deployment descriptor. The beans may be fully or partially configured.

Parameters:
inputArchive - The input stream for the file from which the DConfigBeans should be restored.
bean - The DDBeanRoot bean associated with the deployment descriptor file.
Returns:
The top most parent configuration bean, DConfigBeanRoot
Throws:
ConfigurationException - reports errors in generating a configuration bean

saveDConfigBean

public void saveDConfigBean(OutputStream outputArchive,
                            DConfigBeanRoot bean)
                     throws ConfigurationException
Save to disk all the configuration beans associated with a particular deployment descriptor file. The saved data may be fully or partially configured DConfigBeans. The output file format is recommended to be XML.

Parameters:
outputArchive - The output stream to which the DConfigBeans should be saved.
bean - The top level bean, DConfigBeanRoot, from which to be save.
Throws:
ConfigurationException - reports errors in generating a configuration bean

restore

public void restore(InputStream inputArchive)
             throws ConfigurationException
Restore from disk to a full set of configuration beans previously stored.

Parameters:
inputArchive - The input stream from which to restore the Configuration.
Throws:
ConfigurationException - reports errors in generating a configuration bean

save

public void save(OutputStream outputArchive)
          throws ConfigurationException
Save to disk the current set configuration beans created for this deployable module. It is recommended the file format be XML.

Parameters:
outputArchive - The output stream to which to save the Configuration.
Throws:
ConfigurationException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeploymentManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface DeploymentManager

public interface DeploymentManager

The DeploymentManager object provides the core set of functions a J2EE platform must provide for J2EE application deployment. It provides server related information, such as, a list of deployment targets, and vendor unique runtime configuration information.

Method Summary
DeploymentConfiguration | createConfiguration(DeployableObject dObj) Retrieve the object that provides server-specific deployment configuration information for the J2EE deployable component.
ProgressObject | distribute(Target[] targetList, File moduleArchive, File deploymentPlan) The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
ProgressObject | distribute(Target[] targetList, InputStream moduleArchive, InputStream deploymentPlan) The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
TargetModuleID[] | getAvailableModules(ModuleType moduleType, Target[] targetList) Retrieve the list of all J2EE application modules running or not running on the identified targets.
Locale | getCurrentLocale() Returns the active locale this implementation of javax.enterprise.deploy.spi subpackages is running.
DConfigBeanVersionType | getDConfigBeanVersion() Returns the J2EE platform version number for which the configuration beans are provided.
Locale | getDefaultLocale() Returns the default locale supported by this implementation of javax.enterprise.deploy.spi subpackages.
TargetModuleID[] | getNonRunningModules(ModuleType moduleType, Target[] targetList) Retrieve the list of J2EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.
TargetModuleID[] | getRunningModules(ModuleType moduleType, Target[] targetList) Retrieve the list of J2EE application modules distributed to the identified targets and that are currently running on the associated server or servers.
Locale[] | getSupportedLocales() Returns an array of supported locales for this implementation.
Target[] | getTargets() Retrieve the list of deployment targets supported by this DeploymentManager.
boolean | isDConfigBeanVersionSupported(DConfigBeanVersionType version) Returns 'true' if the configuration beans support the J2EE platform version specified.
boolean | isLocaleSupported(Locale locale) Reports if this implementation supports the designated locale.
boolean | isRedeploySupported() This method designates whether this platform vendor provides application redeployment functionality.
ProgressObject | redeploy(TargetModuleID[] moduleIDList, File moduleArchive, File deploymentPlan) (optional) The redeploy method provides a means for updating currently deployed J2EE applications.
ProgressObject | redeploy(TargetModuleID[] moduleIDList, InputStream moduleArchive, InputStream deploymentPlan) (optional) The redeploy method provides a means for updating currently deployed J2EE applications.
void | release() The release method is the mechanism by which the tool signals to the DeploymentManager that the tool does not need it to continue running connected to the platform.
void | setDConfigBeanVersion(DConfigBeanVersionType version) Set the configuration beans to be used to the J2EE platform version specificed.
void | setLocale(Locale locale) Set the active locale for this implementation of javax.enterprise.deploy.spi subpackages to run.
ProgressObject | start(TargetModuleID[] moduleIDList) Start the application running.
ProgressObject | stop(TargetModuleID[] moduleIDList) Stop the application running.
ProgressObject | undeploy(TargetModuleID[] moduleIDList) Remove the application from the target server.

Method Detail

getTargets

public Target[] getTargets()
                    throws IllegalStateException
Retrieve the list of deployment targets supported by this DeploymentManager.

Returns:
A list of deployment Target designators the user may select for application deployment or 'null' if there are none.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

getRunningModules

public TargetModuleID[] getRunningModules(ModuleType moduleType,
                                          Target[] targetList)
                                   throws TargetException,
                                          IllegalStateException
Retrieve the list of J2EE application modules distributed to the identified targets and that are currently running on the associated server or servers.

Parameters:
moduleType - A predefined designator for a J2EE module type.
targetList - A list of deployment Target designators the user wants checked for module run status.
Returns:
An array of TargetModuleID objects representing the running modules or 'null' if there are none.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.
TargetException - An invalid Target designator encountered.

getNonRunningModules

public TargetModuleID[] getNonRunningModules(ModuleType moduleType,
                                             Target[] targetList)
                                      throws TargetException,
                                             IllegalStateException
Retrieve the list of J2EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.

Parameters:
moduleType - A predefined designator for a J2EE module type.
targetList - A list of deployment Target designators the user wants checked for module not running status.
Returns:
An array of TargetModuleID objects representing the non-running modules or 'null' if there are none.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.
TargetException - An invalid Target designator encountered.

getAvailableModules

public TargetModuleID[] getAvailableModules(ModuleType moduleType,
                                            Target[] targetList)
                                     throws TargetException,
                                            IllegalStateException
Retrieve the list of all J2EE application modules running or not running on the identified targets.

Parameters:
moduleType - A predefined designator for a J2EE module type.
targetList - A list of deployment Target designators the user wants checked for module not running status.
Returns:
An array of TargetModuleID objects representing all deployed modules running or not or 'null' if there are no deployed modules.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.
TargetException - An invalid Target designator encountered.

createConfiguration

public DeploymentConfiguration createConfiguration(DeployableObject dObj)
                                            throws InvalidModuleException
Retrieve the object that provides server-specific deployment configuration information for the J2EE deployable component.

Parameters:
dObj - An object representing a J2EE deployable component.
Throws:
InvalidModuleException - The DeployableObject is an unknown or unsupport component for this configuration tool.

distribute

public ProgressObject distribute(Target[] targetList,
                                 File moduleArchive,
                                 File deploymentPlan)
                          throws IllegalStateException
The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.

Parameters:
targetList - A list of server targets the user is specifying this application be deployed to.
moduleArchive - The file name of the application archive to be disrtibuted.
deploymentPlan - The XML file containing the runtime configuration information associated with this application archive.
Returns:
ProgressObject an object that tracks and reports the status of the distribution process.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

distribute

public ProgressObject distribute(Target[] targetList,
                                 InputStream moduleArchive,
                                 InputStream deploymentPlan)
                          throws IllegalStateException
The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.

Parameters:
targetList - A list of server targets the user is specifying this application be deployed to.
moduleArchive - The input stream containing the application archive to be disrtibuted.
deploymentPlan - The input stream containing the deployment configuration information associated with this application archive.
Returns:
ProgressObject an object that tracks and reports the status of the distribution process.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

start

public ProgressObject start(TargetModuleID[] moduleIDList)
                     throws IllegalStateException
Start the application running.

Only the TargetModuleIDs which represent a root module are valid for being started. A root TargetModuleID has no parent. A TargetModuleID with a parent can not be individually started. A root TargetModuleID module and all its child modules will be started.

Parameters:
moduleIDList - A array of TargetModuleID objects representing the modules to be started.
Returns:
ProgressObject an object that tracks and reports the status of the start operation.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

stop

public ProgressObject stop(TargetModuleID[] moduleIDList)
                    throws IllegalStateException
Stop the application running.

Only the TargetModuleIDs which represent a root module are valid for being stopped. A root TargetModuleID has no parent. A TargetModuleID with a parent can not be individually stopped. A root TargetModuleID module and all its child modules will be stopped.

Parameters:
moduleIDList - A array of TargetModuleID objects representing the modules to be stopped.
Returns:
ProgressObject an object that tracks and reports the status of the stop operation.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

undeploy

public ProgressObject undeploy(TargetModuleID[] moduleIDList)
                        throws IllegalStateException
Remove the application from the target server.

Only the TargetModuleIDs which represent a root module are valid for undeployment. A root TargetModuleID has no parent. A TargetModuleID with a parent can not be undeployed. A root TargetModuleID module and all its child modules will be undeployed. The root TargetModuleID module and all its child modules must stopped before they can be undeployed.

Parameters:
moduleIDList - An array of TargetModuleID objects representing the root modules to be stopped.
Returns:
ProgressObject an object that tracks and reports the status of the stop operation.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

isRedeploySupported

public boolean isRedeploySupported()
This method designates whether this platform vendor provides application redeployment functionality. A value of true means it is supported. False means it is not.

Returns:
A value of true means redeployment is supported by this vendor's DeploymentManager. False means it is not.

redeploy

public ProgressObject redeploy(TargetModuleID[] moduleIDList,
                               File moduleArchive,
                               File deploymentPlan)
                        throws UnsupportedOperationException,
                               IllegalStateException
(optional) The redeploy method provides a means for updating currently deployed J2EE applications. This is an optional method for vendor implementation. Redeploy replaces a currently deployed application with an updated version. The runtime configuration information for the updated application must remain identical to the application it is updating. When an application update is redeployed, all existing client connections to the original running application must not be disrupted; new clients will connect to the application update. This operation is valid for TargetModuleIDs that represent a root module. A root TargetModuleID has no parent. A root TargetModuleID module and all its child modules will be redeployed. A child TargetModuleID module cannot be individually redeployed. The redeploy operation is complete only when this action for all the modules has completed.

Parameters:
moduleIDList - An array of designators of the applications to be updated.
moduleArchive - The file name of the application archive to be disrtibuted.
deploymentPlan - The deployment configuration information associated with this application archive.
Returns:
ProgressObject an object that tracks and reports the status of the redeploy operation.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.
UnsupportedOperationException - this optional command is not supported by this implementation.

redeploy

public ProgressObject redeploy(TargetModuleID[] moduleIDList,
                               InputStream moduleArchive,
                               InputStream deploymentPlan)
                        throws UnsupportedOperationException,
                               IllegalStateException
(optional) The redeploy method provides a means for updating currently deployed J2EE applications. This is an optional method for vendor implementation. Redeploy replaces a currently deployed application with an updated version. The runtime configuration information for the updated application must remain identical to the application it is updating. When an application update is redeployed, all existing client connections to the original running application must not be disrupted; new clients will connect to the application update. This operation is valid for TargetModuleIDs that represent a root module. A root TargetModuleID has no parent. A root TargetModuleID module and all its child modules will be redeployed. A child TargetModuleID module cannot be individually redeployed. The redeploy operation is complete only when this action for all the modules has completed.

Parameters:
moduleIDList - An array of designators of the applications to be updated.
moduleArchive - The input stream containing the application archive to be disrtibuted.
deploymentPlan - The input stream containing the runtime configuration information associated with this application archive.
Returns:
ProgressObject an object that tracks and reports the status of the redeploy operation.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.
UnsupportedOperationException - this optional command is not supported by this implementation.

release

public void release()
The release method is the mechanism by which the tool signals to the DeploymentManager that the tool does not need it to continue running connected to the platform. The tool may be signaling it wants to run in a disconnected mode or it is planning to shutdown. When release is called the DeploymentManager may close any J2EE resource connections it had for deployment configuration and perform other related resource cleanup. It should not accept any new operation requests (i.e., distribute, start stop, undeploy, redeploy. It should finish any operations that are currently in process. Each ProgressObject associated with a running operation should be marked as released (see the ProgressObject).

getDefaultLocale

public Locale getDefaultLocale()
Returns the default locale supported by this implementation of javax.enterprise.deploy.spi subpackages.

Returns:
Locale the default locale for this implementation.

getCurrentLocale

public Locale getCurrentLocale()
Returns the active locale this implementation of javax.enterprise.deploy.spi subpackages is running.

Returns:
Locale the active locale of this implementation.

setLocale

public void setLocale(Locale locale)
               throws UnsupportedOperationException
Set the active locale for this implementation of javax.enterprise.deploy.spi subpackages to run.

Throws:
UnsupportedOperationException - the provide locale is not supported.

getSupportedLocales

public Locale[] getSupportedLocales()
Returns an array of supported locales for this implementation.

Returns:
Locale[] the list of supported locales.

isLocaleSupported

public boolean isLocaleSupported(Locale locale)
Reports if this implementation supports the designated locale.

Returns:
A value of 'true' means it is support and 'false' it is not.

getDConfigBeanVersion

public DConfigBeanVersionType getDConfigBeanVersion()
Returns the J2EE platform version number for which the configuration beans are provided. The beans must have been compiled with the J2SE version required by the J2EE platform.

Returns:
a DConfigBeanVersionType object representing the platform version number for which these beans are provided.

isDConfigBeanVersionSupported

public boolean isDConfigBeanVersionSupported(DConfigBeanVersionType version)
Returns 'true' if the configuration beans support the J2EE platform version specified. It returns 'false' if the version is not supported.

Parameters:
version - a DConfigBeanVersionType object representing the J2EE platform version for which support is requested.
Returns:
'true' if the version is supported and 'false if not.

setDConfigBeanVersion

public void setDConfigBeanVersion(DConfigBeanVersionType version)
                           throws DConfigBeanVersionUnsupportedException
Set the configuration beans to be used to the J2EE platform version specificed.

Parameters:
version - a DConfigBeanVersionType object representing the J2EE platform version for which support is requested.
Throws:
DConfigBeanVersionUnsupportedException - when the requested bean version is not supported.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


exceptions

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.spi.exceptions

Provides J2EE Product Vendor deployment exception implementation classes.

See:
Description

Exception Summary
BeanNotFoundException | This exception is to report that the bean is not a child of the parent bean.
ClientExecuteException | This exception reports errors in setting up an application client for execution.
ConfigurationException | This exception reports errors in generating a configuration bean.
DConfigBeanVersionUnsupportedException | This exception is to report that there is no support for the DConfigBean version requested.
DeploymentManagerCreationException | This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.
InvalidModuleException | This exception is to report an invalid J2EE deployment module type.
OperationUnsupportedException | This exception is to report that the method called is not supported by this implementation.
TargetException | This exception is to report bad target designators.

Package javax.enterprise.deploy.spi.exceptions Description

Provides J2EE Product Vendor deployment exception implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.spi.exceptions Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.spi.exceptions

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
        • class javax.enterprise.deploy.spi.exceptions.ClientExecuteException
        • class javax.enterprise.deploy.spi.exceptions.ConfigurationException
        • class javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
        • class javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
        • class javax.enterprise.deploy.spi.exceptions.InvalidModuleException
        • class javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException
        • class javax.enterprise.deploy.spi.exceptions.TargetException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BeanNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class BeanNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
All Implemented Interfaces:
Serializable
public class BeanNotFoundException
extends Exception

This exception is to report that the bean is not a child of the parent bean.

See Also:
Serialized Form

Constructor Summary
BeanNotFoundException(String s)
Creates an new BeanNotFoundException object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BeanNotFoundException

public BeanNotFoundException(String s)
Creates an new BeanNotFoundException object.

Parameters:
s - a string indicating what was wrong with the target.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ClientExecuteException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class ClientExecuteException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.enterprise.deploy.spi.exceptions.ClientExecuteException
All Implemented Interfaces:
Serializable
public class ClientExecuteException
extends Exception

This exception reports errors in setting up an application client for execution.

Author:
gfink
See Also:
Serialized Form

Constructor Summary
ClientExecuteException()
Creates new ClientExecuteException without detail message.
ClientExecuteException(String msg)
Constructs an ClientExecuteException with the specified detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ClientExecuteException

public ClientExecuteException()
Creates new ClientExecuteException without detail message.

ClientExecuteException

public ClientExecuteException(String msg)
Constructs an ClientExecuteException with the specified detail message.

Parameters:
msg - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConfigurationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class ConfigurationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.enterprise.deploy.spi.exceptions.ConfigurationException
All Implemented Interfaces:
Serializable
public class ConfigurationException
extends Exception

This exception reports errors in generating a configuration bean.

Author:
gfink
See Also:
Serialized Form

Constructor Summary
ConfigurationException()
Creates new ConfigurationException without detail message.
ConfigurationException(String msg)
Constructs an ConfigurationException with the specified detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ConfigurationException

public ConfigurationException()
Creates new ConfigurationException without detail message.

ConfigurationException

public ConfigurationException(String msg)
Constructs an ConfigurationException with the specified detail message.

Parameters:
msg - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DConfigBeanVersionUnsupportedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class DConfigBeanVersionUnsupportedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
All Implemented Interfaces:
Serializable
public class DConfigBeanVersionUnsupportedException
extends Exception

This exception is to report that there is no support for the DConfigBean version requested.

See Also:
Serialized Form

Constructor Summary
DConfigBeanVersionUnsupportedException(String s)
Creates an new DConfigBeanVersionUnsupportedException object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DConfigBeanVersionUnsupportedException

public DConfigBeanVersionUnsupportedException(String s)
Creates an new DConfigBeanVersionUnsupportedException object.

Parameters:
s - a string indicating what was wrong with the version request.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeploymentManagerCreationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class DeploymentManagerCreationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
All Implemented Interfaces:
Serializable
public class DeploymentManagerCreationException
extends Exception

This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.

See Also:
Serialized Form

Constructor Summary
DeploymentManagerCreationException(String s)
Creates an new DeploymentManagerCreationException object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DeploymentManagerCreationException

public DeploymentManagerCreationException(String s)
Creates an new DeploymentManagerCreationException object.

Parameters:
s - a string providing more information about the problem.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidModuleException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class InvalidModuleException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.enterprise.deploy.spi.exceptions.InvalidModuleException
All Implemented Interfaces:
Serializable
public class InvalidModuleException
extends Exception

This exception is to report an invalid J2EE deployment module type.

See Also:
Serialized Form

Constructor Summary
InvalidModuleException(String s)
Creates an new InvalidModuleException object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidModuleException

public InvalidModuleException(String s)
Creates an new InvalidModuleException object.

Parameters:
s - a string indicating what was wrong with the module type.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OperationUnsupportedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class OperationUnsupportedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException
All Implemented Interfaces:
Serializable
public class OperationUnsupportedException
extends Exception

This exception is to report that the method called is not supported by this implementation.

See Also:
Serialized Form

Constructor Summary
OperationUnsupportedException(String s)
Creates an new OperationUnsupportedException object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OperationUnsupportedException

public OperationUnsupportedException(String s)
Creates an new OperationUnsupportedException object.

Parameters:
s - a string indicating what was wrong with the target.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TargetException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class TargetException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.enterprise.deploy.spi.exceptions.TargetException
All Implemented Interfaces:
Serializable
public class TargetException
extends Exception

This exception is to report bad target designators.

See Also:
Serialized Form

Constructor Summary
TargetException(String s)
Creates an new TargetException object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TargetException

public TargetException(String s)
Creates an new TargetException object.

Parameters:
s - a string indicating what was wrong with the target.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


factories

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.spi.factories

Provides J2EE Product Vendor deployment factory implementation classes.

See:
Description

Interface Summary
DeploymentFactory The DeploymentFactory interface is a deployment driver for a J2EE plaform product.

Package javax.enterprise.deploy.spi.factories Description

Provides J2EE Product Vendor deployment factory implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.spi.factories Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.spi.factories

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeploymentFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.factories
Interface DeploymentFactory

public interface DeploymentFactory

The DeploymentFactory interface is a deployment driver for a J2EE plaform product. It returns a DeploymentManager object which represents a connection to a specific J2EE platform product.

Each application server vendor must provide an implementation of this class in order for the J2EE Deployment API to work with their product.

The class implementing this interface should have a public no-argument constructor, and it should be stateless (two instances of the class should always behave the same). It is suggested but not required that the class have a static initializer that registers an instance of the class with the DeploymentFactoryManager class.

A connected or disconnected DeploymentManager can be requested. A DeploymentManager that runs connected to the platform can provide access to J2EE resources. A DeploymentManager that runs disconnected only provides module deployment configuration support.

See Also:
DeploymentFactoryManager

Method Summary
DeploymentManager | getDeploymentManager(String uri, String username, String password) Return a connected DeploymentManager instance.
DeploymentManager | getDisconnectedDeploymentManager(String uri) Return a disconnected DeploymentManager instance.
String | getDisplayName() Provide a string with the name of this vendor's DeploymentManager.
String | getProductVersion() Provide a string identifying version of this vendor's DeploymentManager.
boolean | handlesURI(String uri) Tests whether this factory can create a DeploymentManager object based on the specificed URI.

Method Detail

handlesURI

public boolean handlesURI(String uri)
Tests whether this factory can create a DeploymentManager object based on the specificed URI. This does not indicate whether such an attempt will be successful, only whether the factory can handle the uri.

Parameters:
uri - The uri to check
Returns:
true if the factory can handle the uri.

getDeploymentManager

public DeploymentManager getDeploymentManager(String uri,
                                              String username,
                                              String password)
                                       throws DeploymentManagerCreationException
Return a connected DeploymentManager instance.

Parameters:
uri - The URI that specifies the connection parameters
username - An optional username (may be null if no authentication is required for this platform).
password - An optional password (may be null if no authentication is required for this platform).
Returns:
A ready DeploymentManager instance.
Throws:
DeploymentManagerCreationException - occurs when a DeploymentManager could not be returned (server down, unable to authenticate, etc).

getDisconnectedDeploymentManager

public DeploymentManager getDisconnectedDeploymentManager(String uri)
                                                   throws DeploymentManagerCreationException
Return a disconnected DeploymentManager instance.

Parameters:
uri - the uri of the DeploymentManager to return.
Returns:
A DeploymentManager disconnected instance.
Throws:
DeploymentManagerCreationException - occurs if the DeploymentManager could not be created.

getDisplayName

public String getDisplayName()
Provide a string with the name of this vendor's DeploymentManager.

Returns:
the name of the vendor's DeploymentManager.

getProductVersion

public String getProductVersion()
Provide a string identifying version of this vendor's DeploymentManager.

Returns:
the name of the vendor's DeploymentManager.
Overview  Package   Class  Tree  Deprecated  Index  Help
JavaTM 2 Platform
Ent. Ed. v1.4
 PREV CLASS   NEXT CLASS | FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


status

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.spi.status

Provides J2EE Product Vendor deployment status implementation classes.

See:
Description

Interface Summary
ClientConfiguration | The ClientConfiguration object installs, configures and executes an Application Client.
DeploymentStatus | The DeploymentStatus interface provides information about the progress status of a deployment action.
ProgressListener | The listener interface for receiving deployment progress events.
ProgressObject | The ProgressObject interface tracks and reports the progress of the deployment activities, distribute, start, stop, undeploy.

Class Summary
ProgressEvent An event which indicates that a deployment status change has occurred.

Package javax.enterprise.deploy.spi.status Description

Provides J2EE Product Vendor deployment status implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.spi.status Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.spi.status

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.enterprise.deploy.spi.status.ProgressEvent

Interface Hierarchy

  • interface javax.enterprise.deploy.spi.status.DeploymentStatus
  • interface java.util.EventListener
    • interface javax.enterprise.deploy.spi.status.ProgressListener
  • interface javax.enterprise.deploy.spi.status.ProgressObject
  • interface java.io.Serializable
    • interface javax.enterprise.deploy.spi.status.ClientConfiguration
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ClientConfiguration

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.status
Interface ClientConfiguration

All Superinterfaces:
Serializable
public interface ClientConfiguration
extends Serializable

The ClientConfiguration object installs, configures and executes an Application Client. This class resolves the settings for installing and running the application client.

Method Summary
 void execute()
This method performs an exec and starts the application client running in another process.

Method Detail

execute

public void execute()
             throws ClientExecuteException
This method performs an exec and starts the application client running in another process.

Throws:
ClientExecuteException - when the configuration is incomplete.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeploymentStatus

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.status
Interface DeploymentStatus

public interface DeploymentStatus

The DeploymentStatus interface provides information about the progress status of a deployment action.

Method Summary
ActionType | getAction() Retrieve the deployment ActionType for this event.
CommandType | getCommand() Retrieve the deployment CommandType of this event.
String | getMessage() Retrieve any additional information about the status of this event.
StateType | getState() Retrieve the StateType value.
boolean | isCompleted() A convience method to report if the operation is in the completed state.
boolean | isFailed() A convience method to report if the operation is in the failed state.
boolean | isRunning() A convience method to report if the operation is in the running state.

Method Detail

getState

public StateType getState()
Retrieve the StateType value.

Returns:
the StateType object

getCommand

public CommandType getCommand()
Retrieve the deployment CommandType of this event.

Returns:
the CommandType Object

getAction

public ActionType getAction()
Retrieve the deployment ActionType for this event.

Returns:
the ActionType Object

getMessage

public String getMessage()
Retrieve any additional information about the status of this event.

Returns:
message text

isCompleted

public boolean isCompleted()
A convience method to report if the operation is in the completed state.

Returns:
true if this command has completed successfully

isFailed

public boolean isFailed()
A convience method to report if the operation is in the failed state.

Returns:
true if this command has failed

isRunning

public boolean isRunning()
A convience method to report if the operation is in the running state.

Returns:
true if this command is still running
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ProgressEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.status
Class ProgressEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.enterprise.deploy.spi.status.ProgressEvent
All Implemented Interfaces:
Serializable
public class ProgressEvent
extends EventObject

An event which indicates that a deployment status change has occurred.

See Also:
ProgressListener, ProgressObject, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ProgressEvent(Object source, TargetModuleID targetModuleID, DeploymentStatus sCode)
Creates a new object representing a deployment progress event.
Method Summary
DeploymentStatus | getDeploymentStatus() Retrieve the status information.
TargetModuleID | getTargetModuleID() Retrieve the TargetModuleID for this event
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ProgressEvent

public ProgressEvent(Object source,
                     TargetModuleID targetModuleID,
                     DeploymentStatus sCode)
Creates a new object representing a deployment progress event.

Parameters:
source - the object on which the Event initially occurred.
sCode - the object containing the status information.
Method Detail

getTargetModuleID

public TargetModuleID getTargetModuleID()
Retrieve the TargetModuleID for this event

Returns:
the object containing the TargetModuleID

getDeploymentStatus

public DeploymentStatus getDeploymentStatus()
Retrieve the status information.

Returns:
the object containing the status information.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ProgressListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.status
Interface ProgressListener

All Superinterfaces:
EventListener
public interface ProgressListener
extends EventListener

The listener interface for receiving deployment progress events.

Method Summary
 void handleProgressEvent(ProgressEvent event)
Invoked when a deployment progress event occurs.

Method Detail

handleProgressEvent

public void handleProgressEvent(ProgressEvent event)
Invoked when a deployment progress event occurs.

Parameters:
event - the progress status event.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ProgressObject

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.status
Interface ProgressObject

public interface ProgressObject

The ProgressObject interface tracks and reports the progress of the deployment activities, distribute, start, stop, undeploy.

This class has an optional cancel method. The support of the cancel function can be tested by the isCancelSupported method.

The ProgressObject structure allows the user the option of polling for status or to provide a callback.

Method Summary
void | addProgressListener(ProgressListener pol) Add a listener to receive Progress events on deployment actions.
void | cancel() (optional) A cancel request on an in-process operation stops all further processing of the operation and returns the environment to it original state before the operation was executed.
ClientConfiguration | getClientConfiguration(TargetModuleID id) Return the ClientConfiguration object associated with the TargetModuleID.
DeploymentStatus | getDeploymentStatus() Retrieve the status of this activity.
TargetModuleID[] | getResultTargetModuleIDs() Retrieve the list of TargetModuleIDs successfully processed or created by the associated DeploymentManager operation.
boolean | isCancelSupported() Tests whether the vendor supports a cancel opertation for deployment activities.
boolean | isStopSupported() Tests whether the vendor supports a stop opertation for deployment activities.
void | removeProgressListener(ProgressListener pol) Remove a ProgressObject listener.
void | stop() (optional) A stop request on an in-process operation allows the operation on the current TargetModuleID to run to completion but does not process any of the remaining unprocessed TargetModuleID objects.

Method Detail

getDeploymentStatus

public DeploymentStatus getDeploymentStatus()
Retrieve the status of this activity.

Returns:
An object containing the status information.

getResultTargetModuleIDs

public TargetModuleID[] getResultTargetModuleIDs()
Retrieve the list of TargetModuleIDs successfully processed or created by the associated DeploymentManager operation.

Returns:
a list of TargetModuleIDs.

getClientConfiguration

public ClientConfiguration getClientConfiguration(TargetModuleID id)
Return the ClientConfiguration object associated with the TargetModuleID.

Returns:
ClientConfiguration for a given TargetModuleID or null if none exists.

isCancelSupported

public boolean isCancelSupported()
Tests whether the vendor supports a cancel opertation for deployment activities.

Returns:
true if canceling an activity is supported by this platform.

cancel

public void cancel()
            throws OperationUnsupportedException
(optional) A cancel request on an in-process operation stops all further processing of the operation and returns the environment to it original state before the operation was executed. An operation that has run to completion cannot be cancelled.

Throws:
OperationUnsupportedException - this optional command is not supported by this implementation.

isStopSupported

public boolean isStopSupported()
Tests whether the vendor supports a stop opertation for deployment activities.

Returns:
true if canceling an activity is supported by this platform.

stop

public void stop()
          throws OperationUnsupportedException
(optional) A stop request on an in-process operation allows the operation on the current TargetModuleID to run to completion but does not process any of the remaining unprocessed TargetModuleID objects. The processed TargetModuleIDs must be returned by the method getResultTargetModuleIDs.

Throws:
OperationUnsupportedException - this optional command is not supported by this implementation.

addProgressListener

public void addProgressListener(ProgressListener pol)
Add a listener to receive Progress events on deployment actions.

Parameters:
pol - the listener to receive events
See Also:
ProgressEvent

removeProgressListener

public void removeProgressListener(ProgressListener pol)
Remove a ProgressObject listener.

Parameters:
pol - the listener being removed
See Also:
ProgressEvent
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Target

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface Target

public interface Target

A Target interface represents a single logical core server of one instance of a J2EE platform product. It is a designator for a server and the implied location to copy a configured application for the server to access.

Method Summary
String | getDescription() Retrieve other descriptive information about the target.
String | getName() Retrieve the name of the target server.

Method Detail

getName

public String getName()
Retrieve the name of the target server.

getDescription

public String getDescription()
Retrieve other descriptive information about the target.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TargetModuleID

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface TargetModuleID

public interface TargetModuleID

A TargetModuleID interface represents a unique identifier for a deployed application module. A deployable application module can be an EAR, JAR, WAR or RAR file. A TargetModuleID can represent a root module or a child module. A root module TargetModuleID has no parent. It represents a deployed EAR file or stand alone module. A child module TargetModuleID represents a deployed sub module of a J2EE application. A child TargetModuleID has only one parent, the super module it was bundled and deployed with. The identifier consists of the target name and the unique identifier for the deployed application module.

Method Summary
TargetModuleID[] | getChildTargetModuleID() Retrieve a list of identifiers of the children of this deployed module.
String | getModuleID() Retrieve the id assigned to represent the deployed module.
TargetModuleID | getParentTargetModuleID() Retrieve the identifier of the parent object of this deployed module.
Target | getTarget() Retrieve the name of the target server.
String | getWebURL() If this TargetModulID represents a web module retrieve the URL for it.
String | toString() Retrieve the identifier representing the deployed module.

Method Detail

getTarget

public Target getTarget()
Retrieve the name of the target server. this module was deployed to.

Returns:
Target an object representing a server target.

getModuleID

public String getModuleID()
Retrieve the id assigned to represent the deployed module.

getWebURL

public String getWebURL()
If this TargetModulID represents a web module retrieve the URL for it.

Returns:
the URL of a web module or null if the module is not a web module.

toString

public String toString()
Retrieve the identifier representing the deployed module.

getParentTargetModuleID

public TargetModuleID getParentTargetModuleID()
Retrieve the identifier of the parent object of this deployed module. If there is no parent then this is the root object deployed. The root could represent an EAR file or it could be a stand alone module that was deployed.

Returns:
the TargetModuleID of the parent of this object. A null value means this module is the root object deployed.

getChildTargetModuleID

public TargetModuleID[] getChildTargetModuleID()
Retrieve a list of identifiers of the children of this deployed module.

Returns:
a list of TargetModuleIDs identifying the childern of this object. A null value means this module has no childern
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


jms

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.jms

The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

See:
Description

Interface Summary
BytesMessage | A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.
Connection | A Connection object is a client's active connection to its JMS provider.
ConnectionConsumer | For application servers, Connection objects provide a special facility for creating a ConnectionConsumer (optional).
ConnectionFactory | A ConnectionFactory object encapsulates a set of connection configuration parameters that has been defined by an administrator.
ConnectionMetaData | A ConnectionMetaData object provides information describing the Connection object.
DeliveryMode | The delivery modes supported by the JMS API are PERSISTENT and NON_PERSISTENT.
Destination | A Destination object encapsulates a provider-specific address.
ExceptionListener | If a JMS provider detects a serious problem with a Connection object, it informs the Connection object's ExceptionListener, if one has been registered.
MapMessage | A MapMessage object is used to send a set of name-value pairs.
Message | The Message interface is the root interface of all JMS messages.
MessageConsumer | A client uses a MessageConsumer object to receive messages from a destination.
MessageListener | A MessageListener object is used to receive asynchronously delivered messages.
MessageProducer | A client uses a MessageProducer object to send messages to a destination.
ObjectMessage | An ObjectMessage object is used to send a message that contains a serializable object in the Java programming language ("Java object").
Queue | A Queue object encapsulates a provider-specific queue name.
QueueBrowser | A client uses a QueueBrowser object to look at messages on a queue without removing them.
QueueConnection | A QueueConnection object is an active connection to a point-to-point JMS provider.
QueueConnectionFactory | A client uses a QueueConnectionFactory object to create QueueConnection objects with a point-to-point JMS provider.
QueueReceiver | A client uses a QueueReceiver object to receive messages that have been delivered to a queue.
QueueSender | A client uses a QueueSender object to send messages to a queue.
QueueSession | A QueueSession object provides methods for creating QueueReceiver, QueueSender, QueueBrowser, and TemporaryQueue objects.
ServerSession | A ServerSession object is an application server object that is used by a server to associate a thread with a JMS session (optional).
ServerSessionPool | A ServerSessionPool object is an object implemented by an application server to provide a pool of ServerSession objects for processing the messages of a ConnectionConsumer (optional).
Session | A Session object is a single-threaded context for producing and consuming messages.
StreamMessage | A StreamMessage object is used to send a stream of primitive types in the Java programming language.
TemporaryQueue | A TemporaryQueue object is a unique Queue object created for the duration of a Connection.
TemporaryTopic | A TemporaryTopic object is a unique Topic object created for the duration of a Connection.
TextMessage | A TextMessage object is used to send a message containing a java.lang.String.
Topic | A Topic object encapsulates a provider-specific topic name.
TopicConnection | A TopicConnection object is an active connection to a publish/subscribe JMS provider.
TopicConnectionFactory | A client uses a TopicConnectionFactory object to create TopicConnection objects with a publish/subscribe JMS provider.
TopicPublisher | A client uses a TopicPublisher object to publish messages on a topic.
TopicSession | A TopicSession object provides methods for creating TopicPublisher, TopicSubscriber, and TemporaryTopic objects.
TopicSubscriber | A client uses a TopicSubscriber object to receive messages that have been published to a topic.
XAConnection | The XAConnection interface extends the capability of Connection by providing an XASession (optional).
XAConnectionFactory | The XAConnectionFactory interface is a base interface for the XAQueueConnectionFactory and XATopicConnectionFactory interfaces.
XAQueueConnection | An XAQueueConnection provides the same create options as QueueConnection (optional).
XAQueueConnectionFactory | An XAQueueConnectionFactory provides the same create options as a QueueConnectionFactory (optional).
XAQueueSession | An XAQueueSession provides a regular QueueSession, which can be used to create QueueReceiver, QueueSender, and QueueBrowser objects (optional).
XASession | The XASession interface extends the capability of Session by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional).
XATopicConnection | An XATopicConnection provides the same create options as TopicConnection (optional).
XATopicConnectionFactory | An XATopicConnectionFactory provides the same create options as a TopicConnectionFactory (optional).
XATopicSession | An XATopicSession provides a regular TopicSession.

Class Summary
QueueRequestor | The QueueRequestor helper class simplifies making service requests.
TopicRequestor | The TopicRequestor helper class simplifies making service requests.

Exception Summary
IllegalStateException | This exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation.
InvalidClientIDException | This exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider.
InvalidDestinationException | This exception must be thrown when a destination either is not understood by a provider or is no longer valid.
InvalidSelectorException | This exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax.
JMSException | This is the root class of all JMS API exceptions.
JMSSecurityException | This exception must be thrown when a provider rejects a user name/password submitted by a client.
MessageEOFException | This exception must be thrown when an unexpected end of stream has been reached when a StreamMessage or BytesMessage is being read.
MessageFormatException | This exception must be thrown when a JMS client attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type.
MessageNotReadableException | This exception must be thrown when a JMS client attempts to read a write-only message.
MessageNotWriteableException | This exception must be thrown when a JMS client attempts to write to a read-only message.
ResourceAllocationException | This exception is thrown when a provider is unable to allocate the resources required by a method.
TransactionInProgressException | This exception is thrown when an operation is invalid because a transaction is in progress.
TransactionRolledBackException | This exception must be thrown when a call to Session.commit results in a rollback of the current transaction.

Package javax.jms Description

The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

JMS Applications

A JMS application is composed of the following parts:

  • JMS Provider - a messaging system that implements the JMS API in addition to the other administrative and control functionality required of a full-featured messaging product
  • JMS Clients - the Java language programs that send and receive messages
  • Messages - objects that are used to communicate information between the clients of an application
  • Administered Objects - provider-specific objects that clients look up and use to interact portably with a JMS provider
  • Non-JMS Clients - clients that use a message system's native client API instead of the JMS API. If the application predated the availability of the JMS API, it is likely that it will include both JMS clients and non-JMS clients.

Administration

JMS providers differ significantly in their implementations of underlying messaging technology. There are also major differences in how a JMS provider's system is installed and administered.

For JMS clients to be portable, they must be isolated from these proprietary aspects of a provider. This is done by defining JMS administered objects that are created and customized by a provider's administrator and later used by clients. The client uses them through JMS interfaces that are portable. The administrator creates them using provider-specific facilities.

There are two types of JMS administered objects:

  • ConnectionFactory - the object a client uses to create a connection with a JMS provider
  • Destination - the object a client uses to specify the destination of messages it is sending and the source of messages it receives

Administered objects are placed in a Java Naming and Directory InterfaceTM (JNDI) namespace by an administrator. A JMS client typically notes in its documentation the JMS administered objects it requires and how the JNDI names of these objects should be provided to it.

Two Messaging Styles

The JMS specification defines two styles of messaging: the point-to-point (PTP) or the publish-and-subscribe (Pub/Sub). These styles can be combined in a single application, or a given application can use just one of these styles.

The JMS API defines these two styles because they represent two of the dominant approaches to messaging currently in use. While the domains have many similarities, they also have some differences. JMS provides a unified programming interface to allow the client programmer to easily send and receive message using either domain, but the client programmer must also be aware of the differences between the domains. The key differences relate to how message persistence is handled, and the meaning of certain message attributes.

JMS Interfaces

When programming an application client, the programmer may either program using the domain specific interfaces, or may use the common interfaces. The key interfaces are listed in the table below. The preferred model is to use the common interfaces. The advantage to using the common interfaces is that both point-to-point and pub/sub tasks can be combined in one session, allowing transactions to operate over both domains.

In earlier versions of JMS, there were separate class hierarchies for the pub/sub and point-to-point programming models that had to be used. These class hierarchies are retained to support backward compatibility with earlier versions of the JMS API, but client developers are encouraged to use the common interfaces.

Relationship of PTP and Pub/Sub interfaces
JMS Common | PTP Domain | Pub/Sub Domain
ConnectionFactory | QueueConnectionFactory | TopicConnectionFactory
Connection | QueueConnection | TopicConnection
Destination | Queue | Topic
Session | QueueSession | TopicSession
MessageProducer | QueueSender | TopicPublisher
MessageConsumer | QueueReceiver | TopicSubscriber

The following provides a brief definition of these JMS concepts. See the PTP and Pub/Sub chapters of the JMS specification for more information.

  • ConnectionFactory - an administered object used by a client to create a Connection
  • Connection - an active connection to a JMS provider
  • Destination - an administered object that encapsulates the identity of a message destination
  • Session - a single-threaded context for sending and receiving messages
  • MessageProducer - an object created by a Session that is used for sending messages to a destination
  • MessageConsumer - an object created by a Session that is used for receiving messages sent to a destination

The term consume is used in this document to mean the receipt of a message by a JMS client; that is, a JMS provider has received a message and has given it to its client. Since the JMS API supports both synchronous and asynchronous receipt of messages, the term consume is used when there is no need to make a distinction between them.

The term produce is used as the most general term for sending a message. It means giving a message to a JMS provider for delivery to a destination.

Developing a JMS Application

Broadly speaking, a JMS application is one or more JMS clients that exchange messages. The application may also involve non-JMS clients; however, these clients use the JMS provider's native API in place of the JMS API.

A JMS application can be architected and deployed as a unit. In many cases, JMS clients are added incrementally to an existing application.

The message definitions used by an application may originate with JMS, or they may have been defined by the non-JMS part of the application.

Developing a JMS Client

A typical JMS client executes the following setup procedure:

  • Use JNDI to find a ConnectionFactory object
  • Use JNDI to find one or more Destination objects
  • Use the ConnectionFactory to create a JMS Connection. At this point, message delivery is inhibited
  • Use the Connection to create one or more JMS Sessions
  • Use a Session and the Destinations to create the MessageProducers and MessageConsumers needed
  • Start message delivery for the Connection. Messages will be delivered to MessageConsumers

At this point a client has the basic setup needed to produce and consume messages.

Package Specification

Java Message Service Specification - Version 1.1

Related Documentation

Java Message Service Tutorial

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Destination

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Destination

All Known Subinterfaces:
Queue, TemporaryQueue, TemporaryTopic, Topic
public interface Destination

A Destination object encapsulates a provider-specific address. The JMS API does not define a standard address syntax. Although a standard address syntax was considered, it was decided that the differences in address semantics between existing message-oriented middleware (MOM) products were too wide to bridge with a single syntax.

Since Destination is an administered object, it may contain provider-specific configuration information in addition to its address.

The JMS API also supports a client's use of provider-specific address names.

Destination objects support concurrent use.

A Destination object is a JMS administered object.

JMS administered objects are objects containing configuration information that are created by an administrator and later used by JMS clients. They make it practical to administer the JMS API in the enterprise.

Although the interfaces for administered objects do not explicitly depend on the Java Naming and Directory Interface (JNDI) API, the JMS API establishes the convention that JMS clients find administered objects by looking them up in a JNDI namespace.

An administrator can place an administered object anywhere in a namespace. The JMS API does not define a naming policy.

It is expected that JMS providers will provide the tools an administrator needs to create and configure administered objects in a JNDI namespace. JMS provider implementations of administered objects should implement the javax.naming.Referenceable and java.io.Serializable interfaces so that they can be stored in all JNDI naming contexts. In addition, it is recommended that these implementations follow the JavaBeansTM design patterns.

This strategy provides several benefits:

  • It hides provider-specific details from JMS clients.
  • It abstracts JMS administrative information into objects in the Java programming language ("Java objects") that are easily organized and administered from a common management console.
  • Since there will be JNDI providers for all popular naming services, JMS providers can deliver one implementation of administered objects that will run everywhere.

An administered object should not hold on to any remote resources. Its lookup should not use remote resources other than those used by the JNDI API itself.

Clients should think of administered objects as local Java objects. Looking them up should not have any hidden side effects or use surprising amounts of local resources.

Version:
1.0 - 3 August 1998
Author:
Mark Hapner, Rich Burridge
See Also:
Queue, Topic

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.jms Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.jms

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.jms.QueueRequestor
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.jms.JMSException
          • class javax.jms.IllegalStateException
          • class javax.jms.InvalidClientIDException
          • class javax.jms.InvalidDestinationException
          • class javax.jms.InvalidSelectorException
          • class javax.jms.JMSSecurityException
          • class javax.jms.MessageEOFException
          • class javax.jms.MessageFormatException
          • class javax.jms.MessageNotReadableException
          • class javax.jms.MessageNotWriteableException
          • class javax.jms.ResourceAllocationException
          • class javax.jms.TransactionInProgressException
          • class javax.jms.TransactionRolledBackException
    • class javax.jms.TopicRequestor

Interface Hierarchy

  • interface javax.jms.Connection
    • interface javax.jms.QueueConnection
      • interface javax.jms.XAQueueConnection (also extends javax.jms.XAConnection)
    • interface javax.jms.TopicConnection
      • interface javax.jms.XATopicConnection (also extends javax.jms.XAConnection)
    • interface javax.jms.XAConnection
      • interface javax.jms.XAQueueConnection (also extends javax.jms.QueueConnection)
      • interface javax.jms.XATopicConnection (also extends javax.jms.TopicConnection)
  • interface javax.jms.ConnectionConsumer
  • interface javax.jms.ConnectionFactory
    • interface javax.jms.QueueConnectionFactory
      • interface javax.jms.XAQueueConnectionFactory (also extends javax.jms.XAConnectionFactory)
    • interface javax.jms.TopicConnectionFactory
      • interface javax.jms.XATopicConnectionFactory (also extends javax.jms.XAConnectionFactory)
  • interface javax.jms.ConnectionMetaData
  • interface javax.jms.DeliveryMode
  • interface javax.jms.Destination
    • interface javax.jms.Queue
      • interface javax.jms.TemporaryQueue
    • interface javax.jms.Topic
      • interface javax.jms.TemporaryTopic
  • interface javax.jms.ExceptionListener
  • interface javax.jms.Message
    • interface javax.jms.BytesMessage
    • interface javax.jms.MapMessage
    • interface javax.jms.ObjectMessage
    • interface javax.jms.StreamMessage
    • interface javax.jms.TextMessage
  • interface javax.jms.MessageConsumer
    • interface javax.jms.QueueReceiver
    • interface javax.jms.TopicSubscriber
  • interface javax.jms.MessageListener
  • interface javax.jms.MessageProducer
    • interface javax.jms.QueueSender
    • interface javax.jms.TopicPublisher
  • interface javax.jms.QueueBrowser
  • interface java.lang.Runnable
    • interface javax.jms.Session
      • interface javax.jms.QueueSession
      • interface javax.jms.TopicSession
      • interface javax.jms.XASession
        • interface javax.jms.XAQueueSession
        • interface javax.jms.XATopicSession
  • interface javax.jms.ServerSession
  • interface javax.jms.ServerSessionPool
  • interface javax.jms.XAConnectionFactory
    • interface javax.jms.XAQueueConnectionFactory (also extends javax.jms.QueueConnectionFactory)
    • interface javax.jms.XATopicConnectionFactory (also extends javax.jms.TopicConnectionFactory)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BytesMessage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface BytesMessage

All Superinterfaces:
Message
public interface BytesMessage
extends Message

A BytesMessage object is used to send a message containing a stream of uninterpreted bytes. It inherits from the Message interface and adds a bytes message body. The receiver of the message supplies the interpretation of the bytes.

The BytesMessage methods are based largely on those found in java.io.DataInputStream and java.io.DataOutputStream.

This message type is for client encoding of existing message formats. If possible, one of the other self-defining message types should be used instead.

Although the JMS API allows the use of message properties with byte messages, they are typically not used, since the inclusion of properties may affect the format.

The primitive types can be written explicitly using methods for each type. They may also be written generically as objects. For instance, a call to BytesMessage.writeInt(6) is equivalent to BytesMessage.writeObject(new Integer(6)). Both forms are provided, because the explicit form is convenient for static programming, and the object form is needed when types are not known at compile time.

When the message is first created, and when clearBody is called, the body of the message is in write-only mode. After the first call to reset has been made, the message body is in read-only mode. After a message has been sent, the client that sent it can retain and modify it without affecting the message that has been sent. The same message object can be sent multiple times. When a message has been received, the provider has called reset so that the message body is in read-only mode for the client.

If clearBody is called on a message in read-only mode, the message body is cleared and the message is in write-only mode.

If a client attempts to read a message in write-only mode, a MessageNotReadableException is thrown.

If a client attempts to write a message in read-only mode, a MessageNotWriteableException is thrown.

Version:
1.1 April 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createBytesMessage(), MapMessage, Message, ObjectMessage, StreamMessage, TextMessage

Field Summary
Fields inherited from interface javax.jms.Message
DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE
Method Summary
long | getBodyLength() Gets the number of bytes of the message body when the message is in read-only mode.
boolean | readBoolean() Reads a boolean from the bytes message stream.
byte | readByte() Reads a signed 8-bit value from the bytes message stream.
int | readBytes(byte[] value) Reads a byte array from the bytes message stream.
int | readBytes(byte[] value, int length) Reads a portion of the bytes message stream.
char | readChar() Reads a Unicode character value from the bytes message stream.
double | readDouble() Reads a double from the bytes message stream.
float | readFloat() Reads a float from the bytes message stream.
int | readInt() Reads a signed 32-bit integer from the bytes message stream.
long | readLong() Reads a signed 64-bit integer from the bytes message stream.
short | readShort() Reads a signed 16-bit number from the bytes message stream.
int | readUnsignedByte() Reads an unsigned 8-bit number from the bytes message stream.
int | readUnsignedShort() Reads an unsigned 16-bit number from the bytes message stream.
String | readUTF() Reads a string that has been encoded using a modified UTF-8 format from the bytes message stream.
void | reset() Puts the message body in read-only mode and repositions the stream of bytes to the beginning.
void | writeBoolean(boolean value) Writes a boolean to the bytes message stream as a 1-byte value.
void | writeByte(byte value) Writes a byte to the bytes message stream as a 1-byte value.
void | writeBytes(byte[] value) Writes a byte array to the bytes message stream.
void | writeBytes(byte[] value, int offset, int length) Writes a portion of a byte array to the bytes message stream.
void | writeChar(char value) Writes a char to the bytes message stream as a 2-byte value, high byte first.
void | writeDouble(double value) Converts the double argument to a long using the doubleToLongBits method in class Double, and then writes that long value to the bytes message stream as an 8-byte quantity, high byte first.
void | writeFloat(float value) Converts the float argument to an int using the floatToIntBits method in class Float, and then writes that int value to the bytes message stream as a 4-byte quantity, high byte first.
void | writeInt(int value) Writes an int to the bytes message stream as four bytes, high byte first.
void | writeLong(long value) Writes a long to the bytes message stream as eight bytes, high byte first.
void | writeObject(Object value) Writes an object to the bytes message stream.
void | writeShort(short value) Writes a short to the bytes message stream as two bytes, high byte first.
void | writeUTF(String value) Writes a string to the bytes message stream using UTF-8 encoding in a machine-independent manner.
Methods inherited from interface javax.jms.Message
acknowledge, clearBody, clearProperties, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

Method Detail

getBodyLength

public long getBodyLength()
                   throws JMSException
Gets the number of bytes of the message body when the message is in read-only mode. The value returned can be used to allocate a byte array. The value returned is the entire length of the message body, regardless of where the pointer for reading the message is currently located.

Returns:
number of bytes in the message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageNotReadableException - if the message is in write-only mode.
Since:
1.1

readBoolean

public boolean readBoolean()
                    throws JMSException
Reads a boolean from the bytes message stream.

Returns:
the boolean value read
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readByte

public byte readByte()
              throws JMSException
Reads a signed 8-bit value from the bytes message stream.

Returns:
the next byte from the bytes message stream as a signed 8-bit byte
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readUnsignedByte

public int readUnsignedByte()
                     throws JMSException
Reads an unsigned 8-bit number from the bytes message stream.

Returns:
the next byte from the bytes message stream, interpreted as an unsigned 8-bit number
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readShort

public short readShort()
                throws JMSException
Reads a signed 16-bit number from the bytes message stream.

Returns:
the next two bytes from the bytes message stream, interpreted as a signed 16-bit number
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readUnsignedShort

public int readUnsignedShort()
                      throws JMSException
Reads an unsigned 16-bit number from the bytes message stream.

Returns:
the next two bytes from the bytes message stream, interpreted as an unsigned 16-bit integer
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readChar

public char readChar()
              throws JMSException
Reads a Unicode character value from the bytes message stream.

Returns:
the next two bytes from the bytes message stream as a Unicode character
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readInt

public int readInt()
            throws JMSException
Reads a signed 32-bit integer from the bytes message stream.

Returns:
the next four bytes from the bytes message stream, interpreted as an int
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readLong

public long readLong()
              throws JMSException
Reads a signed 64-bit integer from the bytes message stream.

Returns:
the next eight bytes from the bytes message stream, interpreted as a long
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readFloat

public float readFloat()
                throws JMSException
Reads a float from the bytes message stream.

Returns:
the next four bytes from the bytes message stream, interpreted as a float
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readDouble

public double readDouble()
                  throws JMSException
Reads a double from the bytes message stream.

Returns:
the next eight bytes from the bytes message stream, interpreted as a double
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readUTF

public String readUTF()
               throws JMSException
Reads a string that has been encoded using a modified UTF-8 format from the bytes message stream.

For more information on the UTF-8 format, see "File System Safe UCS Transformation Format (FSS_UTF)", X/Open Preliminary Specification, X/Open Company Ltd., Document Number: P316. This information also appears in ISO/IEC 10646, Annex P.

Returns:
a Unicode string from the bytes message stream
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readBytes

public int readBytes(byte[] value)
              throws JMSException
Reads a byte array from the bytes message stream.

If the length of array value is less than the number of bytes remaining to be read from the stream, the array should be filled. A subsequent call reads the next increment, and so on.

If the number of bytes remaining in the stream is less than the length of array value, the bytes should be read into the array. The return value of the total number of bytes read will be less than the length of the array, indicating that there are no more bytes left to be read from the stream. The next read of the stream returns -1.

Parameters:
value - the buffer into which the data is read
Returns:
the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageNotReadableException - if the message is in write-only mode.

readBytes

public int readBytes(byte[] value,
                     int length)
              throws JMSException
Reads a portion of the bytes message stream.

If the length of array value is less than the number of bytes remaining to be read from the stream, the array should be filled. A subsequent call reads the next increment, and so on.

If the number of bytes remaining in the stream is less than the length of array value, the bytes should be read into the array. The return value of the total number of bytes read will be less than the length of the array, indicating that there are no more bytes left to be read from the stream. The next read of the stream returns -1.

If length is negative, or length is greater than the length of the array value, then an IndexOutOfBoundsException is thrown. No bytes will be read from the stream for this exception case.

Parameters:
value - the buffer into which the data is read
length - the number of bytes to read; must be less than or equal to value.length
Returns:
the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageNotReadableException - if the message is in write-only mode.

writeBoolean

public void writeBoolean(boolean value)
                  throws JMSException
Writes a boolean to the bytes message stream as a 1-byte value. The value true is written as the value (byte)1; the value false is written as the value (byte)0.

Parameters:
value - the boolean value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeByte

public void writeByte(byte value)
               throws JMSException
Writes a byte to the bytes message stream as a 1-byte value.

Parameters:
value - the byte value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeShort

public void writeShort(short value)
                throws JMSException
Writes a short to the bytes message stream as two bytes, high byte first.

Parameters:
value - the short to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeChar

public void writeChar(char value)
               throws JMSException
Writes a char to the bytes message stream as a 2-byte value, high byte first.

Parameters:
value - the char value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeInt

public void writeInt(int value)
              throws JMSException
Writes an int to the bytes message stream as four bytes, high byte first.

Parameters:
value - the int to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeLong

public void writeLong(long value)
               throws JMSException
Writes a long to the bytes message stream as eight bytes, high byte first.

Parameters:
value - the long to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeFloat

public void writeFloat(float value)
                throws JMSException
Converts the float argument to an int using the floatToIntBits method in class Float, and then writes that int value to the bytes message stream as a 4-byte quantity, high byte first.

Parameters:
value - the float value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeDouble

public void writeDouble(double value)
                 throws JMSException
Converts the double argument to a long using the doubleToLongBits method in class Double, and then writes that long value to the bytes message stream as an 8-byte quantity, high byte first.

Parameters:
value - the double value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeUTF

public void writeUTF(String value)
              throws JMSException
Writes a string to the bytes message stream using UTF-8 encoding in a machine-independent manner.

For more information on the UTF-8 format, see "File System Safe UCS Transformation Format (FSS_UTF)", X/Open Preliminary Specification, X/Open Company Ltd., Document Number: P316. This information also appears in ISO/IEC 10646, Annex P.

Parameters:
value - the String value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeBytes

public void writeBytes(byte[] value)
                throws JMSException
Writes a byte array to the bytes message stream.

Parameters:
value - the byte array to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeBytes

public void writeBytes(byte[] value,
                       int offset,
                       int length)
                throws JMSException
Writes a portion of a byte array to the bytes message stream.

Parameters:
value - the byte array value to be written
offset - the initial offset within the byte array
length - the number of bytes to use
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeObject

public void writeObject(Object value)
                 throws JMSException
Writes an object to the bytes message stream.

This method works only for the objectified primitive object types (Integer, Double, Long ...), String objects, and byte arrays.

Parameters:
value - the object in the Java programming language ("Java object") to be written; it must not be null
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageFormatException - if the object is of an invalid type.
MessageNotWriteableException - if the message is in read-only mode.
NullPointerException - if the parameter value is null.

reset

public void reset()
           throws JMSException
Puts the message body in read-only mode and repositions the stream of bytes to the beginning.

Throws:
JMSException - if the JMS provider fails to reset the message due to some internal error.
MessageFormatException - if the message has an invalid format.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Connection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Connection

All Known Subinterfaces:
QueueConnection, TopicConnection, XAConnection, XAQueueConnection, XATopicConnection
public interface Connection

A Connection object is a client's active connection to its JMS provider. It typically allocates provider resources outside the Java virtual machine (JVM).

Connections support concurrent use.

A connection serves several purposes:

  • It encapsulates an open connection with a JMS provider. It typically represents an open TCP/IP socket between a client and the service provider software.
  • Its creation is where client authentication takes place.
  • It can specify a unique client identifier.
  • It provides a ConnectionMetaData object.
  • It supports an optional ExceptionListener object.

Because the creation of a connection involves setting up authentication and communication, a connection is a relatively heavyweight object. Most clients will do all their messaging with a single connection. Other more advanced applications may use several connections. The JMS API does not architect a reason for using multiple connections; however, there may be operational reasons for doing so.

A JMS client typically creates a connection, one or more sessions, and a number of message producers and consumers. When a connection is created, it is in stopped mode. That means that no messages are being delivered.

It is typical to leave the connection in stopped mode until setup is complete (that is, until all message consumers have been created). At that point, the client calls the connection's start method, and messages begin arriving at the connection's consumers. This setup convention minimizes any client confusion that may result from asynchronous message delivery while the client is still in the process of setting itself up.

A connection can be started immediately, and the setup can be done afterwards. Clients that do this must be prepared to handle asynchronous message delivery while they are still in the process of setting up.

A message producer can send messages while a connection is stopped.

Version:
1.1 - February 1, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
ConnectionFactory, QueueConnection, TopicConnection

Method Summary
void | close() Closes the connection.
ConnectionConsumer | createConnectionConsumer(Destination destination, String messageSelector, ServerSessionPool sessionPool, int maxMessages) Creates a connection consumer for this connection (optional operation).
ConnectionConsumer | createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages) Create a durable connection consumer for this connection (optional operation).
Session | createSession(boolean transacted, int acknowledgeMode) Creates a Session object.
String | getClientID() Gets the client identifier for this connection.
ExceptionListener | getExceptionListener() Gets the ExceptionListener object for this connection.
ConnectionMetaData | getMetaData() Gets the metadata for this connection.
void | setClientID(String clientID) Sets the client identifier for this connection.
void | setExceptionListener(ExceptionListener listener) Sets an exception listener for this connection.
void | start() Starts (or restarts) a connection's delivery of incoming messages.
void | stop() Temporarily stops a connection's delivery of incoming messages.

Method Detail

createSession

public Session createSession(boolean transacted,
                             int acknowledgeMode)
                      throws JMSException
Creates a Session object.

Parameters:
transacted - indicates whether the session is transacted
acknowledgeMode - indicates whether the consumer or the client will acknowledge any messages it receives; ignored if the session is transacted. Legal values are Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, and Session.DUPS_OK_ACKNOWLEDGE.
Returns:
a newly created session
Throws:
JMSException - if the Connection object fails to create a session due to some internal error or lack of support for the specific transaction and acknowledgement mode.
Since:
1.1
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE

getClientID

public String getClientID()
                   throws JMSException
Gets the client identifier for this connection.

This value is specific to the JMS provider. It is either preconfigured by an administrator in a ConnectionFactory object or assigned dynamically by the application by calling the setClientID method.

Returns:
the unique client identifier
Throws:
JMSException - if the JMS provider fails to return the client ID for this connection due to some internal error.

setClientID

public void setClientID(String clientID)
                 throws JMSException
Sets the client identifier for this connection.

The preferred way to assign a JMS client's client identifier is for it to be configured in a client-specific ConnectionFactory object and transparently assigned to the Connection object it creates.

Alternatively, a client can set a connection's client identifier using a provider-specific value. The facility to set a connection's client identifier explicitly is not a mechanism for overriding the identifier that has been administratively configured. It is provided for the case where no administratively specified identifier exists. If one does exist, an attempt to change it by setting it must throw an IllegalStateException. If a client sets the client identifier explicitly, it must do so immediately after it creates the connection and before any other action on the connection is taken. After this point, setting the client identifier is a programming error that should throw an IllegalStateException.

The purpose of the client identifier is to associate a connection and its objects with a state maintained on behalf of the client by a provider. The only such state identified by the JMS API is that required to support durable subscriptions.

If another connection with the same clientID is already running when this method is called, the JMS provider should detect the duplicate ID and throw an InvalidClientIDException.

Parameters:
clientID - the unique client identifier
Throws:
JMSException - if the JMS provider fails to set the client ID for this connection due to some internal error.
InvalidClientIDException - if the JMS client specifies an invalid or duplicate client ID.
IllegalStateException - if the JMS client attempts to set a connection's client ID at the wrong time or when it has been administratively configured.

getMetaData

public ConnectionMetaData getMetaData()
                               throws JMSException
Gets the metadata for this connection.

Returns:
the connection metadata
Throws:
JMSException - if the JMS provider fails to get the connection metadata for this connection.
See Also:
ConnectionMetaData

getExceptionListener

public ExceptionListener getExceptionListener()
                                       throws JMSException
Gets the ExceptionListener object for this connection. Not every Connection has an ExceptionListener associated with it.

Returns:
the ExceptionListener for this connection, or null. if no ExceptionListener is associated with this connection.
Throws:
JMSException - if the JMS provider fails to get the ExceptionListener for this connection.
See Also:
setExceptionListener(javax.jms.ExceptionListener)

setExceptionListener

public void setExceptionListener(ExceptionListener listener)
                          throws JMSException
Sets an exception listener for this connection.

If a JMS provider detects a serious problem with a connection, it informs the connection's ExceptionListener, if one has been registered. It does this by calling the listener's onException method, passing it a JMSException object describing the problem.

An exception listener allows a client to be notified of a problem asynchronously. Some connections only consume messages, so they would have no other way to learn their connection has failed.

A connection serializes execution of its ExceptionListener.

A JMS provider should attempt to resolve connection problems itself before it notifies the client of them.

Parameters:
listener - the exception listener
Throws:
JMSException - if the JMS provider fails to set the exception listener for this connection.

start

public void start()
           throws JMSException
Starts (or restarts) a connection's delivery of incoming messages. A call to start on a connection that has already been started is ignored.

Throws:
JMSException - if the JMS provider fails to start message delivery due to some internal error.
See Also:
stop()

stop

public void stop()
          throws JMSException
Temporarily stops a connection's delivery of incoming messages. Delivery can be restarted using the connection's start method. When the connection is stopped, delivery to all the connection's message consumers is inhibited: synchronous receives block, and messages are not delivered to message listeners.

This call blocks until receives and/or message listeners in progress have completed.

Stopping a connection has no effect on its ability to send messages. A call to stop on a connection that has already been stopped is ignored.

A call to stop must not return until delivery of messages has paused. This means that a client can rely on the fact that none of its message listeners will be called and that all threads of control waiting for receive calls to return will not return with a message until the connection is restarted. The receive timers for a stopped connection continue to advance, so receives may time out while the connection is stopped.

If message listeners are running when stop is invoked, the stop call must wait until all of them have returned before it may return. While these message listeners are completing, they must have the full services of the connection available to them.

Throws:
JMSException - if the JMS provider fails to stop message delivery due to some internal error.
See Also:
start()

close

public void close()
           throws JMSException
Closes the connection.

Since a provider typically allocates significant resources outside the JVM on behalf of a connection, clients should close these resources when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

There is no need to close the sessions, producers, and consumers of a closed connection.

Closing a connection causes all temporary destinations to be deleted.

When this method is invoked, it should not return until message processing has been shut down in an orderly fashion. This means that all message listeners that may have been running have returned, and that all pending receives have returned. A close terminates all pending message receives on the connection's sessions' consumers. The receives may return with a message or with null, depending on whether there was a message available at the time of the close. If one or more of the connection's sessions' message listeners is processing a message at the time when connection close is invoked, all the facilities of the connection and its sessions must remain available to those listeners until they return control to the JMS provider.

Closing a connection causes any of its sessions' transactions in progress to be rolled back. In the case where a session's work is coordinated by an external transaction manager, a session's commit and rollback methods are not used and the result of a closed session's work is determined later by the transaction manager. Closing a connection does NOT force an acknowledgment of client-acknowledged sessions.

Invoking the acknowledge method of a received message from a closed connection's session must throw an IllegalStateException. Closing a closed connection must NOT throw an exception.

Throws:
JMSException - if the JMS provider fails to close the connection due to some internal error. For example, a failure to release resources or to close a socket connection can cause this exception to be thrown.

createConnectionConsumer

public ConnectionConsumer createConnectionConsumer(Destination destination,
                                                   String messageSelector,
                                                   ServerSessionPool sessionPool,
                                                   int maxMessages)
                                            throws JMSException
Creates a connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.

Parameters:
destination - the destination to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
sessionPool - the server session pool to associate with this connection consumer
maxMessages - the maximum number of messages that can be assigned to a server session at one time
Returns:
the connection consumer
Throws:
JMSException - if the Connection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
InvalidDestinationException - if an invalid destination is specified.
InvalidSelectorException - if the message selector is invalid.
Since:
1.1
See Also:
ConnectionConsumer

createDurableConnectionConsumer

public ConnectionConsumer createDurableConnectionConsumer(Topic topic,
                                                          String subscriptionName,
                                                          String messageSelector,
                                                          ServerSessionPool sessionPool,
                                                          int maxMessages)
                                                   throws JMSException
Create a durable connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.

Parameters:
topic - topic to access
subscriptionName - durable subscription name
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
sessionPool - the server session pool to associate with this durable connection consumer
maxMessages - the maximum number of messages that can be assigned to a server session at one time
Returns:
the durable connection consumer
Throws:
JMSException - if the Connection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
InvalidDestinationException - if an invalid destination is specified.
InvalidSelectorException - if the message selector is invalid.
Since:
1.1
See Also:
ConnectionConsumer
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionConsumer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ConnectionConsumer

public interface ConnectionConsumer

For application servers, Connection objects provide a special facility for creating a ConnectionConsumer (optional). The messages it is to consume are specified by a Destination and a message selector. In addition, a ConnectionConsumer must be given a ServerSessionPool to use for processing its messages.

Normally, when traffic is light, a ConnectionConsumer gets a ServerSession from its pool, loads it with a single message, and starts it. As traffic picks up, messages can back up. If this happens, a ConnectionConsumer can load each ServerSession with more than one message. This reduces the thread context switches and minimizes resource use at the expense of some serialization of message processing.

Version:
1.1 February 8, 2002
Author:
Mark Hapner, Rich Burridge
See Also:
Connection.createConnectionConsumer(javax.jms.Destination, java.lang.String, javax.jms.ServerSessionPool, int),
Connection.createDurableConnectionConsumer(javax.jms.Topic, java.lang.String, java.lang.String, javax.jms.ServerSessionPool, int),
QueueConnection.createConnectionConsumer(javax.jms.Queue, java.lang.String, javax.jms.ServerSessionPool, int),
TopicConnection.createConnectionConsumer(javax.jms.Topic, java.lang.String, javax.jms.ServerSessionPool, int),
TopicConnection.createDurableConnectionConsumer(javax.jms.Topic, java.lang.String, java.lang.String, javax.jms.ServerSessionPool, int)

Method Summary
void | close() Closes the connection consumer.
ServerSessionPool | getServerSessionPool() Gets the server session pool associated with this connection consumer.

Method Detail

getServerSessionPool

public ServerSessionPool getServerSessionPool()
                                       throws JMSException
Gets the server session pool associated with this connection consumer.

Returns:
the server session pool used by this connection consumer
Throws:
JMSException - if the JMS provider fails to get the server session pool associated with this consumer due to some internal error.

close

public void close()
           throws JMSException
Closes the connection consumer.

Since a provider may allocate some resources on behalf of a connection consumer outside the Java virtual machine, clients should close these resources when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

Throws:
JMSException - if the JMS provider fails to release resources on behalf of the connection consumer or fails to close the connection consumer.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ConnectionFactory

All Known Subinterfaces:
QueueConnectionFactory, TopicConnectionFactory, XAQueueConnectionFactory, XATopicConnectionFactory
public interface ConnectionFactory

A ConnectionFactory object encapsulates a set of connection configuration parameters that has been defined by an administrator. A client uses it to create a connection with a JMS provider.

A ConnectionFactory object is a JMS administered object and supports concurrent use.

JMS administered objects are objects containing configuration information that are created by an administrator and later used by JMS clients. They make it practical to administer the JMS API in the enterprise.

Although the interfaces for administered objects do not explicitly depend on the Java Naming and Directory Interface (JNDI) API, the JMS API establishes the convention that JMS clients find administered objects by looking them up in a JNDI namespace.

An administrator can place an administered object anywhere in a namespace. The JMS API does not define a naming policy.

It is expected that JMS providers will provide the tools an administrator needs to create and configure administered objects in a JNDI namespace. JMS provider implementations of administered objects should be both javax.jndi.Referenceable and java.io.Serializable so that they can be stored in all JNDI naming contexts. In addition, it is recommended that these implementations follow the JavaBeansTM design patterns.

This strategy provides several benefits:

  • It hides provider-specific details from JMS clients.
  • It abstracts administrative information into objects in the Java programming language ("Java objects") that are easily organized and administered from a common management console.
  • Since there will be JNDI providers for all popular naming services, this means that JMS providers can deliver one implementation of administered objects that will run everywhere.

An administered object should not hold on to any remote resources. Its lookup should not use remote resources other than those used by the JNDI API itself.

Clients should think of administered objects as local Java objects. Looking them up should not have any hidden side effects or use surprising amounts of local resources.

Version:
1.1 - February 1, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Connection, QueueConnectionFactory, TopicConnectionFactory

Method Summary
Connection | createConnection() Creates a connection with the default user identity.
Connection | createConnection(String userName, String password) Creates a connection with the specified user identity.

Method Detail

createConnection

public Connection createConnection()
                            throws JMSException
Creates a connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Returns:
a newly created connection
Throws:
JMSException - if the JMS provider fails to create the connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Since:
1.1

createConnection

public Connection createConnection(String userName,
                                   String password)
                            throws JMSException
Creates a connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created connection
Throws:
JMSException - if the JMS provider fails to create the connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Since:
1.1
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionMetaData

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ConnectionMetaData

public interface ConnectionMetaData

A ConnectionMetaData object provides information describing the Connection object.

Version:
1.0 - 13 March 1998
Author:
Mark Hapner, Rich Burridge

Method Summary
int | getJMSMajorVersion() Gets the JMS major version number.
int | getJMSMinorVersion() Gets the JMS minor version number.
String | getJMSProviderName() Gets the JMS provider name.
String | getJMSVersion() Gets the JMS API version.
Enumeration | getJMSXPropertyNames() Gets an enumeration of the JMSX property names.
int | getProviderMajorVersion() Gets the JMS provider major version number.
int | getProviderMinorVersion() Gets the JMS provider minor version number.
String | getProviderVersion() Gets the JMS provider version.

Method Detail

getJMSVersion

public String getJMSVersion()
                     throws JMSException
Gets the JMS API version.

Returns:
the JMS API version
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getJMSMajorVersion

public int getJMSMajorVersion()
                       throws JMSException
Gets the JMS major version number.

Returns:
the JMS API major version number
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getJMSMinorVersion

public int getJMSMinorVersion()
                       throws JMSException
Gets the JMS minor version number.

Returns:
the JMS API minor version number
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getJMSProviderName

public String getJMSProviderName()
                          throws JMSException
Gets the JMS provider name.

Returns:
the JMS provider name
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getProviderVersion

public String getProviderVersion()
                          throws JMSException
Gets the JMS provider version.

Returns:
the JMS provider version
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getProviderMajorVersion

public int getProviderMajorVersion()
                            throws JMSException
Gets the JMS provider major version number.

Returns:
the JMS provider major version number
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getProviderMinorVersion

public int getProviderMinorVersion()
                            throws JMSException
Gets the JMS provider minor version number.

Returns:
the JMS provider minor version number
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getJMSXPropertyNames

public Enumeration getJMSXPropertyNames()
                                 throws JMSException
Gets an enumeration of the JMSX property names.

Returns:
an Enumeration of JMSX property names
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeliveryMode

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface DeliveryMode

public interface DeliveryMode

The delivery modes supported by the JMS API are PERSISTENT and NON_PERSISTENT.

A client marks a message as persistent if it feels that the application will have problems if the message is lost in transit. A client marks a message as non-persistent if an occasional lost message is tolerable. Clients use delivery mode to tell a JMS provider how to balance message transport reliability with throughput.

Delivery mode covers only the transport of the message to its destination. Retention of a message at the destination until its receipt is acknowledged is not guaranteed by a PERSISTENT delivery mode. Clients should assume that message retention policies are set administratively. Message retention policy governs the reliability of message delivery from destination to message consumer. For example, if a client's message storage space is exhausted, some messages may be dropped in accordance with a site-specific message retention policy.

A message is guaranteed to be delivered once and only once by a JMS provider if the delivery mode of the message is PERSISTENT and if the destination has a sufficient message retention policy.

Version:
1.0 - 7 August 1998
Author:
Mark Hapner, Rich Burridge

Field Summary
static int | NON_PERSISTENT This is the lowest-overhead delivery mode because it does not require that the message be logged to stable storage.
static int | PERSISTENT This delivery mode instructs the JMS provider to log the message to stable storage as part of the client's send operation.

Field Detail

NON_PERSISTENT

public static final int NON_PERSISTENT
This is the lowest-overhead delivery mode because it does not require that the message be logged to stable storage. The level of JMS provider failure that causes a NON_PERSISTENT message to be lost is not defined.

A JMS provider must deliver a NON_PERSISTENT message with an at-most-once guarantee. This means that it may lose the message, but it must not deliver it twice.

See Also:
Constant Field Values

PERSISTENT

public static final int PERSISTENT
This delivery mode instructs the JMS provider to log the message to stable storage as part of the client's send operation. Only a hard media failure should cause a PERSISTENT message to be lost.

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ExceptionListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ExceptionListener

public interface ExceptionListener

If a JMS provider detects a serious problem with a Connection object, it informs the Connection object's ExceptionListener, if one has been registered. It does this by calling the listener's onException method, passing it a JMSException argument describing the problem.

An exception listener allows a client to be notified of a problem asynchronously. Some connections only consume messages, so they would have no other way to learn that their connection has failed.

A JMS provider should attempt to resolve connection problems itself before it notifies the client of them.

Version:
1.0 - 9 March 1998
Author:
Mark Hapner, Rich Burridge
See Also:
Connection.setExceptionListener(ExceptionListener)

Method Summary
 void onException(JMSException exception)
Notifies user of a JMS exception.

Method Detail

onException

public void onException(JMSException exception)
Notifies user of a JMS exception.

Parameters:
exception - the JMS exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


IllegalStateException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class IllegalStateException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.IllegalStateException
All Implemented Interfaces:
Serializable
public class IllegalStateException
extends JMSException

This exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation. For example, this exception must be thrown if Session.commit is called on a non-transacted session. This exception is also called when a domain inappropriate method is called, such as calling TopicSession.CreateQueueBrowser.

Version:
April 9, 2002
Author:
Rahul Sharma, Kate Stout
See Also:
Serialized Form

Constructor Summary
IllegalStateException(String reason)
Constructs an IllegalStateException with the specified reason.
IllegalStateException(String reason, String errorCode)
Constructs an IllegalStateException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IllegalStateException

public IllegalStateException(String reason,
                             String errorCode)
Constructs an IllegalStateException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

IllegalStateException

public IllegalStateException(String reason)
Constructs an IllegalStateException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidClientIDException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class InvalidClientIDException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.InvalidClientIDException
All Implemented Interfaces:
Serializable
public class InvalidClientIDException
extends JMSException

This exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
InvalidClientIDException(String reason)
Constructs an InvalidClientIDException with the specified reason.
InvalidClientIDException(String reason, String errorCode)
Constructs an InvalidClientIDException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidClientIDException

public InvalidClientIDException(String reason,
                                String errorCode)
Constructs an InvalidClientIDException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

InvalidClientIDException

public InvalidClientIDException(String reason)
Constructs an InvalidClientIDException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidDestinationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class InvalidDestinationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.InvalidDestinationException
All Implemented Interfaces:
Serializable
public class InvalidDestinationException
extends JMSException

This exception must be thrown when a destination either is not understood by a provider or is no longer valid.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
InvalidDestinationException(String reason)
Constructs an InvalidDestinationException with the specified reason.
InvalidDestinationException(String reason, String errorCode)
Constructs an InvalidDestinationException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidDestinationException

public InvalidDestinationException(String reason,
                                   String errorCode)
Constructs an InvalidDestinationException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

InvalidDestinationException

public InvalidDestinationException(String reason)
Constructs an InvalidDestinationException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidSelectorException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class InvalidSelectorException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.InvalidSelectorException
All Implemented Interfaces:
Serializable
public class InvalidSelectorException
extends JMSException

This exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
InvalidSelectorException(String reason)
Constructs an InvalidSelectorException with the specified reason.
InvalidSelectorException(String reason, String errorCode)
Constructs an InvalidSelectorException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidSelectorException

public InvalidSelectorException(String reason,
                                String errorCode)
Constructs an InvalidSelectorException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

InvalidSelectorException

public InvalidSelectorException(String reason)
Constructs an InvalidSelectorException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JMSException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class JMSException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
IllegalStateException, InvalidClientIDException, InvalidDestinationException, InvalidSelectorException, JMSSecurityException, MessageEOFException, MessageFormatException, MessageNotReadableException, MessageNotWriteableException, ResourceAllocationException, TransactionInProgressException, TransactionRolledBackException
public class JMSException
extends Exception

This is the root class of all JMS API exceptions.

It provides the following information:

  • A provider-specific string describing the error. This string is the standard exception message and is available via the getMessage method.
  • A provider-specific string error code
  • A reference to another exception. Often a JMS API exception will be the result of a lower-level problem. If appropriate, this lower-level exception can be linked to the JMS API exception.

Version:
1.0 - 5 Oct 1998
Author:
Mark Hapner, Rich Burridge
See Also:
Serialized Form

Constructor Summary
JMSException(String reason)
Constructs a JMSException with the specified reason and with the error code defaulting to null.
JMSException(String reason, String errorCode)
Constructs a JMSException with the specified reason and error code.
Method Summary
String | getErrorCode() Gets the vendor-specific error code.
Exception | getLinkedException() Gets the exception linked to this one.
void | setLinkedException(Exception ex) Adds a linked Exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JMSException

public JMSException(String reason,
                    String errorCode)
Constructs a JMSException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

JMSException

public JMSException(String reason)
Constructs a JMSException with the specified reason and with the error code defaulting to null.

Parameters:
reason - a description of the exception
Method Detail

getErrorCode

public String getErrorCode()
Gets the vendor-specific error code.

Returns:
a string specifying the vendor-specific error code

getLinkedException

public Exception getLinkedException()
Gets the exception linked to this one.

Returns:
the linked Exception, null if none

setLinkedException

public void setLinkedException(Exception ex)
Adds a linked Exception.

Parameters:
ex - the linked Exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JMSSecurityException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class JMSSecurityException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.JMSSecurityException
All Implemented Interfaces:
Serializable
public class JMSSecurityException
extends JMSException

This exception must be thrown when a provider rejects a user name/password submitted by a client. It may also be thrown for any case where a security restriction prevents a method from completing.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
JMSSecurityException(String reason)
Constructs a JMSSecurityException with the specified reason.
JMSSecurityException(String reason, String errorCode)
Constructs a JMSSecurityException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JMSSecurityException

public JMSSecurityException(String reason,
                            String errorCode)
Constructs a JMSSecurityException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

JMSSecurityException

public JMSSecurityException(String reason)
Constructs a JMSSecurityException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MapMessage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface MapMessage

All Superinterfaces:
Message
public interface MapMessage
extends Message

A MapMessage object is used to send a set of name-value pairs. The names are String objects, and the values are primitive data types in the Java programming language. The names must have a value that is not null, and not an empty string. The entries can be accessed sequentially or randomly by name. The order of the entries is undefined. MapMessage inherits from the Message interface and adds a message body that contains a Map.

The primitive types can be read or written explicitly using methods for each type. They may also be read or written generically as objects. For instance, a call to MapMessage.setInt("foo", 6) is equivalent to MapMessage.setObject("foo", new Integer(6)). Both forms are provided, because the explicit form is convenient for static programming, and the object form is needed when types are not known at compile time.

When a client receives a MapMessage, it is in read-only mode. If a client attempts to write to the message at this point, a MessageNotWriteableException is thrown. If clearBody is called, the message can now be both read from and written to.

MapMessage objects support the following conversion table. The marked cases must be supported. The unmarked cases must throw a JMSException. The String-to-primitive conversions may throw a runtime exception if the primitive's valueOf() method does not accept it as a valid String representation of the primitive.

A value written as the row type can be read as the column type.

 |        | boolean byte short char int long float double String byte[]
 |----------------------------------------------------------------------
 |boolean |    X                                            X
 |byte    |          X     X         X   X                  X
 |short   |                X         X   X                  X
 |char    |                     X                           X
 |int     |                          X   X                  X
 |long    |                              X                  X
 |float   |                                    X     X      X
 |double  |                                          X      X
 |String  |    X     X     X         X   X     X     X      X
 |byte[]  |                                                        X
 |----------------------------------------------------------------------

Attempting to read a null value as a primitive type must be treated as calling the primitive's corresponding valueOf(String) conversion method with a null value. Since char does not support a String conversion, attempting to read a null value as a char must throw a NullPointerException.

Version:
1.1 February 2, 002
Author:
Mark Hapner, Rich Burridge
See Also:
Session.createMapMessage(), BytesMessage, Message, ObjectMessage, StreamMessage, TextMessage

Field Summary
Fields inherited from interface javax.jms.Message
DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE
Method Summary
boolean | getBoolean(String name) Returns the boolean value with the specified name.
byte | getByte(String name) Returns the byte value with the specified name.
byte[] | getBytes(String name) Returns the byte array value with the specified name.
char | getChar(String name) Returns the Unicode character value with the specified name.
double | getDouble(String name) Returns the double value with the specified name.
float | getFloat(String name) Returns the float value with the specified name.
int | getInt(String name) Returns the int value with the specified name.
long | getLong(String name) Returns the long value with the specified name.
Enumeration | getMapNames() Returns an Enumeration of all the names in the MapMessage object.
Object | getObject(String name) Returns the value of the object with the specified name.
short | getShort(String name) Returns the short value with the specified name.
String | getString(String name) Returns the String value with the specified name.
boolean | itemExists(String name) Indicates whether an item exists in this MapMessage object.
void | setBoolean(String name, boolean value) Sets a boolean value with the specified name into the Map.
void | setByte(String name, byte value) Sets a byte value with the specified name into the Map.
void | setBytes(String name, byte[] value) Sets a byte array value with the specified name into the Map.
void | setBytes(String name, byte[] value, int offset, int length) Sets a portion of the byte array value with the specified name into the Map.
void | setChar(String name, char value) Sets a Unicode character value with the specified name into the Map.
void | setDouble(String name, double value) Sets a double value with the specified name into the Map.
void | setFloat(String name, float value) Sets a float value with the specified name into the Map.
void | setInt(String name, int value) Sets an int value with the specified name into the Map.
void | setLong(String name, long value) Sets a long value with the specified name into the Map.
void | setObject(String name, Object value) Sets an object value with the specified name into the Map.
void | setShort(String name, short value) Sets a short value with the specified name into the Map.
void | setString(String name, String value) Sets a String value with the specified name into the Map.
Methods inherited from interface javax.jms.Message
acknowledge, clearBody, clearProperties, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

Method Detail

getBoolean

public boolean getBoolean(String name)
                   throws JMSException
Returns the boolean value with the specified name.

Parameters:
name - the name of the boolean
Returns:
the boolean value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getByte

public byte getByte(String name)
             throws JMSException
Returns the byte value with the specified name.

Parameters:
name - the name of the byte
Returns:
the byte value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getShort

public short getShort(String name)
               throws JMSException
Returns the short value with the specified name.

Parameters:
name - the name of the short
Returns:
the short value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getChar

public char getChar(String name)
             throws JMSException
Returns the Unicode character value with the specified name.

Parameters:
name - the name of the Unicode character
Returns:
the Unicode character value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getInt

public int getInt(String name)
           throws JMSException
Returns the int value with the specified name.

Parameters:
name - the name of the int
Returns:
the int value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getLong

public long getLong(String name)
             throws JMSException
Returns the long value with the specified name.

Parameters:
name - the name of the long
Returns:
the long value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getFloat

public float getFloat(String name)
               throws JMSException
Returns the float value with the specified name.

Parameters:
name - the name of the float
Returns:
the float value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getDouble

public double getDouble(String name)
                 throws JMSException
Returns the double value with the specified name.

Parameters:
name - the name of the double
Returns:
the double value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getString

public String getString(String name)
                 throws JMSException
Returns the String value with the specified name.

Parameters:
name - the name of the String
Returns:
the String value with the specified name; if there is no item by this name, a null value is returned
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getBytes

public byte[] getBytes(String name)
                throws JMSException
Returns the byte array value with the specified name.

Parameters:
name - the name of the byte array
Returns:
a copy of the byte array value with the specified name; if there is no item by this name, a null value is returned.
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getObject

public Object getObject(String name)
                 throws JMSException
Returns the value of the object with the specified name.

This method can be used to return, in objectified format, an object in the Java programming language ("Java object") that had been stored in the Map with the equivalent setObject method call, or its equivalent primitive settype method.

Note that byte values are returned as byte[], not Byte[].

Parameters:
name - the name of the Java object
Returns:
a copy of the Java object value with the specified name, in objectified format (for example, if the object was set as an int, an Integer is returned); if there is no item by this name, a null value is returned
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.

getMapNames

public Enumeration getMapNames()
                        throws JMSException
Returns an Enumeration of all the names in the MapMessage object.

Returns:
an enumeration of all the names in this MapMessage
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.

setBoolean

public void setBoolean(String name,
                       boolean value)
                throws JMSException
Sets a boolean value with the specified name into the Map.

Parameters:
name - the name of the boolean
value - the boolean value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setByte

public void setByte(String name,
                    byte value)
             throws JMSException
Sets a byte value with the specified name into the Map.

Parameters:
name - the name of the byte
value - the byte value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setShort

public void setShort(String name,
                     short value)
              throws JMSException
Sets a short value with the specified name into the Map.

Parameters:
name - the name of the short
value - the short value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setChar

public void setChar(String name,
                    char value)
             throws JMSException
Sets a Unicode character value with the specified name into the Map.

Parameters:
name - the name of the Unicode character
value - the Unicode character value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setInt

public void setInt(String name,
                   int value)
            throws JMSException
Sets an int value with the specified name into the Map.

Parameters:
name - the name of the int
value - the int value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setLong

public void setLong(String name,
                    long value)
             throws JMSException
Sets a long value with the specified name into the Map.

Parameters:
name - the name of the long
value - the long value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setFloat

public void setFloat(String name,
                     float value)
              throws JMSException
Sets a float value with the specified name into the Map.

Parameters:
name - the name of the float
value - the float value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setDouble

public void setDouble(String name,
                      double value)
               throws JMSException
Sets a double value with the specified name into the Map.

Parameters:
name - the name of the double
value - the double value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setString

public void setString(String name,
                      String value)
               throws JMSException
Sets a String value with the specified name into the Map.

Parameters:
name - the name of the String
value - the String value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setBytes

public void setBytes(String name,
                     byte[] value)
              throws JMSException
Sets a byte array value with the specified name into the Map.

Parameters:
name - the name of the byte array
value - the byte array value to set in the Map; the array is copied so that the value for name will not be altered by future modifications
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
NullPointerException - if the name is null, or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setBytes

public void setBytes(String name,
                     byte[] value,
                     int offset,
                     int length)
              throws JMSException
Sets a portion of the byte array value with the specified name into the Map.

Parameters:
name - the name of the byte array
value - the byte array value to set in the Map
offset - the initial offset within the byte array
length - the number of bytes to use
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setObject

public void setObject(String name,
                      Object value)
               throws JMSException
Sets an object value with the specified name into the Map.

This method works only for the objectified primitive object types (Integer, Double, Long ...), String objects, and byte arrays.

Parameters:
name - the name of the Java object
value - the Java object value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageFormatException - if the object is invalid.
MessageNotWriteableException - if the message is in read-only mode.

itemExists

public boolean itemExists(String name)
                   throws JMSException
Indicates whether an item exists in this MapMessage object.

Parameters:
name - the name of the item to test
Returns:
true if the item exists
Throws:
JMSException - if the JMS provider fails to determine if the item exists due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Message

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Message

All Known Subinterfaces:
BytesMessage, MapMessage, ObjectMessage, StreamMessage, TextMessage
public interface Message

The Message interface is the root interface of all JMS messages. It defines the message header and the acknowledge method used for all messages.

Most message-oriented middleware (MOM) products treat messages as lightweight entities that consist of a header and a payload. The header contains fields used for message routing and identification; the payload contains the application data being sent.

Within this general form, the definition of a message varies significantly across products. It would be quite difficult for the JMS API to support all of these message models.

With this in mind, the JMS message model has the following goals:

  • Provide a single, unified message API
  • Provide an API suitable for creating messages that match the format used by provider-native messaging applications
  • Support the development of heterogeneous applications that span operating systems, machine architectures, and computer languages
  • Support messages containing objects in the Java programming language ("Java objects")
  • Support messages containing Extensible Markup Language (XML) pages

JMS messages are composed of the following parts:

  • Header - All messages support the same set of header fields. Header fields contain values used by both clients and providers to identify and route messages.
  • Properties - Each message contains a built-in facility for supporting application-defined property values. Properties provide an efficient mechanism for supporting application-defined message filtering.
  • Body - The JMS API defines several types of message body, which cover the majority of messaging styles currently in use.

Message Bodies

The JMS API defines five types of message body:

  • Stream - A StreamMessage object's message body contains a stream of primitive values in the Java programming language ("Java primitives"). It is filled and read sequentially.
  • Map - A MapMessage object's message body contains a set of name-value pairs, where names are String objects, and values are Java primitives. The entries can be accessed sequentially or randomly by name. The order of the entries is undefined.
  • Text - A TextMessage object's message body contains a java.lang.String object. This message type can be used to transport plain-text messages, and XML messages.
  • Object - An ObjectMessage object's message body contains a Serializable Java object.
  • Bytes - A BytesMessage object's message body contains a stream of uninterpreted bytes. This message type is for literally encoding a body to match an existing message format. In many cases, it is possible to use one of the other body types, which are easier to use. Although the JMS API allows the use of message properties with byte messages, they are typically not used, since the inclusion of properties may affect the format.

Message Headers

The JMSCorrelationID header field is used for linking one message with another. It typically links a reply message with its requesting message.

JMSCorrelationID can hold a provider-specific message ID, an application-specific String object, or a provider-native byte[] value.

Message Properties

A Message object contains a built-in facility for supporting application-defined property values. In effect, this provides a mechanism for adding application-specific header fields to a message.

Properties allow an application, via message selectors, to have a JMS provider select, or filter, messages on its behalf using application-specific criteria.

Property names must obey the rules for a message selector identifier. Property names must not be null, and must not be empty strings. If a property name is set and it is either null or an empty string, an IllegalArgumentException must be thrown.

Property values can be boolean, byte, short, int, long, float, double, and String.

Property values are set prior to sending a message. When a client receives a message, its properties are in read-only mode. If a client attempts to set properties at this point, a MessageNotWriteableException is thrown. If clearProperties is called, the properties can now be both read from and written to. Note that header fields are distinct from properties. Header fields are never in read-only mode.

A property value may duplicate a value in a message's body, or it may not. Although JMS does not define a policy for what should or should not be made a property, application developers should note that JMS providers will likely handle data in a message's body more efficiently than data in a message's properties. For best performance, applications should use message properties only when they need to customize a message's header. The primary reason for doing this is to support customized message selection.

Message properties support the following conversion table. The marked cases must be supported. The unmarked cases must throw a JMSException. The String-to-primitive conversions may throw a runtime exception if the primitive's valueOf method does not accept the String as a valid representation of the primitive.

A value written as the row type can be read as the column type.

 |        | boolean byte short int long float double String
 |----------------------------------------------------------
 |boolean |    X                                       X
 |byte    |          X     X    X   X                  X
 |short   |                X    X   X                  X
 |int     |                     X   X                  X
 |long    |                         X                  X
 |float   |                               X     X      X
 |double  |                                     X      X
 |String  |    X     X     X    X   X     X     X      X
 |----------------------------------------------------------

In addition to the type-specific set/get methods for properties, JMS provides the setObjectProperty and getObjectProperty methods. These support the same set of property types using the objectified primitive values. Their purpose is to allow the decision of property type to made at execution time rather than at compile time. They support the same property value conversions.

The setObjectProperty method accepts values of class Boolean, Byte, Short, Integer, Long, Float, Double, and String. An attempt to use any other class must throw a JMSException.

The getObjectProperty method only returns values of class Boolean, Byte, Short, Integer, Long, Float, Double, and String.

The order of property values is not defined. To iterate through a message's property values, use getPropertyNames to retrieve a property name enumeration and then use the various property get methods to retrieve their values.

A message's properties are deleted by the clearProperties method. This leaves the message with an empty set of properties.

Getting a property value for a name which has not been set returns a null value. Only the getStringProperty and getObjectProperty methods can return a null value. Attempting to read a null value as a primitive type must be treated as calling the primitive's corresponding valueOf(String) conversion method with a null value.

The JMS API reserves the JMSX property name prefix for JMS defined properties. The full set of these properties is defined in the Java Message Service specification. New JMS defined properties may be added in later versions of the JMS API. Support for these properties is optional. The String[] ConnectionMetaData.getJMSXPropertyNames method returns the names of the JMSX properties supported by a connection.

JMSX properties may be referenced in message selectors whether or not they are supported by a connection. If they are not present in a message, they are treated like any other absent property.

JMSX properties defined in the specification as "set by provider on send" are available to both the producer and the consumers of the message. JMSX properties defined in the specification as "set by provider on receive" are available only to the consumers.

JMSXGroupID and JMSXGroupSeq are standard properties that clients should use if they want to group messages. All providers must support them. Unless specifically noted, the values and semantics of the JMSX properties are undefined.

The JMS API reserves the JMS_vendor_name property name prefix for provider-specific properties. Each provider defines its own value for vendor_name. This is the mechanism a JMS provider uses to make its special per-message services available to a JMS client.

The purpose of provider-specific properties is to provide special features needed to integrate JMS clients with provider-native clients in a single JMS application. They should not be used for messaging between JMS clients.

Provider Implementations of JMS Message Interfaces

The JMS API provides a set of message interfaces that define the JMS message model. It does not provide implementations of these interfaces.

Each JMS provider supplies a set of message factories with its Session object for creating instances of messages. This allows a provider to use message implementations tailored to its specific needs.

A provider must be prepared to accept message implementations that are not its own. They may not be handled as efficiently as its own implementation; however, they must be handled.

Note the following exception case when a provider is handling a foreign message implementation. If the foreign message implementation contains a JMSReplyTo header field that is set to a foreign destination implementation, the provider is not required to handle or preserve the value of this header field.

Message Selectors

A JMS message selector allows a client to specify, by header field references and property references, the messages it is interested in. Only messages whose header and property values match the selector are delivered. What it means for a message not to be delivered depends on the MessageConsumer being used (see QueueReceiver and TopicSubscriber).

Message selectors cannot reference message body values.

A message selector matches a message if the selector evaluates to true when the message's header field values and property values are substituted for their corresponding identifiers in the selector.

A message selector is a String whose syntax is based on a subset of the SQL92 conditional expression syntax. If the value of a message selector is an empty string, the value is treated as a null and indicates that there is no message selector for the message consumer.

The order of evaluation of a message selector is from left to right within precedence level. Parentheses can be used to change this order.

Predefined selector literals and operator names are shown here in uppercase; however, they are case insensitive.

A selector can contain:

  • Literals:
    • A string literal is enclosed in single quotes, with a single quote represented by doubled single quote; for example, 'literal' and 'literal''s'. Like string literals in the Java programming language, these use the Unicode character encoding.
    • An exact numeric literal is a numeric value without a decimal point, such as 57, -957, and +62; numbers in the range of long are supported. Exact numeric literals use the integer literal syntax of the Java programming language.
    • An approximate numeric literal is a numeric value in scientific notation, such as 7E3 and -57.9E2, or a numeric value with a decimal, such as 7., -95.7, and +6.2; numbers in the range of double are supported. Approximate literals use the floating-point literal syntax of the Java programming language.
    • The boolean literals TRUE and FALSE.
  • Identifiers:
    • An identifier is an unlimited-length sequence of letters and digits, the first of which must be a letter. A letter is any character for which the method Character.isJavaLetter returns true. This includes '_' and '$'. A letter or digit is any character for which the method Character.isJavaLetterOrDigit returns true.
    • Identifiers cannot be the names NULL, TRUE, and FALSE.
    • Identifiers cannot be NOT, AND, OR, BETWEEN, LIKE, IN, IS, or ESCAPE.
    • Identifiers are either header field references or property references. The type of a property value in a message selector corresponds to the type used to set the property. If a property that does not exist in a message is referenced, its value is NULL.
    • The conversions that apply to the get methods for properties do not apply when a property is used in a message selector expression. For example, suppose you set a property as a string value, as in the following:
      myMessage.setStringProperty("NumberOfOrders", "2");
      The following expression in a message selector would evaluate to false, because a string cannot be used in an arithmetic expression:
      "NumberOfOrders > 1"
    • Identifiers are case-sensitive.
    • Message header field references are restricted to JMSDeliveryMode, JMSPriority, JMSMessageID, JMSTimestamp, JMSCorrelationID, and JMSType. JMSMessageID, JMSCorrelationID, and JMSType values may be null and if so are treated as a NULL value.
    • Any name beginning with 'JMSX' is a JMS defined property name.
    • Any name beginning with 'JMS_' is a provider-specific property name.
    • Any name that does not begin with 'JMS' is an application-specific property name.
  • White space is the same as that defined for the Java programming language: space, horizontal tab, form feed, and line terminator.
  • Expressions:
    • A selector is a conditional expression; a selector that evaluates to true matches; a selector that evaluates to false or unknown does not match.
    • Arithmetic expressions are composed of themselves, arithmetic operations, identifiers (whose value is treated as a numeric literal), and numeric literals.
    • Conditional expressions are composed of themselves, comparison operations, and logical operations.
  • Standard bracketing () for ordering expression evaluation is supported.
  • Logical operators in precedence order: NOT, AND, OR
  • Comparison operators: =, >, >=, <, <=< /CODE="/CODE">, (not equal)
    • Only like type values can be compared. One exception is that it is valid to compare exact numeric values and approximate numeric values; the type conversion required is defined by the rules of numeric promotion in the Java programming language. If the comparison of non-like type values is attempted, the value of the operation is false. If either of the type values evaluates to NULL, the value of the expression is unknown.
    • String and boolean comparison is restricted to = and . Two strings are equal if and only if they contain the same sequence of characters.
  • Arithmetic operators in precedence order:
    • +, - (unary)
    • *, / (multiplication and division)
    • +, - (addition and subtraction)
    • Arithmetic operations must use numeric promotion in the Java programming language.
  • arithmetic-expr1 [NOT] BETWEEN arithmetic-expr2 AND arithmetic-expr3 (comparison operator)
    • "age BETWEEN 15 AND 19" is equivalent to "age >= 15 AND age <= 19"< /CODE="/CODE">
    • "age NOT BETWEEN 15 AND 19" is equivalent to "age < 15 OR age > 19"
  • identifier [NOT] IN (string-literal1, string-literal2,...) (comparison operator where identifier has a String or NULL value)
    • "Country IN (' UK', 'US', 'France')" is true for 'UK' and false for 'Peru'; it is equivalent to the expression "(Country = ' UK') OR (Country = ' US') OR (Country = ' France')"
    • "Country NOT IN (' UK', 'US', 'France')" is false for 'UK' and true for 'Peru'; it is equivalent to the expression "NOT ((Country = ' UK') OR (Country = ' US') OR (Country = ' France'))"
    • If identifier of an IN or NOT IN operation is NULL, the value of the operation is unknown.
  • identifier [NOT] LIKE pattern-value [ESCAPE escape-character] (comparison operator, where identifier has a String value; pattern-value is a string literal where '_' stands for any single character; '%' stands for any sequence of characters, including the empty sequence; and all other characters stand for themselves. The optional escape-character is a single-character string literal whose character is used to escape the special meaning of the '_' and '%' in pattern-value.)
    • "phone LIKE '12%3'" is true for '123' or '12993' and false for '1234'
    • "word LIKE 'l_se'" is true for 'lose' and false for 'loose'
    • "underscored LIKE '\_%' ESCAPE '\'" is true for '_foo' and false for 'bar'
    • "phone NOT LIKE '12%3'" is false for '123' or '12993' and true for '1234'
    • If identifier of a LIKE or NOT LIKE operation is NULL, the value of the operation is unknown.
  • identifier IS NULL (comparison operator that tests for a null header field value or a missing property value)
    • "prop_name IS NULL"
  • identifier IS NOT NULL (comparison operator that tests for the existence of a non-null header field value or a property value)
    • "prop_name IS NOT NULL"

    JMS providers are required to verify the syntactic correctness of a message selector at the time it is presented. A method that provides a syntactically incorrect selector must result in a JMSException. JMS providers may also optionally provide some semantic checking at the time the selector is presented. Not all semantic checking can be performed at the time a message selector is presented, because property types are not known.

    The following message selector selects messages with a message type of car and color of blue and weight greater than 2500 pounds:

    "JMSType = 'car' AND color = 'blue' AND weight > 2500"

    Null Values

    As noted above, property values may be NULL. The evaluation of selector expressions containing NULL values is defined by SQL92 NULL semantics. A brief description of these semantics is provided here.

    SQL treats a NULL value as unknown. Comparison or arithmetic with an unknown value always yields an unknown value.

    The IS NULL and IS NOT NULL operators convert an unknown value into the respective TRUE and FALSE values.

    The boolean operators use three-valued logic as defined by the following tables:

    The definition of the AND operator

     | AND  |   T   |   F   |   U
 +------+-------+-------+-------
 |  T   |   T   |   F   |   U
 |  F   |   F   |   F   |   F
 |  U   |   U   |   F   |   U
 +------+-------+-------+-------

    The definition of the OR operator

     | OR   |   T   |   F   |   U
 +------+-------+-------+--------
 |  T   |   T   |   T   |   T
 |  F   |   T   |   F   |   U
 |  U   |   T   |   U   |   U
 +------+-------+-------+-------

    The definition of the NOT operator

     | NOT
 +------+------
 |  T   |   F
 |  F   |   T
 |  U   |   U
 +------+-------

    Special Notes

    When used in a message selector, the JMSDeliveryMode header field is treated as having the values 'PERSISTENT' and 'NON_PERSISTENT'.

    Date and time values should use the standard long millisecond value. When a date or time literal is included in a message selector, it should be an integer literal for a millisecond value. The standard way to produce millisecond values is to use java.util.Calendar.

    Although SQL supports fixed decimal comparison and arithmetic, JMS message selectors do not. This is the reason for restricting exact numeric literals to those without a decimal (and the addition of numerics with a decimal as an alternate representation for approximate numeric values).

    SQL comments are not supported.

    Version:
    1.1 April 2, 2002
    Author:
    Mark Hapner, Rich Burridge, Kate Stout
    See Also:
    MessageConsumer.receive(), MessageConsumer.receive(long), MessageConsumer.receiveNoWait(), MessageListener.onMessage(Message), BytesMessage, MapMessage, ObjectMessage, StreamMessage, TextMessage

    Field Summary
    static int DEFAULT_DELIVERY_MODE
              The message producer's default delivery mode is PERSISTENT.
    static int DEFAULT_PRIORITY
              The message producer's default priority is 4.
    static long DEFAULT_TIME_TO_LIVE
              The message producer's default time to live is unlimited; the message never expires.

    Method Summary
     void acknowledge()
              Acknowledges all consumed messages of the session of this consumed message.
     void clearBody()
              Clears out the message body.
     void clearProperties()
              Clears a message's properties.
     boolean getBooleanProperty(String name)
              Returns the value of the boolean property with the specified name.
     byte getByteProperty(String name)
              Returns the value of the byte property with the specified name.
     double getDoubleProperty(String name)
              Returns the value of the double property with the specified name.
     float getFloatProperty(String name)
              Returns the value of the float property with the specified name.
     int getIntProperty(String name)
              Returns the value of the int property with the specified name.
     String getJMSCorrelationID()
              Gets the correlation ID for the message.
     byte[] getJMSCorrelationIDAsBytes()
              Gets the correlation ID as an array of bytes for the message.
     int getJMSDeliveryMode()
              Gets the DeliveryMode value specified for this message.
     Destination getJMSDestination()
              Gets the Destination object for this message.
     long getJMSExpiration()
              Gets the message's expiration value.
     String getJMSMessageID()
              Gets the message ID.
     int getJMSPriority()
              Gets the message priority level.
     boolean getJMSRedelivered()
              Gets an indication of whether this message is being redelivered.
     Destination getJMSReplyTo()
              Gets the Destination object to which a reply to this message should be sent.
     long getJMSTimestamp()
              Gets the message timestamp.
     String getJMSType()
              Gets the message type identifier supplied by the client when the message was sent.
     long getLongProperty(String name)
              Returns the value of the long property with the specified name.
     Object getObjectProperty(String name)
              Returns the value of the Java object property with the specified name.
     Enumeration getPropertyNames()
              Returns an Enumeration of all the property names.
     short getShortProperty(String name)
              Returns the value of the short property with the specified name.
     String getStringProperty(String name)
              Returns the value of the String property with the specified name.
     boolean propertyExists(String name)
              Indicates whether a property value exists.
     void setBooleanProperty(String name, boolean value)
              Sets a boolean property value with the specified name into the message.
     void setByteProperty(String name, byte value)
              Sets a byte property value with the specified name into the message.
     void setDoubleProperty(String name, double value)
              Sets a double property value with the specified name into the message.
     void setFloatProperty(String name, float value)
              Sets a float property value with the specified name into the message.
     void setIntProperty(String name, int value)
              Sets an int property value with the specified name into the message.
     void setJMSCorrelationID(String correlationID)
              Sets the correlation ID for the message.
     void setJMSCorrelationIDAsBytes(byte[] correlationID)
              Sets the correlation ID as an array of bytes for the message.
     void setJMSDeliveryMode(int deliveryMode)
              Sets the DeliveryMode value for this message.
     void setJMSDestination(Destination destination)
              Sets the Destination object for this message.
     void setJMSExpiration(long expiration)
              Sets the message's expiration value.
     void setJMSMessageID(String id)
              Sets the message ID.
     void setJMSPriority(int priority)
              Sets the priority level for this message.
     void setJMSRedelivered(boolean redelivered)
              Specifies whether this message is being redelivered.
     void setJMSReplyTo(Destination replyTo)
              Sets the Destination object to which a reply to this message should be sent.
     void setJMSTimestamp(long timestamp)
              Sets the message timestamp.
     void setJMSType(String type)
              Sets the message type.
     void setLongProperty(String name, long value)
              Sets a long property value with the specified name into the message.
     void setObjectProperty(String name, Object value)
              Sets a Java object property value with the specified name into the message.
     void setShortProperty(String name, short value)
              Sets a short property value with the specified name into the message.
     void setStringProperty(String name, String value)
              Sets a String property value with the specified name into the message.

    Field Detail

    DEFAULT_DELIVERY_MODE

    public static final int DEFAULT_DELIVERY_MODE
    The message producer's default delivery mode is PERSISTENT.

    See Also:
    DeliveryMode.PERSISTENT, Constant Field Values

    DEFAULT_PRIORITY

    public static final int DEFAULT_PRIORITY
    The message producer's default priority is 4.

    See Also:
    Constant Field Values

    DEFAULT_TIME_TO_LIVE

    public static final long DEFAULT_TIME_TO_LIVE
    The message producer's default time to live is unlimited; the message never expires.

    See Also:
    Constant Field Values
    Method Detail

    getJMSMessageID

    public String getJMSMessageID()
                       throws JMSException
    Gets the message ID.

    The JMSMessageID header field contains a value that uniquely identifies each message sent by a provider.

    When a message is sent, JMSMessageID can be ignored. When the send or publish method returns, it contains a provider-assigned value.

    A JMSMessageID is a String value that should function as a unique key for identifying messages in a historical repository. The exact scope of uniqueness is provider-defined. It should at least cover all messages for a specific installation of a provider, where an installation is some connected set of message routers.

    All JMSMessageID values must start with the prefix 'ID:'. Uniqueness of message ID values across different providers is not required.

    Since message IDs take some effort to create and increase a message's size, some JMS providers may be able to optimize message overhead if they are given a hint that the message ID is not used by an application. By calling the MessageProducer.setDisableMessageID method, a JMS client enables this potential optimization for all messages sent by that message producer. If the JMS provider accepts this hint, these messages must have the message ID set to null; if the provider ignores the hint, the message ID must be set to its normal unique value.

    Returns:
    the message ID
    Throws:
    JMSException - if the JMS provider fails to get the message ID due to some internal error.
    See Also:
    setJMSMessageID(String), MessageProducer.setDisableMessageID(boolean)

    setJMSMessageID

    public void setJMSMessageID(String id)
                     throws JMSException
    Sets the message ID.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    id - the ID of the message
    Throws:
    JMSException - if the JMS provider fails to set the message ID due to some internal error.
    See Also:
    getJMSMessageID()

    getJMSTimestamp

    public long getJMSTimestamp()
                     throws JMSException
    Gets the message timestamp.

    The JMSTimestamp header field contains the time a message was handed off to a provider to be sent. It is not the time the message was actually transmitted, because the actual send may occur later due to transactions or other client-side queueing of messages.

    When a message is sent, JMSTimestamp is ignored. When the send or publish method returns, it contains a time value somewhere in the interval between the call and the return. The value is in the format of a normal millis time value in the Java programming language.

    Since timestamps take some effort to create and increase a message's size, some JMS providers may be able to optimize message overhead if they are given a hint that the timestamp is not used by an application. By calling the MessageProducer.setDisableMessageTimestamp method, a JMS client enables this potential optimization for all messages sent by that message producer. If the JMS provider accepts this hint, these messages must have the timestamp set to zero; if the provider ignores the hint, the timestamp must be set to its normal value.

    Returns:
    the message timestamp
    Throws:
    JMSException - if the JMS provider fails to get the timestamp due to some internal error.
    See Also:
    setJMSTimestamp(long), MessageProducer.setDisableMessageTimestamp(boolean)

    setJMSTimestamp

    public void setJMSTimestamp(long timestamp)
                     throws JMSException
    Sets the message timestamp.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    timestamp - the timestamp for this message
    Throws:
    JMSException - if the JMS provider fails to set the timestamp due to some internal error.
    See Also:
    getJMSTimestamp()

    getJMSCorrelationIDAsBytes

    public byte[] getJMSCorrelationIDAsBytes()
                                  throws JMSException
    Gets the correlation ID as an array of bytes for the message.

    The use of a byte[] value for JMSCorrelationID is non-portable.

    Returns:
    the correlation ID of a message as an array of bytes
    Throws:
    JMSException - if the JMS provider fails to get the correlation ID due to some internal error.
    See Also:
    setJMSCorrelationID(String), getJMSCorrelationID(), setJMSCorrelationIDAsBytes(byte[])

    setJMSCorrelationIDAsBytes

    public void setJMSCorrelationIDAsBytes(byte[] correlationID)
                                throws JMSException
    Sets the correlation ID as an array of bytes for the message.

    The array is copied before the method returns, so future modifications to the array will not alter this message header.

    If a provider supports the native concept of correlation ID, a JMS client may need to assign specific JMSCorrelationID values to match those expected by native messaging clients. JMS providers without native correlation ID values are not required to support this method and its corresponding get method; their implementation may throw a java.lang.UnsupportedOperationException.

    The use of a byte[] value for JMSCorrelationID is non-portable.

    Parameters:
    correlationID - the correlation ID value as an array of bytes
    Throws:
    JMSException - if the JMS provider fails to set the correlation ID due to some internal error.
    See Also:
    setJMSCorrelationID(String), getJMSCorrelationID(), getJMSCorrelationIDAsBytes()

    setJMSCorrelationID

    public void setJMSCorrelationID(String correlationID)
                         throws JMSException
    Sets the correlation ID for the message.

    A client can use the JMSCorrelationID header field to link one message with another. A typical use is to link a response message with its request message.

    JMSCorrelationID can hold one of the following:

    • A provider-specific message ID
    • An application-specific String
    • A provider-native byte[] value

    Since each message sent by a JMS provider is assigned a message ID value, it is convenient to link messages via message ID. All message ID values must start with the 'ID:' prefix.

    In some cases, an application (made up of several clients) needs to use an application-specific value for linking messages. For instance, an application may use JMSCorrelationID to hold a value referencing some external information. Application-specified values must not start with the 'ID:' prefix; this is reserved for provider-generated message ID values.

    If a provider supports the native concept of correlation ID, a JMS client may need to assign specific JMSCorrelationID values to match those expected by clients that do not use the JMS API. A byte[] value is used for this purpose. JMS providers without native correlation ID values are not required to support byte[] values. The use of a byte[] value for JMSCorrelationID is non-portable.

    Parameters:
    correlationID - the message ID of a message being referred to
    Throws:
    JMSException - if the JMS provider fails to set the correlation ID due to some internal error.
    See Also:
    getJMSCorrelationID(),
getJMSCorrelationIDAsBytes(),
setJMSCorrelationIDAsBytes(byte[])

    getJMSCorrelationID

    public String getJMSCorrelationID()
                           throws JMSException
    Gets the correlation ID for the message.

    This method is used to return correlation ID values that are either provider-specific message IDs or application-specific String values.

    Returns:
    the correlation ID of a message as a String
    Throws:
    JMSException - if the JMS provider fails to get the correlation ID due to some internal error.
    See Also:
    setJMSCorrelationID(String), getJMSCorrelationIDAsBytes(), setJMSCorrelationIDAsBytes(byte[])

    getJMSReplyTo

    public Destination getJMSReplyTo()
                          throws JMSException
    Gets the Destination object to which a reply to this message should be sent.

    Returns:
    Destination to which to send a response to this message
    Throws:
    JMSException - if the JMS provider fails to get the JMSReplyTo destination due to some internal error.
    See Also:
    setJMSReplyTo(Destination)

    setJMSReplyTo

    public void setJMSReplyTo(Destination replyTo)
                   throws JMSException
    Sets the Destination object to which a reply to this message should be sent.

    The JMSReplyTo header field contains the destination where a reply to the current message should be sent. If it is null, no reply is expected. The destination may be either a Queue object or a Topic object.

    Messages sent with a null JMSReplyTo value may be a notification of some event, or they may just be some data the sender thinks is of interest.

    Messages with a JMSReplyTo value typically expect a response. A response is optional; it is up to the client to decide. These messages are called requests. A message sent in response to a request is called a reply.

    In some cases a client may wish to match a request it sent earlier with a reply it has just received. The client can use the JMSCorrelationID header field for this purpose.

    Parameters:
    replyTo - Destination to which to send a response to this message
    Throws:
    JMSException - if the JMS provider fails to set the JMSReplyTo destination due to some internal error.
    See Also:
    getJMSReplyTo()

    getJMSDestination

    public Destination getJMSDestination()
                              throws JMSException
    Gets the Destination object for this message.

    The JMSDestination header field contains the destination to which the message is being sent.

    When a message is sent, this field is ignored. After completion of the send or publish method, the field holds the destination specified by the method.

    When a message is received, its JMSDestination value must be equivalent to the value assigned when it was sent.

    Returns:
    the destination of this message
    Throws:
    JMSException - if the JMS provider fails to get the destination due to some internal error.
    See Also:
    setJMSDestination(Destination)

    setJMSDestination

    public void setJMSDestination(Destination destination)
                       throws JMSException
    Sets the Destination object for this message.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    destination - the destination for this message
    Throws:
    JMSException - if the JMS provider fails to set the destination due to some internal error.
    See Also:
    getJMSDestination()

    getJMSDeliveryMode

    public int getJMSDeliveryMode()
                       throws JMSException
    Gets the DeliveryMode value specified for this message.

    Returns:
    the delivery mode for this message
    Throws:
    JMSException - if the JMS provider fails to get the delivery mode due to some internal error.
    See Also:
    setJMSDeliveryMode(int), DeliveryMode

    setJMSDeliveryMode

    public void setJMSDeliveryMode(int deliveryMode)
                        throws JMSException
    Sets the DeliveryMode value for this message.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    deliveryMode - the delivery mode for this message
    Throws:
    JMSException - if the JMS provider fails to set the delivery mode due to some internal error.
    See Also:
    getJMSDeliveryMode(), DeliveryMode

    getJMSRedelivered

    public boolean getJMSRedelivered()
                          throws JMSException
    Gets an indication of whether this message is being redelivered.

    If a client receives a message with the JMSRedelivered field set, it is likely, but not guaranteed, that this message was delivered earlier but that its receipt was not acknowledged at that time.

    Returns:
    true if this message is being redelivered
    Throws:
    JMSException - if the JMS provider fails to get the redelivered state due to some internal error.
    See Also:
    setJMSRedelivered(boolean)

    setJMSRedelivered

    public void setJMSRedelivered(boolean redelivered)
                       throws JMSException
    Specifies whether this message is being redelivered.

    This field is set at the time the message is delivered. This method can be used to change the value for a message that has been received.

    Parameters:
    redelivered - an indication of whether this message is being redelivered
    Throws:
    JMSException - if the JMS provider fails to set the redelivered state due to some internal error.
    See Also:
    getJMSRedelivered()

    getJMSType

    public String getJMSType()
                  throws JMSException
    Gets the message type identifier supplied by the client when the message was sent.

    Returns:
    the message type
    Throws:
    JMSException - if the JMS provider fails to get the message type due to some internal error.
    See Also:
    setJMSType(String)

    setJMSType

    public void setJMSType(String type)
                throws JMSException
    Sets the message type.

    Some JMS providers use a message repository that contains the definitions of messages sent by applications. The JMSType header field may reference a message's definition in the provider's repository.

    The JMS API does not define a standard message definition repository, nor does it define a naming policy for the definitions it contains.

    Some messaging systems require that a message type definition for each application message be created and that each message specify its type. In order to work with such JMS providers, JMS clients should assign a value to JMSType, whether the application makes use of it or not. This ensures that the field is properly set for those providers that require it.

    To ensure portability, JMS clients should use symbolic values for JMSType that can be configured at installation time to the values defined in the current provider's message repository. If string literals are used, they may not be valid type names for some JMS providers.

    Parameters:
    type - the message type
    Throws:
    JMSException - if the JMS provider fails to set the message type due to some internal error.
    See Also:
    getJMSType()

    getJMSExpiration

    public long getJMSExpiration()
                      throws JMSException
    Gets the message's expiration value.

    When a message is sent, the JMSExpiration header field is left unassigned. After completion of the send or publish method, it holds the expiration time of the message. This is the sum of the time-to-live value specified by the client and the GMT at the time of the send or publish.

    If the time-to-live is specified as zero, JMSExpiration is set to zero to indicate that the message does not expire.

    When a message's expiration time is reached, a provider should discard it. The JMS API does not define any form of notification of message expiration.

    Clients should not receive messages that have expired; however, the JMS API does not guarantee that this will not happen.

    Returns:
    the time the message expires, which is the sum of the time-to-live value specified by the client and the GMT at the time of the send
    Throws:
    JMSException - if the JMS provider fails to get the message expiration due to some internal error.
    See Also:
    setJMSExpiration(long)

    setJMSExpiration

    public void setJMSExpiration(long expiration)
                      throws JMSException
    Sets the message's expiration value.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    expiration - the message's expiration time
    Throws:
    JMSException - if the JMS provider fails to set the message expiration due to some internal error.
    See Also:
    getJMSExpiration()

    getJMSPriority

    public int getJMSPriority()
                   throws JMSException
    Gets the message priority level.

    The JMS API defines ten levels of priority value, with 0 as the lowest priority and 9 as the highest. In addition, clients should consider priorities 0-4 as gradations of normal priority and priorities 5-9 as gradations of expedited priority.

    The JMS API does not require that a provider strictly implement priority ordering of messages; however, it should do its best to deliver expedited messages ahead of normal messages.

    Returns:
    the default message priority
    Throws:
    JMSException - if the JMS provider fails to get the message priority due to some internal error.
    See Also:
    setJMSPriority(int)

    setJMSPriority

    public void setJMSPriority(int priority)
                    throws JMSException
    Sets the priority level for this message.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    priority - the priority of this message
    Throws:
    JMSException - if the JMS provider fails to set the message priority due to some internal error.
    See Also:
    getJMSPriority()

    clearProperties

    public void clearProperties()
                     throws JMSException
    Clears a message's properties.

    The message's header fields and body are not cleared.

    Throws:
    JMSException - if the JMS provider fails to clear the message properties due to some internal error.

    propertyExists

    public boolean propertyExists(String name)
                       throws JMSException
    Indicates whether a property value exists.

    Parameters:
    name - the name of the property to test
    Returns:
    true if the property exists
    Throws:
    JMSException - if the JMS provider fails to determine if the property exists due to some internal error.

    getBooleanProperty

    public boolean getBooleanProperty(String name)
                           throws JMSException
    Returns the value of the boolean property with the specified name.

    Parameters:
    name - the name of the boolean property
    Returns:
    the boolean property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getByteProperty

    public byte getByteProperty(String name)
                     throws JMSException
    Returns the value of the byte property with the specified name.

    Parameters:
    name - the name of the byte property
    Returns:
    the byte property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getShortProperty

    public short getShortProperty(String name)
                       throws JMSException
    Returns the value of the short property with the specified name.

    Parameters:
    name - the name of the short property
    Returns:
    the short property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getIntProperty

    public int getIntProperty(String name)
                   throws JMSException
    Returns the value of the int property with the specified name.

    Parameters:
    name - the name of the int property
    Returns:
    the int property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getLongProperty

    public long getLongProperty(String name)
                     throws JMSException
    Returns the value of the long property with the specified name.

    Parameters:
    name - the name of the long property
    Returns:
    the long property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getFloatProperty

    public float getFloatProperty(String name)
                       throws JMSException
    Returns the value of the float property with the specified name.

    Parameters:
    name - the name of the float property
    Returns:
    the float property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getDoubleProperty

    public double getDoubleProperty(String name)
                         throws JMSException
    Returns the value of the double property with the specified name.

    Parameters:
    name - the name of the double property
    Returns:
    the double property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getStringProperty

    public String getStringProperty(String name)
                         throws JMSException
    Returns the value of the String property with the specified name.

    Parameters:
    name - the name of the String property
    Returns:
    the String property value for the specified name; if there is no property by this name, a null value is returned
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getObjectProperty

    public Object getObjectProperty(String name)
                         throws JMSException
    Returns the value of the Java object property with the specified name.

    This method can be used to return, in objectified format, an object that has been stored as a property in the message with the equivalent setObjectProperty method call, or its equivalent primitive settypeProperty method.

    Parameters:
    name - the name of the Java object property
    Returns:
    the Java object property value with the specified name, in objectified format (for example, if the property was set as an int, an Integer is returned); if there is no property by this name, a null value is returned
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.

    getPropertyNames

    public Enumeration getPropertyNames()
                             throws JMSException
    Returns an Enumeration of all the property names.

    Note that JMS standard header fields are not considered properties and are not returned in this enumeration.

    Returns:
    an enumeration of all the names of property values
    Throws:
    JMSException - if the JMS provider fails to get the property names due to some internal error.

    setBooleanProperty

    public void setBooleanProperty(String name,
                               boolean value)
                        throws JMSException
    Sets a boolean property value with the specified name into the message.

    Parameters:
    name - the name of the boolean property
    value - the boolean property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setByteProperty

    public void setByteProperty(String name,
                            byte value)
                     throws JMSException
    Sets a byte property value with the specified name into the message.

    Parameters:
    name - the name of the byte property
    value - the byte property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setShortProperty

    public void setShortProperty(String name,
                             short value)
                      throws JMSException
    Sets a short property value with the specified name into the message.

    Parameters:
    name - the name of the short property
    value - the short property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setIntProperty

    public void setIntProperty(String name,
                           int value)
                    throws JMSException
    Sets an int property value with the specified name into the message.

    Parameters:
    name - the name of the int property
    value - the int property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setLongProperty

    public void setLongProperty(String name,
                            long value)
                     throws JMSException
    Sets a long property value with the specified name into the message.

    Parameters:
    name - the name of the long property
    value - the long property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setFloatProperty

    public void setFloatProperty(String name,
                             float value)
                      throws JMSException
    Sets a float property value with the specified name into the message.

    Parameters:
    name - the name of the float property
    value - the float property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setDoubleProperty

    public void setDoubleProperty(String name,
                              double value)
                       throws JMSException
    Sets a double property value with the specified name into the message.

    Parameters:
    name - the name of the double property
    value - the double property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setStringProperty

    public void setStringProperty(String name,
                              String value)
                       throws JMSException
    Sets a String property value with the specified name into the message.

    Parameters:
    name - the name of the String property
    value - the String property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setObjectProperty

    public void setObjectProperty(String name,
                              Object value)
                       throws JMSException
    Sets a Java object property value with the specified name into the message.

    Note that this method works only for the objectified primitive object types (Integer, Double, Long ...) and String objects.

    Parameters:
    name - the name of the Java object property
    value - the Java object property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageFormatException - if the object is invalid
    MessageNotWriteableException - if properties are read-only

    acknowledge

    public void acknowledge()
                 throws JMSException
    Acknowledges all consumed messages of the session of this consumed message.

    All consumed JMS messages support the acknowledge method for use when a client has specified that its JMS session's consumed messages are to be explicitly acknowledged. By invoking acknowledge on a consumed message, a client acknowledges all messages consumed by the session that the message was delivered to.

    Calls to acknowledge are ignored for both transacted sessions and sessions specified to use implicit acknowledgement modes.

    A client may individually acknowledge each message as it is consumed, or it may choose to acknowledge messages as an application-defined group (which is done by calling acknowledge on the last received message of the group, thereby acknowledging all messages consumed by the session.)

    Messages that have been received but not acknowledged may be redelivered.

    Throws:
    JMSException - if the JMS provider fails to acknowledge the messages due to some internal error.
    IllegalStateException - if this method is called on a closed session.
    See Also:
    Session.CLIENT_ACKNOWLEDGE

    clearBody

    public void clearBody()
               throws JMSException
    Clears out the message body. Clearing a message's body does not clear its header values or property entries.

    If this message body was read-only, calling this method leaves the message body in the same state as an empty body in a newly created message.

    Throws:
    JMSException - if the JMS provider fails to clear the message body due to some internal error.
    Overview  Package   Class  Tree  Deprecated  Index  Help
            JavaTM 2 Platform
    Ent. Ed. v1.4
     PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
    Submit a bug or feature

    Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageConsumer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface MessageConsumer

All Known Subinterfaces:
QueueReceiver, TopicSubscriber
public interface MessageConsumer

A client uses a MessageConsumer object to receive messages from a destination. A MessageConsumer object is created by passing a Destination object to a message-consumer creation method supplied by a session.

MessageConsumer is the parent interface for all message consumers.

A message consumer can be created with a message selector. A message selector allows the client to restrict the messages delivered to the message consumer to those that match the selector.

A client may either synchronously receive a message consumer's messages or have the consumer asynchronously deliver them as they arrive.

For synchronous receipt, a client can request the next message from a message consumer using one of its receive methods. There are several variations of receive that allow a client to poll or wait for the next message.

For asynchronous delivery, a client can register a MessageListener object with a message consumer. As messages arrive at the message consumer, it delivers them by calling the MessageListener's onMessage method.

It is a client programming error for a MessageListener to throw an exception.

Version:
1.0 - 13 March 1998
Author:
Mark Hapner, Rich Burridge
See Also:
QueueReceiver, TopicSubscriber, Session

Method Summary
void | close() Closes the message consumer.
MessageListener | getMessageListener() Gets the message consumer's MessageListener.
String | getMessageSelector() Gets this message consumer's message selector expression.
Message | receive() Receives the next message produced for this message consumer.
Message | receive(long timeout) Receives the next message that arrives within the specified timeout interval.
Message | receiveNoWait() Receives the next message if one is immediately available.
void | setMessageListener(MessageListener listener) Sets the message consumer's MessageListener.

Method Detail

getMessageSelector

public String getMessageSelector()
                          throws JMSException
Gets this message consumer's message selector expression.

Returns:
this message consumer's message selector, or null if no message selector exists for the message consumer (that is, if the message selector was not set or was set to null or the empty string)
Throws:
JMSException - if the JMS provider fails to get the message selector due to some internal error.

getMessageListener

public MessageListener getMessageListener()
                                   throws JMSException
Gets the message consumer's MessageListener.

Returns:
the listener for the message consumer, or null if no listener is set
Throws:
JMSException - if the JMS provider fails to get the message listener due to some internal error.
See Also:
setMessageListener(javax.jms.MessageListener)

setMessageListener

public void setMessageListener(MessageListener listener)
                        throws JMSException
Sets the message consumer's MessageListener.

Setting the message listener to null is the equivalent of unsetting the message listener for the message consumer.

The effect of calling MessageConsumer.setMessageListener while messages are being consumed by an existing listener or the consumer is being used to consume messages synchronously is undefined.

Parameters:
listener - the listener to which the messages are to be delivered
Throws:
JMSException - if the JMS provider fails to set the message listener due to some internal error.
See Also:
getMessageListener()

receive

public Message receive()
                throws JMSException
Receives the next message produced for this message consumer.

This call blocks indefinitely until a message is produced or until this message consumer is closed.

If this receive is done within a transaction, the consumer retains the message until the transaction commits.

Returns:
the next message produced for this message consumer, or null if this message consumer is concurrently closed
Throws:
JMSException - if the JMS provider fails to receive the next message due to some internal error.

receive

public Message receive(long timeout)
                throws JMSException
Receives the next message that arrives within the specified timeout interval.

This call blocks until a message arrives, the timeout expires, or this message consumer is closed. A timeout of zero never expires, and the call blocks indefinitely.

Parameters:
timeout - the timeout value (in milliseconds)
Returns:
the next message produced for this message consumer, or null if the timeout expires or this message consumer is concurrently closed
Throws:
JMSException - if the JMS provider fails to receive the next message due to some internal error.

receiveNoWait

public Message receiveNoWait()
                      throws JMSException
Receives the next message if one is immediately available.

Returns:
the next message produced for this message consumer, or null if one is not available
Throws:
JMSException - if the JMS provider fails to receive the next message due to some internal error.

close

public void close()
           throws JMSException
Closes the message consumer.

Since a provider may allocate some resources on behalf of a MessageConsumer outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

This call blocks until a receive or message listener in progress has completed. A blocked message consumer receive call returns null when this message consumer is closed.

Throws:
JMSException - if the JMS provider fails to close the consumer due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageEOFException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class MessageEOFException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.MessageEOFException
All Implemented Interfaces:
Serializable
public class MessageEOFException
extends JMSException

This exception must be thrown when an unexpected end of stream has been reached when a StreamMessage or BytesMessage is being read.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
MessageEOFException(String reason)
Constructs a MessageEOFException with the specified reason.
MessageEOFException(String reason, String errorCode)
Constructs a MessageEOFException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessageEOFException

public MessageEOFException(String reason,
                           String errorCode)
Constructs a MessageEOFException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

MessageEOFException

public MessageEOFException(String reason)
Constructs a MessageEOFException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageFormatException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class MessageFormatException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.MessageFormatException
All Implemented Interfaces:
Serializable
public class MessageFormatException
extends JMSException

This exception must be thrown when a JMS client attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type. It must also be thrown when equivalent type errors are made with message property values. For example, this exception must be thrown if StreamMessage.writeObject is given an unsupported class or if StreamMessage.readShort is used to read a boolean value. Note that the special case of a failure caused by an attempt to read improperly formatted String data as numeric values must throw the java.lang.NumberFormatException.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
MessageFormatException(String reason)
Constructs a MessageFormatException with the specified reason.
MessageFormatException(String reason, String errorCode)
Constructs a MessageFormatException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessageFormatException

public MessageFormatException(String reason,
                              String errorCode)
Constructs a MessageFormatException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

MessageFormatException

public MessageFormatException(String reason)
Constructs a MessageFormatException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface MessageListener

public interface MessageListener

A MessageListener object is used to receive asynchronously delivered messages.

Each session must insure that it passes messages serially to the listener. This means that a listener assigned to one or more consumers of the same session can assume that the onMessage method is not called with the next message until the session has completed the last call.

Version:
1.0 - 13 March 1998
Author:
Mark Hapner, Rich Burridge

Method Summary
 void onMessage(Message message)
Passes a message to the listener.

Method Detail

onMessage

public void onMessage(Message message)
Passes a message to the listener.

Parameters:
message - the message passed to the listener
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageNotReadableException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class MessageNotReadableException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.MessageNotReadableException
All Implemented Interfaces:
Serializable
public class MessageNotReadableException
extends JMSException

This exception must be thrown when a JMS client attempts to read a write-only message.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
MessageNotReadableException(String reason)
Constructs a MessageNotReadableException with the specified reason.
MessageNotReadableException(String reason, String errorCode)
Constructs a MessageNotReadableException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessageNotReadableException

public MessageNotReadableException(String reason,
                                   String errorCode)
Constructs a MessageNotReadableException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

MessageNotReadableException

public MessageNotReadableException(String reason)
Constructs a MessageNotReadableException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageNotWriteableException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class MessageNotWriteableException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.MessageNotWriteableException
All Implemented Interfaces:
Serializable
public class MessageNotWriteableException
extends JMSException

This exception must be thrown when a JMS client attempts to write to a read-only message.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
MessageNotWriteableException(String reason)
Constructs a MessageNotWriteableException with the specified reason.
MessageNotWriteableException(String reason, String errorCode)
Constructs a MessageNotWriteableException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessageNotWriteableException

public MessageNotWriteableException(String reason,
                                    String errorCode)
Constructs a MessageNotWriteableException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

MessageNotWriteableException

public MessageNotWriteableException(String reason)
Constructs a MessageNotWriteableException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageProducer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface MessageProducer

All Known Subinterfaces:
QueueSender, TopicPublisher
public interface MessageProducer

A client uses a MessageProducer object to send messages to a destination. A MessageProducer object is created by passing a Destination object to a message-producer creation method supplied by a session.

MessageProducer is the parent interface for all message producers.

A client also has the option of creating a message producer without supplying a destination. In this case, a destination must be provided with every send operation. A typical use for this kind of message producer is to send replies to requests using the request's JMSReplyTo destination.

A client can specify a default delivery mode, priority, and time to live for messages sent by a message producer. It can also specify the delivery mode, priority, and time to live for an individual message.

A client can specify a time-to-live value in milliseconds for each message it sends. This value defines a message expiration time that is the sum of the message's time-to-live and the GMT when it is sent (for transacted sends, this is the time the client sends the message, not the time the transaction is committed).

A JMS provider should do its best to expire messages accurately; however, the JMS API does not define the accuracy provided.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
TopicPublisher, QueueSender, Session.createProducer(javax.jms.Destination)

Method Summary
void | close() Closes the message producer.
int | getDeliveryMode() Gets the producer's default delivery mode.
Destination | getDestination() Gets the destination associated with this MessageProducer.
boolean | getDisableMessageID() Gets an indication of whether message IDs are disabled.
boolean | getDisableMessageTimestamp() Gets an indication of whether message timestamps are disabled.
int | getPriority() Gets the producer's default priority.
long | getTimeToLive() Gets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.
void | send(Destination destination, Message message) Sends a message to a destination for an unidentified message producer.
void | send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive) Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live.
void | send(Message message) Sends a message using the MessageProducer's default delivery mode, priority, and time to live.
void | send(Message message, int deliveryMode, int priority, long timeToLive) Sends a message to the destination, specifying delivery mode, priority, and time to live.
void | setDeliveryMode(int deliveryMode) Sets the producer's default delivery mode.
void | setDisableMessageID(boolean value) Sets whether message IDs are disabled.
void | setDisableMessageTimestamp(boolean value) Sets whether message timestamps are disabled.
void | setPriority(int defaultPriority) Sets the producer's default priority.
void | setTimeToLive(long timeToLive) Sets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.

Method Detail

setDisableMessageID

public void setDisableMessageID(boolean value)
                         throws JMSException
Sets whether message IDs are disabled.

Since message IDs take some effort to create and increase a message's size, some JMS providers may be able to optimize message overhead if they are given a hint that the message ID is not used by an application. By calling the setDisableMessageID method on this message producer, a JMS client enables this potential optimization for all messages sent by this message producer. If the JMS provider accepts this hint, these messages must have the message ID set to null; if the provider ignores the hint, the message ID must be set to its normal unique value.

Message IDs are enabled by default.

Parameters:
value - indicates if message IDs are disabled
Throws:
JMSException - if the JMS provider fails to set message ID to disabled due to some internal error.

getDisableMessageID

public boolean getDisableMessageID()
                            throws JMSException
Gets an indication of whether message IDs are disabled.

Returns:
an indication of whether message IDs are disabled
Throws:
JMSException - if the JMS provider fails to determine if message IDs are disabled due to some internal error.

setDisableMessageTimestamp

public void setDisableMessageTimestamp(boolean value)
                                throws JMSException
Sets whether message timestamps are disabled.

Since timestamps take some effort to create and increase a message's size, some JMS providers may be able to optimize message overhead if they are given a hint that the timestamp is not used by an application. By calling the setDisableMessageTimestamp method on this message producer, a JMS client enables this potential optimization for all messages sent by this message producer. If the JMS provider accepts this hint, these messages must have the timestamp set to zero; if the provider ignores the hint, the timestamp must be set to its normal value.

Message timestamps are enabled by default.

Parameters:
value - indicates if message timestamps are disabled
Throws:
JMSException - if the JMS provider fails to set timestamps to disabled due to some internal error.

getDisableMessageTimestamp

public boolean getDisableMessageTimestamp()
                                   throws JMSException
Gets an indication of whether message timestamps are disabled.

Returns:
an indication of whether message timestamps are disabled
Throws:
JMSException - if the JMS provider fails to determine if timestamps are disabled due to some internal error.

setDeliveryMode

public void setDeliveryMode(int deliveryMode)
                     throws JMSException
Sets the producer's default delivery mode.

Delivery mode is set to PERSISTENT by default.

Parameters:
deliveryMode - the message delivery mode for this message producer; legal values are DeliveryMode.NON_PERSISTENT and DeliveryMode.PERSISTENT
Throws:
JMSException - if the JMS provider fails to set the delivery mode due to some internal error.
See Also:
getDeliveryMode(), DeliveryMode.NON_PERSISTENT, DeliveryMode.PERSISTENT, Message.DEFAULT_DELIVERY_MODE

getDeliveryMode

public int getDeliveryMode()
                    throws JMSException
Gets the producer's default delivery mode.

Returns:
the message delivery mode for this message producer
Throws:
JMSException - if the JMS provider fails to get the delivery mode due to some internal error.
See Also:
setDeliveryMode(int)

setPriority

public void setPriority(int defaultPriority)
                 throws JMSException
Sets the producer's default priority.

The JMS API defines ten levels of priority value, with 0 as the lowest priority and 9 as the highest. Clients should consider priorities 0-4 as gradations of normal priority and priorities 5-9 as gradations of expedited priority. Priority is set to 4 by default.

Parameters:
defaultPriority - the message priority for this message producer; must be a value between 0 and 9
Throws:
JMSException - if the JMS provider fails to set the priority due to some internal error.
See Also:
getPriority(), Message.DEFAULT_PRIORITY

getPriority

public int getPriority()
                throws JMSException
Gets the producer's default priority.

Returns:
the message priority for this message producer
Throws:
JMSException - if the JMS provider fails to get the priority due to some internal error.
See Also:
setPriority(int)

setTimeToLive

public void setTimeToLive(long timeToLive)
                   throws JMSException
Sets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.

Time to live is set to zero by default.

Parameters:
timeToLive - the message time to live in milliseconds; zero is unlimited
Throws:
JMSException - if the JMS provider fails to set the time to live due to some internal error.
See Also:
getTimeToLive(), Message.DEFAULT_TIME_TO_LIVE

getTimeToLive

public long getTimeToLive()
                   throws JMSException
Gets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.

Returns:
the message time to live in milliseconds; zero is unlimited
Throws:
JMSException - if the JMS provider fails to get the time to live due to some internal error.
See Also:
setTimeToLive(long)

getDestination

public Destination getDestination()
                           throws JMSException
Gets the destination associated with this MessageProducer.

Returns:
this producer's Destination/
Throws:
JMSException - if the JMS provider fails to get the destination for this MessageProducer due to some internal error.
Since:
1.1

close

public void close()
           throws JMSException
Closes the message producer.

Since a provider may allocate some resources on behalf of a MessageProducer outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

Throws:
JMSException - if the JMS provider fails to close the producer due to some internal error.

send

public void send(Message message)
          throws JMSException
Sends a message using the MessageProducer's default delivery mode, priority, and time to live.

Parameters:
message - the message to send
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a MessageProducer with an invalid destination.
UnsupportedOperationException - if a client uses this method with a MessageProducer that did not specify a destination at creation time.
Since:
1.1
See Also:
Session.createProducer(javax.jms.Destination), MessageProducer

send

public void send(Message message,
                 int deliveryMode,
                 int priority,
                 long timeToLive)
          throws JMSException
Sends a message to the destination, specifying delivery mode, priority, and time to live.

Parameters:
message - the message to send
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a MessageProducer with an invalid destination.
UnsupportedOperationException - if a client uses this method with a MessageProducer that did not specify a destination at creation time.
Since:
1.1
See Also:
Session.createProducer(javax.jms.Destination)

send

public void send(Destination destination,
                 Message message)
          throws JMSException
Sends a message to a destination for an unidentified message producer. Uses the MessageProducer's default delivery mode, priority, and time to live.

Typically, a message producer is assigned a destination at creation time; however, the JMS API also supports unidentified message producers, which require that the destination be supplied every time a message is sent.

Parameters:
destination - the destination to send this message to
message - the message to send
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid destination.
UnsupportedOperationException - if a client uses this method with a MessageProducer that specified a destination at creation time.
Since:
1.1
See Also:
Session.createProducer(javax.jms.Destination), MessageProducer

send

public void send(Destination destination,
                 Message message,
                 int deliveryMode,
                 int priority,
                 long timeToLive)
          throws JMSException
Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live.

Typically, a message producer is assigned a destination at creation time; however, the JMS API also supports unidentified message producers, which require that the destination be supplied every time a message is sent.

Parameters:
destination - the destination to send this message to
message - the message to send
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid destination.
Since:
1.1
See Also:
Session.createProducer(javax.jms.Destination)
Overview  Package   Class  Tree  Deprecated  Index  Help
JavaTM 2 Platform
Ent. Ed. v1.4
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ObjectMessage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ObjectMessage

All Superinterfaces:
Message
public interface ObjectMessage
extends Message

An ObjectMessage object is used to send a message that contains a serializable object in the Java programming language ("Java object"). It inherits from the Message interface and adds a body containing a single reference to an object. Only Serializable Java objects can be used.

If a collection of Java objects must be sent, one of the Collection classes provided since JDK 1.2 can be used.

When a client receives an ObjectMessage, it is in read-only mode. If a client attempts to write to the message at this point, a MessageNotWriteableException is thrown. If clearBody is called, the message can now be both read from and written to.

Version:
1.0 - 6 August 1998
Author:
Mark Hapner, Rich Burridge
See Also:
Session.createObjectMessage(), Session.createObjectMessage(Serializable), BytesMessage, MapMessage, Message, StreamMessage, TextMessage

Field Summary
Fields inherited from interface javax.jms.Message
DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE
Method Summary
Serializable | getObject() Gets the serializable object containing this message's data.
void | setObject(Serializable object) Sets the serializable object containing this message's data.
Methods inherited from interface javax.jms.Message
acknowledge, clearBody, clearProperties, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

Method Detail

setObject

public void setObject(Serializable object)
               throws JMSException
Sets the serializable object containing this message's data. It is important to note that an ObjectMessage contains a snapshot of the object at the time setObject() is called; subsequent modifications of the object will have no effect on the ObjectMessage body.

Parameters:
object - the message's data
Throws:
JMSException - if the JMS provider fails to set the object due to some internal error.
MessageFormatException - if object serialization fails.
MessageNotWriteableException - if the message is in read-only mode.

getObject

public Serializable getObject()
                       throws JMSException
Gets the serializable object containing this message's data. The default value is null.

Returns:
the serializable object containing this message's data
Throws:
JMSException - if the JMS provider fails to get the object due to some internal error.
MessageFormatException - if object deserialization fails.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Queue

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Queue

All Superinterfaces:
Destination
All Known Subinterfaces:
TemporaryQueue
public interface Queue
extends Destination

A Queue object encapsulates a provider-specific queue name. It is the way a client specifies the identity of a queue to JMS API methods. For those methods that use a Destination as a parameter, a Queue object used as an argument. For example, a queue can be used to create a MessageConsumer and a MessageProducer by calling:

  • Session.CreateConsumer(Destination destination)
  • Session.CreateProducer(Destination destination)

The actual length of time messages are held by a queue and the consequences of resource overflow are not defined by the JMS API.

Version:
1.1 February 2 - 2000
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createConsumer(Destination),
Session.createProducer(Destination),
Session.createQueue(String),
QueueSession.createQueue(String)

Method Summary
String | getQueueName() Gets the name of this queue.
String | toString() Returns a string representation of this object.

Method Detail

getQueueName

public String getQueueName()
                    throws JMSException
Gets the name of this queue.

Clients that depend upon the name are not portable.

Returns:
the queue name
Throws:
JMSException - if the JMS provider implementation of Queue fails to return the queue name due to some internal error.

toString

public String toString()
Returns a string representation of this object.

Returns:
the provider-specific identity values for this queue
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QueueBrowser

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueBrowser

public interface QueueBrowser

A client uses a QueueBrowser object to look at messages on a queue without removing them.

The getEnumeration method returns a java.util.Enumeration that is used to scan the queue's messages. It may be an enumeration of the entire content of a queue, or it may contain only the messages matching a message selector.

Messages may be arriving and expiring while the scan is done. The JMS API does not require the content of an enumeration to be a static snapshot of queue content. Whether these changes are visible or not depends on the JMS provider.

A QueueBrowser can be created from either a Session or a QueueSession.

Version:
1.1 April 9, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createBrowser(javax.jms.Queue), QueueSession.createBrowser(javax.jms.Queue), QueueReceiver

Method Summary
void | close() Closes the QueueBrowser.
Enumeration | getEnumeration() Gets an enumeration for browsing the current queue messages in the order they would be received.
String | getMessageSelector() Gets this queue browser's message selector expression.
Queue | getQueue() Gets the queue associated with this queue browser.

Method Detail

getQueue

public Queue getQueue()
               throws JMSException
Gets the queue associated with this queue browser.

Returns:
the queue
Throws:
JMSException - if the JMS provider fails to get the queue associated with this browser due to some internal error.

getMessageSelector

public String getMessageSelector()
                          throws JMSException
Gets this queue browser's message selector expression.

Returns:
this queue browser's message selector, or null if no message selector exists for the message consumer (that is, if the message selector was not set or was set to null or the empty string)
Throws:
JMSException - if the JMS provider fails to get the message selector for this browser due to some internal error.

getEnumeration

public Enumeration getEnumeration()
                           throws JMSException
Gets an enumeration for browsing the current queue messages in the order they would be received.

Returns:
an enumeration for browsing the messages
Throws:
JMSException - if the JMS provider fails to get the enumeration for this browser due to some internal error.

close

public void close()
           throws JMSException
Closes the QueueBrowser.

Since a provider may allocate some resources on behalf of a QueueBrowser outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

Throws:
JMSException - if the JMS provider fails to close this browser due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QueueConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueConnection

All Superinterfaces:
Connection
All Known Subinterfaces:
XAQueueConnection
public interface QueueConnection
extends Connection

A QueueConnection object is an active connection to a point-to-point JMS provider. A client uses a QueueConnection object to create one or more QueueSession objects for producing and consuming messages.

A QueueConnection can be used to create a QueueSession, from which specialized queue-related objects can be created. A more general, and recommended, approach is to use the Connection object.

The QueueConnection object should be used to support existing code that has already used it.

A QueueConnection cannot be used to create objects specific to the publish/subscribe domain. The createDurableConnectionConsumer method inherits from Connection, but must throw an IllegalStateException if used from QueueConnection.

Version:
1.1 - April 9, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Connection, ConnectionFactory, QueueConnectionFactory

Method Summary
ConnectionConsumer | createConnectionConsumer(Queue queue, String messageSelector, ServerSessionPool sessionPool, int maxMessages) Creates a connection consumer for this connection (optional operation).
QueueSession | createQueueSession(boolean transacted, int acknowledgeMode) Creates a QueueSession object.
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, createDurableConnectionConsumer, createSession, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

Method Detail

createQueueSession

public QueueSession createQueueSession(boolean transacted,
                                       int acknowledgeMode)
                                throws JMSException
Creates a QueueSession object.

Parameters:
transacted - indicates whether the session is transacted
acknowledgeMode - indicates whether the consumer or the client will acknowledge any messages it receives; ignored if the session is transacted. Legal values are Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, and Session.DUPS_OK_ACKNOWLEDGE.
Returns:
a newly created queue session
Throws:
JMSException - if the QueueConnection object fails to create a session due to some internal error or lack of support for the specific transaction and acknowledgement mode.
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE

createConnectionConsumer

public ConnectionConsumer createConnectionConsumer(Queue queue,
                                                   String messageSelector,
                                                   ServerSessionPool sessionPool,
                                                   int maxMessages)
                                            throws JMSException
Creates a connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.

Parameters:
queue - the queue to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
sessionPool - the server session pool to associate with this connection consumer
maxMessages - the maximum number of messages that can be assigned to a server session at one time
Returns:
the connection consumer
Throws:
JMSException - if the QueueConnection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
InvalidDestinationException - if an invalid queue is specified.
InvalidSelectorException - if the message selector is invalid.
See Also:
ConnectionConsumer
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QueueConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueConnectionFactory

All Superinterfaces:
ConnectionFactory
All Known Subinterfaces:
XAQueueConnectionFactory
public interface QueueConnectionFactory
extends ConnectionFactory

A client uses a QueueConnectionFactory object to create QueueConnection objects with a point-to-point JMS provider.

QueueConnectionFactory can be used to create a QueueConnection, from which specialized queue-related objects can be created. A more general, and recommended, approach is to use the ConnectionFactory object.

The QueueConnectionFactory object can be used to support existing code that already uses it.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
ConnectionFactory

Method Summary
QueueConnection | createQueueConnection() Creates a queue connection with the default user identity.
QueueConnection | createQueueConnection(String userName, String password) Creates a queue connection with the specified user identity.
Methods inherited from interface javax.jms.ConnectionFactory
createConnection, createConnection

Method Detail

createQueueConnection

public QueueConnection createQueueConnection()
                                      throws JMSException
Creates a queue connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called. .

Returns:
a newly created queue connection
Throws:
JMSException - if the JMS provider fails to create the queue connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.

createQueueConnection

public QueueConnection createQueueConnection(String userName,
                                             String password)
                                      throws JMSException
Creates a queue connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created queue connection
Throws:
JMSException - if the JMS provider fails to create the queue connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QueueReceiver

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueReceiver

All Superinterfaces:
MessageConsumer
public interface QueueReceiver
extends MessageConsumer

A client uses a QueueReceiver object to receive messages that have been delivered to a queue.

Although it is possible to have multiple QueueReceivers for the same queue, the JMS API does not define how messages are distributed between the QueueReceivers.

If a QueueReceiver specifies a message selector, the messages that are not selected remain on the queue. By definition, a message selector allows a QueueReceiver to skip messages. This means that when the skipped messages are eventually read, the total ordering of the reads does not retain the partial order defined by each message producer. Only QueueReceivers without a message selector will read messages in message producer order.

Creating a MessageConsumer provides the same features as creating a QueueReceiver. A MessageConsumer object is recommended for creating new code. The QueueReceiver is provided to support existing code.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createConsumer(Destination, String),
Session.createConsumer(Destination),
QueueSession.createReceiver(Queue, String),
QueueSession.createReceiver(Queue),
MessageConsumer

Method Summary
 Queue getQueue()
Gets the Queue associated with this queue receiver.
Methods inherited from interface javax.jms.MessageConsumer
close, getMessageListener, getMessageSelector, receive, receive, receiveNoWait, setMessageListener

Method Detail

getQueue

public Queue getQueue()
               throws JMSException
Gets the Queue associated with this queue receiver.

Returns:
this receiver's Queue
Throws:
JMSException - if the JMS provider fails to get the queue for this queue receiver due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QueueRequestor

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class QueueRequestor

java.lang.Object
    extended by javax.jms.QueueRequestor
public class QueueRequestor
extends Object

The QueueRequestor helper class simplifies making service requests.

The QueueRequestor constructor is given a non-transacted QueueSession and a destination Queue. It creates a TemporaryQueue for the responses and provides a request method that sends the request message and waits for its reply.

This is a basic request/reply abstraction that should be sufficient for most uses. JMS providers and clients are free to create more sophisticated versions.

Version:
1.0 - 8 July 1998
Author:
Mark Hapner, Rich Burridge
See Also:
TopicRequestor

Constructor Summary
QueueRequestor(QueueSession session, Queue queue)
Constructor for the QueueRequestor class.
Method Summary
void | close() Closes the QueueRequestor and its session.
Message | request(Message message) Sends a request and waits for a reply.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueueRequestor

public QueueRequestor(QueueSession session,
                      Queue queue)
               throws JMSException
Constructor for the QueueRequestor class.

This implementation assumes the session parameter to be non-transacted, with a delivery mode of either AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE.

Parameters:
session - the QueueSession the queue belongs to
queue - the queue to perform the request/reply call on
Throws:
JMSException - if the JMS provider fails to create the QueueRequestor due to some internal error.
InvalidDestinationException - if an invalid queue is specified.
Method Detail

request

public Message request(Message message)
                throws JMSException
Sends a request and waits for a reply. The temporary queue is used for the JMSReplyTo destination, and only one reply per request is expected.

Parameters:
message - the message to send
Returns:
the reply message
Throws:
JMSException - if the JMS provider fails to complete the request due to some internal error.

close

public void close()
           throws JMSException
Closes the QueueRequestor and its session.

Since a provider may allocate some resources on behalf of a QueueRequestor outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

Note that this method closes the QueueSession object passed to the QueueRequestor constructor.

Throws:
JMSException - if the JMS provider fails to close the QueueRequestor due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QueueSender

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueSender

All Superinterfaces:
MessageProducer
public interface QueueSender
extends MessageProducer

A client uses a QueueSender object to send messages to a queue.

Normally, the Queue is specified when a QueueSender is created. In this case, an attempt to use the send methods for an unidentified QueueSender will throw a java.lang.UnsupportedOperationException.

If the QueueSender is created with an unidentified Queue, an attempt to use the send methods that assume that the Queue has been identified will throw a java.lang.UnsupportedOperationException.

During the execution of its send method, a message must not be changed by other threads within the client. If the message is modified, the result of the send is undefined.

After sending a message, a client may retain and modify it without affecting the message that has been sent. The same message object may be sent multiple times.

The following message headers are set as part of sending a message: JMSDestination, JMSDeliveryMode, JMSExpiration, JMSPriority, JMSMessageID and JMSTimeStamp. When the message is sent, the values of these headers are ignored. After the completion of the send, the headers hold the values specified by the method sending the message. It is possible for the send method not to set JMSMessageID and JMSTimeStamp if the setting of these headers is explicitly disabled by the MessageProducer.setDisableMessageID or MessageProducer.setDisableMessageTimestamp method.

Creating a MessageProducer provides the same features as creating a QueueSender. A MessageProducer object is recommended when creating new code. The QueueSender is provided to support existing code.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
MessageProducer, Session.createProducer(Destination), QueueSession.createSender(Queue)

Method Summary
Queue | getQueue() Gets the queue associated with this QueueSender.
void | send(Message message) Sends a message to the queue.
void | send(Message message, int deliveryMode, int priority, long timeToLive) Sends a message to the queue, specifying delivery mode, priority, and time to live.
void | send(Queue queue, Message message) Sends a message to a queue for an unidentified message producer.
void | send(Queue queue, Message message, int deliveryMode, int priority, long timeToLive) Sends a message to a queue for an unidentified message producer, specifying delivery mode, priority and time to live.
Methods inherited from interface javax.jms.MessageProducer
close, getDeliveryMode, getDestination, getDisableMessageID, getDisableMessageTimestamp, getPriority, getTimeToLive, send, send, setDeliveryMode, setDisableMessageID, setDisableMessageTimestamp, setPriority, setTimeToLive

Method Detail

getQueue

public Queue getQueue()
               throws JMSException
Gets the queue associated with this QueueSender.

Returns:
this sender's queue
Throws:
JMSException - if the JMS provider fails to get the queue for this QueueSender due to some internal error.

send

public void send(Message message)
          throws JMSException
Sends a message to the queue. Uses the QueueSender's default delivery mode, priority, and time to live.

Specified by:
send in interface MessageProducer
Parameters:
message - the message to send
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a QueueSender with an invalid queue.
UnsupportedOperationException - if a client uses this method with a QueueSender that did not specify a queue at creation time.
See Also:
MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

send

public void send(Message message,
                 int deliveryMode,
                 int priority,
                 long timeToLive)
          throws JMSException
Sends a message to the queue, specifying delivery mode, priority, and time to live.

Specified by:
send in interface MessageProducer
Parameters:
message - the message to send
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a QueueSender with an invalid queue.
UnsupportedOperationException - if a client uses this method with a QueueSender that did not specify a queue at creation time.
See Also:
Session.createProducer(javax.jms.Destination)

send

public void send(Queue queue,
                 Message message)
          throws JMSException
Sends a message to a queue for an unidentified message producer. Uses the QueueSender's default delivery mode, priority, and time to live.

Typically, a message producer is assigned a queue at creation time; however, the JMS API also supports unidentified message producers, which require that the queue be supplied every time a message is sent.

Parameters:
queue - the queue to send this message to
message - the message to send
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid queue.
See Also:
MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

send

public void send(Queue queue,
                 Message message,
                 int deliveryMode,
                 int priority,
                 long timeToLive)
          throws JMSException
Sends a message to a queue for an unidentified message producer, specifying delivery mode, priority and time to live.

Typically, a message producer is assigned a queue at creation time; however, the JMS API also supports unidentified message producers, which require that the queue be supplied every time a message is sent.

Parameters:
queue - the queue to send this message to
message - the message to send
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid queue.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QueueSession

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueSession

All Superinterfaces:
Runnable, Session
public interface QueueSession
extends Session

A QueueSession object provides methods for creating QueueReceiver, QueueSender, QueueBrowser, and TemporaryQueue objects.

If there are messages that have been received but not acknowledged when a QueueSession terminates, these messages will be retained and redelivered when a consumer next accesses the queue.

A QueueSession is used for creating Point-to-Point specific objects. In general, use the Session object. The QueueSession is used to support existing code. Using the Session object simplifies the programming model, and allows transactions to be used across the two messaging domains.

A QueueSession cannot be used to create objects specific to the publish/subscribe domain. The following methods inherit from Session, but must throw an IllegalStateException if they are used from QueueSession:

  • createDurableSubscriber
  • createTemporaryTopic
  • createTopic
  • unsubscribe

Version:
1.1 - April 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session, QueueConnection.createQueueSession(boolean, int), XAQueueSession.getQueueSession()

Field Summary
Fields inherited from interface javax.jms.Session
AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED
Method Summary
QueueBrowser | createBrowser(Queue queue) Creates a QueueBrowser object to peek at the messages on the specified queue.
QueueBrowser | createBrowser(Queue queue, String messageSelector) Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
Queue | createQueue(String queueName) Creates a queue identity given a Queue name.
QueueReceiver | createReceiver(Queue queue) Creates a QueueReceiver object to receive messages from the specified queue.
QueueReceiver | createReceiver(Queue queue, String messageSelector) Creates a QueueReceiver object to receive messages from the specified queue using a message selector.
QueueSender | createSender(Queue queue) Creates a QueueSender object to send messages to the specified queue.
TemporaryQueue | createTemporaryQueue() Creates a TemporaryQueue object.
Methods inherited from interface javax.jms.Session
close, commit, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createStreamMessage, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, getTransacted, recover, rollback, run, setMessageListener, unsubscribe

Method Detail

createQueue

public Queue createQueue(String queueName)
                  throws JMSException
Creates a queue identity given a Queue name.

This facility is provided for the rare cases where clients need to dynamically manipulate queue identity. It allows the creation of a queue identity with a provider-specific name. Clients that depend on this ability are not portable.

Note that this method is not for creating the physical queue. The physical creation of queues is an administrative task and is not to be initiated by the JMS API. The one exception is the creation of temporary queues, which is accomplished with the createTemporaryQueue method.

Specified by:
createQueue in interface Session
Parameters:
queueName - the name of this Queue
Returns:
a Queue with the given name
Throws:
JMSException - if the session fails to create a queue due to some internal error.

createReceiver

public QueueReceiver createReceiver(Queue queue)
                             throws JMSException
Creates a QueueReceiver object to receive messages from the specified queue.

Parameters:
queue - the Queue to access
Throws:
JMSException - if the session fails to create a receiver due to some internal error.
InvalidDestinationException - if an invalid queue is specified.

createReceiver

public QueueReceiver createReceiver(Queue queue,
                                    String messageSelector)
                             throws JMSException
Creates a QueueReceiver object to receive messages from the specified queue using a message selector.

Parameters:
queue - the Queue to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
Throws:
JMSException - if the session fails to create a receiver due to some internal error.
InvalidDestinationException - if an invalid queue is specified.
InvalidSelectorException - if the message selector is invalid.

createSender

public QueueSender createSender(Queue queue)
                         throws JMSException
Creates a QueueSender object to send messages to the specified queue.

Parameters:
queue - the Queue to access, or null if this is an unidentified producer
Throws:
JMSException - if the session fails to create a sender due to some internal error.
InvalidDestinationException - if an invalid queue is specified.

createBrowser

public QueueBrowser createBrowser(Queue queue)
                           throws JMSException
Creates a QueueBrowser object to peek at the messages on the specified queue.

Specified by:
createBrowser in interface Session
Parameters:
queue - the Queue to access
Throws:
JMSException - if the session fails to create a browser due to some internal error.
InvalidDestinationException - if an invalid queue is specified.

createBrowser

public QueueBrowser createBrowser(Queue queue,
                                  String messageSelector)
                           throws JMSException
Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.

Specified by:
createBrowser in interface Session
Parameters:
queue - the Queue to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
Throws:
JMSException - if the session fails to create a browser due to some internal error.
InvalidDestinationException - if an invalid queue is specified.
InvalidSelectorException - if the message selector is invalid.

createTemporaryQueue

public TemporaryQueue createTemporaryQueue()
                                    throws JMSException
Creates a TemporaryQueue object. Its lifetime will be that of the QueueConnection unless it is deleted earlier.

Specified by:
createTemporaryQueue in interface Session
Returns:
a temporary queue identity
Throws:
JMSException - if the session fails to create a temporary queue due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ResourceAllocationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class ResourceAllocationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.ResourceAllocationException
All Implemented Interfaces:
Serializable
public class ResourceAllocationException
extends JMSException

This exception is thrown when a provider is unable to allocate the resources required by a method. For example, this exception should be thrown when a call to TopicConnectionFactory.createTopicConnection fails due to a lack of JMS provider resources.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
ResourceAllocationException(String reason)
Constructs a ResourceAllocationException with the specified reason.
ResourceAllocationException(String reason, String errorCode)
Constructs a ResourceAllocationException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResourceAllocationException

public ResourceAllocationException(String reason,
                                   String errorCode)
Constructs a ResourceAllocationException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

ResourceAllocationException

public ResourceAllocationException(String reason)
Constructs a ResourceAllocationException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServerSession

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ServerSession

public interface ServerSession

A ServerSession object is an application server object that is used by a server to associate a thread with a JMS session (optional).

A ServerSession implements two methods:

  • getSession - returns the ServerSession's JMS session.
  • start - starts the execution of the ServerSession thread and results in the execution of the JMS session's run method.

A ConnectionConsumer implemented by a JMS provider uses a ServerSession to process one or more messages that have arrived. It does this by getting a ServerSession from the ConnectionConsumer's ServerSessionPool; getting the ServerSession's JMS session; loading it with the messages; and then starting the ServerSession.

In most cases the ServerSession will register some object it provides as the ServerSession's thread run object. The ServerSession's start method will call the thread's start method, which will start the new thread, and from it, call the run method of the ServerSession's run object. This object will do some housekeeping and then call the Session's run method. When run returns, the ServerSession's run object can return the ServerSession to the ServerSessionPool, and the cycle starts again.

Note that the JMS API does not architect how the ConnectionConsumer loads the Session with messages. Since both the ConnectionConsumer and Session are implemented by the same JMS provider, they can accomplish the load using a private mechanism.

Version:
1.0 - 9 March 1998
Author:
Mark Hapner, Rich Burridge
See Also:
ServerSessionPool, ConnectionConsumer

Method Summary
Session | getSession() Return the ServerSession's Session.
void | start() Cause the Session's run method to be called to process messages that were just assigned to it.

Method Detail

getSession

public Session getSession()
                   throws JMSException
Return the ServerSession's Session. This must be a Session created by the same Connection that will be dispatching messages to it. The provider will assign one or more messages to the Session and then call start on the ServerSession.

Returns:
the server session's session
Throws:
JMSException - if the JMS provider fails to get the associated session for this ServerSession due to some internal error.

start

public void start()
           throws JMSException
Cause the Session's run method to be called to process messages that were just assigned to it.

Throws:
JMSException - if the JMS provider fails to start the server session to process messages due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServerSessionPool

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ServerSessionPool

public interface ServerSessionPool

A ServerSessionPool object is an object implemented by an application server to provide a pool of ServerSession objects for processing the messages of a ConnectionConsumer (optional).

Its only method is getServerSession. The JMS API does not architect how the pool is implemented. It could be a static pool of ServerSession objects, or it could use a sophisticated algorithm to dynamically create ServerSession objects as needed.

If the ServerSessionPool is out of ServerSession objects, the getServerSession call may block. If a ConnectionConsumer is blocked, it cannot deliver new messages until a ServerSession is eventually returned.

Version:
1.0 - 9 March 1998
Author:
Mark Hapner, Rich Burridge
See Also:
ServerSession

Method Summary
 ServerSession getServerSession()
Return a server session from the pool.

Method Detail

getServerSession

public ServerSession getServerSession()
                               throws JMSException
Return a server session from the pool.

Returns:
a server session from the pool
Throws:
JMSException - if an application server fails to return a ServerSession out of its server session pool.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Session

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Session

All Superinterfaces:
Runnable
All Known Subinterfaces:
QueueSession, TopicSession, XAQueueSession, XASession, XATopicSession
public interface Session
extends Runnable

A Session object is a single-threaded context for producing and consuming messages. Although it may allocate provider resources outside the Java virtual machine (JVM), it is considered a lightweight JMS object.

A session serves several purposes:

  • It is a factory for its message producers and consumers.
  • It supplies provider-optimized message factories.
  • It is a factory for TemporaryTopics and TemporaryQueues.
  • It provides a way to create Queue or Topic objects for those clients that need to dynamically manipulate provider-specific destination names.
  • It supports a single series of transactions that combine work spanning its producers and consumers into atomic units.
  • It defines a serial order for the messages it consumes and the messages it produces.
  • It retains messages it consumes until they have been acknowledged.
  • It serializes execution of message listeners registered with its message consumers.
  • It is a factory for QueueBrowsers.

A session can create and service multiple message producers and consumers.

One typical use is to have a thread block on a synchronous MessageConsumer until a message arrives. The thread may then use one or more of the Session's MessageProducers.

If a client desires to have one thread produce messages while others consume them, the client should use a separate session for its producing thread.

Once a connection has been started, any session with one or more registered message listeners is dedicated to the thread of control that delivers messages to it. It is erroneous for client code to use this session or any of its constituent objects from another thread of control. The only exception to this rule is the use of the session or connection close method.

It should be easy for most clients to partition their work naturally into sessions. This model allows clients to start simply and incrementally add message processing complexity as their need for concurrency grows.

The close method is the only session method that can be called while some other session method is being executed in another thread.

A session may be specified as transacted. Each transacted session supports a single series of transactions. Each transaction groups a set of message sends and a set of message receives into an atomic unit of work. In effect, transactions organize a session's input message stream and output message stream into series of atomic units. When a transaction commits, its atomic unit of input is acknowledged and its associated atomic unit of output is sent. If a transaction rollback is done, the transaction's sent messages are destroyed and the session's input is automatically recovered.

The content of a transaction's input and output units is simply those messages that have been produced and consumed within the session's current transaction.

A transaction is completed using either its session's commit method or its session's rollback method. The completion of a session's current transaction automatically begins the next. The result is that a transacted session always has a current transaction within which its work is done.

The Java Transaction Service (JTS) or some other transaction monitor may be used to combine a session's transaction with transactions on other resources (databases, other JMS sessions, etc.). Since Java distributed transactions are controlled via the Java Transaction API (JTA), use of the session's commit and rollback methods in this context is prohibited.

The JMS API does not require support for JTA; however, it does define how a provider supplies this support.

Although it is also possible for a JMS client to handle distributed transactions directly, it is unlikely that many JMS clients will do this. Support for JTA in the JMS API is targeted at systems vendors who will be integrating the JMS API into their application server products.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
QueueSession, TopicSession, XASession

Field Summary
static int | AUTO_ACKNOWLEDGE With this acknowledgment mode, the session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.
static int | CLIENT_ACKNOWLEDGE With this acknowledgment mode, the client acknowledges a consumed message by calling the message's acknowledge method.
static int | DUPS_OK_ACKNOWLEDGE This acknowledgment mode instructs the session to lazily acknowledge the delivery of messages.
static int | SESSION_TRANSACTED This value is returned from the method getAcknowledgeMode if the session is transacted.
Method Summary
void | close() Closes the session.
void | commit() Commits all messages done in this transaction and releases any locks currently held.
QueueBrowser | createBrowser(Queue queue) Creates a QueueBrowser object to peek at the messages on the specified queue.
QueueBrowser | createBrowser(Queue queue, String messageSelector) Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
BytesMessage | createBytesMessage() Creates a BytesMessage object.
MessageConsumer | createConsumer(Destination destination) Creates a MessageConsumer for the specified destination.
MessageConsumer | createConsumer(Destination destination, String messageSelector) Creates a MessageConsumer for the specified destination, using a message selector.
MessageConsumer | createConsumer(Destination destination, String messageSelector, boolean NoLocal) Creates MessageConsumer for the specified destination, using a message selector.
TopicSubscriber | createDurableSubscriber(Topic topic, String name) Creates a durable subscriber to the specified topic.
TopicSubscriber | createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal) Creates a durable subscriber to the specified topic, using a message selector and specifying whether messages published by its own connection should be delivered to it.
MapMessage | createMapMessage() Creates a MapMessage object.
Message | createMessage() Creates a Message object.
ObjectMessage | createObjectMessage() Creates an ObjectMessage object.
ObjectMessage | createObjectMessage(Serializable object) Creates an initialized ObjectMessage object.
MessageProducer | createProducer(Destination destination) Creates a MessageProducer to send messages to the specified destination.
Queue | createQueue(String queueName) Creates a queue identity given a Queue name.
StreamMessage | createStreamMessage() Creates a StreamMessage object.
TemporaryQueue | createTemporaryQueue() Creates a TemporaryQueue object.
TemporaryTopic | createTemporaryTopic() Creates a TemporaryTopic object.
TextMessage | createTextMessage() Creates a TextMessage object.
TextMessage | createTextMessage(String text) Creates an initialized TextMessage object.
Topic | createTopic(String topicName) Creates a topic identity given a Topic name.
int | getAcknowledgeMode() Returns the acknowledgement mode of the session.
MessageListener | getMessageListener() Returns the session's distinguished message listener (optional).
boolean | getTransacted() Indicates whether the session is in transacted mode.
void | recover() Stops message delivery in this session, and restarts message delivery with the oldest unacknowledged message.
void | rollback() Rolls back any messages done in this transaction and releases any locks currently held.
void | run() Optional operation, intended to be used only by Application Servers, not by ordinary JMS clients.
void | setMessageListener(MessageListener listener) Sets the session's distinguished message listener (optional).
void | unsubscribe(String name) Unsubscribes a durable subscription that has been created by a client.

Field Detail

AUTO_ACKNOWLEDGE

public static final int AUTO_ACKNOWLEDGE
With this acknowledgment mode, the session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.

See Also:
Constant Field Values

CLIENT_ACKNOWLEDGE

public static final int CLIENT_ACKNOWLEDGE
With this acknowledgment mode, the client acknowledges a consumed message by calling the message's acknowledge method. Acknowledging a consumed message acknowledges all messages that the session has consumed.

When client acknowledgment mode is used, a client may build up a large number of unacknowledged messages while attempting to process them. A JMS provider should provide administrators with a way to limit client overrun so that clients are not driven to resource exhaustion and ensuing failure when some resource they are using is temporarily blocked.

See Also:
Message.acknowledge(), Constant Field Values

DUPS_OK_ACKNOWLEDGE

public static final int DUPS_OK_ACKNOWLEDGE
This acknowledgment mode instructs the session to lazily acknowledge the delivery of messages. This is likely to result in the delivery of some duplicate messages if the JMS provider fails, so it should only be used by consumers that can tolerate duplicate messages. Use of this mode can reduce session overhead by minimizing the work the session does to prevent duplicates.

See Also:
Constant Field Values

SESSION_TRANSACTED

public static final int SESSION_TRANSACTED
This value is returned from the method getAcknowledgeMode if the session is transacted. If a Session is transacted, the acknowledgement mode is ignored.

See Also:
Constant Field Values
Method Detail

createBytesMessage

public BytesMessage createBytesMessage()
                                throws JMSException
Creates a BytesMessage object. A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createMapMessage

public MapMessage createMapMessage()
                            throws JMSException
Creates a MapMessage object. A MapMessage object is used to send a self-defining set of name-value pairs, where names are String objects and values are primitive values in the Java programming language.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createMessage

public Message createMessage()
                      throws JMSException
Creates a Message object. The Message interface is the root interface of all JMS messages. A Message object holds all the standard message header information. It can be sent when a message containing only header information is sufficient.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createObjectMessage

public ObjectMessage createObjectMessage()
                                  throws JMSException
Creates an ObjectMessage object. An ObjectMessage object is used to send a message that contains a serializable Java object.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createObjectMessage

public ObjectMessage createObjectMessage(Serializable object)
                                  throws JMSException
Creates an initialized ObjectMessage object. An ObjectMessage object is used to send a message that contains a serializable Java object.

Parameters:
object - the object to use to initialize this message
Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createStreamMessage

public StreamMessage createStreamMessage()
                                  throws JMSException
Creates a StreamMessage object. A StreamMessage object is used to send a self-defining stream of primitive values in the Java programming language.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createTextMessage

public TextMessage createTextMessage()
                              throws JMSException
Creates a TextMessage object. A TextMessage object is used to send a message containing a String object.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createTextMessage

public TextMessage createTextMessage(String text)
                              throws JMSException
Creates an initialized TextMessage object. A TextMessage object is used to send a message containing a String.

Parameters:
text - the string used to initialize this message
Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

getTransacted

public boolean getTransacted()
                      throws JMSException
Indicates whether the session is in transacted mode.

Returns:
true if the session is in transacted mode
Throws:
JMSException - if the JMS provider fails to return the transaction mode due to some internal error.

getAcknowledgeMode

public int getAcknowledgeMode()
                       throws JMSException
Returns the acknowledgement mode of the session. The acknowledgement mode is set at the time that the session is created. If the session is transacted, the acknowledgement mode is ignored.

Returns:
If the session is not transacted, returns the current acknowledgement mode for the session. If the session is transacted, returns SESSION_TRANSACTED.
Throws:
JMSException - if the JMS provider fails to return the acknowledgment mode due to some internal error.
Since:
1.1
See Also:
Connection.createSession(boolean, int)

commit

public void commit()
            throws JMSException
Commits all messages done in this transaction and releases any locks currently held.

Throws:
JMSException - if the JMS provider fails to commit the transaction due to some internal error.
TransactionRolledBackException - if the transaction is rolled back due to some internal error during commit.
IllegalStateException - if the method is not called by a transacted session.

rollback

public void rollback()
              throws JMSException
Rolls back any messages done in this transaction and releases any locks currently held.

Throws:
JMSException - if the JMS provider fails to roll back the transaction due to some internal error.
IllegalStateException - if the method is not called by a transacted session.

close

public void close()
           throws JMSException
Closes the session.

Since a provider may allocate some resources on behalf of a session outside the JVM, clients should close the resources when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

There is no need to close the producers and consumers of a closed session.

This call will block until a receive call or message listener in progress has completed. A blocked message consumer receive call returns null when this session is closed.

Closing a transacted session must roll back the transaction in progress.

This method is the only Session method that can be called concurrently.

Invoking any other Session method on a closed session must throw a JMSException.IllegalStateException. Closing a closed session must not throw an exception.

Throws:
JMSException - if the JMS provider fails to close the session due to some internal error.

recover

public void recover()
             throws JMSException
Stops message delivery in this session, and restarts message delivery with the oldest unacknowledged message.

All consumers deliver messages in a serial order. Acknowledging a received message automatically acknowledges all messages that have been delivered to the client.

Restarting a session causes it to take the following actions:

  • Stop message delivery
  • Mark all messages that might have been delivered but not acknowledged as "redelivered"
  • Restart the delivery sequence including all unacknowledged messages that had been previously delivered. Redelivered messages do not have to be delivered in exactly their original delivery order.

Throws:
JMSException - if the JMS provider fails to stop and restart message delivery due to some internal error.
IllegalStateException - if the method is called by a transacted session.

getMessageListener

public MessageListener getMessageListener()
                                   throws JMSException
Returns the session's distinguished message listener (optional).

Returns:
the message listener associated with this session
Throws:
JMSException - if the JMS provider fails to get the message listener due to an internal error.
See Also:
setMessageListener(javax.jms.MessageListener), ServerSessionPool, ServerSession

setMessageListener

public void setMessageListener(MessageListener listener)
                        throws JMSException
Sets the session's distinguished message listener (optional).

When the distinguished message listener is set, no other form of message receipt in the session can be used; however, all forms of sending messages are still supported.

This is an expert facility not used by regular JMS clients.

Parameters:
listener - the message listener to associate with this session
Throws:
JMSException - if the JMS provider fails to set the message listener due to an internal error.
See Also:
getMessageListener(), ServerSessionPool, ServerSession

run

public void run()
Optional operation, intended to be used only by Application Servers, not by ordinary JMS clients.

Specified by:
run in interface Runnable
See Also:
ServerSession

createProducer

public MessageProducer createProducer(Destination destination)
                               throws JMSException
Creates a MessageProducer to send messages to the specified destination.

A client uses a MessageProducer object to send messages to a destination. Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageProducer object.

Parameters:
destination - the Destination to send to, or null if this is a producer which does not have a specified destination.
Throws:
JMSException - if the session fails to create a MessageProducer due to some internal error.
InvalidDestinationException - if an invalid destination is specified.
Since:
1.1

createConsumer

public MessageConsumer createConsumer(Destination destination)
                               throws JMSException
Creates a MessageConsumer for the specified destination. Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageConsumer.

Parameters:
destination - the Destination to access.
Throws:
JMSException - if the session fails to create a consumer due to some internal error.
InvalidDestinationException - if an invalid destination is specified.
Since:
1.1

createConsumer

public MessageConsumer createConsumer(Destination destination,
                                      String messageSelector)
                               throws JMSException
Creates a MessageConsumer for the specified destination, using a message selector. Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageConsumer.

A client uses a MessageConsumer object to receive messages that have been sent to a destination.

Parameters:
destination - the Destination to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
Throws:
JMSException - if the session fails to create a MessageConsumer due to some internal error.
InvalidDestinationException - if an invalid destination is specified.
InvalidSelectorException - if the message selector is invalid.
Since:
1.1

createConsumer

public MessageConsumer createConsumer(Destination destination,
                                      String messageSelector,
                                      boolean NoLocal)
                               throws JMSException
Creates MessageConsumer for the specified destination, using a message selector. This method can specify whether messages published by its own connection should be delivered to it, if the destination is a topic.

Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageConsumer.

A client uses a MessageConsumer object to receive messages that have been published to a destination.

In some cases, a connection may both publish and subscribe to a topic. The consumer NoLocal attribute allows a consumer to inhibit the delivery of messages published by its own connection. The default value for this attribute is False. The noLocal value must be supported by destinations that are topics.

Parameters:
destination - the Destination to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
NoLocal - - if true, and the destination is a topic, inhibits the delivery of messages published by its own connection. The behavior for NoLocal is not specified if the destination is a queue.
Throws:
JMSException - if the session fails to create a MessageConsumer due to some internal error.
InvalidDestinationException - if an invalid destination is specified.
InvalidSelectorException - if the message selector is invalid.
Since:
1.1

createQueue

public Queue createQueue(String queueName)
                  throws JMSException
Creates a queue identity given a Queue name.

This facility is provided for the rare cases where clients need to dynamically manipulate queue identity. It allows the creation of a queue identity with a provider-specific name. Clients that depend on this ability are not portable.

Note that this method is not for creating the physical queue. The physical creation of queues is an administrative task and is not to be initiated by the JMS API. The one exception is the creation of temporary queues, which is accomplished with the createTemporaryQueue method.

Parameters:
queueName - the name of this Queue
Returns:
a Queue with the given name
Throws:
JMSException - if the session fails to create a queue due to some internal error.
Since:
1.1

createTopic

public Topic createTopic(String topicName)
                  throws JMSException
Creates a topic identity given a Topic name.

This facility is provided for the rare cases where clients need to dynamically manipulate topic identity. This allows the creation of a topic identity with a provider-specific name. Clients that depend on this ability are not portable.

Note that this method is not for creating the physical topic. The physical creation of topics is an administrative task and is not to be initiated by the JMS API. The one exception is the creation of temporary topics, which is accomplished with the createTemporaryTopic method.

Parameters:
topicName - the name of this Topic
Returns:
a Topic with the given name
Throws:
JMSException - if the session fails to create a topic due to some internal error.
Since:
1.1

createDurableSubscriber

public TopicSubscriber createDurableSubscriber(Topic topic,
                                               String name)
                                        throws JMSException
Creates a durable subscriber to the specified topic.

If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name that uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription.

A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscriber is equivalent to unsubscribing (deleting) the old one and creating a new one.

In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection. The default value for this attribute is false.

Parameters:
topic - the non-temporary Topic to subscribe to
name - the name used to identify this subscription
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.
Since:
1.1

createDurableSubscriber

public TopicSubscriber createDurableSubscriber(Topic topic,
                                               String name,
                                               String messageSelector,
                                               boolean noLocal)
                                        throws JMSException
Creates a durable subscriber to the specified topic, using a message selector and specifying whether messages published by its own connection should be delivered to it.

If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name which uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription. An inactive durable subscriber is one that exists but does not currently have a message consumer associated with it.

A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscriber is equivalent to unsubscribing (deleting) the old one and creating a new one.

Parameters:
topic - the non-temporary Topic to subscribe to
name - the name used to identify this subscription
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
noLocal - if set, inhibits the delivery of messages published by its own connection
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.
InvalidSelectorException - if the message selector is invalid.
Since:
1.1

createBrowser

public QueueBrowser createBrowser(Queue queue)
                           throws JMSException
Creates a QueueBrowser object to peek at the messages on the specified queue.

Parameters:
queue - the queue to access
Throws:
JMSException - if the session fails to create a browser due to some internal error.
InvalidDestinationException - if an invalid destination is specified
Since:
1.1

createBrowser

public QueueBrowser createBrowser(Queue queue,
                                  String messageSelector)
                           throws JMSException
Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.

Parameters:
queue - the queue to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
Throws:
JMSException - if the session fails to create a browser due to some internal error.
InvalidDestinationException - if an invalid destination is specified
InvalidSelectorException - if the message selector is invalid.
Since:
1.1

createTemporaryQueue

public TemporaryQueue createTemporaryQueue()
                                    throws JMSException
Creates a TemporaryQueue object. Its lifetime will be that of the Connection unless it is deleted earlier.

Returns:
a temporary queue identity
Throws:
JMSException - if the session fails to create a temporary queue due to some internal error.
Since:
1.1

createTemporaryTopic

public TemporaryTopic createTemporaryTopic()
                                    throws JMSException
Creates a TemporaryTopic object. Its lifetime will be that of the Connection unless it is deleted earlier.

Returns:
a temporary topic identity
Throws:
JMSException - if the session fails to create a temporary topic due to some internal error.
Since:
1.1

unsubscribe

public void unsubscribe(String name)
                 throws JMSException
Unsubscribes a durable subscription that has been created by a client.

This method deletes the state being maintained on behalf of the subscriber by its provider.

It is erroneous for a client to delete a durable subscription while there is an active MessageConsumer or TopicSubscriber for the subscription, or while a consumed message is part of a pending transaction or has not been acknowledged in the session.

Parameters:
name - the name used to identify this subscription
Throws:
JMSException - if the session fails to unsubscribe to the durable subscription due to some internal error.
InvalidDestinationException - if an invalid subscription name is specified.
Since:
1.1
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StreamMessage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface StreamMessage

All Superinterfaces:
Message
public interface StreamMessage
extends Message

A StreamMessage object is used to send a stream of primitive types in the Java programming language. It is filled and read sequentially. It inherits from the Message interface and adds a stream message body. Its methods are based largely on those found in java.io.DataInputStream and java.io.DataOutputStream.

The primitive types can be read or written explicitly using methods for each type. They may also be read or written generically as objects. For instance, a call to StreamMessage.writeInt(6) is equivalent to StreamMessage.writeObject(new Integer(6)). Both forms are provided, because the explicit form is convenient for static programming, and the object form is needed when types are not known at compile time.

When the message is first created, and when clearBody is called, the body of the message is in write-only mode. After the first call to reset has been made, the message body is in read-only mode. After a message has been sent, the client that sent it can retain and modify it without affecting the message that has been sent. The same message object can be sent multiple times. When a message has been received, the provider has called reset so that the message body is in read-only mode for the client.

If clearBody is called on a message in read-only mode, the message body is cleared and the message body is in write-only mode.

If a client attempts to read a message in write-only mode, a MessageNotReadableException is thrown.

If a client attempts to write a message in read-only mode, a MessageNotWriteableException is thrown.

StreamMessage objects support the following conversion table. The marked cases must be supported. The unmarked cases must throw a JMSException. The String-to-primitive conversions may throw a runtime exception if the primitive's valueOf() method does not accept it as a valid String representation of the primitive.

A value written as the row type can be read as the column type.

 |        | boolean byte short char int long float double String byte[]
 |----------------------------------------------------------------------
 |boolean |    X                                            X
 |byte    |          X     X         X   X                  X
 |short   |                X         X   X                  X
 |char    |                     X                           X
 |int     |                          X   X                  X
 |long    |                              X                  X
 |float   |                                    X     X      X
 |double  |                                          X      X
 |String  |    X     X     X         X   X     X     X      X
 |byte[]  |                                                        X
 |----------------------------------------------------------------------

Attempting to read a null value as a primitive type must be treated as calling the primitive's corresponding valueOf(String) conversion method with a null value. Since char does not support a String conversion, attempting to read a null value as a char must throw a NullPointerException.

Version:
1.0 - 6 August 1998
Author:
Mark Hapner, Rich Burridge
See Also:
Session.createStreamMessage(), BytesMessage, MapMessage, Message, ObjectMessage, TextMessage

Field Summary
Fields inherited from interface javax.jms.Message
DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE
Method Summary
boolean | readBoolean() Reads a boolean from the stream message.
byte | readByte() Reads a byte value from the stream message.
int | readBytes(byte[] value) Reads a byte array field from the stream message into the specified byte[] object (the read buffer).
char | readChar() Reads a Unicode character value from the stream message.
double | readDouble() Reads a double from the stream message.
float | readFloat() Reads a float from the stream message.
int | readInt() Reads a 32-bit integer from the stream message.
long | readLong() Reads a 64-bit integer from the stream message.
Object | readObject() Reads an object from the stream message.
short | readShort() Reads a 16-bit integer from the stream message.
String | readString() Reads a String from the stream message.
void | reset() Puts the message body in read-only mode and repositions the stream to the beginning.
void | writeBoolean(boolean value) Writes a boolean to the stream message.
void | writeByte(byte value) Writes a byte to the stream message.
void | writeBytes(byte[] value) Writes a byte array field to the stream message.
void | writeBytes(byte[] value, int offset, int length) Writes a portion of a byte array as a byte array field to the stream message.
void | writeChar(char value) Writes a char to the stream message.
void | writeDouble(double value) Writes a double to the stream message.
void | writeFloat(float value) Writes a float to the stream message.
void | writeInt(int value) Writes an int to the stream message.
void | writeLong(long value) Writes a long to the stream message.
void | writeObject(Object value) Writes an object to the stream message.
void | writeShort(short value) Writes a short to the stream message.
void | writeString(String value) Writes a String to the stream message.
Methods inherited from interface javax.jms.Message
acknowledge, clearBody, clearProperties, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

Method Detail

readBoolean

public boolean readBoolean()
                    throws JMSException
Reads a boolean from the stream message.

Returns:
the boolean value read
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readByte

public byte readByte()
              throws JMSException
Reads a byte value from the stream message.

Returns:
the next byte from the stream message as a 8-bit byte
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readShort

public short readShort()
                throws JMSException
Reads a 16-bit integer from the stream message.

Returns:
a 16-bit integer from the stream message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readChar

public char readChar()
              throws JMSException
Reads a Unicode character value from the stream message.

Returns:
a Unicode character from the stream message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid
MessageNotReadableException - if the message is in write-only mode.

readInt

public int readInt()
            throws JMSException
Reads a 32-bit integer from the stream message.

Returns:
a 32-bit integer value from the stream message, interpreted as an int
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readLong

public long readLong()
              throws JMSException
Reads a 64-bit integer from the stream message.

Returns:
a 64-bit integer value from the stream message, interpreted as a long
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readFloat

public float readFloat()
                throws JMSException
Reads a float from the stream message.

Returns:
a float value from the stream message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readDouble

public double readDouble()
                  throws JMSException
Reads a double from the stream message.

Returns:
a double value from the stream message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readString

public String readString()
                  throws JMSException
Reads a String from the stream message.

Returns:
a Unicode string from the stream message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readBytes

public int readBytes(byte[] value)
              throws JMSException
Reads a byte array field from the stream message into the specified byte[] object (the read buffer).

To read the field value, readBytes should be successively called until it returns a value less than the length of the read buffer. The value of the bytes in the buffer following the last byte read is undefined.

If readBytes returns a value equal to the length of the buffer, a subsequent readBytes call must be made. If there are no more bytes to be read, this call returns -1.

If the byte array field value is null, readBytes returns -1.

If the byte array field value is empty, readBytes returns 0.

Once the first readBytes call on a byte[] field value has been made, the full value of the field must be read before it is valid to read the next field. An attempt to read the next field before that has been done will throw a MessageFormatException.

To read the byte field value into a new byte[] object, use the readObject method.

Parameters:
value - the buffer into which the data is read
Returns:
the total number of bytes read into the buffer, or -1 if there is no more data because the end of the byte field has been reached
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.
See Also:
readObject()

readObject

public Object readObject()
                  throws JMSException
Reads an object from the stream message.

This method can be used to return, in objectified format, an object in the Java programming language ("Java object") that has been written to the stream with the equivalent writeObject method call, or its equivalent primitive writetype method.

Note that byte values are returned as byte[], not Byte[].

An attempt to call readObject to read a byte field value into a new byte[] object before the full value of the byte field has been read will throw a MessageFormatException.

Returns:
a Java object from the stream message, in objectified format (for example, if the object was written as an int, an Integer is returned)
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.
See Also:
readBytes(byte[] value)

writeBoolean

public void writeBoolean(boolean value)
                  throws JMSException
Writes a boolean to the stream message. The value true is written as the value (byte)1; the value false is written as the value (byte)0.

Parameters:
value - the boolean value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeByte

public void writeByte(byte value)
               throws JMSException
Writes a byte to the stream message.

Parameters:
value - the byte value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeShort

public void writeShort(short value)
                throws JMSException
Writes a short to the stream message.

Parameters:
value - the short value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeChar

public void writeChar(char value)
               throws JMSException
Writes a char to the stream message.

Parameters:
value - the char value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeInt

public void writeInt(int value)
              throws JMSException
Writes an int to the stream message.

Parameters:
value - the int value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeLong

public void writeLong(long value)
               throws JMSException
Writes a long to the stream message.

Parameters:
value - the long value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeFloat

public void writeFloat(float value)
                throws JMSException
Writes a float to the stream message.

Parameters:
value - the float value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeDouble

public void writeDouble(double value)
                 throws JMSException
Writes a double to the stream message.

Parameters:
value - the double value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeString

public void writeString(String value)
                 throws JMSException
Writes a String to the stream message.

Parameters:
value - the String value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeBytes

public void writeBytes(byte[] value)
                throws JMSException
Writes a byte array field to the stream message.

The byte array value is written to the message as a byte array field. Consecutively written byte array fields are treated as two distinct fields when the fields are read.

Parameters:
value - the byte array value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeBytes

public void writeBytes(byte[] value,
                       int offset,
                       int length)
                throws JMSException
Writes a portion of a byte array as a byte array field to the stream message.

The a portion of the byte array value is written to the message as a byte array field. Consecutively written byte array fields are treated as two distinct fields when the fields are read.

Parameters:
value - the byte array value to be written
offset - the initial offset within the byte array
length - the number of bytes to use
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeObject

public void writeObject(Object value)
                 throws JMSException
Writes an object to the stream message.

This method works only for the objectified primitive object types (Integer, Double, Long ...), String objects, and byte arrays.

Parameters:
value - the Java object to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageFormatException - if the object is invalid.
MessageNotWriteableException - if the message is in read-only mode.

reset

public void reset()
           throws JMSException
Puts the message body in read-only mode and repositions the stream to the beginning.

Throws:
JMSException - if the JMS provider fails to reset the message due to some internal error.
MessageFormatException - if the message has an invalid format.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TemporaryQueue

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TemporaryQueue

All Superinterfaces:
Destination, Queue
public interface TemporaryQueue
extends Queue

A TemporaryQueue object is a unique Queue object created for the duration of a Connection. It is a system-defined queue that can be consumed only by the Connection that created it.

A TemporaryQueue object can be created at either the Session or QueueSession level. Creating it at the Session level allows to the TemporaryQueue to participate in transactions with objects from the Pub/Sub domain. If it is created at the QueueSession, it will only be able participate in transactions with objects from the PTP domain.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createTemporaryQueue(), QueueSession.createTemporaryQueue()

Method Summary
 void delete()
Deletes this temporary queue.
Methods inherited from interface javax.jms.Queue
getQueueName, toString

Method Detail

delete

public void delete()
            throws JMSException
Deletes this temporary queue. If there are existing receivers still using it, a JMSException will be thrown.

Throws:
JMSException - if the JMS provider fails to delete the temporary queue due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TemporaryTopic

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TemporaryTopic

All Superinterfaces:
Destination, Topic
public interface TemporaryTopic
extends Topic

A TemporaryTopic object is a unique Topic object created for the duration of a Connection. It is a system-defined topic that can be consumed only by the Connection that created it.

A TemporaryTopic object can be created either at the Session or TopicSession level. Creating it at the Session level allows the TemporaryTopic to participate in the same transaction with objects from the PTP domain. If a TemporaryTopic is created at the TopicSession, it will only be able participate in transactions with objects from the Pub/Sub domain.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createTemporaryTopic(), TopicSession.createTemporaryTopic()

Method Summary
 void delete()
Deletes this temporary topic.
Methods inherited from interface javax.jms.Topic
getTopicName, toString

Method Detail

delete

public void delete()
            throws JMSException
Deletes this temporary topic. If there are existing subscribers still using it, a JMSException will be thrown.

Throws:
JMSException - if the JMS provider fails to delete the temporary topic due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TextMessage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TextMessage

All Superinterfaces:
Message
public interface TextMessage
extends Message

A TextMessage object is used to send a message containing a java.lang.String. It inherits from the Message interface and adds a text message body.

This message type can be used to transport text-based messages, including those with XML content.

When a client receives a TextMessage, it is in read-only mode. If a client attempts to write to the message at this point, a MessageNotWriteableException is thrown. If clearBody is called, the message can now be both read from and written to.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createTextMessage(), Session.createTextMessage(String), BytesMessage, MapMessage, Message, ObjectMessage, StreamMessage, String

Field Summary
Fields inherited from interface javax.jms.Message
DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE
Method Summary
String | getText() Gets the string containing this message's data.
void | setText(String string) Sets the string containing this message's data.
Methods inherited from interface javax.jms.Message
acknowledge, clearBody, clearProperties, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

Method Detail

setText

public void setText(String string)
             throws JMSException
Sets the string containing this message's data.

Parameters:
string - the String containing the message's data
Throws:
JMSException - if the JMS provider fails to set the text due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

getText

public String getText()
               throws JMSException
Gets the string containing this message's data. The default value is null.

Returns:
the String containing the message's data
Throws:
JMSException - if the JMS provider fails to get the text due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Topic

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Topic

All Superinterfaces:
Destination
All Known Subinterfaces:
TemporaryTopic
public interface Topic
extends Destination

A Topic object encapsulates a provider-specific topic name. It is the way a client specifies the identity of a topic to JMS API methods. For those methods that use a Destination as a parameter, a Topic object may used as an argument . For example, a Topic can be used to create a MessageConsumer and a MessageProducer by calling:

  • Session.CreateConsumer(Destination destination)
  • Session.CreateProducer(Destination destination)

Many publish/subscribe (pub/sub) providers group topics into hierarchies and provide various options for subscribing to parts of the hierarchy. The JMS API places no restriction on what a Topic object represents. It may be a leaf in a topic hierarchy, or it may be a larger part of the hierarchy.

The organization of topics and the granularity of subscriptions to them is an important part of a pub/sub application's architecture. The JMS API does not specify a policy for how this should be done. If an application takes advantage of a provider-specific topic-grouping mechanism, it should document this. If the application is installed using a different provider, it is the job of the administrator to construct an equivalent topic architecture and create equivalent Topic objects.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createConsumer(Destination),
Session.createProducer(Destination),
TopicSession.createTopic(String)

Method Summary
String | getTopicName() Gets the name of this topic.
String | toString() Returns a string representation of this object.

Method Detail

getTopicName

public String getTopicName()
                    throws JMSException
Gets the name of this topic.

Clients that depend upon the name are not portable.

Returns:
the topic name
Throws:
JMSException - if the JMS provider implementation of Topic fails to return the topic name due to some internal error.

toString

public String toString()
Returns a string representation of this object.

Returns:
the provider-specific identity values for this topic
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TopicConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TopicConnection

All Superinterfaces:
Connection
All Known Subinterfaces:
XATopicConnection
public interface TopicConnection
extends Connection

A TopicConnection object is an active connection to a publish/subscribe JMS provider. A client uses a TopicConnection object to create one or more TopicSession objects for producing and consuming messages.

A TopicConnection can be used to create a TopicSession, from which specialized topic-related objects can be created. A more general, and recommended approach is to use the Connection object.

The TopicConnection object should be used to support existing code.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Connection, ConnectionFactory, TopicConnectionFactory

Method Summary
ConnectionConsumer | createConnectionConsumer(Topic topic, String messageSelector, ServerSessionPool sessionPool, int maxMessages) Creates a connection consumer for this connection (optional operation).
ConnectionConsumer | createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages) Create a durable connection consumer for this connection (optional operation).
TopicSession | createTopicSession(boolean transacted, int acknowledgeMode) Creates a TopicSession object.
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, createSession, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

Method Detail

createTopicSession

public TopicSession createTopicSession(boolean transacted,
                                       int acknowledgeMode)
                                throws JMSException
Creates a TopicSession object.

Parameters:
transacted - indicates whether the session is transacted
acknowledgeMode - indicates whether the consumer or the client will acknowledge any messages it receives; ignored if the session is transacted. Legal values are Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, and Session.DUPS_OK_ACKNOWLEDGE.
Returns:
a newly created topic session
Throws:
JMSException - if the TopicConnection object fails to create a session due to some internal error or lack of support for the specific transaction and acknowledgement mode.
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE

createConnectionConsumer

public ConnectionConsumer createConnectionConsumer(Topic topic,
                                                   String messageSelector,
                                                   ServerSessionPool sessionPool,
                                                   int maxMessages)
                                            throws JMSException
Creates a connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.

Parameters:
topic - the topic to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
sessionPool - the server session pool to associate with this connection consumer
maxMessages - the maximum number of messages that can be assigned to a server session at one time
Returns:
the connection consumer
Throws:
JMSException - if the TopicConnection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
InvalidDestinationException - if an invalid topic is specified.
InvalidSelectorException - if the message selector is invalid.
See Also:
ConnectionConsumer

createDurableConnectionConsumer

public ConnectionConsumer createDurableConnectionConsumer(Topic topic,
                                                          String subscriptionName,
                                                          String messageSelector,
                                                          ServerSessionPool sessionPool,
                                                          int maxMessages)
                                                   throws JMSException
Create a durable connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.

Specified by:
createDurableConnectionConsumer in interface Connection
Parameters:
topic - the topic to access
subscriptionName - durable subscription name
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
sessionPool - the server session pool to associate with this durable connection consumer
maxMessages - the maximum number of messages that can be assigned to a server session at one time
Returns:
the durable connection consumer
Throws:
JMSException - if the TopicConnection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
InvalidDestinationException - if an invalid topic is specified.
InvalidSelectorException - if the message selector is invalid.
See Also:
ConnectionConsumer
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TopicConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TopicConnectionFactory

All Superinterfaces:
ConnectionFactory
All Known Subinterfaces:
XATopicConnectionFactory
public interface TopicConnectionFactory
extends ConnectionFactory

A client uses a TopicConnectionFactory object to create TopicConnection objects with a publish/subscribe JMS provider.

A TopicConnectionFactory can be used to create a TopicConnection, from which specialized topic-related objects can be created. A more general, and recommended approach is to use the ConnectionFactory object.

The TopicConnectionFactory object should be used to support existing code.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
ConnectionFactory

Method Summary
TopicConnection | createTopicConnection() Creates a topic connection with the default user identity.
TopicConnection | createTopicConnection(String userName, String password) Creates a topic connection with the specified user identity.
Methods inherited from interface javax.jms.ConnectionFactory
createConnection, createConnection

Method Detail

createTopicConnection

public TopicConnection createTopicConnection()
                                      throws JMSException
Creates a topic connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Returns:
a newly created topic connection
Throws:
JMSException - if the JMS provider fails to create a topic connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.

createTopicConnection

public TopicConnection createTopicConnection(String userName,
                                             String password)
                                      throws JMSException
Creates a topic connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created topic connection
Throws:
JMSException - if the JMS provider fails to create a topic connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TopicPublisher

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TopicPublisher

All Superinterfaces:
MessageProducer
public interface TopicPublisher
extends MessageProducer

A client uses a TopicPublisher object to publish messages on a topic. A TopicPublisher object is the publish-subscribe form of a message producer.

Normally, the Topic is specified when a TopicPublisher is created. In this case, an attempt to use the publish methods for an unidentified TopicPublisher will throw a java.lang.UnsupportedOperationException.

If the TopicPublisher is created with an unidentified Topic, an attempt to use the publish methods that assume that the Topic has been identified will throw a java.lang.UnsupportedOperationException.

During the execution of its publish method, a message must not be changed by other threads within the client. If the message is modified, the result of the publish is undefined.

After publishing a message, a client may retain and modify it without affecting the message that has been published. The same message object may be published multiple times.

The following message headers are set as part of publishing a message: JMSDestination, JMSDeliveryMode, JMSExpiration, JMSPriority, JMSMessageID and JMSTimeStamp. When the message is published, the values of these headers are ignored. After completion of the publish, the headers hold the values specified by the method publishing the message. It is possible for the publish method not to set JMSMessageID and JMSTimeStamp if the setting of these headers is explicitly disabled by the MessageProducer.setDisableMessageID or MessageProducer.setDisableMessageTimestamp method.

Creating a MessageProducer provides the same features as creating a TopicPublisher. A MessageProducer object is recommended when creating new code. The TopicPublisher is provided to support existing code.

Because TopicPublisher inherits from MessageProducer, it inherits the send methods that are a part of the MessageProducer interface. Using the send methods will have the same effect as using the publish methods: they are functionally the same.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createProducer(Destination), TopicSession.createPublisher(Topic)

Method Summary
Topic | getTopic() Gets the topic associated with this TopicPublisher.
void | publish(Message message) Publishes a message to the topic.
void | publish(Message message, int deliveryMode, int priority, long timeToLive) Publishes a message to the topic, specifying delivery mode, priority, and time to live.
void | publish(Topic topic, Message message) Publishes a message to a topic for an unidentified message producer.
void | publish(Topic topic, Message message, int deliveryMode, int priority, long timeToLive) Publishes a message to a topic for an unidentified message producer, specifying delivery mode, priority and time to live.
Methods inherited from interface javax.jms.MessageProducer
close, getDeliveryMode, getDestination, getDisableMessageID, getDisableMessageTimestamp, getPriority, getTimeToLive, send, send, send, send, setDeliveryMode, setDisableMessageID, setDisableMessageTimestamp, setPriority, setTimeToLive

Method Detail

getTopic

public Topic getTopic()
               throws JMSException
Gets the topic associated with this TopicPublisher.

Returns:
this publisher's topic
Throws:
JMSException - if the JMS provider fails to get the topic for this TopicPublisher due to some internal error.

publish

public void publish(Message message)
             throws JMSException
Publishes a message to the topic. Uses the TopicPublisher's default delivery mode, priority, and time to live.

Parameters:
message - the message to publish
Throws:
JMSException - if the JMS provider fails to publish the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a TopicPublisher with an invalid topic.
UnsupportedOperationException - if a client uses this method with a TopicPublisher that did not specify a topic at creation time.
See Also:
MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

publish

public void publish(Message message,
                    int deliveryMode,
                    int priority,
                    long timeToLive)
             throws JMSException
Publishes a message to the topic, specifying delivery mode, priority, and time to live.

Parameters:
message - the message to publish
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to publish the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a TopicPublisher with an invalid topic.
UnsupportedOperationException - if a client uses this method with a TopicPublisher that did not specify a topic at creation time.

publish

public void publish(Topic topic,
                    Message message)
             throws JMSException
Publishes a message to a topic for an unidentified message producer. Uses the TopicPublisher's default delivery mode, priority, and time to live.

Typically, a message producer is assigned a topic at creation time; however, the JMS API also supports unidentified message producers, which require that the topic be supplied every time a message is published.

Parameters:
topic - the topic to publish this message to
message - the message to publish
Throws:
JMSException - if the JMS provider fails to publish the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid topic.
See Also:
MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

publish

public void publish(Topic topic,
                    Message message,
                    int deliveryMode,
                    int priority,
                    long timeToLive)
             throws JMSException
Publishes a message to a topic for an unidentified message producer, specifying delivery mode, priority and time to live.

Typically, a message producer is assigned a topic at creation time; however, the JMS API also supports unidentified message producers, which require that the topic be supplied every time a message is published.

Parameters:
topic - the topic to publish this message to
message - the message to publish
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to publish the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid topic.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TopicRequestor

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class TopicRequestor

java.lang.Object
    extended by javax.jms.TopicRequestor
public class TopicRequestor
extends Object

The TopicRequestor helper class simplifies making service requests.

The TopicRequestor constructor is given a non-transacted TopicSession and a destination Topic. It creates a TemporaryTopic for the responses and provides a request method that sends the request message and waits for its reply.

This is a basic request/reply abstraction that should be sufficient for most uses. JMS providers and clients are free to create more sophisticated versions.

Version:
1.0 - 8 July 1998
Author:
Mark Hapner, Rich Burridge
See Also:
QueueRequestor

Constructor Summary
TopicRequestor(TopicSession session, Topic topic)
Constructor for the TopicRequestor class.
Method Summary
void | close() Closes the TopicRequestor and its session.
Message | request(Message message) Sends a request and waits for a reply.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TopicRequestor

public TopicRequestor(TopicSession session,
                      Topic topic)
               throws JMSException
Constructor for the TopicRequestor class.

This implementation assumes the session parameter to be non-transacted, with a delivery mode of either AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE.

Parameters:
session - the TopicSession the topic belongs to
topic - the topic to perform the request/reply call on
Throws:
JMSException - if the JMS provider fails to create the TopicRequestor due to some internal error.
InvalidDestinationException - if an invalid topic is specified.
Method Detail

request

public Message request(Message message)
                throws JMSException
Sends a request and waits for a reply. The temporary topic is used for the JMSReplyTo destination; the first reply is returned, and any following replies are discarded.

Parameters:
message - the message to send
Returns:
the reply message
Throws:
JMSException - if the JMS provider fails to complete the request due to some internal error.

close

public void close()
           throws JMSException
Closes the TopicRequestor and its session.

Since a provider may allocate some resources on behalf of a TopicRequestor outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

Note that this method closes the TopicSession object passed to the TopicRequestor constructor.

Throws:
JMSException - if the JMS provider fails to close the TopicRequestor due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TopicSession

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TopicSession

All Superinterfaces:
Runnable, Session
public interface TopicSession
extends Session

A TopicSession object provides methods for creating TopicPublisher, TopicSubscriber, and TemporaryTopic objects. It also provides a method for deleting its client's durable subscribers.

A TopicSession is used for creating Pub/Sub specific objects. In general, use the Session object, and use TopicSession only to support existing code. Using the Session object simplifies the programming model, and allows transactions to be used across the two messaging domains.

A TopicSession cannot be used to create objects specific to the point-to-point domain. The following methods inherit from Session, but must throw an IllegalStateException if used from TopicSession:

  • createBrowser
  • createQueue
  • createTemporaryQueue

Version:
1.1 - April 9, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session,
Connection.createSession(boolean, int),
TopicConnection.createTopicSession(boolean, int),
XATopicSession.getTopicSession()

Field Summary
Fields inherited from interface javax.jms.Session
AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED
Method Summary
TopicSubscriber | createDurableSubscriber(Topic topic, String name) Creates a durable subscriber to the specified topic.
TopicSubscriber | createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal) Creates a durable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
TopicPublisher | createPublisher(Topic topic) Creates a publisher for the specified topic.
TopicSubscriber | createSubscriber(Topic topic) Creates a nondurable subscriber to the specified topic.
TopicSubscriber | createSubscriber(Topic topic, String messageSelector, boolean noLocal) Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
TemporaryTopic | createTemporaryTopic() Creates a TemporaryTopic object.
Topic | createTopic(String topicName) Creates a topic identity given a Topic name.
void | unsubscribe(String name) Unsubscribes a durable subscription that has been created by a client.
Methods inherited from interface javax.jms.Session
close, commit, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createStreamMessage, createTemporaryQueue, createTextMessage, createTextMessage, getAcknowledgeMode, getMessageListener, getTransacted, recover, rollback, run, setMessageListener

Method Detail

createTopic

public Topic createTopic(String topicName)
                  throws JMSException
Creates a topic identity given a Topic name.

This facility is provided for the rare cases where clients need to dynamically manipulate topic identity. This allows the creation of a topic identity with a provider-specific name. Clients that depend on this ability are not portable.

Note that this method is not for creating the physical topic. The physical creation of topics is an administrative task and is not to be initiated by the JMS API. The one exception is the creation of temporary topics, which is accomplished with the createTemporaryTopic method.

Specified by:
createTopic in interface Session
Parameters:
topicName - the name of this Topic
Returns:
a Topic with the given name
Throws:
JMSException - if the session fails to create a topic due to some internal error.

createSubscriber

public TopicSubscriber createSubscriber(Topic topic)
                                 throws JMSException
Creates a nondurable subscriber to the specified topic.

A client uses a TopicSubscriber object to receive messages that have been published to a topic.

Regular TopicSubscriber objects are not durable. They receive only messages that are published while they are active.

In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection. The default value for this attribute is false.

Parameters:
topic - the Topic to subscribe to
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.

createSubscriber

public TopicSubscriber createSubscriber(Topic topic,
                                        String messageSelector,
                                        boolean noLocal)
                                 throws JMSException
Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.

A client uses a TopicSubscriber object to receive messages that have been published to a topic.

Regular TopicSubscriber objects are not durable. They receive only messages that are published while they are active.

Messages filtered out by a subscriber's message selector will never be delivered to the subscriber. From the subscriber's perspective, they do not exist.

In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection. The default value for this attribute is false.

Parameters:
topic - the Topic to subscribe to
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
noLocal - if set, inhibits the delivery of messages published by its own connection
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.
InvalidSelectorException - if the message selector is invalid.

createDurableSubscriber

public TopicSubscriber createDurableSubscriber(Topic topic,
                                               String name)
                                        throws JMSException
Creates a durable subscriber to the specified topic.

If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name that uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription.

A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscriber is equivalent to unsubscribing (deleting) the old one and creating a new one.

In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection. The default value for this attribute is false.

Specified by:
createDurableSubscriber in interface Session
Parameters:
topic - the non-temporary Topic to subscribe to
name - the name used to identify this subscription
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.

createDurableSubscriber

public TopicSubscriber createDurableSubscriber(Topic topic,
                                               String name,
                                               String messageSelector,
                                               boolean noLocal)
                                        throws JMSException
Creates a durable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.

If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name which uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription. An inactive durable subscriber is one that exists but does not currently have a message consumer associated with it.

A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscriber is equivalent to unsubscribing (deleting) the old one and creating a new one.

Specified by:
createDurableSubscriber in interface Session
Parameters:
topic - the non-temporary Topic to subscribe to
name - the name used to identify this subscription
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
noLocal - if set, inhibits the delivery of messages published by its own connection
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.
InvalidSelectorException - if the message selector is invalid.

createPublisher

public TopicPublisher createPublisher(Topic topic)
                               throws JMSException
Creates a publisher for the specified topic.

A client uses a TopicPublisher object to publish messages on a topic. Each time a client creates a TopicPublisher on a topic, it defines a new sequence of messages that have no ordering relationship with the messages it has previously sent.

Parameters:
topic - the Topic to publish to, or null if this is an unidentified producer
Throws:
JMSException - if the session fails to create a publisher due to some internal error.
InvalidDestinationException - if an invalid topic is specified.

createTemporaryTopic

public TemporaryTopic createTemporaryTopic()
                                    throws JMSException
Creates a TemporaryTopic object. Its lifetime will be that of the TopicConnection unless it is deleted earlier.

Specified by:
createTemporaryTopic in interface Session
Returns:
a temporary topic identity
Throws:
JMSException - if the session fails to create a temporary topic due to some internal error.

unsubscribe

public void unsubscribe(String name)
                 throws JMSException
Unsubscribes a durable subscription that has been created by a client.

This method deletes the state being maintained on behalf of the subscriber by its provider.

It is erroneous for a client to delete a durable subscription while there is an active TopicSubscriber for the subscription, or while a consumed message is part of a pending transaction or has not been acknowledged in the session.

Specified by:
unsubscribe in interface Session
Parameters:
name - the name used to identify this subscription
Throws:
JMSException - if the session fails to unsubscribe to the durable subscription due to some internal error.
InvalidDestinationException - if an invalid subscription name is specified.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TopicSubscriber

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TopicSubscriber

All Superinterfaces:
MessageConsumer
public interface TopicSubscriber
extends MessageConsumer

A client uses a TopicSubscriber object to receive messages that have been published to a topic. A TopicSubscriber object is the publish/subscribe form of a message consumer. A MessageConsumer can be created by using Session.createConsumer.

A TopicSession allows the creation of multiple TopicSubscriber objects per topic. It will deliver each message for a topic to each subscriber eligible to receive it. Each copy of the message is treated as a completely separate message. Work done on one copy has no effect on the others; acknowledging one does not acknowledge the others; one message may be delivered immediately, while another waits for its subscriber to process messages ahead of it.

Regular TopicSubscriber objects are not durable. They receive only messages that are published while they are active.

Messages filtered out by a subscriber's message selector will never be delivered to the subscriber. From the subscriber's perspective, they do not exist.

In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection.

If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name that uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription.

A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscription is equivalent to unsubscribing (deleting) the old one and creating a new one.

The unsubscribe method is used to delete a durable subscription. The unsubscribe method can be used at the Session or TopicSession level. This method deletes the state being maintained on behalf of the subscriber by its provider.

Creating a MessageConsumer provides the same features as creating a TopicSubscriber. To create a durable subscriber, use of Session.CreateDurableSubscriber is recommended. The TopicSubscriber is provided to support existing code.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createConsumer(javax.jms.Destination), Session.createDurableSubscriber(javax.jms.Topic, java.lang.String), TopicSession, TopicSession.createSubscriber(javax.jms.Topic), MessageConsumer

Method Summary
boolean | getNoLocal() Gets the NoLocal attribute for this subscriber.
Topic | getTopic() Gets the Topic associated with this subscriber.
Methods inherited from interface javax.jms.MessageConsumer
close, getMessageListener, getMessageSelector, receive, receive, receiveNoWait, setMessageListener

Method Detail

getTopic

public Topic getTopic()
               throws JMSException
Gets the Topic associated with this subscriber.

Returns:
this subscriber's Topic
Throws:
JMSException - if the JMS provider fails to get the topic for this topic subscriber due to some internal error.

getNoLocal

public boolean getNoLocal()
                   throws JMSException
Gets the NoLocal attribute for this subscriber. The default value for this attribute is false.

Returns:
true if locally published messages are being inhibited
Throws:
JMSException - if the JMS provider fails to get the NoLocal attribute for this topic subscriber due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransactionInProgressException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class TransactionInProgressException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.TransactionInProgressException
All Implemented Interfaces:
Serializable
public class TransactionInProgressException
extends JMSException

This exception is thrown when an operation is invalid because a transaction is in progress. For instance, an attempt to call Session.commit when a session is part of a distributed transaction should throw a TransactionInProgressException.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
TransactionInProgressException(String reason)
Constructs a TransactionInProgressException with the specified reason.
TransactionInProgressException(String reason, String errorCode)
Constructs a TransactionInProgressException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionInProgressException

public TransactionInProgressException(String reason,
                                      String errorCode)
Constructs a TransactionInProgressException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

TransactionInProgressException

public TransactionInProgressException(String reason)
Constructs a TransactionInProgressException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransactionRolledBackException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class TransactionRolledBackException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.jms.JMSException
                extended by javax.jms.TransactionRolledBackException
All Implemented Interfaces:
Serializable
public class TransactionRolledBackException
extends JMSException

This exception must be thrown when a call to Session.commit results in a rollback of the current transaction.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
TransactionRolledBackException(String reason)
Constructs a TransactionRolledBackException with the specified reason.
TransactionRolledBackException(String reason, String errorCode)
Constructs a TransactionRolledBackException with the specified reason and error code.
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRolledBackException

public TransactionRolledBackException(String reason,
                                      String errorCode)
Constructs a TransactionRolledBackException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

TransactionRolledBackException

public TransactionRolledBackException(String reason)
Constructs a TransactionRolledBackException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XAConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XAConnection

All Superinterfaces:
Connection
All Known Subinterfaces:
XAQueueConnection, XATopicConnection
public interface XAConnection
extends Connection

The XAConnection interface extends the capability of Connection by providing an XASession (optional).

The XAConnection interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XAQueueConnection, XATopicConnection

Method Summary
Session | createSession(boolean transacted, int acknowledgeMode) Creates an Session object.
XASession | createXASession() Creates an XASession object.
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, createDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

Method Detail

createXASession

public XASession createXASession()
                          throws JMSException
Creates an XASession object.

Returns:
a newly created XASession
Throws:
JMSException - if the XAConnection object fails to create an XASession due to some internal error.
Since:
1.1

createSession

public Session createSession(boolean transacted,
                             int acknowledgeMode)
                      throws JMSException
Creates an Session object.

Specified by:
createSession in interface Connection
Parameters:
transacted - usage undefined
acknowledgeMode - usage undefined
Returns:
a Session object
Throws:
JMSException - if the XAConnection object fails to create an Session due to some internal error.
Since:
1.1
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XAConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XAConnectionFactory

All Known Subinterfaces:
XAQueueConnectionFactory, XATopicConnectionFactory
public interface XAConnectionFactory

The XAConnectionFactory interface is a base interface for the XAQueueConnectionFactory and XATopicConnectionFactory interfaces.

Some application servers provide support for grouping JTS capable resource use into a distributed transaction (optional). To include JMS API transactions in a JTS transaction, an application server requires a JTS aware JMS provider. A JMS provider exposes its JTS support using an XAConnectionFactory object, which an application server uses to create XAConnection objects.

XAConnectionFactory objects are JMS administered objects, just like ConnectionFactory objects. It is expected that application servers will find them using the Java Naming and Directory Interface (JNDI) API.

The XAConnectionFactory interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 April 4, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XAQueueConnectionFactory, XATopicConnectionFactory

Method Summary
XAConnection | createXAConnection() Creates an XAConnection with the default user identity.
XAConnection | createXAConnection(String userName, String password) Creates an XA connection with the specified user identity.

Method Detail

createXAConnection

public XAConnection createXAConnection()
                                throws JMSException
Creates an XAConnection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Returns:
a newly created XAConnection
Throws:
JMSException - if the JMS provider fails to create an XA connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Since:
1.1

createXAConnection

public XAConnection createXAConnection(String userName,
                                       String password)
                                throws JMSException
Creates an XA connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created XA connection
Throws:
JMSException - if the JMS provider fails to create an XA connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Since:
1.1
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XAQueueConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XAQueueConnection

All Superinterfaces:
Connection, QueueConnection, XAConnection
public interface XAQueueConnection
extends XAConnection, QueueConnection

An XAQueueConnection provides the same create options as QueueConnection (optional). The only difference is that an XAConnection is by definition transacted.

The XAQueueConnection interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 February 2 - 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XAConnection

Method Summary
QueueSession | createQueueSession(boolean transacted, int acknowledgeMode) Creates an XAQueueSession object.
XAQueueSession | createXAQueueSession() Creates an XAQueueSession object.
Methods inherited from interface javax.jms.XAConnection
createSession, createXASession
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, createDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop
Methods inherited from interface javax.jms.QueueConnection
createConnectionConsumer

Method Detail

createXAQueueSession

public XAQueueSession createXAQueueSession()
                                    throws JMSException
Creates an XAQueueSession object.

Returns:
a newly created XAQueueSession
Throws:
JMSException - if the XAQueueConnection object fails to create an XA queue session due to some internal error.

createQueueSession

public QueueSession createQueueSession(boolean transacted,
                                       int acknowledgeMode)
                                throws JMSException
Creates an XAQueueSession object.

Specified by:
createQueueSession in interface QueueConnection
Parameters:
transacted - usage undefined
acknowledgeMode - usage undefined
Returns:
a newly created XAQueueSession
Throws:
JMSException - if the XAQueueConnection object fails to create an XA queue session due to some internal error.
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XAQueueConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XAQueueConnectionFactory

All Superinterfaces:
ConnectionFactory, QueueConnectionFactory, XAConnectionFactory
public interface XAQueueConnectionFactory
extends XAConnectionFactory, QueueConnectionFactory

An XAQueueConnectionFactory provides the same create options as a QueueConnectionFactory (optional).

The XATopicConnectionFactory interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 - 8 April 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
QueueConnectionFactory, XAConnectionFactory

Method Summary
XAQueueConnection | createXAQueueConnection() Creates an XA queue connection with the default user identity.
XAQueueConnection | createXAQueueConnection(String userName, String password) Creates an XA queue connection with the specified user identity.
Methods inherited from interface javax.jms.XAConnectionFactory
createXAConnection, createXAConnection
Methods inherited from interface javax.jms.QueueConnectionFactory
createQueueConnection, createQueueConnection
Methods inherited from interface javax.jms.ConnectionFactory
createConnection, createConnection

Method Detail

createXAQueueConnection

public XAQueueConnection createXAQueueConnection()
                                          throws JMSException
Creates an XA queue connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Returns:
a newly created XA queue connection
Throws:
JMSException - if the JMS provider fails to create an XA queue connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.

createXAQueueConnection

public XAQueueConnection createXAQueueConnection(String userName,
                                                 String password)
                                          throws JMSException
Creates an XA queue connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created XA queue connection
Throws:
JMSException - if the JMS provider fails to create an XA queue connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XAQueueSession

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XAQueueSession

All Superinterfaces:
Runnable, Session, XASession
public interface XAQueueSession
extends XASession

An XAQueueSession provides a regular QueueSession, which can be used to create QueueReceiver, QueueSender, and QueueBrowser objects (optional).

The XAQueueSession interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XASession

Field Summary
Fields inherited from interface javax.jms.Session
AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED
Method Summary
 QueueSession getQueueSession()
Gets the queue session associated with this XAQueueSession.
Methods inherited from interface javax.jms.XASession
commit, getSession, getTransacted, getXAResource, rollback
Methods inherited from interface javax.jms.Session
close, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createStreamMessage, createTemporaryQueue, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, recover, run, setMessageListener, unsubscribe

Method Detail

getQueueSession

public QueueSession getQueueSession()
                             throws JMSException
Gets the queue session associated with this XAQueueSession.

Returns:
the queue session object
Throws:
JMSException - if an internal error occurs.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XASession

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XASession

All Superinterfaces:
Runnable, Session
All Known Subinterfaces:
XAQueueSession, XATopicSession
public interface XASession
extends Session

The XASession interface extends the capability of Session by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional). This support takes the form of a javax.transaction.xa.XAResource object. The functionality of this object closely resembles that defined by the standard X/Open XA Resource interface.

An application server controls the transactional assignment of an XASession by obtaining its XAResource. It uses the XAResource to assign the session to a transaction, prepare and commit work on the transaction, and so on.

An XAResource provides some fairly sophisticated facilities for interleaving work on multiple transactions, recovering a list of transactions in progress, and so on. A JTA aware JMS provider must fully implement this functionality. This could be done by using the services of a database that supports XA, or a JMS provider may choose to implement this functionality from scratch.

A client of the application server is given what it thinks is a regular JMS Session. Behind the scenes, the application server controls the transaction management of the underlying XASession.

The XASession interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session

Field Summary
Fields inherited from interface javax.jms.Session
AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED
Method Summary
void | commit() Throws a TransactionInProgressException, since it should not be called for an XASession object.
Session | getSession() Gets the session associated with this XASession.
boolean | getTransacted() Indicates whether the session is in transacted mode.
XAResource | getXAResource() Returns an XA resource to the caller.
void | rollback() Throws a TransactionInProgressException, since it should not be called for an XASession object.
Methods inherited from interface javax.jms.Session
close, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createStreamMessage, createTemporaryQueue, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, recover, run, setMessageListener, unsubscribe

Method Detail

getSession

public Session getSession()
                   throws JMSException
Gets the session associated with this XASession.

Returns:
the session object
Throws:
JMSException - if an internal error occurs.
Since:
1.1

getXAResource

public XAResource getXAResource()
Returns an XA resource to the caller.

Returns:
an XA resource to the caller

getTransacted

public boolean getTransacted()
                      throws JMSException
Indicates whether the session is in transacted mode.

Specified by:
getTransacted in interface Session
Returns:
true
Throws:
JMSException - if the JMS provider fails to return the transaction mode due to some internal error.

commit

public void commit()
            throws JMSException
Throws a TransactionInProgressException, since it should not be called for an XASession object.

Specified by:
commit in interface Session
Throws:
TransactionInProgressException - if the method is called on an XASession.
JMSException - if the JMS provider fails to commit the transaction due to some internal error.

rollback

public void rollback()
              throws JMSException
Throws a TransactionInProgressException, since it should not be called for an XASession object.

Specified by:
rollback in interface Session
Throws:
TransactionInProgressException - if the method is called on an XASession.
JMSException - if the JMS provider fails to roll back the transaction due to some internal error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XATopicConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XATopicConnection

All Superinterfaces:
Connection, TopicConnection, XAConnection
public interface XATopicConnection
extends XAConnection, TopicConnection

An XATopicConnection provides the same create options as TopicConnection (optional). The Topic connections created are transactional.

The XATopicConnection interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XAConnection

Method Summary
TopicSession | createTopicSession(boolean transacted, int acknowledgeMode) Creates an XATopicSession object.
XATopicSession | createXATopicSession() Creates an XATopicSession object.
Methods inherited from interface javax.jms.XAConnection
createSession, createXASession
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, createDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop
Methods inherited from interface javax.jms.TopicConnection
createConnectionConsumer, createDurableConnectionConsumer

Method Detail

createXATopicSession

public XATopicSession createXATopicSession()
                                    throws JMSException
Creates an XATopicSession object.

Returns:
a newly created XA topic session
Throws:
JMSException - if the XATopicConnection object fails to create an XA topic session due to some internal error.

createTopicSession

public TopicSession createTopicSession(boolean transacted,
                                       int acknowledgeMode)
                                throws JMSException
Creates an XATopicSession object.

Specified by:
createTopicSession in interface TopicConnection
Parameters:
transacted - usage undefined
acknowledgeMode - usage undefined
Returns:
a newly created XA topic session
Throws:
JMSException - if the XATopicConnection object fails to create an XA topic session due to some internal error.
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XATopicConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XATopicConnectionFactory

All Superinterfaces:
ConnectionFactory, TopicConnectionFactory, XAConnectionFactory
public interface XATopicConnectionFactory
extends XAConnectionFactory, TopicConnectionFactory

An XATopicConnectionFactory provides the same create options as a TopicConnectionFactory (optional).

The XATopicConnectionFactory interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
TopicConnectionFactory, XAConnectionFactory

Method Summary
XATopicConnection | createXATopicConnection() Creates an XA topic connection with the default user identity.
XATopicConnection | createXATopicConnection(String userName, String password) Creates an XA topic connection with the specified user identity.
Methods inherited from interface javax.jms.XAConnectionFactory
createXAConnection, createXAConnection
Methods inherited from interface javax.jms.TopicConnectionFactory
createTopicConnection, createTopicConnection
Methods inherited from interface javax.jms.ConnectionFactory
createConnection, createConnection

Method Detail

createXATopicConnection

public XATopicConnection createXATopicConnection()
                                          throws JMSException
Creates an XA topic connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Returns:
a newly created XA topic connection
Throws:
JMSException - if the JMS provider fails to create an XA topic connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.

createXATopicConnection

public XATopicConnection createXATopicConnection(String userName,
                                                 String password)
                                          throws JMSException
Creates an XA topic connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created XA topic connection
Throws:
JMSException - if the JMS provider fails to create an XA topic connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XATopicSession

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XATopicSession

All Superinterfaces:
Runnable, Session, XASession
public interface XATopicSession
extends XASession

An XATopicSession provides a regular TopicSession. which can be used to create TopicSubscriber and TopicPublisher objects (optional).

The XATopicSession interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than using these XA interfaces directly.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XASession, TopicSession

Field Summary
Fields inherited from interface javax.jms.Session
AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED
Method Summary
 TopicSession getTopicSession()
Gets the topic session associated with this XATopicSession.
Methods inherited from interface javax.jms.XASession
commit, getSession, getTransacted, getXAResource, rollback
Methods inherited from interface javax.jms.Session
close, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createStreamMessage, createTemporaryQueue, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, recover, run, setMessageListener, unsubscribe

Method Detail

getTopicSession

public TopicSession getTopicSession()
                             throws JMSException
Gets the topic session associated with this XATopicSession.

Returns:
the topic session object
Throws:
JMSException - if an internal error occurs.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


mail

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.mail

Classes modeling a mail system.

See:
Description

Interface Summary
MessageAware | An interface optionally implemented by DataSources to supply information to a DataContentHandler about the message context in which the data content object is operating.
MultipartDataSource | MultipartDataSource is a DataSource that contains body parts.
Part | The Part interface is the common base interface for Messages and BodyParts.
UIDFolder | The UIDFolder interface is implemented by Folders that can support the "disconnected" mode of operation, by providing unique-ids for messages in the folder.

Class Summary
Address | This abstract class models the addresses in a message.
Authenticator | The class Authenticator represents an object that knows how to obtain authentication for a network connection.
BodyPart | This class models a Part that is contained within a Multipart.
FetchProfile | Clients use a FetchProfile to list the Message attributes that it wishes to prefetch from the server for a range of messages.
FetchProfile.Item | This inner class is the base class of all items that can be requested in a FetchProfile.
Flags | The Flags class represents the set of flags on a Message.
Flags.Flag | This inner class represents an individual system flag.
Folder | Folder is an abstract class that represents a folder for mail messages.
Header | The Header class stores a name/value pair to represent headers.
Message | This class models an email message.
Message.RecipientType | This inner class defines the types of recipients allowed by the Message class.
MessageContext | The context in which a piece of Message content is contained.
Multipart | Multipart is a container that holds multiple body parts.
PasswordAuthentication | The class PasswordAuthentication is a data holder that is used by Authenticator.
Provider | The Provider is a class that describes a protocol implementation.
Provider.Type | This inner class defines the Provider type.
Service | An abstract class that contains the functionality common to messaging services, such as stores and transports.
Session | The Session class represents a mail session and is not subclassed.
Store | An abstract class that models a message store and its access protocol, for storing and retrieving messages.
Transport | An abstract class that models a message transport.
UIDFolder.FetchProfileItem | A fetch profile item for fetching UIDs.
URLName | The name of a URL.

Exception Summary
AuthenticationFailedException | This exception is thrown when the connect method on a Store or Transport object fails due to an authentication failure (e.g., bad user name or password).
FolderClosedException | This exception is thrown when a method is invoked on a Messaging object and the Folder that owns that object has died due to some reason.
FolderNotFoundException | This exception is thrown by Folder methods, when those methods are invoked on a non existent folder.
IllegalWriteException | The exception thrown when a write is attempted on a read-only attribute of any Messaging object.
MessageRemovedException | The exception thrown when an invalid method is invoked on an expunged Message.
MessagingException | The base class for all exceptions thrown by the Messaging classes
MethodNotSupportedException | The exception thrown when a method is not supported by the implementation
NoSuchProviderException | This exception is thrown when Session attempts to instantiate a Provider that doesn't exist.
ReadOnlyFolderException | This exception is thrown when an attempt is made to open a folder read-write access when the folder is marked read-only.
SendFailedException | This exception is thrown when the message cannot be sent.
StoreClosedException | This exception is thrown when a method is invoked on a Messaging object and the Store that owns that object has died due to some reason.

Package javax.mail Description

Classes modeling a mail system. The javax.mail package defines classes that are common to all mail systems.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.mail Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.mail

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.mail.Address (implements java.io.Serializable)
    • class javax.mail.Authenticator
    • class javax.mail.BodyPart (implements javax.mail.Part)
    • class javax.mail.FetchProfile
    • class javax.mail.FetchProfile.Item
      • class javax.mail.UIDFolder.FetchProfileItem
    • class javax.mail.Flags (implements java.lang.Cloneable, java.io.Serializable)
    • class javax.mail.Flags.Flag
    • class javax.mail.Folder
    • class javax.mail.Header
    • class javax.mail.Message (implements javax.mail.Part)
    • class javax.mail.Message.RecipientType (implements java.io.Serializable)
    • class javax.mail.MessageContext
    • class javax.mail.Multipart
    • class javax.mail.PasswordAuthentication
    • class javax.mail.Provider
    • class javax.mail.Provider.Type
    • class javax.mail.Service
      • class javax.mail.Store
      • class javax.mail.Transport
    • class javax.mail.Session
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.mail.MessagingException
          • class javax.mail.AuthenticationFailedException
          • class javax.mail.FolderClosedException
          • class javax.mail.FolderNotFoundException
          • class javax.mail.IllegalWriteException
          • class javax.mail.MessageRemovedException
          • class javax.mail.MethodNotSupportedException
          • class javax.mail.NoSuchProviderException
          • class javax.mail.ReadOnlyFolderException
          • class javax.mail.SendFailedException
          • class javax.mail.StoreClosedException
    • class javax.mail.URLName

Interface Hierarchy

  • interface javax.activation.DataSource
    • interface javax.mail.MultipartDataSource
  • interface javax.mail.MessageAware
  • interface javax.mail.Part
  • interface javax.mail.UIDFolder
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Address

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Address

java.lang.Object
    extended by javax.mail.Address
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
InternetAddress, NewsAddress
public abstract class Address
extends Object
implements Serializable

This abstract class models the addresses in a message. Subclasses provide specific implementations. Subclasses will typically be serializable so that (for example) the use of Address objects in search terms can be serialized along with the search terms.

Author:
John Mani, Bill Shannon
See Also:
Serialized Form

Constructor Summary
Address()
Method Summary
abstract boolean | equals(Object address) The equality operator.
abstract String | getType() Return a type string that identifies this address type.
abstract String | toString() Return a String representation of this address object.
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Address

public Address()
Method Detail

getType

public abstract String getType()
Return a type string that identifies this address type.

Returns:
address type
See Also:
InternetAddress

toString

public abstract String toString()
Return a String representation of this address object.

Returns:
string representation of this address

equals

public abstract boolean equals(Object address)
The equality operator.

Parameters:
address - Address object
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AuthenticationFailedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class AuthenticationFailedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.AuthenticationFailedException
All Implemented Interfaces:
Serializable
public class AuthenticationFailedException
extends MessagingException

This exception is thrown when the connect method on a Store or Transport object fails due to an authentication failure (e.g., bad user name or password).

Author:
Bill Shannon
See Also:
Serialized Form

Constructor Summary
AuthenticationFailedException()
Constructor
AuthenticationFailedException(String message)
Constructor
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AuthenticationFailedException

public AuthenticationFailedException()
Constructor

AuthenticationFailedException

public AuthenticationFailedException(String message)
Constructor

Parameters:
message - The detailed error message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Authenticator

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Authenticator

java.lang.Object
    extended by javax.mail.Authenticator
public abstract class Authenticator
extends Object

The class Authenticator represents an object that knows how to obtain authentication for a network connection. Usually, it will do this by prompting the user for information.

Applications use this class by creating a subclass, and registering an instance of that subclass with the session when it is created. When authentication is required, the system will invoke a method on the subclass (like getPasswordAuthentication). The subclass's method can query about the authentication being requested with a number of inherited methods (getRequestingXXX()), and form an appropriate message for the user.

All methods that request authentication have a default implementation that fails.

Version:
1.6, 03/27/02
Author:
Bill Foote, Bill Shannon
See Also:
Authenticator, Session.getInstance(java.util.Properties, javax.mail.Authenticator), Session.getDefaultInstance(java.util.Properties, javax.mail.Authenticator), Session.requestPasswordAuthentication(java.net.InetAddress, int, java.lang.String, java.lang.String, java.lang.String), PasswordAuthentication

Constructor Summary
Authenticator()
Method Summary
protected String | getDefaultUserName()
protected PasswordAuthentication | getPasswordAuthentication() Called when password authentication is needed.
protected int | getRequestingPort()
protected String | getRequestingPrompt()
protected String | getRequestingProtocol() Give the protocol that's requesting the connection.
protected InetAddress | getRequestingSite()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Authenticator

public Authenticator()
Method Detail

getRequestingSite

protected final InetAddress getRequestingSite()
Returns:
the InetAddress of the site requesting authorization, or null if it's not available.

getRequestingPort

protected final int getRequestingPort()
Returns:
the port for the requested connection

getRequestingProtocol

protected final String getRequestingProtocol()
Give the protocol that's requesting the connection. Often this will be based on a URLName.

Returns:
the protcol
See Also:
URLName.getProtocol()

getRequestingPrompt

protected final String getRequestingPrompt()
Returns:
the prompt string given by the requestor

getDefaultUserName

protected final String getDefaultUserName()
Returns:
the default user name given by the requestor

getPasswordAuthentication

protected PasswordAuthentication getPasswordAuthentication()
Called when password authentication is needed. Subclasses should override the default implementation, which returns null.

Note that if this method uses a dialog to prompt the user for this information, the dialog needs to block until the user supplies the information. This method can not simply return after showing the dialog.

Returns:
The PasswordAuthentication collected from the user, or null if none is provided.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BodyPart

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class BodyPart

java.lang.Object
    extended by javax.mail.BodyPart
All Implemented Interfaces:
Part
Direct Known Subclasses:
MimeBodyPart
public abstract class BodyPart
extends Object
implements Part

This class models a Part that is contained within a Multipart. This is an abstract class. Subclasses provide actual implementations.

BodyPart implements the Part interface. Thus, it contains a set of attributes and a "content".

Author:
John Mani, Bill Shannon

Field Summary
protected  Multipart parent
The Multipart object containing this BodyPart, if known.
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Constructor Summary
BodyPart()
Method Summary
 Multipart getParent()
Return the containing Multipart object, or null if not known.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.mail.Part
addHeader, getAllHeaders, getContent, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getInputStream, getLineCount, getMatchingHeaders, getNonMatchingHeaders, getSize, isMimeType, removeHeader, setContent, setContent, setDataHandler, setDescription, setDisposition, setFileName, setHeader, setText, writeTo

Field Detail

parent

protected Multipart parent
The Multipart object containing this BodyPart, if known.

Since:
JavaMail 1.1
Constructor Detail

BodyPart

public BodyPart()
Method Detail

getParent

public Multipart getParent()
Return the containing Multipart object, or null if not known.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


event

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.mail.event

Listeners and events for the JavaMail API.

See:
Description

Interface Summary
ConnectionListener | This is the Listener interface for Connection events.
FolderListener | This is the Listener interface for Folder events.
MessageChangedListener | This is the Listener interface for MessageChanged events
MessageCountListener | This is the Listener interface for MessageCount events.
StoreListener | This is the Listener interface for Store Notifications.
TransportListener | This is the Listener interface for Transport events

Class Summary
ConnectionAdapter | The adapter which receives connection events.
ConnectionEvent | This class models Connection events.
FolderAdapter | The adapter which receives Folder events.
FolderEvent | This class models Folder existence events.
MailEvent | Common base class for mail events, defining the dispatch method.
MessageChangedEvent | This class models Message change events.
MessageCountAdapter | The adapter which receives MessageCount events.
MessageCountEvent | This class notifies changes in the number of messages in a folder.
StoreEvent | This class models notifications from the Store connection.
TransportAdapter | The adapter which receives Transport events.
TransportEvent | This class models Transport events.

Package javax.mail.event Description

Listeners and events for the JavaMail API. This package defines listener classes and event classes used by the classes defined in the javax.mail package.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.mail.event Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.mail.event

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.mail.event.ConnectionAdapter (implements javax.mail.event.ConnectionListener)
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.mail.event.MailEvent
        • class javax.mail.event.ConnectionEvent
        • class javax.mail.event.FolderEvent
        • class javax.mail.event.MessageChangedEvent
        • class javax.mail.event.MessageCountEvent
        • class javax.mail.event.StoreEvent
        • class javax.mail.event.TransportEvent
    • class javax.mail.event.FolderAdapter (implements javax.mail.event.FolderListener)
    • class javax.mail.event.MessageCountAdapter (implements javax.mail.event.MessageCountListener)
    • class javax.mail.event.TransportAdapter (implements javax.mail.event.TransportListener)

Interface Hierarchy

  • interface java.util.EventListener
    • interface javax.mail.event.ConnectionListener
    • interface javax.mail.event.FolderListener
    • interface javax.mail.event.MessageChangedListener
    • interface javax.mail.event.MessageCountListener
    • interface javax.mail.event.StoreListener
    • interface javax.mail.event.TransportListener
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionAdapter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class ConnectionAdapter

java.lang.Object
    extended by javax.mail.event.ConnectionAdapter
All Implemented Interfaces:
ConnectionListener, EventListener
public abstract class ConnectionAdapter
extends Object
implements ConnectionListener

The adapter which receives connection events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.

Author:
John Mani

Constructor Summary
ConnectionAdapter()
Method Summary
void | closed(ConnectionEvent e) Invoked when a Store/Folder/Transport is closed.
void | disconnected(ConnectionEvent e) Invoked when a Store is disconnected.
void | opened(ConnectionEvent e) Invoked when a Store/Folder/Transport is opened.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConnectionAdapter

public ConnectionAdapter()
Method Detail

opened

public void opened(ConnectionEvent e)
Description copied from interface: ConnectionListener
Invoked when a Store/Folder/Transport is opened.

Specified by:
opened in interface ConnectionListener

disconnected

public void disconnected(ConnectionEvent e)
Description copied from interface: ConnectionListener
Invoked when a Store is disconnected. Note that a folder cannot be disconnected, so a folder will not fire this event

Specified by:
disconnected in interface ConnectionListener

closed

public void closed(ConnectionEvent e)
Description copied from interface: ConnectionListener
Invoked when a Store/Folder/Transport is closed.

Specified by:
closed in interface ConnectionListener
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class ConnectionEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.mail.event.MailEvent
            extended by javax.mail.event.ConnectionEvent
All Implemented Interfaces:
Serializable
public class ConnectionEvent
extends MailEvent

This class models Connection events.

Author:
John Mani
See Also:
Serialized Form

Field Summary
static int | CLOSED A connection was closed.
static int | DISCONNECTED A connection was disconnected (not currently used).
static int | OPENED A connection was opened.
protected int | type The event type.
Fields inherited from class java.util.EventObject
source
Constructor Summary
ConnectionEvent(Object source, int type)
Constructor
Method Summary
void | dispatch(Object listener) Invokes the appropriate ConnectionListener method
int | getType() Return the type of this event
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

OPENED

public static final int OPENED
A connection was opened.

See Also:
Constant Field Values

DISCONNECTED

public static final int DISCONNECTED
A connection was disconnected (not currently used).

See Also:
Constant Field Values

CLOSED

public static final int CLOSED
A connection was closed.

See Also:
Constant Field Values

type

protected int type
The event type.

Constructor Detail

ConnectionEvent

public ConnectionEvent(Object source,
                       int type)
Constructor

Parameters:
source - The source object
Method Detail

getType

public int getType()
Return the type of this event

Returns:
type

dispatch

public void dispatch(Object listener)
Invokes the appropriate ConnectionListener method

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface ConnectionListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
ConnectionAdapter
public interface ConnectionListener
extends EventListener

This is the Listener interface for Connection events.

Author:
John Mani

Method Summary
void | closed(ConnectionEvent e) Invoked when a Store/Folder/Transport is closed.
void | disconnected(ConnectionEvent e) Invoked when a Store is disconnected.
void | opened(ConnectionEvent e) Invoked when a Store/Folder/Transport is opened.

Method Detail

opened

public void opened(ConnectionEvent e)
Invoked when a Store/Folder/Transport is opened.

disconnected

public void disconnected(ConnectionEvent e)
Invoked when a Store is disconnected. Note that a folder cannot be disconnected, so a folder will not fire this event

closed

public void closed(ConnectionEvent e)
Invoked when a Store/Folder/Transport is closed.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FolderAdapter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class FolderAdapter

java.lang.Object
    extended by javax.mail.event.FolderAdapter
All Implemented Interfaces:
EventListener, FolderListener
public abstract class FolderAdapter
extends Object
implements FolderListener

The adapter which receives Folder events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.

Author:
John Mani

Constructor Summary
FolderAdapter()
Method Summary
void | folderCreated(FolderEvent e) Invoked when a Folder is created.
void | folderDeleted(FolderEvent e) Invoked when a folder is deleted.
void | folderRenamed(FolderEvent e) Invoked when a folder is renamed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FolderAdapter

public FolderAdapter()
Method Detail

folderCreated

public void folderCreated(FolderEvent e)
Description copied from interface: FolderListener
Invoked when a Folder is created.

Specified by:
folderCreated in interface FolderListener

folderRenamed

public void folderRenamed(FolderEvent e)
Description copied from interface: FolderListener
Invoked when a folder is renamed.

Specified by:
folderRenamed in interface FolderListener

folderDeleted

public void folderDeleted(FolderEvent e)
Description copied from interface: FolderListener
Invoked when a folder is deleted.

Specified by:
folderDeleted in interface FolderListener
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FolderEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class FolderEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.mail.event.MailEvent
            extended by javax.mail.event.FolderEvent
All Implemented Interfaces:
Serializable
public class FolderEvent
extends MailEvent

This class models Folder existence events. FolderEvents are delivered to FolderListeners registered on the affected Folder as well as the containing Store.

Service providers vary widely in their ability to notify clients of these events. At a minimum, service providers must notify listeners registered on the same Store or Folder object on which the operation occurs. Service providers may also notify listeners when changes are made through operations on other objects in the same virtual machine, or by other clients in the same or other hosts. Such notifications are not required and are typically not supported by mail protocols (including IMAP).

Author:
John Mani, Bill Shannon
See Also:
Serialized Form

Field Summary
static int | CREATED The folder was created.
static int | DELETED The folder was deleted.
protected Folder | folder The folder the event occurred on.
protected Folder | newFolder The folder that represents the new name, in case of a RENAMED event.
static int | RENAMED The folder was renamed.
protected int | type The event type.
Fields inherited from class java.util.EventObject
source
Constructor Summary
FolderEvent(Object source, Folder oldFolder, Folder newFolder, int type)
Constructor.
FolderEvent(Object source, Folder folder, int type)
Constructor.
Method Summary
void | dispatch(Object listener) Invokes the appropriate FolderListener method
Folder | getFolder() Return the affected folder.
Folder | getNewFolder() If this event indicates that a folder is renamed, (i.e, the event type is RENAMED), then this method returns the Folder object representing the new name.
int | getType() Return the type of this event.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

CREATED

public static final int CREATED
The folder was created.

See Also:
Constant Field Values

DELETED

public static final int DELETED
The folder was deleted.

See Also:
Constant Field Values

RENAMED

public static final int RENAMED
The folder was renamed.

See Also:
Constant Field Values

type

protected int type
The event type.

folder

protected transient Folder folder
The folder the event occurred on.

newFolder

protected transient Folder newFolder
The folder that represents the new name, in case of a RENAMED event.

Since:
JavaMail 1.1
Constructor Detail

FolderEvent

public FolderEvent(Object source,
                   Folder folder,
                   int type)
Constructor.

Parameters:
source - The source of the event
folder - The affected folder
type - The event type

FolderEvent

public FolderEvent(Object source,
                   Folder oldFolder,
                   Folder newFolder,
                   int type)
Constructor. Use for RENAMED events.

Parameters:
source - The source of the event
oldFolder - The folder that is renamed
newFolder - The folder that represents the new name
type - The event type
Since:
JavaMail 1.1
Method Detail

getType

public int getType()
Return the type of this event.

Returns:
type

getFolder

public Folder getFolder()
Return the affected folder.

Returns:
the affected folder
See Also:
getNewFolder()

getNewFolder

public Folder getNewFolder()
If this event indicates that a folder is renamed, (i.e, the event type is RENAMED), then this method returns the Folder object representing the new name.

The getFolder() method returns the folder that is renamed.

Returns:
Folder representing the new name.
Since:
JavaMail 1.1
See Also:
getFolder()

dispatch

public void dispatch(Object listener)
Invokes the appropriate FolderListener method

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FolderListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface FolderListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
FolderAdapter
public interface FolderListener
extends EventListener

This is the Listener interface for Folder events.

Author:
John Mani

Method Summary
void | folderCreated(FolderEvent e) Invoked when a Folder is created.
void | folderDeleted(FolderEvent e) Invoked when a folder is deleted.
void | folderRenamed(FolderEvent e) Invoked when a folder is renamed.

Method Detail

folderCreated

public void folderCreated(FolderEvent e)
Invoked when a Folder is created.

folderDeleted

public void folderDeleted(FolderEvent e)
Invoked when a folder is deleted.

folderRenamed

public void folderRenamed(FolderEvent e)
Invoked when a folder is renamed.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MailEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class MailEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.mail.event.MailEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ConnectionEvent, FolderEvent, MessageChangedEvent, MessageCountEvent, StoreEvent, TransportEvent
public abstract class MailEvent
extends EventObject

Common base class for mail events, defining the dispatch method.

Author:
Bill Shannon
See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
MailEvent(Object source)
Method Summary
abstract  void dispatch(Object listener)
This method invokes the appropriate method on a listener for this event.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MailEvent

public MailEvent(Object source)
Method Detail

dispatch

public abstract void dispatch(Object listener)
This method invokes the appropriate method on a listener for this event. Subclasses provide the implementation.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageChangedEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class MessageChangedEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.mail.event.MailEvent
            extended by javax.mail.event.MessageChangedEvent
All Implemented Interfaces:
Serializable
public class MessageChangedEvent
extends MailEvent

This class models Message change events.

Author:
John Mani
See Also:
Serialized Form

Field Summary
static int | ENVELOPE_CHANGED The message's envelope (headers, but not body) changed.
static int | FLAGS_CHANGED The message's flags changed.
protected Message | msg The message that changed.
protected int | type The event type.
Fields inherited from class java.util.EventObject
source
Constructor Summary
MessageChangedEvent(Object source, int type, Message msg)
Constructor.
Method Summary
void | dispatch(Object listener) Invokes the appropriate MessageChangedListener method.
Message | getMessage() Return the changed Message.
int | getMessageChangeType() Return the type of this event.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

FLAGS_CHANGED

public static final int FLAGS_CHANGED
The message's flags changed.

See Also:
Constant Field Values

ENVELOPE_CHANGED

public static final int ENVELOPE_CHANGED
The message's envelope (headers, but not body) changed.

See Also:
Constant Field Values

type

protected int type
The event type.

msg

protected transient Message msg
The message that changed.

Constructor Detail

MessageChangedEvent

public MessageChangedEvent(Object source,
                           int type,
                           Message msg)
Constructor.

Parameters:
source - The folder that owns the message
type - The change type
msg - The changed message
Method Detail

getMessageChangeType

public int getMessageChangeType()
Return the type of this event.

Returns:
type

getMessage

public Message getMessage()
Return the changed Message.

Returns:
the message

dispatch

public void dispatch(Object listener)
Invokes the appropriate MessageChangedListener method.

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageChangedListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface MessageChangedListener

All Superinterfaces:
EventListener
public interface MessageChangedListener
extends EventListener

This is the Listener interface for MessageChanged events

Author:
John Mani

Method Summary
 void messageChanged(MessageChangedEvent e)
Invoked when a message is changed.

Method Detail

messageChanged

public void messageChanged(MessageChangedEvent e)
Invoked when a message is changed. The change-type specifies what changed.

See Also:
MessageChangedEvent.FLAGS_CHANGED, MessageChangedEvent.ENVELOPE_CHANGED
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageCountAdapter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class MessageCountAdapter

java.lang.Object
    extended by javax.mail.event.MessageCountAdapter
All Implemented Interfaces:
EventListener, MessageCountListener
public abstract class MessageCountAdapter
extends Object
implements MessageCountListener

The adapter which receives MessageCount events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.

Author:
John Mani

Constructor Summary
MessageCountAdapter()
Method Summary
void | messagesAdded(MessageCountEvent e) Invoked when messages are added into a folder.
void | messagesRemoved(MessageCountEvent e) Invoked when messages are removed (expunged) from a folder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageCountAdapter

public MessageCountAdapter()
Method Detail

messagesAdded

public void messagesAdded(MessageCountEvent e)
Description copied from interface: MessageCountListener
Invoked when messages are added into a folder.

Specified by:
messagesAdded in interface MessageCountListener

messagesRemoved

public void messagesRemoved(MessageCountEvent e)
Description copied from interface: MessageCountListener
Invoked when messages are removed (expunged) from a folder.

Specified by:
messagesRemoved in interface MessageCountListener
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageCountEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class MessageCountEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.mail.event.MailEvent
            extended by javax.mail.event.MessageCountEvent
All Implemented Interfaces:
Serializable
public class MessageCountEvent
extends MailEvent

This class notifies changes in the number of messages in a folder.

Note that some folder types may only deliver MessageCountEvents at certain times or after certain operations. IMAP in particular will only notify the client of MessageCountEvents when a client issues a new command. Refer to RFC 2060 http://www.ietf.org/rfc/rfc2060.txt for details. A client may want "poll" the folder by occasionally calling the getMessageCount or isConnected methods to solicit any such notifications.

Author:
John Mani
See Also:
Serialized Form

Field Summary
static int | ADDED The messages were added to their folder
protected Message[] | msgs The messages.
protected boolean | removed If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this.
static int | REMOVED The messages were removed from their folder
protected int | type The event type.
Fields inherited from class java.util.EventObject
source
Constructor Summary
MessageCountEvent(Folder folder, int type, boolean removed, Message[] msgs)
Constructor.
Method Summary
void | dispatch(Object listener) Invokes the appropriate MessageCountListener method.
Message[] | getMessages() Return the array of messages added or removed.
int | getType() Return the type of this event.
boolean | isRemoved() Indicates whether this event is the result of an explicit expunge by this client, or due to an expunge from external sources.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ADDED

public static final int ADDED
The messages were added to their folder

See Also:
Constant Field Values

REMOVED

public static final int REMOVED
The messages were removed from their folder

See Also:
Constant Field Values

type

protected int type
The event type.

removed

protected boolean removed
If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this. If false, this event is the result of an expunge by external sources.

msgs

protected transient Message[] msgs
The messages.

Constructor Detail

MessageCountEvent

public MessageCountEvent(Folder folder,
                         int type,
                         boolean removed,
                         Message[] msgs)
Constructor.

Parameters:
folder - The containing folder
type - The event type
removed - If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this. If false, this event is the result of an expunge by external sources.
msgs - The messages added/removed
Method Detail

getType

public int getType()
Return the type of this event.

Returns:
type

isRemoved

public boolean isRemoved()
Indicates whether this event is the result of an explicit expunge by this client, or due to an expunge from external sources. If true, this event is due to an explicit expunge and hence all remaining messages in this folder have been renumbered. If false, this event is due to an external expunge.

Note that this method is valid only if the type of this event is REMOVED

getMessages

public Message[] getMessages()
Return the array of messages added or removed.

Returns:
array of messages

dispatch

public void dispatch(Object listener)
Invokes the appropriate MessageCountListener method.

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageCountListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface MessageCountListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
MessageCountAdapter
public interface MessageCountListener
extends EventListener

This is the Listener interface for MessageCount events.

Author:
John Mani

Method Summary
void | messagesAdded(MessageCountEvent e) Invoked when messages are added into a folder.
void | messagesRemoved(MessageCountEvent e) Invoked when messages are removed (expunged) from a folder.

Method Detail

messagesAdded

public void messagesAdded(MessageCountEvent e)
Invoked when messages are added into a folder.

messagesRemoved

public void messagesRemoved(MessageCountEvent e)
Invoked when messages are removed (expunged) from a folder.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StoreEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class StoreEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.mail.event.MailEvent
            extended by javax.mail.event.StoreEvent
All Implemented Interfaces:
Serializable
public class StoreEvent
extends MailEvent

This class models notifications from the Store connection. These notifications can be ALERTS or NOTICES. ALERTS must be presented to the user in a fashion that calls the user's attention to the message.

Author:
John Mani
See Also:
Serialized Form

Field Summary
static int | ALERT Indicates that this message is an ALERT.
protected String | message The message text to be presented to the user.
static int | NOTICE Indicates that this message is a NOTICE.
protected int | type The event type.
Fields inherited from class java.util.EventObject
source
Constructor Summary
StoreEvent(Store store, int type, String message)
Constructor.
Method Summary
void | dispatch(Object listener) Invokes the appropriate StoreListener method.
String | getMessage() Get the message from the Store.
int | getMessageType() Return the type of this event.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ALERT

public static final int ALERT
Indicates that this message is an ALERT.

See Also:
Constant Field Values

NOTICE

public static final int NOTICE
Indicates that this message is a NOTICE.

See Also:
Constant Field Values

type

protected int type
The event type.

message

protected String message
The message text to be presented to the user.

Constructor Detail

StoreEvent

public StoreEvent(Store store,
                  int type,
                  String message)
Constructor.

Parameters:
store - The source Store
Method Detail

getMessageType

public int getMessageType()
Return the type of this event.

Returns:
type
See Also:
ALERT, NOTICE

getMessage

public String getMessage()
Get the message from the Store.

Returns:
message from the Store

dispatch

public void dispatch(Object listener)
Invokes the appropriate StoreListener method.

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StoreListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface StoreListener

All Superinterfaces:
EventListener
public interface StoreListener
extends EventListener

This is the Listener interface for Store Notifications.

Author:
John Mani

Method Summary
 void notification(StoreEvent e)
Invoked when the Store generates a notification event.

Method Detail

notification

public void notification(StoreEvent e)
Invoked when the Store generates a notification event.

See Also:
StoreEvent.ALERT, StoreEvent.NOTICE
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransportAdapter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class TransportAdapter

java.lang.Object
    extended by javax.mail.event.TransportAdapter
All Implemented Interfaces:
EventListener, TransportListener
public abstract class TransportAdapter
extends Object
implements TransportListener

The adapter which receives Transport events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.

Author:
John Mani

Constructor Summary
TransportAdapter()
Method Summary
void | messageDelivered(TransportEvent e) Invoked when a Message is succesfully delivered.
void | messageNotDelivered(TransportEvent e) Invoked when a Message is not delivered.
void | messagePartiallyDelivered(TransportEvent e) Invoked when a Message is partially delivered.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TransportAdapter

public TransportAdapter()
Method Detail

messageDelivered

public void messageDelivered(TransportEvent e)
Description copied from interface: TransportListener
Invoked when a Message is succesfully delivered.

Specified by:
messageDelivered in interface TransportListener
Parameters:
e - TransportEvent

messageNotDelivered

public void messageNotDelivered(TransportEvent e)
Description copied from interface: TransportListener
Invoked when a Message is not delivered.

Specified by:
messageNotDelivered in interface TransportListener
Parameters:
e - TransportEvent
See Also:
TransportEvent

messagePartiallyDelivered

public void messagePartiallyDelivered(TransportEvent e)
Description copied from interface: TransportListener
Invoked when a Message is partially delivered.

Specified by:
messagePartiallyDelivered in interface TransportListener
Parameters:
e - TransportEvent
See Also:
TransportEvent
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransportEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class TransportEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.mail.event.MailEvent
            extended by javax.mail.event.TransportEvent
All Implemented Interfaces:
Serializable
public class TransportEvent
extends MailEvent

This class models Transport events.

Author:
John Mani, Max Spivak
See Also:
Transport, TransportListener, Serialized Form

Field Summary
protected Address[] | invalid
static int | MESSAGE_DELIVERED Message has been successfully delivered to all recipients by the transport firing this event. validSent[] contains all the addresses this transport sent to successfully. validUnsent[] and invalid[] should be null,
static int | MESSAGE_NOT_DELIVERED Message was not sent for some reason. validSent[] should be null.
static int | MESSAGE_PARTIALLY_DELIVERED Message was successfully sent to some recipients but not to all.
protected Message | msg
protected int | type The event type.
protected Address[] | validSent
protected Address[] | validUnsent
Fields inherited from class java.util.EventObject
source
Constructor Summary
TransportEvent(Transport transport, int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
Constructor.
Method Summary
void | dispatch(Object listener) Invokes the appropriate TransportListener method.
Address[] | getInvalidAddresses() Return the addresses to which this message could not be sent.
Message | getMessage() Get the Message object associated with this Transport Event.
int | getType() Return the type of this event.
Address[] | getValidSentAddresses() Return the addresses to which this message was sent succesfully.
Address[] | getValidUnsentAddresses() Return the addresses that are valid but to which this message was not sent.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

MESSAGE_DELIVERED

public static final int MESSAGE_DELIVERED
Message has been successfully delivered to all recipients by the transport firing this event. validSent[] contains all the addresses this transport sent to successfully. validUnsent[] and invalid[] should be null,

See Also:
Constant Field Values

MESSAGE_NOT_DELIVERED

public static final int MESSAGE_NOT_DELIVERED
Message was not sent for some reason. validSent[] should be null. validUnsent[] may have addresses that are valid (but the message wasn't sent to them). invalid[] should likely contain invalid addresses.

See Also:
Constant Field Values

MESSAGE_PARTIALLY_DELIVERED

public static final int MESSAGE_PARTIALLY_DELIVERED
Message was successfully sent to some recipients but not to all. validSent[] holds addresses of recipients to whom the message was sent. validUnsent[] holds valid addresses to which the message was not sent. invalid[] holds invalid addresses, if any.

See Also:
Constant Field Values

type

protected int type
The event type.

validSent

protected transient Address[] validSent

validUnsent

protected transient Address[] validUnsent

invalid

protected transient Address[] invalid

msg

protected transient Message msg
Constructor Detail

TransportEvent

public TransportEvent(Transport transport,
                      int type,
                      Address[] validSent,
                      Address[] validUnsent,
                      Address[] invalid,
                      Message msg)
Constructor.

Parameters:
transport - The Transport object
Method Detail

getType

public int getType()
Return the type of this event.

Returns:
type

getValidSentAddresses

public Address[] getValidSentAddresses()
Return the addresses to which this message was sent succesfully.

Returns:
Addresses to which the message was sent successfully or null

getValidUnsentAddresses

public Address[] getValidUnsentAddresses()
Return the addresses that are valid but to which this message was not sent.

Returns:
Addresses that are valid but to which the message was not sent successfully or null

getInvalidAddresses

public Address[] getInvalidAddresses()
Return the addresses to which this message could not be sent.

Returns:
Addresses to which the message sending failed or null

getMessage

public Message getMessage()
Get the Message object associated with this Transport Event.

Returns:
the Message object
Since:
JavaMail 1.2

dispatch

public void dispatch(Object listener)
Invokes the appropriate TransportListener method.

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransportListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface TransportListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
TransportAdapter
public interface TransportListener
extends EventListener

This is the Listener interface for Transport events

Author:
John Mani, Max Spivak
See Also:
Transport, TransportEvent

Method Summary
void | messageDelivered(TransportEvent e) Invoked when a Message is succesfully delivered.
void | messageNotDelivered(TransportEvent e) Invoked when a Message is not delivered.
void | messagePartiallyDelivered(TransportEvent e) Invoked when a Message is partially delivered.

Method Detail

messageDelivered

public void messageDelivered(TransportEvent e)
Invoked when a Message is succesfully delivered.

Parameters:
e - TransportEvent

messageNotDelivered

public void messageNotDelivered(TransportEvent e)
Invoked when a Message is not delivered.

Parameters:
e - TransportEvent
See Also:
TransportEvent

messagePartiallyDelivered

public void messagePartiallyDelivered(TransportEvent e)
Invoked when a Message is partially delivered.

Parameters:
e - TransportEvent
See Also:
TransportEvent
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FetchProfile

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class FetchProfile

java.lang.Object
    extended by javax.mail.FetchProfile
public class FetchProfile
extends Object

Clients use a FetchProfile to list the Message attributes that it wishes to prefetch from the server for a range of messages.

Messages obtained from a Folder are light-weight objects that typically start off as empty references to the actual messages. Such a Message object is filled in "on-demand" when the appropriate get*() methods are invoked on that particular Message. Certain server-based message access protocols (Ex: IMAP) allow batch fetching of message attributes for a range of messages in a single request. Clients that want to use message attributes for a range of Messages (Example: to display the top-level headers in a headerlist) might want to use the optimization provided by such servers. The FetchProfile allows the client to indicate this desire to the server.

Note that implementations are not obligated to support FetchProfiles, since there might be cases where the backend service does not allow easy, efficient fetching of such profiles.

Sample code that illustrates the use of a FetchProfile is given below:

  Message[] msgs = folder.getMessages();

  FetchProfile fp = new FetchProfile();
  fp.add(FetchProfile.Item.ENVELOPE);
  fp.add("X-mailer");
  folder.fetch(msgs, fp);

Author:
John Mani, Bill Shannon
See Also:
Folder.fetch(javax.mail.Message[], javax.mail.FetchProfile)

Nested Class Summary
static class FetchProfile.Item
This inner class is the base class of all items that can be requested in a FetchProfile.
Constructor Summary
FetchProfile()
Create an empty FetchProfile.
Method Summary
void | add(FetchProfile.Item item) Add the given special item as one of the attributes to be prefetched.
void | add(String headerName) Add the specified header-field to the list of attributes to be prefetched.
boolean | contains(FetchProfile.Item item) Returns true if the fetch profile contains given special item.
boolean | contains(String headerName) Returns true if the fetch profile contains given header name.
String[] | getHeaderNames() Get the names of the header-fields set in this profile.
FetchProfile.Item[] | getItems() Get the items set in this profile.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FetchProfile

public FetchProfile()
Create an empty FetchProfile.

Method Detail

add

public void add(FetchProfile.Item item)
Add the given special item as one of the attributes to be prefetched.

Parameters:
item - the special item to be fetched
See Also:
FetchProfile.Item.ENVELOPE, FetchProfile.Item.CONTENT_INFO, FetchProfile.Item.FLAGS

add

public void add(String headerName)
Add the specified header-field to the list of attributes to be prefetched.

Parameters:
headerName - header to be prefetched

contains

public boolean contains(FetchProfile.Item item)
Returns true if the fetch profile contains given special item.

contains

public boolean contains(String headerName)
Returns true if the fetch profile contains given header name.

getItems

public FetchProfile.Item[] getItems()
Get the items set in this profile.

Returns:
items set in this profile

getHeaderNames

public String[] getHeaderNames()
Get the names of the header-fields set in this profile.

Returns:
headers set in this profile
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FetchProfile.Item

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class FetchProfile.Item

java.lang.Object
    extended by javax.mail.FetchProfile.Item
Direct Known Subclasses:
UIDFolder.FetchProfileItem
Enclosing class:
FetchProfile
public static class FetchProfile.Item
extends Object

This inner class is the base class of all items that can be requested in a FetchProfile. The items currently defined here are ENVELOPE, CONTENT_INFO and FLAGS. The UIDFolder interface defines the UID Item as well.

Note that this class only has a protected constructor, therby restricting new Item types to either this class or subclasses. This effectively implements a enumeration of allowed Item types.

See Also:
UIDFolder

Field Summary
static FetchProfile.Item | CONTENT_INFO This item is for fetching information about the content of the message.
static FetchProfile.Item | ENVELOPE This is the Envelope item.
static FetchProfile.Item | FLAGS This is the Flags item.
Constructor Summary
protected FetchProfile.Item(String name)
Constructor for an item.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ENVELOPE

public static final FetchProfile.Item ENVELOPE
This is the Envelope item.

The Envelope is an aggregration of the common attributes of a Message. Implementations should include the following attributes: From, To, Cc, Bcc, ReplyTo, Subject and Date. More items may be included as well.

For implementations of the IMAP4 protocol (RFC 2060), the Envelope should include the ENVELOPE data item. More items may be included too.

CONTENT_INFO

public static final FetchProfile.Item CONTENT_INFO
This item is for fetching information about the content of the message.

This includes all the attributes that describe the content of the message. Implementations should include the following attributes: ContentType, ContentDisposition, ContentDescription, Size and LineCount. Other items may be included as well.

FLAGS

public static final FetchProfile.Item FLAGS
This is the Flags item.

Constructor Detail

FetchProfile.Item

protected FetchProfile.Item(String name)
Constructor for an item. The name is used only for debugging.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Flags

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Flags

java.lang.Object
    extended by javax.mail.Flags
All Implemented Interfaces:
Cloneable, Serializable
public class Flags
extends Object
implements Cloneable, Serializable

The Flags class represents the set of flags on a Message. Flags are composed of predefined system flags, and user defined flags.

A System flag is represented by the Flags.Flag inner class. A User defined flag is represented as a String. User flags are case-independent.

A set of standard system flags are predefined. Most folder implementations are expected to support these flags. Some implementations may also support arbitrary user-defined flags. The getPermanentFlags method on a Folder returns a Flags object that holds all the flags that are supported by that folder implementation.

A Flags object is serializable so that (for example) the use of Flags objects in search terms can be serialized along with the search terms.

Warning: Serialized objects of this class may not be compatible with future JavaMail API releases. The current serialization support is appropriate for short term storage.

The below code sample illustrates how to set, examine and get the flags for a message.

 Message m = folder.getMessage(1);
 m.setFlag(Flags.Flag.DELETED, true); // set the DELETED flag

 // Check if DELETED flag is set of this message
 if (m.isSet(Flags.Flag.DELETED))
    System.out.println("DELETED message");

 // Examine ALL system flags for this message
 Flags flags = m.getFlags();
 Flags.Flag[] sf = flags.getSystemFlags();
 for (int i = 0; i < sf.length; i++) {
    if (sf[i] == Flags.Flag.DELETED)
            System.out.println("DELETED message");
    else if (sf[i] == Flags.Flag.SEEN)
            System.out.println("SEEN message");
      ......
      ......
 }

Author:
John Mani, Bill Shannon
See Also:
Folder.getPermanentFlags(), Serialized Form

Nested Class Summary
static class Flags.Flag
This inner class represents an individual system flag.
Constructor Summary
Flags()
Construct an empty Flags object.
Flags(Flags.Flag flag)
Construct a Flags object initialized with the given system flag.
Flags(Flags flags)
Construct a Flags object initialized with the given flags.
Flags(String flag)
Construct a Flags object initialized with the given user flag.
Method Summary
void | add(Flags.Flag flag) Add the specified system flag to this Flags object.
void | add(Flags f) Add all the flags in the given Flags object to this Flags object.
void | add(String flag) Add the specified user flag to this Flags object.
Object | clone() Returns a clone of this Flags object.
boolean | contains(Flags.Flag flag) Check whether the specified system flag is present in this Flags object.
boolean | contains(Flags f) Check whether all the flags in the specified Flags object are present in this Flags object.
boolean | contains(String flag) Check whether the specified user flag is present in this Flags object.
boolean | equals(Object obj) Check whether the two Flags objects are equal.
Flags.Flag[] | getSystemFlags() Return all the system flags in this Flags object.
String[] | getUserFlags() Return all the user flags in this Flags object.
int | hashCode() Compute a hash code for this Flags object.
void | remove(Flags.Flag flag) Remove the specified system flag from this Flags object.
void | remove(Flags f) Remove all flags in the given Flags object from this Flags object.
void | remove(String flag) Remove the specified user flag from this Flags object.
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Flags

public Flags()
Construct an empty Flags object.

Flags

public Flags(Flags flags)
Construct a Flags object initialized with the given flags.

Parameters:
flags - the flags for initialization

Flags

public Flags(Flags.Flag flag)
Construct a Flags object initialized with the given system flag.

Parameters:
flag - the flag for initialization

Flags

public Flags(String flag)
Construct a Flags object initialized with the given user flag.

Parameters:
flag - the flag for initialization
Method Detail

add

public void add(Flags.Flag flag)
Add the specified system flag to this Flags object.

Parameters:
flag - the flag to add

add

public void add(String flag)
Add the specified user flag to this Flags object.

Parameters:
flag - the flag to add

add

public void add(Flags f)
Add all the flags in the given Flags object to this Flags object.

Parameters:
f - Flags object

remove

public void remove(Flags.Flag flag)
Remove the specified system flag from this Flags object.

Parameters:
flag - the flag to be removed

remove

public void remove(String flag)
Remove the specified user flag from this Flags object.

Parameters:
flag - the flag to be removed

remove

public void remove(Flags f)
Remove all flags in the given Flags object from this Flags object.

Parameters:
f - the flag to be removed

contains

public boolean contains(Flags.Flag flag)
Check whether the specified system flag is present in this Flags object.

Returns:
true of the given flag is present, otherwise false.

contains

public boolean contains(String flag)
Check whether the specified user flag is present in this Flags object.

Returns:
true of the given flag is present, otherwise false.

contains

public boolean contains(Flags f)
Check whether all the flags in the specified Flags object are present in this Flags object.

Returns:
true if all flags in the given Flags object are present, otherwise false.

equals

public boolean equals(Object obj)
Check whether the two Flags objects are equal.

Returns:
true if they're equal

hashCode

public int hashCode()
Compute a hash code for this Flags object.

Returns:
the hash code

getSystemFlags

public Flags.Flag[] getSystemFlags()
Return all the system flags in this Flags object. Returns an array of size zero if no flags are set.

Returns:
array of Flags.Flag objects representing system flags

getUserFlags

public String[] getUserFlags()
Return all the user flags in this Flags object. Returns an array of size zero if no flags are set.

Returns:
array of Strings, each String represents a flag.

clone

public Object clone()
Returns a clone of this Flags object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Flags.Flag

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Flags.Flag

java.lang.Object
    extended by javax.mail.Flags.Flag
Enclosing class:
Flags
public static final class Flags.Flag
extends Object

This inner class represents an individual system flag. A set of standard system flag objects are predefined here.

Field Summary
static Flags.Flag | ANSWERED This message has been answered.
static Flags.Flag | DELETED This message is marked deleted.
static Flags.Flag | DRAFT This message is a draft.
static Flags.Flag | FLAGGED This message is flagged.
static Flags.Flag | RECENT This message is recent.
static Flags.Flag | SEEN This message is seen.
static Flags.Flag | USER A special flag that indicates that this folder supports user defined flags.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ANSWERED

public static final Flags.Flag ANSWERED
This message has been answered. This flag is set by clients to indicate that this message has been answered to.

DELETED

public static final Flags.Flag DELETED
This message is marked deleted. Clients set this flag to mark a message as deleted. The expunge operation on a folder removes all messages in that folder that are marked for deletion.

DRAFT

public static final Flags.Flag DRAFT
This message is a draft. This flag is set by clients to indicate that the message is a draft message.

FLAGGED

public static final Flags.Flag FLAGGED
This message is flagged. No semantic is defined for this flag. Clients alter this flag.

RECENT

public static final Flags.Flag RECENT
This message is recent. Folder implementations set this flag to indicate that this message is new to this folder, that is, it has arrived since the last time this folder was opened.

Clients cannot alter this flag.

SEEN

public static final Flags.Flag SEEN
This message is seen. This flag is implicitly set by the implementation when the this Message's content is returned to the client in some form. The getInputStream and getContent methods on Message cause this flag to be set.

Clients can alter this flag.

USER

public static final Flags.Flag USER
A special flag that indicates that this folder supports user defined flags.

The implementation sets this flag. Clients cannot alter this flag but can use it to determine if a folder supports user defined flags by using folder.getPermanentFlags().contains(Flags.Flag.USER).

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Folder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Folder

java.lang.Object
    extended by javax.mail.Folder
public abstract class Folder
extends Object

Folder is an abstract class that represents a folder for mail messages. Subclasses implement protocol specific Folders.

Folders can contain Messages, other Folders or both, thus providing a tree-like hierarchy rooted at the Store's default folder. (Note that some Folder implementations may not allow both Messages and other Folders in the same Folder).

The interpretation of folder names is implementation dependent. The different levels of hierarchy in a folder's full name are separated from each other by the hierarchy delimiter character.

The case-insensitive full folder name (that is, the full name relative to the default folder for a Store) INBOX is reserved to mean the "primary folder for this user on this server". Not all Stores will provide an INBOX folder, and not all users will have an INBOX folder at all times. The name INBOX is reserved to refer to this folder, when it exists, in Stores that provide it.

A Folder object obtained from a Store need not actually exist in the backend store. The exists method tests whether the folder exists or not. The create method creates a Folder.

A Folder is initially in the closed state. Certain methods are valid in this state; the documentation for those methods note this. A Folder is opened by calling its 'open' method. All Folder methods, except open, delete and renameTo, are valid in this state.

The only way to get a Folder is by invoking the getFolder method on Store, Folder, or Session, or by invoking the list or listSubscribed methods on Folder. Folder objects returned by the above methods are not cached by the Store. Thus, invoking the getFolder method with the same folder name multiple times will return distinct Folder objects. Likewise for the list and listSubscribed methods.

The Message objects within the Folder are cached by the Folder. Thus, invoking getMessage(msgno) on the same message number multiple times will return the same Message object, until an expunge is done on this Folder.

Note that a Message's message number can change within a session if the containing Folder is expunged using the expunge method. Clients that use message numbers as references to messages should be aware of this and should be prepared to deal with situation (probably by flushing out existing message number references and reloading them). Because of this complexity, it is better for clients to use Message objects as references to messages, rather than message numbers. Expunged Message objects still have to be pruned, but other Message objects in that folder are not affected by the expunge.

Author:
John Mani, Bill Shannon

Field Summary
static int | HOLDS_FOLDERS This folder can contain other folders
static int | HOLDS_MESSAGES This folder can contain messages
protected int | mode The open mode of this folder.
static int | READ_ONLY The Folder is read only.
static int | READ_WRITE The state and contents of this folder can be modified.
protected Store | store The parent store.
Constructor Summary
protected Folder(Store store)
Constructor that takes a Store object.
Method Summary
 void addConnectionListener(ConnectionListener l)
Add a listener for Connection events on this Folder.
 void addFolderListener(FolderListener l)
Add a listener for Folder events on this Folder.
 void addMessageChangedListener(MessageChangedListener l)
Add a listener for MessageChanged events on this Folder.
 void addMessageCountListener(MessageCountListener l)
Add a listener for MessageCount events on this Folder.
abstract  void appendMessages(Message[] msgs)
Append given Messages to this folder.
abstract  void close(boolean expunge)
Close this Folder.
 void copyMessages(Message[] msgs, Folder folder)
Copy the specified Messages from this Folder into another Folder.
abstract  boolean create(int type)
Create this folder on the Store.
abstract  boolean delete(boolean recurse)
Delete this Folder.
abstract  boolean exists()
Tests if this folder physically exists on the Store.
abstract  Message[] expunge()
Expunge (permanently remove) messages marked DELETED.
 void fetch(Message[] msgs, FetchProfile fp)
Prefetch the items specified in the FetchProfile for the given Messages.
protected  void finalize()
 int getDeletedMessageCount()
Get the number of deleted messages in this Folder.
abstract  Folder getFolder(String name)
Return the Folder object corresponding to the given name.
abstract  String getFullName()
Returns the full name of this Folder.
abstract  Message getMessage(int msgnum)
Get the Message object corresponding to the given message number.
abstract  int getMessageCount()
Get total number of messages in this Folder.
 Message[] getMessages()
Get all Message objects from this Folder.
 Message[] getMessages(int[] msgnums)
Get the Message objects for message numbers specified in the array.
 Message[] getMessages(int start, int end)
Get the Message objects for message numbers ranging from start through end, both start and end inclusive.
 int getMode()
Return the open mode of this folder.
abstract  String getName()
Returns the name of this Folder.
 int getNewMessageCount()
Get the number of new messages in this Folder.
abstract  Folder getParent()
Returns the parent folder of this folder.
abstract  Flags getPermanentFlags()
Get the permanent flags supported by this Folder.
abstract  char getSeparator()
Return the delimiter character that separates this Folder's pathname from the names of immediate subfolders.
 Store getStore()
Returns the Store that owns this Folder object.
abstract  int getType()
Returns the type of this Folder, that is, whether this folder can hold messages or subfolders or both.
 int getUnreadMessageCount()
Get the total number of unread messages in this Folder.
 URLName getURLName()
Return a URLName representing this folder.
abstract  boolean hasNewMessages()
Returns true if this Folder has new messages since the last time this indication was reset.
abstract  boolean isOpen()
Indicates whether this Folder is in the 'open' state.
 boolean isSubscribed()
Returns true if this Folder is subscribed.
 Folder[] list()
Convenience method that returns the list of folders under this Folder.
abstract  Folder[] list(String pattern)
Returns a list of Folders belonging to this Folder's namespace that match the specified pattern.
 Folder[] listSubscribed()
Convenience method that returns the list of subscribed folders under this Folder.
 Folder[] listSubscribed(String pattern)
Returns a list of subscribed Folders belonging to this Folder's namespace that match the specified pattern.
protected  void notifyConnectionListeners(int type)
Notify all ConnectionListeners.
protected  void notifyFolderListeners(int type)
Notify all FolderListeners registered on this Folder and this folder's Store.
protected  void notifyFolderRenamedListeners(Folder folder)
Notify all FolderListeners registered on this Folder and this folder's Store about the renaming of this folder.
protected  void notifyMessageAddedListeners(Message[] msgs)
Notify all MessageCountListeners about the addition of messages into this folder.
protected  void notifyMessageChangedListeners(int type, Message msg)
Notify all MessageChangedListeners.
protected  void notifyMessageRemovedListeners(boolean removed, Message[] msgs)
Notify all MessageCountListeners about the removal of messages from this Folder.
abstract  void open(int mode)
Open this Folder.
 void removeConnectionListener(ConnectionListener l)
Remove a Connection event listener.
 void removeFolderListener(FolderListener l)
Remove a Folder event listener.
 void removeMessageChangedListener(MessageChangedListener l)
Remove a MessageChanged listener.
 void removeMessageCountListener(MessageCountListener l)
Remove a MessageCount listener.
abstract  boolean renameTo(Folder f)
Rename this Folder.
 Message[] search(SearchTerm term)
Search this Folder for messages matching the specified search criterion.
 Message[] search(SearchTerm term, Message[] msgs)
Search the given array of messages for those that match the specified search criterion.
 void setFlags(int[] msgnums, Flags flag, boolean value)
Set the specified flags on the messages whose message numbers are in the array.
 void setFlags(int start, int end, Flags flag, boolean value)
Set the specified flags on the messages numbered from start through end, both start and end inclusive.
 void setFlags(Message[] msgs, Flags flag, boolean value)
Set the specified flags on the messages specified in the array.
 void setSubscribed(boolean subscribe)
Subscribe or unsubscribe this Folder.
 String toString()
override the default toString(), it will return the String from Folder.getFullName() or if that is null, it will use the default toString() behavior.
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

store

protected Store store
The parent store.

mode

protected int mode
The open mode of this folder. The open mode is Folder.READ_ONLY, Folder.READ_WRITE, or -1 if not known.

Since:
JavaMail 1.1

HOLDS_MESSAGES

public static final int HOLDS_MESSAGES
This folder can contain messages

See Also:
Constant Field Values

HOLDS_FOLDERS

public static final int HOLDS_FOLDERS
This folder can contain other folders

See Also:
Constant Field Values

READ_ONLY

public static final int READ_ONLY
The Folder is read only. The state and contents of this folder cannot be modified.

See Also:
Constant Field Values

READ_WRITE

public static final int READ_WRITE
The state and contents of this folder can be modified.

See Also:
Constant Field Values
Constructor Detail

Folder

protected Folder(Store store)
Constructor that takes a Store object.

Parameters:
store - the Store that holds this folder
Method Detail

getName

public abstract String getName()
Returns the name of this Folder.

This method can be invoked on a closed Folder.

Returns:
name of the Folder

getFullName

public abstract String getFullName()
Returns the full name of this Folder. If the folder resides under the root hierarchy of this Store, the returned name is relative to the root. Otherwise an absolute name, starting with the hierarchy delimiter, is returned.

This method can be invoked on a closed Folder.

Returns:
full name of the Folder

getURLName

public URLName getURLName()
                   throws MessagingException
Return a URLName representing this folder. The returned URLName does not include the password used to access the store.

Returns:
the URLName representing this folder
Throws:
MessagingException
Since:
JavaMail 1.1
See Also:
URLName

getStore

public Store getStore()
Returns the Store that owns this Folder object. This method can be invoked on a closed Folder.

Returns:
the Store

getParent

public abstract Folder getParent()
                          throws MessagingException
Returns the parent folder of this folder. This method can be invoked on a closed Folder. If this folder is the top of a folder hierarchy, this method returns null.

Note that since Folder objects are not cached, invoking this method returns a new distinct Folder object.

Returns:
Parent folder
Throws:
MessagingException

exists

public abstract boolean exists()
                        throws MessagingException
Tests if this folder physically exists on the Store. This method can be invoked on a closed Folder.

Returns:
true if the folder exists, otherwise false
Throws:
MessagingException - typically if the connection to the server is lost.
See Also:
create(int)

list

public abstract Folder[] list(String pattern)
                       throws MessagingException
Returns a list of Folders belonging to this Folder's namespace that match the specified pattern. Patterns may contain the wildcard characters "%", which matches any character except hierarchy delimiters, and "*", which matches any character.

As an example, given the folder hierarchy:

    Personal/
       Finance/
          Stocks
          Bonus
          StockOptions
       Jokes
list("*") on "Personal" will return the whole hierarchy.
list("%") on "Personal" will return "Finance" and "Jokes".
list("Jokes") on "Personal" will return "Jokes".
list("Stock*") on "Finance" will return "Stocks" and "StockOptions".

Folder objects are not cached by the Store, so invoking this method on the same pattern multiple times will return that many distinct Folder objects.

This method can be invoked on a closed Folder.

Parameters:
pattern - the match pattern
Returns:
array of matching Folder objects. An empty array is returned if no matching Folders exist.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
See Also:
listSubscribed(java.lang.String)

listSubscribed

public Folder[] listSubscribed(String pattern)
                        throws MessagingException
Returns a list of subscribed Folders belonging to this Folder's namespace that match the specified pattern. If the folder does not support subscription, this method should resolve to list. (The default implementation provided here, does just this). The pattern can contain wildcards as for list.

Folder objects are not cached by the Store, so invoking this method on the same pattern multiple times will return that many distinct Folder objects.

This method can be invoked on a closed Folder.

Parameters:
pattern - the match pattern
Returns:
array of matching subscribed Folder objects. An empty array is returned of no matching subscribed folders exist.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
See Also:
list(java.lang.String)

list

public Folder[] list()
              throws MessagingException
Convenience method that returns the list of folders under this Folder. This method just calls the list(String pattern) method with "%" as the match pattern. This method can be invoked on a closed Folder.

Returns:
array of Folder objects under this Folder. An empty array is returned if no subfolders exist.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
See Also:
list(java.lang.String)

listSubscribed

public Folder[] listSubscribed()
                        throws MessagingException
Convenience method that returns the list of subscribed folders under this Folder. This method just calls the listSubscribed(String pattern) method with "%" as the match pattern. This method can be invoked on a closed Folder.

Returns:
array of subscribed Folder objects under this Folder. An empty array is returned if no subscribed subfolders exist.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
See Also:
listSubscribed(java.lang.String)

getSeparator

public abstract char getSeparator()
                           throws MessagingException
Return the delimiter character that separates this Folder's pathname from the names of immediate subfolders. This method can be invoked on a closed Folder.

Returns:
Hierarchy separator character
Throws:
FolderNotFoundException - if this folder does not exist
MessagingException

getType

public abstract int getType()
                     throws MessagingException
Returns the type of this Folder, that is, whether this folder can hold messages or subfolders or both. The returned value is an integer bitfield with the appropriate bits set. This method can be invoked on a closed folder.

Returns:
integer with appropriate bits set
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
See Also:
HOLDS_FOLDERS, HOLDS_MESSAGES

create

public abstract boolean create(int type)
                        throws MessagingException
Create this folder on the Store. When this folder is created, any folders in its path that do not exist are also created.

If the creation is successful, a CREATED FolderEvent is delivered to any FolderListeners registered on this Folder and this Store.

Parameters:
type - The type of this folder.
Returns:
true if the creation succeeds, else false.
Throws:
MessagingException
See Also:
HOLDS_FOLDERS, HOLDS_MESSAGES, FolderEvent

isSubscribed

public boolean isSubscribed()
Returns true if this Folder is subscribed.

This method can be invoked on a closed Folder.

The default implementation provided here just returns true.

Returns:
true if this Folder is subscribed

setSubscribed

public void setSubscribed(boolean subscribe)
                   throws MessagingException
Subscribe or unsubscribe this Folder. Not all Stores support subscription.

This method can be invoked on a closed Folder.

The implementation provided here just throws the MethodNotSupportedException.

Parameters:
subscribe - true to subscribe, false to unsubscribe
Throws:
FolderNotFoundException - if this folder does not exist.
MethodNotSupportedException - if this store does not support subscription
MessagingException

hasNewMessages

public abstract boolean hasNewMessages()
                                throws MessagingException
Returns true if this Folder has new messages since the last time this indication was reset. When this indication is set or reset depends on the Folder implementation (and in the case of IMAP, depends on the server). This method can be used to implement a lightweight "check for new mail" operation on a Folder without opening it. (For example, a thread that monitors a mailbox and flags when it has new mail.) This method should indicate whether any messages in the Folder have the RECENT flag set.

Note that this is not an incremental check for new mail, i.e., it cannot be used to determine whether any new messages have arrived since the last time this method was invoked. To implement incremental checks, the Folder needs to be opened.

This method can be invoked on a closed Folder that can contain Messages.

Returns:
true if the Store has new Messages
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException

getFolder

public abstract Folder getFolder(String name)
                          throws MessagingException
Return the Folder object corresponding to the given name. Note that this folder does not physically have to exist in the Store. The exists() method on a Folder indicates whether it really exists on the Store.

In some Stores, name can be an absolute path if it starts with the hierarchy delimiter. Otherwise, it is interpreted relative to this Folder.

Folder objects are not cached by the Store, so invoking this method on the same name multiple times will return that many distinct Folder objects.

This method can be invoked on a closed Folder.

Parameters:
name - name of the Folder
Returns:
Folder object
Throws:
MessagingException

delete

public abstract boolean delete(boolean recurse)
                        throws MessagingException
Delete this Folder. This method will succeed only on a closed Folder.

The recurse flag controls whether the deletion affects subfolders or not. If true, all subfolders are deleted, then this folder itself is deleted. If false, the behaviour is dependent on the folder type and is elaborated below:

  • The folder can contain only messages: (type == HOLDS_MESSAGES).
    All messages within the folder are removed. The folder itself is then removed. An appropriate FolderEvent is generated by the Store and this folder.

  • The folder can contain only subfolders: (type == HOLDS_FOLDERS).
    If this folder is empty (does not contain any subfolders at all), it is removed. An appropriate FolderEvent is generated by the Store and this folder.
    If this folder contains any subfolders, the delete fails and returns false.

  • The folder can contain subfolders as well as messages:
    If the folder is empty (no messages or subfolders), it is removed. If the folder contains no subfolders, but only messages, then all messages are removed. The folder itself is then removed. In both the above cases, an appropriate FolderEvent is generated by the Store and this folder.

    If the folder contains subfolders there are 3 possible choices an implementation is free to do:

    1. The operation fails, irrespective of whether this folder contains messages or not. Some implementations might elect to go with this simple approach. The delete() method returns false.
    2. Any messages within the folder are removed. Subfolders are not removed. The folder itself is not removed or affected in any manner. The delete() method returns true. And the exists() method on this folder will return true indicating that this folder still exists.
      An appropriate FolderEvent is generated by the Store and this folder.
    3. Any messages within the folder are removed. Subfolders are not removed. The folder itself changes its type from HOLDS_FOLDERS | HOLDS_MESSAGES to HOLDS_FOLDERS. Thus new messages cannot be added to this folder, but new subfolders can be created underneath. The delete() method returns true indicating success. The exists() method on this folder will return true indicating that this folder still exists.
      An appropriate FolderEvent is generated by the Store and this folder.

Returns:
true if the Folder is deleted successfully
Throws:
FolderNotFoundException - if this folder does not exist
IllegalStateException - if this folder is not in the closed state.
MessagingException
See Also:
FolderEvent

renameTo

public abstract boolean renameTo(Folder f)
                          throws MessagingException
Rename this Folder. This method will succeed only on a closed Folder.

If the rename is successful, a RENAMED FolderEvent is delivered to FolderListeners registered on this folder and its containing Store.

Parameters:
f - a folder representing the new name for this Folder
Returns:
true if the Folder is renamed successfully
Throws:
FolderNotFoundException - if this folder does not exist
IllegalStateException - if this folder is not in the closed state.
MessagingException
See Also:
FolderEvent

open

public abstract void open(int mode)
                   throws MessagingException
Open this Folder. This method is valid only on Folders that can contain Messages and that are closed.

If this folder is opened successfully, an OPENED ConnectionEvent is delivered to any ConnectionListeners registered on this Folder.

The effect of opening multiple connections to the same folder on a specifc Store is implementation dependent. Some implementations allow multiple readers, but only one writer. Others allow multiple writers as well as readers.

Parameters:
mode - open the Folder READ_ONLY or READ_WRITE
Throws:
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not in the closed state.
MessagingException
See Also:
READ_ONLY, READ_WRITE, getType(), ConnectionEvent

close

public abstract void close(boolean expunge)
                    throws MessagingException
Close this Folder. This method is valid only on open Folders.

A CLOSED ConnectionEvent is delivered to any ConnectionListeners registered on this Folder. Note that the folder is closed even if this method terminates abnormally by throwing a MessagingException.

Parameters:
expunge - expunges all deleted messages if this flag is true
Throws:
IllegalStateException - if this folder is not opened
MessagingException
See Also:
ConnectionEvent

isOpen

public abstract boolean isOpen()
Indicates whether this Folder is in the 'open' state.

Returns:
true if this Folder is in the 'open' state.

getMode

public int getMode()
Return the open mode of this folder. Returns Folder.READ_ONLY, Folder.READ_WRITE, or -1 if the open mode is not known (usually only because an older Folder provider has not been updated to use this new method).

Returns:
the open mode of this folder
Throws:
IllegalStateException - if this folder is not opened
Since:
JavaMail 1.1

getPermanentFlags

public abstract Flags getPermanentFlags()
Get the permanent flags supported by this Folder. Returns a Flags object that contains all the flags supported.

The special flag Flags.USER indicates that this Folder supports arbitrary user-defined flags.

The supported permanent flags for a folder may not be available until the folder is opened.

Returns:
permanent flags, or null if not known

getMessageCount

public abstract int getMessageCount()
                             throws MessagingException
Get total number of messages in this Folder.

This method can be invoked on a closed folder. However, note that for some folder implementations, getting the total message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

Returns:
total number of messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException

getNewMessageCount

public int getNewMessageCount()
                       throws MessagingException
Get the number of new messages in this Folder.

This method can be invoked on a closed folder. However, note that for some folder implementations, getting the new message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

This implementation returns -1 if this folder is closed. Else this implementation gets each Message in the folder using getMessage(int) and checks whether its RECENT flag is set. The total number of messages that have this flag set is returned.

Returns:
number of new messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException

getUnreadMessageCount

public int getUnreadMessageCount()
                          throws MessagingException
Get the total number of unread messages in this Folder.

This method can be invoked on a closed folder. However, note that for some folder implementations, getting the unread message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

This implementation returns -1 if this folder is closed. Else this implementation gets each Message in the folder using getMessage(int) and checks whether its SEEN flag is set. The total number of messages that do not have this flag set is returned.

Returns:
total number of unread messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException

getDeletedMessageCount

public int getDeletedMessageCount()
                           throws MessagingException
Get the number of deleted messages in this Folder.

This method can be invoked on a closed folder. However, note that for some folder implementations, getting the deleted message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

This implementation returns -1 if this folder is closed. Else this implementation gets each Message in the folder using getMessage(int) and checks whether its DELETED flag is set. The total number of messages that have this flag set is returned.

Returns:
number of deleted messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
Since:
JavaMail 1.3

getMessage

public abstract Message getMessage(int msgnum)
                            throws MessagingException
Get the Message object corresponding to the given message number. A Message object's message number is the relative position of this Message in its Folder. Messages are numbered starting at 1 through the total number of message in the folder. Note that the message number for a particular Message can change during a session if other messages in the Folder are deleted and the Folder is expunged.

Message objects are light-weight references to the actual message that get filled up on demand. Hence Folder implementations are expected to provide light-weight Message objects.

Unlike Folder objects, repeated calls to getMessage with the same message number will return the same Message object, as long as no messages in this folder have been expunged.

Since message numbers can change within a session if the folder is expunged , clients are advised not to use message numbers as references to messages. Use Message objects instead.

Parameters:
msgnum - the message number
Returns:
the Message object
Throws:
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not opened
IndexOutOfBoundsException - if the message number is out of range.
MessagingException
See Also:
getMessageCount(), fetch(javax.mail.Message[], javax.mail.FetchProfile)

getMessages

public Message[] getMessages(int start,
                             int end)
                      throws MessagingException
Get the Message objects for message numbers ranging from start through end, both start and end inclusive. Note that message numbers start at 1, not 0.

Message objects are light-weight references to the actual message that get filled up on demand. Hence Folder implementations are expected to provide light-weight Message objects.

This implementation uses getMessage(index) to obtain the required Message objects. Note that the returned array must contain (end-start+1) Message objects.

Parameters:
start - the number of the first message
end - the number of the last message
Returns:
the Message objects
Throws:
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not opened.
IndexOutOfBoundsException - if the start or end message numbers are out of range.
MessagingException
See Also:
fetch(javax.mail.Message[], javax.mail.FetchProfile)

getMessages

public Message[] getMessages(int[] msgnums)
                      throws MessagingException
Get the Message objects for message numbers specified in the array.

Message objects are light-weight references to the actual message that get filled up on demand. Hence Folder implementations are expected to provide light-weight Message objects.

This implementation uses getMessage(index) to obtain the required Message objects. Note that the returned array must contain msgnums.length Message objects

Parameters:
msgnums - the array of message numbers
Returns:
the array of Message objects.
Throws:
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not opened.
IndexOutOfBoundsException - if any message number in the given array is out of range.
MessagingException
See Also:
fetch(javax.mail.Message[], javax.mail.FetchProfile)

getMessages

public Message[] getMessages()
                      throws MessagingException
Get all Message objects from this Folder. Returns an empty array if the folder is empty. Clients can use Message objects (instead of sequence numbers) as references to the messages within a folder; this method supplies the Message objects to the client. Folder implementations are expected to provide light-weight Message objects, which get filled on demand.

This implementation invokes getMessageCount() to get the current message count and then uses getMessage() to get Message objects from 1 till the message count.

Returns:
array of Message objects, empty array if folder is empty.
Throws:
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not opened.
MessagingException
See Also:
fetch(javax.mail.Message[], javax.mail.FetchProfile)

appendMessages

public abstract void appendMessages(Message[] msgs)
                             throws MessagingException
Append given Messages to this folder. This method can be invoked on a closed Folder. An appropriate MessageCountEvent is delivered to any MessageCountListener registered on this folder when the messages arrive in the folder.

Folder implementations must not abort this operation if a Message in the given message array turns out to be an expunged Message.

Parameters:
msgs - array of Messages to be appended
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException - if the append failed.

fetch

public void fetch(Message[] msgs,
                  FetchProfile fp)
           throws MessagingException
Prefetch the items specified in the FetchProfile for the given Messages.

Clients use this method to indicate that the specified items are needed en-masse for the given message range. Implementations are expected to retrieve these items for the given message range in a efficient manner. Note that this method is just a hint to the implementation to prefetch the desired items.

An example is a client filling its header-view window with the Subject, From and X-mailer headers for all messages in the folder.

  Message[] msgs = folder.getMessages();

  FetchProfile fp = new FetchProfile();
  fp.add(FetchProfile.Item.ENVELOPE);
  fp.add("X-mailer");
  folder.fetch(msgs, fp);

  for (int i = 0; i < folder.getMessageCount(); i++) {
      display(msg[i].getFrom());
      display(msg[i].getSubject());
      display(msg[i].getHeader("X-mailer"));
  }

The implementation provided here just returns without doing anything useful. Providers wanting to provide a real implementation for this method should override this method.

Parameters:
msgs - fetch items for these messages
fp - the FetchProfile
Throws:
IllegalStateException - if this folder is not opened
MessagingException.
MessagingException

setFlags

public void setFlags(Message[] msgs,
                     Flags flag,
                     boolean value)
              throws MessagingException
Set the specified flags on the messages specified in the array. This will result in appropriate MessageChangedEvents being delivered to any MessageChangedListener registered on this Message's containing folder.

Note that the specified Message objects must belong to this folder. Certain Folder implementations can optimize the operation of setting Flags for a group of messages, so clients might want to use this method, rather than invoking Message.setFlags for each Message.

This implementation degenerates to invoking setFlags() on each Message object. Specific Folder implementations that can optimize this case should do so. Also, an implementation must not abort the operation if a Message in the array turns out to be an expunged Message.

Parameters:
msgs - the array of message objects
flag - Flags object containing the flags to be set
value - set the flags to this boolean value
Throws:
IllegalStateException - if this folder is not opened or if it has been opened READ_ONLY.
MessagingException
See Also:
Message.setFlags(javax.mail.Flags, boolean), MessageChangedEvent

setFlags

public void setFlags(int start,
                     int end,
                     Flags flag,
                     boolean value)
              throws MessagingException
Set the specified flags on the messages numbered from start through end, both start and end inclusive. Note that message numbers start at 1, not 0. This will result in appropriate MessageChangedEvents being delivered to any MessageChangedListener registered on this Message's containing folder.

Certain Folder implementations can optimize the operation of setting Flags for a group of messages, so clients might want to use this method, rather than invoking Message.setFlags for each Message.

The default implementation uses getMessage(int) to get each Message object and then invokes setFlags on that object to set the flags. Specific Folder implementations that can optimize this case should do so. Also, an implementation must not abort the operation if a message number refers to an expunged message.

Parameters:
start - the number of the first message
end - the number of the last message
flag - Flags object containing the flags to be set
value - set the flags to this boolean value
Throws:
IllegalStateException - if this folder is not opened or if it has been opened READ_ONLY.
IndexOutOfBoundsException - if the start or end message numbers are out of range.
MessagingException
See Also:
Message.setFlags(javax.mail.Flags, boolean), MessageChangedEvent

setFlags

public void setFlags(int[] msgnums,
                     Flags flag,
                     boolean value)
              throws MessagingException
Set the specified flags on the messages whose message numbers are in the array. This will result in appropriate MessageChangedEvents being delivered to any MessageChangedListener registered on this Message's containing folder.

Certain Folder implementations can optimize the operation of setting Flags for a group of messages, so clients might want to use this method, rather than invoking Message.setFlags for each Message.

The default implementation uses getMessage(int) to get each Message object and then invokes setFlags on that object to set the flags. Specific Folder implementations that can optimize this case should do so. Also, an implementation must not abort the operation if a message number refers to an expunged message.

Parameters:
msgnums - the array of message numbers
flag - Flags object containing the flags to be set
value - set the flags to this boolean value
Throws:
IllegalStateException - if this folder is not opened or if it has been opened READ_ONLY.
IndexOutOfBoundsException - if any message number in the given array is out of range.
MessagingException
See Also:
Message.setFlags(javax.mail.Flags, boolean), MessageChangedEvent

copyMessages

public void copyMessages(Message[] msgs,
                         Folder folder)
                  throws MessagingException
Copy the specified Messages from this Folder into another Folder. This operation appends these Messages to the destination Folder. The destination Folder does not have to be opened. An appropriate MessageCountEvent is delivered to any MessageCountListener registered on the destination folder when the messages arrive in the folder.

Note that the specified Message objects must belong to this folder. Folder implementations might be able to optimize this method by doing server-side copies.

This implementation just invokes appendMessages() on the destination folder to append the given Messages. Specific folder implementations that support server-side copies should do so, if the destination folder's Store is the same as this folder's Store. Also, an implementation must not abort the operation if a Message in the array turns out to be an expunged Message.

Parameters:
msgs - the array of message objects
folder - the folder to copy the messages to
Throws:
FolderNotFoundException - if the destination folder does not exist.
IllegalStateException - if this folder is not opened.
MessagingException
See Also:
appendMessages(javax.mail.Message[])

expunge

public abstract Message[] expunge()
                           throws MessagingException
Expunge (permanently remove) messages marked DELETED. Returns an array containing the expunged message objects. The getMessageNumber method on each of these message objects returns that Message's original (that is, prior to the expunge) sequence number. A MessageCountEvent containing the expunged messages is delivered to any MessageCountListeners registered on the folder.

Expunge causes the renumbering of Message objects subsequent to the expunged messages. Clients that use message numbers as references to messages should be aware of this and should be prepared to deal with the situation (probably by flushing out existing message number caches and reloading them). Because of this complexity, it is better for clients to use Message objects as references to messages, rather than message numbers. Any expunged Messages objects still have to be pruned, but other Messages in that folder are not affected by the expunge.

After a message is expunged, only the isExpunged and getMessageNumber methods are still valid on the corresponding Message object; other methods may throw MessageRemovedException

Returns:
array of expunged Message objects
Throws:
FolderNotFoundException - if this folder does not exist
IllegalStateException - if this folder is not opened.
MessagingException
See Also:
Message.isExpunged(), MessageCountEvent

search

public Message[] search(SearchTerm term)
                 throws MessagingException
Search this Folder for messages matching the specified search criterion. Returns an array containing the matching messages . Returns an empty array if no matches were found.

This implementation invokes search(term, getMessages()), to apply the search over all the messages in this folder. Providers that can implement server-side searching might want to override this method to provide a more efficient implementation.

Parameters:
term - the search criterion
Returns:
array of matching messages
Throws:
SearchException - if the search term is too complex for the implementation to handle.
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not opened.
MessagingException
See Also:
SearchTerm

search

public Message[] search(SearchTerm term,
                        Message[] msgs)
                 throws MessagingException
Search the given array of messages for those that match the specified search criterion. Returns an array containing the matching messages. Returns an empty array if no matches were found.

Note that the specified Message objects must belong to this folder.

This implementation iterates through the given array of messages, and applies the search criterion on each message by calling its match() method with the given term. The messages that succeed in the match are returned. Providers that can implement server-side searching might want to override this method to provide a more efficient implementation. If the search term is too complex or contains user-defined terms that cannot be executed on the server, providers may elect to either throw a SearchException or degenerate to client-side searching by calling super.search() to invoke this implementation.

Parameters:
term - the search criterion
msgs - the messages to be searched
Returns:
array of matching messages
Throws:
SearchException - if the search term is too complex for the implementation to handle.
IllegalStateException - if this folder is not opened
MessagingException
See Also:
SearchTerm

addConnectionListener

public void addConnectionListener(ConnectionListener l)
Add a listener for Connection events on this Folder.

The implementation provided here adds this listener to an internal list of ConnectionListeners.

Parameters:
l - the Listener for Connection events
See Also:
ConnectionEvent

removeConnectionListener

public void removeConnectionListener(ConnectionListener l)
Remove a Connection event listener.

The implementation provided here removes this listener from the internal list of ConnectionListeners.

Parameters:
l - the listener
See Also:
addConnectionListener(javax.mail.event.ConnectionListener)

notifyConnectionListeners

protected void notifyConnectionListeners(int type)
Notify all ConnectionListeners. Folder implementations are expected to use this method to broadcast connection events.

The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered ConnectionListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

Parameters:
type - the ConnectionEvent type
See Also:
ConnectionEvent

addFolderListener

public void addFolderListener(FolderListener l)
Add a listener for Folder events on this Folder.

The implementation provided here adds this listener to an internal list of FolderListeners.

Parameters:
l - the Listener for Folder events
See Also:
FolderEvent

removeFolderListener

public void removeFolderListener(FolderListener l)
Remove a Folder event listener.

The implementation provided here removes this listener from the internal list of FolderListeners.

Parameters:
l - the listener
See Also:
addFolderListener(javax.mail.event.FolderListener)

notifyFolderListeners

protected void notifyFolderListeners(int type)
Notify all FolderListeners registered on this Folder and this folder's Store. Folder implementations are expected to use this method to broadcast Folder events.

The implementation provided here queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the FolderListeners registered on this folder. The implementation also invokes notifyFolderListeners on this folder's Store to notify any FolderListeners registered on the store.

Parameters:
type - type of FolderEvent
See Also:
notifyFolderRenamedListeners(javax.mail.Folder)

notifyFolderRenamedListeners

protected void notifyFolderRenamedListeners(Folder folder)
Notify all FolderListeners registered on this Folder and this folder's Store about the renaming of this folder. Folder implementations are expected to use this method to broadcast Folder events indicating the renaming of folders.

The implementation provided here queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the FolderListeners registered on this folder. The implementation also invokes notifyFolderRenamedListeners on this folder's Store to notify any FolderListeners registered on the store.

Parameters:
folder - Folder representing the new name.
Since:
JavaMail 1.1
See Also:
notifyFolderListeners(int)

addMessageCountListener

public void addMessageCountListener(MessageCountListener l)
Add a listener for MessageCount events on this Folder.

The implementation provided here adds this listener to an internal list of MessageCountListeners.

Parameters:
l - the Listener for MessageCount events
See Also:
MessageCountEvent

removeMessageCountListener

public void removeMessageCountListener(MessageCountListener l)
Remove a MessageCount listener.

The implementation provided here removes this listener from the internal list of MessageCountListeners.

Parameters:
l - the listener
See Also:
addMessageCountListener(javax.mail.event.MessageCountListener)

notifyMessageAddedListeners

protected void notifyMessageAddedListeners(Message[] msgs)
Notify all MessageCountListeners about the addition of messages into this folder. Folder implementations are expected to use this method to broadcast MessageCount events for indicating arrival of new messages.

The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered MessageCountListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

notifyMessageRemovedListeners

protected void notifyMessageRemovedListeners(boolean removed,
                                             Message[] msgs)
Notify all MessageCountListeners about the removal of messages from this Folder. Folder implementations are expected to use this method to broadcast MessageCount events indicating removal of messages.

The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered MessageCountListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

addMessageChangedListener

public void addMessageChangedListener(MessageChangedListener l)
Add a listener for MessageChanged events on this Folder.

The implementation provided here adds this listener to an internal list of MessageChangedListeners.

Parameters:
l - the Listener for MessageChanged events
See Also:
MessageChangedEvent

removeMessageChangedListener

public void removeMessageChangedListener(MessageChangedListener l)
Remove a MessageChanged listener.

The implementation provided here removes this listener from the internal list of MessageChangedListeners.

Parameters:
l - the listener
See Also:
addMessageChangedListener(javax.mail.event.MessageChangedListener)

notifyMessageChangedListeners

protected void notifyMessageChangedListeners(int type,
                                             Message msg)
Notify all MessageChangedListeners. Folder implementations are expected to use this method to broadcast MessageChanged events.

The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to registered MessageChangedListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

finalize

protected void finalize()
                 throws Throwable
Throws:
Throwable

toString

public String toString()
override the default toString(), it will return the String from Folder.getFullName() or if that is null, it will use the default toString() behavior.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FolderClosedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class FolderClosedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.FolderClosedException
All Implemented Interfaces:
Serializable
public class FolderClosedException
extends MessagingException

This exception is thrown when a method is invoked on a Messaging object and the Folder that owns that object has died due to some reason.

Following the exception, the Folder is reset to the "closed" state. All messaging objects owned by the Folder should be considered invalid. The Folder can be reopened using the "open" method to reestablish the lost connection.

The getMessage() method returns more detailed information about the error that caused this exception.

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
FolderClosedException(Folder folder)
Constructor
FolderClosedException(Folder folder, String message)
Constructor
Method Summary
 Folder getFolder()
Returns the dead Folder object
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FolderClosedException

public FolderClosedException(Folder folder)
Constructor

Parameters:
folder - the Folder

FolderClosedException

public FolderClosedException(Folder folder,
                             String message)
Constructor

Parameters:
folder - the Folder
message - the detailed error message
Method Detail

getFolder

public Folder getFolder()
Returns the dead Folder object

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FolderNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class FolderNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.FolderNotFoundException
All Implemented Interfaces:
Serializable
public class FolderNotFoundException
extends MessagingException

This exception is thrown by Folder methods, when those methods are invoked on a non existent folder.

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
FolderNotFoundException()
Constructs a MessagingException with no detail message.
FolderNotFoundException(Folder folder)
Constructs a MessagingException with the specified folder.
FolderNotFoundException(Folder folder, String s)
Constructs a MessagingException with the specified folder and the specified detail message.
FolderNotFoundException(String s, Folder folder)
Constructs a MessagingException with the specified detail message and the specified folder.
Method Summary
 Folder getFolder()
Returns the offending Folder object.
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FolderNotFoundException

public FolderNotFoundException()
Constructs a MessagingException with no detail message.

FolderNotFoundException

public FolderNotFoundException(Folder folder)
Constructs a MessagingException with the specified folder.

Parameters:
folder - the Folder
Since:
JavaMail 1.2

FolderNotFoundException

public FolderNotFoundException(Folder folder,
                               String s)
Constructs a MessagingException with the specified folder and the specified detail message.

Parameters:
folder - the Folder
s - the detail message
Since:
JavaMail 1.2

FolderNotFoundException

public FolderNotFoundException(String s,
                               Folder folder)
Constructs a MessagingException with the specified detail message and the specified folder.

Parameters:
s - the detail message
folder - the Folder
Method Detail

getFolder

public Folder getFolder()
Returns the offending Folder object.

Returns:
the Folder object. Note that the returned value can be null.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Header

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Header

java.lang.Object
    extended by javax.mail.Header
public class Header
extends Object

The Header class stores a name/value pair to represent headers.

Author:
John Mani

Constructor Summary
Header(String name, String value)
Construct a Header object.
Method Summary
String | getName() Returns the name of this header.
String | getValue() Returns the value of this header.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Header

public Header(String name,
              String value)
Construct a Header object.

Parameters:
name - name of the header
value - value of the header
Method Detail

getName

public String getName()
Returns the name of this header.

Returns:
name of the header

getValue

public String getValue()
Returns the value of this header.

Returns:
value of the header
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


IllegalWriteException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class IllegalWriteException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.IllegalWriteException
All Implemented Interfaces:
Serializable
public class IllegalWriteException
extends MessagingException

The exception thrown when a write is attempted on a read-only attribute of any Messaging object.

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
IllegalWriteException()
Constructs a IllegalWriteException with no detail message.
IllegalWriteException(String s)
Constructs a IllegalWriteException with the specified detail message.
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IllegalWriteException

public IllegalWriteException()
Constructs a IllegalWriteException with no detail message.

IllegalWriteException

public IllegalWriteException(String s)
Constructs a IllegalWriteException with the specified detail message.

Parameters:
s - the detail message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


internet

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.mail.internet

Classes specific to Internet mail systems.

See:
Description

Interface Summary
MimePart | The MimePart interface models an Entity as defined by MIME (RFC2045, Section 2.4).
SharedInputStream | An InputStream that is backed by data that can be shared by multiple readers may implement this interface.

Class Summary
ContentDisposition | This class represents a MIME ContentDisposition value.
ContentType | This class represents a MIME ContentType value.
HeaderTokenizer | This class tokenizes RFC822 and MIME headers into the basic symbols specified by RFC822 and MIME.
HeaderTokenizer.Token | The Token class represents tokens returned by the HeaderTokenizer.
InternetAddress | This class represents an Internet email address using the syntax of RFC822.
InternetHeaders | InternetHeaders is a utility class that manages RFC822 style headers.
MailDateFormat | Formats and parses date specification based on the draft-ietf-drums-msg-fmt-08 dated January 26, 2000.
MimeBodyPart | This class represents a MIME body part.
MimeMessage | This class represents a MIME style email message.
MimeMessage.RecipientType | This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes.
MimeMultipart | The MimeMultipart class is an implementation of the abstract Multipart class that uses MIME conventions for the multipart data.
MimePartDataSource | A utility class that implements a DataSource out of a MimePart.
MimeUtility | This is a utility class that provides various MIME related functionality.
NewsAddress | This class models an RFC1036 newsgroup address.
ParameterList | This class holds MIME parameters (attribute-value pairs).

Exception Summary
AddressException | The exception thrown when a wrongly formatted address is encountered.
ParseException | The exception thrown due to an error in parsing RFC822 or MIME headers

Package javax.mail.internet Description

Classes specific to Internet mail systems. This package supports features that are specific to Internet mail systems based on the MIME standard (RFC 2045, RFC 2046, and RFC 2047). The IMAP, SMTP, and POP3 protocols use MimeMessages.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.mail.internet Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.mail.internet

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.mail.Address (implements java.io.Serializable)
      • class javax.mail.internet.InternetAddress (implements java.lang.Cloneable)
      • class javax.mail.internet.NewsAddress
    • class javax.mail.BodyPart (implements javax.mail.Part)
      • class javax.mail.internet.MimeBodyPart (implements javax.mail.internet.MimePart)
    • class javax.mail.internet.ContentDisposition
    • class javax.mail.internet.ContentType
    • class java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • class java.text.DateFormat
        • class java.text.SimpleDateFormat
          • class javax.mail.internet.MailDateFormat
    • class javax.mail.internet.HeaderTokenizer
    • class javax.mail.internet.HeaderTokenizer.Token
    • class javax.mail.internet.InternetHeaders
    • class javax.mail.Message (implements javax.mail.Part)
      • class javax.mail.internet.MimeMessage (implements javax.mail.internet.MimePart)
    • class javax.mail.Message.RecipientType (implements java.io.Serializable)
      • class javax.mail.internet.MimeMessage.RecipientType
    • class javax.mail.internet.MimePartDataSource (implements javax.activation.DataSource, javax.mail.MessageAware)
    • class javax.mail.internet.MimeUtility
    • class javax.mail.Multipart
      • class javax.mail.internet.MimeMultipart
    • class javax.mail.internet.ParameterList
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.mail.MessagingException
          • class javax.mail.internet.ParseException
            • class javax.mail.internet.AddressException

Interface Hierarchy

  • interface javax.mail.Part
    • interface javax.mail.internet.MimePart
  • interface javax.mail.internet.SharedInputStream
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AddressException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class AddressException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.internet.ParseException
                    extended by javax.mail.internet.AddressException
All Implemented Interfaces:
Serializable
public class AddressException
extends ParseException

The exception thrown when a wrongly formatted address is encountered.

Author:
Bill Shannon, Max Spivak
See Also:
Serialized Form

Field Summary
protected int | pos The index in the string where the error occurred, or -1 if not known.
protected String | ref The string being parsed.
Constructor Summary
AddressException()
Constructs an AddressException with no detail message.
AddressException(String s)
Constructs an AddressException with the specified detail message.
AddressException(String s, String ref)
Constructs an AddressException with the specified detail message and reference info.
AddressException(String s, String ref, int pos)
Constructs an AddressException with the specified detail message and reference info.
Method Summary
int | getPos() Get the position with the reference string where the error was detected (-1 if not relevant).
String | getRef() Get the string that was being parsed when the error was detected (null if not relevant).
String | toString()
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ref

protected String ref
The string being parsed.

pos

protected int pos
The index in the string where the error occurred, or -1 if not known.

Constructor Detail

AddressException

public AddressException()
Constructs an AddressException with no detail message.

AddressException

public AddressException(String s)
Constructs an AddressException with the specified detail message.

Parameters:
s - the detail message

AddressException

public AddressException(String s,
                        String ref)
Constructs an AddressException with the specified detail message and reference info.

Parameters:
s - the detail message

AddressException

public AddressException(String s,
                        String ref,
                        int pos)
Constructs an AddressException with the specified detail message and reference info.

Parameters:
s - the detail message
Method Detail

getRef

public String getRef()
Get the string that was being parsed when the error was detected (null if not relevant).

getPos

public int getPos()
Get the position with the reference string where the error was detected (-1 if not relevant).

toString

public String toString()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ContentDisposition

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class ContentDisposition

java.lang.Object
    extended by javax.mail.internet.ContentDisposition
public class ContentDisposition
extends Object

This class represents a MIME ContentDisposition value. It provides methods to parse a ContentDisposition string into individual components and to generate a MIME style ContentDisposition string.

Version:
1.7, 03/04/10
Author:
John Mani

Constructor Summary
ContentDisposition()
No-arg Constructor.
ContentDisposition(String s)
Constructor that takes a ContentDisposition string.
ContentDisposition(String disposition, ParameterList list)
Constructor.
Method Summary
String | getDisposition() Return the disposition value.
String | getParameter(String name) Return the specified parameter value.
ParameterList | getParameterList() Return a ParameterList object that holds all the available parameters.
void | setDisposition(String disposition) Set the disposition.
void | setParameter(String name, String value) Set the specified parameter.
void | setParameterList(ParameterList list) Set a new ParameterList.
String | toString() Retrieve a RFC2045 style string representation of this ContentDisposition.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ContentDisposition

public ContentDisposition()
No-arg Constructor.

ContentDisposition

public ContentDisposition(String disposition,
                          ParameterList list)
Constructor.

Parameters:
disposition - disposition
list - ParameterList
Since:
JavaMail 1.2

ContentDisposition

public ContentDisposition(String s)
                   throws ParseException
Constructor that takes a ContentDisposition string. The String is parsed into its constituents: dispostion and parameters. A ParseException is thrown if the parse fails.

Parameters:
s - the ContentDisposition string.
Throws:
ParseException - if the parse fails.
Since:
JavaMail 1.2
Method Detail

getDisposition

public String getDisposition()
Return the disposition value.

Returns:
the disposition
Since:
JavaMail 1.2

getParameter

public String getParameter(String name)
Return the specified parameter value. Returns null if this parameter is absent.

Returns:
parameter value
Since:
JavaMail 1.2

getParameterList

public ParameterList getParameterList()
Return a ParameterList object that holds all the available parameters. Returns null if no parameters are available.

Returns:
ParameterList
Since:
JavaMail 1.2

setDisposition

public void setDisposition(String disposition)
Set the disposition. Replaces the existing disposition.

Parameters:
disposition - the disposition
Since:
JavaMail 1.2

setParameter

public void setParameter(String name,
                         String value)
Set the specified parameter. If this parameter already exists, it is replaced by this new value.

Parameters:
name - parameter name
value - parameter value
Since:
JavaMail 1.2

setParameterList

public void setParameterList(ParameterList list)
Set a new ParameterList.

Parameters:
list - ParameterList
Since:
JavaMail 1.2

toString

public String toString()
Retrieve a RFC2045 style string representation of this ContentDisposition. Returns null if the conversion failed.

Returns:
RFC2045 style string
Since:
JavaMail 1.2
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ContentType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class ContentType

java.lang.Object
    extended by javax.mail.internet.ContentType
public class ContentType
extends Object

This class represents a MIME ContentType value. It provides methods to parse a ContentType string into individual components and to generate a MIME style ContentType string.

Version:
1.8, 03/04/10
Author:
John Mani

Constructor Summary
ContentType()
No-arg Constructor.
ContentType(String s)
Constructor that takes a Content-Type string.
ContentType(String primaryType, String subType, ParameterList list)
Constructor.
Method Summary
String | getBaseType() Return the MIME type string, without the parameters.
String | getParameter(String name) Return the specified parameter value.
ParameterList | getParameterList() Return a ParameterList object that holds all the available parameters.
String | getPrimaryType() Return the primary type.
String | getSubType() Return the subType.
boolean | match(ContentType cType) Match with the specified ContentType object.
boolean | match(String s) Match with the specified content-type string.
void | setParameter(String name, String value) Set the specified parameter.
void | setParameterList(ParameterList list) Set a new ParameterList.
void | setPrimaryType(String primaryType) Set the primary type.
void | setSubType(String subType) Set the subType.
String | toString() Retrieve a RFC2045 style string representation of this Content-Type.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ContentType

public ContentType()
No-arg Constructor.

ContentType

public ContentType(String primaryType,
                   String subType,
                   ParameterList list)
Constructor.

Parameters:
primaryType - primary type
subType - subType
list - ParameterList

ContentType

public ContentType(String s)
            throws ParseException
Constructor that takes a Content-Type string. The String is parsed into its constituents: primaryType, subType and parameters. A ParseException is thrown if the parse fails.

Parameters:
s - the Content-Type string.
Throws:
ParseException - if the parse fails.
Method Detail

getPrimaryType

public String getPrimaryType()
Return the primary type.

Returns:
the primary type

getSubType

public String getSubType()
Return the subType.

Returns:
the subType

getBaseType

public String getBaseType()
Return the MIME type string, without the parameters. The returned value is basically the concatenation of the primaryType, the '/' character and the secondaryType.

Returns:
the type

getParameter

public String getParameter(String name)
Return the specified parameter value. Returns null if this parameter is absent.

Returns:
parameter value

getParameterList

public ParameterList getParameterList()
Return a ParameterList object that holds all the available parameters. Returns null if no parameters are available.

Returns:
ParameterList

setPrimaryType

public void setPrimaryType(String primaryType)
Set the primary type. Overrides existing primary type.

Parameters:
primaryType - primary type

setSubType

public void setSubType(String subType)
Set the subType. Replaces the existing subType.

Parameters:
subType - the subType

setParameter

public void setParameter(String name,
                         String value)
Set the specified parameter. If this parameter already exists, it is replaced by this new value.

Parameters:
name - parameter name
value - parameter value

setParameterList

public void setParameterList(ParameterList list)
Set a new ParameterList.

Parameters:
list - ParameterList

toString

public String toString()
Retrieve a RFC2045 style string representation of this Content-Type. Returns null if the conversion failed.

Returns:
RFC2045 style string

match

public boolean match(ContentType cType)
Match with the specified ContentType object. This method compares only the primaryType and subType . The parameters of both operands are ignored.

For example, this method will return true when comparing the ContentTypes for "text/plain" and "text/plain; charset=foobar". If the subType of either operand is the special character '*', then the subtype is ignored during the match. For example, this method will return true when comparing the ContentTypes for "text/plain" and "text/*"

Parameters:
cType - ContentType to compare this against

match

public boolean match(String s)
Match with the specified content-type string. This method compares only the primaryType and subType . The parameters of both operands are ignored.

For example, this method will return true when comparing the ContentType for "text/plain" with "text/plain; charset=foobar". If the subType of either operand is the special character '*', then the subtype is ignored during the match. For example, this method will return true when comparing the ContentType for "text/plain" with "text/*"

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HeaderTokenizer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class HeaderTokenizer

java.lang.Object
    extended by javax.mail.internet.HeaderTokenizer
public class HeaderTokenizer
extends Object

This class tokenizes RFC822 and MIME headers into the basic symbols specified by RFC822 and MIME.

This class handles folded headers (ie headers with embedded CRLF SPACE sequences). The folds are removed in the returned tokens.

Version:
1.9, 02/03/27
Author:
John Mani

Nested Class Summary
static class HeaderTokenizer.Token
The Token class represents tokens returned by the HeaderTokenizer.
Field Summary
static String | MIME MIME specials
static String | RFC822 RFC822 specials
Constructor Summary
HeaderTokenizer(String header)
Constructor.
HeaderTokenizer(String header, String delimiters)
Constructor.
HeaderTokenizer(String header, String delimiters, boolean skipComments)
Constructor that takes a rfc822 style header.
Method Summary
String | getRemainder() Return the rest of the Header.
HeaderTokenizer.Token | next() Parses the next token from this String.
HeaderTokenizer.Token | peek() Peek at the next token, without actually removing the token from the parse stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

RFC822

public static final String RFC822
RFC822 specials

See Also:
Constant Field Values

MIME

public static final String MIME
MIME specials

See Also:
Constant Field Values
Constructor Detail

HeaderTokenizer

public HeaderTokenizer(String header,
                       String delimiters,
                       boolean skipComments)
Constructor that takes a rfc822 style header.

Parameters:
header - The rfc822 header to be tokenized
delimiters - Set of delimiter characters to be used to delimit ATOMS. These are usually RFC822 or MIME
skipComments - If true, comments are skipped and not returned as tokens

HeaderTokenizer

public HeaderTokenizer(String header,
                       String delimiters)
Constructor. Comments are ignored and not returned as tokens

Parameters:
header - The header that is tokenized
delimiters - The delimiters to be used

HeaderTokenizer

public HeaderTokenizer(String header)
Constructor. The RFC822 defined delimiters - RFC822 - are used to delimit ATOMS. Also comments are skipped and not returned as tokens

Method Detail

next

public HeaderTokenizer.Token next()
                           throws ParseException
Parses the next token from this String.

Clients sit in a loop calling next() to parse successive tokens until an EOF Token is returned.

Returns:
the next Token
Throws:
ParseException - if the parse fails

peek

public HeaderTokenizer.Token peek()
                           throws ParseException
Peek at the next token, without actually removing the token from the parse stream. Invoking this method multiple times will return successive tokens, until next() is called.

Returns:
the next Token
Throws:
ParseException - if the parse fails

getRemainder

public String getRemainder()
Return the rest of the Header.

Returns:
String rest of header. null is returned if we are already at end of header
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HeaderTokenizer.Token

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class HeaderTokenizer.Token

java.lang.Object
    extended by javax.mail.internet.HeaderTokenizer.Token
Enclosing class:
HeaderTokenizer
public static class HeaderTokenizer.Token
extends Object

The Token class represents tokens returned by the HeaderTokenizer.

Field Summary
static int | ATOM Token type indicating an ATOM.
static int | COMMENT Token type indicating a comment.
static int | EOF Token type indicating end of input.
static int | QUOTEDSTRING Token type indicating a quoted string.
Constructor Summary
HeaderTokenizer.Token(int type, String value)
Constructor.
Method Summary
int | getType() Return the type of the token.
String | getValue() Returns the value of the token just read.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ATOM

public static final int ATOM
Token type indicating an ATOM.

See Also:
Constant Field Values

QUOTEDSTRING

public static final int QUOTEDSTRING
Token type indicating a quoted string. The value field contains the string without the quotes.

See Also:
Constant Field Values

COMMENT

public static final int COMMENT
Token type indicating a comment. The value field contains the comment string without the comment start and end symbols.

See Also:
Constant Field Values

EOF

public static final int EOF
Token type indicating end of input.

See Also:
Constant Field Values
Constructor Detail

HeaderTokenizer.Token

public HeaderTokenizer.Token(int type,
                             String value)
Constructor.

Parameters:
type - Token type
value - Token value
Method Detail

getType

public int getType()
Return the type of the token. If the token represents a delimiter or a control character, the type is that character itself, converted to an integer. Otherwise, it's value is one of the following:
  • ATOM A sequence of ASCII characters delimited by either SPACE, CTL, "(", <"> or the specified SPECIALS
  • QUOTEDSTRING A sequence of ASCII characters within quotes
  • COMMENT A sequence of ASCII characters within "(" and ")".
  • EOF End of header

getValue

public String getValue()
Returns the value of the token just read. When the current token is a quoted string, this field contains the body of the string, without the quotes. When the current token is a comment, this field contains the body of the comment.

Returns:
token value
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InternetAddress

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class InternetAddress

java.lang.Object
    extended by javax.mail.Address
        extended by javax.mail.internet.InternetAddress
All Implemented Interfaces:
Cloneable, Serializable
public class InternetAddress
extends Address
implements Cloneable

This class represents an Internet email address using the syntax of RFC822. Typical address syntax is of the form "user@host.domain" or "Personal Name ".

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected String | address
protected String | encodedPersonal The RFC 2047 encoded version of the personal name.
protected String | personal The personal name.
Constructor Summary
InternetAddress()
Default constructor.
InternetAddress(String address)
Constructor.
InternetAddress(String address, boolean strict)
Parse the given string and create an InternetAddress.
InternetAddress(String address, String personal)
Construct an InternetAddress given the address and personal name.
InternetAddress(String address, String personal, String charset)
Construct an InternetAddress given the address and personal name.
Method Summary
Object | clone() Return a copy of this InternetAddress object.
boolean | equals(Object a) The equality operator.
String | getAddress() Get the email address.
InternetAddress[] | getGroup(boolean strict) Return the members of a group address.
static InternetAddress | getLocalAddress(Session session) Return an InternetAddress object representing the current user.
String | getPersonal() Get the personal name.
String | getType() Return the type of this address.
int | hashCode() Compute a hash code for the address.
boolean | isGroup() Indicates whether this address is an RFC 822 group address.
static InternetAddress[] | parse(String addresslist) Parse the given comma separated sequence of addresses into InternetAddress objects.
static InternetAddress[] | parse(String addresslist, boolean strict) Parse the given sequence of addresses into InternetAddress objects.
static InternetAddress[] | parseHeader(String addresslist, boolean strict) Parse the given sequence of addresses into InternetAddress objects.
void | setAddress(String address) Set the email address.
void | setPersonal(String name) Set the personal name.
void | setPersonal(String name, String charset) Set the personal name.
String | toString() Convert this address into a RFC 822 / RFC 2047 encoded address.
static String | toString(Address[] addresses) Convert the given array of InternetAddress objects into a comma separated sequence of address strings.
static String | toString(Address[] addresses, int used) Convert the given array of InternetAddress objects into a comma separated sequence of address strings.
String | toUnicodeString() Returns a properly formatted address (RFC 822 syntax) of Unicode characters.
void | validate() Validate that this address conforms to the syntax rules of RFC 822.
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

address

protected String address

personal

protected String personal
The personal name.

encodedPersonal

protected String encodedPersonal
The RFC 2047 encoded version of the personal name.

This field and the personal field track each other, so if a subclass sets one of these fields directly, it should set the other to null, so that it is suitably recomputed.

Constructor Detail

InternetAddress

public InternetAddress()
Default constructor.

InternetAddress

public InternetAddress(String address)
                throws AddressException
Constructor.

Parse the given string and create an InternetAddress. See the parse method for details of the parsing. The address is parsed using "strict" parsing.

Parameters:
address - the address in RFC822 format
Throws:
AddressException - if the parse failed

InternetAddress

public InternetAddress(String address,
                       boolean strict)
                throws AddressException
Parse the given string and create an InternetAddress. If strict is false, the detailed syntax of the address isn't checked.

Parameters:
address - the address in RFC822 format
strict - enforce RFC822 syntax
Throws:
AddressException - if the parse failed
Since:
JavaMail 1.3

InternetAddress

public InternetAddress(String address,
                       String personal)
                throws UnsupportedEncodingException
Construct an InternetAddress given the address and personal name. The address is assumed to be a syntactically valid RFC822 address.

Parameters:
address - the address in RFC822 format
personal - the personal name

InternetAddress

public InternetAddress(String address,
                       String personal,
                       String charset)
                throws UnsupportedEncodingException
Construct an InternetAddress given the address and personal name. The address is assumed to be a syntactically valid RFC822 address.

Parameters:
address - the address in RFC822 format
personal - the personal name
charset - the MIME charset for the name
Method Detail

clone

public Object clone()
Return a copy of this InternetAddress object.

Since:
JavaMail 1.2

getType

public String getType()
Return the type of this address. The type of an InternetAddress is "rfc822".

Specified by:
getType in class Address
Returns:
address type
See Also:
InternetAddress

setAddress

public void setAddress(String address)
Set the email address.

Parameters:
address - email address

setPersonal

public void setPersonal(String name,
                        String charset)
                 throws UnsupportedEncodingException
Set the personal name. If the name contains non US-ASCII characters, then the name will be encoded using the specified charset as per RFC 2047. If the name contains only US-ASCII characters, no encoding is done and the name is used as is.

Parameters:
name - personal name
charset - MIME charset to be used to encode the name as per RFC 2047
Throws:
UnsupportedEncodingException - if the charset encoding fails.
See Also:
setPersonal(String)

setPersonal

public void setPersonal(String name)
                 throws UnsupportedEncodingException
Set the personal name. If the name contains non US-ASCII characters, then the name will be encoded using the platform's default charset. If the name contains only US-ASCII characters, no encoding is done and the name is used as is.

Parameters:
name - personal name
Throws:
UnsupportedEncodingException - if the charset encoding fails.
See Also:
setPersonal(String name, String charset)

getAddress

public String getAddress()
Get the email address.

Returns:
email address

getPersonal

public String getPersonal()
Get the personal name. If the name is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as is.

Returns:
personal name

toString

public String toString()
Convert this address into a RFC 822 / RFC 2047 encoded address. The resulting string contains only US-ASCII characters, and hence is mail-safe.

Specified by:
toString in class Address
Returns:
possibly encoded address string

toUnicodeString

public String toUnicodeString()
Returns a properly formatted address (RFC 822 syntax) of Unicode characters.

Returns:
Unicode address string
Since:
JavaMail 1.2

equals

public boolean equals(Object a)
The equality operator.

Specified by:
equals in class Address
Parameters:
a - Address object

hashCode

public int hashCode()
Compute a hash code for the address.

toString

public static String toString(Address[] addresses)
Convert the given array of InternetAddress objects into a comma separated sequence of address strings. The resulting string contains only US-ASCII characters, and hence is mail-safe.

Parameters:
addresses - array of InternetAddress objects
Returns:
comma separated string of addresses
Throws:
ClassCastException, - if any address object in the given array is not an InternetAddress object. Note that this is a RuntimeException.

toString

public static String toString(Address[] addresses,
                              int used)
Convert the given array of InternetAddress objects into a comma separated sequence of address strings. The resulting string contains only US-ASCII characters, and hence is mail-safe.

The 'used' parameter specifies the number of character positions already taken up in the field into which the resulting address sequence string is to be inserted. It is used to determine the line-break positions in the resulting address sequence string.

Parameters:
addresses - array of InternetAddress objects
used - number of character positions already used, in the field into which the address string is to be inserted.
Returns:
comma separated string of addresses
Throws:
ClassCastException, - if any address object in the given array is not an InternetAddress object. Note that this is a RuntimeException.

getLocalAddress

public static InternetAddress getLocalAddress(Session session)
Return an InternetAddress object representing the current user. The entire email address may be specified in the "mail.from" property. If not set, the "mail.user" and "mail.host" properties are tried. If those are not set, the "user.name" property and InetAddress.getLocalHost method are tried. Security exceptions that may occur while accessing this information are ignored. If it is not possible to determine an email address, null is returned.

Parameters:
session - Session object used for property lookup
Returns:
current user's email address

parse

public static InternetAddress[] parse(String addresslist)
                               throws AddressException
Parse the given comma separated sequence of addresses into InternetAddress objects. Addresses must follow RFC822 syntax.

Parameters:
addresslist - comma separated address strings
Returns:
array of InternetAddress objects
Throws:
AddressException - if the parse failed

parse

public static InternetAddress[] parse(String addresslist,
                                      boolean strict)
                               throws AddressException
Parse the given sequence of addresses into InternetAddress objects. If strict is false, simple email addresses separated by spaces are also allowed. If strict is true, many (but not all) of the RFC822 syntax rules are enforced. In particular, even if strict is true, addresses composed of simple names (with no "@domain" part) are allowed. Such "illegal" addresses are not uncommon in real messages.

Non-strict parsing is typically used when parsing a list of mail addresses entered by a human. Strict parsing is typically used when parsing address headers in mail messages.

Parameters:
addresslist - comma separated address strings
strict - enforce RFC822 syntax
Returns:
array of InternetAddress objects
Throws:
AddressException - if the parse failed

parseHeader

public static InternetAddress[] parseHeader(String addresslist,
                                            boolean strict)
                                     throws AddressException
Parse the given sequence of addresses into InternetAddress objects. If strict is false, the full syntax rules for individual addresses are not enforced. If strict is true, many (but not all) of the RFC822 syntax rules are enforced.

To better support the range of "invalid" addresses seen in real messages, this method enforces fewer syntax rules than the parse method when the strict flag is false and enforces more rules when the strict flag is true. If the strict flag is false and the parse is successful in separating out an email address or addresses, the syntax of the addresses themselves is not checked.

Parameters:
addresslist - comma separated address strings
strict - enforce RFC822 syntax
Returns:
array of InternetAddress objects
Throws:
AddressException - if the parse failed
Since:
JavaMail 1.3

validate

public void validate()
              throws AddressException
Validate that this address conforms to the syntax rules of RFC 822. The current implementation checks many, but not all, syntax rules. Note that even though the syntax of the address may be correct, there's no guarantee that a mailbox of that name exists.

Throws:
AddressException - if the address isn't valid.
Since:
JavaMail 1.3

isGroup

public boolean isGroup()
Indicates whether this address is an RFC 822 group address. Note that a group address is different than the mailing list addresses supported by most mail servers. Group addresses are rarely used; see RFC 822 for details.

Returns:
true if this address represents a group
Since:
JavaMail 1.3

getGroup

public InternetAddress[] getGroup(boolean strict)
                           throws AddressException
Return the members of a group address. A group may have zero, one, or more members. If this address is not a group, null is returned. The strict parameter controls whether the group list is parsed using strict RFC 822 rules or not. The parsing is done using the parseHeader method.

Returns:
array of InternetAddress objects, or null
Throws:
AddressException - if the group list can't be parsed
Since:
JavaMail 1.3
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InternetHeaders

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class InternetHeaders

java.lang.Object
    extended by javax.mail.internet.InternetHeaders
public class InternetHeaders
extends Object

InternetHeaders is a utility class that manages RFC822 style headers. Given an RFC822 format message stream, it reads lines until the blank line that indicates end of header. The input stream is positioned at the start of the body. The lines are stored within the object and can be extracted as either Strings or Header objects.

This class is mostly intended for service providers. MimeMessage and MimeBody use this class for holding their headers.

A note on RFC822 and MIME headers

RFC822 and MIME header fields must contain only US-ASCII characters. If a header contains non US-ASCII characters, it must be encoded as per the rules in RFC 2047. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

Author:
John Mani, Bill Shannon
See Also:
MimeUtility

Constructor Summary
InternetHeaders()
Create an empty InternetHeaders object.
InternetHeaders(InputStream is)
Read and parse the given RFC822 message stream till the blank line separating the header from the body.
Method Summary
void | addHeader(String name, String value) Add a header with the specified name and value to the header list.
void | addHeaderLine(String line) Add an RFC822 header line to the header store.
Enumeration | getAllHeaderLines() Return all the header lines as an Enumeration of Strings.
Enumeration | getAllHeaders() Return all the headers as an Enumeration of Header objects.
String[] | getHeader(String name) Return all the values for the specified header.
String | getHeader(String name, String delimiter) Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
Enumeration | getMatchingHeaderLines(String[] names) Return all matching header lines as an Enumeration of Strings.
Enumeration | getMatchingHeaders(String[] names) Return all matching Header objects.
Enumeration | getNonMatchingHeaderLines(String[] names) Return all non-matching header lines
Enumeration | getNonMatchingHeaders(String[] names) Return all non-matching Header objects.
void | load(InputStream is) Read and parse the given RFC822 message stream till the blank line separating the header from the body.
void | removeHeader(String name) Remove all header entries that match the given name
void | setHeader(String name, String value) Change the first header line that matches name to have value, adding a new header if no existing header matches.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InternetHeaders

public InternetHeaders()
Create an empty InternetHeaders object.

InternetHeaders

public InternetHeaders(InputStream is)
                throws MessagingException
Read and parse the given RFC822 message stream till the blank line separating the header from the body. The input stream is left positioned at the start of the body. The header lines are stored internally.

For efficiency, wrap a BufferedInputStream around the actual input stream and pass it as the parameter.

Parameters:
is - RFC822 input stream
Method Detail

load

public void load(InputStream is)
          throws MessagingException
Read and parse the given RFC822 message stream till the blank line separating the header from the body. Store the header lines inside this InternetHeaders object.

Note that the header lines are added into this InternetHeaders object, so any existing headers in this object will not be affected.

Parameters:
is - RFC822 input stream
Throws:
MessagingException

getHeader

public String[] getHeader(String name)
Return all the values for the specified header. The values are String objects. Returns null if no headers with the specified name exist.

Parameters:
name - header name
Returns:
array of header values, or null if none

getHeader

public String getHeader(String name,
                        String delimiter)
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter. If the delimiter is null, only the first header is returned. Returns null if no headers with the specified name exist.

Parameters:
name - header name
delimiter - delimiter
Returns:
the value fields for all headers with this name, or null if none

setHeader

public void setHeader(String name,
                      String value)
Change the first header line that matches name to have value, adding a new header if no existing header matches. Remove all matching headers but the first.

Note that RFC822 headers can only contain US-ASCII characters

Parameters:
name - header name
value - header value

addHeader

public void addHeader(String name,
                      String value)
Add a header with the specified name and value to the header list.

Note that RFC822 headers can only contain US-ASCII characters.

Parameters:
name - header name
value - header value

removeHeader

public void removeHeader(String name)
Remove all header entries that match the given name

Parameters:
name - header name

getAllHeaders

public Enumeration getAllHeaders()
Return all the headers as an Enumeration of Header objects.

Returns:
Header objects

getMatchingHeaders

public Enumeration getMatchingHeaders(String[] names)
Return all matching Header objects.

Returns:
matching Header objects

getNonMatchingHeaders

public Enumeration getNonMatchingHeaders(String[] names)
Return all non-matching Header objects.

Returns:
non-matching Header objects

addHeaderLine

public void addHeaderLine(String line)
Add an RFC822 header line to the header store. If the line starts with a space or tab (a continuation line), add it to the last header line in the list.

Note that RFC822 headers can only contain US-ASCII characters

Parameters:
line - raw RFC822 header line

getAllHeaderLines

public Enumeration getAllHeaderLines()
Return all the header lines as an Enumeration of Strings.

getMatchingHeaderLines

public Enumeration getMatchingHeaderLines(String[] names)
Return all matching header lines as an Enumeration of Strings.

getNonMatchingHeaderLines

public Enumeration getNonMatchingHeaderLines(String[] names)
Return all non-matching header lines

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MailDateFormat

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MailDateFormat

java.lang.Object
    extended by java.text.Format
        extended by java.text.DateFormat
            extended by java.text.SimpleDateFormat
                extended by javax.mail.internet.MailDateFormat
All Implemented Interfaces:
Cloneable, Serializable
public class MailDateFormat
extends SimpleDateFormat

Formats and parses date specification based on the draft-ietf-drums-msg-fmt-08 dated January 26, 2000. This is a followup spec to RFC822.

This class does not take pattern strings. It always formats the date based on the specification below.

3.3 Date and Time Specification

Date and time occur in several header fields of a message. This section specifies the syntax for a full date and time specification. Though folding whitespace is permitted throughout the date-time specification, it is recommended that only a single space be used where FWS is required and no space be used where FWS is optional in the date-time specification; some older implementations may not interpret other occurrences of folding whitespace correctly.

date-time = [ day-of-week "," ] date FWS time [CFWS]

day-of-week = ([FWS] day-name) / obs-day-of-week

day-name = "Mon" / "Tue" / "Wed" / "Thu" / "Fri" / "Sat" / "Sun"

date = day month year

year = 4*DIGIT / obs-year

month = (FWS month-name FWS) / obs-month

month-name = "Jan" / "Feb" / "Mar" / "Apr" /
             "May" / "Jun" / "Jul" / "Aug" /
             "Sep" / "Oct" / "Nov" / "Dec"

day = ([FWS] 1*2DIGIT) / obs-day

time = time-of-day FWS zone

time-of-day = hour ":" minute [ ":" second ]

hour = 2DIGIT / obs-hour

minute = 2DIGIT / obs-minute

second = 2DIGIT / obs-second

zone = (( "+" / "-" ) 4DIGIT) / obs-zone

The day is the numeric day of the month. The year is any numeric year in the common era.

The time-of-day specifies the number of hours, minutes, and optionally seconds since midnight of the date indicated.

The date and time-of-day SHOULD express local time.

The zone specifies the offset from Coordinated Universal Time (UTC, formerly referred to as "Greenwich Mean Time") that the date and time-of-day represent. The "+" or "-" indicates whether the time-of-day is ahead of or behind Universal Time. The first two digits indicate the number of hours difference from Universal Time, and the last two digits indicate the number of minutes difference from Universal Time. (Hence, +hhmm means +(hh * 60 + mm) minutes, and -hhmm means -(hh * 60 + mm) minutes). The form "+0000" SHOULD be used to indicate a time zone at Universal Time. Though "-0000" also indicates Universal Time, it is used to indicate that the time was generated on a system that may be in a local time zone other than Universal Time.

A date-time specification MUST be semantically valid. That is, the day-of-the week (if included) MUST be the day implied by the date, the numeric day-of-month MUST be between 1 and the number of days allowed for the specified month (in the specified year), the time-of-day MUST be in the range 00:00:00 through 23:59:60 (the number of seconds allowing for a leap second; see [STD-12]), and the zone MUST be within the range -9959 through +9959.

Since:
JavaMail 1.2
Author:
Max Spivak
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class java.text.DateFormat
DateFormat.Field
Field Summary
Fields inherited from class java.text.DateFormat
AM_PM_FIELD, calendar, DATE_FIELD, DAY_OF_WEEK_FIELD, DAY_OF_WEEK_IN_MONTH_FIELD, DAY_OF_YEAR_FIELD, DEFAULT, ERA_FIELD, FULL, HOUR_OF_DAY0_FIELD, HOUR_OF_DAY1_FIELD, HOUR0_FIELD, HOUR1_FIELD, LONG, MEDIUM, MILLISECOND_FIELD, MINUTE_FIELD, MONTH_FIELD, numberFormat, SECOND_FIELD, SHORT, TIMEZONE_FIELD, WEEK_OF_MONTH_FIELD, WEEK_OF_YEAR_FIELD, YEAR_FIELD
Constructor Summary
MailDateFormat()
Method Summary
StringBuffer | format(Date date, StringBuffer dateStrBuf, FieldPosition fieldPosition) Formats the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.
Date | parse(String text, ParsePosition pos) Parses the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.
void | setCalendar(Calendar newCalendar) Don't allow setting the calendar
void | setNumberFormat(NumberFormat newNumberFormat) Don't allow setting the NumberFormat
Methods inherited from class java.text.SimpleDateFormat
applyLocalizedPattern, applyPattern, clone, equals, formatToCharacterIterator, get2DigitYearStart, getDateFormatSymbols, hashCode, set2DigitYearStart, setDateFormatSymbols, toLocalizedPattern, toPattern
Methods inherited from class java.text.DateFormat
format, format, getAvailableLocales, getCalendar, getDateInstance, getDateInstance, getDateInstance, getDateTimeInstance, getDateTimeInstance, getDateTimeInstance, getInstance, getNumberFormat, getTimeInstance, getTimeInstance, getTimeInstance, getTimeZone, isLenient, parse, parseObject, setLenient, setTimeZone
Methods inherited from class java.text.Format
format, parseObject
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MailDateFormat

public MailDateFormat()
Method Detail

format

public StringBuffer format(Date date,
                           StringBuffer dateStrBuf,
                           FieldPosition fieldPosition)
Formats the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.

Parameters:
date - the Date object
dateStrBuf - the formatted string
fieldPosition - the current field position
Returns:
StringBuffer the formatted String
Since:
JavaMail 1.2

parse

public Date parse(String text,
                  ParsePosition pos)
Parses the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.

Parameters:
text - the formatted date to be parsed
pos - the current parse position
Returns:
Date the parsed date in a Date object
Since:
JavaMail 1.2

setCalendar

public void setCalendar(Calendar newCalendar)
Don't allow setting the calendar

setNumberFormat

public void setNumberFormat(NumberFormat newNumberFormat)
Don't allow setting the NumberFormat

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimeBodyPart

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimeBodyPart

java.lang.Object
    extended by javax.mail.BodyPart
        extended by javax.mail.internet.MimeBodyPart
All Implemented Interfaces:
MimePart, Part
public class MimeBodyPart
extends BodyPart
implements MimePart

This class represents a MIME body part. It implements the BodyPart abstract class and the MimePart interface. MimeBodyParts are contained in MimeMultipart objects.

MimeBodyPart uses the InternetHeaders class to parse and store the headers of that body part.

A note on RFC 822 and MIME headers

RFC 822 header fields must contain only US-ASCII characters. MIME allows non ASCII characters to be present in certain portions of certain headers, by encoding those characters. RFC 2047 specifies the rules for doing this. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

Author:
John Mani, Bill Shannon
See Also:
Part, MimePart, MimeUtility

Field Summary
protected byte[] | content Byte array that holds the bytes of the content of this Part.
protected InputStream | contentStream If the data for this body part was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this body part.
protected DataHandler | dh The DataHandler object representing this Part's content.
protected InternetHeaders | headers The InternetHeaders object that stores all the headers of this body part.
Fields inherited from class javax.mail.BodyPart
parent
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Constructor Summary
MimeBodyPart()
An empty MimeBodyPart object is created.
MimeBodyPart(InputStream is)
Constructs a MimeBodyPart by reading and parsing the data from the specified input stream.
MimeBodyPart(InternetHeaders headers, byte[] content)
Constructs a MimeBodyPart using the given header and content bytes.
Method Summary
void | addHeader(String name, String value) Add this value to the existing values for this header_name.
void | addHeaderLine(String line) Add a header line to this body part
Enumeration | getAllHeaderLines() Get all header lines as an Enumeration of Strings.
Enumeration | getAllHeaders() Return all the headers from this Message as an Enumeration of Header objects.
Object | getContent() Return the content as a java object.
String | getContentID() Returns the value of the "Content-ID" header field.
String[] | getContentLanguage() Get the languages specified in the Content-Language header of this MimePart.
String | getContentMD5() Return the value of the "Content-MD5" header field.
protected InputStream | getContentStream() Produce the raw bytes of the content.
String | getContentType() Returns the value of the RFC 822 "Content-Type" header field.
DataHandler | getDataHandler() Return a DataHandler for this body part's content.
String | getDescription() Returns the "Content-Description" header field of this body part.
String | getDisposition() Returns the value of the "Content-Disposition" header field.
String | getEncoding() Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
String | getFileName() Get the filename associated with this body part.
String[] | getHeader(String name) Get all the headers for this header_name.
String | getHeader(String name, String delimiter) Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
InputStream | getInputStream() Return a decoded input stream for this body part's "content".
int | getLineCount() Return the number of lines for the content of this Part.
Enumeration | getMatchingHeaderLines(String[] names) Get matching header lines as an Enumeration of Strings.
Enumeration | getMatchingHeaders(String[] names) Return matching headers from this Message as an Enumeration of Header objects.
Enumeration | getNonMatchingHeaderLines(String[] names) Get non-matching header lines as an Enumeration of Strings.
Enumeration | getNonMatchingHeaders(String[] names) Return non-matching headers from this Message as an Enumeration of Header objects.
InputStream | getRawInputStream() Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
int | getSize() Return the size of the content of this body part in bytes.
boolean | isMimeType(String mimeType) Is this Part of the specified MIME type?
void | removeHeader(String name) Remove all headers with this name.
void | setContent(Multipart mp) This method sets the body part's content to a Multipart object.
void | setContent(Object o, String type) A convenience method for setting this body part's content.
void | setContentID(String cid) Set the "Content-ID" header field of this body part.
void | setContentLanguage(String[] languages) Set the Content-Language header of this MimePart.
void | setContentMD5(String md5) Set the "Content-MD5" header field of this body part.
void | setDataHandler(DataHandler dh) This method provides the mechanism to set this body part's content.
void | setDescription(String description) Set the "Content-Description" header field for this body part.
void | setDescription(String description, String charset) Set the "Content-Description" header field for this body part.
void | setDisposition(String disposition) Set the "Content-Disposition" header field of this body part.
void | setFileName(String filename) Set the filename associated with this body part, if possible.
void | setHeader(String name, String value) Set the value for this header_name.
void | setText(String text) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
void | setText(String text, String charset) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
protected void | updateHeaders() Examine the content of this body part and update the appropriate MIME headers.
void | writeTo(OutputStream os) Output the body part as an RFC 822 format stream.
Methods inherited from class javax.mail.BodyPart
getParent
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

dh

protected DataHandler dh
The DataHandler object representing this Part's content.

content

protected byte[] content
Byte array that holds the bytes of the content of this Part.

contentStream

protected InputStream contentStream
If the data for this body part was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this body part. In this case, content will be null.

Since:
JavaMail 1.2

headers

protected InternetHeaders headers
The InternetHeaders object that stores all the headers of this body part.

Constructor Detail

MimeBodyPart

public MimeBodyPart()
An empty MimeBodyPart object is created. This body part maybe filled in by a client constructing a multipart message.

MimeBodyPart

public MimeBodyPart(InputStream is)
             throws MessagingException
Constructs a MimeBodyPart by reading and parsing the data from the specified input stream. The parser consumes data till the end of the given input stream. The input stream must start at the beginning of a valid MIME body part and must terminate at the end of that body part.

Note that the "boundary" string that delimits body parts must not be included in the input stream. The intention is that the MimeMultipart parser will extract each body part's bytes from a multipart stream and feed them into this constructor, without the delimiter strings.

Parameters:
is - the body part Input Stream

MimeBodyPart

public MimeBodyPart(InternetHeaders headers,
                    byte[] content)
             throws MessagingException
Constructs a MimeBodyPart using the given header and content bytes.

Used by providers.

Parameters:
headers - The header of this part
content - bytes representing the body of this part.
Method Detail

getSize

public int getSize()
            throws MessagingException
Return the size of the content of this body part in bytes. Return -1 if the size cannot be determined.

Note that this number may not be an exact measure of the content size and may or may not account for any transfer encoding of the content.

This implementation returns the size of the content array (if not null), or, if contentStream is not null, and the available method returns a positive number, it returns that number as the size. Otherwise, it returns -1.

Specified by:
getSize in interface Part
Returns:
size in bytes, or -1 if not known
Throws:
MessagingException

getLineCount

public int getLineCount()
                 throws MessagingException
Return the number of lines for the content of this Part. Return -1 if this number cannot be determined.

Note that this number may not be an exact measure of the content length and may or may not account for any transfer encoding of the content.

This implementation returns -1.

Specified by:
getLineCount in interface Part
Returns:
number of lines, or -1 if not known
Throws:
MessagingException

getContentType

public String getContentType()
                      throws MessagingException
Returns the value of the RFC 822 "Content-Type" header field. This represents the content type of the content of this body part. This value must not be null. If this field is unavailable, "text/plain" should be returned.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getContentType in interface Part
Returns:
Content-Type of this body part
Throws:
MessagingException
See Also:
DataHandler

isMimeType

public boolean isMimeType(String mimeType)
                   throws MessagingException
Is this Part of the specified MIME type? This method compares only the primaryType and subType. The parameters of the content types are ignored.

For example, this method will return true when comparing a Part of content type "text/plain" with "text/plain; charset=foobar".

If the subType of mimeType is the special character '*', then the subtype is ignored during the comparison.

Specified by:
isMimeType in interface Part
Throws:
MessagingException

getDisposition

public String getDisposition()
                      throws MessagingException
Returns the value of the "Content-Disposition" header field. This represents the disposition of this part. The disposition describes how the part should be presented to the user.

If the Content-Disposition field is unavailable, null is returned.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getDisposition in interface Part
Returns:
disposition of this part, or null if unknown
Throws:
MessagingException
See Also:
headers

setDisposition

public void setDisposition(String disposition)
                    throws MessagingException
Set the "Content-Disposition" header field of this body part. If the disposition is null, any existing "Content-Disposition" header field is removed.

Specified by:
setDisposition in interface Part
Parameters:
disposition - disposition of this part
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException
See Also:
Part.ATTACHMENT, Part.INLINE, Part.setFileName(java.lang.String)

getEncoding

public String getEncoding()
                   throws MessagingException
Returns the content transfer encoding from the "Content-Transfer-Encoding" header field. Returns null if the header is unavailable or its value is absent.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getEncoding in interface MimePart
Returns:
content-transfer-encoding
Throws:
MessagingException
See Also:
headers

getContentID

public String getContentID()
                    throws MessagingException
Returns the value of the "Content-ID" header field. Returns null if the field is unavailable or its value is absent.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getContentID in interface MimePart
Returns:
content-ID
Throws:
MessagingException

setContentID

public void setContentID(String cid)
                  throws MessagingException
Set the "Content-ID" header field of this body part. If the cid parameter is null, any existing "Content-ID" is removed.

Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException
Since:
JavaMail 1.3

getContentMD5

public String getContentMD5()
                     throws MessagingException
Return the value of the "Content-MD5" header field. Returns null if this field is unavailable or its value is absent.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getContentMD5 in interface MimePart
Returns:
content-MD5
Throws:
MessagingException

setContentMD5

public void setContentMD5(String md5)
                   throws MessagingException
Set the "Content-MD5" header field of this body part.

Specified by:
setContentMD5 in interface MimePart
Parameters:
md5 - the MD5 value
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException

getContentLanguage

public String[] getContentLanguage()
                            throws MessagingException
Get the languages specified in the Content-Language header of this MimePart. The Content-Language header is defined by RFC 1766. Returns null if this header is not available or its value is absent.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getContentLanguage in interface MimePart
Throws:
MessagingException

setContentLanguage

public void setContentLanguage(String[] languages)
                        throws MessagingException
Set the Content-Language header of this MimePart. The Content-Language header is defined by RFC 1766.

Specified by:
setContentLanguage in interface MimePart
Parameters:
languages - array of language tags
Throws:
MessagingException

getDescription

public String getDescription()
                      throws MessagingException
Returns the "Content-Description" header field of this body part. This typically associates some descriptive information with this part. Returns null if this field is unavailable or its value is absent.

If the Content-Description field is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as is.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getDescription in interface Part
Returns:
content description
Throws:
MessagingException

setDescription

public void setDescription(String description)
                    throws MessagingException
Set the "Content-Description" header field for this body part. If the description parameter is null, then any existing "Content-Description" fields are removed.

If the description contains non US-ASCII characters, it will be encoded using the platform's default charset. If the description contains only US-ASCII characters, no encoding is done and it is used as is.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Specified by:
setDescription in interface Part
Parameters:
description - content description
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException - otherwise; an UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.

setDescription

public void setDescription(String description,
                           String charset)
                    throws MessagingException
Set the "Content-Description" header field for this body part. If the description parameter is null, then any existing "Content-Description" fields are removed.

If the description contains non US-ASCII characters, it will be encoded using the specified charset. If the description contains only US-ASCII characters, no encoding is done and it is used as is.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Parameters:
description - Description
charset - Charset for encoding
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException - otherwise; an UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.

getFileName

public String getFileName()
                   throws MessagingException
Get the filename associated with this body part.

Returns the value of the "filename" parameter from the "Content-Disposition" header field of this body part. If its not available, returns the value of the "name" parameter from the "Content-Type" header field of this body part. Returns null if both are absent.

Specified by:
getFileName in interface Part
Returns:
filename
Throws:
MessagingException

setFileName

public void setFileName(String filename)
                 throws MessagingException
Set the filename associated with this body part, if possible.

Sets the "filename" parameter of the "Content-Disposition" header field of this body part.

Specified by:
setFileName in interface Part
Parameters:
filename - Filename to associate with this part
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException

getInputStream

public InputStream getInputStream()
                           throws IOException,
                                  MessagingException
Return a decoded input stream for this body part's "content".

This implementation obtains the input stream from the DataHandler. That is, it invokes getDataHandler().getInputStream();

Specified by:
getInputStream in interface Part
Returns:
an InputStream
Throws:
MessagingException
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
See Also:
getContentStream(), DataHandler.getInputStream()

getContentStream

protected InputStream getContentStream()
                                throws MessagingException
Produce the raw bytes of the content. This method is used when creating a DataHandler object for the content. Subclasses that can provide a separate input stream for just the Part content might want to override this method.

Throws:
MessagingException
See Also:
content, MimeMessage.getContentStream()

getRawInputStream

public InputStream getRawInputStream()
                              throws MessagingException
Return an InputStream to the raw data with any Content-Transfer-Encoding intact. This method is useful if the "Content-Transfer-Encoding" header is incorrect or corrupt, which would prevent the getInputStream method or getContent method from returning the correct data. In such a case the application may use this method and attempt to decode the raw data itself.

This implementation simply calls the getContentStream method.

Throws:
MessagingException
Since:
JavaMail 1.2
See Also:
getInputStream(), getContentStream()

getDataHandler

public DataHandler getDataHandler()
                           throws MessagingException
Return a DataHandler for this body part's content.

The implementation provided here works just like the the implementation in MimeMessage.

Specified by:
getDataHandler in interface Part
Returns:
DataHandler for the content
Throws:
MessagingException
See Also:
MimeMessage.getDataHandler()

getContent

public Object getContent()
                  throws IOException,
                         MessagingException
Return the content as a java object. The type of the object returned is of course dependent on the content itself. For example, the native format of a text/plain content is usually a String object. The native format for a "multipart" content is always a Multipart subclass. For content types that are unknown to the DataHandler system, an input stream is returned as the content.

This implementation obtains the content from the DataHandler. That is, it invokes getDataHandler().getContent();

Specified by:
getContent in interface Part
Returns:
Object
Throws:
MessagingException
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
See Also:
DataHandler.getContent()

setDataHandler

public void setDataHandler(DataHandler dh)
                    throws MessagingException
This method provides the mechanism to set this body part's content. The given DataHandler object should wrap the actual content.

Specified by:
setDataHandler in interface Part
Parameters:
dh - The DataHandler for the content
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException

setContent

public void setContent(Object o,
                       String type)
                throws MessagingException
A convenience method for setting this body part's content.

The content is wrapped in a DataHandler object. Note that a DataContentHandler class for the specified type should be available to the JavaMail implementation for this to work right. That is, to do setContent(foobar, "application/x-foobar"), a DataContentHandler for "application/x-foobar" should be installed. Refer to the Java Activation Framework for more information.

Specified by:
setContent in interface Part
Parameters:
o - the content object
type - Mime type of the object
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException

setText

public void setText(String text)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain". If the string contains non US-ASCII characters, it will be encoded using the platform's default charset. The charset is also used to set the "charset" parameter.

Note that there may be a performance penalty if text is large, since this method may have to scan all the characters to determine what charset to use.

If the charset is already known, use the setText() version that takes the charset parameter.

Specified by:
setText in interface MimePart
Throws:
MessagingException
See Also:
setText(String text, String charset)

setText

public void setText(String text,
                    String charset)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.

Specified by:
setText in interface MimePart
Throws:
MessagingException

setContent

public void setContent(Multipart mp)
                throws MessagingException
This method sets the body part's content to a Multipart object.

Specified by:
setContent in interface Part
Parameters:
mp - The multipart object that is the Message's content
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values.
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException

writeTo

public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
Output the body part as an RFC 822 format stream.

Specified by:
writeTo in interface Part
Throws:
MessagingException
IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
See Also:
DataHandler.writeTo(java.io.OutputStream)

getHeader

public String[] getHeader(String name)
                   throws MessagingException
Get all the headers for this header_name. Note that certain headers may be encoded as per RFC 2047 if they contain non US-ASCII characters and these should be decoded.

Specified by:
getHeader in interface Part
Parameters:
name - name of header
Returns:
array of headers
Throws:
MessagingException
See Also:
MimeUtility

getHeader

public String getHeader(String name,
                        String delimiter)
                 throws MessagingException
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter. If the delimiter is null, only the first header is returned.

Specified by:
getHeader in interface MimePart
Parameters:
name - the name of this header
delimiter - delimiter between fields in returned string
Returns:
the value fields for all headers with this name
Throws:
MessagingException

setHeader

public void setHeader(String name,
                      String value)
               throws MessagingException
Set the value for this header_name. Replaces all existing header values with this new value. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must be encoded as per the rules of RFC 2047.

Specified by:
setHeader in interface Part
Parameters:
name - header name
value - header value
Throws:
MessagingException
See Also:
MimeUtility

addHeader

public void addHeader(String name,
                      String value)
               throws MessagingException
Add this value to the existing values for this header_name. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must be encoded as per the rules of RFC 2047.

Specified by:
addHeader in interface Part
Parameters:
name - header name
value - header value
Throws:
MessagingException
See Also:
MimeUtility

removeHeader

public void removeHeader(String name)
                  throws MessagingException
Remove all headers with this name.

Specified by:
removeHeader in interface Part
Parameters:
name - the name of this header
Throws:
MessagingException

getAllHeaders

public Enumeration getAllHeaders()
                          throws MessagingException
Return all the headers from this Message as an Enumeration of Header objects.

Specified by:
getAllHeaders in interface Part
Returns:
enumeration of Header objects
Throws:
MessagingException

getMatchingHeaders

public Enumeration getMatchingHeaders(String[] names)
                               throws MessagingException
Return matching headers from this Message as an Enumeration of Header objects.

Specified by:
getMatchingHeaders in interface Part
Returns:
enumeration of Header objects
Throws:
MessagingException

getNonMatchingHeaders

public Enumeration getNonMatchingHeaders(String[] names)
                                  throws MessagingException
Return non-matching headers from this Message as an Enumeration of Header objects.

Specified by:
getNonMatchingHeaders in interface Part
Returns:
enumeration of Header objects
Throws:
MessagingException

addHeaderLine

public void addHeaderLine(String line)
                   throws MessagingException
Add a header line to this body part

Specified by:
addHeaderLine in interface MimePart
Throws:
MessagingException

getAllHeaderLines

public Enumeration getAllHeaderLines()
                              throws MessagingException
Get all header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header line, containing both the "name" and "value" field.

Specified by:
getAllHeaderLines in interface MimePart
Throws:
MessagingException

getMatchingHeaderLines

public Enumeration getMatchingHeaderLines(String[] names)
                                   throws MessagingException
Get matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header line, containing both the "name" and "value" field.

Specified by:
getMatchingHeaderLines in interface MimePart
Throws:
MessagingException

getNonMatchingHeaderLines

public Enumeration getNonMatchingHeaderLines(String[] names)
                                      throws MessagingException
Get non-matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header line, containing both the "name" and "value" field.

Specified by:
getNonMatchingHeaderLines in interface MimePart
Throws:
MessagingException

updateHeaders

protected void updateHeaders()
                      throws MessagingException
Examine the content of this body part and update the appropriate MIME headers. Typical headers that get set here are Content-Type and Content-Transfer-Encoding. Headers might need to be updated in two cases:
- A message being crafted by a mail application will certainly need to activate this method at some point to fill up its internal headers.
- A message read in from a Store will have obtained all its headers from the store, and so doesn't need this. However, if this message is editable and if any edits have been made to either the content or message structure, we might need to resync our headers.
In both cases this method is typically called by the Message.saveChanges method.

Throws:
MessagingException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimeMessage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimeMessage

java.lang.Object
    extended by javax.mail.Message
        extended by javax.mail.internet.MimeMessage
All Implemented Interfaces:
MimePart, Part
public class MimeMessage
extends Message
implements MimePart

This class represents a MIME style email message. It implements the Message abstract class and the MimePart interface.

Clients wanting to create new MIME style messages will instantiate an empty MimeMessage object and then fill it with appropriate attributes and content.

Service providers that implement MIME compliant backend stores may want to subclass MimeMessage and override certain methods to provide specific implementations. The simplest case is probably a provider that generates a MIME style input stream and leaves the parsing of the stream to this class.

MimeMessage uses the InternetHeaders class to parse and store the top level RFC 822 headers of a message.

The mail.mime.address.strict session property controls the parsing of address headers. By default, strict parsing of address headers is done. If this property is set to "false", strict parsing is not done and many illegal addresses that sometimes occur in real messages are allowed. See the InternetAddress class for details.

A note on RFC 822 and MIME headers

RFC 822 header fields must contain only US-ASCII characters. MIME allows non ASCII characters to be present in certain portions of certain headers, by encoding those characters. RFC 2047 specifies the rules for doing this. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

Author:
John Mani, Bill Shannon, Max Spivak
See Also:
MimeUtility, Part, Message, MimePart, InternetAddress

Nested Class Summary
static class MimeMessage.RecipientType
This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes.
Field Summary
protected byte[] | content Byte array that holds the bytes of this Message's content.
protected InputStream | contentStream If the data for this message was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this message.
protected DataHandler | dh The DataHandler object representing this Message's content.
protected Flags | flags The Flags for this message.
protected InternetHeaders | headers The InternetHeaders object that stores the header of this message.
protected boolean | modified A flag indicating whether the message has been modified.
protected boolean | saved Does the saveChanges method need to be called on this message?
Fields inherited from class javax.mail.Message
expunged, folder, msgnum, session
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Constructor Summary
protected | MimeMessage(Folder folder, InputStream is, int msgnum) Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.
protected | MimeMessage(Folder folder, int msgnum) Constructs an empty MimeMessage object with the given Folder and message number.
protected | MimeMessage(Folder folder, InternetHeaders headers, byte[] content, int msgnum) Constructs a MimeMessage from the given InternetHeaders object and content.
 | MimeMessage(MimeMessage source) Constructs a new MimeMessage with content initialized from the source MimeMessage.
 | MimeMessage(Session session) Default constructor.
 | MimeMessage(Session session, InputStream is) Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.
Method Summary
void | addFrom(Address[] addresses) Add the specified addresses to the existing "From" field.
void | addHeader(String name, String value) Add this value to the existing values for this header_name.
void | addHeaderLine(String line) Add a raw RFC 822 header-line.
void | addRecipients(Message.RecipientType type, Address[] addresses) Add the given addresses to the specified recipient type.
void | addRecipients(Message.RecipientType type, String addresses) Add the given addresses to the specified recipient type.
protected InternetHeaders | createInternetHeaders(InputStream is) Create and return an InternetHeaders object that loads the headers from the given InputStream.
Enumeration | getAllHeaderLines() Get all header lines as an Enumeration of Strings.
Enumeration | getAllHeaders() Return all the headers from this Message as an enumeration of Header objects.
Address[] | getAllRecipients() Get all the recipient addresses for the message.
Object | getContent() Return the content as a Java object.
String | getContentID() Returns the value of the "Content-ID" header field.
String[] | getContentLanguage() Get the languages specified in the "Content-Language" header field of this message.
String | getContentMD5() Return the value of the "Content-MD5" header field.
protected InputStream | getContentStream() Produce the raw bytes of the content.
String | getContentType() Returns the value of the RFC 822 "Content-Type" header field.
DataHandler | getDataHandler() Return a DataHandler for this Message's content.
String | getDescription() Returns the "Content-Description" header field of this Message.
String | getDisposition() Returns the value of the "Content-Disposition" header field.
String | getEncoding() Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
String | getFileName() Get the filename associated with this Message.
Flags | getFlags() Return a Flags object containing the flags for this message.
Address[] | getFrom() Returns the value of the RFC 822 "From" header fields.
String[] | getHeader(String name) Get all the headers for this header_name.
String | getHeader(String name, String delimiter) Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
InputStream | getInputStream() Return a decoded input stream for this Message's "content".
int | getLineCount() Return the number of lines for the content of this message.
Enumeration | getMatchingHeaderLines(String[] names) Get matching header lines as an Enumeration of Strings.
Enumeration | getMatchingHeaders(String[] names) Return matching headers from this Message as an Enumeration of Header objects.
String | getMessageID() Returns the value of the "Message-ID" header field.
Enumeration | getNonMatchingHeaderLines(String[] names) Get non-matching header lines as an Enumeration of Strings.
Enumeration | getNonMatchingHeaders(String[] names) Return non-matching headers from this Message as an Enumeration of Header objects.
InputStream | getRawInputStream() Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
Date | getReceivedDate() Returns the Date on this message was received.
Address[] | getRecipients(Message.RecipientType type) Returns the recepients specified by the type.
Address[] | getReplyTo() Return the value of the RFC 822 "Reply-To" header field.
Address | getSender() Returns the value of the RFC 822 "Sender" header field.
Date | getSentDate() Returns the value of the RFC 822 "Date" field.
int | getSize() Return the size of the content of this message in bytes.
String | getSubject() Returns the value of the "Subject" header field.
boolean | isMimeType(String mimeType) Is this Part of the specified MIME type?
boolean | isSet(Flags.Flag flag) Check whether the flag specified in the flag argument is set in this message.
protected void | parse(InputStream is) Parse the InputStream setting the headers and content fields appropriately.
void | removeHeader(String name) Remove all headers with this name.
Message | reply(boolean replyToAll) Get a new Message suitable for a reply to this message.
void | saveChanges() Updates the appropriate header fields of this message to be consistent with the message's contents.
void | setContent(Multipart mp) This method sets the Message's content to a Multipart object.
void | setContent(Object o, String type) A convenience method for setting this Message's content.
void | setContentID(String cid) Set the "Content-ID" header field of this Message.
void | setContentLanguage(String[] languages) Set the "Content-Language" header of this MimePart.
void | setContentMD5(String md5) Set the "Content-MD5" header field of this Message.
void | setDataHandler(DataHandler dh) This method provides the mechanism to set this part's content.
void | setDescription(String description) Set the "Content-Description" header field for this Message.
void | setDescription(String description, String charset) Set the "Content-Description" header field for this Message.
void | setDisposition(String disposition) Set the "Content-Disposition" header field of this Message.
void | setFileName(String filename) Set the filename associated with this part, if possible.
void | setFlags(Flags flag, boolean set) Set the flags for this message.
void | setFrom() Set the RFC 822 "From" header field using the value of the InternetAddress.getLocalAddress method.
void | setFrom(Address address) Set the RFC 822 "From" header field.
void | setHeader(String name, String value) Set the value for this header_name.
void | setRecipients(Message.RecipientType type, Address[] addresses) Set the specified recipient type to the given addresses.
void | setRecipients(Message.RecipientType type, String addresses) Set the specified recipient type to the given addresses.
void | setReplyTo(Address[] addresses) Set the RFC 822 "Reply-To" header field.
void | setSender(Address address) Set the RFC 822 "Sender" header field.
void | setSentDate(Date d) Set the RFC 822 "Date" header field.
void | setSubject(String subject) Set the "Subject" header field.
void | setSubject(String subject, String charset) Set the "Subject" header field.
void | setText(String text) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
void | setText(String text, String charset) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
protected void | updateHeaders() Called by the saveChanges method to actually update the MIME headers.
void | writeTo(OutputStream os) Output the message as an RFC 822 format stream.
void | writeTo(OutputStream os, String[] ignoreList) Output the message as an RFC 822 format stream, without specified headers.
Methods inherited from class javax.mail.Message
addRecipient, getFolder, getMessageNumber, isExpunged, match, setExpunged, setFlag, setMessageNumber, setRecipient
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

dh

protected DataHandler dh
The DataHandler object representing this Message's content.

content

protected byte[] content
Byte array that holds the bytes of this Message's content.

contentStream

protected InputStream contentStream
If the data for this message was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this message. In this case, content will be null.

Since:
JavaMail 1.2

headers

protected InternetHeaders headers
The InternetHeaders object that stores the header of this message.

flags

protected Flags flags
The Flags for this message.

modified

protected boolean modified
A flag indicating whether the message has been modified. If the message has not been modified, any data in the content array is assumed to be valid and is used directly in the writeTo method. This flag is set to true when an empty message is created or when the saveChanges method is called.

Since:
JavaMail 1.2

saved

protected boolean saved
Does the saveChanges method need to be called on this message? This flag is set to false by the public constructor and set to true by the saveChanges method. The writeTo method checks this flag and calls the saveChanges method as necessary. This avoids the common mistake of forgetting to call the saveChanges method on a newly constructed message.

Since:
JavaMail 1.2
Constructor Detail

MimeMessage

public MimeMessage(Session session)
Default constructor. An empty message object is created. The headers field is set to an empty InternetHeaders object. The flags field is set to an empty Flags object. The modified flag is set to true.

MimeMessage

public MimeMessage(Session session,
                   InputStream is)
            throws MessagingException
Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream. The InputStream will be left positioned at the end of the data for the message. Note that the input stream parse is done within this constructor itself.

The input stream contains an entire MIME formatted message with headers and data.

Parameters:
session - Session object for this message
is - the message input stream
Throws:
MessagingException

MimeMessage

public MimeMessage(MimeMessage source)
            throws MessagingException
Constructs a new MimeMessage with content initialized from the source MimeMessage. The new message is independent of the original.

Note: The current implementation is rather inefficient, copying the data more times than strictly necessary.

Parameters:
source - the message to copy content from
Throws:
MessagingException
Since:
JavaMail 1.2

MimeMessage

protected MimeMessage(Folder folder,
                      int msgnum)
Constructs an empty MimeMessage object with the given Folder and message number.

This method is for providers subclassing MimeMessage.

MimeMessage

protected MimeMessage(Folder folder,
                      InputStream is,
                      int msgnum)
               throws MessagingException
Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream. The InputStream will be left positioned at the end of the data for the message. Note that the input stream parse is done within this constructor itself.

This method is for providers subclassing MimeMessage.

Parameters:
folder - The containing folder.
is - the message input stream
msgnum - Message number of this message within its folder
Throws:
MessagingException

MimeMessage

protected MimeMessage(Folder folder,
                      InternetHeaders headers,
                      byte[] content,
                      int msgnum)
               throws MessagingException
Constructs a MimeMessage from the given InternetHeaders object and content. This method is for providers subclassing MimeMessage.

Parameters:
folder - The containing folder.
headers - The headers
content - The message content
msgnum - Message number of this message within its folder
Throws:
MessagingException
Method Detail

parse

protected void parse(InputStream is)
              throws MessagingException
Parse the InputStream setting the headers and content fields appropriately. Also resets the modified flag.

This method is intended for use by subclasses that need to control when the InputStream is parsed.

Parameters:
is - The message input stream
Throws:
MessagingException

getFrom

public Address[] getFrom()
                  throws MessagingException
Returns the value of the RFC 822 "From" header fields. If this header field is absent, the "Sender" header field is used. If the "Sender" header field is also absent, null is returned.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getFrom in class Message
Returns:
Address object
Throws:
MessagingException
See Also:
headers

setFrom

public void setFrom(Address address)
             throws MessagingException
Set the RFC 822 "From" header field. Any existing values are replaced with the given address. If address is null, this header is removed.

Specified by:
setFrom in class Message
Parameters:
address - the sender of this message
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

setFrom

public void setFrom()
             throws MessagingException
Set the RFC 822 "From" header field using the value of the InternetAddress.getLocalAddress method.

Specified by:
setFrom in class Message
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

addFrom

public void addFrom(Address[] addresses)
             throws MessagingException
Add the specified addresses to the existing "From" field. If the "From" field does not already exist, it is created.

Specified by:
addFrom in class Message
Parameters:
addresses - the senders of this message
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getSender

public Address getSender()
                  throws MessagingException
Returns the value of the RFC 822 "Sender" header field. If the "Sender" header field is absent, null is returned.

This implementation uses the getHeader method to obtain the requisite header field.

Returns:
Address object
Throws:
MessagingException
Since:
JavaMail 1.3
See Also:
headers

setSender

public void setSender(Address address)
               throws MessagingException
Set the RFC 822 "Sender" header field. Any existing values are replaced with the given address. If address is null, this header is removed.

Parameters:
address - the sender of this message
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
Since:
JavaMail 1.3

getRecipients

public Address[] getRecipients(Message.RecipientType type)
                        throws MessagingException
Returns the recepients specified by the type. The mapping between the type and the corresponding RFC 822 header is as follows:
        Message.RecipientType.TO		"To"
        Message.RecipientType.CC		"Cc"
        Message.RecipientType.BCC		"Bcc"
        MimeMessage.RecipientType.NEWSGROUPS	"Newsgroups"

Returns null if the header specified by the type is not found or if its value is empty.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getRecipients in class Message
Parameters:
type - Type of recepient
Returns:
array of Address objects
Throws:
MessagingException - if header could not be retrieved
AddressException - if the header is misformatted
See Also:
headers, Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC, MimeMessage.RecipientType.NEWSGROUPS

getAllRecipients

public Address[] getAllRecipients()
                           throws MessagingException
Get all the recipient addresses for the message. Extracts the TO, CC, BCC, and NEWSGROUPS recipients.

Overrides:
getAllRecipients in class Message
Returns:
array of Address objects
Throws:
MessagingException
See Also:
Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC, MimeMessage.RecipientType.NEWSGROUPS

setRecipients

public void setRecipients(Message.RecipientType type,
                          Address[] addresses)
                   throws MessagingException
Set the specified recipient type to the given addresses. If the address parameter is null, the corresponding recipient field is removed.

Specified by:
setRecipients in class Message
Parameters:
type - Recipient type
addresses - Addresses
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
See Also:
getRecipients(javax.mail.Message.RecipientType)

setRecipients

public void setRecipients(Message.RecipientType type,
                          String addresses)
                   throws MessagingException
Set the specified recipient type to the given addresses. If the address parameter is null, the corresponding recipient field is removed.

Parameters:
type - Recipient type
addresses - Addresses
Throws:
AddressException - if the attempt to parse the addresses String fails
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
Since:
JavaMail 1.2
See Also:
getRecipients(javax.mail.Message.RecipientType)

addRecipients

public void addRecipients(Message.RecipientType type,
                          Address[] addresses)
                   throws MessagingException
Add the given addresses to the specified recipient type.

Specified by:
addRecipients in class Message
Parameters:
type - Recipient type
addresses - Addresses
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

addRecipients

public void addRecipients(Message.RecipientType type,
                          String addresses)
                   throws MessagingException
Add the given addresses to the specified recipient type.

Parameters:
type - Recipient type
addresses - Addresses
Throws:
AddressException - if the attempt to parse the addresses String fails
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
Since:
JavaMail 1.2

getReplyTo

public Address[] getReplyTo()
                     throws MessagingException
Return the value of the RFC 822 "Reply-To" header field. If this header is unavailable or its value is absent, then the getFrom method is called and its value is returned. This implementation uses the getHeader method to obtain the requisite header field.

Overrides:
getReplyTo in class Message
Returns:
addresses to which replies should be directed
Throws:
MessagingException
See Also:
headers

setReplyTo

public void setReplyTo(Address[] addresses)
                throws MessagingException
Set the RFC 822 "Reply-To" header field. If the address parameter is null, this header is removed.

Overrides:
setReplyTo in class Message
Parameters:
addresses - addresses to which replies should be directed
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getSubject

public String getSubject()
                  throws MessagingException
Returns the value of the "Subject" header field. Returns null if the subject field is unavailable or its value is absent.

If the subject is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as is.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getSubject in class Message
Returns:
Subject
Throws:
MessagingException
See Also:
headers

setSubject

public void setSubject(String subject)
                throws MessagingException
Set the "Subject" header field. If the subject contains non US-ASCII characters, it will be encoded using the platform's default charset. If the subject contains only US-ASCII characters, no encoding is done and it is used as-is. If the subject is null, the existing "Subject" field is removed.

The application must ensure that the subject does not contain any line breaks.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Specified by:
setSubject in class Message
Parameters:
subject - The subject
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
MessagingException

setSubject

public void setSubject(String subject,
                       String charset)
                throws MessagingException
Set the "Subject" header field. If the subject contains non US-ASCII characters, it will be encoded using the specified charset. If the subject contains only US-ASCII characters, no encoding is done and it is used as-is. If the subject is null, the existing "Subject" header field is removed.

The application must ensure that the subject does not contain any line breaks.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Parameters:
subject - The subject
charset - The charset
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
MessagingException

getSentDate

public Date getSentDate()
                 throws MessagingException
Returns the value of the RFC 822 "Date" field. This is the date on which this message was sent. Returns null if this field is unavailable or its value is absent.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getSentDate in class Message
Returns:
The sent Date
Throws:
MessagingException

setSentDate

public void setSentDate(Date d)
                 throws MessagingException
Set the RFC 822 "Date" header field. This is the date on which the creator of the message indicates that the message is complete and ready for delivery. If the date parameter is null, the existing "Date" field is removed.

Specified by:
setSentDate in class Message
Parameters:
d - the sent date of this message
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getReceivedDate

public Date getReceivedDate()
                     throws MessagingException
Returns the Date on this message was received. Returns null if this date cannot be obtained.

Note that RFC 822 does not define a field for the received date. Hence only implementations that can provide this date need return a valid value.

This implementation returns null.

Specified by:
getReceivedDate in class Message
Returns:
the date this message was received
Throws:
MessagingException

getSize

public int getSize()
            throws MessagingException
Return the size of the content of this message in bytes. Return -1 if the size cannot be determined.

Note that this number may not be an exact measure of the content size and may or may not account for any transfer encoding of the content.

This implementation returns the size of the content array (if not null), or, if contentStream is not null, and the available method returns a positive number, it returns that number as the size. Otherwise, it returns -1.

Specified by:
getSize in interface Part
Returns:
size of content in bytes
Throws:
MessagingException

getLineCount

public int getLineCount()
                 throws MessagingException
Return the number of lines for the content of this message. Return -1 if this number cannot be determined.

Note that this number may not be an exact measure of the content length and may or may not account for any transfer encoding of the content.

This implementation returns -1.

Specified by:
getLineCount in interface Part
Returns:
number of lines in the content.
Throws:
MessagingException

getContentType

public String getContentType()
                      throws MessagingException
Returns the value of the RFC 822 "Content-Type" header field. This represents the content-type of the content of this message. This value must not be null. If this field is unavailable, "text/plain" should be returned.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getContentType in interface Part
Returns:
The ContentType of this part
Throws:
MessagingException
See Also:
DataHandler

isMimeType

public boolean isMimeType(String mimeType)
                   throws MessagingException
Is this Part of the specified MIME type? This method compares only the primaryType and subType. The parameters of the content types are ignored.

For example, this method will return true when comparing a Part of content type "text/plain" with "text/plain; charset=foobar".

If the subType of mimeType is the special character '*', then the subtype is ignored during the comparison.

Specified by:
isMimeType in interface Part
Throws:
MessagingException

getDisposition

public String getDisposition()
                      throws MessagingException
Returns the value of the "Content-Disposition" header field. This represents the disposition of this part. The disposition describes how the part should be presented to the user.

If the Content-Disposition field is unavailable, null is returned.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getDisposition in interface Part
Returns:
disposition of this part, or null if unknown
Throws:
MessagingException
See Also:
Part.ATTACHMENT, Part.INLINE, Part.getFileName()

setDisposition

public void setDisposition(String disposition)
                    throws MessagingException
Set the "Content-Disposition" header field of this Message. If disposition is null, any existing "Content-Disposition" header field is removed.

Specified by:
setDisposition in interface Part
Parameters:
disposition - disposition of this part
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
See Also:
Part.ATTACHMENT, Part.INLINE, Part.setFileName(java.lang.String)

getEncoding

public String getEncoding()
                   throws MessagingException
Returns the content transfer encoding from the "Content-Transfer-Encoding" header field. Returns null if the header is unavailable or its value is absent.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getEncoding in interface MimePart
Returns:
content-transfer-encoding
Throws:
MessagingException

getContentID

public String getContentID()
                    throws MessagingException
Returns the value of the "Content-ID" header field. Returns null if the field is unavailable or its value is absent.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getContentID in interface MimePart
Returns:
content-ID
Throws:
MessagingException

setContentID

public void setContentID(String cid)
                  throws MessagingException
Set the "Content-ID" header field of this Message. If the cid parameter is null, any existing "Content-ID" is removed.

Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getContentMD5

public String getContentMD5()
                     throws MessagingException
Return the value of the "Content-MD5" header field. Returns null if this field is unavailable or its value is absent.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getContentMD5 in interface MimePart
Returns:
content-MD5
Throws:
MessagingException

setContentMD5

public void setContentMD5(String md5)
                   throws MessagingException
Set the "Content-MD5" header field of this Message.

Specified by:
setContentMD5 in interface MimePart
Parameters:
md5 - the MD5 value
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getDescription

public String getDescription()
                      throws MessagingException
Returns the "Content-Description" header field of this Message. This typically associates some descriptive information with this part. Returns null if this field is unavailable or its value is absent.

If the Content-Description field is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as-is

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getDescription in interface Part
Returns:
content-description
Throws:
MessagingException

setDescription

public void setDescription(String description)
                    throws MessagingException
Set the "Content-Description" header field for this Message. If the description parameter is null, then any existing "Content-Description" fields are removed.

If the description contains non US-ASCII characters, it will be encoded using the platform's default charset. If the description contains only US-ASCII characters, no encoding is done and it is used as-is.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Specified by:
setDescription in interface Part
Parameters:
description - content-description
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
MessagingException

setDescription

public void setDescription(String description,
                           String charset)
                    throws MessagingException
Set the "Content-Description" header field for this Message. If the description parameter is null, then any existing "Content-Description" fields are removed.

If the description contains non US-ASCII characters, it will be encoded using the specified charset. If the description contains only US-ASCII characters, no encoding is done and it is used as-is.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Parameters:
description - Description
charset - Charset for encoding
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
MessagingException

getContentLanguage

public String[] getContentLanguage()
                            throws MessagingException
Get the languages specified in the "Content-Language" header field of this message. The Content-Language header is defined by RFC 1766. Returns null if this field is unavailable or its value is absent.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getContentLanguage in interface MimePart
Returns:
value of content-language header.
Throws:
MessagingException

setContentLanguage

public void setContentLanguage(String[] languages)
                        throws MessagingException
Set the "Content-Language" header of this MimePart. The Content-Language header is defined by RFC 1766.

Specified by:
setContentLanguage in interface MimePart
Parameters:
languages - array of language tags
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getMessageID

public String getMessageID()
                    throws MessagingException
Returns the value of the "Message-ID" header field. Returns null if this field is unavailable or its value is absent.

The default implementation provided here uses the getHeader method to return the value of the "Message-ID" field.

Returns:
Message-ID
Throws:
MessagingException - if the retrieval of this field causes any exception.
Since:
JavaMail 1.1
See Also:
MessageIDTerm

getFileName

public String getFileName()
                   throws MessagingException
Get the filename associated with this Message.

Returns the value of the "filename" parameter from the "Content-Disposition" header field of this message. If it's not available, returns the value of the "name" parameter from the "Content-Type" header field of this BodyPart. Returns null if both are absent.

Specified by:
getFileName in interface Part
Returns:
filename
Throws:
MessagingException

setFileName

public void setFileName(String filename)
                 throws MessagingException
Set the filename associated with this part, if possible.

Sets the "filename" parameter of the "Content-Disposition" header field of this message.

Specified by:
setFileName in interface Part
Parameters:
filename - Filename to associate with this part
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getInputStream

public InputStream getInputStream()
                           throws IOException,
                                  MessagingException
Return a decoded input stream for this Message's "content".

This implementation obtains the input stream from the DataHandler, that is, it invokes getDataHandler().getInputStream().

Specified by:
getInputStream in interface Part
Returns:
an InputStream
Throws:
MessagingException
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
See Also:
getContentStream(), DataHandler.getInputStream()

getContentStream

protected InputStream getContentStream()
                                throws MessagingException
Produce the raw bytes of the content. This method is used during parsing, to create a DataHandler object for the content. Subclasses that can provide a separate input stream for just the message content might want to override this method.

This implementation returns a SharedInputStream, if contentStream is not null. Otherwise, it returns a ByteArrayInputStream constructed out of the content byte array.

Throws:
MessagingException
See Also:
content

getRawInputStream

public InputStream getRawInputStream()
                              throws MessagingException
Return an InputStream to the raw data with any Content-Transfer-Encoding intact. This method is useful if the "Content-Transfer-Encoding" header is incorrect or corrupt, which would prevent the getInputStream method or getContent method from returning the correct data. In such a case the application may use this method and attempt to decode the raw data itself.

This implementation simply calls the getContentStream method.

Throws:
MessagingException
Since:
JavaMail 1.2
See Also:
getInputStream(), getContentStream()

getDataHandler

public DataHandler getDataHandler()
                           throws MessagingException
Return a DataHandler for this Message's content.

The implementation provided here works as follows. Note the use of the getContentStream method to generate the byte stream for the content. Also note that any transfer-decoding is done automatically within this method.

  getDataHandler() {
      if (dh == null) {
          dh = new DataHandler(new MimePartDataSource(this));
      }
      return dh;
  }

  class MimePartDataSource implements DataSource {
      public getInputStream() {
          return MimeUtility.decode(
             getContentStream(), getEncoding());
      }

        ....
  }

Specified by:
getDataHandler in interface Part
Returns:
DataHandler for the content
Throws:
MessagingException

getContent

public Object getContent()
                  throws IOException,
                         MessagingException
Return the content as a Java object. The type of this object is dependent on the content itself. For example, the native format of a "text/plain" content is usually a String object. The native format for a "multipart" message is always a Multipart subclass. For content types that are unknown to the DataHandler system, an input stream is returned as the content.

This implementation obtains the content from the DataHandler, that is, it invokes getDataHandler().getContent().

Specified by:
getContent in interface Part
Returns:
Object
Throws:
MessagingException
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
See Also:
Part, DataHandler.getContent()

setDataHandler

public void setDataHandler(DataHandler dh)
                    throws MessagingException
This method provides the mechanism to set this part's content. The given DataHandler object should wrap the actual content.

Specified by:
setDataHandler in interface Part
Parameters:
dh - The DataHandler for the content.
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

setContent

public void setContent(Object o,
                       String type)
                throws MessagingException
A convenience method for setting this Message's content.

The content is wrapped in a DataHandler object. Note that a DataContentHandler class for the specified type should be available to the JavaMail implementation for this to work right. i.e., to do setContent(foobar, "application/x-foobar"), a DataContentHandler for "application/x-foobar" should be installed. Refer to the Java Activation Framework for more information.

Specified by:
setContent in interface Part
Parameters:
o - the content object
type - Mime type of the object
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

setText

public void setText(String text)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain". If the string contains non US-ASCII characters. it will be encoded using the platform's default charset. The charset is also used to set the "charset" parameter.

Note that there may be a performance penalty if text is large, since this method may have to scan all the characters to determine what charset to use.

If the charset is already known, use the setText method that takes the charset parameter.

Specified by:
setText in interface MimePart
Throws:
MessagingException
See Also:
setText(String text, String charset)

setText

public void setText(String text,
                    String charset)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.

Specified by:
setText in interface MimePart
Throws:
MessagingException

setContent

public void setContent(Multipart mp)
                throws MessagingException
This method sets the Message's content to a Multipart object.

Specified by:
setContent in interface Part
Parameters:
mp - The multipart object that is the Message's content
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

reply

public Message reply(boolean replyToAll)
              throws MessagingException
Get a new Message suitable for a reply to this message. The new Message will have its attributes and headers set up appropriately. Note that this new message object will be empty, i.e., it will not have a "content". These will have to be suitably filled in by the client.

If replyToAll is set, the new Message will be addressed to all recipients of this message. Otherwise, the reply will be addressed to only the sender of this message (using the value of the getReplyTo method).

The "Subject" field is filled in with the original subject prefixed with "Re:" (unless it already starts with "Re:"). The "In-Reply-To" header is set in the new message if this message has a "Message-Id" header. The ANSWERED flag is set in this message.

Specified by:
reply in class Message
Parameters:
replyToAll - reply should be sent to all recipients of this message
Returns:
the reply Message
Throws:
MessagingException

writeTo

public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
Output the message as an RFC 822 format stream.

Note that, depending on how the messag was constructed, it may use a variety of line termination conventions. Generally the output should be sent through an appropriate FilterOutputStream that converts the line terminators to the desired form, either CRLF for MIME compatibility and for use in Internet protocols, or the local platform's line terminator for storage in a local text file.

This implementation calls the writeTo(OutputStream, String[]) method with a null ignore list.

Specified by:
writeTo in interface Part
Throws:
IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
MessagingException
See Also:
DataHandler.writeTo(java.io.OutputStream)

writeTo

public void writeTo(OutputStream os,
                    String[] ignoreList)
             throws IOException,
                    MessagingException
Output the message as an RFC 822 format stream, without specified headers. If the saved flag is not set, the saveChanges method is called. If the modified flag is not set and the content array is not null, the content array is written directly, after writing the appropriate message headers.

Throws:
MessagingException
IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
See Also:
DataHandler.writeTo(java.io.OutputStream)

getHeader

public String[] getHeader(String name)
                   throws MessagingException
Get all the headers for this header_name. Note that certain headers may be encoded as per RFC 2047 if they contain non US-ASCII characters and these should be decoded.

This implementation obtains the headers from the headers InternetHeaders object.

Specified by:
getHeader in interface Part
Parameters:
name - name of header
Returns:
array of headers
Throws:
MessagingException
See Also:
MimeUtility

getHeader

public String getHeader(String name,
                        String delimiter)
                 throws MessagingException
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter. If the delimiter is null, only the first header is returned.

Specified by:
getHeader in interface MimePart
Parameters:
name - the name of this header
delimiter - separator between values
Returns:
the value fields for all headers with this name
Throws:
MessagingException

setHeader

public void setHeader(String name,
                      String value)
               throws MessagingException
Set the value for this header_name. Replaces all existing header values with this new value. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must have been encoded by the caller as per the rules of RFC 2047.

Specified by:
setHeader in interface Part
Parameters:
name - header name
value - header value
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
See Also:
MimeUtility

addHeader

public void addHeader(String name,
                      String value)
               throws MessagingException
Add this value to the existing values for this header_name. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must have been encoded as per the rules of RFC 2047.

Specified by:
addHeader in interface Part
Parameters:
name - header name
value - header value
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
See Also:
MimeUtility

removeHeader

public void removeHeader(String name)
                  throws MessagingException
Remove all headers with this name.

Specified by:
removeHeader in interface Part
Parameters:
name - the name of this header
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getAllHeaders

public Enumeration getAllHeaders()
                          throws MessagingException
Return all the headers from this Message as an enumeration of Header objects.

Note that certain headers may be encoded as per RFC 2047 if they contain non US-ASCII characters and these should be decoded.

This implementation obtains the headers from the headers InternetHeaders object.

Specified by:
getAllHeaders in interface Part
Returns:
array of header objects
Throws:
MessagingException
See Also:
MimeUtility

getMatchingHeaders

public Enumeration getMatchingHeaders(String[] names)
                               throws MessagingException
Return matching headers from this Message as an Enumeration of Header objects. This implementation obtains the headers from the headers InternetHeaders object.

Specified by:
getMatchingHeaders in interface Part
Returns:
enumeration of Header objects
Throws:
MessagingException

getNonMatchingHeaders

public Enumeration getNonMatchingHeaders(String[] names)
                                  throws MessagingException
Return non-matching headers from this Message as an Enumeration of Header objects. This implementation obtains the header from the headers InternetHeaders object.

Specified by:
getNonMatchingHeaders in interface Part
Returns:
enumeration of Header objects
Throws:
MessagingException

addHeaderLine

public void addHeaderLine(String line)
                   throws MessagingException
Add a raw RFC 822 header-line.

Specified by:
addHeaderLine in interface MimePart
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getAllHeaderLines

public Enumeration getAllHeaderLines()
                              throws MessagingException
Get all header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header-line, containing both the "name" and "value" field.

Specified by:
getAllHeaderLines in interface MimePart
Throws:
MessagingException

getMatchingHeaderLines

public Enumeration getMatchingHeaderLines(String[] names)
                                   throws MessagingException
Get matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header-line, containing both the "name" and "value" field.

Specified by:
getMatchingHeaderLines in interface MimePart
Throws:
MessagingException

getNonMatchingHeaderLines

public Enumeration getNonMatchingHeaderLines(String[] names)
                                      throws MessagingException
Get non-matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header-line, containing both the "name" and "value" field.

Specified by:
getNonMatchingHeaderLines in interface MimePart
Throws:
MessagingException

getFlags

public Flags getFlags()
               throws MessagingException
Return a Flags object containing the flags for this message.

Note that a clone of the internal Flags object is returned, so modifying the returned Flags object will not affect the flags of this message.

Specified by:
getFlags in class Message
Returns:
Flags object containing the flags for this message
Throws:
MessagingException
See Also:
Flags

isSet

public boolean isSet(Flags.Flag flag)
              throws MessagingException
Check whether the flag specified in the flag argument is set in this message.

This implementation checks this message's internal flags object.

Overrides:
isSet in class Message
Parameters:
flag - the flag
Returns:
value of the specified flag for this message
Throws:
MessagingException
See Also:
Flags.Flag, Flags.Flag.ANSWERED, Flags.Flag.DELETED, Flags.Flag.DRAFT, Flags.Flag.FLAGGED, Flags.Flag.RECENT, Flags.Flag.SEEN

setFlags

public void setFlags(Flags flag,
                     boolean set)
              throws MessagingException
Set the flags for this message.

This implementation modifies the flags field.

Specified by:
setFlags in class Message
Parameters:
flag - Flags object containing the flags to be set
set - the value to be set
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
See Also:
MessageChangedEvent

saveChanges

public void saveChanges()
                 throws MessagingException
Updates the appropriate header fields of this message to be consistent with the message's contents. If this message is contained in a Folder, any changes made to this message are committed to the containing folder.

If any part of a message's headers or contents are changed, saveChanges must be called to ensure that those changes are permanent. Otherwise, any such modifications may or may not be saved, depending on the folder implementation.

Messages obtained from folders opened READ_ONLY should not be modified and saveChanges should not be called on such messages.

This method sets the modified flag to true, the save flag to true, and then calls the updateHeaders method.

Specified by:
saveChanges in class Message
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

updateHeaders

protected void updateHeaders()
                      throws MessagingException
Called by the saveChanges method to actually update the MIME headers. The implementation here sets the Content-Transfer-Encoding header (if needed and not already set), the Mime-Version header and the Message-ID header. Also, if the content of this message is a MimeMultipart, it's updateHeaders method is called.

Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

createInternetHeaders

protected InternetHeaders createInternetHeaders(InputStream is)
                                         throws MessagingException
Create and return an InternetHeaders object that loads the headers from the given InputStream. Subclasses can override this method to return a subclass of InternetHeaders, if necessary. This implementation simply constructs and returns an InternetHeaders object.

Parameters:
is - the InputStream to read the headers from
Throws:
MessagingException
Since:
JavaMail 1.2
Overview  Package   Class  Tree  Deprecated  Index  Help
JavaTM 2 Platform
Ent. Ed. v1.4
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimeMessage.RecipientType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimeMessage.RecipientType

java.lang.Object
    extended by javax.mail.Message.RecipientType
        extended by javax.mail.internet.MimeMessage.RecipientType
All Implemented Interfaces:
Serializable
Enclosing class:
MimeMessage
public static class MimeMessage.RecipientType
extends Message.RecipientType

This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes. The one additional RecipientType currently defined here is NEWSGROUPS.

See Also:
Message.RecipientType, Serialized Form

Field Summary
static MimeMessage.RecipientType NEWSGROUPS
The "Newsgroup" (Usenet news) recipients.
Fields inherited from class javax.mail.Message.RecipientType
BCC, CC, TO, type
Constructor Summary
protected MimeMessage.RecipientType(String type)
Method Summary
protected  Object readResolve()
When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class.
Methods inherited from class javax.mail.Message.RecipientType
toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NEWSGROUPS

public static final MimeMessage.RecipientType NEWSGROUPS
The "Newsgroup" (Usenet news) recipients.

Constructor Detail

MimeMessage.RecipientType

protected MimeMessage.RecipientType(String type)
Method Detail

readResolve

protected Object readResolve()
                      throws ObjectStreamException
Description copied from class: Message.RecipientType
When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class. Subclasses must implement their own readResolve method that checks for their known instances before calling this super method.

Overrides:
readResolve in class Message.RecipientType
Throws:
ObjectStreamException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimeMultipart

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimeMultipart

java.lang.Object
    extended by javax.mail.Multipart
        extended by javax.mail.internet.MimeMultipart
public class MimeMultipart
extends Multipart

The MimeMultipart class is an implementation of the abstract Multipart class that uses MIME conventions for the multipart data.

A MimeMultipart is obtained from a MimePart whose primary type is "multipart" (by invoking the part's getContent() method) or it can be created by a client as part of creating a new MimeMessage.

The default multipart subtype is "mixed". The other multipart subtypes, such as "alternative", "related", and so on, can be implemented as subclasses of MimeMultipart with additional methods to implement the additional semantics of that type of multipart content. The intent is that service providers, mail JavaBean writers and mail clients will write many such subclasses and their Command Beans, and will install them into the JavaBeans Activation Framework, so that any JavaMail implementation and its clients can transparently find and use these classes. Thus, a MIME multipart handler is treated just like any other type handler, thereby decoupling the process of providing multipart handlers from the JavaMail API. Lacking these additional MimeMultipart subclasses, all subtypes of MIME multipart data appear as MimeMultipart objects.

An application can directly construct a MIME multipart object of any subtype by using the MimeMultipart(String subtype) constructor. For example, to create a "multipart/alternative" object, use new MimeMultipart("alternative").

Version:
1.31, 03/01/29
Author:
John Mani, Bill Shannon, Max Spivak

Field Summary
protected DataSource | ds The DataSource supplying our InputStream.
protected boolean | parsed Have we parsed the data from our InputStream yet?
Fields inherited from class javax.mail.Multipart
contentType, parent, parts
Constructor Summary
MimeMultipart()
Default constructor.
MimeMultipart(DataSource ds)
Constructs a MimeMultipart object and its bodyparts from the given DataSource.
MimeMultipart(String subtype)
Construct a MimeMultipart object of the given subtype.
Method Summary
protected InternetHeaders | createInternetHeaders(InputStream is) Create and return an InternetHeaders object that loads the headers from the given InputStream.
protected MimeBodyPart | createMimeBodyPart(InputStream is) Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
protected MimeBodyPart | createMimeBodyPart(InternetHeaders headers, byte[] content) Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
BodyPart | getBodyPart(int index) Get the specified BodyPart.
BodyPart | getBodyPart(String CID) Get the MimeBodyPart referred to by the given ContentID (CID).
int | getCount() Return the number of enclosed BodyPart objects.
protected void | parse() Parse the InputStream from our DataSource, constructing the appropriate MimeBodyParts.
void | setSubType(String subtype) Set the subtype.
protected void | updateHeaders() Update headers.
void | writeTo(OutputStream os) Iterates through all the parts and outputs each Mime part separated by a boundary.
Methods inherited from class javax.mail.Multipart
addBodyPart, addBodyPart, getContentType, getParent, removeBodyPart, removeBodyPart, setMultipartDataSource, setParent
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ds

protected DataSource ds
The DataSource supplying our InputStream.

parsed

protected boolean parsed
Have we parsed the data from our InputStream yet? Defaults to true; set to false when our constructor is given a DataSource with an InputStream that we need to parse.

Constructor Detail

MimeMultipart

public MimeMultipart()
Default constructor. An empty MimeMultipart object is created. Its content type is set to "multipart/mixed". A unique boundary string is generated and this string is setup as the "boundary" parameter for the contentType field.

MimeBodyParts may be added later.

MimeMultipart

public MimeMultipart(String subtype)
Construct a MimeMultipart object of the given subtype. A unique boundary string is generated and this string is setup as the "boundary" parameter for the contentType field.

MimeBodyParts may be added later.

MimeMultipart

public MimeMultipart(DataSource ds)
              throws MessagingException
Constructs a MimeMultipart object and its bodyparts from the given DataSource.

This constructor handles as a special case the situation where the given DataSource is a MultipartDataSource object. In this case, this method just invokes the superclass (i.e., Multipart) constructor that takes a MultipartDataSource object.

Otherwise, the DataSource is assumed to provide a MIME multipart byte stream. The parsed flag is set to false. When the data for the body parts are needed, the parser extracts the "boundary" parameter from the content type of this DataSource, skips the 'preamble' and reads bytes till the terminating boundary and creates MimeBodyParts for each part of the stream.

Parameters:
ds - DataSource, can be a MultipartDataSource
Method Detail

setSubType

public void setSubType(String subtype)
                throws MessagingException
Set the subtype. This method should be invoked only on a new MimeMultipart object created by the client. The default subtype of such a multipart object is "mixed".

Parameters:
subtype - Subtype
Throws:
MessagingException

getCount

public int getCount()
             throws MessagingException
Return the number of enclosed BodyPart objects.

Overrides:
getCount in class Multipart
Returns:
number of parts
Throws:
MessagingException
See Also:
Multipart.parts

getBodyPart

public BodyPart getBodyPart(int index)
                     throws MessagingException
Get the specified BodyPart. BodyParts are numbered starting at 0.

Overrides:
getBodyPart in class Multipart
Parameters:
index - the index of the desired BodyPart
Returns:
the Part
Throws:
MessagingException - if no such BodyPart exists

getBodyPart

public BodyPart getBodyPart(String CID)
                     throws MessagingException
Get the MimeBodyPart referred to by the given ContentID (CID). Returns null if the part is not found.

Parameters:
CID - the ContentID of the desired part
Returns:
the Part
Throws:
MessagingException

updateHeaders

protected void updateHeaders()
                      throws MessagingException
Update headers. The default implementation here just calls the updateHeaders method on each of its children BodyParts.

Note that the boundary parameter is already set up when a new and empty MimeMultipart object is created.

This method is called when the saveChanges method is invoked on the Message object containing this Multipart. This is typically done as part of the Message send process, however note that a client is free to call it any number of times. So if the header updating process is expensive for a specific MimeMultipart subclass, then it might itself want to track whether its internal state actually did change, and do the header updating only if necessary.

Throws:
MessagingException

writeTo

public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
Iterates through all the parts and outputs each Mime part separated by a boundary.

Specified by:
writeTo in class Multipart
Throws:
MessagingException
IOException - if an IO related exception occurs

parse

protected void parse()
              throws MessagingException
Parse the InputStream from our DataSource, constructing the appropriate MimeBodyParts. The parsed flag is set to true, and if true on entry nothing is done. This method is called by all other methods that need data for the body parts, to make sure the data has been parsed.

Throws:
MessagingException
Since:
JavaMail 1.2

createInternetHeaders

protected InternetHeaders createInternetHeaders(InputStream is)
                                         throws MessagingException
Create and return an InternetHeaders object that loads the headers from the given InputStream. Subclasses can override this method to return a subclass of InternetHeaders, if necessary. This implementation simply constructs and returns an InternetHeaders object.

Parameters:
is - the InputStream to read the headers from
Throws:
MessagingException
Since:
JavaMail 1.2

createMimeBodyPart

protected MimeBodyPart createMimeBodyPart(InternetHeaders headers,
                                          byte[] content)
                                   throws MessagingException
Create and return a MimeBodyPart object to represent a body part parsed from the InputStream. Subclasses can override this method to return a subclass of MimeBodyPart, if necessary. This implementation simply constructs and returns a MimeBodyPart object.

Parameters:
headers - the headers for the body part
content - the content of the body part
Throws:
MessagingException
Since:
JavaMail 1.2

createMimeBodyPart

protected MimeBodyPart createMimeBodyPart(InputStream is)
                                   throws MessagingException
Create and return a MimeBodyPart object to represent a body part parsed from the InputStream. Subclasses can override this method to return a subclass of MimeBodyPart, if necessary. This implementation simply constructs and returns a MimeBodyPart object.

Parameters:
is - InputStream containing the body part
Throws:
MessagingException
Since:
JavaMail 1.2
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimePart

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Interface MimePart

All Superinterfaces:
Part
All Known Implementing Classes:
MimeBodyPart, MimeMessage
public interface MimePart
extends Part

The MimePart interface models an Entity as defined by MIME (RFC2045, Section 2.4).

MimePart extends the Part interface to add additional RFC822 and MIME specific semantics and attributes. It provides the base interface for the MimeMessage and MimeBodyPart classes

A note on RFC822 and MIME headers

RFC822 and MIME header fields must contain only US-ASCII characters. If a header contains non US-ASCII characters, it must be encoded as per the rules in RFC 2047. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

Author:
John Mani
See Also:
MimeUtility, Part

Field Summary
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Method Summary
void | addHeaderLine(String line) Add a raw RFC822 header-line.
Enumeration | getAllHeaderLines() Get all header lines as an Enumeration of Strings.
String | getContentID() Get the Content-ID of this part.
String[] | getContentLanguage() Get the language tags specified in the Content-Language header of this MimePart.
String | getContentMD5() Get the Content-MD5 digest of this part.
String | getEncoding() Get the transfer encoding of this part.
String | getHeader(String name, String delimiter) Get the values of all header fields available for this header, returned as a single String, with the values separated by the delimiter.
Enumeration | getMatchingHeaderLines(String[] names) Get matching header lines as an Enumeration of Strings.
Enumeration | getNonMatchingHeaderLines(String[] names) Get non-matching header lines as an Enumeration of Strings.
void | setContentLanguage(String[] languages) Set the Content-Language header of this MimePart.
void | setContentMD5(String md5) Set the Content-MD5 of this part.
void | setText(String text) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
void | setText(String text, String charset) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
Methods inherited from interface javax.mail.Part
addHeader, getAllHeaders, getContent, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getInputStream, getLineCount, getMatchingHeaders, getNonMatchingHeaders, getSize, isMimeType, removeHeader, setContent, setContent, setDataHandler, setDescription, setDisposition, setFileName, setHeader, writeTo

Method Detail

getHeader

public String getHeader(String name,
                        String delimiter)
                 throws MessagingException
Get the values of all header fields available for this header, returned as a single String, with the values separated by the delimiter. If the delimiter is null, only the first value is returned.

Parameters:
name - the name of this header
delimiter - delimiter between fields in returned string
Returns:
the value fields for all headers with this name
Throws:
MessagingException

addHeaderLine

public void addHeaderLine(String line)
                   throws MessagingException
Add a raw RFC822 header-line.

Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

getAllHeaderLines

public Enumeration getAllHeaderLines()
                              throws MessagingException
Get all header lines as an Enumeration of Strings. A Header line is a raw RFC822 header-line, containing both the "name" and "value" field.

Throws:
MessagingException

getMatchingHeaderLines

public Enumeration getMatchingHeaderLines(String[] names)
                                   throws MessagingException
Get matching header lines as an Enumeration of Strings. A Header line is a raw RFC822 header-line, containing both the "name" and "value" field.

Throws:
MessagingException

getNonMatchingHeaderLines

public Enumeration getNonMatchingHeaderLines(String[] names)
                                      throws MessagingException
Get non-matching header lines as an Enumeration of Strings. A Header line is a raw RFC822 header-line, containing both the "name" and "value" field.

Throws:
MessagingException

getEncoding

public String getEncoding()
                   throws MessagingException
Get the transfer encoding of this part.

Returns:
content-transfer-encoding
Throws:
MessagingException

getContentID

public String getContentID()
                    throws MessagingException
Get the Content-ID of this part. Returns null if none present.

Returns:
content-ID
Throws:
MessagingException

getContentMD5

public String getContentMD5()
                     throws MessagingException
Get the Content-MD5 digest of this part. Returns null if none present.

Returns:
content-MD5
Throws:
MessagingException

setContentMD5

public void setContentMD5(String md5)
                   throws MessagingException
Set the Content-MD5 of this part.

Parameters:
md5 - the MD5 value
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

getContentLanguage

public String[] getContentLanguage()
                            throws MessagingException
Get the language tags specified in the Content-Language header of this MimePart. The Content-Language header is defined by RFC 1766. Returns null if this header is not available.

Throws:
MessagingException

setContentLanguage

public void setContentLanguage(String[] languages)
                        throws MessagingException
Set the Content-Language header of this MimePart. The Content-Language header is defined by RFC1766.

Parameters:
languages - array of language tags
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

setText

public void setText(String text)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain". If the string contains non US-ASCII characters. it will be encoded using the platform's default charset. The charset is also used to set the "charset" parameter.

Note that there may be a performance penalty if text is large, since this method may have to scan all the characters to determine what charset to use.

If the charset is already known, use the setText() version that takes the charset parameter.

Specified by:
setText in interface Part
Parameters:
text - The text that is the Message's content.
Throws:
MessagingException
See Also:
setText(String text, String charset)

setText

public void setText(String text,
                    String charset)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set "charset" parameter.

Throws:
MessagingException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimePartDataSource

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimePartDataSource

java.lang.Object
    extended by javax.mail.internet.MimePartDataSource
All Implemented Interfaces:
DataSource, MessageAware
public class MimePartDataSource
extends Object
implements DataSource, MessageAware

A utility class that implements a DataSource out of a MimePart. This class is primarily meant for service providers.

Author:
John Mani
See Also:
MimePart, DataSource

Constructor Summary
MimePartDataSource(MimePart part)
Constructor, that constructs a DataSource from a MimePart.
Method Summary
String | getContentType() Returns the content-type of this DataSource.
InputStream | getInputStream() Returns an input stream from this MimePart.
MessageContext | getMessageContext() Return the MessageContext for the current part.
String | getName() DataSource method to return a name.
OutputStream | getOutputStream() DataSource method to return an output stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MimePartDataSource

public MimePartDataSource(MimePart part)
Constructor, that constructs a DataSource from a MimePart.

Method Detail

getInputStream

public InputStream getInputStream()
                           throws IOException
Returns an input stream from this MimePart.

This method applies the appropriate transfer-decoding, based on the Content-Transfer-Encoding attribute of this MimePart. Thus the returned input stream is a decoded stream of bytes.

This implementation obtains the raw content from the Part using the getContentStream() method and decodes it using the MimeUtility.decode() method.

Specified by:
getInputStream in interface DataSource
Returns:
decoded input stream
Throws:
IOException
See Also:
MimeMessage.getContentStream(),
MimeBodyPart.getContentStream(),
MimeUtility.decode(java.io.InputStream, java.lang.String)

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
DataSource method to return an output stream.

This implementation throws the UnknownServiceException.

Specified by:
getOutputStream in interface DataSource
Returns:
an OutputStream
Throws:
IOException

getContentType

public String getContentType()
Returns the content-type of this DataSource.

This implementation just invokes the getContentType method on the MimePart.

Specified by:
getContentType in interface DataSource
Returns:
the MIME Type

getName

public String getName()
DataSource method to return a name.

This implementation just returns an empty string.

Specified by:
getName in interface DataSource
Returns:
the name of the object.

getMessageContext

public MessageContext getMessageContext()
Return the MessageContext for the current part.

Specified by:
getMessageContext in interface MessageAware
Since:
JavaMail 1.1
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimeUtility

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimeUtility

java.lang.Object
    extended by javax.mail.internet.MimeUtility
public class MimeUtility
extends Object

This is a utility class that provides various MIME related functionality.

There are a set of methods to encode and decode MIME headers as per RFC 2047. A brief description on handling such headers is given below:

RFC 822 mail headers must contain only US-ASCII characters. Headers that contain non US-ASCII characters must be encoded so that they contain only US-ASCII characters. Basically, this process involves using either BASE64 or QP to encode certain characters. RFC 2047 describes this in detail.

In Java, Strings contain (16 bit) Unicode characters. ASCII is a subset of Unicode (and occupies the range 0 - 127). A String that contains only ASCII characters is already mail-safe. If the String contains non US-ASCII characters, it must be encoded. An additional complexity in this step is that since Unicode is not yet a widely used charset, one might want to first charset-encode the String into another charset and then do the transfer-encoding.

Note that to get the actual bytes of a mail-safe String (say, for sending over SMTP), one must do

    byte[] bytes = string.getBytes("iso-8859-1");

The setHeader and addHeader methods on MimeMessage and MimeBodyPart assume that the given header values are Unicode strings that contain only US-ASCII characters. Hence the callers of those methods must insure that the values they pass do not contain non US-ASCII characters. The methods in this class help do this.

The getHeader family of methods on MimeMessage and MimeBodyPart return the raw header value. These might be encoded as per RFC 2047, and if so, must be decoded into Unicode Strings. The methods in this class help to do this.

Several System properties control strict conformance to the MIME spec. Note that these are not session properties but must be set globally as System properties.

The mail.mime.decodetext.strict property controls decoding of MIME encoded words. The MIME spec requires that encoded words start at the beginning of a whitespace separated word. Some mailers incorrectly include encoded words in the middle of a word. If the mail.mime.decodetext.strict System property is set to "false", an attempt will be made to decode these illegal encoded words. The default is true.

The mail.mime.encodeeol.strict property controls the choice of Content-Transfer-Encoding for MIME parts that are not of type "text". Often such parts will contain textual data for which an encoding that allows normal end of line conventions is appropriate. In rare cases, such a part will appear to contain entirely textual data, but will require an encoding that preserves CR and LF characters without change. If the mail.mime.encodeeol.strict System property is set to "true", such an encoding will be used when necessary. The default is false.

In addition, the mail.mime.charset System property can be used to specify the default MIME charset to use for encoded words and text parts that don't otherwise specify a charset. Normally, the default MIME charset is derived from the default Java charset, as specified in the file.encoding System property. Most applications will have no need to explicitly set the default MIME charset. In cases where the default MIME charset to be used for mail messages is different than the charset used for files stored on the system, this property should be set.

Version:
1.48, 03/06/23
Author:
John Mani, Bill Shannon

Field Summary
static int ALL
Method Summary
static InputStream | decode(InputStream is, String encoding) Decode the given input stream.
static String | decodeText(String etext) Decode "unstructured" headers, that is, headers that are defined as '*text' as per RFC 822.
static String | decodeWord(String eword) The string is parsed using the rules in RFC 2047 for parsing an "encoded-word".
static OutputStream | encode(OutputStream os, String encoding) Wrap an encoder around the given output stream.
static OutputStream | encode(OutputStream os, String encoding, String filename) Wrap an encoder around the given output stream.
static String | encodeText(String text) Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.
static String | encodeText(String text, String charset, String encoding) Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.
static String | encodeWord(String word) Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.
static String | encodeWord(String word, String charset, String encoding) Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.
static String | getDefaultJavaCharset() Get the default charset corresponding to the system's current default locale.
static String | getEncoding(DataHandler dh) Same as getEncoding(DataSource) except that instead of reading the data from an InputStream it uses the writeTo method to examine the data.
static String | getEncoding(DataSource ds) Get the content-transfer-encoding that should be applied to the input stream of this datasource, to make it mailsafe.
static String | javaCharset(String charset) Convert a MIME charset name into a valid Java charset name.
static String | mimeCharset(String charset) Convert a java charset into its MIME charset name.
static String | quote(String word, String specials) A utility method to quote a word, if the word contains any characters from the specified 'specials' list.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ALL

public static final int ALL
See Also:
Constant Field Values
Method Detail

getEncoding

public static String getEncoding(DataSource ds)
Get the content-transfer-encoding that should be applied to the input stream of this datasource, to make it mailsafe.

The algorithm used here is:

  • If the primary type of this datasource is "text" and if all the bytes in its input stream are US-ASCII, then the encoding is "7bit". If more than half of the bytes are non-US-ASCII, then the encoding is "base64". If less than half of the bytes are non-US-ASCII, then the encoding is "quoted-printable".
  • If the primary type of this datasource is not "text", then if all the bytes of its input stream are US-ASCII, the encoding is "7bit". If there is even one non-US-ASCII character, the encoding is "base64".

Parameters:
ds - DataSource
Returns:
the encoding. This is either "7bit", "quoted-printable" or "base64"

getEncoding

public static String getEncoding(DataHandler dh)
Same as getEncoding(DataSource) except that instead of reading the data from an InputStream it uses the writeTo method to examine the data. This is more efficient in the common case of a DataHandler created with an object and a MIME type (for example, a "text/plain" String) because all the I/O is done in this thread. In the case requiring an InputStream the DataHandler uses a thread, a pair of pipe streams, and the writeTo method to produce the data.

Since:
JavaMail 1.2

decode

public static InputStream decode(InputStream is,
                                 String encoding)
                          throws MessagingException
Decode the given input stream. The Input stream returned is the decoded input stream. All the encodings defined in RFC 2045 are supported here. They include "base64", "quoted-printable", "7bit", "8bit", and "binary". In addition, "uuencode" is also supported.

Parameters:
is - input stream
encoding - the encoding of the stream.
Returns:
decoded input stream.
Throws:
MessagingException

encode

public static OutputStream encode(OutputStream os,
                                  String encoding)
                           throws MessagingException
Wrap an encoder around the given output stream. All the encodings defined in RFC 2045 are supported here. They include "base64", "quoted-printable", "7bit", "8bit" and "binary". In addition, "uuencode" is also supported.

Parameters:
os - output stream
encoding - the encoding of the stream.
Returns:
output stream that applies the specified encoding.
Throws:
MessagingException

encode

public static OutputStream encode(OutputStream os,
                                  String encoding,
                                  String filename)
                           throws MessagingException
Wrap an encoder around the given output stream. All the encodings defined in RFC 2045 are supported here. They include "base64", "quoted-printable", "7bit", "8bit" and "binary". In addition, "uuencode" is also supported. The filename parameter is used with the "uuencode" encoding and is included in the encoded output.

Parameters:
os - output stream
encoding - the encoding of the stream.
filename - name for the file being encoded (only used with uuencode)
Returns:
output stream that applies the specified encoding.
Throws:
MessagingException
Since:
JavaMail 1.2

encodeText

public static String encodeText(String text)
                         throws UnsupportedEncodingException
Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.

The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the platform's default charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

Note that this method should be used to encode only "unstructured" RFC 822 headers.

Example of usage:

  MimePart part = ...
  String rawvalue = "FooBar Mailer, Japanese version 1.1"
  try {
    // If we know for sure that rawvalue contains only US-ASCII
    // characters, we can skip the encoding part
    part.setHeader("X-mailer", MimeUtility.encodeText(rawvalue));
  } catch (UnsupportedEncodingException e) {
    // encoding failure
  } catch (MessagingException me) {
   // setHeader() failure
  }

Parameters:
text - Unicode string
Returns:
Unicode string containing only US-ASCII characters
Throws:
UnsupportedEncodingException - if the encoding fails

encodeText

public static String encodeText(String text,
                                String charset,
                                String encoding)
                         throws UnsupportedEncodingException
Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.

The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the specified charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

Note that this method should be used to encode only "unstructured" RFC 822 headers.

Parameters:
text - the header value
charset - the charset. If this parameter is null, the platform's default chatset is used.
encoding - the encoding to be used. Currently supported values are "B" and "Q". If this parameter is null, then the "Q" encoding is used if most of characters to be encoded are in the ASCII charset, otherwise "B" encoding is used.
Returns:
Unicode string containing only US-ASCII characters
Throws:
UnsupportedEncodingException

decodeText

public static String decodeText(String etext)
                         throws UnsupportedEncodingException
Decode "unstructured" headers, that is, headers that are defined as '*text' as per RFC 822.

The string is decoded using the algorithm specified in RFC 2047, Section 6.1.1. If the charset-conversion fails for any sequence, an UnsupportedEncodingException is thrown. If the String is not an RFC 2047 style encoded header, it is returned as-is

Example of usage:

  MimePart part = ...
  String rawvalue = null;
  String  value = null;
  try {
    if ((rawvalue = part.getHeader("X-mailer")[0]) != null)
      value = MimeUtility.decodeText(rawvalue);
  } catch (UnsupportedEncodingException e) {
      // Don't care
      value = rawvalue;
  } catch (MessagingException me) { }

  return value;

Parameters:
etext - the possibly encoded value
Throws:
UnsupportedEncodingException - if the charset conversion failed.

encodeWord

public static String encodeWord(String word)
                         throws UnsupportedEncodingException
Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.

The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the platform's default charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

This method is meant to be used when creating RFC 822 "phrases". The InternetAddress class, for example, uses this to encode it's 'phrase' component.

Parameters:
word - Unicode string
Returns:
Array of Unicode strings containing only US-ASCII characters.
Throws:
UnsupportedEncodingException - if the encoding fails

encodeWord

public static String encodeWord(String word,
                                String charset,
                                String encoding)
                         throws UnsupportedEncodingException
Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.

The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the specified charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

Parameters:
word - Unicode string
charset - the MIME charset
encoding - the encoding to be used. Currently supported values are "B" and "Q". If this parameter is null, then the "Q" encoding is used if most of characters to be encoded are in the ASCII charset, otherwise "B" encoding is used.
Returns:
Unicode string containing only US-ASCII characters
Throws:
UnsupportedEncodingException - if the encoding fails

decodeWord

public static String decodeWord(String eword)
                         throws ParseException,
                                UnsupportedEncodingException
The string is parsed using the rules in RFC 2047 for parsing an "encoded-word". If the parse fails, a ParseException is thrown. Otherwise, it is transfer-decoded, and then charset-converted into Unicode. If the charset-conversion fails, an UnsupportedEncodingException is thrown.

Parameters:
eword - the possibly encoded value
Throws:
ParseException - if the string is not an encoded-word as per RFC 2047.
UnsupportedEncodingException - if the charset conversion failed.

quote

public static String quote(String word,
                           String specials)
A utility method to quote a word, if the word contains any characters from the specified 'specials' list.

The HeaderTokenizer class defines two special sets of delimiters - MIME and RFC 822.

This method is typically used during the generation of RFC 822 and MIME header fields.

Parameters:
word - word to be quoted
specials - the set of special characters
Returns:
the possibly quoted word
See Also:
HeaderTokenizer.MIME, HeaderTokenizer.RFC822

javaCharset

public static String javaCharset(String charset)
Convert a MIME charset name into a valid Java charset name.

Parameters:
charset - the MIME charset name
Returns:
the Java charset equivalent. If a suitable mapping is not available, the passed in charset is itself returned.

mimeCharset

public static String mimeCharset(String charset)
Convert a java charset into its MIME charset name.

Note that a future version of JDK (post 1.2) might provide this functionality, in which case, we may deprecate this method then.

Parameters:
charset - the JDK charset
Returns:
the MIME/IANA equivalent. If a mapping is not possible, the passed in charset itself is returned.
Since:
JavaMail 1.1

getDefaultJavaCharset

public static String getDefaultJavaCharset()
Get the default charset corresponding to the system's current default locale. If the System property mail.mime.charset is set, a system charset corresponding to this MIME charset will be returned.

Returns:
the default charset of the system's default locale, as a Java charset. (NOT a MIME charset)
Since:
JavaMail 1.1
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NewsAddress

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class NewsAddress

java.lang.Object
    extended by javax.mail.Address
        extended by javax.mail.internet.NewsAddress
All Implemented Interfaces:
Serializable
public class NewsAddress
extends Address

This class models an RFC1036 newsgroup address.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected String | host
protected String | newsgroup
Constructor Summary
NewsAddress()
Default constructor.
NewsAddress(String newsgroup)
Construct a NewsAddress with the given newsgroup.
NewsAddress(String newsgroup, String host)
Construct a NewsAddress with the given newsgroup and host.
Method Summary
boolean | equals(Object a) The equality operator.
String | getHost() Get the host.
String | getNewsgroup() Get the newsgroup.
String | getType() Return the type of this address.
int | hashCode() Compute a hash code for the address.
static NewsAddress[] | parse(String newsgroups) Parse the given comma separated sequence of newsgroup into NewsAddress objects.
void | setHost(String host) Set the host.
void | setNewsgroup(String newsgroup) Set the newsgroup.
String | toString() Convert this address into a RFC 1036 address.
static String | toString(Address[] addresses) Convert the given array of NewsAddress objects into a comma separated sequence of address strings.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

newsgroup

protected String newsgroup

host

protected String host
Constructor Detail

NewsAddress

public NewsAddress()
Default constructor.

NewsAddress

public NewsAddress(String newsgroup)
Construct a NewsAddress with the given newsgroup.

Parameters:
newsgroup - the newsgroup

NewsAddress

public NewsAddress(String newsgroup,
                   String host)
Construct a NewsAddress with the given newsgroup and host.

Parameters:
newsgroup - the newsgroup
host - the host
Method Detail

getType

public String getType()
Return the type of this address. The type of a NewsAddress is "news".

Specified by:
getType in class Address
Returns:
address type
See Also:
InternetAddress

setNewsgroup

public void setNewsgroup(String newsgroup)
Set the newsgroup.

Parameters:
newsgroup - the newsgroup

getNewsgroup

public String getNewsgroup()
Get the newsgroup.

Returns:
newsgroup

setHost

public void setHost(String host)
Set the host.

Parameters:
host - the host

getHost

public String getHost()
Get the host.

Returns:
host

toString

public String toString()
Convert this address into a RFC 1036 address.

Specified by:
toString in class Address
Returns:
newsgroup

equals

public boolean equals(Object a)
The equality operator.

Specified by:
equals in class Address
Parameters:
a - Address object

hashCode

public int hashCode()
Compute a hash code for the address.

toString

public static String toString(Address[] addresses)
Convert the given array of NewsAddress objects into a comma separated sequence of address strings. The resulting string contains only US-ASCII characters, and hence is mail-safe.

Parameters:
addresses - array of NewsAddress objects
Returns:
comma separated address strings
Throws:
ClassCastException, - if any address object in the given array is not a NewsAddress objects. Note that this is a RuntimeException.

parse

public static NewsAddress[] parse(String newsgroups)
                           throws AddressException
Parse the given comma separated sequence of newsgroup into NewsAddress objects.

Parameters:
newsgroups - comma separated newsgroup string
Returns:
array of NewsAddress objects
Throws:
AddressException - if the parse failed
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ParameterList

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class ParameterList

java.lang.Object
    extended by javax.mail.internet.ParameterList
public class ParameterList
extends Object

This class holds MIME parameters (attribute-value pairs).

Version:
1.10, 03/02/12
Author:
John Mani

Constructor Summary
ParameterList()
No-arg Constructor.
ParameterList(String s)
Constructor that takes a parameter-list string.
Method Summary
String | get(String name) Returns the value of the specified parameter.
Enumeration | getNames() Return an enumeration of the names of all parameters in this list.
void | remove(String name) Removes the specified parameter from this ParameterList.
void | set(String name, String value) Set a parameter.
int | size() Return the number of parameters in this list.
String | toString() Convert this ParameterList into a MIME String.
String | toString(int used) Convert this ParameterList into a MIME String.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ParameterList

public ParameterList()
No-arg Constructor.

ParameterList

public ParameterList(String s)
              throws ParseException
Constructor that takes a parameter-list string. The String is parsed and the parameters are collected and stored internally. A ParseException is thrown if the parse fails. Note that an empty parameter-list string is valid and will be parsed into an empty ParameterList.

Parameters:
s - the parameter-list string.
Throws:
ParseException - if the parse fails.
Method Detail

size

public int size()
Return the number of parameters in this list.

Returns:
number of parameters.

get

public String get(String name)
Returns the value of the specified parameter. Note that parameter names are case-insensitive.

Parameters:
name - parameter name.
Returns:
Value of the parameter. Returns null if the parameter is not present.

set

public void set(String name,
                String value)
Set a parameter. If this parameter already exists, it is replaced by this new value.

Parameters:
name - name of the parameter.
value - value of the parameter.

remove

public void remove(String name)
Removes the specified parameter from this ParameterList. This method does nothing if the parameter is not present.

Parameters:
name - name of the parameter.

getNames

public Enumeration getNames()
Return an enumeration of the names of all parameters in this list.

Returns:
Enumeration of all parameter names in this list.

toString

public String toString()
Convert this ParameterList into a MIME String. If this is an empty list, an empty string is returned.

Returns:
String

toString

public String toString(int used)
Convert this ParameterList into a MIME String. If this is an empty list, an empty string is returned. The 'used' parameter specifies the number of character positions already taken up in the field into which the resulting parameter list is to be inserted. It's used to determine where to fold the resulting parameter list.

Parameters:
used - number of character positions already used, in the field into which the parameter list is to be inserted.
Returns:
String
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ParseException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class ParseException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.internet.ParseException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AddressException
public class ParseException
extends MessagingException

The exception thrown due to an error in parsing RFC822 or MIME headers

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
ParseException()
Constructs a ParseException with no detail message.
ParseException(String s)
Constructs a ParseException with the specified detail message.
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ParseException

public ParseException()
Constructs a ParseException with no detail message.

ParseException

public ParseException(String s)
Constructs a ParseException with the specified detail message.

Parameters:
s - the detail message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SharedInputStream

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Interface SharedInputStream

public interface SharedInputStream

An InputStream that is backed by data that can be shared by multiple readers may implement this interface. This allows users of such an InputStream to determine the current positionin the InputStream, and to create new InputStreams representing a subset of the data in the original InputStream. The new InputStream will access the same underlying data as the original, without copying the data.

Since:
JavaMail 1.2
Version:
1.2, 02/03/27
Author:
Bill Shannon

Method Summary
long | getPosition() Return the current position in the InputStream, as an offset from the beginning of the InputStream.
InputStream | newStream(long start, long end) Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive).

Method Detail

getPosition

public long getPosition()
Return the current position in the InputStream, as an offset from the beginning of the InputStream.

Returns:
the current position

newStream

public InputStream newStream(long start,
                             long end)
Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive). start must be non-negative. If end is -1, the new stream ends at the same place as this stream. The returned InputStream will also implement the SharedInputStream interface.

Parameters:
start - the starting position
end - the ending position + 1
Returns:
the new stream
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Message

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Message

java.lang.Object
    extended by javax.mail.Message
All Implemented Interfaces:
Part
Direct Known Subclasses:
MimeMessage
public abstract class Message
extends Object
implements Part

This class models an email message. This is an abstract class. Subclasses provide actual implementations.

Message implements the Part interface. Message contains a set of attributes and a "content". Messages within a folder also have a set of flags that describe its state within the folder.

Message defines some new attributes in addition to those defined in the Part interface. These attributes specify meta-data for the message - i.e., addressing and descriptive information about the message.

Message objects are obtained either from a Folder or by constructing a new Message object of the appropriate subclass. Messages that have been received are normally retrieved from a folder named "INBOX".

A Message object obtained from a folder is just a lightweight reference to the actual message. The Message is 'lazily' filled up (on demand) when each item is requested from the message. Note that certain folder implementations may return Message objects that are pre-filled with certain user-specified items. To send a message, an appropriate subclass of Message (e.g., MimeMessage) is instantiated, the attributes and content are filled in, and the message is sent using the Transport.send method.

Author:
John Mani, Bill Shannon, Max Spivak
See Also:
Part

Nested Class Summary
static class Message.RecipientType
This inner class defines the types of recipients allowed by the Message class.
Field Summary
protected boolean | expunged True if this message has been expunged.
protected Folder | folder The containing folder, if this message is obtained from a folder
protected int | msgnum The number of this message within its folder, or zero if the message was not retrieved from a folder.
protected Session | session The Session object for this Message
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Constructor Summary
protected | Message() No-arg version of the constructor.
protected | Message(Folder folder, int msgnum) Constructor that takes a Folder and a message number.
protected | Message(Session session) Constructor that takes a Session.
Method Summary
abstract void | addFrom(Address[] addresses) Add these addresses to the existing "From" attribute
void | addRecipient(Message.RecipientType type, Address address) Add this recipient address to the existing ones of the given type.
abstract void | addRecipients(Message.RecipientType type, Address[] addresses) Add these recipient addresses to the existing ones of the given type.
Address[] | getAllRecipients() Get all the recipient addresses for the message.
abstract Flags | getFlags() Returns a Flags object containing the flags for this message.
Folder | getFolder() Get the folder from which this message was obtained.
abstract Address[] | getFrom() Returns the "From" attribute.
int | getMessageNumber() Get the Message number for this Message.
abstract Date | getReceivedDate() Get the date this message was received.
abstract Address[] | getRecipients(Message.RecipientType type) Get all the recipient addresses of the given type.
Address[] | getReplyTo() Get the addresses to which replies should be directed.
abstract Date | getSentDate() Get the date this message was sent.
abstract String | getSubject() Get the subject of this message.
boolean | isExpunged() Checks whether this message is expunged.
boolean | isSet(Flags.Flag flag) Check whether the flag specified in the flag argument is set in this message.
boolean | match(SearchTerm term) Apply the specified Search criterion to this message.
abstract Message | reply(boolean replyToAll) Get a new Message suitable for a reply to this message.
abstract void | saveChanges() Save any changes made to this message into the message-store when the containing folder is closed, if the message is contained in a folder.
protected void | setExpunged(boolean expunged) Sets the expunged flag for this Message.
void | setFlag(Flags.Flag flag, boolean set) Set the specified flag on this message to the specified value.
abstract void | setFlags(Flags flag, boolean set) Set the specified flags on this message to the specified value.
abstract void | setFrom() Set the "From" attribute in this Message.
abstract void | setFrom(Address address) Set the "From" attribute in this Message.
protected void | setMessageNumber(int msgnum) Set the Message number for this Message.
void | setRecipient(Message.RecipientType type, Address address) Set the recipient address.
abstract void | setRecipients(Message.RecipientType type, Address[] addresses) Set the recipient addresses.
void | setReplyTo(Address[] addresses) Set the addresses to which replies should be directed.
abstract void | setSentDate(Date date) Set the sent date of this message.
abstract void | setSubject(String subject) Set the subject of this message.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.mail.Part
addHeader, getAllHeaders, getContent, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getInputStream, getLineCount, getMatchingHeaders, getNonMatchingHeaders, getSize, isMimeType, removeHeader, setContent, setContent, setDataHandler, setDescription, setDisposition, setFileName, setHeader, setText, writeTo

Field Detail

msgnum

protected int msgnum
The number of this message within its folder, or zero if the message was not retrieved from a folder.

expunged

protected boolean expunged
True if this message has been expunged.

folder

protected Folder folder
The containing folder, if this message is obtained from a folder

session

protected Session session
The Session object for this Message

Constructor Detail

Message

protected Message()
No-arg version of the constructor.

Message

protected Message(Folder folder,
                  int msgnum)
Constructor that takes a Folder and a message number. Used by Folder implementations.

Parameters:
folder - containing folder
msgnum - this message's sequence number within this folder

Message

protected Message(Session session)
Constructor that takes a Session. Used for client created Message objects.

Parameters:
session - A Session object
Method Detail

getFrom

public abstract Address[] getFrom()
                           throws MessagingException
Returns the "From" attribute. The "From" attribute contains the identity of the person(s) who wished this message to be sent.

In certain implementations, this may be different from the entity that actually sent the message.

This method returns null if this attribute is not present in this message. Returns an empty array if this attribute is present, but contains no addresses.

Returns:
array of Address objects
Throws:
MessagingException

setFrom

public abstract void setFrom()
                      throws MessagingException
Set the "From" attribute in this Message. The value of this attribute is obtained from the property "mail.user". If this property is absent, the system property "user.name" is used.

Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

setFrom

public abstract void setFrom(Address address)
                      throws MessagingException
Set the "From" attribute in this Message.

Parameters:
address - the sender
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

addFrom

public abstract void addFrom(Address[] addresses)
                      throws MessagingException
Add these addresses to the existing "From" attribute

Parameters:
addresses - the senders
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getRecipients

public abstract Address[] getRecipients(Message.RecipientType type)
                                 throws MessagingException
Get all the recipient addresses of the given type.

This method returns null if no recipients of the given type are present in this message. It may return an empty array if the header is present, but contains no addresses.

Parameters:
type - the recipient type
Returns:
array of Address objects
Throws:
MessagingException
See Also:
Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC

getAllRecipients

public Address[] getAllRecipients()
                           throws MessagingException
Get all the recipient addresses for the message. The default implementation extracts the TO, CC, and BCC recipients using the getRecipients method.

This method returns null if none of the recipient headers are present in this message. It may Return an empty array if any recipient header is present, but contains no addresses.

Returns:
array of Address objects
Throws:
MessagingException
See Also:
Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC, getRecipients(javax.mail.Message.RecipientType)

setRecipients

public abstract void setRecipients(Message.RecipientType type,
                                   Address[] addresses)
                            throws MessagingException
Set the recipient addresses. All addresses of the specified type are replaced by the addresses parameter.

Parameters:
type - the recipient type
addresses - the addresses
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

setRecipient

public void setRecipient(Message.RecipientType type,
                         Address address)
                  throws MessagingException
Set the recipient address. All addresses of the specified type are replaced by the address parameter.

The default implementation uses the setRecipients method.

Parameters:
type - the recipient type
address - the address
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values

addRecipients

public abstract void addRecipients(Message.RecipientType type,
                                   Address[] addresses)
                            throws MessagingException
Add these recipient addresses to the existing ones of the given type.

Parameters:
type - the recipient type
addresses - the addresses
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

addRecipient

public void addRecipient(Message.RecipientType type,
                         Address address)
                  throws MessagingException
Add this recipient address to the existing ones of the given type.

The default implementation uses the addRecipients method.

Parameters:
type - the recipient type
address - the address
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values

getReplyTo

public Address[] getReplyTo()
                     throws MessagingException
Get the addresses to which replies should be directed. This will usually be the sender of the message, but some messages may direct replies to a different address.

The default implementation simply calls the getFrom method.

This method returns null if the corresponding header is not present. Returns an empty array if the header is present, but contains no addresses.

Returns:
addresses to which replies should be directed
Throws:
MessagingException
See Also:
getFrom()

setReplyTo

public void setReplyTo(Address[] addresses)
                throws MessagingException
Set the addresses to which replies should be directed. (Normally only a single address will be specified.) Not all message types allow this to be specified separately from the sender of the message.

The default implementation provided here just throws the MethodNotSupportedException.

Parameters:
addresses - addresses to which replies should be directed
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MethodNotSupportedException - if the underlying implementation does not support setting this attribute

getSubject

public abstract String getSubject()
                           throws MessagingException
Get the subject of this message.

Returns:
the subject
Throws:
MessagingException

setSubject

public abstract void setSubject(String subject)
                         throws MessagingException
Set the subject of this message.

Parameters:
subject - the subject
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

getSentDate

public abstract Date getSentDate()
                          throws MessagingException
Get the date this message was sent.

Returns:
the date this message was sent
Throws:
MessagingException

setSentDate

public abstract void setSentDate(Date date)
                          throws MessagingException
Set the sent date of this message.

Parameters:
date - the sent date of this message
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

getReceivedDate

public abstract Date getReceivedDate()
                              throws MessagingException
Get the date this message was received.

Returns:
the date this message was received
Throws:
MessagingException

getFlags

public abstract Flags getFlags()
                        throws MessagingException
Returns a Flags object containing the flags for this message.

Modifying any of the flags in this returned Flags object will not affect the flags of this message. Use setFlags() to do that.

Returns:
Flags object containing the flags for this message
Throws:
MessagingException
See Also:
Flags, setFlags(javax.mail.Flags, boolean)

isSet

public boolean isSet(Flags.Flag flag)
              throws MessagingException
Check whether the flag specified in the flag argument is set in this message.

The default implementation uses getFlags.

Parameters:
flag - the flag
Returns:
value of the specified flag for this message
Throws:
MessagingException
See Also:
Flags.Flag, Flags.Flag.ANSWERED, Flags.Flag.DELETED, Flags.Flag.DRAFT, Flags.Flag.FLAGGED, Flags.Flag.RECENT, Flags.Flag.SEEN

setFlags

public abstract void setFlags(Flags flag,
                              boolean set)
                       throws MessagingException
Set the specified flags on this message to the specified value. Note that any flags in this message that are not specified in the given Flags object are unaffected.

This will result in a MessageChangedEvent being delivered to any MessageChangedListener registered on this Message's containing folder.

Parameters:
flag - Flags object containing the flags to be set
set - the value to be set
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values.
IllegalStateException - if this message is obtained from a READ_ONLY folder.
See Also:
MessageChangedEvent

setFlag

public void setFlag(Flags.Flag flag,
                    boolean set)
             throws MessagingException
Set the specified flag on this message to the specified value. This will result in a MessageChangedEvent being delivered to any MessageChangedListener registered on this Message's containing folder.

The default implementation uses the setFlags method.

Parameters:
flag - Flags.Flag object containing the flag to be set
set - the value to be set
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values.
IllegalStateException - if this message is obtained from a READ_ONLY folder.
See Also:
MessageChangedEvent

getMessageNumber

public int getMessageNumber()
Get the Message number for this Message. A Message object's message number is the relative position of this Message in its Folder. Note that the message number for a particular Message can change during a session if other messages in the Folder are deleted and expunged.

Valid message numbers start at 1. Messages that do not belong to any folder (like newly composed or derived messages) have 0 as their message number.

Returns:
the message number

setMessageNumber

protected void setMessageNumber(int msgnum)
Set the Message number for this Message. This method is invoked only by the implementation classes.

getFolder

public Folder getFolder()
Get the folder from which this message was obtained. If this is a new message or nested message, this method returns null.

Returns:
the containing folder

isExpunged

public boolean isExpunged()
Checks whether this message is expunged. All other methods except getMessageNumber() are invalid on an expunged Message object.

Messages that are expunged due to an explict expunge() request on the containing Folder are removed from the Folder immediately. Messages that are externally expunged by another source are marked "expunged" and return true for the isExpunged() method, but they are not removed from the Folder until an explicit expunge() is done on the Folder.

See the description of expunge() for more details on expunge handling.

See Also:
Folder.expunge()

setExpunged

protected void setExpunged(boolean expunged)
Sets the expunged flag for this Message. This method is to be used only by the implementation classes.

Parameters:
expunged - the expunged flag

reply

public abstract Message reply(boolean replyToAll)
                       throws MessagingException
Get a new Message suitable for a reply to this message. The new Message will have its attributes and headers set up appropriately. Note that this new message object will be empty, that is, it will not have a "content". These will have to be suitably filled in by the client.

If replyToAll is set, the new Message will be addressed to all recipients of this message. Otherwise, the reply will be addressed to only the sender of this message (using the value of the getReplyTo method).

The "Subject" field is filled in with the original subject prefixed with "Re:" (unless it already starts with "Re:").

The reply message will use the same session as this message.

Parameters:
replyToAll - reply should be sent to all recipients of this message
Returns:
the reply Message
Throws:
MessagingException

saveChanges

public abstract void saveChanges()
                          throws MessagingException
Save any changes made to this message into the message-store when the containing folder is closed, if the message is contained in a folder. (Some implementations may save the changes immediately.) Update any header fields to be consistent with the changed message contents. If any part of a message's headers or contents are changed, saveChanges must be called to ensure that those changes are permanent. If saveChanges is not called, any such modifications may or may not be saved, depending on the message store and folder implementation.

Messages obtained from folders opened READ_ONLY should not be modified and saveChanges should not be called on such messages.

Throws:
MessagingException
IllegalStateException - if this message is obtained from a READ_ONLY folder.
IllegalWriteException - if the underlying implementation does not support modification of existing values.

match

public boolean match(SearchTerm term)
              throws MessagingException
Apply the specified Search criterion to this message.

Parameters:
term - the Search criterion
Returns:
true if the Message matches this search criterion, false otherwise.
Throws:
MessagingException
See Also:
SearchTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Message.RecipientType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Message.RecipientType

java.lang.Object
    extended by javax.mail.Message.RecipientType
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MimeMessage.RecipientType
Enclosing class:
Message
public static class Message.RecipientType
extends Object
implements Serializable

This inner class defines the types of recipients allowed by the Message class. The currently defined types are TO, CC and BCC. Note that this class only has a protected constructor, thereby restricting new Recipient types to either this class or subclasses. This effectively implements an enumeration of the allowed Recipient types. The following code sample shows how to use this class to obtain the "TO" recipients from a message.

 Message msg = folder.getMessages(1);
 Address[] a = m.getRecipients(Message.RecipientType.TO);

See Also:
Message.getRecipients(javax.mail.Message.RecipientType),
Message.setRecipients(javax.mail.Message.RecipientType, javax.mail.Address[]),
Message.addRecipients(javax.mail.Message.RecipientType, javax.mail.Address[]),
Serialized Form

Field Summary
static Message.RecipientType | BCC The "Bcc" (blind carbon copy) recipients.
static Message.RecipientType | CC The "Cc" (carbon copy) recipients.
static Message.RecipientType | TO The "To" (primary) recipients.
protected String | type The type of recipient, usually the name of a corresponding Internet standard header.
Constructor Summary
protected Message.RecipientType(String type)
Constructor for use by subclasses.
Method Summary
protected Object | readResolve() When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

TO

public static final Message.RecipientType TO
The "To" (primary) recipients.

CC

public static final Message.RecipientType CC
The "Cc" (carbon copy) recipients.

BCC

public static final Message.RecipientType BCC
The "Bcc" (blind carbon copy) recipients.

type

protected String type
The type of recipient, usually the name of a corresponding Internet standard header.

Constructor Detail

Message.RecipientType

protected Message.RecipientType(String type)
Constructor for use by subclasses.

Method Detail

readResolve

protected Object readResolve()
                      throws ObjectStreamException
When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class. Subclasses must implement their own readResolve method that checks for their known instances before calling this super method.

Throws:
ObjectStreamException

toString

public String toString()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageAware

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail
Interface MessageAware

All Known Implementing Classes:
MimePartDataSource
public interface MessageAware

An interface optionally implemented by DataSources to supply information to a DataContentHandler about the message context in which the data content object is operating.

Since:
JavaMail 1.1
See Also:
MessageContext, DataSource, DataContentHandler

Method Summary
 MessageContext getMessageContext()
Return the message context.

Method Detail

getMessageContext

public MessageContext getMessageContext()
Return the message context.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class MessageContext

java.lang.Object
    extended by javax.mail.MessageContext
public class MessageContext
extends Object

The context in which a piece of Message content is contained. A MessageContext object is returned by the getMessageContext method of the MessageAware interface. MessageAware is typically implemented by DataSources to allow a DataContentHandler to pass on information about the context in which a data content object is operating.

Since:
JavaMail 1.1
See Also:
MessageAware, DataSource, DataContentHandler

Constructor Summary
MessageContext(Part part)
Create a MessageContext object describing the context of the given Part.
Method Summary
Message | getMessage() Return the Message that contains the content.
Part | getPart() Return the Part that contains the content.
Session | getSession() Return the Session we're operating in.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageContext

public MessageContext(Part part)
Create a MessageContext object describing the context of the given Part.

Method Detail

getPart

public Part getPart()
Return the Part that contains the content.

Returns:
the containing Part, or null if not known

getMessage

public Message getMessage()
Return the Message that contains the content. Follows the parent chain up through containing Multipart objects until it comes to a Message object, or null.

Returns:
the containing Message, or null if not known

getSession

public Session getSession()
Return the Session we're operating in.

Returns:
the Session, or null if not known
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageRemovedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class MessageRemovedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.MessageRemovedException
All Implemented Interfaces:
Serializable
public class MessageRemovedException
extends MessagingException

The exception thrown when an invalid method is invoked on an expunged Message. The only valid methods on an expunged Message are isExpunged() and getMessageNumber().

Author:
John Mani
See Also:
Message.isExpunged(), Message.getMessageNumber(), Serialized Form

Constructor Summary
MessageRemovedException()
Constructs a MessageRemovedException with no detail message.
MessageRemovedException(String s)
Constructs a MessageRemovedException with the specified detail message.
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessageRemovedException

public MessageRemovedException()
Constructs a MessageRemovedException with no detail message.

MessageRemovedException

public MessageRemovedException(String s)
Constructs a MessageRemovedException with the specified detail message.

Parameters:
s - the detail message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessagingException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class MessagingException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AuthenticationFailedException, FolderClosedException, FolderNotFoundException, IllegalWriteException, MessageRemovedException, MethodNotSupportedException, NoSuchProviderException, ParseException, ReadOnlyFolderException, SearchException, SendFailedException, StoreClosedException
public class MessagingException
extends Exception

The base class for all exceptions thrown by the Messaging classes

Author:
John Mani, Bill Shannon
See Also:
Serialized Form

Constructor Summary
MessagingException()
Constructs a MessagingException with no detail message.
MessagingException(String s)
Constructs a MessagingException with the specified detail message.
MessagingException(String s, Exception e)
Constructs a MessagingException with the specified Exception and detail message.
Method Summary
String | getMessage() Produce the message, include the message from the nested exception if there is one.
Exception | getNextException() Get the next exception chained to this one.
boolean | setNextException(Exception ex) Add an exception to the end of the chain.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessagingException

public MessagingException()
Constructs a MessagingException with no detail message.

MessagingException

public MessagingException(String s)
Constructs a MessagingException with the specified detail message.

Parameters:
s - the detail message

MessagingException

public MessagingException(String s,
                          Exception e)
Constructs a MessagingException with the specified Exception and detail message. The specified exception is chained to this exception.

Parameters:
s - the detail message
e - the embedded exception
See Also:
getNextException(), setNextException(java.lang.Exception)
Method Detail

getNextException

public Exception getNextException()
Get the next exception chained to this one. If the next exception is a MessagingException, the chain may extend further.

Returns:
next Exception, null if none.

setNextException

public boolean setNextException(Exception ex)
Add an exception to the end of the chain. If the end is not a MessagingException, this exception cannot be added to the end.

Parameters:
ex - the new end of the Exception chain
Returns:
true if the this Exception was added, false otherwise.

getMessage

public String getMessage()
Produce the message, include the message from the nested exception if there is one.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MethodNotSupportedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class MethodNotSupportedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.MethodNotSupportedException
All Implemented Interfaces:
Serializable
public class MethodNotSupportedException
extends MessagingException

The exception thrown when a method is not supported by the implementation

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
MethodNotSupportedException()
Constructs a MethodNotSupportedException with no detail message.
MethodNotSupportedException(String s)
Constructs a MethodNotSupportedException with the specified detail message.
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MethodNotSupportedException

public MethodNotSupportedException()
Constructs a MethodNotSupportedException with no detail message.

MethodNotSupportedException

public MethodNotSupportedException(String s)
Constructs a MethodNotSupportedException with the specified detail message.

Parameters:
s - the detail message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Multipart

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Multipart

java.lang.Object
    extended by javax.mail.Multipart
Direct Known Subclasses:
MimeMultipart
public abstract class Multipart
extends Object

Multipart is a container that holds multiple body parts. Multipart provides methods to retrieve and set its subparts.

Multipart also acts as the base class for the content object returned by most Multipart DataContentHandlers. For example, invoking getContent() on a DataHandler whose source is a "multipart/signed" data source may return an appropriate subclass of Multipart.

Some messaging systems provide different subtypes of Multiparts. For example, MIME specifies a set of subtypes that include "alternative", "mixed", "related", "parallel", "signed", etc.

Multipart is an abstract class. Subclasses provide actual implementations.

Version:
1.13, 02/03/27
Author:
John Mani

Field Summary
protected String | contentType This field specifies the content-type of this multipart object.
protected Part | parent The Part containing this Multipart, if known.
protected Vector | parts Vector of BodyPart objects.
Constructor Summary
protected Multipart()
Default constructor.
Method Summary
void | addBodyPart(BodyPart part) Adds a Part to the multipart.
void | addBodyPart(BodyPart part, int index) Adds a BodyPart at position index.
BodyPart | getBodyPart(int index) Get the specified Part.
String | getContentType() Return the content-type of this Multipart.
int | getCount() Return the number of enclosed BodyPart objects.
Part | getParent() Return the Part that contains this Multipart object, or null if not known.
boolean | removeBodyPart(BodyPart part) Remove the specified part from the multipart message.
void | removeBodyPart(int index) Remove the part at specified location (starting from 0).
protected void | setMultipartDataSource(MultipartDataSource mp) Setup this Multipart object from the given MultipartDataSource.
void | setParent(Part parent) Set the parent of this Multipart to be the specified Part.
abstract void | writeTo(OutputStream os) Output an appropriately encoded bytestream to the given OutputStream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

parts

protected Vector parts
Vector of BodyPart objects.

contentType

protected String contentType
This field specifies the content-type of this multipart object. It defaults to "multipart/mixed".

parent

protected Part parent
The Part containing this Multipart, if known.

Since:
JavaMail 1.1
Constructor Detail

Multipart

protected Multipart()
Default constructor. An empty Multipart object is created.

Method Detail

setMultipartDataSource

protected void setMultipartDataSource(MultipartDataSource mp)
                               throws MessagingException
Setup this Multipart object from the given MultipartDataSource.

The method adds the MultipartDataSource's BodyPart objects into this Multipart. This Multipart's contentType is set to that of the MultipartDataSource.

This method is typically used in those cases where one has a multipart data source that has already been pre-parsed into the individual body parts (for example, an IMAP datasource), but needs to create an appropriate Multipart subclass that represents a specific multipart subtype.

Parameters:
mp - Multipart datasource
Throws:
MessagingException

getContentType

public String getContentType()
Return the content-type of this Multipart.

This implementation just returns the value of the contentType field.

Returns:
content-type
See Also:
contentType

getCount

public int getCount()
             throws MessagingException
Return the number of enclosed BodyPart objects.

Returns:
number of parts
Throws:
MessagingException
See Also:
parts

getBodyPart

public BodyPart getBodyPart(int index)
                     throws MessagingException
Get the specified Part. Parts are numbered starting at 0.

Parameters:
index - the index of the desired Part
Returns:
the Part
Throws:
IndexOutOfBoundsException - if the given index is out of range.
MessagingException

removeBodyPart

public boolean removeBodyPart(BodyPart part)
                       throws MessagingException
Remove the specified part from the multipart message. Shifts all the parts after the removed part down one.

Parameters:
part - The part to remove
Returns:
true if part removed, false otherwise
Throws:
MessagingException - if no such Part exists
IllegalWriteException - if the underlying implementation does not support modification of existing values

removeBodyPart

public void removeBodyPart(int index)
                    throws MessagingException
Remove the part at specified location (starting from 0). Shifts all the parts after the removed part down one.

Parameters:
index - Index of the part to remove
Throws:
MessagingException
IndexOutOfBoundsException - if the given index is out of range.
IllegalWriteException - if the underlying implementation does not support modification of existing values

addBodyPart

public void addBodyPart(BodyPart part)
                 throws MessagingException
Adds a Part to the multipart. The BodyPart is appended to the list of existing Parts.

Parameters:
part - The Part to be appended
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values

addBodyPart

public void addBodyPart(BodyPart part,
                        int index)
                 throws MessagingException
Adds a BodyPart at position index. If index is not the last one in the list, the subsequent parts are shifted up. If index is larger than the number of parts present, the BodyPart is appended to the end.

Parameters:
part - The BodyPart to be inserted
index - Location where to insert the part
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values

writeTo

public abstract void writeTo(OutputStream os)
                      throws IOException,
                             MessagingException
Output an appropriately encoded bytestream to the given OutputStream. The implementation subclass decides the appropriate encoding algorithm to be used. The bytestream is typically used for sending.

Throws:
IOException - if an IO related exception occurs
MessagingException

getParent

public Part getParent()
Return the Part that contains this Multipart object, or null if not known.

Since:
JavaMail 1.1

setParent

public void setParent(Part parent)
Set the parent of this Multipart to be the specified Part. Normally called by the Message or BodyPart setContent(Multipart) method. parent may be null if the Multipart is being removed from its containing Part.

Since:
JavaMail 1.1
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MultipartDataSource

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Interface MultipartDataSource

All Superinterfaces:
DataSource
public interface MultipartDataSource
extends DataSource

MultipartDataSource is a DataSource that contains body parts. This allows "mail aware" DataContentHandlers to be implemented more efficiently by being aware of such DataSources and using the appropriate methods to access BodyParts.

Note that the data of a MultipartDataSource is also available as an input stream.

This interface will typically be implemented by providers that preparse multipart bodies, for example an IMAP provider.

Version:
1.6, 02/03/27
Author:
John Mani
See Also:
DataSource

Method Summary
BodyPart | getBodyPart(int index) Get the specified Part.
int | getCount() Return the number of enclosed BodyPart objects.
Methods inherited from interface javax.activation.DataSource
getContentType, getInputStream, getName, getOutputStream

Method Detail

getCount

public int getCount()
Return the number of enclosed BodyPart objects.

Returns:
number of parts

getBodyPart

public BodyPart getBodyPart(int index)
                     throws MessagingException
Get the specified Part. Parts are numbered starting at 0.

Parameters:
index - the index of the desired Part
Returns:
the Part
Throws:
IndexOutOfBoundsException - if the given index is out of range.
MessagingException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NoSuchProviderException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class NoSuchProviderException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.NoSuchProviderException
All Implemented Interfaces:
Serializable
public class NoSuchProviderException
extends MessagingException

This exception is thrown when Session attempts to instantiate a Provider that doesn't exist.

Author:
Max Spivak
See Also:
Serialized Form

Constructor Summary
NoSuchProviderException()
Constructor.
NoSuchProviderException(String message)
Constructor.
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoSuchProviderException

public NoSuchProviderException()
Constructor.

NoSuchProviderException

public NoSuchProviderException(String message)
Constructor.

Parameters:
message - The detailed error message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Part

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Interface Part

All Known Subinterfaces:
MimePart
All Known Implementing Classes:
BodyPart, Message, MimeBodyPart, MimeMessage
public interface Part

The Part interface is the common base interface for Messages and BodyParts.

Part consists of a set of attributes and a "Content".

Attributes:

The JavaMail API defines a set of standard Part attributes that are considered to be common to most existing Mail systems. These attributes have their own settor and gettor methods. Mail systems may support other Part attributes as well, these are represented as name-value pairs where both the name and value are Strings.

Content:

The data type of the "content" is returned by the getContentType() method. The MIME typing system is used to name data types.

The "content" of a Part is available in various formats:

  • As a DataHandler - using the getDataHandler() method. The "content" of a Part is also available through a javax.activation.DataHandler object. The DataHandler object allows clients to discover the operations available on the content, and to instantiate the appropriate component to perform those operations.
  • As an input stream - using the getInputStream() method. Any mail-specific encodings are decoded before this stream is returned.
  • As a Java object - using the getContent() method. This method returns the "content" as a Java object. The returned object is of course dependent on the content itself. In particular, a "multipart" Part's content is always a Multipart or subclass thereof. That is, getContent() on a "multipart" type Part will always return a Multipart (or subclass) object.
Part provides the writeTo() method that streams out its bytestream in mail-safe form suitable for transmission. This bytestream is typically an aggregation of the Part attributes and its content's bytestream.

Message and BodyPart implement the Part interface. Note that in MIME parlance, Part models an Entity (RFC 2045, Section 2.4).

Author:
John Mani

Field Summary
static String | ATTACHMENT This part should be presented as an attachment.
static String | INLINE This part should be presented inline.
Method Summary
void | addHeader(String header_name, String header_value) Add this value to the existing values for this header_name.
Enumeration | getAllHeaders() Return all the headers from this part as an Enumeration of Header objects.
Object | getContent() Return the content as a Java object.
String | getContentType() Returns the Content-Type of the content of this part.
DataHandler | getDataHandler() Return a DataHandler for the content within this part.
String | getDescription() Return a description String for this part.
String | getDisposition() Return the disposition of this part.
String | getFileName() Get the filename associated with this part, if possible.
String[] | getHeader(String header_name) Get all the headers for this header name.
InputStream | getInputStream() Return an input stream for this part's "content".
int | getLineCount() Return the number of lines in the content of this part.
Enumeration | getMatchingHeaders(String[] header_names) Return matching headers from this part as an Enumeration of Header objects.
Enumeration | getNonMatchingHeaders(String[] header_names) Return non-matching headers from this envelope as an Enumeration of Header objects.
int | getSize() Return the size of the content of this part in bytes.
boolean | isMimeType(String mimeType) Is this Part of the specified MIME type?
void | removeHeader(String header_name) Remove all headers with this name.
void | setContent(Multipart mp) This method sets the given Multipart object as this message's content.
void | setContent(Object obj, String type) A convenience method for setting this part's content.
void | setDataHandler(DataHandler dh) This method provides the mechanism to set this part's content.
void | setDescription(String description) Set a description String for this part.
void | setDisposition(String disposition) Set the disposition of this part.
void | setFileName(String filename) Set the filename associated with this part, if possible.
void | setHeader(String header_name, String header_value) Set the value for this header_name.
void | setText(String text) A convenience method that sets the given String as this part's content with a MIME type of "text/plain".
void | writeTo(OutputStream os) Output a bytestream for this Part.

Field Detail

ATTACHMENT

public static final String ATTACHMENT
This part should be presented as an attachment.

See Also:
getDisposition(), setDisposition(java.lang.String), Constant Field Values

INLINE

public static final String INLINE
This part should be presented inline.

See Also:
getDisposition(), setDisposition(java.lang.String), Constant Field Values
Method Detail

getSize

public int getSize()
            throws MessagingException
Return the size of the content of this part in bytes. Return -1 if the size cannot be determined.

Note that the size may not be an exact measure of the content size and may or may not account for any transfer encoding of the content. The size is appropriate for display in a user interface to give the user a rough idea of the size of this part.

Returns:
size of content in bytes
Throws:
MessagingException

getLineCount

public int getLineCount()
                 throws MessagingException
Return the number of lines in the content of this part. Return -1 if the number cannot be determined. Note that this number may not be an exact measure of the content length and may or may not account for any transfer encoding of the content.

Returns:
number of lines in the content.
Throws:
MessagingException

getContentType

public String getContentType()
                      throws MessagingException
Returns the Content-Type of the content of this part. Returns null if the Content-Type could not be determined.

The MIME typing system is used to name Content-types.

Returns:
The ContentType of this part
Throws:
MessagingException
See Also:
DataHandler

isMimeType

public boolean isMimeType(String mimeType)
                   throws MessagingException
Is this Part of the specified MIME type? This method compares only the primaryType and subType. The parameters of the content types are ignored.

For example, this method will return true when comparing a Part of content type "text/plain" with "text/plain; charset=foobar".

If the subType of mimeType is the special character '*', then the subtype is ignored during the comparison.

Throws:
MessagingException

getDisposition

public String getDisposition()
                      throws MessagingException
Return the disposition of this part. The disposition describes how the part should be presented to the user. (See RFC 2183.) The return value should be considered without regard to case. For example:

 String disp = part.getDisposition();
 if (disp == null || disp.equalsIgnoreCase(Part.ATTACHMENT))
    // treat as attachment if not first part

Returns:
disposition of this part, or null if unknown
Throws:
MessagingException
See Also:
ATTACHMENT, INLINE, getFileName()

setDisposition

public void setDisposition(String disposition)
                    throws MessagingException
Set the disposition of this part.

Parameters:
disposition - disposition of this part
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of this header
IllegalStateException - if this Part is obtained from a READ_ONLY folder
See Also:
ATTACHMENT, INLINE, setFileName(java.lang.String)

getDescription

public String getDescription()
                      throws MessagingException
Return a description String for this part. This typically associates some descriptive information with this part. Returns null if none is available.

Returns:
description of this part
Throws:
MessagingException

setDescription

public void setDescription(String description)
                    throws MessagingException
Set a description String for this part. This typically associates some descriptive information with this part.

Parameters:
description - description of this part
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of this header
IllegalStateException - if this Part is obtained from a READ_ONLY folder

getFileName

public String getFileName()
                   throws MessagingException
Get the filename associated with this part, if possible. Useful if this part represents an "attachment" that was loaded from a file. The filename will usually be a simple name, not including directory components.

Returns:
Filename to associate with this part
Throws:
MessagingException

setFileName

public void setFileName(String filename)
                 throws MessagingException
Set the filename associated with this part, if possible. Useful if this part represents an "attachment" that was loaded from a file. The filename will usually be a simple name, not including directory components.

Parameters:
filename - Filename to associate with this part
Throws:
IllegalWriteException - if the underlying implementation does not support modification of this header
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

getInputStream

public InputStream getInputStream()
                           throws IOException,
                                  MessagingException
Return an input stream for this part's "content". Any mail-specific transfer encodings will be decoded before the input stream is provided.

This is typically a convenience method that just invokes the DataHandler's getInputStream() method.

Returns:
an InputStream
Throws:
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
MessagingException
See Also:
getDataHandler(), DataHandler.getInputStream()

getDataHandler

public DataHandler getDataHandler()
                           throws MessagingException
Return a DataHandler for the content within this part. The DataHandler allows clients to operate on as well as retrieve the content.

Returns:
DataHandler for the content
Throws:
MessagingException

getContent

public Object getContent()
                  throws IOException,
                         MessagingException
Return the content as a Java object. The type of the returned object is of course dependent on the content itself. For example, the object returned for "text/plain" content is usually a String object. The object returned for a "multipart" content is always a Multipart subclass. For content-types that are unknown to the DataHandler system, an input stream is returned as the content

This is a convenience method that just invokes the DataHandler's getContent() method

Returns:
Object
Throws:
MessagingException
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
See Also:
DataHandler.getContent()

setDataHandler

public void setDataHandler(DataHandler dh)
                    throws MessagingException
This method provides the mechanism to set this part's content. The DataHandler wraps around the actual content.

Parameters:
dh - The DataHandler for the content.
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder

setContent

public void setContent(Object obj,
                       String type)
                throws MessagingException
A convenience method for setting this part's content. The part internally wraps the content in a DataHandler.

Note that a DataContentHandler class for the specified type should be available to the JavaMail implementation for this to work right. i.e., to do setContent(foobar, "application/x-foobar"), a DataContentHandler for "application/x-foobar" should be installed. Refer to the Java Activation Framework for more information.

Parameters:
obj - A java object.
type - MIME type of this object.
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

setText

public void setText(String text)
             throws MessagingException
A convenience method that sets the given String as this part's content with a MIME type of "text/plain".

Parameters:
text - The text that is the Message's content.
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

setContent

public void setContent(Multipart mp)
                throws MessagingException
This method sets the given Multipart object as this message's content.

Parameters:
mp - The multipart object that is the Message's content
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

writeTo

public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
Output a bytestream for this Part. This bytestream is typically an aggregration of the Part attributes and an appropriately encoded bytestream from its 'content'.

Classes that implement the Part interface decide on the appropriate encoding algorithm to be used.

The bytestream is typically used for sending.

Throws:
IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
MessagingException - if an error occurs fetching the data to be written
See Also:
DataHandler.writeTo(java.io.OutputStream)

getHeader

public String[] getHeader(String header_name)
                   throws MessagingException
Get all the headers for this header name. Returns null if no headers for this header name are available.

Parameters:
header_name - the name of this header
Returns:
the value fields for all headers with this name
Throws:
MessagingException

setHeader

public void setHeader(String header_name,
                      String header_value)
               throws MessagingException
Set the value for this header_name. Replaces all existing header values with this new value.

Parameters:
header_name - the name of this header
header_value - the value for this header
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder

addHeader

public void addHeader(String header_name,
                      String header_value)
               throws MessagingException
Add this value to the existing values for this header_name.

Parameters:
header_name - the name of this header
header_value - the value for this header
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder

removeHeader

public void removeHeader(String header_name)
                  throws MessagingException
Remove all headers with this name.

Parameters:
header_name - the name of this header
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder

getAllHeaders

public Enumeration getAllHeaders()
                          throws MessagingException
Return all the headers from this part as an Enumeration of Header objects.

Returns:
enumeration of Header objects
Throws:
MessagingException

getMatchingHeaders

public Enumeration getMatchingHeaders(String[] header_names)
                               throws MessagingException
Return matching headers from this part as an Enumeration of Header objects.

Returns:
enumeration of Header objects
Throws:
MessagingException

getNonMatchingHeaders

public Enumeration getNonMatchingHeaders(String[] header_names)
                                  throws MessagingException
Return non-matching headers from this envelope as an Enumeration of Header objects.

Returns:
enumeration of Header objects
Throws:
MessagingException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PasswordAuthentication

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class PasswordAuthentication

java.lang.Object
    extended by javax.mail.PasswordAuthentication
public final class PasswordAuthentication
extends Object

The class PasswordAuthentication is a data holder that is used by Authenticator. It is simply a repository for a user name and a password.

Version:
1.4, 03/27/02
Author:
Bill Foote
See Also:
PasswordAuthentication, Authenticator, Authenticator.getPasswordAuthentication()

Constructor Summary
PasswordAuthentication(String userName, String password)
Initialize a new PasswordAuthentication
Method Summary
String | getPassword()
String | getUserName()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PasswordAuthentication

public PasswordAuthentication(String userName,
                              String password)
Initialize a new PasswordAuthentication

Parameters:
userName - the user name
password - The user's password
Method Detail

getUserName

public String getUserName()
Returns:
the user name

getPassword

public String getPassword()
Returns:
the password
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Provider

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Provider

java.lang.Object
    extended by javax.mail.Provider
public class Provider
extends Object

The Provider is a class that describes a protocol implementation. The values come from the javamail.providers & javamail.default.providers resource files.

Version:
1.8, 02/03/27
Author:
Max Spivak

Nested Class Summary
static class Provider.Type
This inner class defines the Provider type.
Method Summary
 String getClassName()
Returns name of the class that implements the protocol
 String getProtocol()
Returns the protocol supported by this Provider
 Provider.Type getType()
Returns the type of this Provider
 String getVendor()
Returns name of vendor associated with this implementation or null
 String getVersion()
Returns version of this implementation or null if no version
 String toString()
Overrides Object.toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getType

public Provider.Type getType()
Returns the type of this Provider

getProtocol

public String getProtocol()
Returns the protocol supported by this Provider

getClassName

public String getClassName()
Returns name of the class that implements the protocol

getVendor

public String getVendor()
Returns name of vendor associated with this implementation or null

getVersion

public String getVersion()
Returns version of this implementation or null if no version

toString

public String toString()
Overrides Object.toString()

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Provider.Type

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Provider.Type

java.lang.Object
    extended by javax.mail.Provider.Type
Enclosing class:
Provider
public static class Provider.Type
extends Object

This inner class defines the Provider type. Currently, STORE and TRANSPORT are the only two provider types supported.

Field Summary
static Provider.Type | STORE
static Provider.Type | TRANSPORT
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

STORE

public static final Provider.Type STORE

TRANSPORT

public static final Provider.Type TRANSPORT
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ReadOnlyFolderException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class ReadOnlyFolderException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.ReadOnlyFolderException
All Implemented Interfaces:
Serializable
public class ReadOnlyFolderException
extends MessagingException

This exception is thrown when an attempt is made to open a folder read-write access when the folder is marked read-only.

The getMessage() method returns more detailed information about the error that caused this exception.

Author:
Jim Glennon
See Also:
Serialized Form

Constructor Summary
ReadOnlyFolderException(Folder folder)
Constructs a MessagingException with the specified folder.
ReadOnlyFolderException(Folder folder, String message)
Constructs a MessagingException with the specified folder and the specified detail message.
Method Summary
 Folder getFolder()
Returns the dead Folder object.
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReadOnlyFolderException

public ReadOnlyFolderException(Folder folder)
Constructs a MessagingException with the specified folder.

Parameters:
folder - the Folder
Since:
JavaMail 1.2

ReadOnlyFolderException

public ReadOnlyFolderException(Folder folder,
                               String message)
Constructs a MessagingException with the specified folder and the specified detail message.

Parameters:
folder - the Folder
message - the detailed error message
Since:
JavaMail 1.2
Method Detail

getFolder

public Folder getFolder()
Returns the dead Folder object.

Since:
JavaMail 1.2
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


search

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.mail.search

Message search terms for the JavaMail API.

See:
Description

Class Summary
AddressStringTerm | This abstract class implements string comparisons for Message addresses.
AddressTerm | This class implements Message Address comparisons.
AndTerm | This class implements the logical AND operator on individual SearchTerms.
BodyTerm | This class implements searches on a Message Body.
ComparisonTerm | This class models the comparison operator.
DateTerm | This class implements comparisons for Dates
FlagTerm | This class implements comparisons for Message Flags.
FromStringTerm | This class implements string comparisons for the From Address header.
FromTerm | This class implements comparisons for the From Address header.
HeaderTerm | This class implements comparisons for Message headers.
IntegerComparisonTerm | This class implements comparisons for integers.
MessageIDTerm | This term models the RFC822 "MessageId" - a message-id for Internet messages that is supposed to be unique per message.
MessageNumberTerm | This class implements comparisons for Message numbers.
NotTerm | This class implements the logical NEGATION operator.
OrTerm | This class implements the logical OR operator on individual SearchTerms.
ReceivedDateTerm | This class implements comparisons for the Message Received date
RecipientStringTerm | This class implements string comparisons for the Recipient Address headers.
RecipientTerm | This class implements comparisons for the Recipient Address headers.
SearchTerm | Search criteria are expressed as a tree of search-terms, forming a parse-tree for the search expression.
SentDateTerm | This class implements comparisons for the Message SentDate.
SizeTerm | This class implements comparisons for Message sizes.
StringTerm | This class implements the match method for Strings.
SubjectTerm | This class implements comparisons for the Message Subject header.

Exception Summary
SearchException The exception thrown when a Search expression could not be handled.

Package javax.mail.search Description

Message search terms for the JavaMail API. This package defines classes that can be used to construct a search expression to search a folder for messages matching the expression; see the search method on javax.mail.Folder. See SearchTerm.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.mail.search Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.mail.search

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.mail.search.SearchTerm (implements java.io.Serializable)
      • class javax.mail.search.AddressTerm
        • class javax.mail.search.FromTerm
        • class javax.mail.search.RecipientTerm
      • class javax.mail.search.AndTerm
      • class javax.mail.search.ComparisonTerm
        • class javax.mail.search.DateTerm
          • class javax.mail.search.ReceivedDateTerm
          • class javax.mail.search.SentDateTerm
        • class javax.mail.search.IntegerComparisonTerm
          • class javax.mail.search.MessageNumberTerm
          • class javax.mail.search.SizeTerm
      • class javax.mail.search.FlagTerm
      • class javax.mail.search.NotTerm
      • class javax.mail.search.OrTerm
      • class javax.mail.search.StringTerm
        • class javax.mail.search.AddressStringTerm
          • class javax.mail.search.FromStringTerm
          • class javax.mail.search.RecipientStringTerm
        • class javax.mail.search.BodyTerm
        • class javax.mail.search.HeaderTerm
        • class javax.mail.search.MessageIDTerm
        • class javax.mail.search.SubjectTerm
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.mail.MessagingException
          • class javax.mail.search.SearchException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AddressStringTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class AddressStringTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.StringTerm
            extended by javax.mail.search.AddressStringTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
FromStringTerm, RecipientStringTerm
public abstract class AddressStringTerm
extends StringTerm

This abstract class implements string comparisons for Message addresses.

Note that this class differs from the AddressTerm class in that this class does comparisons on address strings rather than Address objects.

Since:
JavaMail 1.1
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
protected AddressStringTerm(String pattern)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
protected boolean | match(Address a) Check whether the address pattern specified in the constructor is a substring of the string representation of the given Address object.
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, hashCode, match
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AddressStringTerm

protected AddressStringTerm(String pattern)
Constructor.

Parameters:
pattern - the address pattern to be compared.
Method Detail

match

protected boolean match(Address a)
Check whether the address pattern specified in the constructor is a substring of the string representation of the given Address object.

Note that if the string representation of the given Address object contains charset or transfer encodings, the encodings must be accounted for, during the match process.

Parameters:
a - The comparison is applied to this Address object.
Returns:
true if the match succeeds, otherwise false.

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class StringTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AddressTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class AddressTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.AddressTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
FromTerm, RecipientTerm
public abstract class AddressTerm
extends SearchTerm

This class implements Message Address comparisons.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  Address address
The address.
Constructor Summary
protected AddressTerm(Address address)
Method Summary
boolean | equals(Object obj) Equality comparison.
Address | getAddress() Return the address to match with.
int | hashCode() Compute a hashCode for this object.
protected boolean | match(Address a) Match against the argument Address.
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

address

protected Address address
The address.

Constructor Detail

AddressTerm

protected AddressTerm(Address address)
Method Detail

getAddress

public Address getAddress()
Return the address to match with.

match

protected boolean match(Address a)
Match against the argument Address.

equals

public boolean equals(Object obj)
Equality comparison.

hashCode

public int hashCode()
Compute a hashCode for this object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AndTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class AndTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.AndTerm
All Implemented Interfaces:
Serializable
public final class AndTerm
extends SearchTerm

This class implements the logical AND operator on individual SearchTerms.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  SearchTerm[] terms
The array of terms on which the AND operator should be applied.
Constructor Summary
AndTerm(SearchTerm[] t)
Constructor that takes an array of SearchTerms.
AndTerm(SearchTerm t1, SearchTerm t2)
Constructor that takes two terms.
Method Summary
boolean | equals(Object obj) Equality comparison.
SearchTerm[] | getTerms() Return the search terms.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) The AND operation.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

terms

protected SearchTerm[] terms
The array of terms on which the AND operator should be applied.

Constructor Detail

AndTerm

public AndTerm(SearchTerm t1,
               SearchTerm t2)
Constructor that takes two terms.

Parameters:
t1 - first term
t2 - second term

AndTerm

public AndTerm(SearchTerm[] t)
Constructor that takes an array of SearchTerms.

Parameters:
t - array of terms
Method Detail

getTerms

public SearchTerm[] getTerms()
Return the search terms.

match

public boolean match(Message msg)
The AND operation.

The terms specified in the constructor are applied to the given object and the AND operator is applied to their results.

Specified by:
match in class SearchTerm
Parameters:
msg - The specified SearchTerms are applied to this Message and the AND operator is applied to their results.
Returns:
true if the AND succeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

hashCode

public int hashCode()
Compute a hashCode for this object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BodyTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class BodyTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.StringTerm
            extended by javax.mail.search.BodyTerm
All Implemented Interfaces:
Serializable
public final class BodyTerm
extends StringTerm

This class implements searches on a Message Body. All parts of the message that are of MIME type "text/*" are searched.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
BodyTerm(String pattern)
Constructor
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BodyTerm

public BodyTerm(String pattern)
Constructor

Parameters:
pattern - The String to search for
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - The pattern search is applied on this Message's body
Returns:
true if the pattern is found; otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class StringTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ComparisonTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class ComparisonTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.ComparisonTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
DateTerm, IntegerComparisonTerm
public abstract class ComparisonTerm
extends SearchTerm

This class models the comparison operator. This is an abstract class; subclasses implement comparisons for different datatypes.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected int | comparison The comparison.
static int | EQ
static int | GE
static int | GT
static int | LE
static int | LT
static int | NE
Constructor Summary
ComparisonTerm()
Method Summary
boolean | equals(Object obj) Equality comparison.
int | hashCode() Compute a hashCode for this object.
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

LE

public static final int LE
See Also:
Constant Field Values

LT

public static final int LT
See Also:
Constant Field Values

EQ

public static final int EQ
See Also:
Constant Field Values

NE

public static final int NE
See Also:
Constant Field Values

GT

public static final int GT
See Also:
Constant Field Values

GE

public static final int GE
See Also:
Constant Field Values

comparison

protected int comparison
The comparison.

Constructor Detail

ComparisonTerm

public ComparisonTerm()
Method Detail

equals

public boolean equals(Object obj)
Equality comparison.

hashCode

public int hashCode()
Compute a hashCode for this object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DateTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class DateTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.ComparisonTerm
            extended by javax.mail.search.DateTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ReceivedDateTerm, SentDateTerm
public abstract class DateTerm
extends ComparisonTerm

This class implements comparisons for Dates

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  Date date
The date.
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
protected DateTerm(int comparison, Date date)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
int | getComparison() Return the type of comparison.
Date | getDate() Return the Date to compare with.
int | hashCode() Compute a hashCode for this object.
protected boolean | match(Date d) The date comparison method.
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

date

protected Date date
The date.

Constructor Detail

DateTerm

protected DateTerm(int comparison,
                   Date date)
Constructor.

Parameters:
comparison - the comparison type
date - The Date to be compared against
Method Detail

getDate

public Date getDate()
Return the Date to compare with.

getComparison

public int getComparison()
Return the type of comparison.

match

protected boolean match(Date d)
The date comparison method.

Parameters:
d - the date in the constructor is compared with this date
Returns:
true if the dates match, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class ComparisonTerm

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class ComparisonTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FlagTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class FlagTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.FlagTerm
All Implemented Interfaces:
Serializable
public final class FlagTerm
extends SearchTerm

This class implements comparisons for Message Flags.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected Flags | flags Flags object containing the flags to test.
protected boolean | set Indicates whether to test for the presence or absence of the specified Flag.
Constructor Summary
FlagTerm(Flags flags, boolean set)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
Flags | getFlags() Return the Flags to test.
boolean | getTestSet() Return true if testing whether the flags are set.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) The comparison method.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

set

protected boolean set
Indicates whether to test for the presence or absence of the specified Flag. If true, then test whether all the specified flags are present, else test whether all the specified flags are absent.

flags

protected Flags flags
Flags object containing the flags to test.

Constructor Detail

FlagTerm

public FlagTerm(Flags flags,
                boolean set)
Constructor.

Parameters:
flags - Flags object containing the flags to check for
set - the flag setting to check for
Method Detail

getFlags

public Flags getFlags()
Return the Flags to test.

getTestSet

public boolean getTestSet()
Return true if testing whether the flags are set.

match

public boolean match(Message msg)
The comparison method.

Specified by:
match in class SearchTerm
Parameters:
msg - The flag comparison is applied to this Message
Returns:
true if the comparson succeeds, otherwise false.

equals

public boolean equals(Object obj)
Equality comparison.

hashCode

public int hashCode()
Compute a hashCode for this object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FromStringTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class FromStringTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.StringTerm
            extended by javax.mail.search.AddressStringTerm
                extended by javax.mail.search.FromStringTerm
All Implemented Interfaces:
Serializable
public final class FromStringTerm
extends AddressStringTerm

This class implements string comparisons for the From Address header.

Note that this class differs from the FromTerm class in that this class does comparisons on address strings rather than Address objects. The string comparisons are case-insensitive.

Since:
JavaMail 1.1
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
FromStringTerm(String pattern)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) Check whether the address string specified in the constructor is a substring of the From address of this Message.
Methods inherited from class javax.mail.search.AddressStringTerm
match
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FromStringTerm

public FromStringTerm(String pattern)
Constructor.

Parameters:
pattern - the address pattern to be compared.
Method Detail

match

public boolean match(Message msg)
Check whether the address string specified in the constructor is a substring of the From address of this Message.

Specified by:
match in class SearchTerm
Parameters:
msg - The comparison is applied to this Message's From address.
Returns:
true if the match succeeds, otherwise false.

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class AddressStringTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FromTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class FromTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.AddressTerm
            extended by javax.mail.search.FromTerm
All Implemented Interfaces:
Serializable
public final class FromTerm
extends AddressTerm

This class implements comparisons for the From Address header.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.AddressTerm
address
Constructor Summary
FromTerm(Address address)
Constructor
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The address comparator.
Methods inherited from class javax.mail.search.AddressTerm
getAddress, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FromTerm

public FromTerm(Address address)
Constructor

Parameters:
address - The Address to be compared
Method Detail

match

public boolean match(Message msg)
The address comparator.

Specified by:
match in class SearchTerm
Parameters:
msg - The address comparison is applied to this Message
Returns:
true if the comparison succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class AddressTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HeaderTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class HeaderTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.StringTerm
            extended by javax.mail.search.HeaderTerm
All Implemented Interfaces:
Serializable
public final class HeaderTerm
extends StringTerm

This class implements comparisons for Message headers. The comparison is case-insensitive.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  String headerName
The name of the header.
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
HeaderTerm(String headerName, String pattern)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
String | getHeaderName() Return the name of the header to compare with.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) The header match method.
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

headerName

protected String headerName
The name of the header.

Constructor Detail

HeaderTerm

public HeaderTerm(String headerName,
                  String pattern)
Constructor.

Parameters:
headerName - The name of the header
pattern - The pattern to search for
Method Detail

getHeaderName

public String getHeaderName()
Return the name of the header to compare with.

match

public boolean match(Message msg)
The header match method.

Specified by:
match in class SearchTerm
Parameters:
msg - The match is applied to this Message's header
Returns:
true if the match succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class StringTerm

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class StringTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


IntegerComparisonTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class IntegerComparisonTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.ComparisonTerm
            extended by javax.mail.search.IntegerComparisonTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MessageNumberTerm, SizeTerm
public abstract class IntegerComparisonTerm
extends ComparisonTerm

This class implements comparisons for integers.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  int number
The number.
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
protected IntegerComparisonTerm(int comparison, int number)
Method Summary
boolean | equals(Object obj) Equality comparison.
int | getComparison() Return the type of comparison.
int | getNumber() Return the number to compare with.
int | hashCode() Compute a hashCode for this object.
protected boolean | match(int i)
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

number

protected int number
The number.

Constructor Detail

IntegerComparisonTerm

protected IntegerComparisonTerm(int comparison,
                                int number)
Method Detail

getNumber

public int getNumber()
Return the number to compare with.

getComparison

public int getComparison()
Return the type of comparison.

match

protected boolean match(int i)

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class ComparisonTerm

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class ComparisonTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageIDTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class MessageIDTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.StringTerm
            extended by javax.mail.search.MessageIDTerm
All Implemented Interfaces:
Serializable
public final class MessageIDTerm
extends StringTerm

This term models the RFC822 "MessageId" - a message-id for Internet messages that is supposed to be unique per message. Clients can use this term to search a folder for a message given its MessageId.

The MessageId is represented as a String.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
MessageIDTerm(String msgid)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageIDTerm

public MessageIDTerm(String msgid)
Constructor.

Parameters:
msgid - the msgid to search for
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the match is applied to this Message's Message-ID header
Returns:
true if the match succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class StringTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageNumberTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class MessageNumberTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.ComparisonTerm
            extended by javax.mail.search.IntegerComparisonTerm
                extended by javax.mail.search.MessageNumberTerm
All Implemented Interfaces:
Serializable
public final class MessageNumberTerm
extends IntegerComparisonTerm

This class implements comparisons for Message numbers.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.IntegerComparisonTerm
number
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
MessageNumberTerm(int number)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.IntegerComparisonTerm
getComparison, getNumber, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageNumberTerm

public MessageNumberTerm(int number)
Constructor.

Parameters:
number - the Message number
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the Message number is matched with this Message
Returns:
true if the match succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class IntegerComparisonTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NotTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class NotTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.NotTerm
All Implemented Interfaces:
Serializable
public final class NotTerm
extends SearchTerm

This class implements the logical NEGATION operator.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  SearchTerm term
The search term to negate.
Constructor Summary
NotTerm(SearchTerm t)
Method Summary
boolean | equals(Object obj) Equality comparison.
SearchTerm | getTerm() Return the term to negate.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) This method applies a specific match criterion to the given message and returns the result.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

term

protected SearchTerm term
The search term to negate.

Constructor Detail

NotTerm

public NotTerm(SearchTerm t)
Method Detail

getTerm

public SearchTerm getTerm()
Return the term to negate.

match

public boolean match(Message msg)
Description copied from class: SearchTerm
This method applies a specific match criterion to the given message and returns the result.

Specified by:
match in class SearchTerm
Parameters:
msg - The match criterion is applied on this message
Returns:
true, it the match succeeds, false if the match fails

equals

public boolean equals(Object obj)
Equality comparison.

hashCode

public int hashCode()
Compute a hashCode for this object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OrTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class OrTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.OrTerm
All Implemented Interfaces:
Serializable
public final class OrTerm
extends SearchTerm

This class implements the logical OR operator on individual SearchTerms.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  SearchTerm[] terms
The array of terms on which the OR operator should be applied.
Constructor Summary
OrTerm(SearchTerm[] t)
Constructor that takes an array of SearchTerms.
OrTerm(SearchTerm t1, SearchTerm t2)
Constructor that takes two operands.
Method Summary
boolean | equals(Object obj) Equality comparison.
SearchTerm[] | getTerms() Return the search terms.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) The OR operation.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

terms

protected SearchTerm[] terms
The array of terms on which the OR operator should be applied.

Constructor Detail

OrTerm

public OrTerm(SearchTerm t1,
              SearchTerm t2)
Constructor that takes two operands.

Parameters:
t1 - first term
t2 - second term

OrTerm

public OrTerm(SearchTerm[] t)
Constructor that takes an array of SearchTerms.

Parameters:
t - array of search terms
Method Detail

getTerms

public SearchTerm[] getTerms()
Return the search terms.

match

public boolean match(Message msg)
The OR operation.

The terms specified in the constructor are applied to the given object and the OR operator is applied to their results.

Specified by:
match in class SearchTerm
Parameters:
msg - The specified SearchTerms are applied to this Message and the OR operator is applied to their results.
Returns:
true if the OR succeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

hashCode

public int hashCode()
Compute a hashCode for this object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ReceivedDateTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class ReceivedDateTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.ComparisonTerm
            extended by javax.mail.search.DateTerm
                extended by javax.mail.search.ReceivedDateTerm
All Implemented Interfaces:
Serializable
public final class ReceivedDateTerm
extends DateTerm

This class implements comparisons for the Message Received date

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.DateTerm
date
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
ReceivedDateTerm(int comparison, Date date)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.DateTerm
getComparison, getDate, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReceivedDateTerm

public ReceivedDateTerm(int comparison,
                        Date date)
Constructor.

Parameters:
comparison - the Comparison type
date - the date to be compared
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the date comparator is applied to this Message's sent date
Returns:
true if the comparison succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class DateTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RecipientStringTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class RecipientStringTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.StringTerm
            extended by javax.mail.search.AddressStringTerm
                extended by javax.mail.search.RecipientStringTerm
All Implemented Interfaces:
Serializable
public final class RecipientStringTerm
extends AddressStringTerm

This class implements string comparisons for the Recipient Address headers.

Note that this class differs from the RecipientTerm class in that this class does comparisons on address strings rather than Address objects. The string comparisons are case-insensitive.

Since:
JavaMail 1.1
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
RecipientStringTerm(Message.RecipientType type, String pattern)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
Message.RecipientType | getRecipientType() Return the type of recipient to match with.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) Check whether the address specified in the constructor is a substring of the recipient address of this Message.
Methods inherited from class javax.mail.search.AddressStringTerm
match
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecipientStringTerm

public RecipientStringTerm(Message.RecipientType type,
                           String pattern)
Constructor.

Parameters:
type - the recipient type
pattern - the address pattern to be compared.
Method Detail

getRecipientType

public Message.RecipientType getRecipientType()
Return the type of recipient to match with.

match

public boolean match(Message msg)
Check whether the address specified in the constructor is a substring of the recipient address of this Message.

Specified by:
match in class SearchTerm
Parameters:
msg - The comparison is applied to this Message's recepient address.
Returns:
true if the match succeeds, otherwise false.

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class AddressStringTerm

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class StringTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RecipientTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class RecipientTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.AddressTerm
            extended by javax.mail.search.RecipientTerm
All Implemented Interfaces:
Serializable
public final class RecipientTerm
extends AddressTerm

This class implements comparisons for the Recipient Address headers.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  Message.RecipientType type
The recipient type.
Fields inherited from class javax.mail.search.AddressTerm
address
Constructor Summary
RecipientTerm(Message.RecipientType type, Address address)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
Message.RecipientType | getRecipientType() Return the type of recipient to match with.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.AddressTerm
getAddress, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

type

protected Message.RecipientType type
The recipient type.

Constructor Detail

RecipientTerm

public RecipientTerm(Message.RecipientType type,
                     Address address)
Constructor.

Parameters:
type - the recipient type
address - the address to match for
Method Detail

getRecipientType

public Message.RecipientType getRecipientType()
Return the type of recipient to match with.

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - The address match is applied to this Message's recepient address
Returns:
true if the match succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class AddressTerm

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class AddressTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SearchException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class SearchException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.search.SearchException
All Implemented Interfaces:
Serializable
public class SearchException
extends MessagingException

The exception thrown when a Search expression could not be handled.

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
SearchException()
Constructs a SearchException with no detail message.
SearchException(String s)
Constructs a SearchException with the specified detail message.
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SearchException

public SearchException()
Constructs a SearchException with no detail message.

SearchException

public SearchException(String s)
Constructs a SearchException with the specified detail message.

Parameters:
s - the detail message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SearchTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class SearchTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AddressTerm, AndTerm, ComparisonTerm, FlagTerm, NotTerm, OrTerm, StringTerm
public abstract class SearchTerm
extends Object
implements Serializable

Search criteria are expressed as a tree of search-terms, forming a parse-tree for the search expression.

Search-terms are represented by this class. This is an abstract class; subclasses implement specific match methods.

Search terms are serializable, which allows storing a search term between sessions. Warning: Serialized objects of this class may not be compatible with future JavaMail API releases. The current serialization support is appropriate for short term storage.

Warning: Search terms that include references to objects of type Message.RecipientType will not be deserialized correctly on JDK 1.1 systems. While these objects will be deserialized without throwing any exceptions, the resulting objects violate the type-safe enum contract of the Message.RecipientType class. Proper deserialization of these objects depends on support for the readReplace method, added in JDK 1.2.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Constructor Summary
SearchTerm()
Method Summary
abstract  boolean match(Message msg)
This method applies a specific match criterion to the given message and returns the result.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SearchTerm

public SearchTerm()
Method Detail

match

public abstract boolean match(Message msg)
This method applies a specific match criterion to the given message and returns the result.

Parameters:
msg - The match criterion is applied on this message
Returns:
true, it the match succeeds, false if the match fails
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SentDateTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class SentDateTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.ComparisonTerm
            extended by javax.mail.search.DateTerm
                extended by javax.mail.search.SentDateTerm
All Implemented Interfaces:
Serializable
public final class SentDateTerm
extends DateTerm

This class implements comparisons for the Message SentDate.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.DateTerm
date
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
SentDateTerm(int comparison, Date date)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.DateTerm
getComparison, getDate, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SentDateTerm

public SentDateTerm(int comparison,
                    Date date)
Constructor.

Parameters:
comparison - the Comparison type
date - the date to be compared
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the date comparator is applied to this Message's sent date
Returns:
true if the comparison succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class DateTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SizeTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class SizeTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.ComparisonTerm
            extended by javax.mail.search.IntegerComparisonTerm
                extended by javax.mail.search.SizeTerm
All Implemented Interfaces:
Serializable
public final class SizeTerm
extends IntegerComparisonTerm

This class implements comparisons for Message sizes.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.IntegerComparisonTerm
number
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
SizeTerm(int comparison, int size)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.IntegerComparisonTerm
getComparison, getNumber, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SizeTerm

public SizeTerm(int comparison,
                int size)
Constructor.

Parameters:
comparison - the Comparison type
size - the size
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the size comparator is applied to this Message's size
Returns:
true if the size is equal, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class IntegerComparisonTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StringTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class StringTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.StringTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AddressStringTerm, BodyTerm, HeaderTerm, MessageIDTerm, SubjectTerm
public abstract class StringTerm
extends SearchTerm

This class implements the match method for Strings. The current implementation provides only for substring matching. We could add comparisons (like strcmp ...).

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected boolean | ignoreCase Ignore case when comparing?
protected String | pattern The pattern.
Constructor Summary
protected | StringTerm(String pattern)
protected | StringTerm(String pattern, boolean ignoreCase)
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | getIgnoreCase() Return true if we should ignore case when matching.
String | getPattern() Return the string to match with.
int | hashCode() Compute a hashCode for this object.
protected boolean | match(String s)
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

pattern

protected String pattern
The pattern.

ignoreCase

protected boolean ignoreCase
Ignore case when comparing?

Constructor Detail

StringTerm

protected StringTerm(String pattern)

StringTerm

protected StringTerm(String pattern,
                     boolean ignoreCase)
Method Detail

getPattern

public String getPattern()
Return the string to match with.

getIgnoreCase

public boolean getIgnoreCase()
Return true if we should ignore case when matching.

match

protected boolean match(String s)

equals

public boolean equals(Object obj)
Equality comparison.

hashCode

public int hashCode()
Compute a hashCode for this object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SubjectTerm

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class SubjectTerm

java.lang.Object
    extended by javax.mail.search.SearchTerm
        extended by javax.mail.search.StringTerm
            extended by javax.mail.search.SubjectTerm
All Implemented Interfaces:
Serializable
public final class SubjectTerm
extends StringTerm

This class implements comparisons for the Message Subject header. The comparison is case-insensitive.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
SubjectTerm(String pattern)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SubjectTerm

public SubjectTerm(String pattern)
Constructor.

Parameters:
pattern - the pattern to search for
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the pattern match is applied to this Message's subject header
Returns:
true if the pattern match succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class StringTerm
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SendFailedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class SendFailedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.SendFailedException
All Implemented Interfaces:
Serializable
public class SendFailedException
extends MessagingException

This exception is thrown when the message cannot be sent.

The exception includes those addresses to which the message could not be sent as well as the valid addresses to which the message was sent and valid addresses to which the message was not sent.

Author:
John Mani, Max Spivak
See Also:
Transport.send(javax.mail.Message), Transport.sendMessage(javax.mail.Message, javax.mail.Address[]), TransportEvent, Serialized Form

Field Summary
protected Address[] | invalid
protected Address[] | validSent
protected Address[] | validUnsent
Constructor Summary
SendFailedException()
Constructs a SendFailedException with no detail message.
SendFailedException(String s)
Constructs a SendFailedException with the specified detail message.
SendFailedException(String s, Exception e)
Constructs a SendFailedException with the specified Exception and detail message.
SendFailedException(String msg, Exception ex, Address[] validSent, Address[] validUnsent, Address[] invalid)
Constructs a SendFailedException with the specified string and the specified address objects.
Method Summary
Address[] | getInvalidAddresses() Return the addresses to which this message could not be sent.
Address[] | getValidSentAddresses() Return the addresses to which this message was sent succesfully.
Address[] | getValidUnsentAddresses() Return the addresses that are valid but to which this message was not sent.
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

invalid

protected transient Address[] invalid

validSent

protected transient Address[] validSent

validUnsent

protected transient Address[] validUnsent
Constructor Detail

SendFailedException

public SendFailedException()
Constructs a SendFailedException with no detail message.

SendFailedException

public SendFailedException(String s)
Constructs a SendFailedException with the specified detail message.

Parameters:
s - the detail message

SendFailedException

public SendFailedException(String s,
                           Exception e)
Constructs a SendFailedException with the specified Exception and detail message. The specified exception is chained to this exception.

Parameters:
s - the detail message
e - the embedded exception
See Also:
MessagingException.getNextException(), MessagingException.setNextException(java.lang.Exception)

SendFailedException

public SendFailedException(String msg,
                           Exception ex,
                           Address[] validSent,
                           Address[] validUnsent,
                           Address[] invalid)
Constructs a SendFailedException with the specified string and the specified address objects.

Parameters:
msg - the detail message
ex - the embedded exception
validSent - valid addresses to which message was sent
validUnsent - valid addresses to which message was not sent
invalid - the invalid addresses
See Also:
MessagingException.getNextException(), MessagingException.setNextException(java.lang.Exception)
Method Detail

getValidSentAddresses

public Address[] getValidSentAddresses()
Return the addresses to which this message was sent succesfully.

Returns:
Addresses to which the message was sent successfully or null

getValidUnsentAddresses

public Address[] getValidUnsentAddresses()
Return the addresses that are valid but to which this message was not sent.

Returns:
Addresses that are valid but to which the message was not sent successfully or null

getInvalidAddresses

public Address[] getInvalidAddresses()
Return the addresses to which this message could not be sent.

Returns:
Addresses to which the message sending failed or null;
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Service

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Service

java.lang.Object
    extended by javax.mail.Service
Direct Known Subclasses:
Store, Transport
public abstract class Service
extends Object

An abstract class that contains the functionality common to messaging services, such as stores and transports.

A messaging service is created from a Session and is named using a URLName. A service must be connected before it can be used. Connection events are sent to reflect its connection status.

Version:
1.24, 03/04/10
Author:
Christopher Cotton, Bill Shannon

Field Summary
protected boolean | debug Debug flag for this service.
protected Session | session The session from which this service was created.
protected URLName | url The URLName of this service.
Constructor Summary
protected Service(Session session, URLName urlname)
Constructor.
Method Summary
 void addConnectionListener(ConnectionListener l)
Add a listener for Connection events on this service.
 void close()
Close this service and terminate its connection.
 void connect()
A generic connect method that takes no parameters.
 void connect(String host, int port, String user, String password)
Similar to connect(host, user, password) except a specific port can be specified.
 void connect(String host, String user, String password)
Connect to the specified address.
protected  void finalize()
Stop the event dispatcher thread so the queue can be garbage collected.
 URLName getURLName()
Return a URLName representing this service.
 boolean isConnected()
Is this service currently connected?
protected  void notifyConnectionListeners(int type)
Notify all ConnectionListeners.
protected  boolean protocolConnect(String host, int port, String user, String password)
The service implementation should override this method to perform the actual protocol-specific connection attempt.
protected  void queueEvent(MailEvent event, Vector vector)
Add the event and vector of listeners to the queue to be delivered.
 void removeConnectionListener(ConnectionListener l)
Remove a Connection event listener.
protected  void setConnected(boolean connected)
Set the connection state of this service.
protected  void setURLName(URLName url)
Set the URLName representing this service.
 String toString()
Return getURLName.toString() if this service has a URLName, otherwise it will return the default toString.
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

session

protected Session session
The session from which this service was created.

url

protected URLName url
The URLName of this service.

debug

protected boolean debug
Debug flag for this service. Set from the session's debug flag when this service is created.

Constructor Detail

Service

protected Service(Session session,
                  URLName urlname)
Constructor.

Parameters:
session - Session object for this service
urlname - URLName object to be used for this service
Method Detail

connect

public void connect()
             throws MessagingException
A generic connect method that takes no parameters. Subclasses can implement the appropriate authentication schemes. Subclasses that need additional information might want to use some properties or might get it interactively using a popup window.

If the connection is successful, an "open" ConnectionEvent is delivered to any ConnectionListeners on this service.

Most clients should just call this method to connect to the service.

It is an error to connect to an already connected service.

The implementation provided here simply calls the following connect(String, String, String) method with nulls.

Throws:
AuthenticationFailedException - for authentication failures
MessagingException - for other failures
IllegalStateException - if the service is already connected
See Also:
ConnectionEvent

connect

public void connect(String host,
                    String user,
                    String password)
             throws MessagingException
Connect to the specified address. This method provides a simple authentication scheme that requires a username and password.

If the connection is successful, an "open" ConnectionEvent is delivered to any ConnectionListeners on this service.

It is an error to connect to an already connected service.

The implementation in the Service class will collect defaults for the host, user, and password from the session, from the URLName for this service, and from the supplied parameters and then call the protocolConnect method. If the protocolConnect method returns false, the user will be prompted for any missing information and the protocolConnect method will be called again. The subclass should override the protocolConnect method. The subclass should also implement the getURLName method, or use the implementation in this class.

On a successful connection, the setURLName method is called with a URLName that includes the information used to make the connection, including the password.

If the password passed in is null and this is the first successful connection to this service, the user name and the password collected from the user will be saved as defaults for subsequent connection attempts to this same service when using other Service object instances (the connection information is typically always saved within a particular Service object instance). The password is saved using the Session method setPasswordAuthenticaiton. If the password passed in is not null, it is not saved, on the assumption that the application is managing passwords explicitly.

Parameters:
host - the host to connect to
user - the user name
password - this user's password
Throws:
AuthenticationFailedException - for authentication failures
MessagingException - for other failures
IllegalStateException - if the service is already connected
See Also:
ConnectionEvent, Session.setPasswordAuthentication(javax.mail.URLName, javax.mail.PasswordAuthentication)

connect

public void connect(String host,
                    int port,
                    String user,
                    String password)
             throws MessagingException
Similar to connect(host, user, password) except a specific port can be specified.

Parameters:
host - the host to connect to
port - the port to connect to (-1 means the default port)
user - the user name
password - this user's password
Throws:
AuthenticationFailedException - for authentication failures
MessagingException - for other failures
IllegalStateException - if the service is already connected
See Also:
connect(java.lang.String, java.lang.String, java.lang.String), ConnectionEvent

protocolConnect

protected boolean protocolConnect(String host,
                                  int port,
                                  String user,
                                  String password)
                           throws MessagingException
The service implementation should override this method to perform the actual protocol-specific connection attempt. The default implementation of the connect method calls this method as needed.

The protocolConnect method should return false if a user name or password is required for authentication but the corresponding parameter is null; the connect method will prompt the user when needed to supply missing information. This method may also return false if authentication fails for the supplied user name or password. Alternatively, this method may throw an AuthenticationFailedException when authentication fails. This exception may include a String message with more detail about the failure.

The protocolConnect method should throw an exception to report failures not related to authentication, such as an invalid host name or port number, loss of a connection during the authentication process, unavailability of the server, etc.

Parameters:
host - the name of the host to connect to
port - the port to use (-1 means use default port)
user - the name of the user to login as
password - the user's password
Returns:
true if connection successful, false if authentication failed
Throws:
AuthenticationFailedException - for authentication failures
MessagingException - for non-authentication failures

isConnected

public boolean isConnected()
Is this service currently connected?

This implementation uses a private boolean field to store the connection state. This method returns the value of that field.

Subclasses may want to override this method to verify that any connection to the message store is still alive.

Returns:
true if the service is connected, false if it is not connected

setConnected

protected void setConnected(boolean connected)
Set the connection state of this service. The connection state will automatically be set by the service implementation during the connect and close methods. Subclasses will need to call this method to set the state if the service was automatically disconnected.

The implementation in this class merely sets the private field returned by the isConnected method.

Parameters:
connected - true if the service is connected, false if it is not connected

close

public void close()
           throws MessagingException
Close this service and terminate its connection. A close ConnectionEvent is delivered to any ConnectionListeners. Any Messaging components (Folders, Messages, etc.) belonging to this service are invalid after this service is closed. Note that the service is closed even if this method terminates abnormally by throwing a MessagingException.

This implementation uses setConnected(false) to set this service's connected state to false. It will then send a close ConnectionEvent to any registered ConnectionListeners. Subclasses overriding this method to do implementation specific cleanup should call this method as a last step to insure event notification, probably by including a call to super.close() in a finally clause.

Throws:
MessagingException - for errors while closing
See Also:
ConnectionEvent

getURLName

public URLName getURLName()
Return a URLName representing this service. The returned URLName does not include the password field.

Subclasses should only override this method if their URLName does not follow the standard format.

The implementation in the Service class returns (usually a copy of) the url field with the password and file information stripped out.

Returns:
the URLName representing this service
See Also:
URLName

setURLName

protected void setURLName(URLName url)
Set the URLName representing this service. Normally used to update the url field after a service has successfully connected.

Subclasses should only override this method if their URL does not follow the standard format. In particular, subclasses should override this method if their URL does not require all the possible fields supported by URLName; a new URLName should be constructed with any unneeded fields removed.

The implementation in the Service class simply sets the url field.

See Also:
URLName

addConnectionListener

public void addConnectionListener(ConnectionListener l)
Add a listener for Connection events on this service.

The default implementation provided here adds this listener to an internal list of ConnectionListeners.

Parameters:
l - the Listener for Connection events
See Also:
ConnectionEvent

removeConnectionListener

public void removeConnectionListener(ConnectionListener l)
Remove a Connection event listener.

The default implementation provided here removes this listener from the internal list of ConnectionListeners.

Parameters:
l - the listener
See Also:
addConnectionListener(javax.mail.event.ConnectionListener)

notifyConnectionListeners

protected void notifyConnectionListeners(int type)
Notify all ConnectionListeners. Service implementations are expected to use this method to broadcast connection events.

The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered ConnectionListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

toString

public String toString()
Return getURLName.toString() if this service has a URLName, otherwise it will return the default toString.

queueEvent

protected void queueEvent(MailEvent event,
                          Vector vector)
Add the event and vector of listeners to the queue to be delivered.

finalize

protected void finalize()
                 throws Throwable
Stop the event dispatcher thread so the queue can be garbage collected.

Throws:
Throwable
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Session

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Session

java.lang.Object
    extended by javax.mail.Session
public final class Session
extends Object

The Session class represents a mail session and is not subclassed. It collects together properties and defaults used by the mail API's. A single default session can be shared by multiple applications on the desktop. Unshared sessions can also be created.

The Session class provides access to the protocol providers that implement the Store, Transport, and related classes. The protocol providers are configured using the following files:

  • javamail.providers and javamail.default.providers
  • javamail.address.map and javamail.default.address.map

Each javamail.X resource file is searched for using three methods in the following order:

  1. java.home/lib/javamail.X
  2. META-INF/javamail.X
  3. META-INF/javamail.default.X

The first method allows the user to include their own version of the resource file by placing it in the lib directory where the java.home property points. The second method allows an application that uses the JavaMail APIs to include their own resource files in their application's or jar file's META-INF directory. The javamail.default.X default files are part of the JavaMail mail.jar file.

File location depends upon how the ClassLoader method getResource is implemented. Usually, the getResource method searches through CLASSPATH until it finds the requested file and then stops. JDK 1.1 has a limitation that the number of files of each name that will be found in the CLASSPATH is limited to one. However, this only affects method two, above; method one is loaded from a specific location (if allowed by the SecurityManager) and method three uses a different name to ensure that the default resource file is always loaded successfully. J2SE 1.2 and later are not limited to one file of a given name.

The ordering of entries in the resource files matters. If multiple entries exist, the first entries take precedence over the later entries. For example, the first IMAP provider found will be set as the default IMAP implementation until explicitly changed by the application. The user- or system-supplied resource files augment, they do not override, the default files included with the JavaMail APIs. This means that all entries in all files loaded will be available.

javamail.providers and javamail.default.providers

These resource files specify the stores and transports that are available on the system, allowing an application to "discover" what store and transport implementations are available. The protocol implementations are listed one per line. The file format defines four attributes that describe a protocol implementation. Each attribute is an "="-separated name-value pair with the name in lowercase. Each name-value pair is semi-colon (";") separated. The following names are defined.

Attribute Names in Providers Files
Name | Description
protocol | Name assigned to protocol. For example, smtp for Transport.
type | Valid entries are store and transport.
class | Class name that implements this protocol.
vendor | Optional string identifying the vendor.
version | Optional string identifying the version.

Here's an example of META-INF/javamail.default.providers file contents:

 protocol=imap; type=store; class=com.sun.mail.imap.IMAPStore; vendor=Sun Microsystems, Inc.;
 protocol=smtp; type=transport; class=com.sun.mail.smtp.SMTPTransport; vendor=Sun Microsystems, Inc.;

javamail.address.map and javamail.default.address.map

These resource files map transport address types to the transport protocol. The getType method of javax.mail.Address returns the address type. The javamail.address.map file maps the transport type to the protocol. The file format is a series of name-value pairs. Each key name should correspond to an address type that is currently installed on the system; there should also be an entry for each javax.mail.Address implementation that is present if it is to be used. For example, the javax.mail.internet.InternetAddress method getType returns "rfc822". Each referenced protocol should be installed on the system. For the case of news, below, the client should install a Transport provider supporting the nntp protocol.

Here are the typical contents of a javamail.address.map file:

 rfc822=smtp
 news=nntp

Version:
1.64, 03/05/26
Author:
John Mani, Bill Shannon, Max Spivak

Method Summary
boolean | getDebug() Get the debug setting for this Session.
PrintStream | getDebugOut() Returns the stream to be used for debugging output.
static Session | getDefaultInstance(Properties props) Get the default Session object.
static Session | getDefaultInstance(Properties props, Authenticator authenticator) Get the default Session object.
Folder | getFolder(URLName url) Get a closed Folder object for the given URLName.
static Session | getInstance(Properties props) Get a new Session object.
static Session | getInstance(Properties props, Authenticator authenticator) Get a new Session object.
PasswordAuthentication | getPasswordAuthentication(URLName url) Return any saved PasswordAuthentication for this (store or transport) URLName.
Properties | getProperties() Returns the Properties object associated with this Session
String | getProperty(String name) Returns the value of the specified property.
Provider | getProvider(String protocol) Returns the default Provider for the protocol specified.
Provider[] | getProviders() This method returns an array of all the implementations installed via the javamail.
Store | getStore() Get a Store object that implements this user's desired Store protocol.
Store | getStore(Provider provider) Get an instance of the store specified by Provider.
Store | getStore(String protocol) Get a Store object that implements the specified protocol.
Store | getStore(URLName url) Get a Store object for the given URLName.
Transport | getTransport() Get a Transport object that implements this user's desired Transport protcol.
Transport | getTransport(Address address) Get a Transport object that can transport a Message to the specified address type.
Transport | getTransport(Provider provider) Get an instance of the transport specified in the Provider.
Transport | getTransport(String protocol) Get a Transport object that implements the specified protocol.
Transport | getTransport(URLName url) Get a Transport object for the given URLName.
PasswordAuthentication | requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String defaultUserName) Call back to the application to get the needed user name and password.
void | setDebug(boolean debug) Set the debug setting for this Session.
void | setDebugOut(PrintStream out) Set the stream to be used for debugging output for this session.
void | setPasswordAuthentication(URLName url, PasswordAuthentication pw) Save a PasswordAuthentication for this (store or transport) URLName.
void | setProvider(Provider provider) Set the passed Provider to be the default implementation for the protocol in Provider.protocol overriding any previous values.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getInstance

public static Session getInstance(Properties props,
                                  Authenticator authenticator)
Get a new Session object.

Parameters:
props - Properties object that hold relevant properties.
It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
authenticator - Authenticator object used to call back to the application when a user name and password is needed.
Returns:
a new Session object
See Also:
Authenticator

getInstance

public static Session getInstance(Properties props)
Get a new Session object.

Parameters:
props - Properties object that hold relevant properties.
It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
Returns:
a new Session object
Since:
JavaMail 1.2

getDefaultInstance

public static Session getDefaultInstance(Properties props,
                                         Authenticator authenticator)
Get the default Session object. If a default has not yet been setup, a new Session object is created and installed as the default.

Since the default session is potentially available to all code executing in the same Java virtual machine, and the session can contain security sensitive information such as user names and passwords, access to the default session is restricted. The Authenticator object, which must be created by the caller, is used indirectly to check access permission. The Authenticator object passed in when the session is created is compared with the Authenticator object passed in to subsequent requests to get the default session. If both objects are the same, or are from the same ClassLoader, the request is allowed. Otherwise, it is denied.

Note that if the Authenticator object used to create the session is null, anyone can get the default session by passing in null.

Note also that the Properties object is used only the first time this method is called, when a new Session object is created. Subsequent calls return the Session object that was created by the first call, and ignore the passed Properties object. Use the getInstance method to get a new Session object every time the method is called.

In JDK 1.2, additional security Permission objects may be used to control access to the default session.

Parameters:
props - Properties object. Used only if a new Session object is created.
It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
authenticator - Authenticator object. Used only if a new Session object is created. Otherwise, it must match the Authenticator used to create the Session.
Returns:
the default Session object

getDefaultInstance

public static Session getDefaultInstance(Properties props)
Get the default Session object. If a default has not yet been setup, a new Session object is created and installed as the default.

Note that a default session created with no Authenticator is available to all code executing in the same Java virtual machine, and the session can contain security sensitive information such as user names and passwords.

Parameters:
props - Properties object. Used only if a new Session object is created.
It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
Returns:
the default Session object
Since:
JavaMail 1.2

setDebug

public void setDebug(boolean debug)
Set the debug setting for this Session.

Since the debug setting can be turned on only after the Session has been created, to turn on debugging in the Session constructor, set the property mail.debug in the Properties object passed in to the constructor to true. The value of the mail.debug property is used to initialize the per-Session debugging flag. Subsequent calls to the setDebug method manipulate the per-Session debugging flag and have no affect on the mail.debug property.

Parameters:
debug - Debug setting

getDebug

public boolean getDebug()
Get the debug setting for this Session.

Returns:
current debug setting

setDebugOut

public void setDebugOut(PrintStream out)
Set the stream to be used for debugging output for this session. If out is null, System.out will be used. Note that debugging output that occurs before any session is created, as a result of setting the mail.debug system property, will always be sent to System.out.

Parameters:
out - the PrintStream to use for debugging output
Since:
JavaMail 1.3

getDebugOut

public PrintStream getDebugOut()
Returns the stream to be used for debugging output. If no stream has been set, System.out is returned.

Returns:
the PrintStream to use for debugging output
Since:
JavaMail 1.3

getProviders

public Provider[] getProviders()
This method returns an array of all the implementations installed via the javamail.[default.]providers files that can be loaded using the ClassLoader available to this application.

Returns:
Array of configured providers

getProvider

public Provider getProvider(String protocol)
                     throws NoSuchProviderException
Returns the default Provider for the protocol specified. Checks mail.<protocol>.class property first and if it exists, returns the Provider associated with this implementation. If it doesn't exist, returns the Provider that appeared first in the configuration files. If an implementation for the protocol isn't found, throws NoSuchProviderException

Parameters:
protocol - Configured protocol (i.e. smtp, imap, etc)
Returns:
Currently configured Provider for the specified protocol
Throws:
NoSuchProviderException - If a provider for the given protocol is not found.

setProvider

public void setProvider(Provider provider)
                 throws NoSuchProviderException
Set the passed Provider to be the default implementation for the protocol in Provider.protocol overriding any previous values.

Parameters:
provider - Currently configured Provider which will be set as the default for the protocol
Throws:
NoSuchProviderException - If the provider passed in is invalid.

getStore

public Store getStore()
               throws NoSuchProviderException
Get a Store object that implements this user's desired Store protocol. The mail.store.protocol property specifies the desired protocol. If an appropriate Store object is not obtained, NoSuchProviderException is thrown

Returns:
a Store object
Throws:
NoSuchProviderException - If a provider for the given protocol is not found.

getStore

public Store getStore(String protocol)
               throws NoSuchProviderException
Get a Store object that implements the specified protocol. If an appropriate Store object cannot be obtained, NoSuchProviderException is thrown.

Parameters:
protocol -
Returns:
a Store object
Throws:
NoSuchProviderException - If a provider for the given protocol is not found.

getStore

public Store getStore(URLName url)
               throws NoSuchProviderException
Get a Store object for the given URLName. If the requested Store object cannot be obtained, NoSuchProviderException is thrown. The "scheme" part of the URL string (Refer RFC 1738) is used to locate the Store protocol.

Parameters:
url - URLName that represents the desired Store
Returns:
a closed Store object
Throws:
NoSuchProviderException - If a provider for the given URLName is not found.
See Also:
getFolder(URLName), URLName

getStore

public Store getStore(Provider provider)
               throws NoSuchProviderException
Get an instance of the store specified by Provider. Instantiates the store and returns it.

Parameters:
provider - Store Provider that will be instantiated
Returns:
Instantiated Store
Throws:
NoSuchProviderException - If a provider for the given Provider is not found.

getFolder

public Folder getFolder(URLName url)
                 throws MessagingException
Get a closed Folder object for the given URLName. If the requested Folder object cannot be obtained, null is returned.

The "scheme" part of the URL string (Refer RFC 1738) is used to locate the Store protocol. The rest of the URL string (that is, the "schemepart", as per RFC 1738) is used by that Store in a protocol dependent manner to locate and instantiate the appropriate Folder object.

Note that RFC 1738 also specifies the syntax for the "schemepart" for IP-based protocols (IMAP4, POP3, etc.). Providers of IP-based mail Stores should implement that syntax for referring to Folders.

Parameters:
url - URLName that represents the desired folder
Returns:
Folder
Throws:
NoSuchProviderException - If a provider for the given URLName is not found.
MessagingException - if the Folder could not be located or created.
See Also:
getStore(URLName), URLName

getTransport

public Transport getTransport()
                       throws NoSuchProviderException
Get a Transport object that implements this user's desired Transport protcol. The mail.transport.protocol property specifies the desired protocol. If an appropriate Transport object cannot be obtained, MessagingException is thrown.

Returns:
a Transport object
Throws:
NoSuchProviderException - If the provider is not found.

getTransport

public Transport getTransport(String protocol)
                       throws NoSuchProviderException
Get a Transport object that implements the specified protocol. If an appropriate Transport object cannot be obtained, null is returned.

Returns:
a Transport object
Throws:
NoSuchProviderException - If provider for the given protocol is not found.

getTransport

public Transport getTransport(URLName url)
                       throws NoSuchProviderException
Get a Transport object for the given URLName. If the requested Transport object cannot be obtained, NoSuchProviderException is thrown. The "scheme" part of the URL string (Refer RFC 1738) is used to locate the Transport protocol.

Parameters:
url - URLName that represents the desired Transport
Returns:
a closed Transport object
Throws:
NoSuchProviderException - If a provider for the given URLName is not found.
See Also:
URLName

getTransport

public Transport getTransport(Provider provider)
                       throws NoSuchProviderException
Get an instance of the transport specified in the Provider. Instantiates the transport and returns it.

Parameters:
provider - Transport Provider that will be instantiated
Returns:
Instantiated Transport
Throws:
NoSuchProviderException - If provider for the given provider is not found.

getTransport

public Transport getTransport(Address address)
                       throws NoSuchProviderException
Get a Transport object that can transport a Message to the specified address type.

Parameters:
address -
Returns:
A Transport object
Throws:
NoSuchProviderException - If provider for the Address type is not found
See Also:
Address

setPasswordAuthentication

public void setPasswordAuthentication(URLName url,
                                      PasswordAuthentication pw)
Save a PasswordAuthentication for this (store or transport) URLName. If pw is null the entry corresponding to the URLName is removed.

This is normally used only by the store or transport implementations to allow authentication information to be shared among multiple uses of a session.

getPasswordAuthentication

public PasswordAuthentication getPasswordAuthentication(URLName url)
Return any saved PasswordAuthentication for this (store or transport) URLName. Normally used only by store or transport implementations.

Returns:
the PasswordAuthentication corresponding to the URLName

requestPasswordAuthentication

public PasswordAuthentication requestPasswordAuthentication(InetAddress addr,
                                                            int port,
                                                            String protocol,
                                                            String prompt,
                                                            String defaultUserName)
Call back to the application to get the needed user name and password. The application should put up a dialog something like:

 Connecting to <protocol> mail service on host <addr>, port <port>.
 <prompt>

 User Name: <defaultUserName>
 Password:

Parameters:
addr - InetAddress of the host. may be null.
protocol - protocol scheme (e.g. imap, pop3, etc.)
prompt - any additional String to show as part of the prompt; may be null.
defaultUserName - the default username. may be null.
Returns:
the authentication which was collected by the authenticator; may be null.

getProperties

public Properties getProperties()
Returns the Properties object associated with this Session

Returns:
Properties object

getProperty

public String getProperty(String name)
Returns the value of the specified property. Returns null if this property does not exist.

Returns:
String that is the property value
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Store

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Store

java.lang.Object
    extended by javax.mail.Service
        extended by javax.mail.Store
public abstract class Store
extends Service

An abstract class that models a message store and its access protocol, for storing and retrieving messages. Subclasses provide actual implementations.

Note that Store extends the Service class, which provides many common methods for naming stores, connecting to stores, and listening to connection events.

Version:
1.26, 03/04/10
Author:
John Mani, Bill Shannon
See Also:
Service, ConnectionEvent, StoreEvent

Field Summary
Fields inherited from class javax.mail.Service
debug, session, url
Constructor Summary
protected Store(Session session, URLName urlname)
Constructor.
Method Summary
void | addFolderListener(FolderListener l) Add a listener for Folder events on any Folder object obtained from this Store.
void | addStoreListener(StoreListener l) Add a listener for StoreEvents on this Store.
abstract Folder | getDefaultFolder() Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.
abstract Folder | getFolder(String name) Return the Folder object corresponding to the given name.
abstract Folder | getFolder(URLName url) Return a closed Folder object, corresponding to the given URLName.
Folder[] | getPersonalNamespaces() Return a set of folders representing the personal namespaces for the current user.
Folder[] | getSharedNamespaces() Return a set of folders representing the shared namespaces.
Folder[] | getUserNamespaces(String user) Return a set of folders representing the namespaces for user.
protected void | notifyFolderListeners(int type, Folder folder) Notify all FolderListeners.
protected void | notifyFolderRenamedListeners(Folder oldF, Folder newF) Notify all FolderListeners about the renaming of a folder.
protected void | notifyStoreListeners(int type, String message) Notify all StoreListeners.
void | removeFolderListener(FolderListener l) Remove a listener for Folder events.
void | removeStoreListener(StoreListener l) Remove a listener for Store events.
Methods inherited from class javax.mail.Service
addConnectionListener, close, connect, connect, connect, finalize, getURLName, isConnected, notifyConnectionListeners, protocolConnect, queueEvent, removeConnectionListener, setConnected, setURLName, toString
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Store

protected Store(Session session,
                URLName urlname)
Constructor.

Parameters:
session - Session object for this Store.
urlname - URLName object to be used for this Store
Method Detail

getDefaultFolder

public abstract Folder getDefaultFolder()
                                 throws MessagingException
Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.

Returns:
the root Folder
Throws:
IllegalStateException - if this Store is not connected.
MessagingException

getFolder

public abstract Folder getFolder(String name)
                          throws MessagingException
Return the Folder object corresponding to the given name. Note that a Folder object is returned even if the named folder does not physically exist on the Store. The exists() method on the folder object indicates whether this folder really exists.

Folder objects are not cached by the Store, so invoking this method on the same name multiple times will return that many distinct Folder objects.

Parameters:
name - The name of the Folder. In some Stores, name can be an absolute path if it starts with the hierarchy delimiter. Else it is interpreted relative to the 'root' of this namespace.
Returns:
Folder object
Throws:
IllegalStateException - if this Store is not connected.
MessagingException
See Also:
Folder.exists(), Folder.create(int)

getFolder

public abstract Folder getFolder(URLName url)
                          throws MessagingException
Return a closed Folder object, corresponding to the given URLName. The store specified in the given URLName should refer to this Store object.

Implementations of this method may obtain the name of the actual folder using the getFile() method on URLName, and use that name to create the folder.

Parameters:
url - URLName that denotes a folder
Returns:
Folder object
Throws:
IllegalStateException - if this Store is not connected.
MessagingException
See Also:
URLName

getPersonalNamespaces

public Folder[] getPersonalNamespaces()
                               throws MessagingException
Return a set of folders representing the personal namespaces for the current user. A personal namespace is a set of names that is considered within the personal scope of the authenticated user. Typically, only the authenticated user has access to mail folders in their personal namespace. If an INBOX exists for a user, it must appear within the user's personal namespace. In the typical case, there should be only one personal namespace for each user in each Store.

This implementation returns an array with a single entry containing the return value of the getDefaultFolder method. Subclasses should override this method to return appropriate information.

Returns:
array of Folder objects
Throws:
IllegalStateException - if this Store is not connected.
MessagingException
Since:
JavaMail 1.2

getUserNamespaces

public Folder[] getUserNamespaces(String user)
                           throws MessagingException
Return a set of folders representing the namespaces for user. The namespaces returned represent the personal namespaces for the user. To access mail folders in the other user's namespace, the currently authenticated user must be explicitly granted access rights. For example, it is common for a manager to grant to their secretary access rights to their mail folders.

This implementation returns an empty array. Subclasses should override this method to return appropriate information.

Returns:
array of Folder objects
Throws:
IllegalStateException - if this Store is not connected.
MessagingException
Since:
JavaMail 1.2

getSharedNamespaces

public Folder[] getSharedNamespaces()
                             throws MessagingException
Return a set of folders representing the shared namespaces. A shared namespace is a namespace that consists of mail folders that are intended to be shared amongst users and do not exist within a user's personal namespace.

This implementation returns an empty array. Subclasses should override this method to return appropriate information.

Returns:
array of Folder objects
Throws:
IllegalStateException - if this Store is not connected.
MessagingException
Since:
JavaMail 1.2

addStoreListener

public void addStoreListener(StoreListener l)
Add a listener for StoreEvents on this Store.

The default implementation provided here adds this listener to an internal list of StoreListeners.

Parameters:
l - the Listener for Store events
See Also:
StoreEvent

removeStoreListener

public void removeStoreListener(StoreListener l)
Remove a listener for Store events.

The default implementation provided here removes this listener from the internal list of StoreListeners.

Parameters:
l - the listener
See Also:
addStoreListener(javax.mail.event.StoreListener)

notifyStoreListeners

protected void notifyStoreListeners(int type,
                                    String message)
Notify all StoreListeners. Store implementations are expected to use this method to broadcast StoreEvents.

The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered StoreListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

addFolderListener

public void addFolderListener(FolderListener l)
Add a listener for Folder events on any Folder object obtained from this Store. FolderEvents are delivered to FolderListeners on the affected Folder as well as to FolderListeners on the containing Store.

The default implementation provided here adds this listener to an internal list of FolderListeners.

Parameters:
l - the Listener for Folder events
See Also:
FolderEvent

removeFolderListener

public void removeFolderListener(FolderListener l)
Remove a listener for Folder events.

The default implementation provided here removes this listener from the internal list of FolderListeners.

Parameters:
l - the listener
See Also:
addFolderListener(javax.mail.event.FolderListener)

notifyFolderListeners

protected void notifyFolderListeners(int type,
                                     Folder folder)
Notify all FolderListeners. Store implementations are expected to use this method to broadcast Folder events.

The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered FolderListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

Parameters:
type - type of FolderEvent
folder - affected Folder
See Also:
notifyFolderRenamedListeners(javax.mail.Folder, javax.mail.Folder)

notifyFolderRenamedListeners

protected void notifyFolderRenamedListeners(Folder oldF,
                                            Folder newF)
Notify all FolderListeners about the renaming of a folder. Store implementations are expected to use this method to broadcast Folder events indicating the renaming of folders.

The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered FolderListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

Parameters:
oldF - the folder being renamed
newF - the folder representing the new name.
Since:
JavaMail 1.1
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StoreClosedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class StoreClosedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.mail.MessagingException
                extended by javax.mail.StoreClosedException
All Implemented Interfaces:
Serializable
public class StoreClosedException
extends MessagingException

This exception is thrown when a method is invoked on a Messaging object and the Store that owns that object has died due to some reason. This exception should be treated as a fatal error; in particular any messaging object belonging to that Store must be considered invalid.

The connect method may be invoked on the dead Store object to revive it.

The getMessage() method returns more detailed information about the error that caused this exception.

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
StoreClosedException(Store store)
Constructor
StoreClosedException(Store store, String message)
Constructor
Method Summary
 Store getStore()
Returns the dead Store object
Methods inherited from class javax.mail.MessagingException
getMessage, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StoreClosedException

public StoreClosedException(Store store)
Constructor

Parameters:
store - The dead Store object

StoreClosedException

public StoreClosedException(Store store,
                            String message)
Constructor

Parameters:
store - The dead Store object
message - The detailed error message
Method Detail

getStore

public Store getStore()
Returns the dead Store object

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Transport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Transport

java.lang.Object
    extended by javax.mail.Service
        extended by javax.mail.Transport
public abstract class Transport
extends Service

An abstract class that models a message transport. Subclasses provide actual implementations.

Note that Transport extends the Service class, which provides many common methods for naming transports, connecting to transports, and listening to connection events.

Version:
1.36, 03/04/10
Author:
John Mani, Max Spivak, Bill Shannon
See Also:
Service, ConnectionEvent, TransportEvent

Field Summary
Fields inherited from class javax.mail.Service
debug, session, url
Constructor Summary
Transport(Session session, URLName urlname)
Constructor.
Method Summary
void | addTransportListener(TransportListener l) Add a listener for Transport events.
protected void | notifyTransportListeners(int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg) Notify all TransportListeners.
void | removeTransportListener(TransportListener l) Remove a listener for Transport events.
static void | send(Message msg) Send a message.
static void | send(Message msg, Address[] addresses) Send the message to the specified addresses, ignoring any recipients specified in the message itself.
abstract void | sendMessage(Message msg, Address[] addresses) Send the Message to the specified list of addresses.
Methods inherited from class javax.mail.Service
addConnectionListener, close, connect, connect, connect, finalize, getURLName, isConnected, notifyConnectionListeners, protocolConnect, queueEvent, removeConnectionListener, setConnected, setURLName, toString
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Transport

public Transport(Session session,
                 URLName urlname)
Constructor.

Parameters:
session - Session object for this Transport.
urlname - URLName object to be used for this Transport
Method Detail

send

public static void send(Message msg)
                 throws MessagingException
Send a message. The message will be sent to all recipient addresses specified in the message (as returned from the Message method getAllRecipients), using message transports appropriate to each address. The send method calls the saveChanges method on the message before sending it.

If any of the recipient addresses is detected to be invalid by the Transport during message submission, a SendFailedException is thrown. Clients can get more detail about the failure by examining the exception. Whether or not the message is still sent succesfully to any valid addresses depends on the Transport implementation. See SendFailedException for more details. Note also that success does not imply that the message was delivered to the ultimate recipient, as failures may occur in later stages of delivery. Once a Transport accepts a message for delivery to a recipient, failures that occur later should be reported to the user via another mechanism, such as returning the undeliverable message.

Parameters:
msg - the message to send
Throws:
SendFailedException - if the message could not be sent to some or any of the recipients.
MessagingException
See Also:
Message.saveChanges(),
Message.getAllRecipients(),
send(Message, Address[]),
SendFailedException

send

public static void send(Message msg,
                        Address[] addresses)
                 throws MessagingException
Send the message to the specified addresses, ignoring any recipients specified in the message itself. The send method calls the saveChanges method on the message before sending it.

Parameters:
msg - the message to send
addresses - the addresses to which to send the message
Throws:
SendFailedException - if the message could not be sent to some or any of the recipients.
MessagingException
See Also:
Message.saveChanges(), send(Message), SendFailedException

sendMessage

public abstract void sendMessage(Message msg,
                                 Address[] addresses)
                          throws MessagingException
Send the Message to the specified list of addresses. An appropriate TransportEvent indicating the delivery status is delivered to any TransportListener registered on this Transport. Also, if any of the addresses is invalid, a SendFailedException is thrown. Whether or not the message is still sent succesfully to any valid addresses depends on the Transport implementation.

Unlike the static send method, the sendMessage method does not call the saveChanges method on the message; the caller should do so.

Parameters:
msg - The Message to be sent
addresses - array of addresses to send this message to
Throws:
SendFailedException - if the send failed because of invalid addresses.
MessagingException - if the connection is dead or not in the connected state
See Also:
TransportEvent

addTransportListener

public void addTransportListener(TransportListener l)
Add a listener for Transport events.

The default implementation provided here adds this listener to an internal list of TransportListeners.

Parameters:
l - the Listener for Transport events
See Also:
TransportEvent

removeTransportListener

public void removeTransportListener(TransportListener l)
Remove a listener for Transport events.

The default implementation provided here removes this listener from the internal list of TransportListeners.

Parameters:
l - the listener
See Also:
addTransportListener(javax.mail.event.TransportListener)

notifyTransportListeners

protected void notifyTransportListeners(int type,
                                        Address[] validSent,
                                        Address[] validUnsent,
                                        Address[] invalid,
                                        Message msg)
Notify all TransportListeners. Transport implementations are expected to use this method to broadcast TransportEvents.

The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered TransportListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


UIDFolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail
Interface UIDFolder

public interface UIDFolder

The UIDFolder interface is implemented by Folders that can support the "disconnected" mode of operation, by providing unique-ids for messages in the folder. This interface is based on the IMAP model for supporting disconnected operation.

A Unique identifier (UID) is a positive long value, assigned to each message in a specific folder. Unique identifiers are assigned in a strictly ascending fashion in the mailbox. That is, as each message is added to the mailbox it is assigned a higher UID than the message(s) which were added previously. Unique identifiers persist across sessions. This permits a client to resynchronize its state from a previous session with the server.

Associated with every mailbox is a unique identifier validity value. If unique identifiers from an earlier session fail to persist to this session, the unique identifier validity value must be greater than the one used in the earlier session.

Refer to RFC 2060 http://www.ietf.org/rfc/rfc2060.txt for more information.

Author:
John Mani

Nested Class Summary
static class UIDFolder.FetchProfileItem
A fetch profile item for fetching UIDs.
Field Summary
static long LASTUID
This is a special value that can be used as the end parameter in getMessages(start, end), to denote the last UID in this folder.
Method Summary
Message | getMessageByUID(long uid) Get the Message corresponding to the given UID.
Message[] | getMessagesByUID(long[] uids) Get the Messages specified by the given array of UIDs.
Message[] | getMessagesByUID(long start, long end) Get the Messages specified by the given range.
long | getUID(Message message) Get the UID for the specified message.
long | getUIDValidity() Returns the UIDValidity value associated with this folder.

Field Detail

LASTUID

public static final long LASTUID
This is a special value that can be used as the end parameter in getMessages(start, end), to denote the last UID in this folder.

See Also:
getMessagesByUID(long, long), Constant Field Values
Method Detail

getUIDValidity

public long getUIDValidity()
                    throws MessagingException
Returns the UIDValidity value associated with this folder.

Clients typically compare this value against a UIDValidity value saved from a previous session to insure that any cached UIDs not stale.

Returns:
UIDValidity
Throws:
MessagingException

getMessageByUID

public Message getMessageByUID(long uid)
                        throws MessagingException
Get the Message corresponding to the given UID. If no such message exists, null is returned.

Parameters:
uid - UID for the desired message
Returns:
the Message object. null is returned if no message corresponding to this UID is obtained.
Throws:
MessagingException

getMessagesByUID

public Message[] getMessagesByUID(long start,
                                  long end)
                           throws MessagingException
Get the Messages specified by the given range. The special value LASTUID can be used for the end parameter to indicate the last available UID.

Parameters:
start - start UID
end - end UID
Returns:
array of Message objects
Throws:
MessagingException
See Also:
LASTUID

getMessagesByUID

public Message[] getMessagesByUID(long[] uids)
                           throws MessagingException
Get the Messages specified by the given array of UIDs. If any UID is invalid, null is returned for that entry.

Note that the returned array will be of the same size as the specified array of UIDs, and null entries may be present in the array to indicate invalid UIDs.

Parameters:
uids - array of UIDs
Returns:
array of Message objects
Throws:
MessagingException

getUID

public long getUID(Message message)
            throws MessagingException
Get the UID for the specified message. Note that the message must belong to this folder. Else the java.util.NoSuchElementException is thrown.

Parameters:
message - Message from this folder
Returns:
UID for this message
Throws:
NoSuchElementException - if the given Message is not in this Folder.
MessagingException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


UIDFolder.FetchProfileItem

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class UIDFolder.FetchProfileItem

java.lang.Object
    extended by javax.mail.FetchProfile.Item
        extended by javax.mail.UIDFolder.FetchProfileItem
Enclosing class:
UIDFolder
public static class UIDFolder.FetchProfileItem
extends FetchProfile.Item

A fetch profile item for fetching UIDs. This inner class extends the FetchProfile.Item class to add new FetchProfile item types, specific to UIDFolders. The only item currently defined here is the UID item.

See Also:
FetchProfile

Field Summary
static UIDFolder.FetchProfileItem UID
UID is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder.
Fields inherited from class javax.mail.FetchProfile.Item
CONTENT_INFO, ENVELOPE, FLAGS
Constructor Summary
protected UIDFolder.FetchProfileItem(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UID

public static final UIDFolder.FetchProfileItem UID
UID is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder. This item indicates that the UIDs for messages in the specified range are desired to be prefetched.

An example of how a client uses this is below:

     FetchProfile fp = new FetchProfile();
    fp.add(UIDFolder.FetchProfileItem.UID);
    folder.fetch(msgs, fp);

Constructor Detail

UIDFolder.FetchProfileItem

protected UIDFolder.FetchProfileItem(String name)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


URLName

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class URLName

java.lang.Object
    extended by javax.mail.URLName
public class URLName
extends Object

The name of a URL. This class represents a URL name and also provides the basic parsing functionality to parse most internet standard URL schemes.

Note that this class differs from java.net.URL in that this class just represents the name of a URL, it does not model the connection to a URL.

Version:
1.15, 02/03/27
Author:
Christopher Cotton, Bill Shannon

Field Summary
protected  String fullURL
The full version of the URL
Constructor Summary
URLName(String url)
Construct a URLName from the string.
URLName(String protocol, String host, int port, String file, String username, String password)
Creates a URLName object from the specified protocol, host, port number, file, username, and password.
URLName(URL url)
Construct a URLName from a java.net.URL object.
Method Summary
boolean | equals(Object obj) Compares two URLNames.
String | getFile() Returns the file name of this URLName.
String | getHost() Returns the host of this URLName.
String | getPassword() Returns the password of this URLName.
int | getPort() Returns the port number of this URLName.
String | getProtocol() Returns the protocol of this URLName.
String | getRef() Returns the reference of this URLName.
URL | getURL() Constructs a URL from the URLName.
String | getUsername() Returns the user name of this URLName.
int | hashCode() Compute the hash code for this URLName.
protected void | parseString(String url) Method which does all of the work of parsing the string.
String | toString() Constructs a string representation of this URLName.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

fullURL

protected String fullURL
The full version of the URL

Constructor Detail

URLName

public URLName(String protocol,
               String host,
               int port,
               String file,
               String username,
               String password)
Creates a URLName object from the specified protocol, host, port number, file, username, and password. Specifying a port number of -1 indicates that the URL should use the default port for the protocol.

URLName

public URLName(URL url)
Construct a URLName from a java.net.URL object.

URLName

public URLName(String url)
Construct a URLName from the string. Parses out all the possible information (protocol, host, port, file, username, password).

Method Detail

toString

public String toString()
Constructs a string representation of this URLName.

parseString

protected void parseString(String url)
Method which does all of the work of parsing the string.

getPort

public int getPort()
Returns the port number of this URLName. Returns -1 if the port is not set.

getProtocol

public String getProtocol()
Returns the protocol of this URLName. Returns null if this URLName has no protocol.

getFile

public String getFile()
Returns the file name of this URLName. Returns null if this URLName has no file name.

getRef

public String getRef()
Returns the reference of this URLName. Returns null if this URLName has no reference.

getHost

public String getHost()
Returns the host of this URLName. Returns null if this URLName has no host.

getUsername

public String getUsername()
Returns the user name of this URLName. Returns null if this URLName has no user name.

getPassword

public String getPassword()
Returns the password of this URLName. Returns null if this URLName has no password.

getURL

public URL getURL()
           throws MalformedURLException
Constructs a URL from the URLName.

Throws:
MalformedURLException

equals

public boolean equals(Object obj)
Compares two URLNames. The result is true if and only if the argument is not null and is a URLName object that represents the same URLName as this object. Two URLName objects are equal if they have the same protocol and reference the same host, the same port number on the host, the same username and password, and the same file on the host. The fields (host, username, password, file) are also considered the same if they are both null.

hashCode

public int hashCode()
Compute the hash code for this URLName.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


management

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management

Provides the core JMX classes.

See:
Description

Interface Summary
Descriptor | This interface represents the behavioral metadata set for a JMX Element.
DescriptorAccess | This interface is used to gain access to descriptors of the Descriptor class which are associated with a JMX component, i.e.
DynamicMBean | Defines the methods that should be implemented by a Dynamic MBean (MBean that exposes a dynamic management interface).
MBeanRegistration | Can be implemented by an MBean in order to carry out operations before and after being registered or unregistered from the MBean server.
MBeanServer | This is the interface for MBean manipulation on the agent side.
MBeanServerConnection | This interface represents a way to talk to an MBean server, whether local or remote.
MBeanServerDelegateMBean | Defines the management interface of an object of class MBeanServerDelegate.
NotificationBroadcaster | Interface implemented by an MBean that emits Notifications.
NotificationEmitter | Interface implemented by an MBean that emits Notifications.
NotificationFilter | To be implemented by a any class acting as a notification filter.
NotificationListener | Should be implemented by an object that wants to receive notifications.
PersistentMBean | This class is the interface to be implemented by MBeans that are meant to be persistent.
QueryExp | Represents relational constraints that can be used in database query "where clauses".
ValueExp | Represents values that can be passed as arguments to relational expressions.

Class Summary
Attribute | Represents an MBean attribute by associating its name with its value.
AttributeChangeNotification | Provides definitions of the attribute change notifications sent by MBeans.
AttributeChangeNotificationFilter | This class implements of the NotificationFilter interface for the attribute change notification.
AttributeList | Represents a list of values for attributes of an MBean.
AttributeValueExp | Represents attributes used as arguments to relational constraints.
DefaultLoaderRepository | Deprecated. Use MBeanServer.getClassLoaderRepository()} instead.
MBeanAttributeInfo | Describes an MBean attribute exposed for management.
MBeanConstructorInfo | Describes a constructor exposed by an MBean.
MBeanFeatureInfo | Provides general information for an MBean descriptor object.
MBeanInfo | Describes the management interface exposed by an MBean; that is, the set of attributes and operations which are available for management operations.
MBeanNotificationInfo | The MBeanNotificationInfo class is used to describe the characteristics of the different notification instances emitted by an MBean, for a given Java class of notification.
MBeanOperationInfo | Describes a management operation exposed by an MBean.
MBeanParameterInfo | Describes an argument of an operation exposed by an MBean.
MBeanPermission | Permission controlling access to MBeanServer operations.
MBeanServerBuilder | This class represents a builder that creates a default MBeanServer implementation.
MBeanServerDelegate | Represents the MBean server from the management point of view.
MBeanServerFactory | Provides MBean server references.
MBeanServerInvocationHandler | InvocationHandler that forwards methods in an MBean's management interface through the MBean server to the MBean.
MBeanServerNotification | Represents a notification emitted by the MBean server through the MBeanServerDelegate MBean.
MBeanServerPermission | A Permission to perform actions related to MBeanServers.
MBeanTrustPermission | This permission represents "trust" in a signer or codebase.
Notification | The Notification class represents a notification emitted by an MBean.
NotificationBroadcasterSupport | Provides an implementation of NotificationEmitter interface.
NotificationFilterSupport | Provides an implementation of the NotificationFilter interface.
ObjectInstance | Used to represent the object name of an MBean and its class name.
ObjectName | Represents the object name of an MBean, or a pattern that can match the names of several MBeans.
Query | Constructs query object constraints.
QueryEval | Allows a query to be performed in the context of a specific MBean server.
StandardMBean | An MBean whose management interface is determined by reflection on a Java interface.
StringValueExp | Represents strings that are arguments to relational constraints.

Exception Summary
AttributeNotFoundException | The specified attribute does not exist or cannot be retrieved.
BadAttributeValueExpException | Thrown when an invalid MBean attribute is passed to a query constructing method.
BadBinaryOpValueExpException | Thrown when an invalid expression is passed to a method for constructing a query.
BadStringOperationException | Thrown when an invalid string operation is passed to a method for constructing a query.
InstanceAlreadyExistsException | The MBean is already registered in the repository.
InstanceNotFoundException | The specified MBean does not exist in the repository.
IntrospectionException | An exception occurred during the introspection of an MBean.
InvalidApplicationException | Thrown when an attempt is made to apply either of the following: A subquery expression to an MBean or a qualified attribute expression to an MBean of the wrong class.
InvalidAttributeValueException | The value specified is not valid for the attribute.
JMException | Exceptions thrown by JMX implementations.
JMRuntimeException | Runtime exceptions emitted by JMX implementations.
ListenerNotFoundException | The specified MBean listener does not exist in the repository.
MalformedObjectNameException | The format of the string does not correspond to a valid ObjectName.
MBeanException | Represents "user defined" exceptions thrown by MBean methods in the agent.
MBeanRegistrationException | Wraps exceptions thrown by the preRegister(), preDeregister() methods of the MBeanRegistration interface.
NotCompliantMBeanException | Exception which occurs when trying to register an object in the MBean server that is not a JMX compliant MBean.
OperationsException | Represents exceptions thrown in the MBean server when performing operations on MBeans.
ReflectionException | Represents exceptions thrown in the MBean server when using the java.lang.reflect classes to invoke methods on MBeans.
RuntimeErrorException | When a java.lang.Error occurs in the agent it should be caught and re-thrown as a RuntimeErrorException.
RuntimeMBeanException | Represents runtime exceptions thrown by MBean methods in the agent.
RuntimeOperationsException | Represents runtime exceptions thrown in the agent when performing operations on MBeans.
ServiceNotFoundException | Represents exceptions raised when a requested service is not supported.

Package javax.management Description

Provides the core JMX classes.

Since:
JMX 1.0
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.management Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class javax.management.AttributeList
    • class javax.management.Attribute (implements java.io.Serializable)
    • class javax.management.AttributeChangeNotificationFilter (implements javax.management.NotificationFilter, java.io.Serializable)
    • class javax.management.AttributeValueExp (implements javax.management.ValueExp)
    • class javax.management.DefaultLoaderRepository
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.management.Notification
        • class javax.management.AttributeChangeNotification
        • class javax.management.MBeanServerNotification
    • class javax.management.MBeanFeatureInfo (implements java.io.Serializable)
      • class javax.management.MBeanAttributeInfo (implements java.lang.Cloneable, java.io.Serializable)
      • class javax.management.MBeanConstructorInfo (implements java.lang.Cloneable, java.io.Serializable)
      • class javax.management.MBeanNotificationInfo (implements java.lang.Cloneable, java.io.Serializable)
      • class javax.management.MBeanOperationInfo (implements java.lang.Cloneable, java.io.Serializable)
      • class javax.management.MBeanParameterInfo (implements java.lang.Cloneable, java.io.Serializable)
    • class javax.management.MBeanInfo (implements java.lang.Cloneable, java.io.Serializable)
    • class javax.management.MBeanServerBuilder
    • class javax.management.MBeanServerDelegate (implements javax.management.MBeanServerDelegateMBean, javax.management.NotificationEmitter)
    • class javax.management.MBeanServerFactory
    • class javax.management.MBeanServerInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • class javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
    • class javax.management.NotificationFilterSupport (implements javax.management.NotificationFilter, java.io.Serializable)
    • class javax.management.ObjectInstance (implements java.io.Serializable)
    • class javax.management.ObjectName (implements javax.management.QueryExp, java.io.Serializable)
    • class java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • class java.security.BasicPermission (implements java.io.Serializable)
        • class javax.management.MBeanServerPermission
        • class javax.management.MBeanTrustPermission
      • class javax.management.MBeanPermission
    • class javax.management.Query
    • class javax.management.QueryEval (implements java.io.Serializable)
    • class javax.management.StandardMBean (implements javax.management.DynamicMBean)
    • class javax.management.StringValueExp (implements javax.management.ValueExp)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.management.BadAttributeValueExpException
        • class javax.management.BadBinaryOpValueExpException
        • class javax.management.BadStringOperationException
        • class javax.management.InvalidApplicationException
        • class javax.management.JMException
          • class javax.management.MBeanException
            • class javax.management.MBeanRegistrationException
          • class javax.management.OperationsException
            • class javax.management.AttributeNotFoundException
            • class javax.management.InstanceAlreadyExistsException
            • class javax.management.InstanceNotFoundException
            • class javax.management.IntrospectionException
            • class javax.management.InvalidAttributeValueException
            • class javax.management.ListenerNotFoundException
            • class javax.management.MalformedObjectNameException
            • class javax.management.NotCompliantMBeanException
            • class javax.management.ServiceNotFoundException
          • class javax.management.ReflectionException
        • class java.lang.RuntimeException
          • class javax.management.JMRuntimeException
            • class javax.management.RuntimeErrorException
            • class javax.management.RuntimeMBeanException
            • class javax.management.RuntimeOperationsException

Interface Hierarchy

  • interface java.lang.Cloneable
    • interface javax.management.Descriptor (also extends java.io.Serializable)
  • interface javax.management.DescriptorAccess
  • interface javax.management.DynamicMBean
  • interface java.util.EventListener
    • interface javax.management.NotificationListener
  • interface javax.management.MBeanRegistration
  • interface javax.management.MBeanServerConnection
    • interface javax.management.MBeanServer
  • interface javax.management.MBeanServerDelegateMBean
  • interface javax.management.NotificationBroadcaster
    • interface javax.management.NotificationEmitter
  • interface javax.management.PersistentMBean
  • interface java.io.Serializable
    • interface javax.management.Descriptor (also extends java.lang.Cloneable)
    • interface javax.management.NotificationFilter
    • interface javax.management.QueryExp
    • interface javax.management.ValueExp
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Attribute

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management
Class Attribute

java.lang.Object
    extended by javax.management.Attribute
All Implemented Interfaces:
Serializable
public class Attribute
extends Object
implements Serializable

Represents an MBean attribute by associating its name with its value. The MBean server and other objects use this class to get and set attributes values.

See Also:
Serialized Form

Constructor Summary
Attribute(String name, Object value)
Constructs an Attribute object which associates the given attribute name with the given value.
Method Summary
boolean | equals(Object object) Compares the current Attribute Object with another Attribute Object.
String | getName() Returns a String containing the name of the attribute.
Object | getValue() Returns an Object that is the value of this attribute.
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Attribute

public Attribute(String name,
                 Object value)
Constructs an Attribute object which associates the given attribute name with the given value.

Parameters:
name - A String containing the name of the attribute to be created. Cannot be null.
value - The Object which is assigned to the attribute. This object must be of the same type as the attribute.
Method Detail

getName

public String getName()
Returns a String containing the name of the attribute.

Returns:
the name of the attribute.

getValue

public Object getValue()
Returns an Object that is the value of this attribute.

Returns:
the value of the attribute.

equals

public boolean equals(Object object)
Compares the current Attribute Object with another Attribute Object.

Parameters:
object - The Attribute that the current Attribute is to be compared with.
Returns:
True if the two Attribute objects are equal, otherwise false.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AttributeChangeNotification

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class AttributeChangeNotification

java.lang.Object
    extended by java.util.EventObject
        extended by javax.management.Notification
            extended by javax.management.AttributeChangeNotification
All Implemented Interfaces:
Serializable
public class AttributeChangeNotification
extends Notification

Provides definitions of the attribute change notifications sent by MBeans.

It's up to the MBean owning the attribute of interest to create and send attribute change notifications when the attribute change occurs. So the NotificationBroadcaster interface has to be implemented by any MBean for which an attribute change is of interest.

Example: If an MBean called myMbean needs to notify registered listeners when its attribute:

String myString
is modified, myMbean creates and emits the following notification:
new AttributeChangeNotification(myMbean, sequenceNumber, timeStamp, msg, "myString", "String", oldValue, newValue);

See Also:
Serialized Form

Field Summary
static String ATTRIBUTE_CHANGE
Notification type which indicates that the observed MBean attribute value has changed.
Fields inherited from class javax.management.Notification
source
Constructor Summary
AttributeChangeNotification(Object source, long sequenceNumber, long timeStamp, String msg, String attributeName, String attributeType, Object oldValue, Object newValue)
Constructs an attribute change notification object.
Method Summary
String | getAttributeName() Gets the name of the attribute which has changed.
String | getAttributeType() Gets the type of the attribute which has changed.
Object | getNewValue() Gets the new value of the attribute which has changed.
Object | getOldValue() Gets the old value of the attribute which has changed.
Methods inherited from class javax.management.Notification
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ATTRIBUTE_CHANGE

public static final String ATTRIBUTE_CHANGE
Notification type which indicates that the observed MBean attribute value has changed.
The value of this type string is jmx.attribute.change.

Constructor Detail

AttributeChangeNotification

public AttributeChangeNotification(Object source,
                                   long sequenceNumber,
                                   long timeStamp,
                                   String msg,
                                   String attributeName,
                                   String attributeType,
                                   Object oldValue,
                                   Object newValue)
Constructs an attribute change notification object. In addition to the information common to all notification, the caller must supply the name and type of the attribute, as well as its old and new values.

Parameters:
source - The notification producer, that is, the MBean the attribute belongs to.
sequenceNumber - The notification sequence number within the source object.
timeStamp - The date at which the notification is being sent.
msg - A String containing the message of the notification.
attributeName - A String giving the name of the attribute.
attributeType - A String containing the type of the attribute.
oldValue - An object representing value of the attribute before the change.
newValue - An object representing value of the attribute after the change.
Method Detail

getAttributeName

public String getAttributeName()
Gets the name of the attribute which has changed.

Returns:
A String containing the name of the attribute.

getAttributeType

public String getAttributeType()
Gets the type of the attribute which has changed.

Returns:
A String containing the type of the attribute.

getOldValue

public Object getOldValue()
Gets the old value of the attribute which has changed.

Returns:
An Object containing the old value of the attribute.

getNewValue

public Object getNewValue()
Gets the new value of the attribute which has changed.

Returns:
An Object containing the new value of the attribute.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AttributeChangeNotificationFilter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class AttributeChangeNotificationFilter

java.lang.Object
    extended by javax.management.AttributeChangeNotificationFilter
All Implemented Interfaces:
NotificationFilter, Serializable
public class AttributeChangeNotificationFilter
extends Object
implements NotificationFilter, Serializable

This class implements of the NotificationFilter interface for the attribute change notification. The filtering is performed on the name of the observed attribute.

It manages a list of enabled attribute names. A method allows users to enable/disable as many attribute names as required.

See Also:
Serialized Form

Constructor Summary
AttributeChangeNotificationFilter()
Method Summary
void | disableAllAttributes() Disables all the attribute names.
void | disableAttribute(String name) Disables all the attribute change notifications the attribute name of which equals the specified attribute name to be sent to the listener.
void | enableAttribute(String name) Enables all the attribute change notifications the attribute name of which equals the specified name to be sent to the listener.
Vector | getEnabledAttributes() Gets all the enabled attribute names for this filter.
boolean | isNotificationEnabled(Notification notification) Invoked before sending the specified notification to the listener.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AttributeChangeNotificationFilter

public AttributeChangeNotificationFilter()
Method Detail

isNotificationEnabled

public boolean isNotificationEnabled(Notification notification)
Invoked before sending the specified notification to the listener.
This filter compares the attribute name of the specified attribute change notification with each enabled attribute name. If the attribute name equals one of the enabled attribute names, the notification must be sent to the listener and this method returns true.

Specified by:
isNotificationEnabled in interface NotificationFilter
Parameters:
notification - The attribute change notification to be sent.
Returns:
true if the notification has to be sent to the listener, false otherwise.

enableAttribute

public void enableAttribute(String name)
                     throws IllegalArgumentException
Enables all the attribute change notifications the attribute name of which equals the specified name to be sent to the listener.
If the specified name is already in the list of enabled attribute names, this method has no effect.

Parameters:
name - The attribute name.
Throws:
IllegalArgumentException - The attribute name parameter is null.

disableAttribute

public void disableAttribute(String name)
Disables all the attribute change notifications the attribute name of which equals the specified attribute name to be sent to the listener.
If the specified name is not in the list of enabled attribute names, this method has no effect.

Parameters:
name - The attribute name.

disableAllAttributes

public void disableAllAttributes()
Disables all the attribute names.

getEnabledAttributes

public Vector getEnabledAttributes()
Gets all the enabled attribute names for this filter.

Returns:
The list containing all the enabled attribute names.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AttributeList

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class AttributeList

java.lang.Object
    extended by java.util.AbstractCollection
        extended by java.util.AbstractList
            extended by java.util.ArrayList
                extended by javax.management.AttributeList
All Implemented Interfaces:
Cloneable, Collection, List, RandomAccess, Serializable
public class AttributeList
extends ArrayList

Represents a list of values for attributes of an MBean. The methods used for the insertion of Attribute objects in the AttributeList overrides the corresponding methods in the superclass ArrayList. This is needed in order to insure that the objects contained in the AttributeList are only Attribute objects. This avoids getting an exception when retrieving elements from the AttributeList.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
AttributeList()
Constructs an empty AttributeList.
AttributeList(AttributeList list)
Constructs an AttributeList containing the elements of the AttributeList specified, in the order in which they are returned by the AttributeList's iterator.
AttributeList(int initialCapacity)
Constructs an empty AttributeList with the initial capacity specified.
Method Summary
void | add(Attribute object) Adds the Attribute specified as the last element of the list.
void | add(int index, Attribute object) Inserts the attribute specified as an element at the position specified.
boolean | addAll(AttributeList list) Appends all the elements in the AttributeList specified to the end of the list, in the order in which they are returned by the Iterator of the AttributeList specified.
boolean | addAll(int index, AttributeList list) Inserts all of the elements in the AttributeList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the AttributeList specified.
void | set(int index, Attribute object) Sets the element at the position specified to be the attribute specified.
Methods inherited from class java.util.ArrayList
add, add, addAll, addAll, clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, remove, removeRange, set, size, toArray, toArray, trimToSize
Methods inherited from class java.util.AbstractList
equals, hashCode, iterator, listIterator, listIterator, subList
Methods inherited from class java.util.AbstractCollection
containsAll, remove, removeAll, retainAll, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
containsAll, equals, hashCode, iterator, listIterator, listIterator, remove, removeAll, retainAll, subList

Constructor Detail

AttributeList

public AttributeList()
Constructs an empty AttributeList.

AttributeList

public AttributeList(int initialCapacity)
Constructs an empty AttributeList with the initial capacity specified.

Parameters:
initialCapacity - the initial capacity of the AttributeList, as specified by ArrayList.ArrayList(int).

AttributeList

public AttributeList(AttributeList list)
Constructs an AttributeList containing the elements of the AttributeList specified, in the order in which they are returned by the AttributeList's iterator. The AttributeList instance has an initial capacity of 110% of the size of the AttributeList specified.

Parameters:
list - the AttributeList that defines the initial contents of the new AttributeList.
See Also:
ArrayList.ArrayList(java.util.Collection)
Method Detail

add

public void add(Attribute object)
Adds the Attribute specified as the last element of the list.

Parameters:
object - The attribute to be added.

add

public void add(int index,
                Attribute object)
Inserts the attribute specified as an element at the position specified. Elements with an index greater than or equal to the current position are shifted up. If the index is out of range (index < 0 || index > size() a RuntimeOperationsException should be raised, wrapping the java.lang.IndexOutOfBoundsException thrown.

Parameters:
object - The Attribute object to be inserted.
index - The position in the list where the new Attribute object is to be inserted.

set

public void set(int index,
                Attribute object)
Sets the element at the position specified to be the attribute specified. The previous element at that position is discarded. If the index is out of range (index < 0 || index > size() a RuntimeOperationsException should be raised, wrapping the java.lang.IndexOutOfBoundsException thrown.

Parameters:
object - The value to which the attribute element should be set.
index - The position specified.

addAll

public boolean addAll(AttributeList list)
Appends all the elements in the AttributeList specified to the end of the list, in the order in which they are returned by the Iterator of the AttributeList specified.

Parameters:
list - Elements to be inserted into the list.
Returns:
true if this list changed as a result of the call.
See Also:
ArrayList.addAll(java.util.Collection)

addAll

public boolean addAll(int index,
                      AttributeList list)
Inserts all of the elements in the AttributeList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the AttributeList specified. If the index is out of range (index < 0 || index > size() a RuntimeOperationsException should be raised, wrapping the java.lang.IndexOutOfBoundsException thrown.

Parameters:
list - Elements to be inserted into the list.
index - Position at which to insert the first element from the AttributeList specified.
Returns:
true if this list changed as a result of the call.
See Also:
ArrayList.addAll(int, java.util.Collection)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AttributeNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management
Class AttributeNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.OperationsException
                    extended by javax.management.AttributeNotFoundException
All Implemented Interfaces:
Serializable
public class AttributeNotFoundException
extends OperationsException

The specified attribute does not exist or cannot be retrieved.

See Also:
Serialized Form

Constructor Summary
AttributeNotFoundException()
Default constructor.
AttributeNotFoundException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AttributeNotFoundException

public AttributeNotFoundException()
Default constructor.

AttributeNotFoundException

public AttributeNotFoundException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AttributeValueExp

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class AttributeValueExp

java.lang.Object
    extended by javax.management.AttributeValueExp
All Implemented Interfaces:
Serializable, ValueExp
public class AttributeValueExp
extends Object
implements ValueExp

Represents attributes used as arguments to relational constraints. An AttributeValueExp may be used anywhere a ValueExp is required.

See Also:
Serialized Form

Constructor Summary
AttributeValueExp()
Deprecated. An instance created with this constructor cannot be used in a query.
AttributeValueExp(String attr)
Creates a new AttributeValueExp representing the specified object attribute, named attr.
Method Summary
ValueExp | apply(ObjectName name) Applies the AttributeValueExp on an MBean.
protected Object | getAttribute(ObjectName name) Return the value of the given attribute in the named MBean.
String | getAttributeName() Returns a string representation of the name of the attribute.
void | setMBeanServer(MBeanServer s) Sets the MBean server on which the query is to be performed.
String | toString() Returns the string representing its value.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AttributeValueExp

public AttributeValueExp()
Deprecated. An instance created with this constructor cannot be used in a query.

An AttributeValueExp with a null attribute.

AttributeValueExp

public AttributeValueExp(String attr)
Creates a new AttributeValueExp representing the specified object attribute, named attr.

Parameters:
attr - the name of the attribute whose value is the value of this ValueExp.
Method Detail

getAttributeName

public String getAttributeName()
Returns a string representation of the name of the attribute.

Returns:
the attribute name.

apply

public ValueExp apply(ObjectName name)
               throws BadStringOperationException,
                      BadBinaryOpValueExpException,
                      BadAttributeValueExpException,
                      InvalidApplicationException
Applies the AttributeValueExp on an MBean.

Specified by:
apply in interface ValueExp
Parameters:
name - The name of the MBean on which the AttributeValueExp will be applied.
Returns:
The ValueExp.
Throws:
BadAttributeValueExpException
InvalidApplicationException
BadStringOperationException
BadBinaryOpValueExpException

toString

public String toString()
Returns the string representing its value.

setMBeanServer

public void setMBeanServer(MBeanServer s)
Sets the MBean server on which the query is to be performed.

Specified by:
setMBeanServer in interface ValueExp
Parameters:
s - The MBean server on which the query is to be performed.

getAttribute

protected Object getAttribute(ObjectName name)
Return the value of the given attribute in the named MBean. If the attempt to access the attribute generates an exception, return null.

Parameters:
name - the name of the MBean whose attribute is to be returned.
Returns:
the value of the attribute, or null if it could not be obtained.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BadAttributeValueExpException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class BadAttributeValueExpException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.BadAttributeValueExpException
All Implemented Interfaces:
Serializable
public class BadAttributeValueExpException
extends Exception

Thrown when an invalid MBean attribute is passed to a query constructing method. This exception is used internally by JMX during the evaluation of a query. User code does not usually see it.

See Also:
Serialized Form

Constructor Summary
BadAttributeValueExpException(Object val)
Constructs an BadAttributeValueExpException with the specified Object.
Method Summary
 String toString()
Returns the string representing the object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BadAttributeValueExpException

public BadAttributeValueExpException(Object val)
Constructs an BadAttributeValueExpException with the specified Object.

Parameters:
val - the inappropriate value.
Method Detail

toString

public String toString()
Returns the string representing the object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BadBinaryOpValueExpException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class BadBinaryOpValueExpException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.BadBinaryOpValueExpException
All Implemented Interfaces:
Serializable
public class BadBinaryOpValueExpException
extends Exception

Thrown when an invalid expression is passed to a method for constructing a query. This exception is used internally by JMX during the evaluation of a query. User code does not usually see it.

See Also:
Serialized Form

Constructor Summary
BadBinaryOpValueExpException(ValueExp exp)
Constructs a BadBinaryOpValueExpException with the specified ValueExp.
Method Summary
ValueExp | getExp() Returns the ValueExp that originated the exception.
String | toString() Returns the string representing the object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BadBinaryOpValueExpException

public BadBinaryOpValueExpException(ValueExp exp)
Constructs a BadBinaryOpValueExpException with the specified ValueExp.

Parameters:
exp - the expression whose value was inappropriate.
Method Detail

getExp

public ValueExp getExp()
Returns the ValueExp that originated the exception.

Returns:
the problematic ValueExp.

toString

public String toString()
Returns the string representing the object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BadStringOperationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class BadStringOperationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.BadStringOperationException
All Implemented Interfaces:
Serializable
public class BadStringOperationException
extends Exception

Thrown when an invalid string operation is passed to a method for constructing a query.

See Also:
Serialized Form

Constructor Summary
BadStringOperationException(String message)
Constructs a BadStringOperationException with the specified detail message.
Method Summary
 String toString()
Returns the string representing the object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BadStringOperationException

public BadStringOperationException(String message)
Constructs a BadStringOperationException with the specified detail message.

Parameters:
message - the detail message.
Method Detail

toString

public String toString()
Returns the string representing the object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DefaultLoaderRepository

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class DefaultLoaderRepository

java.lang.Object
    extended by javax.management.DefaultLoaderRepository
Deprecated. Use MBeanServer.getClassLoaderRepository()} instead.

public class DefaultLoaderRepository
extends Object

Keeps the list of Class Loaders registered in the MBean Server. It provides the necessary methods to load classes using the registered Class Loaders.

This deprecated class is maintained for compatibility. In previous versions of JMX, there was one DefaultLoaderRepository shared by all MBean servers. As of JMX 1.2, that functionality is approximated by using MBeanServerFactory.findMBeanServer(java.lang.String) to find all known MBean servers, and consulting the ClassLoaderRepository of each one. It is strongly recommended that code referencing DefaultLoaderRepository be rewritten.

Constructor Summary
DefaultLoaderRepository()
Deprecated.
Method Summary
static Class | loadClass(String className) Deprecated. Go through the list of class loaders and try to load the requested class.
static Class | loadClassWithout(ClassLoader loader, String className) Deprecated. Go through the list of class loaders but exclude the given class loader, then try to load the requested class.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultLoaderRepository

public DefaultLoaderRepository()
Deprecated.
Method Detail

loadClass

public static Class loadClass(String className)
                       throws ClassNotFoundException
Deprecated.
Go through the list of class loaders and try to load the requested class. The method will stop as soon as the class is found. If the class is not found the method will throw a ClassNotFoundException exception.

Parameters:
className - The name of the class to be loaded.
Returns:
the loaded class.
Throws:
ClassNotFoundException - The specified class could not be found.

loadClassWithout

public static Class loadClassWithout(ClassLoader loader,
                                     String className)
                              throws ClassNotFoundException
Deprecated.
Go through the list of class loaders but exclude the given class loader, then try to load the requested class. The method will stop as soon as the class is found. If the class is not found the method will throw a ClassNotFoundException exception.

Parameters:
className - The name of the class to be loaded.
loader - The class loader to be excluded.
Returns:
the loaded class.
Throws:
ClassNotFoundException - The specified class could not be found.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Descriptor

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface Descriptor

All Superinterfaces:
Cloneable, Serializable
All Known Implementing Classes:
DescriptorSupport
public interface Descriptor
extends Serializable, Cloneable

This interface represents the behavioral metadata set for a JMX Element. For examples, a descriptor is part of the ModelMBeanInfo, ModelMBeanNotificationInfo, ModelMBeanAttributeInfo, ModelMBeanConstructorInfo, and ModelMBeanParameterInfo.

A descriptor consists of a collection of fields. Each field is in fieldname=fieldvalue format.

All field names and values are not predefined. New fields can be defined and added by any program. In the case of ModelMBean some fields have been predefined for consistency of implementation and support by the ModelMBeanInfo ModelMBean*Info, and ModelMBean classes.

Method Summary
Object | clone() Returns a new Descriptor which is a duplicate of the Descriptor.
String[] | getFieldNames() Returns all the fields names in the descriptor.
String[] | getFields() Returns all of the fields contained in this descriptor as a string array.
Object | getFieldValue(String fieldName) Returns the value for a specific fieldname.
Object[] | getFieldValues(String[] fieldNames) Returns all the field values in the descriptor as an array of Objects.
boolean | isValid() Returns true if all of the fields have legal values given their names.
void | removeField(String fieldName) Removes a field from the descriptor.
void | setField(String fieldName, Object fieldValue) Sets the value for a specific fieldname.
void | setFields(String[] fieldNames, Object[] fieldValues) Sets all Fields in the list to the new value in with the same index in the fieldValue array.

Method Detail

getFieldValue

public Object getFieldValue(String fieldName)
                     throws RuntimeOperationsException
Returns the value for a specific fieldname.

Parameters:
fieldName - The field name in question; if not found, null is returned.
Returns:
Object Field value.
Throws:
RuntimeOperationsException - for illegal value for field name.

setField

public void setField(String fieldName,
                     Object fieldValue)
              throws RuntimeOperationsException
Sets the value for a specific fieldname. The field value will be validated before it is set. If it is not valid, then an exception will be thrown. This will modify an existing field or add a new field.

Parameters:
fieldName - The field name to be set. Cannot be null or empty.
fieldValue - The field value to be set for the field name. Can be null.
Throws:
RuntimeOperationsException - for illegal value for field name or field value.

getFields

public String[] getFields()
Returns all of the fields contained in this descriptor as a string array.

Returns:
String array of fields in the format fieldName=fieldValue If the value of a field is not a String, then the toString() method will be called on it and the returned value used as the value for the field in the returned array. Object values which are not Strings will be enclosed in parens. If the descriptor is empty, you will get an empty array.
See Also:
setFields(java.lang.String[], java.lang.Object[])

getFieldNames

public String[] getFieldNames()
Returns all the fields names in the descriptor.

Returns:
String array of fields names. If the descriptor is empty, you will get an empty array.

getFieldValues

public Object[] getFieldValues(String[] fieldNames)
Returns all the field values in the descriptor as an array of Objects. The returned values are in the same order as the fieldNames String array parameter.

Parameters:
fieldNames - String array of the names of the fields that the values should be returned for. If the array is empty then an empty array will be returned. If the array is 'null' then all values will be returned. If a field name in the array does not exist, then null is returned for the matching array element being returned.
Returns:
Object array of field values. If the descriptor is empty, you will get an empty array.

removeField

public void removeField(String fieldName)
Removes a field from the descriptor.

Parameters:
fieldName - String name of the field to be removed. If the field is not found no exception is thrown.

setFields

public void setFields(String[] fieldNames,
                      Object[] fieldValues)
               throws RuntimeOperationsException
Sets all Fields in the list to the new value in with the same index in the fieldValue array. Array sizes must match. The field value will be validated before it is set. If it is not valid, then an exception will be thrown. If the arrays are empty, then no change will take effect.

Parameters:
fieldNames - String array of field names. The array and array elements cannot be null.
fieldValues - Object array of the corresponding field values. The array cannot be null. Elements of the array can be null.
Throws:
RuntimeOperationsException - for illegal value for field Names or field Values. Neither can be null. The array lengths must be equal. If the descriptor construction fails for any reason, this exception will be thrown.
See Also:
getFields()

clone

public Object clone()
             throws RuntimeOperationsException
Returns a new Descriptor which is a duplicate of the Descriptor.

Throws:
RuntimeOperationsException - for illegal value for field Names or field Values. If the descriptor construction fails for any reason, this exception will be thrown.

isValid

public boolean isValid()
                throws RuntimeOperationsException
Returns true if all of the fields have legal values given their names.

Returns:
true if the values are legal.
Throws:
RuntimeOperationsException - If the validity checking fails for any reason, this exception will be thrown.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DescriptorAccess

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface DescriptorAccess

All Known Implementing Classes:
ModelMBeanAttributeInfo, ModelMBeanConstructorInfo, ModelMBeanNotificationInfo, ModelMBeanOperationInfo
public interface DescriptorAccess

This interface is used to gain access to descriptors of the Descriptor class which are associated with a JMX component, i.e. MBean, MBeanInfo, MBeanAttributeInfo, MBeanNotificationInfo, MBeanOperationInfo, MBeanParameterInfo.

ModelMBeans make extensive use of this interface in ModelMBeanInfo classes.

Method Summary
Descriptor | getDescriptor() Returns a copy of Descriptor.
void | setDescriptor(Descriptor inDescriptor) Sets Descriptor (full replace).

Method Detail

getDescriptor

public Descriptor getDescriptor()
Returns a copy of Descriptor.

Returns:
Descriptor associated with the component implementing this interface. Null should never be returned. At a minimum a default descriptor with the descriptor name and descriptorType should be returned.
See Also:
setDescriptor(javax.management.Descriptor)

setDescriptor

public void setDescriptor(Descriptor inDescriptor)
Sets Descriptor (full replace).

Parameters:
inDescriptor - replaces the Descriptor associated with the component implementing this interface. If the inDescriptor is invalid for the type of Info object it is being set for, an exception is thrown. If the inDescriptor is null, then the Descriptor will revert to its default value which should contain, at a minimum, the descriptor name and descriptorType.
See Also:
getDescriptor()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DynamicMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface DynamicMBean

All Known Subinterfaces:
ModelMBean
All Known Implementing Classes:
RequiredModelMBean, StandardMBean
public interface DynamicMBean

Defines the methods that should be implemented by a Dynamic MBean (MBean that exposes a dynamic management interface).

Method Summary
Object | getAttribute(String attribute) Obtain the value of a specific attribute of the Dynamic MBean.
AttributeList | getAttributes(String[] attributes) Get the values of several attributes of the Dynamic MBean.
MBeanInfo | getMBeanInfo() Provides the exposed attributes and actions of the Dynamic MBean using an MBeanInfo object.
Object | invoke(String actionName, Object[] params, String[] signature) Allows an action to be invoked on the Dynamic MBean.
void | setAttribute(Attribute attribute) Set the value of a specific attribute of the Dynamic MBean.
AttributeList | setAttributes(AttributeList attributes) Sets the values of several attributes of the Dynamic MBean.

Method Detail

getAttribute

public Object getAttribute(String attribute)
                    throws AttributeNotFoundException,
                           MBeanException,
                           ReflectionException
Obtain the value of a specific attribute of the Dynamic MBean.

Parameters:
attribute - The name of the attribute to be retrieved
Returns:
The value of the attribute retrieved.
Throws:
AttributeNotFoundException
MBeanException - Wraps a java.lang.Exception thrown by the MBean's getter.
ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the getter.
See Also:
setAttribute(javax.management.Attribute)

setAttribute

public void setAttribute(Attribute attribute)
                  throws AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
Set the value of a specific attribute of the Dynamic MBean.

Parameters:
attribute - The identification of the attribute to be set and the value it is to be set to.
Throws:
AttributeNotFoundException
InvalidAttributeValueException
MBeanException - Wraps a java.lang.Exception thrown by the MBean's setter.
ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the MBean's setter.
See Also:
getAttribute(java.lang.String)

getAttributes

public AttributeList getAttributes(String[] attributes)
Get the values of several attributes of the Dynamic MBean.

Parameters:
attributes - A list of the attributes to be retrieved.
Returns:
The list of attributes retrieved.
See Also:
setAttributes(javax.management.AttributeList)

setAttributes

public AttributeList setAttributes(AttributeList attributes)
Sets the values of several attributes of the Dynamic MBean.

Parameters:
attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to.
Returns:
The list of attributes that were set, with their new values.
See Also:
getAttributes(java.lang.String[])

invoke

public Object invoke(String actionName,
                     Object[] params,
                     String[] signature)
              throws MBeanException,
                     ReflectionException
Allows an action to be invoked on the Dynamic MBean.

Parameters:
actionName - The name of the action to be invoked.
params - An array containing the parameters to be set when the action is invoked.
signature - An array containing the signature of the action. The class objects will be loaded through the same class loader as the one used for loading the MBean on which the action is invoked.
Returns:
The object returned by the action, which represents the result of invoking the action on the MBean specified.
Throws:
MBeanException - Wraps a java.lang.Exception thrown by the MBean's invoked method.
ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the method

getMBeanInfo

public MBeanInfo getMBeanInfo()
Provides the exposed attributes and actions of the Dynamic MBean using an MBeanInfo object.

Returns:
An instance of MBeanInfo allowing all attributes and actions exposed by this Dynamic MBean to be retrieved.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InstanceAlreadyExistsException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class InstanceAlreadyExistsException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.OperationsException
                    extended by javax.management.InstanceAlreadyExistsException
All Implemented Interfaces:
Serializable
public class InstanceAlreadyExistsException
extends OperationsException

The MBean is already registered in the repository.

See Also:
Serialized Form

Constructor Summary
InstanceAlreadyExistsException()
Default constructor.
InstanceAlreadyExistsException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InstanceAlreadyExistsException

public InstanceAlreadyExistsException()
Default constructor.

InstanceAlreadyExistsException

public InstanceAlreadyExistsException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InstanceNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class InstanceNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.OperationsException
                    extended by javax.management.InstanceNotFoundException
All Implemented Interfaces:
Serializable
public class InstanceNotFoundException
extends OperationsException

The specified MBean does not exist in the repository.

See Also:
Serialized Form

Constructor Summary
InstanceNotFoundException()
Default constructor.
InstanceNotFoundException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InstanceNotFoundException

public InstanceNotFoundException()
Default constructor.

InstanceNotFoundException

public InstanceNotFoundException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


IntrospectionException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class IntrospectionException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.OperationsException
                    extended by javax.management.IntrospectionException
All Implemented Interfaces:
Serializable
public class IntrospectionException
extends OperationsException

An exception occurred during the introspection of an MBean.

See Also:
Serialized Form

Constructor Summary
IntrospectionException()
Default constructor.
IntrospectionException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IntrospectionException

public IntrospectionException()
Default constructor.

IntrospectionException

public IntrospectionException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidApplicationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class InvalidApplicationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.InvalidApplicationException
All Implemented Interfaces:
Serializable
public class InvalidApplicationException
extends Exception

Thrown when an attempt is made to apply either of the following: A subquery expression to an MBean or a qualified attribute expression to an MBean of the wrong class. This exception is used internally by JMX during the evaluation of a query. User code does not usually see it.

See Also:
Serialized Form

Constructor Summary
InvalidApplicationException(Object val)
Constructs an InvalidApplicationException with the specified Object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidApplicationException

public InvalidApplicationException(Object val)
Constructs an InvalidApplicationException with the specified Object.

Parameters:
val - the detail message of this exception.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidAttributeValueException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class InvalidAttributeValueException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.OperationsException
                    extended by javax.management.InvalidAttributeValueException
All Implemented Interfaces:
Serializable
public class InvalidAttributeValueException
extends OperationsException

The value specified is not valid for the attribute.

See Also:
Serialized Form

Constructor Summary
InvalidAttributeValueException()
Default constructor.
InvalidAttributeValueException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidAttributeValueException

public InvalidAttributeValueException()
Default constructor.

InvalidAttributeValueException

public InvalidAttributeValueException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


j2ee

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management.j2ee

Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

See:
Description

Interface Summary
ListenerRegistration | ListenerRegistration defines the methods which clients of the MEJB use to add and remove event listeners.
Management | The Management interface provides the APIs to navigate and manipulate managed objects.
ManagementHome | The required home interface for the J2EE Management EJB component (MEJB).

Package javax.management.j2ee Description

Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

Package Specification

  • JSR 77, J2EE Management

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.management.j2ee Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management.j2ee

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
      • interface javax.management.j2ee.ManagementHome
    • interface javax.ejb.EJBObject
      • interface javax.management.j2ee.Management
  • interface java.io.Serializable
    • interface javax.management.j2ee.ListenerRegistration
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ListenerRegistration

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee
Interface ListenerRegistration

All Superinterfaces:
Serializable
public interface ListenerRegistration
extends Serializable

ListenerRegistration defines the methods which clients of the MEJB use to add and remove event listeners.

Author:
Hans Hrasna

Method Summary
void | addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) Add a listener to a registered managed object.
void | removeNotificationListener(ObjectName name, NotificationListener listener) Remove a listener from a registered managed object.

Method Detail

addNotificationListener

public void addNotificationListener(ObjectName name,
                                    NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
                             throws InstanceNotFoundException,
                                    RemoteException
Add a listener to a registered managed object.

Parameters:
name - The name of the managed object on which the listener should be added.
listener - The listener object which will handle the notifications emitted by the registered managed object.
filter - The filter object. If filter is null, no filtering will be performed before handling notifications.
handback - The context to be sent to the listener when a notification is emitted.
Throws:
InstanceNotFoundException - The managed object name provided does not match any of the registered managed objects.
RemoteException - A communication exception occurred during the execution of a remote method call

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       NotificationListener listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       RemoteException
Remove a listener from a registered managed object.

Parameters:
name - The name of the managed object on which the listener should be removed.
listener - The listener object which will handle the notifications emitted by the registered managed object. This method will remove all the information related to this listener.
Throws:
InstanceNotFoundException - The managed object name provided does not match any of the registered managed objects.
ListenerNotFoundException - The listener is not registered in the managed object.
RemoteException - A communication exception occurred during the execution of a remote method call
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Management

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee
Interface Management

All Superinterfaces:
EJBObject, Remote
public interface Management
extends EJBObject

The Management interface provides the APIs to navigate and manipulate managed objects. The J2EE Management EJB component (MEJB) must implement this as its remote interface.

Author:
Hans Hrasna

Method Summary
Object | getAttribute(ObjectName name, String attribute) Gets the value of a specific attribute of a named managed object.
AttributeList | getAttributes(ObjectName name, String[] attributes) Enables the values of several attributes of a named managed object.
String | getDefaultDomain() Returns the default domain name of this MEJB.
ListenerRegistration | getListenerRegistry() Returns the listener registry implementation for this MEJB.
Integer | getMBeanCount() Returns the number of managed objects registered in the MEJB.
MBeanInfo | getMBeanInfo(ObjectName name) This method discovers the attributes and operations that a managed object exposes for management.
Object | invoke(ObjectName name, String operationName, Object[] params, String[] signature) Invokes an operation on a managed object.
boolean | isRegistered(ObjectName name) Checks whether a managed object, identified by its object name, is already registered with the MEJB.
Set | queryNames(ObjectName name, QueryExp query) Gets the names of managed objects controlled by the MEJB.
void | setAttribute(ObjectName name, Attribute attribute) Sets the value of a specific attribute of a named managed object.
AttributeList | setAttributes(ObjectName name, AttributeList attributes) Sets the values of several attributes of a named managed object.
Methods inherited from interface javax.ejb.EJBObject
getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

Method Detail

queryNames

public Set queryNames(ObjectName name,
                      QueryExp query)
               throws RemoteException
Gets the names of managed objects controlled by the MEJB. This method enables any of the following to be obtained: The names of all managed objects, the names of a set of managed objects specified by pattern matching on the ObjectName, a specific managed object name (equivalent to testing whether a managed object is registered). When the object name is null or no domain and key properties are specified, all objects are selected. It returns the set of J2EEObjectNames for the managed objects selected.

Parameters:
name - The object name pattern identifying the managed objects to be retrieved. If null or no domain and key properties are specified, all the managed objects registered will be retrieved.
Returns:
A set containing the ObjectNames for the managed objects selected. If no managed object satisfies the query, an empty set is returned.
Throws:
RemoteException - A communication exception occurred during the execution of a remote method call

isRegistered

public boolean isRegistered(ObjectName name)
                     throws RemoteException
Checks whether a managed object, identified by its object name, is already registered with the MEJB.

Parameters:
name - The object name of the managed object to be checked.
Returns:
True if the managed object is already registered in the MEJB, false otherwise.
Throws:
RemoteException - A communication exception occurred during the execution of a remote method call

getMBeanCount

public Integer getMBeanCount()
                      throws RemoteException
Returns the number of managed objects registered in the MEJB.

Throws:
RemoteException - A communication exception occurred during the execution of a remote method call

getMBeanInfo

public MBeanInfo getMBeanInfo(ObjectName name)
                       throws IntrospectionException,
                              InstanceNotFoundException,
                              ReflectionException,
                              RemoteException
This method discovers the attributes and operations that a managed object exposes for management.

Parameters:
name - The name of the managed object to analyze
Returns:
An instance of MBeanInfo allowing the retrieval of all attributes and operations of this managed object.
Throws:
IntrospectionException - An exception occurs during introspection.
InstanceNotFoundException - The managed object specified is not found.
ReflectionException - An exception occurred when trying to perform reflection on a managed object
RemoteException - A communication exception occurred during the execution of a remote method call

getAttribute

public Object getAttribute(ObjectName name,
                           String attribute)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException,
                           RemoteException
Gets the value of a specific attribute of a named managed object. The managed object is identified by its object name.

Parameters:
name - The object name of the managed object from which the attribute is to be retrieved.
attribute - A String specifying the name of the attribute to be retrieved.
Returns:
The value of the retrieved attribute.
Throws:
AttributeNotFoundException - The attribute specified is not accessible in the managed object.
MBeanException - Wraps an exception thrown by the managed object's getter.
InstanceNotFoundException - The managed object specified is not registered in the MEJB.
ReflectionException - An exception occurred when trying to invoke the getAttribute method of a Dynamic MBean
RemoteException - A communication exception occurred during the execution of a remote method call

getAttributes

public AttributeList getAttributes(ObjectName name,
                                   String[] attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   RemoteException
Enables the values of several attributes of a named managed object. The managed object is identified by its object name.

Parameters:
name - The object name of the managed object from which the attributes are retrieved.
attributes - A list of the attributes to be retrieved.
Returns:
The list of the retrieved attributes.
Throws:
InstanceNotFoundException - The managed object specified is not registered in the MEJB.
ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
RemoteException - A communication exception occurred during the execution of a remote method call

setAttribute

public void setAttribute(ObjectName name,
                         Attribute attribute)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException,
                         RemoteException
Sets the value of a specific attribute of a named managed object. The managed object is identified by its object name.

Parameters:
name - The name of the managed object within which the attribute is to be set.
attribute - The identification of the attribute to be set and the value it is to be set to.
Throws:
InstanceNotFoundException - The managed object specified is not registered in the MEJB.
AttributeNotFoundException - The attribute specified is not accessible in the managed object.
InvalidAttributeValueException - The value specified for the attribute is not valid.
MBeanException - Wraps an exception thrown by the managed object's setter.
ReflectionException - An exception occurred when trying to invoke the setAttribute method of a Dynamic MBean.
RemoteException - A communication exception occurred during the execution of a remote method call

setAttributes

public AttributeList setAttributes(ObjectName name,
                                   AttributeList attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   RemoteException
Sets the values of several attributes of a named managed object. The managed object is identified by its object name.

Parameters:
name - The object name of the managed object within which the attributes are to be set.
attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to.
Returns:
The list of attributes that were set, with their new values.
Throws:
InstanceNotFoundException - The managed object specified is not registered in the MEJB.
ReflectionException - An exception occurred when trying to invoke the setAttributes method of a Dynamic MBean.
RemoteException - A communication exception occurred during the execution of a remote method call

invoke

public Object invoke(ObjectName name,
                     String operationName,
                     Object[] params,
                     String[] signature)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException,
                     RemoteException
Invokes an operation on a managed object.

Parameters:
name - The object name of the managed object on which the method is to be invoked.
operationName - The name of the operation to be invoked.
params - An array containing the parameters to be set when the operation is invoked
signature - An array containing the signature of the operation. The class objects will be loaded using the same class loader as the one used for loading the managed object on which the operation was invoked.
Returns:
The object returned by the operation, which represents the result of invoking the operation on the managed object specified.
Throws:
InstanceNotFoundException - The managed object specified is not registered in the MEJB.
MBeanException - Wraps an exception thrown by the managed object's invoked method.
ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the method.
RemoteException - A communication exception occurred during the execution of a remote method call

getDefaultDomain

public String getDefaultDomain()
                        throws RemoteException
Returns the default domain name of this MEJB.

Throws:
RemoteException - A communication exception occurred during the execution of a remote method call

getListenerRegistry

public ListenerRegistration getListenerRegistry()
                                         throws RemoteException
Returns the listener registry implementation for this MEJB. The listener registry implements the methods that enable clints to add and remove event notification listeners managed objects

Returns:
An implementation of javax.management.j2ee.ListenerRegistration
Throws:
RemoteException - A communication exception occurred during the execution of a remote method call
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ManagementHome

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee
Interface ManagementHome

All Superinterfaces:
EJBHome, Remote
public interface ManagementHome
extends EJBHome

The required home interface for the J2EE Management EJB component (MEJB). A J2EE client must be able to create a compliant session object using the specified create() method.

Author:
Hans Hrasna

Method Summary
 Management create()
Creates an MEJB session object which provides access to the J2EE Management Model
Methods inherited from interface javax.ejb.EJBHome
getEJBMetaData, getHomeHandle, remove, remove

Method Detail

create

public Management create()
                  throws CreateException,
                         RemoteException
Creates an MEJB session object which provides access to the J2EE Management Model

Returns:
An MEJB session object which implements javax.management.j2ee.Management
Throws:
CreateExceotion - Indicates a failure to create the EJB object
RemoteException - A communication exception occurred during the execution of a remote method call
CreateException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


statistics

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management.j2ee.statistics

Provides the standard interfaces for accessing performance data from J2EE managed objects Package Specification JSR 77, J2EE Management Related Documentation For overviews, tutorials, examples, guides, and tool documentation, please see: J2EE Tools


BoundedRangeStatistic

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface BoundedRangeStatistic

All Superinterfaces:
BoundaryStatistic, RangeStatistic, Statistic
public interface BoundedRangeStatistic
extends BoundaryStatistic, RangeStatistic

The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.

Methods inherited from interface javax.management.j2ee.statistics.BoundaryStatistic
getLowerBound, getUpperBound
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit
Methods inherited from interface javax.management.j2ee.statistics.RangeStatistic
getCurrent, getHighWaterMark, getLowWaterMark

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.management.j2ee.statistics Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management.j2ee.statistics

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface javax.management.j2ee.statistics.JavaMailStats
  • interface javax.management.j2ee.statistics.Statistic
    • interface javax.management.j2ee.statistics.BoundaryStatistic
      • interface javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.RangeStatistic)
    • interface javax.management.j2ee.statistics.CountStatistic
    • interface javax.management.j2ee.statistics.RangeStatistic
      • interface javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.BoundaryStatistic)
    • interface javax.management.j2ee.statistics.TimeStatistic
  • interface javax.management.j2ee.statistics.Stats
    • interface javax.management.j2ee.statistics.EJBStats
      • interface javax.management.j2ee.statistics.EntityBeanStats
      • interface javax.management.j2ee.statistics.MessageDrivenBeanStats
      • interface javax.management.j2ee.statistics.SessionBeanStats
        • interface javax.management.j2ee.statistics.StatefulSessionBeanStats
        • interface javax.management.j2ee.statistics.StatelessSessionBeanStats
    • interface javax.management.j2ee.statistics.JCAConnectionStats
      • interface javax.management.j2ee.statistics.JCAConnectionPoolStats
    • interface javax.management.j2ee.statistics.JCAStats
    • interface javax.management.j2ee.statistics.JDBCConnectionStats
      • interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
    • interface javax.management.j2ee.statistics.JDBCStats
    • interface javax.management.j2ee.statistics.JMSConnectionStats
    • interface javax.management.j2ee.statistics.JMSEndpointStats
      • interface javax.management.j2ee.statistics.JMSConsumerStats
      • interface javax.management.j2ee.statistics.JMSProducerStats
    • interface javax.management.j2ee.statistics.JMSSessionStats
    • interface javax.management.j2ee.statistics.JMSStats
    • interface javax.management.j2ee.statistics.JTAStats
    • interface javax.management.j2ee.statistics.JVMStats
    • interface javax.management.j2ee.statistics.ServletStats
    • interface javax.management.j2ee.statistics.URLStats
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StatelessSessionBeanStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface StatelessSessionBeanStats

All Superinterfaces:
EJBStats, SessionBeanStats, Stats
public interface StatelessSessionBeanStats
extends SessionBeanStats

Specifies the statistics provided by a stateless session bean.

Methods inherited from interface javax.management.j2ee.statistics.SessionBeanStats
getMethodReadyCount
Methods inherited from interface javax.management.j2ee.statistics.EJBStats
getCreateCount, getRemoveCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


URLStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface URLStats

All Superinterfaces:
Stats
public interface URLStats
extends Stats

Specifies the statistics provided by a URL resource.

Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BoundaryStatistic

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface BoundaryStatistic

All Superinterfaces:
Statistic
All Known Subinterfaces:
BoundedRangeStatistic
public interface BoundaryStatistic
extends Statistic

Specifies standard measurements of the upper and lower limits of the value of an attribute.

Method Summary
long | getLowerBound() The lower limit of the value of this attribute.The upper limit of the value of this attribute.
long | getUpperBound() The upper limit of the value of this attribute.
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit

Method Detail

getUpperBound

public long getUpperBound()
The upper limit of the value of this attribute.

getLowerBound

public long getLowerBound()
The lower limit of the value of this attribute.The upper limit of the value of this attribute.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CountStatistic

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface CountStatistic

All Superinterfaces:
Statistic
public interface CountStatistic
extends Statistic

Specifies standard count measurements.

Method Summary
 long getCount()
The count since the last reset.
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit

Method Detail

getCount

public long getCount()
The count since the last reset.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EJBStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface EJBStats

All Superinterfaces:
Stats
All Known Subinterfaces:
EntityBeanStats, MessageDrivenBeanStats, SessionBeanStats, StatefulSessionBeanStats, StatelessSessionBeanStats
public interface EJBStats
extends Stats

Specifies statistics provided by all EJB component types.

Method Summary
CountStatistic | getCreateCount() Number of times create was called.
CountStatistic | getRemoveCount() Number of times remove was called.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getCreateCount

public CountStatistic getCreateCount()
Number of times create was called.

getRemoveCount

public CountStatistic getRemoveCount()
Number of times remove was called.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EntityBeanStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface EntityBeanStats

All Superinterfaces:
EJBStats, Stats
public interface EntityBeanStats
extends EJBStats

Specifies statistics provided by entity beans.

Method Summary
RangeStatistic | getPooledCount() Number of beans in the pooled state.
RangeStatistic | getReadyCount() Number of beans in the ready state.
Methods inherited from interface javax.management.j2ee.statistics.EJBStats
getCreateCount, getRemoveCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getReadyCount

public RangeStatistic getReadyCount()
Number of beans in the ready state.

getPooledCount

public RangeStatistic getPooledCount()
Number of beans in the pooled state.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JavaMailStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JavaMailStats

public interface JavaMailStats

Specifies the statistics provided by a JavaMail resource.

Method Summary
 CountStatistic getSentMailCount()
The number of mail messages sent.

Method Detail

getSentMailCount

public CountStatistic getSentMailCount()
The number of mail messages sent.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JCAConnectionPoolStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JCAConnectionPoolStats

All Superinterfaces:
JCAConnectionStats, Stats
public interface JCAConnectionPoolStats
extends JCAConnectionStats

Specifies the statistics provided by a JCA Connection Pool

Method Summary
CountStatistic | getCloseCount() The number of connections closed
CountStatistic | getCreateCount() The number of connections created
BoundedRangeStatistic | getFreePoolSize() The number of free connections in the pool
BoundedRangeStatistic | getPoolSize() The size of the connection pool
RangeStatistic | getWaitingThreadCount() The number of threads waiting for a connection
Methods inherited from interface javax.management.j2ee.statistics.JCAConnectionStats
getConnectionFactory, getManagedConnectionFactory, getUseTime, getWaitTime
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getCloseCount

public CountStatistic getCloseCount()
The number of connections closed

Returns:
CountStatistic

getCreateCount

public CountStatistic getCreateCount()
The number of connections created

Returns:
CountStatistic

getFreePoolSize

public BoundedRangeStatistic getFreePoolSize()
The number of free connections in the pool

Returns:
BoundedRangeStatistic

getPoolSize

public BoundedRangeStatistic getPoolSize()
The size of the connection pool

Returns:
BoundedRangeStatistic

getWaitingThreadCount

public RangeStatistic getWaitingThreadCount()
The number of threads waiting for a connection

Returns:
BoundedRangeStatistic
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JCAConnectionStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JCAConnectionStats

All Superinterfaces:
Stats
All Known Subinterfaces:
JCAConnectionPoolStats
public interface JCAConnectionStats
extends Stats

Specifies the statistics provided by a JCA connection

Method Summary
String | getConnectionFactory() Returns the associated JCAConnectionFactory OBJECT_NAME
String | getManagedConnectionFactory() Returns the associated JCAManagedConnectionFactory OBJECT_NAME
TimeStatistic | getUseTime() Returns the time spent using a connection
TimeStatistic | getWaitTime() Returns the time spent waiting for a connection to be available
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getConnectionFactory

public String getConnectionFactory()
Returns the associated JCAConnectionFactory OBJECT_NAME

Returns:
String the OBJECT_NAME of the managed object that identifies the connection factory for this connection

getManagedConnectionFactory

public String getManagedConnectionFactory()
Returns the associated JCAManagedConnectionFactory OBJECT_NAME

Returns:
String the OBJECT_NAME of the managed object that identifies the managed connection factory for this connection

getWaitTime

public TimeStatistic getWaitTime()
Returns the time spent waiting for a connection to be available

Returns:
TimeStatistic

getUseTime

public TimeStatistic getUseTime()
Returns the time spent using a connection

Returns:
TimeStatistic
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JCAStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JCAStats

All Superinterfaces:
Stats
public interface JCAStats
extends Stats

Specifies statistics provided by a JCA resource

Method Summary
JCAConnectionPoolStats[] | getConnectionPools() Returns an array of JCAConnectionPool Stats that provide statistics about the connection pools associated with the referencing JCA resource statistics
JCAConnectionStats[] | getConnections() Returns an array of JCAConnectionStats that provide statistics about the non-pooled connections associated with the referencing JCA resource statistics
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getConnections

public JCAConnectionStats[] getConnections()
Returns an array of JCAConnectionStats that provide statistics about the non-pooled connections associated with the referencing JCA resource statistics

Returns:
JCAConnectionStats []

getConnectionPools

public JCAConnectionPoolStats[] getConnectionPools()
Returns an array of JCAConnectionPool Stats that provide statistics about the connection pools associated with the referencing JCA resource statistics

Returns:
JCAConnectionPoolStats []
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JDBCConnectionPoolStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JDBCConnectionPoolStats

All Superinterfaces:
JDBCConnectionStats, Stats
public interface JDBCConnectionPoolStats
extends JDBCConnectionStats

Specifies the statistics provided by a JDBC connection pool.

Method Summary
CountStatistic | getCloseCount() Number of connections closed.
CountStatistic | getCreateCount() Number of connections created.
BoundedRangeStatistic | getFreePoolSize() Number of free connections in the pool.
BoundedRangeStatistic | getPoolSize() Size of the connection pool.
RangeStatistic | getWaitingThreadCount() Number of threads waiting for a connection.
Methods inherited from interface javax.management.j2ee.statistics.JDBCConnectionStats
getJdbcDataSource, getUseTime, getWaitTime
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getCreateCount

public CountStatistic getCreateCount()
Number of connections created.

getCloseCount

public CountStatistic getCloseCount()
Number of connections closed.

getPoolSize

public BoundedRangeStatistic getPoolSize()
Size of the connection pool.

getFreePoolSize

public BoundedRangeStatistic getFreePoolSize()
Number of free connections in the pool.

getWaitingThreadCount

public RangeStatistic getWaitingThreadCount()
Number of threads waiting for a connection.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JDBCConnectionStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JDBCConnectionStats

All Superinterfaces:
Stats
All Known Subinterfaces:
JDBCConnectionPoolStats
public interface JDBCConnectionStats
extends Stats

Specifies the statistics provided by all (pooled and non-pooled) JDBC connections.

Method Summary
String | getJdbcDataSource() Identifies the JDBC driver for the corresponding JDBCConnection.
TimeStatistic | getUseTime() Time spent using a connection.
TimeStatistic | getWaitTime() Time spent waiting for a connection to be available.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getJdbcDataSource

public String getJdbcDataSource()
Identifies the JDBC driver for the corresponding JDBCConnection.

getWaitTime

public TimeStatistic getWaitTime()
Time spent waiting for a connection to be available.

getUseTime

public TimeStatistic getUseTime()
Time spent using a connection.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JDBCStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JDBCStats

All Superinterfaces:
Stats
public interface JDBCStats
extends Stats

Statistics provided by a JDBC resource

Author:
Hans Hrasna

Method Summary
JDBCConnectionPoolStats[] | getConnectionPools()
JDBCConnectionStats[] | getConnections()
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getConnections

public JDBCConnectionStats[] getConnections()

getConnectionPools

public JDBCConnectionPoolStats[] getConnectionPools()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JMSConnectionStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSConnectionStats

All Superinterfaces:
Stats
public interface JMSConnectionStats
extends Stats

Specifies the statistics provided by a JMS connection

Author:
Hans Hrasna

Method Summary
JMSSessionStats[] | getSessions() Returns an array of JMSSessionStats that provide statistics about the sessions associated with the referencing JMSConnectionStats.
boolean | isTransactional() Returns the transactional state of this JMS connection.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getSessions

public JMSSessionStats[] getSessions()
Returns an array of JMSSessionStats that provide statistics about the sessions associated with the referencing JMSConnectionStats.

isTransactional

public boolean isTransactional()
Returns the transactional state of this JMS connection. If true, indicates that this JMS connection is transactional.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JMSConsumerStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSConsumerStats

All Superinterfaces:
JMSEndpointStats, Stats
public interface JMSConsumerStats
extends JMSEndpointStats

Specifies the statistics provided by a JMS message consumer

Author:
Hans Hrasna

Method Summary
 String getOrigin()
Returns a string that encapsulates the identity of a message origin
Methods inherited from interface javax.management.j2ee.statistics.JMSEndpointStats
getExpiredMessageCount, getMessageCount, getMessageWaitTime, getPendingMessageCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getOrigin

public String getOrigin()
Returns a string that encapsulates the identity of a message origin

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JMSEndpointStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSEndpointStats

All Superinterfaces:
Stats
All Known Subinterfaces:
JMSConsumerStats, JMSProducerStats
public interface JMSEndpointStats
extends Stats

Specifies the statistics provided by a JMS message producer or a JMS message consumer.

Method Summary
CountStatistic | getExpiredMessageCount() Number of messages that expired before delivery.
CountStatistic | getMessageCount() Number of messages sent or received.
TimeStatistic | getMessageWaitTime() Time spent by a message before being delivered.
CountStatistic | getPendingMessageCount() Number of pending messages.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getMessageCount

public CountStatistic getMessageCount()
Number of messages sent or received.

getPendingMessageCount

public CountStatistic getPendingMessageCount()
Number of pending messages.

getExpiredMessageCount

public CountStatistic getExpiredMessageCount()
Number of messages that expired before delivery.

getMessageWaitTime

public TimeStatistic getMessageWaitTime()
Time spent by a message before being delivered.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JMSProducerStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSProducerStats

All Superinterfaces:
JMSEndpointStats, Stats
public interface JMSProducerStats
extends JMSEndpointStats

Specifies the statistics provided by a JMS message producer

Author:
Hans Hrasna

Method Summary
 String getDestination()
Returns a string that encapsulates the identity of the message destination
Methods inherited from interface javax.management.j2ee.statistics.JMSEndpointStats
getExpiredMessageCount, getMessageCount, getMessageWaitTime, getPendingMessageCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getDestination

public String getDestination()
Returns a string that encapsulates the identity of the message destination

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JMSSessionStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSSessionStats

All Superinterfaces:
Stats
public interface JMSSessionStats
extends Stats

Specifies the statistics provided by a JMS session.

Author:
Hans Hrasna

Method Summary
JMSConsumerStats[] | getConsumers() Returns an array of JMSConsumerStats that provide statistics about the message consumers associated with the referencing JMS session statistics.
CountStatistic | getDurableSubscriptionCount() Number of durable subscriptions.
CountStatistic | getExpiredMessageCount() Number of expired messages.
CountStatistic | getMessageCount() Number of messages exchanged.
TimeStatistic | getMessageWaitTime() Time spent by a message before being delivered.
CountStatistic | getPendingMessageCount() Number of pending messages.
JMSProducerStats[] | getProducers() Returns an array of JMSProducerStats that provide statistics about the message producers associated with the referencing JMS session statistics.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getProducers

public JMSProducerStats[] getProducers()
Returns an array of JMSProducerStats that provide statistics about the message producers associated with the referencing JMS session statistics.

getConsumers

public JMSConsumerStats[] getConsumers()
Returns an array of JMSConsumerStats that provide statistics about the message consumers associated with the referencing JMS session statistics.

getMessageCount

public CountStatistic getMessageCount()
Number of messages exchanged.

getPendingMessageCount

public CountStatistic getPendingMessageCount()
Number of pending messages.

getExpiredMessageCount

public CountStatistic getExpiredMessageCount()
Number of expired messages.

getMessageWaitTime

public TimeStatistic getMessageWaitTime()
Time spent by a message before being delivered.

getDurableSubscriptionCount

public CountStatistic getDurableSubscriptionCount()
Number of durable subscriptions.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JMSStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSStats

All Superinterfaces:
Stats
public interface JMSStats
extends Stats

Specifies the statistics provided by a JMS Resource

Author:
Hans Hrasna

Method Summary
 JMSConnectionStats[] getConnections()
Returns an array of JMSConnectionStats that provide statistics about the connections associated with the referencing JMS resource.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getConnections

public JMSConnectionStats[] getConnections()
Returns an array of JMSConnectionStats that provide statistics about the connections associated with the referencing JMS resource.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JTAStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JTAStats

All Superinterfaces:
Stats
public interface JTAStats
extends Stats

Specifies the statistics provided by a JTA resource.

Method Summary
CountStatistic | getActiveCount() Number of active transactions.
CountStatistic | getCommittedCount() Number of committed transactions.
CountStatistic | getRolledbackCount() Number of rolled-back transactions.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getActiveCount

public CountStatistic getActiveCount()
Number of active transactions.

getCommittedCount

public CountStatistic getCommittedCount()
Number of committed transactions.

getRolledbackCount

public CountStatistic getRolledbackCount()
Number of rolled-back transactions.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JVMStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JVMStats

All Superinterfaces:
Stats
public interface JVMStats
extends Stats

Specifies the statistics provided by a Java VM.

Method Summary
BoundedRangeStatistic | getHeapSize() Size of the JVM's heap.
CountStatistic | getUpTime() Amount of time the JVM has been running.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getUpTime

public CountStatistic getUpTime()
Amount of time the JVM has been running.

getHeapSize

public BoundedRangeStatistic getHeapSize()
Size of the JVM's heap.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageDrivenBeanStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface MessageDrivenBeanStats

All Superinterfaces:
EJBStats, Stats
public interface MessageDrivenBeanStats
extends EJBStats

Specifies the statistics provided by a message driven bean.

Method Summary
 CountStatistic getMessageCount()
Number of messages received.
Methods inherited from interface javax.management.j2ee.statistics.EJBStats
getCreateCount, getRemoveCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getMessageCount

public CountStatistic getMessageCount()
Number of messages received.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RangeStatistic

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface RangeStatistic

All Superinterfaces:
Statistic
All Known Subinterfaces:
BoundedRangeStatistic
public interface RangeStatistic
extends Statistic

Specifies standard measurements of the lowest and highest values an attribute has held as well as its current value.

Method Summary
long | getCurrent() The current value of this attribute.
long | getHighWaterMark() The highest value this attribute has held since the beginning of the measurement.
long | getLowWaterMark() The lowest value this attribute has held since the beginning of the measurement.
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit

Method Detail

getHighWaterMark

public long getHighWaterMark()
The highest value this attribute has held since the beginning of the measurement.

getLowWaterMark

public long getLowWaterMark()
The lowest value this attribute has held since the beginning of the measurement.

getCurrent

public long getCurrent()
The current value of this attribute.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface ServletStats

All Superinterfaces:
Stats
public interface ServletStats
extends Stats

Specifies the statistics provided by a Servlet.

Method Summary
 TimeStatistic getServiceTime()
Execution times for the methods.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getServiceTime

public TimeStatistic getServiceTime()
Execution times for the methods.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SessionBeanStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface SessionBeanStats

All Superinterfaces:
EJBStats, Stats
All Known Subinterfaces:
StatefulSessionBeanStats, StatelessSessionBeanStats
public interface SessionBeanStats
extends EJBStats

Specifies the statistics provided by session beans of both stateful and stateless types.

Method Summary
 RangeStatistic getMethodReadyCount()
Number of beans in the method-ready state.
Methods inherited from interface javax.management.j2ee.statistics.EJBStats
getCreateCount, getRemoveCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getMethodReadyCount

public RangeStatistic getMethodReadyCount()
Number of beans in the method-ready state.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StatefulSessionBeanStats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface StatefulSessionBeanStats

All Superinterfaces:
EJBStats, SessionBeanStats, Stats
public interface StatefulSessionBeanStats
extends SessionBeanStats

Specifies the statistics provided by a stateful session bean.

Method Summary
 RangeStatistic getPassiveCount()
Number of beans that are in the passive state.
Methods inherited from interface javax.management.j2ee.statistics.SessionBeanStats
getMethodReadyCount
Methods inherited from interface javax.management.j2ee.statistics.EJBStats
getCreateCount, getRemoveCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getPassiveCount

public RangeStatistic getPassiveCount()
Number of beans that are in the passive state.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Statistic

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface Statistic

All Known Subinterfaces:
BoundaryStatistic, BoundedRangeStatistic, CountStatistic, RangeStatistic, TimeStatistic
public interface Statistic

The Statistic model and its sub-models specify the data models which are requried to be used to provide the performance data described by the specific attributes in the Stats models.

Method Summary
String | getDescription() A human-readable description of the Statistic.
long | getLastSampleTime() The time of the last measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
String | getName() The name of this Statistic.
long | getStartTime() The time of the first measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
String | getUnit() The unit of measurement for this Statistic.

Method Detail

getName

public String getName()
The name of this Statistic.

getUnit

public String getUnit()
The unit of measurement for this Statistic. Valid values for TimeStatistic measurements are "HOUR", "MINUTE", "SECOND", "MILLISECOND", "MICROSECOND" and "NANOSECOND".

getDescription

public String getDescription()
A human-readable description of the Statistic.

getStartTime

public long getStartTime()
The time of the first measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.

getLastSampleTime

public long getLastSampleTime()
The time of the last measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Stats

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface Stats

All Known Subinterfaces:
EJBStats, EntityBeanStats, JCAConnectionPoolStats, JCAConnectionStats, JCAStats, JDBCConnectionPoolStats, JDBCConnectionStats, JDBCStats, JMSConnectionStats, JMSConsumerStats, JMSEndpointStats, JMSProducerStats, JMSSessionStats, JMSStats, JTAStats, JVMStats, MessageDrivenBeanStats, ServletStats, SessionBeanStats, StatefulSessionBeanStats, StatelessSessionBeanStats, URLStats
public interface Stats

The Stats model and its submodels specify performance data attributes for each of the specific managed object types.

Method Summary
Statistic | getStatistic(String statisticName) Get a Statistic by name.
String[] | getStatisticNames() Returns an array of Strings which are the names of the attributes from the specific Stats submodel that this object supports.
Statistic[] | getStatistics() Returns an array containing all of the Statistic objects supported by this Stats object.

Method Detail

getStatistic

public Statistic getStatistic(String statisticName)
Get a Statistic by name.

getStatisticNames

public String[] getStatisticNames()
Returns an array of Strings which are the names of the attributes from the specific Stats submodel that this object supports. Attributes named in the list must correspond to attributes that will return a Statistic object of the appropriate type which contains valid performance data. The return value of attributes in the Stats submodel that are not included in the statisticNames list must be null. For each name in the statisticNames list there must be one Statistic with the same name in the statistics list.

getStatistics

public Statistic[] getStatistics()
Returns an array containing all of the Statistic objects supported by this Stats object.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TimeStatistic

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface TimeStatistic

All Superinterfaces:
Statistic
public interface TimeStatistic
extends Statistic

Specifies standard timing measurements.

Method Summary
long | getCount() Number of times the operation was invoked since the beginning of this measurement.
long | getMaxTime() The maximum amount of time taken to complete one invocation of this operation since the beginning of this measurement.
long | getMinTime() The minimum amount of time taken to complete one invocation of this operation since the beginning of this measurement.
long | getTotalTime() This is the sum total of time taken to complete every invocation of this operation since the beginning of this measurement.
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit

Method Detail

getCount

public long getCount()
Number of times the operation was invoked since the beginning of this measurement.

getMaxTime

public long getMaxTime()
The maximum amount of time taken to complete one invocation of this operation since the beginning of this measurement.

getMinTime

public long getMinTime()
The minimum amount of time taken to complete one invocation of this operation since the beginning of this measurement.

getTotalTime

public long getTotalTime()
This is the sum total of time taken to complete every invocation of this operation since the beginning of this measurement. Dividing totalTime by count will give you the average execution time for this operation.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JMException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class JMException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MBeanException, OpenDataException, OperationsException, ReflectionException, RelationException
public class JMException
extends Exception

Exceptions thrown by JMX implementations. It does not include the runtime exceptions.

See Also:
Serialized Form

Constructor Summary
JMException()
Default constructor.
JMException(String msg)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JMException

public JMException()
Default constructor.

JMException

public JMException(String msg)
Constructor that allows a specific error message to be specified.

Parameters:
msg - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JMRuntimeException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class JMRuntimeException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.management.JMRuntimeException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MonitorSettingException, RuntimeErrorException, RuntimeMBeanException, RuntimeOperationsException
public class JMRuntimeException
extends RuntimeException

Runtime exceptions emitted by JMX implementations.

See Also:
Serialized Form

Constructor Summary
JMRuntimeException()
Default constructor.
JMRuntimeException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JMRuntimeException

public JMRuntimeException()
Default constructor.

JMRuntimeException

public JMRuntimeException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ListenerNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class ListenerNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.OperationsException
                    extended by javax.management.ListenerNotFoundException
All Implemented Interfaces:
Serializable
public class ListenerNotFoundException
extends OperationsException

The specified MBean listener does not exist in the repository.

See Also:
Serialized Form

Constructor Summary
ListenerNotFoundException()
Default constructor.
ListenerNotFoundException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ListenerNotFoundException

public ListenerNotFoundException()
Default constructor.

ListenerNotFoundException

public ListenerNotFoundException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


loading

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management.loading

Provides the classes which implement advanced dynamic loading.

See:
Description

Interface Summary
ClassLoaderRepository | Instances of this interface are used to keep the list of ClassLoaders registered in an MBean Server.
MLetMBean | Exposes the remote management interface of the MLet MBean.
PrivateClassLoader | Marker interface indicating that a ClassLoader should not be added to the ClassLoaderRepository.

Class Summary
DefaultLoaderRepository | Deprecated. Use MBeanServer.getClassLoaderRepository()} instead.
MLet | Allows you to instantiate and register one or several MBeans in the MBean server coming from a remote URL.
PrivateMLet | An MLet that is not added to the ClassLoaderRepository.

Package javax.management.loading Description

Provides the classes which implement advanced dynamic loading.

Since:
JMX 1.0
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.management.loading Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management.loading

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.ClassLoader
      • class java.security.SecureClassLoader
        • class java.net.URLClassLoader
          • class javax.management.loading.MLet (implements java.io.Externalizable, javax.management.MBeanRegistration, javax.management.loading.MLetMBean)
            • class javax.management.loading.PrivateMLet (implements javax.management.loading.PrivateClassLoader)
    • class javax.management.loading.DefaultLoaderRepository

Interface Hierarchy

  • interface javax.management.loading.ClassLoaderRepository
  • interface javax.management.loading.MLetMBean
  • interface javax.management.loading.PrivateClassLoader
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PrivateClassLoader

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.loading
Interface PrivateClassLoader

All Known Implementing Classes:
PrivateMLet
public interface PrivateClassLoader

Marker interface indicating that a ClassLoader should not be added to the ClassLoaderRepository. When a ClassLoader is registered as an MBean in the MBean server, it is added to the MBean server's ClassLoaderRepository unless it implements this interface.

Since:
JMX 1.2

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ClassLoaderRepository

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.loading
Interface ClassLoaderRepository

public interface ClassLoaderRepository

Instances of this interface are used to keep the list of ClassLoaders registered in an MBean Server. They provide the necessary methods to load classes using the registered ClassLoaders.

The first ClassLoader in a ClassLoaderRepository is always the MBean Server's own ClassLoader.

When an MBean is registered in an MBean Server, if it is of a subclass of ClassLoader and if it does not implement the interface PrivateClassLoader, it is added to the end of the MBean Server's ClassLoaderRepository. If it is subsequently unregistered from the MBean Server, it is removed from the ClassLoaderRepository.

The order of MBeans in the ClassLoaderRepository is significant. For any two MBeans X and Y in the ClassLoaderRepository, X must appear before Y if the registration of X was completed before the registration of Y started. If X and Y were registered concurrently, their order is indeterminate. The registration of an MBean corresponds to the call to MBeanServer.registerMBean(java.lang.Object, javax.management.ObjectName) or one of the MBeanServer .createMBean methods.

Since:
JMX 1.1
See Also:
MBeanServerFactory

Method Summary
Class | loadClass(String className) Load the given class name through the list of class loaders.
Class | loadClassBefore(ClassLoader stop, String className) Load the given class name through the list of class loaders, stopping at the given one.
Class | loadClassWithout(ClassLoader exclude, String className) Load the given class name through the list of class loaders, excluding the given one.

Method Detail

loadClass

public Class loadClass(String className)
                throws ClassNotFoundException

Load the given class name through the list of class loaders. Each ClassLoader in turn from the ClassLoaderRepository is asked to load the class via its ClassLoader.loadClass(String) method. If it successfully returns a Class object, that is the result of this method. If it throws a ClassNotFoundException, the search continues with the next ClassLoader. If it throws another exception, the exception is propagated from this method. If the end of the list is reached, a ClassNotFoundException is thrown.

Parameters:
className - The name of the class to be loaded.
Returns:
the loaded class.
Throws:
ClassNotFoundException - The specified class could not be found.

loadClassWithout

public Class loadClassWithout(ClassLoader exclude,
                              String className)
                       throws ClassNotFoundException

Load the given class name through the list of class loaders, excluding the given one. Each ClassLoader in turn from the ClassLoaderRepository, except exclude, is asked to load the class via its ClassLoader.loadClass(String) method. If it successfully returns a Class object, that is the result of this method. If it throws a ClassNotFoundException, the search continues with the next ClassLoader. If it throws another exception, the exception is propagated from this method. If the end of the list is reached, a ClassNotFoundException is thrown.

Be aware that if a ClassLoader in the ClassLoaderRepository calls this method from its loadClass method, it exposes itself to a deadlock if another ClassLoader in the ClassLoaderRepository does the same thing at the same time. The loadClassBefore(java.lang.ClassLoader, java.lang.String) method is recommended to avoid the risk of deadlock.

Parameters:
className - The name of the class to be loaded.
exclude - The class loader to be excluded. May be null, in which case this method is equivalent to loadClass(className).
Returns:
the loaded class.
Throws:
ClassNotFoundException - The specified class could not be found.

loadClassBefore

public Class loadClassBefore(ClassLoader stop,
                             String className)
                      throws ClassNotFoundException

Load the given class name through the list of class loaders, stopping at the given one. Each ClassLoader in turn from the ClassLoaderRepository is asked to load the class via its ClassLoader.loadClass(String) method. If it successfully returns a Class object, that is the result of this method. If it throws a ClassNotFoundException, the search continues with the next ClassLoader. If it throws another exception, the exception is propagated from this method. If the search reaches stop or the end of the list, a ClassNotFoundException is thrown.

Typically this method is called from the loadClass method of stop, to consult loaders that appear before it in the ClassLoaderRepository. By stopping the search as soon as stop is reached, a potential deadlock with concurrent class loading is avoided.

Parameters:
className - The name of the class to be loaded.
stop - The class loader at which to stop. May be null, in which case this method is equivalent to loadClass(className).
Returns:
the loaded class.
Throws:
ClassNotFoundException - The specified class could not be found.
Since:
JMX 1.2
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DefaultLoaderRepository

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.loading
Class DefaultLoaderRepository

java.lang.Object
    extended by javax.management.loading.DefaultLoaderRepository
Deprecated. Use MBeanServer.getClassLoaderRepository()} instead.

public class DefaultLoaderRepository
extends Object

Keeps the list of Class Loaders registered in the MBean Server. It provides the necessary methods to load classes using the registered Class Loaders.

This deprecated class is maintained for compatibility. In previous versions of JMX, there was one DefaultLoaderRepository shared by all MBean servers. As of JMX 1.2, that functionality is approximated by using MBeanServerFactory.findMBeanServer(java.lang.String) to find all known MBean servers, and consulting the ClassLoaderRepository of each one. It is strongly recommended that code referencing DefaultLoaderRepository be rewritten.

Constructor Summary
DefaultLoaderRepository()
Deprecated.
Method Summary
static Class | loadClass(String className) Deprecated. Go through the list of class loaders and try to load the requested class.
static Class | loadClassWithout(ClassLoader loader, String className) Deprecated. Go through the list of class loaders but exclude the given class loader, then try to load the requested class.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultLoaderRepository

public DefaultLoaderRepository()
Deprecated.
Method Detail

loadClass

public static Class loadClass(String className)
                       throws ClassNotFoundException
Deprecated.
Go through the list of class loaders and try to load the requested class. The method will stop as soon as the class is found. If the class is not found the method will throw a ClassNotFoundException exception.

Parameters:
className - The name of the class to be loaded.
Returns:
the loaded class.
Throws:
ClassNotFoundException - The specified class could not be found.

loadClassWithout

public static Class loadClassWithout(ClassLoader loader,
                                     String className)
                              throws ClassNotFoundException
Deprecated.
Go through the list of class loaders but exclude the given class loader, then try to load the requested class. The method will stop as soon as the class is found. If the class is not found the method will throw a ClassNotFoundException exception.

Parameters:
className - The name of the class to be loaded.
loader - The class loader to be excluded.
Returns:
the loaded class.
Throws:
ClassNotFoundException - The specified class could not be found.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MLet

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.loading
Class MLet

java.lang.Object
    extended by java.lang.ClassLoader
        extended by java.security.SecureClassLoader
            extended by java.net.URLClassLoader
                extended by javax.management.loading.MLet
All Implemented Interfaces:
Externalizable, MBeanRegistration, MLetMBean, Serializable
Direct Known Subclasses:
PrivateMLet
public class MLet
extends URLClassLoader
implements MLetMBean, MBeanRegistration, Externalizable

Allows you to instantiate and register one or several MBeans in the MBean server coming from a remote URL. M-let is a shortcut for management applet. The m-let service does this by loading an m-let text file, which specifies information on the MBeans to be obtained. The information on each MBean is specified in a single instance of a tag, called the MLET tag. The location of the m-let text file is specified by a URL.

The MLET tag has the following syntax:

<MLET
CODE = class | OBJECT = serfile
ARCHIVE = "archiveList"
[CODEBASE = codebaseURL]
[NAME = mbeanname]
[VERSION = version]
>
[arglist]
</MLET>

where:

CODE = class
This attribute specifies the full Java class name, including package name, of the MBean to be obtained. The compiled .class file of the MBean must be contained in one of the .jar files specified by the ARCHIVE attribute. Either CODE or OBJECT must be present.
OBJECT = serfile
This attribute specifies the .ser file that contains a serialized representation of the MBean to be obtained. This file must be contained in one of the .jar files specified by the ARCHIVE attribute. If the .jar file contains a directory hierarchy, specify the path of the file within this hierarchy. Otherwise a match will not be found. Either CODE or OBJECT must be present.
ARCHIVE = "archiveList"
This mandatory attribute specifies one or more .jar files containing MBeans or other resources used by the MBean to be obtained. One of the .jar files must contain the file specified by the CODE or OBJECT attribute. If archivelist contains more than one file:
  • Each file must be separated from the one that follows it by a comma (,).
  • archivelist must be enclosed in double quote marks.
All .jar files in archivelist must be stored in the directory specified by the code base URL.
CODEBASE = codebaseURL
This optional attribute specifies the code base URL of the MBean to be obtained. It identifies the directory that contains the .jar files specified by the ARCHIVE attribute. Specify this attribute only if the .jar files are not in the same directory as the m-let text file. If this attribute is not specified, the base URL of the m-let text file is used.
NAME = mbeanname
This optional attribute specifies the object name to be assigned to the MBean instance when the m-let service registers it. If mbeanname starts with the colon character (:), the domain part of the object name is the domain of the agent. The m-let service invokes the getDomain() method of the Framework class to obtain this information.
VERSION = version
This optional attribute specifies the version number of the MBean and associated .jar files to be obtained. This version number can be used to specify that the .jar files are loaded from the server to update those stored locally in the cache the next time the m-let text file is loaded. version must be a series of non-negative decimal integers each separated by a period from the one that precedes it.
arglist
This optional attribute specifies a list of one or more parameters for the MBean to be instantiated. This list describes the parameters to be passed the MBean's constructor. Use the following syntax to specify each item in arglist:

<ARG TYPE=argumentType VALUE=value>

where:
  • argumentType is the type of the argument that will be passed as parameter to the MBean's constructor.

The arguments' type in the argument list should be a Java primitive type or a Java basic type (java.lang.Boolean, java.lang.Byte, java.lang.Short, java.lang.Long, java.lang.Integer, java.lang.Float, java.lang.Double, java.lang.String).

When an m-let text file is loaded, an instance of each MBean specified in the file is created and registered.

The m-let Service extends the java.net.URLClassLoader and can be used to load remote classes and jar files in the VM of the agent.

Note - The MLet class loader uses the MBeanServerFactory.getClassLoaderRepository(javax.management.MBeanServer) to load classes that could not be found in the loaded jar files.

See Also:
Serialized Form

Constructor Summary
MLet()
Constructs a new MLet using the default delegation parent ClassLoader.
MLet(URL[] urls)
Constructs a new MLet for the specified URLs using the default delegation parent ClassLoader.
MLet(URL[] urls, boolean delegateToCLR)
Constructs a new MLet for the specified URLs using the default delegation parent ClassLoader.
MLet(URL[] urls, ClassLoader parent)
Constructs a new MLet for the given URLs.
MLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
Constructs a new MLet for the given URLs.
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
Constructs a new MLet for the specified URLs, parent class loader, and URLStreamHandlerFactory.
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
Constructs a new MLet for the specified URLs, parent class loader, and URLStreamHandlerFactory.
Method Summary
void | addURL(String url) Appends the specified URL to the list of URLs to search for classes and resources.
void | addURL(URL url) Appends the specified URL to the list of URLs to search for classes and resources.
protected URL | check(String version, URL codebase, String jarfile, javax.management.loading.MLetContent mlet) This method is to be overridden when extending this service to support caching and versioning.
protected Class | findClass(String name) This is the main method for class loaders that is being redefined.
protected String | findLibrary(String libname) Returns the absolute path name of a native library.
String | getLibraryDirectory() Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.
Set | getMBeansFromURL(String url) Loads a text file containing MLET tags that define the MBeans to be added to the agent.
Set | getMBeansFromURL(URL url) Loads a text file containing MLET tags that define the MBeans to be added to the agent.
URL[] | getURLs() Returns the search path of URLs for loading classes and resources.
Class | loadClass(String name, ClassLoaderRepository clr) Load a class, using the given ClassLoaderRepository if the class is not found in this MLet's URLs.
void | postDeregister() Allows the m-let to perform any operations needed after having been unregistered in the MBean server.
void | postRegister(Boolean registrationDone) Allows the m-let to perform any operations needed after having been registered in the MBean server or after the registration has failed.
void | preDeregister() Allows the m-let to perform any operations it needs before being unregistered by the MBean server.
ObjectName | preRegister(MBeanServer server, ObjectName name) Allows the m-let to perform any operations it needs before being registered in the MBean server.
void | readExternal(ObjectInput in) Restore this MLet's contents from the given ObjectInput.
void | setLibraryDirectory(String libdir) Sets the directory used by the library loader for storing native libraries before they are loaded into memory.
void | writeExternal(ObjectOutput out) Save this MLet's contents to the given ObjectOutput.
Methods inherited from class java.net.URLClassLoader
definePackage, findResource, findResources, getPermissions, newInstance, newInstance
Methods inherited from class java.security.SecureClassLoader
defineClass
Methods inherited from class java.lang.ClassLoader
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.management.loading.MLetMBean
getResource, getResourceAsStream, getResources

Constructor Detail

MLet

public MLet()
Constructs a new MLet using the default delegation parent ClassLoader.

MLet

public MLet(URL[] urls)
Constructs a new MLet for the specified URLs using the default delegation parent ClassLoader. The URLs will be searched in the order specified for classes and resources after first searching in the parent class loader.

Parameters:
urls - The URLs from which to load classes and resources.

MLet

public MLet(URL[] urls,
            ClassLoader parent)
Constructs a new MLet for the given URLs. The URLs will be searched in the order specified for classes and resources after first searching in the specified parent class loader. The parent argument will be used as the parent class loader for delegation. The factory argument will be used as the stream handler factory to obtain protocol handlers when creating new URLs.

Parameters:
urls - The URLs from which to load classes and resources.
parent - The parent class loader for delegation.

MLet

public MLet(URL[] urls,
            ClassLoader parent,
            URLStreamHandlerFactory factory)
Constructs a new MLet for the specified URLs, parent class loader, and URLStreamHandlerFactory. The parent argument will be used as the parent class loader for delegation. The factory argument will be used as the stream handler factory to obtain protocol handlers when creating new URLs.

Parameters:
urls - The URLs from which to load classes and resources.
parent - The parent class loader for delegation.
factory - The URLStreamHandlerFactory to use when creating URLs.

MLet

public MLet(URL[] urls,
            boolean delegateToCLR)
Constructs a new MLet for the specified URLs using the default delegation parent ClassLoader. The URLs will be searched in the order specified for classes and resources after first searching in the parent class loader.

Parameters:
urls - The URLs from which to load classes and resources.
delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.
Since:
JMX 1.2

MLet

public MLet(URL[] urls,
            ClassLoader parent,
            boolean delegateToCLR)
Constructs a new MLet for the given URLs. The URLs will be searched in the order specified for classes and resources after first searching in the specified parent class loader. The parent argument will be used as the parent class loader for delegation. The factory argument will be used as the stream handler factory to obtain protocol handlers when creating new URLs.

Parameters:
urls - The URLs from which to load classes and resources.
parent - The parent class loader for delegation.
delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.
Since:
JMX 1.2

MLet

public MLet(URL[] urls,
            ClassLoader parent,
            URLStreamHandlerFactory factory,
            boolean delegateToCLR)
Constructs a new MLet for the specified URLs, parent class loader, and URLStreamHandlerFactory. The parent argument will be used as the parent class loader for delegation. The factory argument will be used as the stream handler factory to obtain protocol handlers when creating new URLs.

Parameters:
urls - The URLs from which to load classes and resources.
parent - The parent class loader for delegation.
factory - The URLStreamHandlerFactory to use when creating URLs.
delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.
Since:
JMX 1.2
Method Detail

addURL

public void addURL(URL url)
Appends the specified URL to the list of URLs to search for classes and resources.

Specified by:
addURL in interface MLetMBean

addURL

public void addURL(String url)
            throws ServiceNotFoundException
Appends the specified URL to the list of URLs to search for classes and resources.

Specified by:
addURL in interface MLetMBean
Parameters:
url - the URL to add.
Throws:
ServiceNotFoundException - The specified URL is malformed.

getURLs

public URL[] getURLs()
Returns the search path of URLs for loading classes and resources. This includes the original list of URLs specified to the constructor, along with any URLs subsequently appended by the addURL() method.

Specified by:
getURLs in interface MLetMBean

getMBeansFromURL

public Set getMBeansFromURL(URL url)
                     throws ServiceNotFoundException
Loads a text file containing MLET tags that define the MBeans to be added to the agent. The location of the text file is specified by a URL. The MBeans specified in the MLET file will be instantiated and registered by the MBean server.

Specified by:
getMBeansFromURL in interface MLetMBean
Parameters:
url - The URL of the text file to be loaded as URL object.
Returns:
A set containing one entry per MLET tag in the m-let text file loaded. Each entry specifies either the ObjectInstance for the created MBean, or a throwable object (that is, an error or an exception) if the MBean could not be created.
Throws:
ServiceNotFoundException - One of the following errors has occurred: The m-let text file does not contain an MLET tag, the m-let text file is not found, a mandatory attribute of the MLET tag is not specified, the value of url is null.
IllegalStateException - MLet MBean is not registered with an MBeanServer.

getMBeansFromURL

public Set getMBeansFromURL(String url)
                     throws ServiceNotFoundException
Loads a text file containing MLET tags that define the MBeans to be added to the agent. The location of the text file is specified by a URL. The MBeans specified in the MLET file will be instantiated and registered by the MBean server.

Specified by:
getMBeansFromURL in interface MLetMBean
Parameters:
url - The URL of the text file to be loaded as String object.
Returns:
A set containing one entry per MLET tag in the m-let text file loaded. Each entry specifies either the ObjectInstance for the created MBean, or a throwable object (that is, an error or an exception) if the MBean could not be created.
Throws:
ServiceNotFoundException - One of the following errors has occurred: The m-let text file does not contain an MLET tag, the m-let text file is not found, a mandatory attribute of the MLET tag is not specified, the url is malformed.
IllegalStateException - MLet MBean is not registered with an MBeanServer.

getLibraryDirectory

public String getLibraryDirectory()
Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.

Specified by:
getLibraryDirectory in interface MLetMBean
Returns:
The current directory used by the library loader.
See Also:
setLibraryDirectory(java.lang.String)

setLibraryDirectory

public void setLibraryDirectory(String libdir)
Sets the directory used by the library loader for storing native libraries before they are loaded into memory.

Specified by:
setLibraryDirectory in interface MLetMBean
Parameters:
libdir - The directory used by the library loader.
See Also:
getLibraryDirectory()

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
Allows the m-let to perform any operations it needs before being registered in the MBean server. If the ObjectName is null, the m-let provides a default name for its registration <defaultDomain>:type=MLet

Specified by:
preRegister in interface MBeanRegistration
Parameters:
server - The MBean server in which the m-let will be registered.
name - The object name of the m-let.
Returns:
The name of the m-let registered.
Throws:
Exception - This exception should be caught by the MBean server and re-thrown as an MBeanRegistrationException.

postRegister

public void postRegister(Boolean registrationDone)
Allows the m-let to perform any operations needed after having been registered in the MBean server or after the registration has failed.

Specified by:
postRegister in interface MBeanRegistration
Parameters:
registrationDone - Indicates whether or not the m-let has been successfully registered in the MBean server. The value false means that either the registration phase has failed.

preDeregister

public void preDeregister()
                   throws Exception
Allows the m-let to perform any operations it needs before being unregistered by the MBean server.

Specified by:
preDeregister in interface MBeanRegistration
Throws:
java.langException - This exception should be caught by the MBean server and re-thrown as an MBeanRegistrationException.
Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException or a RuntimeMBeanException.

postDeregister

public void postDeregister()
Allows the m-let to perform any operations needed after having been unregistered in the MBean server.

Specified by:
postDeregister in interface MBeanRegistration

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

Save this MLet's contents to the given ObjectOutput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the written data.

The format of the written data is not specified, but if an implementation supports writeExternal(java.io.ObjectOutput) it must also support readExternal(java.io.ObjectInput) in such a way that what is written by the former can be read by the latter.

Specified by:
writeExternal in interface Externalizable
Parameters:
out - The object output stream to write to.
Throws:
IOException - If a problem occurred while writing.
UnsupportedOperationException - If this implementation does not support this operation.

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

Restore this MLet's contents from the given ObjectInput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the read data.

The format of the read data is not specified, but if an implementation supports readExternal(java.io.ObjectInput) it must also support writeExternal(java.io.ObjectOutput) in such a way that what is written by the latter can be read by the former.

Specified by:
readExternal in interface Externalizable
Parameters:
in - The object input stream to read from.
Throws:
IOException - if a problem occurred while reading.
ClassNotFoundException - if the class for the object being restored cannot be found.
UnsupportedOperationException - if this implementation does not support this operation.

loadClass

public Class loadClass(String name,
                       ClassLoaderRepository clr)
                throws ClassNotFoundException

Load a class, using the given ClassLoaderRepository if the class is not found in this MLet's URLs. The given ClassLoaderRepository can be null, in which case a ClassNotFoundException occurs immediately if the class is not found in this MLet's URLs.

Parameters:
name - The name of the class we want to load.
clr - The ClassLoaderRepository that will be used to search for the given class, if it is not found in this ClassLoader. May be null.
Returns:
The resulting Class object.
Throws:
ClassNotFoundException - The specified class could not be found in this ClassLoader nor in the given ClassLoaderRepository.
Since:
JMX 1.1

findClass

protected Class findClass(String name)
                   throws ClassNotFoundException
This is the main method for class loaders that is being redefined.

Parameters:
name - The name of the class.
Returns:
The resulting Class object.
Throws:
ClassNotFoundException - The specified class could not be found.

findLibrary

protected String findLibrary(String libname)
Returns the absolute path name of a native library. The VM invokes this method to locate the native libraries that belong to classes loaded with this class loader. Libraries are searched in the JAR files using first just the native library name and if not found the native library name together with the architecture-specific path name (OSName/OSArch/OSVersion/lib/nativelibname), i.e.

the library stat on Solaris SPARC 5.7 will be searched in the JAR file as:

  1. libstat.so
  2. SunOS/sparc/5.7/lib/libstat.so
the library stat on Windows NT 4.0 will be searched in the JAR file as:
  1. stat.dll
  2. WindowsNT/x86/4.0/lib/stat.dll

If this method returns null, i.e. the libraries were not found in any of the JAR files loaded with this class loader, the VM searches the library along the path specified as the java.library.path property.

Parameters:
libname - The library name.
Returns:
The absolute path of the native library.

check

protected URL check(String version,
                    URL codebase,
                    String jarfile,
                    javax.management.loading.MLetContent mlet)
             throws Exception

This method is to be overridden when extending this service to support caching and versioning. It is called from getMBeansFromURL when the version, codebase, and jarfile have been extracted from the MLet file, and can be used to verify that it is all right to load the given MBean, or to replace the given URL with a different one.

The default implementation of this method returns codebase unchanged.

Parameters:
version - The version number of the .jar file stored locally.
codebase - The base URL of the remote .jar file.
jarfile - The name of the .jar file to be loaded.
mlet - The MLetContent instance that represents the MLET tag.
Returns:
the codebase to use for the loaded MBean. The returned value should not be null.
Throws:
Exception - if the MBean is not to be loaded for some reason. The exception will be added to the set returned by getMBeansFromURL.
Since:
JMX 1.2
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MLetMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.loading
Interface MLetMBean

All Known Implementing Classes:
MLet
public interface MLetMBean

Exposes the remote management interface of the MLet MBean.

Method Summary
void | addURL(String url) Appends the specified URL to the list of URLs to search for classes and resources.
void | addURL(URL url) Appends the specified URL to the list of URLs to search for classes and resources.
String | getLibraryDirectory() Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.
Set | getMBeansFromURL(String url) Loads a text file containing MLET tags that define the MBeans to be added to the agent.
Set | getMBeansFromURL(URL url) Loads a text file containing MLET tags that define the MBeans to be added to the agent.
URL | getResource(String name) Finds the resource with the given name.
InputStream | getResourceAsStream(String name) Returns an input stream for reading the specified resource.
Enumeration | getResources(String name) Finds all the resources with the given name.
URL[] | getURLs() Returns the search path of URLs for loading classes and resources.
void | setLibraryDirectory(String libdir) Sets the directory used by the library loader for storing native libraries before they are loaded into memory.

Method Detail

getMBeansFromURL

public Set getMBeansFromURL(String url)
                     throws ServiceNotFoundException
Loads a text file containing MLET tags that define the MBeans to be added to the agent. The location of the text file is specified by a URL. The MBeans specified in the MLET file will be instantiated and registered by the MBeanServer.

Parameters:
url - The URL of the text file to be loaded as String object.
Returns:
A set containing one entry per MLET tag in the m-let text file loaded. Each entry specifies either the ObjectInstance for the created MBean, or a throwable object (that is, an error or an exception) if the MBean could not be created.
Throws:
ServiceNotFoundException - One of the following errors has occurred: The m-let text file does not contain an MLET tag, the m-let text file is not found, a mandatory attribute of the MLET tag is not specified, the value of url is malformed.

getMBeansFromURL

public Set getMBeansFromURL(URL url)
                     throws ServiceNotFoundException
Loads a text file containing MLET tags that define the MBeans to be added to the agent. The location of the text file is specified by a URL. The MBeans specified in the MLET file will be instantiated and registered by the MBeanServer.

Parameters:
url - The URL of the text file to be loaded as URL object.
Returns:
A set containing one entry per MLET tag in the m-let text file loaded. Each entry specifies either the ObjectInstance for the created MBean, or a throwable object (that is, an error or an exception) if the MBean could not be created.
Throws:
ServiceNotFoundException - One of the following errors has occurred: The m-let text file does not contain an MLET tag, the m-let text file is not found, a mandatory attribute of the MLET tag is not specified, the value of url is null.

addURL

public void addURL(URL url)
Appends the specified URL to the list of URLs to search for classes and resources.

Parameters:
url - the URL to add.

addURL

public void addURL(String url)
            throws ServiceNotFoundException
Appends the specified URL to the list of URLs to search for classes and resources.

Parameters:
url - the URL to add.
Throws:
ServiceNotFoundException - The specified URL is malformed.

getURLs

public URL[] getURLs()
Returns the search path of URLs for loading classes and resources. This includes the original list of URLs specified to the constructor, along with any URLs subsequently appended by the addURL() method.

Returns:
the list of URLs.

getResource

public URL getResource(String name)
Finds the resource with the given name. A resource is some data (images, audio, text, etc) that can be accessed by class code in a way that is independent of the location of the code. The name of a resource is a "/"-separated path name that identifies the resource.

Parameters:
name - The resource name
Returns:
An URL for reading the resource, or null if the resource could not be found or the caller doesn't have adequate privileges to get the resource.

getResourceAsStream

public InputStream getResourceAsStream(String name)
Returns an input stream for reading the specified resource. The search order is described in the documentation for getResource(String).

Parameters:
name - The resource name
Returns:
An input stream for reading the resource, or null if the resource could not be found

getResources

public Enumeration getResources(String name)
                         throws IOException
Finds all the resources with the given name. A resource is some data (images, audio, text, etc) that can be accessed by class code in a way that is independent of the location of the code. The name of a resource is a "/"-separated path name that identifies the resource.

Parameters:
name - The resource name.
Returns:
An enumeration of URL to the resource. If no resources could be found, the enumeration will be empty. Resources that cannot be accessed will not be in the enumeration.
Throws:
IOException - if an I/O exception occurs when searching for resources.

getLibraryDirectory

public String getLibraryDirectory()
Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.

Returns:
The current directory used by the library loader.
See Also:
setLibraryDirectory(java.lang.String)

setLibraryDirectory

public void setLibraryDirectory(String libdir)
Sets the directory used by the library loader for storing native libraries before they are loaded into memory.

Parameters:
libdir - The directory used by the library loader.
See Also:
getLibraryDirectory()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PrivateMLet

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.loading
Class PrivateMLet

java.lang.Object
    extended by java.lang.ClassLoader
        extended by java.security.SecureClassLoader
            extended by java.net.URLClassLoader
                extended by javax.management.loading.MLet
                    extended by javax.management.loading.PrivateMLet
All Implemented Interfaces:
Externalizable, MBeanRegistration, MLetMBean, PrivateClassLoader, Serializable
public class PrivateMLet
extends MLet
implements PrivateClassLoader

An MLet that is not added to the ClassLoaderRepository. This class acts exactly like its parent class, MLet, with one exception. When a PrivateMLet is registered in an MBean server, it is not added to that MBean server's ClassLoaderRepository. This is true because this class implements the interface PrivateClassLoader.

Since:
JMX 1.2
See Also:
Serialized Form

Constructor Summary
PrivateMLet(URL[] urls, boolean delegateToCLR)
Constructs a new PrivateMLet for the specified URLs using the default delegation parent ClassLoader.
PrivateMLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
Constructs a new PrivateMLet for the given URLs.
PrivateMLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
Constructs a new PrivateMLet for the specified URLs, parent class loader, and URLStreamHandlerFactory.
Methods inherited from class javax.management.loading.MLet
addURL, addURL, check, findClass, findLibrary, getLibraryDirectory, getMBeansFromURL, getMBeansFromURL, getURLs, loadClass, postDeregister, postRegister, preDeregister, preRegister, readExternal, setLibraryDirectory, writeExternal
Methods inherited from class java.net.URLClassLoader
definePackage, findResource, findResources, getPermissions, newInstance, newInstance
Methods inherited from class java.security.SecureClassLoader
defineClass
Methods inherited from class java.lang.ClassLoader
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.management.loading.MLetMBean
getResource, getResourceAsStream, getResources

Constructor Detail

PrivateMLet

public PrivateMLet(URL[] urls,
                   boolean delegateToCLR)
Constructs a new PrivateMLet for the specified URLs using the default delegation parent ClassLoader. The URLs will be searched in the order specified for classes and resources after first searching in the parent class loader.

Parameters:
urls - The URLs from which to load classes and resources.
delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.

PrivateMLet

public PrivateMLet(URL[] urls,
                   ClassLoader parent,
                   boolean delegateToCLR)
Constructs a new PrivateMLet for the given URLs. The URLs will be searched in the order specified for classes and resources after first searching in the specified parent class loader. The parent argument will be used as the parent class loader for delegation. The factory argument will be used as the stream handler factory to obtain protocol handlers when creating new URLs.

Parameters:
urls - The URLs from which to load classes and resources.
parent - The parent class loader for delegation.
delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.

PrivateMLet

public PrivateMLet(URL[] urls,
                   ClassLoader parent,
                   URLStreamHandlerFactory factory,
                   boolean delegateToCLR)
Constructs a new PrivateMLet for the specified URLs, parent class loader, and URLStreamHandlerFactory. The parent argument will be used as the parent class loader for delegation. The factory argument will be used as the stream handler factory to obtain protocol handlers when creating new URLs.

Parameters:
urls - The URLs from which to load classes and resources.
parent - The parent class loader for delegation.
factory - The URLStreamHandlerFactory to use when creating URLs.
delegateToCLR - True if, when a class is not found in either the parent ClassLoader or the URLs, the MLet should delegate to its containing MBeanServer's ClassLoaderRepository.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MalformedObjectNameException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MalformedObjectNameException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.OperationsException
                    extended by javax.management.MalformedObjectNameException
All Implemented Interfaces:
Serializable
public class MalformedObjectNameException
extends OperationsException

The format of the string does not correspond to a valid ObjectName.

See Also:
Serialized Form

Constructor Summary
MalformedObjectNameException()
Default constructor.
MalformedObjectNameException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MalformedObjectNameException

public MalformedObjectNameException()
Default constructor.

MalformedObjectNameException

public MalformedObjectNameException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanAttributeInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanAttributeInfo

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanAttributeInfo
All Implemented Interfaces:
Cloneable, Serializable
Direct Known Subclasses:
ModelMBeanAttributeInfo, OpenMBeanAttributeInfoSupport
public class MBeanAttributeInfo
extends MBeanFeatureInfo
implements Serializable, Cloneable

Describes an MBean attribute exposed for management. Instances of this class are immutable. Subclasses may be mutable but this is not recommended.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
MBeanAttributeInfo(String name, String description, Method getter, Method setter)
This constructor takes the name of a simple attribute, and Method objects for reading and writing the attribute.
MBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)
Constructs an MBeanAttributeInfo object.
Method Summary
Object | clone() Returns a shallow clone of this instance.
boolean | equals(Object o) Compare this MBeanAttributeInfo to another.
String | getType() Returns the class name of the attribute.
int | hashCode()
boolean | isIs() Indicates if this attribute has an "is" getter.
boolean | isReadable() Whether the value of the attribute can be read.
boolean | isWritable() Whether new values can be written to the attribute.
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MBeanAttributeInfo

public MBeanAttributeInfo(String name,
                          String type,
                          String description,
                          boolean isReadable,
                          boolean isWritable,
                          boolean isIs)
                   throws IllegalArgumentException
Constructs an MBeanAttributeInfo object.

Parameters:
name - The name of the attribute.
type - The type or class name of the attribute.
description - A human readable description of the attribute.
isReadable - True if the attribute has a getter method, false otherwise.
isWritable - True if the attribute has a setter method, false otherwise.
isIs - True if this attribute has an "is" getter, false otherwise.
Throws:
IllegalArgumentException - if name is not a valid Java identifier or if type is not a syntactically legal Java type name. Java reserved words are not considered illegal here.

MBeanAttributeInfo

public MBeanAttributeInfo(String name,
                          String description,
                          Method getter,
                          Method setter)
                   throws IntrospectionException
This constructor takes the name of a simple attribute, and Method objects for reading and writing the attribute.

Parameters:
name - The programmatic name of the attribute.
description - A human readable description of the attribute.
getter - The method used for reading the attribute value. May be null if the property is write-only.
setter - The method used for writing the attribute value. May be null if the attribute is read-only.
Throws:
IntrospectionException - There is a consistency problem in the definition of this attribute.
Method Detail

clone

public Object clone()

Returns a shallow clone of this instance. The clone is obtained by simply calling super.clone(), thus calling the default native shallow cloning mechanism implemented by Object.clone(). No deeper cloning of any internal field is made.

Since this class is immutable, cloning is chiefly of interest to subclasses.

getType

public String getType()
Returns the class name of the attribute.

Returns:
the class name.

isReadable

public boolean isReadable()
Whether the value of the attribute can be read.

Returns:
True if the attribute can be read, false otherwise.

isWritable

public boolean isWritable()
Whether new values can be written to the attribute.

Returns:
True if the attribute can be written to, false otherwise.

isIs

public boolean isIs()
Indicates if this attribute has an "is" getter.

Returns:
true if this attribute has an "is" getter.

equals

public boolean equals(Object o)
Compare this MBeanAttributeInfo to another.

Overrides:
equals in class MBeanFeatureInfo
Parameters:
o - the object to compare to.
Returns:
true iff o is an MBeanAttributeInfo such that its MBeanFeatureInfo.getName(), getType(), MBeanFeatureInfo.getDescription(), isReadable(), isWritable(), and isIs() values are equal (not necessarily identical) to those of this MBeanAttributeInfo.

hashCode

public int hashCode()
Overrides:
hashCode in class MBeanFeatureInfo
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanConstructorInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanConstructorInfo

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanConstructorInfo
All Implemented Interfaces:
Cloneable, Serializable
Direct Known Subclasses:
ModelMBeanConstructorInfo, OpenMBeanConstructorInfoSupport
public class MBeanConstructorInfo
extends MBeanFeatureInfo
implements Serializable, Cloneable

Describes a constructor exposed by an MBean. Instances of this class are immutable. Subclasses may be mutable but this is not recommended.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
MBeanConstructorInfo(String description, Constructor constructor)
Constructs an MBeanConstructorInfo object.
MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
Constructs an MBeanConstructorInfo object.
Method Summary
Object | clone() Returns a shallow clone of this instance.
boolean | equals(Object o) Compare this MBeanConstructorInfo to another.
MBeanParameterInfo[] | getSignature() Returns the list of parameters for this constructor.
int | hashCode()
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MBeanConstructorInfo

public MBeanConstructorInfo(String description,
                            Constructor constructor)
Constructs an MBeanConstructorInfo object.

Parameters:
description - A human readable description of the operation.
constructor - The java.lang.reflect.Constructor object describing the MBean constructor.
Throws:
IllegalArgumentException - if one of constructor's parameter types is not a syntactically legal Java type name. Java reserved words are not considered illegal here. If constructor comes from a class compiled from Java, this exception cannot happen.

MBeanConstructorInfo

public MBeanConstructorInfo(String name,
                            String description,
                            MBeanParameterInfo[] signature)
                     throws IllegalArgumentException
Constructs an MBeanConstructorInfo object.

Parameters:
name - The name of the constructor.
signature - MBeanParameterInfo objects describing the parameters(arguments) of the constructor. This may be null with the same effect as a zero-length array.
description - A human readable description of the constructor.
Throws:
IllegalArgumentException - if name is not a valid Java identifier or a syntactically legal Java type name as returned by Constructor.getName(). Java reserved words are not considered illegal here.
Method Detail

clone

public Object clone()

Returns a shallow clone of this instance. The clone is obtained by simply calling super.clone(), thus calling the default native shallow cloning mechanism implemented by Object.clone(). No deeper cloning of any internal field is made.

Since this class is immutable, cloning is chiefly of interest to subclasses.

getSignature

public MBeanParameterInfo[] getSignature()

Returns the list of parameters for this constructor. Each parameter is described by an MBeanParameterInfo object.

The returned array is a shallow copy of the internal array, which means that it is a copy of the internal array of references to the MBeanParameterInfo objects but that each referenced MBeanParameterInfo object is not copied.

Returns:
An array of MBeanParameterInfo objects.

equals

public boolean equals(Object o)
Compare this MBeanConstructorInfo to another.

Overrides:
equals in class MBeanFeatureInfo
Parameters:
o - the object to compare to.
Returns:
true iff o is an MBeanConstructorInfo such that its MBeanFeatureInfo.getName(), MBeanFeatureInfo.getDescription(), and getSignature() values are equal (not necessarily identical) to those of this MBeanConstructorInfo. Two signature arrays are equal if their elements are pairwise equal.

hashCode

public int hashCode()
Overrides:
hashCode in class MBeanFeatureInfo
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.MBeanException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MBeanRegistrationException
public class MBeanException
extends JMException

Represents "user defined" exceptions thrown by MBean methods in the agent. It "wraps" the actual "user defined" exception thrown. This exception will be built by the MBeanServer when a call to an MBean method results in an unknown exception.

See Also:
Serialized Form

Constructor Summary
MBeanException(Exception e)
Creates an MBeanException that wraps the actual java.lang.Exception.
MBeanException(Exception e, String message)
Creates an MBeanException that wraps the actual java.lang.Exception with a detail message.
Method Summary
Throwable | getCause() Return the actual Exception thrown.
Exception | getTargetException() Return the actual Exception thrown.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MBeanException

public MBeanException(Exception e)
Creates an MBeanException that wraps the actual java.lang.Exception.

Parameters:
e - the wrapped exception.

MBeanException

public MBeanException(Exception e,
                      String message)
Creates an MBeanException that wraps the actual java.lang.Exception with a detail message.

Parameters:
e - the wrapped exception.
message - the detail message.
Method Detail

getTargetException

public Exception getTargetException()
Return the actual Exception thrown.

Returns:
the wrapped exception.

getCause

public Throwable getCause()
Return the actual Exception thrown.

Returns:
the wrapped exception.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanFeatureInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanFeatureInfo

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MBeanAttributeInfo, MBeanConstructorInfo, MBeanNotificationInfo, MBeanOperationInfo, MBeanParameterInfo
public class MBeanFeatureInfo
extends Object
implements Serializable

Provides general information for an MBean descriptor object. The feature described can be an attribute, an operation, a parameter, or a notification. Instances of this class are immutable. Subclasses may be mutable but this is not recommended.

See Also:
Serialized Form

Field Summary
protected String | description The human-readable description of the feature.
protected String | name The name of the feature.
Constructor Summary
MBeanFeatureInfo(String name, String description)
Constructs an MBeanFeatureInfo object.
Method Summary
boolean | equals(Object o) Compare this MBeanFeatureInfo to another.
String | getDescription() Returns the human-readable description of the feature.
String | getName() Returns the name of the feature.
int | hashCode()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

protected String name
The name of the feature. It is recommended that subclasses call getName() rather than reading this field, and that they not change it.

description

protected String description
The human-readable description of the feature. It is recommended that subclasses call getDescription() rather than reading this field, and that they not change it.

Constructor Detail

MBeanFeatureInfo

public MBeanFeatureInfo(String name,
                        String description)
                 throws IllegalArgumentException
Constructs an MBeanFeatureInfo object.

Parameters:
name - The name of the feature.
description - A human readable description of the feature.
Throws:
IllegalArgumentException - if name is not a valid Java identifier. Java reserved words are not considered illegal here.
Method Detail

getName

public String getName()
Returns the name of the feature.

Returns:
the name of the feature.

getDescription

public String getDescription()
Returns the human-readable description of the feature.

Returns:
the human-readable description of the feature.

equals

public boolean equals(Object o)
Compare this MBeanFeatureInfo to another.

Parameters:
o - the object to compare to.
Returns:
true iff o is an MBeanFeatureInfo such that its getName() and getDescription() values are equal (not necessarily identical) to those of this MBeanFeatureInfo.

hashCode

public int hashCode()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanInfo

java.lang.Object
    extended by javax.management.MBeanInfo
All Implemented Interfaces:
Cloneable, Serializable
Direct Known Subclasses:
ModelMBeanInfoSupport, OpenMBeanInfoSupport
public class MBeanInfo
extends Object
implements Cloneable, Serializable

Describes the management interface exposed by an MBean; that is, the set of attributes and operations which are available for management operations. Instances of this class are immutable. Subclasses may be mutable but this is not recommended.

The contents of the MBeanInfo for a Dynamic MBean are determined by its getMBeanInfo() method. This includes Open MBeans and Model MBeans, which are kinds of Dynamic MBeans.

The contents of the MBeanInfo for a Standard MBean are determined by the MBean server as follows:

  • getClassName() returns the Java class name of the MBean object;
  • getConstructors() returns the list of all public constructors in that object;
  • getAttributes() returns the list of all attributes whose existence is deduced from the presence in the MBean interface of a getName, isName, or setName method that conforms to the conventions for Standard MBeans;
  • getOperations() returns the list of all methods in the MBean interface that do not represent attributes;
  • getNotifications() returns an empty array if the MBean does not implement the NotificationBroadcaster interface, otherwise the result of calling NotificationBroadcaster.getNotificationInfo() on it.

The remaining details of the MBeanInfo for a Standard MBean are not specified. This includes the description of the MBeanInfo and of any contained constructors, attributes, operations, and notifications; and the names and descriptions of parameters to constructors and operations.

See Also:
Serialized Form

Constructor Summary
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
Constructs an MBeanInfo.
Method Summary
Object | clone() Returns a shallow clone of this instance.
boolean | equals(Object o) Compare this MBeanInfo to another.
MBeanAttributeInfo[] | getAttributes() Returns the list of attributes exposed for management.
String | getClassName() Returns the name of the Java class of the MBean described by this MBeanInfo.
MBeanConstructorInfo[] | getConstructors() Returns the list of the public constructors of the MBean.
String | getDescription() Returns a human readable description of the MBean.
MBeanNotificationInfo[] | getNotifications() Returns the list of the notifications emitted by the MBean.
MBeanOperationInfo[] | getOperations() Returns the list of operations of the MBean.
int | hashCode()
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MBeanInfo

public MBeanInfo(String className,
                 String description,
                 MBeanAttributeInfo[] attributes,
                 MBeanConstructorInfo[] constructors,
                 MBeanOperationInfo[] operations,
                 MBeanNotificationInfo[] notifications)
          throws IllegalArgumentException
Constructs an MBeanInfo.

Parameters:
className - The name of the Java class of the MBean described by this MBeanInfo. This value may be any syntactically legal Java class name. It does not have to be a Java class known to the MBean server or to the MBean's ClassLoader. If it is a Java class known to the MBean's ClassLoader, it is recommended but not required that the class's public methods include those that would appear in a Standard MBean implementing the attributes and operations in this MBeanInfo.
description - A human readable description of the MBean (optional).
attributes - The list of exposed attributes of the MBean. This may be null with the same effect as a zero-length array.
constructors - The list of public constructors of the MBean. This may be null with the same effect as a zero-length array.
operations - The list of operations of the MBean. This may be null with the same effect as a zero-length array.
notifications - The list of notifications emitted. This may be null with the same effect as a zero-length array.
Throws:
IllegalArgumentException - if className is not a syntactically legal Java type name. Java reserved words are not considered illegal here.
Method Detail

clone

public Object clone()

Returns a shallow clone of this instance. The clone is obtained by simply calling super.clone(), thus calling the default native shallow cloning mechanism implemented by Object.clone(). No deeper cloning of any internal field is made.

Since this class is immutable, the clone method is chiefly of interest to subclasses.

getClassName

public String getClassName()
Returns the name of the Java class of the MBean described by this MBeanInfo.

Returns:
the class name.

getDescription

public String getDescription()
Returns a human readable description of the MBean.

Returns:
the description.

getAttributes

public MBeanAttributeInfo[] getAttributes()
Returns the list of attributes exposed for management. Each attribute is described by an MBeanAttributeInfo object. The returned array is a shallow copy of the internal array, which means that it is a copy of the internal array of references to the MBeanAttributeInfo objects but that each referenced MBeanAttributeInfo object is not copied.

Returns:
An array of MBeanAttributeInfo objects.

getOperations

public MBeanOperationInfo[] getOperations()
Returns the list of operations of the MBean. Each operation is described by an MBeanOperationInfo object. The returned array is a shallow copy of the internal array, which means that it is a copy of the internal array of references to the MBeanOperationInfo objects but that each referenced MBeanOperationInfo object is not copied.

Returns:
An array of MBeanOperationInfo objects.

getConstructors

public MBeanConstructorInfo[] getConstructors()

Returns the list of the public constructors of the MBean. Each constructor is described by an MBeanConstructorInfo object.

The returned array is a shallow copy of the internal array, which means that it is a copy of the internal array of references to the MBeanConstructorInfo objects but that each referenced MBeanConstructorInfo object is not copied.

The returned list is not necessarily exhaustive. That is, the MBean may have a public constructor that is not in the list. In this case, the MBean server can construct another instance of this MBean's class using that constructor, even though it is not listed here.

Returns:
An array of MBeanConstructorInfo objects.

getNotifications

public MBeanNotificationInfo[] getNotifications()
Returns the list of the notifications emitted by the MBean. Each notification is described by an MBeanNotificationInfo object. The returned array is a shallow copy of the internal array, which means that it is a copy of the internal array of references to the MBeanNotificationInfo objects but that each referenced MBeanNotificationInfo object is not copied.

Returns:
An array of MBeanNotificationInfo objects.

equals

public boolean equals(Object o)

Compare this MBeanInfo to another. Two MBeanInfo objects are equal iff they return equal values for getClassName() and for getDescription(), and the arrays returned by the two objects for getAttributes(), getOperations(), getConstructors(), and getNotifications() are pairwise equal. Here "equal" means Object.equals(Object), not identity.

If two MBeanInfo objects return the same values in one of their arrays but in a different order then they are not equal.

Parameters:
o - the object to compare to.
Returns:
true iff o is an MBeanInfo that is equal to this one according to the rules above.

hashCode

public int hashCode()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanNotificationInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanNotificationInfo

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanNotificationInfo
All Implemented Interfaces:
Cloneable, Serializable
Direct Known Subclasses:
ModelMBeanNotificationInfo
public class MBeanNotificationInfo
extends MBeanFeatureInfo
implements Cloneable, Serializable

The MBeanNotificationInfo class is used to describe the characteristics of the different notification instances emitted by an MBean, for a given Java class of notification. If an MBean emits notifcations that can be instances of different Java classes, then the metadata for that MBean should provide an MBeanNotificationInfo object for each of these notification Java classes.

Instances of this class are immutable. Subclasses may be mutable but this is not recommended.

This class extends javax.management.MBeanFeatureInfo and thus provides name and description fields. The name field should be the fully qualified Java class name of the notification objects described by this class.

The getNotifTypes method returns an array of strings containing the notification types that the MBean may emit. The notification type is a dot-notation string which describes what the emitted notification is about, not the Java class of the notification. A single generic notification class can be used to send notifications of several types. All of these types are returned in the string array result of the getNotifTypes method.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
MBeanNotificationInfo(String[] notifTypes, String name, String description)
Constructs an MBeanNotificationInfo object.
Method Summary
Object | clone() Returns a shallow clone of this instance.
boolean | equals(Object o) Compare this MBeanAttributeInfo to another.
String[] | getNotifTypes() Returns the array of strings (in dot notation) containing the notification types that the MBean may emit.
int | hashCode()
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MBeanNotificationInfo

public MBeanNotificationInfo(String[] notifTypes,
                             String name,
                             String description)
                      throws IllegalArgumentException
Constructs an MBeanNotificationInfo object.

Parameters:
notifTypes - The array of strings (in dot notation) containing the notification types that the MBean may emit. This may be null with the same effect as a zero-length array.
name - The fully qualified Java class name of the described notifications.
description - A human readable description of the data.
Throws:
IllegalArgumentException - if name is not a valid Java class name. Java reserved words are not considered illegal here.
Method Detail

clone

public Object clone()
Returns a shallow clone of this instance. The clone is obtained by simply calling super.clone(), thus calling the default native shallow cloning mechanism implemented by Object.clone(). No deeper cloning of any internal field is made.

getNotifTypes

public String[] getNotifTypes()
Returns the array of strings (in dot notation) containing the notification types that the MBean may emit.

Returns:
the array of strings. Changing the returned array has no effect on this MBeanNotificationInfo.

equals

public boolean equals(Object o)
Compare this MBeanAttributeInfo to another.

Overrides:
equals in class MBeanFeatureInfo
Parameters:
o - the object to compare to.
Returns:
true iff o is an MBeanNotificationInfo such that its MBeanFeatureInfo.getName(), MBeanFeatureInfo.getDescription(), and getNotifTypes() values are equal (not necessarily identical) to those of this MBeanNotificationInfo. Two notification type arrays are equal if their corresponding elements are equal. They are not equal if they have the same elements but in a different order.

hashCode

public int hashCode()
Overrides:
hashCode in class MBeanFeatureInfo
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanOperationInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanOperationInfo

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanOperationInfo
All Implemented Interfaces:
Cloneable, Serializable
Direct Known Subclasses:
ModelMBeanOperationInfo, OpenMBeanOperationInfoSupport
public class MBeanOperationInfo
extends MBeanFeatureInfo
implements Serializable, Cloneable

Describes a management operation exposed by an MBean. Instances of this class are immutable. Subclasses may be mutable but this is not recommended.

See Also:
Serialized Form

Field Summary
static int | ACTION Indicates that the operation is a write-like, and would modify the MBean in some way, typically by writing some value or changing a configuration.
static int | ACTION_INFO Indicates that the operation is both read-like and write-like.
static int | INFO Indicates that the operation is read-like, it basically returns information.
static int | UNKNOWN Indicates that the operation has an "unknown" nature.
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
MBeanOperationInfo(String description, Method method)
Constructs an MBeanOperationInfo object.
MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
Constructs an MBeanOperationInfo object.
Method Summary
Object | clone() Returns a shallow clone of this instance.
boolean | equals(Object o) Compare this MBeanOperationInfo to another.
int | getImpact() Returns the impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN.
String | getReturnType() Returns the type of the method's return value.
MBeanParameterInfo[] | getSignature() Returns the list of parameters for this operation.
int | hashCode()
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

INFO

public static final int INFO
Indicates that the operation is read-like, it basically returns information.

See Also:
Constant Field Values

ACTION

public static final int ACTION
Indicates that the operation is a write-like, and would modify the MBean in some way, typically by writing some value or changing a configuration.

See Also:
Constant Field Values

ACTION_INFO

public static final int ACTION_INFO
Indicates that the operation is both read-like and write-like.

See Also:
Constant Field Values

UNKNOWN

public static final int UNKNOWN
Indicates that the operation has an "unknown" nature.

See Also:
Constant Field Values
Constructor Detail

MBeanOperationInfo

public MBeanOperationInfo(String description,
                          Method method)
                   throws IllegalArgumentException
Constructs an MBeanOperationInfo object.

Parameters:
method - The java.lang.reflect.Method object describing the MBean operation.
description - A human readable description of the operation.
Throws:
IllegalArgumentException - if the name of method is not a valid Java identifier, or if the name of its return type or one of its parameter types is not a syntactically legal Java type name. Java reserved words are not considered illegal here. If method comes from a class compiled from Java, this exception cannot happen.

MBeanOperationInfo

public MBeanOperationInfo(String name,
                          String description,
                          MBeanParameterInfo[] signature,
                          String type,
                          int impact)
                   throws IllegalArgumentException
Constructs an MBeanOperationInfo object.

Parameters:
name - The name of the method.
description - A human readable description of the operation.
signature - MBeanParameterInfo objects describing the parameters(arguments) of the method. This may be null with the same effect as a zero-length array.
type - The type of the method's return value.
impact - The impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN.
Throws:
IllegalArgumentException - if name is not a valid Java identifier or if type is not a syntactically legal Java type name. Java reserved words are not considered illegal here.
Method Detail

clone

public Object clone()

Returns a shallow clone of this instance. The clone is obtained by simply calling super.clone(), thus calling the default native shallow cloning mechanism implemented by Object.clone(). No deeper cloning of any internal field is made.

Since this class is immutable, cloning is chiefly of interest to subclasses.

getReturnType

public String getReturnType()
Returns the type of the method's return value.

Returns:
the return type.

getSignature

public MBeanParameterInfo[] getSignature()

Returns the list of parameters for this operation. Each parameter is described by an MBeanParameterInfo object.

The returned array is a shallow copy of the internal array, which means that it is a copy of the internal array of references to the MBeanParameterInfo objects but that each referenced MBeanParameterInfo object is not copied.

Returns:
An array of MBeanParameterInfo objects.

getImpact

public int getImpact()
Returns the impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN.

Returns:
the impact code.

equals

public boolean equals(Object o)
Compare this MBeanOperationInfo to another.

Overrides:
equals in class MBeanFeatureInfo
Parameters:
o - the object to compare to.
Returns:
true iff o is an MBeanOperationInfo such that its MBeanFeatureInfo.getName(), getReturnType(), MBeanFeatureInfo.getDescription(), getImpact(), and getSignature() values are equal (not necessarily identical) to those of this MBeanConstructorInfo. Two signature arrays are equal if their elements are pairwise equal.

hashCode

public int hashCode()
Overrides:
hashCode in class MBeanFeatureInfo
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanParameterInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanParameterInfo

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanParameterInfo
All Implemented Interfaces:
Cloneable, Serializable
Direct Known Subclasses:
OpenMBeanParameterInfoSupport
public class MBeanParameterInfo
extends MBeanFeatureInfo
implements Serializable, Cloneable

Describes an argument of an operation exposed by an MBean. Instances of this class are immutable. Subclasses may be mutable but this is not recommended.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
MBeanParameterInfo(String name, String type, String description)
Constructs a MBeanParameterInfo object.
Method Summary
Object | clone() Returns a shallow clone of this instance.
boolean | equals(Object o) Compare this MBeanParameterInfo to another.
String | getType() Returns the type or class name of the data.
int | hashCode()
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MBeanParameterInfo

public MBeanParameterInfo(String name,
                          String type,
                          String description)
                   throws IllegalArgumentException
Constructs a MBeanParameterInfo object.

Parameters:
name - The name of the data
type - The type or class name of the data
description - A human readable description of the data. Optional.
Throws:
IllegalArgumentException - if name is not a valid Java identifier or if type is not a syntactically legal Java type name. Java reserved words are not considered illegal here.
Method Detail

clone

public Object clone()

Returns a shallow clone of this instance. The clone is obtained by simply calling super.clone(), thus calling the default native shallow cloning mechanism implemented by Object.clone(). No deeper cloning of any internal field is made.

Since this class is immutable, cloning is chiefly of interest to subclasses.

getType

public String getType()
Returns the type or class name of the data.

Returns:
the type string.

equals

public boolean equals(Object o)
Compare this MBeanParameterInfo to another.

Overrides:
equals in class MBeanFeatureInfo
Parameters:
o - the object to compare to.
Returns:
true iff o is an MBeanParameterInfo such that its MBeanFeatureInfo.getName(), getType(), and MBeanFeatureInfo.getDescription() values are equal (not necessarily identical) to those of this MBeanParameterInfo.

hashCode

public int hashCode()
Overrides:
hashCode in class MBeanFeatureInfo
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanPermission

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanPermission

java.lang.Object
    extended by java.security.Permission
        extended by javax.management.MBeanPermission
All Implemented Interfaces:
Guard, Serializable
public class MBeanPermission
extends Permission

Permission controlling access to MBeanServer operations. If a security manager has been set using System.setSecurityManager(java.lang.SecurityManager), most operations on the MBean Server require that the caller's permissions imply an MBeanPermission appropriate for the operation. This is described in detail in the documentation for the MBeanServer interface.

As with other Permission objects, an MBeanPermission can represent either a permission that you have or a permission that you need. When a sensitive operation is being checked for permission, an MBeanPermission is constructed representing the permission you need. The operation is only allowed if the permissions you have imply the permission you need.

An MBeanPermission contains four items of information:

  • The action. For a permission you need, this is one of the actions in the list below. For a permission you have, this is a comma-separated list of those actions, or *, representing all actions.

    The action is returned by getActions().

  • The class name.

    For a permission you need, this is the class name of an MBean you are accessing, as returned by MBeanServer.getMBeanInfo(name).getClassName(). Certain operations do not reference a class name, in which case the class name is null.

    For a permission you have, this is either empty or a class name pattern. A class name pattern is a string following the Java conventions for dot-separated class names. It may end with ".*" meaning that the permission grants access to any class that begins with the string preceding ".*". For instance, "javax.management.*" grants access to javax.management.MBeanServerDelegate and javax.management.timer.Timer, among other classes.

    A class name pattern can also be empty or the single character "*", both of which grant access to any class.

  • The member.

    For a permission you need, this is the name of the attribute or operation you are accessing. For operations that do not reference an attribute or operation, the member is null.

    For a permission you have, this is either the name of an attribute or operation you can access, or it is empty or the single character "*", both of which grant access to any member.

  • The object name.

    For a permission you need, this is the ObjectName of the MBean you are accessing. For operations that do not reference a single MBean, it is null. It is never an object name pattern.

    For a permission you have, this is the ObjectName of the MBean or MBeans you can access. It may be an object name pattern to grant access to all MBeans whose names match the pattern. It may also be empty, which grants access to all MBeans whatever their name.

If you have an MBeanPermission, it allows operations only if all four of the items match.

The class name, member, and object name can be written together as a single string, which is the name of this permission. The name of the permission is the string returned by getName(). The format of the string is:

className#member[objectName]

The object name is written using the usual syntax for ObjectName. It may contain any legal characters, including ]. It is terminated by a ] character that is the last character in the string.

One or more of the className, member, or objectName may be omitted. If the member is omitted, the # may be too (but does not have to be). If the objectName is omitted, the [] may be too (but does not have to be). It is not legal to omit all three items, that is to have a name that is the empty string.

One or more of the className, member, or objectName may be the character "-", which is equivalent to a null value. A null value is implied by any value (including another null value) but does not imply any other value.

The possible actions are these:

  • addNotificationListener
  • getAttribute
  • getClassLoader
  • getClassLoaderFor
  • getClassLoaderRepository
  • getDomains
  • getMBeanInfo
  • getObjectInstance
  • instantiate
  • invoke
  • isInstanceOf
  • queryMBeans
  • queryNames
  • registerMBean
  • removeNotificationListener
  • setAttribute
  • unregisterMBean

In a comma-separated list of actions, spaces are allowed before and after each action.

Since:
JMX 1.2
See Also:
Serialized Form

Constructor Summary
MBeanPermission(String name, String actions)
Create a new MBeanPermission object with the specified target name and actions.
MBeanPermission(String className, String member, ObjectName objectName, String actions)
Create a new MBeanPermission object with the specified target name (class name, member, object name) and actions.
Method Summary
boolean | equals(Object obj) Checks two MBeanPermission objects for equality.
String | getActions() Returns the "canonical string representation" of the actions.
int | hashCode() Returns the hash code value for this object.
boolean | implies(Permission p) Checks if this MBeanPermission object "implies" the specified permission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MBeanPermission

public MBeanPermission(String name,
                       String actions)

Create a new MBeanPermission object with the specified target name and actions.

The target name is of the form "className#member[objectName]" where each part is optional. It must not be empty or null.

The actions parameter contains a comma-separated list of the desired actions granted on the target name. It must not be empty or null.

Parameters:
name - the triplet "className#member[objectName]".
actions - the action string.
Throws:
IllegalArgumentException - if the name or actions is invalid.

MBeanPermission

public MBeanPermission(String className,
                       String member,
                       ObjectName objectName,
                       String actions)

Create a new MBeanPermission object with the specified target name (class name, member, object name) and actions.

The class name, member and object name parameters define a target name of the form "className#member[objectName]" where each part is optional. This will be the result of Permission.getName() on the resultant MBeanPermission.

The actions parameter contains a comma-separated list of the desired actions granted on the target name. It must not be empty or null.

Parameters:
className - the class name to which this permission applies. May be null or "-", which represents a class name that is implied by any class name but does not imply any other class name.
member - the member to which this permission applies. May be null or "-", which represents a member that is implied by any member but does not imply any other member.
objectName - the object name to which this permission applies. May be null, which represents an object name that is implied by any object name but does not imply any other object name.
actions - the action string.
Method Detail

getActions

public String getActions()
Returns the "canonical string representation" of the actions. That is, this method always returns present actions in alphabetical order.

Returns:
the canonical string representation of the actions.

hashCode

public int hashCode()
Returns the hash code value for this object.

Returns:
a hash code value for this object.

implies

public boolean implies(Permission p)

Checks if this MBeanPermission object "implies" the specified permission.

More specifically, this method returns true if:

  • p is an instance of MBeanPermission; and
  • p has a null className or p's className matches this object's className; and
  • p has a null member or p's member matches this object's member; and
  • p has a null object name name or or p's object name matches this object's object name; and
  • p's actions are a subset of this object's actions

If this object's className is "*", p's className always matches it. If it is "a.*", p's className matches it if it begins with "a.".

If this object's member is "*", p's member always matches it.

If this object's objectName n1 is an object name pattern, p's objectName n2 matches it if n1.equals(n2) or if n1.apply(n2).

A permission that includes the queryMBeans action is considered to include queryNames as well.

Parameters:
p - the permission to check against.
Returns:
true if the specified permission is implied by this object, false if not.

equals

public boolean equals(Object obj)
Checks two MBeanPermission objects for equality. Checks that obj is an MBeanPermission, and has the same name and actions as this object.

Parameters:
obj - the object we are testing for equality with this object.
Returns:
true if obj is an MBeanPermission, and has the same name and actions as this MBeanPermission object.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanRegistration

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface MBeanRegistration

All Known Implementing Classes:
MLet, Monitor, RelationService, RelationSupport, RequiredModelMBean, Timer
public interface MBeanRegistration

Can be implemented by an MBean in order to carry out operations before and after being registered or unregistered from the MBean server.

Method Summary
void | postDeregister() Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
void | postRegister(Boolean registrationDone) Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
void | preDeregister() Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
ObjectName | preRegister(MBeanServer server, ObjectName name) Allows the MBean to perform any operations it needs before being registered in the MBean server.

Method Detail

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
Allows the MBean to perform any operations it needs before being registered in the MBean server. If the name of the MBean is not specified, the MBean can provide a name for its registration. If any exception is raised, the MBean will not be registered in the MBean server.

Parameters:
server - The MBean server in which the MBean will be registered.
name - The object name of the MBean. This name is null if the name parameter to one of the createMBean or registerMBean methods in the MBeanServer interface is null. In that case, this method must return a non-null ObjectName for the new MBean.
Returns:
The name under which the MBean is to be registered. This value must not be null. If the name parameter is not null, it will usually but not necessarily be the returned value.
Throws:
Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException or a RuntimeMBeanException.

postRegister

public void postRegister(Boolean registrationDone)
Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

Parameters:
registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

preDeregister

public void preDeregister()
                   throws Exception
Allows the MBean to perform any operations it needs before being unregistered by the MBean server.

Throws:
Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException or a RuntimeMBeanException.

postDeregister

public void postDeregister()
Allows the MBean to perform any operations needed after having been unregistered in the MBean server.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanRegistrationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanRegistrationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.MBeanException
                    extended by javax.management.MBeanRegistrationException
All Implemented Interfaces:
Serializable
public class MBeanRegistrationException
extends MBeanException

Wraps exceptions thrown by the preRegister(), preDeregister() methods of the MBeanRegistration interface.

See Also:
Serialized Form

Constructor Summary
MBeanRegistrationException(Exception e)
Creates an MBeanRegistrationException that wraps the actual java.lang.Exception.
MBeanRegistrationException(Exception e, String message)
Creates an MBeanRegistrationException that wraps the actual java.lang.Exception with a detailed message.
Methods inherited from class javax.management.MBeanException
getCause, getTargetException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MBeanRegistrationException

public MBeanRegistrationException(Exception e)
Creates an MBeanRegistrationException that wraps the actual java.lang.Exception.

Parameters:
e - the wrapped exception.

MBeanRegistrationException

public MBeanRegistrationException(Exception e,
                                  String message)
Creates an MBeanRegistrationException that wraps the actual java.lang.Exception with a detailed message.

Parameters:
e - the wrapped exception.
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanServer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface MBeanServer

All Superinterfaces:
MBeanServerConnection
public interface MBeanServer
extends MBeanServerConnection

This is the interface for MBean manipulation on the agent side. It contains the methods necessary for the creation, registration, and deletion of MBeans as well as the access methods for registered MBeans. This is the core component of the JMX infrastructure.

User code does not usually implement this interface. Instead, an object that implements this interface is obtained with one of the methods in the MBeanServerFactory class.

Every MBean which is added to the MBean server becomes manageable: its attributes and operations become remotely accessible through the connectors/adaptors connected to that MBean server. A Java object cannot be registered in the MBean server unless it is a JMX compliant MBean.

When an MBean is registered or unregistered in the MBean server a MBeanServerNotification Notification is emitted. To register an object as listener to MBeanServerNotifications you should call the MBean server method addNotificationListener with ObjectName the ObjectName of the MBeanServerDelegate. This ObjectName is:
JMImplementation:type=MBeanServerDelegate.

An object obtained from the createMBeanServer or newMBeanServer methods of the MBeanServerFactory class applies security checks to its methods, as follows.

First, if there is no security manager (System.getSecurityManager() is null), then no checks are made.

Assuming there is a security manager, the checks are made as detailed below. In what follows, className is the string returned by MBeanInfo.getClassName() for the target MBean.

If a security check fails, the method throws SecurityException.

For methods that can throw InstanceNotFoundException, this exception is thrown for a non-existent MBean, regardless of permissions. This is because a non-existent MBean has no className.

  • For the invoke method, the caller's permissions must imply MBeanPermission(className, operationName, name, "invoke").

  • For the getAttribute method, the caller's permissions must imply MBeanPermission(className, attribute, name, "getAttribute").

  • For the getAttributes method, the caller's permissions must imply MBeanPermission(className, null, name, "getAttribute"). Additionally, for each attribute a in the AttributeList, if the caller's permissions do not imply MBeanPermission(className, a, name, "getAttribute"), the MBean server will behave as if that attribute had not been in the supplied list.

  • For the setAttribute method, the caller's permissions must imply MBeanPermission(className, attrName, name, "getAttribute"), where attrName is attribute.getName().

  • For the setAttributes method, the caller's permissions must imply MBeanPermission(className, null, name, "setAttribute"). Additionally, for each attribute a in the AttributeList, if the caller's permissions do not imply MBeanPermission(className, a, name, "setAttribute"), the MBean server will behave as if that attribute had not been in the supplied list.

  • For the addNotificationListener methods, the caller's permissions must imply MBeanPermission(className, null, name, "addNotificationListener").

  • For the removeNotificationListener methods, the caller's permissions must imply MBeanPermission(className, null, name, "removeNotificationListener").

  • For the getMBeanInfo method, the caller's permissions must imply MBeanPermission(className, null, name, "getMBeanInfo").

  • For the getObjectInstance method, the caller's permissions must imply MBeanPermission(className, null, name, "getObjectInstance").

  • For the isInstanceOf method, the caller's permissions must imply MBeanPermission(className, null, name, "isInstanceOf").

  • For the queryMBeans method, the caller's permissions must imply MBeanPermission(null, null, name, "queryMBeans"). Additionally, for each MBean that matches name, if the caller's permissions do not imply MBeanPermission(className, null, name, "queryMBeans"), the MBean server will behave as if that MBean did not exist.

    Certain query elements perform operations on the MBean server. If the caller does not have the required permissions for a given MBean, that MBean will not be included in the result of the query. The standard query elements that are affected are Query.attr(String), Query.attr(String,String), and Query.classattr().

  • For the queryNames method, the checks are the same as for queryMBeans except that "queryNames" is used instead of "queryMBeans" in the MBeanPermission objects. Note that a "queryMBeans" permission implies the corresponding "queryNames" permission.

  • For the getDomains method, the caller's permissions must imply MBeanPermission(null, null, name, "getDomains"). Additionally, for each domain d in the returned array, if the caller's permissions do not imply MBeanPermission(null, null, new ObjectName("d:x=x"), "queryMBeans"), the domain is eliminated from the array. Here, x=x is any key=value pair, needed to satisfy ObjectName's constructor but not otherwise relevant.

  • For the getClassLoader method, the caller's permissions must imply MBeanPermission(className, null, loaderName, "getClassLoader").

  • For the getClassLoaderFor method, the caller's permissions must imply MBeanPermission(className, null, mbeanName, "getClassLoaderFor").

  • For the getClassLoaderRepository method, the caller's permissions must imply MBeanPermission(null, null, null, "getClassLoaderRepository").

  • For the deprecated deserialize methods, the required permissions are the same as for the methods that replace them.

  • For the instantiate methods, the caller's permissions must imply MBeanPermission(className, null, null, "instantiate").

  • For the registerMBean method, the caller's permissions must imply MBeanPermission(className, null, name, "registerMBean"). Here className is the string returned by MBeanInfo.getClassName() for an object of this class.

    If the MBeanPermission check succeeds, the MBean's class is validated by checking that its ProtectionDomain implies MBeanTrustPermission("register").

    Finally, if the name argument is null, another MBeanPermission check is made using the ObjectName returned by MBeanRegistration.preRegister.

  • For the createMBean methods, the caller's permissions must imply the permissions needed by the equivalent instantiate followed by registerMBean.

  • For the unregisterMBean method, the caller's permissions must imply MBeanPermission(className, null, name, "unregisterMBean").

Method Summary
 void addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
Adds a listener to a registered MBean.
 void addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
Adds a listener to a registered MBean.
 ObjectInstance createMBean(String className, ObjectName name)
Instantiates and registers an MBean in the MBean server.
 ObjectInstance createMBean(String className, ObjectName name, Object[] params, String[] signature)
Instantiates and registers an MBean in the MBean server.
 ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName)
Instantiates and registers an MBean in the MBean server.
 ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
Instantiates and registers an MBean in the MBean server.
 ObjectInputStream deserialize(ObjectName name, byte[] data)
Deprecated. Use getClassLoaderFor to obtain the appropriate class loader for deserialization.
 ObjectInputStream deserialize(String className, byte[] data)
Deprecated. Use getClassLoaderRepository() to obtain the class loader repository and use it to deserialize.
 ObjectInputStream deserialize(String className, ObjectName loaderName, byte[] data)
Deprecated. Use getClassLoader to obtain the class loader for deserialization.
 Object getAttribute(ObjectName name, String attribute)
Gets the value of a specific attribute of a named MBean.
 AttributeList getAttributes(ObjectName name, String[] attributes)
Gets the values of several attributes of a named MBean.
 ClassLoader getClassLoader(ObjectName loaderName)
Return the named ClassLoader.
 ClassLoader getClassLoaderFor(ObjectName mbeanName)
Return the ClassLoader that was used for loading the class of the named MBean.
 ClassLoaderRepository getClassLoaderRepository()
Return the ClassLoaderRepository for this MBeanServer.
 String getDefaultDomain()
Returns the default domain used for naming the MBean.
 String[] getDomains()
Returns the list of domains in which any MBean is currently registered.
 Integer getMBeanCount()
Returns the number of MBeans registered in the MBean server.
 MBeanInfo getMBeanInfo(ObjectName name)
This method discovers the attributes and operations that an MBean exposes for management.
 ObjectInstance getObjectInstance(ObjectName name)
Gets the ObjectInstance for a given MBean registered with the MBean server.
 Object instantiate(String className)
Instantiates an object using the list of all class loaders registered in the MBean server's Class Loader Repository.
 Object instantiate(String className, Object[] params, String[] signature)
Instantiates an object using the list of all class loaders registered in the MBean server Class Loader Repository.
 Object instantiate(String className, ObjectName loaderName)
Instantiates an object using the class Loader specified by its ObjectName.
 Object instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
Instantiates an object.
 Object invoke(ObjectName name, String operationName, Object[] params, String[] signature)
Invokes an operation on an MBean.
 boolean isInstanceOf(ObjectName name, String className)
Returns true if the MBean specified is an instance of the specified class, false otherwise.
 boolean isRegistered(ObjectName name)
Checks whether an MBean, identified by its object name, is already registered with the MBean server.
 Set queryMBeans(ObjectName name, QueryExp query)
Gets MBeans controlled by the MBean server.
 Set queryNames(ObjectName name, QueryExp query)
Gets the names of MBeans controlled by the MBean server.
 ObjectInstance registerMBean(Object object, ObjectName name)
Registers a pre-existing object as an MBean with the MBean server.
 void removeNotificationListener(ObjectName name, NotificationListener listener)
Removes a listener from a registered MBean.
 void removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
Removes a listener from a registered MBean.
 void removeNotificationListener(ObjectName name, ObjectName listener)
Removes a listener from a registered MBean.
 void removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
Removes a listener from a registered MBean.
 void setAttribute(ObjectName name, Attribute attribute)
Sets the value of a specific attribute of a named MBean.
 AttributeList setAttributes(ObjectName name, AttributeList attributes)
Sets the values of several attributes of a named MBean.
 void unregisterMBean(ObjectName name)
Unregisters an MBean from the MBean server.

Method Detail

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException

Instantiates and registers an MBean in the MBean server. The MBean server will use its Default Loader Repository to load the class of the MBean. An object name is associated to the MBean. If the object name given is null, the MBean must provide its own name by implementing the MBeanRegistration interface and returning the name from the preRegister method.

This method is equivalent to createMBean(className, name, (Object[]) null, (String[]) null).

Specified by:
createMBean in interface MBeanServerConnection
Parameters:
className - The class name of the MBean to be instantiated.
name - The object name of the MBean. May be null.
Returns:
An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
MBeanException - The constructor of the MBean has thrown an exception
NotCompliantMBeanException - This class is not a JMX compliant MBean
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern or no ObjectName is specified for the MBean.

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name,
                                  ObjectName loaderName)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException

Instantiates and registers an MBean in the MBean server. The class loader to be used is identified by its object name. An object name is associated to the MBean. If the object name of the loader is null, the ClassLoader that loaded the MBean server will be used. If the MBean's object name given is null, the MBean must provide its own name by implementing the MBeanRegistration interface and returning the name from the preRegister method.

This method is equivalent to createMBean(className, name, loaderName, (Object[]) null, (String[]) null).

Specified by:
createMBean in interface MBeanServerConnection
Parameters:
className - The class name of the MBean to be instantiated.
name - The object name of the MBean. May be null.
loaderName - The object name of the class loader to be used.
Returns:
An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
MBeanException - The constructor of the MBean has thrown an exception
NotCompliantMBeanException - This class is not a JMX compliant MBean
InstanceNotFoundException - The specified class loader is not registered in the MBean server.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern or no ObjectName is specified for the MBean.

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name,
                                  Object[] params,
                                  String[] signature)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException
Instantiates and registers an MBean in the MBean server. The MBean server will use its Default Loader Repository to load the class of the MBean. An object name is associated to the MBean. If the object name given is null, the MBean must provide its own name by implementing the MBeanRegistration interface and returning the name from the preRegister method.

Specified by:
createMBean in interface MBeanServerConnection
Parameters:
className - The class name of the MBean to be instantiated.
name - The object name of the MBean. May be null.
params - An array containing the parameters of the constructor to be invoked.
signature - An array containing the signature of the constructor to be invoked.
Returns:
An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
MBeanException - The constructor of the MBean has thrown an exception
NotCompliantMBeanException - This class is not a JMX compliant MBean
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern or no ObjectName is specified for the MBean.

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name,
                                  ObjectName loaderName,
                                  Object[] params,
                                  String[] signature)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException
Instantiates and registers an MBean in the MBean server. The class loader to be used is identified by its object name. An object name is associated to the MBean. If the object name of the loader is not specified, the ClassLoader that loaded the MBean server will be used. If the MBean object name given is null, the MBean must provide its own name by implementing the MBeanRegistration interface and returning the name from the preRegister method.

Specified by:
createMBean in interface MBeanServerConnection
Parameters:
className - The class name of the MBean to be instantiated.
name - The object name of the MBean. May be null.
params - An array containing the parameters of the constructor to be invoked.
signature - An array containing the signature of the constructor to be invoked.
loaderName - The object name of the class loader to be used.
Returns:
An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
MBeanException - The constructor of the MBean has thrown an exception
NotCompliantMBeanException - This class is not a JMX compliant MBean
InstanceNotFoundException - The specified class loader is not registered in the MBean server.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern or no ObjectName is specified for the MBean.

registerMBean

public ObjectInstance registerMBean(Object object,
                                    ObjectName name)
                             throws InstanceAlreadyExistsException,
                                    MBeanRegistrationException,
                                    NotCompliantMBeanException
Registers a pre-existing object as an MBean with the MBean server. If the object name given is null, the MBean must provide its own name by implementing the MBeanRegistration interface and returning the name from the preRegister method.

Parameters:
object - The MBean to be registered as an MBean.
name - The object name of the MBean. May be null.
Returns:
An ObjectInstance, containing the ObjectName and the Java class name of the newly registered MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
Throws:
InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
NotCompliantMBeanException - This object is not a JMX compliant MBean
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object passed in parameter is null or no object name is specified.

unregisterMBean

public void unregisterMBean(ObjectName name)
                     throws InstanceNotFoundException,
                            MBeanRegistrationException
Unregisters an MBean from the MBean server. The MBean is identified by its object name. Once the method has been invoked, the MBean may no longer be accessed by its object name.

Specified by:
unregisterMBean in interface MBeanServerConnection
Parameters:
name - The object name of the MBean to be unregistered.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
MBeanRegistrationException - The preDeregister ((MBeanRegistration interface) method of the MBean has thrown an exception.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or the MBean you are when trying to unregister is the MBeanServerDelegate MBean.

getObjectInstance

public ObjectInstance getObjectInstance(ObjectName name)
                                 throws InstanceNotFoundException
Gets the ObjectInstance for a given MBean registered with the MBean server.

Specified by:
getObjectInstance in interface MBeanServerConnection
Parameters:
name - The object name of the MBean.
Returns:
The ObjectInstance associated with the MBean specified by name. The contained ObjectName is name and the contained class name is getMBeanInfo(name).getClassName().
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.

queryMBeans

public Set queryMBeans(ObjectName name,
                       QueryExp query)
Gets MBeans controlled by the MBean server. This method allows any of the following to be obtained: All MBeans, a set of MBeans specified by pattern matching on the ObjectName and/or a Query expression, a specific MBean. When the object name is null or no domain and key properties are specified, all objects are to be selected (and filtered if a query is specified). It returns the set of ObjectInstance objects (containing the ObjectName and the Java Class name) for the selected MBeans.

Specified by:
queryMBeans in interface MBeanServerConnection
Parameters:
name - The object name pattern identifying the MBeans to be retrieved. If null or no domain and key properties are specified, all the MBeans registered will be retrieved.
query - The query expression to be applied for selecting MBeans. If null no query expression will be applied for selecting MBeans.
Returns:
A set containing the ObjectInstance objects for the selected MBeans. If no MBean satisfies the query an empty set is returned.

queryNames

public Set queryNames(ObjectName name,
                      QueryExp query)
Gets the names of MBeans controlled by the MBean server. This method enables any of the following to be obtained: The names of all MBeans, the names of a set of MBeans specified by pattern matching on the ObjectName and/or a Query expression, a specific MBean name (equivalent to testing whether an MBean is registered). When the object name is null or no domain and key properties are specified, all objects are selected (and filtered if a query is specified). It returns the set of ObjectNames for the MBeans selected.

Specified by:
queryNames in interface MBeanServerConnection
Parameters:
name - The object name pattern identifying the MBean names to be retrieved. If null oror no domain and key properties are specified, the name of all registered MBeans will be retrieved.
query - The query expression to be applied for selecting MBeans. If null no query expression will be applied for selecting MBeans.
Returns:
A set containing the ObjectNames for the MBeans selected. If no MBean satisfies the query, an empty set is returned.

isRegistered

public boolean isRegistered(ObjectName name)
Checks whether an MBean, identified by its object name, is already registered with the MBean server.

Specified by:
isRegistered in interface MBeanServerConnection
Parameters:
name - The object name of the MBean to be checked.
Returns:
True if the MBean is already registered in the MBean server, false otherwise.
Throws:
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null.

getMBeanCount

public Integer getMBeanCount()
Returns the number of MBeans registered in the MBean server.

Specified by:
getMBeanCount in interface MBeanServerConnection
Returns:
the number of registered MBeans, wrapped in an Integer. If the caller's permissions are restricted, this number may be greater than the number of MBeans the caller can access.

getAttribute

public Object getAttribute(ObjectName name,
                           String attribute)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException
Gets the value of a specific attribute of a named MBean. The MBean is identified by its object name.

Specified by:
getAttribute in interface MBeanServerConnection
Parameters:
name - The object name of the MBean from which the attribute is to be retrieved.
attribute - A String specifying the name of the attribute to be retrieved.
Returns:
The value of the retrieved attribute.
Throws:
AttributeNotFoundException - The attribute specified is not accessible in the MBean.
MBeanException - Wraps an exception thrown by the MBean's getter.
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
ReflectionException - Wraps a java.lang.Exception thrown when trying to invoke the setter.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or the attribute in parameter is null.
See Also:
setAttribute(javax.management.ObjectName, javax.management.Attribute)

getAttributes

public AttributeList getAttributes(ObjectName name,
                                   String[] attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException
Gets the values of several attributes of a named MBean. The MBean is identified by its object name.

Specified by:
getAttributes in interface MBeanServerConnection
Parameters:
name - The object name of the MBean from which the attributes are retrieved.
attributes - A list of the attributes to be retrieved.
Returns:
The list of the retrieved attributes.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
RuntimeOperationsException - Wrap a java.lang.IllegalArgumentException: The object name in parameter is null or attributes in parameter is null.
See Also:
setAttributes(javax.management.ObjectName, javax.management.AttributeList)

setAttribute

public void setAttribute(ObjectName name,
                         Attribute attribute)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
Sets the value of a specific attribute of a named MBean. The MBean is identified by its object name.

Specified by:
setAttribute in interface MBeanServerConnection
Parameters:
name - The name of the MBean within which the attribute is to be set.
attribute - The identification of the attribute to be set and the value it is to be set to.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
AttributeNotFoundException - The attribute specified is not accessible in the MBean.
InvalidAttributeValueException - The value specified for the attribute is not valid.
MBeanException - Wraps an exception thrown by the MBean's setter.
ReflectionException - Wraps a java.lang.Exception thrown when trying to invoke the setter.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or the attribute in parameter is null.
See Also:
getAttribute(javax.management.ObjectName, java.lang.String)

setAttributes

public AttributeList setAttributes(ObjectName name,
                                   AttributeList attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException
Sets the values of several attributes of a named MBean. The MBean is identified by its object name.

Specified by:
setAttributes in interface MBeanServerConnection
Parameters:
name - The object name of the MBean within which the attributes are to be set.
attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to.
Returns:
The list of attributes that were set, with their new values.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or attributes in parameter is null.
See Also:
getAttributes(javax.management.ObjectName, java.lang.String[])

invoke

public Object invoke(ObjectName name,
                     String operationName,
                     Object[] params,
                     String[] signature)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException
Invokes an operation on an MBean.

Specified by:
invoke in interface MBeanServerConnection
Parameters:
name - The object name of the MBean on which the method is to be invoked.
operationName - The name of the operation to be invoked.
params - An array containing the parameters to be set when the operation is invoked
signature - An array containing the signature of the operation. The class objects will be loaded using the same class loader as the one used for loading the MBean on which the operation was invoked.
Returns:
The object returned by the operation, which represents the result ofinvoking the operation on the MBean specified.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
MBeanException - Wraps an exception thrown by the MBean's invoked method.
ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the method.

getDefaultDomain

public String getDefaultDomain()
Returns the default domain used for naming the MBean. The default domain name is used as the domain part in the ObjectName of MBeans if no domain is specified by the user.

Specified by:
getDefaultDomain in interface MBeanServerConnection
Returns:
the default domain.

getDomains

public String[] getDomains()

Returns the list of domains in which any MBean is currently registered. A string is in the returned array if and only if there is at least one MBean registered with an ObjectName whose getDomain() is equal to that string. The order of strings within the returned array is not defined.

Specified by:
getDomains in interface MBeanServerConnection
Returns:
the list of domains.
Since:
JMX 1.2

addNotificationListener

public void addNotificationListener(ObjectName name,
                                    NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
                             throws InstanceNotFoundException

Adds a listener to a registered MBean.

A notification emitted by the MBean will be forwarded by the MBeanServer to the listener. If the source of the notification is a reference to the MBean object, the MBean server will replace it by the MBean's ObjectName. Otherwise the source is unchanged.

Specified by:
addNotificationListener in interface MBeanServerConnection
Parameters:
name - The name of the MBean on which the listener should be added.
listener - The listener object which will handle the notifications emitted by the registered MBean.
filter - The filter object. If filter is null, no filtering will be performed before handling notifications.
handback - The context to be sent to the listener when a notification is emitted.
Throws:
InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
See Also:
removeNotificationListener(ObjectName, NotificationListener), removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

addNotificationListener

public void addNotificationListener(ObjectName name,
                                    ObjectName listener,
                                    NotificationFilter filter,
                                    Object handback)
                             throws InstanceNotFoundException

Adds a listener to a registered MBean.

A notification emitted by the MBean will be forwarded by the MBeanServer to the listener. If the source of the notification is a reference to the MBean object, the MBean server will replace it by the MBean's ObjectName. Otherwise the source is unchanged.

The listener object that receives notifications is the one that is registered with the given name at the time this method is called. Even if it is subsequently unregistered, it will continue to receive notifications.

Specified by:
addNotificationListener in interface MBeanServerConnection
Parameters:
name - The name of the MBean on which the listener should be added.
listener - The object name of the listener which will handle the notifications emitted by the registered MBean.
filter - The filter object. If filter is null, no filtering will be performed before handling notifications.
handback - The context to be sent to the listener when a notification is emitted.
Throws:
InstanceNotFoundException - The MBean name of the notification listener or of the notification broadcaster does not match any of the registered MBeans.
RuntimeOperationsException - Wraps an IllegalArgumentException. The MBean named by listener exists but does not implement the NotificationListener interface.
See Also:
removeNotificationListener(ObjectName, ObjectName), removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       ObjectName listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException
Removes a listener from a registered MBean.

If the listener is registered more than once, perhaps with different filters or callbacks, this method will remove all those registrations.

Specified by:
removeNotificationListener in interface MBeanServerConnection
Parameters:
name - The name of the MBean on which the listener should be removed.
listener - The object name of the listener to be removed.
Throws:
InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
ListenerNotFoundException - The listener is not registered in the MBean.
See Also:
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       ObjectName listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException

Removes a listener from a registered MBean.

The MBean must have a listener that exactly matches the given listener, filter, and handback parameters. If there is more than one such listener, only one is removed.

The filter and handback parameters may be null if and only if they are null in a listener to be removed.

Specified by:
removeNotificationListener in interface MBeanServerConnection
Parameters:
name - The name of the MBean on which the listener should be removed.
listener - A listener that was previously added to this MBean.
filter - The filter that was specified when the listener was added.
handback - The handback that was specified when the listener was added.
Throws:
InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
ListenerNotFoundException - The listener is not registered in the MBean, or it is not registered with the given filter and handback.
Since:
JMX 1.2
See Also:
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       NotificationListener listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException

Removes a listener from a registered MBean.

If the listener is registered more than once, perhaps with different filters or callbacks, this method will remove all those registrations.

Specified by:
removeNotificationListener in interface MBeanServerConnection
Parameters:
name - The name of the MBean on which the listener should be removed.
listener - The object name of the listener to be removed.
Throws:
InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
ListenerNotFoundException - The listener is not registered in the MBean.
See Also:
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException

Removes a listener from a registered MBean.

The MBean must have a listener that exactly matches the given listener, filter, and handback parameters. If there is more than one such listener, only one is removed.

The filter and handback parameters may be null if and only if they are null in a listener to be removed.

Specified by:
removeNotificationListener in interface MBeanServerConnection
Parameters:
name - The name of the MBean on which the listener should be removed.
listener - A listener that was previously added to this MBean.
filter - The filter that was specified when the listener was added.
handback - The handback that was specified when the listener was added.
Throws:
InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
ListenerNotFoundException - The listener is not registered in the MBean, or it is not registered with the given filter and handback.
Since:
JMX 1.2
See Also:
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

getMBeanInfo

public MBeanInfo getMBeanInfo(ObjectName name)
                       throws InstanceNotFoundException,
                              IntrospectionException,
                              ReflectionException
This method discovers the attributes and operations that an MBean exposes for management.

Specified by:
getMBeanInfo in interface MBeanServerConnection
Parameters:
name - The name of the MBean to analyze
Returns:
An instance of MBeanInfo allowing the retrieval of all attributes and operations of this MBean.
Throws:
IntrospectionException - An exception occured during introspection.
InstanceNotFoundException - The MBean specified was not found.
ReflectionException - An exception occurred when trying to invoke the getMBeanInfo of a Dynamic MBean.

isInstanceOf

public boolean isInstanceOf(ObjectName name,
                            String className)
                     throws InstanceNotFoundException

Returns true if the MBean specified is an instance of the specified class, false otherwise.

If name does not name an MBean, this method throws InstanceNotFoundException.

Otherwise, let
X be the MBean named by name,
L be the ClassLoader of X,
N be the class name in X's MBeanInfo.

If N equals className, the result is true.

Otherwise, if L successfully loads both N and className, and the second class is assignable from the first, the result is true.

Otherwise, the result is false.

Specified by:
isInstanceOf in interface MBeanServerConnection
Parameters:
name - The ObjectName of the MBean.
className - The name of the class.
Returns:
true if the MBean specified is an instance of the specified class according to the rules above, false otherwise.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
See Also:
Class.isAssignableFrom(Class)

instantiate

public Object instantiate(String className)
                   throws ReflectionException,
                          MBeanException

Instantiates an object using the list of all class loaders registered in the MBean server's Class Loader Repository. The object's class should have a public constructor. This method returns a reference to the newly created object. The newly created object is not registered in the MBean server.

This method is equivalent to instantiate(className, (Object[]) null, (String[]) null).

Parameters:
className - The class name of the object to be instantiated.
Returns:
The newly instantiated object.
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or the java.lang.Exception that occurred when trying to invoke the object's constructor.
MBeanException - The constructor of the object has thrown an exception
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null.

instantiate

public Object instantiate(String className,
                          ObjectName loaderName)
                   throws ReflectionException,
                          MBeanException,
                          InstanceNotFoundException

Instantiates an object using the class Loader specified by its ObjectName. If the loader name is null, the ClassLoader that loaded the MBean Server will be used. The object's class should have a public constructor. This method returns a reference to the newly created object. The newly created object is not registered in the MBean server.

This method is equivalent to instantiate(className, loaderName, (Object[]) null, (String[]) null).

Parameters:
className - The class name of the MBean to be instantiated.
loaderName - The object name of the class loader to be used.
Returns:
The newly instantiated object.
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or the java.lang.Exception that occurred when trying to invoke the object's constructor.
MBeanException - The constructor of the object has thrown an exception.
InstanceNotFoundException - The specified class loader is not registered in the MBeanServer.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null.

instantiate

public Object instantiate(String className,
                          Object[] params,
                          String[] signature)
                   throws ReflectionException,
                          MBeanException

Instantiates an object using the list of all class loaders registered in the MBean server Class Loader Repository. The object's class should have a public constructor. The call returns a reference to the newly created object. The newly created object is not registered in the MBean server.

Parameters:
className - The class name of the object to be instantiated.
params - An array containing the parameters of the constructor to be invoked.
signature - An array containing the signature of the constructor to be invoked.
Returns:
The newly instantiated object.
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or the java.lang.Exception that occurred when trying to invoke the object's constructor.
MBeanException - The constructor of the object has thrown an exception
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null.

instantiate

public Object instantiate(String className,
                          ObjectName loaderName,
                          Object[] params,
                          String[] signature)
                   throws ReflectionException,
                          MBeanException,
                          InstanceNotFoundException

Instantiates an object. The class loader to be used is identified by its object name. If the object name of the loader is null, the ClassLoader that loaded the MBean server will be used. The object's class should have a public constructor. The call returns a reference to the newly created object. The newly created object is not registered in the MBean server.

Parameters:
className - The class name of the object to be instantiated.
params - An array containing the parameters of the constructor to be invoked.
signature - An array containing the signature of the constructor to be invoked.
loaderName - The object name of the class loader to be used.
Returns:
The newly instantiated object.
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or the java.lang.Exception that occurred when trying to invoke the object's constructor.
MBeanException - The constructor of the object has thrown an exception
InstanceNotFoundException - The specified class loader is not registered in the MBean server.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null.

deserialize

public ObjectInputStream deserialize(ObjectName name,
                                     byte[] data)
                              throws InstanceNotFoundException,
                                     OperationsException
Deprecated. Use getClassLoaderFor to obtain the appropriate class loader for deserialization.

De-serializes a byte array in the context of the class loader of an MBean.

Parameters:
name - The name of the MBean whose class loader should be used for the de-serialization.
data - The byte array to be de-sererialized.
Returns:
The de-serialized object stream.
Throws:
InstanceNotFoundException - The MBean specified is not found.
OperationsException - Any of the usual Input/Output related exceptions.

deserialize

public ObjectInputStream deserialize(String className,
                                     byte[] data)
                              throws OperationsException,
                                     ReflectionException
Deprecated. Use getClassLoaderRepository() to obtain the class loader repository and use it to deserialize.

De-serializes a byte array in the context of a given MBean class loader. The class loader is found by loading the class className through the Class Loader Repository. The resultant class's class loader is the one to use.

Parameters:
className - The name of the class whose class loader should be used for the de-serialization.
data - The byte array to be de-sererialized.
Returns:
The de-serialized object stream.
Throws:
OperationsException - Any of the usual Input/Output related exceptions.
ReflectionException - The specified class could not be loaded by the class loader repository

deserialize

public ObjectInputStream deserialize(String className,
                                     ObjectName loaderName,
                                     byte[] data)
                              throws InstanceNotFoundException,
                                     OperationsException,
                                     ReflectionException
Deprecated. Use getClassLoader to obtain the class loader for deserialization.

De-serializes a byte array in the context of a given MBean class loader. The class loader is the one that loaded the class with name "className". The name of the class loader to be used for loading the specified class is specified. If null, the MBean Server's class loader will be used.

Parameters:
className - The name of the class whose class loader should be used for the de-serialization.
data - The byte array to be de-sererialized.
loaderName - The name of the class loader to be used for loading the specified class. If null, the MBean Server's class loader will be used.
Returns:
The de-serialized object stream.
Throws:
InstanceNotFoundException - The specified class loader MBean is not found.
OperationsException - Any of the usual Input/Output related exceptions.
ReflectionException - The specified class could not be loaded by the specified class loader.

getClassLoaderFor

public ClassLoader getClassLoaderFor(ObjectName mbeanName)
                              throws InstanceNotFoundException

Return the ClassLoader that was used for loading the class of the named MBean.

Parameters:
mbeanName - The ObjectName of the MBean.
Returns:
The ClassLoader used for that MBean. If l is the MBean's actual ClassLoader, and r is the returned value, then either:
  • r is identical to l; or
  • the result of r .loadClass(s) is the same as l .loadClass(s) for any string s.
What this means is that the ClassLoader may be wrapped in another ClassLoader for security or other reasons.
Throws:
InstanceNotFoundException - if the named MBean is not found.
Since:
JMX 1.2

getClassLoader

public ClassLoader getClassLoader(ObjectName loaderName)
                           throws InstanceNotFoundException

Return the named ClassLoader.

Parameters:
loaderName - The ObjectName of the ClassLoader. May be null, in which case the MBean server's own ClassLoader is returned.
Returns:
The named ClassLoader. If l is the actual ClassLoader with that name, and r is the returned value, then either:
  • r is identical to l; or
  • the result of r .loadClass(s) is the same as l .loadClass(s) for any string s.
What this means is that the ClassLoader may be wrapped in another ClassLoader for security or other reasons.
Throws:
InstanceNotFoundException - if the named ClassLoader is not found.
Since:
JMX 1.2

getClassLoaderRepository

public ClassLoaderRepository getClassLoaderRepository()

Return the ClassLoaderRepository for this MBeanServer.

Returns:
The ClassLoaderRepository for this MBeanServer.
Since:
JMX 1.2
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanServerBuilder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanServerBuilder

java.lang.Object
    extended by javax.management.MBeanServerBuilder
public class MBeanServerBuilder
extends Object

This class represents a builder that creates a default MBeanServer implementation. The JMX MBeanServerFactory allows applications to provide their custom MBeanServer implementation by providing a subclass of this class.

By default in this reference implementation, this class instantiates implementations provided in the com.sun.jmx.mbeanserver package.

Since:
JMX 1.2
See Also:
MBeanServer, MBeanServerFactory

Constructor Summary
MBeanServerBuilder()
Public default constructor.
Method Summary
MBeanServer | newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate) This method creates a new MBeanServer implementation object.
MBeanServerDelegate | newMBeanServerDelegate() This method creates a new MBeanServerDelegate for a new MBeanServer.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MBeanServerBuilder

public MBeanServerBuilder()
Public default constructor.

Method Detail

newMBeanServerDelegate

public MBeanServerDelegate newMBeanServerDelegate()
This method creates a new MBeanServerDelegate for a new MBeanServer. When creating a new MBeanServer the MBeanServerFactory first calls this method in order to create a new MBeanServerDelegate.
Then it calls newMBeanServer(defaultDomain,outer,delegate) passing the delegate that should be used by the MBeanServer implementation.

Note that the passed delegate might not be directly the MBeanServerDelegate that was returned by this method. It could be, for instance, a new object wrapping the previously returned object.

Returns:
A new MBeanServerDelegate.

newMBeanServer

public MBeanServer newMBeanServer(String defaultDomain,
                                  MBeanServer outer,
                                  MBeanServerDelegate delegate)
This method creates a new MBeanServer implementation object. When creating a new MBeanServer the MBeanServerFactory first calls newMBeanServerDelegate() in order to obtain a new MBeanServerDelegate for the new MBeanServer. Then it calls newMBeanServer(defaultDomain,outer,delegate) passing the delegate that should be used by the MBeanServer implementation.

Note that the passed delegate might not be directly the MBeanServerDelegate that was returned by this implementation. It could be, for instance, a new object wrapping the previously returned delegate.

The outer parameter is a pointer to the MBeanServer that should be passed to the MBeanRegistration interface when registering MBeans inside the MBeanServer. If outer is null, then the MBeanServer implementation must use its own this reference when invoking the MBeanRegistration interface.

This makes it possible for a MBeanServer implementation to wrap another MBeanServer implementation, in order to implement, e.g, security checks, or to prevent access to the actual MBeanServer implementation by returning a pointer to a wrapping object.

Parameters:
defaultDomain - Default domain of the new MBeanServer.
outer - A pointer to the MBeanServer object that must be passed to the MBeans when invoking their MBeanRegistration interface.
delegate - A pointer to the MBeanServerDelegate associated with the new MBeanServer. The new MBeanServer must register this MBean in its MBean repository.
Returns:
A new private implementation of an MBeanServer.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanServerConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface MBeanServerConnection

All Known Subinterfaces:
MBeanServer
public interface MBeanServerConnection

This interface represents a way to talk to an MBean server, whether local or remote. The MBeanServer interface, representing a local MBean server, extends this interface.

Since:
JMX 1.2

Method Summary
void | addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) Adds a listener to a registered MBean.
void | addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) Adds a listener to a registered MBean.
ObjectInstance | createMBean(String className, ObjectName name) Instantiates and registers an MBean in the MBean server.
ObjectInstance | createMBean(String className, ObjectName name, Object[] params, String[] signature) Instantiates and registers an MBean in the MBean server.
ObjectInstance | createMBean(String className, ObjectName name, ObjectName loaderName) Instantiates and registers an MBean in the MBean server.
ObjectInstance | createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) Instantiates and registers an MBean in the MBean server.
Object | getAttribute(ObjectName name, String attribute) Gets the value of a specific attribute of a named MBean.
AttributeList | getAttributes(ObjectName name, String[] attributes) Enables the values of several attributes of a named MBean.
String | getDefaultDomain() Returns the default domain used for naming the MBean.
String[] | getDomains() Returns the list of domains in which any MBean is currently registered.
Integer | getMBeanCount() Returns the number of MBeans registered in the MBean server.
MBeanInfo | getMBeanInfo(ObjectName name) This method discovers the attributes and operations that an MBean exposes for management.
ObjectInstance | getObjectInstance(ObjectName name) Gets the ObjectInstance for a given MBean registered with the MBean server.
Object | invoke(ObjectName name, String operationName, Object[] params, String[] signature) Invokes an operation on an MBean.
boolean | isInstanceOf(ObjectName name, String className) Returns true if the MBean specified is an instance of the specified class, false otherwise.
boolean | isRegistered(ObjectName name) Checks whether an MBean, identified by its object name, is already registered with the MBean server.
Set | queryMBeans(ObjectName name, QueryExp query) Gets MBeans controlled by the MBean server.
Set | queryNames(ObjectName name, QueryExp query) Gets the names of MBeans controlled by the MBean server.
void | removeNotificationListener(ObjectName name, NotificationListener listener) Removes a listener from a registered MBean.
void | removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) Removes a listener from a registered MBean.
void | removeNotificationListener(ObjectName name, ObjectName listener) Removes a listener from a registered MBean.
void | removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) Removes a listener from a registered MBean.
void | setAttribute(ObjectName name, Attribute attribute) Sets the value of a specific attribute of a named MBean.
AttributeList | setAttributes(ObjectName name, AttributeList attributes) Sets the values of several attributes of a named MBean.
void | unregisterMBean(ObjectName name) Unregisters an MBean from the MBean server.

Method Detail

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException

Instantiates and registers an MBean in the MBean server. The MBean server will use its Default Loader Repository to load the class of the MBean. An object name is associated to the MBean. If the object name given is null, the MBean must provide its own name by implementing the MBeanRegistration interface and returning the name from the preRegister method.

This method is equivalent to createMBean(className, name, (Object[]) null, (String[]) null).

Parameters:
className - The class name of the MBean to be instantiated.
name - The object name of the MBean. May be null.
Returns:
An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
MBeanException - The constructor of the MBean has thrown an exception
NotCompliantMBeanException - This class is not a JMX compliant MBean
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern or no ObjectName is specified for the MBean.
IOException - A communication problem occurred when talking to the MBean server.

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name,
                                  ObjectName loaderName)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException

Instantiates and registers an MBean in the MBean server. The class loader to be used is identified by its object name. An object name is associated to the MBean. If the object name of the loader is null, the ClassLoader that loaded the MBean server will be used. If the MBean's object name given is null, the MBean must provide its own name by implementing the MBeanRegistration interface and returning the name from the preRegister method.

This method is equivalent to createMBean(className, name, loaderName, (Object[]) null, (String[]) null).

Parameters:
className - The class name of the MBean to be instantiated.
name - The object name of the MBean. May be null.
loaderName - The object name of the class loader to be used.
Returns:
An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
MBeanException - The constructor of the MBean has thrown an exception
NotCompliantMBeanException - This class is not a JMX compliant MBean
InstanceNotFoundException - The specified class loader is not registered in the MBean server.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern or no ObjectName is specified for the MBean.
IOException - A communication problem occurred when talking to the MBean server.

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name,
                                  Object[] params,
                                  String[] signature)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException
Instantiates and registers an MBean in the MBean server. The MBean server will use its Default Loader Repository to load the class of the MBean. An object name is associated to the MBean. If the object name given is null, the MBean must provide its own name by implementing the MBeanRegistration interface and returning the name from the preRegister method.

Parameters:
className - The class name of the MBean to be instantiated.
name - The object name of the MBean. May be null.
params - An array containing the parameters of the constructor to be invoked.
signature - An array containing the signature of the constructor to be invoked.
Returns:
An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
MBeanException - The constructor of the MBean has thrown an exception
NotCompliantMBeanException - This class is not a JMX compliant MBean
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern or no ObjectName is specified for the MBean.
IOException - A communication problem occurred when talking to the MBean server.

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name,
                                  ObjectName loaderName,
                                  Object[] params,
                                  String[] signature)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException
Instantiates and registers an MBean in the MBean server. The class loader to be used is identified by its object name. An object name is associated to the MBean. If the object name of the loader is not specified, the ClassLoader that loaded the MBean server will be used. If the MBean object name given is null, the MBean must provide its own name by implementing the MBeanRegistration interface and returning the name from the preRegister method.

Parameters:
className - The class name of the MBean to be instantiated.
name - The object name of the MBean. May be null.
params - An array containing the parameters of the constructor to be invoked.
signature - An array containing the signature of the constructor to be invoked.
loaderName - The object name of the class loader to be used.
Returns:
An ObjectInstance, containing the ObjectName and the Java class name of the newly instantiated MBean. If the contained ObjectName is n, the contained Java class name is getMBeanInfo(n).getClassName().
Throws:
ReflectionException - Wraps a java.lang.ClassNotFoundException or a java.lang.Exception that occurred when trying to invoke the MBean's constructor.
InstanceAlreadyExistsException - The MBean is already under the control of the MBean server.
MBeanRegistrationException - The preRegister (MBeanRegistration interface) method of the MBean has thrown an exception. The MBean will not be registered.
MBeanException - The constructor of the MBean has thrown an exception
NotCompliantMBeanException - This class is not a JMX compliant MBean
InstanceNotFoundException - The specified class loader is not registered in the MBean server.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The className passed in parameter is null, the ObjectName passed in parameter contains a pattern or no ObjectName is specified for the MBean.
IOException - A communication problem occurred when talking to the MBean server.

unregisterMBean

public void unregisterMBean(ObjectName name)
                     throws InstanceNotFoundException,
                            MBeanRegistrationException,
                            IOException
Unregisters an MBean from the MBean server. The MBean is identified by its object name. Once the method has been invoked, the MBean may no longer be accessed by its object name.

Parameters:
name - The object name of the MBean to be unregistered.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
MBeanRegistrationException - The preDeregister ((MBeanRegistration interface) method of the MBean has thrown an exception.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or the MBean you are when trying to unregister is the MBeanServerDelegate MBean.
IOException - A communication problem occurred when talking to the MBean server.

getObjectInstance

public ObjectInstance getObjectInstance(ObjectName name)
                                 throws InstanceNotFoundException,
                                        IOException
Gets the ObjectInstance for a given MBean registered with the MBean server.

Parameters:
name - The object name of the MBean.
Returns:
The ObjectInstance associated with the MBean specified by name. The contained ObjectName is name and the contained class name is getMBeanInfo(name).getClassName().
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
IOException - A communication problem occurred when talking to the MBean server.

queryMBeans

public Set queryMBeans(ObjectName name,
                       QueryExp query)
                throws IOException
Gets MBeans controlled by the MBean server. This method allows any of the following to be obtained: All MBeans, a set of MBeans specified by pattern matching on the ObjectName and/or a Query expression, a specific MBean. When the object name is null or no domain and key properties are specified, all objects are to be selected (and filtered if a query is specified). It returns the set of ObjectInstance objects (containing the ObjectName and the Java Class name) for the selected MBeans.

Parameters:
name - The object name pattern identifying the MBeans to be retrieved. If null or no domain and key properties are specified, all the MBeans registered will be retrieved.
query - The query expression to be applied for selecting MBeans. If null no query expression will be applied for selecting MBeans.
Returns:
A set containing the ObjectInstance objects for the selected MBeans. If no MBean satisfies the query an empty list is returned.
Throws:
IOException - A communication problem occurred when talking to the MBean server.

queryNames

public Set queryNames(ObjectName name,
                      QueryExp query)
               throws IOException
Gets the names of MBeans controlled by the MBean server. This method enables any of the following to be obtained: The names of all MBeans, the names of a set of MBeans specified by pattern matching on the ObjectName and/or a Query expression, a specific MBean name (equivalent to testing whether an MBean is registered). When the object name is null or no domain and key properties are specified, all objects are selected (and filtered if a query is specified). It returns the set of ObjectNames for the MBeans selected.

Parameters:
name - The object name pattern identifying the MBean names to be retrieved. If null oror no domain and key properties are specified, the name of all registered MBeans will be retrieved.
query - The query expression to be applied for selecting MBeans. If null no query expression will be applied for selecting MBeans.
Returns:
A set containing the ObjectNames for the MBeans selected. If no MBean satisfies the query, an empty list is returned.
Throws:
IOException - A communication problem occurred when talking to the MBean server.

isRegistered

public boolean isRegistered(ObjectName name)
                     throws IOException
Checks whether an MBean, identified by its object name, is already registered with the MBean server.

Parameters:
name - The object name of the MBean to be checked.
Returns:
True if the MBean is already registered in the MBean server, false otherwise.
Throws:
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null.
IOException - A communication problem occurred when talking to the MBean server.

getMBeanCount

public Integer getMBeanCount()
                      throws IOException
Returns the number of MBeans registered in the MBean server.

Returns:
the number of MBeans registered.
Throws:
IOException - A communication problem occurred when talking to the MBean server.

getAttribute

public Object getAttribute(ObjectName name,
                           String attribute)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException,
                           IOException
Gets the value of a specific attribute of a named MBean. The MBean is identified by its object name.

Parameters:
name - The object name of the MBean from which the attribute is to be retrieved.
attribute - A String specifying the name of the attribute to be retrieved.
Returns:
The value of the retrieved attribute.
Throws:
AttributeNotFoundException - The attribute specified is not accessible in the MBean.
MBeanException - Wraps an exception thrown by the MBean's getter.
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
ReflectionException - Wraps a java.lang.Exception thrown when trying to invoke the setter.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or the attribute in parameter is null.
IOException - A communication problem occurred when talking to the MBean server.
See Also:
setAttribute(javax.management.ObjectName, javax.management.Attribute)

getAttributes

public AttributeList getAttributes(ObjectName name,
                                   String[] attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
Enables the values of several attributes of a named MBean. The MBean is identified by its object name.

Parameters:
name - The object name of the MBean from which the attributes are retrieved.
attributes - A list of the attributes to be retrieved.
Returns:
The list of the retrieved attributes.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
RuntimeOperationsException - Wrap a java.lang.IllegalArgumentException: The object name in parameter is null or attributes in parameter is null.
IOException - A communication problem occurred when talking to the MBean server.
See Also:
setAttributes(javax.management.ObjectName, javax.management.AttributeList)

setAttribute

public void setAttribute(ObjectName name,
                         Attribute attribute)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException,
                         IOException
Sets the value of a specific attribute of a named MBean. The MBean is identified by its object name.

Parameters:
name - The name of the MBean within which the attribute is to be set.
attribute - The identification of the attribute to be set and the value it is to be set to.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
AttributeNotFoundException - The attribute specified is not accessible in the MBean.
InvalidAttributeValueException - The value specified for the attribute is not valid.
MBeanException - Wraps an exception thrown by the MBean's setter.
ReflectionException - Wraps a java.lang.Exception thrown when trying to invoke the setter.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or the attribute in parameter is null.
IOException - A communication problem occurred when talking to the MBean server.
See Also:
getAttribute(javax.management.ObjectName, java.lang.String)

setAttributes

public AttributeList setAttributes(ObjectName name,
                                   AttributeList attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
Sets the values of several attributes of a named MBean. The MBean is identified by its object name.

Parameters:
name - The object name of the MBean within which the attributes are to be set.
attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to.
Returns:
The list of attributes that were set, with their new values.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
RuntimeOperationsException - Wraps a java.lang.IllegalArgumentException: The object name in parameter is null or attributes in parameter is null.
IOException - A communication problem occurred when talking to the MBean server.
See Also:
getAttributes(javax.management.ObjectName, java.lang.String[])

invoke

public Object invoke(ObjectName name,
                     String operationName,
                     Object[] params,
                     String[] signature)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException,
                     IOException
Invokes an operation on an MBean.

Parameters:
name - The object name of the MBean on which the method is to be invoked.
operationName - The name of the operation to be invoked.
params - An array containing the parameters to be set when the operation is invoked
signature - An array containing the signature of the operation. The class objects will be loaded using the same class loader as the one used for loading the MBean on which the operation was invoked.
Returns:
The object returned by the operation, which represents the result ofinvoking the operation on the MBean specified.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
MBeanException - Wraps an exception thrown by the MBean's invoked method.
ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the method.
IOException - A communication problem occurred when talking to the MBean server.

getDefaultDomain

public String getDefaultDomain()
                        throws IOException
Returns the default domain used for naming the MBean. The default domain name is used as the domain part in the ObjectName of MBeans if no domain is specified by the user.

Returns:
the default domain.
Throws:
IOException - A communication problem occurred when talking to the MBean server.

getDomains

public String[] getDomains()
                    throws IOException

Returns the list of domains in which any MBean is currently registered. A string is in the returned array if and only if there is at least one MBean registered with an ObjectName whose getDomain() is equal to that string. The order of strings within the returned array is not defined.

Returns:
the list of domains.
Throws:
IOException - A communication problem occurred when talking to the MBean server.
Since:
JMX 1.2

addNotificationListener

public void addNotificationListener(ObjectName name,
                                    NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
                             throws InstanceNotFoundException,
                                    IOException

Adds a listener to a registered MBean.

A notification emitted by an MBean will be forwarded by the MBeanServer to the listener. If the source of the notification is a reference to an MBean object, the MBean server will replace it by that MBean's ObjectName. Otherwise the source is unchanged.

Parameters:
name - The name of the MBean on which the listener should be added.
listener - The listener object which will handle the notifications emitted by the registered MBean.
filter - The filter object. If filter is null, no filtering will be performed before handling notifications.
handback - The context to be sent to the listener when a notification is emitted.
Throws:
InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
IOException - A communication problem occurred when talking to the MBean server.
See Also:
removeNotificationListener(ObjectName, NotificationListener), removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

addNotificationListener

public void addNotificationListener(ObjectName name,
                                    ObjectName listener,
                                    NotificationFilter filter,
                                    Object handback)
                             throws InstanceNotFoundException,
                                    IOException

Adds a listener to a registered MBean.

A notification emitted by an MBean will be forwarded by the MBeanServer to the listener. If the source of the notification is a reference to an MBean object, the MBean server will replace it by that MBean's ObjectName. Otherwise the source is unchanged.

The listener object that receives notifications is the one that is registered with the given name at the time this method is called. Even if it is subsequently unregistered, it will continue to receive notifications.

Parameters:
name - The name of the MBean on which the listener should be added.
listener - The object name of the listener which will handle the notifications emitted by the registered MBean.
filter - The filter object. If filter is null, no filtering will be performed before handling notifications.
handback - The context to be sent to the listener when a notification is emitted.
Throws:
InstanceNotFoundException - The MBean name of the notification listener or of the notification broadcaster does not match any of the registered MBeans.
RuntimeOperationsException - Wraps an IllegalArgumentException. The MBean named by listener exists but does not implement the NotificationListener interface.
IOException - A communication problem occurred when talking to the MBean server.
See Also:
removeNotificationListener(ObjectName, ObjectName), removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       ObjectName listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException
Removes a listener from a registered MBean.

If the listener is registered more than once, perhaps with different filters or callbacks, this method will remove all those registrations.

Parameters:
name - The name of the MBean on which the listener should be removed.
listener - The object name of the listener to be removed.
Throws:
InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
ListenerNotFoundException - The listener is not registered in the MBean.
IOException - A communication problem occurred when talking to the MBean server.
See Also:
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       ObjectName listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException

Removes a listener from a registered MBean.

The MBean must have a listener that exactly matches the given listener, filter, and handback parameters. If there is more than one such listener, only one is removed.

The filter and handback parameters may be null if and only if they are null in a listener to be removed.

Parameters:
name - The name of the MBean on which the listener should be removed.
listener - A listener that was previously added to this MBean.
filter - The filter that was specified when the listener was added.
handback - The handback that was specified when the listener was added.
Throws:
InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
ListenerNotFoundException - The listener is not registered in the MBean, or it is not registered with the given filter and handback.
IOException - A communication problem occurred when talking to the MBean server.
Since:
JMX 1.2
See Also:
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       NotificationListener listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException

Removes a listener from a registered MBean.

If the listener is registered more than once, perhaps with different filters or callbacks, this method will remove all those registrations.

Parameters:
name - The name of the MBean on which the listener should be removed.
listener - The object name of the listener to be removed.
Throws:
InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
ListenerNotFoundException - The listener is not registered in the MBean.
IOException - A communication problem occurred when talking to the MBean server.
See Also:
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException

Removes a listener from a registered MBean.

The MBean must have a listener that exactly matches the given listener, filter, and handback parameters. If there is more than one such listener, only one is removed.

The filter and handback parameters may be null if and only if they are null in a listener to be removed.

Parameters:
name - The name of the MBean on which the listener should be removed.
listener - A listener that was previously added to this MBean.
filter - The filter that was specified when the listener was added.
handback - The handback that was specified when the listener was added.
Throws:
InstanceNotFoundException - The MBean name provided does not match any of the registered MBeans.
ListenerNotFoundException - The listener is not registered in the MBean, or it is not registered with the given filter and handback.
IOException - A communication problem occurred when talking to the MBean server.
Since:
JMX 1.2
See Also:
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

getMBeanInfo

public MBeanInfo getMBeanInfo(ObjectName name)
                       throws InstanceNotFoundException,
                              IntrospectionException,
                              ReflectionException,
                              IOException
This method discovers the attributes and operations that an MBean exposes for management.

Parameters:
name - The name of the MBean to analyze
Returns:
An instance of MBeanInfo allowing the retrieval of all attributes and operations of this MBean.
Throws:
IntrospectionException - An exception occured during introspection.
InstanceNotFoundException - The MBean specified was not found.
ReflectionException - An exception occurred when trying to invoke the getMBeanInfo of a Dynamic MBean.
IOException - A communication problem occurred when talking to the MBean server.

isInstanceOf

public boolean isInstanceOf(ObjectName name,
                            String className)
                     throws InstanceNotFoundException,
                            IOException

Returns true if the MBean specified is an instance of the specified class, false otherwise.

If name does not name an MBean, this method throws InstanceNotFoundException.

Otherwise, let
X be the MBean named by name,
L be the ClassLoader of X,
N be the class name in X's MBeanInfo.

If N equals className, the result is true.

Otherwise, if L successfully loads both N and className, and the second class is assignable from the first, the result is true.

Otherwise, the result is false.

Parameters:
name - The ObjectName of the MBean.
className - The name of the class.
Returns:
true if the MBean specified is an instance of the specified class according to the rules above, false otherwise.
Throws:
InstanceNotFoundException - The MBean specified is not registered in the MBean server.
IOException - A communication problem occurred when talking to the MBean server.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanServerDelegate

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanServerDelegate

java.lang.Object
    extended by javax.management.MBeanServerDelegate
All Implemented Interfaces:
MBeanServerDelegateMBean, NotificationBroadcaster, NotificationEmitter
public class MBeanServerDelegate
extends Object
implements MBeanServerDelegateMBean, NotificationEmitter

Represents the MBean server from the management point of view. The MBeanServerDelegate MBean emits the MBeanServerNotifications when an MBean is registered/unregistered in the MBean server.

Constructor Summary
MBeanServerDelegate()
Create a MBeanServerDelegate object.
Method Summary
void | addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) Adds a listener to this MBean.
String | getImplementationName() Returns the JMX implementation name (the name of this product).
String | getImplementationVendor() Returns the JMX implementation vendor (the vendor of this product).
String | getImplementationVersion() Returns the JMX implementation version (the version of this product).
String | getMBeanServerId() Returns the MBean server agent identity.
MBeanNotificationInfo[] | getNotificationInfo() Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.
String | getSpecificationName() Returns the full name of the JMX specification implemented by this product.
String | getSpecificationVendor() Returns the vendor of the JMX specification implemented by this product.
String | getSpecificationVersion() Returns the version of the JMX specification implemented by this product.
void | removeNotificationListener(NotificationListener listener) Removes a listener from this MBean.
void | removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) Removes a listener from this MBean.
void | sendNotification(Notification notification) Enables the MBean server to send a notification.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MBeanServerDelegate

public MBeanServerDelegate()
Create a MBeanServerDelegate object.

Method Detail

getMBeanServerId

public String getMBeanServerId()
Returns the MBean server agent identity.

Specified by:
getMBeanServerId in interface MBeanServerDelegateMBean
Returns:
the identity.

getSpecificationName

public String getSpecificationName()
Returns the full name of the JMX specification implemented by this product.

Specified by:
getSpecificationName in interface MBeanServerDelegateMBean
Returns:
the specification name.

getSpecificationVersion

public String getSpecificationVersion()
Returns the version of the JMX specification implemented by this product.

Specified by:
getSpecificationVersion in interface MBeanServerDelegateMBean
Returns:
the specification version.

getSpecificationVendor

public String getSpecificationVendor()
Returns the vendor of the JMX specification implemented by this product.

Specified by:
getSpecificationVendor in interface MBeanServerDelegateMBean
Returns:
the specification vendor.

getImplementationName

public String getImplementationName()
Returns the JMX implementation name (the name of this product).

Specified by:
getImplementationName in interface MBeanServerDelegateMBean
Returns:
the implementation name.

getImplementationVersion

public String getImplementationVersion()
Returns the JMX implementation version (the version of this product).

Specified by:
getImplementationVersion in interface MBeanServerDelegateMBean
Returns:
the implementation version.

getImplementationVendor

public String getImplementationVendor()
Returns the JMX implementation vendor (the vendor of this product).

Specified by:
getImplementationVendor in interface MBeanServerDelegateMBean
Returns:
the implementation vendor.

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
Description copied from interface: NotificationBroadcaster

Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.

It is not illegal for the MBean to send notifications not described in this array. However, some clients of the MBean server may depend on the array being complete for their correct functioning.

Specified by:
getNotificationInfo in interface NotificationBroadcaster
Returns:
the array of possible notifications.

addNotificationListener

public void addNotificationListener(NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
                             throws IllegalArgumentException
Description copied from interface: NotificationBroadcaster
Adds a listener to this MBean.

Specified by:
addNotificationListener in interface NotificationBroadcaster
Parameters:
listener - The listener object which will handle the notifications emitted by the broadcaster.
filter - The filter object. If filter is null, no filtering will be performed before handling notifications.
handback - An opaque object to be sent back to the listener when a notification is emitted. This object cannot be used by the Notification broadcaster object. It should be resent unchanged with the notification to the listener.
Throws:
IllegalArgumentException - Listener parameter is null.
See Also:
NotificationBroadcaster.removeNotificationListener(javax.management.NotificationListener)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws ListenerNotFoundException
Description copied from interface: NotificationEmitter

Removes a listener from this MBean. The MBean must have a listener that exactly matches the given listener, filter, and handback parameters. If there is more than one such listener, only one is removed.

The filter and handback parameters may be null if and only if they are null in a listener to be removed.

Specified by:
removeNotificationListener in interface NotificationEmitter
Parameters:
listener - A listener that was previously added to this MBean.
filter - The filter that was specified when the listener was added.
handback - The handback that was specified when the listener was added.
Throws:
ListenerNotFoundException - The listener is not registered with the MBean, or it is not registered with the given filter and handback.

removeNotificationListener

public void removeNotificationListener(NotificationListener listener)
                                throws ListenerNotFoundException
Description copied from interface: NotificationBroadcaster
Removes a listener from this MBean. If the listener has been registered with different handback objects or notification filters, all entries corresponding to the listener will be removed.

Specified by:
removeNotificationListener in interface NotificationBroadcaster
Parameters:
listener - A listener that was previously added to this MBean.
Throws:
ListenerNotFoundException - The listener is not registered with the MBean.
See Also:
NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

sendNotification

public void sendNotification(Notification notification)
Enables the MBean server to send a notification. If the passed notification has a sequence number lesser or equal to 0, then replace it with the delegate's own sequence number.

Parameters:
notification - The notification to send.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanServerDelegateMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface MBeanServerDelegateMBean

All Known Implementing Classes:
MBeanServerDelegate
public interface MBeanServerDelegateMBean

Defines the management interface of an object of class MBeanServerDelegate.

Method Summary
String | getImplementationName() Returns the JMX implementation name (the name of this product).
String | getImplementationVendor() Returns the JMX implementation vendor (the vendor of this product).
String | getImplementationVersion() Returns the JMX implementation version (the version of this product).
String | getMBeanServerId() Returns the MBean server agent identity.
String | getSpecificationName() Returns the full name of the JMX specification implemented by this product.
String | getSpecificationVendor() Returns the vendor of the JMX specification implemented by this product.
String | getSpecificationVersion() Returns the version of the JMX specification implemented by this product.

Method Detail

getMBeanServerId

public String getMBeanServerId()
Returns the MBean server agent identity.

Returns:
the agent identity.

getSpecificationName

public String getSpecificationName()
Returns the full name of the JMX specification implemented by this product.

Returns:
the specification name.

getSpecificationVersion

public String getSpecificationVersion()
Returns the version of the JMX specification implemented by this product.

Returns:
the specification version.

getSpecificationVendor

public String getSpecificationVendor()
Returns the vendor of the JMX specification implemented by this product.

Returns:
the specification vendor.

getImplementationName

public String getImplementationName()
Returns the JMX implementation name (the name of this product).

Returns:
the implementation name.

getImplementationVersion

public String getImplementationVersion()
Returns the JMX implementation version (the version of this product).

Returns:
the implementation version.

getImplementationVendor

public String getImplementationVendor()
Returns the JMX implementation vendor (the vendor of this product).

Returns:
the implementation vendor.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanServerFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanServerFactory

java.lang.Object
    extended by javax.management.MBeanServerFactory
public class MBeanServerFactory
extends Object

Provides MBean server references. There are no instances of this class.

Since JMX 1.2 this class makes it possible to replace the default MBeanServer implementation. This is done using the MBeanServerBuilder class. The class of the initial MBeanServerBuilder to be instantiated can be specified through the javax.management.builder.initial system property. The specified class must be a public subclass of MBeanServerBuilder, and must have a public empty constructor.

By default, if no value for that property is specified, an instance of javax.management.MBeanServerBuilder is created. Otherwise, the MBeanServerFactory attempts to load the specified class using Thread.currentThread().getContextClassLoader(), or if that is null, Class.forName(). Then it creates an initial instance of that Class using Class.newInstance(). If any checked exception is raised during this process (e.g. ClassNotFoundException, InstantiationException) the MBeanServerFactory will propagate this exception from within a RuntimeException.

The javax.management.builder.initial system property is consulted every time a new MBeanServer needs to be created, and the class pointed to by that property is loaded. If that class is different from that of the current MBeanServerBuilder, then a new MBeanServerBuilder is created. Otherwise, the MBeanServerFactory may create a new MBeanServerBuilder or reuse the current one.

If the class pointed to by the property cannot be loaded, or does not correspond to a valid subclass of MBeanServerBuilder then an exception is propagated, and no MBeanServer can be created until the javax.management.builder.initial system property is reset to valid value.

The MBeanServerBuilder makes it possible to wrap the MBeanServers returned by the default MBeanServerBuilder implementation, for the purpose of e.g. adding an additional security layer.

Method Summary
static MBeanServer | createMBeanServer() Return a new object implementing the MBeanServer interface with a standard default domain name.
static MBeanServer | createMBeanServer(String domain) Return a new object implementing the MBeanServer interface with the specified default domain name.
static ArrayList | findMBeanServer(String agentId) Return a list of registered MBeanServer objects.
static ClassLoaderRepository | getClassLoaderRepository(MBeanServer server) Return the ClassLoaderRepository used by the given MBeanServer.
static MBeanServer | newMBeanServer() Return a new object implementing the MBeanServer interface with a standard default domain name, without keeping an internal reference to this new object.
static MBeanServer | newMBeanServer(String domain) Return a new object implementing the MBeanServer interface with the specified default domain name, without keeping an internal reference to this new object.
static void | releaseMBeanServer(MBeanServer mbeanServer) Remove internal MBeanServerFactory references to a created MBeanServer.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

releaseMBeanServer

public static void releaseMBeanServer(MBeanServer mbeanServer)
Remove internal MBeanServerFactory references to a created MBeanServer. This allows the garbage collector to remove the MBeanServer object.

Parameters:
mbeanServer - the MBeanServer object to remove.
Throws:
IllegalArgumentException - if mbeanServer was not generated by one of the createMBeanServer methods, or if releaseMBeanServer was already called on it.
SecurityException - if there is a SecurityManager and the caller's permissions do not include or imply MBeanServerPermission("releaseMBeanServer").

createMBeanServer

public static MBeanServer createMBeanServer()

Return a new object implementing the MBeanServer interface with a standard default domain name. The default domain name is used as the domain part in the ObjectName of MBeans when the domain is specified by the user is null.

The standard default domain name is defined in ServiceName.DOMAIN.

The MBeanServer reference is internally kept. This will allow findMBeanServer to return a reference to this MBeanServer object.

This method is equivalent to createMBeanServer(null).

Returns:
the newly created MBeanServer.
Throws:
SecurityException - if there is a SecurityManager and the caller's permissions do not include or imply MBeanServerPermission("createMBeanServer").
JMRuntimeException - if the property javax.management.builder.initial exists but the class it names cannot be instantiated through a public no-argument constructor; or if the instantiated builder returns null from its newMBeanServerDelegate or newMBeanServer methods.
ClassCastException - if the property javax.management.builder.initial exists and can be instantiated but is not assignment compatible with MBeanServerBuilder.

createMBeanServer

public static MBeanServer createMBeanServer(String domain)

Return a new object implementing the MBeanServer interface with the specified default domain name. The given domain name is used as the domain part in the ObjectName of MBeans when the domain is specified by the user is null.

The MBeanServer reference is internally kept. This will allow findMBeanServer to return a reference to this MBeanServer object.

Parameters:
domain - the default domain name for the created MBeanServer. This is the value that will be returned by MBeanServer.getDefaultDomain().
Returns:
the newly created MBeanServer.
Throws:
SecurityException - if there is a SecurityManager and the caller's permissions do not include or imply MBeanServerPermission("createMBeanServer").
JMRuntimeException - if the property javax.management.builder.initial exists but the class it names cannot be instantiated through a public no-argument constructor; or if the instantiated builder returns null from its newMBeanServerDelegate or newMBeanServer methods.
ClassCastException - if the property javax.management.builder.initial exists and can be instantiated but is not assignment compatible with MBeanServerBuilder.

newMBeanServer

public static MBeanServer newMBeanServer()

Return a new object implementing the MBeanServer interface with a standard default domain name, without keeping an internal reference to this new object. The default domain name is used as the domain part in the ObjectName of MBeans when the domain is specified by the user is null.

The standard default domain name is defined in ServiceName.DOMAIN.

No reference is kept. findMBeanServer will not be able to return a reference to this MBeanServer object, but the garbage collector will be able to remove the MBeanServer object when it is no longer referenced.

This method is equivalent to newMBeanServer(null).

Returns:
the newly created MBeanServer.
Throws:
SecurityException - if there is a SecurityManager and the caller's permissions do not include or imply MBeanServerPermission("newMBeanServer").
JMRuntimeException - if the property javax.management.builder.initial exists but the class it names cannot be instantiated through a public no-argument constructor; or if the instantiated builder returns null from its newMBeanServerDelegate or newMBeanServer methods.
ClassCastException - if the property javax.management.builder.initial exists and can be instantiated but is not assignment compatible with MBeanServerBuilder.

newMBeanServer

public static MBeanServer newMBeanServer(String domain)

Return a new object implementing the MBeanServer interface with the specified default domain name, without keeping an internal reference to this new object. The given domain name is used as the domain part in the ObjectName of MBeans when the domain is specified by the user is null.

No reference is kept. findMBeanServer will not be able to return a reference to this MBeanServer object, but the garbage collector will be able to remove the MBeanServer object when it is no longer referenced.

Parameters:
domain - the default domain name for the created MBeanServer. This is the value that will be returned by MBeanServer.getDefaultDomain().
Returns:
the newly created MBeanServer.
Throws:
SecurityException - if there is a SecurityManager and the caller's permissions do not include or imply MBeanServerPermission("newMBeanServer").
JMRuntimeException - if the property javax.management.builder.initial exists but the class it names cannot be instantiated through a public no-argument constructor; or if the instantiated builder returns null from its newMBeanServerDelegate or newMBeanServer methods.
ClassCastException - if the property javax.management.builder.initial exists and can be instantiated but is not assignment compatible with MBeanServerBuilder.

findMBeanServer

public static ArrayList findMBeanServer(String agentId)

Return a list of registered MBeanServer objects. A registered MBeanServer object is one that was created by one of the createMBeanServer methods and not subsequently released with releaseMBeanServer.

Parameters:
agentId - The agent identifier of the MBeanServer to retrieve. If this parameter is null, all registered MBeanServers in this JVM are returned. Otherwise, only MBeanServers whose id is equal to agentId are returned. The id of an MBeanServer is the MBeanServerId attribute of its delegate MBean.
Returns:
A list of MBeanServer objects.
Throws:
SecurityException - if there is a SecurityManager and the caller's permissions do not include or imply MBeanServerPermission("findMBeanServer").

getClassLoaderRepository

public static ClassLoaderRepository getClassLoaderRepository(MBeanServer server)
Return the ClassLoaderRepository used by the given MBeanServer. This method is equivalent to server.getClassLoaderRepository().

Parameters:
server - The MBeanServer under examination. Since JMX 1.2, if server is null, the result is a NullPointerException. This behaviour differs from what was implemented in JMX 1.1 - where the possibility to use null was deprecated.
Returns:
The Class Loader Repository used by the given MBeanServer.
Throws:
SecurityException - if there is a SecurityManager and the caller's permissions do not include or imply MBeanPermission("getClassLoaderRepository").
NullPointerException - if server is null.
Since:
JMX 1.1
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanServerInvocationHandler

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanServerInvocationHandler

java.lang.Object
    extended by javax.management.MBeanServerInvocationHandler
All Implemented Interfaces:
InvocationHandler
public class MBeanServerInvocationHandler
extends Object
implements InvocationHandler

InvocationHandler that forwards methods in an MBean's management interface through the MBean server to the MBean.

Given an MBeanServerConnection, the ObjectName of an MBean within that MBean server, and a Java interface Intf that describes the management interface of the MBean using the patterns for a Standard MBean, this class can be used to construct a proxy for the MBean. The proxy implements the interface Intf such that all of its methods are forwarded through the MBean server to the MBean.

If you have an MBean server mbs containing an MBean with ObjectName name, and if the MBean's management interface is described by the Java interface Intf, you can construct a proxy for the MBean like this:

 Intf proxy = (Intf)
     MBeanServerInvocationHandler.newProxyInstance(mbs,
                                                   name,
                                                   Intf.class,
                                                   false);

Suppose, for example, Intf looks like this:

 public interface Intf {
     public String getSomeAttribute();
     public void setSomeAttribute(String value);
     public void someOperation(String param1, int param2);
 }

Then you can execute:

  • proxy.getSomeAttribute() which will result in a call to mbs. getAttribute (name, "SomeAttribute").
  • proxy.setSomeAttribute("whatever") which will result in a call to mbs. setAttribute (name, new Attribute("SomeAttribute", "whatever")).
  • proxy.someOperation("param1", 2) which will be translated into a call to mbs. invoke (name, "someOperation", <etc>).

If the last parameter to newProxyInstance is true, then the MBean is assumed to be a NotificationBroadcaster or NotificationEmitter and the returned proxy will implement NotificationEmitter. A call to NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object) on the proxy will result in a call to MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object), and likewise for the other methods of NotificationBroadcaster and NotificationEmitter.

The methods Object.toString(), Object.hashCode(), and Object.equals(Object), when invoked on a proxy using this invocation handler, are forwarded to the MBean server as methods on the proxied MBean. This will only work if the MBean declares those methods in its management interface.

Since:
JMX 1.2

Constructor Summary
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName)
Invocation handler that forwards methods through an MBean server.
Method Summary
Object | invoke(Object proxy, Method method, Object[] args)
static Object | newProxyInstance(MBeanServerConnection connection, ObjectName objectName, Class interfaceClass, boolean notificationBroadcaster) Return a proxy that implements the given interface by forwarding its methods through the given MBean server to the named MBean.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MBeanServerInvocationHandler

public MBeanServerInvocationHandler(MBeanServerConnection connection,
                                    ObjectName objectName)

Invocation handler that forwards methods through an MBean server. This constructor may be called instead of relying on newProxyInstance(javax.management.MBeanServerConnection, javax.management.ObjectName, java.lang.Class, boolean), for instance if you need to supply a different ClassLoader to Proxy.newProxyInstance.

Parameters:
connection - the MBean server connection through which all methods of a proxy using this handler will be forwarded.
objectName - the name of the MBean within the MBean server to which methods will be forwarded.
Method Detail

newProxyInstance

public static Object newProxyInstance(MBeanServerConnection connection,
                                      ObjectName objectName,
                                      Class interfaceClass,
                                      boolean notificationBroadcaster)

Return a proxy that implements the given interface by forwarding its methods through the given MBean server to the named MBean.

This method is equivalent to Proxy.newProxyInstance (interfaceClass.getClassLoader(), interfaces, handler). Here handler is the result of new MBeanServerInvocationHandler(connection, objectName), and interfaces is an array that has one element if notificationBroadcaster is false and two if it is true. The first element of interfaces is interfaceClass and the second, if present, is NotificationEmitter.class.

Parameters:
connection - the MBean server to forward to.
objectName - the name of the MBean within connection to forward to.
interfaceClass - the management interface that the MBean exports, which will also be implemented by the returned proxy.
notificationBroadcaster - make the returned proxy implement NotificationEmitter by forwarding its methods via connection.
Returns:
the new proxy instance.

invoke

public Object invoke(Object proxy,
                     Method method,
                     Object[] args)
              throws Throwable
Specified by:
invoke in interface InvocationHandler
Throws:
Throwable
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanServerNotification

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanServerNotification

java.lang.Object
    extended by java.util.EventObject
        extended by javax.management.Notification
            extended by javax.management.MBeanServerNotification
All Implemented Interfaces:
Serializable
public class MBeanServerNotification
extends Notification

Represents a notification emitted by the MBean server through the MBeanServerDelegate MBean. The MBean Server emits the following types of notifications: MBean registration, MBean de-registration.

To receive to MBeanServerNotifications, you need to be declared as listener to the javax.management.MBeanServerDelegate MBean that represents the MBeanServer. The ObjectName of the MBeanServerDelegate is: JMImplementation:type=MBeanServerDelegate.

See Also:
Serialized Form

Field Summary
static String | REGISTRATION_NOTIFICATION Notification type denoting that an MBean has been registered.
static String | UNREGISTRATION_NOTIFICATION Notification type denoting that an MBean has been unregistered.
Fields inherited from class javax.management.Notification
source
Constructor Summary
MBeanServerNotification(String type, Object source, long sequenceNumber, ObjectName objectName)
Creates an MBeanServerNotification object specifying object names of the MBeans that caused the notification and the specified notification type.
Method Summary
 ObjectName getMBeanName()
Returns the object name of the MBean that caused the notification.
Methods inherited from class javax.management.Notification
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

REGISTRATION_NOTIFICATION

public static final String REGISTRATION_NOTIFICATION
Notification type denoting that an MBean has been registered. Value is "JMX.mbean.registered".

See Also:
Constant Field Values

UNREGISTRATION_NOTIFICATION

public static final String UNREGISTRATION_NOTIFICATION
Notification type denoting that an MBean has been unregistered. Value is "JMX.mbean.unregistered".

See Also:
Constant Field Values
Constructor Detail

MBeanServerNotification

public MBeanServerNotification(String type,
                               Object source,
                               long sequenceNumber,
                               ObjectName objectName)
Creates an MBeanServerNotification object specifying object names of the MBeans that caused the notification and the specified notification type.

Parameters:
type - A string denoting the type of the notification. Set it to one these values: REGISTRATION_NOTIFICATION, UNREGISTRATION_NOTIFICATION.
source - The MBeanServerNotification object responsible for forwarding MBean server notification.
sequenceNumber - A sequence number that can be used to order received notifications.
objectName - The object name of the MBean that caused the notification.
Method Detail

getMBeanName

public ObjectName getMBeanName()
Returns the object name of the MBean that caused the notification.

Returns:
the object name of the MBean that caused the notification.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanServerPermission

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanServerPermission

java.lang.Object
    extended by java.security.Permission
        extended by java.security.BasicPermission
            extended by javax.management.MBeanServerPermission
All Implemented Interfaces:
Guard, Serializable
public class MBeanServerPermission
extends BasicPermission

A Permission to perform actions related to MBeanServers. The name of the permission specifies the operation requested or granted by the permission. For a granted permission, it can be * to allow all of the MBeanServer operations specified below. Otherwise, for a granted or requested permission, it must be one of the following:

createMBeanServer
Create a new MBeanServer object using the method MBeanServerFactory.createMBeanServer() or MBeanServerFactory.createMBeanServer(java.lang.String).
findMBeanServer
Find an MBeanServer with a given name, or all MBeanServers in this JVM, using the method MBeanServerFactory.findMBeanServer(java.lang.String).
newMBeanServer
Create a new MBeanServer object without keeping a reference to it, using the method MBeanServerFactory.newMBeanServer() or MBeanServerFactory.newMBeanServer(java.lang.String).
releaseMBeanServer
Remove the MBeanServerFactory's reference to an MBeanServer, using the method MBeanServerFactory.releaseMBeanServer(javax.management.MBeanServer).
The name of the permission can also denote a list of one or more comma-separated operations. Spaces are allowed at the beginning and end of the name and before and after commas.

MBeanServerPermission("createMBeanServer") implies MBeanServerPermission("newMBeanServer").

Since:
JMX 1.1
See Also:
Serialized Form

Constructor Summary
MBeanServerPermission(String name)
Create a new MBeanServerPermission with the given name.
MBeanServerPermission(String name, String actions)
Create a new MBeanServerPermission with the given name.
Method Summary
boolean | equals(Object obj) Checks two MBeanServerPermission objects for equality.
int | hashCode()
boolean | implies(Permission p) Checks if this MBeanServerPermission object "implies" the specified permission.
PermissionCollection | newPermissionCollection()
Methods inherited from class java.security.BasicPermission
getActions
Methods inherited from class java.security.Permission
checkGuard, getName, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MBeanServerPermission

public MBeanServerPermission(String name)

Create a new MBeanServerPermission with the given name.

This constructor is equivalent to MBeanServerPermission(name,null).

Parameters:
name - the name of the granted permission. It must respect the constraints spelt out in the description of the MBeanServerPermission class.
Throws:
NullPointerException - if the name is null.
IllegalArgumentException - if the name is not * or one of the allowed names or a comma-separated list of the allowed names.

MBeanServerPermission

public MBeanServerPermission(String name,
                             String actions)

Create a new MBeanServerPermission with the given name.

Parameters:
name - the name of the granted permission. It must respect the constraints spelt out in the description of the MBeanServerPermission class.
actions - the associated actions. This parameter is not currently used and must be null or the empty string.
Throws:
NullPointerException - if the name is null.
IllegalArgumentException - if the name is not * or one of the allowed names or a comma-separated list of the allowed names, or if actions is a non-null non-empty string.
Method Detail

hashCode

public int hashCode()

implies

public boolean implies(Permission p)

Checks if this MBeanServerPermission object "implies" the specified permission.

More specifically, this method returns true if:

  • p is an instance of MBeanServerPermission,
  • p's target names are a subset of this object's target names

The createMBeanServer permission implies the newMBeanServer permission.

Parameters:
p - the permission to check against.
Returns:
true if the specified permission is implied by this object, false if not.

equals

public boolean equals(Object obj)
Checks two MBeanServerPermission objects for equality. Checks that obj is an MBeanServerPermission, and represents the same list of allowable actions as this object.

Parameters:
obj - the object we are testing for equality with this object.
Returns:
true if the objects are equal.

newPermissionCollection

public PermissionCollection newPermissionCollection()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanTrustPermission

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class MBeanTrustPermission

java.lang.Object
    extended by java.security.Permission
        extended by java.security.BasicPermission
            extended by javax.management.MBeanTrustPermission
All Implemented Interfaces:
Guard, Serializable
public class MBeanTrustPermission
extends BasicPermission

This permission represents "trust" in a signer or codebase.

MBeanTrustPermission contains a target name but no actions list. A single target name, "register", is defined for this permission. The target "*" is also allowed, permitting "register" and any future targets that may be defined. Only the null value or the empty string are allowed for the action to allow the policy object to create the permissions specified in the policy file.

If a signer, or codesource is granted this permission, then it is considered a trusted source for MBeans. Only MBeans from trusted sources may be registered in the MBeanServer.

Since:
JMX 1.2
See Also:
Serialized Form

Constructor Summary
MBeanTrustPermission(String name)
Create a new MBeanTrustPermission with the given name.
MBeanTrustPermission(String name, String actions)
Create a new MBeanTrustPermission with the given name.
Methods inherited from class java.security.BasicPermission
equals, getActions, hashCode, implies, newPermissionCollection
Methods inherited from class java.security.Permission
checkGuard, getName, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

MBeanTrustPermission

public MBeanTrustPermission(String name)

Create a new MBeanTrustPermission with the given name.

This constructor is equivalent to MBeanTrustPermission(name,null).

Parameters:
name - the name of the permission. It must be "register" or "*" for this permission.
Throws:
NullPointerException - if the name is null.
IllegalArgumentException - if the name is neither "register" nor "*".

MBeanTrustPermission

public MBeanTrustPermission(String name,
                            String actions)

Create a new MBeanTrustPermission with the given name.

Parameters:
name - the name of the permission. It must be "register" or "*" for this permission.
actions - the actions for the permission. It must be null or "".
Throws:
NullPointerException - if the name is null.
IllegalArgumentException - if the name is neither "register" nor "*"; or if actions is a non-null non-empty string.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


modelmbean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management.modelmbean

Provides the definition of the ModelMBean classes.

See:
Description

Interface Summary
ModelMBean | This interface must be implemented by the ModelMBeans.
ModelMBeanInfo | This interface is implemented by the ModelMBeanInfo for every ModelMBean.
ModelMBeanNotificationBroadcaster | This interface must be implemented by the ModelMBeans.

Class Summary
DescriptorSupport | This class represents the metadata set for a ModelMBean element.
ModelMBeanAttributeInfo | The ModelMBeanAttributeInfo object describes an attribute of the ModelMBean.
ModelMBeanConstructorInfo | The ModelMBeanConstructorInfo object describes a constructor of the ModelMBean.
ModelMBeanInfoSupport | This class represents the meta data for ModelMBeans.
ModelMBeanNotificationInfo | The ModelMBeanNotificationInfo object describes a notification emitted by a ModelMBean.
ModelMBeanOperationInfo | The ModelMBeanOperationInfo object describes a management operation of the ModelMBean.
RequiredModelMBean | This class is the implementation of a ModelMBean.

Exception Summary
InvalidTargetObjectTypeException | Exception thrown when an invalid target object type is specified.
XMLParseException | This exception is thrown when an XML formatted string is being parsed into ModelMBean objects or when XML formatted strings are being created from ModelMBean objects.

Package javax.management.modelmbean Description

Provides the definition of the ModelMBean classes.

Since:
JMX 1.0
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.management.modelmbean Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management.modelmbean

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.management.modelmbean.DescriptorSupport (implements javax.management.Descriptor)
    • class javax.management.MBeanFeatureInfo (implements java.io.Serializable)
      • class javax.management.MBeanAttributeInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.modelmbean.ModelMBeanAttributeInfo (implements java.lang.Cloneable, javax.management.DescriptorAccess)
      • class javax.management.MBeanConstructorInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.modelmbean.ModelMBeanConstructorInfo (implements java.lang.Cloneable, javax.management.DescriptorAccess)
      • class javax.management.MBeanNotificationInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.modelmbean.ModelMBeanNotificationInfo (implements java.lang.Cloneable, javax.management.DescriptorAccess)
      • class javax.management.MBeanOperationInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.modelmbean.ModelMBeanOperationInfo (implements javax.management.DescriptorAccess)
    • class javax.management.MBeanInfo (implements java.lang.Cloneable, java.io.Serializable)
      • class javax.management.modelmbean.ModelMBeanInfoSupport (implements javax.management.modelmbean.ModelMBeanInfo, java.io.Serializable)
    • class javax.management.modelmbean.RequiredModelMBean (implements javax.management.MBeanRegistration, javax.management.modelmbean.ModelMBean, javax.management.NotificationEmitter)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.management.modelmbean.InvalidTargetObjectTypeException
        • class javax.management.modelmbean.XMLParseException

Interface Hierarchy

  • interface javax.management.DynamicMBean
    • interface javax.management.modelmbean.ModelMBean (also extends javax.management.modelmbean.ModelMBeanNotificationBroadcaster, javax.management.PersistentMBean)
  • interface javax.management.modelmbean.ModelMBeanInfo
  • interface javax.management.NotificationBroadcaster
    • interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster
      • interface javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.PersistentMBean)
  • interface javax.management.PersistentMBean
    • interface javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.modelmbean.ModelMBeanNotificationBroadcaster)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DescriptorSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Class DescriptorSupport

java.lang.Object
    extended by javax.management.modelmbean.DescriptorSupport
All Implemented Interfaces:
Cloneable, Descriptor, Serializable
public class DescriptorSupport
extends Object
implements Descriptor

This class represents the metadata set for a ModelMBean element. A descriptor is part of the ModelMBeanInfo, ModelMBeanNotificationInfo, ModelMBeanAttributeInfo, ModelMBeanConstructorInfo, and ModelMBeanParameterInfo.

A descriptor consists of a collection of fields. Each field is in fieldname=fieldvalue format. Field names are not case sensitive, case will be preserved on field values.

All field names and values are not predefined. New fields can be defined and added by any program. Some fields have been predefined for consistency of implementation and support by the ModelMBeanInfo, ModelMBeanAttributeInfo, ModelMBeanConstructorInfo, ModelMBeanNotificationInfo, ModelMBeanOperationInfo and ModelMBean classes.

See Also:
Serialized Form

Constructor Summary
DescriptorSupport()
Descriptor default constructor.
DescriptorSupport(DescriptorSupport inDescr)
Descriptor constructor taking a Descriptor as parameter.
DescriptorSupport(int initNumFields)
Descriptor constructor.
DescriptorSupport(String inStr)
Descriptor constructor taking an XML String.
DescriptorSupport(String[] fields)
Constructor taking fields in the fieldName=fieldValue format.
DescriptorSupport(String[] fieldNames, Object[] fieldValues)
Constructor taking field names and field values.
Method Summary
Object | clone() Returns a new Descriptor which is a duplicate of the Descriptor.
String[] | getFieldNames() Returns all the fields names in the descriptor.
String[] | getFields() Returns all the fields in the descriptor.
Object | getFieldValue(String inFieldName) Returns the value for a specific fieldname.
Object[] | getFieldValues(String[] fieldNames) Returns all the field values in the descriptor as an array of Objects.
boolean | isValid() Returns true if all of the fields have legal values given their names.
void | removeField(String fieldName) Removes a field from the descriptor.
void | setField(String inFieldName, Object fieldValue) Sets the string value for a specific fieldname.
void | setFields(String[] fieldNames, Object[] fieldValues) Sets all Fields in the list to the new value in with the same index in the fieldValue array.
String | toString() Returns a human readable string representing the descriptor.
String | toXMLString() Returns an XML String representing the descriptor.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DescriptorSupport

public DescriptorSupport()
Descriptor default constructor. Default initial descriptor size is 20. It will grow as needed.
Note that the created empty descriptor is not a valid descriptor (the method isValid returns false)

DescriptorSupport

public DescriptorSupport(int initNumFields)
                  throws MBeanException,
                         RuntimeOperationsException
Descriptor constructor. Takes as parameter the initial capacity of the Map that stores the descriptor fields. Capacity will grow as needed.
Note that the created empty descriptor is not a valid descriptor (the method isValid returns false)

Parameters:
initNumFields - The initial capacity of the Map that stores the descriptor fields.
Throws:
RuntimeOperationsException - for illegal value for initNumFields ( <= 0)="0)" MBeanException - Wraps a distributed communication Exception.

DescriptorSupport

public DescriptorSupport(DescriptorSupport inDescr)
Descriptor constructor taking a Descriptor as parameter. Creates a new descriptor initialized to the values of the descriptor passed in parameter.

Parameters:
inDescr - the descriptor to be used to initialize the constructed descriptor. If it is null or contains no descriptor fields, an empty Descriptor will be created.

DescriptorSupport

public DescriptorSupport(String inStr)
                  throws MBeanException,
                         RuntimeOperationsException,
                         XMLParseException

Descriptor constructor taking an XML String.

The format of the XML string is not defined, but an implementation must ensure that the string returned by toXMLString() on an existing descriptor can be used to instantiate an equivalent descriptor using this constructor.

In this implementation, all field values will be created as Strings. If the field values are not Strings, the programmer will have to reset or convert these fields correctly.

Parameters:
inStr - An XML-formatted string used to populate this Descriptor. The format is not defined, but any implementation must ensure that the string returned by method toXMLString on an existing descriptor can be used to instantiate an equivalent descriptor when instantiated using this constructor.
Throws:
RuntimeOperationsException - If the String inStr passed in parameter is null
XMLParseException - XML parsing problem while parsing the input String
MBeanException - Wraps a distributed communication Exception.

DescriptorSupport

public DescriptorSupport(String[] fieldNames,
                         Object[] fieldValues)
                  throws RuntimeOperationsException
Constructor taking field names and field values. The array and array elements cannot be null.

Parameters:
fieldNames - String array of field names. No elements of this array can be null.
fieldValues - Object array of the corresponding field values. Elements of the array can be null. The fieldValue must be valid for the fieldName (as defined in method isValid) Note: array sizes of parameters should match. If both arrays are null or empty, then an empty descriptor is created.
Throws:
RuntimeOperationsException - for illegal value for field Names or field Values. The array lengths must be equal. If the descriptor construction fails for any reason, this exception will be thrown.

DescriptorSupport

public DescriptorSupport(String[] fields)
Constructor taking fields in the fieldName=fieldValue format.

Parameters:
fields - String array of with each element containing a field name and value. If this array is null or empty, then the default constructor will be executed. Null strings or empty strings will be ignored. All fields values should be Strings. If the field values are not Strings, the programmer will have to reset or convert these fields correctly. Note: Each string should be of the form fieldName=fieldValue.
Throws:
RuntimeOperationsException - for illegal value for field Names or field Values. The field must contain an "=". "=fieldValue", "fieldName", and "fieldValue" are illegal. FieldName cannot be null. "fieldName=" will cause the value to be null. If the descriptor construction fails for any reason, this exception will be thrown.
Method Detail

getFieldValue

public Object getFieldValue(String inFieldName)
                     throws RuntimeOperationsException
Returns the value for a specific fieldname.

Specified by:
getFieldValue in interface Descriptor
Parameters:
inFieldName - The field name in question; if not found, null is returned.
Returns:
An Object representing the field value
Throws:
RuntimeOperationsException - for illegal value (null or empty string) for field Names.

setField

public void setField(String inFieldName,
                     Object fieldValue)
              throws RuntimeOperationsException
Sets the string value for a specific fieldname. The value must be valid for the field (as defined in method isValid). If the field does not exist, it is added at the end of the Descriptor. If it does exist, the value is replaced.

Specified by:
setField in interface Descriptor
Parameters:
inFieldName - The field name to be set. Must not be null or empty string.
fieldValue - The field value to be set for the field name. Can be null.
Throws:
RuntimeOperationsException - for illegal value for field Names.

getFields

public String[] getFields()
Returns all the fields in the descriptor. The order is not the order in which the fields were set.

Specified by:
getFields in interface Descriptor
Returns:
String array of fields in the format fieldName=fieldValue. If there are no fields in the descriptor, then an empty String array is returned. If a fieldValue is not a String then the toString() method is called on it and its returned value is used as the value for the field enclosed in parenthesis.
See Also:
setFields(java.lang.String[], java.lang.Object[])

getFieldNames

public String[] getFieldNames()
Returns all the fields names in the descriptor. The order is not the order in which the fields were set.

Specified by:
getFieldNames in interface Descriptor
Returns:
String array of fields names. If the descriptor is empty, you will get an empty array.

getFieldValues

public Object[] getFieldValues(String[] fieldNames)
Returns all the field values in the descriptor as an array of Objects. The returned values are in the same order as the fieldNames String array parameter.

Specified by:
getFieldValues in interface Descriptor
Parameters:
fieldNames - String array of the names of the fields that the values should be returned for.
If the array is empty then an empty array will be returned.
If the array is 'null' then all values will be returned. The order is not the order in which the fields were set.
If a field name in the array does not exist, then null is returned for the matching array element being returned.
Returns:
Object array of field values. If the descriptor is empty, you will get an empty array.

setFields

public void setFields(String[] fieldNames,
                      Object[] fieldValues)
               throws RuntimeOperationsException
Sets all Fields in the list to the new value in with the same index in the fieldValue array. Array sizes must match. The field value will be validated before it is set (by calling the method isValid) If it is not valid, then an exception will be thrown. If the arrays are empty, then no change will take effect.

Specified by:
setFields in interface Descriptor
Parameters:
fieldNames - String array of field names. The array and array elements cannot be null.
fieldValues - Object array of the corresponding field values. The array cannot be null. Elements of the array can be null.
Throws:
RuntimeOperationsException - for illegal value for field Names or field Values. Neither can be null. The array lengths must be equal.
See Also:
getFields()

clone

public Object clone()
             throws RuntimeOperationsException
Returns a new Descriptor which is a duplicate of the Descriptor.

Specified by:
clone in interface Descriptor
Throws:
RuntimeOperationsException - for illegal value for field Names or field Values. If the descriptor construction fails for any reason, this exception will be thrown.

removeField

public void removeField(String fieldName)
Removes a field from the descriptor.

Specified by:
removeField in interface Descriptor
Parameters:
fieldName - String name of the field to be removed. If the field is not found no exception is thrown.

isValid

public boolean isValid()
                throws RuntimeOperationsException
Returns true if all of the fields have legal values given their names.

This implementation does not support interopreating with a directory or lookup service. Thus, conforming to the specification, no checking is done on the "export" field.

Otherwise this implementation returns false if:

  • name and descriptorType fieldNames are not defined, or null, or empty, or not String
  • class, role, getMethod, setMethod fieldNames, if defined, are null or not String
  • persistPeriod, currencyTimeLimit, lastUpdatedTimeStamp, lastReturnedTimeStamp if defined, are null, or not a Numeric String or not a Numeric Value >= -1
  • log fieldName, if defined, is null, or not a Boolean or not a String with value "t", "f", "true", "false". These String values must not be case sensitive.
  • visibility fieldName, if defined, is null, or not a Numeric String or a not Numeric Value >= 1 and <= 4="4" severity fieldName, if defined, is null, or not a Numeric String or not a Numeric Value >= 1 and <= 5
  • persistPolicy fieldName, if defined, is null, or not a following String :
    "OnUpdate", "OnTimer", "NoMoreOftenThan", "Always", "Never". These String values must not be case sensitive.

Specified by:
isValid in interface Descriptor
Returns:
true if the values are legal.
Throws:
RuntimeOperationsException - If the validity checking fails for any reason, this exception will be thrown.

toXMLString

public String toXMLString()

Returns an XML String representing the descriptor.

The format is not defined, but an implementation must ensure that the string returned by this method can be used to build an equivalent descriptor when instantiated using the constructor DescriptorSupport(String inStr).

Fields which are not String objects will have toString() called on them to create the value. The value will be enclosed in parentheses. It is not guaranteed that you can reconstruct these objects unless they have been specifically set up to support toString() in a meaningful format and have a matching constructor that accepts a String in the same format.

If the descriptor is empty the following String is returned: <Descriptor></Descriptor>

Returns:
the XML string.
Throws:
RuntimeOperationsException - for illegal value for field Names or field Values. If the XML formated string construction fails for any reason, this exception will be thrown.

toString

public String toString()
Returns a human readable string representing the descriptor. The string will be in the format of "fieldName=fieldValue,fieldName2=fieldValue2,..."
If there are no fields in the descriptor, then an empty String is returned.
If a fieldValue is an object then the toString() method is called on it and its returned value is used as the value for the field enclosed in parenthesis.

Throws:
RuntimeOperationsException - for illegal value for field Names or field Values. If the descriptor string fails for any reason, this exception will be thrown.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidTargetObjectTypeException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Class InvalidTargetObjectTypeException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.modelmbean.InvalidTargetObjectTypeException
All Implemented Interfaces:
Serializable
public class InvalidTargetObjectTypeException
extends Exception

Exception thrown when an invalid target object type is specified.

See Also:
Serialized Form

Constructor Summary
InvalidTargetObjectTypeException()
Default constructor.
InvalidTargetObjectTypeException(Exception e, String s)
Constructor taking an exception and a string.
InvalidTargetObjectTypeException(String s)
Constructor from a string.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidTargetObjectTypeException

public InvalidTargetObjectTypeException()
Default constructor.

InvalidTargetObjectTypeException

public InvalidTargetObjectTypeException(String s)
Constructor from a string.

Parameters:
s - String value that will be incorporated in the message for this exception.

InvalidTargetObjectTypeException

public InvalidTargetObjectTypeException(Exception e,
                                        String s)
Constructor taking an exception and a string.

Parameters:
e - Exception that we may have caught to reissue as an InvalidTargetObjectTypeException. The message will be used, and we may want to consider overriding the printStackTrace() methods to get data pointing back to original throw stack.
s - String value that will be incorporated in message for this exception.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ModelMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Interface ModelMBean

All Superinterfaces:
DynamicMBean, ModelMBeanNotificationBroadcaster, NotificationBroadcaster, PersistentMBean
All Known Implementing Classes:
RequiredModelMBean
public interface ModelMBean
extends DynamicMBean, PersistentMBean, ModelMBeanNotificationBroadcaster

This interface must be implemented by the ModelMBeans. An implementation of this interface must be shipped with every JMX Agent.

Java resources wishing to be manageable instantiate the ModelMBean using the MBeanServer's createMBean method. The resource then sets the ModelMBeanInfo (with Descriptors) for the ModelMBean instance. The attributes and operations exposed via the ModelMBeanInfo for the ModelMBean are accessible from MBeans, connectors/adaptors like other MBeans. Through the ModelMBeanInfo Descriptors, values and methods in the managed application can be defined and mapped to attributes and operations of the ModelMBean. This mapping can be defined during development in an XML formatted file or dynamically and programmatically at runtime.

Every ModelMBean which is instantiated in the MBeanServer becomes manageable: its attributes and operations become remotely accessible through the connectors/adaptors connected to that MBeanServer. A Java object cannot be registered in the MBeanServer unless it is a JMX compliant MBean. By instantiating a ModelMBean, resources are guaranteed that the MBean is valid.

MBeanException and RuntimeOperationsException must be thrown on every public method. This allows for wrappering exceptions from distributed communications (RMI, EJB, etc.). These exceptions do not have to be thrown by the implementation except in the scenarios described in the specification and javadoc.

Method Summary
void | setManagedResource(Object mr, String mr_type) Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).
void | setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo) Initializes a ModelMBean object using ModelMBeanInfo passed in.
Methods inherited from interface javax.management.DynamicMBean
getAttribute, getAttributes, getMBeanInfo, invoke, setAttribute, setAttributes
Methods inherited from interface javax.management.PersistentMBean
load, store
Methods inherited from interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster
addAttributeChangeNotificationListener, removeAttributeChangeNotificationListener, sendAttributeChangeNotification, sendAttributeChangeNotification, sendNotification, sendNotification
Methods inherited from interface javax.management.NotificationBroadcaster
addNotificationListener, getNotificationInfo, removeNotificationListener

Method Detail

setModelMBeanInfo

public void setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo)
                       throws MBeanException,
                              RuntimeOperationsException
Initializes a ModelMBean object using ModelMBeanInfo passed in. This method makes it possible to set a customized ModelMBeanInfo on the ModelMBean as long as it is not registered with the MBeanServer.
Once the ModelMBean's ModelMBeanInfo (with Descriptors) are customized and set on the ModelMBean, the ModelMBean can be registered with the MBeanServer.

If the ModelMBean is currently registered, this method throws a RuntimeOperationsException wrapping an IllegalStateException

Parameters:
inModelMBeanInfo - The ModelMBeanInfo object to be used by the ModelMBean.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException -
  • Wraps an IllegalArgumentException if the MBeanInfo passed in parameter is null.
  • Wraps an IllegalStateException if the ModelMBean is currently registered in the MBeanServer.

setManagedResource

public void setManagedResource(Object mr,
                               String mr_type)
                        throws MBeanException,
                               RuntimeOperationsException,
                               InstanceNotFoundException,
                               InvalidTargetObjectTypeException
Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).

Parameters:
mr - Object that is the managed resource
mr_type - The type of reference for the managed resource. Can be: ObjectReference, Handle, IOR, EJBHandle, RMIReference. If the MBeanServer cannot process the mr_type passed in, an InvalidTargetTypeException will be thrown.
Throws:
MBeanException - The initializer of the object has thrown an exception.
RuntimeOperationsException - Wraps an IllegalArgumentException: The managed resource type passed in parameter is null.
InstanceNotFoundException - The managed resource object could not be found
InvalidTargetObjectTypeException - The managed resource type cannot be processed by the ModelMBean or JMX Agent.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ModelMBeanAttributeInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Class ModelMBeanAttributeInfo

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanAttributeInfo
            extended by javax.management.modelmbean.ModelMBeanAttributeInfo
All Implemented Interfaces:
Cloneable, DescriptorAccess, Serializable
public class ModelMBeanAttributeInfo
extends MBeanAttributeInfo
implements DescriptorAccess, Cloneable

The ModelMBeanAttributeInfo object describes an attribute of the ModelMBean. It is a subclass of MBeanAttributeInfo with the addition of an associated Descriptor and an implementation of the DescriptorAccess interface.

The fields in the descriptor are defined, but not limited to, the following:

 name           : attribute name
 descriptorType : must be "attribute"
 value          : current value for attribute
 default        : default value for attribute
 displayName    : name of attribute to be used in displays
 getMethod      : name of operation descriptor for get method
 setMethod      : name of operation descriptor for set method
 protocolMap    : object which implements the Descriptor interface: mappings must be appropriate for the attribute
                  and entries can be updated or augmentted at runtime.
 persistPolicy  : OnUpdate|OnTimer|NoMoreOftenThan|Always|Never
 persistPeriod  : seconds - frequency of persist cycle. Used when persistPolicy is"OnTimer" or "NoMoreOftenThan".
 currencyTimeLimit : how long value is valid, <0 never,="0" always,="always,">0 seconds
 lastUpdatedTimeStamp : when value was set
 visibility     : 1-4 where 1: always visible 4: rarely visible
 presentationString : xml formatted string to allow presentation of data
The default descriptor contains the name, descriptorType and displayName fields.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
ModelMBeanAttributeInfo(ModelMBeanAttributeInfo inInfo)
Constructs a new ModelMBeanAttributeInfo object from this ModelMBeanAttributeInfo Object.
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter)
Constructs a ModelMBeanAttributeInfo object with a default descriptor.
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter, Descriptor descriptor)
Constructs a ModelMBeanAttributeInfo object.
ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)
Constructs a ModelMBeanAttributeInfo object with a default descriptor.
ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
Constructs a ModelMBeanAttributeInfo object with a default descriptor.
Method Summary
Object | clone() Creates and returns a new ModelMBeanAttributeInfo which is a duplicate of this ModelMBeanAttributeInfo.
Descriptor | getDescriptor() Gets a copy of the associated Descriptor for the ModelMBeanAttributeInfo.
void | setDescriptor(Descriptor inDescriptor) Sets associated Descriptor (full replace) for the ModelMBeanAttributeDescriptor.
String | toString() Returns a human-readable version of the ModelMBeanAttributeInfo instance.
Methods inherited from class javax.management.MBeanAttributeInfo
equals, getType, hashCode, isIs, isReadable, isWritable
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ModelMBeanAttributeInfo

public ModelMBeanAttributeInfo(String name,
                               String description,
                               Method getter,
                               Method setter)
                        throws IntrospectionException
Constructs a ModelMBeanAttributeInfo object with a default descriptor.

Parameters:
name - The name of the attribute.
description - A human readable description of the attribute. Optional.
getter - The method used for reading the attribute value. May be null if the property is write-only.
setter - The method used for writing the attribute value. May be null if the attribute is read-only.
Throws:
IntrospectionException - There is a consistency problem in the definition of this attribute.

ModelMBeanAttributeInfo

public ModelMBeanAttributeInfo(String name,
                               String description,
                               Method getter,
                               Method setter,
                               Descriptor descriptor)
                        throws IntrospectionException
Constructs a ModelMBeanAttributeInfo object.

Parameters:
name - The name of the attribute.
description - A human readable description of the attribute. Optional.
getter - The method used for reading the attribute value. May be null if the property is write-only.
setter - The method used for writing the attribute value. May be null if the attribute is read-only.
descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the Attribute. If it is null, then a default descriptor will be created. If the descriptor does not contain the field "displayName" this field is added in the descriptor with its default value.
Throws:
IntrospectionException - There is a consistency problem in the definition of this attribute.
RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to name parameter, or descriptor field "DescriptorType" is not equal to "attribute".

ModelMBeanAttributeInfo

public ModelMBeanAttributeInfo(String name,
                               String type,
                               String description,
                               boolean isReadable,
                               boolean isWritable,
                               boolean isIs)
Constructs a ModelMBeanAttributeInfo object with a default descriptor.

Parameters:
name - The name of the attribute
type - The type or class name of the attribute
description - A human readable description of the attribute.
isReadable - True if the attribute has a getter method, false otherwise.
isWritable - True if the attribute has a setter method, false otherwise.
isIs - True if the attribute has an "is" getter, false otherwise.

ModelMBeanAttributeInfo

public ModelMBeanAttributeInfo(String name,
                               String type,
                               String description,
                               boolean isReadable,
                               boolean isWritable,
                               boolean isIs,
                               Descriptor descriptor)
Constructs a ModelMBeanAttributeInfo object with a default descriptor.

Parameters:
name - The name of the attribute
type - The type or class name of the attribute
description - A human readable description of the attribute.
isReadable - True if the attribute has a getter method, false otherwise.
isWritable - True if the attribute has a setter method, false otherwise.
isIs - True if the attribute has an "is" getter, false otherwise.
descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the Attribute. If it is null then a default descriptor will be created. If the descriptor does not contain the field "displayName" this field is added in the descriptor with its default value.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to name parameter, or descriptor field "DescriptorType" is not equal to "attribute".

ModelMBeanAttributeInfo

public ModelMBeanAttributeInfo(ModelMBeanAttributeInfo inInfo)
Constructs a new ModelMBeanAttributeInfo object from this ModelMBeanAttributeInfo Object. A default descriptor will be created.

Parameters:
inInfo - the ModelMBeanAttributeInfo to be duplicated
Method Detail

getDescriptor

public Descriptor getDescriptor()
Gets a copy of the associated Descriptor for the ModelMBeanAttributeInfo.

Specified by:
getDescriptor in interface DescriptorAccess
Returns:
Descriptor associated with the ModelMBeanAttributeInfo object.
See Also:
setDescriptor(javax.management.Descriptor)

setDescriptor

public void setDescriptor(Descriptor inDescriptor)
Sets associated Descriptor (full replace) for the ModelMBeanAttributeDescriptor. If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor. The Descriptor is validated before it is assigned. If the new Descriptor is invalid, then a RuntimeOperationsException wrapping an IllegalArgumentException is thrown.

Specified by:
setDescriptor in interface DescriptorAccess
Parameters:
inDescriptor - replaces the Descriptor associated with the ModelMBeanAttributeInfo
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException for an invalid Descriptor
See Also:
getDescriptor()

clone

public Object clone()
Creates and returns a new ModelMBeanAttributeInfo which is a duplicate of this ModelMBeanAttributeInfo.

Overrides:
clone in class MBeanAttributeInfo
Throws:
RuntimeOperationsException - for illegal value for field Names or field Values. If the descriptor construction fails for any reason, this exception will be thrown.

toString

public String toString()
Returns a human-readable version of the ModelMBeanAttributeInfo instance.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ModelMBeanConstructorInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Class ModelMBeanConstructorInfo

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanConstructorInfo
            extended by javax.management.modelmbean.ModelMBeanConstructorInfo
All Implemented Interfaces:
Cloneable, DescriptorAccess, Serializable
public class ModelMBeanConstructorInfo
extends MBeanConstructorInfo
implements DescriptorAccess, Cloneable

The ModelMBeanConstructorInfo object describes a constructor of the ModelMBean. It is a subclass of MBeanConstructorInfo with the addition of an associated Descriptor and an implementation of the DescriptorAccess interface.

 The fields in the descriptor are defined, but not limited to, the following:

 name           : constructor name
 descriptorType : must be "operation"
 role           : must be "constructor"
 displayName    : human readable name of constructor
 visibility            : 1-4 where 1: always visible 4: rarely visible
 presentationString :  xml formatted string to describe how to present operation
The persistPolicy and currencyTimeLimit fields are not valid for the constructor. The default descriptor will have the name, descriptorType, displayName and role fields.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
ModelMBeanConstructorInfo(String description, Constructor constructorMethod)
Constructs a MBeanConstructorInfo object with a default descriptor.
ModelMBeanConstructorInfo(String description, Constructor constructorMethod, Descriptor descriptor)
Constructs a MBeanConstructorInfo object.
ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
Constructs a ModelMBeanConstructorInfo object with a default descriptor.
ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
Constructs a MBeanConstructorInfo object.
Method Summary
Object | clone() Creates and returns a new ModelMBeanConstructorInfo which is a duplicate of this ModelMBeanConstructorInfo.
Descriptor | getDescriptor() Returns a copy of the associated Descriptor.
void | setDescriptor(Descriptor inDescriptor) Sets associated Descriptor (full replace) of ModelMBeanConstructorInfo.
String | toString() Returns a string containing the entire contents of the ModelMBeanConstructorInfo in human readable form.
Methods inherited from class javax.management.MBeanConstructorInfo
equals, getSignature, hashCode
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ModelMBeanConstructorInfo

public ModelMBeanConstructorInfo(String description,
                                 Constructor constructorMethod)
Constructs a MBeanConstructorInfo object with a default descriptor.

Parameters:
description - A human readable description of the constructor.
constructorMethod - The java.lang.reflect.Method object describing the MBean constructor.

ModelMBeanConstructorInfo

public ModelMBeanConstructorInfo(String description,
                                 Constructor constructorMethod,
                                 Descriptor descriptor)
Constructs a MBeanConstructorInfo object.

Parameters:
description - A human readable description of the constructor.
constructorMethod - The java.lang.reflect.Method object describing the ModelMBean constructor.
descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the ModelMBeanConstructorInfo. If it is null, then a default descriptor will be created.If the descriptor does not contain the field "displayName" this fields is added in the descriptor with its default value.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to name parameter, or descriptor field "DescriptorType" is not equal to "operation" or descriptor field "role" is not equal to "constructor".

ModelMBeanConstructorInfo

public ModelMBeanConstructorInfo(String name,
                                 String description,
                                 MBeanParameterInfo[] signature)
Constructs a ModelMBeanConstructorInfo object with a default descriptor.

Parameters:
name - The name of the constructor.
description - A human readable description of the constructor.
signature - MBeanParameterInfo object array describing the parameters(arguments) of the constructor.

ModelMBeanConstructorInfo

public ModelMBeanConstructorInfo(String name,
                                 String description,
                                 MBeanParameterInfo[] signature,
                                 Descriptor descriptor)
Constructs a MBeanConstructorInfo object.

Parameters:
name - The name of the constructor.
description - A human readable description of the constructor.
signature - MBeanParameterInfo objects describing the parameters(arguments) of the constructor.
descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the MBeanConstructorInfo. If it is null then a default descriptor will be created. If the descriptor does not contain the field "displayName" this field is added in the descriptor with its default value.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to name parameter, or descriptor field "DescriptorType" is not equal to "operation" or descriptor field "role" is not equal to "constructor".
Method Detail

clone

public Object clone()
Creates and returns a new ModelMBeanConstructorInfo which is a duplicate of this ModelMBeanConstructorInfo.

Overrides:
clone in class MBeanConstructorInfo

getDescriptor

public Descriptor getDescriptor()
Returns a copy of the associated Descriptor.

Specified by:
getDescriptor in interface DescriptorAccess
Returns:
Descriptor associated with the ModelMBeanConstructorInfo object.
See Also:
setDescriptor(javax.management.Descriptor)

setDescriptor

public void setDescriptor(Descriptor inDescriptor)
Sets associated Descriptor (full replace) of ModelMBeanConstructorInfo. If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor. The Descriptor is validated before it is assigned. If the new Descriptor is invalid, then a RuntimeOperationsException wrapping an IllegalArgumentException is thrown.

Specified by:
setDescriptor in interface DescriptorAccess
Parameters:
inDescriptor - replaces the Descriptor associated with the ModelMBeanConstructor. If the descriptor does not contain the field "displayName" this field is added in the descriptor with its default value.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to name parameter, or descriptor field "DescriptorType" is not equal to "operation" or descriptor field "role" is not equal to "constructor".
See Also:
getDescriptor()

toString

public String toString()
Returns a string containing the entire contents of the ModelMBeanConstructorInfo in human readable form.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ModelMBeanInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Interface ModelMBeanInfo

All Known Implementing Classes:
ModelMBeanInfoSupport
public interface ModelMBeanInfo

This interface is implemented by the ModelMBeanInfo for every ModelMBean. An implementation of this interface must be shipped with every JMX Agent.

Java resources wishing to be manageable instantiate the ModelMBean using the MBeanServer's createMBean method. The resource then sets the ModelMBeanInfo and Descriptors for the ModelMBean instance. The attributes, operations, and notifications exposed via the ModelMBeanInfo for the ModelMBean comprise the management interface and are accessible from MBeans, connectors/adaptors like other MBeans. Through the Descriptors, values and methods in the managed application can be defined and mapped to attributes and operations of the ModelMBean. This mapping can be defined during development in a file or dynamically and programmatically at runtime.

Every ModelMBean which is instantiated in the MBeanServer becomes manageable: its attributes, operations, and notifications become remotely accessible through the connectors/adaptors connected to that MBeanServer. A Java object cannot be registered in the MBeanServer unless it is a JMX compliant MBean. By instantiating a ModelMBean, resources are guaranteed that the MBean is valid. MBeanException and RuntimeOperationsException must be thrown on every public method. This allows for wrappering exceptions from distributed communications (RMI, EJB, etc.)

Method Summary
Object | clone() Creates and returns a copy of this object.
ModelMBeanAttributeInfo | getAttribute(String inName) Returns a ModelMBeanAttributeInfo requested by name.
MBeanAttributeInfo[] | getAttributes() Returns the list of attributes exposed for management.
String | getClassName() Returns the name of the Java class of the MBean described by this MBeanInfo.
MBeanConstructorInfo[] | getConstructors() Returns the list of the public constructors of the MBean.
String | getDescription() Returns a human readable description of the MBean.
Descriptor | getDescriptor(String inDescriptorName, String inDescriptorType) Returns a Descriptor requested by name and descriptorType.
Descriptor[] | getDescriptors(String inDescriptorType) Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.
Descriptor | getMBeanDescriptor() Returns the ModelMBean's descriptor which contains MBean wide policies.
ModelMBeanNotificationInfo | getNotification(String inName) Returns a ModelMBeanNotificationInfo requested by name.
MBeanNotificationInfo[] | getNotifications() Returns the list of the notifications emitted by the MBean.
ModelMBeanOperationInfo | getOperation(String inName) Returns a ModelMBeanOperationInfo requested by name.
MBeanOperationInfo[] | getOperations() Returns the list of operations of the MBean.
void | setDescriptor(Descriptor inDescriptor, String inDescriptorType) Sets descriptors in the info array of type inDescriptorType for the ModelMBean.
void | setDescriptors(Descriptor[] inDescriptors) Adds or replaces descriptors in the ModelMBeanInfo.
void | setMBeanDescriptor(Descriptor inDescriptor) Sets the ModelMBean's descriptor.

Method Detail

getDescriptors

public Descriptor[] getDescriptors(String inDescriptorType)
                            throws MBeanException,
                                   RuntimeOperationsException
Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.

Parameters:
inDescriptorType - value of descriptorType field that must be set for the descriptor to be returned. Must be "mbean", "attribute", "operation", "constructor" or "notification". If it is null or empty then all types will be returned.
Returns:
Descriptor array containing all descriptors for the ModelMBean if type inDescriptorType.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException when the descriptorType in parameter is not one of: "mbean", "attribute", "operation", "constructor", "notification", empty or null.
See Also:
setDescriptors(javax.management.Descriptor[])

setDescriptors

public void setDescriptors(Descriptor[] inDescriptors)
                    throws MBeanException,
                           RuntimeOperationsException
Adds or replaces descriptors in the ModelMBeanInfo.

Parameters:
inDescriptors - The descriptors to be set in the ModelMBeanInfo. Null elements of the list will be ignored. All descriptors must have name and descriptorType fields.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException for a null or invalid descriptor.
MBeanException - Wraps a distributed communication Exception.
See Also:
getDescriptors(java.lang.String)

getDescriptor

public Descriptor getDescriptor(String inDescriptorName,
                                String inDescriptorType)
                         throws MBeanException,
                                RuntimeOperationsException
Returns a Descriptor requested by name and descriptorType.

Parameters:
inDescriptorName - The name of the descriptor.
inDescriptorType - The type of the decriptor being requested. If this is null or empty then all types are searched. Valid types are 'mbean', 'attribute', 'constructor' 'operation', and 'notification'. This value will be equal to the 'descriptorType' field in the descriptor that is returned.
Returns:
Descriptor containing the descriptor for the ModelMBean with the same name and descriptorType. If no descriptor is found, null is returned.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for a null descriptor name or null or invalid type. The type must be "mbean","attribute", "constructor", "operation", or "notification".
See Also:
setDescriptor(javax.management.Descriptor, java.lang.String)

setDescriptor

public void setDescriptor(Descriptor inDescriptor,
                          String inDescriptorType)
                   throws MBeanException,
                          RuntimeOperationsException
Sets descriptors in the info array of type inDescriptorType for the ModelMBean. The setDescriptor method of the corresponding ModelMBean*Info will be called to set the specified descriptor.

Parameters:
inDescriptor - The descriptor to be set in the ModelMBean. It must NOT be null. All descriptors must have name and descriptorType fields.
inDescriptorType - The type of the descriptor being set. If this is null then the descriptorType field in the descriptor is used. If specified this value must be set in the descriptorType field in the descriptor. Must be "mbean","attribute", "constructor", "operation", or "notification".
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException for illegal or null arguments or if the name field of the descriptor is not found in the corresponding MBeanAttributeInfo or MBeanConstructorInfo or MBeanNotificationInfo or MBeanOperationInfo.
MBeanException - Wraps a distributed communication Exception.
See Also:
getDescriptor(java.lang.String, java.lang.String)

getMBeanDescriptor

public Descriptor getMBeanDescriptor()
                              throws MBeanException,
                                     RuntimeOperationsException
Returns the ModelMBean's descriptor which contains MBean wide policies. This descriptor contains metadata about the MBean and default policies for persistence and caching.

 The fields in the descriptor are defined, but not limited to, the following:
 name           : MBean name
 descriptorType : must be "mbean"
 displayName    : name of attribute to be used in displays
 persistPolicy  : OnUpdate|OnTimer|NoMoreOftenThan|Always|Never
 persistLocation : The fully qualified directory name where the MBean should be persisted (if appropriate)
 persistFile    : File name into which the MBean should be persisted
 persistPeriod  : seconds - frequency of persist cycle for OnTime and NoMoreOftenThan PersistPolicy
 currencyTimeLimit : how long value is valid, <0 never,="0" always,="always,">0 seconds
 log            : where t: log all notifications f: log no notifications
 logfile        : fully qualified filename to log events to
 visibility     : 1-4 where 1: always visible 4: rarely visible
 export         : name to be used to export/expose this MBean so that it is findable by
                  other JMX Agents.
 presentationString : xml formatted string to allow presentation of data to be associated with the MBean.

The default descriptor is: name=mbeanName,descriptorType=mbean, displayName=this.getClassName(), persistPolicy=never,log=F,export=F,visiblity=1 If the descriptor does not contain all these fields, they will be added with these default values.

Returns:
the MBean descriptor.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - a RuntimeException occurred while getting the descriptor.
See Also:
setMBeanDescriptor(javax.management.Descriptor)

setMBeanDescriptor

public void setMBeanDescriptor(Descriptor inDescriptor)
                        throws MBeanException,
                               RuntimeOperationsException
Sets the ModelMBean's descriptor. This descriptor contains default, MBean wide metadata about the MBean and default policies for persistence and caching. This operation does a complete replacement of the descriptor, no merging is done. If the descriptor to set to is null then the default descriptor will be created. The default descriptor is: name=mbeanName,descriptorType=mbean, displayName=this.getClassName(), persistPolicy=never,log=F,export=F,visiblity=1 If the descriptor does not contain all these fields, they will be added with these default values. See getMBeanDescriptor method javadoc for description of valid field names.

Parameters:
inDescriptor - the descriptor to set.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for invalid descriptor.
See Also:
getMBeanDescriptor()

getAttribute

public ModelMBeanAttributeInfo getAttribute(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
Returns a ModelMBeanAttributeInfo requested by name.

Parameters:
inName - The name of the ModelMBeanAttributeInfo to get. If no ModelMBeanAttributeInfo exists for this name null is returned.
Returns:
the attribute info for the named attribute, or null if there is none.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for a null attribute name.

getOperation

public ModelMBeanOperationInfo getOperation(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
Returns a ModelMBeanOperationInfo requested by name.

Parameters:
inName - The name of the ModelMBeanOperationInfo to get. If no ModelMBeanOperationInfo exists for this name null is returned.
Returns:
the operation info for the named operation, or null if there is none.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for a null operation name.

getNotification

public ModelMBeanNotificationInfo getNotification(String inName)
                                           throws MBeanException,
                                                  RuntimeOperationsException
Returns a ModelMBeanNotificationInfo requested by name.

Parameters:
inName - The name of the ModelMBeanNotificationInfo to get. If no ModelMBeanNotificationInfo exists for this name null is returned.
Returns:
the info for the named notification, or null if there is none.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for a null notification name.

clone

public Object clone()
Creates and returns a copy of this object.

getAttributes

public MBeanAttributeInfo[] getAttributes()
Returns the list of attributes exposed for management. Each attribute is described by an MBeanAttributeInfo object.

Returns:
An array of MBeanAttributeInfo objects.

getClassName

public String getClassName()
Returns the name of the Java class of the MBean described by this MBeanInfo.

Returns:
the Java class name.

getConstructors

public MBeanConstructorInfo[] getConstructors()
Returns the list of the public constructors of the MBean. Each constructor is described by an MBeanConstructorInfo object.

Returns:
An array of MBeanConstructorInfo objects.

getDescription

public String getDescription()
Returns a human readable description of the MBean.

Returns:
the description.

getNotifications

public MBeanNotificationInfo[] getNotifications()
Returns the list of the notifications emitted by the MBean. Each notification is described by an MBeanNotificationInfo object.

In addition to any notification specified by the application, a ModelMBean may always send also two additional notifications:

  • One with descriptor name "GENERIC" and displayName "jmx.modelmbean.generic"
  • Second is a standard attribute change notification with descriptor name "ATTRIBUTE_CHANGE" and displayName "jmx.attribute.change"
Thus any implementation of ModelMBeanInfo should always add those two notifications in addition to those specified by the application.

Returns:
An array of MBeanNotificationInfo objects.

getOperations

public MBeanOperationInfo[] getOperations()
Returns the list of operations of the MBean. Each operation is described by an MBeanOperationInfo object.

Returns:
An array of MBeanOperationInfo objects.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ModelMBeanInfoSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Class ModelMBeanInfoSupport

java.lang.Object
    extended by javax.management.MBeanInfo
        extended by javax.management.modelmbean.ModelMBeanInfoSupport
All Implemented Interfaces:
Cloneable, ModelMBeanInfo, Serializable
public class ModelMBeanInfoSupport
extends MBeanInfo
implements ModelMBeanInfo, Serializable

This class represents the meta data for ModelMBeans. Descriptors have been added on the meta data objects.

Java resources wishing to be manageable instantiate the ModelMBean using the MBeanServer's createMBean method. The resource then sets the ModelMBeanInfo and Descriptors for the ModelMBean instance. The attributes and operations exposed via the ModelMBeanInfo for the ModelMBean are accessible from MBeans, connectors/adaptors like other MBeans. Through the Descriptors, values and methods in the managed application can be defined and mapped to attributes and operations of the ModelMBean. This mapping can be defined during development in a file or dynamically and programmatically at runtime.

Every ModelMBean which is instantiated in the MBeanServer becomes manageable: its attributes and operations become remotely accessible through the connectors/adaptors connected to that MBeanServer. A Java object cannot be registered in the MBeanServer unless it is a JMX compliant MBean. By instantiating a ModelMBean, resources are guaranteed that the MBean is valid. MBeanException and RuntimeOperationsException must be thrown on every public method. This allows for wrappering exceptions from distributed communications (RMI, EJB, etc.)

See Also:
Serialized Form

Constructor Summary
ModelMBeanInfoSupport(ModelMBeanInfo mbi)
constructs a ModelMBeanInfoSupport which is a duplicate of the one passed in.
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
Creates a ModelMBeanInfoSupport with the provided information, but the descriptor is a default.
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
Creates a ModelMBeanInfoSupport with the provided information and the descriptor given in parameter.
Method Summary
Object | clone() Creates and returns a copy of this object.
ModelMBeanAttributeInfo | getAttribute(String inName) Returns a ModelMBeanAttributeInfo requested by name.
ModelMBeanConstructorInfo | getConstructor(String inName) Returns the ModelMBeanConstructorInfo requested by name.
Descriptor | getDescriptor(String inDescriptorName) Returns a Descriptor requested by name.
Descriptor | getDescriptor(String inDescriptorName, String inDescriptorType) Returns a Descriptor requested by name and descriptorType.
Descriptor[] | getDescriptors(String inDescriptorType) Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.
Descriptor | getMBeanDescriptor() Returns the ModelMBean's descriptor which contains MBean wide policies.
ModelMBeanNotificationInfo | getNotification(String inName) Returns a ModelMBeanNotificationInfo requested by name.
ModelMBeanOperationInfo | getOperation(String inName) Returns a ModelMBeanOperationInfo requested by name.
void | setDescriptor(Descriptor inDescriptor, String inDescriptorType) Sets descriptors in the info array of type inDescriptorType for the ModelMBean.
void | setDescriptors(Descriptor[] inDescriptors) Adds or replaces descriptors in the ModelMBeanInfo.
void | setMBeanDescriptor(Descriptor inMBeanDescriptor) Sets the ModelMBean's descriptor.
Methods inherited from class javax.management.MBeanInfo
equals, getAttributes, getClassName, getConstructors, getDescription, getNotifications, getOperations, hashCode
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.management.modelmbean.ModelMBeanInfo
getAttributes, getClassName, getConstructors, getDescription, getNotifications, getOperations

Constructor Detail

ModelMBeanInfoSupport

public ModelMBeanInfoSupport(ModelMBeanInfo mbi)
constructs a ModelMBeanInfoSupport which is a duplicate of the one passed in.

Parameters:
mbi - the ModelMBeanInfo instance from which the ModelMBeanInfo being created is initialized.

ModelMBeanInfoSupport

public ModelMBeanInfoSupport(String className,
                             String description,
                             ModelMBeanAttributeInfo[] attributes,
                             ModelMBeanConstructorInfo[] constructors,
                             ModelMBeanOperationInfo[] operations,
                             ModelMBeanNotificationInfo[] notifications)
Creates a ModelMBeanInfoSupport with the provided information, but the descriptor is a default. The default descriptor is: name=mbeanName,descriptorType=mbean, displayName=ClassName, persistPolicy=never,log=F, visiblity=1

Parameters:
className - classname of the MBean
description - human readable description of the ModelMBean
attributes - array of ModelMBeanAttributeInfo objects which have descriptors
constructors - array of ModelMBeanConstructorInfo objects which have descriptors
operations - array of ModelMBeanOperationInfo objects which have descriptors
notifications - array of ModelMBeanNotificationInfo objects which have descriptors

ModelMBeanInfoSupport

public ModelMBeanInfoSupport(String className,
                             String description,
                             ModelMBeanAttributeInfo[] attributes,
                             ModelMBeanConstructorInfo[] constructors,
                             ModelMBeanOperationInfo[] operations,
                             ModelMBeanNotificationInfo[] notifications,
                             Descriptor mbeandescriptor)
Creates a ModelMBeanInfoSupport with the provided information and the descriptor given in parameter.

Parameters:
className - classname of the MBean
description - human readable description of the ModelMBean
attributes - array of ModelMBeanAttributeInfo objects which have descriptors
constructors - array of ModelMBeanConstructorInfo objects which have descriptor
operations - array of ModelMBeanOperationInfo objects which have descriptor
notifications - array of ModelMBeanNotificationInfo objects which have descriptor
mbeandescriptor - descriptor to be used as the MBeanDescriptor containing MBean wide policy. if the * descriptor null, a default descriptor will be constructed. The default descriptor is: name=className, descriptorType=mbean, displayName=className, persistPolicy=never, log=F, visiblity=1. If the descriptor does not contain all these fields, they will be added with these default values.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException for invalid descriptor passed in parameter. (see getMBeanDescriptor for the definition of a valid MBean descriptor.)
Method Detail

clone

public Object clone()
Description copied from interface: ModelMBeanInfo
Creates and returns a copy of this object.

Specified by:
clone in interface ModelMBeanInfo
Overrides:
clone in class MBeanInfo

getDescriptors

public Descriptor[] getDescriptors(String inDescriptorType)
                            throws MBeanException,
                                   RuntimeOperationsException
Description copied from interface: ModelMBeanInfo
Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.

Specified by:
getDescriptors in interface ModelMBeanInfo
Parameters:
inDescriptorType - value of descriptorType field that must be set for the descriptor to be returned. Must be "mbean", "attribute", "operation", "constructor" or "notification". If it is null or empty then all types will be returned.
Returns:
Descriptor array containing all descriptors for the ModelMBean if type inDescriptorType.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException when the descriptorType in parameter is not one of: "mbean", "attribute", "operation", "constructor", "notification", empty or null.
See Also:
ModelMBeanInfo.setDescriptors(javax.management.Descriptor[])

setDescriptors

public void setDescriptors(Descriptor[] inDescriptors)
                    throws MBeanException,
                           RuntimeOperationsException
Description copied from interface: ModelMBeanInfo
Adds or replaces descriptors in the ModelMBeanInfo.

Specified by:
setDescriptors in interface ModelMBeanInfo
Parameters:
inDescriptors - The descriptors to be set in the ModelMBeanInfo. Null elements of the list will be ignored. All descriptors must have name and descriptorType fields.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for a null or invalid descriptor.
See Also:
ModelMBeanInfo.getDescriptors(java.lang.String)

getDescriptor

public Descriptor getDescriptor(String inDescriptorName)
                         throws MBeanException,
                                RuntimeOperationsException
Returns a Descriptor requested by name.

Parameters:
inDescriptorName - The name of the descriptor.
Returns:
Descriptor containing a descriptor for the ModelMBean with the same name. If no descriptor is found, null is returned.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for null name.
See Also:
setDescriptor(javax.management.Descriptor, java.lang.String)

getDescriptor

public Descriptor getDescriptor(String inDescriptorName,
                                String inDescriptorType)
                         throws MBeanException,
                                RuntimeOperationsException
Description copied from interface: ModelMBeanInfo
Returns a Descriptor requested by name and descriptorType.

Specified by:
getDescriptor in interface ModelMBeanInfo
Parameters:
inDescriptorName - The name of the descriptor.
inDescriptorType - The type of the decriptor being requested. If this is null or empty then all types are searched. Valid types are 'mbean', 'attribute', 'constructor' 'operation', and 'notification'. This value will be equal to the 'descriptorType' field in the descriptor that is returned.
Returns:
Descriptor containing the descriptor for the ModelMBean with the same name and descriptorType. If no descriptor is found, null is returned.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for a null descriptor name or null or invalid type. The type must be "mbean","attribute", "constructor", "operation", or "notification".
See Also:
ModelMBeanInfo.setDescriptor(javax.management.Descriptor, java.lang.String)

setDescriptor

public void setDescriptor(Descriptor inDescriptor,
                          String inDescriptorType)
                   throws MBeanException,
                          RuntimeOperationsException
Description copied from interface: ModelMBeanInfo
Sets descriptors in the info array of type inDescriptorType for the ModelMBean. The setDescriptor method of the corresponding ModelMBean*Info will be called to set the specified descriptor.

Specified by:
setDescriptor in interface ModelMBeanInfo
Parameters:
inDescriptor - The descriptor to be set in the ModelMBean. It must NOT be null. All descriptors must have name and descriptorType fields.
inDescriptorType - The type of the descriptor being set. If this is null then the descriptorType field in the descriptor is used. If specified this value must be set in the descriptorType field in the descriptor. Must be "mbean","attribute", "constructor", "operation", or "notification".
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException for illegal or null arguments or if the name field of the descriptor is not found in the corresponding MBeanAttributeInfo or MBeanConstructorInfo or MBeanNotificationInfo or MBeanOperationInfo.
MBeanException - Wraps a distributed communication Exception.
See Also:
ModelMBeanInfo.getDescriptor(java.lang.String, java.lang.String)

getAttribute

public ModelMBeanAttributeInfo getAttribute(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
Description copied from interface: ModelMBeanInfo
Returns a ModelMBeanAttributeInfo requested by name.

Specified by:
getAttribute in interface ModelMBeanInfo
Parameters:
inName - The name of the ModelMBeanAttributeInfo to get. If no ModelMBeanAttributeInfo exists for this name null is returned.
Returns:
the attribute info for the named attribute, or null if there is none.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for a null attribute name.

getOperation

public ModelMBeanOperationInfo getOperation(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
Description copied from interface: ModelMBeanInfo
Returns a ModelMBeanOperationInfo requested by name.

Specified by:
getOperation in interface ModelMBeanInfo
Parameters:
inName - The name of the ModelMBeanOperationInfo to get. If no ModelMBeanOperationInfo exists for this name null is returned.
Returns:
the operation info for the named operation, or null if there is none.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for a null operation name.

getConstructor

public ModelMBeanConstructorInfo getConstructor(String inName)
                                         throws MBeanException,
                                                RuntimeOperationsException
Returns the ModelMBeanConstructorInfo requested by name. If no ModelMBeanConstructorInfo exists for this name null is returned.

Parameters:
inName - the name of the constructor.
Returns:
the constructor info for the named constructor, or null if there is none.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for a null constructor name.

getNotification

public ModelMBeanNotificationInfo getNotification(String inName)
                                           throws MBeanException,
                                                  RuntimeOperationsException
Description copied from interface: ModelMBeanInfo
Returns a ModelMBeanNotificationInfo requested by name.

Specified by:
getNotification in interface ModelMBeanInfo
Parameters:
inName - The name of the ModelMBeanNotificationInfo to get. If no ModelMBeanNotificationInfo exists for this name null is returned.
Returns:
the info for the named notification, or null if there is none.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException for a null notification name.

getMBeanDescriptor

public Descriptor getMBeanDescriptor()
                              throws MBeanException,
                                     RuntimeOperationsException
Description copied from interface: ModelMBeanInfo
Returns the ModelMBean's descriptor which contains MBean wide policies. This descriptor contains metadata about the MBean and default policies for persistence and caching.

 The fields in the descriptor are defined, but not limited to, the following:
 name           : MBean name
 descriptorType : must be "mbean"
 displayName    : name of attribute to be used in displays
 persistPolicy  : OnUpdate|OnTimer|NoMoreOftenThan|Always|Never
 persistLocation : The fully qualified directory name where the MBean should be persisted (if appropriate)
 persistFile    : File name into which the MBean should be persisted
 persistPeriod  : seconds - frequency of persist cycle for OnTime and NoMoreOftenThan PersistPolicy
 currencyTimeLimit : how long value is valid, <0 never,="0" always,="always,">0 seconds
 log            : where t: log all notifications f: log no notifications
 logfile        : fully qualified filename to log events to
 visibility     : 1-4 where 1: always visible 4: rarely visible
 export         : name to be used to export/expose this MBean so that it is findable by
                  other JMX Agents.
 presentationString : xml formatted string to allow presentation of data to be associated with the MBean.

The default descriptor is: name=mbeanName,descriptorType=mbean, displayName=this.getClassName(), persistPolicy=never,log=F,export=F,visiblity=1 If the descriptor does not contain all these fields, they will be added with these default values.

Specified by:
getMBeanDescriptor in interface ModelMBeanInfo
Returns:
the MBean descriptor.
Throws:
RuntimeOperationsException - a RuntimeException occurred while getting the descriptor.
MBeanException - Wraps a distributed communication Exception.
See Also:
ModelMBeanInfo.setMBeanDescriptor(javax.management.Descriptor)

setMBeanDescriptor

public void setMBeanDescriptor(Descriptor inMBeanDescriptor)
                        throws MBeanException,
                               RuntimeOperationsException
Description copied from interface: ModelMBeanInfo
Sets the ModelMBean's descriptor. This descriptor contains default, MBean wide metadata about the MBean and default policies for persistence and caching. This operation does a complete replacement of the descriptor, no merging is done. If the descriptor to set to is null then the default descriptor will be created. The default descriptor is: name=mbeanName,descriptorType=mbean, displayName=this.getClassName(), persistPolicy=never,log=F,export=F,visiblity=1 If the descriptor does not contain all these fields, they will be added with these default values. See getMBeanDescriptor method javadoc for description of valid field names.

Specified by:
setMBeanDescriptor in interface ModelMBeanInfo
Parameters:
inMBeanDescriptor - the descriptor to set.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException for invalid descriptor.
MBeanException - Wraps a distributed communication Exception.
See Also:
ModelMBeanInfo.getMBeanDescriptor()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ModelMBeanNotificationBroadcaster

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Interface ModelMBeanNotificationBroadcaster

All Superinterfaces:
NotificationBroadcaster
All Known Subinterfaces:
ModelMBean
All Known Implementing Classes:
RequiredModelMBean
public interface ModelMBeanNotificationBroadcaster
extends NotificationBroadcaster

This interface must be implemented by the ModelMBeans. An implementation of this interface must be shipped with every JMX Agent.

Java resources wishing to be manageable instantiate the ModelMBean using the MBeanServer's createMBean method. The resource then sets the ModelMBeanInfo (with Descriptors) for the ModelMBean instance. The attributes and operations exposed via the ModelMBeanInfo for the ModelMBean are accessible from MBeans, connectors/adaptors like other MBeans. Through the ModelMBeanInfo Descriptors, values and methods in the managed application can be defined and mapped to attributes and operations of the ModelMBean. This mapping can be defined during development in an XML formatted file or dynamically and programmatically at runtime.

Every ModelMBean which is instantiated in the MBeanServer becomes manageable: its attributes and operations become remotely accessible through the connectors/adaptors connected to that MBeanServer. A Java object cannot be registered in the MBeanServer unless it is a JMX compliant MBean. By instantiating a ModelMBean, resources are guaranteed that the MBean is valid.

MBeanException and RuntimeOperationsException must be thrown on every public method. This allows for wrappering exceptions from distributed communications (RMI, EJB, etc.). These exceptions do not have to be thrown by the implementation except in the scenarios described in the specification and javadoc.

Method Summary
void | addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback) Registers an object which implements the NotificationListener interface as a listener.
void | removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName) Removes a listener for attributeChangeNotifications from the RequiredModelMBean.
void | sendAttributeChangeNotification(Attribute oldValue, Attribute newValue) Sends an attributeChangeNotification which contains the old value and new value for the attribute to the registered AttributeChangeNotification listeners on the ModelMBean.
void | sendAttributeChangeNotification(AttributeChangeNotification notification) Sends an attributeChangeNotification which is passed in to the registered attributeChangeNotification listeners on the ModelMBean.
void | sendNotification(Notification ntfyObj) Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.
void | sendNotification(String ntfyText) Sends a Notification which contains the text string that is passed in to the registered Notification listeners on the ModelMBean.
Methods inherited from interface javax.management.NotificationBroadcaster
addNotificationListener, getNotificationInfo, removeNotificationListener

Method Detail

sendNotification

public void sendNotification(Notification ntfyObj)
                      throws MBeanException,
                             RuntimeOperationsException
Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.

Parameters:
ntfyObj - The notification which is to be passed to the 'handleNotification' method of the listener object.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException: The Notification object passed in parameter is null.

sendNotification

public void sendNotification(String ntfyText)
                      throws MBeanException,
                             RuntimeOperationsException
Sends a Notification which contains the text string that is passed in to the registered Notification listeners on the ModelMBean.

Parameters:
ntfyText - The text which is to be passed in the Notification to the 'handleNotification' method of the listener object. the constructed Notification will be: type "jmx.modelmbean.generic" source this ModelMBean instance sequence 1
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException: The Notification text string passed in parameter is null.

sendAttributeChangeNotification

public void sendAttributeChangeNotification(AttributeChangeNotification notification)
                                     throws MBeanException,
                                            RuntimeOperationsException
Sends an attributeChangeNotification which is passed in to the registered attributeChangeNotification listeners on the ModelMBean.

Parameters:
notification - The notification which is to be passed to the 'handleNotification' method of the listener object.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException: The AttributeChangeNotification object passed in parameter is null.

sendAttributeChangeNotification

public void sendAttributeChangeNotification(Attribute oldValue,
                                            Attribute newValue)
                                     throws MBeanException,
                                            RuntimeOperationsException
Sends an attributeChangeNotification which contains the old value and new value for the attribute to the registered AttributeChangeNotification listeners on the ModelMBean.

Parameters:
oldValue - The origional value for the Attribute
newValue - The current value for the Attribute

 The constructed attributeChangeNotification will be:
   type        "jmx.attribute.change"
   source      this ModelMBean instance
   sequence    1
   attributeName oldValue.getName()
   attributeType oldValue's class
   attributeOldValue oldValue.getValue()
   attributeNewValue newValue.getValue()
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException: An Attribute object passed in parameter is null or the names of the two Attribute objects in parameter are not the same.

addAttributeChangeNotificationListener

public void addAttributeChangeNotificationListener(NotificationListener listener,
                                                   String attributeName,
                                                   Object handback)
                                            throws MBeanException,
                                                   RuntimeOperationsException,
                                                   IllegalArgumentException
Registers an object which implements the NotificationListener interface as a listener. This object's 'handleNotification()' method will be invoked when any attributeChangeNotification is issued through or by the ModelMBean. This does not include other Notifications. They must be registered for independently. An AttributeChangeNotification will be generated for this attributeName.

Parameters:
listener - The listener object which will handles notifications emitted by the registered MBean.
attributeName - The name of the ModelMBean attribute for which to receive change notifications. If null, then all attribute changes will cause an attributeChangeNotification to be issued.
handback - The context to be sent to the listener with the notification when a notification is emitted.
Throws:
IllegalArgumentException - The listener cannot be null.
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException The attribute name passed in parameter does not exist.
See Also:
removeAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String)

removeAttributeChangeNotificationListener

public void removeAttributeChangeNotificationListener(NotificationListener listener,
                                                      String attributeName)
                                               throws MBeanException,
                                                      RuntimeOperationsException,
                                                      ListenerNotFoundException
Removes a listener for attributeChangeNotifications from the RequiredModelMBean.

Parameters:
listener - The listener name which was handling notifications emitted by the registered MBean. This method will remove all information related to this listener.
attributeName - The attribute for which the listener no longer wants to receive attributeChangeNotifications. If null the listener will be removed for all attributeChangeNotifications.
Throws:
ListenerNotFoundException - The listener is not registered in the MBean or is null.
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException If the inAttributeName parameter does not correspond to an attribute name.
See Also:
addAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String, java.lang.Object)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ModelMBeanNotificationInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Class ModelMBeanNotificationInfo

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanNotificationInfo
            extended by javax.management.modelmbean.ModelMBeanNotificationInfo
All Implemented Interfaces:
Cloneable, DescriptorAccess, Serializable
public class ModelMBeanNotificationInfo
extends MBeanNotificationInfo
implements DescriptorAccess, Cloneable

The ModelMBeanNotificationInfo object describes a notification emitted by a ModelMBean. It is a subclass of MBeanNotificationInfo with the addition of an associated Descriptor and an implementation of the Descriptor interface.

The fields in the descriptor are defined, but not limited to, the following:

 name           : notification name
 descriptorType : must be "notification"
 severity       : 1-5 where 1: fatal 2: severe 3: error 4: warn 5: info
 messageID      : unique key for message text (to allow translation,
                  analysis)
 messageText    : text of notification
 log            : T - log message F - do not log message
 logfile        : string fully qualified file name appropriate for
                  operating system
 visibility     : 1-4 where 1: always visible 4: rarely visible
 presentationString : xml formatted string to allow presentation of data
The default descriptor contains the name, descriptorType, displayName and severity(=5) fields.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
ModelMBeanNotificationInfo(ModelMBeanNotificationInfo inInfo)
Constructs a new ModelMBeanNotificationInfo object from this ModelMBeanNotfication Object.
ModelMBeanNotificationInfo(String[] notifTypes, String name, String description)
Constructs a ModelMBeanNotificationInfo object with a default descriptor.
ModelMBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
Constructs a ModelMBeanNotificationInfo object.
Method Summary
Object | clone() Creates and returns a new ModelMBeanNotificationInfo which is a duplicate of this ModelMBeanNotificationInfo.
Descriptor | getDescriptor() Returns a copy of the associated Descriptor for the ModelMBeanNotificationInfo.
void | setDescriptor(Descriptor inDescriptor) Sets associated Descriptor (full replace) for the ModelMBeanNotificationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor.
String | toString() Returns a human readable string containing ModelMBeanNotificationInfo.
Methods inherited from class javax.management.MBeanNotificationInfo
equals, getNotifTypes, hashCode
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ModelMBeanNotificationInfo

public ModelMBeanNotificationInfo(String[] notifTypes,
                                  String name,
                                  String description)
Constructs a ModelMBeanNotificationInfo object with a default descriptor.

Parameters:
notifTypes - The array of strings (in dot notation) containing the notification types that may be emitted.
name - The name of the Notification class.
description - A human readable description of the Notification. Optional.

ModelMBeanNotificationInfo

public ModelMBeanNotificationInfo(String[] notifTypes,
                                  String name,
                                  String description,
                                  Descriptor descriptor)
Constructs a ModelMBeanNotificationInfo object.

Parameters:
notifTypes - The array of strings (in dot notation) containing the notification types that may be emitted.
name - The name of the Notification class.
description - A human readable description of the Notification. Optional.
descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the MBeanNotificationInfo. If it is null a default descriptor will be created. If the descriptor does not contain the fields "displayName" or "severity" these fields are added in the descriptor with their default values.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to parameter name, or descriptor field "DescriptorType" is not equal to "notification".

ModelMBeanNotificationInfo

public ModelMBeanNotificationInfo(ModelMBeanNotificationInfo inInfo)
Constructs a new ModelMBeanNotificationInfo object from this ModelMBeanNotfication Object.

Parameters:
inInfo - the ModelMBeanNotificationInfo to be duplicated
Method Detail

clone

public Object clone()
Creates and returns a new ModelMBeanNotificationInfo which is a duplicate of this ModelMBeanNotificationInfo.

Overrides:
clone in class MBeanNotificationInfo

getDescriptor

public Descriptor getDescriptor()
Returns a copy of the associated Descriptor for the ModelMBeanNotificationInfo.

Specified by:
getDescriptor in interface DescriptorAccess
Returns:
Descriptor associated with the ModelMBeanNotificationInfo object.
See Also:
setDescriptor(javax.management.Descriptor)

setDescriptor

public void setDescriptor(Descriptor inDescriptor)
Sets associated Descriptor (full replace) for the ModelMBeanNotificationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor. The Descriptor is validated before it is assigned. If the new Descriptor is invalid, then a RuntimeOperationsException wrapping an IllegalArgumentException is thrown.

Specified by:
setDescriptor in interface DescriptorAccess
Parameters:
inDescriptor - replaces the Descriptor associated with the ModelMBeanNotification interface
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException for invalid Descriptor.
See Also:
getDescriptor()

toString

public String toString()
Returns a human readable string containing ModelMBeanNotificationInfo.

Returns:
a string describing this object.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ModelMBeanOperationInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Class ModelMBeanOperationInfo

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanOperationInfo
            extended by javax.management.modelmbean.ModelMBeanOperationInfo
All Implemented Interfaces:
Cloneable, DescriptorAccess, Serializable
public class ModelMBeanOperationInfo
extends MBeanOperationInfo
implements DescriptorAccess

The ModelMBeanOperationInfo object describes a management operation of the ModelMBean. It is a subclass of MBeanOperationInfo with the addition of an associated Descriptor and an implementation of the DescriptorAccess interface.

 The fields in the descriptor are defined, but not limited to, the following:
 name           : operation name
 descriptorType : must be "operation"
 class          : class where method is defined (fully qualified)
 role           : must be "operation", "getter", or "setter
 targetObject   : object on which to execute this method
 targetType     : type of object reference for targetObject. Can be: ObjectReference | Handle | EJBHandle | IOR | RMIReference.
 value          : cached value for operation
 currencyTimeLimit : how long cached value is valid
 lastUpdatedTimeStamp : when cached value was set
 visibility            : 1-4 where 1: always visible 4: rarely visible
 presentationString :  xml formatted string to describe how to present operation
The default descriptor will have name, descriptorType, displayName and role fields set.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanOperationInfo
ACTION, ACTION_INFO, INFO, UNKNOWN
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
ModelMBeanOperationInfo(ModelMBeanOperationInfo inInfo)
Constructs a new ModelMBeanOperationInfo object from this ModelMBeanOperation Object.
ModelMBeanOperationInfo(String description, Method operationMethod)
Constructs a ModelMBeanOperationInfo object with a default descriptor.
ModelMBeanOperationInfo(String description, Method operationMethod, Descriptor descriptor)
Constructs a ModelMBeanOperationInfo object.
ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
Constructs a ModelMBeanOperationInfo object with a default descriptor.
ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
Constructs a ModelMBeanOperationInfo object.
Method Summary
Object | clone() Creates and returns a new ModelMBeanOperationInfo which is a duplicate of this ModelMBeanOperationInfo.
Descriptor | getDescriptor() Returns a copy of the associated Descriptor of the ModelMBeanOperationInfo.
void | setDescriptor(Descriptor inDescriptor) Sets associated Descriptor (full replace) for the ModelMBeanOperationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor.
String | toString() Returns a string containing the entire contents of the ModelMBeanOperationInfo in human readable form.
Methods inherited from class javax.management.MBeanOperationInfo
equals, getImpact, getReturnType, getSignature, hashCode
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ModelMBeanOperationInfo

public ModelMBeanOperationInfo(String description,
                               Method operationMethod)
Constructs a ModelMBeanOperationInfo object with a default descriptor.

Parameters:
operationMethod - The java.lang.reflect.Method object describing the MBean operation.
description - A human readable description of the operation.

ModelMBeanOperationInfo

public ModelMBeanOperationInfo(String description,
                               Method operationMethod,
                               Descriptor descriptor)
Constructs a ModelMBeanOperationInfo object.

Parameters:
operationMethod - The java.lang.reflect.Method object describing the MBean operation.
description - A human readable description of the operation.
descriptor - An instance of Descriptor containing the appropriate metadata for this instance of the ModelMBeanOperationInfo. If it is null a default descriptor will be created. If the descriptor does not contain the fields "displayName" or "role" these fields are added in the descriptor with their default values.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to operation name, or descriptor field "DescriptorType" is not equal to "operation", or descriptor field "role" is not equal to "operation".

ModelMBeanOperationInfo

public ModelMBeanOperationInfo(String name,
                               String description,
                               MBeanParameterInfo[] signature,
                               String type,
                               int impact)
Constructs a ModelMBeanOperationInfo object with a default descriptor.

Parameters:
name - The name of the method.
description - A human readable description of the operation.
signature - MBeanParameterInfo objects describing the parameters(arguments) of the method.
type - The type of the method's return value.
impact - The impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN.

ModelMBeanOperationInfo

public ModelMBeanOperationInfo(String name,
                               String description,
                               MBeanParameterInfo[] signature,
                               String type,
                               int impact,
                               Descriptor descriptor)
Constructs a ModelMBeanOperationInfo object.

Parameters:
name - The name of the method.
description - A human readable description of the operation.
signature - MBeanParameterInfo objects describing the parameters(arguments) of the method.
type - The type of the method's return value.
impact - The impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN.
descriptor - An instance of Descriptor containing the appropriate metadata. for this instance of the MBeanOperationInfo.If it is null then a default descriptor will be created. If the descriptor does not contain the fields "displayName" or "role" these fields are added in the descriptor with their default values.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException. The descriptor is invalid, or descriptor field "name" is not equal to operation name, or descriptor field "DescriptorType" is not equal to "operation", or descriptor field "role" is not equal to "operation".

ModelMBeanOperationInfo

public ModelMBeanOperationInfo(ModelMBeanOperationInfo inInfo)
Constructs a new ModelMBeanOperationInfo object from this ModelMBeanOperation Object.

Parameters:
inInfo - the ModelMBeanOperationInfo to be duplicated
Method Detail

clone

public Object clone()
Creates and returns a new ModelMBeanOperationInfo which is a duplicate of this ModelMBeanOperationInfo.

Overrides:
clone in class MBeanOperationInfo

getDescriptor

public Descriptor getDescriptor()
Returns a copy of the associated Descriptor of the ModelMBeanOperationInfo.

Specified by:
getDescriptor in interface DescriptorAccess
Returns:
Descriptor associated with the ModelMBeanOperationInfo object.
See Also:
setDescriptor(javax.management.Descriptor)

setDescriptor

public void setDescriptor(Descriptor inDescriptor)
Sets associated Descriptor (full replace) for the ModelMBeanOperationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor. The Descriptor is validated before it is assigned. If the new Descriptor is invalid, then a RuntimeOperationsException wrapping an IllegalArgumentException is thrown.

Specified by:
setDescriptor in interface DescriptorAccess
Parameters:
inDescriptor - replaces the Descriptor associated with the ModelMBeanOperation.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException for invalid Descriptor.
See Also:
getDescriptor()

toString

public String toString()
Returns a string containing the entire contents of the ModelMBeanOperationInfo in human readable form.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RequiredModelMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Class RequiredModelMBean

java.lang.Object
    extended by javax.management.modelmbean.RequiredModelMBean
All Implemented Interfaces:
DynamicMBean, MBeanRegistration, ModelMBean, ModelMBeanNotificationBroadcaster, NotificationBroadcaster, NotificationEmitter, PersistentMBean
public class RequiredModelMBean
extends Object
implements ModelMBean, MBeanRegistration, NotificationEmitter

This class is the implementation of a ModelMBean. An appropriate implementation of a ModelMBean must be shipped with every JMX Agent and the class must be named RequiredModelMBean.

Java resources wishing to be manageable instantiate the RequiredModelMBean using the MBeanServer's createMBean method. The resource then sets the MBeanInfo and Descriptors for the RequiredModelMBean instance. The attributes and operations exposed via the ModelMBeanInfo for the ModelMBean are accessible from MBeans, connectors/adaptors like other MBeans. Through the Descriptors, values and methods in the managed application can be defined and mapped to attributes and operations of the ModelMBean. This mapping can be defined in an XML formatted file or dynamically and programmatically at runtime.

Every RequiredModelMBean which is instantiated in the MBeanServer becomes manageable:
its attributes and operations become remotely accessible through the connectors/adaptors connected to that MBeanServer.

A Java object cannot be registered in the MBeanServer unless it is a JMX compliant MBean. By instantiating a RequiredModelMBean, resources are guaranteed that the MBean is valid. MBeanException and RuntimeOperationsException must be thrown on every public method. This allows for wrappering exceptions from distributed communications (RMI, EJB, etc.)

Constructor Summary
RequiredModelMBean()
Constructs an RequiredModelMBean with an empty ModelMBeanInfo.
RequiredModelMBean(ModelMBeanInfo mbi)
Constructs a RequiredModelMBean object using ModelMBeanInfo passed in.
Method Summary
void | addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback) Registers an object which implements the NotificationListener interface as a listener.
void | addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) Registers an object which implements the NotificationListener interface as a listener.
Object | getAttribute(String attrName) Returns the value of a specific attribute defined for this ModelMBean.
AttributeList | getAttributes(String[] attrNames) Returns the values of several attributes in the ModelMBean.
protected ClassLoaderRepository | getClassLoaderRepository() Return the Class Loader Repository used to perform class loading.
MBeanInfo | getMBeanInfo() Returns the attributes, operations, constructors and notifications that this RequiredModelMBean exposes for management.
MBeanNotificationInfo[] | getNotificationInfo() Returns the array of Notifications always generated by the RequiredModelMBean.
Object | invoke(String opName, Object[] opArgs, String[] sig) Invokes a method on or through a RequiredModelMBean and returns the result of the method execution.
void | load() Persistence is not supported by the this Model MBean implementation.
void | postDeregister() Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
void | postRegister(Boolean registrationDone) Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
void | preDeregister() Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
ObjectName | preRegister(MBeanServer server, ObjectName name) Allows the MBean to perform any operations it needs before being registered in the MBean server.
void | removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName) Removes a listener for attributeChangeNotifications from the RequiredModelMBean.
void | removeNotificationListener(NotificationListener listener) Removes a listener for Notifications from the RequiredModelMBean.
void | removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) Removes a listener from this MBean.
void | sendAttributeChangeNotification(Attribute inOldVal, Attribute inNewVal) Sends an attributeChangeNotification which contains the old value and new value for the attribute to the registered AttributeChangeNotification listeners on the ModelMBean.
void | sendAttributeChangeNotification(AttributeChangeNotification ntfyObj) Sends an attributeChangeNotification which is passed in to the registered attributeChangeNotification listeners on the ModelMBean.
void | sendNotification(Notification ntfyObj) Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.
void | sendNotification(String ntfyText) Sends a Notification which contains the text string that is passed in to the registered Notification listeners on the ModelMBean.
void | setAttribute(Attribute attribute) Sets the value of a specific attribute of a named ModelMBean.
AttributeList | setAttributes(AttributeList attributes) Sets the values of an array of attributes of this ModelMBean.
void | setManagedResource(Object mr, String mr_type) Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).
void | setModelMBeanInfo(ModelMBeanInfo mbi) Initializes a ModelMBean object using ModelMBeanInfo passed in.
void | store() Persistence is not supported by the this Model MBean implementation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RequiredModelMBean

public RequiredModelMBean()
                   throws MBeanException,
                          RuntimeOperationsException
Constructs an RequiredModelMBean with an empty ModelMBeanInfo.

The RequiredModelMBean's MBeanInfo and Descriptors can be customized using the setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo) method. After the RequiredModelMBean's MBeanInfo and Descriptors are customized, the RequiredModelMBean can be registered with the MBeanServer.

Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps a RuntimeException during the construction of the object.

RequiredModelMBean

public RequiredModelMBean(ModelMBeanInfo mbi)
                   throws MBeanException,
                          RuntimeOperationsException
Constructs a RequiredModelMBean object using ModelMBeanInfo passed in. As long as the RequiredModelMBean is not registered with the MBeanServer yet, the RequiredModelMBean's MBeanInfo and Descriptors can be customized using the setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo) method. After the RequiredModelMBean's MBeanInfo and Descriptors are customized, the RequiredModelMBean can be registered with the MBeanServer.

Parameters:
mbi - The ModelMBeanInfo object to be used by the RequiredModelMBean. The given ModelMBeanInfo is cloned and modified as specified by setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo)
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an {link java.lang.IllegalArgumentException}: The MBeanInfo passed in parameter is null.
Method Detail

setModelMBeanInfo

public void setModelMBeanInfo(ModelMBeanInfo mbi)
                       throws MBeanException,
                              RuntimeOperationsException
Initializes a ModelMBean object using ModelMBeanInfo passed in. This method makes it possible to set a customized ModelMBeanInfo on the ModelMBean as long as it is not registered with the MBeanServer.
Once the ModelMBean's ModelMBeanInfo (with Descriptors) are customized and set on the ModelMBean, the ModelMBean be registered with the MBeanServer.

If the ModelMBean is currently registered, this method throws a RuntimeOperationsException wrapping an IllegalStateException

If the given inModelMBeanInfo does not contain any ModelMBeanNotificationInfo for the GENERIC or ATTRIBUTE_CHANGE notifications, then the RequiredModelMBean will supply its own default ModelMBeanNotificationInfos for those missing notifications.

Specified by:
setModelMBeanInfo in interface ModelMBean
Parameters:
mbi - The ModelMBeanInfo object to be used by the ModelMBean.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException -
  • Wraps an IllegalArgumentException if the MBeanInfo passed in parameter is null.
  • Wraps an IllegalStateException if the ModelMBean is currently registered in the MBeanServer.

setManagedResource

public void setManagedResource(Object mr,
                               String mr_type)
                        throws MBeanException,
                               RuntimeOperationsException,
                               InstanceNotFoundException,
                               InvalidTargetObjectTypeException
Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).

Specified by:
setManagedResource in interface ModelMBean
Parameters:
mr - Object that is the managed resource
mr_type - The type of reference for the managed resource.
Can be: "ObjectReference", "Handle", "IOR", "EJBHandle", or "RMIReference".
In this implementation only "ObjectReference" is supported.
Throws:
MBeanException - The initializer of the object has thrown an exception.
InstanceNotFoundException - The managed resource object could not be found
InvalidTargetObjectTypeException - The managed resource type should be "ObjectReference".
RuntimeOperationsException - Wraps a RuntimeException when setting the resource.

load

public void load()
          throws MBeanException,
                 RuntimeOperationsException,
                 InstanceNotFoundException
Persistence is not supported by the this Model MBean implementation. An MBeanException wrapping a ServiceNotFoundException is thrown.

Specified by:
load in interface PersistentMBean
Throws:
MBeanException - Wraps another exception or persistence is not supported
InstanceNotFoundException - Could not find or load this MBean from persistent storage
RuntimeOperationsException - Wraps exceptions from the persistence mechanism

store

public void store()
           throws MBeanException,
                  RuntimeOperationsException,
                  InstanceNotFoundException
Persistence is not supported by the this Model MBean implementation. An MBeanException wrapping a ServiceNotFoundException is thrown.

Specified by:
store in interface PersistentMBean
Throws:
InstanceNotFoundException - Could not find/access the persistant store
MBeanException - Wraps another exception or persistence is not supported
RuntimeOperationsException - Wraps exceptions from the persistence mechanism

getMBeanInfo

public MBeanInfo getMBeanInfo()
Returns the attributes, operations, constructors and notifications that this RequiredModelMBean exposes for management.

Specified by:
getMBeanInfo in interface DynamicMBean
Returns:
An instance of ModelMBeanInfo allowing retrieval all attributes, operations, and Notifications of this MBean.

invoke

public Object invoke(String opName,
                     Object[] opArgs,
                     String[] sig)
              throws MBeanException,
                     ReflectionException
Invokes a method on or through a RequiredModelMBean and returns the result of the method execution.

If the given method to be invoked, together with the provided signature, matches one of RequiredModelMbean accessible methods, this one will be call. Otherwise the call to the given method will be tried on the managed ressource.

The last value returned by an operation may be cached in the operation's descriptor which is in the ModelMBeanOperationInfo's descriptor. The valid value will be in the 'value' field if there is one. If the 'currencyTimeLimit' field in the descriptor is:

  • <0 Then the value is not cached and is never valid. The operation method is invoked. The 'value' and 'lastUpdatedTimeStamp' fields are cleared.
  • =0 Then the value is always cached and always valid. The 'value' field is returned. If there is no 'value' field then the operation method is invoked for the attribute. The 'lastUpdatedTimeStamp' field and `value' fields are set to the operation's return value and the current time stamp.
  • >0 Represents the number of seconds that the 'value' field is valid. The 'value' field is no longer valid when 'lastUpdatedTimeStamp' + 'currencyTimeLimit' > Now.
    • When 'value' is valid, 'value' is returned.
    • When 'value' is no longer valid then the operation method is invoked. The 'lastUpdatedTimeStamp' field and `value' fields are updated.

Specified by:
invoke in interface DynamicMBean
Parameters:
opName - The name of the method to be invoked. The name can be the fully qualified method name including the classname, or just the method name if the classname is defined in the 'class' field of the operation descriptor.
opArgs - An array containing the parameters to be set when the operation is invoked
sig - An array containing the signature of the operation. The class objects will be loaded using the same class loader as the one used for loading the MBean on which the operation was invoked.
Returns:
The object returned by the method, which represents the result of invoking the method on the specified managed resource.
Throws:
MBeanException - Wraps one of the following Exceptions:
  • An Exception thrown by the managed object's invoked method.
  • ServiceNotFoundException: No ModelMBeanOperationInfo or no descriptor defined for the specified operation or the managed resource is null.
  • InvalidTargetObjectTypeException: The 'targetType' field value is not 'objectReference'.
ReflectionException - Wraps an Exception thrown while trying to invoke the method.
RuntimeOperationsException - Wraps an IllegalArgumentException Method name is null.

getAttribute

public Object getAttribute(String attrName)
                    throws AttributeNotFoundException,
                           MBeanException,
                           ReflectionException
Returns the value of a specific attribute defined for this ModelMBean. The last value returned by an attribute may be cached in the attribute's descriptor. The valid value will be in the 'value' field if there is one. If the 'currencyTimeLimit' field in the descriptor is:
  • <0 Then the value is not cached and is never valid. The getter method is invoked for the attribute. The 'value' and 'lastUpdatedTimeStamp' fields are cleared.
  • =0 Then the value is always cached and always valid. The 'value' field is returned. If there is no'value' field then the getter method is invoked for the attribute. The 'lastUpdatedTimeStamp' field and `value' fields are set to the attribute's value and the current time stamp.
  • >0 Represents the number of seconds that the 'value' field is valid. The 'value' field is no longer valid when 'lastUpdatedTimeStamp' + 'currencyTimeLimit' > Now.
    • When 'value' is valid, 'value' is returned.
    • When 'value' is no longer valid then the getter method is invoked for the attribute. The 'lastUpdatedTimeStamp' field and `value' fields are updated.
If the 'getMethod' field contains the name of a valid operation descriptor, then the method described by the operation descriptor is executed. The response from the method is returned as the value of the attribute. If the operation fails or the returned value is not of the same type as the attribute, an exception will be thrown. If no 'getMethod' field is defined then the default value of the attribute is returned. In this implementation, in every case where the getMethod needs to be called, because the method is invoked through the standard "invoke" method and thus needs operationInfo, an operation must be specified for that getMethod so that the invocation works correctly.

Specified by:
getAttribute in interface DynamicMBean
Parameters:
attrName - A String specifying the name of the attribute to be retrieved. It must match the name of a ModelMBeanAttributeInfo.
Returns:
The value of the retrieved attribute from the descriptor 'value' field or from the invocation of the operation in the 'getMethod' field of the descriptor.
Throws:
AttributeNotFoundException - The specified attribute is not accessible in the MBean. The following cases may result in an AttributeNotFoundException:
  • No ModelMBeanInfo was found for the Model MBean.
  • No ModelMBeanAttributeInfo was found for the specified attribute name.
  • The ModelMBeanAttributeInfo isReadable method returns 'false'.
MBeanException - Wraps one of the following Exceptions:
  • InvalidAttributeValueException: A wrong value type was received from the attribute's getter method or no 'getMethod' field defined in the descriptor for the attribute and no default value exists.
  • ServiceNotFoundException: No ModelMBeanOperationInfo defined for the attribute's getter method or no descriptor associated with the ModelMBeanOperationInfo or the managed resource is null.
  • InvalidTargetObjectTypeException The 'targetType' field value is not 'objectReference'.
  • An Exception thrown by the managed object's getter.
ReflectionException - Wraps an Exception thrown while trying to invoke the getter.
RuntimeOperationsException - Wraps an IllegalArgumentException: The attribute name in parameter is null.
See Also:
setAttribute(javax.management.Attribute)

getAttributes

public AttributeList getAttributes(String[] attrNames)
Returns the values of several attributes in the ModelMBean. Executes a getAttribute for each attribute name in the attrNames array passed in.

Specified by:
getAttributes in interface DynamicMBean
Parameters:
attrNames - A String array of names of the attributes to be retrieved.
Returns:
The array of the retrieved attributes.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException: The object name in parameter is null or attributes in parameter is null.
See Also:
setAttributes(javax.management.AttributeList)

setAttribute

public void setAttribute(Attribute attribute)
                  throws AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
Sets the value of a specific attribute of a named ModelMBean. If the 'setMethod' field of the attribute's descriptor contains the name of a valid operation descriptor, then the method described by the operation descriptor is executed. In this implementation, the operation descriptor must be specified correctly and assigned to the modelMBeanInfo so that the 'setMethod' works correctly. The response from the method is set as the value of the attribute in the descriptor.

If currencyTimeLimit is > 0, then the new value for the attribute is cached in the attribute descriptor's 'value' field and the 'lastUpdatedTimeStamp' field is set to the current time stamp.

If the persist field of the attribute's descriptor is not null then Persistance policy from the attribute descriptor is used to guide storing the attribute in a persistent store.
Store the MBean if 'persistPolicy' field is:

  • != "never"
  • = "always"
  • = "onUpdate"
  • = "onTimer" and now > 'lastPersistTime' + 'persistPeriod'
  • = "NoMoreOftenThan" and now > 'lastPersistTime' + 'persistPeriod'
Do not store the MBean if 'persistPolicy' field is:
  • = "never"
  • = "onTimer" && now < 'lastPersistTime' + 'persistPeriod'
  • = "NoMoreOftenThan" and now < 'lastPersistTime' + 'persistPeriod'

The ModelMBeanInfo of the Model MBean is stored in a file.

Specified by:
setAttribute in interface DynamicMBean
Parameters:
attribute - The Attribute instance containing the name of the attribute to be set and the value it is to be set to.
Throws:
AttributeNotFoundException - The specified attribute is not accessible in the MBean.
The following cases may result in an AttributeNotFoundException:
  • No ModelMBeanAttributeInfo is found for the specified attribute.
  • The ModelMBeanAttributeInfo's isWritable method returns 'false'.
InvalidAttributeValueException - No descriptor is defined for the specified attribute.
MBeanException - Wraps one of the following Exceptions:
  • An Exception thrown by the managed object's setter.
  • A ServiceNotFoundException if no `setMethod` field is defined in the descriptor for the attribute or the managed resource is null.
  • InvalidTargetObjectTypeException The 'targetType' field value is not 'objectReference'.
  • An Exception thrown by the managed object's getter.
ReflectionException - Wraps an Exception thrown while trying to invoke the setter.
RuntimeOperationsException - Wraps an IllegalArgumentException: The attribute in parameter is null.
See Also:
getAttribute(java.lang.String)

setAttributes

public AttributeList setAttributes(AttributeList attributes)
Sets the values of an array of attributes of this ModelMBean. Executes the setAttribute() method for each attribute in the list.

Specified by:
setAttributes in interface DynamicMBean
Parameters:
attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to.
Returns:
The array of attributes that were set, with their new values in Attribute instances.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException: The object name in parameter is null or attributes in parameter is null.
See Also:
getAttributes(java.lang.String[])

addNotificationListener

public void addNotificationListener(NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
                             throws IllegalArgumentException
Registers an object which implements the NotificationListener interface as a listener. This object's 'handleNotification()' method will be invoked when any notification is issued through or by the ModelMBean. This does not include attributeChangeNotifications. They must be registered for independently.

Specified by:
addNotificationListener in interface NotificationBroadcaster
Parameters:
listener - The listener object which will handles notifications emitted by the registered MBean.
filter - The filter object. If null, no filtering will be performed before handling notifications.
handback - The context to be sent to the listener with the notification when a notification is emitted.
Throws:
IllegalArgumentException - The listener cannot be null.
See Also:
removeNotificationListener(javax.management.NotificationListener)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener)
                                throws ListenerNotFoundException
Removes a listener for Notifications from the RequiredModelMBean.

Specified by:
removeNotificationListener in interface NotificationBroadcaster
Parameters:
listener - The listener name which was handling notifications emitted by the registered MBean. This method will remove all information related to this listener.
Throws:
ListenerNotFoundException - The listener is not registered in the MBean or is null.
See Also:
addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws ListenerNotFoundException
Description copied from interface: NotificationEmitter

Removes a listener from this MBean. The MBean must have a listener that exactly matches the given listener, filter, and handback parameters. If there is more than one such listener, only one is removed.

The filter and handback parameters may be null if and only if they are null in a listener to be removed.

Specified by:
removeNotificationListener in interface NotificationEmitter
Parameters:
listener - A listener that was previously added to this MBean.
filter - The filter that was specified when the listener was added.
handback - The handback that was specified when the listener was added.
Throws:
ListenerNotFoundException - The listener is not registered with the MBean, or it is not registered with the given filter and handback.

sendNotification

public void sendNotification(Notification ntfyObj)
                      throws MBeanException,
                             RuntimeOperationsException
Description copied from interface: ModelMBeanNotificationBroadcaster
Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.

Specified by:
sendNotification in interface ModelMBeanNotificationBroadcaster
Parameters:
ntfyObj - The notification which is to be passed to the 'handleNotification' method of the listener object.
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException: The Notification object passed in parameter is null.

sendNotification

public void sendNotification(String ntfyText)
                      throws MBeanException,
                             RuntimeOperationsException
Description copied from interface: ModelMBeanNotificationBroadcaster
Sends a Notification which contains the text string that is passed in to the registered Notification listeners on the ModelMBean.

Specified by:
sendNotification in interface ModelMBeanNotificationBroadcaster
Parameters:
ntfyText - The text which is to be passed in the Notification to the 'handleNotification' method of the listener object. the constructed Notification will be: type "jmx.modelmbean.generic" source this ModelMBean instance sequence 1
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException: The Notification text string passed in parameter is null.

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
Returns the array of Notifications always generated by the RequiredModelMBean.

RequiredModelMBean may always send also two additional notifications:

  • One with descriptor "name=GENERIC,descriptorType=notification,log=T,severity=5,displayName=jmx.modelmbean.generic"
  • Second is a standard attribute change notification with descriptor "name=ATTRIBUTE_CHANGE,descriptorType=notification,log=T,severity=5,displayName=jmx.attribute.change"
Thus these two notifications are always added to those specified by the application.

Specified by:
getNotificationInfo in interface NotificationBroadcaster
Returns:
MBeanNotificationInfo[]

addAttributeChangeNotificationListener

public void addAttributeChangeNotificationListener(NotificationListener inlistener,
                                                   String inAttributeName,
                                                   Object inhandback)
                                            throws MBeanException,
                                                   RuntimeOperationsException,
                                                   IllegalArgumentException
Description copied from interface: ModelMBeanNotificationBroadcaster
Registers an object which implements the NotificationListener interface as a listener. This object's 'handleNotification()' method will be invoked when any attributeChangeNotification is issued through or by the ModelMBean. This does not include other Notifications. They must be registered for independently. An AttributeChangeNotification will be generated for this attributeName.

Specified by:
addAttributeChangeNotificationListener in interface ModelMBeanNotificationBroadcaster
Parameters:
inlistener - The listener object which will handles notifications emitted by the registered MBean.
inAttributeName - The name of the ModelMBean attribute for which to receive change notifications. If null, then all attribute changes will cause an attributeChangeNotification to be issued.
inhandback - The context to be sent to the listener with the notification when a notification is emitted.
Throws:
IllegalArgumentException - The listener cannot be null.
RuntimeOperationsException - Wraps an IllegalArgumentException The attribute name passed in parameter does not exist.
MBeanException - Wraps a distributed communication Exception.
See Also:
ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String)

removeAttributeChangeNotificationListener

public void removeAttributeChangeNotificationListener(NotificationListener inlistener,
                                                      String inAttributeName)
                                               throws MBeanException,
                                                      RuntimeOperationsException,
                                                      ListenerNotFoundException
Description copied from interface: ModelMBeanNotificationBroadcaster
Removes a listener for attributeChangeNotifications from the RequiredModelMBean.

Specified by:
removeAttributeChangeNotificationListener in interface ModelMBeanNotificationBroadcaster
Parameters:
inlistener - The listener name which was handling notifications emitted by the registered MBean. This method will remove all information related to this listener.
inAttributeName - The attribute for which the listener no longer wants to receive attributeChangeNotifications. If null the listener will be removed for all attributeChangeNotifications.
Throws:
MBeanException - Wraps a distributed communication Exception.
ListenerNotFoundException - The listener is not registered in the MBean or is null.
RuntimeOperationsException - Wraps an IllegalArgumentException If the inAttributeName parameter does not correspond to an attribute name.
See Also:
ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String, java.lang.Object)

sendAttributeChangeNotification

public void sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)
                                     throws MBeanException,
                                            RuntimeOperationsException
Description copied from interface: ModelMBeanNotificationBroadcaster
Sends an attributeChangeNotification which is passed in to the registered attributeChangeNotification listeners on the ModelMBean.

Specified by:
sendAttributeChangeNotification in interface ModelMBeanNotificationBroadcaster
Parameters:
ntfyObj - The notification which is to be passed to the 'handleNotification' method of the listener object.
Throws:
RuntimeOperationsException - Wraps an IllegalArgumentException: The AttributeChangeNotification object passed in parameter is null.
MBeanException - Wraps a distributed communication Exception.

sendAttributeChangeNotification

public void sendAttributeChangeNotification(Attribute inOldVal,
                                            Attribute inNewVal)
                                     throws MBeanException,
                                            RuntimeOperationsException
Description copied from interface: ModelMBeanNotificationBroadcaster
Sends an attributeChangeNotification which contains the old value and new value for the attribute to the registered AttributeChangeNotification listeners on the ModelMBean.

Specified by:
sendAttributeChangeNotification in interface ModelMBeanNotificationBroadcaster
Parameters:
inOldVal - The origional value for the Attribute
inNewVal - The current value for the Attribute

 The constructed attributeChangeNotification will be:
   type        "jmx.attribute.change"
   source      this ModelMBean instance
   sequence    1
   attributeName oldValue.getName()
   attributeType oldValue's class
   attributeOldValue oldValue.getValue()
   attributeNewValue newValue.getValue()
Throws:
MBeanException - Wraps a distributed communication Exception.
RuntimeOperationsException - Wraps an IllegalArgumentException: An Attribute object passed in parameter is null or the names of the two Attribute objects in parameter are not the same.

getClassLoaderRepository

protected ClassLoaderRepository getClassLoaderRepository()
Return the Class Loader Repository used to perform class loading. Subclasses may wish to redefine this method in order to return the appropriate ClassLoaderRepository that should be used in this object.

Returns:
the Class Loader Repository.
Since:
JMX 1.1

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
Allows the MBean to perform any operations it needs before being registered in the MBean server. If the name of the MBean is not specified, the MBean can provide a name for its registration. If any exception is raised, the MBean will not be registered in the MBean server.

In order to ensure proper run-time semantics of RequireModelMBean, Any subclass of RequiredModelMBean overloading or overriding this method should call super.preRegister(server, name) in its own preRegister implementation.

Specified by:
preRegister in interface MBeanRegistration
Parameters:
server - The MBean server in which the MBean will be registered.
name - The object name of the MBean. This name is null if the name parameter to one of the createMBean or registerMBean methods in the MBeanServer interface is null. In that case, this method must return a non-null ObjectName for the new MBean.
Returns:
The name under which the MBean is to be registered. This value must not be null. If the name parameter is not null, it will usually but not necessarily be the returned value.
Throws:
Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException or a RuntimeMBeanException.

postRegister

public void postRegister(Boolean registrationDone)
Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

In order to ensure proper run-time semantics of RequireModelMBean, Any subclass of RequiredModelMBean overloading or overriding this method should call super.postRegister(registrationDone) in its own postRegister implementation.

Specified by:
postRegister in interface MBeanRegistration
Parameters:
registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

preDeregister

public void preDeregister()
                   throws Exception
Allows the MBean to perform any operations it needs before being unregistered by the MBean server.

In order to ensure proper run-time semantics of RequireModelMBean, Any subclass of RequiredModelMBean overloading or overriding this method should call super.preDeregister() in its own preDeregister implementation.

Specified by:
preDeregister in interface MBeanRegistration
Throws:
Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException or a RuntimeMBeanException.

postDeregister

public void postDeregister()
Allows the MBean to perform any operations needed after having been unregistered in the MBean server.

In order to ensure proper run-time semantics of RequireModelMBean, Any subclass of RequiredModelMBean overloading or overriding this method should call super.postDeregister() in its own postDeregister implementation.

Specified by:
postDeregister in interface MBeanRegistration
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XMLParseException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.modelmbean
Class XMLParseException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.modelmbean.XMLParseException
All Implemented Interfaces:
Serializable
public class XMLParseException
extends Exception

This exception is thrown when an XML formatted string is being parsed into ModelMBean objects or when XML formatted strings are being created from ModelMBean objects. It is also used to wrapper exceptions from XML parsers that may be used.

See Also:
Serialized Form

Constructor Summary
XMLParseException()
Default constructor .
XMLParseException(Exception e, String s)
Constructor taking a string and an exception.
XMLParseException(String s)
Constructor taking a string.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XMLParseException

public XMLParseException()
Default constructor .

XMLParseException

public XMLParseException(String s)
Constructor taking a string.

Parameters:
s - the detail message.

XMLParseException

public XMLParseException(Exception e,
                         String s)
Constructor taking a string and an exception.

Parameters:
e - the nested exception.
s - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


monitor

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management.monitor

Provides the definition of the monitor classes.

See:
Description

Interface Summary
CounterMonitorMBean | Exposes the remote management interface of the counter monitor MBean.
GaugeMonitorMBean | Exposes the remote management interface of the gauge monitor MBean.
MonitorMBean | Exposes the remote management interface of monitor MBeans.
StringMonitorMBean | Exposes the remote management interface of the string monitor MBean.

Class Summary
CounterMonitor | Defines a monitor MBean designed to observe the values of a counter attribute.
GaugeMonitor | Defines a monitor MBean designed to observe the values of a gauge attribute.
Monitor | Defines the common part to all monitor MBeans.
MonitorNotification | Provides definitions of the notifications sent by monitor MBeans.
StringMonitor | Defines a monitor MBean designed to observe the values of a string attribute.

Exception Summary
MonitorSettingException Exception thrown by the monitor when a monitor setting becomes invalid while the monitor is running.

Package javax.management.monitor Description

Provides the definition of the monitor classes.

Since:
JMX 1.0
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.management.monitor Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management.monitor

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.management.Notification
        • class javax.management.monitor.MonitorNotification
    • class javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • class javax.management.monitor.Monitor (implements javax.management.MBeanRegistration, javax.management.monitor.MonitorMBean)
        • class javax.management.monitor.CounterMonitor (implements javax.management.monitor.CounterMonitorMBean)
        • class javax.management.monitor.GaugeMonitor (implements javax.management.monitor.GaugeMonitorMBean)
        • class javax.management.monitor.StringMonitor (implements javax.management.monitor.StringMonitorMBean)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class javax.management.JMRuntimeException
            • class javax.management.monitor.MonitorSettingException

Interface Hierarchy

  • interface javax.management.monitor.MonitorMBean
    • interface javax.management.monitor.CounterMonitorMBean
    • interface javax.management.monitor.GaugeMonitorMBean
    • interface javax.management.monitor.StringMonitorMBean
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CounterMonitor

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.monitor
Class CounterMonitor

java.lang.Object
    extended by javax.management.NotificationBroadcasterSupport
        extended by javax.management.monitor.Monitor
            extended by javax.management.monitor.CounterMonitor
All Implemented Interfaces:
CounterMonitorMBean, MBeanRegistration, MonitorMBean, NotificationBroadcaster, NotificationEmitter
public class CounterMonitor
extends Monitor
implements CounterMonitorMBean

Defines a monitor MBean designed to observe the values of a counter attribute.

A counter monitor sends a threshold notification when the value of the counter reaches or exceeds a threshold known as the comparison level. The notify flag must be set to true.
In addition, an offset mechanism enables particular counting intervals to be detected.

If the offset value is not zero, whenever the threshold is triggered by the counter value reaching a comparison level, that comparison level is incremented by the offset value. This is regarded as taking place instantaneously, that is before the count is incremented. Thus, for each level, the threshold triggers an event notification every time the count increases by an interval equal to the offset value.

If the counter can wrap around its maximum value, the modulus needs to be specified. The modulus is the value at which the counter is reset to zero.

If the counter difference mode is used, the value of the derived gauge is calculated as the difference between the observed counter values for two successive observations. If this difference is negative, the value of the derived gauge is incremented by the value of the modulus.
The derived gauge value (V[t]) is calculated using the following method: w *

  • if (counter[t] - counter[t-GP]) is positive then V[t] = counter[t] - counter[t-GP]
  • if (counter[t] - counter[t-GP]) is negative then V[t] = counter[t] - counter[t-GP] + MODULUS
This implementation of the counter monitor requires the observed attribute to be of the type integer (Byte, Integer, Short, Long).

Version:
1.59 10/08/02
Author:
Sun Microsystems, Inc

Field Summary
Fields inherited from class javax.management.monitor.Monitor
alreadyNotified, alreadyNotifieds, capacityIncrement, dbgTag, elementCount, OBSERVED_ATTRIBUTE_ERROR_NOTIFIED, OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED, OBSERVED_OBJECT_ERROR_NOTIFIED, RESET_FLAGS_ALREADY_NOTIFIED, RUNTIME_ERROR_NOTIFIED, server
Constructor Summary
CounterMonitor()
Default constructor.
Method Summary
Number | getDerivedGauge() Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
Number | getDerivedGauge(ObjectName object) Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
long | getDerivedGaugeTimeStamp() Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
long | getDerivedGaugeTimeStamp(ObjectName object) Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
boolean | getDifferenceMode() Gets the difference mode flag value common to all observed MBeans.
Number | getInitThreshold() Gets the initial threshold value common to all observed objects.
Number | getModulus() Gets the modulus value common to all observed MBeans.
MBeanNotificationInfo[] | getNotificationInfo() Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the counter monitor.
boolean | getNotify() Gets the notification's on/off switch value common to all observed MBeans.
Number | getOffset() Gets the offset value common to all observed MBeans.
Number | getThreshold() Deprecated. As of JMX 1.2, replaced by getThreshold(ObjectName)
Number | getThreshold(ObjectName object) Gets the current threshold value of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
void | preDeregister() Allows the counter monitor MBean to perform any operations it needs before being unregistered by the MBean server.
void | setDifferenceMode(boolean value) Sets the difference mode flag value common to all observed MBeans.
void | setGranularityPeriod(long period) Sets the granularity period (in milliseconds).
void | setInitThreshold(Number value) Sets the initial threshold value common to all observed objects.
void | setModulus(Number value) Sets the modulus value common to all observed MBeans.
void | setNotify(boolean value) Sets the notification's on/off switch value common to all observed MBeans.
void | setOffset(Number value) Sets the offset value common to all observed MBeans.
void | setThreshold(Number value) Deprecated. As of JMX 1.2, replaced by setInitThreshold(java.lang.Number)
void | start() Starts the counter monitor.
void | stop() Stops the counter monitor.
Methods inherited from class javax.management.monitor.Monitor
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, postDeregister, postRegister, preRegister, removeObservedObject, setObservedAttribute, setObservedObject
Methods inherited from class javax.management.NotificationBroadcasterSupport
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.management.monitor.MonitorMBean
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setObservedAttribute, setObservedObject

Constructor Detail

CounterMonitor

public CounterMonitor()
Default constructor.

Method Detail

preDeregister

public void preDeregister()
                   throws Exception
Allows the counter monitor MBean to perform any operations it needs before being unregistered by the MBean server.

Resets the threshold values.

Specified by:
preDeregister in interface MBeanRegistration
Overrides:
preDeregister in class Monitor
Throws:
Exception

start

public void start()
Starts the counter monitor.

Specified by:
start in interface MonitorMBean
Specified by:
start in class Monitor

stop

public void stop()
Stops the counter monitor. This method is not synchronized, because if it were there could be a deadlock with a thread that attempted to get the lock on the monitor before being interrupted or noticing that it had been interrupted.

Specified by:
stop in interface MonitorMBean
Specified by:
stop in class Monitor

setGranularityPeriod

public void setGranularityPeriod(long period)
                          throws IllegalArgumentException
Sets the granularity period (in milliseconds).
The default value of the granularity period is 10 seconds.

Specified by:
setGranularityPeriod in interface MonitorMBean
Overrides:
setGranularityPeriod in class Monitor
Parameters:
period - The granularity period value.
Throws:
IllegalArgumentException - The granularity period is less than or equal to zero.
See Also:
Monitor.setGranularityPeriod(long)

getDerivedGauge

public Number getDerivedGauge(ObjectName object)
Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

Specified by:
getDerivedGauge in interface CounterMonitorMBean
Parameters:
object - the name of the object whose derived gauge is to be returned.
Returns:
The derived gauge of the specified object.
Since:
JMX 1.2

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp(ObjectName object)
Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

Specified by:
getDerivedGaugeTimeStamp in interface CounterMonitorMBean
Parameters:
object - the name of the object whose derived gauge timestamp is to be returned.
Returns:
The derived gauge timestamp of the specified object.
Since:
JMX 1.2

getThreshold

public Number getThreshold(ObjectName object)
Gets the current threshold value of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

Specified by:
getThreshold in interface CounterMonitorMBean
Parameters:
object - the name of the object whose threshold is to be returned.
Returns:
The threshold value of the specified object.
Since:
JMX 1.2
See Also:
setThreshold(java.lang.Number)

getInitThreshold

public Number getInitThreshold()
Gets the initial threshold value common to all observed objects.

Specified by:
getInitThreshold in interface CounterMonitorMBean
Returns:
The initial threshold.
Since:
JMX 1.2
See Also:
setInitThreshold(java.lang.Number)

setInitThreshold

public void setInitThreshold(Number value)
                      throws IllegalArgumentException
Sets the initial threshold value common to all observed objects.
The current threshold of every object in the set of observed MBeans is updated consequently.

Specified by:
setInitThreshold in interface CounterMonitorMBean
Parameters:
value - The initial threshold value.
Throws:
IllegalArgumentException - The specified threshold is null or the threshold value is less than zero.
Since:
JMX 1.2
See Also:
getInitThreshold()

getDerivedGauge

public Number getDerivedGauge()
Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)

Returns the derived gauge of the first object in the set of observed MBeans.

Specified by:
getDerivedGauge in interface CounterMonitorMBean
Returns:
The derived gauge.

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp()
Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)

Gets the derived gauge timestamp of the first object in the set of observed MBeans.

Specified by:
getDerivedGaugeTimeStamp in interface CounterMonitorMBean
Returns:
The derived gauge timestamp.

getThreshold

public Number getThreshold()
Deprecated. As of JMX 1.2, replaced by getThreshold(ObjectName)

Gets the threshold value of the first object in the set of observed MBeans.

Specified by:
getThreshold in interface CounterMonitorMBean
Returns:
The threshold value.
See Also:
setThreshold(Number)

setThreshold

public void setThreshold(Number value)
                  throws IllegalArgumentException
Deprecated. As of JMX 1.2, replaced by setInitThreshold(java.lang.Number)

Sets the initial threshold value.

Specified by:
setThreshold in interface CounterMonitorMBean
Parameters:
value - The initial threshold value.
Throws:
IllegalArgumentException - The specified threshold is null or the threshold value is less than zero.
See Also:
getThreshold()

getOffset

public Number getOffset()
Gets the offset value common to all observed MBeans.

Specified by:
getOffset in interface CounterMonitorMBean
Returns:
The offset value.
See Also:
setOffset(java.lang.Number)

setOffset

public void setOffset(Number value)
               throws IllegalArgumentException
Sets the offset value common to all observed MBeans.

Specified by:
setOffset in interface CounterMonitorMBean
Parameters:
value - The offset value.
Throws:
IllegalArgumentException - The specified offset is null or the offset value is less than zero.
See Also:
getOffset()

getModulus

public Number getModulus()
Gets the modulus value common to all observed MBeans.

Specified by:
getModulus in interface CounterMonitorMBean
Returns:
The modulus value.
See Also:
setModulus(java.lang.Number)

setModulus

public void setModulus(Number value)
                throws IllegalArgumentException
Sets the modulus value common to all observed MBeans.

Specified by:
setModulus in interface CounterMonitorMBean
Parameters:
value - The modulus value.
Throws:
IllegalArgumentException - The specified modulus is null or the modulus value is less than zero.
See Also:
getModulus()

getNotify

public boolean getNotify()
Gets the notification's on/off switch value common to all observed MBeans.

Specified by:
getNotify in interface CounterMonitorMBean
Returns:
true if the counter monitor notifies when exceeding the threshold, false otherwise.
See Also:
setNotify(boolean)

setNotify

public void setNotify(boolean value)
Sets the notification's on/off switch value common to all observed MBeans.

Specified by:
setNotify in interface CounterMonitorMBean
Parameters:
value - The notification's on/off switch value.
See Also:
getNotify()

getDifferenceMode

public boolean getDifferenceMode()
Gets the difference mode flag value common to all observed MBeans.

Specified by:
getDifferenceMode in interface CounterMonitorMBean
Returns:
true if the difference mode is used, false otherwise.
See Also:
setDifferenceMode(boolean)

setDifferenceMode

public void setDifferenceMode(boolean value)
Sets the difference mode flag value common to all observed MBeans.

Specified by:
setDifferenceMode in interface CounterMonitorMBean
Parameters:
value - The difference mode flag value.
See Also:
getDifferenceMode()

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the counter monitor.

Specified by:
getNotificationInfo in interface NotificationBroadcaster
Overrides:
getNotificationInfo in class NotificationBroadcasterSupport
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CounterMonitorMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.monitor
Interface CounterMonitorMBean

All Superinterfaces:
MonitorMBean
All Known Implementing Classes:
CounterMonitor
public interface CounterMonitorMBean
extends MonitorMBean

Exposes the remote management interface of the counter monitor MBean.

Version:
4.14 09/06/02
Author:
Sun Microsystems, Inc

Method Summary
Number | getDerivedGauge() Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
Number | getDerivedGauge(ObjectName object) Gets the derived gauge for the specified MBean.
long | getDerivedGaugeTimeStamp() Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
long | getDerivedGaugeTimeStamp(ObjectName object) Gets the derived gauge timestamp for the specified MBean.
boolean | getDifferenceMode() Gets the difference mode flag value.
Number | getInitThreshold() Gets the initial threshold value common to all observed objects.
Number | getModulus() Gets the modulus value.
boolean | getNotify() Gets the notification's on/off switch value.
Number | getOffset() Gets the offset value.
Number | getThreshold() Deprecated. As of JMX 1.2, replaced by getThreshold(ObjectName)
Number | getThreshold(ObjectName object) Gets the threshold value for the specified MBean.
void | setDifferenceMode(boolean value) Sets the difference mode flag value.
void | setInitThreshold(Number value) Sets the initial threshold value common to all observed MBeans.
void | setModulus(Number value) Sets the modulus value.
void | setNotify(boolean value) Sets the notification's on/off switch value.
void | setOffset(Number value) Sets the offset value.
void | setThreshold(Number value) Deprecated. As of JMX 1.2, replaced by setInitThreshold(java.lang.Number)
Methods inherited from interface javax.management.monitor.MonitorMBean
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject, start, stop

Method Detail

getDerivedGauge

public Number getDerivedGauge()
Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)

Gets the derived gauge.

Returns:
The derived gauge.

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp()
Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)

Gets the derived gauge timestamp.

Returns:
The derived gauge timestamp.

getThreshold

public Number getThreshold()
Deprecated. As of JMX 1.2, replaced by getThreshold(ObjectName)

Gets the threshold value.

Returns:
The threshold value.
See Also:
setThreshold(Number)

setThreshold

public void setThreshold(Number value)
                  throws IllegalArgumentException
Deprecated. As of JMX 1.2, replaced by setInitThreshold(java.lang.Number)

Sets the threshold value.

Parameters:
value - The threshold value.
Throws:
IllegalArgumentException - The specified threshold is null or the threshold value is less than zero.
See Also:
getThreshold()

getDerivedGauge

public Number getDerivedGauge(ObjectName object)
Gets the derived gauge for the specified MBean.

Parameters:
object - the MBean for which the derived gauge is to be returned
Returns:
The derived gauge for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.
Since:
JMX 1.2

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp(ObjectName object)
Gets the derived gauge timestamp for the specified MBean.

Parameters:
object - the MBean for which the derived gauge timestamp is to be returned
Returns:
The derived gauge timestamp for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.
Since:
JMX 1.2

getThreshold

public Number getThreshold(ObjectName object)
Gets the threshold value for the specified MBean.

Parameters:
object - the MBean for which the threashold value is to be returned
Returns:
The threshold value for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.
Since:
JMX 1.2
See Also:
setThreshold(java.lang.Number)

getInitThreshold

public Number getInitThreshold()
Gets the initial threshold value common to all observed objects.

Returns:
The initial threshold value.
Since:
JMX 1.2
See Also:
setInitThreshold(java.lang.Number)

setInitThreshold

public void setInitThreshold(Number value)
                      throws IllegalArgumentException
Sets the initial threshold value common to all observed MBeans.

Parameters:
value - The initial threshold value.
Throws:
IllegalArgumentException - The specified threshold is null or the threshold value is less than zero.
Since:
JMX 1.2
See Also:
getInitThreshold()

getOffset

public Number getOffset()
Gets the offset value.

Returns:
The offset value.
See Also:
setOffset(Number)

setOffset

public void setOffset(Number value)
               throws IllegalArgumentException
Sets the offset value.

Parameters:
value - The offset value.
Throws:
IllegalArgumentException - The specified offset is null or the offset value is less than zero.
See Also:
getOffset()

getModulus

public Number getModulus()
Gets the modulus value.

Returns:
The modulus value.
See Also:
setModulus(java.lang.Number)

setModulus

public void setModulus(Number value)
                throws IllegalArgumentException
Sets the modulus value.

Parameters:
value - The modulus value.
Throws:
IllegalArgumentException - The specified modulus is null or the modulus value is less than zero.
See Also:
getModulus()

getNotify

public boolean getNotify()
Gets the notification's on/off switch value.

Returns:
true if the counter monitor notifies when exceeding the threshold, false otherwise.
See Also:
setNotify(boolean)

setNotify

public void setNotify(boolean value)
Sets the notification's on/off switch value.

Parameters:
value - The notification's on/off switch value.
See Also:
getNotify()

getDifferenceMode

public boolean getDifferenceMode()
Gets the difference mode flag value.

Returns:
true if the difference mode is used, false otherwise.
See Also:
setDifferenceMode(boolean)

setDifferenceMode

public void setDifferenceMode(boolean value)
Sets the difference mode flag value.

Parameters:
value - The difference mode flag value.
See Also:
getDifferenceMode()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


GaugeMonitor

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.monitor
Class GaugeMonitor

java.lang.Object
    extended by javax.management.NotificationBroadcasterSupport
        extended by javax.management.monitor.Monitor
            extended by javax.management.monitor.GaugeMonitor
All Implemented Interfaces:
GaugeMonitorMBean, MBeanRegistration, MonitorMBean, NotificationBroadcaster, NotificationEmitter
public class GaugeMonitor
extends Monitor
implements GaugeMonitorMBean

Defines a monitor MBean designed to observe the values of a gauge attribute.

A gauge monitor observes an attribute that is continuously variable with time. A gauge monitor sends notifications as follows:

  • if the attribute value is increasing and becomes equal to or greater than the high threshold value, a threshold high notification is sent. The notify high flag must be set to true
    Subsequent crossings of the high threshold value do not cause further notifications unless the attribute value becomes equal to or less than the low threshold value.
  • if the attribute value is decreasing and becomes equal to or less than the low threshold value, a threshold low notification is sent. The notify low flag must be set to true.
    Subsequent crossings of the low threshold value do not cause further notifications unless the attribute value becomes equal to or greater than the high threshold value.
This provides a hysteresis mechanism to avoid repeated triggering of notifications when the attribute value makes small oscillations around the high or low threshold value.

If the gauge difference mode is used, the value of the derived gauge is calculated as the difference between the observed gauge values for two successive observations.
The derived gauge value (V[t]) is calculated using the following method:

  • V[t] = gauge[t] - gauge[t-GP]
This implementation of the gauge monitor requires the observed attribute to be of the type integer or floating-point (Byte, Integer, Short, Long, Float, Double).

Version:
1.57 10/08/02
Author:
Sun Microsystems, Inc

Field Summary
Fields inherited from class javax.management.monitor.Monitor
alreadyNotified, alreadyNotifieds, capacityIncrement, dbgTag, elementCount, OBSERVED_ATTRIBUTE_ERROR_NOTIFIED, OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED, OBSERVED_OBJECT_ERROR_NOTIFIED, RESET_FLAGS_ALREADY_NOTIFIED, RUNTIME_ERROR_NOTIFIED, server
Constructor Summary
GaugeMonitor()
Default constructor.
Method Summary
Number | getDerivedGauge() Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
Number | getDerivedGauge(ObjectName object) Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
long | getDerivedGaugeTimeStamp() Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
long | getDerivedGaugeTimeStamp(ObjectName object) Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
boolean | getDifferenceMode() Gets the difference mode flag value common to all observed MBeans.
Number | getHighThreshold() Gets the high threshold value common to all observed MBeans.
Number | getLowThreshold() Gets the low threshold value common to all observed MBeans.
MBeanNotificationInfo[] | getNotificationInfo() Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the gauge monitor.
boolean | getNotifyHigh() Gets the high notification's on/off switch value common to all observed MBeans.
boolean | getNotifyLow() Gets the low notification's on/off switch value common to all observed MBeans.
void | setDifferenceMode(boolean value) Sets the difference mode flag value common to all observed MBeans.
void | setGranularityPeriod(long period) Sets the granularity period (in milliseconds).
void | setNotifyHigh(boolean value) Sets the high notification's on/off switch value common to all observed MBeans.
void | setNotifyLow(boolean value) Sets the low notification's on/off switch value common to all observed MBeans.
void | setThresholds(Number highValue, Number lowValue) Sets the high and the low threshold values common to all observed MBeans.
void | start() Starts the gauge monitor.
void | stop() Stops the gauge monitor.
Methods inherited from class javax.management.monitor.Monitor
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, postDeregister, postRegister, preDeregister, preRegister, removeObservedObject, setObservedAttribute, setObservedObject
Methods inherited from class javax.management.NotificationBroadcasterSupport
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.management.monitor.MonitorMBean
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setObservedAttribute, setObservedObject

Constructor Detail

GaugeMonitor

public GaugeMonitor()
Default constructor.

Method Detail

start

public void start()
Starts the gauge monitor.

Specified by:
start in interface MonitorMBean
Specified by:
start in class Monitor

stop

public void stop()
Stops the gauge monitor.

Specified by:
stop in interface MonitorMBean
Specified by:
stop in class Monitor

setGranularityPeriod

public void setGranularityPeriod(long period)
                          throws IllegalArgumentException
Sets the granularity period (in milliseconds).
The default value of the granularity period is 10 seconds.

Specified by:
setGranularityPeriod in interface MonitorMBean
Overrides:
setGranularityPeriod in class Monitor
Parameters:
period - The granularity period value.
Throws:
IllegalArgumentException - The granularity period is less than or equal to zero.
See Also:
Monitor.setGranularityPeriod(long)

getDerivedGauge

public Number getDerivedGauge(ObjectName object)
Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

Specified by:
getDerivedGauge in interface GaugeMonitorMBean
Parameters:
object - the name of the MBean.
Returns:
The derived gauge of the specified object.
Since:
JMX 1.2

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp(ObjectName object)
Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

Specified by:
getDerivedGaugeTimeStamp in interface GaugeMonitorMBean
Parameters:
object - the name of the MBean.
Returns:
The derived gauge timestamp of the specified object.
Since:
JMX 1.2

getDerivedGauge

public Number getDerivedGauge()
Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)

Returns the derived gauge of the first object in the set of observed MBeans.

Specified by:
getDerivedGauge in interface GaugeMonitorMBean
Returns:
The derived gauge.

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp()
Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)

Gets the derived gauge timestamp of the first object in the set of observed MBeans.

Specified by:
getDerivedGaugeTimeStamp in interface GaugeMonitorMBean
Returns:
The derived gauge timestamp.

getHighThreshold

public Number getHighThreshold()
Gets the high threshold value common to all observed MBeans.

Specified by:
getHighThreshold in interface GaugeMonitorMBean
Returns:
The high threshold value.

getLowThreshold

public Number getLowThreshold()
Gets the low threshold value common to all observed MBeans.

Specified by:
getLowThreshold in interface GaugeMonitorMBean
Returns:
The low threshold value.

setThresholds

public void setThresholds(Number highValue,
                          Number lowValue)
                   throws IllegalArgumentException
Sets the high and the low threshold values common to all observed MBeans.

Specified by:
setThresholds in interface GaugeMonitorMBean
Parameters:
highValue - The high threshold value.
lowValue - The low threshold value.
Throws:
IllegalArgumentException - The specified high/low threshold is null or the low threshold is greater than the high threshold or the high threshold and the low threshold are not of the same type.

getNotifyHigh

public boolean getNotifyHigh()
Gets the high notification's on/off switch value common to all observed MBeans.

Specified by:
getNotifyHigh in interface GaugeMonitorMBean
Returns:
true if the gauge monitor notifies when exceeding the high threshold, false otherwise.
See Also:
setNotifyHigh(boolean)

setNotifyHigh

public void setNotifyHigh(boolean value)
Sets the high notification's on/off switch value common to all observed MBeans.

Specified by:
setNotifyHigh in interface GaugeMonitorMBean
Parameters:
value - The high notification's on/off switch value.
See Also:
getNotifyHigh()

getNotifyLow

public boolean getNotifyLow()
Gets the low notification's on/off switch value common to all observed MBeans.

Specified by:
getNotifyLow in interface GaugeMonitorMBean
Returns:
true if the gauge monitor notifies when exceeding the low threshold, false otherwise.
See Also:
setNotifyLow(boolean)

setNotifyLow

public void setNotifyLow(boolean value)
Sets the low notification's on/off switch value common to all observed MBeans.

Specified by:
setNotifyLow in interface GaugeMonitorMBean
Parameters:
value - The low notification's on/off switch value.
See Also:
getNotifyLow()

getDifferenceMode

public boolean getDifferenceMode()
Gets the difference mode flag value common to all observed MBeans.

Specified by:
getDifferenceMode in interface GaugeMonitorMBean
Returns:
true if the difference mode is used, false otherwise.
See Also:
setDifferenceMode(boolean)

setDifferenceMode

public void setDifferenceMode(boolean value)
Sets the difference mode flag value common to all observed MBeans.

Specified by:
setDifferenceMode in interface GaugeMonitorMBean
Parameters:
value - The difference mode flag value.
See Also:
getDifferenceMode()

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the gauge monitor.

Specified by:
getNotificationInfo in interface NotificationBroadcaster
Overrides:
getNotificationInfo in class NotificationBroadcasterSupport
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


GaugeMonitorMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.monitor
Interface GaugeMonitorMBean

All Superinterfaces:
MonitorMBean
All Known Implementing Classes:
GaugeMonitor
public interface GaugeMonitorMBean
extends MonitorMBean

Exposes the remote management interface of the gauge monitor MBean.

Version:
4.14 09/06/02
Author:
Sun Microsystems, Inc

Method Summary
Number | getDerivedGauge() Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
Number | getDerivedGauge(ObjectName object) Gets the derived gauge for the specified MBean.
long | getDerivedGaugeTimeStamp() Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
long | getDerivedGaugeTimeStamp(ObjectName object) Gets the derived gauge timestamp for the specified MBean.
boolean | getDifferenceMode() Gets the difference mode flag value.
Number | getHighThreshold() Gets the high threshold value.
Number | getLowThreshold() Gets the low threshold value.
boolean | getNotifyHigh() Gets the high notification's on/off switch value.
boolean | getNotifyLow() Gets the low notification's on/off switch value.
void | setDifferenceMode(boolean value) Sets the difference mode flag value.
void | setNotifyHigh(boolean value) Sets the high notification's on/off switch value.
void | setNotifyLow(boolean value) Sets the low notification's on/off switch value.
void | setThresholds(Number highValue, Number lowValue) Sets the high and the low threshold values.
Methods inherited from interface javax.management.monitor.MonitorMBean
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject, start, stop

Method Detail

getDerivedGauge

public Number getDerivedGauge()
Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)

Gets the derived gauge.

Returns:
The derived gauge.

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp()
Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)

Gets the derived gauge timestamp.

Returns:
The derived gauge timestamp.

getDerivedGauge

public Number getDerivedGauge(ObjectName object)
Gets the derived gauge for the specified MBean.

Parameters:
object - the MBean for which the derived gauge is to be returned
Returns:
The derived gauge for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.
Since:
JMX 1.2

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp(ObjectName object)
Gets the derived gauge timestamp for the specified MBean.

Parameters:
object - the MBean for which the derived gauge timestamp is to be returned
Returns:
The derived gauge timestamp for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.
Since:
JMX 1.2

getHighThreshold

public Number getHighThreshold()
Gets the high threshold value.

Returns:
The high threshold value.

getLowThreshold

public Number getLowThreshold()
Gets the low threshold value.

Returns:
The low threshold value.

setThresholds

public void setThresholds(Number highValue,
                          Number lowValue)
                   throws IllegalArgumentException
Sets the high and the low threshold values.

Parameters:
highValue - The high threshold value.
lowValue - The low threshold value.
Throws:
IllegalArgumentException - The specified high/low threshold is null or the low threshold is greater than the high threshold or the high threshold and the low threshold are not of the same type.

getNotifyHigh

public boolean getNotifyHigh()
Gets the high notification's on/off switch value.

Returns:
true if the gauge monitor notifies when exceeding the high threshold, false otherwise.
See Also:
setNotifyHigh(boolean)

setNotifyHigh

public void setNotifyHigh(boolean value)
Sets the high notification's on/off switch value.

Parameters:
value - The high notification's on/off switch value.
See Also:
getNotifyHigh()

getNotifyLow

public boolean getNotifyLow()
Gets the low notification's on/off switch value.

Returns:
true if the gauge monitor notifies when exceeding the low threshold, false otherwise.
See Also:
setNotifyLow(boolean)

setNotifyLow

public void setNotifyLow(boolean value)
Sets the low notification's on/off switch value.

Parameters:
value - The low notification's on/off switch value.
See Also:
getNotifyLow()

getDifferenceMode

public boolean getDifferenceMode()
Gets the difference mode flag value.

Returns:
true if the difference mode is used, false otherwise.
See Also:
setDifferenceMode(boolean)

setDifferenceMode

public void setDifferenceMode(boolean value)
Sets the difference mode flag value.

Parameters:
value - The difference mode flag value.
See Also:
getDifferenceMode()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Monitor

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.monitor
Class Monitor

java.lang.Object
    extended by javax.management.NotificationBroadcasterSupport
        extended by javax.management.monitor.Monitor
All Implemented Interfaces:
MBeanRegistration, MonitorMBean, NotificationBroadcaster, NotificationEmitter
Direct Known Subclasses:
CounterMonitor, GaugeMonitor, StringMonitor
public abstract class Monitor
extends NotificationBroadcasterSupport
implements MonitorMBean, MBeanRegistration

Defines the common part to all monitor MBeans. A monitor MBean monitors values of an attribute common to a set of observed MBeans. The observed attribute is monitored at intervals specified by the granularity period. A gauge value (derived gauge) is derived from the values of the observed attribute.

Version:
4.28 09/06/02
Author:
Sun Microsystems, Inc

Field Summary
protected int | alreadyNotified Deprecated. equivalent to alreadyNotifieds[0].
protected int[] | alreadyNotifieds Selected monitor errors that have already been notified.
protected static int | capacityIncrement The amount by which the capacity of the monitor arrays are automatically incremented when their size becomes greater than their capacity.
protected String | dbgTag Deprecated. No replacement.
protected int | elementCount The number of valid components in the vector of observed objects.
protected static int | OBSERVED_ATTRIBUTE_ERROR_NOTIFIED Flag denoting that a notification has occurred after changing the observed attribute.
protected static int | OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED Flag denoting that a notification has occurred after changing the observed object or the observed attribute.
protected static int | OBSERVED_OBJECT_ERROR_NOTIFIED Flag denoting that a notification has occurred after changing the observed object.
protected static int | RESET_FLAGS_ALREADY_NOTIFIED This flag is used to reset the alreadyNotifieds monitor attribute.
protected static int | RUNTIME_ERROR_NOTIFIED Flag denoting that a notification has occurred after changing the observed object or the observed attribute.
protected MBeanServer | server Reference on the MBean server.
Constructor Summary
Monitor()
Method Summary
 void addObservedObject(ObjectName object)
Adds the specified object in the set of observed MBeans, if this object is not already present.
 boolean containsObservedObject(ObjectName object)
Tests whether the specified object is in the set of observed MBeans.
 long getGranularityPeriod()
Gets the granularity period (in milliseconds).
 String getObservedAttribute()
Gets the attribute being observed.
 ObjectName getObservedObject()
Deprecated. As of JMX 1.2, replaced by getObservedObjects()
 ObjectName[] getObservedObjects()
Returns an array containing the objects being observed.
 boolean isActive()
Tests whether the monitor MBean is active.
 void postDeregister()
Allows the monitor MBean to perform any operations needed after having been unregistered by the MBean server.
 void postRegister(Boolean registrationDone)
Allows the monitor MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
 void preDeregister()
Allows the monitor MBean to perform any operations it needs before being unregistered by the MBean server.
 ObjectName preRegister(MBeanServer server, ObjectName name)
Allows the monitor MBean to perform any operations it needs before being registered in the MBean server.
 void removeObservedObject(ObjectName object)
Removes the specified object from the set of observed MBeans.
 void setGranularityPeriod(long period)
Sets the granularity period (in milliseconds).
 void setObservedAttribute(String attribute)
Sets the attribute to observe.
 void setObservedObject(ObjectName object)
Deprecated. As of JMX 1.2, replaced by addObservedObject(javax.management.ObjectName)
abstract  void start()
Starts the monitor.
abstract  void stop()
Stops the monitor.
Methods inherited from class javax.management.NotificationBroadcasterSupport
addNotificationListener, getNotificationInfo, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

capacityIncrement

protected static final int capacityIncrement
The amount by which the capacity of the monitor arrays are automatically incremented when their size becomes greater than their capacity.

See Also:
Constant Field Values

elementCount

protected int elementCount
The number of valid components in the vector of observed objects.

Since:
JMX 1.2

alreadyNotified

protected int alreadyNotified
Deprecated. equivalent to alreadyNotifieds[0].

Monitor errors that have already been notified.

alreadyNotifieds

protected int[] alreadyNotifieds

Selected monitor errors that have already been notified.

Each element in this array corresponds to an observed object in the vector. It contains a bit mask of the flags OBSERVED_OBJECT_ERROR_NOTIFIED etc, indicating whether the corresponding notification has already been sent for the MBean being monitored.

Since:
JMX 1.2

server

protected MBeanServer server
Reference on the MBean server. This reference is null when the monitor MBean is not registered in an MBean server. This reference is initialized before the monitor MBean is registered in the MBean server.

See Also:
preRegister(MBeanServer server, ObjectName name)

RESET_FLAGS_ALREADY_NOTIFIED

protected static final int RESET_FLAGS_ALREADY_NOTIFIED
This flag is used to reset the alreadyNotifieds monitor attribute.

See Also:
Constant Field Values

OBSERVED_OBJECT_ERROR_NOTIFIED

protected static final int OBSERVED_OBJECT_ERROR_NOTIFIED
Flag denoting that a notification has occurred after changing the observed object. This flag is used to check that the new observed object is registered in the MBean server at the time of the first notification.

See Also:
Constant Field Values

OBSERVED_ATTRIBUTE_ERROR_NOTIFIED

protected static final int OBSERVED_ATTRIBUTE_ERROR_NOTIFIED
Flag denoting that a notification has occurred after changing the observed attribute. This flag is used to check that the new observed attribute belongs to the observed object at the time of the first notification.

See Also:
Constant Field Values

OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED

protected static final int OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED
Flag denoting that a notification has occurred after changing the observed object or the observed attribute. This flag is used to check that the observed attribute type is correct (depending on the monitor in use) at the time of the first notification.

See Also:
Constant Field Values

RUNTIME_ERROR_NOTIFIED

protected static final int RUNTIME_ERROR_NOTIFIED
Flag denoting that a notification has occurred after changing the observed object or the observed attribute. This flag is used to notify any exception (except the cases described above) when trying to get the value of the observed attribute at the time of the first notification.

See Also:
Constant Field Values

dbgTag

protected String dbgTag
Deprecated. No replacement.

This field is retained for compatibility but should not be referenced.

Constructor Detail

Monitor

public Monitor()
Method Detail

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
Allows the monitor MBean to perform any operations it needs before being registered in the MBean server.

Initializes the reference to the MBean server.

Specified by:
preRegister in interface MBeanRegistration
Parameters:
server - The MBean server in which the monitor MBean will be registered.
name - The object name of the monitor MBean.
Returns:
The name of the monitor MBean registered.
Throws:
Exception

postRegister

public void postRegister(Boolean registrationDone)
Allows the monitor MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

Not used in this context.

Specified by:
postRegister in interface MBeanRegistration
Parameters:
registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

preDeregister

public void preDeregister()
                   throws Exception
Allows the monitor MBean to perform any operations it needs before being unregistered by the MBean server.

Stops the monitor.

Specified by:
preDeregister in interface MBeanRegistration
Throws:
Exception

postDeregister

public void postDeregister()
Allows the monitor MBean to perform any operations needed after having been unregistered by the MBean server.

Not used in this context.

Specified by:
postDeregister in interface MBeanRegistration

start

public abstract void start()
Starts the monitor.

Specified by:
start in interface MonitorMBean

stop

public abstract void stop()
Stops the monitor.

Specified by:
stop in interface MonitorMBean

getObservedObject

public ObjectName getObservedObject()
Deprecated. As of JMX 1.2, replaced by getObservedObjects()

Returns the object name of the first object in the set of observed MBeans, or null if there is no such object.

Specified by:
getObservedObject in interface MonitorMBean
Returns:
The object being observed.
See Also:
setObservedObject(ObjectName)

setObservedObject

public void setObservedObject(ObjectName object)
                       throws IllegalArgumentException
Deprecated. As of JMX 1.2, replaced by addObservedObject(javax.management.ObjectName)

Removes all objects from the set of observed objects, and then adds the specified object.

Specified by:
setObservedObject in interface MonitorMBean
Parameters:
object - The object to observe.
Throws:
IllegalArgumentException - The specified object is null.
See Also:
getObservedObject()

addObservedObject

public void addObservedObject(ObjectName object)
                       throws IllegalArgumentException
Adds the specified object in the set of observed MBeans, if this object is not already present.

Specified by:
addObservedObject in interface MonitorMBean
Parameters:
object - The object to observe.
Throws:
IllegalArgumentException - The specified object is null.
Since:
JMX 1.2

removeObservedObject

public void removeObservedObject(ObjectName object)
Removes the specified object from the set of observed MBeans.

Specified by:
removeObservedObject in interface MonitorMBean
Parameters:
object - The object to remove.
Since:
JMX 1.2

containsObservedObject

public boolean containsObservedObject(ObjectName object)
Tests whether the specified object is in the set of observed MBeans.

Specified by:
containsObservedObject in interface MonitorMBean
Parameters:
object - The object to check.
Returns:
true if the specified object is present, false otherwise.
Since:
JMX 1.2

getObservedObjects

public ObjectName[] getObservedObjects()
Returns an array containing the objects being observed.

Specified by:
getObservedObjects in interface MonitorMBean
Returns:
The objects being observed.
Since:
JMX 1.2

getObservedAttribute

public String getObservedAttribute()
Gets the attribute being observed.
The observed attribute is not initialized by default (set to null).

Specified by:
getObservedAttribute in interface MonitorMBean
Returns:
The attribute being observed.
See Also:
setObservedAttribute(java.lang.String)

setObservedAttribute

public void setObservedAttribute(String attribute)
                          throws IllegalArgumentException
Sets the attribute to observe.
The observed attribute is not initialized by default (set to null).

Specified by:
setObservedAttribute in interface MonitorMBean
Parameters:
attribute - The attribute to observe.
Throws:
IllegalArgumentException - The specified attribute is null.
See Also:
getObservedAttribute()

getGranularityPeriod

public long getGranularityPeriod()
Gets the granularity period (in milliseconds).
The default value of the granularity period is 10 seconds.

Specified by:
getGranularityPeriod in interface MonitorMBean
Returns:
The granularity period value.
See Also:
setGranularityPeriod(long)

setGranularityPeriod

public void setGranularityPeriod(long period)
                          throws IllegalArgumentException
Sets the granularity period (in milliseconds).
The default value of the granularity period is 10 seconds.

Specified by:
setGranularityPeriod in interface MonitorMBean
Parameters:
period - The granularity period value.
Throws:
IllegalArgumentException - The granularity period is less than or equal to zero.
See Also:
getGranularityPeriod()

isActive

public boolean isActive()
Tests whether the monitor MBean is active. A monitor MBean is marked active when the start method is called. It becomes inactive when the stop method is called.

Specified by:
isActive in interface MonitorMBean
Returns:
true if the monitor MBean is active, false otherwise.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MonitorMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.monitor
Interface MonitorMBean

All Known Subinterfaces:
CounterMonitorMBean, GaugeMonitorMBean, StringMonitorMBean
All Known Implementing Classes:
CounterMonitor, GaugeMonitor, Monitor, StringMonitor
public interface MonitorMBean

Exposes the remote management interface of monitor MBeans.

Version:
4.12 09/06/02
Author:
Sun Microsystems, Inc

Method Summary
 void addObservedObject(ObjectName object)
Adds the specified object in the set of observed MBeans.
 boolean containsObservedObject(ObjectName object)
Tests whether the specified object is in the set of observed MBeans.
 long getGranularityPeriod()
Gets the granularity period (in milliseconds).
 String getObservedAttribute()
Gets the attribute being observed.
 ObjectName getObservedObject()
Deprecated. As of JMX 1.2, replaced by getObservedObjects()
 ObjectName[] getObservedObjects()
Returns an array containing the objects being observed.
 boolean isActive()
Tests if the monitor MBean is active.
 void removeObservedObject(ObjectName object)
Removes the specified object from the set of observed MBeans.
 void setGranularityPeriod(long period)
Sets the granularity period (in milliseconds).
 void setObservedAttribute(String attribute)
Sets the attribute to observe.
 void setObservedObject(ObjectName object)
Deprecated. As of JMX 1.2, replaced by addObservedObject(javax.management.ObjectName)
 void start()
Starts the monitor.
 void stop()
Stops the monitor.

Method Detail

start

public void start()
Starts the monitor.

stop

public void stop()
Stops the monitor.

addObservedObject

public void addObservedObject(ObjectName object)
                       throws IllegalArgumentException
Adds the specified object in the set of observed MBeans.

Parameters:
object - The object to observe.
Throws:
IllegalArgumentException - the specified object is null.
Since:
JMX 1.2

removeObservedObject

public void removeObservedObject(ObjectName object)
Removes the specified object from the set of observed MBeans.

Parameters:
object - The object to remove.
Since:
JMX 1.2

containsObservedObject

public boolean containsObservedObject(ObjectName object)
Tests whether the specified object is in the set of observed MBeans.

Parameters:
object - The object to check.
Returns:
true if the specified object is in the set, false otherwise.
Since:
JMX 1.2

getObservedObjects

public ObjectName[] getObservedObjects()
Returns an array containing the objects being observed.

Returns:
The objects being observed.
Since:
JMX 1.2

getObservedObject

public ObjectName getObservedObject()
Deprecated. As of JMX 1.2, replaced by getObservedObjects()

Gets the object name of the object being observed.

Returns:
The object being observed.
See Also:
setObservedObject(javax.management.ObjectName)

setObservedObject

public void setObservedObject(ObjectName object)
Deprecated. As of JMX 1.2, replaced by addObservedObject(javax.management.ObjectName)

Sets the object to observe identified by its object name.

Parameters:
object - The object to observe.
See Also:
getObservedObject()

getObservedAttribute

public String getObservedAttribute()
Gets the attribute being observed.

Returns:
The attribute being observed.
See Also:
setObservedAttribute(java.lang.String)

setObservedAttribute

public void setObservedAttribute(String attribute)
Sets the attribute to observe.

Parameters:
attribute - The attribute to observe.
See Also:
getObservedAttribute()

getGranularityPeriod

public long getGranularityPeriod()
Gets the granularity period (in milliseconds).

Returns:
The granularity period.
See Also:
setGranularityPeriod(long)

setGranularityPeriod

public void setGranularityPeriod(long period)
                          throws IllegalArgumentException
Sets the granularity period (in milliseconds).

Parameters:
period - The granularity period.
Throws:
IllegalArgumentException - The granularity period is less than or equal to zero.
See Also:
getGranularityPeriod()

isActive

public boolean isActive()
Tests if the monitor MBean is active. A monitor MBean is marked active when the start method is called. It becomes inactive when the stop method is called.

Returns:
true if the monitor MBean is active, false otherwise.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MonitorNotification

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.monitor
Class MonitorNotification

java.lang.Object
    extended by java.util.EventObject
        extended by javax.management.Notification
            extended by javax.management.monitor.MonitorNotification
All Implemented Interfaces:
Serializable
public class MonitorNotification
extends Notification

Provides definitions of the notifications sent by monitor MBeans.

The notification source and a set of parameters concerning the monitor MBean's state need to be specified when creating a new object of this class. The list of notifications fired by the monitor MBeans is the following:

  • Common to all kind of monitors:
    • The observed object is not registered in the MBean server.
    • The observed attribute is not contained in the observed object.
    • The type of the observed attribute is not correct.
    • Any exception (except the cases described above) occurs when trying to get the value of the observed attribute.
  • Common to the counter and the gauge monitors:
    • The threshold high or threshold low are not of the same type as the gauge (gauge monitors).
    • The threshold or the offset or the modulus are not of the same type as the counter (counter monitors).
  • Counter monitors only:
    • The observed attribute has reached the threshold value.
  • Gauge monitors only:
    • The observed attribute has exceeded the threshold high value.
    • The observed attribute has exceeded the threshold low value.
  • String monitors only:
    • The observed attribute has matched the "string to compare" value.
    • The observed attribute has differed from the "string to compare" value.

Version:
4.14 02/27/02
Author:
Sun Microsystems, Inc
See Also:
Serialized Form

Field Summary
static String | OBSERVED_ATTRIBUTE_ERROR Notification type denoting that the observed attribute is not contained in the observed object.
static String | OBSERVED_ATTRIBUTE_TYPE_ERROR Notification type denoting that the type of the observed attribute is not correct.
static String | OBSERVED_OBJECT_ERROR Notification type denoting that the observed object is not registered in the MBean server.
static String | RUNTIME_ERROR Notification type denoting that a non-predefined error type has occurred when trying to get the value of the observed attribute.
static String | STRING_TO_COMPARE_VALUE_DIFFERED Notification type denoting that the observed attribute has differed from the "string to compare" value.
static String | STRING_TO_COMPARE_VALUE_MATCHED Notification type denoting that the observed attribute has matched the "string to compare" value.
static String | THRESHOLD_ERROR Notification type denoting that the type of the thresholds, offset or modulus is not correct.
static String | THRESHOLD_HIGH_VALUE_EXCEEDED Notification type denoting that the observed attribute has exceeded the threshold high value.
static String | THRESHOLD_LOW_VALUE_EXCEEDED Notification type denoting that the observed attribute has exceeded the threshold low value.
static String | THRESHOLD_VALUE_EXCEEDED Notification type denoting that the observed attribute has reached the threshold value.
Fields inherited from class javax.management.Notification
source
Method Summary
Object | getDerivedGauge() Gets the derived gauge of this monitor notification.
String | getObservedAttribute() Gets the observed attribute of this monitor notification.
ObjectName | getObservedObject() Gets the observed object of this monitor notification.
Object | getTrigger() Gets the threshold/string (depending on the monitor type) that triggered off this monitor notification.
Methods inherited from class javax.management.Notification
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

OBSERVED_OBJECT_ERROR

public static final String OBSERVED_OBJECT_ERROR
Notification type denoting that the observed object is not registered in the MBean server. This notification is fired by all kinds of monitors.
The value of this notification type is jmx.monitor.error.mbean.

OBSERVED_ATTRIBUTE_ERROR

public static final String OBSERVED_ATTRIBUTE_ERROR
Notification type denoting that the observed attribute is not contained in the observed object. This notification is fired by all kinds of monitors.
The value of this notification type is jmx.monitor.error.attribute.

OBSERVED_ATTRIBUTE_TYPE_ERROR

public static final String OBSERVED_ATTRIBUTE_TYPE_ERROR
Notification type denoting that the type of the observed attribute is not correct. This notification is fired by all kinds of monitors.
The value of this notification type is jmx.monitor.error.type.

THRESHOLD_ERROR

public static final String THRESHOLD_ERROR
Notification type denoting that the type of the thresholds, offset or modulus is not correct. This notification is fired by counter and gauge monitors.
The value of this notification type is jmx.monitor.error.threshold.

RUNTIME_ERROR

public static final String RUNTIME_ERROR
Notification type denoting that a non-predefined error type has occurred when trying to get the value of the observed attribute. This notification is fired by all kinds of monitors.
The value of this notification type is jmx.monitor.error.runtime.

THRESHOLD_VALUE_EXCEEDED

public static final String THRESHOLD_VALUE_EXCEEDED
Notification type denoting that the observed attribute has reached the threshold value. This notification is only fired by counter monitors.
The value of this notification type is jmx.monitor.counter.threshold.

THRESHOLD_HIGH_VALUE_EXCEEDED

public static final String THRESHOLD_HIGH_VALUE_EXCEEDED
Notification type denoting that the observed attribute has exceeded the threshold high value. This notification is only fired by gauge monitors.
The value of this notification type is jmx.monitor.gauge.high.

THRESHOLD_LOW_VALUE_EXCEEDED

public static final String THRESHOLD_LOW_VALUE_EXCEEDED
Notification type denoting that the observed attribute has exceeded the threshold low value. This notification is only fired by gauge monitors.
The value of this notification type is jmx.monitor.gauge.low.

STRING_TO_COMPARE_VALUE_MATCHED

public static final String STRING_TO_COMPARE_VALUE_MATCHED
Notification type denoting that the observed attribute has matched the "string to compare" value. This notification is only fired by string monitors.
The value of this notification type is jmx.monitor.string.matches.

STRING_TO_COMPARE_VALUE_DIFFERED

public static final String STRING_TO_COMPARE_VALUE_DIFFERED
Notification type denoting that the observed attribute has differed from the "string to compare" value. This notification is only fired by string monitors.
The value of this notification type is jmx.monitor.string.differs.

Method Detail

getObservedObject

public ObjectName getObservedObject()
Gets the observed object of this monitor notification.

Returns:
The observed object.

getObservedAttribute

public String getObservedAttribute()
Gets the observed attribute of this monitor notification.

Returns:
The observed attribute.

getDerivedGauge

public Object getDerivedGauge()
Gets the derived gauge of this monitor notification.

Returns:
The derived gauge.

getTrigger

public Object getTrigger()
Gets the threshold/string (depending on the monitor type) that triggered off this monitor notification.

Returns:
The trigger.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MonitorSettingException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.monitor
Class MonitorSettingException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.management.JMRuntimeException
                    extended by javax.management.monitor.MonitorSettingException
All Implemented Interfaces:
Serializable
public class MonitorSettingException
extends JMRuntimeException

Exception thrown by the monitor when a monitor setting becomes invalid while the monitor is running.

As the monitor attributes may change at runtime, a check is performed before each observation. If a monitor attribute has become invalid, a monitor setting exception is thrown.

Version:
4.9 02/27/02
Author:
Sun Microsystems, Inc
See Also:
Serialized Form

Constructor Summary
MonitorSettingException()
Default constructor.
MonitorSettingException(String message)
Constructor that allows an error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MonitorSettingException

public MonitorSettingException()
Default constructor.

MonitorSettingException

public MonitorSettingException(String message)
Constructor that allows an error message to be specified.

Parameters:
message - The specific error message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StringMonitor

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.monitor
Class StringMonitor

java.lang.Object
    extended by javax.management.NotificationBroadcasterSupport
        extended by javax.management.monitor.Monitor
            extended by javax.management.monitor.StringMonitor
All Implemented Interfaces:
MBeanRegistration, MonitorMBean, NotificationBroadcaster, NotificationEmitter, StringMonitorMBean
public class StringMonitor
extends Monitor
implements StringMonitorMBean

Defines a monitor MBean designed to observe the values of a string attribute.

A string monitor sends notifications as follows:

  • if the attribute value matches the string to compare value, a match notification is sent. The notify match flag must be set to true.
    Subsequent matchings of the string to compare values do not cause further notifications unless the attribute value differs from the string to compare value.
  • if the attribute value differs from the string to compare value, a differ notification is sent. The notify differ flag must be set to true.
    Subsequent differences from the string to compare value do not cause further notifications unless the attribute value matches the string to compare value.

Version:
4.28 10/08/02
Author:
Sun Microsystems, Inc

Field Summary
Fields inherited from class javax.management.monitor.Monitor
alreadyNotified, alreadyNotifieds, capacityIncrement, dbgTag, elementCount, OBSERVED_ATTRIBUTE_ERROR_NOTIFIED, OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED, OBSERVED_OBJECT_ERROR_NOTIFIED, RESET_FLAGS_ALREADY_NOTIFIED, RUNTIME_ERROR_NOTIFIED, server
Constructor Summary
StringMonitor()
Default constructor.
Method Summary
String | getDerivedGauge() Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
String | getDerivedGauge(ObjectName object) Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
long | getDerivedGaugeTimeStamp() Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
long | getDerivedGaugeTimeStamp(ObjectName object) Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.
MBeanNotificationInfo[] | getNotificationInfo() Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the string monitor.
boolean | getNotifyDiffer() Gets the differing notification's on/off switch value common to all observed MBeans.
boolean | getNotifyMatch() Gets the matching notification's on/off switch value common to all observed MBeans.
String | getStringToCompare() Gets the string to compare with the observed attribute common to all observed MBeans.
void | setGranularityPeriod(long period) Sets the granularity period (in milliseconds).
void | setNotifyDiffer(boolean value) Sets the differing notification's on/off switch value common to all observed MBeans.
void | setNotifyMatch(boolean value) Sets the matching notification's on/off switch value common to all observed MBeans.
void | setStringToCompare(String value) Sets the string to compare with the observed attribute common to all observed MBeans.
void | start() Starts the string monitor.
void | stop() Stops the string monitor.
Methods inherited from class javax.management.monitor.Monitor
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, postDeregister, postRegister, preDeregister, preRegister, removeObservedObject, setObservedAttribute, setObservedObject
Methods inherited from class javax.management.NotificationBroadcasterSupport
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.management.monitor.MonitorMBean
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setObservedAttribute, setObservedObject

Constructor Detail

StringMonitor

public StringMonitor()
Default constructor.

Method Detail

start

public void start()
Starts the string monitor.

Specified by:
start in interface MonitorMBean
Specified by:
start in class Monitor

stop

public void stop()
Stops the string monitor.

Specified by:
stop in interface MonitorMBean
Specified by:
stop in class Monitor

setGranularityPeriod

public void setGranularityPeriod(long period)
                          throws IllegalArgumentException
Sets the granularity period (in milliseconds).
The default value of the granularity period is 10 seconds.

Specified by:
setGranularityPeriod in interface MonitorMBean
Overrides:
setGranularityPeriod in class Monitor
Parameters:
period - The granularity period value.
Throws:
IllegalArgumentException - The granularity period is less than or equal to zero.
See Also:
Monitor.setGranularityPeriod(long)

getDerivedGauge

public String getDerivedGauge(ObjectName object)
Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

Specified by:
getDerivedGauge in interface StringMonitorMBean
Parameters:
object - the name of the MBean whose derived gauge is required.
Returns:
The derived gauge of the specified object.
Since:
JMX 1.2

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp(ObjectName object)
Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

Specified by:
getDerivedGaugeTimeStamp in interface StringMonitorMBean
Parameters:
object - the name of the MBean whose derived gauge timestamp is required.
Returns:
The derived gauge timestamp of the specified object.
Since:
JMX 1.2

getDerivedGauge

public String getDerivedGauge()
Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)

Returns the derived gauge of the first object in the set of observed MBeans.

Specified by:
getDerivedGauge in interface StringMonitorMBean
Returns:
The derived gauge.

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp()
Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)

Gets the derived gauge timestamp of the first object in the set of observed MBeans.

Specified by:
getDerivedGaugeTimeStamp in interface StringMonitorMBean
Returns:
The derived gauge timestamp.

getStringToCompare

public String getStringToCompare()
Gets the string to compare with the observed attribute common to all observed MBeans.

Specified by:
getStringToCompare in interface StringMonitorMBean
Returns:
The string value.
See Also:
setStringToCompare(java.lang.String)

setStringToCompare

public void setStringToCompare(String value)
                        throws IllegalArgumentException
Sets the string to compare with the observed attribute common to all observed MBeans.

Specified by:
setStringToCompare in interface StringMonitorMBean
Parameters:
value - The string value.
Throws:
IllegalArgumentException - The specified string to compare is null.
See Also:
getStringToCompare()

getNotifyMatch

public boolean getNotifyMatch()
Gets the matching notification's on/off switch value common to all observed MBeans.

Specified by:
getNotifyMatch in interface StringMonitorMBean
Returns:
true if the string monitor notifies when matching the string to compare, false otherwise.
See Also:
setNotifyMatch(boolean)

setNotifyMatch

public void setNotifyMatch(boolean value)
Sets the matching notification's on/off switch value common to all observed MBeans.

Specified by:
setNotifyMatch in interface StringMonitorMBean
Parameters:
value - The matching notification's on/off switch value.
See Also:
getNotifyMatch()

getNotifyDiffer

public boolean getNotifyDiffer()
Gets the differing notification's on/off switch value common to all observed MBeans.

Specified by:
getNotifyDiffer in interface StringMonitorMBean
Returns:
true if the string monitor notifies when differing from the string to compare, false otherwise.
See Also:
setNotifyDiffer(boolean)

setNotifyDiffer

public void setNotifyDiffer(boolean value)
Sets the differing notification's on/off switch value common to all observed MBeans.

Specified by:
setNotifyDiffer in interface StringMonitorMBean
Parameters:
value - The differing notification's on/off switch value.
See Also:
getNotifyDiffer()

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the string monitor.

Specified by:
getNotificationInfo in interface NotificationBroadcaster
Overrides:
getNotificationInfo in class NotificationBroadcasterSupport
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StringMonitorMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.monitor
Interface StringMonitorMBean

All Superinterfaces:
MonitorMBean
All Known Implementing Classes:
StringMonitor
public interface StringMonitorMBean
extends MonitorMBean

Exposes the remote management interface of the string monitor MBean.

Version:
4.13 09/06/02
Author:
Sun Microsystems, Inc

Method Summary
String | getDerivedGauge() Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)
String | getDerivedGauge(ObjectName object) Gets the derived gauge for the specified MBean.
long | getDerivedGaugeTimeStamp() Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)
long | getDerivedGaugeTimeStamp(ObjectName object) Gets the derived gauge timestamp for the specified MBean.
boolean | getNotifyDiffer() Gets the differing notification's on/off switch value.
boolean | getNotifyMatch() Gets the matching notification's on/off switch value.
String | getStringToCompare() Gets the string to compare with the observed attribute.
void | setNotifyDiffer(boolean value) Sets the differing notification's on/off switch value.
void | setNotifyMatch(boolean value) Sets the matching notification's on/off switch value.
void | setStringToCompare(String value) Sets the string to compare with the observed attribute.
Methods inherited from interface javax.management.monitor.MonitorMBean
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject, start, stop

Method Detail

getDerivedGauge

public String getDerivedGauge()
Deprecated. As of JMX 1.2, replaced by getDerivedGauge(ObjectName)

Gets the derived gauge.

Returns:
The derived gauge.

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp()
Deprecated. As of JMX 1.2, replaced by getDerivedGaugeTimeStamp(ObjectName)

Gets the derived gauge timestamp.

Returns:
The derived gauge timestamp.

getDerivedGauge

public String getDerivedGauge(ObjectName object)
Gets the derived gauge for the specified MBean.

Parameters:
object - the MBean for which the derived gauge is to be returned
Returns:
The derived gauge for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.
Since:
JMX 1.2

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp(ObjectName object)
Gets the derived gauge timestamp for the specified MBean.

Parameters:
object - the MBean for which the derived gauge timestamp is to be returned
Returns:
The derived gauge timestamp for the specified MBean if this MBean is in the set of observed MBeans, or null otherwise.
Since:
JMX 1.2

getStringToCompare

public String getStringToCompare()
Gets the string to compare with the observed attribute.

Returns:
The string value.
See Also:
setStringToCompare(java.lang.String)

setStringToCompare

public void setStringToCompare(String value)
                        throws IllegalArgumentException
Sets the string to compare with the observed attribute.

Parameters:
value - The string value.
Throws:
IllegalArgumentException - The specified string to compare is null.
See Also:
getStringToCompare()

getNotifyMatch

public boolean getNotifyMatch()
Gets the matching notification's on/off switch value.

Returns:
true if the string monitor notifies when matching, false otherwise.
See Also:
setNotifyMatch(boolean)

setNotifyMatch

public void setNotifyMatch(boolean value)
Sets the matching notification's on/off switch value.

Parameters:
value - The matching notification's on/off switch value.
See Also:
getNotifyMatch()

getNotifyDiffer

public boolean getNotifyDiffer()
Gets the differing notification's on/off switch value.

Returns:
true if the string monitor notifies when differing, false otherwise.
See Also:
setNotifyDiffer(boolean)

setNotifyDiffer

public void setNotifyDiffer(boolean value)
Sets the differing notification's on/off switch value.

Parameters:
value - The differing notification's on/off switch value.
See Also:
getNotifyDiffer()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NotCompliantMBeanException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class NotCompliantMBeanException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.OperationsException
                    extended by javax.management.NotCompliantMBeanException
All Implemented Interfaces:
Serializable
public class NotCompliantMBeanException
extends OperationsException

Exception which occurs when trying to register an object in the MBean server that is not a JMX compliant MBean.

See Also:
Serialized Form

Constructor Summary
NotCompliantMBeanException()
Default constructor.
NotCompliantMBeanException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NotCompliantMBeanException

public NotCompliantMBeanException()
Default constructor.

NotCompliantMBeanException

public NotCompliantMBeanException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Notification

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class Notification

java.lang.Object
    extended by java.util.EventObject
        extended by javax.management.Notification
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AttributeChangeNotification, MBeanServerNotification, MonitorNotification, RelationNotification, TimerAlarmClockNotification, TimerNotification
public class Notification
extends EventObject

The Notification class represents a notification emitted by an MBean. It contains a reference to the source MBean: if the notification has been forwarded through the MBean server, this is the object name of the MBean. If the listener has registered directly with the MBean, this is either the object name or a direct reference to the MBean.

It is strongly recommended that notification senders use the object name rather than a reference to the MBean object as the source.

See Also:
Serialized Form

Field Summary
protected  Object source
This field hides the EventObject.source field in the parent class to make it non-transient and therefore part of the serialized form.
Constructor Summary
Notification(String type, Object source, long sequenceNumber)
Creates a Notification object.
Notification(String type, Object source, long sequenceNumber, long timeStamp)
Creates a Notification object.
Notification(String type, Object source, long sequenceNumber, long timeStamp, String message)
Creates a Notification object.
Notification(String type, Object source, long sequenceNumber, String message)
Creates a Notification object.
Method Summary
String | getMessage() Get the notification message.
long | getSequenceNumber() Get the notification sequence number.
long | getTimeStamp() Get the notification timestamp.
String | getType() Get the notification type.
Object | getUserData() Get the user data.
void | setSequenceNumber(long sequenceNumber) Set the notification sequence number.
void | setSource(Object source) Sets the source.
void | setTimeStamp(long timeStamp) Set the notification timestamp.
void | setUserData(Object userData) Set the user data.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

source

protected Object source

This field hides the EventObject.source field in the parent class to make it non-transient and therefore part of the serialized form.

Constructor Detail

Notification

public Notification(String type,
                    Object source,
                    long sequenceNumber)
Creates a Notification object. The notification timeStamp is set to the current date.

Parameters:
type - The notification type.
source - The notification source.
sequenceNumber - The notification sequence number within the source object.

Notification

public Notification(String type,
                    Object source,
                    long sequenceNumber,
                    String message)
Creates a Notification object. The notification timeStamp is set to the current date.

Parameters:
type - The notification type.
source - The notification source.
sequenceNumber - The notification sequence number within the source object.
message - The detailed message.

Notification

public Notification(String type,
                    Object source,
                    long sequenceNumber,
                    long timeStamp)
Creates a Notification object.

Parameters:
type - The notification type.
source - The notification source.
sequenceNumber - The notification sequence number within the source object.
timeStamp - The notification emission date.

Notification

public Notification(String type,
                    Object source,
                    long sequenceNumber,
                    long timeStamp,
                    String message)
Creates a Notification object.

Parameters:
type - The notification type.
source - The notification source.
sequenceNumber - The notification sequence number within the source object.
timeStamp - The notification emission date.
message - The detailed message.
Method Detail

setSource

public void setSource(Object source)
Sets the source.

Parameters:
source - the new source for this object.
See Also:
EventObject.getSource()

getSequenceNumber

public long getSequenceNumber()
Get the notification sequence number.

Returns:
The notification sequence number within the source object. It's a serial number identifying a particular instance of notification in the context of the notification source. The notification model does not assume that notifications will be received in the same order that they are sent. The sequence number helps listeners to sort received notifications.
See Also:
setSequenceNumber(long)

setSequenceNumber

public void setSequenceNumber(long sequenceNumber)
Set the notification sequence number.

Parameters:
sequenceNumber - The notification sequence number within the source object. It is a serial number identifying a particular instance of notification in the context of the notification source.
See Also:
getSequenceNumber()

getType

public String getType()
Get the notification type.

Returns:
The notification type. It's a string expressed in a dot notation similar to Java properties. An example of a notification type is network.alarm.router .

getTimeStamp

public long getTimeStamp()
Get the notification timestamp.

Returns:
The notification timestamp.
See Also:
setTimeStamp(long)

setTimeStamp

public void setTimeStamp(long timeStamp)
Set the notification timestamp.

Parameters:
timeStamp - The notification timestamp. It indicates when the notification was generated.
See Also:
getTimeStamp()

getMessage

public String getMessage()
Get the notification message.

Returns:
The message string of this notification object. It contains in a string, which could be the explanation of the notification for displaying to a user

getUserData

public Object getUserData()
Get the user data.

Returns:
The user data object. It is used for whatever data the notification source wishes to communicate to its consumers.
See Also:
setUserData(java.lang.Object)

setUserData

public void setUserData(Object userData)
Set the user data.

Parameters:
userData - The user data object. It is used for whatever data the notification source wishes to communicate to its consumers.
See Also:
getUserData()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NotificationBroadcaster

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface NotificationBroadcaster

All Known Subinterfaces:
ModelMBean, ModelMBeanNotificationBroadcaster, NotificationEmitter
All Known Implementing Classes:
MBeanServerDelegate, NotificationBroadcasterSupport, RequiredModelMBean
public interface NotificationBroadcaster

Interface implemented by an MBean that emits Notifications. It allows a listener to be registered with the MBean as a notification listener.

New code should use the NotificationEmitter interface instead.

Method Summary
void | addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) Adds a listener to this MBean.
MBeanNotificationInfo[] | getNotificationInfo() Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.
void | removeNotificationListener(NotificationListener listener) Removes a listener from this MBean.

Method Detail

addNotificationListener

public void addNotificationListener(NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
                             throws IllegalArgumentException
Adds a listener to this MBean.

Parameters:
listener - The listener object which will handle the notifications emitted by the broadcaster.
filter - The filter object. If filter is null, no filtering will be performed before handling notifications.
handback - An opaque object to be sent back to the listener when a notification is emitted. This object cannot be used by the Notification broadcaster object. It should be resent unchanged with the notification to the listener.
Throws:
IllegalArgumentException - Listener parameter is null.
See Also:
removeNotificationListener(javax.management.NotificationListener)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener)
                                throws ListenerNotFoundException
Removes a listener from this MBean. If the listener has been registered with different handback objects or notification filters, all entries corresponding to the listener will be removed.

Parameters:
listener - A listener that was previously added to this MBean.
Throws:
ListenerNotFoundException - The listener is not registered with the MBean.
See Also:
addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()

Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.

It is not illegal for the MBean to send notifications not described in this array. However, some clients of the MBean server may depend on the array being complete for their correct functioning.

Returns:
the array of possible notifications.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NotificationBroadcasterSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class NotificationBroadcasterSupport

java.lang.Object
    extended by javax.management.NotificationBroadcasterSupport
All Implemented Interfaces:
NotificationBroadcaster, NotificationEmitter
Direct Known Subclasses:
Monitor, RelationService, Timer
public class NotificationBroadcasterSupport
extends Object
implements NotificationEmitter

Provides an implementation of NotificationEmitter interface. This can be used as the super class of an MBean that sends notifications.

It is not specified whether the notification dispatch model is synchronous or asynchronous. That is, when a thread calls sendNotification, the NotificationListener.handleNotification method of each listener may be called within that thread (a synchronous model) or within some other thread (an asynchronous model).

Applications should not depend on notification dispatch being synchronous or being asynchronous. Thus:

  • Applications should not assume a synchronous model. When the sendNotification method returns, it is not guaranteed that every listener's handleNotification method has been called. It is not guaranteed either that a listener will see notifications in the same order as they were generated. Listeners that depend on order should use the sequence number of notifications to determine their order (see Notification.getSequenceNumber()).
  • Applications should not assume an asynchronous model. If the actions performed by a listener are potentially slow, the listener should arrange for them to be performed in another thread, to avoid holding up other listeners and the caller of sendNotification.

Constructor Summary
NotificationBroadcasterSupport()
Method Summary
void | addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) Adds a listener.
MBeanNotificationInfo[] | getNotificationInfo() Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.
protected void | handleNotification(NotificationListener listener, Notification notif, Object handback) This method is called by sendNotification for each listener in order to send the notification to that listener.
void | removeNotificationListener(NotificationListener listener) Removes a listener from this MBean.
void | removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) Removes a listener from this MBean.
void | sendNotification(Notification notification) Sends a notification.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NotificationBroadcasterSupport

public NotificationBroadcasterSupport()
Method Detail

addNotificationListener

public void addNotificationListener(NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
Adds a listener.

Specified by:
addNotificationListener in interface NotificationBroadcaster
Parameters:
listener - The listener to receive notifications.
filter - The filter object. If filter is null, no filtering will be performed before handling notifications.
handback - An opaque object to be sent back to the listener when a notification is emitted. This object cannot be used by the Notification broadcaster object. It should be resent unchanged with the notification to the listener.
Throws:
IllegalArgumentException - thrown if the istener is null.
See Also:
removeNotificationListener(javax.management.NotificationListener)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener)
                                throws ListenerNotFoundException
Description copied from interface: NotificationBroadcaster
Removes a listener from this MBean. If the listener has been registered with different handback objects or notification filters, all entries corresponding to the listener will be removed.

Specified by:
removeNotificationListener in interface NotificationBroadcaster
Parameters:
listener - A listener that was previously added to this MBean.
Throws:
ListenerNotFoundException - The listener is not registered with the MBean.
See Also:
NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws ListenerNotFoundException
Description copied from interface: NotificationEmitter

Removes a listener from this MBean. The MBean must have a listener that exactly matches the given listener, filter, and handback parameters. If there is more than one such listener, only one is removed.

The filter and handback parameters may be null if and only if they are null in a listener to be removed.

Specified by:
removeNotificationListener in interface NotificationEmitter
Parameters:
listener - A listener that was previously added to this MBean.
filter - The filter that was specified when the listener was added.
handback - The handback that was specified when the listener was added.
Throws:
ListenerNotFoundException - The listener is not registered with the MBean, or it is not registered with the given filter and handback.

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
Description copied from interface: NotificationBroadcaster

Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.

It is not illegal for the MBean to send notifications not described in this array. However, some clients of the MBean server may depend on the array being complete for their correct functioning.

Specified by:
getNotificationInfo in interface NotificationBroadcaster
Returns:
the array of possible notifications.

sendNotification

public void sendNotification(Notification notification)
Sends a notification.

Parameters:
notification - The notification to send.

handleNotification

protected void handleNotification(NotificationListener listener,
                                  Notification notif,
                                  Object handback)

This method is called by sendNotification for each listener in order to send the notification to that listener. It can be overridden in subclasses to change the behaviour of notification delivery, for instance to deliver the notification in a separate thread.

It is not guaranteed that this method is called by the same thread as the one that called sendNotification.

The default implementation of this method is equivalent to

 listener.handleNotification(notif, handback);

Parameters:
listener - the listener to which the notification is being delivered.
notif - the notification being delivered to the listener.
handback - the handback object that was supplied when the listener was added.
Since:
JMX 1.2
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NotificationEmitter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface NotificationEmitter

All Superinterfaces:
NotificationBroadcaster
All Known Implementing Classes:
MBeanServerDelegate, NotificationBroadcasterSupport, RequiredModelMBean
public interface NotificationEmitter
extends NotificationBroadcaster

Interface implemented by an MBean that emits Notifications. It allows a listener to be registered with the MBean as a notification listener.

This interface should be used by new code in preference to the NotificationBroadcaster interface.

Since:
JMX 1.2

Method Summary
 void removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
Removes a listener from this MBean.
Methods inherited from interface javax.management.NotificationBroadcaster
addNotificationListener, getNotificationInfo, removeNotificationListener

Method Detail

removeNotificationListener

public void removeNotificationListener(NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws ListenerNotFoundException

Removes a listener from this MBean. The MBean must have a listener that exactly matches the given listener, filter, and handback parameters. If there is more than one such listener, only one is removed.

The filter and handback parameters may be null if and only if they are null in a listener to be removed.

Parameters:
listener - A listener that was previously added to this MBean.
filter - The filter that was specified when the listener was added.
handback - The handback that was specified when the listener was added.
Throws:
ListenerNotFoundException - The listener is not registered with the MBean, or it is not registered with the given filter and handback.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NotificationFilter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface NotificationFilter

All Superinterfaces:
Serializable
All Known Implementing Classes:
AttributeChangeNotificationFilter, NotificationFilterSupport
public interface NotificationFilter
extends Serializable

To be implemented by a any class acting as a notification filter. It allows a registered notification listener to filter the notifications of interest.

Method Summary
 boolean isNotificationEnabled(Notification notification)
Invoked before sending the specified notification to the listener.

Method Detail

isNotificationEnabled

public boolean isNotificationEnabled(Notification notification)
Invoked before sending the specified notification to the listener.

Parameters:
notification - The notification to be sent.
Returns:
true if the notification has to be sent to the listener, false otherwise.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NotificationFilterSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class NotificationFilterSupport

java.lang.Object
    extended by javax.management.NotificationFilterSupport
All Implemented Interfaces:
NotificationFilter, Serializable
Direct Known Subclasses:
MBeanServerNotificationFilter
public class NotificationFilterSupport
extends Object
implements NotificationFilter, Serializable

Provides an implementation of the NotificationFilter interface. The filtering is performed on the notification type attribute.

Manages a list of enabled notification types. A method allows users to enable/disable as many notification types as required.

Then, before sending a notification to a listener registered with a filter, the notification broadcaster compares this notification type with all notification types enabled by the filter. The notification will be sent to the listener only if its filter enables this notification type.

Example:

 NotificationFilterSupport myFilter = new NotificationFilterSupport();
 myFilter.enableType("my_example.my_type");
 myBroadcaster.addListener(myListener, myFilter, null);
The listener myListener will only receive notifications the type of which equals/starts with "my_example.my_type".

See Also:
NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), Serialized Form

Constructor Summary
NotificationFilterSupport()
Method Summary
void | disableAllTypes() Disables all notification types.
void | disableType(String prefix) Removes the given prefix from the prefix list.
void | enableType(String prefix) Enables all the notifications the type of which starts with the specified prefix to be sent to the listener.
Vector | getEnabledTypes() Gets all the enabled notification types for this filter.
boolean | isNotificationEnabled(Notification notification) Invoked before sending the specified notification to the listener.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NotificationFilterSupport

public NotificationFilterSupport()
Method Detail

isNotificationEnabled

public boolean isNotificationEnabled(Notification notification)
Invoked before sending the specified notification to the listener.
This filter compares the type of the specified notification with each enabled type. If the notification type matches one of the enabled types, the notification should be sent to the listener and this method returns true.

Specified by:
isNotificationEnabled in interface NotificationFilter
Parameters:
notification - The notification to be sent.
Returns:
true if the notification should be sent to the listener, false otherwise.

enableType

public void enableType(String prefix)
                throws IllegalArgumentException
Enables all the notifications the type of which starts with the specified prefix to be sent to the listener.
If the specified prefix is already in the list of enabled notification types, this method has no effect.

Example:

 // Enables all notifications the type of which starts with "my_example" to be sent.
 myFilter.enableType("my_example");
 // Enables all notifications the type of which is "my_example.my_type" to be sent.
 myFilter.enableType("my_example.my_type");
Note that:
myFilter.enableType("my_example.*");
will no match any notification type.

Parameters:
prefix - The prefix.
Throws:
IllegalArgumentException - The prefix parameter is null.

disableType

public void disableType(String prefix)
Removes the given prefix from the prefix list.
If the specified prefix is not in the list of enabled notification types, this method has no effect.

Parameters:
prefix - The prefix.

disableAllTypes

public void disableAllTypes()
Disables all notification types.

getEnabledTypes

public Vector getEnabledTypes()
Gets all the enabled notification types for this filter.

Returns:
The list containing all the enabled notification types.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NotificationListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface NotificationListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
RelationService
public interface NotificationListener
extends EventListener

Should be implemented by an object that wants to receive notifications.

Method Summary
 void handleNotification(Notification notification, Object handback)
Invoked when a JMX notification occurs.

Method Detail

handleNotification

public void handleNotification(Notification notification,
                               Object handback)
Invoked when a JMX notification occurs. The implementation of this method should return as soon as possible, to avoid blocking its notification broadcaster.

Parameters:
notification - The notification.
handback - An opaque object which helps the listener to associate information regarding the MBean emitter. This object is passed to the MBean during the addListener call and resent, without modification, to the listener. The MBean object should not use or modify the object.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ObjectInstance

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class ObjectInstance

java.lang.Object
    extended by javax.management.ObjectInstance
All Implemented Interfaces:
Serializable
public class ObjectInstance
extends Object
implements Serializable

Used to represent the object name of an MBean and its class name. If the MBean is a Dynamic MBean the class name should be retrieved from the MBeanInfo it provides.

See Also:
Serialized Form

Constructor Summary
ObjectInstance(ObjectName objectName, String className)
Allows an object instance to be created given an object name and the full class name, including the package name.
ObjectInstance(String objectName, String className)
Allows an object instance to be created given a string representation of an object name and the full class name, including the package name.
Method Summary
boolean | equals(Object object) Compares the current object instance with another object instance.
String | getClassName() Returns the class part.
ObjectName | getObjectName() Returns the object name part.
int | hashCode()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectInstance

public ObjectInstance(String objectName,
                      String className)
               throws MalformedObjectNameException
Allows an object instance to be created given a string representation of an object name and the full class name, including the package name.

Parameters:
objectName - A string representation of the object name.
className - The full class name, including the package name, of the object instance. If the MBean is a Dynamic MBean the class name corresponds to its getMBeanInfo() .getClassName().
Throws:
MalformedObjectNameException - The string passed as a parameter does not have the right format.

ObjectInstance

public ObjectInstance(ObjectName objectName,
                      String className)
Allows an object instance to be created given an object name and the full class name, including the package name.

Parameters:
objectName - The object name.
className - The full class name, including the package name, of the object instance. If the MBean is a Dynamic MBean the class name corresponds to its getMBeanInfo() .getClassName(). If the MBean is a Dynamic MBean the class name should be retrieved from the MBeanInfo it provides.
Method Detail

equals

public boolean equals(Object object)
Compares the current object instance with another object instance.

Parameters:
object - The object instance that the current object instance is to be compared with.
Returns:
True if the two object instances are equal, otherwise false.

hashCode

public int hashCode()

getObjectName

public ObjectName getObjectName()
Returns the object name part.

Returns:
the object name.

getClassName

public String getClassName()
Returns the class part.

Returns:
the class name.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ObjectName

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class ObjectName

java.lang.Object
    extended by javax.management.ObjectName
All Implemented Interfaces:
QueryExp, Serializable
public class ObjectName
extends Object
implements QueryExp, Serializable

Represents the object name of an MBean, or a pattern that can match the names of several MBeans. Instances of this class are immutable.

An instance of this class can be used to represent:

  • An object name
  • An object name pattern, within the context of a query

An object name consists of two parts, the domain and the key properties.

The domain is a string of characters not including the character colon (:).

If the domain includes at least one occurrence of the wildcard characters asterisk (*) or question mark (?), then the object name is a pattern. The asterisk matches any sequence of zero or more characters, while the question mark matches any single character.

If the domain is empty, it will be replaced in certain contexts by the default domain of the MBean server in which the ObjectName is used.

The key properties are an unordered set of keys and associated values.

Each key is a nonempty string of characters which may not contain any of the characters comma (,), equals (=), colon, asterisk, or question mark. The same key may not occur twice in a given ObjectName.

Each value associated with a key is a string of characters that is either unquoted or quoted.

An unquoted value is a possibly empty string of characters which may not contain any of the characters comma, equals, colon, quote, asterisk, or question mark.

A quoted value consists of a quote ("), followed by a possibly empty string of characters, followed by another quote. Within the string of characters, the backslash (\) has a special meaning. It must be followed by one of the following characters:

  • Another backslash. The second backslash has no special meaning and the two characters represent a single blackslash.
  • The character 'n'. The two characters represent a newline ('\n' in Java).
  • A quote. The two characters represent a quote, and that quote is not considered to terminate the quoted value. An ending closing quote must be present for the quoted value to be valid.
  • A question mark (?) or star (*). The two characters represent a question mark or star respectively.

A quote, question mark, or star may not appear inside a quoted value except immediately after an odd number of consecutive backslashes.

The quotes surrounding a quoted value, and any backslashes within that value, are considered to be part of the value.

An ObjectName may be a property pattern. In this case it may have zero or more keys and associated values. It matches a nonpattern ObjectName whose domain matches and that contains the same keys and associated values, as well as possibly other keys and values.

An ObjectName is a pattern if its domain contains a wildcard or if the ObjectName is a property pattern.

If an ObjectName is not a pattern, it must contain at least one key with its associated value.

An ObjectName can be written as a String with the following elements in order:

  • The domain.
  • A colon (:).
  • A key property list as defined below.

A key property list written as a String is a comma-separated list of elements. Each element is either an asterisk or a key property. A key property consists of a key, an equals (=), and the associated value.

At most one element of a key property list may be an asterisk. If the key property list contains an asterisk element, the ObjectName is a property pattern.

Spaces have no special significance in a String representing an ObjectName. For example, the String:

 domain: key1 = value1 , key2 = value2
represents an ObjectName with two keys. The name of each key contains six characters, of which the first and last are spaces. The value associated with the key " key1 " also begins and ends with a space.

In addition to the restrictions on characters spelt out above, no part of an ObjectName may contain a newline character ('\n'), whether the domain, a key, or a value, whether quoted or unquoted. The newline character can be represented in a quoted value with the sequence \n.

The rules on special characters and quoting apply regardless of which constructor is used to make an ObjectName.

To avoid collisions between MBeans supplied by different vendors, a useful convention is to begin the domain name with the reverse DNS name of the organization that specifies the MBeans, followed by a period and a string whose interpretation is determined by that organization. For example, MBeans specified by Sun Microsystems Inc., DNS name sun.com, would have domains such as com.sun.MyDomain. This is essentially the same convention as for Java-language package names.

See Also:
Serialized Form

Constructor Summary
ObjectName(String name)
Construct an object name from the given string.
ObjectName(String domain, Hashtable table)
Construct an object name with several key properties from a Hashtable.
ObjectName(String domain, String key, String value)
Construct an object name with exactly one key property.
Method Summary
 boolean apply(ObjectName name)
Test whether this ObjectName, which may be a pattern, matches another ObjectName.
 boolean equals(Object object)
Compares the current object name with another object name.
 String getCanonicalKeyPropertyListString()
Returns a string representation of the list of key properties, in which the key properties are sorted in lexical order.
 String getCanonicalName()
Returns the canonical form of the name; that is, a string representation where the properties are sorted in lexical order.
 String getDomain()
Returns the domain part.
static ObjectName getInstance(ObjectName name)
Return an instance of ObjectName that can be used anywhere the given object can be used.
static ObjectName getInstance(String name)
Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(name) can be used.
static ObjectName getInstance(String domain, Hashtable table)
Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, table) can be used.
static ObjectName getInstance(String domain, String key, String value)
Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, key, value) can be used.
 String getKeyProperty(String property)
Obtains the value associated with a key in a key property.
 Hashtable getKeyPropertyList()
Returns the key properties as a Hashtable.
 String getKeyPropertyListString()
Returns a string representation of the list of key properties specified at creation time.
 int hashCode()
Returns a hash code for this object name.
 boolean isDomainPattern()
Checks whether the object name is a pattern on the domain part.
 boolean isPattern()
Checks whether the object name is a pattern.
 boolean isPropertyPattern()
Checks whether the object name is a pattern on the key properties.
static String quote(String s)
Returns a quoted form of the given String, suitable for inclusion in an ObjectName.
 void setMBeanServer(MBeanServer mbs)
Sets the MBean server on which the query is to be performed.
 String toString()
Returns a string representation of the object name.
static String unquote(String q)
Returns an unquoted form of the given String.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ObjectName

public ObjectName(String name)
           throws MalformedObjectNameException,
                  NullPointerException
Construct an object name from the given string.

Parameters:
name - A string representation of the object name.
Throws:
MalformedObjectNameException - The string passed as a parameter does not have the right format.
NullPointerException - The name parameter is null.

ObjectName

public ObjectName(String domain,
                  String key,
                  String value)
           throws MalformedObjectNameException,
                  NullPointerException
Construct an object name with exactly one key property.

Parameters:
domain - The domain part of the object name.
key - The attribute in the key property of the object name.
value - The value in the key property of the object name.
Throws:
MalformedObjectNameException - The domain, key, or value contains an illegal character, or value does not follow the rules for quoting.
NullPointerException - One of the parameters is null.

ObjectName

public ObjectName(String domain,
                  Hashtable table)
           throws MalformedObjectNameException,
                  NullPointerException
Construct an object name with several key properties from a Hashtable.

Parameters:
domain - The domain part of the object name.
table - A hash table containing one or more key properties. The key of each entry in the table is the key of a key property in the object name. The associated value in the table is the associated value in the object name.
Throws:
MalformedObjectNameException - The domain contains an illegal character, or one of the keys or values in table contains an illegal character, or one of the values in table does not follow the rules for quoting.
NullPointerException - One of the parameters is null.
Method Detail

getInstance

public static ObjectName getInstance(String name)
                              throws MalformedObjectNameException,
                                     NullPointerException

Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(name) can be used. The returned object may be of a subclass of ObjectName. Calling this method twice with the same parameters may return the same object or two equal but not identical objects.

Parameters:
name - A string representation of the object name.
Returns:
an ObjectName corresponding to the given String.
Throws:
MalformedObjectNameException - The string passed as a parameter does not have the right format.
NullPointerException - The name parameter is null.
Since:
JMX 1.2

getInstance

public static ObjectName getInstance(String domain,
                                     String key,
                                     String value)
                              throws MalformedObjectNameException,
                                     NullPointerException

Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, key, value) can be used. The returned object may be of a subclass of ObjectName. Calling this method twice with the same parameters may return the same object or two equal but not identical objects.

Parameters:
domain - The domain part of the object name.
key - The attribute in the key property of the object name.
value - The value in the key property of the object name.
Returns:
an ObjectName corresponding to the given domain, key, and value.
Throws:
MalformedObjectNameException - The domain, key, or value contains an illegal character, or value does not follow the rules for quoting.
NullPointerException - One of the parameters is null.
Since:
JMX 1.2

getInstance

public static ObjectName getInstance(String domain,
                                     Hashtable table)
                              throws MalformedObjectNameException,
                                     NullPointerException

Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, table) can be used. The returned object may be of a subclass of ObjectName. Calling this method twice with the same parameters may return the same object or two equal but not identical objects.

Parameters:
domain - The domain part of the object name.
table - A hash table containing one or more key properties. The key of each entry in the table is the key of a key property in the object name. The associated value in the table is the associated value in the object name.
Returns:
an ObjectName corresponding to the given domain and key mappings.
Throws:
MalformedObjectNameException - The domain contains an illegal character, or one of the keys or values in table contains an illegal character, or one of the values in table does not follow the rules for quoting.
NullPointerException - One of the parameters is null.
Since:
JMX 1.2

getInstance

public static ObjectName getInstance(ObjectName name)
                              throws NullPointerException

Return an instance of ObjectName that can be used anywhere the given object can be used. The returned object may be of a subclass of ObjectName. If name is of a subclass of ObjectName, it is not guaranteed that the returned object will be of the same class.

The returned value may or may not be identical to name. Calling this method twice with the same parameters may return the same object or two equal but not identical objects.

Since ObjectName is immutable, it is not usually useful to make a copy of an ObjectName. The principal use of this method is to guard against a malicious caller who might pass an instance of a subclass with surprising behaviour to sensitive code. Such code can call this method to obtain an ObjectName that is known not to have surprising behaviour.

Parameters:
name - an instance of the ObjectName class or of a subclass
Returns:
an instance of ObjectName or a subclass that is known to have the same semantics. If name respects the semantics of ObjectName, then the returned object is equal (though not necessarily identical) to name.
Throws:
NullPointerException - The name is null.
Since:
JMX 1.2

isPattern

public boolean isPattern()
Checks whether the object name is a pattern. An object name is a pattern if its domain contains a wildcard or if the object name is a property pattern.

Returns:
True if the name is a pattern, otherwise false.

isDomainPattern

public boolean isDomainPattern()
Checks whether the object name is a pattern on the domain part.

Returns:
True if the name is a domain pattern, otherwise false.
Since:
JMX 1.2

isPropertyPattern

public boolean isPropertyPattern()
Checks whether the object name is a pattern on the key properties.

Returns:
True if the name is a pattern, otherwise false.

getCanonicalName

public String getCanonicalName()

Returns the canonical form of the name; that is, a string representation where the properties are sorted in lexical order.

More precisely, the canonical form of the name is a String consisting of the domain part, a colon (:), the canonical key property list, and a pattern indication.

The canonical key property list is the same string as described for getCanonicalKeyPropertyListString().

The pattern indication is:

  • empty for an ObjectName that is not a property pattern;
  • an asterisk for an ObjectName that is a property pattern with no keys; or
  • a comma and an asterisk (,*) for an ObjectName that is a property pattern with at least one key.

Returns:
The canonical form of the name.

getDomain

public String getDomain()
Returns the domain part.

Returns:
the domain.

getKeyProperty

public String getKeyProperty(String property)
                      throws NullPointerException
Obtains the value associated with a key in a key property.

Parameters:
property - The property whose value is to be obtained.
Returns:
The value of the property, or null if there is no such property in this ObjectName.
Throws:
NullPointerException - If property is null.

getKeyPropertyList

public Hashtable getKeyPropertyList()

Returns the key properties as a Hashtable. The returned value is a Hashtable in which each key is a key in the ObjectName's key property list and each value is the associated value.

The returned value may be unmodifiable. If it is modifiable, changing it has no effect on this ObjectName.

Returns:
The table of key properties.

getKeyPropertyListString

public String getKeyPropertyListString()

Returns a string representation of the list of key properties specified at creation time. If this ObjectName was constructed with the constructor ObjectName(String), the key properties in the returned String will be in the same order as in the argument to the constructor.

Returns:
The key property list string. This string is independent of whether the ObjectName is a pattern.

getCanonicalKeyPropertyListString

public String getCanonicalKeyPropertyListString()
Returns a string representation of the list of key properties, in which the key properties are sorted in lexical order. This is used in lexicographic comparisons performed in order to select MBeans based on their key property list. Lexical order is the order implied by String.compareTo(String).

Returns:
The canonical key property list string. This string is independent of whether the ObjectName is a pattern.

toString

public String toString()

Returns a string representation of the object name. The format of this string is not specified, but users can expect that two ObjectNames return the same string if and only if they are equal.

Returns:
a string representation of this object name.

equals

public boolean equals(Object object)
Compares the current object name with another object name. Two ObjectName instances are equal if and only if their canonical forms are equal. The canonical form is the string described for getCanonicalName().

Parameters:
object - The object name that the current object name is to be compared with.
Returns:
True if object is an ObjectName whose canonical form is equal to that of this ObjectName.

hashCode

public int hashCode()
Returns a hash code for this object name.

quote

public static String quote(String s)
                    throws NullPointerException

Returns a quoted form of the given String, suitable for inclusion in an ObjectName. The returned value can be used as the value associated with a key in an ObjectName. The String s may contain any character. Appropriate quoting ensures that the returned value is legal in an ObjectName.

The returned value consists of a quote ('"'), a sequence of characters corresponding to the characters of s, and another quote. Characters in s appear unchanged within the returned value except:

  • A quote ('"')is replaced by a backslash (\) followed by a quote.
  • A star ('*') is replaced by a backslash (\) followed by a star.
  • A question mark ('?') is replaced by a backslash (\) followed by a question mark.
  • A backslash ('\') is replaced by two backslashes.
  • A newline character (the character '\n' in Java) is replaced by a backslash followed by the character '\n'.

Parameters:
s - the String to be quoted.
Returns:
the quoted String.
Throws:
NullPointerException - if s is null.
Since:
JMX 1.2

unquote

public static String unquote(String q)
                      throws IllegalArgumentException,
                             NullPointerException

Returns an unquoted form of the given String. If q is a String returned by quote(s), then unquote(q).equals(s). If there is no String s for which quote(s).equals(q), then unquote(q) throws an IllegalArgumentException.

These rules imply that there is a one-to-one mapping between quoted and unquoted forms.

Parameters:
q - the String to be unquoted.
Returns:
the unquoted String.
Throws:
IllegalArgumentException - if q could not have been returned by the quote(java.lang.String) method, for instance if it does not begin and end with a quote (").
NullPointerException - if q is null.
Since:
JMX 1.2

apply

public boolean apply(ObjectName name)
              throws NullPointerException

Test whether this ObjectName, which may be a pattern, matches another ObjectName. If name is a pattern, the result is false. If this ObjectName is a pattern, the result is true if and only if name matches the pattern. If neither this ObjectName nor name is a pattern, the result is true if and only if the two ObjectNames are equal as described for the equals(Object) method.

Specified by:
apply in interface QueryExp
Parameters:
name - The name of the MBean to compare to.
Returns:
True if name matches this ObjectName.
Throws:
NullPointerException - if name is null.
Since:
JMX 1.2

setMBeanServer

public void setMBeanServer(MBeanServer mbs)
Description copied from interface: QueryExp
Sets the MBean server on which the query is to be performed.

Specified by:
setMBeanServer in interface QueryExp
Parameters:
mbs - The MBean server on which the query is to be performed.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


openmbean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management.openmbean

Provides the open data types and open mbean descriptors classes.

See:
Description

Interface Summary
CompositeData | The CompositeData interface specifies the behaviour of a specific type of complex open data objects which represent composite data structures.
OpenMBeanAttributeInfo | Describes an attribute of an open MBean.
OpenMBeanConstructorInfo | Describes a constructor of an Open MBean.
OpenMBeanInfo | Describes an Open MBean: an Open MBean is recognized as such if its getMBeanInfo() method returns an instance of a class which implements the OpenMBeanInfo interface, typically OpenMBeanInfoSupport.
OpenMBeanOperationInfo | Describes an operation of an Open MBean.
OpenMBeanParameterInfo | Describes a parameter used in one or more operations or constructors of an open MBean.
TabularData | The TabularData interface specifies the behaviour of a specific type of complex open data objects which represent tabular data structures.

Class Summary
ArrayType | The ArrayType class is the open type class whose instances describe all open data values which are n-dimensional arrays of open data values.
CompositeDataSupport | The CompositeDataSupport class is the open data class which implements the CompositeData interface.
CompositeType | The CompositeType class is the open type class whose instances describe the types of CompositeData values.
OpenMBeanAttributeInfoSupport | Describes an attribute of an open MBean.
OpenMBeanConstructorInfoSupport | Describes a constructor of an Open MBean.
OpenMBeanInfoSupport | The OpenMBeanInfoSupport class describes the management information of an open MBean: it is a subclass of MBeanInfo, and it implements the OpenMBeanInfo interface.
OpenMBeanOperationInfoSupport | Describes an operation of an Open MBean.
OpenMBeanParameterInfoSupport | Describes a parameter used in one or more operations or constructors of an open MBean.
OpenType | The OpenType class is the parent abstract class of all classes which describe the actual open type of open data values.
SimpleType | The SimpleType class is the open type class whose instances describe all open data values which are neither arrays, nor CompositeData values, nor TabularData values.
TabularDataSupport | The TabularDataSupport class is the open data class which implements the TabularData and the Map interfaces, and which is internally based on a hash map data structure.
TabularType | The TabularType class is the open type class whose instances describe the types of TabularData values.

Exception Summary
InvalidKeyException | This runtime exception is thrown to indicate that a method parameter which was expected to be an item name of a composite data or a row index of a tabular data is not valid.
InvalidOpenTypeException | This runtime exception is thrown to indicate that the open type of an open data value is not the one expected.
KeyAlreadyExistsException | This runtime exception is thrown to indicate that the index of a row to be added to a tabular data instance is already used to refer to another row in this tabular data instance.
OpenDataException | This checked exception is thrown when an open type, an open data or an open MBean metadata info instance could not be constructed because one or more validity constraints were not met.

Package javax.management.openmbean Description

Provides the open data types and open mbean descriptors classes.

Since:
JMX 1.1
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.management.openmbean Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management.openmbean

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.management.openmbean.CompositeDataSupport (implements javax.management.openmbean.CompositeData, java.io.Serializable)
    • class javax.management.MBeanFeatureInfo (implements java.io.Serializable)
      • class javax.management.MBeanAttributeInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.openmbean.OpenMBeanAttributeInfoSupport (implements javax.management.openmbean.OpenMBeanAttributeInfo, java.io.Serializable)
      • class javax.management.MBeanConstructorInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.openmbean.OpenMBeanConstructorInfoSupport (implements javax.management.openmbean.OpenMBeanConstructorInfo, java.io.Serializable)
      • class javax.management.MBeanOperationInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.openmbean.OpenMBeanOperationInfoSupport (implements javax.management.openmbean.OpenMBeanOperationInfo, java.io.Serializable)
      • class javax.management.MBeanParameterInfo (implements java.lang.Cloneable, java.io.Serializable)
        • class javax.management.openmbean.OpenMBeanParameterInfoSupport (implements javax.management.openmbean.OpenMBeanParameterInfo, java.io.Serializable)
    • class javax.management.MBeanInfo (implements java.lang.Cloneable, java.io.Serializable)
      • class javax.management.openmbean.OpenMBeanInfoSupport (implements javax.management.openmbean.OpenMBeanInfo, java.io.Serializable)
    • class javax.management.openmbean.OpenType (implements java.io.Serializable)
      • class javax.management.openmbean.ArrayType (implements java.io.Serializable)
      • class javax.management.openmbean.CompositeType (implements java.io.Serializable)
      • class javax.management.openmbean.SimpleType (implements java.io.Serializable)
      • class javax.management.openmbean.TabularType (implements java.io.Serializable)
    • class javax.management.openmbean.TabularDataSupport (implements java.lang.Cloneable, java.util.Map, java.io.Serializable, javax.management.openmbean.TabularData)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.management.JMException
          • class javax.management.openmbean.OpenDataException (implements java.io.Serializable)
        • class java.lang.RuntimeException
          • class java.lang.IllegalArgumentException
            • class javax.management.openmbean.InvalidKeyException (implements java.io.Serializable)
            • class javax.management.openmbean.InvalidOpenTypeException (implements java.io.Serializable)
            • class javax.management.openmbean.KeyAlreadyExistsException (implements java.io.Serializable)

Interface Hierarchy

  • interface javax.management.openmbean.CompositeData
  • interface javax.management.openmbean.OpenMBeanConstructorInfo
  • interface javax.management.openmbean.OpenMBeanInfo
  • interface javax.management.openmbean.OpenMBeanOperationInfo
  • interface javax.management.openmbean.OpenMBeanParameterInfo
    • interface javax.management.openmbean.OpenMBeanAttributeInfo
  • interface javax.management.openmbean.TabularData
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ArrayType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class ArrayType

java.lang.Object
    extended by javax.management.openmbean.OpenType
        extended by javax.management.openmbean.ArrayType
All Implemented Interfaces:
Serializable
public class ArrayType
extends OpenType
implements Serializable

The ArrayType class is the open type class whose instances describe all open data values which are n-dimensional arrays of open data values.

Since:
JMX 1.1
Version:
3.13 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.openmbean.OpenType
ALLOWED_CLASSNAMES
Constructor Summary
ArrayType(int dimension, OpenType elementType)
Constructs an ArrayType instance describing open data values which are arrays with dimension dimension of elements whose open type is elementType.
Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this ArrayType instance for equality.
int | getDimension() Returns the dimension of arrays described by this ArrayType instance.
OpenType | getElementOpenType() Returns the open type of element values contained in the arrays described by this ArrayType instance.
int | hashCode() Returns the hash code value for this ArrayType instance.
boolean | isValue(Object obj) Tests whether obj is a value for this ArrayType instance.
String | toString() Returns a string representation of this ArrayType instance.
Methods inherited from class javax.management.openmbean.OpenType
getClassName, getDescription, getTypeName, isArray
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ArrayType

public ArrayType(int dimension,
                 OpenType elementType)
          throws OpenDataException
Constructs an ArrayType instance describing open data values which are arrays with dimension dimension of elements whose open type is elementType.

When invoked on an ArrayType instance, the getClassName method returns the class name of the array instances it describes (following the rules defined by the getName method of java.lang.Class), not the class name of the array elements (which is returned by a call to getElementOpenType().getClassName()).

The internal field corresponding to the type name of this ArrayType instance is also set to the class name of the array instances it describes. In other words, the methods getClassName and getTypeName return the same string value. The internal field corresponding to the description of this ArrayType instance is set to a string value which follows the following template:
<dimension>-dimension array of <element_class_name>

As an example, the following piece of code:

 ArrayType t = new ArrayType(3, SimpleType.STRING);
 System.out.println("array class name       = "+ t.getClassName());
 System.out.println("element class name     = "+ t.getElementOpenType().getClassName());
 System.out.println("array type name        = "+ t.getTypeName());
 System.out.println("array type description = "+ t.getDescription());
would produce the following output:
 array class name       = [[[java.lang.String;
 element class name     = java.lang.String
 array type name        = [[[java.lang.String;
 array type description = 3-dimension array of java.lang.String

Parameters:
dimension - the dimension of arrays described by this ArrayType instance; must be greater than or equal to 1.
elementType - the open type of element values contained in the arrays described by this ArrayType instance; must be an instance of either SimpleType, CompositeType or TabularType.
Throws:
IllegalArgumentException - if dimension is not a positive integer
OpenDataException - if elementType is an instance of ArrayType
Method Detail

getDimension

public int getDimension()
Returns the dimension of arrays described by this ArrayType instance.

Returns:
the dimension.

getElementOpenType

public OpenType getElementOpenType()
Returns the open type of element values contained in the arrays described by this ArrayType instance.

Returns:
the element type.

isValue

public boolean isValue(Object obj)
Tests whether obj is a value for this ArrayType instance.

This method returns true if and only if obj is not null, obj is an array and any one of the following is true:

  • if this ArrayType instance describes an array of SimpleType elements, obj's class name is the same as the className field defined for this ArrayType instance (ie the class name returned by the getClassName method, which includes the dimension information),
  • if this ArrayType instance describes an array of classes implementing the TabularData interface or the CompositeData interface, obj is assignable to such a declared array, and each element contained in obj is either null or a valid value for the element's open type specified by this ArrayType instance.

Specified by:
isValue in class OpenType
Parameters:
obj - the object to be tested.
Returns:
true if obj is a value for this ArrayType instance.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this ArrayType instance for equality.

Two ArrayType instances are equal if and only if they describes array instances which have the same dimension and elements' open type.

Specified by:
equals in class OpenType
Parameters:
obj - the object to be compared for equality with this ArrayType instance; if obj is null or is not an instance of the class ArrayType, equals returns false.
Returns:
true if the specified object is equal to this ArrayType instance.

hashCode

public int hashCode()
Returns the hash code value for this ArrayType instance.

The hash code of a ArrayType instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: dimension and elements' type). This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two ArrayType instances t1 and t2, as required by the general contract of the method Object.hashCode .

As ArrayType instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

Specified by:
hashCode in class OpenType
Returns:
the hash code value for this ArrayType instance

toString

public String toString()
Returns a string representation of this ArrayType instance.

The string representation consists of the name of this class (ie javax.management.openmbean.ArrayType), the type name, the dimension and elements' type defined for this instance,

As ArrayType instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

Specified by:
toString in class OpenType
Returns:
a string representation of this ArrayType instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CompositeData

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Interface CompositeData

All Known Implementing Classes:
CompositeDataSupport
public interface CompositeData

The CompositeData interface specifies the behaviour of a specific type of complex open data objects which represent composite data structures.

Since:
JMX 1.1
Version:
3.7 02/10/01
Author:
Sun Microsystems, Inc.

Method Summary
boolean | containsKey(String key) Returns true if and only if this CompositeData instance contains an item whose name is key.
boolean | containsValue(Object value) Returns true if and only if this CompositeData instance contains an item whose value is value.
boolean | equals(Object obj) Compares the specified obj parameter with this CompositeData instance for equality.
Object | get(String key) Returns the value of the item whose name is key.
Object[] | getAll(String[] keys) Returns an array of the values of the items whose names are specified by keys, in the same order as keys.
CompositeType | getCompositeType() Returns the composite type of this composite data instance.
int | hashCode() Returns the hash code value for this CompositeData instance.
String | toString() Returns a string representation of this CompositeData instance.
Collection | values() Returns an unmodifiable Collection view of the item values contained in this CompositeData instance.

Method Detail

getCompositeType

public CompositeType getCompositeType()
Returns the composite type of this composite data instance.

Returns:
the type of this CompositeData.

get

public Object get(String key)
Returns the value of the item whose name is key.

Parameters:
key - the name of the item.
Returns:
the value associated with this key.
Throws:
IllegalArgumentException - if key is a null or empty String.
InvalidKeyException - if key is not an existing item name for this CompositeData instance.

getAll

public Object[] getAll(String[] keys)
Returns an array of the values of the items whose names are specified by keys, in the same order as keys.

Parameters:
keys - the names of the items.
Returns:
the values corresponding to the keys.
Throws:
IllegalArgumentException - if an element in keys is a null or empty String.
InvalidKeyException - if an element in keys is not an existing item name for this CompositeData instance.

containsKey

public boolean containsKey(String key)
Returns true if and only if this CompositeData instance contains an item whose name is key. If key is a null or empty String, this method simply returns false.

Parameters:
key - the key to be tested.
Returns:
true if this CompositeData contains the key.

containsValue

public boolean containsValue(Object value)
Returns true if and only if this CompositeData instance contains an item whose value is value.

Parameters:
value - the value to be tested.
Returns:
true if this CompositeData contains the value.

values

public Collection values()
Returns an unmodifiable Collection view of the item values contained in this CompositeData instance. The returned collection's iterator will return the values in the ascending lexicographic order of the corresponding item names.

Returns:
the values.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this CompositeData instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the CompositeData interface,
  • their composite types are equal
  • their contents (ie item values) are equal.
This ensures that this equals method works properly for obj parameters which are different implementations of the CompositeData interface.

Parameters:
obj - the object to be compared for equality with this CompositeData instance;
Returns:
true if the specified object is equal to this CompositeData instance.

hashCode

public int hashCode()
Returns the hash code value for this CompositeData instance.

The hash code of a CompositeData instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its composite type and all the item values).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two CompositeData instances t1 and t2, as required by the general contract of the method Object.hashCode .

Returns:
the hash code value for this CompositeData instance

toString

public String toString()
Returns a string representation of this CompositeData instance.

The string representation consists of the name of the implementing class, the string representation of the composite type of this instance, and the string representation of the contents (ie list the itemName=itemValue mappings).

Returns:
a string representation of this CompositeData instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CompositeDataSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class CompositeDataSupport

java.lang.Object
    extended by javax.management.openmbean.CompositeDataSupport
All Implemented Interfaces:
CompositeData, Serializable
public class CompositeDataSupport
extends Object
implements CompositeData, Serializable

The CompositeDataSupport class is the open data class which implements the CompositeData interface.

Since:
JMX 1.1
Version:
3.15 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Constructor Summary
CompositeDataSupport(CompositeType compositeType, Map items)
Constructs a CompositeDataSupport instance with the specified compositeType, whose item names and corresponding values are given by the mappings in the map items.
CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
Constructs a CompositeDataSupport instance with the specified compositeType, whose item values are specified by itemValues[], in the same order as in itemNames[].
Method Summary
boolean | containsKey(String key) Returns true if and only if this CompositeData instance contains an item whose name is key.
boolean | containsValue(Object value) Returns true if and only if this CompositeData instance contains an item whose value is value.
boolean | equals(Object obj) Compares the specified obj parameter with this CompositeDataSupport instance for equality.
Object | get(String key) Returns the value of the item whose name is key.
Object[] | getAll(String[] keys) Returns an array of the values of the items whose names are specified by keys, in the same order as keys.
CompositeType | getCompositeType() Returns the composite type of this composite data instance.
int | hashCode() Returns the hash code value for this CompositeDataSupport instance.
String | toString() Returns a string representation of this CompositeDataSupport instance.
Collection | values() Returns an unmodifiable Collection view of the item values contained in this CompositeData instance.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CompositeDataSupport

public CompositeDataSupport(CompositeType compositeType,
                            String[] itemNames,
                            Object[] itemValues)
                     throws OpenDataException

Constructs a CompositeDataSupport instance with the specified compositeType, whose item values are specified by itemValues[], in the same order as in itemNames[]. As a CompositeType does not specify any order on its items, the itemNames[] parameter is used to specify the order in which the values are given in itemValues[]. The items contained in this CompositeDataSupport instance are internally stored in a TreeMap, thus sorted in ascending lexicographic order of their names, for faster retrieval of individual item values.

The constructor checks that all the constraints listed below for each parameter are satisfied, and throws the appropriate exception if they are not.

Parameters:
compositeType - the composite type of this composite data instance; must not be null.

itemNames - itemNames must list, in any order, all the item names defined in compositeType; the order in which the names are listed, is used to match values in itemValues[]; must not be null or empty.

itemValues - the values of the items, listed in the same order as their respective names in itemNames; each item value can be null, but if it is non-null it must be a valid value for the open type defined in compositeType for the corresponding item; must be of the same size as itemNames; must not be null or empty.

Throws:
IllegalArgumentException - compositeType is null, or itemNames[] or itemValues[] is null or empty, or one of the elements in itemNames[] is a null or empty string, or itemNames[] and itemValues[] are not of the same size.

OpenDataException - itemNames[] or itemValues[]'s size differs from the number of items defined in compositeType, or one of the elements in itemNames[] does not exist as an item name defined in compositeType, or one of the elements in itemValues[] is not a valid value for the corresponding item as defined in compositeType.

CompositeDataSupport

public CompositeDataSupport(CompositeType compositeType,
                            Map items)
                     throws OpenDataException

Constructs a CompositeDataSupport instance with the specified compositeType, whose item names and corresponding values are given by the mappings in the map items. This constructor converts the keys to a string array and the values to an object array and calls CompositeDataSupport(javax.management.openmbean.CompositeType, java.lang.String[], java.lang.Object[]).

Parameters:
compositeType - the composite type of this composite data instance; must not be null.

items - the mappings of all the item names to their values; items must contain all the item names defined in compositeType; must not be null or empty.

Throws:
IllegalArgumentException - compositeType is null, or items is null or empty, or one of the keys in items is a null or empty string, or one of the values in items is null.

OpenDataException - items' size differs from the number of items defined in compositeType, or one of the keys in items does not exist as an item name defined in compositeType, or one of the values in items is not a valid value for the corresponding item as defined in compositeType.

ArrayStoreException - one or more keys in items is not of the class java.lang.String.

Method Detail

getCompositeType

public CompositeType getCompositeType()
Returns the composite type of this composite data instance.

Specified by:
getCompositeType in interface CompositeData
Returns:
the type of this CompositeData.

get

public Object get(String key)
Returns the value of the item whose name is key.

Specified by:
get in interface CompositeData
Parameters:
key - the name of the item.
Returns:
the value associated with this key.
Throws:
IllegalArgumentException - if key is a null or empty String.
InvalidKeyException - if key is not an existing item name for this CompositeData instance.

getAll

public Object[] getAll(String[] keys)
Returns an array of the values of the items whose names are specified by keys, in the same order as keys.

Specified by:
getAll in interface CompositeData
Parameters:
keys - the names of the items.
Returns:
the values corresponding to the keys.
Throws:
IllegalArgumentException - if an element in keys is a null or empty String.
InvalidKeyException - if an element in keys is not an existing item name for this CompositeData instance.

containsKey

public boolean containsKey(String key)
Returns true if and only if this CompositeData instance contains an item whose name is key. If key is a null or empty String, this method simply returns false.

Specified by:
containsKey in interface CompositeData
Parameters:
key - the key to be tested.
Returns:
true if this CompositeData contains the key.

containsValue

public boolean containsValue(Object value)
Returns true if and only if this CompositeData instance contains an item whose value is value.

Specified by:
containsValue in interface CompositeData
Parameters:
value - the value to be tested.
Returns:
true if this CompositeData contains the value.

values

public Collection values()
Returns an unmodifiable Collection view of the item values contained in this CompositeData instance. The returned collection's iterator will return the values in the ascending lexicographic order of the corresponding item names.

Specified by:
values in interface CompositeData
Returns:
the values.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this CompositeDataSupport instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the CompositeData interface,
  • their composite types are equal
  • their contents, i.e. (name, value) pairs are equal.
This ensures that this equals method works properly for obj parameters which are different implementations of the CompositeData interface, with the restrictions mentioned in the equals method of the java.util.Collection interface.

Specified by:
equals in interface CompositeData
Parameters:
obj - the object to be compared for equality with this CompositeDataSupport instance;
Returns:
true if the specified object is equal to this CompositeDataSupport instance.

hashCode

public int hashCode()
Returns the hash code value for this CompositeDataSupport instance.

The hash code of a CompositeDataSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its composite type and all the item values).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two CompositeDataSupport instances t1 and t2, as required by the general contract of the method Object.hashCode .

However, note that another instance of a class implementing the CompositeData interface may be equal to this CompositeDataSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

Specified by:
hashCode in interface CompositeData
Returns:
the hash code value for this CompositeDataSupport instance

toString

public String toString()
Returns a string representation of this CompositeDataSupport instance.

The string representation consists of the name of this class (ie javax.management.openmbean.CompositeDataSupport), the string representation of the composite type of this instance, and the string representation of the contents (ie list the itemName=itemValue mappings).

Specified by:
toString in interface CompositeData
Returns:
a string representation of this CompositeDataSupport instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CompositeType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class CompositeType

java.lang.Object
    extended by javax.management.openmbean.OpenType
        extended by javax.management.openmbean.CompositeType
All Implemented Interfaces:
Serializable
public class CompositeType
extends OpenType
implements Serializable

The CompositeType class is the open type class whose instances describe the types of CompositeData values.

Since:
JMX 1.1
Version:
3.14 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.openmbean.OpenType
ALLOWED_CLASSNAMES
Constructor Summary
CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType[] itemTypes)
Constructs a CompositeType instance, checking for the validity of the given parameters.
Method Summary
boolean | containsKey(String itemName) Returns true if this CompositeType instance defines an item whose name is itemName.
boolean | equals(Object obj) Compares the specified obj parameter with this CompositeType instance for equality.
String | getDescription(String itemName) Returns the description of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.
OpenType | getType(String itemName) Returns the open type of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.
int | hashCode() Returns the hash code value for this CompositeType instance.
boolean | isValue(Object obj) Tests whether obj is a value which could be described by this CompositeType instance.
Set | keySet() Returns an unmodifiable Set view of all the item names defined by this CompositeType instance.
String | toString() Returns a string representation of this CompositeType instance.
Methods inherited from class javax.management.openmbean.OpenType
getClassName, getDescription, getTypeName, isArray
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CompositeType

public CompositeType(String typeName,
                     String description,
                     String[] itemNames,
                     String[] itemDescriptions,
                     OpenType[] itemTypes)
              throws OpenDataException
Constructs a CompositeType instance, checking for the validity of the given parameters. The validity constraints are described below for each parameter.

Note that the contents of the three array parameters itemNames, itemDescriptions and itemTypes are internally copied so that any subsequent modification of these arrays by the caller of this constructor has no impact on the constructed CompositeType instance.

The Java class name of composite data values this composite type represents (ie the class name returned by the getClassName method) is set to the string value returned by CompositeData.class.getName().

Parameters:
typeName - The name given to the composite type this instance represents; cannot be a null or empty string.
description - The human readable description of the composite type this instance represents; cannot be a null or empty string.
itemNames - The names of the items contained in the composite data values described by this CompositeType instance; cannot be null and should contain at least one element; no element can be a null or empty string. Note that the order in which the item names are given is not important to differentiate a CompositeType instance from another; the item names are internally stored sorted in ascending alphanumeric order.
itemDescriptions - The descriptions, in the same order as itemNames, of the items contained in the composite data values described by this CompositeType instance; should be of the same size as itemNames; no element can be a null or empty string.
itemTypes - The open type instances, in the same order as itemNames, describing the items contained in the composite data values described by this CompositeType instance; should be of the same size as itemNames; no element can be null.
Throws:
IllegalArgumentException - If typeName or description is a null or empty string, or itemNames or itemDescriptions or itemTypes is null, or any element of itemNames or itemDescriptions is a null or empty string, or any element of itemTypes is null, or itemNames or itemDescriptions or itemTypes are not of the same size.
OpenDataException - If itemNames contains duplicate item names (case sensitive, but leading and trailing whitespaces removed).
Method Detail

containsKey

public boolean containsKey(String itemName)
Returns true if this CompositeType instance defines an item whose name is itemName.

Parameters:
itemName - the name of the item.
Returns:
true if an item of this name is present.

getDescription

public String getDescription(String itemName)
Returns the description of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.

Parameters:
itemName - the name of the item.
Returns:
the description.

getType

public OpenType getType(String itemName)
Returns the open type of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.

Parameters:
itemName - the name of the time.
Returns:
the type.

keySet

public Set keySet()
Returns an unmodifiable Set view of all the item names defined by this CompositeType instance. The set's iterator will return the item names in ascending order.

Returns:
a Set of String.

isValue

public boolean isValue(Object obj)
Tests whether obj is a value which could be described by this CompositeType instance.

If obj is null or is not an instance of javax.management.openmbean.CompositeData, isValue returns false. If obj is an instance of javax.management.openmbean.CompositeData, its composite type is tested for equality with this CompositeType instance, and isValue returns true if and only if equals returns true.

Specified by:
isValue in class OpenType
Parameters:
obj - the value whose open type is to be tested for equality with this CompositeType instance.
Returns:
true if obj is a value for this composite type, false otherwise.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this CompositeType instance for equality.

Two CompositeType instances are equal if and only if all of the following statements are true:

  • their type names are equal
  • their items' names and types are equal

Specified by:
equals in class OpenType
Parameters:
obj - the object to be compared for equality with this CompositeType instance; if obj is null, equals returns false.
Returns:
true if the specified object is equal to this CompositeType instance.

hashCode

public int hashCode()
Returns the hash code value for this CompositeType instance.

The hash code of a CompositeType instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: name, items names, items types). This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two CompositeType instances t1 and t2, as required by the general contract of the method Object.hashCode .

As CompositeType instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

Specified by:
hashCode in class OpenType
Returns:
the hash code value for this CompositeType instance

toString

public String toString()
Returns a string representation of this CompositeType instance.

The string representation consists of the name of this class (ie javax.management.openmbean.CompositeType), the type name for this instance, and the list of the items names and types string representation of this instance.

As CompositeType instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

Specified by:
toString in class OpenType
Returns:
a string representation of this CompositeType instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidKeyException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class InvalidKeyException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by java.lang.IllegalArgumentException
                    extended by javax.management.openmbean.InvalidKeyException
All Implemented Interfaces:
Serializable
public class InvalidKeyException
extends IllegalArgumentException
implements Serializable

This runtime exception is thrown to indicate that a method parameter which was expected to be an item name of a composite data or a row index of a tabular data is not valid.

Since:
JMX 1.1
Version:
3.7 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Constructor Summary
InvalidKeyException()
An InvalidKeyException with no detail message.
InvalidKeyException(String msg)
An InvalidKeyException with a detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidKeyException

public InvalidKeyException()
An InvalidKeyException with no detail message.

InvalidKeyException

public InvalidKeyException(String msg)
An InvalidKeyException with a detail message.

Parameters:
msg - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidOpenTypeException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class InvalidOpenTypeException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by java.lang.IllegalArgumentException
                    extended by javax.management.openmbean.InvalidOpenTypeException
All Implemented Interfaces:
Serializable
public class InvalidOpenTypeException
extends IllegalArgumentException
implements Serializable

This runtime exception is thrown to indicate that the open type of an open data value is not the one expected.

Since:
JMX 1.1
Version:
3.7 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Constructor Summary
InvalidOpenTypeException()
An InvalidOpenTypeException with no detail message.
InvalidOpenTypeException(String msg)
An InvalidOpenTypeException with a detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidOpenTypeException

public InvalidOpenTypeException()
An InvalidOpenTypeException with no detail message.

InvalidOpenTypeException

public InvalidOpenTypeException(String msg)
An InvalidOpenTypeException with a detail message.

Parameters:
msg - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


KeyAlreadyExistsException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class KeyAlreadyExistsException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by java.lang.IllegalArgumentException
                    extended by javax.management.openmbean.KeyAlreadyExistsException
All Implemented Interfaces:
Serializable
public class KeyAlreadyExistsException
extends IllegalArgumentException
implements Serializable

This runtime exception is thrown to indicate that the index of a row to be added to a tabular data instance is already used to refer to another row in this tabular data instance.

Since:
JMX 1.1
Version:
3.7 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Constructor Summary
KeyAlreadyExistsException()
A KeyAlreadyExistsException with no detail message.
KeyAlreadyExistsException(String msg)
A KeyAlreadyExistsException with a detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

KeyAlreadyExistsException

public KeyAlreadyExistsException()
A KeyAlreadyExistsException with no detail message.

KeyAlreadyExistsException

public KeyAlreadyExistsException(String msg)
A KeyAlreadyExistsException with a detail message.

Parameters:
msg - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenDataException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class OpenDataException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.openmbean.OpenDataException
All Implemented Interfaces:
Serializable
public class OpenDataException
extends JMException
implements Serializable

This checked exception is thrown when an open type, an open data or an open MBean metadata info instance could not be constructed because one or more validity constraints were not met.

Since:
JMX 1.1
Version:
3.7 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Constructor Summary
OpenDataException()
An OpenDataException with no detail message.
OpenDataException(String msg)
An OpenDataException with a detail message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OpenDataException

public OpenDataException()
An OpenDataException with no detail message.

OpenDataException

public OpenDataException(String msg)
An OpenDataException with a detail message.

Parameters:
msg - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenMBeanAttributeInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Interface OpenMBeanAttributeInfo

All Superinterfaces:
OpenMBeanParameterInfo
All Known Implementing Classes:
OpenMBeanAttributeInfoSupport
public interface OpenMBeanAttributeInfo
extends OpenMBeanParameterInfo

Describes an attribute of an open MBean.

This interface declares the same methods as the class MBeanAttributeInfo. A class implementing this interface (typically OpenMBeanAttributeInfoSupport) should extend MBeanAttributeInfo.

Since:
JMX 1.1
Version:
3.9 02/10/03
Author:
Sun Microsystems, Inc.

Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this OpenMBeanAttributeInfo instance for equality.
int | hashCode() Returns the hash code value for this OpenMBeanAttributeInfo instance.
boolean | isIs() Returns true if the attribute described by this OpenMBeanAttributeInfo instance is accessed through a isXXX getter (applies only to boolean and Boolean values), false otherwise.
boolean | isReadable() Returns true if the attribute described by this OpenMBeanAttributeInfo instance is readable, false otherwise.
boolean | isWritable() Returns true if the attribute described by this OpenMBeanAttributeInfo instance is writable, false otherwise.
String | toString() Returns a string representation of this OpenMBeanAttributeInfo instance.
Methods inherited from interface javax.management.openmbean.OpenMBeanParameterInfo
getDefaultValue, getDescription, getLegalValues, getMaxValue, getMinValue, getName, getOpenType, hasDefaultValue, hasLegalValues, hasMaxValue, hasMinValue, isValue

Method Detail

isReadable

public boolean isReadable()
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is readable, false otherwise.

Returns:
true if the attribute is readable.

isWritable

public boolean isWritable()
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is writable, false otherwise.

Returns:
true if the attribute is writable.

isIs

public boolean isIs()
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is accessed through a isXXX getter (applies only to boolean and Boolean values), false otherwise.

Returns:
true if the attribute is accessed through isXXX.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this OpenMBeanAttributeInfo instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the OpenMBeanAttributeInfo interface,
  • their names are equal
  • their open types are equal
  • their access properties (isReadable, isWritable and isIs) are equal
  • their default, min, max and legal values are equal.
This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanAttributeInfo interface.

Specified by:
equals in interface OpenMBeanParameterInfo
Parameters:
obj - the object to be compared for equality with this OpenMBeanAttributeInfo instance;
Returns:
true if the specified object is equal to this OpenMBeanAttributeInfo instance.

hashCode

public int hashCode()
Returns the hash code value for this OpenMBeanAttributeInfo instance.

The hash code of an OpenMBeanAttributeInfo instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, its open type, and its default, min, max and legal values).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanAttributeInfo instances t1 and t2, as required by the general contract of the method Object.hashCode .

Specified by:
hashCode in interface OpenMBeanParameterInfo
Returns:
the hash code value for this OpenMBeanAttributeInfo instance

toString

public String toString()
Returns a string representation of this OpenMBeanAttributeInfo instance.

The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanAttributeInfo), the string representation of the name and open type of the described attribute, and the string representation of its default, min, max and legal values.

Specified by:
toString in interface OpenMBeanParameterInfo
Returns:
a string representation of this OpenMBeanAttributeInfo instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenMBeanAttributeInfoSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class OpenMBeanAttributeInfoSupport

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanAttributeInfo
            extended by javax.management.openmbean.OpenMBeanAttributeInfoSupport
All Implemented Interfaces:
Cloneable, OpenMBeanAttributeInfo, OpenMBeanParameterInfo, Serializable
public class OpenMBeanAttributeInfoSupport
extends MBeanAttributeInfo
implements OpenMBeanAttributeInfo, Serializable

Describes an attribute of an open MBean.

Since:
JMX 1.1
Version:
3.17 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
OpenMBeanAttributeInfoSupport(String name, String description, OpenType openType, boolean isReadable, boolean isWritable, boolean isIs)
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType and description, and the specified read/write access properties.
OpenMBeanAttributeInfoSupport(String name, String description, OpenType openType, boolean isReadable, boolean isWritable, boolean isIs, Object defaultValue)
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, description and defaultValue, and the specified read/write access properties.
OpenMBeanAttributeInfoSupport(String name, String description, OpenType openType, boolean isReadable, boolean isWritable, boolean isIs, Object defaultValue, Comparable minValue, Comparable maxValue)
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description, defaultValue, minValue and maxValue.
OpenMBeanAttributeInfoSupport(String name, String description, OpenType openType, boolean isReadable, boolean isWritable, boolean isIs, Object defaultValue, Object[] legalValues)
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, description, defaultValue and legalValues, and the specified read/write access properties.
Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this OpenMBeanAttributeInfoSupport instance for equality.
Object | getDefaultValue() Returns the default value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
Set | getLegalValues() Returns an unmodifiable Set of legal values for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
Comparable | getMaxValue() Returns the maximal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
Comparable | getMinValue() Returns the minimal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.
OpenType | getOpenType() Returns the open type for the values of the attribute described by this OpenMBeanAttributeInfoSupport instance.
boolean | hasDefaultValue() Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null default value for the described attribute, false otherwise.
int | hashCode() Returns the hash code value for this OpenMBeanAttributeInfoSupport instance.
boolean | hasLegalValues() Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null set of legal values for the described attribute, false otherwise.
boolean | hasMaxValue() Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null maximal value for the described attribute, false otherwise.
boolean | hasMinValue() Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null minimal value for the described attribute, false otherwise.
boolean | isValue(Object obj) Tests whether obj is a valid value for the attribute described by this OpenMBeanAttributeInfoSupport instance.
String | toString() Returns a string representation of this OpenMBeanAttributeInfoSupport instance.
Methods inherited from class javax.management.MBeanAttributeInfo
clone, getType, isIs, isReadable, isWritable
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface javax.management.openmbean.OpenMBeanAttributeInfo
isIs, isReadable, isWritable
Methods inherited from interface javax.management.openmbean.OpenMBeanParameterInfo
getDescription, getName

Constructor Detail

OpenMBeanAttributeInfoSupport

public OpenMBeanAttributeInfoSupport(String name,
                                     String description,
                                     OpenType openType,
                                     boolean isReadable,
                                     boolean isWritable,
                                     boolean isIs)
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType and description, and the specified read/write access properties.

Parameters:
name - cannot be a null or empty string.
description - cannot be a null or empty string.
openType - cannot be null.
isReadable - true if the attribute has a getter exposed for management.
isWritable - true if the attribute has a setter exposed for management.
isIs - true if the attribute's getter is of the form isXXX.
Throws:
IllegalArgumentException - if name or description are null or empty string, or openType is null.

OpenMBeanAttributeInfoSupport

public OpenMBeanAttributeInfoSupport(String name,
                                     String description,
                                     OpenType openType,
                                     boolean isReadable,
                                     boolean isWritable,
                                     boolean isIs,
                                     Object defaultValue)
                              throws OpenDataException
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, description and defaultValue, and the specified read/write access properties.

Parameters:
name - cannot be a null or empty string.
description - cannot be a null or empty string.
openType - cannot be null.
isReadable - true if the attribute has a getter exposed for management.
isWritable - true if the attribute has a setter exposed for management.
isIs - true if the attribute's getter is of the form isXXX.
defaultValue - must be a valid value for the openType specified for this attribute; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
Throws:
IllegalArgumentException - if name or description are null or empty string, or openType is null.
OpenDataException - if defaultValue is not a valid value for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType.

OpenMBeanAttributeInfoSupport

public OpenMBeanAttributeInfoSupport(String name,
                                     String description,
                                     OpenType openType,
                                     boolean isReadable,
                                     boolean isWritable,
                                     boolean isIs,
                                     Object defaultValue,
                                     Object[] legalValues)
                              throws OpenDataException
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, description, defaultValue and legalValues, and the specified read/write access properties. The contents of legalValues are internally dumped into an unmodifiable Set, so subsequent modifications of the array referenced by legalValues have no impact on this OpenMBeanAttributeInfoSupport instance.

Parameters:
name - cannot be a null or empty string.
description - cannot be a null or empty string.
openType - cannot be null.
isReadable - true if the attribute has a getter exposed for management.
isWritable - true if the attribute has a setter exposed for management.
isIs - true if the attribute's getter is of the form isXXX.
defaultValue - must be a valid value for the openType specified for this attribute; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
legalValues - each contained value must be valid for the openType specified for this attribute; legal values not supported for ArrayType and TabularType; can be null or empty.
Throws:
IllegalArgumentException - if name or description are null or empty string, or openType is null.
OpenDataException - if defaultValue is not a valid value for the specified openType, or one value in legalValues is not valid for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType, or legalValues is non null and non empty and openType is an ArrayType or a TabularType, or legalValues is non null and non empty and defaultValue is not contained in legalValues.

OpenMBeanAttributeInfoSupport

public OpenMBeanAttributeInfoSupport(String name,
                                     String description,
                                     OpenType openType,
                                     boolean isReadable,
                                     boolean isWritable,
                                     boolean isIs,
                                     Object defaultValue,
                                     Comparable minValue,
                                     Comparable maxValue)
                              throws OpenDataException
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description, defaultValue, minValue and maxValue. It is possible to specify minimal and maximal values only for an open type whose values are Comparable.

Parameters:
name - cannot be a null or empty string.
description - cannot be a null or empty string.
openType - cannot be null.
isReadable - true if the attribute has a getter exposed for management.
isWritable - true if the attribute has a setter exposed for management.
isIs - true if the attribute's getter is of the form isXXX.
defaultValue - must be a valid value for the openType specified for this attribute; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
minValue - must be valid for the openType specified for this attribute; can be null, in which case it means that no minimal value is set.
maxValue - must be valid for the openType specified for this attribute; can be null, in which case it means that no maximal value is set.
Throws:
IllegalArgumentException - if name or description are null or empty string, or openType is null.
OpenDataException - if defaultValue, minValue or maxValue is not a valid value for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType, or both minValue and maxValue are non-null and minValue.compareTo(maxValue) > 0 is true, or both defaultValue and minValue are non-null and minValue.compareTo(defaultValue) > 0 is true, or both defaultValue and maxValue are non-null and defaultValue.compareTo(maxValue) > 0 is true.
Method Detail

getOpenType

public OpenType getOpenType()
Returns the open type for the values of the attribute described by this OpenMBeanAttributeInfoSupport instance.

Specified by:
getOpenType in interface OpenMBeanParameterInfo
Returns:
the open type.

getDefaultValue

public Object getDefaultValue()
Returns the default value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

Specified by:
getDefaultValue in interface OpenMBeanParameterInfo
Returns:
the default value.

getLegalValues

public Set getLegalValues()
Returns an unmodifiable Set of legal values for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

Specified by:
getLegalValues in interface OpenMBeanParameterInfo
Returns:
the set of legal values.

getMinValue

public Comparable getMinValue()
Returns the minimal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

Specified by:
getMinValue in interface OpenMBeanParameterInfo
Returns:
the minimum value.

getMaxValue

public Comparable getMaxValue()
Returns the maximal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

Specified by:
getMaxValue in interface OpenMBeanParameterInfo
Returns:
the maximum value.

hasDefaultValue

public boolean hasDefaultValue()
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null default value for the described attribute, false otherwise.

Specified by:
hasDefaultValue in interface OpenMBeanParameterInfo
Returns:
true if there is a default value.

hasLegalValues

public boolean hasLegalValues()
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null set of legal values for the described attribute, false otherwise.

Specified by:
hasLegalValues in interface OpenMBeanParameterInfo
Returns:
true if there is a set of legal values.

hasMinValue

public boolean hasMinValue()
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null minimal value for the described attribute, false otherwise.

Specified by:
hasMinValue in interface OpenMBeanParameterInfo
Returns:
true if there is a minimum value.

hasMaxValue

public boolean hasMaxValue()
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null maximal value for the described attribute, false otherwise.

Specified by:
hasMaxValue in interface OpenMBeanParameterInfo
Returns:
true if there is a maximum value.

isValue

public boolean isValue(Object obj)
Tests whether obj is a valid value for the attribute described by this OpenMBeanAttributeInfoSupport instance.

Specified by:
isValue in interface OpenMBeanParameterInfo
Parameters:
obj - the object to be tested.
Returns:
true if obj is a valid value for for the parameter described by this OpenMBeanAttributeInfoSupport instance, false otherwise.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this OpenMBeanAttributeInfoSupport instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the OpenMBeanAttributeInfo interface,
  • their names are equal
  • their open types are equal
  • their access properties (isReadable, isWritable and isIs) are equal
  • their default, min, max and legal values are equal.
This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanAttributeInfo interface.

Specified by:
equals in interface OpenMBeanAttributeInfo
Overrides:
equals in class MBeanAttributeInfo
Parameters:
obj - the object to be compared for equality with this OpenMBeanAttributeInfoSupport instance;
Returns:
true if the specified object is equal to this OpenMBeanAttributeInfoSupport instance.

hashCode

public int hashCode()
Returns the hash code value for this OpenMBeanAttributeInfoSupport instance.

The hash code of an OpenMBeanAttributeInfoSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, its open type, and its default, min, max and legal values).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanAttributeInfoSupport instances t1 and t2, as required by the general contract of the method Object.hashCode .

However, note that another instance of a class implementing the OpenMBeanAttributeInfo interface may be equal to this OpenMBeanAttributeInfoSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

As OpenMBeanAttributeInfoSupport instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

Specified by:
hashCode in interface OpenMBeanAttributeInfo
Overrides:
hashCode in class MBeanAttributeInfo
Returns:
the hash code value for this OpenMBeanAttributeInfoSupport instance

toString

public String toString()
Returns a string representation of this OpenMBeanAttributeInfoSupport instance.

The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanAttributeInfoSupport), the string representation of the name and open type of the described parameter, and the string representation of its default, min, max and legal values.

As OpenMBeanAttributeInfoSupport instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

Specified by:
toString in interface OpenMBeanAttributeInfo
Returns:
a string representation of this OpenMBeanAttributeInfoSupport instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenMBeanConstructorInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Interface OpenMBeanConstructorInfo

All Known Implementing Classes:
OpenMBeanConstructorInfoSupport
public interface OpenMBeanConstructorInfo

Describes a constructor of an Open MBean.

This interface declares the same methods as the class MBeanConstructorInfo. A class implementing this interface (typically OpenMBeanConstructorInfoSupport) should extend MBeanConstructorInfo.

The getSignature() method should return at runtime an array of instances of a subclass of MBeanParameterInfo which implements the OpenMBeanParameterInfo interface (typically OpenMBeanParameterInfoSupport).

Since:
JMX 1.1
Version:
3.8 02/10/03
Author:
Sun Microsystems, Inc.

Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this OpenMBeanConstructorInfo instance for equality.
String | getDescription() Returns a human readable description of the constructor described by this OpenMBeanConstructorInfo instance.
String | getName() Returns the name of the constructor described by this OpenMBeanConstructorInfo instance.
MBeanParameterInfo[] | getSignature() Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the constructor described by this OpenMBeanConstructorInfo instance.
int | hashCode() Returns the hash code value for this OpenMBeanConstructorInfo instance.
String | toString() Returns a string representation of this OpenMBeanConstructorInfo instance.

Method Detail

getDescription

public String getDescription()
Returns a human readable description of the constructor described by this OpenMBeanConstructorInfo instance.

Returns:
the description.

getName

public String getName()
Returns the name of the constructor described by this OpenMBeanConstructorInfo instance.

Returns:
the name.

getSignature

public MBeanParameterInfo[] getSignature()
Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the constructor described by this OpenMBeanConstructorInfo instance.

Returns:
the signature.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this OpenMBeanConstructorInfo instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the OpenMBeanConstructorInfo interface,
  • their names are equal
  • their signatures are equal.
This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanConstructorInfo interface.

Parameters:
obj - the object to be compared for equality with this OpenMBeanConstructorInfo instance;
Returns:
true if the specified object is equal to this OpenMBeanConstructorInfo instance.

hashCode

public int hashCode()
Returns the hash code value for this OpenMBeanConstructorInfo instance.

The hash code of an OpenMBeanConstructorInfo instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name and signature, where the signature hashCode is calculated by a call to java.util.Arrays.asList(this.getSignature).hashCode()).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanConstructorInfo instances t1 and t2, as required by the general contract of the method Object.hashCode .

Returns:
the hash code value for this OpenMBeanConstructorInfo instance

toString

public String toString()
Returns a string representation of this OpenMBeanConstructorInfo instance.

The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanConstructorInfo), and the name and signature of the described constructor.

Returns:
a string representation of this OpenMBeanConstructorInfo instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenMBeanConstructorInfoSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class OpenMBeanConstructorInfoSupport

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanConstructorInfo
            extended by javax.management.openmbean.OpenMBeanConstructorInfoSupport
All Implemented Interfaces:
Cloneable, OpenMBeanConstructorInfo, Serializable
public class OpenMBeanConstructorInfoSupport
extends MBeanConstructorInfo
implements OpenMBeanConstructorInfo, Serializable

Describes a constructor of an Open MBean.

Since:
JMX 1.1
Version:
3.11 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature)
Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, description and signature.
Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this OpenMBeanConstructorInfoSupport instance for equality.
int | hashCode() Returns the hash code value for this OpenMBeanConstructorInfoSupport instance.
String | toString() Returns a string representation of this OpenMBeanConstructorInfoSupport instance.
Methods inherited from class javax.management.MBeanConstructorInfo
clone, getSignature
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface javax.management.openmbean.OpenMBeanConstructorInfo
getDescription, getName, getSignature

Constructor Detail

OpenMBeanConstructorInfoSupport

public OpenMBeanConstructorInfoSupport(String name,
                                       String description,
                                       OpenMBeanParameterInfo[] signature)
Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, description and signature.

The signature array parameter is internally copied, so that subsequent changes to the array referenced by signature have no effect on this instance.

Parameters:
name - cannot be a null or empty string.
description - cannot be a null or empty string.
signature - can be null or empty if there are no parameters to describe.
Throws:
IllegalArgumentException - if name or description are null or empty string.
ArrayStoreException - If signature is not an array of instances of a subclass of MBeanParameterInfo.
Method Detail

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this OpenMBeanConstructorInfoSupport instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the OpenMBeanConstructorInfo interface,
  • their names are equal
  • their signatures are equal.
This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanConstructorInfo interface.

Specified by:
equals in interface OpenMBeanConstructorInfo
Overrides:
equals in class MBeanConstructorInfo
Parameters:
obj - the object to be compared for equality with this OpenMBeanConstructorInfoSupport instance;
Returns:
true if the specified object is equal to this OpenMBeanConstructorInfoSupport instance.

hashCode

public int hashCode()
Returns the hash code value for this OpenMBeanConstructorInfoSupport instance.

The hash code of an OpenMBeanConstructorInfoSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name and signature, where the signature hashCode is calculated by a call to java.util.Arrays.asList(this.getSignature).hashCode()).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanConstructorInfoSupport instances t1 and t2, as required by the general contract of the method Object.hashCode .

However, note that another instance of a class implementing the OpenMBeanConstructorInfo interface may be equal to this OpenMBeanConstructorInfoSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

As OpenMBeanConstructorInfoSupport instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

Specified by:
hashCode in interface OpenMBeanConstructorInfo
Overrides:
hashCode in class MBeanConstructorInfo
Returns:
the hash code value for this OpenMBeanConstructorInfoSupport instance

toString

public String toString()
Returns a string representation of this OpenMBeanConstructorInfoSupport instance.

The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanConstructorInfoSupport), and of the name and signature of the described constructor.

As OpenMBeanConstructorInfoSupport instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

Specified by:
toString in interface OpenMBeanConstructorInfo
Returns:
a string representation of this OpenMBeanConstructorInfoSupport instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenMBeanInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Interface OpenMBeanInfo

All Known Implementing Classes:
OpenMBeanInfoSupport
public interface OpenMBeanInfo

Describes an Open MBean: an Open MBean is recognized as such if its getMBeanInfo() method returns an instance of a class which implements the OpenMBeanInfo interface, typically OpenMBeanInfoSupport.

This interface declares the same methods as the class MBeanInfo. A class implementing this interface (typically OpenMBeanInfoSupport) should extend MBeanInfo.

The getAttributes(), getOperations() and getConstructors() methods of the implementing class should return at runtime an array of instances of a subclass of MBeanAttributeInfo, MBeanOperationInfo or MBeanConstructorInfo respectively which implement the OpenMBeanAttributeInfo, OpenMBeanOperationInfo or OpenMBeanConstructorInfo interface respectively.

Since:
JMX 1.1
Version:
3.11 02/10/01
Author:
Sun Microsystems, Inc.

Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this OpenMBeanInfo instance for equality.
MBeanAttributeInfo[] | getAttributes() Returns an array of OpenMBeanAttributeInfo instances describing each attribute in the open MBean described by this OpenMBeanInfo instance.
String | getClassName() Returns the fully qualified Java class name of the open MBean instances this OpenMBeanInfo describes.
MBeanConstructorInfo[] | getConstructors() Returns an array of OpenMBeanConstructorInfo instances describing each constructor in the open MBean described by this OpenMBeanInfo instance.
String | getDescription() Returns a human readable description of the type of open MBean instances this OpenMBeanInfo describes.
MBeanNotificationInfo[] | getNotifications() Returns an array of MBeanNotificationInfo instances describing each notification emitted by the open MBean described by this OpenMBeanInfo instance.
MBeanOperationInfo[] | getOperations() Returns an array of OpenMBeanOperationInfo instances describing each operation in the open MBean described by this OpenMBeanInfo instance.
int | hashCode() Returns the hash code value for this OpenMBeanInfo instance.
String | toString() Returns a string representation of this OpenMBeanInfo instance.

Method Detail

getClassName

public String getClassName()
Returns the fully qualified Java class name of the open MBean instances this OpenMBeanInfo describes.

Returns:
the class name.

getDescription

public String getDescription()
Returns a human readable description of the type of open MBean instances this OpenMBeanInfo describes.

Returns:
the description.

getAttributes

public MBeanAttributeInfo[] getAttributes()
Returns an array of OpenMBeanAttributeInfo instances describing each attribute in the open MBean described by this OpenMBeanInfo instance. Each instance in the returned array should actually be a subclass of MBeanAttributeInfo which implements the OpenMBeanAttributeInfo interface (typically OpenMBeanAttributeInfoSupport).

Returns:
the attribute array.

getOperations

public MBeanOperationInfo[] getOperations()
Returns an array of OpenMBeanOperationInfo instances describing each operation in the open MBean described by this OpenMBeanInfo instance. Each instance in the returned array should actually be a subclass of MBeanOperationInfo which implements the OpenMBeanOperationInfo interface (typically OpenMBeanOperationInfoSupport).

Returns:
the operation array.

getConstructors

public MBeanConstructorInfo[] getConstructors()
Returns an array of OpenMBeanConstructorInfo instances describing each constructor in the open MBean described by this OpenMBeanInfo instance. Each instance in the returned array should actually be a subclass of MBeanConstructorInfo which implements the OpenMBeanConstructorInfo interface (typically OpenMBeanConstructorInfoSupport).

Returns:
the constructor array.

getNotifications

public MBeanNotificationInfo[] getNotifications()
Returns an array of MBeanNotificationInfo instances describing each notification emitted by the open MBean described by this OpenMBeanInfo instance.

Returns:
the notification array.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this OpenMBeanInfo instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the OpenMBeanInfo interface,
  • their class names are equal
  • their infos on attributes, constructors, operations and notifications are equal
This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanInfo interface.

Parameters:
obj - the object to be compared for equality with this OpenMBeanInfo instance;
Returns:
true if the specified object is equal to this OpenMBeanInfo instance.

hashCode

public int hashCode()
Returns the hash code value for this OpenMBeanInfo instance.

The hash code of an OpenMBeanInfo instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its class name, and its infos on attributes, constructors, operations and notifications, where the hashCode of each of these arrays is calculated by a call to new java.util.HashSet(java.util.Arrays.asList(this.getSignature)).hashCode()).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanInfo instances t1 and t2, as required by the general contract of the method Object.hashCode .

Returns:
the hash code value for this OpenMBeanInfo instance

toString

public String toString()
Returns a string representation of this OpenMBeanInfo instance.

The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanInfo), the MBean class name, and the string representation of infos on attributes, constructors, operations and notifications of the described MBean.

Returns:
a string representation of this OpenMBeanInfo instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenMBeanInfoSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class OpenMBeanInfoSupport

java.lang.Object
    extended by javax.management.MBeanInfo
        extended by javax.management.openmbean.OpenMBeanInfoSupport
All Implemented Interfaces:
Cloneable, OpenMBeanInfo, Serializable
public class OpenMBeanInfoSupport
extends MBeanInfo
implements OpenMBeanInfo, Serializable

The OpenMBeanInfoSupport class describes the management information of an open MBean: it is a subclass of MBeanInfo, and it implements the OpenMBeanInfo interface. Note that an open MBean is recognized as such if its getMBeanInfo() method returns an instance of a class which implements the OpenMBeanInfo interface, typically OpenMBeanInfoSupport.

Since:
JMX 1.1
Version:
3.11 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Constructor Summary
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, description, openAttributes, openConstructors , openOperations and notifications.
Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this OpenMBeanInfoSupport instance for equality.
int | hashCode() Returns the hash code value for this OpenMBeanInfoSupport instance.
String | toString() Returns a string representation of this OpenMBeanInfoSupport instance.
Methods inherited from class javax.management.MBeanInfo
clone, getAttributes, getClassName, getConstructors, getDescription, getNotifications, getOperations
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface javax.management.openmbean.OpenMBeanInfo
getAttributes, getClassName, getConstructors, getDescription, getNotifications, getOperations

Constructor Detail

OpenMBeanInfoSupport

public OpenMBeanInfoSupport(String className,
                            String description,
                            OpenMBeanAttributeInfo[] openAttributes,
                            OpenMBeanConstructorInfo[] openConstructors,
                            OpenMBeanOperationInfo[] openOperations,
                            MBeanNotificationInfo[] notifications)
Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, description, openAttributes, openConstructors , openOperations and notifications.

The openAttributes, openConstructors, openOperations and notifications array parameters are internally copied, so that subsequent changes to the arrays referenced by these parameters have no effect on this instance.

Parameters:
className - The fully qualified Java class name of the open MBean described by this OpenMBeanInfoSupport instance.
description - A human readable description of the open MBean described by this OpenMBeanInfoSupport instance.
openAttributes - The list of exposed attributes of the described open MBean; Must be an array of instances of a subclass of MBeanAttributeInfo, typically OpenMBeanAttributeInfoSupport.
openConstructors - The list of exposed public constructors of the described open MBean; Must be an array of instances of a subclass of MBeanConstructorInfo, typically OpenMBeanConstructorInfoSupport.
openOperations - The list of exposed operations of the described open MBean. Must be an array of instances of a subclass of MBeanOperationInfo, typically OpenMBeanOperationInfoSupport.
notifications - The list of notifications emitted by the described open MBean.
Throws:
ArrayStoreException - If openAttributes, openConstructors or openOperations is not an array of instances of a subclass of MBeanAttributeInfo, MBeanConstructorInfo or MBeanOperationInfo respectively.
Method Detail

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this OpenMBeanInfoSupport instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the OpenMBeanInfo interface,
  • their class names are equal
  • their infos on attributes, constructors, operations and notifications are equal
This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanInfo interface.

Specified by:
equals in interface OpenMBeanInfo
Overrides:
equals in class MBeanInfo
Parameters:
obj - the object to be compared for equality with this OpenMBeanInfoSupport instance;
Returns:
true if the specified object is equal to this OpenMBeanInfoSupport instance.

hashCode

public int hashCode()
Returns the hash code value for this OpenMBeanInfoSupport instance.

The hash code of an OpenMBeanInfoSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its class name, and its infos on attributes, constructors, operations and notifications, where the hashCode of each of these arrays is calculated by a call to new java.util.HashSet(java.util.Arrays.asList(this.getSignature)).hashCode()).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanInfoSupport instances t1 and t2, as required by the general contract of the method Object.hashCode .

However, note that another instance of a class implementing the OpenMBeanInfo interface may be equal to this OpenMBeanInfoSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

As OpenMBeanInfoSupport instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

Specified by:
hashCode in interface OpenMBeanInfo
Overrides:
hashCode in class MBeanInfo
Returns:
the hash code value for this OpenMBeanInfoSupport instance

toString

public String toString()
Returns a string representation of this OpenMBeanInfoSupport instance.

The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanInfoSupport), the MBean class name, and the string representation of infos on attributes, constructors, operations and notifications of the described MBean.

As OpenMBeanInfoSupport instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

Specified by:
toString in interface OpenMBeanInfo
Returns:
a string representation of this OpenMBeanInfoSupport instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenMBeanOperationInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Interface OpenMBeanOperationInfo

All Known Implementing Classes:
OpenMBeanOperationInfoSupport
public interface OpenMBeanOperationInfo

Describes an operation of an Open MBean.

This interface declares the same methods as the class MBeanOperationInfo. A class implementing this interface (typically OpenMBeanOperationInfoSupport) should extend MBeanOperationInfo.

The getSignature() method should return at runtime an array of instances of a subclass of MBeanParameterInfo which implements the OpenMBeanParameterInfo interface (typically OpenMBeanParameterInfoSupport).

Since:
JMX 1.1
Version:
3.9 02/10/03
Author:
Sun Microsystems, Inc.

Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this OpenMBeanOperationInfo instance for equality.
String | getDescription() Returns a human readable description of the operation described by this OpenMBeanOperationInfo instance.
int | getImpact() Returns an int constant qualifying the impact of the operation described by this OpenMBeanOperationInfo instance.
String | getName() Returns the name of the operation described by this OpenMBeanOperationInfo instance.
OpenType | getReturnOpenType() Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.
String | getReturnType() Returns the fully qualified Java class name of the values returned by the operation described by this OpenMBeanOperationInfo instance.
MBeanParameterInfo[] | getSignature() Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the operation described by this OpenMBeanOperationInfo instance.
int | hashCode() Returns the hash code value for this OpenMBeanOperationInfo instance.
String | toString() Returns a string representation of this OpenMBeanOperationInfo instance.

Method Detail

getDescription

public String getDescription()
Returns a human readable description of the operation described by this OpenMBeanOperationInfo instance.

Returns:
the description.

getName

public String getName()
Returns the name of the operation described by this OpenMBeanOperationInfo instance.

Returns:
the name.

getSignature

public MBeanParameterInfo[] getSignature()
Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the operation described by this OpenMBeanOperationInfo instance. Each instance in the returned array should actually be a subclass of MBeanParameterInfo which implements the OpenMBeanParameterInfo interface (typically OpenMBeanParameterInfoSupport).

Returns:
the signature.

getImpact

public int getImpact()
Returns an int constant qualifying the impact of the operation described by this OpenMBeanOperationInfo instance. The returned constant is one of MBeanOperationInfo.INFO, MBeanOperationInfo.ACTION or MBeanOperationInfo.ACTION_INFO.

Returns:
the impact code.

getReturnType

public String getReturnType()
Returns the fully qualified Java class name of the values returned by the operation described by this OpenMBeanOperationInfo instance. This method should return the same value as a call to getReturnOpenType().getClassName().

Returns:
the return type.

getReturnOpenType

public OpenType getReturnOpenType()
Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.

Returns:
the return type.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this OpenMBeanOperationInfo instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the OpenMBeanOperationInfo interface,
  • their names are equal
  • their signatures are equal
  • their return open types are equal
  • their impacts are equal
This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanOperationInfo interface.

Parameters:
obj - the object to be compared for equality with this OpenMBeanOperationInfo instance;
Returns:
true if the specified object is equal to this OpenMBeanOperationInfo instance.

hashCode

public int hashCode()
Returns the hash code value for this OpenMBeanOperationInfo instance.

The hash code of an OpenMBeanOperationInfo instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, return open type, impact and signature, where the signature hashCode is calculated by a call to java.util.Arrays.asList(this.getSignature).hashCode()).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanOperationInfo instances t1 and t2, as required by the general contract of the method Object.hashCode .

Returns:
the hash code value for this OpenMBeanOperationInfo instance

toString

public String toString()
Returns a string representation of this OpenMBeanOperationInfo instance.

The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanOperationInfo), and the name, signature, return open type and impact of the described operation.

Returns:
a string representation of this OpenMBeanOperationInfo instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenMBeanOperationInfoSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class OpenMBeanOperationInfoSupport

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanOperationInfo
            extended by javax.management.openmbean.OpenMBeanOperationInfoSupport
All Implemented Interfaces:
Cloneable, OpenMBeanOperationInfo, Serializable
public class OpenMBeanOperationInfoSupport
extends MBeanOperationInfo
implements OpenMBeanOperationInfo, Serializable

Describes an operation of an Open MBean.

Since:
JMX 1.1
Version:
3.14 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanOperationInfo
ACTION, ACTION_INFO, INFO, UNKNOWN
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType returnOpenType, int impact)
Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, description, signature, returnOpenType and impact.
Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this OpenMBeanOperationInfoSupport instance for equality.
OpenType | getReturnOpenType() Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.
int | hashCode() Returns the hash code value for this OpenMBeanOperationInfoSupport instance.
String | toString() Returns a string representation of this OpenMBeanOperationInfoSupport instance.
Methods inherited from class javax.management.MBeanOperationInfo
clone, getImpact, getReturnType, getSignature
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface javax.management.openmbean.OpenMBeanOperationInfo
getDescription, getImpact, getName, getReturnType, getSignature

Constructor Detail

OpenMBeanOperationInfoSupport

public OpenMBeanOperationInfoSupport(String name,
                                     String description,
                                     OpenMBeanParameterInfo[] signature,
                                     OpenType returnOpenType,
                                     int impact)
Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, description, signature, returnOpenType and impact.

The signature array parameter is internally copied, so that subsequent changes to the array referenced by signature have no effect on this instance.

Parameters:
name - cannot be a null or empty string.
description - cannot be a null or empty string.
signature - can be null or empty if there are no parameters to describe.
returnOpenType - cannot be null: use SimpleType.VOID for operations that return nothing.
impact - can be only one of ACTION, ACTION_INFO or INFO.
Throws:
IllegalArgumentException - if name or description are null or empty string, or returnOpenType is null, or impact is not one of ACTION, ACTION_INFO or INFO.
ArrayStoreException - If signature is not an array of instances of a subclass of MBeanParameterInfo.
Method Detail

getReturnOpenType

public OpenType getReturnOpenType()
Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.

Specified by:
getReturnOpenType in interface OpenMBeanOperationInfo
Returns:
the return type.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this OpenMBeanOperationInfoSupport instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the OpenMBeanOperationInfo interface,
  • their names are equal
  • their signatures are equal
  • their return open types are equal
  • their impacts are equal
This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanOperationInfo interface.

Specified by:
equals in interface OpenMBeanOperationInfo
Overrides:
equals in class MBeanOperationInfo
Parameters:
obj - the object to be compared for equality with this OpenMBeanOperationInfoSupport instance;
Returns:
true if the specified object is equal to this OpenMBeanOperationInfoSupport instance.

hashCode

public int hashCode()
Returns the hash code value for this OpenMBeanOperationInfoSupport instance.

The hash code of an OpenMBeanOperationInfoSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, return open type, impact and signature, where the signature hashCode is calculated by a call to java.util.Arrays.asList(this.getSignature).hashCode()).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanOperationInfoSupport instances t1 and t2, as required by the general contract of the method Object.hashCode .

However, note that another instance of a class implementing the OpenMBeanOperationInfo interface may be equal to this OpenMBeanOperationInfoSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

As OpenMBeanOperationInfoSupport instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

Specified by:
hashCode in interface OpenMBeanOperationInfo
Overrides:
hashCode in class MBeanOperationInfo
Returns:
the hash code value for this OpenMBeanOperationInfoSupport instance

toString

public String toString()
Returns a string representation of this OpenMBeanOperationInfoSupport instance.

The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanOperationInfoSupport), and the name, signature, return open type and impact of the described operation.

As OpenMBeanOperationInfoSupport instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

Specified by:
toString in interface OpenMBeanOperationInfo
Returns:
a string representation of this OpenMBeanOperationInfoSupport instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenMBeanParameterInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Interface OpenMBeanParameterInfo

All Known Subinterfaces:
OpenMBeanAttributeInfo
All Known Implementing Classes:
OpenMBeanAttributeInfoSupport, OpenMBeanParameterInfoSupport
public interface OpenMBeanParameterInfo

Describes a parameter used in one or more operations or constructors of an open MBean.

This interface declares the same methods as the class MBeanParameterInfo. A class implementing this interface (typically OpenMBeanParameterInfoSupport) should extend MBeanParameterInfo.

Since:
JMX 1.1
Version:
3.10 02/10/03
Author:
Sun Microsystems, Inc.

Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this OpenMBeanParameterInfo instance for equality.
Object | getDefaultValue() Returns the default value for this parameter, if it has one, or null otherwise.
String | getDescription() Returns a human readable description of the parameter described by this OpenMBeanParameterInfo instance.
Set | getLegalValues() Returns the set of legal values for this parameter, if it has one, or null otherwise.
Comparable | getMaxValue() Returns the maximal value for this parameter, if it has one, or null otherwise.
Comparable | getMinValue() Returns the minimal value for this parameter, if it has one, or null otherwise.
String | getName() Returns the name of the parameter described by this OpenMBeanParameterInfo instance.
OpenType | getOpenType() Returns the open type of the values of the parameter described by this OpenMBeanParameterInfo instance.
boolean | hasDefaultValue() Returns true if this parameter has a specified default value, or false otherwise.
int | hashCode() Returns the hash code value for this OpenMBeanParameterInfo instance.
boolean | hasLegalValues() Returns true if this parameter has a specified set of legal values, or false otherwise.
boolean | hasMaxValue() Returns true if this parameter has a specified maximal value, or false otherwise.
boolean | hasMinValue() Returns true if this parameter has a specified minimal value, or false otherwise.
boolean | isValue(Object obj) Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
String | toString() Returns a string representation of this OpenMBeanParameterInfo instance.

Method Detail

getDescription

public String getDescription()
Returns a human readable description of the parameter described by this OpenMBeanParameterInfo instance.

Returns:
the description.

getName

public String getName()
Returns the name of the parameter described by this OpenMBeanParameterInfo instance.

Returns:
the name.

getOpenType

public OpenType getOpenType()
Returns the open type of the values of the parameter described by this OpenMBeanParameterInfo instance.

Returns:
the open type.

getDefaultValue

public Object getDefaultValue()
Returns the default value for this parameter, if it has one, or null otherwise.

Returns:
the default value.

getLegalValues

public Set getLegalValues()
Returns the set of legal values for this parameter, if it has one, or null otherwise.

Returns:
the set of legal values.

getMinValue

public Comparable getMinValue()
Returns the minimal value for this parameter, if it has one, or null otherwise.

Returns:
the minimum value.

getMaxValue

public Comparable getMaxValue()
Returns the maximal value for this parameter, if it has one, or null otherwise.

Returns:
the maximum value.

hasDefaultValue

public boolean hasDefaultValue()
Returns true if this parameter has a specified default value, or false otherwise.

Returns:
true if there is a default value.

hasLegalValues

public boolean hasLegalValues()
Returns true if this parameter has a specified set of legal values, or false otherwise.

Returns:
true if there is a set of legal values.

hasMinValue

public boolean hasMinValue()
Returns true if this parameter has a specified minimal value, or false otherwise.

Returns:
true if there is a minimum value.

hasMaxValue

public boolean hasMaxValue()
Returns true if this parameter has a specified maximal value, or false otherwise.

Returns:
true if there is a maximum value.

isValue

public boolean isValue(Object obj)
Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.

Parameters:
obj - the object to be tested.
Returns:
true if obj is a valid value for for the parameter described by this OpenMBeanParameterInfo instance, false otherwise.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this OpenMBeanParameterInfo instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the OpenMBeanParameterInfo interface,
  • their names are equal
  • their open types are equal
  • their default, min, max and legal values are equal.
This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanParameterInfo interface.

Parameters:
obj - the object to be compared for equality with this OpenMBeanParameterInfo instance;
Returns:
true if the specified object is equal to this OpenMBeanParameterInfo instance.

hashCode

public int hashCode()
Returns the hash code value for this OpenMBeanParameterInfo instance.

The hash code of an OpenMBeanParameterInfo instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, its open type, and its default, min, max and legal values).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanParameterInfo instances t1 and t2, as required by the general contract of the method Object.hashCode .

Returns:
the hash code value for this OpenMBeanParameterInfo instance

toString

public String toString()
Returns a string representation of this OpenMBeanParameterInfo instance.

The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanParameterInfo), the string representation of the name and open type of the described parameter, and the string representation of its default, min, max and legal values.

Returns:
a string representation of this OpenMBeanParameterInfo instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenMBeanParameterInfoSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class OpenMBeanParameterInfoSupport

java.lang.Object
    extended by javax.management.MBeanFeatureInfo
        extended by javax.management.MBeanParameterInfo
            extended by javax.management.openmbean.OpenMBeanParameterInfoSupport
All Implemented Interfaces:
Cloneable, OpenMBeanParameterInfo, Serializable
public class OpenMBeanParameterInfoSupport
extends MBeanParameterInfo
implements OpenMBeanParameterInfo, Serializable

Describes a parameter used in one or more operations or constructors of an open MBean.

Since:
JMX 1.1
Version:
3.17 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.MBeanFeatureInfo
description, name
Constructor Summary
OpenMBeanParameterInfoSupport(String name, String description, OpenType openType)
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType and description.
OpenMBeanParameterInfoSupport(String name, String description, OpenType openType, Object defaultValue)
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description and defaultValue.
OpenMBeanParameterInfoSupport(String name, String description, OpenType openType, Object defaultValue, Comparable minValue, Comparable maxValue)
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description, defaultValue, minValue and maxValue.
OpenMBeanParameterInfoSupport(String name, String description, OpenType openType, Object defaultValue, Object[] legalValues)
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description, defaultValue and legalValues.
Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this OpenMBeanParameterInfoSupport instance for equality.
Object | getDefaultValue() Returns the default value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
Set | getLegalValues() Returns an unmodifiable Set of legal values for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
Comparable | getMaxValue() Returns the maximal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
Comparable | getMinValue() Returns the minimal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.
OpenType | getOpenType() Returns the open type for the values of the parameter described by this OpenMBeanParameterInfoSupport instance.
boolean | hasDefaultValue() Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null default value for the described parameter, false otherwise.
int | hashCode() Returns the hash code value for this OpenMBeanParameterInfoSupport instance.
boolean | hasLegalValues() Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null set of legal values for the described parameter, false otherwise.
boolean | hasMaxValue() Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null maximal value for the described parameter, false otherwise.
boolean | hasMinValue() Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null minimal value for the described parameter, false otherwise.
boolean | isValue(Object obj) Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
String | toString() Returns a string representation of this OpenMBeanParameterInfoSupport instance.
Methods inherited from class javax.management.MBeanParameterInfo
clone, getType
Methods inherited from class javax.management.MBeanFeatureInfo
getDescription, getName
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface javax.management.openmbean.OpenMBeanParameterInfo
getDescription, getName

Constructor Detail

OpenMBeanParameterInfoSupport

public OpenMBeanParameterInfoSupport(String name,
                                     String description,
                                     OpenType openType)
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType and description.

Parameters:
name - cannot be a null or empty string.
description - cannot be a null or empty string.
openType - cannot be null.
Throws:
IllegalArgumentException - if name or description are null or empty string, or openType is null.

OpenMBeanParameterInfoSupport

public OpenMBeanParameterInfoSupport(String name,
                                     String description,
                                     OpenType openType,
                                     Object defaultValue)
                              throws OpenDataException
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description and defaultValue.

Parameters:
name - cannot be a null or empty string.
description - cannot be a null or empty string.
openType - cannot be null.
defaultValue - must be a valid value for the openType specified for this parameter; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
Throws:
IllegalArgumentException - if name or description are null or empty string, or openType is null.
OpenDataException - if defaultValue is not a valid value for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType.

OpenMBeanParameterInfoSupport

public OpenMBeanParameterInfoSupport(String name,
                                     String description,
                                     OpenType openType,
                                     Object defaultValue,
                                     Object[] legalValues)
                              throws OpenDataException
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description, defaultValue and legalValues. The contents of legalValues are internally dumped into an unmodifiable Set, so subsequent modifications of the array referenced by legalValues have no impact on this OpenMBeanParameterInfoSupport instance.

Parameters:
name - cannot be a null or empty string.
description - cannot be a null or empty string.
openType - cannot be null.
defaultValue - must be a valid value for the openType specified for this parameter; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
legalValues - each contained value must be valid for the openType specified for this parameter; legal values not supported for ArrayType and TabularType; can be null or empty.
Throws:
IllegalArgumentException - if name or description are null or empty string, or openType is null.
OpenDataException - if defaultValue is not a valid value for the specified openType, or one value in legalValues is not valid for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType, or legalValues is non null and non empty and openType is an ArrayType or a TabularType, or legalValues is non null and non empty and defaultValue is not contained in legalValues.

OpenMBeanParameterInfoSupport

public OpenMBeanParameterInfoSupport(String name,
                                     String description,
                                     OpenType openType,
                                     Object defaultValue,
                                     Comparable minValue,
                                     Comparable maxValue)
                              throws OpenDataException
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description, defaultValue, minValue and maxValue. It is possible to specify minimal and maximal values only for an open type whose values are Comparable.

Parameters:
name - cannot be a null or empty string.
description - cannot be a null or empty string.
openType - cannot be null.
defaultValue - must be a valid value for the openType specified for this parameter; default value not supported for ArrayType and TabularType; can be null, in which case it means that no default value is set.
minValue - must be valid for the openType specified for this parameter; can be null, in which case it means that no minimal value is set.
maxValue - must be valid for the openType specified for this parameter; can be null, in which case it means that no maximal value is set.
Throws:
IllegalArgumentException - if name or description are null or empty string, or openType is null.
OpenDataException - if defaultValue, minValue or maxValue is not a valid value for the specified openType, or defaultValue is non null and openType is an ArrayType or a TabularType, or both minValue and maxValue are non-null and minValue.compareTo(maxValue) > 0 is true, or both defaultValue and minValue are non-null and minValue.compareTo(defaultValue) > 0 is true, or both defaultValue and maxValue are non-null and defaultValue.compareTo(maxValue) > 0 is true.
Method Detail

getOpenType

public OpenType getOpenType()
Returns the open type for the values of the parameter described by this OpenMBeanParameterInfoSupport instance.

Specified by:
getOpenType in interface OpenMBeanParameterInfo
Returns:
the open type.

getDefaultValue

public Object getDefaultValue()
Returns the default value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

Specified by:
getDefaultValue in interface OpenMBeanParameterInfo
Returns:
the default value.

getLegalValues

public Set getLegalValues()
Returns an unmodifiable Set of legal values for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

Specified by:
getLegalValues in interface OpenMBeanParameterInfo
Returns:
the set of legal values.

getMinValue

public Comparable getMinValue()
Returns the minimal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

Specified by:
getMinValue in interface OpenMBeanParameterInfo
Returns:
the minimum value.

getMaxValue

public Comparable getMaxValue()
Returns the maximal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

Specified by:
getMaxValue in interface OpenMBeanParameterInfo
Returns:
the maximum value.

hasDefaultValue

public boolean hasDefaultValue()
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null default value for the described parameter, false otherwise.

Specified by:
hasDefaultValue in interface OpenMBeanParameterInfo
Returns:
true if there is a default value.

hasLegalValues

public boolean hasLegalValues()
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null set of legal values for the described parameter, false otherwise.

Specified by:
hasLegalValues in interface OpenMBeanParameterInfo
Returns:
true if there is a set of legal values.

hasMinValue

public boolean hasMinValue()
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null minimal value for the described parameter, false otherwise.

Specified by:
hasMinValue in interface OpenMBeanParameterInfo
Returns:
true if there is a minimum value.

hasMaxValue

public boolean hasMaxValue()
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null maximal value for the described parameter, false otherwise.

Specified by:
hasMaxValue in interface OpenMBeanParameterInfo
Returns:
true if there is a maximum value.

isValue

public boolean isValue(Object obj)
Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.

Specified by:
isValue in interface OpenMBeanParameterInfo
Parameters:
obj - the object to be tested.
Returns:
true if obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance, false otherwise.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this OpenMBeanParameterInfoSupport instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the OpenMBeanParameterInfo interface,
  • their names are equal
  • their open types are equal
  • their default, min, max and legal values are equal.
This ensures that this equals method works properly for obj parameters which are different implementations of the OpenMBeanParameterInfo interface.

Specified by:
equals in interface OpenMBeanParameterInfo
Overrides:
equals in class MBeanParameterInfo
Parameters:
obj - the object to be compared for equality with this OpenMBeanParameterInfoSupport instance;
Returns:
true if the specified object is equal to this OpenMBeanParameterInfoSupport instance.

hashCode

public int hashCode()
Returns the hash code value for this OpenMBeanParameterInfoSupport instance.

The hash code of an OpenMBeanParameterInfoSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its name, its open type, and its default, min, max and legal values).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two OpenMBeanParameterInfoSupport instances t1 and t2, as required by the general contract of the method Object.hashCode .

However, note that another instance of a class implementing the OpenMBeanParameterInfo interface may be equal to this OpenMBeanParameterInfoSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

As OpenMBeanParameterInfoSupport instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

Specified by:
hashCode in interface OpenMBeanParameterInfo
Overrides:
hashCode in class MBeanParameterInfo
Returns:
the hash code value for this OpenMBeanParameterInfoSupport instance

toString

public String toString()
Returns a string representation of this OpenMBeanParameterInfoSupport instance.

The string representation consists of the name of this class (ie javax.management.openmbean.OpenMBeanParameterInfoSupport), the string representation of the name and open type of the described parameter, and the string representation of its default, min, max and legal values.

As OpenMBeanParameterInfoSupport instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

Specified by:
toString in interface OpenMBeanParameterInfo
Returns:
a string representation of this OpenMBeanParameterInfoSupport instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OpenType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class OpenType

java.lang.Object
    extended by javax.management.openmbean.OpenType
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ArrayType, CompositeType, SimpleType, TabularType
public abstract class OpenType
extends Object
implements Serializable

The OpenType class is the parent abstract class of all classes which describe the actual open type of open data values.

An open type is defined by:

  • the fully qualified Java class name of the open data values this type describes; note that only a limited set of Java classes is allowed for open data values (see ALLOWED_CLASSNAMES),
  • its name,
  • its description.

Since:
JMX 1.1
Version:
3.16 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Field Summary
static String[] ALLOWED_CLASSNAMES
List of the fully qualified names of the Java classes allowed for open data values.
Constructor Summary
protected OpenType(String className, String typeName, String description)
Constructs an OpenType instance (actually a subclass instance as OpenType is abstract), checking for the validity of the given parameters.
Method Summary
abstract boolean | equals(Object obj) Compares the specified obj parameter with this open type instance for equality.
String | getClassName() Returns the fully qualified Java class name of the open data values this open type describes.
String | getDescription() Returns the text description of this OpenType instance.
String | getTypeName() Returns the name of this OpenType instance.
abstract int | hashCode()
boolean | isArray() Returns true if the open data values this open type describes are arrays, false otherwise.
abstract boolean | isValue(Object obj) Tests whether obj is a value for this open type.
abstract String | toString() Returns a string representation of this open type instance.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

ALLOWED_CLASSNAMES

public static final String[] ALLOWED_CLASSNAMES
List of the fully qualified names of the Java classes allowed for open data values. A multidimensional array of any one of these classes is also an allowed for open data values.
ALLOWED_CLASSNAMES = {
        "java.lang.Void",
        "java.lang.Boolean",
        "java.lang.Character",
        "java.lang.Byte",
        "java.lang.Short",
        "java.lang.Integer",
        "java.lang.Long",
        "java.lang.Float",
        "java.lang.Double",
        "java.lang.String",
        "java.math.BigDecimal",
        "java.math.BigInteger",
        "java.util.Date",
        "javax.management.ObjectName",
        CompositeData.class.getName(),
        TabularData.class.getName() } ;

Constructor Detail

OpenType

protected OpenType(String className,
                   String typeName,
                   String description)
            throws OpenDataException
Constructs an OpenType instance (actually a subclass instance as OpenType is abstract), checking for the validity of the given parameters. The validity constraints are described below for each parameter.

Parameters:
className - The fully qualified Java class name of the open data values this open type describes. The valid Java class names allowed for open data values are listed in ALLOWED_CLASSNAMES. A multidimensional array of any one of these classes is also an allowed class, in which case the class name follows the rules defined by the method getName of java.lang.Class. For example, a 3-dimensional array of Strings has for class name "[[[Ljava.lang.String;" (without the quotes).
typeName - The name given to the open type this instance represents; cannot be a null or empty string.
description - The human readable description of the open type this instance represents; cannot be a null or empty string.
Throws:
IllegalArgumentException - if className, typeName or description is a null or empty string
OpenDataException - if className is not one of the allowed Java class names for open data
Method Detail

getClassName

public String getClassName()
Returns the fully qualified Java class name of the open data values this open type describes. The only possible Java class names for open data values are listed in ALLOWED_CLASSNAMES. A multidimensional array of any one of these classes is also an allowed class, in which case the class name follows the rules defined by the method getName of java.lang.Class. For example, a 3-dimensional array of Strings has for class name "[[[Ljava.lang.String;" (without the quotes).

Returns:
the class name.

getTypeName

public String getTypeName()
Returns the name of this OpenType instance.

Returns:
the type name.

getDescription

public String getDescription()
Returns the text description of this OpenType instance.

Returns:
the description.

isArray

public boolean isArray()
Returns true if the open data values this open type describes are arrays, false otherwise.

Returns:
true if this is an array type.

isValue

public abstract boolean isValue(Object obj)
Tests whether obj is a value for this open type.

Parameters:
obj - the object to be tested for validity.
Returns:
true if obj is a value for this open type, false otherwise.

equals

public abstract boolean equals(Object obj)
Compares the specified obj parameter with this open type instance for equality.

Parameters:
obj - the object to compare to.
Returns:
true if this object and obj are equal.

hashCode

public abstract int hashCode()

toString

public abstract String toString()
Returns a string representation of this open type instance.

Returns:
the string representation.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SimpleType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class SimpleType

java.lang.Object
    extended by javax.management.openmbean.OpenType
        extended by javax.management.openmbean.SimpleType
All Implemented Interfaces:
Serializable
public final class SimpleType
extends OpenType
implements Serializable

The SimpleType class is the open type class whose instances describe all open data values which are neither arrays, nor CompositeData values, nor TabularData values. It predefines all its possible instances as static fields, and has no public constructor.

Given a SimpleType instance describing values whose Java class name is className, the internal fields corresponding to the name and description of this SimpleType instance are also set to className. In other words, its methods getClassName, getTypeName and getDescription all return the same string value className.

Since:
JMX 1.1
Version:
3.13 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Field Summary
static SimpleType | BIGDECIMAL The SimpleType instance describing values whose Java class name is java.math.BigDecimal.
static SimpleType | BIGINTEGER The SimpleType instance describing values whose Java class name is java.math.BigInteger.
static SimpleType | BOOLEAN The SimpleType instance describing values whose Java class name is java.lang.Boolean.
static SimpleType | BYTE The SimpleType instance describing values whose Java class name is java.lang.Byte.
static SimpleType | CHARACTER The SimpleType instance describing values whose Java class name is java.lang.Character.
static SimpleType | DATE The SimpleType instance describing values whose Java class name is java.util.Date.
static SimpleType | DOUBLE The SimpleType instance describing values whose Java class name is java.lang.Double.
static SimpleType | FLOAT The SimpleType instance describing values whose Java class name is java.lang.Float.
static SimpleType | INTEGER The SimpleType instance describing values whose Java class name is java.lang.Integer.
static SimpleType | LONG The SimpleType instance describing values whose Java class name is java.lang.Long.
static SimpleType | OBJECTNAME The SimpleType instance describing values whose Java class name is javax.management.ObjectName.
static SimpleType | SHORT The SimpleType instance describing values whose Java class name is java.lang.Short.
static SimpleType | STRING The SimpleType instance describing values whose Java class name is java.lang.String.
static SimpleType | VOID The SimpleType instance describing values whose Java class name is java.lang.Void.
Fields inherited from class javax.management.openmbean.OpenType
ALLOWED_CLASSNAMES
Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this SimpleType instance for equality.
int | hashCode() Returns the hash code value for this SimpleType instance.
boolean | isValue(Object obj) Tests whether obj is a value for this SimpleType instance.
Object | readResolve() Replace an object read from an ObjectInputStream with the unique instance for that value.
String | toString() Returns a string representation of this SimpleType instance.
Methods inherited from class javax.management.openmbean.OpenType
getClassName, getDescription, getTypeName, isArray
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

VOID

public static final SimpleType VOID
The SimpleType instance describing values whose Java class name is java.lang.Void.

BOOLEAN

public static final SimpleType BOOLEAN
The SimpleType instance describing values whose Java class name is java.lang.Boolean.

CHARACTER

public static final SimpleType CHARACTER
The SimpleType instance describing values whose Java class name is java.lang.Character.

BYTE

public static final SimpleType BYTE
The SimpleType instance describing values whose Java class name is java.lang.Byte.

SHORT

public static final SimpleType SHORT
The SimpleType instance describing values whose Java class name is java.lang.Short.

INTEGER

public static final SimpleType INTEGER
The SimpleType instance describing values whose Java class name is java.lang.Integer.

LONG

public static final SimpleType LONG
The SimpleType instance describing values whose Java class name is java.lang.Long.

FLOAT

public static final SimpleType FLOAT
The SimpleType instance describing values whose Java class name is java.lang.Float.

DOUBLE

public static final SimpleType DOUBLE
The SimpleType instance describing values whose Java class name is java.lang.Double.

STRING

public static final SimpleType STRING
The SimpleType instance describing values whose Java class name is java.lang.String.

BIGDECIMAL

public static final SimpleType BIGDECIMAL
The SimpleType instance describing values whose Java class name is java.math.BigDecimal.

BIGINTEGER

public static final SimpleType BIGINTEGER
The SimpleType instance describing values whose Java class name is java.math.BigInteger.

DATE

public static final SimpleType DATE
The SimpleType instance describing values whose Java class name is java.util.Date.

OBJECTNAME

public static final SimpleType OBJECTNAME
The SimpleType instance describing values whose Java class name is javax.management.ObjectName.

Method Detail

isValue

public boolean isValue(Object obj)
Tests whether obj is a value for this SimpleType instance.

This method returns true if and only if obj is not null and obj's class name is the same as the className field defined for this SimpleType instance (ie the class name returned by the getClassName method).

Specified by:
isValue in class OpenType
Parameters:
obj - the object to be tested.
Returns:
true if obj is a value for this SimpleType instance.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this SimpleType instance for equality.

Two SimpleType instances are equal if and only if their getClassName methods return the same value.

Specified by:
equals in class OpenType
Parameters:
obj - the object to be compared for equality with this SimpleType instance; if obj is null or is not an instance of the class SimpleType, equals returns false.
Returns:
true if the specified object is equal to this SimpleType instance.

hashCode

public int hashCode()
Returns the hash code value for this SimpleType instance. The hash code of a SimpleType instance is the the hash code of the string value returned by the getClassName method.

As SimpleType instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

Specified by:
hashCode in class OpenType
Returns:
the hash code value for this SimpleType instance

toString

public String toString()
Returns a string representation of this SimpleType instance.

The string representation consists of the name of this class (ie javax.management.openmbean.SimpleType) and the type name for this instance (which is the java class name of the values this SimpleType instance represents).

As SimpleType instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

Specified by:
toString in class OpenType
Returns:
a string representation of this SimpleType instance

readResolve

public Object readResolve()
                   throws ObjectStreamException
Replace an object read from an ObjectInputStream with the unique instance for that value.

Returns:
the replacement object.
Throws:
ObjectStreamException - if the read object cannot be resolved.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TabularData

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Interface TabularData

All Known Implementing Classes:
TabularDataSupport
public interface TabularData

The TabularData interface specifies the behaviour of a specific type of complex open data objects which represent tabular data structures.

Since:
JMX 1.1
Version:
3.7 02/10/01
Author:
Sun Microsystems, Inc.

Method Summary
Object[] | calculateIndex(CompositeData value) Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
void | clear() Removes all CompositeData values (ie rows) from this TabularData instance.
boolean | containsKey(Object[] key) Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
boolean | containsValue(CompositeData value) Returns true if and only if this TabularData instance contains the specified CompositeData value.
boolean | equals(Object obj) Compares the specified obj parameter with this TabularData instance for equality.
CompositeData | get(Object[] key) Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.
TabularType | getTabularType() Returns the tabular type describing this TabularData instance.
int | hashCode() Returns the hash code value for this TabularData instance.
boolean | isEmpty() Returns true if the number of CompositeData values (ie the number of rows) contained in this TabularData instance is zero.
Set | keySet() Returns a set view of the keys (ie the index values) of the CompositeData values (ie the rows) contained in this TabularData instance.
void | put(CompositeData value) Adds value to this TabularData instance.
void | putAll(CompositeData[] values) Add all the elements in values to this TabularData instance.
CompositeData | remove(Object[] key) Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.
int | size() Returns the number of CompositeData values (ie the number of rows) contained in this TabularData instance.
String | toString() Returns a string representation of this TabularData instance.
Collection | values() Returns a collection view of the CompositeData values (ie the rows) contained in this TabularData instance.

Method Detail

getTabularType

public TabularType getTabularType()
Returns the tabular type describing this TabularData instance.

Returns:
the tabular type.

calculateIndex

public Object[] calculateIndex(CompositeData value)
Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance. This method checks for the type validity of the specified value, but does not check if the calculated index is already used to refer to a value in this TabularData instance.

Parameters:
value - the composite data value whose index in this TabularData instance is to be calculated; must be of the same composite type as this instance's row type; must not be null.
Returns:
the index that the specified value would have in this TabularData instance.
Throws:
NullPointerException - if value is null
InvalidOpenTypeException - if value does not conform to this TabularData instance's row type definition.

size

public int size()
Returns the number of CompositeData values (ie the number of rows) contained in this TabularData instance.

Returns:
the number of values contained.

isEmpty

public boolean isEmpty()
Returns true if the number of CompositeData values (ie the number of rows) contained in this TabularData instance is zero.

Returns:
true if this TabularData is empty.

containsKey

public boolean containsKey(Object[] key)
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key. If key is null or does not conform to this TabularData instance's TabularType definition, this method simply returns false.

Parameters:
key - the index value whose presence in this TabularData instance is to be tested.
Returns:
true if this TabularData indexes a row value with the specified key.

containsValue

public boolean containsValue(CompositeData value)
Returns true if and only if this TabularData instance contains the specified CompositeData value. If value is null or does not conform to this TabularData instance's row type definition, this method simply returns false.

Parameters:
value - the row value whose presence in this TabularData instance is to be tested.
Returns:
true if this TabularData instance contains the specified row value.

get

public CompositeData get(Object[] key)
Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.

Parameters:
key - the key of the row to return.
Returns:
the value corresponding to key.
Throws:
NullPointerException - if the key is null
InvalidKeyException - if the key does not conform to this TabularData instance's * TabularType definition

put

public void put(CompositeData value)
Adds value to this TabularData instance. The composite type of value must be the same as this instance's row type (ie the composite type returned by this.getTabularType().getRowType()), and there must not already be an existing value in this TabularData instance whose index is the same as the one calculated for the value to be added. The index for value is calculated according to this TabularData instance's TabularType definition (see TabularType.getIndexNames()).

Parameters:
value - the composite data value to be added as a new row to this TabularData instance; must be of the same composite type as this instance's row type; must not be null.
Throws:
NullPointerException - if value is null
InvalidOpenTypeException - if value does not conform to this TabularData instance's row type definition.
KeyAlreadyExistsException - if the index for value, calculated according to this TabularData instance's TabularType definition already maps to an existing value in the underlying HashMap.

remove

public CompositeData remove(Object[] key)
Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.

Parameters:
key - the index of the value to get in this TabularData instance; must be valid with this TabularData instance's row type definition; must not be null.
Returns:
previous value associated with specified key, or null if there was no mapping for key.
Throws:
NullPointerException - if the key is null
InvalidKeyException - if the key does not conform to this TabularData instance's TabularType definition

putAll

public void putAll(CompositeData[] values)
Add all the elements in values to this TabularData instance. If any element in values does not satisfy the constraints defined in put, or if any two elements in values have the same index calculated according to this TabularData instance's TabularType definition, then an exception describing the failure is thrown and no element of values is added, thus leaving this TabularData instance unchanged.

Parameters:
values - the array of composite data values to be added as new rows to this TabularData instance; if values is null or empty, this method returns without doing anything.
Throws:
NullPointerException - if an element of values is null
InvalidOpenTypeException - if an element of values does not conform to this TabularData instance's row type definition
KeyAlreadyExistsException - if the index for an element of values, calculated according to this TabularData instance's TabularType definition already maps to an existing value in this instance, or two elements of values have the same index.

clear

public void clear()
Removes all CompositeData values (ie rows) from this TabularData instance.

keySet

public Set keySet()
Returns a set view of the keys (ie the index values) of the CompositeData values (ie the rows) contained in this TabularData instance. The returned Set can then be used to iterate over the keys.

Returns:
a set view of the index values used in this TabularData instance.

values

public Collection values()
Returns a collection view of the CompositeData values (ie the rows) contained in this TabularData instance. The returned collection can then be used to iterate over the values.

Returns:
a collection view of the rows contained in this TabularData instance.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this TabularData instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the TabularData interface,
  • their row types are equal
  • their contents (ie index to value mappings) are equal
This ensures that this equals method works properly for obj parameters which are different implementations of the TabularData interface.

Parameters:
obj - the object to be compared for equality with this TabularData instance;
Returns:
true if the specified object is equal to this TabularData instance.

hashCode

public int hashCode()
Returns the hash code value for this TabularData instance.

The hash code of a TabularData instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its tabular type and its content, where the content is defined as all the index to value mappings).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two TabularDataSupport instances t1 and t2, as required by the general contract of the method Object.hashCode .

Returns:
the hash code value for this TabularDataSupport instance

toString

public String toString()
Returns a string representation of this TabularData instance.

The string representation consists of the name of the implementing class, and the tabular type of this instance.

Returns:
a string representation of this TabularData instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TabularDataSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class TabularDataSupport

java.lang.Object
    extended by javax.management.openmbean.TabularDataSupport
All Implemented Interfaces:
Cloneable, Map, Serializable, TabularData
public class TabularDataSupport
extends Object
implements TabularData, Map, Cloneable, Serializable

The TabularDataSupport class is the open data class which implements the TabularData and the Map interfaces, and which is internally based on a hash map data structure.

Since:
JMX 1.1
Version:
3.19 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class java.util.Map
Map.Entry
Constructor Summary
TabularDataSupport(TabularType tabularType)
Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has a default initial capacity (101) and default load factor (0.75).
TabularDataSupport(TabularType tabularType, int initialCapacity, float loadFactor)
Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has the specified initial capacity and load factor.
Method Summary
 Object[] calculateIndex(CompositeData value)
Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
 void clear()
Removes all rows from this TabularDataSupport instance.
 Object clone()
Returns a clone of this TabularDataSupport instance: the clone is obtained by calling super.clone(), and then cloning the underlying map.
 boolean containsKey(Object key)
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
 boolean containsKey(Object[] key)
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
 boolean containsValue(CompositeData value)
Returns true if and only if this TabularData instance contains the specified CompositeData value.
 boolean containsValue(Object value)
Returns true if and only if this TabularData instance contains the specified value.
 Set entrySet()
Returns a collection view of the index to row mappings contained in this TabularDataSupport instance.
 boolean equals(Object obj)
Compares the specified obj parameter with this TabularDataSupport instance for equality.
 Object get(Object key)
This method simply calls get((Object[]) key).
 CompositeData get(Object[] key)
Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.
 TabularType getTabularType()
Returns the tabular type describing this TabularData instance.
 int hashCode()
Returns the hash code value for this TabularDataSupport instance.
 boolean isEmpty()
Returns true if this TabularDataSupport instance contains no rows.
 Set keySet()
Returns a set view of the keys contained in the underlying map of this TabularDataSupport instance, and used to index the rows.
 void put(CompositeData value)
Adds value to this TabularData instance.
 Object put(Object key, Object value)
This method simply calls put((CompositeData) value) and therefore ignores its key parameter which can be null.
 void putAll(CompositeData[] values)
Add all the elements in values to this TabularData instance.
 void putAll(Map t)
Add all the values contained in the specified map t to this TabularData instance.
 Object remove(Object key)
This method simply calls remove((Object[]) key).
 CompositeData remove(Object[] key)
Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.
 int size()
Returns the number of rows in this TabularDataSupport instance.
 String toString()
Returns a string representation of this TabularDataSupport instance.
 Collection values()
Returns a collection view of the rows contained in this TabularDataSupport instance.
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TabularDataSupport

public TabularDataSupport(TabularType tabularType)
Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has a default initial capacity (101) and default load factor (0.75).

This constructor simply calls this(tabularType, 101, 0.75f);

Parameters:
tabularType - the tabular type describing this TabularData instance; cannot be null.
Throws:
IllegalArgumentException - if the tabular type is null.

TabularDataSupport

public TabularDataSupport(TabularType tabularType,
                          int initialCapacity,
                          float loadFactor)
Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has the specified initial capacity and load factor.

Parameters:
tabularType - the tabular type describing this TabularData instance; cannot be null.
initialCapacity - the initial capacity of the HashMap.
loadFactor - the load factor of the HashMap
Throws:
IllegalArgumentException - if the initial capacity is less than zero, or the load factor is nonpositive, or the tabular type is null.
Method Detail

getTabularType

public TabularType getTabularType()
Returns the tabular type describing this TabularData instance.

Specified by:
getTabularType in interface TabularData
Returns:
the tabular type.

calculateIndex

public Object[] calculateIndex(CompositeData value)
Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance. This method checks for the type validity of the specified value, but does not check if the calculated index is already used to refer to a value in this TabularData instance.

Specified by:
calculateIndex in interface TabularData
Parameters:
value - the composite data value whose index in this TabularData instance is to be calculated; must be of the same composite type as this instance's row type; must not be null.
Returns:
the index that the specified value would have in this TabularData instance.
Throws:
NullPointerException - if value is null.
InvalidOpenTypeException - if value does not conform to this TabularData instance's row type definition.

containsKey

public boolean containsKey(Object key)
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key. If key cannot be cast to a one dimension array of Object instances, this method simply returns false; otherwise it returns the the result of the call to this.containsKey((Object[]) key).

Specified by:
containsKey in interface Map
Parameters:
key - the index value whose presence in this TabularData instance is to be tested.
Returns:
true if this TabularData indexes a row value with the specified key.

containsKey

public boolean containsKey(Object[] key)
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key. If key is null or does not conform to this TabularData instance's TabularType definition, this method simply returns false.

Specified by:
containsKey in interface TabularData
Parameters:
key - the index value whose presence in this TabularData instance is to be tested.
Returns:
true if this TabularData indexes a row value with the specified key.

containsValue

public boolean containsValue(CompositeData value)
Returns true if and only if this TabularData instance contains the specified CompositeData value. If value is null or does not conform to this TabularData instance's row type definition, this method simply returns false.

Specified by:
containsValue in interface TabularData
Parameters:
value - the row value whose presence in this TabularData instance is to be tested.
Returns:
true if this TabularData instance contains the specified row value.

containsValue

public boolean containsValue(Object value)
Returns true if and only if this TabularData instance contains the specified value.

Specified by:
containsValue in interface Map
Parameters:
value - the row value whose presence in this TabularData instance is to be tested.
Returns:
true if this TabularData instance contains the specified row value.

get

public Object get(Object key)
This method simply calls get((Object[]) key).

Specified by:
get in interface Map
Throws:
NullPointerException - if the key is null
ClassCastException - if the key is not of the type Object[]
InvalidKeyException - if the key does not conform to this TabularData instance's TabularType definition

get

public CompositeData get(Object[] key)
Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.

Specified by:
get in interface TabularData
Parameters:
key - the index of the value to get in this TabularData instance; * must be valid with this TabularData instance's row type definition; * must not be null.
Returns:
the value corresponding to key.
Throws:
NullPointerException - if the key is null
InvalidKeyException - if the key does not conform to this TabularData instance's TabularType type definition.

put

public Object put(Object key,
                  Object value)
This method simply calls put((CompositeData) value) and therefore ignores its key parameter which can be null.

Specified by:
put in interface Map
Parameters:
key - an ignored parameter.
value - the CompositeData to put.
Returns:
the value which is put
Throws:
NullPointerException - if the value is null
ClassCastException - if the value is not of the type CompositeData
InvalidOpenTypeException - if the value does not conform to this TabularData instance's TabularType definition
KeyAlreadyExistsException - if the key for the value parameter, calculated according to this TabularData instance's TabularType definition already maps to an existing value

put

public void put(CompositeData value)
Description copied from interface: TabularData
Adds value to this TabularData instance. The composite type of value must be the same as this instance's row type (ie the composite type returned by this.getTabularType().getRowType()), and there must not already be an existing value in this TabularData instance whose index is the same as the one calculated for the value to be added. The index for value is calculated according to this TabularData instance's TabularType definition (see TabularType.getIndexNames()).

Specified by:
put in interface TabularData
Parameters:
value - the composite data value to be added as a new row to this TabularData instance; must be of the same composite type as this instance's row type; must not be null.

remove

public Object remove(Object key)
This method simply calls remove((Object[]) key).

Specified by:
remove in interface Map
Parameters:
key - an Object[] representing the key to remove.
Returns:
previous value associated with specified key, or null if there was no mapping for key.
Throws:
NullPointerException - if the key is null
ClassCastException - if the key is not of the type Object[]
InvalidKeyException - if the key does not conform to this TabularData instance's TabularType definition

remove

public CompositeData remove(Object[] key)
Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.

Specified by:
remove in interface TabularData
Parameters:
key - the index of the value to get in this TabularData instance; must be valid with this TabularData instance's row type definition; must not be null.
Returns:
previous value associated with specified key, or null if there was no mapping for key.
Throws:
NullPointerException - if the key is null
InvalidKeyException - if the key does not conform to this TabularData instance's TabularType definition

putAll

public void putAll(Map t)
Add all the values contained in the specified map t to this TabularData instance. This method converts the collection of values contained in this map into an array of CompositeData values, if possible, and then call the method putAll(CompositeData[]). Note that the keys used in the specified map t are ignored. This method allows, for example to add the content of another TabularData instance with the same row type (but possibly different index names) into this instance.

Specified by:
putAll in interface Map
Parameters:
t - the map whose values are to be added as new rows to this TabularData instance; if t is null or empty, this method returns without doing anything.
Throws:
NullPointerException - if a value in t is null.
ClassCastException - if a value in t is not an instance of CompositeData.
InvalidOpenTypeException - if a value in t does not conform to this TabularData instance's row type definition.
KeyAlreadyExistsException - if the index for a value in t, calculated according to this TabularData instance's TabularType definition already maps to an existing value in this instance, or two values in t have the same index.

putAll

public void putAll(CompositeData[] values)
Add all the elements in values to this TabularData instance. If any element in values does not satisfy the constraints defined in put, or if any two elements in values have the same index calculated according to this TabularData instance's TabularType definition, then an exception describing the failure is thrown and no element of values is added, thus leaving this TabularData instance unchanged.

Specified by:
putAll in interface TabularData
Parameters:
values - the array of composite data values to be added as new rows to this TabularData instance; if values is null or empty, this method returns without doing anything.
Throws:
NullPointerException - if an element of values is null
InvalidOpenTypeException - if an element of values does not conform to this TabularData instance's row type definition (ie its TabularType definition)
KeyAlreadyExistsException - if the index for an element of values, calculated according to this TabularData instance's TabularType definition already maps to an existing value in this instance, or two elements of values have the same index

clear

public void clear()
Removes all rows from this TabularDataSupport instance.

Specified by:
clear in interface TabularData

size

public int size()
Returns the number of rows in this TabularDataSupport instance.

Specified by:
size in interface TabularData
Returns:
the number of rows in this TabularDataSupport instance.

isEmpty

public boolean isEmpty()
Returns true if this TabularDataSupport instance contains no rows.

Specified by:
isEmpty in interface TabularData
Returns:
true if this TabularDataSupport instance contains no rows.

keySet

public Set keySet()
Returns a set view of the keys contained in the underlying map of this TabularDataSupport instance, and used to index the rows. Each key contained in this set is an unmodifiable List. The set is backed by the underlying map of this TabularDataSupport instance, so changes to the TabularDataSupport instance are reflected in the set, and vice-versa. The set supports element removal, which removes the corresponding row from this TabularDataSupport instance, via the Iterator.remove, Set.remove, removeAll, retainAll, and clear operations. It does not support the add or addAll operations

Specified by:
keySet in interface TabularData
Returns:
a set view of the keys used to index the rows of this TabularDataSupport instance.

values

public Collection values()
Returns a collection view of the rows contained in this TabularDataSupport instance. The collection is backed by the underlying map, so changes to the TabularDataSupport instance are reflected in the collection, and vice-versa. The collection supports element removal, which removes the corresponding index to row mapping from this TabularDataSupport instance, via the Iterator.remove, Collection.remove, removeAll, retainAll, and clear operations. It does not support the add or addAll operations.

Specified by:
values in interface TabularData
Returns:
a collection view of the values contained in this TabularDataSupport instance.

entrySet

public Set entrySet()
Returns a collection view of the index to row mappings contained in this TabularDataSupport instance. Each element in the returned collection is a Map.Entry. The collection is backed by the underlying map of this TabularDataSupport instance, in so changes to the TabularDataSupport instance are reflected the collection, and vice-versa. The collection supports element removal, which removes the corresponding mapping from the map, via the Iterator.remove, Collection.remove, removeAll, retainAll, and clear operations. It does not support the add or addAll operations.

IMPORTANT NOTICE: Do not use the SetValue method of Map.Entry elements contained in the returned collection view. Doing so would corrupt the index to row mappings contained in this TabularDataSupport instance.

Specified by:
entrySet in interface Map
Returns:
a collection view of the mappings contained in this map.
See Also:
Map.Entry

clone

public Object clone()
Returns a clone of this TabularDataSupport instance: the clone is obtained by calling super.clone(), and then cloning the underlying map. Only a shallow clone of the underlying map is made, i.e. no cloning of the indexes and row values is made as they are immutable.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this TabularDataSupport instance for equality.

Returns true if and only if all of the following statements are true:

  • obj is non null,
  • obj also implements the TabularData interface,
  • their tabular types are equal
  • their contents (ie all CompositeData values) are equal.
This ensures that this equals method works properly for obj parameters which are different implementations of the TabularData interface.

Specified by:
equals in interface TabularData
Parameters:
obj - the object to be compared for equality with this TabularDataSupport instance;
Returns:
true if the specified object is equal to this TabularDataSupport instance.

hashCode

public int hashCode()
Returns the hash code value for this TabularDataSupport instance.

The hash code of a TabularDataSupport instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: its tabular type and its content, where the content is defined as all the CompositeData values).

This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two TabularDataSupport instances t1 and t2, as required by the general contract of the method Object.hashCode .

However, note that another instance of a class implementing the TabularData interface may be equal to this TabularDataSupport instance as defined by equals(java.lang.Object), but may have a different hash code if it is calculated differently.

Specified by:
hashCode in interface TabularData
Returns:
the hash code value for this TabularDataSupport instance

toString

public String toString()
Returns a string representation of this TabularDataSupport instance.

The string representation consists of the name of this class (ie javax.management.openmbean.TabularDataSupport), the string representation of the tabular type of this instance, and the string representation of the contents (ie list the key=value mappings as returned by a call to dataMap.toString()).

Specified by:
toString in interface TabularData
Returns:
a string representation of this TabularDataSupport instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TabularType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.openmbean
Class TabularType

java.lang.Object
    extended by javax.management.openmbean.OpenType
        extended by javax.management.openmbean.TabularType
All Implemented Interfaces:
Serializable
public class TabularType
extends OpenType
implements Serializable

The TabularType class is the open type class whose instances describe the types of TabularData values.

Since:
JMX 1.1
Version:
3.11 02/10/01
Author:
Sun Microsystems, Inc.
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.openmbean.OpenType
ALLOWED_CLASSNAMES
Constructor Summary
TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
Constructs a TabularType instance, checking for the validity of the given parameters.
Method Summary
boolean | equals(Object obj) Compares the specified obj parameter with this TabularType instance for equality.
List | getIndexNames() Returns, in the same order as was given to this instance's constructor, an unmodifiable List of the names of the items the values of which are used to uniquely index each row element of tabular data values described by this TabularType instance.
CompositeType | getRowType() Returns the type of the row elements of tabular data values described by this TabularType instance.
int | hashCode() Returns the hash code value for this TabularType instance.
boolean | isValue(Object obj) Tests whether obj is a value which could be described by this TabularType instance.
String | toString() Returns a string representation of this TabularType instance.
Methods inherited from class javax.management.openmbean.OpenType
getClassName, getDescription, getTypeName, isArray
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TabularType

public TabularType(String typeName,
                   String description,
                   CompositeType rowType,
                   String[] indexNames)
            throws OpenDataException
Constructs a TabularType instance, checking for the validity of the given parameters. The validity constraints are described below for each parameter.

The Java class name of tabular data values this tabular type represents (ie the class name returned by the getClassName method) is set to the string value returned by TabularData.class.getName().

Parameters:
typeName - The name given to the tabular type this instance represents; cannot be a null or empty string.
description - The human readable description of the tabular type this instance represents; cannot be a null or empty string.
rowType - The type of the row elements of tabular data values described by this tabular type instance; cannot be null.
indexNames - The names of the items the values of which are used to uniquely index each row element in the tabular data values described by this tabular type instance; cannot be null or empty. Each element should be an item name defined in rowType (no null or empty string allowed). It is important to note that the order of the item names in indexNames is used by the methods get and remove of class TabularData to match their array of values parameter to items.
Throws:
IllegalArgumentException - if rowType is null, or indexNames is a null or empty array, or an element in indexNames is a null or empty string, or typeName or description is a null or empty string.
OpenDataException - if an element's value of indexNames is not an item name defined in rowType.
Method Detail

getRowType

public CompositeType getRowType()
Returns the type of the row elements of tabular data values described by this TabularType instance.

Returns:
the type of each row.

getIndexNames

public List getIndexNames()

Returns, in the same order as was given to this instance's constructor, an unmodifiable List of the names of the items the values of which are used to uniquely index each row element of tabular data values described by this TabularType instance.

Returns:
a List of String representing the names of the index items.

isValue

public boolean isValue(Object obj)
Tests whether obj is a value which could be described by this TabularType instance.

If obj is null or is not an instance of javax.management.openmbean.TabularData, isValue returns false. If obj is an instance of javax.management.openmbean.TabularData, its tabular type is tested for equality with this tabular type instance, and isValue returns true if and only if equals returns true.

Specified by:
isValue in class OpenType
Parameters:
obj - the value whose open type is to be tested for equality with this TabularType instance.
Returns:
true if obj is a value for this tabular type, false otherwise.

equals

public boolean equals(Object obj)
Compares the specified obj parameter with this TabularType instance for equality.

Two TabularType instances are equal if and only if all of the following statements are true:

  • their type names are equal
  • their row types are equal
  • they use the same index names, in the same order

Specified by:
equals in class OpenType
Parameters:
obj - the object to be compared for equality with this TabularType instance; if obj is null, equals returns false.
Returns:
true if the specified object is equal to this TabularType instance.

hashCode

public int hashCode()
Returns the hash code value for this TabularType instance.

The hash code of a TabularType instance is the sum of the hash codes of all elements of information used in equals comparisons (ie: name, row type, index names). This ensures that t1.equals(t2) implies that t1.hashCode()==t2.hashCode() for any two TabularType instances t1 and t2, as required by the general contract of the method Object.hashCode .

As TabularType instances are immutable, the hash code for this instance is calculated once, on the first call to hashCode, and then the same value is returned for subsequent calls.

Specified by:
hashCode in class OpenType
Returns:
the hash code value for this TabularType instance

toString

public String toString()
Returns a string representation of this TabularType instance.

The string representation consists of the name of this class (ie javax.management.openmbean.TabularType), the type name for this instance, the row type string representation of this instance, and the index names of this instance.

As TabularType instances are immutable, the string representation for this instance is calculated once, on the first call to toString, and then the same value is returned for subsequent calls.

Specified by:
toString in class OpenType
Returns:
a string representation of this TabularType instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OperationsException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class OperationsException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.OperationsException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AttributeNotFoundException, InstanceAlreadyExistsException, InstanceNotFoundException, IntrospectionException, InvalidAttributeValueException, ListenerNotFoundException, MalformedObjectNameException, NotCompliantMBeanException, ServiceNotFoundException
public class OperationsException
extends JMException

Represents exceptions thrown in the MBean server when performing operations on MBeans.

See Also:
Serialized Form

Constructor Summary
OperationsException()
Default constructor.
OperationsException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OperationsException

public OperationsException()
Default constructor.

OperationsException

public OperationsException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PersistentMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface PersistentMBean

All Known Subinterfaces:
ModelMBean
All Known Implementing Classes:
RequiredModelMBean
public interface PersistentMBean

This class is the interface to be implemented by MBeans that are meant to be persistent. MBeans supporting this interface should call the load method during construction in order to prime the MBean from the persistent store. In the case of a ModelMBean, the store method should be called by the MBeanServer based on the descriptors in the ModelMBean or by the MBean itself during normal processing of the ModelMBean.

Method Summary
void | load() Instantiates thisMBean instance with the data found for the MBean in the persistent store.
void | store() Captures the current state of this MBean instance and writes it out to the persistent store.

Method Detail

load

public void load()
          throws MBeanException,
                 RuntimeOperationsException,
                 InstanceNotFoundException
Instantiates thisMBean instance with the data found for the MBean in the persistent store. The data loaded could include attribute and operation values. This method should be called during construction or initialization of this instance, and before the MBean is registered with the MBeanServer.

Throws:
MBeanException - Wraps another exception or persistence is not supported
RuntimeOperationsException - Wraps exceptions from the persistence mechanism
InstanceNotFoundException - Could not find or load this MBean from persistent storage

store

public void store()
           throws MBeanException,
                  RuntimeOperationsException,
                  InstanceNotFoundException
Captures the current state of this MBean instance and writes it out to the persistent store. The state stored could include attribute and operation values. If one of these methods of persistence is not supported a "serviceNotFound" exception will be thrown.

Persistance policy from the MBean and attribute descriptor is used to guide execution of this method. The MBean should be stored if 'persistPolicy' field is:

  != "never"
   = "always"
   = "onTimer" and now > 'lastPersistTime' + 'persistPeriod'
   = "NoMoreOftenThan" and now > 'lastPersistTime' + 'persistPeriod'

 Do not store the MBean if 'persistPolicy' field is:
    = "never"
    = "onUpdate"
    = "onTimer" && now < 'lastPersistTime' + 'persistPeriod'

Throws:
MBeanException - Wraps another exception or persistence is not supported
RuntimeOperationsException - Wraps exceptions from the persistence mechanism
InstanceNotFoundException - Could not find/access the persistant store
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Query

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class Query

java.lang.Object
    extended by javax.management.Query
public class Query
extends Object

Constructs query object constraints. The static methods provided return query expressions that may be used in listing and enumerating MBeans. Individual constraint construction methods allow only appropriate types as arguments. Composition of calls can construct arbitrary nestings of constraints, as the following example illustrates:

 QueryExp exp = Query.and(Query.gt(Query.attr("age"),Query.value(5)),
                          Query.match(Query.attr("name"),
                                      Query.value("Smith")));

Field Summary
static int | DIV A code representing the div(javax.management.ValueExp, javax.management.ValueExp) expression.
static int | EQ A code representing the eq(javax.management.ValueExp, javax.management.ValueExp) query.
static int | GE A code representing the geq(javax.management.ValueExp, javax.management.ValueExp) query.
static int | GT A code representing the gt(javax.management.ValueExp, javax.management.ValueExp) query.
static int | LE A code representing the leq(javax.management.ValueExp, javax.management.ValueExp) query.
static int | LT A code representing the lt(javax.management.ValueExp, javax.management.ValueExp) query.
static int | MINUS A code representing the minus(javax.management.ValueExp, javax.management.ValueExp) expression.
static int | PLUS A code representing the plus(javax.management.ValueExp, javax.management.ValueExp) expression.
static int | TIMES A code representing the times(javax.management.ValueExp, javax.management.ValueExp) expression.
Constructor Summary
Query()
Basic constructor.
Method Summary
static QueryExp | and(QueryExp q1, QueryExp q2) Returns a query expression that is the conjunction of two other query expressions.
static QueryExp | anySubString(AttributeValueExp a, StringValueExp s) Returns a query expression that represents a matching constraint on a string argument.
static AttributeValueExp | attr(String name) Returns a new attribute expression.
static AttributeValueExp | attr(String className, String name) Returns a new qualified attribute expression.
static QueryExp | between(ValueExp v1, ValueExp v2, ValueExp v3) Returns a query expression that represents the constraint that one value is between two other values.
static AttributeValueExp | classattr() Returns a new class attribute expression which can be used in any Query call that expects a ValueExp.
static ValueExp | div(ValueExp value1, ValueExp value2) Returns a binary expression representing the quotient of two numeric values.
static QueryExp | eq(ValueExp v1, ValueExp v2) Returns a query expression that represents an equality constraint on two values.
static QueryExp | finalSubString(AttributeValueExp a, StringValueExp s) Returns a query expression that represents a matching constraint on a string argument.
static QueryExp | geq(ValueExp v1, ValueExp v2) Returns a query expression that represents a "greater than or equal to" constraint on two values.
static QueryExp | gt(ValueExp v1, ValueExp v2) Returns a query expression that represents a "greater than" constraint on two values.
static QueryExp | in(ValueExp val, ValueExp[] valueList) Returns an expression constraining a value to be one of an explicit list.
static QueryExp | initialSubString(AttributeValueExp a, StringValueExp s) Returns a query expression that represents a matching constraint on a string argument.
static QueryExp | leq(ValueExp v1, ValueExp v2) Returns a query expression that represents a "less than or equal to" constraint on two values.
static QueryExp | lt(ValueExp v1, ValueExp v2) Returns a query expression that represents a "less than" constraint on two values.
static QueryExp | match(AttributeValueExp a, StringValueExp s) Returns a query expression that represents a matching constraint on a string argument.
static ValueExp | minus(ValueExp value1, ValueExp value2) Returns a binary expression representing the difference between two numeric values.
static QueryExp | not(QueryExp queryExp) Returns a constraint that is the negation of its argument.
static QueryExp | or(QueryExp q1, QueryExp q2) Returns a query expression that is the disjunction of two other query expressions.
static ValueExp | plus(ValueExp value1, ValueExp value2) Returns a binary expression representing the sum of two numeric values, or the concatenation of two string values.
static ValueExp | times(ValueExp value1, ValueExp value2) Returns a binary expression representing the product of two numeric values.
static ValueExp | value(boolean val) Returns a boolean value expression that can be used in any Query call that expects a ValueExp.
static ValueExp | value(double val) Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
static ValueExp | value(float val) Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
static ValueExp | value(int val) Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
static ValueExp | value(long val) Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
static ValueExp | value(Number val) Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
static StringValueExp | value(String val) Returns a new string expression.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

GT

public static final int GT
A code representing the gt(javax.management.ValueExp, javax.management.ValueExp) query. This is chiefly of interest for the serialized form of queries.

See Also:
Constant Field Values

LT

public static final int LT
A code representing the lt(javax.management.ValueExp, javax.management.ValueExp) query. This is chiefly of interest for the serialized form of queries.

See Also:
Constant Field Values

GE

public static final int GE
A code representing the geq(javax.management.ValueExp, javax.management.ValueExp) query. This is chiefly of interest for the serialized form of queries.

See Also:
Constant Field Values

LE

public static final int LE
A code representing the leq(javax.management.ValueExp, javax.management.ValueExp) query. This is chiefly of interest for the serialized form of queries.

See Also:
Constant Field Values

EQ

public static final int EQ
A code representing the eq(javax.management.ValueExp, javax.management.ValueExp) query. This is chiefly of interest for the serialized form of queries.

See Also:
Constant Field Values

PLUS

public static final int PLUS
A code representing the plus(javax.management.ValueExp, javax.management.ValueExp) expression. This is chiefly of interest for the serialized form of queries.

See Also:
Constant Field Values

MINUS

public static final int MINUS
A code representing the minus(javax.management.ValueExp, javax.management.ValueExp) expression. This is chiefly of interest for the serialized form of queries.

See Also:
Constant Field Values

TIMES

public static final int TIMES
A code representing the times(javax.management.ValueExp, javax.management.ValueExp) expression. This is chiefly of interest for the serialized form of queries.

See Also:
Constant Field Values

DIV

public static final int DIV
A code representing the div(javax.management.ValueExp, javax.management.ValueExp) expression. This is chiefly of interest for the serialized form of queries.

See Also:
Constant Field Values
Constructor Detail

Query

public Query()
Basic constructor.

Method Detail

and

public static QueryExp and(QueryExp q1,
                           QueryExp q2)
Returns a query expression that is the conjunction of two other query expressions.

Parameters:
q1 - A query expression.
q2 - Another query expression.
Returns:
The conjunction of the two arguments.

or

public static QueryExp or(QueryExp q1,
                          QueryExp q2)
Returns a query expression that is the disjunction of two other query expressions.

Parameters:
q1 - A query expression.
q2 - Another query expression.
Returns:
The disjunction of the two arguments.

gt

public static QueryExp gt(ValueExp v1,
                          ValueExp v2)
Returns a query expression that represents a "greater than" constraint on two values.

Parameters:
v1 - A value expression.
v2 - Another value expression.
Returns:
A "greater than" constraint on the arguments.

geq

public static QueryExp geq(ValueExp v1,
                           ValueExp v2)
Returns a query expression that represents a "greater than or equal to" constraint on two values.

Parameters:
v1 - A value expression.
v2 - Another value expression.
Returns:
A "greater than or equal to" constraint on the arguments.

leq

public static QueryExp leq(ValueExp v1,
                           ValueExp v2)
Returns a query expression that represents a "less than or equal to" constraint on two values.

Parameters:
v1 - A value expression.
v2 - Another value expression.
Returns:
A "less than or equal to" constraint on the arguments.

lt

public static QueryExp lt(ValueExp v1,
                          ValueExp v2)
Returns a query expression that represents a "less than" constraint on two values.

Parameters:
v1 - A value expression.
v2 - Another value expression.
Returns:
A "less than" constraint on the arguments.

eq

public static QueryExp eq(ValueExp v1,
                          ValueExp v2)
Returns a query expression that represents an equality constraint on two values.

Parameters:
v1 - A value expression.
v2 - Another value expression.
Returns:
A "equal to" constraint on the arguments.

between

public static QueryExp between(ValueExp v1,
                               ValueExp v2,
                               ValueExp v3)
Returns a query expression that represents the constraint that one value is between two other values.

Parameters:
v1 - A value expression that is "between" v2 and v3.
v2 - Value expression that represents a boundary of the constraint.
v3 - Value expression that represents a boundary of the constraint.
Returns:
The constraint that v1 lies between v2 and v3.

match

public static QueryExp match(AttributeValueExp a,
                             StringValueExp s)
Returns a query expression that represents a matching constraint on a string argument. The matching syntax is consistent with file globbing: Supports "?", "*", "[", each of which may be escaped with "\"; Character classes may use "!" for negation and "-" for range. (* for any character sequence ? for a single arbitrary character [...] for a character sequence). For example: a*b?c would match a string starting with the character a, followed by any number of characters, followed by a b, any single character, and a c.

Parameters:
a - An attribute expression
s - A string value expression representing a matching constraint
Returns:
A query expression that represents the matching constraint on the string argument.

attr

public static AttributeValueExp attr(String name)

Returns a new attribute expression.

Evaluating this expression for a given objectName includes performing MBeanServer.getAttribute(objectName, name).

Parameters:
name - The name of the attribute.
Returns:
An attribute expression for the attribute named name.

attr

public static AttributeValueExp attr(String className,
                                     String name)

Returns a new qualified attribute expression.

Evaluating this expression for a given objectName includes performing MBeanServer.getObjectInstance(objectName) and MBeanServer.getAttribute(objectName, name).

Parameters:
className - The name of the class possessing the attribute.
name - The name of the attribute.
Returns:
An attribute expression for the attribute named name.

classattr

public static AttributeValueExp classattr()

Returns a new class attribute expression which can be used in any Query call that expects a ValueExp.

Evaluating this expression for a given objectName includes performing MBeanServer.getObjectInstance(objectName).

Returns:
A class attribute expression.

not

public static QueryExp not(QueryExp queryExp)
Returns a constraint that is the negation of its argument.

Parameters:
queryExp - The constraint to negate.
Returns:
A negated constraint.

in

public static QueryExp in(ValueExp val,
                          ValueExp[] valueList)
Returns an expression constraining a value to be one of an explicit list.

Parameters:
val - A value to be constrained.
valueList - An array of ValueExps.
Returns:
A QueryExp that represents the constraint.

value

public static StringValueExp value(String val)
Returns a new string expression.

Parameters:
val - The string value.
Returns:
A ValueExp object containing the string argument.

value

public static ValueExp value(Number val)
Returns a numeric value expression that can be used in any Query call that expects a ValueExp.

Parameters:
val - An instance of Number.
Returns:
A ValueExp object containing the argument.

value

public static ValueExp value(int val)
Returns a numeric value expression that can be used in any Query call that expects a ValueExp.

Parameters:
val - An int value.
Returns:
A ValueExp object containing the argument.

value

public static ValueExp value(long val)
Returns a numeric value expression that can be used in any Query call that expects a ValueExp.

Parameters:
val - A long value.
Returns:
A ValueExp object containing the argument.

value

public static ValueExp value(float val)
Returns a numeric value expression that can be used in any Query call that expects a ValueExp.

Parameters:
val - A float value.
Returns:
A ValueExp object containing the argument.

value

public static ValueExp value(double val)
Returns a numeric value expression that can be used in any Query call that expects a ValueExp.

Parameters:
val - A double value.
Returns:
A ValueExp object containing the argument.

value

public static ValueExp value(boolean val)
Returns a boolean value expression that can be used in any Query call that expects a ValueExp.

Parameters:
val - A boolean value.
Returns:
A ValueExp object containing the argument.

plus

public static ValueExp plus(ValueExp value1,
                            ValueExp value2)
Returns a binary expression representing the sum of two numeric values, or the concatenation of two string values.

Parameters:
value1 - The first '+' operand.
value2 - The second '+' operand.
Returns:
A ValueExp representing the sum or concatenation of the two arguments.

times

public static ValueExp times(ValueExp value1,
                             ValueExp value2)
Returns a binary expression representing the product of two numeric values.

Parameters:
value1 - The first '*' operand.
value2 - The second '*' operand.
Returns:
A ValueExp representing the product.

minus

public static ValueExp minus(ValueExp value1,
                             ValueExp value2)
Returns a binary expression representing the difference between two numeric values.

Parameters:
value1 - The first '-' operand.
value2 - The second '-' operand.
Returns:
A ValueExp representing the difference between two arguments.

div

public static ValueExp div(ValueExp value1,
                           ValueExp value2)
Returns a binary expression representing the quotient of two numeric values.

Parameters:
value1 - The first '/' operand.
value2 - The second '/' operand.
Returns:
A ValueExp representing the quotient of two arguments.

initialSubString

public static QueryExp initialSubString(AttributeValueExp a,
                                        StringValueExp s)
Returns a query expression that represents a matching constraint on a string argument. The value must start with the given string value.

Parameters:
a - An attribute expression.
s - A string value expression representing the beginning of the string value.
Returns:
The constraint that a matches s.

anySubString

public static QueryExp anySubString(AttributeValueExp a,
                                    StringValueExp s)
Returns a query expression that represents a matching constraint on a string argument. The value must contain the given string value.

Parameters:
a - An attribute expression.
s - A string value expression representing the substring.
Returns:
The constraint that a matches s.

finalSubString

public static QueryExp finalSubString(AttributeValueExp a,
                                      StringValueExp s)
Returns a query expression that represents a matching constraint on a string argument. The value must contain the given string value.

Parameters:
a - An attribute expression.
s - A string value expression representing the end of the string value.
Returns:
The constraint that a matches s.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QueryEval

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class QueryEval

java.lang.Object
    extended by javax.management.QueryEval
All Implemented Interfaces:
Serializable
public abstract class QueryEval
extends Object
implements Serializable

Allows a query to be performed in the context of a specific MBean server.

See Also:
Serialized Form

Constructor Summary
QueryEval()
Method Summary
static MBeanServer | getMBeanServer() Return the MBean server that was most recently given to the setMBeanServer method by this thread.
void | setMBeanServer(MBeanServer s) Sets the MBean server on which the query is to be performed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryEval

public QueryEval()
Method Detail

setMBeanServer

public void setMBeanServer(MBeanServer s)

Sets the MBean server on which the query is to be performed. The setting is valid for the thread performing the set. It is copied to any threads created by that thread at the moment of their creation.

For historical reasons, this method is not static, but its behaviour does not depend on the instance on which it is called.

Parameters:
s - The MBean server on which the query is to be performed.
See Also:
getMBeanServer()

getMBeanServer

public static MBeanServer getMBeanServer()

Return the MBean server that was most recently given to the setMBeanServer method by this thread. If this thread never called that method, the result is the value its parent thread would have obtained from getMBeanServer at the moment of the creation of this thread, or null if there is no parent thread.

Returns:
the MBean server.
Since:
JMX 1.2
See Also:
setMBeanServer(javax.management.MBeanServer)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QueryExp

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface QueryExp

All Superinterfaces:
Serializable
All Known Implementing Classes:
ObjectName
public interface QueryExp
extends Serializable

Represents relational constraints that can be used in database query "where clauses". Instances of QueryExp are returned by the static methods of the Query class.

It is possible, but not recommended, to create custom queries by implementing this interface. In that case, it is better to extend the QueryEval class than to implement the interface directly, so that the setMBeanServer(javax.management.MBeanServer) method works correctly.

Method Summary
boolean | apply(ObjectName name) Applies the QueryExp on an MBean.
void | setMBeanServer(MBeanServer s) Sets the MBean server on which the query is to be performed.

Method Detail

apply

public boolean apply(ObjectName name)
              throws BadStringOperationException,
                     BadBinaryOpValueExpException,
                     BadAttributeValueExpException,
                     InvalidApplicationException
Applies the QueryExp on an MBean.

Parameters:
name - The name of the MBean on which the QueryExp will be applied.
Returns:
True if the query was successfully applied to the MBean, false otherwise
Throws:
BadStringOperationException
BadBinaryOpValueExpException
BadAttributeValueExpException
InvalidApplicationException

setMBeanServer

public void setMBeanServer(MBeanServer s)
Sets the MBean server on which the query is to be performed.

Parameters:
s - The MBean server on which the query is to be performed.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ReflectionException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class ReflectionException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.ReflectionException
All Implemented Interfaces:
Serializable
public class ReflectionException
extends JMException

Represents exceptions thrown in the MBean server when using the java.lang.reflect classes to invoke methods on MBeans. It "wraps" the actual java.lang.Exception thrown.

See Also:
Serialized Form

Constructor Summary
ReflectionException(Exception e)
Creates a ReflectionException that wraps the actual java.lang.Exception.
ReflectionException(Exception e, String message)
Creates a ReflectionException that wraps the actual java.lang.Exception with a detail message.
Method Summary
Throwable | getCause() Returns the actual Exception thrown.
Exception | getTargetException() Returns the actual Exception thrown.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReflectionException

public ReflectionException(Exception e)
Creates a ReflectionException that wraps the actual java.lang.Exception.

Parameters:
e - the wrapped exception.

ReflectionException

public ReflectionException(Exception e,
                           String message)
Creates a ReflectionException that wraps the actual java.lang.Exception with a detail message.

Parameters:
e - the wrapped exception.
message - the detail message.
Method Detail

getTargetException

public Exception getTargetException()
Returns the actual Exception thrown.

Returns:
the wrapped Exception.

getCause

public Throwable getCause()
Returns the actual Exception thrown.

Returns:
the wrapped Exception.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


relation

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management.relation

Provides the definition of the Relation service.

See:
Description

Interface Summary
Relation | This interface has to be implemented by any MBean class expected to represent a relation managed using the Relation Service.
RelationServiceMBean | The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.
RelationSupportMBean | A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.
RelationType | The RelationType interface has to be implemented by any class expected to represent a relation type.

Class Summary
MBeanServerNotificationFilter | Filter for MBeanServerNotification.
RelationNotification | A notification of a change in the Relation Service.
RelationService | The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.
RelationSupport | A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.
RelationTypeSupport | A RelationTypeSupport object implements the RelationType interface.
Role | Represents a role: includes a role name and referenced MBeans (via their ObjectNames).
RoleInfo | A RoleInfo object summarises a role in a relation type.
RoleList | A RoleList represents a list of roles (Role objects).
RoleResult | Represents the result of a multiple access to several roles of a relation (either for reading or writing).
RoleStatus | This class describes the various problems which can be encountered when accessing a role.
RoleUnresolved | Represents an unresolved role: a role not retrieved from a relation due to a problem.
RoleUnresolvedList | A RoleUnresolvedList represents a list of RoleUnresolved objects, representing roles not retrieved from a relation due to a problem encountered when trying to access (read or write to roles).

Exception Summary
InvalidRelationIdException | This exception is raised when relation id provided for a relation is already used.
InvalidRelationServiceException | This exception is raised when an invalid Relation Service is provided.
InvalidRelationTypeException | Invalid relation type.
InvalidRoleInfoException | This exception is raised when, in a role info, its minimum degree is greater than its maximum degree.
InvalidRoleValueException | Role value is invalid.
RelationException | This class is the superclass of any exception which can be raised during relation management.
RelationNotFoundException | This exception is raised when there is no relation for a given relation id in a Relation Service.
RelationServiceNotRegisteredException | This exception is raised when an access is done to the Relation Service and that one is not registered.
RelationTypeNotFoundException | This exception is raised when there is no relation type with given name in Relation Service.
RoleInfoNotFoundException | This exception is raised when there is no role info with given name in a given relation type.
RoleNotFoundException | This exception is raised when a role in a relation does not exist, or is not readable, or is not settable.

Package javax.management.relation Description

Provides the definition of the Relation service.

Since:
JMX 1.0
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.management.relation Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management.relation

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class javax.management.relation.RoleList
          • class javax.management.relation.RoleUnresolvedList
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.management.Notification
        • class javax.management.relation.RelationNotification
    • class javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • class javax.management.relation.RelationService (implements javax.management.MBeanRegistration, javax.management.NotificationListener, javax.management.relation.RelationServiceMBean)
    • class javax.management.NotificationFilterSupport (implements javax.management.NotificationFilter, java.io.Serializable)
      • class javax.management.relation.MBeanServerNotificationFilter
    • class javax.management.relation.RelationSupport (implements javax.management.MBeanRegistration, javax.management.relation.RelationSupportMBean)
    • class javax.management.relation.RelationTypeSupport (implements javax.management.relation.RelationType)
    • class javax.management.relation.Role (implements java.io.Serializable)
    • class javax.management.relation.RoleInfo (implements java.io.Serializable)
    • class javax.management.relation.RoleResult (implements java.io.Serializable)
    • class javax.management.relation.RoleStatus
    • class javax.management.relation.RoleUnresolved (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.management.JMException
          • class javax.management.relation.RelationException
            • class javax.management.relation.InvalidRelationIdException
            • class javax.management.relation.InvalidRelationServiceException
            • class javax.management.relation.InvalidRelationTypeException
            • class javax.management.relation.InvalidRoleInfoException
            • class javax.management.relation.InvalidRoleValueException
            • class javax.management.relation.RelationNotFoundException
            • class javax.management.relation.RelationServiceNotRegisteredException
            • class javax.management.relation.RelationTypeNotFoundException
            • class javax.management.relation.RoleInfoNotFoundException
            • class javax.management.relation.RoleNotFoundException

Interface Hierarchy

  • interface javax.management.relation.Relation
    • interface javax.management.relation.RelationSupportMBean
  • interface javax.management.relation.RelationServiceMBean
  • interface java.io.Serializable
    • interface javax.management.relation.RelationType
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidRelationIdException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class InvalidRelationIdException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
                    extended by javax.management.relation.InvalidRelationIdException
All Implemented Interfaces:
Serializable
public class InvalidRelationIdException
extends RelationException

This exception is raised when relation id provided for a relation is already used.

See Also:
Serialized Form

Constructor Summary
InvalidRelationIdException()
Default constructor, no message put in exception.
InvalidRelationIdException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidRelationIdException

public InvalidRelationIdException()
Default constructor, no message put in exception.

InvalidRelationIdException

public InvalidRelationIdException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidRelationServiceException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class InvalidRelationServiceException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
                    extended by javax.management.relation.InvalidRelationServiceException
All Implemented Interfaces:
Serializable
public class InvalidRelationServiceException
extends RelationException

This exception is raised when an invalid Relation Service is provided.

See Also:
Serialized Form

Constructor Summary
InvalidRelationServiceException()
Default constructor, no message put in exception.
InvalidRelationServiceException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidRelationServiceException

public InvalidRelationServiceException()
Default constructor, no message put in exception.

InvalidRelationServiceException

public InvalidRelationServiceException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidRelationTypeException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class InvalidRelationTypeException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
                    extended by javax.management.relation.InvalidRelationTypeException
All Implemented Interfaces:
Serializable
public class InvalidRelationTypeException
extends RelationException

Invalid relation type. This exception is raised when, in a relation type, there is already a relation type with that name, or the same name has been used for two different role infos, or no role info provided, or one null role info provided.

See Also:
Serialized Form

Constructor Summary
InvalidRelationTypeException()
Default constructor, no message put in exception.
InvalidRelationTypeException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidRelationTypeException

public InvalidRelationTypeException()
Default constructor, no message put in exception.

InvalidRelationTypeException

public InvalidRelationTypeException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidRoleInfoException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class InvalidRoleInfoException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
                    extended by javax.management.relation.InvalidRoleInfoException
All Implemented Interfaces:
Serializable
public class InvalidRoleInfoException
extends RelationException

This exception is raised when, in a role info, its minimum degree is greater than its maximum degree.

See Also:
Serialized Form

Constructor Summary
InvalidRoleInfoException()
Default constructor, no message put in exception.
InvalidRoleInfoException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidRoleInfoException

public InvalidRoleInfoException()
Default constructor, no message put in exception.

InvalidRoleInfoException

public InvalidRoleInfoException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidRoleValueException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class InvalidRoleValueException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
                    extended by javax.management.relation.InvalidRoleValueException
All Implemented Interfaces:
Serializable
public class InvalidRoleValueException
extends RelationException

Role value is invalid. This exception is raised when, in a role, the number of referenced MBeans in given value is less than expected minimum degree, or the number of referenced MBeans in provided value exceeds expected maximum degree, or one referenced MBean in the value is not an Object of the MBean class expected for that role, or an MBean provided for that role does not exist.

See Also:
Serialized Form

Constructor Summary
InvalidRoleValueException()
Default constructor, no message put in exception.
InvalidRoleValueException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidRoleValueException

public InvalidRoleValueException()
Default constructor, no message put in exception.

InvalidRoleValueException

public InvalidRoleValueException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MBeanServerNotificationFilter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class MBeanServerNotificationFilter

java.lang.Object
    extended by javax.management.NotificationFilterSupport
        extended by javax.management.relation.MBeanServerNotificationFilter
All Implemented Interfaces:
NotificationFilter, Serializable
public class MBeanServerNotificationFilter
extends NotificationFilterSupport

Filter for MBeanServerNotification. This filter filters MBeanServerNotification notifications by selecting the ObjectNames of interest and the operations (registration, unregistration, both) of interest (corresponding to notification types).

See Also:
Serialized Form

Constructor Summary
MBeanServerNotificationFilter()
Creates a filter selecting all MBeanServerNotification notifications for all ObjectNames.
Method Summary
void | disableAllObjectNames() Disables any MBeanServerNotification (all ObjectNames are deselected).
void | disableObjectName(ObjectName theObjName) Disables MBeanServerNotifications concerning given ObjectName.
void | enableAllObjectNames() Enables all MBeanServerNotifications (all ObjectNames are selected).
void | enableObjectName(ObjectName theObjName) Enables MBeanServerNotifications concerning given ObjectName.
Vector | getDisabledObjectNames() Gets all the ObjectNames disabled.
Vector | getEnabledObjectNames() Gets all the ObjectNames enabled.
boolean | isNotificationEnabled(Notification theNtf) Invoked before sending the specified notification to the listener.
Methods inherited from class javax.management.NotificationFilterSupport
disableAllTypes, disableType, enableType, getEnabledTypes
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MBeanServerNotificationFilter

public MBeanServerNotificationFilter()
Creates a filter selecting all MBeanServerNotification notifications for all ObjectNames.

Method Detail

disableAllObjectNames

public void disableAllObjectNames()
Disables any MBeanServerNotification (all ObjectNames are deselected).

disableObjectName

public void disableObjectName(ObjectName theObjName)
                       throws IllegalArgumentException
Disables MBeanServerNotifications concerning given ObjectName.

Parameters:
theObjName - ObjectName no longer of interest
Throws:
IllegalArgumentException - if the given ObjectName is null

enableAllObjectNames

public void enableAllObjectNames()
Enables all MBeanServerNotifications (all ObjectNames are selected).

enableObjectName

public void enableObjectName(ObjectName theObjName)
                      throws IllegalArgumentException
Enables MBeanServerNotifications concerning given ObjectName.

Parameters:
theObjName - ObjectName of interest
Throws:
IllegalArgumentException - if the given ObjectName is null

getEnabledObjectNames

public Vector getEnabledObjectNames()
Gets all the ObjectNames enabled.

Returns:
Vector of ObjectNames:

- null means all ObjectNames are implicitly selected, except the ObjectNames explicitly deselected

- empty means all ObjectNames are deselected, i.e. no ObjectName selected.

getDisabledObjectNames

public Vector getDisabledObjectNames()
Gets all the ObjectNames disabled.

Returns:
Vector of ObjectNames:

- null means all ObjectNames are implicitly deselected, except the ObjectNames explicitly selected

- empty means all ObjectNames are selected, i.e. no ObjectName deselected.

isNotificationEnabled

public boolean isNotificationEnabled(Notification theNtf)
                              throws IllegalArgumentException
Invoked before sending the specified notification to the listener.

If:

- the ObjectName of the concerned MBean is selected (explicitly OR (implicitly and not explicitly deselected))

AND

- the type of the operation (registration or unregistration) is selected

then the notification is sent to the listener.

Specified by:
isNotificationEnabled in interface NotificationFilter
Overrides:
isNotificationEnabled in class NotificationFilterSupport
Parameters:
theNtf - The notification to be sent.
Returns:
true if the notification has to be sent to the listener, false otherwise.
Throws:
IllegalArgumentException - if null parameter
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Relation

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Interface Relation

All Known Subinterfaces:
RelationSupportMBean
All Known Implementing Classes:
RelationSupport
public interface Relation

This interface has to be implemented by any MBean class expected to represent a relation managed using the Relation Service.

Simple relations, i.e. having only roles, no properties or methods, can be created directly by the Relation Service (represented as RelationSupport objects, internally handled by the Relation Service).

If the user wants to represent more complex relations, involving properties and/or methods, he has to provide his own class implementing the Relation interface. This can be achieved either by inheriting from RelationSupport class, or by implementing the interface (fully or delegation to a RelationSupport object member).

Specifying such user relation class is to introduce properties and/or methods. Those have to be exposed for remote management. So this means that any user relation class must be a MBean class.

Method Summary
RoleResult | getAllRoles() Returns all roles present in the relation.
Map | getReferencedMBeans() Retrieves MBeans referenced in the various roles of the relation.
String | getRelationId() Returns relation identifier (used to uniquely identify the relation inside the Relation Service).
ObjectName | getRelationServiceName() Returns ObjectName of the Relation Service handling the relation.
String | getRelationTypeName() Returns name of associated relation type.
List | getRole(String theRoleName) Retrieves role value for given role name.
Integer | getRoleCardinality(String theRoleName) Returns the number of MBeans currently referenced in the given role.
RoleResult | getRoles(String[] theRoleNameArray) Retrieves values of roles with given names.
void | handleMBeanUnregistration(ObjectName theObjName, String theRoleName) Callback used by the Relation Service when a MBean referenced in a role is unregistered.
RoleList | retrieveAllRoles() Returns all roles in the relation without checking read mode.
void | setRole(Role theRole) Sets the given role.
RoleResult | setRoles(RoleList theRoleList) Sets the given roles.

Method Detail

getRole

public List getRole(String theRoleName)
             throws IllegalArgumentException,
                    RoleNotFoundException,
                    RelationServiceNotRegisteredException
Retrieves role value for given role name.

Checks if the role exists and is readable according to the relation type.

Parameters:
theRoleName - name of role
Returns:
the ArrayList of ObjectName objects being the role value
Throws:
IllegalArgumentException - if null role name
RoleNotFoundException - if:

- there is no role with given name

- the role is not readable.

RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
See Also:
setRole(javax.management.relation.Role)

getRoles

public RoleResult getRoles(String[] theRoleNameArray)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException
Retrieves values of roles with given names.

Checks for each role if it exists and is readable according to the relation type.

Parameters:
theRoleNameArray - array of names of roles to be retrieved
Returns:
a RoleResult object, including a RoleList (for roles succcessfully retrieved) and a RoleUnresolvedList (for roles not retrieved).
Throws:
IllegalArgumentException - if null role name
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
See Also:
setRoles(javax.management.relation.RoleList)

getRoleCardinality

public Integer getRoleCardinality(String theRoleName)
                           throws IllegalArgumentException,
                                  RoleNotFoundException
Returns the number of MBeans currently referenced in the given role.

Parameters:
theRoleName - name of role
Returns:
the number of currently referenced MBeans in that role
Throws:
IllegalArgumentException - if null role name
RoleNotFoundException - if there is no role with given name

getAllRoles

public RoleResult getAllRoles()
                       throws RelationServiceNotRegisteredException
Returns all roles present in the relation.

Returns:
a RoleResult object, including a RoleList (for roles succcessfully retrieved) and a RoleUnresolvedList (for roles not readable).
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server

retrieveAllRoles

public RoleList retrieveAllRoles()
Returns all roles in the relation without checking read mode.

Returns:
a RoleList.

setRole

public void setRole(Role theRole)
             throws IllegalArgumentException,
                    RoleNotFoundException,
                    RelationTypeNotFoundException,
                    InvalidRoleValueException,
                    RelationServiceNotRegisteredException,
                    RelationNotFoundException
Sets the given role.

Will check the role according to its corresponding role definition provided in relation's relation type

Will send a notification (RelationNotification with type RELATION_BASIC_UPDATE or RELATION_MBEAN_UPDATE, depending if the relation is a MBean or not).

Parameters:
theRole - role to be set (name and new value)
Throws:
IllegalArgumentException - if null role
RoleNotFoundException - if the role is not writable (no test on the write access mode performed when initialising the role)
InvalidRoleValueException - if value provided for role is not valid, i.e.:

- the number of referenced MBeans in given value is less than expected minimum degree

- the number of referenced MBeans in provided value exceeds expected maximum degree

- one referenced MBean in the value is not an Object of the MBean class expected for that role

- a MBean provided for that role does not exist.

RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service.
RelationNotFoundException - if the relation has not been added in the Relation Service.
See Also:
getRole(java.lang.String)

setRoles

public RoleResult setRoles(RoleList theRoleList)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException,
                           RelationTypeNotFoundException,
                           RelationNotFoundException
Sets the given roles.

Will check the role according to its corresponding role definition provided in relation's relation type

Will send one notification (RelationNotification with type RELATION_BASIC_UPDATE or RELATION_MBEAN_UPDATE, depending if the relation is a MBean or not) per updated role.

Parameters:
theRoleList - list of roles to be set
Returns:
a RoleResult object, including a RoleList (for roles succcessfully set) and a RoleUnresolvedList (for roles not set).
Throws:
IllegalArgumentException - if null role name
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service.
RelationNotFoundException - if the relation MBean has not been added in the Relation Service.
See Also:
getRoles(java.lang.String[])

handleMBeanUnregistration

public void handleMBeanUnregistration(ObjectName theObjName,
                                      String theRoleName)
                               throws IllegalArgumentException,
                                      RoleNotFoundException,
                                      InvalidRoleValueException,
                                      RelationServiceNotRegisteredException,
                                      RelationTypeNotFoundException,
                                      RelationNotFoundException
Callback used by the Relation Service when a MBean referenced in a role is unregistered.

The Relation Service will call this method to let the relation take action to reflect the impact of such unregistration.

BEWARE. the user is not expected to call this method.

Current implementation is to set the role with its current value (list of ObjectNames of referenced MBeans) without the unregistered one.

Parameters:
theObjName - ObjectName of unregistered MBean
theRoleName - name of role where the MBean is referenced
Throws:
IllegalArgumentException - if null parameter
RoleNotFoundException - if role does not exist in the relation or is not writable
InvalidRoleValueException - if role value does not conform to the associated role info (this will never happen when called from the Relation Service)
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service.
RelationNotFoundException - if this method is called for a relation MBean not added in the Relation Service.

getReferencedMBeans

public Map getReferencedMBeans()
Retrieves MBeans referenced in the various roles of the relation.

Returns:
a HashMap mapping:

ObjectName -> ArrayList of String (role names)

getRelationTypeName

public String getRelationTypeName()
Returns name of associated relation type.

Returns:
the name of the relation type.

getRelationServiceName

public ObjectName getRelationServiceName()
Returns ObjectName of the Relation Service handling the relation.

Returns:
the ObjectName of the Relation Service.

getRelationId

public String getRelationId()
Returns relation identifier (used to uniquely identify the relation inside the Relation Service).

Returns:
the relation id.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RelationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
InvalidRelationIdException, InvalidRelationServiceException, InvalidRelationTypeException, InvalidRoleInfoException, InvalidRoleValueException, RelationNotFoundException, RelationServiceNotRegisteredException, RelationTypeNotFoundException, RoleInfoNotFoundException, RoleNotFoundException
public class RelationException
extends JMException

This class is the superclass of any exception which can be raised during relation management.

See Also:
Serialized Form

Constructor Summary
RelationException()
Default constructor, no message put in exception.
RelationException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RelationException

public RelationException()
Default constructor, no message put in exception.

RelationException

public RelationException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RelationNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
                    extended by javax.management.relation.RelationNotFoundException
All Implemented Interfaces:
Serializable
public class RelationNotFoundException
extends RelationException

This exception is raised when there is no relation for a given relation id in a Relation Service.

See Also:
Serialized Form

Constructor Summary
RelationNotFoundException()
Default constructor, no message put in exception.
RelationNotFoundException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RelationNotFoundException

public RelationNotFoundException()
Default constructor, no message put in exception.

RelationNotFoundException

public RelationNotFoundException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationNotification

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RelationNotification

java.lang.Object
    extended by java.util.EventObject
        extended by javax.management.Notification
            extended by javax.management.relation.RelationNotification
All Implemented Interfaces:
Serializable
public class RelationNotification
extends Notification

A notification of a change in the Relation Service. A RelationNotification notification is sent when a relation is created via the Relation Service, or an MBean is added as a relation in the Relation Service, or a role is updated in a relation, or a relation is removed from the Relation Service.

See Also:
Serialized Form

Field Summary
static String | RELATION_BASIC_CREATION Type for the creation of an internal relation.
static String | RELATION_BASIC_REMOVAL Type for the removal from the Relation Service of an internal relation.
static String | RELATION_BASIC_UPDATE Type for an update of an internal relation.
static String | RELATION_MBEAN_CREATION Type for the relation MBean added into the Relation Service.
static String | RELATION_MBEAN_REMOVAL Type for the removal from the Relation Service of a relation MBean.
static String | RELATION_MBEAN_UPDATE Type for the update of a relation MBean.
Fields inherited from class javax.management.Notification
source
Constructor Summary
RelationNotification(String theNtfType, Object theSrcObj, long TheSeqNbr, long theTimeStamp, String theMsg, String theRelId, String theRelTypeName, ObjectName theRelObjName, List theUnregMBeanList)
Creates a notification for either a relation creation (RelationSupport object created internally in the Relation Service, or an MBean added as a relation) or for a relation removal from the Relation Service.
RelationNotification(String theNtfType, Object theSrcObj, long TheSeqNbr, long theTimeStamp, String theMsg, String theRelId, String theRelTypeName, ObjectName theRelObjName, String theRoleName, List theNewRoleValue, List theOldRoleValue)
Creates a notification for a role update in a relation.
Method Summary
List | getMBeansToUnregister() Returns the list of ObjectNames of MBeans expected to be unregistered due to a relation removal (only for relation removal).
List | getNewRoleValue() Returns new value of updated role (only for role update).
ObjectName | getObjectName() Returns the ObjectName of the created/removed/updated relation.
List | getOldRoleValue() Returns old value of updated role (only for role update).
String | getRelationId() Returns the relation identifier of created/removed/updated relation.
String | getRelationTypeName() Returns the relation type name of created/removed/updated relation.
String | getRoleName() Returns name of updated role of updated relation (only for role update).
Methods inherited from class javax.management.Notification
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RELATION_BASIC_CREATION

public static final String RELATION_BASIC_CREATION
Type for the creation of an internal relation.

See Also:
Constant Field Values

RELATION_MBEAN_CREATION

public static final String RELATION_MBEAN_CREATION
Type for the relation MBean added into the Relation Service.

See Also:
Constant Field Values

RELATION_BASIC_UPDATE

public static final String RELATION_BASIC_UPDATE
Type for an update of an internal relation.

See Also:
Constant Field Values

RELATION_MBEAN_UPDATE

public static final String RELATION_MBEAN_UPDATE
Type for the update of a relation MBean.

See Also:
Constant Field Values

RELATION_BASIC_REMOVAL

public static final String RELATION_BASIC_REMOVAL
Type for the removal from the Relation Service of an internal relation.

See Also:
Constant Field Values

RELATION_MBEAN_REMOVAL

public static final String RELATION_MBEAN_REMOVAL
Type for the removal from the Relation Service of a relation MBean.

See Also:
Constant Field Values
Constructor Detail

RelationNotification

public RelationNotification(String theNtfType,
                            Object theSrcObj,
                            long TheSeqNbr,
                            long theTimeStamp,
                            String theMsg,
                            String theRelId,
                            String theRelTypeName,
                            ObjectName theRelObjName,
                            List theUnregMBeanList)
                     throws IllegalArgumentException
Creates a notification for either a relation creation (RelationSupport object created internally in the Relation Service, or an MBean added as a relation) or for a relation removal from the Relation Service.

Parameters:
theNtfType - type of the notification; either:

- RELATION_BASIC_CREATION

- RELATION_MBEAN_CREATION

- RELATION_BASIC_REMOVAL

- RELATION_MBEAN_REMOVAL

theSrcObj - source object, sending the notification. Will always be a RelationService object.
TheSeqNbr - sequence number to identify the notification
theTimeStamp - time stamp
theMsg - human-readable message describing the notification
theRelId - relation id identifying the relation in the Relation Service
theRelTypeName - name of the relation type
theRelObjName - ObjectName of the relation object if it is an MBean (null for relations internally handled by the Relation Service)
theUnregMBeanList - list of ObjectNames of referenced MBeans expected to be unregistered due to relation removal (only for removal, due to CIM qualifiers, can be null)
Throws:
IllegalArgumentException - if:

- no value for the notification type

- the notification type is not RELATION_BASIC_CREATION, RELATION_MBEAN_CREATION, RELATION_BASIC_REMOVAL or RELATION_MBEAN_REMOVAL

- no source object

- the source object is not a Relation Service

- no relation id

- no relation type name

RelationNotification

public RelationNotification(String theNtfType,
                            Object theSrcObj,
                            long TheSeqNbr,
                            long theTimeStamp,
                            String theMsg,
                            String theRelId,
                            String theRelTypeName,
                            ObjectName theRelObjName,
                            String theRoleName,
                            List theNewRoleValue,
                            List theOldRoleValue)
                     throws IllegalArgumentException
Creates a notification for a role update in a relation.

Parameters:
theNtfType - type of the notification; either:

- RELATION_BASIC_UPDATE

- RELATION_MBEAN_UPDATE

theSrcObj - source object, sending the notification. Will always be a RelationService object.
TheSeqNbr - sequence number to identify the notification
theTimeStamp - time stamp
theMsg - human-readable message describing the notification
theRelId - relation id identifying the relation in the Relation Service
theRelTypeName - name of the relation type
theRelObjName - ObjectName of the relation object if it is an MBean (null for relations internally handled by the Relation Service)
theRoleName - name of the updated role
theNewRoleValue - new value (ArrayList of ObjectName objects)
theOldRoleValue - old value (ArrayList of ObjectName objects)
Throws:
IllegalArgumentException - if null parameter
Method Detail

getRelationId

public String getRelationId()
Returns the relation identifier of created/removed/updated relation.

Returns:
the relation id.

getRelationTypeName

public String getRelationTypeName()
Returns the relation type name of created/removed/updated relation.

Returns:
the relation type name.

getObjectName

public ObjectName getObjectName()
Returns the ObjectName of the created/removed/updated relation.

Returns:
the ObjectName if the relation is an MBean, otherwise null.

getMBeansToUnregister

public List getMBeansToUnregister()
Returns the list of ObjectNames of MBeans expected to be unregistered due to a relation removal (only for relation removal).

Returns:
a List of ObjectName.

getRoleName

public String getRoleName()
Returns name of updated role of updated relation (only for role update).

Returns:
the name of the updated role.

getOldRoleValue

public List getOldRoleValue()
Returns old value of updated role (only for role update).

Returns:
the old value of the updated role.

getNewRoleValue

public List getNewRoleValue()
Returns new value of updated role (only for role update).

Returns:
the new value of the updated role.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationService

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RelationService

java.lang.Object
    extended by javax.management.NotificationBroadcasterSupport
        extended by javax.management.relation.RelationService
All Implemented Interfaces:
EventListener, MBeanRegistration, NotificationBroadcaster, NotificationEmitter, NotificationListener, RelationServiceMBean
public class RelationService
extends NotificationBroadcasterSupport
implements RelationServiceMBean, MBeanRegistration, NotificationListener

The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.

It implements the NotificationBroadcaster by extending NotificationBroadcasterSupport to send notifications when a relation is removed from it.

It implements the NotificationListener interface to be able to receive notifications concerning unregistration of MBeans referenced in relation roles and of relation MBeans.

It implements the MBeanRegistration interface to be able to retrieve its ObjectName and MBean Server.

Constructor Summary
RelationService(boolean theImmediatePurgeFlg)
Constructor.
Method Summary
void | addRelation(ObjectName theRelObjectName) Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
void | addRelationType(RelationType theRelTypeObj) Adds given object as a relation type.
Integer | checkRoleReading(String theRoleName, String theRelTypeName) Checks if given Role can be read in a relation of the given type.
Integer | checkRoleWriting(Role theRole, String theRelTypeName, Boolean theInitFlg) Checks if given Role can be set in a relation of given type.
void | createRelation(String theRelId, String theRelTypeName, RoleList theRoleList) Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
void | createRelationType(String theRelTypeName, RoleInfo[] theRoleInfoArray) Creates a relation type (a RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
Map | findAssociatedMBeans(ObjectName theMBeanName, String theRelTypeName, String theRoleName) Retrieves the MBeans associated to given one in a relation.
Map | findReferencingRelations(ObjectName theMBeanName, String theRelTypeName, String theRoleName) Retrieves the relations where a given MBean is referenced.
List | findRelationsOfType(String theRelTypeName) Returns the relation ids for relations of the given type.
List | getAllRelationIds() Returns all the relation ids for all the relations handled by the Relation Service.
List | getAllRelationTypeNames() Retrieves names of all known relation types.
RoleResult | getAllRoles(String theRelId) Returns all roles present in the relation.
MBeanNotificationInfo[] | getNotificationInfo() Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent.
boolean | getPurgeFlag() Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.
Map | getReferencedMBeans(String theRelId) Retrieves MBeans referenced in the various roles of the relation.
String | getRelationTypeName(String theRelId) Returns name of associated relation type for given relation.
List | getRole(String theRelId, String theRoleName) Retrieves role value for given role name in given relation.
Integer | getRoleCardinality(String theRelId, String theRoleName) Retrieves the number of MBeans currently referenced in the given role.
RoleInfo | getRoleInfo(String theRelTypeName, String theRoleInfoName) Retrieves role info for given role name of a given relation type.
List | getRoleInfos(String theRelTypeName) Retrieves list of role infos (RoleInfo objects) of a given relation type.
RoleResult | getRoles(String theRelId, String[] theRoleNameArray) Retrieves values of roles with given names in given relation.
void | handleNotification(Notification theNtf, Object theHandback) Invoked when a JMX notification occurs.
Boolean | hasRelation(String theRelId) Checks if there is a relation identified in Relation Service with given relation id.
void | isActive() Checks if the Relation Service is active.
String | isRelation(ObjectName theObjName) Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
ObjectName | isRelationMBean(String theRelId) If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
void | postDeregister() Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
void | postRegister(Boolean registrationDone) Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
void | preDeregister() Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
ObjectName | preRegister(MBeanServer server, ObjectName name) Allows the MBean to perform any operations it needs before being registered in the MBean server.
void | purgeRelations() Purges the relations.
void | removeRelation(String theRelId) Removes given relation from the Relation Service.
void | removeRelationType(String theRelTypeName) Removes given relation type from Relation Service.
void | sendRelationCreationNotification(String theRelId) Sends a notification (RelationNotification) for a relation creation.
void | sendRelationRemovalNotification(String theRelId, List theUnregMBeanList) Sends a notification (RelationNotification) for a relation removal.
void | sendRoleUpdateNotification(String theRelId, Role theNewRole, List theOldRoleValue) Sends a notification (RelationNotification) for a role update in the given relation.
void | setPurgeFlag(boolean thePurgeFlg) Sets the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.
void | setRole(String theRelId, Role theRole) Sets the given role in given relation.
RoleResult | setRoles(String theRelId, RoleList theRoleList) Sets the given roles in given relation.
void | updateRoleMap(String theRelId, Role theNewRole, List theOldRoleValue) Handles update of the Relation Service role map for the update of given role in given relation.
Methods inherited from class javax.management.NotificationBroadcasterSupport
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RelationService

public RelationService(boolean theImmediatePurgeFlg)
Constructor.

Parameters:
theImmediatePurgeFlg - flag to indicate when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.

true is immediate purge.

Method Detail

isActive

public void isActive()
              throws RelationServiceNotRegisteredException
Checks if the Relation Service is active. Current condition is that the Relation Service must be registered in the MBean Server

Specified by:
isActive in interface RelationServiceMBean
Throws:
RelationServiceNotRegisteredException - if it is not registered

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
Description copied from interface: MBeanRegistration
Allows the MBean to perform any operations it needs before being registered in the MBean server. If the name of the MBean is not specified, the MBean can provide a name for its registration. If any exception is raised, the MBean will not be registered in the MBean server.

Specified by:
preRegister in interface MBeanRegistration
Parameters:
server - The MBean server in which the MBean will be registered.
name - The object name of the MBean. This name is null if the name parameter to one of the createMBean or registerMBean methods in the MBeanServer interface is null. In that case, this method must return a non-null ObjectName for the new MBean.
Returns:
The name under which the MBean is to be registered. This value must not be null. If the name parameter is not null, it will usually but not necessarily be the returned value.
Throws:
Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException or a RuntimeMBeanException.

postRegister

public void postRegister(Boolean registrationDone)
Description copied from interface: MBeanRegistration
Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

Specified by:
postRegister in interface MBeanRegistration
Parameters:
registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

preDeregister

public void preDeregister()
                   throws Exception
Description copied from interface: MBeanRegistration
Allows the MBean to perform any operations it needs before being unregistered by the MBean server.

Specified by:
preDeregister in interface MBeanRegistration
Throws:
Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException or a RuntimeMBeanException.

postDeregister

public void postDeregister()
Description copied from interface: MBeanRegistration
Allows the MBean to perform any operations needed after having been unregistered in the MBean server.

Specified by:
postDeregister in interface MBeanRegistration

getPurgeFlag

public boolean getPurgeFlag()
Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.

true is immediate purge.

Specified by:
getPurgeFlag in interface RelationServiceMBean
Returns:
true if purges are automatic.
See Also:
setPurgeFlag(boolean)

setPurgeFlag

public void setPurgeFlag(boolean thePurgeFlg)
Sets the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.

true is immediate purge.

Specified by:
setPurgeFlag in interface RelationServiceMBean
Parameters:
thePurgeFlg - flag
See Also:
getPurgeFlag()

createRelationType

public void createRelationType(String theRelTypeName,
                               RoleInfo[] theRoleInfoArray)
                        throws IllegalArgumentException,
                               InvalidRelationTypeException
Creates a relation type (a RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.

Specified by:
createRelationType in interface RelationServiceMBean
Parameters:
theRelTypeName - name of the relation type
theRoleInfoArray - array of role infos
Throws:
IllegalArgumentException - if null parameter
InvalidRelationTypeException - If:

- there is already a relation type with that name

- the same name has been used for two different role infos

- no role info provided

- one null role info provided

addRelationType

public void addRelationType(RelationType theRelTypeObj)
                     throws IllegalArgumentException,
                            InvalidRelationTypeException
Adds given object as a relation type. The object is expected to implement the RelationType interface.

Specified by:
addRelationType in interface RelationServiceMBean
Parameters:
theRelTypeObj - relation type object (implementing the RelationType interface)
Throws:
IllegalArgumentException - if null parameter
InvalidRelationTypeException - if:

- the same name has been used for two different roles

- no role info provided

- one null role info provided

- there is already a relation type with that name

getAllRelationTypeNames

public List getAllRelationTypeNames()
Retrieves names of all known relation types.

Specified by:
getAllRelationTypeNames in interface RelationServiceMBean
Returns:
ArrayList of relation type names (Strings)

getRoleInfos

public List getRoleInfos(String theRelTypeName)
                  throws IllegalArgumentException,
                         RelationTypeNotFoundException
Retrieves list of role infos (RoleInfo objects) of a given relation type.

Specified by:
getRoleInfos in interface RelationServiceMBean
Parameters:
theRelTypeName - name of relation type
Returns:
ArrayList of RoleInfo.
Throws:
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - if there is no relation type with that name.

getRoleInfo

public RoleInfo getRoleInfo(String theRelTypeName,
                            String theRoleInfoName)
                     throws IllegalArgumentException,
                            RelationTypeNotFoundException,
                            RoleInfoNotFoundException
Retrieves role info for given role name of a given relation type.

Specified by:
getRoleInfo in interface RelationServiceMBean
Parameters:
theRelTypeName - name of relation type
theRoleInfoName - name of role
Returns:
RoleInfo object.
Throws:
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - if the relation type is not known in the Relation Service
RoleInfoNotFoundException - if the role is not part of the relation type.

removeRelationType

public void removeRelationType(String theRelTypeName)
                        throws RelationServiceNotRegisteredException,
                               IllegalArgumentException,
                               RelationTypeNotFoundException
Removes given relation type from Relation Service.

The relation objects of that type will be removed from the Relation Service.

Specified by:
removeRelationType in interface RelationServiceMBean
Parameters:
theRelTypeName - name of the relation type to be removed
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - If there is no relation type with that name

createRelation

public void createRelation(String theRelId,
                           String theRelTypeName,
                           RoleList theRoleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RoleNotFoundException,
                           InvalidRelationIdException,
                           RelationTypeNotFoundException,
                           InvalidRoleValueException
Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.

Roles are initialized according to the role list provided in parameter. The ones not initialized in this way are set to an empty ArrayList of ObjectNames.

A RelationNotification, with type RELATION_BASIC_CREATION, is sent.

Specified by:
createRelation in interface RelationServiceMBean
Parameters:
theRelId - relation identifier, to identify uniquely the relation inside the Relation Service
theRelTypeName - name of the relation type (has to be created in the Relation Service)
theRoleList - role list to initialize roles of the relation (can be null).
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter, except the role lis which can be null if no role initialization
RoleNotFoundException - if a value is provided for a role that does not exist in the relation type
InvalidRelationIdException - if relation id already used
RelationTypeNotFoundException - if relation type not known in Relation Service
InvalidRoleValueException - if:

- the same role name is used for two different roles

- the number of referenced MBeans in given value is less than expected minimum degree

- the number of referenced MBeans in provided value exceeds expected maximum degree

- one referenced MBean in the value is not an Object of the MBean class expected for that role

- an MBean provided for that role does not exist

addRelation

public void addRelation(ObjectName theRelObjectName)
                 throws IllegalArgumentException,
                        RelationServiceNotRegisteredException,
                        NoSuchMethodException,
                        InvalidRelationIdException,
                        InstanceNotFoundException,
                        InvalidRelationServiceException,
                        RelationTypeNotFoundException,
                        RoleNotFoundException,
                        InvalidRoleValueException
Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.

To be added as a relation, the MBean must conform to the following:

- implement the Relation interface

- have for RelationService ObjectName the ObjectName of current Relation Service

- have a relation id unique and unused in current Relation Service

- have for relation type a relation type created in the Relation Service

- have roles conforming to the role info provided in the relation type.

Specified by:
addRelation in interface RelationServiceMBean
Parameters:
theRelObjectName - ObjectName of the relation MBean to be added.
Throws:
IllegalArgumentException - if null parameter
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
NoSuchMethodException - If the MBean does not implement the Relation interface
InvalidRelationIdException - if:

- no relation identifier in MBean

- the relation identifier is already used in the Relation Service

InstanceNotFoundException - if the MBean for given ObjectName has not been registered
InvalidRelationServiceException - if:

- no Relation Service name in MBean

- the Relation Service name in the MBean is not the one of the current Relation Service

RelationTypeNotFoundException - if:

- no relation type name in MBean

- the relation type name in MBean does not correspond to a relation type created in the Relation Service

InvalidRoleValueException - if:

- the number of referenced MBeans in a role is less than expected minimum degree

- the number of referenced MBeans in a role exceeds expected maximum degree

- one referenced MBean in the value is not an Object of the MBean class expected for that role

- an MBean provided for a role does not exist

RoleNotFoundException - if a value is provided for a role that does not exist in the relation type

isRelationMBean

public ObjectName isRelationMBean(String theRelId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.

Specified by:
isRelationMBean in interface RelationServiceMBean
Parameters:
theRelId - relation id identifying the relation
Returns:
ObjectName of the corresponding relation MBean, or null if the relation is not an MBean.
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - there is no relation associated to that id

isRelation

public String isRelation(ObjectName theObjName)
                  throws IllegalArgumentException
Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.

Specified by:
isRelation in interface RelationServiceMBean
Parameters:
theObjName - ObjectName of supposed relation
Returns:
relation id (String) or null (if the ObjectName is not a relation handled by the Relation Service)
Throws:
IllegalArgumentException - if null parameter

hasRelation

public Boolean hasRelation(String theRelId)
                    throws IllegalArgumentException
Checks if there is a relation identified in Relation Service with given relation id.

Specified by:
hasRelation in interface RelationServiceMBean
Parameters:
theRelId - relation id identifying the relation
Returns:
boolean: true if there is a relation, false else
Throws:
IllegalArgumentException - if null parameter

getAllRelationIds

public List getAllRelationIds()
Returns all the relation ids for all the relations handled by the Relation Service.

Specified by:
getAllRelationIds in interface RelationServiceMBean
Returns:
ArrayList of String

checkRoleReading

public Integer checkRoleReading(String theRoleName,
                                String theRelTypeName)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
Checks if given Role can be read in a relation of the given type.

Specified by:
checkRoleReading in interface RelationServiceMBean
Parameters:
theRoleName - name of role to be checked
theRelTypeName - name of the relation type
Returns:
an Integer wrapping an integer corresponding to possible problems represented as constants in RoleUnresolved:

- 0 if role can be read

- integer corresponding to RoleStatus.NO_ROLE_WITH_NAME

- integer corresponding to RoleStatus.ROLE_NOT_READABLE

Throws:
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - if the relation type is not known in the Relation Service

checkRoleWriting

public Integer checkRoleWriting(Role theRole,
                                String theRelTypeName,
                                Boolean theInitFlg)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
Checks if given Role can be set in a relation of given type.

Specified by:
checkRoleWriting in interface RelationServiceMBean
Parameters:
theRole - role to be checked
theRelTypeName - name of relation type
theInitFlg - flag to specify that the checking is done for the initialization of a role, write access shall not be verified.
Returns:
an Integer wrapping an integer corresponding to possible problems represented as constants in RoleUnresolved:

- 0 if role can be set

- integer corresponding to RoleStatus.NO_ROLE_WITH_NAME

- integer for RoleStatus.ROLE_NOT_WRITABLE

- integer for RoleStatus.LESS_THAN_MIN_ROLE_DEGREE

- integer for RoleStatus.MORE_THAN_MAX_ROLE_DEGREE

- integer for RoleStatus.REF_MBEAN_OF_INCORRECT_CLASS

- integer for RoleStatus.REF_MBEAN_NOT_REGISTERED

Throws:
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - if unknown relation type

sendRelationCreationNotification

public void sendRelationCreationNotification(String theRelId)
                                      throws IllegalArgumentException,
                                             RelationNotFoundException
Sends a notification (RelationNotification) for a relation creation. The notification type is:

- RelationNotification.RELATION_BASIC_CREATION if the relation is an object internal to the Relation Service

- RelationNotification.RELATION_MBEAN_CREATION if the relation is a MBean added as a relation.

The source object is the Relation Service itself.

It is called in Relation Service createRelation() and addRelation() methods.

Specified by:
sendRelationCreationNotification in interface RelationServiceMBean
Parameters:
theRelId - relation identifier of the updated relation
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if there is no relation for given relation id

sendRoleUpdateNotification

public void sendRoleUpdateNotification(String theRelId,
                                       Role theNewRole,
                                       List theOldRoleValue)
                                throws IllegalArgumentException,
                                       RelationNotFoundException
Sends a notification (RelationNotification) for a role update in the given relation. The notification type is:

- RelationNotification.RELATION_BASIC_UPDATE if the relation is an object internal to the Relation Service

- RelationNotification.RELATION_MBEAN_UPDATE if the relation is a MBean added as a relation.

The source object is the Relation Service itself.

It is called in relation MBean setRole() (for given role) and setRoles() (for each role) methods (implementation provided in RelationSupport class).

It is also called in Relation Service setRole() (for given role) and setRoles() (for each role) methods.

Specified by:
sendRoleUpdateNotification in interface RelationServiceMBean
Parameters:
theRelId - relation identifier of the updated relation
theNewRole - new role (name and new value)
theOldRoleValue - old role value (ArrayList of ObjectName objects)
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if there is no relation for given relation id

sendRelationRemovalNotification

public void sendRelationRemovalNotification(String theRelId,
                                            List theUnregMBeanList)
                                     throws IllegalArgumentException,
                                            RelationNotFoundException
Sends a notification (RelationNotification) for a relation removal. The notification type is:

- RelationNotification.RELATION_BASIC_REMOVAL if the relation is an object internal to the Relation Service

- RelationNotification.RELATION_MBEAN_REMOVAL if the relation is a MBean added as a relation.

The source object is the Relation Service itself.

It is called in Relation Service removeRelation() method.

Specified by:
sendRelationRemovalNotification in interface RelationServiceMBean
Parameters:
theRelId - relation identifier of the updated relation
theUnregMBeanList - ArrayList of ObjectNames of MBeans expected to be unregistered due to relation removal (can be null)
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if there is no relation for given relation id

updateRoleMap

public void updateRoleMap(String theRelId,
                          Role theNewRole,
                          List theOldRoleValue)
                   throws IllegalArgumentException,
                          RelationServiceNotRegisteredException,
                          RelationNotFoundException
Handles update of the Relation Service role map for the update of given role in given relation.

It is called in relation MBean setRole() (for given role) and setRoles() (for each role) methods (implementation provided in RelationSupport class).

It is also called in Relation Service setRole() (for given role) and setRoles() (for each role) methods.

To allow the Relation Service to maintain the consistency (in case of MBean unregistration) and to be able to perform queries, this method must be called when a role is updated.

Specified by:
updateRoleMap in interface RelationServiceMBean
Parameters:
theRelId - relation identifier of the updated relation
theNewRole - new role (name and new value)
theOldRoleValue - old role value (ArrayList of ObjectName objects)
Throws:
IllegalArgumentException - if null parameter
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
RelationNotFoundException - if no relation for given id.

removeRelation

public void removeRelation(String theRelId)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
Removes given relation from the Relation Service.

A RelationNotification notification is sent, its type being:

- RelationNotification.RELATION_BASIC_REMOVAL if the relation was only internal to the Relation Service

- RelationNotification.RELATION_MBEAN_REMOVAL if the relation is registered as an MBean.

For MBeans referenced in such relation, nothing will be done,

Specified by:
removeRelation in interface RelationServiceMBean
Parameters:
theRelId - relation id of the relation to be removed
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation corresponding to given relation id

purgeRelations

public void purgeRelations()
                    throws RelationServiceNotRegisteredException
Purges the relations.

Depending on the purgeFlag value, this method is either called automatically when a notification is received for the unregistration of an MBean referenced in a relation (if the flag is set to true), or not (if the flag is set to false).

In that case it is up to the user to call it to maintain the consistency of the relations. To be kept in mind that if an MBean is unregistered and the purge not done immediately, if the ObjectName is reused and assigned to another MBean referenced in a relation, calling manually this purgeRelations() method will cause trouble, as will consider the ObjectName as corresponding to the unregistered MBean, not seeing the new one.

The behavior depends on the cardinality of the role where the unregistered MBean is referenced:

- if removing one MBean reference in the role makes its number of references less than the minimum degree, the relation has to be removed.

- if the remaining number of references after removing the MBean reference is still in the cardinality range, keep the relation and update it calling its handleMBeanUnregistration() callback.

Specified by:
purgeRelations in interface RelationServiceMBean
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server.

findReferencingRelations

public Map findReferencingRelations(ObjectName theMBeanName,
                                    String theRelTypeName,
                                    String theRoleName)
                             throws IllegalArgumentException
Retrieves the relations where a given MBean is referenced.

This corresponds to the CIM "References" and "ReferenceNames" operations.

Specified by:
findReferencingRelations in interface RelationServiceMBean
Parameters:
theMBeanName - ObjectName of MBean
theRelTypeName - can be null; if specified, only the relations of that type will be considered in the search. Else all relation types are considered.
theRoleName - can be null; if specified, only the relations where the MBean is referenced in that role will be returned. Else all roles are considered.
Returns:
an HashMap, where the keys are the relation ids of the relations where the MBean is referenced, and the value is, for each key, an ArrayList of role names (as an MBean can be referenced in several roles in the same relation).
Throws:
IllegalArgumentException - if null parameter

findAssociatedMBeans

public Map findAssociatedMBeans(ObjectName theMBeanName,
                                String theRelTypeName,
                                String theRoleName)
                         throws IllegalArgumentException
Retrieves the MBeans associated to given one in a relation.

This corresponds to CIM Associators and AssociatorNames operations.

Specified by:
findAssociatedMBeans in interface RelationServiceMBean
Parameters:
theMBeanName - ObjectName of MBean
theRelTypeName - can be null; if specified, only the relations of that type will be considered in the search. Else all relation types are considered.
theRoleName - can be null; if specified, only the relations where the MBean is referenced in that role will be considered. Else all roles are considered.
Returns:
an HashMap, where the keys are the ObjectNames of the MBeans associated to given MBean, and the value is, for each key, an ArrayList of the relation ids of the relations where the key MBean is associated to given one (as they can be associated in several different relations).
Throws:
IllegalArgumentException - if null parameter

findRelationsOfType

public List findRelationsOfType(String theRelTypeName)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
Returns the relation ids for relations of the given type.

Specified by:
findRelationsOfType in interface RelationServiceMBean
Parameters:
theRelTypeName - relation type name
Returns:
an ArrayList of relation ids.
Throws:
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - if there is no relation type with that name.

getRole

public List getRole(String theRelId,
                    String theRoleName)
             throws RelationServiceNotRegisteredException,
                    IllegalArgumentException,
                    RelationNotFoundException,
                    RoleNotFoundException
Retrieves role value for given role name in given relation.

Specified by:
getRole in interface RelationServiceMBean
Parameters:
theRelId - relation id
theRoleName - name of role
Returns:
the ArrayList of ObjectName objects being the role value
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation with given id
RoleNotFoundException - if:

- there is no role with given name

or

- the role is not readable.

See Also:
setRole(java.lang.String, javax.management.relation.Role)

getRoles

public RoleResult getRoles(String theRelId,
                           String[] theRoleNameArray)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
Retrieves values of roles with given names in given relation.

Specified by:
getRoles in interface RelationServiceMBean
Parameters:
theRelId - relation id
theRoleNameArray - array of names of roles to be retrieved
Returns:
a RoleResult object, including a RoleList (for roles succcessfully retrieved) and a RoleUnresolvedList (for roles not retrieved).
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation with given id
See Also:
setRoles(java.lang.String, javax.management.relation.RoleList)

getAllRoles

public RoleResult getAllRoles(String theRelId)
                       throws IllegalArgumentException,
                              RelationNotFoundException,
                              RelationServiceNotRegisteredException
Returns all roles present in the relation.

Specified by:
getAllRoles in interface RelationServiceMBean
Parameters:
theRelId - relation id
Returns:
a RoleResult object, including a RoleList (for roles succcessfully retrieved) and a RoleUnresolvedList (for roles not readable).
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation for given id
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server

getRoleCardinality

public Integer getRoleCardinality(String theRelId,
                                  String theRoleName)
                           throws IllegalArgumentException,
                                  RelationNotFoundException,
                                  RoleNotFoundException
Retrieves the number of MBeans currently referenced in the given role.

Specified by:
getRoleCardinality in interface RelationServiceMBean
Parameters:
theRelId - relation id
theRoleName - name of role
Returns:
the number of currently referenced MBeans in that role
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation with given id
RoleNotFoundException - if there is no role with given name

setRole

public void setRole(String theRelId,
                    Role theRole)
             throws RelationServiceNotRegisteredException,
                    IllegalArgumentException,
                    RelationNotFoundException,
                    RoleNotFoundException,
                    InvalidRoleValueException
Sets the given role in given relation.

Will check the role according to its corresponding role definition provided in relation's relation type

The Relation Service will keep track of the change to keep the consistency of relations by handling referenced MBean unregistrations.

Specified by:
setRole in interface RelationServiceMBean
Parameters:
theRelId - relation id
theRole - role to be set (name and new value)
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation with given id
RoleNotFoundException - if the role does not exist or is not writable
InvalidRoleValueException - if value provided for role is not valid:

- the number of referenced MBeans in given value is less than expected minimum degree

or

- the number of referenced MBeans in provided value exceeds expected maximum degree

or

- one referenced MBean in the value is not an Object of the MBean class expected for that role

or

- an MBean provided for that role does not exist

See Also:
getRole(java.lang.String, java.lang.String)

setRoles

public RoleResult setRoles(String theRelId,
                           RoleList theRoleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
Sets the given roles in given relation.

Will check the role according to its corresponding role definition provided in relation's relation type

The Relation Service keeps track of the changes to keep the consistency of relations by handling referenced MBean unregistrations.

Specified by:
setRoles in interface RelationServiceMBean
Parameters:
theRelId - relation id
theRoleList - list of roles to be set
Returns:
a RoleResult object, including a RoleList (for roles succcessfully set) and a RoleUnresolvedList (for roles not set).
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation with given id
See Also:
getRoles(java.lang.String, java.lang.String[])

getReferencedMBeans

public Map getReferencedMBeans(String theRelId)
                        throws IllegalArgumentException,
                               RelationNotFoundException
Retrieves MBeans referenced in the various roles of the relation.

Specified by:
getReferencedMBeans in interface RelationServiceMBean
Parameters:
theRelId - relation id
Returns:
a HashMap mapping:

ObjectName -> ArrayList of String (role names)

Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation for given relation id

getRelationTypeName

public String getRelationTypeName(String theRelId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
Returns name of associated relation type for given relation.

Specified by:
getRelationTypeName in interface RelationServiceMBean
Parameters:
theRelId - relation id
Returns:
the name of the associated relation type.
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation for given relation id

handleNotification

public void handleNotification(Notification theNtf,
                               Object theHandback)
Invoked when a JMX notification occurs. Currently handles notifications for unregistration of MBeans, either referenced in a relation role or being a relation itself.

Specified by:
handleNotification in interface NotificationListener
Parameters:
theNtf - The notification.
theHandback - An opaque object which helps the listener to associate information regarding the MBean emitter (can be null).

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent.

Specified by:
getNotificationInfo in interface NotificationBroadcaster
Overrides:
getNotificationInfo in class NotificationBroadcasterSupport
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationServiceMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Interface RelationServiceMBean

All Known Implementing Classes:
RelationService
public interface RelationServiceMBean

The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.

Method Summary
void | addRelation(ObjectName theRelObjectName) Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
void | addRelationType(RelationType theRelTypeObj) Adds given object as a relation type.
Integer | checkRoleReading(String theRoleName, String theRelTypeName) Checks if given Role can be read in a relation of the given type.
Integer | checkRoleWriting(Role theRole, String theRelTypeName, Boolean theInitFlg) Checks if given Role can be set in a relation of given type.
void | createRelation(String theRelId, String theRelTypeName, RoleList theRoleList) Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
void | createRelationType(String theRelTypeName, RoleInfo[] theRoleInfoArray) Creates a relation type (RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
Map | findAssociatedMBeans(ObjectName theMBeanName, String theRelTypeName, String theRoleName) Retrieves the MBeans associated to given one in a relation.
Map | findReferencingRelations(ObjectName theMBeanName, String theRelTypeName, String theRoleName) Retrieves the relations where a given MBean is referenced.
List | findRelationsOfType(String theRelTypeName) Returns the relation ids for relations of the given type.
List | getAllRelationIds() Returns all the relation ids for all the relations handled by the Relation Service.
List | getAllRelationTypeNames() Retrieves names of all known relation types.
RoleResult | getAllRoles(String theRelId) Returns all roles present in the relation.
boolean | getPurgeFlag() Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.
Map | getReferencedMBeans(String theRelId) Retrieves MBeans referenced in the various roles of the relation.
String | getRelationTypeName(String theRelId) Returns name of associated relation type for given relation.
List | getRole(String theRelId, String theRoleName) Retrieves role value for given role name in given relation.
Integer | getRoleCardinality(String theRelId, String theRoleName) Retrieves the number of MBeans currently referenced in the given role.
RoleInfo | getRoleInfo(String theRelTypeName, String theRoleInfoName) Retrieves role info for given role of a given relation type.
List | getRoleInfos(String theRelTypeName) Retrieves list of role infos (RoleInfo objects) of a given relation type.
RoleResult | getRoles(String theRelId, String[] theRoleNameArray) Retrieves values of roles with given names in given relation.
Boolean | hasRelation(String theRelId) Checks if there is a relation identified in Relation Service with given relation id.
void | isActive() Checks if the Relation Service is active.
String | isRelation(ObjectName theObjName) Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
ObjectName | isRelationMBean(String theRelId) If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
void | purgeRelations() Purges the relations.
void | removeRelation(String theRelId) Removes given relation from the Relation Service.
void | removeRelationType(String theRelTypeName) Removes given relation type from Relation Service.
void | sendRelationCreationNotification(String theRelId) Sends a notification (RelationNotification) for a relation creation.
void | sendRelationRemovalNotification(String theRelId, List theUnregMBeanList) Sends a notification (RelationNotification) for a relation removal.
void | sendRoleUpdateNotification(String theRelId, Role theNewRole, List theOldRoleValue) Sends a notification (RelationNotification) for a role update in the given relation.
void | setPurgeFlag(boolean thePurgeFlg) Sets the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.
void | setRole(String theRelId, Role theRole) Sets the given role in given relation.
RoleResult | setRoles(String theRelId, RoleList theRoleList) Sets the given roles in given relation.
void | updateRoleMap(String theRelId, Role theNewRole, List theOldRoleValue) Handles update of the Relation Service role map for the update of given role in given relation.

Method Detail

isActive

public void isActive()
              throws RelationServiceNotRegisteredException
Checks if the Relation Service is active. Current condition is that the Relation Service must be registered in the MBean Server

Throws:
RelationServiceNotRegisteredException - if it is not registered

getPurgeFlag

public boolean getPurgeFlag()
Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.

true is immediate purge.

Returns:
true if purges are immediate.
See Also:
setPurgeFlag(boolean)

setPurgeFlag

public void setPurgeFlag(boolean thePurgeFlg)
Sets the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.

true is immediate purge.

Parameters:
thePurgeFlg - flag
See Also:
getPurgeFlag()

createRelationType

public void createRelationType(String theRelTypeName,
                               RoleInfo[] theRoleInfoArray)
                        throws IllegalArgumentException,
                               InvalidRelationTypeException
Creates a relation type (RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.

Parameters:
theRelTypeName - name of the relation type
theRoleInfoArray - array of role infos
Throws:
IllegalArgumentException - if null parameter
InvalidRelationTypeException - If:

- there is already a relation type with that name

- the same name has been used for two different role infos

- no role info provided

- one null role info provided

addRelationType

public void addRelationType(RelationType theRelTypeObj)
                     throws IllegalArgumentException,
                            InvalidRelationTypeException
Adds given object as a relation type. The object is expected to implement the RelationType interface.

Parameters:
theRelTypeObj - relation type object (implementing the RelationType interface)
Throws:
IllegalArgumentException - if null parameter
InvalidRelationTypeException - if there is already a relation type with that name

getAllRelationTypeNames

public List getAllRelationTypeNames()
Retrieves names of all known relation types.

Returns:
ArrayList of relation type names (Strings)

getRoleInfos

public List getRoleInfos(String theRelTypeName)
                  throws IllegalArgumentException,
                         RelationTypeNotFoundException
Retrieves list of role infos (RoleInfo objects) of a given relation type.

Parameters:
theRelTypeName - name of relation type
Returns:
ArrayList of RoleInfo.
Throws:
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - if there is no relation type with that name.

getRoleInfo

public RoleInfo getRoleInfo(String theRelTypeName,
                            String theRoleInfoName)
                     throws IllegalArgumentException,
                            RelationTypeNotFoundException,
                            RoleInfoNotFoundException
Retrieves role info for given role of a given relation type.

Parameters:
theRelTypeName - name of relation type
theRoleInfoName - name of role
Returns:
RoleInfo object.
Throws:
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - if the relation type is not known in the Relation Service
RoleInfoNotFoundException - if the role is not part of the relation type.

removeRelationType

public void removeRelationType(String theRelTypeName)
                        throws RelationServiceNotRegisteredException,
                               IllegalArgumentException,
                               RelationTypeNotFoundException
Removes given relation type from Relation Service.

The relation objects of that type will be removed from the Relation Service.

Parameters:
theRelTypeName - name of the relation type to be removed
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - If there is no relation type with that name

createRelation

public void createRelation(String theRelId,
                           String theRelTypeName,
                           RoleList theRoleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RoleNotFoundException,
                           InvalidRelationIdException,
                           RelationTypeNotFoundException,
                           InvalidRoleValueException
Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.

Roles are initialized according to the role list provided in parameter. The ones not initialized in this way are set to an empty ArrayList of ObjectNames.

A RelationNotification, with type RELATION_BASIC_CREATION, is sent.

Parameters:
theRelId - relation identifier, to identify uniquely the relation inside the Relation Service
theRelTypeName - name of the relation type (has to be created in the Relation Service)
theRoleList - role list to initialize roles of the relation (can be null).
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null paramater
RoleNotFoundException - if a value is provided for a role that does not exist in the relation type
InvalidRelationIdException - if relation id already used
RelationTypeNotFoundException - if relation type not known in Relation Service
InvalidRoleValueException - if:

- the same role name is used for two different roles

- the number of referenced MBeans in given value is less than expected minimum degree

- the number of referenced MBeans in provided value exceeds expected maximum degree

- one referenced MBean in the value is not an Object of the MBean class expected for that role

- an MBean provided for that role does not exist

addRelation

public void addRelation(ObjectName theRelObjectName)
                 throws IllegalArgumentException,
                        RelationServiceNotRegisteredException,
                        NoSuchMethodException,
                        InvalidRelationIdException,
                        InstanceNotFoundException,
                        InvalidRelationServiceException,
                        RelationTypeNotFoundException,
                        RoleNotFoundException,
                        InvalidRoleValueException
Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.

To be added as a relation, the MBean must conform to the following:

- implement the Relation interface

- have for RelationService ObjectName the ObjectName of current Relation Service

- have a relation id that is unique and unused in current Relation Service

- have for relation type a relation type created in the Relation Service

- have roles conforming to the role info provided in the relation type.

Parameters:
theRelObjectName - ObjectName of the relation MBean to be added.
Throws:
IllegalArgumentException - if null parameter
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
NoSuchMethodException - If the MBean does not implement the Relation interface
InvalidRelationIdException - if:

- no relation identifier in MBean

- the relation identifier is already used in the Relation Service

InstanceNotFoundException - if the MBean for given ObjectName has not been registered
InvalidRelationServiceException - if:

- no Relation Service name in MBean

- the Relation Service name in the MBean is not the one of the current Relation Service

RelationTypeNotFoundException - if:

- no relation type name in MBean

- the relation type name in MBean does not correspond to a relation type created in the Relation Service

InvalidRoleValueException - if:

- the number of referenced MBeans in a role is less than expected minimum degree

- the number of referenced MBeans in a role exceeds expected maximum degree

- one referenced MBean in the value is not an Object of the MBean class expected for that role

- an MBean provided for a role does not exist

RoleNotFoundException - if a value is provided for a role that does not exist in the relation type

isRelationMBean

public ObjectName isRelationMBean(String theRelId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.

Parameters:
theRelId - relation id identifying the relation
Returns:
ObjectName of the corresponding relation MBean, or null if the relation is not an MBean.
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - there is no relation associated to that id

isRelation

public String isRelation(ObjectName theObjName)
                  throws IllegalArgumentException
Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.

Parameters:
theObjName - ObjectName of supposed relation
Returns:
relation id (String) or null (if the ObjectName is not a relation handled by the Relation Service)
Throws:
IllegalArgumentException - if null parameter

hasRelation

public Boolean hasRelation(String theRelId)
                    throws IllegalArgumentException
Checks if there is a relation identified in Relation Service with given relation id.

Parameters:
theRelId - relation id identifying the relation
Returns:
boolean: true if there is a relation, false else
Throws:
IllegalArgumentException - if null parameter

getAllRelationIds

public List getAllRelationIds()
Returns all the relation ids for all the relations handled by the Relation Service.

Returns:
ArrayList of String

checkRoleReading

public Integer checkRoleReading(String theRoleName,
                                String theRelTypeName)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
Checks if given Role can be read in a relation of the given type.

Parameters:
theRoleName - name of role to be checked
theRelTypeName - name of the relation type
Returns:
an Integer wrapping an integer corresponding to possible problems represented as constants in RoleUnresolved:

- 0 if role can be read

- integer corresponding to RoleStatus.NO_ROLE_WITH_NAME

- integer corresponding to RoleStatus.ROLE_NOT_READABLE

Throws:
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - if the relation type is not known in the Relation Service

checkRoleWriting

public Integer checkRoleWriting(Role theRole,
                                String theRelTypeName,
                                Boolean theInitFlg)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
Checks if given Role can be set in a relation of given type.

Parameters:
theRole - role to be checked
theRelTypeName - name of relation type
theInitFlg - flag to specify that the checking is done for the initialization of a role, write access shall not be verified.
Returns:
an Integer wrapping an integer corresponding to possible problems represented as constants in RoleUnresolved:

- 0 if role can be set

- integer corresponding to RoleStatus.NO_ROLE_WITH_NAME

- integer for RoleStatus.ROLE_NOT_WRITABLE

- integer for RoleStatus.LESS_THAN_MIN_ROLE_DEGREE

- integer for RoleStatus.MORE_THAN_MAX_ROLE_DEGREE

- integer for RoleStatus.REF_MBEAN_OF_INCORRECT_CLASS

- integer for RoleStatus.REF_MBEAN_NOT_REGISTERED

Throws:
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - if unknown relation type

sendRelationCreationNotification

public void sendRelationCreationNotification(String theRelId)
                                      throws IllegalArgumentException,
                                             RelationNotFoundException
Sends a notification (RelationNotification) for a relation creation. The notification type is:

- RelationNotification.RELATION_BASIC_CREATION if the relation is an object internal to the Relation Service

- RelationNotification.RELATION_MBEAN_CREATION if the relation is a MBean added as a relation.

The source object is the Relation Service itself.

It is called in Relation Service createRelation() and addRelation() methods.

Parameters:
theRelId - relation identifier of the updated relation
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if there is no relation for given relation id

sendRoleUpdateNotification

public void sendRoleUpdateNotification(String theRelId,
                                       Role theNewRole,
                                       List theOldRoleValue)
                                throws IllegalArgumentException,
                                       RelationNotFoundException
Sends a notification (RelationNotification) for a role update in the given relation. The notification type is:

- RelationNotification.RELATION_BASIC_UPDATE if the relation is an object internal to the Relation Service

- RelationNotification.RELATION_MBEAN_UPDATE if the relation is a MBean added as a relation.

The source object is the Relation Service itself.

It is called in relation MBean setRole() (for given role) and setRoles() (for each role) methods (implementation provided in RelationSupport class).

It is also called in Relation Service setRole() (for given role) and setRoles() (for each role) methods.

Parameters:
theRelId - relation identifier of the updated relation
theNewRole - new role (name and new value)
theOldRoleValue - old role value (ArrayList of ObjectName objects)
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if there is no relation for given relation id

sendRelationRemovalNotification

public void sendRelationRemovalNotification(String theRelId,
                                            List theUnregMBeanList)
                                     throws IllegalArgumentException,
                                            RelationNotFoundException
Sends a notification (RelationNotification) for a relation removal. The notification type is:

- RelationNotification.RELATION_BASIC_REMOVAL if the relation is an object internal to the Relation Service

- RelationNotification.RELATION_MBEAN_REMOVAL if the relation is a MBean added as a relation.

The source object is the Relation Service itself.

It is called in Relation Service removeRelation() method.

Parameters:
theRelId - relation identifier of the updated relation
theUnregMBeanList - ArrayList of ObjectNames of MBeans expected to be unregistered due to relation removal (can be null)
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if there is no relation for given relation id

updateRoleMap

public void updateRoleMap(String theRelId,
                          Role theNewRole,
                          List theOldRoleValue)
                   throws IllegalArgumentException,
                          RelationServiceNotRegisteredException,
                          RelationNotFoundException
Handles update of the Relation Service role map for the update of given role in given relation.

It is called in relation MBean setRole() (for given role) and setRoles() (for each role) methods (implementation provided in RelationSupport class).

It is also called in Relation Service setRole() (for given role) and setRoles() (for each role) methods.

To allow the Relation Service to maintain the consistency (in case of MBean unregistration) and to be able to perform queries, this method must be called when a role is updated.

Parameters:
theRelId - relation identifier of the updated relation
theNewRole - new role (name and new value)
theOldRoleValue - old role value (ArrayList of ObjectName objects)
Throws:
IllegalArgumentException - if null parameter
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
RelationNotFoundException - if no relation for given id.

removeRelation

public void removeRelation(String theRelId)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
Removes given relation from the Relation Service.

A RelationNotification notification is sent, its type being:

- RelationNotification.RELATION_BASIC_REMOVAL if the relation was only internal to the Relation Service

- RelationNotification.RELATION_MBEAN_REMOVAL if the relation is registered as an MBean.

For MBeans referenced in such relation, nothing will be done,

Parameters:
theRelId - relation id of the relation to be removed
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation corresponding to given relation id

purgeRelations

public void purgeRelations()
                    throws RelationServiceNotRegisteredException
Purges the relations.

Depending on the purgeFlag value, this method is either called automatically when a notification is received for the unregistration of an MBean referenced in a relation (if the flag is set to true), or not (if the flag is set to false).

In that case it is up to the user to call it to maintain the consistency of the relations. To be kept in mind that if an MBean is unregistered and the purge not done immediately, if the ObjectName is reused and assigned to another MBean referenced in a relation, calling manually this purgeRelations() method will cause trouble, as will consider the ObjectName as corresponding to the unregistered MBean, not seeing the new one.

The behavior depends on the cardinality of the role where the unregistered MBean is referenced:

- if removing one MBean reference in the role makes its number of references less than the minimum degree, the relation has to be removed.

- if the remaining number of references after removing the MBean reference is still in the cardinality range, keep the relation and update it calling its handleMBeanUnregistration() callback.

Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server.

findReferencingRelations

public Map findReferencingRelations(ObjectName theMBeanName,
                                    String theRelTypeName,
                                    String theRoleName)
                             throws IllegalArgumentException
Retrieves the relations where a given MBean is referenced.

This corresponds to the CIM "References" and "ReferenceNames" operations.

Parameters:
theMBeanName - ObjectName of MBean
theRelTypeName - can be null; if specified, only the relations of that type will be considered in the search. Else all relation types are considered.
theRoleName - can be null; if specified, only the relations where the MBean is referenced in that role will be returned. Else all roles are considered.
Returns:
an HashMap, where the keys are the relation ids of the relations where the MBean is referenced, and the value is, for each key, an ArrayList of role names (as an MBean can be referenced in several roles in the same relation).
Throws:
IllegalArgumentException - if null parameter

findAssociatedMBeans

public Map findAssociatedMBeans(ObjectName theMBeanName,
                                String theRelTypeName,
                                String theRoleName)
                         throws IllegalArgumentException
Retrieves the MBeans associated to given one in a relation.

This corresponds to CIM Associators and AssociatorNames operations.

Parameters:
theMBeanName - ObjectName of MBean
theRelTypeName - can be null; if specified, only the relations of that type will be considered in the search. Else all relation types are considered.
theRoleName - can be null; if specified, only the relations where the MBean is referenced in that role will be considered. Else all roles are considered.
Returns:
an HashMap, where the keys are the ObjectNames of the MBeans associated to given MBean, and the value is, for each key, an ArrayList of the relation ids of the relations where the key MBean is associated to given one (as they can be associated in several different relations).
Throws:
IllegalArgumentException - if null parameter

findRelationsOfType

public List findRelationsOfType(String theRelTypeName)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
Returns the relation ids for relations of the given type.

Parameters:
theRelTypeName - relation type name
Returns:
an ArrayList of relation ids.
Throws:
IllegalArgumentException - if null parameter
RelationTypeNotFoundException - if there is no relation type with that name.

getRole

public List getRole(String theRelId,
                    String theRoleName)
             throws RelationServiceNotRegisteredException,
                    IllegalArgumentException,
                    RelationNotFoundException,
                    RoleNotFoundException
Retrieves role value for given role name in given relation.

Parameters:
theRelId - relation id
theRoleName - name of role
Returns:
the ArrayList of ObjectName objects being the role value
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation with given id
RoleNotFoundException - if:

- there is no role with given name

or

- the role is not readable.

See Also:
setRole(java.lang.String, javax.management.relation.Role)

getRoles

public RoleResult getRoles(String theRelId,
                           String[] theRoleNameArray)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
Retrieves values of roles with given names in given relation.

Parameters:
theRelId - relation id
theRoleNameArray - array of names of roles to be retrieved
Returns:
a RoleResult object, including a RoleList (for roles succcessfully retrieved) and a RoleUnresolvedList (for roles not retrieved).
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation with given id
See Also:
setRoles(java.lang.String, javax.management.relation.RoleList)

getAllRoles

public RoleResult getAllRoles(String theRelId)
                       throws IllegalArgumentException,
                              RelationNotFoundException,
                              RelationServiceNotRegisteredException
Returns all roles present in the relation.

Parameters:
theRelId - relation id
Returns:
a RoleResult object, including a RoleList (for roles succcessfully retrieved) and a RoleUnresolvedList (for roles not readable).
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation for given id
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server

getRoleCardinality

public Integer getRoleCardinality(String theRelId,
                                  String theRoleName)
                           throws IllegalArgumentException,
                                  RelationNotFoundException,
                                  RoleNotFoundException
Retrieves the number of MBeans currently referenced in the given role.

Parameters:
theRelId - relation id
theRoleName - name of role
Returns:
the number of currently referenced MBeans in that role
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation with given id
RoleNotFoundException - if there is no role with given name

setRole

public void setRole(String theRelId,
                    Role theRole)
             throws RelationServiceNotRegisteredException,
                    IllegalArgumentException,
                    RelationNotFoundException,
                    RoleNotFoundException,
                    InvalidRoleValueException,
                    RelationTypeNotFoundException
Sets the given role in given relation.

Will check the role according to its corresponding role definition provided in relation's relation type

The Relation Service will keep track of the change to keep the consistency of relations by handling referenced MBean unregistrations.

Parameters:
theRelId - relation id
theRole - role to be set (name and new value)
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation with given id
RoleNotFoundException - if:

- internal relation

and

- the role does not exist or is not writable

InvalidRoleValueException - if internal relation and value provided for role is not valid:

- the number of referenced MBeans in given value is less than expected minimum degree

or

- the number of referenced MBeans in provided value exceeds expected maximum degree

or

- one referenced MBean in the value is not an Object of the MBean class expected for that role

or

- an MBean provided for that role does not exist

RelationTypeNotFoundException - if unknown relation type
See Also:
getRole(java.lang.String, java.lang.String)

setRoles

public RoleResult setRoles(String theRelId,
                           RoleList theRoleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
Sets the given roles in given relation.

Will check the role according to its corresponding role definition provided in relation's relation type

The Relation Service keeps track of the changes to keep the consistency of relations by handling referenced MBean unregistrations.

Parameters:
theRelId - relation id
theRoleList - list of roles to be set
Returns:
a RoleResult object, including a RoleList (for roles succcessfully set) and a RoleUnresolvedList (for roles not set).
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation with given id
See Also:
getRoles(java.lang.String, java.lang.String[])

getReferencedMBeans

public Map getReferencedMBeans(String theRelId)
                        throws IllegalArgumentException,
                               RelationNotFoundException
Retrieves MBeans referenced in the various roles of the relation.

Parameters:
theRelId - relation id
Returns:
a HashMap mapping:

ObjectName -> ArrayList of String (role names)

Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation for given relation id

getRelationTypeName

public String getRelationTypeName(String theRelId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
Returns name of associated relation type for given relation.

Parameters:
theRelId - relation id
Returns:
the name of the associated relation type.
Throws:
IllegalArgumentException - if null parameter
RelationNotFoundException - if no relation for given relation id
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationServiceNotRegisteredException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RelationServiceNotRegisteredException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
                    extended by javax.management.relation.RelationServiceNotRegisteredException
All Implemented Interfaces:
Serializable
public class RelationServiceNotRegisteredException
extends RelationException

This exception is raised when an access is done to the Relation Service and that one is not registered.

See Also:
Serialized Form

Constructor Summary
RelationServiceNotRegisteredException()
Default constructor, no message put in exception.
RelationServiceNotRegisteredException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RelationServiceNotRegisteredException

public RelationServiceNotRegisteredException()
Default constructor, no message put in exception.

RelationServiceNotRegisteredException

public RelationServiceNotRegisteredException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RelationSupport

java.lang.Object
    extended by javax.management.relation.RelationSupport
All Implemented Interfaces:
MBeanRegistration, Relation, RelationSupportMBean
public class RelationSupport
extends Object
implements RelationSupportMBean, MBeanRegistration

A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type. As internal representation, it is not exposed to the user.

RelationSupport class conforms to the design patterns of standard MBean. So the user can decide to instantiate a RelationSupport object himself as a MBean (as it follows the MBean design patterns), to register it in the MBean Server, and then to add it in the Relation Service.

The user can also, when creating his own MBean relation class, have it extending RelationSupport, to retrieve the implementations of required interfaces (see below).

It is also possible to have in a user relation MBean class a member being a RelationSupport object, and to implement the required interfaces by delegating all to this member.

RelationSupport implements the Relation interface (to be handled by the Relation Service).

It implements also the MBeanRegistration interface to be able to retrieve the MBean Server where it is registered (if registered as a MBean) to access to its Relation Service.

Constructor Summary
RelationSupport(String theRelId, ObjectName theRelServiceName, MBeanServer theRelServiceMBeanServer, String theRelTypeName, RoleList theRoleList)
Creates object.
RelationSupport(String theRelId, ObjectName theRelServiceName, String theRelTypeName, RoleList theRoleList)
Creates object.
Method Summary
RoleResult | getAllRoles() Returns all roles present in the relation.
Map | getReferencedMBeans() Retrieves MBeans referenced in the various roles of the relation.
String | getRelationId() Returns relation identifier (used to uniquely identify the relation inside the Relation Service).
ObjectName | getRelationServiceName() Returns ObjectName of the Relation Service handling the relation.
String | getRelationTypeName() Returns name of associated relation type.
List | getRole(String theRoleName) Retrieves role value for given role name.
Integer | getRoleCardinality(String theRoleName) Returns the number of MBeans currently referenced in the given role.
RoleResult | getRoles(String[] theRoleNameArray) Retrieves values of roles with given names.
void | handleMBeanUnregistration(ObjectName theObjName, String theRoleName) Callback used by the Relation Service when a MBean referenced in a role is unregistered.
Boolean | isInRelationService() Returns an internal flag specifying if the object is still handled by the Relation Service.
void | postDeregister() Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
void | postRegister(Boolean registrationDone) Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
void | preDeregister() Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
ObjectName | preRegister(MBeanServer server, ObjectName name) Allows the MBean to perform any operations it needs before being registered in the MBean server.
RoleList | retrieveAllRoles() Returns all roles in the relation without checking read mode.
void | setRelationServiceManagementFlag(Boolean theFlg) Specifies whether this relation is handled by the Relation Service.
void | setRole(Role theRole) Sets the given role.
RoleResult | setRoles(RoleList theRoleList) Sets the given roles.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RelationSupport

public RelationSupport(String theRelId,
                       ObjectName theRelServiceName,
                       String theRelTypeName,
                       RoleList theRoleList)
                throws InvalidRoleValueException,
                       IllegalArgumentException
Creates object.

This constructor has to be used when the RelationSupport object will be registered as a MBean by the user, or when creating a user relation MBean those class extends RelationSupport.

Nothing is done at the Relation Service level, i.e. the RelationSupport object is not added, and no check if the provided values are correct. The object is always created, EXCEPT if:

- one mandatory parameter is not provided

- the same name is used for two roles.

To be handled as a relation, the object has then to be added in the Relation Service using Relation Service method addRelation().

Parameters:
theRelId - relation identifier, to identify the relation in the Relation Service.

Expected to be unique in the given Relation Service.

theRelServiceName - ObjectName of the Relation Service where the relation will be registered.

It is required as this is the Relation Service that is aware of the definition of the relation type of given relation, so that will be able to check update operations (set).

theRelTypeName - Name of relation type.

Expected to have been created in given Relation Service.

theRoleList - list of roles (Role objects) to initialised the relation. Can be null.

Expected to conform to relation info in associated relation type.

Throws:
InvalidRoleValueException - if the same name is used for two roles.
IllegalArgumentException - if a required value (Relation Service Object Name, etc.) is not provided as parameter.

RelationSupport

public RelationSupport(String theRelId,
                       ObjectName theRelServiceName,
                       MBeanServer theRelServiceMBeanServer,
                       String theRelTypeName,
                       RoleList theRoleList)
                throws InvalidRoleValueException,
                       IllegalArgumentException
Creates object.

This constructor has to be used when the user relation MBean implements the interfaces expected to be supported by a relation by delegating to a RelationSupport object.

This object needs to know the Relation Service expected to handle the relation. So it has to know the MBean Server where the Relation Service is registered.

According to a limitation, a relation MBean must be registered in the same MBean Server as the Relation Service expected to handle it. So the user relation MBean has to be created and registered, and then the wrapped RelationSupport object can be created with identified MBean Server.

Nothing is done at the Relation Service level, i.e. the RelationSupport object is not added, and no check if the provided values are correct. The object is always created, EXCEPT if:

- one required parameter is not provided

- the same name is used for two roles.

To be handled as a relation, the object has then to be added in the Relation Service using the Relation Service method addRelation().

Parameters:
theRelId - relation identifier, to identify the relation in the Relation Service.

Expected to be unique in the given Relation Service.

theRelServiceName - ObjectName of the Relation Service where the relation will be registered.

It is required as this is the Relation Service that is aware of the definition of the relation type of given relation, so that will be able to check update operations (set).

theRelServiceMBeanServer - MBean Server where the wrapping MBean is or will be registered.

Expected to be the MBean Server where the Relation Service is or will be registered.

theRelTypeName - Name of relation type.

Expected to have been created in given Relation Service.

theRoleList - list of roles (Role objects) to initialised the relation. Can be null.

Expected to conform to relation info in associated relation type.

Throws:
InvalidRoleValueException - if the same name is used for two roles.
IllegalArgumentException - if a required value (Relation Service Object Name, etc.) is not provided as parameter.
Method Detail

getRole

public List getRole(String theRoleName)
             throws IllegalArgumentException,
                    RoleNotFoundException,
                    RelationServiceNotRegisteredException
Retrieves role value for given role name.

Checks if the role exists and is readable according to the relation type.

Specified by:
getRole in interface Relation
Parameters:
theRoleName - name of role
Returns:
the ArrayList of ObjectName objects being the role value
Throws:
IllegalArgumentException - if null role name
RoleNotFoundException - if:

- there is no role with given name

- the role is not readable.

RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
See Also:
setRole(javax.management.relation.Role)

getRoles

public RoleResult getRoles(String[] theRoleNameArray)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException
Retrieves values of roles with given names.

Checks for each role if it exists and is readable according to the relation type.

Specified by:
getRoles in interface Relation
Parameters:
theRoleNameArray - array of names of roles to be retrieved
Returns:
a RoleResult object, including a RoleList (for roles succcessfully retrieved) and a RoleUnresolvedList (for roles not retrieved).
Throws:
IllegalArgumentException - if null role name
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
See Also:
setRoles(javax.management.relation.RoleList)

getAllRoles

public RoleResult getAllRoles()
                       throws RelationServiceNotRegisteredException
Returns all roles present in the relation.

Specified by:
getAllRoles in interface Relation
Returns:
a RoleResult object, including a RoleList (for roles succcessfully retrieved) and a RoleUnresolvedList (for roles not readable).
Throws:
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server

retrieveAllRoles

public RoleList retrieveAllRoles()
Returns all roles in the relation without checking read mode.

Specified by:
retrieveAllRoles in interface Relation
Returns:
a RoleList

getRoleCardinality

public Integer getRoleCardinality(String theRoleName)
                           throws IllegalArgumentException,
                                  RoleNotFoundException
Returns the number of MBeans currently referenced in the given role.

Specified by:
getRoleCardinality in interface Relation
Parameters:
theRoleName - name of role
Returns:
the number of currently referenced MBeans in that role
Throws:
IllegalArgumentException - if null role name
RoleNotFoundException - if there is no role with given name

setRole

public void setRole(Role theRole)
             throws IllegalArgumentException,
                    RoleNotFoundException,
                    RelationTypeNotFoundException,
                    InvalidRoleValueException,
                    RelationServiceNotRegisteredException,
                    RelationNotFoundException
Sets the given role.

Will check the role according to its corresponding role definition provided in relation's relation type

Will send a notification (RelationNotification with type RELATION_BASIC_UPDATE or RELATION_MBEAN_UPDATE, depending if the relation is a MBean or not).

Specified by:
setRole in interface Relation
Parameters:
theRole - role to be set (name and new value)
Throws:
IllegalArgumentException - if null role
RoleNotFoundException - if the role is not writable (no test on the write access mode performed when initialising the role)
InvalidRoleValueException - if value provided for role is not valid, i.e.:

- the number of referenced MBeans in given value is less than expected minimum degree

- the number of referenced MBeans in provided value exceeds expected maximum degree

- one referenced MBean in the value is not an Object of the MBean class expected for that role

- a MBean provided for that role does not exist

RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service
RelationNotFoundException - if the relation has not been added in the Relation Service.
See Also:
getRole(java.lang.String)

setRoles

public RoleResult setRoles(RoleList theRoleList)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException,
                           RelationTypeNotFoundException,
                           RelationNotFoundException
Sets the given roles.

Will check the role according to its corresponding role definition provided in relation's relation type

Will send one notification (RelationNotification with type RELATION_BASIC_UPDATE or RELATION_MBEAN_UPDATE, depending if the relation is a MBean or not) per updated role.

Specified by:
setRoles in interface Relation
Parameters:
theRoleList - list of roles to be set
Returns:
a RoleResult object, including a RoleList (for roles succcessfully set) and a RoleUnresolvedList (for roles not set).
Throws:
IllegalArgumentException - if null role name
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service.
RelationNotFoundException - if the relation MBean has not been added in the Relation Service.
See Also:
getRoles(java.lang.String[])

handleMBeanUnregistration

public void handleMBeanUnregistration(ObjectName theObjName,
                                      String theRoleName)
                               throws IllegalArgumentException,
                                      RoleNotFoundException,
                                      InvalidRoleValueException,
                                      RelationServiceNotRegisteredException,
                                      RelationTypeNotFoundException,
                                      RelationNotFoundException
Callback used by the Relation Service when a MBean referenced in a role is unregistered.

The Relation Service will call this method to let the relation take action to reflect the impact of such unregistration.

BEWARE. the user is not expected to call this method.

Current implementation is to set the role with its current value (list of ObjectNames of referenced MBeans) without the unregistered one.

Specified by:
handleMBeanUnregistration in interface Relation
Parameters:
theObjName - ObjectName of unregistered MBean
theRoleName - name of role where the MBean is referenced
Throws:
IllegalArgumentException - if null parameter
RoleNotFoundException - if role does not exist in the relation or is not writable
InvalidRoleValueException - if role value does not conform to the associated role info (this will never happen when called from the Relation Service)
RelationServiceNotRegisteredException - if the Relation Service is not registered in the MBean Server
RelationTypeNotFoundException - if the relation type has not been declared in the Relation Service.
RelationNotFoundException - if this method is called for a relation MBean not added in the Relation Service.

getReferencedMBeans

public Map getReferencedMBeans()
Retrieves MBeans referenced in the various roles of the relation.

Specified by:
getReferencedMBeans in interface Relation
Returns:
a HashMap mapping:

ObjectName -> ArrayList of String (role names)

getRelationTypeName

public String getRelationTypeName()
Returns name of associated relation type.

Specified by:
getRelationTypeName in interface Relation
Returns:
the name of the relation type.

getRelationServiceName

public ObjectName getRelationServiceName()
Returns ObjectName of the Relation Service handling the relation.

Specified by:
getRelationServiceName in interface Relation
Returns:
the ObjectName of the Relation Service.

getRelationId

public String getRelationId()
Returns relation identifier (used to uniquely identify the relation inside the Relation Service).

Specified by:
getRelationId in interface Relation
Returns:
the relation id.

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
Description copied from interface: MBeanRegistration
Allows the MBean to perform any operations it needs before being registered in the MBean server. If the name of the MBean is not specified, the MBean can provide a name for its registration. If any exception is raised, the MBean will not be registered in the MBean server.

Specified by:
preRegister in interface MBeanRegistration
Parameters:
server - The MBean server in which the MBean will be registered.
name - The object name of the MBean. This name is null if the name parameter to one of the createMBean or registerMBean methods in the MBeanServer interface is null. In that case, this method must return a non-null ObjectName for the new MBean.
Returns:
The name under which the MBean is to be registered. This value must not be null. If the name parameter is not null, it will usually but not necessarily be the returned value.
Throws:
Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException or a RuntimeMBeanException.

postRegister

public void postRegister(Boolean registrationDone)
Description copied from interface: MBeanRegistration
Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

Specified by:
postRegister in interface MBeanRegistration
Parameters:
registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

preDeregister

public void preDeregister()
                   throws Exception
Description copied from interface: MBeanRegistration
Allows the MBean to perform any operations it needs before being unregistered by the MBean server.

Specified by:
preDeregister in interface MBeanRegistration
Throws:
Exception - This exception will be caught by the MBean server and re-thrown as an MBeanRegistrationException or a RuntimeMBeanException.

postDeregister

public void postDeregister()
Description copied from interface: MBeanRegistration
Allows the MBean to perform any operations needed after having been unregistered in the MBean server.

Specified by:
postDeregister in interface MBeanRegistration

isInRelationService

public Boolean isInRelationService()
Returns an internal flag specifying if the object is still handled by the Relation Service.

Specified by:
isInRelationService in interface RelationSupportMBean
Returns:
a Boolean equal to Boolean.TRUE if the object is still handled by the Relation Service and Boolean.FALSE otherwise.

setRelationServiceManagementFlag

public void setRelationServiceManagementFlag(Boolean theFlg)
                                      throws IllegalArgumentException
Description copied from interface: RelationSupportMBean

Specifies whether this relation is handled by the Relation Service.

BEWARE, this method has to be exposed as the Relation Service will access the relation through its management interface. It is RECOMMENDED NOT to use this method. Using it does not affect the registration of the relation object in the Relation Service, but will provide wrong information about it!

Specified by:
setRelationServiceManagementFlag in interface RelationSupportMBean
Parameters:
theFlg - whether the relation is handled by the Relation Service.
Throws:
IllegalArgumentException - if null parameter
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationSupportMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Interface RelationSupportMBean

All Superinterfaces:
Relation
All Known Implementing Classes:
RelationSupport
public interface RelationSupportMBean
extends Relation

A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type. As internal representation, it is not exposed to the user.

RelationSupport class conforms to the design patterns of standard MBean. So the user can decide to instantiate a RelationSupport object himself as a MBean (as it follows the MBean design patterns), to register it in the MBean Server, and then to add it in the Relation Service.

The user can also, when creating his own MBean relation class, have it extending RelationSupport, to retrieve the implementations of required interfaces (see below).

It is also possible to have in a user relation MBean class a member being a RelationSupport object, and to implement the required interfaces by delegating all to this member.

RelationSupport implements the Relation interface (to be handled by the Relation Service).

Method Summary
Boolean | isInRelationService() Returns an internal flag specifying if the object is still handled by the Relation Service.
void | setRelationServiceManagementFlag(Boolean theFlg) Specifies whether this relation is handled by the Relation Service.
Methods inherited from interface javax.management.relation.Relation
getAllRoles, getReferencedMBeans, getRelationId, getRelationServiceName, getRelationTypeName, getRole, getRoleCardinality, getRoles, handleMBeanUnregistration, retrieveAllRoles, setRole, setRoles

Method Detail

isInRelationService

public Boolean isInRelationService()
Returns an internal flag specifying if the object is still handled by the Relation Service.

Returns:
a Boolean equal to Boolean.TRUE if the object is still handled by the Relation Service and Boolean.FALSE otherwise.

setRelationServiceManagementFlag

public void setRelationServiceManagementFlag(Boolean theFlg)
                                      throws IllegalArgumentException

Specifies whether this relation is handled by the Relation Service.

BEWARE, this method has to be exposed as the Relation Service will access the relation through its management interface. It is RECOMMENDED NOT to use this method. Using it does not affect the registration of the relation object in the Relation Service, but will provide wrong information about it!

Parameters:
theFlg - whether the relation is handled by the Relation Service.
Throws:
IllegalArgumentException - if null parameter
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Interface RelationType

All Superinterfaces:
Serializable
All Known Implementing Classes:
RelationTypeSupport
public interface RelationType
extends Serializable

The RelationType interface has to be implemented by any class expected to represent a relation type.

Method Summary
String | getRelationTypeName() Returns the relation type name.
RoleInfo | getRoleInfo(String theRoleInfoName) Returns the role info (RoleInfo object) for the given role info name (null if not found).
List | getRoleInfos() Returns the list of role definitions (ArrayList of RoleInfo objects).

Method Detail

getRelationTypeName

public String getRelationTypeName()
Returns the relation type name.

Returns:
the relation type name.

getRoleInfos

public List getRoleInfos()
Returns the list of role definitions (ArrayList of RoleInfo objects).

Returns:
an ArrayList of RoleInfo.

getRoleInfo

public RoleInfo getRoleInfo(String theRoleInfoName)
                     throws IllegalArgumentException,
                            RoleInfoNotFoundException
Returns the role info (RoleInfo object) for the given role info name (null if not found).

Parameters:
theRoleInfoName - role info name
Returns:
RoleInfo object providing role definition does not exist
Throws:
IllegalArgumentException - if null parameter
RoleInfoNotFoundException - if no role info with that name in relation type.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationTypeNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RelationTypeNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
                    extended by javax.management.relation.RelationTypeNotFoundException
All Implemented Interfaces:
Serializable
public class RelationTypeNotFoundException
extends RelationException

This exception is raised when there is no relation type with given name in Relation Service.

See Also:
Serialized Form

Constructor Summary
RelationTypeNotFoundException()
Default constructor, no message put in exception.
RelationTypeNotFoundException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RelationTypeNotFoundException

public RelationTypeNotFoundException()
Default constructor, no message put in exception.

RelationTypeNotFoundException

public RelationTypeNotFoundException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RelationTypeSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RelationTypeSupport

java.lang.Object
    extended by javax.management.relation.RelationTypeSupport
All Implemented Interfaces:
RelationType, Serializable
public class RelationTypeSupport
extends Object
implements RelationType

A RelationTypeSupport object implements the RelationType interface.

It represents a relation type, providing role information for each role expected to be supported in every relation of that type.

A relation type includes a relation type name and a list of role infos (represented by RoleInfo objects).

A relation type has to be declared in the Relation Service:

- either using the createRelationType() method, where a RelationTypeSupport object will be created and kept in the Relation Service

- either using the addRelationType() method where the user has to create an object implementing the RelationType interface, and this object will be used as representing a relation type in the Relation Service.

See Also:
Serialized Form

Constructor Summary
protected | RelationTypeSupport(String theRelTypeName) Constructor to be used for subclasses.
 | RelationTypeSupport(String theRelTypeName, RoleInfo[] theRoleInfoArray) Constructor where all role definitions are dynamically created and passed as parameter.
Method Summary
protected void | addRoleInfo(RoleInfo theRoleInfo) Add a role info.
String | getRelationTypeName() Returns the relation type name.
RoleInfo | getRoleInfo(String theRoleInfoName) Returns the role info (RoleInfo object) for the given role info name (null if not found).
List | getRoleInfos() Returns the list of role definitions (ArrayList of RoleInfo objects).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RelationTypeSupport

public RelationTypeSupport(String theRelTypeName,
                           RoleInfo[] theRoleInfoArray)
                    throws IllegalArgumentException,
                           InvalidRelationTypeException
Constructor where all role definitions are dynamically created and passed as parameter.

Parameters:
theRelTypeName - Name of relation type
theRoleInfoArray - List of role definitions (RoleInfo objects)
Throws:
IllegalArgumentException - if null parameter
InvalidRelationTypeException - if:

- the same name has been used for two different roles

- no role info provided

- one null role info provided

RelationTypeSupport

protected RelationTypeSupport(String theRelTypeName)
Constructor to be used for subclasses.

Parameters:
theRelTypeName - Name of relation type.
Throws:
IllegalArgumentException - if null parameter.
Method Detail

getRelationTypeName

public String getRelationTypeName()
Returns the relation type name.

Specified by:
getRelationTypeName in interface RelationType
Returns:
the relation type name.

getRoleInfos

public List getRoleInfos()
Returns the list of role definitions (ArrayList of RoleInfo objects).

Specified by:
getRoleInfos in interface RelationType
Returns:
an ArrayList of RoleInfo.

getRoleInfo

public RoleInfo getRoleInfo(String theRoleInfoName)
                     throws IllegalArgumentException,
                            RoleInfoNotFoundException
Returns the role info (RoleInfo object) for the given role info name (null if not found).

Specified by:
getRoleInfo in interface RelationType
Parameters:
theRoleInfoName - role info name
Returns:
RoleInfo object providing role definition does not exist
Throws:
IllegalArgumentException - if null parameter
RoleInfoNotFoundException - if no role info with that name in relation type.

addRoleInfo

protected void addRoleInfo(RoleInfo theRoleInfo)
                    throws IllegalArgumentException,
                           InvalidRelationTypeException
Add a role info. This method of course should not be used after the creation of the relation type, because updating it would invalidate that the relations created associated to that type still conform to it. Can throw a RuntimeException if trying to update a relation type declared in the Relation Service.

Parameters:
theRoleInfo - role info to be added.
Throws:
IllegalArgumentException - if null parameter.
InvalidRelationTypeException - if there is already a role info in current relation type with the same name.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Role

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class Role

java.lang.Object
    extended by javax.management.relation.Role
All Implemented Interfaces:
Serializable
public class Role
extends Object
implements Serializable

Represents a role: includes a role name and referenced MBeans (via their ObjectNames). The role value is always represented as an ArrayList collection (of ObjectNames) to homogenize the access.

See Also:
Serialized Form

Constructor Summary
Role(String theRoleName, List theRoleValue)
Make a new Role object.
Method Summary
Object | clone() Clone the role object.
String | getRoleName() Retrieves role name.
List | getRoleValue() Retrieves role value.
static String | roleValueToString(List theRoleValue) Returns a string for the given role value.
void | setRoleName(String theRoleName) Sets role name.
void | setRoleValue(List theRoleValue) Sets role value.
String | toString() Returns a string describing the role.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Role

public Role(String theRoleName,
            List theRoleValue)
     throws IllegalArgumentException

Make a new Role object. No check is made that the ObjectNames in the role value exist in an MBean server. That check will be made when the role is set in a relation.

Parameters:
theRoleName - role name
theRoleValue - role value (ArrayList of ObjectName objects)
Throws:
IllegalArgumentException - if null parameter
Method Detail

getRoleName

public String getRoleName()
Retrieves role name.

Returns:
the role name.
See Also:
setRoleName(java.lang.String)

getRoleValue

public List getRoleValue()
Retrieves role value.

Returns:
ArrayList of ObjectName objects for referenced MBeans.
See Also:
setRoleValue(java.util.List)

setRoleName

public void setRoleName(String theRoleName)
                 throws IllegalArgumentException
Sets role name.

Parameters:
theRoleName - role name
Throws:
IllegalArgumentException - if null parameter
See Also:
getRoleName()

setRoleValue

public void setRoleValue(List theRoleValue)
                  throws IllegalArgumentException
Sets role value.

Parameters:
theRoleValue - ArrayList of ObjectName objects for referenced MBeans.
Throws:
IllegalArgumentException - if null parameter
See Also:
getRoleValue()

toString

public String toString()
Returns a string describing the role.

Returns:
the description of the role.

clone

public Object clone()
Clone the role object.

Returns:
a Role that is an independent copy of the current Role object.

roleValueToString

public static String roleValueToString(List theRoleValue)
                                throws IllegalArgumentException
Returns a string for the given role value.

Parameters:
theRoleValue - ArrayList of ObjectName objects
Returns:
A String consisting of the ObjectNames separated by newlines (\n).
Throws:
IllegalArgumentException - if null parameter
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RoleInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RoleInfo

java.lang.Object
    extended by javax.management.relation.RoleInfo
All Implemented Interfaces:
Serializable
public class RoleInfo
extends Object
implements Serializable

A RoleInfo object summarises a role in a relation type.

See Also:
Serialized Form

Field Summary
static int ROLE_CARDINALITY_INFINITY
To specify an unlimited cardinality.
Constructor Summary
RoleInfo(RoleInfo theRoleInfo)
Copy constructor.
RoleInfo(String theName, String theRefMBeanClassName)
Constructor.
RoleInfo(String theName, String theRefMBeanClassName, boolean theIsReadable, boolean theIsWritable)
Constructor.
RoleInfo(String theName, String theRefMBeanClassName, boolean theIsReadable, boolean theIsWritable, int theMinDegree, int theMaxDegree, String theDescription)
Constructor.
Method Summary
boolean | checkMaxDegree(int theValue) Returns a boolean to specify if given value is less or equal than expected maximum degree (true if yes).
boolean | checkMinDegree(int theValue) Returns a boolean to specify if given value is greater or equal than expected minimum degree (true if yes).
String | getDescription() Returns description text for the role.
int | getMaxDegree() Returns maximum degree for corresponding role reference.
int | getMinDegree() Returns minimum degree for corresponding role reference.
String | getName() Returns the name of the role.
String | getRefMBeanClassName() Returns name of type of MBean expected to be referenced in corresponding role.
boolean | isReadable() Returns read access mode for the role (true if it is readable).
boolean | isWritable() Returns write access mode for the role (true if it is writable).
String | toString() Returns a string describing the role info.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ROLE_CARDINALITY_INFINITY

public static int ROLE_CARDINALITY_INFINITY
To specify an unlimited cardinality.

Constructor Detail

RoleInfo

public RoleInfo(String theName,
                String theRefMBeanClassName,
                boolean theIsReadable,
                boolean theIsWritable,
                int theMinDegree,
                int theMaxDegree,
                String theDescription)
         throws IllegalArgumentException,
                InvalidRoleInfoException,
                ClassNotFoundException,
                NotCompliantMBeanException
Constructor.

Parameters:
theName - name of the role.
theRefMBeanClassName - name of the class of MBean(s) expected to be referenced in corresponding role. If an MBean M is in this role, then the MBean server must return true for isInstanceOf(M, theRefMBeanClassName).
theIsReadable - flag to indicate if the corresponding role can be read
theIsWritable - flag to indicate if the corresponding role can be set
theMinDegree - minimum degree for role, i.e. minimum number of MBeans to provide in corresponding role Must be less or equal than theMaxDegree. (ROLE_CARDINALITY_INFINITY for unlimited)
theMaxDegree - maximum degree for role, i.e. maximum number of MBeans to provide in corresponding role Must be greater or equal than theMinDegree (ROLE_CARDINALITY_INFINITY for unlimited)
theDescription - description of the role (can be null)
Throws:
IllegalArgumentException - if null parameter
InvalidRoleInfoException - if the minimum degree is greater than the maximum degree.
ClassNotFoundException - As of JMX 1.2, this exception can no longer be thrown. It is retained in the declaration of this class for compatibility with existing code.
NotCompliantMBeanException - if the class theRefMBeanClassName is not a MBean class.

RoleInfo

public RoleInfo(String theName,
                String theRefMBeanClassName,
                boolean theIsReadable,
                boolean theIsWritable)
         throws IllegalArgumentException,
                ClassNotFoundException,
                NotCompliantMBeanException
Constructor.

Parameters:
theName - name of the role
theRefMBeanClassName - name of the class of MBean(s) expected to be referenced in corresponding role. If an MBean M is in this role, then the MBean server must return true for isInstanceOf(M, theRefMBeanClassName).
theIsReadable - flag to indicate if the corresponding role can be read
theIsWritable - flag to indicate if the corresponding role can be set

Minimum and maximum degrees defaulted to 1.

Description of role defaulted to null.

Throws:
IllegalArgumentException - if null parameter
ClassNotFoundException - As of JMX 1.2, this exception can no longer be thrown. It is retained in the declaration of this class for compatibility with existing code.
NotCompliantMBeanException - As of JMX 1.2, this exception can no longer be thrown. It is retained in the declaration of this class for compatibility with existing code.

RoleInfo

public RoleInfo(String theName,
                String theRefMBeanClassName)
         throws IllegalArgumentException,
                ClassNotFoundException,
                NotCompliantMBeanException
Constructor.

Parameters:
theName - name of the role
theRefMBeanClassName - name of the class of MBean(s) expected to be referenced in corresponding role. If an MBean M is in this role, then the MBean server must return true for isInstanceOf(M, theRefMBeanClassName).

IsReadable and IsWritable defaulted to true.

Minimum and maximum degrees defaulted to 1.

Description of role defaulted to null.

Throws:
IllegalArgumentException - if null parameter
ClassNotFoundException - As of JMX 1.2, this exception can no longer be thrown. It is retained in the declaration of this class for compatibility with existing code.
NotCompliantMBeanException - As of JMX 1.2, this exception can no longer be thrown. It is retained in the declaration of this class for compatibility with existing code.

RoleInfo

public RoleInfo(RoleInfo theRoleInfo)
         throws IllegalArgumentException
Copy constructor.

Parameters:
theRoleInfo - the RoleInfo to be copied.
Throws:
IllegalArgumentException - if null parameter
Method Detail

getName

public String getName()
Returns the name of the role.

Returns:
the name of the role.

isReadable

public boolean isReadable()
Returns read access mode for the role (true if it is readable).

Returns:
true if the role is readable.

isWritable

public boolean isWritable()
Returns write access mode for the role (true if it is writable).

Returns:
true if the role is writable.

getDescription

public String getDescription()
Returns description text for the role.

Returns:
the description of the role.

getMinDegree

public int getMinDegree()
Returns minimum degree for corresponding role reference.

Returns:
the minimum degree.

getMaxDegree

public int getMaxDegree()
Returns maximum degree for corresponding role reference.

Returns:
the maximum degree.

getRefMBeanClassName

public String getRefMBeanClassName()

Returns name of type of MBean expected to be referenced in corresponding role.

Returns:
the name of the referenced type.

checkMinDegree

public boolean checkMinDegree(int theValue)
Returns a boolean to specify if given value is greater or equal than expected minimum degree (true if yes).

Parameters:
theValue - value
Returns:
true if greater or equal than minimum degree, false otherwise.

checkMaxDegree

public boolean checkMaxDegree(int theValue)
Returns a boolean to specify if given value is less or equal than expected maximum degree (true if yes).

Parameters:
theValue - value
Returns:
true if less or equal than maximum degree, false otherwise.

toString

public String toString()
Returns a string describing the role info.

Returns:
a description of the role info.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RoleInfoNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RoleInfoNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
                    extended by javax.management.relation.RoleInfoNotFoundException
All Implemented Interfaces:
Serializable
public class RoleInfoNotFoundException
extends RelationException

This exception is raised when there is no role info with given name in a given relation type.

See Also:
Serialized Form

Constructor Summary
RoleInfoNotFoundException()
Default constructor, no message put in exception.
RoleInfoNotFoundException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RoleInfoNotFoundException

public RoleInfoNotFoundException()
Default constructor, no message put in exception.

RoleInfoNotFoundException

public RoleInfoNotFoundException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RoleList

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RoleList

java.lang.Object
    extended by java.util.AbstractCollection
        extended by java.util.AbstractList
            extended by java.util.ArrayList
                extended by javax.management.relation.RoleList
All Implemented Interfaces:
Cloneable, Collection, List, RandomAccess, Serializable
public class RoleList
extends ArrayList

A RoleList represents a list of roles (Role objects). It is used as parameter when creating a relation, and when trying to set several roles in a relation (via 'setRoles()' method). It is returned as part of a RoleResult, to provide roles successfully retrieved.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
RoleList()
Constructs an empty RoleList.
RoleList(int theInitialCapacity)
Constructs an empty RoleList with the initial capacity specified.
RoleList(List theList)
Constructs a RoleList containing the elements of the ArrayList specified, in the order in which they are returned by the ArrayList's iterator.
Method Summary
void | add(int theIndex, Role theRole) Inserts the role specified as an element at the position specified.
void | add(Role theRole) Adds the Role specified as the last element of the list.
boolean | addAll(int theIndex, RoleList theRoleList) Inserts all of the elements in the RoleList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleList specified.
boolean | addAll(RoleList theRoleList) Appends all the elements in the RoleList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleList specified.
void | set(int theIndex, Role theRole) Sets the element at the position specified to be the role specified.
Methods inherited from class java.util.ArrayList
add, add, addAll, addAll, clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, remove, removeRange, set, size, toArray, toArray, trimToSize
Methods inherited from class java.util.AbstractList
equals, hashCode, iterator, listIterator, listIterator, subList
Methods inherited from class java.util.AbstractCollection
containsAll, remove, removeAll, retainAll, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
containsAll, equals, hashCode, iterator, listIterator, listIterator, remove, removeAll, retainAll, subList

Constructor Detail

RoleList

public RoleList()
Constructs an empty RoleList.

RoleList

public RoleList(int theInitialCapacity)
Constructs an empty RoleList with the initial capacity specified.

Parameters:
theInitialCapacity - initial capacity

RoleList

public RoleList(List theList)
         throws IllegalArgumentException
Constructs a RoleList containing the elements of the ArrayList specified, in the order in which they are returned by the ArrayList's iterator. The RoleList instance has an initial capacity of 110% of the size of the ArrayList specified.

Parameters:
theList - list of Role objects
Throws:
IllegalArgumentException - if:

- null parameter

or

- an element in the ArrayList is not a Role

Method Detail

add

public void add(Role theRole)
         throws IllegalArgumentException
Adds the Role specified as the last element of the list.

Parameters:
theRole - the role to be added.
Throws:
IllegalArgumentException - if the role is null.

add

public void add(int theIndex,
                Role theRole)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
Inserts the role specified as an element at the position specified. Elements with an index greater than or equal to the current position are shifted up.

Parameters:
theIndex - The position in the list where the new Role object is to be inserted.
theRole - The Role object to be inserted.
Throws:
IllegalArgumentException - if the role is null.
IndexOutOfBoundsException - if accessing with an index outside of the list.

set

public void set(int theIndex,
                Role theRole)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
Sets the element at the position specified to be the role specified. The previous element at that position is discarded.

Parameters:
theIndex - The position specified.
theRole - The value to which the role element should be set.
Throws:
IllegalArgumentException - if the role is null.
IndexOutOfBoundsException - if accessing with an index outside of the list.

addAll

public boolean addAll(RoleList theRoleList)
               throws IndexOutOfBoundsException
Appends all the elements in the RoleList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleList specified.

Parameters:
theRoleList - Elements to be inserted into the list (can be null)
Returns:
true if this list changed as a result of the call.
Throws:
IndexOutOfBoundsException - if accessing with an index outside of the list.
See Also:
ArrayList.addAll(Collection)

addAll

public boolean addAll(int theIndex,
                      RoleList theRoleList)
               throws IllegalArgumentException,
                      IndexOutOfBoundsException
Inserts all of the elements in the RoleList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleList specified.

Parameters:
theIndex - Position at which to insert the first element from the RoleList specified.
theRoleList - Elements to be inserted into the list.
Returns:
true if this list changed as a result of the call.
Throws:
IllegalArgumentException - if the role is null.
IndexOutOfBoundsException - if accessing with an index outside of the list.
See Also:
ArrayList.addAll(int, Collection)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RoleNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RoleNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.relation.RelationException
                    extended by javax.management.relation.RoleNotFoundException
All Implemented Interfaces:
Serializable
public class RoleNotFoundException
extends RelationException

This exception is raised when a role in a relation does not exist, or is not readable, or is not settable.

See Also:
Serialized Form

Constructor Summary
RoleNotFoundException()
Default constructor, no message put in exception.
RoleNotFoundException(String message)
Constructor with given message put in exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RoleNotFoundException

public RoleNotFoundException()
Default constructor, no message put in exception.

RoleNotFoundException

public RoleNotFoundException(String message)
Constructor with given message put in exception.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RoleResult

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RoleResult

java.lang.Object
    extended by javax.management.relation.RoleResult
All Implemented Interfaces:
Serializable
public class RoleResult
extends Object
implements Serializable

Represents the result of a multiple access to several roles of a relation (either for reading or writing).

See Also:
Serialized Form

Constructor Summary
RoleResult(RoleList theRoleList, RoleUnresolvedList theRoleUnresList)
Constructor.
Method Summary
RoleList | getRoles() Retrieves list of roles successfully accessed.
RoleUnresolvedList | getRolesUnresolved() Retrieves list of roles unsuccessfully accessed.
void | setRoles(RoleList theRoleList) Sets list of roles successfully accessed.
void | setRolesUnresolved(RoleUnresolvedList theRoleUnresList) Sets list of roles unsuccessfully accessed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RoleResult

public RoleResult(RoleList theRoleList,
                  RoleUnresolvedList theRoleUnresList)
Constructor.

Parameters:
theRoleList - list of roles succesfully accessed.
theRoleUnresList - list of roles not accessed (with problem descriptions).
Method Detail

getRoles

public RoleList getRoles()
Retrieves list of roles successfully accessed.

Returns:
a RoleList
See Also:
setRoles(javax.management.relation.RoleList)

getRolesUnresolved

public RoleUnresolvedList getRolesUnresolved()
Retrieves list of roles unsuccessfully accessed.

Returns:
a RoleUnresolvedList.
See Also:
setRolesUnresolved(javax.management.relation.RoleUnresolvedList)

setRoles

public void setRoles(RoleList theRoleList)
Sets list of roles successfully accessed.

Parameters:
theRoleList - list of roles successfully accessed
See Also:
getRoles()

setRolesUnresolved

public void setRolesUnresolved(RoleUnresolvedList theRoleUnresList)
Sets list of roles unsuccessfully accessed.

Parameters:
theRoleUnresList - list of roles unsuccessfully accessed
See Also:
getRolesUnresolved()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RoleStatus

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RoleStatus

java.lang.Object
    extended by javax.management.relation.RoleStatus
public class RoleStatus
extends Object

This class describes the various problems which can be encountered when accessing a role.

Field Summary
static int | LESS_THAN_MIN_ROLE_DEGREE Problem type when trying to set a role value with less ObjectNames than the minimum expected cardinality.
static int | MORE_THAN_MAX_ROLE_DEGREE Problem type when trying to set a role value with more ObjectNames than the maximum expected cardinality.
static int | NO_ROLE_WITH_NAME Problem type when trying to access an unknown role.
static int | REF_MBEAN_NOT_REGISTERED Problem type when trying to set a role value including the ObjectName of a MBean not registered in the MBean Server.
static int | REF_MBEAN_OF_INCORRECT_CLASS Problem type when trying to set a role value including the ObjectName of a MBean not of the class expected for that role.
static int | ROLE_NOT_READABLE Problem type when trying to read a non-readable attribute.
static int | ROLE_NOT_WRITABLE Problem type when trying to update a non-writable attribute.
Constructor Summary
RoleStatus()
Method Summary
static boolean isRoleStatus(int theRoleStatus)
Returns true if given value corresponds to a known role status, false otherwise.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NO_ROLE_WITH_NAME

public static final int NO_ROLE_WITH_NAME
Problem type when trying to access an unknown role.

See Also:
Constant Field Values

ROLE_NOT_READABLE

public static final int ROLE_NOT_READABLE
Problem type when trying to read a non-readable attribute.

See Also:
Constant Field Values

ROLE_NOT_WRITABLE

public static final int ROLE_NOT_WRITABLE
Problem type when trying to update a non-writable attribute.

See Also:
Constant Field Values

LESS_THAN_MIN_ROLE_DEGREE

public static final int LESS_THAN_MIN_ROLE_DEGREE
Problem type when trying to set a role value with less ObjectNames than the minimum expected cardinality.

See Also:
Constant Field Values

MORE_THAN_MAX_ROLE_DEGREE

public static final int MORE_THAN_MAX_ROLE_DEGREE
Problem type when trying to set a role value with more ObjectNames than the maximum expected cardinality.

See Also:
Constant Field Values

REF_MBEAN_OF_INCORRECT_CLASS

public static final int REF_MBEAN_OF_INCORRECT_CLASS
Problem type when trying to set a role value including the ObjectName of a MBean not of the class expected for that role.

See Also:
Constant Field Values

REF_MBEAN_NOT_REGISTERED

public static final int REF_MBEAN_NOT_REGISTERED
Problem type when trying to set a role value including the ObjectName of a MBean not registered in the MBean Server.

See Also:
Constant Field Values
Constructor Detail

RoleStatus

public RoleStatus()
Method Detail

isRoleStatus

public static boolean isRoleStatus(int theRoleStatus)
Returns true if given value corresponds to a known role status, false otherwise.

Parameters:
theRoleStatus - a status code.
Returns:
true if this value is a known role status.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RoleUnresolved

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RoleUnresolved

java.lang.Object
    extended by javax.management.relation.RoleUnresolved
All Implemented Interfaces:
Serializable
public class RoleUnresolved
extends Object
implements Serializable

Represents an unresolved role: a role not retrieved from a relation due to a problem. It provides the role name, value (if problem when trying to set the role) and an integer defining the problem (constants defined in RoleStatus).

See Also:
Serialized Form

Constructor Summary
RoleUnresolved(String theRoleName, List theRoleValue, int thePbType)
Constructor.
Method Summary
Object | clone() Clone this object.
int | getProblemType() Retrieves problem type.
String | getRoleName() Retrieves role name.
List | getRoleValue() Retrieves role value.
void | setProblemType(int thePbType) Sets problem type.
void | setRoleName(String theRoleName) Sets role name.
void | setRoleValue(List theRoleValue) Sets role value.
String | toString() Return a string describing this object.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RoleUnresolved

public RoleUnresolved(String theRoleName,
                      List theRoleValue,
                      int thePbType)
               throws IllegalArgumentException
Constructor.

Parameters:
theRoleName - name of the role
theRoleValue - value of the role (if problem when setting the role)
thePbType - type of problem (according to known problem types, listed as static final members).
Throws:
IllegalArgumentException - if null parameter or incorrect problem type
Method Detail

getRoleName

public String getRoleName()
Retrieves role name.

Returns:
the role name.
See Also:
setRoleName(java.lang.String)

getRoleValue

public List getRoleValue()
Retrieves role value.

Returns:
an ArrayList of ObjectName objects, the one provided to be set in given role. Null if the unresolved role is returned for a read access.
See Also:
setRoleValue(java.util.List)

getProblemType

public int getProblemType()
Retrieves problem type.

Returns:
an integer corresponding to a problem, those being described as static final members of current class.
See Also:
setProblemType(int)

setRoleName

public void setRoleName(String theRoleName)
                 throws IllegalArgumentException
Sets role name.

Parameters:
theRoleName - the new role name.
Throws:
IllegalArgumentException - if null parameter
See Also:
getRoleName()

setRoleValue

public void setRoleValue(List theRoleValue)
Sets role value.

Parameters:
theRoleValue - ArrayList of ObjectName objects for referenced MBeans not set in role.
See Also:
getRoleValue()

setProblemType

public void setProblemType(int thePbType)
                    throws IllegalArgumentException
Sets problem type.

Parameters:
thePbType - integer corresponding to a problem. Must be one of those described as static final members of current class.
Throws:
IllegalArgumentException - if incorrect problem type
See Also:
getProblemType()

clone

public Object clone()
Clone this object.

Returns:
an independent clone.

toString

public String toString()
Return a string describing this object.

Returns:
a description of this RoleUnresolved object.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RoleUnresolvedList

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.relation
Class RoleUnresolvedList

java.lang.Object
    extended by java.util.AbstractCollection
        extended by java.util.AbstractList
            extended by java.util.ArrayList
                extended by javax.management.relation.RoleUnresolvedList
All Implemented Interfaces:
Cloneable, Collection, List, RandomAccess, Serializable
public class RoleUnresolvedList
extends ArrayList

A RoleUnresolvedList represents a list of RoleUnresolved objects, representing roles not retrieved from a relation due to a problem encountered when trying to access (read or write to roles).

See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
RoleUnresolvedList()
Constructs an empty RoleUnresolvedList.
RoleUnresolvedList(int theInitialCapacity)
Constructs an empty RoleUnresolvedList with the initial capacity specified.
RoleUnresolvedList(List theList)
Constructs a RoleUnresolvedList containing the elements of the ArrayList specified, in the order in which they are returned by the ArrayList's iterator.
Method Summary
void | add(int index, RoleUnresolved theRoleUnres) Inserts the unresolved role specified as an element at the position specified.
void | add(RoleUnresolved theRoleUnres) Adds the RoleUnresolved specified as the last element of the list.
boolean | addAll(int index, RoleUnresolvedList theRoleUnresolvedList) Inserts all of the elements in the RoleUnresolvedList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
boolean | addAll(RoleUnresolvedList theRoleUnresolvedList) Appends all the elements in the RoleUnresolvedList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
void | set(int index, RoleUnresolved theRoleUnres) Sets the element at the position specified to be the unresolved role specified.
Methods inherited from class java.util.ArrayList
add, add, addAll, addAll, clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, remove, removeRange, set, size, toArray, toArray, trimToSize
Methods inherited from class java.util.AbstractList
equals, hashCode, iterator, listIterator, listIterator, subList
Methods inherited from class java.util.AbstractCollection
containsAll, remove, removeAll, retainAll, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
containsAll, equals, hashCode, iterator, listIterator, listIterator, remove, removeAll, retainAll, subList

Constructor Detail

RoleUnresolvedList

public RoleUnresolvedList()
Constructs an empty RoleUnresolvedList.

RoleUnresolvedList

public RoleUnresolvedList(int theInitialCapacity)
Constructs an empty RoleUnresolvedList with the initial capacity specified.

Parameters:
theInitialCapacity - initial capacity

RoleUnresolvedList

public RoleUnresolvedList(List theList)
                   throws IllegalArgumentException
Constructs a RoleUnresolvedList containing the elements of the ArrayList specified, in the order in which they are returned by the ArrayList's iterator. The RoleUnresolvedList instance has an initial capacity of 110% of the size of the ArrayList specified.

Parameters:
theList - list of RoleUnresolved objects
Throws:
IllegalArgumentException - if:

- null parameter

or

- an element in the ArrayList is not a RoleUnresolved

Method Detail

add

public void add(RoleUnresolved theRoleUnres)
         throws IllegalArgumentException
Adds the RoleUnresolved specified as the last element of the list.

Parameters:
theRoleUnres - - the unresolved role to be added.
Throws:
IllegalArgumentException - if the unresolved role is null.

add

public void add(int index,
                RoleUnresolved theRoleUnres)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
Inserts the unresolved role specified as an element at the position specified. Elements with an index greater than or equal to the current position are shifted up.

Parameters:
index - - The position in the list where the new RoleUnresolved object is to be inserted.
theRoleUnres - - The RoleUnresolved object to be inserted.
Throws:
IllegalArgumentException - if the unresolved role is null.
IndexOutOfBoundsException - if index is out of range (index < 0 || index > size()).

set

public void set(int index,
                RoleUnresolved theRoleUnres)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
Sets the element at the position specified to be the unresolved role specified. The previous element at that position is discarded.

Parameters:
index - - The position specified.
theRoleUnres - - The value to which the unresolved role element should be set.
Throws:
IllegalArgumentException - if the unresolved role is null.
IndexOutOfBoundsException - if index is out of range (index < 0 || index >= size()).

addAll

public boolean addAll(RoleUnresolvedList theRoleUnresolvedList)
               throws IndexOutOfBoundsException
Appends all the elements in the RoleUnresolvedList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.

Parameters:
theRoleUnresolvedList - - Elements to be inserted into the list (can be null).
Returns:
true if this list changed as a result of the call.
Throws:
IndexOutOfBoundsException - if accessing with an index outside of the list.

addAll

public boolean addAll(int index,
                      RoleUnresolvedList theRoleUnresolvedList)
               throws IllegalArgumentException,
                      IndexOutOfBoundsException
Inserts all of the elements in the RoleUnresolvedList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.

Parameters:
index - - Position at which to insert the first element from the RoleUnresolvedList specified.
theRoleUnresolvedList - - Elements to be inserted into the list.
Returns:
true if this list changed as a result of the call.
Throws:
IllegalArgumentException - if the role is null.
IndexOutOfBoundsException - if index is out of range (index < 0 || index > size()).
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RuntimeErrorException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class RuntimeErrorException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.management.JMRuntimeException
                    extended by javax.management.RuntimeErrorException
All Implemented Interfaces:
Serializable
public class RuntimeErrorException
extends JMRuntimeException

When a java.lang.Error occurs in the agent it should be caught and re-thrown as a RuntimeErrorException.

See Also:
Serialized Form

Constructor Summary
RuntimeErrorException(Error e)
Default constructor.
RuntimeErrorException(Error e, String message)
Constructor that allows a specific error message to be specified.
Method Summary
Throwable | getCause() Returns the actual Error thrown.
Error | getTargetError() Returns the actual Error thrown.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RuntimeErrorException

public RuntimeErrorException(Error e)
Default constructor.

Parameters:
e - the wrapped error.

RuntimeErrorException

public RuntimeErrorException(Error e,
                             String message)
Constructor that allows a specific error message to be specified.

Parameters:
e - the wrapped error.
message - the detail message.
Method Detail

getTargetError

public Error getTargetError()
Returns the actual Error thrown.

Returns:
the wrapped Error.

getCause

public Throwable getCause()
Returns the actual Error thrown.

Returns:
the wrapped Error.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RuntimeMBeanException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class RuntimeMBeanException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.management.JMRuntimeException
                    extended by javax.management.RuntimeMBeanException
All Implemented Interfaces:
Serializable
public class RuntimeMBeanException
extends JMRuntimeException

Represents runtime exceptions thrown by MBean methods in the agent. It "wraps" the actual java.lang.RuntimeException exception thrown. This exception will be built by the MBeanServer when a call to an MBean method throws a runtime exception.

See Also:
Serialized Form

Constructor Summary
RuntimeMBeanException(RuntimeException e)
Creates a RuntimeMBeanException that wraps the actual java.lang.RuntimeException.
RuntimeMBeanException(RuntimeException e, String message)
Creates a RuntimeMBeanException that wraps the actual java.lang.RuntimeException with a detailed message.
Method Summary
Throwable | getCause() Returns the actual RuntimeException thrown.
RuntimeException | getTargetException() Returns the actual RuntimeException thrown.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RuntimeMBeanException

public RuntimeMBeanException(RuntimeException e)
Creates a RuntimeMBeanException that wraps the actual java.lang.RuntimeException.

Parameters:
e - the wrapped exception.

RuntimeMBeanException

public RuntimeMBeanException(RuntimeException e,
                             String message)
Creates a RuntimeMBeanException that wraps the actual java.lang.RuntimeException with a detailed message.

Parameters:
e - the wrapped exception.
message - the detail message.
Method Detail

getTargetException

public RuntimeException getTargetException()
Returns the actual RuntimeException thrown.

Returns:
the wrapped RuntimeException.

getCause

public Throwable getCause()
Returns the actual RuntimeException thrown.

Returns:
the wrapped RuntimeException.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RuntimeOperationsException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class RuntimeOperationsException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.management.JMRuntimeException
                    extended by javax.management.RuntimeOperationsException
All Implemented Interfaces:
Serializable
public class RuntimeOperationsException
extends JMRuntimeException

Represents runtime exceptions thrown in the agent when performing operations on MBeans. It wraps the actual java.lang.RuntimeException thrown.

See Also:
Serialized Form

Constructor Summary
RuntimeOperationsException(RuntimeException e)
Creates a RuntimeOperationsException that wraps the actual java.lang.RuntimeException.
RuntimeOperationsException(RuntimeException e, String message)
Creates a RuntimeOperationsException that wraps the actual java.lang.RuntimeException with a detailed message.
Method Summary
Throwable | getCause() Returns the actual RuntimeException thrown.
RuntimeException | getTargetException() Returns the actual RuntimeException thrown.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RuntimeOperationsException

public RuntimeOperationsException(RuntimeException e)
Creates a RuntimeOperationsException that wraps the actual java.lang.RuntimeException.

Parameters:
e - the wrapped exception.

RuntimeOperationsException

public RuntimeOperationsException(RuntimeException e,
                                  String message)
Creates a RuntimeOperationsException that wraps the actual java.lang.RuntimeException with a detailed message.

Parameters:
e - the wrapped exception.
message - the detail message.
Method Detail

getTargetException

public RuntimeException getTargetException()
Returns the actual RuntimeException thrown.

Returns:
the wrapped RuntimeException.

getCause

public Throwable getCause()
Returns the actual RuntimeException thrown.

Returns:
the wrapped RuntimeException.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServiceNotFoundException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management
Class ServiceNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.management.JMException
                extended by javax.management.OperationsException
                    extended by javax.management.ServiceNotFoundException
All Implemented Interfaces:
Serializable
public class ServiceNotFoundException
extends OperationsException

Represents exceptions raised when a requested service is not supported.

See Also:
Serialized Form

Constructor Summary
ServiceNotFoundException()
Default constructor.
ServiceNotFoundException(String message)
Constructor that allows a specific error message to be specified.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServiceNotFoundException

public ServiceNotFoundException()
Default constructor.

ServiceNotFoundException

public ServiceNotFoundException(String message)
Constructor that allows a specific error message to be specified.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StandardMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management
Class StandardMBean

java.lang.Object
    extended by javax.management.StandardMBean
All Implemented Interfaces:
DynamicMBean
public class StandardMBean
extends Object
implements DynamicMBean

An MBean whose management interface is determined by reflection on a Java interface.

This class brings more flexibility to the notion of Management Interface in the use of Standard MBeans. Straightforward use of the patterns for Standard MBeans described in the JMX Specification means that there is a fixed relationship between the implementation class of an MBean and its management interface (i.e., if the implementation class is Thing, the management interface must be ThingMBean). This class makes it possible to keep the convenience of specifying the management interface with a Java interface, without requiring that there be any naming relationship between the implementation and interface classes.

By making a DynamicMBean out of an MBean, this class makes it possible to select any interface implemented by the MBean as its management interface, provided that it complies with JMX patterns (i.e., attributes defined by getter/setter etc...).

This class also provides hooks that make it possible to supply custom descriptions and names for the MBeanInfo returned by the DynamicMBean interface.

Using this class, an MBean can be created with any implementation class name Impl and with a management interface defined (as for current Standard MBeans) by any interface Intf, in one of two general ways:

  • Using the public constructor StandardMBean(impl,interface):
         MBeanServer mbs;
     ...
     Impl impl = new Impl(...);
     StandardMBean mbean = new StandardMBean(impl, Intf.class);
     mbs.registerMBean(mbean, objectName);
  • Subclassing StandardMBean:
         public class Impl extends StandardMBean implements Intf {
        public Impl() {
          super(Intf.class);
       }
       // implement methods of Intf
     }

     [...]

     MBeanServer mbs;
     ....
     Impl impl = new Impl();
     mbs.registerMBean(impl, objectName);

In either case, the class Impl must implement the interface Intf.

Standard MBeans based on the naming relationship between implementation and interface classes are of course still available.

Since:
JMX 1.2

Constructor Summary
protected | StandardMBean(Class mbeanInterface) Make a DynamicMBean out of this, using the specified mbeanInterface class.
 | StandardMBean(Object implementation, Class mbeanInterface) Make a DynamicMBean out of the object implementation, using the specified mbeanInterface class.
Method Summary
protected void | cacheMBeanInfo(MBeanInfo info) Customization hook: cache the MBeanInfo built for this object.
Object | getAttribute(String attribute) Obtain the value of a specific attribute of the Dynamic MBean.
AttributeList | getAttributes(String[] attributes) Get the values of several attributes of the Dynamic MBean.
protected MBeanInfo | getCachedMBeanInfo() Customization hook: Return the MBeanInfo cached for this object.
protected String | getClassName(MBeanInfo info) Customization hook: Get the className that will be used in the MBeanInfo returned by this MBean.
protected MBeanConstructorInfo[] | getConstructors(MBeanConstructorInfo[] ctors, Object impl) Customization hook: Get the MBeanConstructorInfo[] that will be used in the MBeanInfo returned by this MBean.
protected String | getDescription(MBeanAttributeInfo info) Customization hook: Get the description that will be used in the MBeanAttributeInfo returned by this MBean.
protected String | getDescription(MBeanConstructorInfo info) Customization hook: Get the description that will be used in the MBeanConstructorInfo returned by this MBean.
protected String | getDescription(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) Customization hook: Get the description that will be used for the sequence MBeanParameterInfo of the MBeanConstructorInfo returned by this MBean.
protected String | getDescription(MBeanFeatureInfo info) Customization hook: Get the description that will be used in the MBeanFeatureInfo returned by this MBean.
protected String | getDescription(MBeanInfo info) Customization hook: Get the description that will be used in the MBeanInfo returned by this MBean.
protected String | getDescription(MBeanOperationInfo info) Customization hook: Get the description that will be used in the MBeanOperationInfo returned by this MBean.
protected String | getDescription(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) Customization hook: Get the description that will be used for the sequence MBeanParameterInfo of the MBeanOperationInfo returned by this MBean.
protected int | getImpact(MBeanOperationInfo info) Customization hook: Get the impact flag of the operation that will be used in the MBeanOperationInfo returned by this MBean.
Object | getImplementation() Get the implementation of this MBean.
Class | getImplementationClass() Get the class of the implementation of this MBean.
MBeanInfo | getMBeanInfo() Get the MBeanInfo for this MBean.
Class | getMBeanInterface() Get the Management Interface of this MBean.
protected String | getParameterName(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) Customization hook: Get the name that will be used for the sequence MBeanParameterInfo of the MBeanConstructorInfo returned by this MBean.
protected String | getParameterName(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) Customization hook: Get the name that will be used for the sequence MBeanParameterInfo of the MBeanOperationInfo returned by this MBean.
Object | invoke(String actionName, Object[] params, String[] signature) Allows an action to be invoked on the Dynamic MBean.
void | setAttribute(Attribute attribute) Set the value of a specific attribute of the Dynamic MBean.
AttributeList | setAttributes(AttributeList attributes) Sets the values of several attributes of the Dynamic MBean.
void | setImplementation(Object implementation) Replace the implementation object wrapped in this object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StandardMBean

public StandardMBean(Object implementation,
                     Class mbeanInterface)
              throws NotCompliantMBeanException

Make a DynamicMBean out of the object implementation, using the specified mbeanInterface class.

Parameters:
implementation - The implementation of this MBean.
mbeanInterface - The Management Interface exported by this MBean's implementation. If null, then this object will use standard JMX design pattern to determine the management interface associated with the given implementation.
Throws:
IllegalArgumentException - if the given implementation is null.
NotCompliantMBeanException - if the mbeanInterface does not follow JMX design patterns for Management Interfaces, or if the given implementation does not implement the specified interface.

StandardMBean

protected StandardMBean(Class mbeanInterface)
                 throws NotCompliantMBeanException

Make a DynamicMBean out of this, using the specified mbeanInterface class.

Call this(this,mbeanInterface). This constructor is reserved to subclasses.

Parameters:
mbeanInterface - The Management Interface exported by this MBean.
Throws:
NotCompliantMBeanException - if the mbeanInterface does not follow JMX design patterns for Management Interfaces, or if this does not implement the specified interface.
Method Detail

setImplementation

public void setImplementation(Object implementation)
                       throws NotCompliantMBeanException

Replace the implementation object wrapped in this object.

Parameters:
implementation - The new implementation of this MBean. The implementation object must implement the MBean interface that was supplied when this StandardMBean was constructed.
Throws:
IllegalArgumentException - if the given implementation is null.
NotCompliantMBeanException - if the given implementation does not implement the MBean interface that was supplied at construction.
See Also:
getImplementation()

getImplementation

public Object getImplementation()
Get the implementation of this MBean.

Returns:
The implementation of this MBean.
See Also:
setImplementation(java.lang.Object)

getMBeanInterface

public final Class getMBeanInterface()
Get the Management Interface of this MBean.

Returns:
The management interface of this MBean.

getImplementationClass

public Class getImplementationClass()
Get the class of the implementation of this MBean.

Returns:
The class of the implementation of this MBean.

getAttribute

public Object getAttribute(String attribute)
                    throws AttributeNotFoundException,
                           MBeanException,
                           ReflectionException
Description copied from interface: DynamicMBean
Obtain the value of a specific attribute of the Dynamic MBean.

Specified by:
getAttribute in interface DynamicMBean
Parameters:
attribute - The name of the attribute to be retrieved
Returns:
The value of the attribute retrieved.
Throws:
ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the getter.
AttributeNotFoundException
MBeanException - Wraps a java.lang.Exception thrown by the MBean's getter.
See Also:
DynamicMBean.setAttribute(javax.management.Attribute)

setAttribute

public void setAttribute(Attribute attribute)
                  throws AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
Description copied from interface: DynamicMBean
Set the value of a specific attribute of the Dynamic MBean.

Specified by:
setAttribute in interface DynamicMBean
Parameters:
attribute - The identification of the attribute to be set and the value it is to be set to.
Throws:
InvalidAttributeValueException
AttributeNotFoundException
MBeanException - Wraps a java.lang.Exception thrown by the MBean's setter.
ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the MBean's setter.
See Also:
DynamicMBean.getAttribute(java.lang.String)

getAttributes

public AttributeList getAttributes(String[] attributes)
Description copied from interface: DynamicMBean
Get the values of several attributes of the Dynamic MBean.

Specified by:
getAttributes in interface DynamicMBean
Parameters:
attributes - A list of the attributes to be retrieved.
Returns:
The list of attributes retrieved.
See Also:
DynamicMBean.setAttributes(javax.management.AttributeList)

setAttributes

public AttributeList setAttributes(AttributeList attributes)
Description copied from interface: DynamicMBean
Sets the values of several attributes of the Dynamic MBean.

Specified by:
setAttributes in interface DynamicMBean
Parameters:
attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to.
Returns:
The list of attributes that were set, with their new values.
See Also:
DynamicMBean.getAttributes(java.lang.String[])

invoke

public Object invoke(String actionName,
                     Object[] params,
                     String[] signature)
              throws MBeanException,
                     ReflectionException
Description copied from interface: DynamicMBean
Allows an action to be invoked on the Dynamic MBean.

Specified by:
invoke in interface DynamicMBean
Parameters:
actionName - The name of the action to be invoked.
params - An array containing the parameters to be set when the action is invoked.
signature - An array containing the signature of the action. The class objects will be loaded through the same class loader as the one used for loading the MBean on which the action is invoked.
Returns:
The object returned by the action, which represents the result of invoking the action on the MBean specified.
Throws:
MBeanException - Wraps a java.lang.Exception thrown by the MBean's invoked method.
ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the method

getMBeanInfo

public MBeanInfo getMBeanInfo()
Get the MBeanInfo for this MBean.

This method implements DynamicMBean.getMBeanInfo().

This method first calls getCachedMBeanInfo() in order to retrieve the cached MBeanInfo for this MBean, if any. If the MBeanInfo returned by getCachedMBeanInfo() is not null, then it is returned.
Otherwise, this method builds a default MBeanInfo for this MBean, using the Management Interface specified for this MBean.

While building the MBeanInfo, this method calls the customization hooks that make it possible for subclasses to supply their custom descriptions, parameter names, etc...
Finally, it calls cacheMBeanInfo() in order to cache the new MBeanInfo.

Specified by:
getMBeanInfo in interface DynamicMBean
Returns:
The cached MBeanInfo for that MBean, if not null, or a newly built MBeanInfo if none was cached.

getClassName

protected String getClassName(MBeanInfo info)
Customization hook: Get the className that will be used in the MBeanInfo returned by this MBean.
Subclasses may redefine this method in order to supply their custom class name. The default implementation returns info.getClassName().

Parameters:
info - The default MBeanInfo derived by reflection.
Returns:
the class name for the new MBeanInfo.

getDescription

protected String getDescription(MBeanInfo info)
Customization hook: Get the description that will be used in the MBeanInfo returned by this MBean.
Subclasses may redefine this method in order to supply their custom MBean description. The default implementation returns info.getDescription().

Parameters:
info - The default MBeanInfo derived by reflection.
Returns:
the description for the new MBeanInfo.

getDescription

protected String getDescription(MBeanFeatureInfo info)

Customization hook: Get the description that will be used in the MBeanFeatureInfo returned by this MBean.

Subclasses may redefine this method in order to supply their custom description. The default implementation returns info.getDescription().

This method is called by getDescription(MBeanAttributeInfo), getDescription(MBeanOperationInfo), getDescription(MBeanConstructorInfo).

Parameters:
info - The default MBeanFeatureInfo derived by reflection.
Returns:
the description for the given MBeanFeatureInfo.

getDescription

protected String getDescription(MBeanAttributeInfo info)
Customization hook: Get the description that will be used in the MBeanAttributeInfo returned by this MBean.

Subclasses may redefine this method in order to supply their custom description. The default implementation returns getDescription((MBeanFeatureInfo) info).

Parameters:
info - The default MBeanAttributeInfo derived by reflection.
Returns:
the description for the given MBeanAttributeInfo.

getDescription

protected String getDescription(MBeanConstructorInfo info)
Customization hook: Get the description that will be used in the MBeanConstructorInfo returned by this MBean.
Subclasses may redefine this method in order to supply their custom description. The default implementation returns getDescription((MBeanFeatureInfo) info).

Parameters:
info - The default MBeanConstructorInfo derived by reflection.
Returns:
the description for the given MBeanConstructorInfo.

getDescription

protected String getDescription(MBeanConstructorInfo ctor,
                                MBeanParameterInfo param,
                                int sequence)
Customization hook: Get the description that will be used for the sequence MBeanParameterInfo of the MBeanConstructorInfo returned by this MBean.
Subclasses may redefine this method in order to supply their custom description. The default implementation returns param.getDescription().

Parameters:
ctor - The default MBeanConstructorInfo derived by reflection.
param - The default MBeanParameterInfo derived by reflection.
sequence - The sequence number of the parameter considered ("0" for the first parameter, "1" for the second parameter, etc...).
Returns:
the description for the given MBeanParameterInfo.

getParameterName

protected String getParameterName(MBeanConstructorInfo ctor,
                                  MBeanParameterInfo param,
                                  int sequence)
Customization hook: Get the name that will be used for the sequence MBeanParameterInfo of the MBeanConstructorInfo returned by this MBean.
Subclasses may redefine this method in order to supply their custom parameter name. The default implementation returns param.getName().

Parameters:
ctor - The default MBeanConstructorInfo derived by reflection.
param - The default MBeanParameterInfo derived by reflection.
sequence - The sequence number of the parameter considered ("0" for the first parameter, "1" for the second parameter, etc...).
Returns:
the name for the given MBeanParameterInfo.

getDescription

protected String getDescription(MBeanOperationInfo info)
Customization hook: Get the description that will be used in the MBeanOperationInfo returned by this MBean.
Subclasses may redefine this method in order to supply their custom description. The default implementation returns getDescription((MBeanFeatureInfo) info).

Parameters:
info - The default MBeanOperationInfo derived by reflection.
Returns:
the description for the given MBeanOperationInfo.

getImpact

protected int getImpact(MBeanOperationInfo info)
Customization hook: Get the impact flag of the operation that will be used in the MBeanOperationInfo returned by this MBean.
Subclasses may redefine this method in order to supply their custom impact flag. The default implementation returns info.getImpact().

Parameters:
info - The default MBeanOperationInfo derived by reflection.
Returns:
the impact flag for the given MBeanOperationInfo.

getParameterName

protected String getParameterName(MBeanOperationInfo op,
                                  MBeanParameterInfo param,
                                  int sequence)
Customization hook: Get the name that will be used for the sequence MBeanParameterInfo of the MBeanOperationInfo returned by this MBean.
Subclasses may redefine this method in order to supply their custom parameter name. The default implementation returns param.getName().

Parameters:
op - The default MBeanOperationInfo derived by reflection.
param - The default MBeanParameterInfo derived by reflection.
sequence - The sequence number of the parameter considered ("0" for the first parameter, "1" for the second parameter, etc...).
Returns:
the name to use for the given MBeanParameterInfo.

getDescription

protected String getDescription(MBeanOperationInfo op,
                                MBeanParameterInfo param,
                                int sequence)
Customization hook: Get the description that will be used for the sequence MBeanParameterInfo of the MBeanOperationInfo returned by this MBean.
Subclasses may redefine this method in order to supply their custom description. The default implementation returns param.getDescription().

Parameters:
op - The default MBeanOperationInfo derived by reflection.
param - The default MBeanParameterInfo derived by reflection.
sequence - The sequence number of the parameter considered ("0" for the first parameter, "1" for the second parameter, etc...).
Returns:
the description for the given MBeanParameterInfo.

getConstructors

protected MBeanConstructorInfo[] getConstructors(MBeanConstructorInfo[] ctors,
                                                 Object impl)
Customization hook: Get the MBeanConstructorInfo[] that will be used in the MBeanInfo returned by this MBean.
By default, this method returns null if the wrapped implementation is not this. Indeed, if the wrapped implementation is not this object itself, it will not be possible to recreate a wrapped implementation by calling the implementation constructors through MBeanServer.createMBean(...).
Otherwise, if the wrapped implementation is this, ctors is returned.
Subclasses may redefine this method in order to modify this behaviour, if needed.

Parameters:
ctors - The default MBeanConstructorInfo[] derived by reflection.
impl - The wrapped implementation. If null is passed, the wrapped implementation is ignored and ctors is returned.
Returns:
the MBeanConstructorInfo[] for the new MBeanInfo.

getCachedMBeanInfo

protected MBeanInfo getCachedMBeanInfo()
Customization hook: Return the MBeanInfo cached for this object.

Subclasses may redefine this method in order to implement their own caching policy. The default implementation stores one MBeanInfo object per instance.

Returns:
The cached MBeanInfo, or null if no MBeanInfo is cached.
See Also:
cacheMBeanInfo(MBeanInfo)

cacheMBeanInfo

protected void cacheMBeanInfo(MBeanInfo info)
Customization hook: cache the MBeanInfo built for this object.

Subclasses may redefine this method in order to implement their own caching policy. The default implementation stores info in this instance. A subclass can define other policies, such as not saving info (so it is reconstructed every time getMBeanInfo() is called) or sharing a unique MBeanInfo object when several StandardMBean instances have equal MBeanInfo values.

Parameters:
info - the new MBeanInfo to cache. Any previously cached value is discarded. This parameter may be null, in which case there is no new cached value.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StringValueExp

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management
Class StringValueExp

java.lang.Object
    extended by javax.management.StringValueExp
All Implemented Interfaces:
Serializable, ValueExp
public class StringValueExp
extends Object
implements ValueExp

Represents strings that are arguments to relational constraints. A StringValueExp may be used anywhere a ValueExp is required.

See Also:
Serialized Form

Constructor Summary
StringValueExp()
Basic constructor.
StringValueExp(String val)
Creates a new StringValueExp representing the given string.
Method Summary
ValueExp | apply(ObjectName name) Applies the ValueExp on a MBean.
String | getValue() Returns the string represented by the StringValueExp instance.
void | setMBeanServer(MBeanServer s) Sets the MBean server on which the query is to be performed.
String | toString() Returns the string representing the object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StringValueExp

public StringValueExp()
Basic constructor.

StringValueExp

public StringValueExp(String val)
Creates a new StringValueExp representing the given string.

Parameters:
val - the string that will be the value of this expression
Method Detail

getValue

public String getValue()
Returns the string represented by the StringValueExp instance.

Returns:
the string.

toString

public String toString()
Returns the string representing the object.

setMBeanServer

public void setMBeanServer(MBeanServer s)
Sets the MBean server on which the query is to be performed.

Specified by:
setMBeanServer in interface ValueExp
Parameters:
s - The MBean server on which the query is to be performed.

apply

public ValueExp apply(ObjectName name)
               throws BadStringOperationException,
                      BadBinaryOpValueExpException,
                      BadAttributeValueExpException,
                      InvalidApplicationException
Applies the ValueExp on a MBean.

Specified by:
apply in interface ValueExp
Parameters:
name - The name of the MBean on which the ValueExp will be applied.
Returns:
The ValueExp.
Throws:
BadStringOperationException
BadBinaryOpValueExpException
BadAttributeValueExpException
InvalidApplicationException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


timer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management.timer

Provides the definition of the Timer MBean.

See:
Description

Interface Summary
TimerMBean Exposes the management interface of the timer MBean.

Class Summary
Timer | Provides the implementation of the timer MBean.
TimerAlarmClockNotification | Deprecated. This class is of no use to user code.
TimerNotification | This class provides definitions of the notifications sent by timer MBeans.

Package javax.management.timer Description

Provides the definition of the Timer MBean.

Since:
JMX 1.0
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.management.timer Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management.timer

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.management.Notification
        • class javax.management.timer.TimerAlarmClockNotification
        • class javax.management.timer.TimerNotification
    • class javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • class javax.management.timer.Timer (implements javax.management.MBeanRegistration, javax.management.timer.TimerMBean)

Interface Hierarchy

  • interface javax.management.timer.TimerMBean
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Timer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.timer
Class Timer

java.lang.Object
    extended by javax.management.NotificationBroadcasterSupport
        extended by javax.management.timer.Timer
All Implemented Interfaces:
MBeanRegistration, NotificationBroadcaster, NotificationEmitter, TimerMBean
public class Timer
extends NotificationBroadcasterSupport
implements TimerMBean, MBeanRegistration

Provides the implementation of the timer MBean. The timer MBean sends out an alarm at a specified time that wakes up all the listeners registered to receive timer notifications.

This class manages a list of dated timer notifications. A method allows users to add/remove as many notifications as required. When a timer notification is emitted by the timer and becomes obsolete, it is automatically removed from the list of timer notifications.
Additional timer notifications can be added into regularly repeating notifications.

Note:

  1. All notifications before the time when the addNotification method is called are ignored, irrespective of the sendPastNotifications flag.
  2. When sending timer notifications, the timer updates the notification sequence number irrespective of the notification type.
  3. The timer service relies on the system date of the host where the Timer class is loaded. Listeners may receive untimely notifications if their host has a different system date. To avoid such problems, synchronize the system date of all host machines where timing is needed.
  4. The default behaviour for periodic notifications is fixed-delay execution, as specified in Timer. In order to use fixed-rate execution, use the overloaded addNotification(String, String, Object, Date, long, long, boolean) method.
  5. Notification listeners are potentially all executed in the same thread. Therefore, they should execute rapidly to avoid holding up other listeners or perturbing the regularity of fixed-delay executions. See NotificationBroadcasterSupport.

Version:
4.47 10/03/02
Author:
Sun Microsystems, Inc

Field Summary
static long | ONE_DAY Number of milliseconds in one day.
static long | ONE_HOUR Number of milliseconds in one hour.
static long | ONE_MINUTE Number of milliseconds in one minute.
static long | ONE_SECOND Number of milliseconds in one second.
static long | ONE_WEEK Number of milliseconds in one week.
Constructor Summary
Timer()
Default constructor.
Method Summary
Integer | addNotification(String type, String message, Object userData, Date date) Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurences.
Integer | addNotification(String type, String message, Object userData, Date date, long period) Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurences.
Integer | addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.
Integer | addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.
Vector | getAllNotificationIDs() Gets all timer notification identifiers registered into the list of notifications.
Date | getDate(Integer id) Gets a copy of the date associated to a timer notification.
Boolean | getFixedRate(Integer id) Gets a copy of the flag indicating whether a peridic notification is executed at fixed-delay or at fixed-rate.
int | getNbNotifications() Gets the number of timer notifications registered into the list of notifications.
Long | getNbOccurences(Integer id) Gets a copy of the remaining number of occurences associated to a timer notification.
Vector | getNotificationIDs(String type) Gets all the identifiers of timer notifications corresponding to the specified type.
String | getNotificationMessage(Integer id) Gets the timer notification detailed message corresponding to the specified identifier.
String | getNotificationType(Integer id) Gets the timer notification type corresponding to the specified identifier.
Object | getNotificationUserData(Integer id) Gets the timer notification user data object corresponding to the specified identifier.
Long | getPeriod(Integer id) Gets a copy of the period (in milliseconds) associated to a timer notification.
boolean | getSendPastNotifications() Gets the flag indicating whether or not the timer sends past notifications.
boolean | isActive() Tests whether the timer MBean is active.
boolean | isEmpty() Tests whether the list of timer notifications is empty.
void | postDeregister() Allows the timer MBean to perform any operations needed after having been unregistered by the MBean server.
void | postRegister(Boolean registrationDone) Allows the timer MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
void | preDeregister() Allows the timer MBean to perform any operations it needs before being unregistered by the MBean server.
ObjectName | preRegister(MBeanServer server, ObjectName name) Allows the timer MBean to perform any operations it needs before being registered in the MBean server.
void | removeAllNotifications() Removes all the timer notifications from the list of notifications and resets the counter used to update the timer notification identifiers.
void | removeNotification(Integer id) Removes the timer notification corresponding to the specified identifier from the list of notifications.
void | removeNotifications(String type) Removes all the timer notifications corresponding to the specified type from the list of notifications.
void | setSendPastNotifications(boolean value) Sets the flag indicating whether the timer sends past notifications or not.
void | start() Starts the timer.
void | stop() Stops the timer.
Methods inherited from class javax.management.NotificationBroadcasterSupport
addNotificationListener, getNotificationInfo, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ONE_SECOND

public static final long ONE_SECOND
Number of milliseconds in one second. Useful constant for the addNotification method.

See Also:
Constant Field Values

ONE_MINUTE

public static final long ONE_MINUTE
Number of milliseconds in one minute. Useful constant for the addNotification method.

See Also:
Constant Field Values

ONE_HOUR

public static final long ONE_HOUR
Number of milliseconds in one hour. Useful constant for the addNotification method.

See Also:
Constant Field Values

ONE_DAY

public static final long ONE_DAY
Number of milliseconds in one day. Useful constant for the addNotification method.

See Also:
Constant Field Values

ONE_WEEK

public static final long ONE_WEEK
Number of milliseconds in one week. Useful constant for the addNotification method.

See Also:
Constant Field Values
Constructor Detail

Timer

public Timer()
Default constructor.

Method Detail

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
Allows the timer MBean to perform any operations it needs before being registered in the MBean server.

Not used in this context.

Specified by:
preRegister in interface MBeanRegistration
Parameters:
server - The MBean server in which the timer MBean will be registered.
name - The object name of the timer MBean.
Returns:
The name of the timer MBean registered.
Throws:
Exception

postRegister

public void postRegister(Boolean registrationDone)
Allows the timer MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.

Not used in this context.

Specified by:
postRegister in interface MBeanRegistration
Parameters:
registrationDone - Indicates whether or not the MBean has been successfully registered in the MBean server. The value false means that the registration phase has failed.

preDeregister

public void preDeregister()
                   throws Exception
Allows the timer MBean to perform any operations it needs before being unregistered by the MBean server.

Stops the timer.

Specified by:
preDeregister in interface MBeanRegistration
Throws:
Exception

postDeregister

public void postDeregister()
Allows the timer MBean to perform any operations needed after having been unregistered by the MBean server.

Not used in this context.

Specified by:
postDeregister in interface MBeanRegistration

start

public void start()
Starts the timer.

If there is one or more timer notifications before the time in the list of notifications, the notification is sent according to the sendPastNotifications flag and then, updated according to its period and remaining number of occurences. If the timer notification date remains earlier than the current date, this notification is just removed from the list of notifications.

Specified by:
start in interface TimerMBean

stop

public void stop()
Stops the timer.

Specified by:
stop in interface TimerMBean

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date,
                               long period,
                               long nbOccurences,
                               boolean fixedRate)
                        throws IllegalArgumentException
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.

If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date.
For once-off notifications, the notification is delivered immediately.
For periodic notifications, the first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

Note that once the timer notification has been added into the list of notifications, its associated date, period and number of occurences cannot be updated.

In the case of a periodic notification, the value of parameter fixedRate is used to specify the execution scheme, as specified in Timer.

Specified by:
addNotification in interface TimerMBean
Parameters:
type - The timer notification type.
message - The timer notification detailed message.
userData - The timer notification user data object.
date - The date when the notification occurs.
period - The period of the timer notification (in milliseconds).
nbOccurences - The total number the timer notification will be emitted.
fixedRate - If true and if the notification is periodic, the notification is scheduled with a fixed-rate execution scheme. If false and if the notification is periodic, the notification is scheduled with a fixed-delay execution scheme. Ignored if the notification is not periodic.
Returns:
The identifier of the new created timer notification.
Throws:
IllegalArgumentException - The period or the number of occurences is negative
See Also:
addNotification(String, String, Object, Date, long, long)

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date,
                               long period,
                               long nbOccurences)
                        throws IllegalArgumentException
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.

If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date.
For once-off notifications, the notification is delivered immediately.
For periodic notifications, the first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

Note that once the timer notification has been added into the list of notifications, its associated date, period and number of occurences cannot be updated.

In the case of a periodic notification, uses a fixed-delay execution scheme, as specified in Timer. In order to use a fixed-rate execution scheme, use addNotification(String, String, Object, Date, long, long, boolean) instead.

Specified by:
addNotification in interface TimerMBean
Parameters:
type - The timer notification type.
message - The timer notification detailed message.
userData - The timer notification user data object.
date - The date when the notification occurs.
period - The period of the timer notification (in milliseconds).
nbOccurences - The total number the timer notification will be emitted.
Returns:
The identifier of the new created timer notification.
Throws:
IllegalArgumentException - The period or the number of occurences is negative
See Also:
addNotification(String, String, Object, Date, long, long, boolean)

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date,
                               long period)
                        throws IllegalArgumentException
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurences.

The timer notification will repeat continuously using the timer period using a fixed-delay execution scheme, as specified in Timer. In order to use a fixed-rate execution scheme, use addNotification(String, String, Object, Date, long, long, boolean) instead.

If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date. The first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

Specified by:
addNotification in interface TimerMBean
Parameters:
type - The timer notification type.
message - The timer notification detailed message.
userData - The timer notification user data object.
date - The date when the notification occurs.
period - The period of the timer notification (in milliseconds).
Returns:
The identifier of the new created timer notification.
Throws:
IllegalArgumentException - The period is negative or the date notification is before the current date.

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date)
                        throws IllegalArgumentException
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurences.

The timer notification will be handled once at the specified date.

If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date and the notification is delivered immediately.

Specified by:
addNotification in interface TimerMBean
Parameters:
type - The timer notification type.
message - The timer notification detailed message.
userData - The timer notification user data object.
date - The date when the notification occurs.
Returns:
The identifier of the new created timer notification.
Throws:
IllegalArgumentException - The date notification is before the current date.

removeNotification

public void removeNotification(Integer id)
                        throws InstanceNotFoundException
Removes the timer notification corresponding to the specified identifier from the list of notifications.

Specified by:
removeNotification in interface TimerMBean
Parameters:
id - The timer notification identifier.
Throws:
InstanceNotFoundException - The specified identifier does not correspond to any timer notification in the list of notifications of this timer MBean.

removeNotifications

public void removeNotifications(String type)
                         throws InstanceNotFoundException
Removes all the timer notifications corresponding to the specified type from the list of notifications.

Specified by:
removeNotifications in interface TimerMBean
Parameters:
type - The timer notification type.
Throws:
InstanceNotFoundException - The specified type does not correspond to any timer notification in the list of notifications of this timer MBean.

removeAllNotifications

public void removeAllNotifications()
Removes all the timer notifications from the list of notifications and resets the counter used to update the timer notification identifiers.

Specified by:
removeAllNotifications in interface TimerMBean

getNbNotifications

public int getNbNotifications()
Gets the number of timer notifications registered into the list of notifications.

Specified by:
getNbNotifications in interface TimerMBean
Returns:
The number of timer notifications.

getAllNotificationIDs

public Vector getAllNotificationIDs()
Gets all timer notification identifiers registered into the list of notifications.

Specified by:
getAllNotificationIDs in interface TimerMBean
Returns:
A vector of Integer objects containing all the timer notification identifiers.
The vector is empty if there is no timer notification registered for this timer MBean.

getNotificationIDs

public Vector getNotificationIDs(String type)
Gets all the identifiers of timer notifications corresponding to the specified type.

Specified by:
getNotificationIDs in interface TimerMBean
Parameters:
type - The timer notification type.
Returns:
A vector of Integer objects containing all the identifiers of timer notifications with the specified type.
The vector is empty if there is no timer notifications registered for this timer MBean with the specified type.

getNotificationType

public String getNotificationType(Integer id)
Gets the timer notification type corresponding to the specified identifier.

Specified by:
getNotificationType in interface TimerMBean
Parameters:
id - The timer notification identifier.
Returns:
The timer notification type or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getNotificationMessage

public String getNotificationMessage(Integer id)
Gets the timer notification detailed message corresponding to the specified identifier.

Specified by:
getNotificationMessage in interface TimerMBean
Parameters:
id - The timer notification identifier.
Returns:
The timer notification detailed message or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getNotificationUserData

public Object getNotificationUserData(Integer id)
Gets the timer notification user data object corresponding to the specified identifier.

Specified by:
getNotificationUserData in interface TimerMBean
Parameters:
id - The timer notification identifier.
Returns:
The timer notification user data object or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getDate

public Date getDate(Integer id)
Gets a copy of the date associated to a timer notification.

Specified by:
getDate in interface TimerMBean
Parameters:
id - The timer notification identifier.
Returns:
A copy of the date or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getPeriod

public Long getPeriod(Integer id)
Gets a copy of the period (in milliseconds) associated to a timer notification.

Specified by:
getPeriod in interface TimerMBean
Parameters:
id - The timer notification identifier.
Returns:
A copy of the period or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getNbOccurences

public Long getNbOccurences(Integer id)
Gets a copy of the remaining number of occurences associated to a timer notification.

Specified by:
getNbOccurences in interface TimerMBean
Parameters:
id - The timer notification identifier.
Returns:
A copy of the remaining number of occurences or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getFixedRate

public Boolean getFixedRate(Integer id)
Gets a copy of the flag indicating whether a peridic notification is executed at fixed-delay or at fixed-rate.

Specified by:
getFixedRate in interface TimerMBean
Parameters:
id - The timer notification identifier.
Returns:
A copy of the flag indicating whether a peridic notification is executed at fixed-delay or at fixed-rate.

getSendPastNotifications

public boolean getSendPastNotifications()
Gets the flag indicating whether or not the timer sends past notifications.
The default value of the past notifications sending on/off flag is false.

Specified by:
getSendPastNotifications in interface TimerMBean
Returns:
The past notifications sending on/off flag value.
See Also:
setSendPastNotifications(boolean)

setSendPastNotifications

public void setSendPastNotifications(boolean value)
Sets the flag indicating whether the timer sends past notifications or not.
The default value of the past notifications sending on/off flag is false.

Specified by:
setSendPastNotifications in interface TimerMBean
Parameters:
value - The past notifications sending on/off flag value.
See Also:
getSendPastNotifications()

isActive

public boolean isActive()
Tests whether the timer MBean is active. A timer MBean is marked active when the start method is called. It becomes inactive when the stop method is called.
The default value of the active on/off flag is false.

Specified by:
isActive in interface TimerMBean
Returns:
true if the timer MBean is active, false otherwise.

isEmpty

public boolean isEmpty()
Tests whether the list of timer notifications is empty.

Specified by:
isEmpty in interface TimerMBean
Returns:
true if the list of timer notifications is empty, false otherwise.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TimerAlarmClockNotification

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.timer
Class TimerAlarmClockNotification

java.lang.Object
    extended by java.util.EventObject
        extended by javax.management.Notification
            extended by javax.management.timer.TimerAlarmClockNotification
All Implemented Interfaces:
Serializable
Deprecated. This class is of no use to user code. It is retained purely for compatibility reasons.

public class TimerAlarmClockNotification
extends Notification

Definitions of the notifications sent by TimerAlarmClock MBeans.

Since:
JMX 1.1
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.Notification
source
Constructor Summary
TimerAlarmClockNotification(javax.management.timer.TimerAlarmClock source)
Deprecated. Constructor.
Methods inherited from class javax.management.Notification
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TimerAlarmClockNotification

public TimerAlarmClockNotification(javax.management.timer.TimerAlarmClock source)
Deprecated.
Constructor.

Parameters:
source - the source.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TimerMBean

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.timer
Interface TimerMBean

All Known Implementing Classes:
Timer
public interface TimerMBean

Exposes the management interface of the timer MBean.

Version:
4.17 09/06/02
Author:
Sun Microsystems, Inc

Method Summary
Integer | addNotification(String type, String message, Object userData, Date date) Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurences.
Integer | addNotification(String type, String message, Object userData, Date date, long period) Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurences.
Integer | addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.
Integer | addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.
Vector | getAllNotificationIDs() Gets all timer notification identifiers registered into the list of notifications.
Date | getDate(Integer id) Gets a copy of the date associated to a timer notification.
Boolean | getFixedRate(Integer id) Gets a copy of the flag indicating whether a peridic notification is executed at fixed-delay or at fixed-rate.
int | getNbNotifications() Gets the number of timer notifications registered into the list of notifications.
Long | getNbOccurences(Integer id) Gets a copy of the remaining number of occurences associated to a timer notification.
Vector | getNotificationIDs(String type) Gets all the identifiers of timer notifications corresponding to the specified type.
String | getNotificationMessage(Integer id) Gets the timer notification detailed message corresponding to the specified identifier.
String | getNotificationType(Integer id) Gets the timer notification type corresponding to the specified identifier.
Object | getNotificationUserData(Integer id) Gets the timer notification user data object corresponding to the specified identifier.
Long | getPeriod(Integer id) Gets a copy of the period (in milliseconds) associated to a timer notification.
boolean | getSendPastNotifications() Gets the flag indicating whether or not the timer sends past notifications.
boolean | isActive() Tests whether the timer MBean is active.
boolean | isEmpty() Tests whether the list of timer notifications is empty.
void | removeAllNotifications() Removes all the timer notifications from the list of notifications and resets the counter used to update the timer notification identifiers.
void | removeNotification(Integer id) Removes the timer notification corresponding to the specified identifier from the list of notifications.
void | removeNotifications(String type) Removes all the timer notifications corresponding to the specified type from the list of notifications.
void | setSendPastNotifications(boolean value) Sets the flag indicating whether the timer sends past notifications or not.
void | start() Starts the timer.
void | stop() Stops the timer.

Method Detail

start

public void start()
Starts the timer.

If there is one or more timer notifications before the time in the list of notifications, the notification is sent according to the sendPastNotifications flag and then, updated according to its period and remaining number of occurences. If the timer notification date remains earlier than the current date, this notification is just removed from the list of notifications.

stop

public void stop()
Stops the timer.

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date,
                               long period,
                               long nbOccurences,
                               boolean fixedRate)
                        throws IllegalArgumentException
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.

If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date.
For once-off notifications, the notification is delivered immediately.
For periodic notifications, the first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

Note that once the timer notification has been added into the list of notifications, its associated date, period and number of occurences cannot be updated.

In the case of a periodic notification, the value of parameter fixedRate is used to specify the execution scheme, as specified in Timer.

Parameters:
type - The timer notification type.
message - The timer notification detailed message.
userData - The timer notification user data object.
date - The date when the notification occurs.
period - The period of the timer notification (in milliseconds).
nbOccurences - The total number the timer notification will be emitted.
fixedRate - If true and if the notification is periodic, the notification is scheduled with a fixed-rate execution scheme. If false and if the notification is periodic, the notification is scheduled with a fixed-delay execution scheme. Ignored if the notification is not periodic.
Returns:
The identifier of the new created timer notification.
Throws:
IllegalArgumentException - The period or the number of occurences is negative
See Also:
addNotification(String, String, Object, Date, long, long)

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date,
                               long period,
                               long nbOccurences)
                        throws IllegalArgumentException
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurences.

If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date.
For once-off notifications, the notification is delivered immediately.
For periodic notifications, the first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

Note that once the timer notification has been added into the list of notifications, its associated date, period and number of occurences cannot be updated.

In the case of a periodic notification, uses a fixed-delay execution scheme, as specified in Timer. In order to use a fixed-rate execution scheme, use addNotification(String, String, Object, Date, long, long, boolean) instead.

Parameters:
type - The timer notification type.
message - The timer notification detailed message.
userData - The timer notification user data object.
date - The date when the notification occurs.
period - The period of the timer notification (in milliseconds).
nbOccurences - The total number the timer notification will be emitted.
Returns:
The identifier of the new created timer notification.
Throws:
IllegalArgumentException - The period or the number of occurences is negative
See Also:
addNotification(String, String, Object, Date, long, long, boolean)

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date,
                               long period)
                        throws IllegalArgumentException
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurences.

The timer notification will repeat continuously using the timer period using a fixed-delay execution scheme, as specified in Timer. In order to use a fixed-rate execution scheme, use addNotification(String, String, Object, Date, long, long, boolean) instead.

If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date. The first notification is delivered immediately and the subsequent ones are spaced as specified by the period parameter.

Parameters:
type - The timer notification type.
message - The timer notification detailed message.
userData - The timer notification user data object.
date - The date when the notification occurs.
period - The period of the timer notification (in milliseconds).
Returns:
The identifier of the new created timer notification.
Throws:
IllegalArgumentException - The period is negative or the date notification is before the current date.

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date)
                        throws IllegalArgumentException
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurences.

The timer notification will be handled once at the specified date.

If the timer notification to be inserted has a date that is before the current date, the method behaves as if the specified date were the current date and the notification is delivered immediately.

Parameters:
type - The timer notification type.
message - The timer notification detailed message.
userData - The timer notification user data object.
date - The date when the notification occurs.
Returns:
The identifier of the new created timer notification.
Throws:
IllegalArgumentException - The date notification is before the current date.

removeNotification

public void removeNotification(Integer id)
                        throws InstanceNotFoundException
Removes the timer notification corresponding to the specified identifier from the list of notifications.

Parameters:
id - The timer notification identifier.
Throws:
InstanceNotFoundException - The specified identifier does not correspond to any timer notification in the list of notifications of this timer MBean.

removeNotifications

public void removeNotifications(String type)
                         throws InstanceNotFoundException
Removes all the timer notifications corresponding to the specified type from the list of notifications.

Parameters:
type - The timer notification type.
Throws:
InstanceNotFoundException - The specified type does not correspond to any timer notification in the list of notifications of this timer MBean.

removeAllNotifications

public void removeAllNotifications()
Removes all the timer notifications from the list of notifications and resets the counter used to update the timer notification identifiers.

getNbNotifications

public int getNbNotifications()
Gets the number of timer notifications registered into the list of notifications.

Returns:
The number of timer notifications.

getAllNotificationIDs

public Vector getAllNotificationIDs()
Gets all timer notification identifiers registered into the list of notifications.

Returns:
A vector of Integer objects containing all the timer notification identifiers.
The vector is empty if there is no timer notification registered for this timer MBean.

getNotificationIDs

public Vector getNotificationIDs(String type)
Gets all the identifiers of timer notifications corresponding to the specified type.

Parameters:
type - The timer notification type.
Returns:
A vector of Integer objects containing all the identifiers of timer notifications with the specified type.
The vector is empty if there is no timer notifications registered for this timer MBean with the specified type.

getNotificationType

public String getNotificationType(Integer id)
Gets the timer notification type corresponding to the specified identifier.

Parameters:
id - The timer notification identifier.
Returns:
The timer notification type or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getNotificationMessage

public String getNotificationMessage(Integer id)
Gets the timer notification detailed message corresponding to the specified identifier.

Parameters:
id - The timer notification identifier.
Returns:
The timer notification detailed message or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getNotificationUserData

public Object getNotificationUserData(Integer id)
Gets the timer notification user data object corresponding to the specified identifier.

Parameters:
id - The timer notification identifier.
Returns:
The timer notification user data object or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getDate

public Date getDate(Integer id)
Gets a copy of the date associated to a timer notification.

Parameters:
id - The timer notification identifier.
Returns:
A copy of the date or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getPeriod

public Long getPeriod(Integer id)
Gets a copy of the period (in milliseconds) associated to a timer notification.

Parameters:
id - The timer notification identifier.
Returns:
A copy of the period or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getNbOccurences

public Long getNbOccurences(Integer id)
Gets a copy of the remaining number of occurences associated to a timer notification.

Parameters:
id - The timer notification identifier.
Returns:
A copy of the remaining number of occurences or null if the identifier is not mapped to any timer notification registered for this timer MBean.

getFixedRate

public Boolean getFixedRate(Integer id)
Gets a copy of the flag indicating whether a peridic notification is executed at fixed-delay or at fixed-rate.

Parameters:
id - The timer notification identifier.
Returns:
A copy of the flag indicating whether a peridic notification is executed at fixed-delay or at fixed-rate.

getSendPastNotifications

public boolean getSendPastNotifications()
Gets the flag indicating whether or not the timer sends past notifications.

Returns:
The past notifications sending on/off flag value.
See Also:
setSendPastNotifications(boolean)

setSendPastNotifications

public void setSendPastNotifications(boolean value)
Sets the flag indicating whether the timer sends past notifications or not.

Parameters:
value - The past notifications sending on/off flag value.
See Also:
getSendPastNotifications()

isActive

public boolean isActive()
Tests whether the timer MBean is active. A timer MBean is marked active when the start method is called. It becomes inactive when the stop method is called.

Returns:
true if the timer MBean is active, false otherwise.

isEmpty

public boolean isEmpty()
Tests whether the list of timer notifications is empty.

Returns:
true if the list of timer notifications is empty, false otherwise.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TimerNotification

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.timer
Class TimerNotification

java.lang.Object
    extended by java.util.EventObject
        extended by javax.management.Notification
            extended by javax.management.timer.TimerNotification
All Implemented Interfaces:
Serializable
public class TimerNotification
extends Notification

This class provides definitions of the notifications sent by timer MBeans.
It defines a timer notification identifier which allows to retrieve a timer notification from the list of notifications of a timer MBean.

The timer notifications are created and handled by the timer MBean.

Version:
1.13 08/27/02
Author:
Sun Microsystems, Inc
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.management.Notification
source
Constructor Summary
TimerNotification(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)
Creates a timer notification object.
Method Summary
 Integer getNotificationID()
Gets the identifier of this timer notification.
Methods inherited from class javax.management.Notification
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TimerNotification

public TimerNotification(String type,
                         Object source,
                         long sequenceNumber,
                         long timeStamp,
                         String msg,
                         Integer id)
Creates a timer notification object.

Parameters:
type - The notification type.
source - The notification producer.
sequenceNumber - The notification sequence number within the source object.
timeStamp - The notification emission date.
msg - The notification message.
id - The notification identifier.
Since:
JMX 1.2
Method Detail

getNotificationID

public Integer getNotificationID()
Gets the identifier of this timer notification.

Returns:
The identifier.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ValueExp

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management
Interface ValueExp

All Superinterfaces:
Serializable
All Known Implementing Classes:
AttributeValueExp, StringValueExp
public interface ValueExp
extends Serializable

Represents values that can be passed as arguments to relational expressions. Strings, numbers, attributes are valid values and should be represented by implementations of ValueExp.

Method Summary
ValueExp | apply(ObjectName name) Applies the ValueExp on a MBean.
void | setMBeanServer(MBeanServer s) Deprecated. This method is not needed because a ValueExp can access the MBean server in which it is being evaluated by using QueryEval.getMBeanServer().

Method Detail

apply

public ValueExp apply(ObjectName name)
               throws BadStringOperationException,
                      BadBinaryOpValueExpException,
                      BadAttributeValueExpException,
                      InvalidApplicationException
Applies the ValueExp on a MBean.

Parameters:
name - The name of the MBean on which the ValueExp will be applied.
Returns:
The ValueExp.
Throws:
BadStringOperationException
BadBinaryOpValueExpException
BadAttributeValueExpException
InvalidApplicationException

setMBeanServer

public void setMBeanServer(MBeanServer s)
Deprecated. This method is not needed because a ValueExp can access the MBean server in which it is being evaluated by using QueryEval.getMBeanServer().

Sets the MBean server on which the query is to be performed.

Parameters:
s - The MBean server on which the query is to be performed.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


resource

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource

The javax.resource package is the top-level package for the J2EE Connector API specification.

See:
Description

Interface Summary
Referenceable The Referenceable interface extends the javax.naming.Referenceable interface.

Exception Summary
NotSupportedException | A NotSupportedException is thrown to indicate that callee (resource adapter or application server for system contracts) cannot execute an operation because the operation is not a supported feature.
ResourceException | This is the root interface of the exception hierarchy defined for the Connector architecture.

Package javax.resource Description

The javax.resource package is the top-level package for the J2EE Connector API specification.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.resource Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.resource.ResourceException
          • class javax.resource.NotSupportedException

Interface Hierarchy

  • interface javax.naming.Referenceable
    • interface javax.resource.Referenceable
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


cci

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource.cci

The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

See:
Description

Interface Summary
Connection | A Connection represents an application-level handle that is used by a client to access the underlying physical connection.
ConnectionFactory | ConnectionFactory provides an interface for getting connection to an EIS instance.
ConnectionMetaData | The interface ConnectionMetaData provides information about an EIS instance connected through a Connection instance.
ConnectionSpec | ConnectionSpec is used by an application component to pass connection request-specific properties to the ConnectionFactory.
IndexedRecord | IndexedRecord represents an ordered collection of record elements based on the java.util.List interface.
Interaction | The javax.resource.cci.Interaction enables a component to execute EIS functions.
InteractionSpec | An InteractionSpec holds properties for driving an Interaction with an EIS instance.
LocalTransaction | The LocalTransaction defines a transaction demarcation interface for resource manager local transactions.
MappedRecord | The interface javax.resource.cci.MappedRecord is used for key-value map based representation of record elements.
MessageListener | This serves as a request-response message listener type that message endpoints (message-driven beans) may implement.
Record | The javax.resource.cci.Record interface is the base interface for the representation of an input or output to the execute methods defined on an Interaction.
RecordFactory | The RecordFactory interface is used for creating MappedRecord and IndexedRecord instances.
ResourceAdapterMetaData | The interface javax.resource.cci.ResourceAdapterMetaData provides information about capabilities of a resource adapter implementation.
ResultSet | A ResultSet represents tabular data that is retrieved from an EIS instance by the execution of an Interaction..
ResultSetInfo | The interface javax.resource.cci.ResultSetInfo provides information on the support provided for ResultSet by a connected EIS instance.
Streamable | Streamable interface enables a resource adapter to extract data from an input Record or set data into an output Record as a stream of bytes.

Exception Summary
ResourceWarning A ResourceWarning provides information on warnings related to execution of an interaction with an EIS.

Package javax.resource.cci Description

The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionSpec

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ConnectionSpec

public interface ConnectionSpec

ConnectionSpec is used by an application component to pass connection request-specific properties to the ConnectionFactory. getConnection method.

It is recommended that the ConnectionSpec interface be implemented as a JavaBean to support tools. The properties on the ConnectionSpec implementation class must be defined through the getter and setter methods pattern.

The CCI specification defines a set of standard properties for an ConnectionSpec. The properties are defined either on a derived interface or an implementation class of an empty ConnectionSpec interface. In addition, a resource adapter may define additional properties specific to its underlying EIS.

Version:
1.0 Public Draft 1
Author:
Rahul Sharma
See Also:
ConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


IndexedRecord

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface IndexedRecord

All Superinterfaces:
Cloneable, Collection, List, Record, Serializable
public interface IndexedRecord
extends Record, List, Serializable

IndexedRecord represents an ordered collection of record elements based on the java.util.List interface. This interface allows a client to access elements by their integer index (position in the list) and search for elements in the List.

Since:
0.8
Author:
Rahul Sharma

Methods inherited from interface javax.resource.cci.Record
clone, equals, getRecordName, getRecordShortDescription, hashCode, setRecordName, setRecordShortDescription
Methods inherited from interface java.util.List
add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, remove, remove, removeAll, retainAll, set, size, subList, toArray, toArray

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.resource.cci Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource.cci

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.resource.ResourceException
          • class javax.resource.cci.ResourceWarning

Interface Hierarchy

  • interface java.lang.Cloneable
    • interface javax.resource.cci.Record (also extends java.io.Serializable)
      • interface javax.resource.cci.IndexedRecord (also extends java.util.List, java.io.Serializable)
      • interface javax.resource.cci.MappedRecord (also extends java.util.Map, java.io.Serializable)
      • interface javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
  • interface java.util.Collection
    • interface java.util.List
      • interface javax.resource.cci.IndexedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
  • interface javax.resource.cci.Connection
  • interface javax.resource.cci.ConnectionMetaData
  • interface javax.resource.cci.ConnectionSpec
  • interface javax.resource.cci.Interaction
  • interface javax.resource.cci.LocalTransaction
  • interface java.util.Map
    • interface javax.resource.cci.MappedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
  • interface javax.resource.cci.MessageListener
  • interface javax.resource.cci.RecordFactory
  • interface javax.naming.Referenceable
    • interface javax.resource.Referenceable
      • interface javax.resource.cci.ConnectionFactory (also extends java.io.Serializable)
  • interface javax.resource.cci.ResourceAdapterMetaData
  • interface java.sql.ResultSet
    • interface javax.resource.cci.ResultSet (also extends javax.resource.cci.Record)
  • interface javax.resource.cci.ResultSetInfo
  • interface java.io.Serializable
    • interface javax.resource.cci.ConnectionFactory (also extends javax.resource.Referenceable)
    • interface javax.resource.cci.IndexedRecord (also extends java.util.List, javax.resource.cci.Record)
    • interface javax.resource.cci.InteractionSpec
    • interface javax.resource.cci.MappedRecord (also extends java.util.Map, javax.resource.cci.Record)
    • interface javax.resource.cci.Record (also extends java.lang.Cloneable)
      • interface javax.resource.cci.IndexedRecord (also extends java.util.List, java.io.Serializable)
      • interface javax.resource.cci.MappedRecord (also extends java.util.Map, java.io.Serializable)
      • interface javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
  • interface javax.resource.cci.Streamable
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ResultSet

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ResultSet

All Superinterfaces:
Cloneable, Record, ResultSet, Serializable
public interface ResultSet
extends Record, ResultSet

A ResultSet represents tabular data that is retrieved from an EIS instance by the execution of an Interaction.. The CCI ResultSet is based on the JDBC ResultSet.

Refer the CCI specification in Connectors 1.0 for detailed requirements on the implementation of a CCI ResultSet.

Since:
0.8
Author:
Rahul Sharma
See Also:
ResultSet

Field Summary
Fields inherited from interface java.sql.ResultSet
CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE
Methods inherited from interface javax.resource.cci.Record
clone, equals, getRecordName, getRecordShortDescription, hashCode, setRecordName, setRecordShortDescription
Methods inherited from interface java.sql.ResultSet
absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getInt, getInt, getLong, getLong, getMetaData, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getShort, getShort, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, next, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateShort, updateShort, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Connection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface Connection

public interface Connection

A Connection represents an application-level handle that is used by a client to access the underlying physical connection. The actual physical connection associated with a Connection instance is represented by a ManagedConnection instance.

A client gets a Connection instance by using the getConnection method on a ConnectionFactory instance. A connection can be associated with zero or more Interaction instances.

Version:
0.8
Author:
Rahul Sharma
See Also:
ConnectionFactory, Interaction

Method Summary
void | close() Initiates close of the connection handle at the application level.
Interaction | createInteraction() Creates an Interaction associated with this Connection.
LocalTransaction | getLocalTransaction() Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection.
ConnectionMetaData | getMetaData() Gets the information on the underlying EIS instance represented through an active connection.
ResultSetInfo | getResultSetInfo() Gets the information on the ResultSet functionality supported by a connected EIS instance.

Method Detail

createInteraction

public Interaction createInteraction()
                              throws ResourceException
Creates an Interaction associated with this Connection. An Interaction enables an application to execute EIS functions.

Returns:
Interaction instance
Throws:
ResourceException - Failed to create an Interaction

getLocalTransaction

public LocalTransaction getLocalTransaction()
                                     throws ResourceException
Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection. If a resource adapter does not allow a component to demarcate local transactions on an Connection using LocalTransaction interface, then the method getLocalTransaction should throw a NotSupportedException.

Returns:
LocalTransaction instance
Throws:
ResourceException - Failed to return a LocalTransaction instance because of a resource adapter error
NotSupportedException - Demarcation of Resource manager local transactions is not supported on this Connection
See Also:
LocalTransaction

getMetaData

public ConnectionMetaData getMetaData()
                               throws ResourceException
Gets the information on the underlying EIS instance represented through an active connection.

Returns:
ConnectionMetaData instance representing information about the EIS instance
Throws:
ResourceException - Failed to get information about the connected EIS instance. Error can be resource adapter-internal, EIS-specific or communication related.

getResultSetInfo

public ResultSetInfo getResultSetInfo()
                               throws ResourceException
Gets the information on the ResultSet functionality supported by a connected EIS instance.

Returns:
ResultSetInfo instance
Throws:
ResourceException - Failed to get ResultSet related information
NotSupportedException - ResultSet functionality is not supported

close

public void close()
           throws ResourceException
Initiates close of the connection handle at the application level. A client should not use a closed connection to interact with an EIS.

Throws:
ResourceException - Exception thrown if close on a connection handle fails.

Any invalid connection close invocation--example, calling close on a connection handle that is already closed--should also throw this exception.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ConnectionFactory

All Superinterfaces:
Referenceable, Referenceable, Serializable
public interface ConnectionFactory
extends Serializable, Referenceable

ConnectionFactory provides an interface for getting connection to an EIS instance. An implementation of ConnectionFactory interface is provided by a resource adapter.

Application code looks up a ConnectionFactory instance from JNDI namespace and uses it to get EIS connections.

An implementation class for ConnectionFactory is required to implement java.io.Serializable and javax.resource.Referenceableinterfaces to support JNDI registration.

Version:
0.8
Author:
Rahul Sharma
See Also:
Connection, Referenceable

Method Summary
Connection | getConnection() Gets a connection to an EIS instance.
Connection | getConnection(ConnectionSpec properties) Gets a connection to an EIS instance.
ResourceAdapterMetaData | getMetaData() Gets metadata for the Resource Adapter.
RecordFactory | getRecordFactory() Gets a RecordFactory instance.
Methods inherited from interface javax.resource.Referenceable
setReference
Methods inherited from interface javax.naming.Referenceable
getReference

Method Detail

getConnection

public Connection getConnection()
                         throws ResourceException
Gets a connection to an EIS instance. This getConnection variant should be used when a component wants the container to manage EIS sign-on. This case is termed container-managed sign-on. The component does not pass any security information.

Returns:
Connection instance
Throws:
ResourceException - Failed to get a connection to the EIS instance. Examples of error cases are:
  • Invalid configuration of ManagedConnectionFactory-- example: invalid server name
  • Application server-internal error--example: connection pool related error
  • Communication error
  • EIS-specific error--example: EIS not active
  • Resource adapter-internal error
  • Security related error; example: invalid user
  • Failure to allocate system resources

getConnection

public Connection getConnection(ConnectionSpec properties)
                         throws ResourceException
Gets a connection to an EIS instance. A component should use the getConnection variant with javax.resource.cci.ConnectionSpec parameter, if it needs to pass any resource adapter specific security information and connection parameters. In the component- managed sign-on case, an application component passes security information (example: username, password) through the ConnectionSpec instance.

It is important to note that the properties passed through the getConnection method should be client-specific (example: username, password, language) and not related to the configuration of a target EIS instance (example: port number, server name). The ManagedConnectionFactory instance is configured with complete set of properties required for the creation of a connection to an EIS instance.

Parameters:
properties - Connection parameters and security information specified as ConnectionSpec instance
Returns:
Connection instance
Throws:
ResourceException - Failed to get a connection to the EIS instance. Examples of error cases are:
  • Invalid specification of input parameters
  • Invalid configuration of ManagedConnectionFactory-- example: invalid server name
  • Application server-internal error--example: connection pool related error
  • Communication error
  • EIS-specific error--example: EIS not active
  • Resource adapter-internal error
  • Security related error; example: invalid user
  • Failure to allocate system resources
See Also:
ConnectionSpec

getRecordFactory

public RecordFactory getRecordFactory()
                               throws ResourceException
Gets a RecordFactory instance. The RecordFactory is used for the creation of generic Record instances.

Returns:
RecordFactory RecordFactory instance
Throws:
ResourceException - Failed to create a RecordFactory
NotSupportedException - Operation not supported

getMetaData

public ResourceAdapterMetaData getMetaData()
                                    throws ResourceException
Gets metadata for the Resource Adapter. Note that the metadata information is about the ResourceAdapter and not the EIS instance. An invocation of this method does not require that an active connection to an EIS instance should have been established.

Returns:
ResourceAdapterMetaData instance
Throws:
ResourceException - Failed to get metadata information about the resource adapter
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionMetaData

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ConnectionMetaData

public interface ConnectionMetaData

The interface ConnectionMetaData provides information about an EIS instance connected through a Connection instance. A component calls the method Connection.getMetaData to get a ConnectionMetaData instance.

Version:
0.8
Author:
Rahul Sharma
See Also:
Connection, ResultSetInfo

Method Summary
String | getEISProductName() Returns product name of the underlying EIS instance connected through the Connection that produced this metadata.
String | getEISProductVersion() Returns product version of the underlying EIS instance.
String | getUserName() Returns the user name for an active connection as known to the underlying EIS instance.

Method Detail

getEISProductName

public String getEISProductName()
                         throws ResourceException
Returns product name of the underlying EIS instance connected through the Connection that produced this metadata.

Returns:
Product name of the EIS instance
Throws:
ResourceException - Failed to get the information for the EIS instance

getEISProductVersion

public String getEISProductVersion()
                            throws ResourceException
Returns product version of the underlying EIS instance.

Returns:
Product version of an EIS instance.
Throws:
ResourceException - Failed to get the information for the EIS instance

getUserName

public String getUserName()
                   throws ResourceException
Returns the user name for an active connection as known to the underlying EIS instance. The name corresponds the resource principal under whose security context a connection to the EIS instance has been established.

Returns:
String representing the user name
Throws:
ResourceException - Failed to get the information for the EIS instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Interaction

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface Interaction

public interface Interaction

The javax.resource.cci.Interaction enables a component to execute EIS functions. An Interaction instance supports the following ways of interacting with an EIS instance:

  • execute method that takes an input Record, output Record and an InteractionSpec. This method executes the EIS function represented by the InteractionSpec and updates the output Record
  • execute method that takes an input Record and an InteractionSpec. This method implementation executes the EIS function represented by the InteractionSpec and produces the output Record as a return value.

An Interaction instance is created from a Connection and is required to maintain its association with the Connection instance. The close method releases all resources maintained by the resource adapter for the Interaction. The close of an Interaction instance should not close the associated Connection instance.

Since:
0.8
Version:
0.8
Author:
Rahul Sharma
See Also:
ResultSet

Method Summary
void | clearWarnings() Clears all the warning reported by this Interaction instance.
void | close() Closes the current Interaction and release all the resources held for this instance by the resource adapter.
Record | execute(InteractionSpec ispec, Record input) Executes an interaction represented by the InteractionSpec.
boolean | execute(InteractionSpec ispec, Record input, Record output) Executes an interaction represented by the InteractionSpec.
Connection | getConnection() Gets the Connection associated with the Interaction.
ResourceWarning | getWarnings() Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.

Method Detail

close

public void close()
           throws ResourceException
Closes the current Interaction and release all the resources held for this instance by the resource adapter. The close of an Interaction instance does not close the associated Connection instance. It is recommended that Interaction instances be closed explicitly to free any held resources.

Throws:
ResourceException - Failed to close the Interaction instance. Invoking close on an already closed Interaction should also throw this exception.

getConnection

public Connection getConnection()
Gets the Connection associated with the Interaction.

Returns:
Connection instance associated with the Interaction

execute

public boolean execute(InteractionSpec ispec,
                       Record input,
                       Record output)
                throws ResourceException
Executes an interaction represented by the InteractionSpec. This form of invocation takes an input Record and updates the output Record.

Parameters:
ispec - InteractionSpec representing a target EIS data/function module
input - Input Record
output - Output Record
Returns:
true if execution of the EIS function has been successful and output Record has been updated; false otherwise
Throws:
ResourceException - Exception if execute operation fails. Examples of error cases are:
  • Resource adapter internal, EIS-specific or communication error
  • Invalid specification of an InteractionSpec, input or output record structure
  • Errors in use of input or output Record
  • Invalid connection associated with this Interaction
NotSupportedException - Operation not supported

execute

public Record execute(InteractionSpec ispec,
                      Record input)
               throws ResourceException
Executes an interaction represented by the InteractionSpec. This form of invocation takes an input Record and returns an output Record if the execution of the Interaction has been successfull.

Parameters:
ispec - InteractionSpec representing a target EIS data/function module
input - Input Record
Returns:
output Record if execution of the EIS function has been successful; null otherwise
Throws:
ResourceException - Exception if execute operation fails. Examples of error cases are:
  • Resource adapter internal, EIS-specific or communication error
  • Invalid specification of an InteractionSpec or input record structure
  • Errors in use of input Record or creation of an output Record
  • Invalid connection associated with this Interaction
NotSupportedException - Operation not supported

getWarnings

public ResourceWarning getWarnings()
                            throws ResourceException
Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.

Returns:
ResourceWarning at top of the warning chain
Throws:
ResourceException - Failed to get ResourceWarnings associated with Interaction

clearWarnings

public void clearWarnings()
                   throws ResourceException
Clears all the warning reported by this Interaction instance. After a call to this method, the method getWarnings will return null until a new warning is reported for this Interaction.

Throws:
ResourceException - Failed to clear ResourceWarnings associated with Interaction
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InteractionSpec

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface InteractionSpec

All Superinterfaces:
Serializable
public interface InteractionSpec
extends Serializable

An InteractionSpec holds properties for driving an Interaction with an EIS instance. An InteractionSpec is used by an Interaction to execute the specified function on an underlying EIS.

The CCI specification defines a set of standard properties for an InteractionSpec. An InteractionSpec implementation is not required to support a standard property if that property does not apply to its underlying EIS.

The InteractionSpec implementation class must provide getter and setter methods for each of its supported properties. The getter and setter methods convention should be based on the Java Beans design pattern.

The standard properties are as follows:

  • FunctionName: name of an EIS function
  • InteractionVerb: mode of interaction with an EIS instance: SYNC_SEND, SYNC_SEND_RECEIVE, SYNC_RECEIVE
  • ExecutionTimeout: the number of milliseconds an Interaction will wait for an EIS to execute the specified function

The following standard properties are used to give hints to an Interaction instance about the ResultSet requirements:

  • FetchSize
  • FetchDirection
  • MaxFieldSize
  • ResultSetType
  • ResultSetConcurrency

A CCI implementation can provide additional properties beyond that described in the InteractionSpec interface. Note that the format and type of the additional properties is specific to an EIS and is outside the scope of the CCI specification.

It is required that the InteractionSpec interface be implemented as a JavaBean for the toolability support. The properties on the InteractionSpec implementation class should be defined through the getter and setter methods pattern. An implementation class for InteractionSpec interface is required to implement the java.io.Serializable interface.

Since:
0.8
Version:
0.8
Author:
Rahul Sharma
See Also:
Interaction

Field Summary
static int | SYNC_RECEIVE The execution of an Interaction results in a synchronous receive of an output Record.
static int | SYNC_SEND Interaction Verb type: The execution of an Interaction does only a send to the target EIS instance.
static int | SYNC_SEND_RECEIVE Interaction Verb type: The execution of an Interaction sends a request to the EIS instance and receives response synchronously.

Field Detail

SYNC_SEND

public static final int SYNC_SEND
Interaction Verb type: The execution of an Interaction does only a send to the target EIS instance. The input record is sent to the EIS instance without any synchronous response in terms of an output Record or ResultSet.

See Also:
Constant Field Values

SYNC_SEND_RECEIVE

public static final int SYNC_SEND_RECEIVE
Interaction Verb type: The execution of an Interaction sends a request to the EIS instance and receives response synchronously. The input record is sent to the EIS instance with the output received either as Record or CCIResultSet.

See Also:
Constant Field Values

SYNC_RECEIVE

public static final int SYNC_RECEIVE
The execution of an Interaction results in a synchronous receive of an output Record. An example is: a session bean gets a method invocation and it uses this SEND_RECEIVE form of interaction to retrieve messages that have been delivered to a message queue.

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


LocalTransaction

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface LocalTransaction

public interface LocalTransaction

The LocalTransaction defines a transaction demarcation interface for resource manager local transactions. Note that this interface is used for application level local transaction demarcation. The system contract level LocalTransaction interface (as defined in the javax.resource.spi package) is used by the container for local transaction management.

A local transaction is managed internal to a resource manager. There is no external transaction manager involved in the coordination of such transactions.

A CCI implementation can (but is not required to) implement the LocalTransaction interface. If the LocalTransaction interface is supported by a CCI implementation, then the method Connection.getLocalTransaction should return a LocalTransaction instance. A component can then use the returned LocalTransaction to demarcate a resource manager local transaction (associated with the Connection instance) on the underlying EIS instance.

Since:
0.8
Author:
Rahul Sharma
See Also:
Connection

Method Summary
void | begin() Begins a local transaction on an EIS instance.
void | commit() Commits the current local transaction and release all locks held by the underlying EIS instance.
void | rollback() Rollbacks the current resource manager local transaction.

Method Detail

begin

public void begin()
           throws ResourceException
Begins a local transaction on an EIS instance.

Throws:
ResourceException - Failed to begin a local transaction. Examples of error cases are:
  • Resource adapter internal or EIS-specific error
  • Connection is already participating in a local or JTA transaction

commit

public void commit()
            throws ResourceException
Commits the current local transaction and release all locks held by the underlying EIS instance.

Throws:
ResourceException - Failed to commit a local transaction. Examples of error cases are:
  • Resource adapter internal or EIS-specific error
  • Violation of integrity constraints, deadlock detection, communication failure during transaction completion, or any retry requirement
  • Connection is participating in an active JTA transaction
  • Invalid transaction context; commit operation invoked without an active transaction context

rollback

public void rollback()
              throws ResourceException
Rollbacks the current resource manager local transaction.

Throws:
ResourceException - Failed to rollback a local transaction. Examples of error cases are:
  • Resource adapter internal or EIS-specific error
  • Connection is participating in an active JTA transaction
  • Invalid transaction context; rollback operation invoked without an active transaction context
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MappedRecord

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface MappedRecord

All Superinterfaces:
Cloneable, Map, Record, Serializable
public interface MappedRecord
extends Record, Map, Serializable

The interface javax.resource.cci.MappedRecord is used for key-value map based representation of record elements. The MappedRecord interface extends both Record and java.util.Mapinterfaces.

Version:
0.8
Author:
Rahul Sharma

Nested Class Summary
Nested classes inherited from class java.util.Map
Map.Entry
Methods inherited from interface javax.resource.cci.Record
clone, equals, getRecordName, getRecordShortDescription, hashCode, setRecordName, setRecordShortDescription
Methods inherited from interface java.util.Map
clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface MessageListener

public interface MessageListener

This serves as a request-response message listener type that message endpoints (message-driven beans) may implement. This allows an EIS to communicate with an endpoint using a request-response style.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 Record onMessage(Record inputData)
This method allows an EIS to call a message endpoint using a request-response style communication.

Method Detail

onMessage

public Record onMessage(Record inputData)
                 throws ResourceException
This method allows an EIS to call a message endpoint using a request-response style communication.

Parameters:
inputData - a Record instance.
Returns:
a Record instance or null.
Throws:
ResourceException - indicates an exceptional condition.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Record

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface Record

All Superinterfaces:
Cloneable, Serializable
All Known Subinterfaces:
IndexedRecord, MappedRecord, ResultSet
public interface Record
extends Cloneable, Serializable

The javax.resource.cci.Record interface is the base interface for the representation of an input or output to the execute methods defined on an Interaction.

The Record interface can be extended to form a one of the following representations:

  • MappedRecord: A key-value pair based collection represents a record. This interface is based on the java.util.Map
  • IndexedRecord:An ordered and indexed collection represents a record. This interface is based on the java.util.List.
  • JavaBean based representation of an EIS abstraction: An example is a custom record generated to represent a purchase order in an ERP system.
  • javax.resource.cci.ResultSet: This interface extends both java.sql.ResultSet and javax.resource.cci.Record. A ResultSet represents tabular data.

A MappedRecord or IndexedRecord can contain another Record. This means that MappedRecord and IndexedRecord can be used to create a hierarchical structure of any arbitrary depth. A basic Java type is used as the leaf element of a hierarchical structure represented by a MappedRecord or IndexedRecord.

Version:
0.8
Author:
Rahul Sharma
See Also:
Interaction, ResultSet

Method Summary
Object | clone() Creates and returns a copy of this object.
boolean | equals(Object other) Check if this instance is equal to another Record.
String | getRecordName() Gets the name of the Record.
String | getRecordShortDescription() Gets a short description string for the Record.
int | hashCode() Returns the hash code for the Record instance.
void | setRecordName(String name) Sets the name of the Record.
void | setRecordShortDescription(String description) Sets a short description string for the Record.

Method Detail

getRecordName

public String getRecordName()
Gets the name of the Record.

Returns:
String representing name of the Record

setRecordName

public void setRecordName(String name)
Sets the name of the Record.

Parameters:
name - Name of the Record

setRecordShortDescription

public void setRecordShortDescription(String description)
Sets a short description string for the Record. This property is used primarily by application development tools.

Parameters:
description - Description of the Record

getRecordShortDescription

public String getRecordShortDescription()
Gets a short description string for the Record. This property is used primarily by application development tools.

Returns:
String representing a short description of the Record

equals

public boolean equals(Object other)
Check if this instance is equal to another Record.

Returns:
true if two instances are equal

hashCode

public int hashCode()
Returns the hash code for the Record instance.

Returns:
hash code

clone

public Object clone()
             throws CloneNotSupportedException
Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object.

Returns:
a clone of this instance.
Throws:
CloneNotSupportedException - If the object's class does not support the Cloneable interface Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RecordFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface RecordFactory

public interface RecordFactory

The RecordFactory interface is used for creating MappedRecord and IndexedRecord instances. Note that the RecordFactory is only used for creation of generic record instances. A CCI implementation provides an implementation class for the RecordFactory interface.

Since:
0.8
Author:
Rahul Sharma
See Also:
IndexedRecord, MappedRecord

Method Summary
IndexedRecord | createIndexedRecord(String recordName) Creates a IndexedRecord.
MappedRecord | createMappedRecord(String recordName) Creates a MappedRecord.

Method Detail

createMappedRecord

public MappedRecord createMappedRecord(String recordName)
                                throws ResourceException
Creates a MappedRecord. The method takes the name of the record that is to be created by the RecordFactory. The name of the record acts as a pointer to the meta information (stored in the metadata repository) for a specific record type.

Parameters:
recordName - Name of the Record
Returns:
MappedRecord
Throws:
ResourceException - Failed to create a MappedRecord. Example error cases are:
  • Invalid specification of record name
  • Resource adapter internal error
  • Failed to access metadata repository
NotSupportedException - Operation not supported

createIndexedRecord

public IndexedRecord createIndexedRecord(String recordName)
                                  throws ResourceException
Creates a IndexedRecord. The method takes the name of the record that is to be created by the RecordFactory. The name of the record acts as a pointer to the meta information (stored in the metadata repository) for a specific record type.

Parameters:
recordName - Name of the Record
Returns:
IndexedRecord
Throws:
ResourceException - Failed to create an IndexedRecord. Example error cases are:
  • Invalid specification of record name
  • Resource adapter internal error
  • Failed to access metadata repository
NotSupportedException - Operation not supported
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ResourceAdapterMetaData

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ResourceAdapterMetaData

public interface ResourceAdapterMetaData

The interface javax.resource.cci.ResourceAdapterMetaData provides information about capabilities of a resource adapter implementation. Note that this interface does not provide information about an EIS instance that is connected through the resource adapter.

A CCI client uses a ConnectionFactory.getMetaData to get metadata information about the resource adapter. The getMetaData method does not require that an active connection to an EIS instance should have been established.

The ResourceAdapterMetaData can be extended to provide more information specific to a resource adapter implementation.

Since:
0.8
Version:
0.8
Author:
Rahul Sharma
See Also:
ConnectionFactory

Method Summary
 String getAdapterName()
Gets a tool displayable name of the resource adapter.
 String getAdapterShortDescription()
Gets a tool displayable short desription of the resource adapter.
 String getAdapterVendorName()
Gets the name of the vendor that has provided the resource adapter.
 String getAdapterVersion()
Gets the version of the resource adapter.
 String[] getInteractionSpecsSupported()
Returns an array of fully-qualified names of InteractionSpec types supported by the CCI implementation for this resource adapter.
 String getSpecVersion()
Returns a string representation of the version of the connector architecture specification that is supported by the resource adapter.
 boolean supportsExecuteWithInputAndOutputRecord()
Returns true if the implementation class for the Interaction interface implements public boolean execute(InteractionSpec ispec, Record input, Record output) method; otherwise the method returns false.
 boolean supportsExecuteWithInputRecordOnly()
Returns true if the implementation class for the Interaction interface implements public Record execute(InteractionSpec ispec, Record input) method; otherwise the method returns false.
 boolean supportsLocalTransactionDemarcation()
Returns true if the resource adapter implements the LocalTransaction interface and supports local transaction demarcation on the underlying EIS instance through the LocalTransaction interface.

Method Detail

getAdapterVersion

public String getAdapterVersion()
Gets the version of the resource adapter.

Returns:
String representing version of the resource adapter

getAdapterVendorName

public String getAdapterVendorName()
Gets the name of the vendor that has provided the resource adapter.

Returns:
String representing name of the vendor that has provided the resource adapter

getAdapterName

public String getAdapterName()
Gets a tool displayable name of the resource adapter.

Returns:
String representing the name of the resource adapter

getAdapterShortDescription

public String getAdapterShortDescription()
Gets a tool displayable short desription of the resource adapter.

Returns:
String describing the resource adapter

getSpecVersion

public String getSpecVersion()
Returns a string representation of the version of the connector architecture specification that is supported by the resource adapter.

Returns:
String representing the supported version of the connector architecture

getInteractionSpecsSupported

public String[] getInteractionSpecsSupported()
Returns an array of fully-qualified names of InteractionSpec types supported by the CCI implementation for this resource adapter. Note that the fully-qualified class name is for the implementation class of an InteractionSpec. This method may be used by tools vendor to find information on the supported InteractionSpec types. The method should return an array of length 0 if the CCI implementation does not define specific InteractionSpec types.

Returns:
Array of fully-qualified class names of InteractionSpec classes supported by this resource adapter's CCI implementation
See Also:
InteractionSpec

supportsExecuteWithInputAndOutputRecord

public boolean supportsExecuteWithInputAndOutputRecord()
Returns true if the implementation class for the Interaction interface implements public boolean execute(InteractionSpec ispec, Record input, Record output) method; otherwise the method returns false.

Returns:
boolean depending on method support
See Also:
Interaction

supportsExecuteWithInputRecordOnly

public boolean supportsExecuteWithInputRecordOnly()
Returns true if the implementation class for the Interaction interface implements public Record execute(InteractionSpec ispec, Record input) method; otherwise the method returns false.

Returns:
boolean depending on method support
See Also:
Interaction

supportsLocalTransactionDemarcation

public boolean supportsLocalTransactionDemarcation()
Returns true if the resource adapter implements the LocalTransaction interface and supports local transaction demarcation on the underlying EIS instance through the LocalTransaction interface.

Returns:
true if resource adapter supports resource manager local transaction demarcation through LocalTransaction interface; false otherwise
See Also:
LocalTransaction
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ResourceWarning

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Class ResourceWarning

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.cci.ResourceWarning
All Implemented Interfaces:
Serializable
public class ResourceWarning
extends ResourceException

A ResourceWarning provides information on warnings related to execution of an interaction with an EIS. Warnings are silently chained to the object whose method caused it to be reported.

See Also:
Interaction.getWarnings(), Serialized Form

Constructor Summary
ResourceWarning()
Constructs a new instance with null as its detail message.
ResourceWarning(String message)
Constructs a new instance with the specified detail message.
ResourceWarning(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
ResourceWarning(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
ResourceWarning(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
ResourceWarning | getLinkedWarning() Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
void | setLinkedWarning(ResourceWarning warning) Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResourceWarning

public ResourceWarning()
Constructs a new instance with null as its detail message.

ResourceWarning

public ResourceWarning(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

ResourceWarning

public ResourceWarning(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

ResourceWarning

public ResourceWarning(String message,
                       Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

ResourceWarning

public ResourceWarning(String message,
                       String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Method Detail

getLinkedWarning

public ResourceWarning getLinkedWarning()
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

Retrieves the warning chained to this ResourceWarning object.

Returns:
next ResourceWarning in the chain; null if none.

setLinkedWarning

public void setLinkedWarning(ResourceWarning warning)
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

Adds an ResourceWarning object to the end of the chain.

Parameters:
warning - ResourceWarning to be added to the chain.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ResultSetInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ResultSetInfo

public interface ResultSetInfo

The interface javax.resource.cci.ResultSetInfo provides information on the support provided for ResultSet by a connected EIS instance. A component calls the method Connection.getResultInfo to get the ResultSetInfo instance.

A CCI implementation is not required to support javax.resource.cci.ResultSetInfo interface. The implementation of this interface is provided only if the CCI supports the ResultSet facility.

Version:
0.9
Author:
Rahul Sharma
See Also:
Connection, ResultSet, ConnectionMetaData

Method Summary
boolean | deletesAreDetected(int type)
boolean | insertsAreDetected(int type) Indicates whether or not a visible row insert can be detected by calling ResultSet.rowInserted.
boolean | othersDeletesAreVisible(int type) Indicates whether deletes made by others are visible.
boolean | othersInsertsAreVisible(int type) Indicates whether inserts made by others are visible.
boolean | othersUpdatesAreVisible(int type) Indicates whether updates made by others are visible.
boolean | ownDeletesAreVisible(int type)
boolean | ownInsertsAreVisible(int type)
boolean | ownUpdatesAreVisible(int type)
boolean | supportsResultSetType(int type) Indicates whether or not a resource adapter supports a type of ResultSet.
boolean | supportsResultTypeConcurrency(int type, int concurrency) Indicates whether or not a resource adapter supports the concurrency type in combination with the given ResultSet type/
boolean | updatesAreDetected(int type) Indicates whether or not a visible row update can be detected by calling the method ResultSet.rowUpdated.

Method Detail

updatesAreDetected

public boolean updatesAreDetected(int type)
                           throws ResourceException
Indicates whether or not a visible row update can be detected by calling the method ResultSet.rowUpdated.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if changes are detected by the result set type; false otherwise
Throws:
ResourceException - Failed to get the information
See Also:
ResultSet.rowUpdated()

insertsAreDetected

public boolean insertsAreDetected(int type)
                           throws ResourceException
Indicates whether or not a visible row insert can be detected by calling ResultSet.rowInserted.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if changes are detected by the result set type; false otherwise
Throws:
ResourceException - Failed to get the information
See Also:
ResultSet.rowInserted()

deletesAreDetected

public boolean deletesAreDetected(int type)
                           throws ResourceException
Throws:
ResourceException

supportsResultSetType

public boolean supportsResultSetType(int type)
                              throws ResourceException
Indicates whether or not a resource adapter supports a type of ResultSet.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if ResultSet type supported; false otherwise
Throws:
ResourceException - Failed to get the information

supportsResultTypeConcurrency

public boolean supportsResultTypeConcurrency(int type,
                                             int concurrency)
                                      throws ResourceException
Indicates whether or not a resource adapter supports the concurrency type in combination with the given ResultSet type/

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
concurrency - ResultSet concurrency type defined in java.sql.ResultSet
Returns:
true if the specified combination supported; false otherwise
Throws:
ResourceException - Failed to get the information

othersUpdatesAreVisible

public boolean othersUpdatesAreVisible(int type)
                                throws ResourceException
Indicates whether updates made by others are visible.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if updates by others are visible for the ResultSet type; false otherwise
Throws:
ResourceException - Failed to get the information

othersDeletesAreVisible

public boolean othersDeletesAreVisible(int type)
                                throws ResourceException
Indicates whether deletes made by others are visible.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if deletes by others are visible for the ResultSet type; false otherwise
Throws:
ResourceException - Failed to get the information

othersInsertsAreVisible

public boolean othersInsertsAreVisible(int type)
                                throws ResourceException
Indicates whether inserts made by others are visible.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if inserts by others are visible for the ResultSet type; false otherwise
Throws:
ResourceException - Failed to get the information

ownUpdatesAreVisible

public boolean ownUpdatesAreVisible(int type)
                             throws ResourceException
Throws:
ResourceException

ownInsertsAreVisible

public boolean ownInsertsAreVisible(int type)
                             throws ResourceException
Throws:
ResourceException

ownDeletesAreVisible

public boolean ownDeletesAreVisible(int type)
                             throws ResourceException
Throws:
ResourceException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Streamable

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface Streamable

public interface Streamable

Streamable interface enables a resource adapter to extract data from an input Record or set data into an output Record as a stream of bytes.

The Streamable interface provides a resource adapter's view of the data that has been set in a Record instance by a component.

The Streamable interface is not directly used by a component. It is used by a resource adapter implementation. A component uses Record or any derived interfaces to manage records.

Since:
0.8
Author:
Rahul Sharma
See Also:
Record

Method Summary
void | read(InputStream istream) Read data from an InputStream and initialize fields of a Streamable object.
void | write(OutputStream ostream) Write fields of a Streamable object to an OutputStream

Method Detail

read

public void read(InputStream istream)
          throws IOException
Read data from an InputStream and initialize fields of a Streamable object.

Parameters:
istream - InputStream that represents a resource adapter specific internal representation of fields of a Streamable object
Throws:
IOException

write

public void write(OutputStream ostream)
           throws IOException
Write fields of a Streamable object to an OutputStream

Parameters:
ostream - OutputStream that holds value of a Streamable object
Throws:
IOException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NotSupportedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource
Class NotSupportedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.NotSupportedException
All Implemented Interfaces:
Serializable
public class NotSupportedException
extends ResourceException

A NotSupportedException is thrown to indicate that callee (resource adapter or application server for system contracts) cannot execute an operation because the operation is not a supported feature. For example, if the transaction support level for a resource adapter is NO_TRANSACTION, an invocation of getXAResource method on a ManagedConnection object should throw a NotSupportedException exception.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
NotSupportedException()
Constructs a new instance with null as its detail message.
NotSupportedException(String message)
Constructs a new instance with the specified detail message.
NotSupportedException(String message, String errorCode)
Constructs a new throwable with the specified detail message and error code.
NotSupportedException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
NotSupportedException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NotSupportedException

public NotSupportedException()
Constructs a new instance with null as its detail message.

NotSupportedException

public NotSupportedException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

NotSupportedException

public NotSupportedException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

NotSupportedException

public NotSupportedException(String message,
                             Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

NotSupportedException

public NotSupportedException(String message,
                             String errorCode)
Constructs a new throwable with the specified detail message and error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Referenceable

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource
Interface Referenceable

All Superinterfaces:
Referenceable
All Known Subinterfaces:
ConnectionFactory
public interface Referenceable
extends Referenceable

The Referenceable interface extends the javax.naming.Referenceable interface. It enables support for JNDI Reference mechanism for the registration of the connection factory in the JNDI name space. Note that the implementation and structure of Reference is specific to an application server.

The implementation class for a connection factory interface is required to implement both java.io.Serializable and javax.resource.Referenceable interfaces to support JNDI registration.

Version:
0.9
Author:
Rahul Sharma

Method Summary
 void setReference(Reference reference)
Sets the Reference instance.
Methods inherited from interface javax.naming.Referenceable
getReference

Method Detail

setReference

public void setReference(Reference reference)
Sets the Reference instance. This method is called by the deployment code to set the Reference that can be later returned by the getReference method (as defined in the javax.naming.Referenceable interface).

Parameters:
reference - A Reference instance
See Also:
Referenceable.getReference()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ResourceException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource
Class ResourceException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ApplicationServerInternalException, CommException, EISSystemException, IllegalStateException, InvalidPropertyException, LocalTransactionException, NotSupportedException, ResourceAdapterInternalException, ResourceAllocationException, ResourceWarning, SecurityException, SharingViolationException, UnavailableException, WorkException
public class ResourceException
extends Exception

This is the root interface of the exception hierarchy defined for the Connector architecture. The ResourceException provides the following information:

  • A resource adapter vendor specific string describing the error. This string is a standard Java exception message and is available through getMessage() method.
  • resource adapter vendor specific error code.
  • reference to another exception. Often a resource exception will be result of a lower level problem. If appropriate, this lower level exception can be linked to the ResourceException. Note, this has been deprecated in favor of J2SE release 1.4 exception chaining facility.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
ResourceException()
Constructs a new instance with null as its detail message.
ResourceException(String message)
Constructs a new instance with the specified detail message.
ResourceException(String message, String errorCode)
Create a new throwable with the specified message and error code.
ResourceException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
ResourceException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
String | getErrorCode() Get the error code.
Exception | getLinkedException() Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..
String | getMessage() Returns a detailed message string describing this exception.
void | setErrorCode(String errorCode) Set the error code.
void | setLinkedException(Exception ex) Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResourceException

public ResourceException()
Constructs a new instance with null as its detail message.

ResourceException

public ResourceException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

ResourceException

public ResourceException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

ResourceException

public ResourceException(String message,
                         Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

ResourceException

public ResourceException(String message,
                         String errorCode)
Create a new throwable with the specified message and error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Method Detail

setErrorCode

public void setErrorCode(String errorCode)
Set the error code.

Parameters:
errorCode - the error code.

getErrorCode

public String getErrorCode()
Get the error code.

Returns:
the error code.

getLinkedException

public Exception getLinkedException()
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..

Get the exception linked to this ResourceException

Returns:
linked Exception, null if none

setLinkedException

public void setLinkedException(Exception ex)
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

Add a linked Exception to this ResourceException.

Parameters:
ex - linked Exception

getMessage

public String getMessage()
Returns a detailed message string describing this exception.

Returns:
a detailed message string.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


spi

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource.spi

The javax.resource.spi package contains APIs for the system contracts defined in the J2EE Connector Architecture specification.

See:
Description

Interface Summary
ActivationSpec | This interface serves as a marker.
BootstrapContext | This provides a mechanism to pass a bootstrap context to a resource adapter instance when it is bootstrapped.
ConnectionEventListener | The ConnectionEventListener interface provides an event callback mechanism to enable an application server to receive notifications from a ManagedConnection instance.
ConnectionManager | ConnectionManager interface provides a hook for the resource adapter to pass a connection request to the application server.
ConnectionRequestInfo | The ConnectionRequestInfo interface enables a resource adapter to pass its own request specific data structure across the connection request flow.
DissociatableManagedConnection | This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation.
LazyAssociatableConnectionManager | This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation.
LazyEnlistableConnectionManager | This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation.
LazyEnlistableManagedConnection | This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation.
LocalTransaction | LocalTransaction interface provides support for transactions that are managed internal to an EIS resource manager, and do not require an external transaction manager.
ManagedConnection | ManagedConnection instance represents a physical connection to the underlying EIS.
ManagedConnectionFactory | ManagedConnectionFactory instance is a factory of both ManagedConnection and EIS-specific connection factory instances.
ManagedConnectionMetaData | The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with a ManagedConnection instance.
ResourceAdapter | This represents a resource adapter instance and contains operations for lifecycle management and message endpoint setup.
ResourceAdapterAssociation | This interface specifies the methods to associate a ResourceAdapter object with other objects that implement this interface like ManagedConnectionFactory and ActivationSpec.
ValidatingManagedConnectionFactory | This interface is implemented by a ManagedConnectionFactory instance that supports the ability to validate ManagedConnection objects.
XATerminator | The XATerminator interface is used for transaction completion and crash recovery flows.

Class Summary
ConnectionEvent The ConnectionEvent class provides information about the source of a connection related event.A ConnectionEvent instance contains the following information: Type of the connection event ManagedConnection instance that generated the connection event.

Exception Summary
ApplicationServerInternalException | An ApplicationServerInternalException is thrown by an application server to indicate error conditions specific to an application server.
CommException | This indicates errors related to failed or interrupted communication with an EIS instance.
EISSystemException | An EISSystemException is used to indicate any EIS specific system-level error conditions.
IllegalStateException | An IllegalStateException is thrown from a method if the callee (resource adapter or application server for system contracts) is in an illegal or inappropriate state for the method invocation.
InvalidPropertyException | This exception is thrown to indicate invalid configuration property settings.
LocalTransactionException | A LocalTransactionException represents various error conditions related to the local transaction management contract.
ResourceAdapterInternalException | A ResourceAdapterInternalException indicates any system-level error conditions related to a resource adapter.
ResourceAllocationException | A ResourceAllocationException can be thrown by an application server or resource adapter to indicate any failure to allocate system resources (example: threads, physical connections).
SecurityException | A SecurityException indicates error conditions related to the security contract between an application server and resource adapter.
SharingViolationException | This is thrown to indicate a connection sharing violation.
UnavailableException | This is thrown to indicate that a service is unavailable.

Package javax.resource.spi Description

The javax.resource.spi package contains APIs for the system contracts defined in the J2EE Connector Architecture specification.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.resource.spi Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource.spi

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.resource.spi.ConnectionEvent
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.resource.ResourceException
          • class javax.resource.spi.ApplicationServerInternalException
          • class javax.resource.spi.CommException
          • class javax.resource.spi.EISSystemException
          • class javax.resource.spi.IllegalStateException
          • class javax.resource.spi.InvalidPropertyException
          • class javax.resource.spi.LocalTransactionException
          • class javax.resource.spi.ResourceAdapterInternalException
          • class javax.resource.spi.ResourceAllocationException
          • class javax.resource.spi.SecurityException
          • class javax.resource.spi.SharingViolationException
          • class javax.resource.spi.UnavailableException

Interface Hierarchy

  • interface javax.resource.spi.BootstrapContext
  • interface javax.resource.spi.ConnectionRequestInfo
  • interface javax.resource.spi.DissociatableManagedConnection
  • interface java.util.EventListener
    • interface javax.resource.spi.ConnectionEventListener
  • interface javax.resource.spi.LazyAssociatableConnectionManager
  • interface javax.resource.spi.LazyEnlistableConnectionManager
  • interface javax.resource.spi.LazyEnlistableManagedConnection
  • interface javax.resource.spi.LocalTransaction
  • interface javax.resource.spi.ManagedConnection
  • interface javax.resource.spi.ManagedConnectionMetaData
  • interface javax.resource.spi.ResourceAdapter
  • interface javax.resource.spi.ResourceAdapterAssociation
    • interface javax.resource.spi.ActivationSpec
  • interface java.io.Serializable
    • interface javax.resource.spi.ConnectionManager
    • interface javax.resource.spi.ManagedConnectionFactory
  • interface javax.resource.spi.ValidatingManagedConnectionFactory
  • interface javax.resource.spi.XATerminator
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


LazyEnlistableManagedConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface LazyEnlistableManagedConnection

public interface LazyEnlistableManagedConnection

This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation. An implementation of this interface must support the lazy transaction enlistment optimization.

Version:
1.0
Author:
Ram Jeyaraman

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ActivationSpec

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ActivationSpec

All Superinterfaces:
ResourceAdapterAssociation
public interface ActivationSpec
extends ResourceAdapterAssociation

This interface serves as a marker. An instance of an ActivationSpec must be a JavaBean and must be serializable. This holds the activation configuration information for a message endpoint.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 void validate()
This method may be called by a deployment tool to validate the overall activation configuration information provided by the endpoint deployer.
Methods inherited from interface javax.resource.spi.ResourceAdapterAssociation
getResourceAdapter, setResourceAdapter

Method Detail

validate

public void validate()
              throws InvalidPropertyException
This method may be called by a deployment tool to validate the overall activation configuration information provided by the endpoint deployer. This helps to catch activation configuration errors earlier on without having to wait until endpoint activation time for configuration validation. The implementation of this self-validation check behavior is optional.

Throws:
InvalidPropertyException - indicates invalid configuration property settings.
InvalidPropertyException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ApplicationServerInternalException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class ApplicationServerInternalException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.ApplicationServerInternalException
All Implemented Interfaces:
Serializable
public class ApplicationServerInternalException
extends ResourceException

An ApplicationServerInternalException is thrown by an application server to indicate error conditions specific to an application server. These error conditions can be related to either configuration related errors or implementation of mechanisms internal to an application server (example: connection pooling, thread management).

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
ApplicationServerInternalException()
Constructs a new instance with null as its detail message.
ApplicationServerInternalException(String message)
Constructs a new instance with the specified detail message.
ApplicationServerInternalException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
ApplicationServerInternalException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
ApplicationServerInternalException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ApplicationServerInternalException

public ApplicationServerInternalException()
Constructs a new instance with null as its detail message.

ApplicationServerInternalException

public ApplicationServerInternalException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

ApplicationServerInternalException

public ApplicationServerInternalException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

ApplicationServerInternalException

public ApplicationServerInternalException(String message,
                                          Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

ApplicationServerInternalException

public ApplicationServerInternalException(String message,
                                          String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BootstrapContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface BootstrapContext

public interface BootstrapContext

This provides a mechanism to pass a bootstrap context to a resource adapter instance when it is bootstrapped. That is, when (start(BootstrapContext)) method on the ResourceAdapter class is invoked. The bootstrap context contains references to useful facilities that could be used by the resource adapter instance.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
Timer | createTimer() Creates a new java.util.Timer instance.
WorkManager | getWorkManager() Provides a handle to a WorkManager instance.
XATerminator | getXATerminator() Provides a handle to a XATerminator instance.

Method Detail

getWorkManager

public WorkManager getWorkManager()
Provides a handle to a WorkManager instance. The WorkManager instance could be used by a resource adapter to do its work by submitting Work instances for execution.

Returns:
a WorkManager instance.

getXATerminator

public XATerminator getXATerminator()
Provides a handle to a XATerminator instance. The XATerminator instance could be used by a resource adapter to flow-in transaction completion and crash recovery calls from an EIS.

Returns:
a XATerminator instance.

createTimer

public Timer createTimer()
                  throws UnavailableException
Creates a new java.util.Timer instance. The Timer instance could be used to perform periodic Work executions or other tasks.

Returns:
a new Timer instance.
Throws:
UnavailableException - indicates that a Timer instance is not available. The request may be retried later.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CommException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class CommException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.CommException
All Implemented Interfaces:
Serializable
public class CommException
extends ResourceException

This indicates errors related to failed or interrupted communication with an EIS instance. Examples of common error conditions represented by this exception type are communication protocol error and invalidated connection due to server failure.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
CommException()
Constructs a new instance with null as its detail message.
CommException(String message)
Constructs a new instance with the specified detail message.
CommException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
CommException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
CommException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CommException

public CommException()
Constructs a new instance with null as its detail message.

CommException

public CommException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

CommException

public CommException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

CommException

public CommException(String message,
                     Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

CommException

public CommException(String message,
                     String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class ConnectionEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.resource.spi.ConnectionEvent
All Implemented Interfaces:
Serializable
public class ConnectionEvent
extends EventObject

The ConnectionEvent class provides information about the source of a connection related event.A ConnectionEvent instance contains the following information:

  • Type of the connection event
  • ManagedConnection instance that generated the connection event. A ManagedConnection instance is returned from the method ConnectionEvent.getSource.
  • Connection handle associated with the ManagedConnection instance; required for the CONNECTION_CLOSED event and optional for the other event types.
  • Optionally, an exception indicating the connection related error. Note that exception is used for CONNECTION_ERROR_OCCURRED.

This class defines following types of event notifications:

  • CONNECTION_CLOSED
  • LOCAL_TRANSACTION_STARTED
  • LOCAL_TRANSACTION_COMMITTED
  • LOCAL_TRANSACTION_ROLLEDBACK
  • CONNECTION_ERROR_OCCURRED

Version:
0.5
Author:
Rahul Sharma
See Also:
ConnectionEventListener, Serialized Form

Field Summary
static int | CONNECTION_CLOSED Event notification that an application component has closed the connection
static int | CONNECTION_ERROR_OCCURRED Event notification that an error occurred on the connection.
protected int | id Type of the event
static int | LOCAL_TRANSACTION_COMMITTED Event notification that a Resource Manager Local Transaction was committed on the connection
static int | LOCAL_TRANSACTION_ROLLEDBACK Event notification that a Resource Manager Local Transaction was rolled back on the connection
static int | LOCAL_TRANSACTION_STARTED Event notification that a Resource Manager Local Transaction was started on the connection
Fields inherited from class java.util.EventObject
source
Constructor Summary
ConnectionEvent(ManagedConnection source, int eid)
Construct a ConnectionEvent object.
ConnectionEvent(ManagedConnection source, int eid, Exception exception)
Construct a ConnectionEvent object.
Method Summary
Object | getConnectionHandle() Get the connection handle associated with the Managed Connection instance.
Exception | getException() Get the exception.
int | getId() Get the type of event
void | setConnectionHandle(Object connectionHandle) Set the connection handle.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

CONNECTION_CLOSED

public static final int CONNECTION_CLOSED
Event notification that an application component has closed the connection

See Also:
Constant Field Values

LOCAL_TRANSACTION_STARTED

public static final int LOCAL_TRANSACTION_STARTED
Event notification that a Resource Manager Local Transaction was started on the connection

See Also:
Constant Field Values

LOCAL_TRANSACTION_COMMITTED

public static final int LOCAL_TRANSACTION_COMMITTED
Event notification that a Resource Manager Local Transaction was committed on the connection

See Also:
Constant Field Values

LOCAL_TRANSACTION_ROLLEDBACK

public static final int LOCAL_TRANSACTION_ROLLEDBACK
Event notification that a Resource Manager Local Transaction was rolled back on the connection

See Also:
Constant Field Values

CONNECTION_ERROR_OCCURRED

public static final int CONNECTION_ERROR_OCCURRED
Event notification that an error occurred on the connection. This event indicates that the ManagedConnection instance is now invalid and unusable.

See Also:
Constant Field Values

id

protected int id
Type of the event

Constructor Detail

ConnectionEvent

public ConnectionEvent(ManagedConnection source,
                       int eid)
Construct a ConnectionEvent object. Exception defaults to null.

Parameters:
source - ManagedConnection that is the source of the event
eid - type of the Connection event

ConnectionEvent

public ConnectionEvent(ManagedConnection source,
                       int eid,
                       Exception exception)
Construct a ConnectionEvent object.

Parameters:
source - ManagedConnection that is the source of the event
exception - exception about to be thrown to the application
eid - type of the Connection event
Method Detail

getConnectionHandle

public Object getConnectionHandle()
Get the connection handle associated with the Managed Connection instance. Used for CONNECTION_CLOSED event.

Returns:
the connection handle. May be null

setConnectionHandle

public void setConnectionHandle(Object connectionHandle)
Set the connection handle. Used for CONNECTION_CLOSED event

getException

public Exception getException()
Get the exception. May be null.

Returns:
the exception about to be thrown.

getId

public int getId()
Get the type of event

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionEventListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ConnectionEventListener

All Superinterfaces:
EventListener
public interface ConnectionEventListener
extends EventListener

The ConnectionEventListener interface provides an event callback mechanism to enable an application server to receive notifications from a ManagedConnection instance.

An application server uses these event notifications to manage its connection pool, to clean up any invalid or terminated connections and to manage local transactions.

An application server implements the ConnectionEventListener interface. It registers a connection listener with a ManagedConnection instance by using ManagedConnection.addConnectionEventListener method.

Version:
0.5
Author:
Rahul Sharma
See Also:
ConnectionEvent

Method Summary
void | connectionClosed(ConnectionEvent event) Notifies that an application component has closed the connection.
void | connectionErrorOccurred(ConnectionEvent event) Notifies a connection related error.
void | localTransactionCommitted(ConnectionEvent event) Notifies that a Resource Manager Local Transaction was committed on the ManagedConnection instance.
void | localTransactionRolledback(ConnectionEvent event) Notifies that a Resource Manager Local Transaction was rolled back on the ManagedConnection instance.
void | localTransactionStarted(ConnectionEvent event) Notifies that a Resource Manager Local Transaction was started on the ManagedConnection instance.

Method Detail

connectionClosed

public void connectionClosed(ConnectionEvent event)
Notifies that an application component has closed the connection.

A ManagedConnection instance notifies its registered set of listeners by calling ConnectionEventListener.connectionClosed method when an application component closes a connection handle. The application server uses this connection close event to put the ManagedConnection instance back in to the connection pool.

Parameters:
event - event object describing the source of the event

localTransactionStarted

public void localTransactionStarted(ConnectionEvent event)
Notifies that a Resource Manager Local Transaction was started on the ManagedConnection instance.

Parameters:
event - event object describing the source of the event

localTransactionCommitted

public void localTransactionCommitted(ConnectionEvent event)
Notifies that a Resource Manager Local Transaction was committed on the ManagedConnection instance.

Parameters:
event - event object describing the source of the event

localTransactionRolledback

public void localTransactionRolledback(ConnectionEvent event)
Notifies that a Resource Manager Local Transaction was rolled back on the ManagedConnection instance.

Parameters:
event - event object describing the source of the event

connectionErrorOccurred

public void connectionErrorOccurred(ConnectionEvent event)
Notifies a connection related error. The ManagedConnection instance calls the method ConnectionEventListener.connectionErrorOccurred to notify its registered listeners of the occurrence of a physical connection-related error. The event notification happens just before a resource adapter throws an exception to the application component using the connection handle. The connectionErrorOccurred method indicates that the associated ManagedConnection instance is now invalid and unusable. The application server handles the connection error event notification by initiating application server-specific cleanup (for example, removing ManagedConnection instance from the connection pool) and then calling ManagedConnection.destroy method to destroy the physical connection.

Parameters:
event - event object describing the source of the event
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ConnectionManager

All Superinterfaces:
Serializable
public interface ConnectionManager
extends Serializable

ConnectionManager interface provides a hook for the resource adapter to pass a connection request to the application server.

An application server provides implementation of the ConnectionManager interface. This implementation is not specific to any particular type of the resource adapter or connection factory interface.

The ConnectionManager implementation delegates to the application server to enable latter to provide quality of services (QoS) - security, connection pool management, transaction management and error logging/tracing.

An application server implements these services in a generic manner, independent of any resource adapter and EIS specific mechanisms. The connector architecture does not specify how an application server implements these services; the implementation is specific to an application server.

After an application server hooks-in its services, the connection request gets delegated to a ManagedConnectionFactory instance either for the creation of a new physical connection or for the matching of an already existing physical connection.

An implementation class for ConnectionManager interface is required to implement the java.io.Serializable interface.

In the non-managed application scenario, the ConnectionManager implementation class can be provided either by a resource adapter (as a default ConnectionManager implementation) or by application developers. In both cases, QOS can be provided as components by third party vendors.

Since:
0.6
Author:
Rahul Sharma
See Also:
ManagedConnectionFactory

Method Summary
 Object allocateConnection(ManagedConnectionFactory mcf, ConnectionRequestInfo cxRequestInfo)
The method allocateConnection gets called by the resource adapter's connection factory instance.

Method Detail

allocateConnection

public Object allocateConnection(ManagedConnectionFactory mcf,
                                 ConnectionRequestInfo cxRequestInfo)
                          throws ResourceException

The method allocateConnection gets called by the resource adapter's connection factory instance. This lets connection factory instance (provided by the resource adapter) pass a connection request to the ConnectionManager instance.

The connectionRequestInfo parameter represents information specific to the resource adapter for handling of the connection request.

Parameters:
mcf - used by application server to delegate connection matching/creation
cxRequestInfo - connection request Information
Returns:
connection handle with an EIS specific connection interface.
Throws:
ResourceException - Generic exception
ApplicationServerInternalException - Application server specific exception
SecurityException - Security related error
ResourceAllocationException - Failed to allocate system resources for connection request
ResourceAdapterInternalException - Resource adapter related error condition
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionRequestInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ConnectionRequestInfo

public interface ConnectionRequestInfo

The ConnectionRequestInfo interface enables a resource adapter to pass its own request specific data structure across the connection request flow. A resource adapter extends the empty interface to supports its own data structures for connection request.

A typical use allows a resource adapter to handle application component specified per-connection request properties (example - client ID, language). The application server passes these properties back across to match/createManagedConnection calls on the resource adapter. These properties remain opaque to the application server during the connection request flow.

Once the ConnectionRequestInfo reaches match/createManagedConnection methods on the ManagedConnectionFactory instance, resource adapter uses this additional per-request information to do connection creation and matching.

Version:
0.8
Author:
Rahul Sharma
See Also:
ManagedConnectionFactory, ManagedConnection

Method Summary
boolean | equals(Object other) Checks whether this instance is equal to another.
int | hashCode() Returns the hashCode of the ConnectionRequestInfo.

Method Detail

equals

public boolean equals(Object other)
Checks whether this instance is equal to another. Since connectionRequestInfo is defined specific to a resource adapter, the resource adapter is required to implement this method. The conditions for equality are specific to the resource adapter.

Returns:
True if the two instances are equal.

hashCode

public int hashCode()
Returns the hashCode of the ConnectionRequestInfo.

Returns:
hash code os this instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DissociatableManagedConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface DissociatableManagedConnection

public interface DissociatableManagedConnection

This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation. An implementation of this interface must support the lazy connection association optimization.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 void dissociateConnections()
This method is called by an application server (that is capable of lazy connection association optimization) in order to dissociate a ManagedConnection instance from all of its connection handles.

Method Detail

dissociateConnections

public void dissociateConnections()
                           throws ResourceException
This method is called by an application server (that is capable of lazy connection association optimization) in order to dissociate a ManagedConnection instance from all of its connection handles.

Throws:
ResourceException - generic exception if operation fails.
ResourceAdapterInternalException - resource adapter internal error condition
IllegalStateException - Illegal state for calling connection cleanup. Example - if a localtransaction is in progress that doesn't allow connection cleanup.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EISSystemException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class EISSystemException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.EISSystemException
All Implemented Interfaces:
Serializable
public class EISSystemException
extends ResourceException

An EISSystemException is used to indicate any EIS specific system-level error conditions. The common error conditions are: failure or inactivity of an EIS instance, communication failure and EIS specific error in the creation of a new physical connection.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
EISSystemException()
Constructs a new instance with null as its detail message.
EISSystemException(String message)
Constructs a new instance with the specified detail message.
EISSystemException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
EISSystemException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
EISSystemException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EISSystemException

public EISSystemException()
Constructs a new instance with null as its detail message.

EISSystemException

public EISSystemException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

EISSystemException

public EISSystemException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

EISSystemException

public EISSystemException(String message,
                          Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

EISSystemException

public EISSystemException(String message,
                          String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


endpoint

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource.spi.endpoint

This package contains system contracts for service endpoint interactions.

See:
Description

Interface Summary
MessageEndpoint | This defines a contract for a message endpoint.
MessageEndpointFactory | This serves as a factory for creating message endpoints.

Package javax.resource.spi.endpoint Description

This package contains system contracts for service endpoint interactions.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.resource.spi.endpoint Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource.spi.endpoint

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface javax.resource.spi.endpoint.MessageEndpoint
  • interface javax.resource.spi.endpoint.MessageEndpointFactory
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageEndpoint

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.endpoint
Interface MessageEndpoint

public interface MessageEndpoint

This defines a contract for a message endpoint. This is implemented by an application server.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
void | afterDelivery() This is called by a resource adapter after a message is delivered.
void | beforeDelivery(Method method) This is called by a resource adapter before a message is delivered.
void | release() This method may be called by the resource adapter to indicate that it no longer needs a proxy endpoint instance.

Method Detail

beforeDelivery

public void beforeDelivery(Method method)
                    throws NoSuchMethodException,
                           ResourceException
This is called by a resource adapter before a message is delivered.

Parameters:
method - description of a target method. This information about the intended target method allows an application server to decide whether to start a transaction during this method call, depending on the transaction preferences of the target method. The processing (by the application server) of the actual message delivery method call on the endpoint must be independent of the class loader associated with this descriptive method object.
Throws:
NoSuchMethodException - indicates that the specified method does not exist on the target endpoint.
ResourceException - generic exception.
ApplicationServerInternalException - indicates an error condition in the application server.
IllegalStateException - indicates that the endpoint is in an illegal state for the method invocation. For example, this occurs when beforeDelivery and afterDelivery method calls are not paired.
UnavailableException - indicates that the endpoint is not available.

afterDelivery

public void afterDelivery()
                   throws ResourceException
This is called by a resource adapter after a message is delivered.

Throws:
ResourceException - generic exception.
ApplicationServerInternalException - indicates an error condition in the application server.
IllegalStateException - indicates that the endpoint is in an illegal state for the method invocation. For example, this occurs when beforeDelivery and afterDelivery method calls are not paired.
UnavailableException - indicates that the endpoint is not available.

release

public void release()
This method may be called by the resource adapter to indicate that it no longer needs a proxy endpoint instance. This hint may be used by the application server for endpoint pooling decisions.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageEndpointFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.endpoint
Interface MessageEndpointFactory

public interface MessageEndpointFactory

This serves as a factory for creating message endpoints.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
MessageEndpoint | createEndpoint(XAResource xaResource) This is used to create a message endpoint.
boolean | isDeliveryTransacted(Method method) This is used to find out whether message deliveries to a target method on a message listener interface that is implemented by a message endpoint will be transacted or not.

Method Detail

createEndpoint

public MessageEndpoint createEndpoint(XAResource xaResource)
                               throws UnavailableException
This is used to create a message endpoint. The message endpoint is expected to implement the correct message listener type.

Parameters:
xaResource - an optional XAResource instance used to get transaction notifications when the message delivery is transacted.
Returns:
a message endpoint instance.
Throws:
UnavailableException - indicates a transient failure in creating a message endpoint. Subsequent attempts to create a message endpoint might succeed.

isDeliveryTransacted

public boolean isDeliveryTransacted(Method method)
                             throws NoSuchMethodException
This is used to find out whether message deliveries to a target method on a message listener interface that is implemented by a message endpoint will be transacted or not. The message endpoint may indicate its transacted delivery preferences (at a per method level) through its deployment descriptor. The message delivery preferences must not change during the lifetime of a message endpoint.

Parameters:
method - description of a target method. This information about the intended target method allows an application server to find out whether the target method call will be transacted or not.
Returns:
true, if message endpoint requires transacted message delivery.
Throws:
NoSuchMethodException - indicates that the specified method does not exist on the target endpoint.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


IllegalStateException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class IllegalStateException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.IllegalStateException
All Implemented Interfaces:
Serializable
public class IllegalStateException
extends ResourceException

An IllegalStateException is thrown from a method if the callee (resource adapter or application server for system contracts) is in an illegal or inappropriate state for the method invocation.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
IllegalStateException()
Constructs a new instance with null as its detail message.
IllegalStateException(String message)
Constructs a new instance with the specified detail message.
IllegalStateException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
IllegalStateException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
IllegalStateException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IllegalStateException

public IllegalStateException()
Constructs a new instance with null as its detail message.

IllegalStateException

public IllegalStateException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

IllegalStateException

public IllegalStateException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

IllegalStateException

public IllegalStateException(String message,
                             Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

IllegalStateException

public IllegalStateException(String message,
                             String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidPropertyException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class InvalidPropertyException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.InvalidPropertyException
All Implemented Interfaces:
Serializable
public class InvalidPropertyException
extends ResourceException

This exception is thrown to indicate invalid configuration property settings.

Version:
0.2
Author:
Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
InvalidPropertyException()
Create a InvalidPropertyException.
InvalidPropertyException(String message)
Create a InvalidPropertyException.
InvalidPropertyException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
InvalidPropertyException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
InvalidPropertyException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
PropertyDescriptor[] | getInvalidPropertyDescriptors() Get the list of invalid properties.
void | setInvalidPropertyDescriptors(PropertyDescriptor[] invalidProperties) Set a list of invalid properties.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidPropertyException

public InvalidPropertyException()
Create a InvalidPropertyException.

InvalidPropertyException

public InvalidPropertyException(String message)
Create a InvalidPropertyException.

Parameters:
message - a description of the exception

InvalidPropertyException

public InvalidPropertyException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

InvalidPropertyException

public InvalidPropertyException(String message,
                                Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

InvalidPropertyException

public InvalidPropertyException(String message,
                                String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Method Detail

setInvalidPropertyDescriptors

public void setInvalidPropertyDescriptors(PropertyDescriptor[] invalidProperties)
Set a list of invalid properties.

getInvalidPropertyDescriptors

public PropertyDescriptor[] getInvalidPropertyDescriptors()
Get the list of invalid properties.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


LazyAssociatableConnectionManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface LazyAssociatableConnectionManager

public interface LazyAssociatableConnectionManager

This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation. An implementation of this interface must support the lazy connection association optimization.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 void associateConnection(Object connection, ManagedConnectionFactory mcf, ConnectionRequestInfo cxReqInfo)
This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.

Method Detail

associateConnection

public void associateConnection(Object connection,
                                ManagedConnectionFactory mcf,
                                ConnectionRequestInfo cxReqInfo)
                         throws ResourceException
This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.

Parameters:
connection - the connection object that is to be associated.
mcf - The ManagedConnectionFactory instance that was originally used to create the connection object.
cxReqInfo - connection request information. This information must be the same as that used to originally create the connection object.
Throws:
ResourceException - Generic exception.
ApplicationServerInternalException - Application server specific exception.
SecurityException - Security related error.
ResourceAllocationException - Failed to allocate system resources for connection request.
ResourceAdapterInternalException - Resource adapter related error condition.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


LazyEnlistableConnectionManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface LazyEnlistableConnectionManager

public interface LazyEnlistableConnectionManager

This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation. An implementation of this interface must support the lazy transaction enlistment optimization.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 void lazyEnlist(ManagedConnection mc)
This method is called by a resource adapter (that is capable of lazy transaction enlistment optimization) in order to lazily enlist a connection object with a XA transaction.

Method Detail

lazyEnlist

public void lazyEnlist(ManagedConnection mc)
                throws ResourceException
This method is called by a resource adapter (that is capable of lazy transaction enlistment optimization) in order to lazily enlist a connection object with a XA transaction.

Parameters:
mc - The ManagedConnection instance that needs to be lazily associated.
Throws:
ResourceException - Generic exception.
ApplicationServerInternalException - Application server specific exception.
ResourceAllocationException - Failed to allocate system resources for connection request.
ResourceAdapterInternalException - Resource adapter related error condition.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


LocalTransaction

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface LocalTransaction

public interface LocalTransaction

LocalTransaction interface provides support for transactions that are managed internal to an EIS resource manager, and do not require an external transaction manager.

A resource adapter implements the javax.resource.spi.LocalTransaction interface to provide support for local transactions that are performed on the underlying resource manager.

If a resource adapter supports the LocalTransaction interface, then the application server can choose to perform local transaction optimization (uses local transaction instead of a JTA transaction for a single resource manager case).

Version:
0.5
Author:
Rahul Sharma
See Also:
ManagedConnection

Method Summary
void | begin() Begin a local transaction
void | commit() Commit a local transaction
void | rollback() Rollback a local transaction

Method Detail

begin

public void begin()
           throws ResourceException
Begin a local transaction

Throws:
ResourceException - generic exception if operation fails
LocalTransactionException - error condition related to local transaction management
ResourceAdapterInternalException - error condition internal to resource adapter
EISSystemException - EIS instance specific error condition

commit

public void commit()
            throws ResourceException
Commit a local transaction

Throws:
ResourceException - generic exception if operation fails
LocalTransactionException - error condition related to local transaction management
ResourceAdapterInternalException - error condition internal to resource adapter
EISSystemException - EIS instance specific error condition

rollback

public void rollback()
              throws ResourceException
Rollback a local transaction

Throws:
ResourceException - generic exception if operation fails
LocalTransactionException - error condition related to local transaction management
ResourceAdapterInternalException - error condition internal to resource adapter
EISSystemException - EIS instance specific error condition
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


LocalTransactionException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class LocalTransactionException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.LocalTransactionException
All Implemented Interfaces:
Serializable
public class LocalTransactionException
extends ResourceException

A LocalTransactionException represents various error conditions related to the local transaction management contract. The Java Transaction API specification specifies the javax.transaction.xa.XAException class for exceptions related to XAResource based transaction management contract.

The LocalTransactionException is used for the local transaction management contract to indicate the following common error conditions:

  • Invalid transaction context when a transaction operation is executed. For example, calling commit method on LocalTransaction object without an active local transaction is an error condition.
  • Transaction is rolled back instead of getting committed during a commit method call on the LocalTransaction object.
  • An attempt to start a local transaction from the same thread on a ManagedConnection that is already associated with an active local transaction.
  • Any resource adapter or resource manager specific error conditions related to local transaction management. Examples are violation of integrity of resources, deadlock detection, communication failure during transaction completion, retry required or any internal error in a resource manager.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
LocalTransactionException()
Constructs a new instance with null as its detail message.
LocalTransactionException(String message)
Constructs a new instance with the specified detail message.
LocalTransactionException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
LocalTransactionException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
LocalTransactionException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LocalTransactionException

public LocalTransactionException()
Constructs a new instance with null as its detail message.

LocalTransactionException

public LocalTransactionException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

LocalTransactionException

public LocalTransactionException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

LocalTransactionException

public LocalTransactionException(String message,
                                 Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

LocalTransactionException

public LocalTransactionException(String message,
                                 String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ManagedConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ManagedConnection

public interface ManagedConnection

ManagedConnection instance represents a physical connection to the underlying EIS.

A ManagedConnection instance provides access to a pair of interfaces: javax.transaction.xa.XAResource and javax.resource.spi.LocalTransaction.

XAResource interface is used by the transaction manager to associate and dissociate a transaction with the underlying EIS resource manager instance and to perform two-phase commit protocol. The ManagedConnection interface is not directly used by the transaction manager. More details on the XAResource interface are described in the JTA specification.

The LocalTransaction interface is used by the application server to manage local transactions.

Version:
0.5
Author:
Rahul Sharma
See Also:
ManagedConnectionFactory, XAResource, LocalTransaction

Method Summary
void | addConnectionEventListener(ConnectionEventListener listener) Adds a connection event listener to the ManagedConnection instance.
void | associateConnection(Object connection) Used by the container to change the association of an application-level connection handle with a ManagedConneciton instance.
void | cleanup() Application server calls this method to force any cleanup on the ManagedConnection instance.
void | destroy() Destroys the physical connection to the underlying resource manager.
Object | getConnection(Subject subject, ConnectionRequestInfo cxRequestInfo) Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance.
LocalTransaction | getLocalTransaction() Returns an javax.resource.spi.LocalTransaction instance.
PrintWriter | getLogWriter() Gets the log writer for this ManagedConnection instance.
ManagedConnectionMetaData | getMetaData() Gets the metadata information for this connection's underlying EIS resource manager instance.
XAResource | getXAResource() Returns an javax.transaction.xa.XAresource instance.
void | removeConnectionEventListener(ConnectionEventListener listener) Removes an already registered connection event listener from the ManagedConnection instance.
void | setLogWriter(PrintWriter out) Sets the log writer for this ManagedConnection instance.

Method Detail

getConnection

public Object getConnection(Subject subject,
                            ConnectionRequestInfo cxRequestInfo)
                     throws ResourceException
Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance. This connection handle is used by the application code to refer to the underlying physical connection. This connection handle is associated with its ManagedConnection instance in a resource adapter implementation specific way.

The ManagedConnection uses the Subject and additional ConnectionRequest Info (which is specific to resource adapter and opaque to application server) to set the state of the physical connection.

Parameters:
subject - security context as JAAS subject
cxRequestInfo - ConnectionRequestInfo instance
Returns:
generic Object instance representing the connection handle. For CCI, the connection handle created by a ManagedConnection instance is of the type javax.resource.cci.Connection.
Throws:
ResourceException - generic exception if operation fails
ResourceAdapterInternalException - resource adapter internal error condition
SecurityException - security related error condition
CommException - failed communication with EIS instance
EISSystemException - internal error condition in EIS instance - used if EIS instance is involved in setting state of ManagedConnection

destroy

public void destroy()
             throws ResourceException
Destroys the physical connection to the underlying resource manager.

To manage the size of the connection pool, an application server can explictly call ManagedConnection.destroy to destroy a physical connection. A resource adapter should destroy all allocated system resources for this ManagedConnection instance when the method destroy is called.

Throws:
ResourceException - generic exception if operation failed
IllegalStateException - illegal state for destroying connection

cleanup

public void cleanup()
             throws ResourceException
Application server calls this method to force any cleanup on the ManagedConnection instance.

The method ManagedConnection.cleanup initiates a cleanup of the any client-specific state as maintained by a ManagedConnection instance. The cleanup should invalidate all connection handles that had been created using this ManagedConnection instance. Any attempt by an application component to use the connection handle after cleanup of the underlying ManagedConnection should result in an exception.

The cleanup of ManagedConnection is always driven by an application server. An application server should not invoke ManagedConnection.cleanup when there is an uncompleted transaction (associated with a ManagedConnection instance) in progress.

The invocation of ManagedConnection.cleanup method on an already cleaned-up connection should not throw an exception.

The cleanup of ManagedConnection instance resets its client specific state and prepares the connection to be put back in to a connection pool. The cleanup method should not cause resource adapter to close the physical pipe and reclaim system resources associated with the physical connection.

Throws:
ResourceException - generic exception if operation fails
ResourceAdapterInternalException - resource adapter internal error condition
IllegalStateException - Illegal state for calling connection cleanup. Example - if a localtransaction is in progress that doesn't allow connection cleanup

associateConnection

public void associateConnection(Object connection)
                         throws ResourceException
Used by the container to change the association of an application-level connection handle with a ManagedConneciton instance. The container should find the right ManagedConnection instance and call the associateConnection method.

The resource adapter is required to implement the associateConnection method. The method implementation for a ManagedConnection should dissociate the connection handle (passed as a parameter) from its currently associated ManagedConnection and associate the new connection handle with itself.

Parameters:
connection - Application-level connection handle
Throws:
ResourceException - Failed to associate the connection handle with this ManagedConnection instance
IllegalStateException - Illegal state for invoking this method
ResourceAdapterInternalException - Resource adapter internal error condition

addConnectionEventListener

public void addConnectionEventListener(ConnectionEventListener listener)
Adds a connection event listener to the ManagedConnection instance.

The registered ConnectionEventListener instances are notified of connection close and error events, also of local transaction related events on the Managed Connection.

Parameters:
listener - a new ConnectionEventListener to be registered

removeConnectionEventListener

public void removeConnectionEventListener(ConnectionEventListener listener)
Removes an already registered connection event listener from the ManagedConnection instance.

Parameters:
listener - already registered connection event listener to be removed

getXAResource

public XAResource getXAResource()
                         throws ResourceException
Returns an javax.transaction.xa.XAresource instance. An application server enlists this XAResource instance with the Transaction Manager if the ManagedConnection instance is being used in a JTA transaction that is being coordinated by the Transaction Manager.

Returns:
XAResource instance
Throws:
ResourceException - generic exception if operation fails
NotSupportedException - if the operation is not supported
ResourceAdapterInternalException - resource adapter internal error condition

getLocalTransaction

public LocalTransaction getLocalTransaction()
                                     throws ResourceException
Returns an javax.resource.spi.LocalTransaction instance. The LocalTransaction interface is used by the container to manage local transactions for a RM instance.

Returns:
LocalTransaction instance
Throws:
ResourceException - generic exception if operation fails
NotSupportedException - if the operation is not supported
ResourceAdapterInternalException - resource adapter internal error condition

getMetaData

public ManagedConnectionMetaData getMetaData()
                                      throws ResourceException

Gets the metadata information for this connection's underlying EIS resource manager instance. The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with the ManagedConenction instance.

Returns:
ManagedConnectionMetaData instance
Throws:
ResourceException - generic exception if operation fails
NotSupportedException - if the operation is not supported

setLogWriter

public void setLogWriter(PrintWriter out)
                  throws ResourceException
Sets the log writer for this ManagedConnection instance.

The log writer is a character output stream to which all logging and tracing messages for this ManagedConnection instance will be printed. Application Server manages the association of output stream with the ManagedConnection instance based on the connection pooling requirements.

When a ManagedConnection object is initially created, the default log writer associated with this instance is obtained from the ManagedConnectionFactory. An application server can set a log writer specific to this ManagedConnection to log/trace this instance using setLogWriter method.

Parameters:
out - Character Output stream to be associated
Throws:
ResourceException - generic exception if operation fails
ResourceAdapterInternalException - resource adapter related error condition

getLogWriter

public PrintWriter getLogWriter()
                         throws ResourceException
Gets the log writer for this ManagedConnection instance.

The log writer is a character output stream to which all logging and tracing messages for this ManagedConnection instance will be printed. ConnectionManager manages the association of output stream with the ManagedConnection instance based on the connection pooling requirements.

The Log writer associated with a ManagedConnection instance can be one set as default from the ManagedConnectionFactory (that created this connection) or one set specifically for this instance by the application server.

Returns:
Character ourput stream associated with this Managed- Connection instance
Throws:
ResourceException - generic exception if operation fails
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ManagedConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ManagedConnectionFactory

All Superinterfaces:
Serializable
public interface ManagedConnectionFactory
extends Serializable

ManagedConnectionFactory instance is a factory of both ManagedConnection and EIS-specific connection factory instances. This interface supports connection pooling by providing methods for matching and creation of ManagedConnection instance. A ManagedConnectionFactory instance is required to be a JavaBean.

Version:
0.6
Author:
Rahul Sharma
See Also:
ManagedConnection

Method Summary
Object | createConnectionFactory() Creates a Connection Factory instance.
Object | createConnectionFactory(ConnectionManager cxManager) Creates a Connection Factory instance.
ManagedConnection | createManagedConnection(Subject subject, ConnectionRequestInfo cxRequestInfo) Creates a new physical connection to the underlying EIS resource manager.
boolean | equals(Object other) Check if this ManagedConnectionFactory is equal to another ManagedConnectionFactory.
PrintWriter | getLogWriter() Get the log writer for this ManagedConnectionFactory instance.
int | hashCode() Returns the hash code for the ManagedConnectionFactory
ManagedConnection | matchManagedConnections(Set connectionSet, Subject subject, ConnectionRequestInfo cxRequestInfo) Returns a matched connection from the candidate set of connections.
void | setLogWriter(PrintWriter out) Set the log writer for this ManagedConnectionFactory instance.

Method Detail

createConnectionFactory

public Object createConnectionFactory(ConnectionManager cxManager)
                               throws ResourceException
Creates a Connection Factory instance. The Connection Factory instance gets initialized with the passed ConnectionManager. In the managed scenario, ConnectionManager is provided by the application server.

Parameters:
cxManager - ConnectionManager to be associated with created EIS connection factory instance
Returns:
EIS-specific Connection Factory instance or javax.resource.cci.ConnectionFactory instance
Throws:
ResourceException - Generic exception
ResourceAdapterInternalException - Resource adapter related error condition

createConnectionFactory

public Object createConnectionFactory()
                               throws ResourceException
Creates a Connection Factory instance. The Connection Factory instance gets initialized with a default ConnectionManager provided by the resource adapter.

Returns:
EIS-specific Connection Factory instance or javax.resource.cci.ConnectionFactory instance
Throws:
ResourceException - Generic exception
ResourceAdapterInternalException - Resource adapter related error condition

createManagedConnection

public ManagedConnection createManagedConnection(Subject subject,
                                                 ConnectionRequestInfo cxRequestInfo)
                                          throws ResourceException
Creates a new physical connection to the underlying EIS resource manager.

ManagedConnectionFactory uses the security information (passed as Subject) and additional ConnectionRequestInfo (which is specific to ResourceAdapter and opaque to application server) to create this new connection.

Parameters:
subject - Caller's security information
cxRequestInfo - Additional resource adapter specific connection request information
Returns:
ManagedConnection instance
Throws:
ResourceException - generic exception
SecurityException - security related error
ResourceAllocationException - failed to allocate system resources for connection request
ResourceAdapterInternalException - resource adapter related error condition
EISSystemException - internal error condition in EIS instance

matchManagedConnections

public ManagedConnection matchManagedConnections(Set connectionSet,
                                                 Subject subject,
                                                 ConnectionRequestInfo cxRequestInfo)
                                          throws ResourceException
Returns a matched connection from the candidate set of connections.

ManagedConnectionFactory uses the security info (as in Subject) and information provided through ConnectionRequestInfo and additional Resource Adapter specific criteria to do matching. Note that criteria used for matching is specific to a resource adapter and is not prescribed by the Connector specification.

This method returns a ManagedConnection instance that is the best match for handling the connection allocation request.

Parameters:
connectionSet - candidate connection set
subject - caller's security information
cxRequestInfo - additional resource adapter specific connection request information
Returns:
ManagedConnection if resource adapter finds an acceptable match otherwise null
Throws:
ResourceException - generic exception
SecurityException - security related error
ResourceAdapterInternalException - resource adapter related error condition
NotSupportedException - if operation is not supported

setLogWriter

public void setLogWriter(PrintWriter out)
                  throws ResourceException
Set the log writer for this ManagedConnectionFactory instance.

The log writer is a character output stream to which all logging and tracing messages for this ManagedConnectionfactory instance will be printed.

ApplicationServer manages the association of output stream with the ManagedConnectionFactory. When a ManagedConnectionFactory object is created the log writer is initially null, in other words, logging is disabled. Once a log writer is associated with a ManagedConnectionFactory, logging and tracing for ManagedConnectionFactory instance is enabled.

The ManagedConnection instances created by ManagedConnectionFactory "inherits" the log writer, which can be overridden by ApplicationServer using ManagedConnection.setLogWriter to set ManagedConnection specific logging and tracing.

Parameters:
out - PrintWriter - an out stream for error logging and tracing
Throws:
ResourceException - generic exception
ResourceAdapterInternalException - resource adapter related error condition

getLogWriter

public PrintWriter getLogWriter()
                         throws ResourceException
Get the log writer for this ManagedConnectionFactory instance.

The log writer is a character output stream to which all logging and tracing messages for this ManagedConnectionFactory instance will be printed

ApplicationServer manages the association of output stream with the ManagedConnectionFactory. When a ManagedConnectionFactory object is created the log writer is initially null, in other words, logging is disabled.

Returns:
PrintWriter
Throws:
ResourceException - generic exception

hashCode

public int hashCode()
Returns the hash code for the ManagedConnectionFactory

Returns:
hash code for the ManagedConnectionFactory

equals

public boolean equals(Object other)
Check if this ManagedConnectionFactory is equal to another ManagedConnectionFactory.

Returns:
true if two instances are equal
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ManagedConnectionMetaData

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ManagedConnectionMetaData

public interface ManagedConnectionMetaData

The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with a ManagedConnection instance. An application server uses this information to get runtime information about a connected EIS instance.

The method ManagedConnection.getMetaData returns a ManagedConnectionMetaData instance.

Version:
0.8
Author:
Rahul Sharma
See Also:
ManagedConnection

Method Summary
String | getEISProductName() Returns Product name of the underlying EIS instance connected through the ManagedConnection.
String | getEISProductVersion() Returns product version of the underlying EIS instance connected through the ManagedConnection.
int | getMaxConnections() Returns maximum limit on number of active concurrent connections that an EIS instance can support across client processes.
String | getUserName() Returns name of the user associated with the ManagedConnection instance.

Method Detail

getEISProductName

public String getEISProductName()
                         throws ResourceException
Returns Product name of the underlying EIS instance connected through the ManagedConnection.

Returns:
Product name of the EIS instance.
Throws:
ResourceException

getEISProductVersion

public String getEISProductVersion()
                            throws ResourceException
Returns product version of the underlying EIS instance connected through the ManagedConnection.

Returns:
Product version of the EIS instance
Throws:
ResourceException

getMaxConnections

public int getMaxConnections()
                      throws ResourceException
Returns maximum limit on number of active concurrent connections that an EIS instance can support across client processes. If an EIS instance does not know about (or does not have) any such limit, it returns a 0.

Returns:
Maximum limit for number of active concurrent connections
Throws:
ResourceException

getUserName

public String getUserName()
                   throws ResourceException
Returns name of the user associated with the ManagedConnection instance. The name corresponds to the resource principal under whose whose security context, a connection to the EIS instance has been established.

Returns:
name of the user
Throws:
ResourceException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ResourceAdapter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ResourceAdapter

public interface ResourceAdapter

This represents a resource adapter instance and contains operations for lifecycle management and message endpoint setup. A concrete implementation of this interface is required to be a JavaBean.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
void | endpointActivation(MessageEndpointFactory endpointFactory, ActivationSpec spec) This is called during the activation of a message endpoint.
void | endpointDeactivation(MessageEndpointFactory endpointFactory, ActivationSpec spec) This is called when a message endpoint is deactivated.
XAResource[] | getXAResources(ActivationSpec[] specs) This method is called by the application server during crash recovery.
void | start(BootstrapContext ctx) This is called when a resource adapter instance is bootstrapped.
void | stop() This is called when a resource adapter instance is undeployed or during application server shutdown.

Method Detail

start

public void start(BootstrapContext ctx)
           throws ResourceAdapterInternalException
This is called when a resource adapter instance is bootstrapped. This may be during resource adapter deployment or application server startup. This is a startup notification from the application server, and this method is called by an application server thread. The application server thread executes in an unspecified context.

During this method call a ResourceAdapter JavaBean is responsible for initializing the resource adapter instance. Any exception thrown during this method call causes the application server to abort the bootstrap procedure for this specific resource adapter instance.

Parameters:
ctx - a bootstrap context containing references to useful facilities that could be used by a resource adapter instance.
Throws:
ResourceAdapterInternalException - indicates bootstrap failure. The resource adapter instance is unusable and must be discarded.

stop

public void stop()
This is called when a resource adapter instance is undeployed or during application server shutdown. This is a shutdown notification from the application server, and this method is called by an application server thread. The application server thread executes in an unspecified context.

During this method call, a ResourceAdapter JavaBean is responsible for performing an orderly shutdown of the resource adapter instance. Any exception thrown by this method call does not alter the processing of the application server shutdown or resource adapter undeployment that caused this method call. The application server may log the exception information for error reporting purposes.

endpointActivation

public void endpointActivation(MessageEndpointFactory endpointFactory,
                               ActivationSpec spec)
                        throws ResourceException
This is called during the activation of a message endpoint. This causes the resource adapter instance to do the necessary setup (ie., setup message delivery for the message endpoint with a message provider). Note that message delivery to the message endpoint might start even before this method returns.

Endpoint activation is deemed successful only when this method completes successfully without throwing any exceptions.

Parameters:
endpointFactory - a message endpoint factory instance.
spec - an activation spec JavaBean instance.
Throws:
NotSupportedException - indicates message endpoint activation rejection due to incorrect activation setup information.
ResourceException

endpointDeactivation

public void endpointDeactivation(MessageEndpointFactory endpointFactory,
                                 ActivationSpec spec)
This is called when a message endpoint is deactivated. The instances passed as arguments to this method call should be identical to those passed in for the corresponding endpointActivation call. This causes the resource adapter to stop delivering messages to the message endpoint.

Any exception thrown by this method is ignored. After this method call, the endpoint is deemed inactive.

Parameters:
endpointFactory - a message endpoint factory instance.
spec - an activation spec JavaBean instance.

getXAResources

public XAResource[] getXAResources(ActivationSpec[] specs)
                            throws ResourceException
This method is called by the application server during crash recovery. This method takes in an array of ActivationSpec JavaBeans and returns an array of XAResource objects each of which represents a unique resource manager. The resource adapter may return null if it does not implement the XAResource interface. Otherwise, it must return an array of XAResource objects, each of which represents a unique resource manager that was used by the endpoint applications. The application server uses the XAResource objects to query each resource manager for a list of in-doubt transactions. It then completes each pending transaction by sending the commit decision to the participating resource managers.

Parameters:
specs - an array of ActivationSpec JavaBeans each of which corresponds to an deployed endpoint application that was active prior to the system crash.
Returns:
an array of XAResource objects each of which represents a unique resource manager.
Throws:
ResourceException - generic exception if operation fails due to an error condition.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ResourceAdapterAssociation

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ResourceAdapterAssociation

All Known Subinterfaces:
ActivationSpec
public interface ResourceAdapterAssociation

This interface specifies the methods to associate a ResourceAdapter object with other objects that implement this interface like ManagedConnectionFactory and ActivationSpec.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
ResourceAdapter | getResourceAdapter() Get the associated ResourceAdapter object.
void | setResourceAdapter(ResourceAdapter ra) Associate this object with a ResourceAdapter object.

Method Detail

getResourceAdapter

public ResourceAdapter getResourceAdapter()
Get the associated ResourceAdapter object.

Returns:
the associated ResourceAdapter object.

setResourceAdapter

public void setResourceAdapter(ResourceAdapter ra)
                        throws ResourceException
Associate this object with a ResourceAdapter object. Note, this method must be called exactly once. That is, the association must not change during the lifetime of this object.

Parameters:
ra - ResourceAdapter object to be associated with.
Throws:
ResourceException - generic exception.
ResourceAdapterInternalException - resource adapter related error condition.
IllegalStateException - indicates that this object is in an illegal state for the method invocation. For example, this occurs when this method is called more than once on the same object.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ResourceAdapterInternalException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class ResourceAdapterInternalException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.ResourceAdapterInternalException
All Implemented Interfaces:
Serializable
public class ResourceAdapterInternalException
extends ResourceException

A ResourceAdapterInternalException indicates any system-level error conditions related to a resource adapter. The common conditions indicated by this exception type are:

  • Invalid configuration for creation of a new physical connection. An example is invalid server name for a target EIS instance.
  • Failure to create a physical connection to a EIS instance due to communication protocol error or any resource adapter implementation specific error.
  • Error conditions internal to resource adapter implementation.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
ResourceAdapterInternalException()
Constructs a new instance with null as its detail message.
ResourceAdapterInternalException(String message)
Constructs a new instance with the specified detail message.
ResourceAdapterInternalException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
ResourceAdapterInternalException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
ResourceAdapterInternalException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResourceAdapterInternalException

public ResourceAdapterInternalException()
Constructs a new instance with null as its detail message.

ResourceAdapterInternalException

public ResourceAdapterInternalException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

ResourceAdapterInternalException

public ResourceAdapterInternalException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

ResourceAdapterInternalException

public ResourceAdapterInternalException(String message,
                                        Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

ResourceAdapterInternalException

public ResourceAdapterInternalException(String message,
                                        String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ResourceAllocationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class ResourceAllocationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.ResourceAllocationException
All Implemented Interfaces:
Serializable
public class ResourceAllocationException
extends ResourceException

A ResourceAllocationException can be thrown by an application server or resource adapter to indicate any failure to allocate system resources (example: threads, physical connections). An example is error condition when an upper bound is reached on the maximum number of physical connections that can be managed by an application server specific connection pool.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
ResourceAllocationException()
Constructs a new instance with null as its detail message.
ResourceAllocationException(String message)
Constructs a new instance with the specified detail message.
ResourceAllocationException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
ResourceAllocationException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
ResourceAllocationException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResourceAllocationException

public ResourceAllocationException()
Constructs a new instance with null as its detail message.

ResourceAllocationException

public ResourceAllocationException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

ResourceAllocationException

public ResourceAllocationException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

ResourceAllocationException

public ResourceAllocationException(String message,
                                   Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

ResourceAllocationException

public ResourceAllocationException(String message,
                                   String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


security

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource.spi.security

The javax.resource.spi.security package contains APIs for the security management contract.

See:
Description

Interface Summary
GenericCredential Deprecated. The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.

Class Summary
PasswordCredential The class PasswordCredential acts as a holder for username and password.

Package javax.resource.spi.security Description

The javax.resource.spi.security package contains APIs for the security management contract.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.resource.spi.security Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource.spi.security

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.resource.spi.security.PasswordCredential (implements java.io.Serializable)

Interface Hierarchy

  • interface javax.resource.spi.security.GenericCredential
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


GenericCredential

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.security
Interface GenericCredential

Deprecated. The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.

public interface GenericCredential

The interface javax.resource.spi.security.GenericCredential defines a security mechanism independent interface for accessing security credential of a resource principal.

The GenericCredential interface provides a Java wrapper over an underlying mechanism specific representation of a security credential. For example, the GenericCredential interface can be used to wrap Kerberos credentials.

The connector architecture does not define any standard format and requirements for security mechanism specific credentials. For example, a security credential wrapped by a GenericCredential interface can have a native representation specific to an operating system.

The GenericCredential interface enables a resource adapter to extract information about a security credential. The resource adapter can then manage EIS sign-on for a resource principal by either:

  • using the credentials in an EIS specific manner if the underlying EIS supports the security mechanism type represented by the GenericCredential instance, or,
  • using GSS-API if the resource adapter and underlying EIS instance support GSS-API.

Since:
0.7
Version:
0.7
Author:
Rahul Sharma
See Also:
Subject, Principal

Method Summary
boolean | equals(Object another) Deprecated. Tests if this GenericCredential instance refers to the same entity as the supplied object.
byte[] | getCredentialData() Deprecated. Gets security data for a specific security mechanism represented by the GenericCredential.
String | getMechType() Deprecated. Returns the mechanism type for the GenericCredential instance.
String | getName() Deprecated. Returns the name of the resource principal associated with a GenericCredential instance.
int | hashCode() Deprecated. Returns the hash code for this GenericCredential

Method Detail

getName

public String getName()
Deprecated.
Returns the name of the resource principal associated with a GenericCredential instance.

Returns:
Name of the principal

getMechType

public String getMechType()
Deprecated.
Returns the mechanism type for the GenericCredential instance. The mechanism type definition for GenericCredential should be consistent with the Object Identifier (OID) based representation specified in the GSS specification. In the GenericCredential interface, the mechanism type is returned as a stringified representation of the OID specification.

Returns:
mechanism type

getCredentialData

public byte[] getCredentialData()
                         throws SecurityException
Deprecated.
Gets security data for a specific security mechanism represented by the GenericCredential. An example is authentication data required for establishing a secure association with an EIS instance on behalf of the associated resource principal.

The getCredentialData method returns the credential representation as an array of bytes. Note that the connector architecture does not define any standard format for the returned credential data.

Returns:
credential representation as an array of bytes.
Throws:
SecurityException - Failed operation due to security related error condition

equals

public boolean equals(Object another)
Deprecated.
Tests if this GenericCredential instance refers to the same entity as the supplied object. The two credentials must be acquired over the same mechanisms and must refer to the same principal. Returns true if the two GenericCredentials refer to the same entity; false otherwise.

hashCode

public int hashCode()
Deprecated.
Returns the hash code for this GenericCredential

Returns:
hash code for this GenericCredential
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PasswordCredential

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.security
Class PasswordCredential

java.lang.Object
    extended by javax.resource.spi.security.PasswordCredential
All Implemented Interfaces:
Serializable
public final class PasswordCredential
extends Object
implements Serializable

The class PasswordCredential acts as a holder for username and password.

Since:
0.6
Version:
0.6
Author:
Rahul Sharma
See Also:
ManagedConnectionFactory, Serialized Form

Constructor Summary
PasswordCredential(String userName, char[] password)
Creates a new PasswordCredential object from the given user name and password.
Method Summary
boolean | equals(Object other) Compares this PasswordCredential with the specified object for equality.
ManagedConnectionFactory | getManagedConnectionFactory() Gets the target ManagedConnectionFactory for which the user name and password has been set by the application server.
char[] | getPassword() Returns the user password.
String | getUserName() Returns the user name.
int | hashCode() Returns the hash code for this PasswordCredential
void | setManagedConnectionFactory(ManagedConnectionFactory mcf) Sets the target ManagedConenctionFactory instance for which the user name and password has been set by the application server.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PasswordCredential

public PasswordCredential(String userName,
                          char[] password)
Creates a new PasswordCredential object from the given user name and password.

Note that the given user password is cloned before it is stored in the new PasswordCredential object.

Parameters:
userName - the user name
password - the user's password
Method Detail

getUserName

public String getUserName()
Returns the user name.

Returns:
the user name

getPassword

public char[] getPassword()
Returns the user password.

Note that this method returns a reference to the password. It is the caller's responsibility to zero out the password information after it is no longer needed.

Returns:
the password

getManagedConnectionFactory

public ManagedConnectionFactory getManagedConnectionFactory()
Gets the target ManagedConnectionFactory for which the user name and password has been set by the application server. A ManagedConnection- Factory uses this field to find out whether PasswordCredential should be used by it for sign-on to the target EIS instance.

Returns:
ManagedConnectionFactory instance for which user name and password have been specified

setManagedConnectionFactory

public void setManagedConnectionFactory(ManagedConnectionFactory mcf)
Sets the target ManagedConenctionFactory instance for which the user name and password has been set by the application server.

Parameters:
mcf - ManagedConnectionFactory instance for which user name and password have been specified

equals

public boolean equals(Object other)
Compares this PasswordCredential with the specified object for equality. The two PasswordCredential instances are the same if they are equal in username and password.

Parameters:
other - Object to which PasswordCredential is to be compared
Returns:
true if and if the specified object is a PasswordCredential whose username and password are equal to this instance.

hashCode

public int hashCode()
Returns the hash code for this PasswordCredential

Returns:
hash code for this PasswordCredential
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SecurityException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class SecurityException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.SecurityException
All Implemented Interfaces:
Serializable
public class SecurityException
extends ResourceException

A SecurityException indicates error conditions related to the security contract between an application server and resource adapter. The common error conditions represented by this exception are:

  • Invalid security information (represented as a Subject instance) passed across the security contract - for example, credentials have expired or have invalid format.
  • Lack of support for a specific security mechanism in an EIS or resource adapter.
  • Failure to create a connection to an EIS because of failed authentication or authorization.
  • Failure to authenticate a resource principal to an EIS instance or failure to establish a secure association with an underlying EIS instance.
  • Access control exception to indicate that a requested access to an EIS resource or a request to create a new connection is denied.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
SecurityException()
Constructs a new instance with null as its detail message.
SecurityException(String message)
Constructs a new instance with the specified detail message.
SecurityException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
SecurityException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
SecurityException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SecurityException

public SecurityException()
Constructs a new instance with null as its detail message.

SecurityException

public SecurityException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

SecurityException

public SecurityException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

SecurityException

public SecurityException(String message,
                         Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

SecurityException

public SecurityException(String message,
                         String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SharingViolationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class SharingViolationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.SharingViolationException
All Implemented Interfaces:
Serializable
public class SharingViolationException
extends ResourceException

This is thrown to indicate a connection sharing violation.

This may be thrown by a resource adapter when an application uses a shareable connection in an unshareable manner.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
SharingViolationException()
Constructs a new instance with null as its detail message.
SharingViolationException(String message)
Constructs a new instance with the specified detail message.
SharingViolationException(String message, String errorCode)
Constructs a new throwable with the specified detail message and error code.
SharingViolationException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
SharingViolationException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SharingViolationException

public SharingViolationException()
Constructs a new instance with null as its detail message.

SharingViolationException

public SharingViolationException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

SharingViolationException

public SharingViolationException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

SharingViolationException

public SharingViolationException(String message,
                                 Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

SharingViolationException

public SharingViolationException(String message,
                                 String errorCode)
Constructs a new throwable with the specified detail message and error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


UnavailableException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class UnavailableException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.UnavailableException
All Implemented Interfaces:
Serializable
public class UnavailableException
extends ResourceException

This is thrown to indicate that a service is unavailable.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
UnavailableException()
Constructs a new instance with null as its detail message.
UnavailableException(String message)
Constructs a new instance with the specified detail message.
UnavailableException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
UnavailableException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
UnavailableException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnavailableException

public UnavailableException()
Constructs a new instance with null as its detail message.

UnavailableException

public UnavailableException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

UnavailableException

public UnavailableException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

UnavailableException

public UnavailableException(String message,
                            Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

UnavailableException

public UnavailableException(String message,
                            String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ValidatingManagedConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ValidatingManagedConnectionFactory

public interface ValidatingManagedConnectionFactory

This interface is implemented by a ManagedConnectionFactory instance that supports the ability to validate ManagedConnection objects.

This may be used by the application server to prune invalid ManagedConnection objects from its connection pool.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 Set getInvalidConnections(Set connectionSet)
This method returns a set of invalid ManagedConnection objects chosen from a specified set of ManagedConnection objects.

Method Detail

getInvalidConnections

public Set getInvalidConnections(Set connectionSet)
                          throws ResourceException
This method returns a set of invalid ManagedConnection objects chosen from a specified set of ManagedConnection objects.

Parameters:
connectionSet - a set of ManagedConnection objects that need to be validated.
Returns:
a set of invalid ManagedConnection objects.
Throws:
ResourceException - generic exception.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


work

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource.spi.work

This package contains APIs for the work management contract.

See:
Description

Interface Summary
Work | This models a Work instance that would be executed by a WorkManager upon submission.
WorkListener | This models a WorkListener instance which would be notified by the WorkManager when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
WorkManager | This interface models a WorkManager which provides a facility to submit Work instances for execution.

Class Summary
ExecutionContext | This class models an execution context (transaction, security, etc) with which the Work instance must be executed.
WorkAdapter | This class is provided as a convenience for easily creating WorkListener instances by extending this class and overriding only those methods of interest.
WorkEvent | This class models the various events that occur during the processing of a Work instance.

Exception Summary
WorkCompletedException | This exception is thrown by a WorkManager to indicate that a submitted Work instance has completed with an exception.
WorkException | A common base class for all Work processing related exceptions.
WorkRejectedException | This exception is thrown by a WorkManager to indicate that a submitted Work instance has been rejected.

Package javax.resource.spi.work Description

This package contains APIs for the work management contract.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.resource.spi.work Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource.spi.work

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.resource.spi.work.WorkEvent
    • class javax.resource.spi.work.ExecutionContext
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.resource.ResourceException
          • class javax.resource.spi.work.WorkException
            • class javax.resource.spi.work.WorkCompletedException
            • class javax.resource.spi.work.WorkRejectedException
    • class javax.resource.spi.work.WorkAdapter (implements javax.resource.spi.work.WorkListener)

Interface Hierarchy

  • interface java.util.EventListener
    • interface javax.resource.spi.work.WorkListener
  • interface java.lang.Runnable
    • interface javax.resource.spi.work.Work
  • interface javax.resource.spi.work.WorkManager
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ExecutionContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class ExecutionContext

java.lang.Object
    extended by javax.resource.spi.work.ExecutionContext
public class ExecutionContext
extends Object

This class models an execution context (transaction, security, etc) with which the Work instance must be executed. This class is provided as a convenience for easily creating ExecutionContext instances by extending this class and overriding only those methods of interest.

Some reasons why it is better for ExecutionContext to be a class rather than an interface:

  • There is no need for a resource adapter to implement this class. It only needs to implement the context information like transaction, etc.
  • The resource adapter code does not have to change when the ExecutionContext class evolves. For example, more context types could be added to the ExecutionContext class (in the future) without forcing resource adapter implementations to change.

Version:
1.0
Author:
Ram Jeyaraman

Constructor Summary
ExecutionContext()
Method Summary
long | getTransactionTimeout() Get the transaction timeout value for a imported transaction.
Xid | getXid()
void | setTransactionTimeout(long timeout) Set the transaction timeout value for a imported transaction.
void | setXid(Xid xid) set a transaction context.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExecutionContext

public ExecutionContext()
Method Detail

setXid

public void setXid(Xid xid)
set a transaction context.

Parameters:
xid - transaction context.

getXid

public Xid getXid()

setTransactionTimeout

public void setTransactionTimeout(long timeout)
                           throws NotSupportedException
Set the transaction timeout value for a imported transaction.

Parameters:
timeout - transaction timeout value in seconds. Only positive non-zero values are accepted. Other values are illegal and are rejected with a NotSupportedException.
Throws:
NotSupportedException - thrown to indicate an illegal timeout value.

getTransactionTimeout

public long getTransactionTimeout()
Get the transaction timeout value for a imported transaction.

Returns:
the specified transaction timeout value in seconds. When no timeout value or an illegal timeout value had been specified, a value of -1 (WorkManager.UNKNOWN) is returned; such a transaction is excluded from regular timeout processing.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Work

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Interface Work

All Superinterfaces:
Runnable
public interface Work
extends Runnable

This models a Work instance that would be executed by a WorkManager upon submission.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 void release()
The WorkManager might call this method to hint the active Work instance to complete execution as soon as possible.
Methods inherited from interface java.lang.Runnable
run

Method Detail

release

public void release()
The WorkManager might call this method to hint the active Work instance to complete execution as soon as possible. This would be called on a seperate thread other than the one currently executing the Work instance.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


WorkAdapter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class WorkAdapter

java.lang.Object
    extended by javax.resource.spi.work.WorkAdapter
All Implemented Interfaces:
EventListener, WorkListener
public class WorkAdapter
extends Object
implements WorkListener

This class is provided as a convenience for easily creating WorkListener instances by extending this class and overriding only those methods of interest.

Version:
1.0
Author:
Ram Jeyaraman

Constructor Summary
WorkAdapter()
Method Summary
void | workAccepted(WorkEvent e) Invoked when a Work instance has been accepted.
void | workCompleted(WorkEvent e) Invoked when a Work instance has completed execution.
void | workRejected(WorkEvent e) Invoked when a Work instance has been rejected.
void | workStarted(WorkEvent e) Invoked when a Work instance has started execution.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkAdapter

public WorkAdapter()
Method Detail

workAccepted

public void workAccepted(WorkEvent e)
Invoked when a Work instance has been accepted.

Specified by:
workAccepted in interface WorkListener

workRejected

public void workRejected(WorkEvent e)
Invoked when a Work instance has been rejected.

Specified by:
workRejected in interface WorkListener

workStarted

public void workStarted(WorkEvent e)
Invoked when a Work instance has started execution. This only means that a thread has been allocated.

Specified by:
workStarted in interface WorkListener

workCompleted

public void workCompleted(WorkEvent e)
Invoked when a Work instance has completed execution.

Specified by:
workCompleted in interface WorkListener
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


WorkCompletedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class WorkCompletedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.work.WorkException
                    extended by javax.resource.spi.work.WorkCompletedException
All Implemented Interfaces:
Serializable
public class WorkCompletedException
extends WorkException

This exception is thrown by a WorkManager to indicate that a submitted Work instance has completed with an exception.

This could be thrown only after the execution of a Work instance has started (that is, after a thread has been allocated for Work execution). The allocated thread sets up an execution context (if it has been specified), and then calls Work.run().

Any exception thrown during execution context setup or during Work execution (that is, during Work.run()) is chained within this exception.

An associated error code indicates the nature of the error condition. Possible error codes are WorkException.TX_RECREATE_FAILED, WorkException.TX_CONCURRENT_WORK_DISALLOWED or WorkException.UNDEFINED.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.resource.spi.work.WorkException
INTERNAL, START_TIMED_OUT, TX_CONCURRENT_WORK_DISALLOWED, TX_RECREATE_FAILED, UNDEFINED
Constructor Summary
WorkCompletedException()
Constructs a new instance with null as its detail message.
WorkCompletedException(String message)
Constructs a new instance with the specified detail message.
WorkCompletedException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
WorkCompletedException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
WorkCompletedException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkCompletedException

public WorkCompletedException()
Constructs a new instance with null as its detail message.

WorkCompletedException

public WorkCompletedException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

WorkCompletedException

public WorkCompletedException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

WorkCompletedException

public WorkCompletedException(String message,
                              Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

WorkCompletedException

public WorkCompletedException(String message,
                              String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


WorkEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class WorkEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.resource.spi.work.WorkEvent
All Implemented Interfaces:
Serializable
public class WorkEvent
extends EventObject

This class models the various events that occur during the processing of a Work instance.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Field Summary
static int | WORK_ACCEPTED Indicates Work instance has been accepted.
static int | WORK_COMPLETED Indicates Work instance has completed execution.
static int | WORK_REJECTED Indicates Work instance has been rejected.
static int | WORK_STARTED Indicates Work instance has started execution.
Fields inherited from class java.util.EventObject
source
Constructor Summary
WorkEvent(Object source, int type, Work work, WorkException exc)
Constructor.
WorkEvent(Object source, int type, Work work, WorkException exc, long startDuration)
Constructor.
Method Summary
WorkException | getException() Return the WorkException.
long | getStartDuration() Return the start interval duration.
int | getType() Return the type of this event.
Work | getWork() Return the Work instance which is the cause of the event.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

WORK_ACCEPTED

public static final int WORK_ACCEPTED
Indicates Work instance has been accepted.

See Also:
Constant Field Values

WORK_REJECTED

public static final int WORK_REJECTED
Indicates Work instance has been rejected.

See Also:
Constant Field Values

WORK_STARTED

public static final int WORK_STARTED
Indicates Work instance has started execution.

See Also:
Constant Field Values

WORK_COMPLETED

public static final int WORK_COMPLETED
Indicates Work instance has completed execution.

See Also:
Constant Field Values
Constructor Detail

WorkEvent

public WorkEvent(Object source,
                 int type,
                 Work work,
                 WorkException exc)
Constructor.

Parameters:
source - The object on which the event initially occurred.
type - The event type.
work - The Work object on which the event occured.
exc - The exception that occured during Work processing.

WorkEvent

public WorkEvent(Object source,
                 int type,
                 Work work,
                 WorkException exc,
                 long startDuration)
Constructor.

Parameters:
source - The object on which the event initially occurred.
type - The event type.
work - The Work object on which the event occured.
exc - The exception that occured during Work processing.
startDuration - The start delay duration (in milliseconds).
Method Detail

getType

public int getType()
Return the type of this event.

Returns:
the event type.

getWork

public Work getWork()
Return the Work instance which is the cause of the event.

Returns:
the Work instance.

getStartDuration

public long getStartDuration()
Return the start interval duration.

Returns:
the time elapsed (in milliseconds) since the Work was accepted, until the Work execution started. Note, this does not offer real-time guarantees. It is valid to return -1, if the actual start interval duration is unknown.

getException

public WorkException getException()
Return the WorkException. The actual WorkException subtype returned depends on the type of the event.

Returns:
a WorkRejectedException or a WorkCompletedException, if any.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


WorkException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class WorkException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.work.WorkException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
WorkCompletedException, WorkRejectedException
public class WorkException
extends ResourceException

A common base class for all Work processing related exceptions.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Field Summary
static String | INTERNAL Indicates an internal error condition.
static String | START_TIMED_OUT Indicates start timeout expiration.
static String | TX_CONCURRENT_WORK_DISALLOWED Indicates that concurrent work within a transaction is disallowed.
static String | TX_RECREATE_FAILED Indicates a failure in recreating the specified transaction context.
static String | UNDEFINED Undefined error code.
Constructor Summary
WorkException()
Constructs a new instance with null as its detail message.
WorkException(String message)
Constructs a new instance with the specified detail message.
WorkException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
WorkException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
WorkException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

INTERNAL

public static final String INTERNAL
Indicates an internal error condition.

See Also:
Constant Field Values

UNDEFINED

public static final String UNDEFINED
Undefined error code.

See Also:
Constant Field Values

START_TIMED_OUT

public static final String START_TIMED_OUT
Indicates start timeout expiration.

See Also:
Constant Field Values

TX_CONCURRENT_WORK_DISALLOWED

public static final String TX_CONCURRENT_WORK_DISALLOWED
Indicates that concurrent work within a transaction is disallowed. That is, there is already another Work instance associated with the specified transaction context.

See Also:
Constant Field Values

TX_RECREATE_FAILED

public static final String TX_RECREATE_FAILED
Indicates a failure in recreating the specified transaction context.

See Also:
Constant Field Values
Constructor Detail

WorkException

public WorkException()
Constructs a new instance with null as its detail message.

WorkException

public WorkException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

WorkException

public WorkException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

WorkException

public WorkException(String message,
                     Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

WorkException

public WorkException(String message,
                     String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


WorkListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Interface WorkListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
WorkAdapter
public interface WorkListener
extends EventListener

This models a WorkListener instance which would be notified by the WorkManager when the various Work processing events (work accepted, work rejected, work started, work completed) occur. The WorkListener instance must not make any thread assumptions and must be thread-safe ie., a notification could occur from any arbitrary thread. Further, it must not make any assumptions on the ordering of notifications.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
void | workAccepted(WorkEvent e) Invoked when a Work instance has been accepted.
void | workCompleted(WorkEvent e) Invoked when a Work instance has completed execution.
void | workRejected(WorkEvent e) Invoked when a Work instance has been rejected.
void | workStarted(WorkEvent e) Invoked when a Work instance has started execution.

Method Detail

workAccepted

public void workAccepted(WorkEvent e)
Invoked when a Work instance has been accepted.

workRejected

public void workRejected(WorkEvent e)
Invoked when a Work instance has been rejected.

workStarted

public void workStarted(WorkEvent e)
Invoked when a Work instance has started execution. This only means that a thread has been allocated.

workCompleted

public void workCompleted(WorkEvent e)
Invoked when a Work instance has completed execution.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


WorkManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Interface WorkManager

public interface WorkManager

This interface models a WorkManager which provides a facility to submit Work instances for execution. This frees the user from having to create Java threads directly to do work. Further, this allows efficient pooling of thread resources and more control over thread usage. The various stages in Work processing are:

  • work submit: A Work instance is being submitted for execution. The Work instance could either be accepted or rejected with a WorkRejectedException set to an appropriate error code.
  • work accepted: The submitted Work instance has been accepted. The accepted Work instance could either start execution or could be rejected again with a WorkRejectedException set to an appropriate error code. There is no guarantee on when the execution would start unless a start timeout duration is specified. When a start timeout is specified, the Work execution must be started within the specified duration (not a real-time guarantee), failing which a WorkRejectedException set to an error code (WorkRejected.TIMED_OUT) is thrown.
  • work rejected: The Work instance has been rejected. The Work instance could be rejected during Work submittal or after the Work instance has been accepted (but before Work instance starts execution). The rejection could be due to internal factors or start timeout expiration. A WorkRejectedException with an appropriate error code (indicates the reason) is thrown in both cases.
  • work started: The execution of the Work instance has started. This means that a thread has been allocated for its execution. But this does not guarantee that the allocated thread has been scheduled to run on a CPU resource. Once execution is started, the allocated thread sets up an appropriate execution context (transaction , security, etc) and calls Work.run(). Note, any exception thrown during execution context setup or Work.run() leads to completion of processing.
  • work completed: The execution of the Work has been completed. The execution could complete with or without an exception. The WorkManager catches any exception thrown during Work processing (which includes execution context setup), and wraps it with a WorkCompletedException.

Version:
1.0
Author:
Ram Jeyaraman

Field Summary
static long | IMMEDIATE A constant to indicate timeout duration.
static long | INDEFINITE A constant to indicate timeout duration.
static long | UNKNOWN A constant to indicate an unknown start delay duration or other unknown values.
Method Summary
void | doWork(Work work) Accepts a Work instance for processing.
void | doWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener) Accepts a Work instance for processing.
void | scheduleWork(Work work) Accepts a Work instance for processing.
void | scheduleWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener) Accepts a Work instance for processing.
long | startWork(Work work) Accepts a Work instance for processing.
long | startWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener) Accepts a Work instance for processing.

Field Detail

IMMEDIATE

public static final long IMMEDIATE
A constant to indicate timeout duration. A zero timeout value indicates an action be performed immediately.

See Also:
Constant Field Values

INDEFINITE

public static final long INDEFINITE
A constant to indicate timeout duration. A maximum timeout value indicates that an action be performed arbitrarily without any time constraint.

See Also:
Constant Field Values

UNKNOWN

public static final long UNKNOWN
A constant to indicate an unknown start delay duration or other unknown values.

See Also:
Constant Field Values
Method Detail

doWork

public void doWork(Work work)
            throws WorkException
Accepts a Work instance for processing. This call blocks until the Work instance completes execution. There is no guarantee on when the accepted Work instance would start execution ie., there is no time constraint to start execution.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
WorkCompletedException - indicates that a Work instance has completed execution with an exception.
WorkException

doWork

public void doWork(Work work,
                   long startTimeout,
                   ExecutionContext execContext,
                   WorkListener workListener)
            throws WorkException
Accepts a Work instance for processing. This call blocks until the Work instance completes execution.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
startTimeout - a time duration (in milliseconds) within which the execution of the Work instance must start. Otherwise, the Work instance is rejected with a WorkRejectedException set to an appropriate error code (WorkRejectedException.TIMED_OUT). Note, this does not offer real-time guarantees.
execContext - an object containing the execution context with which the submitted Work instance must be executed.
workListener - an object which would be notified when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors or start timeout expiration.
WorkCompletedException - indicates that a Work instance has completed execution with an exception.
WorkException

startWork

public long startWork(Work work)
               throws WorkException
Accepts a Work instance for processing. This call blocks until the Work instance starts execution but not until its completion. There is no guarantee on when the accepted Work instance would start execution ie., there is no time constraint to start execution.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
Returns:
the time elapsed (in milliseconds) from Work acceptance until start of execution. Note, this does not offer real-time guarantees. It is valid to return -1, if the actual start delay duration is unknown.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
WorkException

startWork

public long startWork(Work work,
                      long startTimeout,
                      ExecutionContext execContext,
                      WorkListener workListener)
               throws WorkException
Accepts a Work instance for processing. This call blocks until the Work instance starts execution but not until its completion. There is no guarantee on when the accepted Work instance would start execution ie., there is no time constraint to start execution.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
startTimeout - a time duration (in milliseconds) within which the execution of the Work instance must start. Otherwise, the Work instance is rejected with a WorkRejectedException set to an appropriate error code (WorkRejectedException.TIMED_OUT). Note, this does not offer real-time guarantees.
execContext - an object containing the execution context with which the submitted Work instance must be executed.
workListener - an object which would be notified when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
Returns:
the time elapsed (in milliseconds) from Work acceptance until start of execution. Note, this does not offer real-time guarantees. It is valid to return -1, if the actual start delay duration is unknown.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors or start timeout expiration.
WorkException

scheduleWork

public void scheduleWork(Work work)
                  throws WorkException
Accepts a Work instance for processing. This call does not block and returns immediately once a Work instance has been accepted for processing. There is no guarantee on when the submitted Work instance would start execution ie., there is no time constraint to start execution.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
WorkException

scheduleWork

public void scheduleWork(Work work,
                         long startTimeout,
                         ExecutionContext execContext,
                         WorkListener workListener)
                  throws WorkException
Accepts a Work instance for processing. This call does not block and returns immediately once a Work instance has been accepted for processing.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
startTimeout - a time duration (in milliseconds) within which the execution of the Work instance must start. Otherwise, the Work instance is rejected with a WorkRejectedException set to an appropriate error code (WorkRejectedException.TIMED_OUT). Note, this does not offer real-time guarantees.
execContext - an object containing the execution context with which the submitted Work instance must be executed.
workListener - an object which would be notified when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
WorkException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


WorkRejectedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class WorkRejectedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.resource.ResourceException
                extended by javax.resource.spi.work.WorkException
                    extended by javax.resource.spi.work.WorkRejectedException
All Implemented Interfaces:
Serializable
public class WorkRejectedException
extends WorkException

This exception is thrown by a WorkManager to indicate that a submitted Work instance has been rejected. The rejection could be due to internal factors or start timeout expiration.

This could be thrown only before the execution of a Work instance starts (that is, before a thread has been allocated for Work execution).

An associated error code indicates the nature of the error condition. Possible error codes are WorkException.START_TIMED_OUT, WorkException.INTERNAL or WorkException.UNDEFINED.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.resource.spi.work.WorkException
INTERNAL, START_TIMED_OUT, TX_CONCURRENT_WORK_DISALLOWED, TX_RECREATE_FAILED, UNDEFINED
Constructor Summary
WorkRejectedException()
Constructs a new instance with null as its detail message.
WorkRejectedException(String message)
Constructs a new instance with the specified detail message.
WorkRejectedException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
WorkRejectedException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
WorkRejectedException(Throwable cause)
Constructs a new throwable with the specified cause.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkRejectedException

public WorkRejectedException()
Constructs a new instance with null as its detail message.

WorkRejectedException

public WorkRejectedException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

WorkRejectedException

public WorkRejectedException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

WorkRejectedException

public WorkRejectedException(String message,
                             Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

WorkRejectedException

public WorkRejectedException(String message,
                             String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XATerminator

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface XATerminator

public interface XATerminator

The XATerminator interface is used for transaction completion and crash recovery flows.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
void | commit(Xid xid, boolean onePhase) Commits the global transaction specified by xid.
void | forget(Xid xid) Tells the resource manager to forget about a heuristically completed transaction branch.
int | prepare(Xid xid) Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
Xid[] | recover(int flag) Obtains a list of prepared transaction branches from a resource manager.
void | rollback(Xid xid) Informs the resource manager to roll back work done on behalf of a transaction branch.

Method Detail

commit

public void commit(Xid xid,
                   boolean onePhase)
            throws XAException
Commits the global transaction specified by xid.

Parameters:
xid - A global transaction identifier
onePhase - If true, the resource manager should use a one-phase commit protocol to commit the work done on behalf of xid.
Throws:
XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

If the resource manager did not commit the transaction and the parameter onePhase is set to true, the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

forget

public void forget(Xid xid)
            throws XAException
Tells the resource manager to forget about a heuristically completed transaction branch.

Parameters:
xid - A global transaction identifier.
Throws:
XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

prepare

public int prepare(Xid xid)
            throws XAException
Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.

Parameters:
xid - A global transaction identifier.
Returns:
A value indicating the resource manager's vote on the outcome of the transaction. The possible values are: XA_RDONLY or XA_OK. These constants are defined in javax.transaction.xa.XAResource interface. If the resource manager wants to roll back the transaction, it should do so by raising an appropriate XAException in the prepare method.
Throws:
XAException - An error has occurred. Possible exception values are: XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

recover

public Xid[] recover(int flag)
              throws XAException
Obtains a list of prepared transaction branches from a resource manager. The transaction manager calls this method during recovery to obtain the list of transaction branches that are currently in prepared or heuristically completed states.

Parameters:
flag - One of TMSTARTRSCAN, TMENDRSCAN, TMNOFLAGS. TMNOFLAGS must be used when no other flags are set in the parameter. These constants are defined in javax.transaction.xa.XAResource interface.
Returns:
The resource manager returns zero or more XIDs of the transaction branches that are currently in a prepared or heuristically completed state. If an error occurs during the operation, the resource manager should throw the appropriate XAException.
Throws:
XAException - An error has occurred. Possible values are XAER_RMERR, XAER_RMFAIL, XAER_INVAL, and XAER_PROTO.

rollback

public void rollback(Xid xid)
              throws XAException
Informs the resource manager to roll back work done on behalf of a transaction branch.

Parameters:
xid - A global transaction identifier.
Throws:
XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

If the transaction branch is already marked rollback-only the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


jacc

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.security.jacc

This package contains the Java Authorization Contract for Containers API

See:
Description

Interface Summary
PolicyConfiguration | The methods of this interface are used by containers to create policy statements in a Policy provider.
PolicyContextHandler | This interface defines the methods that must be implemented by handlers that are to be registered and activated by the PolicyContext class.

Class Summary
EJBMethodPermission | Class for EJB method permissions.
EJBRoleRefPermission | Class for EJB isCallerInRole (String reference) permissions.
PolicyConfigurationFactory | Abstract factory and finder class for obtaining the instance of the class that implements the PolicyConfigurationFactory of a provider.
PolicyContext | This utility class is used by containers to communicate policy context identifiers and other policy relevant context to Policy providers.
WebResourcePermission | Class for Servlet web resource permissions.
WebRoleRefPermission | Class for Servlet isUserInRole (String reference) permissions.
WebUserDataPermission | Class for Servlet Web user data permissions.

Exception Summary
PolicyContextException This checked exception is thrown by implementations of the javax.security.jacc.PolicyConfiguration Interface, the javax.security.jacc.PolicyConfigurationFactory abstract class, the javax.security.jacc.PolicyContext utility class, and implementations of the javax.security.jacc.PolicyContextException Interface.

Package javax.security.jacc Description

This package contains the Java Authorization Contract for Containers API

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.security.jacc Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.security.jacc

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • class javax.security.jacc.EJBMethodPermission (implements java.io.Serializable)
      • class javax.security.jacc.EJBRoleRefPermission (implements java.io.Serializable)
      • class javax.security.jacc.WebResourcePermission (implements java.io.Serializable)
      • class javax.security.jacc.WebRoleRefPermission (implements java.io.Serializable)
      • class javax.security.jacc.WebUserDataPermission (implements java.io.Serializable)
    • class javax.security.jacc.PolicyConfigurationFactory
    • class javax.security.jacc.PolicyContext
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.security.jacc.PolicyContextException

Interface Hierarchy

  • interface javax.security.jacc.PolicyConfiguration
  • interface javax.security.jacc.PolicyContextHandler
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EJBMethodPermission

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class EJBMethodPermission

java.lang.Object
    extended by java.security.Permission
        extended by javax.security.jacc.EJBMethodPermission
All Implemented Interfaces:
Guard, Serializable
public final class EJBMethodPermission
extends Permission
implements Serializable

Class for EJB method permissions.

The name of an EJBMethodPermission contains the value of the ejb-name element in the application's deployment descriptor that identifies the target EJB.

The actions of an EJBMethodPermission identifies the methods of the EJB to which the permission applies.

Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, Serialized Form

Constructor Summary
EJBMethodPermission(String name, String actions)
Creates a new EJBMethodPermission with the specified name and actions.
EJBMethodPermission(String EJBName, String methodInterface, Method method)
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodInterface, and the Method object.
EJBMethodPermission(String EJBName, String methodName, String methodInterface, String[] methodParams)
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodName, methodInterface, and methodParams.
Method Summary
boolean | equals(Object o) Checks two EJBMethodPermission objects for equality.
String | getActions() Returns a String containing a canonical representation of the actions of this EJBMethodPermission.
int | hashCode() Returns the hash code value for this EJBMethodPermission.
boolean | implies(Permission permission) Determines if the argument Permission is "implied by" this EJBMethodPermission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EJBMethodPermission

public EJBMethodPermission(String name,
                           String actions)
Creates a new EJBMethodPermission with the specified name and actions.

The name contains the value of the ejb-name element corresponding to an EJB in the application's deployment descriptor.

The actions contains a methodSpec. The syntax of the actions parameter is defined as follows:

      methodNameSpec ::= methodName | emptyString

      methodInterfaceName ::= String

      methodInterfaceSpec ::= methodInterfaceName | emptyString

      typeName ::= typeName | typeName []

      methodParams ::= typeName | methodParams comma typeName

      methodParamsSpec ::= emptyString | methodParams

      methodSpec ::= null |
           methodNameSpec |
           methodNameSpec comma methodInterfaceName |
           methodNameSpec comma methodInterfaceSpec comma methodParamsSpec

A MethodInterfaceName is a non-empty String and should contain a method-intf value as defined for use in EJB deployment descriptors. An implementation must be flexible such that it supports additional interface names especially if they are standardized by the EJB Specification. The EJB Specification currently defines the following method-intf values:

       { "Home", "LocalHome", "Remote", "Local", "ServiceEndpoint" }

A null or empty string methodSpec indicates that the permission applies to all methods of the EJB. A methodSpec with a methodNameSpec of the empty string matches all methods of the EJB that match the methodInterface and methodParams elements of the methodSpec.

A methodSpec with a methodInterfaceSpec of the empty string matches all methods of the EJB that match the methodNameSpec and methodParamsSpec elements of the methodSpec.

A methodSpec without a methodParamsSpec matches all methods of the EJB that match the methodNameSpec and methodInterface elements of the methodSpec.

The order of the typeNames in methodParams array must match the order of occurence of the corresponding parameters in the method signature of the target method(s). Each typeName in the methodParams must contain the canonical form of the corresponding parameter's typeName as defined by the getActions method. A methodSpec with an empty methodParamsSpec matches all 0 argument methods of the EJB that match the methodNameSpec and methodInterfaceSpec elements of the methodSpec.

Parameters:
name - of the EJB to which the permission pertains.

actions - identifies the methods of the EJB to which the permission pertains.

EJBMethodPermission

public EJBMethodPermission(String EJBName,
                           String methodName,
                           String methodInterface,
                           String[] methodParams)
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodName, methodInterface, and methodParams.

Parameters:
EJBName - The string representation of the name of the EJB as it appears in the corresponding ejb-name element in the deployment descriptor.

methodName - A string that may be used to indicate the method of the EJB to which the permission pertains. A value of null or "" indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of method name.

methodInterface - A string that may be used to specify the EJB interface to which the permission pertains. A value of null or "", indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of the interface they occur on.

methodParams - An array of strings that may be used to specify (by typeNames) the parameter signature of the target methods. The order of the typeNames in methodParams array must match the order of occurence of the corresponding parameters in the method signature of the target method(s). Each typeName in the methodParams array must contain the canonical form of the corresponding parameter's typeName as defined by the getActions method. An empty methodParams array is used to represent a method signature with no arguments. A value of null indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of method signature.

EJBMethodPermission

public EJBMethodPermission(String EJBName,
                           String methodInterface,
                           Method method)
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodInterface, and the Method object.

A container uses this constructor prior to checking if a caller has permission to call the method of an EJB.

Parameters:
EJBName - The string representation of the name of the EJB as it appears in the corresponding ejb-name element in the deployment descriptor.

methodInterface - A string that may be used to specify the EJB interface to which the permission pertains. A value of null or "", indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of the interface they occur on.

method - an instance of the Java.lang.reflect.Method class corresponding to the method that the container is trying to determine whether the caller has permission to access. This value must not be null.
Method Detail

equals

public boolean equals(Object o)
Checks two EJBMethodPermission objects for equality. EJBMethodPermission objects are equivalent if they have case sensitive equivalent name and actions values.

Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

Parameters:
o - the EJBMethodPermission object being tested for equality with this EJBMethodPermission

Returns:
true if the argument EJBMethodPermission object is equivalent to this EJBMethodPermission.

getActions

public String getActions()
Returns a String containing a canonical representation of the actions of this EJBMethodPermission. The Canonical form of the actions of an EJBMethodPermission is described by the following syntax description.

      methodNameSpec ::= methodName | emptyString

      methodInterfaceName ::= String

      methodInterfaceSpec ::= methodInterfaceName | emptyString

      typeName ::= typeName | typeName []

      methodParams ::= typeName | methodParams comma typeName

      methodParamsSpec ::= emptyString | methodParams

      methodSpec ::= null |
           methodName |
           methodNameSpec comma methodInterfaceName |
           methodNameSpec comma methodInterfaceSpec comma methodParamsSpec

The canonical form of each typeName must begin with the fully qualified Java name of the corresponding parameter's type. The canonical form of a typeName for an array parameter is the fully qualified Java name of the array's component type followed by as many instances of the string "[]" as there are dimensions to the array. No additional characters (e.g. blanks) may occur in the canonical form.

A MethodInterfaceName is a non-empty String and should contain a method-intf value as defined for use in EJB deployment descriptors. An implementation must be flexible such that it supports additional interface names especially if they are standardized by the EJB Specification. The EJB Specification currently defines the following method-intf values:

       { "Home", "LocalHome", "Remote", "Local", "ServiceEndpoint" }

Returns:
a String containing the canonicalized actions of this EJBMethodPermission.

hashCode

public int hashCode()
Returns the hash code value for this EJBMethodPermission. The properties of the returned hash code must be as follows:

  • During the lifetime of a Java application, the hashCode method must return the same integer value every time it is called on a EJBMethodPermission object. The value returned by hashCode for a particular EJBMethodPermission need not remain consistent from one execution of an application to another.
  • If two EJBMethodPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

Returns:
the integer hash code value for this object.

implies

public boolean implies(Permission permission)
Determines if the argument Permission is "implied by" this EJBMethodPermission. For this to be the case,

  • The argument must be an instanceof EJBMethodPermission
  • with name equivalent to that of this EJBMethodPermission, and
  • the methods to which the argument permission applies (as defined in its actions) must be a subset of the methods to which this EJBMethodPermission applies (as defined in its actions).

The argument permission applies to a subset of the methods to which this permission applies if all of the following conditions are met.

  • the method name component of the methodNameSpec of this permission is null, the empty string, or equivalent to the method name of the argument permission, and
  • the method interface component of the methodNameSpec of this permission is null, the empty string, or equivalent to the method interface of the argument permission, and
  • the method parameter list component of the methodNameSpec of this permission is null, the empty string, or equivalent to the method parameter list of the argument permission.

The name and actions comparisons described above are case sensitive.

Parameters:
permission - "this" EJBMethodPermission is checked to see if it implies the argument permission.

Returns:
true if the specified permission is implied by this object, false if not.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EJBRoleRefPermission

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class EJBRoleRefPermission

java.lang.Object
    extended by java.security.Permission
        extended by javax.security.jacc.EJBRoleRefPermission
All Implemented Interfaces:
Guard, Serializable
public final class EJBRoleRefPermission
extends Permission
implements Serializable

Class for EJB isCallerInRole (String reference) permissions. An EJBRoleRefPermission is a named permission and has actions.

The name of an EJBRoleRefPermission contains the value of the ejb-name element in the application's deployment descriptor that identifies the EJB in whose context the permission is being evalutated.

the actions of an EJBRoleRefPermission identifies the role reference to which the permission applies. An EJBRoleRefPermission is checked to determine if the subject is a member of the role identified by the reference.

Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, Serialized Form

Constructor Summary
EJBRoleRefPermission(String name, String actions)
Creates a new EJBRoleRefPermission with the specified name and actions.
Method Summary
boolean | equals(Object o) Checks two EJBRoleRefPermission objects for equality.
String | getActions() Returns a canonical String representation of the actions of this EJBRoleRefPermission.
int | hashCode() Returns the hash code value for this EJBRoleRefPermission.
boolean | implies(Permission permission) Determines if the argument Permission is "implied by" this EJBRoleRefPermission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EJBRoleRefPermission

public EJBRoleRefPermission(String name,
                            String actions)
Creates a new EJBRoleRefPermission with the specified name and actions.

Parameters:
name - the ejb-name that identifies the EJB in whose context the role references are to be evaluated.

actions - identifies the role reference to which the permission pertains. The role reference is scoped to the EJB identified in the name parameter. The value of the role reference must not be null or the empty string.
Method Detail

equals

public boolean equals(Object o)
Checks two EJBRoleRefPermission objects for equality. EJBRoleRefPermission objects are equivalent if they have case equivalent name and actions values.

Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

Parameters:
o - the EJBRoleRefPermission object being tested for equality with this EJBRoleRefPermission.

Returns:
true if the argument EJBRoleRefPermission object is equivalent to this EJBRoleRefPermission.

getActions

public String getActions()
Returns a canonical String representation of the actions of this EJBRoleRefPermission.

Returns:
a String containing the canonicalized actions of this EJBRoleRefPermission.

hashCode

public int hashCode()
Returns the hash code value for this EJBRoleRefPermission. The properties of the returned hash code must be as follows:

  • During the lifetime of a Java application, the hashCode method must return the same integer value, every time it is called on a EJBRoleRefPermission object. The value returned by hashCode for a particular EJBRoleRefPermission need not remain consistent from one execution of an application to another.
  • If two EJBRoleRefPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

Returns:
the integer hash code value for this object.

implies

public boolean implies(Permission permission)
Determines if the argument Permission is "implied by" this EJBRoleRefPermission. For this to be the case,

  • The argument must be an instanceof EJBRoleRefPermission
  • with name equivalent to that of this EJBRoleRefPermission, and
  • with the role reference equivalent to that of this EJBRoleRefPermission applies.

    The name and actions comparisons described above are case sensitive.

    Parameters:
    permission - "this" EJBRoleRefPermission is checked to see if it implies the argument permission.

    Returns:
    true if the specified permission is implied by this object, false if not.
    • Overview Package Class Tree Deprecated Index Help
            JavaTM 2 Platform
    Ent. Ed. v1.4
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
    Submit a bug or feature

    Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PolicyConfiguration

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Interface PolicyConfiguration

public interface PolicyConfiguration

The methods of this interface are used by containers to create policy statements in a Policy provider. An object that implements the PolicyConfiguration interface provides the policy statement configuration interface for a corresponding policy context within the corresponding Policy provider.

The life cycle of a policy context is defined by three states; "open", "inService", and "deleted". A policy context is in one of these three states.

A policy context in the "open" state is in the process of being configured, and may be operated on by any of the methods of the PolicyConfiguration interface. A policy context in the "open" state must not be assimilated at Policy.refresh into the policy statements used by the Policy provider in performing its access decisions. In order for the policy statements of a policy context to be assimilated by the associated provider, the policy context must be in the "inService" state. A policy context in the "open" state is transitioned to the "inService" state by calling the commit method.

A policy context in the "inService" state is available for assimilation into the policy statements being used to perform access decisions by the associated Policy provider. Providers assimilate policy contexts containing policy statements when the refresh method of the provider is called. When a provider's refresh method is called, it must assimilate only those policy contexts whose state is "inService" and it must ensure that the policy statements put into service for each policy context are only those defined in the context at the time of the call to refresh. A policy context in the "inService" state is not available for additional configuration and may be returned to the "open" state by calling the getPolicyConfiguration method of the PolicyConfigurationFactory.

A policy context in the "deleted" state is neither available for configuration, nor is it available for assimilation into the Provider. A policy context whose state is "deleted" may be reclaimed for subsequent processing by calling the getPolicyConfiguration method of the associated PolicyConfigurationFactory. A "deleted" policy context is transitioned to the "open" state when it it returned as a result of a call to getPolicyConfiguration.

The following table captures the correspondence between the policy context life cycle and the methods of the PolicyConfiguration interface. The rightmost 3 columns of the table correspond to the PolicyConfiguration state identified at the head of the column. The values in the cells of these columns indicate the next state resulting from a call to the method identifed in the leftmost column of the corresponding row, or that calling the method is unsupported in the state represented by the column (in which case the state will remain unchanged).

PolicyConfiguration State Table
Method | Current State to Next State
 | deleted | open | inService
addToExcludedPolicy | Unsupported Operation | open | Unsupported Operation
addToRole | Unsupported Operation | open | Unsupported Operation
addToUncheckedPolicy | Unsupported Operation | open | Unsupported Operation
commit | Unsupported Operation | inService | inService
delete | deleted | deleted | deleted
getContextID | deleted | open | inService
inService | deleted | open | inService
linkConfiguration | Unsupported Operation | open | Unsupported Operation
removeExcludedPolicy | Unsupported Operation | open | Unsupported Operation
removeRole | Unsupported Operation | open | Unsupported Operation
removeUncheckedPolicy | Unsupported Operation | open | Unsupported Operation

For a provider implementation to be compatible with multi-threaded environments, it may be necessary to synchronize the refresh method of the provider with the methods of its PolicyConfiguration interface and with the getPolicyConfiguration and inService methods of its PolicyConfigurationFactory.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, PermissionCollection, PolicyContextException, PolicyConfigurationFactory

Method Summary
void | addToExcludedPolicy(Permission permission) Used to add a single excluded policy statement to this PolicyConfiguration.
void | addToExcludedPolicy(PermissionCollection permissions) Used to add excluded policy statements to this PolicyConfiguration.
void | addToRole(String roleName, Permission permission) Used to add a single permission to a named role in this PolicyConfiguration.
void | addToRole(String roleName, PermissionCollection permissions) Used to add permissions to a named role in this PolicyConfiguration.
void | addToUncheckedPolicy(Permission permission) Used to add a single unchecked policy statement to this PolicyConfiguration.
void | addToUncheckedPolicy(PermissionCollection permissions) Used to add unchecked policy statements to this PolicyConfiguration.
void | commit() This method is used to set to "inService" the state of the policy context whose interface is this PolicyConfiguration Object.
void | delete() Causes all policy statements to be deleted from this PolicyConfiguration and sets its internal state such that calling any method, other than delete, getContextID, or inService on the PolicyConfiguration will be rejected and cause an UnsupportedOperationException to be thrown.
String | getContextID() This method returns this object's policy context identifier.
boolean | inService() This method is used to determine if the policy context whose interface is this PolicyConfiguration Object is in the "inService" state.
void | linkConfiguration(PolicyConfiguration link) Creates a relationship between this configuration and another such that they share the same principal-to-role mappings.
void | removeExcludedPolicy() Used to remove any excluded policy statements from this PolicyConfiguration.
void | removeRole(String roleName) Used to remove a role and all its permissions from this PolicyConfiguration.
void | removeUncheckedPolicy() Used to remove any unchecked policy statements from this PolicyConfiguration.

Method Detail

getContextID

public String getContextID()
                    throws PolicyContextException
This method returns this object's policy context identifier.

Returns:
this object's policy context identifier.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the getContextID method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToRole

public void addToRole(String roleName,
                      PermissionCollection permissions)
               throws PolicyContextException
Used to add permissions to a named role in this PolicyConfiguration. If the named Role does not exist in the PolicyConfiguration, it is created as a result of the call to this function.

It is the job of the Policy provider to ensure that all the permissions added to a role are granted to principals "mapped to the role".

Parameters:
roleName - the name of the Role to which the permissions are to be added.

permissions - the collection of permissions to be added to the role. The collection may be either a homogenous or heterogenous collection.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToRole method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToRole

public void addToRole(String roleName,
                      Permission permission)
               throws PolicyContextException
Used to add a single permission to a named role in this PolicyConfiguration. If the named Role does not exist in the PolicyConfiguration, it is created as a result of the call to this function.

It is the job of the Policy provider to ensure that all the permissions added to a role are granted to principals "mapped to the role".

Parameters:
roleName - the name of the Role to which the permission is to be added.

permission - the permission to be added to the role.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToRole method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToUncheckedPolicy

public void addToUncheckedPolicy(PermissionCollection permissions)
                          throws PolicyContextException
Used to add unchecked policy statements to this PolicyConfiguration.

Parameters:
permissions - the collection of permissions to be added as unchecked policy statements. The collection may be either a homogenous or heterogenous collection.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToUncheckedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToUncheckedPolicy

public void addToUncheckedPolicy(Permission permission)
                          throws PolicyContextException
Used to add a single unchecked policy statement to this PolicyConfiguration.

Parameters:
permission - the permission to be added to the unchecked policy statements.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToUncheckedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToExcludedPolicy

public void addToExcludedPolicy(PermissionCollection permissions)
                         throws PolicyContextException
Used to add excluded policy statements to this PolicyConfiguration.

Parameters:
permissions - the collection of permissions to be added to the excluded policy statements. The collection may be either a homogenous or heterogenous collection.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToExcludedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToExcludedPolicy

public void addToExcludedPolicy(Permission permission)
                         throws PolicyContextException
Used to add a single excluded policy statement to this PolicyConfiguration.

Parameters:
permission - the permission to be added to the excluded policy statements.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToExcludedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

removeRole

public void removeRole(String roleName)
                throws PolicyContextException
Used to remove a role and all its permissions from this PolicyConfiguration.

Parameters:
roleName - the name of the Role to remove from this PolicyConfiguration.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the removeRole method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

removeUncheckedPolicy

public void removeUncheckedPolicy()
                           throws PolicyContextException
Used to remove any unchecked policy statements from this PolicyConfiguration.

Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the removeUncheckedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

removeExcludedPolicy

public void removeExcludedPolicy()
                          throws PolicyContextException
Used to remove any excluded policy statements from this PolicyConfiguration.

Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the removeExcludedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

linkConfiguration

public void linkConfiguration(PolicyConfiguration link)
                       throws PolicyContextException
Creates a relationship between this configuration and another such that they share the same principal-to-role mappings. PolicyConfigurations are linked to apply a common principal-to-role mapping to multiple seperately manageable PolicyConfigurations, as is required when an application is composed of multiple modules.

Note that the policy statements which comprise a role, or comprise the excluded or unchecked policy collections in a PolicyConfiguration are unaffected by the configuration being linked to another.

Parameters:
link - a reference to a different PolicyConfiguration than this PolicyConfiguration.

The relationship formed by this method is symetric, transitive and idempotent. If the argument PolicyConfiguration does not have a different Policy context identifier than this PolicyConfiguration no relationship is formed, and an exception, as described below, is thrown.

Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
IllegalArgumentException - if called with an argument PolicyConfiguration whose Policy context is equivalent to that of this PolicyConfiguration.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the linkConfiguration method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

delete

public void delete()
            throws PolicyContextException
Causes all policy statements to be deleted from this PolicyConfiguration and sets its internal state such that calling any method, other than delete, getContextID, or inService on the PolicyConfiguration will be rejected and cause an UnsupportedOperationException to be thrown.

This operation has no affect on any linked PolicyConfigurations other than removing any links involving the deleted PolicyConfiguration.

Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the delete method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

commit

public void commit()
            throws PolicyContextException
This method is used to set to "inService" the state of the policy context whose interface is this PolicyConfiguration Object. Only those policy contexts whose state is "inService" will be included in the policy contexts processed by the Policy.refresh method. A policy context whose state is "inService" may be returned to the "open" state by calling the getPolicyConfiguration method of the PolicyConfiguration factory with the policy context identifier of the policy context.

When the state of a policy context is "inService", calling any method other than commit, delete, getContextID, or inService on its PolicyConfiguration Object will cause an UnsupportedOperationException to be thrown.

Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the commit method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

inService

public boolean inService()
                  throws PolicyContextException
This method is used to determine if the policy context whose interface is this PolicyConfiguration Object is in the "inService" state.

Returns:
true if the state of the associated policy context is "inService"; false otherwise.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the inService method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PolicyConfigurationFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class PolicyConfigurationFactory

java.lang.Object
    extended by javax.security.jacc.PolicyConfigurationFactory
public abstract class PolicyConfigurationFactory
extends Object

Abstract factory and finder class for obtaining the instance of the class that implements the PolicyConfigurationFactory of a provider. The factory will be used to instantiate PolicyConfiguration objects that will be used by the deployment tools of the container to create and manage policy contexts within the Policy Provider.

Implementation classes must have a public no argument constructor that may be used to create an operational instance of the factory implementation class.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison, Harpreet Singh
See Also:
Permission, PolicyConfiguration, PolicyContextException

Constructor Summary
PolicyConfigurationFactory()
Method Summary
abstract PolicyConfiguration | getPolicyConfiguration(String contextID, boolean remove) This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider.
static PolicyConfigurationFactory | getPolicyConfigurationFactory() This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class.
abstract boolean | inService(String contextID) This method determines if the identified policy context exists with state "inService" in the Policy provider associated with the factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PolicyConfigurationFactory

public PolicyConfigurationFactory()
Method Detail

getPolicyConfigurationFactory

public static PolicyConfigurationFactory getPolicyConfigurationFactory()
                                                                throws ClassNotFoundException,
                                                                       PolicyContextException
This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class. The name of the provider specific factory implementation class is obtained from the value of the system property,

     javax.security.jacc.PolicyConfigurationFactory.provider.

Returns:
the singleton instance of the provider specific PolicyConfigurationFactory implementation class.
Throws:
SecurityException - when called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
ClassNotFoundException - when the class named by the system property could not be found including because the value of the system property has not be set.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the getPolicyConfigurationFactory method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException

getPolicyConfiguration

public abstract PolicyConfiguration getPolicyConfiguration(String contextID,
                                                           boolean remove)
                                                    throws PolicyContextException
This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider. The methods of the PolicyConfiguration interface are used to define the policy statements of the identified policy context.

If at the time of the call, the identified policy context does not exist in the provider, then the policy context will be created in the provider and the Object that implements the context's PolicyConfiguration Interface will be returned. If the state of the identified context is "deleted" or "inService" it will be transitioned to the "open" state as a result of the call. The states in the lifecycle of a policy context are defined by the PolicyConfiguration interface.

For a given value of policy context identifier, this method must always return the same instance of PolicyConfiguration and there must be at most one actual instance of a PolicyConfiguration with a given policy context identifier (during a process context).

To preserve the invariant that there be at most one PolicyConfiguration object for a given policy context, it may be necessary for this method to be thread safe.

Parameters:
contextID - A String identifying the policy context whose PolicyConfiguration interface is to be returned. The value passed to this parameter must not be null.

remove - A boolean value that establishes whether or not the policy statements of an existing policy context are to be removed before its PolicyConfiguration object is returned. If the value passed to this parameter is true, the policy statements of an existing policy context will be removed. If the value is false, they will not be removed.
Returns:
an Object that implements the PolicyConfiguration Interface matched to the Policy provider and corresponding to the identified policy context.
Throws:
SecurityException - when called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the getPolicyConfiguration method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

inService

public abstract boolean inService(String contextID)
                           throws PolicyContextException
This method determines if the identified policy context exists with state "inService" in the Policy provider associated with the factory.

Parameters:
contextID - A string identifying a policy context
Returns:
true if the identified policy context exists within the provider and its state is "inService", false otherwise.
Throws:
SecurityException - when called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the inService method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PolicyContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class PolicyContext

java.lang.Object
    extended by javax.security.jacc.PolicyContext
public final class PolicyContext
extends Object

This utility class is used by containers to communicate policy context identifiers and other policy relevant context to Policy providers. Policy providers use the policy context identifier to select the subset of policy to apply in access decisions.

The value of a policy context identifier is a String and each thread has an independently established policy context identifier. A container will establish the thread-scoped value of a policy context identifier by calling the static setContextID method. The value of a thread-scoped policy context identifier is available (to Policy) by calling the static getContextID method.

This class is also used by Policy providers to request additional thread-scoped policy relevant context objects from the calling container. Containers register container-specific PolicyContext handlers using the static registerHandler method. Handler registration is scoped to the class, such that the same handler registrations are active in all thread contexts. Containers may use the static method setHandlerData to establish a thread-scoped parameter that will be passed to handlers when they are activated by Policy providers. The static getContext method is used to activate a handler and obtain the corresponding context object.

The static accessor functions provided by this class allow per-thread policy context values to be established and communicated independent of a common reference to a particular PolicyContext instance.

The PolicyContext class may encapsulate static ThreadLocal instance variables to represent the policy context identifier and handler data values.

The Application server must bundle or install the PolicyContext class, and the containers of the application server must prevent the methods of the PolicyContext class from being called from calling contexts that are not authorized to call these methods. With the exception of the getContextID and GetHandlerKeys methods, containers must restrict and afford access to the methods of the PolicyContext class to calling contexts trusted by the container to perform container access decisions. The PolicyContext class may satisfy this requirement (on behalf of its container) by rejecting calls made from an AccessControlContext that has not been granted the "setPolicy" SecurityPermission, and by ensuring that Policy providers used to perform container access decisions are granted the "setPolicy" permission.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison
See Also:
PolicyContextHandler

Method Summary
static Object | getContext(String key) This method may be used by a Policy provider to activate the PolicyContextHandler registered to the context object key and cause it to return the corresponding policy context object from the container.
static String | getContextID() This static method returns the value of the policy context identifier associated with the thread on which the accessor is called.
static Set | getHandlerKeys() This method may be used to obtain the keys that identify the container specific context handlers registered by the container.
static void | registerHandler(String key, PolicyContextHandler handler, boolean replace) Authorization protected method used to register a container specific PolicyContext handler.
static void | setContextID(String contextID) Authorization protected method used to modify the value of the policy context identifier associated with the thread on which this method is called.
static void | setHandlerData(Object data) Authorization protected method that may be used to associate a thread-scoped handler data object with the PolicyContext.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

setContextID

public static void setContextID(String contextID)
Authorization protected method used to modify the value of the policy context identifier associated with the thread on which this method is called.

Parameters:
contextID - a String that represents the value of the policy context identifier to be assigned to the PolicyContext for the calling thread. The value null is a legitimate value for this parameter.
Throws:
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.

getContextID

public static String getContextID()
This static method returns the value of the policy context identifier associated with the thread on which the accessor is called.

Returns:
The String (or null) policy context identifier established for the thread. This method must return the default policy context identifier, null, if the policy context identifier of the thread has not been set via setContext to another value.
Throws:
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method. Containers may choose to authorize calls to this method by any AccessControlContext.

setHandlerData

public static void setHandlerData(Object data)
Authorization protected method that may be used to associate a thread-scoped handler data object with the PolicyContext. The handler data object will be made available to handlers, where it can serve to supply or bind the handler to invocation scoped state within the container.

Parameters:
data - a container-specific object that will be associated with the calling thread and passed to any handler activated by a Policy provider (on the thread). The value null is a legitimate value for this parameter, and is the value that will be used in the activation of handlers if the setHandlerData has not been called on the thread.
Throws:
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.

registerHandler

public static void registerHandler(String key,
                                   PolicyContextHandler handler,
                                   boolean replace)
                            throws PolicyContextException
Authorization protected method used to register a container specific PolicyContext handler. A handler may be registered to handle multiple keys, but at any time, at most one handler may be registered for a key.

Parameters:
key - a (case-sensitive) String that identifies the context object handled by the handler. The value of this parameter must not be null.
handler - an object that implements the PolicyContextHandler interface. The value of this parameter must not be null.
replace - this boolean value defines the behavior of this method if, when it is called, a PolicyContextHandler has already been registered to handle the same key. In that case, and if the value of this argument is true, the existing handler is replaced with the argument handler. If the value of this parameter is false the existing registration is preserved and an exception is thrown.
Throws:
IllegalArgumentException - if the value of either of the handler or key arguments is null, or the value of the replace argument is false and a handler with the same key as the argument handler is already registered.
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.
PolicyContextException - if an operation by this method on the argument PolicyContextHandler causes it to throw a checked exception that is not accounted for in the signature of this method.

getHandlerKeys

public static Set getHandlerKeys()
This method may be used to obtain the keys that identify the container specific context handlers registered by the container.

Returns:
A Set, the elements of which, are the String key values that identify the handlers that have been registered and therefore may be activated on the PolicyContext.
Throws:
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method. Containers may choose to authorize calls to this method by any AccessControlContext.

getContext

public static Object getContext(String key)
                         throws PolicyContextException
This method may be used by a Policy provider to activate the PolicyContextHandler registered to the context object key and cause it to return the corresponding policy context object from the container. When this method activates a handler, it passes to the handler the context object key and the handler data associated with the calling thread.

Parameters:
key - a String that identifies the PolicyContextHandler to activate and the context object to be acquired from the handler. The value of this parameter must not be null.
Returns:
the container and handler specific object containing the desired context. A null value is returned if the corresponding handler has been registered, and the value of the corresponding context is null.
Throws:
IllegalArgumentException - if a PolicyContextHandler has not been registered for the key or the registered handler no longer supports the key.
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.
PolicyContextException - if an operation by this method on the identified PolicyContextHandler causes it to throw a checked exception that is not accounted for in the signature of this method.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PolicyContextException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class PolicyContextException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.security.jacc.PolicyContextException
All Implemented Interfaces:
Serializable
public class PolicyContextException
extends Exception

This checked exception is thrown by implementations of the javax.security.jacc.PolicyConfiguration Interface, the javax.security.jacc.PolicyConfigurationFactory abstract class, the javax.security.jacc.PolicyContext utility class, and implementations of the javax.security.jacc.PolicyContextException Interface.

This exception is used by javax.security.jacc implementation classes to rethrow checked exceptions ocurring within an implementation that are not declared by the interface or class being implemented.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison
See Also:
Exception, PolicyConfiguration, PolicyConfigurationFactory, PolicyContext, PolicyContextHandler, Serialized Form

Constructor Summary
PolicyContextException()
Constructs a new PolicyContextException with null as its detail message.
PolicyContextException(String msg)
Constructs a new PolicyContextException with the specified detail message
PolicyContextException(String msg, Throwable cause)
Constructs a new PolicyContextException with the specified detail message and cause.
PolicyContextException(Throwable cause)
Constructs a new PolicyContextException with the specified cause.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PolicyContextException

public PolicyContextException()
Constructs a new PolicyContextException with null as its detail message. describing the cause of the exception.

PolicyContextException

public PolicyContextException(String msg)
Constructs a new PolicyContextException with the specified detail message

Parameters:
msg - - a String containing a detail message describing the cause of the exception.

PolicyContextException

public PolicyContextException(String msg,
                              Throwable cause)
Constructs a new PolicyContextException with the specified detail message and cause. The cause will be encapsulated in the constructed exception.

Parameters:
msg - - a String containing a detail message describing the cause of the exception.
cause - - the Throwable that is "causing" this exception to be constructed. A null value is permitted, and the value passed through this parameter may subsequently be retrieved by calling getCause() on the constructed exception.

PolicyContextException

public PolicyContextException(Throwable cause)
Constructs a new PolicyContextException with the specified cause. The cause will be encapsulated in the constructed exception.

Parameters:
cause - - the Throwable that is "causing" this exception to be constructed. A null value is permitted, and the value passed through this parameter may subsequently be retrieved by calling getCause() on the constructed exception.
Overview  Package   Class  Tree  Deprecated  Index  Help
JavaTM 2 Platform
Ent. Ed. v1.4
 PREV CLASS   NEXT CLASS | FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PolicyContextHandler

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Interface PolicyContextHandler

public interface PolicyContextHandler

This interface defines the methods that must be implemented by handlers that are to be registered and activated by the PolicyContext class. The PolicyContext class provides methods for containers to register and activate container-specific PolicyContext handlers. Policy providers use the PolicyContext class to activate handlers to obtain (from the container) additional policy relevant context to apply in their access decisions. All handlers registered and activated via the PolicyContext class must implement the PolicyContextHandler interface.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison
See Also:
PolicyContext, PolicyContextException

Method Summary
Object | getContext(String key, Object data) This public method is used by the PolicyContext class to activate the handler and obtain from it the context object identified by the (case-sensitive) key.
String[] | getKeys() This public method returns the keys identifying the context objects supported by the handler.
boolean | supports(String key) This public method returns a boolean result indicating whether or not the handler supports the context object identified by the (case-sensitive) key value.

Method Detail

supports

public boolean supports(String key)
                 throws PolicyContextException
This public method returns a boolean result indicating whether or not the handler supports the context object identified by the (case-sensitive) key value.

Parameters:
key - a String value identifying a context object that could be supported by the handler. The value of this parameter must not be null.
Returns:
a boolean indicating whether or not the context object corresponding to the argument key is handled by the handler.
Throws:
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException

getKeys

public String[] getKeys()
                 throws PolicyContextException
This public method returns the keys identifying the context objects supported by the handler. The value of each key supported by a handler must be a non-null String value.

Returns:
an array containing String values identifing the context objects supported by the handler. The array must not contain duplicate key values. In the unlikely case that the Handler supports no keys, the handler must return a zero length array. The value null must never be returned by this method.
Throws:
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException

getContext

public Object getContext(String key,
                         Object data)
                  throws PolicyContextException
This public method is used by the PolicyContext class to activate the handler and obtain from it the context object identified by the (case-sensitive) key. In addition to the key, the handler will be activated with the handler data value associated within the PolicyContext class with the thread on which the call to this method is made.

Note that the policy context identifier associated with a thread is available to the handler by calling PolicyContext.getContextID().

Parameters:
key - a String that identifies the context object to be returned by the handler. The value of this paramter must not be null.
data - the handler data Object associated with the thread on which the call to this method has been made. Note that the value passed through this parameter may be null.
Returns:
The container and handler specific Object containing the desired context. A null value may be returned if the value of the corresponding context is null.
Throws:
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


WebResourcePermission

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class WebResourcePermission

java.lang.Object
    extended by java.security.Permission
        extended by javax.security.jacc.WebResourcePermission
All Implemented Interfaces:
Guard, Serializable
public final class WebResourcePermission
extends Permission
implements Serializable

Class for Servlet web resource permissions. A WebResourcePermission is a named permission and has actions.

The name of a WebResourcePermission (also referred to as the target name) identifies the Web resources to which the permission pertains.

Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, Serialized Form

Constructor Summary
WebResourcePermission(HttpServletRequest request)
Creates a new WebResourcePermission from the HttpServletRequest object.
WebResourcePermission(String name, String actions)
Creates a new WebResourcePermission with the specified name and actions.
WebResourcePermission(String urlPatternSpec, String[] HTTPMethods)
Creates a new WebResourcePermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods.
Method Summary
boolean | equals(Object o) Checks two WebResourcePermission objects for equality.
String | getActions() Returns a canonical String representation of the actions of this WebResourcePermission.
int | hashCode() Returns the hash code value for this WebResourcePermission.
boolean | implies(Permission permission) Determines if the argument Permission is "implied by" this WebResourcePermission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WebResourcePermission

public WebResourcePermission(String name,
                             String actions)
Creates a new WebResourcePermission with the specified name and actions.

The name contains a URLPatternSpec that identifies the web resources to which the permissions applies. The syntax of a URLPatternSpec is as follows:

          URLPatternList ::= URLPattern | URLPatternList colon URLPattern

          URLPatternSpec ::= null | URLPattern | URLPattern colon URLPatternList

A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor. The empty string is an exact URLPattern, and may occur anywhere in a URLPatternSpec that an exact URLPattern may occur. The first URLPattern in a URLPatternSpec may be any of the pattern types, exact, path-prefix, extension, or default as defined in the Java Servlet Specification). When a URLPatternSpec includes a URLPatternList, the patterns of the URLPatternList identify the resources to which the permission does NOT apply and depend on the pattern type and value of the first pattern as follows:

  • No pattern may exist in the URLPatternList that matches the first pattern.
  • If the first pattern is a path-prefix pattern, only exact patterns matched by the first pattern and path-prefix patterns matched by, but different from, the first pattern may occur in the URLPatternList.
  • If the first pattern is an extension pattern, only exact patterns that are matched by the first pattern and path-prefix patterns may occur in the URLPatternList.
  • If the first pattern is the default pattern, "/", any pattern except the default pattern may occur in the URLPatternList.
  • If the first pattern is an exact pattern a URLPatternList must not be present in the URLPatternSpec.

The actions parameter contains a comma seperated list of HTTP methods. The syntax of the actions parameter is defined as follows:

          HTTPMethod ::= "GET" | "POST" | "PUT" | "DELETE" | "HEAD" |
                   "OPTIONS" | "TRACE"

          HTTPMethodList ::= HTTPMethod | HTTPMethodList comma HTTPMethod

          HTTPMethodSpec ::= null | HTTPMethodList

If duplicates occur in the HTTPMethodSpec they must be eliminated by the permission constructor.

A null or empty string HTTPMethodSpec indicates that the permission applies to all HTTP methods at the resources identified by the URL pattern.

Parameters:
name - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor.

actions - identifies the HTTP methods to which the permission pertains. If the value passed through this parameter is null or the empty string, then the permission is constructed with actions corresponding to all the possible HTTP methods.

WebResourcePermission

public WebResourcePermission(String urlPatternSpec,
                             String[] HTTPMethods)
Creates a new WebResourcePermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods.

Parameters:
urlPatternSpec - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor.

HTTPMethods - an array of strings each element of which contains the value of an HTTP method. If the value passed through this parameter is null or is an array with no elements, then the permission is constructed with actions corresponding to all the possible HTTP methods.

WebResourcePermission

public WebResourcePermission(HttpServletRequest request)
Creates a new WebResourcePermission from the HttpServletRequest object.

Parameters:
request - the HttpServletRequest object corresponding to the Servlet operation to which the permission pertains. The permission name is the substring of the requestURI (HttpServletRequest.getRequestURI()) that begins after the contextPath (HttpServletRequest.getContextPath()). When the substring operation yields the string "/", the permission is constructed with the empty string as its name. The permission's actions field is obtained from HttpServletRequest.getMethod().
Method Detail

equals

public boolean equals(Object o)
Checks two WebResourcePermission objects for equality. WebResourcePermission objects are equivalent if their URLPatternSpec and (canonicalized) actions values are equivalent. The URLPatternSpec of a reference permission is equivalent to that of an argument permission if their first patterns are equivalent, and the patterns of the URLPatternList of the reference permission collectively match exactly the same set of patterns as are matched by the patterns of the URLPatternList of the argument permission.

Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

Parameters:
o - the WebResourcePermission object being tested for equality with this WebResourcePermission.

Returns:
true if the argument WebResourcePermission object is equivalent to this WebResourcePermission.

getActions

public String getActions()
Returns a canonical String representation of the actions of this WebResourcePermission. WebResourcePermission actions are canonicalized by sorting the HTTP methods into ascending lexical order. There may be no duplicate HTTP methods in the canonical form, and the canonical form of the set of all HTTP methods is the value null.

Returns:
a String containing the canonicalized actions of this WebResourcePermission (or the null value).

hashCode

public int hashCode()
Returns the hash code value for this WebResourcePermission. The properties of the returned hash code must be as follows:

  • During the lifetime of a Java application, the hashCode method must return the same integer value, every time it is called on a WebResourcePermission object. The value returned by hashCode for a particular WebResourcePermission need not remain consistent from one execution of an application to another.
  • If two WebResourcePermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

Returns:
the integer hash code value for this object.

implies

public boolean implies(Permission permission)
Determines if the argument Permission is "implied by" this WebResourcePermission. For this to be the case, all of the following must be true:

  • The argument is an instanceof WebResourcePermission
  • The first URLPattern in the name of the argument permission is matched by the first URLPattern in the name of this permission.
  • The first URLPattern in the name of the argument permission is NOT matched by any URLPattern in the URLPatternList of the URLPatternSpec of this permission.
  • If the first URLPattern in the name of the argument permission matches the first URLPattern in the URLPatternSpec of this permission, then every URLPattern in the URLPatternList of the URLPatternSpec of this permission is matched by a URLPattern in the URLPatternList of the argument permission.
  • The HTTP methods in the actions of the argument permission are a subset of the HTTP methods in the actions of this permission.

URLPattern matching is performed using the Servlet matching rules where two URL patterns match if they are related as follows:

  • their pattern values are String equivalent, or
  • this pattern is the path-prefix pattern "/*", or
  • this pattern is a path-prefix pattern (that is, it starts with "/" and ends with "/*") and the argument pattern starts with the substring of this pattern, minus its last 2 characters, and the next character of the argument pattern, if there is one, is "/", or
  • this pattern is an extension pattern (that is, it starts with "*.") and the argument pattern ends with this pattern, or
  • the reference pattern is the special default pattern, "/", which matches all argument patterns.

All of the comparisons described above are case sensitive.

Parameters:
permission - "this" WebResourcePermission is checked to see if it implies the argument permission.

Returns:
true if the specified permission is implied by this object, false if not.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


WebRoleRefPermission

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class WebRoleRefPermission

java.lang.Object
    extended by java.security.Permission
        extended by javax.security.jacc.WebRoleRefPermission
All Implemented Interfaces:
Guard, Serializable
public final class WebRoleRefPermission
extends Permission
implements Serializable

Class for Servlet isUserInRole (String reference) permissions. A WebRoleRefPermission is a named permission and has actions.

The name of an WebRoleRefPermission (also referred to as the target name) identifies a Web resource by the servlet name (in the deployment descriptor corresponding to the component from which the call to isUserInRole (String reference) is being made.

The actions of an WebRoleRefPermission identifies the role reference to which the permission applies. A WebRoleRefPermission is checked to determine if the subject is a member of the role identified by the reference.

Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, Serialized Form

Constructor Summary
WebRoleRefPermission(String name, String actions)
Creates a new WebRoleRefPermission with the specified name and actions.
Method Summary
boolean | equals(Object o) Checks two WebRoleRefPermission objects for equality.
String | getActions() Returns a canonical String representation of the actions of this WebRoleRefPermission.
int | hashCode() Returns the hash code value for this WebRoleRefPermission.
boolean | implies(Permission permission) Determines if the argument Permission is "implied by" this WebRoleRefPermission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WebRoleRefPermission

public WebRoleRefPermission(String name,
                            String actions)
Creates a new WebRoleRefPermission with the specified name and actions.

Parameters:
name - the servlet-name that identifies the application specific web resource in whose context the role references are to be evaluated.

actions - identifies the role reference to which the permission pertains. The role reference is scoped to the Web resource identified in the name parameter. The value of the role reference must not be null or the empty string.
Method Detail

equals

public boolean equals(Object o)
Checks two WebRoleRefPermission objects for equality. WebRoleRefPermission objects are equivalent if they have case equivalent name and actions values.

Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

The name and actions comparisons described above are case sensitive.

Parameters:
o - the WebRoleRefPermission object being tested for equality with this WebRoleRefPermission.
Returns:
true if the argument WebRoleRefPermission object is equivalent to this WebRoleRefPermission.

getActions

public String getActions()
Returns a canonical String representation of the actions of this WebRoleRefPermission.

Returns:
a String containing the canonicalized actions of this WebRoleRefPermission.

hashCode

public int hashCode()
Returns the hash code value for this WebRoleRefPermission. The properties of the returned hash code must be as follows:

  • During the lifetime of a Java application, the hashCode method must return the same integer value, every time it is called on a WebRoleRefPermission object. The value returned by hashCode for a particular WebRoleRefPermission need not remain consistent from one execution of an application to another.
  • If two WebRoleRefPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

Returns:
the integer hash code value for this object.

implies

public boolean implies(Permission permission)
Determines if the argument Permission is "implied by" this WebRoleRefPermission. For this to be the case,

  • The argument must be an instanceof WebRoleRefPermission
  • with name equivalent to this WebRoleRefPermission, and
  • with role reference equivalent to this WebRoleRefPermission (as defined in their actions).

The comparisons described above are case sensitive.

Parameters:
permission - "this" WebRoleRefPermission is checked to see if it implies the argument permission.

Returns:
true if the specified permission is implied by this object, false if not.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


WebUserDataPermission

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class WebUserDataPermission

java.lang.Object
    extended by java.security.Permission
        extended by javax.security.jacc.WebUserDataPermission
All Implemented Interfaces:
Guard, Serializable
public final class WebUserDataPermission
extends Permission
implements Serializable

Class for Servlet Web user data permissions. A WebUserDataPermission is a named permission and has actions.

The name of a WebUserDataPermission (also referred to as the target name) identifies a Web resource by its context path relative URL pattern.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, Serialized Form

Constructor Summary
WebUserDataPermission(HttpServletRequest request)
Creates a new WebUserDataPermission from the HttpServletRequest object.
WebUserDataPermission(String name, String actions)
Creates a new WebUserDataPermission with the specified name and actions.
WebUserDataPermission(String urlPatternSpec, String[] HTTPMethods, String transportType)
Creates a new WebUserDataPermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods and the transport type.
Method Summary
boolean | equals(Object o) Checks two WebUserDataPermission objects for equality.
String | getActions() Returns a canonical String representation of the actions of this WebUserDataPermission.
int | hashCode() Returns the hash code value for this WebUserDataPermission.
boolean | implies(Permission permission) Determines if the argument Permission is "implied by" this WebUserDataPermission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WebUserDataPermission

public WebUserDataPermission(String name,
                             String actions)
Creates a new WebUserDataPermission with the specified name and actions.

The name contains a URLPatternSpec that identifies the web resources to which the permissions applies. The syntax of a URLPatternSpec is as follows:

          URLPatternList ::= URLPattern | URLPatternList colon URLPattern

          URLPatternSpec ::= null | URLPattern | URLPattern colon URLPatternList

A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor. The empty string is an exact URLPattern, and may occur anywhere in a URLPatternSpec that an exact URLPattern may occur. The first URLPattern in a URLPatternSpec may be any of the pattern types, exact, path-prefix, extension, or default as defined in the Java Servlet Specification). When a URLPatternSpec includes a URLPatternList, the patterns of the URLPatternList identify the resources to which the permission does NOT apply and depend on the pattern type and value of the first pattern as follows:

  • No pattern may exist in the URLPatternList that matches the first pattern.
  • If the first pattern is a path-prefix pattern, only exact patterns matched by the first pattern and path-prefix patterns matched by, but different from, the first pattern may occur in the URLPatternList.
  • If the first pattern is an extension pattern, only exact patterns that are matched by the first pattern and path-prefix patterns may occur in the URLPatternList.
  • If the first pattern is the default pattern, "/", any pattern except the default pattern may occur in the URLPatternList.
  • If the first pattern is an exact pattern a URLPatternList must not be present in the URLPatternSpec.

The actions parameter contains a comma separated list of HTTP methods that may be followed by a transportType separated from the HTTP method by a colon.

          HTTPMethod ::= "Get" | "POST" | "PUT" | "DELETE" | "HEAD" |
                  "OPTIONS" | "TRACE"

          HTTPMethodList ::= HTTPMethod | HTTPMethodList comma HTTPMethod

          HTTPMethodSpec ::= emptyString | HTTPMethodList

          transportType ::= "INTEGRAL" | "CONFIDENTIAL" | "NONE"

          actions ::= null | HTTPMethodSpec |
                  HTTPMethodSpec colon transportType

If duplicates occur in the HTTPMethodSpec they must be eliminated by the permission constructor.

An empty string HTTPMethodSpec is a shorthand for a List containing all the possible HTTP methods.

An actions string without a transportType is a shorthand for a actions string with the value "NONE" as its TransportType.

A granted permission representing a transportType of "NONE", indicates that the associated resources may be accessed using any conection type.

Parameters:
name - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor.

actions - identifies the HTTP methods and transport type to which the permission pertains. If the value passed through this parameter is null or the empty string, then the permission is constructed with actions corresponding to all the possible HTTP methods and transportType "NONE".

WebUserDataPermission

public WebUserDataPermission(String urlPatternSpec,
                             String[] HTTPMethods,
                             String transportType)
Creates a new WebUserDataPermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods and the transport type.

Parameters:
urlPatternSpec - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor.

HTTPMethods - an array of strings each element of which contains the value of an HTTP method. If the value passed through this parameter is null or is an array with no elements, then the permission is constructed with actions containing all the possible HTTP methods.

transportType - a String whose value is a transportType. If the value passed through this parameter is null, then the permission is constructed with actions containing transportType "NONE".

WebUserDataPermission

public WebUserDataPermission(HttpServletRequest request)
Creates a new WebUserDataPermission from the HttpServletRequest object.

Parameters:
request - the HttpServletRequest object corresponding to the Servlet operation to which the permission pertains. The permission name is the substring of the requestURI (HttpServletRequest.getRequestURI()) that begins after the contextPath (HttpServletRequest.getContextPath()). When the substring operation yields the string "/", the permission is constructed with the empty string as its name. The HTTP method component of the permission's actions is as obtained from HttpServletRequest.getMethod(). The TransportType component of the permission's actions is determined by calling HttpServletRequest.isSecure().
Method Detail

equals

public boolean equals(Object o)
Checks two WebUserDataPermission objects for equality. WebUserDataPermission objects are equivalent if their URLPatternSpec and (canonicalized) actions values are equivalent. The URLPatternSpec of a reference permission is equivalent to that of an argument permission if their first patterns are equivalent, and the patterns of the URLPatternList of the reference permission collectively match exactly the same set of patterns as are matched by the patterns of the URLPatternList of the argument permission.

Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

Parameters:
o - the WebUserDataPermission object being tested for equality with this WebUserDataPermission.

Returns:
true if the argument WebUserDataPermission object is equivalent to this WebUserDataPermission.

getActions

public String getActions()
Returns a canonical String representation of the actions of this WebUserDataPermission. The canonical form of the actions of a WebUserDataPermission is described by the following syntax description.

          HTTPMethod ::= "Get" | "POST" | "PUT" | "DELETE" | "HEAD" |
                  "OPTIONS" | "TRACE"

          HTTPMethodList ::= HTTPMethod | HTTPMethodList comma HTTPMethod

          HTTPMethodSpec ::= emptyString | HTTPMethodList

          transportType ::= "INTEGRAL" | "CONFIDENTIAL" | "NONE"

          actions ::= null | HTTPMethodList |
                  HTTPMethodSpec colon transportType

If the permission's HTTP methods include the entire HTTP method set and the permission's transport type is "INTEGRAL" or "CONFIDENTIAL", the HTTP methods shall be represented in the canonical form by an empty string HTTPMethodSpec. If the permission's HTTP methods include the entire HTTP method set and the permission's transport type is not "INTEGRAL"or "CONFIDENTIAL", the canonical actions value shall be the null value. If the permission's methods do not include the entire HTTP method set, duplicates must be eliminated and the remaining elements must be sorted into ascending lexical order. The resulting HTTPMethodList must be included in the canonical form, and if the permission's transport type is not "INTEGRAL" or "CONFIDENTIAL", the canonical actions value must be exactly the resulting HTTPMethodList .

Returns:
a String containing the canonicalized actions of this WebUserDataPermission (or the null value).

hashCode

public int hashCode()
Returns the hash code value for this WebUserDataPermission. The properties of the returned hash code must be as follows:

  • During the lifetime of a Java application, the hashCode method shall return the same integer value every time it is called on a WebUserDataPermission object. The value returned by hashCode for a particular EJBMethod permission need not remain consistent from one execution of an application to another.
  • If two WebUserDataPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

Returns:
the integer hash code value for this object.

implies

public boolean implies(Permission permission)
Determines if the argument Permission is "implied by" this WebUserDataPermission. For this to be the case all of the following must be true:

  • The argument is an instanceof WebUserDataPermission.
  • The first URLPattern in the name of the argument permission is matched by the first URLPattern in the name of this permission.
  • The first URLPattern in the name of the argument permission is NOT matched by any URLPattern in the URLPatternList of the URLPatternSpec of this permission.
  • If the first URLPattern in the name of the argument permission matches the first URLPattern in the URLPatternSpec of this permission, then every URLPattern in the URLPatternList of the URLPatternSpec of this permission is matched by a URLPattern in the URLPatternList of the argument permission.
  • The HTTP methods in the actions of the argument permission are a subset of the HTTP methods in the actions of this permission.
  • The transportType in the actions of this permission either corresponds to the value "NONE", or equals the transportType in the actions of the argument permission.

URLPattern matching is performed using the Servlet matching rules where two URL patterns match if they are related as follows:

  • their pattern values are String equivalent, or
  • this pattern is the path-prefix pattern "/*", or
  • this pattern is a path-prefix pattern (that is, it starts with "/" and ends with "/*") and the argument pattern starts with the substring of this pattern, minus its last 2 characters, and the next character of the argument pattern, if there is one, is "/", or
  • this pattern is an extension pattern (that is, it starts with "*.") and the argument pattern ends with this pattern, or
  • the reference pattern is the special default pattern, "/", which matches all argument patterns.

All of the comparisons described above are case sensitive.

Parameters:
permission - "this" WebUserDataPermission is checked to see if it implies the argument permission.

Returns:
true if the specified permission is implied by this object, false if not.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


servlet

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.servlet

The javax.servlet package contains a number of classes and interfaces that describe and define the contr acts between a servlet class and the runtime environment provided for an insta nce of such a class by a conforming servlet container.

See:
Description

Interface Summary
Filter | A filter is an object that performs filtering tasks on either the request to a resource (a servlet or static content), or on the response from a resource, or both.
FilterChain | A FilterChain is an object provided by the servlet container to the developer giving a view into the invocation chain of a filtered request for a resource.
FilterConfig | A filter configuration object used by a servlet container to pass information to a filter during initialization.
RequestDispatcher | Defines an object that receives requests from the client and sends them to any resource (such as a servlet, HTML file, or JSP file) on the server.
Servlet | Defines methods that all servlets must implement.
ServletConfig | A servlet configuration object used by a servlet container to pass information to a servlet during initialization.
ServletContext | Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.
ServletContextAttributeListener | Implementations of this interface recieve notifications of changes to the attribute list on the servlet context of a web application.
ServletContextListener | Implementations of this interface recieve notifications about changes to the servlet context of the web application they are part of.
ServletRequest | Defines an object to provide client request information to a servlet.
ServletRequestAttributeListener | Implementations of this interface receive notifications of changes to the attribute list on the servlet request of a web application.
ServletRequestListener | Implementations of this interface recieve notifications about changes to the servlet request of the web application they are part of.
ServletResponse | Defines an object to assist a servlet in sending a response to the client.
SingleThreadModel | Deprecated. As of Java Servlet API 2.4, with no direct replacement.

Class Summary
GenericServlet | Defines a generic, protocol-independent servlet.
ServletContextAttributeEvent | This is the event class for notifications about changes to the attributes of the servlet context of a web application.
ServletContextEvent | This is the event class for notifications about changes to the servlet context of a web application.
ServletInputStream | Provides an input stream for reading binary data from a client request, including an efficient readLine method for reading data one line at a time.
ServletOutputStream | Provides an output stream for sending binary data to the client.
ServletRequestAttributeEvent | This is the event class for notifications about changes to the attributes of the servlet request of a web application.
ServletRequestEvent | This is the event class for notifications about changes to the servlet request of a web application.
ServletRequestWrapper | Provides a convenient implementation of the ServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
ServletResponseWrapper | Provides a convenient implementation of the ServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.

Exception Summary
ServletException | Defines a general exception a servlet can throw when it encounters difficulty.
UnavailableException | Defines an exception that a servlet or filter throws to indicate that it is permanently or temporarily unavailable.

Package javax.servlet Description

The javax.servlet package contains a number of classes and interfaces that describe and define the contr acts between a servlet class and the runtime environment provided for an insta nce of such a class by a conforming servlet container.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.servlet Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.servlet

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.servlet.ServletContextEvent
        • class javax.servlet.ServletContextAttributeEvent
      • class javax.servlet.ServletRequestEvent
        • class javax.servlet.ServletRequestAttributeEvent
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
    • class java.io.InputStream
      • class javax.servlet.ServletInputStream
    • class java.io.OutputStream
      • class javax.servlet.ServletOutputStream
    • class javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
    • class javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.ServletException
          • class javax.servlet.UnavailableException

Interface Hierarchy

  • interface java.util.EventListener
    • interface javax.servlet.ServletContextAttributeListener
    • interface javax.servlet.ServletContextListener
    • interface javax.servlet.ServletRequestAttributeListener
    • interface javax.servlet.ServletRequestListener
  • interface javax.servlet.Filter
  • interface javax.servlet.FilterChain
  • interface javax.servlet.FilterConfig
  • interface javax.servlet.RequestDispatcher
  • interface javax.servlet.Servlet
  • interface javax.servlet.ServletConfig
  • interface javax.servlet.ServletContext
  • interface javax.servlet.ServletRequest
  • interface javax.servlet.ServletResponse
  • interface javax.servlet.SingleThreadModel
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SingleThreadModel

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface SingleThreadModel

Deprecated. As of Java Servlet API 2.4, with no direct replacement.

public interface SingleThreadModel

Ensures that servlets handle only one request at a time. This interface has no methods.

If a servlet implements this interface, you are guaranteed that no two threads will execute concurrently in the servlet's service method. The servlet container can make this guarantee by synchronizing access to a single instance of the servlet, or by maintaining a pool of servlet instances and dispatching each new request to a free servlet.

Note that SingleThreadModel does not solve all thread safety issues. For example, session attributes and static variables can still be accessed by multiple requests on multiple threads at the same time, even when SingleThreadModel servlets are used. It is recommended that a developer take other means to resolve those issues instead of implementing this interface, such as avoiding the usage of an instance variable or synchronizing the block of the code accessing those resources. This interface is deprecated in Servlet API version 2.4.

Version:
$Version$
Author:
Various

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Filter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface Filter

public interface Filter

A filter is an object that performs filtering tasks on either the request to a resource (a servlet or static content), or on the response from a resource, or both.

Filters perform filtering in the doFilter method. Every Filter has access to a FilterConfig object from which it can obtain its initialization parameters, a reference to the ServletContext which it can use, for example, to load resources needed for filtering tasks.

Filters are configured in the deployment descriptor of a web application

Examples that have been identified for this design are
1) Authentication Filters
2) Logging and Auditing Filters
3) Image conversion Filters
4) Data compression Filters
5) Encryption Filters
6) Tokenizing Filters
7) Filters that trigger resource access events
8) XSL/T filters
9) Mime-type chain Filter

Since:
Servlet 2.3

Method Summary
void | destroy() Called by the web container to indicate to a filter that it is being taken out of service.
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain.
void | init(FilterConfig filterConfig) Called by the web container to indicate to a filter that it is being placed into service.

Method Detail

init

public void init(FilterConfig filterConfig)
          throws ServletException
Called by the web container to indicate to a filter that it is being placed into service. The servlet container calls the init method exactly once after instantiating the filter. The init method must complete successfully before the filter is asked to do any filtering work.

The web container cannot place the filter into service if the init method either
1.Throws a ServletException
2.Does not return within a time period defined by the web container

Throws:
ServletException

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws IOException,
                     ServletException
The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain. The FilterChain passed in to this method allows the Filter to pass on the request and response to the next entity in the chain.

A typical implementation of this method would follow the following pattern:-
1. Examine the request
2. Optionally wrap the request object with a custom implementation to filter content or headers for input filtering
3. Optionally wrap the response object with a custom implementation to filter content or headers for output filtering
4. a) Either invoke the next entity in the chain using the FilterChain object (chain.doFilter()),
4. b) or not pass on the request/response pair to the next entity in the filter chain to block the request processing
5. Directly set headers on the response after invocation of the next entity in ther filter chain.

Throws:
IOException
ServletException

destroy

public void destroy()
Called by the web container to indicate to a filter that it is being taken out of service. This method is only called once all threads within the filter's doFilter method have exited or after a timeout period has passed. After the web container calls this method, it will not call the doFilter method again on this instance of the filter.

This method gives the filter an opportunity to clean up any resources that are being held (for example, memory, file handles, threads) and make sure that any persistent state is synchronized with the filter's current state in memory.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FilterChain

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface FilterChain

public interface FilterChain

A FilterChain is an object provided by the servlet container to the developer giving a view into the invocation chain of a filtered request for a resource. Filters use the FilterChain to invoke the next filter in the chain, or if the calling filter is the last filter in the chain, to invoke the rosource at the end of the chain.

Since:
Servlet 2.3
See Also:
Filter

Method Summary
 void doFilter(ServletRequest request, ServletResponse response)
Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.

Method Detail

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response)
              throws IOException,
                     ServletException
Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.

Parameters:
request - the request to pass along the chain.
response - the response to pass along the chain.
Throws:
IOException
ServletException
Since:
2.3
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FilterConfig

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface FilterConfig

public interface FilterConfig

A filter configuration object used by a servlet container to pass information to a filter during initialization.

Since:
Servlet 2.3
See Also:
Filter

Method Summary
String | getFilterName() Returns the filter-name of this filter as defined in the deployment descriptor.
String | getInitParameter(String name) Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
Enumeration | getInitParameterNames() Returns the names of the filter's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the filter has no initialization parameters.
ServletContext | getServletContext() Returns a reference to the ServletContext in which the caller is executing.

Method Detail

getFilterName

public String getFilterName()
Returns the filter-name of this filter as defined in the deployment descriptor.

getServletContext

public ServletContext getServletContext()
Returns a reference to the ServletContext in which the caller is executing.

Returns:
a ServletContext object, used by the caller to interact with its servlet container
See Also:
ServletContext

getInitParameter

public String getInitParameter(String name)
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.

Parameters:
name - a String specifying the name of the initialization parameter
Returns:
a String containing the value of the initialization parameter

getInitParameterNames

public Enumeration getInitParameterNames()
Returns the names of the filter's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the filter has no initialization parameters.

Returns:
an Enumeration of String objects containing the names of the filter's initialization parameters
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


GenericServlet

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class GenericServlet

java.lang.Object
    extended by javax.servlet.GenericServlet
All Implemented Interfaces:
Serializable, Servlet, ServletConfig
Direct Known Subclasses:
HttpServlet
public abstract class GenericServlet
extends Object
implements Servlet, ServletConfig, Serializable

Defines a generic, protocol-independent servlet. To write an HTTP servlet for use on the Web, extend HttpServlet instead.

GenericServlet implements the Servlet and ServletConfig interfaces. GenericServlet may be directly extended by a servlet, although it's more common to extend a protocol-specific subclass such as HttpServlet.

GenericServlet makes writing servlets easier. It provides simple versions of the lifecycle methods init and destroy and of the methods in the ServletConfig interface. GenericServlet also implements the log method, declared in the ServletContext interface.

To write a generic servlet, you need only override the abstract service method.

Version:
$Version$
Author:
Various
See Also:
Serialized Form

Constructor Summary
GenericServlet()
Does nothing.
Method Summary
 void destroy()
Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.
 String getInitParameter(String name)
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
 Enumeration getInitParameterNames()
Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
 ServletConfig getServletConfig()
Returns this servlet's ServletConfig object.
 ServletContext getServletContext()
Returns a reference to the ServletContext in which this servlet is running.
 String getServletInfo()
Returns information about the servlet, such as author, version, and copyright.
 String getServletName()
Returns the name of this servlet instance.
 void init()
A convenience method which can be overridden so that there's no need to call super.init(config).
 void init(ServletConfig config)
Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
 void log(String msg)
Writes the specified message to a servlet log file, prepended by the servlet's name.
 void log(String message, Throwable t)
Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file, prepended by the servlet's name.
abstract  void service(ServletRequest req, ServletResponse res)
Called by the servlet container to allow the servlet to respond to a request.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GenericServlet

public GenericServlet()
Does nothing. All of the servlet initialization is done by one of the init methods.

Method Detail

destroy

public void destroy()
Called by the servlet container to indicate to a servlet that the servlet is being taken out of service. See Servlet.destroy().

Specified by:
destroy in interface Servlet

getInitParameter

public String getInitParameter(String name)
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist. See ServletConfig.getInitParameter(java.lang.String).

This method is supplied for convenience. It gets the value of the named parameter from the servlet's ServletConfig object.

Specified by:
getInitParameter in interface ServletConfig
Parameters:
name - a String specifying the name of the initialization parameter
Returns:
String a String containing the value of the initalization parameter

getInitParameterNames

public Enumeration getInitParameterNames()
Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters. See ServletConfig.getInitParameterNames().

This method is supplied for convenience. It gets the parameter names from the servlet's ServletConfig object.

Specified by:
getInitParameterNames in interface ServletConfig
Returns:
Enumeration an enumeration of String objects containing the names of the servlet's initialization parameters

getServletConfig

public ServletConfig getServletConfig()
Returns this servlet's ServletConfig object.

Specified by:
getServletConfig in interface Servlet
Returns:
ServletConfig the ServletConfig object that initialized this servlet
See Also:
Servlet.init(javax.servlet.ServletConfig)

getServletContext

public ServletContext getServletContext()
Returns a reference to the ServletContext in which this servlet is running. See ServletConfig.getServletContext().

This method is supplied for convenience. It gets the context from the servlet's ServletConfig object.

Specified by:
getServletContext in interface ServletConfig
Returns:
ServletContext the ServletContext object passed to this servlet by the init method
See Also:
ServletContext

getServletInfo

public String getServletInfo()
Returns information about the servlet, such as author, version, and copyright. By default, this method returns an empty string. Override this method to have it return a meaningful value. See Servlet.getServletInfo().

Specified by:
getServletInfo in interface Servlet
Returns:
String information about this servlet, by default an empty string

init

public void init(ServletConfig config)
          throws ServletException
Called by the servlet container to indicate to a servlet that the servlet is being placed into service. See Servlet.init(javax.servlet.ServletConfig).

This implementation stores the ServletConfig object it receives from the servlet container for later use. When overriding this form of the method, call super.init(config).

Specified by:
init in interface Servlet
Parameters:
config - the ServletConfig object that contains configutation information for this servlet
Throws:
ServletException - if an exception occurs that interrupts the servlet's normal operation
See Also:
UnavailableException

init

public void init()
          throws ServletException
A convenience method which can be overridden so that there's no need to call super.init(config).

Instead of overriding init(ServletConfig), simply override this method and it will be called by GenericServlet.init(ServletConfig config). The ServletConfig object can still be retrieved via getServletConfig().

Throws:
ServletException - if an exception occurs that interrupts the servlet's normal operation

log

public void log(String msg)
Writes the specified message to a servlet log file, prepended by the servlet's name. See ServletContext.log(String).

Parameters:
msg - a String specifying the message to be written to the log file

log

public void log(String message,
                Throwable t)
Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file, prepended by the servlet's name. See ServletContext.log(String, Throwable).

Parameters:
message - a String that describes the error or exception
t - the java.lang.Throwable error or exception

service

public abstract void service(ServletRequest req,
                             ServletResponse res)
                      throws ServletException,
                             IOException
Called by the servlet container to allow the servlet to respond to a request. See Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse).

This method is declared abstract so subclasses, such as HttpServlet, must override it.

Specified by:
service in interface Servlet
Parameters:
req - the ServletRequest object that contains the client's request
res - the ServletResponse object that will contain the servlet's response
Throws:
ServletException - if an exception occurs that interferes with the servlet's normal operation occurred
IOException - if an input or output exception occurs

getServletName

public String getServletName()
Returns the name of this servlet instance. See ServletConfig.getServletName().

Specified by:
getServletName in interface ServletConfig
Returns:
the name of this servlet instance
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


http

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.servlet.http

The javax.servlet.http package contains a number of classes and interfaces that describe and define the contr acts between a servlet class running under the HTTP protocol and the runtime e nvironment provided for an instance of such a class by a conforming servlet co ntainer.

See:
Description

Interface Summary
HttpServletRequest | Extends the ServletRequest interface to provide request information for HTTP servlets.
HttpServletResponse | Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response.
HttpSession | Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.
HttpSessionActivationListener | Objects that are bound to a session may listen to container events notifying them that sessions will be passivated and that session will be activated.
HttpSessionAttributeListener | This listener interface can be implemented in order to get notifications of changes to the attribute lists of sessions within this web application.
HttpSessionBindingListener | Causes an object to be notified when it is bound to or unbound from a session.
HttpSessionContext | Deprecated. As of Java(tm) Servlet API 2.1 for security reasons, with no replacement.
HttpSessionListener | Implementations of this interface are notified of changes to the list of active sessions in a web application.

Class Summary
Cookie | Creates a cookie, a small amount of information sent by a servlet to a Web browser, saved by the browser, and later sent back to the server.
HttpServlet | Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site.
HttpServletRequestWrapper | Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
HttpServletResponseWrapper | Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
HttpSessionBindingEvent | Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.
HttpSessionEvent | This is the class representing event notifications for changes to sessions within a web application.
HttpUtils | Deprecated. As of Java(tm) Servlet API 2.3.

Package javax.servlet.http Description

The javax.servlet.http package contains a number of classes and interfaces that describe and define the contr acts between a servlet class running under the HTTP protocol and the runtime e nvironment provided for an instance of such a class by a conforming servlet co ntainer.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.servlet.http Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.servlet.http

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.servlet.http.Cookie (implements java.lang.Cloneable)
    • class java.util.EventObject (implements java.io.Serializable)
      • class javax.servlet.http.HttpSessionEvent
        • class javax.servlet.http.HttpSessionBindingEvent
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
    • class javax.servlet.http.HttpUtils
    • class javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • class javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
    • class javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • class javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)

Interface Hierarchy

  • interface java.util.EventListener
    • interface javax.servlet.http.HttpSessionActivationListener
    • interface javax.servlet.http.HttpSessionAttributeListener
    • interface javax.servlet.http.HttpSessionBindingListener
    • interface javax.servlet.http.HttpSessionListener
  • interface javax.servlet.http.HttpSession
  • interface javax.servlet.http.HttpSessionContext
  • interface javax.servlet.ServletRequest
    • interface javax.servlet.http.HttpServletRequest
  • interface javax.servlet.ServletResponse
    • interface javax.servlet.http.HttpServletResponse
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Cookie

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class Cookie

java.lang.Object
    extended by javax.servlet.http.Cookie
All Implemented Interfaces:
Cloneable
public class Cookie
extends Object
implements Cloneable

Creates a cookie, a small amount of information sent by a servlet to a Web browser, saved by the browser, and later sent back to the server. A cookie's value can uniquely identify a client, so cookies are commonly used for session management.

A cookie has a name, a single value, and optional attributes such as a comment, path and domain qualifiers, a maximum age, and a version number. Some Web browsers have bugs in how they handle the optional attributes, so use them sparingly to improve the interoperability of your servlets.

The servlet sends cookies to the browser by using the HttpServletResponse.addCookie(javax.servlet.http.Cookie) method, which adds fields to HTTP response headers to send cookies to the browser, one at a time. The browser is expected to support 20 cookies for each Web server, 300 cookies total, and may limit cookie size to 4 KB each.

The browser returns cookies to the servlet by adding fields to HTTP request headers. Cookies can be retrieved from a request by using the HttpServletRequest.getCookies() method. Several cookies might have the same name but different path attributes.

Cookies affect the caching of the Web pages that use them. HTTP 1.0 does not cache pages that use cookies created with this class. This class does not support the cache control defined with HTTP 1.1.

This class supports both the Version 0 (by Netscape) and Version 1 (by RFC 2109) cookie specifications. By default, cookies are created using Version 0 to ensure the best interoperability.

Version:
$Version$
Author:
Various

Constructor Summary
Cookie(String name, String value)
Constructs a cookie with a specified name and value.
Method Summary
Object | clone() Overrides the standard java.lang.Object.clone method to return a copy of this cookie.
String | getComment() Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.
String | getDomain() Returns the domain name set for this cookie.
int | getMaxAge() Returns the maximum age of the cookie, specified in seconds, By default, -1 indicating the cookie will persist until browser shutdown.
String | getName() Returns the name of the cookie.
String | getPath() Returns the path on the server to which the browser returns this cookie.
boolean | getSecure() Returns true if the browser is sending cookies only over a secure protocol, or false if the browser can send cookies using any protocol.
String | getValue() Returns the value of the cookie.
int | getVersion() Returns the version of the protocol this cookie complies with.
void | setComment(String purpose) Specifies a comment that describes a cookie's purpose.
void | setDomain(String pattern) Specifies the domain within which this cookie should be presented.
void | setMaxAge(int expiry) Sets the maximum age of the cookie in seconds.
void | setPath(String uri) Specifies a path for the cookie to which the client should return the cookie.
void | setSecure(boolean flag) Indicates to the browser whether the cookie should only be sent using a secure protocol, such as HTTPS or SSL.
void | setValue(String newValue) Assigns a new value to a cookie after the cookie is created.
void | setVersion(int v) Sets the version of the cookie protocol this cookie complies with.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Cookie

public Cookie(String name,
              String value)
Constructs a cookie with a specified name and value.

The name must conform to RFC 2109. That means it can contain only ASCII alphanumeric characters and cannot contain commas, semicolons, or white space or begin with a $ character. The cookie's name cannot be changed after creation.

The value can be anything the server chooses to send. Its value is probably of interest only to the server. The cookie's value can be changed after creation with the setValue method.

By default, cookies are created according to the Netscape cookie specification. The version can be changed with the setVersion method.

Parameters:
name - a String specifying the name of the cookie
value - a String specifying the value of the cookie
Throws:
IllegalArgumentException - if the cookie name contains illegal characters (for example, a comma, space, or semicolon) or it is one of the tokens reserved for use by the cookie protocol
See Also:
setValue(java.lang.String), setVersion(int)
Method Detail

setComment

public void setComment(String purpose)
Specifies a comment that describes a cookie's purpose. The comment is useful if the browser presents the cookie to the user. Comments are not supported by Netscape Version 0 cookies.

Parameters:
purpose - a String specifying the comment to display to the user
See Also:
getComment()

getComment

public String getComment()
Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.

Returns:
a String containing the comment, or null if none
See Also:
setComment(java.lang.String)

setDomain

public void setDomain(String pattern)
Specifies the domain within which this cookie should be presented.

The form of the domain name is specified by RFC 2109. A domain name begins with a dot (.foo.com) and means that the cookie is visible to servers in a specified Domain Name System (DNS) zone (for example, www.foo.com, but not a.b.foo.com). By default, cookies are only returned to the server that sent them.

Parameters:
pattern - a String containing the domain name within which this cookie is visible; form is according to RFC 2109
See Also:
getDomain()

getDomain

public String getDomain()
Returns the domain name set for this cookie. The form of the domain name is set by RFC 2109.

Returns:
a String containing the domain name
See Also:
setDomain(java.lang.String)

setMaxAge

public void setMaxAge(int expiry)
Sets the maximum age of the cookie in seconds.

A positive value indicates that the cookie will expire after that many seconds have passed. Note that the value is the maximum age when the cookie will expire, not the cookie's current age.

A negative value means that the cookie is not stored persistently and will be deleted when the Web browser exits. A zero value causes the cookie to be deleted.

Parameters:
expiry - an integer specifying the maximum age of the cookie in seconds; if negative, means the cookie is not stored; if zero, deletes the cookie
See Also:
getMaxAge()

getMaxAge

public int getMaxAge()
Returns the maximum age of the cookie, specified in seconds, By default, -1 indicating the cookie will persist until browser shutdown.

Returns:
an integer specifying the maximum age of the cookie in seconds; if negative, means the cookie persists until browser shutdown
See Also:
setMaxAge(int)

setPath

public void setPath(String uri)
Specifies a path for the cookie to which the client should return the cookie.

The cookie is visible to all the pages in the directory you specify, and all the pages in that directory's subdirectories. A cookie's path must include the servlet that set the cookie, for example, /catalog, which makes the cookie visible to all directories on the server under /catalog.

Consult RFC 2109 (available on the Internet) for more information on setting path names for cookies.

Parameters:
uri - a String specifying a path
See Also:
getPath()

getPath

public String getPath()
Returns the path on the server to which the browser returns this cookie. The cookie is visible to all subpaths on the server.

Returns:
a String specifying a path that contains a servlet name, for example, /catalog
See Also:
setPath(java.lang.String)

setSecure

public void setSecure(boolean flag)
Indicates to the browser whether the cookie should only be sent using a secure protocol, such as HTTPS or SSL.

The default value is false.

Parameters:
flag - if true, sends the cookie from the browser to the server only when using a secure protocol; if false, sent on any protocol
See Also:
getSecure()

getSecure

public boolean getSecure()
Returns true if the browser is sending cookies only over a secure protocol, or false if the browser can send cookies using any protocol.

Returns:
true if the browser uses a secure protocol; otherwise, true
See Also:
setSecure(boolean)

getName

public String getName()
Returns the name of the cookie. The name cannot be changed after creation.

Returns:
a String specifying the cookie's name

setValue

public void setValue(String newValue)
Assigns a new value to a cookie after the cookie is created. If you use a binary value, you may want to use BASE64 encoding.

With Version 0 cookies, values should not contain white space, brackets, parentheses, equals signs, commas, double quotes, slashes, question marks, at signs, colons, and semicolons. Empty values may not behave the same way on all browsers.

Parameters:
newValue - a String specifying the new value
See Also:
getValue(), Cookie

getValue

public String getValue()
Returns the value of the cookie.

Returns:
a String containing the cookie's present value
See Also:
setValue(java.lang.String), Cookie

getVersion

public int getVersion()
Returns the version of the protocol this cookie complies with. Version 1 complies with RFC 2109, and version 0 complies with the original cookie specification drafted by Netscape. Cookies provided by a browser use and identify the browser's cookie version.

Returns:
0 if the cookie complies with the original Netscape specification; 1 if the cookie complies with RFC 2109
See Also:
setVersion(int)

setVersion

public void setVersion(int v)
Sets the version of the cookie protocol this cookie complies with. Version 0 complies with the original Netscape cookie specification. Version 1 complies with RFC 2109.

Since RFC 2109 is still somewhat new, consider version 1 as experimental; do not use it yet on production sites.

Parameters:
v - 0 if the cookie should comply with the original Netscape specification; 1 if the cookie should comply with RFC 2109
See Also:
getVersion()

clone

public Object clone()
Overrides the standard java.lang.Object.clone method to return a copy of this cookie.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpServlet

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpServlet

java.lang.Object
    extended by javax.servlet.GenericServlet
        extended by javax.servlet.http.HttpServlet
All Implemented Interfaces:
Serializable, Servlet, ServletConfig
public abstract class HttpServlet
extends GenericServlet
implements Serializable

Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site. A subclass of HttpServlet must override at least one method, usually one of these:

  • doGet, if the servlet supports HTTP GET requests
  • doPost, for HTTP POST requests
  • doPut, for HTTP PUT requests
  • doDelete, for HTTP DELETE requests
  • init and destroy, to manage resources that are held for the life of the servlet
  • getServletInfo, which the servlet uses to provide information about itself

There's almost no reason to override the service method. service handles standard HTTP requests by dispatching them to the handler methods for each HTTP request type (the do XXX methods listed above).

Likewise, there's almost no reason to override the doOptions and doTrace methods.

Servlets typically run on multithreaded servers, so be aware that a servlet must handle concurrent requests and be careful to synchronize access to shared resources. Shared resources include in-memory data such as instance or class variables and external objects such as files, database connections, and network connections. See the Java Tutorial on Multithreaded Programming for more information on handling multiple threads in a Java program.

Version:
$Version$
Author:
Various
See Also:
Serialized Form

Constructor Summary
HttpServlet()
Does nothing, because this is an abstract class.
Method Summary
protected void | doDelete(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a DELETE request.
protected void | doGet(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a GET request.
protected void | doHead(HttpServletRequest req, HttpServletResponse resp) Receives an HTTP HEAD request from the protected service method and handles the request.
protected void | doOptions(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a OPTIONS request.
protected void | doPost(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a POST request.
protected void | doPut(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a PUT request.
protected void | doTrace(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a TRACE request.
protected long | getLastModified(HttpServletRequest req) Returns the time the HttpServletRequest object was last modified, in milliseconds since midnight January 1, 1970 GMT.
protected void | service(HttpServletRequest req, HttpServletResponse resp) Receives standard HTTP requests from the public service method and dispatches them to the do XXX methods defined in this class.
void | service(ServletRequest req, ServletResponse res) Dispatches client requests to the protected service method.
Methods inherited from class javax.servlet.GenericServlet
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, init, log, log
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HttpServlet

public HttpServlet()
Does nothing, because this is an abstract class.

Method Detail

doGet

protected void doGet(HttpServletRequest req,
                     HttpServletResponse resp)
              throws ServletException,
                     IOException
Called by the server (via the service method) to allow a servlet to handle a GET request.

Overriding this method to support a GET request also automatically supports an HTTP HEAD request. A HEAD request is a GET request that returns no body in the response, only the request header fields.

When overriding this method, read the request data, write the response headers, get the response's writer or output stream object, and finally, write the response data. It's best to include content type and encoding. When using a PrintWriter object to return the response, set the content type before accessing the PrintWriter object.

The servlet container must write the headers before committing the response, because in HTTP the headers must be sent before the response body.

Where possible, set the Content-Length header (with the ServletResponse.setContentLength(int) method), to allow the servlet container to use a persistent connection to return its response to the client, improving performance. The content length is automatically set if the entire response fits inside the response buffer.

When using HTTP 1.1 chunked encoding (which means that the response has a Transfer-Encoding header), do not set the Content-Length header.

The GET method should be safe, that is, without any side effects for which users are held responsible. For example, most form queries have no side effects. If a client request is intended to change stored data, the request should use some other HTTP method.

The GET method should also be idempotent, meaning that it can be safely repeated. Sometimes making a method safe also makes it idempotent. For example, repeating queries is both safe and idempotent, but buying a product online or modifying data is neither safe nor idempotent.

If the request is incorrectly formatted, doGet returns an HTTP "Bad Request" message.

Parameters:
req - an HttpServletRequest object that contains the request the client has made of the servlet
resp - an HttpServletResponse object that contains the response the servlet sends to the client
Throws:
IOException - if an input or output error is detected when the servlet handles the GET request
ServletException - if the request for the GET could not be handled
See Also:
ServletResponse.setContentType(java.lang.String)

getLastModified

protected long getLastModified(HttpServletRequest req)
Returns the time the HttpServletRequest object was last modified, in milliseconds since midnight January 1, 1970 GMT. If the time is unknown, this method returns a negative number (the default).

Servlets that support HTTP GET requests and can quickly determine their last modification time should override this method. This makes browser and proxy caches work more effectively, reducing the load on server and network resources.

Parameters:
req - the HttpServletRequest object that is sent to the servlet
Returns:
a long integer specifying the time the HttpServletRequest object was last modified, in milliseconds since midnight, January 1, 1970 GMT, or -1 if the time is not known

doHead

protected void doHead(HttpServletRequest req,
                      HttpServletResponse resp)
               throws ServletException,
                      IOException

Receives an HTTP HEAD request from the protected service method and handles the request. The client sends a HEAD request when it wants to see only the headers of a response, such as Content-Type or Content-Length. The HTTP HEAD method counts the output bytes in the response to set the Content-Length header accurately.

If you override this method, you can avoid computing the response body and just set the response headers directly to improve performance. Make sure that the doHead method you write is both safe and idempotent (that is, protects itself from being called multiple times for one HTTP HEAD request).

If the HTTP HEAD request is incorrectly formatted, doHead returns an HTTP "Bad Request" message.

Parameters:
req - the request object that is passed to the servlet
resp - the response object that the servlet uses to return the headers to the clien
Throws:
IOException - if an input or output error occurs
ServletException - if the request for the HEAD could not be handled

doPost

protected void doPost(HttpServletRequest req,
                      HttpServletResponse resp)
               throws ServletException,
                      IOException
Called by the server (via the service method) to allow a servlet to handle a POST request. The HTTP POST method allows the client to send data of unlimited length to the Web server a single time and is useful when posting information such as credit card numbers.

When overriding this method, read the request data, write the response headers, get the response's writer or output stream object, and finally, write the response data. It's best to include content type and encoding. When using a PrintWriter object to return the response, set the content type before accessing the PrintWriter object.

The servlet container must write the headers before committing the response, because in HTTP the headers must be sent before the response body.

Where possible, set the Content-Length header (with the ServletResponse.setContentLength(int) method), to allow the servlet container to use a persistent connection to return its response to the client, improving performance. The content length is automatically set if the entire response fits inside the response buffer.

When using HTTP 1.1 chunked encoding (which means that the response has a Transfer-Encoding header), do not set the Content-Length header.

This method does not need to be either safe or idempotent. Operations requested through POST can have side effects for which the user can be held accountable, for example, updating stored data or buying items online.

If the HTTP POST request is incorrectly formatted, doPost returns an HTTP "Bad Request" message.

Parameters:
req - an HttpServletRequest object that contains the request the client has made of the servlet
resp - an HttpServletResponse object that contains the response the servlet sends to the client
Throws:
IOException - if an input or output error is detected when the servlet handles the request
ServletException - if the request for the POST could not be handled
See Also:
ServletOutputStream, ServletResponse.setContentType(java.lang.String)

doPut

protected void doPut(HttpServletRequest req,
                     HttpServletResponse resp)
              throws ServletException,
                     IOException
Called by the server (via the service method) to allow a servlet to handle a PUT request. The PUT operation allows a client to place a file on the server and is similar to sending a file by FTP.

When overriding this method, leave intact any content headers sent with the request (including Content-Length, Content-Type, Content-Transfer-Encoding, Content-Encoding, Content-Base, Content-Language, Content-Location, Content-MD5, and Content-Range). If your method cannot handle a content header, it must issue an error message (HTTP 501 - Not Implemented) and discard the request. For more information on HTTP 1.1, see RFC 2616 .

This method does not need to be either safe or idempotent. Operations that doPut performs can have side effects for which the user can be held accountable. When using this method, it may be useful to save a copy of the affected URL in temporary storage.

If the HTTP PUT request is incorrectly formatted, doPut returns an HTTP "Bad Request" message.

Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
resp - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the PUT request
ServletException - if the request for the PUT cannot be handled

doDelete

protected void doDelete(HttpServletRequest req,
                        HttpServletResponse resp)
                 throws ServletException,
                        IOException
Called by the server (via the service method) to allow a servlet to handle a DELETE request. The DELETE operation allows a client to remove a document or Web page from the server.

This method does not need to be either safe or idempotent. Operations requested through DELETE can have side effects for which users can be held accountable. When using this method, it may be useful to save a copy of the affected URL in temporary storage.

If the HTTP DELETE request is incorrectly formatted, doDelete returns an HTTP "Bad Request" message.

Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
resp - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the DELETE request
ServletException - if the request for the DELETE cannot be handled

doOptions

protected void doOptions(HttpServletRequest req,
                         HttpServletResponse resp)
                  throws ServletException,
                         IOException
Called by the server (via the service method) to allow a servlet to handle a OPTIONS request. The OPTIONS request determines which HTTP methods the server supports and returns an appropriate header. For example, if a servlet overrides doGet, this method returns the following header:

Allow: GET, HEAD, TRACE, OPTIONS

There's no need to override this method unless the servlet implements new HTTP methods, beyond those implemented by HTTP 1.1.

Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
resp - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the OPTIONS request
ServletException - if the request for the OPTIONS cannot be handled

doTrace

protected void doTrace(HttpServletRequest req,
                       HttpServletResponse resp)
                throws ServletException,
                       IOException
Called by the server (via the service method) to allow a servlet to handle a TRACE request. A TRACE returns the headers sent with the TRACE request to the client, so that they can be used in debugging. There's no need to override this method.

Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
resp - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the TRACE request
ServletException - if the request for the TRACE cannot be handled

service

protected void service(HttpServletRequest req,
                       HttpServletResponse resp)
                throws ServletException,
                       IOException
Receives standard HTTP requests from the public service method and dispatches them to the do XXX methods defined in this class. This method is an HTTP-specific version of the Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse) method. There's no need to override this method.

Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
resp - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the HTTP request
ServletException - if the HTTP request cannot be handled
See Also:
Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)

service

public void service(ServletRequest req,
                    ServletResponse res)
             throws ServletException,
                    IOException
Dispatches client requests to the protected service method. There's no need to override this method.

Specified by:
service in interface Servlet
Specified by:
service in class GenericServlet
Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
res - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the HTTP request
ServletException - if the HTTP request cannot be handled
See Also:
Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpServletRequest

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpServletRequest

All Superinterfaces:
ServletRequest
All Known Implementing Classes:
HttpServletRequestWrapper
public interface HttpServletRequest
extends ServletRequest

Extends the ServletRequest interface to provide request information for HTTP servlets.

The servlet container creates an HttpServletRequest object and passes it as an argument to the servlet's service methods (doGet, doPost, etc).

Version:
$Version$
Author:
Various

Field Summary
static String | BASIC_AUTH String identifier for Basic authentication.
static String | CLIENT_CERT_AUTH String identifier for Client Certificate authentication.
static String | DIGEST_AUTH String identifier for Digest authentication.
static String | FORM_AUTH String identifier for Form authentication.
Method Summary
 String getAuthType()
Returns the name of the authentication scheme used to protect the servlet.
 String getContextPath()
Returns the portion of the request URI that indicates the context of the request.
 Cookie[] getCookies()
Returns an array containing all of the Cookie objects the client sent with this request.
 long getDateHeader(String name)
Returns the value of the specified request header as a long value that represents a Date object.
 String getHeader(String name)
Returns the value of the specified request header as a String.
 Enumeration getHeaderNames()
Returns an enumeration of all the header names this request contains.
 Enumeration getHeaders(String name)
Returns all the values of the specified request header as an Enumeration of String objects.
 int getIntHeader(String name)
Returns the value of the specified request header as an int.
 String getMethod()
Returns the name of the HTTP method with which this request was made, for example, GET, POST, or PUT.
 String getPathInfo()
Returns any extra path information associated with the URL the client sent when it made this request.
 String getPathTranslated()
Returns any extra path information after the servlet name but before the query string, and translates it to a real path.
 String getQueryString()
Returns the query string that is contained in the request URL after the path.
 String getRemoteUser()
Returns the login of the user making this request, if the user has been authenticated, or null if the user has not been authenticated.
 String getRequestedSessionId()
Returns the session ID specified by the client.
 String getRequestURI()
Returns the part of this request's URL from the protocol name up to the query string in the first line of the HTTP request.
 StringBuffer getRequestURL()
Reconstructs the URL the client used to make the request.
 String getServletPath()
Returns the part of this request's URL that calls the servlet.
 HttpSession getSession()
Returns the current session associated with this request, or if the request does not have a session, creates one.
 HttpSession getSession(boolean create)
Returns the current HttpSession associated with this request or, if there is no current session and create is true, returns a new session.
 Principal getUserPrincipal()
Returns a java.security.Principal object containing the name of the current authenticated user.
 boolean isRequestedSessionIdFromCookie()
Checks whether the requested session ID came in as a cookie.
 boolean isRequestedSessionIdFromUrl()
Deprecated. As of Version 2.1 of the Java Servlet API, use isRequestedSessionIdFromURL() instead.
 boolean isRequestedSessionIdFromURL()
Checks whether the requested session ID came in as part of the request URL.
 boolean isRequestedSessionIdValid()
Checks whether the requested session ID is still valid.
 boolean isUserInRole(String role)
Returns a boolean indicating whether the authenticated user is included in the specified logical "role".
Methods inherited from interface javax.servlet.ServletRequest
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

Field Detail

BASIC_AUTH

public static final String BASIC_AUTH
String identifier for Basic authentication. Value "BASIC"

See Also:
Constant Field Values

FORM_AUTH

public static final String FORM_AUTH
String identifier for Form authentication. Value "FORM"

See Also:
Constant Field Values

CLIENT_CERT_AUTH

public static final String CLIENT_CERT_AUTH
String identifier for Client Certificate authentication. Value "CLIENT_CERT"

See Also:
Constant Field Values

DIGEST_AUTH

public static final String DIGEST_AUTH
String identifier for Digest authentication. Value "DIGEST"

See Also:
Constant Field Values
Method Detail

getAuthType

public String getAuthType()
Returns the name of the authentication scheme used to protect the servlet. All servlet containers support basic, form and client certificate authentication, and may additionally support digest authentication. If the servlet is not authenticated null is returned.

Same as the value of the CGI variable AUTH_TYPE.

Returns:
one of the static members BASIC_AUTH, FORM_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH (suitable for == comparison) or the container-specific string indicating the authentication scheme, or null if the request was not authenticated.

getCookies

public Cookie[] getCookies()
Returns an array containing all of the Cookie objects the client sent with this request. This method returns null if no cookies were sent.

Returns:
an array of all the Cookies included with this request, or null if the request has no cookies

getDateHeader

public long getDateHeader(String name)
Returns the value of the specified request header as a long value that represents a Date object. Use this method with headers that contain dates, such as If-Modified-Since.

The date is returned as the number of milliseconds since January 1, 1970 GMT. The header name is case insensitive.

If the request did not have a header of the specified name, this method returns -1. If the header can't be converted to a date, the method throws an IllegalArgumentException.

Parameters:
name - a String specifying the name of the header
Returns:
a long value representing the date specified in the header expressed as the number of milliseconds since January 1, 1970 GMT, or -1 if the named header was not included with the reqest
Throws:
IllegalArgumentException - If the header value can't be converted to a date

getHeader

public String getHeader(String name)
Returns the value of the specified request header as a String. If the request did not include a header of the specified name, this method returns null. If there are multiple headers with the same name, this method returns the first head in the request. The header name is case insensitive. You can use this method with any request header.

Parameters:
name - a String specifying the header name
Returns:
a String containing the value of the requested header, or null if the request does not have a header of that name

getHeaders

public Enumeration getHeaders(String name)
Returns all the values of the specified request header as an Enumeration of String objects.

Some headers, such as Accept-Language can be sent by clients as several headers each with a different value rather than sending the header as a comma separated list.

If the request did not include any headers of the specified name, this method returns an empty Enumeration. The header name is case insensitive. You can use this method with any request header.

Parameters:
name - a String specifying the header name
Returns:
an Enumeration containing the values of the requested header. If the request does not have any headers of that name return an empty enumeration. If the container does not allow access to header information, return null

getHeaderNames

public Enumeration getHeaderNames()
Returns an enumeration of all the header names this request contains. If the request has no headers, this method returns an empty enumeration.

Some servlet containers do not allow servlets to access headers using this method, in which case this method returns null

Returns:
an enumeration of all the header names sent with this request; if the request has no headers, an empty enumeration; if the servlet container does not allow servlets to use this method, null

getIntHeader

public int getIntHeader(String name)
Returns the value of the specified request header as an int. If the request does not have a header of the specified name, this method returns -1. If the header cannot be converted to an integer, this method throws a NumberFormatException.

The header name is case insensitive.

Parameters:
name - a String specifying the name of a request header
Returns:
an integer expressing the value of the request header or -1 if the request doesn't have a header of this name
Throws:
NumberFormatException - If the header value can't be converted to an int

getMethod

public String getMethod()
Returns the name of the HTTP method with which this request was made, for example, GET, POST, or PUT. Same as the value of the CGI variable REQUEST_METHOD.

Returns:
a String specifying the name of the method with which this request was made

getPathInfo

public String getPathInfo()
Returns any extra path information associated with the URL the client sent when it made this request. The extra path information follows the servlet path but precedes the query string and will start with a "/" character.

This method returns null if there was no extra path information.

Same as the value of the CGI variable PATH_INFO.

Returns:
a String, decoded by the web container, specifying extra path information that comes after the servlet path but before the query string in the request URL; or null if the URL does not have any extra path information

getPathTranslated

public String getPathTranslated()
Returns any extra path information after the servlet name but before the query string, and translates it to a real path. Same as the value of the CGI variable PATH_TRANSLATED.

If the URL does not have any extra path information, this method returns null or the servlet container cannot translate the virtual path to a real path for any reason (such as when the web application is executed from an archive). The web container does not decode this string.

Returns:
a String specifying the real path, or null if the URL does not have any extra path information

getContextPath

public String getContextPath()
Returns the portion of the request URI that indicates the context of the request. The context path always comes first in a request URI. The path starts with a "/" character but does not end with a "/" character. For servlets in the default (root) context, this method returns "". The container does not decode this string.

Returns:
a String specifying the portion of the request URI that indicates the context of the request

getQueryString

public String getQueryString()
Returns the query string that is contained in the request URL after the path. This method returns null if the URL does not have a query string. Same as the value of the CGI variable QUERY_STRING.

Returns:
a String containing the query string or null if the URL contains no query string. The value is not decoded by the container.

getRemoteUser

public String getRemoteUser()
Returns the login of the user making this request, if the user has been authenticated, or null if the user has not been authenticated. Whether the user name is sent with each subsequent request depends on the browser and type of authentication. Same as the value of the CGI variable REMOTE_USER.

Returns:
a String specifying the login of the user making this request, or null if the user login is not known

isUserInRole

public boolean isUserInRole(String role)
Returns a boolean indicating whether the authenticated user is included in the specified logical "role". Roles and role membership can be defined using deployment descriptors. If the user has not been authenticated, the method returns false.

Parameters:
role - a String specifying the name of the role
Returns:
a boolean indicating whether the user making this request belongs to a given role; false if the user has not been authenticated

getUserPrincipal

public Principal getUserPrincipal()
Returns a java.security.Principal object containing the name of the current authenticated user. If the user has not been authenticated, the method returns null.

Returns:
a java.security.Principal containing the name of the user making this request; null if the user has not been authenticated

getRequestedSessionId

public String getRequestedSessionId()
Returns the session ID specified by the client. This may not be the same as the ID of the current valid session for this request. If the client did not specify a session ID, this method returns null.

Returns:
a String specifying the session ID, or null if the request did not specify a session ID
See Also:
isRequestedSessionIdValid()

getRequestURI

public String getRequestURI()
Returns the part of this request's URL from the protocol name up to the query string in the first line of the HTTP request. The web container does not decode this String. For example:
First line of HTTP request | Returned Value
POST /some/path.html HTTP/1.1 | /some/path.html
GET http://foo.bar/a.html HTTP/1.0 | /a.html
HEAD /xyz?a=b HTTP/1.1 | /xyz

To reconstruct an URL with a scheme and host, use HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest).

Returns:
a String containing the part of the URL from the protocol name up to the query string
See Also:
HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest)

getRequestURL

public StringBuffer getRequestURL()
Reconstructs the URL the client used to make the request. The returned URL contains a protocol, server name, port number, and server path, but it does not include query string parameters.

Because this method returns a StringBuffer, not a string, you can modify the URL easily, for example, to append query parameters.

This method is useful for creating redirect messages and for reporting errors.

Returns:
a StringBuffer object containing the reconstructed URL

getServletPath

public String getServletPath()
Returns the part of this request's URL that calls the servlet. This path starts with a "/" character and includes either the servlet name or a path to the servlet, but does not include any extra path information or a query string. Same as the value of the CGI variable SCRIPT_NAME.

This method will return an empty string ("") if the servlet used to process this request was matched using the "/*" pattern.

Returns:
a String containing the name or path of the servlet being called, as specified in the request URL, decoded, or an empty string if the servlet used to process the request is matched using the "/*" pattern.

getSession

public HttpSession getSession(boolean create)
Returns the current HttpSession associated with this request or, if there is no current session and create is true, returns a new session.

If create is false and the request has no valid HttpSession, this method returns null.

To make sure the session is properly maintained, you must call this method before the response is committed. If the container is using cookies to maintain session integrity and is asked to create a new session when the response is committed, an IllegalStateException is thrown.

Parameters:
create - true to create a new session for this request if necessary; false to return null if there's no current session
Returns:
the HttpSession associated with this request or null if create is false and the request has no valid session
See Also:
getSession()

getSession

public HttpSession getSession()
Returns the current session associated with this request, or if the request does not have a session, creates one.

Returns:
the HttpSession associated with this request
See Also:
getSession(boolean)

isRequestedSessionIdValid

public boolean isRequestedSessionIdValid()
Checks whether the requested session ID is still valid.

Returns:
true if this request has an id for a valid session in the current session context; false otherwise
See Also:
getRequestedSessionId(), getSession(boolean), HttpSessionContext

isRequestedSessionIdFromCookie

public boolean isRequestedSessionIdFromCookie()
Checks whether the requested session ID came in as a cookie.

Returns:
true if the session ID came in as a cookie; otherwise, false
See Also:
getSession(boolean)

isRequestedSessionIdFromURL

public boolean isRequestedSessionIdFromURL()
Checks whether the requested session ID came in as part of the request URL.

Returns:
true if the session ID came in as part of a URL; otherwise, false
See Also:
getSession(boolean)

isRequestedSessionIdFromUrl

public boolean isRequestedSessionIdFromUrl()
Deprecated. As of Version 2.1 of the Java Servlet API, use isRequestedSessionIdFromURL() instead.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpServletRequestWrapper

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpServletRequestWrapper

java.lang.Object
    extended by javax.servlet.ServletRequestWrapper
        extended by javax.servlet.http.HttpServletRequestWrapper
All Implemented Interfaces:
HttpServletRequest, ServletRequest
public class HttpServletRequestWrapper
extends ServletRequestWrapper
implements HttpServletRequest

Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped request object.

Since:
v 2.3
See Also:
HttpServletRequest

Field Summary
Fields inherited from interface javax.servlet.http.HttpServletRequest
BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH
Constructor Summary
HttpServletRequestWrapper(HttpServletRequest request)
Constructs a request object wrapping the given request.
Method Summary
 String getAuthType()
The default behavior of this method is to return getAuthType() on the wrapped request object.
 String getContextPath()
The default behavior of this method is to return getContextPath() on the wrapped request object.
 Cookie[] getCookies()
The default behavior of this method is to return getCookies() on the wrapped request object.
 long getDateHeader(String name)
The default behavior of this method is to return getDateHeader(String name) on the wrapped request object.
 String getHeader(String name)
The default behavior of this method is to return getHeader(String name) on the wrapped request object.
 Enumeration getHeaderNames()
The default behavior of this method is to return getHeaderNames() on the wrapped request object.
 Enumeration getHeaders(String name)
The default behavior of this method is to return getHeaders(String name) on the wrapped request object.
 int getIntHeader(String name)
The default behavior of this method is to return getIntHeader(String name) on the wrapped request object.
 String getMethod()
The default behavior of this method is to return getMethod() on the wrapped request object.
 String getPathInfo()
The default behavior of this method is to return getPathInfo() on the wrapped request object.
 String getPathTranslated()
The default behavior of this method is to return getPathTranslated() on the wrapped request object.
 String getQueryString()
The default behavior of this method is to return getQueryString() on the wrapped request object.
 String getRemoteUser()
The default behavior of this method is to return getRemoteUser() on the wrapped request object.
 String getRequestedSessionId()
The default behavior of this method is to return getRequestedSessionId() on the wrapped request object.
 String getRequestURI()
The default behavior of this method is to return getRequestURI() on the wrapped request object.
 StringBuffer getRequestURL()
The default behavior of this method is to return getRequestURL() on the wrapped request object.
 String getServletPath()
The default behavior of this method is to return getServletPath() on the wrapped request object.
 HttpSession getSession()
The default behavior of this method is to return getSession() on the wrapped request object.
 HttpSession getSession(boolean create)
The default behavior of this method is to return getSession(boolean create) on the wrapped request object.
 Principal getUserPrincipal()
The default behavior of this method is to return getUserPrincipal() on the wrapped request object.
 boolean isRequestedSessionIdFromCookie()
The default behavior of this method is to return isRequestedSessionIdFromCookie() on the wrapped request object.
 boolean isRequestedSessionIdFromUrl()
The default behavior of this method is to return isRequestedSessionIdFromUrl() on the wrapped request object.
 boolean isRequestedSessionIdFromURL()
The default behavior of this method is to return isRequestedSessionIdFromURL() on the wrapped request object.
 boolean isRequestedSessionIdValid()
The default behavior of this method is to return isRequestedSessionIdValid() on the wrapped request object.
 boolean isUserInRole(String role)
The default behavior of this method is to return isUserInRole(String role) on the wrapped request object.
Methods inherited from class javax.servlet.ServletRequestWrapper
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequest, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding, setRequest
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.ServletRequest
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

Constructor Detail

HttpServletRequestWrapper

public HttpServletRequestWrapper(HttpServletRequest request)
Constructs a request object wrapping the given request.

Throws:
IllegalArgumentException - if the request is null
Method Detail

getAuthType

public String getAuthType()
The default behavior of this method is to return getAuthType() on the wrapped request object.

Specified by:
getAuthType in interface HttpServletRequest
Returns:
one of the static members BASIC_AUTH, FORM_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH (suitable for == comparison) or the container-specific string indicating the authentication scheme, or null if the request was not authenticated.

getCookies

public Cookie[] getCookies()
The default behavior of this method is to return getCookies() on the wrapped request object.

Specified by:
getCookies in interface HttpServletRequest
Returns:
an array of all the Cookies included with this request, or null if the request has no cookies

getDateHeader

public long getDateHeader(String name)
The default behavior of this method is to return getDateHeader(String name) on the wrapped request object.

Specified by:
getDateHeader in interface HttpServletRequest
Parameters:
name - a String specifying the name of the header
Returns:
a long value representing the date specified in the header expressed as the number of milliseconds since January 1, 1970 GMT, or -1 if the named header was not included with the reqest

getHeader

public String getHeader(String name)
The default behavior of this method is to return getHeader(String name) on the wrapped request object.

Specified by:
getHeader in interface HttpServletRequest
Parameters:
name - a String specifying the header name
Returns:
a String containing the value of the requested header, or null if the request does not have a header of that name

getHeaders

public Enumeration getHeaders(String name)
The default behavior of this method is to return getHeaders(String name) on the wrapped request object.

Specified by:
getHeaders in interface HttpServletRequest
Parameters:
name - a String specifying the header name
Returns:
an Enumeration containing the values of the requested header. If the request does not have any headers of that name return an empty enumeration. If the container does not allow access to header information, return null

getHeaderNames

public Enumeration getHeaderNames()
The default behavior of this method is to return getHeaderNames() on the wrapped request object.

Specified by:
getHeaderNames in interface HttpServletRequest
Returns:
an enumeration of all the header names sent with this request; if the request has no headers, an empty enumeration; if the servlet container does not allow servlets to use this method, null

getIntHeader

public int getIntHeader(String name)
The default behavior of this method is to return getIntHeader(String name) on the wrapped request object.

Specified by:
getIntHeader in interface HttpServletRequest
Parameters:
name - a String specifying the name of a request header
Returns:
an integer expressing the value of the request header or -1 if the request doesn't have a header of this name

getMethod

public String getMethod()
The default behavior of this method is to return getMethod() on the wrapped request object.

Specified by:
getMethod in interface HttpServletRequest
Returns:
a String specifying the name of the method with which this request was made

getPathInfo

public String getPathInfo()
The default behavior of this method is to return getPathInfo() on the wrapped request object.

Specified by:
getPathInfo in interface HttpServletRequest
Returns:
a String, decoded by the web container, specifying extra path information that comes after the servlet path but before the query string in the request URL; or null if the URL does not have any extra path information

getPathTranslated

public String getPathTranslated()
The default behavior of this method is to return getPathTranslated() on the wrapped request object.

Specified by:
getPathTranslated in interface HttpServletRequest
Returns:
a String specifying the real path, or null if the URL does not have any extra path information

getContextPath

public String getContextPath()
The default behavior of this method is to return getContextPath() on the wrapped request object.

Specified by:
getContextPath in interface HttpServletRequest
Returns:
a String specifying the portion of the request URI that indicates the context of the request

getQueryString

public String getQueryString()
The default behavior of this method is to return getQueryString() on the wrapped request object.

Specified by:
getQueryString in interface HttpServletRequest
Returns:
a String containing the query string or null if the URL contains no query string. The value is not decoded by the container.

getRemoteUser

public String getRemoteUser()
The default behavior of this method is to return getRemoteUser() on the wrapped request object.

Specified by:
getRemoteUser in interface HttpServletRequest
Returns:
a String specifying the login of the user making this request, or null if the user login is not known

isUserInRole

public boolean isUserInRole(String role)
The default behavior of this method is to return isUserInRole(String role) on the wrapped request object.

Specified by:
isUserInRole in interface HttpServletRequest
Parameters:
role - a String specifying the name of the role
Returns:
a boolean indicating whether the user making this request belongs to a given role; false if the user has not been authenticated

getUserPrincipal

public Principal getUserPrincipal()
The default behavior of this method is to return getUserPrincipal() on the wrapped request object.

Specified by:
getUserPrincipal in interface HttpServletRequest
Returns:
a java.security.Principal containing the name of the user making this request; null if the user has not been authenticated

getRequestedSessionId

public String getRequestedSessionId()
The default behavior of this method is to return getRequestedSessionId() on the wrapped request object.

Specified by:
getRequestedSessionId in interface HttpServletRequest
Returns:
a String specifying the session ID, or null if the request did not specify a session ID
See Also:
HttpServletRequest.isRequestedSessionIdValid()

getRequestURI

public String getRequestURI()
The default behavior of this method is to return getRequestURI() on the wrapped request object.

Specified by:
getRequestURI in interface HttpServletRequest
Returns:
a String containing the part of the URL from the protocol name up to the query string
See Also:
HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest)

getRequestURL

public StringBuffer getRequestURL()
The default behavior of this method is to return getRequestURL() on the wrapped request object.

Specified by:
getRequestURL in interface HttpServletRequest
Returns:
a StringBuffer object containing the reconstructed URL

getServletPath

public String getServletPath()
The default behavior of this method is to return getServletPath() on the wrapped request object.

Specified by:
getServletPath in interface HttpServletRequest
Returns:
a String containing the name or path of the servlet being called, as specified in the request URL, decoded, or an empty string if the servlet used to process the request is matched using the "/*" pattern.

getSession

public HttpSession getSession(boolean create)
The default behavior of this method is to return getSession(boolean create) on the wrapped request object.

Specified by:
getSession in interface HttpServletRequest
Parameters:
create - true to create a new session for this request if necessary; false to return null if there's no current session
Returns:
the HttpSession associated with this request or null if create is false and the request has no valid session
See Also:
HttpServletRequest.getSession()

getSession

public HttpSession getSession()
The default behavior of this method is to return getSession() on the wrapped request object.

Specified by:
getSession in interface HttpServletRequest
Returns:
the HttpSession associated with this request
See Also:
HttpServletRequest.getSession(boolean)

isRequestedSessionIdValid

public boolean isRequestedSessionIdValid()
The default behavior of this method is to return isRequestedSessionIdValid() on the wrapped request object.

Specified by:
isRequestedSessionIdValid in interface HttpServletRequest
Returns:
true if this request has an id for a valid session in the current session context; false otherwise
See Also:
HttpServletRequest.getRequestedSessionId(), HttpServletRequest.getSession(boolean), HttpSessionContext

isRequestedSessionIdFromCookie

public boolean isRequestedSessionIdFromCookie()
The default behavior of this method is to return isRequestedSessionIdFromCookie() on the wrapped request object.

Specified by:
isRequestedSessionIdFromCookie in interface HttpServletRequest
Returns:
true if the session ID came in as a cookie; otherwise, false
See Also:
HttpServletRequest.getSession(boolean)

isRequestedSessionIdFromURL

public boolean isRequestedSessionIdFromURL()
The default behavior of this method is to return isRequestedSessionIdFromURL() on the wrapped request object.

Specified by:
isRequestedSessionIdFromURL in interface HttpServletRequest
Returns:
true if the session ID came in as part of a URL; otherwise, false
See Also:
HttpServletRequest.getSession(boolean)

isRequestedSessionIdFromUrl

public boolean isRequestedSessionIdFromUrl()
The default behavior of this method is to return isRequestedSessionIdFromUrl() on the wrapped request object.

Specified by:
isRequestedSessionIdFromUrl in interface HttpServletRequest
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpServletResponse

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpServletResponse

All Superinterfaces:
ServletResponse
All Known Implementing Classes:
HttpServletResponseWrapper
public interface HttpServletResponse
extends ServletResponse

Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response. For example, it has methods to access HTTP headers and cookies.

The servlet container creates an HttpServletResponse object and passes it as an argument to the servlet's service methods (doGet, doPost, etc).

Version:
$Version$
Author:
Various
See Also:
ServletResponse

Field Summary
static int | SC_ACCEPTED Status code (202) indicating that a request was accepted for processing, but was not completed.
static int | SC_BAD_GATEWAY Status code (502) indicating that the HTTP server received an invalid response from a server it consulted when acting as a proxy or gateway.
static int | SC_BAD_REQUEST Status code (400) indicating the request sent by the client was syntactically incorrect.
static int | SC_CONFLICT Status code (409) indicating that the request could not be completed due to a conflict with the current state of the resource.
static int | SC_CONTINUE Status code (100) indicating the client can continue.
static int | SC_CREATED Status code (201) indicating the request succeeded and created a new resource on the server.
static int | SC_EXPECTATION_FAILED Status code (417) indicating that the server could not meet the expectation given in the Expect request header.
static int | SC_FORBIDDEN Status code (403) indicating the server understood the request but refused to fulfill it.
static int | SC_FOUND Status code (302) indicating that the resource reside temporarily under a different URI.
static int | SC_GATEWAY_TIMEOUT Status code (504) indicating that the server did not receive a timely response from the upstream server while acting as a gateway or proxy.
static int | SC_GONE Status code (410) indicating that the resource is no longer available at the server and no forwarding address is known.
static int | SC_HTTP_VERSION_NOT_SUPPORTED Status code (505) indicating that the server does not support or refuses to support the HTTP protocol version that was used in the request message.
static int | SC_INTERNAL_SERVER_ERROR Status code (500) indicating an error inside the HTTP server which prevented it from fulfilling the request.
static int | SC_LENGTH_REQUIRED Status code (411) indicating that the request cannot be handled without a defined Content-Length.
static int | SC_METHOD_NOT_ALLOWED Status code (405) indicating that the method specified in the Request-Line is not allowed for the resource identified by the Request-URI.
static int | SC_MOVED_PERMANENTLY Status code (301) indicating that the resource has permanently moved to a new location, and that future references should use a new URI with their requests.
static int | SC_MOVED_TEMPORARILY Status code (302) indicating that the resource has temporarily moved to another location, but that future references should still use the original URI to access the resource.
static int | SC_MULTIPLE_CHOICES Status code (300) indicating that the requested resource corresponds to any one of a set of representations, each with its own specific location.
static int | SC_NO_CONTENT Status code (204) indicating that the request succeeded but that there was no new information to return.
static int | SC_NON_AUTHORITATIVE_INFORMATION Status code (203) indicating that the meta information presented by the client did not originate from the server.
static int | SC_NOT_ACCEPTABLE Status code (406) indicating that the resource identified by the request is only capable of generating response entities which have content characteristics not acceptable according to the accept headers sent in the request.
static int | SC_NOT_FOUND Status code (404) indicating that the requested resource is not available.
static int | SC_NOT_IMPLEMENTED Status code (501) indicating the HTTP server does not support the functionality needed to fulfill the request.
static int | SC_NOT_MODIFIED Status code (304) indicating that a conditional GET operation found that the resource was available and not modified.
static int | SC_OK Status code (200) indicating the request succeeded normally.
static int | SC_PARTIAL_CONTENT Status code (206) indicating that the server has fulfilled the partial GET request for the resource.
static int | SC_PAYMENT_REQUIRED Status code (402) reserved for future use.
static int | SC_PRECONDITION_FAILED Status code (412) indicating that the precondition given in one or more of the request-header fields evaluated to false when it was tested on the server.
static int | SC_PROXY_AUTHENTICATION_REQUIRED Status code (407) indicating that the client MUST first authenticate itself with the proxy.
static int | SC_REQUEST_ENTITY_TOO_LARGE Status code (413) indicating that the server is refusing to process the request because the request entity is larger than the server is willing or able to process.
static int | SC_REQUEST_TIMEOUT Status code (408) indicating that the client did not produce a request within the time that the server was prepared to wait.
static int | SC_REQUEST_URI_TOO_LONG Status code (414) indicating that the server is refusing to service the request because the Request-URI is longer than the server is willing to interpret.
static int | SC_REQUESTED_RANGE_NOT_SATISFIABLE Status code (416) indicating that the server cannot serve the requested byte range.
static int | SC_RESET_CONTENT Status code (205) indicating that the agent SHOULD reset the document view which caused the request to be sent.
static int | SC_SEE_OTHER Status code (303) indicating that the response to the request can be found under a different URI.
static int | SC_SERVICE_UNAVAILABLE Status code (503) indicating that the HTTP server is temporarily overloaded, and unable to handle the request.
static int | SC_SWITCHING_PROTOCOLS Status code (101) indicating the server is switching protocols according to Upgrade header.
static int | SC_TEMPORARY_REDIRECT Status code (307) indicating that the requested resource resides temporarily under a different URI.
static int | SC_UNAUTHORIZED Status code (401) indicating that the request requires HTTP authentication.
static int | SC_UNSUPPORTED_MEDIA_TYPE Status code (415) indicating that the server is refusing to service the request because the entity of the request is in a format not supported by the requested resource for the requested method.
static int | SC_USE_PROXY Status code (305) indicating that the requested resource MUST be accessed through the proxy given by the Location field.
Method Summary
 void addCookie(Cookie cookie)
Adds the specified cookie to the response.
 void addDateHeader(String name, long date)
Adds a response header with the given name and date-value.
 void addHeader(String name, String value)
Adds a response header with the given name and value.
 void addIntHeader(String name, int value)
Adds a response header with the given name and integer value.
 boolean containsHeader(String name)
Returns a boolean indicating whether the named response header has already been set.
 String encodeRedirectUrl(String url)
Deprecated. As of version 2.1, use encodeRedirectURL(String url) instead
 String encodeRedirectURL(String url)
Encodes the specified URL for use in the sendRedirect method or, if encoding is not needed, returns the URL unchanged.
 String encodeUrl(String url)
Deprecated. As of version 2.1, use encodeURL(String url) instead
 String encodeURL(String url)
Encodes the specified URL by including the session ID in it, or, if encoding is not needed, returns the URL unchanged.
 void sendError(int sc)
Sends an error response to the client using the specified status code and clearing the buffer.
 void sendError(int sc, String msg)
Sends an error response to the client using the specified status.
 void sendRedirect(String location)
Sends a temporary redirect response to the client using the specified redirect location URL.
 void setDateHeader(String name, long date)
Sets a response header with the given name and date-value.
 void setHeader(String name, String value)
Sets a response header with the given name and value.
 void setIntHeader(String name, int value)
Sets a response header with the given name and integer value.
 void setStatus(int sc)
Sets the status code for this response.
 void setStatus(int sc, String sm)
Deprecated. As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String). Sets the status code and message for this response.
Methods inherited from interface javax.servlet.ServletResponse
flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentType, setLocale

Field Detail

SC_CONTINUE

public static final int SC_CONTINUE
Status code (100) indicating the client can continue.

See Also:
Constant Field Values

SC_SWITCHING_PROTOCOLS

public static final int SC_SWITCHING_PROTOCOLS
Status code (101) indicating the server is switching protocols according to Upgrade header.

See Also:
Constant Field Values

SC_OK

public static final int SC_OK
Status code (200) indicating the request succeeded normally.

See Also:
Constant Field Values

SC_CREATED

public static final int SC_CREATED
Status code (201) indicating the request succeeded and created a new resource on the server.

See Also:
Constant Field Values

SC_ACCEPTED

public static final int SC_ACCEPTED
Status code (202) indicating that a request was accepted for processing, but was not completed.

See Also:
Constant Field Values

SC_NON_AUTHORITATIVE_INFORMATION

public static final int SC_NON_AUTHORITATIVE_INFORMATION
Status code (203) indicating that the meta information presented by the client did not originate from the server.

See Also:
Constant Field Values

SC_NO_CONTENT

public static final int SC_NO_CONTENT
Status code (204) indicating that the request succeeded but that there was no new information to return.

See Also:
Constant Field Values

SC_RESET_CONTENT

public static final int SC_RESET_CONTENT
Status code (205) indicating that the agent SHOULD reset the document view which caused the request to be sent.

See Also:
Constant Field Values

SC_PARTIAL_CONTENT

public static final int SC_PARTIAL_CONTENT
Status code (206) indicating that the server has fulfilled the partial GET request for the resource.

See Also:
Constant Field Values

SC_MULTIPLE_CHOICES

public static final int SC_MULTIPLE_CHOICES
Status code (300) indicating that the requested resource corresponds to any one of a set of representations, each with its own specific location.

See Also:
Constant Field Values

SC_MOVED_PERMANENTLY

public static final int SC_MOVED_PERMANENTLY
Status code (301) indicating that the resource has permanently moved to a new location, and that future references should use a new URI with their requests.

See Also:
Constant Field Values

SC_MOVED_TEMPORARILY

public static final int SC_MOVED_TEMPORARILY
Status code (302) indicating that the resource has temporarily moved to another location, but that future references should still use the original URI to access the resource. This definition is being retained for backwards compatibility. SC_FOUND is now the preferred definition.

See Also:
Constant Field Values

SC_FOUND

public static final int SC_FOUND
Status code (302) indicating that the resource reside temporarily under a different URI. Since the redirection might be altered on occasion, the client should continue to use the Request-URI for future requests.(HTTP/1.1) To represent the status code (302), it is recommended to use this variable.

See Also:
Constant Field Values

SC_SEE_OTHER

public static final int SC_SEE_OTHER
Status code (303) indicating that the response to the request can be found under a different URI.

See Also:
Constant Field Values

SC_NOT_MODIFIED

public static final int SC_NOT_MODIFIED
Status code (304) indicating that a conditional GET operation found that the resource was available and not modified.

See Also:
Constant Field Values

SC_USE_PROXY

public static final int SC_USE_PROXY
Status code (305) indicating that the requested resource MUST be accessed through the proxy given by the Location field.

See Also:
Constant Field Values

SC_TEMPORARY_REDIRECT

public static final int SC_TEMPORARY_REDIRECT
Status code (307) indicating that the requested resource resides temporarily under a different URI. The temporary URI SHOULD be given by the Location field in the response.

See Also:
Constant Field Values

SC_BAD_REQUEST

public static final int SC_BAD_REQUEST
Status code (400) indicating the request sent by the client was syntactically incorrect.

See Also:
Constant Field Values

SC_UNAUTHORIZED

public static final int SC_UNAUTHORIZED
Status code (401) indicating that the request requires HTTP authentication.

See Also:
Constant Field Values

SC_PAYMENT_REQUIRED

public static final int SC_PAYMENT_REQUIRED
Status code (402) reserved for future use.

See Also:
Constant Field Values

SC_FORBIDDEN

public static final int SC_FORBIDDEN
Status code (403) indicating the server understood the request but refused to fulfill it.

See Also:
Constant Field Values

SC_NOT_FOUND

public static final int SC_NOT_FOUND
Status code (404) indicating that the requested resource is not available.

See Also:
Constant Field Values

SC_METHOD_NOT_ALLOWED

public static final int SC_METHOD_NOT_ALLOWED
Status code (405) indicating that the method specified in the Request-Line is not allowed for the resource identified by the Request-URI.

See Also:
Constant Field Values

SC_NOT_ACCEPTABLE

public static final int SC_NOT_ACCEPTABLE
Status code (406) indicating that the resource identified by the request is only capable of generating response entities which have content characteristics not acceptable according to the accept headers sent in the request.

See Also:
Constant Field Values

SC_PROXY_AUTHENTICATION_REQUIRED

public static final int SC_PROXY_AUTHENTICATION_REQUIRED
Status code (407) indicating that the client MUST first authenticate itself with the proxy.

See Also:
Constant Field Values

SC_REQUEST_TIMEOUT

public static final int SC_REQUEST_TIMEOUT
Status code (408) indicating that the client did not produce a request within the time that the server was prepared to wait.

See Also:
Constant Field Values

SC_CONFLICT

public static final int SC_CONFLICT
Status code (409) indicating that the request could not be completed due to a conflict with the current state of the resource.

See Also:
Constant Field Values

SC_GONE

public static final int SC_GONE
Status code (410) indicating that the resource is no longer available at the server and no forwarding address is known. This condition SHOULD be considered permanent.

See Also:
Constant Field Values

SC_LENGTH_REQUIRED

public static final int SC_LENGTH_REQUIRED
Status code (411) indicating that the request cannot be handled without a defined Content-Length.

See Also:
Constant Field Values

SC_PRECONDITION_FAILED

public static final int SC_PRECONDITION_FAILED
Status code (412) indicating that the precondition given in one or more of the request-header fields evaluated to false when it was tested on the server.

See Also:
Constant Field Values

SC_REQUEST_ENTITY_TOO_LARGE

public static final int SC_REQUEST_ENTITY_TOO_LARGE
Status code (413) indicating that the server is refusing to process the request because the request entity is larger than the server is willing or able to process.

See Also:
Constant Field Values

SC_REQUEST_URI_TOO_LONG

public static final int SC_REQUEST_URI_TOO_LONG
Status code (414) indicating that the server is refusing to service the request because the Request-URI is longer than the server is willing to interpret.

See Also:
Constant Field Values

SC_UNSUPPORTED_MEDIA_TYPE

public static final int SC_UNSUPPORTED_MEDIA_TYPE
Status code (415) indicating that the server is refusing to service the request because the entity of the request is in a format not supported by the requested resource for the requested method.

See Also:
Constant Field Values

SC_REQUESTED_RANGE_NOT_SATISFIABLE

public static final int SC_REQUESTED_RANGE_NOT_SATISFIABLE
Status code (416) indicating that the server cannot serve the requested byte range.

See Also:
Constant Field Values

SC_EXPECTATION_FAILED

public static final int SC_EXPECTATION_FAILED
Status code (417) indicating that the server could not meet the expectation given in the Expect request header.

See Also:
Constant Field Values

SC_INTERNAL_SERVER_ERROR

public static final int SC_INTERNAL_SERVER_ERROR
Status code (500) indicating an error inside the HTTP server which prevented it from fulfilling the request.

See Also:
Constant Field Values

SC_NOT_IMPLEMENTED

public static final int SC_NOT_IMPLEMENTED
Status code (501) indicating the HTTP server does not support the functionality needed to fulfill the request.

See Also:
Constant Field Values

SC_BAD_GATEWAY

public static final int SC_BAD_GATEWAY
Status code (502) indicating that the HTTP server received an invalid response from a server it consulted when acting as a proxy or gateway.

See Also:
Constant Field Values

SC_SERVICE_UNAVAILABLE

public static final int SC_SERVICE_UNAVAILABLE
Status code (503) indicating that the HTTP server is temporarily overloaded, and unable to handle the request.

See Also:
Constant Field Values

SC_GATEWAY_TIMEOUT

public static final int SC_GATEWAY_TIMEOUT
Status code (504) indicating that the server did not receive a timely response from the upstream server while acting as a gateway or proxy.

See Also:
Constant Field Values

SC_HTTP_VERSION_NOT_SUPPORTED

public static final int SC_HTTP_VERSION_NOT_SUPPORTED
Status code (505) indicating that the server does not support or refuses to support the HTTP protocol version that was used in the request message.

See Also:
Constant Field Values
Method Detail

addCookie

public void addCookie(Cookie cookie)
Adds the specified cookie to the response. This method can be called multiple times to set more than one cookie.

Parameters:
cookie - the Cookie to return to the client

containsHeader

public boolean containsHeader(String name)
Returns a boolean indicating whether the named response header has already been set.

Parameters:
name - the header name
Returns:
true if the named response header has already been set; false otherwise

encodeURL

public String encodeURL(String url)
Encodes the specified URL by including the session ID in it, or, if encoding is not needed, returns the URL unchanged. The implementation of this method includes the logic to determine whether the session ID needs to be encoded in the URL. For example, if the browser supports cookies, or session tracking is turned off, URL encoding is unnecessary.

For robust session tracking, all URLs emitted by a servlet should be run through this method. Otherwise, URL rewriting cannot be used with browsers which do not support cookies.

Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

encodeRedirectURL

public String encodeRedirectURL(String url)
Encodes the specified URL for use in the sendRedirect method or, if encoding is not needed, returns the URL unchanged. The implementation of this method includes the logic to determine whether the session ID needs to be encoded in the URL. Because the rules for making this determination can differ from those used to decide whether to encode a normal link, this method is separete from the encodeURL method.

All URLs sent to the HttpServletResponse.sendRedirect method should be run through this method. Otherwise, URL rewriting cannot be used with browsers which do not support cookies.

Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.
See Also:
sendRedirect(java.lang.String), encodeUrl(java.lang.String)

encodeUrl

public String encodeUrl(String url)
Deprecated. As of version 2.1, use encodeURL(String url) instead

Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

encodeRedirectUrl

public String encodeRedirectUrl(String url)
Deprecated. As of version 2.1, use encodeRedirectURL(String url) instead

Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

sendError

public void sendError(int sc,
                      String msg)
               throws IOException
Sends an error response to the client using the specified status. The server defaults to creating the response to look like an HTML-formatted server error page containing the specified message, setting the content type to "text/html", leaving cookies and other headers unmodified. If an error-page declaration has been made for the web application corresponding to the status code passed in, it will be served back in preference to the suggested msg parameter.

If the response has already been committed, this method throws an IllegalStateException. After using this method, the response should be considered to be committed and should not be written to.

Parameters:
sc - the error status code
msg - the descriptive message
Throws:
IOException - If an input or output exception occurs
IllegalStateException - If the response was committed

sendError

public void sendError(int sc)
               throws IOException
Sends an error response to the client using the specified status code and clearing the buffer.

If the response has already been committed, this method throws an IllegalStateException. After using this method, the response should be considered to be committed and should not be written to.

Parameters:
sc - the error status code
Throws:
IOException - If an input or output exception occurs
IllegalStateException - If the response was committed before this method call

sendRedirect

public void sendRedirect(String location)
                  throws IOException
Sends a temporary redirect response to the client using the specified redirect location URL. This method can accept relative URLs; the servlet container must convert the relative URL to an absolute URL before sending the response to the client. If the location is relative without a leading '/' the container interprets it as relative to the current request URI. If the location is relative with a leading '/' the container interprets it as relative to the servlet container root.

If the response has already been committed, this method throws an IllegalStateException. After using this method, the response should be considered to be committed and should not be written to.

Parameters:
location - the redirect location URL
Throws:
IOException - If an input or output exception occurs
IllegalStateException - If the response was committed or if a partial URL is given and cannot be converted into a valid URL

setDateHeader

public void setDateHeader(String name,
                          long date)
Sets a response header with the given name and date-value. The date is specified in terms of milliseconds since the epoch. If the header had already been set, the new value overwrites the previous one. The containsHeader method can be used to test for the presence of a header before setting its value.

Parameters:
name - the name of the header to set
date - the assigned date value
See Also:
containsHeader(java.lang.String), addDateHeader(java.lang.String, long)

addDateHeader

public void addDateHeader(String name,
                          long date)
Adds a response header with the given name and date-value. The date is specified in terms of milliseconds since the epoch. This method allows response headers to have multiple values.

Parameters:
name - the name of the header to set
date - the additional date value
See Also:
setDateHeader(java.lang.String, long)

setHeader

public void setHeader(String name,
                      String value)
Sets a response header with the given name and value. If the header had already been set, the new value overwrites the previous one. The containsHeader method can be used to test for the presence of a header before setting its value.

Parameters:
name - the name of the header
value - the header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
See Also:
containsHeader(java.lang.String), addHeader(java.lang.String, java.lang.String)

addHeader

public void addHeader(String name,
                      String value)
Adds a response header with the given name and value. This method allows response headers to have multiple values.

Parameters:
name - the name of the header
value - the additional header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
See Also:
setHeader(java.lang.String, java.lang.String)

setIntHeader

public void setIntHeader(String name,
                         int value)
Sets a response header with the given name and integer value. If the header had already been set, the new value overwrites the previous one. The containsHeader method can be used to test for the presence of a header before setting its value.

Parameters:
name - the name of the header
value - the assigned integer value
See Also:
containsHeader(java.lang.String), addIntHeader(java.lang.String, int)

addIntHeader

public void addIntHeader(String name,
                         int value)
Adds a response header with the given name and integer value. This method allows response headers to have multiple values.

Parameters:
name - the name of the header
value - the assigned integer value
See Also:
setIntHeader(java.lang.String, int)

setStatus

public void setStatus(int sc)
Sets the status code for this response. This method is used to set the return status code when there is no error (for example, for the status codes SC_OK or SC_MOVED_TEMPORARILY). If there is an error, and the caller wishes to invoke an error-page defined in the web applicaion, the sendError method should be used instead.

The container clears the buffer and sets the Location header, preserving cookies and other headers.

Parameters:
sc - the status code
See Also:
sendError(int, java.lang.String)

setStatus

public void setStatus(int sc,
                      String sm)
Deprecated. As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String). Sets the status code and message for this response.

Parameters:
sc - the status code
sm - the status message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpServletResponseWrapper

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpServletResponseWrapper

java.lang.Object
    extended by javax.servlet.ServletResponseWrapper
        extended by javax.servlet.http.HttpServletResponseWrapper
All Implemented Interfaces:
HttpServletResponse, ServletResponse
public class HttpServletResponseWrapper
extends ServletResponseWrapper
implements HttpServletResponse

Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped response object.

Since:
v 2.3
Version:
$Version$
Author:
Various
See Also:
HttpServletResponse

Field Summary
Fields inherited from interface javax.servlet.http.HttpServletResponse
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_FOUND, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
Constructor Summary
HttpServletResponseWrapper(HttpServletResponse response)
Constructs a response adaptor wrapping the given response.
Method Summary
 void addCookie(Cookie cookie)
The default behavior of this method is to call addCookie(Cookie cookie) on the wrapped response object.
 void addDateHeader(String name, long date)
The default behavior of this method is to call addDateHeader(String name, long date) on the wrapped response object.
 void addHeader(String name, String value)
The default behavior of this method is to return addHeader(String name, String value) on the wrapped response object.
 void addIntHeader(String name, int value)
The default behavior of this method is to call addIntHeader(String name, int value) on the wrapped response object.
 boolean containsHeader(String name)
The default behavior of this method is to call containsHeader(String name) on the wrapped response object.
 String encodeRedirectUrl(String url)
The default behavior of this method is to return encodeRedirectUrl(String url) on the wrapped response object.
 String encodeRedirectURL(String url)
The default behavior of this method is to return encodeRedirectURL(String url) on the wrapped response object.
 String encodeUrl(String url)
The default behavior of this method is to call encodeUrl(String url) on the wrapped response object.
 String encodeURL(String url)
The default behavior of this method is to call encodeURL(String url) on the wrapped response object.
 void sendError(int sc)
The default behavior of this method is to call sendError(int sc) on the wrapped response object.
 void sendError(int sc, String msg)
The default behavior of this method is to call sendError(int sc, String msg) on the wrapped response object.
 void sendRedirect(String location)
The default behavior of this method is to return sendRedirect(String location) on the wrapped response object.
 void setDateHeader(String name, long date)
The default behavior of this method is to call setDateHeader(String name, long date) on the wrapped response object.
 void setHeader(String name, String value)
The default behavior of this method is to return setHeader(String name, String value) on the wrapped response object.
 void setIntHeader(String name, int value)
The default behavior of this method is to call setIntHeader(String name, int value) on the wrapped response object.
 void setStatus(int sc)
The default behavior of this method is to call setStatus(int sc) on the wrapped response object.
 void setStatus(int sc, String sm)
The default behavior of this method is to call setStatus(int sc, String sm) on the wrapped response object.
Methods inherited from class javax.servlet.ServletResponseWrapper
flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getOutputStream, getResponse, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentType, setLocale, setResponse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.ServletResponse
flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentType, setLocale

Constructor Detail

HttpServletResponseWrapper

public HttpServletResponseWrapper(HttpServletResponse response)
Constructs a response adaptor wrapping the given response.

Throws:
IllegalArgumentException - if the response is null
Method Detail

addCookie

public void addCookie(Cookie cookie)
The default behavior of this method is to call addCookie(Cookie cookie) on the wrapped response object.

Specified by:
addCookie in interface HttpServletResponse
Parameters:
cookie - the Cookie to return to the client

containsHeader

public boolean containsHeader(String name)
The default behavior of this method is to call containsHeader(String name) on the wrapped response object.

Specified by:
containsHeader in interface HttpServletResponse
Parameters:
name - the header name
Returns:
true if the named response header has already been set; false otherwise

encodeURL

public String encodeURL(String url)
The default behavior of this method is to call encodeURL(String url) on the wrapped response object.

Specified by:
encodeURL in interface HttpServletResponse
Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

encodeRedirectURL

public String encodeRedirectURL(String url)
The default behavior of this method is to return encodeRedirectURL(String url) on the wrapped response object.

Specified by:
encodeRedirectURL in interface HttpServletResponse
Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.
See Also:
HttpServletResponse.sendRedirect(java.lang.String), HttpServletResponse.encodeUrl(java.lang.String)

encodeUrl

public String encodeUrl(String url)
The default behavior of this method is to call encodeUrl(String url) on the wrapped response object.

Specified by:
encodeUrl in interface HttpServletResponse
Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

encodeRedirectUrl

public String encodeRedirectUrl(String url)
The default behavior of this method is to return encodeRedirectUrl(String url) on the wrapped response object.

Specified by:
encodeRedirectUrl in interface HttpServletResponse
Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

sendError

public void sendError(int sc,
                      String msg)
               throws IOException
The default behavior of this method is to call sendError(int sc, String msg) on the wrapped response object.

Specified by:
sendError in interface HttpServletResponse
Parameters:
sc - the error status code
msg - the descriptive message
Throws:
IOException - If an input or output exception occurs

sendError

public void sendError(int sc)
               throws IOException
The default behavior of this method is to call sendError(int sc) on the wrapped response object.

Specified by:
sendError in interface HttpServletResponse
Parameters:
sc - the error status code
Throws:
IOException - If an input or output exception occurs

sendRedirect

public void sendRedirect(String location)
                  throws IOException
The default behavior of this method is to return sendRedirect(String location) on the wrapped response object.

Specified by:
sendRedirect in interface HttpServletResponse
Parameters:
location - the redirect location URL
Throws:
IOException - If an input or output exception occurs

setDateHeader

public void setDateHeader(String name,
                          long date)
The default behavior of this method is to call setDateHeader(String name, long date) on the wrapped response object.

Specified by:
setDateHeader in interface HttpServletResponse
Parameters:
name - the name of the header to set
date - the assigned date value
See Also:
HttpServletResponse.containsHeader(java.lang.String), HttpServletResponse.addDateHeader(java.lang.String, long)

addDateHeader

public void addDateHeader(String name,
                          long date)
The default behavior of this method is to call addDateHeader(String name, long date) on the wrapped response object.

Specified by:
addDateHeader in interface HttpServletResponse
Parameters:
name - the name of the header to set
date - the additional date value
See Also:
HttpServletResponse.setDateHeader(java.lang.String, long)

setHeader

public void setHeader(String name,
                      String value)
The default behavior of this method is to return setHeader(String name, String value) on the wrapped response object.

Specified by:
setHeader in interface HttpServletResponse
Parameters:
name - the name of the header
value - the header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
See Also:
HttpServletResponse.containsHeader(java.lang.String), HttpServletResponse.addHeader(java.lang.String, java.lang.String)

addHeader

public void addHeader(String name,
                      String value)
The default behavior of this method is to return addHeader(String name, String value) on the wrapped response object.

Specified by:
addHeader in interface HttpServletResponse
Parameters:
name - the name of the header
value - the additional header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
See Also:
HttpServletResponse.setHeader(java.lang.String, java.lang.String)

setIntHeader

public void setIntHeader(String name,
                         int value)
The default behavior of this method is to call setIntHeader(String name, int value) on the wrapped response object.

Specified by:
setIntHeader in interface HttpServletResponse
Parameters:
name - the name of the header
value - the assigned integer value
See Also:
HttpServletResponse.containsHeader(java.lang.String), HttpServletResponse.addIntHeader(java.lang.String, int)

addIntHeader

public void addIntHeader(String name,
                         int value)
The default behavior of this method is to call addIntHeader(String name, int value) on the wrapped response object.

Specified by:
addIntHeader in interface HttpServletResponse
Parameters:
name - the name of the header
value - the assigned integer value
See Also:
HttpServletResponse.setIntHeader(java.lang.String, int)

setStatus

public void setStatus(int sc)
The default behavior of this method is to call setStatus(int sc) on the wrapped response object.

Specified by:
setStatus in interface HttpServletResponse
Parameters:
sc - the status code
See Also:
HttpServletResponse.sendError(int, java.lang.String)

setStatus

public void setStatus(int sc,
                      String sm)
The default behavior of this method is to call setStatus(int sc, String sm) on the wrapped response object.

Specified by:
setStatus in interface HttpServletResponse
Parameters:
sc - the status code
sm - the status message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpSession

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSession

public interface HttpSession

Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.

The servlet container uses this interface to create a session between an HTTP client and an HTTP server. The session persists for a specified time period, across more than one connection or page request from the user. A session usually corresponds to one user, who may visit a site many times. The server can maintain a session in many ways such as using cookies or rewriting URLs.

This interface allows servlets to

  • View and manipulate information about a session, such as the session identifier, creation time, and last accessed time
  • Bind objects to sessions, allowing user information to persist across multiple user connections

When an application stores an object in or removes an object from a session, the session checks whether the object implements HttpSessionBindingListener. If it does, the servlet notifies the object that it has been bound to or unbound from the session. Notifications are sent after the binding methods complete. For session that are invalidated or expire, notifications are sent after the session has been invalidatd or expired.

When container migrates a session between VMs in a distributed container setting, all session attributes implementing the HttpSessionActivationListener interface are notified.

A servlet should be able to handle cases in which the client does not choose to join a session, such as when cookies are intentionally turned off. Until the client joins the session, isNew returns true. If the client chooses not to join the session, getSession will return a different session on each request, and isNew will always return true.

Session information is scoped only to the current web application (ServletContext), so information stored in one context will not be directly visible in another.

Version:
$Version$
Author:
Various
See Also:
HttpSessionBindingListener, HttpSessionContext

Method Summary
 Object getAttribute(String name)
Returns the object bound with the specified name in this session, or null if no object is bound under the name.
 Enumeration getAttributeNames()
Returns an Enumeration of String objects containing the names of all the objects bound to this session.
 long getCreationTime()
Returns the time when this session was created, measured in milliseconds since midnight January 1, 1970 GMT.
 String getId()
Returns a string containing the unique identifier assigned to this session.
 long getLastAccessedTime()
Returns the last time the client sent a request associated with this session, as the number of milliseconds since midnight January 1, 1970 GMT, and marked by the time the container received the request.
 int getMaxInactiveInterval()
Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses.
 ServletContext getServletContext()
Returns the ServletContext to which this session belongs.
 HttpSessionContext getSessionContext()
Deprecated. As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.
 Object getValue(String name)
Deprecated. As of Version 2.2, this method is replaced by getAttribute(java.lang.String).
 String[] getValueNames()
Deprecated. As of Version 2.2, this method is replaced by getAttributeNames()
 void invalidate()
Invalidates this session then unbinds any objects bound to it.
 boolean isNew()
Returns true if the client does not yet know about the session or if the client chooses not to join the session.
 void putValue(String name, Object value)
Deprecated. As of Version 2.2, this method is replaced by setAttribute(java.lang.String, java.lang.Object)
 void removeAttribute(String name)
Removes the object bound with the specified name from this session.
 void removeValue(String name)
Deprecated. As of Version 2.2, this method is replaced by removeAttribute(java.lang.String)
 void setAttribute(String name, Object value)
Binds an object to this session, using the name specified.
 void setMaxInactiveInterval(int interval)
Specifies the time, in seconds, between client requests before the servlet container will invalidate this session.

Method Detail

getCreationTime

public long getCreationTime()
Returns the time when this session was created, measured in milliseconds since midnight January 1, 1970 GMT.

Returns:
a long specifying when this session was created, expressed in milliseconds since 1/1/1970 GMT
Throws:
IllegalStateException - if this method is called on an invalidated session

getId

public String getId()
Returns a string containing the unique identifier assigned to this session. The identifier is assigned by the servlet container and is implementation dependent.

Returns:
a string specifying the identifier assigned to this session
Throws:
IllegalStateException - if this method is called on an invalidated session

getLastAccessedTime

public long getLastAccessedTime()
Returns the last time the client sent a request associated with this session, as the number of milliseconds since midnight January 1, 1970 GMT, and marked by the time the container received the request.

Actions that your application takes, such as getting or setting a value associated with the session, do not affect the access time.

Returns:
a long representing the last time the client sent a request associated with this session, expressed in milliseconds since 1/1/1970 GMT
Throws:
IllegalStateException - if this method is called on an invalidated session

getServletContext

public ServletContext getServletContext()
Returns the ServletContext to which this session belongs.

Returns:
The ServletContext object for the web application
Since:
2.3

setMaxInactiveInterval

public void setMaxInactiveInterval(int interval)
Specifies the time, in seconds, between client requests before the servlet container will invalidate this session. A negative time indicates the session should never timeout.

Parameters:
interval - An integer specifying the number of seconds

getMaxInactiveInterval

public int getMaxInactiveInterval()
Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses. After this interval, the servlet container will invalidate the session. The maximum time interval can be set with the setMaxInactiveInterval method. A negative time indicates the session should never timeout.

Returns:
an integer specifying the number of seconds this session remains open between client requests
See Also:
setMaxInactiveInterval(int)

getSessionContext

public HttpSessionContext getSessionContext()
Deprecated. As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.

getAttribute

public Object getAttribute(String name)
Returns the object bound with the specified name in this session, or null if no object is bound under the name.

Parameters:
name - a string specifying the name of the object
Returns:
the object with the specified name
Throws:
IllegalStateException - if this method is called on an invalidated session

getValue

public Object getValue(String name)
Deprecated. As of Version 2.2, this method is replaced by getAttribute(java.lang.String).

Parameters:
name - a string specifying the name of the object
Returns:
the object with the specified name
Throws:
IllegalStateException - if this method is called on an invalidated session

getAttributeNames

public Enumeration getAttributeNames()
Returns an Enumeration of String objects containing the names of all the objects bound to this session.

Returns:
an Enumeration of String objects specifying the names of all the objects bound to this session
Throws:
IllegalStateException - if this method is called on an invalidated session

getValueNames

public String[] getValueNames()
Deprecated. As of Version 2.2, this method is replaced by getAttributeNames()

Returns:
an array of String objects specifying the names of all the objects bound to this session
Throws:
IllegalStateException - if this method is called on an invalidated session

setAttribute

public void setAttribute(String name,
                         Object value)
Binds an object to this session, using the name specified. If an object of the same name is already bound to the session, the object is replaced.

After this method executes, and if the new object implements HttpSessionBindingListener, the container calls HttpSessionBindingListener.valueBound. The container then notifies any HttpSessionAttributeListeners in the web application.

If an object was already bound to this session of this name that implements HttpSessionBindingListener, its HttpSessionBindingListener.valueUnbound method is called.

If the value passed in is null, this has the same effect as calling removeAttribute().

Parameters:
name - the name to which the object is bound; cannot be null
value - the object to be bound
Throws:
IllegalStateException - if this method is called on an invalidated session

putValue

public void putValue(String name,
                     Object value)
Deprecated. As of Version 2.2, this method is replaced by setAttribute(java.lang.String, java.lang.Object)

Parameters:
name - the name to which the object is bound; cannot be null
value - the object to be bound; cannot be null
Throws:
IllegalStateException - if this method is called on an invalidated session

removeAttribute

public void removeAttribute(String name)
Removes the object bound with the specified name from this session. If the session does not have an object bound with the specified name, this method does nothing.

After this method executes, and if the object implements HttpSessionBindingListener, the container calls HttpSessionBindingListener.valueUnbound. The container then notifies any HttpSessionAttributeListeners in the web application.

Parameters:
name - the name of the object to remove from this session
Throws:
IllegalStateException - if this method is called on an invalidated session

removeValue

public void removeValue(String name)
Deprecated. As of Version 2.2, this method is replaced by removeAttribute(java.lang.String)

Parameters:
name - the name of the object to remove from this session
Throws:
IllegalStateException - if this method is called on an invalidated session

invalidate

public void invalidate()
Invalidates this session then unbinds any objects bound to it.

Throws:
IllegalStateException - if this method is called on an already invalidated session

isNew

public boolean isNew()
Returns true if the client does not yet know about the session or if the client chooses not to join the session. For example, if the server used only cookie-based sessions, and the client had disabled the use of cookies, then a session would be new on each request.

Returns:
true if the server has created a session, but the client has not yet joined
Throws:
IllegalStateException - if this method is called on an already invalidated session
Overview  Package   Class  Tree  Deprecated  Index  Help
JavaTM 2 Platform
Ent. Ed. v1.4
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpSessionActivationListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSessionActivationListener

All Superinterfaces:
EventListener
public interface HttpSessionActivationListener
extends EventListener

Objects that are bound to a session may listen to container events notifying them that sessions will be passivated and that session will be activated. A container that migrates session between VMs or persists sessions is required to notify all attributes bound to sessions implementing HttpSessionActivationListener.

Since:
2.3

Method Summary
void | sessionDidActivate(HttpSessionEvent se) Notification that the session has just been activated.
void | sessionWillPassivate(HttpSessionEvent se) Notification that the session is about to be passivated.

Method Detail

sessionWillPassivate

public void sessionWillPassivate(HttpSessionEvent se)
Notification that the session is about to be passivated.

sessionDidActivate

public void sessionDidActivate(HttpSessionEvent se)
Notification that the session has just been activated.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpSessionAttributeListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSessionAttributeListener

All Superinterfaces:
EventListener
public interface HttpSessionAttributeListener
extends EventListener

This listener interface can be implemented in order to get notifications of changes to the attribute lists of sessions within this web application.

Since:
v 2.3

Method Summary
void | attributeAdded(HttpSessionBindingEvent se) Notification that an attribute has been added to a session.
void | attributeRemoved(HttpSessionBindingEvent se) Notification that an attribute has been removed from a session.
void | attributeReplaced(HttpSessionBindingEvent se) Notification that an attribute has been replaced in a session.

Method Detail

attributeAdded

public void attributeAdded(HttpSessionBindingEvent se)
Notification that an attribute has been added to a session. Called after the attribute is added.

attributeRemoved

public void attributeRemoved(HttpSessionBindingEvent se)
Notification that an attribute has been removed from a session. Called after the attribute is removed.

attributeReplaced

public void attributeReplaced(HttpSessionBindingEvent se)
Notification that an attribute has been replaced in a session. Called after the attribute is replaced.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpSessionBindingEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpSessionBindingEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.servlet.http.HttpSessionEvent
            extended by javax.servlet.http.HttpSessionBindingEvent
All Implemented Interfaces:
Serializable
public class HttpSessionBindingEvent
extends HttpSessionEvent

Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.

The session binds the object by a call to HttpSession.setAttribute and unbinds the object by a call to HttpSession.removeAttribute.

Version:
$Version$
Author:
Various
See Also:
HttpSession, HttpSessionBindingListener, HttpSessionAttributeListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
HttpSessionBindingEvent(HttpSession session, String name)
Constructs an event that notifies an object that it has been bound to or unbound from a session.
HttpSessionBindingEvent(HttpSession session, String name, Object value)
Constructs an event that notifies an object that it has been bound to or unbound from a session.
Method Summary
String | getName() Returns the name with which the attribute is bound to or unbound from the session.
HttpSession | getSession() Return the session that changed.
Object | getValue() Returns the value of the attribute that has been added, removed or replaced.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HttpSessionBindingEvent

public HttpSessionBindingEvent(HttpSession session,
                               String name)
Constructs an event that notifies an object that it has been bound to or unbound from a session. To receive the event, the object must implement HttpSessionBindingListener.

Parameters:
session - the session to which the object is bound or unbound
name - the name with which the object is bound or unbound
See Also:
getName(), getSession()

HttpSessionBindingEvent

public HttpSessionBindingEvent(HttpSession session,
                               String name,
                               Object value)
Constructs an event that notifies an object that it has been bound to or unbound from a session. To receive the event, the object must implement HttpSessionBindingListener.

Parameters:
session - the session to which the object is bound or unbound
name - the name with which the object is bound or unbound
See Also:
getName(), getSession()
Method Detail

getSession

public HttpSession getSession()
Return the session that changed.

Overrides:
getSession in class HttpSessionEvent

getName

public String getName()
Returns the name with which the attribute is bound to or unbound from the session.

Returns:
a string specifying the name with which the object is bound to or unbound from the session

getValue

public Object getValue()
Returns the value of the attribute that has been added, removed or replaced. If the attribute was added (or bound), this is the value of the attribute. If the attrubute was removed (or unbound), this is the value of the removed attribute. If the attribute was replaced, this is the old value of the attribute.

Since:
2.3
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpSessionBindingListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSessionBindingListener

All Superinterfaces:
EventListener
public interface HttpSessionBindingListener
extends EventListener

Causes an object to be notified when it is bound to or unbound from a session. The object is notified by an HttpSessionBindingEvent object. This may be as a result of a servlet programmer explicitly unbinding an attribute from a session, due to a session being invalidated, or due to a session timing out.

Version:
$Version$
Author:
Various
See Also:
HttpSession, HttpSessionBindingEvent

Method Summary
void | valueBound(HttpSessionBindingEvent event) Notifies the object that it is being bound to a session and identifies the session.
void | valueUnbound(HttpSessionBindingEvent event) Notifies the object that it is being unbound from a session and identifies the session.

Method Detail

valueBound

public void valueBound(HttpSessionBindingEvent event)
Notifies the object that it is being bound to a session and identifies the session.

Parameters:
event - the event that identifies the session
See Also:
valueUnbound(javax.servlet.http.HttpSessionBindingEvent)

valueUnbound

public void valueUnbound(HttpSessionBindingEvent event)
Notifies the object that it is being unbound from a session and identifies the session.

Parameters:
event - the event that identifies the session
See Also:
valueBound(javax.servlet.http.HttpSessionBindingEvent)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpSessionContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSessionContext

Deprecated. As of Java(tm) Servlet API 2.1 for security reasons, with no replacement. This interface will be removed in a future version of this API.

public interface HttpSessionContext

Version:
$Version$
Author:
Various
See Also:
HttpSession, HttpSessionBindingEvent, HttpSessionBindingListener

Method Summary
Enumeration | getIds() Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.
HttpSession | getSession(String sessionId) Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.

Method Detail

getSession

public HttpSession getSession(String sessionId)
Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.

getIds

public Enumeration getIds()
Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpSessionEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpSessionEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.servlet.http.HttpSessionEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
HttpSessionBindingEvent
public class HttpSessionEvent
extends EventObject

This is the class representing event notifications for changes to sessions within a web application.

Since:
v 2.3
See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
HttpSessionEvent(HttpSession source)
Construct a session event from the given source.
Method Summary
 HttpSession getSession()
Return the session that changed.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HttpSessionEvent

public HttpSessionEvent(HttpSession source)
Construct a session event from the given source.

Method Detail

getSession

public HttpSession getSession()
Return the session that changed.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpSessionListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSessionListener

All Superinterfaces:
EventListener
public interface HttpSessionListener
extends EventListener

Implementations of this interface are notified of changes to the list of active sessions in a web application. To receive notification events, the implementation class must be configured in the deployment descriptor for the web application.

Since:
v 2.3
See Also:
HttpSessionEvent

Method Summary
void | sessionCreated(HttpSessionEvent se) Notification that a session was created.
void | sessionDestroyed(HttpSessionEvent se) Notification that a session is about to be invalidated.

Method Detail

sessionCreated

public void sessionCreated(HttpSessionEvent se)
Notification that a session was created.

Parameters:
se - the notification event

sessionDestroyed

public void sessionDestroyed(HttpSessionEvent se)
Notification that a session is about to be invalidated.

Parameters:
se - the notification event
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpUtils

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpUtils

java.lang.Object
    extended by javax.servlet.http.HttpUtils
Deprecated. As of Java(tm) Servlet API 2.3. These methods were only useful with the default encoding and have been moved to the request interfaces.

public class HttpUtils
extends Object

Constructor Summary
HttpUtils()
Deprecated. Constructs an empty HttpUtils object.
Method Summary
static StringBuffer | getRequestURL(HttpServletRequest req) Deprecated. Reconstructs the URL the client used to make the request, using information in the HttpServletRequest object.
static Hashtable | parsePostData(int len, ServletInputStream in) Deprecated. Parses data from an HTML form that the client sends to the server using the HTTP POST method and the application/x-www-form-urlencoded MIME type.
static Hashtable | parseQueryString(String s) Deprecated. Parses a query string passed from the client to the server and builds a HashTable object with key-value pairs.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HttpUtils

public HttpUtils()
Deprecated.
Constructs an empty HttpUtils object.

Method Detail

parseQueryString

public static Hashtable parseQueryString(String s)
Deprecated.
Parses a query string passed from the client to the server and builds a HashTable object with key-value pairs. The query string should be in the form of a string packaged by the GET or POST method, that is, it should have key-value pairs in the form key=value, with each pair separated from the next by a & character.

A key can appear more than once in the query string with different values. However, the key appears only once in the hashtable, with its value being an array of strings containing the multiple values sent by the query string.

The keys and values in the hashtable are stored in their decoded form, so any + characters are converted to spaces, and characters sent in hexadecimal notation (like %xx) are converted to ASCII characters.

Parameters:
s - a string containing the query to be parsed
Returns:
a HashTable object built from the parsed key-value pairs
Throws:
IllegalArgumentException - if the query string is invalid

parsePostData

public static Hashtable parsePostData(int len,
                                      ServletInputStream in)
Deprecated.
Parses data from an HTML form that the client sends to the server using the HTTP POST method and the application/x-www-form-urlencoded MIME type.

The data sent by the POST method contains key-value pairs. A key can appear more than once in the POST data with different values. However, the key appears only once in the hashtable, with its value being an array of strings containing the multiple values sent by the POST method.

The keys and values in the hashtable are stored in their decoded form, so any + characters are converted to spaces, and characters sent in hexadecimal notation (like %xx) are converted to ASCII characters.

Parameters:
len - an integer specifying the length, in characters, of the ServletInputStream object that is also passed to this method
in - the ServletInputStream object that contains the data sent from the client
Returns:
a HashTable object built from the parsed key-value pairs
Throws:
IllegalArgumentException - if the data sent by the POST method is invalid

getRequestURL

public static StringBuffer getRequestURL(HttpServletRequest req)
Deprecated.
Reconstructs the URL the client used to make the request, using information in the HttpServletRequest object. The returned URL contains a protocol, server name, port number, and server path, but it does not include query string parameters.

Because this method returns a StringBuffer, not a string, you can modify the URL easily, for example, to append query parameters.

This method is useful for creating redirect messages and for reporting errors.

Parameters:
req - a HttpServletRequest object containing the client's request
Returns:
a StringBuffer object containing the reconstructed URL
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


jsp

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.servlet.jsp

Classes and interfaces for the Core JSP 2.0 API.

See:
Description

Interface Summary
HttpJspPage | The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.
JspPage | The JspPage interface describes the generic interaction that a JSP Page Implementation class must satisfy; pages that use the HTTP protocol are described by the HttpJspPage interface.

Class Summary
ErrorData | Contains information about an error, for error pages.
JspContext | JspContext serves as the base class for the PageContext class and abstracts all information that is not specific to servlets.
JspEngineInfo | The JspEngineInfo is an abstract class that provides information on the current JSP engine.
JspFactory | The JspFactory is an abstract class that defines a number of factory methods available to a JSP page at runtime for the purposes of creating instances of various interfaces and classes used to support the JSP implementation.
JspWriter | The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.
PageContext | PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.

Exception Summary
JspException | A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.
JspTagException | Exception to be used by a Tag Handler to indicate some unrecoverable error.
SkipPageException | Exception to indicate the calling page must cease evaluation.

Package javax.servlet.jsp Description

Classes and interfaces for the Core JSP 2.0 API.

The javax.servlet.jsp package contains a number of classes and interfaces that describe and define the contracts between a JSP page implementation class and the runtime environment provided for an instance of such a class by a conforming JSP container.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HttpJspPage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Interface HttpJspPage

All Superinterfaces:
JspPage, Servlet
public interface HttpJspPage
extends JspPage

The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.

The behaviour is identical to that of the JspPage, except for the signature of the _jspService method, which is now expressible in the Java type system and included explicitly in the interface.

See Also:
JspPage

Method Summary
 void _jspService(HttpServletRequest request, HttpServletResponse response)
The _jspService()method corresponds to the body of the JSP page.
Methods inherited from interface javax.servlet.jsp.JspPage
jspDestroy, jspInit
Methods inherited from interface javax.servlet.Servlet
destroy, getServletConfig, getServletInfo, init, service

Method Detail

_jspService

public void _jspService(HttpServletRequest request,
                        HttpServletResponse response)
                 throws ServletException,
                        IOException
The _jspService()method corresponds to the body of the JSP page. This method is defined automatically by the JSP container and should never be defined by the JSP page author.

If a superclass is specified using the extends attribute, that superclass may choose to perform some actions in its service() method before or after calling the _jspService() method. See using the extends attribute in the JSP_Engine chapter of the JSP specification.

Parameters:
request - Provides client request information to the JSP.
response - Assists the JSP in sending a response to the client.
Throws:
ServletException - Thrown if an error occurred during the processing of the JSP and that the container should take appropriate action to clean up the request.
IOException - Thrown if an error occurred while writing the response for this page.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.servlet.jsp Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.servlet.jsp

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.servlet.jsp.ErrorData
    • class javax.servlet.jsp.JspContext
      • class javax.servlet.jsp.PageContext
    • class javax.servlet.jsp.JspEngineInfo
    • class javax.servlet.jsp.JspFactory
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.jsp.JspException
          • class javax.servlet.jsp.JspTagException
          • class javax.servlet.jsp.SkipPageException
    • class java.io.Writer
      • class javax.servlet.jsp.JspWriter

Interface Hierarchy

  • interface javax.servlet.Servlet
    • interface javax.servlet.jsp.JspPage
      • interface javax.servlet.jsp.HttpJspPage
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


el

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.servlet.jsp.el

Classes and interfaces for the JSP 2.0 Expression Language API.

See:
Description

Interface Summary
FunctionMapper | The interface to a map between EL function names and methods.
VariableResolver | This class is used to customize the way an ExpressionEvaluator resolves variable references at evaluation time.

Class Summary
Expression | The abstract class for a prepared expression.
ExpressionEvaluator | The abstract base class for an expression-language evaluator.

Exception Summary
ELException | Represents any of the exception conditions that arise during the operation evaluation of the evaluator.
ELParseException | Represents a parsing error encountered while parsing an EL expression.

Package javax.servlet.jsp.el Description

Classes and interfaces for the JSP 2.0 Expression Language API.

The JavaServer Pages(tm) (JSP) 2.0 specification provides a portable API for evaluating "EL Expressions". As of JSP 2.0, EL expressions can be placed directly in the template text of JSP pages and tag files.

This package contains a number of classes and interfaces that describe and define programmatic access to the Expression Language evaluator. This API can also be used by an implementation of JSP to evaluate the expressions, but other implementations, like open-coding into Java bytecodes, are allowed. This package is intended to have no dependencies on other portions of the JSP 2.0 specification.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.servlet.jsp.el Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.servlet.jsp.el

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.servlet.jsp.el.Expression
    • class javax.servlet.jsp.el.ExpressionEvaluator
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.jsp.el.ELException
          • class javax.servlet.jsp.el.ELParseException

Interface Hierarchy

  • interface javax.servlet.jsp.el.FunctionMapper
  • interface javax.servlet.jsp.el.VariableResolver
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ELException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Class ELException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.servlet.jsp.el.ELException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ELParseException
public class ELException
extends Exception

Represents any of the exception conditions that arise during the operation evaluation of the evaluator.

Since:
2.0
See Also:
Serialized Form

Constructor Summary
ELException()
Creates an ELException with no detail message.
ELException(String pMessage)
Creates an ELException with the provided detail message.
ELException(String pMessage, Throwable pRootCause)
Creates an ELException with the given detail message and root cause.
ELException(Throwable pRootCause)
Creates an ELException with the given root cause.
Method Summary
 Throwable getRootCause()
Returns the root cause.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ELException

public ELException()
Creates an ELException with no detail message.

ELException

public ELException(String pMessage)
Creates an ELException with the provided detail message.

Parameters:
pMessage - the detail message

ELException

public ELException(Throwable pRootCause)
Creates an ELException with the given root cause.

Parameters:
pRootCause - the originating cause of this exception

ELException

public ELException(String pMessage,
                   Throwable pRootCause)
Creates an ELException with the given detail message and root cause.

Parameters:
pMessage - the detail message
pRootCause - the originating cause of this exception
Method Detail

getRootCause

public Throwable getRootCause()
Returns the root cause.

Returns:
the root cause of this exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ELParseException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Class ELParseException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.servlet.jsp.el.ELException
                extended by javax.servlet.jsp.el.ELParseException
All Implemented Interfaces:
Serializable
public class ELParseException
extends ELException

Represents a parsing error encountered while parsing an EL expression.

Since:
2.0
See Also:
Serialized Form

Constructor Summary
ELParseException()
Creates an ELParseException with no detail message.
ELParseException(String pMessage)
Creates an ELParseException with the provided detail message.
Methods inherited from class javax.servlet.jsp.el.ELException
getRootCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ELParseException

public ELParseException()
Creates an ELParseException with no detail message.

ELParseException

public ELParseException(String pMessage)
Creates an ELParseException with the provided detail message.

Parameters:
pMessage - the detail message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Expression

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Class Expression

java.lang.Object
    extended by javax.servlet.jsp.el.Expression
public abstract class Expression
extends Object

The abstract class for a prepared expression.

An instance of an Expression can be obtained via from an ExpressionEvaluator instance.

An Expression may or not have done a syntactic parse of the expression. A client invoking the evaluate() method should be ready for the case where ELParseException exceptions are raised.

Since:
2.0

Constructor Summary
Expression()
Method Summary
abstract  Object evaluate(VariableResolver vResolver)
Evaluates an expression that was previously prepared.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Expression

public Expression()
Method Detail

evaluate

public abstract Object evaluate(VariableResolver vResolver)
                         throws ELException
Evaluates an expression that was previously prepared. In some implementations preparing an expression involves full syntactic validation, but others may not do so. Evaluating the expression may raise an ELParseException as well as other ELExceptions due to run-time evaluation.

Parameters:
vResolver - A VariableResolver instance that can be used at runtime to resolve the name of implicit objects into Objects.
Returns:
The result of the expression evaluation.
Throws:
ELException - Thrown if the expression evaluation failed.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ExpressionEvaluator

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Class ExpressionEvaluator

java.lang.Object
    extended by javax.servlet.jsp.el.ExpressionEvaluator
public abstract class ExpressionEvaluator
extends Object

The abstract base class for an expression-language evaluator. Classes that implement an expression language expose their functionality via this abstract class.

An instance of the ExpressionEvaluator can be obtained via the JspContext / PageContext

The parseExpression() and evaluate() methods must be thread-safe. That is, multiple threads may call these methods on the same ExpressionEvaluator object simultaneously. Implementations should synchronize access if they depend on transient state. Implementations should not, however, assume that only one object of each ExpressionEvaluator type will be instantiated; global caching should therefore be static.

Only a single EL expression, starting with '${' and ending with '}', can be parsed or evaluated at a time. EL expressions cannot be mixed with static text. For example, attempting to parse or evaluate "abc${1+1}def${1+1}ghi" or even "${1+1}${1+1}" will cause an ELException to be thrown.

The following are examples of syntactically legal EL expressions:

  • ${person.lastName}
  • ${8 * 8}
  • ${my:reverse('hello')}

Since:
2.0

Constructor Summary
ExpressionEvaluator()
Method Summary
abstract Object | evaluate(String expression, Class expectedType, VariableResolver vResolver, FunctionMapper fMapper) Evaluates an expression.
abstract Expression | parseExpression(String expression, Class expectedType, FunctionMapper fMapper) Prepare an expression for later evaluation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExpressionEvaluator

public ExpressionEvaluator()
Method Detail

parseExpression

public abstract Expression parseExpression(String expression,
                                           Class expectedType,
                                           FunctionMapper fMapper)
                                    throws ELException
Prepare an expression for later evaluation. This method should perform syntactic validation of the expression; if in doing so it detects errors, it should raise an ELParseException.

Parameters:
expression - The expression to be evaluated.
expectedType - The expected type of the result of the evaluation
fMapper - A FunctionMapper to resolve functions found in the expression. It can be null, in which case no functions are supported for this invocation. The ExpressionEvaluator must not hold on to the FunctionMapper reference after returning from parseExpression(). The Expression object returned must invoke the same functions regardless of whether the mappings in the provided FunctionMapper instance change between calling ExpressionEvaluator.parseExpression() and Expression.evaluate().
Returns:
The Expression object encapsulating the arguments.
Throws:
ELException - Thrown if parsing errors were found.

evaluate

public abstract Object evaluate(String expression,
                                Class expectedType,
                                VariableResolver vResolver,
                                FunctionMapper fMapper)
                         throws ELException
Evaluates an expression. This method may perform some syntactic validation and, if so, it should raise an ELParseException error if it encounters syntactic errors. EL evaluation errors should cause an ELException to be raised.

Parameters:
expression - The expression to be evaluated.
expectedType - The expected type of the result of the evaluation
vResolver - A VariableResolver instance that can be used at runtime to resolve the name of implicit objects into Objects.
fMapper - A FunctionMapper to resolve functions found in the expression. It can be null, in which case no functions are supported for this invocation.
Returns:
The result of the expression evaluation.
Throws:
ELException - Thrown if the expression evaluation failed.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FunctionMapper

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Interface FunctionMapper

public interface FunctionMapper

The interface to a map between EL function names and methods.

Classes implementing this interface may, for instance, consult tag library information to resolve the map.

Since:
2.0

Method Summary
 Method resolveFunction(String prefix, String localName)
Resolves the specified local name and prefix into a Java.lang.Method.

Method Detail

resolveFunction

public Method resolveFunction(String prefix,
                              String localName)
Resolves the specified local name and prefix into a Java.lang.Method. Returns null if the prefix and local name are not found.

Parameters:
prefix - the prefix of the function, or "" if no prefix.
localName - the short name of the function
Returns:
the result of the method mapping. Null means no entry found.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


VariableResolver

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Interface VariableResolver

public interface VariableResolver

This class is used to customize the way an ExpressionEvaluator resolves variable references at evaluation time. For example, instances of this class can implement their own variable lookup mechanisms, or introduce the notion of "implicit variables" which override any other variables. An instance of this class should be passed when evaluating an expression.

An instance of this class includes the context against which resolution will happen

Since:
2.0

Method Summary
 Object resolveVariable(String pName)
Resolves the specified variable.

Method Detail

resolveVariable

public Object resolveVariable(String pName)
                       throws ELException
Resolves the specified variable. Returns null if the variable is not found.

Parameters:
pName - the name of the variable to resolve
Returns:
the result of the variable resolution
Throws:
ELException - if a failure occurred while trying to resolve the given variable
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ErrorData

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class ErrorData

java.lang.Object
    extended by javax.servlet.jsp.ErrorData
public final class ErrorData
extends Object

Contains information about an error, for error pages. The information contained in this instance is meaningless if not used in the context of an error page. To indicate a JSP is an error page, the page author must set the isErrorPage attribute of the page directive to "true".

Since:
2.0
See Also:
PageContext.getErrorData()

Constructor Summary
ErrorData(Throwable throwable, int statusCode, String uri, String servletName)
Creates a new ErrorData object.
Method Summary
String | getRequestURI() Returns the request URI.
String | getServletName() Returns the name of the servlet invoked.
int | getStatusCode() Returns the status code of the error.
Throwable | getThrowable() Returns the Throwable that caused the error.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ErrorData

public ErrorData(Throwable throwable,
                 int statusCode,
                 String uri,
                 String servletName)
Creates a new ErrorData object.

Parameters:
throwable - The Throwable that is the cause of the error
statusCode - The status code of the error
uri - The request URI
servletName - The name of the servlet invoked
Method Detail

getThrowable

public Throwable getThrowable()
Returns the Throwable that caused the error.

Returns:
The Throwable that caused the error

getStatusCode

public int getStatusCode()
Returns the status code of the error.

Returns:
The status code of the error

getRequestURI

public String getRequestURI()
Returns the request URI.

Returns:
The request URI

getServletName

public String getServletName()
Returns the name of the servlet invoked.

Returns:
The name of the servlet invoked
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JspContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspContext

java.lang.Object
    extended by javax.servlet.jsp.JspContext
Direct Known Subclasses:
PageContext
public abstract class JspContext
extends Object

JspContext serves as the base class for the PageContext class and abstracts all information that is not specific to servlets. This allows for Simple Tag Extensions to be used outside of the context of a request/response Servlet.

The JspContext provides a number of facilities to the page/component author and page implementor, including:

  • a single API to manage the various scoped namespaces
  • a mechanism to obtain the JspWriter for output
  • a mechanism to expose page directive attributes to the scripting environment

Methods Intended for Container Generated Code

The following methods enable the management of nested JspWriter streams to implement Tag Extensions: pushBody() and popBody()

Methods Intended for JSP authors

Some methods provide uniform access to the diverse objects representing scopes. The implementation must use the underlying machinery corresponding to that scope, so information can be passed back and forth between the underlying environment (e.g. Servlets) and JSP pages. The methods are: setAttribute(), getAttribute(), findAttribute(), removeAttribute(), getAttributesScope() and getAttributeNamesInScope().

The following methods provide convenient access to implicit objects: getOut()

The following methods provide programmatic access to the Expression Language evaluator: getExpressionEvaluator(), getVariableResolver()

Since:
2.0

Constructor Summary
JspContext()
Sole constructor.
Method Summary
abstract  Object findAttribute(String name)
Searches for the named attribute in page, request, session (if valid), and application scope(s) in order and returns the value associated or null.
abstract  Object getAttribute(String name)
Returns the object associated with the name in the page scope or null if not found.
abstract  Object getAttribute(String name, int scope)
Return the object associated with the name in the specified scope or null if not found.
abstract  Enumeration getAttributeNamesInScope(int scope)
Enumerate all the attributes in a given scope.
abstract  int getAttributesScope(String name)
Get the scope where a given attribute is defined.
abstract  ExpressionEvaluator getExpressionEvaluator()
Provides programmatic access to the ExpressionEvaluator.
abstract  JspWriter getOut()
The current value of the out object (a JspWriter).
abstract  VariableResolver getVariableResolver()
Returns an instance of a VariableResolver that provides access to the implicit objects specified in the JSP specification using this JspContext as the context object.
 JspWriter popBody()
Return the previous JspWriter "out" saved by the matching pushBody(), and update the value of the "out" attribute in the page scope attribute namespace of the JspContext.
 JspWriter pushBody(Writer writer)
Return a new JspWriter object that sends output to the provided Writer.
abstract  void removeAttribute(String name)
Remove the object reference associated with the given name from all scopes.
abstract  void removeAttribute(String name, int scope)
Remove the object reference associated with the specified name in the given scope.
abstract  void setAttribute(String name, Object value)
Register the name and value specified with page scope semantics.
abstract  void setAttribute(String name, Object value, int scope)
Register the name and value specified with appropriate scope semantics.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JspContext

public JspContext()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

setAttribute

public abstract void setAttribute(String name,
                                  Object value)
Register the name and value specified with page scope semantics. If the value passed in is null, this has the same effect as calling removeAttribute( name, PageContext.PAGE_SCOPE ).

Parameters:
name - the name of the attribute to set
value - the value to associate with the name, or null if the attribute is to be removed from the page scope.
Throws:
NullPointerException - if the name is null

setAttribute

public abstract void setAttribute(String name,
                                  Object value,
                                  int scope)
Register the name and value specified with appropriate scope semantics. If the value passed in is null, this has the same effect as calling removeAttribute( name, scope ).

Parameters:
name - the name of the attribute to set
value - the object to associate with the name, or null if the attribute is to be removed from the specified scope.
scope - the scope with which to associate the name/object
Throws:
NullPointerException - if the name is null
IllegalArgumentException - if the scope is invalid
IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.

getAttribute

public abstract Object getAttribute(String name)
Returns the object associated with the name in the page scope or null if not found.

Parameters:
name - the name of the attribute to get
Returns:
the object associated with the name in the page scope or null if not found.
Throws:
NullPointerException - if the name is null

getAttribute

public abstract Object getAttribute(String name,
                                    int scope)
Return the object associated with the name in the specified scope or null if not found.

Parameters:
name - the name of the attribute to set
scope - the scope with which to associate the name/object
Returns:
the object associated with the name in the specified scope or null if not found.
Throws:
NullPointerException - if the name is null
IllegalArgumentException - if the scope is invalid
IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.

findAttribute

public abstract Object findAttribute(String name)
Searches for the named attribute in page, request, session (if valid), and application scope(s) in order and returns the value associated or null.

Parameters:
name - the name of the attribute to search for
Returns:
the value associated or null
Throws:
NullPointerException - if the name is null

removeAttribute

public abstract void removeAttribute(String name)
Remove the object reference associated with the given name from all scopes. Does nothing if there is no such object.

Parameters:
name - The name of the object to remove.
Throws:
NullPointerException - if the name is null

removeAttribute

public abstract void removeAttribute(String name,
                                     int scope)
Remove the object reference associated with the specified name in the given scope. Does nothing if there is no such object.

Parameters:
name - The name of the object to remove.
scope - The scope where to look.
Throws:
IllegalArgumentException - if the scope is invalid
IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.
NullPointerException - if the name is null

getAttributesScope

public abstract int getAttributesScope(String name)
Get the scope where a given attribute is defined.

Parameters:
name - the name of the attribute to return the scope for
Returns:
the scope of the object associated with the name specified or 0
Throws:
NullPointerException - if the name is null

getAttributeNamesInScope

public abstract Enumeration getAttributeNamesInScope(int scope)
Enumerate all the attributes in a given scope.

Parameters:
scope - the scope to enumerate all the attributes for
Returns:
an enumeration of names (java.lang.String) of all the attributes the specified scope
Throws:
IllegalArgumentException - if the scope is invalid
IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.

getOut

public abstract JspWriter getOut()
The current value of the out object (a JspWriter).

Returns:
the current JspWriter stream being used for client response

getExpressionEvaluator

public abstract ExpressionEvaluator getExpressionEvaluator()
Provides programmatic access to the ExpressionEvaluator. The JSP Container must return a valid instance of an ExpressionEvaluator that can parse EL expressions.

Returns:
A valid instance of an ExpressionEvaluator.
Since:
2.0

getVariableResolver

public abstract VariableResolver getVariableResolver()
Returns an instance of a VariableResolver that provides access to the implicit objects specified in the JSP specification using this JspContext as the context object.

Returns:
A valid instance of a VariableResolver.
Since:
2.0

pushBody

public JspWriter pushBody(Writer writer)
Return a new JspWriter object that sends output to the provided Writer. Saves the current "out" JspWriter, and updates the value of the "out" attribute in the page scope attribute namespace of the JspContext.

The returned JspWriter must implement all methods and behave as though it were unbuffered. More specifically:

  • clear() must throw an IOException
  • clearBuffer() does nothing
  • getBufferSize() always returns 0
  • getRemaining() always returns 0

Parameters:
writer - The Writer for the returned JspWriter to send output to.
Returns:
a new JspWriter that writes to the given Writer.
Since:
2.0

popBody

public JspWriter popBody()
Return the previous JspWriter "out" saved by the matching pushBody(), and update the value of the "out" attribute in the page scope attribute namespace of the JspContext.

Returns:
the saved JspWriter.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JspEngineInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspEngineInfo

java.lang.Object
    extended by javax.servlet.jsp.JspEngineInfo
public abstract class JspEngineInfo
extends Object

The JspEngineInfo is an abstract class that provides information on the current JSP engine.

Constructor Summary
JspEngineInfo()
Sole constructor.
Method Summary
abstract  String getSpecificationVersion()
Return the version number of the JSP specification that is supported by this JSP engine.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JspEngineInfo

public JspEngineInfo()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

getSpecificationVersion

public abstract String getSpecificationVersion()
Return the version number of the JSP specification that is supported by this JSP engine.

Specification version numbers that consists of positive decimal integers separated by periods ".", for example, "2.0" or "1.2.3.4.5.6.7". This allows an extensible number to be used to represent major, minor, micro, etc versions. The version number must begin with a number.

Returns:
the specification version, null is returned if it is not known
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JspException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.servlet.jsp.JspException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
JspTagException, SkipPageException
public class JspException
extends Exception

A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.

See Also:
Serialized Form

Constructor Summary
JspException()
Construct a JspException.
JspException(String msg)
Constructs a new JSP exception with the specified message.
JspException(String message, Throwable rootCause)
Constructs a new JSP exception when the JSP needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
JspException(Throwable rootCause)
Constructs a new JSP exception when the JSP needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.
Method Summary
 Throwable getRootCause()
Returns the exception that caused this JSP exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JspException

public JspException()
Construct a JspException.

JspException

public JspException(String msg)
Constructs a new JSP exception with the specified message. The message can be written to the server log and/or displayed for the user.

Parameters:
msg - a String specifying the text of the exception message

JspException

public JspException(String message,
                    Throwable rootCause)
Constructs a new JSP exception when the JSP needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.

Parameters:
message - a String containing the text of the exception message
rootCause - the Throwable exception that interfered with the servlet's normal operation, making this servlet exception necessary

JspException

public JspException(Throwable rootCause)
Constructs a new JSP exception when the JSP needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation. The exception's message is based on the localized message of the underlying exception.

This method calls the getLocalizedMessage method on the Throwable exception to get a localized exception message. When subclassing JspException, this method can be overridden to create an exception message designed for a specific locale.

Parameters:
rootCause - the Throwable exception that interfered with the JSP's normal operation, making the JSP exception necessary
Method Detail

getRootCause

public Throwable getRootCause()
Returns the exception that caused this JSP exception.

Returns:
the Throwable that caused this JSP exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JspFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspFactory

java.lang.Object
    extended by javax.servlet.jsp.JspFactory
public abstract class JspFactory
extends Object

The JspFactory is an abstract class that defines a number of factory methods available to a JSP page at runtime for the purposes of creating instances of various interfaces and classes used to support the JSP implementation.

A conformant JSP Engine implementation will, during it's initialization instantiate an implementation dependent subclass of this class, and make it globally available for use by JSP implementation classes by registering the instance created with this class via the static setDefaultFactory() method.

The PageContext and the JspEngineInfo classes are the only implementation-dependent classes that can be created from the factory.

JspFactory objects should not be used by JSP page authors.

Constructor Summary
JspFactory()
Sole constructor.
Method Summary
static JspFactory | getDefaultFactory() Returns the default factory for this implementation.
abstract JspEngineInfo | getEngineInfo() called to get implementation-specific information on the current JSP engine.
abstract PageContext | getPageContext(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int buffer, boolean autoflush) obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.
abstract void | releasePageContext(PageContext pc) called to release a previously allocated PageContext object.
static void | setDefaultFactory(JspFactory deflt) set the default factory for this implementation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JspFactory

public JspFactory()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

setDefaultFactory

public static void setDefaultFactory(JspFactory deflt)

set the default factory for this implementation. It is illegal for any principal other than the JSP Engine runtime to call this method.

Parameters:
deflt - The default factory implementation

getDefaultFactory

public static JspFactory getDefaultFactory()
Returns the default factory for this implementation.

Returns:
the default factory for this implementation

getPageContext

public abstract PageContext getPageContext(Servlet servlet,
                                           ServletRequest request,
                                           ServletResponse response,
                                           String errorPageURL,
                                           boolean needsSession,
                                           int buffer,
                                           boolean autoflush)

obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.

This method is typically called early in the processing of the _jspService() method of a JSP implementation class in order to obtain a PageContext object for the request being processed.

Invoking this method shall result in the PageContext.initialize() method being invoked. The PageContext returned is properly initialized.

All PageContext objects obtained via this method shall be released by invoking releasePageContext().

Parameters:
servlet - the requesting servlet
request - the current request pending on the servlet
response - the current response pending on the servlet
errorPageURL - the URL of the error page for the requesting JSP, or null
needsSession - true if the JSP participates in a session
buffer - size of buffer in bytes, PageContext.NO_BUFFER if no buffer, PageContext.DEFAULT_BUFFER if implementation default.
autoflush - should the buffer autoflush to the output stream on buffer overflow, or throw an IOException?
Returns:
the page context
See Also:
PageContext

releasePageContext

public abstract void releasePageContext(PageContext pc)

called to release a previously allocated PageContext object. Results in PageContext.release() being invoked. This method should be invoked prior to returning from the _jspService() method of a JSP implementation class.

Parameters:
pc - A PageContext previously obtained by getPageContext()

getEngineInfo

public abstract JspEngineInfo getEngineInfo()

called to get implementation-specific information on the current JSP engine.

Returns:
a JspEngineInfo object describing the current JSP engine
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JspPage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Interface JspPage

All Superinterfaces:
Servlet
All Known Subinterfaces:
HttpJspPage
public interface JspPage
extends Servlet

The JspPage interface describes the generic interaction that a JSP Page Implementation class must satisfy; pages that use the HTTP protocol are described by the HttpJspPage interface.

Two plus One Methods

The interface defines a protocol with 3 methods; only two of them: jspInit() and jspDestroy() are part of this interface as the signature of the third method: _jspService() depends on the specific protocol used and cannot be expressed in a generic way in Java.

A class implementing this interface is responsible for invoking the above methods at the appropriate time based on the corresponding Servlet-based method invocations.

The jspInit() and jspDestroy() methods can be defined by a JSP author, but the _jspService() method is defined automatically by the JSP processor based on the contents of the JSP page.

_jspService()

The _jspService()method corresponds to the body of the JSP page. This method is defined automatically by the JSP container and should never be defined by the JSP page author.

If a superclass is specified using the extends attribute, that superclass may choose to perform some actions in its service() method before or after calling the _jspService() method. See using the extends attribute in the JSP_Engine chapter of the JSP specification.

The specific signature depends on the protocol supported by the JSP page.

 public void _jspService(ServletRequestSubtype request,
                             ServletResponseSubtype response)
        throws ServletException, IOException;

Method Summary
 void jspDestroy()
The jspDestroy() method is invoked when the JSP page is about to be destroyed.
 void jspInit()
The jspInit() method is invoked when the JSP page is initialized.
Methods inherited from interface javax.servlet.Servlet
destroy, getServletConfig, getServletInfo, init, service

Method Detail

jspInit

public void jspInit()
The jspInit() method is invoked when the JSP page is initialized. It is the responsibility of the JSP implementation (and of the class mentioned by the extends attribute, if present) that at this point invocations to the getServletConfig() method will return the desired value. A JSP page can override this method by including a definition for it in a declaration element. A JSP page should redefine the init() method from Servlet.

jspDestroy

public void jspDestroy()
The jspDestroy() method is invoked when the JSP page is about to be destroyed. A JSP page can override this method by including a definition for it in a declaration element. A JSP page should redefine the destroy() method from Servlet.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JspTagException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspTagException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.servlet.jsp.JspException
                extended by javax.servlet.jsp.JspTagException
All Implemented Interfaces:
Serializable
public class JspTagException
extends JspException

Exception to be used by a Tag Handler to indicate some unrecoverable error. This error is to be caught by the top level of the JSP page and will result in an error page.

See Also:
Serialized Form

Constructor Summary
JspTagException()
Constructs a new JspTagException with no message.
JspTagException(String msg)
Constructs a new JspTagException with the specified message.
JspTagException(String message, Throwable rootCause)
Constructs a new JspTagException when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
JspTagException(Throwable rootCause)
Constructs a new JSP Tag exception when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.
Methods inherited from class javax.servlet.jsp.JspException
getRootCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JspTagException

public JspTagException(String msg)
Constructs a new JspTagException with the specified message. The message can be written to the server log and/or displayed for the user.

Parameters:
msg - a String specifying the text of the exception message

JspTagException

public JspTagException()
Constructs a new JspTagException with no message.

JspTagException

public JspTagException(String message,
                       Throwable rootCause)
Constructs a new JspTagException when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.

Parameters:
message - a String containing the text of the exception message
rootCause - the Throwable exception that interfered with the JSP Tag's normal operation, making this JSP Tag exception necessary
Since:
2.0

JspTagException

public JspTagException(Throwable rootCause)
Constructs a new JSP Tag exception when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation. The exception's message is based on the localized message of the underlying exception.

This method calls the getLocalizedMessage method on the Throwable exception to get a localized exception message. When subclassing JspTagException, this method can be overridden to create an exception message designed for a specific locale.

Parameters:
rootCause - the Throwable exception that interfered with the JSP Tag's normal operation, making the JSP Tag exception necessary
Since:
2.0
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JspWriter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspWriter

java.lang.Object
    extended by java.io.Writer
        extended by javax.servlet.jsp.JspWriter
Direct Known Subclasses:
BodyContent
public abstract class JspWriter
extends Writer

The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.

This abstract class emulates some of the functionality found in the java.io.BufferedWriter and java.io.PrintWriter classes, however it differs in that it throws java.io.IOException from the print methods while PrintWriter does not.

Buffering

The initial JspWriter object is associated with the PrintWriter object of the ServletResponse in a way that depends on whether the page is or is not buffered. If the page is not buffered, output written to this JspWriter object will be written through to the PrintWriter directly, which will be created if necessary by invoking the getWriter() method on the response object. But if the page is buffered, the PrintWriter object will not be created until the buffer is flushed and operations like setContentType() are legal. Since this flexibility simplifies programming substantially, buffering is the default for JSP pages.

Buffering raises the issue of what to do when the buffer is exceeded. Two approaches can be taken:

  • Exceeding the buffer is not a fatal error; when the buffer is exceeded, just flush the output.
  • Exceeding the buffer is a fatal error; when the buffer is exceeded, raise an exception.

Both approaches are valid, and thus both are supported in the JSP technology. The behavior of a page is controlled by the autoFlush attribute, which defaults to true. In general, JSP pages that need to be sure that correct and complete data has been sent to their client may want to set autoFlush to false, with a typical case being that where the client is an application itself. On the other hand, JSP pages that send data that is meaningful even when partially constructed may want to set autoFlush to true; such as when the data is sent for immediate display through a browser. Each application will need to consider their specific needs.

An alternative considered was to make the buffer size unbounded; but, this had the disadvantage that runaway computations would consume an unbounded amount of resources.

The "out" implicit variable of a JSP implementation class is of this type. If the page directive selects autoflush="true" then all the I/O operations on this class shall automatically flush the contents of the buffer if an overflow condition would result if the current operation were performed without a flush. If autoflush="false" then all the I/O operations on this class shall throw an IOException if performing the current operation would result in a buffer overflow condition.

See Also:
Writer, BufferedWriter, PrintWriter

Field Summary
protected boolean | autoFlush Whether the JspWriter is autoflushing.
protected int | bufferSize The size of the buffer used by the JspWriter.
static int | DEFAULT_BUFFER Constant indicating that the Writer is buffered and is using the implementation default buffer size.
static int | NO_BUFFER Constant indicating that the Writer is not buffering output.
static int | UNBOUNDED_BUFFER Constant indicating that the Writer is buffered and is unbounded; this is used in BodyContent.
Fields inherited from class java.io.Writer
lock
Constructor Summary
protected JspWriter(int bufferSize, boolean autoFlush)
Protected constructor.
Method Summary
abstract void | clear() Clear the contents of the buffer.
abstract void | clearBuffer() Clears the current contents of the buffer.
abstract void | close() Close the stream, flushing it first.
abstract void | flush() Flush the stream.
int | getBufferSize() This method returns the size of the buffer used by the JspWriter.
abstract int | getRemaining() This method returns the number of unused bytes in the buffer.
boolean | isAutoFlush() This method indicates whether the JspWriter is autoFlushing.
abstract void | newLine() Write a line separator.
abstract void | print(boolean b) Print a boolean value.
abstract void | print(char c) Print a character.
abstract void | print(char[] s) Print an array of characters.
abstract void | print(double d) Print a double-precision floating-point number.
abstract void | print(float f) Print a floating-point number.
abstract void | print(int i) Print an integer.
abstract void | print(long l) Print a long integer.
abstract void | print(Object obj) Print an object.
abstract void | print(String s) Print a string.
abstract void | println() Terminate the current line by writing the line separator string.
abstract void | println(boolean x) Print a boolean value and then terminate the line.
abstract void | println(char x) Print a character and then terminate the line.
abstract void | println(char[] x) Print an array of characters and then terminate the line.
abstract void | println(double x) Print a double-precision floating-point number and then terminate the line.
abstract void | println(float x) Print a floating-point number and then terminate the line.
abstract void | println(int x) Print an integer and then terminate the line.
abstract void | println(long x) Print a long integer and then terminate the line.
abstract void | println(Object x) Print an Object and then terminate the line.
abstract void | println(String x) Print a String and then terminate the line.
Methods inherited from class java.io.Writer
write, write, write, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NO_BUFFER

public static final int NO_BUFFER
Constant indicating that the Writer is not buffering output.

See Also:
Constant Field Values

DEFAULT_BUFFER

public static final int DEFAULT_BUFFER
Constant indicating that the Writer is buffered and is using the implementation default buffer size.

See Also:
Constant Field Values

UNBOUNDED_BUFFER

public static final int UNBOUNDED_BUFFER
Constant indicating that the Writer is buffered and is unbounded; this is used in BodyContent.

See Also:
Constant Field Values

bufferSize

protected int bufferSize
The size of the buffer used by the JspWriter.

autoFlush

protected boolean autoFlush
Whether the JspWriter is autoflushing.

Constructor Detail

JspWriter

protected JspWriter(int bufferSize,
                    boolean autoFlush)
Protected constructor.

Parameters:
bufferSize - the size of the buffer to be used by the JspWriter
autoFlush - whether the JspWriter should be autoflushing
Method Detail

newLine

public abstract void newLine()
                      throws IOException
Write a line separator. The line separator string is defined by the system property line.separator, and is not necessarily a single newline ('\n') character.

Throws:
IOException - If an I/O error occurs

print

public abstract void print(boolean b)
                    throws IOException
Print a boolean value. The string produced by String.valueOf(boolean) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
b - The boolean to be printed
Throws:
IOException - If an error occured while writing

print

public abstract void print(char c)
                    throws IOException
Print a character. The character is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
c - The char to be printed
Throws:
IOException - If an error occured while writing

print

public abstract void print(int i)
                    throws IOException
Print an integer. The string produced by String.valueOf(int) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
i - The int to be printed
Throws:
IOException - If an error occured while writing
See Also:
Integer.toString(int)

print

public abstract void print(long l)
                    throws IOException
Print a long integer. The string produced by String.valueOf(long) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
l - The long to be printed
Throws:
IOException - If an error occured while writing
See Also:
Long.toString(long)

print

public abstract void print(float f)
                    throws IOException
Print a floating-point number. The string produced by String.valueOf(float) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
f - The float to be printed
Throws:
IOException - If an error occured while writing
See Also:
Float.toString(float)

print

public abstract void print(double d)
                    throws IOException
Print a double-precision floating-point number. The string produced by String.valueOf(double) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
d - The double to be printed
Throws:
IOException - If an error occured while writing
See Also:
Double.toString(double)

print

public abstract void print(char[] s)
                    throws IOException
Print an array of characters. The characters are written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
s - The array of chars to be printed
Throws:
NullPointerException - If s is null
IOException - If an error occured while writing

print

public abstract void print(String s)
                    throws IOException
Print a string. If the argument is null then the string "null" is printed. Otherwise, the string's characters are written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
s - The String to be printed
Throws:
IOException - If an error occured while writing

print

public abstract void print(Object obj)
                    throws IOException
Print an object. The string produced by the String.valueOf(Object) method is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
obj - The Object to be printed
Throws:
IOException - If an error occured while writing
See Also:
Object.toString()

println

public abstract void println()
                      throws IOException
Terminate the current line by writing the line separator string. The line separator string is defined by the system property line.separator, and is not necessarily a single newline character ('\n').

Throws:
IOException - If an error occured while writing

println

public abstract void println(boolean x)
                      throws IOException
Print a boolean value and then terminate the line. This method behaves as though it invokes print(boolean) and then println().

Parameters:
x - the boolean to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(char x)
                      throws IOException
Print a character and then terminate the line. This method behaves as though it invokes print(char) and then println().

Parameters:
x - the char to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(int x)
                      throws IOException
Print an integer and then terminate the line. This method behaves as though it invokes print(int) and then println().

Parameters:
x - the int to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(long x)
                      throws IOException
Print a long integer and then terminate the line. This method behaves as though it invokes print(long) and then println().

Parameters:
x - the long to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(float x)
                      throws IOException
Print a floating-point number and then terminate the line. This method behaves as though it invokes print(float) and then println().

Parameters:
x - the float to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(double x)
                      throws IOException
Print a double-precision floating-point number and then terminate the line. This method behaves as though it invokes print(double) and then println().

Parameters:
x - the double to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(char[] x)
                      throws IOException
Print an array of characters and then terminate the line. This method behaves as though it invokes print(char[]) and then println().

Parameters:
x - the char[] to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(String x)
                      throws IOException
Print a String and then terminate the line. This method behaves as though it invokes print(String) and then println().

Parameters:
x - the String to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(Object x)
                      throws IOException
Print an Object and then terminate the line. This method behaves as though it invokes print(Object) and then println().

Parameters:
x - the Object to write
Throws:
IOException - If an error occured while writing

clear

public abstract void clear()
                    throws IOException
Clear the contents of the buffer. If the buffer has been already been flushed then the clear operation shall throw an IOException to signal the fact that some data has already been irrevocably written to the client response stream.

Throws:
IOException - If an I/O error occurs

clearBuffer

public abstract void clearBuffer()
                          throws IOException
Clears the current contents of the buffer. Unlike clear(), this method will not throw an IOException if the buffer has already been flushed. It merely clears the current content of the buffer and returns.

Throws:
IOException - If an I/O error occurs

flush

public abstract void flush()
                    throws IOException
Flush the stream. If the stream has saved any characters from the various write() methods in a buffer, write them immediately to their intended destination. Then, if that destination is another character or byte stream, flush it. Thus one flush() invocation will flush all the buffers in a chain of Writers and OutputStreams.

The method may be invoked indirectly if the buffer size is exceeded.

Once a stream has been closed, further write() or flush() invocations will cause an IOException to be thrown.

Throws:
IOException - If an I/O error occurs

close

public abstract void close()
                    throws IOException
Close the stream, flushing it first.

This method needs not be invoked explicitly for the initial JspWriter as the code generated by the JSP container will automatically include a call to close().

Closing a previously-closed stream, unlike flush(), has no effect.

Throws:
IOException - If an I/O error occurs

getBufferSize

public int getBufferSize()
This method returns the size of the buffer used by the JspWriter.

Returns:
the size of the buffer in bytes, or 0 is unbuffered.

getRemaining

public abstract int getRemaining()
This method returns the number of unused bytes in the buffer.

Returns:
the number of bytes unused in the buffer

isAutoFlush

public boolean isAutoFlush()
This method indicates whether the JspWriter is autoFlushing.

Returns:
if this JspWriter is auto flushing or throwing IOExceptions on buffer overflow conditions
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PageContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class PageContext

java.lang.Object
    extended by javax.servlet.jsp.JspContext
        extended by javax.servlet.jsp.PageContext
public abstract class PageContext
extends JspContext

PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.

A PageContext instance provides access to all the namespaces associated with a JSP page, provides access to several page attributes, as well as a layer above the implementation details. Implicit objects are added to the pageContext automatically.

The PageContext class is an abstract class, designed to be extended to provide implementation dependent implementations thereof, by conformant JSP engine runtime environments. A PageContext instance is obtained by a JSP implementation class by calling the JspFactory.getPageContext() method, and is released by calling JspFactory.releasePageContext().

An example of how PageContext, JspFactory, and other classes can be used within a JSP Page Implementation object is given elsewhere.

The PageContext provides a number of facilities to the page/component author and page implementor, including:

  • a single API to manage the various scoped namespaces
  • a number of convenience API's to access various public objects
  • a mechanism to obtain the JspWriter for output
  • a mechanism to manage session usage by the page
  • a mechanism to expose page directive attributes to the scripting environment
  • mechanisms to forward or include the current request to other active components in the application
  • a mechanism to handle errorpage exception processing

Methods Intended for Container Generated Code

Some methods are intended to be used by the code generated by the container, not by code written by JSP page authors, or JSP tag library authors.

The methods supporting lifecycle are initialize() and release()

The following methods enable the management of nested JspWriter streams to implement Tag Extensions: pushBody()

Methods Intended for JSP authors

The following methods provide convenient access to implicit objects:
getException(),  getPage()
getRequest(),  getResponse(),
getSession(),  getServletConfig()
and getServletContext().

The following methods provide support for forwarding, inclusion and error handling: forward(), include(), and handlePageException().

Field Summary
static String | APPLICATION Name used to store ServletContext in PageContext name table.
static int | APPLICATION_SCOPE Application scope: named reference remains available in the ServletContext until it is reclaimed.
static String | CONFIG Name used to store ServletConfig in PageContext name table.
static String | EXCEPTION Name used to store uncaught exception in ServletRequest attribute list and PageContext name table.
static String | OUT Name used to store current JspWriter in PageContext name table.
static String | PAGE Name used to store the Servlet in this PageContext's nametables.
static int | PAGE_SCOPE Page scope: (this is the default) the named reference remains available in this PageContext until the return from the current Servlet.service() invocation.
static String | PAGECONTEXT Name used to store this PageContext in it's own name table.
static String | REQUEST Name used to store ServletRequest in PageContext name table.
static int | REQUEST_SCOPE Request scope: the named reference remains available from the ServletRequest associated with the Servlet until the current request is completed.
static String | RESPONSE Name used to store ServletResponse in PageContext name table.
static String | SESSION Name used to store HttpSession in PageContext name table.
static int | SESSION_SCOPE Session scope (only valid if this page participates in a session): the named reference remains available from the HttpSession (if any) associated with the Servlet until the HttpSession is invalidated.
Constructor Summary
PageContext()
Sole constructor.
Method Summary
abstract  void forward(String relativeUrlPath)
This method is used to re-direct, or "forward" the current ServletRequest and ServletResponse to another active component in the application.
 ErrorData getErrorData()
Provides convenient access to error information.
abstract  Exception getException()
The current value of the exception object (an Exception).
abstract  Object getPage()
The current value of the page object (In a Servlet environment, this is an instance of javax.servlet.Servlet).
abstract  ServletRequest getRequest()
The current value of the request object (a ServletRequest).
abstract  ServletResponse getResponse()
The current value of the response object (a ServletResponse).
abstract  ServletConfig getServletConfig()
The ServletConfig instance.
abstract  ServletContext getServletContext()
The ServletContext instance.
abstract  HttpSession getSession()
The current value of the session object (an HttpSession).
abstract  void handlePageException(Exception e)
This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
abstract  void handlePageException(Throwable t)
This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
abstract  void include(String relativeUrlPath)
Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
abstract  void include(String relativeUrlPath, boolean flush)
Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
abstract  void initialize(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int bufferSize, boolean autoFlush)
The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.
 BodyContent pushBody()
Return a new BodyContent object, save the current "out" JspWriter, and update the value of the "out" attribute in the page scope attribute namespace of the PageContext.
abstract  void release()
This method shall "reset" the internal state of a PageContext, releasing all internal references, and preparing the PageContext for potential reuse by a later invocation of initialize().
Methods inherited from class javax.servlet.jsp.JspContext
findAttribute, getAttribute, getAttribute, getAttributeNamesInScope, getAttributesScope, getExpressionEvaluator, getOut, getVariableResolver, popBody, pushBody, removeAttribute, removeAttribute, setAttribute, setAttribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PAGE_SCOPE

public static final int PAGE_SCOPE
Page scope: (this is the default) the named reference remains available in this PageContext until the return from the current Servlet.service() invocation.

See Also:
Constant Field Values

REQUEST_SCOPE

public static final int REQUEST_SCOPE
Request scope: the named reference remains available from the ServletRequest associated with the Servlet until the current request is completed.

See Also:
Constant Field Values

SESSION_SCOPE

public static final int SESSION_SCOPE
Session scope (only valid if this page participates in a session): the named reference remains available from the HttpSession (if any) associated with the Servlet until the HttpSession is invalidated.

See Also:
Constant Field Values

APPLICATION_SCOPE

public static final int APPLICATION_SCOPE
Application scope: named reference remains available in the ServletContext until it is reclaimed.

See Also:
Constant Field Values

PAGE

public static final String PAGE
Name used to store the Servlet in this PageContext's nametables.

See Also:
Constant Field Values

PAGECONTEXT

public static final String PAGECONTEXT
Name used to store this PageContext in it's own name table.

See Also:
Constant Field Values

REQUEST

public static final String REQUEST
Name used to store ServletRequest in PageContext name table.

See Also:
Constant Field Values

RESPONSE

public static final String RESPONSE
Name used to store ServletResponse in PageContext name table.

See Also:
Constant Field Values

CONFIG

public static final String CONFIG
Name used to store ServletConfig in PageContext name table.

See Also:
Constant Field Values

SESSION

public static final String SESSION
Name used to store HttpSession in PageContext name table.

See Also:
Constant Field Values

OUT

public static final String OUT
Name used to store current JspWriter in PageContext name table.

See Also:
Constant Field Values

APPLICATION

public static final String APPLICATION
Name used to store ServletContext in PageContext name table.

See Also:
Constant Field Values

EXCEPTION

public static final String EXCEPTION
Name used to store uncaught exception in ServletRequest attribute list and PageContext name table.

See Also:
Constant Field Values
Constructor Detail

PageContext

public PageContext()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

initialize

public abstract void initialize(Servlet servlet,
                                ServletRequest request,
                                ServletResponse response,
                                String errorPageURL,
                                boolean needsSession,
                                int bufferSize,
                                boolean autoFlush)
                         throws IOException,
                                IllegalStateException,
                                IllegalArgumentException

The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.

This method is typically called from JspFactory.getPageContext() in order to initialize state.

This method is required to create an initial JspWriter, and associate the "out" name in page scope with this newly created object.

This method should not be used by page or tag library authors.

Parameters:
servlet - The Servlet that is associated with this PageContext
request - The currently pending request for this Servlet
response - The currently pending response for this Servlet
errorPageURL - The value of the errorpage attribute from the page directive or null
needsSession - The value of the session attribute from the page directive
bufferSize - The value of the buffer attribute from the page directive
autoFlush - The value of the autoflush attribute from the page directive
Throws:
IOException - during creation of JspWriter
IllegalStateException - if out not correctly initialized
IllegalArgumentException - If one of the given parameters is invalid

release

public abstract void release()

This method shall "reset" the internal state of a PageContext, releasing all internal references, and preparing the PageContext for potential reuse by a later invocation of initialize(). This method is typically called from JspFactory.releasePageContext().

Subclasses shall envelope this method.

This method should not be used by page or tag library authors.

getSession

public abstract HttpSession getSession()
The current value of the session object (an HttpSession).

Returns:
the HttpSession for this PageContext or null

getPage

public abstract Object getPage()
The current value of the page object (In a Servlet environment, this is an instance of javax.servlet.Servlet).

Returns:
the Page implementation class instance associated with this PageContext

getRequest

public abstract ServletRequest getRequest()
The current value of the request object (a ServletRequest).

Returns:
The ServletRequest for this PageContext

getResponse

public abstract ServletResponse getResponse()
The current value of the response object (a ServletResponse).

Returns:
the ServletResponse for this PageContext

getException

public abstract Exception getException()
The current value of the exception object (an Exception).

Returns:
any exception passed to this as an errorpage

getServletConfig

public abstract ServletConfig getServletConfig()
The ServletConfig instance.

Returns:
the ServletConfig for this PageContext

getServletContext

public abstract ServletContext getServletContext()
The ServletContext instance.

Returns:
the ServletContext for this PageContext

forward

public abstract void forward(String relativeUrlPath)
                      throws ServletException,
                             IOException

This method is used to re-direct, or "forward" the current ServletRequest and ServletResponse to another active component in the application.

If the relativeUrlPath begins with a "/" then the URL specified is calculated relative to the DOCROOT of the ServletContext for this JSP. If the path does not begin with a "/" then the URL specified is calculated relative to the URL of the request that was mapped to the calling JSP.

It is only valid to call this method from a Thread executing within a _jspService(...) method of a JSP.

Once this method has been called successfully, it is illegal for the calling Thread to attempt to modify the ServletResponse object. Any such attempt to do so, shall result in undefined behavior. Typically, callers immediately return from _jspService(...) after calling this method.

Parameters:
relativeUrlPath - specifies the relative URL path to the target resource as described above
Throws:
IllegalStateException - if ServletResponse is not in a state where a forward can be performed
ServletException - if the page that was forwarded to throws a ServletException
IOException - if an I/O error occurred while forwarding

include

public abstract void include(String relativeUrlPath)
                      throws ServletException,
                             IOException

Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread. The output of the target resources processing of the request is written directly to the ServletResponse output stream.

The current JspWriter "out" for this JSP is flushed as a side-effect of this call, prior to processing the include.

If the relativeUrlPath begins with a "/" then the URL specified is calculated relative to the DOCROOT of the ServletContext for this JSP. If the path does not begin with a "/" then the URL specified is calculated relative to the URL of the request that was mapped to the calling JSP.

It is only valid to call this method from a Thread executing within a _jspService(...) method of a JSP.

Parameters:
relativeUrlPath - specifies the relative URL path to the target resource to be included
Throws:
ServletException - if the page that was forwarded to throws a ServletException
IOException - if an I/O error occurred while forwarding

include

public abstract void include(String relativeUrlPath,
                             boolean flush)
                      throws ServletException,
                             IOException

Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread. The output of the target resources processing of the request is written directly to the current JspWriter returned by a call to getOut().

If flush is true, The current JspWriter "out" for this JSP is flushed as a side-effect of this call, prior to processing the include. Otherwise, the JspWriter "out" is not flushed.

If the relativeUrlPath begins with a "/" then the URL specified is calculated relative to the DOCROOT of the ServletContext for this JSP. If the path does not begin with a "/" then the URL specified is calculated relative to the URL of the request that was mapped to the calling JSP.

It is only valid to call this method from a Thread executing within a _jspService(...) method of a JSP.

Parameters:
relativeUrlPath - specifies the relative URL path to the target resource to be included
flush - True if the JspWriter is to be flushed before the include, or false if not.
Throws:
ServletException - if the page that was forwarded to throws a ServletException
IOException - if an I/O error occurred while forwarding
Since:
2.0

handlePageException

public abstract void handlePageException(Exception e)
                                  throws ServletException,
                                         IOException

This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP. If forwarding is not possible (for example because the response has already been committed), an implementation dependent mechanism should be used to invoke the error page (e.g. "including" the error page instead).

If no error page is defined in the page, the exception should be rethrown so that the standard servlet error handling takes over.

A JSP implementation class shall typically clean up any local state prior to invoking this and will return immediately thereafter. It is illegal to generate any output to the client, or to modify any ServletResponse state after invoking this call.

This method is kept for backwards compatiblity reasons. Newly generated code should use PageContext.handlePageException(Throwable).

Parameters:
e - the exception to be handled
Throws:
ServletException - if an error occurs while invoking the error page
IOException - if an I/O error occurred while invoking the error page
NullPointerException - if the exception is null
See Also:
handlePageException(Throwable)

handlePageException

public abstract void handlePageException(Throwable t)
                                  throws ServletException,
                                         IOException

This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP. If forwarding is not possible (for example because the response has already been committed), an implementation dependent mechanism should be used to invoke the error page (e.g. "including" the error page instead).

If no error page is defined in the page, the exception should be rethrown so that the standard servlet error handling takes over.

This method is intended to process an unhandled "page" level exception by redirecting the exception to either the specified error page for this JSP, or if none was specified, to perform some implementation dependent action.

A JSP implementation class shall typically clean up any local state prior to invoking this and will return immediately thereafter. It is illegal to generate any output to the client, or to modify any ServletResponse state after invoking this call.

Parameters:
t - the throwable to be handled
Throws:
ServletException - if an error occurs while invoking the error page
IOException - if an I/O error occurred while invoking the error page
NullPointerException - if the exception is null
See Also:
handlePageException(Exception)

pushBody

public BodyContent pushBody()
Return a new BodyContent object, save the current "out" JspWriter, and update the value of the "out" attribute in the page scope attribute namespace of the PageContext.

Returns:
the new BodyContent

getErrorData

public ErrorData getErrorData()
Provides convenient access to error information.

Returns:
an ErrorData instance containing information about the error, as obtained from the request attributes, as per the Servlet specification. If this is not an error page (that is, if the isErrorPage attribute of the page directive is not set to "true"), the information is meaningless.
Since:
2.0
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SkipPageException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class SkipPageException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.servlet.jsp.JspException
                extended by javax.servlet.jsp.SkipPageException
All Implemented Interfaces:
Serializable
public class SkipPageException
extends JspException

Exception to indicate the calling page must cease evaluation. Thrown by a simple tag handler to indicate that the remainder of the page must not be evaluated. The result is propagated back to the pagein the case where one tag invokes another (as can be the case with tag files). The effect is similar to that of a Classic Tag Handler returning Tag.SKIP_PAGE from doEndTag(). Jsp Fragments may also throw this exception. This exception should not be thrown manually in a JSP page or tag file - the behavior is undefined. The exception is intended to be thrown inside SimpleTag handlers and in JSP fragments.

Since:
2.0
See Also:
SimpleTag.doTag(),
JspFragment.invoke(java.io.Writer),
Tag.doEndTag(),
Serialized Form

Constructor Summary
SkipPageException()
Creates a SkipPageException with no message.
SkipPageException(String message)
Creates a SkipPageException with the provided message.
SkipPageException(String message, Throwable rootCause)
Creates a SkipPageException with the provided message and root cause.
SkipPageException(Throwable rootCause)
Creates a SkipPageException with the provided root cause.
Methods inherited from class javax.servlet.jsp.JspException
getRootCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SkipPageException

public SkipPageException()
Creates a SkipPageException with no message.

SkipPageException

public SkipPageException(String message)
Creates a SkipPageException with the provided message.

Parameters:
message - the detail message

SkipPageException

public SkipPageException(String message,
                         Throwable rootCause)
Creates a SkipPageException with the provided message and root cause.

Parameters:
message - the detail message
rootCause - the originating cause of this exception

SkipPageException

public SkipPageException(Throwable rootCause)
Creates a SkipPageException with the provided root cause.

Parameters:
rootCause - the originating cause of this exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


tagext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.servlet.jsp.tagext

Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

See:
Description

Interface Summary
BodyTag | The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.
DynamicAttributes | For a tag to declare that it accepts dynamic attributes, it must implement this interface.
IterationTag | The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.
JspTag | Serves as a base class for Tag and SimpleTag.
SimpleTag | Interface for defining Simple Tag Handlers.
Tag | The interface of a classic tag handler that does not want to manipulate its body.
TryCatchFinally | The auxiliary interface of a Tag, IterationTag or BodyTag tag handler that wants additional hooks for managing resources.

Class Summary
BodyContent | An encapsulation of the evaluation of the body of an action so it is available to a tag handler.
BodyTagSupport | A base class for defining tag handlers implementing BodyTag.
FunctionInfo | Information for a function in a Tag Library.
JspFragment | Encapsulates a portion of JSP code in an object that can be invoked as many times as needed.
PageData | Translation-time information on a JSP page.
SimpleTagSupport | A base class for defining tag handlers implementing SimpleTag.
TagAdapter | Wraps any SimpleTag and exposes it using a Tag interface.
TagAttributeInfo | Information on the attributes of a Tag, available at translation time.
TagData | The (translation-time only) attribute/value information for a tag instance.
TagExtraInfo | Optional class provided by the tag library author to describe additional translation-time information not described in the TLD.
TagFileInfo | Tag information for a tag file in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
TagInfo | Tag information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
TagLibraryInfo | Translation-time information associated with a taglib directive, and its underlying TLD file.
TagLibraryValidator | Translation-time validator class for a JSP page.
TagSupport | A base class for defining new tag handlers implementing Tag.
TagVariableInfo | Variable information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
ValidationMessage | A validation message from either TagLibraryValidator or TagExtraInfo.
VariableInfo | Information on the scripting variables that are created/modified by a tag (at run-time).

Package javax.servlet.jsp.tagext Description

Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

The JavaServer Pages(tm) (JSP) 2.0 specification provides a portable mechanism for the description of tag libraries.

A JSP tag library contains

  • A Tag Library Descriptor
  • A number of Tag Files or Tag handler classes defining request-time behavior
  • Additional classes and resources used at runtime
  • Possibly some additional classes to provide extra translation information

The JSP 2.0 specification and the reference implementation both contain simple and moderately complex examples of actions defined using this mechanism. These are available at JSP's web site, at http://java.sun.com/products/jsp. Some readers may want to consult those to get a quick feel for how the mechanisms work together.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.servlet.jsp.tagext Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.servlet.jsp.tagext

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.servlet.jsp.tagext.FunctionInfo
    • class javax.servlet.jsp.tagext.JspFragment
    • class javax.servlet.jsp.tagext.PageData
    • class javax.servlet.jsp.tagext.SimpleTagSupport (implements javax.servlet.jsp.tagext.SimpleTag)
    • class javax.servlet.jsp.tagext.TagAdapter (implements javax.servlet.jsp.tagext.Tag)
    • class javax.servlet.jsp.tagext.TagAttributeInfo
    • class javax.servlet.jsp.tagext.TagData (implements java.lang.Cloneable)
    • class javax.servlet.jsp.tagext.TagExtraInfo
    • class javax.servlet.jsp.tagext.TagFileInfo
    • class javax.servlet.jsp.tagext.TagInfo
    • class javax.servlet.jsp.tagext.TagLibraryInfo
    • class javax.servlet.jsp.tagext.TagLibraryValidator
    • class javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • class javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
    • class javax.servlet.jsp.tagext.TagVariableInfo
    • class javax.servlet.jsp.tagext.ValidationMessage
    • class javax.servlet.jsp.tagext.VariableInfo
    • class java.io.Writer
      • class javax.servlet.jsp.JspWriter
        • class javax.servlet.jsp.tagext.BodyContent

Interface Hierarchy

  • interface javax.servlet.jsp.tagext.DynamicAttributes
  • interface javax.servlet.jsp.tagext.JspTag
    • interface javax.servlet.jsp.tagext.SimpleTag
    • interface javax.servlet.jsp.tagext.Tag
      • interface javax.servlet.jsp.tagext.IterationTag
        • interface javax.servlet.jsp.tagext.BodyTag
  • interface javax.servlet.jsp.tagext.TryCatchFinally
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JspTag

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface JspTag

All Known Subinterfaces:
BodyTag, IterationTag, SimpleTag, Tag
All Known Implementing Classes:
BodyTagSupport, SimpleTagSupport, TagAdapter, TagSupport
public interface JspTag

Serves as a base class for Tag and SimpleTag. This is mostly for organizational and type-safety purposes.

Since:
2.0

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BodyContent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class BodyContent

java.lang.Object
    extended by java.io.Writer
        extended by javax.servlet.jsp.JspWriter
            extended by javax.servlet.jsp.tagext.BodyContent
public abstract class BodyContent
extends JspWriter

An encapsulation of the evaluation of the body of an action so it is available to a tag handler. BodyContent is a subclass of JspWriter.

Note that the content of BodyContent is the result of evaluation, so it will not contain actions and the like, but the result of their invocation.

BodyContent has methods to convert its contents into a String, to read its contents, and to clear the contents.

The buffer size of a BodyContent object is unbounded. A BodyContent object cannot be in autoFlush mode. It is not possible to invoke flush on a BodyContent object, as there is no backing stream.

Instances of BodyContent are created by invoking the pushBody and popBody methods of the PageContext class. A BodyContent is enclosed within another JspWriter (maybe another BodyContent object) following the structure of their associated actions.

A BodyContent is made available to a BodyTag through a setBodyContent() call. The tag handler can use the object until after the call to doEndTag().

Field Summary
Fields inherited from class javax.servlet.jsp.JspWriter
autoFlush, bufferSize, DEFAULT_BUFFER, NO_BUFFER, UNBOUNDED_BUFFER
Fields inherited from class java.io.Writer
lock
Constructor Summary
protected BodyContent(JspWriter e)
Protected constructor.
Method Summary
 void clearBody()
Clear the body without throwing any exceptions.
 void flush()
Redefined flush() so it is not legal.
 JspWriter getEnclosingWriter()
Get the enclosing JspWriter.
abstract  Reader getReader()
Return the value of this BodyContent as a Reader.
abstract  String getString()
Return the value of the BodyContent as a String.
abstract  void writeOut(Writer out)
Write the contents of this BodyContent into a Writer.
Methods inherited from class javax.servlet.jsp.JspWriter
clear, clearBuffer, close, getBufferSize, getRemaining, isAutoFlush, newLine, print, print, print, print, print, print, print, print, print, println, println, println, println, println, println, println, println, println, println
Methods inherited from class java.io.Writer
write, write, write, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BodyContent

protected BodyContent(JspWriter e)
Protected constructor. Unbounded buffer, no autoflushing.

Parameters:
e - the enclosing JspWriter
Method Detail

flush

public void flush()
           throws IOException
Redefined flush() so it is not legal.

It is not valid to flush a BodyContent because there is no backing stream behind it.

Specified by:
flush in class JspWriter
Throws:
IOException - always thrown

clearBody

public void clearBody()
Clear the body without throwing any exceptions.

getReader

public abstract Reader getReader()
Return the value of this BodyContent as a Reader.

Returns:
the value of this BodyContent as a Reader

getString

public abstract String getString()
Return the value of the BodyContent as a String.

Returns:
the value of the BodyContent as a String

writeOut

public abstract void writeOut(Writer out)
                       throws IOException
Write the contents of this BodyContent into a Writer. Subclasses may optimize common invocation patterns.

Parameters:
out - The writer into which to place the contents of this body evaluation
Throws:
IOException - if an I/O error occurred while writing the contents of this BodyContent to the given Writer

getEnclosingWriter

public JspWriter getEnclosingWriter()
Get the enclosing JspWriter.

Returns:
the enclosing JspWriter passed at construction time
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BodyTag

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface BodyTag

All Superinterfaces:
IterationTag, JspTag, Tag
All Known Implementing Classes:
BodyTagSupport
public interface BodyTag
extends IterationTag

The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.

It is the responsibility of the tag handler to manipulate the body content. For example the tag handler may take the body content, convert it into a String using the bodyContent.getString method and then use it. Or the tag handler may take the body content and write it out into its enclosing JspWriter using the bodyContent.writeOut method.

A tag handler that implements BodyTag is treated as one that implements IterationTag, except that the doStartTag method can return SKIP_BODY, EVAL_BODY_INCLUDE or EVAL_BODY_BUFFERED.

If EVAL_BODY_INCLUDE is returned, then evaluation happens as in IterationTag.

If EVAL_BODY_BUFFERED is returned, then a BodyContent object will be created (by code generated by the JSP compiler) to capture the body evaluation. The code generated by the JSP compiler obtains the BodyContent object by calling the pushBody method of the current pageContext, which additionally has the effect of saving the previous out value. The page compiler returns this object by calling the popBody method of the PageContext class; the call also restores the value of out.

The interface provides one new property with a setter method and one new action method.

Properties

There is a new property: bodyContent, to contain the BodyContent object, where the JSP Page implementation object will place the evaluation (and reevaluation, if appropriate) of the body. The setter method (setBodyContent) will only be invoked if doStartTag() returns EVAL_BODY_BUFFERED and the corresponding action element does not have an empty body.

Methods

In addition to the setter method for the bodyContent property, there is a new action method: doInitBody(), which is invoked right after setBodyContent() and before the body evaluation. This method is only invoked if doStartTag() returns EVAL_BODY_BUFFERED.

Lifecycle

Lifecycle details are described by the transition diagram below. Exceptions that are thrown during the computation of doStartTag(), setBodyContent(), doInitBody(), BODY, doAfterBody() interrupt the execution sequence and are propagated up the stack, unless the tag handler implements the TryCatchFinally interface; see that interface for details.

Lifecycle Details Transition Diagram for BodyTag

Empty and Non-Empty Action

If the TagLibraryDescriptor file indicates that the action must always have an empty element body, by an <body-content> entry of "empty", then the doStartTag() method must return SKIP_BODY. Otherwise, the doStartTag() method may return SKIP_BODY, EVAL_BODY_INCLUDE, or EVAL_BODY_BUFFERED.

Note that which methods are invoked after the doStartTag() depends on both the return value and on if the custom action element is empty or not in the JSP page, not how it's declared in the TLD.

If SKIP_BODY is returned the body is not evaluated, and doEndTag() is invoked.

If EVAL_BODY_INCLUDE is returned, and the custom action element is not empty, setBodyContent() is not invoked, doInitBody() is not invoked, the body is evaluated and "passed through" to the current out, doAfterBody() is invoked and then, after zero or more iterations, doEndTag() is invoked. If the custom action element is empty, only doStart() and doEndTag() are invoked.

If EVAL_BODY_BUFFERED is returned, and the custom action element is not empty, setBodyContent() is invoked, doInitBody() is invoked, the body is evaluated, doAfterBody() is invoked, and then, after zero or more iterations, doEndTag() is invoked. If the custom action element is empty, only doStart() and doEndTag() are invoked.

Field Summary
static int | EVAL_BODY_BUFFERED Request the creation of new buffer, a BodyContent on which to evaluate the body of this tag.
static int | EVAL_BODY_TAG Deprecated. As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Method Summary
void | doInitBody() Prepare for evaluation of the body.
void | setBodyContent(BodyContent b) Set the bodyContent property.
Methods inherited from interface javax.servlet.jsp.tagext.IterationTag
doAfterBody
Methods inherited from interface javax.servlet.jsp.tagext.Tag
doEndTag, doStartTag, getParent, release, setPageContext, setParent

Field Detail

EVAL_BODY_TAG

public static final int EVAL_BODY_TAG
Deprecated. As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.

Deprecated constant that has the same value as EVAL_BODY_BUFFERED and EVAL_BODY_AGAIN. This name has been marked as deprecated to encourage the use of the two different terms, which are much more descriptive.

See Also:
Constant Field Values

EVAL_BODY_BUFFERED

public static final int EVAL_BODY_BUFFERED
Request the creation of new buffer, a BodyContent on which to evaluate the body of this tag. Returned from doStartTag when it implements BodyTag. This is an illegal return value for doStartTag when the class does not implement BodyTag.

See Also:
Constant Field Values
Method Detail

setBodyContent

public void setBodyContent(BodyContent b)
Set the bodyContent property. This method is invoked by the JSP page implementation object at most once per action invocation. This method will be invoked before doInitBody. This method will not be invoked for empty tags or for non-empty tags whose doStartTag() method returns SKIP_BODY or EVAL_BODY_INCLUDE.

When setBodyContent is invoked, the value of the implicit object out has already been changed in the pageContext object. The BodyContent object passed will have not data on it but may have been reused (and cleared) from some previous invocation.

The BodyContent object is available and with the appropriate content until after the invocation of the doEndTag method, at which case it may be reused.

Parameters:
b - the BodyContent
See Also:
doInitBody(), IterationTag.doAfterBody()

doInitBody

public void doInitBody()
                throws JspException
Prepare for evaluation of the body. This method is invoked by the JSP page implementation object after setBodyContent and before the first time the body is to be evaluated. This method will not be invoked for empty tags or for non-empty tags whose doStartTag() method returns SKIP_BODY or EVAL_BODY_INCLUDE.

The JSP container will resynchronize the values of any AT_BEGIN and NESTED variables (defined by the associated TagExtraInfo or TLD) after the invocation of doInitBody().

Throws:
JspException - if an error occurred while processing this tag
See Also:
IterationTag.doAfterBody()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BodyTagSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class BodyTagSupport

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagSupport
        extended by javax.servlet.jsp.tagext.BodyTagSupport
All Implemented Interfaces:
BodyTag, IterationTag, JspTag, Serializable, Tag
public class BodyTagSupport
extends TagSupport
implements BodyTag

A base class for defining tag handlers implementing BodyTag.

The BodyTagSupport class implements the BodyTag interface and adds additional convenience methods including getter methods for the bodyContent property and methods to get at the previous out JspWriter.

Many tag handlers will extend BodyTagSupport and only redefine a few methods.

See Also:
Serialized Form

Field Summary
protected  BodyContent bodyContent
The current BodyContent for this BodyTag.
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
BodyTagSupport()
Default constructor, all subclasses are required to only define a public constructor with the same signature, and to call the superclass constructor.
Method Summary
int | doAfterBody() After the body evaluation: do not reevaluate and continue with the page.
int | doEndTag() Default processing of the end tag returning EVAL_PAGE.
void | doInitBody() Prepare for evaluation of the body just before the first body evaluation: no action.
int | doStartTag() Default processing of the start tag returning EVAL_BODY_BUFFERED.
BodyContent | getBodyContent() Get current bodyContent.
JspWriter | getPreviousOut() Get surrounding out JspWriter.
void | release() Release state.
void | setBodyContent(BodyContent b) Prepare for evaluation of the body: stash the bodyContent away.
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

bodyContent

protected BodyContent bodyContent
The current BodyContent for this BodyTag.

Constructor Detail

BodyTagSupport

public BodyTagSupport()
Default constructor, all subclasses are required to only define a public constructor with the same signature, and to call the superclass constructor. This constructor is called by the code generated by the JSP translator.

Method Detail

doStartTag

public int doStartTag()
               throws JspException
Default processing of the start tag returning EVAL_BODY_BUFFERED.

Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class TagSupport
Returns:
EVAL_BODY_BUFFERED
Throws:
JspException - if an error occurred while processing this tag
See Also:
Tag.doStartTag()

doEndTag

public int doEndTag()
             throws JspException
Default processing of the end tag returning EVAL_PAGE.

Specified by:
doEndTag in interface Tag
Overrides:
doEndTag in class TagSupport
Returns:
EVAL_PAGE
Throws:
JspException - if an error occurred while processing this tag
See Also:
Tag.doEndTag()

setBodyContent

public void setBodyContent(BodyContent b)
Prepare for evaluation of the body: stash the bodyContent away.

Specified by:
setBodyContent in interface BodyTag
Parameters:
b - the BodyContent
See Also:
doAfterBody(),
doInitBody(),
BodyTag.setBodyContent(javax.servlet.jsp.tagext.BodyContent)

doInitBody

public void doInitBody()
                throws JspException
Prepare for evaluation of the body just before the first body evaluation: no action.

Specified by:
doInitBody in interface BodyTag
Throws:
JspException - if an error occurred while processing this tag
See Also:
setBodyContent(javax.servlet.jsp.tagext.BodyContent),
doAfterBody(),
BodyTag.doInitBody()

doAfterBody

public int doAfterBody()
                throws JspException
After the body evaluation: do not reevaluate and continue with the page. By default nothing is done with the bodyContent data (if any).

Specified by:
doAfterBody in interface IterationTag
Overrides:
doAfterBody in class TagSupport
Returns:
SKIP_BODY
Throws:
JspException - if an error occurred while processing this tag
See Also:
doInitBody(), IterationTag.doAfterBody()

release

public void release()
Release state.

Specified by:
release in interface Tag
Overrides:
release in class TagSupport
See Also:
Tag.release()

getBodyContent

public BodyContent getBodyContent()
Get current bodyContent.

Returns:
the body content.

getPreviousOut

public JspWriter getPreviousOut()
Get surrounding out JspWriter.

Returns:
the enclosing JspWriter, from the bodyContent.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DynamicAttributes

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface DynamicAttributes

public interface DynamicAttributes

For a tag to declare that it accepts dynamic attributes, it must implement this interface. The entry for the tag in the Tag Library Descriptor must also be configured to indicate dynamic attributes are accepted.
For any attribute that is not declared in the Tag Library Descriptor for this tag, instead of getting an error at translation time, the setDynamicAttribute() method is called, with the name and value of the attribute. It is the responsibility of the tag to remember the names and values of the dynamic attributes.

Since:
2.0

Method Summary
 void setDynamicAttribute(String uri, String localName, Object value)
Called when a tag declared to accept dynamic attributes is passed an attribute that is not declared in the Tag Library Descriptor.

Method Detail

setDynamicAttribute

public void setDynamicAttribute(String uri,
                                String localName,
                                Object value)
                         throws JspException
Called when a tag declared to accept dynamic attributes is passed an attribute that is not declared in the Tag Library Descriptor.

Parameters:
uri - the namespace of the attribute, or null if in the default namespace.
localName - the name of the attribute being set.
value - the value of the attribute
Throws:
JspException - if the tag handler wishes to signal that it does not accept the given attribute. The container must not call doStartTag() or doTag() for this tag.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FunctionInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class FunctionInfo

java.lang.Object
    extended by javax.servlet.jsp.tagext.FunctionInfo
public class FunctionInfo
extends Object

Information for a function in a Tag Library. This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.

Since:
2.0

Constructor Summary
FunctionInfo(String name, String klass, String signature)
Constructor for FunctionInfo.
Method Summary
String | getFunctionClass() The class of the function.
String | getFunctionSignature() The signature of the function.
String | getName() The name of the function.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FunctionInfo

public FunctionInfo(String name,
                    String klass,
                    String signature)
Constructor for FunctionInfo.

Parameters:
name - The name of the function
klass - The class of the function
signature - The signature of the function
Method Detail

getName

public String getName()
The name of the function.

Returns:
The name of the function

getFunctionClass

public String getFunctionClass()
The class of the function.

Returns:
The class of the function

getFunctionSignature

public String getFunctionSignature()
The signature of the function.

Returns:
The signature of the function
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


IterationTag

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface IterationTag

All Superinterfaces:
JspTag, Tag
All Known Subinterfaces:
BodyTag
All Known Implementing Classes:
BodyTagSupport, TagSupport
public interface IterationTag
extends Tag

The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.

A tag handler that implements IterationTag is treated as one that implements Tag regarding the doStartTag() and doEndTag() methods. IterationTag provides a new method: doAfterBody().

The doAfterBody() method is invoked after every body evaluation to control whether the body will be reevaluated or not. If doAfterBody() returns IterationTag.EVAL_BODY_AGAIN, then the body will be reevaluated. If doAfterBody() returns Tag.SKIP_BODY, then the body will be skipped and doEndTag() will be evaluated instead.

Properties There are no new properties in addition to those in Tag.

Methods There is one new methods: doAfterBody().

Lifecycle

Lifecycle details are described by the transition diagram below. Exceptions that are thrown during the computation of doStartTag(), BODY and doAfterBody() interrupt the execution sequence and are propagated up the stack, unless the tag handler implements the TryCatchFinally interface; see that interface for details.

Lifecycle Details Transition Diagram for IterationTag

Empty and Non-Empty Action

If the TagLibraryDescriptor file indicates that the action must always have an empty element body, by a <body-content> entry of "empty", then the doStartTag() method must return SKIP_BODY.

Note that which methods are invoked after the doStartTag() depends on both the return value and on if the custom action element is empty or not in the JSP page, not on how it's declared in the TLD.

If SKIP_BODY is returned the body is not evaluated, and then doEndTag() is invoked.

If EVAL_BODY_INCLUDE is returned, and the custom action element is not empty, the body is evaluated and "passed through" to the current out, then doAfterBody() is invoked and, after zero or more iterations, doEndTag() is invoked.

Field Summary
static int EVAL_BODY_AGAIN
Request the reevaluation of some body.
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Method Summary
 int doAfterBody()
Process body (re)evaluation.
Methods inherited from interface javax.servlet.jsp.tagext.Tag
doEndTag, doStartTag, getParent, release, setPageContext, setParent

Field Detail

EVAL_BODY_AGAIN

public static final int EVAL_BODY_AGAIN
Request the reevaluation of some body. Returned from doAfterBody. For compatibility with JSP 1.1, the value is carefully selected to be the same as the, now deprecated, BodyTag.EVAL_BODY_TAG,

See Also:
Constant Field Values
Method Detail

doAfterBody

public int doAfterBody()
                throws JspException
Process body (re)evaluation. This method is invoked by the JSP Page implementation object after every evaluation of the body into the BodyEvaluation object. The method is not invoked if there is no body evaluation.

If doAfterBody returns EVAL_BODY_AGAIN, a new evaluation of the body will happen (followed by another invocation of doAfterBody). If doAfterBody returns SKIP_BODY, no more body evaluations will occur, and the doEndTag method will be invoked.

If this tag handler implements BodyTag and doAfterBody returns SKIP_BODY, the value of out will be restored using the popBody method in pageContext prior to invoking doEndTag.

The method re-invocations may be lead to different actions because there might have been some changes to shared state, or because of external computation.

The JSP container will resynchronize the values of any AT_BEGIN and NESTED variables (defined by the associated TagExtraInfo or TLD) after the invocation of doAfterBody().

Returns:
whether additional evaluations of the body are desired
Throws:
JspException - if an error occurred while processing this tag
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JspFragment

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class JspFragment

java.lang.Object
    extended by javax.servlet.jsp.tagext.JspFragment
public abstract class JspFragment
extends Object

Encapsulates a portion of JSP code in an object that can be invoked as many times as needed. JSP Fragments are defined using JSP syntax as the body of a tag for an invocation to a SimpleTag handler, or as the body of a <jsp:attribute> standard action specifying the value of an attribute that is declared as a fragment, or to be of type JspFragment in the TLD.

The definition of the JSP fragment must only contain template text and JSP action elements. In other words, it must not contain scriptlets or scriptlet expressions. At translation time, the container generates an implementation of the JspFragment abstract class capable of executing the defined fragment.

A tag handler can invoke the fragment zero or more times, or pass it along to other tags, before returning. To communicate values to/from a JSP fragment, tag handlers store/retrieve values in the JspContext associated with the fragment.

Note that tag library developers and page authors should not generate JspFragment implementations manually.

Implementation Note: It is not necessary to generate a separate class for each fragment. One possible implementation is to generate a single helper class for each page that implements JspFragment. Upon construction, a discriminator can be passed to select which fragment that instance will execute.

Since:
2.0

Constructor Summary
JspFragment()
Method Summary
abstract JspContext | getJspContext() Returns the JspContext that is bound to this JspFragment.
abstract void | invoke(Writer out) Executes the fragment and directs all output to the given Writer, or the JspWriter returned by the getOut() method of the JspContext associated with the fragment if out is null.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JspFragment

public JspFragment()
Method Detail

invoke

public abstract void invoke(Writer out)
                     throws JspException,
                            IOException
Executes the fragment and directs all output to the given Writer, or the JspWriter returned by the getOut() method of the JspContext associated with the fragment if out is null.

Parameters:
out - The Writer to output the fragment to, or null if output should be sent to JspContext.getOut().
Throws:
JspException - Thrown if an error occured while invoking this fragment.
SkipPageException - Thrown if the page that (either directly or indirectly) invoked the tag handler that invoked this fragment is to cease evaluation. The container must throw this exception if a Classic Tag Handler returned Tag.SKIP_PAGE or if a Simple Tag Handler threw SkipPageException.
IOException - If there was an error writing to the stream.

getJspContext

public abstract JspContext getJspContext()
Returns the JspContext that is bound to this JspFragment.

Returns:
The JspContext used by this fragment at invocation time.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PageData

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class PageData

java.lang.Object
    extended by javax.servlet.jsp.tagext.PageData
public abstract class PageData
extends Object

Translation-time information on a JSP page. The information corresponds to the XML view of the JSP page.

Objects of this type are generated by the JSP translator, e.g. when being pased to a TagLibraryValidator instance.

Constructor Summary
PageData()
Sole constructor.
Method Summary
abstract  InputStream getInputStream()
Returns an input stream on the XML view of a JSP page.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PageData

public PageData()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

getInputStream

public abstract InputStream getInputStream()
Returns an input stream on the XML view of a JSP page. The stream is encoded in UTF-8. Recall tht the XML view of a JSP page has the include directives expanded.

Returns:
An input stream on the document.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SimpleTag

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface SimpleTag

All Superinterfaces:
JspTag
All Known Implementing Classes:
SimpleTagSupport
public interface SimpleTag
extends JspTag

Interface for defining Simple Tag Handlers.

Simple Tag Handlers differ from Classic Tag Handlers in that instead of supporting doStartTag() and doEndTag(), the SimpleTag interface provides a simple doTag() method, which is called once and only once for any given tag invocation. All tag logic, iteration, body evaluations, etc. are to be performed in this single method. Thus, simple tag handlers have the equivalent power of BodyTag, but with a much simpler lifecycle and interface.

To support body content, the setJspBody() method is provided. The container invokes the setJspBody() method with a JspFragment object encapsulating the body of the tag. The tag handler implementation can call invoke() on that fragment to evaluate the body as many times as it needs.

A SimpleTag handler must have a public no-args constructor. Most SimpleTag handlers should extend SimpleTagSupport.

Lifecycle

The following is a non-normative, brief overview of the SimpleTag lifecycle. Refer to the JSP Specification for details.

  1. A new tag handler instance is created each time by the container by calling the provided zero-args constructor. Unlike classic tag handlers, simple tag handlers are never cached and reused by the JSP container.
  2. The setJspContext() and setParent() methods are called by the container. The setParent() method is only called if the element is nested within another tag invocation.
  3. The setters for each attribute defined for this tag are called by the container.
  4. If a body exists, the setJspBody() method is called by the container to set the body of this tag, as a JspFragment. If the action element is empty in the page, this method is not called at all.
  5. The doTag() method is called by the container. All tag logic, iteration, body evaluations, etc. occur in this method.
  6. The doTag() method returns and all variables are synchronized.

Since:
2.0
See Also:
SimpleTagSupport

Method Summary
void | doTag() Called by the container to invoke this tag.
JspTag | getParent() Returns the parent of this tag, for collaboration purposes.
void | setJspBody(JspFragment jspBody) Provides the body of this tag as a JspFragment object, able to be invoked zero or more times by the tag handler.
void | setJspContext(JspContext pc) Called by the container to provide this tag handler with the JspContext for this invocation.
void | setParent(JspTag parent) Sets the parent of this tag, for collaboration purposes.

Method Detail

doTag

public void doTag()
           throws JspException,
                  IOException
Called by the container to invoke this tag. The implementation of this method is provided by the tag library developer, and handles all tag processing, body iteration, etc.

The JSP container will resynchronize any AT_BEGIN and AT_END variables (defined by the associated tag file, TagExtraInfo, or TLD) after the invocation of doTag().

Throws:
JspException - If an error occurred while processing this tag.
SkipPageException - If the page that (either directly or indirectly) invoked this tag is to cease evaluation. A Simple Tag Handler generated from a tag file must throw this exception if an invoked Classic Tag Handler returned SKIP_PAGE or if an invoked Simple Tag Handler threw SkipPageException or if an invoked Jsp Fragment threw a SkipPageException.
IOException - If there was an error writing to the output stream.

setParent

public void setParent(JspTag parent)
Sets the parent of this tag, for collaboration purposes.

The container invokes this method only if this tag invocation is nested within another tag invocation.

Parameters:
parent - the tag that encloses this tag

getParent

public JspTag getParent()
Returns the parent of this tag, for collaboration purposes.

Returns:
the parent of this tag

setJspContext

public void setJspContext(JspContext pc)
Called by the container to provide this tag handler with the JspContext for this invocation. An implementation should save this value.

Parameters:
pc - the page context for this invocation
See Also:
Tag.setPageContext(javax.servlet.jsp.PageContext)

setJspBody

public void setJspBody(JspFragment jspBody)
Provides the body of this tag as a JspFragment object, able to be invoked zero or more times by the tag handler.

This method is invoked by the JSP page implementation object prior to doTag(). If the action element is empty in the page, this method is not called at all.

Parameters:
jspBody - The fragment encapsulating the body of this tag.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SimpleTagSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class SimpleTagSupport

java.lang.Object
    extended by javax.servlet.jsp.tagext.SimpleTagSupport
All Implemented Interfaces:
JspTag, SimpleTag
public class SimpleTagSupport
extends Object
implements SimpleTag

A base class for defining tag handlers implementing SimpleTag.

The SimpleTagSupport class is a utility class intended to be used as the base class for new simple tag handlers. The SimpleTagSupport class implements the SimpleTag interface and adds additional convenience methods including getter methods for the properties in SimpleTag.

Since:
2.0

Constructor Summary
SimpleTagSupport()
Sole constructor.
Method Summary
void | doTag() Default processing of the tag does nothing.
static JspTag | findAncestorWithClass(JspTag from, Class klass) Find the instance of a given class type that is closest to a given instance.
protected JspFragment | getJspBody() Returns the body passed in by the container via setJspBody.
protected JspContext | getJspContext() Returns the page context passed in by the container via setJspContext.
JspTag | getParent() Returns the parent of this tag, for collaboration purposes.
void | setJspBody(JspFragment jspBody) Stores the provided JspFragment.
void | setJspContext(JspContext pc) Stores the provided JSP context in the private jspContext field.
void | setParent(JspTag parent) Sets the parent of this tag, for collaboration purposes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SimpleTagSupport

public SimpleTagSupport()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

doTag

public void doTag()
           throws JspException,
                  IOException
Default processing of the tag does nothing.

Specified by:
doTag in interface SimpleTag
Throws:
JspException - Subclasses can throw JspException to indicate an error occurred while processing this tag.
SkipPageException - If the page that (either directly or indirectly) invoked this tag is to cease evaluation. A Simple Tag Handler generated from a tag file must throw this exception if an invoked Classic Tag Handler returned SKIP_PAGE or if an invoked Simple Tag Handler threw SkipPageException or if an invoked Jsp Fragment threw a SkipPageException.
IOException - Subclasses can throw IOException if there was an error writing to the output stream
See Also:
SimpleTag.doTag()

setParent

public void setParent(JspTag parent)
Sets the parent of this tag, for collaboration purposes.

The container invokes this method only if this tag invocation is nested within another tag invocation.

Specified by:
setParent in interface SimpleTag
Parameters:
parent - the tag that encloses this tag

getParent

public JspTag getParent()
Returns the parent of this tag, for collaboration purposes.

Specified by:
getParent in interface SimpleTag
Returns:
the parent of this tag

setJspContext

public void setJspContext(JspContext pc)
Stores the provided JSP context in the private jspContext field. Subclasses can access the JspContext via getJspContext().

Specified by:
setJspContext in interface SimpleTag
Parameters:
pc - the page context for this invocation
See Also:
SimpleTag.setJspContext(javax.servlet.jsp.JspContext)

getJspContext

protected JspContext getJspContext()
Returns the page context passed in by the container via setJspContext.

Returns:
the page context for this invocation

setJspBody

public void setJspBody(JspFragment jspBody)
Stores the provided JspFragment.

Specified by:
setJspBody in interface SimpleTag
Parameters:
jspBody - The fragment encapsulating the body of this tag. If the action element is empty in the page, this method is not called at all.
See Also:
SimpleTag.setJspBody(javax.servlet.jsp.tagext.JspFragment)

getJspBody

protected JspFragment getJspBody()
Returns the body passed in by the container via setJspBody.

Returns:
the fragment encapsulating the body of this tag, or null if the action element is empty in the page.

findAncestorWithClass

public static final JspTag findAncestorWithClass(JspTag from,
                                                 Class klass)
Find the instance of a given class type that is closest to a given instance. This method uses the getParent method from the Tag and/or SimpleTag interfaces. This method is used for coordination among cooperating tags.

For every instance of TagAdapter encountered while traversing the ancestors, the tag handler returned by TagAdapter.getAdaptee() - instead of the TagAdpater itself - is compared to klass. If the tag handler matches, it - and not its TagAdapter - is returned.

The current version of the specification only provides one formal way of indicating the observable type of a tag handler: its tag handler implementation class, described in the tag-class subelement of the tag element. This is extended in an informal manner by allowing the tag library author to indicate in the description subelement an observable type. The type should be a subtype of the tag handler implementation class or void. This addititional constraint can be exploited by a specialized container that knows about that specific tag library, as in the case of the JSP standard tag library.

When a tag library author provides information on the observable type of a tag handler, client programmatic code should adhere to that constraint. Specifically, the Class passed to findAncestorWithClass should be a subtype of the observable type.

Parameters:
from - The instance from where to start looking.
klass - The subclass of JspTag or interface to be matched
Returns:
the nearest ancestor that implements the interface or is an instance of the class specified
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Tag

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface Tag

All Superinterfaces:
JspTag
All Known Subinterfaces:
BodyTag, IterationTag
All Known Implementing Classes:
BodyTagSupport, TagAdapter, TagSupport
public interface Tag
extends JspTag

The interface of a classic tag handler that does not want to manipulate its body. The Tag interface defines the basic protocol between a Tag handler and JSP page implementation class. It defines the life cycle and the methods to be invoked at start and end tag.

Properties

The Tag interface specifies the setter and getter methods for the core pageContext and parent properties.

The JSP page implementation object invokes setPageContext and setParent, in that order, before invoking doStartTag() or doEndTag().

Methods

There are two main actions: doStartTag and doEndTag. Once all appropriate properties have been initialized, the doStartTag and doEndTag methods can be invoked on the tag handler. Between these invocations, the tag handler is assumed to hold a state that must be preserved. After the doEndTag invocation, the tag handler is available for further invocations (and it is expected to have retained its properties).

Lifecycle

Lifecycle details are described by the transition diagram below, with the following comments:

  • [1] This transition is intended to be for releasing long-term data. no guarantees are assumed on whether any properties have been retained or not.
  • [2] This transition happens if and only if the tag ends normally without raising an exception
  • [3] Some setters may be called again before a tag handler is reused. For instance, setParent() is called if it's reused within the same page but at a different level, setPageContext() is called if it's used in another page, and attribute setters are called if the values differ or are expressed as request-time attribute values.
  • Check the TryCatchFinally interface for additional details related to exception handling and resource management.

Lifecycle Details Transition Diagram for Tag

Once all invocations on the tag handler are completed, the release method is invoked on it. Once a release method is invoked all properties, including parent and pageContext, are assumed to have been reset to an unspecified value. The page compiler guarantees that release() will be invoked on the Tag handler before the handler is released to the GC.

Empty and Non-Empty Action

If the TagLibraryDescriptor file indicates that the action must always have an empty action, by an <body-content> entry of "empty", then the doStartTag() method must return SKIP_BODY.

Otherwise, the doStartTag() method may return SKIP_BODY or EVAL_BODY_INCLUDE.

If SKIP_BODY is returned the body, if present, is not evaluated.

If EVAL_BODY_INCLUDE is returned, the body is evaluated and "passed through" to the current out.

Field Summary
static int | EVAL_BODY_INCLUDE Evaluate body into existing out stream.
static int | EVAL_PAGE Continue evaluating the page.
static int | SKIP_BODY Skip body evaluation.
static int | SKIP_PAGE Skip the rest of the page.
Method Summary
int | doEndTag() Process the end tag for this instance.
int | doStartTag() Process the start tag for this instance.
Tag | getParent() Get the parent (closest enclosing tag handler) for this tag handler.
void | release() Called on a Tag handler to release state.
void | setPageContext(PageContext pc) Set the current page context.
void | setParent(Tag t) Set the parent (closest enclosing tag handler) of this tag handler.

Field Detail

SKIP_BODY

public static final int SKIP_BODY
Skip body evaluation. Valid return value for doStartTag and doAfterBody.

See Also:
Constant Field Values

EVAL_BODY_INCLUDE

public static final int EVAL_BODY_INCLUDE
Evaluate body into existing out stream. Valid return value for doStartTag.

See Also:
Constant Field Values

SKIP_PAGE

public static final int SKIP_PAGE
Skip the rest of the page. Valid return value for doEndTag.

See Also:
Constant Field Values

EVAL_PAGE

public static final int EVAL_PAGE
Continue evaluating the page. Valid return value for doEndTag().

See Also:
Constant Field Values
Method Detail

setPageContext

public void setPageContext(PageContext pc)
Set the current page context. This method is invoked by the JSP page implementation object prior to doStartTag().

This value is *not* reset by doEndTag() and must be explicitly reset by a page implementation if it changes between calls to doStartTag().

Parameters:
pc - The page context for this tag handler.

setParent

public void setParent(Tag t)
Set the parent (closest enclosing tag handler) of this tag handler. Invoked by the JSP page implementation object prior to doStartTag().

This value is *not* reset by doEndTag() and must be explicitly reset by a page implementation.

Parameters:
t - The parent tag, or null.

getParent

public Tag getParent()
Get the parent (closest enclosing tag handler) for this tag handler.

The getParent() method can be used to navigate the nested tag handler structure at runtime for cooperation among custom actions; for example, the findAncestorWithClass() method in TagSupport provides a convenient way of doing this.

The current version of the specification only provides one formal way of indicating the observable type of a tag handler: its tag handler implementation class, described in the tag-class subelement of the tag element. This is extended in an informal manner by allowing the tag library author to indicate in the description subelement an observable type. The type should be a subtype of the tag handler implementation class or void. This addititional constraint can be exploited by a specialized container that knows about that specific tag library, as in the case of the JSP standard tag library.

Returns:
the current parent, or null if none.
See Also:
TagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.Tag, java.lang.Class)

doStartTag

public int doStartTag()
               throws JspException
Process the start tag for this instance. This method is invoked by the JSP page implementation object.

The doStartTag method assumes that the properties pageContext and parent have been set. It also assumes that any properties exposed as attributes have been set too. When this method is invoked, the body has not yet been evaluated.

This method returns Tag.EVAL_BODY_INCLUDE or BodyTag.EVAL_BODY_BUFFERED to indicate that the body of the action should be evaluated or SKIP_BODY to indicate otherwise.

When a Tag returns EVAL_BODY_INCLUDE the result of evaluating the body (if any) is included into the current "out" JspWriter as it happens and then doEndTag() is invoked.

BodyTag.EVAL_BODY_BUFFERED is only valid if the tag handler implements BodyTag.

The JSP container will resynchronize the values of any AT_BEGIN and NESTED variables (defined by the associated TagExtraInfo or TLD) after the invocation of doStartTag(), except for a tag handler implementing BodyTag whose doStartTag() method returns BodyTag.EVAL_BODY_BUFFERED.

Returns:
EVAL_BODY_INCLUDE if the tag wants to process body, SKIP_BODY if it does not want to process it.
Throws:
JspException - if an error occurred while processing this tag
See Also:
BodyTag

doEndTag

public int doEndTag()
             throws JspException
Process the end tag for this instance. This method is invoked by the JSP page implementation object on all Tag handlers.

This method will be called after returning from doStartTag. The body of the action may or may not have been evaluated, depending on the return value of doStartTag.

If this method returns EVAL_PAGE, the rest of the page continues to be evaluated. If this method returns SKIP_PAGE, the rest of the page is not evaluated, the request is completed, and the doEndTag() methods of enclosing tags are not invoked. If this request was forwarded or included from another page (or Servlet), only the current page evaluation is stopped.

The JSP container will resynchronize the values of any AT_BEGIN and AT_END variables (defined by the associated TagExtraInfo or TLD) after the invocation of doEndTag().

Returns:
indication of whether to continue evaluating the JSP page.
Throws:
JspException - if an error occurred while processing this tag

release

public void release()
Called on a Tag handler to release state. The page compiler guarantees that JSP page implementation objects will invoke this method on all tag handlers, but there may be multiple invocations on doStartTag and doEndTag in between.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TagAdapter

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagAdapter

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagAdapter
All Implemented Interfaces:
JspTag, Tag
public class TagAdapter
extends Object
implements Tag

Wraps any SimpleTag and exposes it using a Tag interface. This is used to allow collaboration between classic Tag handlers and SimpleTag handlers.

Because SimpleTag does not extend Tag, and because Tag.setParent() only accepts a Tag instance, a classic tag handler (one that implements Tag) cannot have a SimpleTag as its parent. To remedy this, a TagAdapter is created to wrap the SimpleTag parent, and the adapter is passed to setParent() instead. A classic Tag Handler can call getAdaptee() to retrieve the encapsulated SimpleTag instance.

Since:
2.0

Field Summary
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TagAdapter(SimpleTag adaptee)
Creates a new TagAdapter that wraps the given SimpleTag and returns the parent tag when getParent() is called.
Method Summary
 int doEndTag()
Must not be called.
 int doStartTag()
Must not be called.
 JspTag getAdaptee()
Gets the tag that is being adapted to the Tag interface.
 Tag getParent()
Returns the parent of this tag, which is always getAdaptee().getParent().
 void release()
Must not be called.
 void setPageContext(PageContext pc)
Must not be called.
 void setParent(Tag parentTag)
Must not be called.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagAdapter

public TagAdapter(SimpleTag adaptee)
Creates a new TagAdapter that wraps the given SimpleTag and returns the parent tag when getParent() is called.

Parameters:
adaptee - The SimpleTag being adapted as a Tag.
Method Detail

setPageContext

public void setPageContext(PageContext pc)
Must not be called.

Specified by:
setPageContext in interface Tag
Parameters:
pc - ignored.
Throws:
UnsupportedOperationException - Must not be called

setParent

public void setParent(Tag parentTag)
Must not be called. The parent of this tag is always getAdaptee().getParent().

Specified by:
setParent in interface Tag
Parameters:
parentTag - ignored.
Throws:
UnsupportedOperationException - Must not be called.

getParent

public Tag getParent()
Returns the parent of this tag, which is always getAdaptee().getParent(). This will either be the enclosing Tag (if getAdaptee().getParent() implements Tag), or an adapter to the enclosing Tag (if getAdaptee().getParent() does not implement Tag).

Specified by:
getParent in interface Tag
Returns:
The parent of the tag being adapted.
See Also:
TagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.Tag, java.lang.Class)

getAdaptee

public JspTag getAdaptee()
Gets the tag that is being adapted to the Tag interface. This should be an instance of SimpleTag in JSP 2.0, but room is left for other kinds of tags in future spec versions.

Returns:
the tag that is being adapted

doStartTag

public int doStartTag()
               throws JspException
Must not be called.

Specified by:
doStartTag in interface Tag
Returns:
always throws UnsupportedOperationException
Throws:
UnsupportedOperationException - Must not be called
JspException - never thrown
See Also:
BodyTag

doEndTag

public int doEndTag()
             throws JspException
Must not be called.

Specified by:
doEndTag in interface Tag
Returns:
always throws UnsupportedOperationException
Throws:
UnsupportedOperationException - Must not be called
JspException - never thrown

release

public void release()
Must not be called.

Specified by:
release in interface Tag
Throws:
UnsupportedOperationException - Must not be called
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TagAttributeInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagAttributeInfo

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagAttributeInfo
public class TagAttributeInfo
extends Object

Information on the attributes of a Tag, available at translation time. This class is instantiated from the Tag Library Descriptor file (TLD).

Only the information needed to generate code is included here. Other information like SCHEMA for validation belongs elsewhere.

Field Summary
static String ID
"id" is wired in to be ID.
Constructor Summary
TagAttributeInfo(String name, boolean required, String type, boolean reqTime)
Constructor for TagAttributeInfo.
TagAttributeInfo(String name, boolean required, String type, boolean reqTime, boolean fragment)
JSP 2.0 Constructor for TagAttributeInfo.
Method Summary
boolean | canBeRequestTime() Whether this attribute can hold a request-time value.
static TagAttributeInfo | getIdAttribute(TagAttributeInfo[] a) Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".
String | getName() The name of this attribute.
String | getTypeName() The type (as a String) of this attribute.
boolean | isFragment() Whether this attribute is of type JspFragment.
boolean | isRequired() Whether this attribute is required.
String | toString() Returns a String representation of this TagAttributeInfo, suitable for debugging purposes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ID

public static final String ID
"id" is wired in to be ID. There is no real benefit in having it be something else IDREFs are not handled any differently.

See Also:
Constant Field Values
Constructor Detail

TagAttributeInfo

public TagAttributeInfo(String name,
                        boolean required,
                        String type,
                        boolean reqTime)
Constructor for TagAttributeInfo. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor).

Parameters:
name - The name of the attribute.
required - If this attribute is required in tag instances.
type - The name of the type of the attribute.
reqTime - Whether this attribute holds a request-time Attribute.

TagAttributeInfo

public TagAttributeInfo(String name,
                        boolean required,
                        String type,
                        boolean reqTime,
                        boolean fragment)
JSP 2.0 Constructor for TagAttributeInfo. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor).

Parameters:
name - The name of the attribute.
required - If this attribute is required in tag instances.
type - The name of the type of the attribute.
reqTime - Whether this attribute holds a request-time Attribute.
fragment - Whether this attribute is of type JspFragment
Since:
2.0
Method Detail

getName

public String getName()
The name of this attribute.

Returns:
the name of the attribute

getTypeName

public String getTypeName()
The type (as a String) of this attribute.

Returns:
the type of the attribute

canBeRequestTime

public boolean canBeRequestTime()
Whether this attribute can hold a request-time value.

Returns:
if the attribute can hold a request-time value.

isRequired

public boolean isRequired()
Whether this attribute is required.

Returns:
if the attribute is required.

getIdAttribute

public static TagAttributeInfo getIdAttribute(TagAttributeInfo[] a)
Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".

Parameters:
a - An array of TagAttributeInfo
Returns:
The TagAttributeInfo reference with name "id"

isFragment

public boolean isFragment()
Whether this attribute is of type JspFragment.

Returns:
if the attribute is of type JspFragment
Since:
2.0

toString

public String toString()
Returns a String representation of this TagAttributeInfo, suitable for debugging purposes.

Returns:
a String representation of this TagAttributeInfo
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TagData

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagData

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagData
All Implemented Interfaces:
Cloneable
public class TagData
extends Object
implements Cloneable

The (translation-time only) attribute/value information for a tag instance.

TagData is only used as an argument to the isValid, validate, and getVariableInfo methods of TagExtraInfo, which are invoked at translation time.

Field Summary
static Object REQUEST_TIME_VALUE
Distinguished value for an attribute to indicate its value is a request-time expression (which is not yet available because TagData instances are used at translation-time).
Constructor Summary
TagData(Hashtable attrs)
Constructor for a TagData.
TagData(Object[][] atts)
Constructor for TagData.
Method Summary
Object | getAttribute(String attName) The value of the attribute.
Enumeration | getAttributes() Enumerates the attributes.
String | getAttributeString(String attName) Get the value for a given attribute.
String | getId() The value of the tag's id attribute.
void | setAttribute(String attName, Object value) Set the value of an attribute.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

REQUEST_TIME_VALUE

public static final Object REQUEST_TIME_VALUE
Distinguished value for an attribute to indicate its value is a request-time expression (which is not yet available because TagData instances are used at translation-time).

Constructor Detail

TagData

public TagData(Object[][] atts)
Constructor for TagData.

A typical constructor may be

 static final Object[][] att = {{"connection", "conn0"}, {"id", "query0"}};
 static final TagData td = new TagData(att);
All values must be Strings except for those holding the distinguished object REQUEST_TIME_VALUE.

Parameters:
atts - the static attribute and values. May be null.

TagData

public TagData(Hashtable attrs)
Constructor for a TagData. If you already have the attributes in a hashtable, use this constructor.

Parameters:
attrs - A hashtable to get the values from.
Method Detail

getId

public String getId()
The value of the tag's id attribute.

Returns:
the value of the tag's id attribute, or null if no such attribute was specified.

getAttribute

public Object getAttribute(String attName)
The value of the attribute. If a static value is specified for an attribute that accepts a request-time attribute expression then that static value is returned, even if the value is provided in the body of a action. The distinguished object REQUEST_TIME_VALUE is only returned if the value is specified as a request-time attribute expression or via the <jsp:attribute> action with a body that contains dynamic content (scriptlets, scripting expressions, EL expressions, standard actions, or custom actions). Returns null if the attribute is not set.

Parameters:
attName - the name of the attribute
Returns:
the attribute's value

setAttribute

public void setAttribute(String attName,
                         Object value)
Set the value of an attribute.

Parameters:
attName - the name of the attribute
value - the value.

getAttributeString

public String getAttributeString(String attName)
Get the value for a given attribute.

Parameters:
attName - the name of the attribute
Returns:
the attribute value string
Throws:
ClassCastException - if attribute value is not a String

getAttributes

public Enumeration getAttributes()
Enumerates the attributes.

Returns:
An enumeration of the attributes in a TagData
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TagExtraInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagExtraInfo

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagExtraInfo
public abstract class TagExtraInfo
extends Object

Optional class provided by the tag library author to describe additional translation-time information not described in the TLD. The TagExtraInfo class is mentioned in the Tag Library Descriptor file (TLD).

This class can be used:

  • to indicate that the tag defines scripting variables
  • to perform translation-time validation of the tag attributes.

It is the responsibility of the JSP translator that the initial value to be returned by calls to getTagInfo() corresponds to a TagInfo object for the tag being translated. If an explicit call to setTagInfo() is done, then the object passed will be returned in subsequent calls to getTagInfo().

The only way to affect the value returned by getTagInfo() is through a setTagInfo() call, and thus, TagExtraInfo.setTagInfo() is to be called by the JSP translator, with a TagInfo object that corresponds to the tag being translated. The call should happen before any invocation on validate() and before any invocation on getVariableInfo().

NOTE: It is a (translation time) error for a tag definition in a TLD with one or more variable subelements to have an associated TagExtraInfo implementation that returns a VariableInfo array with one or more elements from a call to getVariableInfo().

Constructor Summary
TagExtraInfo()
Sole constructor.
Method Summary
TagInfo | getTagInfo() Get the TagInfo for this class.
VariableInfo[] | getVariableInfo(TagData data) information on scripting variables defined by the tag associated with this TagExtraInfo instance.
boolean | isValid(TagData data) Translation-time validation of the attributes.
void | setTagInfo(TagInfo tagInfo) Set the TagInfo for this class.
ValidationMessage[] | validate(TagData data) Translation-time validation of the attributes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagExtraInfo

public TagExtraInfo()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

getVariableInfo

public VariableInfo[] getVariableInfo(TagData data)
information on scripting variables defined by the tag associated with this TagExtraInfo instance. Request-time attributes are indicated as such in the TagData parameter.

Parameters:
data - The TagData instance.
Returns:
An array of VariableInfo data, or null or a zero length array if no scripting variables are to be defined.

isValid

public boolean isValid(TagData data)
Translation-time validation of the attributes. Request-time attributes are indicated as such in the TagData parameter. Note that the preferred way to do validation is with the validate() method, since it can return more detailed information.

Parameters:
data - The TagData instance.
Returns:
Whether this tag instance is valid.
See Also:
validate(javax.servlet.jsp.tagext.TagData)

validate

public ValidationMessage[] validate(TagData data)
Translation-time validation of the attributes. Request-time attributes are indicated as such in the TagData parameter. Because of the higher quality validation messages possible, this is the preferred way to do validation (although isValid() still works).

JSP 2.0 and higher containers call validate() instead of isValid(). The default implementation of this method is to call isValid(). If isValid() returns false, a generic ValidationMessage[] is returned indicating isValid() returned false.

Parameters:
data - The TagData instance.
Returns:
A null object, or zero length array if no errors, an array of ValidationMessages otherwise.
Since:
2.0

setTagInfo

public final void setTagInfo(TagInfo tagInfo)
Set the TagInfo for this class.

Parameters:
tagInfo - The TagInfo this instance is extending

getTagInfo

public final TagInfo getTagInfo()
Get the TagInfo for this class.

Returns:
the taginfo instance this instance is extending
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TagFileInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagFileInfo

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagFileInfo
public class TagFileInfo
extends Object

Tag information for a tag file in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.

Since:
2.0

Constructor Summary
TagFileInfo(String name, String path, TagInfo tagInfo)
Constructor for TagFileInfo from data in the JSP 2.0 format for TLD.
Method Summary
String | getName() The unique action name of this tag.
String | getPath() Where to find the .tag file implementing this action.
TagInfo | getTagInfo() Returns information about this tag, parsed from the directives in the tag file.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagFileInfo

public TagFileInfo(String name,
                   String path,
                   TagInfo tagInfo)
Constructor for TagFileInfo from data in the JSP 2.0 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagFileInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.

Parameters:
name - The unique action name of this tag
path - Where to find the .tag file implementing this action, relative to the location of the TLD file.
tagInfo - The detailed information about this tag, as parsed from the directives in the tag file.
Method Detail

getName

public String getName()
The unique action name of this tag.

Returns:
The (short) name of the tag.

getPath

public String getPath()
Where to find the .tag file implementing this action.

Returns:
The path of the tag file, relative to the TLD, or "." if the tag file was defined in an implicit tag file.

getTagInfo

public TagInfo getTagInfo()
Returns information about this tag, parsed from the directives in the tag file.

Returns:
a TagInfo object containing information about this tag
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TagInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagInfo

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagInfo
public class TagInfo
extends Object

Tag information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.

Field Summary
static String | BODY_CONTENT_EMPTY Static constant for getBodyContent() when it is empty.
static String | BODY_CONTENT_JSP Static constant for getBodyContent() when it is JSP.
static String | BODY_CONTENT_SCRIPTLESS Static constant for getBodyContent() when it is scriptless.
static String | BODY_CONTENT_TAG_DEPENDENT Static constant for getBodyContent() when it is Tag dependent.
Constructor Summary
TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo)
Constructor for TagInfo from data in the JSP 1.1 format for TLD.
TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi)
Constructor for TagInfo from data in the JSP 1.2 format for TLD.
TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi, boolean dynamicAttributes)
Constructor for TagInfo from data in the JSP 2.0 format for TLD.
Method Summary
TagAttributeInfo[] | getAttributes() Attribute information (in the TLD) on this tag.
String | getBodyContent() The bodycontent information for this tag.
String | getDisplayName() Get the displayName.
String | getInfoString() The information string for the tag.
String | getLargeIcon() Get the path to the large icon.
String | getSmallIcon() Get the path to the small icon.
String | getTagClassName() Name of the class that provides the handler for this tag.
TagExtraInfo | getTagExtraInfo() The instance (if any) for extra tag information.
TagLibraryInfo | getTagLibrary() The instance of TabLibraryInfo we belong to.
String | getTagName() The name of the Tag.
TagVariableInfo[] | getTagVariableInfos() Get TagVariableInfo objects associated with this TagInfo.
VariableInfo[] | getVariableInfo(TagData data) Information on the scripting objects created by this tag at runtime.
boolean | hasDynamicAttributes() Get dynamicAttributes associated with this TagInfo.
boolean | isValid(TagData data) Translation-time validation of the attributes.
void | setTagExtraInfo(TagExtraInfo tei) Set the instance for extra tag information.
void | setTagLibrary(TagLibraryInfo tl) Set the TagLibraryInfo property.
ValidationMessage[] | validate(TagData data) Translation-time validation of the attributes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BODY_CONTENT_JSP

public static final String BODY_CONTENT_JSP
Static constant for getBodyContent() when it is JSP.

See Also:
Constant Field Values

BODY_CONTENT_TAG_DEPENDENT

public static final String BODY_CONTENT_TAG_DEPENDENT
Static constant for getBodyContent() when it is Tag dependent.

See Also:
Constant Field Values

BODY_CONTENT_EMPTY

public static final String BODY_CONTENT_EMPTY
Static constant for getBodyContent() when it is empty.

See Also:
Constant Field Values

BODY_CONTENT_SCRIPTLESS

public static final String BODY_CONTENT_SCRIPTLESS
Static constant for getBodyContent() when it is scriptless.

Since:
2.0
See Also:
Constant Field Values
Constructor Detail

TagInfo

public TagInfo(String tagName,
               String tagClassName,
               String bodycontent,
               String infoString,
               TagLibraryInfo taglib,
               TagExtraInfo tagExtraInfo,
               TagAttributeInfo[] attributeInfo)
Constructor for TagInfo from data in the JSP 1.1 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.

Parameters:
tagName - The name of this tag
tagClassName - The name of the tag handler class
bodycontent - Information on the body content of these tags
infoString - The (optional) string information for this tag
taglib - The instance of the tag library that contains us.
tagExtraInfo - The instance providing extra Tag info. May be null
attributeInfo - An array of AttributeInfo data from descriptor. May be null;

TagInfo

public TagInfo(String tagName,
               String tagClassName,
               String bodycontent,
               String infoString,
               TagLibraryInfo taglib,
               TagExtraInfo tagExtraInfo,
               TagAttributeInfo[] attributeInfo,
               String displayName,
               String smallIcon,
               String largeIcon,
               TagVariableInfo[] tvi)
Constructor for TagInfo from data in the JSP 1.2 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.

Parameters:
tagName - The name of this tag
tagClassName - The name of the tag handler class
bodycontent - Information on the body content of these tags
infoString - The (optional) string information for this tag
taglib - The instance of the tag library that contains us.
tagExtraInfo - The instance providing extra Tag info. May be null
attributeInfo - An array of AttributeInfo data from descriptor. May be null;
displayName - A short name to be displayed by tools
smallIcon - Path to a small icon to be displayed by tools
largeIcon - Path to a large icon to be displayed by tools
tvi - An array of a TagVariableInfo (or null)

TagInfo

public TagInfo(String tagName,
               String tagClassName,
               String bodycontent,
               String infoString,
               TagLibraryInfo taglib,
               TagExtraInfo tagExtraInfo,
               TagAttributeInfo[] attributeInfo,
               String displayName,
               String smallIcon,
               String largeIcon,
               TagVariableInfo[] tvi,
               boolean dynamicAttributes)
Constructor for TagInfo from data in the JSP 2.0 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.

Parameters:
tagName - The name of this tag
tagClassName - The name of the tag handler class
bodycontent - Information on the body content of these tags
infoString - The (optional) string information for this tag
taglib - The instance of the tag library that contains us.
tagExtraInfo - The instance providing extra Tag info. May be null
attributeInfo - An array of AttributeInfo data from descriptor. May be null;
displayName - A short name to be displayed by tools
smallIcon - Path to a small icon to be displayed by tools
largeIcon - Path to a large icon to be displayed by tools
tvi - An array of a TagVariableInfo (or null)
dynamicAttributes - True if supports dynamic attributes
Since:
2.0
Method Detail

getTagName

public String getTagName()
The name of the Tag.

Returns:
The (short) name of the tag.

getAttributes

public TagAttributeInfo[] getAttributes()
Attribute information (in the TLD) on this tag. The return is an array describing the attributes of this tag, as indicated in the TLD.

Returns:
The array of TagAttributeInfo for this tag, or a zero-length array if the tag has no attributes.

getVariableInfo

public VariableInfo[] getVariableInfo(TagData data)
Information on the scripting objects created by this tag at runtime. This is a convenience method on the associated TagExtraInfo class.

Parameters:
data - TagData describing this action.
Returns:
if a TagExtraInfo object is associated with this TagInfo, the result of getTagExtraInfo().getVariableInfo( data ), otherwise null.

isValid

public boolean isValid(TagData data)
Translation-time validation of the attributes. This is a convenience method on the associated TagExtraInfo class.

Parameters:
data - The translation-time TagData instance.
Returns:
Whether the data is valid.

validate

public ValidationMessage[] validate(TagData data)
Translation-time validation of the attributes. This is a convenience method on the associated TagExtraInfo class.

Parameters:
data - The translation-time TagData instance.
Returns:
A null object, or zero length array if no errors, an array of ValidationMessages otherwise.
Since:
2.0

setTagExtraInfo

public void setTagExtraInfo(TagExtraInfo tei)
Set the instance for extra tag information.

Parameters:
tei - the TagExtraInfo instance

getTagExtraInfo

public TagExtraInfo getTagExtraInfo()
The instance (if any) for extra tag information.

Returns:
The TagExtraInfo instance, if any.

getTagClassName

public String getTagClassName()
Name of the class that provides the handler for this tag.

Returns:
The name of the tag handler class.

getBodyContent

public String getBodyContent()
The bodycontent information for this tag. If the bodycontent is not defined for this tag, the default of JSP will be returned.

Returns:
the body content string.

getInfoString

public String getInfoString()
The information string for the tag.

Returns:
the info string, or null if not defined

setTagLibrary

public void setTagLibrary(TagLibraryInfo tl)
Set the TagLibraryInfo property. Note that a TagLibraryInfo element is dependent not just on the TLD information but also on the specific taglib instance used. This means that a fair amount of work needs to be done to construct and initialize TagLib objects. If used carefully, this setter can be used to avoid having to create new TagInfo elements for each taglib directive.

Parameters:
tl - the TagLibraryInfo to assign

getTagLibrary

public TagLibraryInfo getTagLibrary()
The instance of TabLibraryInfo we belong to.

Returns:
the tag library instance we belong to

getDisplayName

public String getDisplayName()
Get the displayName.

Returns:
A short name to be displayed by tools, or null if not defined

getSmallIcon

public String getSmallIcon()
Get the path to the small icon.

Returns:
Path to a small icon to be displayed by tools, or null if not defined

getLargeIcon

public String getLargeIcon()
Get the path to the large icon.

Returns:
Path to a large icon to be displayed by tools, or null if not defined

getTagVariableInfos

public TagVariableInfo[] getTagVariableInfos()
Get TagVariableInfo objects associated with this TagInfo.

Returns:
Array of TagVariableInfo objects corresponding to variables declared by this tag, or a zero length array if no variables have been declared

hasDynamicAttributes

public boolean hasDynamicAttributes()
Get dynamicAttributes associated with this TagInfo.

Returns:
True if tag handler supports dynamic attributes
Since:
2.0
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TagLibraryInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagLibraryInfo

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagLibraryInfo
public abstract class TagLibraryInfo
extends Object

Translation-time information associated with a taglib directive, and its underlying TLD file. Most of the information is directly from the TLD, except for the prefix and the uri values used in the taglib directive

Field Summary
protected FunctionInfo[] | functions An array describing the functions that are defined in this tag library.
protected String | info Information (documentation) for this TLD.
protected String | jspversion The version of the JSP specification this tag library is written to.
protected String | prefix The prefix assigned to this taglib from the taglib directive.
protected String | shortname The preferred short name (prefix) as indicated in the TLD.
protected TagFileInfo[] | tagFiles An array describing the tag files that are defined in this tag library.
protected TagInfo[] | tags An array describing the tags that are defined in this tag library.
protected String | tlibversion The version of the tag library.
protected String | uri The value of the uri attribute from the taglib directive for this library.
protected String | urn The "reliable" URN indicated in the TLD.
Constructor Summary
protected TagLibraryInfo(String prefix, String uri)
Constructor.
Method Summary
FunctionInfo | getFunction(String name) Get the FunctionInfo for a given function name, looking through all the functions in this tag library.
FunctionInfo[] | getFunctions() An array describing the functions that are defined in this tag library.
String | getInfoString() Information (documentation) for this TLD.
String | getPrefixString() The prefix assigned to this taglib from the taglib directive
String | getReliableURN() The "reliable" URN indicated in the TLD (the uri element).
String | getRequiredVersion() A string describing the required version of the JSP container.
String | getShortName() The preferred short name (prefix) as indicated in the TLD.
TagInfo | getTag(String shortname) Get the TagInfo for a given tag name, looking through all the tags in this tag library.
TagFileInfo | getTagFile(String shortname) Get the TagFileInfo for a given tag name, looking through all the tag files in this tag library.
TagFileInfo[] | getTagFiles() An array describing the tag files that are defined in this tag library.
TagInfo[] | getTags() An array describing the tags that are defined in this tag library.
String | getURI() The value of the uri attribute from the taglib directive for this library.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

prefix

protected String prefix
The prefix assigned to this taglib from the taglib directive.

uri

protected String uri
The value of the uri attribute from the taglib directive for this library.

tags

protected TagInfo[] tags
An array describing the tags that are defined in this tag library.

tagFiles

protected TagFileInfo[] tagFiles
An array describing the tag files that are defined in this tag library.

Since:
2.0

functions

protected FunctionInfo[] functions
An array describing the functions that are defined in this tag library.

Since:
2.0

tlibversion

protected String tlibversion
The version of the tag library.

jspversion

protected String jspversion
The version of the JSP specification this tag library is written to.

shortname

protected String shortname
The preferred short name (prefix) as indicated in the TLD.

urn

protected String urn
The "reliable" URN indicated in the TLD.

info

protected String info
Information (documentation) for this TLD.

Constructor Detail

TagLibraryInfo

protected TagLibraryInfo(String prefix,
                         String uri)
Constructor. This will invoke the constructors for TagInfo, and TagAttributeInfo after parsing the TLD file.

Parameters:
prefix - the prefix actually used by the taglib directive
uri - the URI actually used by the taglib directive
Method Detail

getURI

public String getURI()
The value of the uri attribute from the taglib directive for this library.

Returns:
the value of the uri attribute

getPrefixString

public String getPrefixString()
The prefix assigned to this taglib from the taglib directive

Returns:
the prefix assigned to this taglib from the taglib directive

getShortName

public String getShortName()
The preferred short name (prefix) as indicated in the TLD. This may be used by authoring tools as the preferred prefix to use when creating an taglib directive for this library.

Returns:
the preferred short name for the library

getReliableURN

public String getReliableURN()
The "reliable" URN indicated in the TLD (the uri element). This may be used by authoring tools as a global identifier to use when creating a taglib directive for this library.

Returns:
a reliable URN to a TLD like this

getInfoString

public String getInfoString()
Information (documentation) for this TLD.

Returns:
the info string for this tag lib

getRequiredVersion

public String getRequiredVersion()
A string describing the required version of the JSP container.

Returns:
the (minimal) required version of the JSP container.
See Also:
JspEngineInfo

getTags

public TagInfo[] getTags()
An array describing the tags that are defined in this tag library.

Returns:
the TagInfo objects corresponding to the tags defined by this tag library, or a zero length array if this tag library defines no tags

getTagFiles

public TagFileInfo[] getTagFiles()
An array describing the tag files that are defined in this tag library.

Returns:
the TagFileInfo objects corresponding to the tag files defined by this tag library, or a zero length array if this tag library defines no tags files
Since:
2.0

getTag

public TagInfo getTag(String shortname)
Get the TagInfo for a given tag name, looking through all the tags in this tag library.

Parameters:
shortname - The short name (no prefix) of the tag
Returns:
the TagInfo for the tag with the specified short name, or null if no such tag is found

getTagFile

public TagFileInfo getTagFile(String shortname)
Get the TagFileInfo for a given tag name, looking through all the tag files in this tag library.

Parameters:
shortname - The short name (no prefix) of the tag
Returns:
the TagFileInfo for the specified Tag file, or null if no Tag file is found
Since:
2.0

getFunctions

public FunctionInfo[] getFunctions()
An array describing the functions that are defined in this tag library.

Returns:
the functions defined in this tag library, or a zero length array if the tag library defines no functions.
Since:
2.0

getFunction

public FunctionInfo getFunction(String name)
Get the FunctionInfo for a given function name, looking through all the functions in this tag library.

Parameters:
name - The name (no prefix) of the function
Returns:
the FunctionInfo for the function with the given name, or null if no such function exists
Since:
2.0
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TagLibraryValidator

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagLibraryValidator

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagLibraryValidator
public abstract class TagLibraryValidator
extends Object

Translation-time validator class for a JSP page. A validator operates on the XML view associated with the JSP page.

The TLD file associates a TagLibraryValidator class and some init arguments with a tag library.

The JSP container is reponsible for locating an appropriate instance of the appropriate subclass by

  • new a fresh instance, or reuse an available one
  • invoke the setInitParams(Map) method on the instance
once initialized, the validate(String, String, PageData) method will be invoked, where the first two arguments are the prefix and uri for this tag library in the XML View. The prefix is intended to make it easier to produce an error message. However, it is not always accurate. In the case where a single URI is mapped to more than one prefix in the XML view, the prefix of the first URI is provided. Therefore, to provide high quality error messages in cases where the tag elements themselves are checked, the prefix parameter should be ignored and the actual prefix of the element should be used instead. TagLibraryValidators should always use the uri to identify elements as beloning to the tag library, not the prefix.

A TagLibraryValidator instance may create auxiliary objects internally to perform the validation (e.g. an XSchema validator) and may reuse it for all the pages in a given translation run.

The JSP container is not guaranteed to serialize invocations of validate() method, and TagLibraryValidators should perform any synchronization they may require.

As of JSP 2.0, a JSP container must provide a jsp:id attribute to provide higher quality validation errors. The container will track the JSP pages as passed to the container, and will assign to each element a unique "id", which is passed as the value of the jsp:id attribute. Each XML element in the XML view available will be extended with this attribute. The TagLibraryValidator can then use the attribute in one or more ValidationMessage objects. The container then, in turn, can use these values to provide more precise information on the location of an error.

The actual prefix of the id attribute may or may not be jsp but it will always map to the namespace http://java.sun.com/JSP/Page. A TagLibraryValidator implementation must rely on the uri, not the prefix, of the id attribute.

Constructor Summary
TagLibraryValidator()
Sole constructor.
Method Summary
Map | getInitParameters() Get the init parameters data as an immutable Map.
void | release() Release any data kept by this instance for validation purposes.
void | setInitParameters(Map map) Set the init data in the TLD for this validator.
ValidationMessage[] | validate(String prefix, String uri, PageData page) Validate a JSP page.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagLibraryValidator

public TagLibraryValidator()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

setInitParameters

public void setInitParameters(Map map)
Set the init data in the TLD for this validator. Parameter names are keys, and parameter values are the values.

Parameters:
map - A Map describing the init parameters

getInitParameters

public Map getInitParameters()
Get the init parameters data as an immutable Map. Parameter names are keys, and parameter values are the values.

Returns:
The init parameters as an immutable map.

validate

public ValidationMessage[] validate(String prefix,
                                    String uri,
                                    PageData page)
Validate a JSP page. This will get invoked once per unique tag library URI in the XML view. This method will return null if the page is valid; otherwise the method should return an array of ValidationMessage objects. An array of length zero is also interpreted as no errors.

Parameters:
prefix - the first prefix with which the tag library is associated, in the XML view. Note that some tags may use a different prefix if the namespace is redefined.
uri - the tag library's unique identifier
page - the JspData page object
Returns:
A null object, or zero length array if no errors, an array of ValidationMessages otherwise.

release

public void release()
Release any data kept by this instance for validation purposes.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TagSupport

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagSupport

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagSupport
All Implemented Interfaces:
IterationTag, JspTag, Serializable, Tag
Direct Known Subclasses:
BodyTagSupport
public class TagSupport
extends Object
implements IterationTag, Serializable

A base class for defining new tag handlers implementing Tag.

The TagSupport class is a utility class intended to be used as the base class for new tag handlers. The TagSupport class implements the Tag and IterationTag interfaces and adds additional convenience methods including getter methods for the properties in Tag. TagSupport has one static method that is included to facilitate coordination among cooperating tags.

Many tag handlers will extend TagSupport and only redefine a few methods.

See Also:
Serialized Form

Field Summary
protected String | id The value of the id attribute of this tag; or null.
protected PageContext | pageContext The PageContext.
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TagSupport()
Default constructor, all subclasses are required to define only a public constructor with the same signature, and to call the superclass constructor.
Method Summary
int | doAfterBody() Default processing for a body.
int | doEndTag() Default processing of the end tag returning EVAL_PAGE.
int | doStartTag() Default processing of the start tag, returning SKIP_BODY.
static Tag | findAncestorWithClass(Tag from, Class klass) Find the instance of a given class type that is closest to a given instance.
String | getId() The value of the id attribute of this tag; or null.
Tag | getParent() The Tag instance most closely enclosing this tag instance.
Object | getValue(String k) Get a the value associated with a key.
Enumeration | getValues() Enumerate the keys for the values kept by this tag handler.
void | release() Release state.
void | removeValue(String k) Remove a value associated with a key.
void | setId(String id) Set the id attribute for this tag.
void | setPageContext(PageContext pageContext) Set the page context.
void | setParent(Tag t) Set the nesting tag of this tag.
void | setValue(String k, Object o) Associate a value with a String key.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

id

protected String id
The value of the id attribute of this tag; or null.

pageContext

protected PageContext pageContext
The PageContext.

Constructor Detail

TagSupport

public TagSupport()
Default constructor, all subclasses are required to define only a public constructor with the same signature, and to call the superclass constructor. This constructor is called by the code generated by the JSP translator.

Method Detail

findAncestorWithClass

public static final Tag findAncestorWithClass(Tag from,
                                              Class klass)
Find the instance of a given class type that is closest to a given instance. This method uses the getParent method from the Tag interface. This method is used for coordination among cooperating tags.

The current version of the specification only provides one formal way of indicating the observable type of a tag handler: its tag handler implementation class, described in the tag-class subelement of the tag element. This is extended in an informal manner by allowing the tag library author to indicate in the description subelement an observable type. The type should be a subtype of the tag handler implementation class or void. This addititional constraint can be exploited by a specialized container that knows about that specific tag library, as in the case of the JSP standard tag library.

When a tag library author provides information on the observable type of a tag handler, client programmatic code should adhere to that constraint. Specifically, the Class passed to findAncestorWithClass should be a subtype of the observable type.

Parameters:
from - The instance from where to start looking.
klass - The subclass of Tag or interface to be matched
Returns:
the nearest ancestor that implements the interface or is an instance of the class specified

doStartTag

public int doStartTag()
               throws JspException
Default processing of the start tag, returning SKIP_BODY.

Specified by:
doStartTag in interface Tag
Returns:
SKIP_BODY
Throws:
JspException - if an error occurs while processing this tag
See Also:
Tag.doStartTag()

doEndTag

public int doEndTag()
             throws JspException
Default processing of the end tag returning EVAL_PAGE.

Specified by:
doEndTag in interface Tag
Returns:
EVAL_PAGE
Throws:
JspException - if an error occurs while processing this tag
See Also:
Tag.doEndTag()

doAfterBody

public int doAfterBody()
                throws JspException
Default processing for a body.

Specified by:
doAfterBody in interface IterationTag
Returns:
SKIP_BODY
Throws:
JspException - if an error occurs while processing this tag
See Also:
IterationTag.doAfterBody()

release

public void release()
Release state.

Specified by:
release in interface Tag
See Also:
Tag.release()

setParent

public void setParent(Tag t)
Set the nesting tag of this tag.

Specified by:
setParent in interface Tag
Parameters:
t - The parent Tag.
See Also:
Tag.setParent(Tag)

getParent

public Tag getParent()
The Tag instance most closely enclosing this tag instance.

Specified by:
getParent in interface Tag
Returns:
the parent tag instance or null
See Also:
Tag.getParent()

setId

public void setId(String id)
Set the id attribute for this tag.

Parameters:
id - The String for the id.

getId

public String getId()
The value of the id attribute of this tag; or null.

Returns:
the value of the id attribute, or null

setPageContext

public void setPageContext(PageContext pageContext)
Set the page context.

Specified by:
setPageContext in interface Tag
Parameters:
pageContext - The PageContext.
See Also:
Tag.setPageContext(javax.servlet.jsp.PageContext)

setValue

public void setValue(String k,
                     Object o)
Associate a value with a String key.

Parameters:
k - The key String.
o - The value to associate.

getValue

public Object getValue(String k)
Get a the value associated with a key.

Parameters:
k - The string key.
Returns:
The value associated with the key, or null.

removeValue

public void removeValue(String k)
Remove a value associated with a key.

Parameters:
k - The string key.

getValues

public Enumeration getValues()
Enumerate the keys for the values kept by this tag handler.

Returns:
An enumeration of all the keys for the values set, or null or an empty Enumeration if no values have been set.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TagVariableInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagVariableInfo

java.lang.Object
    extended by javax.servlet.jsp.tagext.TagVariableInfo
public class TagVariableInfo
extends Object

Variable information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time. This object should be immutable. This information is only available in JSP 1.2 format TLDs or above.

Constructor Summary
TagVariableInfo(String nameGiven, String nameFromAttribute, String className, boolean declare, int scope)
Constructor for TagVariableInfo.
Method Summary
String | getClassName() The body of the <variable-class> element.
boolean | getDeclare() The body of the <declare> element.
String | getNameFromAttribute() The body of the <name-from-attribute> element.
String | getNameGiven() The body of the <name-given> element.
int | getScope() The body of the <scope> element.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagVariableInfo

public TagVariableInfo(String nameGiven,
                       String nameFromAttribute,
                       String className,
                       boolean declare,
                       int scope)
Constructor for TagVariableInfo.

Parameters:
nameGiven - value of <name-given>
nameFromAttribute - value of <name-from-attribute>
className - value of <variable-class>
declare - value of <declare>
scope - value of <scope>
Method Detail

getNameGiven

public String getNameGiven()
The body of the <name-given> element.

Returns:
The variable name as a constant

getNameFromAttribute

public String getNameFromAttribute()
The body of the <name-from-attribute> element. This is the name of an attribute whose (translation-time) value will give the name of the variable. One of <name-given> or <name-from-attribute> is required.

Returns:
The attribute whose value defines the variable name

getClassName

public String getClassName()
The body of the <variable-class> element.

Returns:
The name of the class of the variable or 'java.lang.String' if not defined in the TLD.

getDeclare

public boolean getDeclare()
The body of the <declare> element.

Returns:
Whether the variable is to be declared or not. If not defined in the TLD, 'true' will be returned.

getScope

public int getScope()
The body of the <scope> element.

Returns:
The scope to give the variable. NESTED scope will be returned if not defined in the TLD.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TryCatchFinally

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface TryCatchFinally

public interface TryCatchFinally

The auxiliary interface of a Tag, IterationTag or BodyTag tag handler that wants additional hooks for managing resources.

This interface provides two new methods: doCatch(Throwable) and doFinally(). The prototypical invocation is as follows:

 h = get a Tag();  // get a tag handler, perhaps from pool

 h.setPageContext(pc);  // initialize as desired
 h.setParent(null);
 h.setFoo("foo");

 // tag invocation protocol; see Tag.java
 try {
   doStartTag()...
   ....
   doEndTag()...
 } catch (Throwable t) {
   // react to exceptional condition
   h.doCatch(t);
 } finally {
   // restore data invariants and release per-invocation resources
   h.doFinally();
 }

 ... other invocations perhaps with some new setters
 ...
 h.release();  // release long-term resources

Method Summary
 void doCatch(Throwable t)
Invoked if a Throwable occurs while evaluating the BODY inside a tag or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().
 void doFinally()
Invoked in all cases after doEndTag() for any class implementing Tag, IterationTag or BodyTag.

Method Detail

doCatch

public void doCatch(Throwable t)
             throws Throwable
Invoked if a Throwable occurs while evaluating the BODY inside a tag or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().

This method is not invoked if the Throwable occurs during one of the setter methods.

This method may throw an exception (the same or a new one) that will be propagated further up the nest chain. If an exception is thrown, doFinally() will be invoked.

This method is intended to be used to respond to an exceptional condition.

Parameters:
t - The throwable exception navigating through this tag.
Throws:
Throwable - if the exception is to be rethrown further up the nest chain.

doFinally

public void doFinally()
Invoked in all cases after doEndTag() for any class implementing Tag, IterationTag or BodyTag. This method is invoked even if an exception has occurred in the BODY of the tag, or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().

This method is not invoked if the Throwable occurs during one of the setter methods.

This method should not throw an Exception.

This method is intended to maintain per-invocation data integrity and resource management actions.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ValidationMessage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class ValidationMessage

java.lang.Object
    extended by javax.servlet.jsp.tagext.ValidationMessage
public class ValidationMessage
extends Object

A validation message from either TagLibraryValidator or TagExtraInfo.

As of JSP 2.0, a JSP container must support a jsp:id attribute to provide higher quality validation errors. The container will track the JSP pages as passed to the container, and will assign to each element a unique "id", which is passed as the value of the jsp:id attribute. Each XML element in the XML view available will be extended with this attribute. The TagLibraryValidator can then use the attribute in one or more ValidationMessage objects. The container then, in turn, can use these values to provide more precise information on the location of an error.

The actual prefix of the id attribute may or may not be jsp but it will always map to the namespace http://java.sun.com/JSP/Page. A TagLibraryValidator implementation must rely on the uri, not the prefix, of the id attribute.

Constructor Summary
ValidationMessage(String id, String message)
Create a ValidationMessage.
Method Summary
String | getId() Get the jsp:id.
String | getMessage() Get the localized validation message.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValidationMessage

public ValidationMessage(String id,
                         String message)
Create a ValidationMessage. The message String should be non-null. The value of id may be null, if the message is not specific to any XML element, or if no jsp:id attributes were passed on. If non-null, the value of id must be the value of a jsp:id attribute for the PageData passed into the validate() method.

Parameters:
id - Either null, or the value of a jsp:id attribute.
message - A localized validation message.
Method Detail

getId

public String getId()
Get the jsp:id. Null means that there is no information available.

Returns:
The jsp:id information.

getMessage

public String getMessage()
Get the localized validation message.

Returns:
A validation message
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


VariableInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class VariableInfo

java.lang.Object
    extended by javax.servlet.jsp.tagext.VariableInfo
public class VariableInfo
extends Object

Information on the scripting variables that are created/modified by a tag (at run-time). This information is provided by TagExtraInfo classes and it is used by the translation phase of JSP.

Scripting variables generated by a custom action have an associated scope of either AT_BEGIN, NESTED, or AT_END.

The class name (VariableInfo.getClassName) in the returned objects is used to determine the types of the scripting variables. Note that because scripting variables are assigned their values from scoped attributes which cannot be of primitive types, "boxed" types such as java.lang.Integer must be used instead of primitives.

The class name may be a Fully Qualified Class Name, or a short class name.

If a Fully Qualified Class Name is provided, it should refer to a class that should be in the CLASSPATH for the Web Application (see Servlet 2.4 specification - essentially it is WEB-INF/lib and WEB-INF/classes). Failure to be so will lead to a translation-time error.

If a short class name is given in the VariableInfo objects, then the class name must be that of a public class in the context of the import directives of the page where the custom action appears. The class must also be in the CLASSPATH for the Web Application (see Servlet 2.4 specification - essentially it is WEB-INF/lib and WEB-INF/classes). Failure to be so will lead to a translation-time error.

Usage Comments

Frequently a fully qualified class name will refer to a class that is known to the tag library and thus, delivered in the same JAR file as the tag handlers. In most other remaining cases it will refer to a class that is in the platform on which the JSP processor is built (like J2EE). Using fully qualified class names in this manner makes the usage relatively resistant to configuration errors.

A short name is usually generated by the tag library based on some attributes passed through from the custom action user (the author), and it is thus less robust: for instance a missing import directive in the referring JSP page will lead to an invalid short name class and a translation error.

Synchronization Protocol

The result of the invocation on getVariableInfo is an array of VariableInfo objects. Each such object describes a scripting variable by providing its name, its type, whether the variable is new or not, and what its scope is. Scope is best described through a picture:

NESTED, AT_BEGIN and AT_END Variable Scopes

The JSP 2.0 specification defines the interpretation of 3 values:

  • NESTED, if the scripting variable is available between the start tag and the end tag of the action that defines it.
  • AT_BEGIN, if the scripting variable is available from the start tag of the action that defines it until the end of the scope.
  • AT_END, if the scripting variable is available after the end tag of the action that defines it until the end of the scope.
The scope value for a variable implies what methods may affect its value and thus where synchronization is needed as illustrated by the table below. Note: the synchronization of the variable(s) will occur after the respective method has been called.
Variable Synchronization Points
doStartTag() doInitBody() doAfterBody() doEndTag() doTag()
Tag
         AT_BEGIN, NESTED

AT_BEGIN, AT_END
IterationTag
         AT_BEGIN, NESTED
AT_BEGIN, NESTED
 AT_BEGIN, AT_END
BodyTag
         AT_BEGIN, NESTED1
 AT_BEGIN, NESTED1
 AT_BEGIN, NESTED
 AT_BEGIN, AT_END
SimpleTag

AT_BEGIN, AT_END
1 Called after doStartTag() if EVAL_BODY_INCLUDE is returned, or after doInitBody() otherwise.

Variable Information in the TLD

Scripting variable information can also be encoded directly for most cases into the Tag Library Descriptor using the <variable> subelement of the <tag> element. See the JSP specification.

Field Summary
static int | AT_BEGIN Scope information that scripting variable is visible after start tag.
static int | AT_END Scope information that scripting variable is visible after end tag.
static int | NESTED Scope information that scripting variable is visible only within the start/end tags.
Constructor Summary
VariableInfo(String varName, String className, boolean declare, int scope)
Constructor These objects can be created (at translation time) by the TagExtraInfo instances.
Method Summary
String | getClassName() Returns the type of this variable.
boolean | getDeclare() Returns whether this is a new variable.
int | getScope() Returns the lexical scope of the variable.
String | getVarName() Returns the name of the scripting variable.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NESTED

public static final int NESTED
Scope information that scripting variable is visible only within the start/end tags.

See Also:
Constant Field Values

AT_BEGIN

public static final int AT_BEGIN
Scope information that scripting variable is visible after start tag.

See Also:
Constant Field Values

AT_END

public static final int AT_END
Scope information that scripting variable is visible after end tag.

See Also:
Constant Field Values
Constructor Detail

VariableInfo

public VariableInfo(String varName,
                    String className,
                    boolean declare,
                    int scope)
Constructor These objects can be created (at translation time) by the TagExtraInfo instances.

Parameters:
varName - The name of the scripting variable
className - The type of this variable
declare - If true, it is a new variable (in some languages this will require a declaration)
scope - Indication on the lexical scope of the variable
Method Detail

getVarName

public String getVarName()
Returns the name of the scripting variable.

Returns:
the name of the scripting variable

getClassName

public String getClassName()
Returns the type of this variable.

Returns:
the type of this variable

getDeclare

public boolean getDeclare()
Returns whether this is a new variable. If so, in some languages this will require a declaration.

Returns:
whether this is a new variable.

getScope

public int getScope()
Returns the lexical scope of the variable.

Returns:
the lexical scope of the variable, either AT_BEGIN, AT_END, or NESTED.
See Also:
AT_BEGIN, AT_END, NESTED
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RequestDispatcher

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface RequestDispatcher

public interface RequestDispatcher

Defines an object that receives requests from the client and sends them to any resource (such as a servlet, HTML file, or JSP file) on the server. The servlet container creates the RequestDispatcher object, which is used as a wrapper around a server resource located at a particular path or given by a particular name.

This interface is intended to wrap servlets, but a servlet container can create RequestDispatcher objects to wrap any type of resource.

Version:
$Version$
Author:
Various
See Also:
ServletContext.getRequestDispatcher(java.lang.String),
ServletContext.getNamedDispatcher(java.lang.String),
ServletRequest.getRequestDispatcher(java.lang.String)

Method Summary
void | forward(ServletRequest request, ServletResponse response) Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server.
void | include(ServletRequest request, ServletResponse response) Includes the content of a resource (servlet, JSP page, HTML file) in the response.

Method Detail

forward

public void forward(ServletRequest request,
                    ServletResponse response)
             throws ServletException,
                    IOException
Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server. This method allows one servlet to do preliminary processing of a request and another resource to generate the response.

For a RequestDispatcher obtained via getRequestDispatcher(), the ServletRequest object has its path elements and parameters adjusted to match the path of the target resource.

forward should be called before the response has been committed to the client (before response body output has been flushed). If the response already has been committed, this method throws an IllegalStateException. Uncommitted output in the response buffer is automatically cleared before the forward.

The request and response parameters must be either the same objects as were passed to the calling servlet's service method or be subclasses of the ServletRequestWrapper or ServletResponseWrapper classes that wrap them.

Parameters:
request - a ServletRequest object that represents the request the client makes of the servlet
response - a ServletResponse object that represents the response the servlet returns to the client
Throws:
ServletException - if the target resource throws this exception
IOException - if the target resource throws this exception
IllegalStateException - if the response was already committed

include

public void include(ServletRequest request,
                    ServletResponse response)
             throws ServletException,
                    IOException
Includes the content of a resource (servlet, JSP page, HTML file) in the response. In essence, this method enables programmatic server-side includes.

The ServletResponse object has its path elements and parameters remain unchanged from the caller's. The included servlet cannot change the response status code or set headers; any attempt to make a change is ignored.

The request and response parameters must be either the same objects as were passed to the calling servlet's service method or be subclasses of the ServletRequestWrapper or ServletResponseWrapper classes that wrap them.

Parameters:
request - a ServletRequest object that contains the client's request
response - a ServletResponse object that contains the servlet's response
Throws:
ServletException - if the included resource throws this exception
IOException - if the included resource throws this exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Servlet

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface Servlet

All Known Subinterfaces:
HttpJspPage, JspPage
All Known Implementing Classes:
GenericServlet
public interface Servlet

Defines methods that all servlets must implement.

A servlet is a small Java program that runs within a Web server. Servlets receive and respond to requests from Web clients, usually across HTTP, the HyperText Transfer Protocol.

To implement this interface, you can write a generic servlet that extends javax.servlet.GenericServlet or an HTTP servlet that extends javax.servlet.http.HttpServlet.

This interface defines methods to initialize a servlet, to service requests, and to remove a servlet from the server. These are known as life-cycle methods and are called in the following sequence:

  1. The servlet is constructed, then initialized with the init method.
  2. Any calls from clients to the service method are handled.
  3. The servlet is taken out of service, then destroyed with the destroy method, then garbage collected and finalized.

In addition to the life-cycle methods, this interface provides the getServletConfig method, which the servlet can use to get any startup information, and the getServletInfo method, which allows the servlet to return basic information about itself, such as author, version, and copyright.

Version:
$Version$
Author:
Various
See Also:
GenericServlet, HttpServlet

Method Summary
void | destroy() Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.
ServletConfig | getServletConfig() Returns a ServletConfig object, which contains initialization and startup parameters for this servlet.
String | getServletInfo() Returns information about the servlet, such as author, version, and copyright.
void | init(ServletConfig config) Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
void | service(ServletRequest req, ServletResponse res) Called by the servlet container to allow the servlet to respond to a request.

Method Detail

init

public void init(ServletConfig config)
          throws ServletException
Called by the servlet container to indicate to a servlet that the servlet is being placed into service.

The servlet container calls the init method exactly once after instantiating the servlet. The init method must complete successfully before the servlet can receive any requests.

The servlet container cannot place the servlet into service if the init method

  1. Throws a ServletException
  2. Does not return within a time period defined by the Web server

Parameters:
config - a ServletConfig object containing the servlet's configuration and initialization parameters
Throws:
ServletException - if an exception has occurred that interferes with the servlet's normal operation
See Also:
UnavailableException, getServletConfig()

getServletConfig

public ServletConfig getServletConfig()
Returns a ServletConfig object, which contains initialization and startup parameters for this servlet. The ServletConfig object returned is the one passed to the init method.

Implementations of this interface are responsible for storing the ServletConfig object so that this method can return it. The GenericServlet class, which implements this interface, already does this.

Returns:
the ServletConfig object that initializes this servlet
See Also:
init(javax.servlet.ServletConfig)

service

public void service(ServletRequest req,
                    ServletResponse res)
             throws ServletException,
                    IOException
Called by the servlet container to allow the servlet to respond to a request.

This method is only called after the servlet's init() method has completed successfully.

The status code of the response always should be set for a servlet that throws or sends an error.

Servlets typically run inside multithreaded servlet containers that can handle multiple requests concurrently. Developers must be aware to synchronize access to any shared resources such as files, network connections, and as well as the servlet's class and instance variables. More information on multithreaded programming in Java is available in the Java tutorial on multi-threaded programming.

Parameters:
req - the ServletRequest object that contains the client's request
res - the ServletResponse object that contains the servlet's response
Throws:
ServletException - if an exception occurs that interferes with the servlet's normal operation
IOException - if an input or output exception occurs

getServletInfo

public String getServletInfo()
Returns information about the servlet, such as author, version, and copyright.

The string that this method returns should be plain text and not markup of any kind (such as HTML, XML, etc.).

Returns:
a String containing servlet information

destroy

public void destroy()
Called by the servlet container to indicate to a servlet that the servlet is being taken out of service. This method is only called once all threads within the servlet's service method have exited or after a timeout period has passed. After the servlet container calls this method, it will not call the service method again on this servlet.

This method gives the servlet an opportunity to clean up any resources that are being held (for example, memory, file handles, threads) and make sure that any persistent state is synchronized with the servlet's current state in memory.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletConfig

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletConfig

All Known Implementing Classes:
GenericServlet
public interface ServletConfig

A servlet configuration object used by a servlet container to pass information to a servlet during initialization.

Method Summary
String | getInitParameter(String name) Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
Enumeration | getInitParameterNames() Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
ServletContext | getServletContext() Returns a reference to the ServletContext in which the caller is executing.
String | getServletName() Returns the name of this servlet instance.

Method Detail

getServletName

public String getServletName()
Returns the name of this servlet instance. The name may be provided via server administration, assigned in the web application deployment descriptor, or for an unregistered (and thus unnamed) servlet instance it will be the servlet's class name.

Returns:
the name of the servlet instance

getServletContext

public ServletContext getServletContext()
Returns a reference to the ServletContext in which the caller is executing.

Returns:
a ServletContext object, used by the caller to interact with its servlet container
See Also:
ServletContext

getInitParameter

public String getInitParameter(String name)
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.

Parameters:
name - a String specifying the name of the initialization parameter
Returns:
a String containing the value of the initialization parameter

getInitParameterNames

public Enumeration getInitParameterNames()
Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.

Returns:
an Enumeration of String objects containing the names of the servlet's initialization parameters
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletContext

public interface ServletContext

Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.

There is one context per "web application" per Java Virtual Machine. (A "web application" is a collection of servlets and content installed under a specific subset of the server's URL namespace such as /catalog and possibly installed via a .war file.)

In the case of a web application marked "distributed" in its deployment descriptor, there will be one context instance for each virtual machine. In this situation, the context cannot be used as a location to share global information (because the information won't be truly global). Use an external resource like a database instead.

The ServletContext object is contained within the ServletConfig object, which the Web server provides the servlet when the servlet is initialized.

Version:
$Version$
Author:
Various
See Also:
Servlet.getServletConfig(), ServletConfig.getServletContext()

Method Summary
 Object getAttribute(String name)
Returns the servlet container attribute with the given name, or null if there is no attribute by that name.
 Enumeration getAttributeNames()
Returns an Enumeration containing the attribute names available within this servlet context.
 ServletContext getContext(String uripath)
Returns a ServletContext object that corresponds to a specified URL on the server.
 String getInitParameter(String name)
Returns a String containing the value of the named context-wide initialization parameter, or null if the parameter does not exist.
 Enumeration getInitParameterNames()
Returns the names of the context's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the context has no initialization parameters.
 int getMajorVersion()
Returns the major version of the Java Servlet API that this servlet container supports.
 String getMimeType(String file)
Returns the MIME type of the specified file, or null if the MIME type is not known.
 int getMinorVersion()
Returns the minor version of the Servlet API that this servlet container supports.
 RequestDispatcher getNamedDispatcher(String name)
Returns a RequestDispatcher object that acts as a wrapper for the named servlet.
 String getRealPath(String path)
Returns a String containing the real path for a given virtual path.
 RequestDispatcher getRequestDispatcher(String path)
Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
 URL getResource(String path)
Returns a URL to the resource that is mapped to a specified path.
 InputStream getResourceAsStream(String path)
Returns the resource located at the named path as an InputStream object.
 Set getResourcePaths(String path)
Returns a directory-like listing of all the paths to resources within the web application whose longest sub-path matches the supplied path argument.
 String getServerInfo()
Returns the name and version of the servlet container on which the servlet is running.
 Servlet getServlet(String name)
Deprecated. As of Java Servlet API 2.1, with no direct replacement.

This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.

 String getServletContextName()
Returns the name of this web application correponding to this ServletContext as specified in the deployment descriptor for this web application by the display-name element.
 Enumeration getServletNames()
Deprecated. As of Java Servlet API 2.1, with no replacement.

This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

 Enumeration getServlets()
Deprecated. As of Java Servlet API 2.0, with no replacement.

This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

 void log(Exception exception, String msg)
Deprecated. As of Java Servlet API 2.1, use log(String message, Throwable throwable) instead.

This method was originally defined to write an exception's stack trace and an explanatory error message to the servlet log file.

 void log(String msg)
Writes the specified message to a servlet log file, usually an event log.
 void log(String message, Throwable throwable)
Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file.
 void removeAttribute(String name)
Removes the attribute with the given name from the servlet context.
 void setAttribute(String name, Object object)
Binds an object to a given attribute name in this servlet context.

Method Detail

getContext

public ServletContext getContext(String uripath)
Returns a ServletContext object that corresponds to a specified URL on the server.

This method allows servlets to gain access to the context for various parts of the server, and as needed obtain RequestDispatcher objects from the context. The given path must be begin with "/", is interpreted relative to the server's document root and is matched against the context roots of other web applications hosted on this container.

In a security conscious environment, the servlet container may return null for a given URL.

Parameters:
uripath - a String specifying the context path of another web application in the container.
Returns:
the ServletContext object that corresponds to the named URL, or null if either none exists or the container wishes to restrict this access.
See Also:
RequestDispatcher

getMajorVersion

public int getMajorVersion()
Returns the major version of the Java Servlet API that this servlet container supports. All implementations that comply with Version 2.4 must have this method return the integer 2.

Returns:
2

getMinorVersion

public int getMinorVersion()
Returns the minor version of the Servlet API that this servlet container supports. All implementations that comply with Version 2.4 must have this method return the integer 4.

Returns:
4

getMimeType

public String getMimeType(String file)
Returns the MIME type of the specified file, or null if the MIME type is not known. The MIME type is determined by the configuration of the servlet container, and may be specified in a web application deployment descriptor. Common MIME types are "text/html" and "image/gif".

Parameters:
file - a String specifying the name of a file
Returns:
a String specifying the file's MIME type

getResourcePaths

public Set getResourcePaths(String path)
Returns a directory-like listing of all the paths to resources within the web application whose longest sub-path matches the supplied path argument. Paths indicating subdirectory paths end with a '/'. The returned paths are all relative to the root of the web application and have a leading '/'. For example, for a web application containing

/welcome.html
/catalog/index.html
/catalog/products.html
/catalog/offers/books.html
/catalog/offers/music.html
/customer/login.jsp
/WEB-INF/web.xml
/WEB-INF/classes/com.acme.OrderServlet.class,

getResourcePaths("/") returns {"/welcome.html", "/catalog/", "/customer/", "/WEB-INF/"}
getResourcePaths("/catalog/") returns {"/catalog/index.html", "/catalog/products.html", "/catalog/offers/"}.

Parameters:
path - the partial path used to match the resources, which must start with a /
Returns:
a Set containing the directory listing, or null if there are no resources in the web application whose path begins with the supplied path.
Since:
Servlet 2.3

getResource

public URL getResource(String path)
                throws MalformedURLException
Returns a URL to the resource that is mapped to a specified path. The path must begin with a "/" and is interpreted as relative to the current context root.

This method allows the servlet container to make a resource available to servlets from any source. Resources can be located on a local or remote file system, in a database, or in a .war file.

The servlet container must implement the URL handlers and URLConnection objects that are necessary to access the resource.

This method returns null if no resource is mapped to the pathname.

Some containers may allow writing to the URL returned by this method using the methods of the URL class.

The resource content is returned directly, so be aware that requesting a .jsp page returns the JSP source code. Use a RequestDispatcher instead to include results of an execution.

This method has a different purpose than java.lang.Class.getResource, which looks up resources based on a class loader. This method does not use class loaders.

Parameters:
path - a String specifying the path to the resource
Returns:
the resource located at the named path, or null if there is no resource at that path
Throws:
MalformedURLException - if the pathname is not given in the correct form

getResourceAsStream

public InputStream getResourceAsStream(String path)
Returns the resource located at the named path as an InputStream object.

The data in the InputStream can be of any type or length. The path must be specified according to the rules given in getResource. This method returns null if no resource exists at the specified path.

Meta-information such as content length and content type that is available via getResource method is lost when using this method.

The servlet container must implement the URL handlers and URLConnection objects necessary to access the resource.

This method is different from java.lang.Class.getResourceAsStream, which uses a class loader. This method allows servlet containers to make a resource available to a servlet from any location, without using a class loader.

Parameters:
path - a String specifying the path to the resource
Returns:
the InputStream returned to the servlet, or null if no resource exists at the specified path

getRequestDispatcher

public RequestDispatcher getRequestDispatcher(String path)
Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path. A RequestDispatcher object can be used to forward a request to the resource or to include the resource in a response. The resource can be dynamic or static.

The pathname must begin with a "/" and is interpreted as relative to the current context root. Use getContext to obtain a RequestDispatcher for resources in foreign contexts. This method returns null if the ServletContext cannot return a RequestDispatcher.

Parameters:
path - a String specifying the pathname to the resource
Returns:
a RequestDispatcher object that acts as a wrapper for the resource at the specified path, or null if the ServletContext cannot return a RequestDispatcher
See Also:
RequestDispatcher, getContext(java.lang.String)

getNamedDispatcher

public RequestDispatcher getNamedDispatcher(String name)
Returns a RequestDispatcher object that acts as a wrapper for the named servlet.

Servlets (and JSP pages also) may be given names via server administration or via a web application deployment descriptor. A servlet instance can determine its name using ServletConfig.getServletName().

This method returns null if the ServletContext cannot return a RequestDispatcher for any reason.

Parameters:
name - a String specifying the name of a servlet to wrap
Returns:
a RequestDispatcher object that acts as a wrapper for the named servlet, or null if the ServletContext cannot return a RequestDispatcher
See Also:
RequestDispatcher, getContext(java.lang.String), ServletConfig.getServletName()

getServlet

public Servlet getServlet(String name)
                   throws ServletException
Deprecated. As of Java Servlet API 2.1, with no direct replacement.

This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.

Throws:
ServletException

getServlets

public Enumeration getServlets()
Deprecated. As of Java Servlet API 2.0, with no replacement.

This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

getServletNames

public Enumeration getServletNames()
Deprecated. As of Java Servlet API 2.1, with no replacement.

This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

log

public void log(String msg)
Writes the specified message to a servlet log file, usually an event log. The name and type of the servlet log file is specific to the servlet container.

Parameters:
msg - a String specifying the message to be written to the log file

log

public void log(Exception exception,
                String msg)
Deprecated. As of Java Servlet API 2.1, use log(String message, Throwable throwable) instead.

This method was originally defined to write an exception's stack trace and an explanatory error message to the servlet log file.

log

public void log(String message,
                Throwable throwable)
Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file. The name and type of the servlet log file is specific to the servlet container, usually an event log.

Parameters:
message - a String that describes the error or exception
throwable - the Throwable error or exception

getRealPath

public String getRealPath(String path)
Returns a String containing the real path for a given virtual path. For example, the path "/index.html" returns the absolute file path on the server's filesystem would be served by a request for "http://host/contextPath/index.html", where contextPath is the context path of this ServletContext..

The real path returned will be in a form appropriate to the computer and operating system on which the servlet container is running, including the proper path separators. This method returns null if the servlet container cannot translate the virtual path to a real path for any reason (such as when the content is being made available from a .war archive).

Parameters:
path - a String specifying a virtual path
Returns:
a String specifying the real path, or null if the translation cannot be performed

getServerInfo

public String getServerInfo()
Returns the name and version of the servlet container on which the servlet is running.

The form of the returned string is servername/versionnumber. For example, the JavaServer Web Development Kit may return the string JavaServer Web Dev Kit/1.0.

The servlet container may return other optional information after the primary string in parentheses, for example, JavaServer Web Dev Kit/1.0 (JDK 1.1.6; Windows NT 4.0 x86).

Returns:
a String containing at least the servlet container name and version number

getInitParameter

public String getInitParameter(String name)
Returns a String containing the value of the named context-wide initialization parameter, or null if the parameter does not exist.

This method can make available configuration information useful to an entire "web application". For example, it can provide a webmaster's email address or the name of a system that holds critical data.

Parameters:
name - a String containing the name of the parameter whose value is requested
Returns:
a String containing at least the servlet container name and version number
See Also:
ServletConfig.getInitParameter(java.lang.String)

getInitParameterNames

public Enumeration getInitParameterNames()
Returns the names of the context's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the context has no initialization parameters.

Returns:
an Enumeration of String objects containing the names of the context's initialization parameters
See Also:
ServletConfig.getInitParameter(java.lang.String)

getAttribute

public Object getAttribute(String name)
Returns the servlet container attribute with the given name, or null if there is no attribute by that name. An attribute allows a servlet container to give the servlet additional information not already provided by this interface. See your server documentation for information about its attributes. A list of supported attributes can be retrieved using getAttributeNames.

The attribute is returned as a java.lang.Object or some subclass. Attribute names should follow the same convention as package names. The Java Servlet API specification reserves names matching java.*, javax.*, and sun.*.

Parameters:
name - a String specifying the name of the attribute
Returns:
an Object containing the value of the attribute, or null if no attribute exists matching the given name
See Also:
getAttributeNames()

getAttributeNames

public Enumeration getAttributeNames()
Returns an Enumeration containing the attribute names available within this servlet context. Use the getAttribute(java.lang.String) method with an attribute name to get the value of an attribute.

Returns:
an Enumeration of attribute names
See Also:
getAttribute(java.lang.String)

setAttribute

public void setAttribute(String name,
                         Object object)
Binds an object to a given attribute name in this servlet context. If the name specified is already used for an attribute, this method will replace the attribute with the new to the new attribute.

If listeners are configured on the ServletContext the container notifies them accordingly.

If a null value is passed, the effect is the same as calling removeAttribute().

Attribute names should follow the same convention as package names. The Java Servlet API specification reserves names matching java.*, javax.*, and sun.*.

Parameters:
name - a String specifying the name of the attribute
object - an Object representing the attribute to be bound

removeAttribute

public void removeAttribute(String name)
Removes the attribute with the given name from the servlet context. After removal, subsequent calls to getAttribute(java.lang.String) to retrieve the attribute's value will return null.

If listeners are configured on the ServletContext the container notifies them accordingly.

Parameters:
name - a String specifying the name of the attribute to be removed

getServletContextName

public String getServletContextName()
Returns the name of this web application correponding to this ServletContext as specified in the deployment descriptor for this web application by the display-name element.

Returns:
The name of the web application or null if no name has been declared in the deployment descriptor.
Since:
Servlet 2.3
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletContextAttributeEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletContextAttributeEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.servlet.ServletContextEvent
            extended by javax.servlet.ServletContextAttributeEvent
All Implemented Interfaces:
Serializable
public class ServletContextAttributeEvent
extends ServletContextEvent

This is the event class for notifications about changes to the attributes of the servlet context of a web application.

Since:
v 2.3
See Also:
ServletContextAttributeListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ServletContextAttributeEvent(ServletContext source, String name, Object value)
Construct a ServletContextAttributeEvent from the given context for the given attribute name and attribute value.
Method Summary
String | getName() Return the name of the attribute that changed on the ServletContext.
Object | getValue() Returns the value of the attribute that has been added, removed, or replaced.
Methods inherited from class javax.servlet.ServletContextEvent
getServletContext
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServletContextAttributeEvent

public ServletContextAttributeEvent(ServletContext source,
                                    String name,
                                    Object value)
Construct a ServletContextAttributeEvent from the given context for the given attribute name and attribute value.

Method Detail

getName

public String getName()
Return the name of the attribute that changed on the ServletContext.

getValue

public Object getValue()
Returns the value of the attribute that has been added, removed, or replaced. If the attribute was added, this is the value of the attribute. If the attrubute was removed, this is the value of the removed attribute. If the attribute was replaced, this is the old value of the attribute.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletContextAttributeListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletContextAttributeListener

All Superinterfaces:
EventListener
public interface ServletContextAttributeListener
extends EventListener

Implementations of this interface recieve notifications of changes to the attribute list on the servlet context of a web application. To recieve notification events, the implementation class must be configured in the deployment descriptor for the web application.

Since:
v 2.3
See Also:
ServletContextAttributeEvent

Method Summary
void | attributeAdded(ServletContextAttributeEvent scab) Notification that a new attribute was added to the servlet context.
void | attributeRemoved(ServletContextAttributeEvent scab) Notification that an existing attribute has been removed from the servlet context.
void | attributeReplaced(ServletContextAttributeEvent scab) Notification that an attribute on the servlet context has been replaced.

Method Detail

attributeAdded

public void attributeAdded(ServletContextAttributeEvent scab)
Notification that a new attribute was added to the servlet context. Called after the attribute is added.

attributeRemoved

public void attributeRemoved(ServletContextAttributeEvent scab)
Notification that an existing attribute has been removed from the servlet context. Called after the attribute is removed.

attributeReplaced

public void attributeReplaced(ServletContextAttributeEvent scab)
Notification that an attribute on the servlet context has been replaced. Called after the attribute is replaced.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletContextEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletContextEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.servlet.ServletContextEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ServletContextAttributeEvent
public class ServletContextEvent
extends EventObject

This is the event class for notifications about changes to the servlet context of a web application.

Since:
v 2.3
See Also:
ServletContextListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ServletContextEvent(ServletContext source)
Construct a ServletContextEvent from the given context.
Method Summary
 ServletContext getServletContext()
Return the ServletContext that changed.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServletContextEvent

public ServletContextEvent(ServletContext source)
Construct a ServletContextEvent from the given context.

Parameters:
source - - the ServletContext that is sending the event.
Method Detail

getServletContext

public ServletContext getServletContext()
Return the ServletContext that changed.

Returns:
the ServletContext that sent the event.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletContextListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletContextListener

All Superinterfaces:
EventListener
public interface ServletContextListener
extends EventListener

Implementations of this interface recieve notifications about changes to the servlet context of the web application they are part of. To recieve notification events, the implementation class must be configured in the deployment descriptor for the web application.

Since:
v 2.3
See Also:
ServletContextEvent

Method Summary
void | contextDestroyed(ServletContextEvent sce) Notification that the servlet context is about to be shut down.
void | contextInitialized(ServletContextEvent sce) Notification that the web application initialization process is starting.

Method Detail

contextInitialized

public void contextInitialized(ServletContextEvent sce)
Notification that the web application initialization process is starting. All ServletContextListeners are notified of context initialisation before any filter or servlet in the web application is initialized.

contextDestroyed

public void contextDestroyed(ServletContextEvent sce)
Notification that the servlet context is about to be shut down. All servlets have been destroy()ed before any ServletContextListeners are notified of context destruction.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.servlet.ServletException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
UnavailableException
public class ServletException
extends Exception

Defines a general exception a servlet can throw when it encounters difficulty.

Version:
$Version$
Author:
Various
See Also:
Serialized Form

Constructor Summary
ServletException()
Constructs a new servlet exception.
ServletException(String message)
Constructs a new servlet exception with the specified message.
ServletException(String message, Throwable rootCause)
Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
ServletException(Throwable rootCause)
Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.
Method Summary
 Throwable getRootCause()
Returns the exception that caused this servlet exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServletException

public ServletException()
Constructs a new servlet exception.

ServletException

public ServletException(String message)
Constructs a new servlet exception with the specified message. The message can be written to the server log and/or displayed for the user.

Parameters:
message - a String specifying the text of the exception message

ServletException

public ServletException(String message,
                        Throwable rootCause)
Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.

Parameters:
message - a String containing the text of the exception message
rootCause - the Throwable exception that interfered with the servlet's normal operation, making this servlet exception necessary

ServletException

public ServletException(Throwable rootCause)
Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation. The exception's message is based on the localized message of the underlying exception.

This method calls the getLocalizedMessage method on the Throwable exception to get a localized exception message. When subclassing ServletException, this method can be overridden to create an exception message designed for a specific locale.

Parameters:
rootCause - the Throwable exception that interfered with the servlet's normal operation, making the servlet exception necessary
Method Detail

getRootCause

public Throwable getRootCause()
Returns the exception that caused this servlet exception.

Returns:
the Throwable that caused this servlet exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletInputStream

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletInputStream

java.lang.Object
    extended by java.io.InputStream
        extended by javax.servlet.ServletInputStream
public abstract class ServletInputStream
extends InputStream

Provides an input stream for reading binary data from a client request, including an efficient readLine method for reading data one line at a time. With some protocols, such as HTTP POST and PUT, a ServletInputStream object can be used to read data sent from the client.

A ServletInputStream object is normally retrieved via the ServletRequest.getInputStream() method.

This is an abstract class that a servlet container implements. Subclasses of this class must implement the java.io.InputStream.read() method.

Version:
$Version$
Author:
Various
See Also:
ServletRequest

Constructor Summary
protected ServletInputStream()
Does nothing, because this is an abstract class.
Method Summary
 int readLine(byte[] b, int off, int len)
Reads the input stream, one line at a time.
Methods inherited from class java.io.InputStream
available, close, mark, markSupported, read, read, read, reset, skip
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServletInputStream

protected ServletInputStream()
Does nothing, because this is an abstract class.

Method Detail

readLine

public int readLine(byte[] b,
                    int off,
                    int len)
             throws IOException
Reads the input stream, one line at a time. Starting at an offset, reads bytes into an array, until it reads a certain number of bytes or reaches a newline character, which it reads into the array as well.

This method returns -1 if it reaches the end of the input stream before reading the maximum number of bytes.

Parameters:
b - an array of bytes into which data is read
off - an integer specifying the character at which this method begins reading
len - an integer specifying the maximum number of bytes to read
Returns:
an integer specifying the actual number of bytes read, or -1 if the end of the stream is reached
Throws:
IOException - if an input or output exception has occurred
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletOutputStream

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletOutputStream

java.lang.Object
    extended by java.io.OutputStream
        extended by javax.servlet.ServletOutputStream
public abstract class ServletOutputStream
extends OutputStream

Provides an output stream for sending binary data to the client. A ServletOutputStream object is normally retrieved via the ServletResponse.getOutputStream() method.

This is an abstract class that the servlet container implements. Subclasses of this class must implement the java.io.OutputStream.write(int) method.

Version:
$Version$
Author:
Various
See Also:
ServletResponse

Constructor Summary
protected ServletOutputStream()
Does nothing, because this is an abstract class.
Method Summary
void | print(boolean b) Writes a boolean value to the client, with no carriage return-line feed (CRLF) character at the end.
void | print(char c) Writes a character to the client, with no carriage return-line feed (CRLF) at the end.
void | print(double d) Writes a double value to the client, with no carriage return-line feed (CRLF) at the end.
void | print(float f) Writes a float value to the client, with no carriage return-line feed (CRLF) at the end.
void | print(int i) Writes an int to the client, with no carriage return-line feed (CRLF) at the end.
void | print(long l) Writes a long value to the client, with no carriage return-line feed (CRLF) at the end.
void | print(String s) Writes a String to the client, without a carriage return-line feed (CRLF) character at the end.
void | println() Writes a carriage return-line feed (CRLF) to the client.
void | println(boolean b) Writes a boolean value to the client, followed by a carriage return-line feed (CRLF).
void | println(char c) Writes a character to the client, followed by a carriage return-line feed (CRLF).
void | println(double d) Writes a double value to the client, followed by a carriage return-line feed (CRLF).
void | println(float f) Writes a float value to the client, followed by a carriage return-line feed (CRLF).
void | println(int i) Writes an int to the client, followed by a carriage return-line feed (CRLF) character.
void | println(long l) Writes a long value to the client, followed by a carriage return-line feed (CRLF).
void | println(String s) Writes a String to the client, followed by a carriage return-line feed (CRLF).
Methods inherited from class java.io.OutputStream
close, flush, write, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServletOutputStream

protected ServletOutputStream()
Does nothing, because this is an abstract class.

Method Detail

print

public void print(String s)
           throws IOException
Writes a String to the client, without a carriage return-line feed (CRLF) character at the end.

Parameters:
s - the String to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(boolean b)
           throws IOException
Writes a boolean value to the client, with no carriage return-line feed (CRLF) character at the end.

Parameters:
b - the boolean value to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(char c)
           throws IOException
Writes a character to the client, with no carriage return-line feed (CRLF) at the end.

Parameters:
c - the character to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(int i)
           throws IOException
Writes an int to the client, with no carriage return-line feed (CRLF) at the end.

Parameters:
i - the int to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(long l)
           throws IOException
Writes a long value to the client, with no carriage return-line feed (CRLF) at the end.

Parameters:
l - the long value to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(float f)
           throws IOException
Writes a float value to the client, with no carriage return-line feed (CRLF) at the end.

Parameters:
f - the float value to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(double d)
           throws IOException
Writes a double value to the client, with no carriage return-line feed (CRLF) at the end.

Parameters:
d - the double value to send to the client
Throws:
IOException - if an input or output exception occurred

println

public void println()
             throws IOException
Writes a carriage return-line feed (CRLF) to the client.

Throws:
IOException - if an input or output exception occurred

println

public void println(String s)
             throws IOException
Writes a String to the client, followed by a carriage return-line feed (CRLF).

Parameters:
s - the String to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(boolean b)
             throws IOException
Writes a boolean value to the client, followed by a carriage return-line feed (CRLF).

Parameters:
b - the boolean value to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(char c)
             throws IOException
Writes a character to the client, followed by a carriage return-line feed (CRLF).

Parameters:
c - the character to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(int i)
             throws IOException
Writes an int to the client, followed by a carriage return-line feed (CRLF) character.

Parameters:
i - the int to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(long l)
             throws IOException
Writes a long value to the client, followed by a carriage return-line feed (CRLF).

Parameters:
l - the long value to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(float f)
             throws IOException
Writes a float value to the client, followed by a carriage return-line feed (CRLF).

Parameters:
f - the float value to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(double d)
             throws IOException
Writes a double value to the client, followed by a carriage return-line feed (CRLF).

Parameters:
d - the double value to write to the client
Throws:
IOException - if an input or output exception occurred
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletRequest

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletRequest

All Known Subinterfaces:
HttpServletRequest
All Known Implementing Classes:
HttpServletRequestWrapper, ServletRequestWrapper
public interface ServletRequest

Defines an object to provide client request information to a servlet. The servlet container creates a ServletRequest object and passes it as an argument to the servlet's service method.

A ServletRequest object provides data including parameter name and values, attributes, and an input stream. Interfaces that extend ServletRequest can provide additional protocol-specific data (for example, HTTP data is provided by HttpServletRequest.

Version:
$Version$
Author:
Various
See Also:
HttpServletRequest

Method Summary
Object | getAttribute(String name) Returns the value of the named attribute as an Object, or null if no attribute of the given name exists.
Enumeration | getAttributeNames() Returns an Enumeration containing the names of the attributes available to this request.
String | getCharacterEncoding() Returns the name of the character encoding used in the body of this request.
int | getContentLength() Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known.
String | getContentType() Returns the MIME type of the body of the request, or null if the type is not known.
ServletInputStream | getInputStream() Retrieves the body of the request as binary data using a ServletInputStream.
String | getLocalAddr() Returns the Internet Protocol (IP) address of the interface on which the request was received.
Locale | getLocale() Returns the preferred Locale that the client will accept content in, based on the Accept-Language header.
Enumeration | getLocales() Returns an Enumeration of Locale objects indicating, in decreasing order starting with the preferred locale, the locales that are acceptable to the client based on the Accept-Language header.
String | getLocalName() Returns the host name of the Internet Protocol (IP) interface on which the request was received.
int | getLocalPort() Returns the Internet Protocol (IP) port number of the interface on which the request was received.
String | getParameter(String name) Returns the value of a request parameter as a String, or null if the parameter does not exist.
Map | getParameterMap() Returns a java.util.Map of the parameters of this request.
Enumeration | getParameterNames() Returns an Enumeration of String objects containing the names of the parameters contained in this request.
String[] | getParameterValues(String name) Returns an array of String objects containing all of the values the given request parameter has, or null if the parameter does not exist.
String | getProtocol() Returns the name and version of the protocol the request uses in the form protocol/majorVersion.minorVersion, for example, HTTP/1.1.
BufferedReader | getReader() Retrieves the body of the request as character data using a BufferedReader.
String | getRealPath(String path) Deprecated. As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.
String | getRemoteAddr() Returns the Internet Protocol (IP) address of the client or last proxy that sent the request.
String | getRemoteHost() Returns the fully qualified name of the client or the last proxy that sent the request.
int | getRemotePort() Returns the Internet Protocol (IP) source port of the client or last proxy that sent the request.
RequestDispatcher | getRequestDispatcher(String path) Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
String | getScheme() Returns the name of the scheme used to make this request, for example, http, https, or ftp.
String | getServerName() Returns the host name of the server to which the request was sent.
int | getServerPort() Returns the port number to which the request was sent.
boolean | isSecure() Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.
void | removeAttribute(String name) Removes an attribute from this request.
void | setAttribute(String name, Object o) Stores an attribute in this request.
void | setCharacterEncoding(String env) Overrides the name of the character encoding used in the body of this request.

Method Detail

getAttribute

public Object getAttribute(String name)
Returns the value of the named attribute as an Object, or null if no attribute of the given name exists.

Attributes can be set two ways. The servlet container may set attributes to make available custom information about a request. For example, for requests made using HTTPS, the attribute javax.servlet.request.X509Certificate can be used to retrieve information on the certificate of the client. Attributes can also be set programatically using setAttribute(java.lang.String, java.lang.Object). This allows information to be embedded into a request before a RequestDispatcher call.

Attribute names should follow the same conventions as package names. This specification reserves names matching java.*, javax.*, and sun.*.

Parameters:
name - a String specifying the name of the attribute
Returns:
an Object containing the value of the attribute, or null if the attribute does not exist

getAttributeNames

public Enumeration getAttributeNames()
Returns an Enumeration containing the names of the attributes available to this request. This method returns an empty Enumeration if the request has no attributes available to it.

Returns:
an Enumeration of strings containing the names of the request's attributes

getCharacterEncoding

public String getCharacterEncoding()
Returns the name of the character encoding used in the body of this request. This method returns null if the request does not specify a character encoding

Returns:
a String containing the name of the chararacter encoding, or null if the request does not specify a character encoding

setCharacterEncoding

public void setCharacterEncoding(String env)
                          throws UnsupportedEncodingException
Overrides the name of the character encoding used in the body of this request. This method must be called prior to reading request parameters or reading input using getReader().

Parameters:
env - a String containing the name of the chararacter encoding.
Throws:
UnsupportedEncodingException - if this is not a valid encoding

getContentLength

public int getContentLength()
Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known. For HTTP servlets, same as the value of the CGI variable CONTENT_LENGTH.

Returns:
an integer containing the length of the request body or -1 if the length is not known

getContentType

public String getContentType()
Returns the MIME type of the body of the request, or null if the type is not known. For HTTP servlets, same as the value of the CGI variable CONTENT_TYPE.

Returns:
a String containing the name of the MIME type of the request, or null if the type is not known

getInputStream

public ServletInputStream getInputStream()
                                  throws IOException
Retrieves the body of the request as binary data using a ServletInputStream. Either this method or getReader() may be called to read the body, not both.

Returns:
a ServletInputStream object containing the body of the request
Throws:
IllegalStateException - if the getReader() method has already been called for this request
IOException - if an input or output exception occurred

getParameter

public String getParameter(String name)
Returns the value of a request parameter as a String, or null if the parameter does not exist. Request parameters are extra information sent with the request. For HTTP servlets, parameters are contained in the query string or posted form data.

You should only use this method when you are sure the parameter has only one value. If the parameter might have more than one value, use getParameterValues(java.lang.String).

If you use this method with a multivalued parameter, the value returned is equal to the first value in the array returned by getParameterValues.

If the parameter data was sent in the request body, such as occurs with an HTTP POST request, then reading the body directly via getInputStream() or getReader() can interfere with the execution of this method.

Parameters:
name - a String specifying the name of the parameter
Returns:
a String representing the single value of the parameter
See Also:
getParameterValues(java.lang.String)

getParameterNames

public Enumeration getParameterNames()
Returns an Enumeration of String objects containing the names of the parameters contained in this request. If the request has no parameters, the method returns an empty Enumeration.

Returns:
an Enumeration of String objects, each String containing the name of a request parameter; or an empty Enumeration if the request has no parameters

getParameterValues

public String[] getParameterValues(String name)
Returns an array of String objects containing all of the values the given request parameter has, or null if the parameter does not exist.

If the parameter has a single value, the array has a length of 1.

Parameters:
name - a String containing the name of the parameter whose value is requested
Returns:
an array of String objects containing the parameter's values
See Also:
getParameter(java.lang.String)

getParameterMap

public Map getParameterMap()
Returns a java.util.Map of the parameters of this request. Request parameters are extra information sent with the request. For HTTP servlets, parameters are contained in the query string or posted form data.

Returns:
an immutable java.util.Map containing parameter names as keys and parameter values as map values. The keys in the parameter map are of type String. The values in the parameter map are of type String array.

getProtocol

public String getProtocol()
Returns the name and version of the protocol the request uses in the form protocol/majorVersion.minorVersion, for example, HTTP/1.1. For HTTP servlets, the value returned is the same as the value of the CGI variable SERVER_PROTOCOL.

Returns:
a String containing the protocol name and version number

getScheme

public String getScheme()
Returns the name of the scheme used to make this request, for example, http, https, or ftp. Different schemes have different rules for constructing URLs, as noted in RFC 1738.

Returns:
a String containing the name of the scheme used to make this request

getServerName

public String getServerName()
Returns the host name of the server to which the request was sent. It is the value of the part before ":" in the Host header, if any, or the resolved server name, or the server IP address.

Returns:
a String containing the name of the server

getServerPort

public int getServerPort()
Returns the port number to which the request was sent. It is the value of the part after ":" in the Host header, if any, or the server port where the client connection was accepted on.

Returns:
an integer specifying the port number

getReader

public BufferedReader getReader()
                         throws IOException
Retrieves the body of the request as character data using a BufferedReader. The reader translates the character data according to the character encoding used on the body. Either this method or getInputStream() may be called to read the body, not both.

Returns:
a BufferedReader containing the body of the request
Throws:
UnsupportedEncodingException - if the character set encoding used is not supported and the text cannot be decoded
IllegalStateException - if getInputStream() method has been called on this request
IOException - if an input or output exception occurred
See Also:
getInputStream()

getRemoteAddr

public String getRemoteAddr()
Returns the Internet Protocol (IP) address of the client or last proxy that sent the request. For HTTP servlets, same as the value of the CGI variable REMOTE_ADDR.

Returns:
a String containing the IP address of the client that sent the request

getRemoteHost

public String getRemoteHost()
Returns the fully qualified name of the client or the last proxy that sent the request. If the engine cannot or chooses not to resolve the hostname (to improve performance), this method returns the dotted-string form of the IP address. For HTTP servlets, same as the value of the CGI variable REMOTE_HOST.

Returns:
a String containing the fully qualified name of the client

setAttribute

public void setAttribute(String name,
                         Object o)
Stores an attribute in this request. Attributes are reset between requests. This method is most often used in conjunction with RequestDispatcher.

Attribute names should follow the same conventions as package names. Names beginning with java.*, javax.*, and com.sun.*, are reserved for use by Sun Microsystems.
If the object passed in is null, the effect is the same as calling removeAttribute(java.lang.String).

Parameters:
name - a String specifying the name of the attribute
o - the Object to be stored

removeAttribute

public void removeAttribute(String name)
Removes an attribute from this request. This method is not generally needed as attributes only persist as long as the request is being handled.

Attribute names should follow the same conventions as package names. Names beginning with java.*, javax.*, and com.sun.*, are reserved for use by Sun Microsystems.

Parameters:
name - a String specifying the name of the attribute to remove

getLocale

public Locale getLocale()
Returns the preferred Locale that the client will accept content in, based on the Accept-Language header. If the client request doesn't provide an Accept-Language header, this method returns the default locale for the server.

Returns:
the preferred Locale for the client

getLocales

public Enumeration getLocales()
Returns an Enumeration of Locale objects indicating, in decreasing order starting with the preferred locale, the locales that are acceptable to the client based on the Accept-Language header. If the client request doesn't provide an Accept-Language header, this method returns an Enumeration containing one Locale, the default locale for the server.

Returns:
an Enumeration of preferred Locale objects for the client

isSecure

public boolean isSecure()
Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.

Returns:
a boolean indicating if the request was made using a secure channel

getRequestDispatcher

public RequestDispatcher getRequestDispatcher(String path)
Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path. A RequestDispatcher object can be used to forward a request to the resource or to include the resource in a response. The resource can be dynamic or static.

The pathname specified may be relative, although it cannot extend outside the current servlet context. If the path begins with a "/" it is interpreted as relative to the current context root. This method returns null if the servlet container cannot return a RequestDispatcher.

The difference between this method and ServletContext.getRequestDispatcher(java.lang.String) is that this method can take a relative path.

Parameters:
path - a String specifying the pathname to the resource. If it is relative, it must be relative against the current servlet.
Returns:
a RequestDispatcher object that acts as a wrapper for the resource at the specified path, or null if the servlet container cannot return a RequestDispatcher
See Also:
RequestDispatcher, ServletContext.getRequestDispatcher(java.lang.String)

getRealPath

public String getRealPath(String path)
Deprecated. As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.

getRemotePort

public int getRemotePort()
Returns the Internet Protocol (IP) source port of the client or last proxy that sent the request.

Since:
2.4

getLocalName

public String getLocalName()
Returns the host name of the Internet Protocol (IP) interface on which the request was received.

Returns:
a String containing the host name of the IP on which the request was received.
Since:
2.4

getLocalAddr

public String getLocalAddr()
Returns the Internet Protocol (IP) address of the interface on which the request was received.

Returns:
a String containing the IP address on which the request was received.
Since:
2.4

getLocalPort

public int getLocalPort()
Returns the Internet Protocol (IP) port number of the interface on which the request was received.

Returns:
an integer specifying the port number
Since:
2.4
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletRequestAttributeEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletRequestAttributeEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.servlet.ServletRequestEvent
            extended by javax.servlet.ServletRequestAttributeEvent
All Implemented Interfaces:
Serializable
public class ServletRequestAttributeEvent
extends ServletRequestEvent

This is the event class for notifications about changes to the attributes of the servlet request of a web application.

Since:
v 2.4
See Also:
ServletRequestAttributeListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ServletRequestAttributeEvent(ServletContext sc, ServletRequest request, String name, Object value)
Construct a ServletRequestAttributeEvent from the given context for the given attribute name and attribute value.
Method Summary
String | getName() Return the name of the attribute that changed on the ServletRequest.
Object | getValue() Returns the value of the attribute that has been added removed or replaced.
Methods inherited from class javax.servlet.ServletRequestEvent
getServletContext, getServletRequest
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServletRequestAttributeEvent

public ServletRequestAttributeEvent(ServletContext sc,
                                    ServletRequest request,
                                    String name,
                                    Object value)
Construct a ServletRequestAttributeEvent from the given context for the given attribute name and attribute value.

Parameters:
sc - - the ServletContext that is sending the event.
request - - the ServletRequest that is sending the event.
name - - the name of the request attribute.
value - - the value of the request attribute.
Method Detail

getName

public String getName()
Return the name of the attribute that changed on the ServletRequest.

Returns:
String - the name of the changed request attribute.

getValue

public Object getValue()
Returns the value of the attribute that has been added removed or replaced. If the attribute was added, this is the value of the attribute. If the attribute was removed, this is the value of the removed attribute. If the attribute was replaced, this is the old value of the attribute.

Returns:
Object - the value of the changed request attribute.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletRequestAttributeListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletRequestAttributeListener

All Superinterfaces:
EventListener
public interface ServletRequestAttributeListener
extends EventListener

Implementations of this interface receive notifications of changes to the attribute list on the servlet request of a web application. To receive notification events, the implementation class must be configured in the deployment descriptor for the web application.

Since:
v 2.4
See Also:
ServletRequestAttributeEvent

Method Summary
void | attributeAdded(ServletRequestAttributeEvent srae) Notification that a new attribute was added to the servlet request.
void | attributeRemoved(ServletRequestAttributeEvent srae) Notification that an existing attribute has been removed from the servlet request.
void | attributeReplaced(ServletRequestAttributeEvent srae) Notification that an attribute on the servlet request has been replaced.

Method Detail

attributeAdded

public void attributeAdded(ServletRequestAttributeEvent srae)
Notification that a new attribute was added to the servlet request. Called after the attribute is added.

attributeRemoved

public void attributeRemoved(ServletRequestAttributeEvent srae)
Notification that an existing attribute has been removed from the servlet request. Called after the attribute is removed.

attributeReplaced

public void attributeReplaced(ServletRequestAttributeEvent srae)
Notification that an attribute on the servlet request has been replaced. Called after the attribute is replaced.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletRequestEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletRequestEvent

java.lang.Object
    extended by java.util.EventObject
        extended by javax.servlet.ServletRequestEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ServletRequestAttributeEvent
public class ServletRequestEvent
extends EventObject

This is the event class for notifications about changes to the servlet request of a web application.

Since:
v 2.4
See Also:
ServletRequestListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ServletRequestEvent(ServletContext sc, ServletRequest request)
Construct a ServletRequestEvent from the given context.
Method Summary
ServletContext | getServletContext() Return the ServletContext that changed.
ServletRequest | getServletRequest() Return the ServletRequest that changed.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServletRequestEvent

public ServletRequestEvent(ServletContext sc,
                           ServletRequest request)
Construct a ServletRequestEvent from the given context.

Parameters:
sc - - the ServletContext of the web application.
request - - the ServletRequest that is sending the event.
Method Detail

getServletRequest

public ServletRequest getServletRequest()
Return the ServletRequest that changed.

Returns:
the ServletRequest that sent the event.

getServletContext

public ServletContext getServletContext()
Return the ServletContext that changed.

Returns:
the ServletContext of the web application.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletRequestListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletRequestListener

All Superinterfaces:
EventListener
public interface ServletRequestListener
extends EventListener

Implementations of this interface recieve notifications about changes to the servlet request of the web application they are part of. To receive notification events, the implementation class must be configured in the deployment descriptor for the web application.

Since:
v 2.4
See Also:
ServletContextEvent

Method Summary
void | requestDestroyed(ServletRequestEvent sre) Notification that the servlet request is about to go out of scope.
void | requestInitialized(ServletRequestEvent sre) Notification that the servlet request is about to go into scope.

Method Detail

requestDestroyed

public void requestDestroyed(ServletRequestEvent sre)
Notification that the servlet request is about to go out of scope.

requestInitialized

public void requestInitialized(ServletRequestEvent sre)
Notification that the servlet request is about to go into scope.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletRequestWrapper

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletRequestWrapper

java.lang.Object
    extended by javax.servlet.ServletRequestWrapper
All Implemented Interfaces:
ServletRequest
Direct Known Subclasses:
HttpServletRequestWrapper
public class ServletRequestWrapper
extends Object
implements ServletRequest

Provides a convenient implementation of the ServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped request object.

Since:
v 2.3
See Also:
ServletRequest

Constructor Summary
ServletRequestWrapper(ServletRequest request)
Creates a ServletRequest adaptor wrapping the given request object.
Method Summary
 Object getAttribute(String name)
The default behavior of this method is to call getAttribute(String name) on the wrapped request object.
 Enumeration getAttributeNames()
The default behavior of this method is to return getAttributeNames() on the wrapped request object.
 String getCharacterEncoding()
The default behavior of this method is to return getCharacterEncoding() on the wrapped request object.
 int getContentLength()
The default behavior of this method is to return getContentLength() on the wrapped request object.
 String getContentType()
The default behavior of this method is to return getContentType() on the wrapped request object.
 ServletInputStream getInputStream()
The default behavior of this method is to return getInputStream() on the wrapped request object.
 String getLocalAddr()
The default behavior of this method is to return getLocalAddr() on the wrapped request object.
 Locale getLocale()
The default behavior of this method is to return getLocale() on the wrapped request object.
 Enumeration getLocales()
The default behavior of this method is to return getLocales() on the wrapped request object.
 String getLocalName()
The default behavior of this method is to return getLocalName() on the wrapped request object.
 int getLocalPort()
The default behavior of this method is to return getLocalPort() on the wrapped request object.
 String getParameter(String name)
The default behavior of this method is to return getParameter(String name) on the wrapped request object.
 Map getParameterMap()
The default behavior of this method is to return getParameterMap() on the wrapped request object.
 Enumeration getParameterNames()
The default behavior of this method is to return getParameterNames() on the wrapped request object.
 String[] getParameterValues(String name)
The default behavior of this method is to return getParameterValues(String name) on the wrapped request object.
 String getProtocol()
The default behavior of this method is to return getProtocol() on the wrapped request object.
 BufferedReader getReader()
The default behavior of this method is to return getReader() on the wrapped request object.
 String getRealPath(String path)
The default behavior of this method is to return getRealPath(String path) on the wrapped request object.
 String getRemoteAddr()
The default behavior of this method is to return getRemoteAddr() on the wrapped request object.
 String getRemoteHost()
The default behavior of this method is to return getRemoteHost() on the wrapped request object.
 int getRemotePort()
The default behavior of this method is to return getRemotePort() on the wrapped request object.
 ServletRequest getRequest()
Return the wrapped request object.
 RequestDispatcher getRequestDispatcher(String path)
The default behavior of this method is to return getRequestDispatcher(String path) on the wrapped request object.
 String getScheme()
The default behavior of this method is to return getScheme() on the wrapped request object.
 String getServerName()
The default behavior of this method is to return getServerName() on the wrapped request object.
 int getServerPort()
The default behavior of this method is to return getServerPort() on the wrapped request object.
 boolean isSecure()
The default behavior of this method is to return isSecure() on the wrapped request object.
 void removeAttribute(String name)
The default behavior of this method is to call removeAttribute(String name) on the wrapped request object.
 void setAttribute(String name, Object o)
The default behavior of this method is to return setAttribute(String name, Object o) on the wrapped request object.
 void setCharacterEncoding(String enc)
The default behavior of this method is to set the character encoding on the wrapped request object.
 void setRequest(ServletRequest request)
Sets the request object being wrapped.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServletRequestWrapper

public ServletRequestWrapper(ServletRequest request)
Creates a ServletRequest adaptor wrapping the given request object.

Throws:
IllegalArgumentException - if the request is null
Method Detail

getRequest

public ServletRequest getRequest()
Return the wrapped request object.

setRequest

public void setRequest(ServletRequest request)
Sets the request object being wrapped.

Throws:
IllegalArgumentException - if the request is null.

getAttribute

public Object getAttribute(String name)
The default behavior of this method is to call getAttribute(String name) on the wrapped request object.

Specified by:
getAttribute in interface ServletRequest
Parameters:
name - a String specifying the name of the attribute
Returns:
an Object containing the value of the attribute, or null if the attribute does not exist

getAttributeNames

public Enumeration getAttributeNames()
The default behavior of this method is to return getAttributeNames() on the wrapped request object.

Specified by:
getAttributeNames in interface ServletRequest
Returns:
an Enumeration of strings containing the names of the request's attributes

getCharacterEncoding

public String getCharacterEncoding()
The default behavior of this method is to return getCharacterEncoding() on the wrapped request object.

Specified by:
getCharacterEncoding in interface ServletRequest
Returns:
a String containing the name of the chararacter encoding, or null if the request does not specify a character encoding

setCharacterEncoding

public void setCharacterEncoding(String enc)
                          throws UnsupportedEncodingException
The default behavior of this method is to set the character encoding on the wrapped request object.

Specified by:
setCharacterEncoding in interface ServletRequest
Parameters:
enc - a String containing the name of the chararacter encoding.
Throws:
UnsupportedEncodingException - if this is not a valid encoding

getContentLength

public int getContentLength()
The default behavior of this method is to return getContentLength() on the wrapped request object.

Specified by:
getContentLength in interface ServletRequest
Returns:
an integer containing the length of the request body or -1 if the length is not known

getContentType

public String getContentType()
The default behavior of this method is to return getContentType() on the wrapped request object.

Specified by:
getContentType in interface ServletRequest
Returns:
a String containing the name of the MIME type of the request, or null if the type is not known

getInputStream

public ServletInputStream getInputStream()
                                  throws IOException
The default behavior of this method is to return getInputStream() on the wrapped request object.

Specified by:
getInputStream in interface ServletRequest
Returns:
a ServletInputStream object containing the body of the request
Throws:
IOException - if an input or output exception occurred

getParameter

public String getParameter(String name)
The default behavior of this method is to return getParameter(String name) on the wrapped request object.

Specified by:
getParameter in interface ServletRequest
Parameters:
name - a String specifying the name of the parameter
Returns:
a String representing the single value of the parameter
See Also:
ServletRequest.getParameterValues(java.lang.String)

getParameterMap

public Map getParameterMap()
The default behavior of this method is to return getParameterMap() on the wrapped request object.

Specified by:
getParameterMap in interface ServletRequest
Returns:
an immutable java.util.Map containing parameter names as keys and parameter values as map values. The keys in the parameter map are of type String. The values in the parameter map are of type String array.

getParameterNames

public Enumeration getParameterNames()
The default behavior of this method is to return getParameterNames() on the wrapped request object.

Specified by:
getParameterNames in interface ServletRequest
Returns:
an Enumeration of String objects, each String containing the name of a request parameter; or an empty Enumeration if the request has no parameters

getParameterValues

public String[] getParameterValues(String name)
The default behavior of this method is to return getParameterValues(String name) on the wrapped request object.

Specified by:
getParameterValues in interface ServletRequest
Parameters:
name - a String containing the name of the parameter whose value is requested
Returns:
an array of String objects containing the parameter's values
See Also:
ServletRequest.getParameter(java.lang.String)

getProtocol

public String getProtocol()
The default behavior of this method is to return getProtocol() on the wrapped request object.

Specified by:
getProtocol in interface ServletRequest
Returns:
a String containing the protocol name and version number

getScheme

public String getScheme()
The default behavior of this method is to return getScheme() on the wrapped request object.

Specified by:
getScheme in interface ServletRequest
Returns:
a String containing the name of the scheme used to make this request

getServerName

public String getServerName()
The default behavior of this method is to return getServerName() on the wrapped request object.

Specified by:
getServerName in interface ServletRequest
Returns:
a String containing the name of the server

getServerPort

public int getServerPort()
The default behavior of this method is to return getServerPort() on the wrapped request object.

Specified by:
getServerPort in interface ServletRequest
Returns:
an integer specifying the port number

getReader

public BufferedReader getReader()
                         throws IOException
The default behavior of this method is to return getReader() on the wrapped request object.

Specified by:
getReader in interface ServletRequest
Returns:
a BufferedReader containing the body of the request
Throws:
IOException - if an input or output exception occurred
See Also:
ServletRequest.getInputStream()

getRemoteAddr

public String getRemoteAddr()
The default behavior of this method is to return getRemoteAddr() on the wrapped request object.

Specified by:
getRemoteAddr in interface ServletRequest
Returns:
a String containing the IP address of the client that sent the request

getRemoteHost

public String getRemoteHost()
The default behavior of this method is to return getRemoteHost() on the wrapped request object.

Specified by:
getRemoteHost in interface ServletRequest
Returns:
a String containing the fully qualified name of the client

setAttribute

public void setAttribute(String name,
                         Object o)
The default behavior of this method is to return setAttribute(String name, Object o) on the wrapped request object.

Specified by:
setAttribute in interface ServletRequest
Parameters:
name - a String specifying the name of the attribute
o - the Object to be stored

removeAttribute

public void removeAttribute(String name)
The default behavior of this method is to call removeAttribute(String name) on the wrapped request object.

Specified by:
removeAttribute in interface ServletRequest
Parameters:
name - a String specifying the name of the attribute to remove

getLocale

public Locale getLocale()
The default behavior of this method is to return getLocale() on the wrapped request object.

Specified by:
getLocale in interface ServletRequest
Returns:
the preferred Locale for the client

getLocales

public Enumeration getLocales()
The default behavior of this method is to return getLocales() on the wrapped request object.

Specified by:
getLocales in interface ServletRequest
Returns:
an Enumeration of preferred Locale objects for the client

isSecure

public boolean isSecure()
The default behavior of this method is to return isSecure() on the wrapped request object.

Specified by:
isSecure in interface ServletRequest
Returns:
a boolean indicating if the request was made using a secure channel

getRequestDispatcher

public RequestDispatcher getRequestDispatcher(String path)
The default behavior of this method is to return getRequestDispatcher(String path) on the wrapped request object.

Specified by:
getRequestDispatcher in interface ServletRequest
Parameters:
path - a String specifying the pathname to the resource. If it is relative, it must be relative against the current servlet.
Returns:
a RequestDispatcher object that acts as a wrapper for the resource at the specified path, or null if the servlet container cannot return a RequestDispatcher
See Also:
RequestDispatcher, ServletContext.getRequestDispatcher(java.lang.String)

getRealPath

public String getRealPath(String path)
The default behavior of this method is to return getRealPath(String path) on the wrapped request object.

Specified by:
getRealPath in interface ServletRequest

getRemotePort

public int getRemotePort()
The default behavior of this method is to return getRemotePort() on the wrapped request object.

Specified by:
getRemotePort in interface ServletRequest
Since:
2.4

getLocalName

public String getLocalName()
The default behavior of this method is to return getLocalName() on the wrapped request object.

Specified by:
getLocalName in interface ServletRequest
Returns:
a String containing the host name of the IP on which the request was received.
Since:
2.4

getLocalAddr

public String getLocalAddr()
The default behavior of this method is to return getLocalAddr() on the wrapped request object.

Specified by:
getLocalAddr in interface ServletRequest
Returns:
a String containing the IP address on which the request was received.
Since:
2.4

getLocalPort

public int getLocalPort()
The default behavior of this method is to return getLocalPort() on the wrapped request object.

Specified by:
getLocalPort in interface ServletRequest
Returns:
an integer specifying the port number
Since:
2.4
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletResponse

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletResponse

All Known Subinterfaces:
HttpServletResponse
All Known Implementing Classes:
HttpServletResponseWrapper, ServletResponseWrapper
public interface ServletResponse

Defines an object to assist a servlet in sending a response to the client. The servlet container creates a ServletResponse object and passes it as an argument to the servlet's service method.

To send binary data in a MIME body response, use the ServletOutputStream returned by getOutputStream(). To send character data, use the PrintWriter object returned by getWriter(). To mix binary and text data, for example, to create a multipart response, use a ServletOutputStream and manage the character sections manually.

The charset for the MIME body response can be specified explicitly using the setCharacterEncoding(java.lang.String) and setContentType(java.lang.String) methods, or implicitly using the setLocale(java.util.Locale) method. Explicit specifications take precedence over implicit specifications. If no charset is specified, ISO-8859-1 will be used. The setCharacterEncoding, setContentType, or setLocale method must be called before getWriter and before committing the response for the character encoding to be used.

See the Internet RFCs such as RFC 2045 for more information on MIME. Protocols such as SMTP and HTTP define profiles of MIME, and those standards are still evolving.

Version:
$Version$
Author:
Various
See Also:
ServletOutputStream

Method Summary
 void flushBuffer()
Forces any content in the buffer to be written to the client.
 int getBufferSize()
Returns the actual buffer size used for the response.
 String getCharacterEncoding()
Returns the name of the character encoding (MIME charset) used for the body sent in this response.
 String getContentType()
Returns the content type used for the MIME body sent in this response.
 Locale getLocale()
Returns the locale specified for this response using the setLocale(java.util.Locale) method.
 ServletOutputStream getOutputStream()
Returns a ServletOutputStream suitable for writing binary data in the response.
 PrintWriter getWriter()
Returns a PrintWriter object that can send character text to the client.
 boolean isCommitted()
Returns a boolean indicating if the response has been committed.
 void reset()
Clears any data that exists in the buffer as well as the status code and headers.
 void resetBuffer()
Clears the content of the underlying buffer in the response without clearing headers or status code.
 void setBufferSize(int size)
Sets the preferred buffer size for the body of the response.
 void setCharacterEncoding(String charset)
Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8.
 void setContentLength(int len)
Sets the length of the content body in the response In HTTP servlets, this method sets the HTTP Content-Length header.
 void setContentType(String type)
Sets the content type of the response being sent to the client, if the response has not been committed yet.
 void setLocale(Locale loc)
Sets the locale of the response, if the response has not been committed yet.

Method Detail

getCharacterEncoding

public String getCharacterEncoding()
Returns the name of the character encoding (MIME charset) used for the body sent in this response. The character encoding may have been specified explicitly using the setCharacterEncoding(java.lang.String) or setContentType(java.lang.String) methods, or implicitly using the setLocale(java.util.Locale) method. Explicit specifications take precedence over implicit specifications. Calls made to these methods after getWriter has been called or after the response has been committed have no effect on the character encoding. If no character encoding has been specified, ISO-8859-1 is returned.

See RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt) for more information about character encoding and MIME.

Returns:
a String specifying the name of the character encoding, for example, UTF-8

getContentType

public String getContentType()
Returns the content type used for the MIME body sent in this response. The content type proper must have been specified using setContentType(java.lang.String) before the response is committed. If no content type has been specified, this method returns null. If a content type has been specified and a character encoding has been explicitly or implicitly specified as described in getCharacterEncoding(), the charset parameter is included in the string returned. If no character encoding has been specified, the charset parameter is omitted.

Returns:
a String specifying the content type, for example, text/html; charset=UTF-8, or null
Since:
2.4

getOutputStream

public ServletOutputStream getOutputStream()
                                    throws IOException
Returns a ServletOutputStream suitable for writing binary data in the response. The servlet container does not encode the binary data.

Calling flush() on the ServletOutputStream commits the response. Either this method or getWriter() may be called to write the body, not both.

Returns:
a ServletOutputStream for writing binary data
Throws:
IllegalStateException - if the getWriter method has been called on this response
IOException - if an input or output exception occurred
See Also:
getWriter()

getWriter

public PrintWriter getWriter()
                      throws IOException
Returns a PrintWriter object that can send character text to the client. The PrintWriter uses the character encoding returned by getCharacterEncoding(). If the response's character encoding has not been specified as described in getCharacterEncoding (i.e., the method just returns the default value ISO-8859-1), getWriter updates it to ISO-8859-1.

Calling flush() on the PrintWriter commits the response.

Either this method or getOutputStream() may be called to write the body, not both.

Returns:
a PrintWriter object that can return character data to the client
Throws:
UnsupportedEncodingException - if the character encoding returned by getCharacterEncoding cannot be used
IllegalStateException - if the getOutputStream method has already been called for this response object
IOException - if an input or output exception occurred
See Also:
getOutputStream(), setCharacterEncoding(java.lang.String)

setCharacterEncoding

public void setCharacterEncoding(String charset)
Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8. If the character encoding has already been set by setContentType(java.lang.String) or setLocale(java.util.Locale), this method overrides it. Calling setContentType(java.lang.String) with the String of text/html and calling this method with the String of UTF-8 is equivalent with calling setContentType with the String of text/html; charset=UTF-8.

This method can be called repeatedly to change the character encoding. This method has no effect if it is called after getWriter has been called or after the response has been committed.

Containers must communicate the character encoding used for the servlet response's writer to the client if the protocol provides a way for doing so. In the case of HTTP, the character encoding is communicated as part of the Content-Type header for text media types. Note that the character encoding cannot be communicated via HTTP headers if the servlet does not specify a content type; however, it is still used to encode text written via the servlet response's writer.

Parameters:
charset - a String specifying only the character set defined by IANA Character Sets (http://www.iana.org/assignments/character-sets)
Since:
2.4
See Also:
#setLocale

setContentLength

public void setContentLength(int len)
Sets the length of the content body in the response In HTTP servlets, this method sets the HTTP Content-Length header.

Parameters:
len - an integer specifying the length of the content being returned to the client; sets the Content-Length header

setContentType

public void setContentType(String type)
Sets the content type of the response being sent to the client, if the response has not been committed yet. The given content type may include a character encoding specification, for example, text/html;charset=UTF-8. The response's character encoding is only set from the given content type if this method is called before getWriter is called.

This method may be called repeatedly to change content type and character encoding. This method has no effect if called after the response has been committed. It does not set the response's character encoding if it is called after getWriter has been called or after the response has been committed.

Containers must communicate the content type and the character encoding used for the servlet response's writer to the client if the protocol provides a way for doing so. In the case of HTTP, the Content-Type header is used.

Parameters:
type - a String specifying the MIME type of the content
See Also:
setLocale(java.util.Locale),
setCharacterEncoding(java.lang.String),
getOutputStream(),
getWriter()

setBufferSize

public void setBufferSize(int size)
Sets the preferred buffer size for the body of the response. The servlet container will use a buffer at least as large as the size requested. The actual buffer size used can be found using getBufferSize.

A larger buffer allows more content to be written before anything is actually sent, thus providing the servlet with more time to set appropriate status codes and headers. A smaller buffer decreases server memory load and allows the client to start receiving data more quickly.

This method must be called before any response body content is written; if content has been written or the response object has been committed, this method throws an IllegalStateException.

Parameters:
size - the preferred buffer size
Throws:
IllegalStateException - if this method is called after content has been written
See Also:
getBufferSize(),
flushBuffer(),
isCommitted(),
reset()

getBufferSize

public int getBufferSize()
Returns the actual buffer size used for the response. If no buffering is used, this method returns 0.

Returns:
the actual buffer size used
See Also:
setBufferSize(int),
flushBuffer(),
isCommitted(),
reset()

flushBuffer

public void flushBuffer()
                 throws IOException
Forces any content in the buffer to be written to the client. A call to this method automatically commits the response, meaning the status code and headers will be written.

Throws:
IOException
See Also:
setBufferSize(int),
getBufferSize(),
isCommitted(),
reset()

resetBuffer

public void resetBuffer()
Clears the content of the underlying buffer in the response without clearing headers or status code. If the response has been committed, this method throws an IllegalStateException.

Since:
2.3
See Also:
setBufferSize(int),
getBufferSize(),
isCommitted(),
reset()

isCommitted

public boolean isCommitted()
Returns a boolean indicating if the response has been committed. A commited response has already had its status code and headers written.

Returns:
a boolean indicating if the response has been committed
See Also:
setBufferSize(int),
getBufferSize(),
flushBuffer(),
reset()

reset

public void reset()
Clears any data that exists in the buffer as well as the status code and headers. If the response has been committed, this method throws an IllegalStateException.

Throws:
IllegalStateException - if the response has already been committed
See Also:
setBufferSize(int),
getBufferSize(),
flushBuffer(),
isCommitted()

setLocale

public void setLocale(Locale loc)
Sets the locale of the response, if the response has not been committed yet. It also sets the response's character encoding appropriately for the locale, if the character encoding has not been explicitly set using setContentType(java.lang.String) or setCharacterEncoding(java.lang.String), getWriter hasn't been called yet, and the response hasn't been committed yet. If the deployment descriptor contains a locale-encoding-mapping-list element, and that element provides a mapping for the given locale, that mapping is used. Otherwise, the mapping from locale to character encoding is container dependent.

This method may be called repeatedly to change locale and character encoding. The method has no effect if called after the response has been committed. It does not set the response's character encoding if it is called after setContentType(java.lang.String) has been called with a charset specification, after setCharacterEncoding(java.lang.String) has been called, after getWriter has been called, or after the response has been committed.

Containers must communicate the locale and the character encoding used for the servlet response's writer to the client if the protocol provides a way for doing so. In the case of HTTP, the locale is communicated via the Content-Language header, the character encoding as part of the Content-Type header for text media types. Note that the character encoding cannot be communicated via HTTP headers if the servlet does not specify a content type; however, it is still used to encode text written via the servlet response's writer.

Parameters:
loc - the locale of the response
See Also:
getLocale(),
setContentType(java.lang.String),
setCharacterEncoding(java.lang.String)

getLocale

public Locale getLocale()
Returns the locale specified for this response using the setLocale(java.util.Locale) method. Calls made to setLocale after the response is committed have no effect. If no locale has been specified, the container's default locale is returned.

See Also:
setLocale(java.util.Locale)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletResponseWrapper

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletResponseWrapper

java.lang.Object
    extended by javax.servlet.ServletResponseWrapper
All Implemented Interfaces:
ServletResponse
Direct Known Subclasses:
HttpServletResponseWrapper
public class ServletResponseWrapper
extends Object
implements ServletResponse

Provides a convenient implementation of the ServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped response object.

Since:
v 2.3
Version:
$Version$
Author:
Various
See Also:
ServletResponse

Constructor Summary
ServletResponseWrapper(ServletResponse response)
Creates a ServletResponse adaptor wrapping the given response object.
Method Summary
 void flushBuffer()
The default behavior of this method is to call flushBuffer() on the wrapped response object.
 int getBufferSize()
The default behavior of this method is to return getBufferSize() on the wrapped response object.
 String getCharacterEncoding()
The default behavior of this method is to return getCharacterEncoding() on the wrapped response object.
 String getContentType()
The default behavior of this method is to return getContentType() on the wrapped response object.
 Locale getLocale()
The default behavior of this method is to return getLocale() on the wrapped response object.
 ServletOutputStream getOutputStream()
The default behavior of this method is to return getOutputStream() on the wrapped response object.
 ServletResponse getResponse()
Return the wrapped ServletResponse object.
 PrintWriter getWriter()
The default behavior of this method is to return getWriter() on the wrapped response object.
 boolean isCommitted()
The default behavior of this method is to return isCommitted() on the wrapped response object.
 void reset()
The default behavior of this method is to call reset() on the wrapped response object.
 void resetBuffer()
The default behavior of this method is to call resetBuffer() on the wrapped response object.
 void setBufferSize(int size)
The default behavior of this method is to call setBufferSize(int size) on the wrapped response object.
 void setCharacterEncoding(String charset)
The default behavior of this method is to call setCharacterEncoding(String charset) on the wrapped response object.
 void setContentLength(int len)
The default behavior of this method is to call setContentLength(int len) on the wrapped response object.
 void setContentType(String type)
The default behavior of this method is to call setContentType(String type) on the wrapped response object.
 void setLocale(Locale loc)
The default behavior of this method is to call setLocale(Locale loc) on the wrapped response object.
 void setResponse(ServletResponse response)
Sets the response being wrapped.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServletResponseWrapper

public ServletResponseWrapper(ServletResponse response)
Creates a ServletResponse adaptor wrapping the given response object.

Throws:
IllegalArgumentException - if the response is null.
Method Detail

getResponse

public ServletResponse getResponse()
Return the wrapped ServletResponse object.

setResponse

public void setResponse(ServletResponse response)
Sets the response being wrapped.

Throws:
IllegalArgumentException - if the response is null.

setCharacterEncoding

public void setCharacterEncoding(String charset)
The default behavior of this method is to call setCharacterEncoding(String charset) on the wrapped response object.

Specified by:
setCharacterEncoding in interface ServletResponse
Parameters:
charset - a String specifying only the character set defined by IANA Character Sets (http://www.iana.org/assignments/character-sets)
Since:
2.4
See Also:
#setLocale

getCharacterEncoding

public String getCharacterEncoding()
The default behavior of this method is to return getCharacterEncoding() on the wrapped response object.

Specified by:
getCharacterEncoding in interface ServletResponse
Returns:
a String specifying the name of the character encoding, for example, UTF-8

getOutputStream

public ServletOutputStream getOutputStream()
                                    throws IOException
The default behavior of this method is to return getOutputStream() on the wrapped response object.

Specified by:
getOutputStream in interface ServletResponse
Returns:
a ServletOutputStream for writing binary data
Throws:
IOException - if an input or output exception occurred
See Also:
ServletResponse.getWriter()

getWriter

public PrintWriter getWriter()
                      throws IOException
The default behavior of this method is to return getWriter() on the wrapped response object.

Specified by:
getWriter in interface ServletResponse
Returns:
a PrintWriter object that can return character data to the client
Throws:
IOException - if an input or output exception occurred
See Also:
ServletResponse.getOutputStream(), ServletResponse.setCharacterEncoding(java.lang.String)

setContentLength

public void setContentLength(int len)
The default behavior of this method is to call setContentLength(int len) on the wrapped response object.

Specified by:
setContentLength in interface ServletResponse
Parameters:
len - an integer specifying the length of the content being returned to the client; sets the Content-Length header

setContentType

public void setContentType(String type)
The default behavior of this method is to call setContentType(String type) on the wrapped response object.

Specified by:
setContentType in interface ServletResponse
Parameters:
type - a String specifying the MIME type of the content
See Also:
ServletResponse.setLocale(java.util.Locale),
ServletResponse.setCharacterEncoding(java.lang.String),
ServletResponse.getOutputStream(),
ServletResponse.getWriter()

getContentType

public String getContentType()
The default behavior of this method is to return getContentType() on the wrapped response object.

Specified by:
getContentType in interface ServletResponse
Returns:
a String specifying the content type, for example, text/html; charset=UTF-8, or null
Since:
2.4

setBufferSize

public void setBufferSize(int size)
The default behavior of this method is to call setBufferSize(int size) on the wrapped response object.

Specified by:
setBufferSize in interface ServletResponse
Parameters:
size - the preferred buffer size
See Also:
ServletResponse.getBufferSize(),
ServletResponse.flushBuffer(),
ServletResponse.isCommitted(),
ServletResponse.reset()

getBufferSize

public int getBufferSize()
The default behavior of this method is to return getBufferSize() on the wrapped response object.

Specified by:
getBufferSize in interface ServletResponse
Returns:
the actual buffer size used
See Also:
ServletResponse.setBufferSize(int),
ServletResponse.flushBuffer(),
ServletResponse.isCommitted(),
ServletResponse.reset()

flushBuffer

public void flushBuffer()
                 throws IOException
The default behavior of this method is to call flushBuffer() on the wrapped response object.

Specified by:
flushBuffer in interface ServletResponse
Throws:
IOException
See Also:
ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.isCommitted(),
ServletResponse.reset()

isCommitted

public boolean isCommitted()
The default behavior of this method is to return isCommitted() on the wrapped response object.

Specified by:
isCommitted in interface ServletResponse
Returns:
a boolean indicating if the response has been committed
See Also:
ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.flushBuffer(),
ServletResponse.reset()

reset

public void reset()
The default behavior of this method is to call reset() on the wrapped response object.

Specified by:
reset in interface ServletResponse
See Also:
ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.flushBuffer(),
ServletResponse.isCommitted()

resetBuffer

public void resetBuffer()
The default behavior of this method is to call resetBuffer() on the wrapped response object.

Specified by:
resetBuffer in interface ServletResponse
See Also:
ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.isCommitted(),
ServletResponse.reset()

setLocale

public void setLocale(Locale loc)
The default behavior of this method is to call setLocale(Locale loc) on the wrapped response object.

Specified by:
setLocale in interface ServletResponse
Parameters:
loc - the locale of the response
See Also:
ServletResponse.getLocale(),
ServletResponse.setContentType(java.lang.String),
ServletResponse.setCharacterEncoding(java.lang.String)

getLocale

public Locale getLocale()
The default behavior of this method is to return getLocale() on the wrapped response object.

Specified by:
getLocale in interface ServletResponse
See Also:
ServletResponse.setLocale(java.util.Locale)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


UnavailableException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class UnavailableException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.servlet.ServletException
                extended by javax.servlet.UnavailableException
All Implemented Interfaces:
Serializable
public class UnavailableException
extends ServletException

Defines an exception that a servlet or filter throws to indicate that it is permanently or temporarily unavailable.

When a servlet or filter is permanently unavailable, something is wrong with it, and it cannot handle requests until some action is taken. For example, a servlet might be configured incorrectly, or a filter's state may be corrupted. The component should log both the error and the corrective action that is needed.

A servlet or filter is temporarily unavailable if it cannot handle requests momentarily due to some system-wide problem. For example, a third-tier server might not be accessible, or there may be insufficient memory or disk storage to handle requests. A system administrator may need to take corrective action.

Servlet containers can safely treat both types of unavailable exceptions in the same way. However, treating temporary unavailability effectively makes the servlet container more robust. Specifically, the servlet container might block requests to the servlet or filter for a period of time suggested by the exception, rather than rejecting them until the servlet container restarts.

Version:
$Version$
Author:
Various
See Also:
Serialized Form

Constructor Summary
UnavailableException(int seconds, Servlet servlet, String msg)
Deprecated. As of Java Servlet API 2.2, use UnavailableException(String, int) instead.
UnavailableException(Servlet servlet, String msg)
Deprecated. As of Java Servlet API 2.2, use UnavailableException(String) instead.
UnavailableException(String msg)
Constructs a new exception with a descriptive message indicating that the servlet is permanently unavailable.
UnavailableException(String msg, int seconds)
Constructs a new exception with a descriptive message indicating that the servlet is temporarily unavailable and giving an estimate of how long it will be unavailable.
Method Summary
Servlet | getServlet() Deprecated. As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.
int | getUnavailableSeconds() Returns the number of seconds the servlet expects to be temporarily unavailable.
boolean | isPermanent() Returns a boolean indicating whether the servlet is permanently unavailable.
Methods inherited from class javax.servlet.ServletException
getRootCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnavailableException

public UnavailableException(Servlet servlet,
                            String msg)
Deprecated. As of Java Servlet API 2.2, use UnavailableException(String) instead.

Parameters:
servlet - the Servlet instance that is unavailable
msg - a String specifying the descriptive message

UnavailableException

public UnavailableException(int seconds,
                            Servlet servlet,
                            String msg)
Deprecated. As of Java Servlet API 2.2, use UnavailableException(String, int) instead.

Parameters:
seconds - an integer specifying the number of seconds the servlet expects to be unavailable; if zero or negative, indicates that the servlet can't make an estimate
servlet - the Servlet that is unavailable
msg - a String specifying the descriptive message, which can be written to a log file or displayed for the user.

UnavailableException

public UnavailableException(String msg)
Constructs a new exception with a descriptive message indicating that the servlet is permanently unavailable.

Parameters:
msg - a String specifying the descriptive message

UnavailableException

public UnavailableException(String msg,
                            int seconds)
Constructs a new exception with a descriptive message indicating that the servlet is temporarily unavailable and giving an estimate of how long it will be unavailable.

In some cases, the servlet cannot make an estimate. For example, the servlet might know that a server it needs is not running, but not be able to report how long it will take to be restored to functionality. This can be indicated with a negative or zero value for the seconds argument.

Parameters:
msg - a String specifying the descriptive message, which can be written to a log file or displayed for the user.
seconds - an integer specifying the number of seconds the servlet expects to be unavailable; if zero or negative, indicates that the servlet can't make an estimate
Method Detail

isPermanent

public boolean isPermanent()
Returns a boolean indicating whether the servlet is permanently unavailable. If so, something is wrong with the servlet, and the system administrator must take some corrective action.

Returns:
true if the servlet is permanently unavailable; false if the servlet is available or temporarily unavailable

getServlet

public Servlet getServlet()
Deprecated. As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.

Returns:
the Servlet object that is throwing the UnavailableException

getUnavailableSeconds

public int getUnavailableSeconds()
Returns the number of seconds the servlet expects to be temporarily unavailable.

If this method returns a negative number, the servlet is permanently unavailable or cannot provide an estimate of how long it will be unavailable. No effort is made to correct for the time elapsed since the exception was first reported.

Returns:
an integer specifying the number of seconds the servlet will be temporarily unavailable, or a negative number if the servlet is permanently unavailable or cannot make an estimate
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


transaction

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.transaction

Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

See:
Description

Interface Summary
Status | The Status interface defines static variables used for transaction status codes.
Synchronization | The transaction manager supports a synchronization mechanism that allows the interested party to be notified before and after the transaction completes.
Transaction | The Transaction interface allows operations to be performed against the transaction in the target Transaction object.
TransactionManager | The TransactionManager interface defines the methods that allow an application server to manage transaction boundaries.
UserTransaction | The UserTransaction interface defines the methods that allow an application to explicitly manage transaction boundaries.

Exception Summary
HeuristicCommitException | This exception is thrown by the rollback operation on a resource to report that a heuristic decision was made and that all relevant updates have been committed.
HeuristicMixedException | This exception is thrown to report that a heuristic decision was made and that some relevant updates have been committed and others have been rolled back.
HeuristicRollbackException | This exception is thrown by the commit operation to report that a heuristic decision was made and that all relevant updates have been rolled back.
InvalidTransactionException | This exception indicates that the request carried an invalid transaction context.
NotSupportedException | NotSupportedException exception indicates that the request cannot be executed because the operation is not a supported feature.
RollbackException | RollbackException exception is thrown when the transaction has been marked for rollback only or the transaction has been rolled back instead of committed.
SystemException | The SystemException is thrown by the transaction manager to indicate that it has encountered an unexpected error condition that prevents future transaction services from proceeding.
TransactionRequiredException | This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.
TransactionRolledbackException | This exception indicates that the transaction associated with processing of the request has been rolled back, or it has been marked to roll back.

Package javax.transaction Description

Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server. The implementation of this API is provided by the application server vendor and the resource manager driver vendor.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.transaction Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.transaction

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.transaction.HeuristicCommitException
        • class javax.transaction.HeuristicMixedException
        • class javax.transaction.HeuristicRollbackException
        • class java.io.IOException
          • class java.rmi.RemoteException
            • class javax.transaction.InvalidTransactionException
            • class javax.transaction.TransactionRequiredException
            • class javax.transaction.TransactionRolledbackException
        • class javax.transaction.NotSupportedException
        • class javax.transaction.RollbackException
        • class javax.transaction.SystemException

Interface Hierarchy

  • interface javax.transaction.Status
  • interface javax.transaction.Synchronization
  • interface javax.transaction.Transaction
  • interface javax.transaction.TransactionManager
  • interface javax.transaction.UserTransaction
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HeuristicCommitException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class HeuristicCommitException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.transaction.HeuristicCommitException
All Implemented Interfaces:
Serializable
public class HeuristicCommitException
extends Exception

This exception is thrown by the rollback operation on a resource to report that a heuristic decision was made and that all relevant updates have been committed.

See Also:
Serialized Form

Constructor Summary
HeuristicCommitException()
HeuristicCommitException(String msg)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HeuristicCommitException

public HeuristicCommitException()

HeuristicCommitException

public HeuristicCommitException(String msg)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HeuristicMixedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class HeuristicMixedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.transaction.HeuristicMixedException
All Implemented Interfaces:
Serializable
public class HeuristicMixedException
extends Exception

This exception is thrown to report that a heuristic decision was made and that some relevant updates have been committed and others have been rolled back.

See Also:
Serialized Form

Constructor Summary
HeuristicMixedException()
HeuristicMixedException(String msg)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HeuristicMixedException

public HeuristicMixedException()

HeuristicMixedException

public HeuristicMixedException(String msg)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HeuristicRollbackException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class HeuristicRollbackException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.transaction.HeuristicRollbackException
All Implemented Interfaces:
Serializable
public class HeuristicRollbackException
extends Exception

This exception is thrown by the commit operation to report that a heuristic decision was made and that all relevant updates have been rolled back.

See Also:
Serialized Form

Constructor Summary
HeuristicRollbackException()
HeuristicRollbackException(String msg)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HeuristicRollbackException

public HeuristicRollbackException()

HeuristicRollbackException

public HeuristicRollbackException(String msg)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidTransactionException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class InvalidTransactionException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.io.IOException
                extended by java.rmi.RemoteException
                    extended by javax.transaction.InvalidTransactionException
All Implemented Interfaces:
Serializable
public class InvalidTransactionException
extends RemoteException

This exception indicates that the request carried an invalid transaction context. For example, this exception could be raised if an error occurred when trying to register a resource.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.rmi.RemoteException
detail
Constructor Summary
InvalidTransactionException()
InvalidTransactionException(String msg)
Methods inherited from class java.rmi.RemoteException
getCause, getMessage
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidTransactionException

public InvalidTransactionException()

InvalidTransactionException

public InvalidTransactionException(String msg)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NotSupportedException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class NotSupportedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.transaction.NotSupportedException
All Implemented Interfaces:
Serializable
public class NotSupportedException
extends Exception

NotSupportedException exception indicates that the request cannot be executed because the operation is not a supported feature. For example, because nested transactions are not supported, the Transaction Manager throws this exception when a calling thread that is already associated with a transaction attempts to start a new transaction. (A nested transaction occurs when a thread is already associated with one transaction and attempts to start a second transaction.)

See Also:
Serialized Form

Constructor Summary
NotSupportedException()
NotSupportedException(String msg)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NotSupportedException

public NotSupportedException()

NotSupportedException

public NotSupportedException(String msg)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RollbackException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class RollbackException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.transaction.RollbackException
All Implemented Interfaces:
Serializable
public class RollbackException
extends Exception

RollbackException exception is thrown when the transaction has been marked for rollback only or the transaction has been rolled back instead of committed. This is a local exception thrown by methods in the UserTransaction, Transaction, and TransactionManager interfaces.

See Also:
Serialized Form

Constructor Summary
RollbackException()
RollbackException(String msg)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RollbackException

public RollbackException()

RollbackException

public RollbackException(String msg)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Status

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface Status

public interface Status

The Status interface defines static variables used for transaction status codes.

Field Summary
static int | STATUS_ACTIVE A transaction is associated with the target object and it is in the active state.
static int | STATUS_COMMITTED A transaction is associated with the target object and it has been committed.
static int | STATUS_COMMITTING A transaction is associated with the target object and it is in the process of committing.
static int | STATUS_MARKED_ROLLBACK A transaction is associated with the target object and it has been marked for rollback, perhaps as a result of a setRollbackOnly operation.
static int | STATUS_NO_TRANSACTION No transaction is currently associated with the target object.
static int | STATUS_PREPARED A transaction is associated with the target object and it has been prepared.
static int | STATUS_PREPARING A transaction is associated with the target object and it is in the process of preparing.
static int | STATUS_ROLLEDBACK A transaction is associated with the target object and the outcome has been determined to be rollback.
static int | STATUS_ROLLING_BACK A transaction is associated with the target object and it is in the process of rolling back.
static int | STATUS_UNKNOWN A transaction is associated with the target object but its current status cannot be determined.

Field Detail

STATUS_ACTIVE

public static final int STATUS_ACTIVE
A transaction is associated with the target object and it is in the active state. An implementation returns this status after a transaction has been started and prior to a Coordinator issuing any prepares, unless the transaction has been marked for rollback.

See Also:
Constant Field Values

STATUS_MARKED_ROLLBACK

public static final int STATUS_MARKED_ROLLBACK
A transaction is associated with the target object and it has been marked for rollback, perhaps as a result of a setRollbackOnly operation.

See Also:
Constant Field Values

STATUS_PREPARED

public static final int STATUS_PREPARED
A transaction is associated with the target object and it has been prepared. That is, all subordinates have agreed to commit. The target object may be waiting for instructions from a superior as to how to proceed.

See Also:
Constant Field Values

STATUS_COMMITTED

public static final int STATUS_COMMITTED
A transaction is associated with the target object and it has been committed. It is likely that heuristics exist; otherwise, the transaction would have been destroyed and NoTransaction returned.

See Also:
Constant Field Values

STATUS_ROLLEDBACK

public static final int STATUS_ROLLEDBACK
A transaction is associated with the target object and the outcome has been determined to be rollback. It is likely that heuristics exist; otherwise, the transaction would have been destroyed and NoTransaction returned.

See Also:
Constant Field Values

STATUS_UNKNOWN

public static final int STATUS_UNKNOWN
A transaction is associated with the target object but its current status cannot be determined. This is a transient condition and a subsequent invocation will ultimately return a different status.

See Also:
Constant Field Values

STATUS_NO_TRANSACTION

public static final int STATUS_NO_TRANSACTION
No transaction is currently associated with the target object. This will occur after a transaction has completed.

See Also:
Constant Field Values

STATUS_PREPARING

public static final int STATUS_PREPARING
A transaction is associated with the target object and it is in the process of preparing. An implementation returns this status if it has started preparing, but has not yet completed the process. The likely reason for this is that the implementation is probably waiting for responses to prepare from one or more Resources.

See Also:
Constant Field Values

STATUS_COMMITTING

public static final int STATUS_COMMITTING
A transaction is associated with the target object and it is in the process of committing. An implementation returns this status if it has decided to commit but has not yet completed the committing process. This occurs because the implementation is probably waiting for responses from one or more Resources.

See Also:
Constant Field Values

STATUS_ROLLING_BACK

public static final int STATUS_ROLLING_BACK
A transaction is associated with the target object and it is in the process of rolling back. An implementation returns this status if it has decided to rollback but has not yet completed the process. The implementation is probably waiting for responses from one or more Resources.

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Synchronization

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface Synchronization

public interface Synchronization

The transaction manager supports a synchronization mechanism that allows the interested party to be notified before and after the transaction completes. Using the registerSynchronization method, the application server registers a Synchronization object for the transaction currently associated with the target Transaction object.

Method Summary
void | afterCompletion(int status) This method is called by the transaction manager after the transaction is committed or rolled back.
void | beforeCompletion() The beforeCompletion method is called by the transaction manager prior to the start of the two-phase transaction commit process.

Method Detail

beforeCompletion

public void beforeCompletion()
The beforeCompletion method is called by the transaction manager prior to the start of the two-phase transaction commit process. This call is executed with the transaction context of the transaction that is being committed.

afterCompletion

public void afterCompletion(int status)
This method is called by the transaction manager after the transaction is committed or rolled back.

Parameters:
status - The status of the transaction completion.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SystemException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class SystemException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.transaction.SystemException
All Implemented Interfaces:
Serializable
public class SystemException
extends Exception

The SystemException is thrown by the transaction manager to indicate that it has encountered an unexpected error condition that prevents future transaction services from proceeding.

See Also:
Serialized Form

Field Summary
 int errorCode
The error code with which to create the SystemException.
Constructor Summary
SystemException()
SystemException(int errcode)
Create a SystemException with a given error code.
SystemException(String s)
Create a SystemException with a given string.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

errorCode

public int errorCode
The error code with which to create the SystemException.

Constructor Detail

SystemException

public SystemException()

SystemException

public SystemException(String s)
Create a SystemException with a given string.

Parameters:
s - The string message for the exception

SystemException

public SystemException(int errcode)
Create a SystemException with a given error code.

Parameters:
errcode - The error code for the exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Transaction

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface Transaction

public interface Transaction

The Transaction interface allows operations to be performed against the transaction in the target Transaction object. A Transaction object is created corresponding to each global transaction creation. The Transaction object can be used for resource enlistment, synchronization registration, transaction completion, and status query operations.

Method Summary
void | commit() Complete the transaction represented by this Transaction object.
boolean | delistResource(XAResource xaRes, int flag) Disassociate the resource specified from the transaction associated with the target Transaction object.
boolean | enlistResource(XAResource xaRes) Enlist the resource specified with the transaction associated with the target Transaction object.
int | getStatus() Obtain the status of the transaction associated with the target Transaction object.
void | registerSynchronization(Synchronization sync) Register a synchronization object for the transaction currently associated with the target object.
void | rollback() Rollback the transaction represented by this Transaction object.
void | setRollbackOnly() Modify the transaction associated with the target object such that the only possible outcome of the transaction is to roll back the transaction.

Method Detail

commit

public void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
Complete the transaction represented by this Transaction object.

Throws:
RollbackException - Thrown to indicate that the transaction has been rolled back rather than committed.
HeuristicMixedException - Thrown to indicate that a heuristic decision was made and that some relevant updates have been committed while others have been rolled back.
HeuristicRollbackException - Thrown to indicate that a heuristic decision was made and that all relevant updates have been rolled back.
SecurityException - Thrown to indicate that the thread is not allowed to commit the transaction.
IllegalStateException - Thrown if the transaction in the target object is inactive.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

delistResource

public boolean delistResource(XAResource xaRes,
                              int flag)
                       throws IllegalStateException,
                              SystemException
Disassociate the resource specified from the transaction associated with the target Transaction object.

Parameters:
xaRes - The XAResource object associated with the resource (connection).
flag - One of the values of TMSUCCESS, TMSUSPEND, or TMFAIL.
Returns:
true if the resource was delisted successfully; otherwise false.
Throws:
IllegalStateException - Thrown if the transaction in the target object is inactive.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

enlistResource

public boolean enlistResource(XAResource xaRes)
                       throws RollbackException,
                              IllegalStateException,
                              SystemException
Enlist the resource specified with the transaction associated with the target Transaction object.

Parameters:
xaRes - The XAResource object associated with the resource (connection).
Returns:
true if the resource was enlisted successfully; otherwise false.
Throws:
RollbackException - Thrown to indicate that the transaction has been marked for rollback only.
IllegalStateException - Thrown if the transaction in the target object is in the prepared state or the transaction is inactive.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

getStatus

public int getStatus()
              throws SystemException
Obtain the status of the transaction associated with the target Transaction object.

Returns:
The transaction status. If no transaction is associated with the target object, this method returns the Status.NoTransaction value.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

registerSynchronization

public void registerSynchronization(Synchronization sync)
                             throws RollbackException,
                                    IllegalStateException,
                                    SystemException
Register a synchronization object for the transaction currently associated with the target object. The transction manager invokes the beforeCompletion method prior to starting the two-phase transaction commit process. After the transaction is completed, the transaction manager invokes the afterCompletion method.

Parameters:
sync - The Synchronization object for the transaction associated with the target object.
Throws:
RollbackException - Thrown to indicate that the transaction has been marked for rollback only.
IllegalStateException - Thrown if the transaction in the target object is in the prepared state or the transaction is inactive.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

rollback

public void rollback()
              throws IllegalStateException,
                     SystemException
Rollback the transaction represented by this Transaction object.

Throws:
IllegalStateException - Thrown if the transaction in the target object is in the prepared state or the transaction is inactive.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

setRollbackOnly

public void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
Modify the transaction associated with the target object such that the only possible outcome of the transaction is to roll back the transaction.

Throws:
IllegalStateException - Thrown if the target object is not associated with any transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransactionManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface TransactionManager

public interface TransactionManager

The TransactionManager interface defines the methods that allow an application server to manage transaction boundaries.

Method Summary
void | begin() Create a new transaction and associate it with the current thread.
void | commit() Complete the transaction associated with the current thread.
int | getStatus() Obtain the status of the transaction associated with the current thread.
Transaction | getTransaction() Get the transaction object that represents the transaction context of the calling thread.
void | resume(Transaction tobj) Resume the transaction context association of the calling thread with the transaction represented by the supplied Transaction object.
void | rollback() Roll back the transaction associated with the current thread.
void | setRollbackOnly() Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.
void | setTransactionTimeout(int seconds) Modify the timeout value that is associated with transactions started by subsequent invocations of the begin method.
Transaction | suspend() Suspend the transaction currently associated with the calling thread and return a Transaction object that represents the transaction context being suspended.

Method Detail

begin

public void begin()
           throws NotSupportedException,
                  SystemException
Create a new transaction and associate it with the current thread.

Throws:
NotSupportedException - Thrown if the thread is already associated with a transaction and the Transaction Manager implementation does not support nested transactions.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

commit

public void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
Complete the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.

Throws:
RollbackException - Thrown to indicate that the transaction has been rolled back rather than committed.
HeuristicMixedException - Thrown to indicate that a heuristic decision was made and that some relevant updates have been committed while others have been rolled back.
HeuristicRollbackException - Thrown to indicate that a heuristic decision was made and that all relevant updates have been rolled back.
SecurityException - Thrown to indicate that the thread is not allowed to commit the transaction.
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

getStatus

public int getStatus()
              throws SystemException
Obtain the status of the transaction associated with the current thread.

Returns:
The transaction status. If no transaction is associated with the current thread, this method returns the Status.NoTransaction value.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

getTransaction

public Transaction getTransaction()
                           throws SystemException
Get the transaction object that represents the transaction context of the calling thread.

Returns:
the Transaction object representing the transaction associated with the calling thread.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

resume

public void resume(Transaction tobj)
            throws InvalidTransactionException,
                   IllegalStateException,
                   SystemException
Resume the transaction context association of the calling thread with the transaction represented by the supplied Transaction object. When this method returns, the calling thread is associated with the transaction context specified.

Parameters:
tobj - The Transaction object that represents the transaction to be resumed.
Throws:
InvalidTransactionException - Thrown if the parameter transaction object contains an invalid transaction.
IllegalStateException - Thrown if the thread is already associated with another transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

rollback

public void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
Roll back the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.

Throws:
SecurityException - Thrown to indicate that the thread is not allowed to roll back the transaction.
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

setRollbackOnly

public void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.

Throws:
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

setTransactionTimeout

public void setTransactionTimeout(int seconds)
                           throws SystemException
Modify the timeout value that is associated with transactions started by subsequent invocations of the begin method.

If an application has not called this method, the transaction service uses some default value for the transaction timeout.

Parameters:
seconds - The value of the timeout in seconds. If the value is zero, the transaction service restores the default value. If the value is negative a SystemException is thrown.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

suspend

public Transaction suspend()
                    throws SystemException
Suspend the transaction currently associated with the calling thread and return a Transaction object that represents the transaction context being suspended. If the calling thread is not associated with a transaction, the method returns a null object reference. When this method returns, the calling thread is not associated with a transaction.

Returns:
Transaction object representing the suspended transaction.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransactionRequiredException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class TransactionRequiredException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.io.IOException
                extended by java.rmi.RemoteException
                    extended by javax.transaction.TransactionRequiredException
All Implemented Interfaces:
Serializable
public class TransactionRequiredException
extends RemoteException

This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.rmi.RemoteException
detail
Constructor Summary
TransactionRequiredException()
TransactionRequiredException(String msg)
Methods inherited from class java.rmi.RemoteException
getCause, getMessage
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRequiredException

public TransactionRequiredException()

TransactionRequiredException

public TransactionRequiredException(String msg)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransactionRolledbackException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class TransactionRolledbackException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.io.IOException
                extended by java.rmi.RemoteException
                    extended by javax.transaction.TransactionRolledbackException
All Implemented Interfaces:
Serializable
public class TransactionRolledbackException
extends RemoteException

This exception indicates that the transaction associated with processing of the request has been rolled back, or it has been marked to roll back. Thus the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.rmi.RemoteException
detail
Constructor Summary
TransactionRolledbackException()
TransactionRolledbackException(String msg)
Methods inherited from class java.rmi.RemoteException
getCause, getMessage
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRolledbackException

public TransactionRolledbackException()

TransactionRolledbackException

public TransactionRolledbackException(String msg)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


UserTransaction

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface UserTransaction

public interface UserTransaction

The UserTransaction interface defines the methods that allow an application to explicitly manage transaction boundaries.

Method Summary
void | begin() Create a new transaction and associate it with the current thread.
void | commit() Complete the transaction associated with the current thread.
int | getStatus() Obtain the status of the transaction associated with the current thread.
void | rollback() Roll back the transaction associated with the current thread.
void | setRollbackOnly() Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.
void | setTransactionTimeout(int seconds) Modify the timeout value that is associated with transactions started by subsequent invocations of the begin method.

Method Detail

begin

public void begin()
           throws NotSupportedException,
                  SystemException
Create a new transaction and associate it with the current thread.

Throws:
NotSupportedException - Thrown if the thread is already associated with a transaction and the Transaction Manager implementation does not support nested transactions.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

commit

public void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
Complete the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.

Throws:
RollbackException - Thrown to indicate that the transaction has been rolled back rather than committed.
HeuristicMixedException - Thrown to indicate that a heuristic decision was made and that some relevant updates have been committed while others have been rolled back.
HeuristicRollbackException - Thrown to indicate that a heuristic decision was made and that all relevant updates have been rolled back.
SecurityException - Thrown to indicate that the thread is not allowed to commit the transaction.
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

rollback

public void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
Roll back the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.

Throws:
SecurityException - Thrown to indicate that the thread is not allowed to roll back the transaction.
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

setRollbackOnly

public void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.

Throws:
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

getStatus

public int getStatus()
              throws SystemException
Obtain the status of the transaction associated with the current thread.

Returns:
The transaction status. If no transaction is associated with the current thread, this method returns the Status.NoTransaction value.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

setTransactionTimeout

public void setTransactionTimeout(int seconds)
                           throws SystemException
Modify the timeout value that is associated with transactions started by subsequent invocations of the begin method.

If an application has not called this method, the transaction service uses some default value for the transaction timeout.

Parameters:
seconds - The value of the timeout in seconds. If the value is zero, the transaction service restores the default value. If the value is negative a SystemException is thrown.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


xa

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.transaction.xa

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

See:
Description

Interface Summary
XAResource | The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
Xid | The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.

Exception Summary
XAException The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.

Package javax.transaction.xa Description

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions. The driver vendor for a specific resource manager provides the implementation of this API.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.transaction.xa Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.transaction.xa

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.transaction.xa.XAException

Interface Hierarchy

  • interface javax.transaction.xa.XAResource
  • interface javax.transaction.xa.Xid
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XAException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction.xa
Class XAException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.transaction.xa.XAException
All Implemented Interfaces:
Serializable
public class XAException
extends Exception

The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.

See Also:
Serialized Form

Field Summary
int | errorCode The error code with which to create the SystemException.
static int | XA_HEURCOM The transaction branch has been heuristically committed.
static int | XA_HEURHAZ The transaction branch may have been heuristically completed.
static int | XA_HEURMIX The transaction branch has been heuristically committed and rolled back.
static int | XA_HEURRB The transaction branch has been heuristically rolled back.
static int | XA_NOMIGRATE Resumption must occur where the suspension occurred.
static int | XA_RBBASE The inclusive lower bound of the rollback codes.
static int | XA_RBCOMMFAIL Indicates that the rollback was caused by a communication failure.
static int | XA_RBDEADLOCK A deadlock was detected.
static int | XA_RBEND The inclusive upper bound of the rollback error code.
static int | XA_RBINTEGRITY A condition that violates the integrity of the resource was detected.
static int | XA_RBOTHER The resource manager rolled back the transaction branch for a reason not on this list.
static int | XA_RBPROTO A protocol error occurred in the resource manager.
static int | XA_RBROLLBACK Indicates that the rollback was caused by an unspecified reason.
static int | XA_RBTIMEOUT A transaction branch took too long.
static int | XA_RBTRANSIENT May retry the transaction branch.
static int | XA_RDONLY The transaction branch was read-only and has been committed.
static int | XA_RETRY Routine returned with no effect and may be reissued.
static int | XAER_ASYNC There is an asynchronous operation already outstanding.
static int | XAER_DUPID The XID already exists.
static int | XAER_INVAL Invalid arguments were given.
static int | XAER_NOTA The XID is not valid.
static int | XAER_OUTSIDE The resource manager is doing work outside a global transaction.
static int | XAER_PROTO Routine was invoked in an improper context.
static int | XAER_RMERR A resource manager error has occurred in the transaction branch.
static int | XAER_RMFAIL Resource manager is unavailable.
Constructor Summary
XAException()
Create an XAException.
XAException(int errcode)
Create an XAException with a given error code.
XAException(String s)
Create an XAException with a given string.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

errorCode

public int errorCode
The error code with which to create the SystemException.

XA_RBBASE

public static final int XA_RBBASE
The inclusive lower bound of the rollback codes.

See Also:
Constant Field Values

XA_RBROLLBACK

public static final int XA_RBROLLBACK
Indicates that the rollback was caused by an unspecified reason.

See Also:
Constant Field Values

XA_RBCOMMFAIL

public static final int XA_RBCOMMFAIL
Indicates that the rollback was caused by a communication failure.

See Also:
Constant Field Values

XA_RBDEADLOCK

public static final int XA_RBDEADLOCK
A deadlock was detected.

See Also:
Constant Field Values

XA_RBINTEGRITY

public static final int XA_RBINTEGRITY
A condition that violates the integrity of the resource was detected.

See Also:
Constant Field Values

XA_RBOTHER

public static final int XA_RBOTHER
The resource manager rolled back the transaction branch for a reason not on this list.

See Also:
Constant Field Values

XA_RBPROTO

public static final int XA_RBPROTO
A protocol error occurred in the resource manager.

See Also:
Constant Field Values

XA_RBTIMEOUT

public static final int XA_RBTIMEOUT
A transaction branch took too long.

See Also:
Constant Field Values

XA_RBTRANSIENT

public static final int XA_RBTRANSIENT
May retry the transaction branch.

See Also:
Constant Field Values

XA_RBEND

public static final int XA_RBEND
The inclusive upper bound of the rollback error code.

See Also:
Constant Field Values

XA_NOMIGRATE

public static final int XA_NOMIGRATE
Resumption must occur where the suspension occurred.

See Also:
Constant Field Values

XA_HEURHAZ

public static final int XA_HEURHAZ
The transaction branch may have been heuristically completed.

See Also:
Constant Field Values

XA_HEURCOM

public static final int XA_HEURCOM
The transaction branch has been heuristically committed.

See Also:
Constant Field Values

XA_HEURRB

public static final int XA_HEURRB
The transaction branch has been heuristically rolled back.

See Also:
Constant Field Values

XA_HEURMIX

public static final int XA_HEURMIX
The transaction branch has been heuristically committed and rolled back.

See Also:
Constant Field Values

XA_RETRY

public static final int XA_RETRY
Routine returned with no effect and may be reissued.

See Also:
Constant Field Values

XA_RDONLY

public static final int XA_RDONLY
The transaction branch was read-only and has been committed.

See Also:
Constant Field Values

XAER_ASYNC

public static final int XAER_ASYNC
There is an asynchronous operation already outstanding.

See Also:
Constant Field Values

XAER_RMERR

public static final int XAER_RMERR
A resource manager error has occurred in the transaction branch.

See Also:
Constant Field Values

XAER_NOTA

public static final int XAER_NOTA
The XID is not valid.

See Also:
Constant Field Values

XAER_INVAL

public static final int XAER_INVAL
Invalid arguments were given.

See Also:
Constant Field Values

XAER_PROTO

public static final int XAER_PROTO
Routine was invoked in an improper context.

See Also:
Constant Field Values

XAER_RMFAIL

public static final int XAER_RMFAIL
Resource manager is unavailable.

See Also:
Constant Field Values

XAER_DUPID

public static final int XAER_DUPID
The XID already exists.

See Also:
Constant Field Values

XAER_OUTSIDE

public static final int XAER_OUTSIDE
The resource manager is doing work outside a global transaction.

See Also:
Constant Field Values
Constructor Detail

XAException

public XAException()
Create an XAException.

XAException

public XAException(String s)
Create an XAException with a given string.

Parameters:
s - The String object containing the exception message.

XAException

public XAException(int errcode)
Create an XAException with a given error code.

Parameters:
errcode - The error code identifying the exception.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XAResource

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction.xa
Interface XAResource

public interface XAResource

The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).

The XA interface defines the contract between a Resource Manager and a Transaction Manager in a distributed transaction processing (DTP) environment. A JDBC driver or a JMS provider implements this interface to support the association between a global transaction and a database or message service connection.

The XAResource interface can be supported by any transactional resource that is intended to be used by application programs in an environment where transactions are controlled by an external transaction manager. An example of such a resource is a database management system. An application may access data through multiple database connections. Each database connection is enlisted with the transaction manager as a transactional resource. The transaction manager obtains an XAResource for each connection participating in a global transaction. The transaction manager uses the start method to associate the global transaction with the resource, and it uses the end method to disassociate the transaction from the resource. The resource manager is responsible for associating the global transaction to all work performed on its data between the start and end method invocations.

At transaction commit time, the resource managers are informed by the transaction manager to prepare, commit, or rollback a transaction according to the two-phase commit protocol.

Field Summary
static int | TMENDRSCAN Ends a recovery scan.
static int | TMFAIL Disassociates the caller and marks the transaction branch rollback-only.
static int | TMJOIN Caller is joining existing transaction branch.
static int | TMNOFLAGS Use TMNOFLAGS to indicate no flags value is selected.
static int | TMONEPHASE Caller is using one-phase optimization.
static int | TMRESUME Caller is resuming association with a suspended transaction branch.
static int | TMSTARTRSCAN Starts a recovery scan.
static int | TMSUCCESS Disassociates caller from a transaction branch.
static int | TMSUSPEND Caller is suspending (not ending) its association with a transaction branch.
static int | XA_OK The transaction work has been prepared normally.
static int | XA_RDONLY The transaction branch has been read-only and has been committed.
Method Summary
void | commit(Xid xid, boolean onePhase) Commits the global transaction specified by xid.
void | end(Xid xid, int flags) Ends the work performed on behalf of a transaction branch.
void | forget(Xid xid) Tells the resource manager to forget about a heuristically completed transaction branch.
int | getTransactionTimeout() Obtains the current transaction timeout value set for this XAResource instance.
boolean | isSameRM(XAResource xares) This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
int | prepare(Xid xid) Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
Xid[] | recover(int flag) Obtains a list of prepared transaction branches from a resource manager.
void | rollback(Xid xid) Informs the resource manager to roll back work done on behalf of a transaction branch.
boolean | setTransactionTimeout(int seconds) Sets the current transaction timeout value for this XAResource instance.
void | start(Xid xid, int flags) Starts work on behalf of a transaction branch specified in xid.

Field Detail

TMENDRSCAN

public static final int TMENDRSCAN
Ends a recovery scan.

See Also:
Constant Field Values

TMFAIL

public static final int TMFAIL
Disassociates the caller and marks the transaction branch rollback-only.

See Also:
Constant Field Values

TMJOIN

public static final int TMJOIN
Caller is joining existing transaction branch.

See Also:
Constant Field Values

TMNOFLAGS

public static final int TMNOFLAGS
Use TMNOFLAGS to indicate no flags value is selected.

See Also:
Constant Field Values

TMONEPHASE

public static final int TMONEPHASE
Caller is using one-phase optimization.

See Also:
Constant Field Values

TMRESUME

public static final int TMRESUME
Caller is resuming association with a suspended transaction branch.

See Also:
Constant Field Values

TMSTARTRSCAN

public static final int TMSTARTRSCAN
Starts a recovery scan.

See Also:
Constant Field Values

TMSUCCESS

public static final int TMSUCCESS
Disassociates caller from a transaction branch.

See Also:
Constant Field Values

TMSUSPEND

public static final int TMSUSPEND
Caller is suspending (not ending) its association with a transaction branch.

See Also:
Constant Field Values

XA_RDONLY

public static final int XA_RDONLY
The transaction branch has been read-only and has been committed.

See Also:
Constant Field Values

XA_OK

public static final int XA_OK
The transaction work has been prepared normally.

See Also:
Constant Field Values
Method Detail

commit

public void commit(Xid xid,
                   boolean onePhase)
            throws XAException
Commits the global transaction specified by xid.

Parameters:
xid - A global transaction identifier
onePhase - If true, the resource manager should use a one-phase commit protocol to commit the work done on behalf of xid.
Throws:
XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

If the resource manager did not commit the transaction and the parameter onePhase is set to true, the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

end

public void end(Xid xid,
                int flags)
         throws XAException
Ends the work performed on behalf of a transaction branch. The resource manager disassociates the XA resource from the transaction branch specified and lets the transaction complete.

If TMSUSPEND is specified in the flags, the transaction branch is temporarily suspended in an incomplete state. The transaction context is in a suspended state and must be resumed via the start method with TMRESUME specified.

If TMFAIL is specified, the portion of work has failed. The resource manager may mark the transaction as rollback-only

If TMSUCCESS is specified, the portion of work has completed successfully.

Parameters:
xid - A global transaction identifier that is the same as the identifier used previously in the start method.
flags - One of TMSUCCESS, TMFAIL, or TMSUSPEND.
Throws:
XAException - An error has occurred. Possible XAException values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, XAER_PROTO, or XA_RB*.

forget

public void forget(Xid xid)
            throws XAException
Tells the resource manager to forget about a heuristically completed transaction branch.

Parameters:
xid - A global transaction identifier.
Throws:
XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

getTransactionTimeout

public int getTransactionTimeout()
                          throws XAException
Obtains the current transaction timeout value set for this XAResource instance. If XAResource.setTransactionTimeout was not used prior to invoking this method, the return value is the default timeout set for the resource manager; otherwise, the value used in the previous setTransactionTimeout call is returned.

Returns:
the transaction timeout value in seconds.
Throws:
XAException - An error has occurred. Possible exception values are XAER_RMERR and XAER_RMFAIL.

isSameRM

public boolean isSameRM(XAResource xares)
                 throws XAException
This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.

Parameters:
xares - An XAResource object whose resource manager instance is to be compared with the resource manager instance of the target object.
Returns:
true if it's the same RM instance; otherwise false.
Throws:
XAException - An error has occurred. Possible exception values are XAER_RMERR and XAER_RMFAIL.

prepare

public int prepare(Xid xid)
            throws XAException
Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.

Parameters:
xid - A global transaction identifier.
Returns:
A value indicating the resource manager's vote on the outcome of the transaction. The possible values are: XA_RDONLY or XA_OK. If the resource manager wants to roll back the transaction, it should do so by raising an appropriate XAException in the prepare method.
Throws:
XAException - An error has occurred. Possible exception values are: XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

recover

public Xid[] recover(int flag)
              throws XAException
Obtains a list of prepared transaction branches from a resource manager. The transaction manager calls this method during recovery to obtain the list of transaction branches that are currently in prepared or heuristically completed states.

Parameters:
flag - One of TMSTARTRSCAN, TMENDRSCAN, TMNOFLAGS. TMNOFLAGS must be used when no other flags are set in the parameter.
Returns:
The resource manager returns zero or more XIDs of the transaction branches that are currently in a prepared or heuristically completed state. If an error occurs during the operation, the resource manager should throw the appropriate XAException.
Throws:
XAException - An error has occurred. Possible values are XAER_RMERR, XAER_RMFAIL, XAER_INVAL, and XAER_PROTO.

rollback

public void rollback(Xid xid)
              throws XAException
Informs the resource manager to roll back work done on behalf of a transaction branch.

Parameters:
xid - A global transaction identifier.
Throws:
XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

If the transaction branch is already marked rollback-only the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

setTransactionTimeout

public boolean setTransactionTimeout(int seconds)
                              throws XAException

Sets the current transaction timeout value for this XAResource instance. Once set, this timeout value is effective until setTransactionTimeout is invoked again with a different value. To reset the timeout value to the default value used by the resource manager, set the value to zero. If the timeout operation is performed successfully, the method returns true; otherwise false. If a resource manager does not support explicitly setting the transaction timeout value, this method returns false.

Parameters:
seconds - The transaction timeout value in seconds.
Returns:
true if the transaction timeout value is set successfully; otherwise false.
Throws:
XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, or XAER_INVAL.

start

public void start(Xid xid,
                  int flags)
           throws XAException
Starts work on behalf of a transaction branch specified in xid. If TMJOIN is specified, the start applies to joining a transaction previously seen by the resource manager. If TMRESUME is specified, the start applies to resuming a suspended transaction specified in the parameter xid. If neither TMJOIN nor TMRESUME is specified and the transaction specified by xid has previously been seen by the resource manager, the resource manager throws the XAException exception with XAER_DUPID error code.

Parameters:
xid - A global transaction identifier to be associated with the resource.
flags - One of TMNOFLAGS, TMJOIN, or TMRESUME.
Throws:
XAException - An error has occurred. Possible exceptions are XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_DUPID, XAER_OUTSIDE, XAER_NOTA, XAER_INVAL, or XAER_PROTO.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Xid

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction.xa
Interface Xid

public interface Xid

The Xid interface is a Java mapping of the X/Open transaction identifier XID structure. This interface specifies three accessor methods to retrieve a global transaction?s format ID, global transaction ID, and branch qualifier. The Xid interface is used by the transaction manager and the resource managers. This interface is not visible to the application programs.

Field Summary
static int | MAXBQUALSIZE Maximum number of bytes returned by getBqual.
static int | MAXGTRIDSIZE Maximum number of bytes returned by getGtrid.
Method Summary
byte[] | getBranchQualifier() Obtain the transaction branch identifier part of XID as an array of bytes.
int | getFormatId() Obtain the format identifier part of the XID.
byte[] | getGlobalTransactionId() Obtain the global transaction identifier part of XID as an array of bytes.

Field Detail

MAXGTRIDSIZE

public static final int MAXGTRIDSIZE
Maximum number of bytes returned by getGtrid.

See Also:
Constant Field Values

MAXBQUALSIZE

public static final int MAXBQUALSIZE
Maximum number of bytes returned by getBqual.

See Also:
Constant Field Values
Method Detail

getFormatId

public int getFormatId()
Obtain the format identifier part of the XID.

Returns:
Format identifier. O means the OSI CCR format.

getGlobalTransactionId

public byte[] getGlobalTransactionId()
Obtain the global transaction identifier part of XID as an array of bytes.

Returns:
Global transaction identifier.

getBranchQualifier

public byte[] getBranchQualifier()
Obtain the transaction branch identifier part of XID as an array of bytes.

Returns:
Global transaction identifier.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


namespace

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.namespace

This package contains the QName class.

See:
Description

Class Summary
QName QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.

Package javax.xml.namespace Description

This package contains the QName class.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.namespace Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.namespace

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.namespace.QName (implements java.io.Serializable)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QName

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.namespace
Class QName

java.lang.Object
    extended by javax.xml.namespace.QName
All Implemented Interfaces:
Serializable
public class QName
extends Object
implements Serializable

QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.

The value of a QName contains a Namespace URI, local part and prefix.

The prefix is included in QName to retain lexical information when present in an XML input source. The prefix is NOT used in QName.equals(Object) or to compute the QName.hashCode(). Equality and the hash code are defined using only the Namespace URI and local part.

If not specified, the Namespace URI is set to "" (the empty string). If not specified, the prefix is set to "" (the empty string).

QName is immutable.

Version:
1.1
Author:
Jeff Suttor
See Also:
XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata, Serialized Form

Constructor Summary
QName(String localPart)
QName constructor specifying the local part.
QName(String namespaceURI, String localPart)
QName constructor specifying the Namespace URI and local part.
QName(String namespaceURI, String localPart, String prefix)
QName constructor specifying the Namespace URI, local part and prefix.
Method Summary
boolean | equals(Object objectToTest) Test this QName for equality with another Object.
String | getLocalPart() Get the local part of this QName.
String | getNamespaceURI() Get the Namespace URI of this QName.
String | getPrefix() Get the prefix of this QName.
int | hashCode() Generate the hash code for this QName.
String | toString() String representation of this QName.
static QName | valueOf(String qNameAsString) QName derived from parsing the formatted String.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

QName

public QName(String namespaceURI,
             String localPart)

QName constructor specifying the Namespace URI and local part.

If the Namespace URI is null, it is set to "". This value represents no explicitly defined Namespace as defined by the Namespaces in XML specification. This action preserves compatible behavior with QName 1.0.

If the local part is null, an IllegalArgumentException is thrown.

When using this constructor, the prefix is set to "".

Parameters:
namespaceURI - Namespace URI of the QName
localPart - local part of the QName
See Also:
QName(String namespaceURI, String localPart, String prefix)

QName

public QName(String namespaceURI,
             String localPart,
             String prefix)

QName constructor specifying the Namespace URI, local part and prefix.

If the Namespace URI is null, it is set to "". This value represents no explicitly defined Namespace as defined by the Namespaces in XML specification. This action preserves compatible behavior with QName 1.0.

If the local part is null, an IllegalArgumentException is thrown.

If the prefix is null, an IllegalArgumentException is thrown. Use "" to explicitly indicate that no prefix is present or the prefix is not relevant.

Parameters:
namespaceURI - Namespace URI of the QName
localPart - local part of the QName
prefix - prefix of the QName

QName

public QName(String localPart)

QName constructor specifying the local part.

If the local part is null or .equals(""), an IllegalArgumentException is thrown.

When using this constructor, the Namespace URI is set to "" and the prefix is set to "".

In an XML context, all Element and Attribute names exist in the context of a Namespace. Making this explicit during the construction of a QName helps to prevent hard to diagnosis XML validity errors. The constructors QName(String namespaceURI, String localPart) and QName(String namespaceURI, String localPart, String prefix) are preferred.

Parameters:
localPart - local part of the QName
See Also:
QName(String namespaceURI, String localPart), QName(String namespaceURI, String localPart, String prefix)
Method Detail

getNamespaceURI

public String getNamespaceURI()

Get the Namespace URI of this QName.

Returns:
Namespace URI of this QName

getLocalPart

public String getLocalPart()

Get the local part of this QName.

Returns:
local part of this QName

getPrefix

public String getPrefix()

Get the prefix of this QName.

The prefix assigned to a QName may NOT be valid in a different context. For example, a QName may be assigned a prefix in the context of parsing a document but that prefix may be invalid in the context of a different document.

Returns:
prefix of this QName

equals

public boolean equals(Object objectToTest)

Test this QName for equality with another Object.

If the Object to be tested is not a QName or is null, then this method returns false.

Two QNames are considered equal if and only if both the Namespace URI and local part are equal. This method uses String.equals() to check equality of the Namespace URI and local part. The prefix is NOT used to determine equality.

This method satisfies the general contract of Object.equals(Object)

Parameters:
objectToTest - the Object to test for equality with this QName
Returns:
true if the given Object is equal to this QName else false

hashCode

public int hashCode()

Generate the hash code for this QName.

The hash code is calculated using both the Namespace URI and the local part of the QName. The prefix is NOT used to calculate the hash code.

This method satisfies the general contract of Object.hashCode().

Returns:
hash code for this QName Object

toString

public String toString()

String representation of this QName.

There is NO standard specification for representing a QName as a String. The returned String is not portable across implementations and will change when a standard String representation is defined. This implementation currently represents a QName as: "{" + Namespace URI + "}" + local part. If the Namespace URI .equals(""), only the local part is returned. An appropriate use of this method is for debugging or logging for human consumption.

Note the prefix value is NOT returned as part of the String representation.

This method satisfies the general contract of Object.toString().

Returns:
String representation of this QName

valueOf

public static QName valueOf(String qNameAsString)

QName derived from parsing the formatted String.

If the String is null or does not conform to QName.toString() formatting, an IllegalArgumentException is thrown.

The String MUST be in the form returned by QName.toString(). There is NO standard specification for representing a QName as a String. The String format is NOT portable across implementations and will change when a standard String representation is defined. This implementation currently parses a String formatted as: "{" + Namespace URI + "}" + local part. If the Namespace URI .equals(""), only the local part should be provided.

The prefix value CANNOT be represented in the String and will be set to ""

This method does not do full validation of the resulting QName. In particular, the local part is not validated as a NCName as specified in Namespaces in XML.

Parameters:
qNameAsString - String representation of the QName
Returns:
QName corresponding to the given String
See Also:
QName.toString()
Overview  Package   Class  Tree  Deprecated  Index  Help
JavaTM 2 Platform
Ent. Ed. v1.4
 PREV CLASS   NEXT CLASS | FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


parsers

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.parsers

Provides classes allowing the processing of XML documents.

See:
Description

Class Summary
DocumentBuilder | Defines the API to obtain DOM Document instances from an XML document.
DocumentBuilderFactory | Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
SAXParser | Defines the API that wraps an XMLReader implementation class.
SAXParserFactory | Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.

Exception Summary
ParserConfigurationException Indicates a serious configuration error.

Error Summary
FactoryConfigurationError Thrown when a problem with configuration with the Parser Factories exists.

Package javax.xml.parsers Description

Provides classes allowing the processing of XML documents. Two types of plugable parsers are supported:

  • SAX (Simple API for XML)
  • DOM (Document Object Model)

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.parsers Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.parsers

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.parsers.DocumentBuilder
    • class javax.xml.parsers.DocumentBuilderFactory
    • class javax.xml.parsers.SAXParser
    • class javax.xml.parsers.SAXParserFactory
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Error
        • class javax.xml.parsers.FactoryConfigurationError
      • class java.lang.Exception
        • class javax.xml.parsers.ParserConfigurationException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DocumentBuilder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.parsers
Class DocumentBuilder

java.lang.Object
    extended by javax.xml.parsers.DocumentBuilder
public abstract class DocumentBuilder
extends Object

Defines the API to obtain DOM Document instances from an XML document. Using this class, an application programmer can obtain a Document from XML.

An instance of this class can be obtained from the DocumentBuilderFactory.newDocumentBuilder method. Once an instance of this class is obtained, XML can be parsed from a variety of input sources. These input sources are InputStreams, Files, URLs, and SAX InputSources.

Note that this class reuses several classes from the SAX API. This does not require that the implementor of the underlying DOM implementation use a SAX parser to parse XML document into a Document. It merely requires that the implementation communicate with the application using these existing APIs.

An implementation of DocumentBuilder is NOT guaranteed to behave as per the specification if it is used concurrently by two or more threads. It is recommended to have one instance of the DocumentBuilder per thread or it is upto the application to make sure about the use of DocumentBuilder from more than one thread.

Since:
JAXP 1.0
Version:
1.0

Constructor Summary
protected DocumentBuilder()
Method Summary
abstract DOMImplementation | getDOMImplementation() Obtain an instance of a DOMImplementation object.
abstract boolean | isNamespaceAware() Indicates whether or not this parser is configured to understand namespaces.
abstract boolean | isValidating() Indicates whether or not this parser is configured to validate XML documents.
abstract Document | newDocument() Obtain a new instance of a DOM Document object to build a DOM tree with.
Document | parse(File f) Parse the content of the given file as an XML document and return a new DOM Document object.
abstract Document | parse(InputSource is) Parse the content of the given input source as an XML document and return a new DOM Document object.
Document | parse(InputStream is) Parse the content of the given InputStream as an XML document and return a new DOM Document object.
Document | parse(InputStream is, String systemId) Parse the content of the given InputStream as an XML document and return a new DOM Document object.
Document | parse(String uri) Parse the content of the given URI as an XML document and return a new DOM Document object.
abstract void | setEntityResolver(EntityResolver er) Specify the EntityResolver to be used to resolve entities present in the XML document to be parsed.
abstract void | setErrorHandler(ErrorHandler eh) Specify the ErrorHandler to be used to report errors present in the XML document to be parsed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DocumentBuilder

protected DocumentBuilder()
Method Detail

parse

public Document parse(InputStream is)
               throws SAXException,
                      IOException
Parse the content of the given InputStream as an XML document and return a new DOM Document object.

Parameters:
is - InputStream containing the content to be parsed.
Throws:
IOException - If any IO errors occur.
SAXException - If any parse errors occur.
IllegalArgumentException - If the InputStream is null
See Also:
DocumentHandler

parse

public Document parse(InputStream is,
                      String systemId)
               throws SAXException,
                      IOException
Parse the content of the given InputStream as an XML document and return a new DOM Document object.

Parameters:
is - InputStream containing the content to be parsed.
systemId - Provide a base for resolving relative URIs.
Returns:
A new DOM Document object.
Throws:
IOException - If any IO errors occur.
SAXException - If any parse errors occur.
IllegalArgumentException - If the InputStream is null.
See Also:
DocumentHandler

parse

public Document parse(String uri)
               throws SAXException,
                      IOException
Parse the content of the given URI as an XML document and return a new DOM Document object.

Parameters:
uri - The location of the content to be parsed.
Returns:
A new DOM Document object.
Throws:
IOException - If any IO errors occur.
SAXException - If any parse errors occur.
IllegalArgumentException - If the URI is null.
See Also:
DocumentHandler

parse

public Document parse(File f)
               throws SAXException,
                      IOException
Parse the content of the given file as an XML document and return a new DOM Document object.

Parameters:
f - The file containing the XML to parse.
Returns:
A new DOM Document object.
Throws:
IOException - If any IO errors occur.
SAXException - If any parse errors occur.
IllegalArgumentException - If the file is null.
See Also:
DocumentHandler

parse

public abstract Document parse(InputSource is)
                        throws SAXException,
                               IOException
Parse the content of the given input source as an XML document and return a new DOM Document object.

Parameters:
is - InputSource containing the content to be parsed.
Returns:
A new DOM Document object.
Throws:
IOException - If any IO errors occur.
SAXException - If any parse errors occur.
IllegalArgumentException - If the InputSource is null.
See Also:
DocumentHandler

isNamespaceAware

public abstract boolean isNamespaceAware()
Indicates whether or not this parser is configured to understand namespaces.

Returns:
true if this parser is configured to understand namespaces; false otherwise.

isValidating

public abstract boolean isValidating()
Indicates whether or not this parser is configured to validate XML documents.

Returns:
true if this parser is configured to validate XML documents; false otherwise.

setEntityResolver

public abstract void setEntityResolver(EntityResolver er)
Specify the EntityResolver to be used to resolve entities present in the XML document to be parsed. Setting this to null will result in the underlying implementation using it's own default implementation and behavior.

Parameters:
er - The EntityResolver to be used to resolve entities present in the XML document to be parsed.

setErrorHandler

public abstract void setErrorHandler(ErrorHandler eh)
Specify the ErrorHandler to be used to report errors present in the XML document to be parsed. Setting this to null will result in the underlying implementation using it's own default implementation and behavior.

Parameters:
eh - The ErrorHandler to be used to report errors present in the XML document to be parsed.

newDocument

public abstract Document newDocument()
Obtain a new instance of a DOM Document object to build a DOM tree with. An alternative way to create a DOM Document object is to use the getDOMImplementation method to get a DOM Level 2 DOMImplementation object and then use DOM Level 2 methods on that object to create a DOM Document object.

Returns:
A new instance of a DOM Document object.

getDOMImplementation

public abstract DOMImplementation getDOMImplementation()
Obtain an instance of a DOMImplementation object.

Returns:
A new instance of a DOMImplementation.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DocumentBuilderFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.parsers
Class DocumentBuilderFactory

java.lang.Object
    extended by javax.xml.parsers.DocumentBuilderFactory
public abstract class DocumentBuilderFactory
extends Object

Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents. An implementation of the DocumentBuilderFactory class is NOT guaranteed to be thread safe. It is up to the user application to make sure about the use of the DocumentBuilderFactory from more than one thread. Alternatively the application can have one instance of the DocumentBuilderFactory per thread. An application can use the same instance of the factory to obtain one or more instances of the DocumentBuilder provided the instance of the factory isn't being used in more than one thread at a time.

Since:
JAXP 1.0
Version:
1.0

Constructor Summary
protected DocumentBuilderFactory()
Method Summary
abstract Object | getAttribute(String name) Allows the user to retrieve specific attributes on the underlying implementation.
boolean | isCoalescing() Indicates whether or not the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node.
boolean | isExpandEntityReferences() Indicates whether or not the factory is configured to produce parsers which expand entity reference nodes.
boolean | isIgnoringComments() Indicates whether or not the factory is configured to produce parsers which ignores comments.
boolean | isIgnoringElementContentWhitespace() Indicates whether or not the factory is configured to produce parsers which ignore ignorable whitespace in element content.
boolean | isNamespaceAware() Indicates whether or not the factory is configured to produce parsers which are namespace aware.
boolean | isValidating() Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
abstract DocumentBuilder | newDocumentBuilder() Creates a new instance of a DocumentBuilder using the currently configured parameters.
static DocumentBuilderFactory | newInstance() Obtain a new instance of a DocumentBuilderFactory.
abstract void | setAttribute(String name, Object value) Allows the user to set specific attributes on the underlying implementation.
void | setCoalescing(boolean coalescing) Specifies that the parser produced by this code will convert CDATA nodes to Text nodes and append it to the adjacent (if any) text node.
void | setExpandEntityReferences(boolean expandEntityRef) Specifies that the parser produced by this code will expand entity reference nodes.
void | setIgnoringComments(boolean ignoreComments) Specifies that the parser produced by this code will ignore comments.
void | setIgnoringElementContentWhitespace(boolean whitespace) Specifies that the parsers created by this factory must eliminate whitespace in element content (sometimes known loosely as 'ignorable whitespace') when parsing XML documents (see XML Rec 2.10).
void | setNamespaceAware(boolean awareness) Specifies that the parser produced by this code will provide support for XML namespaces.
void | setValidating(boolean validating) Specifies that the parser produced by this code will validate documents as they are parsed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DocumentBuilderFactory

protected DocumentBuilderFactory()
Method Detail

newInstance

public static DocumentBuilderFactory newInstance()
                                          throws FactoryConfigurationError
Obtain a new instance of a DocumentBuilderFactory. This static method creates a new factory instance. This method uses the following ordered lookup procedure to determine the DocumentBuilderFactory implementation class to load:
  • Use the javax.xml.parsers.DocumentBuilderFactory system property.
  • Use the properties file "lib/jaxp.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
  • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.parsers.DocumentBuilderFactory in jars available to the runtime.
  • Platform default DocumentBuilderFactory instance.
Once an application has obtained a reference to a DocumentBuilderFactory it can use the factory to configure and obtain parser instances.

Throws:
FactoryConfigurationError - if the implementation is not available or cannot be instantiated.

newDocumentBuilder

public abstract DocumentBuilder newDocumentBuilder()
                                            throws ParserConfigurationException
Creates a new instance of a DocumentBuilder using the currently configured parameters.

Returns:
A new instance of a DocumentBuilder.
Throws:
ParserConfigurationException - if a DocumentBuilder cannot be created which satisfies the configuration requested.

setNamespaceAware

public void setNamespaceAware(boolean awareness)
Specifies that the parser produced by this code will provide support for XML namespaces. By default the value of this is set to false

Parameters:
awareness - true if the parser produced will provide support for XML namespaces; false otherwise.

setValidating

public void setValidating(boolean validating)
Specifies that the parser produced by this code will validate documents as they are parsed. By default the value of this is set to false.

Parameters:
validating - true if the parser produced will validate documents as they are parsed; false otherwise.

setIgnoringElementContentWhitespace

public void setIgnoringElementContentWhitespace(boolean whitespace)
Specifies that the parsers created by this factory must eliminate whitespace in element content (sometimes known loosely as 'ignorable whitespace') when parsing XML documents (see XML Rec 2.10). Note that only whitespace which is directly contained within element content that has an element only content model (see XML Rec 3.2.1) will be eliminated. Due to reliance on the content model this setting requires the parser to be in validating mode. By default the value of this is set to false.

Parameters:
whitespace - true if the parser created must eliminate whitespace in the element content when parsing XML documents; false otherwise.

setExpandEntityReferences

public void setExpandEntityReferences(boolean expandEntityRef)
Specifies that the parser produced by this code will expand entity reference nodes. By default the value of this is set to true

Parameters:
expandEntityRef - true if the parser produced will expand entity reference nodes; false otherwise.

setIgnoringComments

public void setIgnoringComments(boolean ignoreComments)
Specifies that the parser produced by this code will ignore comments. By default the value of this is set to false

setCoalescing

public void setCoalescing(boolean coalescing)
Specifies that the parser produced by this code will convert CDATA nodes to Text nodes and append it to the adjacent (if any) text node. By default the value of this is set to false

Parameters:
coalescing - true if the parser produced will convert CDATA nodes to Text nodes and append it to the adjacent (if any) text node; false otherwise.

isNamespaceAware

public boolean isNamespaceAware()
Indicates whether or not the factory is configured to produce parsers which are namespace aware.

Returns:
true if the factory is configured to produce parsers which are namespace aware; false otherwise.

isValidating

public boolean isValidating()
Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.

Returns:
true if the factory is configured to produce parsers which validate the XML content during parse; false otherwise.

isIgnoringElementContentWhitespace

public boolean isIgnoringElementContentWhitespace()
Indicates whether or not the factory is configured to produce parsers which ignore ignorable whitespace in element content.

Returns:
true if the factory is configured to produce parsers which ignore ignorable whitespace in element content; false otherwise.

isExpandEntityReferences

public boolean isExpandEntityReferences()
Indicates whether or not the factory is configured to produce parsers which expand entity reference nodes.

Returns:
true if the factory is configured to produce parsers which expand entity reference nodes; false otherwise.

isIgnoringComments

public boolean isIgnoringComments()
Indicates whether or not the factory is configured to produce parsers which ignores comments.

Returns:
true if the factory is configured to produce parsers which ignores comments; false otherwise.

isCoalescing

public boolean isCoalescing()
Indicates whether or not the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node.

Returns:
true if the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node; false otherwise.

setAttribute

public abstract void setAttribute(String name,
                                  Object value)
                           throws IllegalArgumentException
Allows the user to set specific attributes on the underlying implementation.

Parameters:
name - The name of the attribute.
value - The value of the attribute.
Throws:
IllegalArgumentException - thrown if the underlying implementation doesn't recognize the attribute.

getAttribute

public abstract Object getAttribute(String name)
                             throws IllegalArgumentException
Allows the user to retrieve specific attributes on the underlying implementation.

Parameters:
name - The name of the attribute.
Returns:
value The value of the attribute.
Throws:
IllegalArgumentException - thrown if the underlying implementation doesn't recognize the attribute.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FactoryConfigurationError

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.parsers
Class FactoryConfigurationError

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Error
            extended by javax.xml.parsers.FactoryConfigurationError
All Implemented Interfaces:
Serializable
public class FactoryConfigurationError
extends Error

Thrown when a problem with configuration with the Parser Factories exists. This error will typically be thrown when the class of a parser factory specified in the system properties cannot be found or instantiated.

Since:
JAXP 1.0
Version:
1.0
See Also:
Serialized Form

Constructor Summary
FactoryConfigurationError()
Create a new FactoryConfigurationError with no detail mesage.
FactoryConfigurationError(Exception e)
Create a new FactoryConfigurationError with a given Exception base cause of the error.
FactoryConfigurationError(Exception e, String msg)
Create a new FactoryConfigurationError with the given Exception base cause and detail message.
FactoryConfigurationError(String msg)
Create a new FactoryConfigurationError with the String specified as an error message.
Method Summary
Exception | getException() Return the actual exception (if any) that caused this exception to be raised.
String | getMessage() Return the message (if any) for this error .
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FactoryConfigurationError

public FactoryConfigurationError()
Create a new FactoryConfigurationError with no detail mesage.

FactoryConfigurationError

public FactoryConfigurationError(String msg)
Create a new FactoryConfigurationError with the String specified as an error message.

Parameters:
msg - The error message for the exception.

FactoryConfigurationError

public FactoryConfigurationError(Exception e)
Create a new FactoryConfigurationError with a given Exception base cause of the error.

Parameters:
e - The exception to be encapsulated in a FactoryConfigurationError.

FactoryConfigurationError

public FactoryConfigurationError(Exception e,
                                 String msg)
Create a new FactoryConfigurationError with the given Exception base cause and detail message.

Parameters:
e - The exception to be encapsulated in a FactoryConfigurationError
msg - The detail message.
Method Detail

getMessage

public String getMessage()
Return the message (if any) for this error . If there is no message for the exception and there is an encapsulated exception then the message of that exception, if it exists will be returned. Else the name of the encapsulated exception will be returned.

Returns:
The error message.

getException

public Exception getException()
Return the actual exception (if any) that caused this exception to be raised.

Returns:
The encapsulated exception, or null if there is none.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ParserConfigurationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.parsers
Class ParserConfigurationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.parsers.ParserConfigurationException
All Implemented Interfaces:
Serializable
public class ParserConfigurationException
extends Exception

Indicates a serious configuration error.

Since:
JAXP 1.0
Version:
1.0
See Also:
Serialized Form

Constructor Summary
ParserConfigurationException()
Create a new ParserConfigurationException with no detail mesage.
ParserConfigurationException(String msg)
Create a new ParserConfigurationException with the String specified as an error message.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ParserConfigurationException

public ParserConfigurationException()
Create a new ParserConfigurationException with no detail mesage.

ParserConfigurationException

public ParserConfigurationException(String msg)
Create a new ParserConfigurationException with the String specified as an error message.

Parameters:
msg - The error message for the exception.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SAXParser

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.parsers
Class SAXParser

java.lang.Object
    extended by javax.xml.parsers.SAXParser
public abstract class SAXParser
extends Object

Defines the API that wraps an XMLReader implementation class. In JAXP 1.0, this class wrapped the Parser interface, however this interface was replaced by the XMLReader. For ease of transition, this class continues to support the same name and interface as well as supporting new methods. An instance of this class can be obtained from the SAXParserFactory.newSAXParser() method. Once an instance of this class is obtained, XML can be parsed from a variety of input sources. These input sources are InputStreams, Files, URLs, and SAX InputSources.

As the content is parsed by the underlying parser, methods of the given HandlerBase or the DefaultHandler are called.

Implementors of this class which wrap an underlying implementation can consider using the ParserAdapter class to initially adapt their SAX1 impelemntation to work under this revised class.

An implementation of SAXParser is NOT guaranteed to behave as per the specification if it is used concurrently by two or more threads. It is recommended to have one instance of the SAXParser per thread or it is upto the application to make sure about the use of SAXParser from more than one thread.

Since:
JAXP 1.0
Version:
1.0

Constructor Summary
protected SAXParser()
Method Summary
abstract Parser | getParser() Returns the SAX parser that is encapsultated by the implementation of this class.
abstract Object | getProperty(String name) Returns the particular property requested for in the underlying implementation of XMLReader.
abstract XMLReader | getXMLReader() Returns the XMLReader that is encapsulated by the implementation of this class.
abstract boolean | isNamespaceAware() Indicates whether or not this parser is configured to understand namespaces.
abstract boolean | isValidating() Indicates whether or not this parser is configured to validate XML documents.
void | parse(File f, DefaultHandler dh) Parse the content of the file specified as XML using the specified DefaultHandler.
void | parse(File f, HandlerBase hb) Parse the content of the file specified as XML using the specified HandlerBase.
void | parse(InputSource is, DefaultHandler dh) Parse the content given InputSource as XML using the specified DefaultHandler.
void | parse(InputSource is, HandlerBase hb) Parse the content given InputSource as XML using the specified HandlerBase.
void | parse(InputStream is, DefaultHandler dh) Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
void | parse(InputStream is, DefaultHandler dh, String systemId) Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
void | parse(InputStream is, HandlerBase hb) Parse the content of the given InputStream instance as XML using the specified HandlerBase.
void | parse(InputStream is, HandlerBase hb, String systemId) Parse the content of the given InputStream instance as XML using the specified HandlerBase.
void | parse(String uri, DefaultHandler dh) Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.
void | parse(String uri, HandlerBase hb) Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase.
abstract void | setProperty(String name, Object value) Sets the particular property in the underlying implementation of XMLReader.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SAXParser

protected SAXParser()
Method Detail

parse

public void parse(InputStream is,
                  HandlerBase hb)
           throws SAXException,
                  IOException
Parse the content of the given InputStream instance as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0

Parameters:
is - InputStream containing the content to be parsed.
hb - The SAX HandlerBase to use.
Throws:
IOException - If any IO errors occur.
IllegalArgumentException - If the given InputStream is null.
SAXException - If the underlying parser throws a SAXException while parsing.
See Also:
DocumentHandler

parse

public void parse(InputStream is,
                  HandlerBase hb,
                  String systemId)
           throws SAXException,
                  IOException
Parse the content of the given InputStream instance as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0

Parameters:
is - InputStream containing the content to be parsed.
hb - The SAX HandlerBase to use.
systemId - The systemId which is needed for resolving relative URIs.
Throws:
IOException - If any IO errors occur.
IllegalArgumentException - If the given InputStream is null.
SAXException - If the underlying parser throws a SAXException while parsing.
See Also:
version of this method instead.

parse

public void parse(InputStream is,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
Parse the content of the given InputStream instance as XML using the specified DefaultHandler.

Parameters:
is - InputStream containing the content to be parsed.
dh - The SAX DefaultHandler to use.
Throws:
IOException - If any IO errors occur.
IllegalArgumentException - If the given InputStream is null.
SAXException - If the underlying parser throws a SAXException while parsing.
See Also:
DocumentHandler

parse

public void parse(InputStream is,
                  DefaultHandler dh,
                  String systemId)
           throws SAXException,
                  IOException
Parse the content of the given InputStream instance as XML using the specified DefaultHandler.

Parameters:
is - InputStream containing the content to be parsed.
dh - The SAX DefaultHandler to use.
systemId - The systemId which is needed for resolving relative URIs.
Throws:
IOException - If any IO errors occur.
IllegalArgumentException - If the given InputStream is null.
SAXException - If the underlying parser throws a SAXException while parsing.
See Also:
version of this method instead.

parse

public void parse(String uri,
                  HandlerBase hb)
           throws SAXException,
                  IOException
Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0

Parameters:
uri - The location of the content to be parsed.
hb - The SAX HandlerBase to use.
Throws:
IOException - If any IO errors occur.
IllegalArgumentException - If the uri is null.
SAXException - If the underlying parser throws a SAXException while parsing.
See Also:
DocumentHandler

parse

public void parse(String uri,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.

Parameters:
uri - The location of the content to be parsed.
dh - The SAX DefaultHandler to use.
Throws:
IOException - If any IO errors occur.
IllegalArgumentException - If the uri is null.
SAXException - If the underlying parser throws a SAXException while parsing.
See Also:
DocumentHandler

parse

public void parse(File f,
                  HandlerBase hb)
           throws SAXException,
                  IOException
Parse the content of the file specified as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0

Parameters:
f - The file containing the XML to parse
hb - The SAX HandlerBase to use.
Throws:
IOException - If any IO errors occur.
IllegalArgumentException - If the File object is null.
SAXException - If the underlying parser throws a SAXException while parsing.
See Also:
DocumentHandler

parse

public void parse(File f,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
Parse the content of the file specified as XML using the specified DefaultHandler.

Parameters:
f - The file containing the XML to parse
dh - The SAX DefaultHandler to use.
Throws:
IOException - If any IO errors occur.
IllegalArgumentException - If the File object is null.
SAXException - If the underlying parser throws a SAXException while parsing.
See Also:
DocumentHandler

parse

public void parse(InputSource is,
                  HandlerBase hb)
           throws SAXException,
                  IOException
Parse the content given InputSource as XML using the specified HandlerBase. Use of the DefaultHandler version of this method is recommended as the HandlerBase class has been deprecated in SAX 2.0

Parameters:
is - The InputSource containing the content to be parsed.
hb - The SAX HandlerBase to use.
Throws:
IOException - If any IO errors occur.
IllegalArgumentException - If the InputSource is null.
SAXException - If the underlying parser throws a SAXException while parsing.
See Also:
DocumentHandler

parse

public void parse(InputSource is,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
Parse the content given InputSource as XML using the specified DefaultHandler.

Parameters:
is - The InputSource containing the content to be parsed.
dh - The SAX DefaultHandler to use.
Throws:
IOException - If any IO errors occur.
IllegalArgumentException - If the InputSource is null.
SAXException - If the underlying parser throws a SAXException while parsing.
See Also:
DocumentHandler

getParser

public abstract Parser getParser()
                          throws SAXException
Returns the SAX parser that is encapsultated by the implementation of this class.

Returns:
The SAX parser that is encapsultated by the implementation of this class.
Throws:
SAXException

getXMLReader

public abstract XMLReader getXMLReader()
                                throws SAXException
Returns the XMLReader that is encapsulated by the implementation of this class.

Returns:
The XMLReader that is encapsulated by the implementation of this class.
Throws:
SAXException

isNamespaceAware

public abstract boolean isNamespaceAware()
Indicates whether or not this parser is configured to understand namespaces.

Returns:
true if this parser is configured to understand namespaces; false otherwise.

isValidating

public abstract boolean isValidating()
Indicates whether or not this parser is configured to validate XML documents.

Returns:
true if this parser is configured to validate XML documents; false otherwise.

setProperty

public abstract void setProperty(String name,
                                 Object value)
                          throws SAXNotRecognizedException,
                                 SAXNotSupportedException
Sets the particular property in the underlying implementation of XMLReader. A list of the core features and properties can be found at http://www.megginson.com/SAX/Java/features.html

Parameters:
name - The name of the property to be set.
value - The value of the property to be set.
Throws:
SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
See Also:
XMLReader.setProperty(java.lang.String, java.lang.Object)

getProperty

public abstract Object getProperty(String name)
                            throws SAXNotRecognizedException,
                                   SAXNotSupportedException
Returns the particular property requested for in the underlying implementation of XMLReader.

Parameters:
name - The name of the property to be retrieved.
Returns:
Value of the requested property.
Throws:
SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
See Also:
XMLReader.getProperty(java.lang.String)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SAXParserFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.parsers
Class SAXParserFactory

java.lang.Object
    extended by javax.xml.parsers.SAXParserFactory
public abstract class SAXParserFactory
extends Object

Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.

An implementation of the SAXParserFactory class is NOT guaranteed to be thread safe. It is up to the user application to make sure about the use of the SAXParserFactory from more than one thread. Alternatively the application can have one instance of the SAXParserFactory per thread. An application can use the same instance of the factory to obtain one or more instances of the SAXParser provided the instance of the factory isn't being used in more than one thread at a time.

The static newInstance method returns a new concrete implementation of this class.

Since:
JAXP 1.0
Version:
1.0

Constructor Summary
protected SAXParserFactory()
Method Summary
abstract boolean | getFeature(String name) Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
boolean | isNamespaceAware() Indicates whether or not the factory is configured to produce parsers which are namespace aware.
boolean | isValidating() Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
static SAXParserFactory | newInstance() Obtain a new instance of a SAXParserFactory.
abstract SAXParser | newSAXParser() Creates a new instance of a SAXParser using the currently configured factory parameters.
abstract void | setFeature(String name, boolean value) Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
void | setNamespaceAware(boolean awareness) Specifies that the parser produced by this code will provide support for XML namespaces.
void | setValidating(boolean validating) Specifies that the parser produced by this code will validate documents as they are parsed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SAXParserFactory

protected SAXParserFactory()
Method Detail

newInstance

public static SAXParserFactory newInstance()
                                    throws FactoryConfigurationError
Obtain a new instance of a SAXParserFactory. This static method creates a new factory instance This method uses the following ordered lookup procedure to determine the SAXParserFactory implementation class to load:
  • Use the javax.xml.parsers.SAXParserFactory system property.
  • Use the properties file "lib/jaxp.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
  • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.parsers.SAXParserFactory in jars available to the runtime.
  • Platform default SAXParserFactory instance.
Once an application has obtained a reference to a SAXParserFactory it can use the factory to configure and obtain parser instances.

Returns:
A new instance of a SAXParserFactory.
Throws:
FactoryConfigurationError - if the implementation is not available or cannot be instantiated.

newSAXParser

public abstract SAXParser newSAXParser()
                                throws ParserConfigurationException,
                                       SAXException
Creates a new instance of a SAXParser using the currently configured factory parameters.

Returns:
A new instance of a SAXParser.
Throws:
ParserConfigurationException - if a parser cannot be created which satisfies the requested configuration.
SAXException

setNamespaceAware

public void setNamespaceAware(boolean awareness)
Specifies that the parser produced by this code will provide support for XML namespaces. By default the value of this is set to false.

Parameters:
awareness - true if the parser produced by this code will provide support for XML namespaces; false otherwise.

setValidating

public void setValidating(boolean validating)
Specifies that the parser produced by this code will validate documents as they are parsed. By default the value of this is set to false.

Parameters:
validating - true if the parser produced by this code will validate documents as they are parsed; false otherwise.

isNamespaceAware

public boolean isNamespaceAware()
Indicates whether or not the factory is configured to produce parsers which are namespace aware.

Returns:
true if the factory is configured to produce parsers which are namespace aware; false otherwise.

isValidating

public boolean isValidating()
Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.

Returns:
true if the factory is configured to produce parsers which validate the XML content during parse; false otherwise.

setFeature

public abstract void setFeature(String name,
                                boolean value)
                         throws ParserConfigurationException,
                                SAXNotRecognizedException,
                                SAXNotSupportedException
Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader. A list of the core features and properties can be found at http://www.megginson.com/SAX/Java/features.html

Parameters:
name - The name of the feature to be set.
value - The value of the feature to be set.
Throws:
SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
ParserConfigurationException
See Also:
XMLReader.setFeature(java.lang.String, boolean)

getFeature

public abstract boolean getFeature(String name)
                            throws ParserConfigurationException,
                                   SAXNotRecognizedException,
                                   SAXNotSupportedException
Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.

Parameters:
name - The name of the property to be retrieved.
Returns:
Value of the requested property.
Throws:
SAXNotRecognizedException - When the underlying XMLReader does not recognize the property name.
SAXNotSupportedException - When the underlying XMLReader recognizes the property name but doesn't support the property.
ParserConfigurationException
See Also:
XMLReader.getProperty(java.lang.String)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


registry

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.registry

This package and its sub-packages describe the API classes and interfaces for the JAXR API.

See:
Description

Interface Summary
BulkResponse | Contains the response of a method in the API that performs a bulk operation and returns a bulk response.
BusinessLifeCycleManager | The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API.
BusinessQueryManager | The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface.
CapabilityProfile | Provides information about the capabilities of a JAXR provider.
Connection | This class represents a connection between a JAXR client and a JAXR provider.
DeclarativeQueryManager | This interface provides the ability to execute declarative queries (e.g.
FederatedConnection | Represents a single logical connection to a federation or group of registry providers.
FindQualifier | FindQualifier provides various constants that identify options that effect find method behavior.
JAXRResponse | A JAXR requests' response.
LifeCycleManager | The LifeCycleManager interface is the main interface in the API for managing life cycle operations on objects defined by the information model.
Query | The Query interface encapsulates a query in a declarative query language.
QueryManager | This is the common base interface for all QueryManagers in the API.
RegistryService | This is the principal interface implemented by a JAXR provider.

Class Summary
ConnectionFactory This is the abstract base class for factory classes for creating a JAXR connection.

Exception Summary
DeleteException | A RegistryException that occurs during a delete action.
FindException | A RegistryException that occurs during a find action.
InvalidRequestException | This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.
JAXRException | Signals that a JAXR exception has occurred.
RegistryException | This is the common base class for all Exceptions that are detected on the registry provider side rather than the JAXR client side.
SaveException | A RegistryException that occurs during a save action.
UnexpectedObjectException | This exception is thrown when the JAXR provider finds a Object that is out-of-place or of the wrong type within the context of a user request.
UnsupportedCapabilityException | This exception must be thrown when a JAXR client attempts to invoke an API method that is not supported by the capability profile that is supported by the JAXR provider.

Package javax.xml.registry Description

This package and its sub-packages describe the API classes and interfaces for the JAXR API. In this package are the high-level interfaces and classes that a client uses to interact with a registry via a JAXR provider.

Figure 1 shows the primary interfaces in the JAXR API.

Primary Interfaces in the JAXR API
Figure 1. Primary Interfaces in the JAXR API

Figure 2 shows the response and exception classes in the JAXR API.

Response and Exception Classes in the JAXR API
Figure 2. Response and Exception Classes in the JAXR API

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FederatedConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface FederatedConnection

All Superinterfaces:
Connection
public interface FederatedConnection
extends Connection

Represents a single logical connection to a federation or group of registry providers. This interface is used in support of the distributed query feature of the JAXR API.

Author:
Farrukh S. Najmi

Methods inherited from interface javax.xml.registry.Connection
close, getCredentials, getRegistryService, isClosed, isSynchronous, setCredentials, setSynchronous

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.registry Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.registry

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.registry.ConnectionFactory
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.xml.registry.JAXRException (implements javax.xml.registry.JAXRResponse)
          • class javax.xml.registry.InvalidRequestException
          • class javax.xml.registry.RegistryException
            • class javax.xml.registry.DeleteException
            • class javax.xml.registry.FindException
            • class javax.xml.registry.SaveException
          • class javax.xml.registry.UnexpectedObjectException
          • class javax.xml.registry.UnsupportedCapabilityException

Interface Hierarchy

  • interface javax.xml.registry.CapabilityProfile
  • interface javax.xml.registry.Connection
    • interface javax.xml.registry.FederatedConnection
  • interface javax.xml.registry.FindQualifier
  • interface javax.xml.registry.JAXRResponse
    • interface javax.xml.registry.BulkResponse
  • interface javax.xml.registry.LifeCycleManager
    • interface javax.xml.registry.BusinessLifeCycleManager
  • interface javax.xml.registry.Query
  • interface javax.xml.registry.QueryManager
    • interface javax.xml.registry.BusinessQueryManager
    • interface javax.xml.registry.DeclarativeQueryManager
  • interface javax.xml.registry.RegistryService
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BulkResponse

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface BulkResponse

All Superinterfaces:
JAXRResponse
public interface BulkResponse
extends JAXRResponse

Contains the response of a method in the API that performs a bulk operation and returns a bulk response. Partial commits are allowed on a bulk operation.

In the event of a partial success where only a subset of objects were processed successfully, the getStatus method of the BulkResponse must return JAXRResponse.STATUS_WARNING. In this case, a Collection of JAXRException instances is included in the BulkResponse instance. The JAXRExceptions provide information on each error that prevented some objects in the request to not be processed successfully.

Author:
Farrukh S. Najmi
See Also:
QueryManager, LifeCycleManager

Field Summary
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Method Summary
Collection | getCollection() Get the Collection of objects returned as a response of a bulk operation.
Collection | getExceptions() Get the Collection of RegistryException instances in case of partial commit.
boolean | isPartialResponse() Determines whether the response is a partial response due to large result set.
Methods inherited from interface javax.xml.registry.JAXRResponse
getRequestId, getStatus, isAvailable

Method Detail

getCollection

public Collection getCollection()
                         throws JAXRException
Get the Collection of objects returned as a response of a bulk operation. Caller thread will block here if result is not yet available.

Capability Level: 0

Returns:
Collection of RegistryObject instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryObject

getExceptions

public Collection getExceptions()
                         throws JAXRException
Get the Collection of RegistryException instances in case of partial commit. Caller thread will block here if result is not yet available.

Capability Level: 0

Returns:
Collection of RegistryException instances. Return null if result is available and there is no RegistryException.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryException

isPartialResponse

public boolean isPartialResponse()
                          throws JAXRException
Determines whether the response is a partial response due to large result set.

Capability Level: 0

Returns:
true if the response is partial; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BusinessLifeCycleManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface BusinessLifeCycleManager

All Superinterfaces:
LifeCycleManager
public interface BusinessLifeCycleManager
extends LifeCycleManager

The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API. Note that there is no authentication information provided, because the Connection interface keeps that state and context on behalf of the client.

Author:
Farrukh S. Najmi
See Also:
LifeCycleManager

Field Summary
Fields inherited from interface javax.xml.registry.LifeCycleManager
ASSOCIATION, AUDITABLE_EVENT, CLASSIFICATION, CLASSIFICATION_SCHEME, CONCEPT, EMAIL_ADDRESS, EXTERNAL_IDENTIFIER, EXTERNAL_LINK, EXTRINSIC_OBJECT, INTERNATIONAL_STRING, KEY, LOCALIZED_STRING, ORGANIZATION, PERSON_NAME, POSTAL_ADDRESS, REGISTRY_ENTRY, REGISTRY_PACKAGE, SERVICE, SERVICE_BINDING, SLOT, SPECIFICATION_LINK, TELEPHONE_NUMBER, USER, VERSIONABLE
Method Summary
void | confirmAssociation(Association assoc) Confirms this Association by the User associated with the caller.
BulkResponse | deleteAssociations(Collection associationKeys) Deletes the Associations corresponding to the specified Keys.
BulkResponse | deleteClassificationSchemes(Collection schemeKeys) Deletes the ClassificationSchemes corresponding to the specified Keys.
BulkResponse | deleteConcepts(Collection conceptKeys) Deletes the Concepts corresponding to the specified Keys.
BulkResponse | deleteOrganizations(Collection organizationKeys) Deletes the organizations corresponding to the specified Keys.
BulkResponse | deleteServiceBindings(Collection bindingKeys) Deletes the ServiceBindings corresponding to the specified Keys.
BulkResponse | deleteServices(Collection serviceKeys) Deletes the services corresponding to the specified Keys.
BulkResponse | saveAssociations(Collection associations, boolean replace) Saves the specified Association instances.
BulkResponse | saveClassificationSchemes(Collection schemes) Saves the specified ClassificationScheme instances.
BulkResponse | saveConcepts(Collection concepts) Saves the specified Concepts.
BulkResponse | saveOrganizations(Collection organizations) Saves the specified Organizations.
BulkResponse | saveServiceBindings(Collection bindings) Saves the specified ServiceBindings.
BulkResponse | saveServices(Collection services) Saves the specified Services.
void | unConfirmAssociation(Association assoc) Undoes a previous confirmation of this Association by the User associated with the caller.
Methods inherited from interface javax.xml.registry.LifeCycleManager
createAssociation, createClassification, createClassification, createClassification, createClassificationScheme, createClassificationScheme, createClassificationScheme, createConcept, createConcept, createEmailAddress, createEmailAddress, createExternalIdentifier, createExternalIdentifier, createExternalLink, createExternalLink, createExtrinsicObject, createInternationalString, createInternationalString, createInternationalString, createKey, createLocalizedString, createLocalizedString, createObject, createOrganization, createOrganization, createPersonName, createPersonName, createPostalAddress, createRegistryPackage, createRegistryPackage, createService, createService, createServiceBinding, createSlot, createSlot, createSpecificationLink, createTelephoneNumber, createUser, deleteObjects, deleteObjects, deprecateObjects, getRegistryService, saveObjects, unDeprecateObjects

Method Detail

saveOrganizations

public BulkResponse saveOrganizations(Collection organizations)
                               throws JAXRException
Saves the specified Organizations.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
organizations - the Collection of Organization objects to be saved
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveServices

public BulkResponse saveServices(Collection services)
                          throws JAXRException
Saves the specified Services.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
services - the Collection of Service objects to be saved
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveServiceBindings

public BulkResponse saveServiceBindings(Collection bindings)
                                 throws JAXRException
Saves the specified ServiceBindings.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
bindings - the Collection of ServiceBinding objects to be saved
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveConcepts

public BulkResponse saveConcepts(Collection concepts)
                          throws JAXRException
Saves the specified Concepts.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
concepts - the Collection of Concept objects to be saved
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveClassificationSchemes

public BulkResponse saveClassificationSchemes(Collection schemes)
                                       throws JAXRException
Saves the specified ClassificationScheme instances.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
schemes - the Collection of ClassificationScheme objects to be saved
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveAssociations

public BulkResponse saveAssociations(Collection associations,
                                     boolean replace)
                              throws JAXRException
Saves the specified Association instances.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
associations - the Collection of Association objects to be saved
replace - If set to true, the specified associations replace any existing associations owned by the caller. If set to false, the specified associations are saved, while any existing associations not being updated by this call are preserved.
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteOrganizations

public BulkResponse deleteOrganizations(Collection organizationKeys)
                                 throws JAXRException
Deletes the organizations corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
organizationKeys - the Collection of keys for the Organization objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteServices

public BulkResponse deleteServices(Collection serviceKeys)
                            throws JAXRException
Deletes the services corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
serviceKeys - the Collection of keys for the Service objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteServiceBindings

public BulkResponse deleteServiceBindings(Collection bindingKeys)
                                   throws JAXRException
Deletes the ServiceBindings corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
bindingKeys - the Collection of keys for the ServiceBinding objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteConcepts

public BulkResponse deleteConcepts(Collection conceptKeys)
                            throws JAXRException
Deletes the Concepts corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
conceptKeys - the Collection of keys for the Concept objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteClassificationSchemes

public BulkResponse deleteClassificationSchemes(Collection schemeKeys)
                                         throws JAXRException
Deletes the ClassificationSchemes corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
schemeKeys - the Collection of keys for the ClassificationScheme objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteAssociations

public BulkResponse deleteAssociations(Collection associationKeys)
                                throws JAXRException
Deletes the Associations corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
associationKeys - the Collection of keys for the Association objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

confirmAssociation

public void confirmAssociation(Association assoc)
                        throws JAXRException,
                               InvalidRequestException
Confirms this Association by the User associated with the caller. The User must be the owner of the sourceObject or the targetObject in this association.

  • If the Association is intramural, this method does nothing and returns.
  • If the Association is extramural and already confirmed (isConfirmed returns true), this method does nothing and returns.
  • If the Association is extramural and not already confirmed, this method confirms the association for the User associated with the caller.

The details of confirming an extramural Association are registry-specific. For UDDI and ebXML registries, the registry-specific details are described in the JAXR specification.

Capability Level: 0

Parameters:
assoc - the Association object to be confirmed
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException - if the User is not the owner of the sourceObject or the targetObject

unConfirmAssociation

public void unConfirmAssociation(Association assoc)
                          throws JAXRException,
                                 InvalidRequestException
Undoes a previous confirmation of this Association by the User associated with the caller. The User must be the owner of the sourceObject or the targetObject in this association.

  • If the Association is intramural, this method does nothing and returns.
  • If the Association is extramural and already confirmed (isConfirmed returns true), this method unconfirms it for the requestor.
  • If the Association is extramural and not already confirmed, this method does nothing and returns.

The details of unconfirming an extramural Association are registry-specific. For UDDI and ebXML registries, the registry-specific details are described in the JAXR specification.

Capability Level: 0

Parameters:
assoc - the Association object to be unconfirmed
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException - if the User is not the owner of the sourceObject or the targetObject
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BusinessQueryManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface BusinessQueryManager

All Superinterfaces:
QueryManager
public interface BusinessQueryManager
extends QueryManager

The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface. It is also referred to as the focused query interface.

Author:
Farrukh S. Najmi
See Also:
DeclarativeQueryManager, FindQualifier, BulkResponse

Method Summary
BulkResponse | findAssociations(Collection findQualifiers, String sourceObjectId, String targetObjectId, Collection associationTypes) Finds all Association objects that match all of the criteria specified by the parameters of this call.
BulkResponse | findCallerAssociations(Collection findQualifiers, Boolean confirmedByCaller, Boolean confirmedByOtherParty, Collection associationTypes) Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call.
ClassificationScheme | findClassificationSchemeByName(Collection findQualifiers, String namePattern) Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.
BulkResponse | findClassificationSchemes(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalLinks) Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call.
Concept | findConceptByPath(String path) Finds a Concept based on the path specified.
BulkResponse | findConcepts(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalIdentifiers, Collection externalLinks) Finds all Concept objects that match all of the criteria specified by the parameters of this call.
BulkResponse | findOrganizations(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications, Collection externalIdentifiers, Collection externalLinks) Finds all Organization objects that match all of the criteria specified by the parameters of this call.
BulkResponse | findRegistryPackages(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalLinks) Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call.
BulkResponse | findServiceBindings(Key serviceKey, Collection findQualifiers, Collection classifications, Collection specifications) Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call.
BulkResponse | findServices(Key orgKey, Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications) Finds all Service objects that match all of the criteria specified by the parameters of this call.
Methods inherited from interface javax.xml.registry.QueryManager
getRegistryObject, getRegistryObject, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryService

Method Detail

findAssociations

public BulkResponse findAssociations(Collection findQualifiers,
                                     String sourceObjectId,
                                     String targetObjectId,
                                     Collection associationTypes)
                              throws JAXRException
Finds all Association objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters. If no parameters are specified, no Associations are returned.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
sourceObjectId - a String that represents the id for a RegistryObject that must be the sourceObject of the Associations that match. This parameter is ignored if specified as null.
targetObjectId - a String that represents the id for a RegistryObject that must be the targetObject of the Associations that match. This parameter is ignored if specified as null.
associationTypes - a Collection of associationTypes. This is a logical OR operation across the collection. This parameter is ignored if specified as null.
Returns:
a BulkResponse containing a Collection of Associations
Throws:
JAXRException - if the JAXR provider encounters an internal error

findCallerAssociations

public BulkResponse findCallerAssociations(Collection findQualifiers,
                                           Boolean confirmedByCaller,
                                           Boolean confirmedByOtherParty,
                                           Collection associationTypes)
                                    throws JAXRException
Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters. If no parameters are specified, no Associations are returned.

This call is sensitive to the identity of the caller and is a privileged operation that requires the caller to have provided its identity credentials to the Connection associated with this object.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
confirmedByCaller - If true, provider must include Associations involving the caller that have been confirmed by the caller. If false, provider must include Associations involving the caller that have not been confirmed by the caller. This parameter is ignored if specified as null.
confirmedByOtherParty - If true, provider must include Associations involving the caller that have been confirmed by the other party. If false, provider must include Associations involving the caller that have not been confirmed by the other party. This parameter is ignored if specified as null.
associationTypes - a Collection of associationTypes. This is a logical OR operation across the collection. This parameter is ignored if specified as null.
Returns:
a BulkResponse containing a Collection of Associations
Throws:
JAXRException - if the JAXR provider encounters an internal error

findOrganizations

public BulkResponse findOrganizations(Collection findQualifiers,
                                      Collection namePatterns,
                                      Collection classifications,
                                      Collection specifications,
                                      Collection externalIdentifiers,
                                      Collection externalLinks)
                               throws JAXRException
Finds all Organization objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
specifications - a Collection of RegistryObjects that represent (proxy) a technical specification. It is analogous to a tModelBag in the UDDI specification. In the case of a UDDI provider, the RegistryObject is a specification Concept. In the case of an ebXML provider, the RegistryObject is likely to be an ExtrinsicObject. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Specifications qualifies as a match for this criterion.
externalIdentifiers - a Collection of ExternalIdentifier objects that provide an external identifier for the object using an identification scheme such as DUNS. It is analogous to an identifierBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalIdentifiers qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createExternalIdentifier method to create a transient ExternalIdentifier for use in this Collection.
externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of Organizations
Throws:
JAXRException - if the JAXR provider encounters an internal error

findServices

public BulkResponse findServices(Key orgKey,
                                 Collection findQualifiers,
                                 Collection namePatterns,
                                 Collection classifications,
                                 Collection specifications)
                          throws JAXRException
Finds all Service objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 0

Parameters:
orgKey - Key identifying an Organization. Required for UDDI providers.
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
specifications - a Collection of RegistryObjects that represent (proxy) a technical specification. It is analogous to a tModelBag in the UDDI specification. In the case of a UDDI provider, the RegistryObject is a specification Concept. In the case of an ebXML provider, the RegistryObject is likely to be an ExtrinsicObject. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Specifications qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of Services
Throws:
JAXRException - if the JAXR provider encounters an internal error

findServiceBindings

public BulkResponse findServiceBindings(Key serviceKey,
                                        Collection findQualifiers,
                                        Collection classifications,
                                        Collection specifications)
                                 throws JAXRException
Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 0

Parameters:
serviceKey - Key identifying a Service. Required for UDDI providers.
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
specifications - a Collection of RegistryObjects that represent (proxy) a technical specification. It is analogous to a tModelBag in the UDDI specification. In the case of a UDDI provider, the RegistryObject is a specification Concept. In the case of an ebXML provider, the RegistryObject is likely to be an ExtrinsicObject. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Specifications qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of ServiceBindings
Throws:
JAXRException - if the JAXR provider encounters an internal error

findClassificationSchemes

public BulkResponse findClassificationSchemes(Collection findQualifiers,
                                              Collection namePatterns,
                                              Collection classifications,
                                              Collection externalLinks)
                                       throws JAXRException
Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of ClassificationSchemes
Throws:
JAXRException - if the JAXR provider encounters an internal error

findClassificationSchemeByName

public ClassificationScheme findClassificationSchemeByName(Collection findQualifiers,
                                                           String namePattern)
                                                    throws JAXRException
Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePattern - a String that is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification
Returns:
the ClassificationScheme matching the namePattern, or null if no match is found.
Throws:
JAXRException - if the JAXR provider encounters an internal error. Throws an InvalidRequestException if multiple matches are found.

findConcepts

public BulkResponse findConcepts(Collection findQualifiers,
                                 Collection namePatterns,
                                 Collection classifications,
                                 Collection externalIdentifiers,
                                 Collection externalLinks)
                          throws JAXRException
Finds all Concept objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
externalIdentifiers - a Collection of ExternalIdentifier objects that provide an external identifier for the object using an identification scheme such as DUNS. It is analogous to an identifierBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalIdentifiers qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createExternalIdentifier method to create a transient ExternalIdentifier for use in this Collection.
externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of Concepts
Throws:
JAXRException - if the JAXR provider encounters an internal error

findConceptByPath

public Concept findConceptByPath(String path)
                          throws JAXRException
Finds a Concept based on the path specified. If the specified path matches more than one Concept, the one that is most general (higher in the concept hierarchy) is returned.

Capability Level: 0

Parameters:
path - a canonical path expression, as defined in the JAXR specification, that identifies the Concept.
Returns:
the Concept found, or null if no match is found
Throws:
JAXRException - if the JAXR provider encounters an internal error

findRegistryPackages

public BulkResponse findRegistryPackages(Collection findQualifiers,
                                         Collection namePatterns,
                                         Collection classifications,
                                         Collection externalLinks)
                                  throws JAXRException
Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 1

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of RegistryPackages
Throws:
JAXRException - if the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CapabilityProfile

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface CapabilityProfile

public interface CapabilityProfile

Provides information about the capabilities of a JAXR provider.

Author:
Farrukh S. Najmi

Method Summary
int | getCapabilityLevel() Gets the capability level supported by the JAXR provider.
String | getVersion() Gets the JAXR specification version supported by the JAXR provider.

Method Detail

getVersion

public String getVersion()
                  throws JAXRException
Gets the JAXR specification version supported by the JAXR provider.

Capability Level: 0

Returns:
the specification version
Throws:
JAXRException - If the JAXR provider encounters an internal error

getCapabilityLevel

public int getCapabilityLevel()
                       throws JAXRException
Gets the capability level supported by the JAXR provider.

Capability Level: 0

Returns:
the capability level
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Connection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface Connection

All Known Subinterfaces:
FederatedConnection
public interface Connection

This class represents a connection between a JAXR client and a JAXR provider.

Author:
Farrukh S. Najmi
See Also:
ConnectionFactory

Method Summary
void | close() Closes a Connection when it is no longer needed.
Set | getCredentials() Gets the credentials associated with this client.
RegistryService | getRegistryService() Gets the RegistryService interface associated with the Connection.
boolean | isClosed() Indicated whether this Connection has been closed or not.
boolean | isSynchronous() Indicates whether a client uses synchronous communication with JAXR provider or not.
void | setCredentials(Set credentials) Sets the Credentials associated with this client.
void | setSynchronous(boolean sync) Sets whether the client uses synchronous communication or not.

Method Detail

getRegistryService

public RegistryService getRegistryService()
                                   throws JAXRException
Gets the RegistryService interface associated with the Connection. If a Connection property (e.g. credentials) is set after the client calls getRegistryService then the newly set Connection property is visible to the RegistryService previously returned by this call.

Capability Level: 0

Returns:
the RegistryService associated with this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryService

close

public void close()
           throws JAXRException
Closes a Connection when it is no longer needed. Since a provider typically allocates significant resources outside the JVM on behalf of a Connection, clients should close them when they are not needed.

Capability Level: 0

Throws:
JAXRException - If the JAXR provider encounters an internal error

isClosed

public boolean isClosed()
                 throws JAXRException
Indicated whether this Connection has been closed or not.

Capability Level: 0

Returns:
true if Connection is closed; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

isSynchronous

public boolean isSynchronous()
                      throws JAXRException
Indicates whether a client uses synchronous communication with JAXR provider or not. A JAXR provider must support both modes of communication. A JAXR client can choose which mode it wants to use.

Capability Level: 0

Returns:
true if Connection is synchronous (default); false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

setSynchronous

public void setSynchronous(boolean sync)
                    throws JAXRException
Sets whether the client uses synchronous communication or not. A JAXR client may dynamically change its communication style preference.

Capability Level: 0

Parameters:
sync - true if Connection is desired to be synchronous; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

setCredentials

public void setCredentials(Set credentials)
                    throws JAXRException
Sets the Credentials associated with this client. The credentials is used to authenticate the client with the JAXR provider. A JAXR client may dynamically change its identity by changing the credentials associated with it.

Capability Level: 0

Parameters:
credentials - a Collection oj java.lang.Objects which provide identity related information for the caller.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getCredentials

public Set getCredentials()
                   throws JAXRException
Gets the credentials associated with this client.

Capability Level: 0

Returns:
Set of java.lang.Object instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class ConnectionFactory

java.lang.Object
    extended by javax.xml.registry.ConnectionFactory
public abstract class ConnectionFactory
extends Object

This is the abstract base class for factory classes for creating a JAXR connection. A JAXR ConnectionFactory object is configured in a provider-specific way to create connections with registry providers.

Looking Up a ConnectionFactory Using the JNDI API

The preferred way for a client to look up a JAXR ConnectionFactory is within the Java Naming and Directory InterfaceTM (JNDI) API. A ConnectionFactory object is registered with a naming service in a provider specific way, such as one based on the JNDI API. This registration associates the ConnectionFactory object with a logical name. When an application wants to establish a connection with the provider associated with that ConnectionFactory object, it does a lookup, providing the logical name. The application can then use the ConnectionFactory object that is returned to create a connection to the messaging provider.

Looking Up a ConnectionFactory Without Using the JNDI API

The JAXR API provides an alternative way to look up a JAXR ConnectionFactory that does not require the use of the JNDI API. This is done using the newInstance static method on the abstract class ConnectionFactory provided in the JAXR API. The newInstance method returns a JAXR ConnectionFactory. The client may indicate which factory class should be instantiated by the newInstance method by defining the system property javax.xml.registry.ConnectionFactoryClass. If this property is not set, the JAXR provider must return a default ConnectionFactory instance.

Author:
Farrukh S. Najmi
See Also:
Connection

Constructor Summary
ConnectionFactory()
Method Summary
abstract Connection | createConnection() Create a named connection.
abstract FederatedConnection | createFederatedConnection(Collection connections) Create a FederatedConnection.
abstract Properties | getProperties() Gets the Properties used during createConnection and createFederatedConnection calls.
static ConnectionFactory | newInstance() Creates a default ConnectionFactory object.
abstract void | setProperties(Properties properties) Sets the Properties used during createConnection and createFederatedConnection calls.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConnectionFactory

public ConnectionFactory()
Method Detail

setProperties

public abstract void setProperties(Properties properties)
                            throws JAXRException
Sets the Properties used during createConnection and createFederatedConnection calls.

Standard Connection Properties:
javax.xml.registry.queryManagerURL - URL String for the query manager service within the target registry provider
javax.xml.registry.lifeCycleManagerURL - URL String for the life cycle manager service within the target registry provider. If unspecified, must default to value of the queryManagerURL described above
javax.xml.registry.semanticEquivalences - String that allows specification of semantic equivalences
javax.xml.registry.security.authenticationMethod - string that provides a hint to the JAXR provider on the authentication method to be used when authenticating with the registry provider. Possible value include but are not limited to "UDDI_GET_AUTHTOKEN", "HTTP_BASIC", "CLIENT_CERTIFICATE", "MS_PASSPORT"
javax.xml.registry.uddi.maxRows - integer that specifies the maximum number of rows to be returned for find operations. This property is specific for UDDI providers
javax.xml.registry.postalAddressScheme - String that specifies the id of a ClassificationScheme that is used as the default postal address scheme for this connection

Capability Level: 0

Parameters:
properties - configuration properties that are either specified by JAXR specification or are provider specific.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getProperties

public abstract Properties getProperties()
                                  throws JAXRException
Gets the Properties used during createConnection and createFederatedConnection calls.

Capability Level: 0

Returns:
the Properties defined for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

createConnection

public abstract Connection createConnection()
                                     throws JAXRException
Create a named connection. Such a connection can be used to communicate with a JAXR provider.

Capability Level: 0

Returns:
the Connection created by this call
Throws:
JAXRException - If the JAXR provider encounters an internal error

createFederatedConnection

public abstract FederatedConnection createFederatedConnection(Collection connections)
                                                       throws JAXRException
Create a FederatedConnection.

Capability Level: 0 (optional)

Parameters:
connections - Is a Collection of Connection objects. Note that Connection objects may also be FederatedConnection objects.
Returns:
the FederatedConnection created by this call
Throws:
JAXRException - If the JAXR provider encounters an internal error

newInstance

public static ConnectionFactory newInstance()
                                     throws JAXRException
Creates a default ConnectionFactory object.

Returns:
a new instance of a ConnectionFactory
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeclarativeQueryManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface DeclarativeQueryManager

All Superinterfaces:
QueryManager
public interface DeclarativeQueryManager
extends QueryManager

This interface provides the ability to execute declarative queries (e.g. SQL)

Author:
Farrukh S. Najmi

Method Summary
Query | createQuery(int queryType, String queryString) Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.
BulkResponse | executeQuery(Query query) Executes a query as specified by query parameter.
Methods inherited from interface javax.xml.registry.QueryManager
getRegistryObject, getRegistryObject, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryService

Method Detail

createQuery

public Query createQuery(int queryType,
                         String queryString)
                  throws InvalidRequestException,
                         JAXRException
Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.

Capability Level: 1

Parameters:
queryType - the type of query
queryString - the query in its string representation
Throws:
JAXRException - If the JAXR provider encounters an internal error
InvalidRequestException - If the JAXR provider validates query syntax (optional) and the sqlQuery is not valid
See Also:
Query.QUERY_TYPE_SQL, Query.QUERY_TYPE_XQUERY, Query.QUERY_TYPE_EBXML_FILTER_QUERY

executeQuery

public BulkResponse executeQuery(Query query)
                          throws JAXRException
Executes a query as specified by query parameter.

Capability Level: 1

Parameters:
query - the query to be executed
Returns:
the BulkResponse that is the result of the query
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeleteException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class DeleteException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.registry.JAXRException
                extended by javax.xml.registry.RegistryException
                    extended by javax.xml.registry.DeleteException
All Implemented Interfaces:
JAXRResponse, Serializable
public class DeleteException
extends RegistryException

A RegistryException that occurs during a delete action.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
DeleteException()
Constructs a JAXRException object with no reason or embedded Throwable.
DeleteException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
DeleteException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
DeleteException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Methods inherited from class javax.xml.registry.RegistryException
getErrorObjectKey, setErrorObjectKey
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DeleteException

public DeleteException()
Constructs a JAXRException object with no reason or embedded Throwable.

DeleteException

public DeleteException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

DeleteException

public DeleteException(String reason,
                       Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

DeleteException

public DeleteException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FindException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class FindException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.registry.JAXRException
                extended by javax.xml.registry.RegistryException
                    extended by javax.xml.registry.FindException
All Implemented Interfaces:
JAXRResponse, Serializable
public class FindException
extends RegistryException

A RegistryException that occurs during a find action.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
FindException()
Constructs a JAXRException object with no reason or embedded Throwable.
FindException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
FindException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
FindException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Methods inherited from class javax.xml.registry.RegistryException
getErrorObjectKey, setErrorObjectKey
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FindException

public FindException()
Constructs a JAXRException object with no reason or embedded Throwable.

FindException

public FindException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

FindException

public FindException(String reason,
                     Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

FindException

public FindException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FindQualifier

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface FindQualifier

public interface FindQualifier

FindQualifier provides various constants that identify options that effect find method behavior. A JAXR provider may silently ignore any qualifiers marked as optional. A JAXR provider must support qualifiers not marked optional.

See Also:
BusinessQueryManager

Field Summary
static String | AND_ALL_KEYS
static String | CASE_SENSITIVE_MATCH
static String | COMBINE_CLASSIFICATIONS Maps to UDDI combineCategoryBags.
static String | EXACT_NAME_MATCH
static String | OR_ALL_KEYS
static String | OR_LIKE_KEYS
static String | SERVICE_SUBSET Maps to UDDI serviceSubset.
static String | SORT_BY_DATE_ASC
static String | SORT_BY_DATE_DESC
static String | SORT_BY_NAME_ASC
static String | SORT_BY_NAME_DESC
static String | SOUNDEX Optional qualifier that allows matching strings by their sounds.

Field Detail

EXACT_NAME_MATCH

public static final String EXACT_NAME_MATCH
See Also:
Constant Field Values

CASE_SENSITIVE_MATCH

public static final String CASE_SENSITIVE_MATCH
See Also:
Constant Field Values

SORT_BY_NAME_ASC

public static final String SORT_BY_NAME_ASC
See Also:
Constant Field Values

SORT_BY_NAME_DESC

public static final String SORT_BY_NAME_DESC
See Also:
Constant Field Values

SORT_BY_DATE_ASC

public static final String SORT_BY_DATE_ASC
See Also:
Constant Field Values

SORT_BY_DATE_DESC

public static final String SORT_BY_DATE_DESC
See Also:
Constant Field Values

OR_LIKE_KEYS

public static final String OR_LIKE_KEYS
See Also:
Constant Field Values

OR_ALL_KEYS

public static final String OR_ALL_KEYS
See Also:
Constant Field Values

COMBINE_CLASSIFICATIONS

public static final String COMBINE_CLASSIFICATIONS
Maps to UDDI combineCategoryBags. Required for JAXR UDDI providers, optional for all others.

See Also:
Constant Field Values

SERVICE_SUBSET

public static final String SERVICE_SUBSET
Maps to UDDI serviceSubset. Required for JAXR UDDI providers, optional for all others.

See Also:
Constant Field Values

AND_ALL_KEYS

public static final String AND_ALL_KEYS
See Also:
Constant Field Values

SOUNDEX

public static final String SOUNDEX
Optional qualifier that allows matching strings by their sounds.

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


infomodel

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.registry.infomodel

This package describes the information model for the JAXR API.

See:
Description

Interface Summary
Association | A RegistryObject instance may be associated with zero or more RegistryObject instances.
AuditableEvent | AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject.
Classification | The Classification interface is used to classify RegistryObject instances.
ClassificationScheme | A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
Concept | The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.
EmailAddress | Represents an email address.
ExtensibleObject | An ExtensibleObject is one that allows itself to be extended by utilizing dynamically added Slots that add arbitrary attributes to the object on a per instance basis.
ExternalIdentifier | ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization.
ExternalLink | ExternalLink instances model a named URI to content that may reside outside the registry.
ExtrinsicObject | ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).
InternationalString | This interface represents a String that has been internationalized into several Locales.
Key | Represents a unique key that identifies a RegistryObject.
LocalizedString | This interface is used as a simple wrapper interface that associates a String with its Locale.
Organization | Organization instances provide information on organizations such as a Submitting Organization.
PersonName | Represents a person's name.
PostalAddress | PostalAddress is a simple re-usable entity class that defines attributes of a postal Address.
RegistryEntry | The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface.
RegistryObject | The RegistryObject class is an abstract base class used by most classes in the model.
RegistryPackage | RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together.
Service | Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization.
ServiceBinding | ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance.
Slot | Slot instances provide a dynamic way to add arbitrary attributes to RegistryObject instances.
SpecificationLink | A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding.
TelephoneNumber | A simple re-usable entity class that defines attributes of a telephone number.
URIValidator | Defines common behavior expected of any class that validates URIs.
User | User instances are RegistryObjects that are used to provide information about registered users within the registry.
Versionable | The Versionable interface defines the behavior common to classes that are capable of creating versions of their instances.

Package javax.xml.registry.infomodel Description

This package describes the information model for the JAXR API. It is based largely on the ebXML Registry Information Model with enhancements to support other registry specifications such as UDDI.

The class diagram in Figure 1 shows the public view of the information model.

Information Model Public View
Figure 1. Information Model Public View

The class diagram in Figure 2 shows the inheritance view of the information model.

Information Model Detailed View
Figure 2. Information Model Detailed View

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.registry.infomodel Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.registry.infomodel

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface javax.xml.registry.infomodel.EmailAddress
  • interface javax.xml.registry.infomodel.ExtensibleObject
    • interface javax.xml.registry.infomodel.PostalAddress
    • interface javax.xml.registry.infomodel.RegistryObject
      • interface javax.xml.registry.infomodel.Association
      • interface javax.xml.registry.infomodel.AuditableEvent
      • interface javax.xml.registry.infomodel.Classification
      • interface javax.xml.registry.infomodel.Concept
      • interface javax.xml.registry.infomodel.ExternalIdentifier
      • interface javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.URIValidator)
      • interface javax.xml.registry.infomodel.Organization
      • interface javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.Versionable)
        • interface javax.xml.registry.infomodel.ClassificationScheme
        • interface javax.xml.registry.infomodel.ExtrinsicObject
        • interface javax.xml.registry.infomodel.RegistryPackage
        • interface javax.xml.registry.infomodel.Service
      • interface javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.URIValidator)
      • interface javax.xml.registry.infomodel.SpecificationLink
      • interface javax.xml.registry.infomodel.User
  • interface javax.xml.registry.infomodel.InternationalString
  • interface javax.xml.registry.infomodel.Key
  • interface javax.xml.registry.infomodel.LocalizedString
  • interface javax.xml.registry.infomodel.PersonName
  • interface javax.xml.registry.infomodel.Slot
  • interface javax.xml.registry.infomodel.TelephoneNumber
  • interface javax.xml.registry.infomodel.URIValidator
    • interface javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.RegistryObject)
    • interface javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.RegistryObject)
  • interface javax.xml.registry.infomodel.Versionable
    • interface javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.RegistryObject)
      • interface javax.xml.registry.infomodel.ClassificationScheme
      • interface javax.xml.registry.infomodel.ExtrinsicObject
      • interface javax.xml.registry.infomodel.RegistryPackage
      • interface javax.xml.registry.infomodel.Service
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Association

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Association

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface Association
extends RegistryObject

A RegistryObject instance may be associated with zero or more RegistryObject instances. The information model defines an Association interface, an instance of which may be used to associate any two RegistryObject instances.

Example of an Association

One example of such an association is between two ClassificationScheme instances, where one ClassificationScheme supersedes the other ClassificationScheme as shown in Figure 1. This may be the case when a new version of a ClassificationScheme is submitted. In Figure 1, we see how an Association is defined between a new version of the NAICS ClassificationScheme and an older version of the NAICS ClassificationScheme.

Example of RegistryObject Association
Figure 1. Example of RegistryObject Association

Source and Target Objects

An Association instance represents an association between a source RegistryObject and a target RegistryObject. These are referred to as sourceObject and targetObject for the Association instance. It is important which object is the sourceObject and which is the targetObject as it determines the directional semantics of an Association. In the example in Figure 1, it is important to make the newer version of NAICS ClassificationScheme be the sourceObject and the older version of NAICS be the targetObject because the associationType implies that the sourceObject supersedes the targetObject (and not the other way around).

Association Types

Each Association must have an associationType attribute that identifies the type of that association. The associationType attribute is a reference to an enumeration Concept as defined by the predefined associationType ClassificationScheme in the JAXR specification. Our example uses the pre-defined associationType Concept named Supersedes.

Intramural Associations

A common use case for the Association interface is when a User "u" creates an Association "a" between two RegistryObjects "o1" and "o2" where association "a" and RegistryObjects "o1" and "o2" are objects that were created by the same User "u". This is the simplest use case where the association is between two objects that are owned by same User that is defining the Association. Such associations are referred to as intramural associations. Figure 2 extends the previous example in Figure 1 for the intramural association case.

Example of Intramural Association
Figure 2. Example of Intramural Association

Extramural Association

The information model also allows a more sophisticated use case where a User "u1" creates an Association "a" between two RegistryObjects "o1" and "o2" where association "a" is owned by User "u1", but RegistryObjects "o1" and "o2" are owned by User "u2" and User "u3" respectively. In this use case the Association is being defined where either or both objects that are being associated are owned by a User different from the User defining the Association. Such associations are referred to as extramural associations. The Association interface provides a convenience method called isExtramural that returns true if the Association instance is an extramural Association. Figure 3 extends the previous example in Figure 1 for the extramural association case. Note that it is possible for an extramural association to have two distinct Users rather than three distinct Users as shown in Figure 3. In such case, one of the two users owns two of the three objects involved (Association, sourceObject and targetObject).

Example of Extramural Association
Figure 3. Example of Extramural Association

Confirmation of an Association

An association may need to be confirmed by the parties whose objects are involved in that Association. This section describes the semantics of confirmation of an association by the parties involved.

Confirmation of Intramural Associations

Intramural associations may be viewed as declarations of truth and do not require any explicit steps to confirm that Association as being true. In other words, intramural associations are implicitly considered be confirmed.

Confirmation of Extramural Associations

Extramural associations may be viewed as a unilateral assertion that may not be viewed as truth until it has been confirmed by the other (extramural) parties (Users "u2" and "u3" in example). The confirmAssociation method on the BusinessLifeCycleManager interface may be called by the extramural parties that own the sourceObject or targetObject.

Visibility of Unconfirmed Associations

Extramural associations require each extramural party to confirm the assertion being made by the extramural Association before the Association is visible to 3rd parties that are not involved in the Association. This ensures that unconfirmed Associations are not visible to 3rd party registry clients.

Possible Confirmation States

Assume the most general case where there are three distinct User instances as shown in Figure 23 for an extramural Association. The extramural Association needs to be confirmed by both the other (extramural) parties (Users "u2" and "u3" in example) in order to be fully confirmed. The methods isConfirmedBySourceOwner and isConfiremedByTargetOwner in the Association interface provide access to confirmation state for both the sourceObject and targetObject. A third convenience method called isConfirmed provides a way to determine whether the Association is fully confirmed or not. So there are the following four possibilities related to confirmation state of an extramural Association:
  • The Association is confirmed neither by the owner of the sourceObject nor is it confirmed by owner of targetObject.
  • The Association is confirmed by the owner of the sourceObject but it is not confirmed by owner of targetObject.
  • The Association is not confirmed by the owner of the sourceObject but it is confirmed by owner of targetObject.
  • The Association is confirmed by the owner of the sourceObject and it is confirmed by owner of targetObject. This is the only state where the Association is fully confirmed.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Method Summary
Concept | getAssociationType() Gets the association type for this Association.
RegistryObject | getSourceObject() Gets the Object that is the source of this Association.
RegistryObject | getTargetObject() Gets the Object that is the target of this Association.
boolean | isConfirmed() Determines whether an Association has been confirmed completely.
boolean | isConfirmedBySourceOwner() Determines whether an Association has been confirmed by the owner of the source object.
boolean | isConfirmedByTargetOwner() Determines whether an Association has been confirmed by the owner of the target object.
boolean | isExtramural() Determines whether an Association is extramural or not.
void | setAssociationType(Concept associationType) Sets the association type for this Association.
void | setSourceObject(RegistryObject srcObject) Sets the Object that is the source of this Association.
void | setTargetObject(RegistryObject targetObject) Sets the Object that is the target of this Association.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getSourceObject

public RegistryObject getSourceObject()
                               throws JAXRException
Gets the Object that is the source of this Association.

Capability Level: 0

Returns:
The RegistryObject that is the source object of this Association
Throws:
JAXRException - If the JAXR provider encounters an internal error

setSourceObject

public void setSourceObject(RegistryObject srcObject)
                     throws JAXRException
Sets the Object that is the source of this Association.

Capability Level: 0

Parameters:
srcObject - the RegistryObject that is the source object of this Association
Throws:
JAXRException - If the JAXR provider encounters an internal error

getTargetObject

public RegistryObject getTargetObject()
                               throws JAXRException
Gets the Object that is the target of this Association.

Capability Level: 0

Returns:
The RegistryObject that is the target object of this Association
Throws:
JAXRException - If the JAXR provider encounters an internal error

setTargetObject

public void setTargetObject(RegistryObject targetObject)
                     throws JAXRException
Sets the Object that is the target of this Association.

Capability Level: 0

Parameters:
targetObject - the RegistryObject that is the target object of this Association
Throws:
JAXRException - If the JAXR provider encounters an internal error

getAssociationType

public Concept getAssociationType()
                           throws JAXRException
Gets the association type for this Association.

Capability Level: 0

Returns:
The association type for this Association which is a Concept in the AssociationType ClassificationScheme
Throws:
JAXRException - If the JAXR provider encounters an internal error

setAssociationType

public void setAssociationType(Concept associationType)
                        throws JAXRException
Sets the association type for this Association.

Capability Level: 0

Parameters:
associationType - the association type for this Association which is a Concept in the AssociationType ClassificationScheme
Throws:
JAXRException - If the JAXR provider encounters an internal error

isExtramural

public boolean isExtramural()
                     throws JAXRException
Determines whether an Association is extramural or not.

An Extramural Association must be confirmed by the User(s) that own the source and/or targert object, if they are different from the User who creates this extramural association. Both the sourceObject and targetObject owners must confirm an extramural Association, in order for it to be visible to third parties.

Capability Level: 0

Returns:
true if the sourceObject and/or the targetObject are owned by a User that is different from the User that created the Association; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

isConfirmedBySourceOwner

public boolean isConfirmedBySourceOwner()
                                 throws JAXRException
Determines whether an Association has been confirmed by the owner of the source object.

Capability Level: 0

Returns:
true if the association has been confirmed by the owner of the sourceObject; false otherwise. For intramural Associations always return true
Throws:
JAXRException - If the JAXR provider encounters an internal error

isConfirmedByTargetOwner

public boolean isConfirmedByTargetOwner()
                                 throws JAXRException
Determines whether an Association has been confirmed by the owner of the target object.

Capability Level: 0

Returns:
true if the association has been confirmed by the owner of the targetObject; false otherwise. For intramural Associations always return true
Throws:
JAXRException - If the JAXR provider encounters an internal error

isConfirmed

public boolean isConfirmed()
                    throws JAXRException
Determines whether an Association has been confirmed completely.

An association should only be visible to third parties (not involved with the Association) if isConfirmed returns true.

Capability Level: 0

Returns:
true if the isConfirmedBySourceOwner and isConfirmedByTargetOwner methods both return true; false otherwise. For intramural Associations always return true
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
isConfirmedBySourceOwner(), isConfirmedByTargetOwner()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AuditableEvent

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface AuditableEvent

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface AuditableEvent
extends RegistryObject

AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject. Such events are usually a result of a client initiated request. AuditableEvent instances are generated by the registry service to log such events.

Often such events effect a change in the life cycle of a RegistryObject. For example a client request could Create, Update, Deprecate or Delete a RegistryObject. No AuditableEvent is created for requests that do not alter the state of a RegistryObject. Specifically, read-only requests do not generate an AuditableEvent. No AuditableEvent is generated for a RegistryObject when it is classified, assigned to a Package or associated with another Object.

A RegistryObject is associated with an ordered Collection of AuditableEvent instances that provide a complete audit trail for that Object.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Field Summary
static int | EVENT_TYPE_CREATED An event where a RegistryObject is created.
static int | EVENT_TYPE_DELETED An event where a RegistryObject is deleted.
static int | EVENT_TYPE_DEPRECATED An event where a RegistryObject is deprecated.
static int | EVENT_TYPE_UNDEPRECATED An event where a RegistryObject is undeprecated.
static int | EVENT_TYPE_UPDATED An event where a RegistryObject is updated.
static int | EVENT_TYPE_VERSIONED An event where a RegistryObject is versioned.
Method Summary
int | getEventType() Gets the type of this event.
RegistryObject | getRegistryObject() Gets the RegistryObject associated with this AuditableEvent.
Timestamp | getTimestamp() Gets the Timestamp for when this event occurred.
User | getUser() Gets the User associated with this object.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Field Detail

EVENT_TYPE_CREATED

public static final int EVENT_TYPE_CREATED
An event where a RegistryObject is created.

See Also:
Constant Field Values

EVENT_TYPE_DELETED

public static final int EVENT_TYPE_DELETED
An event where a RegistryObject is deleted.

See Also:
Constant Field Values

EVENT_TYPE_DEPRECATED

public static final int EVENT_TYPE_DEPRECATED
An event where a RegistryObject is deprecated.

See Also:
Constant Field Values

EVENT_TYPE_UPDATED

public static final int EVENT_TYPE_UPDATED
An event where a RegistryObject is updated.

See Also:
Constant Field Values

EVENT_TYPE_VERSIONED

public static final int EVENT_TYPE_VERSIONED
An event where a RegistryObject is versioned.

See Also:
Constant Field Values

EVENT_TYPE_UNDEPRECATED

public static final int EVENT_TYPE_UNDEPRECATED
An event where a RegistryObject is undeprecated.

See Also:
Constant Field Values
Method Detail

getUser

public User getUser()
             throws JAXRException
Gets the User associated with this object.

Capability Level: 1

Returns:
the User that sent the request that generated this this AuditableEvent. Must not be null
Throws:
JAXRException - If the JAXR provider encounters an internal error

getTimestamp

public Timestamp getTimestamp()
                       throws JAXRException
Gets the Timestamp for when this event occurred.

Capability Level: 1

Returns:
the timestamp that records the time the event occured
Throws:
JAXRException - If the JAXR provider encounters an internal error

getEventType

public int getEventType()
                 throws JAXRException
Gets the type of this event.

Capability Level: 1

Returns:
the type of this event
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
EVENT_TYPE_CREATED

getRegistryObject

public RegistryObject getRegistryObject()
                                 throws JAXRException
Gets the RegistryObject associated with this AuditableEvent.

Capability Level: 1

Returns:
the RegistryObject that was the focus of this event
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Classification

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Classification

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface Classification
extends RegistryObject

The Classification interface is used to classify RegistryObject instances. A RegistryObject may be classified along multiple dimensions by adding zero or more Classification instances to the RegistryObject. For example, an Organization may be classified by its industry, by the products it sells and by its geographical location. In this example the RegistryObject would have at least three Classification instances added to it. The RegistryObject interface provides several addClassification methods to allow a client to add Classification instances to a Registry Object.

Figure 1 shows how a Classification classifies a RegistryObject using a ClassificationScheme.

Using a ClassificationScheme to Classify an Object
Figure 1. Using a ClassificationScheme to Classify an Object

Internal vs. External Taxonomies

A taxonomy may be represented within a JAXR provider in one of the following ways:
  1. The taxonomy elements and their structural relationship with each other are available within the JAXR provider. This case is referred to as Internal Taxonomy since the structure of the taxonomy is available internal to the JAXR provider.
  2. The taxonomy elements and their structural relationship with each other is represented somewhere external to the JAXR provider. This case is referred to as External Taxonomy since the structure of the taxonomy is not available to the JAXR provider.

Internal vs. External Classifications

The Classification interface allows the classification of RegistryObjects using a ClassificationScheme whether the ClassificationScheme represents an internal taxonomy or an external taxonomy. When a Classification instance uses a ClassificationScheme representing an internal taxonomy then it is referred to as an internal Classification. When a Classification instance uses a ClassificationScheme representing an external taxonomy then it is referred to as an external Classification.

Internal Classification

When a Classification instance is used to classify a RegistryObject using an internal taxonomy it is referred to as an internal Classification. A client must call the setConcept method on a Classification and define a reference to a Concept instance from the Classification instance in order for that Classification to use an internal taxonomy. It is not necessary for the client to call setClassificationScheme for internal Classifications since the classifying Concept already knows it root ClassificationScheme.

Example of Internal Classification

Figure 2 shows an example of internal classification using a Concept to represent a taxonomy element. The example classifies an Organization instance as a Book Publisher using the NAICS standard taxonomy available as an internal taxonomy. Note that the figure does not show all the Concepts between the ?Book Publishers? node and the NAICS ClassificationScheme to save space. Had they been there they would have been linked together by the parent attribute of each Concept.

Example of Internal Classification
Figure 2. Example of Internal Classification

External Classification

When a Classification instance is used to classify a RegistryObject using an external taxonomy it is referred to as an external Classification. A client must call the setValue method on a Classification and define a unique value that logically represents a taxonomy element within the taxonomy whose structure is defined externally. It is necessary for the client call setClassificationScheme for external Classifications since there is no other way to infer the ClassificationScheme that represents the external taxonomy.

Example of External Classification

Figure 3 shows an example of external classification. The example uses the same scenario where a Classification classifies an Organization instance as a Book Publisher using the NAICS standard taxonomy. However, this time the structure of the NAICS taxonomy is not available internally to the JAXR provider and consequently there is no Concept instance. Instead, the name and value attributes of the Classification are used to pinpoint the Book Publisher's taxonomy element. Note that name is optional but value is required.

Example of External Classification
Figure 3. Example of External Classification

An Example of Multiple Classifications

The next example shows how a RegistryObject may be classified by multiple classification schemes. In this example, two internal ClassificationSchemes named Industry and Geography are used to classify several Organization RegistryObjects by their industry and Geography. In Figure 4, in order to save space and improve readability, the Classification instances are not explicitly shown but are implied as associations between the RegistryObjects (shaded leaf node) and the associated Concepts.

Example of Multiple Classifications
Figure 4. Example of Multiple Classifications

Author:
Farrukh S. Najmi
See Also:
RegistryObject, Concept

Method Summary
ClassificationScheme | getClassificationScheme() Gets the ClassificationScheme that is used in classifying the object.
RegistryObject | getClassifiedObject() Gets the Object that is being classified.
Concept | getConcept() Gets the Concept that is classifying the object.
String | getValue() Gets the taxonomy value for this Classification.
boolean | isExternal() Returns true if this is an external classification.
void | setClassificationScheme(ClassificationScheme classificationScheme) Sets the ClassificationScheme for this external classification.
void | setClassifiedObject(RegistryObject classifiedObject) Sets the object that is being classified.
void | setConcept(Concept concept) Sets the concept for this internal classification.
void | setValue(String value) Sets the taxonomy value for this external Classification.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getConcept

public Concept getConcept()
                   throws JAXRException
Gets the Concept that is classifying the object.

Capability Level: 0

Returns:
the Concept that is classifying the classified object. null if this is a external Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

setConcept

public void setConcept(Concept concept)
                throws JAXRException
Sets the concept for this internal classification.

This method should be used mutually exclusively with the setClassificationScheme method.

Capability Level: 0

Parameters:
concept - the Concept that is classifying the classified object.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getClassificationScheme

public ClassificationScheme getClassificationScheme()
                                             throws JAXRException
Gets the ClassificationScheme that is used in classifying the object. If the Classification is an internal Classification then this method should return the value returned by calling the getClassificationScheme method on the Concept representing the taxonomy element.

Capability Level: 0

Returns:
the ClassificationScheme used by this Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
ClassificationScheme

setClassificationScheme

public void setClassificationScheme(ClassificationScheme classificationScheme)
                             throws JAXRException
Sets the ClassificationScheme for this external classification.

If this method is called then you must also call setValue method. This method should be used mutually exclusively with the setConcept method.

Capability Level: 0

Parameters:
classificationScheme - the ClassificationScheme used by this Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

getValue

public String getValue()
                throws JAXRException
Gets the taxonomy value for this Classification.

Capability Level: 0

Returns:
the value of the taxonomy element if external Classification; the value of the Concept representing the taxonomy element if internal Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

public void setValue(String value)
              throws JAXRException
Sets the taxonomy value for this external Classification.

Capability Level: 0

Parameters:
value - the taxonomy value used by this external Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

getClassifiedObject

public RegistryObject getClassifiedObject()
                                   throws JAXRException
Gets the Object that is being classified.

Capability Level: 0

Returns:
the RegistryObject that is classified by this Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

setClassifiedObject

public void setClassifiedObject(RegistryObject classifiedObject)
                         throws JAXRException
Sets the object that is being classified.

Capability Level: 0

Parameters:
classifiedObject - the RegistryObject that is classified by this Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

isExternal

public boolean isExternal()
                   throws JAXRException
Returns true if this is an external classification.

Capability Level: 0

Returns:
true if this is an external Classification; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ClassificationScheme

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ClassificationScheme

All Superinterfaces:
ExtensibleObject, RegistryEntry, RegistryObject, Versionable
public interface ClassificationScheme
extends RegistryEntry

A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances. A very common example of a classification scheme in science is the Classification of living things where living things are categorized in under a tree like structure. Another example is the Dewey Decimal system used in libraries to categorize books and other publications. A common example in eBusiness is that of North American Industry Classification System (NAICS), which is a classification scheme used to classify businesses and services by the industry to which they belong.

Figure 1 shows how a ClassificationScheme is used by a Classification to classify a RegistryObject.

Using a ClassificationScheme to Classify an Object
Figure 1. Using a ClassificationScheme to Classify an Object

Field Summary
static int | VALUE_TYPE_EMBEDDED_PATH Each taxonomy value in ClassificationScheme embeds the full path from scheme to that Concept.
static int | VALUE_TYPE_NON_UNIQUE Taxonomy values in ClassificationScheme may be repeated within the same scheme.
static int | VALUE_TYPE_UNIQUE Each taxonomy value in ClassificationScheme is unique.
Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry
STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN
Method Summary
void | addChildConcept(Concept concept) Adds a child Concept.
void | addChildConcepts(Collection concepts) Adds a Collection of Concept children.
int | getChildConceptCount() Gets number of children.
Collection | getChildrenConcepts() Gets all immediate children Concepts.
Collection | getDescendantConcepts() Gets all descendant Concepts.
int | getValueType() Gets the value type for this object.
boolean | isExternal() Determines whether this ClassificationScheme is an external ClassificationScheme or an internal ClassificationScheme.
void | removeChildConcept(Concept concept) Removes a child Concept.
void | removeChildConcepts(Collection concepts) Removes a Collection of children Concepts.
void | setValueType(int valueType) Sets the value type for this object.
Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry
getExpiration, getStability, getStatus, setExpiration, setStability
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.Versionable
getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

Field Detail

VALUE_TYPE_UNIQUE

public static final int VALUE_TYPE_UNIQUE
Each taxonomy value in ClassificationScheme is unique.

See Also:
Constant Field Values

VALUE_TYPE_EMBEDDED_PATH

public static final int VALUE_TYPE_EMBEDDED_PATH
Each taxonomy value in ClassificationScheme embeds the full path from scheme to that Concept. This also implies that each taxonomy value is unique.

See Also:
Constant Field Values

VALUE_TYPE_NON_UNIQUE

public static final int VALUE_TYPE_NON_UNIQUE
Taxonomy values in ClassificationScheme may be repeated within the same scheme. However, two Concepts that have the same parent cannot have the same value.

See Also:
Constant Field Values
Method Detail

addChildConcept

public void addChildConcept(Concept concept)
                     throws JAXRException
Adds a child Concept.

Capability Level: 0

Parameters:
concept - the concept being added as a child of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addChildConcepts

public void addChildConcepts(Collection concepts)
                      throws JAXRException
Adds a Collection of Concept children.

Capability Level: 0

Parameters:
concepts - the Collection of Concepts being added as a children of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildConcept

public void removeChildConcept(Concept concept)
                        throws JAXRException
Removes a child Concept.

Capability Level: 0

Parameters:
concept - the concept being removed as a child Concept of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildConcepts

public void removeChildConcepts(Collection concepts)
                         throws JAXRException
Removes a Collection of children Concepts.

Capability Level: 0

Parameters:
concepts - the Collection of Concepts being removed as children Concepts of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildConceptCount

public int getChildConceptCount()
                         throws JAXRException
Gets number of children.

Capability Level: 0

Returns:
the number of children Concepts
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildrenConcepts

public Collection getChildrenConcepts()
                               throws JAXRException
Gets all immediate children Concepts.

Capability Level: 0

Returns:
Collection of Concept instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Concept

getDescendantConcepts

public Collection getDescendantConcepts()
                                 throws JAXRException
Gets all descendant Concepts.

Capability Level: 0

Returns:
Collection of Concept instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Concept

isExternal

public boolean isExternal()
                   throws JAXRException
Determines whether this ClassificationScheme is an external ClassificationScheme or an internal ClassificationScheme.

Capability Level: 0

Returns:
trueif this is an external ClassificationScheme; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

getValueType

public int getValueType()
                 throws JAXRException
Gets the value type for this object. The value type describes how taxonomy values are defined within the scheme.

Capability Level: 1

Returns:
an integer constant that describes the type of values supported by this ClassificationScheme
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
VALUE_TYPE_UNIQUE, VALUE_TYPE_EMBEDDED_PATH, VALUE_TYPE_NON_UNIQUE

setValueType

public void setValueType(int valueType)
                  throws JAXRException
Sets the value type for this object.

Capability Level: 1

Parameters:
valueType - an integer constant that describes the type of values supported by this ClassificationScheme
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
VALUE_TYPE_UNIQUE, VALUE_TYPE_EMBEDDED_PATH, VALUE_TYPE_NON_UNIQUE
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Concept

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Concept

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface Concept
extends RegistryObject

The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy. Concept instances are used to define tree structures where the root of the tree is a ClassificationScheme instance and each node in the tree is a Concept instance. Two Concepts may be defined as being equivalent.

Figure 1 shows how Concept instances are used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.

Using Concepts to Represent Taxonomy Elements
Figure 1. Using Concepts to Represent Taxonomy Elements

Author:
Farrukh S. Najmi
See Also:
RegistryObject, Classification, ClassificationScheme

Method Summary
void | addChildConcept(Concept concept) Adds a child Concept.
void | addChildConcepts(Collection concepts) Adds a Collection of Concept children.
int | getChildConceptCount() Gets number of children.
Collection | getChildrenConcepts() Gets all immediate children Concepts.
ClassificationScheme | getClassificationScheme() Gets the ClassificationScheme that this Concept is a descendent of.
Collection | getDescendantConcepts() Gets all descendant Concepts.
RegistryObject | getParent() Gets the parent Concept or ClassificationScheme for this object.
Concept | getParentConcept() Gets the parent Concept or null if parent is a ClassificationScheme.
String | getPath() Gets the canonical path representation for this Concept.
String | getValue() Gets the value (usually a code in a taxonomy) associated with this Concept.
void | removeChildConcept(Concept concept) Removes a child Concept.
void | removeChildConcepts(Collection concepts) Removes a Collection of children Concepts.
void | setValue(String value) Sets the value (usually a taxonomy value) associated with this Concept.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getValue

public String getValue()
                throws JAXRException
Gets the value (usually a code in a taxonomy) associated with this Concept.

Capability Level: 0

Returns:
the value (usually a taxonomy value) associated with this Concept
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

public void setValue(String value)
              throws JAXRException
Sets the value (usually a taxonomy value) associated with this Concept.

Capability Level: 0

Parameters:
value - the value (usually a taxonomy value) associated with this Concept
Throws:
JAXRException - If the JAXR provider encounters an internal error

addChildConcept

public void addChildConcept(Concept concept)
                     throws JAXRException
Adds a child Concept.

Capability Level: 0

Parameters:
concept - the concept being added as a child of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addChildConcepts

public void addChildConcepts(Collection concepts)
                      throws JAXRException
Adds a Collection of Concept children.

Capability Level: 0

Parameters:
concepts - the Collection of Concepts being added as a children of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildConcept

public void removeChildConcept(Concept concept)
                        throws JAXRException
Removes a child Concept.

Capability Level: 0

Parameters:
concept - the concept being removed as a child Concept of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildConcepts

public void removeChildConcepts(Collection concepts)
                         throws JAXRException
Removes a Collection of children Concepts.

Capability Level: 0

Parameters:
concepts - the Collection of Concepts being removed as children Concepts of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildConceptCount

public int getChildConceptCount()
                         throws JAXRException
Gets number of children.

Capability Level: 0

Returns:
the number of children Concepts
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildrenConcepts

public Collection getChildrenConcepts()
                               throws JAXRException
Gets all immediate children Concepts.

Capability Level: 0

Returns:
Collection of Concept instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Concept

getDescendantConcepts

public Collection getDescendantConcepts()
                                 throws JAXRException
Gets all descendant Concepts.

Capability Level: 0

Returns:
Collection of Concept instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Concept

getParentConcept

public Concept getParentConcept()
                         throws JAXRException
Gets the parent Concept or null if parent is a ClassificationScheme.

Capability Level: 0

Returns:
the Concept that is the parent of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getClassificationScheme

public ClassificationScheme getClassificationScheme()
                                             throws JAXRException
Gets the ClassificationScheme that this Concept is a descendent of.

Capability Level: 0

Returns:
the ClassificationScheme that is the ancestor of this object. May return null
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPath

public String getPath()
               throws JAXRException
Gets the canonical path representation for this Concept.

Capability Level: 0

Returns:
the canonical path String representing this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getParent

public RegistryObject getParent()
                         throws JAXRException
Gets the parent Concept or ClassificationScheme for this object.

Capability Level: 0

Returns:
the parent Concept or ClassificationScheme for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


EmailAddress

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface EmailAddress

public interface EmailAddress

Represents an email address.

Author:
Farrukh S. Najmi
See Also:
User

Method Summary
String | getAddress() Returns the email address for this object.
String | getType() Gets the type for this object.
void | setAddress(String address) Sets the email address for this object.
void | setType(String type) Sets the type for this object.

Method Detail

getAddress

public String getAddress()
                  throws JAXRException
Returns the email address for this object. Default is a NULL String.

Capability Level: 0

Returns:
the actual email address (e.g. john.doe@acme.com)
Throws:
JAXRException - If the JAXR provider encounters an internal error

setAddress

public void setAddress(String address)
                throws JAXRException
Sets the email address for this object.

Capability Level: 0

Parameters:
address - the actual email address (e.g. john.doe@acme.com)
Throws:
JAXRException - If the JAXR provider encounters an internal error

getType

public String getType()
               throws JAXRException
Gets the type for this object. Default is a NULL String.

Capability Level: 0

Returns:
the usage type for this object which is an arbitrary value (e.g. "Home" or "Office")
Throws:
JAXRException - If the JAXR provider encounters an internal error

setType

public void setType(String type)
             throws JAXRException
Sets the type for this object.

Capability Level: 0

Parameters:
type - the usage type for this object which is an arbitrary value (e.g. "Home" or "Office")
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ExtensibleObject

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ExtensibleObject

All Known Subinterfaces:
Association, AuditableEvent, Classification, ClassificationScheme, Concept, ExternalIdentifier, ExternalLink, ExtrinsicObject, Organization, PostalAddress, RegistryEntry, RegistryObject, RegistryPackage, Service, ServiceBinding, SpecificationLink, User
public interface ExtensibleObject

An ExtensibleObject is one that allows itself to be extended by utilizing dynamically added Slots that add arbitrary attributes to the object on a per instance basis.

Author:
Farrukh S. Najmi
See Also:
Slot

Method Summary
void | addSlot(Slot slot) Adds a Slot to this object.
void | addSlots(Collection slots) Adds more Slots to this object.
Slot | getSlot(String slotName) Gets the slot specified by slotName.
Collection | getSlots() Returns the Slots associated with this object.
void | removeSlot(String slotName) Removes a Slot from this object.
void | removeSlots(Collection slotNames) Removes specified Slots from this object.

Method Detail

addSlot

public void addSlot(Slot slot)
             throws JAXRException
Adds a Slot to this object.

Capability Level: 0

Parameters:
slot - the Slot object being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addSlots

public void addSlots(Collection slots)
              throws JAXRException
Adds more Slots to this object.

Capability Level: 0

Parameters:
slots - the Collection of Slot objects being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeSlot

public void removeSlot(String slotName)
                throws JAXRException
Removes a Slot from this object. The Slot is identified by its name.

Capability Level: 0

Parameters:
slotName - the name for the Slot object being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeSlots

public void removeSlots(Collection slotNames)
                 throws JAXRException
Removes specified Slots from this object. The Slots are identified by its name.

Capability Level: 0

Parameters:
slotNames - the Collection of names for Slot objects being removed from this object. Must be a Collection of Strings
Throws:
JAXRException - If the JAXR provider encounters an internal error

getSlot

public Slot getSlot(String slotName)
             throws JAXRException
Gets the slot specified by slotName.

Capability Level: 0

Parameters:
slotName - the name of the desired Slot object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getSlots

public Collection getSlots()
                    throws JAXRException
Returns the Slots associated with this object.

Capability Level: 0

Returns:
Collection of Slot instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ExternalIdentifier

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ExternalIdentifier

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface ExternalIdentifier
extends RegistryObject

ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization. The attribute name inherited from RegistryObject is used to contain the identification scheme ("DUNS" "Social Security Number", etc.), and the attribute value contains the actual information (e.g. the actual DUNS number). Each RegistryObject may have 0 or more ExternalIdentifiers.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Method Summary
ClassificationScheme | getIdentificationScheme() Gets the ClassificationScheme that is used as the identification scheme for identifying this object.
RegistryObject | getRegistryObject() Gets the parent RegistryObject for this ExternalIdentifier.
String | getValue() Gets the value of an ExternalIdentifier.
void | setIdentificationScheme(ClassificationScheme identificationScheme) Sets the ClassificationScheme that is used as the identification scheme for identifying this object.
void | setValue(String value) Sets the value of an ExternalIdentifier.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getRegistryObject

public RegistryObject getRegistryObject()
                                 throws JAXRException
Gets the parent RegistryObject for this ExternalIdentifier. To set the registryObject call addExternalIdentifier on a RegistryObject.

Capability Level: 0

Returns:
the RegistryObject that this object identifies
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryObject.addExternalIdentifier(ExternalIdentifier ei)

getValue

public String getValue()
                throws JAXRException
Gets the value of an ExternalIdentifier.

Capability Level: 0

Returns:
the identification value defined by this object (e.g. a company's DUNS number)
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

public void setValue(String value)
              throws JAXRException
Sets the value of an ExternalIdentifier.

Capability Level: 0

Parameters:
value - the identification value defined by this object (e.g. a company's DUNS number)
Throws:
JAXRException - If the JAXR provider encounters an internal error

getIdentificationScheme

public ClassificationScheme getIdentificationScheme()
                                             throws JAXRException
Gets the ClassificationScheme that is used as the identification scheme for identifying this object.

Capability Level: 0

Returns:
the ClassificationScheme that is used as the identification scheme (e.g. "DUNS")
Throws:
JAXRException - If the JAXR provider encounters an internal error

setIdentificationScheme

public void setIdentificationScheme(ClassificationScheme identificationScheme)
                             throws JAXRException
Sets the ClassificationScheme that is used as the identification scheme for identifying this object.

Capability Level: 0

Parameters:
identificationScheme - the ClassificationScheme that is used as the identification scheme (e.g. "DUNS")
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ExternalLink

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ExternalLink

All Superinterfaces:
ExtensibleObject, RegistryObject, URIValidator
public interface ExternalLink
extends RegistryObject, URIValidator

ExternalLink instances model a named URI to content that may reside outside the registry. RegistryObject may be associated with any number of ExternalLinks to annotate a RegistryObject with external links to external content.

Consider the case where a Submitting Organization submits a repository item (e.g. a DTD) and wants to associate some external content to that object (e.g. the Submitting Organization's home page). The ExternalLink enables this capability.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Method Summary
String | getExternalURI() Gets URI to the an external resource.
Collection | getLinkedObjects() Gets the collection of RegistryObjects that are annotated by this ExternalLink.
void | setExternalURI(String uri) Sets URI for an external resource.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.URIValidator
getValidateURI, setValidateURI

Method Detail

getLinkedObjects

public Collection getLinkedObjects()
                            throws JAXRException
Gets the collection of RegistryObjects that are annotated by this ExternalLink.

Capability Level: 0

Returns:
Collection of RegistryObjects. Return an empty Collection if no RegistryObjects are annotated by this object.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getExternalURI

public String getExternalURI()
                      throws JAXRException
Gets URI to the an external resource. Default is a NULL String.

Capability Level: 0

Returns:
the URI String for this object (e.g. "http://java.sun.com")
Throws:
JAXRException - If the JAXR provider encounters an internal error

setExternalURI

public void setExternalURI(String uri)
                    throws JAXRException
Sets URI for an external resource.

Capability Level: 0

Parameters:
uri - the URI String for this object (e.g. "http://java.sun.com")
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ExtrinsicObject

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ExtrinsicObject

All Superinterfaces:
ExtensibleObject, RegistryEntry, RegistryObject, Versionable
public interface ExtrinsicObject
extends RegistryEntry

ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).

Examples of content described by ExtrinsicObject include Collaboration Protocol Profiles (CPP), business process descriptions, and schemas.

Author:
Farrukh S. Najmi

Field Summary
Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry
STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN
Method Summary
String | getMimeType() Gets the mime type associated with this object.
DataHandler | getRepositoryItem() Gets the repository item for this object.
boolean | isOpaque() Determines whether the ExtrinsicObject is opaque (not readable) by the registry operator.
void | setMimeType(String mimeType) Sets the mime type associated with this object.
void | setOpaque(boolean isOpaque) Sets whether the ExtrinsicObject is opaque (not readable) by the registry.
void | setRepositoryItem(DataHandler repositoryItem) Sets the repository item for this object.
Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry
getExpiration, getStability, getStatus, setExpiration, setStability
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.Versionable
getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

Method Detail

getMimeType

public String getMimeType()
                   throws JAXRException
Gets the mime type associated with this object. Default is a NULL String.

Capability Level: 1

Returns:
the mime type associated with this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setMimeType

public void setMimeType(String mimeType)
                 throws JAXRException
Sets the mime type associated with this object.

Capability Level: 1

Parameters:
mimeType - the mime type associated with this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

isOpaque

public boolean isOpaque()
                 throws JAXRException
Determines whether the ExtrinsicObject is opaque (not readable) by the registry operator.

In some situations, a Submitting Organization may submit content that is encrypted and not even readable by the registry. This attribute allows the registry to know whether this is the case.

Capability Level: 1

Returns:
true if the ExtrinsicObject is readable by the registry operator; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

setOpaque

public void setOpaque(boolean isOpaque)
               throws JAXRException
Sets whether the ExtrinsicObject is opaque (not readable) by the registry.

Capability Level: 1

Parameters:
isOpaque - boolean value set to true if the ExtrinsicObject is readable by the registry operator; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRepositoryItem

public DataHandler getRepositoryItem()
                              throws JAXRException
Gets the repository item for this object. Must not return null.

Capability Level: 1

Returns:
the DataHandler for the repository item
Throws:
JAXRException - If the JAXR provider encounters an internal error

setRepositoryItem

public void setRepositoryItem(DataHandler repositoryItem)
                       throws JAXRException
Sets the repository item for this object.

Capability Level: 1

Parameters:
repositoryItem - the DataHandler for the repository item. Must not be null
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InternationalString

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface InternationalString

public interface InternationalString

This interface represents a String that has been internationalized into several Locales. This interface is used as a replacement for the String type whenever a String attribute needs to be I18N capable. An instance of the InternationalString interface composes within it a Collection of LocalizedString instances, where each String is specific to a particular Locale. The InternationalString interface provides set/get methods for adding or getting locale specific String values for the InternationalString instance.

Author:
Farrukh S. Najmi
See Also:
LocalizedString

Method Summary
 void addLocalizedString(LocalizedString localizedString)
Adds a LocalizedString to this object.
 void addLocalizedStrings(Collection localizedStrings)
Adds many LocalizedStrings to this object.
 LocalizedString getLocalizedString(Locale locale, String charsetName)
Gets the LocalizedString for the specified Locale and charsetName.
 Collection getLocalizedStrings()
Returns the LocalizedStrings associated with this object.
 String getValue()
Gets the String value for the Locale returned by Locale.getDefault().
 String getValue(Locale locale)
Gets the String value for the specified Locale.
 void removeLocalizedString(LocalizedString localizedString)
Removes a LocalizedString from this object.
 void removeLocalizedStrings(Collection localizedStrings)
Removes specified LocalizedStrings to this object.
 void setValue(Locale locale, String value)
Sets the String value for the specified Locale.
 void setValue(String value)
Sets the String value for the Locale returned by Locale.getDefault().

Method Detail

getValue

public String getValue()
                throws JAXRException
Gets the String value for the Locale returned by Locale.getDefault().

Capability Level: 0

Returns:
the String value for the Locale returned by Locale.getDefault()
Throws:
JAXRException - If the JAXR provider encounters an internal error

getValue

public String getValue(Locale locale)
                throws JAXRException
Gets the String value for the specified Locale. Return null if no locale specific value is found for the specified locale.

Capability Level: 0

Parameters:
locale - The Locale for the desired value
Returns:
the String value for the specified Locale
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

public void setValue(String value)
              throws JAXRException
Sets the String value for the Locale returned by Locale.getDefault().

Capability Level: 0

Parameters:
value - the String value for the Locale returned by Locale.getDefault()
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

public void setValue(Locale locale,
                     String value)
              throws JAXRException
Sets the String value for the specified Locale.

Capability Level: 0

Parameters:
locale - The locale for this value being set
value - The value being set
Throws:
JAXRException - If the JAXR provider encounters an internal error

addLocalizedString

public void addLocalizedString(LocalizedString localizedString)
                        throws JAXRException
Adds a LocalizedString to this object.

Capability Level: 0

Parameters:
localizedString - the LocalizedString being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addLocalizedStrings

public void addLocalizedStrings(Collection localizedStrings)
                         throws JAXRException
Adds many LocalizedStrings to this object.

Capability Level: 0

Parameters:
localizedStrings - the Collection of LocalizedStrings being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeLocalizedString

public void removeLocalizedString(LocalizedString localizedString)
                           throws JAXRException
Removes a LocalizedString from this object.

Capability Level: 0

Parameters:
localizedString - the LocalizedString being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeLocalizedStrings

public void removeLocalizedStrings(Collection localizedStrings)
                            throws JAXRException
Removes specified LocalizedStrings to this object.

Capability Level: 0

Parameters:
localizedStrings - the Collection of LocalizedStrings being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getLocalizedString

public LocalizedString getLocalizedString(Locale locale,
                                          String charsetName)
                                   throws JAXRException
Gets the LocalizedString for the specified Locale and charsetName.

Capability Level: 0

Parameters:
locale - The loacle for the desired LocalizedStrings
charsetName - The character set name for the desired LocalizedStrings
Returns:
the LocalizedString that matches specified locale and character set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getLocalizedStrings

public Collection getLocalizedStrings()
                               throws JAXRException
Returns the LocalizedStrings associated with this object.

Capability Level: 0

Returns:
Collection of LocalizedString instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
LocalizedString
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Key

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Key

public interface Key

Represents a unique key that identifies a RegistryObject. Must be a DCE 128 UUID.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Method Summary
String | getId() Returns the unique Id of this key.
void | setId(String id) Sets the unique id associated with this key.

Method Detail

getId

public String getId()
             throws JAXRException
Returns the unique Id of this key. Default is a NULL String.

Capability Level: 0

Returns:
the id for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setId

public void setId(String id)
           throws JAXRException
Sets the unique id associated with this key.

Capability Level: 0

Parameters:
id - the id being defined for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


LocalizedString

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface LocalizedString

public interface LocalizedString

This interface is used as a simple wrapper interface that associates a String with its Locale. The interface is needed in the InternationalString interface where a Collection of LocalizedString instances are kept. Each LocalizedString instance has a Locale and a String instance.

Author:
Farrukh S. Najmi
See Also:
InternationalString

Field Summary
static String DEFAULT_CHARSET_NAME
The default name returned by getCharsetName if no other name has explicitly been set.
Method Summary
String | getCharsetName() Gets the canonical name for the charset for this object.
Locale | getLocale() Get the Locale for this object.
String | getValue() Get the String value for this object.
void | setCharsetName(String charsetName) Set the canonical name for the charset for this object.
void | setLocale(Locale locale) Set the Locale for this object.
void | setValue(String value) Set the String value for the specified object.

Field Detail

DEFAULT_CHARSET_NAME

public static final String DEFAULT_CHARSET_NAME
The default name returned by getCharsetName if no other name has explicitly been set.

See Also:
Constant Field Values
Method Detail

getCharsetName

public String getCharsetName()
                      throws JAXRException
Gets the canonical name for the charset for this object. Must return the default charset when there is no charset name defined.

Capability Level: 0

Returns:
the character set name for the character set used by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
DEFAULT_CHARSET_NAME

getLocale

public Locale getLocale()
                 throws JAXRException
Get the Locale for this object. Must return the default Locale when no Locale has been defined.

Capability Level: 0

Returns:
the Locale used by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Locale.getDefault()

getValue

public String getValue()
                throws JAXRException
Get the String value for this object.

Capability Level: 0

Returns:
the value defined by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setCharsetName

public void setCharsetName(String charsetName)
                    throws JAXRException
Set the canonical name for the charset for this object.

Capability Level: 0

Parameters:
charsetName - the character set name for the character set used by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setLocale

public void setLocale(Locale locale)
               throws JAXRException
Set the Locale for this object.

Capability Level: 0

Parameters:
locale - the Locale used by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

public void setValue(String value)
              throws JAXRException
Set the String value for the specified object.

Capability Level: 0

Parameters:
value - the value defined by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Organization

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Organization

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface Organization
extends RegistryObject

Organization instances provide information on organizations such as a Submitting Organization. Each Organization instance may have a reference to a parent Organization. In addition it may have a contact attribute defining the primary contact within the organization. An Organization also has an address attribute.

Author:
Farrukh S. Najmi
See Also:
Service

Method Summary
void | addChildOrganization(Organization organization) Adds a child Organization.
void | addChildOrganizations(Collection organizations) Adds a Collection of Organization children.
void | addService(Service service) Adds a child Service.
void | addServices(Collection services) Adds a Collection of Service children.
void | addUser(User user) Adds a User.
void | addUsers(Collection users) Adds a Collection of Users.
int | getChildOrganizationCount() Gets number of children.
Collection | getChildOrganizations() Gets all immediate children Organizations.
Collection | getDescendantOrganizations() Gets all descendant Organizations.
Organization | getParentOrganization() Gets the parent (container) organization.
PostalAddress | getPostalAddress() Gets the Address for this Organization.
User | getPrimaryContact() Gets the primary Contact for this Organization.
Organization | getRootOrganization() Gets the root organization.
Collection | getServices() Gets all children Services.
Collection | getTelephoneNumbers(String phoneType) Gets the telephone numbers for this User that match the specified telephone number type.
Collection | getUsers() Gets the Collection of Users affiliated with this Organization.
void | removeChildOrganization(Organization organization) Removes a child Organization.
void | removeChildOrganizations(Collection organizations) Removes a Collection of children Organizations.
void | removeService(Service service) Removes a Service from this object.
void | removeServices(Collection services) Removes a Collection of children Services from this object.
void | removeUser(User user) Removes a User.
void | removeUsers(Collection users) Removes a Collection of Users.
void | setPostalAddress(PostalAddress address) Sets the address for this Organization.
void | setPrimaryContact(User primaryContact) Sets the primary contact for this Organization.
void | setTelephoneNumbers(Collection phoneNumbers) Sets the various telephone numbers for this user.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getPostalAddress

public PostalAddress getPostalAddress()
                               throws JAXRException
Gets the Address for this Organization.

Capability Level: 1

Returns:
the PostalAddress for this Organization
Throws:
JAXRException - If the JAXR provider encounters an internal error

setPostalAddress

public void setPostalAddress(PostalAddress address)
                      throws JAXRException
Sets the address for this Organization.

Capability Level: 1

Parameters:
address - the PostalAddress for this Organization
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPrimaryContact

public User getPrimaryContact()
                       throws JAXRException
Gets the primary Contact for this Organization. The primary contact is one of the Users of the Organization, as returned by the getUsers call on an Organization instance.

Capability Level: 0

Returns:
the User that is the primary Contact for this Organization. Must not be null
Throws:
JAXRException - If the JAXR provider encounters an internal error

setPrimaryContact

public void setPrimaryContact(User primaryContact)
                       throws JAXRException
Sets the primary contact for this Organization. If the primary contact is not in the existing Collection of User instances for this object then it must be added to that Collection. If the primary contact is already in the existing Collection of User instances for this object, then it should not be added to the Users collection as a duplicate entry. In either case, the primary contact is a distinguished User instance within the Collection of User instances for this Object.

Capability Level: 0

Parameters:
primaryContact - the User that is the primary Contact for this Organization
Throws:
JAXRException - If the JAXR provider encounters an internal error

addUser

public void addUser(User user)
             throws JAXRException
Adds a User.

Capability Level: 0

Parameters:
user - the User being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addUsers

public void addUsers(Collection users)
              throws JAXRException
Adds a Collection of Users.

Capability Level: 0

Parameters:
users - the Collection of Users being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeUser

public void removeUser(User user)
                throws JAXRException
Removes a User.

Capability Level: 0

Parameters:
user - the User being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeUsers

public void removeUsers(Collection users)
                 throws JAXRException
Removes a Collection of Users.

Capability Level: 0

Parameters:
users - the Collection of Users being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUsers

public Collection getUsers()
                    throws JAXRException
Gets the Collection of Users affiliated with this Organization. One of these users is designated as the primary contact.

Capability Level: 0

Returns:
Collection of User instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
User

getTelephoneNumbers

public Collection getTelephoneNumbers(String phoneType)
                               throws JAXRException
Gets the telephone numbers for this User that match the specified telephone number type. If phoneType is null return all telephoneNumbers.

Capability Level: 0

Parameters:
phoneType - a String that specifies the type of phone numbers desired
Returns:
Collection of TelephoneNumber instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
TelephoneNumber

setTelephoneNumbers

public void setTelephoneNumbers(Collection phoneNumbers)
                         throws JAXRException
Sets the various telephone numbers for this user.

Capability Level: 0

Parameters:
phoneNumbers - the TelephoneNumbers being set for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addService

public void addService(Service service)
                throws JAXRException
Adds a child Service.

Capability Level: 0

Parameters:
service - the Service being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addServices

public void addServices(Collection services)
                 throws JAXRException
Adds a Collection of Service children.

Capability Level: 0

Parameters:
services - the Collection of Services being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeService

public void removeService(Service service)
                   throws JAXRException
Removes a Service from this object.

Capability Level: 0

Parameters:
service - the Service being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeServices

public void removeServices(Collection services)
                    throws JAXRException
Removes a Collection of children Services from this object.

Capability Level: 0

Parameters:
services - the Collection of Services being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getServices

public Collection getServices()
                       throws JAXRException
Gets all children Services.

Capability Level: 0

Returns:
Collection of Service instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Service

addChildOrganization

public void addChildOrganization(Organization organization)
                          throws JAXRException
Adds a child Organization.

Capability Level: 1

Parameters:
organization - the child Organization being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addChildOrganizations

public void addChildOrganizations(Collection organizations)
                           throws JAXRException
Adds a Collection of Organization children.

Capability Level: 1

Parameters:
organizations - the Collection of child Organizations being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildOrganization

public void removeChildOrganization(Organization organization)
                             throws JAXRException
Removes a child Organization.

Capability Level: 1

Parameters:
organization - the child Organization being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildOrganizations

public void removeChildOrganizations(Collection organizations)
                              throws JAXRException
Removes a Collection of children Organizations.

Capability Level: 1

Parameters:
organizations - the Collection of child Organizations being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildOrganizationCount

public int getChildOrganizationCount()
                              throws JAXRException
Gets number of children.

Capability Level: 1

Returns:
the number of children Organizations
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildOrganizations

public Collection getChildOrganizations()
                                 throws JAXRException
Gets all immediate children Organizations.

Capability Level: 1

Returns:
Collection of Organization instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Organization

getDescendantOrganizations

public Collection getDescendantOrganizations()
                                      throws JAXRException
Gets all descendant Organizations.

Capability Level: 1

Returns:
Collection of Organization instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Organization

getParentOrganization

public Organization getParentOrganization()
                                   throws JAXRException
Gets the parent (container) organization.

Capability Level: 1

Returns:
the parent Organization or null if object has no parent Organization
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRootOrganization

public Organization getRootOrganization()
                                 throws JAXRException
Gets the root organization.

Capability Level: 1

Returns:
the root Organization or null if object has no parent Organization
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PersonName

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface PersonName

public interface PersonName

Represents a person's name.

Author:
Farrukh S. Najmi

Method Summary
String | getFirstName() Gets the first name for this Person.
String | getFullName() Gets the fully formatted name for this person.
String | getLastName() Gets the last name (surname) for this Person.
String | getMiddleName() Gets the middle name for this Person.
void | setFirstName(String firstName) Sets the first name for this Person.
void | setFullName(String fullName) Sets the fully formatted name for this person.
void | setLastName(String lastName) Sets the last name (surname) for this Person.
void | setMiddleName(String middleName) Sets the middle name for this Person.

Method Detail

getLastName

public String getLastName()
                   throws JAXRException
Gets the last name (surname) for this Person. Default is a NULL String.

Capability Level: 1

Returns:
the person's last name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setLastName

public void setLastName(String lastName)
                 throws JAXRException
Sets the last name (surname) for this Person.

Capability Level: 1

Parameters:
lastName - the person's last name
Throws:
JAXRException - If the JAXR provider encounters an internal error

getFirstName

public String getFirstName()
                    throws JAXRException
Gets the first name for this Person. Default is an empty String.

Capability Level: 1

Returns:
the person's first name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setFirstName

public void setFirstName(String firstName)
                  throws JAXRException
Sets the first name for this Person.

Capability Level: 1

Parameters:
firstName - the person's first name
Throws:
JAXRException - If the JAXR provider encounters an internal error

getMiddleName

public String getMiddleName()
                     throws JAXRException
Gets the middle name for this Person. Default is an empty String.

Capability Level: 1

Returns:
the person's middle name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setMiddleName

public void setMiddleName(String middleName)
                   throws JAXRException
Sets the middle name for this Person.

Capability Level: 1

Parameters:
middleName - the person's middle name
Throws:
JAXRException - If the JAXR provider encounters an internal error

getFullName

public String getFullName()
                   throws JAXRException
Gets the fully formatted name for this person. Default is an empty String.

Capability Level: 0

Returns:
the person's full name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setFullName

public void setFullName(String fullName)
                 throws JAXRException
Sets the fully formatted name for this person.

Capability Level: 0

Parameters:
fullName - the person's full name
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


PostalAddress

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface PostalAddress

All Superinterfaces:
ExtensibleObject
public interface PostalAddress
extends ExtensibleObject

PostalAddress is a simple re-usable entity class that defines attributes of a postal Address.

Author:
Farrukh S. Najmi

Method Summary
String | getCity() Returns the city.
String | getCountry() Returns the country.
String | getPostalCode() Returns the postal or zip code.
ClassificationScheme | getPostalScheme() Returns a user-defined postal scheme for codifying the attributes of PostalAddress.
String | getStateOrProvince() Returns the state or province.
String | getStreet() Returns the street name.
String | getStreetNumber() Returns the street number.
String | getType() Returns the type of address (for example, "headquarters") as a String.
void | setCity(String city) Sets the city.
void | setCountry(String country) Sets the country.
void | setPostalCode(String postalCode) Sets the postal or zip code.
void | setPostalScheme(ClassificationScheme scheme) Sets a user-defined postal scheme for codifying the attributes of PostalAddress.
void | setStateOrProvince(String stateOrProvince) Sets the state or province.
void | setStreet(String street) Sets the street name.
void | setStreetNumber(String streetNumber) Sets the street number.
void | setType(String type) Sets the type of address (for example, "headquarters") as a String.
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getStreet

public String getStreet()
                 throws JAXRException
Returns the street name. Default is an empty String.

Capability Level: 0

Returns:
the street name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setStreet

public void setStreet(String street)
               throws JAXRException
Sets the street name.

Capability Level: 0

Parameters:
street - the street name
Throws:
JAXRException - If the JAXR provider encounters an internal error

getStreetNumber

public String getStreetNumber()
                       throws JAXRException
Returns the street number. Default is an empty String.

Capability Level: 0

Returns:
the street number
Throws:
JAXRException - If the JAXR provider encounters an internal error

setStreetNumber

public void setStreetNumber(String streetNumber)
                     throws JAXRException
Sets the street number.

Capability Level: 0

Parameters:
streetNumber - the street number
Throws:
JAXRException - If the JAXR provider encounters an internal error

getCity

public String getCity()
               throws JAXRException
Returns the city. Default is an empty String.

Capability Level: 0

Returns:
the city
Throws:
JAXRException - If the JAXR provider encounters an internal error

setCity

public void setCity(String city)
             throws JAXRException
Sets the city.

Capability Level: 0

Parameters:
city - the city
Throws:
JAXRException - If the JAXR provider encounters an internal error

getStateOrProvince

public String getStateOrProvince()
                          throws JAXRException
Returns the state or province. Default is an empty String.

Capability Level: 0

Returns:
the state or province
Throws:
JAXRException - If the JAXR provider encounters an internal error

setStateOrProvince

public void setStateOrProvince(String stateOrProvince)
                        throws JAXRException
Sets the state or province.

Capability Level: 0

Parameters:
stateOrProvince - the state or province
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPostalCode

public String getPostalCode()
                     throws JAXRException
Returns the postal or zip code. Default is an empty String.

Capability Level: 0

Returns:
the postal code (e.g. US zip code)
Throws:
JAXRException - If the JAXR provider encounters an internal error

setPostalCode

public void setPostalCode(String postalCode)
                   throws JAXRException
Sets the postal or zip code.

Capability Level: 0

Parameters:
postalCode - the postal code (e.g. US zip code)
Throws:
JAXRException - If the JAXR provider encounters an internal error

getCountry

public String getCountry()
                  throws JAXRException
Returns the country. Default is an empty String.

Capability Level: 0

Returns:
the country
Throws:
JAXRException - If the JAXR provider encounters an internal error

setCountry

public void setCountry(String country)
                throws JAXRException
Sets the country.

Capability Level: 0

Parameters:
country - the country
Throws:
JAXRException - If the JAXR provider encounters an internal error

getType

public String getType()
               throws JAXRException
Returns the type of address (for example, "headquarters") as a String.

Capability Level: 0

Returns:
the type for this PostalAddress. This is an arbitrary String (e.g. "Home", "Office")
Throws:
JAXRException - If the JAXR provider encounters an internal error

setType

public void setType(String type)
             throws JAXRException
Sets the type of address (for example, "headquarters") as a String.

Capability Level: 0

Parameters:
type - the type for this PostalAddress. This is an arbitrary String (e.g. "Home", "Office")
Throws:
JAXRException - If the JAXR provider encounters an internal error

setPostalScheme

public void setPostalScheme(ClassificationScheme scheme)
                     throws JAXRException
Sets a user-defined postal scheme for codifying the attributes of PostalAddress.

Capability Level: 0

Parameters:
scheme - the user defined postal scheme.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPostalScheme

public ClassificationScheme getPostalScheme()
                                     throws JAXRException
Returns a user-defined postal scheme for codifying the attributes of PostalAddress. If none is defined for this object, then must return the default value returned by RegistryService#getDefaultPostalScheme()

Capability Level: 0

Returns:
the user defined postal scheme.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryService.getDefaultPostalScheme()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RegistryEntry

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface RegistryEntry

All Superinterfaces:
ExtensibleObject, RegistryObject, Versionable
All Known Subinterfaces:
ClassificationScheme, ExtrinsicObject, RegistryPackage, Service
public interface RegistryEntry
extends RegistryObject, Versionable

The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface. A few interfaces in the model represent high level (coarse grain) objects in the registry that require additional metadata such as version information and indication of the stability or volatility of the information.

Author:
Farrukh S. Najmi

Field Summary
static int | STABILITY_DYNAMIC RegistryEntry may change at any time.
static int | STABILITY_DYNAMIC_COMPATIBLE RegistryEntry may change at any time, however the changes will be backward compatible.
static int | STABILITY_STATIC RegistryEntry will not change.
static int | STATUS_APPROVED RegistryEntry has been submitted and approved.
static int | STATUS_DEPRECATED RegistryEntry has been deprecated.
static int | STATUS_SUBMITTED RegistryEntry has been submitted.
static int | STATUS_WITHDRAWN RegistryEntry has been withdrawn by the submitter.
Method Summary
Date | getExpiration() Gets expirationDate attribute of the RegistryEntry within the Registry.
int | getStability() Gets the stability indicator for the RegistryEntry within the Registry.
int | getStatus() Gets the life cycle status of the RegistryEntry within the registry.
void | setExpiration(Date expiration) Sets the expirationDate.
void | setStability(int stability) Sets the stability indicator for the RegistryEntry.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.Versionable
getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

Field Detail

STATUS_SUBMITTED

public static final int STATUS_SUBMITTED
RegistryEntry has been submitted.

See Also:
Constant Field Values

STATUS_APPROVED

public static final int STATUS_APPROVED
RegistryEntry has been submitted and approved.

See Also:
Constant Field Values

STATUS_DEPRECATED

public static final int STATUS_DEPRECATED
RegistryEntry has been deprecated.

See Also:
Constant Field Values

STATUS_WITHDRAWN

public static final int STATUS_WITHDRAWN
RegistryEntry has been withdrawn by the submitter.

See Also:
Constant Field Values

STABILITY_DYNAMIC

public static final int STABILITY_DYNAMIC
RegistryEntry may change at any time.

See Also:
Constant Field Values

STABILITY_DYNAMIC_COMPATIBLE

public static final int STABILITY_DYNAMIC_COMPATIBLE
RegistryEntry may change at any time, however the changes will be backward compatible.

See Also:
Constant Field Values

STABILITY_STATIC

public static final int STABILITY_STATIC
RegistryEntry will not change.

See Also:
Constant Field Values
Method Detail

getStatus

public int getStatus()
              throws JAXRException
Gets the life cycle status of the RegistryEntry within the registry.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
the life cycle status as an integer enumeration
Throws:
JAXRException - If the JAXR provider encounters an internal error

getStability

public int getStability()
                 throws JAXRException
Gets the stability indicator for the RegistryEntry within the Registry. The stability indicator is provided by the submitter as an indication of the level of stability for the content.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
the stability indicator as an integer enumeration
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
STABILITY_DYNAMIC

setStability

public void setStability(int stability)
                  throws JAXRException
Sets the stability indicator for the RegistryEntry.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Parameters:
stability - the stability indicator
Throws:
JAXRException - If the JAXR provider encounters an internal error

getExpiration

public Date getExpiration()
                   throws JAXRException
Gets expirationDate attribute of the RegistryEntry within the Registry. This attribute defines a time limit upon the stability indication provided by the stability attribute. Once the expirationDate has been reached the stability attribute in effect becomes STABILITY_DYNAMIC implying that content can change at any time and in any manner. A null value implies that there is no expiration on stability attribute.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
the expiration Date for the stability indicator
Throws:
JAXRException - If the JAXR provider encounters an internal error

setExpiration

public void setExpiration(Date expiration)
                   throws JAXRException
Sets the expirationDate.

Capability Level: 1

Parameters:
expiration - the expiration Date for the stability indicator
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RegistryObject

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface RegistryObject

All Superinterfaces:
ExtensibleObject
All Known Subinterfaces:
Association, AuditableEvent, Classification, ClassificationScheme, Concept, ExternalIdentifier, ExternalLink, ExtrinsicObject, Organization, RegistryEntry, RegistryPackage, Service, ServiceBinding, SpecificationLink, User
public interface RegistryObject
extends ExtensibleObject

The RegistryObject class is an abstract base class used by most classes in the model. It provides minimal metadata for registry objects. It also provides methods for accessing related objects that provide additional dynamic metadata for the registry object.

Author:
Farrukh S. Najmi
See Also:
RegistryEntry

Method Summary
void | addAssociation(Association association) Adds specified Association to use this object as source.
void | addAssociations(Collection associations) Adds specified Associations to use this object as source.
void | addClassification(Classification classification) Adds specified Classification to this object.
void | addClassifications(Collection classifications) Adds specified Classifications to this object.
void | addExternalIdentifier(ExternalIdentifier externalIdentifier) Adds specified ExternalIdentifier as an external identifier to this object.
void | addExternalIdentifiers(Collection externalIdentifiers) Adds specified ExternalIdentifiers as an external identifiers to this object.
void | addExternalLink(ExternalLink externalLink) Adds specified ExternalLink to this object.
void | addExternalLinks(Collection externalLinks) Adds specified ExternalLinks to this object.
Collection | getAssociatedObjects() Returns the collection of RegistryObject instances associated with this object.
Collection | getAssociations() Gets all Associations where this object is source.
Collection | getAuditTrail() Returns the complete audit trail of all requests that effected a state change in this object as an ordered Collection of AuditableEvent objects.
Collection | getClassifications() Gets the Classification instances that classify this object.
InternationalString | getDescription() Gets the textual description for this object.
Collection | getExternalIdentifiers() Returns the ExternalIdentifiers associated with this object that are external identifiers for this object.
Collection | getExternalLinks() Returns the ExternalLinks associated with this object.
Key | getKey() Gets the key representing the universally unique ID (UUID) for this object.
LifeCycleManager | getLifeCycleManager() Returns the LifeCycleManager that created this object.
InternationalString | getName() Gets the user-friendly name of this object.
Concept | getObjectType() Gets the object type that best describes the RegistryObject.
Collection | getRegistryPackages() Returns the Package associated with this object.
Organization | getSubmittingOrganization() Gets the Organization that submitted this RegistryObject.
void | removeAssociation(Association association) Removes specified Association from this object.
void | removeAssociations(Collection associations) Removes specified Associations from this object.
void | removeClassification(Classification classification) Removes specified Classification from this object.
void | removeClassifications(Collection classifications) Removes specified Classifications from this object.
void | removeExternalIdentifier(ExternalIdentifier externalIdentifier) Removes specified ExternalIdentifier as an external identifier from this object.
void | removeExternalIdentifiers(Collection externalIdentifiers) Removes specified ExternalIdentifiers as an external identifiers from this object.
void | removeExternalLink(ExternalLink externalLink) Removes specified ExternalLink from this object.
void | removeExternalLinks(Collection externalLinks) Removes specified ExternalLinks from this object.
void | setAssociations(Collection associations) Replaces all previous Associations from this object with specified Associations.
void | setClassifications(Collection classifications) Replaces all previous Classifications with specified Classifications.
void | setDescription(InternationalString description) Sets the context independent textual description for this object.
void | setExternalIdentifiers(Collection externalIdentifiers) Replaces all previous external identifiers with specified Collection of ExternalIdentifiers as an external identifier.
void | setExternalLinks(Collection externalLinks) Replaces all previous ExternalLinks with specified ExternalLinks.
void | setKey(Key key) Sets the key representing the universally unique ID (UUID) for this object.
void | setName(InternationalString name) Sets user-friendly name of object in repository.
String | toXML() Returns a registry provider specific XML representation of this Object.
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getKey

public Key getKey()
           throws JAXRException
Gets the key representing the universally unique ID (UUID) for this object.

Capability Level: 0

Returns:
the Key for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getDescription

public InternationalString getDescription()
                                   throws JAXRException
Gets the textual description for this object.

Capability Level: 0

Returns:
the description for this object which must not be null
Throws:
JAXRException - If the JAXR provider encounters an internal error

setDescription

public void setDescription(InternationalString description)
                    throws JAXRException
Sets the context independent textual description for this object.

Capability Level: 0

Parameters:
description - the description for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getName

public InternationalString getName()
                            throws JAXRException
Gets the user-friendly name of this object.

Capability Level: 0

Returns:
the name for this object which must not be null.
Throws:
JAXRException - If the JAXR provider encounters an internal error

setName

public void setName(InternationalString name)
             throws JAXRException
Sets user-friendly name of object in repository.

Capability Level: 0

Parameters:
name - the name for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setKey

public void setKey(Key key)
            throws JAXRException
Sets the key representing the universally unique ID (UUID) for this object.

Capability Level: 0

Parameters:
key - the key for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

toXML

public String toXML()
             throws JAXRException
Returns a registry provider specific XML representation of this Object. This may be used as a last resort back door way to get to a provider specific information element that is not accessible via the API. Implementation may choose to throw a UnsupportedCapabilityException.

Capability Level: 0

Returns:
the String containing the XML representation for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addClassification

public void addClassification(Classification classification)
                       throws JAXRException
Adds specified Classification to this object. Silently replaces the classifiedObject in Classification with reference to this object.

Capability Level: 0

Parameters:
classification - the Classification being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addClassifications

public void addClassifications(Collection classifications)
                        throws JAXRException
Adds specified Classifications to this object. Silently replaces the classifiedObject in Classifications with reference to this object.

Capability Level: 0

Parameters:
classifications - the Collection of Classifications being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeClassification

public void removeClassification(Classification classification)
                          throws JAXRException
Removes specified Classification from this object.

Capability Level: 0

Parameters:
classification - the Classification being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeClassifications

public void removeClassifications(Collection classifications)
                           throws JAXRException
Removes specified Classifications from this object.

Capability Level: 0

Parameters:
classifications - the Collection of Classifications being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

setClassifications

public void setClassifications(Collection classifications)
                        throws JAXRException
Replaces all previous Classifications with specified Classifications.

Capability Level: 0

Parameters:
classifications - the Collection of Classifications being set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getClassifications

public Collection getClassifications()
                              throws JAXRException
Gets the Classification instances that classify this object.

Capability Level: 0

Returns:
Collection of Classification instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Classification

getAuditTrail

public Collection getAuditTrail()
                         throws JAXRException
Returns the complete audit trail of all requests that effected a state change in this object as an ordered Collection of AuditableEvent objects.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
Collection of AuditableEvent instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
AuditableEvent

addAssociation

public void addAssociation(Association association)
                    throws JAXRException
Adds specified Association to use this object as source. Silently replaces the sourceObject in Association with reference to this object.

Capability Level: 0

Parameters:
association - the Association being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addAssociations

public void addAssociations(Collection associations)
                     throws JAXRException
Adds specified Associations to use this object as source. Silently replaces the sourceObject in Associations with reference to this object.

Capability Level: 0

Parameters:
associations - the Collection of Associations being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeAssociation

public void removeAssociation(Association association)
                       throws JAXRException
Removes specified Association from this object.

Capability Level: 0

Parameters:
association - the Association being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeAssociations

public void removeAssociations(Collection associations)
                        throws JAXRException
Removes specified Associations from this object.

Capability Level: 0

Parameters:
associations - the Collection of Associations being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

setAssociations

public void setAssociations(Collection associations)
                     throws JAXRException
Replaces all previous Associations from this object with specified Associations.

Capability Level: 0

Parameters:
associations - the Collection of Associations being set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getAssociations

public Collection getAssociations()
                           throws JAXRException
Gets all Associations where this object is source.

Capability Level: 0

Returns:
Collection of Association instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Association

getAssociatedObjects

public Collection getAssociatedObjects()
                                throws JAXRException
Returns the collection of RegistryObject instances associated with this object.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
Collection of RegistryObject instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryObject

addExternalIdentifier

public void addExternalIdentifier(ExternalIdentifier externalIdentifier)
                           throws JAXRException
Adds specified ExternalIdentifier as an external identifier to this object. Silently replaces the registryObject in ExternalIdentifier with reference to this object.

Capability Level: 0

Parameters:
externalIdentifier - the ExternalIdentifier being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addExternalIdentifiers

public void addExternalIdentifiers(Collection externalIdentifiers)
                            throws JAXRException
Adds specified ExternalIdentifiers as an external identifiers to this object. Silently replaces the registryObject in ExternalIdentifiers with reference to this object.

Capability Level: 0

Parameters:
externalIdentifiers - the Collection of ExternalIdentifiers being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeExternalIdentifier

public void removeExternalIdentifier(ExternalIdentifier externalIdentifier)
                              throws JAXRException
Removes specified ExternalIdentifier as an external identifier from this object.

Capability Level: 0

Parameters:
externalIdentifier - the ExternalIdentifier being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeExternalIdentifiers

public void removeExternalIdentifiers(Collection externalIdentifiers)
                               throws JAXRException
Removes specified ExternalIdentifiers as an external identifiers from this object.

Capability Level: 0

Parameters:
externalIdentifiers - the Collection of ExternalIdentifiers being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

setExternalIdentifiers

public void setExternalIdentifiers(Collection externalIdentifiers)
                            throws JAXRException
Replaces all previous external identifiers with specified Collection of ExternalIdentifiers as an external identifier.

Capability Level: 0

Parameters:
externalIdentifiers - the Collection of ExternalIdentifiers being set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getExternalIdentifiers

public Collection getExternalIdentifiers()
                                  throws JAXRException
Returns the ExternalIdentifiers associated with this object that are external identifiers for this object.

Capability Level: 0

Returns:
Collection of ExternalIdentifier instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
ExternalIdentifier

addExternalLink

public void addExternalLink(ExternalLink externalLink)
                     throws JAXRException
Adds specified ExternalLink to this object.

Capability Level: 0

Throws:
JAXRException - If the JAXR provider encounters an internal error

addExternalLinks

public void addExternalLinks(Collection externalLinks)
                      throws JAXRException
Adds specified ExternalLinks to this object.

Capability Level: 0

Parameters:
externalLinks - the Collection of ExternalLinks being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeExternalLink

public void removeExternalLink(ExternalLink externalLink)
                        throws JAXRException
Removes specified ExternalLink from this object.

Capability Level: 0

Parameters:
externalLink - the ExternalLink being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeExternalLinks

public void removeExternalLinks(Collection externalLinks)
                         throws JAXRException
Removes specified ExternalLinks from this object.

Capability Level: 0

Parameters:
externalLinks - the Collection of ExternalLinks being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

setExternalLinks

public void setExternalLinks(Collection externalLinks)
                      throws JAXRException
Replaces all previous ExternalLinks with specified ExternalLinks.

Capability Level: 0

Throws:
JAXRException - If the JAXR provider encounters an internal error

getExternalLinks

public Collection getExternalLinks()
                            throws JAXRException
Returns the ExternalLinks associated with this object.

Capability Level: 0

Returns:
Collection of ExternalLink instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
ExternalLink

getObjectType

public Concept getObjectType()
                      throws JAXRException
Gets the object type that best describes the RegistryObject.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
the object type as a Concept within the pre-defined ClassificationScheme named ObjectType
Throws:
JAXRException - If the JAXR provider encounters an internal error

getSubmittingOrganization

public Organization getSubmittingOrganization()
                                       throws JAXRException
Gets the Organization that submitted this RegistryObject.

Returns:
the Organization that submitted this object to the registry
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryPackages

public Collection getRegistryPackages()
                               throws JAXRException
Returns the Package associated with this object.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
Collection of RegistryPackage instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryPackage

getLifeCycleManager

public LifeCycleManager getLifeCycleManager()
                                     throws JAXRException
Returns the LifeCycleManager that created this object.

Capability Level: 0

Returns:
the LifeCycleManager objet that created this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RegistryPackage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface RegistryPackage

All Superinterfaces:
ExtensibleObject, RegistryEntry, RegistryObject, Versionable
public interface RegistryPackage
extends RegistryEntry

RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together. A package may contain any number of RegistryObjects. A RegistryObject may be a member of any number of Packages.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Field Summary
Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry
STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN
Method Summary
void | addRegistryObject(RegistryObject registryObject) Adds a child RegistryObject as member.
void | addRegistryObjects(Collection registryObjects) Adds a Collection of RegistryObject children as members.
Set | getRegistryObjects() Gets the collection of member RegistryObjects of this RegistryPackage.
void | removeRegistryObject(RegistryObject registryObject) Removes a child RegistryObject from membership.
void | removeRegistryObjects(Collection registryObjects) Removes a Collection of children RegistryObjects from membership.
Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry
getExpiration, getStability, getStatus, setExpiration, setStability
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.Versionable
getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

Method Detail

addRegistryObject

public void addRegistryObject(RegistryObject registryObject)
                       throws JAXRException
Adds a child RegistryObject as member.

Capability Level: 1

Parameters:
registryObject - the RegistryObject being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addRegistryObjects

public void addRegistryObjects(Collection registryObjects)
                        throws JAXRException
Adds a Collection of RegistryObject children as members.

Capability Level: 1

Parameters:
registryObjects - the Collection of RegistryObjects being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeRegistryObject

public void removeRegistryObject(RegistryObject registryObject)
                          throws JAXRException
Removes a child RegistryObject from membership.

Capability Level: 1

Parameters:
registryObject - the RegistryObject being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeRegistryObjects

public void removeRegistryObjects(Collection registryObjects)
                           throws JAXRException
Removes a Collection of children RegistryObjects from membership.

Capability Level: 1

Parameters:
registryObjects - the Collection of RegistryObject being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObjects

public Set getRegistryObjects()
                       throws JAXRException
Gets the collection of member RegistryObjects of this RegistryPackage.

Capability Level: 1

Returns:
the Set of RegistryObjects that are members of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Service

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Service

All Superinterfaces:
ExtensibleObject, RegistryEntry, RegistryObject, Versionable
public interface Service
extends RegistryEntry

Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization. A Service may have a set of ServiceBinding instances. Maps to a BusinessService in UDDI.

Author:
Farrukh S. Najmi
See Also:
ServiceBinding

Field Summary
Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry
STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN
Method Summary
void | addServiceBinding(ServiceBinding serviceBinding) Adds a child ServiceBinding.
void | addServiceBindings(Collection serviceBindings) Adds a Collection of ServiceBinding children.
Organization | getProvidingOrganization() Gets the Organization that provides this service.
Collection | getServiceBindings() Gets all children ServiceBindings.
void | removeServiceBinding(ServiceBinding serviceBinding) Removes a child ServiceBinding.
void | removeServiceBindings(Collection serviceBindings) Removes a Collection of children ServiceBindings.
void | setProvidingOrganization(Organization providingOrganization) Sets the Organization that provides this service.
Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry
getExpiration, getStability, getStatus, setExpiration, setStability
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.Versionable
getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

Method Detail

getProvidingOrganization

public Organization getProvidingOrganization()
                                      throws JAXRException
Gets the Organization that provides this service. Providing Organization may be null. The providing Organization may be different from the Submitting Organization as defined by RegistryObject#getSubmittingOrganization.

Capability Level: 0

Returns:
the Organization that provides this service
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryObject.getSubmittingOrganization()

setProvidingOrganization

public void setProvidingOrganization(Organization providingOrganization)
                              throws JAXRException
Sets the Organization that provides this service.

Capability Level: 0

Parameters:
providingOrganization - the Organization that provides this service
Throws:
JAXRException - If the JAXR provider encounters an internal error

addServiceBinding

public void addServiceBinding(ServiceBinding serviceBinding)
                       throws JAXRException
Adds a child ServiceBinding.

Capability Level: 0

Parameters:
serviceBinding - the ServiceBinding being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addServiceBindings

public void addServiceBindings(Collection serviceBindings)
                        throws JAXRException
Adds a Collection of ServiceBinding children.

Capability Level: 0

Parameters:
serviceBindings - the Collection of ServiceBindings being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeServiceBinding

public void removeServiceBinding(ServiceBinding serviceBinding)
                          throws JAXRException
Removes a child ServiceBinding.

Capability Level: 0

Parameters:
serviceBinding - the ServiceBinding being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeServiceBindings

public void removeServiceBindings(Collection serviceBindings)
                           throws JAXRException
Removes a Collection of children ServiceBindings.

Capability Level: 0

Parameters:
serviceBindings - the Collection of ServiceBindings being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

getServiceBindings

public Collection getServiceBindings()
                              throws JAXRException
Gets all children ServiceBindings.

Capability Level: 0

Returns:
Collection of ServiceBinding instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
ServiceBinding
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServiceBinding

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ServiceBinding

All Superinterfaces:
ExtensibleObject, RegistryObject, URIValidator
public interface ServiceBinding
extends RegistryObject, URIValidator

ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance. A ServiceBinding may have a set of SpecificationLink instances. Maps to a BindingTemplate in UDDI.

Author:
Farrukh S. Najmi
See Also:
Concept

Method Summary
void | addSpecificationLink(SpecificationLink specificationLink) Adds a child SpecificationLink.
void | addSpecificationLinks(Collection specificationLinks) Adds a Collection of SpecificationLink children.
String | getAccessURI() Gets the URI that gives access to the service via this binding.
Service | getService() Gets the parent service for which this is a binding.
Collection | getSpecificationLinks() Gets all children SpecificationLinks.
ServiceBinding | getTargetBinding() Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.
void | removeSpecificationLink(SpecificationLink specificationLink) Removes a child SpecificationLink.
void | removeSpecificationLinks(Collection specificationLinks) Removes a Collection of children SpecificationLinks.
void | setAccessURI(String uri) Sets the URI that gives access to the service via this binding.
void | setTargetBinding(ServiceBinding binding) Sets the next ServiceBinding in case there is a redirection.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.URIValidator
getValidateURI, setValidateURI

Method Detail

getAccessURI

public String getAccessURI()
                    throws JAXRException
Gets the URI that gives access to the service via this binding. Default is a NULL String.

Capability Level: 0

Returns:
the URI that gives access to the service via this binding
Throws:
JAXRException - If the JAXR provider encounters an internal error

setAccessURI

public void setAccessURI(String uri)
                  throws JAXRException
Sets the URI that gives access to the service via this binding. The accessURI is mutually exclusive from targetBinding. JAXR Provider must throw an InvalidRequestException if an accessURI is set when there is already a non-null targetBinding defined.

Capability Level: 0

Parameters:
uri - the URI that gives access to the service via this binding
Throws:
JAXRException - If the JAXR provider encounters an internal error

getTargetBinding

public ServiceBinding getTargetBinding()
                                throws JAXRException
Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.

Capability Level: 0

Returns:
the next ServiceBinding in case there is a service redirection
Throws:
JAXRException - If the JAXR provider encounters an internal error

setTargetBinding

public void setTargetBinding(ServiceBinding binding)
                      throws JAXRException
Sets the next ServiceBinding in case there is a redirection. The targetBinding is mutually exclusive from the accessURI. JAXR Provider must throw an InvalidRequestExcpetion if a targetBinding is set when there is already a non-null accessURI defined.

Capability Level: 0

Parameters:
binding - the target ServiceBinding to which this object is redirected to
Throws:
JAXRException - If the JAXR provider encounters an internal error

getService

public Service getService()
                   throws JAXRException
Gets the parent service for which this is a binding.

Capability Level: 0

Returns:
the parent Service object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addSpecificationLink

public void addSpecificationLink(SpecificationLink specificationLink)
                          throws JAXRException
Adds a child SpecificationLink.

Capability Level: 0

Parameters:
specificationLink - the SpecificationLink being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addSpecificationLinks

public void addSpecificationLinks(Collection specificationLinks)
                           throws JAXRException
Adds a Collection of SpecificationLink children.

Capability Level: 0

Parameters:
specificationLinks - the Collection of SpecificationLinks being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeSpecificationLink

public void removeSpecificationLink(SpecificationLink specificationLink)
                             throws JAXRException
Removes a child SpecificationLink.

Capability Level: 0

Parameters:
specificationLink - the SpecificationLink being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeSpecificationLinks

public void removeSpecificationLinks(Collection specificationLinks)
                              throws JAXRException
Removes a Collection of children SpecificationLinks.

Capability Level: 0

Parameters:
specificationLinks - the Collection of SpecificationLinks being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

getSpecificationLinks

public Collection getSpecificationLinks()
                                 throws JAXRException
Gets all children SpecificationLinks.

Capability Level: 0

Returns:
Collection of SpecificationLink instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
SpecificationLink
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Slot

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Slot

public interface Slot

Slot instances provide a dynamic way to add arbitrary attributes to RegistryObject instances. This ability to add attributes dynamically to RegistryObject instances enables extensibility within the Registry Information Model.

A RegistryObject may have 0 or more Slots. A slot is composed of a name, a slotType and a collection of values. The name of a slot is locally unique within the RegistryObject instance. Similarly, the value of a Slot is locally unique within a slot instance. Since a Slot represents an extensible attribute whose value may be a collection, a Slot is allowed to have a collection of values rather than a single value. The slotType attribute may optionally specify a type or category for the slot.

Author:
Farrukh S. Najmi
See Also:
ExtensibleObject

Field Summary
static String | ADDRESS_LINES_SLOT Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.
static String | AUTHORIZED_NAME_SLOT Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.
static String | OPERATOR_SLOT Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.
static String | SORT_CODE_SLOT Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.
Method Summary
String | getName() Gets the name for this Slot.
String | getSlotType() Gets the slotType for this Slot.
Collection | getValues() Gets the values for this Slot.
void | setName(String name) Sets the name for this Slot.
void | setSlotType(String slotType) Sets the slotType for this Slot.
void | setValues(Collection values) Sets the values for this Slot.

Field Detail

SORT_CODE_SLOT

public static final String SORT_CODE_SLOT
Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.

See Also:
Constant Field Values

ADDRESS_LINES_SLOT

public static final String ADDRESS_LINES_SLOT
Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.

See Also:
Constant Field Values

AUTHORIZED_NAME_SLOT

public static final String AUTHORIZED_NAME_SLOT
Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.

See Also:
Constant Field Values

OPERATOR_SLOT

public static final String OPERATOR_SLOT
Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.

See Also:
Constant Field Values
Method Detail

getName

public String getName()
               throws JAXRException
Gets the name for this Slot. Default is a NULL String.

Capability Level: 0

Returns:
the name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setName

public void setName(String name)
             throws JAXRException
Sets the name for this Slot. Default is a NULL String.

Capability Level: 0

Parameters:
name - the name
Throws:
JAXRException - If the JAXR provider encounters an internal error

getSlotType

public String getSlotType()
                   throws JAXRException
Gets the slotType for this Slot. Default is a NULL String.

Capability Level: 0

Returns:
the slot type which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error

setSlotType

public void setSlotType(String slotType)
                 throws JAXRException
Sets the slotType for this Slot.

Capability Level: 0

Parameters:
slotType - the slot type which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error

getValues

public Collection getValues()
                     throws JAXRException
Gets the values for this Slot.

Capability Level: 0

Returns:
Collection of String instances representing the values for this Slot. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
String

setValues

public void setValues(Collection values)
               throws JAXRException
Sets the values for this Slot.

Capability Level: 0

Parameters:
values - the values for this Slot
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SpecificationLink

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface SpecificationLink

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface SpecificationLink
extends RegistryObject

A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding. For example, a ServiceBinding may have a SpecificationLink instance that describes how to access the service using a technical specification in the form of a WSDL document or a CORBA IDL document. It serves the same purpose as the union of the tModelInstanceInfo and instanceDetails structures in UDDI.

Author:
Farrukh S. Najmi
See Also:
Concept

Method Summary
ServiceBinding | getServiceBinding() Gets the parent ServiceBinding for this SpecificationLink.
RegistryObject | getSpecificationObject() Gets the specification object for this object.
InternationalString | getUsageDescription() Gets the description of usage parameters.
Collection | getUsageParameters() Gets any usage parameters.
void | setSpecificationObject(RegistryObject obj) Sets the specification object for this object.
void | setUsageDescription(InternationalString usageDescription) Sets the description of usage parameters.
void | setUsageParameters(Collection usageParameters) Sets any usage parameters.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getSpecificationObject

public RegistryObject getSpecificationObject()
                                      throws JAXRException
Gets the specification object for this object.

Capability Level: 0

Returns:
the RegistryObject that is the specification object. For a UDDI provider the specification object must be a Concept with no parent. For an ebXML provider it is likely to be an ExtrinsicObject.
Throws:
JAXRException - If the JAXR provider encounters an internal error

setSpecificationObject

public void setSpecificationObject(RegistryObject obj)
                            throws JAXRException
Sets the specification object for this object.

Capability Level: 0

Parameters:
obj - the RegistryObject that is the specification object. For a UDDI provider the specification object must be a Concept with no parent. For an ebXML provider it is likely to be an ExtrinsicObject.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUsageDescription

public InternationalString getUsageDescription()
                                        throws JAXRException
Gets the description of usage parameters. Default is an empty String.

Capability Level: 0

Returns:
the usage description for this object, which must not be null
Throws:
JAXRException - If the JAXR provider encounters an internal error

setUsageDescription

public void setUsageDescription(InternationalString usageDescription)
                         throws JAXRException
Sets the description of usage parameters.

Capability Level: 0

Parameters:
usageDescription - the description of usage parameters for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUsageParameters

public Collection getUsageParameters()
                              throws JAXRException
Gets any usage parameters. A usage parameter is an arbitrary String that describes how to use the technical specification accessed via this SpecificationLink. Each parameter is a String.

Capability Level: 0

Returns:
the Collection of String instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error

setUsageParameters

public void setUsageParameters(Collection usageParameters)
                        throws JAXRException
Sets any usage parameters. Each parameter is a String

Capability Level: 0

Parameters:
usageParameters - the Collection of usage parameter Strings
Throws:
JAXRException - If the JAXR provider encounters an internal error

getServiceBinding

public ServiceBinding getServiceBinding()
                                 throws JAXRException
Gets the parent ServiceBinding for this SpecificationLink.

Capability Level: 0

Returns:
the parent ServiceBinding within which this object is composed
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TelephoneNumber

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface TelephoneNumber

public interface TelephoneNumber

A simple re-usable entity class that defines attributes of a telephone number.

Author:
Farrukh S. Najmi

Method Summary
String | getAreaCode() Gets the area code.
String | getCountryCode() Gets the country code.
String | getExtension() Gets the internal extension.
String | getNumber() Gets the telephone number suffix, not including the country or area code.
String | getType() The type of telephone number (for example, "fax").
String | getUrl() Gets the URL that can dial this number electronically.
void | setAreaCode(String areaCode) Sets the area code.
void | setCountryCode(String countryCode) Sets country code.
void | setExtension(String extension) Sets the internal extension.
void | setNumber(String number) Sets the telephone number suffix, not including the country or area code.
void | setType(String type) Sets the type of telephone number (for example, "fax").
void | setUrl(String url) Sets the URL that can dial this number electronically.

Method Detail

getCountryCode

public String getCountryCode()
                      throws JAXRException
Gets the country code. Default is an empty String.

Capability Level: 1

Returns:
the country code
Throws:
JAXRException - If the JAXR provider encounters an internal error

getAreaCode

public String getAreaCode()
                   throws JAXRException
Gets the area code. Default is an empty String.

Capability Level: 1

Returns:
the area code
Throws:
JAXRException - If the JAXR provider encounters an internal error

getNumber

public String getNumber()
                 throws JAXRException
Gets the telephone number suffix, not including the country or area code. Default is an empty String.

Capability Level: 0

Returns:
the telephone number
Throws:
JAXRException - If the JAXR provider encounters an internal error

getExtension

public String getExtension()
                    throws JAXRException
Gets the internal extension. Default is an empty String.

Capability Level: 1

Returns:
the internal extension number
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUrl

public String getUrl()
              throws JAXRException
Gets the URL that can dial this number electronically. Default is a NULL String.

Capability Level: 1

Returns:
the url
Throws:
JAXRException - If the JAXR provider encounters an internal error

getType

public String getType()
               throws JAXRException
The type of telephone number (for example, "fax"). Any String would do.

Capability Level: 0

Returns:
the type for this TelephoneNumber, which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error

setCountryCode

public void setCountryCode(String countryCode)
                    throws JAXRException
Sets country code.

Capability Level: 1

Parameters:
countryCode - the country code
Throws:
JAXRException - If the JAXR provider encounters an internal error

setAreaCode

public void setAreaCode(String areaCode)
                 throws JAXRException
Sets the area code.

Capability Level: 1

Parameters:
areaCode - the area code
Throws:
JAXRException - If the JAXR provider encounters an internal error

setNumber

public void setNumber(String number)
               throws JAXRException
Sets the telephone number suffix, not including the country or area code.

Capability Level: 0

Parameters:
number - the telephone number
Throws:
JAXRException - If the JAXR provider encounters an internal error

setExtension

public void setExtension(String extension)
                  throws JAXRException
Sets the internal extension.

Capability Level: 1

Parameters:
extension - the internal extension number
Throws:
JAXRException - If the JAXR provider encounters an internal error

setUrl

public void setUrl(String url)
            throws JAXRException
Sets the URL that can dial this number electronically.

Capability Level: 1

Parameters:
url - the URL string
Throws:
JAXRException - If the JAXR provider encounters an internal error

setType

public void setType(String type)
             throws JAXRException
Sets the type of telephone number (for example, "fax"). Any String will do.

Capability Level: 0

Parameters:
type - the type for this TelephoneNumber, which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


URIValidator

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface URIValidator

All Known Subinterfaces:
ExternalLink, ServiceBinding
public interface URIValidator

Defines common behavior expected of any class that validates URIs.

Author:
Farrukh S. Najmi

Method Summary
boolean | getValidateURI() Gets whether to do URI validation for this object.
void | setValidateURI(boolean validate) Sets whether to do URI validation for this object.

Method Detail

setValidateURI

public void setValidateURI(boolean validate)
                    throws JAXRException
Sets whether to do URI validation for this object. Default is true.

Capability Level: 0

Parameters:
validate - true implies JAXR provider must perform validation of URIs when they are set; false implies validation is turned off
Throws:
JAXRException - If the JAXR provider encounters an internal error

getValidateURI

public boolean getValidateURI()
                       throws JAXRException
Gets whether to do URI validation for this object.

Capability Level: 0

Returns:
true implies JAXR provider must perform validation of URIs when they are set; false implies validation is turned off
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


User

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface User

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface User
extends RegistryObject

User instances are RegistryObjects that are used to provide information about registered users within the registry. Users are affiliated with Organizations. User objects are used in the audit trail for a RegistryObject.

Author:
Farrukh S. Najmi
See Also:
Organization, AuditableEvent

Method Summary
Collection | getEmailAddresses() Gets the email addresses for this User.
Organization | getOrganization() Gets the Organization that this User is affiliated with.
PersonName | getPersonName() Returns the name of this User.
Collection | getPostalAddresses() Gets the postal address for this User.
Collection | getTelephoneNumbers(String phoneType) Gets the telephone numbers for this User that match the specified telephone number type.
String | getType() Gets the type for this User.
URL | getUrl() Gets the URL to the web page for this User.
void | setEmailAddresses(Collection emailAddresses) Sets the Collection of EmailAddress instances for this User.
void | setPersonName(PersonName personName) Sets the name of this User.
void | setPostalAddresses(Collection addresses) Sets the addresses for this User.
void | setTelephoneNumbers(Collection phoneNumbers) Sets the various telephone numbers for this user.
void | setType(String type) Sets the type for this User.
void | setUrl(URL url) Sets the URL to the web page for this User.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getOrganization

public Organization getOrganization()
                             throws JAXRException
Gets the Organization that this User is affiliated with.

Capability Level: 0

Returns:
the Organization that this User is affiliated with
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPersonName

public PersonName getPersonName()
                         throws JAXRException
Returns the name of this User.

Capability Level: 0

Returns:
the name of this User
Throws:
JAXRException - If the JAXR provider encounters an internal error

setPersonName

public void setPersonName(PersonName personName)
                   throws JAXRException
Sets the name of this User.

Capability Level: 0

Parameters:
personName - the name of this User
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPostalAddresses

public Collection getPostalAddresses()
                              throws JAXRException
Gets the postal address for this User.

Capability Level: 0

Returns:
Collection of PostalAddress instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
PostalAddress

setPostalAddresses

public void setPostalAddresses(Collection addresses)
                        throws JAXRException
Sets the addresses for this User.

Capability Level: 0

Parameters:
addresses - Is a Collection of PostAddress instances.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUrl

public URL getUrl()
           throws JAXRException
Gets the URL to the web page for this User.

Capability Level: 1

Returns:
the URL for this User's home page
Throws:
JAXRException - If the JAXR provider encounters an internal error

setUrl

public void setUrl(URL url)
            throws JAXRException
Sets the URL to the web page for this User.

Capability Level: 1

Parameters:
url - the URL for this User's home page
Throws:
JAXRException - If the JAXR provider encounters an internal error

getTelephoneNumbers

public Collection getTelephoneNumbers(String phoneType)
                               throws JAXRException
Gets the telephone numbers for this User that match the specified telephone number type.

Capability Level: 0

Parameters:
phoneType - specifies the type of phone numbers to be returned. If phoneType is null, return all telephoneNumbers
Returns:
Collection of TelephoneNumber instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
TelephoneNumber

setTelephoneNumbers

public void setTelephoneNumbers(Collection phoneNumbers)
                         throws JAXRException
Sets the various telephone numbers for this user.

Capability Level: 0

Parameters:
phoneNumbers - the Collection of TelephoneNumbers to be set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getEmailAddresses

public Collection getEmailAddresses()
                             throws JAXRException
Gets the email addresses for this User.

Capability Level: 0

Returns:
Collection of EmailAddress instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
EmailAddress

setEmailAddresses

public void setEmailAddresses(Collection emailAddresses)
                       throws JAXRException
Sets the Collection of EmailAddress instances for this User.

Capability Level: 0

Parameters:
emailAddresses - the Collection of EmailAddresses to be set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getType

public String getType()
               throws JAXRException
Gets the type for this User. Default is a NULL String.

Capability Level: 0

Returns:
the type for this User, which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error

setType

public void setType(String type)
             throws JAXRException
Sets the type for this User.

Capability Level: 0

Parameters:
type - the type for this User, which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Versionable

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Versionable

All Known Subinterfaces:
ClassificationScheme, ExtrinsicObject, RegistryEntry, RegistryPackage, Service
public interface Versionable

The Versionable interface defines the behavior common to classes that are capable of creating versions of their instances. At present all RegistryEntry classes are required to implement the Versionable interface.

Author:
Farrukh S. Najmi
See Also:
RegistryEntry

Method Summary
int | getMajorVersion() Gets the major revision number for this version of the Versionable object.
int | getMinorVersion() Gets the minor revision number for this version of the Versionable object.
String | getUserVersion() Gets the user-specified revision number for this version of the Versionable object.
void | setMajorVersion(int majorVersion) Sets the major revision number for this version of the Versionable object.
void | setMinorVersion(int minorVersion) Sets the minor revision number for this version of the Versionable object.
void | setUserVersion(String userVersion) Sets the user specified revision number for this version of the Versionable object.

Method Detail

getMajorVersion

public int getMajorVersion()
                    throws JAXRException
Gets the major revision number for this version of the Versionable object.

Capability Level: 1

Returns:
the major version for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setMajorVersion

public void setMajorVersion(int majorVersion)
                     throws JAXRException
Sets the major revision number for this version of the Versionable object.

Capability Level: 1

Parameters:
majorVersion - the major version number
Throws:
JAXRException - If the JAXR provider encounters an internal error

getMinorVersion

public int getMinorVersion()
                    throws JAXRException
Gets the minor revision number for this version of the Versionable object.

Capability Level: 1

Returns:
the minor version for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setMinorVersion

public void setMinorVersion(int minorVersion)
                     throws JAXRException
Sets the minor revision number for this version of the Versionable object.

Capability Level: 1

Parameters:
minorVersion - the minor version number
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUserVersion

public String getUserVersion()
                      throws JAXRException
Gets the user-specified revision number for this version of the Versionable object.

Capability Level: 1

Returns:
the user-defined version number
Throws:
JAXRException - If the JAXR provider encounters an internal error

setUserVersion

public void setUserVersion(String userVersion)
                    throws JAXRException
Sets the user specified revision number for this version of the Versionable object.

Capability Level: 1

Parameters:
userVersion - the user-defined version number
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


InvalidRequestException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class InvalidRequestException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.registry.JAXRException
                extended by javax.xml.registry.InvalidRequestException
All Implemented Interfaces:
JAXRResponse, Serializable
public class InvalidRequestException
extends JAXRException

This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
InvalidRequestException()
Constructs a JAXRException object with no reason or embedded Throwable.
InvalidRequestException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
InvalidRequestException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
InvalidRequestException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidRequestException

public InvalidRequestException()
Constructs a JAXRException object with no reason or embedded Throwable.

InvalidRequestException

public InvalidRequestException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

InvalidRequestException

public InvalidRequestException(String reason,
                               Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

InvalidRequestException

public InvalidRequestException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JAXRException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class JAXRException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.registry.JAXRException
All Implemented Interfaces:
JAXRResponse, Serializable
Direct Known Subclasses:
InvalidRequestException, RegistryException, UnexpectedObjectException, UnsupportedCapabilityException
public class JAXRException
extends Exception
implements JAXRResponse

Signals that a JAXR exception has occurred. It contains no members other than the standard reason String.

Author:
Nicholas Kassem, Mark Hapner, Rajiv Mordani, Farrukh Najmi
See Also:
JAXRResponse, Serialized Form

Field Summary
protected  Throwable cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
JAXRException()
Constructs a JAXRException object with no reason or embedded Throwable.
JAXRException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
JAXRException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
JAXRException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Method Summary
Throwable | getCause() Returns the Throwable embedded in this JAXRException if there is one.
String | getMessage() Returns the detail message for this JAXRException object.
String | getRequestId() Returns the unique id for the request that generated this response.
int | getStatus() Returns the status for this response.
Throwable | initCause(Throwable cause) Initializes the cause of this throwable to the specified value.
boolean | isAvailable() Returns true if a response is available, false otherwise.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

cause

protected Throwable cause
Constructor Detail

JAXRException

public JAXRException()
Constructs a JAXRException object with no reason or embedded Throwable.

JAXRException

public JAXRException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

JAXRException

public JAXRException(String reason,
                     Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

JAXRException

public JAXRException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Method Detail

getMessage

public String getMessage()
Returns the detail message for this JAXRException object.

If there is an embedded Throwable, and if the JAXRException object has no detail message of its own, this method will return the detail message from the embedded Throwable.

Returns:
the error or warning message for this JAXRException or, if it has none, the message of the embedded Throwable, if there is one

getCause

public Throwable getCause()
Returns the Throwable embedded in this JAXRException if there is one. Otherwise, this method returns null.

Returns:
the embedded Throwable or null if there is none

initCause

public Throwable initCause(Throwable cause)
Initializes the cause of this throwable to the specified value. (The cause is the throwable that caused this throwable to get thrown.)

This method can be called at most once. It is generally called from within the constructor, or immediately after creating the throwable. If this throwable was created with JAXRException(Throwable) or JAXRException(String,Throwable), this method cannot be called even once.

Parameters:
cause - the cause (which is saved for later retrieval by the getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Returns:
a reference to this Throwable instance.
Throws:
IllegalArgumentException - if cause is this throwable. (A throwable cannot be its own cause.)
IllegalStateException - if this throwable was created with JAXRException(Throwable) or JAXRException(String,Throwable), or this method has already been called on this throwable.

getRequestId

public String getRequestId()
Description copied from interface: JAXRResponse
Returns the unique id for the request that generated this response.

Capability Level: 0

Specified by:
getRequestId in interface JAXRResponse
Returns:
the request id

getStatus

public int getStatus()
Description copied from interface: JAXRResponse
Returns the status for this response.

Capability Level: 0

Specified by:
getStatus in interface JAXRResponse
Returns:
the status which is an integer enumerated value
See Also:
JAXRResponse.STATUS_SUCCESS

isAvailable

public boolean isAvailable()
                    throws JAXRException
Returns true if a response is available, false otherwise. This is a polling method and must not block.

Specified by:
isAvailable in interface JAXRResponse
Returns:
true if the response is available; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JAXRResponse

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface JAXRResponse

All Known Subinterfaces:
BulkResponse
All Known Implementing Classes:
JAXRException
public interface JAXRResponse

A JAXR requests' response.

Author:
Farrukh S. Najmi
See Also:
JAXRException

Field Summary
static int | STATUS_FAILURE Status indicating a failure response.
static int | STATUS_SUCCESS Status indicating a successful response.
static int | STATUS_UNAVAILABLE Status indicating that the results are currently unavailable.
static int | STATUS_WARNING Status indicating a successful response that included at least one warning.
Method Summary
String | getRequestId() Returns the unique id for the request that generated this response.
int | getStatus() Returns the status for this response.
boolean | isAvailable() Returns true if a response is available, false otherwise.

Field Detail

STATUS_SUCCESS

public static final int STATUS_SUCCESS
Status indicating a successful response.

See Also:
Constant Field Values

STATUS_WARNING

public static final int STATUS_WARNING
Status indicating a successful response that included at least one warning.

See Also:
Constant Field Values

STATUS_FAILURE

public static final int STATUS_FAILURE
Status indicating a failure response.

See Also:
Constant Field Values

STATUS_UNAVAILABLE

public static final int STATUS_UNAVAILABLE
Status indicating that the results are currently unavailable.

See Also:
Constant Field Values
Method Detail

getRequestId

public String getRequestId()
                    throws JAXRException
Returns the unique id for the request that generated this response.

Capability Level: 0

Returns:
the request id
Throws:
JAXRException - If the JAXR provider encounters an internal error

getStatus

public int getStatus()
              throws JAXRException
Returns the status for this response.

Capability Level: 0

Returns:
the status which is an integer enumerated value
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
STATUS_SUCCESS

isAvailable

public boolean isAvailable()
                    throws JAXRException
Returns true if a response is available, false otherwise. This is a polling method and must not block.

Capability Level: 0

Returns:
true if the response is available; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


LifeCycleManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface LifeCycleManager

All Known Subinterfaces:
BusinessLifeCycleManager
public interface LifeCycleManager

The LifeCycleManager interface is the main interface in the API for managing life cycle operations on objects defined by the information model.

The factory methods of this interface must throw an UnsupportedCapabilityException if the client attempts to create an instance of an infomodel interface that is not supported by the capability level of the JAXR provider.

Author:
Farrukh S. Najmi

Field Summary
static String | ASSOCIATION
static String | AUDITABLE_EVENT
static String | CLASSIFICATION
static String | CLASSIFICATION_SCHEME
static String | CONCEPT
static String | EMAIL_ADDRESS
static String | EXTERNAL_IDENTIFIER
static String | EXTERNAL_LINK
static String | EXTRINSIC_OBJECT
static String | INTERNATIONAL_STRING
static String | KEY
static String | LOCALIZED_STRING
static String | ORGANIZATION
static String | PERSON_NAME
static String | POSTAL_ADDRESS
static String | REGISTRY_ENTRY
static String | REGISTRY_PACKAGE
static String | SERVICE
static String | SERVICE_BINDING
static String | SLOT
static String | SPECIFICATION_LINK
static String | TELEPHONE_NUMBER
static String | USER
static String | VERSIONABLE
Method Summary
Association | createAssociation(RegistryObject targetObject, Concept associationType) Creates an Association instance using the specified parameters.
Classification | createClassification(ClassificationScheme scheme, InternationalString name, String value) Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.
Classification | createClassification(ClassificationScheme scheme, String name, String value) Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.
Classification | createClassification(Concept concept) Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.
ClassificationScheme | createClassificationScheme(Concept concept) Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.
ClassificationScheme | createClassificationScheme(InternationalString name, InternationalString description) Creates a ClassificationScheme given the specified InternationalString parameters.
ClassificationScheme | createClassificationScheme(String name, String description) Creates a ClassificationScheme given the specified String parameters.
Concept | createConcept(RegistryObject parent, InternationalString name, String value) Creates a Concept instance using the specified parameters, where the name is an InternationalString.
Concept | createConcept(RegistryObject parent, String name, String value) Creates a Concept instance using the specified parameters, where the name is a String.
EmailAddress | createEmailAddress(String address) Creates an EmailAddress instance using an address as the parameter.
EmailAddress | createEmailAddress(String address, String type) Creates an EmailAddress instance using both an address and a type as parameters.
ExternalIdentifier | createExternalIdentifier(ClassificationScheme identificationScheme, InternationalString name, String value) Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.
ExternalIdentifier | createExternalIdentifier(ClassificationScheme identificationScheme, String name, String value) Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.
ExternalLink | createExternalLink(String externalURI, InternationalString description) Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.
ExternalLink | createExternalLink(String externalURI, String description) Creates an ExternalLink instance using the specified parameters, where the description is a String.
ExtrinsicObject | createExtrinsicObject(DataHandler repositoryItem) Creates an ExtrinsicObject instance using the specified parameters.
InternationalString | createInternationalString() Creates an empty InternationalString instance.
InternationalString | createInternationalString(Locale l, String s) Creates an InternationalString instance using the specified Locale and String parameters.
InternationalString | createInternationalString(String s) Creates an InternationalString instance using a String parameter and the default Locale.
Key | createKey(String id) Creates a Key instance from an ID.
LocalizedString | createLocalizedString(Locale l, String s) Creates a LocalizedString instance using the specified Locale and String parameters.
LocalizedString | createLocalizedString(Locale l, String s, String charSetName) Creates a LocalizedString instance using the specified Locale, String, and character set parameters.
Object | createObject(String interfaceName) Creates instances of information model interfaces (factory method).
Organization | createOrganization(InternationalString name) Creates an Organization instance using the specified name, where the name is an InternationalString.
Organization | createOrganization(String name) Creates an Organization instance using the specified name, where the name is a String.
PersonName | createPersonName(String fullName) Creates a PersonName instance using the specified full name.
PersonName | createPersonName(String firstName, String middleName, String lastName) Creates a PersonName instance using the specified first, middle, and last names.
PostalAddress | createPostalAddress(String streetNumber, String street, String city, String stateOrProvince, String country, String postalCode, String type) Creates a PostalAddress instance using the specified parameters.
RegistryPackage | createRegistryPackage(InternationalString name) Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.
RegistryPackage | createRegistryPackage(String name) Creates a RegistryPackage instance using the specified name, where the name is a String.
Service | createService(InternationalString name) Creates a Service instance using the specified name, where the name is an InternationalString.
Service | createService(String name) Creates a Service instance using the specified name, where the name is a String.
ServiceBinding | createServiceBinding() Creates an empty ServiceBinding instance.
Slot | createSlot(String name, Collection values, String slotType) Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.
Slot | createSlot(String name, String value, String slotType) Creates a Slot instance using the specified parameters, where the value is a String.
SpecificationLink | createSpecificationLink() Creates an empty SpecificationLink instance.
TelephoneNumber | createTelephoneNumber() Creates an empty TelephoneNumber instance.
User | createUser() Creates an empty User instance.
BulkResponse | deleteObjects(Collection keys) Deletes one or more previously submitted objects from the registry using the object keys.
BulkResponse | deleteObjects(Collection keys, String objectType) Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.
BulkResponse | deprecateObjects(Collection keys) Deprecates one or more previously submitted objects.
RegistryService | getRegistryService() Returns the parent RegistryService that created this object.
BulkResponse | saveObjects(Collection objects) Saves one or more Objects to the registry.
BulkResponse | unDeprecateObjects(Collection keys) Undeprecates one or more previously deprecated objects.

Field Detail

ASSOCIATION

public static final String ASSOCIATION
See Also:
Constant Field Values

AUDITABLE_EVENT

public static final String AUDITABLE_EVENT
See Also:
Constant Field Values

CLASSIFICATION

public static final String CLASSIFICATION
See Also:
Constant Field Values

CLASSIFICATION_SCHEME

public static final String CLASSIFICATION_SCHEME
See Also:
Constant Field Values

CONCEPT

public static final String CONCEPT
See Also:
Constant Field Values

EMAIL_ADDRESS

public static final String EMAIL_ADDRESS
See Also:
Constant Field Values

EXTERNAL_IDENTIFIER

public static final String EXTERNAL_IDENTIFIER
See Also:
Constant Field Values

EXTERNAL_LINK

public static final String EXTERNAL_LINK
See Also:
Constant Field Values

EXTRINSIC_OBJECT

public static final String EXTRINSIC_OBJECT
See Also:
Constant Field Values

INTERNATIONAL_STRING

public static final String INTERNATIONAL_STRING
See Also:
Constant Field Values

KEY

public static final String KEY
See Also:
Constant Field Values

LOCALIZED_STRING

public static final String LOCALIZED_STRING
See Also:
Constant Field Values

ORGANIZATION

public static final String ORGANIZATION
See Also:
Constant Field Values

PERSON_NAME

public static final String PERSON_NAME
See Also:
Constant Field Values

POSTAL_ADDRESS

public static final String POSTAL_ADDRESS
See Also:
Constant Field Values

REGISTRY_ENTRY

public static final String REGISTRY_ENTRY
See Also:
Constant Field Values

REGISTRY_PACKAGE

public static final String REGISTRY_PACKAGE
See Also:
Constant Field Values

SERVICE

public static final String SERVICE
See Also:
Constant Field Values

SERVICE_BINDING

public static final String SERVICE_BINDING
See Also:
Constant Field Values

SLOT

public static final String SLOT
See Also:
Constant Field Values

SPECIFICATION_LINK

public static final String SPECIFICATION_LINK
See Also:
Constant Field Values

TELEPHONE_NUMBER

public static final String TELEPHONE_NUMBER
See Also:
Constant Field Values

USER

public static final String USER
See Also:
Constant Field Values

VERSIONABLE

public static final String VERSIONABLE
See Also:
Constant Field Values
Method Detail

createObject

public Object createObject(String interfaceName)
                    throws JAXRException,
                           InvalidRequestException,
                           UnsupportedCapabilityException
Creates instances of information model interfaces (factory method). To create an Organization, use this method as follows:
 Organization org = (Organization)
    lifeCycleMgr.createObject(LifeCycleManager.ORGANIZATION);

Capability Level: 0

Parameters:
interfaceName - the unqualified name of an interface in the javax.xml.registry.infomodel package
Returns:
an Object that can then be cast to an instance of the interface
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException - if the interface is not an interface in the javax.xml.registry.infomodel package
UnsupportedCapabilityException - if the client attempts to create an instance of an infomodel interface that is not supported by the capability level of the JAXR provider

createAssociation

public Association createAssociation(RegistryObject targetObject,
                                     Concept associationType)
                              throws JAXRException
Creates an Association instance using the specified parameters. The sourceObject is left null and will be set when the Association is added to a RegistryObject.

Note that for a UDDI provider an Association may only be created between Organizations.

Capability Level: 0

Parameters:
targetObject - the target RegistryObject for the association
associationType - the association type for the Association
Returns:
the Association instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createClassification

public Classification createClassification(ClassificationScheme scheme,
                                           String name,
                                           String value)
                                    throws JAXRException
Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.

Capability Level: 0

Parameters:
scheme - the ClassificationScheme to be used
name - the name of the taxonomy element (a String)
value - the value of the taxonomy element
Returns:
the Classification instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createClassification

public Classification createClassification(ClassificationScheme scheme,
                                           InternationalString name,
                                           String value)
                                    throws JAXRException
Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.

Capability Level: 0

Parameters:
scheme - the ClassificationScheme to be used
name - the name of the taxonomy element (an InternationalString)
value - the value of the taxonomy element
Returns:
the Classification instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createClassification

public Classification createClassification(Concept concept)
                                    throws JAXRException,
                                           InvalidRequestException
Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.

Capability Level: 0

Parameters:
concept - the Concept that identifies the taxonomy element
Returns:
the Classification instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException - if the Concept is not under a ClassificationScheme

createClassificationScheme

public ClassificationScheme createClassificationScheme(String name,
                                                       String description)
                                                throws JAXRException,
                                                       InvalidRequestException
Creates a ClassificationScheme given the specified String parameters.

Capability Level: 0

Parameters:
name - the name of the ClassificationScheme (a String)
description - a description of the ClassificationScheme (a String)
Returns:
the ClassificationScheme instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException

createClassificationScheme

public ClassificationScheme createClassificationScheme(InternationalString name,
                                                       InternationalString description)
                                                throws JAXRException,
                                                       InvalidRequestException
Creates a ClassificationScheme given the specified InternationalString parameters.

Capability Level: 0

Parameters:
name - the name of the ClassificationScheme (an InternationalString)
description - a description of the ClassificationScheme (an InternationalString)
Returns:
the ClassificationScheme instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException

createClassificationScheme

public ClassificationScheme createClassificationScheme(Concept concept)
                                                throws JAXRException,
                                                       InvalidRequestException
Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.

This method is a special-case method to do a type-safe conversion from Concept to ClassificationScheme.

This method is provided to allow for Concepts returned by the BusinessQueryManager findConcepts call to be safely cast to ClassificationScheme. It is up to the programmer to make sure that the Concept is indeed semantically a ClassificationScheme.

This method is necessary because in the UDDI specification a tModel may serve multiple purposes, and there is no way to know when a tModel maps to a Concept and when it maps to a ClassificationScheme. The UDDI specification leaves the determination to the programmer, and consequently so does this method.

Capability Level: 0

Parameters:
concept - the Concept to be used
Returns:
the ClassificationScheme instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException - if the Concept has a parent Concept or is under a ClassificationScheme

createConcept

public Concept createConcept(RegistryObject parent,
                             String name,
                             String value)
                      throws JAXRException
Creates a Concept instance using the specified parameters, where the name is a String.

Capability Level: 0

Parameters:
parent - a reference either to a parent ClassificationScheme or to a Concept
name - the name of the concept (a String)
value - the value of the concept
Returns:
the Concept instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createConcept

public Concept createConcept(RegistryObject parent,
                             InternationalString name,
                             String value)
                      throws JAXRException
Creates a Concept instance using the specified parameters, where the name is an InternationalString.

Capability Level: 0

Parameters:
parent - a reference either to a parent ClassificationScheme or to a Concept
name - the name of the concept (an InternationalString)
value - the value of the concept
Returns:
the Concept instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createEmailAddress

public EmailAddress createEmailAddress(String address)
                                throws JAXRException
Creates an EmailAddress instance using an address as the parameter.

Capability Level: 0

Parameters:
address - the email address
Returns:
the EmailAddress instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createEmailAddress

public EmailAddress createEmailAddress(String address,
                                       String type)
                                throws JAXRException
Creates an EmailAddress instance using both an address and a type as parameters.

Capability Level: 0

Parameters:
address - the email address
type - the type of the address
Returns:
the EmailAddress instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createExternalIdentifier

public ExternalIdentifier createExternalIdentifier(ClassificationScheme identificationScheme,
                                                   String name,
                                                   String value)
                                            throws JAXRException
Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.

Capability Level: 0

Parameters:
identificationScheme - the ClassificationScheme used
name - the name of the external identifier (a String)
value - the value of the external identifier
Returns:
the ExternalIdentifier instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createExternalIdentifier

public ExternalIdentifier createExternalIdentifier(ClassificationScheme identificationScheme,
                                                   InternationalString name,
                                                   String value)
                                            throws JAXRException
Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.

Capability Level: 0

Parameters:
identificationScheme - the ClassificationScheme used
name - the name of the external identifier (an InternationalString)
value - the value of the external identifier
Returns:
the ExternalIdentifier instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createExternalLink

public ExternalLink createExternalLink(String externalURI,
                                       String description)
                                throws JAXRException
Creates an ExternalLink instance using the specified parameters, where the description is a String.

Capability Level: 0

Parameters:
externalURI - the external URI
description - a description of the link (a String)
Returns:
the ExternalLink instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createExternalLink

public ExternalLink createExternalLink(String externalURI,
                                       InternationalString description)
                                throws JAXRException
Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.

Capability Level: 0

Parameters:
externalURI - the external URI
description - a description of the link (an InternationalString)
Returns:
the ExternalLink instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createExtrinsicObject

public ExtrinsicObject createExtrinsicObject(DataHandler repositoryItem)
                                      throws JAXRException
Creates an ExtrinsicObject instance using the specified parameters.

Capability Level: 1

Parameters:
repositoryItem - the DataHandler for the repository item. Must not be null.
Returns:
the ExtrinsicObject instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createInternationalString

public InternationalString createInternationalString()
                                              throws JAXRException
Creates an empty InternationalString instance.

Capability Level: 0

Returns:
the InternationalString instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createInternationalString

public InternationalString createInternationalString(String s)
                                              throws JAXRException
Creates an InternationalString instance using a String parameter and the default Locale.

Capability Level: 0

Parameters:
s - the String from which to create the InternationalString
Returns:
the InternationalString instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createInternationalString

public InternationalString createInternationalString(Locale l,
                                                     String s)
                                              throws JAXRException
Creates an InternationalString instance using the specified Locale and String parameters.

Capability Level: 0

Parameters:
l - the Locale in which to create the InternationalString
s - the String from which to create the InternationalString
Returns:
the InternationalString instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createKey

public Key createKey(String id)
              throws JAXRException
Creates a Key instance from an ID.

Capability Level: 0

Parameters:
id - the ID string from which to create the Key
Returns:
the Key instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createLocalizedString

public LocalizedString createLocalizedString(Locale l,
                                             String s)
                                      throws JAXRException
Creates a LocalizedString instance using the specified Locale and String parameters.

Capability Level: 0

Parameters:
l - the Locale in which to create the LocalizedString
s - the String from which to create the LocalizedString
Returns:
the LocalizedString instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createLocalizedString

public LocalizedString createLocalizedString(Locale l,
                                             String s,
                                             String charSetName)
                                      throws JAXRException
Creates a LocalizedString instance using the specified Locale, String, and character set parameters.

Capability Level: 0

Parameters:
l - the Locale in which to create the LocalizedString
s - the String from which to create the LocalizedString
charSetName - the name of the character set to use
Returns:
the LocalizedString instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createOrganization

public Organization createOrganization(String name)
                                throws JAXRException
Creates an Organization instance using the specified name, where the name is a String.

Capability Level: 0

Parameters:
name - the name of the Organization
Returns:
the Organization instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createOrganization

public Organization createOrganization(InternationalString name)
                                throws JAXRException
Creates an Organization instance using the specified name, where the name is an InternationalString.

Capability Level: 0

Parameters:
name - the name of the Organization
Returns:
the Organization instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createPersonName

public PersonName createPersonName(String firstName,
                                   String middleName,
                                   String lastName)
                            throws JAXRException
Creates a PersonName instance using the specified first, middle, and last names.

Capability Level: 1

Parameters:
firstName - the person's first name
middleName - the person's middle name
lastName - the person's last name
Returns:
the PersonName instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createPersonName

public PersonName createPersonName(String fullName)
                            throws JAXRException
Creates a PersonName instance using the specified full name.

Capability Level: 0

Parameters:
fullName - the person's full name
Returns:
the PersonName instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createPostalAddress

public PostalAddress createPostalAddress(String streetNumber,
                                         String street,
                                         String city,
                                         String stateOrProvince,
                                         String country,
                                         String postalCode,
                                         String type)
                                  throws JAXRException
Creates a PostalAddress instance using the specified parameters.

Capability Level: 0

Parameters:
streetNumber - the street number
street - the street name
city - the city name
stateOrProvince - the state or province name
country - the country name
postalCode - the postal code (such as a US ZIP code)
type - the type of the address
Returns:
the PostalAddress instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createRegistryPackage

public RegistryPackage createRegistryPackage(String name)
                                      throws JAXRException
Creates a RegistryPackage instance using the specified name, where the name is a String.

Capability Level: 1

Parameters:
name - the name of the registry package (a String)
Returns:
the RegistryPackage instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createRegistryPackage

public RegistryPackage createRegistryPackage(InternationalString name)
                                      throws JAXRException
Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.

Capability Level: 1

Parameters:
name - the name of the registry package (an InternationalString)
Returns:
the RegistryPackage instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createService

public Service createService(String name)
                      throws JAXRException
Creates a Service instance using the specified name, where the name is a String.

Capability Level: 0

Parameters:
name - the name of the Service (a String)
Returns:
the Service instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createService

public Service createService(InternationalString name)
                      throws JAXRException
Creates a Service instance using the specified name, where the name is an InternationalString.

Capability Level: 0

Parameters:
name - the name of the Service (an InternationalString)
Returns:
the Service instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createServiceBinding

public ServiceBinding createServiceBinding()
                                    throws JAXRException
Creates an empty ServiceBinding instance.

Capability Level: 0

Returns:
the ServiceBinding instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createSlot

public Slot createSlot(String name,
                       String value,
                       String slotType)
                throws JAXRException
Creates a Slot instance using the specified parameters, where the value is a String.

Capability Level: 0

Parameters:
name - the name of the Slot
value - the value (a String)
slotType - the slot type
Returns:
the Slot instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createSlot

public Slot createSlot(String name,
                       Collection values,
                       String slotType)
                throws JAXRException
Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.

Capability Level: 0

Parameters:
name - the name of the Slot
slotType - the slot type
Returns:
the Slot instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createSpecificationLink

public SpecificationLink createSpecificationLink()
                                          throws JAXRException
Creates an empty SpecificationLink instance.

Capability Level: 0

Returns:
the SpecificationLink instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createTelephoneNumber

public TelephoneNumber createTelephoneNumber()
                                      throws JAXRException
Creates an empty TelephoneNumber instance.

Capability Level: 0

Returns:
the TelephoneNumber instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createUser

public User createUser()
                throws JAXRException
Creates an empty User instance.

Capability Level: 0

Returns:
the User instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveObjects

public BulkResponse saveObjects(Collection objects)
                         throws JAXRException
Saves one or more Objects to the registry. An object may be a RegistryObject subclass instance.

If an object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, then its state is updated (replaced) in the registry.

Capability Level: 0

Parameters:
objects - a potentially heterogeneous Collection of RegistryObject instances
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deprecateObjects

public BulkResponse deprecateObjects(Collection keys)
                              throws JAXRException
Deprecates one or more previously submitted objects. Deprecation marks an object as "soon to be deleted". Once an object is deprecated, the JAXR provider must not allow any new references (e.g. new Associations, Classifications and ExternalLinks) to that object to be submitted. If a client makes an API call that results in a new reference to a deprecated object, the JAXR provider must throw a java.lang.IllegalStateException within a JAXRException. However, existing references to a deprecated object continue to function normally.

Capability Level: 1

Parameters:
keys - a Collection of keys for the objects to be deprecated
Returns:
a BulkResponse containing the Collection of keys for those objects that were deprecated successfully and any JAXRException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

unDeprecateObjects

public BulkResponse unDeprecateObjects(Collection keys)
                                throws JAXRException
Undeprecates one or more previously deprecated objects. If an object was not previously deprecated, it is not an error, and no exception is thrown. Once an object is undeprecated, the JAXR provider must again allow new references (e.g. new Associations, Classifications and ExternalLinks) to that object to be submitted.

Capability Level: 1

Parameters:
keys - a Collection of keys for the objects to be undeprecated
Returns:
a BulkResponse containing the Collection of keys for those objects that were deprecated successfully and any JAXRException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteObjects

public BulkResponse deleteObjects(Collection keys)
                           throws JAXRException
Deletes one or more previously submitted objects from the registry using the object keys.

Capability Level: 1

Parameters:
keys - a Collection of keys for the objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteObjects

public BulkResponse deleteObjects(Collection keys,
                                  String objectType)
                           throws JAXRException
Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.

Capability Level: 0

Parameters:
keys - a Collection of keys for the objects to be deleted
objectType - the objectType attribute for the objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

getRegistryService

public RegistryService getRegistryService()
                                   throws JAXRException
Returns the parent RegistryService that created this object.

Capability Level: 0

Returns:
the parent RegistryService
Throws:
JAXRException - if the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Query

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface Query

public interface Query

The Query interface encapsulates a query in a declarative query language. Currently a Query can be an SQL query or an ebXML Filter Query only. In future support for other query languages such as XQL query may be added. The query must conform to a fixed schema as defined by the JAXR specification.

Author:
Farrukh S. Najmi

Field Summary
static int | QUERY_TYPE_EBXML_FILTER_QUERY An OASIS ebXML Registry XML Filter Query type.
static int | QUERY_TYPE_SQL An SQL query type.
static int | QUERY_TYPE_XQUERY A W3C XQuery type.
Method Summary
int | getType() Gets the type of Query (for example, QUERY_TYPE_SQL).
String | toString() Returns the String representing the query.

Field Detail

QUERY_TYPE_SQL

public static final int QUERY_TYPE_SQL
An SQL query type.

See Also:
Constant Field Values

QUERY_TYPE_XQUERY

public static final int QUERY_TYPE_XQUERY
A W3C XQuery type.

See Also:
Constant Field Values

QUERY_TYPE_EBXML_FILTER_QUERY

public static final int QUERY_TYPE_EBXML_FILTER_QUERY
An OASIS ebXML Registry XML Filter Query type.

See Also:
Constant Field Values
Method Detail

getType

public int getType()
            throws JAXRException
Gets the type of Query (for example, QUERY_TYPE_SQL).

Capability Level: 1

Returns:
the type of query
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
QUERY_TYPE_SQL, QUERY_TYPE_XQUERY, QUERY_TYPE_EBXML_FILTER_QUERY

toString

public String toString()
Returns the String representing the query. For example, in the case of an SQL query, returns the SQL query as a string.

Capability Level: 1

Returns:
the String representation for this query
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QueryManager

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface QueryManager

All Known Subinterfaces:
BusinessQueryManager, DeclarativeQueryManager
public interface QueryManager

This is the common base interface for all QueryManagers in the API.

Author:
Farrukh S. Najmi

Method Summary
RegistryObject | getRegistryObject(String id) Gets the RegistryObject specified by the Id.
RegistryObject | getRegistryObject(String id, String objectType) Gets the RegistryObject specified by the Id and type of object.
BulkResponse | getRegistryObjects() Gets the RegistryObjects owned by the caller.
BulkResponse | getRegistryObjects(Collection objectKeys) Gets the specified RegistryObjects.
BulkResponse | getRegistryObjects(Collection objectKeys, String objectTypes) Gets the specified RegistryObjects.
BulkResponse | getRegistryObjects(String objectType) Gets the RegistryObjects owned by the caller, that are of the specified type.
RegistryService | getRegistryService() Returns the parent RegistryService that created this object.

Method Detail

getRegistryObject

public RegistryObject getRegistryObject(String id,
                                        String objectType)
                                 throws JAXRException
Gets the RegistryObject specified by the Id and type of object.

Capability Level: 0

Parameters:
id - is the id of the Key for a RegistryObject.
objectType - is a constant definition from LifeCycleManager that specifies the type of object desired.
Returns:
the RegistryObject, returned as its concrete type (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObject

public RegistryObject getRegistryObject(String id)
                                 throws JAXRException
Gets the RegistryObject specified by the Id.

Capability Level: 1

Parameters:
id - the id for the desired object
Returns:
the RegistryObject, returned as its concrete type (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObjects

public BulkResponse getRegistryObjects(Collection objectKeys)
                                throws JAXRException
Gets the specified RegistryObjects. The objects are returned as their concrete type (e.g. Organization, User etc.).

Capability Level: 1

Parameters:
objectKeys - a Collection of Key objects for the desired objects
Returns:
BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObjects

public BulkResponse getRegistryObjects(Collection objectKeys,
                                       String objectTypes)
                                throws JAXRException
Gets the specified RegistryObjects. The objects are returned as their concrete type (e.g. Organization, User etc.).

Capability Level: 0

Parameters:
objectKeys - a Collection of Key objects for the desired objects
objectTypes - a Collection of String objects that allow filtering desired objects by their type
Returns:
BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObjects

public BulkResponse getRegistryObjects()
                                throws JAXRException
Gets the RegistryObjects owned by the caller. The objects are returned as their concrete type (e.g. Organization, User etc.).

Capability Level: 0

Returns:
BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObjects

public BulkResponse getRegistryObjects(String objectType)
                                throws JAXRException
Gets the RegistryObjects owned by the caller, that are of the specified type. The objects are returned as their concrete type (e.g. Organization, User etc.).

Capability Level: 0

Parameters:
objectType - Is a constant that defines the type of object sought. See LifeCycleManager for constants for object types.
Returns:
BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
LifeCycleManager.ORGANIZATION

getRegistryService

public RegistryService getRegistryService()
                                   throws JAXRException
Returns the parent RegistryService that created this object.

Capability Level: 0

Returns:
the RegistryService created this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RegistryException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class RegistryException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.registry.JAXRException
                extended by javax.xml.registry.RegistryException
All Implemented Interfaces:
JAXRResponse, Serializable
Direct Known Subclasses:
DeleteException, FindException, SaveException
public class RegistryException
extends JAXRException

This is the common base class for all Exceptions that are detected on the registry provider side rather than the JAXR client side.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
RegistryException()
Constructs a JAXRException object with no reason or embedded Throwable.
RegistryException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
RegistryException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
RegistryException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Method Summary
Key | getErrorObjectKey() Gets the Key to the first object that encountered an error in the registry.
void | setErrorObjectKey(Key key) Sets the Key to the first object that encountered an error in the registry.
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RegistryException

public RegistryException()
Constructs a JAXRException object with no reason or embedded Throwable.

RegistryException

public RegistryException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

RegistryException

public RegistryException(String reason,
                         Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

RegistryException

public RegistryException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Method Detail

getErrorObjectKey

public Key getErrorObjectKey()
                      throws JAXRException
Gets the Key to the first object that encountered an error in the registry.

Returns:
the key to the first object in error
Throws:
JAXRException

setErrorObjectKey

public void setErrorObjectKey(Key key)
                       throws JAXRException
Sets the Key to the first object that encountered an error in the registry.

Parameters:
key - the key to the first object in error
Throws:
JAXRException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


RegistryService

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface RegistryService

public interface RegistryService

This is the principal interface implemented by a JAXR provider. A registry client can get this interface from a Connection to a registry. It provides the methods that are used by the client to discover various capability specific interfaces implemented by the JAXR provider.

Author:
Farrukh S. Najmi
See Also:
Connection

Method Summary
BulkResponse | getBulkResponse(String requestId) Returns the BulkResponse associated with specified requestId.
BusinessLifeCycleManager | getBusinessLifeCycleManager() Returns the BusinessLifeCycleManager object implemented by the JAXR provider.
BusinessQueryManager | getBusinessQueryManager() Returns the BusinessQueryManager object implemented by the JAXR provider.
CapabilityProfile | getCapabilityProfile() Returns the CapabilityProfile for the JAXR provider.
DeclarativeQueryManager | getDeclarativeQueryManager() Returns the DeclarativeQueryManager object implemented by the JAXR provider.
ClassificationScheme | getDefaultPostalScheme() Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.
String | makeRegistrySpecificRequest(String request) Takes a String that is an XML request in a registry-specific format, sends the request to the registry, and returns a String that is the registry-specific XML response.

Method Detail

getCapabilityProfile

public CapabilityProfile getCapabilityProfile()
                                       throws JAXRException
Returns the CapabilityProfile for the JAXR provider.

Capability Level: 0

Returns:
the CapabilityProfile for a JAXR provider
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
LifeCycleManager

getBusinessLifeCycleManager

public BusinessLifeCycleManager getBusinessLifeCycleManager()
                                                     throws JAXRException
Returns the BusinessLifeCycleManager object implemented by the JAXR provider.

Capability Level: 0

Returns:
the BusinessLifeCycleManager
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
LifeCycleManager

getBusinessQueryManager

public BusinessQueryManager getBusinessQueryManager()
                                             throws JAXRException
Returns the BusinessQueryManager object implemented by the JAXR provider.

Capability Level: 0

Returns:
the BusinessQueryManaer
Throws:
JAXRException - If the JAXR provider encounters an internal error

getDeclarativeQueryManager

public DeclarativeQueryManager getDeclarativeQueryManager()
                                                   throws JAXRException,
                                                          UnsupportedCapabilityException
Returns the DeclarativeQueryManager object implemented by the JAXR provider.

Capability Level: 1

Returns:
the DeclarativeQueryManager
Throws:
JAXRException - If the JAXR provider encounters an internal error
UnsupportedCapabilityException

getBulkResponse

public BulkResponse getBulkResponse(String requestId)
                             throws InvalidRequestException,
                                    JAXRException
Returns the BulkResponse associated with specified requestId. Once a client retrieves a BulkResponse for a particular requestId any subsequent calls to retrieve the Bulkresponse for the same requestId should result in an InvalidRequestException.

Capability Level: 0

Parameters:
requestId - the id for a previous asynchronous request
Returns:
the BulkResponse that contains the result for the specified request
Throws:
InvalidRequestException - if no responses exist for specified requestId
JAXRException - If the JAXR provider encounters an internal error

getDefaultPostalScheme

public ClassificationScheme getDefaultPostalScheme()
                                            throws JAXRException
Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.

Capability Level: 0

Returns:
the ClassificationScheme that is the default postal scheme
Throws:
JAXRException - If the JAXR provider encounters an internal error

makeRegistrySpecificRequest

public String makeRegistrySpecificRequest(String request)
                                   throws JAXRException
Takes a String that is an XML request in a registry-specific format, sends the request to the registry, and returns a String that is the registry-specific XML response.

Capability Level: 0

Parameters:
request - the registry-specific request in a String representation
Returns:
the String that is the XML response in a registry-specific manner
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SaveException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class SaveException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.registry.JAXRException
                extended by javax.xml.registry.RegistryException
                    extended by javax.xml.registry.SaveException
All Implemented Interfaces:
JAXRResponse, Serializable
public class SaveException
extends RegistryException

A RegistryException that occurs during a save action.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
SaveException()
Constructs a JAXRException object with no reason or embedded Throwable.
SaveException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
SaveException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
SaveException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Methods inherited from class javax.xml.registry.RegistryException
getErrorObjectKey, setErrorObjectKey
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SaveException

public SaveException()
Constructs a JAXRException object with no reason or embedded Throwable.

SaveException

public SaveException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

SaveException

public SaveException(String reason,
                     Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

SaveException

public SaveException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


UnexpectedObjectException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class UnexpectedObjectException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.registry.JAXRException
                extended by javax.xml.registry.UnexpectedObjectException
All Implemented Interfaces:
JAXRResponse, Serializable
public class UnexpectedObjectException
extends JAXRException

This exception is thrown when the JAXR provider finds a Object that is out-of-place or of the wrong type within the context of a user request. For example a saveOrganizations request in BusinessLifeCycleManager would throw this Exception if it found an Object other than Organization in the Collection of Objects provided by client to be saved by the request.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
UnexpectedObjectException()
Constructs a JAXRException object with no reason or embedded Throwable.
UnexpectedObjectException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
UnexpectedObjectException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
UnexpectedObjectException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnexpectedObjectException

public UnexpectedObjectException()
Constructs a JAXRException object with no reason or embedded Throwable.

UnexpectedObjectException

public UnexpectedObjectException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

UnexpectedObjectException

public UnexpectedObjectException(String reason,
                                 Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

UnexpectedObjectException

public UnexpectedObjectException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


UnsupportedCapabilityException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class UnsupportedCapabilityException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.registry.JAXRException
                extended by javax.xml.registry.UnsupportedCapabilityException
All Implemented Interfaces:
JAXRResponse, Serializable
public class UnsupportedCapabilityException
extends JAXRException

This exception must be thrown when a JAXR client attempts to invoke an API method that is not supported by the capability profile that is supported by the JAXR provider.

Author:
Farrukh S. Najmi
See Also:
RegistryService, Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
UnsupportedCapabilityException()
Constructs a JAXRException object with no reason or embedded Throwable.
UnsupportedCapabilityException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
UnsupportedCapabilityException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
UnsupportedCapabilityException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnsupportedCapabilityException

public UnsupportedCapabilityException()
Constructs a JAXRException object with no reason or embedded Throwable.

UnsupportedCapabilityException

public UnsupportedCapabilityException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

UnsupportedCapabilityException

public UnsupportedCapabilityException(String reason,
                                      Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

UnsupportedCapabilityException

public UnsupportedCapabilityException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


rpc

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc

This package contains the core JAX-RPC APIs for the client programming model.

See:
Description

Interface Summary
Call | The javax.xml.rpc.Call interface provides support for the dynamic invocation of a service endpoint.
Service | Service class acts as a factory of the following: Dynamic proxy for the target service endpoint.
Stub | The interface javax.xml.rpc.Stub is the common base interface for the stub classes.

Class Summary
NamespaceConstants | Constants used in JAX-RPC for namespace prefixes and URIs
ParameterMode | The javax.xml.rpc.ParameterMode is a type-safe enumeration for parameter mode.
ServiceFactory | The javax.xml.rpc.ServiceFactory is an abstract class that provides a factory for the creation of instances of the type javax.xml.rpc.Service.

Exception Summary
JAXRPCException | The javax.xml.rpc.JAXRPCException is thrown from the core JAX-RPC APIs to indicate an exception related to the JAX-RPC runtime mechanisms.
ServiceException | The javax.xml.rpc.ServiceException is thrown from the methods in the javax.xml.rpc.Service interface and ServiceFactory class.

Package javax.xml.rpc Description

This package contains the core JAX-RPC APIs for the client programming model.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.rpc.NamespaceConstants
    • class javax.xml.rpc.ParameterMode
    • class javax.xml.rpc.ServiceFactory
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class javax.xml.rpc.JAXRPCException
        • class javax.xml.rpc.ServiceException

Interface Hierarchy

  • interface javax.xml.rpc.Call
  • interface javax.xml.rpc.Service
  • interface javax.xml.rpc.Stub
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Call

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Interface Call

public interface Call

The javax.xml.rpc.Call interface provides support for the dynamic invocation of a service endpoint. The javax.xml.rpc.Service interface acts as a factory for the creation of Call instances.

Once a Call instance is created, various setter and getter methods may be used to configure this Call instance.

Version:
1.0
Author:
Rahul Sharma

Field Summary
static String | ENCODINGSTYLE_URI_PROPERTY Standard property for encoding Style: Encoding style specified as a namespace URI.
static String | OPERATION_STYLE_PROPERTY Standard property for operation style.
static String | PASSWORD_PROPERTY Standard property: Password for authentication Type: java.lang.String
static String | SESSION_MAINTAIN_PROPERTY Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.
static String | SOAPACTION_URI_PROPERTY Standard property for SOAPAction.
static String | SOAPACTION_USE_PROPERTY Standard property for SOAPAction.
static String | USERNAME_PROPERTY Standard property: User name for authentication Type: java.lang.String
Method Summary
void | addParameter(String paramName, QName xmlType, Class javaType, ParameterMode parameterMode) Adds a parameter type and mode for a specific operation.
void | addParameter(String paramName, QName xmlType, ParameterMode parameterMode) Adds a parameter type and mode for a specific operation.
QName | getOperationName() Gets the name of the operation to be invoked using this Call instance.
Map | getOutputParams() Returns a Map of {name, value} for the output parameters of the last invoked operation.
List | getOutputValues() Returns a List values for the output parameters of the last invoked operation.
QName | getParameterTypeByName(String paramName) Gets the XML type of a parameter by name
QName | getPortTypeName() Gets the qualified name of the port type.
Object | getProperty(String name) Gets the value of a named property.
Iterator | getPropertyNames() Gets the names of configurable properties supported by this Call object.
QName | getReturnType() Gets the return type for a specific operation
String | getTargetEndpointAddress() Gets the address of a target service endpoint.
Object | invoke(Object[] inputParams) Invokes a specific operation using a synchronous request-response interaction mode.
Object | invoke(QName operationName, Object[] inputParams) Invokes a specific operation using a synchronous request-response interaction mode.
void | invokeOneWay(Object[] inputParams) Invokes a remote method using the one-way interaction mode.
boolean | isParameterAndReturnSpecRequired(QName operationName) Indicates whether addParameter and setReturnType methods are to be invoked to specify the parameter and return type specification for a specific operation.
void | removeAllParameters() Removes all specified parameters from this Call instance.
void | removeProperty(String name) Removes a named property.
void | setOperationName(QName operationName) Sets the name of the operation to be invoked using this Call instance.
void | setPortTypeName(QName portType) Sets the qualified name of the port type.
void | setProperty(String name, Object value) Sets the value for a named property.
void | setReturnType(QName xmlType) Sets the return type for a specific operation.
void | setReturnType(QName xmlType, Class javaType) Sets the return type for a specific operation.
void | setTargetEndpointAddress(String address) Sets the address of the target service endpoint.

Field Detail

USERNAME_PROPERTY

public static final String USERNAME_PROPERTY
Standard property: User name for authentication

Type: java.lang.String

See Also:
Constant Field Values

PASSWORD_PROPERTY

public static final String PASSWORD_PROPERTY
Standard property: Password for authentication

Type: java.lang.String

See Also:
Constant Field Values

OPERATION_STYLE_PROPERTY

public static final String OPERATION_STYLE_PROPERTY
Standard property for operation style. This property is set to "rpc" if the operation style is rpc; "document" if the operation style is document.

Type: java.lang.String

See Also:
Constant Field Values

SOAPACTION_USE_PROPERTY

public static final String SOAPACTION_USE_PROPERTY
Standard property for SOAPAction. This boolean property indicates whether or not SOAPAction is to be used. The default value of this property is false indicating that the SOAPAction is not used.

Type: java.lang.Boolean

See Also:
Constant Field Values

SOAPACTION_URI_PROPERTY

public static final String SOAPACTION_URI_PROPERTY
Standard property for SOAPAction. Indicates the SOAPAction URI if the javax.xml.rpc.soap.http.soapaction.use property is set to true.

Type: java.lang.String

See Also:
Constant Field Values

ENCODINGSTYLE_URI_PROPERTY

public static final String ENCODINGSTYLE_URI_PROPERTY
Standard property for encoding Style: Encoding style specified as a namespace URI. The default value is the SOAP 1.1 encoding http://schemas.xmlsoap.org/soap/encoding/

Type: java.lang.String

See Also:
Constant Field Values

SESSION_MAINTAIN_PROPERTY

public static final String SESSION_MAINTAIN_PROPERTY
Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint. If this property is set to true, the service client indicates that it wants the session to be maintained. If set to false, the session is not maintained. The default value for this property is false.

Type: java.lang.Boolean

See Also:
Constant Field Values
Method Detail

isParameterAndReturnSpecRequired

public boolean isParameterAndReturnSpecRequired(QName operationName)
Indicates whether addParameter and setReturnType methods are to be invoked to specify the parameter and return type specification for a specific operation.

Parameters:
operationName - Qualified name of the operation
Returns:
Returns true if the Call implementation class requires addParameter and setReturnType to be invoked in the client code for the specified operation. This method returns false otherwise.
Throws:
IllegalArgumentException - If invalid operation name is specified

addParameter

public void addParameter(String paramName,
                         QName xmlType,
                         ParameterMode parameterMode)
Adds a parameter type and mode for a specific operation. Note that the client code may not call any addParameter and setReturnType methods before calling the invoke method. In this case, the Call implementation class determines the parameter types by using reflection on parameters, using the WSDL description and configured type mapping registry.

Parameters:
paramName - Name of the parameter
xmlType - XML type of the parameter
parameterMode - Mode of the parameter-whether ParameterMode.IN, ParameterMode.OUT, or ParameterMode.INOUT,
Throws:
javax.xml.rpc.JAXRPCException: - This exception may be thrown if the method isParameterAndReturnSpecRequired returns false for this operation.
IllegalArgumentException - If any illegal parameter name or XML type is specified
See Also:
isParameterAndReturnSpecRequired(javax.xml.namespace.QName)

addParameter

public void addParameter(String paramName,
                         QName xmlType,
                         Class javaType,
                         ParameterMode parameterMode)
Adds a parameter type and mode for a specific operation. This method is used to specify the Java type for either OUT or INOUT parameters.

Parameters:
paramName - Name of the parameter
xmlType - XML type of the parameter
javaType - Java class of the parameter
parameterMode - Mode of the parameter-whether ParameterMode.IN, OUT or INOUT
Throws:
JAXRPCException -
  • This exception may be thrown if this method is invoked when the method isParameterAndReturnSpecRequired returns false.
  • If specified XML type and Java type mapping is not valid. For example, TypeMappingRegistry has no serializers for this mapping.
IllegalArgumentException - If any illegal parameter name or XML type is specified
UnsupportedOperationException - If this method is not supported
See Also:
isParameterAndReturnSpecRequired(javax.xml.namespace.QName)

getParameterTypeByName

public QName getParameterTypeByName(String paramName)
Gets the XML type of a parameter by name

Parameters:
paramName - Name of the parameter
Returns:
Returns XML type for the specified parameter

setReturnType

public void setReturnType(QName xmlType)
Sets the return type for a specific operation. Invoking setReturnType(null) removes the return type for this Call object.

Parameters:
xmlType - XML data type of the return value
Throws:
JAXRPCException - This exception may be thrown when the method isParameterAndReturnSpecRequired returns false.
IllegalArgumentException - If an illegal XML type is specified

setReturnType

public void setReturnType(QName xmlType,
                          Class javaType)
Sets the return type for a specific operation.

Parameters:
javaType - Java Class of the return value
Throws:
JAXRPCException -
  • This exception may be thrown if this method is invoked when the method isParameterAndReturnSpecRequired returns false.
  • If XML type and Java type cannot be mapped using the standard type mapping or TypeMapping registry
UnsupportedOperationException - If this method is not supported
IllegalArgumentException - If an illegal XML type is specified

getReturnType

public QName getReturnType()
Gets the return type for a specific operation

Returns:
Returns the XML type for the return value

removeAllParameters

public void removeAllParameters()
Removes all specified parameters from this Call instance. Note that this method removes only the parameters and not the return type. The setReturnType(null) is used to remove the return type.

Throws:
JAXRPCException - This exception may be thrown If this method is called when the method isParameterAndReturnSpecRequired returns false for this Call's operation.

getOperationName

public QName getOperationName()
Gets the name of the operation to be invoked using this Call instance.

Returns:
Qualified name of the operation

setOperationName

public void setOperationName(QName operationName)
Sets the name of the operation to be invoked using this Call instance.

Parameters:
operationName - QName of the operation to be invoked using the Call instance

getPortTypeName

public QName getPortTypeName()
Gets the qualified name of the port type.

Returns:
Qualified name of the port type

setPortTypeName

public void setPortTypeName(QName portType)
Sets the qualified name of the port type.

Parameters:
portType - Qualified name of the port type

setTargetEndpointAddress

public void setTargetEndpointAddress(String address)
Sets the address of the target service endpoint. This address must correspond to the transport specified in the binding for this Call instance.

Parameters:
address - Address of the target service endpoint; specified as an URI

getTargetEndpointAddress

public String getTargetEndpointAddress()
Gets the address of a target service endpoint.

Returns:
Address of the target service endpoint as an URI

setProperty

public void setProperty(String name,
                        Object value)
Sets the value for a named property. JAX-RPC specification specifies a standard set of properties that may be passed to the Call.setProperty method.

Parameters:
name - Name of the property
value - Value of the property
Throws:
JAXRPCException -
  • If an optional standard property name is specified, however this Call implementation class does not support the configuration of this property.
  • If an invalid (or unsupported) property name is specified or if a value of mismatched property type is passed.
  • If there is any error in the configuration of a valid property.

getProperty

public Object getProperty(String name)
Gets the value of a named property.

Parameters:
name - Name of the property
Returns:
Value of the named property
Throws:
JAXRPCException - if an invalid or unsupported property name is passed.

removeProperty

public void removeProperty(String name)
Removes a named property.

Parameters:
name - Name of the property
Returns:
boolean Returns code>true if the specified property is removed; false otherwise
Throws:
JAXRPCException - if an invalid or unsupported property name is passed.

getPropertyNames

public Iterator getPropertyNames()
Gets the names of configurable properties supported by this Call object.

Returns:
Iterator for the property names

invoke

public Object invoke(Object[] inputParams)
              throws RemoteException
Invokes a specific operation using a synchronous request-response interaction mode.

Parameters:
inputParams - Object[]--Parameters for this invocation. This includes only the input params
Returns:
Returns the return value or null
Throws:
RemoteException - if there is any error in the remote method invocation
SOAPFaultException - Indicates a SOAP fault
JAXRPCException -
  • If there is an error in the configuration of the Call object
  • If inputParams do not match the required parameter set (as specified through the addParameter invocations or in the corresponding WSDL)
  • If parameters and return type are incorrectly specified

invoke

public Object invoke(QName operationName,
                     Object[] inputParams)
              throws RemoteException
Invokes a specific operation using a synchronous request-response interaction mode.

Parameters:
operationName - QName of the operation
inputParams - Object[]--Parameters for this invocation. This includes only the input params.
Returns:
Return value or null
Throws:
RemoteException - if there is any error in the remote method invocation.
SOAPFaultException - Indicates a SOAP fault
JAXRPCException -
  • If there is an error in the configuration of the Call object
  • If inputParams do not match the required parameter set (as specified through the addParameter invocations or in the corresponding WSDL)
  • If parameters and return type are incorrectly specified

invokeOneWay

public void invokeOneWay(Object[] inputParams)
Invokes a remote method using the one-way interaction mode. The client thread does not normally block waiting for the completion of the server processing for this remote method invocation. When the protocol in use is SOAP/HTTP, this method should block until an HTTP response code has been received or an error occurs. This method must not throw any remote exceptions. This method may throw a JAXRPCException during the processing of the one-way remote call.

Parameters:
inputParams - Object[]--Parameters for this invocation. This includes only the input params.
Throws:
JAXRPCException - if there is an error in the configuration of the Call object (example: a non-void return type has been incorrectly specified for the one-way call) or if there is any error during the invocation of the one-way remote call

getOutputParams

public Map getOutputParams()
Returns a Map of {name, value} for the output parameters of the last invoked operation. The parameter names in the returned Map are of type java.lang.String.

Returns:
Map Output parameters for the last Call.invoke(). Empty Map is returned if there are no output parameters.
Throws:
JAXRPCException - If this method is invoked for a one-way operation or is invoked before any invoke method has been called.

getOutputValues

public List getOutputValues()
Returns a List values for the output parameters of the last invoked operation.

Returns:
java.util.List Values for the output parameters. An empty List is returned if there are no output values.
Throws:
JAXRPCException - If this method is invoked for a one-way operation or is invoked before any invoke method has been called.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


encoding

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.encoding

This package defines APIs for the extensible type mapping framework.

See:
Description

Interface Summary
DeserializationContext | The javax.xml.rpc.encoding.DeserializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner.
Deserializer | The javax.xml.rpc.encoding.Deserializer interface defines a base interface for deserializers.
DeserializerFactory | The javax.xml.rpc.encoding.DeserializerFactory is a factory of deserializers.
SerializationContext | The javax.xml.rpc.encoding.SerializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner.
Serializer | The javax.xml.rpc.encoding.Serializer interface defines the base interface for serializers.
SerializerFactory | The javax.xml.rpc.encoding.SerializerFactory is a factory of the serializers.
TypeMapping | The javax.xml.rpc.encoding.TypeMapping is the base interface for the representation of a type mapping.
TypeMappingRegistry | The interface javax.xml.rpc.encoding.TypeMappingRegistry defines a registry of TypeMapping instances for various encoding styles.

Class Summary
XMLType Constants for common XML Schema and SOAP 1.1 types.

Package javax.xml.rpc.encoding Description

This package defines APIs for the extensible type mapping framework.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeserializationContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface DeserializationContext

public interface DeserializationContext

The javax.xml.rpc.encoding.DeserializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner. A deserializer uses this interface to access and maintain context information during the deserialization..

Version:
1.0
Author:
Rahul Sharma

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.encoding Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.encoding

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.rpc.encoding.XMLType

Interface Hierarchy

  • interface javax.xml.rpc.encoding.DeserializationContext
  • interface java.io.Serializable
    • interface javax.xml.rpc.encoding.Deserializer
    • interface javax.xml.rpc.encoding.DeserializerFactory
    • interface javax.xml.rpc.encoding.Serializer
    • interface javax.xml.rpc.encoding.SerializerFactory
    • interface javax.xml.rpc.encoding.TypeMappingRegistry
  • interface javax.xml.rpc.encoding.SerializationContext
  • interface javax.xml.rpc.encoding.TypeMapping
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SerializationContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface SerializationContext

public interface SerializationContext

The javax.xml.rpc.encoding.SerializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner. A serializer uses the SerializationContext interface during the serialization to get the context information related to the XML processing mechanism and to manage information specific to serialization.

Version:
1.0
Author:
Rahul Sharma
See Also:
Serializer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Deserializer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface Deserializer

All Superinterfaces:
Serializable
public interface Deserializer
extends Serializable

The javax.xml.rpc.encoding.Deserializer interface defines a base interface for deserializers. A Deserializer converts an XML representation to a Java object using a specific XML processing mechanism and based on the specified type mapping and encoding style.

Version:
1.0
Author:
Rahul Sharma

Method Summary
 String getMechanismType()
Gets the type of the XML processing mechanism and representation used by this Deserializer.

Method Detail

getMechanismType

public String getMechanismType()
Gets the type of the XML processing mechanism and representation used by this Deserializer.

Returns:
XML processing mechanism type
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DeserializerFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface DeserializerFactory

All Superinterfaces:
Serializable
public interface DeserializerFactory
extends Serializable

The javax.xml.rpc.encoding.DeserializerFactory is a factory of deserializers. A DeserializerFactory is registered with a TypeMapping instance as part of the TypeMappingRegistry.

Version:
1.0
Author:
Rahul Sharma
See Also:
Serializer

Method Summary
Deserializer | getDeserializerAs(String mechanismType) Returns a Deserializer for the specified XML processing mechanism type.
Iterator | getSupportedMechanismTypes() Returns a list of all XML processing mechanism types supported by this DeserializerFactory.

Method Detail

getDeserializerAs

public Deserializer getDeserializerAs(String mechanismType)
Returns a Deserializer for the specified XML processing mechanism type.

Parameters:
mechanismType - XML processing mechanism type [TBD: definition of valid constants]
Throws:
JAXRPCException - If DeserializerFactory does not support the specified XML processing mechanism

getSupportedMechanismTypes

public Iterator getSupportedMechanismTypes()
Returns a list of all XML processing mechanism types supported by this DeserializerFactory.

Returns:
List of unique identifiers for the supported XML processing mechanism types
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Serializer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface Serializer

All Superinterfaces:
Serializable
public interface Serializer
extends Serializable

The javax.xml.rpc.encoding.Serializer interface defines the base interface for serializers. A Serializer converts a Java object to an XML representation using a specific XML processing mechanism and based on the specified type mapping and encoding style.

Version:
1.0
Author:
Rahul Sharma

Method Summary
 String getMechanismType()
Gets the type of the XML processing mechanism and representation used by this Serializer.

Method Detail

getMechanismType

public String getMechanismType()
Gets the type of the XML processing mechanism and representation used by this Serializer.

Returns:
XML processing mechanism type
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SerializerFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface SerializerFactory

All Superinterfaces:
Serializable
public interface SerializerFactory
extends Serializable

The javax.xml.rpc.encoding.SerializerFactory is a factory of the serializers. A SerializerFactory is registered with a TypeMapping object as part of the TypeMappingRegistry.

Version:
1.0
Author:
Rahul Sharma
See Also:
Serializer

Method Summary
Serializer | getSerializerAs(String mechanismType) Returns a Serializer for the specified XML processing mechanism type.
Iterator | getSupportedMechanismTypes() Returns a list of all XML processing mechanism types supported by this SerializerFactory.

Method Detail

getSerializerAs

public Serializer getSerializerAs(String mechanismType)
Returns a Serializer for the specified XML processing mechanism type.

Parameters:
mechanismType - XML processing mechanism type [TBD: definition of valid constants]
Throws:
JAXRPCException - If SerializerFactory does not support the specified XML processing mechanism
IllegalArgumentException - If an invalid mechanism type is specified.

getSupportedMechanismTypes

public Iterator getSupportedMechanismTypes()
Returns a list of all XML processing mechanism types supported by this SerializerFactory.

Returns:
List of unique identifiers for the supported XML processing mechanism types
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TypeMapping

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface TypeMapping

public interface TypeMapping

The javax.xml.rpc.encoding.TypeMapping is the base interface for the representation of a type mapping. A TypeMapping implementation class may support one or more encoding styles.

For its supported encoding styles, a TypeMapping instance maintains a set of tuples of the type {Java type, SerializerFactory, DeserializerFactory, XML type}.

Version:
1.0
Author:
Rahul Sharma

Method Summary
DeserializerFactory | getDeserializer(Class javaType, QName xmlType) Gets the DeserializerFactory registered for the specified pair of Java type and XML data type.
SerializerFactory | getSerializer(Class javaType, QName xmlType) Gets the SerializerFactory registered for the specified pair of Java type and XML data type.
String[] | getSupportedEncodings() Returns the encodingStyle URIs (as String[]) supported by this TypeMapping instance.
boolean | isRegistered(Class javaType, QName xmlType) Checks whether or not type mapping between specified XML type and Java type is registered.
void | register(Class javaType, QName xmlType, SerializerFactory sf, DeserializerFactory dsf) Registers SerializerFactory and DeserializerFactory for a specific type mapping between an XML type and Java type.
void | removeDeserializer(Class javaType, QName xmlType) Removes the DeserializerFactory registered for the specified pair of Java type and XML data type.
void | removeSerializer(Class javaType, QName xmlType) Removes the SerializerFactory registered for the specified pair of Java type and XML data type.
void | setSupportedEncodings(String[] encodingStyleURIs) Sets the encodingStyle URIs supported by this TypeMapping instance.

Method Detail

getSupportedEncodings

public String[] getSupportedEncodings()
Returns the encodingStyle URIs (as String[]) supported by this TypeMapping instance. A TypeMapping that contains only encoding style independent serializers and deserializers returns null from this method.

Returns:
Array of encodingStyle URIs for the supported encoding styles

setSupportedEncodings

public void setSupportedEncodings(String[] encodingStyleURIs)
Sets the encodingStyle URIs supported by this TypeMapping instance. A TypeMapping that contains only encoding independent serializers and deserializers requires null as the parameter for this method.

Parameters:
encodingStyleURIs - Array of encodingStyle URIs for the supported encoding styles

isRegistered

public boolean isRegistered(Class javaType,
                            QName xmlType)
Checks whether or not type mapping between specified XML type and Java type is registered.

Parameters:
javaType - Class of the Java type
Returns:
boolean; true if type mapping between the specified XML type and Java type is registered; otherwise false

register

public void register(Class javaType,
                     QName xmlType,
                     SerializerFactory sf,
                     DeserializerFactory dsf)
Registers SerializerFactory and DeserializerFactory for a specific type mapping between an XML type and Java type. This method replaces any existing registered SerializerFactory DeserializerFactory instances.

Parameters:
javaType - Class of the Java type
sf - SerializerFactory
dsf - DeserializerFactory
Throws:
JAXRPCException - If any error during the registration

getSerializer

public SerializerFactory getSerializer(Class javaType,
                                       QName xmlType)
Gets the SerializerFactory registered for the specified pair of Java type and XML data type.

Parameters:
javaType - Class of the Java type
Returns:
Registered SerializerFactory or null if there is no registered factory

getDeserializer

public DeserializerFactory getDeserializer(Class javaType,
                                           QName xmlType)
Gets the DeserializerFactory registered for the specified pair of Java type and XML data type.

Parameters:
javaType - Class of the Java type
Returns:
Registered DeserializerFactory or null if there is no registered factory

removeSerializer

public void removeSerializer(Class javaType,
                             QName xmlType)
Removes the SerializerFactory registered for the specified pair of Java type and XML data type.

Throws:
JAXRPCException - If there is error in removing the registered SerializerFactory

removeDeserializer

public void removeDeserializer(Class javaType,
                               QName xmlType)
Removes the DeserializerFactory registered for the specified pair of Java type and XML data type.

Throws:
JAXRPCException - If there is error in removing the registered DeserializerFactory
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TypeMappingRegistry

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface TypeMappingRegistry

All Superinterfaces:
Serializable
public interface TypeMappingRegistry
extends Serializable

The interface javax.xml.rpc.encoding.TypeMappingRegistry defines a registry of TypeMapping instances for various encoding styles.

Version:
1.0
Author:
Rahul Sharma

Method Summary
void | clear() Removes all registered TypeMappings and encodingStyleURIs from this TypeMappingRegistry.
TypeMapping | createTypeMapping() Creates a new empty TypeMapping object.
TypeMapping | getDefaultTypeMapping() Gets the registered default TypeMapping instance.
String[] | getRegisteredEncodingStyleURIs() Returns a list of registered encodingStyle URIs in this TypeMappingRegistry instance.
TypeMapping | getTypeMapping(String encodingStyleURI) Returns the registered TypeMapping for the specified encodingStyle URI.
TypeMapping | register(String encodingStyleURI, TypeMapping mapping) Registers a TypeMapping instance with the TypeMappingRegistry.
void | registerDefault(TypeMapping mapping) Registers the TypeMapping instance that is default for all encoding styles supported by the TypeMappingRegistry.
boolean | removeTypeMapping(TypeMapping mapping) Removes a TypeMapping from the TypeMappingRegistry.
TypeMapping | unregisterTypeMapping(String encodingStyleURI) Unregisters a TypeMapping instance, if present, from the specified encodingStyleURI.

Method Detail

register

public TypeMapping register(String encodingStyleURI,
                            TypeMapping mapping)
Registers a TypeMapping instance with the TypeMappingRegistry. This method replaces any existing registered TypeMapping instance for the specified encodingStyleURI.

Parameters:
encodingStyleURI - An encoding style specified as an URI. An example is "http://schemas.xmlsoap.org/soap/encoding/"
mapping - TypeMapping instance
Returns:
Previous TypeMapping associated with the specified encodingStyleURI, or null if there was no TypeMapping associated with the specified encodingStyleURI
Throws:
JAXRPCException - If there is an error in the registration of the TypeMapping for the specified encodingStyleURI.

registerDefault

public void registerDefault(TypeMapping mapping)
Registers the TypeMapping instance that is default for all encoding styles supported by the TypeMappingRegistry. A default TypeMapping should include serializers and deserializers that are independent of and usable with any encoding style. Successive invocations of the registerDefault method replace any existing default TypeMapping instance.

If the default TypeMapping is registered, any other TypeMapping instances registered through the TypeMappingRegistry.register method (for a set of encodingStyle URIs) override the default TypeMapping.

Parameters:
mapping - TypeMapping instance
Throws:
JAXRPCException - If there is an error in the registration of the default TypeMapping

getDefaultTypeMapping

public TypeMapping getDefaultTypeMapping()
Gets the registered default TypeMapping instance. This method returns null if there is no registered default TypeMapping in the registry.

Returns:
The registered default TypeMapping instance or null

getRegisteredEncodingStyleURIs

public String[] getRegisteredEncodingStyleURIs()
Returns a list of registered encodingStyle URIs in this TypeMappingRegistry instance.

Returns:
Array of the registered encodingStyle URIs

getTypeMapping

public TypeMapping getTypeMapping(String encodingStyleURI)
Returns the registered TypeMapping for the specified encodingStyle URI. If there is no registered TypeMapping for the specified encodingStyleURI, this method returns null.

Parameters:
encodingStyleURI - Encoding style specified as an URI
Returns:
TypeMapping for the specified encodingStyleURI or null

createTypeMapping

public TypeMapping createTypeMapping()
Creates a new empty TypeMapping object.

Returns:
TypeMapping instance

unregisterTypeMapping

public TypeMapping unregisterTypeMapping(String encodingStyleURI)
Unregisters a TypeMapping instance, if present, from the specified encodingStyleURI.

Parameters:
encodingStyleURI - Encoding style specified as an URI
Returns:
TypeMapping instance that has been unregistered or null if there was no TypeMapping registered for the specified encodingStyleURI

removeTypeMapping

public boolean removeTypeMapping(TypeMapping mapping)
Removes a TypeMapping from the TypeMappingRegistry. A TypeMapping is associated with 1 or more encodingStyleURIs. This method unregisters the specified TypeMapping instance from all associated encodingStyleURIs and then removes this TypeMapping instance from the registry.

Parameters:
mapping - TypeMapping to be removed
Returns:
true if specified TypeMapping is removed from the TypeMappingRegistry; false if the specified TypeMapping was not in the TypeMappingRegistry

clear

public void clear()
Removes all registered TypeMappings and encodingStyleURIs from this TypeMappingRegistry.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


XMLType

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Class XMLType

java.lang.Object
    extended by javax.xml.rpc.encoding.XMLType
public class XMLType
extends Object

Constants for common XML Schema and SOAP 1.1 types.

Version:
1.0
Author:
Rahul Sharma

Field Summary
static QName | SOAP_ARRAY The name of the SOAP-ENC:Array type.
static QName | SOAP_BASE64 The name of the SOAP-ENC:base64 type.
static QName | SOAP_BOOLEAN The name of the SOAP-ENC:boolean type.
static QName | SOAP_BYTE The name of the SOAP-ENC:byte type.
static QName | SOAP_DOUBLE The name of the SOAP-ENC:double type.
static QName | SOAP_FLOAT The name of the SOAP-ENC:float type.
static QName | SOAP_INT The name of the SOAP-ENC:int type.
static QName | SOAP_LONG The name of the SOAP-ENC:long type.
static QName | SOAP_SHORT The name of the SOAP-ENC:short type.
static QName | SOAP_STRING The name of the SOAP-ENC:string type.
static QName | XSD_BASE64 The name of the xsd:base64Binary type.
static QName | XSD_BOOLEAN The name of the xsd:boolean type.
static QName | XSD_BYTE The name of the xsd:byte type.
static QName | XSD_DATETIME The name of the xsd:dateTime type.
static QName | XSD_DECIMAL The name of the xsd:decimal type.
static QName | XSD_DOUBLE The name of the xsd:double type.
static QName | XSD_FLOAT The name of the xsd:float type.
static QName | XSD_HEXBINARY The name of the xsd:hexBinary type.
static QName | XSD_INT The name of the xsd:int type.
static QName | XSD_INTEGER The name of the xsd:integer type.
static QName | XSD_LONG The name of the xsd:long type.
static QName | XSD_QNAME The name of the xsd:QName type.
static QName | XSD_SHORT The name of the xsd:short type.
static QName | XSD_STRING The name of the xsd:string type.
Constructor Summary
XMLType()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

XSD_STRING

public static final QName XSD_STRING
The name of the xsd:string type.

XSD_FLOAT

public static final QName XSD_FLOAT
The name of the xsd:float type.

XSD_BOOLEAN

public static final QName XSD_BOOLEAN
The name of the xsd:boolean type.

XSD_DOUBLE

public static final QName XSD_DOUBLE
The name of the xsd:double type.

XSD_INTEGER

public static final QName XSD_INTEGER
The name of the xsd:integer type.

XSD_INT

public static final QName XSD_INT
The name of the xsd:int type.

XSD_LONG

public static final QName XSD_LONG
The name of the xsd:long type.

XSD_SHORT

public static final QName XSD_SHORT
The name of the xsd:short type.

XSD_DECIMAL

public static final QName XSD_DECIMAL
The name of the xsd:decimal type.

XSD_BASE64

public static final QName XSD_BASE64
The name of the xsd:base64Binary type.

XSD_HEXBINARY

public static final QName XSD_HEXBINARY
The name of the xsd:hexBinary type.

XSD_BYTE

public static final QName XSD_BYTE
The name of the xsd:byte type.

XSD_DATETIME

public static final QName XSD_DATETIME
The name of the xsd:dateTime type.

XSD_QNAME

public static final QName XSD_QNAME
The name of the xsd:QName type.

SOAP_STRING

public static final QName SOAP_STRING
The name of the SOAP-ENC:string type.

SOAP_BOOLEAN

public static final QName SOAP_BOOLEAN
The name of the SOAP-ENC:boolean type.

SOAP_DOUBLE

public static final QName SOAP_DOUBLE
The name of the SOAP-ENC:double type.

SOAP_BASE64

public static final QName SOAP_BASE64
The name of the SOAP-ENC:base64 type.

SOAP_FLOAT

public static final QName SOAP_FLOAT
The name of the SOAP-ENC:float type.

SOAP_INT

public static final QName SOAP_INT
The name of the SOAP-ENC:int type.

SOAP_LONG

public static final QName SOAP_LONG
The name of the SOAP-ENC:long type.

SOAP_SHORT

public static final QName SOAP_SHORT
The name of the SOAP-ENC:short type.

SOAP_BYTE

public static final QName SOAP_BYTE
The name of the SOAP-ENC:byte type.

SOAP_ARRAY

public static final QName SOAP_ARRAY
The name of the SOAP-ENC:Array type.

Constructor Detail

XMLType

public XMLType()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


handler

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.handler

This package defines APIs for SOAP Message Handlers

See:
Description

Interface Summary
Handler | The javax.xml.rpc.handler.Handler interface is required to be implemented by a SOAP message handler.
HandlerChain | The javax.xml.rpc.handler.HandlerChain represents a list of handlers.
HandlerRegistry | The javax.xml.rpc.handler.HandlerRegistry provides support for the programmatic configuration of handlers in a HandlerRegistry.
MessageContext | The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

Class Summary
GenericHandler | The javax.xml.rpc.handler.GenericHandler class implements the Handler interface.
HandlerInfo | The javax.xml.rpc.handler.HandlerInfo represents information about a handler in the HandlerChain.

Package javax.xml.rpc.handler Description

This package defines APIs for SOAP Message Handlers

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.handler Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.handler

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.rpc.handler.GenericHandler (implements javax.xml.rpc.handler.Handler)
    • class javax.xml.rpc.handler.HandlerInfo (implements java.io.Serializable)

Interface Hierarchy

  • interface java.util.Collection
    • interface java.util.List
      • interface javax.xml.rpc.handler.HandlerChain
  • interface javax.xml.rpc.handler.Handler
  • interface javax.xml.rpc.handler.MessageContext
  • interface java.io.Serializable
    • interface javax.xml.rpc.handler.HandlerRegistry
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


GenericHandler

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Class GenericHandler

java.lang.Object
    extended by javax.xml.rpc.handler.GenericHandler
All Implemented Interfaces:
Handler
public abstract class GenericHandler
extends Object
implements Handler

The javax.xml.rpc.handler.GenericHandler class implements the Handler interface. SOAP Message Handler developers should typically subclass GenericHandler class unless the Handler class needs another class as a superclass.

The GenericHandler class is a convenience abstract class that makes writing Handlers easy. This class provides default implementations of the lifecycle methods init and destroy and also different handle methods. A Handler developer should only override methods that it needs to specialize as part of the derived Handler implementation class.

Version:
1.0
Author:
Rahul Sharma

Constructor Summary
protected GenericHandler()
Default constructor
Method Summary
void | destroy() The destroy method indicates the end of lifecycle for a Handler instance.
abstract QName[] | getHeaders() Gets the header blocks processed by this Handler instance.
boolean | handleFault(MessageContext context) The handleFault method processes the SOAP faults based on the SOAP message processing model.
boolean | handleRequest(MessageContext context) The handleRequest method processes the request SOAP message.
boolean | handleResponse(MessageContext context) The handleResponse method processes the response message.
void | init(HandlerInfo config) The init method to enable the Handler instance to initialize itself.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GenericHandler

protected GenericHandler()
Default constructor

Method Detail

handleRequest

public boolean handleRequest(MessageContext context)
The handleRequest method processes the request SOAP message. The default implementation of this method returns true. This indicates that the handler chain should continue processing of the request SOAP message. This method should be overridden if the derived Handler class needs to specialize implementation of this method.

Specified by:
handleRequest in interface Handler
Parameters:
context - MessageContext parameter provides access to the request message.
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing of the request handler chain. The HandlerChain takes the responsibility of invoking the next entity. The next entity may be the next handler in the HandlerChain or if this handler is the last handler in the chain, the next entity is the service endpoint object.
  • Return false to indicate blocking of the request handler chain. In this case, further processing of the request handler chain is blocked and the target service endpoint is not dispatched. The JAX-RPC runtime system takes the responsibility of invoking the response handler chain next with the SOAPMessageContext. The Handler implementation class has the the responsibility of setting the appropriate response SOAP message in either handleRequest and/or handleResponse method. In the default processing model, the response handler chain starts processing from the same Handler instance (that returned false) and goes backward in the execution sequence.
See Also:
Handler.handleRequest(javax.xml.rpc.handler.MessageContext)

handleResponse

public boolean handleResponse(MessageContext context)
The handleResponse method processes the response message. The default implementation of this method returns true. This indicates that the handler chain should continue processing of the response SOAP message. This method should be overridden if the derived Handler class needs to specialize implementation of this method.

Specified by:
handleResponse in interface Handler
Parameters:
context - MessageContext parameter provides access to the response SOAP message
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing ofthe response handler chain. The HandlerChain invokes the handleResponse method on the next Handler in the handler chain.
  • Return false to indicate blocking of the response handler chain. In this case, no other response handlers in the handler chain are invoked.
See Also:
Handler.handleResponse(javax.xml.rpc.handler.MessageContext)

handleFault

public boolean handleFault(MessageContext context)
The handleFault method processes the SOAP faults based on the SOAP message processing model. The default implementation of this method returns true. This indicates that the handler chain should continue processing of the SOAP fault. This method should be overridden if the derived Handler class needs to specialize implementation of this method.

Specified by:
handleFault in interface Handler
Parameters:
context - MessageContext parameter provides access to the SOAP message
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing of SOAP Fault. The HandlerChain invokes the handleFault method on the next Handler in the handler chain.
  • Return false to indicate end of the SOAP fault processing. In this case, no other handlers in the handler chain are invoked.
See Also:
Handler.handleFault(javax.xml.rpc.handler.MessageContext)

init

public void init(HandlerInfo config)
The init method to enable the Handler instance to initialize itself. This method should be overridden if the derived Handler class needs to specialize implementation of this method.

Specified by:
init in interface Handler
See Also:
Handler.init(javax.xml.rpc.handler.HandlerInfo)

destroy

public void destroy()
The destroy method indicates the end of lifecycle for a Handler instance. This method should be overridden if the derived Handler class needs to specialize implementation of this method.

Specified by:
destroy in interface Handler
See Also:
Handler.destroy()

getHeaders

public abstract QName[] getHeaders()
Gets the header blocks processed by this Handler instance.

Specified by:
getHeaders in interface Handler
Returns:
Array of QNames of header blocks processed by this handler instance. QName is the qualified name of the outermost element of the Header block.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Handler

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Interface Handler

All Known Implementing Classes:
GenericHandler
public interface Handler

The javax.xml.rpc.handler.Handler interface is required to be implemented by a SOAP message handler. The handleRequest, handleResponse and handleFault methods for a SOAP message handler get access to the SOAPMessage from the SOAPMessageContext. The implementation of these methods can modify the SOAPMessage including the headers and body elements.

Version:
1.0
Author:
Rahul Sharma

Method Summary
void | destroy() The destroy method indicates the end of lifecycle for a Handler instance.
QName[] | getHeaders() Gets the header blocks that can be processed by this Handler instance.
boolean | handleFault(MessageContext context) The handleFault method processes the SOAP faults based on the SOAP message processing model.
boolean | handleRequest(MessageContext context) The handleRequest method processes the request message.
boolean | handleResponse(MessageContext context) The handleResponse method processes the response SOAP message.
void | init(HandlerInfo config) The init method enables the Handler instance to initialize itself.

Method Detail

handleRequest

public boolean handleRequest(MessageContext context)
The handleRequest method processes the request message.

Parameters:
context - MessageContext parameter provides access to the request message.
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing of the request handler chain. The HandlerChain takes the responsibility of invoking the next entity. The next entity may be the next handler in the HandlerChain or if this handler is the last handler in the chain, the next entity is the service endpoint object.
  • Return false to indicate blocking of the request handler chain. In this case, further processing of the request handler chain is blocked and the target service endpoint is not dispatched. The JAX-RPC runtime system takes the responsibility of invoking the response handler chain next with the SOAPMessageContext. The Handler implementation class has the the responsibility of setting the appropriate response SOAP message in either handleRequest and/or handleResponse method. In the default processing model, the response handler chain starts processing from the same Handler instance (that returned false) and goes backward in the execution sequence.
Throws:
JAXRPCException - This exception indicates handler specific runtime error. If JAXRPCException is thrown by a handleRequest method, the HandlerChain terminates the further processing of this handler chain. On the server side, the HandlerChain generates a SOAP fault that indicates that the message could not be processed for reasons not directly attributable to the contents of the message itself but rather to a runtime error during the processing of the message. On the client side, the exception is propagated to the client code
SOAPFaultException - This indicates a SOAP fault. The Handler implementation class has the the responsibility of setting the SOAP fault in the SOAP message in either handleRequest and/or handleFault method. If SOAPFaultException is thrown by a server-side request handler's handleRequest method, the HandlerChain terminates the further processing of the request handlers in this handler chain and invokes the handleFault method on the HandlerChain with the SOAP message context. Next, the HandlerChain invokes the handleFault method on handlers registered in the handler chain, beginning with the Handler instance that threw the exception and going backward in execution. The client-side request handler's handleRequest method should not throw the SOAPFaultException.

handleResponse

public boolean handleResponse(MessageContext context)
The handleResponse method processes the response SOAP message.

Parameters:
context - MessageContext parameter provides access to the response SOAP message
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing ofthe response handler chain. The HandlerChain invokes the handleResponse method on the next Handler in the handler chain.
  • Return false to indicate blocking of the response handler chain. In this case, no other response handlers in the handler chain are invoked.
Throws:
JAXRPCException - Indicates handler specific runtime error. If JAXRPCException is thrown by a handleResponse method, the HandlerChain terminates the further processing of this handler chain. On the server side, the HandlerChain generates a SOAP fault that indicates that the message could not be processed for reasons not directly attributable to the contents of the message itself but rather to a runtime error during the processing of the message. On the client side, the runtime exception is propagated to the client code.

handleFault

public boolean handleFault(MessageContext context)
The handleFault method processes the SOAP faults based on the SOAP message processing model.

Parameters:
context - MessageContext parameter provides access to the SOAP message
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing of SOAP Fault. The HandlerChain invokes the handleFault method on the next Handler in the handler chain.
  • Return false to indicate end of the SOAP fault processing. In this case, no other handlers in the handler chain are invoked.
Throws:
JAXRPCException - Indicates handler specific runtime error. If JAXRPCException is thrown by a handleFault method, the HandlerChain terminates the further processing of this handler chain. On the server side, the HandlerChain generates a SOAP fault that indicates that the message could not be processed for reasons not directly attributable to the contents of the message itself but rather to a runtime error during the processing of the message. On the client side, the JAXRPCException is propagated to the client code.

init

public void init(HandlerInfo config)
The init method enables the Handler instance to initialize itself. The init method passes the handler configuration as a HandlerInfo instance. The HandlerInfo is used to configure the Handler (for example: setup access to an external resource or service) during the initialization.

In the init method, the Handler class may get access to any resources (for example; access to a logging service or database) and maintain these as part of its instance variables. Note that these instance variables must not have any state specific to the SOAP message processing performed in the various handle method.

Throws:
JAXRPCException - If initialization of the handler fails

destroy

public void destroy()
The destroy method indicates the end of lifecycle for a Handler instance. The Handler implementation class should release its resources and perform cleanup in the implementation of the destroy method.

Throws:
JAXRPCException - If any error during destroy

getHeaders

public QName[] getHeaders()
Gets the header blocks that can be processed by this Handler instance.

Returns:
Array of QNames of header blocks processed by this handler instance. QName is the qualified name of the outermost element of the Header block.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HandlerChain

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Interface HandlerChain

All Superinterfaces:
Collection, List
public interface HandlerChain
extends List

The javax.xml.rpc.handler.HandlerChain represents a list of handlers. All elements in the HandlerChain are of the type javax.xml.rpc.handler.Handler.

An implementation class for the HandlerChain interface abstracts the policy and mechanism for the invocation of the registered handlers.

Version:
1.0
Author:
Rahul Sharma
See Also:
HandlerChain

Method Summary
void | destroy() Indicates the end of lifecycle for a HandlerChain.
String[] | getRoles() Gets SOAP actor roles registered for this HandlerChain at this SOAP node.
boolean | handleFault(MessageContext context) The handleFault method initiates the SOAP fault processing for this handler chain.
boolean | handleRequest(MessageContext context) The handleRequest method initiates the request processing for this handler chain.
boolean | handleResponse(MessageContext context) The handleResponse method initiates the response processing for this handler chain.
void | init(Map config) Initializes the configuration for a HandlerChain.
void | setRoles(String[] soapActorNames) Sets SOAP Actor roles for this HandlerChain.
Methods inherited from interface java.util.List
add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, remove, remove, removeAll, retainAll, set, size, subList, toArray, toArray

Method Detail

handleRequest

public boolean handleRequest(MessageContext context)
The handleRequest method initiates the request processing for this handler chain.

Parameters:
context - MessageContext parameter provides access to the request SOAP message.
Returns:
boolean Returns true if all handlers in chain have been processed. Returns false if a handler in the chain returned false from its handleRequest method.
Throws:
JAXRPCException - if any processing error happens
See Also:
Handler.handleRequest(javax.xml.rpc.handler.MessageContext)

handleResponse

public boolean handleResponse(MessageContext context)
The handleResponse method initiates the response processing for this handler chain.

Parameters:
context - MessageContext parameter provides access to the response SOAP message.
Returns:
boolean Returns true if all handlers in chain have been processed. Returns false if a handler in the chain returned false from its handleResponse method.
Throws:
JAXRPCException - if any processing error happens
See Also:
Handler.handleResponse(javax.xml.rpc.handler.MessageContext)

handleFault

public boolean handleFault(MessageContext context)
The handleFault method initiates the SOAP fault processing for this handler chain.

Parameters:
context - MessageContext parameter provides access to the SOAP message.
Returns:
boolean Returns true if all handlers in chain have been processed. Returns false if a handler in the chain returned false from its handleFault method.
Throws:
JAXRPCException - if any processing error happens
See Also:
Handler.handleFault(javax.xml.rpc.handler.MessageContext)

init

public void init(Map config)
Initializes the configuration for a HandlerChain.

Parameters:
config - Configuration for the initialization of this handler chain
Throws:
JAXRPCException - If any error during initialization

destroy

public void destroy()
Indicates the end of lifecycle for a HandlerChain.

Throws:
JAXRPCException - If any error during destroy

setRoles

public void setRoles(String[] soapActorNames)
Sets SOAP Actor roles for this HandlerChain. This specifies the set of roles in which this HandlerChain is to act for the SOAP message processing at this SOAP node. These roles assumed by a HandlerChain must be invariant during the processing of an individual SOAP message through the HandlerChain.

A HandlerChain always acts in the role of the special SOAP actor next. Refer to the SOAP specification for the URI name for this special SOAP actor. There is no need to set this special role using this method.

Parameters:
soapActorNames - URIs for SOAP actor name
See Also:
NamespaceConstants

getRoles

public String[] getRoles()
Gets SOAP actor roles registered for this HandlerChain at this SOAP node. The returned array includes the special SOAP actor next.

Returns:
String[] SOAP Actor roles as URIs
See Also:
NamespaceConstants
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HandlerInfo

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Class HandlerInfo

java.lang.Object
    extended by javax.xml.rpc.handler.HandlerInfo
All Implemented Interfaces:
Serializable
public class HandlerInfo
extends Object
implements Serializable

The javax.xml.rpc.handler.HandlerInfo represents information about a handler in the HandlerChain. A HandlerInfo instance is passed in the Handler.init method to initialize a Handler instance.

Version:
1.0
Author:
Rahul Sharma
See Also:
HandlerChain, Serialized Form

Constructor Summary
HandlerInfo()
Default constructor
HandlerInfo(Class handlerClass, Map config, QName[] headers)
Constructor for HandlerInfo
Method Summary
Class | getHandlerClass() Gets the Handler class
Map | getHandlerConfig() Gets the Handler configuration
QName[] | getHeaders() Gets the header blocks processed by this Handler.
void | setHandlerClass(Class handlerClass) Sets the Handler class
void | setHandlerConfig(Map config) Sets the Handler configuration as java.util.Map
void | setHeaders(QName[] headers) Sets the header blocks processed by this Handler.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HandlerInfo

public HandlerInfo()
Default constructor

HandlerInfo

public HandlerInfo(Class handlerClass,
                   Map config,
                   QName[] headers)
Constructor for HandlerInfo

Parameters:
handlerClass - Java Class for the Handler
config - Handler Configuration as a java.util.Map
headers - QNames for the header blocks processed by this Handler. QName is the qualified name of the outermost element of a header block
Method Detail

setHandlerClass

public void setHandlerClass(Class handlerClass)
Sets the Handler class

Parameters:
handlerClass - Class for the Handler

getHandlerClass

public Class getHandlerClass()
Gets the Handler class

Returns:
Returns null if no Handler class has been set; otherwise the set handler class

setHandlerConfig

public void setHandlerConfig(Map config)
Sets the Handler configuration as java.util.Map

Parameters:
config - Configuration map

getHandlerConfig

public Map getHandlerConfig()
Gets the Handler configuration

Returns:
Returns empty Map if no configuration map has been set; otherwise returns the set configuration map

setHeaders

public void setHeaders(QName[] headers)
Sets the header blocks processed by this Handler.

Parameters:
headers - QNames of the header blocks. QName is the qualified name of the outermost element of the SOAP header block

getHeaders

public QName[] getHeaders()
Gets the header blocks processed by this Handler.

Returns:
Array of QNames for the header blocks. Returns null if no header blocks have been set using the setHeaders method.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


HandlerRegistry

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Interface HandlerRegistry

All Superinterfaces:
Serializable
public interface HandlerRegistry
extends Serializable

The javax.xml.rpc.handler.HandlerRegistry provides support for the programmatic configuration of handlers in a HandlerRegistry.

A handler chain is registered per service endpoint, as indicated by the qualified name of a port. The getHandlerChain returns the handler chain (as a java.util.List) for the specified service endpoint. The returned handler chain is configured using the java.util.List interface. Each element in this list is required to be of the Java type javax.xml.rpc.handler.HandlerInfo.

Version:
1.0
Author:
Rahul Sharma
See Also:
Service

Method Summary
List | getHandlerChain(QName portName) Gets the handler chain for the specified service endpoint.
void | setHandlerChain(QName portName, List chain) Sets the handler chain for the specified service endpoint as a java.util.List.

Method Detail

getHandlerChain

public List getHandlerChain(QName portName)
Gets the handler chain for the specified service endpoint. The returned List is used to configure this specific handler chain in this HandlerRegistry. Each element in this list is required to be of the Java type javax.xml.rpc.handler.HandlerInfo.

Parameters:
portName - Qualified name of the target service endpoint
Returns:
java.util.List Handler chain
Throws:
IllegalArgumentException - If an invalid portName is specified

setHandlerChain

public void setHandlerChain(QName portName,
                            List chain)
Sets the handler chain for the specified service endpoint as a java.util.List. Each element in this list is required to be of the Java type javax.xml.rpc.handler.HandlerInfo.

Parameters:
portName - Qualified name of the target service endpoint
chain - A List representing configuration for the handler chain
Throws:
JAXRPCException - If any error in the configuration of the handler chain
UnsupportedOperationException - If this set operation is not supported. This is done to avoid any overriding of a pre-configured handler chain.
IllegalArgumentException - If an invalid portName is specified
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Interface MessageContext

All Known Subinterfaces:
SOAPMessageContext
public interface MessageContext

The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

The MessageContext interface provides methods to manage a property set. MessageContext properties enable handlers in a handler chain to share processing related state.

Version:
1.1
Author:
Rahul Sharma, Roberto Chinnici
See Also:
Handler

Method Summary
boolean | containsProperty(String name) Returns true if the MessageContext contains a property with the specified name.
Object | getProperty(String name) Gets the value of a specific property from the MessageContext
Iterator | getPropertyNames() Returns an Iterator view of the names of the properties in this MessageContext
void | removeProperty(String name) Removes a property (name-value pair) from the MessageContext
void | setProperty(String name, Object value) Sets the name and value of a property associated with the MessageContext.

Method Detail

setProperty

public void setProperty(String name,
                        Object value)
Sets the name and value of a property associated with the MessageContext. If the MessageContext contains a value of the same property, the old value is replaced.

Parameters:
name - Name of the property associated with the MessageContext
value - Value of the property
Throws:
IllegalArgumentException - If some aspect of the property is prevents it from being stored in the context
UnsupportedOperationException - If this method is not supported.

getProperty

public Object getProperty(String name)
Gets the value of a specific property from the MessageContext

Parameters:
name - Name of the property whose value is to be retrieved
Returns:
Value of the property
Throws:
IllegalArgumentException - if an illegal property name is specified

removeProperty

public void removeProperty(String name)
Removes a property (name-value pair) from the MessageContext

Parameters:
name - Name of the property to be removed
Throws:
IllegalArgumentException - if an illegal property name is specified

containsProperty

public boolean containsProperty(String name)
Returns true if the MessageContext contains a property with the specified name.

Parameters:
name - Name of the property whose presense is to be tested
Returns:
Returns true if the MessageContext contains the property; otherwise false

getPropertyNames

public Iterator getPropertyNames()
Returns an Iterator view of the names of the properties in this MessageContext

Returns:
Iterator for the property names
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


soap

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.handler.soap

This package defines APIs for SOAP Message Handlers

See:
Description

Interface Summary
SOAPMessageContext The interface javax.xml.rpc.soap.SOAPMessageContext provides access to the SOAP message for either RPC request or response.

Package javax.xml.rpc.handler.soap Description

This package defines APIs for SOAP Message Handlers

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.handler.soap Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.handler.soap

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface javax.xml.rpc.handler.MessageContext
    • interface javax.xml.rpc.handler.soap.SOAPMessageContext
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPMessageContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler.soap
Interface SOAPMessageContext

All Superinterfaces:
MessageContext
public interface SOAPMessageContext
extends MessageContext

The interface javax.xml.rpc.soap.SOAPMessageContext provides access to the SOAP message for either RPC request or response. The javax.xml.soap.SOAPMessage specifies the standard Java API for the representation of a SOAP 1.1 message with attachments.

Version:
1.0
Author:
Rahul Sharma
See Also:
SOAPMessage

Method Summary
SOAPMessage | getMessage() Gets the SOAPMessage from this message context
String[] | getRoles() Gets the SOAP actor roles associated with an execution of the HandlerChain and its contained Handler instances.
void | setMessage(SOAPMessage message) Sets the SOAPMessage in this message context
Methods inherited from interface javax.xml.rpc.handler.MessageContext
containsProperty, getProperty, getPropertyNames, removeProperty, setProperty

Method Detail

getMessage

public SOAPMessage getMessage()
Gets the SOAPMessage from this message context

Returns:
Returns the SOAPMessage; returns null if no SOAPMessage is present in this message context

setMessage

public void setMessage(SOAPMessage message)
Sets the SOAPMessage in this message context

Parameters:
message - SOAP message
Throws:
JAXRPCException - If any error during the setting of the SOAPMessage in this message context
UnsupportedOperationException - If this operation is not supported

getRoles

public String[] getRoles()
Gets the SOAP actor roles associated with an execution of the HandlerChain and its contained Handler instances. Note that SOAP actor roles apply to the SOAP node and are managed using HandlerChain.setRoles and HandlerChain.getRoles. Handler instances in the HandlerChain use this information about the SOAP actor roles to process the SOAP header blocks. Note that the SOAP actor roles are invariant during the processing of SOAP message through the HandlerChain.

Returns:
Array of URIs for SOAP actor roles
See Also:
HandlerChain.setRoles(java.lang.String[]), HandlerChain.getRoles()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


holders

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.holders

This package contains the standard Java Holder classes.

See:
Description

Interface Summary
Holder The java.xml.rpc.holders.Holder interface represents the base interface for both standard and generated Holder classes.

Class Summary
BigDecimalHolder
BigIntegerHolder
BooleanHolder
BooleanWrapperHolder
ByteArrayHolder
ByteHolder
ByteWrapperHolder
CalendarHolder
DoubleHolder
DoubleWrapperHolder
FloatHolder
FloatWrapperHolder
IntegerWrapperHolder
IntHolder
LongHolder
LongWrapperHolder
ObjectHolder
QNameHolder
ShortHolder
ShortWrapperHolder
StringHolder

Package javax.xml.rpc.holders Description

This package contains the standard Java Holder classes.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Holder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Interface Holder

All Known Implementing Classes:
BigDecimalHolder, BigIntegerHolder, BooleanHolder, BooleanWrapperHolder, ByteArrayHolder, ByteHolder, ByteWrapperHolder, CalendarHolder, DoubleHolder, DoubleWrapperHolder, FloatHolder, FloatWrapperHolder, IntegerWrapperHolder, IntHolder, LongHolder, LongWrapperHolder, ObjectHolder, QNameHolder, ShortHolder, ShortWrapperHolder, StringHolder
public interface Holder

The java.xml.rpc.holders.Holder interface represents the base interface for both standard and generated Holder classes. A generated Holder class is required to implement this Holder interface.

Version:
1.0
Author:
Rahul Sharma

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.holders Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.holders

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.rpc.holders.BigDecimalHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.BigIntegerHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.BooleanHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.BooleanWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.ByteArrayHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.ByteHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.ByteWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.CalendarHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.DoubleHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.DoubleWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.FloatHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.FloatWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.IntegerWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.IntHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.LongHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.LongWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.ObjectHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.QNameHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.ShortHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.ShortWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • class javax.xml.rpc.holders.StringHolder (implements javax.xml.rpc.holders.Holder)

Interface Hierarchy

  • interface javax.xml.rpc.holders.Holder
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BigDecimalHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class BigDecimalHolder

java.lang.Object
    extended by javax.xml.rpc.holders.BigDecimalHolder
All Implemented Interfaces:
Holder
public final class BigDecimalHolder
extends Object
implements Holder

Field Summary
 BigDecimal value
Constructor Summary
BigDecimalHolder()
BigDecimalHolder(BigDecimal myBigDecimal)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public BigDecimal value
Constructor Detail

BigDecimalHolder

public BigDecimalHolder()

BigDecimalHolder

public BigDecimalHolder(BigDecimal myBigDecimal)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BigIntegerHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class BigIntegerHolder

java.lang.Object
    extended by javax.xml.rpc.holders.BigIntegerHolder
All Implemented Interfaces:
Holder
public final class BigIntegerHolder
extends Object
implements Holder

Field Summary
 BigInteger value
Constructor Summary
BigIntegerHolder()
BigIntegerHolder(BigInteger myBigInteger)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public BigInteger value
Constructor Detail

BigIntegerHolder

public BigIntegerHolder()

BigIntegerHolder

public BigIntegerHolder(BigInteger myBigInteger)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BooleanHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class BooleanHolder

java.lang.Object
    extended by javax.xml.rpc.holders.BooleanHolder
All Implemented Interfaces:
Holder
public final class BooleanHolder
extends Object
implements Holder

Field Summary
 boolean value
Constructor Summary
BooleanHolder()
BooleanHolder(boolean myboolean)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public boolean value
Constructor Detail

BooleanHolder

public BooleanHolder()

BooleanHolder

public BooleanHolder(boolean myboolean)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


BooleanWrapperHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class BooleanWrapperHolder

java.lang.Object
    extended by javax.xml.rpc.holders.BooleanWrapperHolder
All Implemented Interfaces:
Holder
public final class BooleanWrapperHolder
extends Object
implements Holder

Field Summary
 Boolean value
Constructor Summary
BooleanWrapperHolder()
BooleanWrapperHolder(Boolean myboolean)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Boolean value
Constructor Detail

BooleanWrapperHolder

public BooleanWrapperHolder()

BooleanWrapperHolder

public BooleanWrapperHolder(Boolean myboolean)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ByteArrayHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ByteArrayHolder

java.lang.Object
    extended by javax.xml.rpc.holders.ByteArrayHolder
All Implemented Interfaces:
Holder
public final class ByteArrayHolder
extends Object
implements Holder

Field Summary
 byte[] value
Constructor Summary
ByteArrayHolder()
ByteArrayHolder(byte[] mybyteArray)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public byte[] value
Constructor Detail

ByteArrayHolder

public ByteArrayHolder()

ByteArrayHolder

public ByteArrayHolder(byte[] mybyteArray)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ByteHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ByteHolder

java.lang.Object
    extended by javax.xml.rpc.holders.ByteHolder
All Implemented Interfaces:
Holder
public final class ByteHolder
extends Object
implements Holder

Field Summary
 byte value
Constructor Summary
ByteHolder()
ByteHolder(byte mybyte)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public byte value
Constructor Detail

ByteHolder

public ByteHolder()

ByteHolder

public ByteHolder(byte mybyte)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ByteWrapperHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ByteWrapperHolder

java.lang.Object
    extended by javax.xml.rpc.holders.ByteWrapperHolder
All Implemented Interfaces:
Holder
public final class ByteWrapperHolder
extends Object
implements Holder

Field Summary
 Byte value
Constructor Summary
ByteWrapperHolder()
ByteWrapperHolder(Byte mybyte)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Byte value
Constructor Detail

ByteWrapperHolder

public ByteWrapperHolder()

ByteWrapperHolder

public ByteWrapperHolder(Byte mybyte)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


CalendarHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class CalendarHolder

java.lang.Object
    extended by javax.xml.rpc.holders.CalendarHolder
All Implemented Interfaces:
Holder
public final class CalendarHolder
extends Object
implements Holder

Field Summary
 Calendar value
Constructor Summary
CalendarHolder()
CalendarHolder(Calendar myCalendar)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Calendar value
Constructor Detail

CalendarHolder

public CalendarHolder()

CalendarHolder

public CalendarHolder(Calendar myCalendar)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DoubleHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class DoubleHolder

java.lang.Object
    extended by javax.xml.rpc.holders.DoubleHolder
All Implemented Interfaces:
Holder
public final class DoubleHolder
extends Object
implements Holder

Field Summary
 double value
Constructor Summary
DoubleHolder()
DoubleHolder(double mydouble)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public double value
Constructor Detail

DoubleHolder

public DoubleHolder()

DoubleHolder

public DoubleHolder(double mydouble)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DoubleWrapperHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class DoubleWrapperHolder

java.lang.Object
    extended by javax.xml.rpc.holders.DoubleWrapperHolder
All Implemented Interfaces:
Holder
public final class DoubleWrapperHolder
extends Object
implements Holder

Field Summary
 Double value
Constructor Summary
DoubleWrapperHolder()
DoubleWrapperHolder(Double mydouble)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Double value
Constructor Detail

DoubleWrapperHolder

public DoubleWrapperHolder()

DoubleWrapperHolder

public DoubleWrapperHolder(Double mydouble)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FloatHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class FloatHolder

java.lang.Object
    extended by javax.xml.rpc.holders.FloatHolder
All Implemented Interfaces:
Holder
public final class FloatHolder
extends Object
implements Holder

Field Summary
 float value
Constructor Summary
FloatHolder()
FloatHolder(float myfloat)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public float value
Constructor Detail

FloatHolder

public FloatHolder()

FloatHolder

public FloatHolder(float myfloat)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


FloatWrapperHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class FloatWrapperHolder

java.lang.Object
    extended by javax.xml.rpc.holders.FloatWrapperHolder
All Implemented Interfaces:
Holder
public final class FloatWrapperHolder
extends Object
implements Holder

Field Summary
 Float value
Constructor Summary
FloatWrapperHolder()
FloatWrapperHolder(Float myfloat)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Float value
Constructor Detail

FloatWrapperHolder

public FloatWrapperHolder()

FloatWrapperHolder

public FloatWrapperHolder(Float myfloat)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


IntegerWrapperHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class IntegerWrapperHolder

java.lang.Object
    extended by javax.xml.rpc.holders.IntegerWrapperHolder
All Implemented Interfaces:
Holder
public final class IntegerWrapperHolder
extends Object
implements Holder

Field Summary
 Integer value
Constructor Summary
IntegerWrapperHolder()
IntegerWrapperHolder(Integer myint)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Integer value
Constructor Detail

IntegerWrapperHolder

public IntegerWrapperHolder()

IntegerWrapperHolder

public IntegerWrapperHolder(Integer myint)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


IntHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class IntHolder

java.lang.Object
    extended by javax.xml.rpc.holders.IntHolder
All Implemented Interfaces:
Holder
public final class IntHolder
extends Object
implements Holder

Field Summary
 int value
Constructor Summary
IntHolder()
IntHolder(int myint)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public int value
Constructor Detail

IntHolder

public IntHolder()

IntHolder

public IntHolder(int myint)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


LongHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class LongHolder

java.lang.Object
    extended by javax.xml.rpc.holders.LongHolder
All Implemented Interfaces:
Holder
public final class LongHolder
extends Object
implements Holder

Field Summary
 long value
Constructor Summary
LongHolder()
LongHolder(long mylong)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public long value
Constructor Detail

LongHolder

public LongHolder()

LongHolder

public LongHolder(long mylong)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


LongWrapperHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class LongWrapperHolder

java.lang.Object
    extended by javax.xml.rpc.holders.LongWrapperHolder
All Implemented Interfaces:
Holder
public final class LongWrapperHolder
extends Object
implements Holder

Field Summary
 Long value
Constructor Summary
LongWrapperHolder()
LongWrapperHolder(Long mylong)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Long value
Constructor Detail

LongWrapperHolder

public LongWrapperHolder()

LongWrapperHolder

public LongWrapperHolder(Long mylong)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ObjectHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ObjectHolder

java.lang.Object
    extended by javax.xml.rpc.holders.ObjectHolder
All Implemented Interfaces:
Holder
public final class ObjectHolder
extends Object
implements Holder

Field Summary
 Object value
Constructor Summary
ObjectHolder()
ObjectHolder(Object value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Object value
Constructor Detail

ObjectHolder

public ObjectHolder()

ObjectHolder

public ObjectHolder(Object value)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


QNameHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class QNameHolder

java.lang.Object
    extended by javax.xml.rpc.holders.QNameHolder
All Implemented Interfaces:
Holder
public final class QNameHolder
extends Object
implements Holder

Field Summary
 QName value
Constructor Summary
QNameHolder()
QNameHolder(QName myQName)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public QName value
Constructor Detail

QNameHolder

public QNameHolder()

QNameHolder

public QNameHolder(QName myQName)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ShortHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ShortHolder

java.lang.Object
    extended by javax.xml.rpc.holders.ShortHolder
All Implemented Interfaces:
Holder
public final class ShortHolder
extends Object
implements Holder

Field Summary
 short value
Constructor Summary
ShortHolder()
ShortHolder(short myshort)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public short value
Constructor Detail

ShortHolder

public ShortHolder()

ShortHolder

public ShortHolder(short myshort)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ShortWrapperHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ShortWrapperHolder

java.lang.Object
    extended by javax.xml.rpc.holders.ShortWrapperHolder
All Implemented Interfaces:
Holder
public final class ShortWrapperHolder
extends Object
implements Holder

Field Summary
 Short value
Constructor Summary
ShortWrapperHolder()
ShortWrapperHolder(Short myshort)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Short value
Constructor Detail

ShortWrapperHolder

public ShortWrapperHolder()

ShortWrapperHolder

public ShortWrapperHolder(Short myshort)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StringHolder

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class StringHolder

java.lang.Object
    extended by javax.xml.rpc.holders.StringHolder
All Implemented Interfaces:
Holder
public final class StringHolder
extends Object
implements Holder

Field Summary
 String value
Constructor Summary
StringHolder()
StringHolder(String myString)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public String value
Constructor Detail

StringHolder

public StringHolder()

StringHolder

public StringHolder(String myString)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


JAXRPCException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Class JAXRPCException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.xml.rpc.JAXRPCException
All Implemented Interfaces:
Serializable
public class JAXRPCException
extends RuntimeException

The javax.xml.rpc.JAXRPCException is thrown from the core JAX-RPC APIs to indicate an exception related to the JAX-RPC runtime mechanisms.

Version:
1.0
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
JAXRPCException()
Constructs a new exception with null as its detail message.
JAXRPCException(String message)
Constructs a new exception with the specified detail message.
JAXRPCException(String message, Throwable cause)
Constructs a new exception with the specified detail message and cause.
JAXRPCException(Throwable cause)
Constructs a new JAXRPCException with the specified cause and a detail message of (cause==null ?
Method Summary
 Throwable getLinkedCause()
Gets the Linked cause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JAXRPCException

public JAXRPCException()
Constructs a new exception with null as its detail message. The cause is not initialized.

JAXRPCException

public JAXRPCException(String message)
Constructs a new exception with the specified detail message. The cause is not initialized.

Parameters:
message - The detail message which is later retrieved using the getMessage method

JAXRPCException

public JAXRPCException(String message,
                       Throwable cause)
Constructs a new exception with the specified detail message and cause.

Parameters:
message - The detail message which is later retrieved using the getMessage method
cause - The cause which is saved for the later retrieval throw by the getCause method

JAXRPCException

public JAXRPCException(Throwable cause)
Constructs a new JAXRPCException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

Parameters:
cause - The cause which is saved for the later retrieval throw by the getCause method. (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Method Detail

getLinkedCause

public Throwable getLinkedCause()
Gets the Linked cause

Returns:
The cause of this Exception or null if the cause is noexistent or unknown
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


NamespaceConstants

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Class NamespaceConstants

java.lang.Object
    extended by javax.xml.rpc.NamespaceConstants
public class NamespaceConstants
extends Object

Constants used in JAX-RPC for namespace prefixes and URIs

Version:
1.0
Author:
Rahul Sharma

Field Summary
static String | NSPREFIX_SCHEMA_XSD Namespace prefix for XML schema XSD
static String | NSPREFIX_SCHEMA_XSI Namespace prefix for XML Schema XSI
static String | NSPREFIX_SOAP_ENCODING Namespace prefix for SOAP Encoding
static String | NSPREFIX_SOAP_ENVELOPE Namespace prefix for SOAP Envelope
static String | NSURI_SCHEMA_XSD Namespace URI for XML Schema XSD
static String | NSURI_SCHEMA_XSI Namespace URI for XML Schema XSI
static String | NSURI_SOAP_ENCODING Nameapace URI for SOAP 1.1 Encoding
static String | NSURI_SOAP_ENVELOPE Nameapace URI for SOAP 1.1 Envelope
static String | NSURI_SOAP_NEXT_ACTOR Nameapace URI for SOAP 1.1 next actor role
Constructor Summary
NamespaceConstants()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NSPREFIX_SOAP_ENVELOPE

public static final String NSPREFIX_SOAP_ENVELOPE
Namespace prefix for SOAP Envelope

See Also:
Constant Field Values

NSPREFIX_SOAP_ENCODING

public static final String NSPREFIX_SOAP_ENCODING
Namespace prefix for SOAP Encoding

See Also:
Constant Field Values

NSPREFIX_SCHEMA_XSD

public static final String NSPREFIX_SCHEMA_XSD
Namespace prefix for XML schema XSD

See Also:
Constant Field Values

NSPREFIX_SCHEMA_XSI

public static final String NSPREFIX_SCHEMA_XSI
Namespace prefix for XML Schema XSI

See Also:
Constant Field Values

NSURI_SOAP_ENVELOPE

public static final String NSURI_SOAP_ENVELOPE
Nameapace URI for SOAP 1.1 Envelope

See Also:
Constant Field Values

NSURI_SOAP_ENCODING

public static final String NSURI_SOAP_ENCODING
Nameapace URI for SOAP 1.1 Encoding

See Also:
Constant Field Values

NSURI_SOAP_NEXT_ACTOR

public static final String NSURI_SOAP_NEXT_ACTOR
Nameapace URI for SOAP 1.1 next actor role

See Also:
Constant Field Values

NSURI_SCHEMA_XSD

public static final String NSURI_SCHEMA_XSD
Namespace URI for XML Schema XSD

See Also:
Constant Field Values

NSURI_SCHEMA_XSI

public static final String NSURI_SCHEMA_XSI
Namespace URI for XML Schema XSI

See Also:
Constant Field Values
Constructor Detail

NamespaceConstants

public NamespaceConstants()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ParameterMode

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Class ParameterMode

java.lang.Object
    extended by javax.xml.rpc.ParameterMode
public class ParameterMode
extends Object

The javax.xml.rpc.ParameterMode is a type-safe enumeration for parameter mode. This class is used in the CallAPI to specify parameter passing modes.

Version:
1.0
Author:
Rahul Sharma
See Also:
Call

Field Summary
static ParameterMode | IN IN mode for parameter passing
static ParameterMode | INOUT INOUT mode for parameter passing
static ParameterMode | OUT OUT mode for parameter passing
Method Summary
 String toString()
Returns a String describing this ParameterMode object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

IN

public static final ParameterMode IN
IN mode for parameter passing

OUT

public static final ParameterMode OUT
OUT mode for parameter passing

INOUT

public static final ParameterMode INOUT
INOUT mode for parameter passing

Method Detail

toString

public String toString()
Returns a String describing this ParameterMode object.

Returns:
A string representation of the object.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


server

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.server

This package defines APIs for the servlet based JAX-RPC endpoint model.

See:
Description

Interface Summary
ServiceLifecycle | The javax.xml.rpc.server.ServiceLifecycle defines a lifecycle interface for a JAX-RPC service endpoint.
ServletEndpointContext | The ServletEndpointContext provides an endpoint context maintained by the underlying servlet container based JAX-RPC runtime system.

Package javax.xml.rpc.server Description

This package defines APIs for the servlet based JAX-RPC endpoint model.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.server Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.server

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface javax.xml.rpc.server.ServiceLifecycle
  • interface javax.xml.rpc.server.ServletEndpointContext
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServiceLifecycle

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.server
Interface ServiceLifecycle

public interface ServiceLifecycle

The javax.xml.rpc.server.ServiceLifecycle defines a lifecycle interface for a JAX-RPC service endpoint. If the service endpoint class implements the ServiceLifeycle interface, the servlet container based JAX-RPC runtime system is required to manage the lifecycle of the corresponding service endpoint objects.

Version:
1.0
Author:
Rahul Sharma

Method Summary
void | destroy() JAX-RPC runtime system ends the lifecycle of a service endpoint instance by invoking the destroy method.
void | init(Object context) Used for initialization of a service endpoint.

Method Detail

init

public void init(Object context)
          throws ServiceException
Used for initialization of a service endpoint. After a service endpoint instance (an instance of a service endpoint class) is instantiated, the JAX-RPC runtime system invokes the init method. The service endpoint class uses the init method to initialize its configuration and setup access to any external resources. The context parameter in the init method enables the endpoint instance to access the endpoint context provided by the underlying JAX-RPC runtime system.

The init method implementation should typecast the context parameter to an appropriate Java type. For service endpoints deployed on a servlet container based JAX-RPC runtime system, the context parameter is of the Java type javax.xml.rpc.server.ServletEndpointContext. The ServletEndpointContext provides an endpoint context maintained by the underlying servlet container based JAX-RPC runtime system

Parameters:
context - Endpoint context for a JAX-RPC service endpoint
Throws:
ServiceException - If any error in initialization of the service endpoint; or if any illegal context has been provided in the init method

destroy

public void destroy()
JAX-RPC runtime system ends the lifecycle of a service endpoint instance by invoking the destroy method. The service endpoint releases its resourcesin the implementation of the destroy method.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServletEndpointContext

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.server
Interface ServletEndpointContext

public interface ServletEndpointContext

The ServletEndpointContext provides an endpoint context maintained by the underlying servlet container based JAX-RPC runtime system. For service endpoints deployed on a servlet container based JAX-RPC runtime system, the context parameter in the ServiceLifecycle.init method is required to be of the Java type javax.xml.rpc.server.ServletEndpointContext.

A servlet container based JAX-RPC runtime system implements the ServletEndpointContext interface. The JAX-RPC runtime system is required to provide appropriate session, message context, servlet context and user principal information per method invocation on the endpoint class.

Version:
1.1
Author:
Rahul Sharma, Roberto Chinnici

Method Summary
HttpSession | getHttpSession() The getHttpSession method returns the current HTTP session (as a javax.servlet.http.HTTPSession).
MessageContext | getMessageContext() The method getMessageContext returns the MessageContext targeted for this endpoint instance.
ServletContext | getServletContext() The method getServletContext returns the ServletContext associated with the web application that contain this endpoint.
Principal | getUserPrincipal() Returns a java.security.Principal instance that contains the name of the authenticated user for the current method invocation on the endpoint instance.
boolean | isUserInRole(String role) Returns a boolean indicating whether the authenticated user for the current method invocation on the endpoint instance is included in the specified logical "role".

Method Detail

getMessageContext

public MessageContext getMessageContext()
The method getMessageContext returns the MessageContext targeted for this endpoint instance. This enables the service endpoint instance to acccess the MessageContext propagated by request HandlerChain (and its contained Handler instances) to the target endpoint instance and to share any SOAP message processing related context. The endpoint instance can access and manipulate the MessageContext and share the SOAP message processing related context with the response HandlerChain.

Returns:
MessageContext; If there is no associated MessageContext, this method returns null.
Throws:
IllegalStateException - if this method is invoked outside a remote method implementation by a service endpoint instance.
See Also:
MessageContext, HandlerChain, Handler

getUserPrincipal

public Principal getUserPrincipal()
Returns a java.security.Principal instance that contains the name of the authenticated user for the current method invocation on the endpoint instance. This method returns null if there is no associated principal yet. The underlying JAX-RPC runtime system takes the responsibility of providing the appropriate authenticated principal for a remote method invocation on the service endpoint instance.

Returns:
A java.security.Principal for the authenticated principal associated with the current invocation on the servlet endpoint instance; Returns null if there no authenticated user associated with a method invocation.
See Also:
Principal

getHttpSession

public HttpSession getHttpSession()
The getHttpSession method returns the current HTTP session (as a javax.servlet.http.HTTPSession). When invoked by the service endpoint within a remote method implementation, the getHttpSession returns the HTTP session associated currently with this method invocation. This method returns null if there is no HTTP session currently active and associated with this service endpoint. An endpoint class should not rely on an active HTTP session being always there; the underlying JAX-RPC runtime system is responsible for managing whether or not there is an active HTTP session.

The getHttpSession method throws JAXRPCException if invoked by an non HTTP bound endpoint.

Returns:
The HTTP session associated with the current invocation or null if there is no active session.
Throws:
JAXRPCException - If this method invoked by any non-HTTP bound endpoint
See Also:
HttpSession

getServletContext

public ServletContext getServletContext()
The method getServletContext returns the ServletContext associated with the web application that contain this endpoint. According to the Servlet specification, There is one context per web application (installed as a WAR) per JVM . A servlet based service endpoint is deployed as part of a web application.

Returns:
ServletContext
See Also:
ServletContext

isUserInRole

public boolean isUserInRole(String role)
Returns a boolean indicating whether the authenticated user for the current method invocation on the endpoint instance is included in the specified logical "role".

Parameters:
role - a String specifying the name of the role
Returns:
a boolean indicating whether the authenticated user associated with the current method invocation belongs to a given role; false if the user has not been authenticated
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Service

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Interface Service

public interface Service

Service class acts as a factory of the following:

  • Dynamic proxy for the target service endpoint.
  • Instance of the type javax.xml.rpc.Call for the dynamic invocation of a remote operation on the target service endpoint.
  • Instance of a generated stub class

Version:
1.0
Author:
Rahul Sharma
See Also:
Call, Stub

Method Summary
Call | createCall() Creates a Call object not associated with specific operation or target service endpoint.
Call | createCall(QName portName) Creates a Call instance.
Call | createCall(QName portName, QName operationName) Creates a Call instance.
Call | createCall(QName portName, String operationName) Creates a Call instance.
Call[] | getCalls(QName portName) Gets an array of preconfigured Call objects for invoking operations on the specified port.
HandlerRegistry | getHandlerRegistry() Returns the configured HandlerRegistry instance for this Service instance.
Remote | getPort(Class serviceEndpointInterface) The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
Remote | getPort(QName portName, Class serviceEndpointInterface) The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
Iterator | getPorts() Returns an Iterator for the list of QNames of service endpoints grouped by this service
QName | getServiceName() Gets the name of this service.
TypeMappingRegistry | getTypeMappingRegistry() Gets the TypeMappingRegistry for this Service object.
URL | getWSDLDocumentLocation() Gets the location of the WSDL document for this Service.

Method Detail

getPort

public Remote getPort(QName portName,
                      Class serviceEndpointInterface)
               throws ServiceException
The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy. A service client uses this dynamic proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy or stub instance.

Parameters:
portName - Qualified name of the service endpoint in the WSDL service description
serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy or stub instance
Returns:
java.rmi.Remote Stub instance or dynamic proxy that supports the specified service endpoint interface
Throws:
ServiceException - This exception is thrown in the following cases:
  • If there is an error in creation of the dynamic proxy or stub instance
  • If there is any missing WSDL metadata as required by this method
  • Optionally, if an illegal serviceEndpointInterface or portName is specified
See Also:
Proxy, InvocationHandler

getPort

public Remote getPort(Class serviceEndpointInterface)
               throws ServiceException
The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned stub or proxy. In the implementation of this method, the JAX-RPC runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the stub accordingly. The returned Stub instance should not be reconfigured by the client.

Parameters:
serviceEndpointInterface - Service endpoint interface
Returns:
Stub instance or dynamic proxy that supports the specified service endpoint interface
Throws:
ServiceException -
  • If there is an error during creation of stub instance or dynamic proxy
  • If there is any missing WSDL metadata as required by this method
  • Optionally, if an illegal serviceEndpointInterface is specified

getCalls

public Call[] getCalls(QName portName)
                throws ServiceException
Gets an array of preconfigured Call objects for invoking operations on the specified port. There is one Call object per operation that can be invoked on the specified port. Each Call object is pre-configured and does not need to be configured using the setter methods on Call interface.

Each invocation of the getCalls method returns a new array of preconfigured Call objects

This method requires the Service implementation class to have access to the WSDL related metadata.

Parameters:
portName - Qualified name for the target service endpoint
Returns:
Call[] Array of pre-configured Call objects
Throws:
ServiceException - If this Service class does not have access to the required WSDL metadata or if an illegal portName is specified.

createCall

public Call createCall(QName portName)
                throws ServiceException
Creates a Call instance.

Parameters:
portName - Qualified name for the target service endpoint
Returns:
Call instance
Throws:
ServiceException - If any error in the creation of the Call object

createCall

public Call createCall(QName portName,
                       QName operationName)
                throws ServiceException
Creates a Call instance.

Parameters:
portName - Qualified name for the target service endpoint
operationName - Qualified Name of the operation for which this Call object is to be created.
Returns:
Call instance
Throws:
ServiceException - If any error in the creation of the Call object

createCall

public Call createCall(QName portName,
                       String operationName)
                throws ServiceException
Creates a Call instance.

Parameters:
portName - Qualified name for the target service endpoint
operationName - Name of the operation for which this Call object is to be created.
Returns:
Call instance
Throws:
ServiceException - If any error in the creation of the Call object

createCall

public Call createCall()
                throws ServiceException
Creates a Call object not associated with specific operation or target service endpoint. This Call object needs to be configured using the setter methods on the Call interface.

Returns:
Call object
Throws:
ServiceException - If any error in the creation of the Call object

getServiceName

public QName getServiceName()
Gets the name of this service.

Returns:
Qualified name of this service

getPorts

public Iterator getPorts()
                  throws ServiceException
Returns an Iterator for the list of QNames of service endpoints grouped by this service

Returns:
Returns java.util.Iterator with elements of type javax.xml.namespace.QName
Throws:
ServiceException - If this Service class does not have access to the required WSDL metadata

getWSDLDocumentLocation

public URL getWSDLDocumentLocation()
Gets the location of the WSDL document for this Service.

Returns:
URL for the location of the WSDL document for this service

getTypeMappingRegistry

public TypeMappingRegistry getTypeMappingRegistry()
Gets the TypeMappingRegistry for this Service object. The returned TypeMappingRegistry instance is pre-configured to support the standard type mapping between XML and Java types types as required by the JAX-RPC specification.

Returns:
The TypeMappingRegistry for this Service object.
Throws:
java.lang.UnsupportedOperationException - if the Service class does not support the configuration of TypeMappingRegistry.

getHandlerRegistry

public HandlerRegistry getHandlerRegistry()
Returns the configured HandlerRegistry instance for this Service instance.

Returns:
HandlerRegistry
Throws:
java.lang.UnsupportedOperationException - if the Service class does not support the configuration of a HandlerRegistry
Overview  Package   Class  Tree  Deprecated  Index  Help
JavaTM 2 Platform
Ent. Ed. v1.4
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServiceException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Class ServiceException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.rpc.ServiceException
All Implemented Interfaces:
Serializable
public class ServiceException
extends Exception

The javax.xml.rpc.ServiceException is thrown from the methods in the javax.xml.rpc.Service interface and ServiceFactory class.

Version:
1.0
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
ServiceException()
Constructs a new exception with null as its detail message.
ServiceException(String message)
Constructs a new exception with the specified detail message.
ServiceException(String message, Throwable cause)
Constructs a new exception with the specified detail message and cause.
ServiceException(Throwable cause)
Constructs a new exception with the specified cause and a detail message of (cause==null ?
Method Summary
 Throwable getLinkedCause()
Gets the Linked cause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServiceException

public ServiceException()
Constructs a new exception with null as its detail message. The cause is not initialized.

ServiceException

public ServiceException(String message)
Constructs a new exception with the specified detail message. The cause is not initialized.

Parameters:
message - The detail message which is later retrieved using the getMessage method

ServiceException

public ServiceException(String message,
                        Throwable cause)
Constructs a new exception with the specified detail message and cause.

Parameters:
message - The detail message which is later retrieved using the getMessage method
cause - The cause which is saved for the later retrieval throw by the getCause method

ServiceException

public ServiceException(Throwable cause)
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

Parameters:
cause - The cause which is saved for the later retrieval throw by the getCause method. (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Method Detail

getLinkedCause

public Throwable getLinkedCause()
Gets the Linked cause

Returns:
The cause of this Exception or null if the cause is noexistent or unknown
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ServiceFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Class ServiceFactory

java.lang.Object
    extended by javax.xml.rpc.ServiceFactory
public abstract class ServiceFactory
extends Object

The javax.xml.rpc.ServiceFactory is an abstract class that provides a factory for the creation of instances of the type javax.xml.rpc.Service. This abstract class follows the abstract static factory design pattern. This enables a J2SE based client to create a Service instance in a portable manner without using the constructor of the Service implementation class.

The ServiceFactory implementation class is set using the system property SERVICEFACTORY_PROPERTY.

Version:
1.1
Author:
Rahul Sharma, Roberto Chinnici
See Also:
Service

Field Summary
static String SERVICEFACTORY_PROPERTY
A constant representing the property used to lookup the name of a ServiceFactory implementation class.
Constructor Summary
protected ServiceFactory()
Method Summary
abstract Service | createService(QName serviceName) Create a Service instance.
abstract Service | createService(URL wsdlDocumentLocation, QName serviceName) Create a Service instance.
abstract Service | loadService(Class serviceInterface) Create an instance of the generated service implementation class for a given service interface, if available.
abstract Service | loadService(URL wsdlDocumentLocation, Class serviceInterface, Properties properties) Create an instance of the generated service implementation class for a given service interface, if available.
abstract Service | loadService(URL wsdlDocumentLocation, QName serviceName, Properties properties) Create an instance of the generated service implementation class for a given service, if available.
static ServiceFactory | newInstance() Gets an instance of the ServiceFactory Only one copy of a factory exists and is returned to the application each time this method is called.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SERVICEFACTORY_PROPERTY

public static final String SERVICEFACTORY_PROPERTY
A constant representing the property used to lookup the name of a ServiceFactory implementation class.

See Also:
Constant Field Values
Constructor Detail

ServiceFactory

protected ServiceFactory()
Method Detail

newInstance

public static ServiceFactory newInstance()
                                  throws ServiceException
Gets an instance of the ServiceFactory

Only one copy of a factory exists and is returned to the application each time this method is called.

The implementation class to be used can be overridden by setting the javax.xml.rpc.ServiceFactory system property.

Throws:
ServiceException

createService

public abstract Service createService(URL wsdlDocumentLocation,
                                      QName serviceName)
                               throws ServiceException
Create a Service instance.

Parameters:
wsdlDocumentLocation - URL for the WSDL document location for the service
serviceName - QName for the service
Throws:
ServiceException - If any error in creation of the specified service

createService

public abstract Service createService(QName serviceName)
                               throws ServiceException
Create a Service instance.

Parameters:
serviceName - QName for the service
Throws:
ServiceException - If any error in creation of the specified service

loadService

public abstract Service loadService(Class serviceInterface)
                             throws ServiceException
Create an instance of the generated service implementation class for a given service interface, if available.

Parameters:
serviceInterface - Service interface
Throws:
ServiceException - If there is any error while creating the specified service, including the case where a generated service implementation class cannot be located

loadService

public abstract Service loadService(URL wsdlDocumentLocation,
                                    Class serviceInterface,
                                    Properties properties)
                             throws ServiceException
Create an instance of the generated service implementation class for a given service interface, if available. An implementation may use the provided wsdlDocumentLocation and properties to help locate the generated implementation class. If no such class is present, a ServiceException will be thrown.

Parameters:
wsdlDocumentLocation - URL for the WSDL document location for the service or null
serviceInterface - Service interface
properties - A set of implementation-specific properties to help locate the generated service implementation class
Throws:
ServiceException - If there is any error while creating the specified service, including the case where a generated service implementation class cannot be located

loadService

public abstract Service loadService(URL wsdlDocumentLocation,
                                    QName serviceName,
                                    Properties properties)
                             throws ServiceException
Create an instance of the generated service implementation class for a given service, if available. The service is uniquely identified by the wsdlDocumentLocation and serviceName arguments. An implementation may use the provided properties to help locate the generated implementation class. If no such class is present, a ServiceException will be thrown.

Parameters:
wsdlDocumentLocation - URL for the WSDL document location for the service or null
serviceName - Qualified name for the service
properties - A set of implementation-specific properties to help locate the generated service implementation class
Throws:
ServiceException - If there is any error while creating the specified service, including the case where a generated service implementation class cannot be located
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


soap

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.soap

This package defines APIs specific to the SOAP binding.

See:
Description

Exception Summary
SOAPFaultException The SOAPFaultException exception represents a SOAP fault.

Package javax.xml.rpc.soap Description

This package defines APIs specific to the SOAP binding.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.soap Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.soap

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class javax.xml.rpc.soap.SOAPFaultException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPFaultException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.soap
Class SOAPFaultException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by javax.xml.rpc.soap.SOAPFaultException
All Implemented Interfaces:
Serializable
public class SOAPFaultException
extends RuntimeException

The SOAPFaultException exception represents a SOAP fault.

The message part in the SOAP fault maps to the contents of faultdetail element accessible through the getDetail method on the SOAPFaultException. The method createDetail on the javax.xml.soap.SOAPFactory creates an instance of the javax.xml.soap.Detail.

The faultstring provides a human-readable description of the SOAP fault. The faultcode element provides an algorithmic mapping of the SOAP fault.

Refer to SOAP 1.1 and WSDL 1.1 specifications for more details of the SOAP faults.

Version:
1.0
Author:
Rahul Sharma
See Also:
Detail, SOAPFactory.createDetail(), Serialized Form

Constructor Summary
SOAPFaultException(QName faultcode, String faultstring, String faultactor, Detail faultdetail)
Constructor for the SOAPFaultException
Method Summary
Detail | getDetail() Gets the detail element.
String | getFaultActor() Gets the faultactor element.
QName | getFaultCode() Gets the faultcode element.
String | getFaultString() Gets the faultstring element.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SOAPFaultException

public SOAPFaultException(QName faultcode,
                          String faultstring,
                          String faultactor,
                          Detail faultdetail)
Constructor for the SOAPFaultException

Parameters:
faultstring - faultstring element of SOAP fault
faultactor - faultactor element of SOAP fault
faultdetail - faultdetail element of SOAP fault
See Also:
SOAPFactory.createDetail()
Method Detail

getFaultCode

public QName getFaultCode()
Gets the faultcode element. The faultcode element provides an algorithmic mechanism for identifying the fault. SOAP defines a small set of SOAP fault codes covering basic SOAP faults.

Returns:
QName of the faultcode element

getFaultString

public String getFaultString()
Gets the faultstring element. The faultstring provides a human-readable description of the SOAP fault and is not intended for algorithmic processing.

Returns:
faultstring element of the SOAP fault

getFaultActor

public String getFaultActor()
Gets the faultactor element. The faultactor element provides information about which SOAP node on the SOAP message path caused the fault to happen. It indicates the source of the fault.

Returns:
faultactor element of the SOAP fault

getDetail

public Detail getDetail()
Gets the detail element. The detail element is intended for carrying application specific error information related to the SOAP Body.

See Also:
Detail
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Stub

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Interface Stub

public interface Stub

The interface javax.xml.rpc.Stub is the common base interface for the stub classes. All generated stub classes are required to implement the javax.xml.rpc.Stub interface. An instance of a stub class represents a client side proxy or stub instance for the target service endpoint.

The javax.xml.rpc.Stub interface provides an extensible property mechanism for the dynamic configuration of a stub instance.

Version:
0.1
Author:
Rahul Sharma
See Also:
Service

Field Summary
static String | ENDPOINT_ADDRESS_PROPERTY Standard property: Target service endpoint address.
static String | PASSWORD_PROPERTY Standard property: Password for authentication.
static String | SESSION_MAINTAIN_PROPERTY Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.
static String | USERNAME_PROPERTY Standard property: User name for authentication.
Method Summary
Object | _getProperty(String name) Gets the value of a specific configuration property.
Iterator | _getPropertyNames() Returns an Iterato view of the names of the properties that can be configured on this stub instance.
void | _setProperty(String name, Object value) Sets the name and value of a configuration property for this Stub instance.

Field Detail

USERNAME_PROPERTY

public static final String USERNAME_PROPERTY
Standard property: User name for authentication.

Type: java.lang.String

See Also:
Constant Field Values

PASSWORD_PROPERTY

public static final String PASSWORD_PROPERTY
Standard property: Password for authentication.

Type: java.lang.String

See Also:
Constant Field Values

ENDPOINT_ADDRESS_PROPERTY

public static final String ENDPOINT_ADDRESS_PROPERTY
Standard property: Target service endpoint address. The URI scheme for the endpoint address specification must correspond to the protocol/transport binding for this stub class.

Type: java.lang.String

See Also:
Constant Field Values

SESSION_MAINTAIN_PROPERTY

public static final String SESSION_MAINTAIN_PROPERTY
Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint. If this property is set to true, the service client indicates that it wants the session to be maintained. If set to false, the session is not maintained. The default value for this property is false.

Type: java.lang.Boolean

See Also:
Constant Field Values
Method Detail

_setProperty

public void _setProperty(String name,
                         Object value)
Sets the name and value of a configuration property for this Stub instance. If the Stub instances contains a value of the same property, the old value is replaced.

Note that the _setProperty method may not perform validity check on a configured property value. An example is the standard property for the target service endpoint address that is not checked for validity in the _setProperty method. In this case, stub configuration errors are detected at the remote method invocation.

Parameters:
name - Name of the configuration property
value - Value of the property
Throws:
JAXRPCException -
  • If an optional standard property name is specified, however this Stub implementation class does not support the configuration of this property.
  • If an invalid or unsupported property name is specified or if a value of mismatched property type is passed.
  • If there is any error in the configuration of a valid property.

_getProperty

public Object _getProperty(String name)
Gets the value of a specific configuration property.

Parameters:
name - Name of the property whose value is to be retrieved
Returns:
Value of the configuration property
Throws:
JAXRPCException - if an invalid or unsupported property name is passed.

_getPropertyNames

public Iterator _getPropertyNames()
Returns an Iterato view of the names of the properties that can be configured on this stub instance.

Returns:
Iterator for the property names of the type java.lang.String
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


soap

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.soap

Provides the API for creating and building SOAP messages.

See:
Description

Interface Summary
Detail | A container for DetailEntry objects.
DetailEntry | The content for a Detail object, giving details for a SOAPFault object.
Name | A representation of an XML name.
Node | A representation of a node (element) in an XML document.
SOAPBody | An object that represents the contents of the SOAP body element in a SOAP message.
SOAPBodyElement | A SOAPBodyElement object represents the contents in a SOAPBody object.
SOAPConstants | The definition of constants pertaining to the SOAP 1.1 protocol.
SOAPElement | An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
SOAPEnvelope | The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
SOAPFault | An element in the SOAPBody object that contains error and/or status information.
SOAPFaultElement | A representation of the contents in a SOAPFault object.
SOAPHeader | A representation of the SOAP header element.
SOAPHeaderElement | An object representing the contents in the SOAP header part of the SOAP envelope.
Text | A representation of a node whose value is text.

Class Summary
AttachmentPart | A single attachment to a SOAPMessage object.
MessageFactory | A factory for creating SOAPMessage objects.
MimeHeader | An object that stores a MIME header name and its value.
MimeHeaders | A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.
SOAPConnection | A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).
SOAPConnectionFactory | A factory for creating SOAPConnection objects.
SOAPElementFactory | Deprecated. - Use javax.xml.soap.SOAPFactory for creating SOAPElements.
SOAPFactory | SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
SOAPMessage | The root class for all SOAP messages.
SOAPPart | The container for the SOAP-specific portion of a SOAPMessage object.

Exception Summary
SOAPException An exception that signals that a SOAP exception has occurred.

Package javax.xml.soap Description

Provides the API for creating and building SOAP messages. This package is defined in the SOAP with Attachments API for JavaTM (SAAJ) 1.1 specification.

The API in the javax.xml.soap package allows you to do the following:

  • create a point-to-point connection to a specified endpoint
  • create a SOAP message
  • create an XML fragment
  • add content to the header of a SOAP message
  • add content to the body of a SOAP message
  • create attachment parts and add content to them
  • access/add/modify parts of a SOAP message
  • create/add/modify SOAP fault information
  • extract content from a SOAP message
  • send a SOAP request-response message

In addition the APIs in the javax.xml.soap package extend their counterparts in the org.w3c.dom package. This means that the SOAPPart of a SOAPMessage is also a DOM Level 2 Document, and can be manipulated as such by applications, tools and libraries that use DOM (see http://www.w3.org/DOM/ for more information). It is important to note that, while it is possible to use DOM APIs to add ordinary DOM nodes to a SAAJ tree, the SAAJ APIs are still required to return SAAJ types when examining or manipulating the tree. In order to accomplish this the SAAJ APIs (specifically SOAPElement.getChildElements()) are allowed to silently replace objects that are incorrectly typed relative to SAAJ requirements with equivalent objects of the required type. These replacements must never cause the logical structure of the tree to change, so from the perspective of the DOM APIs the tree will remain unchanged. However, the physical composition of the tree will have changed so that references to the nodes that were replaced will refer to nodes that are no longer a part of the tree. The SAAJ APIs are not allowed to make these replacements if they are not required so the replacement objects will never subsequently be silently replaced by future calls to the SAAJ API.

What this means in practical terms is that an application that starts to use SAAJ APIs on a tree after manipulating it using DOM APIs must assume that the tree has been translated into an all SAAJ tree and that any references to objects within the tree that were obtained using DOM APIs are no longer valid. Switching from SAAJ APIs to DOM APIs is not allowed to cause invalid references and neither is using SAAJ APIs exclusively. It is only switching from using DOM APIs on a particular SAAJ tree to using SAAJ APIs that causes the risk of invalid references.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DetailEntry

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface DetailEntry

All Superinterfaces:
Element, Node, Node, SOAPElement
public interface DetailEntry
extends SOAPElement

The content for a Detail object, giving details for a SOAPFault object. A DetailEntry object, which carries information about errors related to the SOAPBody object that contains it, is application-specific.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, getAllAttributes, getAttributeValue, getChildElements, getChildElements, getElementName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeContents, removeNamespaceDeclaration, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.soap Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.soap

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.soap.AttachmentPart
    • class javax.xml.soap.MessageFactory
    • class javax.xml.soap.MimeHeader
    • class javax.xml.soap.MimeHeaders
    • class javax.xml.soap.SOAPConnection
    • class javax.xml.soap.SOAPConnectionFactory
    • class javax.xml.soap.SOAPElementFactory
    • class javax.xml.soap.SOAPFactory
    • class javax.xml.soap.SOAPMessage
    • class javax.xml.soap.SOAPPart (implements org.w3c.dom.Document)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.xml.soap.SOAPException

Interface Hierarchy

  • interface javax.xml.soap.Name
  • interface org.w3c.dom.Node
    • interface org.w3c.dom.CharacterData
      • interface org.w3c.dom.Text
        • interface javax.xml.soap.Text (also extends javax.xml.soap.Node)
    • interface org.w3c.dom.Element
      • interface javax.xml.soap.SOAPElement (also extends javax.xml.soap.Node)
        • interface javax.xml.soap.DetailEntry
        • interface javax.xml.soap.SOAPBody
        • interface javax.xml.soap.SOAPBodyElement
          • interface javax.xml.soap.SOAPFault
        • interface javax.xml.soap.SOAPEnvelope
        • interface javax.xml.soap.SOAPFaultElement
          • interface javax.xml.soap.Detail
        • interface javax.xml.soap.SOAPHeader
        • interface javax.xml.soap.SOAPHeaderElement
    • interface javax.xml.soap.Node
      • interface javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element)
        • interface javax.xml.soap.DetailEntry
        • interface javax.xml.soap.SOAPBody
        • interface javax.xml.soap.SOAPBodyElement
          • interface javax.xml.soap.SOAPFault
        • interface javax.xml.soap.SOAPEnvelope
        • interface javax.xml.soap.SOAPFaultElement
          • interface javax.xml.soap.Detail
        • interface javax.xml.soap.SOAPHeader
        • interface javax.xml.soap.SOAPHeaderElement
      • interface javax.xml.soap.Text (also extends org.w3c.dom.Text)
  • interface javax.xml.soap.SOAPConstants
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPBodyElement

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPBodyElement

All Superinterfaces:
Element, Node, Node, SOAPElement
All Known Subinterfaces:
SOAPFault
public interface SOAPBodyElement
extends SOAPElement

A SOAPBodyElement object represents the contents in a SOAPBody object. The SOAPFault interface is a SOAPBodyElement object that has been defined.

A new SOAPBodyElement object can be created and added to a SOAPBody object with the SOAPBody method addBodyElement. In the following line of code, sb is a SOAPBody object, and myName is a Name object.

    SOAPBodyElement sbe = sb.addBodyElement(myName);

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, getAllAttributes, getAttributeValue, getChildElements, getChildElements, getElementName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeContents, removeNamespaceDeclaration, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPFaultElement

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPFaultElement

All Superinterfaces:
Element, Node, Node, SOAPElement
All Known Subinterfaces:
Detail
public interface SOAPFaultElement
extends SOAPElement

A representation of the contents in a SOAPFault object. The Detail interface is a SOAPFaultElement.

Content is added to a SOAPFaultElement using the SOAPElement method addTextNode.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, getAllAttributes, getAttributeValue, getChildElements, getChildElements, getElementName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeContents, removeNamespaceDeclaration, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


AttachmentPart

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class AttachmentPart

java.lang.Object
    extended by javax.xml.soap.AttachmentPart
public abstract class AttachmentPart
extends Object

A single attachment to a SOAPMessage object. A SOAPMessage object may contain zero, one, or many AttachmentPart objects. Each AttachmentPart object consists of two parts, application-specific content and associated MIME headers. The MIME headers consists of name/value pairs that can be used to identify and describe the content.

An AttachmentPart object must conform to certain standards.

  1. It must conform to MIME [RFC2045] standards
  2. It MUST contain content
  3. The header portion MUST include the following header:
    • Content-Type
      This header identifies the type of data in the content of an AttachmentPart object and MUST conform to [RFC2045]. The following is an example of a Content-Type header:
             Content-Type:  application/xml
      The following line of code, in which ap is an AttachmentPart object, sets the header shown in the previous example.
             ap.setMimeHeader("Content-Type", "application/xml");

There are no restrictions on the content portion of an AttachmentPart object. The content may be anything from a simple plain text object to a complex XML document or image file.

An AttachmentPart object is created with the method SOAPMessage.createAttachmentPart. After setting its MIME headers, the AttachmentPart object is added to the message that created it with the method SOAPMessage.addAttachmentPart.

The following code fragment, in which m is a SOAPMessage object and contentStringl is a String, creates an instance of AttachmentPart, sets the AttachmentPart object with some content and header information, and adds the AttachmentPart object to the SOAPMessage object.

     AttachmentPart ap1 = m.createAttachmentPart();
     ap1.setContent(contentString1, "text/plain");
     m.addAttachmentPart(ap1);

The following code fragment creates and adds a second AttachmentPart instance to the same message. jpegData is a binary byte buffer representing the jpeg file.

     AttachmentPart ap2 = m.createAttachmentPart();
     byte[] jpegData =  ...;
     ap2.setContent(new ByteArrayInputStream(jpegData), "image/jpeg");
     m.addAttachmentPart(ap2);

The getContent method retrieves the contents and header from an AttachmentPart object. Depending on the DataContentHandler objects present, the returned Object can either be a typed Java object corresponding to the MIME type or an InputStream object that contains the content as bytes.

     String content1 = ap1.getContent();
     java.io.InputStream content2 = ap2.getContent();
The method clearContent removes all the content from an AttachmentPart object but does not affect its header information.
     ap1.clearContent();

Constructor Summary
AttachmentPart()
Method Summary
abstract void | addMimeHeader(String name, String value) Adds a MIME header with the specified name and value to this AttachmentPart object.
abstract void | clearContent() Clears out the content of this AttachmentPart object.
abstract Iterator | getAllMimeHeaders() Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.
abstract Object | getContent() Gets the content of this AttachmentPart object as a Java object.
String | getContentId() Gets the value of the MIME header whose name is "Content-Id".
String | getContentLocation() Gets the value of the MIME header whose name is "Content-Location".
String | getContentType() Gets the value of the MIME header whose name is "Content-Type".
abstract DataHandler | getDataHandler() Gets the DataHandler object for this AttachmentPart object.
abstract Iterator | getMatchingMimeHeaders(String[] names) Retrieves all MimeHeader objects that match a name in the given array.
abstract String[] | getMimeHeader(String name) Gets all the values of the header identified by the given String.
abstract Iterator | getNonMatchingMimeHeaders(String[] names) Retrieves all MimeHeader objects whose name does not match a name in the given array.
abstract int | getSize() Returns the number of bytes in this AttachmentPart object.
abstract void | removeAllMimeHeaders() Removes all the MIME header entries.
abstract void | removeMimeHeader(String header) Removes all MIME headers that match the given name.
abstract void | setContent(Object object, String contentType) Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type.
void | setContentId(String contentId) Sets the MIME header whose name is "Content-Id" with the given value.
void | setContentLocation(String contentLocation) Sets the MIME header whose name is "Content-Location" with the given value.
void | setContentType(String contentType) Sets the MIME header whose name is "Content-Type" with the given value.
abstract void | setDataHandler(DataHandler dataHandler) Sets the given DataHandler object as the data handler for this AttachmentPart object.
abstract void | setMimeHeader(String name, String value) Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AttachmentPart

public AttachmentPart()
Method Detail

getSize

public abstract int getSize()
                     throws SOAPException
Returns the number of bytes in this AttachmentPart object.

Returns:
the size of this AttachmentPart object in bytes or -1 if the size cannot be determined
Throws:
SOAPException - if the content of this attachment is corrupted of if there was an exception while trying to determine the size.

clearContent

public abstract void clearContent()
Clears out the content of this AttachmentPart object. The MIME header portion is left untouched.

getContent

public abstract Object getContent()
                           throws SOAPException
Gets the content of this AttachmentPart object as a Java object. The type of the returned Java object depends on (1) the DataContentHandler object that is used to interpret the bytes and (2) the Content-Type given in the header.

For the MIME content types "text/plain", "text/html" and "text/xml", the DataContentHandler object does the conversions to and from the Java types corresponding to the MIME types. For other MIME types,the DataContentHandler object can return an InputStream object that contains the content data as raw bytes.

A SAAJ-compliant implementation must, as a minimum, return a java.lang.String object corresponding to any content stream with a Content-Type value of text/plain, a javax.xml.transform.stream.StreamSource object corresponding to a content stream with a Content-Type value of text/xml, a java.awt.Image object corresponding to a content stream with a Content-Type value of image/gif or image/jpeg. For those content types that an installed DataContentHandler object does not understand, the DataContentHandler object is required to return a java.io.InputStream object with the raw bytes.

Returns:
a Java object with the content of this AttachmentPart object
Throws:
SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error

setContent

public abstract void setContent(Object object,
                                String contentType)
Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type. The type of the Object should correspond to the value given for the Content-Type. This depends on the particular set of DataContentHandler objects in use.

Parameters:
object - the Java object that makes up the content for this attachment part
contentType - the MIME string that specifies the type of the content
Throws:
IllegalArgumentException - if the contentType does not match the type of the content object, or if there was no DataContentHandler object for this content object
See Also:
getContent()

getDataHandler

public abstract DataHandler getDataHandler()
                                    throws SOAPException
Gets the DataHandler object for this AttachmentPart object.

Returns:
the DataHandler object associated with this AttachmentPart object
Throws:
SOAPException - if there is no data in this AttachmentPart object
SOAPException

setDataHandler

public abstract void setDataHandler(DataHandler dataHandler)
Sets the given DataHandler object as the data handler for this AttachmentPart object. Typically, on an incoming message, the data handler is automatically set. When a message is being created and populated with content, the setDataHandler method can be used to get data from various data sources into the message.

Parameters:
dataHandler - the DataHandler object to be set
Throws:
IllegalArgumentException - if there was a problem with the specified DataHandler object

getContentId

public String getContentId()
Gets the value of the MIME header whose name is "Content-Id".

Returns:
a String giving the value of the "Content-Id" header or null if there is none
See Also:
setContentId(java.lang.String)

getContentLocation

public String getContentLocation()
Gets the value of the MIME header whose name is "Content-Location".

Returns:
a String giving the value of the "Content-Location" header or null if there is none

getContentType

public String getContentType()
Gets the value of the MIME header whose name is "Content-Type".

Returns:
a String giving the value of the "Content-Type" header or null if there is none

setContentId

public void setContentId(String contentId)
Sets the MIME header whose name is "Content-Id" with the given value.

Parameters:
contentId - a String giving the value of the "Content-Id" header
Throws:
IllegalArgumentException - if there was a problem with the specified contentId value
See Also:
getContentId()

setContentLocation

public void setContentLocation(String contentLocation)
Sets the MIME header whose name is "Content-Location" with the given value.

Parameters:
contentLocation - a String giving the value of the "Content-Location" header
Throws:
IllegalArgumentException - if there was a problem with the specified content location

setContentType

public void setContentType(String contentType)
Sets the MIME header whose name is "Content-Type" with the given value.

Parameters:
contentType - a String giving the value of the "Content-Type" header
Throws:
IllegalArgumentException - if there was a problem with the specified content type

removeMimeHeader

public abstract void removeMimeHeader(String header)
Removes all MIME headers that match the given name.

Parameters:
header - the string name of the MIME header/s to be removed

removeAllMimeHeaders

public abstract void removeAllMimeHeaders()
Removes all the MIME header entries.

getMimeHeader

public abstract String[] getMimeHeader(String name)
Gets all the values of the header identified by the given String.

Parameters:
name - the name of the header; example: "Content-Type"
Returns:
a String array giving the value for the specified header
See Also:
setMimeHeader(java.lang.String, java.lang.String)

setMimeHeader

public abstract void setMimeHeader(String name,
                                   String value)
Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches. This method also removes all matching headers but the first.

Note that RFC822 headers can only contain US-ASCII characters.

Parameters:
name - a String giving the name of the header for which to search
value - a String giving the value to be set for the header whose name matches the given name
Throws:
IllegalArgumentException - if there was a problem with the specified mime header name or value

addMimeHeader

public abstract void addMimeHeader(String name,
                                   String value)
Adds a MIME header with the specified name and value to this AttachmentPart object.

Note that RFC822 headers can contain only US-ASCII characters.

Parameters:
name - a String giving the name of the header to be added
value - a String giving the value of the header to be added
Throws:
IllegalArgumentException - if there was a problem with the specified mime header name or value

getAllMimeHeaders

public abstract Iterator getAllMimeHeaders()
Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.

Returns:
an Iterator object with all of the Mime headers for this AttachmentPart object

getMatchingMimeHeaders

public abstract Iterator getMatchingMimeHeaders(String[] names)
Retrieves all MimeHeader objects that match a name in the given array.

Parameters:
names - a String array with the name(s) of the MIME headers to be returned
Returns:
all of the MIME headers that match one of the names in the given array as an Iterator object

getNonMatchingMimeHeaders

public abstract Iterator getNonMatchingMimeHeaders(String[] names)
Retrieves all MimeHeader objects whose name does not match a name in the given array.

Parameters:
names - a String array with the name(s) of the MIME headers not to be returned
Returns:
all of the MIME headers in this AttachmentPart object except those that match one of the names in the given array. The nonmatching MIME headers are returned as an Iterator object.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Detail

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface Detail

All Superinterfaces:
Element, Node, Node, SOAPElement, SOAPFaultElement
public interface Detail
extends SOAPFaultElement

A container for DetailEntry objects. DetailEntry objects give detailed error information that is application-specific and related to the SOAPBody object that contains it.

A Detail object, which is part of a SOAPFault object, can be retrieved using the method SOAPFault.getDetail. The Detail interface provides two methods. One creates a new DetailEntry object and also automatically adds it to the Detail object. The second method gets a list of the DetailEntry objects contained in a Detail object.

The following code fragment, in which sf is a SOAPFault object, gets its Detail object (d), adds a new DetailEntry object to d, and then gets a list of all the DetailEntry objects in d. The code also creates a Name object to pass to the method addDetailEntry. The variable se, used to create the Name object, is a SOAPEnvelope object.

    Detail d = sf.getDetail();
    Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");
    d.addDetailEntry(name);
    Iterator it = d.getDetailEntries();

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
DetailEntry | addDetailEntry(Name name) Creates a new DetailEntry object with the given name and adds it to this Detail object.
Iterator | getDetailEntries() Gets an Iterator over all of the DetailEntrys in this Detail object.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, getAllAttributes, getAttributeValue, getChildElements, getChildElements, getElementName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeContents, removeNamespaceDeclaration, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS

Method Detail

addDetailEntry

public DetailEntry addDetailEntry(Name name)
                           throws SOAPException
Creates a new DetailEntry object with the given name and adds it to this Detail object.

Parameters:
name - a Name object identifying the new DetailEntry object
Throws:
SOAPException - thrown when there is a problem in adding a DetailEntry object to this Detail object.

getDetailEntries

public Iterator getDetailEntries()
Gets an Iterator over all of the DetailEntrys in this Detail object.

Returns:
an Iterator object over the DetailEntry objects in this Detail object
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MessageFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class MessageFactory

java.lang.Object
    extended by javax.xml.soap.MessageFactory
public abstract class MessageFactory
extends Object

A factory for creating SOAPMessage objects.

A SAAJ client can create a MessageFactory object using the method newInstance, as shown in the following line of code.

       MessageFactory mf = MessageFactory.newInstance();
A standalone client (a client that is not running in a container) can use the newInstance method to create a MessageFactory object.

All MessageFactory objects, regardless of how they are created, will produce SOAPMessage objects that have the following elements by default:

  • A SOAPPart object
  • A SOAPEnvelope object
  • A SOAPBody object
  • A SOAPHeader object
MessageFactory objects can be initialized with a JAXM profile. In such a case it will produce messages that also come prepopulated with additional entries in the SOAPHeader object and the SOAPBody object. The content of a new SOAPMessage object depends on which of the two MessageFactory methods is used to create it.
  • createMessage() -- message has no content
    This is the method clients would normally use to create a request message.
  • createMessage(MimeHeaders, java.io.InputStream) -- message has content from the InputStream object and headers from the MimeHeaders object
    This method can be used internally by a service implementation to create a message that is a response to a request.

Constructor Summary
MessageFactory()
Method Summary
abstract SOAPMessage | createMessage() Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
abstract SOAPMessage | createMessage(MimeHeaders headers, InputStream in) Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
static MessageFactory | newInstance() Creates a new MessageFactory object that is an instance of the default implementation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageFactory

public MessageFactory()
Method Detail

newInstance

public static MessageFactory newInstance()
                                  throws SOAPException
Creates a new MessageFactory object that is an instance of the default implementation.

Throws:
SOAPException - if there was an error in creating the default implementation of the MessageFactory.

createMessage

public abstract SOAPMessage createMessage()
                                   throws SOAPException
Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects. Profile-specific message factories can choose to prepopulate the SOAPMessage object with profile-specific headers.

Content can be added to this message's SOAPPart object, and the message can be sent "as is" when a message containing only a SOAP part is sufficient. Otherwise, the SOAPMessage object needs to create one or more AttachmentPart objects and add them to itself. Any content that is not in XML format must be in an AttachmentPart object.

Returns:
a new SOAPMessage object
Throws:
SOAPException - if a SOAP error occurs

createMessage

public abstract SOAPMessage createMessage(MimeHeaders headers,
                                          InputStream in)
                                   throws IOException,
                                          SOAPException
Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.

Parameters:
in - the InputStream object that contains the data for a message
headers - the transport-specific headers passed to the message in a transport-independent fashion for creation of the message
Returns:
a new SOAPMessage object containing the data from the given InputStream object
Throws:
IOException - if there is a problem in reading data from the input stream
SOAPException - if the message is invalid
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimeHeader

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class MimeHeader

java.lang.Object
    extended by javax.xml.soap.MimeHeader
public class MimeHeader
extends Object

An object that stores a MIME header name and its value. One or more MimeHeader objects may be contained in a MimeHeaders object.

See Also:
MimeHeaders

Constructor Summary
MimeHeader(String name, String value)
Constructs a MimeHeader object initialized with the given name and value.
Method Summary
String | getName() Returns the name of this MimeHeader object.
String | getValue() Returns the value of this MimeHeader object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MimeHeader

public MimeHeader(String name,
                  String value)
Constructs a MimeHeader object initialized with the given name and value.

Parameters:
name - a String giving the name of the header
value - a String giving the value of the header
Method Detail

getName

public String getName()
Returns the name of this MimeHeader object.

Returns:
the name of the header as a String

getValue

public String getValue()
Returns the value of this MimeHeader object.

Returns:
the value of the header as a String
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


MimeHeaders

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class MimeHeaders

java.lang.Object
    extended by javax.xml.soap.MimeHeaders
public class MimeHeaders
extends Object

A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.

This class is used primarily when an application wants to retrieve specific attachments based on certain MIME headers and values. This class will most likely be used by implementations of AttachmentPart and other MIME dependent parts of the SAAJ API.

See Also:
SOAPMessage.getAttachments(), AttachmentPart

Constructor Summary
MimeHeaders()
Constructs a default MimeHeaders object initialized with an empty Vector object.
Method Summary
void | addHeader(String name, String value) Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.
Iterator | getAllHeaders() Returns all the MimeHeaders in this MimeHeaders object.
String[] | getHeader(String name) Returns all of the values for the specified header as an array of String objects.
Iterator | getMatchingHeaders(String[] names) Returns all the MimeHeader objects whose name matches a name in the given array of names.
Iterator | getNonMatchingHeaders(String[] names) Returns all of the MimeHeader objects whose name does not match a name in the given array of names.
void | removeAllHeaders() Removes all the header entries from this MimeHeaders object.
void | removeHeader(String name) Remove all MimeHeader objects whose name matches the the given name.
void | setHeader(String name, String value) Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MimeHeaders

public MimeHeaders()
Constructs a default MimeHeaders object initialized with an empty Vector object.

Method Detail

getHeader

public String[] getHeader(String name)
Returns all of the values for the specified header as an array of String objects.

Parameters:
name - the name of the header for which values will be returned
Returns:
a String array with all of the values for the specified header
See Also:
setHeader(java.lang.String, java.lang.String)

setHeader

public void setHeader(String name,
                      String value)
Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches. This method also removes all matching headers after the first one.

Note that RFC822 headers can contain only US-ASCII characters.

Parameters:
name - a String with the name of the header for which to search
value - a String with the value that will replace the current value of the specified header
Throws:
IllegalArgumentException - if there was a problem in the mime header name or the value being set
See Also:
getHeader(java.lang.String)

addHeader

public void addHeader(String name,
                      String value)
Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.

Note that RFC822 headers can contain only US-ASCII characters.

Parameters:
name - a String with the name of the header to be added
value - a String with the value of the header to be added
Throws:
IllegalArgumentException - if there was a problem in the mime header name or value being added

removeHeader

public void removeHeader(String name)
Remove all MimeHeader objects whose name matches the the given name.

Parameters:
name - a String with the name of the header for which to search

removeAllHeaders

public void removeAllHeaders()
Removes all the header entries from this MimeHeaders object.

getAllHeaders

public Iterator getAllHeaders()
Returns all the MimeHeaders in this MimeHeaders object.

Returns:
an Iterator object over this MimeHeaders object's list of MimeHeader objects

getMatchingHeaders

public Iterator getMatchingHeaders(String[] names)
Returns all the MimeHeader objects whose name matches a name in the given array of names.

Parameters:
names - an array of String objects with the names for which to search
Returns:
an Iterator object over the MimeHeader objects whose name matches one of the names in the given list

getNonMatchingHeaders

public Iterator getNonMatchingHeaders(String[] names)
Returns all of the MimeHeader objects whose name does not match a name in the given array of names.

Parameters:
names - an array of String objects with the names for which to search
Returns:
an Iterator object over the MimeHeader objects whose name does not match one of the names in the given list
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Name

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface Name

public interface Name

A representation of an XML name. This interface provides methods for getting the local and namespace-qualified names and also for getting the prefix associated with the namespace for the name. It is also possible to get the URI of the namespace.

The following is an example of a namespace declaration in an element.

   <wombat:GetLastTradePrice xmlns:wombat="http://www.wombat.org/trader">
("xmlns" stands for "XML namespace".) The following shows what the methods in the Name interface will return.
  • getQualifiedName will return "prefix:LocalName" = "WOMBAT:GetLastTradePrice"
  • getURI will return "http://www.wombat.org/trader"
  • getLocalName will return "GetLastTracePrice"
  • getPrefix will return "WOMBAT"

XML namespaces are used to disambiguate SOAP identifiers from application-specific identifiers.

Name objects are created using the method SOAPEnvelope.createName, which has two versions. One method creates Name objects with a local name, a namespace prefix, and a namespace URI. and the second creates Name objects with just a local name. The following line of code, in which se is a SOAPEnvelope object, creates a new Name object with all three.

     Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");
The following line of code gives an example of how a Name object can be used. The variable element is a SOAPElement object. This code creates a new SOAPElement object with the given name and adds it to element.
     element.addChildElement(name);

See Also:
SOAPEnvelope.createName, SOAPFactory.createName

Method Summary
String | getLocalName() Gets the local name part of the XML name that this Name object represents.
String | getPrefix() Returns the prefix that was specified when this Name object was initialized.
String | getQualifiedName() Gets the namespace-qualified name of the XML name that this Name object represents.
String | getURI() Returns the URI of the namespace for the XML name that this Name object represents.

Method Detail

getLocalName

public String getLocalName()
Gets the local name part of the XML name that this Name object represents.

Returns:
a string giving the local name

getQualifiedName

public String getQualifiedName()
Gets the namespace-qualified name of the XML name that this Name object represents.

Returns:
the namespace-qualified name as a string

getPrefix

public String getPrefix()
Returns the prefix that was specified when this Name object was initialized. This prefix is associated with the namespace for the XML name that this Name object represents.

Returns:
the prefix as a string

getURI

public String getURI()
Returns the URI of the namespace for the XML name that this Name object represents.

Returns:
the URI as a string
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Node

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface Node

All Superinterfaces:
Node
All Known Subinterfaces:
Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text
public interface Node
extends Node

A representation of a node (element) in an XML document. This interface extnends the standard DOM Node interface with methods for getting and setting the value of a node, for getting and setting the parent of a node, and for removing a node.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
void | detachNode() Removes this Node object from the tree.
SOAPElement | getParentElement() Returns the parent element of this Node object.
String | getValue() Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise.
void | recycleNode() Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.
void | setParentElement(SOAPElement parent) Sets the parent of this Node object to the given SOAPElement object.
void | setValue(String value) If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node.
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix

Method Detail

getValue

public String getValue()
Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise. If there is an immediate child of this Node that it is a Text node then it's value will be returned. If there is more than one Text node then the value of the first Text Node will be returned. Otherwise null is returned.

Returns:
a String with the text of this node if this is a Text node or the text contained by the first immediate child of this Node object that is a Text object if such a child exists; null otherwise.

setValue

public void setValue(String value)
If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node. The value of the immediate child of this node can be set only if, there is one child node and that node is a Text node, or if there are no children in which case a child Text node will be created.

Throws:
IllegalStateException - if the node is not a Text node and either has more than one child node or has a child node that is not a Text node.
Since:
SAAJ 1.2

setParentElement

public void setParentElement(SOAPElement parent)
                      throws SOAPException
Sets the parent of this Node object to the given SOAPElement object.

Parameters:
parent - the SOAPElement object to be set as the parent of this Node object
Throws:
SOAPException - if there is a problem in setting the parent to the given element
See Also:
getParentElement()

getParentElement

public SOAPElement getParentElement()
Returns the parent element of this Node object. This method can throw an UnsupportedOperationException if the tree is not kept in memory.

Returns:
the SOAPElement object that is the parent of this Node object or null if this Node object is root
Throws:
UnsupportedOperationException - if the whole tree is not kept in memory
See Also:
setParentElement(javax.xml.soap.SOAPElement)

detachNode

public void detachNode()
Removes this Node object from the tree.

recycleNode

public void recycleNode()
Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.

Calling the method recycleNode implies that the method detachNode has been called previously.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPBody

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPBody

All Superinterfaces:
Element, Node, Node, SOAPElement
public interface SOAPBody
extends SOAPElement

An object that represents the contents of the SOAP body element in a SOAP message. A SOAP body element consists of XML data that affects the way the application-specific content is processed.

A SOAPBody object contains SOAPBodyElement objects, which have the content for the SOAP body. A SOAPFault object, which carries status and/or error information, is an example of a SOAPBodyElement object.

See Also:
SOAPFault

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
SOAPBodyElement | addBodyElement(Name name) Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
SOAPBodyElement | addDocument(Document document) Adds the root node of the DOM Document to this SOAPBody object.
SOAPFault | addFault() Creates a new SOAPFault object and adds it to this SOAPBody object.
SOAPFault | addFault(Name faultCode, String faultString) Creates a new SOAPFault object and adds it to this SOAPBody object.
SOAPFault | addFault(Name faultCode, String faultString, Locale locale) Creates a new SOAPFault object and adds it to this SOAPBody object.
SOAPFault | getFault() Returns the SOAPFault object in this SOAPBody object.
boolean | hasFault() Indicates whether a SOAPFault object exists in this SOAPBody object.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, getAllAttributes, getAttributeValue, getChildElements, getChildElements, getElementName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeContents, removeNamespaceDeclaration, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS

Method Detail

addFault

public SOAPFault addFault()
                   throws SOAPException
Creates a new SOAPFault object and adds it to this SOAPBody object. The new SOAPFault will have default values set for the mandatory child elements faultcode and faultstring.

A SOAPBody may contain at most one SOAPFault child element

Returns:
the new SOAPFault object
Throws:
SOAPException - if there is a SOAP error

addFault

public SOAPFault addFault(Name faultCode,
                          String faultString,
                          Locale locale)
                   throws SOAPException
Creates a new SOAPFault object and adds it to this SOAPBody object. The new SOAPFault will have a faultcode element that is set to the faultCode parameter and a faultstring set to faultString and localized to locale.

A SOAPBody may contain at most one SOAPFault child element

Parameters:
faultCode - a Name object giving the fault code to be set; must be one of the fault codes defined in the SOAP 1.1 specification and of type QName
faultString - a String giving an explanation of the fault
locale - a Locale object indicating the native language of the faultString
Returns:
the new SOAPFault object
Throws:
SOAPException - if there is a SOAP error
Since:
SAAJ 1.2
See Also:
SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

addFault

public SOAPFault addFault(Name faultCode,
                          String faultString)
                   throws SOAPException
Creates a new SOAPFault object and adds it to this SOAPBody object. The new SOAPFault will have a faultcode element that is set to the faultCode parameter and a faultstring set to faultString.

A SOAPBody may contain at most one SOAPFault child element

Parameters:
faultCode - a Name object giving the fault code to be set; must be one of the fault codes defined in the SOAP 1.1 specification and of type QName
faultString - a String giving an explanation of the fault
Returns:
the new SOAPFault object
Throws:
SOAPException - if there is a SOAP error
Since:
SAAJ 1.2
See Also:
SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

hasFault

public boolean hasFault()
Indicates whether a SOAPFault object exists in this SOAPBody object.

Returns:
true if a SOAPFault object exists in this SOAPBody object; false otherwise

getFault

public SOAPFault getFault()
Returns the SOAPFault object in this SOAPBody object.

Returns:
the SOAPFault object in this SOAPBody object

addBodyElement

public SOAPBodyElement addBodyElement(Name name)
                               throws SOAPException
Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.

Parameters:
name - a Name object with the name for the new SOAPBodyElement object
Returns:
the new SOAPBodyElement object
Throws:
SOAPException - if a SOAP error occurs

addDocument

public SOAPBodyElement addDocument(Document document)
                            throws SOAPException
Adds the root node of the DOM Document to this SOAPBody object.

Calling this method invalidates the document parameter. The client application should discard all references to this Document and its contents upon calling addDocument. The behavior of an application that continues to use such references is undefined.

Parameters:
document - the Document object whose root node will be added to this SOAPBody.
Returns:
the SOAPBodyElement that represents the root node that was added.
Throws:
SOAPException - if the Document cannot be added
Since:
SAAJ 1.2
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPConnection

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPConnection

java.lang.Object
    extended by javax.xml.soap.SOAPConnection
public abstract class SOAPConnection
extends Object

A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).

The SOAPConnection class is optional. Some implementations may not implement this interface in which case the call to SOAPConnectionFactory.newInstance() (see below) will throw an UnsupportedOperationException.

A client can obtain a SOAPConnection object using a SOAPConnectionFactory object as in the following example:

      SOAPConnectionFactory factory = SOAPConnectionFactory.newInstance();
      SOAPConnection con = factory.createConnection();
A SOAPConnection object can be used to send messages directly to a URL following the request/response paradigm. That is, messages are sent using the method call, which sends the message and then waits until it gets a reply.

Constructor Summary
SOAPConnection()
Method Summary
abstract SOAPMessage | call(SOAPMessage request, Object to) Sends the given message to the specified endpoint and blocks until it has returned the response.
abstract void | close() Closes this SOAPConnection object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SOAPConnection

public SOAPConnection()
Method Detail

call

public abstract SOAPMessage call(SOAPMessage request,
                                 Object to)
                          throws SOAPException
Sends the given message to the specified endpoint and blocks until it has returned the response.

Parameters:
request - the SOAPMessage object to be sent
to - an Object that identifies where the message should be sent. It is required to support Objects of type java.lang.String, java.net.URL, and when JAXM is present javax.xml.messaging.URLEndpoint
Returns:
the SOAPMessage object that is the response to the message that was sent
Throws:
SOAPException - if there is a SOAP error

close

public abstract void close()
                    throws SOAPException
Closes this SOAPConnection object.

Throws:
SOAPException - if there is a SOAP error
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPConnectionFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPConnectionFactory

java.lang.Object
    extended by javax.xml.soap.SOAPConnectionFactory
public abstract class SOAPConnectionFactory
extends Object

A factory for creating SOAPConnection objects. Implementation of this class is optional. If SOAPConnectionFactory.newInstance() throws an UnsupportedOperationException then the implementation does not support the SAAJ communication infrastructure. Otherwise SOAPConnection objects can be created by calling createConnection() on the newly created SOAPConnectionFactory object.

Constructor Summary
SOAPConnectionFactory()
Method Summary
abstract SOAPConnection | createConnection() Create a new SOAPConnection.
static SOAPConnectionFactory | newInstance() Creates an instance of the default SOAPConnectionFactory object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SOAPConnectionFactory

public SOAPConnectionFactory()
Method Detail

newInstance

public static SOAPConnectionFactory newInstance()
                                         throws SOAPException,
                                                UnsupportedOperationException
Creates an instance of the default SOAPConnectionFactory object.

Returns:
a new instance of a default SOAPConnectionFactory object
Throws:
SOAPException - if there was an error creating the SOAPConnectionFactory
UnsupportedOperationException - if newInstance is not supported.

createConnection

public abstract SOAPConnection createConnection()
                                         throws SOAPException
Create a new SOAPConnection.

Returns:
the new SOAPConnection object.
Throws:
SOAPException - if there was an exception creating the SOAPConnection object.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPConstants

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPConstants

public interface SOAPConstants

The definition of constants pertaining to the SOAP 1.1 protocol.

Field Summary
static String | URI_NS_SOAP_ENCODING The namespace identifier for the SOAP 1.1 encoding.
static String | URI_NS_SOAP_ENVELOPE The namespace identifier for the SOAP 1.1 envelope.
static String | URI_SOAP_ACTOR_NEXT The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

Field Detail

URI_NS_SOAP_ENVELOPE

public static final String URI_NS_SOAP_ENVELOPE
The namespace identifier for the SOAP 1.1 envelope. All SOAPElements in this namespace are defined by the SOAP 1.1 specification.

See Also:
Constant Field Values

URI_NS_SOAP_ENCODING

public static final String URI_NS_SOAP_ENCODING
The namespace identifier for the SOAP 1.1 encoding. An attribute named encodingStyle in the URI_NS_SOAP_ENVELOPE namespace and set to the value URI_NS_SOAP_ENCODING can be added to an element to indicate that it is encoded using the rules in section 5 of the SOAP 1.1 specification.

See Also:
Constant Field Values

URI_SOAP_ACTOR_NEXT

public static final String URI_SOAP_ACTOR_NEXT
The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

This value can be passed to
SOAPHeader.examineMustUnderstandHeaderElements(String),
SOAPHeader.examineHeaderElements(String) and
SOAPHeader.extractHeaderElements(String)

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPElement

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPElement

All Superinterfaces:
Element, Node, Node
All Known Subinterfaces:
Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement
public interface SOAPElement
extends Node, Element

An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification. This interface serves as the base interface for those objects that are specifically prescribed by a SOAP specification.

Methods in this interface that are required to return SAAJ specific objects may "silently" replace nodes in the tree as required to successfully return objects of the correct type. See getChildElements() and javax.xml.soap for details.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
SOAPElement | addAttribute(Name name, String value) Adds an attribute with the specified name and value to this SOAPElement object.
SOAPElement | addChildElement(Name name) Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
SOAPElement | addChildElement(SOAPElement element) Add a SOAPElement as a child of this SOAPElement instance.
SOAPElement | addChildElement(String localName) Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
SOAPElement | addChildElement(String localName, String prefix) Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
SOAPElement | addChildElement(String localName, String prefix, String uri) Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
SOAPElement | addNamespaceDeclaration(String prefix, String uri) Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
SOAPElement | addTextNode(String text) Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
Iterator | getAllAttributes() Returns an Iterator over all of the attribute Name objects in this SOAPElement object.
String | getAttributeValue(Name name) Returns the value of the attribute with the specified name.
Iterator | getChildElements() Returns an Iterator over all the immediate child Nodes of this element.
Iterator | getChildElements(Name name) Returns an Iterator over all the immediate child Nodes of this element with the specified name.
Name | getElementName() Returns the name of this SOAPElement object.
String | getEncodingStyle() Returns the encoding style for this SOAPElement object.
Iterator | getNamespacePrefixes() Returns an Iterator over the namespace prefix Strings declared by this element.
String | getNamespaceURI(String prefix) Returns the URI of the namespace that has the given prefix.
Iterator | getVisibleNamespacePrefixes() Returns an Iterator over the namespace prefix Strings visible to this element.
boolean | removeAttribute(Name name) Removes the attribute with the specified name.
void | removeContents() Detaches all children of this SOAPElement.
boolean | removeNamespaceDeclaration(String prefix) Removes the namespace declaration corresponding to the given prefix.
void | setEncodingStyle(String encodingStyle) Sets the encoding style for this SOAPElement object to one specified.
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS

Method Detail

addChildElement

public SOAPElement addChildElement(Name name)
                            throws SOAPException
Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.

Parameters:
name - a Name object with the XML name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object

addChildElement

public SOAPElement addChildElement(String localName)
                            throws SOAPException
Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.

Parameters:
localName - a String giving the local name for the element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object

addChildElement

public SOAPElement addChildElement(String localName,
                                   String prefix)
                            throws SOAPException
Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.

Parameters:
localName - a String giving the local name for the new element
prefix - a String giving the namespace prefix for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object

addChildElement

public SOAPElement addChildElement(String localName,
                                   String prefix,
                                   String uri)
                            throws SOAPException
Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.

Parameters:
localName - a String giving the local name for the new element
prefix - a String giving the namespace prefix for the new element
uri - a String giving the URI of the namespace to which the new element belongs
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object

addChildElement

public SOAPElement addChildElement(SOAPElement element)
                            throws SOAPException
Add a SOAPElement as a child of this SOAPElement instance. The SOAPElement is expected to be created by a SOAPElementFactory. Callers should not rely on the element instance being added as is into the XML tree. Implementations could end up copying the content of the SOAPElement passed into an instance of a different SOAPElement implementation. For instance if addChildElement() is called on a SOAPHeader, element will be copied into an instance of a SOAPHeaderElement.

The fragment rooted in element is either added as a whole or not at all, if there was an error.

The fragment rooted in element cannot contain elements named "Envelope", "Header" or "Body" and in the SOAP namespace. Any namespace prefixes present in the fragment should be fully resolved using appropriate namespace declarations within the fragment itself.

Parameters:
element - the SOAPElement to be added as a new child
Returns:
an instance representing the new SOAP element that was actually added to the tree.
Throws:
SOAPException - if there was an error in adding this element as a child

removeContents

public void removeContents()
Detaches all children of this SOAPElement.

This method is useful for rolling back the construction of partially completed SOAPHeaders and SOAPBodys in preparation for sending a fault when an error condition is detected. It is also useful for recycling portions of a document within a SOAP message.

Since:
SAAJ 1.2

addTextNode

public SOAPElement addTextNode(String text)
                        throws SOAPException
Creates a new Text object initialized with the given String and adds it to this SOAPElement object.

Parameters:
text - a String object with the textual content to be added
Returns:
the SOAPElement object into which the new Text object was inserted
Throws:
SOAPException - if there is an error in creating the new Text object

addAttribute

public SOAPElement addAttribute(Name name,
                                String value)
                         throws SOAPException
Adds an attribute with the specified name and value to this SOAPElement object.

Parameters:
name - a Name object with the name of the attribute
value - a String giving the value of the attribute
Returns:
the SOAPElement object into which the attribute was inserted
Throws:
SOAPException - if there is an error in creating the Attribute

addNamespaceDeclaration

public SOAPElement addNamespaceDeclaration(String prefix,
                                           String uri)
                                    throws SOAPException
Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.

Parameters:
prefix - a String giving the prefix of the namespace
uri - a String giving the uri of the namespace
Returns:
the SOAPElement object into which this namespace declaration was inserted.
Throws:
SOAPException - if there is an error in creating the namespace

getAttributeValue

public String getAttributeValue(Name name)
Returns the value of the attribute with the specified name.

Parameters:
name - a Name object with the name of the attribute
Returns:
a String giving the value of the specified attribute

getAllAttributes

public Iterator getAllAttributes()
Returns an Iterator over all of the attribute Name objects in this SOAPElement object. The iterator can be used to get the attribute names, which can then be passed to the method getAttributeValue to retrieve the value of each attribute.

Returns:
an iterator over the names of the attributes

getNamespaceURI

public String getNamespaceURI(String prefix)
Returns the URI of the namespace that has the given prefix.

Parameters:
prefix - a String giving the prefix of the namespace for which to search
Returns:
a String with the uri of the namespace that has the given prefix

getNamespacePrefixes

public Iterator getNamespacePrefixes()
Returns an Iterator over the namespace prefix Strings declared by this element. The prefixes returned by this iterator can be passed to the method getNamespaceURI to retrieve the URI of each namespace.

Returns:
an iterator over the namespace prefixes in this SOAPElement object

getVisibleNamespacePrefixes

public Iterator getVisibleNamespacePrefixes()
Returns an Iterator over the namespace prefix Strings visible to this element. The prefixes returned by this iterator can be passed to the method getNamespaceURI to retrieve the URI of each namespace.

Returns:
an iterator over the namespace prefixes are within scope of this SOAPElement object
Since:
SAAJ 1.2

getElementName

public Name getElementName()
Returns the name of this SOAPElement object.

Returns:
a Name object with the name of this SOAPElement object

removeAttribute

public boolean removeAttribute(Name name)
Removes the attribute with the specified name.

Parameters:
name - the Name object with the name of the attribute to be removed
Returns:
true if the attribute was removed successfully; false if it was not

removeNamespaceDeclaration

public boolean removeNamespaceDeclaration(String prefix)
Removes the namespace declaration corresponding to the given prefix.

Parameters:
prefix - a String giving the prefix for which to search
Returns:
true if the namespace declaration was removed successfully; false if it was not

getChildElements

public Iterator getChildElements()
Returns an Iterator over all the immediate child Nodes of this element. This includes javax.xml.soap.Text objects as well as SOAPElement objects.

Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

Returns:
an iterator with the content of this SOAPElement object

getChildElements

public Iterator getChildElements(Name name)
Returns an Iterator over all the immediate child Nodes of this element with the specified name. All of these children will be SOAPElement nodes.

Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

Parameters:
name - a Name object with the name of the child elements to be returned
Returns:
an Iterator object over all the elements in this SOAPElement object with the specified name

setEncodingStyle

public void setEncodingStyle(String encodingStyle)
                      throws SOAPException
Sets the encoding style for this SOAPElement object to one specified.

Parameters:
encodingStyle - a String giving the encoding style
Throws:
IllegalArgumentException - if there was a problem in the encoding style being set.
SOAPException
See Also:
getEncodingStyle()

getEncodingStyle

public String getEncodingStyle()
Returns the encoding style for this SOAPElement object.

Returns:
a String giving the encoding style
See Also:
setEncodingStyle(java.lang.String)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPElementFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPElementFactory

java.lang.Object
    extended by javax.xml.soap.SOAPElementFactory
Deprecated. - Use javax.xml.soap.SOAPFactory for creating SOAPElements.

public class SOAPElementFactory
extends Object

SOAPElementFactory is a factory for XML fragments that will eventually end up in the SOAP part. These fragments can be inserted as children of the SOAPHeader or SOAPBody or SOAPEnvelope.

Elements created using this factory do not have the properties of an element that lives inside a SOAP header document. These elements are copied into the XML document tree when they are inserted.

See Also:
SOAPFactory

Method Summary
 SOAPElement create(Name name)
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
 SOAPElement create(String localName)
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
 SOAPElement create(String localName, String prefix, String uri)
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
static SOAPElementFactory newInstance()
Deprecated. Creates a new instance of SOAPElementFactory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

create

public SOAPElement create(Name name)
                   throws SOAPException
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead

Create a SOAPElement object initialized with the given Name object.

Parameters:
name - a Name object with the XML name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object
See Also:
SOAPFactory.createElement(javax.xml.soap.Name)

create

public SOAPElement create(String localName)
                   throws SOAPException
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName) instead

Create a SOAPElement object initialized with the given local name.

Parameters:
localName - a String giving the local name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object
See Also:
SOAPFactory.createElement(java.lang.String)

create

public SOAPElement create(String localName,
                          String prefix,
                          String uri)
                   throws SOAPException
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead

Create a new SOAPElement object with the given local name, prefix and uri.

Parameters:
localName - a String giving the local name for the new element
prefix - the prefix for this SOAPElement
uri - a String giving the URI of the namespace to which the new element belongs
Throws:
SOAPException - if there is an error in creating the SOAPElement object
See Also:
SOAPFactory.createElement(java.lang.String, java.lang.String, java.lang.String)

newInstance

public static SOAPElementFactory newInstance()
                                      throws SOAPException
Deprecated.
Creates a new instance of SOAPElementFactory.

Returns:
a new instance of a SOAPElementFactory
Throws:
SOAPException - if there was an error creating the default SOAPElementFactory
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPEnvelope

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPEnvelope

All Superinterfaces:
Element, Node, Node, SOAPElement
public interface SOAPEnvelope
extends SOAPElement

The container for the SOAPHeader and SOAPBody portions of a SOAPPart object. By default, a SOAPMessage object is created with a SOAPPart object that has a SOAPEnvelope object. The SOAPEnvelope object by default has an empty SOAPBody object and an empty SOAPHeader object. The SOAPBody object is required, and the SOAPHeader object, though optional, is used in the majority of cases. If the SOAPHeader object is not needed, it can be deleted, which is shown later.

A client can access the SOAPHeader and SOAPBody objects by calling the methods SOAPEnvelope.getHeader and SOAPEnvelope.getBody. The following lines of code use these two methods after starting with the SOAPMessage object message to get the SOAPPart object sp, which is then used to get the SOAPEnvelope object se.

     SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     SOAPHeader sh = se.getHeader();
     SOAPBody sb = se.getBody();

It is possible to change the body or header of a SOAPEnvelope object by retrieving the current one, deleting it, and then adding a new body or header. The javax.xml.soap.Node method deleteNode deletes the XML element (node) on which it is called. For example, the following line of code deletes the SOAPBody object that is retrieved by the method getBody.

      se.getBody().detachNode();
To create a SOAPHeader object to replace the one that was removed, a client uses the method SOAPEnvelope.addHeader, which creates a new header and adds it to the SOAPEnvelope object. Similarly, the method addBody creates a new SOAPBody object and adds it to the SOAPEnvelope object. The following code fragment retrieves the current header, removes it, and adds a new one. Then it retrieves the current body, removes it, and adds a new one.
     SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     se.getHeader().detachNode();
     SOAPHeader sh = se.addHeader();
     se.getBody().detachNode();
     SOAPBody sb = se.addBody();
It is an error to add a SOAPBody or SOAPHeader object if one already exists.

The SOAPEnvelope interface provides three methods for creating Name objects. One method creates Name objects with a local name, a namespace prefix, and a namesapce URI. The second method creates Name objects with a local name and a namespace prefix, and the third creates Name objects with just a local name. The following line of code, in which se is a SOAPEnvelope object, creates a new Name object with all three.

     Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
SOAPBody | addBody() Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
SOAPHeader | addHeader() Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
Name | createName(String localName) Creates a new Name object initialized with the given local name.
Name | createName(String localName, String prefix, String uri) Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
SOAPBody | getBody() Returns the SOAPBody object associated with this SOAPEnvelope object.
SOAPHeader | getHeader() Returns the SOAPHeader object for this SOAPEnvelope object.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, getAllAttributes, getAttributeValue, getChildElements, getChildElements, getElementName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeContents, removeNamespaceDeclaration, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS

Method Detail

createName

public Name createName(String localName,
                       String prefix,
                       String uri)
                throws SOAPException
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

This factory method creates Name objects for use in the SOAP/XML document.

Parameters:
localName - a String giving the local name
prefix - a String giving the prefix of the namespace
uri - a String giving the URI of the namespace
Returns:
a Name object initialized with the given local name, namespace prefix, and namespace URI
Throws:
SOAPException - if there is a SOAP error

createName

public Name createName(String localName)
                throws SOAPException
Creates a new Name object initialized with the given local name.

This factory method creates Name objects for use in the SOAP/XML document.

Parameters:
localName - a String giving the local name
Returns:
a Name object initialized with the given local name
Throws:
SOAPException - if there is a SOAP error

getHeader

public SOAPHeader getHeader()
                     throws SOAPException
Returns the SOAPHeader object for this SOAPEnvelope object.

A new SOAPMessage object is by default created with a SOAPEnvelope object that contains an empty SOAPHeader object. As a result, the method getHeader will always return a SOAPHeader object unless the header has been removed and a new one has not been added.

Returns:
the SOAPHeader object or null if there is none
Throws:
SOAPException - if there is a problem obtaining the SOAPHeader object

getBody

public SOAPBody getBody()
                 throws SOAPException
Returns the SOAPBody object associated with this SOAPEnvelope object.

A new SOAPMessage object is by default created with a SOAPEnvelope object that contains an empty SOAPBody object. As a result, the method getBody will always return a SOAPBody object unless the body has been removed and a new one has not been added.

Returns:
the SOAPBody object for this SOAPEnvelope object or null if there is none
Throws:
SOAPException - if there is a problem obtaining the SOAPBody object

addHeader

public SOAPHeader addHeader()
                     throws SOAPException
Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.

It is illegal to add a header when the envelope already contains a header. Therefore, this method should be called only after the existing header has been removed.

Returns:
the new SOAPHeader object
Throws:
SOAPException - if this SOAPEnvelope object already contains a valid SOAPHeader object

addBody

public SOAPBody addBody()
                 throws SOAPException
Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.

It is illegal to add a body when the envelope already contains a body. Therefore, this method should be called only after the existing body has been removed.

Returns:
the new SOAPBody object
Throws:
SOAPException - if this SOAPEnvelope object already contains a valid SOAPBody object
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.soap.SOAPException
All Implemented Interfaces:
Serializable
public class SOAPException
extends Exception

An exception that signals that a SOAP exception has occurred. A SOAPException object may contain a String that gives the reason for the exception, an embedded Throwable object, or both. This class provides methods for retrieving reason messages and for retrieving the embedded Throwable object.

Typical reasons for throwing a SOAPException object are problems such as difficulty setting a header, not being able to send a message, and not being able to get a connection with the provider. Reasons for embedding a Throwable object include problems such as input/output errors or a parsing problem, such as an error in parsing a header.

See Also:
Serialized Form

Constructor Summary
SOAPException()
Constructs a SOAPException object with no reason or embedded Throwable object.
SOAPException(String reason)
Constructs a SOAPException object with the given String as the reason for the exception being thrown.
SOAPException(String reason, Throwable cause)
Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.
SOAPException(Throwable cause)
Constructs a SOAPException object initialized with the given Throwable object.
Method Summary
Throwable | getCause() Returns the Throwable object embedded in this SOAPException if there is one.
String | getMessage() Returns the detail message for this SOAPException object.
Throwable | initCause(Throwable cause) Initializes the cause field of this SOAPException object with the given Throwable object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SOAPException

public SOAPException()
Constructs a SOAPException object with no reason or embedded Throwable object.

SOAPException

public SOAPException(String reason)
Constructs a SOAPException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

SOAPException

public SOAPException(String reason,
                     Throwable cause)
Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this SOAPException object

SOAPException

public SOAPException(Throwable cause)
Constructs a SOAPException object initialized with the given Throwable object.

Method Detail

getMessage

public String getMessage()
Returns the detail message for this SOAPException object.

If there is an embedded Throwable object, and if the SOAPException object has no detail message of its own, this method will return the detail message from the embedded Throwable object.

Returns:
the error or warning message for this SOAPException or, if it has none, the message of the embedded Throwable object, if there is one

getCause

public Throwable getCause()
Returns the Throwable object embedded in this SOAPException if there is one. Otherwise, this method returns null.

Returns:
the embedded Throwable object or null if there is none

initCause

public Throwable initCause(Throwable cause)
Initializes the cause field of this SOAPException object with the given Throwable object.

This method can be called at most once. It is generally called from within the constructor or immediately after the constructor has returned a new SOAPException object. If this SOAPException object was created with the constructor SOAPException(Throwable) or SOAPException(String,Throwable), meaning that its cause field already has a value, this method cannot be called even once.

Parameters:
cause - the Throwable object that caused this SOAPException object to be thrown. The value of this parameter is saved for later retrieval by the getCause() method. A null value is permitted and indicates that the cause is nonexistent or unknown.
Returns:
a reference to this SOAPException instance
Throws:
IllegalArgumentException - if cause is this Throwable object. (A Throwable object cannot be its own cause.)
IllegalStateException - if the cause for this SOAPException object has already been initialized
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPFactory

java.lang.Object
    extended by javax.xml.soap.SOAPFactory
public abstract class SOAPFactory
extends Object

SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree. SOAPFactory can be used to create XML fragments that will eventually end up in the SOAP part. These fragments can be inserted as children of the SOAPHeaderElement or SOAPBodyElement or SOAPEnvelope or other SOAPElement objects. SOAPFactory also has methods to create javax.xml.soap.Detail objects as well as java.xml.soap.Name objects.

Constructor Summary
SOAPFactory()
Method Summary
abstract Detail | createDetail() Creates a new Detail object which serves as a container for DetailEntry objects.
abstract SOAPElement | createElement(Name name) Create a SOAPElement object initialized with the given Name object.
abstract SOAPElement | createElement(String localName) Create a SOAPElement object initialized with the given local name.
abstract SOAPElement | createElement(String localName, String prefix, String uri) Create a new SOAPElement object with the given local name, prefix and uri.
abstract Name | createName(String localName) Creates a new Name object initialized with the given local name.
abstract Name | createName(String localName, String prefix, String uri) Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
static SOAPFactory | newInstance() Creates a new instance of SOAPFactory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SOAPFactory

public SOAPFactory()
Method Detail

createElement

public abstract SOAPElement createElement(Name name)
                                   throws SOAPException
Create a SOAPElement object initialized with the given Name object.

Parameters:
name - a Name object with the XML name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object

createElement

public abstract SOAPElement createElement(String localName)
                                   throws SOAPException
Create a SOAPElement object initialized with the given local name.

Parameters:
localName - a String giving the local name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object

createElement

public abstract SOAPElement createElement(String localName,
                                          String prefix,
                                          String uri)
                                   throws SOAPException
Create a new SOAPElement object with the given local name, prefix and uri.

Parameters:
localName - a String giving the local name for the new element
prefix - the prefix for this SOAPElement
uri - a String giving the URI of the namespace to which the new element belongs
Throws:
SOAPException - if there is an error in creating the SOAPElement object

createDetail

public abstract Detail createDetail()
                             throws SOAPException
Creates a new Detail object which serves as a container for DetailEntry objects.

This factory method creates Detail objects for use in situations where it is not practical to use the SOAPFault abstraction.

Returns:
a Detail object
Throws:
SOAPException - if there is a SOAP error

createName

public abstract Name createName(String localName,
                                String prefix,
                                String uri)
                         throws SOAPException
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

This factory method creates Name objects for use in situations where it is not practical to use the SOAPEnvelope abstraction.

Parameters:
localName - a String giving the local name
prefix - a String giving the prefix of the namespace
uri - a String giving the URI of the namespace
Returns:
a Name object initialized with the given local name, namespace prefix, and namespace URI
Throws:
SOAPException - if there is a SOAP error

createName

public abstract Name createName(String localName)
                         throws SOAPException
Creates a new Name object initialized with the given local name.

This factory method creates Name objects for use in situations where it is not practical to use the SOAPEnvelope abstraction.

Parameters:
localName - a String giving the local name
Returns:
a Name object initialized with the given local name
Throws:
SOAPException - if there is a SOAP error

newInstance

public static SOAPFactory newInstance()
                               throws SOAPException
Creates a new instance of SOAPFactory.

Returns:
a new instance of a SOAPFactory
Throws:
SOAPException - if there was an error creating the default SOAPFactory
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPFault

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPFault

All Superinterfaces:
Element, Node, Node, SOAPBodyElement, SOAPElement
public interface SOAPFault
extends SOAPBodyElement

An element in the SOAPBody object that contains error and/or status information. This information may relate to errors in the SOAPMessage object or to problems that are not related to the content in the message itself. Problems not related to the message itself are generally errors in processing, such as the inability to communicate with an upstream server.

The SOAPFault interface provides methods for retrieving the information contained in a SOAPFault object and for setting the fault code, the fault actor, and a string describing the fault. A fault code is one of the codes defined in the SOAP 1.1 specification that describe the fault. An actor is an intermediate recipient to whom a message was routed. The message path may include one or more actors, or, if no actors are specified, the message goes only to the default actor, which is the final intended recipient.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Detail | addDetail() Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
Detail | getDetail() Returns the optional detail element for this SOAPFault object.
String | getFaultActor() Gets the fault actor for this SOAPFault object.
String | getFaultCode() Gets the fault code for this SOAPFault object.
Name | getFaultCodeAsName() Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.
String | getFaultString() Gets the fault string for this SOAPFault object.
Locale | getFaultStringLocale() Gets the locale of the fault string for this SOAPFault object.
void | setFaultActor(String faultActor) Sets this SOAPFault object with the given fault actor.
void | setFaultCode(Name faultCodeQName) Sets this SOAPFault object with the given fault code.
void | setFaultCode(String faultCode) Sets this SOAPFault object with the give fault code.
void | setFaultString(String faultString) Sets the fault string for this SOAPFault object to the given string.
void | setFaultString(String faultString, Locale locale) Sets the fault string for this SOAPFault object to the given string and localized to the given locale.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, getAllAttributes, getAttributeValue, getChildElements, getChildElements, getElementName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeContents, removeNamespaceDeclaration, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS

Method Detail

setFaultCode

public void setFaultCode(Name faultCodeQName)
                  throws SOAPException
Sets this SOAPFault object with the given fault code.

Fault codes, which give information about the fault, are defined in the SOAP 1.1 specification. A fault code is mandatory and must be of type QName. This method provides a convenient way to set a fault code. For example,

 SOAPEnvelope se = ...;
 // Create a qualified name in the SOAP namespace with a localName
 // of "Client".  Note that prefix parameter is optional and is null
 // here which causes the implementation to use an appropriate prefix.
 Name qname = se.createName("Client", null,
                            SOAPConstants.URI_NS_SOAP_ENVELOPE);
 SOAPFault fault = ...;
 fault.setFaultCode(qname);
It is preferable to use this method over setFaultCode(String).

Parameters:
faultCodeQName - a Name object giving the fault code to be set. It must be namespace qualified.
Throws:
SOAPException - if there was an error in adding the faultcode element to the underlying XML tree.
Since:
SAAJ 1.2
See Also:
getFaultCodeAsName()

setFaultCode

public void setFaultCode(String faultCode)
                  throws SOAPException
Sets this SOAPFault object with the give fault code.

Fault codes, which given information about the fault, are defined in the SOAP 1.1 specification. This element is mandatory in SOAP 1.1. Because the fault code is required to be a QName it is preferable to use the setFaultCode(Name) form of this method.

Parameters:
faultCode - a String giving the fault code to be set. It must be of the form "prefix:localName" where the prefix has been defined in a namespace declaration.
Throws:
SOAPException - if there was an error in adding the faultCode to the underlying XML tree.
See Also:
setFaultCode(Name), getFaultCode(), SOAPElement.addNamespaceDeclaration(java.lang.String, java.lang.String)

getFaultCodeAsName

public Name getFaultCodeAsName()
Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object. The SOAP 1.1 specification requires the value of the "faultcode" element to be of type QName. This method returns the content of the element as a QName in the form of a SAAJ Name object. This method should be used instead of the getFaultCode method since it allows applications to easily access the namespace name without additional parsing.

In the future, a QName object version of this method may also be added.

Returns:
a Name representing the faultcode
Since:
SAAJ 1.2
See Also:
setFaultCode(Name)

getFaultCode

public String getFaultCode()
Gets the fault code for this SOAPFault object.

Returns:
a String with the fault code
See Also:
getFaultCodeAsName(), setFaultCode(javax.xml.soap.Name)

setFaultActor

public void setFaultActor(String faultActor)
                   throws SOAPException
Sets this SOAPFault object with the given fault actor.

The fault actor is the recipient in the message path who caused the fault to happen.

Parameters:
faultActor - a String identifying the actor that caused this SOAPFault object
Throws:
SOAPException - if there was an error in adding the faultActor to the underlying XML tree.
See Also:
getFaultActor()

getFaultActor

public String getFaultActor()
Gets the fault actor for this SOAPFault object.

Returns:
a String giving the actor in the message path that caused this SOAPFault object
See Also:
setFaultActor(java.lang.String)

setFaultString

public void setFaultString(String faultString)
                    throws SOAPException
Sets the fault string for this SOAPFault object to the given string.

Parameters:
faultString - a String giving an explanation of the fault
Throws:
SOAPException - if there was an error in adding the faultString to the underlying XML tree.
See Also:
getFaultString()

setFaultString

public void setFaultString(String faultString,
                           Locale locale)
                    throws SOAPException
Sets the fault string for this SOAPFault object to the given string and localized to the given locale.

Parameters:
faultString - a String giving an explanation of the fault
locale - a Locale object indicating the native language of the faultString
Throws:
SOAPException - if there was an error in adding the faultString to the underlying XML tree.
Since:
SAAJ 1.2
See Also:
getFaultString()

getFaultString

public String getFaultString()
Gets the fault string for this SOAPFault object.

Returns:
a String giving an explanation of the fault
See Also:
setFaultString(String), setFaultString(String, Locale)

getFaultStringLocale

public Locale getFaultStringLocale()
Gets the locale of the fault string for this SOAPFault object.

Returns:
a Locale object indicating the native language of the fault string or null if no locale was specified
Since:
SAAJ 1.2
See Also:
setFaultString(String, Locale)

getDetail

public Detail getDetail()
Returns the optional detail element for this SOAPFault object.

A Detail object carries application-specific error information related to SOAPBodyElement objects.

Returns:
a Detail object with application-specific error information

addDetail

public Detail addDetail()
                 throws SOAPException
Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.

It is illegal to add a detail when the fault already contains a detail. Therefore, this method should be called only after the existing detail has been removed.

Returns:
the new Detail object
Throws:
SOAPException - if this SOAPFault object already contains a valid Detail object
SOAPException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPHeader

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPHeader

All Superinterfaces:
Element, Node, Node, SOAPElement
public interface SOAPHeader
extends SOAPElement

A representation of the SOAP header element. A SOAP header element consists of XML data that affects the way the application-specific content is processed by the message provider. For example, transaction semantics, authentication information, and so on, can be specified as the content of a SOAPHeader object.

A SOAPEnvelope object contains an empty SOAPHeader object by default. If the SOAPHeader object, which is optional, is not needed, it can be retrieved and deleted with the following line of code. The variable se is a SOAPEnvelope object.

      se.getHeader().detachNode();
A SOAPHeader object is created with the SOAPEnvelope method addHeader. This method, which creates a new header and adds it to the envelope, may be called only after the existing header has been removed.
      se.getHeader().detachNode();
      SOAPHeader sh = se.addHeader();

A SOAPHeader object can have only SOAPHeaderElement objects as its immediate children. The method addHeaderElement creates a new HeaderElement object and adds it to the SOAPHeader object. In the following line of code, the argument to the method addHeaderElement is a Name object that is the name for the new HeaderElement object.

      SOAPHeaderElement shElement = sh.addHeaderElement(name);

See Also:
SOAPHeaderElement

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
SOAPHeaderElement | addHeaderElement(Name name) Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
Iterator | examineAllHeaderElements() Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
Iterator | examineHeaderElements(String actor) Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor.
Iterator | examineMustUnderstandHeaderElements(String actor) Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.
Iterator | extractAllHeaderElements() Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
Iterator | extractHeaderElements(String actor) Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, getAllAttributes, getAttributeValue, getChildElements, getChildElements, getElementName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeContents, removeNamespaceDeclaration, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS

Method Detail

addHeaderElement

public SOAPHeaderElement addHeaderElement(Name name)
                                   throws SOAPException
Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.

Parameters:
name - a Name object with the name of the new SOAPHeaderElement object
Returns:
the new SOAPHeaderElement object that was inserted into this SOAPHeader object
Throws:
SOAPException - if a SOAP error occurs

examineMustUnderstandHeaderElements

public Iterator examineMustUnderstandHeaderElements(String actor)
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.

Parameters:
actor - a String giving the URI of the actor for which to search
Returns:
an Iterator object over all the SOAPHeaderElement objects that contain the specified actor and are marked as MustUnderstand
Since:
SAAJ 1.2
See Also:
examineHeaderElements(java.lang.String), extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

examineHeaderElements

public Iterator examineHeaderElements(String actor)
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor. An actor is a global attribute that indicates the intermediate parties that should process a message before it reaches its ultimate receiver. An actor receives the message and processes it before sending it on to the next actor. The default actor is the ultimate intended recipient for the message, so if no actor attribute is included in a SOAPHeader object, it is sent to the ultimate receiver along with the message body.

Parameters:
actor - a String giving the URI of the actor for which to search
Returns:
an Iterator object over all the SOAPHeaderElement objects that contain the specified actor
See Also:
extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

extractHeaderElements

public Iterator extractHeaderElements(String actor)
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.

This method allows an actor to process the parts of the SOAPHeader object that apply to it and to remove them before passing the message on to the next actor.

Parameters:
actor - a String giving the URI of the actor for which to search
Returns:
an Iterator object over all the SOAPHeaderElement objects that contain the specified actor
See Also:
examineHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

examineAllHeaderElements

public Iterator examineAllHeaderElements()
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.

Returns:
an Iterator object over all the SOAPHeaderElement objects contained by this SOAPHeader
Since:
SAAJ 1.2
See Also:
extractAllHeaderElements()

extractAllHeaderElements

public Iterator extractAllHeaderElements()
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.

Returns:
an Iterator object over all the SOAPHeaderElement objects contained by this SOAPHeader
Since:
SAAJ 1.2
See Also:
examineAllHeaderElements()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPHeaderElement

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPHeaderElement

All Superinterfaces:
Element, Node, Node, SOAPElement
public interface SOAPHeaderElement
extends SOAPElement

An object representing the contents in the SOAP header part of the SOAP envelope. The immediate children of a SOAPHeader object can be represented only as SOAPHeaderElement objects.

A SOAPHeaderElement object can have other SOAPElement objects as its children.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
String | getActor() Returns the uri of the actor associated with this SOAPHeaderElement object.
boolean | getMustUnderstand() Returns whether the mustUnderstand attribute for this SOAPHeaderElement object is turned on.
void | setActor(String actorURI) Sets the actor associated with this SOAPHeaderElement object to the specified actor.
void | setMustUnderstand(boolean mustUnderstand) Sets the mustUnderstand attribute for this SOAPHeaderElement object to be on or off.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, getAllAttributes, getAttributeValue, getChildElements, getChildElements, getElementName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeContents, removeNamespaceDeclaration, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS

Method Detail

setActor

public void setActor(String actorURI)
Sets the actor associated with this SOAPHeaderElement object to the specified actor. The default value of an actor is: SOAPConstants.URI_SOAP_ACTOR_NEXT

Parameters:
actorURI - a String giving the URI of the actor to set
Throws:
IllegalArgumentException - if there is a problem in setting the actor.
See Also:
getActor()

getActor

public String getActor()
Returns the uri of the actor associated with this SOAPHeaderElement object.

Returns:
a String giving the URI of the actor
See Also:
setActor(java.lang.String)

setMustUnderstand

public void setMustUnderstand(boolean mustUnderstand)
Sets the mustUnderstand attribute for this SOAPHeaderElement object to be on or off.

If the mustUnderstand attribute is on, the actor who receives the SOAPHeaderElement must process it correctly. This ensures, for example, that if the SOAPHeaderElement object modifies the message, that the message is being modified correctly.

Parameters:
mustUnderstand - true to set the mustUnderstand attribute on; false to turn if off
Throws:
IllegalArgumentException - if there is a problem in setting the mustunderstand attribute
See Also:
getMustUnderstand()

getMustUnderstand

public boolean getMustUnderstand()
Returns whether the mustUnderstand attribute for this SOAPHeaderElement object is turned on.

Returns:
true if the mustUnderstand attribute of this SOAPHeaderElement object is turned on; false otherwise
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPMessage

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPMessage

java.lang.Object
    extended by javax.xml.soap.SOAPMessage
public abstract class SOAPMessage
extends Object

The root class for all SOAP messages. As transmitted on the "wire", a SOAP message is an XML document or a MIME message whose first body part is an XML/SOAP document.

A SOAPMessage object consists of a SOAP part and optionally one or more attachment parts. The SOAP part for a SOAPMessage object is a SOAPPart object, which contains information used for message routing and identification, and which can contain application-specific content. All data in the SOAP Part of a message must be in XML format.

A new SOAPMessage object contains the following by default:

  • A SOAPPart object
  • A SOAPEnvelope object
  • A SOAPBody object
  • A SOAPHeader object
The SOAP part of a message can be retrieved by calling the method SOAPMessage.getSOAPPart(). The SOAPEnvelope object is retrieved from the SOAPPart object, and the SOAPEnvelope object is used to retrieve the SOAPBody and SOAPHeader objects.
     SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     SOAPBody sb = se.getBody();
     SOAPHeader sh = se.getHeader();

In addition to the mandatory SOAPPart object, a SOAPMessage object may contain zero or more AttachmentPart objects, each of which contains application-specific data. The SOAPMessage interface provides methods for creating AttachmentPart objects and also for adding them to a SOAPMessage object. A party that has received a SOAPMessage object can examine its contents by retrieving individual attachment parts.

Unlike the rest of a SOAP message, an attachment is not required to be in XML format and can therefore be anything from simple text to an image file. Consequently, any message content that is not in XML format must be in an AttachmentPart object.

A MessageFactory object may create SOAPMessage objects with behavior that is specialized to a particular implementation or application of SAAJ. For instance, a MessageFactory object may produce SOAPMessage objects that conform to a particular Profile such as ebXML. In this case a MessageFactory object might produce SOAPMessage objects that are initialized with ebXML headers.

In order to ensure backward source compatibility, methods that are added to this class after version 1.1 of the SAAJ specification are all concrete instead of abstract and they all have default implementations. Unless otherwise noted in the JavaDocs for those methods the default implementations simply throw an UnsupportedOperationException and the SAAJ implementation code must override them with methods that provide the specified behavior. Legacy client code does not have this restriction, however, so long as there is no claim made that it conforms to some later version of the specification than it was originally written for. A legacy class that extends the SOAPMessage class can be compiled and/or run against succeeding versions of the SAAJ API without modification. If such a class was correctly implemented then it will continue to behave correctly relative the the version of the specification against which it was written.

See Also:
MessageFactory, AttachmentPart

Field Summary
static String | CHARACTER_SET_ENCODING Specifies the character type encoding for the SOAP Message.
static String | WRITE_XML_DECLARATION Specifies whether the SOAP Message will contain an XML declaration when it is sent.
Constructor Summary
SOAPMessage()
Method Summary
abstract void | addAttachmentPart(AttachmentPart AttachmentPart) Adds the given AttachmentPart object to this SOAPMessage object.
abstract int | countAttachments() Gets a count of the number of attachments in this message.
abstract AttachmentPart | createAttachmentPart() Creates a new empty AttachmentPart object.
AttachmentPart | createAttachmentPart(DataHandler dataHandler) Creates an AttachmentPart object and populates it using the given DataHandler object.
AttachmentPart | createAttachmentPart(Object content, String contentType) Creates an AttachmentPart object and populates it with the specified data of the specified content type.
abstract Iterator | getAttachments() Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.
abstract Iterator | getAttachments(MimeHeaders headers) Retrieves all the AttachmentPart objects that have header entries that match the specified headers.
abstract String | getContentDescription() Retrieves a description of this SOAPMessage object's content.
abstract MimeHeaders | getMimeHeaders() Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
Object | getProperty(String property) Retrieves value of the specified property.
SOAPBody | getSOAPBody() Gets the SOAP Body contained in this SOAPMessage object.
SOAPHeader | getSOAPHeader() Gets the SOAP Header contained in this SOAPMessage object.
abstract SOAPPart | getSOAPPart() Gets the SOAP part of this SOAPMessage object.
abstract void | removeAllAttachments() Removes all AttachmentPart objects that have been added to this SOAPMessage object.
abstract void | saveChanges() Updates this SOAPMessage object with all the changes that have been made to it.
abstract boolean | saveRequired() Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.
abstract void | setContentDescription(String description) Sets the description of this SOAPMessage object's content with the given description.
void | setProperty(String property, Object value) Associates the specified value with the specified property.
abstract void | writeTo(OutputStream out) Writes this SOAPMessage object to the given output stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CHARACTER_SET_ENCODING

public static final String CHARACTER_SET_ENCODING
Specifies the character type encoding for the SOAP Message. Valid values include "utf-8" and "utf-16". See vendor documentation for additional supported values. The default is "utf-8".

Since:
SAAJ 1.2
See Also:
SOAPMessage.setProperty, Constant Field Values

WRITE_XML_DECLARATION

public static final String WRITE_XML_DECLARATION
Specifies whether the SOAP Message will contain an XML declaration when it is sent. The only valid values are "true" and "false". The default is "false".

Since:
SAAJ 1.2
See Also:
SOAPMessage.setProperty, Constant Field Values
Constructor Detail

SOAPMessage

public SOAPMessage()
Method Detail

setContentDescription

public abstract void setContentDescription(String description)
Sets the description of this SOAPMessage object's content with the given description.

Parameters:
description - a String describing the content of this message
See Also:
getContentDescription()

getContentDescription

public abstract String getContentDescription()
Retrieves a description of this SOAPMessage object's content.

Returns:
a String describing the content of this message or null if no description has been set
See Also:
setContentDescription(java.lang.String)

getSOAPPart

public abstract SOAPPart getSOAPPart()
Gets the SOAP part of this SOAPMessage object.

SOAPMessage object contains one or more attachments, the SOAP Part must be the first MIME body part in the message.

Returns:
the SOAPPart object for this SOAPMessage object

getSOAPBody

public SOAPBody getSOAPBody()
                     throws SOAPException
Gets the SOAP Body contained in this SOAPMessage object.

Returns:
the SOAPBody object contained by this SOAPMessage object
Throws:
SOAPException - if the SOAP Body does not exist or cannot be retrieved
Since:
SAAJ 1.2

getSOAPHeader

public SOAPHeader getSOAPHeader()
                         throws SOAPException
Gets the SOAP Header contained in this SOAPMessage object.

Returns:
the SOAPHeader object contained by this SOAPMessage object
Throws:
SOAPException - if the SOAP Header does not exist or cannot be retrieved
Since:
SAAJ 1.2

removeAllAttachments

public abstract void removeAllAttachments()
Removes all AttachmentPart objects that have been added to this SOAPMessage object.

This method does not touch the SOAP part.

countAttachments

public abstract int countAttachments()
Gets a count of the number of attachments in this message. This count does not include the SOAP part.

Returns:
the number of AttachmentPart objects that are part of this SOAPMessage object

getAttachments

public abstract Iterator getAttachments()
Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.

Returns:
an iterator over all the attachments in this message

getAttachments

public abstract Iterator getAttachments(MimeHeaders headers)
Retrieves all the AttachmentPart objects that have header entries that match the specified headers. Note that a returned attachment could have headers in addition to those specified.

Parameters:
headers - a MimeHeaders object containing the MIME headers for which to search
Returns:
an iterator over all attachments that have a header that matches one of the given headers

addAttachmentPart

public abstract void addAttachmentPart(AttachmentPart AttachmentPart)
Adds the given AttachmentPart object to this SOAPMessage object. An AttachmentPart object must be created before it can be added to a message.

Parameters:
AttachmentPart - an AttachmentPart object that is to become part of this SOAPMessage object
Throws:
IllegalArgumentException

createAttachmentPart

public abstract AttachmentPart createAttachmentPart()
Creates a new empty AttachmentPart object. Note that the method addAttachmentPart must be called with this new AttachmentPart object as the parameter in order for it to become an attachment to this SOAPMessage object.

Returns:
a new AttachmentPart object that can be populated and added to this SOAPMessage object

createAttachmentPart

public AttachmentPart createAttachmentPart(DataHandler dataHandler)
Creates an AttachmentPart object and populates it using the given DataHandler object.

Parameters:
dataHandler - the javax.activation.DataHandler object that will generate the content for this SOAPMessage object
Returns:
a new AttachmentPart object that contains data generated by the given DataHandler object
Throws:
IllegalArgumentException - if there was a problem with the specified DataHandler object
See Also:
DataHandler, DataContentHandler

getMimeHeaders

public abstract MimeHeaders getMimeHeaders()
Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.

Returns:
a MimeHeaders object containing the MimeHeader objects

createAttachmentPart

public AttachmentPart createAttachmentPart(Object content,
                                           String contentType)
Creates an AttachmentPart object and populates it with the specified data of the specified content type.

Parameters:
content - an Object containing the content for this SOAPMessage object
contentType - a String object giving the type of content; examples are "text/xml", "text/plain", and "image/jpeg"
Returns:
a new AttachmentPart object that contains the given data
Throws:
IllegalArgumentException - if the contentType does not match the type of the content object, or if there was no DataContentHandler object for the given content object
See Also:
DataHandler, DataContentHandler

saveChanges

public abstract void saveChanges()
                          throws SOAPException
Updates this SOAPMessage object with all the changes that have been made to it. This method is called automatically when writeTo(OutputStream) is called. However, if changes are made to a message that was received or to one that has already been sent, the method saveChanges needs to be called explicitly in order to save the changes. The method saveChanges also generates any changes that can be read back (for example, a MessageId in profiles that support a message id). All MIME headers in a message that is created for sending purposes are guaranteed to have valid values only after saveChanges has been called.

In addition, this method marks the point at which the data from all constituent AttachmentPart objects are pulled into the message.

Throws:
SOAPException - if there was a problem saving changes to this message.
SOAPException

saveRequired

public abstract boolean saveRequired()
Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.

Returns:
true if saveChanges needs to be called; false otherwise.

writeTo

public abstract void writeTo(OutputStream out)
                      throws SOAPException,
                             IOException
Writes this SOAPMessage object to the given output stream. The externalization format is as defined by the SOAP 1.1 with Attachments specification.

If there are no attachments, just an XML stream is written out. For those messages that have attachments, writeTo writes a MIME-encoded byte stream.

Parameters:
out - the OutputStream object to which this SOAPMessage object will be written
Throws:
IOException - if an I/O error occurs
SOAPException - if there was a problem in externalizing this SOAP message

setProperty

public void setProperty(String property,
                        Object value)
                 throws SOAPException
Associates the specified value with the specified property. If there was already a value associated with this property, the old value is replaced.

The valid property names include WRITE_XML_DECLARATION and CHARACTER_SET_ENCODING. All of these standard SAAJ properties are prefixed by "javax.xml.soap". Vendors may also add implementation specific properties. These properties must be prefixed with package names that are unique to the vendor.

Setting the property WRITE_XML_DECLARATION to "true" will cause an XML Declaration to be written out at the start of the SOAP message. The default value of "false" suppresses this declaration.

The property CHARACTER_SET_ENCODING defaults to the value "utf-8" which causes the SOAP message to be encoded using UTF-8. Setting CHARACTER_SET_ENCODING to "utf-16" causes the SOAP message to be encoded using UTF-16.

Some implementations may allow encodings in addition to UTF-8 and UTF-16. Refer to your vendor's documentation for details.

Parameters:
property - the property with which the specified value is to be associated.
value - the value to be associated with the specified property
Throws:
SOAPException - if the property name is not recognized.
Since:
SAAJ 1.2

getProperty

public Object getProperty(String property)
                   throws SOAPException
Retrieves value of the specified property.

Parameters:
property - the name of the property to retrieve
Returns:
the value associated with the named property or null if no such property exists.
Throws:
SOAPException - if the property name is not recognized.
Since:
SAAJ 1.2
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SOAPPart

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPPart

java.lang.Object
    extended by javax.xml.soap.SOAPPart
All Implemented Interfaces:
Document, Node
public abstract class SOAPPart
extends Object
implements Document

The container for the SOAP-specific portion of a SOAPMessage object. All messages are required to have a SOAP part, so when a SOAPMessage object is created, it will automatically have a SOAPPart object.

A SOAPPart object is a MIME part and has the MIME headers Content-Id, Content-Location, and Content-Type. Because the value of Content-Type must be "text/xml", a SOAPPart object automatically has a MIME header of Content-Type with its value set to "text/xml". The value must be "text/xml" because content in the SOAP part of a message must be in XML format. Content that is not of type "text/xml" must be in an AttachmentPart object rather than in the SOAPPart object.

When a message is sent, its SOAP part must have the MIME header Content-Type set to "text/xml". Or, from the other perspective, the SOAP part of any message that is received must have the MIME header Content-Type with a value of "text/xml".

A client can access the SOAPPart object of a SOAPMessage object by calling the method SOAPMessage.getSOAPPart. The following line of code, in which message is a SOAPMessage object, retrieves the SOAP part of a message.

   SOAPPart soapPart = message.getSOAPPart();

A SOAPPart object contains a SOAPEnvelope object, which in turn contains a SOAPBody object and a SOAPHeader object. The SOAPPart method getEnvelope can be used to retrieve the SOAPEnvelope object.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
SOAPPart()
Method Summary
abstract void | addMimeHeader(String name, String value) Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object.
abstract Iterator | getAllMimeHeaders() Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.
abstract Source | getContent() Returns the content of the SOAPEnvelope as a JAXP Source object.
String | getContentId() Retrieves the value of the MIME header whose name is "Content-Id".
String | getContentLocation() Retrieves the value of the MIME header whose name is "Content-Location".
abstract SOAPEnvelope | getEnvelope() Gets the SOAPEnvelope object associated with this SOAPPart object.
abstract Iterator | getMatchingMimeHeaders(String[] names) Retrieves all MimeHeader objects that match a name in the given array.
abstract String[] | getMimeHeader(String name) Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.
abstract Iterator | getNonMatchingMimeHeaders(String[] names) Retrieves all MimeHeader objects whose name does not match a name in the given array.
abstract void | removeAllMimeHeaders() Removes all the MimeHeader objects for this SOAPEnvelope object.
abstract void | removeMimeHeader(String header) Removes all MIME headers that match the given name.
abstract void | setContent(Source source) Sets the content of the SOAPEnvelope object with the data from the given Source object.
void | setContentId(String contentId) Sets the value of the MIME header named "Content-Id" to the given String.
void | setContentLocation(String contentLocation) Sets the value of the MIME header "Content-Location" to the given String.
abstract void | setMimeHeader(String name, String value) Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.w3c.dom.Document
createAttribute, createAttributeNS, createCDATASection, createComment, createDocumentFragment, createElement, createElementNS, createEntityReference, createProcessingInstruction, createTextNode, getDoctype, getDocumentElement, getElementById, getElementsByTagName, getElementsByTagNameNS, getImplementation, importNode
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix

Constructor Detail

SOAPPart

public SOAPPart()
Method Detail

getEnvelope

public abstract SOAPEnvelope getEnvelope()
                                  throws SOAPException
Gets the SOAPEnvelope object associated with this SOAPPart object. Once the SOAP envelope is obtained, it can be used to get its contents.

Returns:
the SOAPEnvelope object for this SOAPPart object
Throws:
SOAPException - if there is a SOAP error

getContentId

public String getContentId()
Retrieves the value of the MIME header whose name is "Content-Id".

Returns:
a String giving the value of the MIME header named "Content-Id"
See Also:
setContentId(java.lang.String)

getContentLocation

public String getContentLocation()
Retrieves the value of the MIME header whose name is "Content-Location".

Returns:
a String giving the value of the MIME header whose name is "Content-Location"
See Also:
setContentLocation(java.lang.String)

setContentId

public void setContentId(String contentId)
Sets the value of the MIME header named "Content-Id" to the given String.

Parameters:
contentId - a String giving the value of the MIME header "Content-Id"
Throws:
IllegalArgumentException - if there is a problem in setting the content id
See Also:
getContentId()

setContentLocation

public void setContentLocation(String contentLocation)
Sets the value of the MIME header "Content-Location" to the given String.

Parameters:
contentLocation - a String giving the value of the MIME header "Content-Location"
Throws:
IllegalArgumentException - if there is a problem in setting the content location.
See Also:
getContentLocation()

removeMimeHeader

public abstract void removeMimeHeader(String header)
Removes all MIME headers that match the given name.

Parameters:
header - a String giving the name of the MIME header(s) to be removed

removeAllMimeHeaders

public abstract void removeAllMimeHeaders()
Removes all the MimeHeader objects for this SOAPEnvelope object.

getMimeHeader

public abstract String[] getMimeHeader(String name)
Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.

Parameters:
name - the name of the header; example: "Content-Type"
Returns:
a String array giving all the values for the specified header
See Also:
setMimeHeader(java.lang.String, java.lang.String)

setMimeHeader

public abstract void setMimeHeader(String name,
                                   String value)
Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match. If there is a match, this method clears all existing values for the first header that matches and sets the given value instead. If more than one header has the given name, this method removes all of the matching headers after the first one.

Note that RFC822 headers can contain only US-ASCII characters.

Parameters:
name - a String giving the header name for which to search
value - a String giving the value to be set. This value will be substituted for the current value(s) of the first header that is a match if there is one. If there is no match, this value will be the value for a new MimeHeader object.
Throws:
IllegalArgumentException - if there was a problem with the specified mime header name or value
See Also:
getMimeHeader(java.lang.String)

addMimeHeader

public abstract void addMimeHeader(String name,
                                   String value)
Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object. If a MimeHeader with the specified name already exists, this method adds the specified value to the already existing value(s).

Note that RFC822 headers can contain only US-ASCII characters.

Parameters:
name - a String giving the header name
value - a String giving the value to be set or added
Throws:
IllegalArgumentException - if there was a problem with the specified mime header name or value

getAllMimeHeaders

public abstract Iterator getAllMimeHeaders()
Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.

Returns:
an Iterator object with all of the Mime headers for this SOAPPart object

getMatchingMimeHeaders

public abstract Iterator getMatchingMimeHeaders(String[] names)
Retrieves all MimeHeader objects that match a name in the given array.

Parameters:
names - a String array with the name(s) of the MIME headers to be returned
Returns:
all of the MIME headers that match one of the names in the given array, returned as an Iterator object

getNonMatchingMimeHeaders

public abstract Iterator getNonMatchingMimeHeaders(String[] names)
Retrieves all MimeHeader objects whose name does not match a name in the given array.

Parameters:
names - a String array with the name(s) of the MIME headers not to be returned
Returns:
all of the MIME headers in this SOAPPart object except those that match one of the names in the given array. The nonmatching MIME headers are returned as an Iterator object.

setContent

public abstract void setContent(Source source)
                         throws SOAPException
Sets the content of the SOAPEnvelope object with the data from the given Source object. This Source must contain a valid SOAP document.

Parameters:
source - the javax.xml.transform.Source object with the data to be set
Throws:
SOAPException - if there is a problem in setting the source
See Also:
getContent()

getContent

public abstract Source getContent()
                           throws SOAPException
Returns the content of the SOAPEnvelope as a JAXP Source object.

Returns:
the content as a javax.xml.transform.Source object
Throws:
SOAPException - if the implementation cannot convert the specified Source object
See Also:
setContent(javax.xml.transform.Source)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Text

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface Text

All Superinterfaces:
CharacterData, Node, Node, Text
public interface Text
extends Node, Text

A representation of a node whose value is text. A Text object may represent text that is content or text that is a comment.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
 boolean isComment()
Retrieves whether this Text object represents a comment.
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, getAttributes, getChildNodes, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, hasAttributes, hasChildNodes, insertBefore, isSupported, normalize, removeChild, replaceChild, setNodeValue, setPrefix
Methods inherited from interface org.w3c.dom.Text
splitText
Methods inherited from interface org.w3c.dom.CharacterData
appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

Method Detail

isComment

public boolean isComment()
Retrieves whether this Text object represents a comment.

Returns:
true if this Text object is a comment; false otherwise
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


transform

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.transform

This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.

See:
Description

Interface Summary
ErrorListener | To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer.
Result | An object that implements this interface contains the information needed to build a transformation result tree.
Source | An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).
SourceLocator | This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.
Templates | An object that implements this interface is the runtime representation of processed transformation instructions.
URIResolver | An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.

Class Summary
OutputKeys | Provides string constants that can be used to set output properties for a Transformer, or to retrieve output properties from a Transformer or Templates object.
Transformer | An instance of this abstract class can transform a source tree into a result tree.
TransformerFactory | A TransformerFactory instance can be used to create Transformer and Templates objects.

Exception Summary
TransformerConfigurationException | Indicates a serious configuration error.
TransformerException | This class specifies an exceptional condition that occured during the transformation process.

Error Summary
TransformerFactoryConfigurationError Thrown when a problem with configuration with the Transformer Factories exists.

Package javax.xml.transform Description

This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result. These interfaces have no dependencies on SAX or the DOM standard, and try to make as few assumptions as possible about the details of the source and result of a transformation. It achieves this by defining Source and Result interfaces.

To define concrete classes for the user, the API defines specializations of the interfaces found at the root level. These interfaces are found in javax.xml.transform.sax, javax.xml.transform.dom, and javax.xml.transform.stream.

Creating Objects

The API allows a concrete TransformerFactory object to be created from the static function TransformerFactory.newInstance().

Specification of Inputs and Outputs

This API defines two interface objects called Source and Result. In order to pass Source and Result objects to the interfaces, concrete classes must be used. Three concrete representations are defined for each of these objects: StreamSource and StreamResult, SAXSource and SAXResult, and DOMSource and DOMResult. Each of these objects defines a FEATURE string (which is i the form of a URL), which can be passed into TransformerFactory.getFeature(java.lang.String) to see if the given type of Source or Result object is supported. For instance, to test if a DOMSource and a StreamResult is supported, you can apply the following test.

    TransformerFactory tfactory = TransformerFactory.newInstance();

    if (tfactory.getFeature(DOMSource.FEATURE) && tfactory.getFeature(StreamResult.FEATURE))
    {
       ...
    }

Qualified Name Representation

Namespaces present something of a problem area when dealing with XML objects. Qualified Names appear in XML markup as prefixed names. But the prefixes themselves do not hold identity. Rather, it is the URIs that they contextually map to that hold the identity. Therefore, when passing a Qualified Name like "xyz:foo" among Java programs, one must provide a means to map "xyz" to a namespace.

One solution has been to create a "QName" object that holds the namespace URI, as well as the prefix and local name, but this is not always an optimal solution, as when, for example, you want to use unique strings as keys in a dictionary object. Not having a string representation also makes it difficult to specify a namespaced identity outside the context of an XML document.

In order to pass namespaced values to transformations, for instance as a set of properties to the Serializer, this specification defines that a String "qname" object parameter be passed as two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the qname has a null URI, then the String object only contains the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the Qualified Name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that the prefix is lost.

Result Tree Serialization

Serialization of the result tree to a stream can be controlled with the Transformer.setOutputProperties(java.util.Properties) and the Transformer.setOutputProperty(java.lang.String, java.lang.String) methods. Strings that match the XSLT specification for xsl:output attributes can be referenced from the OutputKeys class. Other strings can be specified as well. If the transformer does not recognize an output key, a IllegalArgumentException is thrown, unless the key name is namespace qualified. Output key names that are qualified by a namespace are ignored or passed on to the serializer mechanism.

If all that is desired is the simple identity transformation of a source to a result, then TransformerFactory provides a TransformerFactory.newTransformer() method with no arguments. This method creates a Transformer that effectively copies the source to the result. This method may be used to create a DOM from SAX events or to create an XML or HTML stream from a DOM or SAX events.

Exceptions and Error Reporting

The transformation API throw three types of specialized exceptions. A TransformerFactoryConfigurationError is parallel to the FactoryConfigurationError, and is thrown when a configuration problem with the TransformerFactory exists. This error will typically be thrown when the transformation factory class specified with the "javax.xml.transform.TransformerFactory" system property cannot be found or instantiated.

A TransformerConfigurationException may be thrown if for any reason a Transformer can not be created. A TransformerConfigurationException may be thrown if there is a syntax error in the transformation instructions, for example when TransformerFactory.newTransformer(javax.xml.transform.Source) is called.

TransformerException is a general exception that occurs during the course of a transformation. A transformer exception may wrap another exception, and if any of the TransformerException.printStackTrace() methods are called on it, it will produce a list of stack dumps, starting from the most recent. The transformer exception also provides a SourceLocator object which indicates where in the source tree or transformation instructions the error occurred. TransformerException.getMessageAndLocation() may be called to get an error message with location info, and TransformerException.getLocationAsString() may be called to get just the location string.

Transformation warnings and errors are normally first sent to a ErrorListener, at which point the implementor may decide to report the error or warning, and may decide to throw an exception for a non-fatal error. The error listener may be set via TransformerFactory.setErrorListener(javax.xml.transform.ErrorListener) for reporting errors that have to do with syntax errors in the transformation instructions, or via Transformer.setErrorListener(javax.xml.transform.ErrorListener) to report errors that occur during the transformation. The error listener on both objects should always be valid and non-null, whether set by the user or a default implementation provided by the processor.

Resolution of URIs within a transformation

The API provides a way for URIs referenced from within the stylesheet instructions or within the transformation to be resolved by the calling application. This can be done by creating a class that implements the URIResolver interface, with its one method, URIResolver.resolve(java.lang.String, java.lang.String), and use this class to set the URI resolution for the transformation instructions or transformation with TransformerFactory.setURIResolver(javax.xml.transform.URIResolver) or Transformer.setURIResolver(javax.xml.transform.URIResolver). The URIResolver.resolve method takes two String arguments, the URI found in the stylesheet instructions or built as part of the transformation process, and the base URI in effect when the URI passed as the first argument was encountered. The returned Source object must be usable by the transformer, as specified in its implemented features.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.transform Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.transform

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.transform.OutputKeys
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Error
        • class javax.xml.transform.TransformerFactoryConfigurationError
      • class java.lang.Exception
        • class javax.xml.transform.TransformerException
          • class javax.xml.transform.TransformerConfigurationException
    • class javax.xml.transform.Transformer
    • class javax.xml.transform.TransformerFactory

Interface Hierarchy

  • interface javax.xml.transform.ErrorListener
  • interface javax.xml.transform.Result
  • interface javax.xml.transform.Source
  • interface javax.xml.transform.SourceLocator
  • interface javax.xml.transform.Templates
  • interface javax.xml.transform.URIResolver
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


dom

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.transform.dom

This package implements DOM-specific transformation APIs.

See:
Description

Interface Summary
DOMLocator Indicates the position of a node in a source DOM, intended primarily for error reporting.

Class Summary
DOMResult | Acts as a holder for a transformation result tree, in the form of a Document Object Model (DOM) tree.
DOMSource | Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.

Package javax.xml.transform.dom Description

This package implements DOM-specific transformation APIs.

The DOMSource class allows the client of the implementation of this API to specify a DOM Node as the source of the input tree. The model of how the Transformer deals with the DOM tree in terms of mismatches with the XSLT data model or other data models is beyond the scope of this document. Any of the nodes derived from Node are legal input.

The DOMResult class allows a Node to be specified to which result DOM nodes will be appended. If an output node is not specified, the transformer will use DocumentBuilder.newDocument() to create an output Document node. If a node is specified, it should be one of the following: Document, Element, or DocumentFragment. Specification of any other node type is implementation dependent and undefined by this API. If the result is a Document, the output of the transformation must have a single element root to set as the document element.

The DOMLocator node may be passed to TransformerException objects, and retrieved by trying to cast the result of the TransformerException.getLocator() method. The implementation has no responsibility to use a DOMLocator instead of a SourceLocator (though line numbers and the like do not make much sense for a DOM), so the result of getLocator must always be tested with an instanceof.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.transform.dom Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.transform.dom

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
    • class javax.xml.transform.dom.DOMSource (implements javax.xml.transform.Source)

Interface Hierarchy

  • interface javax.xml.transform.SourceLocator
    • interface javax.xml.transform.dom.DOMLocator
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DOMLocator

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform.dom
Interface DOMLocator

All Superinterfaces:
SourceLocator
public interface DOMLocator
extends SourceLocator

Indicates the position of a node in a source DOM, intended primarily for error reporting. To use a DOMLocator, the receiver of an error must downcast the SourceLocator object returned by an exception. A Transformer may use this object for purposes other than error reporting, for instance, to indicate the source node that originated a result node.

Method Summary
 Node getOriginatingNode()
Return the node where the event occurred.
Methods inherited from interface javax.xml.transform.SourceLocator
getColumnNumber, getLineNumber, getPublicId, getSystemId

Method Detail

getOriginatingNode

public Node getOriginatingNode()
Return the node where the event occurred.

Returns:
The node that is the location for the event.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DOMResult

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform.dom
Class DOMResult

java.lang.Object
    extended by javax.xml.transform.dom.DOMResult
All Implemented Interfaces:
Result
public class DOMResult
extends Object
implements Result

Acts as a holder for a transformation result tree, in the form of a Document Object Model (DOM) tree. If no output DOM source is set, the transformation will create a Document node as the holder for the result of the transformation, which may be retrieved with getNode.

Field Summary
static String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
Fields inherited from interface javax.xml.transform.Result
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
Constructor Summary
DOMResult()
Zero-argument default constructor.
DOMResult(Node node)
Use a DOM node to create a new output target.
DOMResult(Node node, String systemID)
Create a new output target with a DOM node.
Method Summary
Node | getNode() Get the node that will contain the result DOM tree.
String | getSystemId() Get the system identifier that was set with setSystemId.
void | setNode(Node node) Set the node that will contain the result DOM tree.
void | setSystemId(String systemId) Method setSystemId Set the systemID that may be used in association with the node.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FEATURE

public static final String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

See Also:
Constant Field Values
Constructor Detail

DOMResult

public DOMResult()
Zero-argument default constructor.

DOMResult

public DOMResult(Node node)
Use a DOM node to create a new output target. In practice, the node should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

DOMResult

public DOMResult(Node node,
                 String systemID)
Create a new output target with a DOM node. In practice, the node should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

Parameters:
node - The DOM node that will contain the result tree.
systemID - The system identifier which may be used in association with this node.
Method Detail

setNode

public void setNode(Node node)
Set the node that will contain the result DOM tree. In practice, the node should be a Document node, a DocumentFragment node, or a Element node. In other words, a node that accepts children.

Parameters:
node - The node to which the transformation will be appended.

getNode

public Node getNode()
Get the node that will contain the result DOM tree. If no node was set via setNode, the node will be set by the transformation, and may be obtained from this method once the transformation is complete.

Returns:
The node to which the transformation will be appended.

setSystemId

public void setSystemId(String systemId)
Method setSystemId Set the systemID that may be used in association with the node.

Specified by:
setSystemId in interface Result
Parameters:
systemId - The system identifier as a URI string.

getSystemId

public String getSystemId()
Get the system identifier that was set with setSystemId.

Specified by:
getSystemId in interface Result
Returns:
The system identifier that was set with setSystemId, or null if setSystemId was not called.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


DOMSource

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform.dom
Class DOMSource

java.lang.Object
    extended by javax.xml.transform.dom.DOMSource
All Implemented Interfaces:
Source
public class DOMSource
extends Object
implements Source

Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.

See Also:
Document Object Model (DOM) Level 2 Specification

Field Summary
static String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
Constructor Summary
DOMSource()
Zero-argument default constructor.
DOMSource(Node n)
Create a new input source with a DOM node.
DOMSource(Node node, String systemID)
Create a new input source with a DOM node, and with the system ID also passed in as the base URI.
Method Summary
Node | getNode() Get the node that represents a Source DOM tree.
String | getSystemId() Get the base ID (URL or system ID) from where URLs will be resolved.
void | setNode(Node node) Set the node that will represents a Source DOM tree.
void | setSystemId(String baseID) Set the base ID (URL or system ID) from where URLs will be resolved.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FEATURE

public static final String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.

See Also:
Constant Field Values
Constructor Detail

DOMSource

public DOMSource()
Zero-argument default constructor. If this is used, and no DOM source is set, then the Transformer will create an empty source Document using DocumentBuilder.newDocument().

DOMSource

public DOMSource(Node n)
Create a new input source with a DOM node. The operation will be applied to the subtree rooted at this node. In XSLT, a "/" pattern still means the root of the tree (not the subtree), and the evaluation of global variables and parameters is done from the root node also.

Parameters:
n - The DOM node that will contain the Source tree.

DOMSource

public DOMSource(Node node,
                 String systemID)
Create a new input source with a DOM node, and with the system ID also passed in as the base URI.

Parameters:
node - The DOM node that will contain the Source tree.
systemID - Specifies the base URI associated with node.
Method Detail

setNode

public void setNode(Node node)
Set the node that will represents a Source DOM tree.

Parameters:
node - The node that is to be transformed.

getNode

public Node getNode()
Get the node that represents a Source DOM tree.

Returns:
The node that is to be transformed.

setSystemId

public void setSystemId(String baseID)
Set the base ID (URL or system ID) from where URLs will be resolved.

Specified by:
setSystemId in interface Source
Parameters:
baseID - Base URL for this DOM tree.

getSystemId

public String getSystemId()
Get the base ID (URL or system ID) from where URLs will be resolved.

Specified by:
getSystemId in interface Source
Returns:
Base URL for this DOM tree.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


ErrorListener

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Interface ErrorListener

public interface ErrorListener

To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer. The Transformer then reports all errors and warnings through this interface.

If an application does not register an ErrorListener, errors are reported to System.err.

For transformation errors, a Transformer must use this interface instead of throwing an exception: it is up to the application to decide whether to throw an exception for different types of errors and warnings. Note however that the Transformer is not required to continue with the transformation after a call to fatalError.

Transformers may use this mechanism to report XML parsing errors as well as transformation errors.

Method Summary
void | error(TransformerException exception) Receive notification of a recoverable error.
void | fatalError(TransformerException exception) Receive notification of a non-recoverable error.
void | warning(TransformerException exception) Receive notification of a warning.

Method Detail

warning

public void warning(TransformerException exception)
             throws TransformerException
Receive notification of a warning.

Transformer can use this method to report conditions that are not errors or fatal errors. The default behaviour is to take no action.

After invoking this method, the Transformer must continue with the transformation. It should still be possible for the application to process the document through to the end.

Parameters:
exception - The warning information encapsulated in a transformer exception.
Throws:
TransformerException - if the application chooses to discontinue the transformation.
See Also:
TransformerException

error

public void error(TransformerException exception)
           throws TransformerException
Receive notification of a recoverable error.

The transformer must continue to try and provide normal transformation after invoking this method. It should still be possible for the application to process the document through to the end if no other errors are encountered.

Parameters:
exception - The error information encapsulated in a transformer exception.
Throws:
TransformerException - if the application chooses to discontinue the transformation.
See Also:
TransformerException

fatalError

public void fatalError(TransformerException exception)
                throws TransformerException
Receive notification of a non-recoverable error.

The transformer must continue to try and provide normal transformation after invoking this method. It should still be possible for the application to process the document through to the end if no other errors are encountered, but there is no guarantee that the output will be useable.

Parameters:
exception - The error information encapsulated in a transformer exception.
Throws:
TransformerException - if the application chooses to discontinue the transformation.
See Also:
TransformerException
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


OutputKeys

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Class OutputKeys

java.lang.Object
    extended by javax.xml.transform.OutputKeys
public class OutputKeys
extends Object

Provides string constants that can be used to set output properties for a Transformer, or to retrieve output properties from a Transformer or Templates object.

A properties in this class are read-only.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation

Field Summary
static String | CDATA_SECTION_ELEMENTS cdata-section-elements = expanded names.
static String | DOCTYPE_PUBLIC doctype-public = string.
static String | DOCTYPE_SYSTEM doctype-system = string.
static String | ENCODING encoding = string.
static String | INDENT indent = "yes" | "no".
static String | MEDIA_TYPE media-type = string.
static String | METHOD method = "xml" | "html" | "text" | expanded name.
static String | OMIT_XML_DECLARATION omit-xml-declaration = "yes" | "no".
static String | STANDALONE standalone = "yes" | "no".
static String | VERSION version = nmtoken.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

METHOD

public static final String METHOD
method = "xml" | "html" | "text" | expanded name.

The method attribute identifies the overall method that should be used for outputting the result tree. Other non-namespaced values may be used, such as "xhtml", but, if accepted, the handling of such values is implementation defined. If any of the method values are not accepted and are not namespace qualified, then Transformer.setOutputProperty(java.lang.String, java.lang.String) or Transformer.setOutputProperties(java.util.Properties) will throw a IllegalArgumentException.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

VERSION

public static final String VERSION
version = nmtoken.

version specifies the version of the output method.

When the output method is "xml", the version value specifies the version of XML to be used for outputting the result tree. The default value for the xml output method is 1.0. When the output method is "html", the version value indicates the version of the HTML. The default value for the xml output method is 4.0, which specifies that the result should be output as HTML conforming to the HTML 4.0 Recommendation [HTML]. If the output method is "text", the version property is ignored.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

ENCODING

public static final String ENCODING
encoding = string.

encoding specifies the preferred character encoding that the Transformer should use to encode sequences of characters as sequences of bytes. The value of the attribute should be treated case-insensitively. The value must only contain characters in the range #x21 to #x7E (i.e., printable ASCII characters). The value should either be a charset registered with the Internet Assigned Numbers Authority [IANA], [RFC2278] or start with X-.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

OMIT_XML_DECLARATION

public static final String OMIT_XML_DECLARATION
omit-xml-declaration = "yes" | "no".

omit-xml-declaration specifies whether the XSLT processor should output an XML declaration; the value must be yes or no.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

STANDALONE

public static final String STANDALONE
standalone = "yes" | "no".

standalone specifies whether the Transformer should output a standalone document declaration; the value must be yes or no.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

DOCTYPE_PUBLIC

public static final String DOCTYPE_PUBLIC
doctype-public = string.

See the documentation for the DOCTYPE_SYSTEM property for a description of what the value of the key should be.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

DOCTYPE_SYSTEM

public static final String DOCTYPE_SYSTEM
doctype-system = string.

doctype-public specifies the public identifier to be used in the document type declaration.

If the doctype-system property is specified, the xml output method should output a document type declaration immediately before the first element. The name following <!DOCTYPE should be the name of the first element. If doctype-public property is also specified, then the xml output method should output PUBLIC followed by the public identifier and then the system identifier; otherwise, it should output SYSTEM followed by the system identifier. The internal subset should be empty. The doctype-public attribute should be ignored unless the doctype-system attribute is specified.

If the doctype-public or doctype-system attributes are specified, then the html output method should output a document type declaration immediately before the first element. The name following <!DOCTYPE should be HTML or html. If the doctype-public attribute is specified, then the output method should output PUBLIC followed by the specified public identifier; if the doctype-system attribute is also specified, it should also output the specified system identifier following the public identifier. If the doctype-system attribute is specified but the doctype-public attribute is not specified, then the output method should output SYSTEM followed by the specified system identifier.

doctype-system specifies the system identifier to be used in the document type declaration.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

CDATA_SECTION_ELEMENTS

public static final String CDATA_SECTION_ELEMENTS
cdata-section-elements = expanded names.

cdata-section-elements specifies a whitespace delimited list of the names of elements whose text node children should be output using CDATA sections.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation., Constant Field Values

INDENT

public static final String INDENT
indent = "yes" | "no".

indent specifies whether the Transformer may add additional whitespace when outputting the result tree; the value must be yes or no.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values

MEDIA_TYPE

public static final String MEDIA_TYPE
media-type = string.

media-type specifies the media type (MIME content type) of the data that results from outputting the result tree. The charset parameter should not be specified explicitly; instead, when the top-level media type is text, a charset parameter should be added according to the character encoding actually used by the output method.

See Also:
section 16 of the XSL Transformations (XSLT) W3C Recommendation, Constant Field Values
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Result

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Interface Result

All Known Implementing Classes:
DOMResult, SAXResult, StreamResult
public interface Result

An object that implements this interface contains the information needed to build a transformation result tree.

Field Summary
static String | PI_DISABLE_OUTPUT_ESCAPING The name of the processing instruction that is sent if the result tree disables output escaping.
static String | PI_ENABLE_OUTPUT_ESCAPING The name of the processing instruction that is sent if the result tree enables output escaping at some point after having received a PI_DISABLE_OUTPUT_ESCAPING processing instruction.
Method Summary
String | getSystemId() Get the system identifier that was set with setSystemId.
void | setSystemId(String systemId) Set the system identifier for this Result.

Field Detail

PI_DISABLE_OUTPUT_ESCAPING

public static final String PI_DISABLE_OUTPUT_ESCAPING
The name of the processing instruction that is sent if the result tree disables output escaping.

Normally, result tree serialization escapes & and < (and possibly other characters) when outputting text nodes. This ensures that the output is well-formed XML. However, it is sometimes convenient to be able to produce output that is almost, but not quite well-formed XML; for example, the output may include ill-formed sections that will be transformed into well-formed XML by a subsequent non-XML aware process. If a processing instruction is sent with this name, serialization should be output without any escaping.

Result DOM trees may also have PI_DISABLE_OUTPUT_ESCAPING and PI_ENABLE_OUTPUT_ESCAPING inserted into the tree.

See Also:
disable-output-escaping in XSLT Specification, Constant Field Values

PI_ENABLE_OUTPUT_ESCAPING

public static final String PI_ENABLE_OUTPUT_ESCAPING
The name of the processing instruction that is sent if the result tree enables output escaping at some point after having received a PI_DISABLE_OUTPUT_ESCAPING processing instruction.

See Also:
disable-output-escaping in XSLT Specification, Constant Field Values
Method Detail

setSystemId

public void setSystemId(String systemId)
Set the system identifier for this Result.

If the Result is not to be written to a file, the system identifier is optional. The application may still want to provide one, however, for use in error messages and warnings, or to resolve relative output identifiers.

Parameters:
systemId - The system identifier as a URI string.

getSystemId

public String getSystemId()
Get the system identifier that was set with setSystemId.

Returns:
The system identifier that was set with setSystemId, or null if setSystemId was not called.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


sax

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.transform.sax

This package implements SAX2-specific transformation APIs.

See:
Description

Interface Summary
TemplatesHandler | A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
TransformerHandler | A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.

Class Summary
SAXResult | Acts as an holder for a transformation Result.
SAXSource | Acts as an holder for SAX-style Source.
SAXTransformerFactory | This class extends TransformerFactory to provide SAX-specific factory methods.

Package javax.xml.transform.sax Description

This package implements SAX2-specific transformation APIs. It provides classes which allow input from ContentHandler events, and also classes that produce org.xml.sax.ContentHandler events. It also provides methods to set the input source as an XMLReader, or to use a InputSource as the source. It also allows the creation of a XMLFilter, which enables transformations to "pull" from other transformations, and lets the transformer to be used polymorphically as an XMLReader.

The SAXSource class allows the setting of an XMLReader to be used for "pulling" parse events, and an InputSource that may be used to specify the SAX source.

The SAXResult class allows the setting of a ContentHandler to be the receiver of SAX2 events from the transformation.

The SAXTransformerFactory extends TransformerFactory to provide factory methods for creating TemplatesHandler, TransformerHandler, and XMLReader instances.

To obtain a SAXTransformerFactory, the caller must cast the TransformerFactory instance returned from TransformerFactory.newInstance().

The TransformerHandler interface allows a transformation to be created from SAX2 parse events, which is a "push" model rather than the "pull" model that normally occurs for a transformation. Normal parse events are received through the ContentHandler interface, lexical events such as startCDATA and endCDATA are received through the LexicalHandler interface, and events that signal the start or end of disabling output escaping are received via ContentHandler.processingInstruction(java.lang.String, java.lang.String), with the target parameter being Result.PI_DISABLE_OUTPUT_ESCAPING and Result.PI_ENABLE_OUTPUT_ESCAPING. If parameters, output properties, or other features need to be set on the Transformer handler, a Transformer reference will need to be obtained from TransformerHandler.getTransformer(), and the methods invoked from that reference.

The TemplatesHandler interface allows the creation of Templates objects from SAX2 parse events. Once the ContentHandler events are complete, the Templates object may be obtained from TemplatesHandler.getTemplates(). Note that TemplatesHandler.setSystemId(java.lang.String) should normally be called in order to establish a base system ID from which relative URLs may be resolved.

The SAXTransformerFactory.newXMLFilter(javax.xml.transform.Source) method allows the creation of a XMLFilter, which encapsulates the SAX2 notion of a "pull" transformation. The following illustrates several transformations chained together. Each filter points to a parent XMLReader, and the final transformation is caused by invoking XMLReader.parse(org.xml.sax.InputSource) on the final reader in the chain.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.transform.sax Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.transform.sax

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
    • class javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
    • class javax.xml.transform.TransformerFactory
      • class javax.xml.transform.sax.SAXTransformerFactory

Interface Hierarchy

  • interface org.xml.sax.ContentHandler
    • interface javax.xml.transform.sax.TemplatesHandler
    • interface javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.DTDHandler, org.xml.sax.ext.LexicalHandler)
  • interface org.xml.sax.DTDHandler
    • interface javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.ext.LexicalHandler)
  • interface org.xml.sax.ext.LexicalHandler
    • interface javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.DTDHandler)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SAXResult

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform.sax
Class SAXResult

java.lang.Object
    extended by javax.xml.transform.sax.SAXResult
All Implemented Interfaces:
Result
public class SAXResult
extends Object
implements Result

Acts as an holder for a transformation Result.

Field Summary
static String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
Fields inherited from interface javax.xml.transform.Result
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
Constructor Summary
SAXResult()
Zero-argument default constructor.
SAXResult(ContentHandler handler)
Create a SAXResult that targets a SAX2 ContentHandler.
Method Summary
ContentHandler | getHandler() Get the ContentHandler that is the Result.
LexicalHandler | getLexicalHandler() Get a SAX2 LexicalHandler for the output.
String | getSystemId() Get the system identifier that was set with setSystemId.
void | setHandler(ContentHandler handler) Set the target to be a SAX2 ContentHandler.
void | setLexicalHandler(LexicalHandler handler) Set the SAX2 LexicalHandler for the output.
void | setSystemId(String systemId) Method setSystemId Set the systemID that may be used in association with the ContentHandler.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FEATURE

public static final String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

See Also:
Constant Field Values
Constructor Detail

SAXResult

public SAXResult()
Zero-argument default constructor.

SAXResult

public SAXResult(ContentHandler handler)
Create a SAXResult that targets a SAX2 ContentHandler.

Parameters:
handler - Must be a non-null ContentHandler reference.
Method Detail

setHandler

public void setHandler(ContentHandler handler)
Set the target to be a SAX2 ContentHandler.

Parameters:
handler - Must be a non-null ContentHandler reference.

getHandler

public ContentHandler getHandler()
Get the ContentHandler that is the Result.

Returns:
The ContentHandler that is to be transformation output.

setLexicalHandler

public void setLexicalHandler(LexicalHandler handler)
Set the SAX2 LexicalHandler for the output.

This is needed to handle XML comments and the like. If the lexical handler is not set, an attempt should be made by the transformer to cast the ContentHandler to a LexicalHandler.

Parameters:
handler - A non-null LexicalHandler for handling lexical parse events.

getLexicalHandler

public LexicalHandler getLexicalHandler()
Get a SAX2 LexicalHandler for the output.

Returns:
A LexicalHandler, or null.

setSystemId

public void setSystemId(String systemId)
Method setSystemId Set the systemID that may be used in association with the ContentHandler.

Specified by:
setSystemId in interface Result
Parameters:
systemId - The system identifier as a URI string.

getSystemId

public String getSystemId()
Get the system identifier that was set with setSystemId.

Specified by:
getSystemId in interface Result
Returns:
The system identifier that was set with setSystemId, or null if setSystemId was not called.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SAXSource

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform.sax
Class SAXSource

java.lang.Object
    extended by javax.xml.transform.sax.SAXSource
All Implemented Interfaces:
Source
public class SAXSource
extends Object
implements Source

Acts as an holder for SAX-style Source.

Field Summary
static String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
Constructor Summary
SAXSource()
Zero-argument default constructor.
SAXSource(InputSource inputSource)
Create a SAXSource, using a SAX InputSource.
SAXSource(XMLReader reader, InputSource inputSource)
Create a SAXSource, using an XMLReader and a SAX InputSource.
Method Summary
InputSource | getInputSource() Get the SAX InputSource to be used for the Source.
String | getSystemId() Get the base ID (URI or system ID) from where URIs will be resolved.
XMLReader | getXMLReader() Get the XMLReader to be used for the Source.
void | setInputSource(InputSource inputSource) Set the SAX InputSource to be used for the Source.
void | setSystemId(String systemId) Set the system identifier for this Source.
void | setXMLReader(XMLReader reader) Set the XMLReader to be used for the Source.
static InputSource | sourceToInputSource(Source source) Attempt to obtain a SAX InputSource object from a TrAX Source object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FEATURE

public static final String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.

See Also:
Constant Field Values
Constructor Detail

SAXSource

public SAXSource()
Zero-argument default constructor. If this constructor is used, and no other method is called, the Transformer assumes an empty input tree, with a default root node.

SAXSource

public SAXSource(XMLReader reader,
                 InputSource inputSource)
Create a SAXSource, using an XMLReader and a SAX InputSource. The Transformer or SAXTransformerFactory will set itself to be the reader's ContentHandler, and then will call reader.parse(inputSource).

Parameters:
reader - An XMLReader to be used for the parse.
inputSource - A SAX input source reference that must be non-null and that will be passed to the reader parse method.

SAXSource

public SAXSource(InputSource inputSource)
Create a SAXSource, using a SAX InputSource. The Transformer or SAXTransformerFactory creates a reader via XMLReaderFactory (if setXMLReader is not used), sets itself as the reader's ContentHandler, and calls reader.parse(inputSource).

Parameters:
inputSource - An input source reference that must be non-null and that will be passed to the parse method of the reader.
Method Detail

setXMLReader

public void setXMLReader(XMLReader reader)
Set the XMLReader to be used for the Source.

Parameters:
reader - A valid XMLReader or XMLFilter reference.

getXMLReader

public XMLReader getXMLReader()
Get the XMLReader to be used for the Source.

Returns:
A valid XMLReader or XMLFilter reference, or null.

setInputSource

public void setInputSource(InputSource inputSource)
Set the SAX InputSource to be used for the Source.

Parameters:
inputSource - A valid InputSource reference.

getInputSource

public InputSource getInputSource()
Get the SAX InputSource to be used for the Source.

Returns:
A valid InputSource reference, or null.

setSystemId

public void setSystemId(String systemId)
Set the system identifier for this Source. If an input source has already been set, it will set the system ID or that input source, otherwise it will create a new input source.

The system identifier is optional if there is a byte stream or a character stream, but it is still useful to provide one, since the application can use it to resolve relative URIs and can include it in error messages and warnings (the parser will attempt to open a connection to the URI only if no byte stream or character stream is specified).

Specified by:
setSystemId in interface Source
Parameters:
systemId - The system identifier as a URI string.

getSystemId

public String getSystemId()
Get the base ID (URI or system ID) from where URIs will be resolved.

Specified by:
getSystemId in interface Source
Returns:
Base URL for the Source, or null.

sourceToInputSource

public static InputSource sourceToInputSource(Source source)
Attempt to obtain a SAX InputSource object from a TrAX Source object.

Parameters:
source - Must be a non-null Source reference.
Returns:
An InputSource, or null if Source can not be converted.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SAXTransformerFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform.sax
Class SAXTransformerFactory

java.lang.Object
    extended by javax.xml.transform.TransformerFactory
        extended by javax.xml.transform.sax.SAXTransformerFactory
public abstract class SAXTransformerFactory
extends TransformerFactory

This class extends TransformerFactory to provide SAX-specific factory methods. It provides two types of ContentHandlers, one for creating Transformers, the other for creating Templates objects.

If an application wants to set the ErrorHandler or EntityResolver for an XMLReader used during a transformation, it should use a URIResolver to return the SAXSource which provides (with getXMLReader) a reference to the XMLReader.

Field Summary
static String | FEATURE If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the TransformerFactory returned from TransformerFactory.newInstance() may be safely cast to a SAXTransformerFactory.
static String | FEATURE_XMLFILTER If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the newXMLFilter(Source src) and newXMLFilter(Templates templates) methods are supported.
Constructor Summary
protected SAXTransformerFactory()
The default constructor is protected on purpose.
Method Summary
abstract TemplatesHandler | newTemplatesHandler() Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.
abstract TransformerHandler | newTransformerHandler() Get a TransformerHandler object that can process SAX ContentHandler events into a Result.
abstract TransformerHandler | newTransformerHandler(Source src) Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
abstract TransformerHandler | newTransformerHandler(Templates templates) Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
abstract XMLFilter | newXMLFilter(Source src) Create an XMLFilter that uses the given Source as the transformation instructions.
abstract XMLFilter | newXMLFilter(Templates templates) Create an XMLFilter, based on the Templates argument..
Methods inherited from class javax.xml.transform.TransformerFactory
getAssociatedStylesheet, getAttribute, getErrorListener, getFeature, getURIResolver, newInstance, newTemplates, newTransformer, newTransformer, setAttribute, setErrorListener, setURIResolver
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FEATURE

public static final String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the TransformerFactory returned from TransformerFactory.newInstance() may be safely cast to a SAXTransformerFactory.

See Also:
Constant Field Values

FEATURE_XMLFILTER

public static final String FEATURE_XMLFILTER
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the newXMLFilter(Source src) and newXMLFilter(Templates templates) methods are supported.

See Also:
Constant Field Values
Constructor Detail

SAXTransformerFactory

protected SAXTransformerFactory()
The default constructor is protected on purpose.

Method Detail

newTransformerHandler

public abstract TransformerHandler newTransformerHandler(Source src)
                                                  throws TransformerConfigurationException
Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.

Parameters:
src - The Source of the transformation instructions.
Returns:
TransformerHandler ready to transform SAX events.
Throws:
TransformerConfigurationException - If for some reason the TransformerHandler can not be created.

newTransformerHandler

public abstract TransformerHandler newTransformerHandler(Templates templates)
                                                  throws TransformerConfigurationException
Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.

Parameters:
templates - The compiled transformation instructions.
Returns:
TransformerHandler ready to transform SAX events.
Throws:
TransformerConfigurationException - If for some reason the TransformerHandler can not be created.

newTransformerHandler

public abstract TransformerHandler newTransformerHandler()
                                                  throws TransformerConfigurationException
Get a TransformerHandler object that can process SAX ContentHandler events into a Result. The transformation is defined as an identity (or copy) transformation, for example to copy a series of SAX parse events into a DOM tree.

Returns:
A non-null reference to a TransformerHandler, that may be used as a ContentHandler for SAX parse events.
Throws:
TransformerConfigurationException - If for some reason the TransformerHandler cannot be created.

newTemplatesHandler

public abstract TemplatesHandler newTemplatesHandler()
                                              throws TransformerConfigurationException
Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.

Returns:
A non-null reference to a TransformerHandler, that may be used as a ContentHandler for SAX parse events.
Throws:
TransformerConfigurationException - If for some reason the TemplatesHandler cannot be created.

newXMLFilter

public abstract XMLFilter newXMLFilter(Source src)
                                throws TransformerConfigurationException
Create an XMLFilter that uses the given Source as the transformation instructions.

Parameters:
src - The Source of the transformation instructions.
Returns:
An XMLFilter object, or null if this feature is not supported.
Throws:
TransformerConfigurationException - If for some reason the TemplatesHandler cannot be created.

newXMLFilter

public abstract XMLFilter newXMLFilter(Templates templates)
                                throws TransformerConfigurationException
Create an XMLFilter, based on the Templates argument..

Parameters:
templates - The compiled transformation instructions.
Returns:
An XMLFilter object, or null if this feature is not supported.
Throws:
TransformerConfigurationException - If for some reason the TemplatesHandler cannot be created.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TemplatesHandler

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform.sax
Interface TemplatesHandler

All Superinterfaces:
ContentHandler
public interface TemplatesHandler
extends ContentHandler

A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.

Note that TemplatesHandler does not need to implement LexicalHandler.

Method Summary
String | getSystemId() Get the base ID (URI or system ID) from where relative URLs will be resolved.
Templates | getTemplates() When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.
void | setSystemId(String systemID) Set the base ID (URI or system ID) for the Templates object created by this builder.
Methods inherited from interface org.xml.sax.ContentHandler
characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

Method Detail

getTemplates

public Templates getTemplates()
When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.

Returns:
The Templates object that was created during the SAX event process, or null if no Templates object has been created.

setSystemId

public void setSystemId(String systemID)
Set the base ID (URI or system ID) for the Templates object created by this builder. This must be set in order to resolve relative URIs in the stylesheet. This must be called before the startDocument event.

getSystemId

public String getSystemId()
Get the base ID (URI or system ID) from where relative URLs will be resolved.

Returns:
The systemID that was set with setSystemId(java.lang.String).
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransformerHandler

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform.sax
Interface TransformerHandler

All Superinterfaces:
ContentHandler, DTDHandler, LexicalHandler
public interface TransformerHandler
extends ContentHandler, LexicalHandler, DTDHandler

A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.

Method Summary
String | getSystemId() Get the base ID (URI or system ID) from where relative URLs will be resolved.
Transformer | getTransformer() Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.
void | setResult(Result result) Enables the user of the TransformerHandler to set the to set the Result for the transformation.
void | setSystemId(String systemID) Set the base ID (URI or system ID) from where relative URLs will be resolved.
Methods inherited from interface org.xml.sax.ContentHandler
characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping
Methods inherited from interface org.xml.sax.ext.LexicalHandler
comment, endCDATA, endDTD, endEntity, startCDATA, startDTD, startEntity
Methods inherited from interface org.xml.sax.DTDHandler
notationDecl, unparsedEntityDecl

Method Detail

setResult

public void setResult(Result result)
               throws IllegalArgumentException
Enables the user of the TransformerHandler to set the to set the Result for the transformation.

Parameters:
result - A Result instance, should not be null.
Throws:
IllegalArgumentException - if result is invalid for some reason.

setSystemId

public void setSystemId(String systemID)
Set the base ID (URI or system ID) from where relative URLs will be resolved.

Parameters:
systemID - Base URI for the source tree.

getSystemId

public String getSystemId()
Get the base ID (URI or system ID) from where relative URLs will be resolved.

Returns:
The systemID that was set with setSystemId(java.lang.String).

getTransformer

public Transformer getTransformer()
Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Source

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Interface Source

All Known Implementing Classes:
DOMSource, SAXSource, StreamSource
public interface Source

An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).

Method Summary
String | getSystemId() Get the system identifier that was set with setSystemId.
void | setSystemId(String systemId) Set the system identifier for this Source.

Method Detail

setSystemId

public void setSystemId(String systemId)
Set the system identifier for this Source.

The system identifier is optional if the source does not get its data from a URL, but it may still be useful to provide one. The application can use a system identifier, for example, to resolve relative URIs and to include in error messages and warnings.

Parameters:
systemId - The system identifier as a URL string.

getSystemId

public String getSystemId()
Get the system identifier that was set with setSystemId.

Returns:
The system identifier that was set with setSystemId, or null if setSystemId was not called.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


SourceLocator

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Interface SourceLocator

All Known Subinterfaces:
DOMLocator
public interface SourceLocator

This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.

Method Summary
int | getColumnNumber() Return the character position where the current document event ends.
int | getLineNumber() Return the line number where the current document event ends.
String | getPublicId() Return the public identifier for the current document event.
String | getSystemId() Return the system identifier for the current document event.

Method Detail

getPublicId

public String getPublicId()
Return the public identifier for the current document event.

The return value is the public identifier of the document entity or of the external parsed entity in which the markup that triggered the event appears.

Returns:
A string containing the public identifier, or null if none is available.
See Also:
getSystemId()

getSystemId

public String getSystemId()
Return the system identifier for the current document event.

The return value is the system identifier of the document entity or of the external parsed entity in which the markup that triggered the event appears.

If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

Returns:
A string containing the system identifier, or null if none is available.
See Also:
getPublicId()

getLineNumber

public int getLineNumber()
Return the line number where the current document event ends.

Warning: The return value from the method is intended only as an approximation for the sake of error reporting; it is not intended to provide sufficient information to edit the character content of the original XML document.

The return value is an approximation of the line number in the document entity or external parsed entity where the markup that triggered the event appears.

Returns:
The line number, or -1 if none is available.
See Also:
getColumnNumber()

getColumnNumber

public int getColumnNumber()
Return the character position where the current document event ends.

Warning: The return value from the method is intended only as an approximation for the sake of error reporting; it is not intended to provide sufficient information to edit the character content of the original XML document.

The return value is an approximation of the column number in the document entity or external parsed entity where the markup that triggered the event appears.

Returns:
The column number, or -1 if none is available.
See Also:
getLineNumber()
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


stream

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.transform.stream

This package implements stream- and URI- specific transformation APIs.

See:
Description

Class Summary
StreamResult | Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.
StreamSource | Acts as an holder for a transformation Source in the form of a stream of XML markup.

Package javax.xml.transform.stream Description

This package implements stream- and URI- specific transformation APIs.

The StreamSource class provides methods for specifying InputStream input, Reader input, and URL input in the form of strings. Even if an input stream or reader is specified as the source, StreamSource.setSystemId(java.lang.String) should still be called, so that the transformer can know from where it should resolve relative URIs. The public identifier is always optional: if the application writer includes one, it will be provided as part of the SourceLocator information.

The StreamResult class provides methods for specifying OutputStream, Writer, or an output system ID, as the output of the transformation result.

Normally streams should be used rather than readers or writers, for both the Source and Result, since readers and writers already have the encoding established to and from the internal Unicode format. However, there are times when it is useful to write to a character stream, such as when using a StringWriter in order to write to a String, or in the case of reading source XML from a StringReader.

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


javax.xml.transform.stream Class Hierarchy

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.transform.stream

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.xml.transform.stream.StreamResult (implements javax.xml.transform.Result)
    • class javax.xml.transform.stream.StreamSource (implements javax.xml.transform.Source)
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StreamResult

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform.stream
Class StreamResult

java.lang.Object
    extended by javax.xml.transform.stream.StreamResult
All Implemented Interfaces:
Result
public class StreamResult
extends Object
implements Result

Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.

Field Summary
static String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
Fields inherited from interface javax.xml.transform.Result
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
Constructor Summary
StreamResult()
Zero-argument default constructor.
StreamResult(File f)
Construct a StreamResult from a File.
StreamResult(OutputStream outputStream)
Construct a StreamResult from a byte stream.
StreamResult(String systemId)
Construct a StreamResult from a URL.
StreamResult(Writer writer)
Construct a StreamResult from a character stream.
Method Summary
OutputStream | getOutputStream() Get the byte stream that was set with setOutputStream.
String | getSystemId() Get the system identifier that was set with setSystemId.
Writer | getWriter() Get the character stream that was set with setWriter.
void | setOutputStream(OutputStream outputStream) Set the ByteStream that is to be written to.
void | setSystemId(File f) Set the system ID from a File reference.
void | setSystemId(String systemId) Set the systemID that may be used in association with the byte or character stream, or, if neither is set, use this value as a writeable URI (probably a file name).
void | setWriter(Writer writer) Set the writer that is to receive the result.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FEATURE

public static final String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.

See Also:
Constant Field Values
Constructor Detail

StreamResult

public StreamResult()
Zero-argument default constructor.

StreamResult

public StreamResult(OutputStream outputStream)
Construct a StreamResult from a byte stream. Normally, a stream should be used rather than a reader, so that the transformer may use instructions contained in the transformation instructions to control the encoding.

Parameters:
outputStream - A valid OutputStream reference.

StreamResult

public StreamResult(Writer writer)
Construct a StreamResult from a character stream. Normally, a stream should be used rather than a reader, so that the transformer may use instructions contained in the transformation instructions to control the encoding. However, there are times when it is useful to write to a character stream, such as when using a StringWriter.

Parameters:
writer - A valid Writer reference.

StreamResult

public StreamResult(String systemId)
Construct a StreamResult from a URL.

Parameters:
systemId - Must be a String that conforms to the URI syntax.

StreamResult

public StreamResult(File f)
Construct a StreamResult from a File.

Parameters:
f - Must a non-null File reference.
Method Detail

setOutputStream

public void setOutputStream(OutputStream outputStream)
Set the ByteStream that is to be written to. Normally, a stream should be used rather than a reader, so that the transformer may use instructions contained in the transformation instructions to control the encoding.

Parameters:
outputStream - A valid OutputStream reference.

getOutputStream

public OutputStream getOutputStream()
Get the byte stream that was set with setOutputStream.

Returns:
The byte stream that was set with setOutputStream, or null if setOutputStream or the ByteStream constructor was not called.

setWriter

public void setWriter(Writer writer)
Set the writer that is to receive the result. Normally, a stream should be used rather than a writer, so that the transformer may use instructions contained in the transformation instructions to control the encoding. However, there are times when it is useful to write to a writer, such as when using a StringWriter.

Parameters:
writer - A valid Writer reference.

getWriter

public Writer getWriter()
Get the character stream that was set with setWriter.

Returns:
The character stream that was set with setWriter, or null if setWriter or the Writer constructor was not called.

setSystemId

public void setSystemId(String systemId)
Set the systemID that may be used in association with the byte or character stream, or, if neither is set, use this value as a writeable URI (probably a file name).

Specified by:
setSystemId in interface Result
Parameters:
systemId - The system identifier as a URI string.

setSystemId

public void setSystemId(File f)
Set the system ID from a File reference.

Parameters:
f - Must a non-null File reference.

getSystemId

public String getSystemId()
Get the system identifier that was set with setSystemId.

Specified by:
getSystemId in interface Result
Returns:
The system identifier that was set with setSystemId, or null if setSystemId was not called.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


StreamSource

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform.stream
Class StreamSource

java.lang.Object
    extended by javax.xml.transform.stream.StreamSource
All Implemented Interfaces:
Source
public class StreamSource
extends Object
implements Source

Acts as an holder for a transformation Source in the form of a stream of XML markup.

Field Summary
static String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
Constructor Summary
StreamSource()
Zero-argument default constructor.
StreamSource(File f)
Construct a StreamSource from a File.
StreamSource(InputStream inputStream)
Construct a StreamSource from a byte stream.
StreamSource(InputStream inputStream, String systemId)
Construct a StreamSource from a byte stream.
StreamSource(Reader reader)
Construct a StreamSource from a character reader.
StreamSource(Reader reader, String systemId)
Construct a StreamSource from a character reader.
StreamSource(String systemId)
Construct a StreamSource from a URL.
Method Summary
InputStream | getInputStream() Get the byte stream that was set with setByteStream.
String | getPublicId() Get the public identifier that was set with setPublicId.
Reader | getReader() Get the character stream that was set with setReader.
String | getSystemId() Get the system identifier that was set with setSystemId.
void | setInputStream(InputStream inputStream) Set the byte stream to be used as input.
void | setPublicId(String publicId) Set the public identifier for this Source.
void | setReader(Reader reader) Set the input to be a character reader.
void | setSystemId(File f) Set the system ID from a File reference.
void | setSystemId(String systemId) Set the system identifier for this Source.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FEATURE

public static final String FEATURE
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.

See Also:
Constant Field Values
Constructor Detail

StreamSource

public StreamSource()
Zero-argument default constructor. If this constructor is used, and no other method is called, the transformer will assume an empty input tree, with a default root node.

StreamSource

public StreamSource(InputStream inputStream)
Construct a StreamSource from a byte stream. Normally, a stream should be used rather than a reader, so the XML parser can resolve character encoding specified by the XML declaration.

If this constructor is used to process a stylesheet, normally setSystemId should also be called, so that relative URI references can be resolved.

Parameters:
inputStream - A valid InputStream reference to an XML stream.

StreamSource

public StreamSource(InputStream inputStream,
                    String systemId)
Construct a StreamSource from a byte stream. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration.

This constructor allows the systemID to be set in addition to the input stream, which allows relative URIs to be processed.

Parameters:
inputStream - A valid InputStream reference to an XML stream.
systemId - Must be a String that conforms to the URI syntax.

StreamSource

public StreamSource(Reader reader)
Construct a StreamSource from a character reader. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration. However, in many cases the encoding of the input stream is already resolved, as in the case of reading XML from a StringReader.

Parameters:
reader - A valid Reader reference to an XML character stream.

StreamSource

public StreamSource(Reader reader,
                    String systemId)
Construct a StreamSource from a character reader. Normally, a stream should be used rather than a reader, so that the XML parser may resolve character encoding specified by the XML declaration. However, in many cases the encoding of the input stream is already resolved, as in the case of reading XML from a StringReader.

Parameters:
reader - A valid Reader reference to an XML character stream.
systemId - Must be a String that conforms to the URI syntax.

StreamSource

public StreamSource(String systemId)
Construct a StreamSource from a URL.

Parameters:
systemId - Must be a String that conforms to the URI syntax.

StreamSource

public StreamSource(File f)
Construct a StreamSource from a File.

Parameters:
f - Must a non-null File reference.
Method Detail

setInputStream

public void setInputStream(InputStream inputStream)
Set the byte stream to be used as input. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration.

If this Source object is used to process a stylesheet, normally setSystemId should also be called, so that relative URL references can be resolved.

Parameters:
inputStream - A valid InputStream reference to an XML stream.

getInputStream

public InputStream getInputStream()
Get the byte stream that was set with setByteStream.

Returns:
The byte stream that was set with setByteStream, or null if setByteStream or the ByteStream constructor was not called.

setReader

public void setReader(Reader reader)
Set the input to be a character reader. Normally, a stream should be used rather than a reader, so that the XML parser can resolve character encoding specified by the XML declaration. However, in many cases the encoding of the input stream is already resolved, as in the case of reading XML from a StringReader.

Parameters:
reader - A valid Reader reference to an XML CharacterStream.

getReader

public Reader getReader()
Get the character stream that was set with setReader.

Returns:
The character stream that was set with setReader, or null if setReader or the Reader constructor was not called.

setPublicId

public void setPublicId(String publicId)
Set the public identifier for this Source.

The public identifier is always optional: if the application writer includes one, it will be provided as part of the location information.

Parameters:
publicId - The public identifier as a string.

getPublicId

public String getPublicId()
Get the public identifier that was set with setPublicId.

Returns:
The public identifier that was set with setPublicId, or null if setPublicId was not called.

setSystemId

public void setSystemId(String systemId)
Set the system identifier for this Source.

The system identifier is optional if there is a byte stream or a character stream, but it is still useful to provide one, since the application can use it to resolve relative URIs and can include it in error messages and warnings (the parser will attempt to open a connection to the URI only if there is no byte stream or character stream specified).

Specified by:
setSystemId in interface Source
Parameters:
systemId - The system identifier as a URL string.

getSystemId

public String getSystemId()
Get the system identifier that was set with setSystemId.

Specified by:
getSystemId in interface Source
Returns:
The system identifier that was set with setSystemId, or null if setSystemId was not called.

setSystemId

public void setSystemId(File f)
Set the system ID from a File reference.

Parameters:
f - Must a non-null File reference.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Templates

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Interface Templates

public interface Templates

An object that implements this interface is the runtime representation of processed transformation instructions.

Templates must be threadsafe for a given instance over multiple threads running concurrently, and may be used multiple times in a given session.

Method Summary
Properties | getOutputProperties() Get the static properties for xsl:output.
Transformer | newTransformer() Create a new transformation context for this Templates object.

Method Detail

newTransformer

public Transformer newTransformer()
                           throws TransformerConfigurationException
Create a new transformation context for this Templates object.

Returns:
A valid non-null instance of a Transformer.
Throws:
TransformerConfigurationException - if a Transformer can not be created.

getOutputProperties

public Properties getOutputProperties()
Get the static properties for xsl:output. The object returned will be a clone of the internal values. Accordingly, it can be mutated without mutating the Templates object, and then handed in to Transformer.setOutputProperties(java.util.Properties).

The properties returned should contain properties set by the stylesheet, and these properties are "defaulted" by default properties specified by section 16 of the XSL Transformations (XSLT) W3C Recommendation. The properties that were specifically set by the stylesheet should be in the base Properties list, while the XSLT default properties that were not specifically set should be in the "default" Properties list. Thus, getOutputProperties().getProperty(String key) will obtain any property in that was set by the stylesheet, or the default properties, while getOutputProperties().get(String key) will only retrieve properties that were explicitly set in the stylesheet.

For XSLT, Attribute Value Templates attribute values will be returned unexpanded (since there is no context at this point). The namespace prefixes inside Attribute Value Templates will be unexpanded, so that they remain valid XPath values. (For XSLT 1.0, this is not a problem since Attribute Value Templates are not allowed for xsl:output attributes. However, the will be allowed in versions after 1.1.)

Returns:
A Properties object, never null.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Transformer

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Class Transformer

java.lang.Object
    extended by javax.xml.transform.Transformer
public abstract class Transformer
extends Object

An instance of this abstract class can transform a source tree into a result tree.

An instance of this class can be obtained with the TransformerFactory.newTransformer method. This instance may then be used to process XML from a variety of sources and write the transformation output to a variety of sinks.

An object of this class may not be used in multiple threads running concurrently. Different Transformers may be used concurrently by different threads.

A Transformer may be used multiple times. Parameters and output properties are preserved across transformations.

Constructor Summary
protected Transformer()
          Default constructor is protected on purpose.

Method Summary
abstract  void clearParameters()
          Clear all parameters set with setParameter.
abstract  ErrorListener getErrorListener()
          Get the error event handler in effect for the transformation.
abstract  Properties getOutputProperties()
          Get a copy of the output properties for the transformation.
abstract  String getOutputProperty(String name)
          Get an output property that is in effect for the transformation.
abstract  Object getParameter(String name)
          Get a parameter that was explicitly set with setParameter or setParameters.
abstract  URIResolver getURIResolver()
          Get an object that will be used to resolve URIs used in document(), etc.
abstract  void setErrorListener(ErrorListener listener)
          Set the error event listener in effect for the transformation.
abstract  void setOutputProperties(Properties oformat)
          Set the output properties for the transformation.
abstract  void setOutputProperty(String name, String value)
          Set an output property that will be in effect for the transformation.
abstract  void setParameter(String name, Object value)
          Add a parameter for the transformation.
abstract  void setURIResolver(URIResolver resolver)
          Set an object that will be used to resolve URIs used in document().
abstract  void transform(Source xmlSource, Result outputTarget)
          Process the source tree to the output result.

Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Transformer

protected Transformer()
Default constructor is protected on purpose.

Method Detail

transform

public abstract void transform(Source xmlSource,
                               Result outputTarget)
                        throws TransformerException
Process the source tree to the output result.

Parameters:
xmlSource - The input for the source tree.
outputTarget - The output target.
Throws:
TransformerException - If an unrecoverable error occurs during the course of the transformation.

setParameter

public abstract void setParameter(String name,
                                  Object value)
Add a parameter for the transformation.

Pass a qualified name as a two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the name has a null URL, the String only contain the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the qualified name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that no prefix is used.

Parameters:
name - The name of the parameter, which may begin with a namespace URI in curly braces ({}).
value - The value object. This can be any valid Java object. It is up to the processor to provide the proper object coersion or to simply pass the object on for use in an extension.

getParameter

public abstract Object getParameter(String name)
Get a parameter that was explicitly set with setParameter or setParameters.

This method does not return a default parameter value, which cannot be determined until the node context is evaluated during the transformation process.

Returns:
A parameter that has been set with setParameter.

clearParameters

public abstract void clearParameters()
Clear all parameters set with setParameter.

setURIResolver

public abstract void setURIResolver(URIResolver resolver)
Set an object that will be used to resolve URIs used in document().

If the resolver argument is null, the URIResolver value will be cleared, and the default behavior will be used.

Parameters:
resolver - An object that implements the URIResolver interface, or null.

getURIResolver

public abstract URIResolver getURIResolver()
Get an object that will be used to resolve URIs used in document(), etc.

Returns:
An object that implements the URIResolver interface, or null.

setOutputProperties

public abstract void setOutputProperties(Properties oformat)
                                  throws IllegalArgumentException
Set the output properties for the transformation. These properties will override properties set in the Templates with xsl:output.

If argument to this function is null, any properties previously set are removed, and the value will revert to the value defined in the templates object.

Pass a qualified property key name as a two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the name has a null URL, the String only contain the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the qualified name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that no prefix is used.

Parameters:
oformat - A set of output properties that will be used to override any of the same properties in affect for the transformation.
Throws:
IllegalArgumentException - if any of the argument keys are not recognized and are not namespace qualified.
See Also:
OutputKeys, Properties

getOutputProperties

public abstract Properties getOutputProperties()
Get a copy of the output properties for the transformation.

The properties returned should contain properties set by the user, and properties set by the stylesheet, and these properties are "defaulted" by default properties specified by section 16 of the XSL Transformations (XSLT) W3C Recommendation. The properties that were specifically set by the user or the stylesheet should be in the base Properties list, while the XSLT default properties that were not specifically set should be the default Properties list. Thus, getOutputProperties().getProperty(String key) will obtain any property in that was set by setOutputProperty(java.lang.String, java.lang.String), setOutputProperties(java.util.Properties), in the stylesheet, or the default properties, while getOutputProperties().get(String key) will only retrieve properties that were explicitly set by setOutputProperty(java.lang.String, java.lang.String), setOutputProperties(java.util.Properties), or in the stylesheet.

Note that mutation of the Properties object returned will not effect the properties that the transformation contains.

If any of the argument keys are not recognized and are not namespace qualified, the property will be ignored. In other words the behaviour is not orthogonal with setOutputProperties.

See Also:
OutputKeys, Properties

setOutputProperty

public abstract void setOutputProperty(String name,
                                       String value)
                                throws IllegalArgumentException
Set an output property that will be in effect for the transformation.

Pass a qualified property name as a two-part string, the namespace URI enclosed in curly braces ({}), followed by the local name. If the name has a null URL, the String only contain the local name. An application can safely check for a non-null URI by testing to see if the first character of the name is a '{' character.

For example, if a URI and local name were obtained from an element defined with <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/>, then the qualified name would be "{http://xyz.foo.com/yada/baz.html}foo". Note that no prefix is used.

The Properties object that was passed to setOutputProperties(java.util.Properties) won't be effected by calling this method.

Parameters:
name - A non-null String that specifies an output property name, which may be namespace qualified.
value - The non-null string value of the output property.
Throws:
IllegalArgumentException - If the property is not supported, and is not qualified with a namespace.
See Also:
OutputKeys

getOutputProperty

public abstract String getOutputProperty(String name)
                                  throws IllegalArgumentException
Get an output property that is in effect for the transformation. The property specified may be a property that was set with setOutputProperty, or it may be a property specified in the stylesheet.

Parameters:
name - A non-null String that specifies an output property name, which may be namespace qualified.
Returns:
The string value of the output property, or null if no property was found.
Throws:
IllegalArgumentException - If the property is not supported.
See Also:
OutputKeys

setErrorListener

public abstract void setErrorListener(ErrorListener listener)
                               throws IllegalArgumentException
Set the error event listener in effect for the transformation.

Parameters:
listener - The new error listener.
Throws:
IllegalArgumentException - if listener is null.

getErrorListener

public abstract ErrorListener getErrorListener()
Get the error event handler in effect for the transformation.

Returns:
The current error handler, which should never be null.
Overview  Package   Class  Tree  Deprecated  Index  Help
JavaTM 2 Platform
Ent. Ed. v1.4
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransformerConfigurationException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Class TransformerConfigurationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.transform.TransformerException
                extended by javax.xml.transform.TransformerConfigurationException
All Implemented Interfaces:
Serializable
public class TransformerConfigurationException
extends TransformerException

Indicates a serious configuration error.

See Also:
Serialized Form

Constructor Summary
TransformerConfigurationException()
Create a new TransformerConfigurationException with no detail mesage.
TransformerConfigurationException(String msg)
Create a new TransformerConfigurationException with the String specified as an error message.
TransformerConfigurationException(String message, SourceLocator locator)
Create a new TransformerConfigurationException from a message and a Locator.
TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
Wrap an existing exception in a TransformerConfigurationException.
TransformerConfigurationException(String msg, Throwable e)
Create a new TransformerConfigurationException with the given Exception base cause and detail message.
TransformerConfigurationException(Throwable e)
Create a new TransformerConfigurationException with a given Exception base cause of the error.
Methods inherited from class javax.xml.transform.TransformerException
getCause, getException, getLocationAsString, getLocator, getMessageAndLocation, initCause, printStackTrace, printStackTrace, printStackTrace, setLocator
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransformerConfigurationException

public TransformerConfigurationException()
Create a new TransformerConfigurationException with no detail mesage.

TransformerConfigurationException

public TransformerConfigurationException(String msg)
Create a new TransformerConfigurationException with the String specified as an error message.

Parameters:
msg - The error message for the exception.

TransformerConfigurationException

public TransformerConfigurationException(Throwable e)
Create a new TransformerConfigurationException with a given Exception base cause of the error.

Parameters:
e - The exception to be encapsulated in a TransformerConfigurationException.

TransformerConfigurationException

public TransformerConfigurationException(String msg,
                                         Throwable e)
Create a new TransformerConfigurationException with the given Exception base cause and detail message.

Parameters:
e - The exception to be encapsulated in a TransformerConfigurationException
msg - The detail message.

TransformerConfigurationException

public TransformerConfigurationException(String message,
                                         SourceLocator locator)
Create a new TransformerConfigurationException from a message and a Locator.

This constructor is especially useful when an application is creating its own exception from within a DocumentHandler callback.

Parameters:
message - The error or warning message.
locator - The locator object for the error or warning.

TransformerConfigurationException

public TransformerConfigurationException(String message,
                                         SourceLocator locator,
                                         Throwable e)
Wrap an existing exception in a TransformerConfigurationException.

Parameters:
message - The error or warning message, or null to use the message from the embedded exception.
locator - The locator object for the error or warning.
e - Any exception.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransformerException

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Class TransformerException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by javax.xml.transform.TransformerException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
TransformerConfigurationException
public class TransformerException
extends Exception

This class specifies an exceptional condition that occured during the transformation process.

See Also:
Serialized Form

Constructor Summary
TransformerException(String message)
Create a new TransformerException.
TransformerException(String message, SourceLocator locator)
Create a new TransformerException from a message and a Locator.
TransformerException(String message, SourceLocator locator, Throwable e)
Wrap an existing exception in a TransformerException.
TransformerException(String message, Throwable e)
Wrap an existing exception in a TransformerException.
TransformerException(Throwable e)
Create a new TransformerException wrapping an existing exception.
Method Summary
Throwable | getCause() Returns the cause of this throwable or null if the cause is nonexistent or unknown.
Throwable | getException() This method retrieves an exception that this exception wraps.
String | getLocationAsString() Get the location information as a string.
SourceLocator | getLocator() Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.
String | getMessageAndLocation() Get the error message with location information appended.
Throwable | initCause(Throwable cause) Initializes the cause of this throwable to the specified value.
void | printStackTrace() Print the the trace of methods from where the error originated.
void | printStackTrace(PrintStream s) Print the the trace of methods from where the error originated.
void | printStackTrace(PrintWriter s) Print the the trace of methods from where the error originated.
void | setLocator(SourceLocator location) Method setLocator sets an instance of a SourceLocator object that specifies where an error occured.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransformerException

public TransformerException(String message)
Create a new TransformerException.

Parameters:
message - The error or warning message.

TransformerException

public TransformerException(Throwable e)
Create a new TransformerException wrapping an existing exception.

Parameters:
e - The exception to be wrapped.

TransformerException

public TransformerException(String message,
                            Throwable e)
Wrap an existing exception in a TransformerException.

This is used for throwing processor exceptions before the processing has started.

Parameters:
message - The error or warning message, or null to use the message from the embedded exception.
e - Any exception

TransformerException

public TransformerException(String message,
                            SourceLocator locator)
Create a new TransformerException from a message and a Locator.

This constructor is especially useful when an application is creating its own exception from within a DocumentHandler callback.

Parameters:
message - The error or warning message.
locator - The locator object for the error or warning.

TransformerException

public TransformerException(String message,
                            SourceLocator locator,
                            Throwable e)
Wrap an existing exception in a TransformerException.

Parameters:
message - The error or warning message, or null to use the message from the embedded exception.
locator - The locator object for the error or warning.
e - Any exception
Method Detail

getLocator

public SourceLocator getLocator()
Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.

Returns:
A SourceLocator object, or null if none was specified.

setLocator

public void setLocator(SourceLocator location)
Method setLocator sets an instance of a SourceLocator object that specifies where an error occured.

Parameters:
location - A SourceLocator object, or null to clear the location.

getException

public Throwable getException()
This method retrieves an exception that this exception wraps.

Returns:
An Throwable object, or null.
See Also:
getCause()

getCause

public Throwable getCause()
Returns the cause of this throwable or null if the cause is nonexistent or unknown. (The cause is the throwable that caused this throwable to get thrown.)

initCause

public Throwable initCause(Throwable cause)
Initializes the cause of this throwable to the specified value. (The cause is the throwable that caused this throwable to get thrown.)

This method can be called at most once. It is generally called from within the constructor, or immediately after creating the throwable. If this throwable was created with TransformerException(Throwable) or TransformerException(String,Throwable), this method cannot be called even once.

Parameters:
cause - the cause (which is saved for later retrieval by the getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Returns:
a reference to this Throwable instance.
Throws:
IllegalArgumentException - if cause is this throwable. (A throwable cannot be its own cause.)
IllegalStateException - if this throwable was created with TransformerException(Throwable) or TransformerException(String,Throwable), or this method has already been called on this throwable.

getMessageAndLocation

public String getMessageAndLocation()
Get the error message with location information appended.

Returns:
A String representing the error message with location information appended.

getLocationAsString

public String getLocationAsString()
Get the location information as a string.

Returns:
A string with location info, or null if there is no location information.

printStackTrace

public void printStackTrace()
Print the the trace of methods from where the error originated. This will trace all nested exception objects, as well as this object.

printStackTrace

public void printStackTrace(PrintStream s)
Print the the trace of methods from where the error originated. This will trace all nested exception objects, as well as this object.

Parameters:
s - The stream where the dump will be sent to.

printStackTrace

public void printStackTrace(PrintWriter s)
Print the the trace of methods from where the error originated. This will trace all nested exception objects, as well as this object.

Parameters:
s - The writer where the dump will be sent to.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransformerFactory

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Class TransformerFactory

java.lang.Object
    extended by javax.xml.transform.TransformerFactory
Direct Known Subclasses:
SAXTransformerFactory
public abstract class TransformerFactory
extends Object

A TransformerFactory instance can be used to create Transformer and Templates objects.

The system property that determines which Factory implementation to create is named "javax.xml.transform.TransformerFactory". This property names a concrete subclass of the TransformerFactory abstract class. If the property is not defined, a platform default is be used.

An implementation of the TransformerFactory class is NOT guaranteed to be thread safe. It is up to the user application to make sure about the use of the TransformerFactory from more than one thread. Alternatively the application can have one instance of the TransformerFactory per thread. An application can use the same instance of the factory to obtain one or more instances of a Transformer or Templates provided the instance of the factory isn't being used in more than one thread at a time.

Constructor Summary
protected TransformerFactory()
Default constructor is protected on purpose.
Method Summary
abstract  Source getAssociatedStylesheet(Source source, String media, String title, String charset)
Get the stylesheet specification(s) associated via the xml-stylesheet processing instruction (see http://www.w3.org/TR/xml-stylesheet/) with the document document specified in the source parameter, and that match the given criteria.
abstract  Object getAttribute(String name)
Allows the user to retrieve specific attributes on the underlying implementation.
abstract  ErrorListener getErrorListener()
Get the error event handler for the TransformerFactory.
abstract  boolean getFeature(String name)
Look up the value of a feature.
abstract  URIResolver getURIResolver()
Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.
static TransformerFactory newInstance()
Obtain a new instance of a TransformerFactory.
abstract  Templates newTemplates(Source source)
Process the Source into a Templates object, which is a a compiled representation of the source.
abstract  Transformer newTransformer()
Create a new Transformer object that performs a copy of the source to the result.
abstract  Transformer newTransformer(Source source)
Process the Source into a Transformer object.
abstract  void setAttribute(String name, Object value)
Allows the user to set specific attributes on the underlying implementation.
abstract  void setErrorListener(ErrorListener listener)
Set the error event listener for the TransformerFactory, which is used for the processing of transformation instructions, and not for the transformation itself.
abstract  void setURIResolver(URIResolver resolver)
Set an object that is used by default during the transformation to resolve URIs used in xsl:import, or xsl:include.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TransformerFactory

protected TransformerFactory()
Default constructor is protected on purpose.

Method Detail

newInstance

public static TransformerFactory newInstance()
                                      throws TransformerFactoryConfigurationError
Obtain a new instance of a TransformerFactory. This static method creates a new factory instance This method uses the following ordered lookup procedure to determine the TransformerFactory implementation class to load:
  • Use the javax.xml.transform.TransformerFactory system property.
  • Use the properties file "lib/jaxp.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
  • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.transform.TransformerFactory in jars available to the runtime.
  • Platform default TransformerFactory instance.
Once an application has obtained a reference to a TransformerFactory it can use the factory to configure and obtain parser instances.

Returns:
new TransformerFactory instance, never null.
Throws:
TransformerFactoryConfigurationError - if the implmentation is not available or cannot be instantiated.

newTransformer

public abstract Transformer newTransformer(Source source)
                                    throws TransformerConfigurationException
Process the Source into a Transformer object. Care must be given not to use this object in multiple threads running concurrently. Different TransformerFactories can be used concurrently by different threads.

Parameters:
source - An object that holds a URI, input stream, etc.
Returns:
A Transformer object that may be used to perform a transformation in a single thread, never null.
Throws:
TransformerConfigurationException - May throw this during the parse when it is constructing the Templates object and fails.

newTransformer

public abstract Transformer newTransformer()
                                    throws TransformerConfigurationException
Create a new Transformer object that performs a copy of the source to the result.

Returns:
A Transformer object that may be used to perform a transformation in a single thread, never null.
Throws:
TransformerConfigurationException - May throw this during the parse when it is constructing the Templates object and fails.

newTemplates

public abstract Templates newTemplates(Source source)
                                throws TransformerConfigurationException
Process the Source into a Templates object, which is a a compiled representation of the source. This Templates object may then be used concurrently across multiple threads. Creating a Templates object allows the TransformerFactory to do detailed performance optimization of transformation instructions, without penalizing runtime transformation.

Parameters:
source - An object that holds a URL, input stream, etc.
Returns:
A Templates object capable of being used for transformation purposes, never null.
Throws:
TransformerConfigurationException - May throw this during the parse when it is constructing the Templates object and fails.

getAssociatedStylesheet

public abstract Source getAssociatedStylesheet(Source source,
                                               String media,
                                               String title,
                                               String charset)
                                        throws TransformerConfigurationException
Get the stylesheet specification(s) associated via the xml-stylesheet processing instruction (see http://www.w3.org/TR/xml-stylesheet/) with the document document specified in the source parameter, and that match the given criteria. Note that it is possible to return several stylesheets, in which case they are applied as if they were a list of imports or cascades in a single stylesheet.

Parameters:
source - The XML source document.
media - The media attribute to be matched. May be null, in which case the prefered templates will be used (i.e. alternate = no).
title - The value of the title attribute to match. May be null.
charset - The value of the charset attribute to match. May be null.
Returns:
A Source object suitable for passing to the TransformerFactory.
Throws:
TransformerConfigurationException.
TransformerConfigurationException

setURIResolver

public abstract void setURIResolver(URIResolver resolver)
Set an object that is used by default during the transformation to resolve URIs used in xsl:import, or xsl:include.

Parameters:
resolver - An object that implements the URIResolver interface, or null.

getURIResolver

public abstract URIResolver getURIResolver()
Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.

Returns:
The URIResolver that was set with setURIResolver.

getFeature

public abstract boolean getFeature(String name)
Look up the value of a feature.

The feature name is any absolute URI.

Parameters:
name - The feature name, which is an absolute URI.
Returns:
The current state of the feature (true or false).

setAttribute

public abstract void setAttribute(String name,
                                  Object value)
                           throws IllegalArgumentException
Allows the user to set specific attributes on the underlying implementation. An attribute in this context is defined to be an option that the implementation provides.

Parameters:
name - The name of the attribute.
value - The value of the attribute.
Throws:
IllegalArgumentException - thrown if the underlying implementation doesn't recognize the attribute.

getAttribute

public abstract Object getAttribute(String name)
                             throws IllegalArgumentException
Allows the user to retrieve specific attributes on the underlying implementation.

Parameters:
name - The name of the attribute.
Returns:
value The value of the attribute.
Throws:
IllegalArgumentException - thrown if the underlying implementation doesn't recognize the attribute.

setErrorListener

public abstract void setErrorListener(ErrorListener listener)
                               throws IllegalArgumentException
Set the error event listener for the TransformerFactory, which is used for the processing of transformation instructions, and not for the transformation itself.

Parameters:
listener - The new error listener.
Throws:
IllegalArgumentException - if listener is null.

getErrorListener

public abstract ErrorListener getErrorListener()
Get the error event handler for the TransformerFactory.

Returns:
The current error handler, which should never be null.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


TransformerFactoryConfigurationError

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Class TransformerFactoryConfigurationError

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Error
            extended by javax.xml.transform.TransformerFactoryConfigurationError
All Implemented Interfaces:
Serializable
public class TransformerFactoryConfigurationError
extends Error

Thrown when a problem with configuration with the Transformer Factories exists. This error will typically be thrown when the class of a transformation factory specified in the system properties cannot be found or instantiated.

See Also:
Serialized Form

Constructor Summary
TransformerFactoryConfigurationError()
Create a new TransformerFactoryConfigurationError with no detail mesage.
TransformerFactoryConfigurationError(Exception e)
Create a new TransformerFactoryConfigurationError with a given Exception base cause of the error.
TransformerFactoryConfigurationError(Exception e, String msg)
Create a new TransformerFactoryConfigurationError with the given Exception base cause and detail message.
TransformerFactoryConfigurationError(String msg)
Create a new TransformerFactoryConfigurationError with the String specified as an error message.
Method Summary
Exception | getException() Return the actual exception (if any) that caused this exception to be raised.
String | getMessage() Return the message (if any) for this error .
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransformerFactoryConfigurationError

public TransformerFactoryConfigurationError()
Create a new TransformerFactoryConfigurationError with no detail mesage.

TransformerFactoryConfigurationError

public TransformerFactoryConfigurationError(String msg)
Create a new TransformerFactoryConfigurationError with the String specified as an error message.

Parameters:
msg - The error message for the exception.

TransformerFactoryConfigurationError

public TransformerFactoryConfigurationError(Exception e)
Create a new TransformerFactoryConfigurationError with a given Exception base cause of the error.

Parameters:
e - The exception to be encapsulated in a TransformerFactoryConfigurationError.

TransformerFactoryConfigurationError

public TransformerFactoryConfigurationError(Exception e,
                                            String msg)
Create a new TransformerFactoryConfigurationError with the given Exception base cause and detail message.

Parameters:
e - The exception to be encapsulated in a TransformerFactoryConfigurationError
msg - The detail message.
Method Detail

getMessage

public String getMessage()
Return the message (if any) for this error . If there is no message for the exception and there is an encapsulated exception then the message of that exception will be returned.

Returns:
The error message.

getException

public Exception getException()
Return the actual exception (if any) that caused this exception to be raised.

Returns:
The encapsulated exception, or null if there is none.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


URIResolver

Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.transform
Interface URIResolver

public interface URIResolver

An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.

Method Summary
 Source resolve(String href, String base)
Called by the processor when it encounters an xsl:include, xsl:import, or document() function.

Method Detail

resolve

public Source resolve(String href,
                      String base)
               throws TransformerException
Called by the processor when it encounters an xsl:include, xsl:import, or document() function.

Parameters:
href - An href attribute, which may be relative or absolute.
base - The base URI in effect when the href attribute was encountered.
Returns:
A Source object, or null if the href cannot be resolved, and the processor should try to resolve the URI itself.
Throws:
TransformerException - if an error occurs when trying to resolve the URI.
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2003 Sun Microsystems, Inc. All rights reserved.


Overview

TM 2 Platform Enterprise Edition, v 1.4
API Specification">
JavaTM 2 Platform
Ent. Ed. v1.4
All Classes

Packages
javax.activation
javax.ejb
javax.ejb.spi
javax.enterprise.deploy.model
javax.enterprise.deploy.shared
javax.enterprise.deploy.shared.factories
javax.enterprise.deploy.spi
javax.enterprise.deploy.spi.exceptions
javax.enterprise.deploy.spi.factories
javax.enterprise.deploy.spi.status
javax.jms
javax.mail
javax.mail.event
javax.mail.internet
javax.mail.search
javax.management
javax.management.j2ee
javax.management.j2ee.statistics
javax.management.loading
javax.management.modelmbean
javax.management.monitor
javax.management.openmbean
javax.management.relation
javax.management.timer
javax.resource
javax.resource.cci
javax.resource.spi
javax.resource.spi.endpoint
javax.resource.spi.security
javax.resource.spi.work
javax.security.jacc
javax.servlet
javax.servlet.http
javax.servlet.jsp
javax.servlet.jsp.el
javax.servlet.jsp.tagext
javax.transaction
javax.transaction.xa
javax.xml.namespace
javax.xml.parsers
javax.xml.registry
javax.xml.registry.infomodel
javax.xml.rpc
javax.xml.rpc.encoding
javax.xml.rpc.handler
javax.xml.rpc.handler.soap
javax.xml.rpc.holders
javax.xml.rpc.server
javax.xml.rpc.soap
javax.xml.soap
javax.xml.transform
javax.xml.transform.dom
javax.xml.transform.sax
javax.xml.transform.stream


Java 2 SDK Enterprise Edition 1.4 Documentation

TM 2 Platform Enterprise Edition, v 1.4
API Specification">
Overview Package Class Tree Deprecated Index Help
JavaTM 2 Platform
Ent. Ed. v1.4
PREV NEXT FRAMES NO FRAMES

JavaTM 2 Platform Enterprise Edition, v 1.4
API Specification

Packages
javax.activation | The JavaBeans(TM) Activation Framework is used by the JavaMail(TM) API to manage MIME data.
javax.ejb | The javax.ejb package contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
javax.ejb.spi | The javax.ejb.spi package defines interfaces that are implemented by the EJB container.
javax.enterprise.deploy.model | Provides Tool Vendor implementation classes.
javax.enterprise.deploy.shared | Provides shared objects for Tool Vendor and Product Vendor implementation classes.
javax.enterprise.deploy.shared.factories | Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
javax.enterprise.deploy.spi | Provides J2EE Product Vendor implementation classes.
javax.enterprise.deploy.spi.exceptions | Provides J2EE Product Vendor deployment exception implementation classes.
javax.enterprise.deploy.spi.factories | Provides J2EE Product Vendor deployment factory implementation classes.
javax.enterprise.deploy.spi.status | Provides J2EE Product Vendor deployment status implementation classes.
javax.jms | The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.
javax.mail | Classes modeling a mail system.
javax.mail.event | Listeners and events for the JavaMail API.
javax.mail.internet | Classes specific to Internet mail systems.
javax.mail.search | Message search terms for the JavaMail API.
javax.management | Provides the core JMX classes.
javax.management.j2ee | Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.
javax.management.j2ee.statistics | Provides the standard interfaces for accessing performance data from J2EE managed objects Package Specification JSR 77, J2EE Management Related Documentation For overviews, tutorials, examples, guides, and tool documentation, please see: J2EE Tools


The front page has been relocated.Please see:
Frame version
Non-frame version.


Occurences of AccessLocalException (constructors)

AccessLocalException (constructors) occurences:
javax.ejb.AccessLocalException()
javax.ejb.AccessLocalException(java.lang.String)
javax.ejb.AccessLocalException(java.lang.String, java.lang.Exception)


Occurences of ActivationDataFlavor (constructors)

ActivationDataFlavor (constructors) occurences:
javax.activation.ActivationDataFlavor(java.lang.Class, java.lang.String)
javax.activation.ActivationDataFlavor(java.lang.Class, java.lang.String, java.lang.String)
javax.activation.ActivationDataFlavor(java.lang.String, java.lang.String)


Occurences of add

add occurences:
javax.mail.FetchProfile.add(java.lang.String)
javax.mail.FetchProfile.add(javax.mail.FetchProfile.Item)
javax.mail.Flags.add(java.lang.String)
javax.mail.Flags.add(javax.mail.Flags)
javax.mail.Flags.add(javax.mail.Flags.Flag)
javax.management.AttributeList.add(int, javax.management.Attribute)
javax.management.AttributeList.add(javax.management.Attribute)
javax.management.relation.RoleList.add(int, javax.management.relation.Role)
javax.management.relation.RoleList.add(javax.management.relation.Role)
javax.management.relation.RoleUnresolvedList.add(int, javax.management.relation.RoleUnresolved)
javax.management.relation.RoleUnresolvedList.add(javax.management.relation.RoleUnresolved)


Occurences of addAll

addAll occurences:
javax.management.AttributeList.addAll(int, javax.management.AttributeList)
javax.management.AttributeList.addAll(javax.management.AttributeList)
javax.management.relation.RoleList.addAll(int, javax.management.relation.RoleList)
javax.management.relation.RoleList.addAll(javax.management.relation.RoleList)
javax.management.relation.RoleUnresolvedList.addAll(int, javax.management.relation.RoleUnresolvedList)
javax.management.relation.RoleUnresolvedList.addAll(javax.management.relation.RoleUnresolvedList)


Occurences of addAttributeChangeNotificationListener

addAttributeChangeNotificationListener occurences:
javax.management.modelmbean.ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String, java.lang.Object)
javax.management.modelmbean.RequiredModelMBean.addAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String, java.lang.Object)


Occurences of addBodyPart

addBodyPart occurences:
javax.mail.Multipart.addBodyPart(javax.mail.BodyPart)
javax.mail.Multipart.addBodyPart(javax.mail.BodyPart, int)


Occurences of addChildConcept

addChildConcept occurences:
javax.xml.registry.infomodel.ClassificationScheme.addChildConcept(javax.xml.registry.infomodel.Concept)
javax.xml.registry.infomodel.Concept.addChildConcept(javax.xml.registry.infomodel.Concept)


Occurences of addChildConcepts

addChildConcepts occurences:
javax.xml.registry.infomodel.ClassificationScheme.addChildConcepts(java.util.Collection)
javax.xml.registry.infomodel.Concept.addChildConcepts(java.util.Collection)


Occurences of addChildElement

addChildElement occurences:
javax.xml.soap.SOAPElement.addChildElement(java.lang.String)
javax.xml.soap.SOAPElement.addChildElement(java.lang.String, java.lang.String)
javax.xml.soap.SOAPElement.addChildElement(java.lang.String, java.lang.String, java.lang.String)
javax.xml.soap.SOAPElement.addChildElement(javax.xml.soap.Name)
javax.xml.soap.SOAPElement.addChildElement(javax.xml.soap.SOAPElement)


Occurences of addConnectionListener

addConnectionListener occurences:
javax.mail.Folder.addConnectionListener(javax.mail.event.ConnectionListener)
javax.mail.Service.addConnectionListener(javax.mail.event.ConnectionListener)


Occurences of addCookie

addCookie occurences:
javax.servlet.http.HttpServletResponse.addCookie(javax.servlet.http.Cookie)
javax.servlet.http.HttpServletResponseWrapper.addCookie(javax.servlet.http.Cookie)


Occurences of addDateHeader

addDateHeader occurences:
javax.servlet.http.HttpServletResponse.addDateHeader(java.lang.String, long)
javax.servlet.http.HttpServletResponseWrapper.addDateHeader(java.lang.String, long)


Occurences of addFault

addFault occurences:
javax.xml.soap.SOAPBody.addFault()
javax.xml.soap.SOAPBody.addFault(javax.xml.soap.Name, java.lang.String)
javax.xml.soap.SOAPBody.addFault(javax.xml.soap.Name, java.lang.String, java.util.Locale)


Occurences of addFolderListener

addFolderListener occurences:
javax.mail.Folder.addFolderListener(javax.mail.event.FolderListener)
javax.mail.Store.addFolderListener(javax.mail.event.FolderListener)


Occurences of addFrom

addFrom occurences:
javax.mail.internet.MimeMessage.addFrom(javax.mail.Address[])
javax.mail.Message.addFrom(javax.mail.Address[])


Occurences of addHeader

addHeader occurences:
javax.mail.internet.InternetHeaders.addHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeBodyPart.addHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.addHeader(java.lang.String, java.lang.String)
javax.mail.Part.addHeader(java.lang.String, java.lang.String)
javax.servlet.http.HttpServletResponse.addHeader(java.lang.String, java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.addHeader(java.lang.String, java.lang.String)
javax.xml.soap.MimeHeaders.addHeader(java.lang.String, java.lang.String)
javax.xml.soap.SOAPEnvelope.addHeader()


Occurences of addHeaderLine

addHeaderLine occurences:
javax.mail.internet.InternetHeaders.addHeaderLine(java.lang.String)
javax.mail.internet.MimeBodyPart.addHeaderLine(java.lang.String)
javax.mail.internet.MimeMessage.addHeaderLine(java.lang.String)
javax.mail.internet.MimePart.addHeaderLine(java.lang.String)


Occurences of addIntHeader

addIntHeader occurences:
javax.servlet.http.HttpServletResponse.addIntHeader(java.lang.String, int)
javax.servlet.http.HttpServletResponseWrapper.addIntHeader(java.lang.String, int)


Occurences of addMimeHeader

addMimeHeader occurences:
javax.xml.soap.AttachmentPart.addMimeHeader(java.lang.String, java.lang.String)
javax.xml.soap.SOAPPart.addMimeHeader(java.lang.String, java.lang.String)


Occurences of addNotification

addNotification occurences:
javax.management.timer.Timer.addNotification(java.lang.String, java.lang.String, java.lang.Object, java.util.Date)
javax.management.timer.Timer.addNotification(java.lang.String, java.lang.String, java.lang.Object, java.util.Date, long)
javax.management.timer.Timer.addNotification(java.lang.String, java.lang.String, java.lang.Object, java.util.Date, long, long)
javax.management.timer.Timer.addNotification(java.lang.String, java.lang.String, java.lang.Object, java.util.Date, long, long, boolean)
javax.management.timer.TimerMBean.addNotification(java.lang.String, java.lang.String, java.lang.Object, java.util.Date)
javax.management.timer.TimerMBean.addNotification(java.lang.String, java.lang.String, java.lang.Object, java.util.Date, long)
javax.management.timer.TimerMBean.addNotification(java.lang.String, java.lang.String, java.lang.Object, java.util.Date, long, long)
javax.management.timer.TimerMBean.addNotification(java.lang.String, java.lang.String, java.lang.Object, java.util.Date, long, long, boolean)


Occurences of addNotificationListener

addNotificationListener occurences:
javax.management.j2ee.ListenerRegistration.addNotificationListener(javax.management.ObjectName, javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.MBeanServer.addNotificationListener(javax.management.ObjectName, javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.MBeanServer.addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, javax.management.NotificationFilter, java.lang.Object)
javax.management.MBeanServerConnection.addNotificationListener(javax.management.ObjectName, javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.MBeanServerConnection.addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, javax.management.NotificationFilter, java.lang.Object)
javax.management.MBeanServerDelegate.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.modelmbean.RequiredModelMBean.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.NotificationBroadcasterSupport.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)


Occurences of addObservedObject

addObservedObject occurences:
javax.management.monitor.Monitor.addObservedObject(javax.management.ObjectName)
javax.management.monitor.MonitorMBean.addObservedObject(javax.management.ObjectName)


Occurences of addParameter

addParameter occurences:
javax.xml.rpc.Call.addParameter(java.lang.String, javax.xml.namespace.QName, java.lang.Class, javax.xml.rpc.ParameterMode)
javax.xml.rpc.Call.addParameter(java.lang.String, javax.xml.namespace.QName, javax.xml.rpc.ParameterMode)


Occurences of addRecipients

addRecipients occurences:
javax.mail.internet.MimeMessage.addRecipients(javax.mail.Message.RecipientType, java.lang.String)
javax.mail.internet.MimeMessage.addRecipients(javax.mail.Message.RecipientType, javax.mail.Address[])
javax.mail.Message.addRecipients(javax.mail.Message.RecipientType, javax.mail.Address[])


Occurences of addRelation

addRelation occurences:
javax.management.relation.RelationService.addRelation(javax.management.ObjectName)
javax.management.relation.RelationServiceMBean.addRelation(javax.management.ObjectName)


Occurences of addRelationType

addRelationType occurences:
javax.management.relation.RelationService.addRelationType(javax.management.relation.RelationType)
javax.management.relation.RelationServiceMBean.addRelationType(javax.management.relation.RelationType)


Occurences of address

address occurences:
javax.mail.internet.address
javax.mail.search.address


Occurences of AddressException (constructors)

AddressException (constructors) occurences:
javax.mail.internet.AddressException()
javax.mail.internet.AddressException(java.lang.String)
javax.mail.internet.AddressException(java.lang.String, java.lang.String)
javax.mail.internet.AddressException(java.lang.String, java.lang.String, int)


Occurences of addToExcludedPolicy

addToExcludedPolicy occurences:
javax.security.jacc.PolicyConfiguration.addToExcludedPolicy(java.security.Permission)
javax.security.jacc.PolicyConfiguration.addToExcludedPolicy(java.security.PermissionCollection)


Occurences of addToRole

addToRole occurences:
javax.security.jacc.PolicyConfiguration.addToRole(java.lang.String, java.security.Permission)
javax.security.jacc.PolicyConfiguration.addToRole(java.lang.String, java.security.PermissionCollection)


Occurences of addToUncheckedPolicy

addToUncheckedPolicy occurences:
javax.security.jacc.PolicyConfiguration.addToUncheckedPolicy(java.security.Permission)
javax.security.jacc.PolicyConfiguration.addToUncheckedPolicy(java.security.PermissionCollection)


Occurences of addURL

addURL occurences:
javax.management.loading.MLet.addURL(java.lang.String)
javax.management.loading.MLet.addURL(java.net.URL)
javax.management.loading.MLetMBean.addURL(java.lang.String)
javax.management.loading.MLetMBean.addURL(java.net.URL)


Occurences of addXpathListener

addXpathListener occurences:
javax.enterprise.deploy.model.DDBean.addXpathListener(java.lang.String, javax.enterprise.deploy.model.XpathListener)
javax.enterprise.deploy.model.J2eeApplicationObject.addXpathListener(javax.enterprise.deploy.shared.ModuleType, java.lang.String, javax.enterprise.deploy.model.XpathListener)


Occurences of afterCompletion

afterCompletion occurences:
javax.ejb.SessionSynchronization.afterCompletion(boolean)
javax.transaction.Synchronization.afterCompletion(int)


Occurences of All Classes

All Classes occurences:
All Classes
All Classes


Occurences of AndTerm (constructors)

AndTerm (constructors) occurences:
javax.mail.search.AndTerm(javax.mail.search.SearchTerm, javax.mail.search.SearchTerm)
javax.mail.search.AndTerm(javax.mail.search.SearchTerm[])


Occurences of ApplicationServerInternalException (constructors)

ApplicationServerInternalException (constructors) occurences:
javax.resource.spi.ApplicationServerInternalException()
javax.resource.spi.ApplicationServerInternalException(java.lang.String)
javax.resource.spi.ApplicationServerInternalException(java.lang.String, java.lang.String)
javax.resource.spi.ApplicationServerInternalException(java.lang.String, java.lang.Throwable)
javax.resource.spi.ApplicationServerInternalException(java.lang.Throwable)


Occurences of apply

apply occurences:
javax.management.AttributeValueExp.apply(javax.management.ObjectName)
javax.management.ObjectName.apply(javax.management.ObjectName)
javax.management.QueryExp.apply(javax.management.ObjectName)
javax.management.StringValueExp.apply(javax.management.ObjectName)
javax.management.ValueExp.apply(javax.management.ObjectName)


Occurences of associateConnection

associateConnection occurences:
javax.resource.spi.LazyAssociatableConnectionManager.associateConnection(java.lang.Object, javax.resource.spi.ManagedConnectionFactory, javax.resource.spi.ConnectionRequestInfo)
javax.resource.spi.ManagedConnection.associateConnection(java.lang.Object)


Occurences of attr

attr occurences:
javax.management.Query.attr(java.lang.String)
javax.management.Query.attr(java.lang.String, java.lang.String)


Occurences of attributeAdded

attributeAdded occurences:
javax.servlet.http.HttpSessionAttributeListener.attributeAdded(javax.servlet.http.HttpSessionBindingEvent)
javax.servlet.ServletContextAttributeListener.attributeAdded(javax.servlet.ServletContextAttributeEvent)
javax.servlet.ServletRequestAttributeListener.attributeAdded(javax.servlet.ServletRequestAttributeEvent)


Occurences of AttributeList (constructors)

AttributeList (constructors) occurences:
javax.management.AttributeList()
javax.management.AttributeList(int)
javax.management.AttributeList(javax.management.AttributeList)


Occurences of AttributeNotFoundException (constructors)

AttributeNotFoundException (constructors) occurences:
javax.management.AttributeNotFoundException()
javax.management.AttributeNotFoundException(java.lang.String)


Occurences of attributeRemoved

attributeRemoved occurences:
javax.servlet.http.HttpSessionAttributeListener.attributeRemoved(javax.servlet.http.HttpSessionBindingEvent)
javax.servlet.ServletContextAttributeListener.attributeRemoved(javax.servlet.ServletContextAttributeEvent)
javax.servlet.ServletRequestAttributeListener.attributeRemoved(javax.servlet.ServletRequestAttributeEvent)


Occurences of attributeReplaced

attributeReplaced occurences:
javax.servlet.http.HttpSessionAttributeListener.attributeReplaced(javax.servlet.http.HttpSessionBindingEvent)
javax.servlet.ServletContextAttributeListener.attributeReplaced(javax.servlet.ServletContextAttributeEvent)
javax.servlet.ServletRequestAttributeListener.attributeReplaced(javax.servlet.ServletRequestAttributeEvent)


Occurences of AttributeValueExp (constructors)

AttributeValueExp (constructors) occurences:
javax.management.AttributeValueExp()
javax.management.AttributeValueExp(java.lang.String)


Occurences of AuthenticationFailedException (constructors)

AuthenticationFailedException (constructors) occurences:
javax.mail.AuthenticationFailedException()
javax.mail.AuthenticationFailedException(java.lang.String)


Occurences of beforeCompletion

beforeCompletion occurences:
javax.ejb.SessionSynchronization.beforeCompletion()
javax.transaction.Synchronization.beforeCompletion()


Occurences of begin

begin occurences:
javax.resource.cci.LocalTransaction.begin()
javax.resource.spi.LocalTransaction.begin()
javax.transaction.TransactionManager.begin()
javax.transaction.UserTransaction.begin()


Occurences of BigDecimalHolder (constructors)

BigDecimalHolder (constructors) occurences:
javax.xml.rpc.holders.BigDecimalHolder()
javax.xml.rpc.holders.BigDecimalHolder(java.math.BigDecimal)


Occurences of BigIntegerHolder (constructors)

BigIntegerHolder (constructors) occurences:
javax.xml.rpc.holders.BigIntegerHolder()
javax.xml.rpc.holders.BigIntegerHolder(java.math.BigInteger)


Occurences of BooleanHolder (constructors)

BooleanHolder (constructors) occurences:
javax.xml.rpc.holders.BooleanHolder()
javax.xml.rpc.holders.BooleanHolder(boolean)


Occurences of BooleanWrapperHolder (constructors)

BooleanWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.BooleanWrapperHolder()
javax.xml.rpc.holders.BooleanWrapperHolder(java.lang.Boolean)


Occurences of ByteArrayHolder (constructors)

ByteArrayHolder (constructors) occurences:
javax.xml.rpc.holders.ByteArrayHolder()
javax.xml.rpc.holders.ByteArrayHolder(byte[])


Occurences of ByteHolder (constructors)

ByteHolder (constructors) occurences:
javax.xml.rpc.holders.ByteHolder()
javax.xml.rpc.holders.ByteHolder(byte)


Occurences of ByteWrapperHolder (constructors)

ByteWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.ByteWrapperHolder()
javax.xml.rpc.holders.ByteWrapperHolder(java.lang.Byte)


Occurences of calculateIndex

calculateIndex occurences:
javax.management.openmbean.TabularData.calculateIndex(javax.management.openmbean.CompositeData)
javax.management.openmbean.TabularDataSupport.calculateIndex(javax.management.openmbean.CompositeData)


Occurences of CalendarHolder (constructors)

CalendarHolder (constructors) occurences:
javax.xml.rpc.holders.CalendarHolder()
javax.xml.rpc.holders.CalendarHolder(java.util.Calendar)


Occurences of cancel

cancel occurences:
javax.ejb.Timer.cancel()
javax.enterprise.deploy.spi.status.ProgressObject.cancel()


Occurences of checkRoleReading

checkRoleReading occurences:
javax.management.relation.RelationService.checkRoleReading(java.lang.String, java.lang.String)
javax.management.relation.RelationServiceMBean.checkRoleReading(java.lang.String, java.lang.String)


Occurences of checkRoleWriting

checkRoleWriting occurences:
javax.management.relation.RelationService.checkRoleWriting(javax.management.relation.Role, java.lang.String, java.lang.Boolean)
javax.management.relation.RelationServiceMBean.checkRoleWriting(javax.management.relation.Role, java.lang.String, java.lang.Boolean)


Occurences of clear

clear occurences:
javax.management.openmbean.TabularData.clear()
javax.management.openmbean.TabularDataSupport.clear()
javax.servlet.jsp.JspWriter.clear()
javax.xml.rpc.encoding.TypeMappingRegistry.clear()


Occurences of clearBody

clearBody occurences:
javax.jms.Message.clearBody()
javax.servlet.jsp.tagext.BodyContent.clearBody()


Occurences of ClientExecuteException (constructors)

ClientExecuteException (constructors) occurences:
javax.enterprise.deploy.spi.exceptions.ClientExecuteException()
javax.enterprise.deploy.spi.exceptions.ClientExecuteException(java.lang.String)


Occurences of clone

clone occurences:
javax.mail.Flags.clone()
javax.mail.internet.InternetAddress.clone()
javax.management.Descriptor.clone()
javax.management.MBeanAttributeInfo.clone()
javax.management.MBeanConstructorInfo.clone()
javax.management.MBeanInfo.clone()
javax.management.MBeanNotificationInfo.clone()
javax.management.MBeanOperationInfo.clone()
javax.management.MBeanParameterInfo.clone()
javax.management.modelmbean.DescriptorSupport.clone()
javax.management.modelmbean.ModelMBeanAttributeInfo.clone()
javax.management.modelmbean.ModelMBeanConstructorInfo.clone()
javax.management.modelmbean.ModelMBeanInfo.clone()
javax.management.modelmbean.ModelMBeanInfoSupport.clone()
javax.management.modelmbean.ModelMBeanNotificationInfo.clone()
javax.management.modelmbean.ModelMBeanOperationInfo.clone()
javax.management.openmbean.TabularDataSupport.clone()
javax.management.relation.Role.clone()
javax.management.relation.RoleUnresolved.clone()
javax.resource.cci.Record.clone()
javax.servlet.http.Cookie.clone()


Occurences of close

close occurences:
javax.jms.Connection.close()
javax.jms.ConnectionConsumer.close()
javax.jms.MessageConsumer.close()
javax.jms.MessageProducer.close()
javax.jms.QueueBrowser.close()
javax.jms.QueueRequestor.close()
javax.jms.Session.close()
javax.jms.TopicRequestor.close()
javax.mail.Folder.close(boolean)
javax.mail.Service.close()
javax.resource.cci.Connection.close()
javax.resource.cci.Interaction.close()
javax.servlet.jsp.JspWriter.close()
javax.xml.registry.Connection.close()
javax.xml.soap.SOAPConnection.close()


Occurences of closed

closed occurences:
javax.mail.event.ConnectionAdapter.closed(javax.mail.event.ConnectionEvent)
javax.mail.event.ConnectionListener.closed(javax.mail.event.ConnectionEvent)


Occurences of CommException (constructors)

CommException (constructors) occurences:
javax.resource.spi.CommException()
javax.resource.spi.CommException(java.lang.String)
javax.resource.spi.CommException(java.lang.String, java.lang.String)
javax.resource.spi.CommException(java.lang.String, java.lang.Throwable)
javax.resource.spi.CommException(java.lang.Throwable)


Occurences of commit

commit occurences:
javax.jms.Session.commit()
javax.jms.XASession.commit()
javax.resource.cci.LocalTransaction.commit()
javax.resource.spi.LocalTransaction.commit()
javax.resource.spi.XATerminator.commit(javax.transaction.xa.Xid, boolean)
javax.security.jacc.PolicyConfiguration.commit()
javax.transaction.Transaction.commit()
javax.transaction.TransactionManager.commit()
javax.transaction.UserTransaction.commit()
javax.transaction.xa.XAResource.commit(javax.transaction.xa.Xid, boolean)


Occurences of CompositeDataSupport (constructors)

CompositeDataSupport (constructors) occurences:
javax.management.openmbean.CompositeDataSupport(javax.management.openmbean.CompositeType, java.lang.String[], java.lang.Object[])
javax.management.openmbean.CompositeDataSupport(javax.management.openmbean.CompositeType, java.util.Map)


Occurences of ConfigurationException (constructors)

ConfigurationException (constructors) occurences:
javax.enterprise.deploy.spi.exceptions.ConfigurationException()
javax.enterprise.deploy.spi.exceptions.ConfigurationException(java.lang.String)


Occurences of connect

connect occurences:
javax.mail.Service.connect()
javax.mail.Service.connect(java.lang.String, int, java.lang.String, java.lang.String)
javax.mail.Service.connect(java.lang.String, java.lang.String, java.lang.String)


Occurences of Connection

Connection occurences:
javax.jms.Connection
javax.resource.cci.Connection
javax.xml.registry.Connection


Occurences of ConnectionEvent

ConnectionEvent occurences:
javax.mail.event.ConnectionEvent
javax.resource.spi.ConnectionEvent


Occurences of ConnectionEvent (constructors)

ConnectionEvent (constructors) occurences:
javax.mail.event.ConnectionEvent(java.lang.Object, int)
javax.resource.spi.ConnectionEvent(javax.resource.spi.ManagedConnection, int)
javax.resource.spi.ConnectionEvent(javax.resource.spi.ManagedConnection, int, java.lang.Exception)


Occurences of ConnectionFactory

ConnectionFactory occurences:
javax.jms.ConnectionFactory
javax.resource.cci.ConnectionFactory
javax.xml.registry.ConnectionFactory


Occurences of ConnectionMetaData

ConnectionMetaData occurences:
javax.jms.ConnectionMetaData
javax.resource.cci.ConnectionMetaData


Occurences of contains

contains occurences:
javax.mail.FetchProfile.contains(java.lang.String)
javax.mail.FetchProfile.contains(javax.mail.FetchProfile.Item)
javax.mail.Flags.contains(java.lang.String)
javax.mail.Flags.contains(javax.mail.Flags)
javax.mail.Flags.contains(javax.mail.Flags.Flag)


Occurences of containsHeader

containsHeader occurences:
javax.servlet.http.HttpServletResponse.containsHeader(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.containsHeader(java.lang.String)


Occurences of containsKey

containsKey occurences:
javax.management.openmbean.CompositeData.containsKey(java.lang.String)
javax.management.openmbean.CompositeDataSupport.containsKey(java.lang.String)
javax.management.openmbean.CompositeType.containsKey(java.lang.String)
javax.management.openmbean.TabularData.containsKey(java.lang.Object[])
javax.management.openmbean.TabularDataSupport.containsKey(java.lang.Object)
javax.management.openmbean.TabularDataSupport.containsKey(java.lang.Object[])


Occurences of containsObservedObject

containsObservedObject occurences:
javax.management.monitor.Monitor.containsObservedObject(javax.management.ObjectName)
javax.management.monitor.MonitorMBean.containsObservedObject(javax.management.ObjectName)


Occurences of containsValue

containsValue occurences:
javax.management.openmbean.CompositeData.containsValue(java.lang.Object)
javax.management.openmbean.CompositeDataSupport.containsValue(java.lang.Object)
javax.management.openmbean.TabularData.containsValue(javax.management.openmbean.CompositeData)
javax.management.openmbean.TabularDataSupport.containsValue(java.lang.Object)
javax.management.openmbean.TabularDataSupport.containsValue(javax.management.openmbean.CompositeData)


Occurences of content

content occurences:
javax.mail.internet.content
javax.mail.internet.content


Occurences of ContentDisposition (constructors)

ContentDisposition (constructors) occurences:
javax.mail.internet.ContentDisposition()
javax.mail.internet.ContentDisposition(java.lang.String)
javax.mail.internet.ContentDisposition(java.lang.String, javax.mail.internet.ParameterList)


Occurences of contentStream

contentStream occurences:
javax.mail.internet.contentStream
javax.mail.internet.contentStream


Occurences of ContentType (constructors)

ContentType (constructors) occurences:
javax.mail.internet.ContentType()
javax.mail.internet.ContentType(java.lang.String)
javax.mail.internet.ContentType(java.lang.String, java.lang.String, javax.mail.internet.ParameterList)


Occurences of create

create occurences:
javax.mail.Folder.create(int)
javax.management.j2ee.ManagementHome.create()
javax.xml.soap.SOAPElementFactory.create(java.lang.String)
javax.xml.soap.SOAPElementFactory.create(java.lang.String, java.lang.String, java.lang.String)
javax.xml.soap.SOAPElementFactory.create(javax.xml.soap.Name)


Occurences of createAttachmentPart

createAttachmentPart occurences:
javax.xml.soap.SOAPMessage.createAttachmentPart()
javax.xml.soap.SOAPMessage.createAttachmentPart(java.lang.Object, java.lang.String)
javax.xml.soap.SOAPMessage.createAttachmentPart(javax.activation.DataHandler)


Occurences of createBrowser

createBrowser occurences:
javax.jms.QueueSession.createBrowser(javax.jms.Queue)
javax.jms.QueueSession.createBrowser(javax.jms.Queue, java.lang.String)
javax.jms.Session.createBrowser(javax.jms.Queue)
javax.jms.Session.createBrowser(javax.jms.Queue, java.lang.String)


Occurences of createCall

createCall occurences:
javax.xml.rpc.Service.createCall()
javax.xml.rpc.Service.createCall(javax.xml.namespace.QName)
javax.xml.rpc.Service.createCall(javax.xml.namespace.QName, java.lang.String)
javax.xml.rpc.Service.createCall(javax.xml.namespace.QName, javax.xml.namespace.QName)


Occurences of createClassification

createClassification occurences:
javax.xml.registry.LifeCycleManager.createClassification(javax.xml.registry.infomodel.ClassificationScheme, java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createClassification(javax.xml.registry.infomodel.ClassificationScheme, javax.xml.registry.infomodel.InternationalString, java.lang.String)
javax.xml.registry.LifeCycleManager.createClassification(javax.xml.registry.infomodel.Concept)


Occurences of createClassificationScheme

createClassificationScheme occurences:
javax.xml.registry.LifeCycleManager.createClassificationScheme(java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createClassificationScheme(javax.xml.registry.infomodel.Concept)
javax.xml.registry.LifeCycleManager.createClassificationScheme(javax.xml.registry.infomodel.InternationalString, javax.xml.registry.infomodel.InternationalString)


Occurences of createConcept

createConcept occurences:
javax.xml.registry.LifeCycleManager.createConcept(javax.xml.registry.infomodel.RegistryObject, java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createConcept(javax.xml.registry.infomodel.RegistryObject, javax.xml.registry.infomodel.InternationalString, java.lang.String)


Occurences of createConnection

createConnection occurences:
javax.jms.ConnectionFactory.createConnection()
javax.jms.ConnectionFactory.createConnection(java.lang.String, java.lang.String)
javax.xml.registry.ConnectionFactory.createConnection()
javax.xml.soap.SOAPConnectionFactory.createConnection()


Occurences of createConnectionConsumer

createConnectionConsumer occurences:
javax.jms.Connection.createConnectionConsumer(javax.jms.Destination, java.lang.String, javax.jms.ServerSessionPool, int)
javax.jms.QueueConnection.createConnectionConsumer(javax.jms.Queue, java.lang.String, javax.jms.ServerSessionPool, int)
javax.jms.TopicConnection.createConnectionConsumer(javax.jms.Topic, java.lang.String, javax.jms.ServerSessionPool, int)


Occurences of createConnectionFactory

createConnectionFactory occurences:
javax.resource.spi.ManagedConnectionFactory.createConnectionFactory()
javax.resource.spi.ManagedConnectionFactory.createConnectionFactory(javax.resource.spi.ConnectionManager)


Occurences of createConsumer

createConsumer occurences:
javax.jms.Session.createConsumer(javax.jms.Destination)
javax.jms.Session.createConsumer(javax.jms.Destination, java.lang.String)
javax.jms.Session.createConsumer(javax.jms.Destination, java.lang.String, boolean)


Occurences of createDataContentHandler

createDataContentHandler occurences:
javax.activation.CommandMap.createDataContentHandler(java.lang.String)
javax.activation.DataContentHandlerFactory.createDataContentHandler(java.lang.String)
javax.activation.MailcapCommandMap.createDataContentHandler(java.lang.String)


Occurences of createDurableConnectionConsumer

createDurableConnectionConsumer occurences:
javax.jms.Connection.createDurableConnectionConsumer(javax.jms.Topic, java.lang.String, java.lang.String, javax.jms.ServerSessionPool, int)
javax.jms.TopicConnection.createDurableConnectionConsumer(javax.jms.Topic, java.lang.String, java.lang.String, javax.jms.ServerSessionPool, int)


Occurences of createDurableSubscriber

createDurableSubscriber occurences:
javax.jms.Session.createDurableSubscriber(javax.jms.Topic, java.lang.String)
javax.jms.Session.createDurableSubscriber(javax.jms.Topic, java.lang.String, java.lang.String, boolean)
javax.jms.TopicSession.createDurableSubscriber(javax.jms.Topic, java.lang.String)
javax.jms.TopicSession.createDurableSubscriber(javax.jms.Topic, java.lang.String, java.lang.String, boolean)


Occurences of createElement

createElement occurences:
javax.xml.soap.SOAPFactory.createElement(java.lang.String)
javax.xml.soap.SOAPFactory.createElement(java.lang.String, java.lang.String, java.lang.String)
javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name)


Occurences of createEmailAddress

createEmailAddress occurences:
javax.xml.registry.LifeCycleManager.createEmailAddress(java.lang.String)
javax.xml.registry.LifeCycleManager.createEmailAddress(java.lang.String, java.lang.String)


Occurences of CreateException (constructors)

CreateException (constructors) occurences:
javax.ejb.CreateException()
javax.ejb.CreateException(java.lang.String)


Occurences of createExternalIdentifier

createExternalIdentifier occurences:
javax.xml.registry.LifeCycleManager.createExternalIdentifier(javax.xml.registry.infomodel.ClassificationScheme, java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createExternalIdentifier(javax.xml.registry.infomodel.ClassificationScheme, javax.xml.registry.infomodel.InternationalString, java.lang.String)


Occurences of createExternalLink

createExternalLink occurences:
javax.xml.registry.LifeCycleManager.createExternalLink(java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createExternalLink(java.lang.String, javax.xml.registry.infomodel.InternationalString)


Occurences of createInternationalString

createInternationalString occurences:
javax.xml.registry.LifeCycleManager.createInternationalString()
javax.xml.registry.LifeCycleManager.createInternationalString(java.lang.String)
javax.xml.registry.LifeCycleManager.createInternationalString(java.util.Locale, java.lang.String)


Occurences of createInternetHeaders

createInternetHeaders occurences:
javax.mail.internet.MimeMessage.createInternetHeaders(java.io.InputStream)
javax.mail.internet.MimeMultipart.createInternetHeaders(java.io.InputStream)


Occurences of createLocalizedString

createLocalizedString occurences:
javax.xml.registry.LifeCycleManager.createLocalizedString(java.util.Locale, java.lang.String)
javax.xml.registry.LifeCycleManager.createLocalizedString(java.util.Locale, java.lang.String, java.lang.String)


Occurences of createMBean

createMBean occurences:
javax.management.MBeanServer.createMBean(java.lang.String, javax.management.ObjectName)
javax.management.MBeanServer.createMBean(java.lang.String, javax.management.ObjectName, java.lang.Object[], java.lang.String[])
javax.management.MBeanServer.createMBean(java.lang.String, javax.management.ObjectName, javax.management.ObjectName)
javax.management.MBeanServer.createMBean(java.lang.String, javax.management.ObjectName, javax.management.ObjectName, java.lang.Object[], java.lang.String[])
javax.management.MBeanServerConnection.createMBean(java.lang.String, javax.management.ObjectName)
javax.management.MBeanServerConnection.createMBean(java.lang.String, javax.management.ObjectName, java.lang.Object[], java.lang.String[])
javax.management.MBeanServerConnection.createMBean(java.lang.String, javax.management.ObjectName, javax.management.ObjectName)
javax.management.MBeanServerConnection.createMBean(java.lang.String, javax.management.ObjectName, javax.management.ObjectName, java.lang.Object[], java.lang.String[])


Occurences of createMBeanServer

createMBeanServer occurences:
javax.management.MBeanServerFactory.createMBeanServer()
javax.management.MBeanServerFactory.createMBeanServer(java.lang.String)


Occurences of createMessage

createMessage occurences:
javax.jms.Session.createMessage()
javax.xml.soap.MessageFactory.createMessage()
javax.xml.soap.MessageFactory.createMessage(javax.xml.soap.MimeHeaders, java.io.InputStream)


Occurences of createMimeBodyPart

createMimeBodyPart occurences:
javax.mail.internet.MimeMultipart.createMimeBodyPart(java.io.InputStream)
javax.mail.internet.MimeMultipart.createMimeBodyPart(javax.mail.internet.InternetHeaders, byte[])


Occurences of createName

createName occurences:
javax.xml.soap.SOAPEnvelope.createName(java.lang.String)
javax.xml.soap.SOAPEnvelope.createName(java.lang.String, java.lang.String, java.lang.String)
javax.xml.soap.SOAPFactory.createName(java.lang.String)
javax.xml.soap.SOAPFactory.createName(java.lang.String, java.lang.String, java.lang.String)


Occurences of createObjectMessage

createObjectMessage occurences:
javax.jms.Session.createObjectMessage()
javax.jms.Session.createObjectMessage(java.io.Serializable)


Occurences of createOrganization

createOrganization occurences:
javax.xml.registry.LifeCycleManager.createOrganization(java.lang.String)
javax.xml.registry.LifeCycleManager.createOrganization(javax.xml.registry.infomodel.InternationalString)


Occurences of createPersonName

createPersonName occurences:
javax.xml.registry.LifeCycleManager.createPersonName(java.lang.String)
javax.xml.registry.LifeCycleManager.createPersonName(java.lang.String, java.lang.String, java.lang.String)


Occurences of createQueue

createQueue occurences:
javax.jms.QueueSession.createQueue(java.lang.String)
javax.jms.Session.createQueue(java.lang.String)


Occurences of createQueueConnection

createQueueConnection occurences:
javax.jms.QueueConnectionFactory.createQueueConnection()
javax.jms.QueueConnectionFactory.createQueueConnection(java.lang.String, java.lang.String)


Occurences of createQueueSession

createQueueSession occurences:
javax.jms.QueueConnection.createQueueSession(boolean, int)
javax.jms.XAQueueConnection.createQueueSession(boolean, int)


Occurences of createReceiver

createReceiver occurences:
javax.jms.QueueSession.createReceiver(javax.jms.Queue)
javax.jms.QueueSession.createReceiver(javax.jms.Queue, java.lang.String)


Occurences of createRegistryPackage

createRegistryPackage occurences:
javax.xml.registry.LifeCycleManager.createRegistryPackage(java.lang.String)
javax.xml.registry.LifeCycleManager.createRegistryPackage(javax.xml.registry.infomodel.InternationalString)


Occurences of createRelation

createRelation occurences:
javax.management.relation.RelationService.createRelation(java.lang.String, java.lang.String, javax.management.relation.RoleList)
javax.management.relation.RelationServiceMBean.createRelation(java.lang.String, java.lang.String, javax.management.relation.RoleList)


Occurences of createRelationType

createRelationType occurences:
javax.management.relation.RelationService.createRelationType(java.lang.String, javax.management.relation.RoleInfo[])
javax.management.relation.RelationServiceMBean.createRelationType(java.lang.String, javax.management.relation.RoleInfo[])


Occurences of createService

createService occurences:
javax.xml.registry.LifeCycleManager.createService(java.lang.String)
javax.xml.registry.LifeCycleManager.createService(javax.xml.registry.infomodel.InternationalString)
javax.xml.rpc.ServiceFactory.createService(java.net.URL, javax.xml.namespace.QName)
javax.xml.rpc.ServiceFactory.createService(javax.xml.namespace.QName)


Occurences of createSession

createSession occurences:
javax.jms.Connection.createSession(boolean, int)
javax.jms.XAConnection.createSession(boolean, int)


Occurences of createSlot

createSlot occurences:
javax.xml.registry.LifeCycleManager.createSlot(java.lang.String, java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createSlot(java.lang.String, java.util.Collection, java.lang.String)


Occurences of createSubscriber

createSubscriber occurences:
javax.jms.TopicSession.createSubscriber(javax.jms.Topic)
javax.jms.TopicSession.createSubscriber(javax.jms.Topic, java.lang.String, boolean)


Occurences of createTemporaryQueue

createTemporaryQueue occurences:
javax.jms.QueueSession.createTemporaryQueue()
javax.jms.Session.createTemporaryQueue()


Occurences of createTemporaryTopic

createTemporaryTopic occurences:
javax.jms.Session.createTemporaryTopic()
javax.jms.TopicSession.createTemporaryTopic()


Occurences of createTextMessage

createTextMessage occurences:
javax.jms.Session.createTextMessage()
javax.jms.Session.createTextMessage(java.lang.String)


Occurences of createTimer

createTimer occurences:
javax.ejb.TimerService.createTimer(java.util.Date, java.io.Serializable)
javax.ejb.TimerService.createTimer(java.util.Date, long, java.io.Serializable)
javax.ejb.TimerService.createTimer(long, java.io.Serializable)
javax.ejb.TimerService.createTimer(long, long, java.io.Serializable)
javax.resource.spi.BootstrapContext.createTimer()


Occurences of createTopic

createTopic occurences:
javax.jms.Session.createTopic(java.lang.String)
javax.jms.TopicSession.createTopic(java.lang.String)


Occurences of createTopicConnection

createTopicConnection occurences:
javax.jms.TopicConnectionFactory.createTopicConnection()
javax.jms.TopicConnectionFactory.createTopicConnection(java.lang.String, java.lang.String)


Occurences of createTopicSession

createTopicSession occurences:
javax.jms.TopicConnection.createTopicSession(boolean, int)
javax.jms.XATopicConnection.createTopicSession(boolean, int)


Occurences of createXAConnection

createXAConnection occurences:
javax.jms.XAConnectionFactory.createXAConnection()
javax.jms.XAConnectionFactory.createXAConnection(java.lang.String, java.lang.String)


Occurences of createXAQueueConnection

createXAQueueConnection occurences:
javax.jms.XAQueueConnectionFactory.createXAQueueConnection()
javax.jms.XAQueueConnectionFactory.createXAQueueConnection(java.lang.String, java.lang.String)


Occurences of createXATopicConnection

createXATopicConnection occurences:
javax.jms.XATopicConnectionFactory.createXATopicConnection()
javax.jms.XATopicConnectionFactory.createXATopicConnection(java.lang.String, java.lang.String)


Occurences of DataHandler (constructors)

DataHandler (constructors) occurences:
javax.activation.DataHandler(java.lang.Object, java.lang.String)
javax.activation.DataHandler(java.net.URL)
javax.activation.DataHandler(javax.activation.DataSource)


Occurences of DefaultLoaderRepository

DefaultLoaderRepository occurences:
javax.management.DefaultLoaderRepository
javax.management.loading.DefaultLoaderRepository


Occurences of DefaultLoaderRepository (constructors)

DefaultLoaderRepository (constructors) occurences:
javax.management.DefaultLoaderRepository()
javax.management.loading.DefaultLoaderRepository()


Occurences of delete

delete occurences:
javax.jms.TemporaryQueue.delete()
javax.jms.TemporaryTopic.delete()
javax.mail.Folder.delete(boolean)
javax.security.jacc.PolicyConfiguration.delete()


Occurences of DELETED

DELETED occurences:
javax.mail.DELETED
javax.mail.event.DELETED


Occurences of DeleteException (constructors)

DeleteException (constructors) occurences:
javax.xml.registry.DeleteException()
javax.xml.registry.DeleteException(java.lang.String)
javax.xml.registry.DeleteException(java.lang.String, java.lang.Throwable)
javax.xml.registry.DeleteException(java.lang.Throwable)


Occurences of deleteObjects

deleteObjects occurences:
javax.xml.registry.LifeCycleManager.deleteObjects(java.util.Collection)
javax.xml.registry.LifeCycleManager.deleteObjects(java.util.Collection, java.lang.String)


Occurences of DescriptorSupport (constructors)

DescriptorSupport (constructors) occurences:
javax.management.modelmbean.DescriptorSupport()
javax.management.modelmbean.DescriptorSupport(int)
javax.management.modelmbean.DescriptorSupport(java.lang.String)
javax.management.modelmbean.DescriptorSupport(java.lang.String[])
javax.management.modelmbean.DescriptorSupport(java.lang.String[], java.lang.Object[])
javax.management.modelmbean.DescriptorSupport(javax.management.modelmbean.DescriptorSupport)


Occurences of deserialize

deserialize occurences:
javax.management.MBeanServer.deserialize(java.lang.String, byte[])
javax.management.MBeanServer.deserialize(java.lang.String, javax.management.ObjectName, byte[])
javax.management.MBeanServer.deserialize(javax.management.ObjectName, byte[])


Occurences of destroy

destroy occurences:
javax.resource.spi.ManagedConnection.destroy()
javax.servlet.Filter.destroy()
javax.servlet.GenericServlet.destroy()
javax.servlet.Servlet.destroy()
javax.xml.rpc.handler.GenericHandler.destroy()
javax.xml.rpc.handler.Handler.destroy()
javax.xml.rpc.handler.HandlerChain.destroy()
javax.xml.rpc.server.ServiceLifecycle.destroy()


Occurences of dh

dh occurences:
javax.mail.internet.dh
javax.mail.internet.dh


Occurences of disconnected

disconnected occurences:
javax.mail.event.ConnectionAdapter.disconnected(javax.mail.event.ConnectionEvent)
javax.mail.event.ConnectionListener.disconnected(javax.mail.event.ConnectionEvent)


Occurences of dispatch

dispatch occurences:
javax.mail.event.ConnectionEvent.dispatch(java.lang.Object)
javax.mail.event.FolderEvent.dispatch(java.lang.Object)
javax.mail.event.MailEvent.dispatch(java.lang.Object)
javax.mail.event.MessageChangedEvent.dispatch(java.lang.Object)
javax.mail.event.MessageCountEvent.dispatch(java.lang.Object)
javax.mail.event.StoreEvent.dispatch(java.lang.Object)
javax.mail.event.TransportEvent.dispatch(java.lang.Object)


Occurences of distribute

distribute occurences:
javax.enterprise.deploy.spi.DeploymentManager.distribute(javax.enterprise.deploy.spi.Target[], java.io.File, java.io.File)
javax.enterprise.deploy.spi.DeploymentManager.distribute(javax.enterprise.deploy.spi.Target[], java.io.InputStream, java.io.InputStream)


Occurences of doAfterBody

doAfterBody occurences:
javax.servlet.jsp.tagext.BodyTagSupport.doAfterBody()
javax.servlet.jsp.tagext.IterationTag.doAfterBody()
javax.servlet.jsp.tagext.TagSupport.doAfterBody()


Occurences of doEndTag

doEndTag occurences:
javax.servlet.jsp.tagext.BodyTagSupport.doEndTag()
javax.servlet.jsp.tagext.Tag.doEndTag()
javax.servlet.jsp.tagext.TagAdapter.doEndTag()
javax.servlet.jsp.tagext.TagSupport.doEndTag()


Occurences of doFilter

doFilter occurences:
javax.servlet.Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)
javax.servlet.FilterChain.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse)


Occurences of doInitBody

doInitBody occurences:
javax.servlet.jsp.tagext.BodyTag.doInitBody()
javax.servlet.jsp.tagext.BodyTagSupport.doInitBody()


Occurences of DOMResult (constructors)

DOMResult (constructors) occurences:
javax.xml.transform.dom.DOMResult()
javax.xml.transform.dom.DOMResult(org.w3c.dom.Node)
javax.xml.transform.dom.DOMResult(org.w3c.dom.Node, java.lang.String)


Occurences of DOMSource (constructors)

DOMSource (constructors) occurences:
javax.xml.transform.dom.DOMSource()
javax.xml.transform.dom.DOMSource(org.w3c.dom.Node)
javax.xml.transform.dom.DOMSource(org.w3c.dom.Node, java.lang.String)


Occurences of doStartTag

doStartTag occurences:
javax.servlet.jsp.tagext.BodyTagSupport.doStartTag()
javax.servlet.jsp.tagext.Tag.doStartTag()
javax.servlet.jsp.tagext.TagAdapter.doStartTag()
javax.servlet.jsp.tagext.TagSupport.doStartTag()


Occurences of doTag

doTag occurences:
javax.servlet.jsp.tagext.SimpleTag.doTag()
javax.servlet.jsp.tagext.SimpleTagSupport.doTag()


Occurences of DoubleHolder (constructors)

DoubleHolder (constructors) occurences:
javax.xml.rpc.holders.DoubleHolder()
javax.xml.rpc.holders.DoubleHolder(double)


Occurences of DoubleWrapperHolder (constructors)

DoubleWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.DoubleWrapperHolder()
javax.xml.rpc.holders.DoubleWrapperHolder(java.lang.Double)


Occurences of doWork

doWork occurences:
javax.resource.spi.work.WorkManager.doWork(javax.resource.spi.work.Work)
javax.resource.spi.work.WorkManager.doWork(javax.resource.spi.work.Work, long, javax.resource.spi.work.ExecutionContext, javax.resource.spi.work.WorkListener)


Occurences of DuplicateKeyException (constructors)

DuplicateKeyException (constructors) occurences:
javax.ejb.DuplicateKeyException()
javax.ejb.DuplicateKeyException(java.lang.String)


Occurences of EISSystemException (constructors)

EISSystemException (constructors) occurences:
javax.resource.spi.EISSystemException()
javax.resource.spi.EISSystemException(java.lang.String)
javax.resource.spi.EISSystemException(java.lang.String, java.lang.String)
javax.resource.spi.EISSystemException(java.lang.String, java.lang.Throwable)
javax.resource.spi.EISSystemException(java.lang.Throwable)


Occurences of ejbActivate

ejbActivate occurences:
javax.ejb.EntityBean.ejbActivate()
javax.ejb.SessionBean.ejbActivate()


Occurences of EJBException (constructors)

EJBException (constructors) occurences:
javax.ejb.EJBException()
javax.ejb.EJBException(java.lang.Exception)
javax.ejb.EJBException(java.lang.String)
javax.ejb.EJBException(java.lang.String, java.lang.Exception)


Occurences of EJBMethodPermission (constructors)

EJBMethodPermission (constructors) occurences:
javax.security.jacc.EJBMethodPermission(java.lang.String, java.lang.String)
javax.security.jacc.EJBMethodPermission(java.lang.String, java.lang.String, java.lang.reflect.Method)
javax.security.jacc.EJBMethodPermission(java.lang.String, java.lang.String, java.lang.String, java.lang.String[])


Occurences of ejbPassivate

ejbPassivate occurences:
javax.ejb.EntityBean.ejbPassivate()
javax.ejb.SessionBean.ejbPassivate()


Occurences of ejbRemove

ejbRemove occurences:
javax.ejb.EntityBean.ejbRemove()
javax.ejb.MessageDrivenBean.ejbRemove()
javax.ejb.SessionBean.ejbRemove()


Occurences of ELException (constructors)

ELException (constructors) occurences:
javax.servlet.jsp.el.ELException()
javax.servlet.jsp.el.ELException(java.lang.String)
javax.servlet.jsp.el.ELException(java.lang.String, java.lang.Throwable)
javax.servlet.jsp.el.ELException(java.lang.Throwable)


Occurences of ELParseException (constructors)

ELParseException (constructors) occurences:
javax.servlet.jsp.el.ELParseException()
javax.servlet.jsp.el.ELParseException(java.lang.String)


Occurences of encode

encode occurences:
javax.mail.internet.MimeUtility.encode(java.io.OutputStream, java.lang.String)
javax.mail.internet.MimeUtility.encode(java.io.OutputStream, java.lang.String, java.lang.String)


Occurences of encodeRedirectUrl

encodeRedirectUrl occurences:
javax.servlet.http.HttpServletResponse.encodeRedirectUrl(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.encodeRedirectUrl(java.lang.String)


Occurences of encodeRedirectURL

encodeRedirectURL occurences:
javax.servlet.http.HttpServletResponse.encodeRedirectURL(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.encodeRedirectURL(java.lang.String)


Occurences of encodeText

encodeText occurences:
javax.mail.internet.MimeUtility.encodeText(java.lang.String)
javax.mail.internet.MimeUtility.encodeText(java.lang.String, java.lang.String, java.lang.String)


Occurences of encodeURL

encodeURL occurences:
javax.servlet.http.HttpServletResponse.encodeURL(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.encodeURL(java.lang.String)


Occurences of encodeUrl

encodeUrl occurences:
javax.servlet.http.HttpServletResponse.encodeUrl(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.encodeUrl(java.lang.String)


Occurences of encodeWord

encodeWord occurences:
javax.mail.internet.MimeUtility.encodeWord(java.lang.String)
javax.mail.internet.MimeUtility.encodeWord(java.lang.String, java.lang.String, java.lang.String)


Occurences of EQ

EQ occurences:
javax.mail.search.EQ
javax.management.EQ


Occurences of equals

equals occurences:
javax.activation.ActivationDataFlavor.equals(java.awt.datatransfer.DataFlavor)
javax.mail.Address.equals(java.lang.Object)
javax.mail.Flags.equals(java.lang.Object)
javax.mail.internet.InternetAddress.equals(java.lang.Object)
javax.mail.internet.NewsAddress.equals(java.lang.Object)
javax.mail.search.AddressStringTerm.equals(java.lang.Object)
javax.mail.search.AddressTerm.equals(java.lang.Object)
javax.mail.search.AndTerm.equals(java.lang.Object)
javax.mail.search.BodyTerm.equals(java.lang.Object)
javax.mail.search.ComparisonTerm.equals(java.lang.Object)
javax.mail.search.DateTerm.equals(java.lang.Object)
javax.mail.search.FlagTerm.equals(java.lang.Object)
javax.mail.search.FromStringTerm.equals(java.lang.Object)
javax.mail.search.FromTerm.equals(java.lang.Object)
javax.mail.search.HeaderTerm.equals(java.lang.Object)
javax.mail.search.IntegerComparisonTerm.equals(java.lang.Object)
javax.mail.search.MessageIDTerm.equals(java.lang.Object)
javax.mail.search.MessageNumberTerm.equals(java.lang.Object)
javax.mail.search.NotTerm.equals(java.lang.Object)
javax.mail.search.OrTerm.equals(java.lang.Object)
javax.mail.search.ReceivedDateTerm.equals(java.lang.Object)
javax.mail.search.RecipientStringTerm.equals(java.lang.Object)
javax.mail.search.RecipientTerm.equals(java.lang.Object)
javax.mail.search.SentDateTerm.equals(java.lang.Object)
javax.mail.search.SizeTerm.equals(java.lang.Object)
javax.mail.search.StringTerm.equals(java.lang.Object)
javax.mail.search.SubjectTerm.equals(java.lang.Object)
javax.mail.URLName.equals(java.lang.Object)
javax.management.Attribute.equals(java.lang.Object)
javax.management.MBeanAttributeInfo.equals(java.lang.Object)
javax.management.MBeanConstructorInfo.equals(java.lang.Object)
javax.management.MBeanFeatureInfo.equals(java.lang.Object)
javax.management.MBeanInfo.equals(java.lang.Object)
javax.management.MBeanNotificationInfo.equals(java.lang.Object)
javax.management.MBeanOperationInfo.equals(java.lang.Object)
javax.management.MBeanParameterInfo.equals(java.lang.Object)
javax.management.MBeanPermission.equals(java.lang.Object)
javax.management.MBeanServerPermission.equals(java.lang.Object)
javax.management.ObjectInstance.equals(java.lang.Object)
javax.management.ObjectName.equals(java.lang.Object)
javax.management.openmbean.ArrayType.equals(java.lang.Object)
javax.management.openmbean.CompositeData.equals(java.lang.Object)
javax.management.openmbean.CompositeDataSupport.equals(java.lang.Object)
javax.management.openmbean.CompositeType.equals(java.lang.Object)
javax.management.openmbean.OpenMBeanAttributeInfo.equals(java.lang.Object)
javax.management.openmbean.OpenMBeanAttributeInfoSupport.equals(java.lang.Object)
javax.management.openmbean.OpenMBeanConstructorInfo.equals(java.lang.Object)
javax.management.openmbean.OpenMBeanConstructorInfoSupport.equals(java.lang.Object)
javax.management.openmbean.OpenMBeanInfo.equals(java.lang.Object)
javax.management.openmbean.OpenMBeanInfoSupport.equals(java.lang.Object)
javax.management.openmbean.OpenMBeanOperationInfo.equals(java.lang.Object)
javax.management.openmbean.OpenMBeanOperationInfoSupport.equals(java.lang.Object)
javax.management.openmbean.OpenMBeanParameterInfo.equals(java.lang.Object)
javax.management.openmbean.OpenMBeanParameterInfoSupport.equals(java.lang.Object)
javax.management.openmbean.OpenType.equals(java.lang.Object)
javax.management.openmbean.SimpleType.equals(java.lang.Object)
javax.management.openmbean.TabularData.equals(java.lang.Object)
javax.management.openmbean.TabularDataSupport.equals(java.lang.Object)
javax.management.openmbean.TabularType.equals(java.lang.Object)
javax.resource.cci.Record.equals(java.lang.Object)
javax.resource.spi.ConnectionRequestInfo.equals(java.lang.Object)
javax.resource.spi.ManagedConnectionFactory.equals(java.lang.Object)
javax.resource.spi.security.GenericCredential.equals(java.lang.Object)
javax.resource.spi.security.PasswordCredential.equals(java.lang.Object)
javax.security.jacc.EJBMethodPermission.equals(java.lang.Object)
javax.security.jacc.EJBRoleRefPermission.equals(java.lang.Object)
javax.security.jacc.WebResourcePermission.equals(java.lang.Object)
javax.security.jacc.WebRoleRefPermission.equals(java.lang.Object)
javax.security.jacc.WebUserDataPermission.equals(java.lang.Object)
javax.xml.namespace.QName.equals(java.lang.Object)


Occurences of errorCode

errorCode occurences:
javax.transaction.errorCode
javax.transaction.xa.errorCode


Occurences of evaluate

evaluate occurences:
javax.servlet.jsp.el.Expression.evaluate(javax.servlet.jsp.el.VariableResolver)
javax.servlet.jsp.el.ExpressionEvaluator.evaluate(java.lang.String, java.lang.Class, javax.servlet.jsp.el.VariableResolver, javax.servlet.jsp.el.FunctionMapper)


Occurences of execute

execute occurences:
javax.enterprise.deploy.spi.status.ClientConfiguration.execute()
javax.resource.cci.Interaction.execute(javax.resource.cci.InteractionSpec, javax.resource.cci.Record)
javax.resource.cci.Interaction.execute(javax.resource.cci.InteractionSpec, javax.resource.cci.Record, javax.resource.cci.Record)


Occurences of factories

factories occurences:
javax.enterprise.deploy.shared.factories
javax.enterprise.deploy.spi.factories


Occurences of FactoryConfigurationError (constructors)

FactoryConfigurationError (constructors) occurences:
javax.xml.parsers.FactoryConfigurationError()
javax.xml.parsers.FactoryConfigurationError(java.lang.Exception)
javax.xml.parsers.FactoryConfigurationError(java.lang.Exception, java.lang.String)
javax.xml.parsers.FactoryConfigurationError(java.lang.String)


Occurences of FEATURE

FEATURE occurences:
javax.xml.transform.dom.FEATURE
javax.xml.transform.dom.FEATURE
javax.xml.transform.sax.FEATURE
javax.xml.transform.sax.FEATURE
javax.xml.transform.sax.FEATURE
javax.xml.transform.stream.FEATURE
javax.xml.transform.stream.FEATURE


Occurences of FileDataSource (constructors)

FileDataSource (constructors) occurences:
javax.activation.FileDataSource(java.io.File)
javax.activation.FileDataSource(java.lang.String)


Occurences of finalize

finalize occurences:
javax.mail.Folder.finalize()
javax.mail.Service.finalize()


Occurences of findAncestorWithClass

findAncestorWithClass occurences:
javax.servlet.jsp.tagext.SimpleTagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.JspTag, java.lang.Class)
javax.servlet.jsp.tagext.TagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.Tag, java.lang.Class)


Occurences of findAssociatedMBeans

findAssociatedMBeans occurences:
javax.management.relation.RelationService.findAssociatedMBeans(javax.management.ObjectName, java.lang.String, java.lang.String)
javax.management.relation.RelationServiceMBean.findAssociatedMBeans(javax.management.ObjectName, java.lang.String, java.lang.String)


Occurences of FinderException (constructors)

FinderException (constructors) occurences:
javax.ejb.FinderException()
javax.ejb.FinderException(java.lang.String)


Occurences of FindException (constructors)

FindException (constructors) occurences:
javax.xml.registry.FindException()
javax.xml.registry.FindException(java.lang.String)
javax.xml.registry.FindException(java.lang.String, java.lang.Throwable)
javax.xml.registry.FindException(java.lang.Throwable)


Occurences of findReferencingRelations

findReferencingRelations occurences:
javax.management.relation.RelationService.findReferencingRelations(javax.management.ObjectName, java.lang.String, java.lang.String)
javax.management.relation.RelationServiceMBean.findReferencingRelations(javax.management.ObjectName, java.lang.String, java.lang.String)


Occurences of findRelationsOfType

findRelationsOfType occurences:
javax.management.relation.RelationService.findRelationsOfType(java.lang.String)
javax.management.relation.RelationServiceMBean.findRelationsOfType(java.lang.String)


Occurences of flags

flags occurences:
javax.mail.internet.flags
javax.mail.search.flags


Occurences of Flags (constructors)

Flags (constructors) occurences:
javax.mail.Flags()
javax.mail.Flags(java.lang.String)
javax.mail.Flags(javax.mail.Flags)
javax.mail.Flags(javax.mail.Flags.Flag)


Occurences of FloatHolder (constructors)

FloatHolder (constructors) occurences:
javax.xml.rpc.holders.FloatHolder()
javax.xml.rpc.holders.FloatHolder(float)


Occurences of FloatWrapperHolder (constructors)

FloatWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.FloatWrapperHolder()
javax.xml.rpc.holders.FloatWrapperHolder(java.lang.Float)


Occurences of flush

flush occurences:
javax.servlet.jsp.JspWriter.flush()
javax.servlet.jsp.tagext.BodyContent.flush()


Occurences of flushBuffer

flushBuffer occurences:
javax.servlet.ServletResponse.flushBuffer()
javax.servlet.ServletResponseWrapper.flushBuffer()


Occurences of folder

folder occurences:
javax.mail.event.folder
javax.mail.folder


Occurences of FolderClosedException (constructors)

FolderClosedException (constructors) occurences:
javax.mail.FolderClosedException(javax.mail.Folder)
javax.mail.FolderClosedException(javax.mail.Folder, java.lang.String)


Occurences of folderCreated

folderCreated occurences:
javax.mail.event.FolderAdapter.folderCreated(javax.mail.event.FolderEvent)
javax.mail.event.FolderListener.folderCreated(javax.mail.event.FolderEvent)


Occurences of folderDeleted

folderDeleted occurences:
javax.mail.event.FolderAdapter.folderDeleted(javax.mail.event.FolderEvent)
javax.mail.event.FolderListener.folderDeleted(javax.mail.event.FolderEvent)


Occurences of FolderEvent (constructors)

FolderEvent (constructors) occurences:
javax.mail.event.FolderEvent(java.lang.Object, javax.mail.Folder, int)
javax.mail.event.FolderEvent(java.lang.Object, javax.mail.Folder, javax.mail.Folder, int)


Occurences of FolderNotFoundException (constructors)

FolderNotFoundException (constructors) occurences:
javax.mail.FolderNotFoundException()
javax.mail.FolderNotFoundException(java.lang.String, javax.mail.Folder)
javax.mail.FolderNotFoundException(javax.mail.Folder)
javax.mail.FolderNotFoundException(javax.mail.Folder, java.lang.String)


Occurences of folderRenamed

folderRenamed occurences:
javax.mail.event.FolderAdapter.folderRenamed(javax.mail.event.FolderEvent)
javax.mail.event.FolderListener.folderRenamed(javax.mail.event.FolderEvent)


Occurences of forget

forget occurences:
javax.resource.spi.XATerminator.forget(javax.transaction.xa.Xid)
javax.transaction.xa.XAResource.forget(javax.transaction.xa.Xid)


Occurences of forward

forward occurences:
javax.servlet.jsp.PageContext.forward(java.lang.String)
javax.servlet.RequestDispatcher.forward(javax.servlet.ServletRequest, javax.servlet.ServletResponse)


Occurences of GE

GE occurences:
javax.mail.search.GE
javax.management.GE


Occurences of get

get occurences:
javax.activation.MimeTypeParameterList.get(java.lang.String)
javax.mail.internet.ParameterList.get(java.lang.String)
javax.management.openmbean.CompositeData.get(java.lang.String)
javax.management.openmbean.CompositeDataSupport.get(java.lang.String)
javax.management.openmbean.TabularData.get(java.lang.Object[])
javax.management.openmbean.TabularDataSupport.get(java.lang.Object)
javax.management.openmbean.TabularDataSupport.get(java.lang.Object[])


Occurences of getActions

getActions occurences:
javax.management.MBeanPermission.getActions()
javax.security.jacc.EJBMethodPermission.getActions()
javax.security.jacc.EJBRoleRefPermission.getActions()
javax.security.jacc.WebResourcePermission.getActions()
javax.security.jacc.WebRoleRefPermission.getActions()
javax.security.jacc.WebUserDataPermission.getActions()


Occurences of getAddress

getAddress occurences:
javax.mail.internet.InternetAddress.getAddress()
javax.mail.search.AddressTerm.getAddress()
javax.xml.registry.infomodel.EmailAddress.getAddress()


Occurences of getAll

getAll occurences:
javax.management.openmbean.CompositeData.getAll(java.lang.String[])
javax.management.openmbean.CompositeDataSupport.getAll(java.lang.String[])


Occurences of getAllCommands

getAllCommands occurences:
javax.activation.CommandMap.getAllCommands(java.lang.String)
javax.activation.DataHandler.getAllCommands()
javax.activation.MailcapCommandMap.getAllCommands(java.lang.String)


Occurences of getAllHeaderLines

getAllHeaderLines occurences:
javax.mail.internet.InternetHeaders.getAllHeaderLines()
javax.mail.internet.MimeBodyPart.getAllHeaderLines()
javax.mail.internet.MimeMessage.getAllHeaderLines()
javax.mail.internet.MimePart.getAllHeaderLines()


Occurences of getAllHeaders

getAllHeaders occurences:
javax.mail.internet.InternetHeaders.getAllHeaders()
javax.mail.internet.MimeBodyPart.getAllHeaders()
javax.mail.internet.MimeMessage.getAllHeaders()
javax.mail.Part.getAllHeaders()
javax.xml.soap.MimeHeaders.getAllHeaders()


Occurences of getAllMimeHeaders

getAllMimeHeaders occurences:
javax.xml.soap.AttachmentPart.getAllMimeHeaders()
javax.xml.soap.SOAPPart.getAllMimeHeaders()


Occurences of getAllNotificationIDs

getAllNotificationIDs occurences:
javax.management.timer.Timer.getAllNotificationIDs()
javax.management.timer.TimerMBean.getAllNotificationIDs()


Occurences of getAllRecipients

getAllRecipients occurences:
javax.mail.internet.MimeMessage.getAllRecipients()
javax.mail.Message.getAllRecipients()


Occurences of getAllRelationIds

getAllRelationIds occurences:
javax.management.relation.RelationService.getAllRelationIds()
javax.management.relation.RelationServiceMBean.getAllRelationIds()


Occurences of getAllRelationTypeNames

getAllRelationTypeNames occurences:
javax.management.relation.RelationService.getAllRelationTypeNames()
javax.management.relation.RelationServiceMBean.getAllRelationTypeNames()


Occurences of getAllRoles

getAllRoles occurences:
javax.management.relation.Relation.getAllRoles()
javax.management.relation.RelationService.getAllRoles(java.lang.String)
javax.management.relation.RelationServiceMBean.getAllRoles(java.lang.String)
javax.management.relation.RelationSupport.getAllRoles()


Occurences of getAttachments

getAttachments occurences:
javax.xml.soap.SOAPMessage.getAttachments()
javax.xml.soap.SOAPMessage.getAttachments(javax.xml.soap.MimeHeaders)


Occurences of getAttribute

getAttribute occurences:
javax.management.AttributeValueExp.getAttribute(javax.management.ObjectName)
javax.management.DynamicMBean.getAttribute(java.lang.String)
javax.management.j2ee.Management.getAttribute(javax.management.ObjectName, java.lang.String)
javax.management.MBeanServer.getAttribute(javax.management.ObjectName, java.lang.String)
javax.management.MBeanServerConnection.getAttribute(javax.management.ObjectName, java.lang.String)
javax.management.modelmbean.ModelMBeanInfo.getAttribute(java.lang.String)
javax.management.modelmbean.ModelMBeanInfoSupport.getAttribute(java.lang.String)
javax.management.modelmbean.RequiredModelMBean.getAttribute(java.lang.String)
javax.management.StandardMBean.getAttribute(java.lang.String)
javax.servlet.http.HttpSession.getAttribute(java.lang.String)
javax.servlet.jsp.JspContext.getAttribute(java.lang.String)
javax.servlet.jsp.JspContext.getAttribute(java.lang.String, int)
javax.servlet.jsp.tagext.TagData.getAttribute(java.lang.String)
javax.servlet.ServletContext.getAttribute(java.lang.String)
javax.servlet.ServletRequest.getAttribute(java.lang.String)
javax.servlet.ServletRequestWrapper.getAttribute(java.lang.String)
javax.xml.parsers.DocumentBuilderFactory.getAttribute(java.lang.String)
javax.xml.transform.TransformerFactory.getAttribute(java.lang.String)


Occurences of getAttributeName

getAttributeName occurences:
javax.management.AttributeChangeNotification.getAttributeName()
javax.management.AttributeValueExp.getAttributeName()


Occurences of getAttributeNames

getAttributeNames occurences:
javax.enterprise.deploy.model.DDBean.getAttributeNames()
javax.servlet.http.HttpSession.getAttributeNames()
javax.servlet.ServletContext.getAttributeNames()
javax.servlet.ServletRequest.getAttributeNames()
javax.servlet.ServletRequestWrapper.getAttributeNames()


Occurences of getAttributes

getAttributes occurences:
javax.management.DynamicMBean.getAttributes(java.lang.String[])
javax.management.j2ee.Management.getAttributes(javax.management.ObjectName, java.lang.String[])
javax.management.MBeanInfo.getAttributes()
javax.management.MBeanServer.getAttributes(javax.management.ObjectName, java.lang.String[])
javax.management.MBeanServerConnection.getAttributes(javax.management.ObjectName, java.lang.String[])
javax.management.modelmbean.ModelMBeanInfo.getAttributes()
javax.management.modelmbean.RequiredModelMBean.getAttributes(java.lang.String[])
javax.management.openmbean.OpenMBeanInfo.getAttributes()
javax.management.StandardMBean.getAttributes(java.lang.String[])
javax.servlet.jsp.tagext.TagData.getAttributes()
javax.servlet.jsp.tagext.TagInfo.getAttributes()


Occurences of getAttributeValue

getAttributeValue occurences:
javax.enterprise.deploy.model.DDBean.getAttributeValue(java.lang.String)
javax.xml.soap.SOAPElement.getAttributeValue(javax.xml.soap.Name)


Occurences of getAuthType

getAuthType occurences:
javax.servlet.http.HttpServletRequest.getAuthType()
javax.servlet.http.HttpServletRequestWrapper.getAuthType()


Occurences of getBaseType

getBaseType occurences:
javax.activation.MimeType.getBaseType()
javax.mail.internet.ContentType.getBaseType()


Occurences of getBean

getBean occurences:
javax.activation.DataHandler.getBean(javax.activation.CommandInfo)
javax.enterprise.deploy.model.XpathEvent.getBean()


Occurences of getBodyContent

getBodyContent occurences:
javax.servlet.jsp.tagext.BodyTagSupport.getBodyContent()
javax.servlet.jsp.tagext.TagInfo.getBodyContent()


Occurences of getBodyPart

getBodyPart occurences:
javax.mail.internet.MimeMultipart.getBodyPart(int)
javax.mail.internet.MimeMultipart.getBodyPart(java.lang.String)
javax.mail.Multipart.getBodyPart(int)
javax.mail.MultipartDataSource.getBodyPart(int)


Occurences of getBufferSize

getBufferSize occurences:
javax.servlet.jsp.JspWriter.getBufferSize()
javax.servlet.ServletResponse.getBufferSize()
javax.servlet.ServletResponseWrapper.getBufferSize()


Occurences of getCause

getCause occurences:
javax.management.MBeanException.getCause()
javax.management.ReflectionException.getCause()
javax.management.RuntimeErrorException.getCause()
javax.management.RuntimeMBeanException.getCause()
javax.management.RuntimeOperationsException.getCause()
javax.xml.registry.JAXRException.getCause()
javax.xml.soap.SOAPException.getCause()
javax.xml.transform.TransformerException.getCause()


Occurences of getCharacterEncoding

getCharacterEncoding occurences:
javax.servlet.ServletRequest.getCharacterEncoding()
javax.servlet.ServletRequestWrapper.getCharacterEncoding()
javax.servlet.ServletResponse.getCharacterEncoding()
javax.servlet.ServletResponseWrapper.getCharacterEncoding()


Occurences of getChildBean

getChildBean occurences:
javax.enterprise.deploy.model.DDBean.getChildBean(java.lang.String)
javax.enterprise.deploy.model.DeployableObject.getChildBean(java.lang.String)
javax.enterprise.deploy.model.J2eeApplicationObject.getChildBean(javax.enterprise.deploy.shared.ModuleType, java.lang.String)


Occurences of getChildConceptCount

getChildConceptCount occurences:
javax.xml.registry.infomodel.ClassificationScheme.getChildConceptCount()
javax.xml.registry.infomodel.Concept.getChildConceptCount()


Occurences of getChildElements

getChildElements occurences:
javax.xml.soap.SOAPElement.getChildElements()
javax.xml.soap.SOAPElement.getChildElements(javax.xml.soap.Name)


Occurences of getChildrenConcepts

getChildrenConcepts occurences:
javax.xml.registry.infomodel.ClassificationScheme.getChildrenConcepts()
javax.xml.registry.infomodel.Concept.getChildrenConcepts()


Occurences of getClassificationScheme

getClassificationScheme occurences:
javax.xml.registry.infomodel.Classification.getClassificationScheme()
javax.xml.registry.infomodel.Concept.getClassificationScheme()


Occurences of getClassLoaderRepository

getClassLoaderRepository occurences:
javax.management.MBeanServer.getClassLoaderRepository()
javax.management.MBeanServerFactory.getClassLoaderRepository(javax.management.MBeanServer)
javax.management.modelmbean.RequiredModelMBean.getClassLoaderRepository()


Occurences of getClassName

getClassName occurences:
javax.mail.Provider.getClassName()
javax.management.MBeanInfo.getClassName()
javax.management.modelmbean.ModelMBeanInfo.getClassName()
javax.management.ObjectInstance.getClassName()
javax.management.openmbean.OpenMBeanInfo.getClassName()
javax.management.openmbean.OpenType.getClassName()
javax.management.StandardMBean.getClassName(javax.management.MBeanInfo)
javax.servlet.jsp.tagext.TagVariableInfo.getClassName()
javax.servlet.jsp.tagext.VariableInfo.getClassName()


Occurences of getCloseCount

getCloseCount occurences:
javax.management.j2ee.statistics.JCAConnectionPoolStats.getCloseCount()
javax.management.j2ee.statistics.JDBCConnectionPoolStats.getCloseCount()


Occurences of getCommand

getCommand occurences:
javax.activation.CommandMap.getCommand(java.lang.String, java.lang.String)
javax.activation.DataHandler.getCommand(java.lang.String)
javax.activation.MailcapCommandMap.getCommand(java.lang.String, java.lang.String)
javax.enterprise.deploy.spi.status.DeploymentStatus.getCommand()


Occurences of getComparison

getComparison occurences:
javax.mail.search.DateTerm.getComparison()
javax.mail.search.IntegerComparisonTerm.getComparison()


Occurences of getCompositeType

getCompositeType occurences:
javax.management.openmbean.CompositeData.getCompositeType()
javax.management.openmbean.CompositeDataSupport.getCompositeType()


Occurences of getConnection

getConnection occurences:
javax.resource.cci.ConnectionFactory.getConnection()
javax.resource.cci.ConnectionFactory.getConnection(javax.resource.cci.ConnectionSpec)
javax.resource.cci.Interaction.getConnection()
javax.resource.spi.ManagedConnection.getConnection(javax.security.auth.Subject, javax.resource.spi.ConnectionRequestInfo)


Occurences of getConnectionPools

getConnectionPools occurences:
javax.management.j2ee.statistics.JCAStats.getConnectionPools()
javax.management.j2ee.statistics.JDBCStats.getConnectionPools()


Occurences of getConnections

getConnections occurences:
javax.management.j2ee.statistics.JCAStats.getConnections()
javax.management.j2ee.statistics.JDBCStats.getConnections()
javax.management.j2ee.statistics.JMSStats.getConnections()


Occurences of getConstructors

getConstructors occurences:
javax.management.MBeanInfo.getConstructors()
javax.management.modelmbean.ModelMBeanInfo.getConstructors()
javax.management.openmbean.OpenMBeanInfo.getConstructors()
javax.management.StandardMBean.getConstructors(javax.management.MBeanConstructorInfo[], java.lang.Object)


Occurences of getContent

getContent occurences:
javax.activation.DataContentHandler.getContent(javax.activation.DataSource)
javax.activation.DataHandler.getContent()
javax.mail.internet.MimeBodyPart.getContent()
javax.mail.internet.MimeMessage.getContent()
javax.mail.Part.getContent()
javax.xml.soap.AttachmentPart.getContent()
javax.xml.soap.SOAPPart.getContent()


Occurences of getContentId

getContentId occurences:
javax.xml.soap.AttachmentPart.getContentId()
javax.xml.soap.SOAPPart.getContentId()


Occurences of getContentID

getContentID occurences:
javax.mail.internet.MimeBodyPart.getContentID()
javax.mail.internet.MimeMessage.getContentID()
javax.mail.internet.MimePart.getContentID()


Occurences of getContentLanguage

getContentLanguage occurences:
javax.mail.internet.MimeBodyPart.getContentLanguage()
javax.mail.internet.MimeMessage.getContentLanguage()
javax.mail.internet.MimePart.getContentLanguage()


Occurences of getContentLength

getContentLength occurences:
javax.servlet.ServletRequest.getContentLength()
javax.servlet.ServletRequestWrapper.getContentLength()


Occurences of getContentLocation

getContentLocation occurences:
javax.xml.soap.AttachmentPart.getContentLocation()
javax.xml.soap.SOAPPart.getContentLocation()


Occurences of getContentMD5

getContentMD5 occurences:
javax.mail.internet.MimeBodyPart.getContentMD5()
javax.mail.internet.MimeMessage.getContentMD5()
javax.mail.internet.MimePart.getContentMD5()


Occurences of getContentStream

getContentStream occurences:
javax.mail.internet.MimeBodyPart.getContentStream()
javax.mail.internet.MimeMessage.getContentStream()


Occurences of getContentType

getContentType occurences:
javax.activation.DataHandler.getContentType()
javax.activation.DataSource.getContentType()
javax.activation.FileDataSource.getContentType()
javax.activation.FileTypeMap.getContentType(java.io.File)
javax.activation.FileTypeMap.getContentType(java.lang.String)
javax.activation.MimetypesFileTypeMap.getContentType(java.io.File)
javax.activation.MimetypesFileTypeMap.getContentType(java.lang.String)
javax.activation.URLDataSource.getContentType()
javax.mail.internet.MimeBodyPart.getContentType()
javax.mail.internet.MimeMessage.getContentType()
javax.mail.internet.MimePartDataSource.getContentType()
javax.mail.Multipart.getContentType()
javax.mail.Part.getContentType()
javax.servlet.ServletRequest.getContentType()
javax.servlet.ServletRequestWrapper.getContentType()
javax.servlet.ServletResponse.getContentType()
javax.servlet.ServletResponseWrapper.getContentType()
javax.xml.soap.AttachmentPart.getContentType()


Occurences of getContext

getContext occurences:
javax.security.jacc.PolicyContext.getContext(java.lang.String)
javax.security.jacc.PolicyContextHandler.getContext(java.lang.String, java.lang.Object)
javax.servlet.ServletContext.getContext(java.lang.String)


Occurences of getContextID

getContextID occurences:
javax.security.jacc.PolicyConfiguration.getContextID()
javax.security.jacc.PolicyContext.getContextID()


Occurences of getContextPath

getContextPath occurences:
javax.servlet.http.HttpServletRequest.getContextPath()
javax.servlet.http.HttpServletRequestWrapper.getContextPath()


Occurences of getCookies

getCookies occurences:
javax.servlet.http.HttpServletRequest.getCookies()
javax.servlet.http.HttpServletRequestWrapper.getCookies()


Occurences of getCount

getCount occurences:
javax.mail.internet.MimeMultipart.getCount()
javax.mail.Multipart.getCount()
javax.mail.MultipartDataSource.getCount()
javax.management.j2ee.statistics.CountStatistic.getCount()
javax.management.j2ee.statistics.TimeStatistic.getCount()


Occurences of getCreateCount

getCreateCount occurences:
javax.management.j2ee.statistics.EJBStats.getCreateCount()
javax.management.j2ee.statistics.JCAConnectionPoolStats.getCreateCount()
javax.management.j2ee.statistics.JDBCConnectionPoolStats.getCreateCount()


Occurences of getDataHandler

getDataHandler occurences:
javax.mail.internet.MimeBodyPart.getDataHandler()
javax.mail.internet.MimeMessage.getDataHandler()
javax.mail.Part.getDataHandler()
javax.xml.soap.AttachmentPart.getDataHandler()


Occurences of getDate

getDate occurences:
javax.mail.search.DateTerm.getDate()
javax.management.timer.Timer.getDate(java.lang.Integer)
javax.management.timer.TimerMBean.getDate(java.lang.Integer)


Occurences of getDateHeader

getDateHeader occurences:
javax.servlet.http.HttpServletRequest.getDateHeader(java.lang.String)
javax.servlet.http.HttpServletRequestWrapper.getDateHeader(java.lang.String)


Occurences of getDConfigBean

getDConfigBean occurences:
javax.enterprise.deploy.spi.DConfigBean.getDConfigBean(javax.enterprise.deploy.model.DDBean)
javax.enterprise.deploy.spi.DConfigBeanRoot.getDConfigBean(javax.enterprise.deploy.model.DDBeanRoot)


Occurences of getDDBeanRoot

getDDBeanRoot occurences:
javax.enterprise.deploy.model.DeployableObject.getDDBeanRoot()
javax.enterprise.deploy.model.DeployableObject.getDDBeanRoot(java.lang.String)


Occurences of getDeclare

getDeclare occurences:
javax.servlet.jsp.tagext.TagVariableInfo.getDeclare()
javax.servlet.jsp.tagext.VariableInfo.getDeclare()


Occurences of getDefaultDomain

getDefaultDomain occurences:
javax.management.j2ee.Management.getDefaultDomain()
javax.management.MBeanServer.getDefaultDomain()
javax.management.MBeanServerConnection.getDefaultDomain()


Occurences of getDefaultInstance

getDefaultInstance occurences:
javax.mail.Session.getDefaultInstance(java.util.Properties)
javax.mail.Session.getDefaultInstance(java.util.Properties, javax.mail.Authenticator)


Occurences of getDefaultValue

getDefaultValue occurences:
javax.management.openmbean.OpenMBeanAttributeInfoSupport.getDefaultValue()
javax.management.openmbean.OpenMBeanParameterInfo.getDefaultValue()
javax.management.openmbean.OpenMBeanParameterInfoSupport.getDefaultValue()


Occurences of getDeployableObject

getDeployableObject occurences:
javax.enterprise.deploy.model.DDBeanRoot.getDeployableObject()
javax.enterprise.deploy.model.J2eeApplicationObject.getDeployableObject(java.lang.String)
javax.enterprise.deploy.spi.DeploymentConfiguration.getDeployableObject()


Occurences of getDeployableObjects

getDeployableObjects occurences:
javax.enterprise.deploy.model.J2eeApplicationObject.getDeployableObjects()
javax.enterprise.deploy.model.J2eeApplicationObject.getDeployableObjects(javax.enterprise.deploy.shared.ModuleType)


Occurences of getDeploymentManager

getDeploymentManager occurences:
javax.enterprise.deploy.shared.factories.DeploymentFactoryManager.getDeploymentManager(java.lang.String, java.lang.String, java.lang.String)
javax.enterprise.deploy.spi.factories.DeploymentFactory.getDeploymentManager(java.lang.String, java.lang.String, java.lang.String)


Occurences of getDeploymentStatus

getDeploymentStatus occurences:
javax.enterprise.deploy.spi.status.ProgressEvent.getDeploymentStatus()
javax.enterprise.deploy.spi.status.ProgressObject.getDeploymentStatus()


Occurences of getDerivedGauge

getDerivedGauge occurences:
javax.management.monitor.CounterMonitor.getDerivedGauge()
javax.management.monitor.CounterMonitor.getDerivedGauge(javax.management.ObjectName)
javax.management.monitor.CounterMonitorMBean.getDerivedGauge()
javax.management.monitor.CounterMonitorMBean.getDerivedGauge(javax.management.ObjectName)
javax.management.monitor.GaugeMonitor.getDerivedGauge()
javax.management.monitor.GaugeMonitor.getDerivedGauge(javax.management.ObjectName)
javax.management.monitor.GaugeMonitorMBean.getDerivedGauge()
javax.management.monitor.GaugeMonitorMBean.getDerivedGauge(javax.management.ObjectName)
javax.management.monitor.MonitorNotification.getDerivedGauge()
javax.management.monitor.StringMonitor.getDerivedGauge()
javax.management.monitor.StringMonitor.getDerivedGauge(javax.management.ObjectName)
javax.management.monitor.StringMonitorMBean.getDerivedGauge()
javax.management.monitor.StringMonitorMBean.getDerivedGauge(javax.management.ObjectName)


Occurences of getDerivedGaugeTimeStamp

getDerivedGaugeTimeStamp occurences:
javax.management.monitor.CounterMonitor.getDerivedGaugeTimeStamp()
javax.management.monitor.CounterMonitor.getDerivedGaugeTimeStamp(javax.management.ObjectName)
javax.management.monitor.CounterMonitorMBean.getDerivedGaugeTimeStamp()
javax.management.monitor.CounterMonitorMBean.getDerivedGaugeTimeStamp(javax.management.ObjectName)
javax.management.monitor.GaugeMonitor.getDerivedGaugeTimeStamp()
javax.management.monitor.GaugeMonitor.getDerivedGaugeTimeStamp(javax.management.ObjectName)
javax.management.monitor.GaugeMonitorMBean.getDerivedGaugeTimeStamp()
javax.management.monitor.GaugeMonitorMBean.getDerivedGaugeTimeStamp(javax.management.ObjectName)
javax.management.monitor.StringMonitor.getDerivedGaugeTimeStamp()
javax.management.monitor.StringMonitor.getDerivedGaugeTimeStamp(javax.management.ObjectName)
javax.management.monitor.StringMonitorMBean.getDerivedGaugeTimeStamp()
javax.management.monitor.StringMonitorMBean.getDerivedGaugeTimeStamp(javax.management.ObjectName)


Occurences of getDescendantConcepts

getDescendantConcepts occurences:
javax.xml.registry.infomodel.ClassificationScheme.getDescendantConcepts()
javax.xml.registry.infomodel.Concept.getDescendantConcepts()


Occurences of getDescription

getDescription occurences:
javax.enterprise.deploy.spi.Target.getDescription()
javax.mail.internet.MimeBodyPart.getDescription()
javax.mail.internet.MimeMessage.getDescription()
javax.mail.Part.getDescription()
javax.management.j2ee.statistics.Statistic.getDescription()
javax.management.MBeanFeatureInfo.getDescription()
javax.management.MBeanInfo.getDescription()
javax.management.modelmbean.ModelMBeanInfo.getDescription()
javax.management.openmbean.CompositeType.getDescription(java.lang.String)
javax.management.openmbean.OpenMBeanConstructorInfo.getDescription()
javax.management.openmbean.OpenMBeanInfo.getDescription()
javax.management.openmbean.OpenMBeanOperationInfo.getDescription()
javax.management.openmbean.OpenMBeanParameterInfo.getDescription()
javax.management.openmbean.OpenType.getDescription()
javax.management.relation.RoleInfo.getDescription()
javax.management.StandardMBean.getDescription(javax.management.MBeanAttributeInfo)
javax.management.StandardMBean.getDescription(javax.management.MBeanConstructorInfo)
javax.management.StandardMBean.getDescription(javax.management.MBeanConstructorInfo, javax.management.MBeanParameterInfo, int)
javax.management.StandardMBean.getDescription(javax.management.MBeanFeatureInfo)
javax.management.StandardMBean.getDescription(javax.management.MBeanInfo)
javax.management.StandardMBean.getDescription(javax.management.MBeanOperationInfo)
javax.management.StandardMBean.getDescription(javax.management.MBeanOperationInfo, javax.management.MBeanParameterInfo, int)
javax.xml.registry.infomodel.RegistryObject.getDescription()


Occurences of getDescriptor

getDescriptor occurences:
javax.management.DescriptorAccess.getDescriptor()
javax.management.modelmbean.ModelMBeanAttributeInfo.getDescriptor()
javax.management.modelmbean.ModelMBeanConstructorInfo.getDescriptor()
javax.management.modelmbean.ModelMBeanInfo.getDescriptor(java.lang.String, java.lang.String)
javax.management.modelmbean.ModelMBeanInfoSupport.getDescriptor(java.lang.String)
javax.management.modelmbean.ModelMBeanInfoSupport.getDescriptor(java.lang.String, java.lang.String)
javax.management.modelmbean.ModelMBeanNotificationInfo.getDescriptor()
javax.management.modelmbean.ModelMBeanOperationInfo.getDescriptor()


Occurences of getDescriptors

getDescriptors occurences:
javax.management.modelmbean.ModelMBeanInfo.getDescriptors(java.lang.String)
javax.management.modelmbean.ModelMBeanInfoSupport.getDescriptors(java.lang.String)


Occurences of getDestination

getDestination occurences:
javax.jms.MessageProducer.getDestination()
javax.management.j2ee.statistics.JMSProducerStats.getDestination()


Occurences of getDetail

getDetail occurences:
javax.xml.rpc.soap.SOAPFaultException.getDetail()
javax.xml.soap.SOAPFault.getDetail()


Occurences of getDifferenceMode

getDifferenceMode occurences:
javax.management.monitor.CounterMonitor.getDifferenceMode()
javax.management.monitor.CounterMonitorMBean.getDifferenceMode()
javax.management.monitor.GaugeMonitor.getDifferenceMode()
javax.management.monitor.GaugeMonitorMBean.getDifferenceMode()


Occurences of getDisconnectedDeploymentManager

getDisconnectedDeploymentManager occurences:
javax.enterprise.deploy.shared.factories.DeploymentFactoryManager.getDisconnectedDeploymentManager(java.lang.String)
javax.enterprise.deploy.spi.factories.DeploymentFactory.getDisconnectedDeploymentManager(java.lang.String)


Occurences of getDisplayName

getDisplayName occurences:
javax.enterprise.deploy.spi.factories.DeploymentFactory.getDisplayName()
javax.servlet.jsp.tagext.TagInfo.getDisplayName()


Occurences of getDisposition

getDisposition occurences:
javax.mail.internet.ContentDisposition.getDisposition()
javax.mail.internet.MimeBodyPart.getDisposition()
javax.mail.internet.MimeMessage.getDisposition()
javax.mail.Part.getDisposition()


Occurences of getDomain

getDomain occurences:
javax.management.ObjectName.getDomain()
javax.servlet.http.Cookie.getDomain()


Occurences of getDomains

getDomains occurences:
javax.management.MBeanServer.getDomains()
javax.management.MBeanServerConnection.getDomains()


Occurences of getEISProductName

getEISProductName occurences:
javax.resource.cci.ConnectionMetaData.getEISProductName()
javax.resource.spi.ManagedConnectionMetaData.getEISProductName()


Occurences of getEISProductVersion

getEISProductVersion occurences:
javax.resource.cci.ConnectionMetaData.getEISProductVersion()
javax.resource.spi.ManagedConnectionMetaData.getEISProductVersion()


Occurences of getEJBHome

getEJBHome occurences:
javax.ejb.EJBContext.getEJBHome()
javax.ejb.EJBMetaData.getEJBHome()
javax.ejb.EJBObject.getEJBHome()
javax.ejb.HomeHandle.getEJBHome()


Occurences of getEJBLocalHome

getEJBLocalHome occurences:
javax.ejb.EJBContext.getEJBLocalHome()
javax.ejb.EJBLocalObject.getEJBLocalHome()


Occurences of getEJBLocalObject

getEJBLocalObject occurences:
javax.ejb.EntityContext.getEJBLocalObject()
javax.ejb.SessionContext.getEJBLocalObject()


Occurences of getEJBObject

getEJBObject occurences:
javax.ejb.EntityContext.getEJBObject()
javax.ejb.Handle.getEJBObject()
javax.ejb.SessionContext.getEJBObject()


Occurences of getEncoding

getEncoding occurences:
javax.mail.internet.MimeBodyPart.getEncoding()
javax.mail.internet.MimeMessage.getEncoding()
javax.mail.internet.MimePart.getEncoding()
javax.mail.internet.MimeUtility.getEncoding(javax.activation.DataHandler)
javax.mail.internet.MimeUtility.getEncoding(javax.activation.DataSource)


Occurences of getEnumValueTable

getEnumValueTable occurences:
javax.enterprise.deploy.shared.ActionType.getEnumValueTable()
javax.enterprise.deploy.shared.CommandType.getEnumValueTable()
javax.enterprise.deploy.shared.DConfigBeanVersionType.getEnumValueTable()
javax.enterprise.deploy.shared.ModuleType.getEnumValueTable()
javax.enterprise.deploy.shared.StateType.getEnumValueTable()


Occurences of getErrorCode

getErrorCode occurences:
javax.jms.JMSException.getErrorCode()
javax.resource.ResourceException.getErrorCode()


Occurences of getErrorListener

getErrorListener occurences:
javax.xml.transform.Transformer.getErrorListener()
javax.xml.transform.TransformerFactory.getErrorListener()


Occurences of getException

getException occurences:
javax.resource.spi.ConnectionEvent.getException()
javax.resource.spi.work.WorkEvent.getException()
javax.servlet.jsp.PageContext.getException()
javax.xml.parsers.FactoryConfigurationError.getException()
javax.xml.transform.TransformerException.getException()
javax.xml.transform.TransformerFactoryConfigurationError.getException()


Occurences of getExpiredMessageCount

getExpiredMessageCount occurences:
javax.management.j2ee.statistics.JMSEndpointStats.getExpiredMessageCount()
javax.management.j2ee.statistics.JMSSessionStats.getExpiredMessageCount()


Occurences of getFaultActor

getFaultActor occurences:
javax.xml.rpc.soap.SOAPFaultException.getFaultActor()
javax.xml.soap.SOAPFault.getFaultActor()


Occurences of getFaultCode

getFaultCode occurences:
javax.xml.rpc.soap.SOAPFaultException.getFaultCode()
javax.xml.soap.SOAPFault.getFaultCode()


Occurences of getFaultString

getFaultString occurences:
javax.xml.rpc.soap.SOAPFaultException.getFaultString()
javax.xml.soap.SOAPFault.getFaultString()


Occurences of getFeature

getFeature occurences:
javax.xml.parsers.SAXParserFactory.getFeature(java.lang.String)
javax.xml.transform.TransformerFactory.getFeature(java.lang.String)


Occurences of getFieldNames

getFieldNames occurences:
javax.management.Descriptor.getFieldNames()
javax.management.modelmbean.DescriptorSupport.getFieldNames()


Occurences of getFields

getFields occurences:
javax.management.Descriptor.getFields()
javax.management.modelmbean.DescriptorSupport.getFields()


Occurences of getFieldValue

getFieldValue occurences:
javax.management.Descriptor.getFieldValue(java.lang.String)
javax.management.modelmbean.DescriptorSupport.getFieldValue(java.lang.String)


Occurences of getFieldValues

getFieldValues occurences:
javax.management.Descriptor.getFieldValues(java.lang.String[])
javax.management.modelmbean.DescriptorSupport.getFieldValues(java.lang.String[])


Occurences of getFile

getFile occurences:
javax.activation.FileDataSource.getFile()
javax.mail.URLName.getFile()


Occurences of getFileName

getFileName occurences:
javax.mail.internet.MimeBodyPart.getFileName()
javax.mail.internet.MimeMessage.getFileName()
javax.mail.Part.getFileName()


Occurences of getFixedRate

getFixedRate occurences:
javax.management.timer.Timer.getFixedRate(java.lang.Integer)
javax.management.timer.TimerMBean.getFixedRate(java.lang.Integer)


Occurences of getFlags

getFlags occurences:
javax.mail.internet.MimeMessage.getFlags()
javax.mail.Message.getFlags()
javax.mail.search.FlagTerm.getFlags()


Occurences of getFolder

getFolder occurences:
javax.mail.event.FolderEvent.getFolder()
javax.mail.Folder.getFolder(java.lang.String)
javax.mail.FolderClosedException.getFolder()
javax.mail.FolderNotFoundException.getFolder()
javax.mail.Message.getFolder()
javax.mail.ReadOnlyFolderException.getFolder()
javax.mail.Session.getFolder(javax.mail.URLName)
javax.mail.Store.getFolder(java.lang.String)
javax.mail.Store.getFolder(javax.mail.URLName)


Occurences of getFreePoolSize

getFreePoolSize occurences:
javax.management.j2ee.statistics.JCAConnectionPoolStats.getFreePoolSize()
javax.management.j2ee.statistics.JDBCConnectionPoolStats.getFreePoolSize()


Occurences of getFrom

getFrom occurences:
javax.mail.internet.MimeMessage.getFrom()
javax.mail.Message.getFrom()


Occurences of getFullName

getFullName occurences:
javax.mail.Folder.getFullName()
javax.xml.registry.infomodel.PersonName.getFullName()


Occurences of getGranularityPeriod

getGranularityPeriod occurences:
javax.management.monitor.Monitor.getGranularityPeriod()
javax.management.monitor.MonitorMBean.getGranularityPeriod()


Occurences of getHandle

getHandle occurences:
javax.ejb.EJBObject.getHandle()
javax.ejb.Timer.getHandle()


Occurences of getHeader

getHeader occurences:
javax.mail.internet.InternetHeaders.getHeader(java.lang.String)
javax.mail.internet.InternetHeaders.getHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeBodyPart.getHeader(java.lang.String)
javax.mail.internet.MimeBodyPart.getHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.getHeader(java.lang.String)
javax.mail.internet.MimeMessage.getHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimePart.getHeader(java.lang.String, java.lang.String)
javax.mail.Part.getHeader(java.lang.String)
javax.servlet.http.HttpServletRequest.getHeader(java.lang.String)
javax.servlet.http.HttpServletRequestWrapper.getHeader(java.lang.String)
javax.xml.soap.MimeHeaders.getHeader(java.lang.String)
javax.xml.soap.SOAPEnvelope.getHeader()


Occurences of getHeaderNames

getHeaderNames occurences:
javax.mail.FetchProfile.getHeaderNames()
javax.servlet.http.HttpServletRequest.getHeaderNames()
javax.servlet.http.HttpServletRequestWrapper.getHeaderNames()


Occurences of getHeaders

getHeaders occurences:
javax.servlet.http.HttpServletRequest.getHeaders(java.lang.String)
javax.servlet.http.HttpServletRequestWrapper.getHeaders(java.lang.String)
javax.xml.rpc.handler.GenericHandler.getHeaders()
javax.xml.rpc.handler.Handler.getHeaders()
javax.xml.rpc.handler.HandlerInfo.getHeaders()


Occurences of getHighThreshold

getHighThreshold occurences:
javax.management.monitor.GaugeMonitor.getHighThreshold()
javax.management.monitor.GaugeMonitorMBean.getHighThreshold()


Occurences of getHost

getHost occurences:
javax.mail.internet.NewsAddress.getHost()
javax.mail.URLName.getHost()


Occurences of getId

getId occurences:
javax.enterprise.deploy.model.DDBean.getId()
javax.resource.spi.ConnectionEvent.getId()
javax.servlet.http.HttpSession.getId()
javax.servlet.jsp.tagext.TagData.getId()
javax.servlet.jsp.tagext.TagSupport.getId()
javax.servlet.jsp.tagext.ValidationMessage.getId()
javax.xml.registry.infomodel.Key.getId()


Occurences of getImpact

getImpact occurences:
javax.management.MBeanOperationInfo.getImpact()
javax.management.openmbean.OpenMBeanOperationInfo.getImpact()
javax.management.StandardMBean.getImpact(javax.management.MBeanOperationInfo)


Occurences of getImplementationName

getImplementationName occurences:
javax.management.MBeanServerDelegate.getImplementationName()
javax.management.MBeanServerDelegateMBean.getImplementationName()


Occurences of getImplementationVendor

getImplementationVendor occurences:
javax.management.MBeanServerDelegate.getImplementationVendor()
javax.management.MBeanServerDelegateMBean.getImplementationVendor()


Occurences of getImplementationVersion

getImplementationVersion occurences:
javax.management.MBeanServerDelegate.getImplementationVersion()
javax.management.MBeanServerDelegateMBean.getImplementationVersion()


Occurences of getInfoString

getInfoString occurences:
javax.servlet.jsp.tagext.TagInfo.getInfoString()
javax.servlet.jsp.tagext.TagLibraryInfo.getInfoString()


Occurences of getInitParameter

getInitParameter occurences:
javax.servlet.FilterConfig.getInitParameter(java.lang.String)
javax.servlet.GenericServlet.getInitParameter(java.lang.String)
javax.servlet.ServletConfig.getInitParameter(java.lang.String)
javax.servlet.ServletContext.getInitParameter(java.lang.String)


Occurences of getInitParameterNames

getInitParameterNames occurences:
javax.servlet.FilterConfig.getInitParameterNames()
javax.servlet.GenericServlet.getInitParameterNames()
javax.servlet.ServletConfig.getInitParameterNames()
javax.servlet.ServletContext.getInitParameterNames()


Occurences of getInitThreshold

getInitThreshold occurences:
javax.management.monitor.CounterMonitor.getInitThreshold()
javax.management.monitor.CounterMonitorMBean.getInitThreshold()


Occurences of getInputStream

getInputStream occurences:
javax.activation.DataHandler.getInputStream()
javax.activation.DataSource.getInputStream()
javax.activation.FileDataSource.getInputStream()
javax.activation.URLDataSource.getInputStream()
javax.mail.internet.MimeBodyPart.getInputStream()
javax.mail.internet.MimeMessage.getInputStream()
javax.mail.internet.MimePartDataSource.getInputStream()
javax.mail.Part.getInputStream()
javax.servlet.jsp.tagext.PageData.getInputStream()
javax.servlet.ServletRequest.getInputStream()
javax.servlet.ServletRequestWrapper.getInputStream()
javax.xml.transform.stream.StreamSource.getInputStream()


Occurences of getInstance

getInstance occurences:
javax.enterprise.deploy.shared.factories.DeploymentFactoryManager.getInstance()
javax.mail.Session.getInstance(java.util.Properties)
javax.mail.Session.getInstance(java.util.Properties, javax.mail.Authenticator)
javax.management.ObjectName.getInstance(java.lang.String)
javax.management.ObjectName.getInstance(java.lang.String, java.lang.String, java.lang.String)
javax.management.ObjectName.getInstance(java.lang.String, java.util.Hashtable)
javax.management.ObjectName.getInstance(javax.management.ObjectName)


Occurences of getIntHeader

getIntHeader occurences:
javax.servlet.http.HttpServletRequest.getIntHeader(java.lang.String)
javax.servlet.http.HttpServletRequestWrapper.getIntHeader(java.lang.String)


Occurences of getInvalidAddresses

getInvalidAddresses occurences:
javax.mail.event.TransportEvent.getInvalidAddresses()
javax.mail.SendFailedException.getInvalidAddresses()


Occurences of getJspContext

getJspContext occurences:
javax.servlet.jsp.tagext.JspFragment.getJspContext()
javax.servlet.jsp.tagext.SimpleTagSupport.getJspContext()


Occurences of getLegalValues

getLegalValues occurences:
javax.management.openmbean.OpenMBeanAttributeInfoSupport.getLegalValues()
javax.management.openmbean.OpenMBeanParameterInfo.getLegalValues()
javax.management.openmbean.OpenMBeanParameterInfoSupport.getLegalValues()


Occurences of getLibraryDirectory

getLibraryDirectory occurences:
javax.management.loading.MLet.getLibraryDirectory()
javax.management.loading.MLetMBean.getLibraryDirectory()


Occurences of getLineCount

getLineCount occurences:
javax.mail.internet.MimeBodyPart.getLineCount()
javax.mail.internet.MimeMessage.getLineCount()
javax.mail.Part.getLineCount()


Occurences of getLinkedCause

getLinkedCause occurences:
javax.xml.rpc.JAXRPCException.getLinkedCause()
javax.xml.rpc.ServiceException.getLinkedCause()


Occurences of getLinkedException

getLinkedException occurences:
javax.jms.JMSException.getLinkedException()
javax.resource.ResourceException.getLinkedException()


Occurences of getLocalAddr

getLocalAddr occurences:
javax.servlet.ServletRequest.getLocalAddr()
javax.servlet.ServletRequestWrapper.getLocalAddr()


Occurences of getLocale

getLocale occurences:
javax.servlet.ServletRequest.getLocale()
javax.servlet.ServletRequestWrapper.getLocale()
javax.servlet.ServletResponse.getLocale()
javax.servlet.ServletResponseWrapper.getLocale()
javax.xml.registry.infomodel.LocalizedString.getLocale()


Occurences of getLocales

getLocales occurences:
javax.servlet.ServletRequest.getLocales()
javax.servlet.ServletRequestWrapper.getLocales()


Occurences of getLocalName

getLocalName occurences:
javax.servlet.ServletRequest.getLocalName()
javax.servlet.ServletRequestWrapper.getLocalName()
javax.xml.soap.Name.getLocalName()


Occurences of getLocalPort

getLocalPort occurences:
javax.servlet.ServletRequest.getLocalPort()
javax.servlet.ServletRequestWrapper.getLocalPort()


Occurences of getLocalTransaction

getLocalTransaction occurences:
javax.resource.cci.Connection.getLocalTransaction()
javax.resource.spi.ManagedConnection.getLocalTransaction()


Occurences of getLogWriter

getLogWriter occurences:
javax.resource.spi.ManagedConnection.getLogWriter()
javax.resource.spi.ManagedConnectionFactory.getLogWriter()


Occurences of getLowThreshold

getLowThreshold occurences:
javax.management.monitor.GaugeMonitor.getLowThreshold()
javax.management.monitor.GaugeMonitorMBean.getLowThreshold()


Occurences of getMajorVersion

getMajorVersion occurences:
javax.servlet.ServletContext.getMajorVersion()
javax.xml.registry.infomodel.Versionable.getMajorVersion()


Occurences of getManagedConnectionFactory

getManagedConnectionFactory occurences:
javax.management.j2ee.statistics.JCAConnectionStats.getManagedConnectionFactory()
javax.resource.spi.security.PasswordCredential.getManagedConnectionFactory()


Occurences of getMatchingHeaderLines

getMatchingHeaderLines occurences:
javax.mail.internet.InternetHeaders.getMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimeBodyPart.getMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimeMessage.getMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimePart.getMatchingHeaderLines(java.lang.String[])


Occurences of getMatchingHeaders

getMatchingHeaders occurences:
javax.mail.internet.InternetHeaders.getMatchingHeaders(java.lang.String[])
javax.mail.internet.MimeBodyPart.getMatchingHeaders(java.lang.String[])
javax.mail.internet.MimeMessage.getMatchingHeaders(java.lang.String[])
javax.mail.Part.getMatchingHeaders(java.lang.String[])
javax.xml.soap.MimeHeaders.getMatchingHeaders(java.lang.String[])


Occurences of getMatchingMimeHeaders

getMatchingMimeHeaders occurences:
javax.xml.soap.AttachmentPart.getMatchingMimeHeaders(java.lang.String[])
javax.xml.soap.SOAPPart.getMatchingMimeHeaders(java.lang.String[])


Occurences of getMaxValue

getMaxValue occurences:
javax.management.openmbean.OpenMBeanAttributeInfoSupport.getMaxValue()
javax.management.openmbean.OpenMBeanParameterInfo.getMaxValue()
javax.management.openmbean.OpenMBeanParameterInfoSupport.getMaxValue()


Occurences of getMBeanCount

getMBeanCount occurences:
javax.management.j2ee.Management.getMBeanCount()
javax.management.MBeanServer.getMBeanCount()
javax.management.MBeanServerConnection.getMBeanCount()


Occurences of getMBeanDescriptor

getMBeanDescriptor occurences:
javax.management.modelmbean.ModelMBeanInfo.getMBeanDescriptor()
javax.management.modelmbean.ModelMBeanInfoSupport.getMBeanDescriptor()


Occurences of getMBeanInfo

getMBeanInfo occurences:
javax.management.DynamicMBean.getMBeanInfo()
javax.management.j2ee.Management.getMBeanInfo(javax.management.ObjectName)
javax.management.MBeanServer.getMBeanInfo(javax.management.ObjectName)
javax.management.MBeanServerConnection.getMBeanInfo(javax.management.ObjectName)
javax.management.modelmbean.RequiredModelMBean.getMBeanInfo()
javax.management.StandardMBean.getMBeanInfo()


Occurences of getMBeanServerId

getMBeanServerId occurences:
javax.management.MBeanServerDelegate.getMBeanServerId()
javax.management.MBeanServerDelegateMBean.getMBeanServerId()


Occurences of getMBeansFromURL

getMBeansFromURL occurences:
javax.management.loading.MLet.getMBeansFromURL(java.lang.String)
javax.management.loading.MLet.getMBeansFromURL(java.net.URL)
javax.management.loading.MLetMBean.getMBeansFromURL(java.lang.String)
javax.management.loading.MLetMBean.getMBeansFromURL(java.net.URL)


Occurences of getMechanismType

getMechanismType occurences:
javax.xml.rpc.encoding.Deserializer.getMechanismType()
javax.xml.rpc.encoding.Serializer.getMechanismType()


Occurences of getMessage

getMessage occurences:
javax.ejb.EJBException.getMessage()
javax.enterprise.deploy.spi.status.DeploymentStatus.getMessage()
javax.mail.event.MessageChangedEvent.getMessage()
javax.mail.event.StoreEvent.getMessage()
javax.mail.event.TransportEvent.getMessage()
javax.mail.Folder.getMessage(int)
javax.mail.MessageContext.getMessage()
javax.mail.MessagingException.getMessage()
javax.management.Notification.getMessage()
javax.resource.ResourceException.getMessage()
javax.servlet.jsp.tagext.ValidationMessage.getMessage()
javax.xml.parsers.FactoryConfigurationError.getMessage()
javax.xml.registry.JAXRException.getMessage()
javax.xml.rpc.handler.soap.SOAPMessageContext.getMessage()
javax.xml.soap.SOAPException.getMessage()
javax.xml.transform.TransformerFactoryConfigurationError.getMessage()


Occurences of getMessageContext

getMessageContext occurences:
javax.ejb.SessionContext.getMessageContext()
javax.mail.internet.MimePartDataSource.getMessageContext()
javax.mail.MessageAware.getMessageContext()
javax.xml.rpc.server.ServletEndpointContext.getMessageContext()


Occurences of getMessageCount

getMessageCount occurences:
javax.mail.Folder.getMessageCount()
javax.management.j2ee.statistics.JMSEndpointStats.getMessageCount()
javax.management.j2ee.statistics.JMSSessionStats.getMessageCount()
javax.management.j2ee.statistics.MessageDrivenBeanStats.getMessageCount()


Occurences of getMessageListener

getMessageListener occurences:
javax.jms.MessageConsumer.getMessageListener()
javax.jms.Session.getMessageListener()


Occurences of getMessages

getMessages occurences:
javax.mail.event.MessageCountEvent.getMessages()
javax.mail.Folder.getMessages()
javax.mail.Folder.getMessages(int, int)
javax.mail.Folder.getMessages(int[])


Occurences of getMessagesByUID

getMessagesByUID occurences:
javax.mail.UIDFolder.getMessagesByUID(long, long)
javax.mail.UIDFolder.getMessagesByUID(long[])


Occurences of getMessageSelector

getMessageSelector occurences:
javax.jms.MessageConsumer.getMessageSelector()
javax.jms.QueueBrowser.getMessageSelector()


Occurences of getMessageWaitTime

getMessageWaitTime occurences:
javax.management.j2ee.statistics.JMSEndpointStats.getMessageWaitTime()
javax.management.j2ee.statistics.JMSSessionStats.getMessageWaitTime()


Occurences of getMetaData

getMetaData occurences:
javax.jms.Connection.getMetaData()
javax.resource.cci.Connection.getMetaData()
javax.resource.cci.ConnectionFactory.getMetaData()
javax.resource.spi.ManagedConnection.getMetaData()


Occurences of getMethod

getMethod occurences:
javax.servlet.http.HttpServletRequest.getMethod()
javax.servlet.http.HttpServletRequestWrapper.getMethod()


Occurences of getMimeHeader

getMimeHeader occurences:
javax.xml.soap.AttachmentPart.getMimeHeader(java.lang.String)
javax.xml.soap.SOAPPart.getMimeHeader(java.lang.String)


Occurences of getMimeType

getMimeType occurences:
javax.activation.ActivationDataFlavor.getMimeType()
javax.servlet.ServletContext.getMimeType(java.lang.String)
javax.xml.registry.infomodel.ExtrinsicObject.getMimeType()


Occurences of getMinorVersion

getMinorVersion occurences:
javax.servlet.ServletContext.getMinorVersion()
javax.xml.registry.infomodel.Versionable.getMinorVersion()


Occurences of getMinValue

getMinValue occurences:
javax.management.openmbean.OpenMBeanAttributeInfoSupport.getMinValue()
javax.management.openmbean.OpenMBeanParameterInfo.getMinValue()
javax.management.openmbean.OpenMBeanParameterInfoSupport.getMinValue()


Occurences of getModuleDTDVersion

getModuleDTDVersion occurences:
javax.enterprise.deploy.model.DDBeanRoot.getModuleDTDVersion()
javax.enterprise.deploy.model.DeployableObject.getModuleDTDVersion()


Occurences of getModuleUris

getModuleUris occurences:
javax.enterprise.deploy.model.J2eeApplicationObject.getModuleUris()
javax.enterprise.deploy.model.J2eeApplicationObject.getModuleUris(javax.enterprise.deploy.shared.ModuleType)


Occurences of getModulus

getModulus occurences:
javax.management.monitor.CounterMonitor.getModulus()
javax.management.monitor.CounterMonitorMBean.getModulus()


Occurences of getName

getName occurences:
javax.activation.DataHandler.getName()
javax.activation.DataSource.getName()
javax.activation.FileDataSource.getName()
javax.activation.URLDataSource.getName()
javax.enterprise.deploy.spi.Target.getName()
javax.mail.Folder.getName()
javax.mail.Header.getName()
javax.mail.internet.MimePartDataSource.getName()
javax.management.Attribute.getName()
javax.management.j2ee.statistics.Statistic.getName()
javax.management.MBeanFeatureInfo.getName()
javax.management.openmbean.OpenMBeanConstructorInfo.getName()
javax.management.openmbean.OpenMBeanOperationInfo.getName()
javax.management.openmbean.OpenMBeanParameterInfo.getName()
javax.management.relation.RoleInfo.getName()
javax.resource.spi.security.GenericCredential.getName()
javax.servlet.http.Cookie.getName()
javax.servlet.http.HttpSessionBindingEvent.getName()
javax.servlet.jsp.tagext.FunctionInfo.getName()
javax.servlet.jsp.tagext.TagAttributeInfo.getName()
javax.servlet.jsp.tagext.TagFileInfo.getName()
javax.servlet.ServletContextAttributeEvent.getName()
javax.servlet.ServletRequestAttributeEvent.getName()
javax.xml.registry.infomodel.RegistryObject.getName()
javax.xml.registry.infomodel.Slot.getName()
javax.xml.soap.MimeHeader.getName()


Occurences of getNames

getNames occurences:
javax.activation.MimeTypeParameterList.getNames()
javax.mail.internet.ParameterList.getNames()


Occurences of getNamespaceURI

getNamespaceURI occurences:
javax.xml.namespace.QName.getNamespaceURI()
javax.xml.soap.SOAPElement.getNamespaceURI(java.lang.String)


Occurences of getNbNotifications

getNbNotifications occurences:
javax.management.timer.Timer.getNbNotifications()
javax.management.timer.TimerMBean.getNbNotifications()


Occurences of getNbOccurences

getNbOccurences occurences:
javax.management.timer.Timer.getNbOccurences(java.lang.Integer)
javax.management.timer.TimerMBean.getNbOccurences(java.lang.Integer)


Occurences of getNode

getNode occurences:
javax.xml.transform.dom.DOMResult.getNode()
javax.xml.transform.dom.DOMSource.getNode()


Occurences of getNonMatchingHeaderLines

getNonMatchingHeaderLines occurences:
javax.mail.internet.InternetHeaders.getNonMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimeBodyPart.getNonMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimeMessage.getNonMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimePart.getNonMatchingHeaderLines(java.lang.String[])


Occurences of getNonMatchingHeaders

getNonMatchingHeaders occurences:
javax.mail.internet.InternetHeaders.getNonMatchingHeaders(java.lang.String[])
javax.mail.internet.MimeBodyPart.getNonMatchingHeaders(java.lang.String[])
javax.mail.internet.MimeMessage.getNonMatchingHeaders(java.lang.String[])
javax.mail.Part.getNonMatchingHeaders(java.lang.String[])
javax.xml.soap.MimeHeaders.getNonMatchingHeaders(java.lang.String[])


Occurences of getNonMatchingMimeHeaders

getNonMatchingMimeHeaders occurences:
javax.xml.soap.AttachmentPart.getNonMatchingMimeHeaders(java.lang.String[])
javax.xml.soap.SOAPPart.getNonMatchingMimeHeaders(java.lang.String[])


Occurences of getNotification

getNotification occurences:
javax.management.modelmbean.ModelMBeanInfo.getNotification(java.lang.String)
javax.management.modelmbean.ModelMBeanInfoSupport.getNotification(java.lang.String)


Occurences of getNotificationIDs

getNotificationIDs occurences:
javax.management.timer.Timer.getNotificationIDs(java.lang.String)
javax.management.timer.TimerMBean.getNotificationIDs(java.lang.String)


Occurences of getNotificationInfo

getNotificationInfo occurences:
javax.management.MBeanServerDelegate.getNotificationInfo()
javax.management.modelmbean.RequiredModelMBean.getNotificationInfo()
javax.management.monitor.CounterMonitor.getNotificationInfo()
javax.management.monitor.GaugeMonitor.getNotificationInfo()
javax.management.monitor.StringMonitor.getNotificationInfo()
javax.management.NotificationBroadcaster.getNotificationInfo()
javax.management.NotificationBroadcasterSupport.getNotificationInfo()
javax.management.relation.RelationService.getNotificationInfo()


Occurences of getNotificationMessage

getNotificationMessage occurences:
javax.management.timer.Timer.getNotificationMessage(java.lang.Integer)
javax.management.timer.TimerMBean.getNotificationMessage(java.lang.Integer)


Occurences of getNotifications

getNotifications occurences:
javax.management.MBeanInfo.getNotifications()
javax.management.modelmbean.ModelMBeanInfo.getNotifications()
javax.management.openmbean.OpenMBeanInfo.getNotifications()


Occurences of getNotificationType

getNotificationType occurences:
javax.management.timer.Timer.getNotificationType(java.lang.Integer)
javax.management.timer.TimerMBean.getNotificationType(java.lang.Integer)


Occurences of getNotificationUserData

getNotificationUserData occurences:
javax.management.timer.Timer.getNotificationUserData(java.lang.Integer)
javax.management.timer.TimerMBean.getNotificationUserData(java.lang.Integer)


Occurences of getNotify

getNotify occurences:
javax.management.monitor.CounterMonitor.getNotify()
javax.management.monitor.CounterMonitorMBean.getNotify()


Occurences of getNotifyDiffer

getNotifyDiffer occurences:
javax.management.monitor.StringMonitor.getNotifyDiffer()
javax.management.monitor.StringMonitorMBean.getNotifyDiffer()


Occurences of getNotifyHigh

getNotifyHigh occurences:
javax.management.monitor.GaugeMonitor.getNotifyHigh()
javax.management.monitor.GaugeMonitorMBean.getNotifyHigh()


Occurences of getNotifyLow

getNotifyLow occurences:
javax.management.monitor.GaugeMonitor.getNotifyLow()
javax.management.monitor.GaugeMonitorMBean.getNotifyLow()


Occurences of getNotifyMatch

getNotifyMatch occurences:
javax.management.monitor.StringMonitor.getNotifyMatch()
javax.management.monitor.StringMonitorMBean.getNotifyMatch()


Occurences of getNumber

getNumber occurences:
javax.mail.search.IntegerComparisonTerm.getNumber()
javax.xml.registry.infomodel.TelephoneNumber.getNumber()


Occurences of getObject

getObject occurences:
javax.jms.MapMessage.getObject(java.lang.String)
javax.jms.ObjectMessage.getObject()


Occurences of getObjectInstance

getObjectInstance occurences:
javax.management.MBeanServer.getObjectInstance(javax.management.ObjectName)
javax.management.MBeanServerConnection.getObjectInstance(javax.management.ObjectName)


Occurences of getObjectName

getObjectName occurences:
javax.management.ObjectInstance.getObjectName()
javax.management.relation.RelationNotification.getObjectName()


Occurences of getObservedAttribute

getObservedAttribute occurences:
javax.management.monitor.Monitor.getObservedAttribute()
javax.management.monitor.MonitorMBean.getObservedAttribute()
javax.management.monitor.MonitorNotification.getObservedAttribute()


Occurences of getObservedObject

getObservedObject occurences:
javax.management.monitor.Monitor.getObservedObject()
javax.management.monitor.MonitorMBean.getObservedObject()
javax.management.monitor.MonitorNotification.getObservedObject()


Occurences of getObservedObjects

getObservedObjects occurences:
javax.management.monitor.Monitor.getObservedObjects()
javax.management.monitor.MonitorMBean.getObservedObjects()


Occurences of getOffset

getOffset occurences:
javax.enterprise.deploy.shared.ActionType.getOffset()
javax.enterprise.deploy.shared.CommandType.getOffset()
javax.enterprise.deploy.shared.DConfigBeanVersionType.getOffset()
javax.enterprise.deploy.shared.ModuleType.getOffset()
javax.enterprise.deploy.shared.StateType.getOffset()
javax.management.monitor.CounterMonitor.getOffset()
javax.management.monitor.CounterMonitorMBean.getOffset()


Occurences of getOpenType

getOpenType occurences:
javax.management.openmbean.OpenMBeanAttributeInfoSupport.getOpenType()
javax.management.openmbean.OpenMBeanParameterInfo.getOpenType()
javax.management.openmbean.OpenMBeanParameterInfoSupport.getOpenType()


Occurences of getOperation

getOperation occurences:
javax.management.modelmbean.ModelMBeanInfo.getOperation(java.lang.String)
javax.management.modelmbean.ModelMBeanInfoSupport.getOperation(java.lang.String)


Occurences of getOperations

getOperations occurences:
javax.management.MBeanInfo.getOperations()
javax.management.modelmbean.ModelMBeanInfo.getOperations()
javax.management.openmbean.OpenMBeanInfo.getOperations()


Occurences of getOutputProperties

getOutputProperties occurences:
javax.xml.transform.Templates.getOutputProperties()
javax.xml.transform.Transformer.getOutputProperties()


Occurences of getOutputStream

getOutputStream occurences:
javax.activation.DataHandler.getOutputStream()
javax.activation.DataSource.getOutputStream()
javax.activation.FileDataSource.getOutputStream()
javax.activation.URLDataSource.getOutputStream()
javax.mail.internet.MimePartDataSource.getOutputStream()
javax.servlet.ServletResponse.getOutputStream()
javax.servlet.ServletResponseWrapper.getOutputStream()
javax.xml.transform.stream.StreamResult.getOutputStream()


Occurences of getParameter

getParameter occurences:
javax.activation.MimeType.getParameter(java.lang.String)
javax.mail.internet.ContentDisposition.getParameter(java.lang.String)
javax.mail.internet.ContentType.getParameter(java.lang.String)
javax.servlet.ServletRequest.getParameter(java.lang.String)
javax.servlet.ServletRequestWrapper.getParameter(java.lang.String)
javax.xml.transform.Transformer.getParameter(java.lang.String)


Occurences of getParameterList

getParameterList occurences:
javax.mail.internet.ContentDisposition.getParameterList()
javax.mail.internet.ContentType.getParameterList()


Occurences of getParameterMap

getParameterMap occurences:
javax.servlet.ServletRequest.getParameterMap()
javax.servlet.ServletRequestWrapper.getParameterMap()


Occurences of getParameterName

getParameterName occurences:
javax.management.StandardMBean.getParameterName(javax.management.MBeanConstructorInfo, javax.management.MBeanParameterInfo, int)
javax.management.StandardMBean.getParameterName(javax.management.MBeanOperationInfo, javax.management.MBeanParameterInfo, int)


Occurences of getParameterNames

getParameterNames occurences:
javax.servlet.ServletRequest.getParameterNames()
javax.servlet.ServletRequestWrapper.getParameterNames()


Occurences of getParameterValues

getParameterValues occurences:
javax.servlet.ServletRequest.getParameterValues(java.lang.String)
javax.servlet.ServletRequestWrapper.getParameterValues(java.lang.String)


Occurences of getParent

getParent occurences:
javax.mail.BodyPart.getParent()
javax.mail.Folder.getParent()
javax.mail.Multipart.getParent()
javax.servlet.jsp.tagext.SimpleTag.getParent()
javax.servlet.jsp.tagext.SimpleTagSupport.getParent()
javax.servlet.jsp.tagext.Tag.getParent()
javax.servlet.jsp.tagext.TagAdapter.getParent()
javax.servlet.jsp.tagext.TagSupport.getParent()
javax.xml.registry.infomodel.Concept.getParent()


Occurences of getPassword

getPassword occurences:
javax.mail.PasswordAuthentication.getPassword()
javax.mail.URLName.getPassword()
javax.resource.spi.security.PasswordCredential.getPassword()


Occurences of getPasswordAuthentication

getPasswordAuthentication occurences:
javax.mail.Authenticator.getPasswordAuthentication()
javax.mail.Session.getPasswordAuthentication(javax.mail.URLName)


Occurences of getPath

getPath occurences:
javax.servlet.http.Cookie.getPath()
javax.servlet.jsp.tagext.TagFileInfo.getPath()
javax.xml.registry.infomodel.Concept.getPath()


Occurences of getPathInfo

getPathInfo occurences:
javax.servlet.http.HttpServletRequest.getPathInfo()
javax.servlet.http.HttpServletRequestWrapper.getPathInfo()


Occurences of getPathTranslated

getPathTranslated occurences:
javax.servlet.http.HttpServletRequest.getPathTranslated()
javax.servlet.http.HttpServletRequestWrapper.getPathTranslated()


Occurences of getPendingMessageCount

getPendingMessageCount occurences:
javax.management.j2ee.statistics.JMSEndpointStats.getPendingMessageCount()
javax.management.j2ee.statistics.JMSSessionStats.getPendingMessageCount()


Occurences of getPeriod

getPeriod occurences:
javax.management.timer.Timer.getPeriod(java.lang.Integer)
javax.management.timer.TimerMBean.getPeriod(java.lang.Integer)


Occurences of getPoolSize

getPoolSize occurences:
javax.management.j2ee.statistics.JCAConnectionPoolStats.getPoolSize()
javax.management.j2ee.statistics.JDBCConnectionPoolStats.getPoolSize()


Occurences of getPort

getPort occurences:
javax.mail.URLName.getPort()
javax.xml.rpc.Service.getPort(java.lang.Class)
javax.xml.rpc.Service.getPort(javax.xml.namespace.QName, java.lang.Class)


Occurences of getPreferredCommands

getPreferredCommands occurences:
javax.activation.CommandMap.getPreferredCommands(java.lang.String)
javax.activation.DataHandler.getPreferredCommands()
javax.activation.MailcapCommandMap.getPreferredCommands(java.lang.String)


Occurences of getPrefix

getPrefix occurences:
javax.xml.namespace.QName.getPrefix()
javax.xml.soap.Name.getPrefix()


Occurences of getPrimaryKey

getPrimaryKey occurences:
javax.ejb.EJBLocalObject.getPrimaryKey()
javax.ejb.EJBObject.getPrimaryKey()
javax.ejb.EntityContext.getPrimaryKey()


Occurences of getPrimaryType

getPrimaryType occurences:
javax.activation.MimeType.getPrimaryType()
javax.mail.internet.ContentType.getPrimaryType()


Occurences of getProperties

getProperties occurences:
javax.mail.Session.getProperties()
javax.xml.registry.ConnectionFactory.getProperties()


Occurences of getProperty

getProperty occurences:
javax.mail.Session.getProperty(java.lang.String)
javax.xml.parsers.SAXParser.getProperty(java.lang.String)
javax.xml.rpc.Call.getProperty(java.lang.String)
javax.xml.rpc.handler.MessageContext.getProperty(java.lang.String)
javax.xml.soap.SOAPMessage.getProperty(java.lang.String)


Occurences of getPropertyNames

getPropertyNames occurences:
javax.jms.Message.getPropertyNames()
javax.xml.rpc.Call.getPropertyNames()
javax.xml.rpc.handler.MessageContext.getPropertyNames()


Occurences of getProtocol

getProtocol occurences:
javax.mail.Provider.getProtocol()
javax.mail.URLName.getProtocol()
javax.servlet.ServletRequest.getProtocol()
javax.servlet.ServletRequestWrapper.getProtocol()


Occurences of getPublicId

getPublicId occurences:
javax.xml.transform.SourceLocator.getPublicId()
javax.xml.transform.stream.StreamSource.getPublicId()


Occurences of getPurgeFlag

getPurgeFlag occurences:
javax.management.relation.RelationService.getPurgeFlag()
javax.management.relation.RelationServiceMBean.getPurgeFlag()


Occurences of getQueryString

getQueryString occurences:
javax.servlet.http.HttpServletRequest.getQueryString()
javax.servlet.http.HttpServletRequestWrapper.getQueryString()


Occurences of getQueue

getQueue occurences:
javax.jms.QueueBrowser.getQueue()
javax.jms.QueueReceiver.getQueue()
javax.jms.QueueSender.getQueue()


Occurences of getRawInputStream

getRawInputStream occurences:
javax.mail.internet.MimeBodyPart.getRawInputStream()
javax.mail.internet.MimeMessage.getRawInputStream()


Occurences of getReader

getReader occurences:
javax.servlet.jsp.tagext.BodyContent.getReader()
javax.servlet.ServletRequest.getReader()
javax.servlet.ServletRequestWrapper.getReader()
javax.xml.transform.stream.StreamSource.getReader()


Occurences of getRealPath

getRealPath occurences:
javax.servlet.ServletContext.getRealPath(java.lang.String)
javax.servlet.ServletRequest.getRealPath(java.lang.String)
javax.servlet.ServletRequestWrapper.getRealPath(java.lang.String)


Occurences of getReceivedDate

getReceivedDate occurences:
javax.mail.internet.MimeMessage.getReceivedDate()
javax.mail.Message.getReceivedDate()


Occurences of getRecipients

getRecipients occurences:
javax.mail.internet.MimeMessage.getRecipients(javax.mail.Message.RecipientType)
javax.mail.Message.getRecipients(javax.mail.Message.RecipientType)


Occurences of getRecipientType

getRecipientType occurences:
javax.mail.search.RecipientStringTerm.getRecipientType()
javax.mail.search.RecipientTerm.getRecipientType()


Occurences of getRef

getRef occurences:
javax.mail.internet.AddressException.getRef()
javax.mail.URLName.getRef()


Occurences of getReferencedMBeans

getReferencedMBeans occurences:
javax.management.relation.Relation.getReferencedMBeans()
javax.management.relation.RelationService.getReferencedMBeans(java.lang.String)
javax.management.relation.RelationServiceMBean.getReferencedMBeans(java.lang.String)
javax.management.relation.RelationSupport.getReferencedMBeans()


Occurences of getRegistryObject

getRegistryObject occurences:
javax.xml.registry.infomodel.AuditableEvent.getRegistryObject()
javax.xml.registry.infomodel.ExternalIdentifier.getRegistryObject()
javax.xml.registry.QueryManager.getRegistryObject(java.lang.String)
javax.xml.registry.QueryManager.getRegistryObject(java.lang.String, java.lang.String)


Occurences of getRegistryObjects

getRegistryObjects occurences:
javax.xml.registry.infomodel.RegistryPackage.getRegistryObjects()
javax.xml.registry.QueryManager.getRegistryObjects()
javax.xml.registry.QueryManager.getRegistryObjects(java.lang.String)
javax.xml.registry.QueryManager.getRegistryObjects(java.util.Collection)
javax.xml.registry.QueryManager.getRegistryObjects(java.util.Collection, java.lang.String)


Occurences of getRegistryService

getRegistryService occurences:
javax.xml.registry.Connection.getRegistryService()
javax.xml.registry.LifeCycleManager.getRegistryService()
javax.xml.registry.QueryManager.getRegistryService()


Occurences of getRelationId

getRelationId occurences:
javax.management.relation.Relation.getRelationId()
javax.management.relation.RelationNotification.getRelationId()
javax.management.relation.RelationSupport.getRelationId()


Occurences of getRelationServiceName

getRelationServiceName occurences:
javax.management.relation.Relation.getRelationServiceName()
javax.management.relation.RelationSupport.getRelationServiceName()


Occurences of getRelationTypeName

getRelationTypeName occurences:
javax.management.relation.Relation.getRelationTypeName()
javax.management.relation.RelationNotification.getRelationTypeName()
javax.management.relation.RelationService.getRelationTypeName(java.lang.String)
javax.management.relation.RelationServiceMBean.getRelationTypeName(java.lang.String)
javax.management.relation.RelationSupport.getRelationTypeName()
javax.management.relation.RelationType.getRelationTypeName()
javax.management.relation.RelationTypeSupport.getRelationTypeName()


Occurences of getRemoteAddr

getRemoteAddr occurences:
javax.servlet.ServletRequest.getRemoteAddr()
javax.servlet.ServletRequestWrapper.getRemoteAddr()


Occurences of getRemoteHost

getRemoteHost occurences:
javax.servlet.ServletRequest.getRemoteHost()
javax.servlet.ServletRequestWrapper.getRemoteHost()


Occurences of getRemotePort

getRemotePort occurences:
javax.servlet.ServletRequest.getRemotePort()
javax.servlet.ServletRequestWrapper.getRemotePort()


Occurences of getRemoteUser

getRemoteUser occurences:
javax.servlet.http.HttpServletRequest.getRemoteUser()
javax.servlet.http.HttpServletRequestWrapper.getRemoteUser()


Occurences of getReplyTo

getReplyTo occurences:
javax.mail.internet.MimeMessage.getReplyTo()
javax.mail.Message.getReplyTo()


Occurences of getRequest

getRequest occurences:
javax.servlet.jsp.PageContext.getRequest()
javax.servlet.ServletRequestWrapper.getRequest()


Occurences of getRequestDispatcher

getRequestDispatcher occurences:
javax.servlet.ServletContext.getRequestDispatcher(java.lang.String)
javax.servlet.ServletRequest.getRequestDispatcher(java.lang.String)
javax.servlet.ServletRequestWrapper.getRequestDispatcher(java.lang.String)


Occurences of getRequestedSessionId

getRequestedSessionId occurences:
javax.servlet.http.HttpServletRequest.getRequestedSessionId()
javax.servlet.http.HttpServletRequestWrapper.getRequestedSessionId()


Occurences of getRequestId

getRequestId occurences:
javax.xml.registry.JAXRException.getRequestId()
javax.xml.registry.JAXRResponse.getRequestId()


Occurences of getRequestURI

getRequestURI occurences:
javax.servlet.http.HttpServletRequest.getRequestURI()
javax.servlet.http.HttpServletRequestWrapper.getRequestURI()
javax.servlet.jsp.ErrorData.getRequestURI()


Occurences of getRequestURL

getRequestURL occurences:
javax.servlet.http.HttpServletRequest.getRequestURL()
javax.servlet.http.HttpServletRequestWrapper.getRequestURL()
javax.servlet.http.HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest)


Occurences of getResource

getResource occurences:
javax.management.loading.MLetMBean.getResource(java.lang.String)
javax.servlet.ServletContext.getResource(java.lang.String)


Occurences of getResourceAsStream

getResourceAsStream occurences:
javax.management.loading.MLetMBean.getResourceAsStream(java.lang.String)
javax.servlet.ServletContext.getResourceAsStream(java.lang.String)


Occurences of getResponse

getResponse occurences:
javax.servlet.jsp.PageContext.getResponse()
javax.servlet.ServletResponseWrapper.getResponse()


Occurences of getReturnOpenType

getReturnOpenType occurences:
javax.management.openmbean.OpenMBeanOperationInfo.getReturnOpenType()
javax.management.openmbean.OpenMBeanOperationInfoSupport.getReturnOpenType()


Occurences of getReturnType

getReturnType occurences:
javax.management.MBeanOperationInfo.getReturnType()
javax.management.openmbean.OpenMBeanOperationInfo.getReturnType()
javax.xml.rpc.Call.getReturnType()


Occurences of getRole

getRole occurences:
javax.management.relation.Relation.getRole(java.lang.String)
javax.management.relation.RelationService.getRole(java.lang.String, java.lang.String)
javax.management.relation.RelationServiceMBean.getRole(java.lang.String, java.lang.String)
javax.management.relation.RelationSupport.getRole(java.lang.String)


Occurences of getRoleCardinality

getRoleCardinality occurences:
javax.management.relation.Relation.getRoleCardinality(java.lang.String)
javax.management.relation.RelationService.getRoleCardinality(java.lang.String, java.lang.String)
javax.management.relation.RelationServiceMBean.getRoleCardinality(java.lang.String, java.lang.String)
javax.management.relation.RelationSupport.getRoleCardinality(java.lang.String)


Occurences of getRoleInfo

getRoleInfo occurences:
javax.management.relation.RelationService.getRoleInfo(java.lang.String, java.lang.String)
javax.management.relation.RelationServiceMBean.getRoleInfo(java.lang.String, java.lang.String)
javax.management.relation.RelationType.getRoleInfo(java.lang.String)
javax.management.relation.RelationTypeSupport.getRoleInfo(java.lang.String)


Occurences of getRoleInfos

getRoleInfos occurences:
javax.management.relation.RelationService.getRoleInfos(java.lang.String)
javax.management.relation.RelationServiceMBean.getRoleInfos(java.lang.String)
javax.management.relation.RelationType.getRoleInfos()
javax.management.relation.RelationTypeSupport.getRoleInfos()


Occurences of getRoleName

getRoleName occurences:
javax.management.relation.RelationNotification.getRoleName()
javax.management.relation.Role.getRoleName()
javax.management.relation.RoleUnresolved.getRoleName()


Occurences of getRoles

getRoles occurences:
javax.management.relation.Relation.getRoles(java.lang.String[])
javax.management.relation.RelationService.getRoles(java.lang.String, java.lang.String[])
javax.management.relation.RelationServiceMBean.getRoles(java.lang.String, java.lang.String[])
javax.management.relation.RelationSupport.getRoles(java.lang.String[])
javax.management.relation.RoleResult.getRoles()
javax.xml.rpc.handler.HandlerChain.getRoles()
javax.xml.rpc.handler.soap.SOAPMessageContext.getRoles()


Occurences of getRoleValue

getRoleValue occurences:
javax.management.relation.Role.getRoleValue()
javax.management.relation.RoleUnresolved.getRoleValue()


Occurences of getRootCause

getRootCause occurences:
javax.servlet.jsp.el.ELException.getRootCause()
javax.servlet.jsp.JspException.getRootCause()
javax.servlet.ServletException.getRootCause()


Occurences of getScheme

getScheme occurences:
javax.servlet.ServletRequest.getScheme()
javax.servlet.ServletRequestWrapper.getScheme()


Occurences of getScope

getScope occurences:
javax.servlet.jsp.tagext.TagVariableInfo.getScope()
javax.servlet.jsp.tagext.VariableInfo.getScope()


Occurences of getSendPastNotifications

getSendPastNotifications occurences:
javax.management.timer.Timer.getSendPastNotifications()
javax.management.timer.TimerMBean.getSendPastNotifications()


Occurences of getSentDate

getSentDate occurences:
javax.mail.internet.MimeMessage.getSentDate()
javax.mail.Message.getSentDate()


Occurences of getServerName

getServerName occurences:
javax.servlet.ServletRequest.getServerName()
javax.servlet.ServletRequestWrapper.getServerName()


Occurences of getServerPort

getServerPort occurences:
javax.servlet.ServletRequest.getServerPort()
javax.servlet.ServletRequestWrapper.getServerPort()


Occurences of getServlet

getServlet occurences:
javax.servlet.ServletContext.getServlet(java.lang.String)
javax.servlet.UnavailableException.getServlet()


Occurences of getServletConfig

getServletConfig occurences:
javax.servlet.GenericServlet.getServletConfig()
javax.servlet.jsp.PageContext.getServletConfig()
javax.servlet.Servlet.getServletConfig()


Occurences of getServletContext

getServletContext occurences:
javax.servlet.FilterConfig.getServletContext()
javax.servlet.GenericServlet.getServletContext()
javax.servlet.http.HttpSession.getServletContext()
javax.servlet.jsp.PageContext.getServletContext()
javax.servlet.ServletConfig.getServletContext()
javax.servlet.ServletContextEvent.getServletContext()
javax.servlet.ServletRequestEvent.getServletContext()
javax.xml.rpc.server.ServletEndpointContext.getServletContext()


Occurences of getServletInfo

getServletInfo occurences:
javax.servlet.GenericServlet.getServletInfo()
javax.servlet.Servlet.getServletInfo()


Occurences of getServletName

getServletName occurences:
javax.servlet.GenericServlet.getServletName()
javax.servlet.jsp.ErrorData.getServletName()
javax.servlet.ServletConfig.getServletName()


Occurences of getServletPath

getServletPath occurences:
javax.servlet.http.HttpServletRequest.getServletPath()
javax.servlet.http.HttpServletRequestWrapper.getServletPath()


Occurences of getSession

getSession occurences:
javax.jms.ServerSession.getSession()
javax.jms.XASession.getSession()
javax.mail.MessageContext.getSession()
javax.servlet.http.HttpServletRequest.getSession()
javax.servlet.http.HttpServletRequest.getSession(boolean)
javax.servlet.http.HttpServletRequestWrapper.getSession()
javax.servlet.http.HttpServletRequestWrapper.getSession(boolean)
javax.servlet.http.HttpSessionBindingEvent.getSession()
javax.servlet.http.HttpSessionContext.getSession(java.lang.String)
javax.servlet.http.HttpSessionEvent.getSession()
javax.servlet.jsp.PageContext.getSession()


Occurences of getSignature

getSignature occurences:
javax.management.MBeanConstructorInfo.getSignature()
javax.management.MBeanOperationInfo.getSignature()
javax.management.openmbean.OpenMBeanConstructorInfo.getSignature()
javax.management.openmbean.OpenMBeanOperationInfo.getSignature()


Occurences of getSize

getSize occurences:
javax.mail.internet.MimeBodyPart.getSize()
javax.mail.internet.MimeMessage.getSize()
javax.mail.Part.getSize()
javax.xml.soap.AttachmentPart.getSize()


Occurences of getSpecificationName

getSpecificationName occurences:
javax.management.MBeanServerDelegate.getSpecificationName()
javax.management.MBeanServerDelegateMBean.getSpecificationName()


Occurences of getSpecificationVendor

getSpecificationVendor occurences:
javax.management.MBeanServerDelegate.getSpecificationVendor()
javax.management.MBeanServerDelegateMBean.getSpecificationVendor()


Occurences of getSpecificationVersion

getSpecificationVersion occurences:
javax.management.MBeanServerDelegate.getSpecificationVersion()
javax.management.MBeanServerDelegateMBean.getSpecificationVersion()
javax.servlet.jsp.JspEngineInfo.getSpecificationVersion()


Occurences of getStatus

getStatus occurences:
javax.transaction.Transaction.getStatus()
javax.transaction.TransactionManager.getStatus()
javax.transaction.UserTransaction.getStatus()
javax.xml.registry.infomodel.RegistryEntry.getStatus()
javax.xml.registry.JAXRException.getStatus()
javax.xml.registry.JAXRResponse.getStatus()


Occurences of getStore

getStore occurences:
javax.mail.Folder.getStore()
javax.mail.Session.getStore()
javax.mail.Session.getStore(java.lang.String)
javax.mail.Session.getStore(javax.mail.Provider)
javax.mail.Session.getStore(javax.mail.URLName)
javax.mail.StoreClosedException.getStore()


Occurences of getString

getString occurences:
javax.jms.MapMessage.getString(java.lang.String)
javax.servlet.jsp.tagext.BodyContent.getString()


Occurences of getStringTable

getStringTable occurences:
javax.enterprise.deploy.shared.ActionType.getStringTable()
javax.enterprise.deploy.shared.CommandType.getStringTable()
javax.enterprise.deploy.shared.DConfigBeanVersionType.getStringTable()
javax.enterprise.deploy.shared.ModuleType.getStringTable()
javax.enterprise.deploy.shared.StateType.getStringTable()


Occurences of getStringToCompare

getStringToCompare occurences:
javax.management.monitor.StringMonitor.getStringToCompare()
javax.management.monitor.StringMonitorMBean.getStringToCompare()


Occurences of getSubject

getSubject occurences:
javax.mail.internet.MimeMessage.getSubject()
javax.mail.Message.getSubject()


Occurences of getSubType

getSubType occurences:
javax.activation.MimeType.getSubType()
javax.mail.internet.ContentType.getSubType()


Occurences of getSupportedMechanismTypes

getSupportedMechanismTypes occurences:
javax.xml.rpc.encoding.DeserializerFactory.getSupportedMechanismTypes()
javax.xml.rpc.encoding.SerializerFactory.getSupportedMechanismTypes()


Occurences of getSystemId

getSystemId occurences:
javax.xml.transform.dom.DOMResult.getSystemId()
javax.xml.transform.dom.DOMSource.getSystemId()
javax.xml.transform.Result.getSystemId()
javax.xml.transform.sax.SAXResult.getSystemId()
javax.xml.transform.sax.SAXSource.getSystemId()
javax.xml.transform.sax.TemplatesHandler.getSystemId()
javax.xml.transform.sax.TransformerHandler.getSystemId()
javax.xml.transform.Source.getSystemId()
javax.xml.transform.SourceLocator.getSystemId()
javax.xml.transform.stream.StreamResult.getSystemId()
javax.xml.transform.stream.StreamSource.getSystemId()


Occurences of getTabularType

getTabularType occurences:
javax.management.openmbean.TabularData.getTabularType()
javax.management.openmbean.TabularDataSupport.getTabularType()


Occurences of getTagInfo

getTagInfo occurences:
javax.servlet.jsp.tagext.TagExtraInfo.getTagInfo()
javax.servlet.jsp.tagext.TagFileInfo.getTagInfo()


Occurences of getTargetException

getTargetException occurences:
javax.management.MBeanException.getTargetException()
javax.management.ReflectionException.getTargetException()
javax.management.RuntimeMBeanException.getTargetException()
javax.management.RuntimeOperationsException.getTargetException()


Occurences of getTelephoneNumbers

getTelephoneNumbers occurences:
javax.xml.registry.infomodel.Organization.getTelephoneNumbers(java.lang.String)
javax.xml.registry.infomodel.User.getTelephoneNumbers(java.lang.String)


Occurences of getTerms

getTerms occurences:
javax.mail.search.AndTerm.getTerms()
javax.mail.search.OrTerm.getTerms()


Occurences of getText

getText occurences:
javax.enterprise.deploy.model.DDBean.getText()
javax.enterprise.deploy.model.DDBean.getText(java.lang.String)
javax.enterprise.deploy.model.DeployableObject.getText(java.lang.String)
javax.enterprise.deploy.model.J2eeApplicationObject.getText(javax.enterprise.deploy.shared.ModuleType, java.lang.String)
javax.jms.TextMessage.getText()


Occurences of getThreshold

getThreshold occurences:
javax.management.monitor.CounterMonitor.getThreshold()
javax.management.monitor.CounterMonitor.getThreshold(javax.management.ObjectName)
javax.management.monitor.CounterMonitorMBean.getThreshold()
javax.management.monitor.CounterMonitorMBean.getThreshold(javax.management.ObjectName)


Occurences of getTopic

getTopic occurences:
javax.jms.TopicPublisher.getTopic()
javax.jms.TopicSubscriber.getTopic()


Occurences of getTransacted

getTransacted occurences:
javax.jms.Session.getTransacted()
javax.jms.XASession.getTransacted()


Occurences of getTransactionTimeout

getTransactionTimeout occurences:
javax.resource.spi.work.ExecutionContext.getTransactionTimeout()
javax.transaction.xa.XAResource.getTransactionTimeout()


Occurences of getTransferData

getTransferData occurences:
javax.activation.DataContentHandler.getTransferData(java.awt.datatransfer.DataFlavor, javax.activation.DataSource)
javax.activation.DataHandler.getTransferData(java.awt.datatransfer.DataFlavor)


Occurences of getTransferDataFlavors

getTransferDataFlavors occurences:
javax.activation.DataContentHandler.getTransferDataFlavors()
javax.activation.DataHandler.getTransferDataFlavors()


Occurences of getTransport

getTransport occurences:
javax.mail.Session.getTransport()
javax.mail.Session.getTransport(java.lang.String)
javax.mail.Session.getTransport(javax.mail.Address)
javax.mail.Session.getTransport(javax.mail.Provider)
javax.mail.Session.getTransport(javax.mail.URLName)


Occurences of getType

getType occurences:
javax.enterprise.deploy.model.DDBeanRoot.getType()
javax.enterprise.deploy.model.DeployableObject.getType()
javax.mail.Address.getType()
javax.mail.event.ConnectionEvent.getType()
javax.mail.event.FolderEvent.getType()
javax.mail.event.MessageCountEvent.getType()
javax.mail.event.TransportEvent.getType()
javax.mail.Folder.getType()
javax.mail.internet.HeaderTokenizer.Token.getType()
javax.mail.internet.InternetAddress.getType()
javax.mail.internet.NewsAddress.getType()
javax.mail.Provider.getType()
javax.management.MBeanAttributeInfo.getType()
javax.management.MBeanParameterInfo.getType()
javax.management.Notification.getType()
javax.management.openmbean.CompositeType.getType(java.lang.String)
javax.resource.spi.work.WorkEvent.getType()
javax.xml.registry.infomodel.EmailAddress.getType()
javax.xml.registry.infomodel.PostalAddress.getType()
javax.xml.registry.infomodel.TelephoneNumber.getType()
javax.xml.registry.infomodel.User.getType()
javax.xml.registry.Query.getType()


Occurences of getTypeName

getTypeName occurences:
javax.management.openmbean.OpenType.getTypeName()
javax.servlet.jsp.tagext.TagAttributeInfo.getTypeName()


Occurences of getURI

getURI occurences:
javax.servlet.jsp.tagext.TagLibraryInfo.getURI()
javax.xml.soap.Name.getURI()


Occurences of getURIResolver

getURIResolver occurences:
javax.xml.transform.Transformer.getURIResolver()
javax.xml.transform.TransformerFactory.getURIResolver()


Occurences of getURL

getURL occurences:
javax.activation.URLDataSource.getURL()
javax.mail.URLName.getURL()


Occurences of getUrl

getUrl occurences:
javax.xml.registry.infomodel.TelephoneNumber.getUrl()
javax.xml.registry.infomodel.User.getUrl()


Occurences of getURLName

getURLName occurences:
javax.mail.Folder.getURLName()
javax.mail.Service.getURLName()


Occurences of getURLs

getURLs occurences:
javax.management.loading.MLet.getURLs()
javax.management.loading.MLetMBean.getURLs()


Occurences of getUserName

getUserName occurences:
javax.mail.PasswordAuthentication.getUserName()
javax.resource.cci.ConnectionMetaData.getUserName()
javax.resource.spi.ManagedConnectionMetaData.getUserName()
javax.resource.spi.security.PasswordCredential.getUserName()


Occurences of getUserPrincipal

getUserPrincipal occurences:
javax.servlet.http.HttpServletRequest.getUserPrincipal()
javax.servlet.http.HttpServletRequestWrapper.getUserPrincipal()
javax.xml.rpc.server.ServletEndpointContext.getUserPrincipal()


Occurences of getUseTime

getUseTime occurences:
javax.management.j2ee.statistics.JCAConnectionStats.getUseTime()
javax.management.j2ee.statistics.JDBCConnectionStats.getUseTime()


Occurences of getValidSentAddresses

getValidSentAddresses occurences:
javax.mail.event.TransportEvent.getValidSentAddresses()
javax.mail.SendFailedException.getValidSentAddresses()


Occurences of getValidUnsentAddresses

getValidUnsentAddresses occurences:
javax.mail.event.TransportEvent.getValidUnsentAddresses()
javax.mail.SendFailedException.getValidUnsentAddresses()


Occurences of getValue

getValue occurences:
javax.enterprise.deploy.shared.ActionType.getValue()
javax.enterprise.deploy.shared.CommandType.getValue()
javax.enterprise.deploy.shared.DConfigBeanVersionType.getValue()
javax.enterprise.deploy.shared.ModuleType.getValue()
javax.enterprise.deploy.shared.StateType.getValue()
javax.mail.Header.getValue()
javax.mail.internet.HeaderTokenizer.Token.getValue()
javax.management.Attribute.getValue()
javax.management.StringValueExp.getValue()
javax.servlet.http.Cookie.getValue()
javax.servlet.http.HttpSession.getValue(java.lang.String)
javax.servlet.http.HttpSessionBindingEvent.getValue()
javax.servlet.jsp.tagext.TagSupport.getValue(java.lang.String)
javax.servlet.ServletContextAttributeEvent.getValue()
javax.servlet.ServletRequestAttributeEvent.getValue()
javax.xml.registry.infomodel.Classification.getValue()
javax.xml.registry.infomodel.Concept.getValue()
javax.xml.registry.infomodel.ExternalIdentifier.getValue()
javax.xml.registry.infomodel.InternationalString.getValue()
javax.xml.registry.infomodel.InternationalString.getValue(java.util.Locale)
javax.xml.registry.infomodel.LocalizedString.getValue()
javax.xml.soap.MimeHeader.getValue()
javax.xml.soap.Node.getValue()


Occurences of getValues

getValues occurences:
javax.servlet.jsp.tagext.TagSupport.getValues()
javax.xml.registry.infomodel.Slot.getValues()


Occurences of getVariableInfo

getVariableInfo occurences:
javax.servlet.jsp.tagext.TagExtraInfo.getVariableInfo(javax.servlet.jsp.tagext.TagData)
javax.servlet.jsp.tagext.TagInfo.getVariableInfo(javax.servlet.jsp.tagext.TagData)


Occurences of getVersion

getVersion occurences:
javax.mail.Provider.getVersion()
javax.servlet.http.Cookie.getVersion()
javax.xml.registry.CapabilityProfile.getVersion()


Occurences of getWaitingThreadCount

getWaitingThreadCount occurences:
javax.management.j2ee.statistics.JCAConnectionPoolStats.getWaitingThreadCount()
javax.management.j2ee.statistics.JDBCConnectionPoolStats.getWaitingThreadCount()


Occurences of getWaitTime

getWaitTime occurences:
javax.management.j2ee.statistics.JCAConnectionStats.getWaitTime()
javax.management.j2ee.statistics.JDBCConnectionStats.getWaitTime()


Occurences of getWriter

getWriter occurences:
javax.servlet.ServletResponse.getWriter()
javax.servlet.ServletResponseWrapper.getWriter()
javax.xml.transform.stream.StreamResult.getWriter()


Occurences of getXAResource

getXAResource occurences:
javax.jms.XASession.getXAResource()
javax.resource.spi.ManagedConnection.getXAResource()


Occurences of getXMLReader

getXMLReader occurences:
javax.xml.parsers.SAXParser.getXMLReader()
javax.xml.transform.sax.SAXSource.getXMLReader()


Occurences of getXpath

getXpath occurences:
javax.enterprise.deploy.model.DDBean.getXpath()
javax.enterprise.deploy.model.DDBeanRoot.getXpath()


Occurences of GT

GT occurences:
javax.mail.search.GT
javax.management.GT


Occurences of handleFault

handleFault occurences:
javax.xml.rpc.handler.GenericHandler.handleFault(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.Handler.handleFault(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.HandlerChain.handleFault(javax.xml.rpc.handler.MessageContext)


Occurences of handleMBeanUnregistration

handleMBeanUnregistration occurences:
javax.management.relation.Relation.handleMBeanUnregistration(javax.management.ObjectName, java.lang.String)
javax.management.relation.RelationSupport.handleMBeanUnregistration(javax.management.ObjectName, java.lang.String)


Occurences of handleNotification

handleNotification occurences:
javax.management.NotificationBroadcasterSupport.handleNotification(javax.management.NotificationListener, javax.management.Notification, java.lang.Object)
javax.management.NotificationListener.handleNotification(javax.management.Notification, java.lang.Object)
javax.management.relation.RelationService.handleNotification(javax.management.Notification, java.lang.Object)


Occurences of handlePageException

handlePageException occurences:
javax.servlet.jsp.PageContext.handlePageException(java.lang.Exception)
javax.servlet.jsp.PageContext.handlePageException(java.lang.Throwable)


Occurences of handleRequest

handleRequest occurences:
javax.xml.rpc.handler.GenericHandler.handleRequest(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.Handler.handleRequest(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.HandlerChain.handleRequest(javax.xml.rpc.handler.MessageContext)


Occurences of handleResponse

handleResponse occurences:
javax.xml.rpc.handler.GenericHandler.handleResponse(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.Handler.handleResponse(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.HandlerChain.handleResponse(javax.xml.rpc.handler.MessageContext)


Occurences of HandlerInfo (constructors)

HandlerInfo (constructors) occurences:
javax.xml.rpc.handler.HandlerInfo()
javax.xml.rpc.handler.HandlerInfo(java.lang.Class, java.util.Map, javax.xml.namespace.QName[])


Occurences of hasDefaultValue

hasDefaultValue occurences:
javax.management.openmbean.OpenMBeanAttributeInfoSupport.hasDefaultValue()
javax.management.openmbean.OpenMBeanParameterInfo.hasDefaultValue()
javax.management.openmbean.OpenMBeanParameterInfoSupport.hasDefaultValue()


Occurences of hashCode

hashCode occurences:
javax.mail.Flags.hashCode()
javax.mail.internet.InternetAddress.hashCode()
javax.mail.internet.NewsAddress.hashCode()
javax.mail.search.AddressTerm.hashCode()
javax.mail.search.AndTerm.hashCode()
javax.mail.search.ComparisonTerm.hashCode()
javax.mail.search.DateTerm.hashCode()
javax.mail.search.FlagTerm.hashCode()
javax.mail.search.HeaderTerm.hashCode()
javax.mail.search.IntegerComparisonTerm.hashCode()
javax.mail.search.NotTerm.hashCode()
javax.mail.search.OrTerm.hashCode()
javax.mail.search.RecipientStringTerm.hashCode()
javax.mail.search.RecipientTerm.hashCode()
javax.mail.search.StringTerm.hashCode()
javax.mail.URLName.hashCode()
javax.management.MBeanAttributeInfo.hashCode()
javax.management.MBeanConstructorInfo.hashCode()
javax.management.MBeanFeatureInfo.hashCode()
javax.management.MBeanInfo.hashCode()
javax.management.MBeanNotificationInfo.hashCode()
javax.management.MBeanOperationInfo.hashCode()
javax.management.MBeanParameterInfo.hashCode()
javax.management.MBeanPermission.hashCode()
javax.management.MBeanServerPermission.hashCode()
javax.management.ObjectInstance.hashCode()
javax.management.ObjectName.hashCode()
javax.management.openmbean.ArrayType.hashCode()
javax.management.openmbean.CompositeData.hashCode()
javax.management.openmbean.CompositeDataSupport.hashCode()
javax.management.openmbean.CompositeType.hashCode()
javax.management.openmbean.OpenMBeanAttributeInfo.hashCode()
javax.management.openmbean.OpenMBeanAttributeInfoSupport.hashCode()
javax.management.openmbean.OpenMBeanConstructorInfo.hashCode()
javax.management.openmbean.OpenMBeanConstructorInfoSupport.hashCode()
javax.management.openmbean.OpenMBeanInfo.hashCode()
javax.management.openmbean.OpenMBeanInfoSupport.hashCode()
javax.management.openmbean.OpenMBeanOperationInfo.hashCode()
javax.management.openmbean.OpenMBeanOperationInfoSupport.hashCode()
javax.management.openmbean.OpenMBeanParameterInfo.hashCode()
javax.management.openmbean.OpenMBeanParameterInfoSupport.hashCode()
javax.management.openmbean.OpenType.hashCode()
javax.management.openmbean.SimpleType.hashCode()
javax.management.openmbean.TabularData.hashCode()
javax.management.openmbean.TabularDataSupport.hashCode()
javax.management.openmbean.TabularType.hashCode()
javax.resource.cci.Record.hashCode()
javax.resource.spi.ConnectionRequestInfo.hashCode()
javax.resource.spi.ManagedConnectionFactory.hashCode()
javax.resource.spi.security.GenericCredential.hashCode()
javax.resource.spi.security.PasswordCredential.hashCode()
javax.security.jacc.EJBMethodPermission.hashCode()
javax.security.jacc.EJBRoleRefPermission.hashCode()
javax.security.jacc.WebResourcePermission.hashCode()
javax.security.jacc.WebRoleRefPermission.hashCode()
javax.security.jacc.WebUserDataPermission.hashCode()
javax.xml.namespace.QName.hashCode()


Occurences of hasLegalValues

hasLegalValues occurences:
javax.management.openmbean.OpenMBeanAttributeInfoSupport.hasLegalValues()
javax.management.openmbean.OpenMBeanParameterInfo.hasLegalValues()
javax.management.openmbean.OpenMBeanParameterInfoSupport.hasLegalValues()


Occurences of hasMaxValue

hasMaxValue occurences:
javax.management.openmbean.OpenMBeanAttributeInfoSupport.hasMaxValue()
javax.management.openmbean.OpenMBeanParameterInfo.hasMaxValue()
javax.management.openmbean.OpenMBeanParameterInfoSupport.hasMaxValue()


Occurences of hasMinValue

hasMinValue occurences:
javax.management.openmbean.OpenMBeanAttributeInfoSupport.hasMinValue()
javax.management.openmbean.OpenMBeanParameterInfo.hasMinValue()
javax.management.openmbean.OpenMBeanParameterInfoSupport.hasMinValue()


Occurences of hasRelation

hasRelation occurences:
javax.management.relation.RelationService.hasRelation(java.lang.String)
javax.management.relation.RelationServiceMBean.hasRelation(java.lang.String)


Occurences of headers

headers occurences:
javax.mail.internet.headers
javax.mail.internet.headers


Occurences of HeaderTokenizer (constructors)

HeaderTokenizer (constructors) occurences:
javax.mail.internet.HeaderTokenizer(java.lang.String)
javax.mail.internet.HeaderTokenizer(java.lang.String, java.lang.String)
javax.mail.internet.HeaderTokenizer(java.lang.String, java.lang.String, boolean)


Occurences of HeuristicCommitException (constructors)

HeuristicCommitException (constructors) occurences:
javax.transaction.HeuristicCommitException()
javax.transaction.HeuristicCommitException(java.lang.String)


Occurences of HeuristicMixedException (constructors)

HeuristicMixedException (constructors) occurences:
javax.transaction.HeuristicMixedException()
javax.transaction.HeuristicMixedException(java.lang.String)


Occurences of HeuristicRollbackException (constructors)

HeuristicRollbackException (constructors) occurences:
javax.transaction.HeuristicRollbackException()
javax.transaction.HeuristicRollbackException(java.lang.String)


Occurences of HttpSessionBindingEvent (constructors)

HttpSessionBindingEvent (constructors) occurences:
javax.servlet.http.HttpSessionBindingEvent(javax.servlet.http.HttpSession, java.lang.String)
javax.servlet.http.HttpSessionBindingEvent(javax.servlet.http.HttpSession, java.lang.String, java.lang.Object)


Occurences of id

id occurences:
javax.resource.spi.id
javax.servlet.jsp.tagext.id


Occurences of IllegalStateException

IllegalStateException occurences:
javax.jms.IllegalStateException
javax.resource.spi.IllegalStateException


Occurences of IllegalStateException (constructors)

IllegalStateException (constructors) occurences:
javax.jms.IllegalStateException(java.lang.String)
javax.jms.IllegalStateException(java.lang.String, java.lang.String)
javax.resource.spi.IllegalStateException()
javax.resource.spi.IllegalStateException(java.lang.String)
javax.resource.spi.IllegalStateException(java.lang.String, java.lang.String)
javax.resource.spi.IllegalStateException(java.lang.String, java.lang.Throwable)
javax.resource.spi.IllegalStateException(java.lang.Throwable)


Occurences of IllegalWriteException (constructors)

IllegalWriteException (constructors) occurences:
javax.mail.IllegalWriteException()
javax.mail.IllegalWriteException(java.lang.String)


Occurences of implies

implies occurences:
javax.management.MBeanPermission.implies(java.security.Permission)
javax.management.MBeanServerPermission.implies(java.security.Permission)
javax.security.jacc.EJBMethodPermission.implies(java.security.Permission)
javax.security.jacc.EJBRoleRefPermission.implies(java.security.Permission)
javax.security.jacc.WebResourcePermission.implies(java.security.Permission)
javax.security.jacc.WebRoleRefPermission.implies(java.security.Permission)
javax.security.jacc.WebUserDataPermission.implies(java.security.Permission)


Occurences of include

include occurences:
javax.servlet.jsp.PageContext.include(java.lang.String)
javax.servlet.jsp.PageContext.include(java.lang.String, boolean)
javax.servlet.RequestDispatcher.include(javax.servlet.ServletRequest, javax.servlet.ServletResponse)


Occurences of init

init occurences:
javax.servlet.Filter.init(javax.servlet.FilterConfig)
javax.servlet.GenericServlet.init()
javax.servlet.GenericServlet.init(javax.servlet.ServletConfig)
javax.servlet.Servlet.init(javax.servlet.ServletConfig)
javax.xml.rpc.handler.GenericHandler.init(javax.xml.rpc.handler.HandlerInfo)
javax.xml.rpc.handler.Handler.init(javax.xml.rpc.handler.HandlerInfo)
javax.xml.rpc.handler.HandlerChain.init(java.util.Map)
javax.xml.rpc.server.ServiceLifecycle.init(java.lang.Object)


Occurences of initCause

initCause occurences:
javax.xml.registry.JAXRException.initCause(java.lang.Throwable)
javax.xml.soap.SOAPException.initCause(java.lang.Throwable)
javax.xml.transform.TransformerException.initCause(java.lang.Throwable)


Occurences of inService

inService occurences:
javax.security.jacc.PolicyConfiguration.inService()
javax.security.jacc.PolicyConfigurationFactory.inService(java.lang.String)


Occurences of InstanceAlreadyExistsException (constructors)

InstanceAlreadyExistsException (constructors) occurences:
javax.management.InstanceAlreadyExistsException()
javax.management.InstanceAlreadyExistsException(java.lang.String)


Occurences of InstanceNotFoundException (constructors)

InstanceNotFoundException (constructors) occurences:
javax.management.InstanceNotFoundException()
javax.management.InstanceNotFoundException(java.lang.String)


Occurences of instantiate

instantiate occurences:
javax.management.MBeanServer.instantiate(java.lang.String)
javax.management.MBeanServer.instantiate(java.lang.String, java.lang.Object[], java.lang.String[])
javax.management.MBeanServer.instantiate(java.lang.String, javax.management.ObjectName)
javax.management.MBeanServer.instantiate(java.lang.String, javax.management.ObjectName, java.lang.Object[], java.lang.String[])


Occurences of IntegerWrapperHolder (constructors)

IntegerWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.IntegerWrapperHolder()
javax.xml.rpc.holders.IntegerWrapperHolder(java.lang.Integer)


Occurences of InternetAddress (constructors)

InternetAddress (constructors) occurences:
javax.mail.internet.InternetAddress()
javax.mail.internet.InternetAddress(java.lang.String)
javax.mail.internet.InternetAddress(java.lang.String, boolean)
javax.mail.internet.InternetAddress(java.lang.String, java.lang.String)
javax.mail.internet.InternetAddress(java.lang.String, java.lang.String, java.lang.String)


Occurences of InternetHeaders (constructors)

InternetHeaders (constructors) occurences:
javax.mail.internet.InternetHeaders()
javax.mail.internet.InternetHeaders(java.io.InputStream)


Occurences of IntHolder (constructors)

IntHolder (constructors) occurences:
javax.xml.rpc.holders.IntHolder()
javax.xml.rpc.holders.IntHolder(int)


Occurences of IntrospectionException (constructors)

IntrospectionException (constructors) occurences:
javax.management.IntrospectionException()
javax.management.IntrospectionException(java.lang.String)


Occurences of invalid

invalid occurences:
javax.mail.event.invalid
javax.mail.invalid


Occurences of InvalidAttributeValueException (constructors)

InvalidAttributeValueException (constructors) occurences:
javax.management.InvalidAttributeValueException()
javax.management.InvalidAttributeValueException(java.lang.String)


Occurences of InvalidClientIDException (constructors)

InvalidClientIDException (constructors) occurences:
javax.jms.InvalidClientIDException(java.lang.String)
javax.jms.InvalidClientIDException(java.lang.String, java.lang.String)


Occurences of InvalidDestinationException (constructors)

InvalidDestinationException (constructors) occurences:
javax.jms.InvalidDestinationException(java.lang.String)
javax.jms.InvalidDestinationException(java.lang.String, java.lang.String)


Occurences of InvalidKeyException (constructors)

InvalidKeyException (constructors) occurences:
javax.management.openmbean.InvalidKeyException()
javax.management.openmbean.InvalidKeyException(java.lang.String)


Occurences of InvalidOpenTypeException (constructors)

InvalidOpenTypeException (constructors) occurences:
javax.management.openmbean.InvalidOpenTypeException()
javax.management.openmbean.InvalidOpenTypeException(java.lang.String)


Occurences of InvalidPropertyException (constructors)

InvalidPropertyException (constructors) occurences:
javax.resource.spi.InvalidPropertyException()
javax.resource.spi.InvalidPropertyException(java.lang.String)
javax.resource.spi.InvalidPropertyException(java.lang.String, java.lang.String)
javax.resource.spi.InvalidPropertyException(java.lang.String, java.lang.Throwable)
javax.resource.spi.InvalidPropertyException(java.lang.Throwable)


Occurences of InvalidRelationIdException (constructors)

InvalidRelationIdException (constructors) occurences:
javax.management.relation.InvalidRelationIdException()
javax.management.relation.InvalidRelationIdException(java.lang.String)


Occurences of InvalidRelationServiceException (constructors)

InvalidRelationServiceException (constructors) occurences:
javax.management.relation.InvalidRelationServiceException()
javax.management.relation.InvalidRelationServiceException(java.lang.String)


Occurences of InvalidRelationTypeException (constructors)

InvalidRelationTypeException (constructors) occurences:
javax.management.relation.InvalidRelationTypeException()
javax.management.relation.InvalidRelationTypeException(java.lang.String)


Occurences of InvalidRequestException (constructors)

InvalidRequestException (constructors) occurences:
javax.xml.registry.InvalidRequestException()
javax.xml.registry.InvalidRequestException(java.lang.String)
javax.xml.registry.InvalidRequestException(java.lang.String, java.lang.Throwable)
javax.xml.registry.InvalidRequestException(java.lang.Throwable)


Occurences of InvalidRoleInfoException (constructors)

InvalidRoleInfoException (constructors) occurences:
javax.management.relation.InvalidRoleInfoException()
javax.management.relation.InvalidRoleInfoException(java.lang.String)


Occurences of InvalidRoleValueException (constructors)

InvalidRoleValueException (constructors) occurences:
javax.management.relation.InvalidRoleValueException()
javax.management.relation.InvalidRoleValueException(java.lang.String)


Occurences of InvalidSelectorException (constructors)

InvalidSelectorException (constructors) occurences:
javax.jms.InvalidSelectorException(java.lang.String)
javax.jms.InvalidSelectorException(java.lang.String, java.lang.String)


Occurences of InvalidTargetObjectTypeException (constructors)

InvalidTargetObjectTypeException (constructors) occurences:
javax.management.modelmbean.InvalidTargetObjectTypeException()
javax.management.modelmbean.InvalidTargetObjectTypeException(java.lang.Exception, java.lang.String)
javax.management.modelmbean.InvalidTargetObjectTypeException(java.lang.String)


Occurences of InvalidTransactionException (constructors)

InvalidTransactionException (constructors) occurences:
javax.transaction.InvalidTransactionException()
javax.transaction.InvalidTransactionException(java.lang.String)


Occurences of invoke

invoke occurences:
javax.management.DynamicMBean.invoke(java.lang.String, java.lang.Object[], java.lang.String[])
javax.management.j2ee.Management.invoke(javax.management.ObjectName, java.lang.String, java.lang.Object[], java.lang.String[])
javax.management.MBeanServer.invoke(javax.management.ObjectName, java.lang.String, java.lang.Object[], java.lang.String[])
javax.management.MBeanServerConnection.invoke(javax.management.ObjectName, java.lang.String, java.lang.Object[], java.lang.String[])
javax.management.MBeanServerInvocationHandler.invoke(java.lang.Object, java.lang.reflect.Method, java.lang.Object[])
javax.management.modelmbean.RequiredModelMBean.invoke(java.lang.String, java.lang.Object[], java.lang.String[])
javax.management.StandardMBean.invoke(java.lang.String, java.lang.Object[], java.lang.String[])
javax.servlet.jsp.tagext.JspFragment.invoke(java.io.Writer)
javax.xml.rpc.Call.invoke(java.lang.Object[])
javax.xml.rpc.Call.invoke(javax.xml.namespace.QName, java.lang.Object[])


Occurences of isActive

isActive occurences:
javax.management.monitor.Monitor.isActive()
javax.management.monitor.MonitorMBean.isActive()
javax.management.relation.RelationService.isActive()
javax.management.relation.RelationServiceMBean.isActive()
javax.management.timer.Timer.isActive()
javax.management.timer.TimerMBean.isActive()


Occurences of isAvailable

isAvailable occurences:
javax.xml.registry.JAXRException.isAvailable()
javax.xml.registry.JAXRResponse.isAvailable()


Occurences of isCallerInRole

isCallerInRole occurences:
javax.ejb.EJBContext.isCallerInRole(java.lang.String)
javax.ejb.EJBContext.isCallerInRole(java.security.Identity)


Occurences of isCommitted

isCommitted occurences:
javax.servlet.ServletResponse.isCommitted()
javax.servlet.ServletResponseWrapper.isCommitted()


Occurences of isEmpty

isEmpty occurences:
javax.activation.MimeTypeParameterList.isEmpty()
javax.management.openmbean.TabularData.isEmpty()
javax.management.openmbean.TabularDataSupport.isEmpty()
javax.management.timer.Timer.isEmpty()
javax.management.timer.TimerMBean.isEmpty()


Occurences of isExternal

isExternal occurences:
javax.xml.registry.infomodel.Classification.isExternal()
javax.xml.registry.infomodel.ClassificationScheme.isExternal()


Occurences of isIdentical

isIdentical occurences:
javax.ejb.EJBLocalObject.isIdentical(javax.ejb.EJBLocalObject)
javax.ejb.EJBObject.isIdentical(javax.ejb.EJBObject)


Occurences of isInRelationService

isInRelationService occurences:
javax.management.relation.RelationSupport.isInRelationService()
javax.management.relation.RelationSupportMBean.isInRelationService()


Occurences of isInstanceOf

isInstanceOf occurences:
javax.management.MBeanServer.isInstanceOf(javax.management.ObjectName, java.lang.String)
javax.management.MBeanServerConnection.isInstanceOf(javax.management.ObjectName, java.lang.String)


Occurences of isIs

isIs occurences:
javax.management.MBeanAttributeInfo.isIs()
javax.management.openmbean.OpenMBeanAttributeInfo.isIs()


Occurences of isMimeType

isMimeType occurences:
javax.mail.internet.MimeBodyPart.isMimeType(java.lang.String)
javax.mail.internet.MimeMessage.isMimeType(java.lang.String)
javax.mail.Part.isMimeType(java.lang.String)


Occurences of isNamespaceAware

isNamespaceAware occurences:
javax.xml.parsers.DocumentBuilder.isNamespaceAware()
javax.xml.parsers.DocumentBuilderFactory.isNamespaceAware()
javax.xml.parsers.SAXParser.isNamespaceAware()
javax.xml.parsers.SAXParserFactory.isNamespaceAware()


Occurences of isNotificationEnabled

isNotificationEnabled occurences:
javax.management.AttributeChangeNotificationFilter.isNotificationEnabled(javax.management.Notification)
javax.management.NotificationFilter.isNotificationEnabled(javax.management.Notification)
javax.management.NotificationFilterSupport.isNotificationEnabled(javax.management.Notification)
javax.management.relation.MBeanServerNotificationFilter.isNotificationEnabled(javax.management.Notification)


Occurences of isReadable

isReadable occurences:
javax.management.MBeanAttributeInfo.isReadable()
javax.management.openmbean.OpenMBeanAttributeInfo.isReadable()
javax.management.relation.RoleInfo.isReadable()


Occurences of isRegistered

isRegistered occurences:
javax.management.j2ee.Management.isRegistered(javax.management.ObjectName)
javax.management.MBeanServer.isRegistered(javax.management.ObjectName)
javax.management.MBeanServerConnection.isRegistered(javax.management.ObjectName)
javax.xml.rpc.encoding.TypeMapping.isRegistered(java.lang.Class, javax.xml.namespace.QName)


Occurences of isRelation

isRelation occurences:
javax.management.relation.RelationService.isRelation(javax.management.ObjectName)
javax.management.relation.RelationServiceMBean.isRelation(javax.management.ObjectName)


Occurences of isRelationMBean

isRelationMBean occurences:
javax.management.relation.RelationService.isRelationMBean(java.lang.String)
javax.management.relation.RelationServiceMBean.isRelationMBean(java.lang.String)


Occurences of isRequestedSessionIdFromCookie

isRequestedSessionIdFromCookie occurences:
javax.servlet.http.HttpServletRequest.isRequestedSessionIdFromCookie()
javax.servlet.http.HttpServletRequestWrapper.isRequestedSessionIdFromCookie()


Occurences of isRequestedSessionIdFromUrl

isRequestedSessionIdFromUrl occurences:
javax.servlet.http.HttpServletRequest.isRequestedSessionIdFromUrl()
javax.servlet.http.HttpServletRequestWrapper.isRequestedSessionIdFromUrl()


Occurences of isRequestedSessionIdFromURL

isRequestedSessionIdFromURL occurences:
javax.servlet.http.HttpServletRequest.isRequestedSessionIdFromURL()
javax.servlet.http.HttpServletRequestWrapper.isRequestedSessionIdFromURL()


Occurences of isRequestedSessionIdValid

isRequestedSessionIdValid occurences:
javax.servlet.http.HttpServletRequest.isRequestedSessionIdValid()
javax.servlet.http.HttpServletRequestWrapper.isRequestedSessionIdValid()


Occurences of isSecure

isSecure occurences:
javax.servlet.ServletRequest.isSecure()
javax.servlet.ServletRequestWrapper.isSecure()


Occurences of isSet

isSet occurences:
javax.mail.internet.MimeMessage.isSet(javax.mail.Flags.Flag)
javax.mail.Message.isSet(javax.mail.Flags.Flag)


Occurences of isUserInRole

isUserInRole occurences:
javax.servlet.http.HttpServletRequest.isUserInRole(java.lang.String)
javax.servlet.http.HttpServletRequestWrapper.isUserInRole(java.lang.String)
javax.xml.rpc.server.ServletEndpointContext.isUserInRole(java.lang.String)


Occurences of isValid

isValid occurences:
javax.management.Descriptor.isValid()
javax.management.modelmbean.DescriptorSupport.isValid()
javax.servlet.jsp.tagext.TagExtraInfo.isValid(javax.servlet.jsp.tagext.TagData)
javax.servlet.jsp.tagext.TagInfo.isValid(javax.servlet.jsp.tagext.TagData)


Occurences of isValidating

isValidating occurences:
javax.xml.parsers.DocumentBuilder.isValidating()
javax.xml.parsers.DocumentBuilderFactory.isValidating()
javax.xml.parsers.SAXParser.isValidating()
javax.xml.parsers.SAXParserFactory.isValidating()


Occurences of isValue

isValue occurences:
javax.management.openmbean.ArrayType.isValue(java.lang.Object)
javax.management.openmbean.CompositeType.isValue(java.lang.Object)
javax.management.openmbean.OpenMBeanAttributeInfoSupport.isValue(java.lang.Object)
javax.management.openmbean.OpenMBeanParameterInfo.isValue(java.lang.Object)
javax.management.openmbean.OpenMBeanParameterInfoSupport.isValue(java.lang.Object)
javax.management.openmbean.OpenType.isValue(java.lang.Object)
javax.management.openmbean.SimpleType.isValue(java.lang.Object)
javax.management.openmbean.TabularType.isValue(java.lang.Object)


Occurences of isWritable

isWritable occurences:
javax.management.MBeanAttributeInfo.isWritable()
javax.management.openmbean.OpenMBeanAttributeInfo.isWritable()
javax.management.relation.RoleInfo.isWritable()


Occurences of JAXRException (constructors)

JAXRException (constructors) occurences:
javax.xml.registry.JAXRException()
javax.xml.registry.JAXRException(java.lang.String)
javax.xml.registry.JAXRException(java.lang.String, java.lang.Throwable)
javax.xml.registry.JAXRException(java.lang.Throwable)


Occurences of JAXRPCException (constructors)

JAXRPCException (constructors) occurences:
javax.xml.rpc.JAXRPCException()
javax.xml.rpc.JAXRPCException(java.lang.String)
javax.xml.rpc.JAXRPCException(java.lang.String, java.lang.Throwable)
javax.xml.rpc.JAXRPCException(java.lang.Throwable)


Occurences of JMException (constructors)

JMException (constructors) occurences:
javax.management.JMException()
javax.management.JMException(java.lang.String)


Occurences of JMRuntimeException (constructors)

JMRuntimeException (constructors) occurences:
javax.management.JMRuntimeException()
javax.management.JMRuntimeException(java.lang.String)


Occurences of JMSException (constructors)

JMSException (constructors) occurences:
javax.jms.JMSException(java.lang.String)
javax.jms.JMSException(java.lang.String, java.lang.String)


Occurences of JMSSecurityException (constructors)

JMSSecurityException (constructors) occurences:
javax.jms.JMSSecurityException(java.lang.String)
javax.jms.JMSSecurityException(java.lang.String, java.lang.String)


Occurences of JspException (constructors)

JspException (constructors) occurences:
javax.servlet.jsp.JspException()
javax.servlet.jsp.JspException(java.lang.String)
javax.servlet.jsp.JspException(java.lang.String, java.lang.Throwable)
javax.servlet.jsp.JspException(java.lang.Throwable)


Occurences of JspTagException (constructors)

JspTagException (constructors) occurences:
javax.servlet.jsp.JspTagException()
javax.servlet.jsp.JspTagException(java.lang.String)
javax.servlet.jsp.JspTagException(java.lang.String, java.lang.Throwable)
javax.servlet.jsp.JspTagException(java.lang.Throwable)


Occurences of KeyAlreadyExistsException (constructors)

KeyAlreadyExistsException (constructors) occurences:
javax.management.openmbean.KeyAlreadyExistsException()
javax.management.openmbean.KeyAlreadyExistsException(java.lang.String)


Occurences of keySet

keySet occurences:
javax.management.openmbean.CompositeType.keySet()
javax.management.openmbean.TabularData.keySet()
javax.management.openmbean.TabularDataSupport.keySet()


Occurences of LE

LE occurences:
javax.mail.search.LE
javax.management.LE


Occurences of list

list occurences:
javax.mail.Folder.list()
javax.mail.Folder.list(java.lang.String)


Occurences of ListenerNotFoundException (constructors)

ListenerNotFoundException (constructors) occurences:
javax.management.ListenerNotFoundException()
javax.management.ListenerNotFoundException(java.lang.String)


Occurences of listSubscribed

listSubscribed occurences:
javax.mail.Folder.listSubscribed()
javax.mail.Folder.listSubscribed(java.lang.String)


Occurences of load

load occurences:
javax.mail.internet.InternetHeaders.load(java.io.InputStream)
javax.management.modelmbean.RequiredModelMBean.load()
javax.management.PersistentMBean.load()


Occurences of loadClass

loadClass occurences:
javax.management.DefaultLoaderRepository.loadClass(java.lang.String)
javax.management.loading.ClassLoaderRepository.loadClass(java.lang.String)
javax.management.loading.DefaultLoaderRepository.loadClass(java.lang.String)
javax.management.loading.MLet.loadClass(java.lang.String, javax.management.loading.ClassLoaderRepository)


Occurences of loadClassWithout

loadClassWithout occurences:
javax.management.DefaultLoaderRepository.loadClassWithout(java.lang.ClassLoader, java.lang.String)
javax.management.loading.ClassLoaderRepository.loadClassWithout(java.lang.ClassLoader, java.lang.String)
javax.management.loading.DefaultLoaderRepository.loadClassWithout(java.lang.ClassLoader, java.lang.String)


Occurences of loadService

loadService occurences:
javax.xml.rpc.ServiceFactory.loadService(java.lang.Class)
javax.xml.rpc.ServiceFactory.loadService(java.net.URL, java.lang.Class, java.util.Properties)
javax.xml.rpc.ServiceFactory.loadService(java.net.URL, javax.xml.namespace.QName, java.util.Properties)


Occurences of LocalTransaction

LocalTransaction occurences:
javax.resource.cci.LocalTransaction
javax.resource.spi.LocalTransaction


Occurences of LocalTransactionException (constructors)

LocalTransactionException (constructors) occurences:
javax.resource.spi.LocalTransactionException()
javax.resource.spi.LocalTransactionException(java.lang.String)
javax.resource.spi.LocalTransactionException(java.lang.String, java.lang.String)
javax.resource.spi.LocalTransactionException(java.lang.String, java.lang.Throwable)
javax.resource.spi.LocalTransactionException(java.lang.Throwable)


Occurences of log

log occurences:
javax.servlet.GenericServlet.log(java.lang.String)
javax.servlet.GenericServlet.log(java.lang.String, java.lang.Throwable)
javax.servlet.ServletContext.log(java.lang.Exception, java.lang.String)
javax.servlet.ServletContext.log(java.lang.String)
javax.servlet.ServletContext.log(java.lang.String, java.lang.Throwable)


Occurences of LongHolder (constructors)

LongHolder (constructors) occurences:
javax.xml.rpc.holders.LongHolder()
javax.xml.rpc.holders.LongHolder(long)


Occurences of LongWrapperHolder (constructors)

LongWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.LongWrapperHolder()
javax.xml.rpc.holders.LongWrapperHolder(java.lang.Long)


Occurences of LT

LT occurences:
javax.mail.search.LT
javax.management.LT


Occurences of MailcapCommandMap (constructors)

MailcapCommandMap (constructors) occurences:
javax.activation.MailcapCommandMap()
javax.activation.MailcapCommandMap(java.io.InputStream)
javax.activation.MailcapCommandMap(java.lang.String)


Occurences of MalformedObjectNameException (constructors)

MalformedObjectNameException (constructors) occurences:
javax.management.MalformedObjectNameException()
javax.management.MalformedObjectNameException(java.lang.String)


Occurences of match

match occurences:
javax.activation.MimeType.match(java.lang.String)
javax.activation.MimeType.match(javax.activation.MimeType)
javax.mail.internet.ContentType.match(java.lang.String)
javax.mail.internet.ContentType.match(javax.mail.internet.ContentType)
javax.mail.Message.match(javax.mail.search.SearchTerm)
javax.mail.search.AddressStringTerm.match(javax.mail.Address)
javax.mail.search.AddressTerm.match(javax.mail.Address)
javax.mail.search.AndTerm.match(javax.mail.Message)
javax.mail.search.BodyTerm.match(javax.mail.Message)
javax.mail.search.DateTerm.match(java.util.Date)
javax.mail.search.FlagTerm.match(javax.mail.Message)
javax.mail.search.FromStringTerm.match(javax.mail.Message)
javax.mail.search.FromTerm.match(javax.mail.Message)
javax.mail.search.HeaderTerm.match(javax.mail.Message)
javax.mail.search.IntegerComparisonTerm.match(int)
javax.mail.search.MessageIDTerm.match(javax.mail.Message)
javax.mail.search.MessageNumberTerm.match(javax.mail.Message)
javax.mail.search.NotTerm.match(javax.mail.Message)
javax.mail.search.OrTerm.match(javax.mail.Message)
javax.mail.search.ReceivedDateTerm.match(javax.mail.Message)
javax.mail.search.RecipientStringTerm.match(javax.mail.Message)
javax.mail.search.RecipientTerm.match(javax.mail.Message)
javax.mail.search.SearchTerm.match(javax.mail.Message)
javax.mail.search.SentDateTerm.match(javax.mail.Message)
javax.mail.search.SizeTerm.match(javax.mail.Message)
javax.mail.search.StringTerm.match(java.lang.String)
javax.mail.search.SubjectTerm.match(javax.mail.Message)
javax.management.Query.match(javax.management.AttributeValueExp, javax.management.StringValueExp)


Occurences of MBeanAttributeInfo (constructors)

MBeanAttributeInfo (constructors) occurences:
javax.management.MBeanAttributeInfo(java.lang.String, java.lang.String, java.lang.reflect.Method, java.lang.reflect.Method)
javax.management.MBeanAttributeInfo(java.lang.String, java.lang.String, java.lang.String, boolean, boolean, boolean)


Occurences of MBeanConstructorInfo (constructors)

MBeanConstructorInfo (constructors) occurences:
javax.management.MBeanConstructorInfo(java.lang.String, java.lang.reflect.Constructor)
javax.management.MBeanConstructorInfo(java.lang.String, java.lang.String, javax.management.MBeanParameterInfo[])


Occurences of MBeanException (constructors)

MBeanException (constructors) occurences:
javax.management.MBeanException(java.lang.Exception)
javax.management.MBeanException(java.lang.Exception, java.lang.String)


Occurences of MBeanOperationInfo (constructors)

MBeanOperationInfo (constructors) occurences:
javax.management.MBeanOperationInfo(java.lang.String, java.lang.reflect.Method)
javax.management.MBeanOperationInfo(java.lang.String, java.lang.String, javax.management.MBeanParameterInfo[], java.lang.String, int)


Occurences of MBeanPermission (constructors)

MBeanPermission (constructors) occurences:
javax.management.MBeanPermission(java.lang.String, java.lang.String)
javax.management.MBeanPermission(java.lang.String, java.lang.String, javax.management.ObjectName, java.lang.String)


Occurences of MBeanRegistrationException (constructors)

MBeanRegistrationException (constructors) occurences:
javax.management.MBeanRegistrationException(java.lang.Exception)
javax.management.MBeanRegistrationException(java.lang.Exception, java.lang.String)


Occurences of MBeanServerPermission (constructors)

MBeanServerPermission (constructors) occurences:
javax.management.MBeanServerPermission(java.lang.String)
javax.management.MBeanServerPermission(java.lang.String, java.lang.String)


Occurences of MBeanTrustPermission (constructors)

MBeanTrustPermission (constructors) occurences:
javax.management.MBeanTrustPermission(java.lang.String)
javax.management.MBeanTrustPermission(java.lang.String, java.lang.String)


Occurences of Message

Message occurences:
javax.jms.Message
javax.mail.Message


Occurences of Message (constructors)

Message (constructors) occurences:
javax.mail.Message()
javax.mail.Message(javax.mail.Folder, int)
javax.mail.Message(javax.mail.Session)


Occurences of MessageContext

MessageContext occurences:
javax.mail.MessageContext
javax.xml.rpc.handler.MessageContext


Occurences of messageDelivered

messageDelivered occurences:
javax.mail.event.TransportAdapter.messageDelivered(javax.mail.event.TransportEvent)
javax.mail.event.TransportListener.messageDelivered(javax.mail.event.TransportEvent)


Occurences of MessageEOFException (constructors)

MessageEOFException (constructors) occurences:
javax.jms.MessageEOFException(java.lang.String)
javax.jms.MessageEOFException(java.lang.String, java.lang.String)


Occurences of MessageFormatException (constructors)

MessageFormatException (constructors) occurences:
javax.jms.MessageFormatException(java.lang.String)
javax.jms.MessageFormatException(java.lang.String, java.lang.String)


Occurences of MessageListener

MessageListener occurences:
javax.jms.MessageListener
javax.resource.cci.MessageListener


Occurences of messageNotDelivered

messageNotDelivered occurences:
javax.mail.event.TransportAdapter.messageNotDelivered(javax.mail.event.TransportEvent)
javax.mail.event.TransportListener.messageNotDelivered(javax.mail.event.TransportEvent)


Occurences of MessageNotReadableException (constructors)

MessageNotReadableException (constructors) occurences:
javax.jms.MessageNotReadableException(java.lang.String)
javax.jms.MessageNotReadableException(java.lang.String, java.lang.String)


Occurences of MessageNotWriteableException (constructors)

MessageNotWriteableException (constructors) occurences:
javax.jms.MessageNotWriteableException(java.lang.String)
javax.jms.MessageNotWriteableException(java.lang.String, java.lang.String)


Occurences of messagePartiallyDelivered

messagePartiallyDelivered occurences:
javax.mail.event.TransportAdapter.messagePartiallyDelivered(javax.mail.event.TransportEvent)
javax.mail.event.TransportListener.messagePartiallyDelivered(javax.mail.event.TransportEvent)


Occurences of MessageRemovedException (constructors)

MessageRemovedException (constructors) occurences:
javax.mail.MessageRemovedException()
javax.mail.MessageRemovedException(java.lang.String)


Occurences of messagesAdded

messagesAdded occurences:
javax.mail.event.MessageCountAdapter.messagesAdded(javax.mail.event.MessageCountEvent)
javax.mail.event.MessageCountListener.messagesAdded(javax.mail.event.MessageCountEvent)


Occurences of messagesRemoved

messagesRemoved occurences:
javax.mail.event.MessageCountAdapter.messagesRemoved(javax.mail.event.MessageCountEvent)
javax.mail.event.MessageCountListener.messagesRemoved(javax.mail.event.MessageCountEvent)


Occurences of MessagingException (constructors)

MessagingException (constructors) occurences:
javax.mail.MessagingException()
javax.mail.MessagingException(java.lang.String)
javax.mail.MessagingException(java.lang.String, java.lang.Exception)


Occurences of MethodNotSupportedException (constructors)

MethodNotSupportedException (constructors) occurences:
javax.mail.MethodNotSupportedException()
javax.mail.MethodNotSupportedException(java.lang.String)


Occurences of MimeBodyPart (constructors)

MimeBodyPart (constructors) occurences:
javax.mail.internet.MimeBodyPart()
javax.mail.internet.MimeBodyPart(java.io.InputStream)
javax.mail.internet.MimeBodyPart(javax.mail.internet.InternetHeaders, byte[])


Occurences of MimeMessage (constructors)

MimeMessage (constructors) occurences:
javax.mail.internet.MimeMessage(javax.mail.Folder, int)
javax.mail.internet.MimeMessage(javax.mail.Folder, java.io.InputStream, int)
javax.mail.internet.MimeMessage(javax.mail.Folder, javax.mail.internet.InternetHeaders, byte[], int)
javax.mail.internet.MimeMessage(javax.mail.internet.MimeMessage)
javax.mail.internet.MimeMessage(javax.mail.Session)
javax.mail.internet.MimeMessage(javax.mail.Session, java.io.InputStream)


Occurences of MimeMultipart (constructors)

MimeMultipart (constructors) occurences:
javax.mail.internet.MimeMultipart()
javax.mail.internet.MimeMultipart(java.lang.String)
javax.mail.internet.MimeMultipart(javax.activation.DataSource)


Occurences of MimeType (constructors)

MimeType (constructors) occurences:
javax.activation.MimeType()
javax.activation.MimeType(java.lang.String)
javax.activation.MimeType(java.lang.String, java.lang.String)


Occurences of MimeTypeParameterList (constructors)

MimeTypeParameterList (constructors) occurences:
javax.activation.MimeTypeParameterList()
javax.activation.MimeTypeParameterList(java.lang.String)


Occurences of MimeTypeParseException (constructors)

MimeTypeParseException (constructors) occurences:
javax.activation.MimeTypeParseException()
javax.activation.MimeTypeParseException(java.lang.String)


Occurences of MimetypesFileTypeMap (constructors)

MimetypesFileTypeMap (constructors) occurences:
javax.activation.MimetypesFileTypeMap()
javax.activation.MimetypesFileTypeMap(java.io.InputStream)
javax.activation.MimetypesFileTypeMap(java.lang.String)


Occurences of MLet (constructors)

MLet (constructors) occurences:
javax.management.loading.MLet()
javax.management.loading.MLet(java.net.URL[])
javax.management.loading.MLet(java.net.URL[], boolean)
javax.management.loading.MLet(java.net.URL[], java.lang.ClassLoader)
javax.management.loading.MLet(java.net.URL[], java.lang.ClassLoader, boolean)
javax.management.loading.MLet(java.net.URL[], java.lang.ClassLoader, java.net.URLStreamHandlerFactory)
javax.management.loading.MLet(java.net.URL[], java.lang.ClassLoader, java.net.URLStreamHandlerFactory, boolean)


Occurences of ModelMBeanAttributeInfo (constructors)

ModelMBeanAttributeInfo (constructors) occurences:
javax.management.modelmbean.ModelMBeanAttributeInfo(java.lang.String, java.lang.String, java.lang.reflect.Method, java.lang.reflect.Method)
javax.management.modelmbean.ModelMBeanAttributeInfo(java.lang.String, java.lang.String, java.lang.reflect.Method, java.lang.reflect.Method, javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanAttributeInfo(java.lang.String, java.lang.String, java.lang.String, boolean, boolean, boolean)
javax.management.modelmbean.ModelMBeanAttributeInfo(java.lang.String, java.lang.String, java.lang.String, boolean, boolean, boolean, javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanAttributeInfo(javax.management.modelmbean.ModelMBeanAttributeInfo)


Occurences of ModelMBeanConstructorInfo (constructors)

ModelMBeanConstructorInfo (constructors) occurences:
javax.management.modelmbean.ModelMBeanConstructorInfo(java.lang.String, java.lang.reflect.Constructor)
javax.management.modelmbean.ModelMBeanConstructorInfo(java.lang.String, java.lang.reflect.Constructor, javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanConstructorInfo(java.lang.String, java.lang.String, javax.management.MBeanParameterInfo[])
javax.management.modelmbean.ModelMBeanConstructorInfo(java.lang.String, java.lang.String, javax.management.MBeanParameterInfo[], javax.management.Descriptor)


Occurences of ModelMBeanInfoSupport (constructors)

ModelMBeanInfoSupport (constructors) occurences:
javax.management.modelmbean.ModelMBeanInfoSupport(java.lang.String, java.lang.String, javax.management.modelmbean.ModelMBeanAttributeInfo[], javax.management.modelmbean.ModelMBeanConstructorInfo[], javax.management.modelmbean.ModelMBeanOperationInfo[], javax.management.modelmbean.ModelMBeanNotificationInfo[])
javax.management.modelmbean.ModelMBeanInfoSupport(java.lang.String, java.lang.String, javax.management.modelmbean.ModelMBeanAttributeInfo[], javax.management.modelmbean.ModelMBeanConstructorInfo[], javax.management.modelmbean.ModelMBeanOperationInfo[], javax.management.modelmbean.ModelMBeanNotificationInfo[], javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanInfoSupport(javax.management.modelmbean.ModelMBeanInfo)


Occurences of ModelMBeanNotificationInfo (constructors)

ModelMBeanNotificationInfo (constructors) occurences:
javax.management.modelmbean.ModelMBeanNotificationInfo(java.lang.String[], java.lang.String, java.lang.String)
javax.management.modelmbean.ModelMBeanNotificationInfo(java.lang.String[], java.lang.String, java.lang.String, javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanNotificationInfo(javax.management.modelmbean.ModelMBeanNotificationInfo)


Occurences of ModelMBeanOperationInfo (constructors)

ModelMBeanOperationInfo (constructors) occurences:
javax.management.modelmbean.ModelMBeanOperationInfo(java.lang.String, java.lang.reflect.Method)
javax.management.modelmbean.ModelMBeanOperationInfo(java.lang.String, java.lang.reflect.Method, javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanOperationInfo(java.lang.String, java.lang.String, javax.management.MBeanParameterInfo[], java.lang.String, int)
javax.management.modelmbean.ModelMBeanOperationInfo(java.lang.String, java.lang.String, javax.management.MBeanParameterInfo[], java.lang.String, int, javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanOperationInfo(javax.management.modelmbean.ModelMBeanOperationInfo)


Occurences of MonitorSettingException (constructors)

MonitorSettingException (constructors) occurences:
javax.management.monitor.MonitorSettingException()
javax.management.monitor.MonitorSettingException(java.lang.String)


Occurences of msg

msg occurences:
javax.mail.event.msg
javax.mail.event.msg


Occurences of nested_class_summary

nested_class_summary occurences:
javax.mail.internet.nested_class_summary
javax.mail.internet.nested_class_summary
javax.mail.internet.nested_class_summary
javax.mail.nested_class_summary
javax.mail.nested_class_summary
javax.mail.nested_class_summary
javax.mail.nested_class_summary
javax.mail.nested_class_summary
javax.management.openmbean.nested_class_summary
javax.resource.cci.nested_class_summary


Occurences of newInstance

newInstance occurences:
javax.xml.parsers.DocumentBuilderFactory.newInstance()
javax.xml.parsers.SAXParserFactory.newInstance()
javax.xml.registry.ConnectionFactory.newInstance()
javax.xml.rpc.ServiceFactory.newInstance()
javax.xml.soap.MessageFactory.newInstance()
javax.xml.soap.SOAPConnectionFactory.newInstance()
javax.xml.soap.SOAPElementFactory.newInstance()
javax.xml.soap.SOAPFactory.newInstance()
javax.xml.transform.TransformerFactory.newInstance()


Occurences of newMBeanServer

newMBeanServer occurences:
javax.management.MBeanServerBuilder.newMBeanServer(java.lang.String, javax.management.MBeanServer, javax.management.MBeanServerDelegate)
javax.management.MBeanServerFactory.newMBeanServer()
javax.management.MBeanServerFactory.newMBeanServer(java.lang.String)


Occurences of NewsAddress (constructors)

NewsAddress (constructors) occurences:
javax.mail.internet.NewsAddress()
javax.mail.internet.NewsAddress(java.lang.String)
javax.mail.internet.NewsAddress(java.lang.String, java.lang.String)


Occurences of newTransformer

newTransformer occurences:
javax.xml.transform.Templates.newTransformer()
javax.xml.transform.TransformerFactory.newTransformer()
javax.xml.transform.TransformerFactory.newTransformer(javax.xml.transform.Source)


Occurences of newTransformerHandler

newTransformerHandler occurences:
javax.xml.transform.sax.SAXTransformerFactory.newTransformerHandler()
javax.xml.transform.sax.SAXTransformerFactory.newTransformerHandler(javax.xml.transform.Source)
javax.xml.transform.sax.SAXTransformerFactory.newTransformerHandler(javax.xml.transform.Templates)


Occurences of newXMLFilter

newXMLFilter occurences:
javax.xml.transform.sax.SAXTransformerFactory.newXMLFilter(javax.xml.transform.Source)
javax.xml.transform.sax.SAXTransformerFactory.newXMLFilter(javax.xml.transform.Templates)


Occurences of NoSuchEntityException (constructors)

NoSuchEntityException (constructors) occurences:
javax.ejb.NoSuchEntityException()
javax.ejb.NoSuchEntityException(java.lang.Exception)
javax.ejb.NoSuchEntityException(java.lang.String)


Occurences of NoSuchObjectLocalException (constructors)

NoSuchObjectLocalException (constructors) occurences:
javax.ejb.NoSuchObjectLocalException()
javax.ejb.NoSuchObjectLocalException(java.lang.String)
javax.ejb.NoSuchObjectLocalException(java.lang.String, java.lang.Exception)


Occurences of NoSuchProviderException (constructors)

NoSuchProviderException (constructors) occurences:
javax.mail.NoSuchProviderException()
javax.mail.NoSuchProviderException(java.lang.String)


Occurences of NotCompliantMBeanException (constructors)

NotCompliantMBeanException (constructors) occurences:
javax.management.NotCompliantMBeanException()
javax.management.NotCompliantMBeanException(java.lang.String)


Occurences of Notification (constructors)

Notification (constructors) occurences:
javax.management.Notification(java.lang.String, java.lang.Object, long)
javax.management.Notification(java.lang.String, java.lang.Object, long, java.lang.String)
javax.management.Notification(java.lang.String, java.lang.Object, long, long)
javax.management.Notification(java.lang.String, java.lang.Object, long, long, java.lang.String)


Occurences of notifyConnectionListeners

notifyConnectionListeners occurences:
javax.mail.Folder.notifyConnectionListeners(int)
javax.mail.Service.notifyConnectionListeners(int)


Occurences of notifyFolderListeners

notifyFolderListeners occurences:
javax.mail.Folder.notifyFolderListeners(int)
javax.mail.Store.notifyFolderListeners(int, javax.mail.Folder)


Occurences of notifyFolderRenamedListeners

notifyFolderRenamedListeners occurences:
javax.mail.Folder.notifyFolderRenamedListeners(javax.mail.Folder)
javax.mail.Store.notifyFolderRenamedListeners(javax.mail.Folder, javax.mail.Folder)


Occurences of NotSupportedException

NotSupportedException occurences:
javax.resource.NotSupportedException
javax.transaction.NotSupportedException


Occurences of NotSupportedException (constructors)

NotSupportedException (constructors) occurences:
javax.resource.NotSupportedException()
javax.resource.NotSupportedException(java.lang.String)
javax.resource.NotSupportedException(java.lang.String, java.lang.String)
javax.resource.NotSupportedException(java.lang.String, java.lang.Throwable)
javax.resource.NotSupportedException(java.lang.Throwable)
javax.transaction.NotSupportedException()
javax.transaction.NotSupportedException(java.lang.String)


Occurences of ObjectHolder (constructors)

ObjectHolder (constructors) occurences:
javax.xml.rpc.holders.ObjectHolder()
javax.xml.rpc.holders.ObjectHolder(java.lang.Object)


Occurences of ObjectInstance (constructors)

ObjectInstance (constructors) occurences:
javax.management.ObjectInstance(java.lang.String, java.lang.String)
javax.management.ObjectInstance(javax.management.ObjectName, java.lang.String)


Occurences of ObjectName (constructors)

ObjectName (constructors) occurences:
javax.management.ObjectName(java.lang.String)
javax.management.ObjectName(java.lang.String, java.lang.String, java.lang.String)
javax.management.ObjectName(java.lang.String, java.util.Hashtable)


Occurences of ObjectNotFoundException (constructors)

ObjectNotFoundException (constructors) occurences:
javax.ejb.ObjectNotFoundException()
javax.ejb.ObjectNotFoundException(java.lang.String)


Occurences of onMessage

onMessage occurences:
javax.jms.MessageListener.onMessage(javax.jms.Message)
javax.resource.cci.MessageListener.onMessage(javax.resource.cci.Record)


Occurences of OpenDataException (constructors)

OpenDataException (constructors) occurences:
javax.management.openmbean.OpenDataException()
javax.management.openmbean.OpenDataException(java.lang.String)


Occurences of opened

opened occurences:
javax.mail.event.ConnectionAdapter.opened(javax.mail.event.ConnectionEvent)
javax.mail.event.ConnectionListener.opened(javax.mail.event.ConnectionEvent)


Occurences of OpenMBeanAttributeInfoSupport (constructors)

OpenMBeanAttributeInfoSupport (constructors) occurences:
javax.management.openmbean.OpenMBeanAttributeInfoSupport(java.lang.String, java.lang.String, javax.management.openmbean.OpenType, boolean, boolean, boolean)
javax.management.openmbean.OpenMBeanAttributeInfoSupport(java.lang.String, java.lang.String, javax.management.openmbean.OpenType, boolean, boolean, boolean, java.lang.Object)
javax.management.openmbean.OpenMBeanAttributeInfoSupport(java.lang.String, java.lang.String, javax.management.openmbean.OpenType, boolean, boolean, boolean, java.lang.Object, java.lang.Comparable, java.lang.Comparable)
javax.management.openmbean.OpenMBeanAttributeInfoSupport(java.lang.String, java.lang.String, javax.management.openmbean.OpenType, boolean, boolean, boolean, java.lang.Object, java.lang.Object[])


Occurences of OpenMBeanParameterInfoSupport (constructors)

OpenMBeanParameterInfoSupport (constructors) occurences:
javax.management.openmbean.OpenMBeanParameterInfoSupport(java.lang.String, java.lang.String, javax.management.openmbean.OpenType)
javax.management.openmbean.OpenMBeanParameterInfoSupport(java.lang.String, java.lang.String, javax.management.openmbean.OpenType, java.lang.Object)
javax.management.openmbean.OpenMBeanParameterInfoSupport(java.lang.String, java.lang.String, javax.management.openmbean.OpenType, java.lang.Object, java.lang.Comparable, java.lang.Comparable)
javax.management.openmbean.OpenMBeanParameterInfoSupport(java.lang.String, java.lang.String, javax.management.openmbean.OpenType, java.lang.Object, java.lang.Object[])


Occurences of OperationsException (constructors)

OperationsException (constructors) occurences:
javax.management.OperationsException()
javax.management.OperationsException(java.lang.String)


Occurences of OrTerm (constructors)

OrTerm (constructors) occurences:
javax.mail.search.OrTerm(javax.mail.search.SearchTerm, javax.mail.search.SearchTerm)
javax.mail.search.OrTerm(javax.mail.search.SearchTerm[])


Occurences of OUT

OUT occurences:
javax.servlet.jsp.OUT
javax.xml.rpc.OUT


Occurences of ParameterList (constructors)

ParameterList (constructors) occurences:
javax.mail.internet.ParameterList()
javax.mail.internet.ParameterList(java.lang.String)


Occurences of parent

parent occurences:
javax.mail.parent
javax.mail.parent


Occurences of parse

parse occurences:
javax.activation.MimeTypeParameterList.parse(java.lang.String)
javax.mail.internet.InternetAddress.parse(java.lang.String)
javax.mail.internet.InternetAddress.parse(java.lang.String, boolean)
javax.mail.internet.MailDateFormat.parse(java.lang.String, java.text.ParsePosition)
javax.mail.internet.MimeMessage.parse(java.io.InputStream)
javax.mail.internet.MimeMultipart.parse()
javax.mail.internet.NewsAddress.parse(java.lang.String)
javax.xml.parsers.DocumentBuilder.parse(java.io.File)
javax.xml.parsers.DocumentBuilder.parse(java.io.InputStream)
javax.xml.parsers.DocumentBuilder.parse(java.io.InputStream, java.lang.String)
javax.xml.parsers.DocumentBuilder.parse(java.lang.String)
javax.xml.parsers.DocumentBuilder.parse(org.xml.sax.InputSource)
javax.xml.parsers.SAXParser.parse(java.io.File, org.xml.sax.HandlerBase)
javax.xml.parsers.SAXParser.parse(java.io.File, org.xml.sax.helpers.DefaultHandler)
javax.xml.parsers.SAXParser.parse(java.io.InputStream, org.xml.sax.HandlerBase)
javax.xml.parsers.SAXParser.parse(java.io.InputStream, org.xml.sax.HandlerBase, java.lang.String)
javax.xml.parsers.SAXParser.parse(java.io.InputStream, org.xml.sax.helpers.DefaultHandler)
javax.xml.parsers.SAXParser.parse(java.io.InputStream, org.xml.sax.helpers.DefaultHandler, java.lang.String)
javax.xml.parsers.SAXParser.parse(java.lang.String, org.xml.sax.HandlerBase)
javax.xml.parsers.SAXParser.parse(java.lang.String, org.xml.sax.helpers.DefaultHandler)
javax.xml.parsers.SAXParser.parse(org.xml.sax.InputSource, org.xml.sax.HandlerBase)
javax.xml.parsers.SAXParser.parse(org.xml.sax.InputSource, org.xml.sax.helpers.DefaultHandler)


Occurences of ParseException (constructors)

ParseException (constructors) occurences:
javax.mail.internet.ParseException()
javax.mail.internet.ParseException(java.lang.String)


Occurences of ParserConfigurationException (constructors)

ParserConfigurationException (constructors) occurences:
javax.xml.parsers.ParserConfigurationException()
javax.xml.parsers.ParserConfigurationException(java.lang.String)


Occurences of PASSWORD_PROPERTY

PASSWORD_PROPERTY occurences:
javax.xml.rpc.PASSWORD_PROPERTY
javax.xml.rpc.PASSWORD_PROPERTY


Occurences of PolicyContextException (constructors)

PolicyContextException (constructors) occurences:
javax.security.jacc.PolicyContextException()
javax.security.jacc.PolicyContextException(java.lang.String)
javax.security.jacc.PolicyContextException(java.lang.String, java.lang.Throwable)
javax.security.jacc.PolicyContextException(java.lang.Throwable)


Occurences of postDeregister

postDeregister occurences:
javax.management.loading.MLet.postDeregister()
javax.management.MBeanRegistration.postDeregister()
javax.management.modelmbean.RequiredModelMBean.postDeregister()
javax.management.monitor.Monitor.postDeregister()
javax.management.relation.RelationService.postDeregister()
javax.management.relation.RelationSupport.postDeregister()
javax.management.timer.Timer.postDeregister()


Occurences of postRegister

postRegister occurences:
javax.management.loading.MLet.postRegister(java.lang.Boolean)
javax.management.MBeanRegistration.postRegister(java.lang.Boolean)
javax.management.modelmbean.RequiredModelMBean.postRegister(java.lang.Boolean)
javax.management.monitor.Monitor.postRegister(java.lang.Boolean)
javax.management.relation.RelationService.postRegister(java.lang.Boolean)
javax.management.relation.RelationSupport.postRegister(java.lang.Boolean)
javax.management.timer.Timer.postRegister(java.lang.Boolean)


Occurences of preDeregister

preDeregister occurences:
javax.management.loading.MLet.preDeregister()
javax.management.MBeanRegistration.preDeregister()
javax.management.modelmbean.RequiredModelMBean.preDeregister()
javax.management.monitor.CounterMonitor.preDeregister()
javax.management.monitor.Monitor.preDeregister()
javax.management.relation.RelationService.preDeregister()
javax.management.relation.RelationSupport.preDeregister()
javax.management.timer.Timer.preDeregister()


Occurences of prepare

prepare occurences:
javax.resource.spi.XATerminator.prepare(javax.transaction.xa.Xid)
javax.transaction.xa.XAResource.prepare(javax.transaction.xa.Xid)


Occurences of preRegister

preRegister occurences:
javax.management.loading.MLet.preRegister(javax.management.MBeanServer, javax.management.ObjectName)
javax.management.MBeanRegistration.preRegister(javax.management.MBeanServer, javax.management.ObjectName)
javax.management.modelmbean.RequiredModelMBean.preRegister(javax.management.MBeanServer, javax.management.ObjectName)
javax.management.monitor.Monitor.preRegister(javax.management.MBeanServer, javax.management.ObjectName)
javax.management.relation.RelationService.preRegister(javax.management.MBeanServer, javax.management.ObjectName)
javax.management.relation.RelationSupport.preRegister(javax.management.MBeanServer, javax.management.ObjectName)
javax.management.timer.Timer.preRegister(javax.management.MBeanServer, javax.management.ObjectName)


Occurences of print

print occurences:
javax.servlet.jsp.JspWriter.print(boolean)
javax.servlet.jsp.JspWriter.print(char)
javax.servlet.jsp.JspWriter.print(char[])
javax.servlet.jsp.JspWriter.print(double)
javax.servlet.jsp.JspWriter.print(float)
javax.servlet.jsp.JspWriter.print(int)
javax.servlet.jsp.JspWriter.print(java.lang.Object)
javax.servlet.jsp.JspWriter.print(java.lang.String)
javax.servlet.jsp.JspWriter.print(long)
javax.servlet.ServletOutputStream.print(boolean)
javax.servlet.ServletOutputStream.print(char)
javax.servlet.ServletOutputStream.print(double)
javax.servlet.ServletOutputStream.print(float)
javax.servlet.ServletOutputStream.print(int)
javax.servlet.ServletOutputStream.print(java.lang.String)
javax.servlet.ServletOutputStream.print(long)


Occurences of println

println occurences:
javax.servlet.jsp.JspWriter.println()
javax.servlet.jsp.JspWriter.println(boolean)
javax.servlet.jsp.JspWriter.println(char)
javax.servlet.jsp.JspWriter.println(char[])
javax.servlet.jsp.JspWriter.println(double)
javax.servlet.jsp.JspWriter.println(float)
javax.servlet.jsp.JspWriter.println(int)
javax.servlet.jsp.JspWriter.println(java.lang.Object)
javax.servlet.jsp.JspWriter.println(java.lang.String)
javax.servlet.jsp.JspWriter.println(long)
javax.servlet.ServletOutputStream.println()
javax.servlet.ServletOutputStream.println(boolean)
javax.servlet.ServletOutputStream.println(char)
javax.servlet.ServletOutputStream.println(double)
javax.servlet.ServletOutputStream.println(float)
javax.servlet.ServletOutputStream.println(int)
javax.servlet.ServletOutputStream.println(java.lang.String)
javax.servlet.ServletOutputStream.println(long)


Occurences of printStackTrace

printStackTrace occurences:
javax.ejb.EJBException.printStackTrace()
javax.ejb.EJBException.printStackTrace(java.io.PrintStream)
javax.ejb.EJBException.printStackTrace(java.io.PrintWriter)
javax.xml.transform.TransformerException.printStackTrace()
javax.xml.transform.TransformerException.printStackTrace(java.io.PrintStream)
javax.xml.transform.TransformerException.printStackTrace(java.io.PrintWriter)


Occurences of PrivateMLet (constructors)

PrivateMLet (constructors) occurences:
javax.management.loading.PrivateMLet(java.net.URL[], boolean)
javax.management.loading.PrivateMLet(java.net.URL[], java.lang.ClassLoader, boolean)
javax.management.loading.PrivateMLet(java.net.URL[], java.lang.ClassLoader, java.net.URLStreamHandlerFactory, boolean)


Occurences of publish

publish occurences:
javax.jms.TopicPublisher.publish(javax.jms.Message)
javax.jms.TopicPublisher.publish(javax.jms.Message, int, int, long)
javax.jms.TopicPublisher.publish(javax.jms.Topic, javax.jms.Message)
javax.jms.TopicPublisher.publish(javax.jms.Topic, javax.jms.Message, int, int, long)


Occurences of purgeRelations

purgeRelations occurences:
javax.management.relation.RelationService.purgeRelations()
javax.management.relation.RelationServiceMBean.purgeRelations()


Occurences of pushBody

pushBody occurences:
javax.servlet.jsp.JspContext.pushBody(java.io.Writer)
javax.servlet.jsp.PageContext.pushBody()


Occurences of put

put occurences:
javax.management.openmbean.TabularData.put(javax.management.openmbean.CompositeData)
javax.management.openmbean.TabularDataSupport.put(java.lang.Object, java.lang.Object)
javax.management.openmbean.TabularDataSupport.put(javax.management.openmbean.CompositeData)


Occurences of putAll

putAll occurences:
javax.management.openmbean.TabularData.putAll(javax.management.openmbean.CompositeData[])
javax.management.openmbean.TabularDataSupport.putAll(java.util.Map)
javax.management.openmbean.TabularDataSupport.putAll(javax.management.openmbean.CompositeData[])


Occurences of QName (constructors)

QName (constructors) occurences:
javax.xml.namespace.QName(java.lang.String)
javax.xml.namespace.QName(java.lang.String, java.lang.String)
javax.xml.namespace.QName(java.lang.String, java.lang.String, java.lang.String)


Occurences of QNameHolder (constructors)

QNameHolder (constructors) occurences:
javax.xml.rpc.holders.QNameHolder()
javax.xml.rpc.holders.QNameHolder(javax.xml.namespace.QName)


Occurences of Query

Query occurences:
javax.management.Query
javax.xml.registry.Query


Occurences of queryMBeans

queryMBeans occurences:
javax.management.MBeanServer.queryMBeans(javax.management.ObjectName, javax.management.QueryExp)
javax.management.MBeanServerConnection.queryMBeans(javax.management.ObjectName, javax.management.QueryExp)


Occurences of queryNames

queryNames occurences:
javax.management.j2ee.Management.queryNames(javax.management.ObjectName, javax.management.QueryExp)
javax.management.MBeanServer.queryNames(javax.management.ObjectName, javax.management.QueryExp)
javax.management.MBeanServerConnection.queryNames(javax.management.ObjectName, javax.management.QueryExp)


Occurences of quote

quote occurences:
javax.mail.internet.MimeUtility.quote(java.lang.String, java.lang.String)
javax.management.ObjectName.quote(java.lang.String)


Occurences of readBoolean

readBoolean occurences:
javax.jms.BytesMessage.readBoolean()
javax.jms.StreamMessage.readBoolean()


Occurences of readByte

readByte occurences:
javax.jms.BytesMessage.readByte()
javax.jms.StreamMessage.readByte()


Occurences of readBytes

readBytes occurences:
javax.jms.BytesMessage.readBytes(byte[])
javax.jms.BytesMessage.readBytes(byte[], int)
javax.jms.StreamMessage.readBytes(byte[])


Occurences of readChar

readChar occurences:
javax.jms.BytesMessage.readChar()
javax.jms.StreamMessage.readChar()


Occurences of readDouble

readDouble occurences:
javax.jms.BytesMessage.readDouble()
javax.jms.StreamMessage.readDouble()


Occurences of readExternal

readExternal occurences:
javax.activation.MimeType.readExternal(java.io.ObjectInput)
javax.management.loading.MLet.readExternal(java.io.ObjectInput)


Occurences of readFloat

readFloat occurences:
javax.jms.BytesMessage.readFloat()
javax.jms.StreamMessage.readFloat()


Occurences of readInt

readInt occurences:
javax.jms.BytesMessage.readInt()
javax.jms.StreamMessage.readInt()


Occurences of readLong

readLong occurences:
javax.jms.BytesMessage.readLong()
javax.jms.StreamMessage.readLong()


Occurences of ReadOnlyFolderException (constructors)

ReadOnlyFolderException (constructors) occurences:
javax.mail.ReadOnlyFolderException(javax.mail.Folder)
javax.mail.ReadOnlyFolderException(javax.mail.Folder, java.lang.String)


Occurences of readResolve

readResolve occurences:
javax.mail.internet.MimeMessage.RecipientType.readResolve()
javax.mail.Message.RecipientType.readResolve()
javax.management.openmbean.SimpleType.readResolve()


Occurences of readShort

readShort occurences:
javax.jms.BytesMessage.readShort()
javax.jms.StreamMessage.readShort()


Occurences of receive

receive occurences:
javax.jms.MessageConsumer.receive()
javax.jms.MessageConsumer.receive(long)


Occurences of recover

recover occurences:
javax.jms.Session.recover()
javax.resource.spi.XATerminator.recover(int)
javax.transaction.xa.XAResource.recover(int)


Occurences of redeploy

redeploy occurences:
javax.enterprise.deploy.spi.DeploymentManager.redeploy(javax.enterprise.deploy.spi.TargetModuleID[], java.io.File, java.io.File)
javax.enterprise.deploy.spi.DeploymentManager.redeploy(javax.enterprise.deploy.spi.TargetModuleID[], java.io.InputStream, java.io.InputStream)


Occurences of ReflectionException (constructors)

ReflectionException (constructors) occurences:
javax.management.ReflectionException(java.lang.Exception)
javax.management.ReflectionException(java.lang.Exception, java.lang.String)


Occurences of register

register occurences:
javax.xml.rpc.encoding.TypeMapping.register(java.lang.Class, javax.xml.namespace.QName, javax.xml.rpc.encoding.SerializerFactory, javax.xml.rpc.encoding.DeserializerFactory)
javax.xml.rpc.encoding.TypeMappingRegistry.register(java.lang.String, javax.xml.rpc.encoding.TypeMapping)


Occurences of RegistryException (constructors)

RegistryException (constructors) occurences:
javax.xml.registry.RegistryException()
javax.xml.registry.RegistryException(java.lang.String)
javax.xml.registry.RegistryException(java.lang.String, java.lang.Throwable)
javax.xml.registry.RegistryException(java.lang.Throwable)


Occurences of RelationException (constructors)

RelationException (constructors) occurences:
javax.management.relation.RelationException()
javax.management.relation.RelationException(java.lang.String)


Occurences of RelationNotFoundException (constructors)

RelationNotFoundException (constructors) occurences:
javax.management.relation.RelationNotFoundException()
javax.management.relation.RelationNotFoundException(java.lang.String)


Occurences of RelationNotification (constructors)

RelationNotification (constructors) occurences:
javax.management.relation.RelationNotification(java.lang.String, java.lang.Object, long, long, java.lang.String, java.lang.String, java.lang.String, javax.management.ObjectName, java.lang.String, java.util.List, java.util.List)
javax.management.relation.RelationNotification(java.lang.String, java.lang.Object, long, long, java.lang.String, java.lang.String, java.lang.String, javax.management.ObjectName, java.util.List)


Occurences of RelationServiceNotRegisteredException (constructors)

RelationServiceNotRegisteredException (constructors) occurences:
javax.management.relation.RelationServiceNotRegisteredException()
javax.management.relation.RelationServiceNotRegisteredException(java.lang.String)


Occurences of RelationSupport (constructors)

RelationSupport (constructors) occurences:
javax.management.relation.RelationSupport(java.lang.String, javax.management.ObjectName, java.lang.String, javax.management.relation.RoleList)
javax.management.relation.RelationSupport(java.lang.String, javax.management.ObjectName, javax.management.MBeanServer, java.lang.String, javax.management.relation.RoleList)


Occurences of RelationTypeNotFoundException (constructors)

RelationTypeNotFoundException (constructors) occurences:
javax.management.relation.RelationTypeNotFoundException()
javax.management.relation.RelationTypeNotFoundException(java.lang.String)


Occurences of RelationTypeSupport (constructors)

RelationTypeSupport (constructors) occurences:
javax.management.relation.RelationTypeSupport(java.lang.String)
javax.management.relation.RelationTypeSupport(java.lang.String, javax.management.relation.RoleInfo[])


Occurences of release

release occurences:
javax.enterprise.deploy.spi.DeploymentManager.release()
javax.resource.spi.endpoint.MessageEndpoint.release()
javax.resource.spi.work.Work.release()
javax.servlet.jsp.PageContext.release()
javax.servlet.jsp.tagext.BodyTagSupport.release()
javax.servlet.jsp.tagext.Tag.release()
javax.servlet.jsp.tagext.TagAdapter.release()
javax.servlet.jsp.tagext.TagLibraryValidator.release()
javax.servlet.jsp.tagext.TagSupport.release()


Occurences of remove

remove occurences:
javax.activation.MimeTypeParameterList.remove(java.lang.String)
javax.ejb.EJBHome.remove(java.lang.Object)
javax.ejb.EJBHome.remove(javax.ejb.Handle)
javax.ejb.EJBLocalHome.remove(java.lang.Object)
javax.ejb.EJBLocalObject.remove()
javax.ejb.EJBObject.remove()
javax.mail.Flags.remove(java.lang.String)
javax.mail.Flags.remove(javax.mail.Flags)
javax.mail.Flags.remove(javax.mail.Flags.Flag)
javax.mail.internet.ParameterList.remove(java.lang.String)
javax.management.openmbean.TabularData.remove(java.lang.Object[])
javax.management.openmbean.TabularDataSupport.remove(java.lang.Object)
javax.management.openmbean.TabularDataSupport.remove(java.lang.Object[])


Occurences of removeAllMimeHeaders

removeAllMimeHeaders occurences:
javax.xml.soap.AttachmentPart.removeAllMimeHeaders()
javax.xml.soap.SOAPPart.removeAllMimeHeaders()


Occurences of removeAllNotifications

removeAllNotifications occurences:
javax.management.timer.Timer.removeAllNotifications()
javax.management.timer.TimerMBean.removeAllNotifications()


Occurences of removeAttribute

removeAttribute occurences:
javax.servlet.http.HttpSession.removeAttribute(java.lang.String)
javax.servlet.jsp.JspContext.removeAttribute(java.lang.String)
javax.servlet.jsp.JspContext.removeAttribute(java.lang.String, int)
javax.servlet.ServletContext.removeAttribute(java.lang.String)
javax.servlet.ServletRequest.removeAttribute(java.lang.String)
javax.servlet.ServletRequestWrapper.removeAttribute(java.lang.String)
javax.xml.soap.SOAPElement.removeAttribute(javax.xml.soap.Name)


Occurences of removeAttributeChangeNotificationListener

removeAttributeChangeNotificationListener occurences:
javax.management.modelmbean.ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String)
javax.management.modelmbean.RequiredModelMBean.removeAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String)


Occurences of removeBodyPart

removeBodyPart occurences:
javax.mail.Multipart.removeBodyPart(int)
javax.mail.Multipart.removeBodyPart(javax.mail.BodyPart)


Occurences of removeChildConcept

removeChildConcept occurences:
javax.xml.registry.infomodel.ClassificationScheme.removeChildConcept(javax.xml.registry.infomodel.Concept)
javax.xml.registry.infomodel.Concept.removeChildConcept(javax.xml.registry.infomodel.Concept)


Occurences of removeChildConcepts

removeChildConcepts occurences:
javax.xml.registry.infomodel.ClassificationScheme.removeChildConcepts(java.util.Collection)
javax.xml.registry.infomodel.Concept.removeChildConcepts(java.util.Collection)


Occurences of removeConnectionListener

removeConnectionListener occurences:
javax.mail.Folder.removeConnectionListener(javax.mail.event.ConnectionListener)
javax.mail.Service.removeConnectionListener(javax.mail.event.ConnectionListener)


Occurences of removeDConfigBean

removeDConfigBean occurences:
javax.enterprise.deploy.spi.DConfigBean.removeDConfigBean(javax.enterprise.deploy.spi.DConfigBean)
javax.enterprise.deploy.spi.DeploymentConfiguration.removeDConfigBean(javax.enterprise.deploy.spi.DConfigBeanRoot)


Occurences of RemoveException (constructors)

RemoveException (constructors) occurences:
javax.ejb.RemoveException()
javax.ejb.RemoveException(java.lang.String)


Occurences of removeField

removeField occurences:
javax.management.Descriptor.removeField(java.lang.String)
javax.management.modelmbean.DescriptorSupport.removeField(java.lang.String)


Occurences of removeFolderListener

removeFolderListener occurences:
javax.mail.Folder.removeFolderListener(javax.mail.event.FolderListener)
javax.mail.Store.removeFolderListener(javax.mail.event.FolderListener)


Occurences of removeHeader

removeHeader occurences:
javax.mail.internet.InternetHeaders.removeHeader(java.lang.String)
javax.mail.internet.MimeBodyPart.removeHeader(java.lang.String)
javax.mail.internet.MimeMessage.removeHeader(java.lang.String)
javax.mail.Part.removeHeader(java.lang.String)
javax.xml.soap.MimeHeaders.removeHeader(java.lang.String)


Occurences of removeMimeHeader

removeMimeHeader occurences:
javax.xml.soap.AttachmentPart.removeMimeHeader(java.lang.String)
javax.xml.soap.SOAPPart.removeMimeHeader(java.lang.String)


Occurences of removeNotification

removeNotification occurences:
javax.management.timer.Timer.removeNotification(java.lang.Integer)
javax.management.timer.TimerMBean.removeNotification(java.lang.Integer)


Occurences of removeNotificationListener

removeNotificationListener occurences:
javax.management.j2ee.ListenerRegistration.removeNotificationListener(javax.management.ObjectName, javax.management.NotificationListener)
javax.management.MBeanServer.removeNotificationListener(javax.management.ObjectName, javax.management.NotificationListener)
javax.management.MBeanServer.removeNotificationListener(javax.management.ObjectName, javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.MBeanServer.removeNotificationListener(javax.management.ObjectName, javax.management.ObjectName)
javax.management.MBeanServer.removeNotificationListener(javax.management.ObjectName, javax.management.ObjectName, javax.management.NotificationFilter, java.lang.Object)
javax.management.MBeanServerConnection.removeNotificationListener(javax.management.ObjectName, javax.management.NotificationListener)
javax.management.MBeanServerConnection.removeNotificationListener(javax.management.ObjectName, javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.MBeanServerConnection.removeNotificationListener(javax.management.ObjectName, javax.management.ObjectName)
javax.management.MBeanServerConnection.removeNotificationListener(javax.management.ObjectName, javax.management.ObjectName, javax.management.NotificationFilter, java.lang.Object)
javax.management.MBeanServerDelegate.removeNotificationListener(javax.management.NotificationListener)
javax.management.MBeanServerDelegate.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.modelmbean.RequiredModelMBean.removeNotificationListener(javax.management.NotificationListener)
javax.management.modelmbean.RequiredModelMBean.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.NotificationBroadcaster.removeNotificationListener(javax.management.NotificationListener)
javax.management.NotificationBroadcasterSupport.removeNotificationListener(javax.management.NotificationListener)
javax.management.NotificationBroadcasterSupport.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)
javax.management.NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)


Occurences of removeNotifications

removeNotifications occurences:
javax.management.timer.Timer.removeNotifications(java.lang.String)
javax.management.timer.TimerMBean.removeNotifications(java.lang.String)


Occurences of removeObservedObject

removeObservedObject occurences:
javax.management.monitor.Monitor.removeObservedObject(javax.management.ObjectName)
javax.management.monitor.MonitorMBean.removeObservedObject(javax.management.ObjectName)


Occurences of removeProperty

removeProperty occurences:
javax.xml.rpc.Call.removeProperty(java.lang.String)
javax.xml.rpc.handler.MessageContext.removeProperty(java.lang.String)


Occurences of removeRelation

removeRelation occurences:
javax.management.relation.RelationService.removeRelation(java.lang.String)
javax.management.relation.RelationServiceMBean.removeRelation(java.lang.String)


Occurences of removeRelationType

removeRelationType occurences:
javax.management.relation.RelationService.removeRelationType(java.lang.String)
javax.management.relation.RelationServiceMBean.removeRelationType(java.lang.String)


Occurences of removeValue

removeValue occurences:
javax.servlet.http.HttpSession.removeValue(java.lang.String)
javax.servlet.jsp.tagext.TagSupport.removeValue(java.lang.String)


Occurences of removeXpathListener

removeXpathListener occurences:
javax.enterprise.deploy.model.DDBean.removeXpathListener(java.lang.String, javax.enterprise.deploy.model.XpathListener)
javax.enterprise.deploy.model.J2eeApplicationObject.removeXpathListener(javax.enterprise.deploy.shared.ModuleType, java.lang.String, javax.enterprise.deploy.model.XpathListener)


Occurences of reply

reply occurences:
javax.mail.internet.MimeMessage.reply(boolean)
javax.mail.Message.reply(boolean)


Occurences of request

request occurences:
javax.jms.QueueRequestor.request(javax.jms.Message)
javax.jms.TopicRequestor.request(javax.jms.Message)


Occurences of RequiredModelMBean (constructors)

RequiredModelMBean (constructors) occurences:
javax.management.modelmbean.RequiredModelMBean()
javax.management.modelmbean.RequiredModelMBean(javax.management.modelmbean.ModelMBeanInfo)


Occurences of reset

reset occurences:
javax.jms.BytesMessage.reset()
javax.jms.StreamMessage.reset()
javax.servlet.ServletResponse.reset()
javax.servlet.ServletResponseWrapper.reset()


Occurences of resetBuffer

resetBuffer occurences:
javax.servlet.ServletResponse.resetBuffer()
javax.servlet.ServletResponseWrapper.resetBuffer()


Occurences of ResourceAdapterInternalException (constructors)

ResourceAdapterInternalException (constructors) occurences:
javax.resource.spi.ResourceAdapterInternalException()
javax.resource.spi.ResourceAdapterInternalException(java.lang.String)
javax.resource.spi.ResourceAdapterInternalException(java.lang.String, java.lang.String)
javax.resource.spi.ResourceAdapterInternalException(java.lang.String, java.lang.Throwable)
javax.resource.spi.ResourceAdapterInternalException(java.lang.Throwable)


Occurences of ResourceAllocationException

ResourceAllocationException occurences:
javax.jms.ResourceAllocationException
javax.resource.spi.ResourceAllocationException


Occurences of ResourceAllocationException (constructors)

ResourceAllocationException (constructors) occurences:
javax.jms.ResourceAllocationException(java.lang.String)
javax.jms.ResourceAllocationException(java.lang.String, java.lang.String)
javax.resource.spi.ResourceAllocationException()
javax.resource.spi.ResourceAllocationException(java.lang.String)
javax.resource.spi.ResourceAllocationException(java.lang.String, java.lang.String)
javax.resource.spi.ResourceAllocationException(java.lang.String, java.lang.Throwable)
javax.resource.spi.ResourceAllocationException(java.lang.Throwable)


Occurences of ResourceException (constructors)

ResourceException (constructors) occurences:
javax.resource.ResourceException()
javax.resource.ResourceException(java.lang.String)
javax.resource.ResourceException(java.lang.String, java.lang.String)
javax.resource.ResourceException(java.lang.String, java.lang.Throwable)
javax.resource.ResourceException(java.lang.Throwable)


Occurences of ResourceWarning (constructors)

ResourceWarning (constructors) occurences:
javax.resource.cci.ResourceWarning()
javax.resource.cci.ResourceWarning(java.lang.String)
javax.resource.cci.ResourceWarning(java.lang.String, java.lang.String)
javax.resource.cci.ResourceWarning(java.lang.String, java.lang.Throwable)
javax.resource.cci.ResourceWarning(java.lang.Throwable)


Occurences of retrieveAllRoles

retrieveAllRoles occurences:
javax.management.relation.Relation.retrieveAllRoles()
javax.management.relation.RelationSupport.retrieveAllRoles()


Occurences of RoleInfo (constructors)

RoleInfo (constructors) occurences:
javax.management.relation.RoleInfo(java.lang.String, java.lang.String)
javax.management.relation.RoleInfo(java.lang.String, java.lang.String, boolean, boolean)
javax.management.relation.RoleInfo(java.lang.String, java.lang.String, boolean, boolean, int, int, java.lang.String)
javax.management.relation.RoleInfo(javax.management.relation.RoleInfo)


Occurences of RoleInfoNotFoundException (constructors)

RoleInfoNotFoundException (constructors) occurences:
javax.management.relation.RoleInfoNotFoundException()
javax.management.relation.RoleInfoNotFoundException(java.lang.String)


Occurences of RoleList (constructors)

RoleList (constructors) occurences:
javax.management.relation.RoleList()
javax.management.relation.RoleList(int)
javax.management.relation.RoleList(java.util.List)


Occurences of RoleNotFoundException (constructors)

RoleNotFoundException (constructors) occurences:
javax.management.relation.RoleNotFoundException()
javax.management.relation.RoleNotFoundException(java.lang.String)


Occurences of RoleUnresolvedList (constructors)

RoleUnresolvedList (constructors) occurences:
javax.management.relation.RoleUnresolvedList()
javax.management.relation.RoleUnresolvedList(int)
javax.management.relation.RoleUnresolvedList(java.util.List)


Occurences of rollback

rollback occurences:
javax.jms.Session.rollback()
javax.jms.XASession.rollback()
javax.resource.cci.LocalTransaction.rollback()
javax.resource.spi.LocalTransaction.rollback()
javax.resource.spi.XATerminator.rollback(javax.transaction.xa.Xid)
javax.transaction.Transaction.rollback()
javax.transaction.TransactionManager.rollback()
javax.transaction.UserTransaction.rollback()
javax.transaction.xa.XAResource.rollback(javax.transaction.xa.Xid)


Occurences of RollbackException (constructors)

RollbackException (constructors) occurences:
javax.transaction.RollbackException()
javax.transaction.RollbackException(java.lang.String)


Occurences of RuntimeErrorException (constructors)

RuntimeErrorException (constructors) occurences:
javax.management.RuntimeErrorException(java.lang.Error)
javax.management.RuntimeErrorException(java.lang.Error, java.lang.String)


Occurences of RuntimeMBeanException (constructors)

RuntimeMBeanException (constructors) occurences:
javax.management.RuntimeMBeanException(java.lang.RuntimeException)
javax.management.RuntimeMBeanException(java.lang.RuntimeException, java.lang.String)


Occurences of RuntimeOperationsException (constructors)

RuntimeOperationsException (constructors) occurences:
javax.management.RuntimeOperationsException(java.lang.RuntimeException)
javax.management.RuntimeOperationsException(java.lang.RuntimeException, java.lang.String)


Occurences of saveChanges

saveChanges occurences:
javax.mail.internet.MimeMessage.saveChanges()
javax.mail.Message.saveChanges()
javax.xml.soap.SOAPMessage.saveChanges()


Occurences of SaveException (constructors)

SaveException (constructors) occurences:
javax.xml.registry.SaveException()
javax.xml.registry.SaveException(java.lang.String)
javax.xml.registry.SaveException(java.lang.String, java.lang.Throwable)
javax.xml.registry.SaveException(java.lang.Throwable)


Occurences of SAXResult (constructors)

SAXResult (constructors) occurences:
javax.xml.transform.sax.SAXResult()
javax.xml.transform.sax.SAXResult(org.xml.sax.ContentHandler)


Occurences of SAXSource (constructors)

SAXSource (constructors) occurences:
javax.xml.transform.sax.SAXSource()
javax.xml.transform.sax.SAXSource(org.xml.sax.InputSource)
javax.xml.transform.sax.SAXSource(org.xml.sax.XMLReader, org.xml.sax.InputSource)


Occurences of scheduleWork

scheduleWork occurences:
javax.resource.spi.work.WorkManager.scheduleWork(javax.resource.spi.work.Work)
javax.resource.spi.work.WorkManager.scheduleWork(javax.resource.spi.work.Work, long, javax.resource.spi.work.ExecutionContext, javax.resource.spi.work.WorkListener)


Occurences of search

search occurences:
javax.mail.Folder.search(javax.mail.search.SearchTerm)
javax.mail.Folder.search(javax.mail.search.SearchTerm, javax.mail.Message[])
javax.mail.search


Occurences of SearchException (constructors)

SearchException (constructors) occurences:
javax.mail.search.SearchException()
javax.mail.search.SearchException(java.lang.String)


Occurences of SecurityException (constructors)

SecurityException (constructors) occurences:
javax.resource.spi.SecurityException()
javax.resource.spi.SecurityException(java.lang.String)
javax.resource.spi.SecurityException(java.lang.String, java.lang.String)
javax.resource.spi.SecurityException(java.lang.String, java.lang.Throwable)
javax.resource.spi.SecurityException(java.lang.Throwable)


Occurences of send

send occurences:
javax.jms.MessageProducer.send(javax.jms.Destination, javax.jms.Message)
javax.jms.MessageProducer.send(javax.jms.Destination, javax.jms.Message, int, int, long)
javax.jms.MessageProducer.send(javax.jms.Message)
javax.jms.MessageProducer.send(javax.jms.Message, int, int, long)
javax.jms.QueueSender.send(javax.jms.Message)
javax.jms.QueueSender.send(javax.jms.Message, int, int, long)
javax.jms.QueueSender.send(javax.jms.Queue, javax.jms.Message)
javax.jms.QueueSender.send(javax.jms.Queue, javax.jms.Message, int, int, long)
javax.mail.Transport.send(javax.mail.Message)
javax.mail.Transport.send(javax.mail.Message, javax.mail.Address[])


Occurences of sendAttributeChangeNotification

sendAttributeChangeNotification occurences:
javax.management.modelmbean.ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(javax.management.Attribute, javax.management.Attribute)
javax.management.modelmbean.ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(javax.management.AttributeChangeNotification)
javax.management.modelmbean.RequiredModelMBean.sendAttributeChangeNotification(javax.management.Attribute, javax.management.Attribute)
javax.management.modelmbean.RequiredModelMBean.sendAttributeChangeNotification(javax.management.AttributeChangeNotification)


Occurences of sendError

sendError occurences:
javax.servlet.http.HttpServletResponse.sendError(int)
javax.servlet.http.HttpServletResponse.sendError(int, java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.sendError(int)
javax.servlet.http.HttpServletResponseWrapper.sendError(int, java.lang.String)


Occurences of SendFailedException (constructors)

SendFailedException (constructors) occurences:
javax.mail.SendFailedException()
javax.mail.SendFailedException(java.lang.String)
javax.mail.SendFailedException(java.lang.String, java.lang.Exception)
javax.mail.SendFailedException(java.lang.String, java.lang.Exception, javax.mail.Address[], javax.mail.Address[], javax.mail.Address[])


Occurences of sendNotification

sendNotification occurences:
javax.management.MBeanServerDelegate.sendNotification(javax.management.Notification)
javax.management.modelmbean.ModelMBeanNotificationBroadcaster.sendNotification(java.lang.String)
javax.management.modelmbean.ModelMBeanNotificationBroadcaster.sendNotification(javax.management.Notification)
javax.management.modelmbean.RequiredModelMBean.sendNotification(java.lang.String)
javax.management.modelmbean.RequiredModelMBean.sendNotification(javax.management.Notification)
javax.management.NotificationBroadcasterSupport.sendNotification(javax.management.Notification)


Occurences of sendRedirect

sendRedirect occurences:
javax.servlet.http.HttpServletResponse.sendRedirect(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.sendRedirect(java.lang.String)


Occurences of sendRelationCreationNotification

sendRelationCreationNotification occurences:
javax.management.relation.RelationService.sendRelationCreationNotification(java.lang.String)
javax.management.relation.RelationServiceMBean.sendRelationCreationNotification(java.lang.String)


Occurences of sendRelationRemovalNotification

sendRelationRemovalNotification occurences:
javax.management.relation.RelationService.sendRelationRemovalNotification(java.lang.String, java.util.List)
javax.management.relation.RelationServiceMBean.sendRelationRemovalNotification(java.lang.String, java.util.List)


Occurences of sendRoleUpdateNotification

sendRoleUpdateNotification occurences:
javax.management.relation.RelationService.sendRoleUpdateNotification(java.lang.String, javax.management.relation.Role, java.util.List)
javax.management.relation.RelationServiceMBean.sendRoleUpdateNotification(java.lang.String, javax.management.relation.Role, java.util.List)


Occurences of server

server occurences:
javax.management.monitor.server
javax.xml.rpc.server


Occurences of service

service occurences:
javax.servlet.GenericServlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)
javax.servlet.http.HttpServlet.service(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
javax.servlet.http.HttpServlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)
javax.servlet.Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)


Occurences of Service

Service occurences:
javax.mail.Service
javax.xml.registry.infomodel.Service
javax.xml.rpc.Service


Occurences of ServiceException (constructors)

ServiceException (constructors) occurences:
javax.xml.rpc.ServiceException()
javax.xml.rpc.ServiceException(java.lang.String)
javax.xml.rpc.ServiceException(java.lang.String, java.lang.Throwable)
javax.xml.rpc.ServiceException(java.lang.Throwable)


Occurences of ServiceNotFoundException (constructors)

ServiceNotFoundException (constructors) occurences:
javax.management.ServiceNotFoundException()
javax.management.ServiceNotFoundException(java.lang.String)


Occurences of ServletException (constructors)

ServletException (constructors) occurences:
javax.servlet.ServletException()
javax.servlet.ServletException(java.lang.String)
javax.servlet.ServletException(java.lang.String, java.lang.Throwable)
javax.servlet.ServletException(java.lang.Throwable)


Occurences of Session

Session occurences:
javax.jms.Session
javax.mail.Session


Occurences of session

session occurences:
javax.mail.session
javax.mail.session


Occurences of SESSION_MAINTAIN_PROPERTY

SESSION_MAINTAIN_PROPERTY occurences:
javax.xml.rpc.SESSION_MAINTAIN_PROPERTY
javax.xml.rpc.SESSION_MAINTAIN_PROPERTY


Occurences of set

set occurences:
javax.activation.MimeTypeParameterList.set(java.lang.String, java.lang.String)
javax.mail.internet.ParameterList.set(java.lang.String, java.lang.String)
javax.mail.search.set
javax.management.AttributeList.set(int, javax.management.Attribute)
javax.management.relation.RoleList.set(int, javax.management.relation.Role)
javax.management.relation.RoleUnresolvedList.set(int, javax.management.relation.RoleUnresolved)


Occurences of setAddress

setAddress occurences:
javax.mail.internet.InternetAddress.setAddress(java.lang.String)
javax.xml.registry.infomodel.EmailAddress.setAddress(java.lang.String)


Occurences of setAttribute

setAttribute occurences:
javax.management.DynamicMBean.setAttribute(javax.management.Attribute)
javax.management.j2ee.Management.setAttribute(javax.management.ObjectName, javax.management.Attribute)
javax.management.MBeanServer.setAttribute(javax.management.ObjectName, javax.management.Attribute)
javax.management.MBeanServerConnection.setAttribute(javax.management.ObjectName, javax.management.Attribute)
javax.management.modelmbean.RequiredModelMBean.setAttribute(javax.management.Attribute)
javax.management.StandardMBean.setAttribute(javax.management.Attribute)
javax.servlet.http.HttpSession.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.jsp.JspContext.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.jsp.JspContext.setAttribute(java.lang.String, java.lang.Object, int)
javax.servlet.jsp.tagext.TagData.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.ServletContext.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.ServletRequest.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.ServletRequestWrapper.setAttribute(java.lang.String, java.lang.Object)
javax.xml.parsers.DocumentBuilderFactory.setAttribute(java.lang.String, java.lang.Object)
javax.xml.transform.TransformerFactory.setAttribute(java.lang.String, java.lang.Object)


Occurences of setAttributes

setAttributes occurences:
javax.management.DynamicMBean.setAttributes(javax.management.AttributeList)
javax.management.j2ee.Management.setAttributes(javax.management.ObjectName, javax.management.AttributeList)
javax.management.MBeanServer.setAttributes(javax.management.ObjectName, javax.management.AttributeList)
javax.management.MBeanServerConnection.setAttributes(javax.management.ObjectName, javax.management.AttributeList)
javax.management.modelmbean.RequiredModelMBean.setAttributes(javax.management.AttributeList)
javax.management.StandardMBean.setAttributes(javax.management.AttributeList)


Occurences of setBodyContent

setBodyContent occurences:
javax.servlet.jsp.tagext.BodyTag.setBodyContent(javax.servlet.jsp.tagext.BodyContent)
javax.servlet.jsp.tagext.BodyTagSupport.setBodyContent(javax.servlet.jsp.tagext.BodyContent)


Occurences of setBufferSize

setBufferSize occurences:
javax.servlet.ServletResponse.setBufferSize(int)
javax.servlet.ServletResponseWrapper.setBufferSize(int)


Occurences of setBytes

setBytes occurences:
javax.jms.MapMessage.setBytes(java.lang.String, byte[])
javax.jms.MapMessage.setBytes(java.lang.String, byte[], int, int)


Occurences of setCharacterEncoding

setCharacterEncoding occurences:
javax.servlet.ServletRequest.setCharacterEncoding(java.lang.String)
javax.servlet.ServletRequestWrapper.setCharacterEncoding(java.lang.String)
javax.servlet.ServletResponse.setCharacterEncoding(java.lang.String)
javax.servlet.ServletResponseWrapper.setCharacterEncoding(java.lang.String)


Occurences of setContent

setContent occurences:
javax.mail.internet.MimeBodyPart.setContent(java.lang.Object, java.lang.String)
javax.mail.internet.MimeBodyPart.setContent(javax.mail.Multipart)
javax.mail.internet.MimeMessage.setContent(java.lang.Object, java.lang.String)
javax.mail.internet.MimeMessage.setContent(javax.mail.Multipart)
javax.mail.Part.setContent(java.lang.Object, java.lang.String)
javax.mail.Part.setContent(javax.mail.Multipart)
javax.xml.soap.AttachmentPart.setContent(java.lang.Object, java.lang.String)
javax.xml.soap.SOAPPart.setContent(javax.xml.transform.Source)


Occurences of setContentId

setContentId occurences:
javax.xml.soap.AttachmentPart.setContentId(java.lang.String)
javax.xml.soap.SOAPPart.setContentId(java.lang.String)


Occurences of setContentID

setContentID occurences:
javax.mail.internet.MimeBodyPart.setContentID(java.lang.String)
javax.mail.internet.MimeMessage.setContentID(java.lang.String)


Occurences of setContentLanguage

setContentLanguage occurences:
javax.mail.internet.MimeBodyPart.setContentLanguage(java.lang.String[])
javax.mail.internet.MimeMessage.setContentLanguage(java.lang.String[])
javax.mail.internet.MimePart.setContentLanguage(java.lang.String[])


Occurences of setContentLength

setContentLength occurences:
javax.servlet.ServletResponse.setContentLength(int)
javax.servlet.ServletResponseWrapper.setContentLength(int)


Occurences of setContentLocation

setContentLocation occurences:
javax.xml.soap.AttachmentPart.setContentLocation(java.lang.String)
javax.xml.soap.SOAPPart.setContentLocation(java.lang.String)


Occurences of setContentMD5

setContentMD5 occurences:
javax.mail.internet.MimeBodyPart.setContentMD5(java.lang.String)
javax.mail.internet.MimeMessage.setContentMD5(java.lang.String)
javax.mail.internet.MimePart.setContentMD5(java.lang.String)


Occurences of setContentType

setContentType occurences:
javax.servlet.ServletResponse.setContentType(java.lang.String)
javax.servlet.ServletResponseWrapper.setContentType(java.lang.String)
javax.xml.soap.AttachmentPart.setContentType(java.lang.String)


Occurences of setDataHandler

setDataHandler occurences:
javax.mail.internet.MimeBodyPart.setDataHandler(javax.activation.DataHandler)
javax.mail.internet.MimeMessage.setDataHandler(javax.activation.DataHandler)
javax.mail.Part.setDataHandler(javax.activation.DataHandler)
javax.xml.soap.AttachmentPart.setDataHandler(javax.activation.DataHandler)


Occurences of setDateHeader

setDateHeader occurences:
javax.servlet.http.HttpServletResponse.setDateHeader(java.lang.String, long)
javax.servlet.http.HttpServletResponseWrapper.setDateHeader(java.lang.String, long)


Occurences of setDescription

setDescription occurences:
javax.mail.internet.MimeBodyPart.setDescription(java.lang.String)
javax.mail.internet.MimeBodyPart.setDescription(java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.setDescription(java.lang.String)
javax.mail.internet.MimeMessage.setDescription(java.lang.String, java.lang.String)
javax.mail.Part.setDescription(java.lang.String)
javax.xml.registry.infomodel.RegistryObject.setDescription(javax.xml.registry.infomodel.InternationalString)


Occurences of setDescriptor

setDescriptor occurences:
javax.management.DescriptorAccess.setDescriptor(javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanAttributeInfo.setDescriptor(javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanConstructorInfo.setDescriptor(javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanInfo.setDescriptor(javax.management.Descriptor, java.lang.String)
javax.management.modelmbean.ModelMBeanInfoSupport.setDescriptor(javax.management.Descriptor, java.lang.String)
javax.management.modelmbean.ModelMBeanNotificationInfo.setDescriptor(javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanOperationInfo.setDescriptor(javax.management.Descriptor)


Occurences of setDescriptors

setDescriptors occurences:
javax.management.modelmbean.ModelMBeanInfo.setDescriptors(javax.management.Descriptor[])
javax.management.modelmbean.ModelMBeanInfoSupport.setDescriptors(javax.management.Descriptor[])


Occurences of setDifferenceMode

setDifferenceMode occurences:
javax.management.monitor.CounterMonitor.setDifferenceMode(boolean)
javax.management.monitor.CounterMonitorMBean.setDifferenceMode(boolean)
javax.management.monitor.GaugeMonitor.setDifferenceMode(boolean)
javax.management.monitor.GaugeMonitorMBean.setDifferenceMode(boolean)


Occurences of setDisposition

setDisposition occurences:
javax.mail.internet.ContentDisposition.setDisposition(java.lang.String)
javax.mail.internet.MimeBodyPart.setDisposition(java.lang.String)
javax.mail.internet.MimeMessage.setDisposition(java.lang.String)
javax.mail.Part.setDisposition(java.lang.String)


Occurences of setErrorListener

setErrorListener occurences:
javax.xml.transform.Transformer.setErrorListener(javax.xml.transform.ErrorListener)
javax.xml.transform.TransformerFactory.setErrorListener(javax.xml.transform.ErrorListener)


Occurences of setFaultCode

setFaultCode occurences:
javax.xml.soap.SOAPFault.setFaultCode(java.lang.String)
javax.xml.soap.SOAPFault.setFaultCode(javax.xml.soap.Name)


Occurences of setFaultString

setFaultString occurences:
javax.xml.soap.SOAPFault.setFaultString(java.lang.String)
javax.xml.soap.SOAPFault.setFaultString(java.lang.String, java.util.Locale)


Occurences of setField

setField occurences:
javax.management.Descriptor.setField(java.lang.String, java.lang.Object)
javax.management.modelmbean.DescriptorSupport.setField(java.lang.String, java.lang.Object)


Occurences of setFields

setFields occurences:
javax.management.Descriptor.setFields(java.lang.String[], java.lang.Object[])
javax.management.modelmbean.DescriptorSupport.setFields(java.lang.String[], java.lang.Object[])


Occurences of setFileName

setFileName occurences:
javax.mail.internet.MimeBodyPart.setFileName(java.lang.String)
javax.mail.internet.MimeMessage.setFileName(java.lang.String)
javax.mail.Part.setFileName(java.lang.String)


Occurences of setFlags

setFlags occurences:
javax.mail.Folder.setFlags(int, int, javax.mail.Flags, boolean)
javax.mail.Folder.setFlags(int[], javax.mail.Flags, boolean)
javax.mail.Folder.setFlags(javax.mail.Message[], javax.mail.Flags, boolean)
javax.mail.internet.MimeMessage.setFlags(javax.mail.Flags, boolean)
javax.mail.Message.setFlags(javax.mail.Flags, boolean)


Occurences of setFrom

setFrom occurences:
javax.mail.internet.MimeMessage.setFrom()
javax.mail.internet.MimeMessage.setFrom(javax.mail.Address)
javax.mail.Message.setFrom()
javax.mail.Message.setFrom(javax.mail.Address)


Occurences of setGranularityPeriod

setGranularityPeriod occurences:
javax.management.monitor.CounterMonitor.setGranularityPeriod(long)
javax.management.monitor.GaugeMonitor.setGranularityPeriod(long)
javax.management.monitor.Monitor.setGranularityPeriod(long)
javax.management.monitor.MonitorMBean.setGranularityPeriod(long)
javax.management.monitor.StringMonitor.setGranularityPeriod(long)


Occurences of setHeader

setHeader occurences:
javax.mail.internet.InternetHeaders.setHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeBodyPart.setHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.setHeader(java.lang.String, java.lang.String)
javax.mail.Part.setHeader(java.lang.String, java.lang.String)
javax.servlet.http.HttpServletResponse.setHeader(java.lang.String, java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.setHeader(java.lang.String, java.lang.String)
javax.xml.soap.MimeHeaders.setHeader(java.lang.String, java.lang.String)


Occurences of setId

setId occurences:
javax.servlet.jsp.tagext.TagSupport.setId(java.lang.String)
javax.xml.registry.infomodel.Key.setId(java.lang.String)


Occurences of setInitThreshold

setInitThreshold occurences:
javax.management.monitor.CounterMonitor.setInitThreshold(java.lang.Number)
javax.management.monitor.CounterMonitorMBean.setInitThreshold(java.lang.Number)


Occurences of setIntHeader

setIntHeader occurences:
javax.servlet.http.HttpServletResponse.setIntHeader(java.lang.String, int)
javax.servlet.http.HttpServletResponseWrapper.setIntHeader(java.lang.String, int)


Occurences of setJspBody

setJspBody occurences:
javax.servlet.jsp.tagext.SimpleTag.setJspBody(javax.servlet.jsp.tagext.JspFragment)
javax.servlet.jsp.tagext.SimpleTagSupport.setJspBody(javax.servlet.jsp.tagext.JspFragment)


Occurences of setJspContext

setJspContext occurences:
javax.servlet.jsp.tagext.SimpleTag.setJspContext(javax.servlet.jsp.JspContext)
javax.servlet.jsp.tagext.SimpleTagSupport.setJspContext(javax.servlet.jsp.JspContext)


Occurences of setLibraryDirectory

setLibraryDirectory occurences:
javax.management.loading.MLet.setLibraryDirectory(java.lang.String)
javax.management.loading.MLetMBean.setLibraryDirectory(java.lang.String)


Occurences of setLinkedException

setLinkedException occurences:
javax.jms.JMSException.setLinkedException(java.lang.Exception)
javax.resource.ResourceException.setLinkedException(java.lang.Exception)


Occurences of setLocale

setLocale occurences:
javax.enterprise.deploy.spi.DeploymentManager.setLocale(java.util.Locale)
javax.servlet.ServletResponse.setLocale(java.util.Locale)
javax.servlet.ServletResponseWrapper.setLocale(java.util.Locale)
javax.xml.registry.infomodel.LocalizedString.setLocale(java.util.Locale)


Occurences of setLogWriter

setLogWriter occurences:
javax.resource.spi.ManagedConnection.setLogWriter(java.io.PrintWriter)
javax.resource.spi.ManagedConnectionFactory.setLogWriter(java.io.PrintWriter)


Occurences of setManagedResource

setManagedResource occurences:
javax.management.modelmbean.ModelMBean.setManagedResource(java.lang.Object, java.lang.String)
javax.management.modelmbean.RequiredModelMBean.setManagedResource(java.lang.Object, java.lang.String)


Occurences of setMBeanDescriptor

setMBeanDescriptor occurences:
javax.management.modelmbean.ModelMBeanInfo.setMBeanDescriptor(javax.management.Descriptor)
javax.management.modelmbean.ModelMBeanInfoSupport.setMBeanDescriptor(javax.management.Descriptor)


Occurences of setMBeanServer

setMBeanServer occurences:
javax.management.AttributeValueExp.setMBeanServer(javax.management.MBeanServer)
javax.management.ObjectName.setMBeanServer(javax.management.MBeanServer)
javax.management.QueryEval.setMBeanServer(javax.management.MBeanServer)
javax.management.QueryExp.setMBeanServer(javax.management.MBeanServer)
javax.management.StringValueExp.setMBeanServer(javax.management.MBeanServer)
javax.management.ValueExp.setMBeanServer(javax.management.MBeanServer)


Occurences of setMessageListener

setMessageListener occurences:
javax.jms.MessageConsumer.setMessageListener(javax.jms.MessageListener)
javax.jms.Session.setMessageListener(javax.jms.MessageListener)


Occurences of setMimeHeader

setMimeHeader occurences:
javax.xml.soap.AttachmentPart.setMimeHeader(java.lang.String, java.lang.String)
javax.xml.soap.SOAPPart.setMimeHeader(java.lang.String, java.lang.String)


Occurences of setModelMBeanInfo

setModelMBeanInfo occurences:
javax.management.modelmbean.ModelMBean.setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo)
javax.management.modelmbean.RequiredModelMBean.setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo)


Occurences of setModulus

setModulus occurences:
javax.management.monitor.CounterMonitor.setModulus(java.lang.Number)
javax.management.monitor.CounterMonitorMBean.setModulus(java.lang.Number)


Occurences of setName

setName occurences:
javax.xml.registry.infomodel.RegistryObject.setName(javax.xml.registry.infomodel.InternationalString)
javax.xml.registry.infomodel.Slot.setName(java.lang.String)


Occurences of setNamespaceAware

setNamespaceAware occurences:
javax.xml.parsers.DocumentBuilderFactory.setNamespaceAware(boolean)
javax.xml.parsers.SAXParserFactory.setNamespaceAware(boolean)


Occurences of setNode

setNode occurences:
javax.xml.transform.dom.DOMResult.setNode(org.w3c.dom.Node)
javax.xml.transform.dom.DOMSource.setNode(org.w3c.dom.Node)


Occurences of setNotify

setNotify occurences:
javax.management.monitor.CounterMonitor.setNotify(boolean)
javax.management.monitor.CounterMonitorMBean.setNotify(boolean)


Occurences of setNotifyDiffer

setNotifyDiffer occurences:
javax.management.monitor.StringMonitor.setNotifyDiffer(boolean)
javax.management.monitor.StringMonitorMBean.setNotifyDiffer(boolean)


Occurences of setNotifyHigh

setNotifyHigh occurences:
javax.management.monitor.GaugeMonitor.setNotifyHigh(boolean)
javax.management.monitor.GaugeMonitorMBean.setNotifyHigh(boolean)


Occurences of setNotifyLow

setNotifyLow occurences:
javax.management.monitor.GaugeMonitor.setNotifyLow(boolean)
javax.management.monitor.GaugeMonitorMBean.setNotifyLow(boolean)


Occurences of setNotifyMatch

setNotifyMatch occurences:
javax.management.monitor.StringMonitor.setNotifyMatch(boolean)
javax.management.monitor.StringMonitorMBean.setNotifyMatch(boolean)


Occurences of setObject

setObject occurences:
javax.jms.MapMessage.setObject(java.lang.String, java.lang.Object)
javax.jms.ObjectMessage.setObject(java.io.Serializable)


Occurences of setObservedAttribute

setObservedAttribute occurences:
javax.management.monitor.Monitor.setObservedAttribute(java.lang.String)
javax.management.monitor.MonitorMBean.setObservedAttribute(java.lang.String)


Occurences of setObservedObject

setObservedObject occurences:
javax.management.monitor.Monitor.setObservedObject(javax.management.ObjectName)
javax.management.monitor.MonitorMBean.setObservedObject(javax.management.ObjectName)


Occurences of setOffset

setOffset occurences:
javax.management.monitor.CounterMonitor.setOffset(java.lang.Number)
javax.management.monitor.CounterMonitorMBean.setOffset(java.lang.Number)


Occurences of setPageContext

setPageContext occurences:
javax.servlet.jsp.tagext.Tag.setPageContext(javax.servlet.jsp.PageContext)
javax.servlet.jsp.tagext.TagAdapter.setPageContext(javax.servlet.jsp.PageContext)
javax.servlet.jsp.tagext.TagSupport.setPageContext(javax.servlet.jsp.PageContext)


Occurences of setParameter

setParameter occurences:
javax.activation.MimeType.setParameter(java.lang.String, java.lang.String)
javax.mail.internet.ContentDisposition.setParameter(java.lang.String, java.lang.String)
javax.mail.internet.ContentType.setParameter(java.lang.String, java.lang.String)
javax.xml.transform.Transformer.setParameter(java.lang.String, java.lang.Object)


Occurences of setParameterList

setParameterList occurences:
javax.mail.internet.ContentDisposition.setParameterList(javax.mail.internet.ParameterList)
javax.mail.internet.ContentType.setParameterList(javax.mail.internet.ParameterList)


Occurences of setParent

setParent occurences:
javax.mail.Multipart.setParent(javax.mail.Part)
javax.servlet.jsp.tagext.SimpleTag.setParent(javax.servlet.jsp.tagext.JspTag)
javax.servlet.jsp.tagext.SimpleTagSupport.setParent(javax.servlet.jsp.tagext.JspTag)
javax.servlet.jsp.tagext.Tag.setParent(javax.servlet.jsp.tagext.Tag)
javax.servlet.jsp.tagext.TagAdapter.setParent(javax.servlet.jsp.tagext.Tag)
javax.servlet.jsp.tagext.TagSupport.setParent(javax.servlet.jsp.tagext.Tag)


Occurences of setPersonal

setPersonal occurences:
javax.mail.internet.InternetAddress.setPersonal(java.lang.String)
javax.mail.internet.InternetAddress.setPersonal(java.lang.String, java.lang.String)


Occurences of setPrimaryType

setPrimaryType occurences:
javax.activation.MimeType.setPrimaryType(java.lang.String)
javax.mail.internet.ContentType.setPrimaryType(java.lang.String)


Occurences of setProperty

setProperty occurences:
javax.xml.parsers.SAXParser.setProperty(java.lang.String, java.lang.Object)
javax.xml.rpc.Call.setProperty(java.lang.String, java.lang.Object)
javax.xml.rpc.handler.MessageContext.setProperty(java.lang.String, java.lang.Object)
javax.xml.soap.SOAPMessage.setProperty(java.lang.String, java.lang.Object)


Occurences of setPurgeFlag

setPurgeFlag occurences:
javax.management.relation.RelationService.setPurgeFlag(boolean)
javax.management.relation.RelationServiceMBean.setPurgeFlag(boolean)


Occurences of setRecipients

setRecipients occurences:
javax.mail.internet.MimeMessage.setRecipients(javax.mail.Message.RecipientType, java.lang.String)
javax.mail.internet.MimeMessage.setRecipients(javax.mail.Message.RecipientType, javax.mail.Address[])
javax.mail.Message.setRecipients(javax.mail.Message.RecipientType, javax.mail.Address[])


Occurences of setRelationServiceManagementFlag

setRelationServiceManagementFlag occurences:
javax.management.relation.RelationSupport.setRelationServiceManagementFlag(java.lang.Boolean)
javax.management.relation.RelationSupportMBean.setRelationServiceManagementFlag(java.lang.Boolean)


Occurences of setReplyTo

setReplyTo occurences:
javax.mail.internet.MimeMessage.setReplyTo(javax.mail.Address[])
javax.mail.Message.setReplyTo(javax.mail.Address[])


Occurences of setReturnType

setReturnType occurences:
javax.xml.rpc.Call.setReturnType(javax.xml.namespace.QName)
javax.xml.rpc.Call.setReturnType(javax.xml.namespace.QName, java.lang.Class)


Occurences of setRole

setRole occurences:
javax.management.relation.Relation.setRole(javax.management.relation.Role)
javax.management.relation.RelationService.setRole(java.lang.String, javax.management.relation.Role)
javax.management.relation.RelationServiceMBean.setRole(java.lang.String, javax.management.relation.Role)
javax.management.relation.RelationSupport.setRole(javax.management.relation.Role)


Occurences of setRoleName

setRoleName occurences:
javax.management.relation.Role.setRoleName(java.lang.String)
javax.management.relation.RoleUnresolved.setRoleName(java.lang.String)


Occurences of setRoles

setRoles occurences:
javax.management.relation.Relation.setRoles(javax.management.relation.RoleList)
javax.management.relation.RelationService.setRoles(java.lang.String, javax.management.relation.RoleList)
javax.management.relation.RelationServiceMBean.setRoles(java.lang.String, javax.management.relation.RoleList)
javax.management.relation.RelationSupport.setRoles(javax.management.relation.RoleList)
javax.management.relation.RoleResult.setRoles(javax.management.relation.RoleList)
javax.xml.rpc.handler.HandlerChain.setRoles(java.lang.String[])


Occurences of setRoleValue

setRoleValue occurences:
javax.management.relation.Role.setRoleValue(java.util.List)
javax.management.relation.RoleUnresolved.setRoleValue(java.util.List)


Occurences of setRollbackOnly

setRollbackOnly occurences:
javax.ejb.EJBContext.setRollbackOnly()
javax.transaction.Transaction.setRollbackOnly()
javax.transaction.TransactionManager.setRollbackOnly()
javax.transaction.UserTransaction.setRollbackOnly()


Occurences of setSendPastNotifications

setSendPastNotifications occurences:
javax.management.timer.Timer.setSendPastNotifications(boolean)
javax.management.timer.TimerMBean.setSendPastNotifications(boolean)


Occurences of setSentDate

setSentDate occurences:
javax.mail.internet.MimeMessage.setSentDate(java.util.Date)
javax.mail.Message.setSentDate(java.util.Date)


Occurences of setStatus

setStatus occurences:
javax.servlet.http.HttpServletResponse.setStatus(int)
javax.servlet.http.HttpServletResponse.setStatus(int, java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.setStatus(int)
javax.servlet.http.HttpServletResponseWrapper.setStatus(int, java.lang.String)


Occurences of setStringToCompare

setStringToCompare occurences:
javax.management.monitor.StringMonitor.setStringToCompare(java.lang.String)
javax.management.monitor.StringMonitorMBean.setStringToCompare(java.lang.String)


Occurences of setSubject

setSubject occurences:
javax.mail.internet.MimeMessage.setSubject(java.lang.String)
javax.mail.internet.MimeMessage.setSubject(java.lang.String, java.lang.String)
javax.mail.Message.setSubject(java.lang.String)


Occurences of setSubType

setSubType occurences:
javax.activation.MimeType.setSubType(java.lang.String)
javax.mail.internet.ContentType.setSubType(java.lang.String)
javax.mail.internet.MimeMultipart.setSubType(java.lang.String)


Occurences of setSystemId

setSystemId occurences:
javax.xml.transform.dom.DOMResult.setSystemId(java.lang.String)
javax.xml.transform.dom.DOMSource.setSystemId(java.lang.String)
javax.xml.transform.Result.setSystemId(java.lang.String)
javax.xml.transform.sax.SAXResult.setSystemId(java.lang.String)
javax.xml.transform.sax.SAXSource.setSystemId(java.lang.String)
javax.xml.transform.sax.TemplatesHandler.setSystemId(java.lang.String)
javax.xml.transform.sax.TransformerHandler.setSystemId(java.lang.String)
javax.xml.transform.Source.setSystemId(java.lang.String)
javax.xml.transform.stream.StreamResult.setSystemId(java.io.File)
javax.xml.transform.stream.StreamResult.setSystemId(java.lang.String)
javax.xml.transform.stream.StreamSource.setSystemId(java.io.File)
javax.xml.transform.stream.StreamSource.setSystemId(java.lang.String)


Occurences of setTelephoneNumbers

setTelephoneNumbers occurences:
javax.xml.registry.infomodel.Organization.setTelephoneNumbers(java.util.Collection)
javax.xml.registry.infomodel.User.setTelephoneNumbers(java.util.Collection)


Occurences of setText

setText occurences:
javax.jms.TextMessage.setText(java.lang.String)
javax.mail.internet.MimeBodyPart.setText(java.lang.String)
javax.mail.internet.MimeBodyPart.setText(java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.setText(java.lang.String)
javax.mail.internet.MimeMessage.setText(java.lang.String, java.lang.String)
javax.mail.internet.MimePart.setText(java.lang.String)
javax.mail.internet.MimePart.setText(java.lang.String, java.lang.String)
javax.mail.Part.setText(java.lang.String)


Occurences of setThreshold

setThreshold occurences:
javax.management.monitor.CounterMonitor.setThreshold(java.lang.Number)
javax.management.monitor.CounterMonitorMBean.setThreshold(java.lang.Number)


Occurences of setThresholds

setThresholds occurences:
javax.management.monitor.GaugeMonitor.setThresholds(java.lang.Number, java.lang.Number)
javax.management.monitor.GaugeMonitorMBean.setThresholds(java.lang.Number, java.lang.Number)


Occurences of setTransactionTimeout

setTransactionTimeout occurences:
javax.resource.spi.work.ExecutionContext.setTransactionTimeout(long)
javax.transaction.TransactionManager.setTransactionTimeout(int)
javax.transaction.UserTransaction.setTransactionTimeout(int)
javax.transaction.xa.XAResource.setTransactionTimeout(int)


Occurences of setType

setType occurences:
javax.xml.registry.infomodel.EmailAddress.setType(java.lang.String)
javax.xml.registry.infomodel.PostalAddress.setType(java.lang.String)
javax.xml.registry.infomodel.TelephoneNumber.setType(java.lang.String)
javax.xml.registry.infomodel.User.setType(java.lang.String)


Occurences of setURIResolver

setURIResolver occurences:
javax.xml.transform.Transformer.setURIResolver(javax.xml.transform.URIResolver)
javax.xml.transform.TransformerFactory.setURIResolver(javax.xml.transform.URIResolver)


Occurences of setUrl

setUrl occurences:
javax.xml.registry.infomodel.TelephoneNumber.setUrl(java.lang.String)
javax.xml.registry.infomodel.User.setUrl(java.net.URL)


Occurences of setValidating

setValidating occurences:
javax.xml.parsers.DocumentBuilderFactory.setValidating(boolean)
javax.xml.parsers.SAXParserFactory.setValidating(boolean)


Occurences of setValue

setValue occurences:
javax.servlet.http.Cookie.setValue(java.lang.String)
javax.servlet.jsp.tagext.TagSupport.setValue(java.lang.String, java.lang.Object)
javax.xml.registry.infomodel.Classification.setValue(java.lang.String)
javax.xml.registry.infomodel.Concept.setValue(java.lang.String)
javax.xml.registry.infomodel.ExternalIdentifier.setValue(java.lang.String)
javax.xml.registry.infomodel.InternationalString.setValue(java.lang.String)
javax.xml.registry.infomodel.InternationalString.setValue(java.util.Locale, java.lang.String)
javax.xml.registry.infomodel.LocalizedString.setValue(java.lang.String)
javax.xml.soap.Node.setValue(java.lang.String)


Occurences of SharingViolationException (constructors)

SharingViolationException (constructors) occurences:
javax.resource.spi.SharingViolationException()
javax.resource.spi.SharingViolationException(java.lang.String)
javax.resource.spi.SharingViolationException(java.lang.String, java.lang.String)
javax.resource.spi.SharingViolationException(java.lang.String, java.lang.Throwable)
javax.resource.spi.SharingViolationException(java.lang.Throwable)


Occurences of ShortHolder (constructors)

ShortHolder (constructors) occurences:
javax.xml.rpc.holders.ShortHolder()
javax.xml.rpc.holders.ShortHolder(short)


Occurences of ShortWrapperHolder (constructors)

ShortWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.ShortWrapperHolder()
javax.xml.rpc.holders.ShortWrapperHolder(java.lang.Short)


Occurences of size

size occurences:
javax.activation.MimeTypeParameterList.size()
javax.mail.internet.ParameterList.size()
javax.management.openmbean.TabularData.size()
javax.management.openmbean.TabularDataSupport.size()


Occurences of SkipPageException (constructors)

SkipPageException (constructors) occurences:
javax.servlet.jsp.SkipPageException()
javax.servlet.jsp.SkipPageException(java.lang.String)
javax.servlet.jsp.SkipPageException(java.lang.String, java.lang.Throwable)
javax.servlet.jsp.SkipPageException(java.lang.Throwable)


Occurences of soap

soap occurences:
javax.xml.rpc.handler.soap
javax.xml.rpc.soap
javax.xml.soap


Occurences of SOAPException (constructors)

SOAPException (constructors) occurences:
javax.xml.soap.SOAPException()
javax.xml.soap.SOAPException(java.lang.String)
javax.xml.soap.SOAPException(java.lang.String, java.lang.Throwable)
javax.xml.soap.SOAPException(java.lang.Throwable)


Occurences of spi

spi occurences:
javax.ejb.spi
javax.enterprise.deploy.spi
javax.resource.spi


Occurences of StandardMBean (constructors)

StandardMBean (constructors) occurences:
javax.management.StandardMBean(java.lang.Class)
javax.management.StandardMBean(java.lang.Object, java.lang.Class)


Occurences of start

start occurences:
javax.enterprise.deploy.spi.DeploymentManager.start(javax.enterprise.deploy.spi.TargetModuleID[])
javax.jms.Connection.start()
javax.jms.ServerSession.start()
javax.management.monitor.CounterMonitor.start()
javax.management.monitor.GaugeMonitor.start()
javax.management.monitor.Monitor.start()
javax.management.monitor.MonitorMBean.start()
javax.management.monitor.StringMonitor.start()
javax.management.timer.Timer.start()
javax.management.timer.TimerMBean.start()
javax.resource.spi.ResourceAdapter.start(javax.resource.spi.BootstrapContext)
javax.transaction.xa.XAResource.start(javax.transaction.xa.Xid, int)


Occurences of startWork

startWork occurences:
javax.resource.spi.work.WorkManager.startWork(javax.resource.spi.work.Work)
javax.resource.spi.work.WorkManager.startWork(javax.resource.spi.work.Work, long, javax.resource.spi.work.ExecutionContext, javax.resource.spi.work.WorkListener)


Occurences of stop

stop occurences:
javax.enterprise.deploy.spi.DeploymentManager.stop(javax.enterprise.deploy.spi.TargetModuleID[])
javax.enterprise.deploy.spi.status.ProgressObject.stop()
javax.jms.Connection.stop()
javax.management.monitor.CounterMonitor.stop()
javax.management.monitor.GaugeMonitor.stop()
javax.management.monitor.Monitor.stop()
javax.management.monitor.MonitorMBean.stop()
javax.management.monitor.StringMonitor.stop()
javax.management.timer.Timer.stop()
javax.management.timer.TimerMBean.stop()
javax.resource.spi.ResourceAdapter.stop()


Occurences of STOP

STOP occurences:
javax.enterprise.deploy.shared.STOP
javax.enterprise.deploy.shared.STOP


Occurences of store

store occurences:
javax.mail.store
javax.management.modelmbean.RequiredModelMBean.store()
javax.management.PersistentMBean.store()


Occurences of StoreClosedException (constructors)

StoreClosedException (constructors) occurences:
javax.mail.StoreClosedException(javax.mail.Store)
javax.mail.StoreClosedException(javax.mail.Store, java.lang.String)


Occurences of StreamResult (constructors)

StreamResult (constructors) occurences:
javax.xml.transform.stream.StreamResult()
javax.xml.transform.stream.StreamResult(java.io.File)
javax.xml.transform.stream.StreamResult(java.io.OutputStream)
javax.xml.transform.stream.StreamResult(java.io.Writer)
javax.xml.transform.stream.StreamResult(java.lang.String)


Occurences of StreamSource (constructors)

StreamSource (constructors) occurences:
javax.xml.transform.stream.StreamSource()
javax.xml.transform.stream.StreamSource(java.io.File)
javax.xml.transform.stream.StreamSource(java.io.InputStream)
javax.xml.transform.stream.StreamSource(java.io.InputStream, java.lang.String)
javax.xml.transform.stream.StreamSource(java.io.Reader)
javax.xml.transform.stream.StreamSource(java.io.Reader, java.lang.String)
javax.xml.transform.stream.StreamSource(java.lang.String)


Occurences of StringHolder (constructors)

StringHolder (constructors) occurences:
javax.xml.rpc.holders.StringHolder()
javax.xml.rpc.holders.StringHolder(java.lang.String)


Occurences of StringTerm (constructors)

StringTerm (constructors) occurences:
javax.mail.search.StringTerm(java.lang.String)
javax.mail.search.StringTerm(java.lang.String, boolean)


Occurences of StringValueExp (constructors)

StringValueExp (constructors) occurences:
javax.management.StringValueExp()
javax.management.StringValueExp(java.lang.String)


Occurences of SystemException (constructors)

SystemException (constructors) occurences:
javax.transaction.SystemException()
javax.transaction.SystemException(int)
javax.transaction.SystemException(java.lang.String)


Occurences of TabularDataSupport (constructors)

TabularDataSupport (constructors) occurences:
javax.management.openmbean.TabularDataSupport(javax.management.openmbean.TabularType)
javax.management.openmbean.TabularDataSupport(javax.management.openmbean.TabularType, int, float)


Occurences of TagAttributeInfo (constructors)

TagAttributeInfo (constructors) occurences:
javax.servlet.jsp.tagext.TagAttributeInfo(java.lang.String, boolean, java.lang.String, boolean)
javax.servlet.jsp.tagext.TagAttributeInfo(java.lang.String, boolean, java.lang.String, boolean, boolean)


Occurences of TagData (constructors)

TagData (constructors) occurences:
javax.servlet.jsp.tagext.TagData(java.lang.Object[][])
javax.servlet.jsp.tagext.TagData(java.util.Hashtable)


Occurences of TagInfo (constructors)

TagInfo (constructors) occurences:
javax.servlet.jsp.tagext.TagInfo(java.lang.String, java.lang.String, java.lang.String, java.lang.String, javax.servlet.jsp.tagext.TagLibraryInfo, javax.servlet.jsp.tagext.TagExtraInfo, javax.servlet.jsp.tagext.TagAttributeInfo[])
javax.servlet.jsp.tagext.TagInfo(java.lang.String, java.lang.String, java.lang.String, java.lang.String, javax.servlet.jsp.tagext.TagLibraryInfo, javax.servlet.jsp.tagext.TagExtraInfo, javax.servlet.jsp.tagext.TagAttributeInfo[], java.lang.String, java.lang.String, java.lang.String, javax.servlet.jsp.tagext.TagVariableInfo[])
javax.servlet.jsp.tagext.TagInfo(java.lang.String, java.lang.String, java.lang.String, java.lang.String, javax.servlet.jsp.tagext.TagLibraryInfo, javax.servlet.jsp.tagext.TagExtraInfo, javax.servlet.jsp.tagext.TagAttributeInfo[], java.lang.String, java.lang.String, java.lang.String, javax.servlet.jsp.tagext.TagVariableInfo[], boolean)


Occurences of terms

terms occurences:
javax.mail.search.terms
javax.mail.search.terms


Occurences of Timer

Timer occurences:
javax.ejb.Timer
javax.management.timer.Timer


Occurences of toString

toString occurences:
javax.activation.MimeType.toString()
javax.activation.MimeTypeParameterList.toString()
javax.enterprise.deploy.shared.ActionType.toString()
javax.enterprise.deploy.shared.CommandType.toString()
javax.enterprise.deploy.shared.DConfigBeanVersionType.toString()
javax.enterprise.deploy.shared.ModuleType.toString()
javax.enterprise.deploy.shared.StateType.toString()
javax.enterprise.deploy.spi.TargetModuleID.toString()
javax.jms.Queue.toString()
javax.jms.Topic.toString()
javax.mail.Address.toString()
javax.mail.Folder.toString()
javax.mail.internet.AddressException.toString()
javax.mail.internet.ContentDisposition.toString()
javax.mail.internet.ContentType.toString()
javax.mail.internet.InternetAddress.toString()
javax.mail.internet.InternetAddress.toString(javax.mail.Address[])
javax.mail.internet.InternetAddress.toString(javax.mail.Address[], int)
javax.mail.internet.NewsAddress.toString()
javax.mail.internet.NewsAddress.toString(javax.mail.Address[])
javax.mail.internet.ParameterList.toString()
javax.mail.internet.ParameterList.toString(int)
javax.mail.Message.RecipientType.toString()
javax.mail.Provider.toString()
javax.mail.Service.toString()
javax.mail.URLName.toString()
javax.management.AttributeValueExp.toString()
javax.management.BadAttributeValueExpException.toString()
javax.management.BadBinaryOpValueExpException.toString()
javax.management.BadStringOperationException.toString()
javax.management.modelmbean.DescriptorSupport.toString()
javax.management.modelmbean.ModelMBeanAttributeInfo.toString()
javax.management.modelmbean.ModelMBeanConstructorInfo.toString()
javax.management.modelmbean.ModelMBeanNotificationInfo.toString()
javax.management.modelmbean.ModelMBeanOperationInfo.toString()
javax.management.ObjectName.toString()
javax.management.openmbean.ArrayType.toString()
javax.management.openmbean.CompositeData.toString()
javax.management.openmbean.CompositeDataSupport.toString()
javax.management.openmbean.CompositeType.toString()
javax.management.openmbean.OpenMBeanAttributeInfo.toString()
javax.management.openmbean.OpenMBeanAttributeInfoSupport.toString()
javax.management.openmbean.OpenMBeanConstructorInfo.toString()
javax.management.openmbean.OpenMBeanConstructorInfoSupport.toString()
javax.management.openmbean.OpenMBeanInfo.toString()
javax.management.openmbean.OpenMBeanInfoSupport.toString()
javax.management.openmbean.OpenMBeanOperationInfo.toString()
javax.management.openmbean.OpenMBeanOperationInfoSupport.toString()
javax.management.openmbean.OpenMBeanParameterInfo.toString()
javax.management.openmbean.OpenMBeanParameterInfoSupport.toString()
javax.management.openmbean.OpenType.toString()
javax.management.openmbean.SimpleType.toString()
javax.management.openmbean.TabularData.toString()
javax.management.openmbean.TabularDataSupport.toString()
javax.management.openmbean.TabularType.toString()
javax.management.relation.Role.toString()
javax.management.relation.RoleInfo.toString()
javax.management.relation.RoleUnresolved.toString()
javax.management.StringValueExp.toString()
javax.servlet.jsp.tagext.TagAttributeInfo.toString()
javax.xml.namespace.QName.toString()
javax.xml.registry.Query.toString()
javax.xml.rpc.ParameterMode.toString()


Occurences of TransactionInProgressException (constructors)

TransactionInProgressException (constructors) occurences:
javax.jms.TransactionInProgressException(java.lang.String)
javax.jms.TransactionInProgressException(java.lang.String, java.lang.String)


Occurences of TransactionRequiredException (constructors)

TransactionRequiredException (constructors) occurences:
javax.transaction.TransactionRequiredException()
javax.transaction.TransactionRequiredException(java.lang.String)


Occurences of TransactionRequiredLocalException (constructors)

TransactionRequiredLocalException (constructors) occurences:
javax.ejb.TransactionRequiredLocalException()
javax.ejb.TransactionRequiredLocalException(java.lang.String)


Occurences of TransactionRolledBackException (constructors)

TransactionRolledBackException (constructors) occurences:
javax.jms.TransactionRolledBackException(java.lang.String)
javax.jms.TransactionRolledBackException(java.lang.String, java.lang.String)


Occurences of TransactionRolledbackException (constructors)

TransactionRolledbackException (constructors) occurences:
javax.transaction.TransactionRolledbackException()
javax.transaction.TransactionRolledbackException(java.lang.String)


Occurences of TransactionRolledbackLocalException (constructors)

TransactionRolledbackLocalException (constructors) occurences:
javax.ejb.TransactionRolledbackLocalException()
javax.ejb.TransactionRolledbackLocalException(java.lang.String)
javax.ejb.TransactionRolledbackLocalException(java.lang.String, java.lang.Exception)


Occurences of transform

transform occurences:
javax.xml.transform
javax.xml.transform.Transformer.transform(javax.xml.transform.Source, javax.xml.transform.Result)


Occurences of TransformerConfigurationException (constructors)

TransformerConfigurationException (constructors) occurences:
javax.xml.transform.TransformerConfigurationException()
javax.xml.transform.TransformerConfigurationException(java.lang.String)
javax.xml.transform.TransformerConfigurationException(java.lang.String, java.lang.Throwable)
javax.xml.transform.TransformerConfigurationException(java.lang.String, javax.xml.transform.SourceLocator)
javax.xml.transform.TransformerConfigurationException(java.lang.String, javax.xml.transform.SourceLocator, java.lang.Throwable)
javax.xml.transform.TransformerConfigurationException(java.lang.Throwable)


Occurences of TransformerException (constructors)

TransformerException (constructors) occurences:
javax.xml.transform.TransformerException(java.lang.String)
javax.xml.transform.TransformerException(java.lang.String, java.lang.Throwable)
javax.xml.transform.TransformerException(java.lang.String, javax.xml.transform.SourceLocator)
javax.xml.transform.TransformerException(java.lang.String, javax.xml.transform.SourceLocator, java.lang.Throwable)
javax.xml.transform.TransformerException(java.lang.Throwable)


Occurences of TransformerFactoryConfigurationError (constructors)

TransformerFactoryConfigurationError (constructors) occurences:
javax.xml.transform.TransformerFactoryConfigurationError()
javax.xml.transform.TransformerFactoryConfigurationError(java.lang.Exception)
javax.xml.transform.TransformerFactoryConfigurationError(java.lang.Exception, java.lang.String)
javax.xml.transform.TransformerFactoryConfigurationError(java.lang.String)


Occurences of type

type occurences:
javax.mail.event.type
javax.mail.event.type
javax.mail.event.type
javax.mail.event.type
javax.mail.event.type
javax.mail.event.type
javax.mail.search.type
javax.mail.type


Occurences of UnavailableException

UnavailableException occurences:
javax.resource.spi.UnavailableException
javax.servlet.UnavailableException


Occurences of UnavailableException (constructors)

UnavailableException (constructors) occurences:
javax.resource.spi.UnavailableException()
javax.resource.spi.UnavailableException(java.lang.String)
javax.resource.spi.UnavailableException(java.lang.String, java.lang.String)
javax.resource.spi.UnavailableException(java.lang.String, java.lang.Throwable)
javax.resource.spi.UnavailableException(java.lang.Throwable)
javax.servlet.UnavailableException(int, javax.servlet.Servlet, java.lang.String)
javax.servlet.UnavailableException(java.lang.String)
javax.servlet.UnavailableException(java.lang.String, int)
javax.servlet.UnavailableException(javax.servlet.Servlet, java.lang.String)


Occurences of UnexpectedObjectException (constructors)

UnexpectedObjectException (constructors) occurences:
javax.xml.registry.UnexpectedObjectException()
javax.xml.registry.UnexpectedObjectException(java.lang.String)
javax.xml.registry.UnexpectedObjectException(java.lang.String, java.lang.Throwable)
javax.xml.registry.UnexpectedObjectException(java.lang.Throwable)


Occurences of UNKNOWN

UNKNOWN occurences:
javax.management.UNKNOWN
javax.resource.spi.work.UNKNOWN


Occurences of unregisterMBean

unregisterMBean occurences:
javax.management.MBeanServer.unregisterMBean(javax.management.ObjectName)
javax.management.MBeanServerConnection.unregisterMBean(javax.management.ObjectName)


Occurences of unsubscribe

unsubscribe occurences:
javax.jms.Session.unsubscribe(java.lang.String)
javax.jms.TopicSession.unsubscribe(java.lang.String)


Occurences of UnsupportedCapabilityException (constructors)

UnsupportedCapabilityException (constructors) occurences:
javax.xml.registry.UnsupportedCapabilityException()
javax.xml.registry.UnsupportedCapabilityException(java.lang.String)
javax.xml.registry.UnsupportedCapabilityException(java.lang.String, java.lang.Throwable)
javax.xml.registry.UnsupportedCapabilityException(java.lang.Throwable)


Occurences of UnsupportedDataTypeException (constructors)

UnsupportedDataTypeException (constructors) occurences:
javax.activation.UnsupportedDataTypeException()
javax.activation.UnsupportedDataTypeException(java.lang.String)


Occurences of updateHeaders

updateHeaders occurences:
javax.mail.internet.MimeBodyPart.updateHeaders()
javax.mail.internet.MimeMessage.updateHeaders()
javax.mail.internet.MimeMultipart.updateHeaders()


Occurences of updateRoleMap

updateRoleMap occurences:
javax.management.relation.RelationService.updateRoleMap(java.lang.String, javax.management.relation.Role, java.util.List)
javax.management.relation.RelationServiceMBean.updateRoleMap(java.lang.String, javax.management.relation.Role, java.util.List)


Occurences of URLName (constructors)

URLName (constructors) occurences:
javax.mail.URLName(java.lang.String)
javax.mail.URLName(java.lang.String, java.lang.String, int, java.lang.String, java.lang.String, java.lang.String)
javax.mail.URLName(java.net.URL)


Occurences of USER

USER occurences:
javax.mail.USER
javax.xml.registry.USER


Occurences of USERNAME_PROPERTY

USERNAME_PROPERTY occurences:
javax.xml.rpc.USERNAME_PROPERTY
javax.xml.rpc.USERNAME_PROPERTY


Occurences of validate

validate occurences:
javax.mail.internet.InternetAddress.validate()
javax.resource.spi.ActivationSpec.validate()
javax.servlet.jsp.tagext.TagExtraInfo.validate(javax.servlet.jsp.tagext.TagData)
javax.servlet.jsp.tagext.TagInfo.validate(javax.servlet.jsp.tagext.TagData)
javax.servlet.jsp.tagext.TagLibraryValidator.validate(java.lang.String, java.lang.String, javax.servlet.jsp.tagext.PageData)


Occurences of validSent

validSent occurences:
javax.mail.event.validSent
javax.mail.validSent


Occurences of validUnsent

validUnsent occurences:
javax.mail.event.validUnsent
javax.mail.validUnsent


Occurences of value

value occurences:
javax.management.Query.value(boolean)
javax.management.Query.value(double)
javax.management.Query.value(float)
javax.management.Query.value(int)
javax.management.Query.value(java.lang.Number)
javax.management.Query.value(java.lang.String)
javax.management.Query.value(long)
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value


Occurences of values

values occurences:
javax.management.openmbean.CompositeData.values()
javax.management.openmbean.CompositeDataSupport.values()
javax.management.openmbean.TabularData.values()
javax.management.openmbean.TabularDataSupport.values()


Occurences of WebResourcePermission (constructors)

WebResourcePermission (constructors) occurences:
javax.security.jacc.WebResourcePermission(java.lang.String, java.lang.String)
javax.security.jacc.WebResourcePermission(java.lang.String, java.lang.String[])
javax.security.jacc.WebResourcePermission(javax.servlet.http.HttpServletRequest)


Occurences of WebUserDataPermission (constructors)

WebUserDataPermission (constructors) occurences:
javax.security.jacc.WebUserDataPermission(java.lang.String, java.lang.String)
javax.security.jacc.WebUserDataPermission(java.lang.String, java.lang.String[], java.lang.String)
javax.security.jacc.WebUserDataPermission(javax.servlet.http.HttpServletRequest)


Occurences of workAccepted

workAccepted occurences:
javax.resource.spi.work.WorkAdapter.workAccepted(javax.resource.spi.work.WorkEvent)
javax.resource.spi.work.WorkListener.workAccepted(javax.resource.spi.work.WorkEvent)


Occurences of workCompleted

workCompleted occurences:
javax.resource.spi.work.WorkAdapter.workCompleted(javax.resource.spi.work.WorkEvent)
javax.resource.spi.work.WorkListener.workCompleted(javax.resource.spi.work.WorkEvent)


Occurences of WorkCompletedException (constructors)

WorkCompletedException (constructors) occurences:
javax.resource.spi.work.WorkCompletedException()
javax.resource.spi.work.WorkCompletedException(java.lang.String)
javax.resource.spi.work.WorkCompletedException(java.lang.String, java.lang.String)
javax.resource.spi.work.WorkCompletedException(java.lang.String, java.lang.Throwable)
javax.resource.spi.work.WorkCompletedException(java.lang.Throwable)


Occurences of WorkEvent (constructors)

WorkEvent (constructors) occurences:
javax.resource.spi.work.WorkEvent(java.lang.Object, int, javax.resource.spi.work.Work, javax.resource.spi.work.WorkException)
javax.resource.spi.work.WorkEvent(java.lang.Object, int, javax.resource.spi.work.Work, javax.resource.spi.work.WorkException, long)


Occurences of WorkException (constructors)

WorkException (constructors) occurences:
javax.resource.spi.work.WorkException()
javax.resource.spi.work.WorkException(java.lang.String)
javax.resource.spi.work.WorkException(java.lang.String, java.lang.String)
javax.resource.spi.work.WorkException(java.lang.String, java.lang.Throwable)
javax.resource.spi.work.WorkException(java.lang.Throwable)


Occurences of workRejected

workRejected occurences:
javax.resource.spi.work.WorkAdapter.workRejected(javax.resource.spi.work.WorkEvent)
javax.resource.spi.work.WorkListener.workRejected(javax.resource.spi.work.WorkEvent)


Occurences of WorkRejectedException (constructors)

WorkRejectedException (constructors) occurences:
javax.resource.spi.work.WorkRejectedException()
javax.resource.spi.work.WorkRejectedException(java.lang.String)
javax.resource.spi.work.WorkRejectedException(java.lang.String, java.lang.String)
javax.resource.spi.work.WorkRejectedException(java.lang.String, java.lang.Throwable)
javax.resource.spi.work.WorkRejectedException(java.lang.Throwable)


Occurences of workStarted

workStarted occurences:
javax.resource.spi.work.WorkAdapter.workStarted(javax.resource.spi.work.WorkEvent)
javax.resource.spi.work.WorkListener.workStarted(javax.resource.spi.work.WorkEvent)


Occurences of writeBoolean

writeBoolean occurences:
javax.jms.BytesMessage.writeBoolean(boolean)
javax.jms.StreamMessage.writeBoolean(boolean)


Occurences of writeByte

writeByte occurences:
javax.jms.BytesMessage.writeByte(byte)
javax.jms.StreamMessage.writeByte(byte)


Occurences of writeBytes

writeBytes occurences:
javax.jms.BytesMessage.writeBytes(byte[])
javax.jms.BytesMessage.writeBytes(byte[], int, int)
javax.jms.StreamMessage.writeBytes(byte[])
javax.jms.StreamMessage.writeBytes(byte[], int, int)


Occurences of writeChar

writeChar occurences:
javax.jms.BytesMessage.writeChar(char)
javax.jms.StreamMessage.writeChar(char)


Occurences of writeDouble

writeDouble occurences:
javax.jms.BytesMessage.writeDouble(double)
javax.jms.StreamMessage.writeDouble(double)


Occurences of writeExternal

writeExternal occurences:
javax.activation.MimeType.writeExternal(java.io.ObjectOutput)
javax.management.loading.MLet.writeExternal(java.io.ObjectOutput)


Occurences of writeFloat

writeFloat occurences:
javax.jms.BytesMessage.writeFloat(float)
javax.jms.StreamMessage.writeFloat(float)


Occurences of writeInt

writeInt occurences:
javax.jms.BytesMessage.writeInt(int)
javax.jms.StreamMessage.writeInt(int)


Occurences of writeLong

writeLong occurences:
javax.jms.BytesMessage.writeLong(long)
javax.jms.StreamMessage.writeLong(long)


Occurences of writeObject

writeObject occurences:
javax.jms.BytesMessage.writeObject(java.lang.Object)
javax.jms.StreamMessage.writeObject(java.lang.Object)


Occurences of writeShort

writeShort occurences:
javax.jms.BytesMessage.writeShort(short)
javax.jms.StreamMessage.writeShort(short)


Occurences of writeTo

writeTo occurences:
javax.activation.DataContentHandler.writeTo(java.lang.Object, java.lang.String, java.io.OutputStream)
javax.activation.DataHandler.writeTo(java.io.OutputStream)
javax.mail.internet.MimeBodyPart.writeTo(java.io.OutputStream)
javax.mail.internet.MimeMessage.writeTo(java.io.OutputStream)
javax.mail.internet.MimeMessage.writeTo(java.io.OutputStream, java.lang.String[])
javax.mail.internet.MimeMultipart.writeTo(java.io.OutputStream)
javax.mail.Multipart.writeTo(java.io.OutputStream)
javax.mail.Part.writeTo(java.io.OutputStream)
javax.xml.soap.SOAPMessage.writeTo(java.io.OutputStream)


Occurences of XAException (constructors)

XAException (constructors) occurences:
javax.transaction.xa.XAException()
javax.transaction.xa.XAException(int)
javax.transaction.xa.XAException(java.lang.String)


Occurences of XA_RDONLY

XA_RDONLY occurences:
javax.transaction.xa.XA_RDONLY
javax.transaction.xa.XA_RDONLY


Occurences of XMLParseException (constructors)

XMLParseException (constructors) occurences:
javax.management.modelmbean.XMLParseException()
javax.management.modelmbean.XMLParseException(java.lang.Exception, java.lang.String)
javax.management.modelmbean.XMLParseException(java.lang.String)


 javax.activation
Interfaces
CommandObject
DataContentHandler
DataContentHandlerFactory
DataSource
Classes
ActivationDataFlavor
CommandInfo
CommandMap
DataHandler
FileDataSource
FileTypeMap
MailcapCommandMap
MimeType
MimeTypeParameterList
MimetypesFileTypeMap
URLDataSource
Exceptions
MimeTypeParseException
UnsupportedDataTypeException


 javax.ejb
Interfaces
EJBContext
EJBHome
EJBLocalHome
EJBLocalObject
EJBMetaData
EJBObject
EnterpriseBean
EntityBean
EntityContext
Handle
HomeHandle
MessageDrivenBean
MessageDrivenContext
SessionBean
SessionContext
SessionSynchronization
TimedObject
Timer
TimerHandle
TimerService
Exceptions
AccessLocalException
CreateException
DuplicateKeyException
EJBException
FinderException
NoSuchEntityException
NoSuchObjectLocalException
ObjectNotFoundException
RemoveException
TransactionRequiredLocalException
TransactionRolledbackLocalException


 javax.ejb.spi
Interfaces
HandleDelegate


 javax.enterprise.deploy.model
Interfaces
DDBean
DDBeanRoot
DeployableObject
J2eeApplicationObject
XpathListener
Classes
XpathEvent


 javax.enterprise.deploy.shared
Classes
ActionType
CommandType
DConfigBeanVersionType
ModuleType
StateType


 javax.enterprise.deploy.shared.factories
Classes
DeploymentFactoryManager


 javax.enterprise.deploy.spi
Interfaces
DConfigBean
DConfigBeanRoot
DeploymentConfiguration
DeploymentManager
Target
TargetModuleID


 javax.enterprise.deploy.spi.exceptions
Exceptions
BeanNotFoundException
ClientExecuteException
ConfigurationException
DConfigBeanVersionUnsupportedException
DeploymentManagerCreationException
InvalidModuleException
OperationUnsupportedException
TargetException


 javax.enterprise.deploy.spi.factories
Interfaces
DeploymentFactory


 javax.enterprise.deploy.spi.status
Interfaces
ClientConfiguration
DeploymentStatus
ProgressListener
ProgressObject
Classes
ProgressEvent


 javax.jms
Interfaces
BytesMessage
Connection
ConnectionConsumer
ConnectionFactory
ConnectionMetaData
DeliveryMode
Destination
ExceptionListener
MapMessage
Message
MessageConsumer
MessageListener
MessageProducer
ObjectMessage
Queue
QueueBrowser
QueueConnection
QueueConnectionFactory
QueueReceiver
QueueSender
QueueSession
ServerSession
ServerSessionPool
Session
StreamMessage
TemporaryQueue
TemporaryTopic
TextMessage
Topic
TopicConnection
TopicConnectionFactory
TopicPublisher
TopicSession
TopicSubscriber
XAConnection
XAConnectionFactory
XAQueueConnection
XAQueueConnectionFactory
XAQueueSession
XASession
XATopicConnection
XATopicConnectionFactory
XATopicSession
Classes
QueueRequestor
TopicRequestor
Exceptions
IllegalStateException
InvalidClientIDException
InvalidDestinationException
InvalidSelectorException
JMSException
JMSSecurityException
MessageEOFException
MessageFormatException
MessageNotReadableException
MessageNotWriteableException
ResourceAllocationException
TransactionInProgressException
TransactionRolledBackException


 javax.mail
Interfaces
MessageAware
MultipartDataSource
Part
UIDFolder
Classes
Address
Authenticator
BodyPart
FetchProfile
FetchProfile.Item
Flags
Flags.Flag
Folder
Header
Message
Message.RecipientType
MessageContext
Multipart
PasswordAuthentication
Provider
Provider.Type
Service
Session
Store
Transport
UIDFolder.FetchProfileItem
URLName
Exceptions
AuthenticationFailedException
FolderClosedException
FolderNotFoundException
IllegalWriteException
MessageRemovedException
MessagingException
MethodNotSupportedException
NoSuchProviderException
ReadOnlyFolderException
SendFailedException
StoreClosedException


 javax.mail.event
Interfaces
ConnectionListener
FolderListener
MessageChangedListener
MessageCountListener
StoreListener
TransportListener
Classes
ConnectionAdapter
ConnectionEvent
FolderAdapter
FolderEvent
MailEvent
MessageChangedEvent
MessageCountAdapter
MessageCountEvent
StoreEvent
TransportAdapter
TransportEvent


 javax.mail.internet
Interfaces
MimePart
SharedInputStream
Classes
ContentDisposition
ContentType
HeaderTokenizer
HeaderTokenizer.Token
InternetAddress
InternetHeaders
MailDateFormat
MimeBodyPart
MimeMessage
MimeMessage.RecipientType
MimeMultipart
MimePartDataSource
MimeUtility
NewsAddress
ParameterList
Exceptions
AddressException
ParseException


 javax.mail.search
Classes
AddressStringTerm
AddressTerm
AndTerm
BodyTerm
ComparisonTerm
DateTerm
FlagTerm
FromStringTerm
FromTerm
HeaderTerm
IntegerComparisonTerm
MessageIDTerm
MessageNumberTerm
NotTerm
OrTerm
ReceivedDateTerm
RecipientStringTerm
RecipientTerm
SearchTerm
SentDateTerm
SizeTerm
StringTerm
SubjectTerm
Exceptions
SearchException


 javax.management
Interfaces
Descriptor
DescriptorAccess
DynamicMBean
MBeanRegistration
MBeanServer
MBeanServerConnection
MBeanServerDelegateMBean
NotificationBroadcaster
NotificationEmitter
NotificationFilter
NotificationListener
PersistentMBean
QueryExp
ValueExp
Classes
Attribute
AttributeChangeNotification
AttributeChangeNotificationFilter
AttributeList
AttributeValueExp
DefaultLoaderRepository
MBeanAttributeInfo
MBeanConstructorInfo
MBeanFeatureInfo
MBeanInfo
MBeanNotificationInfo
MBeanOperationInfo
MBeanParameterInfo
MBeanPermission
MBeanServerBuilder
MBeanServerDelegate
MBeanServerFactory
MBeanServerInvocationHandler
MBeanServerNotification
MBeanServerPermission
MBeanTrustPermission
Notification
NotificationBroadcasterSupport
NotificationFilterSupport
ObjectInstance
ObjectName
Query
QueryEval
StandardMBean
StringValueExp
Exceptions
AttributeNotFoundException
BadAttributeValueExpException
BadBinaryOpValueExpException
BadStringOperationException
InstanceAlreadyExistsException
InstanceNotFoundException
IntrospectionException
InvalidApplicationException
InvalidAttributeValueException
JMException
JMRuntimeException
ListenerNotFoundException
MalformedObjectNameException
MBeanException
MBeanRegistrationException
NotCompliantMBeanException
OperationsException
ReflectionException
RuntimeErrorException
RuntimeMBeanException
RuntimeOperationsException
ServiceNotFoundException


 javax.management.j2ee
Interfaces
ListenerRegistration
Management
ManagementHome


 javax.management.j2ee.statistics
Interfaces
BoundaryStatistic
BoundedRangeStatistic
CountStatistic
EJBStats
EntityBeanStats
JavaMailStats
JCAConnectionPoolStats
JCAConnectionStats
JCAStats
JDBCConnectionPoolStats
JDBCConnectionStats
JDBCStats
JMSConnectionStats
JMSConsumerStats
JMSEndpointStats
JMSProducerStats
JMSSessionStats
JMSStats
JTAStats
JVMStats
MessageDrivenBeanStats
RangeStatistic
ServletStats
SessionBeanStats
StatefulSessionBeanStats
StatelessSessionBeanStats
Statistic
Stats
TimeStatistic
URLStats


 javax.management.loading
Interfaces
ClassLoaderRepository
MLetMBean
PrivateClassLoader
Classes
DefaultLoaderRepository
MLet
PrivateMLet


 javax.management.modelmbean
Interfaces
ModelMBean
ModelMBeanInfo
ModelMBeanNotificationBroadcaster
Classes
DescriptorSupport
ModelMBeanAttributeInfo
ModelMBeanConstructorInfo
ModelMBeanInfoSupport
ModelMBeanNotificationInfo
ModelMBeanOperationInfo
RequiredModelMBean
Exceptions
InvalidTargetObjectTypeException
XMLParseException


 javax.management.monitor
Interfaces
CounterMonitorMBean
GaugeMonitorMBean
MonitorMBean
StringMonitorMBean
Classes
CounterMonitor
GaugeMonitor
Monitor
MonitorNotification
StringMonitor
Exceptions
MonitorSettingException


 javax.management.openmbean
Interfaces
CompositeData
OpenMBeanAttributeInfo
OpenMBeanConstructorInfo
OpenMBeanInfo
OpenMBeanOperationInfo
OpenMBeanParameterInfo
TabularData
Classes
ArrayType
CompositeDataSupport
CompositeType
OpenMBeanAttributeInfoSupport
OpenMBeanConstructorInfoSupport
OpenMBeanInfoSupport
OpenMBeanOperationInfoSupport
OpenMBeanParameterInfoSupport
OpenType
SimpleType
TabularDataSupport
TabularType
Exceptions
InvalidKeyException
InvalidOpenTypeException
KeyAlreadyExistsException
OpenDataException


 javax.management.relation
Interfaces
Relation
RelationServiceMBean
RelationSupportMBean
RelationType
Classes
MBeanServerNotificationFilter
RelationNotification
RelationService
RelationSupport
RelationTypeSupport
Role
RoleInfo
RoleList
RoleResult
RoleStatus
RoleUnresolved
RoleUnresolvedList
Exceptions
InvalidRelationIdException
InvalidRelationServiceException
InvalidRelationTypeException
InvalidRoleInfoException
InvalidRoleValueException
RelationException
RelationNotFoundException
RelationServiceNotRegisteredException
RelationTypeNotFoundException
RoleInfoNotFoundException
RoleNotFoundException


 javax.management.timer
Interfaces
TimerMBean
Classes
Timer
TimerAlarmClockNotification
TimerNotification


 javax.resource
Interfaces
Referenceable
Exceptions
NotSupportedException
ResourceException


 javax.resource.cci
Interfaces
Connection
ConnectionFactory
ConnectionMetaData
ConnectionSpec
IndexedRecord
Interaction
InteractionSpec
LocalTransaction
MappedRecord
MessageListener
Record
RecordFactory
ResourceAdapterMetaData
ResultSet
ResultSetInfo
Streamable
Exceptions
ResourceWarning


 javax.resource.spi
Interfaces
ActivationSpec
BootstrapContext
ConnectionEventListener
ConnectionManager
ConnectionRequestInfo
DissociatableManagedConnection
LazyAssociatableConnectionManager
LazyEnlistableConnectionManager
LazyEnlistableManagedConnection
LocalTransaction
ManagedConnection
ManagedConnectionFactory
ManagedConnectionMetaData
ResourceAdapter
ResourceAdapterAssociation
ValidatingManagedConnectionFactory
XATerminator
Classes
ConnectionEvent
Exceptions
ApplicationServerInternalException
CommException
EISSystemException
IllegalStateException
InvalidPropertyException
LocalTransactionException
ResourceAdapterInternalException
ResourceAllocationException
SecurityException
SharingViolationException
UnavailableException


 javax.resource.spi.endpoint
Interfaces
MessageEndpoint
MessageEndpointFactory


 javax.resource.spi.security
Interfaces
GenericCredential
Classes
PasswordCredential


 javax.resource.spi.work
Interfaces
Work
WorkListener
WorkManager
Classes
ExecutionContext
WorkAdapter
WorkEvent
Exceptions
WorkCompletedException
WorkException
WorkRejectedException


 javax.security.jacc
Interfaces
PolicyConfiguration
PolicyContextHandler
Classes
EJBMethodPermission
EJBRoleRefPermission
PolicyConfigurationFactory
PolicyContext
WebResourcePermission
WebRoleRefPermission
WebUserDataPermission
Exceptions
PolicyContextException


 javax.servlet
Interfaces
Filter
FilterChain
FilterConfig
RequestDispatcher
Servlet
ServletConfig
ServletContext
ServletContextAttributeListener
ServletContextListener
ServletRequest
ServletRequestAttributeListener
ServletRequestListener
ServletResponse
SingleThreadModel
Classes
GenericServlet
ServletContextAttributeEvent
ServletContextEvent
ServletInputStream
ServletOutputStream
ServletRequestAttributeEvent
ServletRequestEvent
ServletRequestWrapper
ServletResponseWrapper
Exceptions
ServletException
UnavailableException


 javax.servlet.http
Interfaces
HttpServletRequest
HttpServletResponse
HttpSession
HttpSessionActivationListener
HttpSessionAttributeListener
HttpSessionBindingListener
HttpSessionContext
HttpSessionListener
Classes
Cookie
HttpServlet
HttpServletRequestWrapper
HttpServletResponseWrapper
HttpSessionBindingEvent
HttpSessionEvent
HttpUtils


 javax.servlet.jsp
Interfaces
HttpJspPage
JspPage
Classes
ErrorData
JspContext
JspEngineInfo
JspFactory
JspWriter
PageContext
Exceptions
JspException
JspTagException
SkipPageException


 javax.servlet.jsp.el
Interfaces
FunctionMapper
VariableResolver
Classes
Expression
ExpressionEvaluator
Exceptions
ELException
ELParseException


 javax.servlet.jsp.tagext
Interfaces
BodyTag
DynamicAttributes
IterationTag
JspTag
SimpleTag
Tag
TryCatchFinally
Classes
BodyContent
BodyTagSupport
FunctionInfo
JspFragment
PageData
SimpleTagSupport
TagAdapter
TagAttributeInfo
TagData
TagExtraInfo
TagFileInfo
TagInfo
TagLibraryInfo
TagLibraryValidator
TagSupport
TagVariableInfo
ValidationMessage
VariableInfo


 javax.transaction
Interfaces
Status
Synchronization
Transaction
TransactionManager
UserTransaction
Exceptions
HeuristicCommitException
HeuristicMixedException
HeuristicRollbackException
InvalidTransactionException
NotSupportedException
RollbackException
SystemException
TransactionRequiredException
TransactionRolledbackException


 javax.transaction.xa
Interfaces
XAResource
Xid
Exceptions
XAException


 javax.xml.namespace
Classes
QName


 javax.xml.parsers
Classes
DocumentBuilder
DocumentBuilderFactory
SAXParser
SAXParserFactory
Exceptions
ParserConfigurationException
Errors
FactoryConfigurationError


 javax.xml.registry
Interfaces
BulkResponse
BusinessLifeCycleManager
BusinessQueryManager
CapabilityProfile
Connection
DeclarativeQueryManager
FederatedConnection
FindQualifier
JAXRResponse
LifeCycleManager
Query
QueryManager
RegistryService
Classes
ConnectionFactory
Exceptions
DeleteException
FindException
InvalidRequestException
JAXRException
RegistryException
SaveException
UnexpectedObjectException
UnsupportedCapabilityException


 javax.xml.registry.infomodel
Interfaces
Association
AuditableEvent
Classification
ClassificationScheme
Concept
EmailAddress
ExtensibleObject
ExternalIdentifier
ExternalLink
ExtrinsicObject
InternationalString
Key
LocalizedString
Organization
PersonName
PostalAddress
RegistryEntry
RegistryObject
RegistryPackage
Service
ServiceBinding
Slot
SpecificationLink
TelephoneNumber
URIValidator
User
Versionable


 javax.xml.rpc
Interfaces
Call
Service
Stub
Classes
NamespaceConstants
ParameterMode
ServiceFactory
Exceptions
JAXRPCException
ServiceException


 javax.xml.rpc.encoding
Interfaces
DeserializationContext
Deserializer
DeserializerFactory
SerializationContext
Serializer
SerializerFactory
TypeMapping
TypeMappingRegistry
Classes
XMLType


 javax.xml.rpc.handler
Interfaces
Handler
HandlerChain
HandlerRegistry
MessageContext
Classes
GenericHandler
HandlerInfo


 javax.xml.rpc.handler.soap
Interfaces
SOAPMessageContext


 javax.xml.rpc.holders
Interfaces
Holder
Classes
BigDecimalHolder
BigIntegerHolder
BooleanHolder
BooleanWrapperHolder
ByteArrayHolder
ByteHolder
ByteWrapperHolder
CalendarHolder
DoubleHolder
DoubleWrapperHolder
FloatHolder
FloatWrapperHolder
IntegerWrapperHolder
IntHolder
LongHolder
LongWrapperHolder
ObjectHolder
QNameHolder
ShortHolder
ShortWrapperHolder
StringHolder


 javax.xml.rpc.server
Interfaces
ServiceLifecycle
ServletEndpointContext


 javax.xml.rpc.soap
Exceptions
SOAPFaultException


 javax.xml.soap
Interfaces
Detail
DetailEntry
Name
Node
SOAPBody
SOAPBodyElement
SOAPConstants
SOAPElement
SOAPEnvelope
SOAPFault
SOAPFaultElement
SOAPHeader
SOAPHeaderElement
Text
Classes
AttachmentPart
MessageFactory
MimeHeader
MimeHeaders
SOAPConnection
SOAPConnectionFactory
SOAPElementFactory
SOAPFactory
SOAPMessage
SOAPPart
Exceptions
SOAPException


 javax.xml.transform
Interfaces
ErrorListener
Result
Source
SourceLocator
Templates
URIResolver
Classes
OutputKeys
Transformer
TransformerFactory
Exceptions
TransformerConfigurationException
TransformerException
Errors
TransformerFactoryConfigurationError


 javax.xml.transform.dom
Interfaces
DOMLocator
Classes
DOMResult
DOMSource


 javax.xml.transform.sax
Interfaces
TemplatesHandler
TransformerHandler
Classes
SAXResult
SAXSource
SAXTransformerFactory


 javax.xml.transform.stream
Classes
StreamResult
StreamSource